$$INTRODUCTION$$ - %%projecttitle%%

GTP.NET.SL Send comments on this topic.

Introduction

Gantt Time Package for .NET Silverlight & WPF

Thank you for looking into the GTP.NET.SL component package. This is a licensed control package with a 30 day evaluation. There is no runtime fee; there is only a onetime fee per developer using the package.

The fee covers the right to deploy solutions that use the components and one year of free updates and support. After the first year of licensing has ended, an additional year of support and updates can be purchased for 25 percent of the current price of a new license.

GTP.NET.SL is developed and maintained by plexityHide AB, Sweden. PlexityHide AB is privately held and has been in business since 1999 focusing on delivering time visualization components to developers.

PlexityHide currently maintains phGantTimePackage for ActiveX and for VCL, GTP.NET for .net winforms and Ajax ASP.NET and now also the GTP.NET.SL that aims to be the generic solution to all time visualization needs for the silverlight platform.

We have drawn from our experience in providing generic components to over a 1000 software projects when designing the GTP.NET.SL.

We have come up with a component that combines the many possibilities of XAML with the generic task of showing anything along a time axis.

If you are looking for a way to display and edit schedules, events, plans or anything else, live on the web, rest assured that we have had you in mind when designing the GTP.NET.SL.

Unlike other specialized solutions that often require you to fit your data into a specific template we are giving you as much freedom as possible. We provide the time axis, the concept of a time item, the concept of a time item link, the concept of moving and resizing time items, the ability to allow or disallow any user action, full databind and full exposure of time item definition with XAML and datatemplates.

Developing for GTP.NET.SL is straight forward and non intrusive.

This XAML code describes the how the time item gets it time axis position and its content:

        <DataTemplate x:Key="TimeItemPres_blue">

            <l:TimeItem    Start="{Binding Path=Start,Mode=TwoWay}"

Stop="{Binding Path=Stop,Mode=TwoWay}" Identity="{Binding Path=Id}" TimeItemSizedFrameworkElementName="TimeItemLook"

Height="40"

MouseLeftButtonDown="TimeItem_MouseLeftButtonDown" >

                <Rectangle        Name="TimeItemLook"

Fill="LightBlue" RadiusX="3" RadiusY="3" Stroke="Black" StrokeThickness="0.5"></Rectangle>

                <Grid >

                    <StackPanel>

                        <TextBlock Text="{Binding Path=Text}"></TextBlock>

                    </StackPanel>

                </Grid>

            </l:TimeItem>

</>

The time items live inside a GanttRow and this sample XAML shows a datatemplate giving a complete row with a column head:

        <DataTemplate x:Key="ScheduleColumn">

            <Grid Width="60">

                <Grid.RowDefinitions>

                    <RowDefinition Height="30"></RowDefinition>

                    <RowDefinition Height="*"></RowDefinition>

                </Grid.RowDefinitions>

                <Canvas Grid.Row="0"  Background="Gray" Height="30">

                    <TextBlock HorizontalAlignment="Center"

VerticalAlignment="Center"

Text="{Binding Text}"></TextBlock>

                </Canvas>

                <l:GanttRow Grid.Row="1"

ItemTemplate="{StaticResource TimeItemPres_blue_schedule}"

ItemsSource="{Binding Path=Items}" Background="Aqua"></l:GanttRow>

            </Grid>

</>

Adding relations between time items is also really easy:

        <DataTemplate x:Key="TimeItemLinkPres">

            <l:TimeItemLink StartIdentity="{Binding Path=Start}"

StopIdentity="{Binding Path=Stop}"  >

            </l:TimeItemLink>

        </DataTemplate>

Since we, in true silverlight and WPF spirit, make no assumptions about how you are going to render your data the Gantt component is merely a collecting instance that make multiple Gantt rows with Time items and Time item links work together. This leaves you in full control just like the intention of the XAML language stipulates:

            <l:Gantt Name="Gantt2"

TimeItemLinksTemplate="{StaticResource TimeItemLinkPres}">

                <data:DataGrid Name="dataGrid2"  AutoGenerateColumns="False">

                    <data:DataGrid.Columns>

                        <data:DataGridTextColumn

                           Header="SomeText"

                           Width="150"

                           Binding="{Binding Text}" >

                            <data:DataGridTextColumn.ElementStyle>

                                <Style TargetType="TextBlock">

                                    <Setter Property="TextWrapping" Value="Wrap"/>

                                </Style>

                            </data:DataGridTextColumn.ElementStyle>

                            <data:DataGridTextColumn.EditingElementStyle>

                                <Style TargetType="TextBox">

                                    <Setter Property="Foreground" Value="Blue"/>

                                </Style>

                            </data:DataGridTextColumn.EditingElementStyle>

                        </data:DataGridTextColumn>

                        <data:DataGridTemplateColumn Header="Hello"

Width="500"

CellTemplate="{StaticResource GanttRowTemplateGantt2}"

HeaderStyle="{StaticResource DateScalerHeader}"  >

                        </data:DataGridTemplateColumn>

                    </data:DataGrid.Columns>

                </data:DataGrid>

            </l:Gantt>

Please visit us or contact us at your convenience.
 support@plexityhide.com ; pre-sales and support questions.
 http://www.plexityhide.com

plexityHide AB
Gråstensvägen 24
S-163 45 Spånga

+46 706 640 160 We are located in GMT+1. If we are unable to answer please leave a message on the voice mail

Welcome to the Gantt Time Package for silverlight & WPF.

Silverlight and WPF are really different compared to windows forms and ASP.NET. The main difference is that a silverlight and WPF component should leave as much of the visual appearance up to the user of the control; you. The challenge is that even though it is easy to understand the benefits of this approach, a control with a lot of inner content and logic, as a Gantt chart, will need to be delivered in parts so that visual control can be delegated to you for each part.

© plexityHide 2009. All Rights Reserved.


%%phrase%%

GTP.NET.SL Send comments on this topic.

Assembly Overview

Namespaces

Namespace | Description
PlexityHide.GTP |


$$GETTING_STARTED$$ - %%projecttitle%%

GTP.NET.SL Send comments on this topic.

Getting Started

Getting started with the Gantt Time Package for .NET Silverlight & WPF

After a successful installation you will find the installed components here: C:\Program Files\plexityHide AB\GTP.NET Silverlight

Choose the “Open up samples in VS2008”:

Remove the not found GTP.NET.SL assembly, right click and choose “Add reference”, choose “browse”, goto C:\Program Files\plexityHide AB\GTP.NET Silverlight and choose “GTP.NET.SL.dll”.

Build and run. You should now see the sample in your browser:

Getting started

© plexityHide 2009. All Rights Reserved.


%%ItemTitle%%

See Also

GTP.NET.SL Assembly

See Also GTP.NET.SL Send comments on this topic.

PlexityHide.GTP Namespace

Inheritance Hierarchy

Classes

Class | Description
BeforeScaleOrSpanChangeArgs | Arguments for the BeforeScaleOrSpanChange event
CollisionDetectEventArgs | CollisionDetect event args
CollisionNote | Holds detailed information about one collision
ConflictArea | This class represents the detailed information that can be collected on each collision that is detected. To collect conflictAreas for a time item GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true.
ConflictArea_UpdateArgs | The arguments used by the ConflictArea_Update event
DateScaleMark | DateScaleMark holds info about one current scale mark in the DateScaler
DateScaler | The DateScaler is the most important component. It handles all conversion between time and pixels for the Gantt chart
ExternalDropArgs | Arguments used in the externaldrop event
Gantt | The Gantt is a collecting control of type Grid. You normally place a DataGrid or TreeView inside the Gantt. You should also always place exactly one DateScaler inside the Gantt. Place the DateScaler where it makes sense for your GanttRows
GanttRow | A GanttRow is connected to DateScaler and can hold multiple TimeItems
GanttRowCanvas | This is the canvas used by the GanttRow, it is only public for technical reasons; dont use
GanttRowItem | This is the created item for each object in the datasource list. The datatemplate is required to define a TimeItem so each GanttRowItem will also have one TimeItem. The GanttRow inherits from ListView, the TimeItem is the content you provide in a DataTemplate, The GanttRowItem is The corresponding ListViewItem that hold selection etc.
GanttUserDrawArgs | The OnDrawBackground and Foreground use these arguments
LinkUserDrawEventArgs | The arguments given in the OnUserDraw event of the TimeItemLink
MultiColumnCoordinator | When having a treeview with multiple columns you want some way to syncronize column resizing for all TreeView DataTemplates The MultiColumnCoordinator helps you with this
MyExtensions |
NonLinearTime | Holds a non-linear time line, the non-linearity is limited to hiding of specific hours during all days and/or hiding of specific days during every week.
NotifyTimeItem | Arguments used by the events that notify about TimeItem
OnGanttRowMinHeightChangeArgs | The Arguments for OnGanttRowMinHeightChange
OnTimeItemChangeArgs | The arguments used in the OnTimeItemChange event
RowChangeArgs | The arguments given in the RowChange event
TextOutOverrideArgs | Arguments used by the OnTextOutOverride event
TimeDistinctItem | Defines the data that is used by collision detect.
TimeDistinctThread | This class is used internally and helps GanttRows to find a collision free position asynchronously.
TimeDistinctThread.StartComparer |
TimeDistinctThread.StopComparer |
TimeItem | A TimeItem is owned by a GanttRow and has a Start and Stop datetime value. The TimeItems can be moved by user. You can fill the TimeItem whit anything. You can have edit controls or videos here.
TimeItemLink | The TimeItemLink is used to show relation between two TimeItems
TimeItemLinkCanvas | TimeItemLinkCanvas is public for technical reasons; do not use
TimeItemLinkItem | TimeItemLinkItem is corresponding to a ListViewItem of an ItemsControl. Each TimeItemLinkItem should point out a DataTemplate that defines a TimeItemLink.
TimeItemLinks | The ItemsControl that holds the TimeItemLinks. One instance is owned by the Gantt.
TreeViewMultiColumnRow | The TreeViewMultiColumnRow inherites from Grid. If you use this in your treeview datatemplas as a layeout for your grid cells you can use the MultiColumnCoordinator to resize them together with other rows on different levels in the tree.

Enumerations

Enumeration | Description
AreaEnum | DateScale has different areas
ConflictAreaUpdateKind | The Different kinds of update that may be signaled on a conflict area
DateScaler.userop | Enum with possible user op values
DateScalerChangeKind | In the BeforeScaleOrSpanChange event this enum specifies what started the change
FishEyeMagnification | FishEyeMagnification.
MoveState | When the user is in a data changing operation for the TimeItem(s) the MoveState is changed from none to one of these
ResizingType | Resizing characteristics.
RowScreenStatus | Value gives information about a row position in a Gantt display
TimeItemLinkStyle | The style of link
TimeResolution | Enumeration for all availbale time scale resolutions
TimeStrEnum |
VerticalDayStripesUse | VerticalDayStripesUse

Delegates

Delegate | Description
BeforeScaleOrSpanChangeEventHandler | The event handler used to communicate change of the DateScaler
CollisionDetectEvent | The delegate for CollisionDetection
ConflictArea_Update | The delegate for ConflictArea_Update
TimeDistinctThread.AsyncDelegate |

See Also

GTP.NET.SL Assembly


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

BeforeScaleOrSpanChangeArgs Class

PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

Arguments for the BeforeScaleOrSpanChange event

For a list of all members of this type, see BeforeScaleOrSpanChangeArgs members.

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.BeforeScaleOrSpanChangeArgs

Syntax

[Visual Basic]
Public Class BeforeScaleOrSpanChangeArgs
   Inherits EventArgs
[C#]
public class BeforeScaleOrSpanChangeArgs : EventArgs
[C++]
public __gc class BeforeScaleOrSpanChangeArgs : public EventArgs
[C++/CLI]
public ref class BeforeScaleOrSpanChangeArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

BeforeScaleOrSpanChangeArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

BeforeScaleOrSpanChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

BeforeScaleOrSpanChangeArgs Class Members

PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

BeforeScaleOrSpanChangeArgs overview

Public Constructors

Public Constructor BeforeScaleOrSpanChangeArgs Constructor

Public Fields

Public Field DateScalerChangeKind | What kind of action that triggered the change
Public Field IsZoom | true if called from the zoom operation; deprecated use DateScalerChangeKind instead
Public Field NewStartTime | The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.
Public Field NewStopTime | The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.

See Also

BeforeScaleOrSpanChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BeforeScaleOrSpanChangeArgs Constructor

PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : BeforeScaleOrSpanChangeArgs Constructor (BeforeScaleOrSpanChangeArgs)
[Visual Basic]
Public Function New()
[C#]
public BeforeScaleOrSpanChangeArgs();
[C++]
public: BeforeScaleOrSpanChangeArgs();
[C++/CLI]
public:
BeforeScaleOrSpanChangeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%% $$Fields$$

BeforeScaleOrSpanChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

BeforeScaleOrSpanChangeArgs Class Fields

PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

For a list of all members of this type, see BeforeScaleOrSpanChangeArgs members.

Public Fields

Public Field DateScalerChangeKind | What kind of action that triggered the change
Public Field IsZoom | true if called from the zoom operation; deprecated use DateScalerChangeKind instead
Public Field NewStartTime | The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.
Public Field NewStopTime | The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.

See Also

BeforeScaleOrSpanChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DateScalerChangeKind Field

PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : DateScalerChangeKind Field (BeforeScaleOrSpanChangeArgs)

What kind of action that triggered the change

[Visual Basic]
Public DateScalerChangeKind As DateScalerChangeKind
[C#]
public DateScalerChangeKind DateScalerChangeKind
[C++]
public: DateScalerChangeKind DateScalerChangeKind
[C++/CLI]
public:
DateScalerChangeKind DateScalerChangeKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsZoom Field

PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : IsZoom Field

true if called from the zoom operation; deprecated use DateScalerChangeKind instead

[Visual Basic]
Public IsZoom As Boolean
[C#]
public bool IsZoom
[C++]
public: bool IsZoom
[C++/CLI]
public:
bool IsZoom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NewStartTime Field

PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : NewStartTime Field

The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.

[Visual Basic]
Public NewStartTime As Date
[C#]
public DateTime NewStartTime
[C++]
public: DateTime NewStartTime
[C++/CLI]
public:
DateTime NewStartTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NewStopTime Field

PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : NewStopTime Field

The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.

[Visual Basic]
Public NewStopTime As Date
[C#]
public DateTime NewStopTime
[C++]
public: DateTime NewStopTime
[C++/CLI]
public:
DateTime NewStopTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

BeforeScaleOrSpanChangeArgs Class | BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

CollisionDetectEventArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

CollisionDetectEventArgs Class

PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

CollisionDetect event args

For a list of all members of this type, see CollisionDetectEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CollisionDetectEventArgs

Syntax

[Visual Basic]
Public Class CollisionDetectEventArgs
   Inherits EventArgs
[C#]
public class CollisionDetectEventArgs : EventArgs
[C++]
public __gc class CollisionDetectEventArgs : public EventArgs
[C++/CLI]
public ref class CollisionDetectEventArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

CollisionDetectEventArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

CollisionDetectEventArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

CollisionDetectEventArgs Class Members

PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

CollisionDetectEventArgs overview

Public Constructors

Public Constructor CollisionDetectEventArgs Constructor

Public Fields

Public Field GanttRow | The row where the collision occured
Public Field TimeDistinctItem | Information on the detected collision

See Also

CollisionDetectEventArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionDetectEventArgs Constructor

PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : CollisionDetectEventArgs Constructor (CollisionDetectEventArgs)
[Visual Basic]
Public Function New()
[C#]
public CollisionDetectEventArgs();
[C++]
public: CollisionDetectEventArgs();
[C++/CLI]
public:
CollisionDetectEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members


%%PageItemTitle%% $$Fields$$

CollisionDetectEventArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

CollisionDetectEventArgs Class Fields

PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

For a list of all members of this type, see CollisionDetectEventArgs members.

Public Fields

Public Field GanttRow | The row where the collision occured
Public Field TimeDistinctItem | Information on the detected collision

See Also

CollisionDetectEventArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow Field

PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : GanttRow Field (CollisionDetectEventArgs)

The row where the collision occured

[Visual Basic]
Public GanttRow As GanttRow
[C#]
public GanttRow GanttRow
[C++]
public: GanttRow* GanttRow
[C++/CLI]
public:
GanttRow^ GanttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members


%%PageItemTitle%%

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeDistinctItem Field

PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : TimeDistinctItem Field (CollisionDetectEventArgs)

Information on the detected collision

[Visual Basic]
Public TimeDistinctItem As TimeDistinctItem
[C#]
public TimeDistinctItem TimeDistinctItem
[C++]
public: TimeDistinctItem* TimeDistinctItem
[C++/CLI]
public:
TimeDistinctItem^ TimeDistinctItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionDetectEventArgs Class | CollisionDetectEventArgs Members


%%PageItemTitle%%

CollisionNote Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

CollisionNote Class

PlexityHide.GTP Namespace : CollisionNote Class

Holds detailed information about one collision

For a list of all members of this type, see CollisionNote members.

Object Model

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CollisionNote

Syntax

[Visual Basic]
Public Class CollisionNote
[C#]
public class CollisionNote
[C++]
public __gc class CollisionNote
[C++/CLI]
public ref class CollisionNote

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

CollisionNote Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

CollisionNote Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

CollisionNote Class Members

PlexityHide.GTP Namespace : CollisionNote Class

CollisionNote overview

Public Constructors

Public Constructor CollisionNote Constructor

Public Fields

Public Field ConflictDepth | The highest amount of time items colliding in this particular position.
Public Field InCollision | One TimeDistinctItem that overlaps with the owner of this CollisionNote
Public Field OverlapStarts | Information on where the overlap starts
Public Field OverlapStops | Information on where the overlap stop

See Also

CollisionNote Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

CollisionNote Class | CollisionNote Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionNote Constructor

PlexityHide.GTP Namespace > CollisionNote Class : CollisionNote Constructor (CollisionNote)
[Visual Basic]
Public Function New()
[C#]
public CollisionNote();
[C++]
public: CollisionNote();
[C++/CLI]
public:
CollisionNote();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionNote Class | CollisionNote Members


%%PageItemTitle%% $$Fields$$

CollisionNote Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

CollisionNote Class Fields

PlexityHide.GTP Namespace : CollisionNote Class

For a list of all members of this type, see CollisionNote members.

Public Fields

Public Field ConflictDepth | The highest amount of time items colliding in this particular position.
Public Field InCollision | One TimeDistinctItem that overlaps with the owner of this CollisionNote
Public Field OverlapStarts | Information on where the overlap starts
Public Field OverlapStops | Information on where the overlap stop

See Also

CollisionNote Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

CollisionNote Class | CollisionNote Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictDepth Field

PlexityHide.GTP Namespace > CollisionNote Class : ConflictDepth Field (CollisionNote)

The highest amount of time items colliding in this particular position.

[Visual Basic]
Public ConflictDepth As Integer
[C#]
public int ConflictDepth
[C++]
public: int ConflictDepth
[C++/CLI]
public:
int ConflictDepth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionNote Class | CollisionNote Members


%%PageItemTitle%%

CollisionNote Class | CollisionNote Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InCollision Field

PlexityHide.GTP Namespace > CollisionNote Class : InCollision Field

One TimeDistinctItem that overlaps with the owner of this CollisionNote

[Visual Basic]
Public InCollision As TimeDistinctItem
[C#]
public TimeDistinctItem InCollision
[C++]
public: TimeDistinctItem* InCollision
[C++/CLI]
public:
TimeDistinctItem^ InCollision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionNote Class | CollisionNote Members


%%PageItemTitle%%

CollisionNote Class | CollisionNote Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OverlapStarts Field

PlexityHide.GTP Namespace > CollisionNote Class : OverlapStarts Field

Information on where the overlap starts

[Visual Basic]
Public OverlapStarts As Date
[C#]
public DateTime OverlapStarts
[C++]
public: DateTime OverlapStarts
[C++/CLI]
public:
DateTime OverlapStarts

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionNote Class | CollisionNote Members


%%PageItemTitle%%

CollisionNote Class | CollisionNote Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OverlapStops Field

PlexityHide.GTP Namespace > CollisionNote Class : OverlapStops Field

Information on where the overlap stop

[Visual Basic]
Public OverlapStops As Date
[C#]
public DateTime OverlapStops
[C++]
public: DateTime OverlapStops
[C++/CLI]
public:
DateTime OverlapStops

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

CollisionNote Class | CollisionNote Members


%%PageItemTitle%%

ConflictArea Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

ConflictArea Class

PlexityHide.GTP Namespace : ConflictArea Class (PlexityHide.GTP)

This class represents the detailed information that can be collected on each collision that is detected. To collect conflictAreas for a time item GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true.

For a list of all members of this type, see ConflictArea members.

Object Model

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ConflictArea

Syntax

[Visual Basic]
Public Class ConflictArea
[C#]
public class ConflictArea
[C++]
public __gc class ConflictArea
[C++/CLI]
public ref class ConflictArea

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

ConflictArea Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

ConflictArea Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea Class Members

PlexityHide.GTP Namespace : ConflictArea Class (PlexityHide.GTP)

ConflictArea overview

Public Constructors

Public Constructor ConflictArea Constructor

Public Fields

Public Field ConflictDepth | The the largest number of time items that exist in the same time during the span of this conflict area
Public Field ConflictingTimeItem | The time item in conflict with OwningTimeItem that this object represents.
Public Field OwningTimeItem | The owning time item for this conflict area
Public Field Start | The start of this conflict
Public Field Stop | The stop of this conflict
Public Field UserReference | Free for you to use...

Public Properties

Public Property InVisibleDateTimeArea Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...

Public Methods

Public Method GetOtherEnd A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.

See Also

ConflictArea Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictArea Constructor

PlexityHide.GTP Namespace > ConflictArea Class : ConflictArea Constructor (ConflictArea)
[Visual Basic]
Public Function New()
[C#]
public ConflictArea();
[C++]
public: ConflictArea();
[C++/CLI]
public:
ConflictArea();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%% $$Methods$$

ConflictArea Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea Class Methods

PlexityHide.GTP Namespace : ConflictArea Class (PlexityHide.GTP)

For a list of all members of this type, see ConflictArea members.

Public Methods

Public Method GetOtherEnd A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.

See Also

ConflictArea Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetOtherEnd Method

PlexityHide.GTP Namespace > ConflictArea Class : GetOtherEnd Method

A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.

[Visual Basic]
Public Function GetOtherEnd() As ConflictArea
[C#]
public ConflictArea GetOtherEnd();
[C++]
public: ConflictArea* GetOtherEnd();
[C++/CLI]
public:
ConflictArea^ GetOtherEnd();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%% $$Properties$$

ConflictArea Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea Class Properties

PlexityHide.GTP Namespace : ConflictArea Class (PlexityHide.GTP)

For a list of all members of this type, see ConflictArea members.

Public Properties

Public Property InVisibleDateTimeArea Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...

See Also

ConflictArea Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InVisibleDateTimeArea Property

PlexityHide.GTP Namespace > ConflictArea Class : InVisibleDateTimeArea Property

Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...

[Visual Basic]
Public ReadOnly Property InVisibleDateTimeArea As Boolean
[C#]
public bool InVisibleDateTimeArea {get;}
[C++]
public: __property bool get_InVisibleDateTimeArea();
[C++/CLI]
public:
property bool InVisibleDateTimeArea {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%% $$Fields$$

ConflictArea Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea Class Fields

PlexityHide.GTP Namespace : ConflictArea Class (PlexityHide.GTP)

For a list of all members of this type, see ConflictArea members.

Public Fields

Public Field ConflictDepth | The the largest number of time items that exist in the same time during the span of this conflict area
Public Field ConflictingTimeItem | The time item in conflict with OwningTimeItem that this object represents.
Public Field OwningTimeItem | The owning time item for this conflict area
Public Field Start | The start of this conflict
Public Field Stop | The stop of this conflict
Public Field UserReference | Free for you to use...

See Also

ConflictArea Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictDepth Field

PlexityHide.GTP Namespace > ConflictArea Class : ConflictDepth Field (ConflictArea)

The the largest number of time items that exist in the same time during the span of this conflict area

[Visual Basic]
Public ConflictDepth As Integer
[C#]
public int ConflictDepth
[C++]
public: int ConflictDepth
[C++/CLI]
public:
int ConflictDepth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictingTimeItem Field

PlexityHide.GTP Namespace > ConflictArea Class : ConflictingTimeItem Field

The time item in conflict with OwningTimeItem that this object represents.

[Visual Basic]
Public ConflictingTimeItem As TimeItem
[C#]
public TimeItem ConflictingTimeItem
[C++]
public: TimeItem* ConflictingTimeItem
[C++/CLI]
public:
TimeItem^ ConflictingTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OwningTimeItem Field

PlexityHide.GTP Namespace > ConflictArea Class : OwningTimeItem Field

The owning time item for this conflict area

[Visual Basic]
Public OwningTimeItem As TimeItem
[C#]
public TimeItem OwningTimeItem
[C++]
public: TimeItem* OwningTimeItem
[C++/CLI]
public:
TimeItem^ OwningTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Start Field

PlexityHide.GTP Namespace > ConflictArea Class : Start Field (ConflictArea)

The start of this conflict

[Visual Basic]
Public Start As Date
[C#]
public DateTime Start
[C++]
public: DateTime Start
[C++/CLI]
public:
DateTime Start

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Stop Field

PlexityHide.GTP Namespace > ConflictArea Class : Stop Field (ConflictArea)

The stop of this conflict

[Visual Basic]
Public Stop As Date
[C#]
public DateTime Stop
[C++]
public: DateTime Stop
[C++/CLI]
public:
DateTime Stop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea Class | ConflictArea Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UserReference Field

PlexityHide.GTP Namespace > ConflictArea Class : UserReference Field

Free for you to use...

[Visual Basic]
Public UserReference As Object
[C#]
public object UserReference
[C++]
public: Object* UserReference
[C++/CLI]
public:
Object^ UserReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea Class | ConflictArea Members


%%PageItemTitle%%

ConflictArea_UpdateArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

ConflictArea_UpdateArgs Class

PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

The arguments used by the ConflictArea_Update event

For a list of all members of this type, see ConflictArea_UpdateArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ConflictArea_UpdateArgs

Syntax

[Visual Basic]
Public Class ConflictArea_UpdateArgs
   Inherits EventArgs
[C#]
public class ConflictArea_UpdateArgs : EventArgs
[C++]
public __gc class ConflictArea_UpdateArgs : public EventArgs
[C++/CLI]
public ref class ConflictArea_UpdateArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

ConflictArea_UpdateArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

ConflictArea_UpdateArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea_UpdateArgs Class Members

PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

ConflictArea_UpdateArgs overview

Public Constructors

Public Constructor ConflictArea_UpdateArgs Constructor

Public Fields

Public Field ConflictArea | The ConflictArea that was updated
Public Field ConflictAreaUpdateKind | The graphics context

See Also

ConflictArea_UpdateArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictArea_UpdateArgs Constructor

PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictArea_UpdateArgs Constructor (ConflictArea_UpdateArgs)
[Visual Basic]
Public Function New()
[C#]
public ConflictArea_UpdateArgs();
[C++]
public: ConflictArea_UpdateArgs();
[C++/CLI]
public:
ConflictArea_UpdateArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members


%%PageItemTitle%% $$Fields$$

ConflictArea_UpdateArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ConflictArea_UpdateArgs Class Fields

PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

For a list of all members of this type, see ConflictArea_UpdateArgs members.

Public Fields

Public Field ConflictArea | The ConflictArea that was updated
Public Field ConflictAreaUpdateKind | The graphics context

See Also

ConflictArea_UpdateArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictArea Field

PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictArea Field (ConflictArea_UpdateArgs)

The ConflictArea that was updated

[Visual Basic]
Public ConflictArea As ConflictArea
[C#]
public ConflictArea ConflictArea
[C++]
public: ConflictArea* ConflictArea
[C++/CLI]
public:
ConflictArea^ ConflictArea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members


%%PageItemTitle%%

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictAreaUpdateKind Field

PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictAreaUpdateKind Field (ConflictArea_UpdateArgs)

The graphics context

[Visual Basic]
Public ConflictAreaUpdateKind As ConflictAreaUpdateKind
[C#]
public ConflictAreaUpdateKind ConflictAreaUpdateKind
[C++]
public: ConflictAreaUpdateKind ConflictAreaUpdateKind
[C++/CLI]
public:
ConflictAreaUpdateKind ConflictAreaUpdateKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ConflictArea_UpdateArgs Class | ConflictArea_UpdateArgs Members


%%PageItemTitle%%

DateScaleMark Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

DateScaleMark Class

PlexityHide.GTP Namespace : DateScaleMark Class

DateScaleMark holds info about one current scale mark in the DateScaler

For a list of all members of this type, see DateScaleMark members.

Inheritance Hierarchy

System.Object
PlexityHide.GTP.DateScaleMark

Syntax

[Visual Basic]
Public Class DateScaleMark
[C#]
public class DateScaleMark
[C++]
public __gc class DateScaleMark
[C++/CLI]
public ref class DateScaleMark

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

DateScaleMark Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

DateScaleMark Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaleMark Class Members

PlexityHide.GTP Namespace : DateScaleMark Class

DateScaleMark overview

Public Constructors

Public Constructor DateScaleMark Constructor Constructor used internally

Public Fields

Public Field Area | The area
Public Field Date | The date time that consitutes the time intervall for this scale mark
Public Field Format | This is how the date string will be formated
Public Field LinePos | This is where the line will go
Public Field LongIntervall | Long or short date intervall
Public Field PixelFarBox | The pixel that denotes the end of the represented time intervall
Public Field PixelMidMark | The pixel at the given datetime
Public Field Resolution | The resoultion
Public Field Text | The text on this scale mark

See Also

DateScaleMark Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

aFormat
aText
aPixelMidMark
aPixelFarBox
aDate
aResolution
aArea
aLongIntervall
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaleMark Constructor

PlexityHide.GTP Namespace > DateScaleMark Class : DateScaleMark Constructor (DateScaleMark)

Constructor used internally

[Visual Basic]
Public Function New( _
   ByVal aFormat As TimeStrEnum, _
   ByVal aText As String, _
   ByVal aPixelMidMark As Double, _
   ByVal aPixelFarBox As Double, _
   ByVal aDate As Date, _
   ByVal aResolution As TimeResolution, _
   ByVal aArea As AreaEnum, _
   ByVal aLongIntervall As Boolean _
)
[C#]
public DateScaleMark(
   TimeStrEnum aFormat,
   string aText,
   double aPixelMidMark,
   double aPixelFarBox,
   DateTime aDate,
   TimeResolution aResolution,
   AreaEnum aArea,
   bool aLongIntervall
);
[C++]
public: DateScaleMark(
   TimeStrEnum aFormat,
   string* aText,
   double aPixelMidMark,
   double aPixelFarBox,
   DateTime aDate,
   TimeResolution aResolution,
   AreaEnum aArea,
   bool aLongIntervall
)
[C++/CLI]
public:
DateScaleMark(
   TimeStrEnum aFormat,
   String^ aText,
   double aPixelMidMark,
   double aPixelFarBox,
   DateTime aDate,
   TimeResolution aResolution,
   AreaEnum aArea,
   bool aLongIntervall
)

Parameters

aFormat
aText
aPixelMidMark
aPixelFarBox
aDate
aResolution
aArea
aLongIntervall

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%% $$Fields$$

DateScaleMark Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaleMark Class Fields

PlexityHide.GTP Namespace : DateScaleMark Class

For a list of all members of this type, see DateScaleMark members.

Public Fields

Public Field Area | The area
Public Field Date | The date time that consitutes the time intervall for this scale mark
Public Field Format | This is how the date string will be formated
Public Field LinePos | This is where the line will go
Public Field LongIntervall | Long or short date intervall
Public Field PixelFarBox | The pixel that denotes the end of the represented time intervall
Public Field PixelMidMark | The pixel at the given datetime
Public Field Resolution | The resoultion
Public Field Text | The text on this scale mark

See Also

DateScaleMark Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Area Field

PlexityHide.GTP Namespace > DateScaleMark Class : Area Field (DateScaleMark)

The area

[Visual Basic]
Public Area As AreaEnum
[C#]
public AreaEnum Area
[C++]
public: AreaEnum Area
[C++/CLI]
public:
AreaEnum Area

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Date Field

PlexityHide.GTP Namespace > DateScaleMark Class : Date Field

The date time that consitutes the time intervall for this scale mark

[Visual Basic]
Public Date As Date
[C#]
public DateTime Date
[C++]
public: DateTime Date
[C++/CLI]
public:
DateTime Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Format Field

PlexityHide.GTP Namespace > DateScaleMark Class : Format Field

This is how the date string will be formated

[Visual Basic]
Public Format As TimeStrEnum
[C#]
public TimeStrEnum Format
[C++]
public: TimeStrEnum Format
[C++/CLI]
public:
TimeStrEnum Format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LinePos Field

PlexityHide.GTP Namespace > DateScaleMark Class : LinePos Field

This is where the line will go

[Visual Basic]
Public LinePos As Double
[C#]
public double LinePos
[C++]
public: double LinePos
[C++/CLI]
public:
double LinePos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LongIntervall Field

PlexityHide.GTP Namespace > DateScaleMark Class : LongIntervall Field

Long or short date intervall

[Visual Basic]
Public LongIntervall As Boolean
[C#]
public bool LongIntervall
[C++]
public: bool LongIntervall
[C++/CLI]
public:
bool LongIntervall

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelFarBox Field

PlexityHide.GTP Namespace > DateScaleMark Class : PixelFarBox Field

The pixel that denotes the end of the represented time intervall

[Visual Basic]
Public PixelFarBox As Double
[C#]
public double PixelFarBox
[C++]
public: double PixelFarBox
[C++/CLI]
public:
double PixelFarBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelMidMark Field

PlexityHide.GTP Namespace > DateScaleMark Class : PixelMidMark Field

The pixel at the given datetime

[Visual Basic]
Public PixelMidMark As Double
[C#]
public double PixelMidMark
[C++]
public: double PixelMidMark
[C++/CLI]
public:
double PixelMidMark

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resolution Field

PlexityHide.GTP Namespace > DateScaleMark Class : Resolution Field (DateScaleMark)

The resoultion

[Visual Basic]
Public Resolution As TimeResolution
[C#]
public TimeResolution Resolution
[C++]
public: TimeResolution Resolution
[C++/CLI]
public:
TimeResolution Resolution

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaleMark Class | DateScaleMark Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Text Field

PlexityHide.GTP Namespace > DateScaleMark Class : Text Field

The text on this scale mark

[Visual Basic]
Public Text As String
[C#]
public string Text
[C++]
public: string* Text
[C++/CLI]
public:
String^ Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaleMark Class | DateScaleMark Members


%%PageItemTitle%%

DateScaler Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

DateScaler Class

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

The DateScaler is the most important component. It handles all conversion between time and pixels for the Gantt chart

For a list of all members of this type, see DateScaler members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
PlexityHide.GTP.DateScaler

Syntax

[Visual Basic]
Public Class DateScaler
   Inherits Panel
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class DateScaler : Panel, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class DateScaler : public Panel, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class DateScaler : public Panel, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

DateScaler Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

DateScaler Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaler Class Members

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

DateScaler overview

Public Fields

Public Field static (Shared in Visual Basic) DateScalerTextBrushProperty | DateScalerTextBrushProperty is the dependencyproperty of the DateScalerTextBrush.
Public Field static (Shared in Visual Basic) StartTimeProperty | StartTimeProperty is the dependencyproperty of the StartTime. This sets the first visible date of the DateScaler.
Public Field static (Shared in Visual Basic) StopTimeProperty | StopTimeProperty is the dependencyproperty of the StopTime. This sets the last visible date of the DateScaler.

Public Properties

Public Property Boxes | Use boxes or not; default true
Public Property BoxesOnDaysRulerOnTime | Use boxes On Days+ and Ruler On Time or not
Public Property CultureInfoDateTimeFormat | Assign a new DateTimeFormatInfo for the culture that you are working with
Public Property CurrentUserOperation | The current operation that the user is performing
Public Property Datescalergeneration | This value increase each time the DateScaler is updated
Public Property DateScalerTextBrush | Brush used for datescaler texts
Public Property DrawBoxDivider | Default true, box dividers are the lines between,above and below the long and short date indications
Public Property FishEyeBrush | This is the brush used by the fisheye area when it is turned on
Public Property FishEyeEnabled | Enables the fisheye feature of the DateScaler. The FishEye holds a magnified resolution in the middle of the DateScaler.
Public Property FishEyeHigh | Get the end position of the fisheye section
Public Property FishEyeLow | Get the start position of the fisheye section
Public Property FishEyeMagnification |
Public Property FontSizeHighBand | The size of the font for the high band of the datescaler
Public Property FontSizeLowBand | The size of the font for the low band of the datescaler
Public Property MinusButton | Access to MinusButton, use MinusButton.Style to assing style
Public Property MinusbuttonStyle | The Style of of the minusbutton
Public Property MinusbuttonVisibility | The visibility of the Minus Button
Public Property OwningGanttRef | If this DateScaler is placed in a collecting Gantt it can be found here.
Public Property PixelsForModeSwitch | Tune the DateScaler drawing. When boxes are getting crowded a modeswitch occure, showing a different resolution. This property defines what "crowded" is
Public Property PixelsForModeSwitch_NarrowDays | Tune the DateScaler drawing. Same as PixelsForModeSwitch but used when UseDayNumbersNotWeeks is true and DayNumbers are in effect.
Public Property PixelsFromBottomLowerLine | Tune the DateScaler drawing.
Public Property PixelsFromBottomUpperLine | Tune the DateScaler drawing.
Public Property PixelsFromLineAboveToScalerText | Tune the DateScaler drawing.
Public Property PlusButton | Access to PlusButton, use PlusButton.Style to assing style
Public Property PlusbuttonStyle | The Style of of the plusbutton
Public Property PlusbuttonVisibility | The visibility of the plus Button
Public Property PrefixQuarter | If the scale presents quarters this prefix will be used, default "Q"
Public Property PrefixWeek | If the scale presents weeks this prefix will be used, default "W"
Public Property ReScaleWithControl | When this is true, the DateScaler will panorate by just grabbing and dragging it and when you hold the ctrl key while doing so the DateScaler will zoom in or out. When this is false it is the other way around.
Public Property RTKey | Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state
Public Property ScaleMarkerBrush | Sets and gets the brush of the scale markers.
Public Property ScaleMarkersHigh | Returns an array with the positions of all markers in the upper scale.
Public Property ScaleMarkersLow | Returns an array with the positions of all markers in the lower scale.
Public Property ScaleOperationInProgress | Returns true if scaling or panning is in progress
Public Property ScheduleMode | ScheduleMode set the DateScaler in vertical mode.
Public Property ScrollButtonMinusContent | Add content for the minus button here
Public Property ScrollButtonPlusContent | Add content for the plus button here
Public Property Serial | Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state
Public Property StartTime | The first DateTime value shown in the DateScale, read and write. Change this to change the view.
Public Property StopTime | The last DateTime value shown in the DateScale, read and write. Change this to change the view.
Public Property UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Public Property UseScheduleTimeLayoutForSmallIntervals | When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display
Public Property UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm | When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour
Public Property VisibleDays | Returns all days visible
Public Property VisibleHours | Returns all hours visible
Public Property ZoomIntoResolution | Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is TimeResolution.secondsBy10000

Public Methods

Public Method FishEyeMove | Move of fish eye by input parameter
Public Method FishEyeResize | Resize of fish eye by input parameter
Public Method static (Shared in Visual Basic) GetAppName | Gets the current application name. This is needed to get a unique runtime key to remove the plexityHide marking.
Public Method Invalidate | Call this to instruct datescaler to redraw drawing pass in message loop
Public Method Pan | Panorate the time scale a certain number of pixels left or right.
Public Method PixelToTime | PixelToTime converts from coordinate space to Time
Public Method TimeToPixel | TimeToPixel converts from Time to coordinate space
Public Method Zoom | Zoom the time scale a certain level, positive zoom out, negative zoom in.

Public Events

Public Event OnBeforeScaleOrSpanChange | Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code
Public Event OnScaleChangeEvent | Fires whenever the Datescaler is redrawn. Most likely due to a change of StartTime or StopTime
Public Event OnTextOutOverride | Override to change the text output in the upper or lower band of the DateScaler

Protected Methods

Protected Method _dateScalerGeneric_OnBeforeScaleOrSpanChange | Overridable for advanced use
Protected Method _dateScalerGeneric_OnInternalStartStopChangedNotify | Overridable for advanced use
Protected Method _dateScalerGeneric_OnInvalidate | Overridable for advanced use
Protected Method _dateScalerGeneric_OnScaleChangeEvent | Overridable for advanced use
Protected Method _minusbutton_Click | Overridable for advanced use
Protected Method _plusbutton_Click | Overridable for advanced use
Protected Method ArrangeOverride | Overridden.
Protected Method CheckForOwningGanttRef | Overridable for advanced use
Protected Method DateScaler_SL_MouseLeftButtonDown | Overridable for advanced use
Protected Method DateScaler_SL_MouseLeftButtonUp | Overridable for advanced use
Protected Method DateScaler_SL_MouseMove | Overridable for advanced use
Protected Method DateScaler_SL_SizeChanged | Overridable for advanced use
Protected Method DoAllDateScalerDrawing | Overridable for advanced use
Protected Method DoScheduleTimeLayoutForSmallIntervals | Overridable for advanced use
Protected Method DrawBoxes1 | Overridable for advanced use
Protected Method DrawLine_FlipAware | Overridable for advanced use
Protected Method InitAncestorGanttRef | Overridable for advanced use
Protected Method RenderContent | Overridable for advanced use
Protected Method RenderContent_Economic | Overridable for advanced use
Protected Method SetClip | Overridable for advanced use

See Also

DateScaler Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

DateScaler Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaler Class Methods

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

For a list of all members of this type, see DateScaler members.

Public Methods

Public Method FishEyeMove | Move of fish eye by input parameter
Public Method FishEyeResize | Resize of fish eye by input parameter
Public Method static (Shared in Visual Basic) GetAppName | Gets the current application name. This is needed to get a unique runtime key to remove the plexityHide marking.
Public Method Invalidate | Call this to instruct datescaler to redraw drawing pass in message loop
Public Method Pan | Panorate the time scale a certain number of pixels left or right.
Public Method PixelToTime | PixelToTime converts from coordinate space to Time
Public Method TimeToPixel | TimeToPixel converts from Time to coordinate space
Public Method Zoom | Zoom the time scale a certain level, positive zoom out, negative zoom in.

Protected Methods

Protected Method _dateScalerGeneric_OnBeforeScaleOrSpanChange | Overridable for advanced use
Protected Method _dateScalerGeneric_OnInternalStartStopChangedNotify | Overridable for advanced use
Protected Method _dateScalerGeneric_OnInvalidate | Overridable for advanced use
Protected Method _dateScalerGeneric_OnScaleChangeEvent | Overridable for advanced use
Protected Method _minusbutton_Click | Overridable for advanced use
Protected Method _plusbutton_Click | Overridable for advanced use
Protected Method ArrangeOverride | Overridden.
Protected Method CheckForOwningGanttRef | Overridable for advanced use
Protected Method DateScaler_SL_MouseLeftButtonDown | Overridable for advanced use
Protected Method DateScaler_SL_MouseLeftButtonUp | Overridable for advanced use
Protected Method DateScaler_SL_MouseMove | Overridable for advanced use
Protected Method DateScaler_SL_SizeChanged | Overridable for advanced use
Protected Method DoAllDateScalerDrawing | Overridable for advanced use
Protected Method DoScheduleTimeLayoutForSmallIntervals | Overridable for advanced use
Protected Method DrawBoxes1 | Overridable for advanced use
Protected Method DrawLine_FlipAware | Overridable for advanced use
Protected Method InitAncestorGanttRef | Overridable for advanced use
Protected Method RenderContent | Overridable for advanced use
Protected Method RenderContent_Economic | Overridable for advanced use
Protected Method SetClip | Overridable for advanced use

See Also

DateScaler Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dateScaler
e
See Also Languages GTP.NET.SL Send comments on this topic.

_dateScalerGeneric_OnBeforeScaleOrSpanChange Method

PlexityHide.GTP Namespace > DateScaler Class : _dateScalerGeneric_OnBeforeScaleOrSpanChange Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _dateScalerGeneric_OnBeforeScaleOrSpanChange( _
   ByVal dateScaler As Object, _
   ByVal e As BeforeScaleOrSpanChangeArgs _
)
[C#]
protected virtual void _dateScalerGeneric_OnBeforeScaleOrSpanChange(
   object dateScaler,
   BeforeScaleOrSpanChangeArgs e
);
[C++]
protected: virtual void _dateScalerGeneric_OnBeforeScaleOrSpanChange(
   Object* dateScaler,
   BeforeScaleOrSpanChangeArgs* e
)
[C++/CLI]
protected:
virtual void _dateScalerGeneric_OnBeforeScaleOrSpanChange(
   Object^ dateScaler,
   BeforeScaleOrSpanChangeArgs^ e
)

Parameters

dateScaler
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_dateScalerGeneric_OnInternalStartStopChangedNotify Method

PlexityHide.GTP Namespace > DateScaler Class : _dateScalerGeneric_OnInternalStartStopChangedNotify Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _dateScalerGeneric_OnInternalStartStopChangedNotify( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void _dateScalerGeneric_OnInternalStartStopChangedNotify(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void _dateScalerGeneric_OnInternalStartStopChangedNotify(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void _dateScalerGeneric_OnInternalStartStopChangedNotify(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_dateScalerGeneric_OnInvalidate Method

PlexityHide.GTP Namespace > DateScaler Class : _dateScalerGeneric_OnInvalidate Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _dateScalerGeneric_OnInvalidate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void _dateScalerGeneric_OnInvalidate(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void _dateScalerGeneric_OnInvalidate(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void _dateScalerGeneric_OnInvalidate(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_dateScalerGeneric_OnScaleChangeEvent Method

PlexityHide.GTP Namespace > DateScaler Class : _dateScalerGeneric_OnScaleChangeEvent Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _dateScalerGeneric_OnScaleChangeEvent( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void _dateScalerGeneric_OnScaleChangeEvent(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void _dateScalerGeneric_OnScaleChangeEvent(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void _dateScalerGeneric_OnScaleChangeEvent(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_minusbutton_Click Method

PlexityHide.GTP Namespace > DateScaler Class : _minusbutton_Click Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _minusbutton_Click( _
   ByVal sender As Object, _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void _minusbutton_Click(
   object sender,
   RoutedEventArgs e
);
[C++]
protected: virtual void _minusbutton_Click(
   Object* sender,
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void _minusbutton_Click(
   Object^ sender,
   RoutedEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_plusbutton_Click Method

PlexityHide.GTP Namespace > DateScaler Class : _plusbutton_Click Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _plusbutton_Click( _
   ByVal sender As Object, _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void _plusbutton_Click(
   object sender,
   RoutedEventArgs e
);
[C++]
protected: virtual void _plusbutton_Click(
   Object* sender,
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void _plusbutton_Click(
   Object^ sender,
   RoutedEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > DateScaler Class : ArrangeOverride Method (DateScaler)
[Visual Basic]
Overrides Protected Function ArrangeOverride( _
   ByVal availableSize As Size _
) As Size
[C#]
protected override Size ArrangeOverride(
   Size availableSize
);
[C++]
protected: Size ArrangeOverride(
   Size availableSize
) override
[C++/CLI]
protected:
Size ArrangeOverride(
   Size availableSize
) override

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CheckForOwningGanttRef Method

PlexityHide.GTP Namespace > DateScaler Class : CheckForOwningGanttRef Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub CheckForOwningGanttRef()
[C#]
protected virtual void CheckForOwningGanttRef();
[C++]
protected: virtual void CheckForOwningGanttRef();
[C++/CLI]
protected:
virtual void CheckForOwningGanttRef();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler_SL_MouseLeftButtonDown Method

PlexityHide.GTP Namespace > DateScaler Class : DateScaler_SL_MouseLeftButtonDown Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DateScaler_SL_MouseLeftButtonDown( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void DateScaler_SL_MouseLeftButtonDown(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void DateScaler_SL_MouseLeftButtonDown(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void DateScaler_SL_MouseLeftButtonDown(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler_SL_MouseLeftButtonUp Method

PlexityHide.GTP Namespace > DateScaler Class : DateScaler_SL_MouseLeftButtonUp Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DateScaler_SL_MouseLeftButtonUp( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void DateScaler_SL_MouseLeftButtonUp(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void DateScaler_SL_MouseLeftButtonUp(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void DateScaler_SL_MouseLeftButtonUp(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler_SL_MouseMove Method

PlexityHide.GTP Namespace > DateScaler Class : DateScaler_SL_MouseMove Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DateScaler_SL_MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void DateScaler_SL_MouseMove(
   object sender,
   MouseEventArgs e
);
[C++]
protected: virtual void DateScaler_SL_MouseMove(
   Object* sender,
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void DateScaler_SL_MouseMove(
   Object^ sender,
   MouseEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler_SL_SizeChanged Method

PlexityHide.GTP Namespace > DateScaler Class : DateScaler_SL_SizeChanged Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DateScaler_SL_SizeChanged( _
   ByVal sender As Object, _
   ByVal e As SizeChangedEventArgs _
)
[C#]
protected virtual void DateScaler_SL_SizeChanged(
   object sender,
   SizeChangedEventArgs e
);
[C++]
protected: virtual void DateScaler_SL_SizeChanged(
   Object* sender,
   SizeChangedEventArgs e
)
[C++/CLI]
protected:
virtual void DateScaler_SL_SizeChanged(
   Object^ sender,
   SizeChangedEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
resolution
aArea
areapixmin
areapixmax
scaleMarkersHigh_boxyhigh
scaleMarkersHigh_boxylow
scaleMarkersLow_boxyhigh
scaleMarkersLow_boxylow
See Also Languages GTP.NET.SL Send comments on this topic.

DoAllDateScalerDrawing Method

PlexityHide.GTP Namespace > DateScaler Class : DoAllDateScalerDrawing Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DoAllDateScalerDrawing( _
   ByVal dp As Canvas, _
   ByVal resolution As TimeResolution, _
   ByVal aArea As AreaEnum, _
   ByVal areapixmin As Double, _
   ByVal areapixmax As Double, _
   ByVal scaleMarkersHigh_boxyhigh As Double, _
   ByVal scaleMarkersHigh_boxylow As Double, _
   ByVal scaleMarkersLow_boxyhigh As Double, _
   ByVal scaleMarkersLow_boxylow As Double _
)
[C#]
protected virtual void DoAllDateScalerDrawing(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double areapixmin,
   double areapixmax,
   double scaleMarkersHigh_boxyhigh,
   double scaleMarkersHigh_boxylow,
   double scaleMarkersLow_boxyhigh,
   double scaleMarkersLow_boxylow
);
[C++]
protected: virtual void DoAllDateScalerDrawing(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double areapixmin,
   double areapixmax,
   double scaleMarkersHigh_boxyhigh,
   double scaleMarkersHigh_boxylow,
   double scaleMarkersLow_boxyhigh,
   double scaleMarkersLow_boxylow
)
[C++/CLI]
protected:
virtual void DoAllDateScalerDrawing(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double areapixmin,
   double areapixmax,
   double scaleMarkersHigh_boxyhigh,
   double scaleMarkersHigh_boxylow,
   double scaleMarkersLow_boxyhigh,
   double scaleMarkersLow_boxylow
)

Parameters

dp
resolution
aArea
areapixmin
areapixmax
scaleMarkersHigh_boxyhigh
scaleMarkersHigh_boxylow
scaleMarkersLow_boxyhigh
scaleMarkersLow_boxylow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
resolution
aArea
ystart
ystop
xleft
xmiddle
xright
See Also Languages GTP.NET.SL Send comments on this topic.

DoScheduleTimeLayoutForSmallIntervals Method

PlexityHide.GTP Namespace > DateScaler Class : DoScheduleTimeLayoutForSmallIntervals Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DoScheduleTimeLayoutForSmallIntervals( _
   ByVal dp As Canvas, _
   ByVal resolution As TimeResolution, _
   ByVal aArea As AreaEnum, _
   ByVal ystart As Double, _
   ByVal ystop As Double, _
   ByVal xleft As Double, _
   ByVal xmiddle As Double, _
   ByVal xright As Double _
)
[C#]
protected virtual void DoScheduleTimeLayoutForSmallIntervals(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double ystart,
   double ystop,
   double xleft,
   double xmiddle,
   double xright
);
[C++]
protected: virtual void DoScheduleTimeLayoutForSmallIntervals(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double ystart,
   double ystop,
   double xleft,
   double xmiddle,
   double xright
)
[C++/CLI]
protected:
virtual void DoScheduleTimeLayoutForSmallIntervals(
   Canvas dp,
   TimeResolution resolution,
   AreaEnum aArea,
   double ystart,
   double ystop,
   double xleft,
   double xmiddle,
   double xright
)

Parameters

dp
resolution
aArea
ystart
ystop
xleft
xmiddle
xright

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
pixmin
pixmax
positions
yhigh
ylow
aArea
See Also Languages GTP.NET.SL Send comments on this topic.

DrawBoxes1 Method

PlexityHide.GTP Namespace > DateScaler Class : DrawBoxes1 Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DrawBoxes1( _
   ByVal dp As Canvas, _
   ByVal pixmin As Double, _
   ByVal pixmax As Double, _
   ByVal positions As List(Of DateScaleMark), _
   ByVal yhigh As Double, _
   ByVal ylow As Double, _
   ByVal aArea As AreaEnum _
)
[C#]
protected virtual void DrawBoxes1(
   Canvas dp,
   double pixmin,
   double pixmax,
   List<DateScaleMark> positions,
   double yhigh,
   double ylow,
   AreaEnum aArea
);
[C++]
protected: virtual void DrawBoxes1(
   Canvas dp,
   double pixmin,
   double pixmax,
   List<DateScaleMark>* positions,
   double yhigh,
   double ylow,
   AreaEnum aArea
)
[C++/CLI]
protected:
virtual void DrawBoxes1(
   Canvas dp,
   double pixmin,
   double pixmax,
   List<DateScaleMark>^ positions,
   double yhigh,
   double ylow,
   AreaEnum aArea
)

Parameters

dp
pixmin
pixmax
positions
yhigh
ylow
aArea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
b
x1
y1
x2
y2
See Also Languages GTP.NET.SL Send comments on this topic.

DrawLine_FlipAware Method

PlexityHide.GTP Namespace > DateScaler Class : DrawLine_FlipAware Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DrawLine_FlipAware( _
   ByVal dp As Canvas, _
   ByVal b As Brush, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
[C#]
protected virtual void DrawLine_FlipAware(
   Canvas dp,
   Brush b,
   double x1,
   double y1,
   double x2,
   double y2
);
[C++]
protected: virtual void DrawLine_FlipAware(
   Canvas dp,
   Brush b,
   double x1,
   double y1,
   double x2,
   double y2
)
[C++/CLI]
protected:
virtual void DrawLine_FlipAware(
   Canvas dp,
   Brush b,
   double x1,
   double y1,
   double x2,
   double y2
)

Parameters

dp
b
x1
y1
x2
y2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

fishEyeDistance
See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeMove Method

PlexityHide.GTP Namespace > DateScaler Class : FishEyeMove Method

Move of fish eye by input parameter

[Visual Basic]
Public Overridable Sub FishEyeMove( _
   ByVal fishEyeDistance As Double _
)
[C#]
public virtual void FishEyeMove(
   double fishEyeDistance
);
[C++]
public: virtual void FishEyeMove(
   double fishEyeDistance
)
[C++/CLI]
public:
virtual void FishEyeMove(
   double fishEyeDistance
)

Parameters

fishEyeDistance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

fishEyeChange
See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeResize Method

PlexityHide.GTP Namespace > DateScaler Class : FishEyeResize Method

Resize of fish eye by input parameter

[Visual Basic]
Public Overridable Sub FishEyeResize( _
   ByVal fishEyeChange As Double _
)
[C#]
public virtual void FishEyeResize(
   double fishEyeChange
);
[C++]
public: virtual void FishEyeResize(
   double fishEyeChange
)
[C++/CLI]
public:
virtual void FishEyeResize(
   double fishEyeChange
)

Parameters

fishEyeChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetAppName Method

PlexityHide.GTP Namespace > DateScaler Class : GetAppName Method

Gets the current application name. This is needed to get a unique runtime key to remove the plexityHide marking.

[Visual Basic]
Public Shared Function GetAppName() As String
[C#]
public static string GetAppName();
[C++]
public: static string* GetAppName();
[C++/CLI]
public:
static String^ GetAppName();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InitAncestorGanttRef Method

PlexityHide.GTP Namespace > DateScaler Class : InitAncestorGanttRef Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub InitAncestorGanttRef()
[C#]
protected virtual void InitAncestorGanttRef();
[C++]
protected: virtual void InitAncestorGanttRef();
[C++/CLI]
protected:
virtual void InitAncestorGanttRef();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Invalidate Method

PlexityHide.GTP Namespace > DateScaler Class : Invalidate Method

Call this to instruct datescaler to redraw drawing pass in message loop

[Visual Basic]
Public Sub Invalidate()
[C#]
public void Invalidate();
[C++]
public: void Invalidate();
[C++/CLI]
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

distance
See Also Languages GTP.NET.SL Send comments on this topic.

Pan Method

PlexityHide.GTP Namespace > DateScaler Class : Pan Method

Panorate the time scale a certain number of pixels left or right.

[Visual Basic]
Public Overridable Sub Pan( _
   ByVal distance As Double _
)
[C#]
public virtual void Pan(
   double distance
);
[C++]
public: virtual void Pan(
   double distance
)
[C++/CLI]
public:
virtual void Pan(
   double distance
)

Parameters

distance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

pos
See Also Languages GTP.NET.SL Send comments on this topic.

PixelToTime Method

PlexityHide.GTP Namespace > DateScaler Class : PixelToTime Method

PixelToTime converts from coordinate space to Time

[Visual Basic]
Public Overridable Function PixelToTime( _
   ByVal pos As Double _
) As Date
[C#]
public virtual DateTime PixelToTime(
   double pos
);
[C++]
public: virtual DateTime PixelToTime(
   double pos
)
[C++/CLI]
public:
virtual DateTime PixelToTime(
   double pos
)

Parameters

pos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

Size
See Also Languages GTP.NET.SL Send comments on this topic.

RenderContent Method

PlexityHide.GTP Namespace > DateScaler Class : RenderContent Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub RenderContent( _
   ByVal Size As Size _
)
[C#]
protected virtual void RenderContent(
   Size Size
);
[C++]
protected: virtual void RenderContent(
   Size Size
)
[C++/CLI]
protected:
virtual void RenderContent(
   Size Size
)

Parameters

Size

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

Size
See Also Languages GTP.NET.SL Send comments on this topic.

RenderContent_Economic Method

PlexityHide.GTP Namespace > DateScaler Class : RenderContent_Economic Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub RenderContent_Economic( _
   ByVal Size As Size _
)
[C#]
protected virtual void RenderContent_Economic(
   Size Size
);
[C++]
protected: virtual void RenderContent_Economic(
   Size Size
)
[C++/CLI]
protected:
virtual void RenderContent_Economic(
   Size Size
)

Parameters

Size

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

Size
dp
x1
x2
See Also Languages GTP.NET.SL Send comments on this topic.

SetClip Method

PlexityHide.GTP Namespace > DateScaler Class : SetClip Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub SetClip( _
   ByVal Size As Size, _
   ByVal dp As Canvas, _
   ByVal x1 As Double, _
   ByVal x2 As Double _
)
[C#]
protected virtual void SetClip(
   Size Size,
   Canvas dp,
   double x1,
   double x2
);
[C++]
protected: virtual void SetClip(
   Size Size,
   Canvas dp,
   double x1,
   double x2
)
[C++/CLI]
protected:
virtual void SetClip(
   Size Size,
   Canvas dp,
   double x1,
   double x2
)

Parameters

Size
dp
x1
x2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

time
See Also Languages GTP.NET.SL Send comments on this topic.

TimeToPixel Method

PlexityHide.GTP Namespace > DateScaler Class : TimeToPixel Method

TimeToPixel converts from Time to coordinate space

[Visual Basic]
Public Overridable Function TimeToPixel( _
   ByVal time As Date _
) As Double
[C#]
public virtual double TimeToPixel(
   DateTime time
);
[C++]
public: virtual double TimeToPixel(
   DateTime time
)
[C++/CLI]
public:
virtual double TimeToPixel(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

level
downPoint
See Also Languages GTP.NET.SL Send comments on this topic.

Zoom Method

PlexityHide.GTP Namespace > DateScaler Class : Zoom Method

Zoom the time scale a certain level, positive zoom out, negative zoom in.

[Visual Basic]
Public Overridable Sub Zoom( _
   ByVal level As Double, _
   ByVal downPoint As Double _
)
[C#]
public virtual void Zoom(
   double level,
   double downPoint
);
[C++]
public: virtual void Zoom(
   double level,
   double downPoint
)
[C++/CLI]
public:
virtual void Zoom(
   double level,
   double downPoint
)

Parameters

level
downPoint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%% $$Properties$$

DateScaler Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaler Class Properties

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

For a list of all members of this type, see DateScaler members.

Public Properties

Public Property Boxes | Use boxes or not; default true
Public Property BoxesOnDaysRulerOnTime | Use boxes On Days+ and Ruler On Time or not
Public Property CultureInfoDateTimeFormat | Assign a new DateTimeFormatInfo for the culture that you are working with
Public Property CurrentUserOperation | The current operation that the user is performing
Public Property Datescalergeneration | This value increase each time the DateScaler is updated
Public Property DateScalerTextBrush | Brush used for datescaler texts
Public Property DrawBoxDivider | Default true, box dividers are the lines between,above and below the long and short date indications
Public Property FishEyeBrush | This is the brush used by the fisheye area when it is turned on
Public Property FishEyeEnabled | Enables the fisheye feature of the DateScaler. The FishEye holds a magnified resolution in the middle of the DateScaler.
Public Property FishEyeHigh | Get the end position of the fisheye section
Public Property FishEyeLow | Get the start position of the fisheye section
Public Property FishEyeMagnification |
Public Property FontSizeHighBand | The size of the font for the high band of the datescaler
Public Property FontSizeLowBand | The size of the font for the low band of the datescaler
Public Property MinusButton | Access to MinusButton, use MinusButton.Style to assing style
Public Property MinusbuttonStyle | The Style of of the minusbutton
Public Property MinusbuttonVisibility | The visibility of the Minus Button
Public Property OwningGanttRef | If this DateScaler is placed in a collecting Gantt it can be found here.
Public Property PixelsForModeSwitch | Tune the DateScaler drawing. When boxes are getting crowded a modeswitch occure, showing a different resolution. This property defines what "crowded" is
Public Property PixelsForModeSwitch_NarrowDays | Tune the DateScaler drawing. Same as PixelsForModeSwitch but used when UseDayNumbersNotWeeks is true and DayNumbers are in effect.
Public Property PixelsFromBottomLowerLine | Tune the DateScaler drawing.
Public Property PixelsFromBottomUpperLine | Tune the DateScaler drawing.
Public Property PixelsFromLineAboveToScalerText | Tune the DateScaler drawing.
Public Property PlusButton | Access to PlusButton, use PlusButton.Style to assing style
Public Property PlusbuttonStyle | The Style of of the plusbutton
Public Property PlusbuttonVisibility | The visibility of the plus Button
Public Property PrefixQuarter | If the scale presents quarters this prefix will be used, default "Q"
Public Property PrefixWeek | If the scale presents weeks this prefix will be used, default "W"
Public Property ReScaleWithControl | When this is true, the DateScaler will panorate by just grabbing and dragging it and when you hold the ctrl key while doing so the DateScaler will zoom in or out. When this is false it is the other way around.
Public Property RTKey | Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state
Public Property ScaleMarkerBrush | Sets and gets the brush of the scale markers.
Public Property ScaleMarkersHigh | Returns an array with the positions of all markers in the upper scale.
Public Property ScaleMarkersLow | Returns an array with the positions of all markers in the lower scale.
Public Property ScaleOperationInProgress | Returns true if scaling or panning is in progress
Public Property ScheduleMode | ScheduleMode set the DateScaler in vertical mode.
Public Property ScrollButtonMinusContent | Add content for the minus button here
Public Property ScrollButtonPlusContent | Add content for the plus button here
Public Property Serial | Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state
Public Property StartTime | The first DateTime value shown in the DateScale, read and write. Change this to change the view.
Public Property StopTime | The last DateTime value shown in the DateScale, read and write. Change this to change the view.
Public Property UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Public Property UseScheduleTimeLayoutForSmallIntervals | When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display
Public Property UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm | When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour
Public Property VisibleDays | Returns all days visible
Public Property VisibleHours | Returns all hours visible
Public Property ZoomIntoResolution | Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is TimeResolution.secondsBy10000

See Also

DateScaler Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Boxes Property

PlexityHide.GTP Namespace > DateScaler Class : Boxes Property

Use boxes or not; default true

[Visual Basic]
Public Property Boxes As Boolean
[C#]
public bool Boxes {get; set;}
[C++]
public: __property bool get_Boxes();
public: __property void set_Boxes(
   bool value
);
[C++/CLI]
public:
property bool Boxes {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BoxesOnDaysRulerOnTime Property

PlexityHide.GTP Namespace > DateScaler Class : BoxesOnDaysRulerOnTime Property

Use boxes On Days+ and Ruler On Time or not

[Visual Basic]
Public Property BoxesOnDaysRulerOnTime As Boolean
[C#]
public bool BoxesOnDaysRulerOnTime {get; set;}
[C++]
public: __property bool get_BoxesOnDaysRulerOnTime();
public: __property void set_BoxesOnDaysRulerOnTime(
   bool value
);
[C++/CLI]
public:
property bool BoxesOnDaysRulerOnTime {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CultureInfoDateTimeFormat Property

PlexityHide.GTP Namespace > DateScaler Class : CultureInfoDateTimeFormat Property

Assign a new DateTimeFormatInfo for the culture that you are working with

[Visual Basic]
Public Property CultureInfoDateTimeFormat As DateTimeFormatInfo
[C#]
public DateTimeFormatInfo CultureInfoDateTimeFormat {get; set;}
[C++]
public: __property DateTimeFormatInfo* get_CultureInfoDateTimeFormat();
public: __property void set_CultureInfoDateTimeFormat(
   DateTimeFormatInfo* value
);
[C++/CLI]
public:
property DateTimeFormatInfo^ CultureInfoDateTimeFormat {
   DateTimeFormatInfo^ get();
   void set (DateTimeFormatInfo^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CurrentUserOperation Property

PlexityHide.GTP Namespace > DateScaler Class : CurrentUserOperation Property

The current operation that the user is performing

[Visual Basic]
Public ReadOnly Property CurrentUserOperation As DateScaler.userop
[C#]
public DateScaler.userop CurrentUserOperation {get;}
[C++]
public: __property DateScaler.userop get_CurrentUserOperation();
[C++/CLI]
public:
property DateScaler.userop CurrentUserOperation {
   DateScaler.userop get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Datescalergeneration Property

PlexityHide.GTP Namespace > DateScaler Class : Datescalergeneration Property

This value increase each time the DateScaler is updated

[Visual Basic]
Public ReadOnly Property Datescalergeneration As Long
[C#]
public long Datescalergeneration {get;}
[C++]
public: __property long get_Datescalergeneration();
[C++/CLI]
public:
property long Datescalergeneration {
   long get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DateScalerTextBrush Property

PlexityHide.GTP Namespace > DateScaler Class : DateScalerTextBrush Property

Brush used for datescaler texts

[Visual Basic]
Public Property DateScalerTextBrush As Brush
[C#]
public Brush DateScalerTextBrush {get; set;}
[C++]
public: __property Brush get_DateScalerTextBrush();
public: __property void set_DateScalerTextBrush(
   Brush value
);
[C++/CLI]
public:
property Brush DateScalerTextBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DrawBoxDivider Property

PlexityHide.GTP Namespace > DateScaler Class : DrawBoxDivider Property

Default true, box dividers are the lines between,above and below the long and short date indications

[Visual Basic]
Public Property DrawBoxDivider As Boolean
[C#]
public bool DrawBoxDivider {get; set;}
[C++]
public: __property bool get_DrawBoxDivider();
public: __property void set_DrawBoxDivider(
   bool value
);
[C++/CLI]
public:
property bool DrawBoxDivider {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeBrush Property

PlexityHide.GTP Namespace > DateScaler Class : FishEyeBrush Property

This is the brush used by the fisheye area when it is turned on

[Visual Basic]
Public Property FishEyeBrush As Brush
[C#]
public Brush FishEyeBrush {get; set;}
[C++]
public: __property Brush get_FishEyeBrush();
public: __property void set_FishEyeBrush(
   Brush value
);
[C++/CLI]
public:
property Brush FishEyeBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeEnabled Property

PlexityHide.GTP Namespace > DateScaler Class : FishEyeEnabled Property

Enables the fisheye feature of the DateScaler. The FishEye holds a magnified resolution in the middle of the DateScaler.

[Visual Basic]
Public Property FishEyeEnabled As Boolean
[C#]
public bool FishEyeEnabled {get; set;}
[C++]
public: __property bool get_FishEyeEnabled();
public: __property void set_FishEyeEnabled(
   bool value
);
[C++/CLI]
public:
property bool FishEyeEnabled {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeHigh Property

PlexityHide.GTP Namespace > DateScaler Class : FishEyeHigh Property

Get the end position of the fisheye section

[Visual Basic]
Public Property FishEyeHigh As Double
[C#]
public double FishEyeHigh {get; set;}
[C++]
public: __property double get_FishEyeHigh();
public: __property void set_FishEyeHigh(
   double value
);
[C++/CLI]
public:
property double FishEyeHigh {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeLow Property

PlexityHide.GTP Namespace > DateScaler Class : FishEyeLow Property

Get the start position of the fisheye section

[Visual Basic]
Public Property FishEyeLow As Double
[C#]
public double FishEyeLow {get; set;}
[C++]
public: __property double get_FishEyeLow();
public: __property void set_FishEyeLow(
   double value
);
[C++/CLI]
public:
property double FishEyeLow {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FishEyeMagnification Property

PlexityHide.GTP Namespace > DateScaler Class : FishEyeMagnification Property (DateScaler)
[Visual Basic]
Public Property FishEyeMagnification As FishEyeMagnification
[C#]
public FishEyeMagnification FishEyeMagnification {get; set;}
[C++]
public: __property FishEyeMagnification get_FishEyeMagnification();
public: __property void set_FishEyeMagnification(
   FishEyeMagnification value
);
[C++/CLI]
public:
property FishEyeMagnification FishEyeMagnification {
   FishEyeMagnification get();
   void set (FishEyeMagnification value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontSizeHighBand Property

PlexityHide.GTP Namespace > DateScaler Class : FontSizeHighBand Property

The size of the font for the high band of the datescaler

[Visual Basic]
Public Property FontSizeHighBand As Double
[C#]
public double FontSizeHighBand {get; set;}
[C++]
public: __property double get_FontSizeHighBand();
public: __property void set_FontSizeHighBand(
   double value
);
[C++/CLI]
public:
property double FontSizeHighBand {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontSizeLowBand Property

PlexityHide.GTP Namespace > DateScaler Class : FontSizeLowBand Property

The size of the font for the low band of the datescaler

[Visual Basic]
Public Property FontSizeLowBand As Double
[C#]
public double FontSizeLowBand {get; set;}
[C++]
public: __property double get_FontSizeLowBand();
public: __property void set_FontSizeLowBand(
   double value
);
[C++/CLI]
public:
property double FontSizeLowBand {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinusButton Property

PlexityHide.GTP Namespace > DateScaler Class : MinusButton Property

Access to MinusButton, use MinusButton.Style to assing style

[Visual Basic]
Public ReadOnly Property MinusButton As RepeatButton
[C#]
public RepeatButton MinusButton {get;}
[C++]
public: __property RepeatButton get_MinusButton();
[C++/CLI]
public:
property RepeatButton MinusButton {
   RepeatButton get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinusbuttonStyle Property

PlexityHide.GTP Namespace > DateScaler Class : MinusbuttonStyle Property

The Style of of the minusbutton

[Visual Basic]
Public Property MinusbuttonStyle As Style
[C#]
public Style MinusbuttonStyle {get; set;}
[C++]
public: __property Style get_MinusbuttonStyle();
public: __property void set_MinusbuttonStyle(
   Style value
);
[C++/CLI]
public:
property Style MinusbuttonStyle {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinusbuttonVisibility Property

PlexityHide.GTP Namespace > DateScaler Class : MinusbuttonVisibility Property

The visibility of the Minus Button

[Visual Basic]
Public Property MinusbuttonVisibility As Visibility
[C#]
public Visibility MinusbuttonVisibility {get; set;}
[C++]
public: __property Visibility get_MinusbuttonVisibility();
public: __property void set_MinusbuttonVisibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility MinusbuttonVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OwningGanttRef Property

PlexityHide.GTP Namespace > DateScaler Class : OwningGanttRef Property (DateScaler)

If this DateScaler is placed in a collecting Gantt it can be found here.

[Visual Basic]
Public ReadOnly Property OwningGanttRef As Gantt
[C#]
public Gantt OwningGanttRef {get;}
[C++]
public: __property Gantt* get_OwningGanttRef();
[C++/CLI]
public:
property Gantt^ OwningGanttRef {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelsForModeSwitch Property

PlexityHide.GTP Namespace > DateScaler Class : PixelsForModeSwitch Property

Tune the DateScaler drawing. When boxes are getting crowded a modeswitch occure, showing a different resolution. This property defines what "crowded" is

[Visual Basic]
Public Property PixelsForModeSwitch As Double
[C#]
public double PixelsForModeSwitch {get; set;}
[C++]
public: __property double get_PixelsForModeSwitch();
public: __property void set_PixelsForModeSwitch(
   double value
);
[C++/CLI]
public:
property double PixelsForModeSwitch {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelsForModeSwitch_NarrowDays Property

PlexityHide.GTP Namespace > DateScaler Class : PixelsForModeSwitch_NarrowDays Property

Tune the DateScaler drawing. Same as PixelsForModeSwitch but used when UseDayNumbersNotWeeks is true and DayNumbers are in effect.

[Visual Basic]
Public Property PixelsForModeSwitch_NarrowDays As Double
[C#]
public double PixelsForModeSwitch_NarrowDays {get; set;}
[C++]
public: __property double get_PixelsForModeSwitch_NarrowDays();
public: __property void set_PixelsForModeSwitch_NarrowDays(
   double value
);
[C++/CLI]
public:
property double PixelsForModeSwitch_NarrowDays {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelsFromBottomLowerLine Property

PlexityHide.GTP Namespace > DateScaler Class : PixelsFromBottomLowerLine Property

Tune the DateScaler drawing.

[Visual Basic]
Public Property PixelsFromBottomLowerLine As Double
[C#]
public double PixelsFromBottomLowerLine {get; set;}
[C++]
public: __property double get_PixelsFromBottomLowerLine();
public: __property void set_PixelsFromBottomLowerLine(
   double value
);
[C++/CLI]
public:
property double PixelsFromBottomLowerLine {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelsFromBottomUpperLine Property

PlexityHide.GTP Namespace > DateScaler Class : PixelsFromBottomUpperLine Property

Tune the DateScaler drawing.

[Visual Basic]
Public Property PixelsFromBottomUpperLine As Double
[C#]
public double PixelsFromBottomUpperLine {get; set;}
[C++]
public: __property double get_PixelsFromBottomUpperLine();
public: __property void set_PixelsFromBottomUpperLine(
   double value
);
[C++/CLI]
public:
property double PixelsFromBottomUpperLine {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PixelsFromLineAboveToScalerText Property

PlexityHide.GTP Namespace > DateScaler Class : PixelsFromLineAboveToScalerText Property

Tune the DateScaler drawing.

[Visual Basic]
Public Property PixelsFromLineAboveToScalerText As Double
[C#]
public double PixelsFromLineAboveToScalerText {get; set;}
[C++]
public: __property double get_PixelsFromLineAboveToScalerText();
public: __property void set_PixelsFromLineAboveToScalerText(
   double value
);
[C++/CLI]
public:
property double PixelsFromLineAboveToScalerText {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PlusButton Property

PlexityHide.GTP Namespace > DateScaler Class : PlusButton Property

Access to PlusButton, use PlusButton.Style to assing style

[Visual Basic]
Public ReadOnly Property PlusButton As RepeatButton
[C#]
public RepeatButton PlusButton {get;}
[C++]
public: __property RepeatButton get_PlusButton();
[C++/CLI]
public:
property RepeatButton PlusButton {
   RepeatButton get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PlusbuttonStyle Property

PlexityHide.GTP Namespace > DateScaler Class : PlusbuttonStyle Property

The Style of of the plusbutton

[Visual Basic]
Public Property PlusbuttonStyle As Style
[C#]
public Style PlusbuttonStyle {get; set;}
[C++]
public: __property Style get_PlusbuttonStyle();
public: __property void set_PlusbuttonStyle(
   Style value
);
[C++/CLI]
public:
property Style PlusbuttonStyle {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PlusbuttonVisibility Property

PlexityHide.GTP Namespace > DateScaler Class : PlusbuttonVisibility Property

The visibility of the plus Button

[Visual Basic]
Public Property PlusbuttonVisibility As Visibility
[C#]
public Visibility PlusbuttonVisibility {get; set;}
[C++]
public: __property Visibility get_PlusbuttonVisibility();
public: __property void set_PlusbuttonVisibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility PlusbuttonVisibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PrefixQuarter Property

PlexityHide.GTP Namespace > DateScaler Class : PrefixQuarter Property

If the scale presents quarters this prefix will be used, default "Q"

[Visual Basic]
Public Property PrefixQuarter As String
[C#]
public string PrefixQuarter {get; set;}
[C++]
public: __property string* get_PrefixQuarter();
public: __property void set_PrefixQuarter(
   string* value
);
[C++/CLI]
public:
property String^ PrefixQuarter {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PrefixWeek Property

PlexityHide.GTP Namespace > DateScaler Class : PrefixWeek Property

If the scale presents weeks this prefix will be used, default "W"

[Visual Basic]
Public Property PrefixWeek As String
[C#]
public string PrefixWeek {get; set;}
[C++]
public: __property string* get_PrefixWeek();
public: __property void set_PrefixWeek(
   string* value
);
[C++/CLI]
public:
property String^ PrefixWeek {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReScaleWithControl Property

PlexityHide.GTP Namespace > DateScaler Class : ReScaleWithControl Property

When this is true, the DateScaler will panorate by just grabbing and dragging it and when you hold the ctrl key while doing so the DateScaler will zoom in or out. When this is false it is the other way around.

[Visual Basic]
Public Property ReScaleWithControl As Boolean
[C#]
public bool ReScaleWithControl {get; set;}
[C++]
public: __property bool get_ReScaleWithControl();
public: __property void set_ReScaleWithControl(
   bool value
);
[C++/CLI]
public:
property bool ReScaleWithControl {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RTKey Property

PlexityHide.GTP Namespace > DateScaler Class : RTKey Property

Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state

[Visual Basic]
Public Property RTKey As String
[C#]
public string RTKey {get; set;}
[C++]
public: __property string* get_RTKey();
public: __property void set_RTKey(
   string* value
);
[C++/CLI]
public:
property String^ RTKey {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScaleMarkerBrush Property

PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkerBrush Property

Sets and gets the brush of the scale markers.

[Visual Basic]
Public Property ScaleMarkerBrush As Brush
[C#]
public Brush ScaleMarkerBrush {get; set;}
[C++]
public: __property Brush get_ScaleMarkerBrush();
public: __property void set_ScaleMarkerBrush(
   Brush value
);
[C++/CLI]
public:
property Brush ScaleMarkerBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScaleMarkersHigh Property

PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkersHigh Property

Returns an array with the positions of all markers in the upper scale.

[Visual Basic]
Public ReadOnly Property ScaleMarkersHigh As List(Of DateScaleMark)
[C#]
public List<DateScaleMark> ScaleMarkersHigh {get;}
[C++]
public: __property List<DateScaleMark>* get_ScaleMarkersHigh();
[C++/CLI]
public:
property List<DateScaleMark>^ ScaleMarkersHigh {
   List<DateScaleMark>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScaleMarkersLow Property

PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkersLow Property

Returns an array with the positions of all markers in the lower scale.

[Visual Basic]
Public ReadOnly Property ScaleMarkersLow As List(Of DateScaleMark)
[C#]
public List<DateScaleMark> ScaleMarkersLow {get;}
[C++]
public: __property List<DateScaleMark>* get_ScaleMarkersLow();
[C++/CLI]
public:
property List<DateScaleMark>^ ScaleMarkersLow {
   List<DateScaleMark>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScaleOperationInProgress Property

PlexityHide.GTP Namespace > DateScaler Class : ScaleOperationInProgress Property

Returns true if scaling or panning is in progress

[Visual Basic]
Public ReadOnly Property ScaleOperationInProgress As Boolean
[C#]
public bool ScaleOperationInProgress {get;}
[C++]
public: __property bool get_ScaleOperationInProgress();
[C++/CLI]
public:
property bool ScaleOperationInProgress {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScheduleMode Property

PlexityHide.GTP Namespace > DateScaler Class : ScheduleMode Property (DateScaler)

ScheduleMode set the DateScaler in vertical mode.

[Visual Basic]
Public Property ScheduleMode As Boolean
[C#]
public bool ScheduleMode {get; set;}
[C++]
public: __property bool get_ScheduleMode();
public: __property void set_ScheduleMode(
   bool value
);
[C++/CLI]
public:
property bool ScheduleMode {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScrollButtonMinusContent Property

PlexityHide.GTP Namespace > DateScaler Class : ScrollButtonMinusContent Property

Add content for the minus button here

[Visual Basic]
Public Property ScrollButtonMinusContent As Object
[C#]
public object ScrollButtonMinusContent {get; set;}
[C++]
public: __property Object* get_ScrollButtonMinusContent();
public: __property void set_ScrollButtonMinusContent(
   Object* value
);
[C++/CLI]
public:
property Object^ ScrollButtonMinusContent {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScrollButtonPlusContent Property

PlexityHide.GTP Namespace > DateScaler Class : ScrollButtonPlusContent Property

Add content for the plus button here

[Visual Basic]
Public Property ScrollButtonPlusContent As Object
[C#]
public object ScrollButtonPlusContent {get; set;}
[C++]
public: __property Object* get_ScrollButtonPlusContent();
public: __property void set_ScrollButtonPlusContent(
   Object* value
);
[C++/CLI]
public:
property Object^ ScrollButtonPlusContent {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Serial Property

PlexityHide.GTP Namespace > DateScaler Class : Serial Property

Fill Serial and RTKey in to remove the plexityHide marking, or enter evaluation state

[Visual Basic]
Public Property Serial As String
[C#]
public string Serial {get; set;}
[C++]
public: __property string* get_Serial();
public: __property void set_Serial(
   string* value
);
[C++/CLI]
public:
property String^ Serial {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartTime Property

PlexityHide.GTP Namespace > DateScaler Class : StartTime Property

The first DateTime value shown in the DateScale, read and write. Change this to change the view.

[Visual Basic]
Public Property StartTime As Date
[C#]
public DateTime StartTime {get; set;}
[C++]
public: __property DateTime get_StartTime();
public: __property void set_StartTime(
   DateTime value
);
[C++/CLI]
public:
property DateTime StartTime {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopTime Property

PlexityHide.GTP Namespace > DateScaler Class : StopTime Property

The last DateTime value shown in the DateScale, read and write. Change this to change the view.

[Visual Basic]
Public Property StopTime As Date
[C#]
public DateTime StopTime {get; set;}
[C++]
public: __property DateTime get_StopTime();
public: __property void set_StopTime(
   DateTime value
);
[C++/CLI]
public:
property DateTime StopTime {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseDayNumbersNotWeeks Property

PlexityHide.GTP Namespace > DateScaler Class : UseDayNumbersNotWeeks Property

When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position

[Visual Basic]
Public Property UseDayNumbersNotWeeks As Boolean
[C#]
public bool UseDayNumbersNotWeeks {get; set;}
[C++]
public: __property bool get_UseDayNumbersNotWeeks();
public: __property void set_UseDayNumbersNotWeeks(
   bool value
);
[C++/CLI]
public:
property bool UseDayNumbersNotWeeks {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseScheduleTimeLayoutForSmallIntervals Property

PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntervals Property

When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display

[Visual Basic]
Public Property UseScheduleTimeLayoutForSmallIntervals As Boolean
[C#]
public bool UseScheduleTimeLayoutForSmallIntervals {get; set;}
[C++]
public: __property bool get_UseScheduleTimeLayoutForSmallIntervals();
public: __property void set_UseScheduleTimeLayoutForSmallIntervals(
   bool value
);
[C++/CLI]
public:
property bool UseScheduleTimeLayoutForSmallIntervals {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm Property

PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm Property

When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour

[Visual Basic]
Public Property UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm As Boolean
[C#]
public bool UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm {get; set;}
[C++]
public: __property bool get_UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm();
public: __property void set_UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm(
   bool value
);
[C++/CLI]
public:
property bool UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VisibleDays Property

PlexityHide.GTP Namespace > DateScaler Class : VisibleDays Property (DateScaler)

Returns all days visible

[Visual Basic]
Public Property VisibleDays As DayOfWeek()
[C#]
public DayOfWeek[] VisibleDays {get; set;}
[C++]
public: __property DayOfWeek[]* get_VisibleDays();
public: __property void set_VisibleDays(
   DayOfWeek[]* value
);
[C++/CLI]
public:
property array<DayOfWeek>^ VisibleDays {
   array<DayOfWeek>^ get();
   void set (DayOfWeekarray<value>^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VisibleHours Property

PlexityHide.GTP Namespace > DateScaler Class : VisibleHours Property (DateScaler)

Returns all hours visible

[Visual Basic]
Public Property VisibleHours As Integer()
[C#]
public int[] VisibleHours {get; set;}
[C++]
public: __property int[]* get_VisibleHours();
public: __property void set_VisibleHours(
   int[]* value
);
[C++/CLI]
public:
property array<int>^ VisibleHours {
   array<int>^ get();
   void set (intarray<value>^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ZoomIntoResolution Property

PlexityHide.GTP Namespace > DateScaler Class : ZoomIntoResolution Property

Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is TimeResolution.secondsBy10000

[Visual Basic]
Public Property ZoomIntoResolution As TimeResolution
[C#]
public TimeResolution ZoomIntoResolution {get; set;}
[C++]
public: __property TimeResolution get_ZoomIntoResolution();
public: __property void set_ZoomIntoResolution(
   TimeResolution value
);
[C++/CLI]
public:
property TimeResolution ZoomIntoResolution {
   TimeResolution get();
   void set (TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%% $$Fields$$

DateScaler Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaler Class Fields

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

For a list of all members of this type, see DateScaler members.

Public Fields

Public Field static (Shared in Visual Basic) DateScalerTextBrushProperty | DateScalerTextBrushProperty is the dependencyproperty of the DateScalerTextBrush.
Public Field static (Shared in Visual Basic) StartTimeProperty | StartTimeProperty is the dependencyproperty of the StartTime. This sets the first visible date of the DateScaler.
Public Field static (Shared in Visual Basic) StopTimeProperty | StopTimeProperty is the dependencyproperty of the StopTime. This sets the last visible date of the DateScaler.

See Also

DateScaler Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DateScalerTextBrushProperty Field

PlexityHide.GTP Namespace > DateScaler Class : DateScalerTextBrushProperty Field

DateScalerTextBrushProperty is the dependencyproperty of the DateScalerTextBrush.

[Visual Basic]
Public Shared DateScalerTextBrushProperty As DependencyProperty
[C#]
public static DependencyProperty DateScalerTextBrushProperty
[C++]
public: static DependencyProperty DateScalerTextBrushProperty
[C++/CLI]
public:
static DependencyProperty DateScalerTextBrushProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartTimeProperty Field

PlexityHide.GTP Namespace > DateScaler Class : StartTimeProperty Field

StartTimeProperty is the dependencyproperty of the StartTime. This sets the first visible date of the DateScaler.

[Visual Basic]
Public Shared StartTimeProperty As DependencyProperty
[C#]
public static DependencyProperty StartTimeProperty
[C++]
public: static DependencyProperty StartTimeProperty
[C++/CLI]
public:
static DependencyProperty StartTimeProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopTimeProperty Field

PlexityHide.GTP Namespace > DateScaler Class : StopTimeProperty Field

StopTimeProperty is the dependencyproperty of the StopTime. This sets the last visible date of the DateScaler.

[Visual Basic]
Public Shared StopTimeProperty As DependencyProperty
[C#]
public static DependencyProperty StopTimeProperty
[C++]
public: static DependencyProperty StopTimeProperty
[C++/CLI]
public:
static DependencyProperty StopTimeProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%% $$Events$$

DateScaler Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

DateScaler Class Events

PlexityHide.GTP Namespace : DateScaler Class (PlexityHide.GTP)

For a list of all members of this type, see DateScaler members.

Public Events

Public Event OnBeforeScaleOrSpanChange | Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code
Public Event OnScaleChangeEvent | Fires whenever the Datescaler is redrawn. Most likely due to a change of StartTime or StopTime
Public Event OnTextOutOverride | Override to change the text output in the upper or lower band of the DateScaler

See Also

DateScaler Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnBeforeScaleOrSpanChange Event

PlexityHide.GTP Namespace > DateScaler Class : OnBeforeScaleOrSpanChange Event

Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code

[Visual Basic]
Public Event OnBeforeScaleOrSpanChange() As BeforeScaleOrSpanChangeEventHandler
[C#]
public event BeforeScaleOrSpanChangeEventHandler OnBeforeScaleOrSpanChange();
[C++]
public: __event BeforeScaleOrSpanChangeEventHandler* OnBeforeScaleOrSpanChange();
[C++/CLI]
public:
event BeforeScaleOrSpanChangeEventHandler^ OnBeforeScaleOrSpanChange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnScaleChangeEvent Event

PlexityHide.GTP Namespace > DateScaler Class : OnScaleChangeEvent Event

Fires whenever the Datescaler is redrawn. Most likely due to a change of StartTime or StopTime

[Visual Basic]
Public Event OnScaleChangeEvent() As EventHandler
[C#]
public event EventHandler OnScaleChangeEvent();
[C++]
public: __event EventHandler* OnScaleChangeEvent();
[C++/CLI]
public:
event EventHandler^ OnScaleChangeEvent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnTextOutOverride Event

PlexityHide.GTP Namespace > DateScaler Class : OnTextOutOverride Event

Override to change the text output in the upper or lower band of the DateScaler

[Visual Basic]
Public Event OnTextOutOverride() As EventHandler(Of TextOutOverrideArgs)
[C#]
public event EventHandler<TextOutOverrideArgs> OnTextOutOverride();
[C++]
public: __event EventHandler<TextOutOverrideArgs>* OnTextOutOverride();
[C++/CLI]
public:
event EventHandler<TextOutOverrideArgs>^ OnTextOutOverride();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

ExternalDropArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

ExternalDropArgs Class

PlexityHide.GTP Namespace : ExternalDropArgs Class

Arguments used in the externaldrop event

For a list of all members of this type, see ExternalDropArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ExternalDropArgs

Syntax

[Visual Basic]
Public Class ExternalDropArgs
   Inherits EventArgs
[C#]
public class ExternalDropArgs : EventArgs
[C++]
public __gc class ExternalDropArgs : public EventArgs
[C++/CLI]
public ref class ExternalDropArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

ExternalDropArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

ExternalDropArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ExternalDropArgs Class Members

PlexityHide.GTP Namespace : ExternalDropArgs Class

ExternalDropArgs overview

Public Constructors

Public Constructor ExternalDropArgs Constructor

Public Fields

Public Field AllTimeItemsInMoveOperation | When using multiselect all selected time items, including the one actually grabbed will be in this collection
Public Field OldRow | The old row the TimeItem was placed on
Public Field RevertMoveInTime | Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.
Public Field StopOperationForFollowingTimeItems | When an ExternalDrop is performed on multiple time items, by multi select, you may want to handle the cluster move in the first ExternalDrop event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the ExternalDrop
Public Field TimeItem | The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

See Also

ExternalDropArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ExternalDropArgs Constructor

PlexityHide.GTP Namespace > ExternalDropArgs Class : ExternalDropArgs Constructor (ExternalDropArgs)
[Visual Basic]
Public Function New()
[C#]
public ExternalDropArgs();
[C++]
public: ExternalDropArgs();
[C++/CLI]
public:
ExternalDropArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%% $$Fields$$

ExternalDropArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

ExternalDropArgs Class Fields

PlexityHide.GTP Namespace : ExternalDropArgs Class

For a list of all members of this type, see ExternalDropArgs members.

Public Fields

Public Field AllTimeItemsInMoveOperation | When using multiselect all selected time items, including the one actually grabbed will be in this collection
Public Field OldRow | The old row the TimeItem was placed on
Public Field RevertMoveInTime | Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.
Public Field StopOperationForFollowingTimeItems | When an ExternalDrop is performed on multiple time items, by multi select, you may want to handle the cluster move in the first ExternalDrop event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the ExternalDrop
Public Field TimeItem | The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

See Also

ExternalDropArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllTimeItemsInMoveOperation Field

PlexityHide.GTP Namespace > ExternalDropArgs Class : AllTimeItemsInMoveOperation Field (ExternalDropArgs)

When using multiselect all selected time items, including the one actually grabbed will be in this collection

[Visual Basic]
Public AllTimeItemsInMoveOperation As TimeItem()
[C#]
public TimeItem[] AllTimeItemsInMoveOperation
[C++]
public: TimeItem*[]* AllTimeItemsInMoveOperation
[C++/CLI]
public:
array<TimeItem^>^ AllTimeItemsInMoveOperation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OldRow Field

PlexityHide.GTP Namespace > ExternalDropArgs Class : OldRow Field (ExternalDropArgs)

The old row the TimeItem was placed on

[Visual Basic]
Public OldRow As GanttRow
[C#]
public GanttRow OldRow
[C++]
public: GanttRow* OldRow
[C++/CLI]
public:
GanttRow^ OldRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RevertMoveInTime Field

PlexityHide.GTP Namespace > ExternalDropArgs Class : RevertMoveInTime Field (ExternalDropArgs)

Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.

[Visual Basic]
Public RevertMoveInTime As Boolean
[C#]
public bool RevertMoveInTime
[C++]
public: bool RevertMoveInTime
[C++/CLI]
public:
bool RevertMoveInTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopOperationForFollowingTimeItems Field

PlexityHide.GTP Namespace > ExternalDropArgs Class : StopOperationForFollowingTimeItems Field (ExternalDropArgs)

When an ExternalDrop is performed on multiple time items, by multi select, you may want to handle the cluster move in the first ExternalDrop event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the ExternalDrop

[Visual Basic]
Public StopOperationForFollowingTimeItems As Boolean
[C#]
public bool StopOperationForFollowingTimeItems
[C++]
public: bool StopOperationForFollowingTimeItems
[C++/CLI]
public:
bool StopOperationForFollowingTimeItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%%

ExternalDropArgs Class | ExternalDropArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Field

PlexityHide.GTP Namespace > ExternalDropArgs Class : TimeItem Field (ExternalDropArgs)

The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

[Visual Basic]
Public TimeItem As TimeItem
[C#]
public TimeItem TimeItem
[C++]
public: TimeItem* TimeItem
[C++/CLI]
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

ExternalDropArgs Class | ExternalDropArgs Members


%%PageItemTitle%%

Gantt Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

Gantt Class

PlexityHide.GTP Namespace : Gantt Class

The Gantt is a collecting control of type Grid. You normally place a DataGrid or TreeView inside the Gantt. You should also always place exactly one DateScaler inside the Gantt. Place the DateScaler where it makes sense for your GanttRows

For a list of all members of this type, see Gantt members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Grid
PlexityHide.GTP.Gantt

Syntax

[Visual Basic]
Public Class Gantt
   Inherits Grid
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class Gantt : Grid, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class Gantt : public Grid, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class Gantt : public Grid, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

Gantt Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

Gantt Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

Gantt Class Members

PlexityHide.GTP Namespace : Gantt Class

Gantt overview

Public Constructors

Public Constructor Gantt Constructor The Gantt constructor takes no arguments

Public Properties

Public Property CollisionDetectionSyncron | When turned on the CollisionDetection is performed directly when a need for evaluation occures. Normally the detection is performed in a worker thread - but if you print or otherwise need immidiate response you turn this on.
Public Property DateScaler | The DateScaler used by this collecting Gantt
Public Property GanttRows | All the GanttRows seen by this collecting Gantt. Note that all rows even if you have a tree hierarchy will end up in this list, and the list has no particular order. To navigate rows in order you should consider iterating your grid or tree component and from that find each GanttRow.
Public Property ScheduleMode | ScheduleMode makes the DateScaler change to vertical orientation and you should use standing GridRows to make sense of this.
Public Property SelectedTimeItems | The currently selected time items.
Public Property TimeItemLinks | You can reach the ItemsControl for the TimeItemLinks here.
Public Property TimeItemLinksItemsSource | Set the datasource for the TimeItemLinks here
Public Property TimeItemLinksTemplate | The Refererence to the DataTemplate that should hold a TimeItemLink object explaining how the StartIdentity and StopIdentity properties of the link are bound. The StartIdentity and StopIdentity must evaluate to something that equals a TimeItem.Id in order for a link to be drawn.
Public Property TodayLineStroke | The today line brush
Public Property TodayLineStrokeThickness | The today line Thickness
Public Property TodayLineUse | Turns the TodayLine on or off
Public Property TurnOffAllCollisionDetect | When turned on, all GanttRows ignore their setting for collision detection
Public Property VerticalDayStripeBrush | The VerticalDayStripe brush
Public Property VerticalDayStripes_Days | VerticalDayStripes set to true, this property then chooses the days, sat and sun default
Public Property VerticalDayStripesHighestResolution | Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property VerticalDayStripesLowestResolution | Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property VerticalDayStripesUse | Vertical stripes on certain days

Public Methods

Public Method ApplyStartAndStopChange | Overridable for advanced use, public for technical reasons
Public Method ClearTimeItemSelections | Clears all selections from the TimeItems
Public Method FindRowForTimeItem | Given a TimeItem's current, potentially moved position, find out what GanttRow its middle is on.
Public Method RegisterDateScaler | Overridable for advanced use, public for technical reasons
Public Method RegisterGanttRow | Overridable for advanced use, public for technical reasons
Public Method SelectionChanged | Overridable for advanced use, public for technical reasons
Public Method TimeItemAboutToBeCleanedForFree | Overridable for advanced use , public for technical reasons
Public Method UnRegisterDateScaler | Overridable for advanced use, public for technical reasons
Public Method UnRegisterGanttRow | Overridable for advanced use, public for technical reasons
Public Method UpdateBackAndForegroundClip | Overridable for advanced use, public for technical reasons
Public Method UpdateBackAndForegroundContent | Overridable for advanced use, public for technical reasons
Public Method UpdateIdentityOfTimeItem | Overridable for advanced use, public for technical reasons
Public Method UpdateMultiSelect | Overloaded. Overridable for advanced use, public for technical reasons
Public Method UpdatePositionOnThisAndSelected | Overridable for advanced use, public for technical reasons

Public Events

Public Event OnCollisionDetect | Fired on detected collisions
Public Event OnConflictArea_Update | Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic
Public Event OnDrawBackground | Fired when the display has changed in such a way that user added time dependant items in the background needs update
Public Event OnDrawForeground | Fired when the display has changed in such a way that user added time dependant items in the foreground needs update
Public Event OnTimeItemExternalDrop | Triggers when d
Public Event OnTimeItemRowChange | When the this event fires you should decide if the move is ok and if so change the underlying data to reflect the move Once the underlaying data is updated the databind will discover this and the time item is removed from the old ganttrow and displayed on the new

Protected Methods

Protected Method AddToSelection | Overridable for advanced use
Protected Method CheckNewRowPossiblyRevertTimeMove | Overridable for advanced use
Protected Method DateScaler_OnTimeItemPositionsOutOfDate | Overridable for advanced use
Protected Method DrawVerticalDayStripes | Overridable for advanced use
Protected Method Gantt_LayoutUpdated | Overridable for advanced use
Protected Method InvalidateTimeItems | Overridable for advanced use
Protected Method RegisterDateScalerEvents | Overridable for advanced use
Protected Method RemoveFromSelection | Overridable for advanced use
Protected Method TodayLine | Overridable for advanced use
Protected Method UnregisterDateScalerEvents | Overridable for advanced use

See Also

Gantt Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Gantt Constructor

PlexityHide.GTP Namespace > Gantt Class : Gantt Constructor (Gantt)

The Gantt constructor takes no arguments

[Visual Basic]
Public Function New()
[C#]
public Gantt();
[C++]
public: Gantt();
[C++/CLI]
public:
Gantt();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%% $$Methods$$

Gantt Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

Gantt Class Methods

PlexityHide.GTP Namespace : Gantt Class

For a list of all members of this type, see Gantt members.

Public Methods

Public Method ApplyStartAndStopChange | Overridable for advanced use, public for technical reasons
Public Method ClearTimeItemSelections | Clears all selections from the TimeItems
Public Method FindRowForTimeItem | Given a TimeItem's current, potentially moved position, find out what GanttRow its middle is on.
Public Method RegisterDateScaler | Overridable for advanced use, public for technical reasons
Public Method RegisterGanttRow | Overridable for advanced use, public for technical reasons
Public Method SelectionChanged | Overridable for advanced use, public for technical reasons
Public Method TimeItemAboutToBeCleanedForFree | Overridable for advanced use , public for technical reasons
Public Method UnRegisterDateScaler | Overridable for advanced use, public for technical reasons
Public Method UnRegisterGanttRow | Overridable for advanced use, public for technical reasons
Public Method UpdateBackAndForegroundClip | Overridable for advanced use, public for technical reasons
Public Method UpdateBackAndForegroundContent | Overridable for advanced use, public for technical reasons
Public Method UpdateIdentityOfTimeItem | Overridable for advanced use, public for technical reasons
Public Method UpdateMultiSelect | Overloaded. Overridable for advanced use, public for technical reasons
Public Method UpdatePositionOnThisAndSelected | Overridable for advanced use, public for technical reasons

Protected Methods

Protected Method AddToSelection | Overridable for advanced use
Protected Method CheckNewRowPossiblyRevertTimeMove | Overridable for advanced use
Protected Method DateScaler_OnTimeItemPositionsOutOfDate | Overridable for advanced use
Protected Method DrawVerticalDayStripes | Overridable for advanced use
Protected Method Gantt_LayoutUpdated | Overridable for advanced use
Protected Method InvalidateTimeItems | Overridable for advanced use
Protected Method RegisterDateScalerEvents | Overridable for advanced use
Protected Method RemoveFromSelection | Overridable for advanced use
Protected Method TodayLine | Overridable for advanced use
Protected Method UnregisterDateScalerEvents | Overridable for advanced use

See Also

Gantt Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
See Also Languages GTP.NET.SL Send comments on this topic.

AddToSelection Method

PlexityHide.GTP Namespace > Gantt Class : AddToSelection Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub AddToSelection( _
   ByVal timeItem As TimeItem _
)
[C#]
protected virtual void AddToSelection(
   TimeItem timeItem
);
[C++]
protected: virtual void AddToSelection(
   TimeItem* timeItem
)
[C++/CLI]
protected:
virtual void AddToSelection(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

diff
See Also Languages GTP.NET.SL Send comments on this topic.

ApplyStartAndStopChange Method

PlexityHide.GTP Namespace > Gantt Class : ApplyStartAndStopChange Method (Gantt)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub ApplyStartAndStopChange( _
   ByVal diff As Point _
)
[C#]
public virtual void ApplyStartAndStopChange(
   Point diff
);
[C++]
public: virtual void ApplyStartAndStopChange(
   Point diff
)
[C++/CLI]
public:
virtual void ApplyStartAndStopChange(
   Point diff
)

Parameters

diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ti
stopOperationForFollowingTimeItems
See Also Languages GTP.NET.SL Send comments on this topic.

CheckNewRowPossiblyRevertTimeMove Method

PlexityHide.GTP Namespace > Gantt Class : CheckNewRowPossiblyRevertTimeMove Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Function CheckNewRowPossiblyRevertTimeMove( _
   ByVal ti As TimeItem, _
   ByRef stopOperationForFollowingTimeItems As Boolean _
) As Boolean
[C#]
protected virtual bool CheckNewRowPossiblyRevertTimeMove(
   TimeItem ti,
   out bool stopOperationForFollowingTimeItems
);
[C++]
protected: virtual bool CheckNewRowPossiblyRevertTimeMove(
   TimeItem* ti,
   [PARAMFLAG::Out] bool stopOperationForFollowingTimeItems
)
[C++/CLI]
protected:
virtual bool CheckNewRowPossiblyRevertTimeMove(
   TimeItem^ ti,
   [Out] bool stopOperationForFollowingTimeItems
)

Parameters

ti
stopOperationForFollowingTimeItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ClearTimeItemSelections Method

PlexityHide.GTP Namespace > Gantt Class : ClearTimeItemSelections Method

Clears all selections from the TimeItems

[Visual Basic]
Public Overridable Sub ClearTimeItemSelections()
[C#]
public virtual void ClearTimeItemSelections();
[C++]
public: virtual void ClearTimeItemSelections();
[C++/CLI]
public:
virtual void ClearTimeItemSelections();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler_OnTimeItemPositionsOutOfDate Method

PlexityHide.GTP Namespace > Gantt Class : DateScaler_OnTimeItemPositionsOutOfDate Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DateScaler_OnTimeItemPositionsOutOfDate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void DateScaler_OnTimeItemPositionsOutOfDate(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void DateScaler_OnTimeItemPositionsOutOfDate(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void DateScaler_OnTimeItemPositionsOutOfDate(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DrawVerticalDayStripes Method

PlexityHide.GTP Namespace > Gantt Class : DrawVerticalDayStripes Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub DrawVerticalDayStripes()
[C#]
protected virtual void DrawVerticalDayStripes();
[C++]
protected: virtual void DrawVerticalDayStripes();
[C++/CLI]
protected:
virtual void DrawVerticalDayStripes();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ti
See Also Languages GTP.NET.SL Send comments on this topic.

FindRowForTimeItem Method

PlexityHide.GTP Namespace > Gantt Class : FindRowForTimeItem Method

Given a TimeItem's current, potentially moved position, find out what GanttRow its middle is on.

[Visual Basic]
Public Overridable Function FindRowForTimeItem( _
   ByVal ti As TimeItem _
) As GanttRow
[C#]
public virtual GanttRow FindRowForTimeItem(
   TimeItem ti
);
[C++]
public: virtual GanttRow* FindRowForTimeItem(
   TimeItem* ti
)
[C++/CLI]
public:
virtual GanttRow^ FindRowForTimeItem(
   TimeItem^ ti
)

Parameters

ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

Gantt_LayoutUpdated Method

PlexityHide.GTP Namespace > Gantt Class : Gantt_LayoutUpdated Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub Gantt_LayoutUpdated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void Gantt_LayoutUpdated(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void Gantt_LayoutUpdated(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void Gantt_LayoutUpdated(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateTimeItems Method

PlexityHide.GTP Namespace > Gantt Class : InvalidateTimeItems Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub InvalidateTimeItems()
[C#]
protected virtual void InvalidateTimeItems();
[C++]
protected: virtual void InvalidateTimeItems();
[C++/CLI]
protected:
virtual void InvalidateTimeItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dateScaler
See Also Languages GTP.NET.SL Send comments on this topic.

RegisterDateScaler Method

PlexityHide.GTP Namespace > Gantt Class : RegisterDateScaler Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub RegisterDateScaler( _
   ByVal dateScaler As DateScaler _
)
[C#]
public virtual void RegisterDateScaler(
   DateScaler dateScaler
);
[C++]
public: virtual void RegisterDateScaler(
   DateScaler* dateScaler
)
[C++/CLI]
public:
virtual void RegisterDateScaler(
   DateScaler^ dateScaler
)

Parameters

dateScaler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RegisterDateScalerEvents Method

PlexityHide.GTP Namespace > Gantt Class : RegisterDateScalerEvents Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub RegisterDateScalerEvents()
[C#]
protected virtual void RegisterDateScalerEvents();
[C++]
protected: virtual void RegisterDateScalerEvents();
[C++/CLI]
protected:
virtual void RegisterDateScalerEvents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ganttRow
See Also Languages GTP.NET.SL Send comments on this topic.

RegisterGanttRow Method

PlexityHide.GTP Namespace > Gantt Class : RegisterGanttRow Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub RegisterGanttRow( _
   ByVal ganttRow As GanttRow _
)
[C#]
public virtual void RegisterGanttRow(
   GanttRow ganttRow
);
[C++]
public: virtual void RegisterGanttRow(
   GanttRow* ganttRow
)
[C++/CLI]
public:
virtual void RegisterGanttRow(
   GanttRow^ ganttRow
)

Parameters

ganttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveFromSelection Method

PlexityHide.GTP Namespace > Gantt Class : RemoveFromSelection Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub RemoveFromSelection( _
   ByVal timeItem As TimeItem _
)
[C#]
protected virtual void RemoveFromSelection(
   TimeItem timeItem
);
[C++]
protected: virtual void RemoveFromSelection(
   TimeItem* timeItem
)
[C++/CLI]
protected:
virtual void RemoveFromSelection(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ganttRow
e
See Also Languages GTP.NET.SL Send comments on this topic.

SelectionChanged Method

PlexityHide.GTP Namespace > Gantt Class : SelectionChanged Method (Gantt)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub SelectionChanged( _
   ByVal ganttRow As GanttRow, _
   ByVal e As SelectionChangedEventArgs _
)
[C#]
public virtual void SelectionChanged(
   GanttRow ganttRow,
   SelectionChangedEventArgs e
);
[C++]
public: virtual void SelectionChanged(
   GanttRow* ganttRow,
   SelectionChangedEventArgs e
)
[C++/CLI]
public:
virtual void SelectionChanged(
   GanttRow^ ganttRow,
   SelectionChangedEventArgs e
)

Parameters

ganttRow
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ti
See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemAboutToBeCleanedForFree Method

PlexityHide.GTP Namespace > Gantt Class : TimeItemAboutToBeCleanedForFree Method

Overridable for advanced use , public for technical reasons

[Visual Basic]
Public Overridable Sub TimeItemAboutToBeCleanedForFree( _
   ByVal ti As TimeItem _
)
[C#]
public virtual void TimeItemAboutToBeCleanedForFree(
   TimeItem ti
);
[C++]
public: virtual void TimeItemAboutToBeCleanedForFree(
   TimeItem* ti
)
[C++/CLI]
public:
virtual void TimeItemAboutToBeCleanedForFree(
   TimeItem^ ti
)

Parameters

ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TodayLine Method

PlexityHide.GTP Namespace > Gantt Class : TodayLine Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub TodayLine()
[C#]
protected virtual void TodayLine();
[C++]
protected: virtual void TodayLine();
[C++/CLI]
protected:
virtual void TodayLine();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dateScaler
See Also Languages GTP.NET.SL Send comments on this topic.

UnRegisterDateScaler Method

PlexityHide.GTP Namespace > Gantt Class : UnRegisterDateScaler Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UnRegisterDateScaler( _
   ByVal dateScaler As DateScaler _
)
[C#]
public virtual void UnRegisterDateScaler(
   DateScaler dateScaler
);
[C++]
public: virtual void UnRegisterDateScaler(
   DateScaler* dateScaler
)
[C++/CLI]
public:
virtual void UnRegisterDateScaler(
   DateScaler^ dateScaler
)

Parameters

dateScaler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UnregisterDateScalerEvents Method

PlexityHide.GTP Namespace > Gantt Class : UnregisterDateScalerEvents Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub UnregisterDateScalerEvents()
[C#]
protected virtual void UnregisterDateScalerEvents();
[C++]
protected: virtual void UnregisterDateScalerEvents();
[C++/CLI]
protected:
virtual void UnregisterDateScalerEvents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ganttRow
See Also Languages GTP.NET.SL Send comments on this topic.

UnRegisterGanttRow Method

PlexityHide.GTP Namespace > Gantt Class : UnRegisterGanttRow Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UnRegisterGanttRow( _
   ByVal ganttRow As GanttRow _
)
[C#]
public virtual void UnRegisterGanttRow(
   GanttRow ganttRow
);
[C++]
public: virtual void UnRegisterGanttRow(
   GanttRow* ganttRow
)
[C++/CLI]
public:
virtual void UnRegisterGanttRow(
   GanttRow^ ganttRow
)

Parameters

ganttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateBackAndForegroundClip Method

PlexityHide.GTP Namespace > Gantt Class : UpdateBackAndForegroundClip Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UpdateBackAndForegroundClip()
[C#]
public virtual void UpdateBackAndForegroundClip();
[C++]
public: virtual void UpdateBackAndForegroundClip();
[C++/CLI]
public:
virtual void UpdateBackAndForegroundClip();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateBackAndForegroundContent Method

PlexityHide.GTP Namespace > Gantt Class : UpdateBackAndForegroundContent Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UpdateBackAndForegroundContent()
[C#]
public virtual void UpdateBackAndForegroundContent();
[C++]
public: virtual void UpdateBackAndForegroundContent();
[C++/CLI]
public:
virtual void UpdateBackAndForegroundContent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
oldValue
newValue
See Also Languages GTP.NET.SL Send comments on this topic.

UpdateIdentityOfTimeItem Method

PlexityHide.GTP Namespace > Gantt Class : UpdateIdentityOfTimeItem Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UpdateIdentityOfTimeItem( _
   ByVal timeItem As TimeItem, _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
public virtual void UpdateIdentityOfTimeItem(
   TimeItem timeItem,
   object oldValue,
   object newValue
);
[C++]
public: virtual void UpdateIdentityOfTimeItem(
   TimeItem* timeItem,
   Object* oldValue,
   Object* newValue
)
[C++/CLI]
public:
virtual void UpdateIdentityOfTimeItem(
   TimeItem^ timeItem,
   Object^ oldValue,
   Object^ newValue
)

Parameters

timeItem
oldValue
newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateMultiSelect Method

PlexityHide.GTP Namespace > Gantt Class : UpdateMultiSelect Method

Overridable for advanced use, public for technical reasons

Overload List

Overridable for advanced use, public for technical reasons

[Visual Basic] Overloads Public Overridable Sub UpdateMultiSelect(TimeItem)

[C#] public virtual void UpdateMultiSelect(TimeItem);

[C++] public virtual void UpdateMultiSelect(TimeItem*);

[C++/CLI] public virtual void UpdateMultiSelect(TimeItem^);

Call this to select a specific time item by code.

[Visual Basic] Overloads Public Overridable Sub UpdateMultiSelect(TimeItem,Boolean)

[C#] public virtual void UpdateMultiSelect(TimeItem,bool);

[C++] public virtual void UpdateMultiSelect(TimeItem*,bool);

[C++/CLI] public virtual void UpdateMultiSelect(TimeItem^,bool);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members | Overload List

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
See Also Languages GTP.NET.SL Send comments on this topic.

UpdateMultiSelect(TimeItem) Method

PlexityHide.GTP Namespace > Gantt Class > UpdateMultiSelect Method : UpdateMultiSelect(TimeItem) Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Overloads Public Overridable Sub UpdateMultiSelect( _
   ByVal timeItem As TimeItem _
)
[C#]
public virtual void UpdateMultiSelect(
   TimeItem timeItem
);
[C++]
public: virtual void UpdateMultiSelect(
   TimeItem* timeItem
)
[C++/CLI]
public:
virtual void UpdateMultiSelect(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members | Overload List


%%PageItemTitle%%

Gantt Class | Gantt Members | Overload List

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
addToSelection
See Also Languages GTP.NET.SL Send comments on this topic.

UpdateMultiSelect(TimeItem,Boolean) Method

PlexityHide.GTP Namespace > Gantt Class > UpdateMultiSelect Method : UpdateMultiSelect(TimeItem,Boolean) Method

Call this to select a specific time item by code.

[Visual Basic]
Overloads Public Overridable Sub UpdateMultiSelect( _
   ByVal timeItem As TimeItem, _
   ByVal addToSelection As Boolean _
)
[C#]
public virtual void UpdateMultiSelect(
   TimeItem timeItem,
   bool addToSelection
);
[C++]
public: virtual void UpdateMultiSelect(
   TimeItem* timeItem,
   bool addToSelection
)
[C++/CLI]
public:
virtual void UpdateMultiSelect(
   TimeItem^ timeItem,
   bool addToSelection
)

Parameters

timeItem
addToSelection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members | Overload List


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
startdiff
stopdiff
See Also Languages GTP.NET.SL Send comments on this topic.

UpdatePositionOnThisAndSelected Method

PlexityHide.GTP Namespace > Gantt Class : UpdatePositionOnThisAndSelected Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UpdatePositionOnThisAndSelected( _
   ByVal timeItem As TimeItem, _
   ByVal startdiff As Point, _
   ByVal stopdiff As Point _
)
[C#]
public virtual void UpdatePositionOnThisAndSelected(
   TimeItem timeItem,
   Point startdiff,
   Point stopdiff
);
[C++]
public: virtual void UpdatePositionOnThisAndSelected(
   TimeItem* timeItem,
   Point startdiff,
   Point stopdiff
)
[C++/CLI]
public:
virtual void UpdatePositionOnThisAndSelected(
   TimeItem^ timeItem,
   Point startdiff,
   Point stopdiff
)

Parameters

timeItem
startdiff
stopdiff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%% $$Properties$$

Gantt Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

Gantt Class Properties

PlexityHide.GTP Namespace : Gantt Class

For a list of all members of this type, see Gantt members.

Public Properties

Public Property CollisionDetectionSyncron | When turned on the CollisionDetection is performed directly when a need for evaluation occures. Normally the detection is performed in a worker thread - but if you print or otherwise need immidiate response you turn this on.
Public Property DateScaler | The DateScaler used by this collecting Gantt
Public Property GanttRows | All the GanttRows seen by this collecting Gantt. Note that all rows even if you have a tree hierarchy will end up in this list, and the list has no particular order. To navigate rows in order you should consider iterating your grid or tree component and from that find each GanttRow.
Public Property ScheduleMode | ScheduleMode makes the DateScaler change to vertical orientation and you should use standing GridRows to make sense of this.
Public Property SelectedTimeItems | The currently selected time items.
Public Property TimeItemLinks | You can reach the ItemsControl for the TimeItemLinks here.
Public Property TimeItemLinksItemsSource | Set the datasource for the TimeItemLinks here
Public Property TimeItemLinksTemplate | The Refererence to the DataTemplate that should hold a TimeItemLink object explaining how the StartIdentity and StopIdentity properties of the link are bound. The StartIdentity and StopIdentity must evaluate to something that equals a TimeItem.Id in order for a link to be drawn.
Public Property TodayLineStroke | The today line brush
Public Property TodayLineStrokeThickness | The today line Thickness
Public Property TodayLineUse | Turns the TodayLine on or off
Public Property TurnOffAllCollisionDetect | When turned on, all GanttRows ignore their setting for collision detection
Public Property VerticalDayStripeBrush | The VerticalDayStripe brush
Public Property VerticalDayStripes_Days | VerticalDayStripes set to true, this property then chooses the days, sat and sun default
Public Property VerticalDayStripesHighestResolution | Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property VerticalDayStripesLowestResolution | Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property VerticalDayStripesUse | Vertical stripes on certain days

See Also

Gantt Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionDetectionSyncron Property

PlexityHide.GTP Namespace > Gantt Class : CollisionDetectionSyncron Property

When turned on the CollisionDetection is performed directly when a need for evaluation occures. Normally the detection is performed in a worker thread - but if you print or otherwise need immidiate response you turn this on.

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property CollisionDetectionSyncron As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool CollisionDetectionSyncron {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_CollisionDetectionSyncron();
public: __property void set_CollisionDetectionSyncron(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool CollisionDetectionSyncron {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler Property

PlexityHide.GTP Namespace > Gantt Class : DateScaler Property (Gantt)

The DateScaler used by this collecting Gantt

[Visual Basic]
Public ReadOnly Property DateScaler As DateScaler
[C#]
public DateScaler DateScaler {get;}
[C++]
public: __property DateScaler* get_DateScaler();
[C++/CLI]
public:
property DateScaler^ DateScaler {
   DateScaler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRows Property

PlexityHide.GTP Namespace > Gantt Class : GanttRows Property

All the GanttRows seen by this collecting Gantt. Note that all rows even if you have a tree hierarchy will end up in this list, and the list has no particular order. To navigate rows in order you should consider iterating your grid or tree component and from that find each GanttRow.

[Visual Basic]
Public ReadOnly Property GanttRows As List(Of GanttRow)
[C#]
public List<GanttRow> GanttRows {get;}
[C++]
public: __property List<GanttRow>* get_GanttRows();
[C++/CLI]
public:
property List<GanttRow>^ GanttRows {
   List<GanttRow>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ScheduleMode Property

PlexityHide.GTP Namespace > Gantt Class : ScheduleMode Property (Gantt)

ScheduleMode makes the DateScaler change to vertical orientation and you should use standing GridRows to make sense of this.

[Visual Basic]
Public Property ScheduleMode As Boolean
[C#]
public bool ScheduleMode {get; set;}
[C++]
public: __property bool get_ScheduleMode();
public: __property void set_ScheduleMode(
   bool value
);
[C++/CLI]
public:
property bool ScheduleMode {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectedTimeItems Property

PlexityHide.GTP Namespace > Gantt Class : SelectedTimeItems Property

The currently selected time items.

[Visual Basic]
Public ReadOnly Property SelectedTimeItems As TimeItem()
[C#]
public TimeItem[] SelectedTimeItems {get;}
[C++]
public: __property TimeItem*[]* get_SelectedTimeItems();
[C++/CLI]
public:
property array<TimeItem^>^ SelectedTimeItems {
   array<TimeItem^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinks Property

PlexityHide.GTP Namespace > Gantt Class : TimeItemLinks Property (Gantt)

You can reach the ItemsControl for the TimeItemLinks here.

[Visual Basic]
Public ReadOnly Property TimeItemLinks As TimeItemLinks
[C#]
public TimeItemLinks TimeItemLinks {get;}
[C++]
public: __property TimeItemLinks* get_TimeItemLinks();
[C++/CLI]
public:
property TimeItemLinks^ TimeItemLinks {
   TimeItemLinks^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinksItemsSource Property

PlexityHide.GTP Namespace > Gantt Class : TimeItemLinksItemsSource Property

Set the datasource for the TimeItemLinks here

[Visual Basic]
Public Property TimeItemLinksItemsSource As IEnumerable
[C#]
public IEnumerable TimeItemLinksItemsSource {get; set;}
[C++]
public: __property IEnumerable* get_TimeItemLinksItemsSource();
public: __property void set_TimeItemLinksItemsSource(
   IEnumerable* value
);
[C++/CLI]
public:
property IEnumerable^ TimeItemLinksItemsSource {
   IEnumerable^ get();
   void set (IEnumerable^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinksTemplate Property

PlexityHide.GTP Namespace > Gantt Class : TimeItemLinksTemplate Property

The Refererence to the DataTemplate that should hold a TimeItemLink object explaining how the StartIdentity and StopIdentity properties of the link are bound. The StartIdentity and StopIdentity must evaluate to something that equals a TimeItem.Id in order for a link to be drawn.

[Visual Basic]
Public Property TimeItemLinksTemplate As DataTemplate
[C#]
public DataTemplate TimeItemLinksTemplate {get; set;}
[C++]
public: __property DataTemplate get_TimeItemLinksTemplate();
public: __property void set_TimeItemLinksTemplate(
   DataTemplate value
);
[C++/CLI]
public:
property DataTemplate TimeItemLinksTemplate {
   DataTemplate get();
   void set (DataTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TodayLineStroke Property

PlexityHide.GTP Namespace > Gantt Class : TodayLineStroke Property

The today line brush

[Visual Basic]
Public Property TodayLineStroke As Brush
[C#]
public Brush TodayLineStroke {get; set;}
[C++]
public: __property Brush get_TodayLineStroke();
public: __property void set_TodayLineStroke(
   Brush value
);
[C++/CLI]
public:
property Brush TodayLineStroke {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TodayLineStrokeThickness Property

PlexityHide.GTP Namespace > Gantt Class : TodayLineStrokeThickness Property

The today line Thickness

[Visual Basic]
Public Property TodayLineStrokeThickness As Double
[C#]
public double TodayLineStrokeThickness {get; set;}
[C++]
public: __property double get_TodayLineStrokeThickness();
public: __property void set_TodayLineStrokeThickness(
   double value
);
[C++/CLI]
public:
property double TodayLineStrokeThickness {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TodayLineUse Property

PlexityHide.GTP Namespace > Gantt Class : TodayLineUse Property

Turns the TodayLine on or off

[Visual Basic]
Public Property TodayLineUse As Boolean
[C#]
public bool TodayLineUse {get; set;}
[C++]
public: __property bool get_TodayLineUse();
public: __property void set_TodayLineUse(
   bool value
);
[C++/CLI]
public:
property bool TodayLineUse {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TurnOffAllCollisionDetect Property

PlexityHide.GTP Namespace > Gantt Class : TurnOffAllCollisionDetect Property

When turned on, all GanttRows ignore their setting for collision detection

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property TurnOffAllCollisionDetect As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool TurnOffAllCollisionDetect {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_TurnOffAllCollisionDetect();
public: __property void set_TurnOffAllCollisionDetect(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool TurnOffAllCollisionDetect {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalDayStripeBrush Property

PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripeBrush Property

The VerticalDayStripe brush

[Visual Basic]
Public Property VerticalDayStripeBrush As Brush
[C#]
public Brush VerticalDayStripeBrush {get; set;}
[C++]
public: __property Brush get_VerticalDayStripeBrush();
public: __property void set_VerticalDayStripeBrush(
   Brush value
);
[C++/CLI]
public:
property Brush VerticalDayStripeBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalDayStripes_Days Property

PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripes_Days Property

VerticalDayStripes set to true, this property then chooses the days, sat and sun default

[Visual Basic]
Public Property VerticalDayStripes_Days As Boolean()
[C#]
public bool[] VerticalDayStripes_Days {get; set;}
[C++]
public: __property bool[]* get_VerticalDayStripes_Days();
public: __property void set_VerticalDayStripes_Days(
   bool[]* value
);
[C++/CLI]
public:
property array<bool>^ VerticalDayStripes_Days {
   array<bool>^ get();
   void set (boolarray<value>^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalDayStripesHighestResolution Property

PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesHighestResolution Property

Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;

[Visual Basic]
Public Property VerticalDayStripesHighestResolution As TimeResolution
[C#]
public TimeResolution VerticalDayStripesHighestResolution {get; set;}
[C++]
public: __property TimeResolution get_VerticalDayStripesHighestResolution();
public: __property void set_VerticalDayStripesHighestResolution(
   TimeResolution value
);
[C++/CLI]
public:
property TimeResolution VerticalDayStripesHighestResolution {
   TimeResolution get();
   void set (TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalDayStripesLowestResolution Property

PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesLowestResolution Property

Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;

[Visual Basic]
Public Property VerticalDayStripesLowestResolution As TimeResolution
[C#]
public TimeResolution VerticalDayStripesLowestResolution {get; set;}
[C++]
public: __property TimeResolution get_VerticalDayStripesLowestResolution();
public: __property void set_VerticalDayStripesLowestResolution(
   TimeResolution value
);
[C++/CLI]
public:
property TimeResolution VerticalDayStripesLowestResolution {
   TimeResolution get();
   void set (TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalDayStripesUse Property

PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesUse Property (Gantt)

Vertical stripes on certain days

[Visual Basic]
Public Property VerticalDayStripesUse As VerticalDayStripesUse
[C#]
public VerticalDayStripesUse VerticalDayStripesUse {get; set;}
[C++]
public: __property VerticalDayStripesUse get_VerticalDayStripesUse();
public: __property void set_VerticalDayStripesUse(
   VerticalDayStripesUse value
);
[C++/CLI]
public:
property VerticalDayStripesUse VerticalDayStripesUse {
   VerticalDayStripesUse get();
   void set (VerticalDayStripesUse value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%% $$Events$$

Gantt Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

Gantt Class Events

PlexityHide.GTP Namespace : Gantt Class

For a list of all members of this type, see Gantt members.

Public Events

Public Event OnCollisionDetect | Fired on detected collisions
Public Event OnConflictArea_Update | Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic
Public Event OnDrawBackground | Fired when the display has changed in such a way that user added time dependant items in the background needs update
Public Event OnDrawForeground | Fired when the display has changed in such a way that user added time dependant items in the foreground needs update
Public Event OnTimeItemExternalDrop | Triggers when d
Public Event OnTimeItemRowChange | When the this event fires you should decide if the move is ok and if so change the underlying data to reflect the move Once the underlaying data is updated the databind will discover this and the time item is removed from the old ganttrow and displayed on the new

See Also

Gantt Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCollisionDetect Event

PlexityHide.GTP Namespace > Gantt Class : OnCollisionDetect Event

Fired on detected collisions

[Visual Basic]
Public Event OnCollisionDetect() As CollisionDetectEvent
[C#]
public event CollisionDetectEvent OnCollisionDetect();
[C++]
public: __event CollisionDetectEvent* OnCollisionDetect();
[C++/CLI]
public:
event CollisionDetectEvent^ OnCollisionDetect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnConflictArea_Update Event

PlexityHide.GTP Namespace > Gantt Class : OnConflictArea_Update Event

Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic

[Visual Basic]
Public Event OnConflictArea_Update() As ConflictArea_Update
[C#]
public event ConflictArea_Update OnConflictArea_Update();
[C++]
public: __event ConflictArea_Update* OnConflictArea_Update();
[C++/CLI]
public:
event ConflictArea_Update^ OnConflictArea_Update();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnDrawBackground Event

PlexityHide.GTP Namespace > Gantt Class : OnDrawBackground Event

Fired when the display has changed in such a way that user added time dependant items in the background needs update

[Visual Basic]
Public Event OnDrawBackground() As EventHandler(Of GanttUserDrawArgs)
[C#]
public event EventHandler<GanttUserDrawArgs> OnDrawBackground();
[C++]
public: __event EventHandler<GanttUserDrawArgs>* OnDrawBackground();
[C++/CLI]
public:
event EventHandler<GanttUserDrawArgs>^ OnDrawBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnDrawForeground Event

PlexityHide.GTP Namespace > Gantt Class : OnDrawForeground Event

Fired when the display has changed in such a way that user added time dependant items in the foreground needs update

[Visual Basic]
Public Event OnDrawForeground() As EventHandler(Of GanttUserDrawArgs)
[C#]
public event EventHandler<GanttUserDrawArgs> OnDrawForeground();
[C++]
public: __event EventHandler<GanttUserDrawArgs>* OnDrawForeground();
[C++/CLI]
public:
event EventHandler<GanttUserDrawArgs>^ OnDrawForeground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnTimeItemExternalDrop Event

PlexityHide.GTP Namespace > Gantt Class : OnTimeItemExternalDrop Event

Triggers when d

[Visual Basic]
Public Event OnTimeItemExternalDrop() As EventHandler(Of ExternalDropArgs)
[C#]
public event EventHandler<ExternalDropArgs> OnTimeItemExternalDrop();
[C++]
public: __event EventHandler<ExternalDropArgs>* OnTimeItemExternalDrop();
[C++/CLI]
public:
event EventHandler<ExternalDropArgs>^ OnTimeItemExternalDrop();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnTimeItemRowChange Event

PlexityHide.GTP Namespace > Gantt Class : OnTimeItemRowChange Event

When the this event fires you should decide if the move is ok and if so change the underlying data to reflect the move Once the underlaying data is updated the databind will discover this and the time item is removed from the old ganttrow and displayed on the new

[Visual Basic]
Public Event OnTimeItemRowChange() As EventHandler(Of RowChangeArgs)
[C#]
public event EventHandler<RowChangeArgs> OnTimeItemRowChange();
[C++]
public: __event EventHandler<RowChangeArgs>* OnTimeItemRowChange();
[C++/CLI]
public:
event EventHandler<RowChangeArgs>^ OnTimeItemRowChange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

GanttRow Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

GanttRow Class

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

A GanttRow is connected to DateScaler and can hold multiple TimeItems

For a list of all members of this type, see GanttRow members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
PlexityHide.GTP.GanttRow

Syntax

[Visual Basic]
Public Class GanttRow
   Inherits ListBox
   Implements IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C#]
public class GanttRow : ListBox, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class GanttRow : public ListBox, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class GanttRow : public ListBox, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

GanttRow Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

GanttRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRow Class Members

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

GanttRow overview

Public Constructors

Public Constructor GanttRow Constructor The GanttRow constructor takes no arguments

Public Fields

Public Field static (Shared in Visual Basic) ShowStatusProperty

Public Properties

Public Property CollisionDetect | Turns the use of CollisionDetection on or off; default is on
Public Property CollisionDetect_UseConflictAreas | Turns the use of ConflictAreas on or off; default is off.
Public Property CollisionTimeItemOffset | See explanation on IncreaseRowHeightOnCollision
Public Property DateScaler | If you do use a collecting Gantt you must assign a DateScaler here
Public Property EffectiveDateScaler | The EffectiveDateScaler will give the DateScaler assigned or the one from the collecting Gantt.
Public Property FollowDateScalerPosition | If this is set, and the GanttRow is placed in a Canvas, and the GanttRow is owned by a collecting Gantt, then the Position will be taken from DateScaler; this can be very practical when using a TreeView that intends the rows Note that it is important to place the GanttRow in a Canvas so that this logig can use Canvas.SetLeft/SetTop and Width/Height to update position
Public Property GanttDateScaler | Access to the collecting Gantt's DateScaler
Public Property IncreaseRow_StartHeight | See explanation on IncreaseRowHeightOnCollision
Public Property IncreaseRowHeightOnCollision | When a collision occure and this setting is on we increase the MinHeight of the GanttRow The new height is calculated with : IncreaseRow_StartHeight + CollisionTimeItemOffset * SubColumnsFromCollisionDetect
Public Property InternalIndexOfContent | Access to the list of GanttRowItems
Public Property MoveState | Access to the currect MoveState
Public Property OwningContentControl | This is the first content control found when traversing all ancestors (may be ListBoxItem, or TreeViewItem or whatever you used for the grid part)
Public Property OwningGanttRef | If this GanttRow is owned by a collecting Gantt you will reach it here
Public Property ShowStatus |
Public Property SubColumnsFromCollisionDetect | Number of sub columns that are derived from use of collision detect

Public Methods

Public Method CurrentlyOnScreen | Information about the row screen status
Public Method CurrentRowPositionInGanttCoords | Current GanttRow position
Public Method GetGanttRowItemFromObject | If you have a Y-Axis databound object thiss will return the GanttRowItem
Public Method HandleMouseDown | Overridable for advanced use , public for technical reasons
Public Method HandleMouseMove | Overridable for advanced use, public for technical reasons
Public Method HandleMouseUp | Overridable for advanced use, public for technical reasons
Public Method IsPointInside | Returns true if the point (in ganttrow coordinates) is inside the row
Public Method MoveBackToNormalParent | Overridable for advanced use, public for technical reasons
Public Method MoveToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method OnApplyTemplate | Overridden.
Public Method UserDrawTimeItem | Overridable for advanced use, public for technical reasons

Public Events

Public Event MouseEnterGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeaveGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeftButtonDownGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeftButtonUpGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseMoveGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event OnGanttRowMinHeightChange | This event fires when the collisiondetection wants to change the calculated MinHeigt of the row. This will only happen when IncreaseRowHeightOnCollision==true. If ScheduleMode then height is really the width
Public Event OnTimeItemChange | This event fires when the user changes a TimeItem's Start or Stop properties. Check the e.MoveState argument to see if it is a move or resize op. The old values are taken from the TimeItem; e.TimeItem.Start The new values you get by applying the difference; e.TimeItem.Start.Add(e.Diff) You can limit the e.Diff, and the new value of difference will be use by the default logic executed after this event.
Public Event OnUserDrawTimeItem | This event fires when the TimeItem's size is updated and UserDraw is true.

Protected Methods

Protected Method _dateScaler_OnTimeItemPositionsOutOfDate | Overridable for advanced use
Protected Method ArrangeOverride | Overridden.
Protected Method ClearContainerForItemOverride | Overridden.
Protected Method GanttRow_Loaded | Overridable for advanced use
Protected Method GanttRow_SL_SelectionChanged | Overridable for advanced use
Protected Method GetContainerForItemOverride | Overridden.
Protected Method GetSuperParent | Overridable for advanced use
Protected Method HandleCursor | Overridable for advanced use
Protected Method IsItemItsOwnContainerOverride | Overridden.
Protected Method OnItemsChanged | Overridden.
Protected Method PrepareContainerForItemOverride | Overridden.
Protected Method UpdatePosition | Overridable for advanced use

See Also

GanttRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow Constructor

PlexityHide.GTP Namespace > GanttRow Class : GanttRow Constructor (GanttRow)

The GanttRow constructor takes no arguments

[Visual Basic]
Public Function New()
[C#]
public GanttRow();
[C++]
public: GanttRow();
[C++/CLI]
public:
GanttRow();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%% $$Methods$$

GanttRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRow Class Methods

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRow members.

Public Methods

Public Method CurrentlyOnScreen | Information about the row screen status
Public Method CurrentRowPositionInGanttCoords | Current GanttRow position
Public Method GetGanttRowItemFromObject | If you have a Y-Axis databound object thiss will return the GanttRowItem
Public Method HandleMouseDown | Overridable for advanced use , public for technical reasons
Public Method HandleMouseMove | Overridable for advanced use, public for technical reasons
Public Method HandleMouseUp | Overridable for advanced use, public for technical reasons
Public Method IsPointInside | Returns true if the point (in ganttrow coordinates) is inside the row
Public Method MoveBackToNormalParent | Overridable for advanced use, public for technical reasons
Public Method MoveToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method OnApplyTemplate | Overridden.
Public Method UserDrawTimeItem | Overridable for advanced use, public for technical reasons

Protected Methods

Protected Method _dateScaler_OnTimeItemPositionsOutOfDate | Overridable for advanced use
Protected Method ArrangeOverride | Overridden.
Protected Method ClearContainerForItemOverride | Overridden.
Protected Method GanttRow_Loaded | Overridable for advanced use
Protected Method GanttRow_SL_SelectionChanged | Overridable for advanced use
Protected Method GetContainerForItemOverride | Overridden.
Protected Method GetSuperParent | Overridable for advanced use
Protected Method HandleCursor | Overridable for advanced use
Protected Method IsItemItsOwnContainerOverride | Overridden.
Protected Method OnItemsChanged | Overridden.
Protected Method PrepareContainerForItemOverride | Overridden.
Protected Method UpdatePosition | Overridable for advanced use

See Also

GanttRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

_dateScaler_OnTimeItemPositionsOutOfDate Method

PlexityHide.GTP Namespace > GanttRow Class : _dateScaler_OnTimeItemPositionsOutOfDate Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub _dateScaler_OnTimeItemPositionsOutOfDate( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
protected virtual void _dateScaler_OnTimeItemPositionsOutOfDate(
   object sender,
   EventArgs e
);
[C++]
protected: virtual void _dateScaler_OnTimeItemPositionsOutOfDate(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
protected:
virtual void _dateScaler_OnTimeItemPositionsOutOfDate(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > GanttRow Class : ArrangeOverride Method (GanttRow)
[Visual Basic]
Overrides Protected Function ArrangeOverride( _
   ByVal availableSize As Size _
) As Size
[C#]
protected override Size ArrangeOverride(
   Size availableSize
);
[C++]
protected: Size ArrangeOverride(
   Size availableSize
) override
[C++/CLI]
protected:
Size ArrangeOverride(
   Size availableSize
) override

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
item
See Also Languages GTP.NET.SL Send comments on this topic.

ClearContainerForItemOverride Method

PlexityHide.GTP Namespace > GanttRow Class : ClearContainerForItemOverride Method (GanttRow)
[Visual Basic]
Overrides Protected Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
[C#]
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
);
[C++]
protected: void ClearContainerForItemOverride(
   DependencyObject element,
   Object* item
) override
[C++/CLI]
protected:
void ClearContainerForItemOverride(
   DependencyObject element,
   Object^ item
) override

Parameters

element
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CurrentlyOnScreen Method

PlexityHide.GTP Namespace > GanttRow Class : CurrentlyOnScreen Method

Information about the row screen status

[Visual Basic]
Public Function CurrentlyOnScreen() As RowScreenStatus
[C#]
public RowScreenStatus CurrentlyOnScreen();
[C++]
public: RowScreenStatus CurrentlyOnScreen();
[C++/CLI]
public:
RowScreenStatus CurrentlyOnScreen();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CurrentRowPositionInGanttCoords Method

PlexityHide.GTP Namespace > GanttRow Class : CurrentRowPositionInGanttCoords Method

Current GanttRow position

[Visual Basic]
Public Function CurrentRowPositionInGanttCoords() As Rect
[C#]
public Rect CurrentRowPositionInGanttCoords();
[C++]
public: Rect CurrentRowPositionInGanttCoords();
[C++/CLI]
public:
Rect CurrentRowPositionInGanttCoords();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow_Loaded Method

PlexityHide.GTP Namespace > GanttRow Class : GanttRow_Loaded Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRow_Loaded( _
   ByVal sender As Object, _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void GanttRow_Loaded(
   object sender,
   RoutedEventArgs e
);
[C++]
protected: virtual void GanttRow_Loaded(
   Object* sender,
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRow_Loaded(
   Object^ sender,
   RoutedEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow_SL_SelectionChanged Method

PlexityHide.GTP Namespace > GanttRow Class : GanttRow_SL_SelectionChanged Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRow_SL_SelectionChanged( _
   ByVal sender As Object, _
   ByVal e As SelectionChangedEventArgs _
)
[C#]
protected virtual void GanttRow_SL_SelectionChanged(
   object sender,
   SelectionChangedEventArgs e
);
[C++]
protected: virtual void GanttRow_SL_SelectionChanged(
   Object* sender,
   SelectionChangedEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRow_SL_SelectionChanged(
   Object^ sender,
   SelectionChangedEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetContainerForItemOverride Method

PlexityHide.GTP Namespace > GanttRow Class : GetContainerForItemOverride Method (GanttRow)
[Visual Basic]
Overrides Protected Function GetContainerForItemOverride() As DependencyObject
[C#]
protected override DependencyObject GetContainerForItemOverride();
[C++]
protected: DependencyObject GetContainerForItemOverride(); override
[C++/CLI]
protected:
DependencyObject GetContainerForItemOverride(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

o
See Also Languages GTP.NET.SL Send comments on this topic.

GetGanttRowItemFromObject Method

PlexityHide.GTP Namespace > GanttRow Class : GetGanttRowItemFromObject Method

If you have a Y-Axis databound object thiss will return the GanttRowItem

[Visual Basic]
Public Overridable Function GetGanttRowItemFromObject( _
   ByVal o As Object _
) As GanttRowItem
[C#]
public virtual GanttRowItem GetGanttRowItemFromObject(
   object o
);
[C++]
public: virtual GanttRowItem* GetGanttRowItemFromObject(
   Object* o
)
[C++/CLI]
public:
virtual GanttRowItem^ GetGanttRowItemFromObject(
   Object^ o
)

Parameters

o

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetSuperParent Method

PlexityHide.GTP Namespace > GanttRow Class : GetSuperParent Method

Overridable for advanced use

[Visual Basic]
Protected Function GetSuperParent() As Panel
[C#]
protected Panel GetSuperParent();
[C++]
protected: Panel GetSuperParent();
[C++/CLI]
protected:
Panel GetSuperParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
p
See Also Languages GTP.NET.SL Send comments on this topic.

HandleCursor Method

PlexityHide.GTP Namespace > GanttRow Class : HandleCursor Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub HandleCursor( _
   ByVal timeItem As TimeItem, _
   ByVal p As Point _
)
[C#]
protected virtual void HandleCursor(
   TimeItem timeItem,
   Point p
);
[C++]
protected: virtual void HandleCursor(
   TimeItem* timeItem,
   Point p
)
[C++/CLI]
protected:
virtual void HandleCursor(
   TimeItem^ timeItem,
   Point p
)

Parameters

timeItem
p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
e
See Also Languages GTP.NET.SL Send comments on this topic.

HandleMouseDown Method

PlexityHide.GTP Namespace > GanttRow Class : HandleMouseDown Method

Overridable for advanced use , public for technical reasons

[Visual Basic]
Public Overridable Sub HandleMouseDown( _
   ByVal timeItem As TimeItem, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
public virtual void HandleMouseDown(
   TimeItem timeItem,
   MouseButtonEventArgs e
);
[C++]
public: virtual void HandleMouseDown(
   TimeItem* timeItem,
   MouseButtonEventArgs e
)
[C++/CLI]
public:
virtual void HandleMouseDown(
   TimeItem^ timeItem,
   MouseButtonEventArgs e
)

Parameters

timeItem
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
e
See Also Languages GTP.NET.SL Send comments on this topic.

HandleMouseMove Method

PlexityHide.GTP Namespace > GanttRow Class : HandleMouseMove Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub HandleMouseMove( _
   ByVal timeItem As TimeItem, _
   ByVal e As MouseEventArgs _
)
[C#]
public virtual void HandleMouseMove(
   TimeItem timeItem,
   MouseEventArgs e
);
[C++]
public: virtual void HandleMouseMove(
   TimeItem* timeItem,
   MouseEventArgs e
)
[C++/CLI]
public:
virtual void HandleMouseMove(
   TimeItem^ timeItem,
   MouseEventArgs e
)

Parameters

timeItem
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
e
See Also Languages GTP.NET.SL Send comments on this topic.

HandleMouseUp Method

PlexityHide.GTP Namespace > GanttRow Class : HandleMouseUp Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub HandleMouseUp( _
   ByVal timeItem As TimeItem, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
public virtual void HandleMouseUp(
   TimeItem timeItem,
   MouseButtonEventArgs e
);
[C++]
public: virtual void HandleMouseUp(
   TimeItem* timeItem,
   MouseButtonEventArgs e
)
[C++/CLI]
public:
virtual void HandleMouseUp(
   TimeItem^ timeItem,
   MouseButtonEventArgs e
)

Parameters

timeItem
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
See Also Languages GTP.NET.SL Send comments on this topic.

IsItemItsOwnContainerOverride Method

PlexityHide.GTP Namespace > GanttRow Class : IsItemItsOwnContainerOverride Method (GanttRow)
[Visual Basic]
Overrides Protected Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
[C#]
protected override bool IsItemItsOwnContainerOverride(
   object item
);
[C++]
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
[C++/CLI]
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

p
See Also Languages GTP.NET.SL Send comments on this topic.

IsPointInside Method

PlexityHide.GTP Namespace > GanttRow Class : IsPointInside Method

Returns true if the point (in ganttrow coordinates) is inside the row

[Visual Basic]
Public Overridable Function IsPointInside( _
   ByVal p As Point _
) As Boolean
[C#]
public virtual bool IsPointInside(
   Point p
);
[C++]
public: virtual bool IsPointInside(
   Point p
)
[C++/CLI]
public:
virtual bool IsPointInside(
   Point p
)

Parameters

p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

GanttRowItem_SL
See Also Languages GTP.NET.SL Send comments on this topic.

MoveBackToNormalParent Method

PlexityHide.GTP Namespace > GanttRow Class : MoveBackToNormalParent Method (GanttRow)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub MoveBackToNormalParent( _
   ByVal GanttRowItem_SL As GanttRowItem _
)
[C#]
public virtual void MoveBackToNormalParent(
   GanttRowItem GanttRowItem_SL
);
[C++]
public: virtual void MoveBackToNormalParent(
   GanttRowItem* GanttRowItem_SL
)
[C++/CLI]
public:
virtual void MoveBackToNormalParent(
   GanttRowItem^ GanttRowItem_SL
)

Parameters

GanttRowItem_SL

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

GanttRowItem
See Also Languages GTP.NET.SL Send comments on this topic.

MoveToMoveCanvas Method

PlexityHide.GTP Namespace > GanttRow Class : MoveToMoveCanvas Method (GanttRow)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub MoveToMoveCanvas( _
   ByVal GanttRowItem As GanttRowItem _
)
[C#]
public virtual void MoveToMoveCanvas(
   GanttRowItem GanttRowItem
);
[C++]
public: virtual void MoveToMoveCanvas(
   GanttRowItem* GanttRowItem
)
[C++/CLI]
public:
virtual void MoveToMoveCanvas(
   GanttRowItem^ GanttRowItem
)

Parameters

GanttRowItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > GanttRow Class : OnApplyTemplate Method (GanttRow)
[Visual Basic]
Overrides Public Sub OnApplyTemplate()
[C#]
public override void OnApplyTemplate();
[C++]
public: void OnApplyTemplate(); override
[C++/CLI]
public:
void OnApplyTemplate(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnItemsChanged Method

PlexityHide.GTP Namespace > GanttRow Class : OnItemsChanged Method (GanttRow)
[Visual Basic]
Overrides Protected Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
[C#]
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
);
[C++]
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
) override
[C++/CLI]
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
item
See Also Languages GTP.NET.SL Send comments on this topic.

PrepareContainerForItemOverride Method

PlexityHide.GTP Namespace > GanttRow Class : PrepareContainerForItemOverride Method (GanttRow)
[Visual Basic]
Overrides Protected Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
[C#]
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
);
[C++]
protected: void PrepareContainerForItemOverride(
   DependencyObject element,
   Object* item
) override
[C++/CLI]
protected:
void PrepareContainerForItemOverride(
   DependencyObject element,
   Object^ item
) override

Parameters

element
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdatePosition Method

PlexityHide.GTP Namespace > GanttRow Class : UpdatePosition Method (GanttRow)

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub UpdatePosition()
[C#]
protected virtual void UpdatePosition();
[C++]
protected: virtual void UpdatePosition();
[C++/CLI]
protected:
virtual void UpdatePosition();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
See Also Languages GTP.NET.SL Send comments on this topic.

UserDrawTimeItem Method

PlexityHide.GTP Namespace > GanttRow Class : UserDrawTimeItem Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub UserDrawTimeItem( _
   ByVal timeItem As TimeItem _
)
[C#]
public virtual void UserDrawTimeItem(
   TimeItem timeItem
);
[C++]
public: virtual void UserDrawTimeItem(
   TimeItem* timeItem
)
[C++/CLI]
public:
virtual void UserDrawTimeItem(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%% $$Properties$$

GanttRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRow Class Properties

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRow members.

Public Properties

Public Property CollisionDetect | Turns the use of CollisionDetection on or off; default is on
Public Property CollisionDetect_UseConflictAreas | Turns the use of ConflictAreas on or off; default is off.
Public Property CollisionTimeItemOffset | See explanation on IncreaseRowHeightOnCollision
Public Property DateScaler | If you do use a collecting Gantt you must assign a DateScaler here
Public Property EffectiveDateScaler | The EffectiveDateScaler will give the DateScaler assigned or the one from the collecting Gantt.
Public Property FollowDateScalerPosition | If this is set, and the GanttRow is placed in a Canvas, and the GanttRow is owned by a collecting Gantt, then the Position will be taken from DateScaler; this can be very practical when using a TreeView that intends the rows Note that it is important to place the GanttRow in a Canvas so that this logig can use Canvas.SetLeft/SetTop and Width/Height to update position
Public Property GanttDateScaler | Access to the collecting Gantt's DateScaler
Public Property IncreaseRow_StartHeight | See explanation on IncreaseRowHeightOnCollision
Public Property IncreaseRowHeightOnCollision | When a collision occure and this setting is on we increase the MinHeight of the GanttRow The new height is calculated with : IncreaseRow_StartHeight + CollisionTimeItemOffset * SubColumnsFromCollisionDetect
Public Property InternalIndexOfContent | Access to the list of GanttRowItems
Public Property MoveState | Access to the currect MoveState
Public Property OwningContentControl | This is the first content control found when traversing all ancestors (may be ListBoxItem, or TreeViewItem or whatever you used for the grid part)
Public Property OwningGanttRef | If this GanttRow is owned by a collecting Gantt you will reach it here
Public Property ShowStatus |
Public Property SubColumnsFromCollisionDetect | Number of sub columns that are derived from use of collision detect

See Also

GanttRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionDetect Property

PlexityHide.GTP Namespace > GanttRow Class : CollisionDetect Property

Turns the use of CollisionDetection on or off; default is on

[Visual Basic]
Public Property CollisionDetect As Boolean
[C#]
public bool CollisionDetect {get; set;}
[C++]
public: __property bool get_CollisionDetect();
public: __property void set_CollisionDetect(
   bool value
);
[C++/CLI]
public:
property bool CollisionDetect {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionDetect_UseConflictAreas Property

PlexityHide.GTP Namespace > GanttRow Class : CollisionDetect_UseConflictAreas Property

Turns the use of ConflictAreas on or off; default is off.

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property CollisionDetect_UseConflictAreas As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool CollisionDetect_UseConflictAreas {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_CollisionDetect_UseConflictAreas();
public: __property void set_CollisionDetect_UseConflictAreas(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool CollisionDetect_UseConflictAreas {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionTimeItemOffset Property

PlexityHide.GTP Namespace > GanttRow Class : CollisionTimeItemOffset Property

See explanation on IncreaseRowHeightOnCollision

[Visual Basic]
Public Property CollisionTimeItemOffset As Double
[C#]
public double CollisionTimeItemOffset {get; set;}
[C++]
public: __property double get_CollisionTimeItemOffset();
public: __property void set_CollisionTimeItemOffset(
   double value
);
[C++/CLI]
public:
property double CollisionTimeItemOffset {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DateScaler Property

PlexityHide.GTP Namespace > GanttRow Class : DateScaler Property (GanttRow)

If you do use a collecting Gantt you must assign a DateScaler here

[Visual Basic]
Public Property DateScaler As DateScaler
[C#]
public DateScaler DateScaler {get; set;}
[C++]
public: __property DateScaler* get_DateScaler();
public: __property void set_DateScaler(
   DateScaler* value
);
[C++/CLI]
public:
property DateScaler^ DateScaler {
   DateScaler^ get();
   void set (DateScaler^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

EffectiveDateScaler Property

PlexityHide.GTP Namespace > GanttRow Class : EffectiveDateScaler Property

The EffectiveDateScaler will give the DateScaler assigned or the one from the collecting Gantt.

[Visual Basic]
Public ReadOnly Property EffectiveDateScaler As DateScaler
[C#]
public DateScaler EffectiveDateScaler {get;}
[C++]
public: __property DateScaler* get_EffectiveDateScaler();
[C++/CLI]
public:
property DateScaler^ EffectiveDateScaler {
   DateScaler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FollowDateScalerPosition Property

PlexityHide.GTP Namespace > GanttRow Class : FollowDateScalerPosition Property

If this is set, and the GanttRow is placed in a Canvas, and the GanttRow is owned by a collecting Gantt, then the Position will be taken from DateScaler; this can be very practical when using a TreeView that intends the rows Note that it is important to place the GanttRow in a Canvas so that this logig can use Canvas.SetLeft/SetTop and Width/Height to update position

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property FollowDateScalerPosition As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool FollowDateScalerPosition {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_FollowDateScalerPosition();
public: __property void set_FollowDateScalerPosition(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool FollowDateScalerPosition {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttDateScaler Property

PlexityHide.GTP Namespace > GanttRow Class : GanttDateScaler Property

Access to the collecting Gantt's DateScaler

[Visual Basic]
Public ReadOnly Property GanttDateScaler As DateScaler
[C#]
public DateScaler GanttDateScaler {get;}
[C++]
public: __property DateScaler* get_GanttDateScaler();
[C++/CLI]
public:
property DateScaler^ GanttDateScaler {
   DateScaler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IncreaseRow_StartHeight Property

PlexityHide.GTP Namespace > GanttRow Class : IncreaseRow_StartHeight Property

See explanation on IncreaseRowHeightOnCollision

[Visual Basic]
Public Property IncreaseRow_StartHeight As Double
[C#]
public double IncreaseRow_StartHeight {get; set;}
[C++]
public: __property double get_IncreaseRow_StartHeight();
public: __property void set_IncreaseRow_StartHeight(
   double value
);
[C++/CLI]
public:
property double IncreaseRow_StartHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IncreaseRowHeightOnCollision Property

PlexityHide.GTP Namespace > GanttRow Class : IncreaseRowHeightOnCollision Property

When a collision occure and this setting is on we increase the MinHeight of the GanttRow The new height is calculated with : IncreaseRow_StartHeight + CollisionTimeItemOffset * SubColumnsFromCollisionDetect

[Visual Basic]
Public Property IncreaseRowHeightOnCollision As Boolean
[C#]
public bool IncreaseRowHeightOnCollision {get; set;}
[C++]
public: __property bool get_IncreaseRowHeightOnCollision();
public: __property void set_IncreaseRowHeightOnCollision(
   bool value
);
[C++/CLI]
public:
property bool IncreaseRowHeightOnCollision {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InternalIndexOfContent Property

PlexityHide.GTP Namespace > GanttRow Class : InternalIndexOfContent Property

Access to the list of GanttRowItems

[Visual Basic]
Public Property InternalIndexOfContent As ObservableCollection(Of GanttRowItem)
[C#]
public ObservableCollection<GanttRowItem> InternalIndexOfContent {get; set;}
[C++]
public: __property ObservableCollection<GanttRowItem> get_InternalIndexOfContent();
public: __property void set_InternalIndexOfContent(
   ObservableCollection<GanttRowItem> value
);
[C++/CLI]
public:
property ObservableCollection<GanttRowItem> InternalIndexOfContent {
   ObservableCollection<GanttRowItem> get();
   void set (ObservableCollection<GanttRowItem> value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MoveState Property

PlexityHide.GTP Namespace > GanttRow Class : MoveState Property (GanttRow)

Access to the currect MoveState

[Visual Basic]
Public ReadOnly Property MoveState As MoveState
[C#]
public MoveState MoveState {get;}
[C++]
public: __property MoveState get_MoveState();
[C++/CLI]
public:
property MoveState MoveState {
   MoveState get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OwningContentControl Property

PlexityHide.GTP Namespace > GanttRow Class : OwningContentControl Property

This is the first content control found when traversing all ancestors (may be ListBoxItem, or TreeViewItem or whatever you used for the grid part)

[Visual Basic]
Public ReadOnly Property OwningContentControl As ContentControl
[C#]
public ContentControl OwningContentControl {get;}
[C++]
public: __property ContentControl get_OwningContentControl();
[C++/CLI]
public:
property ContentControl OwningContentControl {
   ContentControl get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OwningGanttRef Property

PlexityHide.GTP Namespace > GanttRow Class : OwningGanttRef Property (GanttRow)

If this GanttRow is owned by a collecting Gantt you will reach it here

[Visual Basic]
Public ReadOnly Property OwningGanttRef As Gantt
[C#]
public Gantt OwningGanttRef {get;}
[C++]
public: __property Gantt* get_OwningGanttRef();
[C++/CLI]
public:
property Gantt^ OwningGanttRef {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ShowStatus Property

PlexityHide.GTP Namespace > GanttRow Class : ShowStatus Property
[Visual Basic]
Public Property ShowStatus As Boolean
[C#]
public bool ShowStatus {get; set;}
[C++]
public: __property bool get_ShowStatus();
public: __property void set_ShowStatus(
   bool value
);
[C++/CLI]
public:
property bool ShowStatus {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SubColumnsFromCollisionDetect Property

PlexityHide.GTP Namespace > GanttRow Class : SubColumnsFromCollisionDetect Property

Number of sub columns that are derived from use of collision detect

[Visual Basic]
Public ReadOnly Property SubColumnsFromCollisionDetect As Integer
[C#]
public int SubColumnsFromCollisionDetect {get;}
[C++]
public: __property int get_SubColumnsFromCollisionDetect();
[C++/CLI]
public:
property int SubColumnsFromCollisionDetect {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%% $$Fields$$

GanttRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRow Class Fields

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRow members.

Public Fields

Public Field static (Shared in Visual Basic) ShowStatusProperty

See Also

GanttRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ShowStatusProperty Field

PlexityHide.GTP Namespace > GanttRow Class : ShowStatusProperty Field
[Visual Basic]
Public Shared ShowStatusProperty As DependencyProperty
[C#]
public static DependencyProperty ShowStatusProperty
[C++]
public: static DependencyProperty ShowStatusProperty
[C++/CLI]
public:
static DependencyProperty ShowStatusProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%% $$Events$$

GanttRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRow Class Events

PlexityHide.GTP Namespace : GanttRow Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRow members.

Public Events

Public Event MouseEnterGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeaveGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeftButtonDownGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseLeftButtonUpGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event MouseMoveGanttRowBackground | These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations
Public Event OnGanttRowMinHeightChange | This event fires when the collisiondetection wants to change the calculated MinHeigt of the row. This will only happen when IncreaseRowHeightOnCollision==true. If ScheduleMode then height is really the width
Public Event OnTimeItemChange | This event fires when the user changes a TimeItem's Start or Stop properties. Check the e.MoveState argument to see if it is a move or resize op. The old values are taken from the TimeItem; e.TimeItem.Start The new values you get by applying the difference; e.TimeItem.Start.Add(e.Diff) You can limit the e.Diff, and the new value of difference will be use by the default logic executed after this event.
Public Event OnUserDrawTimeItem | This event fires when the TimeItem's size is updated and UserDraw is true.

See Also

GanttRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnterGanttRowBackground Event

PlexityHide.GTP Namespace > GanttRow Class : MouseEnterGanttRowBackground Event

These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations

[Visual Basic]
Public Event MouseEnterGanttRowBackground() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnterGanttRowBackground();
[C++]
public: __event MouseEventHandler MouseEnterGanttRowBackground();
[C++/CLI]
public:
event MouseEventHandler MouseEnterGanttRowBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeaveGanttRowBackground Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeaveGanttRowBackground Event

These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations

[Visual Basic]
Public Event MouseLeaveGanttRowBackground() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeaveGanttRowBackground();
[C++]
public: __event MouseEventHandler MouseLeaveGanttRowBackground();
[C++/CLI]
public:
event MouseEventHandler MouseLeaveGanttRowBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDownGanttRowBackground Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeftButtonDownGanttRowBackground Event

These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations

[Visual Basic]
Public Event MouseLeftButtonDownGanttRowBackground() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDownGanttRowBackground();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDownGanttRowBackground();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDownGanttRowBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUpGanttRowBackground Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeftButtonUpGanttRowBackground Event

These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations

[Visual Basic]
Public Event MouseLeftButtonUpGanttRowBackground() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUpGanttRowBackground();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUpGanttRowBackground();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUpGanttRowBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMoveGanttRowBackground Event

PlexityHide.GTP Namespace > GanttRow Class : MouseMoveGanttRowBackground Event

These events are Channeled from the GanttRowPanel; Ganttrow background mouse operations

[Visual Basic]
Public Event MouseMoveGanttRowBackground() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMoveGanttRowBackground();
[C++]
public: __event MouseEventHandler MouseMoveGanttRowBackground();
[C++/CLI]
public:
event MouseEventHandler MouseMoveGanttRowBackground();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnGanttRowMinHeightChange Event

PlexityHide.GTP Namespace > GanttRow Class : OnGanttRowMinHeightChange Event

This event fires when the collisiondetection wants to change the calculated MinHeigt of the row. This will only happen when IncreaseRowHeightOnCollision==true. If ScheduleMode then height is really the width

[Visual Basic]
Public Event OnGanttRowMinHeightChange() As EventHandler(Of OnGanttRowMinHeightChangeArgs)
[C#]
public event EventHandler<OnGanttRowMinHeightChangeArgs> OnGanttRowMinHeightChange();
[C++]
public: __event EventHandler<OnGanttRowMinHeightChangeArgs>* OnGanttRowMinHeightChange();
[C++/CLI]
public:
event EventHandler<OnGanttRowMinHeightChangeArgs>^ OnGanttRowMinHeightChange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnTimeItemChange Event

PlexityHide.GTP Namespace > GanttRow Class : OnTimeItemChange Event

This event fires when the user changes a TimeItem's Start or Stop properties. Check the e.MoveState argument to see if it is a move or resize op. The old values are taken from the TimeItem; e.TimeItem.Start The new values you get by applying the difference; e.TimeItem.Start.Add(e.Diff) You can limit the e.Diff, and the new value of difference will be use by the default logic executed after this event.

[Visual Basic]
Public Event OnTimeItemChange() As EventHandler(Of OnTimeItemChangeArgs)
[C#]
public event EventHandler<OnTimeItemChangeArgs> OnTimeItemChange();
[C++]
public: __event EventHandler<OnTimeItemChangeArgs>* OnTimeItemChange();
[C++/CLI]
public:
event EventHandler<OnTimeItemChangeArgs>^ OnTimeItemChange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnUserDrawTimeItem Event

PlexityHide.GTP Namespace > GanttRow Class : OnUserDrawTimeItem Event

This event fires when the TimeItem's size is updated and UserDraw is true.

[Visual Basic]
Public Event OnUserDrawTimeItem() As EventHandler(Of NotifyTimeItem)
[C#]
public event EventHandler<NotifyTimeItem> OnUserDrawTimeItem();
[C++]
public: __event EventHandler<NotifyTimeItem>* OnUserDrawTimeItem();
[C++/CLI]
public:
event EventHandler<NotifyTimeItem>^ OnUserDrawTimeItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRowCanvas Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas Class

PlexityHide.GTP Namespace : GanttRowCanvas Class

This is the canvas used by the GanttRow, it is only public for technical reasons; dont use

For a list of all members of this type, see GanttRowCanvas members.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
PlexityHide.GTP.GanttRowCanvas

Syntax

[Visual Basic]
Public Class GanttRowCanvas
   Inherits Canvas
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class GanttRowCanvas : Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class GanttRowCanvas : public Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class GanttRowCanvas : public Canvas, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

GanttRowCanvas Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

GanttRowCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowCanvas Class Members

PlexityHide.GTP Namespace : GanttRowCanvas Class

GanttRowCanvas overview

Public Constructors

Public Constructor GanttRowCanvas Constructor This is the canvas used by the GanttRow, it is only public for technical reasons; dont use

Protected Methods

Protected Method GanttRowCanvas_MouseEnter | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeave | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeftButtonDown | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeftButtonUp | Overridable for advanced use
Protected Method GanttRowCanvas_MouseMove | Overridable for advanced use

See Also

GanttRowCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas Constructor

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas Constructor (GanttRowCanvas)

This is the canvas used by the GanttRow, it is only public for technical reasons; dont use

[Visual Basic]
Public Function New()
[C#]
public GanttRowCanvas();
[C++]
public: GanttRowCanvas();
[C++/CLI]
public:
GanttRowCanvas();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%% $$Methods$$

GanttRowCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowCanvas Class Methods

PlexityHide.GTP Namespace : GanttRowCanvas Class

For a list of all members of this type, see GanttRowCanvas members.

Protected Methods

Protected Method GanttRowCanvas_MouseEnter | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeave | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeftButtonDown | Overridable for advanced use
Protected Method GanttRowCanvas_MouseLeftButtonUp | Overridable for advanced use
Protected Method GanttRowCanvas_MouseMove | Overridable for advanced use

See Also

GanttRowCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas_MouseEnter Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas_MouseEnter Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRowCanvas_MouseEnter( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void GanttRowCanvas_MouseEnter(
   object sender,
   MouseEventArgs e
);
[C++]
protected: virtual void GanttRowCanvas_MouseEnter(
   Object* sender,
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRowCanvas_MouseEnter(
   Object^ sender,
   MouseEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas_MouseLeave Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas_MouseLeave Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRowCanvas_MouseLeave( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void GanttRowCanvas_MouseLeave(
   object sender,
   MouseEventArgs e
);
[C++]
protected: virtual void GanttRowCanvas_MouseLeave(
   Object* sender,
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRowCanvas_MouseLeave(
   Object^ sender,
   MouseEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas_MouseLeftButtonDown Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas_MouseLeftButtonDown Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRowCanvas_MouseLeftButtonDown( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void GanttRowCanvas_MouseLeftButtonDown(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void GanttRowCanvas_MouseLeftButtonDown(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRowCanvas_MouseLeftButtonDown(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas_MouseLeftButtonUp Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas_MouseLeftButtonUp Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRowCanvas_MouseLeftButtonUp( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void GanttRowCanvas_MouseLeftButtonUp(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void GanttRowCanvas_MouseLeftButtonUp(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRowCanvas_MouseLeftButtonUp(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowCanvas_MouseMove Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GanttRowCanvas_MouseMove Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub GanttRowCanvas_MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void GanttRowCanvas_MouseMove(
   object sender,
   MouseEventArgs e
);
[C++]
protected: virtual void GanttRowCanvas_MouseMove(
   Object* sender,
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void GanttRowCanvas_MouseMove(
   Object^ sender,
   MouseEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowItem Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

GanttRowItem Class

PlexityHide.GTP Namespace : GanttRowItem Class (PlexityHide.GTP)

This is the created item for each object in the datasource list. The datatemplate is required to define a TimeItem so each GanttRowItem will also have one TimeItem. The GanttRow inherits from ListView, the TimeItem is the content you provide in a DataTemplate, The GanttRowItem is The corresponding ListViewItem that hold selection etc.

For a list of all members of this type, see GanttRowItem members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.ListBoxItem
PlexityHide.GTP.GanttRowItem

Syntax

[Visual Basic]
Public Class GanttRowItem
   Inherits ListBoxItem
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class GanttRowItem : ListBoxItem, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class GanttRowItem : public ListBoxItem, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class GanttRowItem : public ListBoxItem, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

GanttRowItem Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

GanttRowItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowItem Class Members

PlexityHide.GTP Namespace : GanttRowItem Class (PlexityHide.GTP)

GanttRowItem overview

Public Properties

Public Property GanttRow | The owning GanttRow
Public Property Item | The data that this GanttRowItem represents. This is your business data in the bind and will be the same as DataContext.
Public Property TimeItem | The TimeItem object associated with this GanttRowItem

Public Methods

Public Method CleanForFree | Overridable for advanced use, public for technical reasons
Public Method Init | Overridable for advanced use, public for technical reasons
Public Method MoveBackToNormalParent | Overridable for advanced use, public for technical reasons
Public Method MoveToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method OnApplyTemplate | Overridden.
Public Method SetTimeItem | Overridable for advanced use, public for technical reasons

Public Events

Public Event PropertyChanged INotifyPropertyChanged impl. for binding

Protected Methods

Protected Method ArrangeOverride | Overridden.
Protected Method MeasureOverride | Overridden.

See Also

GanttRowItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

GanttRowItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowItem Class Methods

PlexityHide.GTP Namespace : GanttRowItem Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRowItem members.

Public Methods

Public Method CleanForFree | Overridable for advanced use, public for technical reasons
Public Method Init | Overridable for advanced use, public for technical reasons
Public Method MoveBackToNormalParent | Overridable for advanced use, public for technical reasons
Public Method MoveToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method OnApplyTemplate | Overridden.
Public Method SetTimeItem | Overridable for advanced use, public for technical reasons

Protected Methods

Protected Method ArrangeOverride | Overridden.
Protected Method MeasureOverride | Overridden.

See Also

GanttRowItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeBounds
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > GanttRowItem Class : ArrangeOverride Method (GanttRowItem)
[Visual Basic]
Overrides Protected Function ArrangeOverride( _
   ByVal arrangeBounds As Size _
) As Size
[C#]
protected override Size ArrangeOverride(
   Size arrangeBounds
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeBounds
) override
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeBounds
) override

Parameters

arrangeBounds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CleanForFree Method

PlexityHide.GTP Namespace > GanttRowItem Class : CleanForFree Method (GanttRowItem)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub CleanForFree()
[C#]
public virtual void CleanForFree();
[C++]
public: virtual void CleanForFree();
[C++/CLI]
public:
virtual void CleanForFree();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

owner
item
See Also Languages GTP.NET.SL Send comments on this topic.

Init Method

PlexityHide.GTP Namespace > GanttRowItem Class : Init Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub Init( _
   ByVal owner As GanttRow, _
   ByVal item As Object _
)
[C#]
public virtual void Init(
   GanttRow owner,
   object item
);
[C++]
public: virtual void Init(
   GanttRow* owner,
   Object* item
)
[C++/CLI]
public:
virtual void Init(
   GanttRow^ owner,
   Object^ item
)

Parameters

owner
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > GanttRowItem Class : MeasureOverride Method (GanttRowItem)
[Visual Basic]
Overrides Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected override Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
) override
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
) override

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MoveBackToNormalParent Method

PlexityHide.GTP Namespace > GanttRowItem Class : MoveBackToNormalParent Method (GanttRowItem)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub MoveBackToNormalParent()
[C#]
public virtual void MoveBackToNormalParent();
[C++]
public: virtual void MoveBackToNormalParent();
[C++/CLI]
public:
virtual void MoveBackToNormalParent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MoveToMoveCanvas Method

PlexityHide.GTP Namespace > GanttRowItem Class : MoveToMoveCanvas Method (GanttRowItem)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub MoveToMoveCanvas()
[C#]
public virtual void MoveToMoveCanvas();
[C++]
public: virtual void MoveToMoveCanvas();
[C++/CLI]
public:
virtual void MoveToMoveCanvas();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnApplyTemplate Method (GanttRowItem)
[Visual Basic]
Overrides Public Sub OnApplyTemplate()
[C#]
public override void OnApplyTemplate();
[C++]
public: void OnApplyTemplate(); override
[C++/CLI]
public:
void OnApplyTemplate(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

timeItem
See Also Languages GTP.NET.SL Send comments on this topic.

SetTimeItem Method

PlexityHide.GTP Namespace > GanttRowItem Class : SetTimeItem Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub SetTimeItem( _
   ByVal timeItem As TimeItem _
)
[C#]
public virtual void SetTimeItem(
   TimeItem timeItem
);
[C++]
public: virtual void SetTimeItem(
   TimeItem* timeItem
)
[C++/CLI]
public:
virtual void SetTimeItem(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%% $$Properties$$

GanttRowItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowItem Class Properties

PlexityHide.GTP Namespace : GanttRowItem Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRowItem members.

Public Properties

Public Property GanttRow | The owning GanttRow
Public Property Item | The data that this GanttRowItem represents. This is your business data in the bind and will be the same as DataContext.
Public Property TimeItem | The TimeItem object associated with this GanttRowItem

See Also

GanttRowItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow Property

PlexityHide.GTP Namespace > GanttRowItem Class : GanttRow Property (GanttRowItem)

The owning GanttRow

[Visual Basic]
Public ReadOnly Property GanttRow As GanttRow
[C#]
public GanttRow GanttRow {get;}
[C++]
public: __property GanttRow* get_GanttRow();
[C++/CLI]
public:
property GanttRow^ GanttRow {
   GanttRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Item Property

PlexityHide.GTP Namespace > GanttRowItem Class : Item Property

The data that this GanttRowItem represents. This is your business data in the bind and will be the same as DataContext.

[Visual Basic]
Public ReadOnly Property Item As Object
[C#]
public object Item {get;}
[C++]
public: __property Object* get_Item();
[C++/CLI]
public:
property Object^ Item {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Property

PlexityHide.GTP Namespace > GanttRowItem Class : TimeItem Property (GanttRowItem)

The TimeItem object associated with this GanttRowItem

[Visual Basic]
Public Property TimeItem As TimeItem
[C#]
public TimeItem TimeItem {get; set;}
[C++]
public: __property TimeItem* get_TimeItem();
public: __property void set_TimeItem(
   TimeItem* value
);
[C++/CLI]
public:
property TimeItem^ TimeItem {
   TimeItem^ get();
   void set (TimeItem^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%% $$Events$$

GanttRowItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowItem Class Events

PlexityHide.GTP Namespace : GanttRowItem Class (PlexityHide.GTP)

For a list of all members of this type, see GanttRowItem members.

Public Events

Public Event PropertyChanged INotifyPropertyChanged impl. for binding

See Also

GanttRowItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

PropertyChanged Event

PlexityHide.GTP Namespace > GanttRowItem Class : PropertyChanged Event

INotifyPropertyChanged impl. for binding

[Visual Basic]
Public Event PropertyChanged() As PropertyChangedEventHandler
[C#]
public event PropertyChangedEventHandler PropertyChanged();
[C++]
public: __event PropertyChangedEventHandler PropertyChanged();
[C++/CLI]
public:
event PropertyChangedEventHandler PropertyChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttUserDrawArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

GanttUserDrawArgs Class

PlexityHide.GTP Namespace : GanttUserDrawArgs Class

The OnDrawBackground and Foreground use these arguments

For a list of all members of this type, see GanttUserDrawArgs members.

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.GanttUserDrawArgs

Syntax

[Visual Basic]
Public Class GanttUserDrawArgs
   Inherits EventArgs
[C#]
public class GanttUserDrawArgs : EventArgs
[C++]
public __gc class GanttUserDrawArgs : public EventArgs
[C++/CLI]
public ref class GanttUserDrawArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

GanttUserDrawArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

GanttUserDrawArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttUserDrawArgs Class Members

PlexityHide.GTP Namespace : GanttUserDrawArgs Class

GanttUserDrawArgs overview

Public Constructors

Public Constructor GanttUserDrawArgs Constructor

Public Fields

Public Field Canvas This is the canvas that will hold your drawn objects. You may call clear before adding your stuff.

See Also

GanttUserDrawArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttUserDrawArgs Class | GanttUserDrawArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttUserDrawArgs Constructor

PlexityHide.GTP Namespace > GanttUserDrawArgs Class : GanttUserDrawArgs Constructor (GanttUserDrawArgs)
[Visual Basic]
Public Function New()
[C#]
public GanttUserDrawArgs();
[C++]
public: GanttUserDrawArgs();
[C++/CLI]
public:
GanttUserDrawArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttUserDrawArgs Class | GanttUserDrawArgs Members


%%PageItemTitle%% $$Fields$$

GanttUserDrawArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttUserDrawArgs Class Fields

PlexityHide.GTP Namespace : GanttUserDrawArgs Class

For a list of all members of this type, see GanttUserDrawArgs members.

Public Fields

Public Field Canvas This is the canvas that will hold your drawn objects. You may call clear before adding your stuff.

See Also

GanttUserDrawArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttUserDrawArgs Class | GanttUserDrawArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Canvas Field

PlexityHide.GTP Namespace > GanttUserDrawArgs Class : Canvas Field

This is the canvas that will hold your drawn objects. You may call clear before adding your stuff.

[Visual Basic]
Public Canvas As Canvas
[C#]
public Canvas Canvas
[C++]
public: Canvas Canvas
[C++/CLI]
public:
Canvas Canvas

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttUserDrawArgs Class | GanttUserDrawArgs Members


%%PageItemTitle%%

LinkUserDrawEventArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

LinkUserDrawEventArgs Class

PlexityHide.GTP Namespace : LinkUserDrawEventArgs Class

The arguments given in the OnUserDraw event of the TimeItemLink

For a list of all members of this type, see LinkUserDrawEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.LinkUserDrawEventArgs

Syntax

[Visual Basic]
Public Class LinkUserDrawEventArgs
   Inherits EventArgs
[C#]
public class LinkUserDrawEventArgs : EventArgs
[C++]
public __gc class LinkUserDrawEventArgs : public EventArgs
[C++/CLI]
public ref class LinkUserDrawEventArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

LinkUserDrawEventArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

LinkUserDrawEventArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

LinkUserDrawEventArgs Class Members

PlexityHide.GTP Namespace : LinkUserDrawEventArgs Class

LinkUserDrawEventArgs overview

Public Constructors

Public Constructor LinkUserDrawEventArgs Constructor

Public Fields

Public Field ArrowDir | This int is +1 when the arrow points right or down and -1 when it points left or up (check Gantt.ScheduleMode to decide if vertical or horizontal)
Public Field ContinueStandardDraw | Set this to false to completly take over the link drawing
Public Field Points | The points that will be used by the standard drawing to set up the link You can tune this to change of the default drawing behaves
Public Field TimeItemLink | The time item link to draw

See Also

LinkUserDrawEventArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LinkUserDrawEventArgs Constructor

PlexityHide.GTP Namespace > LinkUserDrawEventArgs Class : LinkUserDrawEventArgs Constructor (LinkUserDrawEventArgs)
[Visual Basic]
Public Function New()
[C#]
public LinkUserDrawEventArgs();
[C++]
public: LinkUserDrawEventArgs();
[C++/CLI]
public:
LinkUserDrawEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members


%%PageItemTitle%% $$Fields$$

LinkUserDrawEventArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

LinkUserDrawEventArgs Class Fields

PlexityHide.GTP Namespace : LinkUserDrawEventArgs Class

For a list of all members of this type, see LinkUserDrawEventArgs members.

Public Fields

Public Field ArrowDir | This int is +1 when the arrow points right or down and -1 when it points left or up (check Gantt.ScheduleMode to decide if vertical or horizontal)
Public Field ContinueStandardDraw | Set this to false to completly take over the link drawing
Public Field Points | The points that will be used by the standard drawing to set up the link You can tune this to change of the default drawing behaves
Public Field TimeItemLink | The time item link to draw

See Also

LinkUserDrawEventArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ArrowDir Field

PlexityHide.GTP Namespace > LinkUserDrawEventArgs Class : ArrowDir Field

This int is +1 when the arrow points right or down and -1 when it points left or up (check Gantt.ScheduleMode to decide if vertical or horizontal)

[Visual Basic]
Public ArrowDir As Integer
[C#]
public int ArrowDir
[C++]
public: int ArrowDir
[C++/CLI]
public:
int ArrowDir

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members


%%PageItemTitle%%

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ContinueStandardDraw Field

PlexityHide.GTP Namespace > LinkUserDrawEventArgs Class : ContinueStandardDraw Field

Set this to false to completly take over the link drawing

[Visual Basic]
Public ContinueStandardDraw As Boolean
[C#]
public bool ContinueStandardDraw
[C++]
public: bool ContinueStandardDraw
[C++/CLI]
public:
bool ContinueStandardDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members


%%PageItemTitle%%

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Points Field

PlexityHide.GTP Namespace > LinkUserDrawEventArgs Class : Points Field

The points that will be used by the standard drawing to set up the link You can tune this to change of the default drawing behaves

[Visual Basic]
Public Points As Point()
[C#]
public Point[] Points
[C++]
public: Point[]* Points
[C++/CLI]
public:
array<Point>^ Points

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members


%%PageItemTitle%%

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLink Field

PlexityHide.GTP Namespace > LinkUserDrawEventArgs Class : TimeItemLink Field (LinkUserDrawEventArgs)

The time item link to draw

[Visual Basic]
Public TimeItemLink As TimeItemLink
[C#]
public TimeItemLink TimeItemLink
[C++]
public: TimeItemLink* TimeItemLink
[C++/CLI]
public:
TimeItemLink^ TimeItemLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

LinkUserDrawEventArgs Class | LinkUserDrawEventArgs Members


%%PageItemTitle%%

MultiColumnCoordinator Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Class

PlexityHide.GTP Namespace : MultiColumnCoordinator Class (PlexityHide.GTP)

When having a treeview with multiple columns you want some way to syncronize column resizing for all TreeView DataTemplates The MultiColumnCoordinator helps you with this

For a list of all members of this type, see MultiColumnCoordinator members.

Inheritance Hierarchy

System.Object
PlexityHide.GTP.MultiColumnCoordinator

Syntax

[Visual Basic]
Public Class MultiColumnCoordinator
[C#]
public class MultiColumnCoordinator
[C++]
public __gc class MultiColumnCoordinator
[C++/CLI]
public ref class MultiColumnCoordinator

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

MultiColumnCoordinator Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

MultiColumnCoordinator Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Class Members

PlexityHide.GTP Namespace : MultiColumnCoordinator Class (PlexityHide.GTP)

MultiColumnCoordinator overview

Public Constructors

Public Constructor MultiColumnCoordinator Constructor

Public Properties

Public Property MaxWidth Set this width and the Clipping will be set on all the seen TreeViewMultiColumnRow to this value

Public Methods

Public Method UpdateSize Call this with you new column sizes and all the seen TreeViewMultiColumnRow will be updated Like this: private void datagrid1_LayoutUpdated(object sender, EventArgs e) { MultiColumnCoordinator mcc = Resources["MCC"] as MultiColumnCoordinator; if (mcc != null) { double[] widths = new double[datagrid1.Columns.Count]; for (int i = 0; i < datagrid1.Columns.Count; i++) { widths[i] = datagrid1.Columns[i].Width.Value; } mcc.MaxWidth = gantt10.ColumnDefinitions[0].ActualWidth-10; mcc.UpdateSize(widths); } }

See Also

MultiColumnCoordinator Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

MultiColumnCoordinator Class | MultiColumnCoordinator Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Constructor

PlexityHide.GTP Namespace > MultiColumnCoordinator Class : MultiColumnCoordinator Constructor (MultiColumnCoordinator)
[Visual Basic]
Public Function New()
[C#]
public MultiColumnCoordinator();
[C++]
public: MultiColumnCoordinator();
[C++/CLI]
public:
MultiColumnCoordinator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MultiColumnCoordinator Class | MultiColumnCoordinator Members


%%PageItemTitle%% $$Methods$$

MultiColumnCoordinator Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Class Methods

PlexityHide.GTP Namespace : MultiColumnCoordinator Class (PlexityHide.GTP)

For a list of all members of this type, see MultiColumnCoordinator members.

Public Methods

Public Method UpdateSize Call this with you new column sizes and all the seen TreeViewMultiColumnRow will be updated Like this: private void datagrid1_LayoutUpdated(object sender, EventArgs e) { MultiColumnCoordinator mcc = Resources["MCC"] as MultiColumnCoordinator; if (mcc != null) { double[] widths = new double[datagrid1.Columns.Count]; for (int i = 0; i < datagrid1.Columns.Count; i++) { widths[i] = datagrid1.Columns[i].Width.Value; } mcc.MaxWidth = gantt10.ColumnDefinitions[0].ActualWidth-10; mcc.UpdateSize(widths); } }

See Also

MultiColumnCoordinator Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

MultiColumnCoordinator Class | MultiColumnCoordinator Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

columnwidths
See Also Languages GTP.NET.SL Send comments on this topic.

UpdateSize Method

PlexityHide.GTP Namespace > MultiColumnCoordinator Class : UpdateSize Method

Call this with you new column sizes and all the seen TreeViewMultiColumnRow will be updated
Like this:

 private void datagrid1_LayoutUpdated(object sender, EventArgs e)
 {

   MultiColumnCoordinator mcc = Resources["MCC"] as MultiColumnCoordinator;
   if (mcc != null)
   {

       double[] widths = new double[datagrid1.Columns.Count];
       for (int i = 0; i < datagrid1.Columns.Count; i++)
       {
           widths[i] = datagrid1.Columns[i].Width.Value;
       }
       mcc.MaxWidth = gantt10.ColumnDefinitions[0].ActualWidth-10;
       mcc.UpdateSize(widths);
   }

 }

[Visual Basic]
Public Sub UpdateSize( _
   ByVal columnwidths() As Double _
)
[C#]
public void UpdateSize(
   double[] columnwidths
);
[C++]
public: void UpdateSize(
   double[]* columnwidths
)
[C++/CLI]
public:
void UpdateSize(
   doublearray<columnwidths>^ columnwidths
)

Parameters

columnwidths

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MultiColumnCoordinator Class | MultiColumnCoordinator Members


%%PageItemTitle%% $$Properties$$

MultiColumnCoordinator Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Class Properties

PlexityHide.GTP Namespace : MultiColumnCoordinator Class (PlexityHide.GTP)

For a list of all members of this type, see MultiColumnCoordinator members.

Public Properties

Public Property MaxWidth Set this width and the Clipping will be set on all the seen TreeViewMultiColumnRow to this value

See Also

MultiColumnCoordinator Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

MultiColumnCoordinator Class | MultiColumnCoordinator Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > MultiColumnCoordinator Class : MaxWidth Property (MultiColumnCoordinator)

Set this width and the Clipping will be set on all the seen TreeViewMultiColumnRow to this value

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property MaxWidth As Double
[C#]
[CompilerGeneratedAttribute()]
public double MaxWidth {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MultiColumnCoordinator Class | MultiColumnCoordinator Members


%%PageItemTitle%%

MyExtensions Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

MyExtensions Class

PlexityHide.GTP Namespace : MyExtensions Class

For a list of all members of this type, see MyExtensions members.

Inheritance Hierarchy

System.Object
PlexityHide.GTP.MyExtensions

Syntax

[Visual Basic]
<ExtensionAttribute()>
Public MustInherit NotInheritable Class MyExtensions
[C#]
[ExtensionAttribute()]
public static class MyExtensions
[C++]
[ExtensionAttribute()]
public __gc abstract __sealed class MyExtensions
[C++/CLI]
[ExtensionAttribute()]
public ref class MyExtensions abstract sealed

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

MyExtensions Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

MyExtensions Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

MyExtensions Class Members

PlexityHide.GTP Namespace : MyExtensions Class

MyExtensions overview

Public Methods

Public Method static (Shared in Visual Basic) IsVisible

See Also

MyExtensions Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

MyExtensions Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

MyExtensions Class Methods

PlexityHide.GTP Namespace : MyExtensions Class

For a list of all members of this type, see MyExtensions members.

Public Methods

Public Method static (Shared in Visual Basic) IsVisible

See Also

MyExtensions Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

MyExtensions Class | MyExtensions Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

theOne
inContext
See Also Languages GTP.NET.SL Send comments on this topic.

IsVisible Method

PlexityHide.GTP Namespace > MyExtensions Class : IsVisible Method
[Visual Basic]
<ExtensionAttribute()>
Public Shared Function IsVisible( _
   ByVal theOne As UIElement, _
   ByVal inContext As UIElement _
) As Boolean
[C#]
[ExtensionAttribute()]
public static bool IsVisible(
   UIElement theOne,
   UIElement inContext
);
[C++]
[ExtensionAttribute()]
public: static bool IsVisible(
   UIElement theOne,
   UIElement inContext
)
[C++/CLI]
[ExtensionAttribute()]
public:
static bool IsVisible(
   UIElement theOne,
   UIElement inContext
)

Parameters

theOne
inContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

MyExtensions Class | MyExtensions Members


%%PageItemTitle%%

NonLinearTime Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

NonLinearTime Class

PlexityHide.GTP Namespace : NonLinearTime Class

Holds a non-linear time line, the non-linearity is limited to hiding of specific hours during all days and/or hiding of specific days during every week.

For a list of all members of this type, see NonLinearTime members.

Inheritance Hierarchy

System.Object
PlexityHide.GTP.NonLinearTime

Syntax

[Visual Basic]
Public Class NonLinearTime
[C#]
public class NonLinearTime
[C++]
public __gc class NonLinearTime
[C++/CLI]
public ref class NonLinearTime

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

NonLinearTime Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

NonLinearTime Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

NonLinearTime Class Members

PlexityHide.GTP Namespace : NonLinearTime Class

NonLinearTime overview

Public Constructors

Public Constructor NonLinearTime Constructor Constructor NonLinearTime.

Public Properties

Public Property DayStart | Returns the first visible hour in the day.
Public Property LowerBound | Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.
Public Property MidWeek | Returns the visible day which is closest to being the middle of the visible week.
Public Property NoOfVisibleDaysInWeek | Returns the number of visible days of the week.
Public Property Noon | Returns the visible hour which is closest to noon.
Public Property StartOfWeek | Sets the day of the week which starts the week. Default day is Monday.
Public Property UpperBound | Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.
Public Property WeekSpan | Returns the number of days until the last day of the week.
Public Property VisibleDays | Returns an array indicating all the visible days
Public Property VisibleHours | Returns an array indicating all the visible hours
Public Property VisibleWeekStartDay | Returns the first visible day in the week.

Public Methods

Public Method CalculateResolution | Returns a time resolution for a specified scale factor a minimum marker distance.
Public Method Exists | Checks whether the specified time exists in the non-linear time line.
Public Method HideDays | Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.
Public Method HideHours | Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.
Public Method ShowDays | Indicates what days to show, takes an array of days.
Public Method ShowHours | Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.
Public Method TicksPerScaleMarker | Indicates how many visible ticks exist between two markers for a given time resolution
Public Method TrueTime | Calculates the true time based on a known time and the number of visible ticks.
Public Method WeekNumber | Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.
Public Method VisibleTime | Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.
Public Method VisibleWeekStart |

See Also

NonLinearTime Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NonLinearTime Constructor

PlexityHide.GTP Namespace > NonLinearTime Class : NonLinearTime Constructor (NonLinearTime)

Constructor NonLinearTime.

[Visual Basic]
Public Function New()
[C#]
public NonLinearTime();
[C++]
public: NonLinearTime();
[C++/CLI]
public:
NonLinearTime();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%% $$Methods$$

NonLinearTime Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

NonLinearTime Class Methods

PlexityHide.GTP Namespace : NonLinearTime Class

For a list of all members of this type, see NonLinearTime members.

Public Methods

Public Method CalculateResolution | Returns a time resolution for a specified scale factor a minimum marker distance.
Public Method Exists | Checks whether the specified time exists in the non-linear time line.
Public Method HideDays | Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.
Public Method HideHours | Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.
Public Method ShowDays | Indicates what days to show, takes an array of days.
Public Method ShowHours | Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.
Public Method TicksPerScaleMarker | Indicates how many visible ticks exist between two markers for a given time resolution
Public Method TrueTime | Calculates the true time based on a known time and the number of visible ticks.
Public Method WeekNumber | Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.
Public Method VisibleTime | Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.
Public Method VisibleWeekStart |

See Also

NonLinearTime Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

scaleFactor
minMarkerDistance
See Also Languages GTP.NET.SL Send comments on this topic.

CalculateResolution Method

PlexityHide.GTP Namespace > NonLinearTime Class : CalculateResolution Method

Returns a time resolution for a specified scale factor a minimum marker distance.

[Visual Basic]
Public Function CalculateResolution( _
   ByVal scaleFactor As Double, _
   ByVal minMarkerDistance As Double _
) As TimeResolution
[C#]
public TimeResolution CalculateResolution(
   double scaleFactor,
   double minMarkerDistance
);
[C++]
public: TimeResolution CalculateResolution(
   double scaleFactor,
   double minMarkerDistance
)
[C++/CLI]
public:
TimeResolution CalculateResolution(
   double scaleFactor,
   double minMarkerDistance
)

Parameters

scaleFactor
minMarkerDistance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

time
See Also Languages GTP.NET.SL Send comments on this topic.

Exists Method

PlexityHide.GTP Namespace > NonLinearTime Class : Exists Method

Checks whether the specified time exists in the non-linear time line.

[Visual Basic]
Public Function Exists( _
   ByVal time As Date _
) As Boolean
[C#]
public bool Exists(
   DateTime time
);
[C++]
public: bool Exists(
   DateTime time
)
[C++/CLI]
public:
bool Exists(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

daysToHide
See Also Languages GTP.NET.SL Send comments on this topic.

HideDays Method

PlexityHide.GTP Namespace > NonLinearTime Class : HideDays Method

Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.

[Visual Basic]
Public Function HideDays( _
   ByVal daysToHide() As DayOfWeek _
) As Boolean
[C#]
public bool HideDays(
   DayOfWeek[] daysToHide
);
[C++]
public: bool HideDays(
   DayOfWeek[]* daysToHide
)
[C++/CLI]
public:
bool HideDays(
   DayOfWeekarray<daysToHide>^ daysToHide
)

Parameters

daysToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

hoursToHide
See Also Languages GTP.NET.SL Send comments on this topic.

HideHours Method

PlexityHide.GTP Namespace > NonLinearTime Class : HideHours Method

Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.

[Visual Basic]
Public Function HideHours( _
   ByVal hoursToHide() As Integer _
) As Boolean
[C#]
public bool HideHours(
   int[] hoursToHide
);
[C++]
public: bool HideHours(
   int[]* hoursToHide
)
[C++/CLI]
public:
bool HideHours(
   intarray<hoursToHide>^ hoursToHide
)

Parameters

hoursToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

daysToShow
See Also Languages GTP.NET.SL Send comments on this topic.

ShowDays Method

PlexityHide.GTP Namespace > NonLinearTime Class : ShowDays Method

Indicates what days to show, takes an array of days.

[Visual Basic]
Public Sub ShowDays( _
   ByVal daysToShow() As DayOfWeek _
)
[C#]
public void ShowDays(
   DayOfWeek[] daysToShow
);
[C++]
public: void ShowDays(
   DayOfWeek[]* daysToShow
)
[C++/CLI]
public:
void ShowDays(
   DayOfWeekarray<daysToShow>^ daysToShow
)

Parameters

daysToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

hoursToShow
See Also Languages GTP.NET.SL Send comments on this topic.

ShowHours Method

PlexityHide.GTP Namespace > NonLinearTime Class : ShowHours Method

Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.

[Visual Basic]
Public Sub ShowHours( _
   ByVal hoursToShow() As Integer _
)
[C#]
public void ShowHours(
   int[] hoursToShow
);
[C++]
public: void ShowHours(
   int[]* hoursToShow
)
[C++/CLI]
public:
void ShowHours(
   intarray<hoursToShow>^ hoursToShow
)

Parameters

hoursToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

i
See Also Languages GTP.NET.SL Send comments on this topic.

TicksPerScaleMarker Method

PlexityHide.GTP Namespace > NonLinearTime Class : TicksPerScaleMarker Method

Indicates how many visible ticks exist between two markers for a given time resolution

[Visual Basic]
Public Function TicksPerScaleMarker( _
   ByVal i As TimeResolution _
) As Long
[C#]
public long TicksPerScaleMarker(
   TimeResolution i
);
[C++]
public: long TicksPerScaleMarker(
   TimeResolution i
)
[C++/CLI]
public:
long TicksPerScaleMarker(
   TimeResolution i
)

Parameters

i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

startTime
visibleTicks
See Also Languages GTP.NET.SL Send comments on this topic.

TrueTime Method

PlexityHide.GTP Namespace > NonLinearTime Class : TrueTime Method

Calculates the true time based on a known time and the number of visible ticks.

[Visual Basic]
Public Function TrueTime( _
   ByVal startTime As Date, _
   ByVal visibleTicks As Long _
) As Date
[C#]
public DateTime TrueTime(
   DateTime startTime,
   long visibleTicks
);
[C++]
public: DateTime TrueTime(
   DateTime startTime,
   long visibleTicks
)
[C++/CLI]
public:
DateTime TrueTime(
   DateTime startTime,
   long visibleTicks
)

Parameters

startTime
visibleTicks

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

time
See Also Languages GTP.NET.SL Send comments on this topic.

WeekNumber Method

PlexityHide.GTP Namespace > NonLinearTime Class : WeekNumber Method

Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.

[Visual Basic]
Public Function WeekNumber( _
   ByVal time As Date _
) As Integer
[C#]
public int WeekNumber(
   DateTime time
);
[C++]
public: int WeekNumber(
   DateTime time
)
[C++/CLI]
public:
int WeekNumber(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

baseTime
time
See Also Languages GTP.NET.SL Send comments on this topic.

VisibleTime Method

PlexityHide.GTP Namespace > NonLinearTime Class : VisibleTime Method

Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.

[Visual Basic]
Public Function VisibleTime( _
   ByVal baseTime As Date, _
   ByVal time As Date _
) As Long
[C#]
public long VisibleTime(
   DateTime baseTime,
   DateTime time
);
[C++]
public: long VisibleTime(
   DateTime baseTime,
   DateTime time
)
[C++/CLI]
public:
long VisibleTime(
   DateTime baseTime,
   DateTime time
)

Parameters

baseTime
time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

time
See Also Languages GTP.NET.SL Send comments on this topic.

VisibleWeekStart Method

PlexityHide.GTP Namespace > NonLinearTime Class : VisibleWeekStart Method
[Visual Basic]
Public Function VisibleWeekStart( _
   ByVal time As Date _
) As Date
[C#]
public DateTime VisibleWeekStart(
   DateTime time
);
[C++]
public: DateTime VisibleWeekStart(
   DateTime time
)
[C++/CLI]
public:
DateTime VisibleWeekStart(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%% $$Properties$$

NonLinearTime Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

NonLinearTime Class Properties

PlexityHide.GTP Namespace : NonLinearTime Class

For a list of all members of this type, see NonLinearTime members.

Public Properties

Public Property DayStart | Returns the first visible hour in the day.
Public Property LowerBound | Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.
Public Property MidWeek | Returns the visible day which is closest to being the middle of the visible week.
Public Property NoOfVisibleDaysInWeek | Returns the number of visible days of the week.
Public Property Noon | Returns the visible hour which is closest to noon.
Public Property StartOfWeek | Sets the day of the week which starts the week. Default day is Monday.
Public Property UpperBound | Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.
Public Property WeekSpan | Returns the number of days until the last day of the week.
Public Property VisibleDays | Returns an array indicating all the visible days
Public Property VisibleHours | Returns an array indicating all the visible hours
Public Property VisibleWeekStartDay | Returns the first visible day in the week.

See Also

NonLinearTime Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DayStart Property

PlexityHide.GTP Namespace > NonLinearTime Class : DayStart Property

Returns the first visible hour in the day.

[Visual Basic]
Public ReadOnly Property DayStart As Integer
[C#]
public int DayStart {get;}
[C++]
public: __property int get_DayStart();
[C++/CLI]
public:
property int DayStart {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LowerBound Property

PlexityHide.GTP Namespace > NonLinearTime Class : LowerBound Property

Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.

[Visual Basic]
Public Property LowerBound As Date
[C#]
public DateTime LowerBound {get; set;}
[C++]
public: __property DateTime get_LowerBound();
public: __property void set_LowerBound(
   DateTime value
);
[C++/CLI]
public:
property DateTime LowerBound {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MidWeek Property

PlexityHide.GTP Namespace > NonLinearTime Class : MidWeek Property

Returns the visible day which is closest to being the middle of the visible week.

[Visual Basic]
Public ReadOnly Property MidWeek As DayOfWeek
[C#]
public DayOfWeek MidWeek {get;}
[C++]
public: __property DayOfWeek get_MidWeek();
[C++/CLI]
public:
property DayOfWeek MidWeek {
   DayOfWeek get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NoOfVisibleDaysInWeek Property

PlexityHide.GTP Namespace > NonLinearTime Class : NoOfVisibleDaysInWeek Property

Returns the number of visible days of the week.

[Visual Basic]
Public ReadOnly Property NoOfVisibleDaysInWeek As Integer
[C#]
public int NoOfVisibleDaysInWeek {get;}
[C++]
public: __property int get_NoOfVisibleDaysInWeek();
[C++/CLI]
public:
property int NoOfVisibleDaysInWeek {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Noon Property

PlexityHide.GTP Namespace > NonLinearTime Class : Noon Property

Returns the visible hour which is closest to noon.

[Visual Basic]
Public ReadOnly Property Noon As Integer
[C#]
public int Noon {get;}
[C++]
public: __property int get_Noon();
[C++/CLI]
public:
property int Noon {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartOfWeek Property

PlexityHide.GTP Namespace > NonLinearTime Class : StartOfWeek Property

Sets the day of the week which starts the week. Default day is Monday.

[Visual Basic]
Public Property StartOfWeek As DayOfWeek
[C#]
public DayOfWeek StartOfWeek {get; set;}
[C++]
public: __property DayOfWeek get_StartOfWeek();
public: __property void set_StartOfWeek(
   DayOfWeek value
);
[C++/CLI]
public:
property DayOfWeek StartOfWeek {
   DayOfWeek get();
   void set (DayOfWeek value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpperBound Property

PlexityHide.GTP Namespace > NonLinearTime Class : UpperBound Property

Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.

[Visual Basic]
Public Property UpperBound As Date
[C#]
public DateTime UpperBound {get; set;}
[C++]
public: __property DateTime get_UpperBound();
public: __property void set_UpperBound(
   DateTime value
);
[C++/CLI]
public:
property DateTime UpperBound {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

WeekSpan Property

PlexityHide.GTP Namespace > NonLinearTime Class : WeekSpan Property

Returns the number of days until the last day of the week.

[Visual Basic]
Public ReadOnly Property WeekSpan As Integer
[C#]
public int WeekSpan {get;}
[C++]
public: __property int get_WeekSpan();
[C++/CLI]
public:
property int WeekSpan {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VisibleDays Property

PlexityHide.GTP Namespace > NonLinearTime Class : VisibleDays Property (NonLinearTime)

Returns an array indicating all the visible days

[Visual Basic]
Public ReadOnly Property VisibleDays As DayOfWeek()
[C#]
public DayOfWeek[] VisibleDays {get;}
[C++]
public: __property DayOfWeek[]* get_VisibleDays();
[C++/CLI]
public:
property array<DayOfWeek>^ VisibleDays {
   array<DayOfWeek>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VisibleHours Property

PlexityHide.GTP Namespace > NonLinearTime Class : VisibleHours Property (NonLinearTime)

Returns an array indicating all the visible hours

[Visual Basic]
Public ReadOnly Property VisibleHours As Integer()
[C#]
public int[] VisibleHours {get;}
[C++]
public: __property int[]* get_VisibleHours();
[C++/CLI]
public:
property array<int>^ VisibleHours {
   array<int>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NonLinearTime Class | NonLinearTime Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VisibleWeekStartDay Property

PlexityHide.GTP Namespace > NonLinearTime Class : VisibleWeekStartDay Property

Returns the first visible day in the week.

[Visual Basic]
Public ReadOnly Property VisibleWeekStartDay As DayOfWeek
[C#]
public DayOfWeek VisibleWeekStartDay {get;}
[C++]
public: __property DayOfWeek get_VisibleWeekStartDay();
[C++/CLI]
public:
property DayOfWeek VisibleWeekStartDay {
   DayOfWeek get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NonLinearTime Class | NonLinearTime Members


%%PageItemTitle%%

NotifyTimeItem Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

NotifyTimeItem Class

PlexityHide.GTP Namespace : NotifyTimeItem Class

Arguments used by the events that notify about TimeItem

For a list of all members of this type, see NotifyTimeItem members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.NotifyTimeItem

Syntax

[Visual Basic]
Public Class NotifyTimeItem
   Inherits EventArgs
[C#]
public class NotifyTimeItem : EventArgs
[C++]
public __gc class NotifyTimeItem : public EventArgs
[C++/CLI]
public ref class NotifyTimeItem : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

NotifyTimeItem Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

NotifyTimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

NotifyTimeItem Class Members

PlexityHide.GTP Namespace : NotifyTimeItem Class

NotifyTimeItem overview

Public Constructors

Public Constructor NotifyTimeItem Constructor

Public Fields

Public Field TimeItem The TimeItem in question

See Also

NotifyTimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

NotifyTimeItem Class | NotifyTimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NotifyTimeItem Constructor

PlexityHide.GTP Namespace > NotifyTimeItem Class : NotifyTimeItem Constructor (NotifyTimeItem)
[Visual Basic]
Public Function New()
[C#]
public NotifyTimeItem();
[C++]
public: NotifyTimeItem();
[C++/CLI]
public:
NotifyTimeItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NotifyTimeItem Class | NotifyTimeItem Members


%%PageItemTitle%% $$Fields$$

NotifyTimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

NotifyTimeItem Class Fields

PlexityHide.GTP Namespace : NotifyTimeItem Class

For a list of all members of this type, see NotifyTimeItem members.

Public Fields

Public Field TimeItem The TimeItem in question

See Also

NotifyTimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

NotifyTimeItem Class | NotifyTimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Field

PlexityHide.GTP Namespace > NotifyTimeItem Class : TimeItem Field (NotifyTimeItem)

The TimeItem in question

[Visual Basic]
Public TimeItem As TimeItem
[C#]
public TimeItem TimeItem
[C++]
public: TimeItem* TimeItem
[C++/CLI]
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

NotifyTimeItem Class | NotifyTimeItem Members


%%PageItemTitle%%

OnGanttRowMinHeightChangeArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

OnGanttRowMinHeightChangeArgs Class

PlexityHide.GTP Namespace : OnGanttRowMinHeightChangeArgs Class

The Arguments for OnGanttRowMinHeightChange

For a list of all members of this type, see OnGanttRowMinHeightChangeArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.OnGanttRowMinHeightChangeArgs

Syntax

[Visual Basic]
Public Class OnGanttRowMinHeightChangeArgs
   Inherits EventArgs
[C#]
public class OnGanttRowMinHeightChangeArgs : EventArgs
[C++]
public __gc class OnGanttRowMinHeightChangeArgs : public EventArgs
[C++/CLI]
public ref class OnGanttRowMinHeightChangeArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

OnGanttRowMinHeightChangeArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

OnGanttRowMinHeightChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

OnGanttRowMinHeightChangeArgs Class Members

PlexityHide.GTP Namespace : OnGanttRowMinHeightChangeArgs Class

OnGanttRowMinHeightChangeArgs overview

Public Constructors

Public Constructor OnGanttRowMinHeightChangeArgs Constructor

Public Fields

Public Field CurrentValue | The CurrentValue, will be GanttRow.MinHeight or MinWidth depending on ScheduleMode setting
Public Field GanttRow | The GanttRow in question
Public Field NewHeight | This is the suggested new height, you can override this by changing the value

See Also

OnGanttRowMinHeightChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnGanttRowMinHeightChangeArgs Constructor

PlexityHide.GTP Namespace > OnGanttRowMinHeightChangeArgs Class : OnGanttRowMinHeightChangeArgs Constructor (OnGanttRowMinHeightChangeArgs)
[Visual Basic]
Public Function New()
[C#]
public OnGanttRowMinHeightChangeArgs();
[C++]
public: OnGanttRowMinHeightChangeArgs();
[C++/CLI]
public:
OnGanttRowMinHeightChangeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members


%%PageItemTitle%% $$Fields$$

OnGanttRowMinHeightChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

OnGanttRowMinHeightChangeArgs Class Fields

PlexityHide.GTP Namespace : OnGanttRowMinHeightChangeArgs Class

For a list of all members of this type, see OnGanttRowMinHeightChangeArgs members.

Public Fields

Public Field CurrentValue | The CurrentValue, will be GanttRow.MinHeight or MinWidth depending on ScheduleMode setting
Public Field GanttRow | The GanttRow in question
Public Field NewHeight | This is the suggested new height, you can override this by changing the value

See Also

OnGanttRowMinHeightChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CurrentValue Field

PlexityHide.GTP Namespace > OnGanttRowMinHeightChangeArgs Class : CurrentValue Field

The CurrentValue, will be GanttRow.MinHeight or MinWidth depending on ScheduleMode setting

[Visual Basic]
Public CurrentValue As Double
[C#]
public double CurrentValue
[C++]
public: double CurrentValue
[C++/CLI]
public:
double CurrentValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members


%%PageItemTitle%%

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow Field

PlexityHide.GTP Namespace > OnGanttRowMinHeightChangeArgs Class : GanttRow Field (OnGanttRowMinHeightChangeArgs)

The GanttRow in question

[Visual Basic]
Public GanttRow As GanttRow
[C#]
public GanttRow GanttRow
[C++]
public: GanttRow* GanttRow
[C++/CLI]
public:
GanttRow^ GanttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members


%%PageItemTitle%%

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NewHeight Field

PlexityHide.GTP Namespace > OnGanttRowMinHeightChangeArgs Class : NewHeight Field

This is the suggested new height, you can override this by changing the value

[Visual Basic]
Public NewHeight As Double
[C#]
public double NewHeight
[C++]
public: double NewHeight
[C++/CLI]
public:
double NewHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnGanttRowMinHeightChangeArgs Class | OnGanttRowMinHeightChangeArgs Members


%%PageItemTitle%%

OnTimeItemChangeArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

OnTimeItemChangeArgs Class

PlexityHide.GTP Namespace : OnTimeItemChangeArgs Class

The arguments used in the OnTimeItemChange event

For a list of all members of this type, see OnTimeItemChangeArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.OnTimeItemChangeArgs

Syntax

[Visual Basic]
Public Class OnTimeItemChangeArgs
   Inherits EventArgs
[C#]
public class OnTimeItemChangeArgs : EventArgs
[C++]
public __gc class OnTimeItemChangeArgs : public EventArgs
[C++/CLI]
public ref class OnTimeItemChangeArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

OnTimeItemChangeArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

OnTimeItemChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

OnTimeItemChangeArgs Class Members

PlexityHide.GTP Namespace : OnTimeItemChangeArgs Class

OnTimeItemChangeArgs overview

Public Constructors

Public Constructor OnTimeItemChangeArgs Constructor

Public Fields

Public Field Allow | If you set this to false it is has the same effect as e.Diff=TimeSpan.Zero
Public Field Diff | The TimeSpan that holds the difference in time about to be applied. If you have business rules to adhere to that limits a valid move you can limit the Diff value to a valid value.
Public Field MoveState | The MoveState, if this is MoveState.move diff will be applied on both Start and Stop. If it is MoveState.resizee diff will be applied on Stop only (resizew on Start only)
Public Field TimeItem | The time item about to be changed

See Also

OnTimeItemChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnTimeItemChangeArgs Constructor

PlexityHide.GTP Namespace > OnTimeItemChangeArgs Class : OnTimeItemChangeArgs Constructor (OnTimeItemChangeArgs)
[Visual Basic]
Public Function New()
[C#]
public OnTimeItemChangeArgs();
[C++]
public: OnTimeItemChangeArgs();
[C++/CLI]
public:
OnTimeItemChangeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members


%%PageItemTitle%% $$Fields$$

OnTimeItemChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

OnTimeItemChangeArgs Class Fields

PlexityHide.GTP Namespace : OnTimeItemChangeArgs Class

For a list of all members of this type, see OnTimeItemChangeArgs members.

Public Fields

Public Field Allow | If you set this to false it is has the same effect as e.Diff=TimeSpan.Zero
Public Field Diff | The TimeSpan that holds the difference in time about to be applied. If you have business rules to adhere to that limits a valid move you can limit the Diff value to a valid value.
Public Field MoveState | The MoveState, if this is MoveState.move diff will be applied on both Start and Stop. If it is MoveState.resizee diff will be applied on Stop only (resizew on Start only)
Public Field TimeItem | The time item about to be changed

See Also

OnTimeItemChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Allow Field

PlexityHide.GTP Namespace > OnTimeItemChangeArgs Class : Allow Field

If you set this to false it is has the same effect as e.Diff=TimeSpan.Zero

[Visual Basic]
Public Allow As Boolean
[C#]
public bool Allow
[C++]
public: bool Allow
[C++/CLI]
public:
bool Allow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members


%%PageItemTitle%%

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Diff Field

PlexityHide.GTP Namespace > OnTimeItemChangeArgs Class : Diff Field

The TimeSpan that holds the difference in time about to be applied. If you have business rules to adhere to that limits a valid move you can limit the Diff value to a valid value.

[Visual Basic]
Public Diff As TimeSpan
[C#]
public TimeSpan Diff
[C++]
public: TimeSpan Diff
[C++/CLI]
public:
TimeSpan Diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members


%%PageItemTitle%%

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MoveState Field

PlexityHide.GTP Namespace > OnTimeItemChangeArgs Class : MoveState Field (OnTimeItemChangeArgs)

The MoveState, if this is MoveState.move diff will be applied on both Start and Stop. If it is MoveState.resizee diff will be applied on Stop only (resizew on Start only)

[Visual Basic]
Public MoveState As MoveState
[C#]
public MoveState MoveState
[C++]
public: MoveState MoveState
[C++/CLI]
public:
MoveState MoveState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members


%%PageItemTitle%%

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Field

PlexityHide.GTP Namespace > OnTimeItemChangeArgs Class : TimeItem Field (OnTimeItemChangeArgs)

The time item about to be changed

[Visual Basic]
Public TimeItem As TimeItem
[C#]
public TimeItem TimeItem
[C++]
public: TimeItem* TimeItem
[C++/CLI]
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

OnTimeItemChangeArgs Class | OnTimeItemChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

RowChangeArgs Class

PlexityHide.GTP Namespace : RowChangeArgs Class

The arguments given in the RowChange event

For a list of all members of this type, see RowChangeArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.RowChangeArgs

Syntax

[Visual Basic]
Public Class RowChangeArgs
   Inherits EventArgs
[C#]
public class RowChangeArgs : EventArgs
[C++]
public __gc class RowChangeArgs : public EventArgs
[C++/CLI]
public ref class RowChangeArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

RowChangeArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

RowChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

RowChangeArgs Class Members

PlexityHide.GTP Namespace : RowChangeArgs Class

RowChangeArgs overview

Public Constructors

Public Constructor RowChangeArgs Constructor

Public Fields

Public Field AllTimeItemsInMoveOperation | When using multiselect all selected time items, including the one actually grabbed will be in this collection
Public Field NewRow | The new row the TimeItem is about to be placed on
Public Field OldRow | The old row the TimeItem was placed on
Public Field RevertMoveInTime | Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.
Public Field StopOperationForFollowingTimeItems | When a row change is performed on multiple time items, by multi select, you may want to handle the cluster move in the first RowChange event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the RowChangeCall
Public Field TimeItem | The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

See Also

RowChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RowChangeArgs Constructor

PlexityHide.GTP Namespace > RowChangeArgs Class : RowChangeArgs Constructor (RowChangeArgs)
[Visual Basic]
Public Function New()
[C#]
public RowChangeArgs();
[C++]
public: RowChangeArgs();
[C++/CLI]
public:
RowChangeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%% $$Fields$$

RowChangeArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

RowChangeArgs Class Fields

PlexityHide.GTP Namespace : RowChangeArgs Class

For a list of all members of this type, see RowChangeArgs members.

Public Fields

Public Field AllTimeItemsInMoveOperation | When using multiselect all selected time items, including the one actually grabbed will be in this collection
Public Field NewRow | The new row the TimeItem is about to be placed on
Public Field OldRow | The old row the TimeItem was placed on
Public Field RevertMoveInTime | Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.
Public Field StopOperationForFollowingTimeItems | When a row change is performed on multiple time items, by multi select, you may want to handle the cluster move in the first RowChange event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the RowChangeCall
Public Field TimeItem | The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

See Also

RowChangeArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllTimeItemsInMoveOperation Field

PlexityHide.GTP Namespace > RowChangeArgs Class : AllTimeItemsInMoveOperation Field (RowChangeArgs)

When using multiselect all selected time items, including the one actually grabbed will be in this collection

[Visual Basic]
Public AllTimeItemsInMoveOperation As TimeItem()
[C#]
public TimeItem[] AllTimeItemsInMoveOperation
[C++]
public: TimeItem*[]* AllTimeItemsInMoveOperation
[C++/CLI]
public:
array<TimeItem^>^ AllTimeItemsInMoveOperation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NewRow Field

PlexityHide.GTP Namespace > RowChangeArgs Class : NewRow Field

The new row the TimeItem is about to be placed on

[Visual Basic]
Public NewRow As GanttRow
[C#]
public GanttRow NewRow
[C++]
public: GanttRow* NewRow
[C++/CLI]
public:
GanttRow^ NewRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OldRow Field

PlexityHide.GTP Namespace > RowChangeArgs Class : OldRow Field (RowChangeArgs)

The old row the TimeItem was placed on

[Visual Basic]
Public OldRow As GanttRow
[C#]
public GanttRow OldRow
[C++]
public: GanttRow* OldRow
[C++/CLI]
public:
GanttRow^ OldRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RevertMoveInTime Field

PlexityHide.GTP Namespace > RowChangeArgs Class : RevertMoveInTime Field (RowChangeArgs)

Since the GanttRow move may have a special meaning you may want to revert the change along the time axis that came with this move.

[Visual Basic]
Public RevertMoveInTime As Boolean
[C#]
public bool RevertMoveInTime
[C++]
public: bool RevertMoveInTime
[C++/CLI]
public:
bool RevertMoveInTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopOperationForFollowingTimeItems Field

PlexityHide.GTP Namespace > RowChangeArgs Class : StopOperationForFollowingTimeItems Field (RowChangeArgs)

When a row change is performed on multiple time items, by multi select, you may want to handle the cluster move in the first RowChange event. If so, set StopOperationForFollowingTimeItems=true, if you do not, each time item in the selection may get the RowChangeCall

[Visual Basic]
Public StopOperationForFollowingTimeItems As Boolean
[C#]
public bool StopOperationForFollowingTimeItems
[C++]
public: bool StopOperationForFollowingTimeItems
[C++/CLI]
public:
bool StopOperationForFollowingTimeItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

RowChangeArgs Class | RowChangeArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Field

PlexityHide.GTP Namespace > RowChangeArgs Class : TimeItem Field (RowChangeArgs)

The TimeItem in question (if the move was multi select, the event will fire once for each TimeItem)

[Visual Basic]
Public TimeItem As TimeItem
[C#]
public TimeItem TimeItem
[C++]
public: TimeItem* TimeItem
[C++/CLI]
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

RowChangeArgs Class | RowChangeArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TextOutOverrideArgs Class

PlexityHide.GTP Namespace : TextOutOverrideArgs Class

Arguments used by the OnTextOutOverride event

For a list of all members of this type, see TextOutOverrideArgs members.

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.TextOutOverrideArgs

Syntax

[Visual Basic]
Public Class TextOutOverrideArgs
   Inherits EventArgs
[C#]
public class TextOutOverrideArgs : EventArgs
[C++]
public __gc class TextOutOverrideArgs : public EventArgs
[C++/CLI]
public ref class TextOutOverrideArgs : public EventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TextOutOverrideArgs Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TextOutOverrideArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TextOutOverrideArgs Class Members

PlexityHide.GTP Namespace : TextOutOverrideArgs Class

TextOutOverrideArgs overview

Public Constructors

Public Constructor TextOutOverrideArgs Constructor

Public Fields

Public Field Area | Information on what area it is that is currently drawn
Public Field IsLargeSchemaText | True if this is a text resulting from this setting UseScheduleTimeLayoutForSmallIntervals
Public Field IsUpperBand | True for upperband output, false for lowerband
Public Field Resolution | The resolution being used in this draw
Public Field ReturnCanvasToUseInstead | Enables you to send in a Canvas that will be used instead of the TextBlock; use this for serious overloads
Public Field TextBlock | This is the textblock that will be used. You can change its text (TextBlock.Text), or font, brush, stroke etc
Public Field Time | The time that this text is representing

See Also

TextOutOverrideArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TextOutOverrideArgs Constructor

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : TextOutOverrideArgs Constructor (TextOutOverrideArgs)
[Visual Basic]
Public Function New()
[C#]
public TextOutOverrideArgs();
[C++]
public: TextOutOverrideArgs();
[C++/CLI]
public:
TextOutOverrideArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%% $$Fields$$

TextOutOverrideArgs Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TextOutOverrideArgs Class Fields

PlexityHide.GTP Namespace : TextOutOverrideArgs Class

For a list of all members of this type, see TextOutOverrideArgs members.

Public Fields

Public Field Area | Information on what area it is that is currently drawn
Public Field IsLargeSchemaText | True if this is a text resulting from this setting UseScheduleTimeLayoutForSmallIntervals
Public Field IsUpperBand | True for upperband output, false for lowerband
Public Field Resolution | The resolution being used in this draw
Public Field ReturnCanvasToUseInstead | Enables you to send in a Canvas that will be used instead of the TextBlock; use this for serious overloads
Public Field TextBlock | This is the textblock that will be used. You can change its text (TextBlock.Text), or font, brush, stroke etc
Public Field Time | The time that this text is representing

See Also

TextOutOverrideArgs Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Area Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : Area Field (TextOutOverrideArgs)

Information on what area it is that is currently drawn

[Visual Basic]
Public Area As AreaEnum
[C#]
public AreaEnum Area
[C++]
public: AreaEnum Area
[C++/CLI]
public:
AreaEnum Area

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsLargeSchemaText Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : IsLargeSchemaText Field

True if this is a text resulting from this setting UseScheduleTimeLayoutForSmallIntervals

[Visual Basic]
Public IsLargeSchemaText As Boolean
[C#]
public bool IsLargeSchemaText
[C++]
public: bool IsLargeSchemaText
[C++/CLI]
public:
bool IsLargeSchemaText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsUpperBand Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : IsUpperBand Field

True for upperband output, false for lowerband

[Visual Basic]
Public IsUpperBand As Boolean
[C#]
public bool IsUpperBand
[C++]
public: bool IsUpperBand
[C++/CLI]
public:
bool IsUpperBand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resolution Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : Resolution Field (TextOutOverrideArgs)

The resolution being used in this draw

[Visual Basic]
Public Resolution As TimeResolution
[C#]
public TimeResolution Resolution
[C++]
public: TimeResolution Resolution
[C++/CLI]
public:
TimeResolution Resolution

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReturnCanvasToUseInstead Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : ReturnCanvasToUseInstead Field

Enables you to send in a Canvas that will be used instead of the TextBlock; use this for serious overloads

[Visual Basic]
Public ReturnCanvasToUseInstead As Canvas
[C#]
public Canvas ReturnCanvasToUseInstead
[C++]
public: Canvas ReturnCanvasToUseInstead
[C++/CLI]
public:
Canvas ReturnCanvasToUseInstead

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TextBlock Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : TextBlock Field

This is the textblock that will be used. You can change its text (TextBlock.Text), or font, brush, stroke etc

[Visual Basic]
Public TextBlock As TextBlock
[C#]
public TextBlock TextBlock
[C++]
public: TextBlock TextBlock
[C++/CLI]
public:
TextBlock TextBlock

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TextOutOverrideArgs Class | TextOutOverrideArgs Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Time Field

PlexityHide.GTP Namespace > TextOutOverrideArgs Class : Time Field

The time that this text is representing

[Visual Basic]
Public Time As Date
[C#]
public DateTime Time
[C++]
public: DateTime Time
[C++/CLI]
public:
DateTime Time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TextOutOverrideArgs Class | TextOutOverrideArgs Members


%%PageItemTitle%%

TimeDistinctItem Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeDistinctItem Class

PlexityHide.GTP Namespace : TimeDistinctItem Class (PlexityHide.GTP)

Defines the data that is used by collision detect.

For a list of all members of this type, see TimeDistinctItem members.

Object Model

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeDistinctItem

Syntax

[Visual Basic]
Public Class TimeDistinctItem
[C#]
public class TimeDistinctItem
[C++]
public __gc class TimeDistinctItem
[C++/CLI]
public ref class TimeDistinctItem

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeDistinctItem Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeDistinctItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctItem Class Members

PlexityHide.GTP Namespace : TimeDistinctItem Class (PlexityHide.GTP)

TimeDistinctItem overview

Public Constructors

Public Constructor TimeDistinctItem Constructor

Public Fields

Public Field CollisionNotes | Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap
Public Field DistinctPosition | Resulting collision free sub position within group
Public Field GroupKey | Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once
Public Field MainOffenderReference | Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)
Public Field Reference | The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)
Public Field Start | The start time that will be used in conflict detection
Public Field Stop | The stop time that will be used in conflict detection

See Also

TimeDistinctItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeDistinctItem Constructor

PlexityHide.GTP Namespace > TimeDistinctItem Class : TimeDistinctItem Constructor (TimeDistinctItem)
[Visual Basic]
Public Function New()
[C#]
public TimeDistinctItem();
[C++]
public: TimeDistinctItem();
[C++/CLI]
public:
TimeDistinctItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%% $$Fields$$

TimeDistinctItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctItem Class Fields

PlexityHide.GTP Namespace : TimeDistinctItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeDistinctItem members.

Public Fields

Public Field CollisionNotes | Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap
Public Field DistinctPosition | Resulting collision free sub position within group
Public Field GroupKey | Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once
Public Field MainOffenderReference | Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)
Public Field Reference | The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)
Public Field Start | The start time that will be used in conflict detection
Public Field Stop | The stop time that will be used in conflict detection

See Also

TimeDistinctItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollisionNotes Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : CollisionNotes Field

Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap

[Visual Basic]
Public CollisionNotes As List(Of CollisionNote)
[C#]
public List<CollisionNote> CollisionNotes
[C++]
public: List<CollisionNote>* CollisionNotes
[C++/CLI]
public:
List<CollisionNote>^ CollisionNotes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DistinctPosition Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : DistinctPosition Field

Resulting collision free sub position within group

[Visual Basic]
Public DistinctPosition As Integer
[C#]
public int DistinctPosition
[C++]
public: int DistinctPosition
[C++/CLI]
public:
int DistinctPosition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GroupKey Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : GroupKey Field

Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once

[Visual Basic]
Public GroupKey As Integer
[C#]
public int GroupKey
[C++]
public: int GroupKey
[C++/CLI]
public:
int GroupKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MainOffenderReference Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : MainOffenderReference Field

Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)

[Visual Basic]
Public MainOffenderReference As Object
[C#]
public object MainOffenderReference
[C++]
public: Object* MainOffenderReference
[C++/CLI]
public:
Object^ MainOffenderReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Reference Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : Reference Field

The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)

[Visual Basic]
Public Reference As TimeItem
[C#]
public TimeItem Reference
[C++]
public: TimeItem* Reference
[C++/CLI]
public:
TimeItem^ Reference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Start Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : Start Field (TimeDistinctItem)

The start time that will be used in conflict detection

[Visual Basic]
Public Start As Date
[C#]
public DateTime Start
[C++]
public: DateTime Start
[C++/CLI]
public:
DateTime Start

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctItem Class | TimeDistinctItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Stop Field

PlexityHide.GTP Namespace > TimeDistinctItem Class : Stop Field (TimeDistinctItem)

The stop time that will be used in conflict detection

[Visual Basic]
Public Stop As Date
[C#]
public DateTime Stop
[C++]
public: DateTime Stop
[C++/CLI]
public:
DateTime Stop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctItem Class | TimeDistinctItem Members


%%PageItemTitle%%

TimeDistinctThread Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread Class

PlexityHide.GTP Namespace : TimeDistinctThread Class

This class is used internally and helps GanttRows to find a collision free position asynchronously.

For a list of all members of this type, see TimeDistinctThread members.

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeDistinctThread

Syntax

[Visual Basic]
Public Class TimeDistinctThread
[C#]
public class TimeDistinctThread
[C++]
public __gc class TimeDistinctThread
[C++/CLI]
public ref class TimeDistinctThread

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeDistinctThread Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeDistinctThread Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread Class Members

PlexityHide.GTP Namespace : TimeDistinctThread Class

TimeDistinctThread overview

Public Constructors

Public Constructor TimeDistinctThread Constructor

Public Properties

Public Property CollectConflictNotes | Controls if detailed Conflict notes should be collected on each detected collision
Public Property List |
Public Property Started |

Public Methods

Public Method NeverMind
Public Method Start
Public Method Start_Syncron

Public Events

Public Event OnCollisionDetectDone This callback is implemented to catch the result from the collisiondetection

Protected Methods

Protected Method ReturnResults

See Also

TimeDistinctThread Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread Constructor

PlexityHide.GTP Namespace > TimeDistinctThread Class : TimeDistinctThread Constructor (TimeDistinctThread)
[Visual Basic]
Public Function New()
[C#]
public TimeDistinctThread();
[C++]
public: TimeDistinctThread();
[C++/CLI]
public:
TimeDistinctThread();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%% $$Methods$$

TimeDistinctThread Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread Class Methods

PlexityHide.GTP Namespace : TimeDistinctThread Class

For a list of all members of this type, see TimeDistinctThread members.

Public Methods

Public Method NeverMind
Public Method Start
Public Method Start_Syncron

Protected Methods

Protected Method ReturnResults

See Also

TimeDistinctThread Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NeverMind Method

PlexityHide.GTP Namespace > TimeDistinctThread Class : NeverMind Method
[Visual Basic]
Public Sub NeverMind()
[C#]
public void NeverMind();
[C++]
public: void NeverMind();
[C++/CLI]
public:
void NeverMind();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReturnResults Method

PlexityHide.GTP Namespace > TimeDistinctThread Class : ReturnResults Method
[Visual Basic]
Protected Sub ReturnResults()
[C#]
protected void ReturnResults();
[C++]
protected: void ReturnResults();
[C++/CLI]
protected:
void ReturnResults();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

aControlToInvalidate
See Also Languages GTP.NET.SL Send comments on this topic.

Start Method

PlexityHide.GTP Namespace > TimeDistinctThread Class : Start Method (TimeDistinctThread)
[Visual Basic]
Public Sub Start( _
   ByVal aControlToInvalidate As GanttRow _
)
[C#]
public void Start(
   GanttRow aControlToInvalidate
);
[C++]
public: void Start(
   GanttRow* aControlToInvalidate
)
[C++/CLI]
public:
void Start(
   GanttRow^ aControlToInvalidate
)

Parameters

aControlToInvalidate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Start_Syncron Method

PlexityHide.GTP Namespace > TimeDistinctThread Class : Start_Syncron Method
[Visual Basic]
Public Sub Start_Syncron()
[C#]
public void Start_Syncron();
[C++]
public: void Start_Syncron();
[C++/CLI]
public:
void Start_Syncron();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%% $$Properties$$

TimeDistinctThread Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread Class Properties

PlexityHide.GTP Namespace : TimeDistinctThread Class

For a list of all members of this type, see TimeDistinctThread members.

Public Properties

Public Property CollectConflictNotes | Controls if detailed Conflict notes should be collected on each detected collision
Public Property List |
Public Property Started |

See Also

TimeDistinctThread Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CollectConflictNotes Property

PlexityHide.GTP Namespace > TimeDistinctThread Class : CollectConflictNotes Property

Controls if detailed Conflict notes should be collected on each detected collision

[Visual Basic]
Public Property CollectConflictNotes As Boolean
[C#]
public bool CollectConflictNotes {get; set;}
[C++]
public: __property bool get_CollectConflictNotes();
public: __property void set_CollectConflictNotes(
   bool value
);
[C++/CLI]
public:
property bool CollectConflictNotes {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

List Property

PlexityHide.GTP Namespace > TimeDistinctThread Class : List Property
[Visual Basic]
Public ReadOnly Property List As List(Of TimeDistinctItem)
[C#]
public List<TimeDistinctItem> List {get;}
[C++]
public: __property List<TimeDistinctItem>* get_List();
[C++/CLI]
public:
property List<TimeDistinctItem>^ List {
   List<TimeDistinctItem>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Started Property

PlexityHide.GTP Namespace > TimeDistinctThread Class : Started Property
[Visual Basic]
Public ReadOnly Property Started As Boolean
[C#]
public bool Started {get;}
[C++]
public: __property bool get_Started();
[C++/CLI]
public:
property bool Started {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%% $$Events$$

TimeDistinctThread Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread Class Events

PlexityHide.GTP Namespace : TimeDistinctThread Class

For a list of all members of this type, see TimeDistinctThread members.

Public Events

Public Event OnCollisionDetectDone This callback is implemented to catch the result from the collisiondetection

See Also

TimeDistinctThread Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread Class | TimeDistinctThread Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCollisionDetectDone Event

PlexityHide.GTP Namespace > TimeDistinctThread Class : OnCollisionDetectDone Event

This callback is implemented to catch the result from the collisiondetection

[Visual Basic]
Public Event OnCollisionDetectDone() As EventHandler
[C#]
public event EventHandler OnCollisionDetectDone();
[C++]
public: __event EventHandler* OnCollisionDetectDone();
[C++/CLI]
public:
event EventHandler^ OnCollisionDetectDone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread Class | TimeDistinctThread Members


%%PageItemTitle%%

TimeDistinctThread.StartComparer Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StartComparer Class

PlexityHide.GTP Namespace : TimeDistinctThread.StartComparer Class

For a list of all members of this type, see TimeDistinctThread.StartComparer members.

Inheritance Hierarchy

System.Object
System.Collections.Generic.Comparer<TimeDistinctItem>
PlexityHide.GTP.TimeDistinctThread.StartComparer

Syntax

[Visual Basic]
Private Class TimeDistinctThread.StartComparer
   Inherits Comparer(Of TimeDistinctItem)
[C#]
private class TimeDistinctThread.StartComparer : Comparer<TimeDistinctItem>
[C++]
private __gc class TimeDistinctThread.StartComparer : public Comparer<TimeDistinctItem>
[C++/CLI]
private ref class TimeDistinctThread.StartComparer : public Comparer<TimeDistinctItem>

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeDistinctThread.StartComparer Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeDistinctThread.StartComparer Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StartComparer Class Members

PlexityHide.GTP Namespace : TimeDistinctThread.StartComparer Class

TimeDistinctThread.StartComparer overview

Public Constructors

Public Constructor TimeDistinctThread.StartComparer Constructor

Public Methods

Public Method Compare Overridden.

See Also

TimeDistinctThread.StartComparer Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread.StartComparer Class | TimeDistinctThread.StartComparer Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StartComparer Constructor

PlexityHide.GTP Namespace > TimeDistinctThread.StartComparer Class : TimeDistinctThread.StartComparer Constructor (TimeDistinctThread.StartComparer)
[Visual Basic]
Public Function New()
[C#]
public TimeDistinctThread.StartComparer();
[C++]
public: TimeDistinctThread.StartComparer();
[C++/CLI]
public:
TimeDistinctThread.StartComparer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread.StartComparer Class | TimeDistinctThread.StartComparer Members


%%PageItemTitle%% $$Methods$$

TimeDistinctThread.StartComparer Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StartComparer Class Methods

PlexityHide.GTP Namespace : TimeDistinctThread.StartComparer Class

For a list of all members of this type, see TimeDistinctThread.StartComparer members.

Public Methods

Public Method Compare Overridden.

See Also

TimeDistinctThread.StartComparer Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread.StartComparer Class | TimeDistinctThread.StartComparer Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

x
y
See Also Languages GTP.NET.SL Send comments on this topic.

Compare Method

PlexityHide.GTP Namespace > TimeDistinctThread.StartComparer Class : Compare Method (TimeDistinctThread.StartComparer)
[Visual Basic]
Overrides Public Function Compare( _
   ByVal x As TimeDistinctItem, _
   ByVal y As TimeDistinctItem _
) As Integer
[C#]
public override int Compare(
   TimeDistinctItem x,
   TimeDistinctItem y
);
[C++]
public: int Compare(
   TimeDistinctItem* x,
   TimeDistinctItem* y
) override
[C++/CLI]
public:
int Compare(
   TimeDistinctItem^ x,
   TimeDistinctItem^ y
) override

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread.StartComparer Class | TimeDistinctThread.StartComparer Members


%%PageItemTitle%%

TimeDistinctThread.StopComparer Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StopComparer Class

PlexityHide.GTP Namespace : TimeDistinctThread.StopComparer Class

For a list of all members of this type, see TimeDistinctThread.StopComparer members.

Inheritance Hierarchy

System.Object
System.Collections.Generic.Comparer<TimeDistinctItem>
PlexityHide.GTP.TimeDistinctThread.StopComparer

Syntax

[Visual Basic]
Private Class TimeDistinctThread.StopComparer
   Inherits Comparer(Of TimeDistinctItem)
[C#]
private class TimeDistinctThread.StopComparer : Comparer<TimeDistinctItem>
[C++]
private __gc class TimeDistinctThread.StopComparer : public Comparer<TimeDistinctItem>
[C++/CLI]
private ref class TimeDistinctThread.StopComparer : public Comparer<TimeDistinctItem>

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeDistinctThread.StopComparer Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeDistinctThread.StopComparer Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StopComparer Class Members

PlexityHide.GTP Namespace : TimeDistinctThread.StopComparer Class

TimeDistinctThread.StopComparer overview

Public Constructors

Public Constructor TimeDistinctThread.StopComparer Constructor

Public Methods

Public Method Compare Overridden.

See Also

TimeDistinctThread.StopComparer Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread.StopComparer Class | TimeDistinctThread.StopComparer Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StopComparer Constructor

PlexityHide.GTP Namespace > TimeDistinctThread.StopComparer Class : TimeDistinctThread.StopComparer Constructor (TimeDistinctThread.StopComparer)
[Visual Basic]
Public Function New()
[C#]
public TimeDistinctThread.StopComparer();
[C++]
public: TimeDistinctThread.StopComparer();
[C++/CLI]
public:
TimeDistinctThread.StopComparer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread.StopComparer Class | TimeDistinctThread.StopComparer Members


%%PageItemTitle%% $$Methods$$

TimeDistinctThread.StopComparer Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeDistinctThread.StopComparer Class Methods

PlexityHide.GTP Namespace : TimeDistinctThread.StopComparer Class

For a list of all members of this type, see TimeDistinctThread.StopComparer members.

Public Methods

Public Method Compare Overridden.

See Also

TimeDistinctThread.StopComparer Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeDistinctThread.StopComparer Class | TimeDistinctThread.StopComparer Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

x
y
See Also Languages GTP.NET.SL Send comments on this topic.

Compare Method

PlexityHide.GTP Namespace > TimeDistinctThread.StopComparer Class : Compare Method (TimeDistinctThread.StopComparer)
[Visual Basic]
Overrides Public Function Compare( _
   ByVal x As TimeDistinctItem, _
   ByVal y As TimeDistinctItem _
) As Integer
[C#]
public override int Compare(
   TimeDistinctItem x,
   TimeDistinctItem y
);
[C++]
public: int Compare(
   TimeDistinctItem* x,
   TimeDistinctItem* y
) override
[C++/CLI]
public:
int Compare(
   TimeDistinctItem^ x,
   TimeDistinctItem^ y
) override

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeDistinctThread.StopComparer Class | TimeDistinctThread.StopComparer Members


%%PageItemTitle%%

TimeItem Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeItem Class

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

A TimeItem is owned by a GanttRow and has a Start and Stop datetime value. The TimeItems can be moved by user. You can fill the TimeItem whit anything. You can have edit controls or videos here.

For a list of all members of this type, see TimeItem members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
PlexityHide.GTP.TimeItem

Syntax

[Visual Basic]
Public Class TimeItem
   Inherits Canvas
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TimeItem : Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TimeItem : public Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TimeItem : public Canvas, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeItem Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItem Class Members

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

TimeItem overview

Public Constructors

Public Constructor TimeItem Constructor The TimeItem constructor. You normally create a DataTemplate that contains a TimeItem definition, then you use that datatemplate in a GanttRow ItemsTemplate: GanttRow ItemTemplate="{StaticResource TimeItemPresentation}"

Public Fields

Public Field static (Shared in Visual Basic) AllowMoveProperty | See AllowMove
Public Field static (Shared in Visual Basic) AllowResizeEastProperty | See AllowResizeEast
Public Field static (Shared in Visual Basic) AllowResizeWestProperty | See AllowResizeWest
Public Field static (Shared in Visual Basic) IdentityProperty | IdentityProperty is the dependency property for the Identity of the TimeItem. Identity is necessary if you want to connect two TimeItems with a TimeItemLink. The Link gives two TimeItem.Identities in order to connect.
Public Field static (Shared in Visual Basic) StartProperty | StartProperty is the dependency property for the Start datetime of the TimeItem
Public Field static (Shared in Visual Basic) StopProperty | StopProperty is the dependency property for the Stop datetime of the TimeItem
Public Field static (Shared in Visual Basic) SubColumnProperty | SubColumnProperty is the dependency property for the Identity of the TimeItem. A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.

Public Properties

Public Property AllowMove | Controls if the time item can be moved by user interaction or not. DependencyProperty
Public Property AllowResizeEast | Controls if the time item can be resized in the east end by user interaction or not. DependencyProperty
Public Property AllowResizeWest | Controls if the time item can be resized in the west end by user interaction or not. DependencyProperty
Public Property ConflictAreas | A list of the conflicting areas seen by a single time item
Public Property ContentPresenter | Overridable for advanced use, public for technical reasons
Public Property EffectiveTimeItemSizedElement |
Public Property FixedWidth | FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true
Public Property FixedWidthUse | FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true
Public Property GanttRow | A Reference to the owning GanttRow
Public Property GanttRowItem | The GanttRow inherits from ListView, the TimeItem is the content you provide in a DataTemplate, The GanttRowItem is The corresponding ListViewItem that hold selection etc.
Public Property Identity | Identity is necessary so that links can refer to it in their connecting properties If you have no intention of using links you do not need to expose Identity of your TimeItems. This is a dependency property
Public Property NormalParent | Overridable for advanced use, public for technical reasons
Public Property Point | Current point of the TimeItem. In GanttRow coordinates
Public Property Start | Start is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property
Public Property Stop | Stop is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property
Public Property SubColumn | A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.
Public Property TimeItemSizedFrameworkElement | Readonly access to the resolved _timeItemSizedFrameworkElementName
Public Property TimeItemSizedFrameworkElementName | The TimeItem can very well contain information that is drawn outside of the box controlled by Start and Stop. To let the Gantt know what sub component of TimeItem that you want to be controlled by the Start and Stop you set its name in this property.
Public Property UserDrawn | When set the OnUserDrawTimeItem event on GanttRow will fire.

Public Methods

Public Method ApplyStartAndStopChange | Overridable for advanced use, public for technical reasons
Public Method ApplyStartChange | Overridable for advanced use, public for technical reasons
Public Method ApplyStopChange | Overridable for advanced use, public for technical reasons
Public Method CheckConflictForTimeItem | Returns the known conflict area for another time item if it exists. Otherwise null.
Public Method CleanForFree | Overridable for advanced use, public for technical reasons
Public Method GetMiddlePoint | Returns the middle in local time item coords, use with TransformToVisual
Public Method IsPointOverActiveArea | Checks if the point if GanttRow coordinates is over the TimeItemSizedFrameworkElement
Public Method LinkConnect | Overridable for advanced use, public for technical reasons
Public Method NotifyLinks | Overridable for advanced use, public for technical reasons
Public Method PointInResizeEArea | Overridable for advanced use, public for technical reasons
Public Method PointInResizeWArea | Overridable for advanced use, public for technical reasons
Public Method SetToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method SetToNormalCanvas | Overridable for advanced use, public for technical reasons
Public Method UpdatePosition | Overloaded. Overridable for advanced use, public for technical reasons

Protected Methods

Protected Method EnsureGanttRowItemConnection | Overridable for advanced use
Protected Method EnsureTimeItemSizedFE | Method returns the FrameworkElement that is used to symbolize a time stretch
Protected Method FindNameThatWorks | Issues with FindName made us use our own override
Protected Method FindNameThatWorksContext | Issues with FindName made us use our own override
Protected Method TimeItem_MouseLeftButtonDown | Overridable for advanced use
Protected Method TimeItem_MouseLeftButtonUp | Overridable for advanced use
Protected Method TimeItem_MouseMove | Overridable for advanced use
Protected Method UpdateIdentity | Overridable for advanced use

See Also

TimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem Constructor

PlexityHide.GTP Namespace > TimeItem Class : TimeItem Constructor (TimeItem)

The TimeItem constructor. You normally create a DataTemplate that contains a TimeItem definition, then you use that datatemplate in a GanttRow ItemsTemplate: GanttRow ItemTemplate="{StaticResource TimeItemPresentation}"

[Visual Basic]
Public Function New()
[C#]
public TimeItem();
[C++]
public: TimeItem();
[C++/CLI]
public:
TimeItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%% $$Methods$$

TimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItem Class Methods

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItem members.

Public Methods

Public Method ApplyStartAndStopChange | Overridable for advanced use, public for technical reasons
Public Method ApplyStartChange | Overridable for advanced use, public for technical reasons
Public Method ApplyStopChange | Overridable for advanced use, public for technical reasons
Public Method CheckConflictForTimeItem | Returns the known conflict area for another time item if it exists. Otherwise null.
Public Method CleanForFree | Overridable for advanced use, public for technical reasons
Public Method GetMiddlePoint | Returns the middle in local time item coords, use with TransformToVisual
Public Method IsPointOverActiveArea | Checks if the point if GanttRow coordinates is over the TimeItemSizedFrameworkElement
Public Method LinkConnect | Overridable for advanced use, public for technical reasons
Public Method NotifyLinks | Overridable for advanced use, public for technical reasons
Public Method PointInResizeEArea | Overridable for advanced use, public for technical reasons
Public Method PointInResizeWArea | Overridable for advanced use, public for technical reasons
Public Method SetToMoveCanvas | Overridable for advanced use, public for technical reasons
Public Method SetToNormalCanvas | Overridable for advanced use, public for technical reasons
Public Method UpdatePosition | Overloaded. Overridable for advanced use, public for technical reasons

Protected Methods

Protected Method EnsureGanttRowItemConnection | Overridable for advanced use
Protected Method EnsureTimeItemSizedFE | Method returns the FrameworkElement that is used to symbolize a time stretch
Protected Method FindNameThatWorks | Issues with FindName made us use our own override
Protected Method FindNameThatWorksContext | Issues with FindName made us use our own override
Protected Method TimeItem_MouseLeftButtonDown | Overridable for advanced use
Protected Method TimeItem_MouseLeftButtonUp | Overridable for advanced use
Protected Method TimeItem_MouseMove | Overridable for advanced use
Protected Method UpdateIdentity | Overridable for advanced use

See Also

TimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

applyRowContext
diff
See Also Languages GTP.NET.SL Send comments on this topic.

ApplyStartAndStopChange Method

PlexityHide.GTP Namespace > TimeItem Class : ApplyStartAndStopChange Method (TimeItem)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub ApplyStartAndStopChange( _
   ByVal applyRowContext As GanttRow, _
   ByVal diff As Point _
)
[C#]
public virtual void ApplyStartAndStopChange(
   GanttRow applyRowContext,
   Point diff
);
[C++]
public: virtual void ApplyStartAndStopChange(
   GanttRow* applyRowContext,
   Point diff
)
[C++/CLI]
public:
virtual void ApplyStartAndStopChange(
   GanttRow^ applyRowContext,
   Point diff
)

Parameters

applyRowContext
diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

diff
See Also Languages GTP.NET.SL Send comments on this topic.

ApplyStartChange Method

PlexityHide.GTP Namespace > TimeItem Class : ApplyStartChange Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub ApplyStartChange( _
   ByVal diff As Point _
)
[C#]
public virtual void ApplyStartChange(
   Point diff
);
[C++]
public: virtual void ApplyStartChange(
   Point diff
)
[C++/CLI]
public:
virtual void ApplyStartChange(
   Point diff
)

Parameters

diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

diff
See Also Languages GTP.NET.SL Send comments on this topic.

ApplyStopChange Method

PlexityHide.GTP Namespace > TimeItem Class : ApplyStopChange Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub ApplyStopChange( _
   ByVal diff As Point _
)
[C#]
public virtual void ApplyStopChange(
   Point diff
);
[C++]
public: virtual void ApplyStopChange(
   Point diff
)
[C++/CLI]
public:
virtual void ApplyStopChange(
   Point diff
)

Parameters

diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

ti
See Also Languages GTP.NET.SL Send comments on this topic.

CheckConflictForTimeItem Method

PlexityHide.GTP Namespace > TimeItem Class : CheckConflictForTimeItem Method

Returns the known conflict area for another time item if it exists. Otherwise null.

[Visual Basic]
Public Function CheckConflictForTimeItem( _
   ByVal ti As TimeItem _
) As ConflictArea
[C#]
public ConflictArea CheckConflictForTimeItem(
   TimeItem ti
);
[C++]
public: ConflictArea* CheckConflictForTimeItem(
   TimeItem* ti
)
[C++/CLI]
public:
ConflictArea^ CheckConflictForTimeItem(
   TimeItem^ ti
)

Parameters

ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CleanForFree Method

PlexityHide.GTP Namespace > TimeItem Class : CleanForFree Method (TimeItem)

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub CleanForFree()
[C#]
public virtual void CleanForFree();
[C++]
public: virtual void CleanForFree();
[C++/CLI]
public:
virtual void CleanForFree();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

EnsureGanttRowItemConnection Method

PlexityHide.GTP Namespace > TimeItem Class : EnsureGanttRowItemConnection Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub EnsureGanttRowItemConnection()
[C#]
protected virtual void EnsureGanttRowItemConnection();
[C++]
protected: virtual void EnsureGanttRowItemConnection();
[C++/CLI]
protected:
virtual void EnsureGanttRowItemConnection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

EnsureTimeItemSizedFE Method

PlexityHide.GTP Namespace > TimeItem Class : EnsureTimeItemSizedFE Method

Method returns the FrameworkElement that is used to symbolize a time stretch

[Visual Basic]
Protected Overridable Function EnsureTimeItemSizedFE() As FrameworkElement
[C#]
protected virtual FrameworkElement EnsureTimeItemSizedFE();
[C++]
protected: virtual FrameworkElement EnsureTimeItemSizedFE();
[C++/CLI]
protected:
virtual FrameworkElement EnsureTimeItemSizedFE();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

TimeItemSizedFrameworkElementName
See Also Languages GTP.NET.SL Send comments on this topic.

FindNameThatWorks Method

PlexityHide.GTP Namespace > TimeItem Class : FindNameThatWorks Method

Issues with FindName made us use our own override

[Visual Basic]
Protected Overridable Function FindNameThatWorks( _
   ByVal TimeItemSizedFrameworkElementName As String _
) As FrameworkElement
[C#]
protected virtual FrameworkElement FindNameThatWorks(
   string TimeItemSizedFrameworkElementName
);
[C++]
protected: virtual FrameworkElement FindNameThatWorks(
   string* TimeItemSizedFrameworkElementName
)
[C++/CLI]
protected:
virtual FrameworkElement FindNameThatWorks(
   String^ TimeItemSizedFrameworkElementName
)

Parameters

TimeItemSizedFrameworkElementName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
name
See Also Languages GTP.NET.SL Send comments on this topic.

FindNameThatWorksContext Method

PlexityHide.GTP Namespace > TimeItem Class : FindNameThatWorksContext Method

Issues with FindName made us use our own override

[Visual Basic]
Protected Overridable Function FindNameThatWorksContext( _
   ByVal dp As DependencyObject, _
   ByVal name As String _
) As FrameworkElement
[C#]
protected virtual FrameworkElement FindNameThatWorksContext(
   DependencyObject dp,
   string name
);
[C++]
protected: virtual FrameworkElement FindNameThatWorksContext(
   DependencyObject dp,
   string* name
)
[C++/CLI]
protected:
virtual FrameworkElement FindNameThatWorksContext(
   DependencyObject dp,
   String^ name
)

Parameters

dp
name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetMiddlePoint Method

PlexityHide.GTP Namespace > TimeItem Class : GetMiddlePoint Method

Returns the middle in local time item coords, use with TransformToVisual

[Visual Basic]
Public Overridable Function GetMiddlePoint() As Point
[C#]
public virtual Point GetMiddlePoint();
[C++]
public: virtual Point GetMiddlePoint();
[C++/CLI]
public:
virtual Point GetMiddlePoint();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

p
See Also Languages GTP.NET.SL Send comments on this topic.

IsPointOverActiveArea Method

PlexityHide.GTP Namespace > TimeItem Class : IsPointOverActiveArea Method

Checks if the point if GanttRow coordinates is over the TimeItemSizedFrameworkElement

[Visual Basic]
Public Function IsPointOverActiveArea( _
   ByVal p As Point _
) As Boolean
[C#]
public bool IsPointOverActiveArea(
   Point p
);
[C++]
public: bool IsPointOverActiveArea(
   Point p
)
[C++/CLI]
public:
bool IsPointOverActiveArea(
   Point p
)

Parameters

p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

isto
til
See Also Languages GTP.NET.SL Send comments on this topic.

LinkConnect Method

PlexityHide.GTP Namespace > TimeItem Class : LinkConnect Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub LinkConnect( _
   ByVal isto As Boolean, _
   ByVal til As TimeItemLinkItem _
)
[C#]
public virtual void LinkConnect(
   bool isto,
   TimeItemLinkItem til
);
[C++]
public: virtual void LinkConnect(
   bool isto,
   TimeItemLinkItem* til
)
[C++/CLI]
public:
virtual void LinkConnect(
   bool isto,
   TimeItemLinkItem^ til
)

Parameters

isto
til

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NotifyLinks Method

PlexityHide.GTP Namespace > TimeItem Class : NotifyLinks Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub NotifyLinks()
[C#]
public virtual void NotifyLinks();
[C++]
public: virtual void NotifyLinks();
[C++/CLI]
public:
virtual void NotifyLinks();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

posinTI
See Also Languages GTP.NET.SL Send comments on this topic.

PointInResizeEArea Method

PlexityHide.GTP Namespace > TimeItem Class : PointInResizeEArea Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Function PointInResizeEArea( _
   ByVal posinTI As Point _
) As Boolean
[C#]
public virtual bool PointInResizeEArea(
   Point posinTI
);
[C++]
public: virtual bool PointInResizeEArea(
   Point posinTI
)
[C++/CLI]
public:
virtual bool PointInResizeEArea(
   Point posinTI
)

Parameters

posinTI

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

posinTI
See Also Languages GTP.NET.SL Send comments on this topic.

PointInResizeWArea Method

PlexityHide.GTP Namespace > TimeItem Class : PointInResizeWArea Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Function PointInResizeWArea( _
   ByVal posinTI As Point _
) As Boolean
[C#]
public virtual bool PointInResizeWArea(
   Point posinTI
);
[C++]
public: virtual bool PointInResizeWArea(
   Point posinTI
)
[C++/CLI]
public:
virtual bool PointInResizeWArea(
   Point posinTI
)

Parameters

posinTI

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

unclipedcanvasformove
See Also Languages GTP.NET.SL Send comments on this topic.

SetToMoveCanvas Method

PlexityHide.GTP Namespace > TimeItem Class : SetToMoveCanvas Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub SetToMoveCanvas( _
   ByVal unclipedcanvasformove As Canvas _
)
[C#]
public virtual void SetToMoveCanvas(
   Canvas unclipedcanvasformove
);
[C++]
public: virtual void SetToMoveCanvas(
   Canvas unclipedcanvasformove
)
[C++/CLI]
public:
virtual void SetToMoveCanvas(
   Canvas unclipedcanvasformove
)

Parameters

unclipedcanvasformove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

unclipedcanvasformove
See Also Languages GTP.NET.SL Send comments on this topic.

SetToNormalCanvas Method

PlexityHide.GTP Namespace > TimeItem Class : SetToNormalCanvas Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable Sub SetToNormalCanvas( _
   ByVal unclipedcanvasformove As Canvas _
)
[C#]
public virtual void SetToNormalCanvas(
   Canvas unclipedcanvasformove
);
[C++]
public: virtual void SetToNormalCanvas(
   Canvas unclipedcanvasformove
)
[C++/CLI]
public:
virtual void SetToNormalCanvas(
   Canvas unclipedcanvasformove
)

Parameters

unclipedcanvasformove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem_MouseLeftButtonDown Method

PlexityHide.GTP Namespace > TimeItem Class : TimeItem_MouseLeftButtonDown Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub TimeItem_MouseLeftButtonDown( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void TimeItem_MouseLeftButtonDown(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void TimeItem_MouseLeftButtonDown(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void TimeItem_MouseLeftButtonDown(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem_MouseLeftButtonUp Method

PlexityHide.GTP Namespace > TimeItem Class : TimeItem_MouseLeftButtonUp Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub TimeItem_MouseLeftButtonUp( _
   ByVal sender As Object, _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void TimeItem_MouseLeftButtonUp(
   object sender,
   MouseButtonEventArgs e
);
[C++]
protected: virtual void TimeItem_MouseLeftButtonUp(
   Object* sender,
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void TimeItem_MouseLeftButtonUp(
   Object^ sender,
   MouseButtonEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
e
See Also Languages GTP.NET.SL Send comments on this topic.

TimeItem_MouseMove Method

PlexityHide.GTP Namespace > TimeItem Class : TimeItem_MouseMove Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub TimeItem_MouseMove( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void TimeItem_MouseMove(
   object sender,
   MouseEventArgs e
);
[C++]
protected: virtual void TimeItem_MouseMove(
   Object* sender,
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void TimeItem_MouseMove(
   Object^ sender,
   MouseEventArgs e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

oldValue
newValue
See Also Languages GTP.NET.SL Send comments on this topic.

UpdateIdentity Method

PlexityHide.GTP Namespace > TimeItem Class : UpdateIdentity Method

Overridable for advanced use

[Visual Basic]
Protected Overridable Sub UpdateIdentity( _
   ByVal oldValue As Object, _
   ByVal newValue As Object _
)
[C#]
protected virtual void UpdateIdentity(
   object oldValue,
   object newValue
);
[C++]
protected: virtual void UpdateIdentity(
   Object* oldValue,
   Object* newValue
)
[C++/CLI]
protected:
virtual void UpdateIdentity(
   Object^ oldValue,
   Object^ newValue
)

Parameters

oldValue
newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdatePosition Method

PlexityHide.GTP Namespace > TimeItem Class : UpdatePosition Method (TimeItem)

Overridable for advanced use, public for technical reasons

Overload List

Overridable for advanced use, public for technical reasons

[Visual Basic] Overloads Public Overridable Sub UpdatePosition()

[C#] public virtual void UpdatePosition();

[C++] public virtual void UpdatePosition()

[C++/CLI] public virtual void UpdatePosition()

Overridable for advanced use, public for technical reasons

[Visual Basic] Overloads Public Overridable Sub UpdatePosition(Point,Point)

[C#] public virtual void UpdatePosition(Point,Point);

[C++] public virtual void UpdatePosition(Point,Point);

[C++/CLI] public virtual void UpdatePosition(Point,Point);

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members | Overload List

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdatePosition() Method

PlexityHide.GTP Namespace > TimeItem Class > UpdatePosition Method : UpdatePosition() Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Overloads Public Overridable Sub UpdatePosition()
[C#]
public virtual void UpdatePosition();
[C++]
public: virtual void UpdatePosition();
[C++/CLI]
public:
virtual void UpdatePosition();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members | Overload List


%%PageItemTitle%%

TimeItem Class | TimeItem Members | Overload List

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

movediffstart
movediffstop
See Also Languages GTP.NET.SL Send comments on this topic.

UpdatePosition(Point,Point) Method

PlexityHide.GTP Namespace > TimeItem Class > UpdatePosition Method : UpdatePosition(Point,Point) Method

Overridable for advanced use, public for technical reasons

[Visual Basic]
Overloads Public Overridable Sub UpdatePosition( _
   ByVal movediffstart As Point, _
   ByVal movediffstop As Point _
)
[C#]
public virtual void UpdatePosition(
   Point movediffstart,
   Point movediffstop
);
[C++]
public: virtual void UpdatePosition(
   Point movediffstart,
   Point movediffstop
)
[C++/CLI]
public:
virtual void UpdatePosition(
   Point movediffstart,
   Point movediffstop
)

Parameters

movediffstart
movediffstop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members | Overload List


%%PageItemTitle%% $$Properties$$

TimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItem Class Properties

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItem members.

Public Properties

Public Property AllowMove | Controls if the time item can be moved by user interaction or not. DependencyProperty
Public Property AllowResizeEast | Controls if the time item can be resized in the east end by user interaction or not. DependencyProperty
Public Property AllowResizeWest | Controls if the time item can be resized in the west end by user interaction or not. DependencyProperty
Public Property ConflictAreas | A list of the conflicting areas seen by a single time item
Public Property ContentPresenter | Overridable for advanced use, public for technical reasons
Public Property EffectiveTimeItemSizedElement |
Public Property FixedWidth | FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true
Public Property FixedWidthUse | FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true
Public Property GanttRow | A Reference to the owning GanttRow
Public Property GanttRowItem | The GanttRow inherits from ListView, the TimeItem is the content you provide in a DataTemplate, The GanttRowItem is The corresponding ListViewItem that hold selection etc.
Public Property Identity | Identity is necessary so that links can refer to it in their connecting properties If you have no intention of using links you do not need to expose Identity of your TimeItems. This is a dependency property
Public Property NormalParent | Overridable for advanced use, public for technical reasons
Public Property Point | Current point of the TimeItem. In GanttRow coordinates
Public Property Start | Start is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property
Public Property Stop | Stop is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property
Public Property SubColumn | A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.
Public Property TimeItemSizedFrameworkElement | Readonly access to the resolved _timeItemSizedFrameworkElementName
Public Property TimeItemSizedFrameworkElementName | The TimeItem can very well contain information that is drawn outside of the box controlled by Start and Stop. To let the Gantt know what sub component of TimeItem that you want to be controlled by the Start and Stop you set its name in this property.
Public Property UserDrawn | When set the OnUserDrawTimeItem event on GanttRow will fire.

See Also

TimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowMove Property

PlexityHide.GTP Namespace > TimeItem Class : AllowMove Property

Controls if the time item can be moved by user interaction or not. DependencyProperty

[Visual Basic]
Public Property AllowMove As Boolean
[C#]
public bool AllowMove {get; set;}
[C++]
public: __property bool get_AllowMove();
public: __property void set_AllowMove(
   bool value
);
[C++/CLI]
public:
property bool AllowMove {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowResizeEast Property

PlexityHide.GTP Namespace > TimeItem Class : AllowResizeEast Property

Controls if the time item can be resized in the east end by user interaction or not. DependencyProperty

[Visual Basic]
Public Property AllowResizeEast As Boolean
[C#]
public bool AllowResizeEast {get; set;}
[C++]
public: __property bool get_AllowResizeEast();
public: __property void set_AllowResizeEast(
   bool value
);
[C++/CLI]
public:
property bool AllowResizeEast {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowResizeWest Property

PlexityHide.GTP Namespace > TimeItem Class : AllowResizeWest Property

Controls if the time item can be resized in the west end by user interaction or not. DependencyProperty

[Visual Basic]
Public Property AllowResizeWest As Boolean
[C#]
public bool AllowResizeWest {get; set;}
[C++]
public: __property bool get_AllowResizeWest();
public: __property void set_AllowResizeWest(
   bool value
);
[C++/CLI]
public:
property bool AllowResizeWest {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ConflictAreas Property

PlexityHide.GTP Namespace > TimeItem Class : ConflictAreas Property

A list of the conflicting areas seen by a single time item

[Visual Basic]
Public ReadOnly Property ConflictAreas As List(Of ConflictArea)
[C#]
public List<ConflictArea> ConflictAreas {get;}
[C++]
public: __property List<ConflictArea>* get_ConflictAreas();
[C++/CLI]
public:
property List<ConflictArea>^ ConflictAreas {
   List<ConflictArea>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ContentPresenter Property

PlexityHide.GTP Namespace > TimeItem Class : ContentPresenter Property

Overridable for advanced use, public for technical reasons

[Visual Basic]
Public Overridable ReadOnly Property ContentPresenter As ContentPresenter
[C#]
public virtual ContentPresenter ContentPresenter {get;}
[C++]
public: __property virtual ContentPresenter get_ContentPresenter();
[C++/CLI]
public:
virtual property ContentPresenter ContentPresenter {
   ContentPresenter get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

EffectiveTimeItemSizedElement Property

PlexityHide.GTP Namespace > TimeItem Class : EffectiveTimeItemSizedElement Property
[Visual Basic]
Public ReadOnly Property EffectiveTimeItemSizedElement As FrameworkElement
[C#]
public FrameworkElement EffectiveTimeItemSizedElement {get;}
[C++]
public: __property FrameworkElement get_EffectiveTimeItemSizedElement();
[C++/CLI]
public:
property FrameworkElement EffectiveTimeItemSizedElement {
   FrameworkElement get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FixedWidth Property

PlexityHide.GTP Namespace > TimeItem Class : FixedWidth Property

FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property FixedWidth As Double
[C#]
[CompilerGeneratedAttribute()]
public double FixedWidth {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property double get_FixedWidth();
public: __property void set_FixedWidth(
   double value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property double FixedWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FixedWidthUse Property

PlexityHide.GTP Namespace > TimeItem Class : FixedWidthUse Property

FixedWidth TimeItems are centered around StartDate and does not use the StopDate; use for Milestones etc. FixedWidth must be >0 and FixedWidthUse must be true

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property FixedWidthUse As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool FixedWidthUse {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_FixedWidthUse();
public: __property void set_FixedWidthUse(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool FixedWidthUse {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRow Property

PlexityHide.GTP Namespace > TimeItem Class : GanttRow Property (TimeItem)

A Reference to the owning GanttRow

[Visual Basic]
Public ReadOnly Property GanttRow As GanttRow
[C#]
public GanttRow GanttRow {get;}
[C++]
public: __property GanttRow* get_GanttRow();
[C++/CLI]
public:
property GanttRow^ GanttRow {
   GanttRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GanttRowItem Property

PlexityHide.GTP Namespace > TimeItem Class : GanttRowItem Property (TimeItem)

The GanttRow inherits from ListView, the TimeItem is the content you provide in a DataTemplate, The GanttRowItem is The corresponding ListViewItem that hold selection etc.

[Visual Basic]
Public ReadOnly Property GanttRowItem As GanttRowItem
[C#]
public GanttRowItem GanttRowItem {get;}
[C++]
public: __property GanttRowItem* get_GanttRowItem();
[C++/CLI]
public:
property GanttRowItem^ GanttRowItem {
   GanttRowItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Identity Property

PlexityHide.GTP Namespace > TimeItem Class : Identity Property

Identity is necessary so that links can refer to it in their connecting properties If you have no intention of using links you do not need to expose Identity of your TimeItems. This is a dependency property

[Visual Basic]
Public Property Identity As Object
[C#]
public object Identity {get; set;}
[C++]
public: __property Object* get_Identity();
public: __property void set_Identity(
   Object* value
);
[C++/CLI]
public:
property Object^ Identity {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

NormalParent Property

PlexityHide.GTP Namespace > TimeItem Class : NormalParent Property

Overridable for advanced use, public for technical reasons

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Overridable Property NormalParent As Panel
[C#]
[CompilerGeneratedAttribute()]
public virtual Panel NormalParent {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property virtual Panel get_NormalParent();
public: __property virtual void set_NormalParent(
   Panel value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
virtual property Panel NormalParent {
   Panel get();
   void set (Panel value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Point Property

PlexityHide.GTP Namespace > TimeItem Class : Point Property

Current point of the TimeItem. In GanttRow coordinates

[Visual Basic]
Public ReadOnly Property Point As Point
[C#]
public Point Point {get;}
[C++]
public: __property Point get_Point();
[C++/CLI]
public:
property Point Point {
   Point get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Start Property

PlexityHide.GTP Namespace > TimeItem Class : Start Property (TimeItem)

Start is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property

[Visual Basic]
Public Property Start As Date
[C#]
public DateTime Start {get; set;}
[C++]
public: __property DateTime get_Start();
public: __property void set_Start(
   DateTime value
);
[C++/CLI]
public:
property DateTime Start {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Stop Property

PlexityHide.GTP Namespace > TimeItem Class : Stop Property (TimeItem)

Stop is the DateTime value that will be rendered according to the settings of the DateScaler component. This is a dependency property

[Visual Basic]
Public Property Stop As Date
[C#]
public DateTime Stop {get; set;}
[C++]
public: __property DateTime get_Stop();
public: __property void set_Stop(
   DateTime value
);
[C++/CLI]
public:
property DateTime Stop {
   DateTime get();
   void set (DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SubColumn Property

PlexityHide.GTP Namespace > TimeItem Class : SubColumn Property

A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.

[Visual Basic]
Public Property SubColumn As Double
[C#]
public double SubColumn {get; set;}
[C++]
public: __property double get_SubColumn();
public: __property void set_SubColumn(
   double value
);
[C++/CLI]
public:
property double SubColumn {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemSizedFrameworkElement Property

PlexityHide.GTP Namespace > TimeItem Class : TimeItemSizedFrameworkElement Property

Readonly access to the resolved _timeItemSizedFrameworkElementName

[Visual Basic]
Public ReadOnly Property TimeItemSizedFrameworkElement As FrameworkElement
[C#]
public FrameworkElement TimeItemSizedFrameworkElement {get;}
[C++]
public: __property FrameworkElement get_TimeItemSizedFrameworkElement();
[C++/CLI]
public:
property FrameworkElement TimeItemSizedFrameworkElement {
   FrameworkElement get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemSizedFrameworkElementName Property

PlexityHide.GTP Namespace > TimeItem Class : TimeItemSizedFrameworkElementName Property

The TimeItem can very well contain information that is drawn outside of the box controlled by Start and Stop. To let the Gantt know what sub component of TimeItem that you want to be controlled by the Start and Stop you set its name in this property.

[Visual Basic]
Public Property TimeItemSizedFrameworkElementName As String
[C#]
public string TimeItemSizedFrameworkElementName {get; set;}
[C++]
public: __property string* get_TimeItemSizedFrameworkElementName();
public: __property void set_TimeItemSizedFrameworkElementName(
   string* value
);
[C++/CLI]
public:
property String^ TimeItemSizedFrameworkElementName {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UserDrawn Property

PlexityHide.GTP Namespace > TimeItem Class : UserDrawn Property

When set the OnUserDrawTimeItem event on GanttRow will fire.

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property UserDrawn As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool UserDrawn {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_UserDrawn();
public: __property void set_UserDrawn(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool UserDrawn {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%% $$Fields$$

TimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItem Class Fields

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItem members.

Public Fields

Public Field static (Shared in Visual Basic) AllowMoveProperty | See AllowMove
Public Field static (Shared in Visual Basic) AllowResizeEastProperty | See AllowResizeEast
Public Field static (Shared in Visual Basic) AllowResizeWestProperty | See AllowResizeWest
Public Field static (Shared in Visual Basic) IdentityProperty | IdentityProperty is the dependency property for the Identity of the TimeItem. Identity is necessary if you want to connect two TimeItems with a TimeItemLink. The Link gives two TimeItem.Identities in order to connect.
Public Field static (Shared in Visual Basic) StartProperty | StartProperty is the dependency property for the Start datetime of the TimeItem
Public Field static (Shared in Visual Basic) StopProperty | StopProperty is the dependency property for the Stop datetime of the TimeItem
Public Field static (Shared in Visual Basic) SubColumnProperty | SubColumnProperty is the dependency property for the Identity of the TimeItem. A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.

See Also

TimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowMoveProperty Field

PlexityHide.GTP Namespace > TimeItem Class : AllowMoveProperty Field

See AllowMove

[Visual Basic]
Public Shared AllowMoveProperty As DependencyProperty
[C#]
public static DependencyProperty AllowMoveProperty
[C++]
public: static DependencyProperty AllowMoveProperty
[C++/CLI]
public:
static DependencyProperty AllowMoveProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowResizeEastProperty Field

PlexityHide.GTP Namespace > TimeItem Class : AllowResizeEastProperty Field

See AllowResizeEast

[Visual Basic]
Public Shared AllowResizeEastProperty As DependencyProperty
[C#]
public static DependencyProperty AllowResizeEastProperty
[C++]
public: static DependencyProperty AllowResizeEastProperty
[C++/CLI]
public:
static DependencyProperty AllowResizeEastProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

AllowResizeWestProperty Field

PlexityHide.GTP Namespace > TimeItem Class : AllowResizeWestProperty Field

See AllowResizeWest

[Visual Basic]
Public Shared AllowResizeWestProperty As DependencyProperty
[C#]
public static DependencyProperty AllowResizeWestProperty
[C++]
public: static DependencyProperty AllowResizeWestProperty
[C++/CLI]
public:
static DependencyProperty AllowResizeWestProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IdentityProperty Field

PlexityHide.GTP Namespace > TimeItem Class : IdentityProperty Field

IdentityProperty is the dependency property for the Identity of the TimeItem. Identity is necessary if you want to connect two TimeItems with a TimeItemLink. The Link gives two TimeItem.Identities in order to connect.

[Visual Basic]
Public Shared IdentityProperty As DependencyProperty
[C#]
public static DependencyProperty IdentityProperty
[C++]
public: static DependencyProperty IdentityProperty
[C++/CLI]
public:
static DependencyProperty IdentityProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartProperty Field

PlexityHide.GTP Namespace > TimeItem Class : StartProperty Field

StartProperty is the dependency property for the Start datetime of the TimeItem

[Visual Basic]
Public Shared StartProperty As DependencyProperty
[C#]
public static DependencyProperty StartProperty
[C++]
public: static DependencyProperty StartProperty
[C++/CLI]
public:
static DependencyProperty StartProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopProperty Field

PlexityHide.GTP Namespace > TimeItem Class : StopProperty Field

StopProperty is the dependency property for the Stop datetime of the TimeItem

[Visual Basic]
Public Shared StopProperty As DependencyProperty
[C#]
public static DependencyProperty StopProperty
[C++]
public: static DependencyProperty StopProperty
[C++/CLI]
public:
static DependencyProperty StopProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SubColumnProperty Field

PlexityHide.GTP Namespace > TimeItem Class : SubColumnProperty Field

SubColumnProperty is the dependency property for the Identity of the TimeItem. A parameter that places the time item in the direction that is not controlled by time. For Schedulemode X, for Gantt mode Y within a single GanttRow.

[Visual Basic]
Public Shared SubColumnProperty As DependencyProperty
[C#]
public static DependencyProperty SubColumnProperty
[C++]
public: static DependencyProperty SubColumnProperty
[C++/CLI]
public:
static DependencyProperty SubColumnProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItemLink Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeItemLink Class

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

The TimeItemLink is used to show relation between two TimeItems

For a list of all members of this type, see TimeItemLink members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
PlexityHide.GTP.TimeItemLink

Syntax

[Visual Basic]
Public Class TimeItemLink
   Inherits Canvas
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TimeItemLink : Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TimeItemLink : public Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TimeItemLink : public Canvas, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeItemLink Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeItemLink Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLink Class Members

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

TimeItemLink overview

Public Constructors

Public Constructor TimeItemLink Constructor

Public Fields

Public Field static (Shared in Visual Basic) StartIdentityProperty | The StartIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Field static (Shared in Visual Basic) StopIdentityProperty | The StopIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

Public Properties

Public Property DrawCanvas | This is the canvas the Link is drawn on
Public Property LinkStroke | The link is drawn with this brush
Public Property LinkStrokeThickness | The link is drawn with a brush having this StrokeThickness
Public Property StartIdentity | The StartIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Property StopIdentity | The StopIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Property TimeItemLinkItem | This reach the corresponding TimeItemLinkItem that inherites from ListViewItenm
Public Property TimeItemLinkStyle | The Style of the link controls where on the TimeItem the link starts and where it stops
Public Property UserDraw | Set this flag to completely replace the standard link, or to add drawing to a link

Public Events

Public Event OnUserDraw Userdrawn links can either completly replace the standard drawing or simply adorn the existing drawing The input to the UserDraw event has a list of points corresponding to each point in the legs 1 to 4 in the graph below Note that if the linked time items are on the same row some of the turns between legs are omitted. xxxxxxxxxx x 1x-| xxxxxxxxxx | |2 -------------------------------------------3 | | | | xxxxxxxx | xxxxxxxxxxxx | - x x |-x 4x-| xxxxxxxx xxxxxxxxxxxx

See Also

TimeItemLink Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLink Constructor

PlexityHide.GTP Namespace > TimeItemLink Class : TimeItemLink Constructor (TimeItemLink)
[Visual Basic]
Public Function New()
[C#]
public TimeItemLink();
[C++]
public: TimeItemLink();
[C++/CLI]
public:
TimeItemLink();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%% $$Properties$$

TimeItemLink Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLink Class Properties

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLink members.

Public Properties

Public Property DrawCanvas | This is the canvas the Link is drawn on
Public Property LinkStroke | The link is drawn with this brush
Public Property LinkStrokeThickness | The link is drawn with a brush having this StrokeThickness
Public Property StartIdentity | The StartIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Property StopIdentity | The StopIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Property TimeItemLinkItem | This reach the corresponding TimeItemLinkItem that inherites from ListViewItenm
Public Property TimeItemLinkStyle | The Style of the link controls where on the TimeItem the link starts and where it stops
Public Property UserDraw | Set this flag to completely replace the standard link, or to add drawing to a link

See Also

TimeItemLink Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DrawCanvas Property

PlexityHide.GTP Namespace > TimeItemLink Class : DrawCanvas Property

This is the canvas the Link is drawn on

[Visual Basic]
Public ReadOnly Property DrawCanvas As Canvas
[C#]
public Canvas DrawCanvas {get;}
[C++]
public: __property Canvas get_DrawCanvas();
[C++/CLI]
public:
property Canvas DrawCanvas {
   Canvas get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LinkStroke Property

PlexityHide.GTP Namespace > TimeItemLink Class : LinkStroke Property

The link is drawn with this brush

[Visual Basic]
Public Property LinkStroke As Brush
[C#]
public Brush LinkStroke {get; set;}
[C++]
public: __property Brush get_LinkStroke();
public: __property void set_LinkStroke(
   Brush value
);
[C++/CLI]
public:
property Brush LinkStroke {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LinkStrokeThickness Property

PlexityHide.GTP Namespace > TimeItemLink Class : LinkStrokeThickness Property

The link is drawn with a brush having this StrokeThickness

[Visual Basic]
Public Property LinkStrokeThickness As Double
[C#]
public double LinkStrokeThickness {get; set;}
[C++]
public: __property double get_LinkStrokeThickness();
public: __property void set_LinkStrokeThickness(
   double value
);
[C++/CLI]
public:
property double LinkStrokeThickness {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartIdentity Property

PlexityHide.GTP Namespace > TimeItemLink Class : StartIdentity Property

The StartIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

[Visual Basic]
Public Property StartIdentity As Object
[C#]
public object StartIdentity {get; set;}
[C++]
public: __property Object* get_StartIdentity();
public: __property void set_StartIdentity(
   Object* value
);
[C++/CLI]
public:
property Object^ StartIdentity {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopIdentity Property

PlexityHide.GTP Namespace > TimeItemLink Class : StopIdentity Property

The StopIdentity connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

[Visual Basic]
Public Property StopIdentity As Object
[C#]
public object StopIdentity {get; set;}
[C++]
public: __property Object* get_StopIdentity();
public: __property void set_StopIdentity(
   Object* value
);
[C++/CLI]
public:
property Object^ StopIdentity {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Property

PlexityHide.GTP Namespace > TimeItemLink Class : TimeItemLinkItem Property (TimeItemLink)

This reach the corresponding TimeItemLinkItem that inherites from ListViewItenm

[Visual Basic]
Public ReadOnly Property TimeItemLinkItem As TimeItemLinkItem
[C#]
public TimeItemLinkItem TimeItemLinkItem {get;}
[C++]
public: __property TimeItemLinkItem* get_TimeItemLinkItem();
[C++/CLI]
public:
property TimeItemLinkItem^ TimeItemLinkItem {
   TimeItemLinkItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkStyle Property

PlexityHide.GTP Namespace > TimeItemLink Class : TimeItemLinkStyle Property (TimeItemLink)

The Style of the link controls where on the TimeItem the link starts and where it stops

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property TimeItemLinkStyle As TimeItemLinkStyle
[C#]
[CompilerGeneratedAttribute()]
public TimeItemLinkStyle TimeItemLinkStyle {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property TimeItemLinkStyle get_TimeItemLinkStyle();
public: __property void set_TimeItemLinkStyle(
   TimeItemLinkStyle value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property TimeItemLinkStyle TimeItemLinkStyle {
   TimeItemLinkStyle get();
   void set (TimeItemLinkStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UserDraw Property

PlexityHide.GTP Namespace > TimeItemLink Class : UserDraw Property

Set this flag to completely replace the standard link, or to add drawing to a link

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property UserDraw As Boolean
[C#]
[CompilerGeneratedAttribute()]
public bool UserDraw {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property bool get_UserDraw();
public: __property void set_UserDraw(
   bool value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property bool UserDraw {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%% $$Fields$$

TimeItemLink Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLink Class Fields

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLink members.

Public Fields

Public Field static (Shared in Visual Basic) StartIdentityProperty | The StartIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.
Public Field static (Shared in Visual Basic) StopIdentityProperty | The StopIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

See Also

TimeItemLink Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StartIdentityProperty Field

PlexityHide.GTP Namespace > TimeItemLink Class : StartIdentityProperty Field

The StartIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

[Visual Basic]
Public Shared StartIdentityProperty As DependencyProperty
[C#]
public static DependencyProperty StartIdentityProperty
[C++]
public: static DependencyProperty StartIdentityProperty
[C++/CLI]
public:
static DependencyProperty StartIdentityProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

StopIdentityProperty Field

PlexityHide.GTP Namespace > TimeItemLink Class : StopIdentityProperty Field

The StopIdentityProperty is the dependencyproperty that connects a TimeItemLink to a TimeItem. The match is made by comparing the TimeItems Id field, so that must be unique in order to get predictable results.

[Visual Basic]
Public Shared StopIdentityProperty As DependencyProperty
[C#]
public static DependencyProperty StopIdentityProperty
[C++]
public: static DependencyProperty StopIdentityProperty
[C++/CLI]
public:
static DependencyProperty StopIdentityProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%% $$Events$$

TimeItemLink Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLink Class Events

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLink members.

Public Events

Public Event OnUserDraw Userdrawn links can either completly replace the standard drawing or simply adorn the existing drawing The input to the UserDraw event has a list of points corresponding to each point in the legs 1 to 4 in the graph below Note that if the linked time items are on the same row some of the turns between legs are omitted. xxxxxxxxxx x 1x-| xxxxxxxxxx | |2 -------------------------------------------3 | | | | xxxxxxxx | xxxxxxxxxxxx | - x x |-x 4x-| xxxxxxxx xxxxxxxxxxxx

See Also

TimeItemLink Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnUserDraw Event

PlexityHide.GTP Namespace > TimeItemLink Class : OnUserDraw Event

Userdrawn links can either completly replace the standard drawing or simply adorn the existing drawing The input to the UserDraw event has a list of points corresponding to each point in the legs 1 to 4 in the graph below Note that if the linked time items are on the same row some of the turns between legs are omitted. xxxxxxxxxx x 1x-| xxxxxxxxxx | |2 -------------------------------------------3 | | | | xxxxxxxx | xxxxxxxxxxxx | - x x |-x 4x-| xxxxxxxx xxxxxxxxxxxx

[Visual Basic]
Public Event OnUserDraw() As EventHandler(Of LinkUserDrawEventArgs)
[C#]
public event EventHandler<LinkUserDrawEventArgs> OnUserDraw();
[C++]
public: __event EventHandler<LinkUserDrawEventArgs>* OnUserDraw();
[C++/CLI]
public:
event EventHandler<LinkUserDrawEventArgs>^ OnUserDraw();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLinkCanvas Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Class

PlexityHide.GTP Namespace : TimeItemLinkCanvas Class

TimeItemLinkCanvas is public for technical reasons; do not use

For a list of all members of this type, see TimeItemLinkCanvas members.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
PlexityHide.GTP.TimeItemLinkCanvas

Syntax

[Visual Basic]
Public Class TimeItemLinkCanvas
   Inherits Canvas
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TimeItemLinkCanvas : Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TimeItemLinkCanvas : public Canvas, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TimeItemLinkCanvas : public Canvas, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeItemLinkCanvas Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Class Members

PlexityHide.GTP Namespace : TimeItemLinkCanvas Class

TimeItemLinkCanvas overview

Public Constructors

Public Constructor TimeItemLinkCanvas Constructor TimeItemLinkCanvas is public for technical reasons; do not use

See Also

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Constructor

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : TimeItemLinkCanvas Constructor (TimeItemLinkCanvas)

TimeItemLinkCanvas is public for technical reasons; do not use

[Visual Basic]
Public Function New()
[C#]
public TimeItemLinkCanvas();
[C++]
public: TimeItemLinkCanvas();
[C++/CLI]
public:
TimeItemLinkCanvas();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkItem Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Class

PlexityHide.GTP Namespace : TimeItemLinkItem Class (PlexityHide.GTP)

TimeItemLinkItem is corresponding to a ListViewItem of an ItemsControl. Each TimeItemLinkItem should point out a DataTemplate that defines a TimeItemLink.

For a list of all members of this type, see TimeItemLinkItem members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.ContentPresenter
PlexityHide.GTP.TimeItemLinkItem

Syntax

[Visual Basic]
Public Class TimeItemLinkItem
   Inherits ContentPresenter
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TimeItemLinkItem : ContentPresenter, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TimeItemLinkItem : public ContentPresenter, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TimeItemLinkItem : public ContentPresenter, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeItemLinkItem Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeItemLinkItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Class Members

PlexityHide.GTP Namespace : TimeItemLinkItem Class (PlexityHide.GTP)

TimeItemLinkItem overview

Public Constructors

Public Constructor TimeItemLinkItem Constructor

Public Properties

Public Property Link | This gives access to your business data that constitutes the link
Public Property TimeItemLinks | Access to owning list

Protected Methods

Protected Method ArrangeOverride | Overridden. Overridable for advanced use
Protected Method MeasureOverride | Overridden.

See Also

TimeItemLinkItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Constructor

PlexityHide.GTP Namespace > TimeItemLinkItem Class : TimeItemLinkItem Constructor (TimeItemLinkItem)
[Visual Basic]
Public Function New()
[C#]
public TimeItemLinkItem();
[C++]
public: TimeItemLinkItem();
[C++/CLI]
public:
TimeItemLinkItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%% $$Methods$$

TimeItemLinkItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Class Methods

PlexityHide.GTP Namespace : TimeItemLinkItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinkItem members.

Protected Methods

Protected Method ArrangeOverride | Overridden. Overridable for advanced use
Protected Method MeasureOverride | Overridden.

See Also

TimeItemLinkItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ArrangeOverride Method (TimeItemLinkItem)

Overridable for advanced use

[Visual Basic]
Overrides Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected override Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
) override
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
) override

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MeasureOverride Method (TimeItemLinkItem)
[Visual Basic]
Overrides Protected Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
[C#]
protected override Size MeasureOverride(
   Size availableSize
);
[C++]
protected: Size MeasureOverride(
   Size availableSize
) override
[C++/CLI]
protected:
Size MeasureOverride(
   Size availableSize
) override

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%% $$Properties$$

TimeItemLinkItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Class Properties

PlexityHide.GTP Namespace : TimeItemLinkItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinkItem members.

Public Properties

Public Property Link | This gives access to your business data that constitutes the link
Public Property TimeItemLinks | Access to owning list

See Also

TimeItemLinkItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Link Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Link Property

This gives access to your business data that constitutes the link

[Visual Basic]
Public ReadOnly Property Link As Object
[C#]
public object Link {get;}
[C++]
public: __property Object* get_Link();
[C++/CLI]
public:
property Object^ Link {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TimeItemLinks Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : TimeItemLinks Property (TimeItemLinkItem)

Access to owning list

[Visual Basic]
Public ReadOnly Property TimeItemLinks As TimeItemLinks
[C#]
public TimeItemLinks TimeItemLinks {get;}
[C++]
public: __property TimeItemLinks* get_TimeItemLinks();
[C++/CLI]
public:
property TimeItemLinks^ TimeItemLinks {
   TimeItemLinks^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinks Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeItemLinks Class

PlexityHide.GTP Namespace : TimeItemLinks Class (PlexityHide.GTP)

The ItemsControl that holds the TimeItemLinks. One instance is owned by the Gantt.

For a list of all members of this type, see TimeItemLinks members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
PlexityHide.GTP.TimeItemLinks

Syntax

[Visual Basic]
Public Class TimeItemLinks
   Inherits ItemsControl
   Implements IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TimeItemLinks : ItemsControl, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TimeItemLinks : public ItemsControl, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TimeItemLinks : public ItemsControl, IGeneratorHost, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TimeItemLinks Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TimeItemLinks Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinks Class Members

PlexityHide.GTP Namespace : TimeItemLinks Class (PlexityHide.GTP)

TimeItemLinks overview

Public Properties

Public Property OwningGanttRef The Gantt component that owns this items control

Protected Methods

Protected Method ClearContainerForItemOverride | Overridden.
Protected Method GetContainerForItemOverride | Overridden.
Protected Method IsItemItsOwnContainerOverride | Overridden.
Protected Method MeasureOverride | Overridden.
Protected Method OnItemsChanged | Overridden.
Protected Method PrepareContainerForItemOverride | Overridden.

See Also

TimeItemLinks Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

TimeItemLinks Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinks Class Methods

PlexityHide.GTP Namespace : TimeItemLinks Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinks members.

Protected Methods

Protected Method ClearContainerForItemOverride | Overridden.
Protected Method GetContainerForItemOverride | Overridden.
Protected Method IsItemItsOwnContainerOverride | Overridden.
Protected Method MeasureOverride | Overridden.
Protected Method OnItemsChanged | Overridden.
Protected Method PrepareContainerForItemOverride | Overridden.

See Also

TimeItemLinks Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
item
See Also Languages GTP.NET.SL Send comments on this topic.

ClearContainerForItemOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ClearContainerForItemOverride Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Sub ClearContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
[C#]
protected override void ClearContainerForItemOverride(
   DependencyObject element,
   object item
);
[C++]
protected: void ClearContainerForItemOverride(
   DependencyObject element,
   Object* item
) override
[C++/CLI]
protected:
void ClearContainerForItemOverride(
   DependencyObject element,
   Object^ item
) override

Parameters

element
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GetContainerForItemOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : GetContainerForItemOverride Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Function GetContainerForItemOverride() As DependencyObject
[C#]
protected override DependencyObject GetContainerForItemOverride();
[C++]
protected: DependencyObject GetContainerForItemOverride(); override
[C++/CLI]
protected:
DependencyObject GetContainerForItemOverride(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
See Also Languages GTP.NET.SL Send comments on this topic.

IsItemItsOwnContainerOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : IsItemItsOwnContainerOverride Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Function IsItemItsOwnContainerOverride( _
   ByVal item As Object _
) As Boolean
[C#]
protected override bool IsItemItsOwnContainerOverride(
   object item
);
[C++]
protected: bool IsItemItsOwnContainerOverride(
   Object* item
) override
[C++/CLI]
protected:
bool IsItemItsOwnContainerOverride(
   Object^ item
) override

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalSize
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : MeasureOverride Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Function MeasureOverride( _
   ByVal finalSize As Size _
) As Size
[C#]
protected override Size MeasureOverride(
   Size finalSize
);
[C++]
protected: Size MeasureOverride(
   Size finalSize
) override
[C++/CLI]
protected:
Size MeasureOverride(
   Size finalSize
) override

Parameters

finalSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnItemsChanged Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnItemsChanged Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Sub OnItemsChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
)
[C#]
protected override void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
);
[C++]
protected: void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
) override
[C++/CLI]
protected:
void OnItemsChanged(
   NotifyCollectionChangedEventArgs e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
item
See Also Languages GTP.NET.SL Send comments on this topic.

PrepareContainerForItemOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : PrepareContainerForItemOverride Method (TimeItemLinks)
[Visual Basic]
Overrides Protected Sub PrepareContainerForItemOverride( _
   ByVal element As DependencyObject, _
   ByVal item As Object _
)
[C#]
protected override void PrepareContainerForItemOverride(
   DependencyObject element,
   object item
);
[C++]
protected: void PrepareContainerForItemOverride(
   DependencyObject element,
   Object* item
) override
[C++/CLI]
protected:
void PrepareContainerForItemOverride(
   DependencyObject element,
   Object^ item
) override

Parameters

element
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%% $$Properties$$

TimeItemLinks Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinks Class Properties

PlexityHide.GTP Namespace : TimeItemLinks Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinks members.

Public Properties

Public Property OwningGanttRef The Gantt component that owns this items control

See Also

TimeItemLinks Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OwningGanttRef Property

PlexityHide.GTP Namespace > TimeItemLinks Class : OwningGanttRef Property (TimeItemLinks)

The Gantt component that owns this items control

[Visual Basic]
Public ReadOnly Property OwningGanttRef As Gantt
[C#]
public Gantt OwningGanttRef {get;}
[C++]
public: __property Gantt* get_OwningGanttRef();
[C++/CLI]
public:
property Gantt^ OwningGanttRef {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TreeViewMultiColumnRow Members | PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

The TreeViewMultiColumnRow inherites from Grid. If you use this in your treeview datatemplas as a layeout for your grid cells you can use the MultiColumnCoordinator to resize them together with other rows on different levels in the tree.

For a list of all members of this type, see TreeViewMultiColumnRow members.

Object Model

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Grid
PlexityHide.GTP.TreeViewMultiColumnRow

Syntax

[Visual Basic]
Public Class TreeViewMultiColumnRow
   Inherits Grid
   Implements IManagedPeer, INativeCoreTypeWrapper
[C#]
public class TreeViewMultiColumnRow : Grid, IManagedPeer, INativeCoreTypeWrapper
[C++]
public __gc class TreeViewMultiColumnRow : public Grid, IManagedPeer, INativeCoreTypeWrapper
[C++/CLI]
public ref class TreeViewMultiColumnRow : public Grid, IManagedPeer, INativeCoreTypeWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

TreeViewMultiColumnRow Members | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class Members

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

TreeViewMultiColumnRow overview

Public Constructors

Public Constructor TreeViewMultiColumnRow Constructor The default constructor

Public Fields

Public Field static (Shared in Visual Basic) MultiColumnCoordinatorProperty See MultiColumnCoordinator property

Public Properties

Public Property LevelReduce | How much this row should be reduced in initial widht to compensate for the tree Level inset
Public Property MultiColumnCoordinator | Assign the same MultiColumnCoordinator for all the TreeViewMultiColumnRow you want to stay in sync: Like this:

See Also

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Constructor

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : TreeViewMultiColumnRow Constructor (TreeViewMultiColumnRow)

The default constructor

[Visual Basic]
Public Function New()
[C#]
public TreeViewMultiColumnRow();
[C++]
public: TreeViewMultiColumnRow();
[C++/CLI]
public:
TreeViewMultiColumnRow();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%% $$Properties$$

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class Properties

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

For a list of all members of this type, see TreeViewMultiColumnRow members.

Public Properties

Public Property LevelReduce | How much this row should be reduced in initial widht to compensate for the tree Level inset
Public Property MultiColumnCoordinator | Assign the same MultiColumnCoordinator for all the TreeViewMultiColumnRow you want to stay in sync: Like this:

See Also

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LevelReduce Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : LevelReduce Property

How much this row should be reduced in initial widht to compensate for the tree Level inset

[Visual Basic]
<CompilerGeneratedAttribute()>
Public Property LevelReduce As Double
[C#]
[CompilerGeneratedAttribute()]
public double LevelReduce {get; set;}
[C++]
[CompilerGeneratedAttribute()]
public: __property double get_LevelReduce();
public: __property void set_LevelReduce(
   double value
);
[C++/CLI]
[CompilerGeneratedAttribute()]
public:
property double LevelReduce {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MultiColumnCoordinator Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MultiColumnCoordinator Property (TreeViewMultiColumnRow)

Assign the same MultiColumnCoordinator for all the TreeViewMultiColumnRow you want to stay in sync: Like this:

[Visual Basic]
Public Property MultiColumnCoordinator As MultiColumnCoordinator
[C#]
public MultiColumnCoordinator MultiColumnCoordinator {get; set;}
[C++]
public: __property MultiColumnCoordinator* get_MultiColumnCoordinator();
public: __property void set_MultiColumnCoordinator(
   MultiColumnCoordinator* value
);
[C++/CLI]
public:
property MultiColumnCoordinator^ MultiColumnCoordinator {
   MultiColumnCoordinator^ get();
   void set (MultiColumnCoordinator^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%% $$Fields$$

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class Fields

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

For a list of all members of this type, see TreeViewMultiColumnRow members.

Public Fields

Public Field static (Shared in Visual Basic) MultiColumnCoordinatorProperty See MultiColumnCoordinator property

See Also

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MultiColumnCoordinatorProperty Field

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MultiColumnCoordinatorProperty Field

See MultiColumnCoordinator property

[Visual Basic]
Public Shared ReadOnly MultiColumnCoordinatorProperty As DependencyProperty
[C#]
public static readonly DependencyProperty MultiColumnCoordinatorProperty
[C++]
public: static readonly DependencyProperty MultiColumnCoordinatorProperty
[C++/CLI]
public:
static readonly DependencyProperty MultiColumnCoordinatorProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

AreaEnum Enumeration

PlexityHide.GTP Namespace : AreaEnum Enumeration

DateScale has different areas

Members

Member | Description
NormalFirst | Only area when fish eye is off, otherwise area in front of fish eye
FishEye | inside fisheye
NormalSecond | after fisheye

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

ConflictAreaUpdateKind Enumeration

PlexityHide.GTP Namespace : ConflictAreaUpdateKind Enumeration (PlexityHide.GTP)

The Different kinds of update that may be signaled on a conflict area

Members

Member | Description
add | The conflict area is new
update | The conflict area was changed
remove | The conflict resolved and the conflict area is removed

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

DateScaler.userop Enumeration

PlexityHide.GTP Namespace : DateScaler.userop Enumeration

Enum with possible user op values

Members

Member | Description
none | No operation
zoom | user is zooming
pan | user is panorating
fisheyemove | user is moving the fisheye
fisheyeresize | user is resizing the fisheye

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

DateScalerChangeKind Enumeration

PlexityHide.GTP Namespace : DateScalerChangeKind Enumeration (PlexityHide.GTP)

In the BeforeScaleOrSpanChange event this enum specifies what started the change

Members

Member | Description
code | Start och StopTime called from code
userzoom | User zooms
userpan | User pans
animation | AnimateScaleTransition in progress

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

FishEyeMagnification Enumeration

PlexityHide.GTP Namespace : FishEyeMagnification Enumeration (PlexityHide.GTP)

FishEyeMagnification.

Members

Member | Description
M1 | No magnification
M2 | 2x magnification
M3 | 3x magnification
M4 | 4x magnification
M5 | 5x magnification
M6 | 6x magnification
M7 | 7x magnification
M8 | 8x magnification
M9 | 9x magnification
M10 | 10x magnification

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

MoveState Enumeration

PlexityHide.GTP Namespace : MoveState Enumeration (PlexityHide.GTP)

When the user is in a data changing operation for the TimeItem(s) the MoveState is changed from none to one of these

Members

Member | Description
none | No operation currently
move | Move operation when a TimeItem is clicked and dragged
resizee | Resize towards east
resizew | Resize Towards west

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

ResizingType Enumeration

PlexityHide.GTP Namespace : ResizingType Enumeration

Resizing characteristics.

Members

Member | Description
StartAndStopLocked | Start and stop time locked, resolution changes with resizing.
StartLocked | Start time locked, stop time changes.
StopLocked | Stop time locked, start time changes.
CenterLocked | Center time locked, start and stop time change.

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

RowScreenStatus Enumeration

PlexityHide.GTP Namespace : RowScreenStatus Enumeration

Value gives information about a row position in a Gantt display

Members

Member | Description
aboveortotheleft |
onscreen |
belowortheright |

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

TimeItemLinkStyle Enumeration

PlexityHide.GTP Namespace : TimeItemLinkStyle Enumeration (PlexityHide.GTP)

The style of link

Members

Member | Description
StartToStart | Start of one time item to another time items start.
StartToStop | Start of one time item to another time items stop.
StopToStart | Stop of one time item to another time items start.
StopToStop | Stop of one time item to another time items start.

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

TimeResolution Enumeration

PlexityHide.GTP Namespace : TimeResolution Enumeration

Enumeration for all availbale time scale resolutions

Members

Member | Description
secondsBy10000 |
secondsBy1000 |
secondsBy100 |
secondsBy10 |
seconds |
seconds10 |
minutes |
minutes10 |
hours |
hours3 |
hours6 |
days |
weeks |
months |
quarters |
years |
years10 |
years20 |
years100 |
years1000 |

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

TimeStrEnum Enumeration

PlexityHide.GTP Namespace : TimeStrEnum Enumeration

Members

Member | Description
Empty |
MilliSec |
SecBy10 |
Sec |
Min |
Hour |
TimeOfDay |
DayName |
Day |
DayOneLetter |
DayName3 |
Week |
Month |
Month3 |
QuarterWithYear |
QuarterWithoutYear |
Year2 |
Year4 |
YearSpan10 |
YearSpan20 |
YearSpan100 |

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements GTP.NET.SL Send comments on this topic.

VerticalDayStripesUse Enumeration

PlexityHide.GTP Namespace : VerticalDayStripesUse Enumeration (PlexityHide.GTP)

VerticalDayStripesUse

Members

Member | Description
foreground | The stripes are placed in the foreground
background | The stripes are placed in the background
none | The stripes are not visible

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

dateScaler
e
See Also Requirements Languages GTP.NET.SL Send comments on this topic.

BeforeScaleOrSpanChangeEventHandler Delegate

PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeEventHandler Delegate

The event handler used to communicate change of the DateScaler

[Visual Basic]
Public Delegate Sub BeforeScaleOrSpanChangeEventHandler( _
   ByVal dateScaler As Object, _
   ByVal e As BeforeScaleOrSpanChangeArgs _
)
[C#]
public delegate void BeforeScaleOrSpanChangeEventHandler(
   object dateScaler,
   BeforeScaleOrSpanChangeArgs e
);
[C++]
public: __gc __delegate void BeforeScaleOrSpanChangeEventHandler(
   Object* dateScaler,
   BeforeScaleOrSpanChangeArgs* e
)
[C++/CLI]
public delegate void BeforeScaleOrSpanChangeEventHandler(
   Object^ dateScaler,
   BeforeScaleOrSpanChangeArgs^ e
)

Parameters

dateScaler
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

aGantt
e
See Also Requirements Languages GTP.NET.SL Send comments on this topic.

CollisionDetectEvent Delegate

PlexityHide.GTP Namespace : CollisionDetectEvent Delegate

The delegate for CollisionDetection

[Visual Basic]
Public Delegate Sub CollisionDetectEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As CollisionDetectEventArgs _
)
[C#]
public delegate void CollisionDetectEvent(
   Gantt aGantt,
   CollisionDetectEventArgs e
);
[C++]
public: __gc __delegate void CollisionDetectEvent(
   Gantt* aGantt,
   CollisionDetectEventArgs* e
)
[C++/CLI]
public delegate void CollisionDetectEvent(
   Gantt^ aGantt,
   CollisionDetectEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

aGantt
e
See Also Requirements Languages GTP.NET.SL Send comments on this topic.

ConflictArea_Update Delegate

PlexityHide.GTP Namespace : ConflictArea_Update Delegate

The delegate for ConflictArea_Update

[Visual Basic]
Public Delegate Sub ConflictArea_Update( _
   ByVal aGantt As Gantt, _
   ByVal e As ConflictArea_UpdateArgs _
)
[C#]
public delegate void ConflictArea_Update(
   Gantt aGantt,
   ConflictArea_UpdateArgs e
);
[C++]
public: __gc __delegate void ConflictArea_Update(
   Gantt* aGantt,
   ConflictArea_UpdateArgs* e
)
[C++/CLI]
public delegate void ConflictArea_Update(
   Gantt^ aGantt,
   ConflictArea_UpdateArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

PlexityHide.GTP Namespace

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages GTP.NET.SL Send comments on this topic.

TimeDistinctThread.AsyncDelegate Delegate

PlexityHide.GTP Namespace : TimeDistinctThread.AsyncDelegate Delegate
[Visual Basic]
Public Delegate Sub TimeDistinctThread.AsyncDelegate()
[C#]
public delegate void TimeDistinctThread.AsyncDelegate();
[C++]
public: __gc __delegate void TimeDistinctThread.AsyncDelegate();
[C++/CLI]
public delegate void TimeDistinctThread.AsyncDelegate();

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: GTP.NET.SL (in GTP.NET.SL.dll)

See Also

PlexityHide.GTP Namespace


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > DateScaler Class : ActualHeight Property (DateScaler)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > DateScaler Class : ActualWidth Property (DateScaler)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > DateScaler Class : AddHandler Method (DateScaler)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > DateScaler Class : Arrange Method (DateScaler)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > DateScaler Class : Background Property (DateScaler)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > DateScaler Class : BindingValidationError Event (DateScaler)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > DateScaler Class : CacheMode Property (DateScaler)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > DateScaler Class : CaptureMouse Method (DateScaler)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > DateScaler Class : Children Property (DateScaler)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > DateScaler Class : ClearValue Method (DateScaler)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > DateScaler Class : Clip Property (DateScaler)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > DateScaler Class : Cursor Property (DateScaler)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > DateScaler Class : DataContext Property (DateScaler)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > DateScaler Class : DesiredSize Property (DateScaler)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > DateScaler Class : Dispatcher Property (DateScaler)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > DateScaler Class : Effect Property (DateScaler)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > DateScaler Class : FindName Method (DateScaler)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > DateScaler Class : GetAnimationBaseValue Method (DateScaler)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > DateScaler Class : GetBindingExpression Method (DateScaler)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > DateScaler Class : GetValue Method (DateScaler)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > DateScaler Class : GotFocus Event (DateScaler)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > DateScaler Class : Height Property (DateScaler)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > DateScaler Class : HorizontalAlignment Property (DateScaler)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > DateScaler Class : InvalidateArrange Method (DateScaler)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > DateScaler Class : InvalidateMeasure Method (DateScaler)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > DateScaler Class : IsHitTestVisible Property (DateScaler)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > DateScaler Class : IsItemsHost Property (DateScaler)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > DateScaler Class : KeyDown Event (DateScaler)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > DateScaler Class : KeyUp Event (DateScaler)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > DateScaler Class : Language Property (DateScaler)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > DateScaler Class : LayoutUpdated Event (DateScaler)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > DateScaler Class : Loaded Event (DateScaler)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > DateScaler Class : LostFocus Event (DateScaler)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > DateScaler Class : LostMouseCapture Event (DateScaler)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > DateScaler Class : Margin Property (DateScaler)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > DateScaler Class : MaxHeight Property (DateScaler)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > DateScaler Class : MaxWidth Property (DateScaler)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > DateScaler Class : Measure Method (DateScaler)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > DateScaler Class : MeasureOverride Method (DateScaler)
[Visual Basic]
Protected Overridable Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
[C#]
protected virtual Size MeasureOverride(
   Size availableSize
);
[C++]
protected: virtual Size MeasureOverride(
   Size availableSize
)
[C++/CLI]
protected:
virtual Size MeasureOverride(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > DateScaler Class : MinHeight Property (DateScaler)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > DateScaler Class : MinWidth Property (DateScaler)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > DateScaler Class : MouseEnter Event (DateScaler)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > DateScaler Class : MouseLeave Event (DateScaler)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > DateScaler Class : MouseLeftButtonDown Event (DateScaler)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > DateScaler Class : MouseLeftButtonUp Event (DateScaler)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > DateScaler Class : MouseMove Event (DateScaler)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > DateScaler Class : MouseWheel Event (DateScaler)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > DateScaler Class : Name Property (DateScaler)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > DateScaler Class : OnApplyTemplate Method (DateScaler)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > DateScaler Class : OnCreateAutomationPeer Method (DateScaler)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > DateScaler Class : Opacity Property (DateScaler)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > DateScaler Class : OpacityMask Property (DateScaler)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > DateScaler Class : Parent Property (DateScaler)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > DateScaler Class : Projection Property (DateScaler)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > DateScaler Class : ReadLocalValue Method (DateScaler)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > DateScaler Class : ReleaseMouseCapture Method (DateScaler)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > DateScaler Class : RemoveHandler Method (DateScaler)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > DateScaler Class : RenderSize Property (DateScaler)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > DateScaler Class : RenderTransform Property (DateScaler)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > DateScaler Class : RenderTransformOrigin Property (DateScaler)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > DateScaler Class : Resources Property (DateScaler)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > DateScaler Class : SetBinding Method (DateScaler)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > DateScaler Class : SetValue Method (DateScaler)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > DateScaler Class : SizeChanged Event (DateScaler)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > DateScaler Class : Style Property (DateScaler)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > DateScaler Class : Tag Property (DateScaler)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > DateScaler Class : TransformToVisual Method (DateScaler)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > DateScaler Class : Triggers Property (DateScaler)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > DateScaler Class : UpdateLayout Method (DateScaler)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > DateScaler Class : UseLayoutRounding Property (DateScaler)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > DateScaler Class : VerticalAlignment Property (DateScaler)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > DateScaler Class : Visibility Property (DateScaler)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%%

DateScaler Class | DateScaler Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > DateScaler Class : Width Property (DateScaler)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

DateScaler Class | DateScaler Members


%%PageItemTitle%% $$Events$$

GanttRowCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowCanvas Class Events

PlexityHide.GTP Namespace : GanttRowCanvas Class

For a list of all members of this type, see GanttRowCanvas members.

See Also

GanttRowCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

GanttRowCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

GanttRowCanvas Class Properties

PlexityHide.GTP Namespace : GanttRowCanvas Class

For a list of all members of this type, see GanttRowCanvas members.

See Also

GanttRowCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : ActualHeight Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : ActualWidth Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : AddHandler Method (GanttRowCanvas)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : Arrange Method (GanttRowCanvas)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : ArrangeOverride Method (GanttRowCanvas)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Background Property (GanttRowCanvas)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : BindingValidationError Event (GanttRowCanvas)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : CacheMode Property (GanttRowCanvas)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : CaptureMouse Method (GanttRowCanvas)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Children Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : ClearValue Method (GanttRowCanvas)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Clip Property (GanttRowCanvas)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Cursor Property (GanttRowCanvas)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : DataContext Property (GanttRowCanvas)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : DesiredSize Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Dispatcher Property (GanttRowCanvas)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Effect Property (GanttRowCanvas)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : FindName Method (GanttRowCanvas)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GetAnimationBaseValue Method (GanttRowCanvas)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GetBindingExpression Method (GanttRowCanvas)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : GetValue Method (GanttRowCanvas)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : GotFocus Event (GanttRowCanvas)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Height Property (GanttRowCanvas)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : HorizontalAlignment Property (GanttRowCanvas)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : InvalidateArrange Method (GanttRowCanvas)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : InvalidateMeasure Method (GanttRowCanvas)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : IsHitTestVisible Property (GanttRowCanvas)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : IsItemsHost Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : KeyDown Event (GanttRowCanvas)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : KeyUp Event (GanttRowCanvas)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Language Property (GanttRowCanvas)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : LayoutUpdated Event (GanttRowCanvas)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : Loaded Event (GanttRowCanvas)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : LostFocus Event (GanttRowCanvas)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : LostMouseCapture Event (GanttRowCanvas)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Margin Property (GanttRowCanvas)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : MaxHeight Property (GanttRowCanvas)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : MaxWidth Property (GanttRowCanvas)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : Measure Method (GanttRowCanvas)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : MeasureOverride Method (GanttRowCanvas)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : MinHeight Property (GanttRowCanvas)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : MinWidth Property (GanttRowCanvas)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseEnter Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseLeave Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseLeftButtonDown Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseLeftButtonUp Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseMove Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : MouseWheel Event (GanttRowCanvas)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Name Property (GanttRowCanvas)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : OnApplyTemplate Method (GanttRowCanvas)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : OnCreateAutomationPeer Method (GanttRowCanvas)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Opacity Property (GanttRowCanvas)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : OpacityMask Property (GanttRowCanvas)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Parent Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Projection Property (GanttRowCanvas)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : ReadLocalValue Method (GanttRowCanvas)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : ReleaseMouseCapture Method (GanttRowCanvas)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : RemoveHandler Method (GanttRowCanvas)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : RenderSize Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : RenderTransform Property (GanttRowCanvas)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : RenderTransformOrigin Property (GanttRowCanvas)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Resources Property (GanttRowCanvas)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : SetBinding Method (GanttRowCanvas)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : SetValue Method (GanttRowCanvas)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > GanttRowCanvas Class : SizeChanged Event (GanttRowCanvas)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Style Property (GanttRowCanvas)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Tag Property (GanttRowCanvas)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : TransformToVisual Method (GanttRowCanvas)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Triggers Property (GanttRowCanvas)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > GanttRowCanvas Class : UpdateLayout Method (GanttRowCanvas)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : UseLayoutRounding Property (GanttRowCanvas)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : VerticalAlignment Property (GanttRowCanvas)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Visibility Property (GanttRowCanvas)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowCanvas Class | GanttRowCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > GanttRowCanvas Class : Width Property (GanttRowCanvas)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowCanvas Class | GanttRowCanvas Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > GanttRowItem Class : ActualHeight Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > GanttRowItem Class : ActualWidth Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > GanttRowItem Class : AddHandler Method (GanttRowItem)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ApplyTemplate Method

PlexityHide.GTP Namespace > GanttRowItem Class : ApplyTemplate Method (GanttRowItem)
[Visual Basic]
Public Function ApplyTemplate() As Boolean
[C#]
public bool ApplyTemplate();
[C++]
public: bool ApplyTemplate();
[C++/CLI]
public:
bool ApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > GanttRowItem Class : Arrange Method (GanttRowItem)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > GanttRowItem Class : Background Property (GanttRowItem)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > GanttRowItem Class : BindingValidationError Event (GanttRowItem)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderBrush Property

PlexityHide.GTP Namespace > GanttRowItem Class : BorderBrush Property (GanttRowItem)
[Visual Basic]
Public Property BorderBrush As Brush
[C#]
public Brush BorderBrush {get; set;}
[C++]
public: __property Brush get_BorderBrush();
public: __property void set_BorderBrush(
   Brush value
);
[C++/CLI]
public:
property Brush BorderBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderThickness Property

PlexityHide.GTP Namespace > GanttRowItem Class : BorderThickness Property (GanttRowItem)
[Visual Basic]
Public Property BorderThickness As Thickness
[C#]
public Thickness BorderThickness {get; set;}
[C++]
public: __property Thickness get_BorderThickness();
public: __property void set_BorderThickness(
   Thickness value
);
[C++/CLI]
public:
property Thickness BorderThickness {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > GanttRowItem Class : CacheMode Property (GanttRowItem)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > GanttRowItem Class : CaptureMouse Method (GanttRowItem)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > GanttRowItem Class : ClearValue Method (GanttRowItem)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > GanttRowItem Class : Clip Property (GanttRowItem)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Content Property

PlexityHide.GTP Namespace > GanttRowItem Class : Content Property (GanttRowItem)
[Visual Basic]
Public Property Content As Object
[C#]
public object Content {get; set;}
[C++]
public: __property Object* get_Content();
public: __property void set_Content(
   Object* value
);
[C++/CLI]
public:
property Object^ Content {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ContentTemplate Property

PlexityHide.GTP Namespace > GanttRowItem Class : ContentTemplate Property (GanttRowItem)
[Visual Basic]
Public Property ContentTemplate As DataTemplate
[C#]
public DataTemplate ContentTemplate {get; set;}
[C++]
public: __property DataTemplate get_ContentTemplate();
public: __property void set_ContentTemplate(
   DataTemplate value
);
[C++/CLI]
public:
property DataTemplate ContentTemplate {
   DataTemplate get();
   void set (DataTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > GanttRowItem Class : Cursor Property (GanttRowItem)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > GanttRowItem Class : DataContext Property (GanttRowItem)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DefaultStyleKey Property

PlexityHide.GTP Namespace > GanttRowItem Class : DefaultStyleKey Property (GanttRowItem)
[Visual Basic]
Protected Property DefaultStyleKey As Object
[C#]
protected object DefaultStyleKey {get; set;}
[C++]
protected: __property Object* get_DefaultStyleKey();
protected: __property void set_DefaultStyleKey(
   Object* value
);
[C++/CLI]
protected:
property Object^ DefaultStyleKey {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > GanttRowItem Class : DesiredSize Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > GanttRowItem Class : Dispatcher Property (GanttRowItem)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > GanttRowItem Class : Effect Property (GanttRowItem)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > GanttRowItem Class : FindName Method (GanttRowItem)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Focus Method

PlexityHide.GTP Namespace > GanttRowItem Class : Focus Method (GanttRowItem)
[Visual Basic]
Public Function Focus() As Boolean
[C#]
public bool Focus();
[C++]
public: bool Focus();
[C++/CLI]
public:
bool Focus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontFamily Property

PlexityHide.GTP Namespace > GanttRowItem Class : FontFamily Property (GanttRowItem)
[Visual Basic]
Public Property FontFamily As FontFamily
[C#]
public FontFamily FontFamily {get; set;}
[C++]
public: __property FontFamily get_FontFamily();
public: __property void set_FontFamily(
   FontFamily value
);
[C++/CLI]
public:
property FontFamily FontFamily {
   FontFamily get();
   void set (FontFamily value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontSize Property

PlexityHide.GTP Namespace > GanttRowItem Class : FontSize Property (GanttRowItem)
[Visual Basic]
Public Property FontSize As Double
[C#]
public double FontSize {get; set;}
[C++]
public: __property double get_FontSize();
public: __property void set_FontSize(
   double value
);
[C++/CLI]
public:
property double FontSize {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStretch Property

PlexityHide.GTP Namespace > GanttRowItem Class : FontStretch Property (GanttRowItem)
[Visual Basic]
Public Property FontStretch As FontStretch
[C#]
public FontStretch FontStretch {get; set;}
[C++]
public: __property FontStretch get_FontStretch();
public: __property void set_FontStretch(
   FontStretch value
);
[C++/CLI]
public:
property FontStretch FontStretch {
   FontStretch get();
   void set (FontStretch value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStyle Property

PlexityHide.GTP Namespace > GanttRowItem Class : FontStyle Property (GanttRowItem)
[Visual Basic]
Public Property FontStyle As FontStyle
[C#]
public FontStyle FontStyle {get; set;}
[C++]
public: __property FontStyle get_FontStyle();
public: __property void set_FontStyle(
   FontStyle value
);
[C++/CLI]
public:
property FontStyle FontStyle {
   FontStyle get();
   void set (FontStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontWeight Property

PlexityHide.GTP Namespace > GanttRowItem Class : FontWeight Property (GanttRowItem)
[Visual Basic]
Public Property FontWeight As FontWeight
[C#]
public FontWeight FontWeight {get; set;}
[C++]
public: __property FontWeight get_FontWeight();
public: __property void set_FontWeight(
   FontWeight value
);
[C++/CLI]
public:
property FontWeight FontWeight {
   FontWeight get();
   void set (FontWeight value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Foreground Property

PlexityHide.GTP Namespace > GanttRowItem Class : Foreground Property (GanttRowItem)
[Visual Basic]
Public Property Foreground As Brush
[C#]
public Brush Foreground {get; set;}
[C++]
public: __property Brush get_Foreground();
public: __property void set_Foreground(
   Brush value
);
[C++/CLI]
public:
property Brush Foreground {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > GanttRowItem Class : GetAnimationBaseValue Method (GanttRowItem)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > GanttRowItem Class : GetBindingExpression Method (GanttRowItem)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

childName
See Also Languages GTP.NET.SL Send comments on this topic.

GetTemplateChild Method

PlexityHide.GTP Namespace > GanttRowItem Class : GetTemplateChild Method (GanttRowItem)
[Visual Basic]
Protected Function GetTemplateChild( _
   ByVal childName As String _
) As DependencyObject
[C#]
protected DependencyObject GetTemplateChild(
   string childName
);
[C++]
protected: DependencyObject GetTemplateChild(
   string* childName
)
[C++/CLI]
protected:
DependencyObject GetTemplateChild(
   String^ childName
)

Parameters

childName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > GanttRowItem Class : GetValue Method (GanttRowItem)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > GanttRowItem Class : GotFocus Event (GanttRowItem)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > GanttRowItem Class : Height Property (GanttRowItem)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > GanttRowItem Class : HorizontalAlignment Property (GanttRowItem)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalContentAlignment Property

PlexityHide.GTP Namespace > GanttRowItem Class : HorizontalContentAlignment Property (GanttRowItem)
[Visual Basic]
Public Property HorizontalContentAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalContentAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalContentAlignment();
public: __property void set_HorizontalContentAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalContentAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > GanttRowItem Class : InvalidateArrange Method (GanttRowItem)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > GanttRowItem Class : InvalidateMeasure Method (GanttRowItem)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabled Property

PlexityHide.GTP Namespace > GanttRowItem Class : IsEnabled Property (GanttRowItem)
[Visual Basic]
Public Property IsEnabled As Boolean
[C#]
public bool IsEnabled {get; set;}
[C++]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
[C++/CLI]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabledChanged Event

PlexityHide.GTP Namespace > GanttRowItem Class : IsEnabledChanged Event (GanttRowItem)
[Visual Basic]
Public Event IsEnabledChanged() As DependencyPropertyChangedEventHandler
[C#]
public event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++]
public: __event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++/CLI]
public:
event DependencyPropertyChangedEventHandler IsEnabledChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > GanttRowItem Class : IsHitTestVisible Property (GanttRowItem)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsSelected Property

PlexityHide.GTP Namespace > GanttRowItem Class : IsSelected Property
[Visual Basic]
Public Property IsSelected As Boolean
[C#]
public bool IsSelected {get; set;}
[C++]
public: __property bool get_IsSelected();
public: __property void set_IsSelected(
   bool value
);
[C++/CLI]
public:
property bool IsSelected {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsTabStop Property

PlexityHide.GTP Namespace > GanttRowItem Class : IsTabStop Property (GanttRowItem)
[Visual Basic]
Public Property IsTabStop As Boolean
[C#]
public bool IsTabStop {get; set;}
[C++]
public: __property bool get_IsTabStop();
public: __property void set_IsTabStop(
   bool value
);
[C++/CLI]
public:
property bool IsTabStop {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > GanttRowItem Class : KeyDown Event (GanttRowItem)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > GanttRowItem Class : KeyUp Event (GanttRowItem)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > GanttRowItem Class : Language Property (GanttRowItem)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > GanttRowItem Class : LayoutUpdated Event (GanttRowItem)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > GanttRowItem Class : Loaded Event (GanttRowItem)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > GanttRowItem Class : LostFocus Event (GanttRowItem)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > GanttRowItem Class : LostMouseCapture Event (GanttRowItem)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > GanttRowItem Class : Margin Property (GanttRowItem)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > GanttRowItem Class : MaxHeight Property (GanttRowItem)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > GanttRowItem Class : MaxWidth Property (GanttRowItem)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > GanttRowItem Class : Measure Method (GanttRowItem)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > GanttRowItem Class : MinHeight Property (GanttRowItem)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > GanttRowItem Class : MinWidth Property (GanttRowItem)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseEnter Event (GanttRowItem)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseLeave Event (GanttRowItem)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseLeftButtonDown Event (GanttRowItem)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseLeftButtonUp Event (GanttRowItem)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseMove Event (GanttRowItem)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > GanttRowItem Class : MouseWheel Event (GanttRowItem)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > GanttRowItem Class : Name Property (GanttRowItem)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

oldContent
newContent
See Also Languages GTP.NET.SL Send comments on this topic.

OnContentChanged Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnContentChanged Method
[Visual Basic]
Protected Overridable Sub OnContentChanged( _
   ByVal oldContent As Object, _
   ByVal newContent As Object _
)
[C#]
protected virtual void OnContentChanged(
   object oldContent,
   object newContent
);
[C++]
protected: virtual void OnContentChanged(
   Object* oldContent,
   Object* newContent
)
[C++/CLI]
protected:
virtual void OnContentChanged(
   Object^ oldContent,
   Object^ newContent
)

Parameters

oldContent
newContent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnCreateAutomationPeer Method (GanttRowItem)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnGotFocus Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnGotFocus Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnGotFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnGotFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnGotFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnGotFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyDown Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnKeyDown Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyDown(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyDown(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyDown(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyUp Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnKeyUp Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyUp(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyUp(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyUp(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostFocus Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnLostFocus Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnLostFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnLostFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnLostFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostMouseCapture Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnLostMouseCapture Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnLostMouseCapture( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnLostMouseCapture(
   MouseEventArgs e
);
[C++]
protected: virtual void OnLostMouseCapture(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostMouseCapture(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseEnter Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseEnter Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseEnter( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseEnter(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseEnter(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseEnter(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeave Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseLeave Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseLeave( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseLeave(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseLeave(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeave(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonDown Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseLeftButtonDown Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonDown( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonUp Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseLeftButtonUp Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonUp( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseMove Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseMove Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseMove(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseMove(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseMove(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseWheel Method

PlexityHide.GTP Namespace > GanttRowItem Class : OnMouseWheel Method (GanttRowItem)
[Visual Basic]
Protected Overridable Sub OnMouseWheel( _
   ByVal e As MouseWheelEventArgs _
)
[C#]
protected virtual void OnMouseWheel(
   MouseWheelEventArgs e
);
[C++]
protected: virtual void OnMouseWheel(
   MouseWheelEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseWheel(
   MouseWheelEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > GanttRowItem Class : Opacity Property (GanttRowItem)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > GanttRowItem Class : OpacityMask Property (GanttRowItem)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Padding Property

PlexityHide.GTP Namespace > GanttRowItem Class : Padding Property (GanttRowItem)
[Visual Basic]
Public Property Padding As Thickness
[C#]
public Thickness Padding {get; set;}
[C++]
public: __property Thickness get_Padding();
public: __property void set_Padding(
   Thickness value
);
[C++/CLI]
public:
property Thickness Padding {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > GanttRowItem Class : Parent Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > GanttRowItem Class : Projection Property (GanttRowItem)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > GanttRowItem Class : ReadLocalValue Method (GanttRowItem)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > GanttRowItem Class : ReleaseMouseCapture Method (GanttRowItem)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > GanttRowItem Class : RemoveHandler Method (GanttRowItem)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > GanttRowItem Class : RenderSize Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > GanttRowItem Class : RenderTransform Property (GanttRowItem)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > GanttRowItem Class : RenderTransformOrigin Property (GanttRowItem)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > GanttRowItem Class : Resources Property (GanttRowItem)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > GanttRowItem Class : SetBinding Method (GanttRowItem)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > GanttRowItem Class : SetValue Method (GanttRowItem)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > GanttRowItem Class : SizeChanged Event (GanttRowItem)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > GanttRowItem Class : Style Property (GanttRowItem)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabIndex Property

PlexityHide.GTP Namespace > GanttRowItem Class : TabIndex Property (GanttRowItem)
[Visual Basic]
Public Property TabIndex As Integer
[C#]
public int TabIndex {get; set;}
[C++]
public: __property int get_TabIndex();
public: __property void set_TabIndex(
   int value
);
[C++/CLI]
public:
property int TabIndex {
   int get();
   void set (int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabNavigation Property

PlexityHide.GTP Namespace > GanttRowItem Class : TabNavigation Property (GanttRowItem)
[Visual Basic]
Public Property TabNavigation As KeyboardNavigationMode
[C#]
public KeyboardNavigationMode TabNavigation {get; set;}
[C++]
public: __property KeyboardNavigationMode get_TabNavigation();
public: __property void set_TabNavigation(
   KeyboardNavigationMode value
);
[C++/CLI]
public:
property KeyboardNavigationMode TabNavigation {
   KeyboardNavigationMode get();
   void set (KeyboardNavigationMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > GanttRowItem Class : Tag Property (GanttRowItem)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Template Property

PlexityHide.GTP Namespace > GanttRowItem Class : Template Property (GanttRowItem)
[Visual Basic]
Public Property Template As ControlTemplate
[C#]
public ControlTemplate Template {get; set;}
[C++]
public: __property ControlTemplate get_Template();
public: __property void set_Template(
   ControlTemplate value
);
[C++/CLI]
public:
property ControlTemplate Template {
   ControlTemplate get();
   void set (ControlTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > GanttRowItem Class : TransformToVisual Method (GanttRowItem)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > GanttRowItem Class : Triggers Property (GanttRowItem)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > GanttRowItem Class : UpdateLayout Method (GanttRowItem)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > GanttRowItem Class : UseLayoutRounding Property (GanttRowItem)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > GanttRowItem Class : VerticalAlignment Property (GanttRowItem)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalContentAlignment Property

PlexityHide.GTP Namespace > GanttRowItem Class : VerticalContentAlignment Property (GanttRowItem)
[Visual Basic]
Public Property VerticalContentAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalContentAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalContentAlignment();
public: __property void set_VerticalContentAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalContentAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > GanttRowItem Class : Visibility Property (GanttRowItem)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRowItem Class | GanttRowItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > GanttRowItem Class : Width Property (GanttRowItem)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRowItem Class | GanttRowItem Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > GanttRow Class : ActualHeight Property (GanttRow)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > GanttRow Class : ActualWidth Property (GanttRow)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > GanttRow Class : AddHandler Method (GanttRow)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ApplyTemplate Method

PlexityHide.GTP Namespace > GanttRow Class : ApplyTemplate Method (GanttRow)
[Visual Basic]
Public Function ApplyTemplate() As Boolean
[C#]
public bool ApplyTemplate();
[C++]
public: bool ApplyTemplate();
[C++/CLI]
public:
bool ApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > GanttRow Class : Arrange Method (GanttRow)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > GanttRow Class : Background Property (GanttRow)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > GanttRow Class : BindingValidationError Event (GanttRow)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderBrush Property

PlexityHide.GTP Namespace > GanttRow Class : BorderBrush Property (GanttRow)
[Visual Basic]
Public Property BorderBrush As Brush
[C#]
public Brush BorderBrush {get; set;}
[C++]
public: __property Brush get_BorderBrush();
public: __property void set_BorderBrush(
   Brush value
);
[C++/CLI]
public:
property Brush BorderBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderThickness Property

PlexityHide.GTP Namespace > GanttRow Class : BorderThickness Property (GanttRow)
[Visual Basic]
Public Property BorderThickness As Thickness
[C#]
public Thickness BorderThickness {get; set;}
[C++]
public: __property Thickness get_BorderThickness();
public: __property void set_BorderThickness(
   Thickness value
);
[C++/CLI]
public:
property Thickness BorderThickness {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > GanttRow Class : CacheMode Property (GanttRow)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > GanttRow Class : CaptureMouse Method (GanttRow)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > GanttRow Class : ClearValue Method (GanttRow)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > GanttRow Class : Clip Property (GanttRow)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > GanttRow Class : Cursor Property (GanttRow)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > GanttRow Class : DataContext Property (GanttRow)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DefaultStyleKey Property

PlexityHide.GTP Namespace > GanttRow Class : DefaultStyleKey Property (GanttRow)
[Visual Basic]
Protected Property DefaultStyleKey As Object
[C#]
protected object DefaultStyleKey {get; set;}
[C++]
protected: __property Object* get_DefaultStyleKey();
protected: __property void set_DefaultStyleKey(
   Object* value
);
[C++/CLI]
protected:
property Object^ DefaultStyleKey {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > GanttRow Class : DesiredSize Property (GanttRow)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > GanttRow Class : Dispatcher Property (GanttRow)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DisplayMemberPath Property

PlexityHide.GTP Namespace > GanttRow Class : DisplayMemberPath Property (GanttRow)
[Visual Basic]
Public Property DisplayMemberPath As String
[C#]
public string DisplayMemberPath {get; set;}
[C++]
public: __property string* get_DisplayMemberPath();
public: __property void set_DisplayMemberPath(
   string* value
);
[C++/CLI]
public:
property String^ DisplayMemberPath {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > GanttRow Class : Effect Property (GanttRow)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > GanttRow Class : FindName Method (GanttRow)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Focus Method

PlexityHide.GTP Namespace > GanttRow Class : Focus Method (GanttRow)
[Visual Basic]
Public Function Focus() As Boolean
[C#]
public bool Focus();
[C++]
public: bool Focus();
[C++/CLI]
public:
bool Focus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontFamily Property

PlexityHide.GTP Namespace > GanttRow Class : FontFamily Property (GanttRow)
[Visual Basic]
Public Property FontFamily As FontFamily
[C#]
public FontFamily FontFamily {get; set;}
[C++]
public: __property FontFamily get_FontFamily();
public: __property void set_FontFamily(
   FontFamily value
);
[C++/CLI]
public:
property FontFamily FontFamily {
   FontFamily get();
   void set (FontFamily value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontSize Property

PlexityHide.GTP Namespace > GanttRow Class : FontSize Property (GanttRow)
[Visual Basic]
Public Property FontSize As Double
[C#]
public double FontSize {get; set;}
[C++]
public: __property double get_FontSize();
public: __property void set_FontSize(
   double value
);
[C++/CLI]
public:
property double FontSize {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStretch Property

PlexityHide.GTP Namespace > GanttRow Class : FontStretch Property (GanttRow)
[Visual Basic]
Public Property FontStretch As FontStretch
[C#]
public FontStretch FontStretch {get; set;}
[C++]
public: __property FontStretch get_FontStretch();
public: __property void set_FontStretch(
   FontStretch value
);
[C++/CLI]
public:
property FontStretch FontStretch {
   FontStretch get();
   void set (FontStretch value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStyle Property

PlexityHide.GTP Namespace > GanttRow Class : FontStyle Property (GanttRow)
[Visual Basic]
Public Property FontStyle As FontStyle
[C#]
public FontStyle FontStyle {get; set;}
[C++]
public: __property FontStyle get_FontStyle();
public: __property void set_FontStyle(
   FontStyle value
);
[C++/CLI]
public:
property FontStyle FontStyle {
   FontStyle get();
   void set (FontStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontWeight Property

PlexityHide.GTP Namespace > GanttRow Class : FontWeight Property (GanttRow)
[Visual Basic]
Public Property FontWeight As FontWeight
[C#]
public FontWeight FontWeight {get; set;}
[C++]
public: __property FontWeight get_FontWeight();
public: __property void set_FontWeight(
   FontWeight value
);
[C++/CLI]
public:
property FontWeight FontWeight {
   FontWeight get();
   void set (FontWeight value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Foreground Property

PlexityHide.GTP Namespace > GanttRow Class : Foreground Property (GanttRow)
[Visual Basic]
Public Property Foreground As Brush
[C#]
public Brush Foreground {get; set;}
[C++]
public: __property Brush get_Foreground();
public: __property void set_Foreground(
   Brush value
);
[C++/CLI]
public:
property Brush Foreground {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > GanttRow Class : GetAnimationBaseValue Method (GanttRow)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > GanttRow Class : GetBindingExpression Method (GanttRow)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

childName
See Also Languages GTP.NET.SL Send comments on this topic.

GetTemplateChild Method

PlexityHide.GTP Namespace > GanttRow Class : GetTemplateChild Method (GanttRow)
[Visual Basic]
Protected Function GetTemplateChild( _
   ByVal childName As String _
) As DependencyObject
[C#]
protected DependencyObject GetTemplateChild(
   string childName
);
[C++]
protected: DependencyObject GetTemplateChild(
   string* childName
)
[C++/CLI]
protected:
DependencyObject GetTemplateChild(
   String^ childName
)

Parameters

childName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > GanttRow Class : GetValue Method (GanttRow)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > GanttRow Class : GotFocus Event (GanttRow)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > GanttRow Class : Height Property (GanttRow)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > GanttRow Class : HorizontalAlignment Property (GanttRow)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalContentAlignment Property

PlexityHide.GTP Namespace > GanttRow Class : HorizontalContentAlignment Property (GanttRow)
[Visual Basic]
Public Property HorizontalContentAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalContentAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalContentAlignment();
public: __property void set_HorizontalContentAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalContentAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > GanttRow Class : InvalidateArrange Method (GanttRow)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > GanttRow Class : InvalidateMeasure Method (GanttRow)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabled Property

PlexityHide.GTP Namespace > GanttRow Class : IsEnabled Property (GanttRow)
[Visual Basic]
Public Property IsEnabled As Boolean
[C#]
public bool IsEnabled {get; set;}
[C++]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
[C++/CLI]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabledChanged Event

PlexityHide.GTP Namespace > GanttRow Class : IsEnabledChanged Event (GanttRow)
[Visual Basic]
Public Event IsEnabledChanged() As DependencyPropertyChangedEventHandler
[C#]
public event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++]
public: __event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++/CLI]
public:
event DependencyPropertyChangedEventHandler IsEnabledChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > GanttRow Class : IsHitTestVisible Property (GanttRow)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsSynchronizedWithCurrentItem Property

PlexityHide.GTP Namespace > GanttRow Class : IsSynchronizedWithCurrentItem Property
[Visual Basic]
<TypeConverterAttribute("System.Windows.NullableBoolConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")>
Public Property IsSynchronizedWithCurrentItem As Nullable(Of Boolean)
[C#]
[TypeConverterAttribute("System.Windows.NullableBoolConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public Nullable<bool> IsSynchronizedWithCurrentItem {get; set;}
[C++]
[TypeConverterAttribute("System.Windows.NullableBoolConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public: __property Nullable<bool> get_IsSynchronizedWithCurrentItem();
public: __property void set_IsSynchronizedWithCurrentItem(
   Nullable<bool> value
);
[C++/CLI]
[TypeConverterAttribute("System.Windows.NullableBoolConverter, System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e")]
public:
property Nullable<bool> IsSynchronizedWithCurrentItem {
   Nullable<bool> get();
   void set (Nullable<bool> value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsTabStop Property

PlexityHide.GTP Namespace > GanttRow Class : IsTabStop Property (GanttRow)
[Visual Basic]
Public Property IsTabStop As Boolean
[C#]
public bool IsTabStop {get; set;}
[C++]
public: __property bool get_IsTabStop();
public: __property void set_IsTabStop(
   bool value
);
[C++/CLI]
public:
property bool IsTabStop {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemContainerGenerator Property

PlexityHide.GTP Namespace > GanttRow Class : ItemContainerGenerator Property (GanttRow)
[Visual Basic]
Public ReadOnly Property ItemContainerGenerator As ItemContainerGenerator
[C#]
public ItemContainerGenerator ItemContainerGenerator {get;}
[C++]
public: __property ItemContainerGenerator get_ItemContainerGenerator();
[C++/CLI]
public:
property ItemContainerGenerator ItemContainerGenerator {
   ItemContainerGenerator get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemContainerStyle Property

PlexityHide.GTP Namespace > GanttRow Class : ItemContainerStyle Property
[Visual Basic]
Public Property ItemContainerStyle As Style
[C#]
public Style ItemContainerStyle {get; set;}
[C++]
public: __property Style get_ItemContainerStyle();
public: __property void set_ItemContainerStyle(
   Style value
);
[C++/CLI]
public:
property Style ItemContainerStyle {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Items Property

PlexityHide.GTP Namespace > GanttRow Class : Items Property (GanttRow)
[Visual Basic]
Public ReadOnly Property Items As ItemCollection
[C#]
public ItemCollection Items {get;}
[C++]
public: __property ItemCollection get_Items();
[C++/CLI]
public:
property ItemCollection Items {
   ItemCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemsPanel Property

PlexityHide.GTP Namespace > GanttRow Class : ItemsPanel Property (GanttRow)
[Visual Basic]
Public Property ItemsPanel As ItemsPanelTemplate
[C#]
public ItemsPanelTemplate ItemsPanel {get; set;}
[C++]
public: __property ItemsPanelTemplate get_ItemsPanel();
public: __property void set_ItemsPanel(
   ItemsPanelTemplate value
);
[C++/CLI]
public:
property ItemsPanelTemplate ItemsPanel {
   ItemsPanelTemplate get();
   void set (ItemsPanelTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemsSource Property

PlexityHide.GTP Namespace > GanttRow Class : ItemsSource Property (GanttRow)
[Visual Basic]
Public Property ItemsSource As IEnumerable
[C#]
public IEnumerable ItemsSource {get; set;}
[C++]
public: __property IEnumerable* get_ItemsSource();
public: __property void set_ItemsSource(
   IEnumerable* value
);
[C++/CLI]
public:
property IEnumerable^ ItemsSource {
   IEnumerable^ get();
   void set (IEnumerable^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemTemplate Property

PlexityHide.GTP Namespace > GanttRow Class : ItemTemplate Property (GanttRow)
[Visual Basic]
Public Property ItemTemplate As DataTemplate
[C#]
public DataTemplate ItemTemplate {get; set;}
[C++]
public: __property DataTemplate get_ItemTemplate();
public: __property void set_ItemTemplate(
   DataTemplate value
);
[C++/CLI]
public:
property DataTemplate ItemTemplate {
   DataTemplate get();
   void set (DataTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > GanttRow Class : KeyDown Event (GanttRow)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > GanttRow Class : KeyUp Event (GanttRow)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > GanttRow Class : Language Property (GanttRow)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > GanttRow Class : LayoutUpdated Event (GanttRow)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > GanttRow Class : Loaded Event (GanttRow)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > GanttRow Class : LostFocus Event (GanttRow)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > GanttRow Class : LostMouseCapture Event (GanttRow)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > GanttRow Class : Margin Property (GanttRow)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > GanttRow Class : MaxHeight Property (GanttRow)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > GanttRow Class : MaxWidth Property (GanttRow)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > GanttRow Class : Measure Method (GanttRow)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > GanttRow Class : MeasureOverride Method (GanttRow)
[Visual Basic]
Protected Overridable Function MeasureOverride( _
   ByVal availableSize As Size _
) As Size
[C#]
protected virtual Size MeasureOverride(
   Size availableSize
);
[C++]
protected: virtual Size MeasureOverride(
   Size availableSize
)
[C++/CLI]
protected:
virtual Size MeasureOverride(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > GanttRow Class : MinHeight Property (GanttRow)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > GanttRow Class : MinWidth Property (GanttRow)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > GanttRow Class : MouseEnter Event (GanttRow)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeave Event (GanttRow)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeftButtonDown Event (GanttRow)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > GanttRow Class : MouseLeftButtonUp Event (GanttRow)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > GanttRow Class : MouseMove Event (GanttRow)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > GanttRow Class : MouseWheel Event (GanttRow)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > GanttRow Class : Name Property (GanttRow)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > GanttRow Class : OnCreateAutomationPeer Method (GanttRow)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnGotFocus Method

PlexityHide.GTP Namespace > GanttRow Class : OnGotFocus Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnGotFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnGotFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnGotFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnGotFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyDown Method

PlexityHide.GTP Namespace > GanttRow Class : OnKeyDown Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyDown(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyDown(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyDown(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyUp Method

PlexityHide.GTP Namespace > GanttRow Class : OnKeyUp Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyUp(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyUp(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyUp(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostFocus Method

PlexityHide.GTP Namespace > GanttRow Class : OnLostFocus Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnLostFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnLostFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnLostFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostMouseCapture Method

PlexityHide.GTP Namespace > GanttRow Class : OnLostMouseCapture Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnLostMouseCapture( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnLostMouseCapture(
   MouseEventArgs e
);
[C++]
protected: virtual void OnLostMouseCapture(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostMouseCapture(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseEnter Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseEnter Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseEnter( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseEnter(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseEnter(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseEnter(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeave Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseLeave Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseLeave( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseLeave(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseLeave(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeave(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonDown Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseLeftButtonDown Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonDown( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonUp Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseLeftButtonUp Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonUp( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseMove Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseMove Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseMove(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseMove(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseMove(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseWheel Method

PlexityHide.GTP Namespace > GanttRow Class : OnMouseWheel Method (GanttRow)
[Visual Basic]
Protected Overridable Sub OnMouseWheel( _
   ByVal e As MouseWheelEventArgs _
)
[C#]
protected virtual void OnMouseWheel(
   MouseWheelEventArgs e
);
[C++]
protected: virtual void OnMouseWheel(
   MouseWheelEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseWheel(
   MouseWheelEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > GanttRow Class : Opacity Property (GanttRow)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > GanttRow Class : OpacityMask Property (GanttRow)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Padding Property

PlexityHide.GTP Namespace > GanttRow Class : Padding Property (GanttRow)
[Visual Basic]
Public Property Padding As Thickness
[C#]
public Thickness Padding {get; set;}
[C++]
public: __property Thickness get_Padding();
public: __property void set_Padding(
   Thickness value
);
[C++/CLI]
public:
property Thickness Padding {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > GanttRow Class : Parent Property (GanttRow)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > GanttRow Class : Projection Property (GanttRow)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > GanttRow Class : ReadLocalValue Method (GanttRow)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > GanttRow Class : ReleaseMouseCapture Method (GanttRow)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > GanttRow Class : RemoveHandler Method (GanttRow)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > GanttRow Class : RenderSize Property (GanttRow)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > GanttRow Class : RenderTransform Property (GanttRow)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > GanttRow Class : RenderTransformOrigin Property (GanttRow)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > GanttRow Class : Resources Property (GanttRow)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

item
See Also Languages GTP.NET.SL Send comments on this topic.

ScrollIntoView Method

PlexityHide.GTP Namespace > GanttRow Class : ScrollIntoView Method
[Visual Basic]
Public Sub ScrollIntoView( _
   ByVal item As Object _
)
[C#]
public void ScrollIntoView(
   object item
);
[C++]
public: void ScrollIntoView(
   Object* item
)
[C++/CLI]
public:
void ScrollIntoView(
   Object^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectedIndex Property

PlexityHide.GTP Namespace > GanttRow Class : SelectedIndex Property
[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}
[C++]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
[C++/CLI]
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectedItem Property

PlexityHide.GTP Namespace > GanttRow Class : SelectedItem Property
[Visual Basic]
Public Property SelectedItem As Object
[C#]
public object SelectedItem {get; set;}
[C++]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
[C++/CLI]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectedItems Property

PlexityHide.GTP Namespace > GanttRow Class : SelectedItems Property
[Visual Basic]
Public ReadOnly Property SelectedItems As IList
[C#]
public IList SelectedItems {get;}
[C++]
public: __property IList* get_SelectedItems();
[C++/CLI]
public:
property IList^ SelectedItems {
   IList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectionChanged Event

PlexityHide.GTP Namespace > GanttRow Class : SelectionChanged Event (GanttRow)
[Visual Basic]
Public Event SelectionChanged() As SelectionChangedEventHandler
[C#]
public event SelectionChangedEventHandler SelectionChanged();
[C++]
public: __event SelectionChangedEventHandler SelectionChanged();
[C++/CLI]
public:
event SelectionChangedEventHandler SelectionChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SelectionMode Property

PlexityHide.GTP Namespace > GanttRow Class : SelectionMode Property
[Visual Basic]
Public Property SelectionMode As SelectionMode
[C#]
public SelectionMode SelectionMode {get; set;}
[C++]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
[C++/CLI]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (SelectionMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > GanttRow Class : SetBinding Method (GanttRow)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > GanttRow Class : SetValue Method (GanttRow)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > GanttRow Class : SizeChanged Event (GanttRow)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > GanttRow Class : Style Property (GanttRow)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabIndex Property

PlexityHide.GTP Namespace > GanttRow Class : TabIndex Property (GanttRow)
[Visual Basic]
Public Property TabIndex As Integer
[C#]
public int TabIndex {get; set;}
[C++]
public: __property int get_TabIndex();
public: __property void set_TabIndex(
   int value
);
[C++/CLI]
public:
property int TabIndex {
   int get();
   void set (int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabNavigation Property

PlexityHide.GTP Namespace > GanttRow Class : TabNavigation Property (GanttRow)
[Visual Basic]
Public Property TabNavigation As KeyboardNavigationMode
[C#]
public KeyboardNavigationMode TabNavigation {get; set;}
[C++]
public: __property KeyboardNavigationMode get_TabNavigation();
public: __property void set_TabNavigation(
   KeyboardNavigationMode value
);
[C++/CLI]
public:
property KeyboardNavigationMode TabNavigation {
   KeyboardNavigationMode get();
   void set (KeyboardNavigationMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > GanttRow Class : Tag Property (GanttRow)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Template Property

PlexityHide.GTP Namespace > GanttRow Class : Template Property (GanttRow)
[Visual Basic]
Public Property Template As ControlTemplate
[C#]
public ControlTemplate Template {get; set;}
[C++]
public: __property ControlTemplate get_Template();
public: __property void set_Template(
   ControlTemplate value
);
[C++/CLI]
public:
property ControlTemplate Template {
   ControlTemplate get();
   void set (ControlTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > GanttRow Class : TransformToVisual Method (GanttRow)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > GanttRow Class : Triggers Property (GanttRow)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > GanttRow Class : UpdateLayout Method (GanttRow)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > GanttRow Class : UseLayoutRounding Property (GanttRow)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > GanttRow Class : VerticalAlignment Property (GanttRow)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalContentAlignment Property

PlexityHide.GTP Namespace > GanttRow Class : VerticalContentAlignment Property (GanttRow)
[Visual Basic]
Public Property VerticalContentAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalContentAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalContentAlignment();
public: __property void set_VerticalContentAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalContentAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > GanttRow Class : Visibility Property (GanttRow)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

GanttRow Class | GanttRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > GanttRow Class : Width Property (GanttRow)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

GanttRow Class | GanttRow Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > Gantt Class : ActualHeight Property (Gantt)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > Gantt Class : ActualWidth Property (Gantt)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > Gantt Class : AddHandler Method (Gantt)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > Gantt Class : Arrange Method (Gantt)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > Gantt Class : ArrangeOverride Method (Gantt)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > Gantt Class : Background Property (Gantt)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > Gantt Class : BindingValidationError Event (Gantt)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > Gantt Class : CacheMode Property (Gantt)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > Gantt Class : CaptureMouse Method (Gantt)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > Gantt Class : Children Property (Gantt)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > Gantt Class : ClearValue Method (Gantt)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > Gantt Class : Clip Property (Gantt)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ColumnDefinitions Property

PlexityHide.GTP Namespace > Gantt Class : ColumnDefinitions Property (Gantt)
[Visual Basic]
Public ReadOnly Property ColumnDefinitions As ColumnDefinitionCollection
[C#]
public ColumnDefinitionCollection ColumnDefinitions {get;}
[C++]
public: __property ColumnDefinitionCollection get_ColumnDefinitions();
[C++/CLI]
public:
property ColumnDefinitionCollection ColumnDefinitions {
   ColumnDefinitionCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > Gantt Class : Cursor Property (Gantt)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > Gantt Class : DataContext Property (Gantt)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > Gantt Class : DesiredSize Property (Gantt)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > Gantt Class : Dispatcher Property (Gantt)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > Gantt Class : Effect Property (Gantt)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > Gantt Class : FindName Method (Gantt)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > Gantt Class : GetAnimationBaseValue Method (Gantt)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > Gantt Class : GetBindingExpression Method (Gantt)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > Gantt Class : GetValue Method (Gantt)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > Gantt Class : GotFocus Event (Gantt)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > Gantt Class : Height Property (Gantt)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > Gantt Class : HorizontalAlignment Property (Gantt)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > Gantt Class : InvalidateArrange Method (Gantt)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > Gantt Class : InvalidateMeasure Method (Gantt)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > Gantt Class : IsHitTestVisible Property (Gantt)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > Gantt Class : IsItemsHost Property (Gantt)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > Gantt Class : KeyDown Event (Gantt)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > Gantt Class : KeyUp Event (Gantt)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > Gantt Class : Language Property (Gantt)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > Gantt Class : LayoutUpdated Event (Gantt)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > Gantt Class : Loaded Event (Gantt)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > Gantt Class : LostFocus Event (Gantt)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > Gantt Class : LostMouseCapture Event (Gantt)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > Gantt Class : Margin Property (Gantt)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > Gantt Class : MaxHeight Property (Gantt)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > Gantt Class : MaxWidth Property (Gantt)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > Gantt Class : Measure Method (Gantt)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > Gantt Class : MeasureOverride Method (Gantt)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > Gantt Class : MinHeight Property (Gantt)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > Gantt Class : MinWidth Property (Gantt)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > Gantt Class : MouseEnter Event (Gantt)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > Gantt Class : MouseLeave Event (Gantt)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > Gantt Class : MouseLeftButtonDown Event (Gantt)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > Gantt Class : MouseLeftButtonUp Event (Gantt)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > Gantt Class : MouseMove Event (Gantt)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > Gantt Class : MouseWheel Event (Gantt)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > Gantt Class : Name Property (Gantt)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > Gantt Class : OnApplyTemplate Method (Gantt)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > Gantt Class : OnCreateAutomationPeer Method (Gantt)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > Gantt Class : Opacity Property (Gantt)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > Gantt Class : OpacityMask Property (Gantt)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > Gantt Class : Parent Property (Gantt)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > Gantt Class : Projection Property (Gantt)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > Gantt Class : ReadLocalValue Method (Gantt)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > Gantt Class : ReleaseMouseCapture Method (Gantt)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > Gantt Class : RemoveHandler Method (Gantt)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > Gantt Class : RenderSize Property (Gantt)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > Gantt Class : RenderTransform Property (Gantt)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > Gantt Class : RenderTransformOrigin Property (Gantt)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > Gantt Class : Resources Property (Gantt)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RowDefinitions Property

PlexityHide.GTP Namespace > Gantt Class : RowDefinitions Property (Gantt)
[Visual Basic]
Public ReadOnly Property RowDefinitions As RowDefinitionCollection
[C#]
public RowDefinitionCollection RowDefinitions {get;}
[C++]
public: __property RowDefinitionCollection get_RowDefinitions();
[C++/CLI]
public:
property RowDefinitionCollection RowDefinitions {
   RowDefinitionCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > Gantt Class : SetBinding Method (Gantt)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > Gantt Class : SetValue Method (Gantt)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ShowGridLines Property

PlexityHide.GTP Namespace > Gantt Class : ShowGridLines Property (Gantt)
[Visual Basic]
Public Property ShowGridLines As Boolean
[C#]
public bool ShowGridLines {get; set;}
[C++]
public: __property bool get_ShowGridLines();
public: __property void set_ShowGridLines(
   bool value
);
[C++/CLI]
public:
property bool ShowGridLines {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > Gantt Class : SizeChanged Event (Gantt)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > Gantt Class : Style Property (Gantt)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > Gantt Class : Tag Property (Gantt)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > Gantt Class : TransformToVisual Method (Gantt)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > Gantt Class : Triggers Property (Gantt)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > Gantt Class : UpdateLayout Method (Gantt)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > Gantt Class : UseLayoutRounding Property (Gantt)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > Gantt Class : VerticalAlignment Property (Gantt)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > Gantt Class : Visibility Property (Gantt)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%%

Gantt Class | Gantt Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > Gantt Class : Width Property (Gantt)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Gantt Class | Gantt Members


%%PageItemTitle%% $$Events$$

TimeItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItem Class Events

PlexityHide.GTP Namespace : TimeItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItem members.

See Also

TimeItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

TimeItemLink Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLink Class Methods

PlexityHide.GTP Namespace : TimeItemLink Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLink members.

See Also

TimeItemLink Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Events$$

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Class Events

PlexityHide.GTP Namespace : TimeItemLinkCanvas Class

For a list of all members of this type, see TimeItemLinkCanvas members.

See Also

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Class Methods

PlexityHide.GTP Namespace : TimeItemLinkCanvas Class

For a list of all members of this type, see TimeItemLinkCanvas members.

See Also

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkCanvas Class Properties

PlexityHide.GTP Namespace : TimeItemLinkCanvas Class

For a list of all members of this type, see TimeItemLinkCanvas members.

See Also

TimeItemLinkCanvas Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ActualHeight Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ActualWidth Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : AddHandler Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Arrange Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ArrangeOverride Method (TimeItemLinkCanvas)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Background Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : BindingValidationError Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : CacheMode Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : CaptureMouse Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Children Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ClearValue Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Clip Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Cursor Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : DataContext Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : DesiredSize Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Dispatcher Property (TimeItemLinkCanvas)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Effect Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : FindName Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : GetAnimationBaseValue Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : GetBindingExpression Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : GetValue Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : GotFocus Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Height Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : HorizontalAlignment Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : InvalidateArrange Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : InvalidateMeasure Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : IsHitTestVisible Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : IsItemsHost Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : KeyDown Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : KeyUp Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Language Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : LayoutUpdated Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Loaded Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : LostFocus Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : LostMouseCapture Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Margin Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MaxHeight Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MaxWidth Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Measure Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MeasureOverride Method (TimeItemLinkCanvas)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MinHeight Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MinWidth Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseEnter Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseLeave Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseLeftButtonDown Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseLeftButtonUp Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseMove Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : MouseWheel Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Name Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : OnApplyTemplate Method (TimeItemLinkCanvas)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : OnCreateAutomationPeer Method (TimeItemLinkCanvas)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Opacity Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : OpacityMask Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Parent Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Projection Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ReadLocalValue Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : ReleaseMouseCapture Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : RemoveHandler Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : RenderSize Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : RenderTransform Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : RenderTransformOrigin Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Resources Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : SetBinding Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : SetValue Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : SizeChanged Event (TimeItemLinkCanvas)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Style Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Tag Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : TransformToVisual Method (TimeItemLinkCanvas)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Triggers Property (TimeItemLinkCanvas)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : UpdateLayout Method (TimeItemLinkCanvas)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : UseLayoutRounding Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : VerticalAlignment Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Visibility Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%%

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TimeItemLinkCanvas Class : Width Property (TimeItemLinkCanvas)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkCanvas Class | TimeItemLinkCanvas Members


%%PageItemTitle%% $$Events$$

TimeItemLinkItem Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinkItem Class Events

PlexityHide.GTP Namespace : TimeItemLinkItem Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinkItem members.

See Also

TimeItemLinkItem Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ActualHeight Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ActualWidth Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : AddHandler Method (TimeItemLinkItem)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Arrange Method (TimeItemLinkItem)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : BindingValidationError Event (TimeItemLinkItem)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : CacheMode Property (TimeItemLinkItem)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : CaptureMouse Method (TimeItemLinkItem)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ClearValue Method (TimeItemLinkItem)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Clip Property (TimeItemLinkItem)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Content Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Content Property (TimeItemLinkItem)
[Visual Basic]
Public Property Content As Object
[C#]
public object Content {get; set;}
[C++]
public: __property Object* get_Content();
public: __property void set_Content(
   Object* value
);
[C++/CLI]
public:
property Object^ Content {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ContentTemplate Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ContentTemplate Property (TimeItemLinkItem)
[Visual Basic]
Public Property ContentTemplate As DataTemplate
[C#]
public DataTemplate ContentTemplate {get; set;}
[C++]
public: __property DataTemplate get_ContentTemplate();
public: __property void set_ContentTemplate(
   DataTemplate value
);
[C++/CLI]
public:
property DataTemplate ContentTemplate {
   DataTemplate get();
   void set (DataTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Cursor Property (TimeItemLinkItem)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : DataContext Property (TimeItemLinkItem)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : DesiredSize Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Dispatcher Property (TimeItemLinkItem)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Effect Property (TimeItemLinkItem)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : FindName Method (TimeItemLinkItem)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : GetAnimationBaseValue Method (TimeItemLinkItem)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : GetBindingExpression Method (TimeItemLinkItem)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : GetValue Method (TimeItemLinkItem)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : GotFocus Event (TimeItemLinkItem)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Height Property (TimeItemLinkItem)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : HorizontalAlignment Property (TimeItemLinkItem)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : InvalidateArrange Method (TimeItemLinkItem)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : InvalidateMeasure Method (TimeItemLinkItem)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : IsHitTestVisible Property (TimeItemLinkItem)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : KeyDown Event (TimeItemLinkItem)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : KeyUp Event (TimeItemLinkItem)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Language Property (TimeItemLinkItem)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : LayoutUpdated Event (TimeItemLinkItem)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Loaded Event (TimeItemLinkItem)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : LostFocus Event (TimeItemLinkItem)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : LostMouseCapture Event (TimeItemLinkItem)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Margin Property (TimeItemLinkItem)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MaxHeight Property (TimeItemLinkItem)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MaxWidth Property (TimeItemLinkItem)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Measure Method (TimeItemLinkItem)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MinHeight Property (TimeItemLinkItem)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MinWidth Property (TimeItemLinkItem)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseEnter Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseLeave Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseLeftButtonDown Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseLeftButtonUp Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseMove Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : MouseWheel Event (TimeItemLinkItem)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Name Property (TimeItemLinkItem)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : OnApplyTemplate Method (TimeItemLinkItem)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : OnCreateAutomationPeer Method (TimeItemLinkItem)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Opacity Property (TimeItemLinkItem)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : OpacityMask Property (TimeItemLinkItem)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Parent Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Projection Property (TimeItemLinkItem)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ReadLocalValue Method (TimeItemLinkItem)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : ReleaseMouseCapture Method (TimeItemLinkItem)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : RemoveHandler Method (TimeItemLinkItem)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : RenderSize Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : RenderTransform Property (TimeItemLinkItem)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : RenderTransformOrigin Property (TimeItemLinkItem)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Resources Property (TimeItemLinkItem)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : SetBinding Method (TimeItemLinkItem)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : SetValue Method (TimeItemLinkItem)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TimeItemLinkItem Class : SizeChanged Event (TimeItemLinkItem)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Style Property (TimeItemLinkItem)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Tag Property (TimeItemLinkItem)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : TransformToVisual Method (TimeItemLinkItem)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Triggers Property (TimeItemLinkItem)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TimeItemLinkItem Class : UpdateLayout Method (TimeItemLinkItem)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : UseLayoutRounding Property (TimeItemLinkItem)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : VerticalAlignment Property (TimeItemLinkItem)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Visibility Property (TimeItemLinkItem)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%%

TimeItemLinkItem Class | TimeItemLinkItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TimeItemLinkItem Class : Width Property (TimeItemLinkItem)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinkItem Class | TimeItemLinkItem Members


%%PageItemTitle%% $$Events$$

TimeItemLinks Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TimeItemLinks Class Events

PlexityHide.GTP Namespace : TimeItemLinks Class (PlexityHide.GTP)

For a list of all members of this type, see TimeItemLinks members.

See Also

TimeItemLinks Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ActualHeight Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ActualWidth Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TimeItemLinks Class : AddHandler Method (TimeItemLinks)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ApplyTemplate Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ApplyTemplate Method (TimeItemLinks)
[Visual Basic]
Public Function ApplyTemplate() As Boolean
[C#]
public bool ApplyTemplate();
[C++]
public: bool ApplyTemplate();
[C++/CLI]
public:
bool ApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TimeItemLinks Class : Arrange Method (TimeItemLinks)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ArrangeOverride Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Function ArrangeOverride( _
   ByVal finalSize As Size _
) As Size
[C#]
protected virtual Size ArrangeOverride(
   Size finalSize
);
[C++]
protected: virtual Size ArrangeOverride(
   Size finalSize
)
[C++/CLI]
protected:
virtual Size ArrangeOverride(
   Size finalSize
)

Parameters

finalSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Background Property (TimeItemLinks)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TimeItemLinks Class : BindingValidationError Event (TimeItemLinks)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderBrush Property

PlexityHide.GTP Namespace > TimeItemLinks Class : BorderBrush Property (TimeItemLinks)
[Visual Basic]
Public Property BorderBrush As Brush
[C#]
public Brush BorderBrush {get; set;}
[C++]
public: __property Brush get_BorderBrush();
public: __property void set_BorderBrush(
   Brush value
);
[C++/CLI]
public:
property Brush BorderBrush {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BorderThickness Property

PlexityHide.GTP Namespace > TimeItemLinks Class : BorderThickness Property (TimeItemLinks)
[Visual Basic]
Public Property BorderThickness As Thickness
[C#]
public Thickness BorderThickness {get; set;}
[C++]
public: __property Thickness get_BorderThickness();
public: __property void set_BorderThickness(
   Thickness value
);
[C++/CLI]
public:
property Thickness BorderThickness {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TimeItemLinks Class : CacheMode Property (TimeItemLinks)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TimeItemLinks Class : CaptureMouse Method (TimeItemLinks)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ClearValue Method (TimeItemLinks)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Clip Property (TimeItemLinks)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Cursor Property (TimeItemLinks)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TimeItemLinks Class : DataContext Property (TimeItemLinks)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DefaultStyleKey Property

PlexityHide.GTP Namespace > TimeItemLinks Class : DefaultStyleKey Property (TimeItemLinks)
[Visual Basic]
Protected Property DefaultStyleKey As Object
[C#]
protected object DefaultStyleKey {get; set;}
[C++]
protected: __property Object* get_DefaultStyleKey();
protected: __property void set_DefaultStyleKey(
   Object* value
);
[C++/CLI]
protected:
property Object^ DefaultStyleKey {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TimeItemLinks Class : DesiredSize Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Dispatcher Property (TimeItemLinks)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DisplayMemberPath Property

PlexityHide.GTP Namespace > TimeItemLinks Class : DisplayMemberPath Property (TimeItemLinks)
[Visual Basic]
Public Property DisplayMemberPath As String
[C#]
public string DisplayMemberPath {get; set;}
[C++]
public: __property string* get_DisplayMemberPath();
public: __property void set_DisplayMemberPath(
   string* value
);
[C++/CLI]
public:
property String^ DisplayMemberPath {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Effect Property (TimeItemLinks)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TimeItemLinks Class : FindName Method (TimeItemLinks)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Focus Method

PlexityHide.GTP Namespace > TimeItemLinks Class : Focus Method (TimeItemLinks)
[Visual Basic]
Public Function Focus() As Boolean
[C#]
public bool Focus();
[C++]
public: bool Focus();
[C++/CLI]
public:
bool Focus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontFamily Property

PlexityHide.GTP Namespace > TimeItemLinks Class : FontFamily Property (TimeItemLinks)
[Visual Basic]
Public Property FontFamily As FontFamily
[C#]
public FontFamily FontFamily {get; set;}
[C++]
public: __property FontFamily get_FontFamily();
public: __property void set_FontFamily(
   FontFamily value
);
[C++/CLI]
public:
property FontFamily FontFamily {
   FontFamily get();
   void set (FontFamily value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontSize Property

PlexityHide.GTP Namespace > TimeItemLinks Class : FontSize Property (TimeItemLinks)
[Visual Basic]
Public Property FontSize As Double
[C#]
public double FontSize {get; set;}
[C++]
public: __property double get_FontSize();
public: __property void set_FontSize(
   double value
);
[C++/CLI]
public:
property double FontSize {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStretch Property

PlexityHide.GTP Namespace > TimeItemLinks Class : FontStretch Property (TimeItemLinks)
[Visual Basic]
Public Property FontStretch As FontStretch
[C#]
public FontStretch FontStretch {get; set;}
[C++]
public: __property FontStretch get_FontStretch();
public: __property void set_FontStretch(
   FontStretch value
);
[C++/CLI]
public:
property FontStretch FontStretch {
   FontStretch get();
   void set (FontStretch value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontStyle Property

PlexityHide.GTP Namespace > TimeItemLinks Class : FontStyle Property (TimeItemLinks)
[Visual Basic]
Public Property FontStyle As FontStyle
[C#]
public FontStyle FontStyle {get; set;}
[C++]
public: __property FontStyle get_FontStyle();
public: __property void set_FontStyle(
   FontStyle value
);
[C++/CLI]
public:
property FontStyle FontStyle {
   FontStyle get();
   void set (FontStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

FontWeight Property

PlexityHide.GTP Namespace > TimeItemLinks Class : FontWeight Property (TimeItemLinks)
[Visual Basic]
Public Property FontWeight As FontWeight
[C#]
public FontWeight FontWeight {get; set;}
[C++]
public: __property FontWeight get_FontWeight();
public: __property void set_FontWeight(
   FontWeight value
);
[C++/CLI]
public:
property FontWeight FontWeight {
   FontWeight get();
   void set (FontWeight value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Foreground Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Foreground Property (TimeItemLinks)
[Visual Basic]
Public Property Foreground As Brush
[C#]
public Brush Foreground {get; set;}
[C++]
public: __property Brush get_Foreground();
public: __property void set_Foreground(
   Brush value
);
[C++/CLI]
public:
property Brush Foreground {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TimeItemLinks Class : GetAnimationBaseValue Method (TimeItemLinks)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TimeItemLinks Class : GetBindingExpression Method (TimeItemLinks)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

childName
See Also Languages GTP.NET.SL Send comments on this topic.

GetTemplateChild Method

PlexityHide.GTP Namespace > TimeItemLinks Class : GetTemplateChild Method (TimeItemLinks)
[Visual Basic]
Protected Function GetTemplateChild( _
   ByVal childName As String _
) As DependencyObject
[C#]
protected DependencyObject GetTemplateChild(
   string childName
);
[C++]
protected: DependencyObject GetTemplateChild(
   string* childName
)
[C++/CLI]
protected:
DependencyObject GetTemplateChild(
   String^ childName
)

Parameters

childName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TimeItemLinks Class : GetValue Method (TimeItemLinks)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TimeItemLinks Class : GotFocus Event (TimeItemLinks)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Height Property (TimeItemLinks)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinks Class : HorizontalAlignment Property (TimeItemLinks)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalContentAlignment Property

PlexityHide.GTP Namespace > TimeItemLinks Class : HorizontalContentAlignment Property (TimeItemLinks)
[Visual Basic]
Public Property HorizontalContentAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalContentAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalContentAlignment();
public: __property void set_HorizontalContentAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalContentAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TimeItemLinks Class : InvalidateArrange Method (TimeItemLinks)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TimeItemLinks Class : InvalidateMeasure Method (TimeItemLinks)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabled Property

PlexityHide.GTP Namespace > TimeItemLinks Class : IsEnabled Property (TimeItemLinks)
[Visual Basic]
Public Property IsEnabled As Boolean
[C#]
public bool IsEnabled {get; set;}
[C++]
public: __property bool get_IsEnabled();
public: __property void set_IsEnabled(
   bool value
);
[C++/CLI]
public:
property bool IsEnabled {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsEnabledChanged Event

PlexityHide.GTP Namespace > TimeItemLinks Class : IsEnabledChanged Event (TimeItemLinks)
[Visual Basic]
Public Event IsEnabledChanged() As DependencyPropertyChangedEventHandler
[C#]
public event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++]
public: __event DependencyPropertyChangedEventHandler IsEnabledChanged();
[C++/CLI]
public:
event DependencyPropertyChangedEventHandler IsEnabledChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TimeItemLinks Class : IsHitTestVisible Property (TimeItemLinks)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsTabStop Property

PlexityHide.GTP Namespace > TimeItemLinks Class : IsTabStop Property (TimeItemLinks)
[Visual Basic]
Public Property IsTabStop As Boolean
[C#]
public bool IsTabStop {get; set;}
[C++]
public: __property bool get_IsTabStop();
public: __property void set_IsTabStop(
   bool value
);
[C++/CLI]
public:
property bool IsTabStop {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemContainerGenerator Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ItemContainerGenerator Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property ItemContainerGenerator As ItemContainerGenerator
[C#]
public ItemContainerGenerator ItemContainerGenerator {get;}
[C++]
public: __property ItemContainerGenerator get_ItemContainerGenerator();
[C++/CLI]
public:
property ItemContainerGenerator ItemContainerGenerator {
   ItemContainerGenerator get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Items Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Items Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property Items As ItemCollection
[C#]
public ItemCollection Items {get;}
[C++]
public: __property ItemCollection get_Items();
[C++/CLI]
public:
property ItemCollection Items {
   ItemCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemsPanel Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ItemsPanel Property (TimeItemLinks)
[Visual Basic]
Public Property ItemsPanel As ItemsPanelTemplate
[C#]
public ItemsPanelTemplate ItemsPanel {get; set;}
[C++]
public: __property ItemsPanelTemplate get_ItemsPanel();
public: __property void set_ItemsPanel(
   ItemsPanelTemplate value
);
[C++/CLI]
public:
property ItemsPanelTemplate ItemsPanel {
   ItemsPanelTemplate get();
   void set (ItemsPanelTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemsSource Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ItemsSource Property (TimeItemLinks)
[Visual Basic]
Public Property ItemsSource As IEnumerable
[C#]
public IEnumerable ItemsSource {get; set;}
[C++]
public: __property IEnumerable* get_ItemsSource();
public: __property void set_ItemsSource(
   IEnumerable* value
);
[C++/CLI]
public:
property IEnumerable^ ItemsSource {
   IEnumerable^ get();
   void set (IEnumerable^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ItemTemplate Property

PlexityHide.GTP Namespace > TimeItemLinks Class : ItemTemplate Property (TimeItemLinks)
[Visual Basic]
Public Property ItemTemplate As DataTemplate
[C#]
public DataTemplate ItemTemplate {get; set;}
[C++]
public: __property DataTemplate get_ItemTemplate();
public: __property void set_ItemTemplate(
   DataTemplate value
);
[C++/CLI]
public:
property DataTemplate ItemTemplate {
   DataTemplate get();
   void set (DataTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TimeItemLinks Class : KeyDown Event (TimeItemLinks)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TimeItemLinks Class : KeyUp Event (TimeItemLinks)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Language Property (TimeItemLinks)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TimeItemLinks Class : LayoutUpdated Event (TimeItemLinks)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TimeItemLinks Class : Loaded Event (TimeItemLinks)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TimeItemLinks Class : LostFocus Event (TimeItemLinks)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TimeItemLinks Class : LostMouseCapture Event (TimeItemLinks)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Margin Property (TimeItemLinks)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TimeItemLinks Class : MaxHeight Property (TimeItemLinks)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TimeItemLinks Class : MaxWidth Property (TimeItemLinks)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TimeItemLinks Class : Measure Method (TimeItemLinks)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TimeItemLinks Class : MinHeight Property (TimeItemLinks)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TimeItemLinks Class : MinWidth Property (TimeItemLinks)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseEnter Event (TimeItemLinks)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseLeave Event (TimeItemLinks)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseLeftButtonDown Event (TimeItemLinks)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseLeftButtonUp Event (TimeItemLinks)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseMove Event (TimeItemLinks)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TimeItemLinks Class : MouseWheel Event (TimeItemLinks)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Name Property (TimeItemLinks)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnApplyTemplate Method (TimeItemLinks)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnCreateAutomationPeer Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnGotFocus Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnGotFocus Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnGotFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnGotFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnGotFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnGotFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyDown Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnKeyDown Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyDown(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyDown(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyDown(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnKeyUp Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnKeyUp Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnKeyUp(
   KeyEventArgs e
);
[C++]
protected: virtual void OnKeyUp(
   KeyEventArgs e
)
[C++/CLI]
protected:
virtual void OnKeyUp(
   KeyEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostFocus Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnLostFocus Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnLostFocus( _
   ByVal e As RoutedEventArgs _
)
[C#]
protected virtual void OnLostFocus(
   RoutedEventArgs e
);
[C++]
protected: virtual void OnLostFocus(
   RoutedEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostFocus(
   RoutedEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnLostMouseCapture Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnLostMouseCapture Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnLostMouseCapture( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnLostMouseCapture(
   MouseEventArgs e
);
[C++]
protected: virtual void OnLostMouseCapture(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnLostMouseCapture(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseEnter Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseEnter Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseEnter( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseEnter(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseEnter(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseEnter(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeave Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseLeave Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseLeave( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseLeave(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseLeave(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeave(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonDown Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseLeftButtonDown Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonDown( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonDown(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseLeftButtonUp Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseLeftButtonUp Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseLeftButtonUp( _
   ByVal e As MouseButtonEventArgs _
)
[C#]
protected virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
);
[C++]
protected: virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseLeftButtonUp(
   MouseButtonEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseMove Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseMove Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnMouseMove(
   MouseEventArgs e
);
[C++]
protected: virtual void OnMouseMove(
   MouseEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseMove(
   MouseEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

e
See Also Languages GTP.NET.SL Send comments on this topic.

OnMouseWheel Method

PlexityHide.GTP Namespace > TimeItemLinks Class : OnMouseWheel Method (TimeItemLinks)
[Visual Basic]
Protected Overridable Sub OnMouseWheel( _
   ByVal e As MouseWheelEventArgs _
)
[C#]
protected virtual void OnMouseWheel(
   MouseWheelEventArgs e
);
[C++]
protected: virtual void OnMouseWheel(
   MouseWheelEventArgs e
)
[C++/CLI]
protected:
virtual void OnMouseWheel(
   MouseWheelEventArgs e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Opacity Property (TimeItemLinks)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TimeItemLinks Class : OpacityMask Property (TimeItemLinks)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Padding Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Padding Property (TimeItemLinks)
[Visual Basic]
Public Property Padding As Thickness
[C#]
public Thickness Padding {get; set;}
[C++]
public: __property Thickness get_Padding();
public: __property void set_Padding(
   Thickness value
);
[C++/CLI]
public:
property Thickness Padding {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Parent Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Projection Property (TimeItemLinks)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ReadLocalValue Method (TimeItemLinks)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TimeItemLinks Class : ReleaseMouseCapture Method (TimeItemLinks)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TimeItemLinks Class : RemoveHandler Method (TimeItemLinks)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TimeItemLinks Class : RenderSize Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TimeItemLinks Class : RenderTransform Property (TimeItemLinks)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TimeItemLinks Class : RenderTransformOrigin Property (TimeItemLinks)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Resources Property (TimeItemLinks)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TimeItemLinks Class : SetBinding Method (TimeItemLinks)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TimeItemLinks Class : SetValue Method (TimeItemLinks)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TimeItemLinks Class : SizeChanged Event (TimeItemLinks)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Style Property (TimeItemLinks)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabIndex Property

PlexityHide.GTP Namespace > TimeItemLinks Class : TabIndex Property (TimeItemLinks)
[Visual Basic]
Public Property TabIndex As Integer
[C#]
public int TabIndex {get; set;}
[C++]
public: __property int get_TabIndex();
public: __property void set_TabIndex(
   int value
);
[C++/CLI]
public:
property int TabIndex {
   int get();
   void set (int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

TabNavigation Property

PlexityHide.GTP Namespace > TimeItemLinks Class : TabNavigation Property (TimeItemLinks)
[Visual Basic]
Public Property TabNavigation As KeyboardNavigationMode
[C#]
public KeyboardNavigationMode TabNavigation {get; set;}
[C++]
public: __property KeyboardNavigationMode get_TabNavigation();
public: __property void set_TabNavigation(
   KeyboardNavigationMode value
);
[C++/CLI]
public:
property KeyboardNavigationMode TabNavigation {
   KeyboardNavigationMode get();
   void set (KeyboardNavigationMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Tag Property (TimeItemLinks)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Template Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Template Property (TimeItemLinks)
[Visual Basic]
Public Property Template As ControlTemplate
[C#]
public ControlTemplate Template {get; set;}
[C++]
public: __property ControlTemplate get_Template();
public: __property void set_Template(
   ControlTemplate value
);
[C++/CLI]
public:
property ControlTemplate Template {
   ControlTemplate get();
   void set (ControlTemplate value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TimeItemLinks Class : TransformToVisual Method (TimeItemLinks)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Triggers Property (TimeItemLinks)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TimeItemLinks Class : UpdateLayout Method (TimeItemLinks)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TimeItemLinks Class : UseLayoutRounding Property (TimeItemLinks)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TimeItemLinks Class : VerticalAlignment Property (TimeItemLinks)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalContentAlignment Property

PlexityHide.GTP Namespace > TimeItemLinks Class : VerticalContentAlignment Property (TimeItemLinks)
[Visual Basic]
Public Property VerticalContentAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalContentAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalContentAlignment();
public: __property void set_VerticalContentAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalContentAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Visibility Property (TimeItemLinks)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLinks Class | TimeItemLinks Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TimeItemLinks Class : Width Property (TimeItemLinks)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLinks Class | TimeItemLinks Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TimeItemLink Class : ActualHeight Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TimeItemLink Class : ActualWidth Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TimeItemLink Class : AddHandler Method (TimeItemLink)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TimeItemLink Class : Arrange Method (TimeItemLink)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TimeItemLink Class : ArrangeOverride Method (TimeItemLink)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > TimeItemLink Class : Background Property (TimeItemLink)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TimeItemLink Class : BindingValidationError Event (TimeItemLink)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TimeItemLink Class : CacheMode Property (TimeItemLink)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TimeItemLink Class : CaptureMouse Method (TimeItemLink)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > TimeItemLink Class : Children Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TimeItemLink Class : ClearValue Method (TimeItemLink)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TimeItemLink Class : Clip Property (TimeItemLink)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TimeItemLink Class : Cursor Property (TimeItemLink)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TimeItemLink Class : DataContext Property (TimeItemLink)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TimeItemLink Class : DesiredSize Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TimeItemLink Class : Dispatcher Property (TimeItemLink)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TimeItemLink Class : Effect Property (TimeItemLink)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TimeItemLink Class : FindName Method (TimeItemLink)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TimeItemLink Class : GetAnimationBaseValue Method (TimeItemLink)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TimeItemLink Class : GetBindingExpression Method (TimeItemLink)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TimeItemLink Class : GetValue Method (TimeItemLink)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TimeItemLink Class : GotFocus Event (TimeItemLink)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TimeItemLink Class : Height Property (TimeItemLink)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TimeItemLink Class : HorizontalAlignment Property (TimeItemLink)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TimeItemLink Class : InvalidateArrange Method (TimeItemLink)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TimeItemLink Class : InvalidateMeasure Method (TimeItemLink)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TimeItemLink Class : IsHitTestVisible Property (TimeItemLink)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > TimeItemLink Class : IsItemsHost Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TimeItemLink Class : KeyDown Event (TimeItemLink)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TimeItemLink Class : KeyUp Event (TimeItemLink)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TimeItemLink Class : Language Property (TimeItemLink)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TimeItemLink Class : LayoutUpdated Event (TimeItemLink)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TimeItemLink Class : Loaded Event (TimeItemLink)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TimeItemLink Class : LostFocus Event (TimeItemLink)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TimeItemLink Class : LostMouseCapture Event (TimeItemLink)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TimeItemLink Class : Margin Property (TimeItemLink)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TimeItemLink Class : MaxHeight Property (TimeItemLink)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TimeItemLink Class : MaxWidth Property (TimeItemLink)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TimeItemLink Class : Measure Method (TimeItemLink)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TimeItemLink Class : MeasureOverride Method (TimeItemLink)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TimeItemLink Class : MinHeight Property (TimeItemLink)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TimeItemLink Class : MinWidth Property (TimeItemLink)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseEnter Event (TimeItemLink)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseLeave Event (TimeItemLink)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseLeftButtonDown Event (TimeItemLink)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseLeftButtonUp Event (TimeItemLink)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseMove Event (TimeItemLink)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TimeItemLink Class : MouseWheel Event (TimeItemLink)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TimeItemLink Class : Name Property (TimeItemLink)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TimeItemLink Class : OnApplyTemplate Method (TimeItemLink)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TimeItemLink Class : OnCreateAutomationPeer Method (TimeItemLink)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TimeItemLink Class : Opacity Property (TimeItemLink)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TimeItemLink Class : OpacityMask Property (TimeItemLink)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TimeItemLink Class : Parent Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TimeItemLink Class : Projection Property (TimeItemLink)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TimeItemLink Class : ReadLocalValue Method (TimeItemLink)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TimeItemLink Class : ReleaseMouseCapture Method (TimeItemLink)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TimeItemLink Class : RemoveHandler Method (TimeItemLink)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TimeItemLink Class : RenderSize Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TimeItemLink Class : RenderTransform Property (TimeItemLink)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TimeItemLink Class : RenderTransformOrigin Property (TimeItemLink)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TimeItemLink Class : Resources Property (TimeItemLink)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TimeItemLink Class : SetBinding Method (TimeItemLink)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TimeItemLink Class : SetValue Method (TimeItemLink)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TimeItemLink Class : SizeChanged Event (TimeItemLink)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TimeItemLink Class : Style Property (TimeItemLink)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TimeItemLink Class : Tag Property (TimeItemLink)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TimeItemLink Class : TransformToVisual Method (TimeItemLink)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TimeItemLink Class : Triggers Property (TimeItemLink)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TimeItemLink Class : UpdateLayout Method (TimeItemLink)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TimeItemLink Class : UseLayoutRounding Property (TimeItemLink)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TimeItemLink Class : VerticalAlignment Property (TimeItemLink)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TimeItemLink Class : Visibility Property (TimeItemLink)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItemLink Class | TimeItemLink Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TimeItemLink Class : Width Property (TimeItemLink)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItemLink Class | TimeItemLink Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TimeItem Class : ActualHeight Property (TimeItem)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TimeItem Class : ActualWidth Property (TimeItem)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TimeItem Class : AddHandler Method (TimeItem)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TimeItem Class : Arrange Method (TimeItem)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TimeItem Class : ArrangeOverride Method (TimeItem)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > TimeItem Class : Background Property (TimeItem)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TimeItem Class : BindingValidationError Event (TimeItem)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TimeItem Class : CacheMode Property (TimeItem)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TimeItem Class : CaptureMouse Method (TimeItem)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > TimeItem Class : Children Property (TimeItem)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TimeItem Class : ClearValue Method (TimeItem)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TimeItem Class : Clip Property (TimeItem)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TimeItem Class : Cursor Property (TimeItem)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TimeItem Class : DataContext Property (TimeItem)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TimeItem Class : DesiredSize Property (TimeItem)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TimeItem Class : Dispatcher Property (TimeItem)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TimeItem Class : Effect Property (TimeItem)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TimeItem Class : FindName Method (TimeItem)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TimeItem Class : GetAnimationBaseValue Method (TimeItem)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TimeItem Class : GetBindingExpression Method (TimeItem)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TimeItem Class : GetValue Method (TimeItem)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TimeItem Class : GotFocus Event (TimeItem)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TimeItem Class : Height Property (TimeItem)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TimeItem Class : HorizontalAlignment Property (TimeItem)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TimeItem Class : InvalidateArrange Method (TimeItem)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TimeItem Class : InvalidateMeasure Method (TimeItem)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TimeItem Class : IsHitTestVisible Property (TimeItem)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > TimeItem Class : IsItemsHost Property (TimeItem)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TimeItem Class : KeyDown Event (TimeItem)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TimeItem Class : KeyUp Event (TimeItem)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TimeItem Class : Language Property (TimeItem)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TimeItem Class : LayoutUpdated Event (TimeItem)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TimeItem Class : Loaded Event (TimeItem)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TimeItem Class : LostFocus Event (TimeItem)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TimeItem Class : LostMouseCapture Event (TimeItem)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TimeItem Class : Margin Property (TimeItem)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TimeItem Class : MaxHeight Property (TimeItem)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TimeItem Class : MaxWidth Property (TimeItem)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TimeItem Class : Measure Method (TimeItem)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TimeItem Class : MeasureOverride Method (TimeItem)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TimeItem Class : MinHeight Property (TimeItem)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TimeItem Class : MinWidth Property (TimeItem)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TimeItem Class : MouseEnter Event (TimeItem)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TimeItem Class : MouseLeave Event (TimeItem)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TimeItem Class : MouseLeftButtonDown Event (TimeItem)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TimeItem Class : MouseLeftButtonUp Event (TimeItem)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TimeItem Class : MouseMove Event (TimeItem)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TimeItem Class : MouseWheel Event (TimeItem)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TimeItem Class : Name Property (TimeItem)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TimeItem Class : OnApplyTemplate Method (TimeItem)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TimeItem Class : OnCreateAutomationPeer Method (TimeItem)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TimeItem Class : Opacity Property (TimeItem)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TimeItem Class : OpacityMask Property (TimeItem)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TimeItem Class : Parent Property (TimeItem)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TimeItem Class : Projection Property (TimeItem)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TimeItem Class : ReadLocalValue Method (TimeItem)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TimeItem Class : ReleaseMouseCapture Method (TimeItem)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TimeItem Class : RemoveHandler Method (TimeItem)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TimeItem Class : RenderSize Property (TimeItem)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TimeItem Class : RenderTransform Property (TimeItem)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TimeItem Class : RenderTransformOrigin Property (TimeItem)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TimeItem Class : Resources Property (TimeItem)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TimeItem Class : SetBinding Method (TimeItem)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TimeItem Class : SetValue Method (TimeItem)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TimeItem Class : SizeChanged Event (TimeItem)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TimeItem Class : Style Property (TimeItem)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TimeItem Class : Tag Property (TimeItem)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TimeItem Class : TransformToVisual Method (TimeItem)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TimeItem Class : Triggers Property (TimeItem)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TimeItem Class : UpdateLayout Method (TimeItem)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TimeItem Class : UseLayoutRounding Property (TimeItem)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TimeItem Class : VerticalAlignment Property (TimeItem)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TimeItem Class : Visibility Property (TimeItem)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%%

TimeItem Class | TimeItem Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TimeItem Class : Width Property (TimeItem)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TimeItem Class | TimeItem Members


%%PageItemTitle%% $$Events$$

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class Events

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

For a list of all members of this type, see TreeViewMultiColumnRow members.

See Also

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace

See Also GTP.NET.SL Send comments on this topic.

TreeViewMultiColumnRow Class Methods

PlexityHide.GTP Namespace : TreeViewMultiColumnRow Class

For a list of all members of this type, see TreeViewMultiColumnRow members.

See Also

TreeViewMultiColumnRow Class | PlexityHide.GTP Namespace


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualHeight Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ActualHeight Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property ActualHeight As Double
[C#]
public double ActualHeight {get;}
[C++]
public: __property double get_ActualHeight();
[C++/CLI]
public:
property double ActualHeight {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ActualWidth Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ActualWidth Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property ActualWidth As Double
[C#]
public double ActualWidth {get;}
[C++]
public: __property double get_ActualWidth();
[C++/CLI]
public:
property double ActualWidth {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
handledEventsToo
See Also Languages GTP.NET.SL Send comments on this topic.

AddHandler Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : AddHandler Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub AddHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate, _
   ByVal handledEventsToo As Boolean _
)
[C#]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
);
[C++]
public: void AddHandler(
   RoutedEvent routedEvent,
   Delegate* handler,
   bool handledEventsToo
)
[C++/CLI]
public:
void AddHandler(
   RoutedEvent routedEvent,
   Delegate^ handler,
   bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

finalRect
See Also Languages GTP.NET.SL Send comments on this topic.

Arrange Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Arrange Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub Arrange( _
   ByVal finalRect As Rect _
)
[C#]
public void Arrange(
   Rect finalRect
);
[C++]
public: void Arrange(
   Rect finalRect
)
[C++/CLI]
public:
void Arrange(
   Rect finalRect
)

Parameters

finalRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

arrangeSize
See Also Languages GTP.NET.SL Send comments on this topic.

ArrangeOverride Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ArrangeOverride Method (TreeViewMultiColumnRow)
[Visual Basic]
Protected Function ArrangeOverride( _
   ByVal arrangeSize As Size _
) As Size
[C#]
protected Size ArrangeOverride(
   Size arrangeSize
);
[C++]
protected: Size ArrangeOverride(
   Size arrangeSize
)
[C++/CLI]
protected:
Size ArrangeOverride(
   Size arrangeSize
)

Parameters

arrangeSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Background Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Background Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Background As Brush
[C#]
public Brush Background {get; set;}
[C++]
public: __property Brush get_Background();
public: __property void set_Background(
   Brush value
);
[C++/CLI]
public:
property Brush Background {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

BindingValidationError Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : BindingValidationError Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event BindingValidationError() As EventHandler(Of ValidationErrorEventArgs)
[C#]
public event EventHandler<ValidationErrorEventArgs> BindingValidationError();
[C++]
public: __event EventHandler<ValidationErrorEventArgs>* BindingValidationError();
[C++/CLI]
public:
event EventHandler<ValidationErrorEventArgs>^ BindingValidationError();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CacheMode Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : CacheMode Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property CacheMode As CacheMode
[C#]
public CacheMode CacheMode {get; set;}
[C++]
public: __property CacheMode get_CacheMode();
public: __property void set_CacheMode(
   CacheMode value
);
[C++/CLI]
public:
property CacheMode CacheMode {
   CacheMode get();
   void set (CacheMode value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

CaptureMouse Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : CaptureMouse Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function CaptureMouse() As Boolean
[C#]
public bool CaptureMouse();
[C++]
public: bool CaptureMouse();
[C++/CLI]
public:
bool CaptureMouse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Children Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Children Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property Children As UIElementCollection
[C#]
public UIElementCollection Children {get;}
[C++]
public: __property UIElementCollection get_Children();
[C++/CLI]
public:
property UIElementCollection Children {
   UIElementCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ClearValue Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ClearValue Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub ClearValue( _
   ByVal dp As DependencyProperty _
)
[C#]
public void ClearValue(
   DependencyProperty dp
);
[C++]
public: void ClearValue(
   DependencyProperty dp
)
[C++/CLI]
public:
void ClearValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Clip Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Clip Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Clip As Geometry
[C#]
public Geometry Clip {get; set;}
[C++]
public: __property Geometry get_Clip();
public: __property void set_Clip(
   Geometry value
);
[C++/CLI]
public:
property Geometry Clip {
   Geometry get();
   void set (Geometry value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ColumnDefinitions Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ColumnDefinitions Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property ColumnDefinitions As ColumnDefinitionCollection
[C#]
public ColumnDefinitionCollection ColumnDefinitions {get;}
[C++]
public: __property ColumnDefinitionCollection get_ColumnDefinitions();
[C++/CLI]
public:
property ColumnDefinitionCollection ColumnDefinitions {
   ColumnDefinitionCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Cursor Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Cursor Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}
[C++]
public: __property Cursor get_Cursor();
public: __property void set_Cursor(
   Cursor value
);
[C++/CLI]
public:
property Cursor Cursor {
   Cursor get();
   void set (Cursor value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DataContext Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : DataContext Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property DataContext As Object
[C#]
public object DataContext {get; set;}
[C++]
public: __property Object* get_DataContext();
public: __property void set_DataContext(
   Object* value
);
[C++/CLI]
public:
property Object^ DataContext {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

DesiredSize Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : DesiredSize Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property DesiredSize As Size
[C#]
public Size DesiredSize {get;}
[C++]
public: __property Size get_DesiredSize();
[C++/CLI]
public:
property Size DesiredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Dispatcher Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Dispatcher Property (TreeViewMultiColumnRow)
[Visual Basic]
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Dispatcher As Dispatcher
[C#]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}
[C++]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Dispatcher get_Dispatcher();
[C++/CLI]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Dispatcher Dispatcher {
   Dispatcher get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Effect Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Effect Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Effect As Effect
[C#]
public Effect Effect {get; set;}
[C++]
public: __property Effect get_Effect();
public: __property void set_Effect(
   Effect value
);
[C++/CLI]
public:
property Effect Effect {
   Effect get();
   void set (Effect value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

name
See Also Languages GTP.NET.SL Send comments on this topic.

FindName Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : FindName Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function FindName( _
   ByVal name As String _
) As Object
[C#]
public object FindName(
   string name
);
[C++]
public: Object* FindName(
   string* name
)
[C++/CLI]
public:
Object^ FindName(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetAnimationBaseValue Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : GetAnimationBaseValue Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function GetAnimationBaseValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetAnimationBaseValue(
   DependencyProperty dp
);
[C++]
public: Object* GetAnimationBaseValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetBindingExpression Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : GetBindingExpression Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function GetBindingExpression( _
   ByVal dp As DependencyProperty _
) As BindingExpression
[C#]
public BindingExpression GetBindingExpression(
   DependencyProperty dp
);
[C++]
public: BindingExpression GetBindingExpression(
   DependencyProperty dp
)
[C++/CLI]
public:
BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

GetValue Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : GetValue Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function GetValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object GetValue(
   DependencyProperty dp
);
[C++]
public: Object* GetValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ GetValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

GotFocus Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : GotFocus Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event GotFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler GotFocus();
[C++]
public: __event RoutedEventHandler GotFocus();
[C++/CLI]
public:
event RoutedEventHandler GotFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Height Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Height Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Height As Double
[C#]
public double Height {get; set;}
[C++]
public: __property double get_Height();
public: __property void set_Height(
   double value
);
[C++/CLI]
public:
property double Height {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

HorizontalAlignment Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : HorizontalAlignment Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property HorizontalAlignment As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment {get; set;}
[C++]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[C++/CLI]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (HorizontalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateArrange Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : InvalidateArrange Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub InvalidateArrange()
[C#]
public void InvalidateArrange();
[C++]
public: void InvalidateArrange();
[C++/CLI]
public:
void InvalidateArrange();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

InvalidateMeasure Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : InvalidateMeasure Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub InvalidateMeasure()
[C#]
public void InvalidateMeasure();
[C++]
public: void InvalidateMeasure();
[C++/CLI]
public:
void InvalidateMeasure();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsHitTestVisible Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : IsHitTestVisible Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property IsHitTestVisible As Boolean
[C#]
public bool IsHitTestVisible {get; set;}
[C++]
public: __property bool get_IsHitTestVisible();
public: __property void set_IsHitTestVisible(
   bool value
);
[C++/CLI]
public:
property bool IsHitTestVisible {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

IsItemsHost Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : IsItemsHost Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property IsItemsHost As Boolean
[C#]
public bool IsItemsHost {get;}
[C++]
public: __property bool get_IsItemsHost();
[C++/CLI]
public:
property bool IsItemsHost {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyDown Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : KeyDown Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event KeyDown() As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown();
[C++]
public: __event KeyEventHandler KeyDown();
[C++/CLI]
public:
event KeyEventHandler KeyDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

KeyUp Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : KeyUp Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event KeyUp() As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp();
[C++]
public: __event KeyEventHandler KeyUp();
[C++/CLI]
public:
event KeyEventHandler KeyUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Language Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Language Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Language As XmlLanguage
[C#]
public XmlLanguage Language {get; set;}
[C++]
public: __property XmlLanguage get_Language();
public: __property void set_Language(
   XmlLanguage value
);
[C++/CLI]
public:
property XmlLanguage Language {
   XmlLanguage get();
   void set (XmlLanguage value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LayoutUpdated Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : LayoutUpdated Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event LayoutUpdated() As EventHandler
[C#]
public event EventHandler LayoutUpdated();
[C++]
public: __event EventHandler* LayoutUpdated();
[C++/CLI]
public:
event EventHandler^ LayoutUpdated();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Loaded Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Loaded Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event Loaded() As RoutedEventHandler
[C#]
public event RoutedEventHandler Loaded();
[C++]
public: __event RoutedEventHandler Loaded();
[C++/CLI]
public:
event RoutedEventHandler Loaded();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostFocus Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : LostFocus Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event LostFocus() As RoutedEventHandler
[C#]
public event RoutedEventHandler LostFocus();
[C++]
public: __event RoutedEventHandler LostFocus();
[C++/CLI]
public:
event RoutedEventHandler LostFocus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

LostMouseCapture Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : LostMouseCapture Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event LostMouseCapture() As MouseEventHandler
[C#]
public event MouseEventHandler LostMouseCapture();
[C++]
public: __event MouseEventHandler LostMouseCapture();
[C++/CLI]
public:
event MouseEventHandler LostMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Margin Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Margin Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Margin As Thickness
[C#]
public Thickness Margin {get; set;}
[C++]
public: __property Thickness get_Margin();
public: __property void set_Margin(
   Thickness value
);
[C++/CLI]
public:
property Thickness Margin {
   Thickness get();
   void set (Thickness value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxHeight Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MaxHeight Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property MaxHeight As Double
[C#]
public double MaxHeight {get; set;}
[C++]
public: __property double get_MaxHeight();
public: __property void set_MaxHeight(
   double value
);
[C++/CLI]
public:
property double MaxHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MaxWidth Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MaxWidth Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property MaxWidth As Double
[C#]
public double MaxWidth {get; set;}
[C++]
public: __property double get_MaxWidth();
public: __property void set_MaxWidth(
   double value
);
[C++/CLI]
public:
property double MaxWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

availableSize
See Also Languages GTP.NET.SL Send comments on this topic.

Measure Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Measure Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub Measure( _
   ByVal availableSize As Size _
)
[C#]
public void Measure(
   Size availableSize
);
[C++]
public: void Measure(
   Size availableSize
)
[C++/CLI]
public:
void Measure(
   Size availableSize
)

Parameters

availableSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

constraint
See Also Languages GTP.NET.SL Send comments on this topic.

MeasureOverride Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MeasureOverride Method (TreeViewMultiColumnRow)
[Visual Basic]
Protected Function MeasureOverride( _
   ByVal constraint As Size _
) As Size
[C#]
protected Size MeasureOverride(
   Size constraint
);
[C++]
protected: Size MeasureOverride(
   Size constraint
)
[C++/CLI]
protected:
Size MeasureOverride(
   Size constraint
)

Parameters

constraint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinHeight Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MinHeight Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property MinHeight As Double
[C#]
public double MinHeight {get; set;}
[C++]
public: __property double get_MinHeight();
public: __property void set_MinHeight(
   double value
);
[C++/CLI]
public:
property double MinHeight {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MinWidth Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MinWidth Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property MinWidth As Double
[C#]
public double MinWidth {get; set;}
[C++]
public: __property double get_MinWidth();
public: __property void set_MinWidth(
   double value
);
[C++/CLI]
public:
property double MinWidth {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseEnter Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseEnter Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseEnter() As MouseEventHandler
[C#]
public event MouseEventHandler MouseEnter();
[C++]
public: __event MouseEventHandler MouseEnter();
[C++/CLI]
public:
event MouseEventHandler MouseEnter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeave Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseLeave Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseLeave() As MouseEventHandler
[C#]
public event MouseEventHandler MouseLeave();
[C++]
public: __event MouseEventHandler MouseLeave();
[C++/CLI]
public:
event MouseEventHandler MouseLeave();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonDown Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseLeftButtonDown Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseLeftButtonDown() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonDown();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonDown();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseLeftButtonUp Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseLeftButtonUp Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseLeftButtonUp() As MouseButtonEventHandler
[C#]
public event MouseButtonEventHandler MouseLeftButtonUp();
[C++]
public: __event MouseButtonEventHandler MouseLeftButtonUp();
[C++/CLI]
public:
event MouseButtonEventHandler MouseLeftButtonUp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseMove Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseMove Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseMove() As MouseEventHandler
[C#]
public event MouseEventHandler MouseMove();
[C++]
public: __event MouseEventHandler MouseMove();
[C++/CLI]
public:
event MouseEventHandler MouseMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

MouseWheel Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : MouseWheel Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event MouseWheel() As MouseWheelEventHandler
[C#]
public event MouseWheelEventHandler MouseWheel();
[C++]
public: __event MouseWheelEventHandler MouseWheel();
[C++/CLI]
public:
event MouseWheelEventHandler MouseWheel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Name Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Name Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnApplyTemplate Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : OnApplyTemplate Method (TreeViewMultiColumnRow)
[Visual Basic]
<SecuritySafeCriticalAttribute()>
Public Overridable Sub OnApplyTemplate()
[C#]
[SecuritySafeCriticalAttribute()]
public virtual void OnApplyTemplate();
[C++]
[SecuritySafeCriticalAttribute()]
public: virtual void OnApplyTemplate();
[C++/CLI]
[SecuritySafeCriticalAttribute()]
public:
virtual void OnApplyTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OnCreateAutomationPeer Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : OnCreateAutomationPeer Method (TreeViewMultiColumnRow)
[Visual Basic]
Protected Overridable Function OnCreateAutomationPeer() As AutomationPeer
[C#]
protected virtual AutomationPeer OnCreateAutomationPeer();
[C++]
protected: virtual AutomationPeer OnCreateAutomationPeer();
[C++/CLI]
protected:
virtual AutomationPeer OnCreateAutomationPeer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Opacity Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Opacity Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Opacity As Double
[C#]
public double Opacity {get; set;}
[C++]
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
[C++/CLI]
public:
property double Opacity {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

OpacityMask Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : OpacityMask Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property OpacityMask As Brush
[C#]
public Brush OpacityMask {get; set;}
[C++]
public: __property Brush get_OpacityMask();
public: __property void set_OpacityMask(
   Brush value
);
[C++/CLI]
public:
property Brush OpacityMask {
   Brush get();
   void set (Brush value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Parent Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Parent Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property Parent As DependencyObject
[C#]
public DependencyObject Parent {get;}
[C++]
public: __property DependencyObject get_Parent();
[C++/CLI]
public:
property DependencyObject Parent {
   DependencyObject get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Projection Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Projection Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Projection As Projection
[C#]
public Projection Projection {get; set;}
[C++]
public: __property Projection get_Projection();
public: __property void set_Projection(
   Projection value
);
[C++/CLI]
public:
property Projection Projection {
   Projection get();
   void set (Projection value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
See Also Languages GTP.NET.SL Send comments on this topic.

ReadLocalValue Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ReadLocalValue Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function ReadLocalValue( _
   ByVal dp As DependencyProperty _
) As Object
[C#]
public object ReadLocalValue(
   DependencyProperty dp
);
[C++]
public: Object* ReadLocalValue(
   DependencyProperty dp
)
[C++/CLI]
public:
Object^ ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ReleaseMouseCapture Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ReleaseMouseCapture Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub ReleaseMouseCapture()
[C#]
public void ReleaseMouseCapture();
[C++]
public: void ReleaseMouseCapture();
[C++/CLI]
public:
void ReleaseMouseCapture();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

routedEvent
handler
See Also Languages GTP.NET.SL Send comments on this topic.

RemoveHandler Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : RemoveHandler Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub RemoveHandler( _
   ByVal routedEvent As RoutedEvent, _
   ByVal handler As Delegate _
)
[C#]
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
);
[C++]
public: void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate* handler
)
[C++/CLI]
public:
void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate^ handler
)

Parameters

routedEvent
handler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderSize Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : RenderSize Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property RenderSize As Size
[C#]
public Size RenderSize {get;}
[C++]
public: __property Size get_RenderSize();
[C++/CLI]
public:
property Size RenderSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransform Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : RenderTransform Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property RenderTransform As Transform
[C#]
public Transform RenderTransform {get; set;}
[C++]
public: __property Transform get_RenderTransform();
public: __property void set_RenderTransform(
   Transform value
);
[C++/CLI]
public:
property Transform RenderTransform {
   Transform get();
   void set (Transform value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RenderTransformOrigin Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : RenderTransformOrigin Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property RenderTransformOrigin As Point
[C#]
public Point RenderTransformOrigin {get; set;}
[C++]
public: __property Point get_RenderTransformOrigin();
public: __property void set_RenderTransformOrigin(
   Point value
);
[C++/CLI]
public:
property Point RenderTransformOrigin {
   Point get();
   void set (Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Resources Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Resources Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Resources As ResourceDictionary
[C#]
public ResourceDictionary Resources {get; set;}
[C++]
public: __property ResourceDictionary get_Resources();
public: __property void set_Resources(
   ResourceDictionary value
);
[C++/CLI]
public:
property ResourceDictionary Resources {
   ResourceDictionary get();
   void set (ResourceDictionary value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

RowDefinitions Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : RowDefinitions Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property RowDefinitions As RowDefinitionCollection
[C#]
public RowDefinitionCollection RowDefinitions {get;}
[C++]
public: __property RowDefinitionCollection get_RowDefinitions();
[C++/CLI]
public:
property RowDefinitionCollection RowDefinitions {
   RowDefinitionCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
binding
See Also Languages GTP.NET.SL Send comments on this topic.

SetBinding Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : SetBinding Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function SetBinding( _
   ByVal dp As DependencyProperty, _
   ByVal binding As Binding _
) As BindingExpressionBase
[C#]
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
);
[C++]
public: BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)
[C++/CLI]
public:
BindingExpressionBase SetBinding(
   DependencyProperty dp,
   Binding binding
)

Parameters

dp
binding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

dp
value
See Also Languages GTP.NET.SL Send comments on this topic.

SetValue Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : SetValue Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub SetValue( _
   ByVal dp As DependencyProperty, _
   ByVal value As Object _
)
[C#]
public void SetValue(
   DependencyProperty dp,
   object value
);
[C++]
public: void SetValue(
   DependencyProperty dp,
   Object* value
)
[C++/CLI]
public:
void SetValue(
   DependencyProperty dp,
   Object^ value
)

Parameters

dp
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

ShowGridLines Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : ShowGridLines Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property ShowGridLines As Boolean
[C#]
public bool ShowGridLines {get; set;}
[C++]
public: __property bool get_ShowGridLines();
public: __property void set_ShowGridLines(
   bool value
);
[C++/CLI]
public:
property bool ShowGridLines {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

SizeChanged Event

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : SizeChanged Event (TreeViewMultiColumnRow)
[Visual Basic]
Public Event SizeChanged() As SizeChangedEventHandler
[C#]
public event SizeChangedEventHandler SizeChanged();
[C++]
public: __event SizeChangedEventHandler SizeChanged();
[C++/CLI]
public:
event SizeChangedEventHandler SizeChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Style Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Style Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Style As Style
[C#]
public Style Style {get; set;}
[C++]
public: __property Style get_Style();
public: __property void set_Style(
   Style value
);
[C++/CLI]
public:
property Style Style {
   Style get();
   void set (Style value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Tag Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Tag Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

visual
See Also Languages GTP.NET.SL Send comments on this topic.

TransformToVisual Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : TransformToVisual Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Function TransformToVisual( _
   ByVal visual As UIElement _
) As GeneralTransform
[C#]
public GeneralTransform TransformToVisual(
   UIElement visual
);
[C++]
public: GeneralTransform TransformToVisual(
   UIElement visual
)
[C++/CLI]
public:
GeneralTransform TransformToVisual(
   UIElement visual
)

Parameters

visual

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Triggers Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Triggers Property (TreeViewMultiColumnRow)
[Visual Basic]
Public ReadOnly Property Triggers As TriggerCollection
[C#]
public TriggerCollection Triggers {get;}
[C++]
public: __property TriggerCollection get_Triggers();
[C++/CLI]
public:
property TriggerCollection Triggers {
   TriggerCollection get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UpdateLayout Method

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : UpdateLayout Method (TreeViewMultiColumnRow)
[Visual Basic]
Public Sub UpdateLayout()
[C#]
public void UpdateLayout();
[C++]
public: void UpdateLayout();
[C++/CLI]
public:
void UpdateLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

UseLayoutRounding Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : UseLayoutRounding Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property UseLayoutRounding As Boolean
[C#]
public bool UseLayoutRounding {get; set;}
[C++]
public: __property bool get_UseLayoutRounding();
public: __property void set_UseLayoutRounding(
   bool value
);
[C++/CLI]
public:
property bool UseLayoutRounding {
   bool get();
   void set (bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

VerticalAlignment Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : VerticalAlignment Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property VerticalAlignment As VerticalAlignment
[C#]
public VerticalAlignment VerticalAlignment {get; set;}
[C++]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[C++/CLI]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (VerticalAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Visibility Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Visibility Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Visibility As Visibility
[C#]
public Visibility Visibility {get; set;}
[C++]
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
[C++/CLI]
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%PageItemTitle%%

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages GTP.NET.SL Send comments on this topic.

Width Property

PlexityHide.GTP Namespace > TreeViewMultiColumnRow Class : Width Property (TreeViewMultiColumnRow)
[Visual Basic]
Public Property Width As Double
[C#]
public double Width {get; set;}
[C++]
public: __property double get_Width();
public: __property void set_Width(
   double value
);
[C++/CLI]
public:
property double Width {
   double get();
   void set (double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

TreeViewMultiColumnRow Class | TreeViewMultiColumnRow Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

GTP.NET.SL Assembly

See Also GTP.NET.SL Send comments on this topic.

PlexityHide.GTP Namespace Inheritance Hierarchy

System.Object
PlexityHide.GTP.CollisionNote
PlexityHide.GTP.ConflictArea
PlexityHide.GTP.DateScaleMark
PlexityHide.GTP.MultiColumnCoordinator
PlexityHide.GTP.MyExtensions
PlexityHide.GTP.NonLinearTime
PlexityHide.GTP.TimeDistinctItem
PlexityHide.GTP.TimeDistinctThread
System.Collections.Generic.Comparer<TimeDistinctItem>
PlexityHide.GTP.TimeDistinctThread.StartComparer
PlexityHide.GTP.TimeDistinctThread.StopComparer
System.EventArgs
PlexityHide.GTP.BeforeScaleOrSpanChangeArgs
PlexityHide.GTP.CollisionDetectEventArgs
PlexityHide.GTP.ConflictArea_UpdateArgs
PlexityHide.GTP.ExternalDropArgs
PlexityHide.GTP.GanttUserDrawArgs
PlexityHide.GTP.LinkUserDrawEventArgs
PlexityHide.GTP.NotifyTimeItem
PlexityHide.GTP.OnGanttRowMinHeightChangeArgs
PlexityHide.GTP.OnTimeItemChangeArgs
PlexityHide.GTP.RowChangeArgs
PlexityHide.GTP.TextOutOverrideArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.ContentPresenter
PlexityHide.GTP.TimeItemLinkItem
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.ListBoxItem
PlexityHide.GTP.GanttRowItem
System.Windows.Controls.ItemsControl
PlexityHide.GTP.TimeItemLinks
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
PlexityHide.GTP.GanttRow
System.Windows.Controls.Panel
PlexityHide.GTP.DateScaler
System.Windows.Controls.Canvas
PlexityHide.GTP.GanttRowCanvas
PlexityHide.GTP.TimeItem
PlexityHide.GTP.TimeItemLink
PlexityHide.GTP.TimeItemLinkCanvas
System.Windows.Controls.Grid
PlexityHide.GTP.Gantt
PlexityHide.GTP.TreeViewMultiColumnRow

See Also

PlexityHide.GTP Namespace | GTP.NET.SL Assembly