$$INTRODUCTION$$ - %%projecttitle%%

PlexityHide.GTP
Introduction
Send comments on this topic.

Glossary Item Box

Welcome to GTP.NET 3.0

Thank you for taking the time to learn about GTP.NET.

Introduction to GTP.NET 3.0

GTP.NET 3.0 contains a sample series named "LetsBuild_". Currently there are 3 distinctively different samples in this series. They are "LetsBuild_ProjectPlanner", "LetsBuild_ResourceBooker" and "LetsBuild_WeeklyPlanner".

The 3 samples shows different patterns of time visualization and manipulation. Depending on your current task you can choose the sample that resembles your need at hand the most and quickly get started with GTP.NET.

To get a good understanding of GTP.NET all 3 samples combined is recommended.

All 3 samples are short and to the point of the problem they solve. You will want to elaborate a lot more to get a compelling finished product.

PlexityHide also offers a lot more specialized samples that can be downloaded to really get in deep with the GTP.NET object model, but if you just stick to the "LetsBuild_" samples series we believe you will get started and introduced to the important parts just fine.

The samples build WindowsForms applications, and they are key to understanding GTP.NET even if your aim is to build ASP.NET or Ajax solutions with the GTP.NET.

The delivery model of your finished product is mostly indifferent when it comes to understanding the GTP.NET object model. GTP.NET will help you with time visualization and manipulation in WindowsForms, ASP.NET, Microsoft Ajax, ClickOnce and XBAP (rich .net controls inside ie).

These are the main areas where GTP.NET shines:

#1 Integration in any .NET environment to visualize time based information for any reason
#2 To allow end users to graphically change time based information (you have full control to stop or allow anything)
#3 To allow the developer full control over look and feel of the finished product.
#4 To integrate into .NET DataSource structures
#5 To help you expose your time based data on the WEB with ASP.NET and microsoft Ajax, the same easy way you show data on windows forms
#6 Give end users a fantastic tool to quickly scan loads of information with time-zoom and fish-eye functions
#7 Give developers a rich API that has been proven around the world

These are the areas were we strive to be better than our competitors:

#1 Faster, both in execution and in adding new features and fixing bugs
#2 More flexible, both in communications and API
#3 No runtime fees
#4 Full source available
#5 Not to make locking assumptions about usage of the GTP.NET, we do not enforce a project planning attitude

Quick function checklist

Feature list

#1 Integration in any .NET environment to visualize time based information for any reason
#2 To allow end users to graphically change time based information (you have full control to stop or allow anything)
#3 To allow the developer full control over look and feel of the finished product.
#4 To integrate into .NET DataSource structures
#5 To help you expose your time based data on the WEB with ASP.NET and Microsoft Ajax, the same easy way you show data on windows forms
#6 Give end users a fantastic tool to quickly scan loads of information with time-zoom and fish-eye functions
#7 Give developers a rich API that has been proven around the world

These are the areas were we strive to be better than our competitors:

#1 Faster, both in execution and in adding new features and fixing bugs
#2 More flexible, both in communications and API
#3 No runtime fees
#4 Full source available
#5 Not to make locking assumptions about usage of the GTP.NET, we do not enforce a project planning attitude

In 3.0

Microsoft Ajax support with client movable and re-sizable time items
Datescaler has better hour-style presentation for ScheduleMode
ASP.NET Schedule (Ajax enabled also)
GUI Re-assignable links (Windows forms)
Full databind of Links, TimeItems, GridNodes (A lot of improvements)
ConflictAreas and detailed tracking of colliding areas for time items
Two new TimeItemStyles
DateScaler zoom around click point
Methods to find objects from UserReference on GridNodes, GanttRows, Layers and TimeItems
PickValueEdit in Grid, to ease input work on users, a window can popup and allow users to choose from common values
TimeMoveMarkers to help users see where movements end up
GTP.NET has been made fully security aware, reducing functionality automatically in low trust environments (ClickOnce, XBAP)
Really down to earth understandable samples on how to build A ProjectPlanner, A Resource booker and A Week planner using Databind

In 2.0

Schedule mode equally powerful as Gantt
Selectable Links
LinkActions
InvisbleLinks
Print multi page both in X and Y axis
End user CreateNewTimeItem on screen
UserDrawLinks
Improved Link rendering
Grid Rowresize
Improved Collision Detection
GridNode filtering
Month day numbers, new option in datescale

In 1.0

Grid
Free tree column
Inplace edit
Multiple edit modes
Layout per cell
Gantt row per Grid node
Multiple layers per Gantt row
Multiple Time items per layer
Multiple Time items Texts per Time Item
Time Item Layout per time item
Time Item Text Layout per time item text
Free zoom date scale
Seconds view
Minute view
Hour view
Day View
Week view
Month view
Year view
Decade view
Date format override
Date adapts to locales
Drag and drop in Grid
Drag and drop in time item area
Resize time items
Time item links
Multiple Time item link styles
Collision detect for time items
Today line
Striped background
Time hiding
Day hiding
Fish eye function in date scale
DataSource Compatible
Row select in grid
Background draw override in Time item area
Background draw override in date scaler area
Foreground draw override in Time item area
Foreground draw override in date scaler area

Did not find what you need?

Ask us about it, we do extensions and anything goes. All request for extensions are evaluated by the product Architect and must be of a generic nature to qualify for the GTP.NET. Extension work is offered as fixed price development based on accepted client spec and our own estimates.

© plexityHide, Stockholm, Sweden 2003,2004,2005,2006,2007. All Rights Reserved.

© 2012 All Rights Reserved.


%%phrase%%

PlexityHide.GTP Assembly
See Also Send comments on this topic.

Glossary Item Box

Brief

GTP.NET is a component package for .NET. The components helps you with time visualization and interaction. GTP.NET contains a fully interactive Gantt chart and a fully interactive Schedule chart. GTP.NET components can be delivered via WindowsForms applications, ASP.NET, Microsoft Ajax and even in reduced trust environments like ClickOnce and XBAP. GTP.NET is runtime royalty free.

Who should use GTP.NET
Organizations that handle time oriented data will benefit from providing the market leading tool of time visualization and interaction to their developers. .NET developers using c#, VB.NET and Delphi.NET will gain momentum using the GTP.NET from plexityHide.com. Anyone that needs to represent and change time oriented data with windows forms or ASP.NET or XBAP or ClickOnce will get great advantages from using the GTP.NET that delivers 6000+ high quality man-hours focused on the specialized generic issue of time presentation and interaction.

Namespaces

Namespace | Description
(Global) |
PlexityHide.GTP |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send comments on this topic.

Glossary Item Box

Online samples GTP.NET

In the following pages you will learn about specific areas of the GTP.NET components so that you can make better use of the components in your own projects. The samples are kept simple so in order solve a real business case you will need to combine an understanding of several of these samples.

The samples in this section are all constructed in C#. C# is a popular .NET languages and it is also easy to translate to VB.NET and Delphi.NET.

Do you miss a specific topic? Please let us know, we encourage user demand and initiative. support@plexityHide.com.

UML class diagram of the GTP.NET components

Time items

Collision detection

Drawing layers

Texts

Styles

Layouts

Date scaler

Zooming

Traversing in time

Time hiding

Day hiding

Fish eye

Grid

Adding data

Looks and CellLayouts

CellLayouts contiuned 1

CellLayouts continued 2

User draw and custom cells

Inline edit modes

Databind

Connecting

Read more on datasource connecting at plexityHide

Read more at plexityhide LetsBuild_ProjectPlanner

Read more at plexityhide LetsBuild_WeeklyPlanner

Read more at plexityhide LetsBuild_ResourceBooker

Read more on Gantt_ASP ASP.NET and Ajax Gantt


%%ItemTitle%%

(Global) Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Glossary Item Box

See Also

Reference

PlexityHide.GTP Assembly


%%ItemTitle%%

PlexityHide.GTP Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Glossary Item Box

Classes

 | Class | Description
Class | AfterEditEventArgs | Arguments cell after edit
Class | BeforeEditEventArgs | Arguments cell edit
Class | BeforeEndEditEventArgs | Arguments cell edit
Class | BeforeFocusedCellChangeEventArgs | Arguments in the OnBeforeFocusedCellChange event
Class | BeforeScaleOrSpanChangeArgs | Arguments for the BeforeScaleOrSpanChange event
Class | BoolCheck | This is the value holder for cells that show boolean data. CellType=BoolCheck
Class | Calendar | The Calendar contains entries (CalendarEntry) that define intervals. These Intervals can be decucted from TimeItems that use BlockedTimeCalculatedStop
Class | Calendar_UserDrawArgs | The argument used by the OnCalendar_UserDraw event
Class | CalendarCollection | a Gantt chart may have several Calendars, they are kept in a collection of this type.
Class | CalendarEntry | CalendarEntry defines a Start and Stop in time. CalenderEntries are combined and owned by a Calendar. Calendars can draw all the entries in the background of the TimeItemArea or DateScaler. Calendars can also be used in TimeItemLayouts as defining BlockedTime. When this is true the TimeItem has a given Length and a Calculated stop. The calculation is Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.
Class | CalendarEntryCollection | Collection of CalendarEntries
Class | Cell | Holds an individual cell in the grid.
Class | CellAndDSArgs | Arguments for node events
Class | CellLayout | Holds all the properties that define the layout at cell rendering.
Class | CellLayouts | CellLayouts holds CellLayout objects that control cell rendering behaviour.
Class | CellSelectChangedEventArgs |
Class | CellTypeChooseEventArgs |
Class | CollisionDetectEventArgs | CollisionDetect event args
Class | CollisionNote | Holds detailed information about one collision
Class | ColumnOrderArgs | Arguments for ColumnOrderEvent
Class | ComboText | ComboText.
Class | CommonDataConnect |
Class | ComparerForGridSort | This class is used internaly when performing unbinded sort.
Class | ConflictArea | This class represents the detailed information that can be collected on each collision that is detected. To collect conflictAreas for a time item GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true.
Class | ConflictArea_UpdateArgs | The arguments used by the ConflictArea_Update event
Class | ConflictArea_UserDrawArgs | The argument used by the ConflictArea_UserDraw event
Class | ContentEntity | ContentEntity.
Class | CountedBitmap |
Class | CustomCell | CustomCell.
Class | CustomCellEventArgs | Arguments for custom cell drawing and editing
Class | DateScaleMark | DateScaleMark holds info about one current scale mark in the DateScaler
Class | DateScaler | DateScaler holds logic for conversion between draw space and time space.
Class | DateScalerDrawBoxesEventArgs | Arguments for date scaler draw boxes event
Class | DateScalerDrawStringEventArgs | Arguments for date scaler draw text event
Class | DateScalerProperties | Exposes some properties of the datescaler to the Gantt in design time
Class | EachListItemWhenDataBoundArgs | Arguments the OnEachListItemWhenDataBound event
Class | EditPickValueWindow | EditPickValueWindow implement the small window that optionally shows under the edited field in the grid
Class | ErrorEventArgs | Exceptions can be handled through the Error Event
Class | Gantt | Gantt component.
Class | GanttRow | A Gantt row is owned by a TreeNode and used for time item rendering in layers
Class | Grid | The Grid component. This grid can work stand-alone or as a part of the Gantt.
Class | GridColumn | Holds the characteristics of a grid column.
Class | GridColumns | Holds the structure for the set of columns and the manipulation possible.
Class | GridNode | Grid node constitues one row in the grid.
Class | GridNodes | GridNodes.
Class | GridProperties | Exposes some properties of the Grid to the Gantt in design time
Class | GridStructure | Structure for the nodes of the grid.
Class | ImageMapLogic | Holds all logic for generating imagemaps for the GTP.NET components
Class | IMapArea | This object holds the definition for one active area in the image map. You will need to add the href part yourself in the callback ImageMapActionCallback to implement your action
Class | Layer | A layer holds possibly many time items on one GanttRow, there can be many layers on one GanttRow. The point of creating many layers on a single row is to control the drawing order, ie the z-order.
Class | LayerEventArgs | Arguments for layer events
Class | Layers | Collection of layers that is held by one GanttRow
Class | LineOption | LineOption
Class | LinkActionEventArgs | CollisionDetect event args
Class | LinkAndDSArgs | Arguments for time item data events
Class | LinkDataConnect | LinkDataConnect coordinates info between a list of Links (a TimeItemLinks) and a dataSource
Class | ListWrapper | The list wrapper is a helper class that allows for easy binding of IList implementing classes to IListSource requiring components
Class | ModDateTimePicker | ModDateTimePicker.
Class | ModTextBox | ModTextBox.
Class | MultiText | Holds the content of a grid cell of type SingleText.
Class | NodeDataConnect | NodeDataConnect coordinates data between a gridnodelist and a datasource.
Class | NodeEventArgs | Arguments for node events
Class | NonLinearTime | Holds a non-linear time line, the non-linearity is limited to hiding of specific hours during all days and/or hiding of specific days during every week.
Class | OffscreenDraw | OffscreenDraw is base class for Grid DateScaler and TimeArea
Class | OffscreenDrawArgs | Arguments for offscreen draw events
Class | OnUserDrawSortSymbolArgs | Arguments for the OnUserDrawSortSymbol event
Class | PanButton | PanButton.
Class | PanEventArgs |
Class | PreCursorChangeEventArgs | Arguments for PreCursorChange event
Class | RowResizeArgs | Arguments for RowResize event
Class | RowResizeDoneArgs | Arguments for RowResizeDone event
Class | SingleText | Holds the content of a grid cell of type SingleText.
Class | TimeAreaOffscreenDraw | Shows time items based on DateScaler and Grid
Class | TimeDate | Holds a DateTime structure as content for a cell.
Class | TimeDistinctItem | Defines the data that is used by collision detect.
Class | TimeDistinctThread | This class is used internally and helps GanttRows to find a collision free position asynchronously.
Class | TimeItem | TimeItem is a time object that is drawn in the gantt
Class | TimeItemAndDSArgs | Arguments for time item data events
Class | TimeItemDataConnect | TimeItemDataConnect coordinates info between a list of timeitems (a layer) and a dataSource
Class | TimeItemDraw | Class that holds drawing styles of time items
Class | TimeItemEventArgs | Time item event args
Class | TimeItemLayout | Holds all the properties that define the layout time item rendering. For example; To show a time item of type Image do like this: First you must assign an imagelist with your images to Gantt.ImageList. Then assign a timeitemlayout to the time item, with TimeItemStyle=Image, and the TimeItemLayout.ImageIndex you set to the index in the imagelist
Class | TimeItemLayouts | TimeItemLayouts keeps the TimeItemLayouts in a Gantt.
Class | TimeItemLink | A Time link is an arrow between two different time items
Class | TimeItemLinkArgs | TimeItemLinkArgs
Class | TimeItemLinks | The collection of all links in the Gantt
Class | TimeItemText | TimeItemText handles the drawing of texts inside TimeItems
Class | TimeItemTextLayout | Holds all the properties that define the layout for texts inside Time items.
Class | TimeItemTextLayouts | TimeItemLayouts is the collection of TimeItemLayout.
Class | TimeItemTexts | TimeItemTexts is held by TimeItems to hold texts that should be shown inside.
Class | TopLeftChangedEventArgs |
Class | UnBindedSortArgs | Arguments for UnBindedSort
Class | UnhandledExceptionArgs | Arguments UnhandledExceptionEvent
Class | UserBrushCreateEventArgs | Since the brush is a very potent tool with a myriad of possibilities we decided to allow a you to create and define it. This is somewhat less complex that implementing a user drawn time item, but can be used in combination with those.
Class | UserDrawLinkEventArgs | UserDrawLink event args
Class | ViewDateInformationArgs | Arguments for the OnViewDateInformation event The View information is the text normally placed in the upper left corner of the datescaler. This text displays the start - stop as text in default drawing.

Interfaces

 | Interface | Description
Interface | IClipboardInteraction | Interface that ContentEntity implementations fullfill to handle clipboard cut and paste Let you derived contentEntity implement this interface to receive clipboard data in custom cells

Delegates

 | Delegate | Description
Delegate | AfterDrawEvent |
Delegate | AfterEditCellHandler |
Delegate | BeforeFocusedCellChangeHandler |
Delegate | BeforeScaleOrSpanChangeEventHandler |
Delegate | Calendar_UserDraw | The delegate for Calendar_UserDrawArgs
Delegate | CellSelectChangedHandler |
Delegate | CellToDSEventHandler |
Delegate | CellTypeChooseHandler |
Delegate | CollisionDetectEvent | The delegate for CollisionDetection
Delegate | ColumnOrderEventHandler |
Delegate | ConflictArea_Update | The delegate for ConflictArea_Update
Delegate | ConflictArea_UserDraw | The delegate for ConflictArea_UserDraw
Delegate | CustomCellEventHandler | Delegate for CustomCellEvents
Delegate | DateScalerDrawBoxesEventHandler |
Delegate | DateScalerDrawStringEventHandler |
Delegate | EachListItemWhenDataBoundHandler |
Delegate | EditCellHandler |
Delegate | EndEditCellHandler |
Delegate | ErrorEvent | The delegate for Error handling
Delegate | ImageMapActionCallback | Implement this delegate and send in a reference when producing your image maps, it will be necessary to do this in order to assign you actions to possible clicks
Delegate | LayerEvent | Delegate for insert and remove in a Layer
Delegate | LinkActionEvent | The delegate for LinkActions
Delegate | LinkToDSEventHandler |
Delegate | NodeEventHandler | Delegate for insert and remove node ops
Delegate | NodeExpandStatusHandler |
Delegate | OffscreenDrawEvent |
Delegate | PanButton.PanEventHandler |
Delegate | PreCursorChangeEvent |
Delegate | RowResizeDoneEventHandler | Delegate for catching user resized grid row
Delegate | RowResizeEventHandler | Delegate for catching user resize grid row
Delegate | TimeDistinctThread.AsyncDelegate |
Delegate | TimeItem_UserBrushCreate | The delegate for TimeItem_UserBrushCreate, event fires when you use TimeItemLayout.BrushKind=BrushKind.UserCreatedBrush
Delegate | TimeItemEvent |
Delegate | TimeItemLinkHandler | Used for TimeItemLinkEvents
Delegate | TimeItemToDSEventHandler |
Delegate | TopLeftChangedHandler |
Delegate | UnBindedSortHandler | Event delegate is used when a column sort occures on an unbinded list
Delegate | UnhandledExceptionEvent |
Delegate | UserDrawLinkEvent | The delegate for UserDrawLinkEvent
Delegate | ViewDateInformationEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | BrushKind | Time items are filled with one of these brushkinds
Enumeration | CalendarBrushKind | The brushkinds available in CalendarEntry drawing
Enumeration | CalendarDrawArea | Enum that describes where a calendar is about to be drawn
Enumeration | CellType | The possible values for GridColumn.Type
Enumeration | CollectionEventKind | Events in the node collection
Enumeration | ConflictAreaDrawStyle | ConflictAreas can be drawn with different styles
Enumeration | ConflictAreaUpdateKind | The Different kinds of update that may be signaled on a conflict area
Enumeration | DateScaleMark.AreaEnum | DateScale has different areas
Enumeration | DateScalerChangeKind | In the BeforeScaleOrSpanChange event this enum specifies what started the change
Enumeration | FishEyeMagnification | FishEyeMagnification.
Enumeration | GridNodeScreenStatus | Enum values for ScreenStatus of a single GridNode on the last operation
Enumeration | HeaderType | Values for grid header rendering
Enumeration | MouseMoveKind | The different mouse move states possible
Enumeration | NonLinearTime.TimeResolution | Enumeration for all availbale time scale resolutions
Enumeration | PanButton.PanDirection |
Enumeration | PanEventArgs.PanSpeed |
Enumeration | ResizingType | Resizing characteristics.
Enumeration | TimeItemLinkAction | TimeItemLinkActions are executed when the time items in the link are changed (Start or Stop is changed). LinkActions can help you enforce some of the business rules that you want to stay in effect when the user changes time items
Enumeration | TimeItemLinkDrawStrategy | Set this to influence if the TimeItemLink can be drawn when the TimeItems are on opposite sides of the visible area
Enumeration | TimeItemLinkDrawStyle | The draw style of a link
Enumeration | TimeItemLinkStyle | The style of link
Enumeration | TimeItemStyle | Time items is drawn according to one of these schemes
Enumeration | TimeStrEnum |

See Also

Reference

PlexityHide.GTP Assembly


%%PageItemTitle%%

[image]
PlexityHide.GTP
AfterEditEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : AfterEditEventArgs Class

Glossary Item Box

Arguments cell after edit

Object Model

AfterEditEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class AfterEditEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As AfterEditEventArgs
C#
public class AfterEditEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class AfterEditEventArgs : public System.EventArgs
C++/CLI
public ref class AfterEditEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.AfterEditEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

AfterEditEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
AfterEditEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : AfterEditEventArgs Class

Glossary Item Box

The following tables list the members exposed by AfterEditEventArgs.

Public Constructors

 | Name | Description
Public Constructor | AfterEditEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The cell that has been applied or abandoned
Top

See Also

Reference

AfterEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AfterEditEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > AfterEditEventArgs Class : AfterEditEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New AfterEditEventArgs()
C#
public AfterEditEventArgs()
Managed Extensions for C++
public: AfterEditEventArgs();
C++/CLI
public:
AfterEditEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
AfterEditEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : AfterEditEventArgs Class

Glossary Item Box

For a list of all members of this type, see AfterEditEventArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The cell that has been applied or abandoned
Top

See Also

Reference

AfterEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > AfterEditEventArgs Class : Cell Field

Glossary Item Box

The cell that has been applied or abandoned

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As AfterEditEventArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AfterEditEventArgs Class
AfterEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeEditEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEditEventArgs Class

Glossary Item Box

Arguments cell edit

Object Model

BeforeEditEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BeforeEditEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BeforeEditEventArgs
C#
public class BeforeEditEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class BeforeEditEventArgs : public System.EventArgs
C++/CLI
public ref class BeforeEditEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.BeforeEditEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeEditEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
BeforeEditEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEditEventArgs Class

Glossary Item Box

The following tables list the members exposed by BeforeEditEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BeforeEditEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The cell about to go into edit mode
Public Field | editAllowed | If you this value to false the cell will not go into edit mode
Public Field | ShowEditPickValueWindow | The Edit pick value mimics the behaviour of the IE value chooser that shows below editors, If you choose to use it, you can populate its internal listbox with pick values
Top

See Also

Reference

BeforeEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeEditEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEditEventArgs Class : BeforeEditEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BeforeEditEventArgs()
C#
public BeforeEditEventArgs()
Managed Extensions for C++
public: BeforeEditEventArgs();
C++/CLI
public:
BeforeEditEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
BeforeEditEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEditEventArgs Class

Glossary Item Box

For a list of all members of this type, see BeforeEditEventArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The cell about to go into edit mode
Public Field | editAllowed | If you this value to false the cell will not go into edit mode
Public Field | ShowEditPickValueWindow | The Edit pick value mimics the behaviour of the IE value chooser that shows below editors, If you choose to use it, you can populate its internal listbox with pick values
Top

See Also

Reference

BeforeEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEditEventArgs Class : Cell Field

Glossary Item Box

The cell about to go into edit mode

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As BeforeEditEventArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
editAllowed Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEditEventArgs Class : editAllowed Field

Glossary Item Box

If you this value to false the cell will not go into edit mode

Syntax

Visual Basic (Declaration)
Public editAllowed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BeforeEditEventArgs
Dim value As Boolean

value = instance.editAllowed

instance.editAllowed = value
C#
public bool editAllowed
Managed Extensions for C++
public: bool editAllowed
C++/CLI
public:
bool editAllowed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowEditPickValueWindow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEditEventArgs Class : ShowEditPickValueWindow Field

Glossary Item Box

The Edit pick value mimics the behaviour of the IE value chooser that shows below editors, If you choose to use it, you can populate its internal listbox with pick values

Syntax

Visual Basic (Declaration)
Public ShowEditPickValueWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BeforeEditEventArgs
Dim value As Boolean

value = instance.ShowEditPickValueWindow

instance.ShowEditPickValueWindow = value
C#
public bool ShowEditPickValueWindow
Managed Extensions for C++
public: bool ShowEditPickValueWindow
C++/CLI
public:
bool ShowEditPickValueWindow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEditEventArgs Class
BeforeEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeEndEditEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEndEditEventArgs Class

Glossary Item Box

Arguments cell edit

Object Model

BeforeEndEditEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BeforeEndEditEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BeforeEndEditEventArgs
C#
public class BeforeEndEditEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class BeforeEndEditEventArgs : public System.EventArgs
C++/CLI
public ref class BeforeEndEditEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.BeforeEndEditEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeEndEditEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
BeforeEndEditEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEndEditEventArgs Class

Glossary Item Box

The following tables list the members exposed by BeforeEndEditEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BeforeEndEditEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The cell about to be applied
Public Field | inputAllowed | If you set this to false the value will not be applied
Top

See Also

Reference

BeforeEndEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeEndEditEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEndEditEventArgs Class : BeforeEndEditEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BeforeEndEditEventArgs()
C#
public BeforeEndEditEventArgs()
Managed Extensions for C++
public: BeforeEndEditEventArgs();
C++/CLI
public:
BeforeEndEditEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEndEditEventArgs Class
BeforeEndEditEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
BeforeEndEditEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeEndEditEventArgs Class

Glossary Item Box

For a list of all members of this type, see BeforeEndEditEventArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The cell about to be applied
Public Field | inputAllowed | If you set this to false the value will not be applied
Top

See Also

Reference

BeforeEndEditEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEndEditEventArgs Class : Cell Field

Glossary Item Box

The cell about to be applied

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As BeforeEndEditEventArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEndEditEventArgs Class
BeforeEndEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
inputAllowed Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeEndEditEventArgs Class : inputAllowed Field

Glossary Item Box

If you set this to false the value will not be applied

Syntax

Visual Basic (Declaration)
Public inputAllowed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BeforeEndEditEventArgs
Dim value As Boolean

value = instance.inputAllowed

instance.inputAllowed = value
C#
public bool inputAllowed
Managed Extensions for C++
public: bool inputAllowed
C++/CLI
public:
bool inputAllowed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeEndEditEventArgs Class
BeforeEndEditEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeFocusedCellChangeEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeFocusedCellChangeEventArgs Class

Glossary Item Box

Arguments in the OnBeforeFocusedCellChange event

Object Model

BeforeFocusedCellChangeEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BeforeFocusedCellChangeEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BeforeFocusedCellChangeEventArgs
C#
public class BeforeFocusedCellChangeEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class BeforeFocusedCellChangeEventArgs : public System.EventArgs
C++/CLI
public ref class BeforeFocusedCellChangeEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.BeforeFocusedCellChangeEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeFocusedCellChangeEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
BeforeFocusedCellChangeEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : BeforeFocusedCellChangeEventArgs Class

Glossary Item Box

The following tables list the members exposed by BeforeFocusedCellChangeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BeforeFocusedCellChangeEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | NewFocusedCell | The cell about to get focus ; can be null. Change this value to take over the decision of focused cell. Like e.NewFocusedCell=e.OldFocusedCell stops the change of focus...
Public Field | OldFocusedCell | The cell about to loose focus ; can be null
Top

See Also

Reference

BeforeFocusedCellChangeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeFocusedCellChangeEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeFocusedCellChangeEventArgs Class : BeforeFocusedCellChangeEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BeforeFocusedCellChangeEventArgs()
C#
public BeforeFocusedCellChangeEventArgs()
Managed Extensions for C++
public: BeforeFocusedCellChangeEventArgs();
C++/CLI
public:
BeforeFocusedCellChangeEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeFocusedCellChangeEventArgs Class
BeforeFocusedCellChangeEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
BeforeFocusedCellChangeEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeFocusedCellChangeEventArgs Class

Glossary Item Box

For a list of all members of this type, see BeforeFocusedCellChangeEventArgs members.

Public Fields

 | Name | Description
Public Field | NewFocusedCell | The cell about to get focus ; can be null. Change this value to take over the decision of focused cell. Like e.NewFocusedCell=e.OldFocusedCell stops the change of focus...
Public Field | OldFocusedCell | The cell about to loose focus ; can be null
Top

See Also

Reference

BeforeFocusedCellChangeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NewFocusedCell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeFocusedCellChangeEventArgs Class : NewFocusedCell Field

Glossary Item Box

The cell about to get focus ; can be null. Change this value to take over the decision of focused cell. Like e.NewFocusedCell=e.OldFocusedCell stops the change of focus...

Syntax

Visual Basic (Declaration)
Public NewFocusedCell As Cell
Visual Basic (Usage) Copy Code
Dim instance As BeforeFocusedCellChangeEventArgs
Dim value As Cell

value = instance.NewFocusedCell

instance.NewFocusedCell = value
C#
public Cell NewFocusedCell
Managed Extensions for C++
public: Cell* NewFocusedCell
C++/CLI
public:
Cell^ NewFocusedCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeFocusedCellChangeEventArgs Class
BeforeFocusedCellChangeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OldFocusedCell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeFocusedCellChangeEventArgs Class : OldFocusedCell Field

Glossary Item Box

The cell about to loose focus ; can be null

Syntax

Visual Basic (Declaration)
Public OldFocusedCell As Cell
Visual Basic (Usage) Copy Code
Dim instance As BeforeFocusedCellChangeEventArgs
Dim value As Cell

value = instance.OldFocusedCell

instance.OldFocusedCell = value
C#
public Cell OldFocusedCell
Managed Extensions for C++
public: Cell* OldFocusedCell
C++/CLI
public:
Cell^ OldFocusedCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeFocusedCellChangeEventArgs Class
BeforeFocusedCellChangeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeScaleOrSpanChangeArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

Glossary Item Box

Arguments for the BeforeScaleOrSpanChange event

Object Model

BeforeScaleOrSpanChangeArgs Class

Syntax

Visual Basic (Declaration)
Public Class BeforeScaleOrSpanChangeArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BeforeScaleOrSpanChangeArgs
C#
public class BeforeScaleOrSpanChangeArgs : System.EventArgs
Managed Extensions for C++
public __gc class BeforeScaleOrSpanChangeArgs : public System.EventArgs
C++/CLI
public ref class BeforeScaleOrSpanChangeArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.BeforeScaleOrSpanChangeArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeScaleOrSpanChangeArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
BeforeScaleOrSpanChangeArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

Glossary Item Box

The following tables list the members exposed by BeforeScaleOrSpanChangeArgs.

Public Constructors

 | Name | Description
Public Constructor | BeforeScaleOrSpanChangeArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | DateScalerChangeKind | What kind of action that triggered the change
Public Field | IsZoom | true if called from the zoom operation; deprecated use DateScalerChangeKind instead
Public Field | NewStartTime | The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.
Public Field | NewStopTime | The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.
Top

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeScaleOrSpanChangeArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : BeforeScaleOrSpanChangeArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BeforeScaleOrSpanChangeArgs()
C#
public BeforeScaleOrSpanChangeArgs()
Managed Extensions for C++
public: BeforeScaleOrSpanChangeArgs();
C++/CLI
public:
BeforeScaleOrSpanChangeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
BeforeScaleOrSpanChangeArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeArgs Class

Glossary Item Box

For a list of all members of this type, see BeforeScaleOrSpanChangeArgs members.

Public Fields

 | Name | Description
Public Field | DateScalerChangeKind | What kind of action that triggered the change
Public Field | IsZoom | true if called from the zoom operation; deprecated use DateScalerChangeKind instead
Public Field | NewStartTime | The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.
Public Field | NewStopTime | The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.
Top

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerChangeKind Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : DateScalerChangeKind Field

Glossary Item Box

What kind of action that triggered the change

Syntax

Visual Basic (Declaration)
Public DateScalerChangeKind As DateScalerChangeKind
Visual Basic (Usage) Copy Code
Dim instance As BeforeScaleOrSpanChangeArgs
Dim value As DateScalerChangeKind

value = instance.DateScalerChangeKind

instance.DateScalerChangeKind = value
C#
public DateScalerChangeKind DateScalerChangeKind
Managed Extensions for C++
public: DateScalerChangeKind DateScalerChangeKind
C++/CLI
public:
DateScalerChangeKind DateScalerChangeKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsZoom Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : IsZoom Field

Glossary Item Box

true if called from the zoom operation; deprecated use DateScalerChangeKind instead

Syntax

Visual Basic (Declaration)
Public IsZoom As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BeforeScaleOrSpanChangeArgs
Dim value As Boolean

value = instance.IsZoom

instance.IsZoom = value
C#
public bool IsZoom
Managed Extensions for C++
public: bool IsZoom
C++/CLI
public:
bool IsZoom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NewStartTime Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : NewStartTime Field

Glossary Item Box

The new proposed value for start. Change this back to DateScaler.StartTime to stop the change.

Syntax

Visual Basic (Declaration)
Public NewStartTime As Date
Visual Basic (Usage) Copy Code
Dim instance As BeforeScaleOrSpanChangeArgs
Dim value As Date

value = instance.NewStartTime

instance.NewStartTime = value
C#
public DateTime NewStartTime
Managed Extensions for C++
public: DateTime NewStartTime
C++/CLI
public:
DateTime NewStartTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NewStopTime Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BeforeScaleOrSpanChangeArgs Class : NewStopTime Field

Glossary Item Box

The new proposed value for stop. Change this back to DateScaler.StopTime to stop the change.

Syntax

Visual Basic (Declaration)
Public NewStopTime As Date
Visual Basic (Usage) Copy Code
Dim instance As BeforeScaleOrSpanChangeArgs
Dim value As Date

value = instance.NewStopTime

instance.NewStopTime = value
C#
public DateTime NewStopTime
Managed Extensions for C++
public: DateTime NewStopTime
C++/CLI
public:
DateTime NewStopTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BeforeScaleOrSpanChangeArgs Class
BeforeScaleOrSpanChangeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BoolCheck Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : BoolCheck Class

Glossary Item Box

This is the value holder for cells that show boolean data. CellType=BoolCheck

Object Model

BoolCheck Class

Syntax

Visual Basic (Declaration)
Public Class BoolCheck
   Inherits ContentEntity
   Implements IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck
C#
public class BoolCheck : ContentEntity, IClipboardInteraction
Managed Extensions for C++
public __gc class BoolCheck : public ContentEntity, IClipboardInteraction
C++/CLI
public ref class BoolCheck : public ContentEntity, IClipboardInteraction

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.BoolCheck

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BoolCheck Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
BoolCheck Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : BoolCheck Class

Glossary Item Box

The following tables list the members exposed by BoolCheck.

Public Properties

 | Name | Description
Public Property | Check | Gets and sets the boolean value of the grid cell.
Public Property | Text | An optional text that is placed next to the checkbox (readonly)
Public Property | Value | Overridden. Treats the value as a boolean
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

BoolCheck Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
BoolCheck Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BoolCheck Class

Glossary Item Box

For a list of all members of this type, see BoolCheck members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

BoolCheck Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BoolCheck Class : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck

instance.CopyToClipboard()
C#
public void CopyToClipboard()
Managed Extensions for C++
public: void CopyToClipboard();
C++/CLI
public:
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoolCheck Class
BoolCheck Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BoolCheck Class : PasteValueFromClipboard Method

Glossary Item Box

Implements the pasting of clipboard data

Syntax

Visual Basic (Declaration)
Public Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck

instance.PasteValueFromClipboard()
C#
public void PasteValueFromClipboard()
Managed Extensions for C++
public: void PasteValueFromClipboard();
C++/CLI
public:
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoolCheck Class
BoolCheck Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
BoolCheck Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BoolCheck Class

Glossary Item Box

For a list of all members of this type, see BoolCheck members.

Public Properties

 | Name | Description
Public Property | Check | Gets and sets the boolean value of the grid cell.
Public Property | Text | An optional text that is placed next to the checkbox (readonly)
Public Property | Value | Overridden. Treats the value as a boolean
Top

See Also

Reference

BoolCheck Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Check Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BoolCheck Class : Check Property

Glossary Item Box

Gets and sets the boolean value of the grid cell.

Syntax

Visual Basic (Declaration)
Public Property Check As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck
Dim value As Boolean

instance.Check = value

value = instance.Check
C#
public bool Check {get; set;}
Managed Extensions for C++
public: __property bool get_Check();
public: __property void set_Check(
   bool value
);
C++/CLI
public:
property bool Check {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoolCheck Class
BoolCheck Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BoolCheck Class : Text Property

Glossary Item Box

An optional text that is placed next to the checkbox (readonly)

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoolCheck Class
BoolCheck Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Value Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > BoolCheck Class : Value Property

Glossary Item Box

Treats the value as a boolean

Syntax

Visual Basic (Declaration)
Public Overrides Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As BoolCheck
Dim value As Object

instance.Value = value

value = instance.Value
C#
public override object Value {get; set;}
Managed Extensions for C++
public: __property Object* get_Value() override;
public: __property void set_Value(
   Object* value
) override;
C++/CLI
public:
property Object^ Value {
   Object^ get() override;
   void set (    Object^ value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BoolCheck Class
BoolCheck Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar Class

Glossary Item Box

The Calendar contains entries (CalendarEntry) that define intervals. These Intervals can be decucted from TimeItems that use BlockedTimeCalculatedStop

Object Model

Calendar ClassCalendarEntryCollection ClassCalendarEntry Class

Syntax

Visual Basic (Declaration)
Public Class Calendar
Visual Basic (Usage) Copy Code
Dim instance As Calendar
C#
public class Calendar
Managed Extensions for C++
public __gc class Calendar
C++/CLI
public ref class Calendar

Inheritance Hierarchy

System.Object
PlexityHide.GTP.Calendar

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Calendar Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Calendar Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : Calendar Class

Glossary Item Box

The following tables list the members exposed by Calendar.

Public Constructors

 | Name | Description
Public Constructor | Calendar Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CalendarEntries | The entries in this Calendar
Public Property | Name | An optional name on the calendar
Top

Public Methods

 | Name | Description
Public Method | CalculateEffectiveStop | Given a Start and a Length this method returns a Stop that has been compensated for the Blocking Calendar Entries by the following calculation Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.
Public Method | GetEntriesInInterval | Returns any CalendarEntries that intersect with the given Start and Stop
Public Method | HiddenTimeInInterval | Returns a TimeSpan with the amount of hidden time found between start and stop
Top

See Also

Reference

Calendar Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : Calendar Constructor

Glossary Item Box

Overload List

Overload | Description
Calendar Constructor(Gantt) | Calendars are owned by a Gantt
Calendar Constructor() | Default constructor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar Constructor(Gantt)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class > Calendar Constructor : Calendar Constructor(Gantt)

associatedGantt

Glossary Item Box

Calendars are owned by a Gantt

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal associatedGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim associatedGantt As Gantt

Dim instance As New Calendar(associatedGantt)
C#
public Calendar(
   Gantt associatedGantt
)
Managed Extensions for C++
public: Calendar(
   Gantt* associatedGantt
)
C++/CLI
public:
Calendar(
   Gantt^ associatedGantt
)

Parameters

associatedGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class > Calendar Constructor : Calendar Constructor()

Glossary Item Box

Default constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Calendar()
C#
public Calendar()
Managed Extensions for C++
public: Calendar();
C++/CLI
public:
Calendar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Calendar Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar Class

Glossary Item Box

For a list of all members of this type, see Calendar members.

Public Methods

 | Name | Description
Public Method | CalculateEffectiveStop | Given a Start and a Length this method returns a Stop that has been compensated for the Blocking Calendar Entries by the following calculation Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.
Public Method | GetEntriesInInterval | Returns any CalendarEntries that intersect with the given Start and Stop
Public Method | HiddenTimeInInterval | Returns a TimeSpan with the amount of hidden time found between start and stop
Top

See Also

Reference

Calendar Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalculateEffectiveStop Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : CalculateEffectiveStop Method

aStart
aLength
usedCalendarEntries

Glossary Item Box

Given a Start and a Length this method returns a Stop that has been compensated for the Blocking Calendar Entries by the following calculation Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.

Syntax

Visual Basic (Declaration)
Public Function CalculateEffectiveStop( _
   ByVal aStart As Date, _
   ByVal aLength As TimeSpan, _
   ByRef usedCalendarEntries As CalendarEntryCollection _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As Calendar
Dim aStart As Date
Dim aLength As TimeSpan
Dim usedCalendarEntries As CalendarEntryCollection
Dim value As Date

value = instance.CalculateEffectiveStop(aStart, aLength, usedCalendarEntries)
C#
public DateTime CalculateEffectiveStop(
   DateTime aStart,
   TimeSpan aLength,
   out CalendarEntryCollection usedCalendarEntries
)
Managed Extensions for C++
public: DateTime CalculateEffectiveStop(
   DateTime aStart,
   TimeSpan aLength,
   [PARAMFLAG::Out] CalendarEntryCollection* usedCalendarEntries
)
C++/CLI
public:
DateTime CalculateEffectiveStop(
   DateTime aStart,
   TimeSpan aLength,
   [Out] CalendarEntryCollection^ usedCalendarEntries
)

Parameters

aStart
aLength
usedCalendarEntries

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetEntriesInInterval Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : GetEntriesInInterval Method

aStart
aStop

Glossary Item Box

Returns any CalendarEntries that intersect with the given Start and Stop

Syntax

Visual Basic (Declaration)
Public Function GetEntriesInInterval( _
   ByVal aStart As Date, _
   ByVal aStop As Date _
) As CalendarEntryCollection
Visual Basic (Usage) Copy Code
Dim instance As Calendar
Dim aStart As Date
Dim aStop As Date
Dim value As CalendarEntryCollection

value = instance.GetEntriesInInterval(aStart, aStop)
C#
public CalendarEntryCollection GetEntriesInInterval(
   DateTime aStart,
   DateTime aStop
)
Managed Extensions for C++
public: CalendarEntryCollection* GetEntriesInInterval(
   DateTime aStart,
   DateTime aStop
)
C++/CLI
public:
CalendarEntryCollection^ GetEntriesInInterval(
   DateTime aStart,
   DateTime aStop
)

Parameters

aStart
aStop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HiddenTimeInInterval Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : HiddenTimeInInterval Method

aStart
aStop

Glossary Item Box

Returns a TimeSpan with the amount of hidden time found between start and stop

Syntax

Visual Basic (Declaration)
Public Function HiddenTimeInInterval( _
   ByVal aStart As Date, _
   ByVal aStop As Date _
) As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As Calendar
Dim aStart As Date
Dim aStop As Date
Dim value As TimeSpan

value = instance.HiddenTimeInInterval(aStart, aStop)
C#
public TimeSpan HiddenTimeInInterval(
   DateTime aStart,
   DateTime aStop
)
Managed Extensions for C++
public: TimeSpan HiddenTimeInInterval(
   DateTime aStart,
   DateTime aStop
)
C++/CLI
public:
TimeSpan HiddenTimeInInterval(
   DateTime aStart,
   DateTime aStop
)

Parameters

aStart
aStop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Calendar Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar Class

Glossary Item Box

For a list of all members of this type, see Calendar members.

Public Properties

 | Name | Description
Public Property | CalendarEntries | The entries in this Calendar
Public Property | Name | An optional name on the calendar
Top

See Also

Reference

Calendar Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntries Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : CalendarEntries Property

Glossary Item Box

The entries in this Calendar

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Property CalendarEntries As CalendarEntryCollection
Visual Basic (Usage) Copy Code
Dim instance As Calendar
Dim value As CalendarEntryCollection

value = instance.CalendarEntries
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public CalendarEntryCollection CalendarEntries {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property CalendarEntryCollection* get_CalendarEntries();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property CalendarEntryCollection^ CalendarEntries {
   CalendarEntryCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Name Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar Class : Name Property

Glossary Item Box

An optional name on the calendar

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Calendar
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar Class
Calendar Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar_UserDrawArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar_UserDrawArgs Class

Glossary Item Box

The argument used by the OnCalendar_UserDraw event

Object Model

Calendar_UserDrawArgs Class

Syntax

Visual Basic (Declaration)
Public Class Calendar_UserDrawArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
C#
public class Calendar_UserDrawArgs : System.EventArgs
Managed Extensions for C++
public __gc class Calendar_UserDrawArgs : public System.EventArgs
C++/CLI
public ref class Calendar_UserDrawArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.Calendar_UserDrawArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Calendar_UserDrawArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Calendar_UserDrawArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : Calendar_UserDrawArgs Class

Glossary Item Box

The following tables list the members exposed by Calendar_UserDrawArgs.

Public Constructors

 | Name | Description
Public Constructor | Calendar_UserDrawArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | CalendarDrawArea | Describes the type of calendar area about to be drawn
Public Field | CalendarEntry | The CalendarEntry to draw
Public Field | G | The graphics context
Public Field | GoOn | set to false if the default drawing should not be applied after you are done in this event
Public Field | Rectangle | The suggested rectangle for drawing
Public Field | TimeItem | if the CalendarDrawArea==CalendarDrawArea.TimeItem this property is set
Top

See Also

Reference

Calendar_UserDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar_UserDrawArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : Calendar_UserDrawArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Calendar_UserDrawArgs()
C#
public Calendar_UserDrawArgs()
Managed Extensions for C++
public: Calendar_UserDrawArgs();
C++/CLI
public:
Calendar_UserDrawArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
Calendar_UserDrawArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar_UserDrawArgs Class

Glossary Item Box

For a list of all members of this type, see Calendar_UserDrawArgs members.

Public Fields

 | Name | Description
Public Field | CalendarDrawArea | Describes the type of calendar area about to be drawn
Public Field | CalendarEntry | The CalendarEntry to draw
Public Field | G | The graphics context
Public Field | GoOn | set to false if the default drawing should not be applied after you are done in this event
Public Field | Rectangle | The suggested rectangle for drawing
Public Field | TimeItem | if the CalendarDrawArea==CalendarDrawArea.TimeItem this property is set
Top

See Also

Reference

Calendar_UserDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarDrawArea Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : CalendarDrawArea Field

Glossary Item Box

Describes the type of calendar area about to be drawn

Syntax

Visual Basic (Declaration)
Public CalendarDrawArea As CalendarDrawArea
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As CalendarDrawArea

value = instance.CalendarDrawArea

instance.CalendarDrawArea = value
C#
public CalendarDrawArea CalendarDrawArea
Managed Extensions for C++
public: CalendarDrawArea CalendarDrawArea
C++/CLI
public:
CalendarDrawArea CalendarDrawArea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : CalendarEntry Field

Glossary Item Box

The CalendarEntry to draw

Syntax

Visual Basic (Declaration)
Public CalendarEntry As CalendarEntry
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As CalendarEntry

value = instance.CalendarEntry

instance.CalendarEntry = value
C#
public CalendarEntry CalendarEntry
Managed Extensions for C++
public: CalendarEntry* CalendarEntry
C++/CLI
public:
CalendarEntry^ CalendarEntry

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : G Field

Glossary Item Box

The graphics context

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GoOn Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : GoOn Field

Glossary Item Box

set to false if the default drawing should not be applied after you are done in this event

Syntax

Visual Basic (Declaration)
Public GoOn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As Boolean

value = instance.GoOn

instance.GoOn = value
C#
public bool GoOn
Managed Extensions for C++
public: bool GoOn
C++/CLI
public:
bool GoOn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rectangle Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : Rectangle Field

Glossary Item Box

The suggested rectangle for drawing

Syntax

Visual Basic (Declaration)
Public Rectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As Rectangle

value = instance.Rectangle

instance.Rectangle = value
C#
public Rectangle Rectangle
Managed Extensions for C++
public: Rectangle Rectangle
C++/CLI
public:
Rectangle Rectangle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Calendar_UserDrawArgs Class : TimeItem Field

Glossary Item Box

if the CalendarDrawArea==CalendarDrawArea.TimeItem this property is set

Syntax

Visual Basic (Declaration)
Public TimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Calendar_UserDrawArgs
Dim value As TimeItem

value = instance.TimeItem

instance.TimeItem = value
C#
public TimeItem TimeItem
Managed Extensions for C++
public: TimeItem* TimeItem
C++/CLI
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Calendar_UserDrawArgs Class
Calendar_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarCollection Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarCollection Class

Glossary Item Box

a Gantt chart may have several Calendars, they are kept in a collection of this type.

Object Model

CalendarCollection ClassCalendar Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CalendarCollection
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As CalendarCollection
C#
[DefaultMemberAttribute("Item")]
public class CalendarCollection : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CalendarCollection : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CalendarCollection : public System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.CalendarCollection

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CalendarCollection Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CalendarCollection Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CalendarCollection Class

Glossary Item Box

The following tables list the members exposed by CalendarCollection.

Public Constructors

 | Name | Description
Public Constructor | CalendarCollection Constructor | A CalendarCollection is Owned by the Gantt chart
Top

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a Calendar to the collection
Top

See Also

Reference

CalendarCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarCollection Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarCollection Class : CalendarCollection Constructor

owningGantt

Glossary Item Box

A CalendarCollection is Owned by the Gantt chart

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owningGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim owningGantt As Gantt

Dim instance As New CalendarCollection(owningGantt)
C#
public CalendarCollection(
   Gantt owningGantt
)
Managed Extensions for C++
public: CalendarCollection(
   Gantt* owningGantt
)
C++/CLI
public:
CalendarCollection(
   Gantt^ owningGantt
)

Parameters

owningGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarCollection Class
CalendarCollection Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CalendarCollection Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarCollection Class

Glossary Item Box

For a list of all members of this type, see CalendarCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a Calendar to the collection
Top

See Also

Reference

CalendarCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarCollection Class : Add Method

c

Glossary Item Box

Adds a Calendar to the collection

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal c As Calendar _
)
Visual Basic (Usage) Copy Code
Dim instance As CalendarCollection
Dim c As Calendar

instance.Add(c)
C#
public void Add(
   Calendar c
)
Managed Extensions for C++
public: void Add(
   Calendar* c
)
C++/CLI
public:
void Add(
   Calendar^ c
)

Parameters

c

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarCollection Class
CalendarCollection Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CalendarCollection Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarCollection Class

Glossary Item Box

For a list of all members of this type, see CalendarCollection members.

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

See Also

Reference

CalendarCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarCollection Class : Item Property

i

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Default Property Item( _
   ByVal i As Integer _
) As Calendar
Visual Basic (Usage) Copy Code
Dim instance As CalendarCollection
Dim i As Integer
Dim value As Calendar

value = instance.Item(i)
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public Calendar this[
   int i
]; {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property Calendar* get_Item   int i
;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property Calendar^ default [int] {
   Calendar^ get(int i);
}

Parameters

i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarCollection Class
CalendarCollection Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntry Class

Glossary Item Box

CalendarEntry defines a Start and Stop in time. CalenderEntries are combined and owned by a Calendar. Calendars can draw all the entries in the background of the TimeItemArea or DateScaler. Calendars can also be used in TimeItemLayouts as defining BlockedTime. When this is true the TimeItem has a given Length and a Calculated stop. The calculation is Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.

Object Model

CalendarEntry ClassCalendar Class

Syntax

Visual Basic (Declaration)
Public Class CalendarEntry
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
C#
public class CalendarEntry
Managed Extensions for C++
public __gc class CalendarEntry
C++/CLI
public ref class CalendarEntry

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CalendarEntry

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CalendarEntry Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CalendarEntry Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntry Class

Glossary Item Box

The following tables list the members exposed by CalendarEntry.

Public Constructors

 | Name | Description
Public Constructor | CalendarEntry Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Alpha | The alpha value that will be applied to the color on default drawing
Public Property | BrushKind | The BrushKind that will be used for the brush on the default drawing
Public Property | Color | The color that will be used for the hatch brush on the default drawing
Public Property | DrawInDateScaler | When set this entry will be drawn in the DateScaler
Public Property | DrawInTimeItemArea | When set this entry will be drawn in the TimeItemArea
Public Property | Frequency | When set, this entry will expand into multiple entries. From start to start+frequency. Use this for repeating entries; ie Every Friday -> Set Start to a Friday in the past, set frequency to 7 days
Public Property | HatchStyle | The Hatch style that will be used for the hatch brush on the default drawing
Public Property | Owner | Owning Calendar
Public Property | Start | The start date of this entry
Public Property | Stop | The stop date of this entry
Public Property | UserReference | User reference, use this to tie against your own data
Top

Public Methods

 | Name | Description
Public Method | Clone | Performs a MemberwiseClone
Public Method | CompareTo | CalendarEntry is compared on Start property
Public Method | GetHashCode | CalendarEntry has Hash of Start property
Top

See Also

Reference

CalendarEntry Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : CalendarEntry Constructor

Glossary Item Box

Overload List

Overload | Description
CalendarEntry Constructor() | CalendarEntry defines a Start and Stop in time. CalenderEntries are combined and owned by a Calendar. Calendars can draw all the entries in the background of the TimeItemArea or DateScaler. Calendars can also be used in TimeItemLayouts as defining BlockedTime. When this is true the TimeItem has a given Length and a Calculated stop. The calculation is Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.
CalendarEntry Constructor(DateTime,DateTime) | See comment on CalendarEntry()
CalendarEntry Constructor(DateTime,DateTime,TimeSpan) | See comment on CalendarEntry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class > CalendarEntry Constructor : CalendarEntry Constructor()

Glossary Item Box

CalendarEntry defines a Start and Stop in time. CalenderEntries are combined and owned by a Calendar. Calendars can draw all the entries in the background of the TimeItemArea or DateScaler. Calendars can also be used in TimeItemLayouts as defining BlockedTime. When this is true the TimeItem has a given Length and a Calculated stop. The calculation is Stop=Start+Length+AnyBlockingCalendarEntriesBetweenStartAndStop.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CalendarEntry()
C#
public CalendarEntry()
Managed Extensions for C++
public: CalendarEntry();
C++/CLI
public:
CalendarEntry();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Constructor(DateTime,DateTime)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class > CalendarEntry Constructor : CalendarEntry Constructor(DateTime,DateTime)

aStart
aStop

Glossary Item Box

See comment on CalendarEntry()

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aStart As Date, _
   ByVal aStop As Date _
)
Visual Basic (Usage) Copy Code
Dim aStart As Date
Dim aStop As Date

Dim instance As New CalendarEntry(aStart, aStop)
C#
public CalendarEntry(
   DateTime aStart,
   DateTime aStop
)
Managed Extensions for C++
public: CalendarEntry(
   DateTime aStart,
   DateTime aStop
)
C++/CLI
public:
CalendarEntry(
   DateTime aStart,
   DateTime aStop
)

Parameters

aStart
aStop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntry Constructor(DateTime,DateTime,TimeSpan)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class > CalendarEntry Constructor : CalendarEntry Constructor(DateTime,DateTime,TimeSpan)

aStart
aStop
aFrequency

Glossary Item Box

See comment on CalendarEntry()

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aStart As Date, _
   ByVal aStop As Date, _
   ByVal aFrequency As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim aStart As Date
Dim aStop As Date
Dim aFrequency As TimeSpan

Dim instance As New CalendarEntry(aStart, aStop, aFrequency)
C#
public CalendarEntry(
   DateTime aStart,
   DateTime aStop,
   TimeSpan aFrequency
)
Managed Extensions for C++
public: CalendarEntry(
   DateTime aStart,
   DateTime aStop,
   TimeSpan aFrequency
)
C++/CLI
public:
CalendarEntry(
   DateTime aStart,
   DateTime aStop,
   TimeSpan aFrequency
)

Parameters

aStart
aStop
aFrequency

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CalendarEntry Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntry Class

Glossary Item Box

For a list of all members of this type, see CalendarEntry members.

Public Methods

 | Name | Description
Public Method | Clone | Performs a MemberwiseClone
Public Method | CompareTo | CalendarEntry is compared on Start property
Public Method | GetHashCode | CalendarEntry has Hash of Start property
Top

See Also

Reference

CalendarEntry Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clone Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Clone Method

Glossary Item Box

Performs a MemberwiseClone

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CompareTo Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : CompareTo Method

obj

Glossary Item Box

CalendarEntry is compared on Start property

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
C#
public int CompareTo(
   object obj
)
Managed Extensions for C++
public: int CompareTo(
   Object* obj
)
C++/CLI
public:
int CompareTo(
   Object^ obj
)

Parameters

obj

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetHashCode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : GetHashCode Method

Glossary Item Box

CalendarEntry has Hash of Start property

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CalendarEntry Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntry Class

Glossary Item Box

For a list of all members of this type, see CalendarEntry members.

Public Properties

 | Name | Description
Public Property | Alpha | The alpha value that will be applied to the color on default drawing
Public Property | BrushKind | The BrushKind that will be used for the brush on the default drawing
Public Property | Color | The color that will be used for the hatch brush on the default drawing
Public Property | DrawInDateScaler | When set this entry will be drawn in the DateScaler
Public Property | DrawInTimeItemArea | When set this entry will be drawn in the TimeItemArea
Public Property | Frequency | When set, this entry will expand into multiple entries. From start to start+frequency. Use this for repeating entries; ie Every Friday -> Set Start to a Friday in the past, set frequency to 7 days
Public Property | HatchStyle | The Hatch style that will be used for the hatch brush on the default drawing
Public Property | Owner | Owning Calendar
Public Property | Start | The start date of this entry
Public Property | Stop | The stop date of this entry
Public Property | UserReference | User reference, use this to tie against your own data
Top

See Also

Reference

CalendarEntry Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Alpha Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Alpha Property

Glossary Item Box

The alpha value that will be applied to the color on default drawing

Syntax

Visual Basic (Declaration)
Public Property Alpha As Byte
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Byte

instance.Alpha = value

value = instance.Alpha
C#
public byte Alpha {get; set;}
Managed Extensions for C++
public: __property byte get_Alpha();
public: __property void set_Alpha(
   byte value
);
C++/CLI
public:
property byte Alpha {
   byte get();
   void set (    byte value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BrushKind Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : BrushKind Property

Glossary Item Box

The BrushKind that will be used for the brush on the default drawing

Syntax

Visual Basic (Declaration)
Public Property BrushKind As CalendarBrushKind
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As CalendarBrushKind

instance.BrushKind = value

value = instance.BrushKind
C#
public CalendarBrushKind BrushKind {get; set;}
Managed Extensions for C++
public: __property CalendarBrushKind get_BrushKind();
public: __property void set_BrushKind(
   CalendarBrushKind value
);
C++/CLI
public:
property CalendarBrushKind BrushKind {
   CalendarBrushKind get();
   void set (    CalendarBrushKind value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Color Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Color Property

Glossary Item Box

The color that will be used for the hatch brush on the default drawing

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}
Managed Extensions for C++
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
public:
property Color Color {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawInDateScaler Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : DrawInDateScaler Property

Glossary Item Box

When set this entry will be drawn in the DateScaler

Syntax

Visual Basic (Declaration)
Public Property DrawInDateScaler As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Boolean

instance.DrawInDateScaler = value

value = instance.DrawInDateScaler
C#
public bool DrawInDateScaler {get; set;}
Managed Extensions for C++
public: __property bool get_DrawInDateScaler();
public: __property void set_DrawInDateScaler(
   bool value
);
C++/CLI
public:
property bool DrawInDateScaler {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawInTimeItemArea Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : DrawInTimeItemArea Property

Glossary Item Box

When set this entry will be drawn in the TimeItemArea

Syntax

Visual Basic (Declaration)
Public Property DrawInTimeItemArea As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Boolean

instance.DrawInTimeItemArea = value

value = instance.DrawInTimeItemArea
C#
public bool DrawInTimeItemArea {get; set;}
Managed Extensions for C++
public: __property bool get_DrawInTimeItemArea();
public: __property void set_DrawInTimeItemArea(
   bool value
);
C++/CLI
public:
property bool DrawInTimeItemArea {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Frequency Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Frequency Property

Glossary Item Box

When set, this entry will expand into multiple entries. From start to start+frequency. Use this for repeating entries; ie Every Friday -> Set Start to a Friday in the past, set frequency to 7 days

Syntax

Visual Basic (Declaration)
Public Property Frequency As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As TimeSpan

instance.Frequency = value

value = instance.Frequency
C#
public TimeSpan Frequency {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_Frequency();
public: __property void set_Frequency(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan Frequency {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HatchStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : HatchStyle Property

Glossary Item Box

The Hatch style that will be used for the hatch brush on the default drawing

Syntax

Visual Basic (Declaration)
Public Property HatchStyle As HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public HatchStyle HatchStyle {get; set;}
Managed Extensions for C++
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
C++/CLI
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (    HatchStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Owner Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Owner Property

Glossary Item Box

Owning Calendar

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Owner As Calendar
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Calendar

value = instance.Owner
C#
[BrowsableAttribute(false)]
public Calendar Owner {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Calendar* get_Owner();
C++/CLI
[BrowsableAttribute(false)]
public:
property Calendar^ Owner {
   Calendar^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Start Property

Glossary Item Box

The start date of this entry

Syntax

Visual Basic (Declaration)
Public Property Start As Date
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}
Managed Extensions for C++
public: __property DateTime get_Start();
public: __property void set_Start(
   DateTime value
);
C++/CLI
public:
property DateTime Start {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Stop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : Stop Property

Glossary Item Box

The stop date of this entry

Syntax

Visual Basic (Declaration)
Public Property Stop As Date
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Date

instance.Stop = value

value = instance.Stop
C#
public DateTime Stop {get; set;}
Managed Extensions for C++
public: __property DateTime get_Stop();
public: __property void set_Stop(
   DateTime value
);
C++/CLI
public:
property DateTime Stop {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntry Class : UserReference Property

Glossary Item Box

User reference, use this to tie against your own data

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntry
Dim value As Object

instance.UserReference = value

value = instance.UserReference
C#
[BrowsableAttribute(false)]
public object UserReference {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_UserReference();
public: __property void set_UserReference(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ UserReference {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntry Class
CalendarEntry Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntryCollection Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntryCollection Class

Glossary Item Box

Collection of CalendarEntries

Object Model

CalendarEntryCollection ClassCalendarEntry Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CalendarEntryCollection
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntryCollection
C#
[DefaultMemberAttribute("Item")]
public class CalendarEntryCollection : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CalendarEntryCollection : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CalendarEntryCollection : public System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.CalendarEntryCollection

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CalendarEntryCollection Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CalendarEntryCollection Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntryCollection Class

Glossary Item Box

The following tables list the members exposed by CalendarEntryCollection.

Public Constructors

 | Name | Description
Public Constructor | CalendarEntryCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item | Indexer for CalendarEntries
Top

Public Methods

 | Name | Description
Public Method | Add | Add a new CalendarEntry to the Calendar
Top

See Also

Reference

CalendarEntryCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarEntryCollection Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntryCollection Class : CalendarEntryCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CalendarEntryCollection()
C#
public CalendarEntryCollection()
Managed Extensions for C++
public: CalendarEntryCollection();
C++/CLI
public:
CalendarEntryCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntryCollection Class
CalendarEntryCollection Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CalendarEntryCollection Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntryCollection Class

Glossary Item Box

For a list of all members of this type, see CalendarEntryCollection members.

Public Methods

 | Name | Description
Public Method | Add | Add a new CalendarEntry to the Calendar
Top

See Also

Reference

CalendarEntryCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntryCollection Class : Add Method

entry

Glossary Item Box

Add a new CalendarEntry to the Calendar

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal entry As CalendarEntry _
)
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntryCollection
Dim entry As CalendarEntry

instance.Add(entry)
C#
public void Add(
   CalendarEntry entry
)
Managed Extensions for C++
public: void Add(
   CalendarEntry* entry
)
C++/CLI
public:
void Add(
   CalendarEntry^ entry
)

Parameters

entry

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntryCollection Class
CalendarEntryCollection Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CalendarEntryCollection Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarEntryCollection Class

Glossary Item Box

For a list of all members of this type, see CalendarEntryCollection members.

Public Properties

 | Name | Description
Public Property | Item | Indexer for CalendarEntries
Top

See Also

Reference

CalendarEntryCollection Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CalendarEntryCollection Class : Item Property

i

Glossary Item Box

Indexer for CalendarEntries

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Default Property Item( _
   ByVal i As Integer _
) As CalendarEntry
Visual Basic (Usage) Copy Code
Dim instance As CalendarEntryCollection
Dim i As Integer
Dim value As CalendarEntry

value = instance.Item(i)
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public CalendarEntry this[
   int i
]; {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property CalendarEntry* get_Item   int i
;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property CalendarEntry^ default [int] {
   CalendarEntry^ get(int i);
}

Parameters

i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalendarEntryCollection Class
CalendarEntryCollection Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : Cell Class

Glossary Item Box

Holds an individual cell in the grid.

Object Model

Cell ClassGridColumn ClassContentEntity ClassGrid ClassGridNode ClassGridStructure ClassCellLayout ClassGridNode Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Cell
Visual Basic (Usage) Copy Code
Dim instance As Cell
C#
[SerializableAttribute()]
public class Cell
Managed Extensions for C++
[SerializableAttribute()]
public __gc class Cell
C++/CLI
[SerializableAttribute()]
public ref class Cell

Example

C# Copy Code
GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
            gantt1.Grid.GridStructure.RootNodes.AddNode();
            gantt1.Grid.GridStructure.RootNodes.AddNode();

            gn.GetCell(c_st.Index).Content.Value="Hello";
Visual Basic Copy Code
Dim gn As GridNode=gantt1.Grid.GridStructure.RootNodes.AddNode()
            gantt1.Grid.GridStructure.RootNodes.AddNode()
            gantt1.Grid.GridStructure.RootNodes.AddNode()

            gn.GetCell(c_st.Index).Content.Value="Hello"

Inheritance Hierarchy

System.Object
PlexityHide.GTP.Cell

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Cell Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Cell Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : Cell Class

Glossary Item Box

The following tables list the members exposed by Cell.

Public Properties

 | Name | Description
Public Property | CellBorderRect | Gets the cell rectangle, border.
Public Property | CellRect | Gets the cell rectangle perimeter.
Public Property | Column | Returns a reference to the column which the cell belongs to.
Public Property | Content | The content of this cell
Public Property | GridControl | Returns the Grid that owns the cell
Public Property | GridNode | Returns a reference to the owning node. Same as Cell.Node.
Public Property | GridStructure | Returns the GridStructure that owns the cell
Public Property | Index | The x-index of this cell
Public Property | IsColumnEntity | Returns true if this cell is a column head, and as such not part of a GridNode
Public Property | Layout | Sets which layout description to use.
Public Property | Node | Returns a reference to the owning node.
Public Property | Selected | Gets and sets the selected status.
Top

Public Methods

 | Name | Description
Public Method | MakeSureVisible | If this cell is not currently visible this call will make it visible
Public Method | StartEdit | Starts edit on a given cell. Edit is normally started by double-click or return key, but this method enables you to start edit in code
Top

See Also

Reference

Cell Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Cell Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Cell Class

Glossary Item Box

For a list of all members of this type, see Cell members.

Public Methods

 | Name | Description
Public Method | MakeSureVisible | If this cell is not currently visible this call will make it visible
Public Method | StartEdit | Starts edit on a given cell. Edit is normally started by double-click or return key, but this method enables you to start edit in code
Top

See Also

Reference

Cell Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
MakeSureVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : MakeSureVisible Method

Glossary Item Box

If this cell is not currently visible this call will make it visible

Syntax

Visual Basic (Declaration)
Public Sub MakeSureVisible()
Visual Basic (Usage) Copy Code
Dim instance As Cell

instance.MakeSureVisible()
C#
public void MakeSureVisible()
Managed Extensions for C++
public: void MakeSureVisible();
C++/CLI
public:
void MakeSureVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartEdit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : StartEdit Method

Glossary Item Box

Starts edit on a given cell. Edit is normally started by double-click or return key, but this method enables you to start edit in code

Syntax

Visual Basic (Declaration)
Public Sub StartEdit()
Visual Basic (Usage) Copy Code
Dim instance As Cell

instance.StartEdit()
C#
public void StartEdit()
Managed Extensions for C++
public: void StartEdit();
C++/CLI
public:
void StartEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Cell Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Cell Class

Glossary Item Box

For a list of all members of this type, see Cell members.

Public Properties

 | Name | Description
Public Property | CellBorderRect | Gets the cell rectangle, border.
Public Property | CellRect | Gets the cell rectangle perimeter.
Public Property | Column | Returns a reference to the column which the cell belongs to.
Public Property | Content | The content of this cell
Public Property | GridControl | Returns the Grid that owns the cell
Public Property | GridNode | Returns a reference to the owning node. Same as Cell.Node.
Public Property | GridStructure | Returns the GridStructure that owns the cell
Public Property | Index | The x-index of this cell
Public Property | IsColumnEntity | Returns true if this cell is a column head, and as such not part of a GridNode
Public Property | Layout | Sets which layout description to use.
Public Property | Node | Returns a reference to the owning node.
Public Property | Selected | Gets and sets the selected status.
Top

See Also

Reference

Cell Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellBorderRect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : CellBorderRect Property

Glossary Item Box

Gets the cell rectangle, border.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellBorderRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Rectangle

value = instance.CellBorderRect
C#
public Rectangle CellBorderRect {get;}
Managed Extensions for C++
public: __property Rectangle get_CellBorderRect();
C++/CLI
public:
property Rectangle CellBorderRect {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellRect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : CellRect Property

Glossary Item Box

Gets the cell rectangle perimeter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Rectangle

value = instance.CellRect
C#
public Rectangle CellRect {get;}
Managed Extensions for C++
public: __property Rectangle get_CellRect();
C++/CLI
public:
property Rectangle CellRect {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Column Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Column Property

Glossary Item Box

Returns a reference to the column which the cell belongs to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As GridColumn

value = instance.Column
C#
public GridColumn Column {get;}
Managed Extensions for C++
public: __property GridColumn* get_Column();
C++/CLI
public:
property GridColumn^ Column {
   GridColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Content Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Content Property

Glossary Item Box

The content of this cell

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Content As ContentEntity
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As ContentEntity

value = instance.Content
C#
public ContentEntity Content {get;}
Managed Extensions for C++
public: __property ContentEntity* get_Content();
C++/CLI
public:
property ContentEntity^ Content {
   ContentEntity^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : GridControl Property

Glossary Item Box

Returns the Grid that owns the cell

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridControl As Grid
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Grid

value = instance.GridControl
C#
[BrowsableAttribute(false)]
public Grid GridControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Grid* get_GridControl();
C++/CLI
[BrowsableAttribute(false)]
public:
property Grid^ GridControl {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : GridNode Property

Glossary Item Box

Returns a reference to the owning node. Same as Cell.Node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GridNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As GridNode

value = instance.GridNode
C#
public GridNode GridNode {get;}
Managed Extensions for C++
public: __property GridNode* get_GridNode();
C++/CLI
public:
property GridNode^ GridNode {
   GridNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridStructure Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : GridStructure Property

Glossary Item Box

Returns the GridStructure that owns the cell

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridStructure As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As GridStructure

value = instance.GridStructure
C#
[BrowsableAttribute(false)]
public GridStructure GridStructure {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridStructure* get_GridStructure();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridStructure^ GridStructure {
   GridStructure^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Index Property

Glossary Item Box

The x-index of this cell

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Integer

value = instance.Index
C#
public int Index {get;}
Managed Extensions for C++
public: __property int get_Index();
C++/CLI
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsColumnEntity Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : IsColumnEntity Property

Glossary Item Box

Returns true if this cell is a column head, and as such not part of a GridNode

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsColumnEntity As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Boolean

value = instance.IsColumnEntity
C#
public bool IsColumnEntity {get;}
Managed Extensions for C++
public: __property bool get_IsColumnEntity();
C++/CLI
public:
property bool IsColumnEntity {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layout Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Layout Property

Glossary Item Box

Sets which layout description to use.

Syntax

Visual Basic (Declaration)
Public Property Layout As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As CellLayout

instance.Layout = value

value = instance.Layout
C#
public CellLayout Layout {get; set;}
Managed Extensions for C++
public: __property CellLayout* get_Layout();
public: __property void set_Layout(
   CellLayout* value
);
C++/CLI
public:
property CellLayout^ Layout {
   CellLayout^ get();
   void set (    CellLayout^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Node Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Node Property

Glossary Item Box

Returns a reference to the owning node.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Node As GridNode
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As GridNode

value = instance.Node
C#
public GridNode Node {get;}
Managed Extensions for C++
public: __property GridNode* get_Node();
C++/CLI
public:
property GridNode^ Node {
   GridNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Selected Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Cell Class : Selected Property

Glossary Item Box

Gets and sets the selected status.

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
public bool Selected {get; set;}
Managed Extensions for C++
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
C++/CLI
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Cell Class
Cell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellAndDSArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellAndDSArgs Class

Glossary Item Box

Arguments for node events

Object Model

CellAndDSArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellAndDSArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellAndDSArgs
C#
public class CellAndDSArgs : System.EventArgs
Managed Extensions for C++
public __gc class CellAndDSArgs : public System.EventArgs
C++/CLI
public ref class CellAndDSArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CellAndDSArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellAndDSArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CellAndDSArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CellAndDSArgs Class

Glossary Item Box

The following tables list the members exposed by CellAndDSArgs.

Public Constructors

 | Name | Description
Public Constructor | CellAndDSArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The cell affected by the update
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | PropertyDescriptorInDS | The propertdescriptor (column) from the CurrencyManager
Public Field | Value | The value about to be applied or about to be moved to the cell. You can override this value but make sure it is the correct type
Top

See Also

Reference

CellAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellAndDSArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellAndDSArgs Class : CellAndDSArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellAndDSArgs()
C#
public CellAndDSArgs()
Managed Extensions for C++
public: CellAndDSArgs();
C++/CLI
public:
CellAndDSArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellAndDSArgs Class
CellAndDSArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CellAndDSArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellAndDSArgs Class

Glossary Item Box

For a list of all members of this type, see CellAndDSArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The cell affected by the update
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | PropertyDescriptorInDS | The propertdescriptor (column) from the CurrencyManager
Public Field | Value | The value about to be applied or about to be moved to the cell. You can override this value but make sure it is the correct type
Top

See Also

Reference

CellAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellAndDSArgs Class : Cell Field

Glossary Item Box

The cell affected by the update

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As CellAndDSArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellAndDSArgs Class
CellAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManagerListItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellAndDSArgs Class : CurrencyManagerListItem Field

Glossary Item Box

The row from the currency manager

Syntax

Visual Basic (Declaration)
Public CurrencyManagerListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As CellAndDSArgs
Dim value As Object

value = instance.CurrencyManagerListItem

instance.CurrencyManagerListItem = value
C#
public object CurrencyManagerListItem
Managed Extensions for C++
public: Object* CurrencyManagerListItem
C++/CLI
public:
Object^ CurrencyManagerListItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellAndDSArgs Class
CellAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PropertyDescriptorInDS Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellAndDSArgs Class : PropertyDescriptorInDS Field

Glossary Item Box

The propertdescriptor (column) from the CurrencyManager

Syntax

Visual Basic (Declaration)
Public PropertyDescriptorInDS As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As CellAndDSArgs
Dim value As PropertyDescriptor

value = instance.PropertyDescriptorInDS

instance.PropertyDescriptorInDS = value
C#
public PropertyDescriptor PropertyDescriptorInDS
Managed Extensions for C++
public: PropertyDescriptor* PropertyDescriptorInDS
C++/CLI
public:
PropertyDescriptor^ PropertyDescriptorInDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellAndDSArgs Class
CellAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Value Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellAndDSArgs Class : Value Field

Glossary Item Box

The value about to be applied or about to be moved to the cell. You can override this value but make sure it is the correct type

Syntax

Visual Basic (Declaration)
Public Value As Object
Visual Basic (Usage) Copy Code
Dim instance As CellAndDSArgs
Dim value As Object

value = instance.Value

instance.Value = value
C#
public object Value
Managed Extensions for C++
public: Object* Value
C++/CLI
public:
Object^ Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellAndDSArgs Class
CellAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayout Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayout Class

Glossary Item Box

Holds all the properties that define the layout at cell rendering.

Object Model

CellLayout ClassCellLayouts ClassCellLayout ClassLineOption ClassLineOption ClassLineOption ClassLineOption Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class CellLayout
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
C#
[TypeConverterAttribute("PlexityHide.GTP.CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class CellLayout
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class CellLayout
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class CellLayout

Example

C# Copy Code
CellLayout layoutrightjust=new CellLayout();
      layoutrightjust.MinHeight=20;
      layoutrightjust.LineRight.Use=true;
      layoutrightjust.LineRight.Color=SystemColors.ControlDark;
      layoutrightjust.LineTop.Use=false;
      layoutrightjust.LineBottom.Use=false;
      layoutrightjust.Font=new Font("Microsoft Sans Serif",10);
      layoutrightjust.FontColor=Color.Black;
      layoutrightjust.Name="layoutrightjust";
      layoutrightjust.HorzAlign=StringAlignment.Far;
      layoutrightjust.VertAlign=StringAlignment.Center;
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor;
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor;
      gantt1.Grid.CellLayouts.Add(layoutrightjust);
Visual Basic Copy Code
Dim layoutrightjust As CellLayout = New CellLayout()
      layoutrightjust.MinHeight=20
      layoutrightjust.LineRight.Use=True
      layoutrightjust.LineRight.Color=SystemColors.ControlDark
      layoutrightjust.LineTop.Use=False
      layoutrightjust.LineBottom.Use=False
      layoutrightjust.Font = New Font("Microsoft Sans Serif",10)
      layoutrightjust.FontColor=Color.Black
      layoutrightjust.Name="layoutrightjust"
      layoutrightjust.HorzAlign=StringAlignment.Far
      layoutrightjust.VertAlign=StringAlignment.Center
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor
      gantt1.Grid.CellLayouts.Add(layoutrightjust)

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CellLayout

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellLayout Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CellLayout Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CellLayout Class

Glossary Item Box

The following tables list the members exposed by CellLayout.

Public Constructors

 | Name | Description
Public Constructor | CellLayout Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | BackgroundColor | Cell background color.
Public Property | BackgroundUse | Should the background color be used, otherwise grid bottom color.
Public Property | CellLayouts | Owning collection
Public Property | DateTimeFormat | When set, controls how cells of type DateTime are rendered.
Public Property | DeSelectedColor | Gets and sets the color of a selected cell in a passive grid.
Public Property | EndEllipsis | Text formatting when text does not fit.
Public Property | Font | Font values
Public Property | FontColor | The color of the text
Public Property | FontColorSelected | The color of the text when a cell is selected
Public Property | HeaderBackgroundColor | If this layout property is used in a header, use this back color
Public Property | HeaderBackgroundGradiantColor | If this layout property is used in a header, use this back gradiant color
Public Property | HorzAlign | Horizontal alignment
Public Property | ImageIndex_Select | Controls what imageList index will be used in front of the rendered text when the cell is selected
Public Property | ImageIndex_UnSelect | Controls what imageList index will be used in front of the rendered text when the cell is NOT selected
Public Property | LineBottom | The bottom line in the cell
Public Property | LineLeft | The left line in the cell
Public Property | LineRight | The right line in the cell
Public Property | LineTop | The top line in the cell
Public Property | MinHeight | Minimum cell height used.
Public Property | Name | Name of CellLayout.
Public Property | Padding | Padding for the cell
Public Property | SelectedColor | Gets and sets the color of a selected cell in active grid.
Public Property | Spacing | Spacing for the cell
Public Property | TextFormat | Gets the object for text formatting.
Public Property | TextFormatNoWrap | Gets the object for text formatting, including no wrapping.
Public Property | VertAlign | Vertical alignment
Top

Public Methods

 | Name | Description
Public Method | Changed | Called in order to update
Public Method | Clone | Clones the CellLayout
Top

See Also

Reference

CellLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayout Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : CellLayout Constructor

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellLayout()
C#
public CellLayout()
Managed Extensions for C++
public: CellLayout();
C++/CLI
public:
CellLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CellLayout Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayout Class

Glossary Item Box

For a list of all members of this type, see CellLayout members.

Public Methods

 | Name | Description
Public Method | Changed | Called in order to update
Public Method | Clone | Clones the CellLayout
Top

See Also

Reference

CellLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Changed Method

Glossary Item Box

Called in order to update

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As CellLayout

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clone Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Clone Method

Glossary Item Box

Clones the CellLayout

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CellLayout Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayout Class

Glossary Item Box

For a list of all members of this type, see CellLayout members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Cell background color.
Public Property | BackgroundUse | Should the background color be used, otherwise grid bottom color.
Public Property | CellLayouts | Owning collection
Public Property | DateTimeFormat | When set, controls how cells of type DateTime are rendered.
Public Property | DeSelectedColor | Gets and sets the color of a selected cell in a passive grid.
Public Property | EndEllipsis | Text formatting when text does not fit.
Public Property | Font | Font values
Public Property | FontColor | The color of the text
Public Property | FontColorSelected | The color of the text when a cell is selected
Public Property | HeaderBackgroundColor | If this layout property is used in a header, use this back color
Public Property | HeaderBackgroundGradiantColor | If this layout property is used in a header, use this back gradiant color
Public Property | HorzAlign | Horizontal alignment
Public Property | ImageIndex_Select | Controls what imageList index will be used in front of the rendered text when the cell is selected
Public Property | ImageIndex_UnSelect | Controls what imageList index will be used in front of the rendered text when the cell is NOT selected
Public Property | LineBottom | The bottom line in the cell
Public Property | LineLeft | The left line in the cell
Public Property | LineRight | The right line in the cell
Public Property | LineTop | The top line in the cell
Public Property | MinHeight | Minimum cell height used.
Public Property | Name | Name of CellLayout.
Public Property | Padding | Padding for the cell
Public Property | SelectedColor | Gets and sets the color of a selected cell in active grid.
Public Property | Spacing | Spacing for the cell
Public Property | TextFormat | Gets the object for text formatting.
Public Property | TextFormatNoWrap | Gets the object for text formatting, including no wrapping.
Public Property | VertAlign | Vertical alignment
Top

See Also

Reference

CellLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : BackgroundColor Property

Glossary Item Box

Cell background color.

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.BackgroundColor = value

value = instance.BackgroundColor
C#
public Color BackgroundColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   Color value
);
C++/CLI
public:
property Color BackgroundColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundUse Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : BackgroundUse Property

Glossary Item Box

Should the background color be used, otherwise grid bottom color.

Syntax

Visual Basic (Declaration)
Public Property BackgroundUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Boolean

instance.BackgroundUse = value

value = instance.BackgroundUse
C#
public bool BackgroundUse {get; set;}
Managed Extensions for C++
public: __property bool get_BackgroundUse();
public: __property void set_BackgroundUse(
   bool value
);
C++/CLI
public:
property bool BackgroundUse {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : CellLayouts Property

Glossary Item Box

Owning collection

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property CellLayouts As CellLayouts
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As CellLayouts

instance.CellLayouts = value

value = instance.CellLayouts
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public CellLayouts CellLayouts {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property CellLayouts* get_CellLayouts();
public: __property void set_CellLayouts(
   CellLayouts* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property CellLayouts^ CellLayouts {
   CellLayouts^ get();
   void set (    CellLayouts^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateTimeFormat Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : DateTimeFormat Property

Glossary Item Box

When set, controls how cells of type DateTime are rendered.

Syntax

Visual Basic (Declaration)
Public Property DateTimeFormat As String
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As String

instance.DateTimeFormat = value

value = instance.DateTimeFormat
C#
public string DateTimeFormat {get; set;}
Managed Extensions for C++
public: __property string* get_DateTimeFormat();
public: __property void set_DateTimeFormat(
   string* value
);
C++/CLI
public:
property String^ DateTimeFormat {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DeSelectedColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : DeSelectedColor Property

Glossary Item Box

Gets and sets the color of a selected cell in a passive grid.

Syntax

Visual Basic (Declaration)
Public Property DeSelectedColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.DeSelectedColor = value

value = instance.DeSelectedColor
C#
public Color DeSelectedColor {get; set;}
Managed Extensions for C++
public: __property Color get_DeSelectedColor();
public: __property void set_DeSelectedColor(
   Color value
);
C++/CLI
public:
property Color DeSelectedColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EndEllipsis Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : EndEllipsis Property

Glossary Item Box

Text formatting when text does not fit.

Syntax

Visual Basic (Declaration)
Public Property EndEllipsis As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Boolean

instance.EndEllipsis = value

value = instance.EndEllipsis
C#
public bool EndEllipsis {get; set;}
Managed Extensions for C++
public: __property bool get_EndEllipsis();
public: __property void set_EndEllipsis(
   bool value
);
C++/CLI
public:
property bool EndEllipsis {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Font Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Font Property

Glossary Item Box

Font values

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
public:
property Font^ Font {
   Font^ get();
   void set (    Font^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FontColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : FontColor Property

Glossary Item Box

The color of the text

Syntax

Visual Basic (Declaration)
Public Property FontColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.FontColor = value

value = instance.FontColor
C#
public Color FontColor {get; set;}
Managed Extensions for C++
public: __property Color get_FontColor();
public: __property void set_FontColor(
   Color value
);
C++/CLI
public:
property Color FontColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FontColorSelected Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : FontColorSelected Property

Glossary Item Box

The color of the text when a cell is selected

Syntax

Visual Basic (Declaration)
Public Property FontColorSelected As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.FontColorSelected = value

value = instance.FontColorSelected
C#
public Color FontColorSelected {get; set;}
Managed Extensions for C++
public: __property Color get_FontColorSelected();
public: __property void set_FontColorSelected(
   Color value
);
C++/CLI
public:
property Color FontColorSelected {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HeaderBackgroundColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : HeaderBackgroundColor Property

Glossary Item Box

If this layout property is used in a header, use this back color

Syntax

Visual Basic (Declaration)
Public Property HeaderBackgroundColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.HeaderBackgroundColor = value

value = instance.HeaderBackgroundColor
C#
public Color HeaderBackgroundColor {get; set;}
Managed Extensions for C++
public: __property Color get_HeaderBackgroundColor();
public: __property void set_HeaderBackgroundColor(
   Color value
);
C++/CLI
public:
property Color HeaderBackgroundColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HeaderBackgroundGradiantColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : HeaderBackgroundGradiantColor Property

Glossary Item Box

If this layout property is used in a header, use this back gradiant color

Syntax

Visual Basic (Declaration)
Public Property HeaderBackgroundGradiantColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.HeaderBackgroundGradiantColor = value

value = instance.HeaderBackgroundGradiantColor
C#
public Color HeaderBackgroundGradiantColor {get; set;}
Managed Extensions for C++
public: __property Color get_HeaderBackgroundGradiantColor();
public: __property void set_HeaderBackgroundGradiantColor(
   Color value
);
C++/CLI
public:
property Color HeaderBackgroundGradiantColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HorzAlign Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : HorzAlign Property

Glossary Item Box

Horizontal alignment

Syntax

Visual Basic (Declaration)
Public Property HorzAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As StringAlignment

instance.HorzAlign = value

value = instance.HorzAlign
C#
public StringAlignment HorzAlign {get; set;}
Managed Extensions for C++
public: __property StringAlignment get_HorzAlign();
public: __property void set_HorzAlign(
   StringAlignment value
);
C++/CLI
public:
property StringAlignment HorzAlign {
   StringAlignment get();
   void set (    StringAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageIndex_Select Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : ImageIndex_Select Property

Glossary Item Box

Controls what imageList index will be used in front of the rendered text when the cell is selected

Syntax

Visual Basic (Declaration)
Public Property ImageIndex_Select As Integer
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Integer

instance.ImageIndex_Select = value

value = instance.ImageIndex_Select
C#
public int ImageIndex_Select {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex_Select();
public: __property void set_ImageIndex_Select(
   int value
);
C++/CLI
public:
property int ImageIndex_Select {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageIndex_UnSelect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : ImageIndex_UnSelect Property

Glossary Item Box

Controls what imageList index will be used in front of the rendered text when the cell is NOT selected

Syntax

Visual Basic (Declaration)
Public Property ImageIndex_UnSelect As Integer
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Integer

instance.ImageIndex_UnSelect = value

value = instance.ImageIndex_UnSelect
C#
public int ImageIndex_UnSelect {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex_UnSelect();
public: __property void set_ImageIndex_UnSelect(
   int value
);
C++/CLI
public:
property int ImageIndex_UnSelect {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineBottom Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : LineBottom Property

Glossary Item Box

The bottom line in the cell

Syntax

Visual Basic (Declaration)
Public Property LineBottom As LineOption
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As LineOption

instance.LineBottom = value

value = instance.LineBottom
C#
public LineOption LineBottom {get; set;}
Managed Extensions for C++
public: __property LineOption* get_LineBottom();
public: __property void set_LineBottom(
   LineOption* value
);
C++/CLI
public:
property LineOption^ LineBottom {
   LineOption^ get();
   void set (    LineOption^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineLeft Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : LineLeft Property

Glossary Item Box

The left line in the cell

Syntax

Visual Basic (Declaration)
Public Property LineLeft As LineOption
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As LineOption

instance.LineLeft = value

value = instance.LineLeft
C#
public LineOption LineLeft {get; set;}
Managed Extensions for C++
public: __property LineOption* get_LineLeft();
public: __property void set_LineLeft(
   LineOption* value
);
C++/CLI
public:
property LineOption^ LineLeft {
   LineOption^ get();
   void set (    LineOption^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineRight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : LineRight Property

Glossary Item Box

The right line in the cell

Syntax

Visual Basic (Declaration)
Public Property LineRight As LineOption
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As LineOption

instance.LineRight = value

value = instance.LineRight
C#
public LineOption LineRight {get; set;}
Managed Extensions for C++
public: __property LineOption* get_LineRight();
public: __property void set_LineRight(
   LineOption* value
);
C++/CLI
public:
property LineOption^ LineRight {
   LineOption^ get();
   void set (    LineOption^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineTop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : LineTop Property

Glossary Item Box

The top line in the cell

Syntax

Visual Basic (Declaration)
Public Property LineTop As LineOption
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As LineOption

instance.LineTop = value

value = instance.LineTop
C#
public LineOption LineTop {get; set;}
Managed Extensions for C++
public: __property LineOption* get_LineTop();
public: __property void set_LineTop(
   LineOption* value
);
C++/CLI
public:
property LineOption^ LineTop {
   LineOption^ get();
   void set (    LineOption^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MinHeight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : MinHeight Property

Glossary Item Box

Minimum cell height used.

Syntax

Visual Basic (Declaration)
Public Property MinHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Integer

instance.MinHeight = value

value = instance.MinHeight
C#
public int MinHeight {get; set;}
Managed Extensions for C++
public: __property int get_MinHeight();
public: __property void set_MinHeight(
   int value
);
C++/CLI
public:
property int MinHeight {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Name Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Name Property

Glossary Item Box

Name of CellLayout.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Padding Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Padding Property

Glossary Item Box

Padding for the cell

Syntax

Visual Basic (Declaration)
Public Property Padding As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Rectangle

instance.Padding = value

value = instance.Padding
C#
public Rectangle Padding {get; set;}
Managed Extensions for C++
public: __property Rectangle get_Padding();
public: __property void set_Padding(
   Rectangle value
);
C++/CLI
public:
property Rectangle Padding {
   Rectangle get();
   void set (    Rectangle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectedColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : SelectedColor Property

Glossary Item Box

Gets and sets the color of a selected cell in active grid.

Syntax

Visual Basic (Declaration)
Public Property SelectedColor As Color
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Color

instance.SelectedColor = value

value = instance.SelectedColor
C#
public Color SelectedColor {get; set;}
Managed Extensions for C++
public: __property Color get_SelectedColor();
public: __property void set_SelectedColor(
   Color value
);
C++/CLI
public:
property Color SelectedColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Spacing Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : Spacing Property

Glossary Item Box

Spacing for the cell

Syntax

Visual Basic (Declaration)
Public Property Spacing As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As Rectangle

instance.Spacing = value

value = instance.Spacing
C#
public Rectangle Spacing {get; set;}
Managed Extensions for C++
public: __property Rectangle get_Spacing();
public: __property void set_Spacing(
   Rectangle value
);
C++/CLI
public:
property Rectangle Spacing {
   Rectangle get();
   void set (    Rectangle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TextFormat Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : TextFormat Property

Glossary Item Box

Gets the object for text formatting.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property TextFormat As StringFormat
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As StringFormat

value = instance.TextFormat
C#
[BrowsableAttribute(false)]
public StringFormat TextFormat {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property StringFormat* get_TextFormat();
C++/CLI
[BrowsableAttribute(false)]
public:
property StringFormat^ TextFormat {
   StringFormat^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TextFormatNoWrap Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : TextFormatNoWrap Property

Glossary Item Box

Gets the object for text formatting, including no wrapping.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property TextFormatNoWrap As StringFormat
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As StringFormat

value = instance.TextFormatNoWrap
C#
[BrowsableAttribute(false)]
public StringFormat TextFormatNoWrap {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property StringFormat* get_TextFormatNoWrap();
C++/CLI
[BrowsableAttribute(false)]
public:
property StringFormat^ TextFormatNoWrap {
   StringFormat^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VertAlign Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayout Class : VertAlign Property

Glossary Item Box

Vertical alignment

Syntax

Visual Basic (Declaration)
Public Property VertAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As CellLayout
Dim value As StringAlignment

instance.VertAlign = value

value = instance.VertAlign
C#
public StringAlignment VertAlign {get; set;}
Managed Extensions for C++
public: __property StringAlignment get_VertAlign();
public: __property void set_VertAlign(
   StringAlignment value
);
C++/CLI
public:
property StringAlignment VertAlign {
   StringAlignment get();
   void set (    StringAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayout Class
CellLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayouts Class

Glossary Item Box

CellLayouts holds CellLayout objects that control cell rendering behaviour.

Object Model

CellLayouts ClassCellLayout Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CellLayouts
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
C#
[DefaultMemberAttribute("Item")]
public class CellLayouts : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CellLayouts : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CellLayouts : public System.Collections.CollectionBase

Example

C# Copy Code
CellLayout layout=new CellLayout();
      layout.MinHeight=20;
      layout.Font=new Font("Microsoft Sans Serif",10);
      layout.FontColor=Color.Black;
      layout.VertAlign=StringAlignment.Center;
      layout.Name="layout";
      layout.HeaderBackgroundColor=SystemColors.Control;
      layout.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor;
      layout.LineRight.Use=true;
      layout.LineRight.Color=SystemColors.ControlDark;
      layout.LineTop.Use=false;
      layout.LineBottom.Use=false;
      gantt1.Grid.CellLayouts.Add(layout);

      CellLayout layoutrightjust=new CellLayout();
      layoutrightjust.MinHeight=20;
      layoutrightjust.LineRight.Use=true;
      layoutrightjust.LineRight.Color=SystemColors.ControlDark;
      layoutrightjust.LineTop.Use=false;
      layoutrightjust.LineBottom.Use=false;
      layoutrightjust.Font=new Font("Microsoft Sans Serif",10);
      layoutrightjust.FontColor=Color.Black;
      layoutrightjust.Name="layoutrightjust";
      layoutrightjust.HorzAlign=StringAlignment.Far;
      layoutrightjust.VertAlign=StringAlignment.Center;
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor;
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor;
      gantt1.Grid.CellLayouts.Add(layoutrightjust);
Visual Basic Copy Code
Dim layout As CellLayout = New CellLayout()
      layout.MinHeight=20
      layout.Font = New Font("Microsoft Sans Serif",10)
      layout.FontColor=Color.Black
      layout.VertAlign=StringAlignment.Center
      layout.Name="layout"
      layout.HeaderBackgroundColor=SystemColors.Control
      layout.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor
      layout.LineRight.Use=True
      layout.LineRight.Color=SystemColors.ControlDark
      layout.LineTop.Use=False
      layout.LineBottom.Use=False
      gantt1.Grid.CellLayouts.Add(layout)

      Dim layoutrightjust As CellLayout = New CellLayout()
      layoutrightjust.MinHeight=20
      layoutrightjust.LineRight.Use=True
      layoutrightjust.LineRight.Color=SystemColors.ControlDark
      layoutrightjust.LineTop.Use=False
      layoutrightjust.LineBottom.Use=False
      layoutrightjust.Font = New Font("Microsoft Sans Serif",10)
      layoutrightjust.FontColor=Color.Black
      layoutrightjust.Name="layoutrightjust"
      layoutrightjust.HorzAlign=StringAlignment.Far
      layoutrightjust.VertAlign=StringAlignment.Center
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor
      gantt1.Grid.CellLayouts.Add(layoutrightjust)

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.CellLayouts

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellLayouts Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CellLayouts Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : CellLayouts Class

Glossary Item Box

The following tables list the members exposed by CellLayouts.

Public Constructors

 | Name | Description
Public Constructor | CellLayouts Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

Public Methods

 | Name | Description
Public Method | Add | Add a CellLayout to the collection. CellLayouts must be in the collection owned by the grid to enable the grid to look CellLayout's up from the name set in a GridColumn.
Public Method | ApplyNamedLayoutToCell | Looks up a CellLayout from a name; case sensitive. And assign it to a cell
Public Method | ApplyNamedLayoutToGridNode | Looks up a CellLayout from a name; case sensitive. And assign it to all cells on a GridNode
Public Method | Changed | Called automatically on changes, signals out of date to the grid and cells
Public Method | GetFromName | Looks up a CellLayout from a name; case sensitive
Public Method | IndexOf | IndexOf
Public Method | Remove | Removes an item from the collection
Top

Public Events

 | Name | Description
Public Event | OnChanged | Event fires on changes
Top

See Also

Reference

CellLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : CellLayouts Constructor

Glossary Item Box

Overload List

Overload | Description
CellLayouts Constructor() | CellLayouts main constructor.
CellLayouts Constructor(Grid) | Constructor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class > CellLayouts Constructor : CellLayouts Constructor()

Glossary Item Box

CellLayouts main constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellLayouts()
C#
public CellLayouts()
Managed Extensions for C++
public: CellLayouts();
C++/CLI
public:
CellLayouts();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Constructor(Grid)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class > CellLayouts Constructor : CellLayouts Constructor(Grid)

aGridControl

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGridControl As Grid _
)
Visual Basic (Usage) Copy Code
Dim aGridControl As Grid

Dim instance As New CellLayouts(aGridControl)
C#
public CellLayouts(
   Grid aGridControl
)
Managed Extensions for C++
public: CellLayouts(
   Grid* aGridControl
)
C++/CLI
public:
CellLayouts(
   Grid^ aGridControl
)

Parameters

aGridControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CellLayouts Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayouts Class

Glossary Item Box

For a list of all members of this type, see CellLayouts members.

Public Methods

 | Name | Description
Public Method | Add | Add a CellLayout to the collection. CellLayouts must be in the collection owned by the grid to enable the grid to look CellLayout's up from the name set in a GridColumn.
Public Method | ApplyNamedLayoutToCell | Looks up a CellLayout from a name; case sensitive. And assign it to a cell
Public Method | ApplyNamedLayoutToGridNode | Looks up a CellLayout from a name; case sensitive. And assign it to all cells on a GridNode
Public Method | Changed | Called automatically on changes, signals out of date to the grid and cells
Public Method | GetFromName | Looks up a CellLayout from a name; case sensitive
Public Method | IndexOf | IndexOf
Public Method | Remove | Removes an item from the collection
Top

See Also

Reference

CellLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : Add Method

aCellLayout

Glossary Item Box

Add a CellLayout to the collection. CellLayouts must be in the collection owned by the grid to enable the grid to look CellLayout's up from the name set in a GridColumn.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aCellLayout As CellLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim aCellLayout As CellLayout

instance.Add(aCellLayout)
C#
public void Add(
   CellLayout aCellLayout
)
Managed Extensions for C++
public: void Add(
   CellLayout* aCellLayout
)
C++/CLI
public:
void Add(
   CellLayout^ aCellLayout
)

Parameters

aCellLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ApplyNamedLayoutToCell Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : ApplyNamedLayoutToCell Method

aName
aCell

Glossary Item Box

Looks up a CellLayout from a name; case sensitive. And assign it to a cell

Syntax

Visual Basic (Declaration)
Public Sub ApplyNamedLayoutToCell( _
   ByVal aName As String, _
   ByVal aCell As Cell _
)
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim aName As String
Dim aCell As Cell

instance.ApplyNamedLayoutToCell(aName, aCell)
C#
public void ApplyNamedLayoutToCell(
   string aName,
   Cell aCell
)
Managed Extensions for C++
public: void ApplyNamedLayoutToCell(
   string* aName,
   Cell* aCell
)
C++/CLI
public:
void ApplyNamedLayoutToCell(
   String^ aName,
   Cell^ aCell
)

Parameters

aName
aCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ApplyNamedLayoutToGridNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : ApplyNamedLayoutToGridNode Method

aName
aNode

Glossary Item Box

Looks up a CellLayout from a name; case sensitive. And assign it to all cells on a GridNode

Syntax

Visual Basic (Declaration)
Public Sub ApplyNamedLayoutToGridNode( _
   ByVal aName As String, _
   ByVal aNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim aName As String
Dim aNode As GridNode

instance.ApplyNamedLayoutToGridNode(aName, aNode)
C#
public void ApplyNamedLayoutToGridNode(
   string aName,
   GridNode aNode
)
Managed Extensions for C++
public: void ApplyNamedLayoutToGridNode(
   string* aName,
   GridNode* aNode
)
C++/CLI
public:
void ApplyNamedLayoutToGridNode(
   String^ aName,
   GridNode^ aNode
)

Parameters

aName
aNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : Changed Method

Glossary Item Box

Called automatically on changes, signals out of date to the grid and cells

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetFromName Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : GetFromName Method

aName

Glossary Item Box

Looks up a CellLayout from a name; case sensitive

Syntax

Visual Basic (Declaration)
Public Function GetFromName( _
   ByVal aName As String _
) As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim aName As String
Dim value As CellLayout

value = instance.GetFromName(aName)
C#
public CellLayout GetFromName(
   string aName
)
Managed Extensions for C++
public: CellLayout* GetFromName(
   string* aName
)
C++/CLI
public:
CellLayout^ GetFromName(
   String^ aName
)

Parameters

aName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : IndexOf Method

value

Glossary Item Box

IndexOf

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : Remove Method

index

Glossary Item Box

Removes an item from the collection

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CellLayouts Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayouts Class

Glossary Item Box

For a list of all members of this type, see CellLayouts members.

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

See Also

Reference

CellLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim Index As Integer
Dim value As CellLayout

value = instance.Item(Index)
C#
public CellLayout this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property CellLayout* get_Item   int Index
;
C++/CLI
public:
property CellLayout^ default [int] {
   CellLayout^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
CellLayouts Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellLayouts Class

Glossary Item Box

For a list of all members of this type, see CellLayouts members.

Public Events

 | Name | Description
Public Event | OnChanged | Event fires on changes
Top

See Also

Reference

CellLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellLayouts Class : OnChanged Event

Glossary Item Box

Event fires on changes

Syntax

Visual Basic (Declaration)
Public Event OnChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CellLayouts
Dim handler As EventHandler

AddHandler instance.OnChanged, handler
C#
public event EventHandler OnChanged
Managed Extensions for C++
public: __event EventHandler* OnChanged
C++/CLI
public:
event EventHandler^ OnChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellLayouts Class
CellLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellSelectChangedEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellSelectChangedEventArgs Class

Glossary Item Box

Object Model

CellSelectChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellSelectChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellSelectChangedEventArgs
C#
public class CellSelectChangedEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CellSelectChangedEventArgs : public System.EventArgs
C++/CLI
public ref class CellSelectChangedEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CellSelectChangedEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellSelectChangedEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CellSelectChangedEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CellSelectChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by CellSelectChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CellSelectChangedEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | nowSelected |
Top

See Also

Reference

CellSelectChangedEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellSelectChangedEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellSelectChangedEventArgs Class : CellSelectChangedEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellSelectChangedEventArgs()
C#
public CellSelectChangedEventArgs()
Managed Extensions for C++
public: CellSelectChangedEventArgs();
C++/CLI
public:
CellSelectChangedEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellSelectChangedEventArgs Class
CellSelectChangedEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CellSelectChangedEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellSelectChangedEventArgs Class

Glossary Item Box

For a list of all members of this type, see CellSelectChangedEventArgs members.

Public Fields

 | Name | Description
Public Field | nowSelected |
Top

See Also

Reference

CellSelectChangedEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
nowSelected Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellSelectChangedEventArgs Class : nowSelected Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public nowSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CellSelectChangedEventArgs
Dim value As Boolean

value = instance.nowSelected

instance.nowSelected = value
C#
public bool nowSelected
Managed Extensions for C++
public: bool nowSelected
C++/CLI
public:
bool nowSelected

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellSelectChangedEventArgs Class
CellSelectChangedEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellTypeChooseEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellTypeChooseEventArgs Class

Glossary Item Box

Object Model

CellTypeChooseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellTypeChooseEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellTypeChooseEventArgs
C#
public class CellTypeChooseEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CellTypeChooseEventArgs : public System.EventArgs
C++/CLI
public ref class CellTypeChooseEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CellTypeChooseEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellTypeChooseEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CellTypeChooseEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CellTypeChooseEventArgs Class

Glossary Item Box

The following tables list the members exposed by CellTypeChooseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CellTypeChooseEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Column |
Public Field | Node |
Public Field | TypeToGiveNewCell |
Top

See Also

Reference

CellTypeChooseEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellTypeChooseEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellTypeChooseEventArgs Class : CellTypeChooseEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellTypeChooseEventArgs()
C#
public CellTypeChooseEventArgs()
Managed Extensions for C++
public: CellTypeChooseEventArgs();
C++/CLI
public:
CellTypeChooseEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellTypeChooseEventArgs Class
CellTypeChooseEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CellTypeChooseEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellTypeChooseEventArgs Class

Glossary Item Box

For a list of all members of this type, see CellTypeChooseEventArgs members.

Public Fields

 | Name | Description
Public Field | Column |
Public Field | Node |
Public Field | TypeToGiveNewCell |
Top

See Also

Reference

CellTypeChooseEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Column Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellTypeChooseEventArgs Class : Column Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Column As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As CellTypeChooseEventArgs
Dim value As GridColumn

value = instance.Column

instance.Column = value
C#
public GridColumn Column
Managed Extensions for C++
public: GridColumn* Column
C++/CLI
public:
GridColumn^ Column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellTypeChooseEventArgs Class
CellTypeChooseEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Node Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellTypeChooseEventArgs Class : Node Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Node As GridNode
Visual Basic (Usage) Copy Code
Dim instance As CellTypeChooseEventArgs
Dim value As GridNode

value = instance.Node

instance.Node = value
C#
public GridNode Node
Managed Extensions for C++
public: GridNode* Node
C++/CLI
public:
GridNode^ Node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellTypeChooseEventArgs Class
CellTypeChooseEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TypeToGiveNewCell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CellTypeChooseEventArgs Class : TypeToGiveNewCell Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public TypeToGiveNewCell As CellType
Visual Basic (Usage) Copy Code
Dim instance As CellTypeChooseEventArgs
Dim value As CellType

value = instance.TypeToGiveNewCell

instance.TypeToGiveNewCell = value
C#
public CellType TypeToGiveNewCell
Managed Extensions for C++
public: CellType TypeToGiveNewCell
C++/CLI
public:
CellType TypeToGiveNewCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellTypeChooseEventArgs Class
CellTypeChooseEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetectEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

Glossary Item Box

CollisionDetect event args

Object Model

CollisionDetectEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CollisionDetectEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CollisionDetectEventArgs
C#
public class CollisionDetectEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CollisionDetectEventArgs : public System.EventArgs
C++/CLI
public ref class CollisionDetectEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CollisionDetectEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CollisionDetectEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CollisionDetectEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

Glossary Item Box

The following tables list the members exposed by CollisionDetectEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CollisionDetectEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | GanttRow | The row where the collision occured
Public Field | TimeDistinctItem | Information on the detected collision
Top

See Also

Reference

CollisionDetectEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetectEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : CollisionDetectEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CollisionDetectEventArgs()
C#
public CollisionDetectEventArgs()
Managed Extensions for C++
public: CollisionDetectEventArgs();
C++/CLI
public:
CollisionDetectEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionDetectEventArgs Class
CollisionDetectEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CollisionDetectEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollisionDetectEventArgs Class

Glossary Item Box

For a list of all members of this type, see CollisionDetectEventArgs members.

Public Fields

 | Name | Description
Public Field | GanttRow | The row where the collision occured
Public Field | TimeDistinctItem | Information on the detected collision
Top

See Also

Reference

CollisionDetectEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : GanttRow Field

Glossary Item Box

The row where the collision occured

Syntax

Visual Basic (Declaration)
Public GanttRow As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As CollisionDetectEventArgs
Dim value As GanttRow

value = instance.GanttRow

instance.GanttRow = value
C#
public GanttRow GanttRow
Managed Extensions for C++
public: GanttRow* GanttRow
C++/CLI
public:
GanttRow^ GanttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionDetectEventArgs Class
CollisionDetectEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionDetectEventArgs Class : TimeDistinctItem Field

Glossary Item Box

Information on the detected collision

Syntax

Visual Basic (Declaration)
Public TimeDistinctItem As TimeDistinctItem
Visual Basic (Usage) Copy Code
Dim instance As CollisionDetectEventArgs
Dim value As TimeDistinctItem

value = instance.TimeDistinctItem

instance.TimeDistinctItem = value
C#
public TimeDistinctItem TimeDistinctItem
Managed Extensions for C++
public: TimeDistinctItem* TimeDistinctItem
C++/CLI
public:
TimeDistinctItem^ TimeDistinctItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionDetectEventArgs Class
CollisionDetectEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionNote Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollisionNote Class

Glossary Item Box

Holds detailed information about one collision

Object Model

CollisionNote Class

Syntax

Visual Basic (Declaration)
Public Class CollisionNote
Visual Basic (Usage) Copy Code
Dim instance As CollisionNote
C#
public class CollisionNote
Managed Extensions for C++
public __gc class CollisionNote
C++/CLI
public ref class CollisionNote

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CollisionNote

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CollisionNote Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CollisionNote Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CollisionNote Class

Glossary Item Box

The following tables list the members exposed by CollisionNote.

Public Constructors

 | Name | Description
Public Constructor | CollisionNote Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConflictDepth | The highest amount of time items colliding in this particular position.
Public Field | InCollision | One TimeDistinctItem that overlaps with the owner of this CollisionNote
Public Field | OverlapStarts | Information on where the overlap starts
Public Field | OverlapStops | Information on where the overlap stop
Top

See Also

Reference

CollisionNote Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionNote Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionNote Class : CollisionNote Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CollisionNote()
C#
public CollisionNote()
Managed Extensions for C++
public: CollisionNote();
C++/CLI
public:
CollisionNote();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionNote Class
CollisionNote Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CollisionNote Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollisionNote Class

Glossary Item Box

For a list of all members of this type, see CollisionNote members.

Public Fields

 | Name | Description
Public Field | ConflictDepth | The highest amount of time items colliding in this particular position.
Public Field | InCollision | One TimeDistinctItem that overlaps with the owner of this CollisionNote
Public Field | OverlapStarts | Information on where the overlap starts
Public Field | OverlapStops | Information on where the overlap stop
Top

See Also

Reference

CollisionNote Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictDepth Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionNote Class : ConflictDepth Field

Glossary Item Box

The highest amount of time items colliding in this particular position.

Syntax

Visual Basic (Declaration)
Public ConflictDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As CollisionNote
Dim value As Integer

value = instance.ConflictDepth

instance.ConflictDepth = value
C#
public int ConflictDepth
Managed Extensions for C++
public: int ConflictDepth
C++/CLI
public:
int ConflictDepth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionNote Class
CollisionNote Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
InCollision Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionNote Class : InCollision Field

Glossary Item Box

One TimeDistinctItem that overlaps with the owner of this CollisionNote

Syntax

Visual Basic (Declaration)
Public InCollision As TimeDistinctItem
Visual Basic (Usage) Copy Code
Dim instance As CollisionNote
Dim value As TimeDistinctItem

value = instance.InCollision

instance.InCollision = value
C#
public TimeDistinctItem InCollision
Managed Extensions for C++
public: TimeDistinctItem* InCollision
C++/CLI
public:
TimeDistinctItem^ InCollision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionNote Class
CollisionNote Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OverlapStarts Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionNote Class : OverlapStarts Field

Glossary Item Box

Information on where the overlap starts

Syntax

Visual Basic (Declaration)
Public OverlapStarts As Date
Visual Basic (Usage) Copy Code
Dim instance As CollisionNote
Dim value As Date

value = instance.OverlapStarts

instance.OverlapStarts = value
C#
public DateTime OverlapStarts
Managed Extensions for C++
public: DateTime OverlapStarts
C++/CLI
public:
DateTime OverlapStarts

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionNote Class
CollisionNote Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OverlapStops Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CollisionNote Class : OverlapStops Field

Glossary Item Box

Information on where the overlap stop

Syntax

Visual Basic (Declaration)
Public OverlapStops As Date
Visual Basic (Usage) Copy Code
Dim instance As CollisionNote
Dim value As Date

value = instance.OverlapStops

instance.OverlapStops = value
C#
public DateTime OverlapStops
Managed Extensions for C++
public: DateTime OverlapStops
C++/CLI
public:
DateTime OverlapStops

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CollisionNote Class
CollisionNote Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnOrderArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ColumnOrderArgs Class

Glossary Item Box

Arguments for ColumnOrderEvent

Object Model

ColumnOrderArgs Class

Syntax

Visual Basic (Declaration)
Public Class ColumnOrderArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ColumnOrderArgs
C#
public class ColumnOrderArgs : System.EventArgs
Managed Extensions for C++
public __gc class ColumnOrderArgs : public System.EventArgs
C++/CLI
public ref class ColumnOrderArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ColumnOrderArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ColumnOrderArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ColumnOrderArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : ColumnOrderArgs Class

Glossary Item Box

The following tables list the members exposed by ColumnOrderArgs.

Public Constructors

 | Name | Description
Public Constructor | ColumnOrderArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Allow | Set Allow to false to stop the move
Public Field | MovedColumnIndex | The index of the GridColumn being moved
Public Field | NewIndex | The new index the column will get if Allow is true
Top

See Also

Reference

ColumnOrderArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnOrderArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ColumnOrderArgs Class : ColumnOrderArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ColumnOrderArgs()
C#
public ColumnOrderArgs()
Managed Extensions for C++
public: ColumnOrderArgs();
C++/CLI
public:
ColumnOrderArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColumnOrderArgs Class
ColumnOrderArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ColumnOrderArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ColumnOrderArgs Class

Glossary Item Box

For a list of all members of this type, see ColumnOrderArgs members.

Public Fields

 | Name | Description
Public Field | Allow | Set Allow to false to stop the move
Public Field | MovedColumnIndex | The index of the GridColumn being moved
Public Field | NewIndex | The new index the column will get if Allow is true
Top

See Also

Reference

ColumnOrderArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Allow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ColumnOrderArgs Class : Allow Field

Glossary Item Box

Set Allow to false to stop the move

Syntax

Visual Basic (Declaration)
Public Allow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColumnOrderArgs
Dim value As Boolean

value = instance.Allow

instance.Allow = value
C#
public bool Allow
Managed Extensions for C++
public: bool Allow
C++/CLI
public:
bool Allow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColumnOrderArgs Class
ColumnOrderArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MovedColumnIndex Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ColumnOrderArgs Class : MovedColumnIndex Field

Glossary Item Box

The index of the GridColumn being moved

Syntax

Visual Basic (Declaration)
Public MovedColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnOrderArgs
Dim value As Integer

value = instance.MovedColumnIndex

instance.MovedColumnIndex = value
C#
public int MovedColumnIndex
Managed Extensions for C++
public: int MovedColumnIndex
C++/CLI
public:
int MovedColumnIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColumnOrderArgs Class
ColumnOrderArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NewIndex Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ColumnOrderArgs Class : NewIndex Field

Glossary Item Box

The new index the column will get if Allow is true

Syntax

Visual Basic (Declaration)
Public NewIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnOrderArgs
Dim value As Integer

value = instance.NewIndex

instance.NewIndex = value
C#
public int NewIndex
Managed Extensions for C++
public: int NewIndex
C++/CLI
public:
int NewIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ColumnOrderArgs Class
ColumnOrderArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ComboText Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ComboText Class

Glossary Item Box

ComboText.

Object Model

ComboText Class

Syntax

Visual Basic (Declaration)
Public Class ComboText
   Inherits ContentEntity
   Implements IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As ComboText
C#
public class ComboText : ContentEntity, IClipboardInteraction
Managed Extensions for C++
public __gc class ComboText : public ContentEntity, IClipboardInteraction
C++/CLI
public ref class ComboText : public ContentEntity, IClipboardInteraction

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.ComboText

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ComboText Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ComboText Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : ComboText Class

Glossary Item Box

The following tables list the members exposed by ComboText.

Public Properties

 | Name | Description
Public Property | EditBox | Gets the editBox.
Public Property | Text | Gets and sets the text of the grid cell.
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

ComboText Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ComboText Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ComboText Class

Glossary Item Box

For a list of all members of this type, see ComboText members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

ComboText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComboText Class : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As ComboText

instance.CopyToClipboard()
C#
public void CopyToClipboard()
Managed Extensions for C++
public: void CopyToClipboard();
C++/CLI
public:
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComboText Class
ComboText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComboText Class : PasteValueFromClipboard Method

Glossary Item Box

Implements the pasting of clipboard data

Syntax

Visual Basic (Declaration)
Public Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As ComboText

instance.PasteValueFromClipboard()
C#
public void PasteValueFromClipboard()
Managed Extensions for C++
public: void PasteValueFromClipboard();
C++/CLI
public:
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComboText Class
ComboText Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ComboText Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ComboText Class

Glossary Item Box

For a list of all members of this type, see ComboText members.

Public Properties

 | Name | Description
Public Property | EditBox | Gets the editBox.
Public Property | Text | Gets and sets the text of the grid cell.
Top

See Also

Reference

ComboText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditBox Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComboText Class : EditBox Property

Glossary Item Box

Gets the editBox.

Syntax

Visual Basic (Declaration)
Public Property EditBox As ComboBox
Visual Basic (Usage) Copy Code
Dim instance As ComboText
Dim value As ComboBox

instance.EditBox = value

value = instance.EditBox
C#
public ComboBox EditBox {get; set;}
Managed Extensions for C++
public: __property ComboBox* get_EditBox();
public: __property void set_EditBox(
   ComboBox* value
);
C++/CLI
public:
property ComboBox^ EditBox {
   ComboBox^ get();
   void set (    ComboBox^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComboText Class
ComboText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComboText Class : Text Property

Glossary Item Box

Gets and sets the text of the grid cell.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ComboText
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComboText Class
ComboText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CommonDataConnect Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CommonDataConnect Class

Glossary Item Box

Object Model

CommonDataConnect Class

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class CommonDataConnect
Visual Basic (Usage) Copy Code
Dim instance As CommonDataConnect
C#
public static class CommonDataConnect
Managed Extensions for C++
public __gc abstract __sealed class CommonDataConnect
C++/CLI
public ref class CommonDataConnect abstract sealed

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CommonDataConnect

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CommonDataConnect Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CommonDataConnect Class Members
See Also Methods Send comments on this topic.
PlexityHide.GTP Namespace : CommonDataConnect Class

Glossary Item Box

The following tables list the members exposed by CommonDataConnect.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertNotifyCollectionChangedToListChanged |
Top

See Also

Reference

CommonDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CommonDataConnect Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CommonDataConnect Class

Glossary Item Box

For a list of all members of this type, see CommonDataConnect members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertNotifyCollectionChangedToListChanged |
Top

See Also

Reference

CommonDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConvertNotifyCollectionChangedToListChanged Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CommonDataConnect Class : ConvertNotifyCollectionChangedToListChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertNotifyCollectionChangedToListChanged( _
   ByVal e As NotifyCollectionChangedEventArgs _
) As ListChangedEventArgs
Visual Basic (Usage) Copy Code
Dim e As NotifyCollectionChangedEventArgs
Dim value As ListChangedEventArgs

value = CommonDataConnect.ConvertNotifyCollectionChangedToListChanged(e)
C#
public static ListChangedEventArgs ConvertNotifyCollectionChangedToListChanged(
   NotifyCollectionChangedEventArgs e
)
Managed Extensions for C++
public: static ListChangedEventArgs* ConvertNotifyCollectionChangedToListChanged(
   NotifyCollectionChangedEventArgs* e
)
C++/CLI
public:
static ListChangedEventArgs^ ConvertNotifyCollectionChangedToListChanged(
   NotifyCollectionChangedEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonDataConnect Class
CommonDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ComparerForGridSort Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ComparerForGridSort Class

Glossary Item Box

This class is used internaly when performing unbinded sort.

Object Model

ComparerForGridSort Class

Syntax

Visual Basic (Declaration)
Public Class ComparerForGridSort
Visual Basic (Usage) Copy Code
Dim instance As ComparerForGridSort
C#
public class ComparerForGridSort
Managed Extensions for C++
public __gc class ComparerForGridSort
C++/CLI
public ref class ComparerForGridSort

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ComparerForGridSort

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ComparerForGridSort Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ComparerForGridSort Class Members
See Also Methods Send comments on this topic.
PlexityHide.GTP Namespace : ComparerForGridSort Class

Glossary Item Box

The following tables list the members exposed by ComparerForGridSort.

Public Constructors

 | Name | Description
Public Constructor | ComparerForGridSort Constructor | Compares two GridNodes based on ColIndex
Top

Public Methods

 | Name | Description
Public Method | Compare | Compares two GridNodes based on ColIndex from the constructor
Top

See Also

Reference

ComparerForGridSort Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ComparerForGridSort Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComparerForGridSort Class : ComparerForGridSort Constructor

aColIndex
aDecending

Glossary Item Box

Compares two GridNodes based on ColIndex

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aColIndex As Integer, _
   ByVal aDecending As Boolean _
)
Visual Basic (Usage) Copy Code
Dim aColIndex As Integer
Dim aDecending As Boolean

Dim instance As New ComparerForGridSort(aColIndex, aDecending)
C#
public ComparerForGridSort(
   int aColIndex,
   bool aDecending
)
Managed Extensions for C++
public: ComparerForGridSort(
   int aColIndex,
   bool aDecending
)
C++/CLI
public:
ComparerForGridSort(
   int aColIndex,
   bool aDecending
)

Parameters

aColIndex
aDecending

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComparerForGridSort Class
ComparerForGridSort Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ComparerForGridSort Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ComparerForGridSort Class

Glossary Item Box

For a list of all members of this type, see ComparerForGridSort members.

Public Methods

 | Name | Description
Public Method | Compare | Compares two GridNodes based on ColIndex from the constructor
Top

See Also

Reference

ComparerForGridSort Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Compare Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ComparerForGridSort Class : Compare Method

x
y

Glossary Item Box

Compares two GridNodes based on ColIndex from the constructor

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal x As Object, _
   ByVal y As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComparerForGridSort
Dim x As Object
Dim y As Object
Dim value As Integer

value = instance.Compare(x, y)
C#
public int Compare(
   object x,
   object y
)
Managed Extensions for C++
public: int Compare(
   Object* x,
   Object* y
)
C++/CLI
public:
int Compare(
   Object^ x,
   Object^ y
)

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ComparerForGridSort Class
ComparerForGridSort Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea Class

Glossary Item Box

This class represents the detailed information that can be collected on each collision that is detected. To collect conflictAreas for a time item GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true.

Object Model

ConflictArea Class

Syntax

Visual Basic (Declaration)
Public Class ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
C#
public class ConflictArea
Managed Extensions for C++
public __gc class ConflictArea
C++/CLI
public ref class ConflictArea

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ConflictArea

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ConflictArea Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ConflictArea Class Members
See Also Fields Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea Class

Glossary Item Box

The following tables list the members exposed by ConflictArea.

Public Constructors

 | Name | Description
Public Constructor | ConflictArea Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConflictDepth | The the largest number of time items that exist in the same time during the span of this conflict area
Public Field | ConflictingTimeItem | The time item in conflict with OwningTimeItem that this object represents.
Public Field | OwningTimeItem | The owning time item for this conflict area
Public Field | Start | The start of this conflict
Public Field | Stop | The stop of this conflict
Public Field | UserReference | Free for you to use...
Top

Public Properties

 | Name | Description
Public Property | InVisibleDateTimeArea | Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawNormal | This method implements the ConflictAreaDrawStyle.Normal style
Public Method | GetBoundingRect | Returns the bounding rect of this conflict area.
Public Method | GetOtherEnd | A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.
Top

See Also

Reference

ConflictArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : ConflictArea Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ConflictArea()
C#
public ConflictArea()
Managed Extensions for C++
public: ConflictArea();
C++/CLI
public:
ConflictArea();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ConflictArea Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea Class

Glossary Item Box

For a list of all members of this type, see ConflictArea members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DrawNormal | This method implements the ConflictAreaDrawStyle.Normal style
Public Method | GetBoundingRect | Returns the bounding rect of this conflict area.
Public Method | GetOtherEnd | A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.
Top

See Also

Reference

ConflictArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawNormal Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : DrawNormal Method

G
r
aTimeItemLayout

Glossary Item Box

This method implements the ConflictAreaDrawStyle.Normal style

Syntax

Visual Basic (Declaration)
Public Shared Sub DrawNormal( _
   ByVal G As Graphics, _
   ByVal r As Rectangle, _
   ByVal aTimeItemLayout As TimeItemLayout _
)
Visual Basic (Usage) Copy Code
Dim G As Graphics
Dim r As Rectangle
Dim aTimeItemLayout As TimeItemLayout

ConflictArea.DrawNormal(G, r, aTimeItemLayout)
C#
public static void DrawNormal(
   Graphics G,
   Rectangle r,
   TimeItemLayout aTimeItemLayout
)
Managed Extensions for C++
public: static void DrawNormal(
   Graphics* G,
   Rectangle r,
   TimeItemLayout* aTimeItemLayout
)
C++/CLI
public:
static void DrawNormal(
   Graphics^ G,
   Rectangle r,
   TimeItemLayout^ aTimeItemLayout
)

Parameters

G
r
aTimeItemLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetBoundingRect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : GetBoundingRect Method

timeItemsCurrentLocation

Glossary Item Box

Returns the bounding rect of this conflict area.

Syntax

Visual Basic (Declaration)
Public Function GetBoundingRect( _
   ByVal timeItemsCurrentLocation As Point _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim timeItemsCurrentLocation As Point
Dim value As Rectangle

value = instance.GetBoundingRect(timeItemsCurrentLocation)
C#
public Rectangle GetBoundingRect(
   Point timeItemsCurrentLocation
)
Managed Extensions for C++
public: Rectangle GetBoundingRect(
   Point timeItemsCurrentLocation
)
C++/CLI
public:
Rectangle GetBoundingRect(
   Point timeItemsCurrentLocation
)

Parameters

timeItemsCurrentLocation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetOtherEnd Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : GetOtherEnd Method

Glossary Item Box

A conflict has always two time items to blame and hence two conflict areas. One conflict area in each time item. Use this method to quickly find the ConflictArea from the other time item.

Syntax

Visual Basic (Declaration)
Public Function GetOtherEnd() As ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As ConflictArea

value = instance.GetOtherEnd()
C#
public ConflictArea GetOtherEnd()
Managed Extensions for C++
public: ConflictArea* GetOtherEnd();
C++/CLI
public:
ConflictArea^ GetOtherEnd();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ConflictArea Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea Class

Glossary Item Box

For a list of all members of this type, see ConflictArea members.

Public Properties

 | Name | Description
Public Property | InVisibleDateTimeArea | Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...
Top

See Also

Reference

ConflictArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
InVisibleDateTimeArea Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : InVisibleDateTimeArea Property

Glossary Item Box

Is this conflict currently visible on screen, datetime wise (could still be on a scrolled, collapsed or hidden row)...

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InVisibleDateTimeArea As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As Boolean

value = instance.InVisibleDateTimeArea
C#
public bool InVisibleDateTimeArea {get;}
Managed Extensions for C++
public: __property bool get_InVisibleDateTimeArea();
C++/CLI
public:
property bool InVisibleDateTimeArea {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ConflictArea Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea Class

Glossary Item Box

For a list of all members of this type, see ConflictArea members.

Public Fields

 | Name | Description
Public Field | ConflictDepth | The the largest number of time items that exist in the same time during the span of this conflict area
Public Field | ConflictingTimeItem | The time item in conflict with OwningTimeItem that this object represents.
Public Field | OwningTimeItem | The owning time item for this conflict area
Public Field | Start | The start of this conflict
Public Field | Stop | The stop of this conflict
Public Field | UserReference | Free for you to use...
Top

See Also

Reference

ConflictArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictDepth Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : ConflictDepth Field

Glossary Item Box

The the largest number of time items that exist in the same time during the span of this conflict area

Syntax

Visual Basic (Declaration)
Public ConflictDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As Integer

value = instance.ConflictDepth

instance.ConflictDepth = value
C#
public int ConflictDepth
Managed Extensions for C++
public: int ConflictDepth
C++/CLI
public:
int ConflictDepth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictingTimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : ConflictingTimeItem Field

Glossary Item Box

The time item in conflict with OwningTimeItem that this object represents.

Syntax

Visual Basic (Declaration)
Public ConflictingTimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As TimeItem

value = instance.ConflictingTimeItem

instance.ConflictingTimeItem = value
C#
public TimeItem ConflictingTimeItem
Managed Extensions for C++
public: TimeItem* ConflictingTimeItem
C++/CLI
public:
TimeItem^ ConflictingTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OwningTimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : OwningTimeItem Field

Glossary Item Box

The owning time item for this conflict area

Syntax

Visual Basic (Declaration)
Public OwningTimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As TimeItem

value = instance.OwningTimeItem

instance.OwningTimeItem = value
C#
public TimeItem OwningTimeItem
Managed Extensions for C++
public: TimeItem* OwningTimeItem
C++/CLI
public:
TimeItem^ OwningTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : Start Field

Glossary Item Box

The start of this conflict

Syntax

Visual Basic (Declaration)
Public Start As Date
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As Date

value = instance.Start

instance.Start = value
C#
public DateTime Start
Managed Extensions for C++
public: DateTime Start
C++/CLI
public:
DateTime Start

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Stop Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : Stop Field

Glossary Item Box

The stop of this conflict

Syntax

Visual Basic (Declaration)
Public Stop As Date
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As Date

value = instance.Stop

instance.Stop = value
C#
public DateTime Stop
Managed Extensions for C++
public: DateTime Stop
C++/CLI
public:
DateTime Stop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea Class : UserReference Field

Glossary Item Box

Free for you to use...

Syntax

Visual Basic (Declaration)
Public UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea
Dim value As Object

value = instance.UserReference

instance.UserReference = value
C#
public object UserReference
Managed Extensions for C++
public: Object* UserReference
C++/CLI
public:
Object^ UserReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea Class
ConflictArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_UpdateArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

Glossary Item Box

The arguments used by the ConflictArea_Update event

Object Model

ConflictArea_UpdateArgs Class

Syntax

Visual Basic (Declaration)
Public Class ConflictArea_UpdateArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UpdateArgs
C#
public class ConflictArea_UpdateArgs : System.EventArgs
Managed Extensions for C++
public __gc class ConflictArea_UpdateArgs : public System.EventArgs
C++/CLI
public ref class ConflictArea_UpdateArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ConflictArea_UpdateArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ConflictArea_UpdateArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ConflictArea_UpdateArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

Glossary Item Box

The following tables list the members exposed by ConflictArea_UpdateArgs.

Public Constructors

 | Name | Description
Public Constructor | ConflictArea_UpdateArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConflictArea | The ConflictArea that was updated
Public Field | ConflictAreaUpdateKind | The graphics context
Top

See Also

Reference

ConflictArea_UpdateArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_UpdateArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictArea_UpdateArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ConflictArea_UpdateArgs()
C#
public ConflictArea_UpdateArgs()
Managed Extensions for C++
public: ConflictArea_UpdateArgs();
C++/CLI
public:
ConflictArea_UpdateArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UpdateArgs Class
ConflictArea_UpdateArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ConflictArea_UpdateArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UpdateArgs Class

Glossary Item Box

For a list of all members of this type, see ConflictArea_UpdateArgs members.

Public Fields

 | Name | Description
Public Field | ConflictArea | The ConflictArea that was updated
Public Field | ConflictAreaUpdateKind | The graphics context
Top

See Also

Reference

ConflictArea_UpdateArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictArea Field

Glossary Item Box

The ConflictArea that was updated

Syntax

Visual Basic (Declaration)
Public ConflictArea As ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UpdateArgs
Dim value As ConflictArea

value = instance.ConflictArea

instance.ConflictArea = value
C#
public ConflictArea ConflictArea
Managed Extensions for C++
public: ConflictArea* ConflictArea
C++/CLI
public:
ConflictArea^ ConflictArea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UpdateArgs Class
ConflictArea_UpdateArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaUpdateKind Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UpdateArgs Class : ConflictAreaUpdateKind Field

Glossary Item Box

The graphics context

Syntax

Visual Basic (Declaration)
Public ConflictAreaUpdateKind As ConflictAreaUpdateKind
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UpdateArgs
Dim value As ConflictAreaUpdateKind

value = instance.ConflictAreaUpdateKind

instance.ConflictAreaUpdateKind = value
C#
public ConflictAreaUpdateKind ConflictAreaUpdateKind
Managed Extensions for C++
public: ConflictAreaUpdateKind ConflictAreaUpdateKind
C++/CLI
public:
ConflictAreaUpdateKind ConflictAreaUpdateKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UpdateArgs Class
ConflictArea_UpdateArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_UserDrawArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UserDrawArgs Class

Glossary Item Box

The argument used by the ConflictArea_UserDraw event

Object Model

ConflictArea_UserDrawArgs Class

Syntax

Visual Basic (Declaration)
Public Class ConflictArea_UserDrawArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UserDrawArgs
C#
public class ConflictArea_UserDrawArgs : System.EventArgs
Managed Extensions for C++
public __gc class ConflictArea_UserDrawArgs : public System.EventArgs
C++/CLI
public ref class ConflictArea_UserDrawArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ConflictArea_UserDrawArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ConflictArea_UserDrawArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ConflictArea_UserDrawArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UserDrawArgs Class

Glossary Item Box

The following tables list the members exposed by ConflictArea_UserDrawArgs.

Public Constructors

 | Name | Description
Public Constructor | ConflictArea_UserDrawArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ConflictArea | The ConflictArea to draw
Public Field | G | The graphics context
Public Field | Rectangle | The suggested rectangle for drawing
Top

See Also

Reference

ConflictArea_UserDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_UserDrawArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UserDrawArgs Class : ConflictArea_UserDrawArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ConflictArea_UserDrawArgs()
C#
public ConflictArea_UserDrawArgs()
Managed Extensions for C++
public: ConflictArea_UserDrawArgs();
C++/CLI
public:
ConflictArea_UserDrawArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UserDrawArgs Class
ConflictArea_UserDrawArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ConflictArea_UserDrawArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UserDrawArgs Class

Glossary Item Box

For a list of all members of this type, see ConflictArea_UserDrawArgs members.

Public Fields

 | Name | Description
Public Field | ConflictArea | The ConflictArea to draw
Public Field | G | The graphics context
Public Field | Rectangle | The suggested rectangle for drawing
Top

See Also

Reference

ConflictArea_UserDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UserDrawArgs Class : ConflictArea Field

Glossary Item Box

The ConflictArea to draw

Syntax

Visual Basic (Declaration)
Public ConflictArea As ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UserDrawArgs
Dim value As ConflictArea

value = instance.ConflictArea

instance.ConflictArea = value
C#
public ConflictArea ConflictArea
Managed Extensions for C++
public: ConflictArea* ConflictArea
C++/CLI
public:
ConflictArea^ ConflictArea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UserDrawArgs Class
ConflictArea_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UserDrawArgs Class : G Field

Glossary Item Box

The graphics context

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UserDrawArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UserDrawArgs Class
ConflictArea_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rectangle Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ConflictArea_UserDrawArgs Class : Rectangle Field

Glossary Item Box

The suggested rectangle for drawing

Syntax

Visual Basic (Declaration)
Public Rectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ConflictArea_UserDrawArgs
Dim value As Rectangle

value = instance.Rectangle

instance.Rectangle = value
C#
public Rectangle Rectangle
Managed Extensions for C++
public: Rectangle Rectangle
C++/CLI
public:
Rectangle Rectangle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ConflictArea_UserDrawArgs Class
ConflictArea_UserDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContentEntity Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ContentEntity Class

Glossary Item Box

ContentEntity.

Object Model

ContentEntity ClassCell Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ContentEntity
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
C#
public abstract class ContentEntity
Managed Extensions for C++
public __gc abstract class ContentEntity
C++/CLI
public ref class ContentEntity abstract

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.BoolCheck
PlexityHide.GTP.ComboText
PlexityHide.GTP.CustomCell
PlexityHide.GTP.MultiText
PlexityHide.GTP.SingleText
PlexityHide.GTP.TimeDate

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ContentEntity Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ContentEntity Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : ContentEntity Class

Glossary Item Box

The following tables list the members exposed by ContentEntity.

Public Properties

 | Name | Description
Public Property | Cell | The Cell that holds this content
Public Property | LimitRect | The rect that edit can use
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | Value | The value of the cell, most content types uses string as the object
Top

Public Methods

 | Name | Description
Public Method | DoAfterEditEvent | Handles event that fires after edit is complete
Public Method | DoBeforeEditEvent | Handles event that fires before edit
Public Method | DoBeforeEndEditEvent | Handles event that fires after edit
Top

See Also

Reference

ContentEntity Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ContentEntity Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ContentEntity Class

Glossary Item Box

For a list of all members of this type, see ContentEntity members.

Public Methods

 | Name | Description
Public Method | DoAfterEditEvent | Handles event that fires after edit is complete
Public Method | DoBeforeEditEvent | Handles event that fires before edit
Public Method | DoBeforeEndEditEvent | Handles event that fires after edit
Top

See Also

Reference

ContentEntity Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DoAfterEditEvent Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : DoAfterEditEvent Method

Glossary Item Box

Handles event that fires after edit is complete

Syntax

Visual Basic (Declaration)
Public Sub DoAfterEditEvent()
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity

instance.DoAfterEditEvent()
C#
public void DoAfterEditEvent()
Managed Extensions for C++
public: void DoAfterEditEvent();
C++/CLI
public:
void DoAfterEditEvent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DoBeforeEditEvent Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : DoBeforeEditEvent Method

Glossary Item Box

Handles event that fires before edit

Syntax

Visual Basic (Declaration)
Public Function DoBeforeEditEvent() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Boolean

value = instance.DoBeforeEditEvent()
C#
public bool DoBeforeEditEvent()
Managed Extensions for C++
public: bool DoBeforeEditEvent();
C++/CLI
public:
bool DoBeforeEditEvent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DoBeforeEndEditEvent Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : DoBeforeEndEditEvent Method

Glossary Item Box

Handles event that fires after edit

Syntax

Visual Basic (Declaration)
Public Function DoBeforeEndEditEvent() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Boolean

value = instance.DoBeforeEndEditEvent()
C#
public bool DoBeforeEndEditEvent()
Managed Extensions for C++
public: bool DoBeforeEndEditEvent();
C++/CLI
public:
bool DoBeforeEndEditEvent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ContentEntity Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ContentEntity Class

Glossary Item Box

For a list of all members of this type, see ContentEntity members.

Public Properties

 | Name | Description
Public Property | Cell | The Cell that holds this content
Public Property | LimitRect | The rect that edit can use
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | Value | The value of the cell, most content types uses string as the object
Top

See Also

Reference

ContentEntity Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : Cell Property

Glossary Item Box

The Cell that holds this content

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Cell

value = instance.Cell
C#
public Cell Cell {get;}
Managed Extensions for C++
public: __property Cell* get_Cell();
C++/CLI
public:
property Cell^ Cell {
   Cell^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LimitRect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : LimitRect Property

Glossary Item Box

The rect that edit can use

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LimitRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Rectangle

value = instance.LimitRect
C#
public Rectangle LimitRect {get;}
Managed Extensions for C++
public: __property Rectangle get_LimitRect();
C++/CLI
public:
property Rectangle LimitRect {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : UserReference Property

Glossary Item Box

User reference, use this to tie against your own data

Syntax

Visual Basic (Declaration)
Public Property UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Object

instance.UserReference = value

value = instance.UserReference
C#
public object UserReference {get; set;}
Managed Extensions for C++
public: __property Object* get_UserReference();
public: __property void set_UserReference(
   Object* value
);
C++/CLI
public:
property Object^ UserReference {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Value Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ContentEntity Class : Value Property

Glossary Item Box

The value of the cell, most content types uses string as the object

Syntax

Visual Basic (Declaration)
Public Overridable Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As ContentEntity
Dim value As Object

instance.Value = value

value = instance.Value
C#
public virtual object Value {get; set;}
Managed Extensions for C++
public: __property virtual Object* get_Value();
public: __property virtual void set_Value(
   Object* value
);
C++/CLI
public:
virtual property Object^ Value {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContentEntity Class
ContentEntity Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CountedBitmap Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CountedBitmap Class

Glossary Item Box

Object Model

CountedBitmap Class

Syntax

Visual Basic (Declaration)
Public Class CountedBitmap
Visual Basic (Usage) Copy Code
Dim instance As CountedBitmap
C#
public class CountedBitmap
Managed Extensions for C++
public __gc class CountedBitmap
C++/CLI
public ref class CountedBitmap

Inheritance Hierarchy

System.Object
PlexityHide.GTP.CountedBitmap

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CountedBitmap Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CountedBitmap Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CountedBitmap Class

Glossary Item Box

The following tables list the members exposed by CountedBitmap.

Public Constructors

 | Name | Description
Public Constructor | CountedBitmap Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Count |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
static (Shared in Visual Basic) | Dispose |
Top

See Also

Reference

CountedBitmap Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CountedBitmap Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CountedBitmap Class : CountedBitmap Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CountedBitmap()
C#
public CountedBitmap()
Managed Extensions for C++
public: CountedBitmap();
C++/CLI
public:
CountedBitmap();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CountedBitmap Class
CountedBitmap Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CountedBitmap Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CountedBitmap Class

Glossary Item Box

For a list of all members of this type, see CountedBitmap members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
static (Shared in Visual Basic) | Dispose |
Top

See Also

Reference

CountedBitmap Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Create Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CountedBitmap Class : Create Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Create()
Visual Basic (Usage) Copy Code
CountedBitmap.Create()
C#
public static void Create()
Managed Extensions for C++
public: static void Create();
C++/CLI
public:
static void Create();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CountedBitmap Class
CountedBitmap Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Dispose Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CountedBitmap Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Dispose()
Visual Basic (Usage) Copy Code
CountedBitmap.Dispose()
C#
public static void Dispose()
Managed Extensions for C++
public: static void Dispose();
C++/CLI
public:
static void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CountedBitmap Class
CountedBitmap Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CountedBitmap Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CountedBitmap Class

Glossary Item Box

For a list of all members of this type, see CountedBitmap members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Count |
Top

See Also

Reference

CountedBitmap Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Count Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CountedBitmap Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CountedBitmap.Count
C#
public static int Count {get;}
Managed Extensions for C++
public: __property static int get_Count();
C++/CLI
public:
static property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CountedBitmap Class
CountedBitmap Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CustomCell Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCell Class

Glossary Item Box

CustomCell.

Object Model

CustomCell Class

Syntax

Visual Basic (Declaration)
Public Class CustomCell
   Inherits ContentEntity
Visual Basic (Usage) Copy Code
Dim instance As CustomCell
C#
public class CustomCell : ContentEntity
Managed Extensions for C++
public __gc class CustomCell : public ContentEntity
C++/CLI
public ref class CustomCell : public ContentEntity

Example

C# Copy Code
private void grid1_OnCustomCellDraw(PlexityHide.GTP.Grid aGrid, PlexityHide.GTP.CustomCellEventArgs e)
{
    e.G.DrawArc(new Pen(Color.Red,3),e.DrawRect,0,180);
    e.G.DrawArc(new Pen(Color.Purple,3),e.DrawRect,180,180);
}
Visual Basic Copy Code
Private Sub grid1_OnCustomCellDraw(ByVal aGrid As PlexityHide.GTP.Grid, ByVal e As PlexityHide.GTP.CustomCellEventArgs)
    e.G.DrawArc(New Pen(Color.Red,3),e.DrawRect,0,180)
    e.G.DrawArc(New Pen(Color.Purple,3),e.DrawRect,180,180)
End Sub

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.CustomCell

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CustomCell Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CustomCell Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : CustomCell Class

Glossary Item Box

The following tables list the members exposed by CustomCell.

Public Properties

 | Name | Description
Public Property | InEdit | This flag is true if this CustomCell is in edit mode. Since the cell is "custom" we have no additional information. It is a good idea to keep a reference of your custom editor somewhere if you need to reference it.
Top

See Also

Reference

CustomCell Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
CustomCell Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCell Class

Glossary Item Box

For a list of all members of this type, see CustomCell members.

Public Properties

 | Name | Description
Public Property | InEdit | This flag is true if this CustomCell is in edit mode. Since the cell is "custom" we have no additional information. It is a good idea to keep a reference of your custom editor somewhere if you need to reference it.
Top

See Also

Reference

CustomCell Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
InEdit Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCell Class : InEdit Property

Glossary Item Box

This flag is true if this CustomCell is in edit mode. Since the cell is "custom" we have no additional information. It is a good idea to keep a reference of your custom editor somewhere if you need to reference it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomCell
Dim value As Boolean

value = instance.InEdit
C#
public bool InEdit {get;}
Managed Extensions for C++
public: __property bool get_InEdit();
C++/CLI
public:
property bool InEdit {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCell Class
CustomCell Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CustomCellEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCellEventArgs Class

Glossary Item Box

Arguments for custom cell drawing and editing

Object Model

CustomCellEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CustomCellEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
C#
public class CustomCellEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CustomCellEventArgs : public System.EventArgs
C++/CLI
public ref class CustomCellEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.CustomCellEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CustomCellEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
CustomCellEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : CustomCellEventArgs Class

Glossary Item Box

The following tables list the members exposed by CustomCellEventArgs.

Public Constructors

 | Name | Description
Public Constructor | CustomCellEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The cell that the Custom edit refers to.
Public Field | CharThatStartedEdit | The character that was typed in the cell when it was not in edit mode; you should decide if you want to start edit.
Public Field | DrawRect |
Public Field | G |
Public Field | MouseEventThatStartedEdit | Details of the mouse event that started the edit
Public Field | ReturnHeight | Custom cells can have their own rules for deciding the cell height
Public Field | StartedEdit | Set to true (default) in the CustomCellEditStartByMouse or OnCustomCellEditStartByKey if you choose to start edit. If edit is not started set to false.
Top

See Also

Reference

CustomCellEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CustomCellEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : CustomCellEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CustomCellEventArgs()
C#
public CustomCellEventArgs()
Managed Extensions for C++
public: CustomCellEventArgs();
C++/CLI
public:
CustomCellEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
CustomCellEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCellEventArgs Class

Glossary Item Box

For a list of all members of this type, see CustomCellEventArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The cell that the Custom edit refers to.
Public Field | CharThatStartedEdit | The character that was typed in the cell when it was not in edit mode; you should decide if you want to start edit.
Public Field | DrawRect |
Public Field | G |
Public Field | MouseEventThatStartedEdit | Details of the mouse event that started the edit
Public Field | ReturnHeight | Custom cells can have their own rules for deciding the cell height
Public Field | StartedEdit | Set to true (default) in the CustomCellEditStartByMouse or OnCustomCellEditStartByKey if you choose to start edit. If edit is not started set to false.
Top

See Also

Reference

CustomCellEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : Cell Field

Glossary Item Box

The cell that the Custom edit refers to.

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CharThatStartedEdit Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : CharThatStartedEdit Field

Glossary Item Box

The character that was typed in the cell when it was not in edit mode; you should decide if you want to start edit.

Syntax

Visual Basic (Declaration)
Public CharThatStartedEdit As Char
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Char

value = instance.CharThatStartedEdit

instance.CharThatStartedEdit = value
C#
public char CharThatStartedEdit
Managed Extensions for C++
public: char CharThatStartedEdit
C++/CLI
public:
char CharThatStartedEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawRect Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : DrawRect Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public DrawRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Rectangle

value = instance.DrawRect

instance.DrawRect = value
C#
public Rectangle DrawRect
Managed Extensions for C++
public: Rectangle DrawRect
C++/CLI
public:
Rectangle DrawRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : G Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseEventThatStartedEdit Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : MouseEventThatStartedEdit Field

Glossary Item Box

Details of the mouse event that started the edit

Syntax

Visual Basic (Declaration)
Public MouseEventThatStartedEdit As MouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As MouseEventArgs

value = instance.MouseEventThatStartedEdit

instance.MouseEventThatStartedEdit = value
C#
public MouseEventArgs MouseEventThatStartedEdit
Managed Extensions for C++
public: MouseEventArgs* MouseEventThatStartedEdit
C++/CLI
public:
MouseEventArgs^ MouseEventThatStartedEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReturnHeight Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : ReturnHeight Field

Glossary Item Box

Custom cells can have their own rules for deciding the cell height

Syntax

Visual Basic (Declaration)
Public ReturnHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Integer

value = instance.ReturnHeight

instance.ReturnHeight = value
C#
public int ReturnHeight
Managed Extensions for C++
public: int ReturnHeight
C++/CLI
public:
int ReturnHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartedEdit Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > CustomCellEventArgs Class : StartedEdit Field

Glossary Item Box

Set to true (default) in the CustomCellEditStartByMouse or OnCustomCellEditStartByKey if you choose to start edit. If edit is not started set to false.

Syntax

Visual Basic (Declaration)
Public StartedEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomCellEventArgs
Dim value As Boolean

value = instance.StartedEdit

instance.StartedEdit = value
C#
public bool StartedEdit
Managed Extensions for C++
public: bool StartedEdit
C++/CLI
public:
bool StartedEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CustomCellEventArgs Class
CustomCellEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaleMark Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaleMark Class

Glossary Item Box

DateScaleMark holds info about one current scale mark in the DateScaler

Object Model

DateScaleMark Class

Syntax

Visual Basic (Declaration)
Public Class DateScaleMark
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
C#
public class DateScaleMark
Managed Extensions for C++
public __gc class DateScaleMark
C++/CLI
public ref class DateScaleMark

Inheritance Hierarchy

System.Object
PlexityHide.GTP.DateScaleMark

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScaleMark Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
DateScaleMark Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : DateScaleMark Class

Glossary Item Box

The following tables list the members exposed by DateScaleMark.

Public Constructors

 | Name | Description
Public Constructor | DateScaleMark Constructor | Constructor used internally
Top

Public Fields

 | Name | Description
Public Field | Area | The area
Public Field | Date | The date time that consitutes the time intervall for this scale mark
Public Field | Format | This is how the date string will be formated
Public Field | LinePos | This is where the line will go
Public Field | LongIntervall | Long or short date intervall
Public Field | PixelFarBox | The pixel that denotes the end of the represented time intervall
Public Field | PixelMidMark | The pixel at the given datetime
Public Field | Resolution | The resoultion
Public Field | Text | The text on this scale mark
Top

See Also

Reference

DateScaleMark Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaleMark Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : DateScaleMark Constructor

aFormat
aText
aPixelMidMark
aPixelFarBox
aDate
aResolution
aArea
aLongIntervall

Glossary Item Box

Constructor used internally

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aFormat As TimeStrEnum, _
   ByVal aText As String, _
   ByVal aPixelMidMark As Integer, _
   ByVal aPixelFarBox As Integer, _
   ByVal aDate As Date, _
   ByVal aResolution As NonLinearTime.TimeResolution, _
   ByVal aArea As DateScaleMark.AreaEnum, _
   ByVal aLongIntervall As Boolean _
)
Visual Basic (Usage) Copy Code
Dim aFormat As TimeStrEnum
Dim aText As String
Dim aPixelMidMark As Integer
Dim aPixelFarBox As Integer
Dim aDate As Date
Dim aResolution As NonLinearTime.TimeResolution
Dim aArea As DateScaleMark.AreaEnum
Dim aLongIntervall As Boolean

Dim instance As New DateScaleMark(aFormat, aText, aPixelMidMark, aPixelFarBox, aDate, aResolution, aArea, aLongIntervall)
C#
public DateScaleMark(
   TimeStrEnum aFormat,
   string aText,
   int aPixelMidMark,
   int aPixelFarBox,
   DateTime aDate,
   NonLinearTime.TimeResolution aResolution,
   DateScaleMark.AreaEnum aArea,
   bool aLongIntervall
)
Managed Extensions for C++
public: DateScaleMark(
   TimeStrEnum aFormat,
   string* aText,
   int aPixelMidMark,
   int aPixelFarBox,
   DateTime aDate,
   NonLinearTime.TimeResolution aResolution,
   DateScaleMark.AreaEnum aArea,
   bool aLongIntervall
)
C++/CLI
public:
DateScaleMark(
   TimeStrEnum aFormat,
   String^ aText,
   int aPixelMidMark,
   int aPixelFarBox,
   DateTime aDate,
   NonLinearTime.TimeResolution aResolution,
   DateScaleMark.AreaEnum aArea,
   bool aLongIntervall
)

Parameters

aFormat
aText
aPixelMidMark
aPixelFarBox
aDate
aResolution
aArea
aLongIntervall

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
DateScaleMark Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaleMark Class

Glossary Item Box

For a list of all members of this type, see DateScaleMark members.

Public Fields

 | Name | Description
Public Field | Area | The area
Public Field | Date | The date time that consitutes the time intervall for this scale mark
Public Field | Format | This is how the date string will be formated
Public Field | LinePos | This is where the line will go
Public Field | LongIntervall | Long or short date intervall
Public Field | PixelFarBox | The pixel that denotes the end of the represented time intervall
Public Field | PixelMidMark | The pixel at the given datetime
Public Field | Resolution | The resoultion
Public Field | Text | The text on this scale mark
Top

See Also

Reference

DateScaleMark Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Area Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : Area Field

Glossary Item Box

The area

Syntax

Visual Basic (Declaration)
Public Area As DateScaleMark.AreaEnum
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As DateScaleMark.AreaEnum

value = instance.Area

instance.Area = value
C#
public DateScaleMark.AreaEnum Area
Managed Extensions for C++
public: DateScaleMark.AreaEnum Area
C++/CLI
public:
DateScaleMark.AreaEnum Area

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Date Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : Date Field

Glossary Item Box

The date time that consitutes the time intervall for this scale mark

Syntax

Visual Basic (Declaration)
Public Date As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As Date

value = instance.Date

instance.Date = value
C#
public DateTime Date
Managed Extensions for C++
public: DateTime Date
C++/CLI
public:
DateTime Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Format Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : Format Field

Glossary Item Box

This is how the date string will be formated

Syntax

Visual Basic (Declaration)
Public Format As TimeStrEnum
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As TimeStrEnum

value = instance.Format

instance.Format = value
C#
public TimeStrEnum Format
Managed Extensions for C++
public: TimeStrEnum Format
C++/CLI
public:
TimeStrEnum Format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinePos Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : LinePos Field

Glossary Item Box

This is where the line will go

Syntax

Visual Basic (Declaration)
Public LinePos As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As Integer

value = instance.LinePos

instance.LinePos = value
C#
public int LinePos
Managed Extensions for C++
public: int LinePos
C++/CLI
public:
int LinePos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LongIntervall Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : LongIntervall Field

Glossary Item Box

Long or short date intervall

Syntax

Visual Basic (Declaration)
Public LongIntervall As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As Boolean

value = instance.LongIntervall

instance.LongIntervall = value
C#
public bool LongIntervall
Managed Extensions for C++
public: bool LongIntervall
C++/CLI
public:
bool LongIntervall

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelFarBox Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : PixelFarBox Field

Glossary Item Box

The pixel that denotes the end of the represented time intervall

Syntax

Visual Basic (Declaration)
Public PixelFarBox As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As Integer

value = instance.PixelFarBox

instance.PixelFarBox = value
C#
public int PixelFarBox
Managed Extensions for C++
public: int PixelFarBox
C++/CLI
public:
int PixelFarBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelMidMark Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : PixelMidMark Field

Glossary Item Box

The pixel at the given datetime

Syntax

Visual Basic (Declaration)
Public PixelMidMark As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As Integer

value = instance.PixelMidMark

instance.PixelMidMark = value
C#
public int PixelMidMark
Managed Extensions for C++
public: int PixelMidMark
C++/CLI
public:
int PixelMidMark

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Resolution Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : Resolution Field

Glossary Item Box

The resoultion

Syntax

Visual Basic (Declaration)
Public Resolution As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As NonLinearTime.TimeResolution

value = instance.Resolution

instance.Resolution = value
C#
public NonLinearTime.TimeResolution Resolution
Managed Extensions for C++
public: NonLinearTime.TimeResolution Resolution
C++/CLI
public:
NonLinearTime.TimeResolution Resolution

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaleMark Class : Text Field

Glossary Item Box

The text on this scale mark

Syntax

Visual Basic (Declaration)
Public Text As String
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark
Dim value As String

value = instance.Text

instance.Text = value
C#
public string Text
Managed Extensions for C++
public: string* Text
C++/CLI
public:
String^ Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaleMark Class
DateScaleMark Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaler Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaler Class

Glossary Item Box

DateScaler holds logic for conversion between draw space and time space.

Object Model

DateScaler ClassPanButton ClassPanButton Class

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)>
<ToolboxBitmapAttribute()>
<TypeConverterAttribute("PlexityHide.GTP.DateScaler+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
Public Class DateScaler
   Inherits OffscreenDraw
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[TypeConverterAttribute("PlexityHide.GTP.DateScaler+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public class DateScaler : OffscreenDraw
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[TypeConverterAttribute("PlexityHide.GTP.DateScaler+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public __gc class DateScaler : public OffscreenDraw
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[TypeConverterAttribute("PlexityHide.GTP.DateScaler+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public ref class DateScaler : public OffscreenDraw

Example

C# Copy Code
// Culture settings
    private void comboBoxCulture_SelectedIndexChanged(object sender, System.EventArgs e)
    {
      if (comboBoxCulture.SelectedIndex>-1)
      {
        dateScaler1.CultureInfoDateTimeFormat=new CultureInfo( comboBoxCulture.Items[comboBoxCulture.SelectedIndex] as string, false ).DateTimeFormat;
      }
    }

    private void Form1_Load(object sender, System.EventArgs e)
    {
      comboBoxCulture.Items.Clear();
      foreach ( CultureInfo ci in CultureInfo.GetCultures( CultureTypes.SpecificCultures ) )
      {
         comboBoxCulture.Items.Add(ci.Name);
      }

    }
 // Resizing types
    private void comboBox1_SelectedIndexChanged(object sender, System.EventArgs e)
    {
      switch (comboBoxResize.SelectedIndex)
      {
        case 0: dateScaler1.ResizeType=ResizingType.CenterLocked;break;
        case 1: dateScaler1.ResizeType=ResizingType.StartLocked;break;
        case 2: dateScaler1.ResizeType=ResizingType.StopLocked;break;
        case 3: dateScaler1.ResizeType=ResizingType.StartAndStopLocked;break;
      }

    }

 // Text override
    private void dateScaler1_OnDateScalerDrawString(PlexityHide.GTP.DateScaler dateScaler, PlexityHide.GTP.DateScalerDrawStringEventArgs e)
    {
      if (checkBoxRedSun.Checked)
      {
        if (e.DateTime.DayOfWeek==DayOfWeek.Sunday )
        {
          if ((!e.LongIntervall && e.Resolution==NonLinearTime.TimeResolution.days) ||
              (e.LongIntervall && (e.Resolution==NonLinearTime.TimeResolution.hours6 || e.Resolution==NonLinearTime.TimeResolution.hours3 || e.Resolution==NonLinearTime.TimeResolution.hours)))
          {
            e.Brush=new SolidBrush(Color.Red);
            e.Font=new Font("Arial", 10,FontStyle.Bold);
            //e.pos.Y=e.pos.Y+3;
            e.ContinueDraw=true;
          }

        }
      }
    }

 // User draw in the scaler
    private void dateScaler1_OnDateScalerDrawBoxes(PlexityHide.GTP.DateScaler dateScaler, PlexityHide.GTP.DateScalerDrawBoxesEventArgs e)
    {
      if (checkBoxShortInt.Checked)
      {
        if (! e.DateScaleMark.LongIntervall)
        {
          e.G.DrawLine(new Pen(Color.RoyalBlue,3),e.DateScaleMark.PixelMidMark,dateScaler.Height-4,e.DateScaleMark.PixelMidMark,dateScaler.Height);

          e.ContinueDraw=false;

        }
      }
    }

 // Hide selected hours from view
     private bool timeHide=false;
    private void buttonToggleHideTime_Click(object sender, System.EventArgs e)
    {
      timeHide=!timeHide;
      if (timeHide)
        dateScaler1.HideHours(new int[]{11,12,13});
      else
        dateScaler1.ShowHours(new int[]{0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23});
    }

 // Programatically setting the viewed span
    private void dateTimePicker1_ValueChanged(object sender, System.EventArgs e)
    {
      dateScaler1.TimeSpanSet(dateTimePicker1.Value,dateTimePicker1.Value.AddDays(30));
    }

    private void buttonanimate_Click(object sender, System.EventArgs e)
    {
      dateScaler1.AnimateScaleTransition(new DateTime(2005,2,23),new DateTime(2005,3,5),40);
    }
Visual Basic Copy Code
' Culture settings
    Private Sub comboBoxCulture_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs)
      If comboBoxCulture.SelectedIndex>-1 Then
        dateScaler1.CultureInfoDateTimeFormat = New CultureInfo(CType(IIf(Typeof comboBoxCulture.Items(comboBoxCulture.SelectedIndex) Is String, comboBoxCulture.Items(comboBoxCulture.SelectedIndex), Nothing), String), False).DateTimeFormat
      End If
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs)
      comboBoxCulture.Items.Clear()
      For Each ci As CultureInfo In CultureInfo.GetCultures(CultureTypes.SpecificCultures)
         comboBoxCulture.Items.Add(ci.Name)
      Next ci

    End Sub
 ' Resizing types
    Private Sub comboBox1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs)
      Select Case comboBoxResize.SelectedIndex
        Case 0
            dateScaler1.ResizeType=ResizingType.CenterLocked
        Case 1
            dateScaler1.ResizeType=ResizingType.StartLocked
        Case 2
            dateScaler1.ResizeType=ResizingType.StopLocked
        Case 3
            dateScaler1.ResizeType=ResizingType.StartAndStopLocked
      End Select

    End Sub

 ' Text override
    Private Sub dateScaler1_OnDateScalerDrawString(ByVal dateScaler As PlexityHide.GTP.DateScaler, ByVal e As PlexityHide.GTP.DateScalerDrawStringEventArgs)
      If checkBoxRedSun.Checked Then
        If e.DateTime.DayOfWeek=DayOfWeek.Sunday Then
          If ((Not e.LongIntervall) AndAlso e.Resolution=NonLinearTime.TimeResolution.days) OrElse (e.LongIntervall AndAlso (e.Resolution=NonLinearTime.TimeResolution.hours6 OrElse e.Resolution=NonLinearTime.TimeResolution.hours3 OrElse e.Resolution=NonLinearTime.TimeResolution.hours)) Then
            e.Brush = New SolidBrush(Color.Red)
            e.Font = New Font("Arial", 10,FontStyle.Bold)
            'e.pos.Y=e.pos.Y+3;
            e.ContinueDraw=True
          End If

        End If
      End If
    End Sub

 ' User draw in the scaler
    Private Sub dateScaler1_OnDateScalerDrawBoxes(ByVal dateScaler As PlexityHide.GTP.DateScaler, ByVal e As PlexityHide.GTP.DateScalerDrawBoxesEventArgs)
      If checkBoxShortInt.Checked Then
        If (Not e.DateScaleMark.LongIntervall) Then
          e.G.DrawLine(New Pen(Color.RoyalBlue,3),e.DateScaleMark.PixelMidMark,dateScaler.Height-4,e.DateScaleMark.PixelMidMark,dateScaler.Height)

          e.ContinueDraw=False

        End If
      End If
    End Sub

 ' Hide selected hours from view
     Private timeHide As Boolean=False
    Private Sub buttonToggleHideTime_Click(ByVal sender As Object, ByVal e As System.EventArgs)
      timeHide=Not timeHide
      If timeHide Then
        dateScaler1.HideHours(New Integer(){11,12,13})
      Else
        dateScaler1.ShowHours(New Integer(){0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23})
      End If
    End Sub

 ' Programatically setting the viewed span
    Private Sub dateTimePicker1_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs)
      dateScaler1.TimeSpanSet(dateTimePicker1.Value,dateTimePicker1.Value.AddDays(30))
    End Sub

    Private Sub buttonanimate_Click(ByVal sender As Object, ByVal e As System.EventArgs)
      dateScaler1.AnimateScaleTransition(New DateTime(2005,2,23),New DateTime(2005,3,5),40)
    End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PlexityHide.GTP.OffscreenDraw
PlexityHide.GTP.DateScaler

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScaler Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
DateScaler Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : DateScaler Class

Glossary Item Box

The following tables list the members exposed by DateScaler.

Public Constructors

 | Name | Description
Public Constructor | DateScaler Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BackgroundImage | Overridden.
Public Property | BackgroundScaleFactor | This is the most recent used resolution of DateScaler background. If the fish eye function is enabled this is the resolution value on both sides of the fish eye. The resolution is defined as LengthOfScale/(stopTime-startTime));
Public Property | BackwardPan | Access to the Backward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler
Public Property | Boxes | Use boxes or not; default true
Public Property | BoxesOnDaysRulerOnTime | Use boxes On Days+ and Ruler On Time or not
Public Property | CultureInfoDateTimeFormat | Assign a new DateTimeFormatInfo for the culture that you are working with
Public Property | DrawBoxDivider | Default true, box dividers are the lines between,above and below the long and short date indications
Public Property | FiscalYearStartMonth | This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May
Public Property | FishEyeColor | Sets and gets the color of the fish eye area.
Public Property | FishEyeenabled | Sets and gets the state of the fish eye.
Public Property | FishEyeHigh | Get the end position of the fisheye section (readonly)
Public Property | FishEyeLow | Get the start position of the fisheye section (readonly)
Public Property | FishEyeMagnification |
Public Property | FishEyeScaleFactor | This is the most recent used resolution of DateScaler background in the fish eye area. Only valid if the fish eye function is enabled . The resolution is defined as LengthOfFishEyeArea/(stopTime-startTime));
Public Property | FlipView | Overridden. Flip scroller
Public Property | ForwardPan | Access to the Forward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler
Public Property | LowerBound | Sets and gets the lower bound in the non-linear time line.
Public Property | MarkerTextColor | Sets and gets the color of the marker text.
Public Property | MarkerTextFont | Gets and sets the font for the text markers.
Public Property | MinSpan | This property controls how small the span can be. Set it to 1 second and the user can zoom down to were one second fills the view.
Public Property | PixelsForModeSwitch | The scaler switches scaling mode when things get to thight. You can change this value if 30 pixels (default) is not perfect for your conditions
Public Property | PixelsForModeSwitch_NarrowDays | Same as PixelsForModeSwitch, but this value is active for day representation and extra narrow to get the S|M|T|W|T|F|S narrow look of msProject
Public Property | PixelsFromBottomLowerLine | The scaler uses two bands to visualize date time information. This value controls the placement of the lower line
Public Property | PixelsFromBottomUpperLine | The scaler uses two bands to visualize date time information. This value controls the placement of the upper line
Public Property | PixelsFromLineAboveToScalerText | This value controls the space between the line above and the text.
Public Property | PrefixQuarter | If the scale presents quarters this prefix will be used, default "Q"
Public Property | PrefixWeek | If the scale presents weeks this prefix will be used, default "W"
Public Property | ReScaleWithControl | If control key while dragging scaler == rescale, otherwise panorate
Public Property | ResizeType | Sets and gets the resizing behaviour.
Public Property | ScaleMarkerColor | Sets and gets the color of the scale markers.
Public Property | ScaleMarkersHigh | Returns an array with the positions of all markers in the upper scale.
Public Property | ScaleMarkersLow | Returns an array with the positions of all markers in the lower scale.
Public Property | ScrollButtonsVisible | Allows you to hide the scaler scroll buttons
Public Property | ShowWeekNumbers | Week numbers or date span for week denomination.
Public Property | SpanTextColor | Sets and gets the color of the span text.
Public Property | SpanTextFont | Gets and sets the font for the span text.
Public Property | StartOfWeek | Sets and gets the day starting the week
Public Property | StartTime | Gets the start time of the scaler.
Public Property | StopTime | Gets the stop time of the scaler.
Public Property | TextCentredInIntervallLessThanDay | When displaying hours in the datescaler upperband you have a choice to display the hour text above the 00 minutes mark and thus giving box-lines at 30 minutes to and 30 minutes after the hour. OR you can display the hour text centred in the hour that gives an hour text just above 30 minutes past the hour, and hence the box-lines at 00 minutes. This choice exists for all the displayed resolutions less than a day. Since we have clients arguing for both approaches being correct we have implemented this option.
Public Property | UpperBound | Sets and gets the upper bound in the non-linear time line.
Public Property | UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Public Property | UseScheduleTimeLayoutForSmallIntervals | When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display
Public Property | UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm | When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour
Public Property | UseScheduleTimeLayoutForSmallIntveralls | Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals
Public Property | UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm | Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm
Public Property | VisibleDays | Returns all days visible
Public Property | VisibleHours | Returns all hours visible
Public Property | ZoomIntoResolution | Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is NonLinearTime.TimeResolution.secondsBy10000 Note that this will only stop the DateScaler from presenting lower resolutions The shown span will get smaller but the resolution will not adapt below you setting, so the long lines will/can get really far apart. To actually stop the DateScaler from getting to small intervalls to display set MinSpan
Top

Public Methods

 | Name | Description
Public Method | AnimateScaleTransition | Function to zoom and pan in animation to a new goal date span
Public Method | DateScalerPaint | Performs the drawing
Public Method | Exists | Checks whether a specified time exists in the time line.
Public Method | FishEyeMove | Move of fish eye by input parameter
Public Method | FishEyeResize | Resize of fish eye by input parameter
Public Method | HideDays | Hide the stated days during all weeks in the time line
Public Method | HideHours | Hide the stated hours during all days in the time line
Public Method | Pan | Panorate the time scale a certain number of pixels left or right.
Public Method | PixelToTime | Given a pixel you will get a DateTime
Public Method | PixelToTime_double | Same as PixelToTime but with higher precision
Public Method | PrintEnd | Overridden. Stop print
Public Method | PrintPage | Overridden. Start print
Public Method | ShowDays | Show the stated days during all weeks in the time line
Public Method | ShowHours | Show the stated hours during all days in the time line
Public Method | SnapTime | Given a time and precision the method will return a time snpped to the closest precision value
Public Method | TimeSpanSet | Sets start and stop time of the scaler.
Public Method | TimeToPixel | Given a DateTime you will get a Pixel
Public Method | TimeToPixel_double | Like TimeToPixel but with higher precision
Public Method | Zoom | Overloaded. Zoom the time scale to this start and stop
Top

Public Events

 | Name | Description
Public Event | OnBeforeScaleOrSpanChange | Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code
Public Event | OnDateScalerDrawBoxes | Event that allows you to override the boxes drawn in the scaler
Public Event | OnDateScalerDrawString | Lets you override scaler textual output
Public Event | OnScaleChangeEvent | Fires whenever the Datescale is redrawn
Public Event | OnViewDateInformation | This event allows you to override the Date information that is placed on the left side of the screen by default
Top

See Also

Reference

DateScaler Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaler Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : DateScaler Constructor

Glossary Item Box

Overload List

Overload | Description
DateScaler Constructor(IContainer) |
DateScaler Constructor() |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaler Constructor(IContainer)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class > DateScaler Constructor : DateScaler Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New DateScaler(container)
C#
public DateScaler(
   IContainer container
)
Managed Extensions for C++
public: DateScaler(
   IContainer* container
)
C++/CLI
public:
DateScaler(
   IContainer^ container
)

Parameters

container

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaler Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class > DateScaler Constructor : DateScaler Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DateScaler()
C#
public DateScaler()
Managed Extensions for C++
public: DateScaler();
C++/CLI
public:
DateScaler();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
DateScaler Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaler Class

Glossary Item Box

For a list of all members of this type, see DateScaler members.

Public Methods

 | Name | Description
Public Method | AnimateScaleTransition | Function to zoom and pan in animation to a new goal date span
Public Method | DateScalerPaint | Performs the drawing
Public Method | Exists | Checks whether a specified time exists in the time line.
Public Method | FishEyeMove | Move of fish eye by input parameter
Public Method | FishEyeResize | Resize of fish eye by input parameter
Public Method | HideDays | Hide the stated days during all weeks in the time line
Public Method | HideHours | Hide the stated hours during all days in the time line
Public Method | Pan | Panorate the time scale a certain number of pixels left or right.
Public Method | PixelToTime | Given a pixel you will get a DateTime
Public Method | PixelToTime_double | Same as PixelToTime but with higher precision
Public Method | PrintEnd | Overridden. Stop print
Public Method | PrintPage | Overridden. Start print
Public Method | ShowDays | Show the stated days during all weeks in the time line
Public Method | ShowHours | Show the stated hours during all days in the time line
Public Method | SnapTime | Given a time and precision the method will return a time snpped to the closest precision value
Public Method | TimeSpanSet | Sets start and stop time of the scaler.
Public Method | TimeToPixel | Given a DateTime you will get a Pixel
Public Method | TimeToPixel_double | Like TimeToPixel but with higher precision
Public Method | Zoom | Overloaded. Zoom the time scale to this start and stop
Top

See Also

Reference

DateScaler Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AnimateScaleTransition Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : AnimateScaleTransition Method

newStart
newStop
animationSteps

Glossary Item Box

Function to zoom and pan in animation to a new goal date span

Syntax

Visual Basic (Declaration)
Public Sub AnimateScaleTransition( _
   ByVal newStart As Date, _
   ByVal newStop As Date, _
   ByVal animationSteps As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim newStart As Date
Dim newStop As Date
Dim animationSteps As Integer

instance.AnimateScaleTransition(newStart, newStop, animationSteps)
C#
public void AnimateScaleTransition(
   DateTime newStart,
   DateTime newStop,
   int animationSteps
)
Managed Extensions for C++
public: void AnimateScaleTransition(
   DateTime newStart,
   DateTime newStop,
   int animationSteps
)
C++/CLI
public:
void AnimateScaleTransition(
   DateTime newStart,
   DateTime newStop,
   int animationSteps
)

Parameters

newStart
newStop
animationSteps

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerPaint Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : DateScalerPaint Method

g

Glossary Item Box

Performs the drawing

Syntax

Visual Basic (Declaration)
Public Sub DateScalerPaint( _
   ByVal g As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim g As Graphics

instance.DateScalerPaint(g)
C#
public void DateScalerPaint(
   Graphics g
)
Managed Extensions for C++
public: void DateScalerPaint(
   Graphics* g
)
C++/CLI
public:
void DateScalerPaint(
   Graphics^ g
)

Parameters

g

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Exists Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : Exists Method

time

Glossary Item Box

Checks whether a specified time exists in the time line.

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal time As Date _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim time As Date
Dim value As Boolean

value = instance.Exists(time)
C#
public bool Exists(
   DateTime time
)
Managed Extensions for C++
public: bool Exists(
   DateTime time
)
C++/CLI
public:
bool Exists(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeMove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeMove Method

fishEyeDistance

Glossary Item Box

Move of fish eye by input parameter

Syntax

Visual Basic (Declaration)
Public Sub FishEyeMove( _
   ByVal fishEyeDistance As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim fishEyeDistance As Integer

instance.FishEyeMove(fishEyeDistance)
C#
public void FishEyeMove(
   int fishEyeDistance
)
Managed Extensions for C++
public: void FishEyeMove(
   int fishEyeDistance
)
C++/CLI
public:
void FishEyeMove(
   int fishEyeDistance
)

Parameters

fishEyeDistance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeResize Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeResize Method

fishEyeChange

Glossary Item Box

Resize of fish eye by input parameter

Syntax

Visual Basic (Declaration)
Public Sub FishEyeResize( _
   ByVal fishEyeChange As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim fishEyeChange As Integer

instance.FishEyeResize(fishEyeChange)
C#
public void FishEyeResize(
   int fishEyeChange
)
Managed Extensions for C++
public: void FishEyeResize(
   int fishEyeChange
)
C++/CLI
public:
void FishEyeResize(
   int fishEyeChange
)

Parameters

fishEyeChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HideDays Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : HideDays Method

daysToHide

Glossary Item Box

Hide the stated days during all weeks in the time line

Syntax

Visual Basic (Declaration)
Public Sub HideDays( _
   ByVal daysToHide() As DayOfWeek _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim daysToHide() As DayOfWeek

instance.HideDays(daysToHide)
C#
public void HideDays(
   DayOfWeek[] daysToHide
)
Managed Extensions for C++
public: void HideDays(
   DayOfWeek[]* daysToHide
)
C++/CLI
public:
void HideDays(
   array<DayOfWeek>^ daysToHide
)

Parameters

daysToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HideHours Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : HideHours Method

hoursToHide

Glossary Item Box

Hide the stated hours during all days in the time line

Syntax

Visual Basic (Declaration)
Public Sub HideHours( _
   ByVal hoursToHide() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim hoursToHide() As Integer

instance.HideHours(hoursToHide)
C#
public void HideHours(
   int[] hoursToHide
)
Managed Extensions for C++
public: void HideHours(
   int[]* hoursToHide
)
C++/CLI
public:
void HideHours(
   array<int>^ hoursToHide
)

Parameters

hoursToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Pan Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : Pan Method

distance

Glossary Item Box

Panorate the time scale a certain number of pixels left or right.

Syntax

Visual Basic (Declaration)
Public Sub Pan( _
   ByVal distance As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim distance As Integer

instance.Pan(distance)
C#
public void Pan(
   int distance
)
Managed Extensions for C++
public: void Pan(
   int distance
)
C++/CLI
public:
void Pan(
   int distance
)

Parameters

distance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelToTime Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelToTime Method

pixel

Glossary Item Box

Given a pixel you will get a DateTime

Syntax

Visual Basic (Declaration)
Public Function PixelToTime( _
   ByVal pixel As Integer _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim pixel As Integer
Dim value As Date

value = instance.PixelToTime(pixel)
C#
public DateTime PixelToTime(
   int pixel
)
Managed Extensions for C++
public: DateTime PixelToTime(
   int pixel
)
C++/CLI
public:
DateTime PixelToTime(
   int pixel
)

Parameters

pixel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelToTime_double Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelToTime_double Method

pixel

Glossary Item Box

Same as PixelToTime but with higher precision

Syntax

Visual Basic (Declaration)
Public Function PixelToTime_double( _
   ByVal pixel As Double _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim pixel As Double
Dim value As Date

value = instance.PixelToTime_double(pixel)
C#
public DateTime PixelToTime_double(
   double pixel
)
Managed Extensions for C++
public: DateTime PixelToTime_double(
   double pixel
)
C++/CLI
public:
DateTime PixelToTime_double(
   double pixel
)

Parameters

pixel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintEnd Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PrintEnd Method

Glossary Item Box

Stop print

Syntax

Visual Basic (Declaration)
Public Overrides Sub PrintEnd()
Visual Basic (Usage) Copy Code
Dim instance As DateScaler

instance.PrintEnd()
C#
public override void PrintEnd()
Managed Extensions for C++
public: void PrintEnd(); override
C++/CLI
public:
void PrintEnd(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PrintPage Method

G
Margins

Glossary Item Box

Start print

Syntax

Visual Basic (Declaration)
Public Overrides Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim G As Graphics
Dim Margins As Rectangle

instance.PrintPage(G, Margins)
C#
public override void PrintPage(
   Graphics G,
   Rectangle Margins
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins
) override
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins
) override

Parameters

G
Margins

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowDays Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ShowDays Method

daysToShow

Glossary Item Box

Show the stated days during all weeks in the time line

Syntax

Visual Basic (Declaration)
Public Sub ShowDays( _
   ByVal daysToShow() As DayOfWeek _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim daysToShow() As DayOfWeek

instance.ShowDays(daysToShow)
C#
public void ShowDays(
   DayOfWeek[] daysToShow
)
Managed Extensions for C++
public: void ShowDays(
   DayOfWeek[]* daysToShow
)
C++/CLI
public:
void ShowDays(
   array<DayOfWeek>^ daysToShow
)

Parameters

daysToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowHours Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ShowHours Method

hoursToShow

Glossary Item Box

Show the stated hours during all days in the time line

Syntax

Visual Basic (Declaration)
Public Sub ShowHours( _
   ByVal hoursToShow() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim hoursToShow() As Integer

instance.ShowHours(hoursToShow)
C#
public void ShowHours(
   int[] hoursToShow
)
Managed Extensions for C++
public: void ShowHours(
   int[]* hoursToShow
)
C++/CLI
public:
void ShowHours(
   array<int>^ hoursToShow
)

Parameters

hoursToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SnapTime Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : SnapTime Method

time
precision

Glossary Item Box

Given a time and precision the method will return a time snpped to the closest precision value

Syntax

Visual Basic (Declaration)
Public Function SnapTime( _
   ByVal time As Date, _
   ByVal precision As TimeSpan _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim time As Date
Dim precision As TimeSpan
Dim value As Date

value = instance.SnapTime(time, precision)
C#
public DateTime SnapTime(
   DateTime time,
   TimeSpan precision
)
Managed Extensions for C++
public: DateTime SnapTime(
   DateTime time,
   TimeSpan precision
)
C++/CLI
public:
DateTime SnapTime(
   DateTime time,
   TimeSpan precision
)

Parameters

time
precision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeSpanSet Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : TimeSpanSet Method

startTime
stopTime

Glossary Item Box

Sets start and stop time of the scaler.

Syntax

Visual Basic (Declaration)
Public Sub TimeSpanSet( _
   ByVal startTime As Date, _
   ByVal stopTime As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim startTime As Date
Dim stopTime As Date

instance.TimeSpanSet(startTime, stopTime)
C#
public void TimeSpanSet(
   DateTime startTime,
   DateTime stopTime
)
Managed Extensions for C++
public: void TimeSpanSet(
   DateTime startTime,
   DateTime stopTime
)
C++/CLI
public:
void TimeSpanSet(
   DateTime startTime,
   DateTime stopTime
)

Parameters

startTime
stopTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeToPixel Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : TimeToPixel Method

time

Glossary Item Box

Given a DateTime you will get a Pixel

Syntax

Visual Basic (Declaration)
Public Function TimeToPixel( _
   ByVal time As Date _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim time As Date
Dim value As Integer

value = instance.TimeToPixel(time)
C#
public int TimeToPixel(
   DateTime time
)
Managed Extensions for C++
public: int TimeToPixel(
   DateTime time
)
C++/CLI
public:
int TimeToPixel(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeToPixel_double Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : TimeToPixel_double Method

time

Glossary Item Box

Like TimeToPixel but with higher precision

Syntax

Visual Basic (Declaration)
Public Function TimeToPixel_double( _
   ByVal time As Date _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim time As Date
Dim value As Double

value = instance.TimeToPixel_double(time)
C#
public double TimeToPixel_double(
   DateTime time
)
Managed Extensions for C++
public: double TimeToPixel_double(
   DateTime time
)
C++/CLI
public:
double TimeToPixel_double(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Zoom Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : Zoom Method

Glossary Item Box

Zoom the time scale to this start and stop

Overload List

Overload | Description
Zoom(DateTime,DateTime) | Zoom the time scale to this start and stop
Zoom(Int32) | Zoom the time scale a certain level, positive zoom out, negative zoom in.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Zoom(DateTime,DateTime) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class > Zoom Method : Zoom(DateTime,DateTime) Method

start
stop

Glossary Item Box

Zoom the time scale to this start and stop

Syntax

Visual Basic (Declaration)
Public Overloads Sub Zoom( _
   ByVal start As Date, _
   ByVal stop As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim start As Date
Dim stop As Date

instance.Zoom(start, stop)
C#
public void Zoom(
   DateTime start,
   DateTime stop
)
Managed Extensions for C++
public: void Zoom(
   DateTime start,
   DateTime stop
)
C++/CLI
public:
void Zoom(
   DateTime start,
   DateTime stop
)

Parameters

start
stop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Zoom(Int32) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class > Zoom Method : Zoom(Int32) Method

level

Glossary Item Box

Zoom the time scale a certain level, positive zoom out, negative zoom in.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Zoom( _
   ByVal level As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim level As Integer

instance.Zoom(level)
C#
public void Zoom(
   int level
)
Managed Extensions for C++
public: void Zoom(
   int level
)
C++/CLI
public:
void Zoom(
   int level
)

Parameters

level

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
DateScaler Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaler Class

Glossary Item Box

For a list of all members of this type, see DateScaler members.

Public Properties

 | Name | Description
Public Property | BackgroundImage | Overridden.
Public Property | BackgroundScaleFactor | This is the most recent used resolution of DateScaler background. If the fish eye function is enabled this is the resolution value on both sides of the fish eye. The resolution is defined as LengthOfScale/(stopTime-startTime));
Public Property | BackwardPan | Access to the Backward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler
Public Property | Boxes | Use boxes or not; default true
Public Property | BoxesOnDaysRulerOnTime | Use boxes On Days+ and Ruler On Time or not
Public Property | CultureInfoDateTimeFormat | Assign a new DateTimeFormatInfo for the culture that you are working with
Public Property | DrawBoxDivider | Default true, box dividers are the lines between,above and below the long and short date indications
Public Property | FiscalYearStartMonth | This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May
Public Property | FishEyeColor | Sets and gets the color of the fish eye area.
Public Property | FishEyeenabled | Sets and gets the state of the fish eye.
Public Property | FishEyeHigh | Get the end position of the fisheye section (readonly)
Public Property | FishEyeLow | Get the start position of the fisheye section (readonly)
Public Property | FishEyeMagnification |
Public Property | FishEyeScaleFactor | This is the most recent used resolution of DateScaler background in the fish eye area. Only valid if the fish eye function is enabled . The resolution is defined as LengthOfFishEyeArea/(stopTime-startTime));
Public Property | FlipView | Overridden. Flip scroller
Public Property | ForwardPan | Access to the Forward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler
Public Property | LowerBound | Sets and gets the lower bound in the non-linear time line.
Public Property | MarkerTextColor | Sets and gets the color of the marker text.
Public Property | MarkerTextFont | Gets and sets the font for the text markers.
Public Property | MinSpan | This property controls how small the span can be. Set it to 1 second and the user can zoom down to were one second fills the view.
Public Property | PixelsForModeSwitch | The scaler switches scaling mode when things get to thight. You can change this value if 30 pixels (default) is not perfect for your conditions
Public Property | PixelsForModeSwitch_NarrowDays | Same as PixelsForModeSwitch, but this value is active for day representation and extra narrow to get the S|M|T|W|T|F|S narrow look of msProject
Public Property | PixelsFromBottomLowerLine | The scaler uses two bands to visualize date time information. This value controls the placement of the lower line
Public Property | PixelsFromBottomUpperLine | The scaler uses two bands to visualize date time information. This value controls the placement of the upper line
Public Property | PixelsFromLineAboveToScalerText | This value controls the space between the line above and the text.
Public Property | PrefixQuarter | If the scale presents quarters this prefix will be used, default "Q"
Public Property | PrefixWeek | If the scale presents weeks this prefix will be used, default "W"
Public Property | ReScaleWithControl | If control key while dragging scaler == rescale, otherwise panorate
Public Property | ResizeType | Sets and gets the resizing behaviour.
Public Property | ScaleMarkerColor | Sets and gets the color of the scale markers.
Public Property | ScaleMarkersHigh | Returns an array with the positions of all markers in the upper scale.
Public Property | ScaleMarkersLow | Returns an array with the positions of all markers in the lower scale.
Public Property | ScrollButtonsVisible | Allows you to hide the scaler scroll buttons
Public Property | ShowWeekNumbers | Week numbers or date span for week denomination.
Public Property | SpanTextColor | Sets and gets the color of the span text.
Public Property | SpanTextFont | Gets and sets the font for the span text.
Public Property | StartOfWeek | Sets and gets the day starting the week
Public Property | StartTime | Gets the start time of the scaler.
Public Property | StopTime | Gets the stop time of the scaler.
Public Property | TextCentredInIntervallLessThanDay | When displaying hours in the datescaler upperband you have a choice to display the hour text above the 00 minutes mark and thus giving box-lines at 30 minutes to and 30 minutes after the hour. OR you can display the hour text centred in the hour that gives an hour text just above 30 minutes past the hour, and hence the box-lines at 00 minutes. This choice exists for all the displayed resolutions less than a day. Since we have clients arguing for both approaches being correct we have implemented this option.
Public Property | UpperBound | Sets and gets the upper bound in the non-linear time line.
Public Property | UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Public Property | UseScheduleTimeLayoutForSmallIntervals | When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display
Public Property | UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm | When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour
Public Property | UseScheduleTimeLayoutForSmallIntveralls | Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals
Public Property | UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm | Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm
Public Property | VisibleDays | Returns all days visible
Public Property | VisibleHours | Returns all hours visible
Public Property | ZoomIntoResolution | Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is NonLinearTime.TimeResolution.secondsBy10000 Note that this will only stop the DateScaler from presenting lower resolutions The shown span will get smaller but the resolution will not adapt below you setting, so the long lines will/can get really far apart. To actually stop the DateScaler from getting to small intervalls to display set MinSpan
Top

See Also

Reference

DateScaler Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundImage Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override Image BackgroundImage {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Image* get_BackgroundImage() override;
public: __property void set_BackgroundImage(
   Image* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Image^ BackgroundImage {
   Image^ get() override;
   void set (    Image^ value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundScaleFactor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : BackgroundScaleFactor Property

Glossary Item Box

This is the most recent used resolution of DateScaler background. If the fish eye function is enabled this is the resolution value on both sides of the fish eye. The resolution is defined as LengthOfScale/(stopTime-startTime));

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackgroundScaleFactor As Double
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Double

value = instance.BackgroundScaleFactor
C#
public double BackgroundScaleFactor {get;}
Managed Extensions for C++
public: __property double get_BackgroundScaleFactor();
C++/CLI
public:
property double BackgroundScaleFactor {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackwardPan Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : BackwardPan Property

Glossary Item Box

Access to the Backward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackwardPan As PanButton
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As PanButton

value = instance.BackwardPan
C#
public PanButton BackwardPan {get;}
Managed Extensions for C++
public: __property PanButton* get_BackwardPan();
C++/CLI
public:
property PanButton^ BackwardPan {
   PanButton^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Boxes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : Boxes Property

Glossary Item Box

Use boxes or not; default true

Syntax

Visual Basic (Declaration)
Public Property Boxes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.Boxes = value

value = instance.Boxes
C#
public bool Boxes {get; set;}
Managed Extensions for C++
public: __property bool get_Boxes();
public: __property void set_Boxes(
   bool value
);
C++/CLI
public:
property bool Boxes {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BoxesOnDaysRulerOnTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : BoxesOnDaysRulerOnTime Property

Glossary Item Box

Use boxes On Days+ and Ruler On Time or not

Syntax

Visual Basic (Declaration)
Public Property BoxesOnDaysRulerOnTime As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.BoxesOnDaysRulerOnTime = value

value = instance.BoxesOnDaysRulerOnTime
C#
public bool BoxesOnDaysRulerOnTime {get; set;}
Managed Extensions for C++
public: __property bool get_BoxesOnDaysRulerOnTime();
public: __property void set_BoxesOnDaysRulerOnTime(
   bool value
);
C++/CLI
public:
property bool BoxesOnDaysRulerOnTime {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CultureInfoDateTimeFormat Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : CultureInfoDateTimeFormat Property

Glossary Item Box

Assign a new DateTimeFormatInfo for the culture that you are working with

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property CultureInfoDateTimeFormat As DateTimeFormatInfo
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As DateTimeFormatInfo

instance.CultureInfoDateTimeFormat = value

value = instance.CultureInfoDateTimeFormat
C#
[BrowsableAttribute(false)]
public DateTimeFormatInfo CultureInfoDateTimeFormat {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DateTimeFormatInfo* get_CultureInfoDateTimeFormat();
public: __property void set_CultureInfoDateTimeFormat(
   DateTimeFormatInfo* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property DateTimeFormatInfo^ CultureInfoDateTimeFormat {
   DateTimeFormatInfo^ get();
   void set (    DateTimeFormatInfo^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawBoxDivider Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : DrawBoxDivider Property

Glossary Item Box

Default true, box dividers are the lines between,above and below the long and short date indications

Syntax

Visual Basic (Declaration)
Public Property DrawBoxDivider As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.DrawBoxDivider = value

value = instance.DrawBoxDivider
C#
public bool DrawBoxDivider {get; set;}
Managed Extensions for C++
public: __property bool get_DrawBoxDivider();
public: __property void set_DrawBoxDivider(
   bool value
);
C++/CLI
public:
property bool DrawBoxDivider {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FiscalYearStartMonth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FiscalYearStartMonth Property

Glossary Item Box

This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May

Syntax

Visual Basic (Declaration)
Public Property FiscalYearStartMonth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.FiscalYearStartMonth = value

value = instance.FiscalYearStartMonth
C#
public int FiscalYearStartMonth {get; set;}
Managed Extensions for C++
public: __property int get_FiscalYearStartMonth();
public: __property void set_FiscalYearStartMonth(
   int value
);
C++/CLI
public:
property int FiscalYearStartMonth {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeColor Property

Glossary Item Box

Sets and gets the color of the fish eye area.

Syntax

Visual Basic (Declaration)
Public Property FishEyeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Color

instance.FishEyeColor = value

value = instance.FishEyeColor
C#
public Color FishEyeColor {get; set;}
Managed Extensions for C++
public: __property Color get_FishEyeColor();
public: __property void set_FishEyeColor(
   Color value
);
C++/CLI
public:
property Color FishEyeColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeenabled Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeenabled Property

Glossary Item Box

Sets and gets the state of the fish eye.

Syntax

Visual Basic (Declaration)
Public Property FishEyeenabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.FishEyeenabled = value

value = instance.FishEyeenabled
C#
public bool FishEyeenabled {get; set;}
Managed Extensions for C++
public: __property bool get_FishEyeenabled();
public: __property void set_FishEyeenabled(
   bool value
);
C++/CLI
public:
property bool FishEyeenabled {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeHigh Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeHigh Property

Glossary Item Box

Get the end position of the fisheye section (readonly)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FishEyeHigh As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

value = instance.FishEyeHigh
C#
public int FishEyeHigh {get;}
Managed Extensions for C++
public: __property int get_FishEyeHigh();
C++/CLI
public:
property int FishEyeHigh {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeLow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeLow Property

Glossary Item Box

Get the start position of the fisheye section (readonly)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FishEyeLow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

value = instance.FishEyeLow
C#
public int FishEyeLow {get;}
Managed Extensions for C++
public: __property int get_FishEyeLow();
C++/CLI
public:
property int FishEyeLow {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeMagnification Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeMagnification Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FishEyeMagnification As FishEyeMagnification
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As FishEyeMagnification

instance.FishEyeMagnification = value

value = instance.FishEyeMagnification
C#
public FishEyeMagnification FishEyeMagnification {get; set;}
Managed Extensions for C++
public: __property FishEyeMagnification get_FishEyeMagnification();
public: __property void set_FishEyeMagnification(
   FishEyeMagnification value
);
C++/CLI
public:
property FishEyeMagnification FishEyeMagnification {
   FishEyeMagnification get();
   void set (    FishEyeMagnification value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeScaleFactor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FishEyeScaleFactor Property

Glossary Item Box

This is the most recent used resolution of DateScaler background in the fish eye area. Only valid if the fish eye function is enabled . The resolution is defined as LengthOfFishEyeArea/(stopTime-startTime));

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FishEyeScaleFactor As Double
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Double

value = instance.FishEyeScaleFactor
C#
public double FishEyeScaleFactor {get;}
Managed Extensions for C++
public: __property double get_FishEyeScaleFactor();
C++/CLI
public:
property double FishEyeScaleFactor {
   double get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FlipView Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : FlipView Property

Glossary Item Box

Flip scroller

Syntax

Visual Basic (Declaration)
Public Overrides Property FlipView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.FlipView = value

value = instance.FlipView
C#
public override bool FlipView {get; set;}
Managed Extensions for C++
public: __property bool get_FlipView() override;
public: __property void set_FlipView(
   bool value
) override;
C++/CLI
public:
property bool FlipView {
   bool get() override;
   void set (    bool value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ForwardPan Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ForwardPan Property

Glossary Item Box

Access to the Forward button on the datescaler. If you need to catch Mouse up on the pan button: Gantt.DateScaler.ForwardPan.OnMouseUp+=YoureventHandler

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForwardPan As PanButton
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As PanButton

value = instance.ForwardPan
C#
public PanButton ForwardPan {get;}
Managed Extensions for C++
public: __property PanButton* get_ForwardPan();
C++/CLI
public:
property PanButton^ ForwardPan {
   PanButton^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LowerBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : LowerBound Property

Glossary Item Box

Sets and gets the lower bound in the non-linear time line.

Syntax

Visual Basic (Declaration)
Public Property LowerBound As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Date

instance.LowerBound = value

value = instance.LowerBound
C#
public DateTime LowerBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_LowerBound();
public: __property void set_LowerBound(
   DateTime value
);
C++/CLI
public:
property DateTime LowerBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MarkerTextColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : MarkerTextColor Property

Glossary Item Box

Sets and gets the color of the marker text.

Syntax

Visual Basic (Declaration)
Public Property MarkerTextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Color

instance.MarkerTextColor = value

value = instance.MarkerTextColor
C#
public Color MarkerTextColor {get; set;}
Managed Extensions for C++
public: __property Color get_MarkerTextColor();
public: __property void set_MarkerTextColor(
   Color value
);
C++/CLI
public:
property Color MarkerTextColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MarkerTextFont Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : MarkerTextFont Property

Glossary Item Box

Gets and sets the font for the text markers.

Syntax

Visual Basic (Declaration)
Public Property MarkerTextFont As Font
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Font

instance.MarkerTextFont = value

value = instance.MarkerTextFont
C#
public Font MarkerTextFont {get; set;}
Managed Extensions for C++
public: __property Font* get_MarkerTextFont();
public: __property void set_MarkerTextFont(
   Font* value
);
C++/CLI
public:
property Font^ MarkerTextFont {
   Font^ get();
   void set (    Font^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MinSpan Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : MinSpan Property

Glossary Item Box

This property controls how small the span can be. Set it to 1 second and the user can zoom down to were one second fills the view.

Syntax

Visual Basic (Declaration)
Public Property MinSpan As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As TimeSpan

instance.MinSpan = value

value = instance.MinSpan
C#
public TimeSpan MinSpan {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_MinSpan();
public: __property void set_MinSpan(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan MinSpan {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelsForModeSwitch Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelsForModeSwitch Property

Glossary Item Box

The scaler switches scaling mode when things get to thight. You can change this value if 30 pixels (default) is not perfect for your conditions

Syntax

Visual Basic (Declaration)
Public Property PixelsForModeSwitch As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.PixelsForModeSwitch = value

value = instance.PixelsForModeSwitch
C#
public int PixelsForModeSwitch {get; set;}
Managed Extensions for C++
public: __property int get_PixelsForModeSwitch();
public: __property void set_PixelsForModeSwitch(
   int value
);
C++/CLI
public:
property int PixelsForModeSwitch {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelsForModeSwitch_NarrowDays Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelsForModeSwitch_NarrowDays Property

Glossary Item Box

Same as PixelsForModeSwitch, but this value is active for day representation and extra narrow to get the S|M|T|W|T|F|S narrow look of msProject

Syntax

Visual Basic (Declaration)
Public Property PixelsForModeSwitch_NarrowDays As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.PixelsForModeSwitch_NarrowDays = value

value = instance.PixelsForModeSwitch_NarrowDays
C#
public int PixelsForModeSwitch_NarrowDays {get; set;}
Managed Extensions for C++
public: __property int get_PixelsForModeSwitch_NarrowDays();
public: __property void set_PixelsForModeSwitch_NarrowDays(
   int value
);
C++/CLI
public:
property int PixelsForModeSwitch_NarrowDays {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelsFromBottomLowerLine Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelsFromBottomLowerLine Property

Glossary Item Box

The scaler uses two bands to visualize date time information. This value controls the placement of the lower line

Syntax

Visual Basic (Declaration)
Public Property PixelsFromBottomLowerLine As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.PixelsFromBottomLowerLine = value

value = instance.PixelsFromBottomLowerLine
C#
public int PixelsFromBottomLowerLine {get; set;}
Managed Extensions for C++
public: __property int get_PixelsFromBottomLowerLine();
public: __property void set_PixelsFromBottomLowerLine(
   int value
);
C++/CLI
public:
property int PixelsFromBottomLowerLine {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelsFromBottomUpperLine Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelsFromBottomUpperLine Property

Glossary Item Box

The scaler uses two bands to visualize date time information. This value controls the placement of the upper line

Syntax

Visual Basic (Declaration)
Public Property PixelsFromBottomUpperLine As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.PixelsFromBottomUpperLine = value

value = instance.PixelsFromBottomUpperLine
C#
public int PixelsFromBottomUpperLine {get; set;}
Managed Extensions for C++
public: __property int get_PixelsFromBottomUpperLine();
public: __property void set_PixelsFromBottomUpperLine(
   int value
);
C++/CLI
public:
property int PixelsFromBottomUpperLine {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PixelsFromLineAboveToScalerText Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PixelsFromLineAboveToScalerText Property

Glossary Item Box

This value controls the space between the line above and the text.

Syntax

Visual Basic (Declaration)
Public Property PixelsFromLineAboveToScalerText As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Integer

instance.PixelsFromLineAboveToScalerText = value

value = instance.PixelsFromLineAboveToScalerText
C#
public int PixelsFromLineAboveToScalerText {get; set;}
Managed Extensions for C++
public: __property int get_PixelsFromLineAboveToScalerText();
public: __property void set_PixelsFromLineAboveToScalerText(
   int value
);
C++/CLI
public:
property int PixelsFromLineAboveToScalerText {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrefixQuarter Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PrefixQuarter Property

Glossary Item Box

If the scale presents quarters this prefix will be used, default "Q"

Syntax

Visual Basic (Declaration)
Public Property PrefixQuarter As String
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As String

instance.PrefixQuarter = value

value = instance.PrefixQuarter
C#
public string PrefixQuarter {get; set;}
Managed Extensions for C++
public: __property string* get_PrefixQuarter();
public: __property void set_PrefixQuarter(
   string* value
);
C++/CLI
public:
property String^ PrefixQuarter {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrefixWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : PrefixWeek Property

Glossary Item Box

If the scale presents weeks this prefix will be used, default "W"

Syntax

Visual Basic (Declaration)
Public Property PrefixWeek As String
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As String

instance.PrefixWeek = value

value = instance.PrefixWeek
C#
public string PrefixWeek {get; set;}
Managed Extensions for C++
public: __property string* get_PrefixWeek();
public: __property void set_PrefixWeek(
   string* value
);
C++/CLI
public:
property String^ PrefixWeek {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReScaleWithControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ReScaleWithControl Property

Glossary Item Box

If control key while dragging scaler == rescale, otherwise panorate

Syntax

Visual Basic (Declaration)
Public Property ReScaleWithControl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.ReScaleWithControl = value

value = instance.ReScaleWithControl
C#
public bool ReScaleWithControl {get; set;}
Managed Extensions for C++
public: __property bool get_ReScaleWithControl();
public: __property void set_ReScaleWithControl(
   bool value
);
C++/CLI
public:
property bool ReScaleWithControl {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ResizeType Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ResizeType Property

Glossary Item Box

Sets and gets the resizing behaviour.

Syntax

Visual Basic (Declaration)
Public Property ResizeType As ResizingType
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As ResizingType

instance.ResizeType = value

value = instance.ResizeType
C#
public ResizingType ResizeType {get; set;}
Managed Extensions for C++
public: __property ResizingType get_ResizeType();
public: __property void set_ResizeType(
   ResizingType value
);
C++/CLI
public:
property ResizingType ResizeType {
   ResizingType get();
   void set (    ResizingType value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScaleMarkerColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkerColor Property

Glossary Item Box

Sets and gets the color of the scale markers.

Syntax

Visual Basic (Declaration)
Public Property ScaleMarkerColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Color

instance.ScaleMarkerColor = value

value = instance.ScaleMarkerColor
C#
public Color ScaleMarkerColor {get; set;}
Managed Extensions for C++
public: __property Color get_ScaleMarkerColor();
public: __property void set_ScaleMarkerColor(
   Color value
);
C++/CLI
public:
property Color ScaleMarkerColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScaleMarkersHigh Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkersHigh Property

Glossary Item Box

Returns an array with the positions of all markers in the upper scale.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ScaleMarkersHigh As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As ArrayList

value = instance.ScaleMarkersHigh
C#
[BrowsableAttribute(false)]
public ArrayList ScaleMarkersHigh {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ArrayList* get_ScaleMarkersHigh();
C++/CLI
[BrowsableAttribute(false)]
public:
property ArrayList^ ScaleMarkersHigh {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScaleMarkersLow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ScaleMarkersLow Property

Glossary Item Box

Returns an array with the positions of all markers in the lower scale.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ScaleMarkersLow As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As ArrayList

value = instance.ScaleMarkersLow
C#
[BrowsableAttribute(false)]
public ArrayList ScaleMarkersLow {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ArrayList* get_ScaleMarkersLow();
C++/CLI
[BrowsableAttribute(false)]
public:
property ArrayList^ ScaleMarkersLow {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScrollButtonsVisible Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ScrollButtonsVisible Property

Glossary Item Box

Allows you to hide the scaler scroll buttons

Syntax

Visual Basic (Declaration)
Public Property ScrollButtonsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.ScrollButtonsVisible = value

value = instance.ScrollButtonsVisible
C#
public bool ScrollButtonsVisible {get; set;}
Managed Extensions for C++
public: __property bool get_ScrollButtonsVisible();
public: __property void set_ScrollButtonsVisible(
   bool value
);
C++/CLI
public:
property bool ScrollButtonsVisible {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowWeekNumbers Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ShowWeekNumbers Property

Glossary Item Box

Week numbers or date span for week denomination.

Syntax

Visual Basic (Declaration)
Public Property ShowWeekNumbers As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.ShowWeekNumbers = value

value = instance.ShowWeekNumbers
C#
public bool ShowWeekNumbers {get; set;}
Managed Extensions for C++
public: __property bool get_ShowWeekNumbers();
public: __property void set_ShowWeekNumbers(
   bool value
);
C++/CLI
public:
property bool ShowWeekNumbers {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SpanTextColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : SpanTextColor Property

Glossary Item Box

Sets and gets the color of the span text.

Syntax

Visual Basic (Declaration)
Public Property SpanTextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Color

instance.SpanTextColor = value

value = instance.SpanTextColor
C#
public Color SpanTextColor {get; set;}
Managed Extensions for C++
public: __property Color get_SpanTextColor();
public: __property void set_SpanTextColor(
   Color value
);
C++/CLI
public:
property Color SpanTextColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SpanTextFont Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : SpanTextFont Property

Glossary Item Box

Gets and sets the font for the span text.

Syntax

Visual Basic (Declaration)
Public Property SpanTextFont As Font
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Font

instance.SpanTextFont = value

value = instance.SpanTextFont
C#
public Font SpanTextFont {get; set;}
Managed Extensions for C++
public: __property Font* get_SpanTextFont();
public: __property void set_SpanTextFont(
   Font* value
);
C++/CLI
public:
property Font^ SpanTextFont {
   Font^ get();
   void set (    Font^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartOfWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : StartOfWeek Property

Glossary Item Box

Sets and gets the day starting the week

Syntax

Visual Basic (Declaration)
Public Property StartOfWeek As DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As DayOfWeek

instance.StartOfWeek = value

value = instance.StartOfWeek
C#
public DayOfWeek StartOfWeek {get; set;}
Managed Extensions for C++
public: __property DayOfWeek get_StartOfWeek();
public: __property void set_StartOfWeek(
   DayOfWeek value
);
C++/CLI
public:
property DayOfWeek StartOfWeek {
   DayOfWeek get();
   void set (    DayOfWeek value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : StartTime Property

Glossary Item Box

Gets the start time of the scaler.

Syntax

Visual Basic (Declaration)
Public Property StartTime As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Date

instance.StartTime = value

value = instance.StartTime
C#
public DateTime StartTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StartTime();
public: __property void set_StartTime(
   DateTime value
);
C++/CLI
public:
property DateTime StartTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StopTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : StopTime Property

Glossary Item Box

Gets the stop time of the scaler.

Syntax

Visual Basic (Declaration)
Public Property StopTime As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Date

instance.StopTime = value

value = instance.StopTime
C#
public DateTime StopTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StopTime();
public: __property void set_StopTime(
   DateTime value
);
C++/CLI
public:
property DateTime StopTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TextCentredInIntervallLessThanDay Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : TextCentredInIntervallLessThanDay Property

Glossary Item Box

When displaying hours in the datescaler upperband you have a choice to display the hour text above the 00 minutes mark and thus giving box-lines at 30 minutes to and 30 minutes after the hour. OR you can display the hour text centred in the hour that gives an hour text just above 30 minutes past the hour, and hence the box-lines at 00 minutes. This choice exists for all the displayed resolutions less than a day. Since we have clients arguing for both approaches being correct we have implemented this option.

Syntax

Visual Basic (Declaration)
Public Property TextCentredInIntervallLessThanDay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.TextCentredInIntervallLessThanDay = value

value = instance.TextCentredInIntervallLessThanDay
C#
public bool TextCentredInIntervallLessThanDay {get; set;}
Managed Extensions for C++
public: __property bool get_TextCentredInIntervallLessThanDay();
public: __property void set_TextCentredInIntervallLessThanDay(
   bool value
);
C++/CLI
public:
property bool TextCentredInIntervallLessThanDay {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UpperBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UpperBound Property

Glossary Item Box

Sets and gets the upper bound in the non-linear time line.

Syntax

Visual Basic (Declaration)
Public Property UpperBound As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Date

instance.UpperBound = value

value = instance.UpperBound
C#
public DateTime UpperBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_UpperBound();
public: __property void set_UpperBound(
   DateTime value
);
C++/CLI
public:
property DateTime UpperBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseDayNumbersNotWeeks Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UseDayNumbersNotWeeks Property

Glossary Item Box

When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position

Syntax

Visual Basic (Declaration)
Public Property UseDayNumbersNotWeeks As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.UseDayNumbersNotWeeks = value

value = instance.UseDayNumbersNotWeeks
C#
public bool UseDayNumbersNotWeeks {get; set;}
Managed Extensions for C++
public: __property bool get_UseDayNumbersNotWeeks();
public: __property void set_UseDayNumbersNotWeeks(
   bool value
);
C++/CLI
public:
property bool UseDayNumbersNotWeeks {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseScheduleTimeLayoutForSmallIntervals Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntervals Property

Glossary Item Box

When this is true the Datescaler will render itself significantly different when in ScheduleMode AND the resolution goes below TimeResolution.hours3. The rendering then performed then is Hour and time centric and will give a better time of day connection to the display

Syntax

Visual Basic (Declaration)
Public Property UseScheduleTimeLayoutForSmallIntervals As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.UseScheduleTimeLayoutForSmallIntervals = value

value = instance.UseScheduleTimeLayoutForSmallIntervals
C#
public bool UseScheduleTimeLayoutForSmallIntervals {get; set;}
Managed Extensions for C++
public: __property bool get_UseScheduleTimeLayoutForSmallIntervals();
public: __property void set_UseScheduleTimeLayoutForSmallIntervals(
   bool value
);
C++/CLI
public:
property bool UseScheduleTimeLayoutForSmallIntervals {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm Property

Glossary Item Box

When UseScheduleTimeLayoutForSmallIntervals is true and this property is true 24 hour clock will be used if false 12 hour clock will be used along with am/pm marking of the first hour

Syntax

Visual Basic (Declaration)
Public Property UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm = value

value = instance.UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm
C#
public bool UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm {get; set;}
Managed Extensions for C++
public: __property bool get_UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm();
public: __property void set_UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm(
   bool value
);
C++/CLI
public:
property bool UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseScheduleTimeLayoutForSmallIntveralls Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntveralls Property

Glossary Item Box

Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals

Syntax

Visual Basic (Declaration)
Public Property UseScheduleTimeLayoutForSmallIntveralls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.UseScheduleTimeLayoutForSmallIntveralls = value

value = instance.UseScheduleTimeLayoutForSmallIntveralls
C#
public bool UseScheduleTimeLayoutForSmallIntveralls {get; set;}
Managed Extensions for C++
public: __property bool get_UseScheduleTimeLayoutForSmallIntveralls();
public: __property void set_UseScheduleTimeLayoutForSmallIntveralls(
   bool value
);
C++/CLI
public:
property bool UseScheduleTimeLayoutForSmallIntveralls {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm Property

Glossary Item Box

Deprecated; misspelled use UseScheduleTimeLayoutForSmallIntervals24HourNotAmPm

Syntax

Visual Basic (Declaration)
Public Property UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As Boolean

instance.UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm = value

value = instance.UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm
C#
public bool UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm {get; set;}
Managed Extensions for C++
public: __property bool get_UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm();
public: __property void set_UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm(
   bool value
);
C++/CLI
public:
property bool UseScheduleTimeLayoutForSmallIntveralls24HourNotAmPm {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleDays Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : VisibleDays Property

Glossary Item Box

Returns all days visible

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleDays As DayOfWeek()
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value() As DayOfWeek

value = instance.VisibleDays
C#
public DayOfWeek[] VisibleDays {get;}
Managed Extensions for C++
public: __property DayOfWeek[]* get_VisibleDays();
C++/CLI
public:
property array<DayOfWeek>^ VisibleDays {
   array<DayOfWeek>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleHours Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : VisibleHours Property

Glossary Item Box

Returns all hours visible

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleHours As Integer()
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value() As Integer

value = instance.VisibleHours
C#
public int[] VisibleHours {get;}
Managed Extensions for C++
public: __property int[]* get_VisibleHours();
C++/CLI
public:
property array<int>^ VisibleHours {
   array<int>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ZoomIntoResolution Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : ZoomIntoResolution Property

Glossary Item Box

Set this to a value that equals the resolution that is one step smaller than the one you want to allow. The default value is NonLinearTime.TimeResolution.secondsBy10000 Note that this will only stop the DateScaler from presenting lower resolutions The shown span will get smaller but the resolution will not adapt below you setting, so the long lines will/can get really far apart. To actually stop the DateScaler from getting to small intervalls to display set MinSpan

Syntax

Visual Basic (Declaration)
Public Property ZoomIntoResolution As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim value As NonLinearTime.TimeResolution

instance.ZoomIntoResolution = value

value = instance.ZoomIntoResolution
C#
public NonLinearTime.TimeResolution ZoomIntoResolution {get; set;}
Managed Extensions for C++
public: __property NonLinearTime.TimeResolution get_ZoomIntoResolution();
public: __property void set_ZoomIntoResolution(
   NonLinearTime.TimeResolution value
);
C++/CLI
public:
property NonLinearTime.TimeResolution ZoomIntoResolution {
   NonLinearTime.TimeResolution get();
   void set (    NonLinearTime.TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
DateScaler Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaler Class

Glossary Item Box

For a list of all members of this type, see DateScaler members.

Public Events

 | Name | Description
Public Event | OnBeforeScaleOrSpanChange | Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code
Public Event | OnDateScalerDrawBoxes | Event that allows you to override the boxes drawn in the scaler
Public Event | OnDateScalerDrawString | Lets you override scaler textual output
Public Event | OnScaleChangeEvent | Fires whenever the Datescale is redrawn
Public Event | OnViewDateInformation | This event allows you to override the Date information that is placed on the left side of the screen by default
Top

See Also

Reference

DateScaler Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeScaleOrSpanChange Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : OnBeforeScaleOrSpanChange Event

Glossary Item Box

Fires whenever the scale or shown intervall is changed by user interaction This would be a good place to limit scaling or panoration in code

Syntax

Visual Basic (Declaration)
Public Event OnBeforeScaleOrSpanChange As BeforeScaleOrSpanChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim handler As BeforeScaleOrSpanChangeEventHandler

AddHandler instance.OnBeforeScaleOrSpanChange, handler
C#
public event BeforeScaleOrSpanChangeEventHandler OnBeforeScaleOrSpanChange
Managed Extensions for C++
public: __event BeforeScaleOrSpanChangeEventHandler* OnBeforeScaleOrSpanChange
C++/CLI
public:
event BeforeScaleOrSpanChangeEventHandler^ OnBeforeScaleOrSpanChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDrawBoxes Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : OnDateScalerDrawBoxes Event

Glossary Item Box

Event that allows you to override the boxes drawn in the scaler

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDrawBoxes As DateScalerDrawBoxesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim handler As DateScalerDrawBoxesEventHandler

AddHandler instance.OnDateScalerDrawBoxes, handler
C#
public event DateScalerDrawBoxesEventHandler OnDateScalerDrawBoxes
Managed Extensions for C++
public: __event DateScalerDrawBoxesEventHandler* OnDateScalerDrawBoxes
C++/CLI
public:
event DateScalerDrawBoxesEventHandler^ OnDateScalerDrawBoxes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDrawString Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : OnDateScalerDrawString Event

Glossary Item Box

Lets you override scaler textual output

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDrawString As DateScalerDrawStringEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim handler As DateScalerDrawStringEventHandler

AddHandler instance.OnDateScalerDrawString, handler
C#
public event DateScalerDrawStringEventHandler OnDateScalerDrawString
Managed Extensions for C++
public: __event DateScalerDrawStringEventHandler* OnDateScalerDrawString
C++/CLI
public:
event DateScalerDrawStringEventHandler^ OnDateScalerDrawString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnScaleChangeEvent Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : OnScaleChangeEvent Event

Glossary Item Box

Fires whenever the Datescale is redrawn

Syntax

Visual Basic (Declaration)
Public Event OnScaleChangeEvent As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim handler As EventHandler

AddHandler instance.OnScaleChangeEvent, handler
C#
public event EventHandler OnScaleChangeEvent
Managed Extensions for C++
public: __event EventHandler* OnScaleChangeEvent
C++/CLI
public:
event EventHandler^ OnScaleChangeEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnViewDateInformation Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScaler Class : OnViewDateInformation Event

Glossary Item Box

This event allows you to override the Date information that is placed on the left side of the screen by default

Syntax

Visual Basic (Declaration)
Public Event OnViewDateInformation As ViewDateInformationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateScaler
Dim handler As ViewDateInformationEventHandler

AddHandler instance.OnViewDateInformation, handler
C#
public event ViewDateInformationEventHandler OnViewDateInformation
Managed Extensions for C++
public: __event ViewDateInformationEventHandler* OnViewDateInformation
C++/CLI
public:
event ViewDateInformationEventHandler^ OnViewDateInformation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScaler Class
DateScaler Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawBoxesEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawBoxesEventArgs Class

Glossary Item Box

Arguments for date scaler draw boxes event

Object Model

DateScalerDrawBoxesEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DateScalerDrawBoxesEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawBoxesEventArgs
C#
public class DateScalerDrawBoxesEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class DateScalerDrawBoxesEventArgs : public System.EventArgs
C++/CLI
public ref class DateScalerDrawBoxesEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.DateScalerDrawBoxesEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScalerDrawBoxesEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
DateScalerDrawBoxesEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawBoxesEventArgs Class

Glossary Item Box

The following tables list the members exposed by DateScalerDrawBoxesEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DateScalerDrawBoxesEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ContinueDraw | If you set this to true the original logic will still draw the default box. If false the original logic is skipped.
Public Field | DateScaleMark | The DateScaleMark holds the specifics about the box about the be drawn
Public Field | G | This is the Graphics object you can use to draw the box or what you want to draw
Top

See Also

Reference

DateScalerDrawBoxesEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawBoxesEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawBoxesEventArgs Class : DateScalerDrawBoxesEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DateScalerDrawBoxesEventArgs()
C#
public DateScalerDrawBoxesEventArgs()
Managed Extensions for C++
public: DateScalerDrawBoxesEventArgs();
C++/CLI
public:
DateScalerDrawBoxesEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawBoxesEventArgs Class
DateScalerDrawBoxesEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
DateScalerDrawBoxesEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawBoxesEventArgs Class

Glossary Item Box

For a list of all members of this type, see DateScalerDrawBoxesEventArgs members.

Public Fields

 | Name | Description
Public Field | ContinueDraw | If you set this to true the original logic will still draw the default box. If false the original logic is skipped.
Public Field | DateScaleMark | The DateScaleMark holds the specifics about the box about the be drawn
Public Field | G | This is the Graphics object you can use to draw the box or what you want to draw
Top

See Also

Reference

DateScalerDrawBoxesEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContinueDraw Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawBoxesEventArgs Class : ContinueDraw Field

Glossary Item Box

If you set this to true the original logic will still draw the default box. If false the original logic is skipped.

Syntax

Visual Basic (Declaration)
Public ContinueDraw As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawBoxesEventArgs
Dim value As Boolean

value = instance.ContinueDraw

instance.ContinueDraw = value
C#
public bool ContinueDraw
Managed Extensions for C++
public: bool ContinueDraw
C++/CLI
public:
bool ContinueDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawBoxesEventArgs Class
DateScalerDrawBoxesEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaleMark Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawBoxesEventArgs Class : DateScaleMark Field

Glossary Item Box

The DateScaleMark holds the specifics about the box about the be drawn

Syntax

Visual Basic (Declaration)
Public DateScaleMark As DateScaleMark
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawBoxesEventArgs
Dim value As DateScaleMark

value = instance.DateScaleMark

instance.DateScaleMark = value
C#
public DateScaleMark DateScaleMark
Managed Extensions for C++
public: DateScaleMark* DateScaleMark
C++/CLI
public:
DateScaleMark^ DateScaleMark

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawBoxesEventArgs Class
DateScalerDrawBoxesEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawBoxesEventArgs Class : G Field

Glossary Item Box

This is the Graphics object you can use to draw the box or what you want to draw

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawBoxesEventArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawBoxesEventArgs Class
DateScalerDrawBoxesEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawStringEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawStringEventArgs Class

Glossary Item Box

Arguments for date scaler draw text event

Object Model

DateScalerDrawStringEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DateScalerDrawStringEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
C#
public class DateScalerDrawStringEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class DateScalerDrawStringEventArgs : public System.EventArgs
C++/CLI
public ref class DateScalerDrawStringEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.DateScalerDrawStringEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScalerDrawStringEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
DateScalerDrawStringEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawStringEventArgs Class

Glossary Item Box

The following tables list the members exposed by DateScalerDrawStringEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DateScalerDrawStringEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush | The brush used by the default drawing logic
Public Field | ContinueDraw | Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.
Public Field | DateTime | This is the DateTime that the text represent
Public Field | Font | The font that will be used by the original logic if you set ContinueDraw to true. Change this to get another font; maybe bigger for Saturdays?
Public Field | G | The Graphics object you can use to draw a text or lines etc
Public Field | LongIntervall | True if this is the LongIntervall text (upper band) false if lower band or short intervall
Public Field | OutputText | The original suggested text
Public Field | pos | This is the pixel pos where the text is placed
Public Field | Resolution | The resoultion used for this band.
Top

See Also

Reference

DateScalerDrawStringEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawStringEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : DateScalerDrawStringEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DateScalerDrawStringEventArgs()
C#
public DateScalerDrawStringEventArgs()
Managed Extensions for C++
public: DateScalerDrawStringEventArgs();
C++/CLI
public:
DateScalerDrawStringEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
DateScalerDrawStringEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawStringEventArgs Class

Glossary Item Box

For a list of all members of this type, see DateScalerDrawStringEventArgs members.

Public Fields

 | Name | Description
Public Field | Brush | The brush used by the default drawing logic
Public Field | ContinueDraw | Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.
Public Field | DateTime | This is the DateTime that the text represent
Public Field | Font | The font that will be used by the original logic if you set ContinueDraw to true. Change this to get another font; maybe bigger for Saturdays?
Public Field | G | The Graphics object you can use to draw a text or lines etc
Public Field | LongIntervall | True if this is the LongIntervall text (upper band) false if lower band or short intervall
Public Field | OutputText | The original suggested text
Public Field | pos | This is the pixel pos where the text is placed
Public Field | Resolution | The resoultion used for this band.
Top

See Also

Reference

DateScalerDrawStringEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Brush Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : Brush Field

Glossary Item Box

The brush used by the default drawing logic

Syntax

Visual Basic (Declaration)
Public Brush As Brush
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Brush

value = instance.Brush

instance.Brush = value
C#
public Brush Brush
Managed Extensions for C++
public: Brush* Brush
C++/CLI
public:
Brush^ Brush

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContinueDraw Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : ContinueDraw Field

Glossary Item Box

Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.

Syntax

Visual Basic (Declaration)
Public ContinueDraw As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Boolean

value = instance.ContinueDraw

instance.ContinueDraw = value
C#
public bool ContinueDraw
Managed Extensions for C++
public: bool ContinueDraw
C++/CLI
public:
bool ContinueDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateTime Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : DateTime Field

Glossary Item Box

This is the DateTime that the text represent

Syntax

Visual Basic (Declaration)
Public DateTime As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Date

value = instance.DateTime

instance.DateTime = value
C#
public DateTime DateTime
Managed Extensions for C++
public: DateTime DateTime
C++/CLI
public:
DateTime DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Font Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : Font Field

Glossary Item Box

The font that will be used by the original logic if you set ContinueDraw to true. Change this to get another font; maybe bigger for Saturdays?

Syntax

Visual Basic (Declaration)
Public Font As Font
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Font

value = instance.Font

instance.Font = value
C#
public Font Font
Managed Extensions for C++
public: Font* Font
C++/CLI
public:
Font^ Font

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : G Field

Glossary Item Box

The Graphics object you can use to draw a text or lines etc

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LongIntervall Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : LongIntervall Field

Glossary Item Box

True if this is the LongIntervall text (upper band) false if lower band or short intervall

Syntax

Visual Basic (Declaration)
Public LongIntervall As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Boolean

value = instance.LongIntervall

instance.LongIntervall = value
C#
public bool LongIntervall
Managed Extensions for C++
public: bool LongIntervall
C++/CLI
public:
bool LongIntervall

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OutputText Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : OutputText Field

Glossary Item Box

The original suggested text

Syntax

Visual Basic (Declaration)
Public OutputText As String
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As String

value = instance.OutputText

instance.OutputText = value
C#
public string OutputText
Managed Extensions for C++
public: string* OutputText
C++/CLI
public:
String^ OutputText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
pos Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : pos Field

Glossary Item Box

This is the pixel pos where the text is placed

Syntax

Visual Basic (Declaration)
Public pos As Point
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As Point

value = instance.pos

instance.pos = value
C#
public Point pos
Managed Extensions for C++
public: Point pos
C++/CLI
public:
Point pos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Resolution Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerDrawStringEventArgs Class : Resolution Field

Glossary Item Box

The resoultion used for this band.

Syntax

Visual Basic (Declaration)
Public Resolution As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As DateScalerDrawStringEventArgs
Dim value As NonLinearTime.TimeResolution

value = instance.Resolution

instance.Resolution = value
C#
public NonLinearTime.TimeResolution Resolution
Managed Extensions for C++
public: NonLinearTime.TimeResolution Resolution
C++/CLI
public:
NonLinearTime.TimeResolution Resolution

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerDrawStringEventArgs Class
DateScalerDrawStringEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerProperties Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerProperties Class

Glossary Item Box

Exposes some properties of the datescaler to the Gantt in design time

Object Model

DateScalerProperties Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Class DateScalerProperties
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public class DateScalerProperties
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public __gc class DateScalerProperties
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ref class DateScalerProperties

Inheritance Hierarchy

System.Object
PlexityHide.GTP.DateScalerProperties

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScalerProperties Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
DateScalerProperties Class Members
See Also Properties Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerProperties Class

Glossary Item Box

The following tables list the members exposed by DateScalerProperties.

Public Constructors

 | Name | Description
Public Constructor | DateScalerProperties Constructor | Called by Gantt and Gantt_Asp.
Top

Public Properties

 | Name | Description
Public Property | ContextMenuStrip | ContextMenu of the datescaler
Public Property | FiscalYearStartMonth | This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May
Public Property | FishEyeColor | Backcolor of the fisheye area
Public Property | FishEyeenabled | Turn on fisheye area
Public Property | FishEyeMagnification | Fisheye area magnifies this much compared to non fisheye
Public Property | LowerBound | Lowest date that user can display
Public Property | MarkerTextColor | Color on texts
Public Property | ResizeType | Sets and gets the resizing behaviour.
Public Property | ScaleMarkerColor | Color on lines
Public Property | ShowWeekNumbers |
Public Property | SpanTextColor | Color on texts
Public Property | StartOfWeek | The week day that is used as start of week
Public Property | StartTime | Current display start time
Public Property | StopTime | Current display stop time
Public Property | UpperBound | Highest date that user can display
Public Property | UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Top

See Also

Reference

DateScalerProperties Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerProperties Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : DateScalerProperties Constructor

aGantt

Glossary Item Box

Called by Gantt and Gantt_Asp.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim aGantt As Gantt

Dim instance As New DateScalerProperties(aGantt)
C#
public DateScalerProperties(
   Gantt aGantt
)
Managed Extensions for C++
public: DateScalerProperties(
   Gantt* aGantt
)
C++/CLI
public:
DateScalerProperties(
   Gantt^ aGantt
)

Parameters

aGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
DateScalerProperties Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerProperties Class

Glossary Item Box

For a list of all members of this type, see DateScalerProperties members.

Public Properties

 | Name | Description
Public Property | ContextMenuStrip | ContextMenu of the datescaler
Public Property | FiscalYearStartMonth | This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May
Public Property | FishEyeColor | Backcolor of the fisheye area
Public Property | FishEyeenabled | Turn on fisheye area
Public Property | FishEyeMagnification | Fisheye area magnifies this much compared to non fisheye
Public Property | LowerBound | Lowest date that user can display
Public Property | MarkerTextColor | Color on texts
Public Property | ResizeType | Sets and gets the resizing behaviour.
Public Property | ScaleMarkerColor | Color on lines
Public Property | ShowWeekNumbers |
Public Property | SpanTextColor | Color on texts
Public Property | StartOfWeek | The week day that is used as start of week
Public Property | StartTime | Current display start time
Public Property | StopTime | Current display stop time
Public Property | UpperBound | Highest date that user can display
Public Property | UseDayNumbersNotWeeks | When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position
Top

See Also

Reference

DateScalerProperties Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContextMenuStrip Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : ContextMenuStrip Property

Glossary Item Box

ContextMenu of the datescaler

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}
Managed Extensions for C++
public: __property ContextMenuStrip* get_ContextMenuStrip();
public: __property void set_ContextMenuStrip(
   ContextMenuStrip* value
);
C++/CLI
public:
property ContextMenuStrip^ ContextMenuStrip {
   ContextMenuStrip^ get();
   void set (    ContextMenuStrip^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FiscalYearStartMonth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : FiscalYearStartMonth Property

Glossary Item Box

This property skewes the displayed Year and Quarter to start at any given month. To show a Fiscal year that starts in May set this to 5 - the month # of May

Syntax

Visual Basic (Declaration)
Public Property FiscalYearStartMonth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Integer

instance.FiscalYearStartMonth = value

value = instance.FiscalYearStartMonth
C#
public int FiscalYearStartMonth {get; set;}
Managed Extensions for C++
public: __property int get_FiscalYearStartMonth();
public: __property void set_FiscalYearStartMonth(
   int value
);
C++/CLI
public:
property int FiscalYearStartMonth {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : FishEyeColor Property

Glossary Item Box

Backcolor of the fisheye area

Syntax

Visual Basic (Declaration)
Public Property FishEyeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Color

instance.FishEyeColor = value

value = instance.FishEyeColor
C#
public Color FishEyeColor {get; set;}
Managed Extensions for C++
public: __property Color get_FishEyeColor();
public: __property void set_FishEyeColor(
   Color value
);
C++/CLI
public:
property Color FishEyeColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeenabled Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : FishEyeenabled Property

Glossary Item Box

Turn on fisheye area

Syntax

Visual Basic (Declaration)
Public Property FishEyeenabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Boolean

instance.FishEyeenabled = value

value = instance.FishEyeenabled
C#
public bool FishEyeenabled {get; set;}
Managed Extensions for C++
public: __property bool get_FishEyeenabled();
public: __property void set_FishEyeenabled(
   bool value
);
C++/CLI
public:
property bool FishEyeenabled {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeMagnification Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : FishEyeMagnification Property

Glossary Item Box

Fisheye area magnifies this much compared to non fisheye

Syntax

Visual Basic (Declaration)
Public Property FishEyeMagnification As FishEyeMagnification
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As FishEyeMagnification

instance.FishEyeMagnification = value

value = instance.FishEyeMagnification
C#
public FishEyeMagnification FishEyeMagnification {get; set;}
Managed Extensions for C++
public: __property FishEyeMagnification get_FishEyeMagnification();
public: __property void set_FishEyeMagnification(
   FishEyeMagnification value
);
C++/CLI
public:
property FishEyeMagnification FishEyeMagnification {
   FishEyeMagnification get();
   void set (    FishEyeMagnification value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LowerBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : LowerBound Property

Glossary Item Box

Lowest date that user can display

Syntax

Visual Basic (Declaration)
Public Property LowerBound As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Date

instance.LowerBound = value

value = instance.LowerBound
C#
public DateTime LowerBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_LowerBound();
public: __property void set_LowerBound(
   DateTime value
);
C++/CLI
public:
property DateTime LowerBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MarkerTextColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : MarkerTextColor Property

Glossary Item Box

Color on texts

Syntax

Visual Basic (Declaration)
Public Property MarkerTextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Color

instance.MarkerTextColor = value

value = instance.MarkerTextColor
C#
public Color MarkerTextColor {get; set;}
Managed Extensions for C++
public: __property Color get_MarkerTextColor();
public: __property void set_MarkerTextColor(
   Color value
);
C++/CLI
public:
property Color MarkerTextColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ResizeType Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : ResizeType Property

Glossary Item Box

Sets and gets the resizing behaviour.

Syntax

Visual Basic (Declaration)
Public Property ResizeType As ResizingType
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As ResizingType

instance.ResizeType = value

value = instance.ResizeType
C#
public ResizingType ResizeType {get; set;}
Managed Extensions for C++
public: __property ResizingType get_ResizeType();
public: __property void set_ResizeType(
   ResizingType value
);
C++/CLI
public:
property ResizingType ResizeType {
   ResizingType get();
   void set (    ResizingType value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScaleMarkerColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : ScaleMarkerColor Property

Glossary Item Box

Color on lines

Syntax

Visual Basic (Declaration)
Public Property ScaleMarkerColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Color

instance.ScaleMarkerColor = value

value = instance.ScaleMarkerColor
C#
public Color ScaleMarkerColor {get; set;}
Managed Extensions for C++
public: __property Color get_ScaleMarkerColor();
public: __property void set_ScaleMarkerColor(
   Color value
);
C++/CLI
public:
property Color ScaleMarkerColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowWeekNumbers Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : ShowWeekNumbers Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ShowWeekNumbers As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Boolean

instance.ShowWeekNumbers = value

value = instance.ShowWeekNumbers
C#
public bool ShowWeekNumbers {get; set;}
Managed Extensions for C++
public: __property bool get_ShowWeekNumbers();
public: __property void set_ShowWeekNumbers(
   bool value
);
C++/CLI
public:
property bool ShowWeekNumbers {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SpanTextColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : SpanTextColor Property

Glossary Item Box

Color on texts

Syntax

Visual Basic (Declaration)
Public Property SpanTextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Color

instance.SpanTextColor = value

value = instance.SpanTextColor
C#
public Color SpanTextColor {get; set;}
Managed Extensions for C++
public: __property Color get_SpanTextColor();
public: __property void set_SpanTextColor(
   Color value
);
C++/CLI
public:
property Color SpanTextColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartOfWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : StartOfWeek Property

Glossary Item Box

The week day that is used as start of week

Syntax

Visual Basic (Declaration)
Public Property StartOfWeek As DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As DayOfWeek

instance.StartOfWeek = value

value = instance.StartOfWeek
C#
public DayOfWeek StartOfWeek {get; set;}
Managed Extensions for C++
public: __property DayOfWeek get_StartOfWeek();
public: __property void set_StartOfWeek(
   DayOfWeek value
);
C++/CLI
public:
property DayOfWeek StartOfWeek {
   DayOfWeek get();
   void set (    DayOfWeek value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : StartTime Property

Glossary Item Box

Current display start time

Syntax

Visual Basic (Declaration)
Public Property StartTime As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Date

instance.StartTime = value

value = instance.StartTime
C#
public DateTime StartTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StartTime();
public: __property void set_StartTime(
   DateTime value
);
C++/CLI
public:
property DateTime StartTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StopTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : StopTime Property

Glossary Item Box

Current display stop time

Syntax

Visual Basic (Declaration)
Public Property StopTime As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Date

instance.StopTime = value

value = instance.StopTime
C#
public DateTime StopTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StopTime();
public: __property void set_StopTime(
   DateTime value
);
C++/CLI
public:
property DateTime StopTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UpperBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : UpperBound Property

Glossary Item Box

Highest date that user can display

Syntax

Visual Basic (Declaration)
Public Property UpperBound As Date
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Date

instance.UpperBound = value

value = instance.UpperBound
C#
public DateTime UpperBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_UpperBound();
public: __property void set_UpperBound(
   DateTime value
);
C++/CLI
public:
property DateTime UpperBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UseDayNumbersNotWeeks Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > DateScalerProperties Class : UseDayNumbersNotWeeks Property

Glossary Item Box

When true weeks will not be indicated. Instead the days will be displayed with their day of month number, and the month will be dsiplayed in the top position

Syntax

Visual Basic (Declaration)
Public Property UseDayNumbersNotWeeks As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateScalerProperties
Dim value As Boolean

instance.UseDayNumbersNotWeeks = value

value = instance.UseDayNumbersNotWeeks
C#
public bool UseDayNumbersNotWeeks {get; set;}
Managed Extensions for C++
public: __property bool get_UseDayNumbersNotWeeks();
public: __property void set_UseDayNumbersNotWeeks(
   bool value
);
C++/CLI
public:
property bool UseDayNumbersNotWeeks {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DateScalerProperties Class
DateScalerProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EachListItemWhenDataBoundArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : EachListItemWhenDataBoundArgs Class

Glossary Item Box

Arguments the OnEachListItemWhenDataBound event

Object Model

EachListItemWhenDataBoundArgs Class

Syntax

Visual Basic (Declaration)
Public Class EachListItemWhenDataBoundArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As EachListItemWhenDataBoundArgs
C#
public class EachListItemWhenDataBoundArgs : System.EventArgs
Managed Extensions for C++
public __gc class EachListItemWhenDataBoundArgs : public System.EventArgs
C++/CLI
public ref class EachListItemWhenDataBoundArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.EachListItemWhenDataBoundArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

EachListItemWhenDataBoundArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
EachListItemWhenDataBoundArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : EachListItemWhenDataBoundArgs Class

Glossary Item Box

The following tables list the members exposed by EachListItemWhenDataBoundArgs.

Public Constructors

 | Name | Description
Public Constructor | EachListItemWhenDataBoundArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GTPObject | The GTP.NET object affected by the update, a GridNode, TimeItemLink or TimeItem
Top

See Also

Reference

EachListItemWhenDataBoundArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EachListItemWhenDataBoundArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > EachListItemWhenDataBoundArgs Class : EachListItemWhenDataBoundArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EachListItemWhenDataBoundArgs()
C#
public EachListItemWhenDataBoundArgs()
Managed Extensions for C++
public: EachListItemWhenDataBoundArgs();
C++/CLI
public:
EachListItemWhenDataBoundArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EachListItemWhenDataBoundArgs Class
EachListItemWhenDataBoundArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
EachListItemWhenDataBoundArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EachListItemWhenDataBoundArgs Class

Glossary Item Box

For a list of all members of this type, see EachListItemWhenDataBoundArgs members.

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GTPObject | The GTP.NET object affected by the update, a GridNode, TimeItemLink or TimeItem
Top

See Also

Reference

EachListItemWhenDataBoundArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManagerListItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > EachListItemWhenDataBoundArgs Class : CurrencyManagerListItem Field

Glossary Item Box

The row from the currency manager

Syntax

Visual Basic (Declaration)
Public CurrencyManagerListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As EachListItemWhenDataBoundArgs
Dim value As Object

value = instance.CurrencyManagerListItem

instance.CurrencyManagerListItem = value
C#
public object CurrencyManagerListItem
Managed Extensions for C++
public: Object* CurrencyManagerListItem
C++/CLI
public:
Object^ CurrencyManagerListItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EachListItemWhenDataBoundArgs Class
EachListItemWhenDataBoundArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GTPObject Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > EachListItemWhenDataBoundArgs Class : GTPObject Field

Glossary Item Box

The GTP.NET object affected by the update, a GridNode, TimeItemLink or TimeItem

Syntax

Visual Basic (Declaration)
Public GTPObject As Object
Visual Basic (Usage) Copy Code
Dim instance As EachListItemWhenDataBoundArgs
Dim value As Object

value = instance.GTPObject

instance.GTPObject = value
C#
public object GTPObject
Managed Extensions for C++
public: Object* GTPObject
C++/CLI
public:
Object^ GTPObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EachListItemWhenDataBoundArgs Class
EachListItemWhenDataBoundArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditPickValueWindow Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : EditPickValueWindow Class

Glossary Item Box

EditPickValueWindow implement the small window that optionally shows under the edited field in the grid

Object Model

EditPickValueWindow Class

Syntax

Visual Basic (Declaration)
Public Class EditPickValueWindow
   Inherits System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As EditPickValueWindow
C#
public class EditPickValueWindow : System.Windows.Forms.Form
Managed Extensions for C++
public __gc class EditPickValueWindow : public System.Windows.Forms.Form
C++/CLI
public ref class EditPickValueWindow : public System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
PlexityHide.GTP.EditPickValueWindow

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

EditPickValueWindow Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
EditPickValueWindow Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : EditPickValueWindow Class

Glossary Item Box

The following tables list the members exposed by EditPickValueWindow.

Public Properties

 | Name | Description
Public Property | ContainsValues | Does the Picker windows currently contains any values?
Top

Public Methods

 | Name | Description
Public Method | AutoPopulate | Does some cunning auto population of the Value picker based on the cells in the column
Top

See Also

Reference

EditPickValueWindow Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
EditPickValueWindow Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EditPickValueWindow Class

Glossary Item Box

For a list of all members of this type, see EditPickValueWindow members.

Public Methods

 | Name | Description
Public Method | AutoPopulate | Does some cunning auto population of the Value picker based on the cells in the column
Top

See Also

Reference

EditPickValueWindow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AutoPopulate Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > EditPickValueWindow Class : AutoPopulate Method

aGrid

Glossary Item Box

Does some cunning auto population of the Value picker based on the cells in the column

Syntax

Visual Basic (Declaration)
Public Sub AutoPopulate( _
   ByVal aGrid As Grid _
)
Visual Basic (Usage) Copy Code
Dim instance As EditPickValueWindow
Dim aGrid As Grid

instance.AutoPopulate(aGrid)
C#
public void AutoPopulate(
   Grid aGrid
)
Managed Extensions for C++
public: void AutoPopulate(
   Grid* aGrid
)
C++/CLI
public:
void AutoPopulate(
   Grid^ aGrid
)

Parameters

aGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EditPickValueWindow Class
EditPickValueWindow Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
EditPickValueWindow Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EditPickValueWindow Class

Glossary Item Box

For a list of all members of this type, see EditPickValueWindow members.

Public Properties

 | Name | Description
Public Property | ContainsValues | Does the Picker windows currently contains any values?
Top

See Also

Reference

EditPickValueWindow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContainsValues Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > EditPickValueWindow Class : ContainsValues Property

Glossary Item Box

Does the Picker windows currently contains any values?

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsValues As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EditPickValueWindow
Dim value As Boolean

value = instance.ContainsValues
C#
public bool ContainsValues {get;}
Managed Extensions for C++
public: __property bool get_ContainsValues();
C++/CLI
public:
property bool ContainsValues {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EditPickValueWindow Class
EditPickValueWindow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ErrorEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ErrorEventArgs Class

Glossary Item Box

Exceptions can be handled through the Error Event

Object Model

ErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ErrorEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
C#
public class ErrorEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class ErrorEventArgs : public System.EventArgs
C++/CLI
public ref class ErrorEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ErrorEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ErrorEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ErrorEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : ErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by ErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ErrorEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Exception | The exception raised by Error
Public Field | Handled | Set to True if event handled event, otherwise will continue with default action.
Top

See Also

Reference

ErrorEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ErrorEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ErrorEventArgs Class : ErrorEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ErrorEventArgs()
C#
public ErrorEventArgs()
Managed Extensions for C++
public: ErrorEventArgs();
C++/CLI
public:
ErrorEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ErrorEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see ErrorEventArgs members.

Public Fields

 | Name | Description
Public Field | Exception | The exception raised by Error
Public Field | Handled | Set to True if event handled event, otherwise will continue with default action.
Top

See Also

Reference

ErrorEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Exception Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ErrorEventArgs Class : Exception Field

Glossary Item Box

The exception raised by Error

Syntax

Visual Basic (Declaration)
Public Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
Dim value As Exception

value = instance.Exception

instance.Exception = value
C#
public Exception Exception
Managed Extensions for C++
public: Exception* Exception
C++/CLI
public:
Exception^ Exception

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Handled Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ErrorEventArgs Class : Handled Field

Glossary Item Box

Set to True if event handled event, otherwise will continue with default action.

Syntax

Visual Basic (Declaration)
Public Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
Dim value As Boolean

value = instance.Handled

instance.Handled = value
C#
public bool Handled
Managed Extensions for C++
public: bool Handled
C++/CLI
public:
bool Handled

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : Gantt Class

Glossary Item Box

Gantt component.

Object Model

Gantt ClassCalendarCollection ClassCalendar ClassDateScaler ClassDateScalerProperties ClassTimeItem ClassGrid ClassGridProperties ClassTimeAreaOffscreenDraw ClassTimeItemLayouts ClassTimeItemLayout ClassTimeItemLinks ClassTimeItemTextLayouts ClassTimeItemTextLayout Class

Syntax

Visual Basic (Declaration)
<LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)>
<ToolboxBitmapAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class Gantt
   Inherits System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As Gantt
C#
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class Gantt : System.Windows.Forms.Control
Managed Extensions for C++
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class Gantt : public System.Windows.Forms.Control
C++/CLI
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class Gantt : public System.Windows.Forms.Control

Example

C# Copy Code
private void buttonCompleteIteration_Click(object sender, System.EventArgs e)
    {
      // The root-level of the grid nodes you access this way;
      for(int i=0;i<gantt1.Grid.RootNodes.Count;i++)
      {
        DoCompleteIterationForOneNode(gantt1.Grid.RootNodes[i]);
      }
    }

    private void DoCompleteIterationForOneNode(GridNode gn)
    {
      // Each gridnode has one cell per column
      for(int i=0;i<gn.GridStructure.Columns.Count;i++)
      {
       Object o=gn.GetCell(i).Content.Value;
      }

      // Each gridnode that is part of a gantt-grid has a GanttRow
      GanttRow gr=GanttRow.FromGridNode(gn);

      // Each GanttRow has layers, the normal scenario is that the GanttRow only has one layer
      for(int i=0;i<gr.Layers.Count;i++)
      {
        // Each Layer has time items
        for(int ii=0;ii<gr.Layers[i].Count;ii++)
        {
          // Each Layer has time items
          PlexityHide.GTP.TimeItem ti=gr.Layers[i][ii];

          //a Time item can have time item texts
          for(int iii=0;iii<ti.TimeItemTexts.Count;iii++)
          {
            ti.TimeItemTexts[iii].Text="";
          }

          // and a time item can also have links....
          ArrayList links=gantt1.TimeItemLinks.GetLinksFromStart(ti);

          for(int iii=0;iii<links.Count;iii++)
          {
            TimeItemLink til=links[iii] as TimeItemLink;
            // Once you have a link you can access the seperate time items
            TimeItem ti1=til.Target;
            TimeItem ti2=til.Start;
          }

        }

      }

      // A grid node may have sub-nodes....
      for(int i=0;i<gn.SubNodes.Count;i++)
      {
        DoCompleteIterationForOneNode(gn.SubNodes[i]);
      }

    }
Visual Basic Copy Code
Private Sub buttonCompleteIteration_Click(ByVal sender As Object, ByVal e As System.EventArgs)
      ' The root-level of the grid nodes you access this way;
      Dim i As Integer=0
      Do While i<gantt1.Grid.RootNodes.Count
        DoCompleteIterationForOneNode(gantt1.Grid.RootNodes(i))
          i += 1
      Loop
    End Sub

    Private Sub DoCompleteIterationForOneNode(ByVal gn As GridNode)
      ' Each gridnode has one cell per column
      Dim i As Integer=0
      Do While i<gn.GridStructure.Columns.Count
       Dim o As Object=gn.GetCell(i).Content.Value
          i += 1
      Loop

      ' Each gridnode that is part of a gantt-grid has a GanttRow
      Dim gr As GanttRow=GanttRow.FromGridNode(gn)

      ' Each GanttRow has layers, the normal scenario is that the GanttRow only has one layer
      i = 0
      Do While i<gr.Layers.Count
        ' Each Layer has time items
        Dim ii As Integer=0
        Do While ii<gr.Layers(i).Count
          ' Each Layer has time items
          Dim ti As PlexityHide.GTP.TimeItem=gr.Layers(i)(ii)

          'a Time item can have time item texts
          Dim iii As Integer=0
          Do While iii<ti.TimeItemTexts.Count
            ti.TimeItemTexts(iii).Text=""
              iii += 1
          Loop

          ' and a time item can also have links....
          Dim links As ArrayList=gantt1.TimeItemLinks.GetLinksFromStart(ti)

          iii = 0
          Do While iii<links.Count
            Dim til As TimeItemLink=CType(IIf(Typeof links(iii) Is TimeItemLink, links(iii), Nothing), TimeItemLink)
            ' Once you have a link you can access the seperate time items
            Dim ti1 As TimeItem=til.Target
            Dim ti2 As TimeItem=til.Start
              iii += 1
          Loop

            ii += 1
        Loop

          i += 1
      Loop

      ' A grid node may have sub-nodes....
      i = 0
      Do While i<gn.SubNodes.Count
        DoCompleteIterationForOneNode(gn.SubNodes(i))
          i += 1
      Loop

    End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PlexityHide.GTP.Gantt

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Gantt Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Gantt Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : Gantt Class

Glossary Item Box

The following tables list the members exposed by Gantt.

Public Constructors

 | Name | Description
Public Constructor | Gantt Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowAreaSelect | Enables time item selection by dragging out a square area
Public Property | AllowAreaSelectPartlyInside | When AllowAreaSelect is true this property controls if the TimeItem must have both Start and Stop inside the rect in order to be selected
Public Property | AutoScrollGridEnable | Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...
Public Property | AutoScrollTimeEnable | Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...
Public Property | CalcGridAndTimeOffset | Returns the difference in start position between Grid and TimeItem area
Public Property | Calendars | The Gantt chart can have multiple Calendars. A Calendar can have multiple CalendarEntry-objects. Each CalendarEntry has a Start and Stop date and an optional Frequency. The CalendarEntries can be used in different ways in the Gantt chart please see explantion on CalenderEntry class.
Public Property | CollisionDetectionSyncron | If false (default) the collision detection for time items will run asynchronously. When using the Gantt in Gantt_ASP you will probably want to set this to true so that collision detections always are resolved before image creation.
Public Property | ContextMenuStripTimeItemArea | ContextMenu of the Grid
Public Property | DateScaler | The DateScale
Public Property | DateScalerHeight | The height of the DateScaler in the Gantt
Public Property | DateScalerProperties | Some DateScale properties for design time
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | FocusedTimeItem | Returns currently focused time item
Public Property | Grid | The grid
Public Property | GridProperties | Some grid properties for design time
Public Property | GridWidth | The widht of the grid in the Gantt. When in ScheduleMode this property controls the height of the column heads
Public Property | ImageList | The image list is used for time items with images
Public Property | MouseDownPoint | This is the point were the mouse was clicked, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item See also MouseMovePoint
Public Property | MouseMoveKind | Tells what the mouse is used for at this instant
Public Property | MouseMovePoint | This is the current point were the mouse is, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item. See also MouseDownPoint.
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | ResizeAreaSize | The Active area that will react to resize events
Public Property | ScheduleMode | ScheduleMode controls the layout. Set ScheduleMode to true and the Gantt turns into a Schedule
Public Property | Splitter | The Splitter between time item area and grid
Public Property | TimeItemArea | The Time item area
Public Property | TimeItemLayouts |
Public Property | TimeItemLinks | Returns all time item links
Public Property | TimeItemTextLayouts | The textlayouts in the gantt
Public Property | TimeMoveMarkerDate | When the user moves a time item you can show move markers that helps the user to see from where the time item is moving and where it will end up if he or she drops it
Public Property | TimeMoveMarkerRow | When the user moves a time item you can show move markers that helps the user to see from what row the time item is moving and where it will end up if he or she drops it
Public Property | TodayLine | Vertical line drawn on Now!
Public Property | TodayLineColor | todayLine color, defaults to Black
Public Property | TurnOffAllCollisionDetect | If set all collision detection is turned off, not only for one row, for all rows. Primarily used to speed up load when using syncron collision detection.
Public Property | VerticalDayStripes | Vertical stripes on certain days
Public Property | VerticalDayStripes_Days | VerticalDayStripes set to true, this property then chooses the days, sat and sun default
Public Property | VerticalDayStripesColor | VerticalDayStripes color, defaults to
Public Property | VerticalDayStripesHighestResolution | Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property | VerticalDayStripesLowestResolution | Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property | VerticalLines | Vertical lines on long scale intervall
Public Property | VerticalLinesColor | VerticalLine color, defaults to Black
Top

Public Methods

 | Name | Description
Public Method | CheckIfStartInBlockedTime | When BlockedTimeCalculatedStop is used there may be situations where the start time of a time item is placed inside blocked time. This can be a perfectly valid case in some situations, but in others it may be illegal. To handle this the event OnTimeItem_StartMovedIntoBlockedTime is fired for you to verify. The event is fired from within this method, and if you want to do the same checks after changing the start time in code, as the component does when the user changes the start time, you will need to call this method.
Public Method | ClearSelected | Clear all selected time items
Public Method | EnterLinkCreateMode | When true clicks will be handled as link create and not as move or resize operation in timeitem area
Public Method | EnterTimeItemCreateMode | When true clicks will be handled as time item create and not as move or resize operation in timeitem area
Public Method | FindTimeItemLinkUserReference | Loops thru all time item links and compare x with TimeItem.UserReference.
Public Method | FindTimeItemUserReference | Loops thru all time items and compare x with TimeItem.UserReference.
static (Shared in Visual Basic) | GanttRowFromGridNode | Find GanttRow from GridNode
Public Method | GanttRowFromPoint | Find row from point, replaces GanttRowFromY. The point sent in shall be in TimeItemArea-coordinates
Public Method | GanttRowFromY | Deprecated. Will be removed. Warning does not support ScheduleMode. Use GanttRowFromPoint instead Find row from pixel.
Public Method | GetSelectedTimeItems | Overloaded. Returns currently selected time items owned by gridnodes currently on screen
Public Method | HandleOnTimeItem_AfterCreateByMouseEvent | Executes the OnTimeItem_AfterCreateByMouse event, exposed for use by the Gantt_ASP mainly
Public Method | MouseMoveCancel | Cancels an on going mouse move operation. Use this to cancel out the default behavior.
Public Method | PerformActionForUserMoveOfSingleTimeItem | Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.
Public Method | PerformActionForUserResizeEastOfSingleTimeItem | Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.
Public Method | PrintEnd | Print is reset
Public Method | PrintInit | Initializes the print process
Public Method | PrintPage | Overloaded. Prints a page. Note that GridWith=zero is not supported, if you need to suppress the grid in printing please use the overloaded PrintPage call with the suppressGrid=true.
Public Method | RegisterRuntimeKey | Call this early in your application to register the runtime key. The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand
Public Method | RuntimeKeyHelp_Assembly | Call this to get hints on what values to put into the registration form to get the runtimekey...
Public Method | RuntimeKeyOnTop | If called the notice about runtime key will be placed in the upper right corner (Gantt_ASP)
Public Method | ScheduleModeAgnostic | Based on the current ScheduleMode the rect is transformed to the standard ScheduleMode=false representation
Public Method | ScheduleModeAware | Based on the current ScheduleMode the rect is transformed from a ScheduleMode Agnostic rect to a SchedulMode aware rect
Public Method | SetMouseMoveKind | Sets the mousemovekind
Public Method | TimeItemFromPoint | Overloaded. Find time item from pixel
Public Method | TimeItemIdentityHash | This HashTable keeps all TimeItems that has been assigned an Identity value. The Hash his used internally to fix up databound timeitemlinks
Public Method | UpdateMultiSelect | Handles multi select behavior for this time item, based on held control keys
Top

Public Events

 | Name | Description
Public Event | OnCalendar_UserDraw | Event is fired when a CalendarEntry is about to be drawn
Public Event | OnCollisionDetect | Fired on detected collisions
Public Event | OnConflictArea_Update | Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic
Public Event | OnConflictArea_UserDraw | Event is fired if conflict areas with ConflictAreaStyle==user is detected Draw you own conflict area in this event implementation
Public Event | OnDateScalerClick | Exposed Standard event
Public Event | OnDateScalerDoubleClick | Exposed Standard event
Public Event | OnDateScalerDragDrop | Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point.
Public Event | OnDateScalerDragEnter | Exposed Standard event
Public Event | OnDateScalerDragLeave | Exposed Standard event
Public Event | OnDateScalerDragOver | Exposed Standard event
Public Event | OnDateScalerDrawBoxes | Event that allows you to override the boxes drawn in the scaler
Public Event | OnDateScalerDrawString | Lets you override scaler textual output
Public Event | OnDateScalerKeyDown | Exposed Standard event
Public Event | OnDateScalerKeyUp | Exposed Standard event
Public Event | OnDateScalerMouseDown | Exposed Standard event
Public Event | OnDateScalerMouseEnter | Exposed Standard event
Public Event | OnDateScalerMouseHover | Exposed Standard event
Public Event | OnDateScalerMouseLeave | Exposed Standard event
Public Event | OnDateScalerMouseMove | Exposed Standard event
Public Event | OnDateScalerMouseUp | Exposed Standard event
Public Event | OnDateScalerMouseWheel | Exposed Standard event
Public Event | OnDateScalerPaintBackground | Fired when it is time to draw the background
Public Event | OnDateScalerPaintForeground | Fired when it is time to draw the foreground
Public Event | OnDateScalerScaleChangeEvent | Fires whenever the scale has changed
Public Event | OnDateScalerViewDateInformation | This event allows you to override the Date information that is placed on the left side of the screen by default
Public Event | OnEachListItemWhenDataBound_GridNode | Called for each new GridNode when Grid is DataBound. This is a good place to set up ChildViews for SubNodes etc
Public Event | OnEachListItemWhenDataBound_TimeItem | Called for each new TimeItem in a databound layer. This is a good place to set up TimeItemTexts, or set up TimeItemLayout etc
Public Event | OnEachListItemWhenDataBound_TimeItemLink | Called for each new TimeItemLink created as a result of databinding. This is a good place to set up special link attributes based on your binded data
Public Event | OnError | This event fires when an internal error occurs
Public Event | OnGridCellSelectChanged | Fired when Selection changes
Public Event | OnGridClick | Exposed Standard event
Public Event | OnGridCustomCellDraw | Draw the content of the cell when not in edit mode
Public Event | OnGridCustomCellEditStartByKey | Edit is started by key
Public Event | OnGridCustomCellEditStartByMouse | Edit is started by clicking
Public Event | OnGridCustomCellEndEdit | Edit is finished
Public Event | OnGridCustomCellHeight | Shall return height of cell
Public Event | OnGridDoubleClick | Exposed Standard event
Public Event | OnGridDragDrop | Exposed Standard event,Drop points are in form-coordinates, use PointToClient to turn it into a local point.
Public Event | OnGridDragEnter | Exposed Standard event
Public Event | OnGridDragLeave | Exposed Standard event
Public Event | OnGridDragOver | Exposed Standard event
Public Event | OnGridKeyDown | Exposed Standard event
Public Event | OnGridKeyUp | Exposed Standard event
Public Event | OnGridMouseDown | Exposed Standard event
Public Event | OnGridMouseEnter | Exposed Standard event
Public Event | OnGridMouseHover | Exposed Standard event
Public Event | OnGridMouseLeave | Exposed Standard event
Public Event | OnGridMouseMove | Exposed Standard event
Public Event | OnGridMouseUp | Exposed Standard event
Public Event | OnGridMouseWheel | Exposed Standard event
Public Event | OnGridPaintBackground | Fired when it is time to draw the background
Public Event | OnGridPaintForeground | Fired when it is time to draw the foreground
Public Event | OnGridTopLeftChanged | Fired when Top left cell in grid changes
Public Event | OnLayer_BeforeRemove | This event fires when a TimeItem is removed from a layer.
Public Event | OnLayer_InsertComplete | This event fires when a TimeItem is added to a layer.
Public Event | OnLinkAction | Fired on Link actions
Public Event | OnNodeInserted | Fired when a node is added
Public Event | OnNodeRemove | Fired when a node is removed
Public Event | OnScaleChangeEvent | Fired when DateScaler in changed, either pan or zoom
Public Event | OnTimeItem_AfterCreateByMouse | Fired after the user has created a new time item by the EnterTimeItemCreateMode
Public Event | OnTimeItem_AfterMove | Fires after a move op is performed. This event fires as a result of a gui operation and will not fire when time items are moved by code alone.
Public Event | OnTimeItem_BeforeMove | Fired before a move op is started
Public Event | OnTimeItem_ChangeRow | Fired on row switch
Public Event | OnTimeItem_DrawRectOverride | Implement this and change the e.Rect for the given time item. You can limit the height of the time item here. Beware of the fact that it is up to you to respect SubColumns, SchemaView etc when making changes to the draw rectangle.
Public Event | OnTimeItem_Hoover | Fired while mouse is moved and possibly over a time item. This is a good place to set e.Allow false if you do not want to allow the ongoing operation. You can also limit dragging in this event by e.x=gantt1.MouseDownPoint.X; will stop move in x direction This event fires as a result of a gui operation and will not fire when time items are moved by code alone.
Public Event | OnTimeItem_LengthChange | Fires when the property Length of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewLengthValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_LinkCreate | Fired on link create, and on link change. On link change check e.LinkUnderEdit to find the link. Note: e.LinkUnderEdit==null when a new link is created
Public Event | OnTimeItem_Move | Fired on while after a move op has completed (onmouseup)
Public Event | OnTimeItem_OnBeforeMouseModeUse | Fired from within mouse down , but before we check the MouseMode. This is a good place to enter a specific mouse mode dynamically. Maybe you want to call EnterLinkCreateMode in this event if the time item is of a certain type and the user presses the shift key?
Public Event | OnTimeItem_SelectionChanged | Fired when selection has changed on time item
Public Event | OnTimeItem_StartChange | Fires when the property Start of a time item is about to change value. This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_StartMovedIntoBlockedTime | When using BlockedTime the user may move a time item so that the Start is inside BlockedTime. This can be perfectly legal and if so set e.Allow=true (default). The BlockedTime logic will calculate a Stop value for the time item taking the leading blocked time into account. But it might also be illegal; then set e.Allow=false, the logic will then move the Start time forward to the end of the blocking CalendarEntry. If the time item's start then ends up in another blocking CalendarEntry this event will fire again.
Public Event | OnTimeItem_StartValueResize | Fired on start value resize operation done
Public Event | OnTimeItem_StopChange | Fires when the property Stop of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_StopValueResize | Fired on stop value resize operation done
Public Event | OnTimeItem_UserBrushCreate | The OnTimeItem_UserBrushCreate event fires when you use TimeItemLayout.BrushKind=BrushKind.UserCreatedBrush
Public Event | OnTimeItem_UserDraw | Fired when a time item with style=user is to be drawn
Public Event | OnTimeItem_UserDrawBounds | Fired to request bounding region of a time item with style=user This is how to use the OnTimeItem_UserDrawBounds and OnTimeItem_UserDraw together: In the OnTimeItem_UserDraw event change the given Rect and Bounding Region (make them the size and shape you need as you need) In the OnTimeItem_UserDrawBounds you must do the same(assign new e.Rect and e.BoundingRegion), since this event Is fired when the logic is finding out the size of the time item for other reasons than drawing.
Public Event | OnTimeItemAreaClick | Exposed Standard event
Public Event | OnTimeItemAreaDoubleClick | Exposed Standard event
Public Event | OnTimeItemAreaDragDrop | Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point. Point p=new Point(e.X,e.Y); GanttRow gr=gantt1.GanttRowFromY(gantt1.TimeItemArea.PointToClient(p).Y);
Public Event | OnTimeItemAreaDragEnter | Exposed Standard event
Public Event | OnTimeItemAreaDragLeave | Exposed Standard event
Public Event | OnTimeItemAreaDragOver | Exposed Standard event
Public Event | OnTimeItemAreaKeyDown | Exposed Standard event
Public Event | OnTimeItemAreaKeyUp | Exposed Standard event
Public Event | OnTimeItemAreaMouseDown | Exposed Standard event
Public Event | OnTimeItemAreaMouseEnter | Exposed Standard event
Public Event | OnTimeItemAreaMouseHover | Exposed Standard event
Public Event | OnTimeItemAreaMouseLeave | Exposed Standard event
Public Event | OnTimeItemAreaMouseMove | Exposed Standard event
Public Event | OnTimeItemAreaMouseUp | Exposed Standard event
Public Event | OnTimeItemAreaMouseWheel | Exposed Standard event
Public Event | OnTimeItemAreaPaintBackground | Fired when it is time to draw the background
Public Event | OnTimeItemAreaPaintForeground | Fired when it is time to draw the foreground
Public Event | OnTimeItemAreaScalerPaintBackground | DEPRECATED, replaced with OnTimeItemAreaPaintBackground
Public Event | OnTimeItemLink_SelectionChanged | Fired when selection has changed on time item link
Public Event | OnUserDrawLink | Fired when link with drawstyle=user need to be drawn. There are two passes to link drawing. First there is the normal draw, the e.G is assigned, and you simply draw the Graphics object supplied. Second there is the selection region pass, this is recongnised by e.G==null and e.BoundingRegion is assigned. Now you can fill the region that is used to decide if a click is on a link or not.
Top

See Also

Reference

Gantt Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : Gantt Constructor

Glossary Item Box

Overload List

Overload | Description
Gantt Constructor(IContainer) | Constructor
Gantt Constructor() | Constructor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Constructor(IContainer)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > Gantt Constructor : Gantt Constructor(IContainer)

container

Glossary Item Box

Constructor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Gantt(container)
C#
public Gantt(
   IContainer container
)
Managed Extensions for C++
public: Gantt(
   IContainer* container
)
C++/CLI
public:
Gantt(
   IContainer^ container
)

Parameters

container

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > Gantt Constructor : Gantt Constructor()

Glossary Item Box

Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Gantt()
C#
public Gantt()
Managed Extensions for C++
public: Gantt();
C++/CLI
public:
Gantt();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Gantt Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Gantt Class

Glossary Item Box

For a list of all members of this type, see Gantt members.

Public Methods

 | Name | Description
Public Method | CheckIfStartInBlockedTime | When BlockedTimeCalculatedStop is used there may be situations where the start time of a time item is placed inside blocked time. This can be a perfectly valid case in some situations, but in others it may be illegal. To handle this the event OnTimeItem_StartMovedIntoBlockedTime is fired for you to verify. The event is fired from within this method, and if you want to do the same checks after changing the start time in code, as the component does when the user changes the start time, you will need to call this method.
Public Method | ClearSelected | Clear all selected time items
Public Method | EnterLinkCreateMode | When true clicks will be handled as link create and not as move or resize operation in timeitem area
Public Method | EnterTimeItemCreateMode | When true clicks will be handled as time item create and not as move or resize operation in timeitem area
Public Method | FindTimeItemLinkUserReference | Loops thru all time item links and compare x with TimeItem.UserReference.
Public Method | FindTimeItemUserReference | Loops thru all time items and compare x with TimeItem.UserReference.
static (Shared in Visual Basic) | GanttRowFromGridNode | Find GanttRow from GridNode
Public Method | GanttRowFromPoint | Find row from point, replaces GanttRowFromY. The point sent in shall be in TimeItemArea-coordinates
Public Method | GanttRowFromY | Deprecated. Will be removed. Warning does not support ScheduleMode. Use GanttRowFromPoint instead Find row from pixel.
Public Method | GetSelectedTimeItems | Overloaded. Returns currently selected time items owned by gridnodes currently on screen
Public Method | HandleOnTimeItem_AfterCreateByMouseEvent | Executes the OnTimeItem_AfterCreateByMouse event, exposed for use by the Gantt_ASP mainly
Public Method | MouseMoveCancel | Cancels an on going mouse move operation. Use this to cancel out the default behavior.
Public Method | PerformActionForUserMoveOfSingleTimeItem | Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.
Public Method | PerformActionForUserResizeEastOfSingleTimeItem | Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.
Public Method | PrintEnd | Print is reset
Public Method | PrintInit | Initializes the print process
Public Method | PrintPage | Overloaded. Prints a page. Note that GridWith=zero is not supported, if you need to suppress the grid in printing please use the overloaded PrintPage call with the suppressGrid=true.
Public Method | RegisterRuntimeKey | Call this early in your application to register the runtime key. The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand
Public Method | RuntimeKeyHelp_Assembly | Call this to get hints on what values to put into the registration form to get the runtimekey...
Public Method | RuntimeKeyOnTop | If called the notice about runtime key will be placed in the upper right corner (Gantt_ASP)
Public Method | ScheduleModeAgnostic | Based on the current ScheduleMode the rect is transformed to the standard ScheduleMode=false representation
Public Method | ScheduleModeAware | Based on the current ScheduleMode the rect is transformed from a ScheduleMode Agnostic rect to a SchedulMode aware rect
Public Method | SetMouseMoveKind | Sets the mousemovekind
Public Method | TimeItemFromPoint | Overloaded. Find time item from pixel
Public Method | TimeItemIdentityHash | This HashTable keeps all TimeItems that has been assigned an Identity value. The Hash his used internally to fix up databound timeitemlinks
Public Method | UpdateMultiSelect | Handles multi select behavior for this time item, based on held control keys
Top

See Also

Reference

Gantt Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CheckIfStartInBlockedTime Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : CheckIfStartInBlockedTime Method

ti

Glossary Item Box

When BlockedTimeCalculatedStop is used there may be situations where the start time of a time item is placed inside blocked time. This can be a perfectly valid case in some situations, but in others it may be illegal. To handle this the event OnTimeItem_StartMovedIntoBlockedTime is fired for you to verify. The event is fired from within this method, and if you want to do the same checks after changing the start time in code, as the component does when the user changes the start time, you will need to call this method.

Syntax

Visual Basic (Declaration)
Public Sub CheckIfStartInBlockedTime( _
   ByVal ti As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim ti As TimeItem

instance.CheckIfStartInBlockedTime(ti)
C#
public void CheckIfStartInBlockedTime(
   TimeItem ti
)
Managed Extensions for C++
public: void CheckIfStartInBlockedTime(
   TimeItem* ti
)
C++/CLI
public:
void CheckIfStartInBlockedTime(
   TimeItem^ ti
)

Parameters

ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ClearSelected Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ClearSelected Method

Glossary Item Box

Clear all selected time items

Syntax

Visual Basic (Declaration)
Public Sub ClearSelected()
Visual Basic (Usage) Copy Code
Dim instance As Gantt

instance.ClearSelected()
C#
public void ClearSelected()
Managed Extensions for C++
public: void ClearSelected();
C++/CLI
public:
void ClearSelected();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EnterLinkCreateMode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : EnterLinkCreateMode Method

value

Glossary Item Box

When true clicks will be handled as link create and not as move or resize operation in timeitem area

Syntax

Visual Basic (Declaration)
Public Sub EnterLinkCreateMode( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.EnterLinkCreateMode(value)
C#
public void EnterLinkCreateMode(
   bool value
)
Managed Extensions for C++
public: void EnterLinkCreateMode(
   bool value
)
C++/CLI
public:
void EnterLinkCreateMode(
   bool value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EnterTimeItemCreateMode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : EnterTimeItemCreateMode Method

value
aTimeItemLayoutForNewTimeItem
aLayerIndexForNewTimeItem

Glossary Item Box

When true clicks will be handled as time item create and not as move or resize operation in timeitem area

Syntax

Visual Basic (Declaration)
Public Sub EnterTimeItemCreateMode( _
   ByVal value As Boolean, _
   ByVal aTimeItemLayoutForNewTimeItem As TimeItemLayout, _
   ByVal aLayerIndexForNewTimeItem As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean
Dim aTimeItemLayoutForNewTimeItem As TimeItemLayout
Dim aLayerIndexForNewTimeItem As Integer

instance.EnterTimeItemCreateMode(value, aTimeItemLayoutForNewTimeItem, aLayerIndexForNewTimeItem)
C#
public void EnterTimeItemCreateMode(
   bool value,
   TimeItemLayout aTimeItemLayoutForNewTimeItem,
   int aLayerIndexForNewTimeItem
)
Managed Extensions for C++
public: void EnterTimeItemCreateMode(
   bool value,
   TimeItemLayout* aTimeItemLayoutForNewTimeItem,
   int aLayerIndexForNewTimeItem
)
C++/CLI
public:
void EnterTimeItemCreateMode(
   bool value,
   TimeItemLayout^ aTimeItemLayoutForNewTimeItem,
   int aLayerIndexForNewTimeItem
)

Parameters

value
aTimeItemLayoutForNewTimeItem
aLayerIndexForNewTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FindTimeItemLinkUserReference Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : FindTimeItemLinkUserReference Method

x

Glossary Item Box

Loops thru all time item links and compare x with TimeItem.UserReference.

Syntax

Visual Basic (Declaration)
Public Function FindTimeItemLinkUserReference( _
   ByVal x As Object _
) As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim x As Object
Dim value As TimeItemLink

value = instance.FindTimeItemLinkUserReference(x)
C#
public TimeItemLink FindTimeItemLinkUserReference(
   object x
)
Managed Extensions for C++
public: TimeItemLink* FindTimeItemLinkUserReference(
   Object* x
)
C++/CLI
public:
TimeItemLink^ FindTimeItemLinkUserReference(
   Object^ x
)

Parameters

x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FindTimeItemUserReference Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : FindTimeItemUserReference Method

x

Glossary Item Box

Loops thru all time items and compare x with TimeItem.UserReference.

Syntax

Visual Basic (Declaration)
Public Function FindTimeItemUserReference( _
   ByVal x As Object _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim x As Object
Dim value As TimeItem

value = instance.FindTimeItemUserReference(x)
C#
public TimeItem FindTimeItemUserReference(
   object x
)
Managed Extensions for C++
public: TimeItem* FindTimeItemUserReference(
   Object* x
)
C++/CLI
public:
TimeItem^ FindTimeItemUserReference(
   Object^ x
)

Parameters

x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRowFromGridNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GanttRowFromGridNode Method

aNode

Glossary Item Box

Find GanttRow from GridNode

Syntax

Visual Basic (Declaration)
Public Shared Function GanttRowFromGridNode( _
   ByVal aNode As GridNode _
) As GanttRow
Visual Basic (Usage) Copy Code
Dim aNode As GridNode
Dim value As GanttRow

value = Gantt.GanttRowFromGridNode(aNode)
C#
public static GanttRow GanttRowFromGridNode(
   GridNode aNode
)
Managed Extensions for C++
public: static GanttRow* GanttRowFromGridNode(
   GridNode* aNode
)
C++/CLI
public:
static GanttRow^ GanttRowFromGridNode(
   GridNode^ aNode
)

Parameters

aNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRowFromPoint Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GanttRowFromPoint Method

p

Glossary Item Box

Find row from point, replaces GanttRowFromY. The point sent in shall be in TimeItemArea-coordinates

Syntax

Visual Basic (Declaration)
Public Function GanttRowFromPoint( _
   ByVal p As Point _
) As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim p As Point
Dim value As GanttRow

value = instance.GanttRowFromPoint(p)
C#
public GanttRow GanttRowFromPoint(
   Point p
)
Managed Extensions for C++
public: GanttRow* GanttRowFromPoint(
   Point p
)
C++/CLI
public:
GanttRow^ GanttRowFromPoint(
   Point p
)

Parameters

p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRowFromY Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GanttRowFromY Method

y

Glossary Item Box

Deprecated. Will be removed. Warning does not support ScheduleMode. Use GanttRowFromPoint instead Find row from pixel.

Syntax

Visual Basic (Declaration)
Public Function GanttRowFromY( _
   ByVal y As Integer _
) As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim y As Integer
Dim value As GanttRow

value = instance.GanttRowFromY(y)
C#
public GanttRow GanttRowFromY(
   int y
)
Managed Extensions for C++
public: GanttRow* GanttRowFromY(
   int y
)
C++/CLI
public:
GanttRow^ GanttRowFromY(
   int y
)

Parameters

y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetSelectedTimeItems Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GetSelectedTimeItems Method

Glossary Item Box

Returns currently selected time items owned by gridnodes currently on screen

Overload List

Overload | Description
GetSelectedTimeItems() | Returns currently selected time items owned by gridnodes currently on screen
GetSelectedTimeItems(Boolean) | Returns currently selected time items, if OnlyCurrentlyOnScreen=true time items owned by gridnodes currently on screen are returned

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetSelectedTimeItems() Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > GetSelectedTimeItems Method : GetSelectedTimeItems() Method

Glossary Item Box

Returns currently selected time items owned by gridnodes currently on screen

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSelectedTimeItems() As TimeItem()
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value() As TimeItem

value = instance.GetSelectedTimeItems()
C#
public TimeItem[] GetSelectedTimeItems()
Managed Extensions for C++
public: TimeItem*[]* GetSelectedTimeItems();
C++/CLI
public:
array<TimeItem^>^ GetSelectedTimeItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetSelectedTimeItems(Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > GetSelectedTimeItems Method : GetSelectedTimeItems(Boolean) Method

onlyCurrentlyOnScreen

Glossary Item Box

Returns currently selected time items, if OnlyCurrentlyOnScreen=true time items owned by gridnodes currently on screen are returned

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSelectedTimeItems( _
   ByVal onlyCurrentlyOnScreen As Boolean _
) As TimeItem()
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim onlyCurrentlyOnScreen As Boolean
Dim value() As TimeItem

value = instance.GetSelectedTimeItems(onlyCurrentlyOnScreen)
C#
public TimeItem[] GetSelectedTimeItems(
   bool onlyCurrentlyOnScreen
)
Managed Extensions for C++
public: TimeItem*[]* GetSelectedTimeItems(
   bool onlyCurrentlyOnScreen
)
C++/CLI
public:
array<TimeItem^>^ GetSelectedTimeItems(
   bool onlyCurrentlyOnScreen
)

Parameters

onlyCurrentlyOnScreen

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
HandleOnTimeItem_AfterCreateByMouseEvent Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : HandleOnTimeItem_AfterCreateByMouseEvent Method

newTimeItemToBeCreated

Glossary Item Box

Executes the OnTimeItem_AfterCreateByMouse event, exposed for use by the Gantt_ASP mainly

Syntax

Visual Basic (Declaration)
Public Sub HandleOnTimeItem_AfterCreateByMouseEvent( _
   ByVal newTimeItemToBeCreated As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim newTimeItemToBeCreated As TimeItem

instance.HandleOnTimeItem_AfterCreateByMouseEvent(newTimeItemToBeCreated)
C#
public void HandleOnTimeItem_AfterCreateByMouseEvent(
   TimeItem newTimeItemToBeCreated
)
Managed Extensions for C++
public: void HandleOnTimeItem_AfterCreateByMouseEvent(
   TimeItem* newTimeItemToBeCreated
)
C++/CLI
public:
void HandleOnTimeItem_AfterCreateByMouseEvent(
   TimeItem^ newTimeItemToBeCreated
)

Parameters

newTimeItemToBeCreated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseMoveCancel Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : MouseMoveCancel Method

Glossary Item Box

Cancels an on going mouse move operation. Use this to cancel out the default behavior.

Syntax

Visual Basic (Declaration)
Public Sub MouseMoveCancel()
Visual Basic (Usage) Copy Code
Dim instance As Gantt

instance.MouseMoveCancel()
C#
public void MouseMoveCancel()
Managed Extensions for C++
public: void MouseMoveCancel();
C++/CLI
public:
void MouseMoveCancel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PerformActionForUserMoveOfSingleTimeItem Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PerformActionForUserMoveOfSingleTimeItem Method

ti
offset
rect

Glossary Item Box

Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.

Syntax

Visual Basic (Declaration)
Public Sub PerformActionForUserMoveOfSingleTimeItem( _
   ByVal ti As TimeItem, _
   ByVal offset As Point, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim ti As TimeItem
Dim offset As Point
Dim rect As Rectangle

instance.PerformActionForUserMoveOfSingleTimeItem(ti, offset, rect)
C#
public void PerformActionForUserMoveOfSingleTimeItem(
   TimeItem ti,
   Point offset,
   Rectangle rect
)
Managed Extensions for C++
public: void PerformActionForUserMoveOfSingleTimeItem(
   TimeItem* ti,
   Point offset,
   Rectangle rect
)
C++/CLI
public:
void PerformActionForUserMoveOfSingleTimeItem(
   TimeItem^ ti,
   Point offset,
   Rectangle rect
)

Parameters

ti
offset
rect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PerformActionForUserResizeEastOfSingleTimeItem Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PerformActionForUserResizeEastOfSingleTimeItem Method

mouseFocusedTimeItem
diff

Glossary Item Box

Made public so that Ajax Gantt can call thru for client side move ops. There will be no or little reason for anyone else to call this method.

Syntax

Visual Basic (Declaration)
Public Sub PerformActionForUserResizeEastOfSingleTimeItem( _
   ByVal mouseFocusedTimeItem As TimeItem, _
   ByVal diff As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim mouseFocusedTimeItem As TimeItem
Dim diff As TimeSpan

instance.PerformActionForUserResizeEastOfSingleTimeItem(mouseFocusedTimeItem, diff)
C#
public void PerformActionForUserResizeEastOfSingleTimeItem(
   TimeItem mouseFocusedTimeItem,
   TimeSpan diff
)
Managed Extensions for C++
public: void PerformActionForUserResizeEastOfSingleTimeItem(
   TimeItem* mouseFocusedTimeItem,
   TimeSpan diff
)
C++/CLI
public:
void PerformActionForUserResizeEastOfSingleTimeItem(
   TimeItem^ mouseFocusedTimeItem,
   TimeSpan diff
)

Parameters

mouseFocusedTimeItem
diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintEnd Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PrintEnd Method

Glossary Item Box

Print is reset

Syntax

Visual Basic (Declaration)
Public Sub PrintEnd()
Visual Basic (Usage) Copy Code
Dim instance As Gantt

instance.PrintEnd()
C#
public void PrintEnd()
Managed Extensions for C++
public: void PrintEnd();
C++/CLI
public:
void PrintEnd();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintInit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PrintInit Method

aStartNode

Glossary Item Box

Initializes the print process

Syntax

Visual Basic (Declaration)
Public Sub PrintInit( _
   ByVal aStartNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim aStartNode As GridNode

instance.PrintInit(aStartNode)
C#
public void PrintInit(
   GridNode aStartNode
)
Managed Extensions for C++
public: void PrintInit(
   GridNode* aStartNode
)
C++/CLI
public:
void PrintInit(
   GridNode^ aStartNode
)

Parameters

aStartNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PrintPage Method

Glossary Item Box

Prints a page. Note that GridWith=zero is not supported, if you need to suppress the grid in printing please use the overloaded PrintPage call with the suppressGrid=true.

Overload List

Overload | Description
PrintPage(Graphics,Rectangle,Int32,Int32,Boolean) | Prints a page. Note that GridWith=zero is not supported, if you need to suppress the grid in printing please use the overloaded PrintPage call with the suppressGrid=true.
PrintPage(Graphics,Rectangle,Int32,Int32,Boolean,Boolean,Boolean) | Prints a page with an option to suppress the grid. The GridWidth is still used to calculate the row heights that might depend on things like row wrap and different MinHeights on cells.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage(Graphics,Rectangle,Int32,Int32,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > PrintPage Method : PrintPage(Graphics,Rectangle,Int32,Int32,Boolean) Method

G
Margins
aGridWidth
aDateScalerHeight
HasMorePages

Glossary Item Box

Prints a page. Note that GridWith=zero is not supported, if you need to suppress the grid in printing please use the overloaded PrintPage call with the suppressGrid=true.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle, _
   ByVal aGridWidth As Integer, _
   ByVal aDateScalerHeight As Integer, _
   ByRef HasMorePages As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim G As Graphics
Dim Margins As Rectangle
Dim aGridWidth As Integer
Dim aDateScalerHeight As Integer
Dim HasMorePages As Boolean

instance.PrintPage(G, Margins, aGridWidth, aDateScalerHeight, HasMorePages)
C#
public void PrintPage(
   Graphics G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   ref bool HasMorePages
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   ref bool HasMorePages
)
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   bool% HasMorePages
)

Parameters

G
Margins
aGridWidth
aDateScalerHeight
HasMorePages

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage(Graphics,Rectangle,Int32,Int32,Boolean,Boolean,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > PrintPage Method : PrintPage(Graphics,Rectangle,Int32,Int32,Boolean,Boolean,Boolean) Method

G
Margins
aGridWidth
aDateScalerHeight
suppressGrid
HasMorePages
doNotStepGridWillPrintTheSameRowsOneMoreTime

Glossary Item Box

Prints a page with an option to suppress the grid. The GridWidth is still used to calculate the row heights that might depend on things like row wrap and different MinHeights on cells.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle, _
   ByVal aGridWidth As Integer, _
   ByVal aDateScalerHeight As Integer, _
   ByVal suppressGrid As Boolean, _
   ByRef HasMorePages As Boolean, _
   ByVal doNotStepGridWillPrintTheSameRowsOneMoreTime As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim G As Graphics
Dim Margins As Rectangle
Dim aGridWidth As Integer
Dim aDateScalerHeight As Integer
Dim suppressGrid As Boolean
Dim HasMorePages As Boolean
Dim doNotStepGridWillPrintTheSameRowsOneMoreTime As Boolean

instance.PrintPage(G, Margins, aGridWidth, aDateScalerHeight, suppressGrid, HasMorePages, doNotStepGridWillPrintTheSameRowsOneMoreTime)
C#
public void PrintPage(
   Graphics G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   bool suppressGrid,
   ref bool HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   bool suppressGrid,
   ref bool HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins,
   int aGridWidth,
   int aDateScalerHeight,
   bool suppressGrid,
   bool% HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)

Parameters

G
Margins
aGridWidth
aDateScalerHeight
suppressGrid
HasMorePages
doNotStepGridWillPrintTheSameRowsOneMoreTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
RegisterRuntimeKey Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : RegisterRuntimeKey Method

runtimekey
registrationname

Glossary Item Box

Call this early in your application to register the runtime key. The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand

Syntax

Visual Basic (Declaration)
Public Function RegisterRuntimeKey( _
   ByVal runtimekey As String, _
   ByVal registrationname As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim runtimekey As String
Dim registrationname As String
Dim value As Boolean

value = instance.RegisterRuntimeKey(runtimekey, registrationname)
C#
public bool RegisterRuntimeKey(
   string runtimekey,
   string registrationname
)
Managed Extensions for C++
public: bool RegisterRuntimeKey(
   string* runtimekey,
   string* registrationname
)
C++/CLI
public:
bool RegisterRuntimeKey(
   String^ runtimekey,
   String^ registrationname
)

Parameters

runtimekey
registrationname

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RuntimeKeyHelp_Assembly Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : RuntimeKeyHelp_Assembly Method

Glossary Item Box

Call this to get hints on what values to put into the registration form to get the runtimekey...

Syntax

Visual Basic (Declaration)
Public Function RuntimeKeyHelp_Assembly() As String()
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value() As String

value = instance.RuntimeKeyHelp_Assembly()
C#
public string[] RuntimeKeyHelp_Assembly()
Managed Extensions for C++
public: string*[]* RuntimeKeyHelp_Assembly();
C++/CLI
public:
array<String^>^ RuntimeKeyHelp_Assembly();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RuntimeKeyOnTop Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : RuntimeKeyOnTop Method

Glossary Item Box

If called the notice about runtime key will be placed in the upper right corner (Gantt_ASP)

Syntax

Visual Basic (Declaration)
Public Sub RuntimeKeyOnTop()
Visual Basic (Usage) Copy Code
Dim instance As Gantt

instance.RuntimeKeyOnTop()
C#
public void RuntimeKeyOnTop()
Managed Extensions for C++
public: void RuntimeKeyOnTop();
C++/CLI
public:
void RuntimeKeyOnTop();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScheduleModeAgnostic Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ScheduleModeAgnostic Method

r

Glossary Item Box

Based on the current ScheduleMode the rect is transformed to the standard ScheduleMode=false representation

Syntax

Visual Basic (Declaration)
Public Function ScheduleModeAgnostic( _
   ByVal r As Rectangle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim r As Rectangle
Dim value As Rectangle

value = instance.ScheduleModeAgnostic(r)
C#
public Rectangle ScheduleModeAgnostic(
   Rectangle r
)
Managed Extensions for C++
public: Rectangle ScheduleModeAgnostic(
   Rectangle r
)
C++/CLI
public:
Rectangle ScheduleModeAgnostic(
   Rectangle r
)

Parameters

r

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScheduleModeAware Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ScheduleModeAware Method

r

Glossary Item Box

Based on the current ScheduleMode the rect is transformed from a ScheduleMode Agnostic rect to a SchedulMode aware rect

Syntax

Visual Basic (Declaration)
Public Function ScheduleModeAware( _
   ByVal r As Rectangle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim r As Rectangle
Dim value As Rectangle

value = instance.ScheduleModeAware(r)
C#
public Rectangle ScheduleModeAware(
   Rectangle r
)
Managed Extensions for C++
public: Rectangle ScheduleModeAware(
   Rectangle r
)
C++/CLI
public:
Rectangle ScheduleModeAware(
   Rectangle r
)

Parameters

r

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SetMouseMoveKind Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : SetMouseMoveKind Method

value

Glossary Item Box

Sets the mousemovekind

Syntax

Visual Basic (Declaration)
Public Sub SetMouseMoveKind( _
   ByVal value As MouseMoveKind _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As MouseMoveKind

instance.SetMouseMoveKind(value)
C#
public void SetMouseMoveKind(
   MouseMoveKind value
)
Managed Extensions for C++
public: void SetMouseMoveKind(
   MouseMoveKind value
)
C++/CLI
public:
void SetMouseMoveKind(
   MouseMoveKind value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemFromPoint Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemFromPoint Method

Glossary Item Box

Find time item from pixel

Overload List

Overload | Description
TimeItemFromPoint(Point) | Find time item from pixel
TimeItemFromPoint(Int32,Int32) | Find time item from pixel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemFromPoint(Point) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > TimeItemFromPoint Method : TimeItemFromPoint(Point) Method

p

Glossary Item Box

Find time item from pixel

Syntax

Visual Basic (Declaration)
Public Overloads Function TimeItemFromPoint( _
   ByVal p As Point _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim p As Point
Dim value As TimeItem

value = instance.TimeItemFromPoint(p)
C#
public TimeItem TimeItemFromPoint(
   Point p
)
Managed Extensions for C++
public: TimeItem* TimeItemFromPoint(
   Point p
)
C++/CLI
public:
TimeItem^ TimeItemFromPoint(
   Point p
)

Parameters

p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemFromPoint(Int32,Int32) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class > TimeItemFromPoint Method : TimeItemFromPoint(Int32,Int32) Method

x
y

Glossary Item Box

Find time item from pixel

Syntax

Visual Basic (Declaration)
Public Overloads Function TimeItemFromPoint( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim x As Integer
Dim y As Integer
Dim value As TimeItem

value = instance.TimeItemFromPoint(x, y)
C#
public TimeItem TimeItemFromPoint(
   int x,
   int y
)
Managed Extensions for C++
public: TimeItem* TimeItemFromPoint(
   int x,
   int y
)
C++/CLI
public:
TimeItem^ TimeItemFromPoint(
   int x,
   int y
)

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemIdentityHash Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemIdentityHash Method

Glossary Item Box

This HashTable keeps all TimeItems that has been assigned an Identity value. The Hash his used internally to fix up databound timeitemlinks

Syntax

Visual Basic (Declaration)
Public Function TimeItemIdentityHash() As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Hashtable

value = instance.TimeItemIdentityHash()
C#
public Hashtable TimeItemIdentityHash()
Managed Extensions for C++
public: Hashtable* TimeItemIdentityHash();
C++/CLI
public:
Hashtable^ TimeItemIdentityHash();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UpdateMultiSelect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : UpdateMultiSelect Method

timeItem

Glossary Item Box

Handles multi select behavior for this time item, based on held control keys

Syntax

Visual Basic (Declaration)
Public Sub UpdateMultiSelect( _
   ByVal timeItem As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim timeItem As TimeItem

instance.UpdateMultiSelect(timeItem)
C#
public void UpdateMultiSelect(
   TimeItem timeItem
)
Managed Extensions for C++
public: void UpdateMultiSelect(
   TimeItem* timeItem
)
C++/CLI
public:
void UpdateMultiSelect(
   TimeItem^ timeItem
)

Parameters

timeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Gantt Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Gantt Class

Glossary Item Box

For a list of all members of this type, see Gantt members.

Public Properties

 | Name | Description
Public Property | AllowAreaSelect | Enables time item selection by dragging out a square area
Public Property | AllowAreaSelectPartlyInside | When AllowAreaSelect is true this property controls if the TimeItem must have both Start and Stop inside the rect in order to be selected
Public Property | AutoScrollGridEnable | Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...
Public Property | AutoScrollTimeEnable | Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...
Public Property | CalcGridAndTimeOffset | Returns the difference in start position between Grid and TimeItem area
Public Property | Calendars | The Gantt chart can have multiple Calendars. A Calendar can have multiple CalendarEntry-objects. Each CalendarEntry has a Start and Stop date and an optional Frequency. The CalendarEntries can be used in different ways in the Gantt chart please see explantion on CalenderEntry class.
Public Property | CollisionDetectionSyncron | If false (default) the collision detection for time items will run asynchronously. When using the Gantt in Gantt_ASP you will probably want to set this to true so that collision detections always are resolved before image creation.
Public Property | ContextMenuStripTimeItemArea | ContextMenu of the Grid
Public Property | DateScaler | The DateScale
Public Property | DateScalerHeight | The height of the DateScaler in the Gantt
Public Property | DateScalerProperties | Some DateScale properties for design time
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | FocusedTimeItem | Returns currently focused time item
Public Property | Grid | The grid
Public Property | GridProperties | Some grid properties for design time
Public Property | GridWidth | The widht of the grid in the Gantt. When in ScheduleMode this property controls the height of the column heads
Public Property | ImageList | The image list is used for time items with images
Public Property | MouseDownPoint | This is the point were the mouse was clicked, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item See also MouseMovePoint
Public Property | MouseMoveKind | Tells what the mouse is used for at this instant
Public Property | MouseMovePoint | This is the current point were the mouse is, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item. See also MouseDownPoint.
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | ResizeAreaSize | The Active area that will react to resize events
Public Property | ScheduleMode | ScheduleMode controls the layout. Set ScheduleMode to true and the Gantt turns into a Schedule
Public Property | Splitter | The Splitter between time item area and grid
Public Property | TimeItemArea | The Time item area
Public Property | TimeItemLayouts |
Public Property | TimeItemLinks | Returns all time item links
Public Property | TimeItemTextLayouts | The textlayouts in the gantt
Public Property | TimeMoveMarkerDate | When the user moves a time item you can show move markers that helps the user to see from where the time item is moving and where it will end up if he or she drops it
Public Property | TimeMoveMarkerRow | When the user moves a time item you can show move markers that helps the user to see from what row the time item is moving and where it will end up if he or she drops it
Public Property | TodayLine | Vertical line drawn on Now!
Public Property | TodayLineColor | todayLine color, defaults to Black
Public Property | TurnOffAllCollisionDetect | If set all collision detection is turned off, not only for one row, for all rows. Primarily used to speed up load when using syncron collision detection.
Public Property | VerticalDayStripes | Vertical stripes on certain days
Public Property | VerticalDayStripes_Days | VerticalDayStripes set to true, this property then chooses the days, sat and sun default
Public Property | VerticalDayStripesColor | VerticalDayStripes color, defaults to
Public Property | VerticalDayStripesHighestResolution | Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property | VerticalDayStripesLowestResolution | Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;
Public Property | VerticalLines | Vertical lines on long scale intervall
Public Property | VerticalLinesColor | VerticalLine color, defaults to Black
Top

See Also

Reference

Gantt Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowAreaSelect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : AllowAreaSelect Property

Glossary Item Box

Enables time item selection by dragging out a square area

Syntax

Visual Basic (Declaration)
Public Property AllowAreaSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.AllowAreaSelect = value

value = instance.AllowAreaSelect
C#
public bool AllowAreaSelect {get; set;}
Managed Extensions for C++
public: __property bool get_AllowAreaSelect();
public: __property void set_AllowAreaSelect(
   bool value
);
C++/CLI
public:
property bool AllowAreaSelect {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowAreaSelectPartlyInside Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : AllowAreaSelectPartlyInside Property

Glossary Item Box

When AllowAreaSelect is true this property controls if the TimeItem must have both Start and Stop inside the rect in order to be selected

Syntax

Visual Basic (Declaration)
Public Property AllowAreaSelectPartlyInside As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.AllowAreaSelectPartlyInside = value

value = instance.AllowAreaSelectPartlyInside
C#
public bool AllowAreaSelectPartlyInside {get; set;}
Managed Extensions for C++
public: __property bool get_AllowAreaSelectPartlyInside();
public: __property void set_AllowAreaSelectPartlyInside(
   bool value
);
C++/CLI
public:
property bool AllowAreaSelectPartlyInside {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AutoScrollGridEnable Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : AutoScrollGridEnable Property

Glossary Item Box

Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...

Syntax

Visual Basic (Declaration)
Public Property AutoScrollGridEnable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.AutoScrollGridEnable = value

value = instance.AutoScrollGridEnable
C#
public bool AutoScrollGridEnable {get; set;}
Managed Extensions for C++
public: __property bool get_AutoScrollGridEnable();
public: __property void set_AutoScrollGridEnable(
   bool value
);
C++/CLI
public:
property bool AutoScrollGridEnable {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AutoScrollTimeEnable Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : AutoScrollTimeEnable Property

Glossary Item Box

Autoscroll happens when you click the mouse in the time item area and drag it outside the time item area. This function is good for users that need to scroll a new position into view, but there are situations when you do not want this behaviour; set this property to false...

Syntax

Visual Basic (Declaration)
Public Property AutoScrollTimeEnable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.AutoScrollTimeEnable = value

value = instance.AutoScrollTimeEnable
C#
public bool AutoScrollTimeEnable {get; set;}
Managed Extensions for C++
public: __property bool get_AutoScrollTimeEnable();
public: __property void set_AutoScrollTimeEnable(
   bool value
);
C++/CLI
public:
property bool AutoScrollTimeEnable {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcGridAndTimeOffset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : CalcGridAndTimeOffset Property

Glossary Item Box

Returns the difference in start position between Grid and TimeItem area

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcGridAndTimeOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Integer

value = instance.CalcGridAndTimeOffset
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcGridAndTimeOffset {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcGridAndTimeOffset();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcGridAndTimeOffset {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendars Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : Calendars Property

Glossary Item Box

The Gantt chart can have multiple Calendars. A Calendar can have multiple CalendarEntry-objects. Each CalendarEntry has a Start and Stop date and an optional Frequency. The CalendarEntries can be used in different ways in the Gantt chart please see explantion on CalenderEntry class.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property Calendars As CalendarCollection
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As CalendarCollection

value = instance.Calendars
C#
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public CalendarCollection Calendars {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property CalendarCollection* get_Calendars();
C++/CLI
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property CalendarCollection^ Calendars {
   CalendarCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetectionSyncron Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : CollisionDetectionSyncron Property

Glossary Item Box

If false (default) the collision detection for time items will run asynchronously. When using the Gantt in Gantt_ASP you will probably want to set this to true so that collision detections always are resolved before image creation.

Syntax

Visual Basic (Declaration)
Public Property CollisionDetectionSyncron As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.CollisionDetectionSyncron = value

value = instance.CollisionDetectionSyncron
C#
public bool CollisionDetectionSyncron {get; set;}
Managed Extensions for C++
public: __property bool get_CollisionDetectionSyncron();
public: __property void set_CollisionDetectionSyncron(
   bool value
);
C++/CLI
public:
property bool CollisionDetectionSyncron {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContextMenuStripTimeItemArea Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ContextMenuStripTimeItemArea Property

Glossary Item Box

ContextMenu of the Grid

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStripTimeItemArea As ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As ContextMenuStrip

instance.ContextMenuStripTimeItemArea = value

value = instance.ContextMenuStripTimeItemArea
C#
public ContextMenuStrip ContextMenuStripTimeItemArea {get; set;}
Managed Extensions for C++
public: __property ContextMenuStrip* get_ContextMenuStripTimeItemArea();
public: __property void set_ContextMenuStripTimeItemArea(
   ContextMenuStrip* value
);
C++/CLI
public:
property ContextMenuStrip^ ContextMenuStripTimeItemArea {
   ContextMenuStrip^ get();
   void set (    ContextMenuStrip^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaler Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : DateScaler Property

Glossary Item Box

The DateScale

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property DateScaler As DateScaler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As DateScaler

value = instance.DateScaler
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public DateScaler DateScaler {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property DateScaler* get_DateScaler();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property DateScaler^ DateScaler {
   DateScaler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerHeight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : DateScalerHeight Property

Glossary Item Box

The height of the DateScaler in the Gantt

Syntax

Visual Basic (Declaration)
Public Property DateScalerHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Integer

instance.DateScalerHeight = value

value = instance.DateScalerHeight
C#
public int DateScalerHeight {get; set;}
Managed Extensions for C++
public: __property int get_DateScalerHeight();
public: __property void set_DateScalerHeight(
   int value
);
C++/CLI
public:
property int DateScalerHeight {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerProperties Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : DateScalerProperties Property

Glossary Item Box

Some DateScale properties for design time

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property DateScalerProperties As DateScalerProperties
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As DateScalerProperties

value = instance.DateScalerProperties
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public DateScalerProperties DateScalerProperties {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property DateScalerProperties* get_DateScalerProperties();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property DateScalerProperties^ DateScalerProperties {
   DateScalerProperties^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawPyjamas Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : DrawPyjamas Property

Glossary Item Box

Decide if the stripes should be draw at all

Syntax

Visual Basic (Declaration)
Public Property DrawPyjamas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.DrawPyjamas = value

value = instance.DrawPyjamas
C#
public bool DrawPyjamas {get; set;}
Managed Extensions for C++
public: __property bool get_DrawPyjamas();
public: __property void set_DrawPyjamas(
   bool value
);
C++/CLI
public:
property bool DrawPyjamas {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FocusedTimeItem Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : FocusedTimeItem Property

Glossary Item Box

Returns currently focused time item

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property FocusedTimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As TimeItem

instance.FocusedTimeItem = value

value = instance.FocusedTimeItem
C#
[BrowsableAttribute(false)]
public TimeItem FocusedTimeItem {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TimeItem* get_FocusedTimeItem();
public: __property void set_FocusedTimeItem(
   TimeItem* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property TimeItem^ FocusedTimeItem {
   TimeItem^ get();
   void set (    TimeItem^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Grid Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : Grid Property

Glossary Item Box

The grid

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property Grid As Grid
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Grid

value = instance.Grid
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Grid Grid {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Grid* get_Grid();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Grid^ Grid {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridProperties Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GridProperties Property

Glossary Item Box

Some grid properties for design time

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property GridProperties As GridProperties
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As GridProperties

value = instance.GridProperties
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public GridProperties GridProperties {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property GridProperties* get_GridProperties();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property GridProperties^ GridProperties {
   GridProperties^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridWidth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : GridWidth Property

Glossary Item Box

The widht of the grid in the Gantt. When in ScheduleMode this property controls the height of the column heads

Syntax

Visual Basic (Declaration)
Public Property GridWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Integer

instance.GridWidth = value

value = instance.GridWidth
C#
public int GridWidth {get; set;}
Managed Extensions for C++
public: __property int get_GridWidth();
public: __property void set_GridWidth(
   int value
);
C++/CLI
public:
property int GridWidth {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ImageList Property

Glossary Item Box

The image list is used for time items with images

Syntax

Visual Basic (Declaration)
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
public ImageList ImageList {get; set;}
Managed Extensions for C++
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (    ImageList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseDownPoint Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : MouseDownPoint Property

Glossary Item Box

This is the point were the mouse was clicked, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item See also MouseMovePoint

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseDownPoint As Point
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Point

value = instance.MouseDownPoint
C#
public Point MouseDownPoint {get;}
Managed Extensions for C++
public: __property Point get_MouseDownPoint();
C++/CLI
public:
property Point MouseDownPoint {
   Point get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseMoveKind Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : MouseMoveKind Property

Glossary Item Box

Tells what the mouse is used for at this instant

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseMoveKind As MouseMoveKind
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As MouseMoveKind

value = instance.MouseMoveKind
C#
public MouseMoveKind MouseMoveKind {get;}
Managed Extensions for C++
public: __property MouseMoveKind get_MouseMoveKind();
C++/CLI
public:
property MouseMoveKind MouseMoveKind {
   MouseMoveKind get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseMovePoint Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : MouseMovePoint Property

Glossary Item Box

This is the current point were the mouse is, and we will use this point to calculate how much the operation (move, resize etc) will effect the time item. See also MouseDownPoint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseMovePoint As Point
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Point

value = instance.MouseMovePoint
C#
public Point MouseMovePoint {get;}
Managed Extensions for C++
public: __property Point get_MouseMovePoint();
C++/CLI
public:
property Point MouseMovePoint {
   Point get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PyjamasColor Property

Glossary Item Box

The color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Color

instance.PyjamasColor = value

value = instance.PyjamasColor
C#
public Color PyjamasColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasColor();
public: __property void set_PyjamasColor(
   Color value
);
C++/CLI
public:
property Color PyjamasColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasGradientColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : PyjamasGradientColor Property

Glossary Item Box

The gradient color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasGradientColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Color

instance.PyjamasGradientColor = value

value = instance.PyjamasGradientColor
C#
public Color PyjamasGradientColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasGradientColor();
public: __property void set_PyjamasGradientColor(
   Color value
);
C++/CLI
public:
property Color PyjamasGradientColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ResizeAreaSize Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ResizeAreaSize Property

Glossary Item Box

The Active area that will react to resize events

Syntax

Visual Basic (Declaration)
Public Property ResizeAreaSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Integer

instance.ResizeAreaSize = value

value = instance.ResizeAreaSize
C#
public int ResizeAreaSize {get; set;}
Managed Extensions for C++
public: __property int get_ResizeAreaSize();
public: __property void set_ResizeAreaSize(
   int value
);
C++/CLI
public:
property int ResizeAreaSize {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScheduleMode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : ScheduleMode Property

Glossary Item Box

ScheduleMode controls the layout. Set ScheduleMode to true and the Gantt turns into a Schedule

Syntax

Visual Basic (Declaration)
Public Property ScheduleMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.ScheduleMode = value

value = instance.ScheduleMode
C#
public bool ScheduleMode {get; set;}
Managed Extensions for C++
public: __property bool get_ScheduleMode();
public: __property void set_ScheduleMode(
   bool value
);
C++/CLI
public:
property bool ScheduleMode {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Splitter Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : Splitter Property

Glossary Item Box

The Splitter between time item area and grid

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Splitter As Splitter
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Splitter

value = instance.Splitter
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Splitter Splitter {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Splitter* get_Splitter();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Splitter^ Splitter {
   Splitter^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemArea Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemArea Property

Glossary Item Box

The Time item area

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property TimeItemArea As TimeAreaOffscreenDraw
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As TimeAreaOffscreenDraw

value = instance.TimeItemArea
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public TimeAreaOffscreenDraw TimeItemArea {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property TimeAreaOffscreenDraw* get_TimeItemArea();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property TimeAreaOffscreenDraw^ TimeItemArea {
   TimeAreaOffscreenDraw^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemLayouts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property TimeItemLayouts As TimeItemLayouts
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As TimeItemLayouts

value = instance.TimeItemLayouts
C#
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TimeItemLayouts TimeItemLayouts {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property TimeItemLayouts* get_TimeItemLayouts();
C++/CLI
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property TimeItemLayouts^ TimeItemLayouts {
   TimeItemLayouts^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinks Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemLinks Property

Glossary Item Box

Returns all time item links

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property TimeItemLinks As TimeItemLinks
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As TimeItemLinks

value = instance.TimeItemLinks
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public TimeItemLinks TimeItemLinks {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property TimeItemLinks* get_TimeItemLinks();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property TimeItemLinks^ TimeItemLinks {
   TimeItemLinks^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeItemTextLayouts Property

Glossary Item Box

The textlayouts in the gantt

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Property TimeItemTextLayouts As TimeItemTextLayouts
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As TimeItemTextLayouts

value = instance.TimeItemTextLayouts
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public TimeItemTextLayouts TimeItemTextLayouts {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property TimeItemTextLayouts* get_TimeItemTextLayouts();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property TimeItemTextLayouts^ TimeItemTextLayouts {
   TimeItemTextLayouts^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeMoveMarkerDate Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeMoveMarkerDate Property

Glossary Item Box

When the user moves a time item you can show move markers that helps the user to see from where the time item is moving and where it will end up if he or she drops it

Syntax

Visual Basic (Declaration)
Public Property TimeMoveMarkerDate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.TimeMoveMarkerDate = value

value = instance.TimeMoveMarkerDate
C#
public bool TimeMoveMarkerDate {get; set;}
Managed Extensions for C++
public: __property bool get_TimeMoveMarkerDate();
public: __property void set_TimeMoveMarkerDate(
   bool value
);
C++/CLI
public:
property bool TimeMoveMarkerDate {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeMoveMarkerRow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TimeMoveMarkerRow Property

Glossary Item Box

When the user moves a time item you can show move markers that helps the user to see from what row the time item is moving and where it will end up if he or she drops it

Syntax

Visual Basic (Declaration)
Public Property TimeMoveMarkerRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.TimeMoveMarkerRow = value

value = instance.TimeMoveMarkerRow
C#
public bool TimeMoveMarkerRow {get; set;}
Managed Extensions for C++
public: __property bool get_TimeMoveMarkerRow();
public: __property void set_TimeMoveMarkerRow(
   bool value
);
C++/CLI
public:
property bool TimeMoveMarkerRow {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TodayLine Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TodayLine Property

Glossary Item Box

Vertical line drawn on Now!

Syntax

Visual Basic (Declaration)
Public Property TodayLine As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.TodayLine = value

value = instance.TodayLine
C#
public bool TodayLine {get; set;}
Managed Extensions for C++
public: __property bool get_TodayLine();
public: __property void set_TodayLine(
   bool value
);
C++/CLI
public:
property bool TodayLine {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TodayLineColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TodayLineColor Property

Glossary Item Box

todayLine color, defaults to Black

Syntax

Visual Basic (Declaration)
Public Property TodayLineColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Color

instance.TodayLineColor = value

value = instance.TodayLineColor
C#
public Color TodayLineColor {get; set;}
Managed Extensions for C++
public: __property Color get_TodayLineColor();
public: __property void set_TodayLineColor(
   Color value
);
C++/CLI
public:
property Color TodayLineColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TurnOffAllCollisionDetect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : TurnOffAllCollisionDetect Property

Glossary Item Box

If set all collision detection is turned off, not only for one row, for all rows. Primarily used to speed up load when using syncron collision detection.

Syntax

Visual Basic (Declaration)
Public Property TurnOffAllCollisionDetect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.TurnOffAllCollisionDetect = value

value = instance.TurnOffAllCollisionDetect
C#
public bool TurnOffAllCollisionDetect {get; set;}
Managed Extensions for C++
public: __property bool get_TurnOffAllCollisionDetect();
public: __property void set_TurnOffAllCollisionDetect(
   bool value
);
C++/CLI
public:
property bool TurnOffAllCollisionDetect {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalDayStripes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripes Property

Glossary Item Box

Vertical stripes on certain days

Syntax

Visual Basic (Declaration)
Public Property VerticalDayStripes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.VerticalDayStripes = value

value = instance.VerticalDayStripes
C#
public bool VerticalDayStripes {get; set;}
Managed Extensions for C++
public: __property bool get_VerticalDayStripes();
public: __property void set_VerticalDayStripes(
   bool value
);
C++/CLI
public:
property bool VerticalDayStripes {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalDayStripes_Days Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripes_Days Property

Glossary Item Box

VerticalDayStripes set to true, this property then chooses the days, sat and sun default

Syntax

Visual Basic (Declaration)
Public Property VerticalDayStripes_Days As Boolean()
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value() As Boolean

instance.VerticalDayStripes_Days = value

value = instance.VerticalDayStripes_Days
C#
public bool[] VerticalDayStripes_Days {get; set;}
Managed Extensions for C++
public: __property bool[]* get_VerticalDayStripes_Days();
public: __property void set_VerticalDayStripes_Days(
   bool[]* value
);
C++/CLI
public:
property array<bool>^ VerticalDayStripes_Days {
   array<bool>^ get();
   void set (    array<bool>^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalDayStripesColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesColor Property

Glossary Item Box

VerticalDayStripes color, defaults to

Syntax

Visual Basic (Declaration)
Public Property VerticalDayStripesColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Color

instance.VerticalDayStripesColor = value

value = instance.VerticalDayStripesColor
C#
public Color VerticalDayStripesColor {get; set;}
Managed Extensions for C++
public: __property Color get_VerticalDayStripesColor();
public: __property void set_VerticalDayStripesColor(
   Color value
);
C++/CLI
public:
property Color VerticalDayStripesColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalDayStripesHighestResolution Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesHighestResolution Property

Glossary Item Box

Controls the highest resolution when the vertical day stripes should be drawn (there is not much point in drawing a single day if the resolution is 10 years) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;

Syntax

Visual Basic (Declaration)
Public Property VerticalDayStripesHighestResolution As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As NonLinearTime.TimeResolution

instance.VerticalDayStripesHighestResolution = value

value = instance.VerticalDayStripesHighestResolution
C#
public NonLinearTime.TimeResolution VerticalDayStripesHighestResolution {get; set;}
Managed Extensions for C++
public: __property NonLinearTime.TimeResolution get_VerticalDayStripesHighestResolution();
public: __property void set_VerticalDayStripesHighestResolution(
   NonLinearTime.TimeResolution value
);
C++/CLI
public:
property NonLinearTime.TimeResolution VerticalDayStripesHighestResolution {
   NonLinearTime.TimeResolution get();
   void set (    NonLinearTime.TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalDayStripesLowestResolution Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalDayStripesLowestResolution Property

Glossary Item Box

Controls the lowest resolution when the vertical day stripes should be drawn (there is not much point in drawing a day if the resolution is 10 minutes) Gantt.VerticalDayStripesHighestResolution=NonLinearTime.TimeResolution.months; Gantt_ASP1.Gantt.VerticalDayStripesLowestResolution = NonLinearTime.TimeResolution.hours;

Syntax

Visual Basic (Declaration)
Public Property VerticalDayStripesLowestResolution As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As NonLinearTime.TimeResolution

instance.VerticalDayStripesLowestResolution = value

value = instance.VerticalDayStripesLowestResolution
C#
public NonLinearTime.TimeResolution VerticalDayStripesLowestResolution {get; set;}
Managed Extensions for C++
public: __property NonLinearTime.TimeResolution get_VerticalDayStripesLowestResolution();
public: __property void set_VerticalDayStripesLowestResolution(
   NonLinearTime.TimeResolution value
);
C++/CLI
public:
property NonLinearTime.TimeResolution VerticalDayStripesLowestResolution {
   NonLinearTime.TimeResolution get();
   void set (    NonLinearTime.TimeResolution value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalLines Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalLines Property

Glossary Item Box

Vertical lines on long scale intervall

Syntax

Visual Basic (Declaration)
Public Property VerticalLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Boolean

instance.VerticalLines = value

value = instance.VerticalLines
C#
public bool VerticalLines {get; set;}
Managed Extensions for C++
public: __property bool get_VerticalLines();
public: __property void set_VerticalLines(
   bool value
);
C++/CLI
public:
property bool VerticalLines {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VerticalLinesColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : VerticalLinesColor Property

Glossary Item Box

VerticalLine color, defaults to Black

Syntax

Visual Basic (Declaration)
Public Property VerticalLinesColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim value As Color

instance.VerticalLinesColor = value

value = instance.VerticalLinesColor
C#
public Color VerticalLinesColor {get; set;}
Managed Extensions for C++
public: __property Color get_VerticalLinesColor();
public: __property void set_VerticalLinesColor(
   Color value
);
C++/CLI
public:
property Color VerticalLinesColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
Gantt Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Gantt Class

Glossary Item Box

For a list of all members of this type, see Gantt members.

Public Events

 | Name | Description
Public Event | OnCalendar_UserDraw | Event is fired when a CalendarEntry is about to be drawn
Public Event | OnCollisionDetect | Fired on detected collisions
Public Event | OnConflictArea_Update | Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic
Public Event | OnConflictArea_UserDraw | Event is fired if conflict areas with ConflictAreaStyle==user is detected Draw you own conflict area in this event implementation
Public Event | OnDateScalerClick | Exposed Standard event
Public Event | OnDateScalerDoubleClick | Exposed Standard event
Public Event | OnDateScalerDragDrop | Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point.
Public Event | OnDateScalerDragEnter | Exposed Standard event
Public Event | OnDateScalerDragLeave | Exposed Standard event
Public Event | OnDateScalerDragOver | Exposed Standard event
Public Event | OnDateScalerDrawBoxes | Event that allows you to override the boxes drawn in the scaler
Public Event | OnDateScalerDrawString | Lets you override scaler textual output
Public Event | OnDateScalerKeyDown | Exposed Standard event
Public Event | OnDateScalerKeyUp | Exposed Standard event
Public Event | OnDateScalerMouseDown | Exposed Standard event
Public Event | OnDateScalerMouseEnter | Exposed Standard event
Public Event | OnDateScalerMouseHover | Exposed Standard event
Public Event | OnDateScalerMouseLeave | Exposed Standard event
Public Event | OnDateScalerMouseMove | Exposed Standard event
Public Event | OnDateScalerMouseUp | Exposed Standard event
Public Event | OnDateScalerMouseWheel | Exposed Standard event
Public Event | OnDateScalerPaintBackground | Fired when it is time to draw the background
Public Event | OnDateScalerPaintForeground | Fired when it is time to draw the foreground
Public Event | OnDateScalerScaleChangeEvent | Fires whenever the scale has changed
Public Event | OnDateScalerViewDateInformation | This event allows you to override the Date information that is placed on the left side of the screen by default
Public Event | OnEachListItemWhenDataBound_GridNode | Called for each new GridNode when Grid is DataBound. This is a good place to set up ChildViews for SubNodes etc
Public Event | OnEachListItemWhenDataBound_TimeItem | Called for each new TimeItem in a databound layer. This is a good place to set up TimeItemTexts, or set up TimeItemLayout etc
Public Event | OnEachListItemWhenDataBound_TimeItemLink | Called for each new TimeItemLink created as a result of databinding. This is a good place to set up special link attributes based on your binded data
Public Event | OnError | This event fires when an internal error occurs
Public Event | OnGridCellSelectChanged | Fired when Selection changes
Public Event | OnGridClick | Exposed Standard event
Public Event | OnGridCustomCellDraw | Draw the content of the cell when not in edit mode
Public Event | OnGridCustomCellEditStartByKey | Edit is started by key
Public Event | OnGridCustomCellEditStartByMouse | Edit is started by clicking
Public Event | OnGridCustomCellEndEdit | Edit is finished
Public Event | OnGridCustomCellHeight | Shall return height of cell
Public Event | OnGridDoubleClick | Exposed Standard event
Public Event | OnGridDragDrop | Exposed Standard event,Drop points are in form-coordinates, use PointToClient to turn it into a local point.
Public Event | OnGridDragEnter | Exposed Standard event
Public Event | OnGridDragLeave | Exposed Standard event
Public Event | OnGridDragOver | Exposed Standard event
Public Event | OnGridKeyDown | Exposed Standard event
Public Event | OnGridKeyUp | Exposed Standard event
Public Event | OnGridMouseDown | Exposed Standard event
Public Event | OnGridMouseEnter | Exposed Standard event
Public Event | OnGridMouseHover | Exposed Standard event
Public Event | OnGridMouseLeave | Exposed Standard event
Public Event | OnGridMouseMove | Exposed Standard event
Public Event | OnGridMouseUp | Exposed Standard event
Public Event | OnGridMouseWheel | Exposed Standard event
Public Event | OnGridPaintBackground | Fired when it is time to draw the background
Public Event | OnGridPaintForeground | Fired when it is time to draw the foreground
Public Event | OnGridTopLeftChanged | Fired when Top left cell in grid changes
Public Event | OnLayer_BeforeRemove | This event fires when a TimeItem is removed from a layer.
Public Event | OnLayer_InsertComplete | This event fires when a TimeItem is added to a layer.
Public Event | OnLinkAction | Fired on Link actions
Public Event | OnNodeInserted | Fired when a node is added
Public Event | OnNodeRemove | Fired when a node is removed
Public Event | OnScaleChangeEvent | Fired when DateScaler in changed, either pan or zoom
Public Event | OnTimeItem_AfterCreateByMouse | Fired after the user has created a new time item by the EnterTimeItemCreateMode
Public Event | OnTimeItem_AfterMove | Fires after a move op is performed. This event fires as a result of a gui operation and will not fire when time items are moved by code alone.
Public Event | OnTimeItem_BeforeMove | Fired before a move op is started
Public Event | OnTimeItem_ChangeRow | Fired on row switch
Public Event | OnTimeItem_DrawRectOverride | Implement this and change the e.Rect for the given time item. You can limit the height of the time item here. Beware of the fact that it is up to you to respect SubColumns, SchemaView etc when making changes to the draw rectangle.
Public Event | OnTimeItem_Hoover | Fired while mouse is moved and possibly over a time item. This is a good place to set e.Allow false if you do not want to allow the ongoing operation. You can also limit dragging in this event by e.x=gantt1.MouseDownPoint.X; will stop move in x direction This event fires as a result of a gui operation and will not fire when time items are moved by code alone.
Public Event | OnTimeItem_LengthChange | Fires when the property Length of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewLengthValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_LinkCreate | Fired on link create, and on link change. On link change check e.LinkUnderEdit to find the link. Note: e.LinkUnderEdit==null when a new link is created
Public Event | OnTimeItem_Move | Fired on while after a move op has completed (onmouseup)
Public Event | OnTimeItem_OnBeforeMouseModeUse | Fired from within mouse down , but before we check the MouseMode. This is a good place to enter a specific mouse mode dynamically. Maybe you want to call EnterLinkCreateMode in this event if the time item is of a certain type and the user presses the shift key?
Public Event | OnTimeItem_SelectionChanged | Fired when selection has changed on time item
Public Event | OnTimeItem_StartChange | Fires when the property Start of a time item is about to change value. This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_StartMovedIntoBlockedTime | When using BlockedTime the user may move a time item so that the Start is inside BlockedTime. This can be perfectly legal and if so set e.Allow=true (default). The BlockedTime logic will calculate a Stop value for the time item taking the leading blocked time into account. But it might also be illegal; then set e.Allow=false, the logic will then move the Start time forward to the end of the blocking CalendarEntry. If the time item's start then ends up in another blocking CalendarEntry this event will fire again.
Public Event | OnTimeItem_StartValueResize | Fired on start value resize operation done
Public Event | OnTimeItem_StopChange | Fires when the property Stop of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change
Public Event | OnTimeItem_StopValueResize | Fired on stop value resize operation done
Public Event | OnTimeItem_UserBrushCreate | The OnTimeItem_UserBrushCreate event fires when you use TimeItemLayout.BrushKind=BrushKind.UserCreatedBrush
Public Event | OnTimeItem_UserDraw | Fired when a time item with style=user is to be drawn
Public Event | OnTimeItem_UserDrawBounds | Fired to request bounding region of a time item with style=user This is how to use the OnTimeItem_UserDrawBounds and OnTimeItem_UserDraw together: In the OnTimeItem_UserDraw event change the given Rect and Bounding Region (make them the size and shape you need as you need) In the OnTimeItem_UserDrawBounds you must do the same(assign new e.Rect and e.BoundingRegion), since this event Is fired when the logic is finding out the size of the time item for other reasons than drawing.
Public Event | OnTimeItemAreaClick | Exposed Standard event
Public Event | OnTimeItemAreaDoubleClick | Exposed Standard event
Public Event | OnTimeItemAreaDragDrop | Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point. Point p=new Point(e.X,e.Y); GanttRow gr=gantt1.GanttRowFromY(gantt1.TimeItemArea.PointToClient(p).Y);
Public Event | OnTimeItemAreaDragEnter | Exposed Standard event
Public Event | OnTimeItemAreaDragLeave | Exposed Standard event
Public Event | OnTimeItemAreaDragOver | Exposed Standard event
Public Event | OnTimeItemAreaKeyDown | Exposed Standard event
Public Event | OnTimeItemAreaKeyUp | Exposed Standard event
Public Event | OnTimeItemAreaMouseDown | Exposed Standard event
Public Event | OnTimeItemAreaMouseEnter | Exposed Standard event
Public Event | OnTimeItemAreaMouseHover | Exposed Standard event
Public Event | OnTimeItemAreaMouseLeave | Exposed Standard event
Public Event | OnTimeItemAreaMouseMove | Exposed Standard event
Public Event | OnTimeItemAreaMouseUp | Exposed Standard event
Public Event | OnTimeItemAreaMouseWheel | Exposed Standard event
Public Event | OnTimeItemAreaPaintBackground | Fired when it is time to draw the background
Public Event | OnTimeItemAreaPaintForeground | Fired when it is time to draw the foreground
Public Event | OnTimeItemAreaScalerPaintBackground | DEPRECATED, replaced with OnTimeItemAreaPaintBackground
Public Event | OnTimeItemLink_SelectionChanged | Fired when selection has changed on time item link
Public Event | OnUserDrawLink | Fired when link with drawstyle=user need to be drawn. There are two passes to link drawing. First there is the normal draw, the e.G is assigned, and you simply draw the Graphics object supplied. Second there is the selection region pass, this is recongnised by e.G==null and e.BoundingRegion is assigned. Now you can fill the region that is used to decide if a click is on a link or not.
Top

See Also

Reference

Gantt Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCalendar_UserDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnCalendar_UserDraw Event

Glossary Item Box

Event is fired when a CalendarEntry is about to be drawn

Syntax

Visual Basic (Declaration)
Public Event OnCalendar_UserDraw As Calendar_UserDraw
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As Calendar_UserDraw

AddHandler instance.OnCalendar_UserDraw, handler
C#
public event Calendar_UserDraw OnCalendar_UserDraw
Managed Extensions for C++
public: __event Calendar_UserDraw* OnCalendar_UserDraw
C++/CLI
public:
event Calendar_UserDraw^ OnCalendar_UserDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCollisionDetect Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnCollisionDetect Event

Glossary Item Box

Fired on detected collisions

Syntax

Visual Basic (Declaration)
Public Event OnCollisionDetect As CollisionDetectEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CollisionDetectEvent

AddHandler instance.OnCollisionDetect, handler
C#
public event CollisionDetectEvent OnCollisionDetect
Managed Extensions for C++
public: __event CollisionDetectEvent* OnCollisionDetect
C++/CLI
public:
event CollisionDetectEvent^ OnCollisionDetect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnConflictArea_Update Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnConflictArea_Update Event

Glossary Item Box

Event is fired when a conflict area is created, deleted or changed. This is the perfect place to react to conflicts that occure in the GUI and should be handled by some business logic

Syntax

Visual Basic (Declaration)
Public Event OnConflictArea_Update As ConflictArea_Update
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As ConflictArea_Update

AddHandler instance.OnConflictArea_Update, handler
C#
public event ConflictArea_Update OnConflictArea_Update
Managed Extensions for C++
public: __event ConflictArea_Update* OnConflictArea_Update
C++/CLI
public:
event ConflictArea_Update^ OnConflictArea_Update

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnConflictArea_UserDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnConflictArea_UserDraw Event

Glossary Item Box

Event is fired if conflict areas with ConflictAreaStyle==user is detected Draw you own conflict area in this event implementation

Syntax

Visual Basic (Declaration)
Public Event OnConflictArea_UserDraw As ConflictArea_UserDraw
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As ConflictArea_UserDraw

AddHandler instance.OnConflictArea_UserDraw, handler
C#
public event ConflictArea_UserDraw OnConflictArea_UserDraw
Managed Extensions for C++
public: __event ConflictArea_UserDraw* OnConflictArea_UserDraw
C++/CLI
public:
event ConflictArea_UserDraw^ OnConflictArea_UserDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerClick, handler
C#
public event EventHandler OnDateScalerClick
Managed Extensions for C++
public: __event EventHandler* OnDateScalerClick
C++/CLI
public:
event EventHandler^ OnDateScalerClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDoubleClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDoubleClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDoubleClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerDoubleClick, handler
C#
public event EventHandler OnDateScalerDoubleClick
Managed Extensions for C++
public: __event EventHandler* OnDateScalerDoubleClick
C++/CLI
public:
event EventHandler^ OnDateScalerDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDragDrop Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDragDrop Event

Glossary Item Box

Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point.

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDragDrop As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnDateScalerDragDrop, handler
C#
public event DragEventHandler OnDateScalerDragDrop
Managed Extensions for C++
public: __event DragEventHandler* OnDateScalerDragDrop
C++/CLI
public:
event DragEventHandler^ OnDateScalerDragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDragEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDragEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDragEnter As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnDateScalerDragEnter, handler
C#
public event DragEventHandler OnDateScalerDragEnter
Managed Extensions for C++
public: __event DragEventHandler* OnDateScalerDragEnter
C++/CLI
public:
event DragEventHandler^ OnDateScalerDragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDragLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDragLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDragLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerDragLeave, handler
C#
public event EventHandler OnDateScalerDragLeave
Managed Extensions for C++
public: __event EventHandler* OnDateScalerDragLeave
C++/CLI
public:
event EventHandler^ OnDateScalerDragLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDragOver Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDragOver Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDragOver As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnDateScalerDragOver, handler
C#
public event DragEventHandler OnDateScalerDragOver
Managed Extensions for C++
public: __event DragEventHandler* OnDateScalerDragOver
C++/CLI
public:
event DragEventHandler^ OnDateScalerDragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDrawBoxes Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDrawBoxes Event

Glossary Item Box

Event that allows you to override the boxes drawn in the scaler

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDrawBoxes As DateScalerDrawBoxesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DateScalerDrawBoxesEventHandler

AddHandler instance.OnDateScalerDrawBoxes, handler
C#
public event DateScalerDrawBoxesEventHandler OnDateScalerDrawBoxes
Managed Extensions for C++
public: __event DateScalerDrawBoxesEventHandler* OnDateScalerDrawBoxes
C++/CLI
public:
event DateScalerDrawBoxesEventHandler^ OnDateScalerDrawBoxes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerDrawString Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerDrawString Event

Glossary Item Box

Lets you override scaler textual output

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerDrawString As DateScalerDrawStringEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DateScalerDrawStringEventHandler

AddHandler instance.OnDateScalerDrawString, handler
C#
public event DateScalerDrawStringEventHandler OnDateScalerDrawString
Managed Extensions for C++
public: __event DateScalerDrawStringEventHandler* OnDateScalerDrawString
C++/CLI
public:
event DateScalerDrawStringEventHandler^ OnDateScalerDrawString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerKeyDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerKeyDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerKeyDown As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnDateScalerKeyDown, handler
C#
public event KeyEventHandler OnDateScalerKeyDown
Managed Extensions for C++
public: __event KeyEventHandler* OnDateScalerKeyDown
C++/CLI
public:
event KeyEventHandler^ OnDateScalerKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerKeyUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerKeyUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerKeyUp As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnDateScalerKeyUp, handler
C#
public event KeyEventHandler OnDateScalerKeyUp
Managed Extensions for C++
public: __event KeyEventHandler* OnDateScalerKeyUp
C++/CLI
public:
event KeyEventHandler^ OnDateScalerKeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseDown As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnDateScalerMouseDown, handler
C#
public event MouseEventHandler OnDateScalerMouseDown
Managed Extensions for C++
public: __event MouseEventHandler* OnDateScalerMouseDown
C++/CLI
public:
event MouseEventHandler^ OnDateScalerMouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseEnter As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerMouseEnter, handler
C#
public event EventHandler OnDateScalerMouseEnter
Managed Extensions for C++
public: __event EventHandler* OnDateScalerMouseEnter
C++/CLI
public:
event EventHandler^ OnDateScalerMouseEnter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseHover Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseHover Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseHover As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerMouseHover, handler
C#
public event EventHandler OnDateScalerMouseHover
Managed Extensions for C++
public: __event EventHandler* OnDateScalerMouseHover
C++/CLI
public:
event EventHandler^ OnDateScalerMouseHover

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerMouseLeave, handler
C#
public event EventHandler OnDateScalerMouseLeave
Managed Extensions for C++
public: __event EventHandler* OnDateScalerMouseLeave
C++/CLI
public:
event EventHandler^ OnDateScalerMouseLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseMove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseMove Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseMove As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnDateScalerMouseMove, handler
C#
public event MouseEventHandler OnDateScalerMouseMove
Managed Extensions for C++
public: __event MouseEventHandler* OnDateScalerMouseMove
C++/CLI
public:
event MouseEventHandler^ OnDateScalerMouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseUp As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnDateScalerMouseUp, handler
C#
public event MouseEventHandler OnDateScalerMouseUp
Managed Extensions for C++
public: __event MouseEventHandler* OnDateScalerMouseUp
C++/CLI
public:
event MouseEventHandler^ OnDateScalerMouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerMouseWheel Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerMouseWheel Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerMouseWheel As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnDateScalerMouseWheel, handler
C#
public event MouseEventHandler OnDateScalerMouseWheel
Managed Extensions for C++
public: __event MouseEventHandler* OnDateScalerMouseWheel
C++/CLI
public:
event MouseEventHandler^ OnDateScalerMouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerPaintBackground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerPaintBackground Event

Glossary Item Box

Fired when it is time to draw the background

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerPaintBackground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnDateScalerPaintBackground, handler
C#
public event OffscreenDrawEvent OnDateScalerPaintBackground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnDateScalerPaintBackground
C++/CLI
public:
event OffscreenDrawEvent^ OnDateScalerPaintBackground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerPaintForeground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerPaintForeground Event

Glossary Item Box

Fired when it is time to draw the foreground

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerPaintForeground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnDateScalerPaintForeground, handler
C#
public event OffscreenDrawEvent OnDateScalerPaintForeground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnDateScalerPaintForeground
C++/CLI
public:
event OffscreenDrawEvent^ OnDateScalerPaintForeground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerScaleChangeEvent Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerScaleChangeEvent Event

Glossary Item Box

Fires whenever the scale has changed

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerScaleChangeEvent As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnDateScalerScaleChangeEvent, handler
C#
public event EventHandler OnDateScalerScaleChangeEvent
Managed Extensions for C++
public: __event EventHandler* OnDateScalerScaleChangeEvent
C++/CLI
public:
event EventHandler^ OnDateScalerScaleChangeEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnDateScalerViewDateInformation Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnDateScalerViewDateInformation Event

Glossary Item Box

This event allows you to override the Date information that is placed on the left side of the screen by default

Syntax

Visual Basic (Declaration)
Public Event OnDateScalerViewDateInformation As ViewDateInformationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As ViewDateInformationEventHandler

AddHandler instance.OnDateScalerViewDateInformation, handler
C#
public event ViewDateInformationEventHandler OnDateScalerViewDateInformation
Managed Extensions for C++
public: __event ViewDateInformationEventHandler* OnDateScalerViewDateInformation
C++/CLI
public:
event ViewDateInformationEventHandler^ OnDateScalerViewDateInformation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnEachListItemWhenDataBound_GridNode Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnEachListItemWhenDataBound_GridNode Event

Glossary Item Box

Called for each new GridNode when Grid is DataBound. This is a good place to set up ChildViews for SubNodes etc

Syntax

Visual Basic (Declaration)
Public Event OnEachListItemWhenDataBound_GridNode As EachListItemWhenDataBoundHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EachListItemWhenDataBoundHandler

AddHandler instance.OnEachListItemWhenDataBound_GridNode, handler
C#
public event EachListItemWhenDataBoundHandler OnEachListItemWhenDataBound_GridNode
Managed Extensions for C++
public: __event EachListItemWhenDataBoundHandler* OnEachListItemWhenDataBound_GridNode
C++/CLI
public:
event EachListItemWhenDataBoundHandler^ OnEachListItemWhenDataBound_GridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnEachListItemWhenDataBound_TimeItem Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnEachListItemWhenDataBound_TimeItem Event

Glossary Item Box

Called for each new TimeItem in a databound layer. This is a good place to set up TimeItemTexts, or set up TimeItemLayout etc

Syntax

Visual Basic (Declaration)
Public Event OnEachListItemWhenDataBound_TimeItem As EachListItemWhenDataBoundHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EachListItemWhenDataBoundHandler

AddHandler instance.OnEachListItemWhenDataBound_TimeItem, handler
C#
public event EachListItemWhenDataBoundHandler OnEachListItemWhenDataBound_TimeItem
Managed Extensions for C++
public: __event EachListItemWhenDataBoundHandler* OnEachListItemWhenDataBound_TimeItem
C++/CLI
public:
event EachListItemWhenDataBoundHandler^ OnEachListItemWhenDataBound_TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnEachListItemWhenDataBound_TimeItemLink Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnEachListItemWhenDataBound_TimeItemLink Event

Glossary Item Box

Called for each new TimeItemLink created as a result of databinding. This is a good place to set up special link attributes based on your binded data

Syntax

Visual Basic (Declaration)
Public Event OnEachListItemWhenDataBound_TimeItemLink As EachListItemWhenDataBoundHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EachListItemWhenDataBoundHandler

AddHandler instance.OnEachListItemWhenDataBound_TimeItemLink, handler
C#
public event EachListItemWhenDataBoundHandler OnEachListItemWhenDataBound_TimeItemLink
Managed Extensions for C++
public: __event EachListItemWhenDataBoundHandler* OnEachListItemWhenDataBound_TimeItemLink
C++/CLI
public:
event EachListItemWhenDataBoundHandler^ OnEachListItemWhenDataBound_TimeItemLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnError Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnError Event

Glossary Item Box

This event fires when an internal error occurs

Syntax

Visual Basic (Declaration)
Public Event OnError As ErrorEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As ErrorEvent

AddHandler instance.OnError, handler
C#
public event ErrorEvent OnError
Managed Extensions for C++
public: __event ErrorEvent* OnError
C++/CLI
public:
event ErrorEvent^ OnError

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCellSelectChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCellSelectChanged Event

Glossary Item Box

Fired when Selection changes

Syntax

Visual Basic (Declaration)
Public Event OnGridCellSelectChanged As CellSelectChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CellSelectChangedHandler

AddHandler instance.OnGridCellSelectChanged, handler
C#
public event CellSelectChangedHandler OnGridCellSelectChanged
Managed Extensions for C++
public: __event CellSelectChangedHandler* OnGridCellSelectChanged
C++/CLI
public:
event CellSelectChangedHandler^ OnGridCellSelectChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridClick, handler
C#
public event EventHandler OnGridClick
Managed Extensions for C++
public: __event EventHandler* OnGridClick
C++/CLI
public:
event EventHandler^ OnGridClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCustomCellDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCustomCellDraw Event

Glossary Item Box

Draw the content of the cell when not in edit mode

Syntax

Visual Basic (Declaration)
Public Event OnGridCustomCellDraw As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CustomCellEventHandler

AddHandler instance.OnGridCustomCellDraw, handler
C#
public event CustomCellEventHandler OnGridCustomCellDraw
Managed Extensions for C++
public: __event CustomCellEventHandler* OnGridCustomCellDraw
C++/CLI
public:
event CustomCellEventHandler^ OnGridCustomCellDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCustomCellEditStartByKey Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCustomCellEditStartByKey Event

Glossary Item Box

Edit is started by key

Syntax

Visual Basic (Declaration)
Public Event OnGridCustomCellEditStartByKey As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CustomCellEventHandler

AddHandler instance.OnGridCustomCellEditStartByKey, handler
C#
public event CustomCellEventHandler OnGridCustomCellEditStartByKey
Managed Extensions for C++
public: __event CustomCellEventHandler* OnGridCustomCellEditStartByKey
C++/CLI
public:
event CustomCellEventHandler^ OnGridCustomCellEditStartByKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCustomCellEditStartByMouse Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCustomCellEditStartByMouse Event

Glossary Item Box

Edit is started by clicking

Syntax

Visual Basic (Declaration)
Public Event OnGridCustomCellEditStartByMouse As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CustomCellEventHandler

AddHandler instance.OnGridCustomCellEditStartByMouse, handler
C#
public event CustomCellEventHandler OnGridCustomCellEditStartByMouse
Managed Extensions for C++
public: __event CustomCellEventHandler* OnGridCustomCellEditStartByMouse
C++/CLI
public:
event CustomCellEventHandler^ OnGridCustomCellEditStartByMouse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCustomCellEndEdit Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCustomCellEndEdit Event

Glossary Item Box

Edit is finished

Syntax

Visual Basic (Declaration)
Public Event OnGridCustomCellEndEdit As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CustomCellEventHandler

AddHandler instance.OnGridCustomCellEndEdit, handler
C#
public event CustomCellEventHandler OnGridCustomCellEndEdit
Managed Extensions for C++
public: __event CustomCellEventHandler* OnGridCustomCellEndEdit
C++/CLI
public:
event CustomCellEventHandler^ OnGridCustomCellEndEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridCustomCellHeight Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridCustomCellHeight Event

Glossary Item Box

Shall return height of cell

Syntax

Visual Basic (Declaration)
Public Event OnGridCustomCellHeight As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As CustomCellEventHandler

AddHandler instance.OnGridCustomCellHeight, handler
C#
public event CustomCellEventHandler OnGridCustomCellHeight
Managed Extensions for C++
public: __event CustomCellEventHandler* OnGridCustomCellHeight
C++/CLI
public:
event CustomCellEventHandler^ OnGridCustomCellHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridDoubleClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridDoubleClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridDoubleClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridDoubleClick, handler
C#
public event EventHandler OnGridDoubleClick
Managed Extensions for C++
public: __event EventHandler* OnGridDoubleClick
C++/CLI
public:
event EventHandler^ OnGridDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridDragDrop Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridDragDrop Event

Glossary Item Box

Exposed Standard event,Drop points are in form-coordinates, use PointToClient to turn it into a local point.

Syntax

Visual Basic (Declaration)
Public Event OnGridDragDrop As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnGridDragDrop, handler
C#
public event DragEventHandler OnGridDragDrop
Managed Extensions for C++
public: __event DragEventHandler* OnGridDragDrop
C++/CLI
public:
event DragEventHandler^ OnGridDragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridDragEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridDragEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridDragEnter As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnGridDragEnter, handler
C#
public event DragEventHandler OnGridDragEnter
Managed Extensions for C++
public: __event DragEventHandler* OnGridDragEnter
C++/CLI
public:
event DragEventHandler^ OnGridDragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridDragLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridDragLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridDragLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridDragLeave, handler
C#
public event EventHandler OnGridDragLeave
Managed Extensions for C++
public: __event EventHandler* OnGridDragLeave
C++/CLI
public:
event EventHandler^ OnGridDragLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridDragOver Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridDragOver Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridDragOver As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnGridDragOver, handler
C#
public event DragEventHandler OnGridDragOver
Managed Extensions for C++
public: __event DragEventHandler* OnGridDragOver
C++/CLI
public:
event DragEventHandler^ OnGridDragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridKeyDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridKeyDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridKeyDown As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnGridKeyDown, handler
C#
public event KeyEventHandler OnGridKeyDown
Managed Extensions for C++
public: __event KeyEventHandler* OnGridKeyDown
C++/CLI
public:
event KeyEventHandler^ OnGridKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridKeyUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridKeyUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridKeyUp As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnGridKeyUp, handler
C#
public event KeyEventHandler OnGridKeyUp
Managed Extensions for C++
public: __event KeyEventHandler* OnGridKeyUp
C++/CLI
public:
event KeyEventHandler^ OnGridKeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseDown As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnGridMouseDown, handler
C#
public event MouseEventHandler OnGridMouseDown
Managed Extensions for C++
public: __event MouseEventHandler* OnGridMouseDown
C++/CLI
public:
event MouseEventHandler^ OnGridMouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseEnter As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridMouseEnter, handler
C#
public event EventHandler OnGridMouseEnter
Managed Extensions for C++
public: __event EventHandler* OnGridMouseEnter
C++/CLI
public:
event EventHandler^ OnGridMouseEnter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseHover Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseHover Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseHover As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridMouseHover, handler
C#
public event EventHandler OnGridMouseHover
Managed Extensions for C++
public: __event EventHandler* OnGridMouseHover
C++/CLI
public:
event EventHandler^ OnGridMouseHover

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnGridMouseLeave, handler
C#
public event EventHandler OnGridMouseLeave
Managed Extensions for C++
public: __event EventHandler* OnGridMouseLeave
C++/CLI
public:
event EventHandler^ OnGridMouseLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseMove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseMove Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseMove As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnGridMouseMove, handler
C#
public event MouseEventHandler OnGridMouseMove
Managed Extensions for C++
public: __event MouseEventHandler* OnGridMouseMove
C++/CLI
public:
event MouseEventHandler^ OnGridMouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseUp As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnGridMouseUp, handler
C#
public event MouseEventHandler OnGridMouseUp
Managed Extensions for C++
public: __event MouseEventHandler* OnGridMouseUp
C++/CLI
public:
event MouseEventHandler^ OnGridMouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridMouseWheel Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridMouseWheel Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnGridMouseWheel As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnGridMouseWheel, handler
C#
public event MouseEventHandler OnGridMouseWheel
Managed Extensions for C++
public: __event MouseEventHandler* OnGridMouseWheel
C++/CLI
public:
event MouseEventHandler^ OnGridMouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridPaintBackground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridPaintBackground Event

Glossary Item Box

Fired when it is time to draw the background

Syntax

Visual Basic (Declaration)
Public Event OnGridPaintBackground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnGridPaintBackground, handler
C#
public event OffscreenDrawEvent OnGridPaintBackground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnGridPaintBackground
C++/CLI
public:
event OffscreenDrawEvent^ OnGridPaintBackground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridPaintForeground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridPaintForeground Event

Glossary Item Box

Fired when it is time to draw the foreground

Syntax

Visual Basic (Declaration)
Public Event OnGridPaintForeground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnGridPaintForeground, handler
C#
public event OffscreenDrawEvent OnGridPaintForeground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnGridPaintForeground
C++/CLI
public:
event OffscreenDrawEvent^ OnGridPaintForeground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridTopLeftChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnGridTopLeftChanged Event

Glossary Item Box

Fired when Top left cell in grid changes

Syntax

Visual Basic (Declaration)
Public Event OnGridTopLeftChanged As TopLeftChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TopLeftChangedHandler

AddHandler instance.OnGridTopLeftChanged, handler
C#
public event TopLeftChangedHandler OnGridTopLeftChanged
Managed Extensions for C++
public: __event TopLeftChangedHandler* OnGridTopLeftChanged
C++/CLI
public:
event TopLeftChangedHandler^ OnGridTopLeftChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnLayer_BeforeRemove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnLayer_BeforeRemove Event

Glossary Item Box

This event fires when a TimeItem is removed from a layer.

Syntax

Visual Basic (Declaration)
Public Event OnLayer_BeforeRemove As LayerEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As LayerEvent

AddHandler instance.OnLayer_BeforeRemove, handler
C#
public event LayerEvent OnLayer_BeforeRemove
Managed Extensions for C++
public: __event LayerEvent* OnLayer_BeforeRemove
C++/CLI
public:
event LayerEvent^ OnLayer_BeforeRemove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnLayer_InsertComplete Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnLayer_InsertComplete Event

Glossary Item Box

This event fires when a TimeItem is added to a layer.

Syntax

Visual Basic (Declaration)
Public Event OnLayer_InsertComplete As LayerEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As LayerEvent

AddHandler instance.OnLayer_InsertComplete, handler
C#
public event LayerEvent OnLayer_InsertComplete
Managed Extensions for C++
public: __event LayerEvent* OnLayer_InsertComplete
C++/CLI
public:
event LayerEvent^ OnLayer_InsertComplete

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnLinkAction Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnLinkAction Event

Glossary Item Box

Fired on Link actions

Syntax

Visual Basic (Declaration)
Public Event OnLinkAction As LinkActionEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As LinkActionEvent

AddHandler instance.OnLinkAction, handler
C#
public event LinkActionEvent OnLinkAction
Managed Extensions for C++
public: __event LinkActionEvent* OnLinkAction
C++/CLI
public:
event LinkActionEvent^ OnLinkAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnNodeInserted Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnNodeInserted Event

Glossary Item Box

Fired when a node is added

Syntax

Visual Basic (Declaration)
Public Event OnNodeInserted As NodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As NodeEventHandler

AddHandler instance.OnNodeInserted, handler
C#
public event NodeEventHandler OnNodeInserted
Managed Extensions for C++
public: __event NodeEventHandler* OnNodeInserted
C++/CLI
public:
event NodeEventHandler^ OnNodeInserted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnNodeRemove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnNodeRemove Event

Glossary Item Box

Fired when a node is removed

Syntax

Visual Basic (Declaration)
Public Event OnNodeRemove As NodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As NodeEventHandler

AddHandler instance.OnNodeRemove, handler
C#
public event NodeEventHandler OnNodeRemove
Managed Extensions for C++
public: __event NodeEventHandler* OnNodeRemove
C++/CLI
public:
event NodeEventHandler^ OnNodeRemove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnScaleChangeEvent Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnScaleChangeEvent Event

Glossary Item Box

Fired when DateScaler in changed, either pan or zoom

Syntax

Visual Basic (Declaration)
Public Event OnScaleChangeEvent As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnScaleChangeEvent, handler
C#
public event EventHandler OnScaleChangeEvent
Managed Extensions for C++
public: __event EventHandler* OnScaleChangeEvent
C++/CLI
public:
event EventHandler^ OnScaleChangeEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_AfterCreateByMouse Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_AfterCreateByMouse Event

Glossary Item Box

Fired after the user has created a new time item by the EnterTimeItemCreateMode

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_AfterCreateByMouse As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_AfterCreateByMouse, handler
C#
public event TimeItemEvent OnTimeItem_AfterCreateByMouse
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_AfterCreateByMouse
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_AfterCreateByMouse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_AfterMove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_AfterMove Event

Glossary Item Box

Fires after a move op is performed. This event fires as a result of a gui operation and will not fire when time items are moved by code alone.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_AfterMove As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_AfterMove, handler
C#
public event TimeItemEvent OnTimeItem_AfterMove
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_AfterMove
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_AfterMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_BeforeMove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_BeforeMove Event

Glossary Item Box

Fired before a move op is started

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_BeforeMove As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_BeforeMove, handler
C#
public event TimeItemEvent OnTimeItem_BeforeMove
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_BeforeMove
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_BeforeMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_ChangeRow Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_ChangeRow Event

Glossary Item Box

Fired on row switch

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_ChangeRow As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_ChangeRow, handler
C#
public event TimeItemEvent OnTimeItem_ChangeRow
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_ChangeRow
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_ChangeRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_DrawRectOverride Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_DrawRectOverride Event

Glossary Item Box

Implement this and change the e.Rect for the given time item. You can limit the height of the time item here. Beware of the fact that it is up to you to respect SubColumns, SchemaView etc when making changes to the draw rectangle.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_DrawRectOverride As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_DrawRectOverride, handler
C#
public event TimeItemEvent OnTimeItem_DrawRectOverride
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_DrawRectOverride
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_DrawRectOverride

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_Hoover Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_Hoover Event

Glossary Item Box

Fired while mouse is moved and possibly over a time item. This is a good place to set e.Allow false if you do not want to allow the ongoing operation. You can also limit dragging in this event by e.x=gantt1.MouseDownPoint.X; will stop move in x direction This event fires as a result of a gui operation and will not fire when time items are moved by code alone.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_Hoover As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_Hoover, handler
C#
public event TimeItemEvent OnTimeItem_Hoover
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_Hoover
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_Hoover

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_LengthChange Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_LengthChange Event

Glossary Item Box

Fires when the property Length of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewLengthValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_LengthChange As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_LengthChange, handler
C#
public event TimeItemEvent OnTimeItem_LengthChange
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_LengthChange
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_LengthChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_LinkCreate Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_LinkCreate Event

Glossary Item Box

Fired on link create, and on link change. On link change check e.LinkUnderEdit to find the link. Note: e.LinkUnderEdit==null when a new link is created

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_LinkCreate As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_LinkCreate, handler
C#
public event TimeItemEvent OnTimeItem_LinkCreate
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_LinkCreate
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_LinkCreate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_Move Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_Move Event

Glossary Item Box

Fired on while after a move op has completed (onmouseup)

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_Move As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_Move, handler
C#
public event TimeItemEvent OnTimeItem_Move
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_Move
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_Move

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_OnBeforeMouseModeUse Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_OnBeforeMouseModeUse Event

Glossary Item Box

Fired from within mouse down , but before we check the MouseMode. This is a good place to enter a specific mouse mode dynamically. Maybe you want to call EnterLinkCreateMode in this event if the time item is of a certain type and the user presses the shift key?

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_OnBeforeMouseModeUse As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_OnBeforeMouseModeUse, handler
C#
public event TimeItemEvent OnTimeItem_OnBeforeMouseModeUse
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_OnBeforeMouseModeUse
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_OnBeforeMouseModeUse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_SelectionChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_SelectionChanged Event

Glossary Item Box

Fired when selection has changed on time item

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_SelectionChanged As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_SelectionChanged, handler
C#
public event TimeItemEvent OnTimeItem_SelectionChanged
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_SelectionChanged
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_SelectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_StartChange Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_StartChange Event

Glossary Item Box

Fires when the property Start of a time item is about to change value. This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_StartChange As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_StartChange, handler
C#
public event TimeItemEvent OnTimeItem_StartChange
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_StartChange
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_StartChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_StartMovedIntoBlockedTime Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_StartMovedIntoBlockedTime Event

Glossary Item Box

When using BlockedTime the user may move a time item so that the Start is inside BlockedTime. This can be perfectly legal and if so set e.Allow=true (default). The BlockedTime logic will calculate a Stop value for the time item taking the leading blocked time into account. But it might also be illegal; then set e.Allow=false, the logic will then move the Start time forward to the end of the blocking CalendarEntry. If the time item's start then ends up in another blocking CalendarEntry this event will fire again.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_StartMovedIntoBlockedTime As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_StartMovedIntoBlockedTime, handler
C#
public event TimeItemEvent OnTimeItem_StartMovedIntoBlockedTime
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_StartMovedIntoBlockedTime
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_StartMovedIntoBlockedTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_StartValueResize Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_StartValueResize Event

Glossary Item Box

Fired on start value resize operation done

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_StartValueResize As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_StartValueResize, handler
C#
public event TimeItemEvent OnTimeItem_StartValueResize
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_StartValueResize
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_StartValueResize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_StopChange Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_StopChange Event

Glossary Item Box

Fires when the property Stop of a time item is about to change value This event is fired even if the change is made from code (unlike OnTimeItem_BeforeMove, OnTimeItem_AfterMove). Active properties in the TimeItemEventArgs for this event are: TimeItemPropertyChange_NewValue ; the value about to be set TimeItem ; the time item affected Allow ; set it to false to avoid applying the change

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_StopChange As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_StopChange, handler
C#
public event TimeItemEvent OnTimeItem_StopChange
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_StopChange
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_StopChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_StopValueResize Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_StopValueResize Event

Glossary Item Box

Fired on stop value resize operation done

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_StopValueResize As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_StopValueResize, handler
C#
public event TimeItemEvent OnTimeItem_StopValueResize
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_StopValueResize
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_StopValueResize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_UserBrushCreate Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_UserBrushCreate Event

Glossary Item Box

The OnTimeItem_UserBrushCreate event fires when you use TimeItemLayout.BrushKind=BrushKind.UserCreatedBrush

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_UserBrushCreate As TimeItem_UserBrushCreate
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItem_UserBrushCreate

AddHandler instance.OnTimeItem_UserBrushCreate, handler
C#
public event TimeItem_UserBrushCreate OnTimeItem_UserBrushCreate
Managed Extensions for C++
public: __event TimeItem_UserBrushCreate* OnTimeItem_UserBrushCreate
C++/CLI
public:
event TimeItem_UserBrushCreate^ OnTimeItem_UserBrushCreate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_UserDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_UserDraw Event

Glossary Item Box

Fired when a time item with style=user is to be drawn

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_UserDraw As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_UserDraw, handler
C#
public event TimeItemEvent OnTimeItem_UserDraw
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_UserDraw
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_UserDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItem_UserDrawBounds Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItem_UserDrawBounds Event

Glossary Item Box

Fired to request bounding region of a time item with style=user This is how to use the OnTimeItem_UserDrawBounds and OnTimeItem_UserDraw together: In the OnTimeItem_UserDraw event change the given Rect and Bounding Region (make them the size and shape you need as you need) In the OnTimeItem_UserDrawBounds you must do the same(assign new e.Rect and e.BoundingRegion), since this event Is fired when the logic is finding out the size of the time item for other reasons than drawing.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_UserDrawBounds As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_UserDrawBounds, handler
C#
public event TimeItemEvent OnTimeItem_UserDrawBounds
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_UserDrawBounds
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_UserDrawBounds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaClick, handler
C#
public event EventHandler OnTimeItemAreaClick
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaClick
C++/CLI
public:
event EventHandler^ OnTimeItemAreaClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaDoubleClick Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaDoubleClick Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaDoubleClick As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaDoubleClick, handler
C#
public event EventHandler OnTimeItemAreaDoubleClick
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaDoubleClick
C++/CLI
public:
event EventHandler^ OnTimeItemAreaDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaDragDrop Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaDragDrop Event

Glossary Item Box

Exposed Standard event. Drop points are in form-coordinates, use PointToClient to turn it into a local point. Point p=new Point(e.X,e.Y); GanttRow gr=gantt1.GanttRowFromY(gantt1.TimeItemArea.PointToClient(p).Y);

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaDragDrop As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnTimeItemAreaDragDrop, handler
C#
public event DragEventHandler OnTimeItemAreaDragDrop
Managed Extensions for C++
public: __event DragEventHandler* OnTimeItemAreaDragDrop
C++/CLI
public:
event DragEventHandler^ OnTimeItemAreaDragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaDragEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaDragEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaDragEnter As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnTimeItemAreaDragEnter, handler
C#
public event DragEventHandler OnTimeItemAreaDragEnter
Managed Extensions for C++
public: __event DragEventHandler* OnTimeItemAreaDragEnter
C++/CLI
public:
event DragEventHandler^ OnTimeItemAreaDragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaDragLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaDragLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaDragLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaDragLeave, handler
C#
public event EventHandler OnTimeItemAreaDragLeave
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaDragLeave
C++/CLI
public:
event EventHandler^ OnTimeItemAreaDragLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaDragOver Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaDragOver Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaDragOver As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As DragEventHandler

AddHandler instance.OnTimeItemAreaDragOver, handler
C#
public event DragEventHandler OnTimeItemAreaDragOver
Managed Extensions for C++
public: __event DragEventHandler* OnTimeItemAreaDragOver
C++/CLI
public:
event DragEventHandler^ OnTimeItemAreaDragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaKeyDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaKeyDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaKeyDown As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnTimeItemAreaKeyDown, handler
C#
public event KeyEventHandler OnTimeItemAreaKeyDown
Managed Extensions for C++
public: __event KeyEventHandler* OnTimeItemAreaKeyDown
C++/CLI
public:
event KeyEventHandler^ OnTimeItemAreaKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaKeyUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaKeyUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaKeyUp As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As KeyEventHandler

AddHandler instance.OnTimeItemAreaKeyUp, handler
C#
public event KeyEventHandler OnTimeItemAreaKeyUp
Managed Extensions for C++
public: __event KeyEventHandler* OnTimeItemAreaKeyUp
C++/CLI
public:
event KeyEventHandler^ OnTimeItemAreaKeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseDown Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseDown Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseDown As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnTimeItemAreaMouseDown, handler
C#
public event MouseEventHandler OnTimeItemAreaMouseDown
Managed Extensions for C++
public: __event MouseEventHandler* OnTimeItemAreaMouseDown
C++/CLI
public:
event MouseEventHandler^ OnTimeItemAreaMouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseEnter Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseEnter Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseEnter As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaMouseEnter, handler
C#
public event EventHandler OnTimeItemAreaMouseEnter
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaMouseEnter
C++/CLI
public:
event EventHandler^ OnTimeItemAreaMouseEnter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseHover Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseHover Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseHover As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaMouseHover, handler
C#
public event EventHandler OnTimeItemAreaMouseHover
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaMouseHover
C++/CLI
public:
event EventHandler^ OnTimeItemAreaMouseHover

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseLeave Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseLeave Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseLeave As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As EventHandler

AddHandler instance.OnTimeItemAreaMouseLeave, handler
C#
public event EventHandler OnTimeItemAreaMouseLeave
Managed Extensions for C++
public: __event EventHandler* OnTimeItemAreaMouseLeave
C++/CLI
public:
event EventHandler^ OnTimeItemAreaMouseLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseMove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseMove Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseMove As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnTimeItemAreaMouseMove, handler
C#
public event MouseEventHandler OnTimeItemAreaMouseMove
Managed Extensions for C++
public: __event MouseEventHandler* OnTimeItemAreaMouseMove
C++/CLI
public:
event MouseEventHandler^ OnTimeItemAreaMouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseUp Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseUp Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseUp As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnTimeItemAreaMouseUp, handler
C#
public event MouseEventHandler OnTimeItemAreaMouseUp
Managed Extensions for C++
public: __event MouseEventHandler* OnTimeItemAreaMouseUp
C++/CLI
public:
event MouseEventHandler^ OnTimeItemAreaMouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaMouseWheel Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaMouseWheel Event

Glossary Item Box

Exposed Standard event

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaMouseWheel As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As MouseEventHandler

AddHandler instance.OnTimeItemAreaMouseWheel, handler
C#
public event MouseEventHandler OnTimeItemAreaMouseWheel
Managed Extensions for C++
public: __event MouseEventHandler* OnTimeItemAreaMouseWheel
C++/CLI
public:
event MouseEventHandler^ OnTimeItemAreaMouseWheel

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaPaintBackground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaPaintBackground Event

Glossary Item Box

Fired when it is time to draw the background

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaPaintBackground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnTimeItemAreaPaintBackground, handler
C#
public event OffscreenDrawEvent OnTimeItemAreaPaintBackground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnTimeItemAreaPaintBackground
C++/CLI
public:
event OffscreenDrawEvent^ OnTimeItemAreaPaintBackground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaPaintForeground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaPaintForeground Event

Glossary Item Box

Fired when it is time to draw the foreground

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaPaintForeground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnTimeItemAreaPaintForeground, handler
C#
public event OffscreenDrawEvent OnTimeItemAreaPaintForeground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnTimeItemAreaPaintForeground
C++/CLI
public:
event OffscreenDrawEvent^ OnTimeItemAreaPaintForeground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemAreaScalerPaintBackground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemAreaScalerPaintBackground Event

Glossary Item Box

DEPRECATED, replaced with OnTimeItemAreaPaintBackground

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemAreaScalerPaintBackground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As OffscreenDrawEvent

AddHandler instance.OnTimeItemAreaScalerPaintBackground, handler
C#
public event OffscreenDrawEvent OnTimeItemAreaScalerPaintBackground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnTimeItemAreaScalerPaintBackground
C++/CLI
public:
event OffscreenDrawEvent^ OnTimeItemAreaScalerPaintBackground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTimeItemLink_SelectionChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnTimeItemLink_SelectionChanged Event

Glossary Item Box

Fired when selection has changed on time item link

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemLink_SelectionChanged As TimeItemLinkHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As TimeItemLinkHandler

AddHandler instance.OnTimeItemLink_SelectionChanged, handler
C#
public event TimeItemLinkHandler OnTimeItemLink_SelectionChanged
Managed Extensions for C++
public: __event TimeItemLinkHandler* OnTimeItemLink_SelectionChanged
C++/CLI
public:
event TimeItemLinkHandler^ OnTimeItemLink_SelectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUserDrawLink Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Gantt Class : OnUserDrawLink Event

Glossary Item Box

Fired when link with drawstyle=user need to be drawn. There are two passes to link drawing. First there is the normal draw, the e.G is assigned, and you simply draw the Graphics object supplied. Second there is the selection region pass, this is recongnised by e.G==null and e.BoundingRegion is assigned. Now you can fill the region that is used to decide if a click is on a link or not.

Syntax

Visual Basic (Declaration)
Public Event OnUserDrawLink As UserDrawLinkEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt
Dim handler As UserDrawLinkEvent

AddHandler instance.OnUserDrawLink, handler
C#
public event UserDrawLinkEvent OnUserDrawLink
Managed Extensions for C++
public: __event UserDrawLinkEvent* OnUserDrawLink
C++/CLI
public:
event UserDrawLinkEvent^ OnUserDrawLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt Class
Gantt Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRow Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : GanttRow Class

Glossary Item Box

A Gantt row is owned by a TreeNode and used for time item rendering in layers

Object Model

GanttRow ClassGantt ClassGridNode ClassLayers ClassLayer Class

Syntax

Visual Basic (Declaration)
Public Class GanttRow
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
C#
public class GanttRow
Managed Extensions for C++
public __gc class GanttRow
C++/CLI
public ref class GanttRow

Example

C# Copy Code
GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
            gn.GetCell(0).Content.Value="Sample of time item layouts";
            GanttRow gr = GanttRow.FromGridNode(gn);
            gr.CollisionDetect=false;
Visual Basic Copy Code
Dim gn As GridNode=gantt1.Grid.GridStructure.RootNodes.AddNode()
            gn.GetCell(0).Content.Value="Sample of time item layouts"
            Dim gr As GanttRow = GanttRow.FromGridNode(gn)
            gr.CollisionDetect=False

Inheritance Hierarchy

System.Object
PlexityHide.GTP.GanttRow

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GanttRow Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GanttRow Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GanttRow Class

Glossary Item Box

The following tables list the members exposed by GanttRow.

Public Constructors

 | Name | Description
Public Constructor | GanttRow Constructor | The constructor is used internally
Top

Public Properties

 | Name | Description
Public Property | CollisionDetect | Use collision detect on this row
Public Property | CollisionDetect_UseConflictAreas | Conflict areas will collect detailed information on each detected collision.
Public Property | CollisionDetectBetweenLayers | Tells if collision detect should treat all layers seperatly or not
Public Property | DrawLayerStart | What layer to draw first
Public Property | EffectiveSubColumns | EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)
Public Property | Gantt | The Gantt
Public Property | GridNode | The owning GridNode
Public Property | IncreaseRow_SuggestedHeightPerItem | if IncreaseRowHeightOnCollision is true this value is used for Total row height calculation. The result will be set in the GridNode.UserHeight property
Public Property | IncreaseRowHeightOnCollision | Tells if a collision should make the row height increase or if the colliding time items should be made thinner.
Public Property | Layers | Layers to draw in for this row
Public Property | SubColumns | The number of SubColumns to use. The number of subcolumns actually applied is found in EffectiveSubColumns. EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)
Public Property | SubColumnsFromCollisionDetect | Number of sub columns that are derived from use of collision detect
Public Property | TimeSpanOffset | Can be set to skew the presentation of the row by TimeSpanOffset ticks. Commonly used when each row represents one day. To compare days side by side rows must be skewed 24 hours. If Monday has TimeSpanOffset=0 (Normal and default) TuesDay would have TimeSpanOffset=-1 day, Wednesday=-2 days etc
Top

Public Methods

 | Name | Description
Public Method | BackwardLayer | Prev layer for drawing,, make sure to check the returned Layer.Visible==true
Public Method | ClearSelected | Unselect all selected time items if any
Public Method | Draw | Draws all the time items
Public Method | DrawSelectedWithOffset | Draws selected with an offset, used for drag ops
Public Method | FindTimeItemUserReference | Loops thru the layers and compare x with TimeItem.UserReference
Public Method | FirstDrawLayer | Returns first Layer for drawing, make sure to check the returned Layer.Visible==true
Public Method | ForwardLayer | Next Layer for drawing,, make sure to check the returned Layer.Visible==true
static (Shared in Visual Basic) | FromGridNode | Find GanttRow from GridNode
Public Method | GetSelectedTimeItems | Returns all time items currently selected in this row
Public Method | Invalidate | Invalidate, redraws at the next convinient time
Public Method | LastDrawLayer | Returns last Layer for drawing,, make sure to check the returned Layer.Visible==true
Public Method | Rect | The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned
Public Method | TimeItemFromXY | Find TimeItem from pixel point
Top

See Also

Reference

GanttRow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRow Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : GanttRow Constructor

aOwningGantt
OwningNode

Glossary Item Box

The constructor is used internally

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aOwningGantt As Gantt, _
   ByVal OwningNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim aOwningGantt As Gantt
Dim OwningNode As GridNode

Dim instance As New GanttRow(aOwningGantt, OwningNode)
C#
public GanttRow(
   Gantt aOwningGantt,
   GridNode OwningNode
)
Managed Extensions for C++
public: GanttRow(
   Gantt* aOwningGantt,
   GridNode* OwningNode
)
C++/CLI
public:
GanttRow(
   Gantt^ aOwningGantt,
   GridNode^ OwningNode
)

Parameters

aOwningGantt
OwningNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GanttRow Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GanttRow Class

Glossary Item Box

For a list of all members of this type, see GanttRow members.

Public Methods

 | Name | Description
Public Method | BackwardLayer | Prev layer for drawing,, make sure to check the returned Layer.Visible==true
Public Method | ClearSelected | Unselect all selected time items if any
Public Method | Draw | Draws all the time items
Public Method | DrawSelectedWithOffset | Draws selected with an offset, used for drag ops
Public Method | FindTimeItemUserReference | Loops thru the layers and compare x with TimeItem.UserReference
Public Method | FirstDrawLayer | Returns first Layer for drawing, make sure to check the returned Layer.Visible==true
Public Method | ForwardLayer | Next Layer for drawing,, make sure to check the returned Layer.Visible==true
static (Shared in Visual Basic) | FromGridNode | Find GanttRow from GridNode
Public Method | GetSelectedTimeItems | Returns all time items currently selected in this row
Public Method | Invalidate | Invalidate, redraws at the next convinient time
Public Method | LastDrawLayer | Returns last Layer for drawing,, make sure to check the returned Layer.Visible==true
Public Method | Rect | The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned
Public Method | TimeItemFromXY | Find TimeItem from pixel point
Top

See Also

Reference

GanttRow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackwardLayer Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : BackwardLayer Method

aLayer

Glossary Item Box

Prev layer for drawing,, make sure to check the returned Layer.Visible==true

Syntax

Visual Basic (Declaration)
Public Function BackwardLayer( _
   ByVal aLayer As Layer _
) As Layer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim aLayer As Layer
Dim value As Layer

value = instance.BackwardLayer(aLayer)
C#
public Layer BackwardLayer(
   Layer aLayer
)
Managed Extensions for C++
public: Layer* BackwardLayer(
   Layer* aLayer
)
C++/CLI
public:
Layer^ BackwardLayer(
   Layer^ aLayer
)

Parameters

aLayer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ClearSelected Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : ClearSelected Method

Glossary Item Box

Unselect all selected time items if any

Syntax

Visual Basic (Declaration)
Public Sub ClearSelected()
Visual Basic (Usage) Copy Code
Dim instance As GanttRow

instance.ClearSelected()
C#
public void ClearSelected()
Managed Extensions for C++
public: void ClearSelected();
C++/CLI
public:
void ClearSelected();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : Draw Method

G
layerIndex

Glossary Item Box

Draws all the time items

Syntax

Visual Basic (Declaration)
Public Sub Draw( _
   ByVal G As Graphics, _
   ByVal layerIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim G As Graphics
Dim layerIndex As Integer

instance.Draw(G, layerIndex)
C#
public void Draw(
   Graphics G,
   int layerIndex
)
Managed Extensions for C++
public: void Draw(
   Graphics* G,
   int layerIndex
)
C++/CLI
public:
void Draw(
   Graphics^ G,
   int layerIndex
)

Parameters

G
layerIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawSelectedWithOffset Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : DrawSelectedWithOffset Method

G
offset

Glossary Item Box

Draws selected with an offset, used for drag ops

Syntax

Visual Basic (Declaration)
Public Sub DrawSelectedWithOffset( _
   ByVal G As Graphics, _
   ByVal offset As Point _
)
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim G As Graphics
Dim offset As Point

instance.DrawSelectedWithOffset(G, offset)
C#
public void DrawSelectedWithOffset(
   Graphics G,
   Point offset
)
Managed Extensions for C++
public: void DrawSelectedWithOffset(
   Graphics* G,
   Point offset
)
C++/CLI
public:
void DrawSelectedWithOffset(
   Graphics^ G,
   Point offset
)

Parameters

G
offset

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FindTimeItemUserReference Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : FindTimeItemUserReference Method

x

Glossary Item Box

Loops thru the layers and compare x with TimeItem.UserReference

Syntax

Visual Basic (Declaration)
Public Function FindTimeItemUserReference( _
   ByVal x As Object _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim x As Object
Dim value As TimeItem

value = instance.FindTimeItemUserReference(x)
C#
public TimeItem FindTimeItemUserReference(
   object x
)
Managed Extensions for C++
public: TimeItem* FindTimeItemUserReference(
   Object* x
)
C++/CLI
public:
TimeItem^ FindTimeItemUserReference(
   Object^ x
)

Parameters

x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FirstDrawLayer Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : FirstDrawLayer Method

Glossary Item Box

Returns first Layer for drawing, make sure to check the returned Layer.Visible==true

Syntax

Visual Basic (Declaration)
Public Function FirstDrawLayer() As Layer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Layer

value = instance.FirstDrawLayer()
C#
public Layer FirstDrawLayer()
Managed Extensions for C++
public: Layer* FirstDrawLayer();
C++/CLI
public:
Layer^ FirstDrawLayer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ForwardLayer Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : ForwardLayer Method

aLayer

Glossary Item Box

Next Layer for drawing,, make sure to check the returned Layer.Visible==true

Syntax

Visual Basic (Declaration)
Public Function ForwardLayer( _
   ByVal aLayer As Layer _
) As Layer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim aLayer As Layer
Dim value As Layer

value = instance.ForwardLayer(aLayer)
C#
public Layer ForwardLayer(
   Layer aLayer
)
Managed Extensions for C++
public: Layer* ForwardLayer(
   Layer* aLayer
)
C++/CLI
public:
Layer^ ForwardLayer(
   Layer^ aLayer
)

Parameters

aLayer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FromGridNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : FromGridNode Method

aNode

Glossary Item Box

Find GanttRow from GridNode

Syntax

Visual Basic (Declaration)
Public Shared Function FromGridNode( _
   ByVal aNode As GridNode _
) As GanttRow
Visual Basic (Usage) Copy Code
Dim aNode As GridNode
Dim value As GanttRow

value = GanttRow.FromGridNode(aNode)
C#
public static GanttRow FromGridNode(
   GridNode aNode
)
Managed Extensions for C++
public: static GanttRow* FromGridNode(
   GridNode* aNode
)
C++/CLI
public:
static GanttRow^ FromGridNode(
   GridNode^ aNode
)

Parameters

aNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetSelectedTimeItems Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : GetSelectedTimeItems Method

Glossary Item Box

Returns all time items currently selected in this row

Syntax

Visual Basic (Declaration)
Public Function GetSelectedTimeItems() As TimeItem()
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value() As TimeItem

value = instance.GetSelectedTimeItems()
C#
public TimeItem[] GetSelectedTimeItems()
Managed Extensions for C++
public: TimeItem*[]* GetSelectedTimeItems();
C++/CLI
public:
array<TimeItem^>^ GetSelectedTimeItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Invalidate Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : Invalidate Method

Glossary Item Box

Invalidate, redraws at the next convinient time

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As GanttRow

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LastDrawLayer Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : LastDrawLayer Method

Glossary Item Box

Returns last Layer for drawing,, make sure to check the returned Layer.Visible==true

Syntax

Visual Basic (Declaration)
Public Function LastDrawLayer() As Layer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Layer

value = instance.LastDrawLayer()
C#
public Layer LastDrawLayer()
Managed Extensions for C++
public: Layer* LastDrawLayer();
C++/CLI
public:
Layer^ LastDrawLayer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : Rect Method

Glossary Item Box

The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned

Syntax

Visual Basic (Declaration)
Public Function Rect() As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Rectangle

value = instance.Rect()
C#
public Rectangle Rect()
Managed Extensions for C++
public: Rectangle Rect();
C++/CLI
public:
Rectangle Rect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemFromXY Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : TimeItemFromXY Method

x
y

Glossary Item Box

Find TimeItem from pixel point

Syntax

Visual Basic (Declaration)
Public Function TimeItemFromXY( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim x As Integer
Dim y As Integer
Dim value As TimeItem

value = instance.TimeItemFromXY(x, y)
C#
public TimeItem TimeItemFromXY(
   int x,
   int y
)
Managed Extensions for C++
public: TimeItem* TimeItemFromXY(
   int x,
   int y
)
C++/CLI
public:
TimeItem^ TimeItemFromXY(
   int x,
   int y
)

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GanttRow Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GanttRow Class

Glossary Item Box

For a list of all members of this type, see GanttRow members.

Public Properties

 | Name | Description
Public Property | CollisionDetect | Use collision detect on this row
Public Property | CollisionDetect_UseConflictAreas | Conflict areas will collect detailed information on each detected collision.
Public Property | CollisionDetectBetweenLayers | Tells if collision detect should treat all layers seperatly or not
Public Property | DrawLayerStart | What layer to draw first
Public Property | EffectiveSubColumns | EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)
Public Property | Gantt | The Gantt
Public Property | GridNode | The owning GridNode
Public Property | IncreaseRow_SuggestedHeightPerItem | if IncreaseRowHeightOnCollision is true this value is used for Total row height calculation. The result will be set in the GridNode.UserHeight property
Public Property | IncreaseRowHeightOnCollision | Tells if a collision should make the row height increase or if the colliding time items should be made thinner.
Public Property | Layers | Layers to draw in for this row
Public Property | SubColumns | The number of SubColumns to use. The number of subcolumns actually applied is found in EffectiveSubColumns. EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)
Public Property | SubColumnsFromCollisionDetect | Number of sub columns that are derived from use of collision detect
Public Property | TimeSpanOffset | Can be set to skew the presentation of the row by TimeSpanOffset ticks. Commonly used when each row represents one day. To compare days side by side rows must be skewed 24 hours. If Monday has TimeSpanOffset=0 (Normal and default) TuesDay would have TimeSpanOffset=-1 day, Wednesday=-2 days etc
Top

See Also

Reference

GanttRow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : CollisionDetect Property

Glossary Item Box

Use collision detect on this row

Syntax

Visual Basic (Declaration)
Public Property CollisionDetect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Boolean

instance.CollisionDetect = value

value = instance.CollisionDetect
C#
public bool CollisionDetect {get; set;}
Managed Extensions for C++
public: __property bool get_CollisionDetect();
public: __property void set_CollisionDetect(
   bool value
);
C++/CLI
public:
property bool CollisionDetect {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetect_UseConflictAreas Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : CollisionDetect_UseConflictAreas Property

Glossary Item Box

Conflict areas will collect detailed information on each detected collision.

Syntax

Visual Basic (Declaration)
Public Property CollisionDetect_UseConflictAreas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Boolean

instance.CollisionDetect_UseConflictAreas = value

value = instance.CollisionDetect_UseConflictAreas
C#
public bool CollisionDetect_UseConflictAreas {get; set;}
Managed Extensions for C++
public: __property bool get_CollisionDetect_UseConflictAreas();
public: __property void set_CollisionDetect_UseConflictAreas(
   bool value
);
C++/CLI
public:
property bool CollisionDetect_UseConflictAreas {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetectBetweenLayers Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : CollisionDetectBetweenLayers Property

Glossary Item Box

Tells if collision detect should treat all layers seperatly or not

Syntax

Visual Basic (Declaration)
Public Property CollisionDetectBetweenLayers As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Boolean

instance.CollisionDetectBetweenLayers = value

value = instance.CollisionDetectBetweenLayers
C#
public bool CollisionDetectBetweenLayers {get; set;}
Managed Extensions for C++
public: __property bool get_CollisionDetectBetweenLayers();
public: __property void set_CollisionDetectBetweenLayers(
   bool value
);
C++/CLI
public:
property bool CollisionDetectBetweenLayers {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawLayerStart Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : DrawLayerStart Property

Glossary Item Box

What layer to draw first

Syntax

Visual Basic (Declaration)
Public Property DrawLayerStart As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Integer

instance.DrawLayerStart = value

value = instance.DrawLayerStart
C#
public int DrawLayerStart {get; set;}
Managed Extensions for C++
public: __property int get_DrawLayerStart();
public: __property void set_DrawLayerStart(
   int value
);
C++/CLI
public:
property int DrawLayerStart {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EffectiveSubColumns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : EffectiveSubColumns Property

Glossary Item Box

EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property EffectiveSubColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Integer

value = instance.EffectiveSubColumns
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int EffectiveSubColumns {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_EffectiveSubColumns();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int EffectiveSubColumns {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : Gantt Property

Glossary Item Box

The Gantt

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Gantt As Gantt
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Gantt

value = instance.Gantt
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Gantt Gantt {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Gantt* get_Gantt();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Gantt^ Gantt {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : GridNode Property

Glossary Item Box

The owning GridNode

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GridNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As GridNode

value = instance.GridNode
C#
public GridNode GridNode {get;}
Managed Extensions for C++
public: __property GridNode* get_GridNode();
C++/CLI
public:
property GridNode^ GridNode {
   GridNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IncreaseRow_SuggestedHeightPerItem Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : IncreaseRow_SuggestedHeightPerItem Property

Glossary Item Box

if IncreaseRowHeightOnCollision is true this value is used for Total row height calculation. The result will be set in the GridNode.UserHeight property

Syntax

Visual Basic (Declaration)
Public Property IncreaseRow_SuggestedHeightPerItem As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Integer

instance.IncreaseRow_SuggestedHeightPerItem = value

value = instance.IncreaseRow_SuggestedHeightPerItem
C#
public int IncreaseRow_SuggestedHeightPerItem {get; set;}
Managed Extensions for C++
public: __property int get_IncreaseRow_SuggestedHeightPerItem();
public: __property void set_IncreaseRow_SuggestedHeightPerItem(
   int value
);
C++/CLI
public:
property int IncreaseRow_SuggestedHeightPerItem {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IncreaseRowHeightOnCollision Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : IncreaseRowHeightOnCollision Property

Glossary Item Box

Tells if a collision should make the row height increase or if the colliding time items should be made thinner.

Syntax

Visual Basic (Declaration)
Public Property IncreaseRowHeightOnCollision As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Boolean

instance.IncreaseRowHeightOnCollision = value

value = instance.IncreaseRowHeightOnCollision
C#
public bool IncreaseRowHeightOnCollision {get; set;}
Managed Extensions for C++
public: __property bool get_IncreaseRowHeightOnCollision();
public: __property void set_IncreaseRowHeightOnCollision(
   bool value
);
C++/CLI
public:
property bool IncreaseRowHeightOnCollision {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : Layers Property

Glossary Item Box

Layers to draw in for this row

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As Layers
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Layers

value = instance.Layers
C#
public Layers Layers {get;}
Managed Extensions for C++
public: __property Layers* get_Layers();
C++/CLI
public:
property Layers^ Layers {
   Layers^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubColumns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : SubColumns Property

Glossary Item Box

The number of SubColumns to use. The number of subcolumns actually applied is found in EffectiveSubColumns. EffectiveSubColumns equals Math.Max(SubColumnsFromCollisionDetect,SubColumns)

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property SubColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Integer

instance.SubColumns = value

value = instance.SubColumns
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int SubColumns {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_SubColumns();
public: __property void set_SubColumns(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int SubColumns {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubColumnsFromCollisionDetect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : SubColumnsFromCollisionDetect Property

Glossary Item Box

Number of sub columns that are derived from use of collision detect

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SubColumnsFromCollisionDetect As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As Integer

value = instance.SubColumnsFromCollisionDetect
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int SubColumnsFromCollisionDetect {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_SubColumnsFromCollisionDetect();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int SubColumnsFromCollisionDetect {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeSpanOffset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GanttRow Class : TimeSpanOffset Property

Glossary Item Box

Can be set to skew the presentation of the row by TimeSpanOffset ticks. Commonly used when each row represents one day. To compare days side by side rows must be skewed 24 hours. If Monday has TimeSpanOffset=0 (Normal and default) TuesDay would have TimeSpanOffset=-1 day, Wednesday=-2 days etc

Syntax

Visual Basic (Declaration)
Public Property TimeSpanOffset As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As GanttRow
Dim value As TimeSpan

instance.TimeSpanOffset = value

value = instance.TimeSpanOffset
C#
public TimeSpan TimeSpanOffset {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_TimeSpanOffset();
public: __property void set_TimeSpanOffset(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan TimeSpanOffset {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRow Class
GanttRow Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Grid Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : Grid Class

Glossary Item Box

The Grid component. This grid can work stand-alone or as a part of the Gantt.

Object Model

Grid ClassCellLayouts ClassCellLayout ClassGridColumns ClassGridColumn ClassEditPickValueWindow ClassCell ClassGridStructure ClassGridNode ClassGridNodes ClassGridNode Class

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class Grid
   Inherits OffscreenDraw
Visual Basic (Usage) Copy Code
Dim instance As Grid
C#
[ToolboxBitmapAttribute()]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class Grid : OffscreenDraw
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class Grid : public OffscreenDraw
C++/CLI
[ToolboxBitmapAttribute()]
[LicenseProviderAttribute(PlexityHide.GTP.LicenseProvider)]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class Grid : public OffscreenDraw

Example

Grid CellLayouts and GridColumns in a typical setup
C# Copy Code
private void button1_Click(object sender, System.EventArgs e)
    {

      CellLayout layout=new CellLayout();
      layout.MinHeight=20;
      layout.Font=new Font("Microsoft Sans Serif",10);
      layout.FontColor=Color.Black;
      layout.VertAlign=StringAlignment.Center;
      layout.Name="layout";
      layout.HeaderBackgroundColor=SystemColors.Control;
      layout.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor;
      layout.LineRight.Use=true;
      layout.LineRight.Color=SystemColors.ControlDark;
      layout.LineTop.Use=false;
      layout.LineBottom.Use=false;
      gantt1.Grid.CellLayouts.Add(layout);

      CellLayout layoutrightjust=new CellLayout();
      layoutrightjust.MinHeight=20;
      layoutrightjust.LineRight.Use=true;
      layoutrightjust.LineRight.Color=SystemColors.ControlDark;
      layoutrightjust.LineTop.Use=false;
      layoutrightjust.LineBottom.Use=false;
      layoutrightjust.Font=new Font("Microsoft Sans Serif",10);
      layoutrightjust.FontColor=Color.Black;
      layoutrightjust.Name="layoutrightjust";
      layoutrightjust.HorzAlign=StringAlignment.Far;
      layoutrightjust.VertAlign=StringAlignment.Center;
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor;
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor;
      gantt1.Grid.CellLayouts.Add(layoutrightjust);

      gantt1.Grid.PyjamasColor=Color.White;
      gantt1.Grid.PyjamasGradientColor=gantt1.Grid.PyjamasColor;

      GridColumn idcol=gantt1.Grid.Columns.AddNew(CellType.SingleText);
      idcol.Title="Id";
      idcol.LayoutName="layoutrightjust";
      idcol.Width=20;

      GridColumn titlecol=gantt1.Grid.Columns.AddNew(CellType.SingleText);
      titlecol.Title="Title";
      titlecol.LayoutName="layout";
      titlecol.Tree=true;
      idcol.Width=100;

      GridColumn startcol=gantt1.Grid.Columns.AddNew(CellType.TimeDate);
      startcol.Title="Start";
      startcol.LayoutName="layout";
      idcol.Width=80;

      gantt1.PyjamasColor=Color.FromArgb(0xCB,0xE2,0xFE);
      gantt1.PyjamasGradientColor=gantt1.PyjamasColor;
      gantt1.TimeItemArea.BackColor=Color.White;

      gantt1.GridWidth=200;

      GridNode node,subnode;
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode());
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
      subnode=InitNode(node.SubNodes.AddNode());
    }
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As System.EventArgs)

      Dim layout As CellLayout = New CellLayout()
      layout.MinHeight=20
      layout.Font = New Font("Microsoft Sans Serif",10)
      layout.FontColor=Color.Black
      layout.VertAlign=StringAlignment.Center
      layout.Name="layout"
      layout.HeaderBackgroundColor=SystemColors.Control
      layout.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor
      layout.LineRight.Use=True
      layout.LineRight.Color=SystemColors.ControlDark
      layout.LineTop.Use=False
      layout.LineBottom.Use=False
      gantt1.Grid.CellLayouts.Add(layout)

      Dim layoutrightjust As CellLayout = New CellLayout()
      layoutrightjust.MinHeight=20
      layoutrightjust.LineRight.Use=True
      layoutrightjust.LineRight.Color=SystemColors.ControlDark
      layoutrightjust.LineTop.Use=False
      layoutrightjust.LineBottom.Use=False
      layoutrightjust.Font = New Font("Microsoft Sans Serif",10)
      layoutrightjust.FontColor=Color.Black
      layoutrightjust.Name="layoutrightjust"
      layoutrightjust.HorzAlign=StringAlignment.Far
      layoutrightjust.VertAlign=StringAlignment.Center
      layoutrightjust.HeaderBackgroundColor=layout.HeaderBackgroundColor
      layoutrightjust.HeaderBackgroundGradiantColor=layout.HeaderBackgroundColor
      gantt1.Grid.CellLayouts.Add(layoutrightjust)

      gantt1.Grid.PyjamasColor=Color.White
      gantt1.Grid.PyjamasGradientColor=gantt1.Grid.PyjamasColor

      Dim idcol As GridColumn=gantt1.Grid.Columns.AddNew(CellType.SingleText)
      idcol.Title="Id"
      idcol.LayoutName="layoutrightjust"
      idcol.Width=20

      Dim titlecol As GridColumn=gantt1.Grid.Columns.AddNew(CellType.SingleText)
      titlecol.Title="Title"
      titlecol.LayoutName="layout"
      titlecol.Tree=True
      idcol.Width=100

      Dim startcol As GridColumn=gantt1.Grid.Columns.AddNew(CellType.TimeDate)
      startcol.Title="Start"
      startcol.LayoutName="layout"
      idcol.Width=80

      gantt1.PyjamasColor=Color.FromArgb(&HCB,&HE2,&HFE)
      gantt1.PyjamasGradientColor=gantt1.PyjamasColor
      gantt1.TimeItemArea.BackColor=Color.White

      gantt1.GridWidth=200

      Dim node, subnode As GridNode
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode())
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
      node=InitNode(gantt1.Grid.GridStructure.RootNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
      subnode=InitNode(node.SubNodes.AddNode())
    End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PlexityHide.GTP.OffscreenDraw
PlexityHide.GTP.Grid

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Grid Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Grid Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : Grid Class

Glossary Item Box

The following tables list the members exposed by Grid.

Public Constructors

 | Name | Description
Public Constructor | Grid Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowRowResize | Controls if the user should be allowed to drag rows to resize them
Public Property | AutoCreateColumnsFromDataset | Set to true(deafult) and columns will be autocreated from dataset...
Public Property | BackgroundImage | Overridden.
Public Property | BorderStyle | BorderStyle BorderStyle effect has been removed in version 2.3.1.13. From this version we are fully security aware,and the assembly can be integrated into IE or ClickOnce Applications with no trust. The implementation of borderstyle required an overide of CreateParams. Overriding CreateParams is a violation of UISecurity that is non trappable and we had to remove it.
Public Property | BottomColor | Set bottom color of the grid.
Public Property | CellLayouts | Returns the list of cell layout properties.
Public Property | Columns | Returns the columns for the main grid-structure
Public Property | CurrentEditor | Cells keep their editor here when in or about to enter edit mode
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | EditPickValueWindow | Access to the window that optionally shows under the edit to help the user with values to pick
Public Property | FlipView | Overridden. Overrides the FlipView of OffscreenDraw
Public Property | FocusedCell | Returns or sets the cell currently in focus, alway the last one selected. Same as Grid.GridStructure.FocusedCell
Public Property | GridStructure | Returns the set of nodes.
Public Property | HasHeader | Header cells visible or not
Public Property | HasUserRowHeightsChanged | True when the Grid will need a second draw pass. Turns false on Draw, Turns true by GanttRow.IncreaseRowHeightOnCollision
Public Property | ImageList | Image list
Public Property | MinWidthOfFlipViewColumns | This is the smallest value allowed for the grid row width's when in the FlipView mode
Public Property | PrintStartNodeForNextPage | This GridNode value is updated for each printed page. It will be set to the GridNode that did not fit the last printed page, and it will be the first printed GridNode on the page if you call PrintPage again. The value is set by the PrintInit method, and it is reset to null by the PrintEnd method, so it will only be meaningfull to change the value between PrintInit and PrintEnd. Setting the value to null will be interperted as GridStructure.FirstVisibleNode.
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | Access to rootnodes also available via GridStructure
Public Property | RootNodes_DataMember | Datamember for root nodes
Public Property | RootNodes_DataSource | Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | RootNodes_DataSourceList | Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | ScrollbarColumns | Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...
Public Property | ScrollbarNodes | Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...
Public Property | SelectNewdataBoundRows | When this property is true a single added row to a IListSource will be selected. The Cell stays in the same column if SelectNewdataBoundRows_KeepColumn=true, the row is changed.
Public Property | SelectNewdataBoundRows_KeepColumn | When the SelectNewdataBoundRows property is true a single added row to a IListSource will be selected. The Cell stays in the same column when SelectNewdataBoundRows_KeepColumn=true, the row is changed.
Public Property | StepCellOnTab | When this property is true Tab steps no next cell. Otherwise Tab steps between controls (default).
Public Property | TreeLevelInset | This value controls the indentation that is made for each level in a tree. The default value is 13.
Top

Public Methods

 | Name | Description
Public Method | AddCellLayoutProperty | Add a new cell property to the collection.
Public Method | CopySelectedCellsToClipBoard | Copies the selected cells to the clipboard
Public Method | EditPickValueWindowVisible | True if the EditPickWindow is visible
Public Method | EndEdit | Stop any editing that might be in progress.
Public Method | FindGridNodeUserReference | Loops thru all GridNodes and compare x with GridNode.UserReference.
Public Method | MakeSureVisible | If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.
Public Method | PasteClipBoardToFocusedCell | Pastes the focused cell to the clipboard
Public Method | PrintEnd | Overridden. Clean up after print
Public Method | PrintInit | Overloaded. Overridden. Call to initiate a print sequence
Public Method | PrintPage | Overloaded. Prints one page
Public Method | SetCurrentEditor | If you use custom editor, let grid know by calling this with your editor control and the cell
Public Method | StopColumnMove | Stops any ColumnMove operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | StopColumnResize | Stops any ColumnResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | StopRowResize | Stops any RowResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | UpdateDesiredSizeInColumns | Call this to force a draw that also ask each cell for its desired size and sets the biggest value for column in the GridColumn DesiredSize property
Top

Public Events

 | Name | Description
Public Event | OnAfterEditCell | Fires when editor has closed.
Public Event | OnBeforeEditCell | Fires before editor is shown, do you extra init here, or prevent show
Public Event | OnBeforeEndEditCell | Fires when editor closes, do extra apply checks here
Public Event | OnBeforeFocusedCellChange | Fires before the grid shiftes focus from one cell to another
Public Event | OnCellSelectChanged | Cell Selection status is changing
Public Event | OnCellTypeChoose | Cell is about to be added, you can change type on it here
Public Event | OnColumnOrderChanged | Fires when a column is moved to another position by a gui-action (not if you set it by code).
Public Event | OnColumnWidthChanged | Fires when the column width is changed by a gui-action (not if you set it by code). The event will fire multiple times while the user drags the column to the desired width.
Public Event | OnCustomCellDraw | Draw the content of the cell when not in edit mode
Public Event | OnCustomCellEditStartByKey | Edit is started by key
Public Event | OnCustomCellEditStartByMouse | Edit is started by clicking
Public Event | OnCustomCellEndEdit | Edit is finished
Public Event | OnCustomCellHeight | Shall return height of cell
Public Event | OnEachListItemWhenDataBound_GridNode | Called for each GridNode when Grid is DataBound and datasource row is changed. This is a good place to set up ChildViews for SubNodes etc
Public Event | OnGridRedrawn | Called when the grid is redrawn
Public Event | OnNodeExpandStatus | Node expansion status is changing
Public Event | OnNodeInserted | fires on node insert
Public Event | OnNodeRemove | fires on node remove
Public Event | OnRowResize | Event fires when user resizes a row. You can implement this event and limit, change or prevent the interaction here.
Public Event | OnRowResizeDone | Event fires when user has resized a row. You can implement this event to do other changes that you want as a result of a row height change, like if you want to change all other Grid rows the same way.
Public Event | OnTopLeftChanged | TopLeft cell has changed, scrolling in progress
Public Event | OnUnBindedSort | Event fires when an unbinded list is to be sorted
Public Event | OnUserDrawSortSymbol | Implement to override sort symbol.
Top

See Also

Reference

Grid Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Grid Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : Grid Constructor

Glossary Item Box

Overload List

Overload | Description
Grid Constructor(IContainer) |
Grid Constructor() |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Grid Constructor(IContainer)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > Grid Constructor : Grid Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Grid(container)
C#
public Grid(
   IContainer container
)
Managed Extensions for C++
public: Grid(
   IContainer* container
)
C++/CLI
public:
Grid(
   IContainer^ container
)

Parameters

container

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Grid Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > Grid Constructor : Grid Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Grid()
C#
public Grid()
Managed Extensions for C++
public: Grid();
C++/CLI
public:
Grid();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Grid Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Grid Class

Glossary Item Box

For a list of all members of this type, see Grid members.

Public Methods

 | Name | Description
Public Method | AddCellLayoutProperty | Add a new cell property to the collection.
Public Method | CopySelectedCellsToClipBoard | Copies the selected cells to the clipboard
Public Method | EditPickValueWindowVisible | True if the EditPickWindow is visible
Public Method | EndEdit | Stop any editing that might be in progress.
Public Method | FindGridNodeUserReference | Loops thru all GridNodes and compare x with GridNode.UserReference.
Public Method | MakeSureVisible | If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.
Public Method | PasteClipBoardToFocusedCell | Pastes the focused cell to the clipboard
Public Method | PrintEnd | Overridden. Clean up after print
Public Method | PrintInit | Overloaded. Overridden. Call to initiate a print sequence
Public Method | PrintPage | Overloaded. Prints one page
Public Method | SetCurrentEditor | If you use custom editor, let grid know by calling this with your editor control and the cell
Public Method | StopColumnMove | Stops any ColumnMove operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | StopColumnResize | Stops any ColumnResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | StopRowResize | Stops any RowResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.
Public Method | UpdateDesiredSizeInColumns | Call this to force a draw that also ask each cell for its desired size and sets the biggest value for column in the GridColumn DesiredSize property
Top

See Also

Reference

Grid Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddCellLayoutProperty Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : AddCellLayoutProperty Method

Glossary Item Box

Add a new cell property to the collection.

Syntax

Visual Basic (Declaration)
Public Function AddCellLayoutProperty() As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As CellLayout

value = instance.AddCellLayoutProperty()
C#
public CellLayout AddCellLayoutProperty()
Managed Extensions for C++
public: CellLayout* AddCellLayoutProperty();
C++/CLI
public:
CellLayout^ AddCellLayoutProperty();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopySelectedCellsToClipBoard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : CopySelectedCellsToClipBoard Method

Glossary Item Box

Copies the selected cells to the clipboard

Syntax

Visual Basic (Declaration)
Public Function CopySelectedCellsToClipBoard() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

value = instance.CopySelectedCellsToClipBoard()
C#
public bool CopySelectedCellsToClipBoard()
Managed Extensions for C++
public: bool CopySelectedCellsToClipBoard();
C++/CLI
public:
bool CopySelectedCellsToClipBoard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditPickValueWindowVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : EditPickValueWindowVisible Method

Glossary Item Box

True if the EditPickWindow is visible

Syntax

Visual Basic (Declaration)
Public Function EditPickValueWindowVisible() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

value = instance.EditPickValueWindowVisible()
C#
public bool EditPickValueWindowVisible()
Managed Extensions for C++
public: bool EditPickValueWindowVisible();
C++/CLI
public:
bool EditPickValueWindowVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EndEdit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : EndEdit Method

Glossary Item Box

Stop any editing that might be in progress.

Syntax

Visual Basic (Declaration)
Public Sub EndEdit()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.EndEdit()
C#
public void EndEdit()
Managed Extensions for C++
public: void EndEdit();
C++/CLI
public:
void EndEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FindGridNodeUserReference Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : FindGridNodeUserReference Method

x

Glossary Item Box

Loops thru all GridNodes and compare x with GridNode.UserReference.

Syntax

Visual Basic (Declaration)
Public Function FindGridNodeUserReference( _
   ByVal x As Object _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim x As Object
Dim value As GridNode

value = instance.FindGridNodeUserReference(x)
C#
public GridNode FindGridNodeUserReference(
   object x
)
Managed Extensions for C++
public: GridNode* FindGridNodeUserReference(
   Object* x
)
C++/CLI
public:
GridNode^ FindGridNodeUserReference(
   Object^ x
)

Parameters

x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MakeSureVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : MakeSureVisible Method

gn

Glossary Item Box

If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.

Syntax

Visual Basic (Declaration)
Public Sub MakeSureVisible( _
   ByVal gn As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim gn As GridNode

instance.MakeSureVisible(gn)
C#
public void MakeSureVisible(
   GridNode gn
)
Managed Extensions for C++
public: void MakeSureVisible(
   GridNode* gn
)
C++/CLI
public:
void MakeSureVisible(
   GridNode^ gn
)

Parameters

gn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteClipBoardToFocusedCell Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PasteClipBoardToFocusedCell Method

Glossary Item Box

Pastes the focused cell to the clipboard

Syntax

Visual Basic (Declaration)
Public Function PasteClipBoardToFocusedCell() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

value = instance.PasteClipBoardToFocusedCell()
C#
public bool PasteClipBoardToFocusedCell()
Managed Extensions for C++
public: bool PasteClipBoardToFocusedCell();
C++/CLI
public:
bool PasteClipBoardToFocusedCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintEnd Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PrintEnd Method

Glossary Item Box

Clean up after print

Syntax

Visual Basic (Declaration)
Public Overrides Sub PrintEnd()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.PrintEnd()
C#
public override void PrintEnd()
Managed Extensions for C++
public: void PrintEnd(); override
C++/CLI
public:
void PrintEnd(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintInit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PrintInit Method

Glossary Item Box

Call to initiate a print sequence

Overload List

Overload | Description
PrintInit() | Call to initiate a print sequence
PrintInit(GridNode) | Call to initiate a print sequence

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintInit() Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > PrintInit Method : PrintInit() Method

Glossary Item Box

Call to initiate a print sequence

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub PrintInit()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.PrintInit()
C#
public override void PrintInit()
Managed Extensions for C++
public: void PrintInit(); override
C++/CLI
public:
void PrintInit(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintInit(GridNode) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > PrintInit Method : PrintInit(GridNode) Method

start

Glossary Item Box

Call to initiate a print sequence

Syntax

Visual Basic (Declaration)
Public Overloads Sub PrintInit( _
   ByVal start As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim start As GridNode

instance.PrintInit(start)
C#
public void PrintInit(
   GridNode start
)
Managed Extensions for C++
public: void PrintInit(
   GridNode* start
)
C++/CLI
public:
void PrintInit(
   GridNode^ start
)

Parameters

start

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PrintPage Method

Glossary Item Box

Prints one page

Overload List

Overload | Description
PrintPage(Graphics,Rectangle,Boolean) | Prints one page
PrintPage(Graphics,Rectangle,Boolean,Boolean) | Prints one page. If you need to break up the print over the X-axis you simply set doNotStepGridWillPrintTheSameRowsOneMoreTime=true

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage(Graphics,Rectangle,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > PrintPage Method : PrintPage(Graphics,Rectangle,Boolean) Method

G
Margins
HasMorePages

Glossary Item Box

Prints one page

Syntax

Visual Basic (Declaration)
Public Overloads Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle, _
   ByRef HasMorePages As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim G As Graphics
Dim Margins As Rectangle
Dim HasMorePages As Boolean

instance.PrintPage(G, Margins, HasMorePages)
C#
public void PrintPage(
   Graphics G,
   Rectangle Margins,
   ref bool HasMorePages
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins,
   ref bool HasMorePages
)
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins,
   bool% HasMorePages
)

Parameters

G
Margins
HasMorePages

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage(Graphics,Rectangle,Boolean,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class > PrintPage Method : PrintPage(Graphics,Rectangle,Boolean,Boolean) Method

G
Margins
HasMorePages
doNotStepGridWillPrintTheSameRowsOneMoreTime

Glossary Item Box

Prints one page. If you need to break up the print over the X-axis you simply set doNotStepGridWillPrintTheSameRowsOneMoreTime=true

Syntax

Visual Basic (Declaration)
Public Overloads Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle, _
   ByRef HasMorePages As Boolean, _
   ByVal doNotStepGridWillPrintTheSameRowsOneMoreTime As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim G As Graphics
Dim Margins As Rectangle
Dim HasMorePages As Boolean
Dim doNotStepGridWillPrintTheSameRowsOneMoreTime As Boolean

instance.PrintPage(G, Margins, HasMorePages, doNotStepGridWillPrintTheSameRowsOneMoreTime)
C#
public void PrintPage(
   Graphics G,
   Rectangle Margins,
   ref bool HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins,
   ref bool HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins,
   bool% HasMorePages,
   bool doNotStepGridWillPrintTheSameRowsOneMoreTime
)

Parameters

G
Margins
HasMorePages
doNotStepGridWillPrintTheSameRowsOneMoreTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
SetCurrentEditor Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : SetCurrentEditor Method

value
cell

Glossary Item Box

If you use custom editor, let grid know by calling this with your editor control and the cell

Syntax

Visual Basic (Declaration)
Public Sub SetCurrentEditor( _
   ByVal value As Object, _
   ByVal cell As Cell _
)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Object
Dim cell As Cell

instance.SetCurrentEditor(value, cell)
C#
public void SetCurrentEditor(
   object value,
   Cell cell
)
Managed Extensions for C++
public: void SetCurrentEditor(
   Object* value,
   Cell* cell
)
C++/CLI
public:
void SetCurrentEditor(
   Object^ value,
   Cell^ cell
)

Parameters

value
cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StopColumnMove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : StopColumnMove Method

Glossary Item Box

Stops any ColumnMove operation that might be going on. This call is usefull if you implement drag and drop in the grid.

Syntax

Visual Basic (Declaration)
Public Sub StopColumnMove()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.StopColumnMove()
C#
public void StopColumnMove()
Managed Extensions for C++
public: void StopColumnMove();
C++/CLI
public:
void StopColumnMove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StopColumnResize Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : StopColumnResize Method

Glossary Item Box

Stops any ColumnResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.

Syntax

Visual Basic (Declaration)
Public Sub StopColumnResize()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.StopColumnResize()
C#
public void StopColumnResize()
Managed Extensions for C++
public: void StopColumnResize();
C++/CLI
public:
void StopColumnResize();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StopRowResize Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : StopRowResize Method

Glossary Item Box

Stops any RowResize operation that might be going on. This call is usefull if you implement drag and drop in the grid.

Syntax

Visual Basic (Declaration)
Public Sub StopRowResize()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.StopRowResize()
C#
public void StopRowResize()
Managed Extensions for C++
public: void StopRowResize();
C++/CLI
public:
void StopRowResize();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UpdateDesiredSizeInColumns Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : UpdateDesiredSizeInColumns Method

Glossary Item Box

Call this to force a draw that also ask each cell for its desired size and sets the biggest value for column in the GridColumn DesiredSize property

Syntax

Visual Basic (Declaration)
Public Sub UpdateDesiredSizeInColumns()
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.UpdateDesiredSizeInColumns()
C#
public void UpdateDesiredSizeInColumns()
Managed Extensions for C++
public: void UpdateDesiredSizeInColumns();
C++/CLI
public:
void UpdateDesiredSizeInColumns();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Grid Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Grid Class

Glossary Item Box

For a list of all members of this type, see Grid members.

Public Properties

 | Name | Description
Public Property | AllowRowResize | Controls if the user should be allowed to drag rows to resize them
Public Property | AutoCreateColumnsFromDataset | Set to true(deafult) and columns will be autocreated from dataset...
Public Property | BackgroundImage | Overridden.
Public Property | BorderStyle | BorderStyle BorderStyle effect has been removed in version 2.3.1.13. From this version we are fully security aware,and the assembly can be integrated into IE or ClickOnce Applications with no trust. The implementation of borderstyle required an overide of CreateParams. Overriding CreateParams is a violation of UISecurity that is non trappable and we had to remove it.
Public Property | BottomColor | Set bottom color of the grid.
Public Property | CellLayouts | Returns the list of cell layout properties.
Public Property | Columns | Returns the columns for the main grid-structure
Public Property | CurrentEditor | Cells keep their editor here when in or about to enter edit mode
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | EditPickValueWindow | Access to the window that optionally shows under the edit to help the user with values to pick
Public Property | FlipView | Overridden. Overrides the FlipView of OffscreenDraw
Public Property | FocusedCell | Returns or sets the cell currently in focus, alway the last one selected. Same as Grid.GridStructure.FocusedCell
Public Property | GridStructure | Returns the set of nodes.
Public Property | HasHeader | Header cells visible or not
Public Property | HasUserRowHeightsChanged | True when the Grid will need a second draw pass. Turns false on Draw, Turns true by GanttRow.IncreaseRowHeightOnCollision
Public Property | ImageList | Image list
Public Property | MinWidthOfFlipViewColumns | This is the smallest value allowed for the grid row width's when in the FlipView mode
Public Property | PrintStartNodeForNextPage | This GridNode value is updated for each printed page. It will be set to the GridNode that did not fit the last printed page, and it will be the first printed GridNode on the page if you call PrintPage again. The value is set by the PrintInit method, and it is reset to null by the PrintEnd method, so it will only be meaningfull to change the value between PrintInit and PrintEnd. Setting the value to null will be interperted as GridStructure.FirstVisibleNode.
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | Access to rootnodes also available via GridStructure
Public Property | RootNodes_DataMember | Datamember for root nodes
Public Property | RootNodes_DataSource | Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | RootNodes_DataSourceList | Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | ScrollbarColumns | Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...
Public Property | ScrollbarNodes | Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...
Public Property | SelectNewdataBoundRows | When this property is true a single added row to a IListSource will be selected. The Cell stays in the same column if SelectNewdataBoundRows_KeepColumn=true, the row is changed.
Public Property | SelectNewdataBoundRows_KeepColumn | When the SelectNewdataBoundRows property is true a single added row to a IListSource will be selected. The Cell stays in the same column when SelectNewdataBoundRows_KeepColumn=true, the row is changed.
Public Property | StepCellOnTab | When this property is true Tab steps no next cell. Otherwise Tab steps between controls (default).
Public Property | TreeLevelInset | This value controls the indentation that is made for each level in a tree. The default value is 13.
Top

See Also

Reference

Grid Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowRowResize Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : AllowRowResize Property

Glossary Item Box

Controls if the user should be allowed to drag rows to resize them

Syntax

Visual Basic (Declaration)
Public Property AllowRowResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.AllowRowResize = value

value = instance.AllowRowResize
C#
public bool AllowRowResize {get; set;}
Managed Extensions for C++
public: __property bool get_AllowRowResize();
public: __property void set_AllowRowResize(
   bool value
);
C++/CLI
public:
property bool AllowRowResize {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AutoCreateColumnsFromDataset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : AutoCreateColumnsFromDataset Property

Glossary Item Box

Set to true(deafult) and columns will be autocreated from dataset...

Syntax

Visual Basic (Declaration)
Public Property AutoCreateColumnsFromDataset As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.AutoCreateColumnsFromDataset = value

value = instance.AutoCreateColumnsFromDataset
C#
public bool AutoCreateColumnsFromDataset {get; set;}
Managed Extensions for C++
public: __property bool get_AutoCreateColumnsFromDataset();
public: __property void set_AutoCreateColumnsFromDataset(
   bool value
);
C++/CLI
public:
property bool AutoCreateColumnsFromDataset {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundImage Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override Image BackgroundImage {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Image* get_BackgroundImage() override;
public: __property void set_BackgroundImage(
   Image* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Image^ BackgroundImage {
   Image^ get() override;
   void set (    Image^ value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BorderStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : BorderStyle Property

Glossary Item Box

BorderStyle BorderStyle effect has been removed in version 2.3.1.13. From this version we are fully security aware,and the assembly can be integrated into IE or ClickOnce Applications with no trust. The implementation of borderstyle required an overide of CreateParams. Overriding CreateParams is a violation of UISecurity that is non trappable and we had to remove it.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public BorderStyle BorderStyle {get; set;}
Managed Extensions for C++
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   BorderStyle value
);
C++/CLI
public:
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (    BorderStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BottomColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : BottomColor Property

Glossary Item Box

Set bottom color of the grid.

Syntax

Visual Basic (Declaration)
Public Property BottomColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Color

instance.BottomColor = value

value = instance.BottomColor
C#
public Color BottomColor {get; set;}
Managed Extensions for C++
public: __property Color get_BottomColor();
public: __property void set_BottomColor(
   Color value
);
C++/CLI
public:
property Color BottomColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : CellLayouts Property

Glossary Item Box

Returns the list of cell layout properties.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property CellLayouts As CellLayouts
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As CellLayouts

value = instance.CellLayouts
C#
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public CellLayouts CellLayouts {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property CellLayouts* get_CellLayouts();
C++/CLI
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property CellLayouts^ CellLayouts {
   CellLayouts^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Columns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : Columns Property

Glossary Item Box

Returns the columns for the main grid-structure

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Property Columns As GridColumns
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As GridColumns

value = instance.Columns
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public GridColumns Columns {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property GridColumns* get_Columns();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property GridColumns^ Columns {
   GridColumns^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrentEditor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : CurrentEditor Property

Glossary Item Box

Cells keep their editor here when in or about to enter edit mode

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property CurrentEditor As Object
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Object

value = instance.CurrentEditor
C#
[BrowsableAttribute(false)]
public object CurrentEditor {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_CurrentEditor();
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ CurrentEditor {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawPyjamas Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : DrawPyjamas Property

Glossary Item Box

Decide if the stripes should be draw at all

Syntax

Visual Basic (Declaration)
Public Property DrawPyjamas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.DrawPyjamas = value

value = instance.DrawPyjamas
C#
public bool DrawPyjamas {get; set;}
Managed Extensions for C++
public: __property bool get_DrawPyjamas();
public: __property void set_DrawPyjamas(
   bool value
);
C++/CLI
public:
property bool DrawPyjamas {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditPickValueWindow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : EditPickValueWindow Property

Glossary Item Box

Access to the window that optionally shows under the edit to help the user with values to pick

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EditPickValueWindow As EditPickValueWindow
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As EditPickValueWindow

value = instance.EditPickValueWindow
C#
public EditPickValueWindow EditPickValueWindow {get;}
Managed Extensions for C++
public: __property EditPickValueWindow* get_EditPickValueWindow();
C++/CLI
public:
property EditPickValueWindow^ EditPickValueWindow {
   EditPickValueWindow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FlipView Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : FlipView Property

Glossary Item Box

Overrides the FlipView of OffscreenDraw

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Property FlipView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid

instance.FlipView = value
C#
public override bool FlipView {set;}
Managed Extensions for C++
public: __property void set_FlipView(
   bool value
) override;
C++/CLI
public:
property bool FlipView {
   void set (    bool value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FocusedCell Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : FocusedCell Property

Glossary Item Box

Returns or sets the cell currently in focus, alway the last one selected. Same as Grid.GridStructure.FocusedCell

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property FocusedCell As Cell
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Cell

instance.FocusedCell = value

value = instance.FocusedCell
C#
[BrowsableAttribute(false)]
public Cell FocusedCell {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Cell* get_FocusedCell();
public: __property void set_FocusedCell(
   Cell* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Cell^ FocusedCell {
   Cell^ get();
   void set (    Cell^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridStructure Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : GridStructure Property

Glossary Item Box

Returns the set of nodes.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridStructure As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As GridStructure

value = instance.GridStructure
C#
[BrowsableAttribute(false)]
public GridStructure GridStructure {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridStructure* get_GridStructure();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridStructure^ GridStructure {
   GridStructure^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HasHeader Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : HasHeader Property

Glossary Item Box

Header cells visible or not

Syntax

Visual Basic (Declaration)
Public Property HasHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.HasHeader = value

value = instance.HasHeader
C#
public bool HasHeader {get; set;}
Managed Extensions for C++
public: __property bool get_HasHeader();
public: __property void set_HasHeader(
   bool value
);
C++/CLI
public:
property bool HasHeader {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HasUserRowHeightsChanged Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : HasUserRowHeightsChanged Property

Glossary Item Box

True when the Grid will need a second draw pass. Turns false on Draw, Turns true by GanttRow.IncreaseRowHeightOnCollision

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasUserRowHeightsChanged As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

value = instance.HasUserRowHeightsChanged
C#
public bool HasUserRowHeightsChanged {get;}
Managed Extensions for C++
public: __property bool get_HasUserRowHeightsChanged();
C++/CLI
public:
property bool HasUserRowHeightsChanged {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : ImageList Property

Glossary Item Box

Image list

Syntax

Visual Basic (Declaration)
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
public ImageList ImageList {get; set;}
Managed Extensions for C++
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (    ImageList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MinWidthOfFlipViewColumns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : MinWidthOfFlipViewColumns Property

Glossary Item Box

This is the smallest value allowed for the grid row width's when in the FlipView mode

Syntax

Visual Basic (Declaration)
Public Property MinWidthOfFlipViewColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Integer

instance.MinWidthOfFlipViewColumns = value

value = instance.MinWidthOfFlipViewColumns
C#
public int MinWidthOfFlipViewColumns {get; set;}
Managed Extensions for C++
public: __property int get_MinWidthOfFlipViewColumns();
public: __property void set_MinWidthOfFlipViewColumns(
   int value
);
C++/CLI
public:
property int MinWidthOfFlipViewColumns {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintStartNodeForNextPage Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PrintStartNodeForNextPage Property

Glossary Item Box

This GridNode value is updated for each printed page. It will be set to the GridNode that did not fit the last printed page, and it will be the first printed GridNode on the page if you call PrintPage again. The value is set by the PrintInit method, and it is reset to null by the PrintEnd method, so it will only be meaningfull to change the value between PrintInit and PrintEnd. Setting the value to null will be interperted as GridStructure.FirstVisibleNode.

Syntax

Visual Basic (Declaration)
Public Property PrintStartNodeForNextPage As GridNode
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As GridNode

instance.PrintStartNodeForNextPage = value

value = instance.PrintStartNodeForNextPage
C#
public GridNode PrintStartNodeForNextPage {get; set;}
Managed Extensions for C++
public: __property GridNode* get_PrintStartNodeForNextPage();
public: __property void set_PrintStartNodeForNextPage(
   GridNode* value
);
C++/CLI
public:
property GridNode^ PrintStartNodeForNextPage {
   GridNode^ get();
   void set (    GridNode^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PyjamasColor Property

Glossary Item Box

The color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Color

instance.PyjamasColor = value

value = instance.PyjamasColor
C#
public Color PyjamasColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasColor();
public: __property void set_PyjamasColor(
   Color value
);
C++/CLI
public:
property Color PyjamasColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasGradientColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : PyjamasGradientColor Property

Glossary Item Box

The gradient color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasGradientColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Color

instance.PyjamasGradientColor = value

value = instance.PyjamasGradientColor
C#
public Color PyjamasGradientColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasGradientColor();
public: __property void set_PyjamasGradientColor(
   Color value
);
C++/CLI
public:
property Color PyjamasGradientColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : RootNodes Property

Glossary Item Box

Access to rootnodes also available via GridStructure

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Property RootNodes As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As GridNodes

value = instance.RootNodes
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public GridNodes RootNodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property GridNodes* get_RootNodes();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property GridNodes^ RootNodes {
   GridNodes^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : RootNodes_DataMember Property

Glossary Item Box

Datamember for root nodes

Syntax

Visual Basic (Declaration)
Public Property RootNodes_DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As String

instance.RootNodes_DataMember = value

value = instance.RootNodes_DataMember
C#
public string RootNodes_DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_RootNodes_DataMember();
public: __property void set_RootNodes_DataMember(
   string* value
);
C++/CLI
public:
property String^ RootNodes_DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : RootNodes_DataSource Property

Glossary Item Box

Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")>
Public Property RootNodes_DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Object

instance.RootNodes_DataSource = value

value = instance.RootNodes_DataSource
C#
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public object RootNodes_DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public: __property Object* get_RootNodes_DataSource();
public: __property void set_RootNodes_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public:
property Object^ RootNodes_DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : RootNodes_DataSourceList Property

Glossary Item Box

Datasource for root nodes DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RootNodes_DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As IList

instance.RootNodes_DataSourceList = value

value = instance.RootNodes_DataSourceList
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public IList RootNodes_DataSourceList {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property IList* get_RootNodes_DataSourceList();
public: __property void set_RootNodes_DataSourceList(
   IList* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property IList^ RootNodes_DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScrollbarColumns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : ScrollbarColumns Property

Glossary Item Box

Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ScrollbarColumns As ScrollBar
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As ScrollBar

value = instance.ScrollbarColumns
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ScrollBar ScrollbarColumns {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ScrollBar* get_ScrollbarColumns();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ScrollBar^ ScrollbarColumns {
   ScrollBar^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScrollbarNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : ScrollbarNodes Property

Glossary Item Box

Returns the internal Scrollbar used by the grid... Take extreme care when changing the values on it...

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property ScrollbarNodes As ScrollBar
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As ScrollBar

value = instance.ScrollbarNodes
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public ScrollBar ScrollbarNodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property ScrollBar* get_ScrollbarNodes();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property ScrollBar^ ScrollbarNodes {
   ScrollBar^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectNewdataBoundRows Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : SelectNewdataBoundRows Property

Glossary Item Box

When this property is true a single added row to a IListSource will be selected. The Cell stays in the same column if SelectNewdataBoundRows_KeepColumn=true, the row is changed.

Syntax

Visual Basic (Declaration)
Public Property SelectNewdataBoundRows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.SelectNewdataBoundRows = value

value = instance.SelectNewdataBoundRows
C#
public bool SelectNewdataBoundRows {get; set;}
Managed Extensions for C++
public: __property bool get_SelectNewdataBoundRows();
public: __property void set_SelectNewdataBoundRows(
   bool value
);
C++/CLI
public:
property bool SelectNewdataBoundRows {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectNewdataBoundRows_KeepColumn Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : SelectNewdataBoundRows_KeepColumn Property

Glossary Item Box

When the SelectNewdataBoundRows property is true a single added row to a IListSource will be selected. The Cell stays in the same column when SelectNewdataBoundRows_KeepColumn=true, the row is changed.

Syntax

Visual Basic (Declaration)
Public Property SelectNewdataBoundRows_KeepColumn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.SelectNewdataBoundRows_KeepColumn = value

value = instance.SelectNewdataBoundRows_KeepColumn
C#
public bool SelectNewdataBoundRows_KeepColumn {get; set;}
Managed Extensions for C++
public: __property bool get_SelectNewdataBoundRows_KeepColumn();
public: __property void set_SelectNewdataBoundRows_KeepColumn(
   bool value
);
C++/CLI
public:
property bool SelectNewdataBoundRows_KeepColumn {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StepCellOnTab Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : StepCellOnTab Property

Glossary Item Box

When this property is true Tab steps no next cell. Otherwise Tab steps between controls (default).

Syntax

Visual Basic (Declaration)
Public Property StepCellOnTab As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Boolean

instance.StepCellOnTab = value

value = instance.StepCellOnTab
C#
public bool StepCellOnTab {get; set;}
Managed Extensions for C++
public: __property bool get_StepCellOnTab();
public: __property void set_StepCellOnTab(
   bool value
);
C++/CLI
public:
property bool StepCellOnTab {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TreeLevelInset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : TreeLevelInset Property

Glossary Item Box

This value controls the indentation that is made for each level in a tree. The default value is 13.

Syntax

Visual Basic (Declaration)
Public Property TreeLevelInset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim value As Integer

instance.TreeLevelInset = value

value = instance.TreeLevelInset
C#
public int TreeLevelInset {get; set;}
Managed Extensions for C++
public: __property int get_TreeLevelInset();
public: __property void set_TreeLevelInset(
   int value
);
C++/CLI
public:
property int TreeLevelInset {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
Grid Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Grid Class

Glossary Item Box

For a list of all members of this type, see Grid members.

Public Events

 | Name | Description
Public Event | OnAfterEditCell | Fires when editor has closed.
Public Event | OnBeforeEditCell | Fires before editor is shown, do you extra init here, or prevent show
Public Event | OnBeforeEndEditCell | Fires when editor closes, do extra apply checks here
Public Event | OnBeforeFocusedCellChange | Fires before the grid shiftes focus from one cell to another
Public Event | OnCellSelectChanged | Cell Selection status is changing
Public Event | OnCellTypeChoose | Cell is about to be added, you can change type on it here
Public Event | OnColumnOrderChanged | Fires when a column is moved to another position by a gui-action (not if you set it by code).
Public Event | OnColumnWidthChanged | Fires when the column width is changed by a gui-action (not if you set it by code). The event will fire multiple times while the user drags the column to the desired width.
Public Event | OnCustomCellDraw | Draw the content of the cell when not in edit mode
Public Event | OnCustomCellEditStartByKey | Edit is started by key
Public Event | OnCustomCellEditStartByMouse | Edit is started by clicking
Public Event | OnCustomCellEndEdit | Edit is finished
Public Event | OnCustomCellHeight | Shall return height of cell
Public Event | OnEachListItemWhenDataBound_GridNode | Called for each GridNode when Grid is DataBound and datasource row is changed. This is a good place to set up ChildViews for SubNodes etc
Public Event | OnGridRedrawn | Called when the grid is redrawn
Public Event | OnNodeExpandStatus | Node expansion status is changing
Public Event | OnNodeInserted | fires on node insert
Public Event | OnNodeRemove | fires on node remove
Public Event | OnRowResize | Event fires when user resizes a row. You can implement this event and limit, change or prevent the interaction here.
Public Event | OnRowResizeDone | Event fires when user has resized a row. You can implement this event to do other changes that you want as a result of a row height change, like if you want to change all other Grid rows the same way.
Public Event | OnTopLeftChanged | TopLeft cell has changed, scrolling in progress
Public Event | OnUnBindedSort | Event fires when an unbinded list is to be sorted
Public Event | OnUserDrawSortSymbol | Implement to override sort symbol.
Top

See Also

Reference

Grid Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnAfterEditCell Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnAfterEditCell Event

Glossary Item Box

Fires when editor has closed.

Syntax

Visual Basic (Declaration)
Public Event OnAfterEditCell As AfterEditCellHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As AfterEditCellHandler

AddHandler instance.OnAfterEditCell, handler
C#
public event AfterEditCellHandler OnAfterEditCell
Managed Extensions for C++
public: __event AfterEditCellHandler* OnAfterEditCell
C++/CLI
public:
event AfterEditCellHandler^ OnAfterEditCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeEditCell Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnBeforeEditCell Event

Glossary Item Box

Fires before editor is shown, do you extra init here, or prevent show

Syntax

Visual Basic (Declaration)
Public Event OnBeforeEditCell As EditCellHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EditCellHandler

AddHandler instance.OnBeforeEditCell, handler
C#
public event EditCellHandler OnBeforeEditCell
Managed Extensions for C++
public: __event EditCellHandler* OnBeforeEditCell
C++/CLI
public:
event EditCellHandler^ OnBeforeEditCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeEndEditCell Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnBeforeEndEditCell Event

Glossary Item Box

Fires when editor closes, do extra apply checks here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeEndEditCell As EndEditCellHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EndEditCellHandler

AddHandler instance.OnBeforeEndEditCell, handler
C#
public event EndEditCellHandler OnBeforeEndEditCell
Managed Extensions for C++
public: __event EndEditCellHandler* OnBeforeEndEditCell
C++/CLI
public:
event EndEditCellHandler^ OnBeforeEndEditCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeFocusedCellChange Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnBeforeFocusedCellChange Event

Glossary Item Box

Fires before the grid shiftes focus from one cell to another

Syntax

Visual Basic (Declaration)
Public Event OnBeforeFocusedCellChange As BeforeFocusedCellChangeHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As BeforeFocusedCellChangeHandler

AddHandler instance.OnBeforeFocusedCellChange, handler
C#
public event BeforeFocusedCellChangeHandler OnBeforeFocusedCellChange
Managed Extensions for C++
public: __event BeforeFocusedCellChangeHandler* OnBeforeFocusedCellChange
C++/CLI
public:
event BeforeFocusedCellChangeHandler^ OnBeforeFocusedCellChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCellSelectChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCellSelectChanged Event

Glossary Item Box

Cell Selection status is changing

Syntax

Visual Basic (Declaration)
Public Event OnCellSelectChanged As CellSelectChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CellSelectChangedHandler

AddHandler instance.OnCellSelectChanged, handler
C#
public event CellSelectChangedHandler OnCellSelectChanged
Managed Extensions for C++
public: __event CellSelectChangedHandler* OnCellSelectChanged
C++/CLI
public:
event CellSelectChangedHandler^ OnCellSelectChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCellTypeChoose Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCellTypeChoose Event

Glossary Item Box

Cell is about to be added, you can change type on it here

Syntax

Visual Basic (Declaration)
Public Event OnCellTypeChoose As CellTypeChooseHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CellTypeChooseHandler

AddHandler instance.OnCellTypeChoose, handler
C#
public event CellTypeChooseHandler OnCellTypeChoose
Managed Extensions for C++
public: __event CellTypeChooseHandler* OnCellTypeChoose
C++/CLI
public:
event CellTypeChooseHandler^ OnCellTypeChoose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnColumnOrderChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnColumnOrderChanged Event

Glossary Item Box

Fires when a column is moved to another position by a gui-action (not if you set it by code).

Syntax

Visual Basic (Declaration)
Public Event OnColumnOrderChanged As ColumnOrderEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As ColumnOrderEventHandler

AddHandler instance.OnColumnOrderChanged, handler
C#
public event ColumnOrderEventHandler OnColumnOrderChanged
Managed Extensions for C++
public: __event ColumnOrderEventHandler* OnColumnOrderChanged
C++/CLI
public:
event ColumnOrderEventHandler^ OnColumnOrderChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnColumnWidthChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnColumnWidthChanged Event

Glossary Item Box

Fires when the column width is changed by a gui-action (not if you set it by code). The event will fire multiple times while the user drags the column to the desired width.

Syntax

Visual Basic (Declaration)
Public Event OnColumnWidthChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EventHandler

AddHandler instance.OnColumnWidthChanged, handler
C#
public event EventHandler OnColumnWidthChanged
Managed Extensions for C++
public: __event EventHandler* OnColumnWidthChanged
C++/CLI
public:
event EventHandler^ OnColumnWidthChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCustomCellDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCustomCellDraw Event

Glossary Item Box

Draw the content of the cell when not in edit mode

Syntax

Visual Basic (Declaration)
Public Event OnCustomCellDraw As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CustomCellEventHandler

AddHandler instance.OnCustomCellDraw, handler
C#
public event CustomCellEventHandler OnCustomCellDraw
Managed Extensions for C++
public: __event CustomCellEventHandler* OnCustomCellDraw
C++/CLI
public:
event CustomCellEventHandler^ OnCustomCellDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCustomCellEditStartByKey Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCustomCellEditStartByKey Event

Glossary Item Box

Edit is started by key

Syntax

Visual Basic (Declaration)
Public Event OnCustomCellEditStartByKey As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CustomCellEventHandler

AddHandler instance.OnCustomCellEditStartByKey, handler
C#
public event CustomCellEventHandler OnCustomCellEditStartByKey
Managed Extensions for C++
public: __event CustomCellEventHandler* OnCustomCellEditStartByKey
C++/CLI
public:
event CustomCellEventHandler^ OnCustomCellEditStartByKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCustomCellEditStartByMouse Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCustomCellEditStartByMouse Event

Glossary Item Box

Edit is started by clicking

Syntax

Visual Basic (Declaration)
Public Event OnCustomCellEditStartByMouse As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CustomCellEventHandler

AddHandler instance.OnCustomCellEditStartByMouse, handler
C#
public event CustomCellEventHandler OnCustomCellEditStartByMouse
Managed Extensions for C++
public: __event CustomCellEventHandler* OnCustomCellEditStartByMouse
C++/CLI
public:
event CustomCellEventHandler^ OnCustomCellEditStartByMouse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCustomCellEndEdit Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCustomCellEndEdit Event

Glossary Item Box

Edit is finished

Syntax

Visual Basic (Declaration)
Public Event OnCustomCellEndEdit As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CustomCellEventHandler

AddHandler instance.OnCustomCellEndEdit, handler
C#
public event CustomCellEventHandler OnCustomCellEndEdit
Managed Extensions for C++
public: __event CustomCellEventHandler* OnCustomCellEndEdit
C++/CLI
public:
event CustomCellEventHandler^ OnCustomCellEndEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCustomCellHeight Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnCustomCellHeight Event

Glossary Item Box

Shall return height of cell

Syntax

Visual Basic (Declaration)
Public Event OnCustomCellHeight As CustomCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As CustomCellEventHandler

AddHandler instance.OnCustomCellHeight, handler
C#
public event CustomCellEventHandler OnCustomCellHeight
Managed Extensions for C++
public: __event CustomCellEventHandler* OnCustomCellHeight
C++/CLI
public:
event CustomCellEventHandler^ OnCustomCellHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnEachListItemWhenDataBound_GridNode Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnEachListItemWhenDataBound_GridNode Event

Glossary Item Box

Called for each GridNode when Grid is DataBound and datasource row is changed. This is a good place to set up ChildViews for SubNodes etc

Syntax

Visual Basic (Declaration)
Public Event OnEachListItemWhenDataBound_GridNode As EachListItemWhenDataBoundHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EachListItemWhenDataBoundHandler

AddHandler instance.OnEachListItemWhenDataBound_GridNode, handler
C#
public event EachListItemWhenDataBoundHandler OnEachListItemWhenDataBound_GridNode
Managed Extensions for C++
public: __event EachListItemWhenDataBoundHandler* OnEachListItemWhenDataBound_GridNode
C++/CLI
public:
event EachListItemWhenDataBoundHandler^ OnEachListItemWhenDataBound_GridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnGridRedrawn Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnGridRedrawn Event

Glossary Item Box

Called when the grid is redrawn

Syntax

Visual Basic (Declaration)
Public Event OnGridRedrawn As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EventHandler

AddHandler instance.OnGridRedrawn, handler
C#
public event EventHandler OnGridRedrawn
Managed Extensions for C++
public: __event EventHandler* OnGridRedrawn
C++/CLI
public:
event EventHandler^ OnGridRedrawn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnNodeExpandStatus Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnNodeExpandStatus Event

Glossary Item Box

Node expansion status is changing

Syntax

Visual Basic (Declaration)
Public Event OnNodeExpandStatus As NodeExpandStatusHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As NodeExpandStatusHandler

AddHandler instance.OnNodeExpandStatus, handler
C#
public event NodeExpandStatusHandler OnNodeExpandStatus
Managed Extensions for C++
public: __event NodeExpandStatusHandler* OnNodeExpandStatus
C++/CLI
public:
event NodeExpandStatusHandler^ OnNodeExpandStatus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnNodeInserted Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnNodeInserted Event

Glossary Item Box

fires on node insert

Syntax

Visual Basic (Declaration)
Public Event OnNodeInserted As NodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As NodeEventHandler

AddHandler instance.OnNodeInserted, handler
C#
public event NodeEventHandler OnNodeInserted
Managed Extensions for C++
public: __event NodeEventHandler* OnNodeInserted
C++/CLI
public:
event NodeEventHandler^ OnNodeInserted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnNodeRemove Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnNodeRemove Event

Glossary Item Box

fires on node remove

Syntax

Visual Basic (Declaration)
Public Event OnNodeRemove As NodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As NodeEventHandler

AddHandler instance.OnNodeRemove, handler
C#
public event NodeEventHandler OnNodeRemove
Managed Extensions for C++
public: __event NodeEventHandler* OnNodeRemove
C++/CLI
public:
event NodeEventHandler^ OnNodeRemove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnRowResize Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnRowResize Event

Glossary Item Box

Event fires when user resizes a row. You can implement this event and limit, change or prevent the interaction here.

Syntax

Visual Basic (Declaration)
Public Event OnRowResize As RowResizeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As RowResizeEventHandler

AddHandler instance.OnRowResize, handler
C#
public event RowResizeEventHandler OnRowResize
Managed Extensions for C++
public: __event RowResizeEventHandler* OnRowResize
C++/CLI
public:
event RowResizeEventHandler^ OnRowResize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnRowResizeDone Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnRowResizeDone Event

Glossary Item Box

Event fires when user has resized a row. You can implement this event to do other changes that you want as a result of a row height change, like if you want to change all other Grid rows the same way.

Syntax

Visual Basic (Declaration)
Public Event OnRowResizeDone As RowResizeDoneEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As RowResizeDoneEventHandler

AddHandler instance.OnRowResizeDone, handler
C#
public event RowResizeDoneEventHandler OnRowResizeDone
Managed Extensions for C++
public: __event RowResizeDoneEventHandler* OnRowResizeDone
C++/CLI
public:
event RowResizeDoneEventHandler^ OnRowResizeDone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnTopLeftChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnTopLeftChanged Event

Glossary Item Box

TopLeft cell has changed, scrolling in progress

Syntax

Visual Basic (Declaration)
Public Event OnTopLeftChanged As TopLeftChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As TopLeftChangedHandler

AddHandler instance.OnTopLeftChanged, handler
C#
public event TopLeftChangedHandler OnTopLeftChanged
Managed Extensions for C++
public: __event TopLeftChangedHandler* OnTopLeftChanged
C++/CLI
public:
event TopLeftChangedHandler^ OnTopLeftChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUnBindedSort Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnUnBindedSort Event

Glossary Item Box

Event fires when an unbinded list is to be sorted

Syntax

Visual Basic (Declaration)
Public Event OnUnBindedSort As UnBindedSortHandler
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As UnBindedSortHandler

AddHandler instance.OnUnBindedSort, handler
C#
public event UnBindedSortHandler OnUnBindedSort
Managed Extensions for C++
public: __event UnBindedSortHandler* OnUnBindedSort
C++/CLI
public:
event UnBindedSortHandler^ OnUnBindedSort

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUserDrawSortSymbol Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Grid Class : OnUserDrawSortSymbol Event

Glossary Item Box

Implement to override sort symbol.

Syntax

Visual Basic (Declaration)
Public Event OnUserDrawSortSymbol As EventHandler(Of OnUserDrawSortSymbolArgs)
Visual Basic (Usage) Copy Code
Dim instance As Grid
Dim handler As EventHandler(Of OnUserDrawSortSymbolArgs)

AddHandler instance.OnUserDrawSortSymbol, handler
C#
public event EventHandler<OnUserDrawSortSymbolArgs> OnUserDrawSortSymbol
Managed Extensions for C++
public: __event EventHandler<OnUserDrawSortSymbolArgs*>* OnUserDrawSortSymbol
C++/CLI
public:
event EventHandler<OnUserDrawSortSymbolArgs^>^ OnUserDrawSortSymbol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Grid Class
Grid Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumn Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumn Class

Glossary Item Box

Holds the characteristics of a grid column.

Object Model

GridColumn ClassCell ClassGridColumns ClassGridColumn ClassGrid ClassCellLayout ClassGridStructure Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.GridColumn+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class GridColumn
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
C#
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class GridColumn
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class GridColumn
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class GridColumn

Example

C# Copy Code
GridColumn gc1=grid1.GridStructure.Columns.AddNew(CellType.SingleText);
            GridColumn gc2=grid1.GridStructure.Columns.AddNew(CellType.TimeDate);
            GridColumn gc3=grid1.GridStructure.Columns.AddNew(CellType.MultiText);
            GridColumn gc4=grid1.GridStructure.Columns.AddNew(CellType.ComboText);
            GridColumn gc5=grid1.GridStructure.Columns.AddNew(CellType.BoolCheck);
            GridColumn gc6=grid1.GridStructure.Columns.AddNew(CellType.CustomCell);

            gc1.LayoutName="layout1";
            gc2.LayoutName="layout1";
            gc3.LayoutName="layout1";
            gc4.LayoutName="layout2";
            gc5.LayoutName="layout2";
            gc6.LayoutName="layout2";

            gc1.Title="Col1";
            gc2.Title="Col2";
            gc3.Title="Col3";
            gc4.Title="Col4";
            gc5.Title="Col5";
            gc6.Title="Col6";

            gc1.Width=100;
            gc2.Width=100;
            gc3.Width=100;
            gc4.Width=100;
            gc5.Width=50;
            gc6.Width=100;

            gc1.Tree=true;

            CellLayout cl1=grid1.CellLayouts.GetFromName("layout1");
            CellLayout cl2=grid1.CellLayouts.GetFromName("layout2");

            cl1.Font=new Font("Arial",10);
            cl1.FontColor=Color.Black;
            cl2.Font=new Font("Arial",10);
            cl2.FontColor=Color.SaddleBrown;
Visual Basic Copy Code
Dim gc1 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.SingleText)
            Dim gc2 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.TimeDate)
            Dim gc3 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.MultiText)
            Dim gc4 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.ComboText)
            Dim gc5 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.BoolCheck)
            Dim gc6 As GridColumn=grid1.GridStructure.Columns.AddNew(CellType.CustomCell)

            gc1.LayoutName="layout1"
            gc2.LayoutName="layout1"
            gc3.LayoutName="layout1"
            gc4.LayoutName="layout2"
            gc5.LayoutName="layout2"
            gc6.LayoutName="layout2"

            gc1.Title="Col1"
            gc2.Title="Col2"
            gc3.Title="Col3"
            gc4.Title="Col4"
            gc5.Title="Col5"
            gc6.Title="Col6"

            gc1.Width=100
            gc2.Width=100
            gc3.Width=100
            gc4.Width=100
            gc5.Width=50
            gc6.Width=100

            gc1.Tree=True

            Dim cl1 As CellLayout=grid1.CellLayouts.GetFromName("layout1")
            Dim cl2 As CellLayout=grid1.CellLayouts.GetFromName("layout2")

            cl1.Font = New Font("Arial",10)
            cl1.FontColor=Color.Black
            cl2.Font = New Font("Arial",10)
            cl2.FontColor=Color.SaddleBrown

Inheritance Hierarchy

System.Object
PlexityHide.GTP.GridColumn

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridColumn Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridColumn Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GridColumn Class

Glossary Item Box

The following tables list the members exposed by GridColumn.

Public Constructors

 | Name | Description
Public Constructor | GridColumn Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowMove | Can this column be moved
Public Property | AllowResize | Can this column be resized
Public Property | ColumnCell | Gets cell column head is drawn in.
Public Property | ColumnDerivedFromDS | If true the this column will be removed from grid if removed from the data source
Public Property | Columns | Gets the column collection
Public Property | CurrentSortState | Current sort state of the column;0=no visible sort widget, 1=ascending, 2=descending Setting this will not perform the actual sort, it will only change the shown widget. Call GridNodes.Sort to perform the actual sort.
Public Property | DataSourceColumn | The name of the datasource column that will use this column for display
Public Property | DataSourceColumnType | The type of the data in the datasource column
Public Property | DesiredSize | This property is initiated after a call to Grid.UpdateDesiredSizeInColumns.
Public Property | GridControl | Returns the valid Grid
Public Property | Hide | Gets whether the column is hidden.
Public Property | Index | The index of this column within columns
Public Property | Layout | Sets the layout object.
Public Property | LayoutName | The layout name that will be used in default of an override of new cells
Public Property | Nodes | Returns the valid GridStructure
Public Property | ReadOnly | Gets and sets whether the entities in the column should be editable.
Public Property | SortEnable | States if the column can be sorted by clicking the column head or not.
Public Property | Title | Gets and sets the title of the column.
Public Property | Tree | Gets and sets whether the column should be shown in a tree format.
Public Property | Type | Gets column type.
Public Property | Width | Gets and sets the width of the column.
Public Property | WrapHeaderText | Setting to control if header rows should use the MultiText cell type or the SingleText cell type
Top

Public Methods

 | Name | Description
Public Method | ReCreateColumnCellToCustomType | Enables you to Create header cells with CustomCellType; go like this private void buttonAddCustomDrawnColumnHead_Click(object sender, EventArgs e) { GridColumn col=gantt1.Grid.Columns.AddNew(CellType.SingleText); col.ReCreateColumnCellToCustomType(); } The above code creates cells with SingleText fields, but a CustomCell header
Public Method | Sort | Sorts a column.
Public Method | SortStateReset | This Resets the sort state on the column, so that no sort symbol is visible on the column head when drawn.
Public Method | SortToggle | This call reverses the current sort order, the same thing that happens when you click the column header if sort is enabled.
Top

See Also

Reference

GridColumn Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumn Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : GridColumn Constructor

Glossary Item Box

Overload List

Overload | Description
GridColumn Constructor(CellType,GridStructure) | Creates a gridcolumn
GridColumn Constructor() | Creates a gridcolumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumn Constructor(CellType,GridStructure)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class > GridColumn Constructor : GridColumn Constructor(CellType,GridStructure)

type
aGridNodes

Glossary Item Box

Creates a gridcolumn

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As CellType, _
   ByVal aGridNodes As GridStructure _
)
Visual Basic (Usage) Copy Code
Dim type As CellType
Dim aGridNodes As GridStructure

Dim instance As New GridColumn(type, aGridNodes)
C#
public GridColumn(
   CellType type,
   GridStructure aGridNodes
)
Managed Extensions for C++
public: GridColumn(
   CellType type,
   GridStructure* aGridNodes
)
C++/CLI
public:
GridColumn(
   CellType type,
   GridStructure^ aGridNodes
)

Parameters

type
aGridNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumn Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class > GridColumn Constructor : GridColumn Constructor()

Glossary Item Box

Creates a gridcolumn

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GridColumn()
C#
public GridColumn()
Managed Extensions for C++
public: GridColumn();
C++/CLI
public:
GridColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GridColumn Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumn Class

Glossary Item Box

For a list of all members of this type, see GridColumn members.

Public Methods

 | Name | Description
Public Method | ReCreateColumnCellToCustomType | Enables you to Create header cells with CustomCellType; go like this private void buttonAddCustomDrawnColumnHead_Click(object sender, EventArgs e) { GridColumn col=gantt1.Grid.Columns.AddNew(CellType.SingleText); col.ReCreateColumnCellToCustomType(); } The above code creates cells with SingleText fields, but a CustomCell header
Public Method | Sort | Sorts a column.
Public Method | SortStateReset | This Resets the sort state on the column, so that no sort symbol is visible on the column head when drawn.
Public Method | SortToggle | This call reverses the current sort order, the same thing that happens when you click the column header if sort is enabled.
Top

See Also

Reference

GridColumn Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReCreateColumnCellToCustomType Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : ReCreateColumnCellToCustomType Method

Glossary Item Box

Enables you to Create header cells with CustomCellType; go like this private void buttonAddCustomDrawnColumnHead_Click(object sender, EventArgs e) { GridColumn col=gantt1.Grid.Columns.AddNew(CellType.SingleText); col.ReCreateColumnCellToCustomType(); } The above code creates cells with SingleText fields, but a CustomCell header

Syntax

Visual Basic (Declaration)
Public Sub ReCreateColumnCellToCustomType()
Visual Basic (Usage) Copy Code
Dim instance As GridColumn

instance.ReCreateColumnCellToCustomType()
C#
public void ReCreateColumnCellToCustomType()
Managed Extensions for C++
public: void ReCreateColumnCellToCustomType();
C++/CLI
public:
void ReCreateColumnCellToCustomType();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Sort Method

descending

Glossary Item Box

Sorts a column.

Syntax

Visual Basic (Declaration)
Public Sub Sort( _
   ByVal descending As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim descending As Boolean

instance.Sort(descending)
C#
public void Sort(
   bool descending
)
Managed Extensions for C++
public: void Sort(
   bool descending
)
C++/CLI
public:
void Sort(
   bool descending
)

Parameters

descending

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SortStateReset Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : SortStateReset Method

Glossary Item Box

This Resets the sort state on the column, so that no sort symbol is visible on the column head when drawn.

Syntax

Visual Basic (Declaration)
Public Sub SortStateReset()
Visual Basic (Usage) Copy Code
Dim instance As GridColumn

instance.SortStateReset()
C#
public void SortStateReset()
Managed Extensions for C++
public: void SortStateReset();
C++/CLI
public:
void SortStateReset();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SortToggle Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : SortToggle Method

Glossary Item Box

This call reverses the current sort order, the same thing that happens when you click the column header if sort is enabled.

Syntax

Visual Basic (Declaration)
Public Sub SortToggle()
Visual Basic (Usage) Copy Code
Dim instance As GridColumn

instance.SortToggle()
C#
public void SortToggle()
Managed Extensions for C++
public: void SortToggle();
C++/CLI
public:
void SortToggle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridColumn Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumn Class

Glossary Item Box

For a list of all members of this type, see GridColumn members.

Public Properties

 | Name | Description
Public Property | AllowMove | Can this column be moved
Public Property | AllowResize | Can this column be resized
Public Property | ColumnCell | Gets cell column head is drawn in.
Public Property | ColumnDerivedFromDS | If true the this column will be removed from grid if removed from the data source
Public Property | Columns | Gets the column collection
Public Property | CurrentSortState | Current sort state of the column;0=no visible sort widget, 1=ascending, 2=descending Setting this will not perform the actual sort, it will only change the shown widget. Call GridNodes.Sort to perform the actual sort.
Public Property | DataSourceColumn | The name of the datasource column that will use this column for display
Public Property | DataSourceColumnType | The type of the data in the datasource column
Public Property | DesiredSize | This property is initiated after a call to Grid.UpdateDesiredSizeInColumns.
Public Property | GridControl | Returns the valid Grid
Public Property | Hide | Gets whether the column is hidden.
Public Property | Index | The index of this column within columns
Public Property | Layout | Sets the layout object.
Public Property | LayoutName | The layout name that will be used in default of an override of new cells
Public Property | Nodes | Returns the valid GridStructure
Public Property | ReadOnly | Gets and sets whether the entities in the column should be editable.
Public Property | SortEnable | States if the column can be sorted by clicking the column head or not.
Public Property | Title | Gets and sets the title of the column.
Public Property | Tree | Gets and sets whether the column should be shown in a tree format.
Public Property | Type | Gets column type.
Public Property | Width | Gets and sets the width of the column.
Public Property | WrapHeaderText | Setting to control if header rows should use the MultiText cell type or the SingleText cell type
Top

See Also

Reference

GridColumn Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowMove Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : AllowMove Property

Glossary Item Box

Can this column be moved

Syntax

Visual Basic (Declaration)
Public Property AllowMove As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public bool AllowMove {get; set;}
Managed Extensions for C++
public: __property bool get_AllowMove();
public: __property void set_AllowMove(
   bool value
);
C++/CLI
public:
property bool AllowMove {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowResize Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : AllowResize Property

Glossary Item Box

Can this column be resized

Syntax

Visual Basic (Declaration)
Public Property AllowResize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.AllowResize = value

value = instance.AllowResize
C#
public bool AllowResize {get; set;}
Managed Extensions for C++
public: __property bool get_AllowResize();
public: __property void set_AllowResize(
   bool value
);
C++/CLI
public:
property bool AllowResize {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnCell Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : ColumnCell Property

Glossary Item Box

Gets cell column head is drawn in.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property ColumnCell As Cell
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Cell

value = instance.ColumnCell
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Cell ColumnCell {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Cell* get_ColumnCell();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Cell^ ColumnCell {
   Cell^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnDerivedFromDS Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : ColumnDerivedFromDS Property

Glossary Item Box

If true the this column will be removed from grid if removed from the data source

Syntax

Visual Basic (Declaration)
Public Property ColumnDerivedFromDS As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.ColumnDerivedFromDS = value

value = instance.ColumnDerivedFromDS
C#
public bool ColumnDerivedFromDS {get; set;}
Managed Extensions for C++
public: __property bool get_ColumnDerivedFromDS();
public: __property void set_ColumnDerivedFromDS(
   bool value
);
C++/CLI
public:
property bool ColumnDerivedFromDS {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Columns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Columns Property

Glossary Item Box

Gets the column collection

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Columns As GridColumns
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As GridColumns

value = instance.Columns
C#
[BrowsableAttribute(false)]
public GridColumns Columns {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridColumns* get_Columns();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridColumns^ Columns {
   GridColumns^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrentSortState Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : CurrentSortState Property

Glossary Item Box

Current sort state of the column;0=no visible sort widget, 1=ascending, 2=descending Setting this will not perform the actual sort, it will only change the shown widget. Call GridNodes.Sort to perform the actual sort.

Syntax

Visual Basic (Declaration)
Public Property CurrentSortState As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Integer

instance.CurrentSortState = value

value = instance.CurrentSortState
C#
public int CurrentSortState {get; set;}
Managed Extensions for C++
public: __property int get_CurrentSortState();
public: __property void set_CurrentSortState(
   int value
);
C++/CLI
public:
property int CurrentSortState {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSourceColumn Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : DataSourceColumn Property

Glossary Item Box

The name of the datasource column that will use this column for display

Syntax

Visual Basic (Declaration)
Public Property DataSourceColumn As String
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As String

instance.DataSourceColumn = value

value = instance.DataSourceColumn
C#
public string DataSourceColumn {get; set;}
Managed Extensions for C++
public: __property string* get_DataSourceColumn();
public: __property void set_DataSourceColumn(
   string* value
);
C++/CLI
public:
property String^ DataSourceColumn {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSourceColumnType Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : DataSourceColumnType Property

Glossary Item Box

The type of the data in the datasource column

Syntax

Visual Basic (Declaration)
Public Property DataSourceColumnType As Type
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Type

instance.DataSourceColumnType = value

value = instance.DataSourceColumnType
C#
public Type DataSourceColumnType {get; set;}
Managed Extensions for C++
public: __property Type* get_DataSourceColumnType();
public: __property void set_DataSourceColumnType(
   Type* value
);
C++/CLI
public:
property Type^ DataSourceColumnType {
   Type^ get();
   void set (    Type^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DesiredSize Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : DesiredSize Property

Glossary Item Box

This property is initiated after a call to Grid.UpdateDesiredSizeInColumns.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property DesiredSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Integer

instance.DesiredSize = value

value = instance.DesiredSize
C#
[BrowsableAttribute(false)]
public int DesiredSize {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_DesiredSize();
public: __property void set_DesiredSize(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property int DesiredSize {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : GridControl Property

Glossary Item Box

Returns the valid Grid

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property GridControl As Grid
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Grid

value = instance.GridControl
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Grid GridControl {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Grid* get_GridControl();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Grid^ GridControl {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Hide Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Hide Property

Glossary Item Box

Gets whether the column is hidden.

Syntax

Visual Basic (Declaration)
Public Property Hide As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.Hide = value

value = instance.Hide
C#
public bool Hide {get; set;}
Managed Extensions for C++
public: __property bool get_Hide();
public: __property void set_Hide(
   bool value
);
C++/CLI
public:
property bool Hide {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Index Property

Glossary Item Box

The index of this column within columns

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layout Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Layout Property

Glossary Item Box

Sets the layout object.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Layout As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As CellLayout

instance.Layout = value

value = instance.Layout
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CellLayout Layout {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property CellLayout* get_Layout();
public: __property void set_Layout(
   CellLayout* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property CellLayout^ Layout {
   CellLayout^ get();
   void set (    CellLayout^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LayoutName Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : LayoutName Property

Glossary Item Box

The layout name that will be used in default of an override of new cells

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.GridColumn+CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
Public Property LayoutName As String
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As String

instance.LayoutName = value

value = instance.LayoutName
C#
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public string LayoutName {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public: __property string* get_LayoutName();
public: __property void set_LayoutName(
   string* value
);
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.GridColumn+CellLayoutConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
public:
property String^ LayoutName {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Nodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Nodes Property

Glossary Item Box

Returns the valid GridStructure

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Nodes As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As GridStructure

instance.Nodes = value

value = instance.Nodes
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public GridStructure Nodes {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property GridStructure* get_Nodes();
public: __property void set_Nodes(
   GridStructure* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property GridStructure^ Nodes {
   GridStructure^ get();
   void set (    GridStructure^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReadOnly Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : ReadOnly Property

Glossary Item Box

Gets and sets whether the entities in the column should be editable.

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}
Managed Extensions for C++
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
public:
property bool ReadOnly {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SortEnable Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : SortEnable Property

Glossary Item Box

States if the column can be sorted by clicking the column head or not.

Syntax

Visual Basic (Declaration)
Public Property SortEnable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.SortEnable = value

value = instance.SortEnable
C#
public bool SortEnable {get; set;}
Managed Extensions for C++
public: __property bool get_SortEnable();
public: __property void set_SortEnable(
   bool value
);
C++/CLI
public:
property bool SortEnable {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Title Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Title Property

Glossary Item Box

Gets and sets the title of the column.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Tree Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Tree Property

Glossary Item Box

Gets and sets whether the column should be shown in a tree format.

Syntax

Visual Basic (Declaration)
Public Property Tree As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.Tree = value

value = instance.Tree
C#
public bool Tree {get; set;}
Managed Extensions for C++
public: __property bool get_Tree();
public: __property void set_Tree(
   bool value
);
C++/CLI
public:
property bool Tree {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Type Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Type Property

Glossary Item Box

Gets column type.

Syntax

Visual Basic (Declaration)
Public Property Type As CellType
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As CellType

instance.Type = value

value = instance.Type
C#
public CellType Type {get; set;}
Managed Extensions for C++
public: __property CellType get_Type();
public: __property void set_Type(
   CellType value
);
C++/CLI
public:
property CellType Type {
   CellType get();
   void set (    CellType value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Width Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : Width Property

Glossary Item Box

Gets and sets the width of the column.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
public:
property int Width {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
WrapHeaderText Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumn Class : WrapHeaderText Property

Glossary Item Box

Setting to control if header rows should use the MultiText cell type or the SingleText cell type

Syntax

Visual Basic (Declaration)
Public Property WrapHeaderText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridColumn
Dim value As Boolean

instance.WrapHeaderText = value

value = instance.WrapHeaderText
C#
public bool WrapHeaderText {get; set;}
Managed Extensions for C++
public: __property bool get_WrapHeaderText();
public: __property void set_WrapHeaderText(
   bool value
);
C++/CLI
public:
property bool WrapHeaderText {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumns Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumns Class

Glossary Item Box

Holds the structure for the set of columns and the manipulation possible.

Object Model

GridColumns ClassGridColumn Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GridColumns
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
C#
[DefaultMemberAttribute("Item")]
public class GridColumns : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class GridColumns : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class GridColumns : public System.Collections.CollectionBase

Example

C# Copy Code
GridColumn c_st=gantt1.Grid.Columns.AddNew(CellType.SingleText);
            GridColumn c_mt=gantt1.Grid.Columns.AddNew(CellType.MultiText);
            GridColumn c_td=gantt1.Grid.Columns.AddNew(CellType.TimeDate);
            GridColumn c_ct=gantt1.Grid.Columns.AddNew(CellType.ComboText);
            GridColumn c_bc=gantt1.Grid.Columns.AddNew(CellType.BoolCheck);
            GridColumn c_cs=gantt1.Grid.Columns.AddNew(CellType.CustomCell);

            c_st.Title="SingleText";
            c_mt.Title="MultiText";
            c_td.Title="TimeDate";
            c_ct.Title="ComboText";
            c_bc.Title="BoolCheck";
            c_cs.Title="CustomCell";
Visual Basic Copy Code
Dim c_st As GridColumn=gantt1.Grid.Columns.AddNew(CellType.SingleText)
            Dim c_mt As GridColumn=gantt1.Grid.Columns.AddNew(CellType.MultiText)
            Dim c_td As GridColumn=gantt1.Grid.Columns.AddNew(CellType.TimeDate)
            Dim c_ct As GridColumn=gantt1.Grid.Columns.AddNew(CellType.ComboText)
            Dim c_bc As GridColumn=gantt1.Grid.Columns.AddNew(CellType.BoolCheck)
            Dim c_cs As GridColumn=gantt1.Grid.Columns.AddNew(CellType.CustomCell)

            c_st.Title="SingleText"
            c_mt.Title="MultiText"
            c_td.Title="TimeDate"
            c_ct.Title="ComboText"
            c_bc.Title="BoolCheck"
            c_cs.Title="CustomCell"

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.GridColumns

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridColumns Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridColumns Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GridColumns Class

Glossary Item Box

The following tables list the members exposed by GridColumns.

Public Constructors

 | Name | Description
Public Constructor | GridColumns Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | ColumnsHeight | Returns the height of the column headers, calculation based in CellLayouts
Public Property | ColumnsOnScreen |
Public Property | GridControl | Owning grid
Public Property | HeaderType | COntrols how the header is rendered
Public Property | Item | Indexer
Public Property | Nodes | Owning grid structure
Top

Public Methods

 | Name | Description
Public Method | Add | Add column
Public Method | AddNew | Add a new column to the set of columns, this method will also add the column to all existing nodes.
Public Method | ChangeWidthBy | Change width of a column by deltaWidth.
Public Method | ColumnIndexFromXY | Find column head from point
Public Method | FirstVisibleColumn | Gets the first column that has Hide=false
Public Method | Hide | Hide the column at index.
Public Method | IndexOf | Overloaded. Find index of the specified GridColumn.
Public Method | IndexOf_DataSourceColumn | Find index of the specified GridColumn from the DataSourceColumn. The comparison is case insensitive (ToLower)
Public Method | InsertNew | Add a new column to the set of columns at index, this method will also add the column to all existing nodes.
Public Method | Move | Move column from oldIndex to newIndex.
Public Method | NextVisible | Find the next visible column, left to right.
Public Method | NonHidden | Returns a snapshot arraylist of all Non hidden columns
Public Method | PreviousVisible | Find the previous visible column, left to right.
Public Method | Remove | Remove column
Public Method | SetLeftCol | Set left most col, hence scroll
Public Method | SetWidth | Set width of a column.
Public Method | SumWidth | Sum up the total width of all visible columns.
Public Method | Unhide | Unhide the column at index.
Top

See Also

Reference

GridColumns Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridColumns Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : GridColumns Constructor

aGridStructure

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGridStructure As GridStructure _
)
Visual Basic (Usage) Copy Code
Dim aGridStructure As GridStructure

Dim instance As New GridColumns(aGridStructure)
C#
public GridColumns(
   GridStructure aGridStructure
)
Managed Extensions for C++
public: GridColumns(
   GridStructure* aGridStructure
)
C++/CLI
public:
GridColumns(
   GridStructure^ aGridStructure
)

Parameters

aGridStructure

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GridColumns Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumns Class

Glossary Item Box

For a list of all members of this type, see GridColumns members.

Public Methods

 | Name | Description
Public Method | Add | Add column
Public Method | AddNew | Add a new column to the set of columns, this method will also add the column to all existing nodes.
Public Method | ChangeWidthBy | Change width of a column by deltaWidth.
Public Method | ColumnIndexFromXY | Find column head from point
Public Method | FirstVisibleColumn | Gets the first column that has Hide=false
Public Method | Hide | Hide the column at index.
Public Method | IndexOf | Overloaded. Find index of the specified GridColumn.
Public Method | IndexOf_DataSourceColumn | Find index of the specified GridColumn from the DataSourceColumn. The comparison is case insensitive (ToLower)
Public Method | InsertNew | Add a new column to the set of columns at index, this method will also add the column to all existing nodes.
Public Method | Move | Move column from oldIndex to newIndex.
Public Method | NextVisible | Find the next visible column, left to right.
Public Method | NonHidden | Returns a snapshot arraylist of all Non hidden columns
Public Method | PreviousVisible | Find the previous visible column, left to right.
Public Method | Remove | Remove column
Public Method | SetLeftCol | Set left most col, hence scroll
Public Method | SetWidth | Set width of a column.
Public Method | SumWidth | Sum up the total width of all visible columns.
Public Method | Unhide | Unhide the column at index.
Top

See Also

Reference

GridColumns Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Add Method

aGridColumn

Glossary Item Box

Add column

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aGridColumn As GridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim aGridColumn As GridColumn

instance.Add(aGridColumn)
C#
public void Add(
   GridColumn aGridColumn
)
Managed Extensions for C++
public: void Add(
   GridColumn* aGridColumn
)
C++/CLI
public:
void Add(
   GridColumn^ aGridColumn
)

Parameters

aGridColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddNew Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : AddNew Method

type

Glossary Item Box

Add a new column to the set of columns, this method will also add the column to all existing nodes.

Syntax

Visual Basic (Declaration)
Public Function AddNew( _
   ByVal type As CellType _
) As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim type As CellType
Dim value As GridColumn

value = instance.AddNew(type)
C#
public GridColumn AddNew(
   CellType type
)
Managed Extensions for C++
public: GridColumn* AddNew(
   CellType type
)
C++/CLI
public:
GridColumn^ AddNew(
   CellType type
)

Parameters

type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ChangeWidthBy Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : ChangeWidthBy Method

index
deltaWidth

Glossary Item Box

Change width of a column by deltaWidth.

Syntax

Visual Basic (Declaration)
Public Sub ChangeWidthBy( _
   ByVal index As Integer, _
   ByVal deltaWidth As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer
Dim deltaWidth As Integer

instance.ChangeWidthBy(index, deltaWidth)
C#
public void ChangeWidthBy(
   int index,
   int deltaWidth
)
Managed Extensions for C++
public: void ChangeWidthBy(
   int index,
   int deltaWidth
)
C++/CLI
public:
void ChangeWidthBy(
   int index,
   int deltaWidth
)

Parameters

index
deltaWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnIndexFromXY Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : ColumnIndexFromXY Method

xPos
yPos

Glossary Item Box

Find column head from point

Syntax

Visual Basic (Declaration)
Public Function ColumnIndexFromXY( _
   ByVal xPos As Integer, _
   ByVal yPos As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim xPos As Integer
Dim yPos As Integer
Dim value As Integer

value = instance.ColumnIndexFromXY(xPos, yPos)
C#
public int ColumnIndexFromXY(
   int xPos,
   int yPos
)
Managed Extensions for C++
public: int ColumnIndexFromXY(
   int xPos,
   int yPos
)
C++/CLI
public:
int ColumnIndexFromXY(
   int xPos,
   int yPos
)

Parameters

xPos
yPos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FirstVisibleColumn Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : FirstVisibleColumn Method

Glossary Item Box

Gets the first column that has Hide=false

Syntax

Visual Basic (Declaration)
Public Function FirstVisibleColumn() As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As GridColumn

value = instance.FirstVisibleColumn()
C#
public GridColumn FirstVisibleColumn()
Managed Extensions for C++
public: GridColumn* FirstVisibleColumn();
C++/CLI
public:
GridColumn^ FirstVisibleColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Hide Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Hide Method

index

Glossary Item Box

Hide the column at index.

Syntax

Visual Basic (Declaration)
Public Sub Hide( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer

instance.Hide(index)
C#
public void Hide(
   int index
)
Managed Extensions for C++
public: void Hide(
   int index
)
C++/CLI
public:
void Hide(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : IndexOf Method

Glossary Item Box

Find index of the specified GridColumn.

Overload List

Overload | Description
IndexOf(GridColumn) | Find index of the specified GridColumn.
IndexOf(String) | Find index of the specified GridColumn from the column title. The comparison is case insensitive (ToLower)
IndexOf(Object) | Returns -1 if not found else index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf(GridColumn) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class > IndexOf Method : IndexOf(GridColumn) Method

column

Glossary Item Box

Find index of the specified GridColumn.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal column As GridColumn _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim column As GridColumn
Dim value As Integer

value = instance.IndexOf(column)
C#
public int IndexOf(
   GridColumn column
)
Managed Extensions for C++
public: int IndexOf(
   GridColumn* column
)
C++/CLI
public:
int IndexOf(
   GridColumn^ column
)

Parameters

column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf(String) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class > IndexOf Method : IndexOf(String) Method

columntitle

Glossary Item Box

Find index of the specified GridColumn from the column title. The comparison is case insensitive (ToLower)

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal columntitle As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim columntitle As String
Dim value As Integer

value = instance.IndexOf(columntitle)
C#
public int IndexOf(
   string columntitle
)
Managed Extensions for C++
public: int IndexOf(
   string* columntitle
)
C++/CLI
public:
int IndexOf(
   String^ columntitle
)

Parameters

columntitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf(Object) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class > IndexOf Method : IndexOf(Object) Method

value

Glossary Item Box

Returns -1 if not found else index

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf_DataSourceColumn Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : IndexOf_DataSourceColumn Method

dataSourceColumn

Glossary Item Box

Find index of the specified GridColumn from the DataSourceColumn. The comparison is case insensitive (ToLower)

Syntax

Visual Basic (Declaration)
Public Function IndexOf_DataSourceColumn( _
   ByVal dataSourceColumn As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim dataSourceColumn As String
Dim value As Integer

value = instance.IndexOf_DataSourceColumn(dataSourceColumn)
C#
public int IndexOf_DataSourceColumn(
   string dataSourceColumn
)
Managed Extensions for C++
public: int IndexOf_DataSourceColumn(
   string* dataSourceColumn
)
C++/CLI
public:
int IndexOf_DataSourceColumn(
   String^ dataSourceColumn
)

Parameters

dataSourceColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
InsertNew Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : InsertNew Method

index
type

Glossary Item Box

Add a new column to the set of columns at index, this method will also add the column to all existing nodes.

Syntax

Visual Basic (Declaration)
Public Function InsertNew( _
   ByVal index As Integer, _
   ByVal type As CellType _
) As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer
Dim type As CellType
Dim value As GridColumn

value = instance.InsertNew(index, type)
C#
public GridColumn InsertNew(
   int index,
   CellType type
)
Managed Extensions for C++
public: GridColumn* InsertNew(
   int index,
   CellType type
)
C++/CLI
public:
GridColumn^ InsertNew(
   int index,
   CellType type
)

Parameters

index
type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Move Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Move Method

oldIndex
newIndex

Glossary Item Box

Move column from oldIndex to newIndex.

Syntax

Visual Basic (Declaration)
Public Sub Move( _
   ByVal oldIndex As Integer, _
   ByVal newIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
public void Move(
   int oldIndex,
   int newIndex
)
Managed Extensions for C++
public: void Move(
   int oldIndex,
   int newIndex
)
C++/CLI
public:
void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NextVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : NextVisible Method

columnIndex

Glossary Item Box

Find the next visible column, left to right.

Syntax

Visual Basic (Declaration)
Public Function NextVisible( _
   ByVal columnIndex As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim columnIndex As Integer
Dim value As Integer

value = instance.NextVisible(columnIndex)
C#
public int NextVisible(
   int columnIndex
)
Managed Extensions for C++
public: int NextVisible(
   int columnIndex
)
C++/CLI
public:
int NextVisible(
   int columnIndex
)

Parameters

columnIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NonHidden Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : NonHidden Method

Glossary Item Box

Returns a snapshot arraylist of all Non hidden columns

Syntax

Visual Basic (Declaration)
Public Function NonHidden() As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As ArrayList

value = instance.NonHidden()
C#
public ArrayList NonHidden()
Managed Extensions for C++
public: ArrayList* NonHidden();
C++/CLI
public:
ArrayList^ NonHidden();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PreviousVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : PreviousVisible Method

columnIndex

Glossary Item Box

Find the previous visible column, left to right.

Syntax

Visual Basic (Declaration)
Public Function PreviousVisible( _
   ByVal columnIndex As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim columnIndex As Integer
Dim value As Integer

value = instance.PreviousVisible(columnIndex)
C#
public int PreviousVisible(
   int columnIndex
)
Managed Extensions for C++
public: int PreviousVisible(
   int columnIndex
)
C++/CLI
public:
int PreviousVisible(
   int columnIndex
)

Parameters

columnIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Remove Method

index

Glossary Item Box

Remove column

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SetLeftCol Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : SetLeftCol Method

aCol

Glossary Item Box

Set left most col, hence scroll

Syntax

Visual Basic (Declaration)
Public Sub SetLeftCol( _
   ByVal aCol As GridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim aCol As GridColumn

instance.SetLeftCol(aCol)
C#
public void SetLeftCol(
   GridColumn aCol
)
Managed Extensions for C++
public: void SetLeftCol(
   GridColumn* aCol
)
C++/CLI
public:
void SetLeftCol(
   GridColumn^ aCol
)

Parameters

aCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SetWidth Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : SetWidth Method

index
width

Glossary Item Box

Set width of a column.

Syntax

Visual Basic (Declaration)
Public Sub SetWidth( _
   ByVal index As Integer, _
   ByVal width As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer
Dim width As Integer

instance.SetWidth(index, width)
C#
public void SetWidth(
   int index,
   int width
)
Managed Extensions for C++
public: void SetWidth(
   int index,
   int width
)
C++/CLI
public:
void SetWidth(
   int index,
   int width
)

Parameters

index
width

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SumWidth Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : SumWidth Method

Glossary Item Box

Sum up the total width of all visible columns.

Syntax

Visual Basic (Declaration)
Public Function SumWidth() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As Integer

value = instance.SumWidth()
C#
public int SumWidth()
Managed Extensions for C++
public: int SumWidth();
C++/CLI
public:
int SumWidth();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Unhide Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Unhide Method

index

Glossary Item Box

Unhide the column at index.

Syntax

Visual Basic (Declaration)
Public Sub Unhide( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim index As Integer

instance.Unhide(index)
C#
public void Unhide(
   int index
)
Managed Extensions for C++
public: void Unhide(
   int index
)
C++/CLI
public:
void Unhide(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridColumns Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridColumns Class

Glossary Item Box

For a list of all members of this type, see GridColumns members.

Public Properties

 | Name | Description
Public Property | ColumnsHeight | Returns the height of the column headers, calculation based in CellLayouts
Public Property | ColumnsOnScreen |
Public Property | GridControl | Owning grid
Public Property | HeaderType | COntrols how the header is rendered
Public Property | Item | Indexer
Public Property | Nodes | Owning grid structure
Top

See Also

Reference

GridColumns Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnsHeight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : ColumnsHeight Property

Glossary Item Box

Returns the height of the column headers, calculation based in CellLayouts

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnsHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As Integer

value = instance.ColumnsHeight
C#
public int ColumnsHeight {get;}
Managed Extensions for C++
public: __property int get_ColumnsHeight();
C++/CLI
public:
property int ColumnsHeight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnsOnScreen Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : ColumnsOnScreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnsOnScreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As Integer

value = instance.ColumnsOnScreen
C#
public int ColumnsOnScreen {get;}
Managed Extensions for C++
public: __property int get_ColumnsOnScreen();
C++/CLI
public:
property int ColumnsOnScreen {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : GridControl Property

Glossary Item Box

Owning grid

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridControl As Grid
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As Grid

value = instance.GridControl
C#
[BrowsableAttribute(false)]
public Grid GridControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Grid* get_GridControl();
C++/CLI
[BrowsableAttribute(false)]
public:
property Grid^ GridControl {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HeaderType Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : HeaderType Property

Glossary Item Box

COntrols how the header is rendered

Syntax

Visual Basic (Declaration)
Public Property HeaderType As HeaderType
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As HeaderType

instance.HeaderType = value

value = instance.HeaderType
C#
public HeaderType HeaderType {get; set;}
Managed Extensions for C++
public: __property HeaderType get_HeaderType();
public: __property void set_HeaderType(
   HeaderType value
);
C++/CLI
public:
property HeaderType HeaderType {
   HeaderType get();
   void set (    HeaderType value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim Index As Integer
Dim value As GridColumn

value = instance.Item(Index)
C#
public GridColumn this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property GridColumn* get_Item   int Index
;
C++/CLI
public:
property GridColumn^ default [int] {
   GridColumn^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Nodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridColumns Class : Nodes Property

Glossary Item Box

Owning grid structure

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Nodes As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As GridColumns
Dim value As GridStructure

value = instance.Nodes
C#
[BrowsableAttribute(false)]
public GridStructure Nodes {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridStructure* get_Nodes();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridStructure^ Nodes {
   GridStructure^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridColumns Class
GridColumns Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNode Class

Glossary Item Box

Grid node constitues one row in the grid.

Object Model

GridNode ClassGrid ClassGridStructure ClassGridStructure ClassGridNodes ClassGridNode ClassGridNode ClassGridNodes ClassGridNode Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.GridNode+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridNode
C#
[TypeConverterAttribute("PlexityHide.GTP.GridNode+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class GridNode
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.GridNode+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class GridNode
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.GridNode+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class GridNode

Example

C# Copy Code
if (grid1.GridStructure.FocusedCell==null)
            {
                GridNode gn=grid1.GridStructure.RootNodes.AddNode();
                InitNodeContent(gn);
            }
            else
            {
                GridNode gn=new GridNode();
                grid1.GridStructure.FocusedCell.Node.
                        OwningCollection.Insert(grid1.GridStructure.FocusedCell.Node.Index,gn);
                InitNodeContent(gn);
            }
Visual Basic Copy Code
If grid1.GridStructure.FocusedCell Is Nothing Then
                Dim gn As GridNode=grid1.GridStructure.RootNodes.AddNode()
                InitNodeContent(gn)
            Else
                Dim gn As GridNode = New GridNode()
                grid1.GridStructure.FocusedCell.Node. OwningCollection.Insert(grid1.GridStructure.FocusedCell.Node.Index,gn)
                InitNodeContent(gn)
            End If

Inheritance Hierarchy

System.Object
PlexityHide.GTP.GridNode

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridNode Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridNode Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GridNode Class

Glossary Item Box

The following tables list the members exposed by GridNode.

Public Constructors

 | Name | Description
Public Constructor | GridNode Constructor | Constructor used by collection editor
Top

Public Properties

 | Name | Description
Public Property | Expanded | Sets and gets whther the node is expanded.
Public Property | FlipViewWidth | Get Width of the GridNode when it is shown in the FlipView, when each GridNode acts like a column header.
Public Property | GridControl | Owning grid
Public Property | GridStructure | Owning grid structure
Public Property | HasSubNodes | Does this node currently hold any sub nodes
Public Property | Index | Index in its parent child list
Public Property | Nodes | Owning grid structure Deprecated, use GridStructure property
Public Property | OwningCollection | Owning collection
Public Property | ParentNode | Gets and sets reference to parent node.
Public Property | RowSelected | Deselects all cells in the node and all childs to the current node.
Public Property | SubLevel | Gets the sublevel of the grid entity.
Public Property | SubNodes | Returns sub node collection
Public Property | SubNodes_DataMember | Data member of child list
Public Property | SubNodes_DataSource | Datasource of child list
Public Property | SubNodes_DataSourceList | This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | UserRowHeight | The UserRowHeight is the height that the user can set by resizing the row with mousedrag, the effective height also takes the MinHeight from the CellLayouts into concearn.
Public Property | Visible | Set to false to temporarily filter out this node from the rendering process (hide it for some reason)
Public Property | VisibleOnLastDraw | Indicates whether the node was drawn on the last screen update. If not it was because it had Visible=false, or was above the TopNode, or below the LastDrawnNode, or had a non-expanded ancestor.
Top

Public Methods

 | Name | Description
Public Method | AboveNode | Is this node above the other node or not...
Public Method | CellValueAsString | Retrieves the cells value as string.
Public Method | Expand | Change this nodes expansion state ; all decendants if recurse is true
Public Method | ExpandAllParents | Expands this node's parent and grand-parent and grand-grand-parent etc.
Public Method | GetCell | Retrieves the cell at columnIndex.
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple
Public Method | MakeSureVisible | If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.
Public Method | MoveNode | Move node to new parent
Public Method | Rect | The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned
Public Method | ScreenStatus | Returns an enum value describing the screen status of GridNode in the last draw operation
Public Method | SetCellLayoutOnAll | Set the same CellLayout on all cells on this row;
Top

See Also

Reference

GridNode Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : GridNode Constructor

Glossary Item Box

Constructor used by collection editor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GridNode()
C#
public GridNode()
Managed Extensions for C++
public: GridNode();
C++/CLI
public:
GridNode();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GridNode Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNode Class

Glossary Item Box

For a list of all members of this type, see GridNode members.

Public Methods

 | Name | Description
Public Method | AboveNode | Is this node above the other node or not...
Public Method | CellValueAsString | Retrieves the cells value as string.
Public Method | Expand | Change this nodes expansion state ; all decendants if recurse is true
Public Method | ExpandAllParents | Expands this node's parent and grand-parent and grand-grand-parent etc.
Public Method | GetCell | Retrieves the cell at columnIndex.
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple
Public Method | MakeSureVisible | If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.
Public Method | MoveNode | Move node to new parent
Public Method | Rect | The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned
Public Method | ScreenStatus | Returns an enum value describing the screen status of GridNode in the last draw operation
Public Method | SetCellLayoutOnAll | Set the same CellLayout on all cells on this row;
Top

See Also

Reference

GridNode Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AboveNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : AboveNode Method

anotherNode

Glossary Item Box

Is this node above the other node or not...

Syntax

Visual Basic (Declaration)
Public Function AboveNode( _
   ByVal anotherNode As GridNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim anotherNode As GridNode
Dim value As Boolean

value = instance.AboveNode(anotherNode)
C#
public bool AboveNode(
   GridNode anotherNode
)
Managed Extensions for C++
public: bool AboveNode(
   GridNode* anotherNode
)
C++/CLI
public:
bool AboveNode(
   GridNode^ anotherNode
)

Parameters

anotherNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellValueAsString Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : CellValueAsString Method

columnIndex

Glossary Item Box

Retrieves the cells value as string.

Syntax

Visual Basic (Declaration)
Public Function CellValueAsString( _
   ByVal columnIndex As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim columnIndex As Integer
Dim value As String

value = instance.CellValueAsString(columnIndex)
C#
public string CellValueAsString(
   int columnIndex
)
Managed Extensions for C++
public: string* CellValueAsString(
   int columnIndex
)
C++/CLI
public:
String^ CellValueAsString(
   int columnIndex
)

Parameters

columnIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Expand Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Expand Method

newExpanded
recurse

Glossary Item Box

Change this nodes expansion state ; all decendants if recurse is true

Syntax

Visual Basic (Declaration)
Public Sub Expand( _
   ByVal newExpanded As Boolean, _
   ByVal recurse As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim newExpanded As Boolean
Dim recurse As Boolean

instance.Expand(newExpanded, recurse)
C#
public void Expand(
   bool newExpanded,
   bool recurse
)
Managed Extensions for C++
public: void Expand(
   bool newExpanded,
   bool recurse
)
C++/CLI
public:
void Expand(
   bool newExpanded,
   bool recurse
)

Parameters

newExpanded
recurse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ExpandAllParents Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : ExpandAllParents Method

Glossary Item Box

Expands this node's parent and grand-parent and grand-grand-parent etc.

Syntax

Visual Basic (Declaration)
Public Sub ExpandAllParents()
Visual Basic (Usage) Copy Code
Dim instance As GridNode

instance.ExpandAllParents()
C#
public void ExpandAllParents()
Managed Extensions for C++
public: void ExpandAllParents();
C++/CLI
public:
void ExpandAllParents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetCell Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : GetCell Method

columnIndex

Glossary Item Box

Retrieves the cell at columnIndex.

Syntax

Visual Basic (Declaration)
Public Function GetCell( _
   ByVal columnIndex As Integer _
) As Cell
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim columnIndex As Integer
Dim value As Cell

value = instance.GetCell(columnIndex)
C#
public Cell GetCell(
   int columnIndex
)
Managed Extensions for C++
public: Cell* GetCell(
   int columnIndex
)
C++/CLI
public:
Cell^ GetCell(
   int columnIndex
)

Parameters

columnIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListItemWhenDataBound Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : ListItemWhenDataBound Method

Glossary Item Box

Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple

Syntax

Visual Basic (Declaration)
Public Function ListItemWhenDataBound() As Object
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Object

value = instance.ListItemWhenDataBound()
C#
public object ListItemWhenDataBound()
Managed Extensions for C++
public: Object* ListItemWhenDataBound();
C++/CLI
public:
Object^ ListItemWhenDataBound();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MakeSureVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : MakeSureVisible Method

Glossary Item Box

If this node is not currenlty on screen, it will be scrolled into view by this call. If the node is inside a non expanded parent or grand parent, these will be expanded.

Syntax

Visual Basic (Declaration)
Public Sub MakeSureVisible()
Visual Basic (Usage) Copy Code
Dim instance As GridNode

instance.MakeSureVisible()
C#
public void MakeSureVisible()
Managed Extensions for C++
public: void MakeSureVisible();
C++/CLI
public:
void MakeSureVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MoveNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : MoveNode Method

aNewParent
aNewPos

Glossary Item Box

Move node to new parent

Syntax

Visual Basic (Declaration)
Public Sub MoveNode( _
   ByVal aNewParent As GridNode, _
   ByVal aNewPos As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim aNewParent As GridNode
Dim aNewPos As Integer

instance.MoveNode(aNewParent, aNewPos)
C#
public void MoveNode(
   GridNode aNewParent,
   int aNewPos
)
Managed Extensions for C++
public: void MoveNode(
   GridNode* aNewParent,
   int aNewPos
)
C++/CLI
public:
void MoveNode(
   GridNode^ aNewParent,
   int aNewPos
)

Parameters

aNewParent
aNewPos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Rect Method

Glossary Item Box

The Rectangle that keeps this row, if not on screen -1,-1,-1,-1 is returned

Syntax

Visual Basic (Declaration)
Public Function Rect() As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Rectangle

value = instance.Rect()
C#
public Rectangle Rect()
Managed Extensions for C++
public: Rectangle Rect();
C++/CLI
public:
Rectangle Rect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ScreenStatus Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : ScreenStatus Method

Glossary Item Box

Returns an enum value describing the screen status of GridNode in the last draw operation

Syntax

Visual Basic (Declaration)
Public Function ScreenStatus() As GridNodeScreenStatus
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridNodeScreenStatus

value = instance.ScreenStatus()
C#
public GridNodeScreenStatus ScreenStatus()
Managed Extensions for C++
public: GridNodeScreenStatus ScreenStatus();
C++/CLI
public:
GridNodeScreenStatus ScreenStatus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SetCellLayoutOnAll Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SetCellLayoutOnAll Method

cl

Glossary Item Box

Set the same CellLayout on all cells on this row;

Syntax

Visual Basic (Declaration)
Public Sub SetCellLayoutOnAll( _
   ByVal cl As CellLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim cl As CellLayout

instance.SetCellLayoutOnAll(cl)
C#
public void SetCellLayoutOnAll(
   CellLayout cl
)
Managed Extensions for C++
public: void SetCellLayoutOnAll(
   CellLayout* cl
)
C++/CLI
public:
void SetCellLayoutOnAll(
   CellLayout^ cl
)

Parameters

cl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridNode Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNode Class

Glossary Item Box

For a list of all members of this type, see GridNode members.

Public Properties

 | Name | Description
Public Property | Expanded | Sets and gets whther the node is expanded.
Public Property | FlipViewWidth | Get Width of the GridNode when it is shown in the FlipView, when each GridNode acts like a column header.
Public Property | GridControl | Owning grid
Public Property | GridStructure | Owning grid structure
Public Property | HasSubNodes | Does this node currently hold any sub nodes
Public Property | Index | Index in its parent child list
Public Property | Nodes | Owning grid structure Deprecated, use GridStructure property
Public Property | OwningCollection | Owning collection
Public Property | ParentNode | Gets and sets reference to parent node.
Public Property | RowSelected | Deselects all cells in the node and all childs to the current node.
Public Property | SubLevel | Gets the sublevel of the grid entity.
Public Property | SubNodes | Returns sub node collection
Public Property | SubNodes_DataMember | Data member of child list
Public Property | SubNodes_DataSource | Datasource of child list
Public Property | SubNodes_DataSourceList | This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | UserRowHeight | The UserRowHeight is the height that the user can set by resizing the row with mousedrag, the effective height also takes the MinHeight from the CellLayouts into concearn.
Public Property | Visible | Set to false to temporarily filter out this node from the rendering process (hide it for some reason)
Public Property | VisibleOnLastDraw | Indicates whether the node was drawn on the last screen update. If not it was because it had Visible=false, or was above the TopNode, or below the LastDrawnNode, or had a non-expanded ancestor.
Top

See Also

Reference

GridNode Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Expanded Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Expanded Property

Glossary Item Box

Sets and gets whther the node is expanded.

Syntax

Visual Basic (Declaration)
Public Property Expanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
C#
public bool Expanded {get; set;}
Managed Extensions for C++
public: __property bool get_Expanded();
public: __property void set_Expanded(
   bool value
);
C++/CLI
public:
property bool Expanded {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FlipViewWidth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : FlipViewWidth Property

Glossary Item Box

Get Width of the GridNode when it is shown in the FlipView, when each GridNode acts like a column header.

Syntax

Visual Basic (Declaration)
Public Property FlipViewWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Integer

instance.FlipViewWidth = value

value = instance.FlipViewWidth
C#
public int FlipViewWidth {get; set;}
Managed Extensions for C++
public: __property int get_FlipViewWidth();
public: __property void set_FlipViewWidth(
   int value
);
C++/CLI
public:
property int FlipViewWidth {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : GridControl Property

Glossary Item Box

Owning grid

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridControl As Grid
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Grid

value = instance.GridControl
C#
[BrowsableAttribute(false)]
public Grid GridControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Grid* get_GridControl();
C++/CLI
[BrowsableAttribute(false)]
public:
property Grid^ GridControl {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridStructure Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : GridStructure Property

Glossary Item Box

Owning grid structure

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridStructure As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridStructure

value = instance.GridStructure
C#
[BrowsableAttribute(false)]
public GridStructure GridStructure {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridStructure* get_GridStructure();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridStructure^ GridStructure {
   GridStructure^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HasSubNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : HasSubNodes Property

Glossary Item Box

Does this node currently hold any sub nodes

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasSubNodes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Boolean

value = instance.HasSubNodes
C#
public bool HasSubNodes {get;}
Managed Extensions for C++
public: __property bool get_HasSubNodes();
C++/CLI
public:
property bool HasSubNodes {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Index Property

Glossary Item Box

Index in its parent child list

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Nodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Nodes Property

Glossary Item Box

Owning grid structure Deprecated, use GridStructure property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Nodes As GridStructure
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridStructure

value = instance.Nodes
C#
[BrowsableAttribute(false)]
public GridStructure Nodes {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridStructure* get_Nodes();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridStructure^ Nodes {
   GridStructure^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OwningCollection Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : OwningCollection Property

Glossary Item Box

Owning collection

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property OwningCollection As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridNodes

value = instance.OwningCollection
C#
[BrowsableAttribute(false)]
public GridNodes OwningCollection {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridNodes* get_OwningCollection();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridNodes^ OwningCollection {
   GridNodes^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ParentNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : ParentNode Property

Glossary Item Box

Gets and sets reference to parent node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property ParentNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridNode

instance.ParentNode = value

value = instance.ParentNode
C#
[BrowsableAttribute(false)]
public GridNode ParentNode {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridNode* get_ParentNode();
public: __property void set_ParentNode(
   GridNode* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property GridNode^ ParentNode {
   GridNode^ get();
   void set (    GridNode^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowSelected Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : RowSelected Property

Glossary Item Box

Deselects all cells in the node and all childs to the current node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property RowSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Boolean

instance.RowSelected = value

value = instance.RowSelected
C#
[BrowsableAttribute(false)]
public bool RowSelected {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_RowSelected();
public: __property void set_RowSelected(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property bool RowSelected {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubLevel Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SubLevel Property

Glossary Item Box

Gets the sublevel of the grid entity.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SubLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Integer

value = instance.SubLevel
C#
[BrowsableAttribute(false)]
public int SubLevel {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_SubLevel();
C++/CLI
[BrowsableAttribute(false)]
public:
property int SubLevel {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SubNodes Property

Glossary Item Box

Returns sub node collection

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
Public ReadOnly Property SubNodes As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As GridNodes

value = instance.SubNodes
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public GridNodes SubNodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public: __property GridNodes* get_SubNodes();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
public:
property GridNodes^ SubNodes {
   GridNodes^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubNodes_DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SubNodes_DataMember Property

Glossary Item Box

Data member of child list

Syntax

Visual Basic (Declaration)
Public Property SubNodes_DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As String

instance.SubNodes_DataMember = value

value = instance.SubNodes_DataMember
C#
public string SubNodes_DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_SubNodes_DataMember();
public: __property void set_SubNodes_DataMember(
   string* value
);
C++/CLI
public:
property String^ SubNodes_DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubNodes_DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SubNodes_DataSource Property

Glossary Item Box

Datasource of child list

Syntax

Visual Basic (Declaration)
Public Property SubNodes_DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Object

instance.SubNodes_DataSource = value

value = instance.SubNodes_DataSource
C#
public object SubNodes_DataSource {get; set;}
Managed Extensions for C++
public: __property Object* get_SubNodes_DataSource();
public: __property void set_SubNodes_DataSource(
   Object* value
);
C++/CLI
public:
property Object^ SubNodes_DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubNodes_DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : SubNodes_DataSourceList Property

Glossary Item Box

This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
Public Property SubNodes_DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As IList

instance.SubNodes_DataSourceList = value

value = instance.SubNodes_DataSourceList
C#
public IList SubNodes_DataSourceList {get; set;}
Managed Extensions for C++
public: __property IList* get_SubNodes_DataSourceList();
public: __property void set_SubNodes_DataSourceList(
   IList* value
);
C++/CLI
public:
property IList^ SubNodes_DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : UserReference Property

Glossary Item Box

User reference, use this to tie against your own data

Syntax

Visual Basic (Declaration)
Public Property UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Object

instance.UserReference = value

value = instance.UserReference
C#
public object UserReference {get; set;}
Managed Extensions for C++
public: __property Object* get_UserReference();
public: __property void set_UserReference(
   Object* value
);
C++/CLI
public:
property Object^ UserReference {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserRowHeight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : UserRowHeight Property

Glossary Item Box

The UserRowHeight is the height that the user can set by resizing the row with mousedrag, the effective height also takes the MinHeight from the CellLayouts into concearn.

Syntax

Visual Basic (Declaration)
Public Property UserRowHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Integer

instance.UserRowHeight = value

value = instance.UserRowHeight
C#
public int UserRowHeight {get; set;}
Managed Extensions for C++
public: __property int get_UserRowHeight();
public: __property void set_UserRowHeight(
   int value
);
C++/CLI
public:
property int UserRowHeight {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Visible Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : Visible Property

Glossary Item Box

Set to false to temporarily filter out this node from the rendering process (hide it for some reason)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleOnLastDraw Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : VisibleOnLastDraw Property

Glossary Item Box

Indicates whether the node was drawn on the last screen update. If not it was because it had Visible=false, or was above the TopNode, or below the LastDrawnNode, or had a non-expanded ancestor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleOnLastDraw As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNode
Dim value As Boolean

value = instance.VisibleOnLastDraw
C#
public bool VisibleOnLastDraw {get;}
Managed Extensions for C++
public: __property bool get_VisibleOnLastDraw();
C++/CLI
public:
property bool VisibleOnLastDraw {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNodes Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNodes Class

Glossary Item Box

GridNodes.

Object Model

GridNodes ClassGridNode Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GridNodes
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
C#
[DefaultMemberAttribute("Item")]
public class GridNodes : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class GridNodes : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class GridNodes : public System.Collections.CollectionBase

Example

GridNode Class

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.GridNodes

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridNodes Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridNodes Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GridNodes Class

Glossary Item Box

The following tables list the members exposed by GridNodes.

Public Constructors

 | Name | Description
Public Constructor | GridNodes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Returns the number of gridnodes
Public Property | IsRootList | Returns true if root
Public Property | Item | Indexer
Public Property | NodeDataConnect | Returns the NodeDataConnect that will give you the currency manager etc if you need access to it.
Top

Public Methods

 | Name | Description
Public Method | Add | Add this Node last in list.
Public Method | AddNode | Create and Add a new node
Public Method | ExpandAll | Enables you to close or open all nodes in the collection
Public Method | IndexOf | Returns -1 if not found else position
Public Method | Insert | Insert this Node at position.
Public Method | Move | Move this node within list
Public Method | Remove | Remove this node
Public Method | Sort | Overloaded. Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is the case, you should sort the datasource instead.
Public Method | SortNonRecursive | Sorts this list only. Does not sort subnodes
Top

See Also

Reference

GridNodes Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNodes Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : GridNodes Constructor

aGridStructure
aowningNode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGridStructure As GridStructure, _
   ByVal aowningNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim aGridStructure As GridStructure
Dim aowningNode As GridNode

Dim instance As New GridNodes(aGridStructure, aowningNode)
C#
public GridNodes(
   GridStructure aGridStructure,
   GridNode aowningNode
)
Managed Extensions for C++
public: GridNodes(
   GridStructure* aGridStructure,
   GridNode* aowningNode
)
C++/CLI
public:
GridNodes(
   GridStructure^ aGridStructure,
   GridNode^ aowningNode
)

Parameters

aGridStructure
aowningNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GridNodes Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNodes Class

Glossary Item Box

For a list of all members of this type, see GridNodes members.

Public Methods

 | Name | Description
Public Method | Add | Add this Node last in list.
Public Method | AddNode | Create and Add a new node
Public Method | ExpandAll | Enables you to close or open all nodes in the collection
Public Method | IndexOf | Returns -1 if not found else position
Public Method | Insert | Insert this Node at position.
Public Method | Move | Move this node within list
Public Method | Remove | Remove this node
Public Method | Sort | Overloaded. Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is the case, you should sort the datasource instead.
Public Method | SortNonRecursive | Sorts this list only. Does not sort subnodes
Top

See Also

Reference

GridNodes Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Add Method

aGridNode

Glossary Item Box

Add this Node last in list.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aGridNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim aGridNode As GridNode

instance.Add(aGridNode)
C#
public void Add(
   GridNode aGridNode
)
Managed Extensions for C++
public: void Add(
   GridNode* aGridNode
)
C++/CLI
public:
void Add(
   GridNode^ aGridNode
)

Parameters

aGridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : AddNode Method

Glossary Item Box

Create and Add a new node

Syntax

Visual Basic (Declaration)
Public Function AddNode() As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim value As GridNode

value = instance.AddNode()
C#
public GridNode AddNode()
Managed Extensions for C++
public: GridNode* AddNode();
C++/CLI
public:
GridNode^ AddNode();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ExpandAll Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : ExpandAll Method

yes

Glossary Item Box

Enables you to close or open all nodes in the collection

Syntax

Visual Basic (Declaration)
Public Sub ExpandAll( _
   ByVal yes As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim yes As Boolean

instance.ExpandAll(yes)
C#
public void ExpandAll(
   bool yes
)
Managed Extensions for C++
public: void ExpandAll(
   bool yes
)
C++/CLI
public:
void ExpandAll(
   bool yes
)

Parameters

yes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : IndexOf Method

value

Glossary Item Box

Returns -1 if not found else position

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Insert Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Insert Method

index
aGridNode

Glossary Item Box

Insert this Node at position.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal aGridNode As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim index As Integer
Dim aGridNode As GridNode

instance.Insert(index, aGridNode)
C#
public void Insert(
   int index,
   GridNode aGridNode
)
Managed Extensions for C++
public: void Insert(
   int index,
   GridNode* aGridNode
)
C++/CLI
public:
void Insert(
   int index,
   GridNode^ aGridNode
)

Parameters

index
aGridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Move Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Move Method

OldIndex
NewIndex

Glossary Item Box

Move this node within list

Syntax

Visual Basic (Declaration)
Public Sub Move( _
   ByVal OldIndex As Integer, _
   ByVal NewIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim OldIndex As Integer
Dim NewIndex As Integer

instance.Move(OldIndex, NewIndex)
C#
public void Move(
   int OldIndex,
   int NewIndex
)
Managed Extensions for C++
public: void Move(
   int OldIndex,
   int NewIndex
)
C++/CLI
public:
void Move(
   int OldIndex,
   int NewIndex
)

Parameters

OldIndex
NewIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Remove Method

index

Glossary Item Box

Remove this node

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Sort Method

Glossary Item Box

Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is the case, you should sort the datasource instead.

Overload List

Overload | Description
Sort(Int32,Int32,IComparer) | Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is the case, you should sort the datasource instead.
Sort(Boolean,GridColumn) | Sorts and calls Sort on subnodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort(Int32,Int32,IComparer) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class > Sort Method : Sort(Int32,Int32,IComparer) Method

index
count
comparer

Glossary Item Box

Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is the case, you should sort the datasource instead.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Sort( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal comparer As IComparer _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim index As Integer
Dim count As Integer
Dim comparer As IComparer

instance.Sort(index, count, comparer)
C#
public virtual void Sort(
   int index,
   int count,
   IComparer comparer
)
Managed Extensions for C++
public: virtual void Sort(
   int index,
   int count,
   IComparer* comparer
)
C++/CLI
public:
virtual void Sort(
   int index,
   int count,
   IComparer^ comparer
)

Parameters

index
count
comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort(Boolean,GridColumn) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class > Sort Method : Sort(Boolean,GridColumn) Method

descending
aColumn

Glossary Item Box

Sorts and calls Sort on subnodes

Syntax

Visual Basic (Declaration)
Public Overloads Sub Sort( _
   ByVal descending As Boolean, _
   ByVal aColumn As GridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim descending As Boolean
Dim aColumn As GridColumn

instance.Sort(descending, aColumn)
C#
public void Sort(
   bool descending,
   GridColumn aColumn
)
Managed Extensions for C++
public: void Sort(
   bool descending,
   GridColumn* aColumn
)
C++/CLI
public:
void Sort(
   bool descending,
   GridColumn^ aColumn
)

Parameters

descending
aColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
SortNonRecursive Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : SortNonRecursive Method

descending
aColumn

Glossary Item Box

Sorts this list only. Does not sort subnodes

Syntax

Visual Basic (Declaration)
Public Sub SortNonRecursive( _
   ByVal descending As Boolean, _
   ByVal aColumn As GridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim descending As Boolean
Dim aColumn As GridColumn

instance.SortNonRecursive(descending, aColumn)
C#
public void SortNonRecursive(
   bool descending,
   GridColumn aColumn
)
Managed Extensions for C++
public: void SortNonRecursive(
   bool descending,
   GridColumn* aColumn
)
C++/CLI
public:
void SortNonRecursive(
   bool descending,
   GridColumn^ aColumn
)

Parameters

descending
aColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridNodes Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNodes Class

Glossary Item Box

For a list of all members of this type, see GridNodes members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of gridnodes
Public Property | IsRootList | Returns true if root
Public Property | Item | Indexer
Public Property | NodeDataConnect | Returns the NodeDataConnect that will give you the currency manager etc if you need access to it.
Top

See Also

Reference

GridNodes Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Count Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Count Property

Glossary Item Box

Returns the number of gridnodes

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim value As Integer

value = instance.Count
C#
public new int Count {get;}
Managed Extensions for C++
public: __property new int get_Count();
C++/CLI
public:
new property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsRootList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : IsRootList Property

Glossary Item Box

Returns true if root

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRootList As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim value As Boolean

value = instance.IsRootList
C#
public bool IsRootList {get;}
Managed Extensions for C++
public: __property bool get_IsRootList();
C++/CLI
public:
property bool IsRootList {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim Index As Integer
Dim value As GridNode

value = instance.Item(Index)
C#
public GridNode this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property GridNode* get_Item   int Index
;
C++/CLI
public:
property GridNode^ default [int] {
   GridNode^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeDataConnect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNodes Class : NodeDataConnect Property

Glossary Item Box

Returns the NodeDataConnect that will give you the currency manager etc if you need access to it.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NodeDataConnect As NodeDataConnect
Visual Basic (Usage) Copy Code
Dim instance As GridNodes
Dim value As NodeDataConnect

value = instance.NodeDataConnect
C#
public NodeDataConnect NodeDataConnect {get;}
Managed Extensions for C++
public: __property NodeDataConnect* get_NodeDataConnect();
C++/CLI
public:
property NodeDataConnect^ NodeDataConnect {
   NodeDataConnect^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNodes Class
GridNodes Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridProperties Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridProperties Class

Glossary Item Box

Exposes some properties of the Grid to the Gantt in design time

Object Model

GridProperties ClassCellLayouts ClassCellLayout ClassGridColumns ClassGridColumn ClassGridNodes ClassGridNode Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Class GridProperties
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public class GridProperties
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public __gc class GridProperties
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ref class GridProperties

Example

Grid Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.GridProperties

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridProperties Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridProperties Class Members
See Also Properties Send comments on this topic.
PlexityHide.GTP Namespace : GridProperties Class

Glossary Item Box

The following tables list the members exposed by GridProperties.

Public Constructors

 | Name | Description
Public Constructor | GridProperties Constructor | Called by Gantt and Gantt_ASP
Top

Public Properties

 | Name | Description
Public Property | AutoCreateColumnsFromDataset | Auto create columns from the datasource
Public Property | BackColor | The back color of the grid. This color fills the little square between the scrollbars
Public Property | BorderStyle | The BorderStyle
Public Property | BottomColor | The bottom color of the grid. Note: this will be overriden by cells that has a cellLayout with UseBackColor=true
Public Property | CellLayouts | The celllayouts in the grid
Public Property | Columns | The columns in the grid
Public Property | ContextMenuStrip | ContextMenu of the Grid
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | HasHeader | Header is optional
Public Property | ImageList | ImageList, these images are available in each cell by setting CellLayout.ImageIndex_Select
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | The list of the root nodes
Public Property | RootNodes_DataMember | The datasource's datamember
Public Property | RootNodes_DataSource | The datasource that will control the rootnode-list
Public Property | RootNodes_DataSourceList | The datasource that will control the rootnode-list
Top

See Also

Reference

GridProperties Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridProperties Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : GridProperties Constructor

aGantt

Glossary Item Box

Called by Gantt and Gantt_ASP

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim aGantt As Gantt

Dim instance As New GridProperties(aGantt)
C#
public GridProperties(
   Gantt aGantt
)
Managed Extensions for C++
public: GridProperties(
   Gantt* aGantt
)
C++/CLI
public:
GridProperties(
   Gantt^ aGantt
)

Parameters

aGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridProperties Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridProperties Class

Glossary Item Box

For a list of all members of this type, see GridProperties members.

Public Properties

 | Name | Description
Public Property | AutoCreateColumnsFromDataset | Auto create columns from the datasource
Public Property | BackColor | The back color of the grid. This color fills the little square between the scrollbars
Public Property | BorderStyle | The BorderStyle
Public Property | BottomColor | The bottom color of the grid. Note: this will be overriden by cells that has a cellLayout with UseBackColor=true
Public Property | CellLayouts | The celllayouts in the grid
Public Property | Columns | The columns in the grid
Public Property | ContextMenuStrip | ContextMenu of the Grid
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | HasHeader | Header is optional
Public Property | ImageList | ImageList, these images are available in each cell by setting CellLayout.ImageIndex_Select
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | The list of the root nodes
Public Property | RootNodes_DataMember | The datasource's datamember
Public Property | RootNodes_DataSource | The datasource that will control the rootnode-list
Public Property | RootNodes_DataSourceList | The datasource that will control the rootnode-list
Top

See Also

Reference

GridProperties Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AutoCreateColumnsFromDataset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : AutoCreateColumnsFromDataset Property

Glossary Item Box

Auto create columns from the datasource

Syntax

Visual Basic (Declaration)
Public Property AutoCreateColumnsFromDataset As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Boolean

instance.AutoCreateColumnsFromDataset = value

value = instance.AutoCreateColumnsFromDataset
C#
public bool AutoCreateColumnsFromDataset {get; set;}
Managed Extensions for C++
public: __property bool get_AutoCreateColumnsFromDataset();
public: __property void set_AutoCreateColumnsFromDataset(
   bool value
);
C++/CLI
public:
property bool AutoCreateColumnsFromDataset {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : BackColor Property

Glossary Item Box

The back color of the grid. This color fills the little square between the scrollbars

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BorderStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : BorderStyle Property

Glossary Item Box

The BorderStyle

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public BorderStyle BorderStyle {get; set;}
Managed Extensions for C++
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   BorderStyle value
);
C++/CLI
public:
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (    BorderStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BottomColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : BottomColor Property

Glossary Item Box

The bottom color of the grid. Note: this will be overriden by cells that has a cellLayout with UseBackColor=true

Syntax

Visual Basic (Declaration)
Public Property BottomColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Color

instance.BottomColor = value

value = instance.BottomColor
C#
public Color BottomColor {get; set;}
Managed Extensions for C++
public: __property Color get_BottomColor();
public: __property void set_BottomColor(
   Color value
);
C++/CLI
public:
property Color BottomColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : CellLayouts Property

Glossary Item Box

The celllayouts in the grid

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property CellLayouts As CellLayouts
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As CellLayouts

value = instance.CellLayouts
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public CellLayouts CellLayouts {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property CellLayouts* get_CellLayouts();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property CellLayouts^ CellLayouts {
   CellLayouts^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Columns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : Columns Property

Glossary Item Box

The columns in the grid

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property Columns As GridColumns
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As GridColumns

value = instance.Columns
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public GridColumns Columns {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property GridColumns* get_Columns();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property GridColumns^ Columns {
   GridColumns^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContextMenuStrip Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : ContextMenuStrip Property

Glossary Item Box

ContextMenu of the Grid

Syntax

Visual Basic (Declaration)
Public Property ContextMenuStrip As ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public ContextMenuStrip ContextMenuStrip {get; set;}
Managed Extensions for C++
public: __property ContextMenuStrip* get_ContextMenuStrip();
public: __property void set_ContextMenuStrip(
   ContextMenuStrip* value
);
C++/CLI
public:
property ContextMenuStrip^ ContextMenuStrip {
   ContextMenuStrip^ get();
   void set (    ContextMenuStrip^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawPyjamas Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : DrawPyjamas Property

Glossary Item Box

Decide if the stripes should be draw at all

Syntax

Visual Basic (Declaration)
Public Property DrawPyjamas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Boolean

instance.DrawPyjamas = value

value = instance.DrawPyjamas
C#
public bool DrawPyjamas {get; set;}
Managed Extensions for C++
public: __property bool get_DrawPyjamas();
public: __property void set_DrawPyjamas(
   bool value
);
C++/CLI
public:
property bool DrawPyjamas {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HasHeader Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : HasHeader Property

Glossary Item Box

Header is optional

Syntax

Visual Basic (Declaration)
Public Property HasHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Boolean

instance.HasHeader = value

value = instance.HasHeader
C#
public bool HasHeader {get; set;}
Managed Extensions for C++
public: __property bool get_HasHeader();
public: __property void set_HasHeader(
   bool value
);
C++/CLI
public:
property bool HasHeader {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : ImageList Property

Glossary Item Box

ImageList, these images are available in each cell by setting CellLayout.ImageIndex_Select

Syntax

Visual Basic (Declaration)
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
public ImageList ImageList {get; set;}
Managed Extensions for C++
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (    ImageList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : PyjamasColor Property

Glossary Item Box

The color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Color

instance.PyjamasColor = value

value = instance.PyjamasColor
C#
public Color PyjamasColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasColor();
public: __property void set_PyjamasColor(
   Color value
);
C++/CLI
public:
property Color PyjamasColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasGradientColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : PyjamasGradientColor Property

Glossary Item Box

The gradient color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasGradientColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Color

instance.PyjamasGradientColor = value

value = instance.PyjamasGradientColor
C#
public Color PyjamasGradientColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasGradientColor();
public: __property void set_PyjamasGradientColor(
   Color value
);
C++/CLI
public:
property Color PyjamasGradientColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : RootNodes Property

Glossary Item Box

The list of the root nodes

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property RootNodes As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As GridNodes

value = instance.RootNodes
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public GridNodes RootNodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property GridNodes* get_RootNodes();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property GridNodes^ RootNodes {
   GridNodes^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : RootNodes_DataMember Property

Glossary Item Box

The datasource's datamember

Syntax

Visual Basic (Declaration)
Public Property RootNodes_DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As String

instance.RootNodes_DataMember = value

value = instance.RootNodes_DataMember
C#
public string RootNodes_DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_RootNodes_DataMember();
public: __property void set_RootNodes_DataMember(
   string* value
);
C++/CLI
public:
property String^ RootNodes_DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : RootNodes_DataSource Property

Glossary Item Box

The datasource that will control the rootnode-list

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")>
Public Property RootNodes_DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As Object

instance.RootNodes_DataSource = value

value = instance.RootNodes_DataSource
C#
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public object RootNodes_DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public: __property Object* get_RootNodes_DataSource();
public: __property void set_RootNodes_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public:
property Object^ RootNodes_DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes_DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridProperties Class : RootNodes_DataSourceList Property

Glossary Item Box

The datasource that will control the rootnode-list

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property RootNodes_DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As GridProperties
Dim value As IList

instance.RootNodes_DataSourceList = value

value = instance.RootNodes_DataSourceList
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public IList RootNodes_DataSourceList {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property IList* get_RootNodes_DataSourceList();
public: __property void set_RootNodes_DataSourceList(
   IList* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property IList^ RootNodes_DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridProperties Class
GridProperties Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridStructure Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridStructure Class

Glossary Item Box

Structure for the nodes of the grid.

Object Model

GridStructure ClassGridColumns ClassGridColumn ClassGridNode ClassCell ClassGrid ClassGridNode ClassGridNodes ClassGridNode ClassGridNode Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SerializableAttribute()>
Public Class GridStructure
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
C#
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SerializableAttribute()]
public class GridStructure
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SerializableAttribute()]
public __gc class GridStructure
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SerializableAttribute()]
public ref class GridStructure

Example

C# Copy Code
GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
            gantt1.Grid.GridStructure.RootNodes.AddNode();
            gantt1.Grid.GridStructure.RootNodes.AddNode();

            gn.GetCell(c_st.Index).Content.Value="Hello";
Visual Basic Copy Code
Dim gn As GridNode=gantt1.Grid.GridStructure.RootNodes.AddNode()
            gantt1.Grid.GridStructure.RootNodes.AddNode()
            gantt1.Grid.GridStructure.RootNodes.AddNode()

            gn.GetCell(c_st.Index).Content.Value="Hello"

Inheritance Hierarchy

System.Object
PlexityHide.GTP.GridStructure

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

GridStructure Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
GridStructure Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : GridStructure Class

Glossary Item Box

The following tables list the members exposed by GridStructure.

Public Constructors

 | Name | Description
Public Constructor | GridStructure Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | Columns | The columns of this gridstructure
Public Property | DrawnNodes | All nodes that are draw, last draw op
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | FirstVisibleNode | This property returns the FirstVisibleNode in the hierarcy. This is normally equal to RootNodes[0], but it can be another value due to the GridNode.Visible property. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode
Public Property | FocusedCell | Returns or sets the cell currently in focus, alway the last one selected.
Public Property | GridControl | Owning grid
Public Property | HasHeader | Header cells visible or not
Public Property | LastDrawnNode | LastDrawnNode returns the last row that is on screen. This Node may be only partly visible.
Public Property | MultiSelect | When this property is set to false, every cell selection de-selects all other selections
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | The root nodes of the tree
Public Property | RowSelect | Select complete rows and not single cells
Public Property | SelectedCells | Returns an array list filled with all the Cell-objects that are currently selected... The list is a copy of an internal list so it is smart to grab this as few times as possible.
Public Property | TopNode | Gets and sets the node displayed in the upper left corner. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode
Public Property | VisibleNodes | All nodes that are not hidden by collapse
Top

Public Methods

 | Name | Description
Public Method | CellFromXY | Gets a cell in the grid based on coordinates.
Public Method | ClearSelections | Deselect all nodes in grid according to list.
Public Method | CollapseAll | Collapses all nodes in root list; all decendants if recurse is true
Public Method | Draw | Draw nodes from topNode and forward.
Public Method | EndEdit | If the Grid is currently editing, this call will end it.
Public Method | ExpandAll | Expands all nodes in root list; all decendants if recurse is true
Public Method | ForwardTree | Return next node in the tree, take the expansion status into account.
Public Method | NextNode | Return next node in the tree, disregard the expansion status. If you send in null, the RootNodes[0] is returned if available.
Public Method | PreviousNode | Return previous node in the tree, disregard the expansion status.
Public Method | ReverseTree | Return previous node in the tree, take the expansion status into account.
Public Method | Sort | Sorts root nodes
Top

See Also

Reference

GridStructure Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridStructure Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : GridStructure Constructor

gridControl

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal gridControl As Grid _
)
Visual Basic (Usage) Copy Code
Dim gridControl As Grid

Dim instance As New GridStructure(gridControl)
C#
public GridStructure(
   Grid gridControl
)
Managed Extensions for C++
public: GridStructure(
   Grid* gridControl
)
C++/CLI
public:
GridStructure(
   Grid^ gridControl
)

Parameters

gridControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
GridStructure Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridStructure Class

Glossary Item Box

For a list of all members of this type, see GridStructure members.

Public Methods

 | Name | Description
Public Method | CellFromXY | Gets a cell in the grid based on coordinates.
Public Method | ClearSelections | Deselect all nodes in grid according to list.
Public Method | CollapseAll | Collapses all nodes in root list; all decendants if recurse is true
Public Method | Draw | Draw nodes from topNode and forward.
Public Method | EndEdit | If the Grid is currently editing, this call will end it.
Public Method | ExpandAll | Expands all nodes in root list; all decendants if recurse is true
Public Method | ForwardTree | Return next node in the tree, take the expansion status into account.
Public Method | NextNode | Return next node in the tree, disregard the expansion status. If you send in null, the RootNodes[0] is returned if available.
Public Method | PreviousNode | Return previous node in the tree, disregard the expansion status.
Public Method | ReverseTree | Return previous node in the tree, take the expansion status into account.
Public Method | Sort | Sorts root nodes
Top

See Also

Reference

GridStructure Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellFromXY Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : CellFromXY Method

x
y

Glossary Item Box

Gets a cell in the grid based on coordinates.

Syntax

Visual Basic (Declaration)
Public Function CellFromXY( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Cell
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim x As Integer
Dim y As Integer
Dim value As Cell

value = instance.CellFromXY(x, y)
C#
public Cell CellFromXY(
   int x,
   int y
)
Managed Extensions for C++
public: Cell* CellFromXY(
   int x,
   int y
)
C++/CLI
public:
Cell^ CellFromXY(
   int x,
   int y
)

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ClearSelections Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : ClearSelections Method

Glossary Item Box

Deselect all nodes in grid according to list.

Syntax

Visual Basic (Declaration)
Public Sub ClearSelections()
Visual Basic (Usage) Copy Code
Dim instance As GridStructure

instance.ClearSelections()
C#
public void ClearSelections()
Managed Extensions for C++
public: void ClearSelections();
C++/CLI
public:
void ClearSelections();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollapseAll Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : CollapseAll Method

recurse

Glossary Item Box

Collapses all nodes in root list; all decendants if recurse is true

Syntax

Visual Basic (Declaration)
Public Sub CollapseAll( _
   ByVal recurse As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim recurse As Boolean

instance.CollapseAll(recurse)
C#
public void CollapseAll(
   bool recurse
)
Managed Extensions for C++
public: void CollapseAll(
   bool recurse
)
C++/CLI
public:
void CollapseAll(
   bool recurse
)

Parameters

recurse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : Draw Method

g
topNode
startColumn
drawRect
FirstNodeOnNextPage

Glossary Item Box

Draw nodes from topNode and forward.

Syntax

Visual Basic (Declaration)
Public Function Draw( _
   ByVal g As Graphics, _
   ByVal topNode As GridNode, _
   ByVal startColumn As Integer, _
   ByVal drawRect As Rectangle, _
   ByRef FirstNodeOnNextPage As GridNode _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim g As Graphics
Dim topNode As GridNode
Dim startColumn As Integer
Dim drawRect As Rectangle
Dim FirstNodeOnNextPage As GridNode
Dim value As Integer

value = instance.Draw(g, topNode, startColumn, drawRect, FirstNodeOnNextPage)
C#
public int Draw(
   Graphics g,
   GridNode topNode,
   int startColumn,
   Rectangle drawRect,
   out GridNode FirstNodeOnNextPage
)
Managed Extensions for C++
public: int Draw(
   Graphics* g,
   GridNode* topNode,
   int startColumn,
   Rectangle drawRect,
   [PARAMFLAG::Out] GridNode* FirstNodeOnNextPage
)
C++/CLI
public:
int Draw(
   Graphics^ g,
   GridNode^ topNode,
   int startColumn,
   Rectangle drawRect,
   [Out] GridNode^ FirstNodeOnNextPage
)

Parameters

g
topNode
startColumn
drawRect
FirstNodeOnNextPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EndEdit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : EndEdit Method

Glossary Item Box

If the Grid is currently editing, this call will end it.

Syntax

Visual Basic (Declaration)
Public Sub EndEdit()
Visual Basic (Usage) Copy Code
Dim instance As GridStructure

instance.EndEdit()
C#
public void EndEdit()
Managed Extensions for C++
public: void EndEdit();
C++/CLI
public:
void EndEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ExpandAll Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : ExpandAll Method

recurse

Glossary Item Box

Expands all nodes in root list; all decendants if recurse is true

Syntax

Visual Basic (Declaration)
Public Sub ExpandAll( _
   ByVal recurse As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim recurse As Boolean

instance.ExpandAll(recurse)
C#
public void ExpandAll(
   bool recurse
)
Managed Extensions for C++
public: void ExpandAll(
   bool recurse
)
C++/CLI
public:
void ExpandAll(
   bool recurse
)

Parameters

recurse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ForwardTree Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : ForwardTree Method

node

Glossary Item Box

Return next node in the tree, take the expansion status into account.

Syntax

Visual Basic (Declaration)
Public Function ForwardTree( _
   ByVal node As GridNode _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim node As GridNode
Dim value As GridNode

value = instance.ForwardTree(node)
C#
public GridNode ForwardTree(
   GridNode node
)
Managed Extensions for C++
public: GridNode* ForwardTree(
   GridNode* node
)
C++/CLI
public:
GridNode^ ForwardTree(
   GridNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NextNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : NextNode Method

node

Glossary Item Box

Return next node in the tree, disregard the expansion status. If you send in null, the RootNodes[0] is returned if available.

Syntax

Visual Basic (Declaration)
Public Function NextNode( _
   ByVal node As GridNode _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim node As GridNode
Dim value As GridNode

value = instance.NextNode(node)
C#
public GridNode NextNode(
   GridNode node
)
Managed Extensions for C++
public: GridNode* NextNode(
   GridNode* node
)
C++/CLI
public:
GridNode^ NextNode(
   GridNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PreviousNode Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : PreviousNode Method

node

Glossary Item Box

Return previous node in the tree, disregard the expansion status.

Syntax

Visual Basic (Declaration)
Public Function PreviousNode( _
   ByVal node As GridNode _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim node As GridNode
Dim value As GridNode

value = instance.PreviousNode(node)
C#
public GridNode PreviousNode(
   GridNode node
)
Managed Extensions for C++
public: GridNode* PreviousNode(
   GridNode* node
)
C++/CLI
public:
GridNode^ PreviousNode(
   GridNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReverseTree Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : ReverseTree Method

node

Glossary Item Box

Return previous node in the tree, take the expansion status into account.

Syntax

Visual Basic (Declaration)
Public Function ReverseTree( _
   ByVal node As GridNode _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim node As GridNode
Dim value As GridNode

value = instance.ReverseTree(node)
C#
public GridNode ReverseTree(
   GridNode node
)
Managed Extensions for C++
public: GridNode* ReverseTree(
   GridNode* node
)
C++/CLI
public:
GridNode^ ReverseTree(
   GridNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : Sort Method

descending
aColumn

Glossary Item Box

Sorts root nodes

Syntax

Visual Basic (Declaration)
Public Sub Sort( _
   ByVal descending As Boolean, _
   ByVal aColumn As GridColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim descending As Boolean
Dim aColumn As GridColumn

instance.Sort(descending, aColumn)
C#
public void Sort(
   bool descending,
   GridColumn aColumn
)
Managed Extensions for C++
public: void Sort(
   bool descending,
   GridColumn* aColumn
)
C++/CLI
public:
void Sort(
   bool descending,
   GridColumn^ aColumn
)

Parameters

descending
aColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
GridStructure Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridStructure Class

Glossary Item Box

For a list of all members of this type, see GridStructure members.

Public Properties

 | Name | Description
Public Property | Columns | The columns of this gridstructure
Public Property | DrawnNodes | All nodes that are draw, last draw op
Public Property | DrawPyjamas | Decide if the stripes should be draw at all
Public Property | FirstVisibleNode | This property returns the FirstVisibleNode in the hierarcy. This is normally equal to RootNodes[0], but it can be another value due to the GridNode.Visible property. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode
Public Property | FocusedCell | Returns or sets the cell currently in focus, alway the last one selected.
Public Property | GridControl | Owning grid
Public Property | HasHeader | Header cells visible or not
Public Property | LastDrawnNode | LastDrawnNode returns the last row that is on screen. This Node may be only partly visible.
Public Property | MultiSelect | When this property is set to false, every cell selection de-selects all other selections
Public Property | PyjamasColor | The color of the stripes
Public Property | PyjamasGradientColor | The gradient color of the stripes
Public Property | RootNodes | The root nodes of the tree
Public Property | RowSelect | Select complete rows and not single cells
Public Property | SelectedCells | Returns an array list filled with all the Cell-objects that are currently selected... The list is a copy of an internal list so it is smart to grab this as few times as possible.
Public Property | TopNode | Gets and sets the node displayed in the upper left corner. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode
Public Property | VisibleNodes | All nodes that are not hidden by collapse
Top

See Also

Reference

GridStructure Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Columns Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : Columns Property

Glossary Item Box

The columns of this gridstructure

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Columns As GridColumns
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As GridColumns

value = instance.Columns
C#
[BrowsableAttribute(false)]
public GridColumns Columns {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property GridColumns* get_Columns();
C++/CLI
[BrowsableAttribute(false)]
public:
property GridColumns^ Columns {
   GridColumns^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawnNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : DrawnNodes Property

Glossary Item Box

All nodes that are draw, last draw op

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DrawnNodes As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As ArrayList

value = instance.DrawnNodes
C#
public ArrayList DrawnNodes {get;}
Managed Extensions for C++
public: __property ArrayList* get_DrawnNodes();
C++/CLI
public:
property ArrayList^ DrawnNodes {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawPyjamas Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : DrawPyjamas Property

Glossary Item Box

Decide if the stripes should be draw at all

Syntax

Visual Basic (Declaration)
Public Property DrawPyjamas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Boolean

instance.DrawPyjamas = value

value = instance.DrawPyjamas
C#
public bool DrawPyjamas {get; set;}
Managed Extensions for C++
public: __property bool get_DrawPyjamas();
public: __property void set_DrawPyjamas(
   bool value
);
C++/CLI
public:
property bool DrawPyjamas {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FirstVisibleNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : FirstVisibleNode Property

Glossary Item Box

This property returns the FirstVisibleNode in the hierarcy. This is normally equal to RootNodes[0], but it can be another value due to the GridNode.Visible property. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FirstVisibleNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As GridNode

value = instance.FirstVisibleNode
C#
public GridNode FirstVisibleNode {get;}
Managed Extensions for C++
public: __property GridNode* get_FirstVisibleNode();
C++/CLI
public:
property GridNode^ FirstVisibleNode {
   GridNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FocusedCell Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : FocusedCell Property

Glossary Item Box

Returns or sets the cell currently in focus, alway the last one selected.

Syntax

Visual Basic (Declaration)
Public Property FocusedCell As Cell
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Cell

instance.FocusedCell = value

value = instance.FocusedCell
C#
public Cell FocusedCell {get; set;}
Managed Extensions for C++
public: __property Cell* get_FocusedCell();
public: __property void set_FocusedCell(
   Cell* value
);
C++/CLI
public:
property Cell^ FocusedCell {
   Cell^ get();
   void set (    Cell^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridControl Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : GridControl Property

Glossary Item Box

Owning grid

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property GridControl As Grid
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Grid

value = instance.GridControl
C#
[BrowsableAttribute(false)]
public Grid GridControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Grid* get_GridControl();
C++/CLI
[BrowsableAttribute(false)]
public:
property Grid^ GridControl {
   Grid^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HasHeader Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : HasHeader Property

Glossary Item Box

Header cells visible or not

Syntax

Visual Basic (Declaration)
Public Property HasHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Boolean

instance.HasHeader = value

value = instance.HasHeader
C#
public bool HasHeader {get; set;}
Managed Extensions for C++
public: __property bool get_HasHeader();
public: __property void set_HasHeader(
   bool value
);
C++/CLI
public:
property bool HasHeader {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LastDrawnNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : LastDrawnNode Property

Glossary Item Box

LastDrawnNode returns the last row that is on screen. This Node may be only partly visible.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastDrawnNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As GridNode

value = instance.LastDrawnNode
C#
public GridNode LastDrawnNode {get;}
Managed Extensions for C++
public: __property GridNode* get_LastDrawnNode();
C++/CLI
public:
property GridNode^ LastDrawnNode {
   GridNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MultiSelect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : MultiSelect Property

Glossary Item Box

When this property is set to false, every cell selection de-selects all other selections

Syntax

Visual Basic (Declaration)
Public Property MultiSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Boolean

instance.MultiSelect = value

value = instance.MultiSelect
C#
public bool MultiSelect {get; set;}
Managed Extensions for C++
public: __property bool get_MultiSelect();
public: __property void set_MultiSelect(
   bool value
);
C++/CLI
public:
property bool MultiSelect {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : PyjamasColor Property

Glossary Item Box

The color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Color

instance.PyjamasColor = value

value = instance.PyjamasColor
C#
public Color PyjamasColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasColor();
public: __property void set_PyjamasColor(
   Color value
);
C++/CLI
public:
property Color PyjamasColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PyjamasGradientColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : PyjamasGradientColor Property

Glossary Item Box

The gradient color of the stripes

Syntax

Visual Basic (Declaration)
Public Property PyjamasGradientColor As Color
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Color

instance.PyjamasGradientColor = value

value = instance.PyjamasGradientColor
C#
public Color PyjamasGradientColor {get; set;}
Managed Extensions for C++
public: __property Color get_PyjamasGradientColor();
public: __property void set_PyjamasGradientColor(
   Color value
);
C++/CLI
public:
property Color PyjamasGradientColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RootNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : RootNodes Property

Glossary Item Box

The root nodes of the tree

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootNodes As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As GridNodes

value = instance.RootNodes
C#
public GridNodes RootNodes {get;}
Managed Extensions for C++
public: __property GridNodes* get_RootNodes();
C++/CLI
public:
property GridNodes^ RootNodes {
   GridNodes^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowSelect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : RowSelect Property

Glossary Item Box

Select complete rows and not single cells

Syntax

Visual Basic (Declaration)
Public Property RowSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As Boolean

instance.RowSelect = value

value = instance.RowSelect
C#
public bool RowSelect {get; set;}
Managed Extensions for C++
public: __property bool get_RowSelect();
public: __property void set_RowSelect(
   bool value
);
C++/CLI
public:
property bool RowSelect {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectedCells Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : SelectedCells Property

Glossary Item Box

Returns an array list filled with all the Cell-objects that are currently selected... The list is a copy of an internal list so it is smart to grab this as few times as possible.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedCells As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As ArrayList

value = instance.SelectedCells
C#
public ArrayList SelectedCells {get;}
Managed Extensions for C++
public: __property ArrayList* get_SelectedCells();
C++/CLI
public:
property ArrayList^ SelectedCells {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TopNode Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : TopNode Property

Glossary Item Box

Gets and sets the node displayed in the upper left corner. Note: The difference between the FirstVisibleNode and TopNode is that TopNode is the current TopNode drawn in the grid and the FirstVisibleNode is the first node that could be considered TopNode

Syntax

Visual Basic (Declaration)
Public Property TopNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As GridNode

instance.TopNode = value

value = instance.TopNode
C#
public GridNode TopNode {get; set;}
Managed Extensions for C++
public: __property GridNode* get_TopNode();
public: __property void set_TopNode(
   GridNode* value
);
C++/CLI
public:
property GridNode^ TopNode {
   GridNode^ get();
   void set (    GridNode^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridStructure Class : VisibleNodes Property

Glossary Item Box

All nodes that are not hidden by collapse

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleNodes As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As GridStructure
Dim value As ArrayList

value = instance.VisibleNodes
C#
public ArrayList VisibleNodes {get;}
Managed Extensions for C++
public: __property ArrayList* get_VisibleNodes();
C++/CLI
public:
property ArrayList^ VisibleNodes {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridStructure Class
GridStructure Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageMapLogic Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ImageMapLogic Class

Glossary Item Box

Holds all logic for generating imagemaps for the GTP.NET components

Object Model

ImageMapLogic Class

Syntax

Visual Basic (Declaration)
Public Class ImageMapLogic
Visual Basic (Usage) Copy Code
Dim instance As ImageMapLogic
C#
public class ImageMapLogic
Managed Extensions for C++
public __gc class ImageMapLogic
C++/CLI
public ref class ImageMapLogic

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ImageMapLogic

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ImageMapLogic Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ImageMapLogic Class Members
See Also Methods Send comments on this topic.
PlexityHide.GTP Namespace : ImageMapLogic Class

Glossary Item Box

The following tables list the members exposed by ImageMapLogic.

Public Constructors

 | Name | Description
Public Constructor | ImageMapLogic Constructor |
Top

Public Methods

 | Name | Description
Public Method | CreateImageMap | When you have produced and array of IMapAreas of several (max 3) arrays of IMapAreas you build the map tag with this call.
Public Method | ProduceAreas_DateScaler | Produces IMapParts for the DateScaler If your are producing a composite Bitmap your datescaler may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Public Method | ProduceAreas_Grid | Produces IMapParts for the Grid If your are producing a composite Bitmap your grid may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Public Method | ProduceAreas_TimeItemArea | Produces IMapParts for the TimeItemArea of the Gantt If your are producing a composite Bitmap your timeItemArea may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Top

See Also

Reference

ImageMapLogic Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageMapLogic Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ImageMapLogic Class : ImageMapLogic Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ImageMapLogic()
C#
public ImageMapLogic()
Managed Extensions for C++
public: ImageMapLogic();
C++/CLI
public:
ImageMapLogic();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ImageMapLogic Class
ImageMapLogic Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ImageMapLogic Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ImageMapLogic Class

Glossary Item Box

For a list of all members of this type, see ImageMapLogic members.

Public Methods

 | Name | Description
Public Method | CreateImageMap | When you have produced and array of IMapAreas of several (max 3) arrays of IMapAreas you build the map tag with this call.
Public Method | ProduceAreas_DateScaler | Produces IMapParts for the DateScaler If your are producing a composite Bitmap your datescaler may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Public Method | ProduceAreas_Grid | Produces IMapParts for the Grid If your are producing a composite Bitmap your grid may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Public Method | ProduceAreas_TimeItemArea | Produces IMapParts for the TimeItemArea of the Gantt If your are producing a composite Bitmap your timeItemArea may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls
Top

See Also

Reference

ImageMapLogic Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CreateImageMap Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ImageMapLogic Class : CreateImageMap Method

NameOfImageMap
set1OfMapAreas
set2OfMapAreas
set3OfMapAreas

Glossary Item Box

When you have produced and array of IMapAreas of several (max 3) arrays of IMapAreas you build the map tag with this call.

Syntax

Visual Basic (Declaration)
Public Function CreateImageMap( _
   ByVal NameOfImageMap As String, _
   ByVal set1OfMapAreas() As IMapArea, _
   ByVal set2OfMapAreas() As IMapArea, _
   ByVal set3OfMapAreas() As IMapArea _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ImageMapLogic
Dim NameOfImageMap As String
Dim set1OfMapAreas() As IMapArea
Dim set2OfMapAreas() As IMapArea
Dim set3OfMapAreas() As IMapArea
Dim value As String

value = instance.CreateImageMap(NameOfImageMap, set1OfMapAreas, set2OfMapAreas, set3OfMapAreas)
C#
public string CreateImageMap(
   string NameOfImageMap,
   IMapArea[] set1OfMapAreas,
   IMapArea[] set2OfMapAreas,
   IMapArea[] set3OfMapAreas
)
Managed Extensions for C++
public: string* CreateImageMap(
   string* NameOfImageMap,
   IMapArea*[]* set1OfMapAreas,
   IMapArea*[]* set2OfMapAreas,
   IMapArea*[]* set3OfMapAreas
)
C++/CLI
public:
String^ CreateImageMap(
   String^ NameOfImageMap,
   array<IMapArea^>^ set1OfMapAreas,
   array<IMapArea^>^ set2OfMapAreas,
   array<IMapArea^>^ set3OfMapAreas
)

Parameters

NameOfImageMap
set1OfMapAreas
set2OfMapAreas
set3OfMapAreas

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ImageMapLogic Class
ImageMapLogic Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ProduceAreas_DateScaler Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ImageMapLogic Class : ProduceAreas_DateScaler Method

offset
aDateScaler
ac

Glossary Item Box

Produces IMapParts for the DateScaler If your are producing a composite Bitmap your datescaler may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls

Syntax

Visual Basic (Declaration)
Public Function ProduceAreas_DateScaler( _
   ByVal offset As Point, _
   ByVal aDateScaler As DateScaler, _
   ByVal ac As ImageMapActionCallback _
) As IMapArea()
Visual Basic (Usage) Copy Code
Dim instance As ImageMapLogic
Dim offset As Point
Dim aDateScaler As DateScaler
Dim ac As ImageMapActionCallback
Dim value() As IMapArea

value = instance.ProduceAreas_DateScaler(offset, aDateScaler, ac)
C#
public IMapArea[] ProduceAreas_DateScaler(
   Point offset,
   DateScaler aDateScaler,
   ImageMapActionCallback ac
)
Managed Extensions for C++
public: IMapArea*[]* ProduceAreas_DateScaler(
   Point offset,
   DateScaler* aDateScaler,
   ImageMapActionCallback* ac
)
C++/CLI
public:
array<IMapArea^>^ ProduceAreas_DateScaler(
   Point offset,
   DateScaler^ aDateScaler,
   ImageMapActionCallback^ ac
)

Parameters

offset
aDateScaler
ac

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ImageMapLogic Class
ImageMapLogic Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ProduceAreas_Grid Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ImageMapLogic Class : ProduceAreas_Grid Method

offset
aGrid
ac

Glossary Item Box

Produces IMapParts for the Grid If your are producing a composite Bitmap your grid may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls

Syntax

Visual Basic (Declaration)
Public Function ProduceAreas_Grid( _
   ByVal offset As Point, _
   ByVal aGrid As Grid, _
   ByVal ac As ImageMapActionCallback _
) As IMapArea()
Visual Basic (Usage) Copy Code
Dim instance As ImageMapLogic
Dim offset As Point
Dim aGrid As Grid
Dim ac As ImageMapActionCallback
Dim value() As IMapArea

value = instance.ProduceAreas_Grid(offset, aGrid, ac)
C#
public IMapArea[] ProduceAreas_Grid(
   Point offset,
   Grid aGrid,
   ImageMapActionCallback ac
)
Managed Extensions for C++
public: IMapArea*[]* ProduceAreas_Grid(
   Point offset,
   Grid* aGrid,
   ImageMapActionCallback* ac
)
C++/CLI
public:
array<IMapArea^>^ ProduceAreas_Grid(
   Point offset,
   Grid^ aGrid,
   ImageMapActionCallback^ ac
)

Parameters

offset
aGrid
ac

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ImageMapLogic Class
ImageMapLogic Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ProduceAreas_TimeItemArea Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ImageMapLogic Class : ProduceAreas_TimeItemArea Method

offset
aGantt
ac

Glossary Item Box

Produces IMapParts for the TimeItemArea of the Gantt If your are producing a composite Bitmap your timeItemArea may be at an offset in the image, make sure that that offset is sent in to this method. Supply a callback in order to set your action urls

Syntax

Visual Basic (Declaration)
Public Function ProduceAreas_TimeItemArea( _
   ByVal offset As Point, _
   ByVal aGantt As Gantt, _
   ByVal ac As ImageMapActionCallback _
) As IMapArea()
Visual Basic (Usage) Copy Code
Dim instance As ImageMapLogic
Dim offset As Point
Dim aGantt As Gantt
Dim ac As ImageMapActionCallback
Dim value() As IMapArea

value = instance.ProduceAreas_TimeItemArea(offset, aGantt, ac)
C#
public IMapArea[] ProduceAreas_TimeItemArea(
   Point offset,
   Gantt aGantt,
   ImageMapActionCallback ac
)
Managed Extensions for C++
public: IMapArea*[]* ProduceAreas_TimeItemArea(
   Point offset,
   Gantt* aGantt,
   ImageMapActionCallback* ac
)
C++/CLI
public:
array<IMapArea^>^ ProduceAreas_TimeItemArea(
   Point offset,
   Gantt^ aGantt,
   ImageMapActionCallback^ ac
)

Parameters

offset
aGantt
ac

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ImageMapLogic Class
ImageMapLogic Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IMapArea Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : IMapArea Class

Glossary Item Box

This object holds the definition for one active area in the image map. You will need to add the href part yourself in the callback ImageMapActionCallback to implement your action

Object Model

IMapArea Class

Syntax

Visual Basic (Declaration)
Public Class IMapArea
Visual Basic (Usage) Copy Code
Dim instance As IMapArea
C#
public class IMapArea
Managed Extensions for C++
public __gc class IMapArea
C++/CLI
public ref class IMapArea

Inheritance Hierarchy

System.Object
PlexityHide.GTP.IMapArea

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

IMapArea Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
IMapArea Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : IMapArea Class

Glossary Item Box

The following tables list the members exposed by IMapArea.

Public Constructors

 | Name | Description
Public Constructor | IMapArea Constructor |
Top

Public Fields

 | Name | Description
Public Field | ActionOwner | Action owner is either Grid, Gantt or DateScaler
Public Field | ActionPart | The Action part will be: a GridColumn for column heads, a Cell for CellAreas, a GridNode for Tree-Expand-Collapse-Buttons a TimeItem for TimeItems a GanttRow for GanttRows the DateScaler for general clicking in the datescaler DateScaler.ForwardPan for forward time scroll DateScaler.BackwardPan for backward time scroll
Public Field | coords | The coordinates as they are expressed in the area tag of a imagemap
Public Field | hRef | This value you provide if you want an action to be triggered when the area is clicked This property must contain valid xhtml attributes like this example "Title='BackwardPan' href='BackwardPan'" If you do not want and action leave it empty == ""
Top

See Also

Reference

IMapArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
IMapArea Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IMapArea Class : IMapArea Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New IMapArea()
C#
public IMapArea()
Managed Extensions for C++
public: IMapArea();
C++/CLI
public:
IMapArea();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IMapArea Class
IMapArea Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
IMapArea Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : IMapArea Class

Glossary Item Box

For a list of all members of this type, see IMapArea members.

Public Fields

 | Name | Description
Public Field | ActionOwner | Action owner is either Grid, Gantt or DateScaler
Public Field | ActionPart | The Action part will be: a GridColumn for column heads, a Cell for CellAreas, a GridNode for Tree-Expand-Collapse-Buttons a TimeItem for TimeItems a GanttRow for GanttRows the DateScaler for general clicking in the datescaler DateScaler.ForwardPan for forward time scroll DateScaler.BackwardPan for backward time scroll
Public Field | coords | The coordinates as they are expressed in the area tag of a imagemap
Public Field | hRef | This value you provide if you want an action to be triggered when the area is clicked This property must contain valid xhtml attributes like this example "Title='BackwardPan' href='BackwardPan'" If you do not want and action leave it empty == ""
Top

See Also

Reference

IMapArea Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ActionOwner Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IMapArea Class : ActionOwner Field

Glossary Item Box

Action owner is either Grid, Gantt or DateScaler

Syntax

Visual Basic (Declaration)
Public ActionOwner As Control
Visual Basic (Usage) Copy Code
Dim instance As IMapArea
Dim value As Control

value = instance.ActionOwner

instance.ActionOwner = value
C#
public Control ActionOwner
Managed Extensions for C++
public: Control* ActionOwner
C++/CLI
public:
Control^ ActionOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IMapArea Class
IMapArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ActionPart Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IMapArea Class : ActionPart Field

Glossary Item Box

The Action part will be: a GridColumn for column heads, a Cell for CellAreas, a GridNode for Tree-Expand-Collapse-Buttons a TimeItem for TimeItems a GanttRow for GanttRows the DateScaler for general clicking in the datescaler DateScaler.ForwardPan for forward time scroll DateScaler.BackwardPan for backward time scroll

Syntax

Visual Basic (Declaration)
Public ActionPart As Object
Visual Basic (Usage) Copy Code
Dim instance As IMapArea
Dim value As Object

value = instance.ActionPart

instance.ActionPart = value
C#
public object ActionPart
Managed Extensions for C++
public: Object* ActionPart
C++/CLI
public:
Object^ ActionPart

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IMapArea Class
IMapArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
coords Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IMapArea Class : coords Field

Glossary Item Box

The coordinates as they are expressed in the area tag of a imagemap

Syntax

Visual Basic (Declaration)
Public coords As String
Visual Basic (Usage) Copy Code
Dim instance As IMapArea
Dim value As String

value = instance.coords

instance.coords = value
C#
public string coords
Managed Extensions for C++
public: string* coords
C++/CLI
public:
String^ coords

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IMapArea Class
IMapArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
hRef Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IMapArea Class : hRef Field

Glossary Item Box

This value you provide if you want an action to be triggered when the area is clicked This property must contain valid xhtml attributes like this example "Title='BackwardPan' href='BackwardPan'" If you do not want and action leave it empty == ""

Syntax

Visual Basic (Declaration)
Public hRef As String
Visual Basic (Usage) Copy Code
Dim instance As IMapArea
Dim value As String

value = instance.hRef

instance.hRef = value
C#
public string hRef
Managed Extensions for C++
public: string* hRef
C++/CLI
public:
String^ hRef

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IMapArea Class
IMapArea Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layer Class

Glossary Item Box

A layer holds possibly many time items on one GanttRow, there can be many layers on one GanttRow. The point of creating many layers on a single row is to control the drawing order, ie the z-order.

Object Model

Layer ClassTimeItem Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Layer
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As Layer
C#
[DefaultMemberAttribute("Item")]
public class Layer : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Layer : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Layer : public System.Collections.CollectionBase

Example

C# Copy Code
GanttRow gr = GanttRow.FromGridNode(gn);
      gr.CollisionDetect=true;
      gr.CollisionDetectBetweenLayers=false;
      gr.Layers.AddLayer();
      gr.Layers.AddLayer();
      TimeItem ti1=gr.Layers[0].AddNewTimeItem();
      TimeItem ti2=gr.Layers[1].AddNewTimeItem();
      TimeItem ti3=gr.Layers[2].AddNewTimeItem();
Visual Basic Copy Code
Dim gr As GanttRow = GanttRow.FromGridNode(gn)
      gr.CollisionDetect=True
      gr.CollisionDetectBetweenLayers=False
      gr.Layers.AddLayer()
      gr.Layers.AddLayer()
      Dim ti1 As TimeItem=gr.Layers(0).AddNewTimeItem()
      Dim ti2 As TimeItem=gr.Layers(1).AddNewTimeItem()
      Dim ti3 As TimeItem=gr.Layers(2).AddNewTimeItem()

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.Layer

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Layer Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Layer Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : Layer Class

Glossary Item Box

The following tables list the members exposed by Layer.

Public Constructors

 | Name | Description
Public Constructor | Layer Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | DataMember | The DataSource datamember
Public Property | DataSource | The DataSource DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprectated since DataSource takes any object
Public Property | Item | indexer
Public Property | Layers | Collection of layers from owning row
Public Property | NameInDS_Identity | The name of the DataSource column containing the Identity value. You will need to set this to help the Gantt resolve databound TimeItemLinks
Public Property | NameInDS_Length | The name of the DataSource column containing the length timespan value. Note: A time item is either using the Length and a CalculatedStop(NameInDS_Stop ignored) OR a Stop time(NameInDS_Length ignored) To use Length rather than Stop set BlockedTimeCalculatedStop on TimeItemLayout
Public Property | NameInDS_Start | The name of the DataSource column containing the start datetime value
Public Property | NameInDS_Stop | The name of the DataSource column containing the stop datetime value
Public Property | TimeItemLayout | Name of TimeItemLayout that will be used when new time items are created in this layer
Public Property | Visible | Use it to temporarily hide a layer from view
Top

Public Methods

 | Name | Description
Public Method | Add | Add existing time item
Public Method | AddNewTimeItem | Create new time item
Public Method | EnsuredTimeItemDataConnect | Returns the TimeItemDataConnect for this layer, if it is not created yet it will be by this call. Deprecated. Use TimeItemDataConnect instead
Public Method | FindTimeItemUserReference | Loops thru this layer and compare x with TimeItem.UserReference
Public Method | IndexOf | Index of time item
Public Method | Insert | Insert this time item at position
Public Method | Invalidate | Will redraw layer
Public Method | Move | Move this time item within list
Public Method | Remove | Remove time item
Public Method | Sort | Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is so, you should sort the datasource instead.
Public Method | TimeItemDataConnect | Returns the TimeItemDataConnect for this layer.
Public Method | TimeItemFromXY | Find time item from pixel
Top

See Also

Reference

Layer Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Layer Constructor

aLayers

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aLayers As Layers _
)
Visual Basic (Usage) Copy Code
Dim aLayers As Layers

Dim instance As New Layer(aLayers)
C#
public Layer(
   Layers aLayers
)
Managed Extensions for C++
public: Layer(
   Layers* aLayers
)
C++/CLI
public:
Layer(
   Layers^ aLayers
)

Parameters

aLayers

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Layer Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layer Class

Glossary Item Box

For a list of all members of this type, see Layer members.

Public Methods

 | Name | Description
Public Method | Add | Add existing time item
Public Method | AddNewTimeItem | Create new time item
Public Method | EnsuredTimeItemDataConnect | Returns the TimeItemDataConnect for this layer, if it is not created yet it will be by this call. Deprecated. Use TimeItemDataConnect instead
Public Method | FindTimeItemUserReference | Loops thru this layer and compare x with TimeItem.UserReference
Public Method | IndexOf | Index of time item
Public Method | Insert | Insert this time item at position
Public Method | Invalidate | Will redraw layer
Public Method | Move | Move this time item within list
Public Method | Remove | Remove time item
Public Method | Sort | Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is so, you should sort the datasource instead.
Public Method | TimeItemDataConnect | Returns the TimeItemDataConnect for this layer.
Public Method | TimeItemFromXY | Find time item from pixel
Top

See Also

Reference

Layer Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Add Method

aTimeItem

Glossary Item Box

Add existing time item

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aTimeItem As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim aTimeItem As TimeItem

instance.Add(aTimeItem)
C#
public void Add(
   TimeItem aTimeItem
)
Managed Extensions for C++
public: void Add(
   TimeItem* aTimeItem
)
C++/CLI
public:
void Add(
   TimeItem^ aTimeItem
)

Parameters

aTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddNewTimeItem Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : AddNewTimeItem Method

Glossary Item Box

Create new time item

Syntax

Visual Basic (Declaration)
Public Function AddNewTimeItem() As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As TimeItem

value = instance.AddNewTimeItem()
C#
public TimeItem AddNewTimeItem()
Managed Extensions for C++
public: TimeItem* AddNewTimeItem();
C++/CLI
public:
TimeItem^ AddNewTimeItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EnsuredTimeItemDataConnect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : EnsuredTimeItemDataConnect Method

Glossary Item Box

Returns the TimeItemDataConnect for this layer, if it is not created yet it will be by this call. Deprecated. Use TimeItemDataConnect instead

Syntax

Visual Basic (Declaration)
Public Function EnsuredTimeItemDataConnect() As TimeItemDataConnect
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As TimeItemDataConnect

value = instance.EnsuredTimeItemDataConnect()
C#
public TimeItemDataConnect EnsuredTimeItemDataConnect()
Managed Extensions for C++
public: TimeItemDataConnect* EnsuredTimeItemDataConnect();
C++/CLI
public:
TimeItemDataConnect^ EnsuredTimeItemDataConnect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FindTimeItemUserReference Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : FindTimeItemUserReference Method

x

Glossary Item Box

Loops thru this layer and compare x with TimeItem.UserReference

Syntax

Visual Basic (Declaration)
Public Function FindTimeItemUserReference( _
   ByVal x As Object _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim x As Object
Dim value As TimeItem

value = instance.FindTimeItemUserReference(x)
C#
public TimeItem FindTimeItemUserReference(
   object x
)
Managed Extensions for C++
public: TimeItem* FindTimeItemUserReference(
   Object* x
)
C++/CLI
public:
TimeItem^ FindTimeItemUserReference(
   Object^ x
)

Parameters

x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : IndexOf Method

value

Glossary Item Box

Index of time item

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Insert Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Insert Method

index
aTimeItem

Glossary Item Box

Insert this time item at position

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal aTimeItem As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim index As Integer
Dim aTimeItem As TimeItem

instance.Insert(index, aTimeItem)
C#
public void Insert(
   int index,
   TimeItem aTimeItem
)
Managed Extensions for C++
public: void Insert(
   int index,
   TimeItem* aTimeItem
)
C++/CLI
public:
void Insert(
   int index,
   TimeItem^ aTimeItem
)

Parameters

index
aTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Invalidate Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Invalidate Method

Glossary Item Box

Will redraw layer

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As Layer

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Move Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Move Method

OldIndex
NewIndex

Glossary Item Box

Move this time item within list

Syntax

Visual Basic (Declaration)
Public Sub Move( _
   ByVal OldIndex As Integer, _
   ByVal NewIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim OldIndex As Integer
Dim NewIndex As Integer

instance.Move(OldIndex, NewIndex)
C#
public void Move(
   int OldIndex,
   int NewIndex
)
Managed Extensions for C++
public: void Move(
   int OldIndex,
   int NewIndex
)
C++/CLI
public:
void Move(
   int OldIndex,
   int NewIndex
)

Parameters

OldIndex
NewIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Remove Method

aTimeItem

Glossary Item Box

Remove time item

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal aTimeItem As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim aTimeItem As TimeItem

instance.Remove(aTimeItem)
C#
public void Remove(
   TimeItem aTimeItem
)
Managed Extensions for C++
public: void Remove(
   TimeItem* aTimeItem
)
C++/CLI
public:
void Remove(
   TimeItem^ aTimeItem
)

Parameters

aTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Sort Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Sort Method

index
count
comparer

Glossary Item Box

Calls the collectionbase.innerlist.sort method. Implement you comparer to sort. Do not use if this list is databound, if that is so, you should sort the datasource instead.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Sort( _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal comparer As IComparer _
)
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim index As Integer
Dim count As Integer
Dim comparer As IComparer

instance.Sort(index, count, comparer)
C#
public virtual void Sort(
   int index,
   int count,
   IComparer comparer
)
Managed Extensions for C++
public: virtual void Sort(
   int index,
   int count,
   IComparer* comparer
)
C++/CLI
public:
virtual void Sort(
   int index,
   int count,
   IComparer^ comparer
)

Parameters

index
count
comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemDataConnect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : TimeItemDataConnect Method

Glossary Item Box

Returns the TimeItemDataConnect for this layer.

Syntax

Visual Basic (Declaration)
Public Function TimeItemDataConnect() As TimeItemDataConnect
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As TimeItemDataConnect

value = instance.TimeItemDataConnect()
C#
public TimeItemDataConnect TimeItemDataConnect()
Managed Extensions for C++
public: TimeItemDataConnect* TimeItemDataConnect();
C++/CLI
public:
TimeItemDataConnect^ TimeItemDataConnect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemFromXY Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : TimeItemFromXY Method

x
y

Glossary Item Box

Find time item from pixel

Syntax

Visual Basic (Declaration)
Public Function TimeItemFromXY( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim x As Integer
Dim y As Integer
Dim value As TimeItem

value = instance.TimeItemFromXY(x, y)
C#
public TimeItem TimeItemFromXY(
   int x,
   int y
)
Managed Extensions for C++
public: TimeItem* TimeItemFromXY(
   int x,
   int y
)
C++/CLI
public:
TimeItem^ TimeItemFromXY(
   int x,
   int y
)

Parameters

x
y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Layer Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layer Class

Glossary Item Box

For a list of all members of this type, see Layer members.

Public Properties

 | Name | Description
Public Property | DataMember | The DataSource datamember
Public Property | DataSource | The DataSource DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprectated since DataSource takes any object
Public Property | Item | indexer
Public Property | Layers | Collection of layers from owning row
Public Property | NameInDS_Identity | The name of the DataSource column containing the Identity value. You will need to set this to help the Gantt resolve databound TimeItemLinks
Public Property | NameInDS_Length | The name of the DataSource column containing the length timespan value. Note: A time item is either using the Length and a CalculatedStop(NameInDS_Stop ignored) OR a Stop time(NameInDS_Length ignored) To use Length rather than Stop set BlockedTimeCalculatedStop on TimeItemLayout
Public Property | NameInDS_Start | The name of the DataSource column containing the start datetime value
Public Property | NameInDS_Stop | The name of the DataSource column containing the stop datetime value
Public Property | TimeItemLayout | Name of TimeItemLayout that will be used when new time items are created in this layer
Public Property | Visible | Use it to temporarily hide a layer from view
Top

See Also

Reference

Layer Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : DataMember Property

Glossary Item Box

The DataSource datamember

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSource Property
See Also Example Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : DataSource Property

Glossary Item Box

The DataSource DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}
Managed Extensions for C++
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Example

C# Copy Code
class TimedThing:object
      {
        public TimedThing(DateTime start,DateTime stop)
        {
          Start=start;
          Stop=stop;
        }
        private DateTime fstart;
        private DateTime fstop;
        public DateTime Start
        {
          get{return fstart;}
          set{fstart=value;}
        }
        public DateTime Stop
        {
          get{return fstop;}
          set{fstop=value;}
        }
      }
    private void button1_Click(object sender, System.EventArgs e)
    {
      ArrayList myTimeItems=new ArrayList();
      myTimeItems.Add(new TimedThing(DateTime.Today,DateTime.Today.AddDays(1)));
      myTimeItems.Add(new TimedThing(DateTime.Today.AddDays(2),DateTime.Today.AddDays(3)));
      myTimeItems.Add(new TimedThing(DateTime.Today.AddDays(4),DateTime.Today.AddDays(5)));
      myTimeItems.Add(new TimedThing(DateTime.Today.AddDays(6),DateTime.Today.AddDays(7)));
      myTimeItems.Add(new TimedThing(DateTime.Today.AddDays(8),DateTime.Today.AddDays(9)));

      GanttRow gr1=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes[0]);
      Layer l=gr1.Layers.AddLayer();
      l.NameInDS_Start="Start";
      l.NameInDS_Stop="Stop";
      l.DataSourceList=myTimeItems;

    }

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : DataSourceList Property

Glossary Item Box

This IList will be used for binding. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprectated since DataSource takes any object

Syntax

Visual Basic (Declaration)
Public Property DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As IList

instance.DataSourceList = value

value = instance.DataSourceList
C#
public IList DataSourceList {get; set;}
Managed Extensions for C++
public: __property IList* get_DataSourceList();
public: __property void set_DataSourceList(
   IList* value
);
C++/CLI
public:
property IList^ DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Example

DataSource Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Item Property

Index

Glossary Item Box

indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim Index As Integer
Dim value As TimeItem

value = instance.Item(Index)
C#
public TimeItem this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property TimeItem* get_Item   int Index
;
C++/CLI
public:
property TimeItem^ default [int] {
   TimeItem^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Layers Property

Glossary Item Box

Collection of layers from owning row

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As Layers
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As Layers

value = instance.Layers
C#
public Layers Layers {get;}
Managed Extensions for C++
public: __property Layers* get_Layers();
C++/CLI
public:
property Layers^ Layers {
   Layers^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_Identity Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : NameInDS_Identity Property

Glossary Item Box

The name of the DataSource column containing the Identity value. You will need to set this to help the Gantt resolve databound TimeItemLinks

Syntax

Visual Basic (Declaration)
Public Property NameInDS_Identity As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.NameInDS_Identity = value

value = instance.NameInDS_Identity
C#
public string NameInDS_Identity {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_Identity();
public: __property void set_NameInDS_Identity(
   string* value
);
C++/CLI
public:
property String^ NameInDS_Identity {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_Length Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : NameInDS_Length Property

Glossary Item Box

The name of the DataSource column containing the length timespan value. Note: A time item is either using the Length and a CalculatedStop(NameInDS_Stop ignored) OR a Stop time(NameInDS_Length ignored) To use Length rather than Stop set BlockedTimeCalculatedStop on TimeItemLayout

Syntax

Visual Basic (Declaration)
Public Property NameInDS_Length As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.NameInDS_Length = value

value = instance.NameInDS_Length
C#
public string NameInDS_Length {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_Length();
public: __property void set_NameInDS_Length(
   string* value
);
C++/CLI
public:
property String^ NameInDS_Length {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_Start Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : NameInDS_Start Property

Glossary Item Box

The name of the DataSource column containing the start datetime value

Syntax

Visual Basic (Declaration)
Public Property NameInDS_Start As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.NameInDS_Start = value

value = instance.NameInDS_Start
C#
public string NameInDS_Start {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_Start();
public: __property void set_NameInDS_Start(
   string* value
);
C++/CLI
public:
property String^ NameInDS_Start {
   String^ get();
   void set (    String^ value);
}

Example

DataSource Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_Stop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : NameInDS_Stop Property

Glossary Item Box

The name of the DataSource column containing the stop datetime value

Syntax

Visual Basic (Declaration)
Public Property NameInDS_Stop As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.NameInDS_Stop = value

value = instance.NameInDS_Stop
C#
public string NameInDS_Stop {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_Stop();
public: __property void set_NameInDS_Stop(
   string* value
);
C++/CLI
public:
property String^ NameInDS_Stop {
   String^ get();
   void set (    String^ value);
}

Example

DataSource Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayout Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : TimeItemLayout Property

Glossary Item Box

Name of TimeItemLayout that will be used when new time items are created in this layer

Syntax

Visual Basic (Declaration)
Public Property TimeItemLayout As String
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As String

instance.TimeItemLayout = value

value = instance.TimeItemLayout
C#
public string TimeItemLayout {get; set;}
Managed Extensions for C++
public: __property string* get_TimeItemLayout();
public: __property void set_TimeItemLayout(
   string* value
);
C++/CLI
public:
property String^ TimeItemLayout {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Visible Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Visible Property

Glossary Item Box

Use it to temporarily hide a layer from view

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Layer
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LayerEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : LayerEventArgs Class

Glossary Item Box

Arguments for layer events

Object Model

LayerEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class LayerEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LayerEventArgs
C#
public class LayerEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class LayerEventArgs : public System.EventArgs
C++/CLI
public ref class LayerEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.LayerEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LayerEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
LayerEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : LayerEventArgs Class

Glossary Item Box

The following tables list the members exposed by LayerEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LayerEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Index | The index of the conceared TimeItem
Public Field | Layer | The layer handled
Public Field | TimeItem | The timeItem handled
Top

See Also

Reference

LayerEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LayerEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LayerEventArgs Class : LayerEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LayerEventArgs()
C#
public LayerEventArgs()
Managed Extensions for C++
public: LayerEventArgs();
C++/CLI
public:
LayerEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayerEventArgs Class
LayerEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
LayerEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LayerEventArgs Class

Glossary Item Box

For a list of all members of this type, see LayerEventArgs members.

Public Fields

 | Name | Description
Public Field | Index | The index of the conceared TimeItem
Public Field | Layer | The layer handled
Public Field | TimeItem | The timeItem handled
Top

See Also

Reference

LayerEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LayerEventArgs Class : Index Field

Glossary Item Box

The index of the conceared TimeItem

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As LayerEventArgs
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayerEventArgs Class
LayerEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LayerEventArgs Class : Layer Field

Glossary Item Box

The layer handled

Syntax

Visual Basic (Declaration)
Public Layer As Layer
Visual Basic (Usage) Copy Code
Dim instance As LayerEventArgs
Dim value As Layer

value = instance.Layer

instance.Layer = value
C#
public Layer Layer
Managed Extensions for C++
public: Layer* Layer
C++/CLI
public:
Layer^ Layer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayerEventArgs Class
LayerEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LayerEventArgs Class : TimeItem Field

Glossary Item Box

The timeItem handled

Syntax

Visual Basic (Declaration)
Public TimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As LayerEventArgs
Dim value As TimeItem

value = instance.TimeItem

instance.TimeItem = value
C#
public TimeItem TimeItem
Managed Extensions for C++
public: TimeItem* TimeItem
C++/CLI
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LayerEventArgs Class
LayerEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layers Class

Glossary Item Box

Collection of layers that is held by one GanttRow

Object Model

Layers ClassLayer Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Layers
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As Layers
C#
[DefaultMemberAttribute("Item")]
public class Layers : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Layers : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Layers : public System.Collections.CollectionBase

Example

Layer Class

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.Layers

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Layers Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
Layers Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : Layers Class

Glossary Item Box

The following tables list the members exposed by Layers.

Public Constructors

 | Name | Description
Public Constructor | Layers Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | GanttRow | Owning GanttRow
Public Property | Item | Indexer
Top

Public Methods

 | Name | Description
Public Method | AddLayer | Adds a layer
Public Method | IndexOf | Finds index of a layer
Public Method | Invalidate | Redraw
Public Method | Remove | removes a layer by index
Top

See Also

Reference

Layers Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : Layers Constructor

Glossary Item Box

Overload List

Overload | Description
Layers Constructor() | internal constructor
Layers Constructor(GanttRow) | constructor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class > Layers Constructor : Layers Constructor()

Glossary Item Box

internal constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Layers()
C#
public Layers()
Managed Extensions for C++
public: Layers();
C++/CLI
public:
Layers();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layers Constructor(GanttRow)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class > Layers Constructor : Layers Constructor(GanttRow)

aGanttRow

Glossary Item Box

constructor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGanttRow As GanttRow _
)
Visual Basic (Usage) Copy Code
Dim aGanttRow As GanttRow

Dim instance As New Layers(aGanttRow)
C#
public Layers(
   GanttRow aGanttRow
)
Managed Extensions for C++
public: Layers(
   GanttRow* aGanttRow
)
C++/CLI
public:
Layers(
   GanttRow^ aGanttRow
)

Parameters

aGanttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
Layers Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layers Class

Glossary Item Box

For a list of all members of this type, see Layers members.

Public Methods

 | Name | Description
Public Method | AddLayer | Adds a layer
Public Method | IndexOf | Finds index of a layer
Public Method | Invalidate | Redraw
Public Method | Remove | removes a layer by index
Top

See Also

Reference

Layers Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddLayer Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : AddLayer Method

Glossary Item Box

Adds a layer

Syntax

Visual Basic (Declaration)
Public Function AddLayer() As Layer
Visual Basic (Usage) Copy Code
Dim instance As Layers
Dim value As Layer

value = instance.AddLayer()
C#
public Layer AddLayer()
Managed Extensions for C++
public: Layer* AddLayer();
C++/CLI
public:
Layer^ AddLayer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : IndexOf Method

value

Glossary Item Box

Finds index of a layer

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Layers
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Invalidate Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : Invalidate Method

Glossary Item Box

Redraw

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As Layers

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : Remove Method

index

Glossary Item Box

removes a layer by index

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Layers
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
Layers Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Layers Class

Glossary Item Box

For a list of all members of this type, see Layers members.

Public Properties

 | Name | Description
Public Property | GanttRow | Owning GanttRow
Public Property | Item | Indexer
Top

See Also

Reference

Layers Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : GanttRow Property

Glossary Item Box

Owning GanttRow

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GanttRow As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As Layers
Dim value As GanttRow

value = instance.GanttRow
C#
public GanttRow GanttRow {get;}
Managed Extensions for C++
public: __property GanttRow* get_GanttRow();
C++/CLI
public:
property GanttRow^ GanttRow {
   GanttRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layers Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As Layer
Visual Basic (Usage) Copy Code
Dim instance As Layers
Dim Index As Integer
Dim value As Layer

value = instance.Item(Index)
C#
public Layer this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property Layer* get_Item   int Index
;
C++/CLI
public:
property Layer^ default [int] {
   Layer^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layers Class
Layers Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineOption Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : LineOption Class

Glossary Item Box

LineOption

Object Model

LineOption Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.LineOptionConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class LineOption
Visual Basic (Usage) Copy Code
Dim instance As LineOption
C#
[TypeConverterAttribute("PlexityHide.GTP.LineOptionConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class LineOption
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.LineOptionConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class LineOption
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.LineOptionConverter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class LineOption

Inheritance Hierarchy

System.Object
PlexityHide.GTP.LineOption

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LineOption Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
LineOption Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : LineOption Class

Glossary Item Box

The following tables list the members exposed by LineOption.

Public Constructors

 | Name | Description
Public Constructor | LineOption Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Color | Color of line
Public Property | Use | Use line at all?
Public Property | Width | Pixel width of line
Top

Public Methods

 | Name | Description
Public Method | Changed | Called internally whenever a change occures
Public Method | Clone | Clones the LineOption
Top

See Also

Reference

LineOption Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineOption Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : LineOption Constructor

Glossary Item Box

Overload List

Overload | Description
LineOption Constructor(CellLayout) | Contructor, used internally
LineOption Constructor() | Contructor, used internally

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineOption Constructor(CellLayout)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class > LineOption Constructor : LineOption Constructor(CellLayout)

aCellLayout

Glossary Item Box

Contructor, used internally

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aCellLayout As CellLayout _
)
Visual Basic (Usage) Copy Code
Dim aCellLayout As CellLayout

Dim instance As New LineOption(aCellLayout)
C#
public LineOption(
   CellLayout aCellLayout
)
Managed Extensions for C++
public: LineOption(
   CellLayout* aCellLayout
)
C++/CLI
public:
LineOption(
   CellLayout^ aCellLayout
)

Parameters

aCellLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
LineOption Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class > LineOption Constructor : LineOption Constructor()

Glossary Item Box

Contructor, used internally

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LineOption()
C#
public LineOption()
Managed Extensions for C++
public: LineOption();
C++/CLI
public:
LineOption();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
LineOption Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LineOption Class

Glossary Item Box

For a list of all members of this type, see LineOption members.

Public Methods

 | Name | Description
Public Method | Changed | Called internally whenever a change occures
Public Method | Clone | Clones the LineOption
Top

See Also

Reference

LineOption Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : Changed Method

Glossary Item Box

Called internally whenever a change occures

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As LineOption

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clone Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : Clone Method

Glossary Item Box

Clones the LineOption

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As LineOption
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
LineOption Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LineOption Class

Glossary Item Box

For a list of all members of this type, see LineOption members.

Public Properties

 | Name | Description
Public Property | Color | Color of line
Public Property | Use | Use line at all?
Public Property | Width | Pixel width of line
Top

See Also

Reference

LineOption Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Color Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : Color Property

Glossary Item Box

Color of line

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As LineOption
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}
Managed Extensions for C++
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
public:
property Color Color {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Use Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : Use Property

Glossary Item Box

Use line at all?

Syntax

Visual Basic (Declaration)
Public Property Use As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LineOption
Dim value As Boolean

instance.Use = value

value = instance.Use
C#
public bool Use {get; set;}
Managed Extensions for C++
public: __property bool get_Use();
public: __property void set_Use(
   bool value
);
C++/CLI
public:
property bool Use {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Width Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LineOption Class : Width Property

Glossary Item Box

Pixel width of line

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As LineOption
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
public:
property int Width {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LineOption Class
LineOption Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkActionEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkActionEventArgs Class

Glossary Item Box

CollisionDetect event args

Object Model

LinkActionEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class LinkActionEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LinkActionEventArgs
C#
public class LinkActionEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class LinkActionEventArgs : public System.EventArgs
C++/CLI
public ref class LinkActionEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.LinkActionEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LinkActionEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
LinkActionEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : LinkActionEventArgs Class

Glossary Item Box

The following tables list the members exposed by LinkActionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LinkActionEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | TimeItemLink | The time item link in question
Top

See Also

Reference

LinkActionEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkActionEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkActionEventArgs Class : LinkActionEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LinkActionEventArgs()
C#
public LinkActionEventArgs()
Managed Extensions for C++
public: LinkActionEventArgs();
C++/CLI
public:
LinkActionEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkActionEventArgs Class
LinkActionEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
LinkActionEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkActionEventArgs Class

Glossary Item Box

For a list of all members of this type, see LinkActionEventArgs members.

Public Fields

 | Name | Description
Public Field | TimeItemLink | The time item link in question
Top

See Also

Reference

LinkActionEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLink Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkActionEventArgs Class : TimeItemLink Field

Glossary Item Box

The time item link in question

Syntax

Visual Basic (Declaration)
Public TimeItemLink As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As LinkActionEventArgs
Dim value As TimeItemLink

value = instance.TimeItemLink

instance.TimeItemLink = value
C#
public TimeItemLink TimeItemLink
Managed Extensions for C++
public: TimeItemLink* TimeItemLink
C++/CLI
public:
TimeItemLink^ TimeItemLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkActionEventArgs Class
LinkActionEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkAndDSArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkAndDSArgs Class

Glossary Item Box

Arguments for time item data events

Object Model

LinkAndDSArgs Class

Syntax

Visual Basic (Declaration)
Public Class LinkAndDSArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
C#
public class LinkAndDSArgs : System.EventArgs
Managed Extensions for C++
public __gc class LinkAndDSArgs : public System.EventArgs
C++/CLI
public ref class LinkAndDSArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.LinkAndDSArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LinkAndDSArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
LinkAndDSArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : LinkAndDSArgs Class

Glossary Item Box

The following tables list the members exposed by LinkAndDSArgs.

Public Constructors

 | Name | Description
Public Constructor | LinkAndDSArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GoOnSetValue | In the OnBeforeLinkToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.
Public Field | Link | The time item in question for the current data operation
Public Field | PropertyDescriptorInDS | The column from the currency manager
Public Field | Value | The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource
Top

See Also

Reference

LinkAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkAndDSArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : LinkAndDSArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LinkAndDSArgs()
C#
public LinkAndDSArgs()
Managed Extensions for C++
public: LinkAndDSArgs();
C++/CLI
public:
LinkAndDSArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
LinkAndDSArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkAndDSArgs Class

Glossary Item Box

For a list of all members of this type, see LinkAndDSArgs members.

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GoOnSetValue | In the OnBeforeLinkToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.
Public Field | Link | The time item in question for the current data operation
Public Field | PropertyDescriptorInDS | The column from the currency manager
Public Field | Value | The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource
Top

See Also

Reference

LinkAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManagerListItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : CurrencyManagerListItem Field

Glossary Item Box

The row from the currency manager

Syntax

Visual Basic (Declaration)
Public CurrencyManagerListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
Dim value As Object

value = instance.CurrencyManagerListItem

instance.CurrencyManagerListItem = value
C#
public object CurrencyManagerListItem
Managed Extensions for C++
public: Object* CurrencyManagerListItem
C++/CLI
public:
Object^ CurrencyManagerListItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GoOnSetValue Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : GoOnSetValue Field

Glossary Item Box

In the OnBeforeLinkToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.

Syntax

Visual Basic (Declaration)
Public GoOnSetValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
Dim value As Boolean

value = instance.GoOnSetValue

instance.GoOnSetValue = value
C#
public bool GoOnSetValue
Managed Extensions for C++
public: bool GoOnSetValue
C++/CLI
public:
bool GoOnSetValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Link Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : Link Field

Glossary Item Box

The time item in question for the current data operation

Syntax

Visual Basic (Declaration)
Public Link As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
Dim value As TimeItemLink

value = instance.Link

instance.Link = value
C#
public TimeItemLink Link
Managed Extensions for C++
public: TimeItemLink* Link
C++/CLI
public:
TimeItemLink^ Link

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PropertyDescriptorInDS Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : PropertyDescriptorInDS Field

Glossary Item Box

The column from the currency manager

Syntax

Visual Basic (Declaration)
Public PropertyDescriptorInDS As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
Dim value As PropertyDescriptor

value = instance.PropertyDescriptorInDS

instance.PropertyDescriptorInDS = value
C#
public PropertyDescriptor PropertyDescriptorInDS
Managed Extensions for C++
public: PropertyDescriptor* PropertyDescriptorInDS
C++/CLI
public:
PropertyDescriptor^ PropertyDescriptorInDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Value Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkAndDSArgs Class : Value Field

Glossary Item Box

The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource

Syntax

Visual Basic (Declaration)
Public Value As Object
Visual Basic (Usage) Copy Code
Dim instance As LinkAndDSArgs
Dim value As Object

value = instance.Value

instance.Value = value
C#
public object Value
Managed Extensions for C++
public: Object* Value
C++/CLI
public:
Object^ Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkAndDSArgs Class
LinkAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkDataConnect Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkDataConnect Class

Glossary Item Box

LinkDataConnect coordinates info between a list of Links (a TimeItemLinks) and a dataSource

Object Model

LinkDataConnect ClassTimeItemLinks Class

Syntax

Visual Basic (Declaration)
Public Class LinkDataConnect
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
C#
public class LinkDataConnect
Managed Extensions for C++
public __gc class LinkDataConnect
C++/CLI
public ref class LinkDataConnect

Inheritance Hierarchy

System.Object
PlexityHide.GTP.LinkDataConnect

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LinkDataConnect Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
LinkDataConnect Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : LinkDataConnect Class

Glossary Item Box

The following tables list the members exposed by LinkDataConnect.

Public Properties

 | Name | Description
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource | This IListSource will be used for binding and for a particular TimeItemLinks and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding and for a particular TimeItemLinks and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since DataSource takes any object
Public Property | HouseKeeping | This property is true whenever the LinkDataConnect is adding/removing or changing time items to keep up with the DataSourceList
Public Property | TimeItemLinks |
Top

Public Methods

 | Name | Description
Public Method | ReBind | This method re-binds to the datasource. It clears all time item links in the TimeItemLinks and creates new time item links from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time item links, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the TimeItemLinks collection that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.
Top

Public Events

 | Name | Description
Public Event | OnBeforeDSToLink | Fires before transfer of data from dataset do Link, do conversions here
Public Event | OnBeforeLinkToDS | Fires before transfer of data from Link do dataset, do conversions here
Top

See Also

Reference

LinkDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
LinkDataConnect Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkDataConnect Class

Glossary Item Box

For a list of all members of this type, see LinkDataConnect members.

Public Methods

 | Name | Description
Public Method | ReBind | This method re-binds to the datasource. It clears all time item links in the TimeItemLinks and creates new time item links from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time item links, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the TimeItemLinks collection that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.
Top

See Also

Reference

LinkDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReBind Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : ReBind Method

Glossary Item Box

This method re-binds to the datasource. It clears all time item links in the TimeItemLinks and creates new time item links from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time item links, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the TimeItemLinks collection that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.

Syntax

Visual Basic (Declaration)
Public Sub ReBind()
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect

instance.ReBind()
C#
public void ReBind()
Managed Extensions for C++
public: void ReBind();
C++/CLI
public:
void ReBind();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
LinkDataConnect Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkDataConnect Class

Glossary Item Box

For a list of all members of this type, see LinkDataConnect members.

Public Properties

 | Name | Description
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource | This IListSource will be used for binding and for a particular TimeItemLinks and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding and for a particular TimeItemLinks and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since DataSource takes any object
Public Property | HouseKeeping | This property is true whenever the LinkDataConnect is adding/removing or changing time items to keep up with the DataSourceList
Public Property | TimeItemLinks |
Top

See Also

Reference

LinkDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManager Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : CurrencyManager Property

Glossary Item Box

Returns the current currency manager

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrencyManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As CurrencyManager

value = instance.CurrencyManager
C#
public CurrencyManager CurrencyManager {get;}
Managed Extensions for C++
public: __property CurrencyManager* get_CurrencyManager();
C++/CLI
public:
property CurrencyManager^ CurrencyManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : DataSource Property

Glossary Item Box

This IListSource will be used for binding and for a particular TimeItemLinks and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public object DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : DataSourceList Property

Glossary Item Box

This IList will be used for binding and for a particular TimeItemLinks and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since DataSource takes any object

Syntax

Visual Basic (Declaration)
Public Property DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As IList

instance.DataSourceList = value

value = instance.DataSourceList
C#
public IList DataSourceList {get; set;}
Managed Extensions for C++
public: __property IList* get_DataSourceList();
public: __property void set_DataSourceList(
   IList* value
);
C++/CLI
public:
property IList^ DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HouseKeeping Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : HouseKeeping Property

Glossary Item Box

This property is true whenever the LinkDataConnect is adding/removing or changing time items to keep up with the DataSourceList

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HouseKeeping As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As Boolean

value = instance.HouseKeeping
C#
public bool HouseKeeping {get;}
Managed Extensions for C++
public: __property bool get_HouseKeeping();
C++/CLI
public:
property bool HouseKeeping {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinks Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : TimeItemLinks Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property TimeItemLinks As TimeItemLinks
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim value As TimeItemLinks

instance.TimeItemLinks = value

value = instance.TimeItemLinks
C#
public TimeItemLinks TimeItemLinks {get; set;}
Managed Extensions for C++
public: __property TimeItemLinks* get_TimeItemLinks();
public: __property void set_TimeItemLinks(
   TimeItemLinks* value
);
C++/CLI
public:
property TimeItemLinks^ TimeItemLinks {
   TimeItemLinks^ get();
   void set (    TimeItemLinks^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
LinkDataConnect Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkDataConnect Class

Glossary Item Box

For a list of all members of this type, see LinkDataConnect members.

Public Events

 | Name | Description
Public Event | OnBeforeDSToLink | Fires before transfer of data from dataset do Link, do conversions here
Public Event | OnBeforeLinkToDS | Fires before transfer of data from Link do dataset, do conversions here
Top

See Also

Reference

LinkDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeDSToLink Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : OnBeforeDSToLink Event

Glossary Item Box

Fires before transfer of data from dataset do Link, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeDSToLink As LinkToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim handler As LinkToDSEventHandler

AddHandler instance.OnBeforeDSToLink, handler
C#
public event LinkToDSEventHandler OnBeforeDSToLink
Managed Extensions for C++
public: __event LinkToDSEventHandler* OnBeforeDSToLink
C++/CLI
public:
event LinkToDSEventHandler^ OnBeforeDSToLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeLinkToDS Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > LinkDataConnect Class : OnBeforeLinkToDS Event

Glossary Item Box

Fires before transfer of data from Link do dataset, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeLinkToDS As LinkToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As LinkDataConnect
Dim handler As LinkToDSEventHandler

AddHandler instance.OnBeforeLinkToDS, handler
C#
public event LinkToDSEventHandler OnBeforeLinkToDS
Managed Extensions for C++
public: __event LinkToDSEventHandler* OnBeforeLinkToDS
C++/CLI
public:
event LinkToDSEventHandler^ OnBeforeLinkToDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LinkDataConnect Class
LinkDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListWrapper Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ListWrapper Class

Glossary Item Box

The list wrapper is a helper class that allows for easy binding of IList implementing classes to IListSource requiring components

Object Model

ListWrapper Class

Syntax

Visual Basic (Declaration)
Public Class ListWrapper
Visual Basic (Usage) Copy Code
Dim instance As ListWrapper
C#
public class ListWrapper
Managed Extensions for C++
public __gc class ListWrapper
C++/CLI
public ref class ListWrapper

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ListWrapper

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ListWrapper Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ListWrapper Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : ListWrapper Class

Glossary Item Box

The following tables list the members exposed by ListWrapper.

Public Constructors

 | Name | Description
Public Constructor | ListWrapper Constructor | constructor, send in your IList
Top

Public Properties

 | Name | Description
Public Property | ContainsListCollection | Defined in IListSource, will always return false in this implementation
Top

Public Methods

 | Name | Description
Public Method | GetList | Defined in IListSource, will return the IList you created this object with.
Top

See Also

Reference

ListWrapper Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListWrapper Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ListWrapper Class : ListWrapper Constructor

aList

Glossary Item Box

constructor, send in your IList

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aList As IList _
)
Visual Basic (Usage) Copy Code
Dim aList As IList

Dim instance As New ListWrapper(aList)
C#
public ListWrapper(
   IList aList
)
Managed Extensions for C++
public: ListWrapper(
   IList* aList
)
C++/CLI
public:
ListWrapper(
   IList^ aList
)

Parameters

aList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ListWrapper Class
ListWrapper Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ListWrapper Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ListWrapper Class

Glossary Item Box

For a list of all members of this type, see ListWrapper members.

Public Methods

 | Name | Description
Public Method | GetList | Defined in IListSource, will return the IList you created this object with.
Top

See Also

Reference

ListWrapper Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetList Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ListWrapper Class : GetList Method

Glossary Item Box

Defined in IListSource, will return the IList you created this object with.

Syntax

Visual Basic (Declaration)
Public Function GetList() As IList
Visual Basic (Usage) Copy Code
Dim instance As ListWrapper
Dim value As IList

value = instance.GetList()
C#
public IList GetList()
Managed Extensions for C++
public: IList* GetList();
C++/CLI
public:
IList^ GetList();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ListWrapper Class
ListWrapper Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ListWrapper Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ListWrapper Class

Glossary Item Box

For a list of all members of this type, see ListWrapper members.

Public Properties

 | Name | Description
Public Property | ContainsListCollection | Defined in IListSource, will always return false in this implementation
Top

See Also

Reference

ListWrapper Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContainsListCollection Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ListWrapper Class : ContainsListCollection Property

Glossary Item Box

Defined in IListSource, will always return false in this implementation

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsListCollection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListWrapper
Dim value As Boolean

value = instance.ContainsListCollection
C#
public bool ContainsListCollection {get;}
Managed Extensions for C++
public: __property bool get_ContainsListCollection();
C++/CLI
public:
property bool ContainsListCollection {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ListWrapper Class
ListWrapper Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ModDateTimePicker Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModDateTimePicker Class

Glossary Item Box

ModDateTimePicker.

Object Model

ModDateTimePicker Class

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ModDateTimePicker
   Inherits System.Windows.Forms.DateTimePicker
Visual Basic (Usage) Copy Code
Dim instance As ModDateTimePicker
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ModDateTimePicker : System.Windows.Forms.DateTimePicker
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ModDateTimePicker : public System.Windows.Forms.DateTimePicker
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ModDateTimePicker : public System.Windows.Forms.DateTimePicker

Example

GridColumn Class

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.DateTimePicker
PlexityHide.GTP.ModDateTimePicker

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ModDateTimePicker Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ModDateTimePicker Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : ModDateTimePicker Class

Glossary Item Box

The following tables list the members exposed by ModDateTimePicker.

See Also

Reference

ModDateTimePicker Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ModTextBox Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModTextBox Class

Glossary Item Box

ModTextBox.

Object Model

ModTextBox Class

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ModTextBox
   Inherits System.Windows.Forms.TextBox
Visual Basic (Usage) Copy Code
Dim instance As ModTextBox
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ModTextBox : System.Windows.Forms.TextBox
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ModTextBox : public System.Windows.Forms.TextBox
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ModTextBox : public System.Windows.Forms.TextBox

Example

GridColumn Class

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.TextBox
PlexityHide.GTP.ModTextBox

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ModTextBox Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ModTextBox Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : ModTextBox Class

Glossary Item Box

The following tables list the members exposed by ModTextBox.

See Also

Reference

ModTextBox Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
MultiText Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : MultiText Class

Glossary Item Box

Holds the content of a grid cell of type SingleText.

Object Model

MultiText Class

Syntax

Visual Basic (Declaration)
Public Class MultiText
   Inherits ContentEntity
   Implements IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As MultiText
C#
public class MultiText : ContentEntity, IClipboardInteraction
Managed Extensions for C++
public __gc class MultiText : public ContentEntity, IClipboardInteraction
C++/CLI
public ref class MultiText : public ContentEntity, IClipboardInteraction

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.MultiText

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

MultiText Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
MultiText Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : MultiText Class

Glossary Item Box

The following tables list the members exposed by MultiText.

Public Constructors

 | Name | Description
Public Constructor | MultiText Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | EditBox | Gets the edit box.
static (Shared in Visual Basic) | EnterIsInputKey | If this property is TRUE (default=true) the enter key will handled as part of the input in the text, if false the enter key will end the current edit without adding the enter to the input
Public Property | Text | Gets and sets the text of the grid cell.
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

MultiText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
MultiText Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : MultiText Constructor

owner

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As Cell _
)
Visual Basic (Usage) Copy Code
Dim owner As Cell

Dim instance As New MultiText(owner)
C#
public MultiText(
   Cell owner
)
Managed Extensions for C++
public: MultiText(
   Cell* owner
)
C++/CLI
public:
MultiText(
   Cell^ owner
)

Parameters

owner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
MultiText Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : MultiText Class

Glossary Item Box

For a list of all members of this type, see MultiText members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

MultiText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As MultiText

instance.CopyToClipboard()
C#
public void CopyToClipboard()
Managed Extensions for C++
public: void CopyToClipboard();
C++/CLI
public:
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : PasteValueFromClipboard Method

Glossary Item Box

Implements the pasting of clipboard data

Syntax

Visual Basic (Declaration)
Public Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As MultiText

instance.PasteValueFromClipboard()
C#
public void PasteValueFromClipboard()
Managed Extensions for C++
public: void PasteValueFromClipboard();
C++/CLI
public:
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
MultiText Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : MultiText Class

Glossary Item Box

For a list of all members of this type, see MultiText members.

Public Properties

 | Name | Description
Public Property | EditBox | Gets the edit box.
static (Shared in Visual Basic) | EnterIsInputKey | If this property is TRUE (default=true) the enter key will handled as part of the input in the text, if false the enter key will end the current edit without adding the enter to the input
Public Property | Text | Gets and sets the text of the grid cell.
Top

See Also

Reference

MultiText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditBox Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : EditBox Property

Glossary Item Box

Gets the edit box.

Syntax

Visual Basic (Declaration)
Public Property EditBox As TextBox
Visual Basic (Usage) Copy Code
Dim instance As MultiText
Dim value As TextBox

instance.EditBox = value

value = instance.EditBox
C#
public TextBox EditBox {get; set;}
Managed Extensions for C++
public: __property TextBox* get_EditBox();
public: __property void set_EditBox(
   TextBox* value
);
C++/CLI
public:
property TextBox^ EditBox {
   TextBox^ get();
   void set (    TextBox^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EnterIsInputKey Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : EnterIsInputKey Property

Glossary Item Box

If this property is TRUE (default=true) the enter key will handled as part of the input in the text, if false the enter key will end the current edit without adding the enter to the input

Syntax

Visual Basic (Declaration)
Public Shared Property EnterIsInputKey As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

MultiText.EnterIsInputKey = value

value = MultiText.EnterIsInputKey
C#
public static bool EnterIsInputKey {get; set;}
Managed Extensions for C++
public: __property static bool get_EnterIsInputKey();
public: __property static void set_EnterIsInputKey(
   bool value
);
C++/CLI
public:
static property bool EnterIsInputKey {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > MultiText Class : Text Property

Glossary Item Box

Gets and sets the text of the grid cell.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As MultiText
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MultiText Class
MultiText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeDataConnect Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeDataConnect Class

Glossary Item Box

NodeDataConnect coordinates data between a gridnodelist and a datasource.

Object Model

NodeDataConnect ClassGridNodes ClassGridNode Class

Syntax

Visual Basic (Declaration)
Public Class NodeDataConnect
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
C#
public class NodeDataConnect
Managed Extensions for C++
public __gc class NodeDataConnect
C++/CLI
public ref class NodeDataConnect

Inheritance Hierarchy

System.Object
PlexityHide.GTP.NodeDataConnect

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

NodeDataConnect Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
NodeDataConnect Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : NodeDataConnect Class

Glossary Item Box

The following tables list the members exposed by NodeDataConnect.

Public Constructors

 | Name | Description
Public Constructor | NodeDataConnect Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnToFieldMapperHash | Set to columnToFieldMapperHashUse to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored
Public Property | ColumnToFieldMapperHashUse | Set to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource |
Public Property | GridNodes |
Top

Public Methods

 | Name | Description
Public Method | GetColumnFromPropDesc | Looks up a grid column from a property descriptor in a data sources If the ColumnToFieldMapperHashUse is true the contents of ColumnToFieldMapperHash will be used
Public Method | GetList | Returns the IList of the set DataSource
Public Method | GetPropDescFromColumn | Looks up the property descriptor from a Column
Top

Public Events

 | Name | Description
Public Event | OnBeforeCellToDS | Fires before transfer of data from cell do dataset, do conversions here
Public Event | OnBeforeDSToCell | Fires before transfer of data from dataset do cell, do conversions here
Top

See Also

Reference

NodeDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeDataConnect Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : NodeDataConnect Constructor

aGridStructure
aGridNodes

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGridStructure As GridStructure, _
   ByVal aGridNodes As GridNodes _
)
Visual Basic (Usage) Copy Code
Dim aGridStructure As GridStructure
Dim aGridNodes As GridNodes

Dim instance As New NodeDataConnect(aGridStructure, aGridNodes)
C#
public NodeDataConnect(
   GridStructure aGridStructure,
   GridNodes aGridNodes
)
Managed Extensions for C++
public: NodeDataConnect(
   GridStructure* aGridStructure,
   GridNodes* aGridNodes
)
C++/CLI
public:
NodeDataConnect(
   GridStructure^ aGridStructure,
   GridNodes^ aGridNodes
)

Parameters

aGridStructure
aGridNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
NodeDataConnect Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeDataConnect Class

Glossary Item Box

For a list of all members of this type, see NodeDataConnect members.

Public Methods

 | Name | Description
Public Method | GetColumnFromPropDesc | Looks up a grid column from a property descriptor in a data sources If the ColumnToFieldMapperHashUse is true the contents of ColumnToFieldMapperHash will be used
Public Method | GetList | Returns the IList of the set DataSource
Public Method | GetPropDescFromColumn | Looks up the property descriptor from a Column
Top

See Also

Reference

NodeDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetColumnFromPropDesc Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : GetColumnFromPropDesc Method

aPropDesc

Glossary Item Box

Looks up a grid column from a property descriptor in a data sources If the ColumnToFieldMapperHashUse is true the contents of ColumnToFieldMapperHash will be used

Syntax

Visual Basic (Declaration)
Public Function GetColumnFromPropDesc( _
   ByVal aPropDesc As PropertyDescriptor _
) As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim aPropDesc As PropertyDescriptor
Dim value As GridColumn

value = instance.GetColumnFromPropDesc(aPropDesc)
C#
public GridColumn GetColumnFromPropDesc(
   PropertyDescriptor aPropDesc
)
Managed Extensions for C++
public: GridColumn* GetColumnFromPropDesc(
   PropertyDescriptor* aPropDesc
)
C++/CLI
public:
GridColumn^ GetColumnFromPropDesc(
   PropertyDescriptor^ aPropDesc
)

Parameters

aPropDesc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetList Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : GetList Method

Glossary Item Box

Returns the IList of the set DataSource

Syntax

Visual Basic (Declaration)
Public Function GetList() As IList
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As IList

value = instance.GetList()
C#
public IList GetList()
Managed Extensions for C++
public: IList* GetList();
C++/CLI
public:
IList^ GetList();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetPropDescFromColumn Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : GetPropDescFromColumn Method

aColumn

Glossary Item Box

Looks up the property descriptor from a Column

Syntax

Visual Basic (Declaration)
Public Function GetPropDescFromColumn( _
   ByVal aColumn As GridColumn _
) As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim aColumn As GridColumn
Dim value As PropertyDescriptor

value = instance.GetPropDescFromColumn(aColumn)
C#
public PropertyDescriptor GetPropDescFromColumn(
   GridColumn aColumn
)
Managed Extensions for C++
public: PropertyDescriptor* GetPropDescFromColumn(
   GridColumn* aColumn
)
C++/CLI
public:
PropertyDescriptor^ GetPropDescFromColumn(
   GridColumn^ aColumn
)

Parameters

aColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
NodeDataConnect Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeDataConnect Class

Glossary Item Box

For a list of all members of this type, see NodeDataConnect members.

Public Properties

 | Name | Description
Public Property | ColumnToFieldMapperHash | Set to columnToFieldMapperHashUse to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored
Public Property | ColumnToFieldMapperHashUse | Set to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource |
Public Property | GridNodes |
Top

See Also

Reference

NodeDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnToFieldMapperHash Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : ColumnToFieldMapperHash Property

Glossary Item Box

Set to columnToFieldMapperHashUse to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnToFieldMapperHash As StringDictionary
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As StringDictionary

value = instance.ColumnToFieldMapperHash
C#
public StringDictionary ColumnToFieldMapperHash {get;}
Managed Extensions for C++
public: __property StringDictionary* get_ColumnToFieldMapperHash();
C++/CLI
public:
property StringDictionary^ ColumnToFieldMapperHash {
   StringDictionary^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnToFieldMapperHashUse Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : ColumnToFieldMapperHashUse Property

Glossary Item Box

Set to true if you want to provide your own ColumnToFieldMapperHash different from the one specified in GridColumn.DataSourceColumn. This is likely what you want to do if you have different definitions on the dataviews on subnodes than the definition on the rootnodes. Add mapping with ColumnToFieldMapperHash.Add("GridColumn.DataSourceColumn name","Name of field in dataview") Note: if ColumnToFieldMapperHashUse=false the ColumnToFieldMapperHash is ignored

Syntax

Visual Basic (Declaration)
Public Property ColumnToFieldMapperHashUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As Boolean

instance.ColumnToFieldMapperHashUse = value

value = instance.ColumnToFieldMapperHashUse
C#
public bool ColumnToFieldMapperHashUse {get; set;}
Managed Extensions for C++
public: __property bool get_ColumnToFieldMapperHashUse();
public: __property void set_ColumnToFieldMapperHashUse(
   bool value
);
C++/CLI
public:
property bool ColumnToFieldMapperHashUse {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManager Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : CurrencyManager Property

Glossary Item Box

Returns the current currency manager

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrencyManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As CurrencyManager

value = instance.CurrencyManager
C#
public CurrencyManager CurrencyManager {get;}
Managed Extensions for C++
public: __property CurrencyManager* get_CurrencyManager();
C++/CLI
public:
property CurrencyManager^ CurrencyManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : DataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}
Managed Extensions for C++
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNodes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : GridNodes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property GridNodes As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim value As GridNodes

instance.GridNodes = value

value = instance.GridNodes
C#
public GridNodes GridNodes {get; set;}
Managed Extensions for C++
public: __property GridNodes* get_GridNodes();
public: __property void set_GridNodes(
   GridNodes* value
);
C++/CLI
public:
property GridNodes^ GridNodes {
   GridNodes^ get();
   void set (    GridNodes^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
NodeDataConnect Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeDataConnect Class

Glossary Item Box

For a list of all members of this type, see NodeDataConnect members.

Public Events

 | Name | Description
Public Event | OnBeforeCellToDS | Fires before transfer of data from cell do dataset, do conversions here
Public Event | OnBeforeDSToCell | Fires before transfer of data from dataset do cell, do conversions here
Top

See Also

Reference

NodeDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeCellToDS Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : OnBeforeCellToDS Event

Glossary Item Box

Fires before transfer of data from cell do dataset, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeCellToDS As CellToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim handler As CellToDSEventHandler

AddHandler instance.OnBeforeCellToDS, handler
C#
public event CellToDSEventHandler OnBeforeCellToDS
Managed Extensions for C++
public: __event CellToDSEventHandler* OnBeforeCellToDS
C++/CLI
public:
event CellToDSEventHandler^ OnBeforeCellToDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeDSToCell Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeDataConnect Class : OnBeforeDSToCell Event

Glossary Item Box

Fires before transfer of data from dataset do cell, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeDSToCell As CellToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As NodeDataConnect
Dim handler As CellToDSEventHandler

AddHandler instance.OnBeforeDSToCell, handler
C#
public event CellToDSEventHandler OnBeforeDSToCell
Managed Extensions for C++
public: __event CellToDSEventHandler* OnBeforeDSToCell
C++/CLI
public:
event CellToDSEventHandler^ OnBeforeDSToCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeDataConnect Class
NodeDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeEventArgs Class

Glossary Item Box

Arguments for node events

Object Model

NodeEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class NodeEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As NodeEventArgs
C#
public class NodeEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class NodeEventArgs : public System.EventArgs
C++/CLI
public ref class NodeEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.NodeEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

NodeEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
NodeEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : NodeEventArgs Class

Glossary Item Box

The following tables list the members exposed by NodeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | NodeEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | EventKind | What kind of action triggered the event
Public Field | GridNode | The GridNode handled
Public Field | Index | The index of the conceared Gridnode
Top

See Also

Reference

NodeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeEventArgs Class : NodeEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NodeEventArgs()
C#
public NodeEventArgs()
Managed Extensions for C++
public: NodeEventArgs();
C++/CLI
public:
NodeEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeEventArgs Class
NodeEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
NodeEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeEventArgs Class

Glossary Item Box

For a list of all members of this type, see NodeEventArgs members.

Public Fields

 | Name | Description
Public Field | EventKind | What kind of action triggered the event
Public Field | GridNode | The GridNode handled
Public Field | Index | The index of the conceared Gridnode
Top

See Also

Reference

NodeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EventKind Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeEventArgs Class : EventKind Field

Glossary Item Box

What kind of action triggered the event

Syntax

Visual Basic (Declaration)
Public EventKind As CollectionEventKind
Visual Basic (Usage) Copy Code
Dim instance As NodeEventArgs
Dim value As CollectionEventKind

value = instance.EventKind

instance.EventKind = value
C#
public CollectionEventKind EventKind
Managed Extensions for C++
public: CollectionEventKind EventKind
C++/CLI
public:
CollectionEventKind EventKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeEventArgs Class
NodeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeEventArgs Class : GridNode Field

Glossary Item Box

The GridNode handled

Syntax

Visual Basic (Declaration)
Public GridNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As NodeEventArgs
Dim value As GridNode

value = instance.GridNode

instance.GridNode = value
C#
public GridNode GridNode
Managed Extensions for C++
public: GridNode* GridNode
C++/CLI
public:
GridNode^ GridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeEventArgs Class
NodeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NodeEventArgs Class : Index Field

Glossary Item Box

The index of the conceared Gridnode

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As NodeEventArgs
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NodeEventArgs Class
NodeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NonLinearTime Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : NonLinearTime Class

Glossary Item Box

Holds a non-linear time line, the non-linearity is limited to hiding of specific hours during all days and/or hiding of specific days during every week.

Object Model

NonLinearTime Class

Syntax

Visual Basic (Declaration)
Public Class NonLinearTime
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
C#
public class NonLinearTime
Managed Extensions for C++
public __gc class NonLinearTime
C++/CLI
public ref class NonLinearTime

Inheritance Hierarchy

System.Object
PlexityHide.GTP.NonLinearTime

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

NonLinearTime Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
NonLinearTime Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : NonLinearTime Class

Glossary Item Box

The following tables list the members exposed by NonLinearTime.

Public Constructors

 | Name | Description
Public Constructor | NonLinearTime Constructor | Constructor NonLinearTime.
Top

Public Properties

 | Name | Description
Public Property | DayStart | Returns the first visible hour in the day.
Public Property | LowerBound | Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.
Public Property | MidWeek | Returns the visible day which is closest to being the middle of the visible week.
Public Property | NoOfVisibleDaysInWeek | Returns the number of visible days of the week.
Public Property | Noon | Returns the visible hour which is closest to noon.
Public Property | StartOfWeek | Sets the day of the week which starts the week. Default day is Monday.
Public Property | UpperBound | Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.
Public Property | WeekSpan | Returns the number of days until the last day of the week.
Public Property | VisibleDays | Returns an array indicating all the visible days
Public Property | VisibleHours | Returns an array indicating all the visible hours
Public Property | VisibleWeekStartDay | Returns the first visible day in the week.
Top

Public Methods

 | Name | Description
Public Method | CalculateResolution | Returns a time resolution for a specified scale factor a minimum marker distance.
Public Method | Exists | Checks whether the specified time exists in the non-linear time line.
Public Method | HideDays | Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.
Public Method | HideHours | Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.
Public Method | ShowDays | Indicates what days to show, takes an array of days.
Public Method | ShowHours | Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.
Public Method | TicksPerScaleMarker | Indicates how many visible ticks exist between two markers for a given time resolution
Public Method | TrueTime | Calculates the true time based on a known time and the number of visible ticks.
Public Method | WeekNumber | Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.
Public Method | VisibleTime | Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.
Public Method | VisibleWeekStart |
Top

See Also

Reference

NonLinearTime Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NonLinearTime Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : NonLinearTime Constructor

Glossary Item Box

Constructor NonLinearTime.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NonLinearTime()
C#
public NonLinearTime()
Managed Extensions for C++
public: NonLinearTime();
C++/CLI
public:
NonLinearTime();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
NonLinearTime Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NonLinearTime Class

Glossary Item Box

For a list of all members of this type, see NonLinearTime members.

Public Methods

 | Name | Description
Public Method | CalculateResolution | Returns a time resolution for a specified scale factor a minimum marker distance.
Public Method | Exists | Checks whether the specified time exists in the non-linear time line.
Public Method | HideDays | Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.
Public Method | HideHours | Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.
Public Method | ShowDays | Indicates what days to show, takes an array of days.
Public Method | ShowHours | Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.
Public Method | TicksPerScaleMarker | Indicates how many visible ticks exist between two markers for a given time resolution
Public Method | TrueTime | Calculates the true time based on a known time and the number of visible ticks.
Public Method | WeekNumber | Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.
Public Method | VisibleTime | Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.
Public Method | VisibleWeekStart |
Top

See Also

Reference

NonLinearTime Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalculateResolution Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : CalculateResolution Method

scaleFactor
minMarkerDistance

Glossary Item Box

Returns a time resolution for a specified scale factor a minimum marker distance.

Syntax

Visual Basic (Declaration)
Public Function CalculateResolution( _
   ByVal scaleFactor As Double, _
   ByVal minMarkerDistance As Integer _
) As NonLinearTime.TimeResolution
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim scaleFactor As Double
Dim minMarkerDistance As Integer
Dim value As NonLinearTime.TimeResolution

value = instance.CalculateResolution(scaleFactor, minMarkerDistance)
C#
public NonLinearTime.TimeResolution CalculateResolution(
   double scaleFactor,
   int minMarkerDistance
)
Managed Extensions for C++
public: NonLinearTime.TimeResolution CalculateResolution(
   double scaleFactor,
   int minMarkerDistance
)
C++/CLI
public:
NonLinearTime.TimeResolution CalculateResolution(
   double scaleFactor,
   int minMarkerDistance
)

Parameters

scaleFactor
minMarkerDistance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Exists Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : Exists Method

time

Glossary Item Box

Checks whether the specified time exists in the non-linear time line.

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal time As Date _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim time As Date
Dim value As Boolean

value = instance.Exists(time)
C#
public bool Exists(
   DateTime time
)
Managed Extensions for C++
public: bool Exists(
   DateTime time
)
C++/CLI
public:
bool Exists(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HideDays Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : HideDays Method

daysToHide

Glossary Item Box

Indicates what days to hide, takes an array of days. If all days are hidden, Sunday is set visible.

Syntax

Visual Basic (Declaration)
Public Function HideDays( _
   ByVal daysToHide() As DayOfWeek _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim daysToHide() As DayOfWeek
Dim value As Boolean

value = instance.HideDays(daysToHide)
C#
public bool HideDays(
   DayOfWeek[] daysToHide
)
Managed Extensions for C++
public: bool HideDays(
   DayOfWeek[]* daysToHide
)
C++/CLI
public:
bool HideDays(
   array<DayOfWeek>^ daysToHide
)

Parameters

daysToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HideHours Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : HideHours Method

hoursToHide

Glossary Item Box

Indicates what hours to hide, takes an array of hour indices, ranging from 0 to 23. If all hours are hidden 12-1 pm is set visible.

Syntax

Visual Basic (Declaration)
Public Function HideHours( _
   ByVal hoursToHide() As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim hoursToHide() As Integer
Dim value As Boolean

value = instance.HideHours(hoursToHide)
C#
public bool HideHours(
   int[] hoursToHide
)
Managed Extensions for C++
public: bool HideHours(
   int[]* hoursToHide
)
C++/CLI
public:
bool HideHours(
   array<int>^ hoursToHide
)

Parameters

hoursToHide

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowDays Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : ShowDays Method

daysToShow

Glossary Item Box

Indicates what days to show, takes an array of days.

Syntax

Visual Basic (Declaration)
Public Sub ShowDays( _
   ByVal daysToShow() As DayOfWeek _
)
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim daysToShow() As DayOfWeek

instance.ShowDays(daysToShow)
C#
public void ShowDays(
   DayOfWeek[] daysToShow
)
Managed Extensions for C++
public: void ShowDays(
   DayOfWeek[]* daysToShow
)
C++/CLI
public:
void ShowDays(
   array<DayOfWeek>^ daysToShow
)

Parameters

daysToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShowHours Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : ShowHours Method

hoursToShow

Glossary Item Box

Indicates what hours to show, takes an array of hour indices, ranging from 0 to 23.

Syntax

Visual Basic (Declaration)
Public Sub ShowHours( _
   ByVal hoursToShow() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim hoursToShow() As Integer

instance.ShowHours(hoursToShow)
C#
public void ShowHours(
   int[] hoursToShow
)
Managed Extensions for C++
public: void ShowHours(
   int[]* hoursToShow
)
C++/CLI
public:
void ShowHours(
   array<int>^ hoursToShow
)

Parameters

hoursToShow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TicksPerScaleMarker Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : TicksPerScaleMarker Method

i

Glossary Item Box

Indicates how many visible ticks exist between two markers for a given time resolution

Syntax

Visual Basic (Declaration)
Public Function TicksPerScaleMarker( _
   ByVal i As NonLinearTime.TimeResolution _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim i As NonLinearTime.TimeResolution
Dim value As Long

value = instance.TicksPerScaleMarker(i)
C#
public long TicksPerScaleMarker(
   NonLinearTime.TimeResolution i
)
Managed Extensions for C++
public: long TicksPerScaleMarker(
   NonLinearTime.TimeResolution i
)
C++/CLI
public:
int64 TicksPerScaleMarker(
   NonLinearTime.TimeResolution i
)

Parameters

i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TrueTime Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : TrueTime Method

startTime
visibleTicks

Glossary Item Box

Calculates the true time based on a known time and the number of visible ticks.

Syntax

Visual Basic (Declaration)
Public Function TrueTime( _
   ByVal startTime As Date, _
   ByVal visibleTicks As Long _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim startTime As Date
Dim visibleTicks As Long
Dim value As Date

value = instance.TrueTime(startTime, visibleTicks)
C#
public DateTime TrueTime(
   DateTime startTime,
   long visibleTicks
)
Managed Extensions for C++
public: DateTime TrueTime(
   DateTime startTime,
   long visibleTicks
)
C++/CLI
public:
DateTime TrueTime(
   DateTime startTime,
   int64 visibleTicks
)

Parameters

startTime
visibleTicks

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
WeekNumber Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : WeekNumber Method

time

Glossary Item Box

Returns the week number for a given date. The week number is based on weeks starting with a Monday. If week start is set to Sunday, this Sunday will belong to the coming week.

Syntax

Visual Basic (Declaration)
Public Function WeekNumber( _
   ByVal time As Date _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim time As Date
Dim value As Integer

value = instance.WeekNumber(time)
C#
public int WeekNumber(
   DateTime time
)
Managed Extensions for C++
public: int WeekNumber(
   DateTime time
)
C++/CLI
public:
int WeekNumber(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleTime Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : VisibleTime Method

baseTime
time

Glossary Item Box

Calculates the number of visible ticks (100 ns) between two time instances, baseTime and time.

Syntax

Visual Basic (Declaration)
Public Function VisibleTime( _
   ByVal baseTime As Date, _
   ByVal time As Date _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim baseTime As Date
Dim time As Date
Dim value As Long

value = instance.VisibleTime(baseTime, time)
C#
public long VisibleTime(
   DateTime baseTime,
   DateTime time
)
Managed Extensions for C++
public: long VisibleTime(
   DateTime baseTime,
   DateTime time
)
C++/CLI
public:
int64 VisibleTime(
   DateTime baseTime,
   DateTime time
)

Parameters

baseTime
time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleWeekStart Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : VisibleWeekStart Method

time

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function VisibleWeekStart( _
   ByVal time As Date _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim time As Date
Dim value As Date

value = instance.VisibleWeekStart(time)
C#
public DateTime VisibleWeekStart(
   DateTime time
)
Managed Extensions for C++
public: DateTime VisibleWeekStart(
   DateTime time
)
C++/CLI
public:
DateTime VisibleWeekStart(
   DateTime time
)

Parameters

time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
NonLinearTime Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NonLinearTime Class

Glossary Item Box

For a list of all members of this type, see NonLinearTime members.

Public Properties

 | Name | Description
Public Property | DayStart | Returns the first visible hour in the day.
Public Property | LowerBound | Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.
Public Property | MidWeek | Returns the visible day which is closest to being the middle of the visible week.
Public Property | NoOfVisibleDaysInWeek | Returns the number of visible days of the week.
Public Property | Noon | Returns the visible hour which is closest to noon.
Public Property | StartOfWeek | Sets the day of the week which starts the week. Default day is Monday.
Public Property | UpperBound | Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.
Public Property | WeekSpan | Returns the number of days until the last day of the week.
Public Property | VisibleDays | Returns an array indicating all the visible days
Public Property | VisibleHours | Returns an array indicating all the visible hours
Public Property | VisibleWeekStartDay | Returns the first visible day in the week.
Top

See Also

Reference

NonLinearTime Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DayStart Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : DayStart Property

Glossary Item Box

Returns the first visible hour in the day.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DayStart As Integer
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Integer

value = instance.DayStart
C#
public int DayStart {get;}
Managed Extensions for C++
public: __property int get_DayStart();
C++/CLI
public:
property int DayStart {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LowerBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : LowerBound Property

Glossary Item Box

Sets and gets the lower bound on the non-linear time scale. The lower bound can not be lower than January 1st, 1000.

Syntax

Visual Basic (Declaration)
Public Property LowerBound As Date
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Date

instance.LowerBound = value

value = instance.LowerBound
C#
public DateTime LowerBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_LowerBound();
public: __property void set_LowerBound(
   DateTime value
);
C++/CLI
public:
property DateTime LowerBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MidWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : MidWeek Property

Glossary Item Box

Returns the visible day which is closest to being the middle of the visible week.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MidWeek As DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As DayOfWeek

value = instance.MidWeek
C#
public DayOfWeek MidWeek {get;}
Managed Extensions for C++
public: __property DayOfWeek get_MidWeek();
C++/CLI
public:
property DayOfWeek MidWeek {
   DayOfWeek get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NoOfVisibleDaysInWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : NoOfVisibleDaysInWeek Property

Glossary Item Box

Returns the number of visible days of the week.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoOfVisibleDaysInWeek As Integer
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Integer

value = instance.NoOfVisibleDaysInWeek
C#
public int NoOfVisibleDaysInWeek {get;}
Managed Extensions for C++
public: __property int get_NoOfVisibleDaysInWeek();
C++/CLI
public:
property int NoOfVisibleDaysInWeek {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Noon Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : Noon Property

Glossary Item Box

Returns the visible hour which is closest to noon.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Noon As Integer
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Integer

value = instance.Noon
C#
public int Noon {get;}
Managed Extensions for C++
public: __property int get_Noon();
C++/CLI
public:
property int Noon {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartOfWeek Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : StartOfWeek Property

Glossary Item Box

Sets the day of the week which starts the week. Default day is Monday.

Syntax

Visual Basic (Declaration)
Public Property StartOfWeek As DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As DayOfWeek

instance.StartOfWeek = value

value = instance.StartOfWeek
C#
public DayOfWeek StartOfWeek {get; set;}
Managed Extensions for C++
public: __property DayOfWeek get_StartOfWeek();
public: __property void set_StartOfWeek(
   DayOfWeek value
);
C++/CLI
public:
property DayOfWeek StartOfWeek {
   DayOfWeek get();
   void set (    DayOfWeek value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UpperBound Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : UpperBound Property

Glossary Item Box

Sets and gets the upper bound on the non linear time scale. The upper bound can not be higher than January 1st, 8000.

Syntax

Visual Basic (Declaration)
Public Property UpperBound As Date
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Date

instance.UpperBound = value

value = instance.UpperBound
C#
public DateTime UpperBound {get; set;}
Managed Extensions for C++
public: __property DateTime get_UpperBound();
public: __property void set_UpperBound(
   DateTime value
);
C++/CLI
public:
property DateTime UpperBound {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
WeekSpan Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : WeekSpan Property

Glossary Item Box

Returns the number of days until the last day of the week.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WeekSpan As Integer
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As Integer

value = instance.WeekSpan
C#
public int WeekSpan {get;}
Managed Extensions for C++
public: __property int get_WeekSpan();
C++/CLI
public:
property int WeekSpan {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleDays Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : VisibleDays Property

Glossary Item Box

Returns an array indicating all the visible days

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleDays As DayOfWeek()
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value() As DayOfWeek

value = instance.VisibleDays
C#
public DayOfWeek[] VisibleDays {get;}
Managed Extensions for C++
public: __property DayOfWeek[]* get_VisibleDays();
C++/CLI
public:
property array<DayOfWeek>^ VisibleDays {
   array<DayOfWeek>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleHours Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : VisibleHours Property

Glossary Item Box

Returns an array indicating all the visible hours

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleHours As Integer()
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value() As Integer

value = instance.VisibleHours
C#
public int[] VisibleHours {get;}
Managed Extensions for C++
public: __property int[]* get_VisibleHours();
C++/CLI
public:
property array<int>^ VisibleHours {
   array<int>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VisibleWeekStartDay Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > NonLinearTime Class : VisibleWeekStartDay Property

Glossary Item Box

Returns the first visible day in the week.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleWeekStartDay As DayOfWeek
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime
Dim value As DayOfWeek

value = instance.VisibleWeekStartDay
C#
public DayOfWeek VisibleWeekStartDay {get;}
Managed Extensions for C++
public: __property DayOfWeek get_VisibleWeekStartDay();
C++/CLI
public:
property DayOfWeek VisibleWeekStartDay {
   DayOfWeek get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

NonLinearTime Class
NonLinearTime Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OffscreenDraw Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDraw Class

Glossary Item Box

OffscreenDraw is base class for Grid DateScaler and TimeArea

Object Model

OffscreenDraw Class

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public MustInherit Class OffscreenDraw
   Inherits System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public abstract class OffscreenDraw : System.Windows.Forms.Control
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc abstract class OffscreenDraw : public System.Windows.Forms.Control
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class OffscreenDraw abstract : public System.Windows.Forms.Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PlexityHide.GTP.OffscreenDraw
PlexityHide.GTP.DateScaler
PlexityHide.GTP.Grid
PlexityHide.GTP.TimeAreaOffscreenDraw

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

OffscreenDraw Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
OffscreenDraw Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDraw Class

Glossary Item Box

The following tables list the members exposed by OffscreenDraw.

Public Properties

 | Name | Description
Public Property | BackgroundImage | Overridden. Since the components completly cover the drawing area the background image is not supported. Use the OnOffscreenPaintBackground event instead.
Public Property | Bitmap | Access to the last drawn bitmap, read only.
Public Property | CalcBottom | Used internally
Public Property | CalcHeight | Used internally
Public Property | CalcLeft | Used internally
Public Property | CalcRect | The effective rectangle used for drawing, takes printing into account
Public Property | CalcRight | Used internally
Public Property | CalcTop | Used internally
Public Property | CalcWidth | Used internally
Public Property | Cursor | Overridden. Overriden to send the OnPreCursorChangeEvent
Public Property | DrawForeground | Set to true to draw transparent stuff in the foreground
Public Property | FlipView | FlipView. The Schedule is a FlipView Gantt.
Public Property | Graphics | Access to the Graphics object that is used for drawing
Public Property | IsPrinting | Returns true if printing
Public Property | PrintRect | The rect that the print should fit within
Top

Public Methods

 | Name | Description
Public Method | DrawToGraphic | Draws content to the supplied Graphics object, usefull to produce images etc
Public Method | EnterLogicalDrawingState | Normally the drawing is performed towards an offscreen bitmap, this call stops all such drawing. This is used to produce large prints and large Web-gantt charts.
Public Method | ExitLogicalDrawingState | Ends the EnterLogicalDrawingState.
Public Method | PrintEnd | Done printing, clean up
Public Method | PrintInit | About to start print, reset page counter
Public Method | PrintPage | Print page and step page counter
Public Method | Refresh | Overridden. Overidden from Control.Refresh(). Here we handle the special cases when the Control is not visible, but need to be drawn anyway.
Top

Public Events

 | Name | Description
Public Event | OnAfterDraw | Fired after draw. This was introduced to handle a specific problem: The Offscreen holds an internal variabel to avoid invalidating while currently drawing (optimization). However there are cases when one needs to invalidate in the draw loop; like the implementation of MakeSureVisible that forces refresh operations to find a setting where the choosen object is actually rendered and the Setting SelectNewDataBoundRows that uses the MakeSureVisible call.
Public Event | OnOffscreenPaintBackground | Fired when it is time to draw the background
Public Event | OnOffscreenPaintForeground | Fired when it is time to draw the foreground
Public Event | OnPreCursorChangeEvent | Fired when the control for some reason is about to set the cursor...
Public Event | OnUnhandledException | Fired when an unhandled exception occures
Top

See Also

Reference

OffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
OffscreenDraw Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see OffscreenDraw members.

Public Methods

 | Name | Description
Public Method | DrawToGraphic | Draws content to the supplied Graphics object, usefull to produce images etc
Public Method | EnterLogicalDrawingState | Normally the drawing is performed towards an offscreen bitmap, this call stops all such drawing. This is used to produce large prints and large Web-gantt charts.
Public Method | ExitLogicalDrawingState | Ends the EnterLogicalDrawingState.
Public Method | PrintEnd | Done printing, clean up
Public Method | PrintInit | About to start print, reset page counter
Public Method | PrintPage | Print page and step page counter
Public Method | Refresh | Overridden. Overidden from Control.Refresh(). Here we handle the special cases when the Control is not visible, but need to be drawn anyway.
Top

See Also

Reference

OffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawToGraphic Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : DrawToGraphic Method

g

Glossary Item Box

Draws content to the supplied Graphics object, usefull to produce images etc

Syntax

Visual Basic (Declaration)
Public Sub DrawToGraphic( _
   ByVal g As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim g As Graphics

instance.DrawToGraphic(g)
C#
public void DrawToGraphic(
   Graphics g
)
Managed Extensions for C++
public: void DrawToGraphic(
   Graphics* g
)
C++/CLI
public:
void DrawToGraphic(
   Graphics^ g
)

Parameters

g

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EnterLogicalDrawingState Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : EnterLogicalDrawingState Method

Glossary Item Box

Normally the drawing is performed towards an offscreen bitmap, this call stops all such drawing. This is used to produce large prints and large Web-gantt charts.

Syntax

Visual Basic (Declaration)
Public Sub EnterLogicalDrawingState()
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw

instance.EnterLogicalDrawingState()
C#
public void EnterLogicalDrawingState()
Managed Extensions for C++
public: void EnterLogicalDrawingState();
C++/CLI
public:
void EnterLogicalDrawingState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ExitLogicalDrawingState Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : ExitLogicalDrawingState Method

Glossary Item Box

Ends the EnterLogicalDrawingState.

Syntax

Visual Basic (Declaration)
Public Sub ExitLogicalDrawingState()
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw

instance.ExitLogicalDrawingState()
C#
public void ExitLogicalDrawingState()
Managed Extensions for C++
public: void ExitLogicalDrawingState();
C++/CLI
public:
void ExitLogicalDrawingState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintEnd Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : PrintEnd Method

Glossary Item Box

Done printing, clean up

Syntax

Visual Basic (Declaration)
Public Overridable Sub PrintEnd()
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw

instance.PrintEnd()
C#
public virtual void PrintEnd()
Managed Extensions for C++
public: virtual void PrintEnd();
C++/CLI
public:
virtual void PrintEnd();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintInit Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : PrintInit Method

Glossary Item Box

About to start print, reset page counter

Syntax

Visual Basic (Declaration)
Public Overridable Sub PrintInit()
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw

instance.PrintInit()
C#
public virtual void PrintInit()
Managed Extensions for C++
public: virtual void PrintInit();
C++/CLI
public:
virtual void PrintInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : PrintPage Method

G
Margins

Glossary Item Box

Print page and step page counter

Syntax

Visual Basic (Declaration)
Public Overridable Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim G As Graphics
Dim Margins As Rectangle

instance.PrintPage(G, Margins)
C#
public virtual void PrintPage(
   Graphics G,
   Rectangle Margins
)
Managed Extensions for C++
public: virtual void PrintPage(
   Graphics* G,
   Rectangle Margins
)
C++/CLI
public:
virtual void PrintPage(
   Graphics^ G,
   Rectangle Margins
)

Parameters

G
Margins

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Refresh Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : Refresh Method

Glossary Item Box

Overidden from Control.Refresh(). Here we handle the special cases when the Control is not visible, but need to be drawn anyway.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw

instance.Refresh()
C#
public override void Refresh()
Managed Extensions for C++
public: void Refresh(); override
C++/CLI
public:
void Refresh(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
OffscreenDraw Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see OffscreenDraw members.

Public Properties

 | Name | Description
Public Property | BackgroundImage | Overridden. Since the components completly cover the drawing area the background image is not supported. Use the OnOffscreenPaintBackground event instead.
Public Property | Bitmap | Access to the last drawn bitmap, read only.
Public Property | CalcBottom | Used internally
Public Property | CalcHeight | Used internally
Public Property | CalcLeft | Used internally
Public Property | CalcRect | The effective rectangle used for drawing, takes printing into account
Public Property | CalcRight | Used internally
Public Property | CalcTop | Used internally
Public Property | CalcWidth | Used internally
Public Property | Cursor | Overridden. Overriden to send the OnPreCursorChangeEvent
Public Property | DrawForeground | Set to true to draw transparent stuff in the foreground
Public Property | FlipView | FlipView. The Schedule is a FlipView Gantt.
Public Property | Graphics | Access to the Graphics object that is used for drawing
Public Property | IsPrinting | Returns true if printing
Public Property | PrintRect | The rect that the print should fit within
Top

See Also

Reference

OffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BackgroundImage Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : BackgroundImage Property

Glossary Item Box

Since the components completly cover the drawing area the background image is not supported. Use the OnOffscreenPaintBackground event instead.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Overrides Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public override Image BackgroundImage {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Image* get_BackgroundImage() override;
public: __property void set_BackgroundImage(
   Image* value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Image^ BackgroundImage {
   Image^ get() override;
   void set (    Image^ value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Bitmap Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : Bitmap Property

Glossary Item Box

Access to the last drawn bitmap, read only.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Bitmap As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Bitmap

value = instance.Bitmap
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Bitmap Bitmap {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Bitmap* get_Bitmap();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Bitmap^ Bitmap {
   Bitmap^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcBottom Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcBottom Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcBottom As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcBottom
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcBottom {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcBottom();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcBottom {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcHeight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcHeight Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcHeight
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcHeight {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcHeight();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcHeight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcLeft Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcLeft Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcLeft As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcLeft
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcLeft {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcLeft();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcLeft {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcRect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcRect Property

Glossary Item Box

The effective rectangle used for drawing, takes printing into account

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property CalcRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Rectangle

value = instance.CalcRect
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Rectangle CalcRect {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Rectangle get_CalcRect();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Rectangle CalcRect {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcRight Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcRight Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property CalcRight As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcRight
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int CalcRight {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_CalcRight();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int CalcRight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcTop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcTop Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcTop As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcTop
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcTop {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcTop();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcTop {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalcWidth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : CalcWidth Property

Glossary Item Box

Used internally

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property CalcWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Integer

value = instance.CalcWidth
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int CalcWidth {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_CalcWidth();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int CalcWidth {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cursor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : Cursor Property

Glossary Item Box

Overriden to send the OnPreCursorChangeEvent

Syntax

Visual Basic (Declaration)
Public Overrides Property Cursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
C#
public override Cursor Cursor {get; set;}
Managed Extensions for C++
public: __property Cursor* get_Cursor() override;
public: __property void set_Cursor(
   Cursor* value
) override;
C++/CLI
public:
property Cursor^ Cursor {
   Cursor^ get() override;
   void set (    Cursor^ value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawForeground Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : DrawForeground Property

Glossary Item Box

Set to true to draw transparent stuff in the foreground

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DrawForeground As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Boolean

instance.DrawForeground = value

value = instance.DrawForeground
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool DrawForeground {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_DrawForeground();
public: __property void set_DrawForeground(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool DrawForeground {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FlipView Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : FlipView Property

Glossary Item Box

FlipView. The Schedule is a FlipView Gantt.

Syntax

Visual Basic (Declaration)
Public Overridable Property FlipView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Boolean

instance.FlipView = value

value = instance.FlipView
C#
public virtual bool FlipView {get; set;}
Managed Extensions for C++
public: __property virtual bool get_FlipView();
public: __property virtual void set_FlipView(
   bool value
);
C++/CLI
public:
virtual property bool FlipView {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Graphics Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : Graphics Property

Glossary Item Box

Access to the Graphics object that is used for drawing

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property Graphics As Graphics
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Graphics

value = instance.Graphics
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Graphics Graphics {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Graphics* get_Graphics();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsPrinting Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : IsPrinting Property

Glossary Item Box

Returns true if printing

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsPrinting As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Boolean

value = instance.IsPrinting
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsPrinting {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_IsPrinting();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool IsPrinting {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintRect Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : PrintRect Property

Glossary Item Box

The rect that the print should fit within

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property PrintRect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim value As Rectangle

value = instance.PrintRect
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Rectangle PrintRect {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Rectangle get_PrintRect();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Rectangle PrintRect {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
OffscreenDraw Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see OffscreenDraw members.

Public Events

 | Name | Description
Public Event | OnAfterDraw | Fired after draw. This was introduced to handle a specific problem: The Offscreen holds an internal variabel to avoid invalidating while currently drawing (optimization). However there are cases when one needs to invalidate in the draw loop; like the implementation of MakeSureVisible that forces refresh operations to find a setting where the choosen object is actually rendered and the Setting SelectNewDataBoundRows that uses the MakeSureVisible call.
Public Event | OnOffscreenPaintBackground | Fired when it is time to draw the background
Public Event | OnOffscreenPaintForeground | Fired when it is time to draw the foreground
Public Event | OnPreCursorChangeEvent | Fired when the control for some reason is about to set the cursor...
Public Event | OnUnhandledException | Fired when an unhandled exception occures
Top

See Also

Reference

OffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnAfterDraw Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : OnAfterDraw Event

Glossary Item Box

Fired after draw. This was introduced to handle a specific problem: The Offscreen holds an internal variabel to avoid invalidating while currently drawing (optimization). However there are cases when one needs to invalidate in the draw loop; like the implementation of MakeSureVisible that forces refresh operations to find a setting where the choosen object is actually rendered and the Setting SelectNewDataBoundRows that uses the MakeSureVisible call.

Syntax

Visual Basic (Declaration)
Public Event OnAfterDraw As AfterDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim handler As AfterDrawEvent

AddHandler instance.OnAfterDraw, handler
C#
public event AfterDrawEvent OnAfterDraw
Managed Extensions for C++
public: __event AfterDrawEvent* OnAfterDraw
C++/CLI
public:
event AfterDrawEvent^ OnAfterDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnOffscreenPaintBackground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : OnOffscreenPaintBackground Event

Glossary Item Box

Fired when it is time to draw the background

Syntax

Visual Basic (Declaration)
Public Event OnOffscreenPaintBackground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim handler As OffscreenDrawEvent

AddHandler instance.OnOffscreenPaintBackground, handler
C#
public event OffscreenDrawEvent OnOffscreenPaintBackground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnOffscreenPaintBackground
C++/CLI
public:
event OffscreenDrawEvent^ OnOffscreenPaintBackground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnOffscreenPaintForeground Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : OnOffscreenPaintForeground Event

Glossary Item Box

Fired when it is time to draw the foreground

Syntax

Visual Basic (Declaration)
Public Event OnOffscreenPaintForeground As OffscreenDrawEvent
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim handler As OffscreenDrawEvent

AddHandler instance.OnOffscreenPaintForeground, handler
C#
public event OffscreenDrawEvent OnOffscreenPaintForeground
Managed Extensions for C++
public: __event OffscreenDrawEvent* OnOffscreenPaintForeground
C++/CLI
public:
event OffscreenDrawEvent^ OnOffscreenPaintForeground

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnPreCursorChangeEvent Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : OnPreCursorChangeEvent Event

Glossary Item Box

Fired when the control for some reason is about to set the cursor...

Syntax

Visual Basic (Declaration)
Public Event OnPreCursorChangeEvent As PreCursorChangeEvent
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim handler As PreCursorChangeEvent

AddHandler instance.OnPreCursorChangeEvent, handler
C#
public event PreCursorChangeEvent OnPreCursorChangeEvent
Managed Extensions for C++
public: __event PreCursorChangeEvent* OnPreCursorChangeEvent
C++/CLI
public:
event PreCursorChangeEvent^ OnPreCursorChangeEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUnhandledException Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDraw Class : OnUnhandledException Event

Glossary Item Box

Fired when an unhandled exception occures

Syntax

Visual Basic (Declaration)
Public Event OnUnhandledException As UnhandledExceptionEvent
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDraw
Dim handler As UnhandledExceptionEvent

AddHandler instance.OnUnhandledException, handler
C#
public event UnhandledExceptionEvent OnUnhandledException
Managed Extensions for C++
public: __event UnhandledExceptionEvent* OnUnhandledException
C++/CLI
public:
event UnhandledExceptionEvent^ OnUnhandledException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDraw Class
OffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OffscreenDrawArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDrawArgs Class

Glossary Item Box

Arguments for offscreen draw events

Object Model

OffscreenDrawArgs Class

Syntax

Visual Basic (Declaration)
Public Class OffscreenDrawArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDrawArgs
C#
public class OffscreenDrawArgs : System.EventArgs
Managed Extensions for C++
public __gc class OffscreenDrawArgs : public System.EventArgs
C++/CLI
public ref class OffscreenDrawArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.OffscreenDrawArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

OffscreenDrawArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
OffscreenDrawArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDrawArgs Class

Glossary Item Box

The following tables list the members exposed by OffscreenDrawArgs.

Public Constructors

 | Name | Description
Public Constructor | OffscreenDrawArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | G |
Top

See Also

Reference

OffscreenDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OffscreenDrawArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDrawArgs Class : OffscreenDrawArgs Constructor

aG

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aG As Graphics _
)
Visual Basic (Usage) Copy Code
Dim aG As Graphics

Dim instance As New OffscreenDrawArgs(aG)
C#
public OffscreenDrawArgs(
   Graphics aG
)
Managed Extensions for C++
public: OffscreenDrawArgs(
   Graphics* aG
)
C++/CLI
public:
OffscreenDrawArgs(
   Graphics^ aG
)

Parameters

aG

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDrawArgs Class
OffscreenDrawArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
OffscreenDrawArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDrawArgs Class

Glossary Item Box

For a list of all members of this type, see OffscreenDrawArgs members.

Public Fields

 | Name | Description
Public Field | G |
Top

See Also

Reference

OffscreenDrawArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OffscreenDrawArgs Class : G Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As OffscreenDrawArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OffscreenDrawArgs Class
OffscreenDrawArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUserDrawSortSymbolArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : OnUserDrawSortSymbolArgs Class

Glossary Item Box

Arguments for the OnUserDrawSortSymbol event

Object Model

OnUserDrawSortSymbolArgs Class

Syntax

Visual Basic (Declaration)
Public Class OnUserDrawSortSymbolArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As OnUserDrawSortSymbolArgs
C#
public class OnUserDrawSortSymbolArgs : System.EventArgs
Managed Extensions for C++
public __gc class OnUserDrawSortSymbolArgs : public System.EventArgs
C++/CLI
public ref class OnUserDrawSortSymbolArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.OnUserDrawSortSymbolArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

OnUserDrawSortSymbolArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
OnUserDrawSortSymbolArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : OnUserDrawSortSymbolArgs Class

Glossary Item Box

The following tables list the members exposed by OnUserDrawSortSymbolArgs.

Public Constructors

 | Name | Description
Public Constructor | OnUserDrawSortSymbolArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Column | The column that needs the sort symbol drawing, check the Column.CurrentSortState and the Column.CellRect, draw a symbol...
Public Field | Graphics | The Graphics context to draw in
Top

See Also

Reference

OnUserDrawSortSymbolArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnUserDrawSortSymbolArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OnUserDrawSortSymbolArgs Class : OnUserDrawSortSymbolArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New OnUserDrawSortSymbolArgs()
C#
public OnUserDrawSortSymbolArgs()
Managed Extensions for C++
public: OnUserDrawSortSymbolArgs();
C++/CLI
public:
OnUserDrawSortSymbolArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OnUserDrawSortSymbolArgs Class
OnUserDrawSortSymbolArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
OnUserDrawSortSymbolArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OnUserDrawSortSymbolArgs Class

Glossary Item Box

For a list of all members of this type, see OnUserDrawSortSymbolArgs members.

Public Fields

 | Name | Description
Public Field | Column | The column that needs the sort symbol drawing, check the Column.CurrentSortState and the Column.CellRect, draw a symbol...
Public Field | Graphics | The Graphics context to draw in
Top

See Also

Reference

OnUserDrawSortSymbolArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Column Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OnUserDrawSortSymbolArgs Class : Column Field

Glossary Item Box

The column that needs the sort symbol drawing, check the Column.CurrentSortState and the Column.CellRect, draw a symbol...

Syntax

Visual Basic (Declaration)
Public Column As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As OnUserDrawSortSymbolArgs
Dim value As GridColumn

value = instance.Column

instance.Column = value
C#
public GridColumn Column
Managed Extensions for C++
public: GridColumn* Column
C++/CLI
public:
GridColumn^ Column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OnUserDrawSortSymbolArgs Class
OnUserDrawSortSymbolArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Graphics Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > OnUserDrawSortSymbolArgs Class : Graphics Field

Glossary Item Box

The Graphics context to draw in

Syntax

Visual Basic (Declaration)
Public Graphics As Graphics
Visual Basic (Usage) Copy Code
Dim instance As OnUserDrawSortSymbolArgs
Dim value As Graphics

value = instance.Graphics

instance.Graphics = value
C#
public Graphics Graphics
Managed Extensions for C++
public: Graphics* Graphics
C++/CLI
public:
Graphics^ Graphics

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

OnUserDrawSortSymbolArgs Class
OnUserDrawSortSymbolArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanButton Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton Class

Glossary Item Box

PanButton.

Object Model

PanButton Class

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class PanButton
   Inherits System.Windows.Forms.Button
Visual Basic (Usage) Copy Code
Dim instance As PanButton
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class PanButton : System.Windows.Forms.Button
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class PanButton : public System.Windows.Forms.Button
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class PanButton : public System.Windows.Forms.Button

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ButtonBase
System.Windows.Forms.Button
PlexityHide.GTP.PanButton

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PanButton Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
PanButton Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : PanButton Class

Glossary Item Box

The following tables list the members exposed by PanButton.

Public Constructors

 | Name | Description
Public Constructor | PanButton Constructor |
Top

Public Properties

 | Name | Description
Public Property | FlipView |
Top

Public Events

 | Name | Description
Public Event | PanEvent |
Top

See Also

Reference

PanButton Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanButton Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PanButton Class : PanButton Constructor

direction

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal direction As PanButton.PanDirection _
)
Visual Basic (Usage) Copy Code
Dim direction As PanButton.PanDirection

Dim instance As New PanButton(direction)
C#
public PanButton(
   PanButton.PanDirection direction
)
Managed Extensions for C++
public: PanButton(
   PanButton.PanDirection direction
)
C++/CLI
public:
PanButton(
   PanButton.PanDirection direction
)

Parameters

direction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PanButton Class
PanButton Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
PanButton Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton Class

Glossary Item Box

For a list of all members of this type, see PanButton members.

Public Properties

 | Name | Description
Public Property | FlipView |
Top

See Also

Reference

PanButton Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
FlipView Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PanButton Class : FlipView Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FlipView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PanButton
Dim value As Boolean

instance.FlipView = value

value = instance.FlipView
C#
public bool FlipView {get; set;}
Managed Extensions for C++
public: __property bool get_FlipView();
public: __property void set_FlipView(
   bool value
);
C++/CLI
public:
property bool FlipView {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PanButton Class
PanButton Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
PanButton Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton Class

Glossary Item Box

For a list of all members of this type, see PanButton members.

Public Events

 | Name | Description
Public Event | PanEvent |
Top

See Also

Reference

PanButton Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanEvent Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PanButton Class : PanEvent Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PanEvent As PanButton.PanEventHandler
Visual Basic (Usage) Copy Code
Dim instance As PanButton
Dim handler As PanButton.PanEventHandler

AddHandler instance.PanEvent, handler
C#
public event PanButton.PanEventHandler PanEvent
Managed Extensions for C++
public: __event PanButton.PanEventHandler* PanEvent
C++/CLI
public:
event PanButton.PanEventHandler^ PanEvent

Event Data

The event handler receives an argument of type PanEventArgs containing data related to this event. The following PanEventArgs properties provide information specific to this event.

Property | Description
Panorate |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PanButton Class
PanButton Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanEventArgs Class

Glossary Item Box

Object Model

PanEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PanEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PanEventArgs
C#
public class PanEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class PanEventArgs : public System.EventArgs
C++/CLI
public ref class PanEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.PanEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PanEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
PanEventArgs Class Members
See Also Properties Send comments on this topic.
PlexityHide.GTP Namespace : PanEventArgs Class

Glossary Item Box

The following tables list the members exposed by PanEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PanEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Panorate |
Top

See Also

Reference

PanEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PanEventArgs Class : PanEventArgs Constructor

panorate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal panorate As PanEventArgs.PanSpeed _
)
Visual Basic (Usage) Copy Code
Dim panorate As PanEventArgs.PanSpeed

Dim instance As New PanEventArgs(panorate)
C#
public PanEventArgs(
   PanEventArgs.PanSpeed panorate
)
Managed Extensions for C++
public: PanEventArgs(
   PanEventArgs.PanSpeed panorate
)
C++/CLI
public:
PanEventArgs(
   PanEventArgs.PanSpeed panorate
)

Parameters

panorate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PanEventArgs Class
PanEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
PanEventArgs Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanEventArgs Class

Glossary Item Box

For a list of all members of this type, see PanEventArgs members.

Public Properties

 | Name | Description
Public Property | Panorate |
Top

See Also

Reference

PanEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Panorate Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PanEventArgs Class : Panorate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Panorate As PanEventArgs.PanSpeed
Visual Basic (Usage) Copy Code
Dim instance As PanEventArgs
Dim value As PanEventArgs.PanSpeed

value = instance.Panorate
C#
public PanEventArgs.PanSpeed Panorate {get;}
Managed Extensions for C++
public: __property PanEventArgs.PanSpeed get_Panorate();
C++/CLI
public:
property PanEventArgs.PanSpeed Panorate {
   PanEventArgs.PanSpeed get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PanEventArgs Class
PanEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PreCursorChangeEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : PreCursorChangeEventArgs Class

Glossary Item Box

Arguments for PreCursorChange event

Object Model

PreCursorChangeEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PreCursorChangeEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PreCursorChangeEventArgs
C#
public class PreCursorChangeEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class PreCursorChangeEventArgs : public System.EventArgs
C++/CLI
public ref class PreCursorChangeEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.PreCursorChangeEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PreCursorChangeEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
PreCursorChangeEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : PreCursorChangeEventArgs Class

Glossary Item Box

The following tables list the members exposed by PreCursorChangeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PreCursorChangeEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cursor | The value of the cursor about to be set. Change this value if needed.
Top

See Also

Reference

PreCursorChangeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PreCursorChangeEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PreCursorChangeEventArgs Class : PreCursorChangeEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PreCursorChangeEventArgs()
C#
public PreCursorChangeEventArgs()
Managed Extensions for C++
public: PreCursorChangeEventArgs();
C++/CLI
public:
PreCursorChangeEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PreCursorChangeEventArgs Class
PreCursorChangeEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
PreCursorChangeEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PreCursorChangeEventArgs Class

Glossary Item Box

For a list of all members of this type, see PreCursorChangeEventArgs members.

Public Fields

 | Name | Description
Public Field | Cursor | The value of the cursor about to be set. Change this value if needed.
Top

See Also

Reference

PreCursorChangeEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Cursor Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > PreCursorChangeEventArgs Class : Cursor Field

Glossary Item Box

The value of the cursor about to be set. Change this value if needed.

Syntax

Visual Basic (Declaration)
Public Cursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As PreCursorChangeEventArgs
Dim value As Cursor

value = instance.Cursor

instance.Cursor = value
C#
public Cursor Cursor
Managed Extensions for C++
public: Cursor* Cursor
C++/CLI
public:
Cursor^ Cursor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PreCursorChangeEventArgs Class
PreCursorChangeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeArgs Class

Glossary Item Box

Arguments for RowResize event

Object Model

RowResizeArgs Class

Syntax

Visual Basic (Declaration)
Public Class RowResizeArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RowResizeArgs
C#
public class RowResizeArgs : System.EventArgs
Managed Extensions for C++
public __gc class RowResizeArgs : public System.EventArgs
C++/CLI
public ref class RowResizeArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.RowResizeArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

RowResizeArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
RowResizeArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeArgs Class

Glossary Item Box

The following tables list the members exposed by RowResizeArgs.

Public Constructors

 | Name | Description
Public Constructor | RowResizeArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Delta | The amount changed by the user. You can change this value to zero = no change, or limit it to a minimum or maximum of your choice.
Public Field | GridNode | The GridNode handled
Top

See Also

Reference

RowResizeArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > RowResizeArgs Class : RowResizeArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New RowResizeArgs()
C#
public RowResizeArgs()
Managed Extensions for C++
public: RowResizeArgs();
C++/CLI
public:
RowResizeArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RowResizeArgs Class
RowResizeArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
RowResizeArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeArgs Class

Glossary Item Box

For a list of all members of this type, see RowResizeArgs members.

Public Fields

 | Name | Description
Public Field | Delta | The amount changed by the user. You can change this value to zero = no change, or limit it to a minimum or maximum of your choice.
Public Field | GridNode | The GridNode handled
Top

See Also

Reference

RowResizeArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Delta Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > RowResizeArgs Class : Delta Field

Glossary Item Box

The amount changed by the user. You can change this value to zero = no change, or limit it to a minimum or maximum of your choice.

Syntax

Visual Basic (Declaration)
Public Delta As Integer
Visual Basic (Usage) Copy Code
Dim instance As RowResizeArgs
Dim value As Integer

value = instance.Delta

instance.Delta = value
C#
public int Delta
Managed Extensions for C++
public: int Delta
C++/CLI
public:
int Delta

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RowResizeArgs Class
RowResizeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > RowResizeArgs Class : GridNode Field

Glossary Item Box

The GridNode handled

Syntax

Visual Basic (Declaration)
Public GridNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As RowResizeArgs
Dim value As GridNode

value = instance.GridNode

instance.GridNode = value
C#
public GridNode GridNode
Managed Extensions for C++
public: GridNode* GridNode
C++/CLI
public:
GridNode^ GridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RowResizeArgs Class
RowResizeArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeDoneArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeDoneArgs Class

Glossary Item Box

Arguments for RowResizeDone event

Object Model

RowResizeDoneArgs Class

Syntax

Visual Basic (Declaration)
Public Class RowResizeDoneArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RowResizeDoneArgs
C#
public class RowResizeDoneArgs : System.EventArgs
Managed Extensions for C++
public __gc class RowResizeDoneArgs : public System.EventArgs
C++/CLI
public ref class RowResizeDoneArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.RowResizeDoneArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

RowResizeDoneArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
RowResizeDoneArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeDoneArgs Class

Glossary Item Box

The following tables list the members exposed by RowResizeDoneArgs.

Public Constructors

 | Name | Description
Public Constructor | RowResizeDoneArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | GridNode | The GridNode handled
Top

See Also

Reference

RowResizeDoneArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeDoneArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > RowResizeDoneArgs Class : RowResizeDoneArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New RowResizeDoneArgs()
C#
public RowResizeDoneArgs()
Managed Extensions for C++
public: RowResizeDoneArgs();
C++/CLI
public:
RowResizeDoneArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RowResizeDoneArgs Class
RowResizeDoneArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
RowResizeDoneArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeDoneArgs Class

Glossary Item Box

For a list of all members of this type, see RowResizeDoneArgs members.

Public Fields

 | Name | Description
Public Field | GridNode | The GridNode handled
Top

See Also

Reference

RowResizeDoneArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > RowResizeDoneArgs Class : GridNode Field

Glossary Item Box

The GridNode handled

Syntax

Visual Basic (Declaration)
Public GridNode As GridNode
Visual Basic (Usage) Copy Code
Dim instance As RowResizeDoneArgs
Dim value As GridNode

value = instance.GridNode

instance.GridNode = value
C#
public GridNode GridNode
Managed Extensions for C++
public: GridNode* GridNode
C++/CLI
public:
GridNode^ GridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RowResizeDoneArgs Class
RowResizeDoneArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SingleText Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : SingleText Class

Glossary Item Box

Holds the content of a grid cell of type SingleText.

Object Model

SingleText Class

Syntax

Visual Basic (Declaration)
Public Class SingleText
   Inherits ContentEntity
   Implements IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As SingleText
C#
public class SingleText : ContentEntity, IClipboardInteraction
Managed Extensions for C++
public __gc class SingleText : public ContentEntity, IClipboardInteraction
C++/CLI
public ref class SingleText : public ContentEntity, IClipboardInteraction

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.SingleText

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

SingleText Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
SingleText Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : SingleText Class

Glossary Item Box

The following tables list the members exposed by SingleText.

Public Constructors

 | Name | Description
Public Constructor | SingleText Constructor | Constructor.
Top

Public Properties

 | Name | Description
Public Property | EditBox | Gets the edit box.
Public Property | Text | Gets and sets the text of the grid cell.
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

SingleText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
SingleText Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > SingleText Class : SingleText Constructor

owner

Glossary Item Box

Constructor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As Cell _
)
Visual Basic (Usage) Copy Code
Dim owner As Cell

Dim instance As New SingleText(owner)
C#
public SingleText(
   Cell owner
)
Managed Extensions for C++
public: SingleText(
   Cell* owner
)
C++/CLI
public:
SingleText(
   Cell^ owner
)

Parameters

owner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SingleText Class
SingleText Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
SingleText Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : SingleText Class

Glossary Item Box

For a list of all members of this type, see SingleText members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

SingleText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > SingleText Class : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As SingleText

instance.CopyToClipboard()
C#
public void CopyToClipboard()
Managed Extensions for C++
public: void CopyToClipboard();
C++/CLI
public:
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SingleText Class
SingleText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > SingleText Class : PasteValueFromClipboard Method

Glossary Item Box

Implements the pasting of clipboard data

Syntax

Visual Basic (Declaration)
Public Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As SingleText

instance.PasteValueFromClipboard()
C#
public void PasteValueFromClipboard()
Managed Extensions for C++
public: void PasteValueFromClipboard();
C++/CLI
public:
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SingleText Class
SingleText Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
SingleText Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : SingleText Class

Glossary Item Box

For a list of all members of this type, see SingleText members.

Public Properties

 | Name | Description
Public Property | EditBox | Gets the edit box.
Public Property | Text | Gets and sets the text of the grid cell.
Top

See Also

Reference

SingleText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditBox Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > SingleText Class : EditBox Property

Glossary Item Box

Gets the edit box.

Syntax

Visual Basic (Declaration)
Public Property EditBox As TextBox
Visual Basic (Usage) Copy Code
Dim instance As SingleText
Dim value As TextBox

instance.EditBox = value

value = instance.EditBox
C#
public TextBox EditBox {get; set;}
Managed Extensions for C++
public: __property TextBox* get_EditBox();
public: __property void set_EditBox(
   TextBox* value
);
C++/CLI
public:
property TextBox^ EditBox {
   TextBox^ get();
   void set (    TextBox^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SingleText Class
SingleText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > SingleText Class : Text Property

Glossary Item Box

Gets and sets the text of the grid cell.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As SingleText
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SingleText Class
SingleText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeAreaOffscreenDraw Class

Glossary Item Box

Shows time items based on DateScaler and Grid

Object Model

TimeAreaOffscreenDraw Class

Syntax

Visual Basic (Declaration)
Public Class TimeAreaOffscreenDraw
   Inherits OffscreenDraw
Visual Basic (Usage) Copy Code
Dim instance As TimeAreaOffscreenDraw
C#
public class TimeAreaOffscreenDraw : OffscreenDraw
Managed Extensions for C++
public __gc class TimeAreaOffscreenDraw : public OffscreenDraw
C++/CLI
public ref class TimeAreaOffscreenDraw : public OffscreenDraw

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
PlexityHide.GTP.OffscreenDraw
PlexityHide.GTP.TimeAreaOffscreenDraw

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeAreaOffscreenDraw Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : TimeAreaOffscreenDraw Class

Glossary Item Box

The following tables list the members exposed by TimeAreaOffscreenDraw.

Public Constructors

 | Name | Description
Public Constructor | TimeAreaOffscreenDraw Constructor |
Top

Public Methods

 | Name | Description
Public Method | PrintPage | Overridden. Used for printing
Top

See Also

Reference

TimeAreaOffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeAreaOffscreenDraw Class : TimeAreaOffscreenDraw Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeAreaOffscreenDraw()
C#
public TimeAreaOffscreenDraw()
Managed Extensions for C++
public: TimeAreaOffscreenDraw();
C++/CLI
public:
TimeAreaOffscreenDraw();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeAreaOffscreenDraw Class
TimeAreaOffscreenDraw Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeAreaOffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see TimeAreaOffscreenDraw members.

Public Methods

 | Name | Description
Public Method | PrintPage | Overridden. Used for printing
Top

See Also

Reference

TimeAreaOffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PrintPage Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeAreaOffscreenDraw Class : PrintPage Method

G
Margins

Glossary Item Box

Used for printing

Syntax

Visual Basic (Declaration)
Public Overrides Sub PrintPage( _
   ByVal G As Graphics, _
   ByVal Margins As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeAreaOffscreenDraw
Dim G As Graphics
Dim Margins As Rectangle

instance.PrintPage(G, Margins)
C#
public override void PrintPage(
   Graphics G,
   Rectangle Margins
)
Managed Extensions for C++
public: void PrintPage(
   Graphics* G,
   Rectangle Margins
) override
C++/CLI
public:
void PrintPage(
   Graphics^ G,
   Rectangle Margins
) override

Parameters

G
Margins

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeAreaOffscreenDraw Class
TimeAreaOffscreenDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDate Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDate Class

Glossary Item Box

Holds a DateTime structure as content for a cell.

Object Model

TimeDate Class

Syntax

Visual Basic (Declaration)
Public Class TimeDate
   Inherits ContentEntity
   Implements IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
C#
public class TimeDate : ContentEntity, IClipboardInteraction
Managed Extensions for C++
public __gc class TimeDate : public ContentEntity, IClipboardInteraction
C++/CLI
public ref class TimeDate : public ContentEntity, IClipboardInteraction

Example

GridColumn Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.TimeDate

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeDate Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeDate Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeDate Class

Glossary Item Box

The following tables list the members exposed by TimeDate.

Public Properties

 | Name | Description
Public Property | DateTime | Gets and sets the date time content.
Public Property | EditBox | Gets the edit box.
Public Property | IsDateNotTime | Show and edit as time or as date?
Public Property | Text | The presented text
Public Property | Time | Gets and sets the date time content. Deprectated, use DateTime- better name
Public Property | TimeSpan | Gets and sets the time span content.
Top

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

TimeDate Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeDate Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDate Class

Glossary Item Box

For a list of all members of this type, see TimeDate members.

Public Methods

 | Name | Description
Public Method | CopyToClipboard | Copy the cell data to the clipboard
Public Method | PasteValueFromClipboard | Implements the pasting of clipboard data
Top

See Also

Reference

TimeDate Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Public Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As TimeDate

instance.CopyToClipboard()
C#
public void CopyToClipboard()
Managed Extensions for C++
public: void CopyToClipboard();
C++/CLI
public:
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : PasteValueFromClipboard Method

Glossary Item Box

Implements the pasting of clipboard data

Syntax

Visual Basic (Declaration)
Public Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As TimeDate

instance.PasteValueFromClipboard()
C#
public void PasteValueFromClipboard()
Managed Extensions for C++
public: void PasteValueFromClipboard();
C++/CLI
public:
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeDate Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDate Class

Glossary Item Box

For a list of all members of this type, see TimeDate members.

Public Properties

 | Name | Description
Public Property | DateTime | Gets and sets the date time content.
Public Property | EditBox | Gets the edit box.
Public Property | IsDateNotTime | Show and edit as time or as date?
Public Property | Text | The presented text
Public Property | Time | Gets and sets the date time content. Deprectated, use DateTime- better name
Public Property | TimeSpan | Gets and sets the time span content.
Top

See Also

Reference

TimeDate Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : DateTime Property

Glossary Item Box

Gets and sets the date time content.

Syntax

Visual Basic (Declaration)
Public Property DateTime As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As Date

instance.DateTime = value

value = instance.DateTime
C#
public DateTime DateTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_DateTime();
public: __property void set_DateTime(
   DateTime value
);
C++/CLI
public:
property DateTime DateTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditBox Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : EditBox Property

Glossary Item Box

Gets the edit box.

Syntax

Visual Basic (Declaration)
Public Property EditBox As DateTimePicker
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As DateTimePicker

instance.EditBox = value

value = instance.EditBox
C#
public DateTimePicker EditBox {get; set;}
Managed Extensions for C++
public: __property DateTimePicker* get_EditBox();
public: __property void set_EditBox(
   DateTimePicker* value
);
C++/CLI
public:
property DateTimePicker^ EditBox {
   DateTimePicker^ get();
   void set (    DateTimePicker^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsDateNotTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : IsDateNotTime Property

Glossary Item Box

Show and edit as time or as date?

Syntax

Visual Basic (Declaration)
Public Property IsDateNotTime As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As Boolean

instance.IsDateNotTime = value

value = instance.IsDateNotTime
C#
public bool IsDateNotTime {get; set;}
Managed Extensions for C++
public: __property bool get_IsDateNotTime();
public: __property void set_IsDateNotTime(
   bool value
);
C++/CLI
public:
property bool IsDateNotTime {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : Text Property

Glossary Item Box

The presented text

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As String

value = instance.Text
C#
public string Text {get;}
Managed Extensions for C++
public: __property string* get_Text();
C++/CLI
public:
property String^ Text {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Time Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : Time Property

Glossary Item Box

Gets and sets the date time content. Deprectated, use DateTime- better name

Syntax

Visual Basic (Declaration)
Public Property Time As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As Date

instance.Time = value

value = instance.Time
C#
public DateTime Time {get; set;}
Managed Extensions for C++
public: __property DateTime get_Time();
public: __property void set_Time(
   DateTime value
);
C++/CLI
public:
property DateTime Time {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeSpan Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDate Class : TimeSpan Property

Glossary Item Box

Gets and sets the time span content.

Syntax

Visual Basic (Declaration)
Public Property TimeSpan As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeDate
Dim value As TimeSpan

instance.TimeSpan = value

value = instance.TimeSpan
C#
public TimeSpan TimeSpan {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_TimeSpan();
public: __property void set_TimeSpan(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan TimeSpan {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDate Class
TimeDate Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctItem Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctItem Class

Glossary Item Box

Defines the data that is used by collision detect.

Object Model

TimeDistinctItem Class

Syntax

Visual Basic (Declaration)
Public Class TimeDistinctItem
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
C#
public class TimeDistinctItem
Managed Extensions for C++
public __gc class TimeDistinctItem
C++/CLI
public ref class TimeDistinctItem

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeDistinctItem

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeDistinctItem Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeDistinctItem Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctItem Class

Glossary Item Box

The following tables list the members exposed by TimeDistinctItem.

Public Constructors

 | Name | Description
Public Constructor | TimeDistinctItem Constructor |
Top

Public Fields

 | Name | Description
Public Field | CollisionNotes | Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap
Public Field | DistinctPosition | Resulting collision free sub position within group
Public Field | GroupKey | Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once
Public Field | MainOffenderReference | Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)
Public Field | Reference | The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)
Public Field | Start | The start time that will be used in conflict detection
Public Field | Stop | The stop time that will be used in conflict detection
Top

See Also

Reference

TimeDistinctItem Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctItem Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : TimeDistinctItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeDistinctItem()
C#
public TimeDistinctItem()
Managed Extensions for C++
public: TimeDistinctItem();
C++/CLI
public:
TimeDistinctItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
TimeDistinctItem Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctItem Class

Glossary Item Box

For a list of all members of this type, see TimeDistinctItem members.

Public Fields

 | Name | Description
Public Field | CollisionNotes | Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap
Public Field | DistinctPosition | Resulting collision free sub position within group
Public Field | GroupKey | Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once
Public Field | MainOffenderReference | Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)
Public Field | Reference | The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)
Public Field | Start | The start time that will be used in conflict detection
Public Field | Stop | The stop time that will be used in conflict detection
Top

See Also

Reference

TimeDistinctItem Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionNotes Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : CollisionNotes Field

Glossary Item Box

Optional CollisionNotes collects detailed information about all colliding time items and exactly were they overlap

Syntax

Visual Basic (Declaration)
Public CollisionNotes As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As ArrayList

value = instance.CollisionNotes

instance.CollisionNotes = value
C#
public ArrayList CollisionNotes
Managed Extensions for C++
public: ArrayList* CollisionNotes
C++/CLI
public:
ArrayList^ CollisionNotes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DistinctPosition Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : DistinctPosition Field

Glossary Item Box

Resulting collision free sub position within group

Syntax

Visual Basic (Declaration)
Public DistinctPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Integer

value = instance.DistinctPosition

instance.DistinctPosition = value
C#
public int DistinctPosition
Managed Extensions for C++
public: int DistinctPosition
C++/CLI
public:
int DistinctPosition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GroupKey Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : GroupKey Field

Glossary Item Box

Group key is used to seperate time distict items from each other so that several dimensions can be resolved at once

Syntax

Visual Basic (Declaration)
Public GroupKey As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Integer

value = instance.GroupKey

instance.GroupKey = value
C#
public int GroupKey
Managed Extensions for C++
public: int GroupKey
C++/CLI
public:
int GroupKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MainOffenderReference Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : MainOffenderReference Field

Glossary Item Box

Reference to the TimeDistinctItems Reference that was first found to be in conflict (if any)

Syntax

Visual Basic (Declaration)
Public MainOffenderReference As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Object

value = instance.MainOffenderReference

instance.MainOffenderReference = value
C#
public object MainOffenderReference
Managed Extensions for C++
public: Object* MainOffenderReference
C++/CLI
public:
Object^ MainOffenderReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Reference Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : Reference Field

Glossary Item Box

The reference to the object that uses this TimeDistinctItem to find conflicts (in GTP.NET this can be a TimeItem)

Syntax

Visual Basic (Declaration)
Public Reference As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Object

value = instance.Reference

instance.Reference = value
C#
public object Reference
Managed Extensions for C++
public: Object* Reference
C++/CLI
public:
Object^ Reference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : Start Field

Glossary Item Box

The start time that will be used in conflict detection

Syntax

Visual Basic (Declaration)
Public Start As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Date

value = instance.Start

instance.Start = value
C#
public DateTime Start
Managed Extensions for C++
public: DateTime Start
C++/CLI
public:
DateTime Start

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Stop Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctItem Class : Stop Field

Glossary Item Box

The stop time that will be used in conflict detection

Syntax

Visual Basic (Declaration)
Public Stop As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctItem
Dim value As Date

value = instance.Stop

instance.Stop = value
C#
public DateTime Stop
Managed Extensions for C++
public: DateTime Stop
C++/CLI
public:
DateTime Stop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctItem Class
TimeDistinctItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctThread Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread Class

Glossary Item Box

This class is used internally and helps GanttRows to find a collision free position asynchronously.

Object Model

TimeDistinctThread Class

Syntax

Visual Basic (Declaration)
Public Class TimeDistinctThread
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
C#
public class TimeDistinctThread
Managed Extensions for C++
public __gc class TimeDistinctThread
C++/CLI
public ref class TimeDistinctThread

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeDistinctThread

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeDistinctThread Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeDistinctThread Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread Class

Glossary Item Box

The following tables list the members exposed by TimeDistinctThread.

Public Constructors

 | Name | Description
Public Constructor | TimeDistinctThread Constructor |
Top

Public Properties

 | Name | Description
Public Property | CollectConflictNotes | Controls if detailed Conflict notes should be collected on each detected collision
Public Property | List |
Public Property | Started |
Top

Public Methods

 | Name | Description
Public Method | NeverMind |
Public Method | Start |
Public Method | Start_Syncron |
Top

Public Events

 | Name | Description
Public Event | OnCollisionDetectDone | This callback is implemented to catch the result from the collisiondetection
Top

See Also

Reference

TimeDistinctThread Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctThread Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : TimeDistinctThread Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeDistinctThread()
C#
public TimeDistinctThread()
Managed Extensions for C++
public: TimeDistinctThread();
C++/CLI
public:
TimeDistinctThread();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeDistinctThread Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread Class

Glossary Item Box

For a list of all members of this type, see TimeDistinctThread members.

Public Methods

 | Name | Description
Public Method | NeverMind |
Public Method | Start |
Public Method | Start_Syncron |
Top

See Also

Reference

TimeDistinctThread Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NeverMind Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : NeverMind Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub NeverMind()
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread

instance.NeverMind()
C#
public void NeverMind()
Managed Extensions for C++
public: void NeverMind();
C++/CLI
public:
void NeverMind();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : Start Method

aControlToInvalidate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal aControlToInvalidate As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
Dim aControlToInvalidate As Control

instance.Start(aControlToInvalidate)
C#
public void Start(
   Control aControlToInvalidate
)
Managed Extensions for C++
public: void Start(
   Control* aControlToInvalidate
)
C++/CLI
public:
void Start(
   Control^ aControlToInvalidate
)

Parameters

aControlToInvalidate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start_Syncron Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : Start_Syncron Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start_Syncron()
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread

instance.Start_Syncron()
C#
public void Start_Syncron()
Managed Extensions for C++
public: void Start_Syncron();
C++/CLI
public:
void Start_Syncron();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeDistinctThread Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread Class

Glossary Item Box

For a list of all members of this type, see TimeDistinctThread members.

Public Properties

 | Name | Description
Public Property | CollectConflictNotes | Controls if detailed Conflict notes should be collected on each detected collision
Public Property | List |
Public Property | Started |
Top

See Also

Reference

TimeDistinctThread Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollectConflictNotes Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : CollectConflictNotes Property

Glossary Item Box

Controls if detailed Conflict notes should be collected on each detected collision

Syntax

Visual Basic (Declaration)
Public Property CollectConflictNotes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
Dim value As Boolean

instance.CollectConflictNotes = value

value = instance.CollectConflictNotes
C#
public bool CollectConflictNotes {get; set;}
Managed Extensions for C++
public: __property bool get_CollectConflictNotes();
public: __property void set_CollectConflictNotes(
   bool value
);
C++/CLI
public:
property bool CollectConflictNotes {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
List Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : List Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
Dim value As ArrayList

value = instance.List
C#
public ArrayList List {get;}
Managed Extensions for C++
public: __property ArrayList* get_List();
C++/CLI
public:
property ArrayList^ List {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Started Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : Started Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Started As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
Dim value As Boolean

value = instance.Started
C#
public bool Started {get;}
Managed Extensions for C++
public: __property bool get_Started();
C++/CLI
public:
property bool Started {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
TimeDistinctThread Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread Class

Glossary Item Box

For a list of all members of this type, see TimeDistinctThread members.

Public Events

 | Name | Description
Public Event | OnCollisionDetectDone | This callback is implemented to catch the result from the collisiondetection
Top

See Also

Reference

TimeDistinctThread Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnCollisionDetectDone Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeDistinctThread Class : OnCollisionDetectDone Event

Glossary Item Box

This callback is implemented to catch the result from the collisiondetection

Syntax

Visual Basic (Declaration)
Public Event OnCollisionDetectDone As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TimeDistinctThread
Dim handler As EventHandler

AddHandler instance.OnCollisionDetectDone, handler
C#
public event EventHandler OnCollisionDetectDone
Managed Extensions for C++
public: __event EventHandler* OnCollisionDetectDone
C++/CLI
public:
event EventHandler^ OnCollisionDetectDone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeDistinctThread Class
TimeDistinctThread Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItem Class

Glossary Item Box

TimeItem is a time object that is drawn in the gantt

Object Model

TimeItem ClassCalendarEntryCollection ClassCalendarEntry ClassGantt ClassGanttRow ClassLayer ClassTimeItem ClassTimeItemLayout ClassTimeItemTexts ClassTimeItemText Class

Syntax

Visual Basic (Declaration)
Public Class TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
C#
public class TimeItem
Managed Extensions for C++
public __gc class TimeItem
C++/CLI
public ref class TimeItem

Example

C# Copy Code
GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
gn.GetCell(0).Content.Value="Sample of collision detection for time items";
gn.UserReference="...to things you might need...";
GanttRow gr = GanttRow.FromGridNode(gn);
gr.CollisionDetect=true;
TimeItem ti1=gr.Layers[0].AddNewTimeItem();
TimeItem ti2=gr.Layers[0].AddNewTimeItem();
TimeItem ti3=gr.Layers[0].AddNewTimeItem();
ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);
ti1.Stop=ti1.Start.AddDays(2);
ti1.TimeItemLayout= new TimeItemLayout();
ti1.TimeItemLayout.SelectHandles=Color.Black;

ti2.Start=ti1.Stop.AddDays(1);
ti2.Stop=ti2.Start.AddDays(3);
ti2.TimeItemLayout= new TimeItemLayout();
ti2.TimeItemLayout.SelectHandles=Color.Black;
ti2.TimeItemLayout.Color=Color.PaleVioletRed;

ti3.Start=ti2.Stop.AddDays(-1);
ti3.Stop=ti3.Start.AddDays(3);
ti3.TimeItemLayout= new TimeItemLayout();
ti3.TimeItemLayout.SelectHandles=Color.Black;
ti3.TimeItemLayout.Color=Color.PaleGoldenrod;
Visual Basic Copy Code
Dim gn As GridNode=gantt1.Grid.GridStructure.RootNodes.AddNode()
gn.GetCell(0).Content.Value="Sample of collision detection for time items"
gn.UserReference="...to things you might need..."
Dim gr As GanttRow = GanttRow.FromGridNode(gn)
gr.CollisionDetect=True
Dim ti1 As TimeItem=gr.Layers(0).AddNewTimeItem()
Dim ti2 As TimeItem=gr.Layers(0).AddNewTimeItem()
Dim ti3 As TimeItem=gr.Layers(0).AddNewTimeItem()
ti1.Start=gantt1.DateScaler.StartTime.AddDays(1)
ti1.Stop=ti1.Start.AddDays(2)
ti1.TimeItemLayout= New TimeItemLayout()
ti1.TimeItemLayout.SelectHandles=Color.Black

ti2.Start=ti1.Stop.AddDays(1)
ti2.Stop=ti2.Start.AddDays(3)
ti2.TimeItemLayout= New TimeItemLayout()
ti2.TimeItemLayout.SelectHandles=Color.Black
ti2.TimeItemLayout.Color=Color.PaleVioletRed

ti3.Start=ti2.Stop.AddDays(-1)
ti3.Stop=ti3.Start.AddDays(3)
ti3.TimeItemLayout= New TimeItemLayout()
ti3.TimeItemLayout.SelectHandles=Color.Black
ti3.TimeItemLayout.Color=Color.PaleGoldenrod

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItem

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItem Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItem Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItem Class

Glossary Item Box

The following tables list the members exposed by TimeItem.

Public Constructors

 | Name | Description
Public Constructor | TimeItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | BlockingCalendarEntries | When TimeItemLayout has BlockedTimeCalculatedStop=true this collection will hold the Blocking calenderEntries for this time item
Public Property | Gantt | Owning Gantt
Public Property | GanttRow | Owning GanttRow
Public Property | Identity | Identity is used to tie databound timeitemlinks. Set Identity to the primary key for your time items. If the time items are databound; assign the TimeItemDataConnect.NameInDS_Identity to the primary key column of your time item row
Public Property | Index | Index in its Layer's time item list
Public Property | Layer | On what layer is this time item placed
Public Property | Length | If TimeItemLayout.BlockedTimeCalculatedStop==true this property controls the length of the time item. In this case the Stop is strictly calculated from the contents of the TimeItemLayout.BlockedTimeCalendar. Otherwise this property returns the Duration of the TimeItem
Public Property | LinkStartCount | The count of time item links that start in this time item
Public Property | LinkTargetCount | The count of time item links that targets this time item
Public Property | Selected | Is it selected
Public Property | Start | Start date of this time item
Public Property | Stop | Stop date of this time item
Public Property | SubCol | Is it placed on a sub column? If the SubCol value is zero the time item is sized based on row height. If the SubCol value is non zero the time item will be placed just as collisiondetection normally places colliding items, in a sub row. The Number of sub columns/rows is controlled by the GanttRow.SubColumns (int).
Public Property | TimeItemLayout | The resolved TimeItemLayout object
Public Property | TimeItemTexts |
Public Property | UserReference | User reference, use this to tie against your own data
Top

Public Methods

 | Name | Description
Public Method | CheckConflictForTimeItem | Returns the known conflict area for another time item if it exists. Otherwise null.
Public Method | ConflictAreasCount | The number of conflict areas known for this time item. For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true
Public Method | ConflictAreasGet | Returns one indexed ConflictArea For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true. Index must be less than ConflictAreasCount()
Public Method | Draw | Overloaded. draw this time item
Public Method | DrawRect | The rect that the time item should use for drawing
Public Method | Duration | Returns the duration (length in time)
Public Method | GetBoundingRect | Get Bounding Rect
Public Method | GetBoundingRegion | Get Bounding Region
Public Method | Invalidate | Will redraw later
Public Method | LinkStart | Access to one of the time item links that Starts in this item
Public Method | LinkTarget | Access to one of the time item links that target this item
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple
Public Method | MakeSureVisible | If this time item is not currenlty on screen, it will be scrolled into view by this call. If the node will not fit on screen due to to high resolution, the resolution will be adapted
Public Method | Move | Adds a timespan to both Start and stop
Public Method | MoveTo | Moves the time item to a new start, keeping its duration
Public Method | PerformLinkActions | Executes the links actions. This is done automatically on user interactions, but you may call in directly if needed.
Public Method | RawRect | The rect without any care to inset or sub columns taken
Top

See Also

Reference

TimeItem Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : TimeItem Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItem()
C#
public TimeItem()
Managed Extensions for C++
public: TimeItem();
C++/CLI
public:
TimeItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItem Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItem Class

Glossary Item Box

For a list of all members of this type, see TimeItem members.

Public Methods

 | Name | Description
Public Method | CheckConflictForTimeItem | Returns the known conflict area for another time item if it exists. Otherwise null.
Public Method | ConflictAreasCount | The number of conflict areas known for this time item. For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true
Public Method | ConflictAreasGet | Returns one indexed ConflictArea For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true. Index must be less than ConflictAreasCount()
Public Method | Draw | Overloaded. draw this time item
Public Method | DrawRect | The rect that the time item should use for drawing
Public Method | Duration | Returns the duration (length in time)
Public Method | GetBoundingRect | Get Bounding Rect
Public Method | GetBoundingRegion | Get Bounding Region
Public Method | Invalidate | Will redraw later
Public Method | LinkStart | Access to one of the time item links that Starts in this item
Public Method | LinkTarget | Access to one of the time item links that target this item
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple
Public Method | MakeSureVisible | If this time item is not currenlty on screen, it will be scrolled into view by this call. If the node will not fit on screen due to to high resolution, the resolution will be adapted
Public Method | Move | Adds a timespan to both Start and stop
Public Method | MoveTo | Moves the time item to a new start, keeping its duration
Public Method | PerformLinkActions | Executes the links actions. This is done automatically on user interactions, but you may call in directly if needed.
Public Method | RawRect | The rect without any care to inset or sub columns taken
Top

See Also

Reference

TimeItem Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CheckConflictForTimeItem Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : CheckConflictForTimeItem Method

ti

Glossary Item Box

Returns the known conflict area for another time item if it exists. Otherwise null.

Syntax

Visual Basic (Declaration)
Public Function CheckConflictForTimeItem( _
   ByVal ti As TimeItem _
) As ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim ti As TimeItem
Dim value As ConflictArea

value = instance.CheckConflictForTimeItem(ti)
C#
public ConflictArea CheckConflictForTimeItem(
   TimeItem ti
)
Managed Extensions for C++
public: ConflictArea* CheckConflictForTimeItem(
   TimeItem* ti
)
C++/CLI
public:
ConflictArea^ CheckConflictForTimeItem(
   TimeItem^ ti
)

Parameters

ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreasCount Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : ConflictAreasCount Method

Glossary Item Box

The number of conflict areas known for this time item. For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true

Syntax

Visual Basic (Declaration)
Public Function ConflictAreasCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Integer

value = instance.ConflictAreasCount()
C#
public int ConflictAreasCount()
Managed Extensions for C++
public: int ConflictAreasCount();
C++/CLI
public:
int ConflictAreasCount();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreasGet Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : ConflictAreasGet Method

index

Glossary Item Box

Returns one indexed ConflictArea For this call to be meaningful GanttRow.CollisionDetect must be true and GanttRow.CollisionDetect_UseConflictAreas must also be true. Index must be less than ConflictAreasCount()

Syntax

Visual Basic (Declaration)
Public Function ConflictAreasGet( _
   ByVal index As Integer _
) As ConflictArea
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim index As Integer
Dim value As ConflictArea

value = instance.ConflictAreasGet(index)
C#
public ConflictArea ConflictAreasGet(
   int index
)
Managed Extensions for C++
public: ConflictArea* ConflictAreasGet(
   int index
)
C++/CLI
public:
ConflictArea^ ConflictAreasGet(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Draw Method

Glossary Item Box

draw this time item

Overload List

Overload | Description
Draw(Graphics) | draw this time item
Draw(Graphics,Point) | Draw this time item with an offset
Draw(Graphics,Point,Boolean) | Draw this time item with an offset
Draw(Graphics,Point,Rectangle) | Use the drawing caracteristics of this time item but draw in the rect supplied
Draw(Graphics,Point,Rectangle,Boolean) | Use the drawing caracteristics of this time item but draw in the rect supplied

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw(Graphics) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class > Draw Method : Draw(Graphics) Method

G

Glossary Item Box

draw this time item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal G As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim G As Graphics

instance.Draw(G)
C#
public void Draw(
   Graphics G
)
Managed Extensions for C++
public: void Draw(
   Graphics* G
)
C++/CLI
public:
void Draw(
   Graphics^ G
)

Parameters

G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw(Graphics,Point) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class > Draw Method : Draw(Graphics,Point) Method

G
offset

Glossary Item Box

Draw this time item with an offset

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal G As Graphics, _
   ByVal offset As Point _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim G As Graphics
Dim offset As Point

instance.Draw(G, offset)
C#
public void Draw(
   Graphics G,
   Point offset
)
Managed Extensions for C++
public: void Draw(
   Graphics* G,
   Point offset
)
C++/CLI
public:
void Draw(
   Graphics^ G,
   Point offset
)

Parameters

G
offset

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw(Graphics,Point,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class > Draw Method : Draw(Graphics,Point,Boolean) Method

G
offset
restrictOffsetBasedOnAllowMove

Glossary Item Box

Draw this time item with an offset

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal G As Graphics, _
   ByVal offset As Point, _
   ByVal restrictOffsetBasedOnAllowMove As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim G As Graphics
Dim offset As Point
Dim restrictOffsetBasedOnAllowMove As Boolean

instance.Draw(G, offset, restrictOffsetBasedOnAllowMove)
C#
public void Draw(
   Graphics G,
   Point offset,
   bool restrictOffsetBasedOnAllowMove
)
Managed Extensions for C++
public: void Draw(
   Graphics* G,
   Point offset,
   bool restrictOffsetBasedOnAllowMove
)
C++/CLI
public:
void Draw(
   Graphics^ G,
   Point offset,
   bool restrictOffsetBasedOnAllowMove
)

Parameters

G
offset
restrictOffsetBasedOnAllowMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw(Graphics,Point,Rectangle) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class > Draw Method : Draw(Graphics,Point,Rectangle) Method

G
offset
rect

Glossary Item Box

Use the drawing caracteristics of this time item but draw in the rect supplied

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal G As Graphics, _
   ByVal offset As Point, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim G As Graphics
Dim offset As Point
Dim rect As Rectangle

instance.Draw(G, offset, rect)
C#
public void Draw(
   Graphics G,
   Point offset,
   Rectangle rect
)
Managed Extensions for C++
public: void Draw(
   Graphics* G,
   Point offset,
   Rectangle rect
)
C++/CLI
public:
void Draw(
   Graphics^ G,
   Point offset,
   Rectangle rect
)

Parameters

G
offset
rect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw(Graphics,Point,Rectangle,Boolean) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class > Draw Method : Draw(Graphics,Point,Rectangle,Boolean) Method

G
offset
rect
restrictOffsetBasedOnAllowMove

Glossary Item Box

Use the drawing caracteristics of this time item but draw in the rect supplied

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal G As Graphics, _
   ByVal offset As Point, _
   ByVal rect As Rectangle, _
   ByVal restrictOffsetBasedOnAllowMove As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim G As Graphics
Dim offset As Point
Dim rect As Rectangle
Dim restrictOffsetBasedOnAllowMove As Boolean

instance.Draw(G, offset, rect, restrictOffsetBasedOnAllowMove)
C#
public void Draw(
   Graphics G,
   Point offset,
   Rectangle rect,
   bool restrictOffsetBasedOnAllowMove
)
Managed Extensions for C++
public: void Draw(
   Graphics* G,
   Point offset,
   Rectangle rect,
   bool restrictOffsetBasedOnAllowMove
)
C++/CLI
public:
void Draw(
   Graphics^ G,
   Point offset,
   Rectangle rect,
   bool restrictOffsetBasedOnAllowMove
)

Parameters

G
offset
rect
restrictOffsetBasedOnAllowMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawRect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : DrawRect Method

Glossary Item Box

The rect that the time item should use for drawing

Syntax

Visual Basic (Declaration)
Public Function DrawRect() As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Rectangle

value = instance.DrawRect()
C#
public Rectangle DrawRect()
Managed Extensions for C++
public: Rectangle DrawRect();
C++/CLI
public:
Rectangle DrawRect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Duration Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Duration Method

Glossary Item Box

Returns the duration (length in time)

Syntax

Visual Basic (Declaration)
Public Function Duration() As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As TimeSpan

value = instance.Duration()
C#
public TimeSpan Duration()
Managed Extensions for C++
public: TimeSpan Duration();
C++/CLI
public:
TimeSpan Duration();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetBoundingRect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : GetBoundingRect Method

Glossary Item Box

Get Bounding Rect

Syntax

Visual Basic (Declaration)
Public Function GetBoundingRect() As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Rectangle

value = instance.GetBoundingRect()
C#
public Rectangle GetBoundingRect()
Managed Extensions for C++
public: Rectangle GetBoundingRect();
C++/CLI
public:
Rectangle GetBoundingRect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetBoundingRegion Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : GetBoundingRegion Method

Glossary Item Box

Get Bounding Region

Syntax

Visual Basic (Declaration)
Public Function GetBoundingRegion() As Region
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Region

value = instance.GetBoundingRegion()
C#
public Region GetBoundingRegion()
Managed Extensions for C++
public: Region* GetBoundingRegion();
C++/CLI
public:
Region^ GetBoundingRegion();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Invalidate Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Invalidate Method

Glossary Item Box

Will redraw later

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As TimeItem

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkStart Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : LinkStart Method

index

Glossary Item Box

Access to one of the time item links that Starts in this item

Syntax

Visual Basic (Declaration)
Public Function LinkStart( _
   ByVal index As Integer _
) As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim index As Integer
Dim value As TimeItemLink

value = instance.LinkStart(index)
C#
public TimeItemLink LinkStart(
   int index
)
Managed Extensions for C++
public: TimeItemLink* LinkStart(
   int index
)
C++/CLI
public:
TimeItemLink^ LinkStart(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkTarget Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : LinkTarget Method

index

Glossary Item Box

Access to one of the time item links that target this item

Syntax

Visual Basic (Declaration)
Public Function LinkTarget( _
   ByVal index As Integer _
) As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim index As Integer
Dim value As TimeItemLink

value = instance.LinkTarget(index)
C#
public TimeItemLink LinkTarget(
   int index
)
Managed Extensions for C++
public: TimeItemLink* LinkTarget(
   int index
)
C++/CLI
public:
TimeItemLink^ LinkTarget(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListItemWhenDataBound Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : ListItemWhenDataBound Method

Glossary Item Box

Retrieves the corresponding list item object if this layer is databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECO2 this will be a RenderedTuple

Syntax

Visual Basic (Declaration)
Public Function ListItemWhenDataBound() As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Object

value = instance.ListItemWhenDataBound()
C#
public object ListItemWhenDataBound()
Managed Extensions for C++
public: Object* ListItemWhenDataBound();
C++/CLI
public:
Object^ ListItemWhenDataBound();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MakeSureVisible Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : MakeSureVisible Method

Glossary Item Box

If this time item is not currenlty on screen, it will be scrolled into view by this call. If the node will not fit on screen due to to high resolution, the resolution will be adapted

Syntax

Visual Basic (Declaration)
Public Sub MakeSureVisible()
Visual Basic (Usage) Copy Code
Dim instance As TimeItem

instance.MakeSureVisible()
C#
public void MakeSureVisible()
Managed Extensions for C++
public: void MakeSureVisible();
C++/CLI
public:
void MakeSureVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Move Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Move Method

howmuch

Glossary Item Box

Adds a timespan to both Start and stop

Syntax

Visual Basic (Declaration)
Public Sub Move( _
   ByVal howmuch As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim howmuch As TimeSpan

instance.Move(howmuch)
C#
public void Move(
   TimeSpan howmuch
)
Managed Extensions for C++
public: void Move(
   TimeSpan howmuch
)
C++/CLI
public:
void Move(
   TimeSpan howmuch
)

Parameters

howmuch

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
MoveTo Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : MoveTo Method

newStart

Glossary Item Box

Moves the time item to a new start, keeping its duration

Syntax

Visual Basic (Declaration)
Public Sub MoveTo( _
   ByVal newStart As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim newStart As Date

instance.MoveTo(newStart)
C#
public void MoveTo(
   DateTime newStart
)
Managed Extensions for C++
public: void MoveTo(
   DateTime newStart
)
C++/CLI
public:
void MoveTo(
   DateTime newStart
)

Parameters

newStart

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PerformLinkActions Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : PerformLinkActions Method

Glossary Item Box

Executes the links actions. This is done automatically on user interactions, but you may call in directly if needed.

Syntax

Visual Basic (Declaration)
Public Sub PerformLinkActions()
Visual Basic (Usage) Copy Code
Dim instance As TimeItem

instance.PerformLinkActions()
C#
public void PerformLinkActions()
Managed Extensions for C++
public: void PerformLinkActions();
C++/CLI
public:
void PerformLinkActions();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
RawRect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : RawRect Method

Glossary Item Box

The rect without any care to inset or sub columns taken

Syntax

Visual Basic (Declaration)
Public Function RawRect() As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Rectangle

value = instance.RawRect()
C#
public Rectangle RawRect()
Managed Extensions for C++
public: Rectangle RawRect();
C++/CLI
public:
Rectangle RawRect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItem Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItem Class

Glossary Item Box

For a list of all members of this type, see TimeItem members.

Public Properties

 | Name | Description
Public Property | BlockingCalendarEntries | When TimeItemLayout has BlockedTimeCalculatedStop=true this collection will hold the Blocking calenderEntries for this time item
Public Property | Gantt | Owning Gantt
Public Property | GanttRow | Owning GanttRow
Public Property | Identity | Identity is used to tie databound timeitemlinks. Set Identity to the primary key for your time items. If the time items are databound; assign the TimeItemDataConnect.NameInDS_Identity to the primary key column of your time item row
Public Property | Index | Index in its Layer's time item list
Public Property | Layer | On what layer is this time item placed
Public Property | Length | If TimeItemLayout.BlockedTimeCalculatedStop==true this property controls the length of the time item. In this case the Stop is strictly calculated from the contents of the TimeItemLayout.BlockedTimeCalendar. Otherwise this property returns the Duration of the TimeItem
Public Property | LinkStartCount | The count of time item links that start in this time item
Public Property | LinkTargetCount | The count of time item links that targets this time item
Public Property | Selected | Is it selected
Public Property | Start | Start date of this time item
Public Property | Stop | Stop date of this time item
Public Property | SubCol | Is it placed on a sub column? If the SubCol value is zero the time item is sized based on row height. If the SubCol value is non zero the time item will be placed just as collisiondetection normally places colliding items, in a sub row. The Number of sub columns/rows is controlled by the GanttRow.SubColumns (int).
Public Property | TimeItemLayout | The resolved TimeItemLayout object
Public Property | TimeItemTexts |
Public Property | UserReference | User reference, use this to tie against your own data
Top

See Also

Reference

TimeItem Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BlockingCalendarEntries Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : BlockingCalendarEntries Property

Glossary Item Box

When TimeItemLayout has BlockedTimeCalculatedStop=true this collection will hold the Blocking calenderEntries for this time item

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BlockingCalendarEntries As CalendarEntryCollection
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As CalendarEntryCollection

value = instance.BlockingCalendarEntries
C#
public CalendarEntryCollection BlockingCalendarEntries {get;}
Managed Extensions for C++
public: __property CalendarEntryCollection* get_BlockingCalendarEntries();
C++/CLI
public:
property CalendarEntryCollection^ BlockingCalendarEntries {
   CalendarEntryCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Gantt Property

Glossary Item Box

Owning Gantt

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Gantt As Gantt
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Gantt

value = instance.Gantt
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Gantt Gantt {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Gantt* get_Gantt();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Gantt^ Gantt {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GanttRow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : GanttRow Property

Glossary Item Box

Owning GanttRow

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property GanttRow As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As GanttRow

value = instance.GanttRow
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public GanttRow GanttRow {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property GanttRow* get_GanttRow();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property GanttRow^ GanttRow {
   GanttRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Identity Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Identity Property

Glossary Item Box

Identity is used to tie databound timeitemlinks. Set Identity to the primary key for your time items. If the time items are databound; assign the TimeItemDataConnect.NameInDS_Identity to the primary key column of your time item row

Syntax

Visual Basic (Declaration)
Public Property Identity As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As String

instance.Identity = value

value = instance.Identity
C#
public string Identity {get; set;}
Managed Extensions for C++
public: __property string* get_Identity();
public: __property void set_Identity(
   string* value
);
C++/CLI
public:
property String^ Identity {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Index Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Index Property

Glossary Item Box

Index in its Layer's time item list

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Layer Property

Glossary Item Box

On what layer is this time item placed

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Layer As Layer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Layer

value = instance.Layer
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Layer Layer {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Layer* get_Layer();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Layer^ Layer {
   Layer^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Length Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Length Property

Glossary Item Box

If TimeItemLayout.BlockedTimeCalculatedStop==true this property controls the length of the time item. In this case the Stop is strictly calculated from the contents of the TimeItemLayout.BlockedTimeCalendar. Otherwise this property returns the Duration of the TimeItem

Syntax

Visual Basic (Declaration)
Public Property Length As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As TimeSpan

instance.Length = value

value = instance.Length
C#
public TimeSpan Length {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_Length();
public: __property void set_Length(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan Length {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkStartCount Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : LinkStartCount Property

Glossary Item Box

The count of time item links that start in this time item

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinkStartCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Integer

value = instance.LinkStartCount
C#
public int LinkStartCount {get;}
Managed Extensions for C++
public: __property int get_LinkStartCount();
C++/CLI
public:
property int LinkStartCount {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkTargetCount Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : LinkTargetCount Property

Glossary Item Box

The count of time item links that targets this time item

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinkTargetCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Integer

value = instance.LinkTargetCount
C#
public int LinkTargetCount {get;}
Managed Extensions for C++
public: __property int get_LinkTargetCount();
C++/CLI
public:
property int LinkTargetCount {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Selected Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Selected Property

Glossary Item Box

Is it selected

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
public bool Selected {get; set;}
Managed Extensions for C++
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
C++/CLI
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Start Property

Glossary Item Box

Start date of this time item

Syntax

Visual Basic (Declaration)
Public Property Start As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}
Managed Extensions for C++
public: __property DateTime get_Start();
public: __property void set_Start(
   DateTime value
);
C++/CLI
public:
property DateTime Start {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Stop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : Stop Property

Glossary Item Box

Stop date of this time item

Syntax

Visual Basic (Declaration)
Public Property Stop As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Date

instance.Stop = value

value = instance.Stop
C#
public DateTime Stop {get; set;}
Managed Extensions for C++
public: __property DateTime get_Stop();
public: __property void set_Stop(
   DateTime value
);
C++/CLI
public:
property DateTime Stop {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SubCol Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : SubCol Property

Glossary Item Box

Is it placed on a sub column? If the SubCol value is zero the time item is sized based on row height. If the SubCol value is non zero the time item will be placed just as collisiondetection normally places colliding items, in a sub row. The Number of sub columns/rows is controlled by the GanttRow.SubColumns (int).

Syntax

Visual Basic (Declaration)
Public Property SubCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Integer

instance.SubCol = value

value = instance.SubCol
C#
public int SubCol {get; set;}
Managed Extensions for C++
public: __property int get_SubCol();
public: __property void set_SubCol(
   int value
);
C++/CLI
public:
property int SubCol {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayout Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : TimeItemLayout Property

Glossary Item Box

The resolved TimeItemLayout object

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property TimeItemLayout As TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As TimeItemLayout

instance.TimeItemLayout = value

value = instance.TimeItemLayout
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public TimeItemLayout TimeItemLayout {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property TimeItemLayout* get_TimeItemLayout();
public: __property void set_TimeItemLayout(
   TimeItemLayout* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property TimeItemLayout^ TimeItemLayout {
   TimeItemLayout^ get();
   void set (    TimeItemLayout^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : TimeItemTexts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property TimeItemTexts As TimeItemTexts
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As TimeItemTexts

value = instance.TimeItemTexts
C#
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TimeItemTexts TimeItemTexts {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property TimeItemTexts* get_TimeItemTexts();
C++/CLI
[EditorAttribute(EditorBaseTypeName="UITypeEditor", EditorTypeName="CollectionEditor")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property TimeItemTexts^ TimeItemTexts {
   TimeItemTexts^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItem Class : UserReference Property

Glossary Item Box

User reference, use this to tie against your own data

Syntax

Visual Basic (Declaration)
Public Property UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItem
Dim value As Object

instance.UserReference = value

value = instance.UserReference
C#
public object UserReference {get; set;}
Managed Extensions for C++
public: __property Object* get_UserReference();
public: __property void set_UserReference(
   Object* value
);
C++/CLI
public:
property Object^ UserReference {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItem Class
TimeItem Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemAndDSArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemAndDSArgs Class

Glossary Item Box

Arguments for time item data events

Object Model

TimeItemAndDSArgs Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemAndDSArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
C#
public class TimeItemAndDSArgs : System.EventArgs
Managed Extensions for C++
public __gc class TimeItemAndDSArgs : public System.EventArgs
C++/CLI
public ref class TimeItemAndDSArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.TimeItemAndDSArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemAndDSArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemAndDSArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemAndDSArgs Class

Glossary Item Box

The following tables list the members exposed by TimeItemAndDSArgs.

Public Constructors

 | Name | Description
Public Constructor | TimeItemAndDSArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GoOnSetValue | In the OnBeforeTimeItemToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.
Public Field | PropertyDescriptorInDS | The column from the currency manager
Public Field | TimeItem | The time item in question for the current data operation
Public Field | Value | The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource
Top

See Also

Reference

TimeItemAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemAndDSArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : TimeItemAndDSArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemAndDSArgs()
C#
public TimeItemAndDSArgs()
Managed Extensions for C++
public: TimeItemAndDSArgs();
C++/CLI
public:
TimeItemAndDSArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
TimeItemAndDSArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemAndDSArgs Class

Glossary Item Box

For a list of all members of this type, see TimeItemAndDSArgs members.

Public Fields

 | Name | Description
Public Field | CurrencyManagerListItem | The row from the currency manager
Public Field | GoOnSetValue | In the OnBeforeTimeItemToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.
Public Field | PropertyDescriptorInDS | The column from the currency manager
Public Field | TimeItem | The time item in question for the current data operation
Public Field | Value | The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource
Top

See Also

Reference

TimeItemAndDSArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManagerListItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : CurrencyManagerListItem Field

Glossary Item Box

The row from the currency manager

Syntax

Visual Basic (Declaration)
Public CurrencyManagerListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
Dim value As Object

value = instance.CurrencyManagerListItem

instance.CurrencyManagerListItem = value
C#
public object CurrencyManagerListItem
Managed Extensions for C++
public: Object* CurrencyManagerListItem
C++/CLI
public:
Object^ CurrencyManagerListItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GoOnSetValue Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : GoOnSetValue Field

Glossary Item Box

In the OnBeforeTimeItemToDS event, if you set this property to false (default true), the actual apply of the value to the DataSource will be ignored.

Syntax

Visual Basic (Declaration)
Public GoOnSetValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
Dim value As Boolean

value = instance.GoOnSetValue

instance.GoOnSetValue = value
C#
public bool GoOnSetValue
Managed Extensions for C++
public: bool GoOnSetValue
C++/CLI
public:
bool GoOnSetValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PropertyDescriptorInDS Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : PropertyDescriptorInDS Field

Glossary Item Box

The column from the currency manager

Syntax

Visual Basic (Declaration)
Public PropertyDescriptorInDS As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
Dim value As PropertyDescriptor

value = instance.PropertyDescriptorInDS

instance.PropertyDescriptorInDS = value
C#
public PropertyDescriptor PropertyDescriptorInDS
Managed Extensions for C++
public: PropertyDescriptor* PropertyDescriptorInDS
C++/CLI
public:
PropertyDescriptor^ PropertyDescriptorInDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : TimeItem Field

Glossary Item Box

The time item in question for the current data operation

Syntax

Visual Basic (Declaration)
Public TimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
Dim value As TimeItem

value = instance.TimeItem

instance.TimeItem = value
C#
public TimeItem TimeItem
Managed Extensions for C++
public: TimeItem* TimeItem
C++/CLI
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Value Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemAndDSArgs Class : Value Field

Glossary Item Box

The value of the property, you can override this but make sure you have a valid type for the Time Item and you datasource

Syntax

Visual Basic (Declaration)
Public Value As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemAndDSArgs
Dim value As Object

value = instance.Value

instance.Value = value
C#
public object Value
Managed Extensions for C++
public: Object* Value
C++/CLI
public:
Object^ Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemAndDSArgs Class
TimeItemAndDSArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemDataConnect Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDataConnect Class

Glossary Item Box

TimeItemDataConnect coordinates info between a list of timeitems (a layer) and a dataSource

Object Model

TimeItemDataConnect ClassLayer ClassTimeItem Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemDataConnect
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
C#
public class TimeItemDataConnect
Managed Extensions for C++
public __gc class TimeItemDataConnect
C++/CLI
public ref class TimeItemDataConnect

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemDataConnect

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemDataConnect Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemDataConnect Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDataConnect Class

Glossary Item Box

The following tables list the members exposed by TimeItemDataConnect.

Public Properties

 | Name | Description
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource | This IListSource will be used for binding and for a particular Layer and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding and for a particular Layer and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since the DataSource property takes any object...
Public Property | HouseKeeping | This property is true whenever the TimeItemDataConnect is adding/removing or changing time items to keep up with the DataSourceList
Public Property | Layer |
Top

Public Methods

 | Name | Description
Public Method | ReBind | This method re-binds to the datasource. It clears all time items in the Layer and creates new time items from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time items, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the Layer that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.
Top

Public Events

 | Name | Description
Public Event | OnBeforeDSToTimeItem | Fires before transfer of data from dataset do timeitem, do conversions here
Public Event | OnBeforeTimeItemToDS | Fires before transfer of data from timeitem do dataset, do conversions here
Top

See Also

Reference

TimeItemDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemDataConnect Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDataConnect Class

Glossary Item Box

For a list of all members of this type, see TimeItemDataConnect members.

Public Methods

 | Name | Description
Public Method | ReBind | This method re-binds to the datasource. It clears all time items in the Layer and creates new time items from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time items, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the Layer that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.
Top

See Also

Reference

TimeItemDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReBind Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : ReBind Method

Glossary Item Box

This method re-binds to the datasource. It clears all time items in the Layer and creates new time items from the datasource This call is completely un-necessary if your bounded list implements the IBindingList interface The call is un-efficient if you have many time items, but if your bounded list only fulfills the IList interface (and not IBindingList) you must yourself announce to the Layer that the content of the list has changed (Adding, Deleting, and Moving changes the list content). (ArrayList only implements IList). Much of the elegancy with databinding is to automatically track added and deleted items of the list so that the GUI can be kept separated from the business logic. The recommendation is that you bind to a list that implements IBindingList.

Syntax

Visual Basic (Declaration)
Public Sub ReBind()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect

instance.ReBind()
C#
public void ReBind()
Managed Extensions for C++
public: void ReBind();
C++/CLI
public:
void ReBind();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemDataConnect Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDataConnect Class

Glossary Item Box

For a list of all members of this type, see TimeItemDataConnect members.

Public Properties

 | Name | Description
Public Property | CurrencyManager | Returns the current currency manager
Public Property | DataMember |
Public Property | DataSource | This IListSource will be used for binding and for a particular Layer and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.
Public Property | DataSourceList | This IList will be used for binding and for a particular Layer and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since the DataSource property takes any object...
Public Property | HouseKeeping | This property is true whenever the TimeItemDataConnect is adding/removing or changing time items to keep up with the DataSourceList
Public Property | Layer |
Top

See Also

Reference

TimeItemDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CurrencyManager Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : CurrencyManager Property

Glossary Item Box

Returns the current currency manager

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrencyManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As CurrencyManager

value = instance.CurrencyManager
C#
public CurrencyManager CurrencyManager {get;}
Managed Extensions for C++
public: __property CurrencyManager* get_CurrencyManager();
C++/CLI
public:
property CurrencyManager^ CurrencyManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : DataMember Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : DataSource Property

Glossary Item Box

This IListSource will be used for binding and for a particular Layer and hold time items DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing.

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public object DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSourceList Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : DataSourceList Property

Glossary Item Box

This IList will be used for binding and for a particular Layer and hold time items. DataSourceList Takes an IList and DataSource takes an IListSource they are otherwise the same thing. Deprecated since the DataSource property takes any object...

Syntax

Visual Basic (Declaration)
Public Property DataSourceList As IList
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As IList

instance.DataSourceList = value

value = instance.DataSourceList
C#
public IList DataSourceList {get; set;}
Managed Extensions for C++
public: __property IList* get_DataSourceList();
public: __property void set_DataSourceList(
   IList* value
);
C++/CLI
public:
property IList^ DataSourceList {
   IList^ get();
   void set (    IList^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HouseKeeping Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : HouseKeeping Property

Glossary Item Box

This property is true whenever the TimeItemDataConnect is adding/removing or changing time items to keep up with the DataSourceList

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HouseKeeping As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As Boolean

value = instance.HouseKeeping
C#
public bool HouseKeeping {get;}
Managed Extensions for C++
public: __property bool get_HouseKeeping();
C++/CLI
public:
property bool HouseKeeping {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : Layer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Layer As Layer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim value As Layer

instance.Layer = value

value = instance.Layer
C#
public Layer Layer {get; set;}
Managed Extensions for C++
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
C++/CLI
public:
property Layer^ Layer {
   Layer^ get();
   void set (    Layer^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
TimeItemDataConnect Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDataConnect Class

Glossary Item Box

For a list of all members of this type, see TimeItemDataConnect members.

Public Events

 | Name | Description
Public Event | OnBeforeDSToTimeItem | Fires before transfer of data from dataset do timeitem, do conversions here
Public Event | OnBeforeTimeItemToDS | Fires before transfer of data from timeitem do dataset, do conversions here
Top

See Also

Reference

TimeItemDataConnect Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeDSToTimeItem Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : OnBeforeDSToTimeItem Event

Glossary Item Box

Fires before transfer of data from dataset do timeitem, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeDSToTimeItem As TimeItemToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim handler As TimeItemToDSEventHandler

AddHandler instance.OnBeforeDSToTimeItem, handler
C#
public event TimeItemToDSEventHandler OnBeforeDSToTimeItem
Managed Extensions for C++
public: __event TimeItemToDSEventHandler* OnBeforeDSToTimeItem
C++/CLI
public:
event TimeItemToDSEventHandler^ OnBeforeDSToTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnBeforeTimeItemToDS Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDataConnect Class : OnBeforeTimeItemToDS Event

Glossary Item Box

Fires before transfer of data from timeitem do dataset, do conversions here

Syntax

Visual Basic (Declaration)
Public Event OnBeforeTimeItemToDS As TimeItemToDSEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDataConnect
Dim handler As TimeItemToDSEventHandler

AddHandler instance.OnBeforeTimeItemToDS, handler
C#
public event TimeItemToDSEventHandler OnBeforeTimeItemToDS
Managed Extensions for C++
public: __event TimeItemToDSEventHandler* OnBeforeTimeItemToDS
C++/CLI
public:
event TimeItemToDSEventHandler^ OnBeforeTimeItemToDS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDataConnect Class
TimeItemDataConnect Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemDraw Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDraw Class

Glossary Item Box

Class that holds drawing styles of time items

Object Model

TimeItemDraw Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemDraw
Visual Basic (Usage) Copy Code
Dim instance As TimeItemDraw
C#
public class TimeItemDraw
Managed Extensions for C++
public __gc class TimeItemDraw
C++/CLI
public ref class TimeItemDraw

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemDraw

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemDraw Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemDraw Class Members
See Also Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDraw Class

Glossary Item Box

The following tables list the members exposed by TimeItemDraw.

Public Constructors

 | Name | Description
Public Constructor | TimeItemDraw Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw | Draws one time item
static (Shared in Visual Basic) | Select | Handles selection visualization of TimeItem
Top

See Also

Reference

TimeItemDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemDraw Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDraw Class : TimeItemDraw Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemDraw()
C#
public TimeItemDraw()
Managed Extensions for C++
public: TimeItemDraw();
C++/CLI
public:
TimeItemDraw();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDraw Class
TimeItemDraw Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemDraw Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemDraw Class

Glossary Item Box

For a list of all members of this type, see TimeItemDraw members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Draw | Draws one time item
static (Shared in Visual Basic) | Select | Handles selection visualization of TimeItem
Top

See Also

Reference

TimeItemDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Draw Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDraw Class : Draw Method

G
aTimeItem
rect
selected
aTimeItemLayout

Glossary Item Box

Draws one time item

Syntax

Visual Basic (Declaration)
Public Shared Sub Draw( _
   ByVal G As Graphics, _
   ByVal aTimeItem As TimeItem, _
   ByVal rect As Rectangle, _
   ByVal selected As Boolean, _
   ByVal aTimeItemLayout As TimeItemLayout _
)
Visual Basic (Usage) Copy Code
Dim G As Graphics
Dim aTimeItem As TimeItem
Dim rect As Rectangle
Dim selected As Boolean
Dim aTimeItemLayout As TimeItemLayout

TimeItemDraw.Draw(G, aTimeItem, rect, selected, aTimeItemLayout)
C#
public static void Draw(
   Graphics G,
   TimeItem aTimeItem,
   Rectangle rect,
   bool selected,
   TimeItemLayout aTimeItemLayout
)
Managed Extensions for C++
public: static void Draw(
   Graphics* G,
   TimeItem* aTimeItem,
   Rectangle rect,
   bool selected,
   TimeItemLayout* aTimeItemLayout
)
C++/CLI
public:
static void Draw(
   Graphics^ G,
   TimeItem^ aTimeItem,
   Rectangle rect,
   bool selected,
   TimeItemLayout^ aTimeItemLayout
)

Parameters

G
aTimeItem
rect
selected
aTimeItemLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDraw Class
TimeItemDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Select Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemDraw Class : Select Method

G
rect
aTimeItemLayout

Glossary Item Box

Handles selection visualization of TimeItem

Syntax

Visual Basic (Declaration)
Public Shared Sub Select( _
   ByVal G As Graphics, _
   ByVal rect As Rectangle, _
   ByVal aTimeItemLayout As TimeItemLayout _
)
Visual Basic (Usage) Copy Code
Dim G As Graphics
Dim rect As Rectangle
Dim aTimeItemLayout As TimeItemLayout

TimeItemDraw.Select(G, rect, aTimeItemLayout)
C#
public static void Select(
   Graphics G,
   Rectangle rect,
   TimeItemLayout aTimeItemLayout
)
Managed Extensions for C++
public: static void Select(
   Graphics* G,
   Rectangle rect,
   TimeItemLayout* aTimeItemLayout
)
C++/CLI
public:
static void Select(
   Graphics^ G,
   Rectangle rect,
   TimeItemLayout^ aTimeItemLayout
)

Parameters

G
rect
aTimeItemLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemDraw Class
TimeItemDraw Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemEventArgs Class

Glossary Item Box

Time item event args

Object Model

TimeItemEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
C#
public class TimeItemEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class TimeItemEventArgs : public System.EventArgs
C++/CLI
public ref class TimeItemEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.TimeItemEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemEventArgs Class

Glossary Item Box

The following tables list the members exposed by TimeItemEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TimeItemEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Allow | You can abort the started operation by changing Allowed to false
Public Field | BoundingRectangle | Only assigned for user draw, if you want use non-rectangle shapes
Public Field | BoundingRegion | Only assigned for user draw, if you want use non-rectangle shapes
Public Field | Diff | Move or resize operation sets the Diff= moved pixels converted to datetime
Public Field | G | Only assigned for user draw
Public Field | IsShadow | This property is defined for OnTimeItem_UserDraw. If true, the Shadow of the time item should be drawn, if false draw the content of the time item. Shadow will be drawn(called) first, so any content drawn after will erase shadow pixels.
Public Field | LinkTargetTimeItem | If this is a linking operation then this is the time item to link to
Public Field | LinkUnderEdit | If this property is assigned (not null) in the OnTimeItem_LinkCreate event, this was a re-assign rather than a create.
Public Field | NewGanttRow | If a row switch was initiated by the user, this value tells you which row the time item will end up on. In the OnTimeItem_Move event this value is equal to null if no row switch is about to happen. In the OnTimeItem_ChangeRow event this value is the new GanttRow, e.TimeItem.GanttRow is the old/current GanttRow You can use the OnTimeItem_Move event and check if e.NewGanttRow != null and e.NewGanttRow != e.TimeItem.GanttRow to detect that a row change is about to be executed In both these events you can change the value of NewGanttRow and hence do "strange things" like move to another place than the user suggested...
Public Field | Rect | Only assigned for user draw
Public Field | TimeItem | The time item under the current mouse position, might be null
Public Field | TimeItemPropertyChange_NewLengthValue | This is where the new value is available for the OnTimeItem_LengthChange event. You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value
Public Field | TimeItemPropertyChange_NewValue | This is where the new Value is available in the OnTimeItem_StartChange and OnTimeItem_StopChange events You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value
Public Field | x | Mouse x pos
Public Field | y | Mouse y pos
Top

See Also

Reference

TimeItemEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : TimeItemEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemEventArgs()
C#
public TimeItemEventArgs()
Managed Extensions for C++
public: TimeItemEventArgs();
C++/CLI
public:
TimeItemEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
TimeItemEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemEventArgs Class

Glossary Item Box

For a list of all members of this type, see TimeItemEventArgs members.

Public Fields

 | Name | Description
Public Field | Allow | You can abort the started operation by changing Allowed to false
Public Field | BoundingRectangle | Only assigned for user draw, if you want use non-rectangle shapes
Public Field | BoundingRegion | Only assigned for user draw, if you want use non-rectangle shapes
Public Field | Diff | Move or resize operation sets the Diff= moved pixels converted to datetime
Public Field | G | Only assigned for user draw
Public Field | IsShadow | This property is defined for OnTimeItem_UserDraw. If true, the Shadow of the time item should be drawn, if false draw the content of the time item. Shadow will be drawn(called) first, so any content drawn after will erase shadow pixels.
Public Field | LinkTargetTimeItem | If this is a linking operation then this is the time item to link to
Public Field | LinkUnderEdit | If this property is assigned (not null) in the OnTimeItem_LinkCreate event, this was a re-assign rather than a create.
Public Field | NewGanttRow | If a row switch was initiated by the user, this value tells you which row the time item will end up on. In the OnTimeItem_Move event this value is equal to null if no row switch is about to happen. In the OnTimeItem_ChangeRow event this value is the new GanttRow, e.TimeItem.GanttRow is the old/current GanttRow You can use the OnTimeItem_Move event and check if e.NewGanttRow != null and e.NewGanttRow != e.TimeItem.GanttRow to detect that a row change is about to be executed In both these events you can change the value of NewGanttRow and hence do "strange things" like move to another place than the user suggested...
Public Field | Rect | Only assigned for user draw
Public Field | TimeItem | The time item under the current mouse position, might be null
Public Field | TimeItemPropertyChange_NewLengthValue | This is where the new value is available for the OnTimeItem_LengthChange event. You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value
Public Field | TimeItemPropertyChange_NewValue | This is where the new Value is available in the OnTimeItem_StartChange and OnTimeItem_StopChange events You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value
Public Field | x | Mouse x pos
Public Field | y | Mouse y pos
Top

See Also

Reference

TimeItemEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Allow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : Allow Field

Glossary Item Box

You can abort the started operation by changing Allowed to false

Syntax

Visual Basic (Declaration)
Public Allow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Boolean

value = instance.Allow

instance.Allow = value
C#
public bool Allow
Managed Extensions for C++
public: bool Allow
C++/CLI
public:
bool Allow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BoundingRectangle Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : BoundingRectangle Field

Glossary Item Box

Only assigned for user draw, if you want use non-rectangle shapes

Syntax

Visual Basic (Declaration)
Public BoundingRectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Rectangle

value = instance.BoundingRectangle

instance.BoundingRectangle = value
C#
public Rectangle BoundingRectangle
Managed Extensions for C++
public: Rectangle BoundingRectangle
C++/CLI
public:
Rectangle BoundingRectangle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BoundingRegion Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : BoundingRegion Field

Glossary Item Box

Only assigned for user draw, if you want use non-rectangle shapes

Syntax

Visual Basic (Declaration)
Public BoundingRegion As Region
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Region

value = instance.BoundingRegion

instance.BoundingRegion = value
C#
public Region BoundingRegion
Managed Extensions for C++
public: Region* BoundingRegion
C++/CLI
public:
Region^ BoundingRegion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Diff Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : Diff Field

Glossary Item Box

Move or resize operation sets the Diff= moved pixels converted to datetime

Syntax

Visual Basic (Declaration)
Public Diff As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As TimeSpan

value = instance.Diff

instance.Diff = value
C#
public TimeSpan Diff
Managed Extensions for C++
public: TimeSpan Diff
C++/CLI
public:
TimeSpan Diff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : G Field

Glossary Item Box

Only assigned for user draw

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IsShadow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : IsShadow Field

Glossary Item Box

This property is defined for OnTimeItem_UserDraw. If true, the Shadow of the time item should be drawn, if false draw the content of the time item. Shadow will be drawn(called) first, so any content drawn after will erase shadow pixels.

Syntax

Visual Basic (Declaration)
Public IsShadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Boolean

value = instance.IsShadow

instance.IsShadow = value
C#
public bool IsShadow
Managed Extensions for C++
public: bool IsShadow
C++/CLI
public:
bool IsShadow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkTargetTimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : LinkTargetTimeItem Field

Glossary Item Box

If this is a linking operation then this is the time item to link to

Syntax

Visual Basic (Declaration)
Public LinkTargetTimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As TimeItem

value = instance.LinkTargetTimeItem

instance.LinkTargetTimeItem = value
C#
public TimeItem LinkTargetTimeItem
Managed Extensions for C++
public: TimeItem* LinkTargetTimeItem
C++/CLI
public:
TimeItem^ LinkTargetTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkUnderEdit Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : LinkUnderEdit Field

Glossary Item Box

If this property is assigned (not null) in the OnTimeItem_LinkCreate event, this was a re-assign rather than a create.

Syntax

Visual Basic (Declaration)
Public LinkUnderEdit As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As TimeItemLink

value = instance.LinkUnderEdit

instance.LinkUnderEdit = value
C#
public TimeItemLink LinkUnderEdit
Managed Extensions for C++
public: TimeItemLink* LinkUnderEdit
C++/CLI
public:
TimeItemLink^ LinkUnderEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NewGanttRow Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : NewGanttRow Field

Glossary Item Box

If a row switch was initiated by the user, this value tells you which row the time item will end up on. In the OnTimeItem_Move event this value is equal to null if no row switch is about to happen. In the OnTimeItem_ChangeRow event this value is the new GanttRow, e.TimeItem.GanttRow is the old/current GanttRow You can use the OnTimeItem_Move event and check if e.NewGanttRow != null and e.NewGanttRow != e.TimeItem.GanttRow to detect that a row change is about to be executed In both these events you can change the value of NewGanttRow and hence do "strange things" like move to another place than the user suggested...

Syntax

Visual Basic (Declaration)
Public NewGanttRow As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As GanttRow

value = instance.NewGanttRow

instance.NewGanttRow = value
C#
public GanttRow NewGanttRow
Managed Extensions for C++
public: GanttRow* NewGanttRow
C++/CLI
public:
GanttRow^ NewGanttRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rect Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : Rect Field

Glossary Item Box

Only assigned for user draw

Syntax

Visual Basic (Declaration)
Public Rect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Rectangle

value = instance.Rect

instance.Rect = value
C#
public Rectangle Rect
Managed Extensions for C++
public: Rectangle Rect
C++/CLI
public:
Rectangle Rect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : TimeItem Field

Glossary Item Box

The time item under the current mouse position, might be null

Syntax

Visual Basic (Declaration)
Public TimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As TimeItem

value = instance.TimeItem

instance.TimeItem = value
C#
public TimeItem TimeItem
Managed Extensions for C++
public: TimeItem* TimeItem
C++/CLI
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemPropertyChange_NewLengthValue Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : TimeItemPropertyChange_NewLengthValue Field

Glossary Item Box

This is where the new value is available for the OnTimeItem_LengthChange event. You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value

Syntax

Visual Basic (Declaration)
Public TimeItemPropertyChange_NewLengthValue As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As TimeSpan

value = instance.TimeItemPropertyChange_NewLengthValue

instance.TimeItemPropertyChange_NewLengthValue = value
C#
public TimeSpan TimeItemPropertyChange_NewLengthValue
Managed Extensions for C++
public: TimeSpan TimeItemPropertyChange_NewLengthValue
C++/CLI
public:
TimeSpan TimeItemPropertyChange_NewLengthValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemPropertyChange_NewValue Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : TimeItemPropertyChange_NewValue Field

Glossary Item Box

This is where the new Value is available in the OnTimeItem_StartChange and OnTimeItem_StopChange events You can inspect the value and possibly change it. You can also set Allow=false in wich case new value will be set to the original value

Syntax

Visual Basic (Declaration)
Public TimeItemPropertyChange_NewValue As Date
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Date

value = instance.TimeItemPropertyChange_NewValue

instance.TimeItemPropertyChange_NewValue = value
C#
public DateTime TimeItemPropertyChange_NewValue
Managed Extensions for C++
public: DateTime TimeItemPropertyChange_NewValue
C++/CLI
public:
DateTime TimeItemPropertyChange_NewValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
x Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : x Field

Glossary Item Box

Mouse x pos

Syntax

Visual Basic (Declaration)
Public x As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Integer

value = instance.x

instance.x = value
C#
public int x
Managed Extensions for C++
public: int x
C++/CLI
public:
int x

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
y Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemEventArgs Class : y Field

Glossary Item Box

Mouse y pos

Syntax

Visual Basic (Declaration)
Public y As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemEventArgs
Dim value As Integer

value = instance.y

instance.y = value
C#
public int y
Managed Extensions for C++
public: int y
C++/CLI
public:
int y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemEventArgs Class
TimeItemEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayout Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayout Class

Glossary Item Box

Holds all the properties that define the layout time item rendering. For example; To show a time item of type Image do like this: First you must assign an imagelist with your images to Gantt.ImageList. Then assign a timeitemlayout to the time item, with TimeItemStyle=Image, and the TimeItemLayout.ImageIndex you set to the index in the imagelist

Object Model

TimeItemLayout ClassCalendar ClassTimeItemLayouts ClassTimeItemLayout Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.TimeItemLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
C#
[TypeConverterAttribute("PlexityHide.GTP.TimeItemLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class TimeItemLayout
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.TimeItemLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class TimeItemLayout
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.TimeItemLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class TimeItemLayout

Example

TimeItem Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemLayout

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLayout Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemLayout Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayout Class

Glossary Item Box

The following tables list the members exposed by TimeItemLayout.

Public Constructors

 | Name | Description
Public Constructor | TimeItemLayout Constructor | Constructor for a time item layout
Top

Public Properties

 | Name | Description
Public Property | AllowChangeRow | Limits the degrees of freedom available to user
Public Property | AllowLinkReAssignStart | Controls if link re-assign can be done for the start of a link
Public Property | AllowLinkReAssignTarget | Controls if link re-assign can be done for the target of a link
Public Property | AllowLinkSelectionStart | Controls if link selection can be done for the start of a link
Public Property | AllowLinkSelectionTarget | Controls if link selection can be done for the targer of a link
Public Property | AllowMove | Limits the degrees of freedom available to user
Public Property | AllowResizeEast | Limits the degrees of freedom available to user
Public Property | AllowResizeWest | Limits the degrees of freedom available to user
Public Property | BlockedTimeCalculatedStop | TimeItems that use this TimeItemLayout will use a calculated stop date based on TimeItem Length and the contents of this timeitemlayout's BlockedTimeCalendar.
Public Property | BlockedTimeCalendar | Assign one of the Gantt's Calendars to this property and set BlockedTimeCalculatedStop=true and the calendar entries will be treated as blocked time for time items using this layout
Public Property | BlockedTimeShow | When using blocked time you can optionally visualize the blocked areas that effect a given time item.
Public Property | BottomInset | Percent inset from bottom of original drawing rect
Public Property | BrushKind | Choose brushkind
Public Property | Color | Background color
Public Property | ConflictAreaColor | ConflictAreaColor
Public Property | ConflictAreaDrawStyle | ConflictAreaDrawStyle
Public Property | ConflictAreaHatchStyle | ConflictAreaHatchStyle
Public Property | DrawDetailsEvenForVerySmallTimeItems | If a time item is very small (less or equal to two pixels high, or two pixels wide ) the details of the time item may not be visible on screen. So if the details are not visible we might as well skip drawing them. We will skip drawing small time item details, like TimeItemTexts etc if this property is true (default). Instead we just draw a rectangle filled with the solid background color.
Public Property | ExtraAddOnDraw | When ExtraAddOnDraw is true, the time item will be drawn with the TimeItemStyle, but then the OnTimeItem_UserDraw will also be called so that you can do some additional add on drawing
Public Property | FixedSize | Fixed size will not allow resize, and will not stretch on zooming
Public Property | FixedSizeUse | Turns fixed size on or off
Public Property | FrameColor | FrameColor
Public Property | GradientColor | Gradient Background color if BrushKind is Gradient
Public Property | HatchStyle | Choose hatchstyle
Public Property | ImageIndex | Image index from imagelist in gantt. Will only have effect on TimeItemStyle==Image
Public Property | Name | Name this TimeItemLayout. Set this name in a time item to use.
Public Property | SelectHandles | Turns select handles on or off
Public Property | Shadow | Turns shadow on or off
Public Property | ShadowColor | Shadow color if Shadow==true
Public Property | ShadowFrameColor | Shadow frame color if Shadow==true
Public Property | SnapStartTime | Precision to snap start time to for time items with this layout, when moved and resized to the west The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStartTime=new TimeSpan(1,0,0,0);
Public Property | SnapStopTime | Precision to snap stop time to for time items with this layout, when resized to the east The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStopTime=new TimeSpan(1,0,0,0);
Public Property | TimeItemLayouts |
Public Property | TimeItemStyle | One of the predifined drawing schemes
Public Property | TopInset | Percent inset from top of original drawing rect
Top

Public Methods

 | Name | Description
Public Method | Changed |
Public Method | Clone | Clones the TimeItemLayout
Public Method | CloneAndAddWithNewName | Easy way to duplicate your time item layouts in order to tweak them
Top

See Also

Reference

TimeItemLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayout Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : TimeItemLayout Constructor

Glossary Item Box

Constructor for a time item layout

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemLayout()
C#
public TimeItemLayout()
Managed Extensions for C++
public: TimeItemLayout();
C++/CLI
public:
TimeItemLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemLayout Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayout Class

Glossary Item Box

For a list of all members of this type, see TimeItemLayout members.

Public Methods

 | Name | Description
Public Method | Changed |
Public Method | Clone | Clones the TimeItemLayout
Public Method | CloneAndAddWithNewName | Easy way to duplicate your time item layouts in order to tweak them
Top

See Also

Reference

TimeItemLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : Changed Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clone Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : Clone Method

Glossary Item Box

Clones the TimeItemLayout

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CloneAndAddWithNewName Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : CloneAndAddWithNewName Method

newName

Glossary Item Box

Easy way to duplicate your time item layouts in order to tweak them

Syntax

Visual Basic (Declaration)
Public Function CloneAndAddWithNewName( _
   ByVal newName As String _
) As TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim newName As String
Dim value As TimeItemLayout

value = instance.CloneAndAddWithNewName(newName)
C#
public TimeItemLayout CloneAndAddWithNewName(
   string newName
)
Managed Extensions for C++
public: TimeItemLayout* CloneAndAddWithNewName(
   string* newName
)
C++/CLI
public:
TimeItemLayout^ CloneAndAddWithNewName(
   String^ newName
)

Parameters

newName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemLayout Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayout Class

Glossary Item Box

For a list of all members of this type, see TimeItemLayout members.

Public Properties

 | Name | Description
Public Property | AllowChangeRow | Limits the degrees of freedom available to user
Public Property | AllowLinkReAssignStart | Controls if link re-assign can be done for the start of a link
Public Property | AllowLinkReAssignTarget | Controls if link re-assign can be done for the target of a link
Public Property | AllowLinkSelectionStart | Controls if link selection can be done for the start of a link
Public Property | AllowLinkSelectionTarget | Controls if link selection can be done for the targer of a link
Public Property | AllowMove | Limits the degrees of freedom available to user
Public Property | AllowResizeEast | Limits the degrees of freedom available to user
Public Property | AllowResizeWest | Limits the degrees of freedom available to user
Public Property | BlockedTimeCalculatedStop | TimeItems that use this TimeItemLayout will use a calculated stop date based on TimeItem Length and the contents of this timeitemlayout's BlockedTimeCalendar.
Public Property | BlockedTimeCalendar | Assign one of the Gantt's Calendars to this property and set BlockedTimeCalculatedStop=true and the calendar entries will be treated as blocked time for time items using this layout
Public Property | BlockedTimeShow | When using blocked time you can optionally visualize the blocked areas that effect a given time item.
Public Property | BottomInset | Percent inset from bottom of original drawing rect
Public Property | BrushKind | Choose brushkind
Public Property | Color | Background color
Public Property | ConflictAreaColor | ConflictAreaColor
Public Property | ConflictAreaDrawStyle | ConflictAreaDrawStyle
Public Property | ConflictAreaHatchStyle | ConflictAreaHatchStyle
Public Property | DrawDetailsEvenForVerySmallTimeItems | If a time item is very small (less or equal to two pixels high, or two pixels wide ) the details of the time item may not be visible on screen. So if the details are not visible we might as well skip drawing them. We will skip drawing small time item details, like TimeItemTexts etc if this property is true (default). Instead we just draw a rectangle filled with the solid background color.
Public Property | ExtraAddOnDraw | When ExtraAddOnDraw is true, the time item will be drawn with the TimeItemStyle, but then the OnTimeItem_UserDraw will also be called so that you can do some additional add on drawing
Public Property | FixedSize | Fixed size will not allow resize, and will not stretch on zooming
Public Property | FixedSizeUse | Turns fixed size on or off
Public Property | FrameColor | FrameColor
Public Property | GradientColor | Gradient Background color if BrushKind is Gradient
Public Property | HatchStyle | Choose hatchstyle
Public Property | ImageIndex | Image index from imagelist in gantt. Will only have effect on TimeItemStyle==Image
Public Property | Name | Name this TimeItemLayout. Set this name in a time item to use.
Public Property | SelectHandles | Turns select handles on or off
Public Property | Shadow | Turns shadow on or off
Public Property | ShadowColor | Shadow color if Shadow==true
Public Property | ShadowFrameColor | Shadow frame color if Shadow==true
Public Property | SnapStartTime | Precision to snap start time to for time items with this layout, when moved and resized to the west The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStartTime=new TimeSpan(1,0,0,0);
Public Property | SnapStopTime | Precision to snap stop time to for time items with this layout, when resized to the east The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStopTime=new TimeSpan(1,0,0,0);
Public Property | TimeItemLayouts |
Public Property | TimeItemStyle | One of the predifined drawing schemes
Public Property | TopInset | Percent inset from top of original drawing rect
Top

See Also

Reference

TimeItemLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowChangeRow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowChangeRow Property

Glossary Item Box

Limits the degrees of freedom available to user

Syntax

Visual Basic (Declaration)
Public Property AllowChangeRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowChangeRow = value

value = instance.AllowChangeRow
C#
public bool AllowChangeRow {get; set;}
Managed Extensions for C++
public: __property bool get_AllowChangeRow();
public: __property void set_AllowChangeRow(
   bool value
);
C++/CLI
public:
property bool AllowChangeRow {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowLinkReAssignStart Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowLinkReAssignStart Property

Glossary Item Box

Controls if link re-assign can be done for the start of a link

Syntax

Visual Basic (Declaration)
Public Property AllowLinkReAssignStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowLinkReAssignStart = value

value = instance.AllowLinkReAssignStart
C#
public bool AllowLinkReAssignStart {get; set;}
Managed Extensions for C++
public: __property bool get_AllowLinkReAssignStart();
public: __property void set_AllowLinkReAssignStart(
   bool value
);
C++/CLI
public:
property bool AllowLinkReAssignStart {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowLinkReAssignTarget Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowLinkReAssignTarget Property

Glossary Item Box

Controls if link re-assign can be done for the target of a link

Syntax

Visual Basic (Declaration)
Public Property AllowLinkReAssignTarget As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowLinkReAssignTarget = value

value = instance.AllowLinkReAssignTarget
C#
public bool AllowLinkReAssignTarget {get; set;}
Managed Extensions for C++
public: __property bool get_AllowLinkReAssignTarget();
public: __property void set_AllowLinkReAssignTarget(
   bool value
);
C++/CLI
public:
property bool AllowLinkReAssignTarget {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowLinkSelectionStart Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowLinkSelectionStart Property

Glossary Item Box

Controls if link selection can be done for the start of a link

Syntax

Visual Basic (Declaration)
Public Property AllowLinkSelectionStart As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowLinkSelectionStart = value

value = instance.AllowLinkSelectionStart
C#
public bool AllowLinkSelectionStart {get; set;}
Managed Extensions for C++
public: __property bool get_AllowLinkSelectionStart();
public: __property void set_AllowLinkSelectionStart(
   bool value
);
C++/CLI
public:
property bool AllowLinkSelectionStart {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowLinkSelectionTarget Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowLinkSelectionTarget Property

Glossary Item Box

Controls if link selection can be done for the targer of a link

Syntax

Visual Basic (Declaration)
Public Property AllowLinkSelectionTarget As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowLinkSelectionTarget = value

value = instance.AllowLinkSelectionTarget
C#
public bool AllowLinkSelectionTarget {get; set;}
Managed Extensions for C++
public: __property bool get_AllowLinkSelectionTarget();
public: __property void set_AllowLinkSelectionTarget(
   bool value
);
C++/CLI
public:
property bool AllowLinkSelectionTarget {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowMove Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowMove Property

Glossary Item Box

Limits the degrees of freedom available to user

Syntax

Visual Basic (Declaration)
Public Property AllowMove As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public bool AllowMove {get; set;}
Managed Extensions for C++
public: __property bool get_AllowMove();
public: __property void set_AllowMove(
   bool value
);
C++/CLI
public:
property bool AllowMove {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowResizeEast Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowResizeEast Property

Glossary Item Box

Limits the degrees of freedom available to user

Syntax

Visual Basic (Declaration)
Public Property AllowResizeEast As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowResizeEast = value

value = instance.AllowResizeEast
C#
public bool AllowResizeEast {get; set;}
Managed Extensions for C++
public: __property bool get_AllowResizeEast();
public: __property void set_AllowResizeEast(
   bool value
);
C++/CLI
public:
property bool AllowResizeEast {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AllowResizeWest Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : AllowResizeWest Property

Glossary Item Box

Limits the degrees of freedom available to user

Syntax

Visual Basic (Declaration)
Public Property AllowResizeWest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.AllowResizeWest = value

value = instance.AllowResizeWest
C#
public bool AllowResizeWest {get; set;}
Managed Extensions for C++
public: __property bool get_AllowResizeWest();
public: __property void set_AllowResizeWest(
   bool value
);
C++/CLI
public:
property bool AllowResizeWest {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BlockedTimeCalculatedStop Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : BlockedTimeCalculatedStop Property

Glossary Item Box

TimeItems that use this TimeItemLayout will use a calculated stop date based on TimeItem Length and the contents of this timeitemlayout's BlockedTimeCalendar.

Syntax

Visual Basic (Declaration)
Public Property BlockedTimeCalculatedStop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.BlockedTimeCalculatedStop = value

value = instance.BlockedTimeCalculatedStop
C#
public bool BlockedTimeCalculatedStop {get; set;}
Managed Extensions for C++
public: __property bool get_BlockedTimeCalculatedStop();
public: __property void set_BlockedTimeCalculatedStop(
   bool value
);
C++/CLI
public:
property bool BlockedTimeCalculatedStop {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BlockedTimeCalendar Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : BlockedTimeCalendar Property

Glossary Item Box

Assign one of the Gantt's Calendars to this property and set BlockedTimeCalculatedStop=true and the calendar entries will be treated as blocked time for time items using this layout

Syntax

Visual Basic (Declaration)
Public Property BlockedTimeCalendar As Calendar
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Calendar

instance.BlockedTimeCalendar = value

value = instance.BlockedTimeCalendar
C#
public Calendar BlockedTimeCalendar {get; set;}
Managed Extensions for C++
public: __property Calendar* get_BlockedTimeCalendar();
public: __property void set_BlockedTimeCalendar(
   Calendar* value
);
C++/CLI
public:
property Calendar^ BlockedTimeCalendar {
   Calendar^ get();
   void set (    Calendar^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BlockedTimeShow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : BlockedTimeShow Property

Glossary Item Box

When using blocked time you can optionally visualize the blocked areas that effect a given time item.

Syntax

Visual Basic (Declaration)
Public Property BlockedTimeShow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.BlockedTimeShow = value

value = instance.BlockedTimeShow
C#
public bool BlockedTimeShow {get; set;}
Managed Extensions for C++
public: __property bool get_BlockedTimeShow();
public: __property void set_BlockedTimeShow(
   bool value
);
C++/CLI
public:
property bool BlockedTimeShow {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BottomInset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : BottomInset Property

Glossary Item Box

Percent inset from bottom of original drawing rect

Syntax

Visual Basic (Declaration)
Public Property BottomInset As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Integer

instance.BottomInset = value

value = instance.BottomInset
C#
public int BottomInset {get; set;}
Managed Extensions for C++
public: __property int get_BottomInset();
public: __property void set_BottomInset(
   int value
);
C++/CLI
public:
property int BottomInset {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BrushKind Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : BrushKind Property

Glossary Item Box

Choose brushkind

Syntax

Visual Basic (Declaration)
Public Property BrushKind As BrushKind
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As BrushKind

instance.BrushKind = value

value = instance.BrushKind
C#
public BrushKind BrushKind {get; set;}
Managed Extensions for C++
public: __property BrushKind get_BrushKind();
public: __property void set_BrushKind(
   BrushKind value
);
C++/CLI
public:
property BrushKind BrushKind {
   BrushKind get();
   void set (    BrushKind value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Color Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : Color Property

Glossary Item Box

Background color

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}
Managed Extensions for C++
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
public:
property Color Color {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ConflictAreaColor Property

Glossary Item Box

ConflictAreaColor

Syntax

Visual Basic (Declaration)
Public Property ConflictAreaColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.ConflictAreaColor = value

value = instance.ConflictAreaColor
C#
public Color ConflictAreaColor {get; set;}
Managed Extensions for C++
public: __property Color get_ConflictAreaColor();
public: __property void set_ConflictAreaColor(
   Color value
);
C++/CLI
public:
property Color ConflictAreaColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaDrawStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ConflictAreaDrawStyle Property

Glossary Item Box

ConflictAreaDrawStyle

Syntax

Visual Basic (Declaration)
Public Property ConflictAreaDrawStyle As ConflictAreaDrawStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As ConflictAreaDrawStyle

instance.ConflictAreaDrawStyle = value

value = instance.ConflictAreaDrawStyle
C#
public ConflictAreaDrawStyle ConflictAreaDrawStyle {get; set;}
Managed Extensions for C++
public: __property ConflictAreaDrawStyle get_ConflictAreaDrawStyle();
public: __property void set_ConflictAreaDrawStyle(
   ConflictAreaDrawStyle value
);
C++/CLI
public:
property ConflictAreaDrawStyle ConflictAreaDrawStyle {
   ConflictAreaDrawStyle get();
   void set (    ConflictAreaDrawStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaHatchStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ConflictAreaHatchStyle Property

Glossary Item Box

ConflictAreaHatchStyle

Syntax

Visual Basic (Declaration)
Public Property ConflictAreaHatchStyle As HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As HatchStyle

instance.ConflictAreaHatchStyle = value

value = instance.ConflictAreaHatchStyle
C#
public HatchStyle ConflictAreaHatchStyle {get; set;}
Managed Extensions for C++
public: __property HatchStyle get_ConflictAreaHatchStyle();
public: __property void set_ConflictAreaHatchStyle(
   HatchStyle value
);
C++/CLI
public:
property HatchStyle ConflictAreaHatchStyle {
   HatchStyle get();
   void set (    HatchStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawDetailsEvenForVerySmallTimeItems Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : DrawDetailsEvenForVerySmallTimeItems Property

Glossary Item Box

If a time item is very small (less or equal to two pixels high, or two pixels wide ) the details of the time item may not be visible on screen. So if the details are not visible we might as well skip drawing them. We will skip drawing small time item details, like TimeItemTexts etc if this property is true (default). Instead we just draw a rectangle filled with the solid background color.

Syntax

Visual Basic (Declaration)
Public Property DrawDetailsEvenForVerySmallTimeItems As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.DrawDetailsEvenForVerySmallTimeItems = value

value = instance.DrawDetailsEvenForVerySmallTimeItems
C#
public bool DrawDetailsEvenForVerySmallTimeItems {get; set;}
Managed Extensions for C++
public: __property bool get_DrawDetailsEvenForVerySmallTimeItems();
public: __property void set_DrawDetailsEvenForVerySmallTimeItems(
   bool value
);
C++/CLI
public:
property bool DrawDetailsEvenForVerySmallTimeItems {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ExtraAddOnDraw Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ExtraAddOnDraw Property

Glossary Item Box

When ExtraAddOnDraw is true, the time item will be drawn with the TimeItemStyle, but then the OnTimeItem_UserDraw will also be called so that you can do some additional add on drawing

Syntax

Visual Basic (Declaration)
Public Property ExtraAddOnDraw As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.ExtraAddOnDraw = value

value = instance.ExtraAddOnDraw
C#
public bool ExtraAddOnDraw {get; set;}
Managed Extensions for C++
public: __property bool get_ExtraAddOnDraw();
public: __property void set_ExtraAddOnDraw(
   bool value
);
C++/CLI
public:
property bool ExtraAddOnDraw {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FixedSize Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : FixedSize Property

Glossary Item Box

Fixed size will not allow resize, and will not stretch on zooming

Syntax

Visual Basic (Declaration)
Public Property FixedSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Integer

instance.FixedSize = value

value = instance.FixedSize
C#
public int FixedSize {get; set;}
Managed Extensions for C++
public: __property int get_FixedSize();
public: __property void set_FixedSize(
   int value
);
C++/CLI
public:
property int FixedSize {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FixedSizeUse Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : FixedSizeUse Property

Glossary Item Box

Turns fixed size on or off

Syntax

Visual Basic (Declaration)
Public Property FixedSizeUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.FixedSizeUse = value

value = instance.FixedSizeUse
C#
public bool FixedSizeUse {get; set;}
Managed Extensions for C++
public: __property bool get_FixedSizeUse();
public: __property void set_FixedSizeUse(
   bool value
);
C++/CLI
public:
property bool FixedSizeUse {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
FrameColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : FrameColor Property

Glossary Item Box

FrameColor

Syntax

Visual Basic (Declaration)
Public Property FrameColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.FrameColor = value

value = instance.FrameColor
C#
public Color FrameColor {get; set;}
Managed Extensions for C++
public: __property Color get_FrameColor();
public: __property void set_FrameColor(
   Color value
);
C++/CLI
public:
property Color FrameColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GradientColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : GradientColor Property

Glossary Item Box

Gradient Background color if BrushKind is Gradient

Syntax

Visual Basic (Declaration)
Public Property GradientColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.GradientColor = value

value = instance.GradientColor
C#
public Color GradientColor {get; set;}
Managed Extensions for C++
public: __property Color get_GradientColor();
public: __property void set_GradientColor(
   Color value
);
C++/CLI
public:
property Color GradientColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HatchStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : HatchStyle Property

Glossary Item Box

Choose hatchstyle

Syntax

Visual Basic (Declaration)
Public Property HatchStyle As HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public HatchStyle HatchStyle {get; set;}
Managed Extensions for C++
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
C++/CLI
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (    HatchStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageIndex Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ImageIndex Property

Glossary Item Box

Image index from imagelist in gantt. Will only have effect on TimeItemStyle==Image

Syntax

Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
public:
property int ImageIndex {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Name Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : Name Property

Glossary Item Box

Name this TimeItemLayout. Set this name in a time item to use.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectHandles Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : SelectHandles Property

Glossary Item Box

Turns select handles on or off

Syntax

Visual Basic (Declaration)
Public Property SelectHandles As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.SelectHandles = value

value = instance.SelectHandles
C#
public Color SelectHandles {get; set;}
Managed Extensions for C++
public: __property Color get_SelectHandles();
public: __property void set_SelectHandles(
   Color value
);
C++/CLI
public:
property Color SelectHandles {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Shadow Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : Shadow Property

Glossary Item Box

Turns shadow on or off

Syntax

Visual Basic (Declaration)
Public Property Shadow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Boolean

instance.Shadow = value

value = instance.Shadow
C#
public bool Shadow {get; set;}
Managed Extensions for C++
public: __property bool get_Shadow();
public: __property void set_Shadow(
   bool value
);
C++/CLI
public:
property bool Shadow {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShadowColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ShadowColor Property

Glossary Item Box

Shadow color if Shadow==true

Syntax

Visual Basic (Declaration)
Public Property ShadowColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.ShadowColor = value

value = instance.ShadowColor
C#
public Color ShadowColor {get; set;}
Managed Extensions for C++
public: __property Color get_ShadowColor();
public: __property void set_ShadowColor(
   Color value
);
C++/CLI
public:
property Color ShadowColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ShadowFrameColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : ShadowFrameColor Property

Glossary Item Box

Shadow frame color if Shadow==true

Syntax

Visual Basic (Declaration)
Public Property ShadowFrameColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Color

instance.ShadowFrameColor = value

value = instance.ShadowFrameColor
C#
public Color ShadowFrameColor {get; set;}
Managed Extensions for C++
public: __property Color get_ShadowFrameColor();
public: __property void set_ShadowFrameColor(
   Color value
);
C++/CLI
public:
property Color ShadowFrameColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SnapStartTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : SnapStartTime Property

Glossary Item Box

Precision to snap start time to for time items with this layout, when moved and resized to the west The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStartTime=new TimeSpan(1,0,0,0);

Syntax

Visual Basic (Declaration)
Public Property SnapStartTime As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As TimeSpan

instance.SnapStartTime = value

value = instance.SnapStartTime
C#
public TimeSpan SnapStartTime {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_SnapStartTime();
public: __property void set_SnapStartTime(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan SnapStartTime {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SnapStopTime Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : SnapStopTime Property

Glossary Item Box

Precision to snap stop time to for time items with this layout, when resized to the east The TimeSpan symbolizes the length between the lines in the snap grid. To Snap to a day you would set SnapStopTime=new TimeSpan(1,0,0,0);

Syntax

Visual Basic (Declaration)
Public Property SnapStopTime As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As TimeSpan

instance.SnapStopTime = value

value = instance.SnapStopTime
C#
public TimeSpan SnapStopTime {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_SnapStopTime();
public: __property void set_SnapStopTime(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan SnapStopTime {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : TimeItemLayouts Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property TimeItemLayouts As TimeItemLayouts
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As TimeItemLayouts

instance.TimeItemLayouts = value

value = instance.TimeItemLayouts
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public TimeItemLayouts TimeItemLayouts {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property TimeItemLayouts* get_TimeItemLayouts();
public: __property void set_TimeItemLayouts(
   TimeItemLayouts* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property TimeItemLayouts^ TimeItemLayouts {
   TimeItemLayouts^ get();
   void set (    TimeItemLayouts^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : TimeItemStyle Property

Glossary Item Box

One of the predifined drawing schemes

Syntax

Visual Basic (Declaration)
Public Property TimeItemStyle As TimeItemStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As TimeItemStyle

instance.TimeItemStyle = value

value = instance.TimeItemStyle
C#
public TimeItemStyle TimeItemStyle {get; set;}
Managed Extensions for C++
public: __property TimeItemStyle get_TimeItemStyle();
public: __property void set_TimeItemStyle(
   TimeItemStyle value
);
C++/CLI
public:
property TimeItemStyle TimeItemStyle {
   TimeItemStyle get();
   void set (    TimeItemStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TopInset Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayout Class : TopInset Property

Glossary Item Box

Percent inset from top of original drawing rect

Syntax

Visual Basic (Declaration)
Public Property TopInset As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayout
Dim value As Integer

instance.TopInset = value

value = instance.TopInset
C#
public int TopInset {get; set;}
Managed Extensions for C++
public: __property int get_TopInset();
public: __property void set_TopInset(
   int value
);
C++/CLI
public:
property int TopInset {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayout Class
TimeItemLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayouts Class

Glossary Item Box

TimeItemLayouts keeps the TimeItemLayouts in a Gantt.

Object Model

TimeItemLayouts ClassTimeItemLayout Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class TimeItemLayouts
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
C#
[DefaultMemberAttribute("Item")]
public class TimeItemLayouts : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class TimeItemLayouts : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class TimeItemLayouts : public System.Collections.CollectionBase

Example

TimeItem Class

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.TimeItemLayouts

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLayouts Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemLayouts Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayouts Class

Glossary Item Box

The following tables list the members exposed by TimeItemLayouts.

Public Constructors

 | Name | Description
Public Constructor | TimeItemLayouts Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a TimeItemLayout
Public Method | Changed |
Public Method | GetFromName | Finds a TimeItemLayout from a name
Public Method | IndexOf | Returns the index of a TimeItemLayout
Public Method | Remove | Remove by index
Top

Public Events

 | Name | Description
Public Event | OnChanged | Fires when a TimeItemLayout has changed in some way
Top

See Also

Reference

TimeItemLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : TimeItemLayouts Constructor

Glossary Item Box

Overload List

Overload | Description
TimeItemLayouts Constructor() |
TimeItemLayouts Constructor(Gantt) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class > TimeItemLayouts Constructor : TimeItemLayouts Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemLayouts()
C#
public TimeItemLayouts()
Managed Extensions for C++
public: TimeItemLayouts();
C++/CLI
public:
TimeItemLayouts();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayouts Constructor(Gantt)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class > TimeItemLayouts Constructor : TimeItemLayouts Constructor(Gantt)

aGanttControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGanttControl As Gantt _
)
Visual Basic (Usage) Copy Code
Dim aGanttControl As Gantt

Dim instance As New TimeItemLayouts(aGanttControl)
C#
public TimeItemLayouts(
   Gantt aGanttControl
)
Managed Extensions for C++
public: TimeItemLayouts(
   Gantt* aGanttControl
)
C++/CLI
public:
TimeItemLayouts(
   Gantt^ aGanttControl
)

Parameters

aGanttControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemLayouts Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayouts Class

Glossary Item Box

For a list of all members of this type, see TimeItemLayouts members.

Public Methods

 | Name | Description
Public Method | Add | Adds a TimeItemLayout
Public Method | Changed |
Public Method | GetFromName | Finds a TimeItemLayout from a name
Public Method | IndexOf | Returns the index of a TimeItemLayout
Public Method | Remove | Remove by index
Top

See Also

Reference

TimeItemLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : Add Method

aTimeItemLayout

Glossary Item Box

Adds a TimeItemLayout

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aTimeItemLayout As TimeItemLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim aTimeItemLayout As TimeItemLayout

instance.Add(aTimeItemLayout)
C#
public void Add(
   TimeItemLayout aTimeItemLayout
)
Managed Extensions for C++
public: void Add(
   TimeItemLayout* aTimeItemLayout
)
C++/CLI
public:
void Add(
   TimeItemLayout^ aTimeItemLayout
)

Parameters

aTimeItemLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : Changed Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetFromName Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : GetFromName Method

aName

Glossary Item Box

Finds a TimeItemLayout from a name

Syntax

Visual Basic (Declaration)
Public Function GetFromName( _
   ByVal aName As String _
) As TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim aName As String
Dim value As TimeItemLayout

value = instance.GetFromName(aName)
C#
public TimeItemLayout GetFromName(
   string aName
)
Managed Extensions for C++
public: TimeItemLayout* GetFromName(
   string* aName
)
C++/CLI
public:
TimeItemLayout^ GetFromName(
   String^ aName
)

Parameters

aName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : IndexOf Method

value

Glossary Item Box

Returns the index of a TimeItemLayout

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : Remove Method

index

Glossary Item Box

Remove by index

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemLayouts Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayouts Class

Glossary Item Box

For a list of all members of this type, see TimeItemLayouts members.

Public Properties

 | Name | Description
Public Property | Item | Indexer
Top

See Also

Reference

TimeItemLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim Index As Integer
Dim value As TimeItemLayout

value = instance.Item(Index)
C#
public TimeItemLayout this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property TimeItemLayout* get_Item   int Index
;
C++/CLI
public:
property TimeItemLayout^ default [int] {
   TimeItemLayout^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
TimeItemLayouts Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLayouts Class

Glossary Item Box

For a list of all members of this type, see TimeItemLayouts members.

Public Events

 | Name | Description
Public Event | OnChanged | Fires when a TimeItemLayout has changed in some way
Top

See Also

Reference

TimeItemLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnChanged Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLayouts Class : OnChanged Event

Glossary Item Box

Fires when a TimeItemLayout has changed in some way

Syntax

Visual Basic (Declaration)
Public Event OnChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLayouts
Dim handler As EventHandler

AddHandler instance.OnChanged, handler
C#
public event EventHandler OnChanged
Managed Extensions for C++
public: __event EventHandler* OnChanged
C++/CLI
public:
event EventHandler^ OnChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLayouts Class
TimeItemLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLink Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLink Class

Glossary Item Box

A Time link is an arrow between two different time items

Object Model

TimeItemLink ClassTimeItem ClassTimeItem Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
C#
public class TimeItemLink
Managed Extensions for C++
public __gc class TimeItemLink
C++/CLI
public ref class TimeItemLink

Example

C# Copy Code
GanttRow gr1=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes[0]);
      GanttRow gr2=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes[1]);
      GanttRow gr3=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes[2]);
      GanttRow gr4=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes[3]);

      TimeItem ti1=gr1.Layers[0].AddNewTimeItem();
      ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);
      ti1.Stop=ti1.Start.AddDays(3);

      TimeItem ti2=gr1.Layers[0].AddNewTimeItem();
      ti2.Start=gantt1.DateScaler.StartTime.AddDays(10);
      ti2.Stop=ti2.Start.AddDays(3);

      TimeItem ti3=gr2.Layers[0].AddNewTimeItem();
      ti3.Start=gantt1.DateScaler.StartTime.AddDays(5);
      ti3.Stop=ti3.Start.AddDays(3);

      TimeItem ti4=gr2.Layers[0].AddNewTimeItem();
      ti4.Start=gantt1.DateScaler.StartTime.AddDays(15);
      ti4.Stop=ti4.Start.AddDays(3);

      TimeItem ti5=gr3.Layers[0].AddNewTimeItem();
      ti5.Start=gantt1.DateScaler.StartTime.AddDays(1);
      ti5.Stop=ti5.Start.AddDays(3);

      TimeItem ti6=gr3.Layers[0].AddNewTimeItem();
      ti6.Start=gantt1.DateScaler.StartTime.AddDays(10);
      ti6.Stop=ti2.Start.AddDays(3);

      TimeItem ti7=gr4.Layers[0].AddNewTimeItem();
      ti7.Start=gantt1.DateScaler.StartTime.AddDays(5);
      ti7.Stop=ti7.Start.AddDays(3);

      TimeItem ti8=gr4.Layers[0].AddNewTimeItem();
      ti8.Start=gantt1.DateScaler.StartTime.AddDays(15);
      ti8.Stop=ti8.Start.AddDays(3);

      TimeItemLink l1=gantt1.TimeItemLinks.AddLink(ti1,ti3);
      TimeItemLink l12=gantt1.TimeItemLinks.AddLink(ti1,ti3);
      TimeItemLink l2=gantt1.TimeItemLinks.AddLink(ti2,ti4);
      TimeItemLink l21=gantt1.TimeItemLinks.AddLink(ti2,ti4);
      TimeItemLink l3=gantt1.TimeItemLinks.AddLink(ti5,ti7);
      TimeItemLink l4=gantt1.TimeItemLinks.AddLink(ti6,ti8);

      l1.Color=Color.ForestGreen;
      l1.Width=1;
      l1.TimeItemLinkStyle=TimeItemLinkStyle.StartToStart;
      l1.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight;

      l12.Color=Color.DarkBlue;
      l12.Width=1;
      l12.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop;
      l12.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight;

      l2.Color=Color.Red;
      l2.Width=2;
      l2.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop;
      l2.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Nurb;

      l21.Color=Color.CornflowerBlue;
      l21.Width=2;
      l21.TimeItemLinkStyle=TimeItemLinkStyle.StartToStart;
      l21.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Nurb;

      l3.Color=Color.RosyBrown;
      l3.Width=3;
      l3.TimeItemLinkStyle=TimeItemLinkStyle.StopToStart;
      l3.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.ZStyle;

      l4.Color=Color.SandyBrown;
      l4.Width=4;
      l4.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop;
      l4.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight;
Visual Basic Copy Code
Dim gr1 As GanttRow=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes(0))
      Dim gr2 As GanttRow=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes(1))
      Dim gr3 As GanttRow=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes(2))
      Dim gr4 As GanttRow=GanttRow.FromGridNode(gantt1.Grid.GridStructure.RootNodes(3))

      Dim ti1 As TimeItem=gr1.Layers(0).AddNewTimeItem()
      ti1.Start=gantt1.DateScaler.StartTime.AddDays(1)
      ti1.Stop=ti1.Start.AddDays(3)

      Dim ti2 As TimeItem=gr1.Layers(0).AddNewTimeItem()
      ti2.Start=gantt1.DateScaler.StartTime.AddDays(10)
      ti2.Stop=ti2.Start.AddDays(3)

      Dim ti3 As TimeItem=gr2.Layers(0).AddNewTimeItem()
      ti3.Start=gantt1.DateScaler.StartTime.AddDays(5)
      ti3.Stop=ti3.Start.AddDays(3)

      Dim ti4 As TimeItem=gr2.Layers(0).AddNewTimeItem()
      ti4.Start=gantt1.DateScaler.StartTime.AddDays(15)
      ti4.Stop=ti4.Start.AddDays(3)

      Dim ti5 As TimeItem=gr3.Layers(0).AddNewTimeItem()
      ti5.Start=gantt1.DateScaler.StartTime.AddDays(1)
      ti5.Stop=ti5.Start.AddDays(3)

      Dim ti6 As TimeItem=gr3.Layers(0).AddNewTimeItem()
      ti6.Start=gantt1.DateScaler.StartTime.AddDays(10)
      ti6.Stop=ti2.Start.AddDays(3)

      Dim ti7 As TimeItem=gr4.Layers(0).AddNewTimeItem()
      ti7.Start=gantt1.DateScaler.StartTime.AddDays(5)
      ti7.Stop=ti7.Start.AddDays(3)

      Dim ti8 As TimeItem=gr4.Layers(0).AddNewTimeItem()
      ti8.Start=gantt1.DateScaler.StartTime.AddDays(15)
      ti8.Stop=ti8.Start.AddDays(3)

      Dim l1 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti1,ti3)
      Dim l12 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti1,ti3)
      Dim l2 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti2,ti4)
      Dim l21 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti2,ti4)
      Dim l3 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti5,ti7)
      Dim l4 As TimeItemLink=gantt1.TimeItemLinks.AddLink(ti6,ti8)

      l1.Color=Color.ForestGreen
      l1.Width=1
      l1.TimeItemLinkStyle=TimeItemLinkStyle.StartToStart
      l1.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight

      l12.Color=Color.DarkBlue
      l12.Width=1
      l12.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop
      l12.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight

      l2.Color=Color.Red
      l2.Width=2
      l2.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop
      l2.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Nurb

      l21.Color=Color.CornflowerBlue
      l21.Width=2
      l21.TimeItemLinkStyle=TimeItemLinkStyle.StartToStart
      l21.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Nurb

      l3.Color=Color.RosyBrown
      l3.Width=3
      l3.TimeItemLinkStyle=TimeItemLinkStyle.StopToStart
      l3.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.ZStyle

      l4.Color=Color.SandyBrown
      l4.Width=4
      l4.TimeItemLinkStyle=TimeItemLinkStyle.StopToStop
      l4.TimeItemLinkDrawStyle=TimeItemLinkDrawStyle.Straight

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemLink

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLink Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemLink Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLink Class

Glossary Item Box

The following tables list the members exposed by TimeItemLink.

Public Properties

 | Name | Description
Public Property | Action | Controls the linkAction that is fired when the start or target time item are changed
Public Property | Color | The Color of the link
Public Property | Selected | Sets or Gets the selection status on this link
Public Property | Start | The start time item, where the link starts
Public Property | StartKey | The StartKey is the key of the time item that acts as start. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.
Public Property | StartPoint | The StartPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.
Public Property | StartPointIsStub | If the StartPoint was hidden due to a non expanded or non visible grid node this value is true
Public Property | Target | The target time item, where the link ends
Public Property | TargetKey | The TargetKey is the key of the time item that acts as target. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.
Public Property | TargetPoint | The TargetPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.
Public Property | TargetPointIsStub | If the TargetPoint was hidden due to a non expanded or non visible grid node this value is true
Public Property | TimeItemLinkDrawStyle | The timeItemLinkDrawStyle of the link
Public Property | TimeItemLinkStyle | Different styles of the link
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | Width | The Width of the link
Public Property | ZIndex | ZIndex allows you to control if the link is drawn above a particular time item layer index or not 0 in ZIndex will ensure the link being drawn below all time items in layer 0 and above 1 in ZIndex will make the links go above layer 0 time items, but below layer 1 time items 999 will put your links on top (unless you have time items in layer 999) 999 is the default value to keep backwards compability when all links were drawn on top
Top

Public Methods

 | Name | Description
Public Method | DropLink | Link is removed when you call this.
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if TimeItemLinks are databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECOIII this will be a RenderedTuple
Public Method | PerformLinkAction | Executes the link actions. This is done automatically on user interactions, but you may call in directly if needed.
Top

See Also

Reference

TimeItemLink Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemLink Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLink Class

Glossary Item Box

For a list of all members of this type, see TimeItemLink members.

Public Methods

 | Name | Description
Public Method | DropLink | Link is removed when you call this.
Public Method | ListItemWhenDataBound | Retrieves the corresponding list item object if TimeItemLinks are databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECOIII this will be a RenderedTuple
Public Method | PerformLinkAction | Executes the link actions. This is done automatically on user interactions, but you may call in directly if needed.
Top

See Also

Reference

TimeItemLink Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DropLink Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : DropLink Method

Glossary Item Box

Link is removed when you call this.

Syntax

Visual Basic (Declaration)
Public Sub DropLink()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink

instance.DropLink()
C#
public void DropLink()
Managed Extensions for C++
public: void DropLink();
C++/CLI
public:
void DropLink();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListItemWhenDataBound Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : ListItemWhenDataBound Method

Glossary Item Box

Retrieves the corresponding list item object if TimeItemLinks are databound to a data source. This will typically be a DataRowView or a DataRow depending on your binding context. In ECOIII this will be a RenderedTuple

Syntax

Visual Basic (Declaration)
Public Function ListItemWhenDataBound() As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Object

value = instance.ListItemWhenDataBound()
C#
public object ListItemWhenDataBound()
Managed Extensions for C++
public: Object* ListItemWhenDataBound();
C++/CLI
public:
Object^ ListItemWhenDataBound();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PerformLinkAction Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : PerformLinkAction Method

Glossary Item Box

Executes the link actions. This is done automatically on user interactions, but you may call in directly if needed.

Syntax

Visual Basic (Declaration)
Public Sub PerformLinkAction()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink

instance.PerformLinkAction()
C#
public void PerformLinkAction()
Managed Extensions for C++
public: void PerformLinkAction();
C++/CLI
public:
void PerformLinkAction();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemLink Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLink Class

Glossary Item Box

For a list of all members of this type, see TimeItemLink members.

Public Properties

 | Name | Description
Public Property | Action | Controls the linkAction that is fired when the start or target time item are changed
Public Property | Color | The Color of the link
Public Property | Selected | Sets or Gets the selection status on this link
Public Property | Start | The start time item, where the link starts
Public Property | StartKey | The StartKey is the key of the time item that acts as start. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.
Public Property | StartPoint | The StartPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.
Public Property | StartPointIsStub | If the StartPoint was hidden due to a non expanded or non visible grid node this value is true
Public Property | Target | The target time item, where the link ends
Public Property | TargetKey | The TargetKey is the key of the time item that acts as target. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.
Public Property | TargetPoint | The TargetPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.
Public Property | TargetPointIsStub | If the TargetPoint was hidden due to a non expanded or non visible grid node this value is true
Public Property | TimeItemLinkDrawStyle | The timeItemLinkDrawStyle of the link
Public Property | TimeItemLinkStyle | Different styles of the link
Public Property | UserReference | User reference, use this to tie against your own data
Public Property | Width | The Width of the link
Public Property | ZIndex | ZIndex allows you to control if the link is drawn above a particular time item layer index or not 0 in ZIndex will ensure the link being drawn below all time items in layer 0 and above 1 in ZIndex will make the links go above layer 0 time items, but below layer 1 time items 999 will put your links on top (unless you have time items in layer 999) 999 is the default value to keep backwards compability when all links were drawn on top
Top

See Also

Reference

TimeItemLink Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Action Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Action Property

Glossary Item Box

Controls the linkAction that is fired when the start or target time item are changed

Syntax

Visual Basic (Declaration)
Public Property Action As TimeItemLinkAction
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As TimeItemLinkAction

instance.Action = value

value = instance.Action
C#
public TimeItemLinkAction Action {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkAction get_Action();
public: __property void set_Action(
   TimeItemLinkAction value
);
C++/CLI
public:
property TimeItemLinkAction Action {
   TimeItemLinkAction get();
   void set (    TimeItemLinkAction value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Color Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Color Property

Glossary Item Box

The Color of the link

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}
Managed Extensions for C++
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
public:
property Color Color {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Selected Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Selected Property

Glossary Item Box

Sets or Gets the selection status on this link

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
public bool Selected {get; set;}
Managed Extensions for C++
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
C++/CLI
public:
property bool Selected {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Start Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Start Property

Glossary Item Box

The start time item, where the link starts

Syntax

Visual Basic (Declaration)
Public Property Start As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As TimeItem

instance.Start = value

value = instance.Start
C#
public TimeItem Start {get; set;}
Managed Extensions for C++
public: __property TimeItem* get_Start();
public: __property void set_Start(
   TimeItem* value
);
C++/CLI
public:
property TimeItem^ Start {
   TimeItem^ get();
   void set (    TimeItem^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartKey Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : StartKey Property

Glossary Item Box

The StartKey is the key of the time item that acts as start. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.

Syntax

Visual Basic (Declaration)
Public Property StartKey As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As String

instance.StartKey = value

value = instance.StartKey
C#
public string StartKey {get; set;}
Managed Extensions for C++
public: __property string* get_StartKey();
public: __property void set_StartKey(
   string* value
);
C++/CLI
public:
property String^ StartKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartPoint Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : StartPoint Property

Glossary Item Box

The StartPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.

Syntax

Visual Basic (Declaration)
Public Property StartPoint As Point
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Point

instance.StartPoint = value

value = instance.StartPoint
C#
public Point StartPoint {get; set;}
Managed Extensions for C++
public: __property Point get_StartPoint();
public: __property void set_StartPoint(
   Point value
);
C++/CLI
public:
property Point StartPoint {
   Point get();
   void set (    Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartPointIsStub Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : StartPointIsStub Property

Glossary Item Box

If the StartPoint was hidden due to a non expanded or non visible grid node this value is true

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartPointIsStub As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Boolean

value = instance.StartPointIsStub
C#
public bool StartPointIsStub {get;}
Managed Extensions for C++
public: __property bool get_StartPointIsStub();
C++/CLI
public:
property bool StartPointIsStub {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Target Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Target Property

Glossary Item Box

The target time item, where the link ends

Syntax

Visual Basic (Declaration)
Public Property Target As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As TimeItem

instance.Target = value

value = instance.Target
C#
public TimeItem Target {get; set;}
Managed Extensions for C++
public: __property TimeItem* get_Target();
public: __property void set_Target(
   TimeItem* value
);
C++/CLI
public:
property TimeItem^ Target {
   TimeItem^ get();
   void set (    TimeItem^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TargetKey Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : TargetKey Property

Glossary Item Box

The TargetKey is the key of the time item that acts as target. This value is set by the LinkDataConnect when you use databind for TimeItemLinks.

Syntax

Visual Basic (Declaration)
Public Property TargetKey As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As String

instance.TargetKey = value

value = instance.TargetKey
C#
public string TargetKey {get; set;}
Managed Extensions for C++
public: __property string* get_TargetKey();
public: __property void set_TargetKey(
   string* value
);
C++/CLI
public:
property String^ TargetKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TargetPoint Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : TargetPoint Property

Glossary Item Box

The TargetPoint in screen pixels. You can set this value in the OnUserDrawLink event. This point is used as a selection hotspot, and should correspond to the TargetPoint of the link.

Syntax

Visual Basic (Declaration)
Public Property TargetPoint As Point
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Point

instance.TargetPoint = value

value = instance.TargetPoint
C#
public Point TargetPoint {get; set;}
Managed Extensions for C++
public: __property Point get_TargetPoint();
public: __property void set_TargetPoint(
   Point value
);
C++/CLI
public:
property Point TargetPoint {
   Point get();
   void set (    Point value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TargetPointIsStub Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : TargetPointIsStub Property

Glossary Item Box

If the TargetPoint was hidden due to a non expanded or non visible grid node this value is true

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetPointIsStub As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Boolean

value = instance.TargetPointIsStub
C#
public bool TargetPointIsStub {get;}
Managed Extensions for C++
public: __property bool get_TargetPointIsStub();
C++/CLI
public:
property bool TargetPointIsStub {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkDrawStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : TimeItemLinkDrawStyle Property

Glossary Item Box

The timeItemLinkDrawStyle of the link

Syntax

Visual Basic (Declaration)
Public Property TimeItemLinkDrawStyle As TimeItemLinkDrawStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As TimeItemLinkDrawStyle

instance.TimeItemLinkDrawStyle = value

value = instance.TimeItemLinkDrawStyle
C#
public TimeItemLinkDrawStyle TimeItemLinkDrawStyle {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkDrawStyle get_TimeItemLinkDrawStyle();
public: __property void set_TimeItemLinkDrawStyle(
   TimeItemLinkDrawStyle value
);
C++/CLI
public:
property TimeItemLinkDrawStyle TimeItemLinkDrawStyle {
   TimeItemLinkDrawStyle get();
   void set (    TimeItemLinkDrawStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : TimeItemLinkStyle Property

Glossary Item Box

Different styles of the link

Syntax

Visual Basic (Declaration)
Public Property TimeItemLinkStyle As TimeItemLinkStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As TimeItemLinkStyle

instance.TimeItemLinkStyle = value

value = instance.TimeItemLinkStyle
C#
public TimeItemLinkStyle TimeItemLinkStyle {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkStyle get_TimeItemLinkStyle();
public: __property void set_TimeItemLinkStyle(
   TimeItemLinkStyle value
);
C++/CLI
public:
property TimeItemLinkStyle TimeItemLinkStyle {
   TimeItemLinkStyle get();
   void set (    TimeItemLinkStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserReference Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : UserReference Property

Glossary Item Box

User reference, use this to tie against your own data

Syntax

Visual Basic (Declaration)
Public Property UserReference As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Object

instance.UserReference = value

value = instance.UserReference
C#
public object UserReference {get; set;}
Managed Extensions for C++
public: __property Object* get_UserReference();
public: __property void set_UserReference(
   Object* value
);
C++/CLI
public:
property Object^ UserReference {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Width Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : Width Property

Glossary Item Box

The Width of the link

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
public:
property int Width {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ZIndex Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLink Class : ZIndex Property

Glossary Item Box

ZIndex allows you to control if the link is drawn above a particular time item layer index or not 0 in ZIndex will ensure the link being drawn below all time items in layer 0 and above 1 in ZIndex will make the links go above layer 0 time items, but below layer 1 time items 999 will put your links on top (unless you have time items in layer 999) 999 is the default value to keep backwards compability when all links were drawn on top

Syntax

Visual Basic (Declaration)
Public Property ZIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLink
Dim value As Integer

instance.ZIndex = value

value = instance.ZIndex
C#
public int ZIndex {get; set;}
Managed Extensions for C++
public: __property int get_ZIndex();
public: __property void set_ZIndex(
   int value
);
C++/CLI
public:
property int ZIndex {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLink Class
TimeItemLink Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkArgs Class

Glossary Item Box

TimeItemLinkArgs

Object Model

TimeItemLinkArgs Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemLinkArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkArgs
C#
public class TimeItemLinkArgs : System.EventArgs
Managed Extensions for C++
public __gc class TimeItemLinkArgs : public System.EventArgs
C++/CLI
public ref class TimeItemLinkArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.TimeItemLinkArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLinkArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemLinkArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkArgs Class

Glossary Item Box

The following tables list the members exposed by TimeItemLinkArgs.

Public Constructors

 | Name | Description
Public Constructor | TimeItemLinkArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ListItem | CurrencyManager ListItem
Public Field | TimeItemLink | The time item link in question for the current data operation
Top

See Also

Reference

TimeItemLinkArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinkArgs Class : TimeItemLinkArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemLinkArgs()
C#
public TimeItemLinkArgs()
Managed Extensions for C++
public: TimeItemLinkArgs();
C++/CLI
public:
TimeItemLinkArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinkArgs Class
TimeItemLinkArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
TimeItemLinkArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkArgs Class

Glossary Item Box

For a list of all members of this type, see TimeItemLinkArgs members.

Public Fields

 | Name | Description
Public Field | ListItem | CurrencyManager ListItem
Public Field | TimeItemLink | The time item link in question for the current data operation
Top

See Also

Reference

TimeItemLinkArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ListItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinkArgs Class : ListItem Field

Glossary Item Box

CurrencyManager ListItem

Syntax

Visual Basic (Declaration)
Public ListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkArgs
Dim value As Object

value = instance.ListItem

instance.ListItem = value
C#
public object ListItem
Managed Extensions for C++
public: Object* ListItem
C++/CLI
public:
Object^ ListItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinkArgs Class
TimeItemLinkArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLink Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinkArgs Class : TimeItemLink Field

Glossary Item Box

The time item link in question for the current data operation

Syntax

Visual Basic (Declaration)
Public TimeItemLink As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkArgs
Dim value As TimeItemLink

value = instance.TimeItemLink

instance.TimeItemLink = value
C#
public TimeItemLink TimeItemLink
Managed Extensions for C++
public: TimeItemLink* TimeItemLink
C++/CLI
public:
TimeItemLink^ TimeItemLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinkArgs Class
TimeItemLinkArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinks Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinks Class

Glossary Item Box

The collection of all links in the Gantt

Object Model

TimeItemLinks ClassTimeItemLink ClassTimeItemLink Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class TimeItemLinks
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
C#
[DefaultMemberAttribute("Item")]
public class TimeItemLinks
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class TimeItemLinks
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class TimeItemLinks

Example

TimeItemLink Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemLinks

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLinks Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemLinks Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinks Class

Glossary Item Box

The following tables list the members exposed by TimeItemLinks.

Public Properties

 | Name | Description
Public Property | Count | Returns how many links that are in the gantt
Public Property | CreationTimeItemLinkColor | This is the color that is used during link creation. Default black See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkDrawStyle | This is the TimeItemLinkDrawStyle that is used during link creation. Default TimeItemLinkDrawStyle.Straight. See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkStyle | This is the TimeItemLinkStyle that is used during link creation. Default TimeItemLinkStyle.StopToStart. See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkWidth | This is the width that is used during link creation. Default 2 See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | DataMember | The DataSource datamember
Public Property | DataSource | The DataSource DataSource takes an IListSource.
Public Property | Item | The indexer
Public Property | LinkSelection_ColorBG | This is the background color that is used when drawing link selections
Public Property | LinkSelection_ColorFG | This is the foreground color that is used when drawing link selections
Public Property | LinkSelection_HatchStyle | This is the hatchstyle that is used when drawing link selections
Public Property | LinkSelectionMarkerPen | DEPRECATED: This is the pen that is used to visualize LinkSelection. You can assign a new pen to control the color and width of the pen used.
Public Property | LinkSelectionMarkerRadius | This is the radius that is used on the circle that is drawn to visualize LinkSelection.
Public Property | NameInDS_StartKey | If you use databind to set up links, the link must have an Identity string to the Start and Target time items. This is where you set up the name of the dataset field
Public Property | NameInDS_TargetKey | Please see descrition for NameInDS_StartKey
Public Property | SelectedLink | Returns the currently selected link.
Public Property | SelectedStartPoint | If there is a selected time item link in the SelectedLink property, this property tells you if it is the Start point (true) or Target point (False) that was selected
Public Property | TimeItemLinkDrawStrategy | Decides how to treat the time item links for time items on opposite sides of the visible area
Top

Public Methods

 | Name | Description
Public Method | AddLink | Add a link between two time items
Public Method | CheckForHotSpotSelect | Selects a link based from a point. Made public mainly to service Gantt_ASP
Public Method | Clear | Clear all links
Public Method | DrawCommonLinks | Overloaded. You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it
Public Method | DropLink | Remove a given link
Public Method | GetLinksFromStart | Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a start object.
Public Method | GetLinksFromTarget | Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a target object.
Public Method | GetTimeItemLinkBoundingRegion | Given a link return a Bounding Region
Public Method | GetTimeItemLinks | Get a list of Time Item Links at point
Public Method | IndexOf | Index of time item link
Public Method | LinkDataConnect | Returns the LinkDataConnect for this TimeItemLinks, if it is not created yet it will be by this call.
Top

Public Events

 | Name | Description
Public Event | OnRemoveTimeItemLink | This event is raised whenever link is removed from collection
Top

See Also

Reference

TimeItemLinks Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemLinks Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinks Class

Glossary Item Box

For a list of all members of this type, see TimeItemLinks members.

Public Methods

 | Name | Description
Public Method | AddLink | Add a link between two time items
Public Method | CheckForHotSpotSelect | Selects a link based from a point. Made public mainly to service Gantt_ASP
Public Method | Clear | Clear all links
Public Method | DrawCommonLinks | Overloaded. You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it
Public Method | DropLink | Remove a given link
Public Method | GetLinksFromStart | Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a start object.
Public Method | GetLinksFromTarget | Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a target object.
Public Method | GetTimeItemLinkBoundingRegion | Given a link return a Bounding Region
Public Method | GetTimeItemLinks | Get a list of Time Item Links at point
Public Method | IndexOf | Index of time item link
Public Method | LinkDataConnect | Returns the LinkDataConnect for this TimeItemLinks, if it is not created yet it will be by this call.
Top

See Also

Reference

TimeItemLinks Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AddLink Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : AddLink Method

aStart
aTarget

Glossary Item Box

Add a link between two time items

Syntax

Visual Basic (Declaration)
Public Function AddLink( _
   ByVal aStart As TimeItem, _
   ByVal aTarget As TimeItem _
) As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim aStart As TimeItem
Dim aTarget As TimeItem
Dim value As TimeItemLink

value = instance.AddLink(aStart, aTarget)
C#
public TimeItemLink AddLink(
   TimeItem aStart,
   TimeItem aTarget
)
Managed Extensions for C++
public: TimeItemLink* AddLink(
   TimeItem* aStart,
   TimeItem* aTarget
)
C++/CLI
public:
TimeItemLink^ AddLink(
   TimeItem^ aStart,
   TimeItem^ aTarget
)

Parameters

aStart
aTarget

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CheckForHotSpotSelect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : CheckForHotSpotSelect Method

p
AllowLinkReAssign

Glossary Item Box

Selects a link based from a point. Made public mainly to service Gantt_ASP

Syntax

Visual Basic (Declaration)
Public Sub CheckForHotSpotSelect( _
   ByVal p As Point, _
   ByRef AllowLinkReAssign As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim p As Point
Dim AllowLinkReAssign As Boolean

instance.CheckForHotSpotSelect(p, AllowLinkReAssign)
C#
public void CheckForHotSpotSelect(
   Point p,
   out bool AllowLinkReAssign
)
Managed Extensions for C++
public: void CheckForHotSpotSelect(
   Point p,
   [PARAMFLAG::Out] bool AllowLinkReAssign
)
C++/CLI
public:
void CheckForHotSpotSelect(
   Point p,
   [Out] bool AllowLinkReAssign
)

Parameters

p
AllowLinkReAssign

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clear Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : Clear Method

Glossary Item Box

Clear all links

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawCommonLinks Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : DrawCommonLinks Method

Glossary Item Box

You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it

Overload List

Overload | Description
DrawCommonLinks(Graphics,Point,Point,TimeItemLink) | You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it
DrawCommonLinks(Graphics,Point,Point,TimeItemLink,Region) | You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawCommonLinks(Graphics,Point,Point,TimeItemLink) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class > DrawCommonLinks Method : DrawCommonLinks(Graphics,Point,Point,TimeItemLink) Method

g
sp
tp
aLink

Glossary Item Box

You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawCommonLinks( _
   ByVal g As Graphics, _
   ByVal sp As Point, _
   ByVal tp As Point, _
   ByVal aLink As TimeItemLink _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim g As Graphics
Dim sp As Point
Dim tp As Point
Dim aLink As TimeItemLink

instance.DrawCommonLinks(g, sp, tp, aLink)
C#
public void DrawCommonLinks(
   Graphics g,
   Point sp,
   Point tp,
   TimeItemLink aLink
)
Managed Extensions for C++
public: void DrawCommonLinks(
   Graphics* g,
   Point sp,
   Point tp,
   TimeItemLink* aLink
)
C++/CLI
public:
void DrawCommonLinks(
   Graphics^ g,
   Point sp,
   Point tp,
   TimeItemLink^ aLink
)

Parameters

g
sp
tp
aLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
DrawCommonLinks(Graphics,Point,Point,TimeItemLink,Region) Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class > DrawCommonLinks Method : DrawCommonLinks(Graphics,Point,Point,TimeItemLink,Region) Method

g
sp
tp
aLink
rgn

Glossary Item Box

You may call this if you are implementing user drawn links and need to merly add stuff, not completly change it

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawCommonLinks( _
   ByVal g As Graphics, _
   ByVal sp As Point, _
   ByVal tp As Point, _
   ByVal aLink As TimeItemLink, _
   ByVal rgn As Region _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim g As Graphics
Dim sp As Point
Dim tp As Point
Dim aLink As TimeItemLink
Dim rgn As Region

instance.DrawCommonLinks(g, sp, tp, aLink, rgn)
C#
public void DrawCommonLinks(
   Graphics g,
   Point sp,
   Point tp,
   TimeItemLink aLink,
   Region rgn
)
Managed Extensions for C++
public: void DrawCommonLinks(
   Graphics* g,
   Point sp,
   Point tp,
   TimeItemLink* aLink,
   Region* rgn
)
C++/CLI
public:
void DrawCommonLinks(
   Graphics^ g,
   Point sp,
   Point tp,
   TimeItemLink^ aLink,
   Region^ rgn
)

Parameters

g
sp
tp
aLink
rgn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
DropLink Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : DropLink Method

aLink

Glossary Item Box

Remove a given link

Syntax

Visual Basic (Declaration)
Public Sub DropLink( _
   ByVal aLink As TimeItemLink _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim aLink As TimeItemLink

instance.DropLink(aLink)
C#
public void DropLink(
   TimeItemLink aLink
)
Managed Extensions for C++
public: void DropLink(
   TimeItemLink* aLink
)
C++/CLI
public:
void DropLink(
   TimeItemLink^ aLink
)

Parameters

aLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetLinksFromStart Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : GetLinksFromStart Method

aStart

Glossary Item Box

Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a start object.

Syntax

Visual Basic (Declaration)
Public Function GetLinksFromStart( _
   ByVal aStart As TimeItem _
) As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim aStart As TimeItem
Dim value As ArrayList

value = instance.GetLinksFromStart(aStart)
C#
public ArrayList GetLinksFromStart(
   TimeItem aStart
)
Managed Extensions for C++
public: ArrayList* GetLinksFromStart(
   TimeItem* aStart
)
C++/CLI
public:
ArrayList^ GetLinksFromStart(
   TimeItem^ aStart
)

Parameters

aStart

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetLinksFromTarget Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : GetLinksFromTarget Method

aTarget

Glossary Item Box

Returns an ArrayList with all TimeItemLinks that connect to the given TimeItem as a target object.

Syntax

Visual Basic (Declaration)
Public Function GetLinksFromTarget( _
   ByVal aTarget As TimeItem _
) As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim aTarget As TimeItem
Dim value As ArrayList

value = instance.GetLinksFromTarget(aTarget)
C#
public ArrayList GetLinksFromTarget(
   TimeItem aTarget
)
Managed Extensions for C++
public: ArrayList* GetLinksFromTarget(
   TimeItem* aTarget
)
C++/CLI
public:
ArrayList^ GetLinksFromTarget(
   TimeItem^ aTarget
)

Parameters

aTarget

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetTimeItemLinkBoundingRegion Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : GetTimeItemLinkBoundingRegion Method

aLink

Glossary Item Box

Given a link return a Bounding Region

Syntax

Visual Basic (Declaration)
Public Function GetTimeItemLinkBoundingRegion( _
   ByVal aLink As TimeItemLink _
) As Region
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim aLink As TimeItemLink
Dim value As Region

value = instance.GetTimeItemLinkBoundingRegion(aLink)
C#
public Region GetTimeItemLinkBoundingRegion(
   TimeItemLink aLink
)
Managed Extensions for C++
public: Region* GetTimeItemLinkBoundingRegion(
   TimeItemLink* aLink
)
C++/CLI
public:
Region^ GetTimeItemLinkBoundingRegion(
   TimeItemLink^ aLink
)

Parameters

aLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetTimeItemLinks Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : GetTimeItemLinks Method

point

Glossary Item Box

Get a list of Time Item Links at point

Syntax

Visual Basic (Declaration)
Public Function GetTimeItemLinks( _
   ByVal point As Point _
) As TimeItemLink()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim point As Point
Dim value() As TimeItemLink

value = instance.GetTimeItemLinks(point)
C#
public TimeItemLink[] GetTimeItemLinks(
   Point point
)
Managed Extensions for C++
public: TimeItemLink*[]* GetTimeItemLinks(
   Point point
)
C++/CLI
public:
array<TimeItemLink^>^ GetTimeItemLinks(
   Point point
)

Parameters

point

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : IndexOf Method

value

Glossary Item Box

Index of time item link

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkDataConnect Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkDataConnect Method

Glossary Item Box

Returns the LinkDataConnect for this TimeItemLinks, if it is not created yet it will be by this call.

Syntax

Visual Basic (Declaration)
Public Function LinkDataConnect() As LinkDataConnect
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As LinkDataConnect

value = instance.LinkDataConnect()
C#
public LinkDataConnect LinkDataConnect()
Managed Extensions for C++
public: LinkDataConnect* LinkDataConnect();
C++/CLI
public:
LinkDataConnect^ LinkDataConnect();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemLinks Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinks Class

Glossary Item Box

For a list of all members of this type, see TimeItemLinks members.

Public Properties

 | Name | Description
Public Property | Count | Returns how many links that are in the gantt
Public Property | CreationTimeItemLinkColor | This is the color that is used during link creation. Default black See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkDrawStyle | This is the TimeItemLinkDrawStyle that is used during link creation. Default TimeItemLinkDrawStyle.Straight. See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkStyle | This is the TimeItemLinkStyle that is used during link creation. Default TimeItemLinkStyle.StopToStart. See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | CreationTimeItemLinkWidth | This is the width that is used during link creation. Default 2 See Gantt.EnterLinkCreateMode to create links by user drag.
Public Property | DataMember | The DataSource datamember
Public Property | DataSource | The DataSource DataSource takes an IListSource.
Public Property | Item | The indexer
Public Property | LinkSelection_ColorBG | This is the background color that is used when drawing link selections
Public Property | LinkSelection_ColorFG | This is the foreground color that is used when drawing link selections
Public Property | LinkSelection_HatchStyle | This is the hatchstyle that is used when drawing link selections
Public Property | LinkSelectionMarkerPen | DEPRECATED: This is the pen that is used to visualize LinkSelection. You can assign a new pen to control the color and width of the pen used.
Public Property | LinkSelectionMarkerRadius | This is the radius that is used on the circle that is drawn to visualize LinkSelection.
Public Property | NameInDS_StartKey | If you use databind to set up links, the link must have an Identity string to the Start and Target time items. This is where you set up the name of the dataset field
Public Property | NameInDS_TargetKey | Please see descrition for NameInDS_StartKey
Public Property | SelectedLink | Returns the currently selected link.
Public Property | SelectedStartPoint | If there is a selected time item link in the SelectedLink property, this property tells you if it is the Start point (true) or Target point (False) that was selected
Public Property | TimeItemLinkDrawStrategy | Decides how to treat the time item links for time items on opposite sides of the visible area
Top

See Also

Reference

TimeItemLinks Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Count Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : Count Property

Glossary Item Box

Returns how many links that are in the gantt

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CreationTimeItemLinkColor Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : CreationTimeItemLinkColor Property

Glossary Item Box

This is the color that is used during link creation. Default black See Gantt.EnterLinkCreateMode to create links by user drag.

Syntax

Visual Basic (Declaration)
Public Property CreationTimeItemLinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Color

instance.CreationTimeItemLinkColor = value

value = instance.CreationTimeItemLinkColor
C#
public Color CreationTimeItemLinkColor {get; set;}
Managed Extensions for C++
public: __property Color get_CreationTimeItemLinkColor();
public: __property void set_CreationTimeItemLinkColor(
   Color value
);
C++/CLI
public:
property Color CreationTimeItemLinkColor {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CreationTimeItemLinkDrawStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : CreationTimeItemLinkDrawStyle Property

Glossary Item Box

This is the TimeItemLinkDrawStyle that is used during link creation. Default TimeItemLinkDrawStyle.Straight. See Gantt.EnterLinkCreateMode to create links by user drag.

Syntax

Visual Basic (Declaration)
Public Property CreationTimeItemLinkDrawStyle As TimeItemLinkDrawStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As TimeItemLinkDrawStyle

instance.CreationTimeItemLinkDrawStyle = value

value = instance.CreationTimeItemLinkDrawStyle
C#
public TimeItemLinkDrawStyle CreationTimeItemLinkDrawStyle {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkDrawStyle get_CreationTimeItemLinkDrawStyle();
public: __property void set_CreationTimeItemLinkDrawStyle(
   TimeItemLinkDrawStyle value
);
C++/CLI
public:
property TimeItemLinkDrawStyle CreationTimeItemLinkDrawStyle {
   TimeItemLinkDrawStyle get();
   void set (    TimeItemLinkDrawStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CreationTimeItemLinkStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : CreationTimeItemLinkStyle Property

Glossary Item Box

This is the TimeItemLinkStyle that is used during link creation. Default TimeItemLinkStyle.StopToStart. See Gantt.EnterLinkCreateMode to create links by user drag.

Syntax

Visual Basic (Declaration)
Public Property CreationTimeItemLinkStyle As TimeItemLinkStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As TimeItemLinkStyle

instance.CreationTimeItemLinkStyle = value

value = instance.CreationTimeItemLinkStyle
C#
public TimeItemLinkStyle CreationTimeItemLinkStyle {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkStyle get_CreationTimeItemLinkStyle();
public: __property void set_CreationTimeItemLinkStyle(
   TimeItemLinkStyle value
);
C++/CLI
public:
property TimeItemLinkStyle CreationTimeItemLinkStyle {
   TimeItemLinkStyle get();
   void set (    TimeItemLinkStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
CreationTimeItemLinkWidth Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : CreationTimeItemLinkWidth Property

Glossary Item Box

This is the width that is used during link creation. Default 2 See Gantt.EnterLinkCreateMode to create links by user drag.

Syntax

Visual Basic (Declaration)
Public Property CreationTimeItemLinkWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Integer

instance.CreationTimeItemLinkWidth = value

value = instance.CreationTimeItemLinkWidth
C#
public int CreationTimeItemLinkWidth {get; set;}
Managed Extensions for C++
public: __property int get_CreationTimeItemLinkWidth();
public: __property void set_CreationTimeItemLinkWidth(
   int value
);
C++/CLI
public:
property int CreationTimeItemLinkWidth {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataMember Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : DataMember Property

Glossary Item Box

The DataSource datamember

Syntax

Visual Basic (Declaration)
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
public string DataMember {get; set;}
Managed Extensions for C++
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
public:
property String^ DataMember {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
DataSource Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : DataSource Property

Glossary Item Box

The DataSource DataSource takes an IListSource.

Syntax

Visual Basic (Declaration)
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public object DataSource {get; set;}
Managed Extensions for C++
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
   void set (    Object^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : Item Property

Index

Glossary Item Box

The indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim Index As Integer
Dim value As TimeItemLink

value = instance.Item(Index)
C#
public TimeItemLink this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property TimeItemLink* get_Item   int Index
;
C++/CLI
public:
property TimeItemLink^ default [int] {
   TimeItemLink^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkSelection_ColorBG Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkSelection_ColorBG Property

Glossary Item Box

This is the background color that is used when drawing link selections

Syntax

Visual Basic (Declaration)
Public Property LinkSelection_ColorBG As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Color

instance.LinkSelection_ColorBG = value

value = instance.LinkSelection_ColorBG
C#
public Color LinkSelection_ColorBG {get; set;}
Managed Extensions for C++
public: __property Color get_LinkSelection_ColorBG();
public: __property void set_LinkSelection_ColorBG(
   Color value
);
C++/CLI
public:
property Color LinkSelection_ColorBG {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkSelection_ColorFG Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkSelection_ColorFG Property

Glossary Item Box

This is the foreground color that is used when drawing link selections

Syntax

Visual Basic (Declaration)
Public Property LinkSelection_ColorFG As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Color

instance.LinkSelection_ColorFG = value

value = instance.LinkSelection_ColorFG
C#
public Color LinkSelection_ColorFG {get; set;}
Managed Extensions for C++
public: __property Color get_LinkSelection_ColorFG();
public: __property void set_LinkSelection_ColorFG(
   Color value
);
C++/CLI
public:
property Color LinkSelection_ColorFG {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkSelection_HatchStyle Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkSelection_HatchStyle Property

Glossary Item Box

This is the hatchstyle that is used when drawing link selections

Syntax

Visual Basic (Declaration)
Public Property LinkSelection_HatchStyle As HatchStyle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As HatchStyle

instance.LinkSelection_HatchStyle = value

value = instance.LinkSelection_HatchStyle
C#
public HatchStyle LinkSelection_HatchStyle {get; set;}
Managed Extensions for C++
public: __property HatchStyle get_LinkSelection_HatchStyle();
public: __property void set_LinkSelection_HatchStyle(
   HatchStyle value
);
C++/CLI
public:
property HatchStyle LinkSelection_HatchStyle {
   HatchStyle get();
   void set (    HatchStyle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkSelectionMarkerPen Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkSelectionMarkerPen Property

Glossary Item Box

DEPRECATED: This is the pen that is used to visualize LinkSelection. You can assign a new pen to control the color and width of the pen used.

Syntax

Visual Basic (Declaration)
Public Property LinkSelectionMarkerPen As Pen
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Pen

instance.LinkSelectionMarkerPen = value

value = instance.LinkSelectionMarkerPen
C#
public Pen LinkSelectionMarkerPen {get; set;}
Managed Extensions for C++
public: __property Pen* get_LinkSelectionMarkerPen();
public: __property void set_LinkSelectionMarkerPen(
   Pen* value
);
C++/CLI
public:
property Pen^ LinkSelectionMarkerPen {
   Pen^ get();
   void set (    Pen^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkSelectionMarkerRadius Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : LinkSelectionMarkerRadius Property

Glossary Item Box

This is the radius that is used on the circle that is drawn to visualize LinkSelection.

Syntax

Visual Basic (Declaration)
Public Property LinkSelectionMarkerRadius As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Integer

instance.LinkSelectionMarkerRadius = value

value = instance.LinkSelectionMarkerRadius
C#
public int LinkSelectionMarkerRadius {get; set;}
Managed Extensions for C++
public: __property int get_LinkSelectionMarkerRadius();
public: __property void set_LinkSelectionMarkerRadius(
   int value
);
C++/CLI
public:
property int LinkSelectionMarkerRadius {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_StartKey Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : NameInDS_StartKey Property

Glossary Item Box

If you use databind to set up links, the link must have an Identity string to the Start and Target time items. This is where you set up the name of the dataset field

Syntax

Visual Basic (Declaration)
Public Property NameInDS_StartKey As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As String

instance.NameInDS_StartKey = value

value = instance.NameInDS_StartKey
C#
public string NameInDS_StartKey {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_StartKey();
public: __property void set_NameInDS_StartKey(
   string* value
);
C++/CLI
public:
property String^ NameInDS_StartKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NameInDS_TargetKey Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : NameInDS_TargetKey Property

Glossary Item Box

Please see descrition for NameInDS_StartKey

Syntax

Visual Basic (Declaration)
Public Property NameInDS_TargetKey As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As String

instance.NameInDS_TargetKey = value

value = instance.NameInDS_TargetKey
C#
public string NameInDS_TargetKey {get; set;}
Managed Extensions for C++
public: __property string* get_NameInDS_TargetKey();
public: __property void set_NameInDS_TargetKey(
   string* value
);
C++/CLI
public:
property String^ NameInDS_TargetKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectedLink Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : SelectedLink Property

Glossary Item Box

Returns the currently selected link.

Syntax

Visual Basic (Declaration)
Public Property SelectedLink As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As TimeItemLink

instance.SelectedLink = value

value = instance.SelectedLink
C#
public TimeItemLink SelectedLink {get; set;}
Managed Extensions for C++
public: __property TimeItemLink* get_SelectedLink();
public: __property void set_SelectedLink(
   TimeItemLink* value
);
C++/CLI
public:
property TimeItemLink^ SelectedLink {
   TimeItemLink^ get();
   void set (    TimeItemLink^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SelectedStartPoint Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : SelectedStartPoint Property

Glossary Item Box

If there is a selected time item link in the SelectedLink property, this property tells you if it is the Start point (true) or Target point (False) that was selected

Syntax

Visual Basic (Declaration)
Public Property SelectedStartPoint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As Boolean

instance.SelectedStartPoint = value

value = instance.SelectedStartPoint
C#
public bool SelectedStartPoint {get; set;}
Managed Extensions for C++
public: __property bool get_SelectedStartPoint();
public: __property void set_SelectedStartPoint(
   bool value
);
C++/CLI
public:
property bool SelectedStartPoint {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkDrawStrategy Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : TimeItemLinkDrawStrategy Property

Glossary Item Box

Decides how to treat the time item links for time items on opposite sides of the visible area

Syntax

Visual Basic (Declaration)
Public Property TimeItemLinkDrawStrategy As TimeItemLinkDrawStrategy
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim value As TimeItemLinkDrawStrategy

instance.TimeItemLinkDrawStrategy = value

value = instance.TimeItemLinkDrawStrategy
C#
public TimeItemLinkDrawStrategy TimeItemLinkDrawStrategy {get; set;}
Managed Extensions for C++
public: __property TimeItemLinkDrawStrategy get_TimeItemLinkDrawStrategy();
public: __property void set_TimeItemLinkDrawStrategy(
   TimeItemLinkDrawStrategy value
);
C++/CLI
public:
property TimeItemLinkDrawStrategy TimeItemLinkDrawStrategy {
   TimeItemLinkDrawStrategy get();
   void set (    TimeItemLinkDrawStrategy value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
TimeItemLinks Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinks Class

Glossary Item Box

For a list of all members of this type, see TimeItemLinks members.

Public Events

 | Name | Description
Public Event | OnRemoveTimeItemLink | This event is raised whenever link is removed from collection
Top

See Also

Reference

TimeItemLinks Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OnRemoveTimeItemLink Event
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemLinks Class : OnRemoveTimeItemLink Event

Glossary Item Box

This event is raised whenever link is removed from collection

Syntax

Visual Basic (Declaration)
Public Event OnRemoveTimeItemLink As TimeItemLinkHandler
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinks
Dim handler As TimeItemLinkHandler

AddHandler instance.OnRemoveTimeItemLink, handler
C#
public event TimeItemLinkHandler OnRemoveTimeItemLink
Managed Extensions for C++
public: __event TimeItemLinkHandler* OnRemoveTimeItemLink
C++/CLI
public:
event TimeItemLinkHandler^ OnRemoveTimeItemLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemLinks Class
TimeItemLinks Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemText Class
Members Example See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemText Class

Glossary Item Box

TimeItemText handles the drawing of texts inside TimeItems

Object Model

TimeItemText ClassTimeItemTextLayout ClassTimeItemTexts ClassTimeItemText Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.TimeItemText+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class TimeItemText
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText
C#
[TypeConverterAttribute("PlexityHide.GTP.TimeItemText+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class TimeItemText
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.TimeItemText+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class TimeItemText
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.TimeItemText+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class TimeItemText

Example

C# Copy Code
GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
gn.GetCell(0).Content.Value="Sample of Texts inside time items";
GanttRow gr = GanttRow.FromGridNode(gn);
gr.CollisionDetect=false;
TimeItem ti1=gr.Layers[0].AddNewTimeItem();
TimeItem ti2=gr.Layers[0].AddNewTimeItem();

TimeItemText titext1=new TimeItemText();
titext1.Text="Sample text";
//titext1.TimeItemTextLayout=new TimeItemTextLayout();
titext1.TimeItemTextLayout=gantt1.TimeItemTextLayouts.GetFromName("Default");
titext1.TimeItemTextLayout.Color=Color.PowderBlue;
titext1.TimeItemTextLayout.Font=new Font(FontFamily.GenericMonospace,14,FontStyle.Bold);
titext1.TimeItemTextLayout.Padding=new Rectangle(2,2,2,2);
titext1.TimeItemTextLayout.VertAlign=StringAlignment.Near;
ti1.TimeItemTexts.Add(titext1);
ti1.TimeItemLayout= new TimeItemLayout();
ti1.TimeItemLayout.SelectHandles=Color.Black;
ti1.TimeItemLayout.Color=Color.SlateBlue;

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);
ti1.Stop=ti1.Start.AddDays(10);

TimeItemText titext2=new TimeItemText();
titext2.Text="Another text same layout";
titext2.TimeItemTextLayout=titext1.TimeItemTextLayout;
ti2.TimeItemTexts.Add(titext2);
ti2.Start=ti1.Stop.AddDays(1);
ti2.Stop=ti2.Start.AddDays(10);
ti2.TimeItemLayout= new TimeItemLayout();
ti2.TimeItemLayout.SelectHandles=Color.Black;
ti2.TimeItemLayout.Color=Color.OrangeRed;
Visual Basic Copy Code
Dim gn As GridNode=gantt1.Grid.GridStructure.RootNodes.AddNode()
gn.GetCell(0).Content.Value="Sample of Texts inside time items"
Dim gr As GanttRow = GanttRow.FromGridNode(gn)
gr.CollisionDetect=False
Dim ti1 As TimeItem=gr.Layers(0).AddNewTimeItem()
Dim ti2 As TimeItem=gr.Layers(0).AddNewTimeItem()

Dim titext1 As TimeItemText = New TimeItemText()
titext1.Text="Sample text"
'titext1.TimeItemTextLayout=new TimeItemTextLayout();
titext1.TimeItemTextLayout=gantt1.TimeItemTextLayouts.GetFromName("Default")
titext1.TimeItemTextLayout.Color=Color.PowderBlue
titext1.TimeItemTextLayout.Font = New Font(FontFamily.GenericMonospace,14,FontStyle.Bold)
titext1.TimeItemTextLayout.Padding = New Rectangle(2,2,2,2)
titext1.TimeItemTextLayout.VertAlign=StringAlignment.Near
ti1.TimeItemTexts.Add(titext1)
ti1.TimeItemLayout= New TimeItemLayout()
ti1.TimeItemLayout.SelectHandles=Color.Black
ti1.TimeItemLayout.Color=Color.SlateBlue

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1)
ti1.Stop=ti1.Start.AddDays(10)

Dim titext2 As TimeItemText = New TimeItemText()
titext2.Text="Another text same layout"
titext2.TimeItemTextLayout=titext1.TimeItemTextLayout
ti2.TimeItemTexts.Add(titext2)
ti2.Start=ti1.Stop.AddDays(1)
ti2.Stop=ti2.Start.AddDays(10)
ti2.TimeItemLayout= New TimeItemLayout()
ti2.TimeItemLayout.SelectHandles=Color.Black
ti2.TimeItemLayout.Color=Color.OrangeRed

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemText

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemText Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemText Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemText Class

Glossary Item Box

The following tables list the members exposed by TimeItemText.

Public Constructors

 | Name | Description
Public Constructor | TimeItemText Constructor |
Top

Public Properties

 | Name | Description
Public Property | Text | The string that is drawn
Public Property | TimeItemTextLayout | The TimeItemTextLayout that will be used for rendering
Public Property | TimeItemTextLayoutName | The TimeItemTextLayout by name, that will be used for rendering
Public Property | TimeItemTexts | The owning collection
Top

Public Methods

 | Name | Description
Public Method | Changed |
Top

See Also

Reference

TimeItemText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemText Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : TimeItemText Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemText()
C#
public TimeItemText()
Managed Extensions for C++
public: TimeItemText();
C++/CLI
public:
TimeItemText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemText Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemText Class

Glossary Item Box

For a list of all members of this type, see TimeItemText members.

Public Methods

 | Name | Description
Public Method | Changed |
Top

See Also

Reference

TimeItemText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : Changed Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemText Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemText Class

Glossary Item Box

For a list of all members of this type, see TimeItemText members.

Public Properties

 | Name | Description
Public Property | Text | The string that is drawn
Public Property | TimeItemTextLayout | The TimeItemTextLayout that will be used for rendering
Public Property | TimeItemTextLayoutName | The TimeItemTextLayout by name, that will be used for rendering
Public Property | TimeItemTexts | The owning collection
Top

See Also

Reference

TimeItemText Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : Text Property

Glossary Item Box

The string that is drawn

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayout Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : TimeItemTextLayout Property

Glossary Item Box

The TimeItemTextLayout that will be used for rendering

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property TimeItemTextLayout As TimeItemTextLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText
Dim value As TimeItemTextLayout

instance.TimeItemTextLayout = value

value = instance.TimeItemTextLayout
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public TimeItemTextLayout TimeItemTextLayout {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property TimeItemTextLayout* get_TimeItemTextLayout();
public: __property void set_TimeItemTextLayout(
   TimeItemTextLayout* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property TimeItemTextLayout^ TimeItemTextLayout {
   TimeItemTextLayout^ get();
   void set (    TimeItemTextLayout^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayoutName Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : TimeItemTextLayoutName Property

Glossary Item Box

The TimeItemTextLayout by name, that will be used for rendering

Syntax

Visual Basic (Declaration)
Public Property TimeItemTextLayoutName As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText
Dim value As String

instance.TimeItemTextLayoutName = value

value = instance.TimeItemTextLayoutName
C#
public string TimeItemTextLayoutName {get; set;}
Managed Extensions for C++
public: __property string* get_TimeItemTextLayoutName();
public: __property void set_TimeItemTextLayoutName(
   string* value
);
C++/CLI
public:
property String^ TimeItemTextLayoutName {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemText Class : TimeItemTexts Property

Glossary Item Box

The owning collection

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property TimeItemTexts As TimeItemTexts
Visual Basic (Usage) Copy Code
Dim instance As TimeItemText
Dim value As TimeItemTexts

instance.TimeItemTexts = value

value = instance.TimeItemTexts
C#
[BrowsableAttribute(false)]
public TimeItemTexts TimeItemTexts {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TimeItemTexts* get_TimeItemTexts();
public: __property void set_TimeItemTexts(
   TimeItemTexts* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property TimeItemTexts^ TimeItemTexts {
   TimeItemTexts^ get();
   void set (    TimeItemTexts^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemText Class
TimeItemText Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayout Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayout Class

Glossary Item Box

Holds all the properties that define the layout for texts inside Time items.

Object Model

TimeItemTextLayout ClassTimeItemTextLayouts ClassTimeItemTextLayout Class

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("PlexityHide.GTP.TimeItemTextLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")>
<SerializableAttribute()>
Public Class TimeItemTextLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
C#
[TypeConverterAttribute("PlexityHide.GTP.TimeItemTextLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public class TimeItemTextLayout
Managed Extensions for C++
[TypeConverterAttribute("PlexityHide.GTP.TimeItemTextLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public __gc class TimeItemTextLayout
C++/CLI
[TypeConverterAttribute("PlexityHide.GTP.TimeItemTextLayout+Converter, PlexityHide.GTP, Version=4.1.4.1, Culture=neutral, PublicKeyToken=56c4486a92e3ee5c")]
[SerializableAttribute()]
public ref class TimeItemTextLayout

Example

TimeItemText Class

Inheritance Hierarchy

System.Object
PlexityHide.GTP.TimeItemTextLayout

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemTextLayout Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemTextLayout Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayout Class

Glossary Item Box

The following tables list the members exposed by TimeItemTextLayout.

Public Constructors

 | Name | Description
Public Constructor | TimeItemTextLayout Constructor |
Top

Public Properties

 | Name | Description
Public Property | Color | Color on the text
Public Property | EndEllipsis | Controls what happens if the text do not fit the given space
Public Property | Font | The font that text will be drawn with
Public Property | HorzAlign | Alignment horizontal
Public Property | ImageIndex | Image index from the imagelist in the Gantt
Public Property | Name | Name for this TimeItemTextLayout that can be set on a TimeItemText
Public Property | NoWrap | NoWrap set to true keeps text on one line
Public Property | OutsideText | Controls if the text should be rendered outside the time item or not.
Public Property | Padding | Padding controls the area for the text to be drawn in. The Padding.Top is added to the TimeItemRect.Top, the Padding.Height is substracted from TimeItemRect.Bottom, etc.
Public Property | SkipDrawIfNoFit | If the text does not fit in the rectangle (after padding) and this property is true, no text is drawn.
Public Property | TimeItemTextLayouts | Owning Collection
Public Property | VertAlign | Vertical Alignment
Top

Public Methods

 | Name | Description
Public Method | Changed |
Public Method | Clone | Clones the TimeItemTextLayout
Top

See Also

Reference

TimeItemTextLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayout Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : TimeItemTextLayout Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemTextLayout()
C#
public TimeItemTextLayout()
Managed Extensions for C++
public: TimeItemTextLayout();
C++/CLI
public:
TimeItemTextLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemTextLayout Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayout Class

Glossary Item Box

For a list of all members of this type, see TimeItemTextLayout members.

Public Methods

 | Name | Description
Public Method | Changed |
Public Method | Clone | Clones the TimeItemTextLayout
Top

See Also

Reference

TimeItemTextLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Changed Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Changed Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Changed()
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout

instance.Changed()
C#
public void Changed()
Managed Extensions for C++
public: void Changed();
C++/CLI
public:
void Changed();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Clone Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Clone Method

Glossary Item Box

Clones the TimeItemTextLayout

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemTextLayout Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayout Class

Glossary Item Box

For a list of all members of this type, see TimeItemTextLayout members.

Public Properties

 | Name | Description
Public Property | Color | Color on the text
Public Property | EndEllipsis | Controls what happens if the text do not fit the given space
Public Property | Font | The font that text will be drawn with
Public Property | HorzAlign | Alignment horizontal
Public Property | ImageIndex | Image index from the imagelist in the Gantt
Public Property | Name | Name for this TimeItemTextLayout that can be set on a TimeItemText
Public Property | NoWrap | NoWrap set to true keeps text on one line
Public Property | OutsideText | Controls if the text should be rendered outside the time item or not.
Public Property | Padding | Padding controls the area for the text to be drawn in. The Padding.Top is added to the TimeItemRect.Top, the Padding.Height is substracted from TimeItemRect.Bottom, etc.
Public Property | SkipDrawIfNoFit | If the text does not fit in the rectangle (after padding) and this property is true, no text is drawn.
Public Property | TimeItemTextLayouts | Owning Collection
Public Property | VertAlign | Vertical Alignment
Top

See Also

Reference

TimeItemTextLayout Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Color Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Color Property

Glossary Item Box

Color on the text

Syntax

Visual Basic (Declaration)
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Color

instance.Color = value

value = instance.Color
C#
public Color Color {get; set;}
Managed Extensions for C++
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
public:
property Color Color {
   Color get();
   void set (    Color value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
EndEllipsis Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : EndEllipsis Property

Glossary Item Box

Controls what happens if the text do not fit the given space

Syntax

Visual Basic (Declaration)
Public Property EndEllipsis As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Boolean

instance.EndEllipsis = value

value = instance.EndEllipsis
C#
public bool EndEllipsis {get; set;}
Managed Extensions for C++
public: __property bool get_EndEllipsis();
public: __property void set_EndEllipsis(
   bool value
);
C++/CLI
public:
property bool EndEllipsis {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Font Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Font Property

Glossary Item Box

The font that text will be drawn with

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
public:
property Font^ Font {
   Font^ get();
   void set (    Font^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
HorzAlign Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : HorzAlign Property

Glossary Item Box

Alignment horizontal

Syntax

Visual Basic (Declaration)
Public Property HorzAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As StringAlignment

instance.HorzAlign = value

value = instance.HorzAlign
C#
public StringAlignment HorzAlign {get; set;}
Managed Extensions for C++
public: __property StringAlignment get_HorzAlign();
public: __property void set_HorzAlign(
   StringAlignment value
);
C++/CLI
public:
property StringAlignment HorzAlign {
   StringAlignment get();
   void set (    StringAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageIndex Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : ImageIndex Property

Glossary Item Box

Image index from the imagelist in the Gantt

Syntax

Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
public:
property int ImageIndex {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Name Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Name Property

Glossary Item Box

Name for this TimeItemTextLayout that can be set on a TimeItemText

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
NoWrap Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : NoWrap Property

Glossary Item Box

NoWrap set to true keeps text on one line

Syntax

Visual Basic (Declaration)
Public Property NoWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Boolean

instance.NoWrap = value

value = instance.NoWrap
C#
public bool NoWrap {get; set;}
Managed Extensions for C++
public: __property bool get_NoWrap();
public: __property void set_NoWrap(
   bool value
);
C++/CLI
public:
property bool NoWrap {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
OutsideText Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : OutsideText Property

Glossary Item Box

Controls if the text should be rendered outside the time item or not.

Syntax

Visual Basic (Declaration)
Public Property OutsideText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Boolean

instance.OutsideText = value

value = instance.OutsideText
C#
public bool OutsideText {get; set;}
Managed Extensions for C++
public: __property bool get_OutsideText();
public: __property void set_OutsideText(
   bool value
);
C++/CLI
public:
property bool OutsideText {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Padding Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : Padding Property

Glossary Item Box

Padding controls the area for the text to be drawn in. The Padding.Top is added to the TimeItemRect.Top, the Padding.Height is substracted from TimeItemRect.Bottom, etc.

Syntax

Visual Basic (Declaration)
Public Property Padding As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Rectangle

instance.Padding = value

value = instance.Padding
C#
public Rectangle Padding {get; set;}
Managed Extensions for C++
public: __property Rectangle get_Padding();
public: __property void set_Padding(
   Rectangle value
);
C++/CLI
public:
property Rectangle Padding {
   Rectangle get();
   void set (    Rectangle value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
SkipDrawIfNoFit Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : SkipDrawIfNoFit Property

Glossary Item Box

If the text does not fit in the rectangle (after padding) and this property is true, no text is drawn.

Syntax

Visual Basic (Declaration)
Public Property SkipDrawIfNoFit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As Boolean

instance.SkipDrawIfNoFit = value

value = instance.SkipDrawIfNoFit
C#
public bool SkipDrawIfNoFit {get; set;}
Managed Extensions for C++
public: __property bool get_SkipDrawIfNoFit();
public: __property void set_SkipDrawIfNoFit(
   bool value
);
C++/CLI
public:
property bool SkipDrawIfNoFit {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : TimeItemTextLayouts Property

Glossary Item Box

Owning Collection

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property TimeItemTextLayouts As TimeItemTextLayouts
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As TimeItemTextLayouts

instance.TimeItemTextLayouts = value

value = instance.TimeItemTextLayouts
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public TimeItemTextLayouts TimeItemTextLayouts {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property TimeItemTextLayouts* get_TimeItemTextLayouts();
public: __property void set_TimeItemTextLayouts(
   TimeItemTextLayouts* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property TimeItemTextLayouts^ TimeItemTextLayouts {
   TimeItemTextLayouts^ get();
   void set (    TimeItemTextLayouts^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
VertAlign Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayout Class : VertAlign Property

Glossary Item Box

Vertical Alignment

Syntax

Visual Basic (Declaration)
Public Property VertAlign As StringAlignment
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayout
Dim value As StringAlignment

instance.VertAlign = value

value = instance.VertAlign
C#
public StringAlignment VertAlign {get; set;}
Managed Extensions for C++
public: __property StringAlignment get_VertAlign();
public: __property void set_VertAlign(
   StringAlignment value
);
C++/CLI
public:
property StringAlignment VertAlign {
   StringAlignment get();
   void set (    StringAlignment value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayout Class
TimeItemTextLayout Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayouts Class

Glossary Item Box

TimeItemLayouts is the collection of TimeItemLayout.

Object Model

TimeItemTextLayouts ClassTimeItemTextLayout Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class TimeItemTextLayouts
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
C#
[DefaultMemberAttribute("Item")]
public class TimeItemTextLayouts : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class TimeItemTextLayouts : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class TimeItemTextLayouts : public System.Collections.CollectionBase

Example

TimeItemText Class

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.TimeItemTextLayouts

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemTextLayouts Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemTextLayouts Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayouts Class

Glossary Item Box

The following tables list the members exposed by TimeItemTextLayouts.

Public Constructors

 | Name | Description
Public Constructor | TimeItemTextLayouts Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Item | The indexer of TimeItemTextLayouts
Top

Public Methods

 | Name | Description
Public Method | Add | Add a TimeItemTextLayout to the collection
Public Method | GetFromName | Looks up a TimeItemTextLayout by name
Public Method | IndexOf | Index of a TimeItemTextLayout in the collection
Public Method | Remove | Remove a TimeItemTextLayout by index
Top

See Also

Reference

TimeItemTextLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : TimeItemTextLayouts Constructor

Glossary Item Box

Overload List

Overload | Description
TimeItemTextLayouts Constructor() |
TimeItemTextLayouts Constructor(Gantt) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class > TimeItemTextLayouts Constructor : TimeItemTextLayouts Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemTextLayouts()
C#
public TimeItemTextLayouts()
Managed Extensions for C++
public: TimeItemTextLayouts();
C++/CLI
public:
TimeItemTextLayouts();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTextLayouts Constructor(Gantt)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class > TimeItemTextLayouts Constructor : TimeItemTextLayouts Constructor(Gantt)

aGantt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim aGantt As Gantt

Dim instance As New TimeItemTextLayouts(aGantt)
C#
public TimeItemTextLayouts(
   Gantt aGantt
)
Managed Extensions for C++
public: TimeItemTextLayouts(
   Gantt* aGantt
)
C++/CLI
public:
TimeItemTextLayouts(
   Gantt^ aGantt
)

Parameters

aGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemTextLayouts Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayouts Class

Glossary Item Box

For a list of all members of this type, see TimeItemTextLayouts members.

Public Methods

 | Name | Description
Public Method | Add | Add a TimeItemTextLayout to the collection
Public Method | GetFromName | Looks up a TimeItemTextLayout by name
Public Method | IndexOf | Index of a TimeItemTextLayout in the collection
Public Method | Remove | Remove a TimeItemTextLayout by index
Top

See Also

Reference

TimeItemTextLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : Add Method

aTimeItemTextLayout

Glossary Item Box

Add a TimeItemTextLayout to the collection

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aTimeItemTextLayout As TimeItemTextLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
Dim aTimeItemTextLayout As TimeItemTextLayout

instance.Add(aTimeItemTextLayout)
C#
public void Add(
   TimeItemTextLayout aTimeItemTextLayout
)
Managed Extensions for C++
public: void Add(
   TimeItemTextLayout* aTimeItemTextLayout
)
C++/CLI
public:
void Add(
   TimeItemTextLayout^ aTimeItemTextLayout
)

Parameters

aTimeItemTextLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
GetFromName Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : GetFromName Method

aName

Glossary Item Box

Looks up a TimeItemTextLayout by name

Syntax

Visual Basic (Declaration)
Public Function GetFromName( _
   ByVal aName As String _
) As TimeItemTextLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
Dim aName As String
Dim value As TimeItemTextLayout

value = instance.GetFromName(aName)
C#
public TimeItemTextLayout GetFromName(
   string aName
)
Managed Extensions for C++
public: TimeItemTextLayout* GetFromName(
   string* aName
)
C++/CLI
public:
TimeItemTextLayout^ GetFromName(
   String^ aName
)

Parameters

aName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : IndexOf Method

value

Glossary Item Box

Index of a TimeItemTextLayout in the collection

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : Remove Method

index

Glossary Item Box

Remove a TimeItemTextLayout by index

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemTextLayouts Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTextLayouts Class

Glossary Item Box

For a list of all members of this type, see TimeItemTextLayouts members.

Public Properties

 | Name | Description
Public Property | Item | The indexer of TimeItemTextLayouts
Top

See Also

Reference

TimeItemTextLayouts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTextLayouts Class : Item Property

Index

Glossary Item Box

The indexer of TimeItemTextLayouts

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As TimeItemTextLayout
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTextLayouts
Dim Index As Integer
Dim value As TimeItemTextLayout

value = instance.Item(Index)
C#
public TimeItemTextLayout this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property TimeItemTextLayout* get_Item   int Index
;
C++/CLI
public:
property TimeItemTextLayout^ default [int] {
   TimeItemTextLayout^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTextLayouts Class
TimeItemTextLayouts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTexts Class

Glossary Item Box

TimeItemTexts is held by TimeItems to hold texts that should be shown inside.

Object Model

TimeItemTexts ClassTimeItemText Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class TimeItemTexts
   Inherits System.Collections.CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
C#
[DefaultMemberAttribute("Item")]
public class TimeItemTexts : System.Collections.CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class TimeItemTexts : public System.Collections.CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class TimeItemTexts : public System.Collections.CollectionBase

Example

TimeItemText Class

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PlexityHide.GTP.TimeItemTexts

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemTexts Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TimeItemTexts Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTexts Class

Glossary Item Box

The following tables list the members exposed by TimeItemTexts.

Public Constructors

 | Name | Description
Public Constructor | TimeItemTexts Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Gantt | Returns the owning Gantt
Public Property | Item | Indexer
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a TimeItemText
Public Method | IndexOf | Returns index of a TimeItemText
Public Method | Remove | removes a TimeItemText from index
Top

See Also

Reference

TimeItemTexts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : TimeItemTexts Constructor

Glossary Item Box

Overload List

Overload | Description
TimeItemTexts Constructor() |
TimeItemTexts Constructor(TimeItem) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Constructor()
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class > TimeItemTexts Constructor : TimeItemTexts Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemTexts()
C#
public TimeItemTexts()
Managed Extensions for C++
public: TimeItemTexts();
C++/CLI
public:
TimeItemTexts();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemTexts Constructor(TimeItem)
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class > TimeItemTexts Constructor : TimeItemTexts Constructor(TimeItem)

aTimeItem

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal aTimeItem As TimeItem _
)
Visual Basic (Usage) Copy Code
Dim aTimeItem As TimeItem

Dim instance As New TimeItemTexts(aTimeItem)
C#
public TimeItemTexts(
   TimeItem aTimeItem
)
Managed Extensions for C++
public: TimeItemTexts(
   TimeItem* aTimeItem
)
C++/CLI
public:
TimeItemTexts(
   TimeItem^ aTimeItem
)

Parameters

aTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
TimeItemTexts Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTexts Class

Glossary Item Box

For a list of all members of this type, see TimeItemTexts members.

Public Methods

 | Name | Description
Public Method | Add | Adds a TimeItemText
Public Method | IndexOf | Returns index of a TimeItemText
Public Method | Remove | removes a TimeItemText from index
Top

See Also

Reference

TimeItemTexts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Add Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : Add Method

aTimeItemText

Glossary Item Box

Adds a TimeItemText

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal aTimeItemText As TimeItemText _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
Dim aTimeItemText As TimeItemText

instance.Add(aTimeItemText)
C#
public void Add(
   TimeItemText aTimeItemText
)
Managed Extensions for C++
public: void Add(
   TimeItemText* aTimeItemText
)
C++/CLI
public:
void Add(
   TimeItemText^ aTimeItemText
)

Parameters

aTimeItemText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
IndexOf Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : IndexOf Method

value

Glossary Item Box

Returns index of a TimeItemText

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : Remove Method

index

Glossary Item Box

removes a TimeItemText from index

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeItemTexts Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemTexts Class

Glossary Item Box

For a list of all members of this type, see TimeItemTexts members.

Public Properties

 | Name | Description
Public Property | Gantt | Returns the owning Gantt
Public Property | Item | Indexer
Top

See Also

Reference

TimeItemTexts Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Gantt Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : Gantt Property

Glossary Item Box

Returns the owning Gantt

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gantt As Gantt
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
Dim value As Gantt

value = instance.Gantt
C#
public Gantt Gantt {get;}
Managed Extensions for C++
public: __property Gantt* get_Gantt();
C++/CLI
public:
property Gantt^ Gantt {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Item Property
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TimeItemTexts Class : Item Property

Index

Glossary Item Box

Indexer

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal Index As Integer _
) As TimeItemText
Visual Basic (Usage) Copy Code
Dim instance As TimeItemTexts
Dim Index As Integer
Dim value As TimeItemText

value = instance.Item(Index)
C#
public TimeItemText this[
   int Index
]; {get;}
Managed Extensions for C++
public: __property TimeItemText* get_Item   int Index
;
C++/CLI
public:
property TimeItemText^ default [int] {
   TimeItemText^ get(int Index);
}

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemTexts Class
TimeItemTexts Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TopLeftChangedEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : TopLeftChangedEventArgs Class

Glossary Item Box

Object Model

TopLeftChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TopLeftChangedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TopLeftChangedEventArgs
C#
public class TopLeftChangedEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class TopLeftChangedEventArgs : public System.EventArgs
C++/CLI
public ref class TopLeftChangedEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.TopLeftChangedEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TopLeftChangedEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
TopLeftChangedEventArgs Class Members
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TopLeftChangedEventArgs Class

Glossary Item Box

The following tables list the members exposed by TopLeftChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TopLeftChangedEventArgs Constructor |
Top

See Also

Reference

TopLeftChangedEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TopLeftChangedEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > TopLeftChangedEventArgs Class : TopLeftChangedEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TopLeftChangedEventArgs()
C#
public TopLeftChangedEventArgs()
Managed Extensions for C++
public: TopLeftChangedEventArgs();
C++/CLI
public:
TopLeftChangedEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TopLeftChangedEventArgs Class
TopLeftChangedEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnBindedSortArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnBindedSortArgs Class

Glossary Item Box

Arguments for UnBindedSort

Object Model

UnBindedSortArgs Class

Syntax

Visual Basic (Declaration)
Public Class UnBindedSortArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UnBindedSortArgs
C#
public class UnBindedSortArgs : System.EventArgs
Managed Extensions for C++
public __gc class UnBindedSortArgs : public System.EventArgs
C++/CLI
public ref class UnBindedSortArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.UnBindedSortArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UnBindedSortArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
UnBindedSortArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : UnBindedSortArgs Class

Glossary Item Box

The following tables list the members exposed by UnBindedSortArgs.

Public Constructors

 | Name | Description
Public Constructor | UnBindedSortArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | aColumn |
Public Field | aListToSort |
Public Field | descending |
Top

See Also

Reference

UnBindedSortArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnBindedSortArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnBindedSortArgs Class : UnBindedSortArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UnBindedSortArgs()
C#
public UnBindedSortArgs()
Managed Extensions for C++
public: UnBindedSortArgs();
C++/CLI
public:
UnBindedSortArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnBindedSortArgs Class
UnBindedSortArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
UnBindedSortArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnBindedSortArgs Class

Glossary Item Box

For a list of all members of this type, see UnBindedSortArgs members.

Public Fields

 | Name | Description
Public Field | aColumn |
Public Field | aListToSort |
Public Field | descending |
Top

See Also

Reference

UnBindedSortArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
aColumn Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnBindedSortArgs Class : aColumn Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public aColumn As GridColumn
Visual Basic (Usage) Copy Code
Dim instance As UnBindedSortArgs
Dim value As GridColumn

value = instance.aColumn

instance.aColumn = value
C#
public GridColumn aColumn
Managed Extensions for C++
public: GridColumn* aColumn
C++/CLI
public:
GridColumn^ aColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnBindedSortArgs Class
UnBindedSortArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
aListToSort Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnBindedSortArgs Class : aListToSort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public aListToSort As GridNodes
Visual Basic (Usage) Copy Code
Dim instance As UnBindedSortArgs
Dim value As GridNodes

value = instance.aListToSort

instance.aListToSort = value
C#
public GridNodes aListToSort
Managed Extensions for C++
public: GridNodes* aListToSort
C++/CLI
public:
GridNodes^ aListToSort

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnBindedSortArgs Class
UnBindedSortArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
descending Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnBindedSortArgs Class : descending Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public descending As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnBindedSortArgs
Dim value As Boolean

value = instance.descending

instance.descending = value
C#
public bool descending
Managed Extensions for C++
public: bool descending
C++/CLI
public:
bool descending

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnBindedSortArgs Class
UnBindedSortArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnhandledExceptionArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnhandledExceptionArgs Class

Glossary Item Box

Arguments UnhandledExceptionEvent

Object Model

UnhandledExceptionArgs Class

Syntax

Visual Basic (Declaration)
Public Class UnhandledExceptionArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UnhandledExceptionArgs
C#
public class UnhandledExceptionArgs : System.EventArgs
Managed Extensions for C++
public __gc class UnhandledExceptionArgs : public System.EventArgs
C++/CLI
public ref class UnhandledExceptionArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.UnhandledExceptionArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UnhandledExceptionArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
UnhandledExceptionArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : UnhandledExceptionArgs Class

Glossary Item Box

The following tables list the members exposed by UnhandledExceptionArgs.

Public Constructors

 | Name | Description
Public Constructor | UnhandledExceptionArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | E | The exception that was left un-handled
Top

See Also

Reference

UnhandledExceptionArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnhandledExceptionArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnhandledExceptionArgs Class : UnhandledExceptionArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UnhandledExceptionArgs()
C#
public UnhandledExceptionArgs()
Managed Extensions for C++
public: UnhandledExceptionArgs();
C++/CLI
public:
UnhandledExceptionArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnhandledExceptionArgs Class
UnhandledExceptionArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
UnhandledExceptionArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnhandledExceptionArgs Class

Glossary Item Box

For a list of all members of this type, see UnhandledExceptionArgs members.

Public Fields

 | Name | Description
Public Field | E | The exception that was left un-handled
Top

See Also

Reference

UnhandledExceptionArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
E Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UnhandledExceptionArgs Class : E Field

Glossary Item Box

The exception that was left un-handled

Syntax

Visual Basic (Declaration)
Public E As Exception
Visual Basic (Usage) Copy Code
Dim instance As UnhandledExceptionArgs
Dim value As Exception

value = instance.E

instance.E = value
C#
public Exception E
Managed Extensions for C++
public: Exception* E
C++/CLI
public:
Exception^ E

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnhandledExceptionArgs Class
UnhandledExceptionArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserBrushCreateEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : UserBrushCreateEventArgs Class

Glossary Item Box

Since the brush is a very potent tool with a myriad of possibilities we decided to allow a you to create and define it. This is somewhat less complex that implementing a user drawn time item, but can be used in combination with those.

Object Model

UserBrushCreateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserBrushCreateEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
C#
public class UserBrushCreateEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserBrushCreateEventArgs : public System.EventArgs
C++/CLI
public ref class UserBrushCreateEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.UserBrushCreateEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UserBrushCreateEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
UserBrushCreateEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : UserBrushCreateEventArgs Class

Glossary Item Box

The following tables list the members exposed by UserBrushCreateEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UserBrushCreateEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | DisposeAfterUse | Dispose after use (default true)
Public Field | Rect | The rectangle the time item that will use the brush will be drawn in
Public Field | ReturnedBrush | Assign your created brush to this property before leaving.
Public Field | TimeItem | The time item that will be drawn
Public Field | TimeItemLayout | The Layout the time item will use
Top

See Also

Reference

UserBrushCreateEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserBrushCreateEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : UserBrushCreateEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UserBrushCreateEventArgs()
C#
public UserBrushCreateEventArgs()
Managed Extensions for C++
public: UserBrushCreateEventArgs();
C++/CLI
public:
UserBrushCreateEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
UserBrushCreateEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UserBrushCreateEventArgs Class

Glossary Item Box

For a list of all members of this type, see UserBrushCreateEventArgs members.

Public Fields

 | Name | Description
Public Field | DisposeAfterUse | Dispose after use (default true)
Public Field | Rect | The rectangle the time item that will use the brush will be drawn in
Public Field | ReturnedBrush | Assign your created brush to this property before leaving.
Public Field | TimeItem | The time item that will be drawn
Public Field | TimeItemLayout | The Layout the time item will use
Top

See Also

Reference

UserBrushCreateEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DisposeAfterUse Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : DisposeAfterUse Field

Glossary Item Box

Dispose after use (default true)

Syntax

Visual Basic (Declaration)
Public DisposeAfterUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
Dim value As Boolean

value = instance.DisposeAfterUse

instance.DisposeAfterUse = value
C#
public bool DisposeAfterUse
Managed Extensions for C++
public: bool DisposeAfterUse
C++/CLI
public:
bool DisposeAfterUse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Rect Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : Rect Field

Glossary Item Box

The rectangle the time item that will use the brush will be drawn in

Syntax

Visual Basic (Declaration)
Public Rect As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
Dim value As Rectangle

value = instance.Rect

instance.Rect = value
C#
public Rectangle Rect
Managed Extensions for C++
public: Rectangle Rect
C++/CLI
public:
Rectangle Rect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ReturnedBrush Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : ReturnedBrush Field

Glossary Item Box

Assign your created brush to this property before leaving.

Syntax

Visual Basic (Declaration)
Public ReturnedBrush As Brush
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
Dim value As Brush

value = instance.ReturnedBrush

instance.ReturnedBrush = value
C#
public Brush ReturnedBrush
Managed Extensions for C++
public: Brush* ReturnedBrush
C++/CLI
public:
Brush^ ReturnedBrush

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : TimeItem Field

Glossary Item Box

The time item that will be drawn

Syntax

Visual Basic (Declaration)
Public TimeItem As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
Dim value As TimeItem

value = instance.TimeItem

instance.TimeItem = value
C#
public TimeItem TimeItem
Managed Extensions for C++
public: TimeItem* TimeItem
C++/CLI
public:
TimeItem^ TimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLayout Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserBrushCreateEventArgs Class : TimeItemLayout Field

Glossary Item Box

The Layout the time item will use

Syntax

Visual Basic (Declaration)
Public TimeItemLayout As TimeItemLayout
Visual Basic (Usage) Copy Code
Dim instance As UserBrushCreateEventArgs
Dim value As TimeItemLayout

value = instance.TimeItemLayout

instance.TimeItemLayout = value
C#
public TimeItemLayout TimeItemLayout
Managed Extensions for C++
public: TimeItemLayout* TimeItemLayout
C++/CLI
public:
TimeItemLayout^ TimeItemLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserBrushCreateEventArgs Class
UserBrushCreateEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserDrawLinkEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : UserDrawLinkEventArgs Class

Glossary Item Box

UserDrawLink event args

Object Model

UserDrawLinkEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserDrawLinkEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
C#
public class UserDrawLinkEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserDrawLinkEventArgs : public System.EventArgs
C++/CLI
public ref class UserDrawLinkEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.UserDrawLinkEventArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UserDrawLinkEventArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
UserDrawLinkEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : UserDrawLinkEventArgs Class

Glossary Item Box

The following tables list the members exposed by UserDrawLinkEventArgs.

Public Constructors

 | Name | Description
Public Constructor | UserDrawLinkEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | BoundingRegion | If Region is assigned then we are requesting bounding region for Link
Public Field | G | The draw environment
Public Field | Link | The time item link in question
Public Field | StartPoint | The Starting point of the link
Public Field | TargetPoint | The target point of the link
Top

See Also

Reference

UserDrawLinkEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserDrawLinkEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : UserDrawLinkEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UserDrawLinkEventArgs()
C#
public UserDrawLinkEventArgs()
Managed Extensions for C++
public: UserDrawLinkEventArgs();
C++/CLI
public:
UserDrawLinkEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
UserDrawLinkEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UserDrawLinkEventArgs Class

Glossary Item Box

For a list of all members of this type, see UserDrawLinkEventArgs members.

Public Fields

 | Name | Description
Public Field | BoundingRegion | If Region is assigned then we are requesting bounding region for Link
Public Field | G | The draw environment
Public Field | Link | The time item link in question
Public Field | StartPoint | The Starting point of the link
Public Field | TargetPoint | The target point of the link
Top

See Also

Reference

UserDrawLinkEventArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BoundingRegion Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : BoundingRegion Field

Glossary Item Box

If Region is assigned then we are requesting bounding region for Link

Syntax

Visual Basic (Declaration)
Public BoundingRegion As Region
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
Dim value As Region

value = instance.BoundingRegion

instance.BoundingRegion = value
C#
public Region BoundingRegion
Managed Extensions for C++
public: Region* BoundingRegion
C++/CLI
public:
Region^ BoundingRegion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
G Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : G Field

Glossary Item Box

The draw environment

Syntax

Visual Basic (Declaration)
Public G As Graphics
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
Dim value As Graphics

value = instance.G

instance.G = value
C#
public Graphics G
Managed Extensions for C++
public: Graphics* G
C++/CLI
public:
Graphics^ G

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Link Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : Link Field

Glossary Item Box

The time item link in question

Syntax

Visual Basic (Declaration)
Public Link As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
Dim value As TimeItemLink

value = instance.Link

instance.Link = value
C#
public TimeItemLink Link
Managed Extensions for C++
public: TimeItemLink* Link
C++/CLI
public:
TimeItemLink^ Link

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
StartPoint Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : StartPoint Field

Glossary Item Box

The Starting point of the link

Syntax

Visual Basic (Declaration)
Public StartPoint As Point
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
Dim value As Point

value = instance.StartPoint

instance.StartPoint = value
C#
public Point StartPoint
Managed Extensions for C++
public: Point StartPoint
C++/CLI
public:
Point StartPoint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
TargetPoint Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > UserDrawLinkEventArgs Class : TargetPoint Field

Glossary Item Box

The target point of the link

Syntax

Visual Basic (Declaration)
Public TargetPoint As Point
Visual Basic (Usage) Copy Code
Dim instance As UserDrawLinkEventArgs
Dim value As Point

value = instance.TargetPoint

instance.TargetPoint = value
C#
public Point TargetPoint
Managed Extensions for C++
public: Point TargetPoint
C++/CLI
public:
Point TargetPoint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UserDrawLinkEventArgs Class
UserDrawLinkEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ViewDateInformationArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : ViewDateInformationArgs Class

Glossary Item Box

Arguments for the OnViewDateInformation event The View information is the text normally placed in the upper left corner of the datescaler. This text displays the start - stop as text in default drawing.

Object Model

ViewDateInformationArgs Class

Syntax

Visual Basic (Declaration)
Public Class ViewDateInformationArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
C#
public class ViewDateInformationArgs : System.EventArgs
Managed Extensions for C++
public __gc class ViewDateInformationArgs : public System.EventArgs
C++/CLI
public ref class ViewDateInformationArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.ViewDateInformationArgs

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ViewDateInformationArgs Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
ViewDateInformationArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP Namespace : ViewDateInformationArgs Class

Glossary Item Box

The following tables list the members exposed by ViewDateInformationArgs.

Public Constructors

 | Name | Description
Public Constructor | ViewDateInformationArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Brush | The Brush that will be used by default draw
Public Field | ContinueDraw | Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.
Public Field | Font | The suggested font
Public Field | Pos | The position to place the View info text
Public Field | Text | The suggested default text
Top

See Also

Reference

ViewDateInformationArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ViewDateInformationArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : ViewDateInformationArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ViewDateInformationArgs()
C#
public ViewDateInformationArgs()
Managed Extensions for C++
public: ViewDateInformationArgs();
C++/CLI
public:
ViewDateInformationArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP
ViewDateInformationArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ViewDateInformationArgs Class

Glossary Item Box

For a list of all members of this type, see ViewDateInformationArgs members.

Public Fields

 | Name | Description
Public Field | Brush | The Brush that will be used by default draw
Public Field | ContinueDraw | Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.
Public Field | Font | The suggested font
Public Field | Pos | The position to place the View info text
Public Field | Text | The suggested default text
Top

See Also

Reference

ViewDateInformationArgs Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Brush Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : Brush Field

Glossary Item Box

The Brush that will be used by default draw

Syntax

Visual Basic (Declaration)
Public Brush As Brush
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
Dim value As Brush

value = instance.Brush

instance.Brush = value
C#
public Brush Brush
Managed Extensions for C++
public: Brush* Brush
C++/CLI
public:
Brush^ Brush

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
ContinueDraw Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : ContinueDraw Field

Glossary Item Box

Set this to true to let the default logic draw the output. Set it to false to prevent the default logic.

Syntax

Visual Basic (Declaration)
Public ContinueDraw As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
Dim value As Boolean

value = instance.ContinueDraw

instance.ContinueDraw = value
C#
public bool ContinueDraw
Managed Extensions for C++
public: bool ContinueDraw
C++/CLI
public:
bool ContinueDraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Font Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : Font Field

Glossary Item Box

The suggested font

Syntax

Visual Basic (Declaration)
Public Font As Font
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
Dim value As Font

value = instance.Font

instance.Font = value
C#
public Font Font
Managed Extensions for C++
public: Font* Font
C++/CLI
public:
Font^ Font

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Pos Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : Pos Field

Glossary Item Box

The position to place the View info text

Syntax

Visual Basic (Declaration)
Public Pos As Point
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
Dim value As Point

value = instance.Pos

instance.Pos = value
C#
public Point Pos
Managed Extensions for C++
public: Point Pos
C++/CLI
public:
Point Pos

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Text Field
See Also Send comments on this topic.
PlexityHide.GTP Namespace > ViewDateInformationArgs Class : Text Field

Glossary Item Box

The suggested default text

Syntax

Visual Basic (Declaration)
Public Text As String
Visual Basic (Usage) Copy Code
Dim instance As ViewDateInformationArgs
Dim value As String

value = instance.Text

instance.Text = value
C#
public string Text
Managed Extensions for C++
public: string* Text
C++/CLI
public:
String^ Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ViewDateInformationArgs Class
ViewDateInformationArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
BrushKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BrushKind Enumeration

Glossary Item Box

Time items are filled with one of these brushkinds

Syntax

Visual Basic (Declaration)
Public Enum BrushKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As BrushKind
C#
public enum BrushKind : System.Enum
Managed Extensions for C++
__value public enum BrushKind : public System.Enum
C++/CLI
public enum class BrushKind : public System.Enum

Members

Member | Description
GradientDiagonal | Gradient Diagonal
GradientHorizontal | Gradient Horizontal
GradientVertical | Gradient Vertical
HatchBrush | Hatch brush
Solid | Default, plain one color draw
UserCreatedBrush | The OnTimeItem_UserBrushCreate event will fire; create the brush and it will be used...

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.BrushKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarBrushKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarBrushKind Enumeration

Glossary Item Box

The brushkinds available in CalendarEntry drawing

Syntax

Visual Basic (Declaration)
Public Enum CalendarBrushKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CalendarBrushKind
C#
public enum CalendarBrushKind : System.Enum
Managed Extensions for C++
__value public enum CalendarBrushKind : public System.Enum
C++/CLI
public enum class CalendarBrushKind : public System.Enum

Members

Member | Description
hatch | Hatch pattern brush
solid | Solid color

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.CalendarBrushKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CalendarDrawArea Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CalendarDrawArea Enumeration

Glossary Item Box

Enum that describes where a calendar is about to be drawn

Syntax

Visual Basic (Declaration)
Public Enum CalendarDrawArea
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CalendarDrawArea
C#
public enum CalendarDrawArea : System.Enum
Managed Extensions for C++
__value public enum CalendarDrawArea : public System.Enum
C++/CLI
public enum class CalendarDrawArea : public System.Enum

Members

Member | Description
DateScaler | In the datescaler
InsideTimeItem | Inside a time item
TimeItemAreaBackground | On the gantt rows, under time items

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.CalendarDrawArea

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellType Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellType Enumeration

Glossary Item Box

The possible values for GridColumn.Type

Syntax

Visual Basic (Declaration)
Public Enum CellType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CellType
C#
public enum CellType : System.Enum
Managed Extensions for C++
__value public enum CellType : public System.Enum
C++/CLI
public enum class CellType : public System.Enum

Members

Member | Description
BoolCheck | Displays as a checkbox, clicking edits directly, no extra edit mode for this one
ComboText | Displays a combobox upon edit, otherwise the same as SingleText
CustomCell | Custom cell, here the developer must implement the CustomCellEvents to set the desired behavior
MultiText | Same as SingleText but supports multiple rows and row wrap
SingleText | Show a single row of text. Turns into a EditBox upon edit
TimeDate | Displays a datetime struct, turns into a dateTimePicker on edit
TimeSpan | Displays a timespan, turns into a time picker on edit

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.CellType

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollectionEventKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollectionEventKind Enumeration

Glossary Item Box

Events in the node collection

Syntax

Visual Basic (Declaration)
Public Enum CollectionEventKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CollectionEventKind
C#
public enum CollectionEventKind : System.Enum
Managed Extensions for C++
__value public enum CollectionEventKind : public System.Enum
C++/CLI
public enum class CollectionEventKind : public System.Enum

Members

Member | Description
delete | The event was triggered by a remove/delete
insert | The event was triggered by an insert

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.CollectionEventKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaDrawStyle Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictAreaDrawStyle Enumeration

Glossary Item Box

ConflictAreas can be drawn with different styles

Syntax

Visual Basic (Declaration)
Public Enum ConflictAreaDrawStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ConflictAreaDrawStyle
C#
public enum ConflictAreaDrawStyle : System.Enum
Managed Extensions for C++
__value public enum ConflictAreaDrawStyle : public System.Enum
C++/CLI
public enum class ConflictAreaDrawStyle : public System.Enum

Members

Member | Description
Normal | A hatch brush and color taken from the TimeItemLayout ConflictAreaColor and ConflictAreaHatchStyle
User | No default drawing and the ConflictArea_UserDraw event is called

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.ConflictAreaDrawStyle

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictAreaUpdateKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictAreaUpdateKind Enumeration

Glossary Item Box

The Different kinds of update that may be signaled on a conflict area

Syntax

Visual Basic (Declaration)
Public Enum ConflictAreaUpdateKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ConflictAreaUpdateKind
C#
public enum ConflictAreaUpdateKind : System.Enum
Managed Extensions for C++
__value public enum ConflictAreaUpdateKind : public System.Enum
C++/CLI
public enum class ConflictAreaUpdateKind : public System.Enum

Members

Member | Description
add | The conflict area is new
remove | The conflict resolved and the conflict area is removed
update | The conflict area was changed

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.ConflictAreaUpdateKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScaleMark.AreaEnum Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScaleMark.AreaEnum Enumeration

Glossary Item Box

DateScale has different areas

Syntax

Visual Basic (Declaration)
Public Enum DateScaleMark.AreaEnum
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DateScaleMark.AreaEnum
C#
public enum DateScaleMark.AreaEnum : System.Enum
Managed Extensions for C++
__value public enum DateScaleMark.AreaEnum : public System.Enum
C++/CLI
public enum class DateScaleMark.AreaEnum : public System.Enum

Members

Member | Description
FishEye | inside fisheye
NormalFirst | Only area when fish eye is off, otherwise area in front of fish eye
NormalSecond | after fisheye

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.DateScaleMark.AreaEnum

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerChangeKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerChangeKind Enumeration

Glossary Item Box

In the BeforeScaleOrSpanChange event this enum specifies what started the change

Syntax

Visual Basic (Declaration)
Public Enum DateScalerChangeKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DateScalerChangeKind
C#
public enum DateScalerChangeKind : System.Enum
Managed Extensions for C++
__value public enum DateScalerChangeKind : public System.Enum
C++/CLI
public enum class DateScalerChangeKind : public System.Enum

Members

Member | Description
animation | AnimateScaleTransition in progress
code | Start och StopTime called from code
userpan | User pans
userzoom | User zooms

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.DateScalerChangeKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
FishEyeMagnification Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : FishEyeMagnification Enumeration

Glossary Item Box

FishEyeMagnification.

Syntax

Visual Basic (Declaration)
Public Enum FishEyeMagnification
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FishEyeMagnification
C#
public enum FishEyeMagnification : System.Enum
Managed Extensions for C++
__value public enum FishEyeMagnification : public System.Enum
C++/CLI
public enum class FishEyeMagnification : public System.Enum

Members

Member | Description
M1 | No magnification
M10 | 10x magnification
M2 | 2x magnification
M3 | 3x magnification
M4 | 4x magnification
M5 | 5x magnification
M6 | 6x magnification
M7 | 7x magnification
M8 | 8x magnification
M9 | 9x magnification

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.FishEyeMagnification

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNodeScreenStatus Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : GridNodeScreenStatus Enumeration

Glossary Item Box

Enum values for ScreenStatus of a single GridNode on the last operation

Syntax

Visual Basic (Declaration)
Public Enum GridNodeScreenStatus
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As GridNodeScreenStatus
C#
public enum GridNodeScreenStatus : System.Enum
Managed Extensions for C++
__value public enum GridNodeScreenStatus : public System.Enum
C++/CLI
public enum class GridNodeScreenStatus : public System.Enum

Members

Member | Description
AboveScreen | The grid node was above the drawn screen on the last draw operation
BelowScreen | The grid node was below the drawn screen on the last draw operation
InNonExpandedAncestor | The grid node was in a non expanded ancestor or hidden by the Visible property being false on the last draw operation
VisibleOnScreen | The grid node was on screen on the last draw operation

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.GridNodeScreenStatus

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
HeaderType Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : HeaderType Enumeration

Glossary Item Box

Values for grid header rendering

Syntax

Visual Basic (Declaration)
Public Enum HeaderType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HeaderType
C#
public enum HeaderType : System.Enum
Managed Extensions for C++
__value public enum HeaderType : public System.Enum
C++/CLI
public enum class HeaderType : public System.Enum

Members

Member | Description
MS | Like the explorer grid etc
Standard | Old school, plain cell and gradient

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.HeaderType

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
MouseMoveKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : MouseMoveKind Enumeration

Glossary Item Box

The different mouse move states possible

Syntax

Visual Basic (Declaration)
Public Enum MouseMoveKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As MouseMoveKind
C#
public enum MouseMoveKind : System.Enum
Managed Extensions for C++
__value public enum MouseMoveKind : public System.Enum
C++/CLI
public enum class MouseMoveKind : public System.Enum

Members

Member | Description
areaSelect | Drags out a square and selects all time items within
linkCreate | The mouse is Currently in a link create operation; the user has clicked one time item dragging out a link looking for the link target.
linkReAssign | The mouse is Currently in a link re-assign operation; the user has clicked the link selection hotspot drags the link point to a new location.
move | The mouse is Currently in a move operation; the user is dragging a time item.
none | The mouse is not in any particular mode.
resizee | The mouse is Currently in a resize operation; the user resizing a time item to the east.
resizew | The mouse is Currently in a resize operation; the user resizing a time item to the west.
timeItemCreate | The mouse is Currently in a Time item create operation; the user has clicked the time item area and drags out a new time item.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.MouseMoveKind

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NonLinearTime.TimeResolution Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NonLinearTime.TimeResolution Enumeration

Glossary Item Box

Enumeration for all availbale time scale resolutions

Syntax

Visual Basic (Declaration)
Public Enum NonLinearTime.TimeResolution
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NonLinearTime.TimeResolution
C#
public enum NonLinearTime.TimeResolution : System.Enum
Managed Extensions for C++
__value public enum NonLinearTime.TimeResolution : public System.Enum
C++/CLI
public enum class NonLinearTime.TimeResolution : public System.Enum

Members

Member | Description
days |
hours |
hours3 |
hours6 |
minutes |
minutes10 |
months |
quarters |
seconds |
seconds10 |
secondsBy10 |
secondsBy100 |
secondsBy1000 |
secondsBy10000 |
weeks |
years |
years10 |
years100 |
years1000 |
years20 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.NonLinearTime.TimeResolution

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanButton.PanDirection Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton.PanDirection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PanButton.PanDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PanButton.PanDirection
C#
public enum PanButton.PanDirection : System.Enum
Managed Extensions for C++
__value public enum PanButton.PanDirection : public System.Enum
C++/CLI
public enum class PanButton.PanDirection : public System.Enum

Members

Member | Description
backward |
forward |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.PanButton.PanDirection

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanEventArgs.PanSpeed Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanEventArgs.PanSpeed Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum PanEventArgs.PanSpeed
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PanEventArgs.PanSpeed
C#
public enum PanEventArgs.PanSpeed : System.Enum
Managed Extensions for C++
__value public enum PanEventArgs.PanSpeed : public System.Enum
C++/CLI
public enum class PanEventArgs.PanSpeed : public System.Enum

Members

Member | Description
fast |
medium |
slow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.PanEventArgs.PanSpeed

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ResizingType Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ResizingType Enumeration

Glossary Item Box

Resizing characteristics.

Syntax

Visual Basic (Declaration)
Public Enum ResizingType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ResizingType
C#
public enum ResizingType : System.Enum
Managed Extensions for C++
__value public enum ResizingType : public System.Enum
C++/CLI
public enum class ResizingType : public System.Enum

Members

Member | Description
CenterLocked | Center time locked, start and stop time change.
StartAndStopLocked | Start and stop time locked, resolution changes with resizing.
StartLocked | Start time locked, stop time changes.
StopLocked | Stop time locked, start time changes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.ResizingType

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkAction Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkAction Enumeration

Glossary Item Box

TimeItemLinkActions are executed when the time items in the link are changed (Start or Stop is changed). LinkActions can help you enforce some of the business rules that you want to stay in effect when the user changes time items

Syntax

Visual Basic (Declaration)
Public Enum TimeItemLinkAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkAction
C#
public enum TimeItemLinkAction : System.Enum
Managed Extensions for C++
__value public enum TimeItemLinkAction : public System.Enum
C++/CLI
public enum class TimeItemLinkAction : public System.Enum

Members

Member | Description
Contain | Target expands to completely cover the Start
Event | fires an event when Start changes
None | No action
PushBack | If the Start is moved so that the Target and Start overlap in time, the target is moved backward to avoid this overlap
PushForward | If the Start is moved so that the Target and Start overlap in time, the target os moved forward to avoid this overlap
SameStart | Target follows Start

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeItemLinkAction

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkDrawStrategy Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkDrawStrategy Enumeration

Glossary Item Box

Set this to influence if the TimeItemLink can be drawn when the TimeItems are on opposite sides of the visible area

Syntax

Visual Basic (Declaration)
Public Enum TimeItemLinkDrawStrategy
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkDrawStrategy
C#
public enum TimeItemLinkDrawStrategy : System.Enum
Managed Extensions for C++
__value public enum TimeItemLinkDrawStrategy : public System.Enum
C++/CLI
public enum class TimeItemLinkDrawStrategy : public System.Enum

Members

Member | Description
AtLeastOneOnScreen | Default, at least one time item on screen or no link is visible
DrawEvenIfNoneOfTheTimeItemsAreOnScreen | Use this to make the TimeItemLink to be drawn when the TimeItems are on opposite sides of the visible area

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeItemLinkDrawStrategy

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkDrawStyle Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkDrawStyle Enumeration

Glossary Item Box

The draw style of a link

Syntax

Visual Basic (Declaration)
Public Enum TimeItemLinkDrawStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkDrawStyle
C#
public enum TimeItemLinkDrawStyle : System.Enum
Managed Extensions for C++
__value public enum TimeItemLinkDrawStyle : public System.Enum
C++/CLI
public enum class TimeItemLinkDrawStyle : public System.Enum

Members

Member | Description
Invisible | Nothing is drawn, good for link actions
Nurb | Nurb link
Straight | Straighter link
User | Implement an event and draw the link yourself
ZStyle | Z-style link Considerable effort is made to avoid running the link thru the Target or the Start time item

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeItemLinkDrawStyle

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkStyle Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkStyle Enumeration

Glossary Item Box

The style of link

Syntax

Visual Basic (Declaration)
Public Enum TimeItemLinkStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeItemLinkStyle
C#
public enum TimeItemLinkStyle : System.Enum
Managed Extensions for C++
__value public enum TimeItemLinkStyle : public System.Enum
C++/CLI
public enum class TimeItemLinkStyle : public System.Enum

Members

Member | Description
StartToStart | Start of one time item to another time items start.
StartToStop | Start of one time item to another time items stop.
StopToStart | Stop of one time item to another time items start.
StopToStop | Stop of one time item to another time items start.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeItemLinkStyle

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemStyle Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemStyle Enumeration

Glossary Item Box

Time items is drawn according to one of these schemes

Syntax

Visual Basic (Declaration)
Public Enum TimeItemStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeItemStyle
C#
public enum TimeItemStyle : System.Enum
Managed Extensions for C++
__value public enum TimeItemStyle : public System.Enum
C++/CLI
public enum class TimeItemStyle : public System.Enum

Members

Member | Description
Glossy | Draws a glossy looking time item
Image | Draws an image from the image list
LineWEnd | Thin line with ends that are drawrect heigh
Modern1 | Draws a modern?! looking time item
Pipe | Draws a pipe(round) looking time item
Romb | A romb, use it as milestone. But to be a true milestone you do not want it to have a length Set FixedSizeUse to true and FixedSize to a value to get the pixel draw length.
Span | Looks like a project span
SpanWithTimeInPoint | Just like span, but time (start and stop) passes trough the points not the edges
Square | the default rectangle
User | When you set this value you must implement the OnUserDraw event to do the drawing

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeItemStyle

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeStrEnum Enumeration
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeStrEnum Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum TimeStrEnum
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TimeStrEnum
C#
public enum TimeStrEnum : System.Enum
Managed Extensions for C++
__value public enum TimeStrEnum : public System.Enum
C++/CLI
public enum class TimeStrEnum : public System.Enum

Members

Member | Description
Day |
DayName |
DayName3 |
DayOneLetter |
Empty |
Hour |
MilliSec |
Min |
Month |
Month3 |
QuarterWithoutYear |
QuarterWithYear |
Sec |
SecBy10 |
TimeOfDay |
Week |
Year2 |
Year4 |
YearSpan10 |
YearSpan100 |
YearSpan20 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.TimeStrEnum

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
IClipboardInteraction Interface
Members See Also Send comments on this topic.
PlexityHide.GTP Namespace : IClipboardInteraction Interface

Glossary Item Box

Interface that ContentEntity implementations fullfill to handle clipboard cut and paste Let you derived contentEntity implement this interface to receive clipboard data in custom cells

Syntax

Visual Basic (Declaration)
Public Interface IClipboardInteraction
Visual Basic (Usage) Copy Code
Dim instance As IClipboardInteraction
C#
public interface IClipboardInteraction
Managed Extensions for C++
public __gc __interface IClipboardInteraction
C++/CLI
public interface class IClipboardInteraction

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

IClipboardInteraction Members
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP
IClipboardInteraction Interface Members
See Also Methods Send comments on this topic.
PlexityHide.GTP Namespace : IClipboardInteraction Interface

Glossary Item Box

The following tables list the members exposed by IClipboardInteraction.

Public Methods

 | Name | Description
Method | CopyToClipboard | Copy the cell data to the clipboard
Method | PasteValueFromClipboard | Paste clipboard data to cell value, you should enter edit mode first to ensure that the cell is not readonly and fire all edit-events
Top

See Also

Reference

IClipboardInteraction Interface
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
IClipboardInteraction Interface Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : IClipboardInteraction Interface

Glossary Item Box

For a list of all members of this type, see IClipboardInteraction members.

Public Methods

 | Name | Description
Method | CopyToClipboard | Copy the cell data to the clipboard
Method | PasteValueFromClipboard | Paste clipboard data to cell value, you should enter edit mode first to ensure that the cell is not readonly and fire all edit-events
Top

See Also

Reference

IClipboardInteraction Interface
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CopyToClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IClipboardInteraction Interface : CopyToClipboard Method

Glossary Item Box

Copy the cell data to the clipboard

Syntax

Visual Basic (Declaration)
Sub CopyToClipboard()
Visual Basic (Usage) Copy Code
Dim instance As IClipboardInteraction

instance.CopyToClipboard()
C#
void CopyToClipboard()
Managed Extensions for C++
void CopyToClipboard();
C++/CLI
void CopyToClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IClipboardInteraction Interface
IClipboardInteraction Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
PasteValueFromClipboard Method
See Also Send comments on this topic.
PlexityHide.GTP Namespace > IClipboardInteraction Interface : PasteValueFromClipboard Method

Glossary Item Box

Paste clipboard data to cell value, you should enter edit mode first to ensure that the cell is not readonly and fire all edit-events

Syntax

Visual Basic (Declaration)
Sub PasteValueFromClipboard()
Visual Basic (Usage) Copy Code
Dim instance As IClipboardInteraction

instance.PasteValueFromClipboard()
C#
void PasteValueFromClipboard()
Managed Extensions for C++
void PasteValueFromClipboard();
C++/CLI
void PasteValueFromClipboard();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IClipboardInteraction Interface
IClipboardInteraction Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
AfterDrawEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : AfterDrawEvent Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub AfterDrawEvent( _
   ByVal sender As Control, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AfterDrawEvent(AddressOf HandlerMethod)
C#
public delegate void AfterDrawEvent(
   Control sender,
   EventArgs e
)
Managed Extensions for C++
public: __gc __delegate void AfterDrawEvent(
   Control* sender,
   EventArgs* e
)
C++/CLI
public delegate void AfterDrawEvent(
   Control^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

AfterDrawEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
AfterEditCellHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : AfterEditCellHandler Delegate

grid
afterEdit

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub AfterEditCellHandler( _
   ByVal grid As Grid, _
   ByVal afterEdit As AfterEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AfterEditCellHandler(AddressOf HandlerMethod)
C#
public delegate void AfterEditCellHandler(
   Grid grid,
   AfterEditEventArgs afterEdit
)
Managed Extensions for C++
public: __gc __delegate void AfterEditCellHandler(
   Grid* grid,
   AfterEditEventArgs* afterEdit
)
C++/CLI
public delegate void AfterEditCellHandler(
   Grid^ grid,
   AfterEditEventArgs^ afterEdit
)

Parameters

grid
afterEdit

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

AfterEditCellHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeFocusedCellChangeHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeFocusedCellChangeHandler Delegate

grid
beforeFocusChange

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeFocusedCellChangeHandler( _
   ByVal grid As Grid, _
   ByVal beforeFocusChange As BeforeFocusedCellChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New BeforeFocusedCellChangeHandler(AddressOf HandlerMethod)
C#
public delegate void BeforeFocusedCellChangeHandler(
   Grid grid,
   BeforeFocusedCellChangeEventArgs beforeFocusChange
)
Managed Extensions for C++
public: __gc __delegate void BeforeFocusedCellChangeHandler(
   Grid* grid,
   BeforeFocusedCellChangeEventArgs* beforeFocusChange
)
C++/CLI
public delegate void BeforeFocusedCellChangeHandler(
   Grid^ grid,
   BeforeFocusedCellChangeEventArgs^ beforeFocusChange
)

Parameters

grid
beforeFocusChange

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeFocusedCellChangeHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
BeforeScaleOrSpanChangeEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : BeforeScaleOrSpanChangeEventHandler Delegate

dateScaler
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub BeforeScaleOrSpanChangeEventHandler( _
   ByVal dateScaler As DateScaler, _
   ByVal e As BeforeScaleOrSpanChangeArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New BeforeScaleOrSpanChangeEventHandler(AddressOf HandlerMethod)
C#
public delegate void BeforeScaleOrSpanChangeEventHandler(
   DateScaler dateScaler,
   BeforeScaleOrSpanChangeArgs e
)
Managed Extensions for C++
public: __gc __delegate void BeforeScaleOrSpanChangeEventHandler(
   DateScaler* dateScaler,
   BeforeScaleOrSpanChangeArgs* e
)
C++/CLI
public delegate void BeforeScaleOrSpanChangeEventHandler(
   DateScaler^ dateScaler,
   BeforeScaleOrSpanChangeArgs^ e
)

Parameters

dateScaler
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

BeforeScaleOrSpanChangeEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
Calendar_UserDraw Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : Calendar_UserDraw Delegate

aGantt
e

Glossary Item Box

The delegate for Calendar_UserDrawArgs

Syntax

Visual Basic (Declaration)
Public Delegate Sub Calendar_UserDraw( _
   ByVal aGantt As Gantt, _
   ByVal e As Calendar_UserDrawArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New Calendar_UserDraw(AddressOf HandlerMethod)
C#
public delegate void Calendar_UserDraw(
   Gantt aGantt,
   Calendar_UserDrawArgs e
)
Managed Extensions for C++
public: __gc __delegate void Calendar_UserDraw(
   Gantt* aGantt,
   Calendar_UserDrawArgs* e
)
C++/CLI
public delegate void Calendar_UserDraw(
   Gantt^ aGantt,
   Calendar_UserDrawArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

Calendar_UserDraw Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellSelectChangedHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellSelectChangedHandler Delegate

cell
cellSelectChanged

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellSelectChangedHandler( _
   ByVal cell As Cell, _
   ByVal cellSelectChanged As CellSelectChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellSelectChangedHandler(AddressOf HandlerMethod)
C#
public delegate void CellSelectChangedHandler(
   Cell cell,
   CellSelectChangedEventArgs cellSelectChanged
)
Managed Extensions for C++
public: __gc __delegate void CellSelectChangedHandler(
   Cell* cell,
   CellSelectChangedEventArgs* cellSelectChanged
)
C++/CLI
public delegate void CellSelectChangedHandler(
   Cell^ cell,
   CellSelectChangedEventArgs^ cellSelectChanged
)

Parameters

cell
cellSelectChanged

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellSelectChangedHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellToDSEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellToDSEventHandler Delegate

aNodeDataConnect
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellToDSEventHandler( _
   ByVal aNodeDataConnect As NodeDataConnect, _
   ByVal args As CellAndDSArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellToDSEventHandler(AddressOf HandlerMethod)
C#
public delegate void CellToDSEventHandler(
   NodeDataConnect aNodeDataConnect,
   CellAndDSArgs args
)
Managed Extensions for C++
public: __gc __delegate void CellToDSEventHandler(
   NodeDataConnect* aNodeDataConnect,
   CellAndDSArgs* args
)
C++/CLI
public delegate void CellToDSEventHandler(
   NodeDataConnect^ aNodeDataConnect,
   CellAndDSArgs^ args
)

Parameters

aNodeDataConnect
args

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellToDSEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CellTypeChooseHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CellTypeChooseHandler Delegate

grid
cellTypeChoose

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellTypeChooseHandler( _
   ByVal grid As Grid, _
   ByVal cellTypeChoose As CellTypeChooseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellTypeChooseHandler(AddressOf HandlerMethod)
C#
public delegate void CellTypeChooseHandler(
   Grid grid,
   CellTypeChooseEventArgs cellTypeChoose
)
Managed Extensions for C++
public: __gc __delegate void CellTypeChooseHandler(
   Grid* grid,
   CellTypeChooseEventArgs* cellTypeChoose
)
C++/CLI
public delegate void CellTypeChooseHandler(
   Grid^ grid,
   CellTypeChooseEventArgs^ cellTypeChoose
)

Parameters

grid
cellTypeChoose

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CellTypeChooseHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CollisionDetectEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CollisionDetectEvent Delegate

aGantt
e

Glossary Item Box

The delegate for CollisionDetection

Syntax

Visual Basic (Declaration)
Public Delegate Sub CollisionDetectEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As CollisionDetectEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CollisionDetectEvent(AddressOf HandlerMethod)
C#
public delegate void CollisionDetectEvent(
   Gantt aGantt,
   CollisionDetectEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void CollisionDetectEvent(
   Gantt* aGantt,
   CollisionDetectEventArgs* e
)
C++/CLI
public delegate void CollisionDetectEvent(
   Gantt^ aGantt,
   CollisionDetectEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CollisionDetectEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ColumnOrderEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ColumnOrderEventHandler Delegate

grid
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ColumnOrderEventHandler( _
   ByVal grid As Grid, _
   ByVal e As ColumnOrderArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ColumnOrderEventHandler(AddressOf HandlerMethod)
C#
public delegate void ColumnOrderEventHandler(
   Grid grid,
   ColumnOrderArgs e
)
Managed Extensions for C++
public: __gc __delegate void ColumnOrderEventHandler(
   Grid* grid,
   ColumnOrderArgs* e
)
C++/CLI
public delegate void ColumnOrderEventHandler(
   Grid^ grid,
   ColumnOrderArgs^ e
)

Parameters

grid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ColumnOrderEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_Update Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_Update Delegate

aGantt
e

Glossary Item Box

The delegate for ConflictArea_Update

Syntax

Visual Basic (Declaration)
Public Delegate Sub ConflictArea_Update( _
   ByVal aGantt As Gantt, _
   ByVal e As ConflictArea_UpdateArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ConflictArea_Update(AddressOf HandlerMethod)
C#
public delegate void ConflictArea_Update(
   Gantt aGantt,
   ConflictArea_UpdateArgs e
)
Managed Extensions for C++
public: __gc __delegate void ConflictArea_Update(
   Gantt* aGantt,
   ConflictArea_UpdateArgs* e
)
C++/CLI
public delegate void ConflictArea_Update(
   Gantt^ aGantt,
   ConflictArea_UpdateArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ConflictArea_Update Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ConflictArea_UserDraw Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ConflictArea_UserDraw Delegate

aGantt
e

Glossary Item Box

The delegate for ConflictArea_UserDraw

Syntax

Visual Basic (Declaration)
Public Delegate Sub ConflictArea_UserDraw( _
   ByVal aGantt As Gantt, _
   ByVal e As ConflictArea_UserDrawArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ConflictArea_UserDraw(AddressOf HandlerMethod)
C#
public delegate void ConflictArea_UserDraw(
   Gantt aGantt,
   ConflictArea_UserDrawArgs e
)
Managed Extensions for C++
public: __gc __delegate void ConflictArea_UserDraw(
   Gantt* aGantt,
   ConflictArea_UserDrawArgs* e
)
C++/CLI
public delegate void ConflictArea_UserDraw(
   Gantt^ aGantt,
   ConflictArea_UserDrawArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ConflictArea_UserDraw Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
CustomCellEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCellEventHandler Delegate

aGrid
e

Glossary Item Box

Delegate for CustomCellEvents

Syntax

Visual Basic (Declaration)
Public Delegate Sub CustomCellEventHandler( _
   ByVal aGrid As Grid, _
   ByVal e As CustomCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CustomCellEventHandler(AddressOf HandlerMethod)
C#
public delegate void CustomCellEventHandler(
   Grid aGrid,
   CustomCellEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void CustomCellEventHandler(
   Grid* aGrid,
   CustomCellEventArgs* e
)
C++/CLI
public delegate void CustomCellEventHandler(
   Grid^ aGrid,
   CustomCellEventArgs^ e
)

Parameters

aGrid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

CustomCellEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawBoxesEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawBoxesEventHandler Delegate

dateScaler
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub DateScalerDrawBoxesEventHandler( _
   ByVal dateScaler As DateScaler, _
   ByVal e As DateScalerDrawBoxesEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DateScalerDrawBoxesEventHandler(AddressOf HandlerMethod)
C#
public delegate void DateScalerDrawBoxesEventHandler(
   DateScaler dateScaler,
   DateScalerDrawBoxesEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DateScalerDrawBoxesEventHandler(
   DateScaler* dateScaler,
   DateScalerDrawBoxesEventArgs* e
)
C++/CLI
public delegate void DateScalerDrawBoxesEventHandler(
   DateScaler^ dateScaler,
   DateScalerDrawBoxesEventArgs^ e
)

Parameters

dateScaler
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScalerDrawBoxesEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
DateScalerDrawStringEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : DateScalerDrawStringEventHandler Delegate

dateScaler
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub DateScalerDrawStringEventHandler( _
   ByVal dateScaler As DateScaler, _
   ByVal e As DateScalerDrawStringEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DateScalerDrawStringEventHandler(AddressOf HandlerMethod)
C#
public delegate void DateScalerDrawStringEventHandler(
   DateScaler dateScaler,
   DateScalerDrawStringEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DateScalerDrawStringEventHandler(
   DateScaler* dateScaler,
   DateScalerDrawStringEventArgs* e
)
C++/CLI
public delegate void DateScalerDrawStringEventHandler(
   DateScaler^ dateScaler,
   DateScalerDrawStringEventArgs^ e
)

Parameters

dateScaler
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

DateScalerDrawStringEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EachListItemWhenDataBoundHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EachListItemWhenDataBoundHandler Delegate

GTPComponent
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub EachListItemWhenDataBoundHandler( _
   ByVal GTPComponent As Object, _
   ByVal e As EachListItemWhenDataBoundArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New EachListItemWhenDataBoundHandler(AddressOf HandlerMethod)
C#
public delegate void EachListItemWhenDataBoundHandler(
   object GTPComponent,
   EachListItemWhenDataBoundArgs e
)
Managed Extensions for C++
public: __gc __delegate void EachListItemWhenDataBoundHandler(
   Object* GTPComponent,
   EachListItemWhenDataBoundArgs* e
)
C++/CLI
public delegate void EachListItemWhenDataBoundHandler(
   Object^ GTPComponent,
   EachListItemWhenDataBoundArgs^ e
)

Parameters

GTPComponent
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

EachListItemWhenDataBoundHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EditCellHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EditCellHandler Delegate

grid
beforeEdit

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub EditCellHandler( _
   ByVal grid As Grid, _
   ByVal beforeEdit As BeforeEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New EditCellHandler(AddressOf HandlerMethod)
C#
public delegate void EditCellHandler(
   Grid grid,
   BeforeEditEventArgs beforeEdit
)
Managed Extensions for C++
public: __gc __delegate void EditCellHandler(
   Grid* grid,
   BeforeEditEventArgs* beforeEdit
)
C++/CLI
public delegate void EditCellHandler(
   Grid^ grid,
   BeforeEditEventArgs^ beforeEdit
)

Parameters

grid
beforeEdit

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

EditCellHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
EndEditCellHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EndEditCellHandler Delegate

grid
beforeEndEdit

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub EndEditCellHandler( _
   ByVal grid As Grid, _
   ByVal beforeEndEdit As BeforeEndEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New EndEditCellHandler(AddressOf HandlerMethod)
C#
public delegate void EndEditCellHandler(
   Grid grid,
   BeforeEndEditEventArgs beforeEndEdit
)
Managed Extensions for C++
public: __gc __delegate void EndEditCellHandler(
   Grid* grid,
   BeforeEndEditEventArgs* beforeEndEdit
)
C++/CLI
public delegate void EndEditCellHandler(
   Grid^ grid,
   BeforeEndEditEventArgs^ beforeEndEdit
)

Parameters

grid
beforeEndEdit

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

EndEditCellHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ErrorEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ErrorEvent Delegate

aGantt
e

Glossary Item Box

The delegate for Error handling

Syntax

Visual Basic (Declaration)
Public Delegate Sub ErrorEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As ErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ErrorEvent(AddressOf HandlerMethod)
C#
public delegate void ErrorEvent(
   Gantt aGantt,
   ErrorEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ErrorEvent(
   Gantt* aGantt,
   ErrorEventArgs* e
)
C++/CLI
public delegate void ErrorEvent(
   Gantt^ aGantt,
   ErrorEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ErrorEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ImageMapActionCallback Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ImageMapActionCallback Delegate

sender
aIMapArea

Glossary Item Box

Implement this delegate and send in a reference when producing your image maps, it will be necessary to do this in order to assign you actions to possible clicks

Syntax

Visual Basic (Declaration)
Public Delegate Sub ImageMapActionCallback( _
   ByVal sender As ImageMapLogic, _
   ByVal aIMapArea As IMapArea _
)
Visual Basic (Usage) Copy Code
Dim instance As New ImageMapActionCallback(AddressOf HandlerMethod)
C#
public delegate void ImageMapActionCallback(
   ImageMapLogic sender,
   IMapArea aIMapArea
)
Managed Extensions for C++
public: __gc __delegate void ImageMapActionCallback(
   ImageMapLogic* sender,
   IMapArea* aIMapArea
)
C++/CLI
public delegate void ImageMapActionCallback(
   ImageMapLogic^ sender,
   IMapArea^ aIMapArea
)

Parameters

sender
aIMapArea

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ImageMapActionCallback Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LayerEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LayerEvent Delegate

aGantt
e

Glossary Item Box

Delegate for insert and remove in a Layer

Syntax

Visual Basic (Declaration)
Public Delegate Sub LayerEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As LayerEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LayerEvent(AddressOf HandlerMethod)
C#
public delegate void LayerEvent(
   Gantt aGantt,
   LayerEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void LayerEvent(
   Gantt* aGantt,
   LayerEventArgs* e
)
C++/CLI
public delegate void LayerEvent(
   Gantt^ aGantt,
   LayerEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LayerEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkActionEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkActionEvent Delegate

aGantt
e

Glossary Item Box

The delegate for LinkActions

Syntax

Visual Basic (Declaration)
Public Delegate Sub LinkActionEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As LinkActionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LinkActionEvent(AddressOf HandlerMethod)
C#
public delegate void LinkActionEvent(
   Gantt aGantt,
   LinkActionEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void LinkActionEvent(
   Gantt* aGantt,
   LinkActionEventArgs* e
)
C++/CLI
public delegate void LinkActionEvent(
   Gantt^ aGantt,
   LinkActionEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LinkActionEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
LinkToDSEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : LinkToDSEventHandler Delegate

aTimeItemDataConnect
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub LinkToDSEventHandler( _
   ByVal aTimeItemDataConnect As LinkDataConnect, _
   ByVal args As LinkAndDSArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LinkToDSEventHandler(AddressOf HandlerMethod)
C#
public delegate void LinkToDSEventHandler(
   LinkDataConnect aTimeItemDataConnect,
   LinkAndDSArgs args
)
Managed Extensions for C++
public: __gc __delegate void LinkToDSEventHandler(
   LinkDataConnect* aTimeItemDataConnect,
   LinkAndDSArgs* args
)
C++/CLI
public delegate void LinkToDSEventHandler(
   LinkDataConnect^ aTimeItemDataConnect,
   LinkAndDSArgs^ args
)

Parameters

aTimeItemDataConnect
args

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

LinkToDSEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeEventHandler Delegate

aGrid
e

Glossary Item Box

Delegate for insert and remove node ops

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeEventHandler( _
   ByVal aGrid As Grid, _
   ByVal e As NodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeEventHandler(
   Grid aGrid,
   NodeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void NodeEventHandler(
   Grid* aGrid,
   NodeEventArgs* e
)
C++/CLI
public delegate void NodeEventHandler(
   Grid^ aGrid,
   NodeEventArgs^ e
)

Parameters

aGrid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

NodeEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
NodeExpandStatusHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : NodeExpandStatusHandler Delegate

node

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeExpandStatusHandler( _
   ByVal node As GridNode _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeExpandStatusHandler(AddressOf HandlerMethod)
C#
public delegate void NodeExpandStatusHandler(
   GridNode node
)
Managed Extensions for C++
public: __gc __delegate void NodeExpandStatusHandler(
   GridNode* node
)
C++/CLI
public delegate void NodeExpandStatusHandler(
   GridNode^ node
)

Parameters

node

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

NodeExpandStatusHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
OffscreenDrawEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : OffscreenDrawEvent Delegate

aOffscreenDraw
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub OffscreenDrawEvent( _
   ByVal aOffscreenDraw As OffscreenDraw, _
   ByVal e As OffscreenDrawArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New OffscreenDrawEvent(AddressOf HandlerMethod)
C#
public delegate void OffscreenDrawEvent(
   OffscreenDraw aOffscreenDraw,
   OffscreenDrawArgs e
)
Managed Extensions for C++
public: __gc __delegate void OffscreenDrawEvent(
   OffscreenDraw* aOffscreenDraw,
   OffscreenDrawArgs* e
)
C++/CLI
public delegate void OffscreenDrawEvent(
   OffscreenDraw^ aOffscreenDraw,
   OffscreenDrawArgs^ e
)

Parameters

aOffscreenDraw
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

OffscreenDrawEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PanButton.PanEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton.PanEventHandler Delegate

sender
pe

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub PanButton.PanEventHandler( _
   ByVal sender As Object, _
   ByVal pe As PanEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PanButton.PanEventHandler(AddressOf HandlerMethod)
C#
public delegate void PanButton.PanEventHandler(
   object sender,
   PanEventArgs pe
)
Managed Extensions for C++
public: __gc __delegate void PanButton.PanEventHandler(
   Object* sender,
   PanEventArgs* pe
)
C++/CLI
public delegate void PanButton.PanEventHandler(
   Object^ sender,
   PanEventArgs^ pe
)

Parameters

sender
pe

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PanButton.PanEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
PreCursorChangeEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PreCursorChangeEvent Delegate

aOffscreenDraw
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub PreCursorChangeEvent( _
   ByVal aOffscreenDraw As OffscreenDraw, _
   ByVal e As PreCursorChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PreCursorChangeEvent(AddressOf HandlerMethod)
C#
public delegate void PreCursorChangeEvent(
   OffscreenDraw aOffscreenDraw,
   PreCursorChangeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void PreCursorChangeEvent(
   OffscreenDraw* aOffscreenDraw,
   PreCursorChangeEventArgs* e
)
C++/CLI
public delegate void PreCursorChangeEvent(
   OffscreenDraw^ aOffscreenDraw,
   PreCursorChangeEventArgs^ e
)

Parameters

aOffscreenDraw
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

PreCursorChangeEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeDoneEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeDoneEventHandler Delegate

aGrid
e

Glossary Item Box

Delegate for catching user resized grid row

Syntax

Visual Basic (Declaration)
Public Delegate Sub RowResizeDoneEventHandler( _
   ByVal aGrid As Grid, _
   ByVal e As RowResizeDoneArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RowResizeDoneEventHandler(AddressOf HandlerMethod)
C#
public delegate void RowResizeDoneEventHandler(
   Grid aGrid,
   RowResizeDoneArgs e
)
Managed Extensions for C++
public: __gc __delegate void RowResizeDoneEventHandler(
   Grid* aGrid,
   RowResizeDoneArgs* e
)
C++/CLI
public delegate void RowResizeDoneEventHandler(
   Grid^ aGrid,
   RowResizeDoneArgs^ e
)

Parameters

aGrid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

RowResizeDoneEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
RowResizeEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : RowResizeEventHandler Delegate

aGrid
e

Glossary Item Box

Delegate for catching user resize grid row

Syntax

Visual Basic (Declaration)
Public Delegate Sub RowResizeEventHandler( _
   ByVal aGrid As Grid, _
   ByVal e As RowResizeArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RowResizeEventHandler(AddressOf HandlerMethod)
C#
public delegate void RowResizeEventHandler(
   Grid aGrid,
   RowResizeArgs e
)
Managed Extensions for C++
public: __gc __delegate void RowResizeEventHandler(
   Grid* aGrid,
   RowResizeArgs* e
)
C++/CLI
public delegate void RowResizeEventHandler(
   Grid^ aGrid,
   RowResizeArgs^ e
)

Parameters

aGrid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

RowResizeEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeDistinctThread.AsyncDelegate Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeDistinctThread.AsyncDelegate Delegate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeDistinctThread.AsyncDelegate()
Visual Basic (Usage) Copy Code
Dim instance As New TimeDistinctThread.AsyncDelegate(AddressOf HandlerMethod)
C#
public delegate void TimeDistinctThread.AsyncDelegate()
Managed Extensions for C++
public: __gc __delegate void TimeDistinctThread.AsyncDelegate();
C++/CLI
public delegate void TimeDistinctThread.AsyncDelegate();

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeDistinctThread.AsyncDelegate Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItem_UserBrushCreate Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItem_UserBrushCreate Delegate

aGantt
e

Glossary Item Box

The delegate for TimeItem_UserBrushCreate, event fires when you use TimeItemLayout.BrushKind=BrushKind.UserCreatedBrush

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeItem_UserBrushCreate( _
   ByVal aGantt As Gantt, _
   ByVal e As UserBrushCreateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TimeItem_UserBrushCreate(AddressOf HandlerMethod)
C#
public delegate void TimeItem_UserBrushCreate(
   Gantt aGantt,
   UserBrushCreateEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TimeItem_UserBrushCreate(
   Gantt* aGantt,
   UserBrushCreateEventArgs* e
)
C++/CLI
public delegate void TimeItem_UserBrushCreate(
   Gantt^ aGantt,
   UserBrushCreateEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItem_UserBrushCreate Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemEvent Delegate

aGantt
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeItemEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As TimeItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemEvent(AddressOf HandlerMethod)
C#
public delegate void TimeItemEvent(
   Gantt aGantt,
   TimeItemEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TimeItemEvent(
   Gantt* aGantt,
   TimeItemEventArgs* e
)
C++/CLI
public delegate void TimeItemEvent(
   Gantt^ aGantt,
   TimeItemEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemLinkHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemLinkHandler Delegate

aLinks
args

Glossary Item Box

Used for TimeItemLinkEvents

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeItemLinkHandler( _
   ByVal aLinks As TimeItemLinks, _
   ByVal args As TimeItemLinkArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemLinkHandler(AddressOf HandlerMethod)
C#
public delegate void TimeItemLinkHandler(
   TimeItemLinks aLinks,
   TimeItemLinkArgs args
)
Managed Extensions for C++
public: __gc __delegate void TimeItemLinkHandler(
   TimeItemLinks* aLinks,
   TimeItemLinkArgs* args
)
C++/CLI
public delegate void TimeItemLinkHandler(
   TimeItemLinks^ aLinks,
   TimeItemLinkArgs^ args
)

Parameters

aLinks
args

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemLinkHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TimeItemToDSEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeItemToDSEventHandler Delegate

aTimeItemDataConnect
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeItemToDSEventHandler( _
   ByVal aTimeItemDataConnect As TimeItemDataConnect, _
   ByVal args As TimeItemAndDSArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemToDSEventHandler(AddressOf HandlerMethod)
C#
public delegate void TimeItemToDSEventHandler(
   TimeItemDataConnect aTimeItemDataConnect,
   TimeItemAndDSArgs args
)
Managed Extensions for C++
public: __gc __delegate void TimeItemToDSEventHandler(
   TimeItemDataConnect* aTimeItemDataConnect,
   TimeItemAndDSArgs* args
)
C++/CLI
public delegate void TimeItemToDSEventHandler(
   TimeItemDataConnect^ aTimeItemDataConnect,
   TimeItemAndDSArgs^ args
)

Parameters

aTimeItemDataConnect
args

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TimeItemToDSEventHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
TopLeftChangedHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TopLeftChangedHandler Delegate

cell

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TopLeftChangedHandler( _
   ByVal cell As Cell _
)
Visual Basic (Usage) Copy Code
Dim instance As New TopLeftChangedHandler(AddressOf HandlerMethod)
C#
public delegate void TopLeftChangedHandler(
   Cell cell
)
Managed Extensions for C++
public: __gc __delegate void TopLeftChangedHandler(
   Cell* cell
)
C++/CLI
public delegate void TopLeftChangedHandler(
   Cell^ cell
)

Parameters

cell

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

TopLeftChangedHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnBindedSortHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnBindedSortHandler Delegate

aGrid
e

Glossary Item Box

Event delegate is used when a column sort occures on an unbinded list

Syntax

Visual Basic (Declaration)
Public Delegate Sub UnBindedSortHandler( _
   ByVal aGrid As Grid, _
   ByVal e As UnBindedSortArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UnBindedSortHandler(AddressOf HandlerMethod)
C#
public delegate void UnBindedSortHandler(
   Grid aGrid,
   UnBindedSortArgs e
)
Managed Extensions for C++
public: __gc __delegate void UnBindedSortHandler(
   Grid* aGrid,
   UnBindedSortArgs* e
)
C++/CLI
public delegate void UnBindedSortHandler(
   Grid^ aGrid,
   UnBindedSortArgs^ e
)

Parameters

aGrid
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UnBindedSortHandler Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UnhandledExceptionEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UnhandledExceptionEvent Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub UnhandledExceptionEvent( _
   ByVal sender As Control, _
   ByVal e As UnhandledExceptionArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UnhandledExceptionEvent(AddressOf HandlerMethod)
C#
public delegate void UnhandledExceptionEvent(
   Control sender,
   UnhandledExceptionArgs e
)
Managed Extensions for C++
public: __gc __delegate void UnhandledExceptionEvent(
   Control* sender,
   UnhandledExceptionArgs* e
)
C++/CLI
public delegate void UnhandledExceptionEvent(
   Control^ sender,
   UnhandledExceptionArgs^ e
)

Parameters

sender
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UnhandledExceptionEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
UserDrawLinkEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : UserDrawLinkEvent Delegate

aGantt
e

Glossary Item Box

The delegate for UserDrawLinkEvent

Syntax

Visual Basic (Declaration)
Public Delegate Sub UserDrawLinkEvent( _
   ByVal aGantt As Gantt, _
   ByVal e As UserDrawLinkEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UserDrawLinkEvent(AddressOf HandlerMethod)
C#
public delegate void UserDrawLinkEvent(
   Gantt aGantt,
   UserDrawLinkEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void UserDrawLinkEvent(
   Gantt* aGantt,
   UserDrawLinkEventArgs* e
)
C++/CLI
public delegate void UserDrawLinkEvent(
   Gantt^ aGantt,
   UserDrawLinkEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

UserDrawLinkEvent Members
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
ViewDateInformationEventHandler Delegate
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ViewDateInformationEventHandler Delegate

dateScaler
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub ViewDateInformationEventHandler( _
   ByVal dateScaler As DateScaler, _
   ByVal e As ViewDateInformationArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ViewDateInformationEventHandler(AddressOf HandlerMethod)
C#
public delegate void ViewDateInformationEventHandler(
   DateScaler dateScaler,
   ViewDateInformationArgs e
)
Managed Extensions for C++
public: __gc __delegate void ViewDateInformationEventHandler(
   DateScaler* dateScaler,
   ViewDateInformationArgs* e
)
C++/CLI
public delegate void ViewDateInformationEventHandler(
   DateScaler^ dateScaler,
   ViewDateInformationArgs^ e
)

Parameters

dateScaler
e

Requirements

Namespace: PlexityHide.GTP

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.dll)

See Also

Reference

ViewDateInformationEventHandler Members
PlexityHide.GTP Namespace


$$INTRODUCTION$$ - %%projecttitle%%

PlexityHide.GTP.WEB
Introduction
Send comments on this topic.

Glossary Item Box

Gantt_ASP

The Gantt in GTP.NET is the foundation for Gantt_ASP. GTP.NET windows forms logic is utilized as an engine to render and handle the logic for presentation of the Gantt_ASP.

Gantt_ASP is a server side ASP.NET control that delivers nothing but html and javascripts. It uses post backs to facilitate zooming and time panoration.

Since it uses the full windows forms Gantt you have access to all the databinding, collision detection, and links.

Gantt_ASP uses the Microsoft Ajax framework to support client side scripts for TimeItem moving, resizing etc. To make use of these futures set ClientTimeItems to true. When this property is set, client side scripts are generated to handle client side operations.


%%phrase%%

PlexityHide.GTP.WEB
PlexityHide.GTP.WEB Assembly
See Also Send comments on this topic.

Glossary Item Box

Namespaces

Namespace | Description
PlexityHide.GTP.WEB |


$$GETTING_STARTED$$ - %%projecttitle%%

PlexityHide.GTP.WEB
Getting Started
Send comments on this topic.

Glossary Item Box

Gantt_ASP instruction page.

Take a look at this sample.

Here we will describe what you need to do in order to display Gantt schemas on your aspx pages.

The Gantt_ASP inherites from System.Web.UI.WebControls.WebControl, but it relies heavily on the logic present in PlexityHide.GTP.Gantt which is a Windows forms component. All Gantt specific logic in Gantt_ASP originates from PlexiHide.GTP.Gantt, so a good understanding of this component is important.

Gantt_ASP will generate images on-the fly based on postbacks from the user. Images will be temporarily stored in a directory of your choosing (design time only); Gantt_ASP.ImagePath. The default value is c:\temp. The directory does not need to be exposed thru IIS, but you as a developer need to have read and write access to it. The images are generated and referred to by Gantt_ASP, and the client request for the image is formed like this: ./GTPImg.aspx?filename=xxx and you must add the GTPImg.aspx web form to your application so the images can be handed over to the client.

You also need to have images that represent the plus and minus of the Gantt tree, you may copy the ones we supply or add your own to your application directory.

Then add the Gantt_ASP WebControl to your form. If you want visual design support for adding columns and all the settings available in PlexityHide.GTP.Gantt you can add the Gantt_ASPSetting component to your form. This component has a expandable property Gantt that contains the PlexityHide.GTP.Gantt. You should connect the Gantt_ASP to Gantt_ASPSettings by setting the Gantt_ASPSettings.Gantt_ASP property. Settings made to the Gantt_ASPSettings component will be persisted in code in the code behind file.

  1. Choose a temporary directory to store images if you do not want them in c:\temp and assign the ImagePath property
  2. Add GTPImg.aspx to your application
  3. Add plus and minus png to your application folder

The design time look of the Gantt_ASP will not work properly until you have performed the above steps and successfully compiled your project once.

Your Web application need these assemblies function with the Gantt_ASP

  1. PlexityHide.GTP
  2. PlexityHide.GTP.WEB
  3. System.Windows.Forms

!Note: Since the PlexityHide.GTP.Gantt relies on Windows forms you must add System.Windows.Forms to your web application, this does not mean that you build a windows form application, its only purpose is to harbor the PlexityHide.GTP.Gantt so that we can use the logic within.


%%ItemTitle%%

PlexityHide.GTP.WEB
PlexityHide.GTP.WEB Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Glossary Item Box

Classes

 | Class | Description
Class | AreaAttributeEventArgs | Arguments for area events
Class | CacheStats | Statitics on what has been put on the cache
Class | CalcFontDifferenceArgs | The Gantt is rendered by windows forms. If you use MultiText in your cells row wrap will occure. Row wrap will make GanttRows higher(fatter). The text in the Gantt_ASP is normal html-text. If the html-text-font and the windows form font are not the same size (even if the have the same size set, they can be rendered differently), you may get the effect that the html-cell is to big for the html text (leaving white space), or to small; crowding the text. In this case we offer this event to provide a calculation factor; how much the fonts differ. You can set this factor to minimize the differences as much as possible.
Class | CellContentTuningArgs | Arguments for CellContentTuningEvent
Class | CellDivArgs | Arguments for the CellDiv event
Class | ClientClick_NodeKeyArgs | Argument for the ClientClick_NodeKey event
Class | Gantt_ASP | Gantt_ASP allows you to produce pure html Gantt charts that use some interaction
Class | Gantt_ASPSettings | Gantt_ASPSettings collects a lot of settings for the windows forms Gantt that you can resuse in a Gantt_ASP
Class | GanttRowClickEventArgs | Arguments for GanttRow click event
Class | GetImage |
Class | TimeItemUserStringPrepareArgs | Arguments for area events

Delegates

 | Delegate | Description
Delegate | AreaAttributeEvent | This event is for Gantt_ASP to allow for extension of area tags
Delegate | CellContentTuningEvent | Fires when preparing cell content.
Delegate | CellDivAttributesStringEvent | Fires when preparing the html for each grid cell. You can implement to inject div attributes on a cell. Can be used to implement tooltips or/and cell events.
Delegate | FontResizeEvent | This event is used to allow for you to minimize difference between winform fonts and html-fonts
Delegate | GanttRowClickEvent | This event is for Gantt_ASP to allow for extension of area tags
Delegate | GetResourceEvent | This event is for Gantt_ASP to allow for override of fixed images
Delegate | TimeItemUserStringPrepareEvent | This event is used to initiade ClientSide TimeItem's UserString property

Enumerations

 | Enumeration | Description
Enumeration | AreaKind | Active Areas are a typed by an AreaKind

See Also

Reference

PlexityHide.GTP.WEB Assembly


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
AreaAttributeEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : AreaAttributeEventArgs Class

Glossary Item Box

Arguments for area events

Object Model

AreaAttributeEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class AreaAttributeEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As AreaAttributeEventArgs
C#
public class AreaAttributeEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class AreaAttributeEventArgs : public System.EventArgs
C++/CLI
public ref class AreaAttributeEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.AreaAttributeEventArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

AreaAttributeEventArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
AreaAttributeEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : AreaAttributeEventArgs Class

Glossary Item Box

The following tables list the members exposed by AreaAttributeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | AreaAttributeEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | AreaKind | The kind of area that the event refers to
Public Field | GroupName | A group name of this item
Public Field | ItemKey | An optional key that makes this item unique from other items with the same group name
Public Field | Result | The outcomming result. This is initiated to the default behaviour of the component. If you wish to keep the default and add your own as well you can append to this. If you want to remove the default you can clear this value and possibly add your own.
Top

See Also

Reference

AreaAttributeEventArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
AreaAttributeEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > AreaAttributeEventArgs Class : AreaAttributeEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New AreaAttributeEventArgs()
C#
public AreaAttributeEventArgs()
Managed Extensions for C++
public: AreaAttributeEventArgs();
C++/CLI
public:
AreaAttributeEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AreaAttributeEventArgs Class
AreaAttributeEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
AreaAttributeEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : AreaAttributeEventArgs Class

Glossary Item Box

For a list of all members of this type, see AreaAttributeEventArgs members.

Public Fields

 | Name | Description
Public Field | AreaKind | The kind of area that the event refers to
Public Field | GroupName | A group name of this item
Public Field | ItemKey | An optional key that makes this item unique from other items with the same group name
Public Field | Result | The outcomming result. This is initiated to the default behaviour of the component. If you wish to keep the default and add your own as well you can append to this. If you want to remove the default you can clear this value and possibly add your own.
Top

See Also

Reference

AreaAttributeEventArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
AreaKind Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > AreaAttributeEventArgs Class : AreaKind Field

Glossary Item Box

The kind of area that the event refers to

Syntax

Visual Basic (Declaration)
Public AreaKind As AreaKind
Visual Basic (Usage) Copy Code
Dim instance As AreaAttributeEventArgs
Dim value As AreaKind

value = instance.AreaKind

instance.AreaKind = value
C#
public AreaKind AreaKind
Managed Extensions for C++
public: AreaKind AreaKind
C++/CLI
public:
AreaKind AreaKind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AreaAttributeEventArgs Class
AreaAttributeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GroupName Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > AreaAttributeEventArgs Class : GroupName Field

Glossary Item Box

A group name of this item

Syntax

Visual Basic (Declaration)
Public GroupName As String
Visual Basic (Usage) Copy Code
Dim instance As AreaAttributeEventArgs
Dim value As String

value = instance.GroupName

instance.GroupName = value
C#
public string GroupName
Managed Extensions for C++
public: string* GroupName
C++/CLI
public:
String^ GroupName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AreaAttributeEventArgs Class
AreaAttributeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ItemKey Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > AreaAttributeEventArgs Class : ItemKey Field

Glossary Item Box

An optional key that makes this item unique from other items with the same group name

Syntax

Visual Basic (Declaration)
Public ItemKey As String
Visual Basic (Usage) Copy Code
Dim instance As AreaAttributeEventArgs
Dim value As String

value = instance.ItemKey

instance.ItemKey = value
C#
public string ItemKey
Managed Extensions for C++
public: string* ItemKey
C++/CLI
public:
String^ ItemKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AreaAttributeEventArgs Class
AreaAttributeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Result Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > AreaAttributeEventArgs Class : Result Field

Glossary Item Box

The outcomming result. This is initiated to the default behaviour of the component. If you wish to keep the default and add your own as well you can append to this. If you want to remove the default you can clear this value and possibly add your own.

Syntax

Visual Basic (Declaration)
Public Result As String
Visual Basic (Usage) Copy Code
Dim instance As AreaAttributeEventArgs
Dim value As String

value = instance.Result

instance.Result = value
C#
public string Result
Managed Extensions for C++
public: string* Result
C++/CLI
public:
String^ Result

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

AreaAttributeEventArgs Class
AreaAttributeEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CacheStats Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CacheStats Class

Glossary Item Box

Statitics on what has been put on the cache

Object Model

CacheStats Class

Syntax

Visual Basic (Declaration)
Public Class CacheStats
Visual Basic (Usage) Copy Code
Dim instance As CacheStats
C#
public class CacheStats
Managed Extensions for C++
public __gc class CacheStats
C++/CLI
public ref class CacheStats

Inheritance Hierarchy

System.Object
PlexityHide.GTP.WEB.CacheStats

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CacheStats Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
CacheStats Class Members
See Also Properties Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CacheStats Class

Glossary Item Box

The following tables list the members exposed by CacheStats.

Public Constructors

 | Name | Description
Public Constructor | CacheStats Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CalculatedAmountOfLiveImages | A calculated value (imagesSeen-imagesRemovedFromCache) on how many images that are currently live on the cache
static (Shared in Visual Basic) | ImagesDuplicates | The count of images that was put on the cache to replace an exactly the like (to extend cache time)
static (Shared in Visual Basic) | ImagesRemovedFromCache | The count of images that the cache has called OnDestroy for
static (Shared in Visual Basic) | ImagesSeen | The count of images that has been inserted to the cache
static (Shared in Visual Basic) | NumberOfExceptionsOnCacheInsertions | The count of swallowed exceptions in page.Cache.Insert
Top

See Also

Reference

CacheStats Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CacheStats Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : CacheStats Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CacheStats()
C#
public CacheStats()
Managed Extensions for C++
public: CacheStats();
C++/CLI
public:
CacheStats();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP.WEB
CacheStats Class Properties
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CacheStats Class

Glossary Item Box

For a list of all members of this type, see CacheStats members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CalculatedAmountOfLiveImages | A calculated value (imagesSeen-imagesRemovedFromCache) on how many images that are currently live on the cache
static (Shared in Visual Basic) | ImagesDuplicates | The count of images that was put on the cache to replace an exactly the like (to extend cache time)
static (Shared in Visual Basic) | ImagesRemovedFromCache | The count of images that the cache has called OnDestroy for
static (Shared in Visual Basic) | ImagesSeen | The count of images that has been inserted to the cache
static (Shared in Visual Basic) | NumberOfExceptionsOnCacheInsertions | The count of swallowed exceptions in page.Cache.Insert
Top

See Also

Reference

CacheStats Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CalculatedAmountOfLiveImages Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : CalculatedAmountOfLiveImages Property

Glossary Item Box

A calculated value (imagesSeen-imagesRemovedFromCache) on how many images that are currently live on the cache

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CalculatedAmountOfLiveImages As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CacheStats.CalculatedAmountOfLiveImages
C#
public static int CalculatedAmountOfLiveImages {get;}
Managed Extensions for C++
public: __property static int get_CalculatedAmountOfLiveImages();
C++/CLI
public:
static property int CalculatedAmountOfLiveImages {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ImagesDuplicates Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : ImagesDuplicates Property

Glossary Item Box

The count of images that was put on the cache to replace an exactly the like (to extend cache time)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ImagesDuplicates As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CacheStats.ImagesDuplicates
C#
public static int ImagesDuplicates {get;}
Managed Extensions for C++
public: __property static int get_ImagesDuplicates();
C++/CLI
public:
static property int ImagesDuplicates {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ImagesRemovedFromCache Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : ImagesRemovedFromCache Property

Glossary Item Box

The count of images that the cache has called OnDestroy for

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ImagesRemovedFromCache As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CacheStats.ImagesRemovedFromCache
C#
public static int ImagesRemovedFromCache {get;}
Managed Extensions for C++
public: __property static int get_ImagesRemovedFromCache();
C++/CLI
public:
static property int ImagesRemovedFromCache {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ImagesSeen Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : ImagesSeen Property

Glossary Item Box

The count of images that has been inserted to the cache

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ImagesSeen As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CacheStats.ImagesSeen
C#
public static int ImagesSeen {get;}
Managed Extensions for C++
public: __property static int get_ImagesSeen();
C++/CLI
public:
static property int ImagesSeen {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
NumberOfExceptionsOnCacheInsertions Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CacheStats Class : NumberOfExceptionsOnCacheInsertions Property

Glossary Item Box

The count of swallowed exceptions in page.Cache.Insert

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NumberOfExceptionsOnCacheInsertions As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CacheStats.NumberOfExceptionsOnCacheInsertions
C#
public static int NumberOfExceptionsOnCacheInsertions {get;}
Managed Extensions for C++
public: __property static int get_NumberOfExceptionsOnCacheInsertions();
C++/CLI
public:
static property int NumberOfExceptionsOnCacheInsertions {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CacheStats Class
CacheStats Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CalcFontDifferenceArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CalcFontDifferenceArgs Class

Glossary Item Box

The Gantt is rendered by windows forms. If you use MultiText in your cells row wrap will occure. Row wrap will make GanttRows higher(fatter). The text in the Gantt_ASP is normal html-text. If the html-text-font and the windows form font are not the same size (even if the have the same size set, they can be rendered differently), you may get the effect that the html-cell is to big for the html text (leaving white space), or to small; crowding the text. In this case we offer this event to provide a calculation factor; how much the fonts differ. You can set this factor to minimize the differences as much as possible.

Object Model

CalcFontDifferenceArgs Class

Syntax

Visual Basic (Declaration)
Public Class CalcFontDifferenceArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CalcFontDifferenceArgs
C#
public class CalcFontDifferenceArgs : System.EventArgs
Managed Extensions for C++
public __gc class CalcFontDifferenceArgs : public System.EventArgs
C++/CLI
public ref class CalcFontDifferenceArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.CalcFontDifferenceArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CalcFontDifferenceArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
CalcFontDifferenceArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CalcFontDifferenceArgs Class

Glossary Item Box

The following tables list the members exposed by CalcFontDifferenceArgs.

Public Constructors

 | Name | Description
Public Constructor | CalcFontDifferenceArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | cellLayout | The CellLayout in question
Public Field | fontResizeFactor | The font resize factor will be multiplied with the Font-size value of the cellLayout in order to get the html-font-size. Default value is 1.0; try to return 1.25 here if your html font is to small for the row wrapped cell.
Top

See Also

Reference

CalcFontDifferenceArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CalcFontDifferenceArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CalcFontDifferenceArgs Class : CalcFontDifferenceArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CalcFontDifferenceArgs()
C#
public CalcFontDifferenceArgs()
Managed Extensions for C++
public: CalcFontDifferenceArgs();
C++/CLI
public:
CalcFontDifferenceArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalcFontDifferenceArgs Class
CalcFontDifferenceArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
CalcFontDifferenceArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CalcFontDifferenceArgs Class

Glossary Item Box

For a list of all members of this type, see CalcFontDifferenceArgs members.

Public Fields

 | Name | Description
Public Field | cellLayout | The CellLayout in question
Public Field | fontResizeFactor | The font resize factor will be multiplied with the Font-size value of the cellLayout in order to get the html-font-size. Default value is 1.0; try to return 1.25 here if your html font is to small for the row wrapped cell.
Top

See Also

Reference

CalcFontDifferenceArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
cellLayout Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CalcFontDifferenceArgs Class : cellLayout Field

Glossary Item Box

The CellLayout in question

Syntax

Visual Basic (Declaration)
Public cellLayout As CellLayout
Visual Basic (Usage) Copy Code
Dim instance As CalcFontDifferenceArgs
Dim value As CellLayout

value = instance.cellLayout

instance.cellLayout = value
C#
public CellLayout cellLayout
Managed Extensions for C++
public: CellLayout* cellLayout
C++/CLI
public:
CellLayout^ cellLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalcFontDifferenceArgs Class
CalcFontDifferenceArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
fontResizeFactor Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CalcFontDifferenceArgs Class : fontResizeFactor Field

Glossary Item Box

The font resize factor will be multiplied with the Font-size value of the cellLayout in order to get the html-font-size. Default value is 1.0; try to return 1.25 here if your html font is to small for the row wrapped cell.

Syntax

Visual Basic (Declaration)
Public fontResizeFactor As Double
Visual Basic (Usage) Copy Code
Dim instance As CalcFontDifferenceArgs
Dim value As Double

value = instance.fontResizeFactor

instance.fontResizeFactor = value
C#
public double fontResizeFactor
Managed Extensions for C++
public: double fontResizeFactor
C++/CLI
public:
double fontResizeFactor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CalcFontDifferenceArgs Class
CalcFontDifferenceArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellContentTuningArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellContentTuningArgs Class

Glossary Item Box

Arguments for CellContentTuningEvent

Object Model

CellContentTuningArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellContentTuningArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellContentTuningArgs
C#
public class CellContentTuningArgs : System.EventArgs
Managed Extensions for C++
public __gc class CellContentTuningArgs : public System.EventArgs
C++/CLI
public ref class CellContentTuningArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.CellContentTuningArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CellContentTuningArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
CellContentTuningArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellContentTuningArgs Class

Glossary Item Box

The following tables list the members exposed by CellContentTuningArgs.

Public Constructors

 | Name | Description
Public Constructor | CellContentTuningArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The Cell that is about to be rendered
Public Field | Content | The content is the textual representation of your cell value, you can change this and the new value will be added instead. You can also inject valid html here.
Top

See Also

Reference

CellContentTuningArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellContentTuningArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellContentTuningArgs Class : CellContentTuningArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellContentTuningArgs()
C#
public CellContentTuningArgs()
Managed Extensions for C++
public: CellContentTuningArgs();
C++/CLI
public:
CellContentTuningArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellContentTuningArgs Class
CellContentTuningArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
CellContentTuningArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellContentTuningArgs Class

Glossary Item Box

For a list of all members of this type, see CellContentTuningArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The Cell that is about to be rendered
Public Field | Content | The content is the textual representation of your cell value, you can change this and the new value will be added instead. You can also inject valid html here.
Top

See Also

Reference

CellContentTuningArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellContentTuningArgs Class : Cell Field

Glossary Item Box

The Cell that is about to be rendered

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As CellContentTuningArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellContentTuningArgs Class
CellContentTuningArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Content Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellContentTuningArgs Class : Content Field

Glossary Item Box

The content is the textual representation of your cell value, you can change this and the new value will be added instead. You can also inject valid html here.

Syntax

Visual Basic (Declaration)
Public Content As String
Visual Basic (Usage) Copy Code
Dim instance As CellContentTuningArgs
Dim value As String

value = instance.Content

instance.Content = value
C#
public string Content
Managed Extensions for C++
public: string* Content
C++/CLI
public:
String^ Content

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellContentTuningArgs Class
CellContentTuningArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellDivArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellDivArgs Class

Glossary Item Box

Arguments for the CellDiv event

Object Model

CellDivArgs Class

Syntax

Visual Basic (Declaration)
Public Class CellDivArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CellDivArgs
C#
public class CellDivArgs : System.EventArgs
Managed Extensions for C++
public __gc class CellDivArgs : public System.EventArgs
C++/CLI
public ref class CellDivArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.CellDivArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CellDivArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
CellDivArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellDivArgs Class

Glossary Item Box

The following tables list the members exposed by CellDivArgs.

Public Constructors

 | Name | Description
Public Constructor | CellDivArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Cell | The Cell that is about to be rendered
Public Field | result | In the result you can inject your own div attributes like e.result="title='Simple tooltip for cell'";
Top

See Also

Reference

CellDivArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellDivArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellDivArgs Class : CellDivArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CellDivArgs()
C#
public CellDivArgs()
Managed Extensions for C++
public: CellDivArgs();
C++/CLI
public:
CellDivArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellDivArgs Class
CellDivArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
CellDivArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellDivArgs Class

Glossary Item Box

For a list of all members of this type, see CellDivArgs members.

Public Fields

 | Name | Description
Public Field | Cell | The Cell that is about to be rendered
Public Field | result | In the result you can inject your own div attributes like e.result="title='Simple tooltip for cell'";
Top

See Also

Reference

CellDivArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Cell Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellDivArgs Class : Cell Field

Glossary Item Box

The Cell that is about to be rendered

Syntax

Visual Basic (Declaration)
Public Cell As Cell
Visual Basic (Usage) Copy Code
Dim instance As CellDivArgs
Dim value As Cell

value = instance.Cell

instance.Cell = value
C#
public Cell Cell
Managed Extensions for C++
public: Cell* Cell
C++/CLI
public:
Cell^ Cell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellDivArgs Class
CellDivArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
result Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > CellDivArgs Class : result Field

Glossary Item Box

In the result you can inject your own div attributes like e.result="title='Simple tooltip for cell'";

Syntax

Visual Basic (Declaration)
Public result As String
Visual Basic (Usage) Copy Code
Dim instance As CellDivArgs
Dim value As String

value = instance.result

instance.result = value
C#
public string result
Managed Extensions for C++
public: string* result
C++/CLI
public:
String^ result

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CellDivArgs Class
CellDivArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientClick_NodeKeyArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : ClientClick_NodeKeyArgs Class

Glossary Item Box

Argument for the ClientClick_NodeKey event

Object Model

ClientClick_NodeKeyArgs Class

Syntax

Visual Basic (Declaration)
Public Class ClientClick_NodeKeyArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ClientClick_NodeKeyArgs
C#
public class ClientClick_NodeKeyArgs : System.EventArgs
Managed Extensions for C++
public __gc class ClientClick_NodeKeyArgs : public System.EventArgs
C++/CLI
public ref class ClientClick_NodeKeyArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.ClientClick_NodeKeyArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

ClientClick_NodeKeyArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
ClientClick_NodeKeyArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : ClientClick_NodeKeyArgs Class

Glossary Item Box

The following tables list the members exposed by ClientClick_NodeKeyArgs.

Public Constructors

 | Name | Description
Public Constructor | ClientClick_NodeKeyArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | NodeKey | Node key, use with GridNodeFromKey
Top

See Also

Reference

ClientClick_NodeKeyArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientClick_NodeKeyArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > ClientClick_NodeKeyArgs Class : ClientClick_NodeKeyArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ClientClick_NodeKeyArgs()
C#
public ClientClick_NodeKeyArgs()
Managed Extensions for C++
public: ClientClick_NodeKeyArgs();
C++/CLI
public:
ClientClick_NodeKeyArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ClientClick_NodeKeyArgs Class
ClientClick_NodeKeyArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
ClientClick_NodeKeyArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : ClientClick_NodeKeyArgs Class

Glossary Item Box

For a list of all members of this type, see ClientClick_NodeKeyArgs members.

Public Fields

 | Name | Description
Public Field | NodeKey | Node key, use with GridNodeFromKey
Top

See Also

Reference

ClientClick_NodeKeyArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
NodeKey Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > ClientClick_NodeKeyArgs Class : NodeKey Field

Glossary Item Box

Node key, use with GridNodeFromKey

Syntax

Visual Basic (Declaration)
Public NodeKey As String
Visual Basic (Usage) Copy Code
Dim instance As ClientClick_NodeKeyArgs
Dim value As String

value = instance.NodeKey

instance.NodeKey = value
C#
public string NodeKey
Managed Extensions for C++
public: string* NodeKey
C++/CLI
public:
String^ NodeKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ClientClick_NodeKeyArgs Class
ClientClick_NodeKeyArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASP Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASP Class

Glossary Item Box

Gantt_ASP allows you to produce pure html Gantt charts that use some interaction

Object Model

Gantt_ASP ClassGantt Class

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<ToolboxDataAttribute("<{0}:Gantt_ASP runat=server></{0}:Gantt_ASP>")>
<PersistChildrenAttribute(Persist=False, UsesCustomPersistence=False)>
<ParseChildrenAttribute(True)>
Public Class Gantt_ASP
   Inherits System.Web.UI.WebControls.WebControl
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
C#
[ToolboxBitmapAttribute()]
[ToolboxDataAttribute("<{0}:Gantt_ASP runat=server></{0}:Gantt_ASP>")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ParseChildrenAttribute(true)]
public class Gantt_ASP : System.Web.UI.WebControls.WebControl
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[ToolboxDataAttribute("<{0}:Gantt_ASP runat=server></{0}:Gantt_ASP>")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ParseChildrenAttribute(true)]
public __gc class Gantt_ASP : public System.Web.UI.WebControls.WebControl
C++/CLI
[ToolboxBitmapAttribute()]
[ToolboxDataAttribute("<{0}:Gantt_ASP runat=server></{0}:Gantt_ASP>")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ParseChildrenAttribute(true)]
public ref class Gantt_ASP : public System.Web.UI.WebControls.WebControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
PlexityHide.GTP.WEB.Gantt_ASP

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

Gantt_ASP Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
Gantt_ASP Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASP Class

Glossary Item Box

The following tables list the members exposed by Gantt_ASP.

Public Constructors

 | Name | Description
Public Constructor | Gantt_ASP Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Overridden. Backcolor is overriden and writes to the Gantt
Public Property | CacheTime | The time that generated images should stay in the page cache... How long should you wait for a user browser to send the request to load the images
static (Shared in Visual Basic) | ClientSideJavaScript_GanttRowClick | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_GanttRowClick(aID,RowId,x,y,button,continueWithPostBack) { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_GanttRowClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;)
static (Shared in Visual Basic) | ClientSideJavaScript_TimeItemClick | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemClick(aID,aClientTimeItem,button,continueWithPostBack { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_TimeItemClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;) aID is the ID of the Gantt_ASP that made the call aClientTimeItem has the property UserString, Start and Stop button holds information on mousebutton used
static (Shared in Visual Basic) | ClientSideJavaScript_TimeItemInit | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemInit(aID,aClientTimeItem,aImgElement) { // To add code here set the static field Gantt_ASP.ClientSideImp_TimeItemInit // Your code ends upp here } You might want to do elaborate tooltips by grabbing data from aClientTimeItem.UserString
Public Property | ClientSideTimeItemCreateMode | Set to true when allowing for client side TimeItemCreate. You must implement the Gantt_ASP.Gantt.OnTimeItem_AfterCreateByMouse event to actually catch the created time item The time item will be created in layer 0. If you want anything else just change the TimeItem in the OnTimeItem_AfterCreateByMouse event.
Public Property | ClientTimeItems | When set, client side scripts will allow for dragging time items, and time item resize. Aka as Ajax Gantt
Public Property | CurrentPage | The currently choosen and rendered page
Public Property | DefaultExpansionState | If you create GridNodes with expansionstate true, set this to true, otherwise false
Public Property | ExternalStyles | When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles.
Public Property | Font | Overridden. Font is taken out of circulation since the Gantt has it its own definition
Public Property | ForeColor | Overridden. ForeColor is taken out of circulation since the Gantt has it its own definition
Public Property | Gantt | Access to the underlaying Gantt object
Public Property | Height | Overridden. Height is overriden and writes to the Gantt
Public Property | HeightExtreme | The Height for a server side control is given in the Unit type. This type is limited to 32767 To overcome this restriction set HeightExtreme to a positive value that is your desired height in pixels.
Public Property | HideGrid | If you want to remove the grid from the gantt presentation all together use this. if you only want to hide certain columns use Gantt_ASP.Gantt.Grid.Columns[x].Hide=true;
Public Property | ImagePath | Path to where we should store temporary images that the control produces (design time images only)
Public Property | JPegQuality | UsePngImages=false means jpeg, adjust quality here; 100 is best, 1 is worst.
Public Property | MaxHeightOfInternalRenderingBitmap | When we render the png or jpeg images to constitute the GanttRows, we use an internal Bitmap. If your Gantt is very big (several thousand pixels high) you get large memory spikes when we allocate the drawing bitmap. You can limit the allowed height of that image by setting this property The Gantt_ASP will respect your limit and instead render smaller bitmaps after each other. This will be more time consuming, but you will avoid the memory spikes (that has proven to severly effect IIS stability).
Public Property | MouseButton_ClientSide | Holds the client side mouse button, this property is valid just before the OnTimeItem_ClientClick event is fired
Public Property | PagingLinksParagraphAttributes | Set this property to inject a style or layout attribute on the pagelinks paragraph. PageLinks is only shown when PagingUse=true. The default value for this property is align='center'.
Public Property | PagingPageSize | If PagingUse=true this value controls the pageSize (number of rows per page)
Public Property | PagingUse | Do you want to page the Gantt data over several pages and have page indices at the bottom of the Gantt
Public Property | PathToStaticImages | The path to get to the static images like plus and minus pngs in the tree and the GTPImg.aspx that is used to deliver images to the client. Default is "./"
Public Property | PercentToJump | Percent of current scale to jump on scroll, or pan in time
Public Property | RescalingButtonsVisible | RescalingButtonsVisible constrols if the Rescaling Buttons are visible or not
Public Property | StartTime | StartTime is saved in ViewState["StartTime"] and writes thru to Gantt.DateScaler
Public Property | StopTime | StopTime is saved in ViewState["StopTime"] and writes thru to Gantt.DateScaler
Public Property | StoreTemporaryImagesOnDisk | Field reports show that if you have large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To Work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.
Public Property | TemporaryImagesOnDiskPath | Field reports show that if you have a large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. This path should be expressed as a relative path from your application and you must enable the account running the ASP.NET read/write permission, you must also allow web access to files in this directory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.
Public Property | TreeExpandStatusInViewState | Should the expand status from the tree be kept in viewstate?
Public Property | UseColumnWidths | Use the defined column widths (fixed cells) or let content expand the grid. When this property is false the html grid will adapt to cell content and produce wider columns than designed like a html grid without width specifications.
Public Property | UseExpandedRowHeights | DEPRECATED Use the resulting row height or use 100%. If the grid content has wrapped and made the cell higher and you have set UseExpandedRowHeights=false you will get a gap above and belove the gantt row. If you set this property to true, the image that constitutes the GanttRow will be stretched to fill this space. This is now deprecated. To allow for wrapping result having other height on client than server has been proven impossible.
Public Property | UseHttpHandlerForImages | When this is true(default) a http handler will be used to deliver generated images. To get this working the config file need to declare a reference like this: system.webServer handlers add name="GetImage" verb="*" path="GetImage.ashx" type="PlexityHide.GTP.WEB.GetImage, PlexityHide.GTP.WEB" handlers system.webServer
Public Property | UseMetaFileToConserveMemoryUsageForLargeGantts | While rendering we create a temporary image the size of the gantt. If this property is false we use a Bitmap, but when producing really large Gantts that can give hard-to-handle large memory spikes (Widht*Height*3) (we have seen IIS choking from this). To avoid these spikes you can set this property to true and we will use a MetaFile instead. The problem with using a metafile is that it will require FullTrust from your IIS server since the MetaFile handling in .NET partly relies on unmanaged code.
Public Property | UsePngImages | The Gantt_ASP produces all images of type PNG, however JPEG are created faster, so set this to true to gain some speed (aprox 5%)
Public Property | Width | Overridden. Width is overriden and writes to the Gantt
static (Shared in Visual Basic) | ZIndexValueForDateScaler | This value is default 999, the DateScaler Scrollbuttons will get a Z-Index this value + 1 If you are doing stuff with popup menus you might want to tune this.
Top

Public Methods

Name | Description
Public Method | Dispose | Overridden.
Public Method | GanttRowFromKey | Returns a GanttRow from a string key
Public Method | GetExpandedStatusForGridNode | Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode
Public Method | GetSortColumn | SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To get the sort columnm and state programatically use this method.
Public Method | GetStyle | Returns a style name from a CellLayout
Public Method | GridNodeFromKey | Returns a GridNode from a string key
Public Method | GridNodeKey | Returns a GridNode string key
Public Method | IsExpandedStatusForGridNodeInitiated | Checks if the GridNodeStatus has been set for a gridnode
Public Method | NumberOfPages | The number of pages needed to display all the data given the current PagingPageSize
Public Method | RaisePostBackEvent | RaisePostBackEvent
Public Method | RegisterRuntimeKey | Call this in your page load to avoid the plexityHide logo: Gantt_ASP1.RegisterRuntimeKey("3787832873284832423" /*your runtime key*/,"CSGTPXXXXXXX" /*Your registration name*/); The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide logo marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand
Public Method | RenderBeginTag | Overridden. Overriden standard method
Public Method | RenderEndTag | Overridden. Overriden standard method
Public Method | RuntimeKeyHelp_Url | Call this to get hints on what values to put into the registration form to get the runtimekey...
Public Method | SetExpandedStatusForGridNode | Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode
Public Method | SetSortColumn | SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To set a sort columnm and state programatically use this method.
Public Method | TimeItemFromKey | Returns a TimeItem from a string key
Public Method | TimeItemKey | Returns a TimeItem string key
Public Method | ToHtmColor | Converts a color to a html color
Public Method | UpdateExternalStyles | When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles. Typical scenario for when to create to the css file: Gantt_ASP_Main.ExternalStyles=true; // You have decided to use external styles, this might be set in the object inspector already LoadMainProjectData(); // You fill the Gantt with data AND you probably create some CellLayouts format grid cells if (!File.Exists(Page.MapPath("GanttStyle.css"))) // If you have no need for dynamic styles, the file does not need to be written every time... Gantt_ASP_Main.UpdateExternalStyles(Page.MapPath("GanttStyle.css")); // This call reads the CellLayouts and create the css content, and saves the file.
Top

Public Events

 | Name | Description
Public Event | OnApplyViewState | Fired when view state should be applied to Gantt before rendering
Public Event | OnAreaAttributes | Fired when server compiles any active areas in the Gantt. This will let you add references to your own client side scripts etc.
Public Event | OnCellContentTuning | Fires when preparing the content for each grid cell. If you want to inject free html in your cell you can do it in this cell by going like e.Content = string.Format(" [image] {0}", e.Content);
Public Event | OnCellDivAttributesString | Fires when preparing the html for each grid cell. You can implement to inject div attributes on a cell. Can be used to implement tooltips or/and cell events.
Public Event | OnClientSideChangesApplied | Event is fired after client side changes has been applied (Ajax move and resize) This is a good place to update the database
Public Event | OnFontResizeEvent | The Gantt is rendered by windows forms. If you use MultiText in your cells row wrap will occure. Row wrap will make GanttRows higher(fatter). The text in the Gantt_ASP is normal html-text. If the html-text-font and the windows form font are not the same size (even if the have the same size set, they can be rendered differently), you may get the effect that the html-cell is to big for the html text (leaving white space), or to small; crowding the text. In this case we offer this event to provide a calculation factor; how much the fonts differ. You can set this factor to minimize the differences as much as possible.
Public Event | OnGanttRow_ClientClick | Fired on client click on GanttRow.
Public Event | OnGetResource | Fired when the component needs an url to an image held as a resource. Overide this to give your own sorting icons, or tree fold/unfold icons, or zoom buttons etc
Public Event | OnNode_ClientClick | Fired on client click on Tree expand/collapse
Public Event | OnNode_ClientClick_NodeKey | Fired on client click on Tree expand/collapse, this event is fired before viewstate has been applied, nodes may be resorted
Public Event | OnPostBackEvent | Fired when the postback event has been handled. This is a good place to override viewstate data that the user submitted, One application is to check that the StartTime and StopTime falls within your defined limits... If not set them to valid values in this event
Public Event | OnTimeItem_ClientClick | Fired on client click on time item
Public Event | OnTimeItemUserStringPrepare | Fired when server compiles ClientSide time items. If this event is implemented the string returned from it can later be accessed in ClientSide TimeItems property UserString. If this event is not implemented, but the TimeItem.UserReference != null, the value TimeItem.UserReference.ToString() will be put into the ClientSide TimeItem's UserString.
Top

See Also

Reference

Gantt_ASP Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASP Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Gantt_ASP Constructor

Glossary Item Box

Overload List

Overload | Description
Gantt_ASP Constructor() | Constructor
Gantt_ASP Constructor(HtmlTextWriterTag) | Constructor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASP Constructor()
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class > Gantt_ASP Constructor : Gantt_ASP Constructor()

Glossary Item Box

Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Gantt_ASP()
C#
public Gantt_ASP()
Managed Extensions for C++
public: Gantt_ASP();
C++/CLI
public:
Gantt_ASP();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASP Constructor(HtmlTextWriterTag)
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class > Gantt_ASP Constructor : Gantt_ASP Constructor(HtmlTextWriterTag)

tag

Glossary Item Box

Constructor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tag As HtmlTextWriterTag _
)
Visual Basic (Usage) Copy Code
Dim tag As HtmlTextWriterTag

Dim instance As New Gantt_ASP(tag)
C#
public Gantt_ASP(
   HtmlTextWriterTag tag
)
Managed Extensions for C++
public: Gantt_ASP(
   HtmlTextWriterTag tag
)
C++/CLI
public:
Gantt_ASP(
   HtmlTextWriterTag tag
)

Parameters

tag

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP.WEB
Gantt_ASP Class Methods
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASP Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASP members.

Public Methods

Name | Description
Public Method | Dispose | Overridden.
Public Method | GanttRowFromKey | Returns a GanttRow from a string key
Public Method | GetExpandedStatusForGridNode | Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode
Public Method | GetSortColumn | SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To get the sort columnm and state programatically use this method.
Public Method | GetStyle | Returns a style name from a CellLayout
Public Method | GridNodeFromKey | Returns a GridNode from a string key
Public Method | GridNodeKey | Returns a GridNode string key
Public Method | IsExpandedStatusForGridNodeInitiated | Checks if the GridNodeStatus has been set for a gridnode
Public Method | NumberOfPages | The number of pages needed to display all the data given the current PagingPageSize
Public Method | RaisePostBackEvent | RaisePostBackEvent
Public Method | RegisterRuntimeKey | Call this in your page load to avoid the plexityHide logo: Gantt_ASP1.RegisterRuntimeKey("3787832873284832423" /*your runtime key*/,"CSGTPXXXXXXX" /*Your registration name*/); The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide logo marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand
Public Method | RenderBeginTag | Overridden. Overriden standard method
Public Method | RenderEndTag | Overridden. Overriden standard method
Public Method | RuntimeKeyHelp_Url | Call this to get hints on what values to put into the registration form to get the runtimekey...
Public Method | SetExpandedStatusForGridNode | Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode
Public Method | SetSortColumn | SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To set a sort columnm and state programatically use this method.
Public Method | TimeItemFromKey | Returns a TimeItem from a string key
Public Method | TimeItemKey | Returns a TimeItem string key
Public Method | ToHtmColor | Converts a color to a html color
Public Method | UpdateExternalStyles | When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles. Typical scenario for when to create to the css file: Gantt_ASP_Main.ExternalStyles=true; // You have decided to use external styles, this might be set in the object inspector already LoadMainProjectData(); // You fill the Gantt with data AND you probably create some CellLayouts format grid cells if (!File.Exists(Page.MapPath("GanttStyle.css"))) // If you have no need for dynamic styles, the file does not need to be written every time... Gantt_ASP_Main.UpdateExternalStyles(Page.MapPath("GanttStyle.css")); // This call reads the CellLayouts and create the css content, and saves the file.
Top

See Also

Reference

Gantt_ASP Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Dispose Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP

instance.Dispose()
C#
public override void Dispose()
Managed Extensions for C++
public: void Dispose(); override
C++/CLI
public:
void Dispose(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GanttRowFromKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GanttRowFromKey Method

aGRKey

Glossary Item Box

Returns a GanttRow from a string key

Syntax

Visual Basic (Declaration)
Public Function GanttRowFromKey( _
   ByVal aGRKey As String _
) As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGRKey As String
Dim value As GanttRow

value = instance.GanttRowFromKey(aGRKey)
C#
public GanttRow GanttRowFromKey(
   string aGRKey
)
Managed Extensions for C++
public: GanttRow* GanttRowFromKey(
   string* aGRKey
)
C++/CLI
public:
GanttRow^ GanttRowFromKey(
   String^ aGRKey
)

Parameters

aGRKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetExpandedStatusForGridNode Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GetExpandedStatusForGridNode Method

aGridNode

Glossary Item Box

Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode

Syntax

Visual Basic (Declaration)
Public Function GetExpandedStatusForGridNode( _
   ByVal aGridNode As GridNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGridNode As GridNode
Dim value As Boolean

value = instance.GetExpandedStatusForGridNode(aGridNode)
C#
public bool GetExpandedStatusForGridNode(
   GridNode aGridNode
)
Managed Extensions for C++
public: bool GetExpandedStatusForGridNode(
   GridNode* aGridNode
)
C++/CLI
public:
bool GetExpandedStatusForGridNode(
   GridNode^ aGridNode
)

Parameters

aGridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetSortColumn Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GetSortColumn Method

decending
col

Glossary Item Box

SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To get the sort columnm and state programatically use this method.

Syntax

Visual Basic (Declaration)
Public Sub GetSortColumn( _
   ByRef decending As Boolean, _
   ByRef col As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim decending As Boolean
Dim col As Integer

instance.GetSortColumn(decending, col)
C#
public void GetSortColumn(
   out bool decending,
   out int col
)
Managed Extensions for C++
public: void GetSortColumn(
   [PARAMFLAG::Out] bool decending,
   [PARAMFLAG::Out] int col
)
C++/CLI
public:
void GetSortColumn(
   [Out] bool decending,
   [Out] int col
)

Parameters

decending
col

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetStyle Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GetStyle Method

cl
isHeaderClass
isOuter

Glossary Item Box

Returns a style name from a CellLayout

Syntax

Visual Basic (Declaration)
Public Function GetStyle( _
   ByVal cl As CellLayout, _
   ByVal isHeaderClass As Boolean, _
   ByVal isOuter As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim cl As CellLayout
Dim isHeaderClass As Boolean
Dim isOuter As Boolean
Dim value As String

value = instance.GetStyle(cl, isHeaderClass, isOuter)
C#
public string GetStyle(
   CellLayout cl,
   bool isHeaderClass,
   bool isOuter
)
Managed Extensions for C++
public: string* GetStyle(
   CellLayout* cl,
   bool isHeaderClass,
   bool isOuter
)
C++/CLI
public:
String^ GetStyle(
   CellLayout^ cl,
   bool isHeaderClass,
   bool isOuter
)

Parameters

cl
isHeaderClass
isOuter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GridNodeFromKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GridNodeFromKey Method

aGridNodeKey

Glossary Item Box

Returns a GridNode from a string key

Syntax

Visual Basic (Declaration)
Public Function GridNodeFromKey( _
   ByVal aGridNodeKey As String _
) As GridNode
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGridNodeKey As String
Dim value As GridNode

value = instance.GridNodeFromKey(aGridNodeKey)
C#
public GridNode GridNodeFromKey(
   string aGridNodeKey
)
Managed Extensions for C++
public: GridNode* GridNodeFromKey(
   string* aGridNodeKey
)
C++/CLI
public:
GridNode^ GridNodeFromKey(
   String^ aGridNodeKey
)

Parameters

aGridNodeKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GridNodeKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : GridNodeKey Method

aGridNode

Glossary Item Box

Returns a GridNode string key

Syntax

Visual Basic (Declaration)
Public Function GridNodeKey( _
   ByVal aGridNode As GridNode _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGridNode As GridNode
Dim value As String

value = instance.GridNodeKey(aGridNode)
C#
public string GridNodeKey(
   GridNode aGridNode
)
Managed Extensions for C++
public: string* GridNodeKey(
   GridNode* aGridNode
)
C++/CLI
public:
String^ GridNodeKey(
   GridNode^ aGridNode
)

Parameters

aGridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
IsExpandedStatusForGridNodeInitiated Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : IsExpandedStatusForGridNodeInitiated Method

aGridNode

Glossary Item Box

Checks if the GridNodeStatus has been set for a gridnode

Syntax

Visual Basic (Declaration)
Public Function IsExpandedStatusForGridNodeInitiated( _
   ByVal aGridNode As GridNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGridNode As GridNode
Dim value As Boolean

value = instance.IsExpandedStatusForGridNodeInitiated(aGridNode)
C#
public bool IsExpandedStatusForGridNodeInitiated(
   GridNode aGridNode
)
Managed Extensions for C++
public: bool IsExpandedStatusForGridNodeInitiated(
   GridNode* aGridNode
)
C++/CLI
public:
bool IsExpandedStatusForGridNodeInitiated(
   GridNode^ aGridNode
)

Parameters

aGridNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
NumberOfPages Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : NumberOfPages Method

Glossary Item Box

The number of pages needed to display all the data given the current PagingPageSize

Syntax

Visual Basic (Declaration)
Public Function NumberOfPages() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

value = instance.NumberOfPages()
C#
public int NumberOfPages()
Managed Extensions for C++
public: int NumberOfPages();
C++/CLI
public:
int NumberOfPages();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RaisePostBackEvent Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

RaisePostBackEvent

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim eventArgument As String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   string eventArgument
)
Managed Extensions for C++
public: void RaisePostBackEvent(
   string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   String^ eventArgument
)

Parameters

eventArgument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RegisterRuntimeKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RegisterRuntimeKey Method

runtimekey
registrationname

Glossary Item Box

Call this in your page load to avoid the plexityHide logo: Gantt_ASP1.RegisterRuntimeKey("3787832873284832423" /*your runtime key*/,"CSGTPXXXXXXX" /*Your registration name*/); The runtime key is free for registered users and is obtained as described at www.plexityhide.com/runtimekeys.htm The runtime key is unique per application, you can obtain as many runtime keys as you need. The runtime key is NOT a runtime license, registered users have the license, the runtime key only removes the runtime plexityHide logo marking. The main reasons for the introduction of runtime keys are: #1 To Better understand customer applications and demands to guide us in further development #2 To better track evaluation copies and important customer feedback #3 To Protect customer investments from unfair competition from pirates #4 Increase awareness of the plexityHide brand

Syntax

Visual Basic (Declaration)
Public Function RegisterRuntimeKey( _
   ByVal runtimekey As String, _
   ByVal registrationname As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim runtimekey As String
Dim registrationname As String
Dim value As Boolean

value = instance.RegisterRuntimeKey(runtimekey, registrationname)
C#
public bool RegisterRuntimeKey(
   string runtimekey,
   string registrationname
)
Managed Extensions for C++
public: bool RegisterRuntimeKey(
   string* runtimekey,
   string* registrationname
)
C++/CLI
public:
bool RegisterRuntimeKey(
   String^ runtimekey,
   String^ registrationname
)

Parameters

runtimekey
registrationname

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RenderBeginTag Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RenderBeginTag Method

writer

Glossary Item Box

Overriden standard method

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderBeginTag( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim writer As HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public override void RenderBeginTag(
   HtmlTextWriter writer
)
Managed Extensions for C++
public: void RenderBeginTag(
   HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderBeginTag(
   HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RenderEndTag Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RenderEndTag Method

writer

Glossary Item Box

Overriden standard method

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim writer As HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   HtmlTextWriter writer
)
Managed Extensions for C++
public: void RenderEndTag(
   HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RuntimeKeyHelp_Url Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RuntimeKeyHelp_Url Method

Glossary Item Box

Call this to get hints on what values to put into the registration form to get the runtimekey...

Syntax

Visual Basic (Declaration)
Public Function RuntimeKeyHelp_Url() As String()
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value() As String

value = instance.RuntimeKeyHelp_Url()
C#
public string[] RuntimeKeyHelp_Url()
Managed Extensions for C++
public: string*[]* RuntimeKeyHelp_Url();
C++/CLI
public:
array<String^>^ RuntimeKeyHelp_Url();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
SetExpandedStatusForGridNode Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : SetExpandedStatusForGridNode Method

aGridNode
aExpanded

Glossary Item Box

Expanded/Collapsed state is stored in ViewState. So in order to change the client view it is not enough to set the GridNode.Expanded state. You must instead use Gantt_ASP.Get/SetExpandedStatusForGridNode

Syntax

Visual Basic (Declaration)
Public Sub SetExpandedStatusForGridNode( _
   ByVal aGridNode As GridNode, _
   ByVal aExpanded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aGridNode As GridNode
Dim aExpanded As Boolean

instance.SetExpandedStatusForGridNode(aGridNode, aExpanded)
C#
public void SetExpandedStatusForGridNode(
   GridNode aGridNode,
   bool aExpanded
)
Managed Extensions for C++
public: void SetExpandedStatusForGridNode(
   GridNode* aGridNode,
   bool aExpanded
)
C++/CLI
public:
void SetExpandedStatusForGridNode(
   GridNode^ aGridNode,
   bool aExpanded
)

Parameters

aGridNode
aExpanded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
SetSortColumn Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : SetSortColumn Method

decending
col

Glossary Item Box

SortColumn and sort state (ascending, decending) is kept in viewstate between posts. To set a sort columnm and state programatically use this method.

Syntax

Visual Basic (Declaration)
Public Sub SetSortColumn( _
   ByVal decending As Boolean, _
   ByVal col As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim decending As Boolean
Dim col As Integer

instance.SetSortColumn(decending, col)
C#
public void SetSortColumn(
   bool decending,
   int col
)
Managed Extensions for C++
public: void SetSortColumn(
   bool decending,
   int col
)
C++/CLI
public:
void SetSortColumn(
   bool decending,
   int col
)

Parameters

decending
col

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TimeItemFromKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : TimeItemFromKey Method

aTimeItemKey

Glossary Item Box

Returns a TimeItem from a string key

Syntax

Visual Basic (Declaration)
Public Function TimeItemFromKey( _
   ByVal aTimeItemKey As String _
) As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aTimeItemKey As String
Dim value As TimeItem

value = instance.TimeItemFromKey(aTimeItemKey)
C#
public TimeItem TimeItemFromKey(
   string aTimeItemKey
)
Managed Extensions for C++
public: TimeItem* TimeItemFromKey(
   string* aTimeItemKey
)
C++/CLI
public:
TimeItem^ TimeItemFromKey(
   String^ aTimeItemKey
)

Parameters

aTimeItemKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TimeItemKey Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : TimeItemKey Method

aTimeItem

Glossary Item Box

Returns a TimeItem string key

Syntax

Visual Basic (Declaration)
Public Function TimeItemKey( _
   ByVal aTimeItem As TimeItem _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim aTimeItem As TimeItem
Dim value As String

value = instance.TimeItemKey(aTimeItem)
C#
public string TimeItemKey(
   TimeItem aTimeItem
)
Managed Extensions for C++
public: string* TimeItemKey(
   TimeItem* aTimeItem
)
C++/CLI
public:
String^ TimeItemKey(
   TimeItem^ aTimeItem
)

Parameters

aTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ToHtmColor Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ToHtmColor Method

color

Glossary Item Box

Converts a color to a html color

Syntax

Visual Basic (Declaration)
Public Function ToHtmColor( _
   ByVal color As Color _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim color As Color
Dim value As String

value = instance.ToHtmColor(color)
C#
public string ToHtmColor(
   Color color
)
Managed Extensions for C++
public: string* ToHtmColor(
   Color color
)
C++/CLI
public:
String^ ToHtmColor(
   Color color
)

Parameters

color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UpdateExternalStyles Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UpdateExternalStyles Method

filename

Glossary Item Box

When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles. Typical scenario for when to create to the css file: Gantt_ASP_Main.ExternalStyles=true; // You have decided to use external styles, this might be set in the object inspector already LoadMainProjectData(); // You fill the Gantt with data AND you probably create some CellLayouts format grid cells if (!File.Exists(Page.MapPath("GanttStyle.css"))) // If you have no need for dynamic styles, the file does not need to be written every time... Gantt_ASP_Main.UpdateExternalStyles(Page.MapPath("GanttStyle.css")); // This call reads the CellLayouts and create the css content, and saves the file.

Syntax

Visual Basic (Declaration)
Public Sub UpdateExternalStyles( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim filename As String

instance.UpdateExternalStyles(filename)
C#
public void UpdateExternalStyles(
   string filename
)
Managed Extensions for C++
public: void UpdateExternalStyles(
   string* filename
)
C++/CLI
public:
void UpdateExternalStyles(
   String^ filename
)

Parameters

filename

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP.WEB
Gantt_ASP Class Properties
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASP Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASP members.

Public Properties

 | Name | Description
Public Property | BackColor | Overridden. Backcolor is overriden and writes to the Gantt
Public Property | CacheTime | The time that generated images should stay in the page cache... How long should you wait for a user browser to send the request to load the images
static (Shared in Visual Basic) | ClientSideJavaScript_GanttRowClick | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_GanttRowClick(aID,RowId,x,y,button,continueWithPostBack) { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_GanttRowClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;)
static (Shared in Visual Basic) | ClientSideJavaScript_TimeItemClick | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemClick(aID,aClientTimeItem,button,continueWithPostBack { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_TimeItemClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;) aID is the ID of the Gantt_ASP that made the call aClientTimeItem has the property UserString, Start and Stop button holds information on mousebutton used
static (Shared in Visual Basic) | ClientSideJavaScript_TimeItemInit | In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemInit(aID,aClientTimeItem,aImgElement) { // To add code here set the static field Gantt_ASP.ClientSideImp_TimeItemInit // Your code ends upp here } You might want to do elaborate tooltips by grabbing data from aClientTimeItem.UserString
Public Property | ClientSideTimeItemCreateMode | Set to true when allowing for client side TimeItemCreate. You must implement the Gantt_ASP.Gantt.OnTimeItem_AfterCreateByMouse event to actually catch the created time item The time item will be created in layer 0. If you want anything else just change the TimeItem in the OnTimeItem_AfterCreateByMouse event.
Public Property | ClientTimeItems | When set, client side scripts will allow for dragging time items, and time item resize. Aka as Ajax Gantt
Public Property | CurrentPage | The currently choosen and rendered page
Public Property | DefaultExpansionState | If you create GridNodes with expansionstate true, set this to true, otherwise false
Public Property | ExternalStyles | When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles.
Public Property | Font | Overridden. Font is taken out of circulation since the Gantt has it its own definition
Public Property | ForeColor | Overridden. ForeColor is taken out of circulation since the Gantt has it its own definition
Public Property | Gantt | Access to the underlaying Gantt object
Public Property | Height | Overridden. Height is overriden and writes to the Gantt
Public Property | HeightExtreme | The Height for a server side control is given in the Unit type. This type is limited to 32767 To overcome this restriction set HeightExtreme to a positive value that is your desired height in pixels.
Public Property | HideGrid | If you want to remove the grid from the gantt presentation all together use this. if you only want to hide certain columns use Gantt_ASP.Gantt.Grid.Columns[x].Hide=true;
Public Property | ImagePath | Path to where we should store temporary images that the control produces (design time images only)
Public Property | JPegQuality | UsePngImages=false means jpeg, adjust quality here; 100 is best, 1 is worst.
Public Property | MaxHeightOfInternalRenderingBitmap | When we render the png or jpeg images to constitute the GanttRows, we use an internal Bitmap. If your Gantt is very big (several thousand pixels high) you get large memory spikes when we allocate the drawing bitmap. You can limit the allowed height of that image by setting this property The Gantt_ASP will respect your limit and instead render smaller bitmaps after each other. This will be more time consuming, but you will avoid the memory spikes (that has proven to severly effect IIS stability).
Public Property | MouseButton_ClientSide | Holds the client side mouse button, this property is valid just before the OnTimeItem_ClientClick event is fired
Public Property | PagingLinksParagraphAttributes | Set this property to inject a style or layout attribute on the pagelinks paragraph. PageLinks is only shown when PagingUse=true. The default value for this property is align='center'.
Public Property | PagingPageSize | If PagingUse=true this value controls the pageSize (number of rows per page)
Public Property | PagingUse | Do you want to page the Gantt data over several pages and have page indices at the bottom of the Gantt
Public Property | PathToStaticImages | The path to get to the static images like plus and minus pngs in the tree and the GTPImg.aspx that is used to deliver images to the client. Default is "./"
Public Property | PercentToJump | Percent of current scale to jump on scroll, or pan in time
Public Property | RescalingButtonsVisible | RescalingButtonsVisible constrols if the Rescaling Buttons are visible or not
Public Property | StartTime | StartTime is saved in ViewState["StartTime"] and writes thru to Gantt.DateScaler
Public Property | StopTime | StopTime is saved in ViewState["StopTime"] and writes thru to Gantt.DateScaler
Public Property | StoreTemporaryImagesOnDisk | Field reports show that if you have large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To Work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.
Public Property | TemporaryImagesOnDiskPath | Field reports show that if you have a large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. This path should be expressed as a relative path from your application and you must enable the account running the ASP.NET read/write permission, you must also allow web access to files in this directory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.
Public Property | TreeExpandStatusInViewState | Should the expand status from the tree be kept in viewstate?
Public Property | UseColumnWidths | Use the defined column widths (fixed cells) or let content expand the grid. When this property is false the html grid will adapt to cell content and produce wider columns than designed like a html grid without width specifications.
Public Property | UseExpandedRowHeights | DEPRECATED Use the resulting row height or use 100%. If the grid content has wrapped and made the cell higher and you have set UseExpandedRowHeights=false you will get a gap above and belove the gantt row. If you set this property to true, the image that constitutes the GanttRow will be stretched to fill this space. This is now deprecated. To allow for wrapping result having other height on client than server has been proven impossible.
Public Property | UseHttpHandlerForImages | When this is true(default) a http handler will be used to deliver generated images. To get this working the config file need to declare a reference like this: system.webServer handlers add name="GetImage" verb="*" path="GetImage.ashx" type="PlexityHide.GTP.WEB.GetImage, PlexityHide.GTP.WEB" handlers system.webServer
Public Property | UseMetaFileToConserveMemoryUsageForLargeGantts | While rendering we create a temporary image the size of the gantt. If this property is false we use a Bitmap, but when producing really large Gantts that can give hard-to-handle large memory spikes (Widht*Height*3) (we have seen IIS choking from this). To avoid these spikes you can set this property to true and we will use a MetaFile instead. The problem with using a metafile is that it will require FullTrust from your IIS server since the MetaFile handling in .NET partly relies on unmanaged code.
Public Property | UsePngImages | The Gantt_ASP produces all images of type PNG, however JPEG are created faster, so set this to true to gain some speed (aprox 5%)
Public Property | Width | Overridden. Width is overriden and writes to the Gantt
static (Shared in Visual Basic) | ZIndexValueForDateScaler | This value is default 999, the DateScaler Scrollbuttons will get a Z-Index this value + 1 If you are doing stuff with popup menus you might want to tune this.
Top

See Also

Reference

Gantt_ASP Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
BackColor Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : BackColor Property

Glossary Item Box

Backcolor is overriden and writes to the Gantt

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP

instance.BackColor = value
C#
public override Color BackColor {set;}
Managed Extensions for C++
public: __property void set_BackColor(
   Color value
) override;
C++/CLI
public:
property Color BackColor {
   void set (    Color value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CacheTime Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : CacheTime Property

Glossary Item Box

The time that generated images should stay in the page cache... How long should you wait for a user browser to send the request to load the images

Syntax

Visual Basic (Declaration)
Public Property CacheTime As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As TimeSpan

instance.CacheTime = value

value = instance.CacheTime
C#
public TimeSpan CacheTime {get; set;}
Managed Extensions for C++
public: __property TimeSpan get_CacheTime();
public: __property void set_CacheTime(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan CacheTime {
   TimeSpan get();
   void set (    TimeSpan value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientSideJavaScript_GanttRowClick Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ClientSideJavaScript_GanttRowClick Property

Glossary Item Box

In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_GanttRowClick(aID,RowId,x,y,button,continueWithPostBack) { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_GanttRowClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;)

Syntax

Visual Basic (Declaration)
Public Shared Property ClientSideJavaScript_GanttRowClick As String
Visual Basic (Usage) Copy Code
Dim value As String

Gantt_ASP.ClientSideJavaScript_GanttRowClick = value

value = Gantt_ASP.ClientSideJavaScript_GanttRowClick
C#
public static string ClientSideJavaScript_GanttRowClick {get; set;}
Managed Extensions for C++
public: __property static string* get_ClientSideJavaScript_GanttRowClick();
public: __property static void set_ClientSideJavaScript_GanttRowClick(
   string* value
);
C++/CLI
public:
static property String^ ClientSideJavaScript_GanttRowClick {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientSideJavaScript_TimeItemClick Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ClientSideJavaScript_TimeItemClick Property

Glossary Item Box

In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemClick(aID,aClientTimeItem,button,continueWithPostBack { // To add code here set the static field Gantt_ASP.ClientSideJavaScript_TimeItemClick // Your code ends up here return continueWithPostBack; } You might want to pop up a window, and if you might want to supress the postback (add continueWithPostBack=false;) aID is the ID of the Gantt_ASP that made the call aClientTimeItem has the property UserString, Start and Stop button holds information on mousebutton used

Syntax

Visual Basic (Declaration)
Public Shared Property ClientSideJavaScript_TimeItemClick As String
Visual Basic (Usage) Copy Code
Dim value As String

Gantt_ASP.ClientSideJavaScript_TimeItemClick = value

value = Gantt_ASP.ClientSideJavaScript_TimeItemClick
C#
public static string ClientSideJavaScript_TimeItemClick {get; set;}
Managed Extensions for C++
public: __property static string* get_ClientSideJavaScript_TimeItemClick();
public: __property static void set_ClientSideJavaScript_TimeItemClick(
   string* value
);
C++/CLI
public:
static property String^ ClientSideJavaScript_TimeItemClick {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientSideJavaScript_TimeItemInit Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ClientSideJavaScript_TimeItemInit Property

Glossary Item Box

In this property you can add multiple rows of valid JavaScript code, this code will be injected into a function that looks like this: function Gantt_ASPClientSideImp_TimeItemInit(aID,aClientTimeItem,aImgElement) { // To add code here set the static field Gantt_ASP.ClientSideImp_TimeItemInit // Your code ends upp here } You might want to do elaborate tooltips by grabbing data from aClientTimeItem.UserString

Syntax

Visual Basic (Declaration)
Public Shared Property ClientSideJavaScript_TimeItemInit As String
Visual Basic (Usage) Copy Code
Dim value As String

Gantt_ASP.ClientSideJavaScript_TimeItemInit = value

value = Gantt_ASP.ClientSideJavaScript_TimeItemInit
C#
public static string ClientSideJavaScript_TimeItemInit {get; set;}
Managed Extensions for C++
public: __property static string* get_ClientSideJavaScript_TimeItemInit();
public: __property static void set_ClientSideJavaScript_TimeItemInit(
   string* value
);
C++/CLI
public:
static property String^ ClientSideJavaScript_TimeItemInit {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientSideTimeItemCreateMode Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ClientSideTimeItemCreateMode Property

Glossary Item Box

Set to true when allowing for client side TimeItemCreate. You must implement the Gantt_ASP.Gantt.OnTimeItem_AfterCreateByMouse event to actually catch the created time item The time item will be created in layer 0. If you want anything else just change the TimeItem in the OnTimeItem_AfterCreateByMouse event.

Syntax

Visual Basic (Declaration)
Public Property ClientSideTimeItemCreateMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.ClientSideTimeItemCreateMode = value

value = instance.ClientSideTimeItemCreateMode
C#
public bool ClientSideTimeItemCreateMode {get; set;}
Managed Extensions for C++
public: __property bool get_ClientSideTimeItemCreateMode();
public: __property void set_ClientSideTimeItemCreateMode(
   bool value
);
C++/CLI
public:
property bool ClientSideTimeItemCreateMode {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientTimeItems Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ClientTimeItems Property

Glossary Item Box

When set, client side scripts will allow for dragging time items, and time item resize. Aka as Ajax Gantt

Syntax

Visual Basic (Declaration)
Public Property ClientTimeItems As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.ClientTimeItems = value

value = instance.ClientTimeItems
C#
public bool ClientTimeItems {get; set;}
Managed Extensions for C++
public: __property bool get_ClientTimeItems();
public: __property void set_ClientTimeItems(
   bool value
);
C++/CLI
public:
property bool ClientTimeItems {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CurrentPage Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : CurrentPage Property

Glossary Item Box

The currently choosen and rendered page

Syntax

Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
public int CurrentPage {get; set;}
Managed Extensions for C++
public: __property int get_CurrentPage();
public: __property void set_CurrentPage(
   int value
);
C++/CLI
public:
property int CurrentPage {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
DefaultExpansionState Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : DefaultExpansionState Property

Glossary Item Box

If you create GridNodes with expansionstate true, set this to true, otherwise false

Syntax

Visual Basic (Declaration)
Public Property DefaultExpansionState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.DefaultExpansionState = value

value = instance.DefaultExpansionState
C#
public bool DefaultExpansionState {get; set;}
Managed Extensions for C++
public: __property bool get_DefaultExpansionState();
public: __property void set_DefaultExpansionState(
   bool value
);
C++/CLI
public:
property bool DefaultExpansionState {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ExternalStyles Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ExternalStyles Property

Glossary Item Box

When setting ExternalStyles to true the css stylesheet is NOT embedded into the rendered html. Intstead you must add an attribute to the head section like this: You will also need to create the theganttstyles.css and you can do this by calling UpdateExternalStyles with the file name of your choice. If you leave ExternalStyles to false (default) you do not need this, but on the other hand ajax does not update the head section so under certain circumstances you can run into troubles using embedded styles.

Syntax

Visual Basic (Declaration)
Public Property ExternalStyles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.ExternalStyles = value

value = instance.ExternalStyles
C#
public bool ExternalStyles {get; set;}
Managed Extensions for C++
public: __property bool get_ExternalStyles();
public: __property void set_ExternalStyles(
   bool value
);
C++/CLI
public:
property bool ExternalStyles {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Font Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Font Property

Glossary Item Box

Font is taken out of circulation since the Gantt has it its own definition

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Font As FontInfo
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As FontInfo

value = instance.Font
C#
[BrowsableAttribute(false)]
public override FontInfo Font {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property FontInfo* get_Font() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property FontInfo^ Font {
   FontInfo^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ForeColor Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ForeColor Property

Glossary Item Box

ForeColor is taken out of circulation since the Gantt has it its own definition

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[BrowsableAttribute(false)]
public override Color ForeColor {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property Color ForeColor {
   Color get() override;
   void set (    Color value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Gantt Property

Glossary Item Box

Access to the underlaying Gantt object

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Gantt As Gantt
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Gantt

value = instance.Gantt
C#
[BrowsableAttribute(false)]
public Gantt Gantt {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Gantt* get_Gantt();
C++/CLI
[BrowsableAttribute(false)]
public:
property Gantt^ Gantt {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Height Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Height Property

Glossary Item Box

Height is overriden and writes to the Gantt

Syntax

Visual Basic (Declaration)
Public Overrides Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public override Unit Height {get; set;}
Managed Extensions for C++
public: __property Unit get_Height() override;
public: __property void set_Height(
   Unit value
) override;
C++/CLI
public:
property Unit Height {
   Unit get() override;
   void set (    Unit value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
HeightExtreme Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : HeightExtreme Property

Glossary Item Box

The Height for a server side control is given in the Unit type. This type is limited to 32767 To overcome this restriction set HeightExtreme to a positive value that is your desired height in pixels.

Syntax

Visual Basic (Declaration)
Public Property HeightExtreme As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

instance.HeightExtreme = value

value = instance.HeightExtreme
C#
public int HeightExtreme {get; set;}
Managed Extensions for C++
public: __property int get_HeightExtreme();
public: __property void set_HeightExtreme(
   int value
);
C++/CLI
public:
property int HeightExtreme {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
HideGrid Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : HideGrid Property

Glossary Item Box

If you want to remove the grid from the gantt presentation all together use this. if you only want to hide certain columns use Gantt_ASP.Gantt.Grid.Columns[x].Hide=true;

Syntax

Visual Basic (Declaration)
Public Property HideGrid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.HideGrid = value

value = instance.HideGrid
C#
public bool HideGrid {get; set;}
Managed Extensions for C++
public: __property bool get_HideGrid();
public: __property void set_HideGrid(
   bool value
);
C++/CLI
public:
property bool HideGrid {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ImagePath Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ImagePath Property

Glossary Item Box

Path to where we should store temporary images that the control produces (design time images only)

Syntax

Visual Basic (Declaration)
Public Property ImagePath As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
C#
public string ImagePath {get; set;}
Managed Extensions for C++
public: __property string* get_ImagePath();
public: __property void set_ImagePath(
   string* value
);
C++/CLI
public:
property String^ ImagePath {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
JPegQuality Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : JPegQuality Property

Glossary Item Box

UsePngImages=false means jpeg, adjust quality here; 100 is best, 1 is worst.

Syntax

Visual Basic (Declaration)
Public Property JPegQuality As Long
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Long

instance.JPegQuality = value

value = instance.JPegQuality
C#
public long JPegQuality {get; set;}
Managed Extensions for C++
public: __property long get_JPegQuality();
public: __property void set_JPegQuality(
   long value
);
C++/CLI
public:
property int64 JPegQuality {
   int64 get();
   void set (    int64 value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
MaxHeightOfInternalRenderingBitmap Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : MaxHeightOfInternalRenderingBitmap Property

Glossary Item Box

When we render the png or jpeg images to constitute the GanttRows, we use an internal Bitmap. If your Gantt is very big (several thousand pixels high) you get large memory spikes when we allocate the drawing bitmap. You can limit the allowed height of that image by setting this property The Gantt_ASP will respect your limit and instead render smaller bitmaps after each other. This will be more time consuming, but you will avoid the memory spikes (that has proven to severly effect IIS stability).

Syntax

Visual Basic (Declaration)
Public Property MaxHeightOfInternalRenderingBitmap As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

instance.MaxHeightOfInternalRenderingBitmap = value

value = instance.MaxHeightOfInternalRenderingBitmap
C#
public int MaxHeightOfInternalRenderingBitmap {get; set;}
Managed Extensions for C++
public: __property int get_MaxHeightOfInternalRenderingBitmap();
public: __property void set_MaxHeightOfInternalRenderingBitmap(
   int value
);
C++/CLI
public:
property int MaxHeightOfInternalRenderingBitmap {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
MouseButton_ClientSide Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : MouseButton_ClientSide Property

Glossary Item Box

Holds the client side mouse button, this property is valid just before the OnTimeItem_ClientClick event is fired

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseButton_ClientSide As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

value = instance.MouseButton_ClientSide
C#
public int MouseButton_ClientSide {get;}
Managed Extensions for C++
public: __property int get_MouseButton_ClientSide();
C++/CLI
public:
property int MouseButton_ClientSide {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
PagingLinksParagraphAttributes Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : PagingLinksParagraphAttributes Property

Glossary Item Box

Set this property to inject a style or layout attribute on the pagelinks paragraph. PageLinks is only shown when PagingUse=true. The default value for this property is align='center'.

Syntax

Visual Basic (Declaration)
Public Property PagingLinksParagraphAttributes As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As String

instance.PagingLinksParagraphAttributes = value

value = instance.PagingLinksParagraphAttributes
C#
public string PagingLinksParagraphAttributes {get; set;}
Managed Extensions for C++
public: __property string* get_PagingLinksParagraphAttributes();
public: __property void set_PagingLinksParagraphAttributes(
   string* value
);
C++/CLI
public:
property String^ PagingLinksParagraphAttributes {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
PagingPageSize Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : PagingPageSize Property

Glossary Item Box

If PagingUse=true this value controls the pageSize (number of rows per page)

Syntax

Visual Basic (Declaration)
Public Property PagingPageSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Integer

instance.PagingPageSize = value

value = instance.PagingPageSize
C#
public int PagingPageSize {get; set;}
Managed Extensions for C++
public: __property int get_PagingPageSize();
public: __property void set_PagingPageSize(
   int value
);
C++/CLI
public:
property int PagingPageSize {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members
PagingUse Property


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
PagingUse Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : PagingUse Property

Glossary Item Box

Do you want to page the Gantt data over several pages and have page indices at the bottom of the Gantt

Syntax

Visual Basic (Declaration)
Public Property PagingUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.PagingUse = value

value = instance.PagingUse
C#
public bool PagingUse {get; set;}
Managed Extensions for C++
public: __property bool get_PagingUse();
public: __property void set_PagingUse(
   bool value
);
C++/CLI
public:
property bool PagingUse {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
PathToStaticImages Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : PathToStaticImages Property

Glossary Item Box

The path to get to the static images like plus and minus pngs in the tree and the GTPImg.aspx that is used to deliver images to the client. Default is "./"

Syntax

Visual Basic (Declaration)
Public Property PathToStaticImages As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As String

instance.PathToStaticImages = value

value = instance.PathToStaticImages
C#
public string PathToStaticImages {get; set;}
Managed Extensions for C++
public: __property string* get_PathToStaticImages();
public: __property void set_PathToStaticImages(
   string* value
);
C++/CLI
public:
property String^ PathToStaticImages {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
PercentToJump Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : PercentToJump Property

Glossary Item Box

Percent of current scale to jump on scroll, or pan in time

Syntax

Visual Basic (Declaration)
Public Property PercentToJump As Double
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Double

instance.PercentToJump = value

value = instance.PercentToJump
C#
public double PercentToJump {get; set;}
Managed Extensions for C++
public: __property double get_PercentToJump();
public: __property void set_PercentToJump(
   double value
);
C++/CLI
public:
property double PercentToJump {
   double get();
   void set (    double value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
RescalingButtonsVisible Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : RescalingButtonsVisible Property

Glossary Item Box

RescalingButtonsVisible constrols if the Rescaling Buttons are visible or not

Syntax

Visual Basic (Declaration)
Public Property RescalingButtonsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.RescalingButtonsVisible = value

value = instance.RescalingButtonsVisible
C#
public bool RescalingButtonsVisible {get; set;}
Managed Extensions for C++
public: __property bool get_RescalingButtonsVisible();
public: __property void set_RescalingButtonsVisible(
   bool value
);
C++/CLI
public:
property bool RescalingButtonsVisible {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
StartTime Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : StartTime Property

Glossary Item Box

StartTime is saved in ViewState["StartTime"] and writes thru to Gantt.DateScaler

Syntax

Visual Basic (Declaration)
Public Property StartTime As Date
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Date

instance.StartTime = value

value = instance.StartTime
C#
public DateTime StartTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StartTime();
public: __property void set_StartTime(
   DateTime value
);
C++/CLI
public:
property DateTime StartTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
StopTime Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : StopTime Property

Glossary Item Box

StopTime is saved in ViewState["StopTime"] and writes thru to Gantt.DateScaler

Syntax

Visual Basic (Declaration)
Public Property StopTime As Date
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Date

instance.StopTime = value

value = instance.StopTime
C#
public DateTime StopTime {get; set;}
Managed Extensions for C++
public: __property DateTime get_StopTime();
public: __property void set_StopTime(
   DateTime value
);
C++/CLI
public:
property DateTime StopTime {
   DateTime get();
   void set (    DateTime value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
StoreTemporaryImagesOnDisk Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : StoreTemporaryImagesOnDisk Property

Glossary Item Box

Field reports show that if you have large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To Work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.

Syntax

Visual Basic (Declaration)
Public Property StoreTemporaryImagesOnDisk As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.StoreTemporaryImagesOnDisk = value

value = instance.StoreTemporaryImagesOnDisk
C#
public bool StoreTemporaryImagesOnDisk {get; set;}
Managed Extensions for C++
public: __property bool get_StoreTemporaryImagesOnDisk();
public: __property void set_StoreTemporaryImagesOnDisk(
   bool value
);
C++/CLI
public:
property bool StoreTemporaryImagesOnDisk {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TemporaryImagesOnDiskPath Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : TemporaryImagesOnDiskPath Property

Glossary Item Box

Field reports show that if you have a large, heavy Gantt chart you may bring IIS down due to memory consumption in the IIS cache. To work around this problem you may want to store the temporary images on disk instead. This will probably be slower, but it will bind less IIS memory. This path should be expressed as a relative path from your application and you must enable the account running the ASP.NET read/write permission, you must also allow web access to files in this directory. When this option is in use (StoreTemporaryImagesOnDisk=TRUE) the GTPImg.aspx page can be omitted.

Syntax

Visual Basic (Declaration)
Public Property TemporaryImagesOnDiskPath As String
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As String

instance.TemporaryImagesOnDiskPath = value

value = instance.TemporaryImagesOnDiskPath
C#
public string TemporaryImagesOnDiskPath {get; set;}
Managed Extensions for C++
public: __property string* get_TemporaryImagesOnDiskPath();
public: __property void set_TemporaryImagesOnDiskPath(
   string* value
);
C++/CLI
public:
property String^ TemporaryImagesOnDiskPath {
   String^ get();
   void set (    String^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TreeExpandStatusInViewState Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : TreeExpandStatusInViewState Property

Glossary Item Box

Should the expand status from the tree be kept in viewstate?

Syntax

Visual Basic (Declaration)
Public Property TreeExpandStatusInViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.TreeExpandStatusInViewState = value

value = instance.TreeExpandStatusInViewState
C#
public bool TreeExpandStatusInViewState {get; set;}
Managed Extensions for C++
public: __property bool get_TreeExpandStatusInViewState();
public: __property void set_TreeExpandStatusInViewState(
   bool value
);
C++/CLI
public:
property bool TreeExpandStatusInViewState {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UseColumnWidths Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UseColumnWidths Property

Glossary Item Box

Use the defined column widths (fixed cells) or let content expand the grid. When this property is false the html grid will adapt to cell content and produce wider columns than designed like a html grid without width specifications.

Syntax

Visual Basic (Declaration)
Public Property UseColumnWidths As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.UseColumnWidths = value

value = instance.UseColumnWidths
C#
public bool UseColumnWidths {get; set;}
Managed Extensions for C++
public: __property bool get_UseColumnWidths();
public: __property void set_UseColumnWidths(
   bool value
);
C++/CLI
public:
property bool UseColumnWidths {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UseExpandedRowHeights Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UseExpandedRowHeights Property

Glossary Item Box

DEPRECATED Use the resulting row height or use 100%. If the grid content has wrapped and made the cell higher and you have set UseExpandedRowHeights=false you will get a gap above and belove the gantt row. If you set this property to true, the image that constitutes the GanttRow will be stretched to fill this space. This is now deprecated. To allow for wrapping result having other height on client than server has been proven impossible.

Syntax

Visual Basic (Declaration)
Public Property UseExpandedRowHeights As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.UseExpandedRowHeights = value

value = instance.UseExpandedRowHeights
C#
public bool UseExpandedRowHeights {get; set;}
Managed Extensions for C++
public: __property bool get_UseExpandedRowHeights();
public: __property void set_UseExpandedRowHeights(
   bool value
);
C++/CLI
public:
property bool UseExpandedRowHeights {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UseHttpHandlerForImages Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UseHttpHandlerForImages Property

Glossary Item Box

When this is true(default) a http handler will be used to deliver generated images. To get this working the config file need to declare a reference like this: system.webServer handlers add name="GetImage" verb="*" path="GetImage.ashx" type="PlexityHide.GTP.WEB.GetImage, PlexityHide.GTP.WEB" handlers system.webServer

Syntax

Visual Basic (Declaration)
Public Property UseHttpHandlerForImages As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.UseHttpHandlerForImages = value

value = instance.UseHttpHandlerForImages
C#
public bool UseHttpHandlerForImages {get; set;}
Managed Extensions for C++
public: __property bool get_UseHttpHandlerForImages();
public: __property void set_UseHttpHandlerForImages(
   bool value
);
C++/CLI
public:
property bool UseHttpHandlerForImages {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UseMetaFileToConserveMemoryUsageForLargeGantts Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UseMetaFileToConserveMemoryUsageForLargeGantts Property

Glossary Item Box

While rendering we create a temporary image the size of the gantt. If this property is false we use a Bitmap, but when producing really large Gantts that can give hard-to-handle large memory spikes (Widht*Height*3) (we have seen IIS choking from this). To avoid these spikes you can set this property to true and we will use a MetaFile instead. The problem with using a metafile is that it will require FullTrust from your IIS server since the MetaFile handling in .NET partly relies on unmanaged code.

Syntax

Visual Basic (Declaration)
Public Property UseMetaFileToConserveMemoryUsageForLargeGantts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.UseMetaFileToConserveMemoryUsageForLargeGantts = value

value = instance.UseMetaFileToConserveMemoryUsageForLargeGantts
C#
public bool UseMetaFileToConserveMemoryUsageForLargeGantts {get; set;}
Managed Extensions for C++
public: __property bool get_UseMetaFileToConserveMemoryUsageForLargeGantts();
public: __property void set_UseMetaFileToConserveMemoryUsageForLargeGantts(
   bool value
);
C++/CLI
public:
property bool UseMetaFileToConserveMemoryUsageForLargeGantts {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
UsePngImages Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : UsePngImages Property

Glossary Item Box

The Gantt_ASP produces all images of type PNG, however JPEG are created faster, so set this to true to gain some speed (aprox 5%)

Syntax

Visual Basic (Declaration)
Public Property UsePngImages As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Boolean

instance.UsePngImages = value

value = instance.UsePngImages
C#
public bool UsePngImages {get; set;}
Managed Extensions for C++
public: __property bool get_UsePngImages();
public: __property void set_UsePngImages(
   bool value
);
C++/CLI
public:
property bool UsePngImages {
   bool get();
   void set (    bool value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Width Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : Width Property

Glossary Item Box

Width is overriden and writes to the Gantt

Syntax

Visual Basic (Declaration)
Public Overrides Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public override Unit Width {get; set;}
Managed Extensions for C++
public: __property Unit get_Width() override;
public: __property void set_Width(
   Unit value
) override;
C++/CLI
public:
property Unit Width {
   Unit get() override;
   void set (    Unit value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ZIndexValueForDateScaler Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : ZIndexValueForDateScaler Property

Glossary Item Box

This value is default 999, the DateScaler Scrollbuttons will get a Z-Index this value + 1 If you are doing stuff with popup menus you might want to tune this.

Syntax

Visual Basic (Declaration)
Public Shared Property ZIndexValueForDateScaler As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

Gantt_ASP.ZIndexValueForDateScaler = value

value = Gantt_ASP.ZIndexValueForDateScaler
C#
public static int ZIndexValueForDateScaler {get; set;}
Managed Extensions for C++
public: __property static int get_ZIndexValueForDateScaler();
public: __property static void set_ZIndexValueForDateScaler(
   int value
);
C++/CLI
public:
static property int ZIndexValueForDateScaler {
   int get();
   void set (    int value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP.WEB
Gantt_ASP Class Events
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASP Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASP members.

Public Events

 | Name | Description
Public Event | OnApplyViewState | Fired when view state should be applied to Gantt before rendering
Public Event | OnAreaAttributes | Fired when server compiles any active areas in the Gantt. This will let you add references to your own client side scripts etc.
Public Event | OnCellContentTuning | Fires when preparing the content for each grid cell. If you want to inject free html in your cell you can do it in this cell by going like e.Content = string.Format(" [image] {0}", e.Content);
Public Event | OnCellDivAttributesString | Fires when preparing the html for each grid cell. You can implement to inject div attributes on a cell. Can be used to implement tooltips or/and cell events.
Public Event | OnClientSideChangesApplied | Event is fired after client side changes has been applied (Ajax move and resize) This is a good place to update the database
Public Event | OnFontResizeEvent | The Gantt is rendered by windows forms. If you use MultiText in your cells row wrap will occure. Row wrap will make GanttRows higher(fatter). The text in the Gantt_ASP is normal html-text. If the html-text-font and the windows form font are not the same size (even if the have the same size set, they can be rendered differently), you may get the effect that the html-cell is to big for the html text (leaving white space), or to small; crowding the text. In this case we offer this event to provide a calculation factor; how much the fonts differ. You can set this factor to minimize the differences as much as possible.
Public Event | OnGanttRow_ClientClick | Fired on client click on GanttRow.
Public Event | OnGetResource | Fired when the component needs an url to an image held as a resource. Overide this to give your own sorting icons, or tree fold/unfold icons, or zoom buttons etc
Public Event | OnNode_ClientClick | Fired on client click on Tree expand/collapse
Public Event | OnNode_ClientClick_NodeKey | Fired on client click on Tree expand/collapse, this event is fired before viewstate has been applied, nodes may be resorted
Public Event | OnPostBackEvent | Fired when the postback event has been handled. This is a good place to override viewstate data that the user submitted, One application is to check that the StartTime and StopTime falls within your defined limits... If not set them to valid values in this event
Public Event | OnTimeItem_ClientClick | Fired on client click on time item
Public Event | OnTimeItemUserStringPrepare | Fired when server compiles ClientSide time items. If this event is implemented the string returned from it can later be accessed in ClientSide TimeItems property UserString. If this event is not implemented, but the TimeItem.UserReference != null, the value TimeItem.UserReference.ToString() will be put into the ClientSide TimeItem's UserString.
Top

See Also

Reference

Gantt_ASP Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnApplyViewState Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnApplyViewState Event

Glossary Item Box

Fired when view state should be applied to Gantt before rendering

Syntax

Visual Basic (Declaration)
Public Event OnApplyViewState As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As EventHandler

AddHandler instance.OnApplyViewState, handler
C#
public event EventHandler OnApplyViewState
Managed Extensions for C++
public: __event EventHandler* OnApplyViewState
C++/CLI
public:
event EventHandler^ OnApplyViewState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnAreaAttributes Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnAreaAttributes Event

Glossary Item Box

Fired when server compiles any active areas in the Gantt. This will let you add references to your own client side scripts etc.

Syntax

Visual Basic (Declaration)
Public Event OnAreaAttributes As AreaAttributeEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As AreaAttributeEvent

AddHandler instance.OnAreaAttributes, handler
C#
public event AreaAttributeEvent OnAreaAttributes
Managed Extensions for C++
public: __event AreaAttributeEvent* OnAreaAttributes
C++/CLI
public:
event AreaAttributeEvent^ OnAreaAttributes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnCellContentTuning Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnCellContentTuning Event

Glossary Item Box

Fires when preparing the content for each grid cell. If you want to inject free html in your cell you can do it in this cell by going like e.Content = string.Format(" [image] {0}", e.Content);

Syntax

Visual Basic (Declaration)
Public Event OnCellContentTuning As CellContentTuningEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As CellContentTuningEvent

AddHandler instance.OnCellContentTuning, handler
C#
public event CellContentTuningEvent OnCellContentTuning
Managed Extensions for C++
public: __event CellContentTuningEvent* OnCellContentTuning
C++/CLI
public:
event CellContentTuningEvent^ OnCellContentTuning

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnCellDivAttributesString Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnCellDivAttributesString Event

Glossary Item Box

Fires when preparing the html for each grid cell. You can implement to inject div attributes on a cell. Can be used to implement tooltips or/and cell events.

Syntax

Visual Basic (Declaration)
Public Event OnCellDivAttributesString As CellDivAttributesStringEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As CellDivAttributesStringEvent

AddHandler instance.OnCellDivAttributesString, handler
C#
public event CellDivAttributesStringEvent OnCellDivAttributesString
Managed Extensions for C++
public: __event CellDivAttributesStringEvent* OnCellDivAttributesString
C++/CLI
public:
event CellDivAttributesStringEvent^ OnCellDivAttributesString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnClientSideChangesApplied Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnClientSideChangesApplied Event

Glossary Item Box

Event is fired after client side changes has been applied (Ajax move and resize) This is a good place to update the database

Syntax

Visual Basic (Declaration)
Public Event OnClientSideChangesApplied As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As EventHandler

AddHandler instance.OnClientSideChangesApplied, handler
C#
public event EventHandler OnClientSideChangesApplied
Managed Extensions for C++
public: __event EventHandler* OnClientSideChangesApplied
C++/CLI
public:
event EventHandler^ OnClientSideChangesApplied

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnFontResizeEvent Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnFontResizeEvent Event

Glossary Item Box

The Gantt is rendered by windows forms. If you use MultiText in your cells row wrap will occure. Row wrap will make GanttRows higher(fatter). The text in the Gantt_ASP is normal html-text. If the html-text-font and the windows form font are not the same size (even if the have the same size set, they can be rendered differently), you may get the effect that the html-cell is to big for the html text (leaving white space), or to small; crowding the text. In this case we offer this event to provide a calculation factor; how much the fonts differ. You can set this factor to minimize the differences as much as possible.

Syntax

Visual Basic (Declaration)
Public Event OnFontResizeEvent As FontResizeEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As FontResizeEvent

AddHandler instance.OnFontResizeEvent, handler
C#
public event FontResizeEvent OnFontResizeEvent
Managed Extensions for C++
public: __event FontResizeEvent* OnFontResizeEvent
C++/CLI
public:
event FontResizeEvent^ OnFontResizeEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnGanttRow_ClientClick Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnGanttRow_ClientClick Event

Glossary Item Box

Fired on client click on GanttRow.

Syntax

Visual Basic (Declaration)
Public Event OnGanttRow_ClientClick As GanttRowClickEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As GanttRowClickEvent

AddHandler instance.OnGanttRow_ClientClick, handler
C#
public event GanttRowClickEvent OnGanttRow_ClientClick
Managed Extensions for C++
public: __event GanttRowClickEvent* OnGanttRow_ClientClick
C++/CLI
public:
event GanttRowClickEvent^ OnGanttRow_ClientClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnGetResource Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnGetResource Event

Glossary Item Box

Fired when the component needs an url to an image held as a resource. Overide this to give your own sorting icons, or tree fold/unfold icons, or zoom buttons etc

Syntax

Visual Basic (Declaration)
Public Event OnGetResource As GetResourceEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As GetResourceEvent

AddHandler instance.OnGetResource, handler
C#
public event GetResourceEvent OnGetResource
Managed Extensions for C++
public: __event GetResourceEvent* OnGetResource
C++/CLI
public:
event GetResourceEvent^ OnGetResource

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnNode_ClientClick Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnNode_ClientClick Event

Glossary Item Box

Fired on client click on Tree expand/collapse

Syntax

Visual Basic (Declaration)
Public Event OnNode_ClientClick As NodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As NodeEventHandler

AddHandler instance.OnNode_ClientClick, handler
C#
public event NodeEventHandler OnNode_ClientClick
Managed Extensions for C++
public: __event NodeEventHandler* OnNode_ClientClick
C++/CLI
public:
event NodeEventHandler^ OnNode_ClientClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnNode_ClientClick_NodeKey Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnNode_ClientClick_NodeKey Event

Glossary Item Box

Fired on client click on Tree expand/collapse, this event is fired before viewstate has been applied, nodes may be resorted

Syntax

Visual Basic (Declaration)
Public Event OnNode_ClientClick_NodeKey As EventHandler(Of ClientClick_NodeKeyArgs)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As EventHandler(Of ClientClick_NodeKeyArgs)

AddHandler instance.OnNode_ClientClick_NodeKey, handler
C#
public event EventHandler<ClientClick_NodeKeyArgs> OnNode_ClientClick_NodeKey
Managed Extensions for C++
public: __event EventHandler<ClientClick_NodeKeyArgs*>* OnNode_ClientClick_NodeKey
C++/CLI
public:
event EventHandler<ClientClick_NodeKeyArgs^>^ OnNode_ClientClick_NodeKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnPostBackEvent Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnPostBackEvent Event

Glossary Item Box

Fired when the postback event has been handled. This is a good place to override viewstate data that the user submitted, One application is to check that the StartTime and StopTime falls within your defined limits... If not set them to valid values in this event

Syntax

Visual Basic (Declaration)
Public Event OnPostBackEvent As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As EventHandler

AddHandler instance.OnPostBackEvent, handler
C#
public event EventHandler OnPostBackEvent
Managed Extensions for C++
public: __event EventHandler* OnPostBackEvent
C++/CLI
public:
event EventHandler^ OnPostBackEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnTimeItem_ClientClick Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnTimeItem_ClientClick Event

Glossary Item Box

Fired on client click on time item

Syntax

Visual Basic (Declaration)
Public Event OnTimeItem_ClientClick As TimeItemEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As TimeItemEvent

AddHandler instance.OnTimeItem_ClientClick, handler
C#
public event TimeItemEvent OnTimeItem_ClientClick
Managed Extensions for C++
public: __event TimeItemEvent* OnTimeItem_ClientClick
C++/CLI
public:
event TimeItemEvent^ OnTimeItem_ClientClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
OnTimeItemUserStringPrepare Event
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASP Class : OnTimeItemUserStringPrepare Event

Glossary Item Box

Fired when server compiles ClientSide time items. If this event is implemented the string returned from it can later be accessed in ClientSide TimeItems property UserString. If this event is not implemented, but the TimeItem.UserReference != null, the value TimeItem.UserReference.ToString() will be put into the ClientSide TimeItem's UserString.

Syntax

Visual Basic (Declaration)
Public Event OnTimeItemUserStringPrepare As TimeItemUserStringPrepareEvent
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASP
Dim handler As TimeItemUserStringPrepareEvent

AddHandler instance.OnTimeItemUserStringPrepare, handler
C#
public event TimeItemUserStringPrepareEvent OnTimeItemUserStringPrepare
Managed Extensions for C++
public: __event TimeItemUserStringPrepareEvent* OnTimeItemUserStringPrepare
C++/CLI
public:
event TimeItemUserStringPrepareEvent^ OnTimeItemUserStringPrepare

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASP Class
Gantt_ASP Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASPSettings Class

Glossary Item Box

Gantt_ASPSettings collects a lot of settings for the windows forms Gantt that you can resuse in a Gantt_ASP

Object Model

Gantt_ASPSettings ClassGantt ClassGantt_ASP Class

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
Public Class Gantt_ASPSettings
   Inherits System.ComponentModel.Component
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
C#
[ToolboxBitmapAttribute()]
public class Gantt_ASPSettings : System.ComponentModel.Component
Managed Extensions for C++
[ToolboxBitmapAttribute()]
public __gc class Gantt_ASPSettings : public System.ComponentModel.Component
C++/CLI
[ToolboxBitmapAttribute()]
public ref class Gantt_ASPSettings : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PlexityHide.GTP.WEB.Gantt_ASPSettings

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

Gantt_ASPSettings Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Class Members
See Also Properties Methods Events Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASPSettings Class

Glossary Item Box

The following tables list the members exposed by Gantt_ASPSettings.

Public Constructors

 | Name | Description
Public Constructor | Gantt_ASPSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | Components |
Public Property | Gantt |
Public Property | Gantt_ASP |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Remove |
Public Method | WrapGantt |
Top

See Also

Reference

Gantt_ASPSettings Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Gantt_ASPSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Gantt_ASPSettings()
C#
public Gantt_ASPSettings()
Managed Extensions for C++
public: Gantt_ASPSettings();
C++/CLI
public:
Gantt_ASPSettings();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Class Methods
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASPSettings Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASPSettings members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Remove |
Public Method | WrapGantt |
Top

See Also

Reference

Gantt_ASPSettings Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Add Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(IComponent) |
Add(IComponent,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Add(IComponent) Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class > Add Method : Add(IComponent) Method

c

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal c As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim c As IComponent

instance.Add(c)
C#
public void Add(
   IComponent c
)
Managed Extensions for C++
public: void Add(
   IComponent* c
)
C++/CLI
public:
void Add(
   IComponent^ c
)

Parameters

c

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Add(IComponent,String) Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class > Add Method : Add(IComponent,String) Method

c
s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal c As IComponent, _
   ByVal s As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim c As IComponent
Dim s As String

instance.Add(c, s)
C#
public void Add(
   IComponent c,
   string s
)
Managed Extensions for C++
public: void Add(
   IComponent* c,
   string* s
)
C++/CLI
public:
void Add(
   IComponent^ c,
   String^ s
)

Parameters

c
s

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members
Overload List


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Remove Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Remove Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal component As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim component As IComponent

instance.Remove(component)
C#
public void Remove(
   IComponent component
)
Managed Extensions for C++
public: void Remove(
   IComponent* component
)
C++/CLI
public:
void Remove(
   IComponent^ component
)

Parameters

component

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
WrapGantt Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : WrapGantt Method

aGantt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub WrapGantt( _
   ByVal aGantt As Gantt _
)
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim aGantt As Gantt

instance.WrapGantt(aGantt)
C#
public void WrapGantt(
   Gantt aGantt
)
Managed Extensions for C++
public: void WrapGantt(
   Gantt* aGantt
)
C++/CLI
public:
void WrapGantt(
   Gantt^ aGantt
)

Parameters

aGantt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Class Properties
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASPSettings Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASPSettings members.

Public Properties

 | Name | Description
Public Property | Components |
Public Property | Gantt |
Public Property | Gantt_ASP |
Top

See Also

Reference

Gantt_ASPSettings Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Components Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Components Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As ComponentCollection
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim value As ComponentCollection

value = instance.Components
C#
public ComponentCollection Components {get;}
Managed Extensions for C++
public: __property ComponentCollection* get_Components();
C++/CLI
public:
property ComponentCollection^ Components {
   ComponentCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Gantt Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property Gantt As Gantt
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim value As Gantt

value = instance.Gantt
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public Gantt Gantt {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property Gantt* get_Gantt();
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property Gantt^ Gantt {
   Gantt^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Gantt_ASP Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > Gantt_ASPSettings Class : Gantt_ASP Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Gantt_ASP As Gantt_ASP
Visual Basic (Usage) Copy Code
Dim instance As Gantt_ASPSettings
Dim value As Gantt_ASP

instance.Gantt_ASP = value

value = instance.Gantt_ASP
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Gantt_ASP Gantt_ASP {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Gantt_ASP* get_Gantt_ASP();
public: __property void set_Gantt_ASP(
   Gantt_ASP* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Gantt_ASP^ Gantt_ASP {
   Gantt_ASP^ get();
   void set (    Gantt_ASP^ value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Gantt_ASPSettings Class
Gantt_ASPSettings Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GanttRowClickEventArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GanttRowClickEventArgs Class

Glossary Item Box

Arguments for GanttRow click event

Object Model

GanttRowClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class GanttRowClickEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As GanttRowClickEventArgs
C#
public class GanttRowClickEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class GanttRowClickEventArgs : public System.EventArgs
C++/CLI
public ref class GanttRowClickEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.GanttRowClickEventArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

GanttRowClickEventArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
GanttRowClickEventArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GanttRowClickEventArgs Class

Glossary Item Box

The following tables list the members exposed by GanttRowClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | GanttRowClickEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | Row | The GanttRow clicked
Public Field | ThisClickSelectedLink | If the GanttRowClick selected a link, this property will be assigned. Otherwise it will be null;
Public Field | X | The click point
Public Field | Y | The click point
Top

See Also

Reference

GanttRowClickEventArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GanttRowClickEventArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GanttRowClickEventArgs Class : GanttRowClickEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GanttRowClickEventArgs()
C#
public GanttRowClickEventArgs()
Managed Extensions for C++
public: GanttRowClickEventArgs();
C++/CLI
public:
GanttRowClickEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRowClickEventArgs Class
GanttRowClickEventArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
GanttRowClickEventArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GanttRowClickEventArgs Class

Glossary Item Box

For a list of all members of this type, see GanttRowClickEventArgs members.

Public Fields

 | Name | Description
Public Field | Row | The GanttRow clicked
Public Field | ThisClickSelectedLink | If the GanttRowClick selected a link, this property will be assigned. Otherwise it will be null;
Public Field | X | The click point
Public Field | Y | The click point
Top

See Also

Reference

GanttRowClickEventArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Row Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GanttRowClickEventArgs Class : Row Field

Glossary Item Box

The GanttRow clicked

Syntax

Visual Basic (Declaration)
Public Row As GanttRow
Visual Basic (Usage) Copy Code
Dim instance As GanttRowClickEventArgs
Dim value As GanttRow

value = instance.Row

instance.Row = value
C#
public GanttRow Row
Managed Extensions for C++
public: GanttRow* Row
C++/CLI
public:
GanttRow^ Row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRowClickEventArgs Class
GanttRowClickEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ThisClickSelectedLink Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GanttRowClickEventArgs Class : ThisClickSelectedLink Field

Glossary Item Box

If the GanttRowClick selected a link, this property will be assigned. Otherwise it will be null;

Syntax

Visual Basic (Declaration)
Public ThisClickSelectedLink As TimeItemLink
Visual Basic (Usage) Copy Code
Dim instance As GanttRowClickEventArgs
Dim value As TimeItemLink

value = instance.ThisClickSelectedLink

instance.ThisClickSelectedLink = value
C#
public TimeItemLink ThisClickSelectedLink
Managed Extensions for C++
public: TimeItemLink* ThisClickSelectedLink
C++/CLI
public:
TimeItemLink^ ThisClickSelectedLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRowClickEventArgs Class
GanttRowClickEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
X Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GanttRowClickEventArgs Class : X Field

Glossary Item Box

The click point

Syntax

Visual Basic (Declaration)
Public X As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRowClickEventArgs
Dim value As Integer

value = instance.X

instance.X = value
C#
public int X
Managed Extensions for C++
public: int X
C++/CLI
public:
int X

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRowClickEventArgs Class
GanttRowClickEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
Y Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GanttRowClickEventArgs Class : Y Field

Glossary Item Box

The click point

Syntax

Visual Basic (Declaration)
Public Y As Integer
Visual Basic (Usage) Copy Code
Dim instance As GanttRowClickEventArgs
Dim value As Integer

value = instance.Y

instance.Y = value
C#
public int Y
Managed Extensions for C++
public: int Y
C++/CLI
public:
int Y

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GanttRowClickEventArgs Class
GanttRowClickEventArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetImage Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GetImage Class

Glossary Item Box

Object Model

GetImage Class

Syntax

Visual Basic (Declaration)
Public Class GetImage
Visual Basic (Usage) Copy Code
Dim instance As GetImage
C#
public class GetImage
Managed Extensions for C++
public __gc class GetImage
C++/CLI
public ref class GetImage

Inheritance Hierarchy

System.Object
PlexityHide.GTP.WEB.GetImage

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

GetImage Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
GetImage Class Members
See Also Properties Methods Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GetImage Class

Glossary Item Box

The following tables list the members exposed by GetImage.

Public Constructors

 | Name | Description
Public Constructor | GetImage Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable | You will need to configure this handler in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

GetImage Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetImage Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GetImage Class : GetImage Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GetImage()
C#
public GetImage()
Managed Extensions for C++
public: GetImage();
C++/CLI
public:
GetImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GetImage Class
GetImage Members


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP.WEB
GetImage Class Methods
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GetImage Class

Glossary Item Box

For a list of all members of this type, see GetImage members.

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

GetImage Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ProcessRequest Method
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GetImage Class : ProcessRequest Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As GetImage
Dim context As HttpContext

instance.ProcessRequest(context)
C#
public void ProcessRequest(
   HttpContext context
)
Managed Extensions for C++
public: void ProcessRequest(
   HttpContext* context
)
C++/CLI
public:
void ProcessRequest(
   HttpContext^ context
)

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GetImage Class
GetImage Members


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP.WEB
GetImage Class Properties
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GetImage Class

Glossary Item Box

For a list of all members of this type, see GetImage members.

Public Properties

 | Name | Description
Public Property | IsReusable | You will need to configure this handler in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007
Top

See Also

Reference

GetImage Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
IsReusable Property
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > GetImage Class : IsReusable Property

Glossary Item Box

You will need to configure this handler in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GetImage
Dim value As Boolean

value = instance.IsReusable
C#
public bool IsReusable {get;}
Managed Extensions for C++
public: __property bool get_IsReusable();
C++/CLI
public:
property bool IsReusable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GetImage Class
GetImage Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TimeItemUserStringPrepareArgs Class
Members See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : TimeItemUserStringPrepareArgs Class

Glossary Item Box

Arguments for area events

Object Model

TimeItemUserStringPrepareArgs Class

Syntax

Visual Basic (Declaration)
Public Class TimeItemUserStringPrepareArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TimeItemUserStringPrepareArgs
C#
public class TimeItemUserStringPrepareArgs : System.EventArgs
Managed Extensions for C++
public __gc class TimeItemUserStringPrepareArgs : public System.EventArgs
C++/CLI
public ref class TimeItemUserStringPrepareArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
PlexityHide.GTP.WEB.TimeItemUserStringPrepareArgs

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

TimeItemUserStringPrepareArgs Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%% $$Members$$

[image]
PlexityHide.GTP.WEB
TimeItemUserStringPrepareArgs Class Members
See Also Fields Send comments on this topic.
PlexityHide.GTP.WEB Namespace : TimeItemUserStringPrepareArgs Class

Glossary Item Box

The following tables list the members exposed by TimeItemUserStringPrepareArgs.

Public Constructors

 | Name | Description
Public Constructor | TimeItemUserStringPrepareArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ClientSideTimeItem | The Client side time item (or at least the server representation of it)
Public Field | result | The result that will be put into the UserString property of the client side time item.
Public Field | ti | The TimeItem that the event refers to
Top

See Also

Reference

TimeItemUserStringPrepareArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TimeItemUserStringPrepareArgs Constructor
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > TimeItemUserStringPrepareArgs Class : TimeItemUserStringPrepareArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemUserStringPrepareArgs()
C#
public TimeItemUserStringPrepareArgs()
Managed Extensions for C++
public: TimeItemUserStringPrepareArgs();
C++/CLI
public:
TimeItemUserStringPrepareArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemUserStringPrepareArgs Class
TimeItemUserStringPrepareArgs Members


%%PageItemTitle%% $$Fields$$

[image]
PlexityHide.GTP.WEB
TimeItemUserStringPrepareArgs Class Fields
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : TimeItemUserStringPrepareArgs Class

Glossary Item Box

For a list of all members of this type, see TimeItemUserStringPrepareArgs members.

Public Fields

 | Name | Description
Public Field | ClientSideTimeItem | The Client side time item (or at least the server representation of it)
Public Field | result | The result that will be put into the UserString property of the client side time item.
Public Field | ti | The TimeItem that the event refers to
Top

See Also

Reference

TimeItemUserStringPrepareArgs Class
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ClientSideTimeItem Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > TimeItemUserStringPrepareArgs Class : ClientSideTimeItem Field

Glossary Item Box

The Client side time item (or at least the server representation of it)

Syntax

Visual Basic (Declaration)
Public ClientSideTimeItem As TimeItemClientData
Visual Basic (Usage) Copy Code
Dim instance As TimeItemUserStringPrepareArgs
Dim value As TimeItemClientData

value = instance.ClientSideTimeItem

instance.ClientSideTimeItem = value
C#
public TimeItemClientData ClientSideTimeItem
Managed Extensions for C++
public: TimeItemClientData* ClientSideTimeItem
C++/CLI
public:
TimeItemClientData^ ClientSideTimeItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemUserStringPrepareArgs Class
TimeItemUserStringPrepareArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
result Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > TimeItemUserStringPrepareArgs Class : result Field

Glossary Item Box

The result that will be put into the UserString property of the client side time item.

Syntax

Visual Basic (Declaration)
Public result As String
Visual Basic (Usage) Copy Code
Dim instance As TimeItemUserStringPrepareArgs
Dim value As String

value = instance.result

instance.result = value
C#
public string result
Managed Extensions for C++
public: string* result
C++/CLI
public:
String^ result

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemUserStringPrepareArgs Class
TimeItemUserStringPrepareArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
ti Field
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace > TimeItemUserStringPrepareArgs Class : ti Field

Glossary Item Box

The TimeItem that the event refers to

Syntax

Visual Basic (Declaration)
Public ti As TimeItem
Visual Basic (Usage) Copy Code
Dim instance As TimeItemUserStringPrepareArgs
Dim value As TimeItem

value = instance.ti

instance.ti = value
C#
public TimeItem ti
Managed Extensions for C++
public: TimeItem* ti
C++/CLI
public:
TimeItem^ ti

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TimeItemUserStringPrepareArgs Class
TimeItemUserStringPrepareArgs Members


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
AreaKind Enumeration
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : AreaKind Enumeration

Glossary Item Box

Active Areas are a typed by an AreaKind

Syntax

Visual Basic (Declaration)
Public Enum AreaKind
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AreaKind
C#
public enum AreaKind : System.Enum
Managed Extensions for C++
__value public enum AreaKind : public System.Enum
C++/CLI
public enum class AreaKind : public System.Enum

Members

Member | Description
DateAdd | Move in time by adding to the intervall
DateSubstract | Move in time by substracting from the intervall
GridNodeButton | The button that either fold or unfolds the subnodes in a tree
ScaleDec | Show time in less detail
ScaleInc | Show time in greater detail
Sort | Column head sort was clicked
TimeItem | a Gantt TimeItem
TimeItemClientMove | After a client/ajax move of a time item
TimeItemClientResize | After a client/ajax resize of a time item
TimeItemRow | The row on which time items may reside

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
PlexityHide.GTP.WEB.AreaKind

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
AreaAttributeEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : AreaAttributeEvent Delegate

aGantt
e

Glossary Item Box

This event is for Gantt_ASP to allow for extension of area tags

Syntax

Visual Basic (Declaration)
Public Delegate Sub AreaAttributeEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As AreaAttributeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AreaAttributeEvent(AddressOf HandlerMethod)
C#
public delegate void AreaAttributeEvent(
   Gantt_ASP aGantt,
   AreaAttributeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void AreaAttributeEvent(
   Gantt_ASP* aGantt,
   AreaAttributeEventArgs* e
)
C++/CLI
public delegate void AreaAttributeEvent(
   Gantt_ASP^ aGantt,
   AreaAttributeEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

AreaAttributeEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellContentTuningEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellContentTuningEvent Delegate

aGantt
e

Glossary Item Box

Fires when preparing cell content.

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellContentTuningEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As CellContentTuningArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellContentTuningEvent(AddressOf HandlerMethod)
C#
public delegate void CellContentTuningEvent(
   Gantt_ASP aGantt,
   CellContentTuningArgs e
)
Managed Extensions for C++
public: __gc __delegate void CellContentTuningEvent(
   Gantt_ASP* aGantt,
   CellContentTuningArgs* e
)
C++/CLI
public delegate void CellContentTuningEvent(
   Gantt_ASP^ aGantt,
   CellContentTuningArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CellContentTuningEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
CellDivAttributesStringEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : CellDivAttributesStringEvent Delegate

aGantt
e

Glossary Item Box

Fires when preparing the html for each grid cell. You can implement to inject div attributes on a cell. Can be used to implement tooltips or/and cell events.

Syntax

Visual Basic (Declaration)
Public Delegate Sub CellDivAttributesStringEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As CellDivArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CellDivAttributesStringEvent(AddressOf HandlerMethod)
C#
public delegate void CellDivAttributesStringEvent(
   Gantt_ASP aGantt,
   CellDivArgs e
)
Managed Extensions for C++
public: __gc __delegate void CellDivAttributesStringEvent(
   Gantt_ASP* aGantt,
   CellDivArgs* e
)
C++/CLI
public delegate void CellDivAttributesStringEvent(
   Gantt_ASP^ aGantt,
   CellDivArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

CellDivAttributesStringEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
FontResizeEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : FontResizeEvent Delegate

aGantt
e

Glossary Item Box

This event is used to allow for you to minimize difference between winform fonts and html-fonts

Syntax

Visual Basic (Declaration)
Public Delegate Sub FontResizeEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As CalcFontDifferenceArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New FontResizeEvent(AddressOf HandlerMethod)
C#
public delegate void FontResizeEvent(
   Gantt_ASP aGantt,
   CalcFontDifferenceArgs e
)
Managed Extensions for C++
public: __gc __delegate void FontResizeEvent(
   Gantt_ASP* aGantt,
   CalcFontDifferenceArgs* e
)
C++/CLI
public delegate void FontResizeEvent(
   Gantt_ASP^ aGantt,
   CalcFontDifferenceArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

FontResizeEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GanttRowClickEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GanttRowClickEvent Delegate

aGantt
e

Glossary Item Box

This event is for Gantt_ASP to allow for extension of area tags

Syntax

Visual Basic (Declaration)
Public Delegate Sub GanttRowClickEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As GanttRowClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New GanttRowClickEvent(AddressOf HandlerMethod)
C#
public delegate void GanttRowClickEvent(
   Gantt_ASP aGantt,
   GanttRowClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void GanttRowClickEvent(
   Gantt_ASP* aGantt,
   GanttRowClickEventArgs* e
)
C++/CLI
public delegate void GanttRowClickEvent(
   Gantt_ASP^ aGantt,
   GanttRowClickEventArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

GanttRowClickEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
GetResourceEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : GetResourceEvent Delegate

aGantt
id
theResourceUrl

Glossary Item Box

This event is for Gantt_ASP to allow for override of fixed images

Syntax

Visual Basic (Declaration)
Public Delegate Sub GetResourceEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal id As String, _
   ByRef theResourceUrl As String _
)
Visual Basic (Usage) Copy Code
Dim instance As New GetResourceEvent(AddressOf HandlerMethod)
C#
public delegate void GetResourceEvent(
   Gantt_ASP aGantt,
   string id,
   ref string theResourceUrl
)
Managed Extensions for C++
public: __gc __delegate void GetResourceEvent(
   Gantt_ASP* aGantt,
   string* id,
   ref string* theResourceUrl
)
C++/CLI
public delegate void GetResourceEvent(
   Gantt_ASP^ aGantt,
   String^ id,
   String^% theResourceUrl
)

Parameters

aGantt
id
theResourceUrl

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

GetResourceEvent Members
PlexityHide.GTP.WEB Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP.WEB
TimeItemUserStringPrepareEvent Delegate
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : TimeItemUserStringPrepareEvent Delegate

aGantt
e

Glossary Item Box

This event is used to initiade ClientSide TimeItem's UserString property

Syntax

Visual Basic (Declaration)
Public Delegate Sub TimeItemUserStringPrepareEvent( _
   ByVal aGantt As Gantt_ASP, _
   ByVal e As TimeItemUserStringPrepareArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TimeItemUserStringPrepareEvent(AddressOf HandlerMethod)
C#
public delegate void TimeItemUserStringPrepareEvent(
   Gantt_ASP aGantt,
   TimeItemUserStringPrepareArgs e
)
Managed Extensions for C++
public: __gc __delegate void TimeItemUserStringPrepareEvent(
   Gantt_ASP* aGantt,
   TimeItemUserStringPrepareArgs* e
)
C++/CLI
public delegate void TimeItemUserStringPrepareEvent(
   Gantt_ASP^ aGantt,
   TimeItemUserStringPrepareArgs^ e
)

Parameters

aGantt
e

Requirements

Namespace: PlexityHide.GTP.WEB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: PlexityHide.GTP.WEB (in C:\Pexlain_wf\Nant\Builds\outs\latest\Ajax.CLR35\PlexityHide.GTP.WEB.dll)

See Also

Reference

TimeItemUserStringPrepareEvent Members
PlexityHide.GTP.WEB Namespace


Connect Gantt to datasources

Datasources

You can connect a datasource to the Grid and you can even connect datasources to the grid nodes to build up a hierarcical tree of data. You can also connect a datasource to each layer of a GanttRow to let the datasource create all, or some, time items for you.

Data present in the Grid and Gantt as a result of datasource connection, can be updated if the datasource allowes it.

In the .Net environment datasources can be datasets that connect to database, but you can also implement the correct interfaces in your domain model to connect your data directly to the Gantt control.

If you fullfill the IList interface you can populate the Gantt with datasources but in order for the Gantt to write back changes applied by the user back into the datasource you must fullfill/implement the IBindingList.

PlexityHide.GTP_gettingstarted.html

  • Datasource

  • Connecting


How to connect a datasource

Gantt_Database sample

The sample Gantt_Database shows how to connect the Gantt to a database that has one table for hierarcical grid nodes (project) and one table for time items on these nodes (projects).

The timeitem table has a foreign key that links to its owning project (TimeItem.ownedby). And the projects has a foreign key that is set to the project parent if it exists. If it does not exists we set this foreign key to -1 or to null.

In the load button of the sample we use the sqladapters to fill the datasets. We create a dataview on the project dataset that filters out the project rows with no parent (firstView.RowFilter="ISNULL(ownedby,-1)=-1";)

We bind the rootnodes of the grid to this dataview with this call: gantt1.GridProperties.RootNodes_DataSourceList=firstView;

        private void button1_Click(object sender, System.EventArgs e)
        {
            dataSet21.Clear();
            dataSet21.project.Clear();
            sqlDataAdapter1.Fill(dataSet21);
            DataView firstView = new DataView(dataSet21.project);
            firstView.RowFilter="ISNULL(ownedby,-1)=-1";
            gantt1.GridProperties.RootNodes_DataSourceList=firstView;

            dataSet_timeitems1.Clear();
            sqlDataAdapter2.Fill(dataSet_timeitems1);

        }
Now the root-nodes will be created from all the rows in the dataview.
The Grid cell values will be resolved using the DataSourceColumn field in the GridColumn (Gantt.GridProperties.Columns):

For each GridNode that is created we want to check if there should be any sub-nodes and/or time items.
We do this in the event OnNodeInserted:

        private void gantt1_OnNodeInserted(PlexityHide.GTP.Grid aGrid, PlexityHide.GTP.NodeEventArgs e)
        {

            object row=e.GridNode.ListItemWhenDataBound();
            object val=e.GridNode.OwningCollection.NodeDataConnect.CurrencyManager.GetItemProperties().Find("id",true).GetValue(row);

            // Set up tree using DataViews, in this sample we only allow for SubLevel zero (root nodes) to have sub nodes
            if (e.GridNode.SubLevel==0)
            {
                DataView subNodeView = new DataView(dataSet21.project);
                if (val is Int32)
                    subNodeView.RowFilter="ownedby="+val.ToString();
                else
                    subNodeView.RowFilter="ownedby=-1";
              // Set the SubNodes to bind to the subNodeView
                e.GridNode.SubNodes_DataSourceList=subNodeView;
            }

            // Set up time items in layer 0 with a dataview of the time items dataset
            GanttRow gr=Gantt.GanttRowFromGridNode(e.GridNode);
            DataView timeitemView = new DataView(dataSet_timeitems1.timeitem);
            if (val is Int32)
                timeitemView.RowFilter="ownedby="+val.ToString();
            else
                timeitemView.RowFilter="ownedby=-1";
            gr.Layers[0].NameInDS_Start="start";
            gr.Layers[0].NameInDS_Stop="stop";
            gr.Layers[0].DataSourceList=timeitemView;
            gr.Layers[0].TimeItemLayout="NiceLook";

        }

And that is it. When you change the time items start or stop properties the dataset will be updated.
When you change the grid cells the dataset will be updated.

But what about moving a time item to a different row?

To handle the move, we actually only want to assign a different foreign key to the TimeItem row in the TimeItem table,
this has very little to do with the gantt control itself, but we need to react to this operation:

    private void gantt1_OnTimeItem_ChangeRow(PlexityHide.GTP.Gantt aGantt, PlexityHide.GTP.TimeItemEventArgs e)
    {
      // What we really want to do when changing rows in a databound Gantt is to change the data in the dataset to reflect
      // the change of owner. This change in data will propagte into the Gantt Automatically.

      e.Allow=false; // Do not perform the move, let propagation handle it

      DataRowView row=e.TimeItem.ListItemWhenDataBound() as DataRowView;
      DataRowView noderow=e.NewGanttRow.GridNode.ListItemWhenDataBound() as DataRowView;

      row["ownedby"]=noderow["id"];   // Set the OwnedBy value to the id of the new row -> move it
    }

PlexityHide.GTP_gettingstarted.html
  • Datasource

  • Connecting


Date scaler

The date scaler is on of the core components of the Gantt component. The Date scaler defines the X-axis for time information and handles the mapping between pixel-space that is used for drawing and the date-time space that is used for calculation and external and internal representation of time items. The crystal clear distinction between pixel space and date time space is vital for allowing for many of the advanced features of the plexityHide date scale component; like time hiding, day hiding, free zooming (not bound by predefined views) and fish eye display.

This display will be used on the following pages and was set up with this code:

private void Form1_Load(object sender, System.EventArgs e)

{

GridNode gn1=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn1.GetCell(0).Content.Value="Test row #1";

GridNode gn2=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn2.GetCell(0).Content.Value="Test row #2";

GridNode gn3=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn3.GetCell(0).Content.Value="Test row #3";

TimeItem ti1=Gantt.GanttRowFromGridNode(gn1).Layers[0].AddNewTimeItem();

TimeItem ti2=Gantt.GanttRowFromGridNode(gn2).Layers[0].AddNewTimeItem();

ti1.TimeItemLayout= new TimeItemLayout();

ti1.TimeItemLayout.Color=Color.SlateBlue;

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);

ti1.Stop=ti1.Start.AddDays(10);

ti2.Start=gantt1.DateScaler.StartTime.AddDays(5);

ti2.Stop=ti2.Start.AddDays(10);

ti2.TimeItemLayout= new TimeItemLayout();

ti2.TimeItemLayout.Color=Color.OrangeRed;

for(int i=0;i<15;i++)

{

TimeItem ti3=Gantt.GanttRowFromGridNode(gn3).Layers[0].AddNewTimeItem();

ti3.Start=gantt1.DateScaler.StartTime.AddDays(1+i);

ti3.Stop=ti3.Start.AddHours(12);

ti3.TimeItemLayout= new TimeItemLayout();

ti3.TimeItemLayout.Color=Color.Yellow;

}

gantt1.DateScaler.FishEyeMagnification=FishEyeMagnification.M8;

}

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Date scaler 1

Date scale zooming

If you want your users to handle the zooming they can do this by dragging the scale component with the mouse. If they hold down the ctrl key they will traverse in time instead. You can toggle this behavior with the property ReScaleWithControl in the DateScaler.

But maybe you want to zoom programmatically and this example show you how:

private void ZoomMinus_Click(object sender, System.EventArgs e)

{

gantt1.DateScaler.StartTime=gantt1.DateScaler.StartTime.AddDays(2);

gantt1.DateScaler.StopTime=gantt1.DateScaler.StopTime.AddDays(-2);

}

private void ZoomPlus_Click(object sender, System.EventArgs e)

{

gantt1.DateScaler.StartTime=gantt1.DateScaler.StartTime.AddDays(-2);

gantt1.DateScaler.StopTime=gantt1.DateScaler.StopTime.AddDays(2);

}

You only need to change the start and stop date times of the scaler and the view will adapt.

in fact you show extremely long intervals in the Gantt:

Or very small:

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Date scaler 2

Date scaler traverse in time

If you want to traverse in time programmatically this is how:

private void PanLeft_Click(object
sender, System.EventArgs e)
{
gantt1.DateScaler.StartTime=gantt1.DateScaler.StartTime.AddDays(2);
gantt1.DateScaler.StopTime=gantt1.DateScaler.StopTime.AddDays(2);
}
private void PanRight_Click(object sender, System.EventArgs
e)
{
gantt1.DateScaler.StartTime=gantt1.DateScaler.StartTime.AddDays(-2);
gantt1.DateScaler.StopTime=gantt1.DateScaler.StopTime.AddDays(-2);
}

The sample moves 2 days on every click, you can move the exact amount you want, from seconds to decades.

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Date scaler 3

Date scaler time hiding

In many real life cases the probable outcome of time information might be restricted to only part of the day. In these cases it is user friendly to avoid showing the other parts of the day that is of no interest, hence giving the user more compact information.

In the date scaler you can specify hours of the day that is of no interest to your users. This does not need to be fixed, you can change the hidden hours in runtime. Even if part of the day is hidden from display it does not mean that the Gantt will not handle the hidden part, in fact the Gantt does not care about this, time hiding is only a display mode.

Code sample:

private bool timeHide=false;

private void TimeHide_Click(object sender, System.EventArgs e)

{

timeHide=!timeHide;

if (timeHide)

gantt1.DateScaler.HideHours(new int[]{18,19,20,21,22,23,0,1,2,3,4,5,6});

else

gantt1.DateScaler.ShowHours(new int[]{0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23});

}

And the display:

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Date scaler 4

Date scaler day hiding

Some days might be of no interest to your users. You can then hide them, thus saving screen pixels and giving your users a more compact view.

Code sample:

private bool dayHide=false;

private void DayHide_Click(object sender, System.EventArgs e)

{

dayHide=!dayHide;

if (dayHide)

gantt1.DateScaler.HideDays(new DayOfWeek[]{DayOfWeek.Saturday,DayOfWeek.Sunday});

else

gantt1.DateScaler.ShowDays(new DayOfWeek[]{DayOfWeek.Saturday,DayOfWeek.Sunday});

}

And the display:

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Date scaler 5

Date scaler fish eye

If your users are browsing a lot of information in small detail they could be helped by a looking glass to focus on part of the information in greater detail. The date scaler has such a feature built in called fish eye view. The name fish eye comes from the fact that information presented this way seems to bulge out like the eye of a fish.

Code sample:

private bool fishEye=false;

private void FishEye_Click(object sender, System.EventArgs e)

{

fishEye=!fishEye;

gantt1.DateScaler.FishEyeenabled=fishEye;

}

And what it looks like on screen:

Note that the bluish part constitutes the fisheye. It has a greater magnification than the surrounding date scaler, hence the time item falling inside this area is perceived in greater detail than other time items of equal length. If you have texts or user drawn details inside these time items that information will be much more accessible to the user using a fish eye.

The same information in a different scale:

And without the fish eye:

PlexityHide.GTP_gettingstarted.html

  • Date scaler

  • Zooming

  • Traversing in time

  • Time hiding

  • Day hiding

  • Fish eye


Grid

The Grid is a vital part of the plexityHide GTP.NET components package. Not only does it constitute the Y axis for time items but can also function stand alone as an advanced GUI component to solve many presentation and updating issues. The grid can also function as a tree.

All colors, fonts and layout properties are controlled by CellLayout objects. One CellLayout object typically serves many Cells. The use of CellLayouts reduces the need of memory compared to implementations where the cell itself holds a lot of visualization properties.

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid1

Grid adding data

To add data to a grid:

Adding columns

GridColumn gc1=grid1.GridStructure.Columns.AddNew(CellType.SingleText);

GridColumn gc2=grid1.GridStructure.Columns.AddNew(CellType.TimeDate);

GridColumn gc3=grid1.GridStructure.Columns.AddNew(CellType.MultiText);

GridColumn gc4=grid1.GridStructure.Columns.AddNew(CellType.ComboText);

GridColumn gc5=grid1.GridStructure.Columns.AddNew(CellType.BoolCheck);

GridColumn gc6=grid1.GridStructure.Columns.AddNew(CellType.CustomCell);

The Grid is capable of handling different data in its cells, the above code shows creating of columns to hold text, datetime, row wrapping texts, combobox edit values, boolean values and custom. With custom cells you must use events to handle drawing and editing.

Adding GridNodes, rootnodes:

if (grid1.GridStructure.FocusedCell==null)

{

GridNode gn=grid1.GridStructure.RootNodes.AddNode();

}

else

{

GridNode gn=new GridNode();

grid1.GridStructure.FocusedCell.Node.

OwningCollection.Insert(grid1.GridStructure.FocusedCell.Node.Index,gn);

}

... or sub nodes

if (grid1.GridStructure.FocusedCell!=null)

{

grid1.GridStructure.FocusedCell.Node.SubNodes.AddNode();

}

And to populate the cells:

private string[] contentValues1={"Roy","Sondra","Gergel","Bruce","John","Jamie","Horace","Dragos","Michael"};

private string[] contentValues2={"Long text that runs over several rows",

"Not so long text",

"Short","Longer than short but still",

"Rather short",

"Really long text that will go over many lines if the column is narrow"};

private void InitNodeContent(GridNode gn)

{

Random r=new Random();

gn.GetCell(0).Content.Value=contentValues1[r.Next(0,9)];

gn.GetCell(1).Content.Value=new DateTime(2003,r.Next(1,12),r.Next(1,28));

gn.GetCell(2).Content.Value=contentValues2[r.Next(0,5)];

gn.GetCell(3).Content.Value="Change this with combobox";

gn.GetCell(5).Content.Value=true;

}

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid2

Grid Looks

CellLayout objects are used to change the look of the cells in a grid. In this example the grid makes use of only two CellLayout objects. There is no limitation to how many you can use.

When we change the two CellLayouts we get a different view, here we change background color, header color, row size and we turn on end ellipses (so when text does not fit it is gracefully ended with 3 full stops like this...):

cl1.BackgroundColor=Color.Turquoise;

cl1.EndEllipsis=true;

cl1.Font=new Font("Helvetica",9);

cl1.HeaderBackgroundColor=Color.Tomato;

cl1.SelectedColor=Color.Violet;

cl1.MinHeight=13;

cl2.BackgroundColor=Color.WhiteSmoke;

cl2.EndEllipsis=true;

cl2.Font=new Font("Times",8);

cl2.HeaderBackgroundColor=Color.YellowGreen;

cl2.SelectedColor=Color.SteelBlue;

cl2.MinHeight=13;

And Change them further to Show some grid lines:

cl1.LineBottom.Color=Color.RosyBrown;

cl1.LineBottom.Use=true;

cl1.LineBottom.Width=2;

cl2.LineBottom.Color=Color.SlateGray;

cl2.LineBottom.Use=true;

cl2.LineBottom.Width=2;

Read on for more on CellLayouts...

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid3

Grid CellLayouts continued

More lines:

cl1.LineRight.Color=Color.RosyBrown;

cl1.LineRight.Use=true;

cl1.LineRight.Width=2;

cl2.LineRight.Color=Color.SlateGray;

cl2.LineRight.Use=true;

cl2.LineRight.Width=2;

Even more lines:

cl1.LineTop.Color=Color.Silver;

cl1.LineTop.Use=true;

cl1.LineTop.Width=2;

cl1.LineLeft.Color=Color.Silver;

cl1.LineLeft.Use=true;

cl1.LineLeft.Width=2;

cl2.LineTop.Color=Color.Silver;

cl2.LineTop.Use=true;

cl2.LineTop.Width=2;

cl2.LineLeft.Color=Color.Silver;

cl2.LineLeft.Use=true;

cl2.LineLeft.Width=2;

And then some insets and padding:

cl1.MinHeight=23;

cl1.Padding=new Rectangle(2,2,2,2);

cl1.Spacing=new Rectangle(2,2,2,2);

cl2.MinHeight=23;

cl2.Padding=new Rectangle(2,2,2,2);

cl2.Spacing=new Rectangle(2,2,2,2);

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid4

Grid CellLayouts continued 2

You can control horizontal and vertical alignment:

cl1.VertAlign=StringAlignment.Center;

cl1.HorzAlign=StringAlignment.Center;

cl2.VertAlign=StringAlignment.Center;

cl2.HorzAlign=StringAlignment.Center;

Let the Background pyjamas color shine through...

cl1.BackgroundUse=false;

cl2.BackgroundUse=false;

And change the Background pyjamas color:

grid1.PyjamasColor=Color.WhiteSmoke;

grid1.PyjamasGradientColor=Color.Wheat;

As you can see the degrees of freedom in this grid are many.

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid5

Grid Custom cells

Custom cells can come in handy when you want to present something different not currently supported by the Grid. By assigning the event OnCustomCellDraw you will get an opportunity to paint the content of the CellKind.CustomCell typed cells.

private void grid1_OnCustomCellDraw(PlexityHide.GTP.Grid aGrid, PlexityHide.GTP.CustomCellEventArgs e)

{

e.G.DrawArc(new Pen(Color.Red,3),e.DrawRect,0,180);

e.G.DrawArc(new Pen(Color.Purple,3),e.DrawRect,180,180);

}

You can even handle edit in Custom cells by implementing events like OnCustomCellEdit.

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


Grid6

Grid Edit modes

When you use a comboBox as edit mode you can easily fill the selectable values like this:

private void grid1_OnBeforeEditCell(PlexityHide.GTP.Grid grid, PlexityHide.GTP.BeforeEditEventArgs beforeEdit)

{

if (beforeEdit.Cell.Content is ComboText)

{

(beforeEdit.Cell.Content as ComboText).EditBox.Items.Clear();

(beforeEdit.Cell.Content as ComboText).EditBox.Items.Add("Item 1");

(beforeEdit.Cell.Content as ComboText).EditBox.Items.Add("Item 2");

(beforeEdit.Cell.Content as ComboText).EditBox.Items.Add("Item 3");

(beforeEdit.Cell.Content as ComboText).EditBox.Items.Add("Item 4");

}

}

Other edit modes are date picker

And check box

And also normal edit and row wrap edit is available.

PlexityHide.GTP_gettingstarted.html

  • Grid

  • Adding data

  • Looks and CellLayouts

  • CellLayouts contiuned 1

  • CellLayouts continued 2

  • User draw and custom cells

  • Inline edit modes


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP.WEB
Gantt_ASPSettings Class Events
See Also Send comments on this topic.
PlexityHide.GTP.WEB Namespace : Gantt_ASPSettings Class

Glossary Item Box

For a list of all members of this type, see Gantt_ASPSettings members.

See Also

Reference

Gantt_ASPSettings Class
PlexityHide.GTP.WEB Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

PlexityHide.GTP.WEB
PlexityHide.GTP.WEB Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Glossary Item Box

Inheritance Hierarchy

System.Object
PlexityHide.GTP.WEB.CacheStats
PlexityHide.GTP.WEB.GetImage
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.WEB.Gantt_ASPSettings
System.EventArgs
PlexityHide.GTP.WEB.AreaAttributeEventArgs
PlexityHide.GTP.WEB.CalcFontDifferenceArgs
PlexityHide.GTP.WEB.CellContentTuningArgs
PlexityHide.GTP.WEB.CellDivArgs
PlexityHide.GTP.WEB.ClientClick_NodeKeyArgs
PlexityHide.GTP.WEB.GanttRowClickEventArgs
PlexityHide.GTP.WEB.TimeItemUserStringPrepareArgs
System.Web.UI.WebControls.WebControl
System.Web.UI.Control
PlexityHide.GTP.WEB.Gantt_ASP

See Also

Reference

PlexityHide.GTP.WEB Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

(Global) Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

PlexityHide.GTP Assembly


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
CustomCell Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : CustomCell Class

Glossary Item Box

For a list of all members of this type, see CustomCell members.

See Also

Reference

CustomCell Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
EditPickValueWindow Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : EditPickValueWindow Class

Glossary Item Box

For a list of all members of this type, see EditPickValueWindow members.

See Also

Reference

EditPickValueWindow Class
PlexityHide.GTP Namespace


%%PageItemTitle%%

[image]
PlexityHide.GTP
GridNode Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > GridNode Class : GridNode Constructor

Glossary Item Box

Overload List

Overload | Description
GridNode Constructor | Constructor used by collection editor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

GridNode Class
GridNode Members


%%PageItemTitle%%

[image]
PlexityHide.GTP
Layer Constructor
See Also Send comments on this topic.
PlexityHide.GTP Namespace > Layer Class : Layer Constructor

Glossary Item Box

Overload List

Overload | Description
Layer Constructor | Constructor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Layer Class
Layer Members


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
ModDateTimePicker Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModDateTimePicker Class

Glossary Item Box

For a list of all members of this type, see ModDateTimePicker members.

See Also

Reference

ModDateTimePicker Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ModDateTimePicker Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModDateTimePicker Class

Glossary Item Box

For a list of all members of this type, see ModDateTimePicker members.

See Also

Reference

ModDateTimePicker Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ModDateTimePicker Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModDateTimePicker Class

Glossary Item Box

For a list of all members of this type, see ModDateTimePicker members.

See Also

Reference

ModDateTimePicker Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
ModTextBox Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModTextBox Class

Glossary Item Box

For a list of all members of this type, see ModTextBox members.

See Also

Reference

ModTextBox Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
ModTextBox Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModTextBox Class

Glossary Item Box

For a list of all members of this type, see ModTextBox members.

See Also

Reference

ModTextBox Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
ModTextBox Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : ModTextBox Class

Glossary Item Box

For a list of all members of this type, see ModTextBox members.

See Also

Reference

ModTextBox Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Methods$$

[image]
PlexityHide.GTP
PanButton Class Methods
See Also Send comments on this topic.
PlexityHide.GTP Namespace : PanButton Class

Glossary Item Box

For a list of all members of this type, see PanButton members.

See Also

Reference

PanButton Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Events$$

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Class Events
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeAreaOffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see TimeAreaOffscreenDraw members.

See Also

Reference

TimeAreaOffscreenDraw Class
PlexityHide.GTP Namespace


%%PageItemTitle%% $$Properties$$

[image]
PlexityHide.GTP
TimeAreaOffscreenDraw Class Properties
See Also Send comments on this topic.
PlexityHide.GTP Namespace : TimeAreaOffscreenDraw Class

Glossary Item Box

For a list of all members of this type, see TimeAreaOffscreenDraw members.

See Also

Reference

TimeAreaOffscreenDraw Class
PlexityHide.GTP Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

PlexityHide.GTP Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Glossary Item Box

Inheritance Hierarchy

System.Object
PlexityHide.GTP.Calendar
PlexityHide.GTP.CalendarEntry
PlexityHide.GTP.Cell
PlexityHide.GTP.CellLayout
PlexityHide.GTP.CollisionNote
PlexityHide.GTP.CommonDataConnect
PlexityHide.GTP.ComparerForGridSort
PlexityHide.GTP.ConflictArea
PlexityHide.GTP.ContentEntity
PlexityHide.GTP.BoolCheck
PlexityHide.GTP.ComboText
PlexityHide.GTP.CustomCell
PlexityHide.GTP.MultiText
PlexityHide.GTP.SingleText
PlexityHide.GTP.TimeDate
PlexityHide.GTP.CountedBitmap
PlexityHide.GTP.DateScaleMark
PlexityHide.GTP.DateScalerProperties
PlexityHide.GTP.GanttRow
PlexityHide.GTP.GridColumn
PlexityHide.GTP.GridNode
PlexityHide.GTP.GridProperties
PlexityHide.GTP.GridStructure
PlexityHide.GTP.ImageMapLogic
PlexityHide.GTP.IMapArea
PlexityHide.GTP.LineOption
PlexityHide.GTP.LinkDataConnect
PlexityHide.GTP.ListWrapper
PlexityHide.GTP.NodeDataConnect
PlexityHide.GTP.NonLinearTime
PlexityHide.GTP.TimeDistinctItem
PlexityHide.GTP.TimeDistinctThread
PlexityHide.GTP.TimeItem
PlexityHide.GTP.TimeItemDataConnect
PlexityHide.GTP.TimeItemDraw
PlexityHide.GTP.TimeItemLayout
PlexityHide.GTP.TimeItemLink
PlexityHide.GTP.TimeItemLinks
PlexityHide.GTP.TimeItemText
PlexityHide.GTP.TimeItemTextLayout
System.Collections.CollectionBase
PlexityHide.GTP.CalendarCollection
PlexityHide.GTP.CalendarEntryCollection
PlexityHide.GTP.CellLayouts
PlexityHide.GTP.GridColumns
PlexityHide.GTP.GridNodes
PlexityHide.GTP.Layer
PlexityHide.GTP.Layers
PlexityHide.GTP.TimeItemLayouts
PlexityHide.GTP.TimeItemTextLayouts
PlexityHide.GTP.TimeItemTexts
System.EventArgs
PlexityHide.GTP.AfterEditEventArgs
PlexityHide.GTP.BeforeEditEventArgs
PlexityHide.GTP.BeforeEndEditEventArgs
PlexityHide.GTP.BeforeFocusedCellChangeEventArgs
PlexityHide.GTP.BeforeScaleOrSpanChangeArgs
PlexityHide.GTP.Calendar_UserDrawArgs
PlexityHide.GTP.CellAndDSArgs
PlexityHide.GTP.CellSelectChangedEventArgs
PlexityHide.GTP.CellTypeChooseEventArgs
PlexityHide.GTP.CollisionDetectEventArgs
PlexityHide.GTP.ColumnOrderArgs
PlexityHide.GTP.ConflictArea_UpdateArgs
PlexityHide.GTP.ConflictArea_UserDrawArgs
PlexityHide.GTP.CustomCellEventArgs
PlexityHide.GTP.DateScalerDrawBoxesEventArgs
PlexityHide.GTP.DateScalerDrawStringEventArgs
PlexityHide.GTP.EachListItemWhenDataBoundArgs
PlexityHide.GTP.ErrorEventArgs
PlexityHide.GTP.LayerEventArgs
PlexityHide.GTP.LinkActionEventArgs
PlexityHide.GTP.LinkAndDSArgs
PlexityHide.GTP.NodeEventArgs
PlexityHide.GTP.OffscreenDrawArgs
PlexityHide.GTP.OnUserDrawSortSymbolArgs
PlexityHide.GTP.PanEventArgs
PlexityHide.GTP.PreCursorChangeEventArgs
PlexityHide.GTP.RowResizeArgs
PlexityHide.GTP.RowResizeDoneArgs
PlexityHide.GTP.TimeItemAndDSArgs
PlexityHide.GTP.TimeItemEventArgs
PlexityHide.GTP.TimeItemLinkArgs
PlexityHide.GTP.TopLeftChangedEventArgs
PlexityHide.GTP.UnBindedSortArgs
PlexityHide.GTP.UnhandledExceptionArgs
PlexityHide.GTP.UserBrushCreateEventArgs
PlexityHide.GTP.UserDrawLinkEventArgs
PlexityHide.GTP.ViewDateInformationArgs
System.Windows.Forms.Button
System.Windows.Forms.ButtonBase
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.PanButton
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.Gantt
PlexityHide.GTP.OffscreenDraw
PlexityHide.GTP.DateScaler
PlexityHide.GTP.Grid
PlexityHide.GTP.TimeAreaOffscreenDraw
System.Windows.Forms.DateTimePicker
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.ModDateTimePicker
System.Windows.Forms.Form
System.Windows.Forms.ContainerControl
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.EditPickValueWindow
System.Windows.Forms.TextBox
System.Windows.Forms.TextBoxBase
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
PlexityHide.GTP.ModTextBox

See Also

Reference

PlexityHide.GTP Assembly


Time Items

Time items you will use to symbolize something with a distinct placement in time in your business domain. It could be an airline flight, a booked hotel room, a rented video, a scheduled stomach operation, the performed maintenance of a nuclear reactor or really anything that makes sense to your business domain. Gantt diagrams are commonly used to symbolize projects but the potential applications are endless.

A time item has a start date time and an end date time, but sometimes you want time items without end dates, like milestones in a project plan, or the marking of crashed cars in your car rental service. To achieve this you can set the FixedSizeUse and the FixedSize properties of the time items TimeItemLayoutProperty, but that is skipping ahead... Please read on.

PlexityHide.GTP_gettingstarted.html
  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


Time items 3

Time item drawing layers

Maybe your business domain calls for several time items on a single row but it is ok that they occupy the same space in time and you need to control their drawing order - their Z-order. If this is your case you can use the drawing layers available in Gantt rows:

private void SetUpDrawingLayerSample()

{

GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn.GetCell(0).Content.Value="Sample of drawing layers for time items";

GanttRow gr = GanttRow.FromGridNode(gn);

gr.CollisionDetect=false;

gr.Layers.AddLayer();

gr.Layers.AddLayer();

TimeItem ti1=gr.Layers[0].AddNewTimeItem();

TimeItem ti2=gr.Layers[1].AddNewTimeItem();

TimeItem ti3=gr.Layers[2].AddNewTimeItem();

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);

ti1.Stop=ti1.Start.AddDays(10);

ti2.Start=ti1.Start.AddDays(1);

ti2.Stop=ti1.Stop.AddDays(3);

ti2.TimeItemLayout= new TimeItemLayout();

ti2.TimeItemLayout.TopInset=8;

ti2.TimeItemLayout.BottomInset=8;

ti2.TimeItemLayout.Color=Color.Pink;

ti3.Start=ti2.Start.AddDays(1);

ti3.Stop=ti2.Stop.AddDays(3);

ti3.TimeItemLayout= new TimeItemLayout();

ti3.TimeItemLayout.TopInset=16;

ti3.TimeItemLayout.BottomInset=16;

ti3.TimeItemLayout.Color=Color.PeachPuff;

}

In this code we make use of drawing layers and also top and bottom insets of the time item layout to make time items appear thinner.

Output:

Drawing layers also control in which order clicks are handled. So if you click the pink one it will be selected, and the white one underneath will stay unselected.

PlexityHide.GTP_gettingstarted.html

  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


Time items 2

Time items collision detection

Sometimes when you have several time items on a single row you may want to use the automatic collision detection mechanism:

private void SetUpCollisionDetectSample()
{
  GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();
  gn.GetCell(0).Content.Value="Sample of collision detection for time items";
  GanttRow gr = GanttRow.FromGridNode(gn);

  gr.CollisionDetect=true;

  TimeItem ti1=gr.Layers[0].AddNewTimeItem();
  TimeItem ti2=gr.Layers[0].AddNewTimeItem();
  TimeItem ti3=gr.Layers[0].AddNewTimeItem();

  ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);
  ti1.Stop=ti1.Start.AddDays(2);

  ti2.Start=ti1.Stop.AddDays(1);
  ti2.Stop=ti2.Start.AddDays(3);
  ti2.TimeItemLayout= new TimeItemLayout();
  ti2.TimeItemLayout.Color=Color.PaleVioletRed;

  ti3.Start=ti2.Stop.AddDays(-1);
  ti3.Stop=ti3.Start.AddDays(3);
  ti3.TimeItemLayout= new TimeItemLayout();
  ti3.TimeItemLayout.Color=Color.PaleGoldenrod;
}

And the result from the code above looks like this:

Collision detections are handled asynchronous by the component.

PlexityHide.GTP_gettingstarted.html

  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


Time Items 4

Time Items texts

It is a common request to present some textual information inside a time item.

private void SetUpTimeItemTextSample()

{

GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn.GetCell(0).Content.Value="Sample of Texts inside time items";

GanttRow gr = GanttRow.FromGridNode(gn);

gr.CollisionDetect=false;

TimeItem ti1=gr.Layers[0].AddNewTimeItem();

TimeItem ti2=gr.Layers[0].AddNewTimeItem();

TimeItemText titext1=new TimeItemText();

titext1.Text="Sample text";

titext1.TimeItemTextLayout=gantt1.TimeItemTextLayouts.GetFromName("Default");

titext1.TimeItemTextLayout.Color=Color.PowderBlue;

titext1.TimeItemTextLayout.Font=new Font(FontFamily.GenericMonospace,14,FontStyle.Bold);

titext1.TimeItemTextLayout.Padding=new Rectangle(2,2,2,2);

titext1.TimeItemTextLayout.VertAlign=StringAlignment.Near;

ti1.TimeItemTexts.Add(titext1);

ti1.TimeItemLayout= new TimeItemLayout();

ti1.TimeItemLayout.Color=Color.SlateBlue;

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);

ti1.Stop=ti1.Start.AddDays(10);

TimeItemText titext2=new TimeItemText();

titext2.Text="Another text same layout";

titext2.TimeItemTextLayout=titext1.TimeItemTextLayout;

ti2.TimeItemTexts.Add(titext2);

ti2.Start=ti1.Stop.AddDays(1);

ti2.Stop=ti2.Start.AddDays(10);

ti2.TimeItemLayout= new TimeItemLayout();

ti2.TimeItemLayout.Color=Color.OrangeRed;

}

And the output of the code above:

Note: the text can be very well defined by utilizing the TimeItemTextLayout objects. You can control alignment, fonts, color etc.

PlexityHide.GTP_gettingstarted.html

  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


Time Items 5

Time Items styles

Depending on what you are representing with your time items you probably want to choose a presentation style that gives the user the correct association. Since we earlier stated that the possible applications for a Gantt component are almost endless it is virtually impossible to supply drawing styles that will leave everyone satisfied. To solve this problem we introduce the OnTimeItem_UserDraw event that let you, the developer, draw time item inside a box provided by the component and the component treats it as any other time item.

private void SetUpTimeItemStyleSample()

{

GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn.GetCell(0).Content.Value="Sample of time item styles";

GanttRow gr = GanttRow.FromGridNode(gn);

gr.CollisionDetect=false;

TimeItem ti1=gr.Layers[0].AddNewTimeItem();

TimeItem ti2=gr.Layers[0].AddNewTimeItem();

TimeItem ti3=gr.Layers[0].AddNewTimeItem();

TimeItem ti4=gr.Layers[0].AddNewTimeItem();

TimeItem ti5=gr.Layers[0].AddNewTimeItem();

TimeItem ti6=gr.Layers[0].AddNewTimeItem();

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);

ti1.Stop=ti1.Start.AddDays(3);

ti1.TimeItemLayout=new TimeItemLayout();

ti1.TimeItemLayout.TimeItemStyle=TimeItemStyle.LineWEnd;

ti2.Start=ti1.Stop.AddDays(1);

ti2.Stop=ti2.Start.AddDays(4);

ti2.TimeItemLayout=new TimeItemLayout();

ti2.TimeItemLayout.TimeItemStyle=TimeItemStyle.Romb;

ti3.Start=ti2.Stop.AddDays(1);

ti3.Stop=ti3.Start.AddDays(4);

ti3.TimeItemLayout=new TimeItemLayout();

ti3.TimeItemLayout.TimeItemStyle=TimeItemStyle.Span;

ti4.Start=ti3.Stop.AddDays(1);

ti4.Stop=ti4.Start.AddDays(4);

ti4.TimeItemLayout=new TimeItemLayout();

ti4.TimeItemLayout.TimeItemStyle=TimeItemStyle.Square;

ti5.Start=ti4.Stop.AddDays(1);

ti5.Stop=ti5.Start.AddDays(4);

ti5.TimeItemLayout=new TimeItemLayout();

ti5.TimeItemLayout.TimeItemStyle=TimeItemStyle.Image;

ti6.Start=ti5.Stop.AddDays(1);

ti6.Stop=ti6.Start.AddDays(4);

ti6.TimeItemLayout=new TimeItemLayout();

ti6.TimeItemLayout.TimeItemStyle=TimeItemStyle.User;

}

And the implenation of the UserDraw event

private void gantt1_OnTimeItem_UserDraw(PlexityHide.GTP.Gantt aGantt, PlexityHide.GTP.TimeItemEventArgs e)

{

e.G.DrawArc(new Pen(Color.RosyBrown,4),e.Rect,0,180);

e.G.DrawArc(new Pen(Color.PowderBlue,6),e.Rect,180,180);

}

And the output from this sample code is:

These look very plain but remember that you can customize the look by the time item layouts... Please read on.

PlexityHide.GTP_gettingstarted.html

  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


Time Items 6

Time Item Layouts

Time item layouts are separated from time items into their own class. This conserves memory when you render many time items with the same look and feel. One TimeItemLayout will typically serve many time items.

private void SetUpTimeItemLayoutSample()

{

GridNode gn=gantt1.Grid.GridStructure.RootNodes.AddNode();

gn.GetCell(0).Content.Value="Sample of time item layouts";

GanttRow gr = GanttRow.FromGridNode(gn);

gr.CollisionDetect=false;

TimeItem ti1=gr.Layers[0].AddNewTimeItem();

TimeItem ti2=gr.Layers[0].AddNewTimeItem();

TimeItem ti3=gr.Layers[0].AddNewTimeItem();

ti1.Start=gantt1.DateScaler.StartTime.AddDays(1);

ti1.Stop=ti1.Start.AddDays(3);

ti1.TimeItemLayout=new TimeItemLayout();

ti1.TimeItemLayout.BrushKind=BrushKind.GradientDiagonal;

ti1.TimeItemLayout.Color=Color.YellowGreen;

ti1.TimeItemLayout.GradientColor=Color.Yellow;

ti2.Start=ti1.Stop.AddDays(1);

ti2.Stop=ti2.Start.AddDays(4);

ti2.TimeItemLayout=new TimeItemLayout();

ti2.TimeItemLayout.FrameColor=Color.Red;

ti3.Start=ti2.Stop.AddDays(1);

ti3.Stop=ti3.Start.AddDays(4);

ti3.TimeItemLayout=new TimeItemLayout();

ti3.TimeItemLayout.Color=Color.PowderBlue;

ti3.TimeItemLayout.Shadow=true;

ti3.TimeItemLayout.ShadowColor=Color.Gray;

}

And the output:

Note: If you combine all these possibilities of time item properties you will be able to construct very distinct and well defined Gantt charts.

PlexityHide.GTP_gettingstarted.html

  • Time items

  • Collision detection

  • Drawing layers

  • Texts

  • Styles

  • Layouts


UML Class Diagram

The core components of the Gantt is the hierarchical Grid and the DateScaler. Together they define the Y-Axis and the X-Axis for the time items. The use of Layout classes (purple in diagram) enables effective reuse of aural properties of objects such as time items, grid cells and time item texts. It is likely that you have several time items sharing the same TimeItemLayout. The time item layout holds definition about color and drawing style of the time item. If you have 1000 time items all using the same TimeItemLayout you use up very little memory and system resources on the things that the time items share (aural and behavioral properties). This design pattern is important when your data visualization needs grow in size.


Online samples

Online samples GTP.NET

In the following pages you will learn about specific areas of the GTP.NET components so that you can make better use of the components in your own projects. The samples are kept simple so in order solve a real business case you will need to combine an understanding of several of these samples.

The samples in this section are all constructed in C#. C# is a popular .NET languages and it is also easy to translate to VB.NET and Delphi.NET.

Do you miss a specific topic? Please let us know, we encourage user demand and initiative. support@plexityHide.com.

UML class diagram of the GTP.NET components

Time items

Collision detection

Drawing layers

Texts

Styles

Layouts

Date scaler

Zooming

Traversing in time

Time hiding

Day hiding

Fish eye

Grid

Adding data

Looks and CellLayouts

CellLayouts contiuned 1

CellLayouts continued 2

User draw and custom cells

Inline edit modes

Datasource

Connecting