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About ePublisher Express
WELCOME

Welcome to the User Manual for ePublisher Express. The User Manual will 
familiarize you with ePublisher Express’ features and capabilities. By learning 
how to utilize the features in ePublisher Express, you can maximize the full 
capabilities of the application to create your desired online Help output. 

Users of all skill levels can use this guide to perform common tasks such as 
creating projects, generating online content, generating conformance reports, and 
setting project preferences.

About ePublisher Express
ePublisher Express is part of WebWorks’ ePublishing solution. It provides a way 
for writers to create content within a single authoring environment and quickly 
produce online output. With ePublisher Express, writers bypass the hassle of 
spending time and resources learning new software like ePublisher Pro; instead, 
writers can instantly benefit from the power and capabilities of ePublisher Pro. 
ePublisher Express is similar to ePublisher Pro except it does not contain a 
Document Designer, Style Designer, and built-in output formats.

ePublisher Express provides a fast and easy way to create online Help. It serves 
two main purposes: to generate output and to serve as a proofing tool. 

To generate output, ePublisher Express takes the information defined with the 
standalone stationery file and uses it to convert your source documents into your 
desired online Help format. The overall appearance of your output depends on 
the style and formatting information defined within the standalone stationery file. 

To ensure that your source documents conform to the style and formatting 
information defined within the standalone stationery file before distributing it 
online, you can generate conformance reports through ePublisher Express. 
Conformance reports serve as proofing tools that indicate where potential errors 
occur in your source documents.
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What Are the Benefits of Using ePublisher Express?

ePublisher Express lets you concentrate on producing high-quality content within 
a single authoring environment and spend less time on designing, implementing, 
and delivering online output. As a writer, you can now simply create your content 
using the template provided by your stationery designer and quickly generate 
output using the standalone stationery file in ePublisher Express.

ePublisher Express improves the documentation process by implementing 
template and stationery usage, which ensures that your output conforms to the 
standards established by the stationery designer. To ensure that your source 
documents adhere to the style and formatting rules defined within the stationery 
file, you can generate conformance reports in ePublisher Express. The 
conformance reports inform and direct you to where specific problems occur in 
your source documents.

Some other benefits of ePublisher Express include:

• Proofing tools

• Fast and efficient online Help conversion

• Template and stationery usage

• Output delivery options

• Merged Help options

• Cross-reference, variables, and conditions editors

How Does ePublisher Express Work?

The first step in producing any type of output is creating an ePublisher Express 
project, which must link to a standalone stationery file and contain source 
documents. ePublisher Express then creates output for your source documents 
using information in the standalone stationery file.

Within your source documents, you should have applied styles your content. The 
style names are important because ePublisher Express uses them to determine 
which styles from the standalone stationery to apply to your output. 

In order to determine what style information to use, ePublisher Express looks to 
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the standalone stationery file, which contains a list of all the style names and their 
style definitions. The style definitions include information like font styles, text 
size, border styles, and margins. ePublisher Express matches the style name from 
the source document to the style name in the standalone stationery file. If the 
style names match, ePublisher Express retreives the formatting information from 
the standalone stationery and applies it to the content.

For example, if you are using Heading 1s in your source document, and Heading 
1 is defined in your standalone stationery with the following style attributes:

Font-family: Times New Roman

Font-size: 12pt

Font-weight: Bold

Text-color: Blue

then any content that uses a Heading1 style will inherit this style information. 

The ePublisher Express Workflow

The basic ePublisher Express workflow involves the following steps:

1. Create your content using the source template provided by your stationery 
designer.

2. Create an ePublisher Express project based on the standalone stationery 
associated with your source template.

3. Add your source documents to the project.

4. Generate conformance reports.

5. Address any issues indicated in the conformance reports.

6. Generate output.

7. Deploy the generated output.

Commonly Used Terminology
The following section explains the commonly used terms in this manual.
WebWorks ePublisher Express User Guide 3
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Template

A template refers to a set of pre-designed formats on which new source 
documents can be based and offers writers a standardized format on which to 
base their content, thus promoting uniformity and conformity. It is a blank, 
reusable document that contains predefined style and formatting information that 
writers can use to create a new document.

Standalone Stationery

A standard stationery file contains the style information, cross-reference 
definitions, conditions settings, variable values, and format settings from an 
ePublisher Pro project; however, a standalone stationery file is essentially a 
standard stationery file, except with one exception: it contains output format 
information.

Each output format (e.g., WebWorks Help 5.0, HTML Help, JavaHelp, Dynamic 
HTML, etc.) requires certain files to generate output; without them, the formats 
would not have the necessary components to create the Help system. We do not 
ship any formats with ePublisher Express; therefore, standalone stationery is 
necessary because it provides ePublisher Express with the necessary files to 
generate output for the target formats specified in your project. 

In order to create standalone stationery, the stationery designer first must create 
an ePublisher Pro project. Once the stationery designer has finalized the project, 
the project needs to be saved and packaged as standalone stationery. Once the 
stationery designer saves the ePublisher Pro project as a standalone stationery 
file, all of the style information, settings, and definitions from the project will be 
added to the stationery file. ePublisher Pro will also copy over the necessary 
format files and save it as part of your standalone stationery.

Once the stationery designer has finished the standalone stationery file, it needs 
to be distributed all ePublisher Express users. If the stationery designer moves or 
deletes the standalone stationery from the location from which ePublisher 
Express projects are accessing it, then the ePublisher Express will alert you that it 
cannot find the location of the standalone stationery file. If this occurs, you will 
need to update your project and direct it to the new location of the standalone 
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stationery or point it to a new standalone stationery file.

Project

A project creates and produces online output; it is the .wrp file that you use to 
generate your output. When you create a new project, you are creating a new 
.wrp file that will contain the source documents, project customizations, and files 
that will be used to generate online output. After you have created a project, you 
will have the ability to add source documents and groups, modify your project 
preferences, generate conformance reports, and produce output. 

Output Format

Output format refers to the type of Help format you wish to create. There are two 
types of Help formats available: online Help formats and HTML formats. Online 
Help formats include WebWorks Help5.0, Microsoft HTML Help 1.x, Microsoft 
WinHelp, Sun JavaHelp 1.1.3, Sun JavaHelp 2, and Oracle Help. HTML formats 
include Dynamic HTML and Simple HTML.

Format Target

Format targets are based on output formats (e.g. WebWorks Help 5.0, HTML 
Help, WinHelp, DHTML, etc.) and are unique to each stationery file. A format 
target refers to the output that you would like the generate and the format settings 
associated with it.

Conformance Reports

There are five types of conformance reports: 

1. Styles

2. Filenames

3. Links

4. Topics

5. Accessiblity

Each report provides you with data with which you can use to proof your source 
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documents. Conformance reports indicate where discrepancies exist between 
your source document and standalone stationery and alert you when potential 
problems occur.
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Before Installing ePublisher Express
INSTALLING EPUBLISHER 
EXPRESS

This section provides you with the necessary information to download and install 
ePublisher Express. It is important that you read this section before installing 
ePublisher Express to ensure that you have all the necessary system requirements 
to support the software. 

Prior to installing ePublisher Express, please read the section “Before Installing 
ePublisher Express” on page 7, which details the system requirements and the 
necessary precautions to take before installing ePublisher Express. This ensures 
that you do not encounter any major problems during the installation process.

Before Installing ePublisher Express
It is highly recommended that you satisfy each of the criteria listed below before 
proceeding with the installation.

Before installing ePublisher Express, you must:

• Close Microsoft Word and/or Adobe FrameMaker.

• Close Microsoft Outlook (if Microsoft Word is your e-mail editor).

• Verify that your computer meets the minimum system requirements. For 
more information, please see “Minimum System Requirements” on page 7.

• Have Microsoft Word or Adobe FrameMaker installed on your system.

• Have Microsoft .NET Framework 2.0 installed on your system.

• Uninstall any previous versions of ePublisher Express.

Minimum System Requirements

• Microsoft Windows 2000 (Service Pack 4) or greater

• Microsoft Internet Explorer 5.5 or greater (with JavaScript enabled)
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Installing ePublisher Express
• Adobe FrameMaker 6.0 or greated

• Microsoft Word 2000 or greater

• Minimum 512 MB RAM

• Minimum 100 MB free hard disk space

• Pentium IV or AMD equivalent processor

• 800 x 600 display screen resolution

• Microsoft .NET Framework 2.0

Recommended System Requirements

• Microsoft Windows XP

• Microsoft Internet Explorer 6.0 (with JavaScript enabled)

• Adobe FrameMaker 7.2

• Microsoft Word 2003

• Minimum 1 GB RAM

• Minimum 200 MB free hard disk space

• 3 GHz or faster Pentium IV or AMD equivalent processor

• 1280 x 1024 display screen resolution (dual monitors supported)

• Microsoft .NET Framework 2.0

Downloading ePublisher Express

The latest version of our software is availble from our download center. Please 
visit the download center and download the latest ePublisher Express installer. 

We recommend you check our website for updated builds of the software, which 
contain fixes to known software defects and software enhancements.

License Keys

Once you have completed the purchasing process, Quadralay's sales team will e-
mail you the ePublisher Express license keys. If you have not received a license 
key, or are having problems with your license key, please contact Quadralay's 
sales team.
8 WebWorks ePublisher Express User Guide
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Installing the Software
You must enter your license key information before generating output with our 
product. If you have not entered your license key information, you will receive 
an error stating that no license key was found to enable support for your 
authoring tool. If you are receiving this error, please verify you have entered your 
license key information correctly.

To add a license key:

1. In ePublisher Express, select Help > License Keys.

2. Enter your license key in the Key field.

3. Click the Add Key button.

4. Click OK to close the License Key window.

To delete a license key:

1. In ePublisher Express, select Help > License Keys.

2. Select the key you would like to delete.

3. Click the Delete Key button.

4. Click OK to close the License Key window.

Installing the Software
You can obtain ePublisher Express from Quadralay’s Web site. To download 
ePublisher Express, please see “Downloading ePublisher Express” on page 8. 
Please be sure to have your license key information ready and register your 
software when the installation process completes.

To install ePublisher Express:

1. Download the installer for ePublisher Express from the WebWorks Download 
Center.

2. Read “Before Installing ePublisher Express” on page 7.

3. Double-click on the WebWorks ePublisher Express.msi file.

4. When the Welcome screen displays, click Next to advance to the next screen.
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Installing ePublisher Express
Figure 3-1: The Welcome Screen

5. The next screen is the license agreement. Select the I Agree option, and click 
the Next button to proceed with the installation. 
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Installing the Software
Figure 3-2: The License Agreement

6. On the next screen, select the shortcuts you would like to create.
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Installing ePublisher Express
Figure 3-3: Application Shortcuts

7. Click the Next button to advance to the next screen.

8. The next screen enables your ability to modify the format settings, condition 
settings, variable values, and cross-reference definitions within your 
ePublisher Express project. 

Note:  If you do not select this option, you will not be able to modify format 
settings, condition settings, variable values, or cross-reference definitions. 
The selection you make here will be the default behavior in the application; if 
you wish to change the behavior once the installation is complete, you must 
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Installing the Software
uninstall and reinstall ePublisher Express. For more information on 
uninstalling ePublisher Express, please see “Uninstalling ePublisher 
Express” on page 17.

Figure 3-4: Settings and Preferences Window

9. Click the Next button to advance to the next screen, where you can choose 
the location of your installation directory.
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Installing ePublisher Express
Figure 3-5: Installation Location

10. Click the Browse button to select a different installation location or leave the 
default installation location, which is C:\Program Files\WebWorks.

11. After specifying an installation location, click the Next button.

12. The next screen alerts you that it is ready to install ePublisher Express. Select 
the Next button to install ePublisher Express.
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Installing the Software
Figure 3-6: Installation Confirmation Screen

After clicking the Next button, the progress window will display.
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Installing ePublisher Express
Figure 3-7: Installation Progress Window

13. Towards the conclusion of the installation, the license key dialog will appear 
prompting you to add a license key. Type in the license key, and click on the 
Add Key button.
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Uninstalling ePublisher Express
Figure 3-8: License Key Information

14. Click OK to close the License Information dialog box.

15. When the HTML Help Workshop 1.3 Setup dialog displays, select the Yes 
button if you want to install HTML Help Workshop or select the No button if 
you do not want to install HTML Help Workshop. For more information 
about HTML Workshop, please visit Microsoft’s Web site.

Figure 3-9: HTML Help Workshop Installation Prompt

16. Once you have selected an option for HTML Workshop, the installation 
process is complete.

Uninstalling ePublisher Express
Before installing any newer versions of ePublisher Express, you must uninstall 
the existing version from your computer. When you uninstall ePublisher Express, 
it will remove the ePublisher Express installation folder and registry entries from 
your system. If ePublisher Express is the only WebWorks product you have 
installed on your system, the Transit menu and its registries will also be removed.

To uninstall ePublisher Express:

1. Click on the Start menu.

2. Select Control Panel > Add or Remove Programs.

3. Select WebWorks ePublisher Express from the list of programs.

4. Select the Remove button.
WebWorks ePublisher Express User Guide 17
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Installing ePublisher Express
Troubleshooting Installation Issues
This section addresses issues with:

Software Removal

License Keys

Microsoft .NET Framework 2.0

Microsoft Word

Problems Uninstalling ePublisher Express

If you are receiving any type of error while uninstalling ePublisher Express and 
are unable to continue, please submit a support request.

When this issue arises, you will have to download and install the Windows 
Installer Cleanup Utility, which will allow you to remove ePublisher Express 
from your system. If you already have the Windows Installer Cleanup Utility 
installed on your system, please skip step 1.

If you are unable to uninstall ePublisher Express:

1. Visit Microsoft’s Website and download and install the Windows Installer 
Cleanup Utility.

2. Launch the Windows Installer Cleanup Utility.

3. Find and select WebWorks ePublisher Express from the list of installed 
products.

4. Click on the Remove button.

5. A dialog will display, alerting you that the product will be deleted from the 
Windows Installer database. Click OK to remove ePublisher Express.
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Troubleshooting Installation Issues
Figure 3-10: Warning from Windows Installer Cleanup Utility

6. Navigate to C:\Program Files\WebWorks.

7. Verify that the ePublisher Express is no longer in that location. If the folder 
still exists, delete it.

Obtaining a License Key

If you did not receive a license key for ePublisher Express, please contact our 
sales team to obtain one. You must have a valid license key to generate output in 
ePublisher Express.

Downloading Microsoft .NET Framework 2.0

To get the latest version of Microsoft .NET 2.0, please visit the Microsoft .NET 
Framework Developer Center. You will need to download and install the .NET 
Framework 2.0 Redistributable Package. You do not need the Software 
Development Kit.

Closing Down Word Processes

If you have any Word processes running, the following error will display: 
WebWorks ePublisher Express User Guide 19
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Installing ePublisher Express
Figure 3-11: Transit Warning 

If you are encountering this error, please try the following:

1. Close any running instances of Microsoft Word.

2. Close Microsoft Outlook.

3. Open the Task Manager.

4. Click on the Processes tab.

5. Search for WINWORD.EXE. If there is a WINWORD.EXE process running, 
proceed to step 6; however, if there are no WINWORD.EXE processes 
running, proceed to step 9.

6. Click on the Image Name bar to sort the processes alphabetically.

7. Select WINWORD.EXE.

8. Click on the End Process button to close all running Word processes.

9. The following message will display. Select Yes to proceed.
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Troubleshooting Installation Issues
Figure 3-12:Task Manager warning

10. Close the Task Manager, and proceed with your ePublisher Express 
installation.
WebWorks ePublisher Express User Guide 21
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The Evaluation Guide
SUPPLEMENTAL MATERIALS

In order to familiarize you with ePublisher Express’ features and capabilities, 
there are supplemental materials that will walk you through the software. Besides 
supplying a sample source template and standalone stationery file for you to use, 
we have included the Evaluation Guide, which will walk you through creating a 
project with the sample source template and standalone stationery file.

The Evaluation Guide
The Evaluation Guide walks you through the ePublisher Express workflow - 
from creating a new project to viewing the final output - to show you how 
creating online Help can be simple and fast. The purpose of the Evaluation Guide 
is to provide you with an understanding of how ePublisher Express works and 
how it fits in the WebWorks ePublishing solution.

The Evaluation Guide is intended for evaluators so that they can preview how 
ePublisher Express works and to get an idea of ePublisher Express’s capabilities; 
however, the Evaluation Guide is also a good starting point for any new user 
because it utilizes the sample stationery file and template and provides you with 
an overview of the basic functionalities in ePublisher Express.

About the Evaluation Period

The evaluation period provides you with an opportunity to work with ePublisher 
Express. The purpose of the evaluation period is to get you quickly acquainted 
with ePublisher Express’ features and capabilities and to show you how 
ePublisher Express promotes style conformance and quality control. 

To demonstrate the ePublisher Express workflow, we have provided you with the 
necessary components to get started with ePublisher Express: a source template 
and a sample standalone stationery. Both of these items work together to create a 
complete and usable Help system. 
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Evaluation Materials

The sample template and standalone stationery files are in the Evaluation 
Materials folder, which is located in the installation directory of ePublisher 
Express. The default location for the Evaluation Guide is C:\Program 
Files\WebWorks\ePublisher Express\Evaluation Materials.
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THE USER INTERFACE

Four windows compose the ePublisher Express user interface:

• The Start Page

• The Document Manager

• The Output Explorer

• The Log Window

The Start Page

The 
Document 
Manager

The 
Output 
Explorer

The Log 
Window
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The User Interface
Figure 5-1: The User Interface

The Start Page
The Start Page lists the most recently opened ePublisher Express projects. You 
can click on any of the project names to open the project file. The number of 
projects displayed on the Start Page depends on settings in the project’s 
preferences. 

Figure 5-2: The Start Page

To select the number of projects that display on the Start Page:

1. In ePublisher Express, select Edit > Preferences.

2. From the General tab, find the option Recent projects to remember.

3. In the field next to the option, type in the number of projects you wish 

Create New 
Project button

Open Existing 
Project button

Links to 
recently 
opened 
projects
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ePublisher Express to display on the Start Page.

Note:  The maximum number you can enter is 99.

4. Click OK to close the Preferences window.

To clear the list of projects displayed on the Start Page:

1. In ePublisher Express, select Edit > Preferences.

2. From the General tab, click the Clear List button, which is located next to the 
Recent projects to remember field.

The Document Manager
The Document Manager lets you organize the source documents in your project. 
Within the Document Manager, you can add, remove, and rearrange the groups 
and source documents in your project. There are three components that can be 
found in the Document Manager: source documents, top-level groups, and 
subgroups.

Figure 5-3: The Document Manager

What Are Groups?

Groups are containers that hold your source documents and allow you to create 
the organizational structure for your Help system. When you first create a new 
project, ePublisher Express will automatically create a new group based on the 

Top-level Group

SubgroupSource 
Documents
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project name and add it to the Document Manager. In the Document Manager, 
groups are broken into two categories: top-level groups and subgroups; see 
Figure 5-4.

Figure 5-4: Top-level Groups and Subgroups

Top-level Groups 

A top-level group is the primary container that holds all of your source 
documents and subgroups, and it is the main group under which the entry-point 
file will be created. The entry-point file is composed of all the generated output 
files contained within the top-level group, and it is the file that launches your 
entire Help set. Since each top-level group generates its own entry-point file, 
these groups are particularly important when merging multiple Help sets. If you 
are creating multivolume help, top-level groups serve as the primary volume 
under which all of your table of contents levels are contained.

Top-level groups allow you to break your Help set into multiple and separate 
volumes; for example, if you want to create a Help set that contains a User’s 
Guide and a Developer’s Guide, then you would need to create two top-level 
groups called User’s Guide and Developer’s Guide. Once you have created your 
top-level groups, you can then create subgroups.

Top-level 
Group

Subgroup
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Subgroups

Unlike top-level groups, subgroups do not create a generated entry-point file. 
Instead, subgroups are virtual folders that provide you with a way of organizing 
the source documents within top-level groups. These subgroups serve as a visual 
aid for you to organize your source documents within their respective top-level 
groups. Subgroups are merely a means of arranging and categorizing source 
documents within top-level groups and do not represent an actual volume or table 
of contents level in a generated Help set.

Adding, Removing, and Rearranging Groups

Groups are virtual containers that hold your source documents and allow you to 
manage the organizational flow of your content. By default, when you first create 
a new project, a new group based on the project name will be added to the 
Document Manager. A group can either be a top-level group or a subgroup. If the 
group will be the primary container for all of the source documents and 
organizational levels within your output, then it will be a top-level group. If the 
source documents within a top-level group need to be further organized, then 
subgroups need to be created. Subgroups are simply virtual folders that allow you 
to organize your source documents into a more visibly coherent layout in the 
Document Manager. 

Adding Groups

In order to add source documents to a project, there must always be at least one 
group in the Document Manager. A group based on the project’s name will 
automatically be added to the Document Manager when you first create a project; 
therefore, you will be able to add source documents to your project. 

To add a group to your project: 

n Select Project > New Group. 

Adding Subgroups

You can add subgroups, or groups within other groups, to your project to 
organize the source documents in your project into a hierarchy, perhaps 
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representing the folder hierarchy where the original source documents are stored. 
Subgroups are basically virtual folders that allow you to rearrange the source 
documents in your project. By rearranging your source documents into 
subgroups, you can organize how the source documents are displayed in the 
Document Manager.

To add a subgroup to your project:

1. Select the group for which you want to add a subgroup. 

2. Select Project > New Group. 

Renaming Groups

If you want an existing group to have a different name, you can rename it. For 
example, by default, when you create a new project, ePublisher Express will 
create a new group based on the project name. Oftentimes, you will want to 
change the default name of the group that is added to your project.

To rename a group: 

1. Click on the group you want to rename. 

2. Enter a name for the group. 

3. Press Enter or click outside of the typing area to change the name.

Removing Groups

If a group is no longer being used, you can remove the group from the Document 
Manager. When you remove a group from your project, any documents 
associated with that group will also be removed from your project. The 
documents are not deleted from your computer but are removed from the current 
project.

To remove a group: 

1. Click to select the group you want to delete. 

2. From the menu bar, choose Edit > Remove.
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Adding, Removing, Rearranging, and Relinking Source Documents

Without source documents, ePublisher Express would not be able to populate 
style information, and there would be no content to generate output with. By 
using the Document Manager, you can add or remove source documents from 
groups, rearrange the order of source documents within groups, and relinking 
source documents with broken file paths. 

Adding Source Documents to a Project

When you create a new project, a top-level group is automatically placed in the 
Document Manager, and if you opted to add source documents, then the group 
will contain all these source documents. If you need to add more source 
documents, there are multiple ways to do so. 

To add a document to your project: 

1. In the Document Manager, click to select the group to which you would like 
to add the source document, and do one of the following: 

• Choose Project >Add Document. 

• Right-click on the group name, and select Add Document from the 
contextual menu.

• Drag and drop a document into ePublisher Express.

2. If you chose one of the first two options, an Open dialog box will display. In 
the Open dialog, choose the source file you want to add to the project and 
then click Open.

Note:  If no files appear in the Open dialog, select the type of document you 
are trying to add from the Files of type drop-down menu.

Rearranging Source Documents in a Project

Once you have added source documents to the groups within the Document 
Manager, you can rearrange and move the source documents within the same 
group or move them to a new group. 

To change the order of documents within a group: 
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1. In the Document Manager, click the document you want to move. 

2. Drag the document to the desired location within the group. 

To move a document into a different group: 

1. In the Document Manager, click the document you want to move. 

2. Drag the document to the desired location within the new group. 

Opening Source Documents from the Document Manager

If you need to edit any content or information within your source documents, you 
will need to open the source document.When you add source documents to the 
groups within the project, the source documents listed in the Document Manager 
serve as a link to the original source document. When you double-click on a 
source document in the Document Manager, the source document will open. 

Relinking Documents

Sometimes, the link to a particular source document’s original location path may 
get broken. This could be because the document was moved to another location, 
deleted, or somehow became corrupt. When this happens, ePublisher Express 
will display a Broken Link icon next to the document in the Output Explorer and 
in the Document Manager. 

To relink your source documents:

1. Double-click on the Broken Link  icon next to the source document in the 
Document Manager.

2. In the dialog box, browse to the new location of the document.

3. Select the document

4. Click the Open button.

Removing Documents

You can remove documents from an ePublisher Express project; however, any 
styles that are associated with that specific source document will remain in the 
Style Designer. For example, if UserManualTitle is only specific to one 
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particular document in your project, and you remove that document from the 
project, the style name UserManualTitle and its style information will remain 
in the Style Designer.

To remove a document from a project: 

1. In the Document Manager, click the document you wish to remove. 

2. Do one of the following: 

• Choose Edit > Remove. 

• Right-click and choose Edit > Remove from the contextual menu. 

• Press Delete. 

3. Click Yes to remove the document from your project, or click No to keep the 
document in your project. 

Note:  If you have set properties or options for any styles in your project that 
are only found in the document you are removing, those styles and settings 
will be removed from your project when you remove the document.

The Output Explorer
The Output Explorer allows you to view your generated output files. Whenever 
you generate output, the generated output files will be listed in the Output 
Explorer. The output files that display in the Output Explorer depends whether 
you have the source document or top-level group selected in the Document 
Manager. If you have the top-level group selected, then the Output Explorer will 
display the entry-point file; if you have a source document selected, the Output 
Explorer will display the individual topic pages.
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Figure 5-5: Top-level Group Selected in Document Manager
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Figure 5-6: Document Selected in Document Manager

Within the Output Explorer, the Navigation group contains either your entry-
point file or generated table of contents and index files depending on what active 
target you have selected in your project; see Figure 5-5 and .Figure 5-6. The Files 
folder contains all of the generated topic files, the Images folder contains all of 
the generated images for your online output, and the Reports folder contains your 
conformance reports.
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Note:  Merged output is only available if your project is set up to create 
multivolume Help.

The Log Window
The Log Window identifies where errors occur when generating output or 
reports. Every time you generate output or conformance reports, the Log 
Window displays the status of the generation process. It logs which pipelines are 
being processed; settings are being applied; and files are being parsed.

Any time you generate output or reports, ePublisher Express creates an external 
log file. If you need to submit support requests, you can send this log file to the 
support team at Quadralay. The log is named generate.log.

Table 6:  Output Files in the Output Explorer

Selection in Document Manager Files Displayed in Output Explorer

Top-level Group Merged output, entry-point file, 
conformance reports

Source Document Merged output, topic pages, images, 
reports

Subgroup Merged output
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Figure 5-7: The Log Window

To view the Log Window:

n In ePublisher Express, select View > Log Window.

To view the log file:

1. Navigate to C:\Documents and Settings\USERNAME\My 
Documents\ePublisher Express Projects\PROJECTNAME\Logs\FORMAT, 
where USERNAME is the name you use to sign onto your computer, 
PROJECTNAME is the name of your ePublisher Express project, and 
FORMAT represents the target format that you are using. The log will be 
called generate.log.

To save a text file of the log:

1. Click on the save button, which is located in the Log Window.

2. When the Save As window appears, enter a name for the log file in the File 
name field.

3. Navigate to the location where you would like to save the log file.

4. Click the Save button.

Menu

Save 
button

Autohide Close
butto
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WORKING WITH PROJECTS

A project consists of all the necessary pieces needed to convert your source 
documents to online output. An ePublisher Express project contains your source 
documents, standalone stationery, and any settings or preferences you have 
specified. After you have created a project, you can modify your project 
preferences, generate conformance reports, and produce output. 

Creating Projects
The first step in creating output in ePublisher Express is to create a project. When 
you create a project, you will select a standalone stationery file and the source 
documents the project will use to generate output. 

When the project is created, it will inherit the information contained within the 
standalone stationery file – such as style information, conditions settings, cross-
reference definitions, Format Settings information, and variable values. 

To create a project in ePublisher Express:

1. Launch WebWorks ePublisher Express.

2. Select File > New Project.

3. In the Project Name field, enter a name for your project.

4. In the Location field, choose a directory to store your ePublisher Express 
projects. By default, projects will be stored at C:\Documents and 
Settings\[USERNAME]\My Documents\ePublisher Express Projects.

5. Click on the folder icon next to the ePublisher Standalone Stationery field. 

6. Browse to the location of your standalone stationery.

7. Select a standalone stationery (.wxsp) file.

8. Click the Open button.

9. Click the Next button.
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Note:  You can create an empty project at this point and add your source 
documents later. If you wish to create an empty project, skip step 10.

10. On the next screen, click on the Add button to browse for source documents 
to add to the project.

11. Click the Finish button to create the project.

Scanning Documents
There are two options for scanning: 

1. Scan All 

2. Scan Selected documents. 

When you choose Scan All Documents, you are scanning all of the documents in 
your project; when you choose to Scan Selected, you are scanning a specific item 
in (such as a document, book, or master document). 

The following sections will discuss how to set the scanning options for a project, 
how to scan a single source document, and how to scan all source documents in a 
project.

When to Scan Documents

Scan your source documents when you have made any of the following changes 
to your source template:

• Added new style information

• Modified any existing styles 

• Added new variables, markers, or conditions 

• Modified existing variables, markers, or conditions

Setting the Scanning Option

The scanning process can be time-consuming. You can reduce the amount of time 
that ePublisher Express takes to scan your documents by setting the scanning 
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option to scan your documents manually. You can either opt to have ePublisher 
Express prompt you to scan your source documents or you can choose to never 
have ePublisher Express scan your source documents; in the latter case, you will 
need to remember to manually scan your source documents whenever any 
changes to the styles, conditions, variables or markers have been made.

To set the scanning options: 

1. Go to Edit > Preferences.

2. For the option to Scan added documents, select one of the following:

• Choose Ask if you want ePublisher Express to prompt you to scan your 
source documents every time you add new documents to your project.

• Choose Always if you do not want ePublisher Express to prompt you to 
scan your source documents. When you choose this option, ePublisher 
Express will automatically scan your documents for style and formatting 
information when you add new documents to your project.

• Choose Never if you want to manually scan your source documents 
yourself each time you add new documents to your project. By choosing 
this option, ePublisher Express will never scan your documents unless you 
command ePublisher Express to do so. If you choose Never, you will need 
to manually scan your source documents. 

Scanning Adobe FrameMaker Books

When adding a FrameMaker book file to a group, the contents of the book will 
not display in the Document Manager until the FrameMaker book has been 
scanned. Since the default scanning option for ePublisher Express is set to 
Always, the FrameMaker files will be added to your project automatically; 
however, if you have changed this option to Never, you will need to manually 
scan the documents, or if you have set this option to Ask, you will need to click 
Yes when you are prompted to scan your source documents.

Scanning Microsoft Word Master Documents

When adding a master document to a project, the referenced documents will not 
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display until the master document has been scanned. Since the default scanning 
option for ePublisher Express is set to Always Scan, the referenced documents 
will automatically be added to your project; however, if you have changed this 
option to Never, you will need to manually scan the documents, or if you have set 
this option to Ask, you will need to click Yes when you are prompted to scan your 
source documents.

Scanning an Individual Document

Oftentimes, you might make a change to a style, condition, variable, or marker in 
a single source document, and need to include that new information in your 
project. You can do so by manually scanning an individual source document.

To manually scan a source document:

1. In the Document Manager, click to select the Microsoft Word document you 
would like to scan.

2. Do one of the following:

• Right-click on the group and choose Scan Selected.

• Choose Project > Scan Selected.

Scanning All Documents

If there have been multiple changes to the style information, conditions, 
variables, or markers in your source documents, then you may opt to scan all of 
the source documents in your project at once. By doing this, you ensure that any 
changes to any of your source documents will be picked up by ePublisher 
Express.

To manually scan all source documents in your project:

1. Choose Project > Scan All Documents.

Generating Output
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When you generate output from a project, ePublisher Express converts your 
source documents into output files based on the information contained within 
your project file. Output refers to the files that the ePublisher Express project 
generates – such as individual topic pages (.html files), Help sets, or graphics 
files (.jpeg, .gif, .tif, etc.). By generating output in ePublisher Express, you are 
creating the files that compose your entire Help system. 

When to Generate Output

As you make changes to your source documents and your project, you will need 
to generate the output files to see any modifications you have made -such as: 

• Content changes in your source documents

• Changes in your ePublisher Express project

• Changes in your standalone stationery file

To Generate or to Regenerate

In ePublisher Express, you can use either the generate or regenerate option to 
create output. The generate and regenerate option both create output for your 
project; however, there are subtle differences between the two options.

Regenerate

When you choose to regenerate output, ePublisher Express will create your 
output files from scratch – that is, it will delete the Data folder from the project 
directory and rebuild a new one. When ePublisher Express regenerates your 
output files, it is creating brand new output files. You should regenerate your 
source document any time you have added new information to your source 
document that is not content – such as modifications to paragraph styles, new 
table styles, edited cross-reference formats, etc. Essentially, you need to 
regenerate your project anytime information within the source template has 
changed, and you need ePublisher Express to pick up this information.

You want to regenerate your output files when any of the following have 
changed:

• Style information in the source documents
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• Cross-reference definitions within the source documents

• Variable values within the source documents

• Conditions settings within the source documents

To regenerate your entire project:

n In your ePublisher Express project, select Project > Regenerate All.

Generate

When you generate your project for the first time, you are basically regenerating 
your project since you are creating your output files from scratch; however, once 
you have generated output files, you may want to use the generate option to 
create output files more quickly. 

When you use the generate option, you are updating your output with content 
changes made within your source documents and changes within your projects. 

You will want to use the generate option when you have made changes to:

• Cross-reference definitions within the project.

• Variable values within the project.

• Format settings

• Merge settings

• Project preferences

• Conditional values

In ePublisher Express, you can generate output for your entire project or you can 
generate output for a top-level group or a single document in your project. 

To generate output for your entire project:

n In your ePublisher Express project, select Project > Generate All.

To generate output for a group or document:

1. In your ePublisher Express project, select a top-level group or document from 
the Document Manager.
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2. Select Project > Generate Selected.

Viewing Output
Once you have generated output for your project, you can view the generated 
output files. There are three ways to view generated output: 

• The Output Explorer

• The Output Directory

• Automatically Launching Generated Output

The Output Explorer

The Output Explorer gives you access to your output from the user interface. You 
can use the Output Explorer to quickly view your output files and conformance 
reports. 

The Output Explorer categorizes the the output files into three possible groups:

• Merged groups

• Document groups 

• Top-level groups 

Each group in the Output Explorer contains the generated output that is relative 
to the scope of the group. For example, the merged group will contain the merged 
Help set for the entire project; the top-level group will contain the navigational 
file for that group; and the document group will contain the individual topic 
pages created for that document.

The group that displays in the Output Explorer depends on what you have 
selected in the Document Manager. For example, if you have selected a top-level 
group in the Document Manager, then the top-level group will display in the 
Output Explorer.

The output files and conformance reports that are available for viewing depends 
on what you have selected in the Document Manager. For example, if you have 
the top level group selected in the Document Manager, you will only be able to 
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view the navigation file, or if you have a document selected in the Document 
Manager, then you will only see the generated files for that document.

To view a merged navigation file using the Output Explorer:

1. Click on the plus sign next to the Merged Output group in the Output 
Explorer.

2. Double-click on the navigation file.

To view the navigation file using the Output Explorer:

1. Select the top level group.

2. Click on the plus sign next to the top level group to expand the group.

3. Click on the plus sign next to the Navigation group to expand the group.

4. Double-click on the navigation file to launch the Help set.

To view the individual files for a specific document:

1. Select a document from the Document Manager.

2. In the Output Explorer, click on the plus sign next to the document to expand 
the group.

3. Click on the plus sign next to the Files group to expand the group.

4. Double-click on any of the html files.

The Output Directory

ePublisher Express stores the generated output pages and graphics in the Output 
Directory. By default, the Output Directory is a subdirectory in your project 
folder. Within the Output Directory, there are individual output folders for each 
one of your target formats. For example, if your project contains target formats 
for WebWorks Help 5.0, HTML Help, and Simple HTML, then there will be 
three folders (each based on the target format’s name) in your Output Directory.

Changing the Location of the Output Directory

When you generate output, ePublisher Express places the output files into the 
Output Directory. You can modify the location where your output files are stored.
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To change the default location of the Output Directory:

1. Select Format > Format Settings.

2. Select the folder icon next to the Generated output location field.

3. When the Browse For Folder window displays, navigate to the folder you 
would like to use to store your output files.

4. Select the desired folder.

5. Click on the OK button to select the location.

6. In the Format Settings dialog box, click on the OK button to close the window 
and apply the changes.

Viewing Output from the Output Directory

ePublisher Express stores your generated output files in the Output Directory. 
You can always view your ouput files by launching them directly from the 
Output Directory. When you launch the Output Explorer, it will open the output 
folder for the format target you are currently viewing in ePublisher Express. 
Within that folder will be a folder based on your project’s name, and this is the 
folder that will contain the generated output files for that particular format target. 
For more information on format targets, please see “Managing Targets” on 
page 51.

To view output from the Output Directory:

1. Select View > Output Directory.

2. When the Output Directory launches, double-click on the folder inside the 
directory. The name of the folder will be based on your project’s name.

3. Double-click on any of the files to launch an output page or image.

Automatically Launching Generated Output

Whenever you generate output for your project, ePublisher Express will prompt 
you to view your generated output; see Figure 6-1.
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Figure 6-1: View Generated Output Dialog

When the View Generated Output dialog appears, you can select one of the 
following options:

• Yes - The generated output will display, and the prompt will continue to 
display everytime you generate output.

• Yes and Don’t ask me about this again - The generated output will always 
display automatically every time you generate output. The prompt will no 
longer display.

• No - The generated output will not display, and the prompt will continue to 
display everytime you generate output.

• No and Don’t ask me about this again - The generated output will never 
display when you generate output, and the prompt will no longer display.

If you have selected Don’t ask me about this again, the selection you have made 
will be the default behavior for displaying your generated output. For example, if 
you have selected Yes and Don’t ask me about this again, ePublisher Express will 
always launch your generated output. If you would like to reset the behavior of 
your generated output, you must clear the Do not ask again option in the 
Preferences window.

To clear the Do not ask again setting:

1. From the menu bar, select Edit > Preferences.

2. Click the “Do not ask again” button.

3. Click OK.
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Deploying Output
In ePublisher Express, there is an option to deploy your output files. When you 
deploy your generated output files, you are directing the files to a location that 
you have specified as a target destination. The target destination is a location that 
you specify, which is either a local directory or a network share.

For example, if you would like to deploy your output files to a network location, 
then in WebWorks ePublisher Pro, you need to create a target destination, which 
essentially specifies the location on the network to which you would like to 
deploy your files.

In order to deploy your output files, you must define at least one target 
destination for your project. You can also define multiple target destinations; this 
can be useful, for example, if you use both a staging server and production server. 
The target destinations you define are saved from one WebWorks ePublisher Pro 
session to another, so you only need to define each target destination once.

In order to deploy output, these are the steps you must follow to deliver your 
output to a target destination:

1. Create a target destination.

2. Specify a target destination.

3. Deploy your output.

Creating a Target Destination

The target destination refers to the location where you would like to deploy your 
generated output files. In ePublisher Express, the target destination is composed 
of two components: a target name and a folder location.

To create a target destination for deploying output:

1. From the main menu, choose Edit > Preferences.

2. Click on the Deployment tab.

3. Click on the Add drop-down button.

4. Choose Folder from the drop-down list.
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5. When the Folder Deployment Editor displays, type in a name for the target 
destination in the Name field. 

Note:  The name will be the nickname of the target destination; for example, 
if you plan to deploy to a location on your local machine, you should assign 
the target destination a descriptive name so that you know that it refers to the 
location on your local machine. When you deploy to a target destination, you 
will only be able to see the name of the target destination, rather than the 
location that the target destination is pointing to; therefore, having a 
descriptive name allows you to identify each target destination more easily.

6. In the Directory field, click on the Open button to browse to the location in 
which you would like to deploy your output.

7. Click OK to populate the Directory field with the path to the location in which 
you would like to deploy your output.

8. Click OK to create the target destination.

Specifying a Target Destination

The target destination refers to the location where you are deploying your output 
files. In order to deploy your output, you must select a target destination in the 
format settings.

To specify a target destination:

1. From the main menu, choose Format > Format Settings.

2. From the Deploy to drop-down list, select a target destination.

Deploying Output

After you have created a target destination and selected the target destination in 
the Format Settings, you are ready to deploy your output. When you deploy your 
output, ePublisher Express copies your output files and place them into the 
location you have specified as the target destination.

To deploy output to a target destination:
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n From the main menu, choose Format > Deploy.

Managing Targets
One of the major benefits of ePublisher Express is that you can produce multiple 
types of output with a single project if your stationery file contains multiple 
target formats. A format target is based on a specific output format (e.g., 
WebWorks Help 5.0, HTML Help, JavaHelp, etc.), but it contains user defined 
customizations that are specific to a project. 

Oftentimes, the target name is different than the output format name. For 
example, you might have a target format named OnlineHelpFormat, which 
is based on the WebWorks Help 5.0 output format, or you can have a target 
format named WebWorks Help 5.0 based on the WebWorks Help 5.0 format. 

In ePublisher Express, you can choose the active format target used by your 
project. The active format target refers to the target format currently selected for 
your project. Whenever you want to generate output or modify format settings 
for a format target, you must have the correct format target selected as the active 
target.

Creating a Format Target

Every project must contain at least one format target or else you will not be able 
to generate output for your project. If your standalone stationery does not contain 
any format targets, you will not be able to add any format targets.

To create a format target:

1. In your ePubilsher Express project, select Project > Manage Format Targets.

2. Click the Add button.

3. Enter a name for the format target in the Name field.

4. Select an output format for your format target from the Format Type 
dropdown list, .

Note:  The output formats available from the dropdown list are the ones 
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already contained within your standalone stationery file. 

5. Click the OK button.

Selecting an Active Target

The active target refers to the format target that is currently selected for your 
project. Anytime you make modifications to your project, or generate output, 
ePublisher Express uses the active target.

To select the active target:

1. In your ePublisher Express project, select Project > Active Target.

2. Click on the dropdown button.

3. Select an active target.

Saving Projects
You should periodically save your project to ensure that you do not lose any 
changes that you have made to your ePublisher Express project. By saving your 
project, you ensure that the information in your project is stored and will be 
available for you the next time you open your project.

To save a project:

n In your ePublisher Express project, select File > Save.

Note:  ePublisher Express will automatically store your project file in the 
location you specified when you first created the project. By default, this 
location is C:\Documents and Settings\USERNAME\My 
Documents\ePublisher Express Projects\NAME OF PROJECT.

Opening Existing Projects
There are two ways to access a project: either directly from the user interface or 
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from its stored location. When you create new projects or open existing projects, 
ePublisher Express will open a separate instance of the program for each project. 
Each project will have its own window.

For example, if you already have an opened project, and you decide to create a 
new project, then ePublisher Express will open up a new instance of itself for the 
new project; therefore, you will have two project windows open concurrently.

To open an existing project:

1. Select File > Open from the menu bar.

2. When the Open window displays, browse to the location where the 
ePublisher Express project (the .wrp file) is stored.

3. Select the project file.

4. Select the Open button.

Closing Projects
When you finish working with a project, you can close it. As long as you have 
saved any changes to your project, closing the project will not cause you to lose 
any information contained within the project. 

To close a project:

n Select File > Exit from the menu bar.

Note:  When you close your project, ePublisher Express will prompt you to 
save any changes to your project that you have not already saved. Click Yes to 
save your changes, click No to exit your project without saving your changes, 
or click Cancel if you do not want to exit your project.
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MODIFYING PROJECT SETTINGS

Once you have created a project, you can make modifications to your project file 
and make minor customizations to your output pages. ePublisher Express 
provides you access to the following settings:

• Format Settings

• Conditions

• Variables

• Cross-References

• Merge Settings

• Preferences

Note:  You can edit your project file only if you have project modification 
permissions. When you installed ePublisher Express, you must have enabled the 
Allow users to modify Format Settings and Properties option. If you did not 
enable this option, you will only be able to modify the Merge Settings. To enable 
this option, you must uninstall ePublisher Express and reinstall it.

Format Settings
In ePublisher Express, the Format Settings window allows you to control 
preferences specific to the target format. Within the Format Settings window, 
there are expandable groups, which display options your format supports.

Generally, most formats will contain the following groups:

• Accessibility

• Company Information

• Files

• Index

• Links
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• Locale

• PDF

• Conformance Reports

• Table of Contents

Accessibility

Since many browsers and screen readers do not support the longdesc attribute, 
ePublisher Express enables you to include a link labeled [D] alongside any image 
for which a long description is available. Because the [D] link is a standard 
hyperlink, it can be processed correctly by browsers and screen readers.

The Accessibility group in the Format Settings window allows you to enable the 
include visible [D] links to images with long descriptions option. This option 
will display a [D] link that will take the user to the long description text.

Note:  The following formats do not support [D] links: JavaHelp 1.x, JavaHelp 
2.x, Simple HTML, Dynamic HTML, WinHelp, and Palm Reader.

To enable [D] links to images with long descriptions:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Accessibility group, find the option Include visible [D] links to 
images with long descriptions.

3. Click in the Value field next to the option to enable the dropdown menu.

4. Select Enabled.

5. Click the OK button to apply your changes and close the Format Settings 
window.

Company Information

You can add your company’s contact information to each output page in your 
Help system. By default, the company contact information will display on the 
bottom and/or top of your output pages. Where the company information 
displays depends on what your stationery designer has specified in the stationery 
file.
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The following company information is available for modifying:

• E-mail address

• Fax number

• Company name

• Phone number

• Web page

Note:  The following formats do not support company information: Palm Reader 
and Microsoft Reader.

To modify the company e-mail address:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Company Information group, find the setting Company email 
address. 

3. In the Value field, type in the e-mail address (e.g., info@webworks.com).

4. Click OK to apply your changes and close the Format Settings window.

To modify the company fax number:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Company Information group, find the setting Company fax 
number. 

3. In the Value field, type in the fax number (e.g., 1-800-555-5555).

4. Click OK to apply your changes and close the Format Settings window.

To modify the company name:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Company Information group, find the setting Company name. 

3. In the Value field, type in the company’s name (e.g., Quadralay 
Corporation).

4. Click OK to apply your changes and close the Format Settings window.
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To modify the company phone number:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Company Information group, find the setting Company phone 
number. 

3. In the Value field, type in the phone number (e.g., 1-800-555-5555).

4. Click OK to apply your changes and close the Format Settings window.

To modify the company Web page:

1. In your ePublisher Express project, select Format > Format Settings.

2. Under the Company Information group, find the setting Company 
webpage. 

3. In the Value field, type in the URL to the company’s website (e.g. 
http://www.webworks.com).

4. Click OK to close the Format Settings dialog box.

Files

When ePublisher Express encounters a page break, it will create a new topic 
page. Page breaks are set in the stationery file; however, you can choose how you 
would like ePublisher Express to handle the page breaks.

In the Format Settings window, the setting Page break handling controls how 
ePublisher Express handles page breaks. The page break handling setting can 
be set to one of the following values:

• Never: ePublisher Express will ignore any page break settngs specified in the 
stationery file.

• Always: ePublisher Express will always honor the page break settings 
specified in the stationery file.

• Combine: ePublisher Express will only honor the page break setting if there 
was not a page break at the previous heading, and if the heading has a greater 
page break priority assigned to it. 

For example, if Heading 1 has a page break priority of 1, Heading 2 has a 
page break priority of 2, and Heading 3 has a page break priority of 3, then a 
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page break will only occur at Heading 1 because Heading 1 has the greatest 
page break priority.

• If not previous: ePublisher Express will only honor the page break setting if 
there was not a page break at the previous heading, and if the heading has a 
greater or equal page break priority assigned to it. 

For example, if you have a Heading 1 with a page break priority of 1 
followed by two Heading 2s whose page break priorities are 2, new topic 
pages will be created at Heading 1 and at the second Heading 2.

To set the page break handling option:

1. In your ePublisher Express project, select Format > Format Settings.

2. Find the option Page break handling under the Files group.

3. Click in the Value field next to the option to enable the dropdown menu.

4. Select one of the available settings. 

5. Click on the OK button to apply your changes and close the Format Settings 
window.

Index

In ePublisher Express, you can choose to generate an index for your Help set. If 
you choose to generate an index for your Help set, you must have index markers 
embedded in your source documents. For more information on embedding index 
markers in your source documents, please visit your authoring tool’s 
documentation. 

Note:  The following format does not offer the Generate index option: WinHelp.

To set index generation options:

1. In your ePublisher Express project, select Format > Format Settings.

2. Find the option Generate Index under the Index group.

3. Click in the Value field next to the option to enable the dropdown menu.

4. Select one of the available settings. 

5. Click on the OK button to apply your changes and close the Format Settings 
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window.

Links

ePublisher Express allows you to determine how links display from your output 
files. The following are the available link options in the Format Settings window 
for the external URL target setting:

• Blank: Use this setting to always open in a new browser window.

• Window: Use this setting to open in a new browser window and continues 
reusing the new browser window.

• Self: Use this setting to reuse the an open and existing browser window.

• None: Use this setting to open links within the same window.

Note:  The following formats do not support external URL targets: Oracle Help, 
Palm Reader, and Microsoft Reader.

To set the external URL target:

1. In your ePublisher Express project, select Format > Format settings.

2. Click on the dropdown button in the Value field next to the External URL 
Target setting.

3. Select one of the target values.

4. Click OK to apply your changes and to close the Format Settings window.

Locale

The locale refers to the language in which your Help system displays. If you have 
a localized Help system, you will need to choose the correct locale for your Help 
set. 

To set the locale for your Help system:

1. In your ePublisher Express project, select Format > Format settings.

2. Click on the dropdown button in the Value field next to the Locale setting .

3. Select one of available locales
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4. Click OK to apply your changes and to close the Format Settings window.

PDF

You can generate PDFs for each source document and/or each top-level group in 
your project. 

To generate a PDF for each source document:

1. In your ePublisher Express project, select Format > Format settings.

2. Find the PDF group.

3. Click on the dropdown button in the value field next to the Generate a PDF 
per document setting.

4. Select Enabled.

5. Click OK to apply your changes and to close the Format Settings window.

To generate a PDF for each top-level group:

1. In your ePublisher Express project, select Format > Format settings.

2. Find the PDF group.

3. Click on the dropdown button in the value field next to the Generate a 
combined PDF per top level group setting.

4. Select Enabled.

5. Click OK to apply your changes and to close the Format Settings window.

Conformance Reports

Conformance reports are proofing tools that identify where problems occur in 
your source documents. Anytime a conformance report encounters a problem or 
behavior within your source document, it will display a notification alert in the 
report. You can set different types of alerts for your notification messages. For 
more information on the types of notifications, please see “Configuring 
Conformance Reports” on page 81.

For information on setting the notification type for the messages within each 
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conformance report, please visit the section for that specific conformance report. 
There are five types of conformance reports:

1. Styles Report

2. Topics Report

3. Filenames Report

4. Links Report

5. Accessibility Report

Table of Contents

ePublisher Express uses the TOC levels assigned in the standalone stationery file 
to create a table of contents for your Help system. Oftentimes, TOC levels will be 
skipped in the table of contents, and when this occurs, an empty TOC icon can 
display in the table of contents. 

Typically, empty TOC levels occur when you skip a TOC heading in the source 
document. For example, let’s say that in your standalone stationery file, you have 
assigned Heading 1, Heading 2, and Heading 3 as TOC levels; however, in your 
source document, you have skipped several Heading 2 headings. 

When you generate your table of contents, you can specify how you would like 
your skipped TOC levels handled. The following are the available Format 
Setting options for collapsing your table of contents:

1. Don’t collapse: Select this option if you want ePublisher Express to 
automatically insert empty table of contents entries for the skipped levels. 
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Figure 7-13: Uncollapsed TOC Hierarchy

2. Fully collapse: Select this option if you want ePublisher Express to remove 
all skipped TOC entries and place all TOC headings at the same level, 
regardless of what TOC level they have been assigned.

Figure 7-14: Fully Collapsed TOC Hierarchy

3. Smart collapse: Select this option if you want to remove empty TOC entries, 
and move the subsequent heading up a level to replace the skipped TOC 
level.

Skipped TOC 
levels labeled 
with blank book 
icons

All skipped TOC 
levels are on the 
same level.
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Figure 7-15: Smart Collapsed TOC Hierarchy

4. Re-label: Select this option if you want to automatically insert labeled entries 
for the skipped TOC levels. The heading text from the TOC entry appearing 
below the current entry will be used as the TOC label.

Figure 7-16: Re-labeled TOC Hierarchy

Whether or not an empty TOC icon displays depends on the setting you have 
specified for your table of contents in the Format Settings window.You can 
specify how you would like your empty TOC levels handled.

To specify how empty TOC levels are handled:

1. In your ePublisher Express project, select Format > Format Settings.

2. Find the Table of contents group.

3. Click on the dropdown button in the Value field next to the Collapse table of 
contents setting.

4. Select one of the available options.

Skipped TOC 
levels have been 
replaced by 
subsequent TOC 
heading

Skipped heading 
level renamed to 
the subsequent 
heading name.
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5. Click OK to apply your changes and to close the Format Settings window.

Conditions
Using conditions, you can set the visibility of content within your generated 
output. Conditions allow you to show or hide information in your online output. 
You can do so by applying conditions to the content in your source document and 
setting the visibility for those conditions in your project. Any content that has a 
condition applied to it is referred to as conditional text.

For example, your source documents might contain information that is used only 
in the print version and information that is used only in the online version. In 
order to reuse your source documents for both print and online Help, you need to 
create conditions specifically for the online content and for the print content and 
apply the conditions to the appropriate content. 

When you create a condition, you need to set the hidden attribute for the 
condition. If the conditional text will be visible in the source document, then the 
hidden attribute should not be selected; however, if the conditional text will not 
be visible in the source document, then the hidden attribute should be selected.

Creating Conditions in Microsoft Word

In Microsoft Word, you can create conditions to either show or hide content 
within your output. These conditions can be set up so that you can tag content to 
either be visible or not visible when your online output is generated.

To create a condition in Microsoft Word:

1. In your Word document, select WebWorks > Conditions.

2. Click on the Add button.

3. Type in a name for the condition.

4. Select Hidden if you do not want the content to appear in the Microsoft Word 
document or leave Hidden deselected if you want the text to appear in the 
source document.
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5. Choose a color with which to highlight the conditional text. By highlighting 
the conditional text, you will be able to easily see exactly where conditional 
text is located in your source documents.

Applying Conditions in Microsoft Word

After you have created conditions in your source document, you need to 
determine what content needs to be tagged as conditional text. Once you have 
decided which content needs to be assigned as conditional text, you need to apply 
the appropriate conditions.

To apply a condition in Microsoft Word:

1. Highlight the content to which the condition will be applied.

2. From the main menu, choose WebWorks > Conditions.

3. Select a condition.

4. Click on the Apply Condition button to apply the condition.

Creating Conditions in Adobe FrameMaker

In Adobe FrameMaker, you can use conditions to make content visible or not 
visible when your online output is generated.

To create conditions in Adobe FrameMaker:

1. From the main menu, choose Special > Conditional Text.

2. Click on the Edit Condition Tag button.

3. For the Tag field, type in a name for the condition.

4. Choose a style for the condition.

5. Choose a color for the condition.

6. Click the Set button to create the condition.

Applying Conditions in Adobe FrameMaker

After you have created conditions in your source document, you need to 
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determine what content needs to be tagged as conditional text and apply 
conditions to that content.

To apply conditions in Adobe FrameMaker:

1. Highlight the content to which the condition will be applied.

2. From the main menu, choose Special > Conditional Text.

3. Select a condition from the Not In list.

4. Click on the left arrow button to move the condition from the Not In list to 
the In list.

5. Click the Apply button to apply the condition.

Setting Conditional Values in a Project

In your source documents, you have set certain visbilities for your conditions; 
however, in your ePublisher Express project, you can modify the visibility for 
each condition. The conditions that are available in your project come directly 
from your source documents. You can modify the value for any of your 
conditions, which in turn, will affect how your conditional text displays online.

In ePublisher Express, you can set the visibility of your conditions to one of the 
following:

• Visible: Select this if you would like the conditional text to appear in your 
output.

• Hidden: Select this if you would like the conditional text to not display in 
your output.

• Use document value: Select this if you would like ePublisher Express to use 
the visibility you have assigned the condition in the source document.

To modify the value of a condition:

1. In your ePublisher Express project, select Format > Conditions.

2. Find the condition you would to modify.

3. Click on the dropdown button in the Value field next to the condition you 
would like to modify.
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4. Select a visibility option.

Variables
A variable serves as a placeholder for information that is liable to change. It 
would be efficient to set up variables for any information whose value fluctuates. 
By setting up variables in the source document, it allows you to have global 
control over the values contained within those variables.

For example, a date can be set up as a variable; if the date ever needs to be 
modified, it would be possible to make the change from a single location instead 
of having to search for and replace all the instances of that date. 

Modifying Variable Values

A major benefit of using variables is that you can control their values from a 
single location. In your project, you are able to change the value of any variable; 
when you change the value of a variable in your project, it will only affect the 
value of the variable in the output. It does not change the value of the variable in 
your actual source document. 

In your ePublisher Express project, you have the option to use your own variable 
value, or you can use the value that is defined for the variable in the source 
document. If you want to use the value defined for the variable in the source 
document, you must select the Use Document Value option.

To modify a variable value:

1. In your ePublisher Express project, select Format > Variables.

2. Find the variable you would like to modify.

3. Click in the Value field next to the variable to highlight its current definition 
and make the desired changes to the value, or select the Use Document 
Value option.
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Cross-References
Cross-references help users access related information quickly in your online 
content. When you convert your source documents to online Help, all cross-
references are automatically converted to hypertext links. 

Typically, cross-references used for printed materials will have a different format 
than cross-references used for online Help. For example, page numbers are not 
generally included in online cross-references because the page numbers would be 
out of context for online Help. 

In ePublisher Express, you can use the Cross-Reference Rules editor to add, 
edit, and/or delete cross-reference formats for your project.

Figure 7-17: Cross-Reference Editor

The Name column shows either the cross-reference format or a set of default 
cross-reference formats. These formats are building blocks or codes that come 
directly from your source document. Next to the Name column, the Value 
column displays the corresponding online format for that cross-reference format.

Note:  If you need help interpreting the building blocks or codes, please see your 

Select Source Document Type

Cross-
Reference 
Format

Cross-
Reference 
Name
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authoring tool’s Help documentation.

To modify the online format for a cross-reference format:

1. In your ePublisher Express project, select Format > Cross Reference Rules.

2. Select the authoring tool you are using from the Document type dropdown 
menu, . By default, this field is always set to Microsoft Word.

3. Double-click on the cross-reference format you would like to modify from 
the Name field.

4. Make your desired changes in the Replacement field.

5. Click OK to apply your changes and close the Edit Cross Reference 
window.

To add a cross-reference format:

1. In your ePublisher Express project, select Format > Cross Reference Rules.

2. Select the authoring tool you are using from the Document type dropdown 
menu. By default, this field is always set to Microsoft Word.

3. Click on the Add New Cross Reference button.

4. Enter a name for the cross-reference format in the Name field.

5. Type in the building blocks or codes for the cross-reference format in the 
Replacement field.

6. Click OK to add the new cross-reference format.

To delete a cross-reference:

1. In your ePublisher Express project, select Format > Cross Reference Rules.

2. Select the authoring tool you are using from the Document type dropdown 
menu. By default, this field is always set to Microsoft Word.

3. Select the cross-reference format you want to delete.

Note:  You can only delete cross-reference formats that you have created in 
the project. You cannot delete cross-reference formats that exist in your 
source documents. Each time you regenerate your project, the cross-reference 
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formats from your source documents will be readded to your project.

4. Click on the Delete Cross Reference button.

Merge Settings
Multivolume Help comprises a single set of files that combine output from 
multiple groups from within your project. When you merge the output files from 
the groups within your project, you are taking the TOC, index, and search data 
from each top-level group’s generated entry-point file, and combining that 
information into a single, consolidated system. 

Currently, when you generate output for your project, each first-level group will 
generate its own entry-point file. In order to create one cohesive Help set, you 
will need to merge the entry-point files into one consolidated Help set. To create 
a single Help set in ePublisher Express, you need to utilize the Merge Settings.

Figure 7-18: Merge Settings

Note:  You can merge projects based on any of the formats provided with 

Controls 
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WebWorks ePublisher Pro, except for the Sun JavaHelp formats, the Microsoft 
WinHelp formats, and the eBook formats.

Creating Multivolume Help

To create multivolume Help, you need to set up at least two top-level groups in 
the Document Manager. The name of your top-level groups will serve as the 
book names in your Help set. 

When you merge the output files from the groups within your project, you are 
taking the table of contents, index, and search data from each top-level group’s 
generated entry-point file, and combining that information into a single, 
consolidated system. Currently, when you generate output for your project, each 
top-level group will generate its own entry-point file. In order to create one 
cohesive Help set, you will need to merge the entry-point files into one 
consolidated Help set.

By default, if you have created several top-level groups in your project, 
ePublisher Express will automatically create a merged or multivolume Help set 
for you. Once you generate output for your project, the multivolume Help set will 
be located in the Merged Output group in the Output Explorer, and it will be 
named index.html.

When you launch your multivolume Help set, you will notice that the names of 
your top-level groups will display in the table of contents. If you want to organize 
and group your top-level groups under a different book name not specified in the 
Document Manager, or if you would like to reorganize the table of contents of 
your multivolume Help set, you will need to use the merge settings feature in 
ePublisher Express. 

To organize the table of contents of a multivolume Help set:

1. In your ePublisher Express project, select Format > Merge Settings.

You will see a listing of all your top-level groups under the Hierarchy section.

2. Click and drag any of your first level groups to reposition them in the TOC 
hierarchy.

3. Close the Merge Settings window.
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4. Select Project > Regenerate All.

To add a group to your multivolume Help set:

1. In your ePublisher Express project, select Format > Merge Settings.

2. Click on the Add button.

A TOC entry, or book, called Untitled Topic will be added to your 
TOC hierarchy.

3. Double-click on Untitled Topic to rename it.

4. Click and drag any of your top-level groups into the new TOC entry.

5. Close the Merge Settings window. 

6. Select Project > Regenerate All.

To rename top-level groups in the table of contents:

1. In your ePublisher Express project, select Format > Merge Settings.

You will see a listing of all of your top-level groups under the Hierarchy 
section.

2. Click to select any of your top-level groups in the TOC hierarchy.

3. In the Table of contents title field, type in the name you would like to assign 
the top-level group. This is the name that will appear in the table of contents.

4. Close the Merge Settings dialog box.

5. Select Project > Regenerate All.

To change the name of Help set that displays in the title bar of the browser:

1. In your ePublisher Express project, select Format > Merge Settings.

2. Enter the name you would like to display in the title bar of the browser when 
the Help set initially launch in the Merge Title field.

To remove a group from the TOC hierarchy:

1. Click on the group you would like to remove.

2. Click the Delete button.
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Note:  You can only remove groups that you have manually added to your 
TOC hierarchy. You cannot move groups that are placed in the TOC by 
default; these are the groups that are contained within the Document 
Manager.

Preferences
In ePublisher Express, you can select your project options through the 
Preferences window. To display the Preferences window, select Edit > 
Preferences. The Preferences window provides you access to three tabs:

• General

• File Mappings

• Deployment

Figure 7-19: Preferences Window
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The General tab is broken into four different areas:

• Recent Projects

• Languages

• Scan Options

• Miscellaneous

Recent Projects

Under the Recent projects area, you can:

• Specify the number of projects listed on the Start Page.

• Clear the list of projects from the Start Page. 

To modify the number of projects displayed on the Start Page:

1. In ePublisher Express, select Edit > Preferences.

2. Delete the existing number in the Recent projects to remember field.

3. Enter the desired number in the Recent projects to remember field.

Note:  This number can be up to 99.

4. Click OK.

To clear the Start Page:

1. In ePublisher Express, select Edit > Preferences.

2. Click the Clear List button.

3. Click OK.

Languages

Under the Languages area, you can select the language the controls in which the 
user interface display. Currently, ePublisher Express is available in three 
languages:

• English

• French
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• German

To select the user interface language:

1. In ePublisher Express, select Edit > Preferences.

2. Click the dropdown menu under the User interface language option.

3. Select a language.

4. Click OK.

Scan Options

By default, ePublisher Express is set to always scan your source documents when 
you add them to your project. When ePublisher Express scans your documents, it 
is reading the style and formatting information, conditions, variables, and 
markers in your source documents. 

If you do not want ePublisher Express to scan your documents automatically 
when they are added to your project, you can set how you would like your source 
documents handled. For example, you can choose to have ePublisher Express 
prompt you to scan the source documents, or you can choose to never have 
ePublisher Express scan the source documents. The scanning option that you 
choose will become the default selection for all existing and subsequent projects. 

To set the scanning options:

1. In ePublisher Express, select Edit > Preferences.

2. Click the dropdown menu under the Scan added documents option.

3. Select one of the following:

• Always 

• Ask 

• Never

4. Click OK.

Miscellaneous
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The Miscellaneous area contains the options for resetting:

• Toolbars 

• Dock positions

• Ask prompts

To reset the toolbar to the default toolbar:

1. In ePublisher Express, select Edit > Preferences.

2. Click the Reset Toolbar button.

3. Click OK.

To reset the dock positions of the windows in the UI:

1. In ePublisher Express, select Edit > Preferences.

2. Click the Reset Dock Positions button.

3. Click OK.

To clear settings for any Do Not Ask Again prompts:

1. In ePublisher Express, select Edit > Preferences.

2. Click the Clear “Do not ask again” button.

3. Click OK.

File Mappings Tab

In ePublisher Express, you can add any source documents that can be opened 
with Microsoft Word or Adobe FrameMaker by using file mappings; for 
example, you can add .txt files to your project. In order to do this, you would 
need to specify the adapter for which ePublisher Express would need to use in 
order to open the .txt file. In ePublisher Express, an adapter refers to an 
application such as Adobe FrameMaker or Microsoft Word; it is the application 
that you will use to open the source documents. In your project, there is a File 
Mapping tab located under Edit > Preferences that will allow you to specify the 
adapter you would like to use for each file type.

By default, ePublisher Express comes with a list of file extensions that are preset 
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to use either Microsoft Word or Adobe FrameMaker. You have the ability to 
choose Adobe FrameMaker or Microsoft Word from the drop-down list of 
adapters for certain file types, such as .txt files, or create user-defined file 
mappings and specify the adapter for those file types. However, certain file 
extensions, such as .book, .fm, and .bk files, are unique to a specific adapter; in 
this case, .fm, .bk, and .book files can only be opened with Adobe FrameMaker. 
Other file extensions, such as .rtf, .xml, and .doc, are specific to Microsoft Word; 
therefore, the adapter for these file extensions must be specified as Microsoft 
Word. If a certain file type cannot normally be opened with either Microsoft 
Word or Adobe FrameMaker, then ePublisher Express will display an error 
message if you try to generate output or a preview with those files.

If you only have a license key for either the Word or FrameMaker adapter, then 
you can only use the adapter that is inline with your version of ePublisher 
Express. Although the option to choose either adapter may be available, you will 
not be able to generate a preview or output with the file if you do not have a 
corresponding license key for that adapter. 

Modifying a File Mapping

By default, ePublisher Express provides you with a default list of file mappings; 
each file extension has been preset to use a specific adapter. For file extensions 
that can either be opened with Microsoft Word or Adobe FrameMaker, such as 
.txt files, you can associate an adapter for the file extension.

To map file extensions to a Word or FrameMaker adapter:

1. From the main menu, choose Edit > Preferences.

2. Click on the File Mappings tab.

3. Choose the file extension for which you would like to specify the adapter 
from the list of extensions.

4. Choose the adapter that is most appropriate for that file extension from the 
drop-down list of adapters.

5. Click OK to apply the changes.
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Creating a New File Mapping

If there is a file extension that you would like to use, but it is not available in the 
default list of file extensions, you can create a new file mapping. A file mapping 
refers to the file extension and its corresponding adapter; to create a file mapping, 
you basically add a new file extension and associate, or map, the file extension to 
an adapter. You can use this user-defined file mapping in order to specify whether 
the file will be opened with Microsoft Word or with Adobe FrameMaker. When 
you create a new file mapping, the mapping will be retained and applied for all 
your subsequent projects that you open; therefore, if you have specified that 
Microsoft Word will be the adapter for .txt files, then by default, each subsequent 
project that is opened will have .txt files mapped to Microsoft Word.

When you choose an adapter for a file extension, you need to verify that the file 
extension can be opened with the adapter outside of ePublisher Express. If the 
file type cannot be normally opened with the adapter, then ePublisher Express 
will not be able to process that document using the adapter. If you specify an 
adapter that is incompatible with the file type, then ePublisher Express will 
display an error. Depending on whether you are trying to generate output or 
generate a preview, ePublisher Express will display a different error if you are 
trying to perform one of these functions on an invalid file type. 

To create a file mapping:

1. From the main menu, choose Edit > Preferences.

2. Click on the File Mappings tab.

3. Click the New button.

4. Type in the file extension that you would like to add in the File Extension 
field; for example, you can add HTML as a file extension. 

5. Select the adapter which ePublisher Express will use to open that file type 
from the Tool drop-down list, . For example, if you are creating a file 
mapping for HTML files, then you can specify Microsoft Word as the 
adapter. 

6. Click OK to create the new file mapping. 
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To delete a file mapping:

1. From the main menu, choose Edit > Preferences.

2. Click the File Mappings tab.

3. Click to select the file mapping that will be deleted.

4. Click the Remove button  to delete the file mapping.

Deployment Tab

Use the Deployment tab to create target destinations, which refer to the locations 
where you would like to deploy your generated output files. For more 
information on creating target destinations, please see “Creating a Target 
Destination” on page 49.
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TEMPORARY PROJECTS

Temporary projects allow you to quickly proof and review your output. They 
provide a quick preview of how a document will look once its content has been 
converted to online output. You can also use temporary projects to generate on-
demand reports, which allow you to verify that your source document conforms 
to stationery standards and does not contain any errors.

Only one temporary project can be open at any given time for any document. 
Once you close a temporary project, the temporary project will be deleted from 
your system. Temporary projects do not produce permanent output – that is, 
output that you can deploy and use. Remember that temporary projects should 
only be used to proof your documents using using the information contained 
within a standalone stationery file.

ePublisher Express will create a temporary project in the following instances:

• If you select the Generate Output option from the WebWorks Transit menu, 
and there is no ePublisher Express project or temporary project open 
containing that source document.

• If you select the Generate Reports option from the WebWorks Transit menu, 
and there is no ePublisher Express project or temporary project open 
containing that source document.

Creating Temporary Projects
As a best practice tip, create your temporary projects prior to creating an 
ePublisher Express project. If the source document is a part of an ePublisher 
Express project that is already open, and you try to generate output from the 
transit menu, ePublisher Express will use the ePublisher Express project to 
generate output. 

You should use temporary projects to periodically check your output because it is 
much faster to create and generate than an ePublisher Express project. In a 
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complete ePublisher Express project, you might be generating output for multiple 
documents, which is time consuming and inefficient if you only want to view 
output for a single document.

Once you close the temporary project, all of the generated output, conformance 
reports, and temporary project files will be deleted from your system and will no 
longer be accessible.

To create a temporary project:

1. From the WebWorks Transit menu in your source document, select ePublisher 
Express > Generate Output.

2. When the New Project Wizard launches, click on the folder button next to the 
Stationery field.

3. When the Browse window displays, navigate to the location of your 
standalone stationery file. 

4. Select the standalone stationery file.

5. Click on the Open button to add the stationery file to your temporary project.

6. From the list of available targets, select the target for which you would like to 
generate output.

7. Click on the Finish button. ePublisher Express will create a temporary project 
based on the source document’s name, and it will automatically generate 
output for you.

Generating Temporary Output
When you generate temporary output, you are taking a snapshot of what your 
content will look like once ePublisher Express converts it to online output. 
Temporary output allows you to quickly proof and review your content without 
creating an ePublisher Express project. 

When you try to generate output for a source document from the Transit menu, 
ePublisher Express will first check to see if the application is already running. If 
the application is running, then it will check to see if the source document is 
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already part of an open ePublisher Express project. If ePublisher Express finds an 
open ePublisher Express project or temporary that contains the source document, 
it will use the open project to generate output; otherwise, it will automatically 
launch the New Project Wizard. If the New Project Wizard launches, please 
create a new project. For more information on creating a project, please see 
“Creating Temporary Projects” on page 81.

To generate temporary output from the WebWorks Transit Menu:

n Select WebWorks > ePublisher Express > Generate Output.

Viewing Temporary Output
Once your temporary project finishes generating output, the output files will be 
accessible from the Output Explorer, which provides you with a UI to view 
temporary output and on-demand reports. If ePublisher Express used a temporary 
project to generate your temporary output files, then the Output Explorer will 
launch once it is done generating output; however, if ePublisher Express used an 
existing project to generate temporary output, then the temporary output files will 
be accessbile from the Output Explorer in ePublisher Express’ user interface.

To view temporary output:

1. In the Output Explorer, click on the plus sign next to the source document to 
expand the group.

2. Click on the plus sign next to the Files group to expand the group.

3. Double-click on any of the output files listed under the group.

Generating On-Demand Reports
You can quickly proof your source document against a stationery file by 
generating on-demand reports. On-demand reports are conformance reports for 
temporary projects. They are proofing tools that identify where problems occur 
in your source documents. These reports contain notifications of how elements in 
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your document have been processed and where errors exist, and you can double-
click on any of the errors in the on-demand reports to take you to the location of 
the problem. 

There are five types of on-demand reports that you can generate: 

• Styles

• Topics 

• Links

• Files

• Accessibility

You can select the on-demand reports you wish to generate, or you can generate 
all on-demand reports at a single time. 

Generating on-demand reports work similarly to generating temporary output. 
ePublisher Express will first check to see if the application is running. If the 
application is running, then it will check to see if an ePublisher Express project or 
temporary project containing the source document you are trying to generate on-
demands reports for is already open. If it finds an open project containing that 
source document, then it will use that project to generate on-demand reports; 
however, if it does not find an open project, it will launch the New Project Wizard. 
In that case, please follow the steps below.

To generate on-demand reports:

1. Select WebWorks > Generate Reports.

Note:  If a temporary project is not already open, then ePublisher Express 
will create a temporary project; however, if an ePublisher Express project or 
temporary project is already open for the document you are generating on-
demand reports for, then ePublisher Express will use that temporary project.

2. When the Report Select dialog box displays, select the reports you would like 
to generate.

3. Click OK to generate the report.
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Viewing On-Demand Reports
Once you have generated your on-demand reports, you can view them from the 
Output Explorer. Both temporary project and ePublisher Express interfaces have 
an Output Explorer, and both work in the same manner, but the main difference 
lies in the groups that are available from the Output Explorer. If you are looking 
at the Output Explorer for a temporary project, then you will only see a document 
group; however, if you are looking at the Output Explorer for an ePublisher 
Express project, then you will see all available groups (e.g., navigation, 
document, and merged output groups). 

To view an on-demand report:

1. In the Output Explorer, click on the plus sign next to source document for 
which you generated on-demand reports. This will expand the group.

2. Click on the plus sign next to Reports to expand the group.

3. Double-click on the report that you would like to view.
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SYCHRONIZING WITH 
STATIONERY

When you open an existing project, two things will happen: ePublisher Express 
will check whether the stationery file has been modified, and it will compare the 
project’s manifest file to the stationery’s manifest file. If any there have been any 
changes to the conditions, variables, cross-reference definitions, format settings, 
and style information within the stationery file or any changes to the user, format, 
or target files within the standalone stationery, ePublisher Express will inform 
you that the stationery file has been modified and prompt you to synchronize 
your project to the stationery file. To synchronize means to match; therefore, 
when you synchronize your project file to your stationery file, you are matching 
the information in your project file to the information in the stationery file.

File Comparisons
In order to determine whether you need to synchronize your project to the 
standalone stationery, ePublisher Express performs file comparisons to determine 
if there are any differences between your project file and your stationery file. 

ePublisher Express will prompt you to synchronize your project to a stationery 
file when:

• There are any differences between the project’s manifest file and the 
stationery’s manifest file.

• The stationery file has been modified.

The Manifest File

When you create a new project, ePublisher Express will copy the standalone 
stationery’s manifest file and place it into the project’s directory. The manifest 
file lists all of the files that are currently associated with the stationery file. The 
manifest specifically lists files that are in the:
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• Formats folder

• Targets folder

• Files folder

Anytime a file has been modified, removed from, or added to any of these folders 
in the standalone stationery, the stationery’s manifest file will be updated to 
reflect these changes; therefore, the manifest file is a record of the Target, 
Format, and User files that are currently associated with a stationery file.

When you open an existing project, ePublisher Express will compare the 
project’s manifest file to the stationery’s manifest file to see if there are any 
differences. If the stationery designer has updated, removed, or added any files to 
the stationery file since you last opened your project, then the project’s manifest 
file will differ from the stationery’s manifest file.

If there are differences, then ePublisher Express will prompt you to synchronize 
your project to the stationery file. When you choose to synchronize your project 
to the stationery file, ePublisher Express will copy over the standalone 
stationery’s updated manifest file and copy over or delete the differing files.

For example, let’s say that the stationery designer has updated the standalone 
stationery by adding a new Page.asp file. The stationery’s manifest file will be 
updated to note this change. When you open the project linked to this stationery 
file, ePublisher Express will recognize that the project’s manifest file is different 
from the stationery’s manifest file; therefore, ePublisher Express will prompt you 
to synchronize your project to your stationery file. .

The Stationery File 

ePublisher Express will determine if your stationery file has been modified by 
examining the checksum. A checksum is a value that is dependent on the 
contents of a file; we use this value to determine whether the file has changed. If 
the checksum of the stationery file is different than the checksum of the project 
file, then ePublisher Express will prompt you to synchronize your project.

Any changes to the following settings within the stationery file will affect the 
checksum:
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• Conditions

• Variables

• Cross-reference definitions

• Format settings

Synchronizing Projects to Stationery
Currently in ePublisher Express, there are two ways to synchronize your project 
to a stationery file. The two types of synchronization are:

1. Automatic Synchronization

2. Manual Synchronization

What Is Synchronization?

When synchronization occurs, ePublisher Express is taking the information from 
the standalone stationery file and applying it to your project file. Synchronizing 
the project file to the stationery file will remedy any differences between the two 
files. Once ePublisher Express finishes synchronizing the project to the 
stationery file, all of the settings and information in the project file will match 
that of the stationery file.

When to Synchronize

When you synchronize a project to a stationery file, you are updating the 
information in the project file to match the information in the stationery file. 
Anytime a stationery file has been modified, all projects using that stationery will 
need to be synchronized to pick up the new information in the stationery. If you 
want your project to contain the most recent stationery information, then you 
need to synchronize the project to the stationery file. If you choose not to 
synchronize, your project will retain its old settings and the information in the 
project file will not match the information in the stationery file.

Automatic Synchronization
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When you open an existing project, ePublisher Express automatically detects 
whether any modifications have been made to the standalone stationery file. For 
more information on the modifications that result in project synchronization, 
please see “The Stationery File” on page 88. 

If any changes have been made to the stationery file, ePublisher Express will 
display a dialog window notifying you that the stationery file has been modified. 
When this dialog window displays, you can choose to synchronize your project 
to the modified stationery file, select a new stationery file which to synchronize 
your project.

To automatically synchronize a project to a stationery file:

n When ePublisher Express displays the dialog asking you to synchronize your 
project to the modified stationery file, click the OK button.

Note:  Verify that the path to the stationery file is correct. If it is not, click on 
the folder icon and browse to the location of the stationery file.

Manual Synchronization

You can manually synchronize your project file to a stationery file by selecting 
File > Sychronize with Stationery. When you do this, ePublisher Express will 
prompt you to select a stationery to synchronize to; this means that you can select 
the stationery file to which your project is currently linked or a new stationery 
file.

You can manually synchronize your project to a stationery file, which means that 
you can update your project so that it inherits the information within

To manually synchronize a project to a stationery file:

1. In the project, select File > Synchronize with Stationery.

2. When the Open window displays, browse to the location of the stationery file.

3. Select the stationery (.wxsp) file.

4. Click the Open button.
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