Getting Started with the SQL Data Compare API

SQL Comparison SDK: SQL Data Compare API 7.1

Getting Started with the SQL Data Compare API

The SQL Comparison SDK provides an Application Program Interface that enables you to automate SQL Data Compare. Online help and sample projects are provided to help you to use the SDK.

You can use the SQL Data Compare API to synchronize multiple databases or upgrade your customers' databases without manual intervention.

The SQL Data Compare engine is implemented using .NET assemblies. You can reference them from Visual Studio 2005 or the development environment of your choice.

The SQL Data Compare API requires the .NET Framework version 2.0. Earlier versions of the .NET framework are not supported.

If you would like to access the tools without programming in .NET and you have purchased a Pro version of SQL Data Compare or SQL Toolbelt; you can use the command line interface.

For more information, you can:

  • view the online help for the SQL Comparison SDK

  • contact us at info@red-gate.com

  • visit the Red Gate Software Support Forum.

Licensing the SQL Data Compare API

To use the SQL Data Compare API, you must have a SQL Comparison SDK license. If you do not have a license, you will be able to use the SDK for 14 days, but you will not be able to redistribute your applications.

The assemblies

To automate SQL Data Compare, you use the following .NET assemblies:

  • RedGate.Shared.Utils and RedGate.Shared.SQL

    These assemblies contain routines used by SQL Data Compare. It provides functions to access and execute batches of SQL statements and other helper functions.

  • RedGate.SQLCompare.Engine

    This is the engine behind SQL Compare. For the SQL Data Compare API, it is used to retrieve the database schema.

  • RedGate.SQLDataCompare.Engine

    This is the engine behind SQL Data Compare. It provides classes used for comparing and synchronizing the data in SQL Server databases.

  • RedGate.SQLCompare.BackupReader

    This is the engine behind SQL Compare when comparing against backups. For the SQL Data Compare API, it is used to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later)..

Referencing the assemblies

You can access the SQL Compare and SQL Data Compare engines from C#, Visual Basic .NET, or any other .NET language. The easiest way to do this is from within the Visual Studio .NET environment. Add references in your project to RedGate.SQL.Shared.dll, RedGate.SQLCompare.Engine.dll, and RedGate.SQLDataCompare.Engine.dll.

Using the API

For details of how you use the API to automate the comparison and synchronization of data, see Comparing and Synchronizing Data Using the API.

Sample API Projects

The SQL Data Compare API provides a number of sample API projects in C# and Visual Basic .NET. To download the sample API projects, click here.

The samples demonstrate how to:

  • synchronize databases
  • receive feedback events
  • print data differences to the console
  • use a customized comparison key
  • use a WHERE clause to filter the data
  • compare BLOBs
  • load and save projects
  • compare to a backup file

See Also

Frequently Asked Questions for the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


Getting Started with the SQL Data Compare API

SQL Comparison SDK: SQL Data Compare API 7.1

Getting Started with the SQL Data Compare API

The SQL Comparison SDK provides an Application Program Interface that enables you to automate SQL Data Compare. Online help and sample projects are provided to help you to use the SDK.

You can use the SQL Data Compare API to synchronize multiple databases or upgrade your customers' databases without manual intervention.

The SQL Data Compare engine is implemented using .NET assemblies. You can reference them from Visual Studio 2005 or the development environment of your choice.

The SQL Data Compare API requires the .NET Framework version 2.0. Earlier versions of the .NET framework are not supported.

If you would like to access the tools without programming in .NET and you have purchased a Pro version of SQL Data Compare or SQL Toolbelt; you can use the command line interface.

For more information, you can:

  • view the online help for the SQL Comparison SDK

  • contact us at info@red-gate.com

  • visit the Red Gate Software Support Forum.

Licensing the SQL Data Compare API

To use the SQL Data Compare API, you must have a SQL Comparison SDK license. If you do not have a license, you will be able to use the SDK for 14 days, but you will not be able to redistribute your applications.

The assemblies

To automate SQL Data Compare, you use the following .NET assemblies:

  • RedGate.Shared.Utils and RedGate.Shared.SQL

    These assemblies contain routines used by SQL Data Compare. It provides functions to access and execute batches of SQL statements and other helper functions.

  • RedGate.SQLCompare.Engine

    This is the engine behind SQL Compare. For the SQL Data Compare API, it is used to retrieve the database schema.

  • RedGate.SQLDataCompare.Engine

    This is the engine behind SQL Data Compare. It provides classes used for comparing and synchronizing the data in SQL Server databases.

  • RedGate.SQLCompare.BackupReader

    This is the engine behind SQL Compare when comparing against backups. For the SQL Data Compare API, it is used to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later)..

Referencing the assemblies

You can access the SQL Compare and SQL Data Compare engines from C#, Visual Basic .NET, or any other .NET language. The easiest way to do this is from within the Visual Studio .NET environment. Add references in your project to RedGate.Shared.SQL.dll, RedGate.SQLCompare.Engine.dll, and RedGate.SQLDataCompare.Engine.dll.

Using the API

For details of how you use the API to automate the comparison and synchronization of data, see Comparing and Synchronizing Data Using the API.

Sample API Projects

The SQL Data Compare API provides a number of sample API projects in C# and Visual Basic .NET. To download the sample API projects, click here.

The samples demonstrate how to:

  • synchronize databases
  • receive feedback events
  • print data differences to the console
  • use a customized comparison key
  • use a WHERE clause to filter the data
  • compare BLOBs
  • load and save projects
  • compare to a backup file

See Also

Frequently Asked Questions for the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


Comparing and Synchronizing Data Using the API

SQL Comparison SDK: SQL Data Compare API 7.1

Comparing and Synchronizing Data Using the API

To automate the comparison and synchronization of database data, you use the SQL Data Compare API. You must reference the following assemblies from your Visual Studio .NET project:

  • RedGate.SQL.Shared.Utils
  • RedGate.Shared.SQL
  • RedGate.SQLCompare.Engine
  • RedGate.SQLDataCompare.Engine
  • RedGate.SQLCompare.BackupReader (when comparing to backups)

You will need to have a number of files in the same directory as the program:

  • RedGate.SQLCompare.Rewriter.dll
  • RedGate.SQLCompare.ASTParser.dll

For comparing to backups you will also need:

  • RedGate.BackupReader.dll
  • System.Data.SQLite.dll

For comparing to SQL Backup files you will also need:

  • RedGate.BackupReader.SqbReader.dll
  • RedGate.BackupReader.CryptoHelper.dll
  • rglz.dll
  • zlib1.dll

To compare and synchronize the data:

  1. Create a SqlCompare.Database object and call RegisterForDataCompare with a SqlCompare.ConnectionProperties object.
  2. Set up a SchemaMappings or TableMappings collection containing information about which tables, views, fields, and keys are to be used in the comparison.

    The easiest way to do this is to call CreateMappings on the SchemaMappings or TableMappings object.

  3. Create a ComparisonSession object and call CompareDatabases.
  4. Use the TableDifferences property to view the differences in data between the two databases.
  5. Create a SqlProvider object and call the GetMigrationSQL method to retrieve an ExecutionBlock object containing the synchronization SQL code.
  6. To run the synchronization script, create a BlockExecutor object and call ExecuteBlock, passing in the ExecutionBlock object.

    You can receive feedback events about the progress of the comparison and synchronization by using the ICancellable interface.

  7. Dispose of the objects when you have finished using them.

See Also

Getting Started with the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


Reference

SQL Comparison SDK: SQL Data Compare API 7.0

API Reference Information

The SQL Data Compare API comprises the following assemblies:

  • RedGate.Shared.Utils and is a library used by SQL Data Compare.
  • RedGate.SQLCompare.Engine is used by the SQL Data Compare API to retrieve the database schema.
  • RedGate.SQLDataCompare.Engine is used to automate the comparison and synchronization of data.
  • RedGate.SQLCompare.BackupReader is used by the SQL Data Compare API to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later).

This Reference provides details of the classes, enumerations, interfaces, and delegates provided by these assemblies.

See Also

Getting Started with the SQL Data Compare API

© 2008 Red Gate Software Ltd. All rights reserved.


API Reference Information

SQL Comparison SDK: SQL Data Compare API 7.1

API Reference Information

The SQL Data Compare API comprises the following assemblies:

  • RedGate.Shared.Utils and RedGate.Shared.SQL are libraries used by SQL Data Compare.
  • RedGate.SQLCompare.Engine is used by the SQL Data Compare API to retrieve the database schema.
  • RedGate.SQLDataCompare.Engine is used to automate the comparison and synchronization of data.
  • RedGate.SQLCompare.BackupReader is used by the SQL Data Compare API to retrieve the database schema of a database backup (SQL Server native or SQL Backup v3 or later).

This Reference provides details of the classes, enumerations, interfaces, and delegates provided by these assemblies.

See Also

Getting Started with the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


RedGate.BackupReader Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.BackupReader Namespace

Classes

Class | Description
BackupCommand | Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.
BackupConnection | An implementation of IDbConnection for reading data from MS SQL Server backup files
BackupDataReader | An implementation of IDataReader for reading data from MS SQL Server backup files
BackupReaderCommandBase | Base class for BackupReader commands
BackupReaderException | An exception thrown from within the BackupReader
BackupSet | A representation of a single backup set - i.e. the result of a "BACKUP DATABASE..." statement. There may be many backup sets in one physical file, or many physical files required for one backup set (if the backup is RAIDed). BackupSet objects are serializable to allow persistence in saved projects, and do not contain references to the physical files they were originally derived from. It is the responsibility of the user to ensure that the required physical files are specified when attempting to use a BackupSet.
CollationHelper | A helper class for collation related tasks
LiveCommand | Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.
LiveConnection | An implementation of IBackupConnection for treating a live DB as a page reader
SqlVariant | A representation of the SQL_VARIANT data type.

Structures

Structure | Description
TableName | Representation of a schema-qualified table name, used when populating additional system tables.


BackupCommand Class

[image]

SQL Data Compare API 7.1.0
BackupCommand Class
Members See Also

Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupCommand _
    Inherits BackupReaderCommandBase
C#
public sealed class BackupCommand : BackupReaderCommandBase
Visual C++
public ref class BackupCommand sealed : public BackupReaderCommandBase

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.BackupCommand

See Also

BackupCommand Members
RedGate.BackupReader Namespace


BackupCommand Members

[image] [image]

SQL Data Compare API 7.1.0
BackupCommand Members
BackupCommand Class Methods Properties Explicit Interface Implementations See Also

The BackupCommand type exposes the following members.

Methods

Name | Description
Cancel | Not yet implemented (Inherited from BackupReaderCommandBase.)
CreateParameter | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Dispose | Frees up resources associated with this object (Inherited from BackupReaderCommandBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op (Inherited from BackupReaderCommandBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source. (Inherited from BackupReaderCommandBase.)
CommandTimeout | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported. (Inherited from BackupReaderCommandBase.)
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand. (Inherited from BackupReaderCommandBase.)
Parameters | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Transaction | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
UpdatedRowSource | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

Explicit Interface Implementations

Name | Description
IDbCommand..::.Connection | (Inherited from BackupReaderCommandBase.)
IDbCommand..::.ExecuteReader | (Inherited from BackupReaderCommandBase.)

See Also

BackupCommand Class
RedGate.BackupReader Namespace


BackupConnection Class

[image]

SQL Data Compare API 7.1.0
BackupConnection Class
Members See Also

An implementation of IDbConnection for reading data from MS SQL Server backup files

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupConnection _
    Implements IBackupConnection, IDbConnection, IDisposable, ICancellable
C#
public sealed class BackupConnection : IBackupConnection,
    IDbConnection, IDisposable, ICancellable
Visual C++
public ref class BackupConnection sealed : IBackupConnection,
    IDbConnection, IDisposable, ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupConnection

See Also

BackupConnection Members
RedGate.BackupReader Namespace


BackupConnection Members

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection Members
BackupConnection Class Constructors Methods Properties Explicit Interface Implementations See Also

The BackupConnection type exposes the following members.

Constructors

Name | Description
BackupConnection | Overloaded.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.
CreateCommand | Creates a BackupCommand object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the BackupConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Returns 7, 8, 9, 10 - SQL7, SQL2000, SQL2005, Katmai
ConnectionString | AttachFilename="C:\File1";AttachFilename="C:\File2" AttachFilename=C:\File1;AttachFilename=C:\File2 AttachFilename=c:\blah\backup.sqb (SQL Backup)
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Returns the current active backup set
Database | Not implemented in this implementation
DatabaseGuid | Gets the Database GUID (Family GUID) for decryption in SQL Server 2K
SQLServerInternalVersionNumber | Returns the internal SQL Server version number
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Explicit Interface Implementations

Name | Description
IDbConnection..::.CreateCommand |

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupConnection Constructor

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection Constructor
BackupConnection Class See Also

Overload List

Name | Description
BackupConnection()()() | Creates a new BackupConnection object
BackupConnection(Assembly) | Creates a new BackupConnection object

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


BackupConnection Constructor

[image]

SQL Data Compare API 7.1.0
BackupConnection Constructor
BackupConnection Class See Also

Creates a new BackupConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupConnection()
Visual C++
public:
BackupConnection()

See Also

BackupConnection Class
BackupConnection Overload
RedGate.BackupReader Namespace


BackupConnection Constructor (Assembly)

[image]

SQL Data Compare API 7.1.0
BackupConnection Constructor (Assembly)
BackupConnection Class See Also

Creates a new BackupConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    asm As Assembly _
)
C#
public BackupConnection(
    Assembly asm
)
Visual C++
public:
BackupConnection(
    Assembly^ asm
)

Parameters

asm
Type: System.Reflection..::.Assembly

See Also

BackupConnection Class
BackupConnection Overload
RedGate.BackupReader Namespace


BackupConnection Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection Methods
BackupConnection Class See Also

The BackupConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.
CreateCommand | Creates a BackupCommand object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the BackupConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Explicit Interface Implementations

Name | Description
IDbConnection..::.CreateCommand |

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection..::.BeginTransaction Method
BackupConnection Class See Also

Overload List

Name | Description
BeginTransaction()()() | Not implemented in this implementation
BeginTransaction(IsolationLevel) | Not implemented in this implementation

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


BeginTransaction Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.BeginTransaction Method
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction As IDbTransaction
C#
public IDbTransaction BeginTransaction()
Visual C++
public:
virtual IDbTransaction^ BeginTransaction() sealed

Return Value

Implements

IDbConnection..::.BeginTransaction()()()

See Also

BackupConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


BeginTransaction Method (IsolationLevel)

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.BeginTransaction Method (IsolationLevel)
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction ( _
    il As IsolationLevel _
) As IDbTransaction
C#
public IDbTransaction BeginTransaction(
    IsolationLevel il
)
Visual C++
public:
virtual IDbTransaction^ BeginTransaction(
    IsolationLevel il
) sealed

Parameters

il
Type: System.Data..::.IsolationLevel

Return Value

Implements

IDbConnection..::.BeginTransaction(IsolationLevel)

See Also

BackupConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.CancelOperation Method
BackupConnection Class See Also

Cancels the operation.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ChangeDatabase Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.ChangeDatabase Method
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeDatabase ( _
    databaseName As String _
)
C#
public void ChangeDatabase(
    string databaseName
)
Visual C++
public:
virtual void ChangeDatabase(
    String^ databaseName
) sealed

Parameters

databaseName
Type: System..::.String

Return Value

Implements

IDbConnection..::.ChangeDatabase(String)

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Close Method
BackupConnection Class See Also

Closes the BackupConnection. If executed while Open() is still executing, the Open() operation should be cancelled as soon as possible.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDbConnection..::.Close()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CreateCommand Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.CreateCommand Method
BackupConnection Class See Also

Creates a BackupCommand object for executing against the main data source

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateCommand As BackupCommand
C#
public BackupCommand CreateCommand()
Visual C++
public:
BackupCommand^ CreateCommand()

Return Value

See Also

BackupConnection Class
RedGate.BackupReader Namespace


IDbConnection.CreateCommand Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.IDbConnection..::.CreateCommand Method
BackupConnection Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function CreateCommand As IDbCommand
    Implements IDbConnection.CreateCommand
C#
IDbCommand IDbConnection.CreateCommand()
Visual C++
private:
virtual IDbCommand^ CreateCommand() sealed = IDbConnection::CreateCommand

Implements

IDbConnection..::.CreateCommand()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.CreateSysTableCommand Method
BackupConnection Class See Also

Creates a command on to the queryable system table store

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSysTableCommand As IDbCommand
C#
public IDbCommand CreateSysTableCommand()
Visual C++
public:
virtual IDbCommand^ CreateSysTableCommand() sealed

Return Value

An instance of IDbCommand connected to the system table store

Implements

IBackupConnection..::.CreateSysTableCommand()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Dispose Method
BackupConnection Class See Also

Not implemented yet

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


GetBackupSets Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.GetBackupSets Method
BackupConnection Class See Also

Gets a list of all the backup sets available in the files specified by the ConnectionString. If the ConnectionString is not valid, or has not been set, an InvalidOperationException is thrown. This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets()
Visual C++
public:
virtual IList<IBackupSet^>^ GetBackupSets() sealed

Return Value

Implements

IBackupConnection..::.GetBackupSets()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.IsPasswordRequired Method
BackupConnection Class See Also

Returns whether a password is required for any of the files specified in the connection string, less any passwords that have already been specified on the connection string. That is, if the connection string specifies files f1.sqb and f2.sqb, with passwords p1 and p2, this method will return true until p1 and p2 are both set. However, if an additional file f3.sqb is also specified, with no password, this will return false if p1 and p2 are already specified.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsPasswordRequired As Boolean
C#
public bool IsPasswordRequired()
Visual C++
public:
virtual bool IsPasswordRequired() sealed

Return Value

True if further passwords are required, false otherwise

Implements

IBackupConnection..::.IsPasswordRequired()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Open Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Open Method
BackupConnection Class See Also

Opens the BackupConnection to the source specified in the ConnectionString. Expensive.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Open
C#
public void Open()
Visual C++
public:
virtual void Open() sealed

Implements

IDbConnection..::.Open()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.OpenForMetaInformation Method
BackupConnection Class See Also

Opens the BackupConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub OpenForMetaInformation
C#
public void OpenForMetaInformation()
Visual C++
public:
virtual void OpenForMetaInformation() sealed

Implements

IBackupConnection..::.OpenForMetaInformation()()()

See Also

BackupConnection Class
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection..::.PopulateAdditionalSystemTables Method
BackupConnection Class See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

See Also

BackupConnection Class
BackupConnection Members
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
BackupConnection Class See Also

Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
public void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
) sealed

Parameters

tables
Type: array<ITableName>[]()[]
The schema-qualified name(s) of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(array<ITableName>[]()[])

Exceptions

Exception | Condition
System..::.ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

BackupConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method (List())

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.PopulateAdditionalSystemTables Method (List<(Of <(>)>))
BackupConnection Class See Also

Populates one or more system tables in addition to those already populated during the call to Open(). The BackupConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
public void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
) sealed

Parameters

tables
Type: System.Collections.Generic..::.List <(Of <(ITableName>)>)
A list of the schema-qualified names of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(List<(Of <(ITableName>)>))

Exceptions

Exception | Condition
System..::.ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

BackupConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


UseBackupSet Method

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.UseBackupSet Method
BackupConnection Class See Also

Sets the backup set to be used by this connection. Must be one of the values returned from GetBackupSets(). This call may be quite expensive, especially if the files are SQB, since all the extents need to be mapped.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub UseBackupSet ( _
    ibackupSet As IBackupSet _
)
C#
public void UseBackupSet(
    IBackupSet ibackupSet
)
Visual C++
public:
virtual void UseBackupSet(
    IBackupSet^ ibackupSet
) sealed

Parameters

ibackupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The backup set to use for this connection

Implements

IBackupConnection..::.UseBackupSet(IBackupSet)

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupConnection Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupConnection Properties
BackupConnection Class See Also

The BackupConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Returns 7, 8, 9, 10 - SQL7, SQL2000, SQL2005, Katmai
ConnectionString | AttachFilename="C:\File1";AttachFilename="C:\File2" AttachFilename=C:\File1;AttachFilename=C:\File2 AttachFilename=c:\blah\backup.sqb (SQL Backup)
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Returns the current active backup set
Database | Not implemented in this implementation
DatabaseGuid | Gets the Database GUID (Family GUID) for decryption in SQL Server 2K
SQLServerInternalVersionNumber | Returns the internal SQL Server version number
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.BackupTemporaryDirectory Property
BackupConnection Class See Also

Get the temporary backup data store directory or null if it doesn't exist

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupTemporaryDirectory As String
C#
public string BackupTemporaryDirectory { get; }
Visual C++
public:
virtual property String^ BackupTemporaryDirectory {
    String^ get () sealed;
}

Implements

IBackupConnection..::.BackupTemporaryDirectory

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.CompatibilityVersion Property
BackupConnection Class See Also

Returns 7, 8, 9, 10 - SQL7, SQL2000, SQL2005, Katmai

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompatibilityVersion As Integer
C#
public int CompatibilityVersion { get; }
Visual C++
public:
virtual property int CompatibilityVersion {
    int get () sealed;
}

Implements

IBackupConnection..::.CompatibilityVersion

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ConnectionString Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.ConnectionString Property
BackupConnection Class See Also

AttachFilename="C:\File1";AttachFilename="C:\File2"
AttachFilename=C:\File1;AttachFilename=C:\File2
AttachFilename=c:\blah\backup.sqb (SQL Backup)

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDbConnection..::.ConnectionString

See Also

BackupConnection Class
RedGate.BackupReader Namespace


ConnectionTimeout Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.ConnectionTimeout Property
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionTimeout As Integer
C#
public int ConnectionTimeout { get; }
Visual C++
public:
virtual property int ConnectionTimeout {
    int get () sealed;
}

Return Value

Implements

IDbConnection..::.ConnectionTimeout

See Also

BackupConnection Class
RedGate.BackupReader Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.CurrentBackupSet Property
BackupConnection Class See Also

Returns the current active backup set

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentBackupSet As IBackupSet
C#
public IBackupSet CurrentBackupSet { get; }
Visual C++
public:
virtual property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get () sealed;
}

Return Value

The active BackupSet

Implements

IBackupConnection..::.CurrentBackupSet

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Database Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Database Property
BackupConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As String
C#
public string Database { get; }
Visual C++
public:
virtual property String^ Database {
    String^ get () sealed;
}

Return Value

Implements

IDbConnection..::.Database

See Also

BackupConnection Class
RedGate.BackupReader Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.DatabaseGuid Property
BackupConnection Class See Also

Gets the Database GUID (Family GUID) for decryption in SQL Server 2K

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseGuid As Guid
C#
public Guid DatabaseGuid { get; }
Visual C++
public:
virtual property Guid DatabaseGuid {
    Guid get () sealed;
}

Implements

IBackupConnection..::.DatabaseGuid

See Also

BackupConnection Class
RedGate.BackupReader Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.SQLServerInternalVersionNumber Property
BackupConnection Class See Also

Returns the internal SQL Server version number

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
public int SQLServerInternalVersionNumber { get; }
Visual C++
public:
virtual property int SQLServerInternalVersionNumber {
    int get () sealed;
}

Implements

IBackupConnection..::.SQLServerInternalVersionNumber

See Also

BackupConnection Class
RedGate.BackupReader Namespace


State Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.State Property
BackupConnection Class See Also

Open or Closed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
C#
public ConnectionState State { get; }
Visual C++
public:
virtual property ConnectionState State {
    ConnectionState get () sealed;
}

Implements

IDbConnection..::.State

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Status Property
BackupConnection Class See Also

An event handler for providing progress feedback.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BackupConnection Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
BackupConnection..::.Version Property
BackupConnection Class See Also

Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

Implements

IBackupConnection..::.Version

See Also

BackupConnection Class
RedGate.BackupReader Namespace


BackupDataReader Class

[image]

SQL Data Compare API 7.1.0
BackupDataReader Class
Members See Also

An implementation of IDataReader for reading data from MS SQL Server backup files

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class BackupDataReader _
    Implements IDataReader, IDisposable, IDataRecord
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class BackupDataReader : IDataReader,
    IDisposable, IDataRecord
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class BackupDataReader sealed : IDataReader,
    IDisposable, IDataRecord

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupDataReader

See Also

BackupDataReader Members
RedGate.BackupReader Namespace


BackupDataReader Members

[image] [image]

SQL Data Compare API 7.1.0
BackupDataReader Members
BackupDataReader Class Methods Properties See Also

The BackupDataReader type exposes the following members.

Methods

Name | Description
Close | Closes the BackupReader 0bject.
CollationNameFromId | Get the string version of the collation
Dispose | Frees any resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBoolean | Gets the boolean value of the specified field
GetByte | Gets the 8-bit unsigned integer value of the specified column
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.
GetChar | Gets the character value of the specified column.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | Not implemented
GetDataStream | Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.
GetDataTypeName | Gets the data type information for the specified field.
GetDateTime | Gets the date and time data value of the specified field.
GetDecimal | Gets the fixed-position numeric value of the specified field.
GetDouble | Gets the double-precision floating point number of the specified field.
GetFieldType | Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).
GetFloat | Gets the single-precision floating point number of the specified field.
GetGuid | Returns the GUID value of the specified field.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInt16 | Gets the 16-bit signed integer value of the specified field.
GetInt32 | Gets the 32-bit signed integer value of the specified field.
GetInt64 | Gets the 64-bit signed integer value of the specified field.
GetName | Gets the name for the field to find.
GetOrdinal | Return the index of the named field.
GetSchemaTable | Not implemented
GetSqlBinary | Returns a SqlBinary corresponding to the contents of the specified field
GetSqlBoolean | Gets the SqlBoolean value of the specified field
GetSqlByte | Gets the 8-bit unsigned integer value of the specified column
GetSqlBytes | Returns an array of bytes corresponding to the contents of the specified field
GetSqlChars | Gets a SqlChars object representing the string value of the column
GetSqlDate | Gets a string representation of the Sql Server 2008 SqlDate object
GetSqlDateTime | Gets the date and time data value of the specified field.
GetSqlDateTime2 | Gets a string representation of the Sql Server 2008 SqlDateTime2 object
GetSqlDateTimeOffset | Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object
GetSqlDecimal | Gets the fixed-position numeric value of the specified field.
GetSqlDouble | Gets the double-precision floating point number of the specified field.
GetSqlGuid | Returns the GUID value of the specified field.
GetSqlInt16 | Gets the 16-bit signed integer value of the specified field.
GetSqlInt32 | Gets the 32-bit signed integer value of the specified field.
GetSqlInt64 | Gets the 64-bit signed integer value of the specified field.
GetSqlMoney | Gets the SqlMoney value of the specified field
GetSqlSingle | Gets the single-precision floating point number of the specified field.
GetSqlString | Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.
GetSqlTime | Gets a string representation of the Sql Server 2008 SqlTime object
GetSqlVariant | Gets the SqlVariant value of the specified field
GetSqlXml | Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.
GetString | Gets the string value of the specified field.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Return the value of the specified field.
GetValues | Gets all the attribute fields in the collection for the current record.
IsDBNull | Return whether the specified field is set to null.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextResult | Not implemented
Read | Advances the BackupReader to the next record.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Depth | Gets a value indicating the depth of nesting for the current row.
FieldCount | Gets the number of fields in each row
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded.
RecordsAffected | Not implemented

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupDataReader Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupDataReader Methods
BackupDataReader Class See Also

The BackupDataReader type exposes the following methods.

Methods

Name | Description
Close | Closes the BackupReader 0bject.
CollationNameFromId | Get the string version of the collation
Dispose | Frees any resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBoolean | Gets the boolean value of the specified field
GetByte | Gets the 8-bit unsigned integer value of the specified column
GetBytes | Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.
GetChar | Gets the character value of the specified column.
GetChars | Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.
GetData | Not implemented
GetDataStream | Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.
GetDataTypeName | Gets the data type information for the specified field.
GetDateTime | Gets the date and time data value of the specified field.
GetDecimal | Gets the fixed-position numeric value of the specified field.
GetDouble | Gets the double-precision floating point number of the specified field.
GetFieldType | Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).
GetFloat | Gets the single-precision floating point number of the specified field.
GetGuid | Returns the GUID value of the specified field.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInt16 | Gets the 16-bit signed integer value of the specified field.
GetInt32 | Gets the 32-bit signed integer value of the specified field.
GetInt64 | Gets the 64-bit signed integer value of the specified field.
GetName | Gets the name for the field to find.
GetOrdinal | Return the index of the named field.
GetSchemaTable | Not implemented
GetSqlBinary | Returns a SqlBinary corresponding to the contents of the specified field
GetSqlBoolean | Gets the SqlBoolean value of the specified field
GetSqlByte | Gets the 8-bit unsigned integer value of the specified column
GetSqlBytes | Returns an array of bytes corresponding to the contents of the specified field
GetSqlChars | Gets a SqlChars object representing the string value of the column
GetSqlDate | Gets a string representation of the Sql Server 2008 SqlDate object
GetSqlDateTime | Gets the date and time data value of the specified field.
GetSqlDateTime2 | Gets a string representation of the Sql Server 2008 SqlDateTime2 object
GetSqlDateTimeOffset | Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object
GetSqlDecimal | Gets the fixed-position numeric value of the specified field.
GetSqlDouble | Gets the double-precision floating point number of the specified field.
GetSqlGuid | Returns the GUID value of the specified field.
GetSqlInt16 | Gets the 16-bit signed integer value of the specified field.
GetSqlInt32 | Gets the 32-bit signed integer value of the specified field.
GetSqlInt64 | Gets the 64-bit signed integer value of the specified field.
GetSqlMoney | Gets the SqlMoney value of the specified field
GetSqlSingle | Gets the single-precision floating point number of the specified field.
GetSqlString | Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.
GetSqlTime | Gets a string representation of the Sql Server 2008 SqlTime object
GetSqlVariant | Gets the SqlVariant value of the specified field
GetSqlXml | Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.
GetString | Gets the string value of the specified field.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Return the value of the specified field.
GetValues | Gets all the attribute fields in the collection for the current record.
IsDBNull | Return whether the specified field is set to null.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextResult | Not implemented
Read | Advances the BackupReader to the next record.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Close Method
BackupDataReader Class See Also

Closes the BackupReader 0bject.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDataReader..::.Close()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


CollationNameFromId Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.CollationNameFromId Method
BackupDataReader Class See Also

Get the string version of the collation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CollationNameFromId ( _
    id As Integer _
) As String
C#
public string CollationNameFromId(
    int id
)
Visual C++
public:
virtual String^ CollationNameFromId(
    int id
) sealed

Parameters

id
Type: System..::.Int32
collation id

Return Value

collation

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Dispose Method
BackupDataReader Class See Also

Frees any resources associated with this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetBoolean Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetBoolean Method
BackupDataReader Class See Also

Gets the boolean value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBoolean ( _
    i As Integer _
) As Boolean
C#
public bool GetBoolean(
    int i
)
Visual C++
public:
virtual bool GetBoolean(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

Return Value

The value of the column

Implements

IDataRecord..::.GetBoolean(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetByte Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetByte Method
BackupDataReader Class See Also

Gets the 8-bit unsigned integer value of the specified column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetByte ( _
    i As Integer _
) As Byte
C#
public byte GetByte(
    int i
)
Visual C++
public:
virtual unsigned char GetByte(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

Return Value

The 8-bit unsigned integer value of the specified column

Implements

IDataRecord..::.GetByte(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetBytes Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetBytes Method
BackupDataReader Class See Also

Reads a stream of bytes from the specified column offset into the buffer as an array, starting at the given buffer offset. If the target buffer is null, then the number of bytes available in the field is returned.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBytes ( _
    i As Integer, _
    fieldOffset As Long, _
    buffer As Byte(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
C#
public long GetBytes(
    int i,
    long fieldOffset,
    byte[] buffer,
    int bufferoffset,
    int length
)
Visual C++
public:
virtual long long GetBytes(
    int i,
    long long fieldOffset,
    array<unsigned char>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal.
fieldOffset
Type: System..::.Int64
The index within the field from which to start the read operation.
buffer
Type: array< System..::.Byte >[]()[]
The buffer into which to read the stream of bytes.
bufferoffset
Type: System..::.Int32
The index for buffer to start the read operation.
length
Type: System..::.Int32
The number of bytes to read.

Return Value

The actual number of bytes read.

Implements

IDataRecord..::.GetBytes(Int32, Int64, array<Byte>[]()[], Int32, Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetChar Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetChar Method
BackupDataReader Class See Also

Gets the character value of the specified column.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChar ( _
    i As Integer _
) As Char
C#
public char GetChar(
    int i
)
Visual C++
public:
virtual wchar_t GetChar(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal.

Return Value

The character value of the specified column.

Implements

IDataRecord..::.GetChar(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetChars Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetChars Method
BackupDataReader Class See Also

Reads a stream of characters from the specified column offset into the buffer as an array, starting at the given buffer offset.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChars ( _
    i As Integer, _
    fieldoffset As Long, _
    buffer As Char(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
C#
public long GetChars(
    int i,
    long fieldoffset,
    char[] buffer,
    int bufferoffset,
    int length
)
Visual C++
public:
virtual long long GetChars(
    int i,
    long long fieldoffset,
    array<wchar_t>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal.
fieldoffset
Type: System..::.Int64
The index within the row from which to start the read operation.
buffer
Type: array< System..::.Char >[]()[]
The buffer into which to read the stream of bytes.
bufferoffset
Type: System..::.Int32
The index for buffer to start the read operation.
length
Type: System..::.Int32
The number of bytes to read.

Return Value

The actual number of characters read.

Implements

IDataRecord..::.GetChars(Int32, Int64, array<Char>[]()[], Int32, Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetData Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetData Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData ( _
    i As Integer _
) As IDataReader
C#
public IDataReader GetData(
    int i
)
Visual C++
public:
virtual IDataReader^ GetData(
    int i
) sealed

Parameters

i
Type: System..::.Int32

Return Value

Implements

IDataRecord..::.GetData(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDataStream Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetDataStream Method
BackupDataReader Class See Also

Gets a stream for the field specified. The stream is not necessarily seekable, but does allow memory-efficient access to large BLOBs, as fragments are only read in as required.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStream ( _
    i As Integer _
) As Stream
C#
public Stream GetDataStream(
    int i
)
Visual C++
public:
virtual Stream^ GetDataStream(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

A Stream corresponding to the raw data of the field requested, or null.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDataTypeName Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetDataTypeName Method
BackupDataReader Class See Also

Gets the data type information for the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataTypeName ( _
    i As Integer _
) As String
C#
public string GetDataTypeName(
    int i
)
Visual C++
public:
virtual String^ GetDataTypeName(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The data type information for the specified field.

Implements

IDataRecord..::.GetDataTypeName(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDateTime Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetDateTime Method
BackupDataReader Class See Also

Gets the date and time data value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDateTime ( _
    i As Integer _
) As DateTime
C#
public DateTime GetDateTime(
    int i
)
Visual C++
public:
virtual DateTime GetDateTime(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The date and time data value of the spcified field.

Implements

IDataRecord..::.GetDateTime(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDecimal Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetDecimal Method
BackupDataReader Class See Also

Gets the fixed-position numeric value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDecimal ( _
    i As Integer _
) As Decimal
C#
public decimal GetDecimal(
    int i
)
Visual C++
public:
virtual Decimal GetDecimal(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The fixed-position numeric value of the specified field.

Implements

IDataRecord..::.GetDecimal(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetDouble Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetDouble Method
BackupDataReader Class See Also

Gets the double-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDouble ( _
    i As Integer _
) As Double
C#
public double GetDouble(
    int i
)
Visual C++
public:
virtual double GetDouble(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The double-precision floating point number of the specified field.

Implements

IDataRecord..::.GetDouble(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetFieldType Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetFieldType Method
BackupDataReader Class See Also

Gets the System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFieldType ( _
    i As Integer _
) As Type
C#
public Type GetFieldType(
    int i
)
Visual C++
public:
virtual Type^ GetFieldType(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The System.Type information corresponding to the type of System.Object that would be returned from System.Data.IDataRecord.GetValue(System.Int32).

Implements

IDataRecord..::.GetFieldType(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetFloat Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetFloat Method
BackupDataReader Class See Also

Gets the single-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFloat ( _
    i As Integer _
) As Single
C#
public float GetFloat(
    int i
)
Visual C++
public:
virtual float GetFloat(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The single-precision floating point number of the specified field.

Implements

IDataRecord..::.GetFloat(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetGuid Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetGuid Method
BackupDataReader Class See Also

Returns the GUID value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetGuid ( _
    i As Integer _
) As Guid
C#
public Guid GetGuid(
    int i
)
Visual C++
public:
virtual Guid GetGuid(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The GUID value of the specified field.

Implements

IDataRecord..::.GetGuid(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt16 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetInt16 Method
BackupDataReader Class See Also

Gets the 16-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt16 ( _
    i As Integer _
) As Short
C#
public short GetInt16(
    int i
)
Visual C++
public:
virtual short GetInt16(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 16-bit signed integer value of the specified field.

Implements

IDataRecord..::.GetInt16(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt32 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetInt32 Method
BackupDataReader Class See Also

Gets the 32-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt32 ( _
    i As Integer _
) As Integer
C#
public int GetInt32(
    int i
)
Visual C++
public:
virtual int GetInt32(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 32-bit signed integer value of the specified field.

Implements

IDataRecord..::.GetInt32(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetInt64 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetInt64 Method
BackupDataReader Class See Also

Gets the 64-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInt64 ( _
    i As Integer _
) As Long
C#
public long GetInt64(
    int i
)
Visual C++
public:
virtual long long GetInt64(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 64-bit signed integer value of the specified field.

Implements

IDataRecord..::.GetInt64(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetName Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetName Method
BackupDataReader Class See Also

Gets the name for the field to find.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetName ( _
    i As Integer _
) As String
C#
public string GetName(
    int i
)
Visual C++
public:
virtual String^ GetName(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The name of the field or the empty string (""), if there is no value to return.

Implements

IDataRecord..::.GetName(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetOrdinal Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetOrdinal Method
BackupDataReader Class See Also

Return the index of the named field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOrdinal ( _
    name As String _
) As Integer
C#
public int GetOrdinal(
    string name
)
Visual C++
public:
virtual int GetOrdinal(
    String^ name
) sealed

Parameters

name
Type: System..::.String
The name of the field to find.

Return Value

The index of the named field.

Implements

IDataRecord..::.GetOrdinal(String)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSchemaTable Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSchemaTable Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSchemaTable As DataTable
C#
public DataTable GetSchemaTable()
Visual C++
public:
virtual DataTable^ GetSchemaTable() sealed

Return Value

Implements

IDataReader..::.GetSchemaTable()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBinary Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlBinary Method
BackupDataReader Class See Also

Returns a SqlBinary corresponding to the contents of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBinary ( _
    i As Integer _
) As SqlBinary
C#
public SqlBinary GetSqlBinary(
    int i
)
Visual C++
public:
virtual SqlBinary GetSqlBinary(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBoolean Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlBoolean Method
BackupDataReader Class See Also

Gets the SqlBoolean value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBoolean ( _
    i As Integer _
) As SqlBoolean
C#
public SqlBoolean GetSqlBoolean(
    int i
)
Visual C++
public:
virtual SqlBoolean GetSqlBoolean(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlByte Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlByte Method
BackupDataReader Class See Also

Gets the 8-bit unsigned integer value of the specified column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlByte ( _
    i As Integer _
) As SqlByte
C#
public SqlByte GetSqlByte(
    int i
)
Visual C++
public:
virtual SqlByte GetSqlByte(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

Return Value

The 8-bit unsigned integer value of the specified column

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlBytes Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlBytes Method
BackupDataReader Class See Also

Returns an array of bytes corresponding to the contents of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlBytes ( _
    i As Integer _
) As SqlBytes
C#
public SqlBytes GetSqlBytes(
    int i
)
Visual C++
public:
virtual SqlBytes^ GetSqlBytes(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlChars Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlChars Method
BackupDataReader Class See Also

Gets a SqlChars object representing the string value of the column

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlChars ( _
    i As Integer _
) As SqlChars
C#
public SqlChars GetSqlChars(
    int i
)
Visual C++
public:
virtual SqlChars^ GetSqlChars(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based column ordinal

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDate Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDate Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDate object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDate ( _
    i As Integer _
) As String
C#
public string GetSqlDate(
    int i
)
Visual C++
public:
virtual String^ GetSqlDate(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTime Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDateTime Method
BackupDataReader Class See Also

Gets the date and time data value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTime ( _
    i As Integer _
) As SqlDateTime
C#
public SqlDateTime GetSqlDateTime(
    int i
)
Visual C++
public:
virtual SqlDateTime GetSqlDateTime(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The date and time data value of the spcified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTime2 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDateTime2 Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDateTime2 object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTime2 ( _
    i As Integer _
) As String
C#
public string GetSqlDateTime2(
    int i
)
Visual C++
public:
virtual String^ GetSqlDateTime2(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDateTimeOffset Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDateTimeOffset Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlDateTimeOffset object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDateTimeOffset ( _
    i As Integer _
) As String
C#
public string GetSqlDateTimeOffset(
    int i
)
Visual C++
public:
virtual String^ GetSqlDateTimeOffset(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDecimal Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDecimal Method
BackupDataReader Class See Also

Gets the fixed-position numeric value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDecimal ( _
    i As Integer _
) As SqlDecimal
C#
public SqlDecimal GetSqlDecimal(
    int i
)
Visual C++
public:
virtual SqlDecimal GetSqlDecimal(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The fixed-position numeric value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlDouble Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlDouble Method
BackupDataReader Class See Also

Gets the double-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDouble ( _
    i As Integer _
) As SqlDouble
C#
public SqlDouble GetSqlDouble(
    int i
)
Visual C++
public:
virtual SqlDouble GetSqlDouble(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The double-precision floating point number of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlGuid Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlGuid Method
BackupDataReader Class See Also

Returns the GUID value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlGuid ( _
    i As Integer _
) As SqlGuid
C#
public SqlGuid GetSqlGuid(
    int i
)
Visual C++
public:
virtual SqlGuid GetSqlGuid(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The GUID value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt16 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlInt16 Method
BackupDataReader Class See Also

Gets the 16-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt16 ( _
    i As Integer _
) As SqlInt16
C#
public SqlInt16 GetSqlInt16(
    int i
)
Visual C++
public:
virtual SqlInt16 GetSqlInt16(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 16-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt32 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlInt32 Method
BackupDataReader Class See Also

Gets the 32-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt32 ( _
    i As Integer _
) As SqlInt32
C#
public SqlInt32 GetSqlInt32(
    int i
)
Visual C++
public:
virtual SqlInt32 GetSqlInt32(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 32-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlInt64 Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlInt64 Method
BackupDataReader Class See Also

Gets the 64-bit signed integer value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlInt64 ( _
    i As Integer _
) As SqlInt64
C#
public SqlInt64 GetSqlInt64(
    int i
)
Visual C++
public:
virtual SqlInt64 GetSqlInt64(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The 64-bit signed integer value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlMoney Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlMoney Method
BackupDataReader Class See Also

Gets the SqlMoney value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlMoney ( _
    i As Integer _
) As SqlMoney
C#
public SqlMoney GetSqlMoney(
    int i
)
Visual C++
public:
virtual SqlMoney GetSqlMoney(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The zero-based index of the field to get

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlSingle Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlSingle Method
BackupDataReader Class See Also

Gets the single-precision floating point number of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlSingle ( _
    i As Integer _
) As SqlSingle
C#
public SqlSingle GetSqlSingle(
    int i
)
Visual C++
public:
virtual SqlSingle GetSqlSingle(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The single-precision floating point number of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlString Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlString Method
BackupDataReader Class See Also

Gets the string value of the specified field. This also works for XML fields (SQL 2005), where the original XML string is returned.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlString ( _
    i As Integer _
) As SqlString
C#
public SqlString GetSqlString(
    int i
)
Visual C++
public:
virtual SqlString GetSqlString(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The string value of the specified field.

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlTime Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlTime Method
BackupDataReader Class See Also

Gets a string representation of the Sql Server 2008 SqlTime object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlTime ( _
    i As Integer _
) As String
C#
public string GetSqlTime(
    int i
)
Visual C++
public:
virtual String^ GetSqlTime(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlVariant Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlVariant Method
BackupDataReader Class See Also

Gets the SqlVariant value of the specified field

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlVariant ( _
    i As Integer _
) As ISqlVariant
C#
public ISqlVariant GetSqlVariant(
    int i
)
Visual C++
public:
virtual ISqlVariant^ GetSqlVariant(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetSqlXml Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetSqlXml Method
BackupDataReader Class See Also

Gets the XML value of the specified field. Note: MSXML doesn't preserve newlines correctly - the original XML uses LF as newline, but the result of SqlXml.Value uses CRLF instead. This causes SQL Data Compare to consider them different, and hence this method should not be used where this is important.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlXml ( _
    i As Integer _
) As SqlXml
C#
public SqlXml GetSqlXml(
    int i
)
Visual C++
public:
virtual SqlXml^ GetSqlXml(
    int i
) sealed

Parameters

i
Type: System..::.Int32
Zero-based index of the field

Return Value

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetString Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetString Method
BackupDataReader Class See Also

Gets the string value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetString ( _
    i As Integer _
) As String
C#
public string GetString(
    int i
)
Visual C++
public:
virtual String^ GetString(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The string value of the specified field.

Implements

IDataRecord..::.GetString(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetValue Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetValue Method
BackupDataReader Class See Also

Return the value of the specified field.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue ( _
    i As Integer _
) As Object
C#
public Object GetValue(
    int i
)
Visual C++
public:
virtual Object^ GetValue(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

The System.Object which will contain the field value upon return.

Implements

IDataRecord..::.GetValue(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


GetValues Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.GetValues Method
BackupDataReader Class See Also

Gets all the attribute fields in the collection for the current record.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues ( _
    values As Object() _
) As Integer
C#
public int GetValues(
    Object[] values
)
Visual C++
public:
virtual int GetValues(
    array<Object^>^ values
) sealed

Parameters

values
Type: array< System..::.Object >[]()[]
An array of System.Object to copy the attribute fields into.

Return Value

The number of instances of System.Object in the array.

Implements

IDataRecord..::.GetValues(array<Object>[]()[])

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


IsDBNull Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.IsDBNull Method
BackupDataReader Class See Also

Return whether the specified field is set to null.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsDBNull ( _
    i As Integer _
) As Boolean
C#
public bool IsDBNull(
    int i
)
Visual C++
public:
virtual bool IsDBNull(
    int i
) sealed

Parameters

i
Type: System..::.Int32
The index of the field to find.

Return Value

true if the specified field is set to null. Otherwise, false.

Implements

IDataRecord..::.IsDBNull(Int32)

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


NextResult Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.NextResult Method
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function NextResult As Boolean
C#
public bool NextResult()
Visual C++
public:
virtual bool NextResult() sealed

Return Value

Implements

IDataReader..::.NextResult()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Read Method

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Read Method
BackupDataReader Class See Also

Advances the BackupReader to the next record.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Read As Boolean
C#
public bool Read()
Visual C++
public:
virtual bool Read() sealed

Return Value

true if there are more rows; otherwise, false.

Implements

IDataReader..::.Read()()()

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupDataReader Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupDataReader Properties
BackupDataReader Class See Also

The BackupDataReader type exposes the following properties.

Properties

Name | Description
Depth | Gets a value indicating the depth of nesting for the current row.
FieldCount | Gets the number of fields in each row
IsClosed | Gets a value indicating whether the data reader is closed.
Item | Overloaded.
RecordsAffected | Not implemented

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Depth Property

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Depth Property
BackupDataReader Class See Also

Gets a value indicating the depth of nesting for the current row.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Depth As Integer
C#
public int Depth { get; }
Visual C++
public:
virtual property int Depth {
    int get () sealed;
}

Implements

IDataReader..::.Depth

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


FieldCount Property

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.FieldCount Property
BackupDataReader Class See Also

Gets the number of fields in each row

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldCount As Integer
C#
public int FieldCount { get; }
Visual C++
public:
virtual property int FieldCount {
    int get () sealed;
}

Implements

IDataRecord..::.FieldCount

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


IsClosed Property

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.IsClosed Property
BackupDataReader Class See Also

Gets a value indicating whether the data reader is closed.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
C#
public bool IsClosed { get; }
Visual C++
public:
virtual property bool IsClosed {
    bool get () sealed;
}

Implements

IDataReader..::.IsClosed

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Item Property
BackupDataReader Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the column located at the specified index.
Item[([(String])]) | Gets the column with the specified name.

See Also

BackupDataReader Class
BackupDataReader Members
RedGate.BackupReader Namespace


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Item Property (Int32)
BackupDataReader Class See Also

Gets the column located at the specified index.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    i As Integer _
) As Object
C#
public Object this[
    int i
] { get; }
Visual C++
public:
virtual property Object^ default[int i] {
    Object^ get (int i) sealed;
}

Parameters

i
Type: System..::.Int32
The index of the column to get.

Return Value

The column located at the specified index as an System.Object.

Implements

IDataRecord..::.Item[([(Int32])])

See Also

BackupDataReader Class
Item Overload
RedGate.BackupReader Namespace


Item Property (String)

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.Item Property (String)
BackupDataReader Class See Also

Gets the column with the specified name.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Object
C#
public Object this[
    string name
] { get; }
Visual C++
public:
virtual property Object^ default[String^ name] {
    Object^ get (String^ name) sealed;
}

Parameters

name
Type: System..::.String
The name of the column to find.

Return Value

The column with the specified name as an System.Object.

Implements

IDataRecord..::.Item[([(String])])

See Also

BackupDataReader Class
Item Overload
RedGate.BackupReader Namespace


RecordsAffected Property

[image]

SQL Data Compare API 7.1.0
BackupDataReader..::.RecordsAffected Property
BackupDataReader Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordsAffected As Integer
C#
public int RecordsAffected { get; }
Visual C++
public:
virtual property int RecordsAffected {
    int get () sealed;
}

Implements

IDataReader..::.RecordsAffected

See Also

BackupDataReader Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Class

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase Class
Members See Also

Base class for BackupReader commands

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BackupReaderCommandBase _
    Implements IDbCommand, IDisposable
C#
public abstract class BackupReaderCommandBase : IDbCommand,
    IDisposable
Visual C++
public ref class BackupReaderCommandBase abstract : IDbCommand,
    IDisposable

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.BackupCommand
RedGate.BackupReader..::.LiveCommand

See Also

BackupReaderCommandBase Members
RedGate.BackupReader Namespace


BackupReaderCommandBase Members

[image] [image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase Members
BackupReaderCommandBase Class Constructors Methods Properties Explicit Interface Implementations See Also

The BackupReaderCommandBase type exposes the following members.

Constructors

Name | Description
BackupReaderCommandBase |

Methods

Name | Description
Cancel | Not yet implemented
CreateParameter | Not implemented in this implementation
Dispose | Frees up resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source.
CommandTimeout | Not implemented in this implementation
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.
Parameters | Not implemented in this implementation
Transaction | Not implemented in this implementation
UpdatedRowSource | Not implemented in this implementation

Explicit Interface Implementations

Name | Description
IDbCommand..::.Connection |
IDbCommand..::.ExecuteReader |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Constructor

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase Constructor
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected BackupReaderCommandBase()
Visual C++
protected:
BackupReaderCommandBase()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase Methods
BackupReaderCommandBase Class See Also

The BackupReaderCommandBase type exposes the following methods.

Methods

Name | Description
Cancel | Not yet implemented
CreateParameter | Not implemented in this implementation
Dispose | Frees up resources associated with this object
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDbCommand..::.ExecuteReader |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Cancel Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Cancel Method
BackupReaderCommandBase Class See Also

Not yet implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Cancel
C#
public void Cancel()
Visual C++
public:
virtual void Cancel() sealed

Implements

IDbCommand..::.Cancel()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CreateParameter Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.CreateParameter Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateParameter As IDbDataParameter
C#
public IDbDataParameter CreateParameter()
Visual C++
public:
virtual IDbDataParameter^ CreateParameter() sealed

Return Value

Implements

IDbCommand..::.CreateParameter()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Dispose Method
BackupReaderCommandBase Class See Also

Frees up resources associated with this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteNonQuery Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.ExecuteNonQuery Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteNonQuery As Integer
C#
public int ExecuteNonQuery()
Visual C++
public:
virtual int ExecuteNonQuery() sealed

Return Value

Implements

IDbCommand..::.ExecuteNonQuery()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteReader Method

[image] [image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.ExecuteReader Method
BackupReaderCommandBase Class See Also

Overload List

Name | Description
ExecuteReader()()() |
ExecuteReader(CommandBehavior) | Not implemented in this implementation

See Also

BackupReaderCommandBase Class
BackupReaderCommandBase Members
RedGate.BackupReader Namespace


ExecuteReader Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.ExecuteReader Method
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteReader As BackupDataReader
C#
public BackupDataReader ExecuteReader()
Visual C++
public:
BackupDataReader^ ExecuteReader()

See Also

BackupReaderCommandBase Class
ExecuteReader Overload
RedGate.BackupReader Namespace


ExecuteReader Method (CommandBehavior)

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.ExecuteReader Method (CommandBehavior)
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteReader ( _
    behavior As CommandBehavior _
) As IDataReader
C#
public IDataReader ExecuteReader(
    CommandBehavior behavior
)
Visual C++
public:
virtual IDataReader^ ExecuteReader(
    CommandBehavior behavior
) sealed

Parameters

behavior
Type: System.Data..::.CommandBehavior

Return Value

Implements

IDbCommand..::.ExecuteReader(CommandBehavior)

See Also

BackupReaderCommandBase Class
ExecuteReader Overload
RedGate.BackupReader Namespace


IDbCommand.ExecuteReader Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.IDbCommand..::.ExecuteReader Method
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function ExecuteReader As IDataReader
    Implements IDbCommand.ExecuteReader
C#
IDataReader IDbCommand.ExecuteReader()
Visual C++
private:
virtual IDataReader^ ExecuteReader() sealed = IDbCommand::ExecuteReader

Implements

IDbCommand..::.ExecuteReader()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


ExecuteScalar Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.ExecuteScalar Method
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteScalar As Object
C#
public Object ExecuteScalar()
Visual C++
public:
virtual Object^ ExecuteScalar() sealed

Return Value

Implements

IDbCommand..::.ExecuteScalar()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Prepare Method

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Prepare Method
BackupReaderCommandBase Class See Also

Intentional No-op

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Prepare
C#
public void Prepare()
Visual C++
public:
virtual void Prepare() sealed

Implements

IDbCommand..::.Prepare()()()

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderCommandBase Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase Properties
BackupReaderCommandBase Class See Also

The BackupReaderCommandBase type exposes the following properties.

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source.
CommandTimeout | Not implemented in this implementation
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.
Parameters | Not implemented in this implementation
Transaction | Not implemented in this implementation
UpdatedRowSource | Not implemented in this implementation

Explicit Interface Implementations

Name | Description
IDbCommand..::.Connection |

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandText Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.CommandText Property
BackupReaderCommandBase Class See Also

Gets or sets the text command to run against the data source.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandText As String
C#
public string CommandText { get; set; }
Visual C++
public:
virtual property String^ CommandText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDbCommand..::.CommandText

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandTimeout Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.CommandTimeout Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout { get; set; }
Visual C++
public:
virtual property int CommandTimeout {
    int get () sealed;
    void set (int value) sealed;
}

Return Value

Implements

IDbCommand..::.CommandTimeout

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


CommandType Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.CommandType Property
BackupReaderCommandBase Class See Also

Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property CommandType As CommandType
C#
public CommandType CommandType { get; set; }
Visual C++
public:
virtual property CommandType CommandType {
    CommandType get () sealed;
    void set (CommandType value) sealed;
}

Implements

IDbCommand..::.CommandType

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Connection Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Connection Property
BackupReaderCommandBase Class See Also

Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Connection As IDbConnection
C#
public IDbConnection Connection { get; set; }
Visual C++
public:
property IDbConnection^ Connection {
    IDbConnection^ get ();
    void set (IDbConnection^ value);
}

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


IDbCommand.Connection Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.IDbCommand..::.Connection Property
BackupReaderCommandBase Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Property Connection As IDbConnection
    Implements IDbCommand.Connection
C#
IDbConnection IDbCommand.Connection { get; set; }
Visual C++
private:
virtual property IDbConnection^ Connection {
    IDbConnection^ get () sealed = IDbCommand::Connection::get;
    void set (IDbConnection^ value) sealed = IDbCommand::Connection::set;
}

Implements

IDbCommand..::.Connection

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Parameters Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Parameters Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IDataParameterCollection
C#
public IDataParameterCollection Parameters { get; }
Visual C++
public:
virtual property IDataParameterCollection^ Parameters {
    IDataParameterCollection^ get () sealed;
}

Return Value

Implements

IDbCommand..::.Parameters

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


Transaction Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.Transaction Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Transaction As IDbTransaction
C#
public IDbTransaction Transaction { get; set; }
Visual C++
public:
virtual property IDbTransaction^ Transaction {
    IDbTransaction^ get () sealed;
    void set (IDbTransaction^ value) sealed;
}

Return Value

Implements

IDbCommand..::.Transaction

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


UpdatedRowSource Property

[image]

SQL Data Compare API 7.1.0
BackupReaderCommandBase..::.UpdatedRowSource Property
BackupReaderCommandBase Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdatedRowSource As UpdateRowSource
C#
public UpdateRowSource UpdatedRowSource { get; set; }
Visual C++
public:
virtual property UpdateRowSource UpdatedRowSource {
    UpdateRowSource get () sealed;
    void set (UpdateRowSource value) sealed;
}

Return Value

Implements

IDbCommand..::.UpdatedRowSource

See Also

BackupReaderCommandBase Class
RedGate.BackupReader Namespace


BackupReaderException Class

[image]

SQL Data Compare API 7.1.0
BackupReaderException Class
Members See Also

An exception thrown from within the BackupReader

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Class BackupReaderException _
    Inherits Exception
C#
public class BackupReaderException : Exception
Visual C++
public ref class BackupReaderException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.BackupReader..::.BackupReaderException

See Also

BackupReaderException Members
RedGate.BackupReader Namespace


BackupReaderException Members

[image] [image]

SQL Data Compare API 7.1.0
BackupReaderException Members
BackupReaderException Class Methods Properties See Also

The BackupReaderException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BackupReaderException Class
RedGate.BackupReader Namespace


BackupSet Class

[image]

SQL Data Compare API 7.1.0
BackupSet Class
Members See Also

A representation of a single backup set - i.e. the result of a "BACKUP DATABASE..." statement. There may be many backup sets in one physical file, or many physical files required for one backup set (if the backup is RAIDed). BackupSet objects are serializable to allow persistence in saved projects, and do not contain references to the physical files they were originally derived from. It is the responsibility of the user to ensure that the required physical files are specified when attempting to use a BackupSet.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class BackupSet _
    Implements IBackupSet, IComparable(Of BackupSet)
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class BackupSet : IBackupSet,
    IComparable<BackupSet>
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class BackupSet sealed : IBackupSet,
    IComparable<BackupSet^>

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupSet

See Also

BackupSet Members
RedGate.BackupReader Namespace


BackupSet Members

[image] [image]

SQL Data Compare API 7.1.0
BackupSet Members
BackupSet Class Constructors Methods Properties See Also

The BackupSet type exposes the following members.

Constructors

Name | Description
BackupSet | A parameterless constructor needed for IRedGateSerializable.

Methods

Name | Description
CompareTo | Compares the current object with another BackupSet object
Deserialize | This method deserializes the object from the current serialization
Equals | Returns whether this BackupSet is equal to the object specified (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets a hash code representing this object (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialize up you data. (Nb the version number has already been added in)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
CheckpointLsn | Log sequence number of most recent checkpoint of this backup
DatabaseName | The original database name
Encrypted | Returns whether the BackupSet is encrypted or not.
EndDate | The date and time the backup completed
FirstLsn | First log sequence number of this backup
FullBackupLsn | Log sequence number of the full backup associated with this backup
LastLsn | Last log sequence number of this backup
Name | The name of the backupset, if one is set.
ServerName | The server from which the database was backed up
Size | Size (in bytes) of this backup
StartDate | The date and time the backup began
Version | This is the current latest version of your serialized data.

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Constructor

[image]

SQL Data Compare API 7.1.0
BackupSet Constructor
BackupSet Class See Also

A parameterless constructor needed for IRedGateSerializable.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupSet()
Visual C++
public:
BackupSet()

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupSet Methods
BackupSet Class See Also

The BackupSet type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the current object with another BackupSet object
Deserialize | This method deserializes the object from the current serialization
Equals | Returns whether this BackupSet is equal to the object specified (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Gets a hash code representing this object (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serialize up you data. (Nb the version number has already been added in)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupSet Class
RedGate.BackupReader Namespace


CompareTo Method

[image]

SQL Data Compare API 7.1.0
BackupSet..::.CompareTo Method
BackupSet Class See Also

Compares the current object with another BackupSet object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    other As BackupSet _
) As Integer
C#
public int CompareTo(
    BackupSet other
)
Visual C++
public:
virtual int CompareTo(
    BackupSet^ other
) sealed

Parameters

other
Type: RedGate.BackupReader..::.BackupSet
A BackupSet to compare with this object.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

BackupSet Class
RedGate.BackupReader Namespace


Deserialize Method

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Deserialize Method
BackupSet Class See Also

This method deserializes the object from the current serialization

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: System..::.Int32
The version of the serialized data
formatter
Type: ISerializeFormatter

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


Equals Method

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Equals Method
BackupSet Class See Also

Returns whether this BackupSet is equal to the object specified

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


GetHashCode Method

[image]

SQL Data Compare API 7.1.0
BackupSet..::.GetHashCode Method
BackupSet Class See Also

Gets a hash code representing this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

See Also

BackupSet Class
RedGate.BackupReader Namespace


Serialize Method

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Serialize Method
BackupSet Class See Also

Serialize up you data. (Nb the version number has already been added in)

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupSet Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupSet Properties
BackupSet Class See Also

The BackupSet type exposes the following properties.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
CheckpointLsn | Log sequence number of most recent checkpoint of this backup
DatabaseName | The original database name
Encrypted | Returns whether the BackupSet is encrypted or not.
EndDate | The date and time the backup completed
FirstLsn | First log sequence number of this backup
FullBackupLsn | Log sequence number of the full backup associated with this backup
LastLsn | Last log sequence number of this backup
Name | The name of the backupset, if one is set.
ServerName | The server from which the database was backed up
Size | Size (in bytes) of this backup
StartDate | The date and time the backup began
Version | This is the current latest version of your serialized data.

See Also

BackupSet Class
RedGate.BackupReader Namespace


BackupType Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.BackupType Property
BackupSet Class See Also

The type of backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupType As BackupType
C#
public BackupType BackupType { get; }
Visual C++
public:
virtual property BackupType BackupType {
    BackupType get () sealed;
}

Implements

IBackupSet..::.BackupType

See Also

BackupSet Class
RedGate.BackupReader Namespace


CanHandle Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.CanHandle Property
BackupSet Class See Also

Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanHandle As Boolean
C#
public bool CanHandle { get; }
Visual C++
public:
virtual property bool CanHandle {
    bool get () sealed;
}

Implements

IBackupSet..::.CanHandle

See Also

BackupSet Class
RedGate.BackupReader Namespace


CheckpointLsn Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.CheckpointLsn Property
BackupSet Class See Also

Log sequence number of most recent checkpoint of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckpointLsn As String
C#
public string CheckpointLsn { get; }
Visual C++
public:
property String^ CheckpointLsn {
    String^ get ();
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.DatabaseName Property
BackupSet Class See Also

The original database name

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
C#
public string DatabaseName { get; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () sealed;
}

Implements

IBackupSet..::.DatabaseName

See Also

BackupSet Class
RedGate.BackupReader Namespace


Encrypted Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Encrypted Property
BackupSet Class See Also

Returns whether the BackupSet is encrypted or not.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IBackupSet..::.Encrypted

See Also

BackupSet Class
RedGate.BackupReader Namespace


EndDate Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.EndDate Property
BackupSet Class See Also

The date and time the backup completed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndDate As DateTime
C#
public DateTime EndDate { get; }
Visual C++
public:
virtual property DateTime EndDate {
    DateTime get () sealed;
}

Implements

IBackupSet..::.EndDate

See Also

BackupSet Class
RedGate.BackupReader Namespace


FirstLsn Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.FirstLsn Property
BackupSet Class See Also

First log sequence number of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FirstLsn As String
C#
public string FirstLsn { get; }
Visual C++
public:
virtual property String^ FirstLsn {
    String^ get () sealed;
}

Implements

IBackupSet..::.FirstLsn

See Also

BackupSet Class
RedGate.BackupReader Namespace


FullBackupLsn Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.FullBackupLsn Property
BackupSet Class See Also

Log sequence number of the full backup associated with this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullBackupLsn As String
C#
public string FullBackupLsn { get; }
Visual C++
public:
property String^ FullBackupLsn {
    String^ get ();
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


LastLsn Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.LastLsn Property
BackupSet Class See Also

Last log sequence number of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastLsn As String
C#
public string LastLsn { get; }
Visual C++
public:
virtual property String^ LastLsn {
    String^ get () sealed;
}

Implements

IBackupSet..::.LastLsn

See Also

BackupSet Class
RedGate.BackupReader Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Name Property
BackupSet Class See Also

The name of the backupset, if one is set.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IBackupSet..::.Name

See Also

BackupSet Class
RedGate.BackupReader Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.ServerName Property
BackupSet Class See Also

The server from which the database was backed up

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerName As String
C#
public string ServerName { get; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () sealed;
}

Implements

IBackupSet..::.ServerName

See Also

BackupSet Class
RedGate.BackupReader Namespace


Size Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Size Property
BackupSet Class See Also

Size (in bytes) of this backup

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As ULong
C#
public ulong Size { get; }
Visual C++
public:
virtual property unsigned long long Size {
    unsigned long long get () sealed;
}

Implements

IBackupSet..::.Size

See Also

BackupSet Class
RedGate.BackupReader Namespace


StartDate Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.StartDate Property
BackupSet Class See Also

The date and time the backup began

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
C#
public DateTime StartDate { get; }
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () sealed;
}

Implements

IBackupSet..::.StartDate

See Also

BackupSet Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
BackupSet..::.Version Property
BackupSet Class See Also

This is the current latest version of your serialized data.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

BackupSet Class
RedGate.BackupReader Namespace


CollationHelper Class

[image]

SQL Data Compare API 7.1.0
CollationHelper Class
Members See Also

A helper class for collation related tasks

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class CollationHelper
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public static class CollationHelper
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class CollationHelper abstract sealed

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.CollationHelper

See Also

CollationHelper Members
RedGate.BackupReader Namespace


CollationHelper Members

[image] [image]

SQL Data Compare API 7.1.0
CollationHelper Members
CollationHelper Class Methods See Also

The CollationHelper type exposes the following members.

Methods

Name | Description
CodePageFromCollationID | Retrieves the codepage associated with a collation ID from the collation's ID.
CollationNameFromId | Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CollationHelper Methods

[image] [image]

SQL Data Compare API 7.1.0
CollationHelper Methods
CollationHelper Class See Also

The CollationHelper type exposes the following methods.

Methods

Name | Description
CodePageFromCollationID | Retrieves the codepage associated with a collation ID from the collation's ID.
CollationNameFromId | Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CodePageFromCollationID Method

[image]

SQL Data Compare API 7.1.0
CollationHelper..::.CodePageFromCollationID Method
CollationHelper Class See Also

Retrieves the codepage associated with a collation ID from the collation's ID.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CodePageFromCollationID ( _
    id As Integer _
) As Integer
C#
public static int CodePageFromCollationID(
    int id
)
Visual C++
public:
static int CodePageFromCollationID(
    int id
)

Parameters

id
Type: System..::.Int32
ID of the collation

Return Value

ID of the codepage

See Also

CollationHelper Class
RedGate.BackupReader Namespace


CollationNameFromId Method

[image]

SQL Data Compare API 7.1.0
CollationHelper..::.CollationNameFromId Method
CollationHelper Class See Also

Retrieves the string collation name (such as SQL_EBCDIC297_CP1_CS_AS) given the SQL Server Collation ID number. Throws an ArgumentException if the collation name cannot be found.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CollationNameFromId ( _
    id As Integer _
) As String
C#
public static string CollationNameFromId(
    int id
)
Visual C++
public:
static String^ CollationNameFromId(
    int id
)

Parameters

id
Type: System..::.Int32
Collation ID

Return Value

Collation name

Exceptions

Exception | Condition
System..::.ArgumentException | if the collation ID isn't known

See Also

CollationHelper Class
RedGate.BackupReader Namespace


LiveCommand Class

[image]

SQL Data Compare API 7.1.0
LiveCommand Class
Members See Also

Represents an SQL statement that is executed while connected to a data source, and is implemented by .NET Framework data providers that access relational databases.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LiveCommand _
    Inherits BackupReaderCommandBase
C#
public sealed class LiveCommand : BackupReaderCommandBase
Visual C++
public ref class LiveCommand sealed : public BackupReaderCommandBase

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.BackupReaderCommandBase
RedGate.BackupReader..::.LiveCommand

See Also

LiveCommand Members
RedGate.BackupReader Namespace


LiveCommand Members

[image] [image]

SQL Data Compare API 7.1.0
LiveCommand Members
LiveCommand Class Methods Properties Explicit Interface Implementations See Also

The LiveCommand type exposes the following members.

Methods

Name | Description
Cancel | Not yet implemented (Inherited from BackupReaderCommandBase.)
CreateParameter | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Dispose | Frees up resources associated with this object (Inherited from BackupReaderCommandBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteNonQuery | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
ExecuteReader | Overloaded.
ExecuteScalar | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Intentional No-op (Inherited from BackupReaderCommandBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommandText | Gets or sets the text command to run against the data source. (Inherited from BackupReaderCommandBase.)
CommandTimeout | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
CommandType | Indicates or specifies how the System.Data.IDbCommand.CommandText property is interpreted. In this implementation, only CommandType.Text is supported. (Inherited from BackupReaderCommandBase.)
Connection | Gets or sets the System.Data.IDbConnection used by this instance of the System.Data.IDbCommand. (Inherited from BackupReaderCommandBase.)
Parameters | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
Transaction | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)
UpdatedRowSource | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

Explicit Interface Implementations

Name | Description
IDbCommand..::.Connection | (Inherited from BackupReaderCommandBase.)
IDbCommand..::.ExecuteReader | (Inherited from BackupReaderCommandBase.)

See Also

LiveCommand Class
RedGate.BackupReader Namespace


LiveConnection Class

[image]

SQL Data Compare API 7.1.0
LiveConnection Class
Members See Also

An implementation of IBackupConnection for treating a live DB as a page reader

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LiveConnection _
    Implements IBackupConnection, IDbConnection, IDisposable, ICancellable
C#
public sealed class LiveConnection : IBackupConnection,
    IDbConnection, IDisposable, ICancellable
Visual C++
public ref class LiveConnection sealed : IBackupConnection,
    IDbConnection, IDisposable, ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.LiveConnection

See Also

LiveConnection Members
RedGate.BackupReader Namespace


LiveConnection Members

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection Members
LiveConnection Class Constructors Methods Properties Explicit Interface Implementations See Also

The LiveConnection type exposes the following members.

Constructors

Name | Description
LiveConnection | Overloaded.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the LiveConnection.
CreateCommand | Creates a command object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Not valid for this object
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Always returns false since the LiveConnection doesn't handle the underlying connection object
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the LiveConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Not valid for this object

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Not implemented
ConnectionString | Gets the string used to open a database.
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Not valid for this object
Database | Not implemented in this implementation
DatabaseGuid | Not implemented
SQLServerInternalVersionNumber | Not valid for this object
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Explicit Interface Implementations

Name | Description
IDbConnection..::.CreateCommand |

See Also

LiveConnection Class
RedGate.BackupReader Namespace


LiveConnection Constructor

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection Constructor
LiveConnection Class See Also

Overload List

Name | Description
LiveConnection(SqlConnection, SQLVersion) | Creates a new LiveConnection object
LiveConnection(SqlConnection, SQLVersion, Boolean) | Creates a new LiveConnection object
LiveConnection(Assembly, SqlConnection, SQLVersion, Boolean) | Creates a new LiveConnection object

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


LiveConnection Constructor (SqlConnection, )

[image]

SQL Data Compare API 7.1.0
LiveConnection Constructor (SqlConnection, )
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    conn As SqlConnection, _
    version As SQLVersion _
)
C#
public LiveConnection(
    SqlConnection conn,
    SQLVersion version
)
Visual C++
public:
LiveConnection(
    SqlConnection^ conn,
    SQLVersion version
)

Parameters

conn
Type: System.Data.SqlClient..::.SqlConnection
version
Type: SQLVersion

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Constructor (SqlConnection, , Boolean)

[image]

SQL Data Compare API 7.1.0
LiveConnection Constructor (SqlConnection, , Boolean)
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    conn As SqlConnection, _
    version As SQLVersion, _
    createNewConnection As Boolean _
)
C#
public LiveConnection(
    SqlConnection conn,
    SQLVersion version,
    bool createNewConnection
)
Visual C++
public:
LiveConnection(
    SqlConnection^ conn,
    SQLVersion version,
    bool createNewConnection
)

Parameters

conn
Type: System.Data.SqlClient..::.SqlConnection
version
Type: SQLVersion
createNewConnection
Type: System..::.Boolean

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Constructor (Assembly, SqlConnection, , Boolean)

[image]

SQL Data Compare API 7.1.0
LiveConnection Constructor (Assembly, SqlConnection, , Boolean)
LiveConnection Class See Also

Creates a new LiveConnection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    asm As Assembly, _
    conn As SqlConnection, _
    version As SQLVersion, _
    createNewConnection As Boolean _
)
C#
public LiveConnection(
    Assembly asm,
    SqlConnection conn,
    SQLVersion version,
    bool createNewConnection
)
Visual C++
public:
LiveConnection(
    Assembly^ asm,
    SqlConnection^ conn,
    SQLVersion version,
    bool createNewConnection
)

Parameters

asm
Type: System.Reflection..::.Assembly
conn
Type: System.Data.SqlClient..::.SqlConnection
version
Type: SQLVersion
createNewConnection
Type: System..::.Boolean

See Also

LiveConnection Class
LiveConnection Overload
RedGate.BackupReader Namespace


LiveConnection Methods

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection Methods
LiveConnection Class See Also

The LiveConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the operation.
ChangeDatabase | Not implemented in this implementation
Close | Closes the LiveConnection.
CreateCommand | Creates a command object for executing against the main data source
CreateSysTableCommand | Creates a command on to the queryable system table store
Dispose | Not implemented yet
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBackupSets | Not valid for this object
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Always returns false since the LiveConnection doesn't handle the underlying connection object
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Opens the LiveConnection to the source specified in the ConnectionString. Expensive.
OpenForMetaInformation | Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.
PopulateAdditionalSystemTables | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseBackupSet | Not valid for this object

Explicit Interface Implementations

Name | Description
IDbConnection..::.CreateCommand |

See Also

LiveConnection Class
RedGate.BackupReader Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection..::.BeginTransaction Method
LiveConnection Class See Also

Overload List

Name | Description
BeginTransaction()()() | Not implemented in this implementation
BeginTransaction(IsolationLevel) | Not implemented in this implementation

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


BeginTransaction Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.BeginTransaction Method
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction As IDbTransaction
C#
public IDbTransaction BeginTransaction()
Visual C++
public:
virtual IDbTransaction^ BeginTransaction() sealed

Return Value

Implements

IDbConnection..::.BeginTransaction()()()

See Also

LiveConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


BeginTransaction Method (IsolationLevel)

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.BeginTransaction Method (IsolationLevel)
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginTransaction ( _
    il As IsolationLevel _
) As IDbTransaction
C#
public IDbTransaction BeginTransaction(
    IsolationLevel il
)
Visual C++
public:
virtual IDbTransaction^ BeginTransaction(
    IsolationLevel il
) sealed

Parameters

il
Type: System.Data..::.IsolationLevel

Return Value

Implements

IDbConnection..::.BeginTransaction(IsolationLevel)

See Also

LiveConnection Class
BeginTransaction Overload
RedGate.BackupReader Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.CancelOperation Method
LiveConnection Class See Also

Cancels the operation.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ChangeDatabase Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.ChangeDatabase Method
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeDatabase ( _
    databaseName As String _
)
C#
public void ChangeDatabase(
    string databaseName
)
Visual C++
public:
virtual void ChangeDatabase(
    String^ databaseName
) sealed

Parameters

databaseName
Type: System..::.String

Return Value

Implements

IDbConnection..::.ChangeDatabase(String)

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Close Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Close Method
LiveConnection Class See Also

Closes the LiveConnection.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
virtual void Close() sealed

Implements

IDbConnection..::.Close()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CreateCommand Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.CreateCommand Method
LiveConnection Class See Also

Creates a command object for executing against the main data source

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateCommand As IDbCommand
C#
public IDbCommand CreateCommand()
Visual C++
public:
IDbCommand^ CreateCommand()

Return Value

See Also

LiveConnection Class
RedGate.BackupReader Namespace


IDbConnection.CreateCommand Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.IDbConnection..::.CreateCommand Method
LiveConnection Class See Also

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Private Function CreateCommand As IDbCommand
    Implements IDbConnection.CreateCommand
C#
IDbCommand IDbConnection.CreateCommand()
Visual C++
private:
virtual IDbCommand^ CreateCommand() sealed = IDbConnection::CreateCommand

Implements

IDbConnection..::.CreateCommand()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.CreateSysTableCommand Method
LiveConnection Class See Also

Creates a command on to the queryable system table store

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSysTableCommand As IDbCommand
C#
public IDbCommand CreateSysTableCommand()
Visual C++
public:
virtual IDbCommand^ CreateSysTableCommand() sealed

Return Value

An instance of IDbCommand connected to the system table store

Implements

IBackupConnection..::.CreateSysTableCommand()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Dispose Method
LiveConnection Class See Also

Not implemented yet

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


GetBackupSets Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.GetBackupSets Method
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets()
Visual C++
public:
virtual IList<IBackupSet^>^ GetBackupSets() sealed

Return Value

Implements

IBackupConnection..::.GetBackupSets()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.IsPasswordRequired Method
LiveConnection Class See Also

Always returns false since the LiveConnection doesn't handle the underlying connection object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Function IsPasswordRequired As Boolean
C#
public bool IsPasswordRequired()
Visual C++
public:
virtual bool IsPasswordRequired() sealed

Return Value

Implements

IBackupConnection..::.IsPasswordRequired()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Open Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Open Method
LiveConnection Class See Also

Opens the LiveConnection to the source specified in the ConnectionString. Expensive.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub Open
C#
public void Open()
Visual C++
public:
virtual void Open() sealed

Implements

IDbConnection..::.Open()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.OpenForMetaInformation Method
LiveConnection Class See Also

Opens the LiveConnection to access database information from the source specified in the ConnectionString. Cheap but not suitable to retrieve actual data / structure from the database - only meta information.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub OpenForMetaInformation
C#
public void OpenForMetaInformation()
Visual C++
public:
virtual void OpenForMetaInformation() sealed

Implements

IBackupConnection..::.OpenForMetaInformation()()()

See Also

LiveConnection Class
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection..::.PopulateAdditionalSystemTables Method
LiveConnection Class See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

See Also

LiveConnection Class
LiveConnection Members
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
LiveConnection Class See Also

Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
public void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
) sealed

Parameters

tables
Type: array<ITableName>[]()[]
The schema-qualified name(s) of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(array<ITableName>[]()[])

Exceptions

Exception | Condition
System..::.ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

LiveConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


PopulateAdditionalSystemTables Method (List())

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.PopulateAdditionalSystemTables Method (List<(Of <(>)>))
LiveConnection Class See Also

Populates one or more system tables in addition to those already populated The LiveConnection must be in the Open state before calling this method. Progress may be given by setting the Status event handler in a similar way to the Open call. Progress will range from 0% to 100% over the course of all the tables to be populated.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
public void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
public:
virtual void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
) sealed

Parameters

tables
Type: System.Collections.Generic..::.List <(Of <(ITableName>)>)
A list of the schema-qualified names of the tables to populate

Implements

IBackupConnection..::.PopulateAdditionalSystemTables(List<(Of <(ITableName>)>))

Exceptions

Exception | Condition
System..::.ArgumentException | Throws ArgumentException if a specified table has already been populated.

See Also

LiveConnection Class
PopulateAdditionalSystemTables Overload
RedGate.BackupReader Namespace


UseBackupSet Method

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.UseBackupSet Method
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub UseBackupSet ( _
    ibackupSet As IBackupSet _
)
C#
public void UseBackupSet(
    IBackupSet ibackupSet
)
Visual C++
public:
virtual void UseBackupSet(
    IBackupSet^ ibackupSet
) sealed

Parameters

ibackupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet

Return Value

Implements

IBackupConnection..::.UseBackupSet(IBackupSet)

See Also

LiveConnection Class
RedGate.BackupReader Namespace


LiveConnection Properties

[image] [image]

SQL Data Compare API 7.1.0
LiveConnection Properties
LiveConnection Class See Also

The LiveConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | Get the temporary backup data store directory or null if it doesn't exist
CompatibilityVersion | Not implemented
ConnectionString | Gets the string used to open a database.
ConnectionTimeout | Not implemented in this implementation
CurrentBackupSet | Not valid for this object
Database | Not implemented in this implementation
DatabaseGuid | Not implemented
SQLServerInternalVersionNumber | Not valid for this object
State | Open or Closed
Status | An event handler for providing progress feedback.
Version | Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

See Also

LiveConnection Class
RedGate.BackupReader Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.BackupTemporaryDirectory Property
LiveConnection Class See Also

Get the temporary backup data store directory or null if it doesn't exist

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupTemporaryDirectory As String
C#
public string BackupTemporaryDirectory { get; }
Visual C++
public:
virtual property String^ BackupTemporaryDirectory {
    String^ get () sealed;
}

Implements

IBackupConnection..::.BackupTemporaryDirectory

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.CompatibilityVersion Property
LiveConnection Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompatibilityVersion As Integer
C#
public int CompatibilityVersion { get; }
Visual C++
public:
virtual property int CompatibilityVersion {
    int get () sealed;
}

Implements

IBackupConnection..::.CompatibilityVersion

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ConnectionString Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.ConnectionString Property
LiveConnection Class See Also

Gets the string used to open a database.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Return Value

A string containing connection settings.

Implements

IDbConnection..::.ConnectionString

See Also

LiveConnection Class
RedGate.BackupReader Namespace


ConnectionTimeout Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.ConnectionTimeout Property
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionTimeout As Integer
C#
public int ConnectionTimeout { get; }
Visual C++
public:
virtual property int ConnectionTimeout {
    int get () sealed;
}

Return Value

Implements

IDbConnection..::.ConnectionTimeout

See Also

LiveConnection Class
RedGate.BackupReader Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.CurrentBackupSet Property
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentBackupSet As IBackupSet
C#
public IBackupSet CurrentBackupSet { get; }
Visual C++
public:
virtual property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get () sealed;
}

Return Value

Implements

IBackupConnection..::.CurrentBackupSet

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Database Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Database Property
LiveConnection Class See Also

Not implemented in this implementation

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As String
C#
public string Database { get; }
Visual C++
public:
virtual property String^ Database {
    String^ get () sealed;
}

Return Value

Implements

IDbConnection..::.Database

See Also

LiveConnection Class
RedGate.BackupReader Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.DatabaseGuid Property
LiveConnection Class See Also

Not implemented

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseGuid As Guid
C#
public Guid DatabaseGuid { get; }
Visual C++
public:
virtual property Guid DatabaseGuid {
    Guid get () sealed;
}

Implements

IBackupConnection..::.DatabaseGuid

See Also

LiveConnection Class
RedGate.BackupReader Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.SQLServerInternalVersionNumber Property
LiveConnection Class See Also

Not valid for this object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
public int SQLServerInternalVersionNumber { get; }
Visual C++
public:
virtual property int SQLServerInternalVersionNumber {
    int get () sealed;
}

Return Value

Implements

IBackupConnection..::.SQLServerInternalVersionNumber

See Also

LiveConnection Class
RedGate.BackupReader Namespace


State Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.State Property
LiveConnection Class See Also

Open or Closed

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
C#
public ConnectionState State { get; }
Visual C++
public:
virtual property ConnectionState State {
    ConnectionState get () sealed;
}

Implements

IDbConnection..::.State

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Status Property
LiveConnection Class See Also

An event handler for providing progress feedback.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

LiveConnection Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
LiveConnection..::.Version Property
LiveConnection Class See Also

Returns 7, 8, 9 - SQL7, SQL2000, SQL2005

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

Implements

IBackupConnection..::.Version

See Also

LiveConnection Class
RedGate.BackupReader Namespace


SqlVariant Class

[image]

SQL Data Compare API 7.1.0
SqlVariant Class
Members See Also

A representation of the SQL_VARIANT data type.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class SqlVariant
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public sealed class SqlVariant
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class SqlVariant sealed

Inheritance Hierarchy

System..::.Object
RedGate.BackupReader..::.SqlVariant

See Also

SqlVariant Members
RedGate.BackupReader Namespace


SqlVariant Members

[image] [image]

SQL Data Compare API 7.1.0
SqlVariant Members
SqlVariant Class Methods Properties See Also

The SqlVariant type exposes the following members.

Methods

Name | Description
Equals | SqlVariant equals The object to compare with (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseType | Gets the SQL base type associated with this instance
BaseTypeName | Gets the SQL name associated with this instance
CollationID | Collation ID for string types
Data | The buffer of actual data
MaxLength | Maximum permissible length for string and binary types
Object | Gets the object contained within this SqlVariant object
Precision | Precision value for numeric / decimal types
Scale | Scale value for numeric / decimal types
Version | Version number - always 1 currently

See Also

SqlVariant Class
RedGate.BackupReader Namespace


SqlVariant Methods

[image] [image]

SQL Data Compare API 7.1.0
SqlVariant Methods
SqlVariant Class See Also

The SqlVariant type exposes the following methods.

Methods

Name | Description
Equals | SqlVariant equals The object to compare with (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Equals Method

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Equals Method
SqlVariant Class See Also

SqlVariant equals The object to compare with

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

SqlVariant Class
RedGate.BackupReader Namespace


SqlVariant Properties

[image] [image]

SQL Data Compare API 7.1.0
SqlVariant Properties
SqlVariant Class See Also

The SqlVariant type exposes the following properties.

Properties

Name | Description
BaseType | Gets the SQL base type associated with this instance
BaseTypeName | Gets the SQL name associated with this instance
CollationID | Collation ID for string types
Data | The buffer of actual data
MaxLength | Maximum permissible length for string and binary types
Object | Gets the object contained within this SqlVariant object
Precision | Precision value for numeric / decimal types
Scale | Scale value for numeric / decimal types
Version | Version number - always 1 currently

See Also

SqlVariant Class
RedGate.BackupReader Namespace


BaseType Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.BaseType Property
SqlVariant Class See Also

Gets the SQL base type associated with this instance

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As BackupSqlType
C#
public BackupSqlType BaseType { get; }
Visual C++
public:
virtual property BackupSqlType BaseType {
    BackupSqlType get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


BaseTypeName Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.BaseTypeName Property
SqlVariant Class See Also

Gets the SQL name associated with this instance

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseTypeName As String
C#
public string BaseTypeName { get; }
Visual C++
public:
virtual property String^ BaseTypeName {
    String^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


CollationID Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.CollationID Property
SqlVariant Class See Also

Collation ID for string types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CollationID As Long
C#
public long CollationID { get; }
Visual C++
public:
virtual property long long CollationID {
    long long get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Data Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Data Property
SqlVariant Class See Also

The buffer of actual data

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
C#
public byte[] Data { get; }
Visual C++
public:
virtual property array<unsigned char>^ Data {
    array<unsigned char>^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


MaxLength Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.MaxLength Property
SqlVariant Class See Also

Maximum permissible length for string and binary types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLength As Integer
C#
public int MaxLength { get; }
Visual C++
public:
virtual property int MaxLength {
    int get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Object Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Object Property
SqlVariant Class See Also

Gets the object contained within this SqlVariant object

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Object As Object
C#
public Object Object { get; }
Visual C++
public:
virtual property Object^ Object {
    Object^ get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Precision Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Precision Property
SqlVariant Class See Also

Precision value for numeric / decimal types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Byte
C#
public byte Precision { get; }
Visual C++
public:
virtual property unsigned char Precision {
    unsigned char get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Scale Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Scale Property
SqlVariant Class See Also

Scale value for numeric / decimal types

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Byte
C#
public byte Scale { get; }
Visual C++
public:
virtual property unsigned char Scale {
    unsigned char get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
SqlVariant..::.Version Property
SqlVariant Class See Also

Version number - always 1 currently

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

SqlVariant Class
RedGate.BackupReader Namespace


TableName Structure

[image]

SQL Data Compare API 7.1.0
TableName Structure
Members See Also

Representation of a schema-qualified table name, used when populating additional system tables.

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Structure TableName
C#
public struct TableName
Visual C++
public value class TableName

See Also

TableName Members
RedGate.BackupReader Namespace


TableName Members

[image] [image]

SQL Data Compare API 7.1.0
TableName Members
TableName Structure Constructors Methods Properties See Also

The TableName type exposes the following members.

Constructors

Name | Description
TableName | Constructs a new TableName structure using the supplied parameters

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Name | Unqualified object name, e.g. sysobjects
Schema | Schema or owner, e.g. dbo

See Also

TableName Structure
RedGate.BackupReader Namespace


TableName Constructor

[image]

SQL Data Compare API 7.1.0
TableName Constructor
TableName Structure See Also

Constructs a new TableName structure using the supplied parameters

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schema As String, _
    name As String _
)
C#
public TableName(
    string schema,
    string name
)
Visual C++
public:
TableName(
    String^ schema,
    String^ name
)

Parameters

schema
Type: System..::.String
Schema or owner
name
Type: System..::.String
Unqualified object name

See Also

TableName Structure
RedGate.BackupReader Namespace


TableName Properties

[image] [image]

SQL Data Compare API 7.1.0
TableName Properties
TableName Structure See Also

The TableName type exposes the following properties.

Properties

Name | Description
Name | Unqualified object name, e.g. sysobjects
Schema | Schema or owner, e.g. dbo

See Also

TableName Structure
RedGate.BackupReader Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
TableName..::.Name Property
TableName Structure See Also

Unqualified object name, e.g. sysobjects

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

See Also

TableName Structure
RedGate.BackupReader Namespace


Schema Property

[image]

SQL Data Compare API 7.1.0
TableName..::.Schema Property
TableName Structure See Also

Schema or owner, e.g. dbo

Namespace: RedGate.BackupReader
Assembly: RedGate.BackupReader (in RedGate.BackupReader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As String
C#
public string Schema { get; }
Visual C++
public:
virtual property String^ Schema {
    String^ get () sealed;
}

See Also

TableName Structure
RedGate.BackupReader Namespace


RedGate.Shared.SQL Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.SQL Namespace

Classes

Class | Description
DataSource | Represents a database data source.
DBConnectionInformation | Contains all the information needed to connect to a SQL Server database.

Interfaces

Interface | Description
IDataSource | Represents a database data source.


DataSource Class

[image]

SQL Data Compare API 7.1.0
DataSource Class
Members See Also

Represents a database data source.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataSource _
    Implements IDataSource
C#
public abstract class DataSource : IDataSource
Visual C++
public ref class DataSource abstract : IDataSource

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.LiveDatabaseSource
RedGate.SQLCompare.Engine..::.SnapshotSource
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupDatabaseSource
RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderDataSource

See Also

DataSource Members
RedGate.Shared.SQL Namespace


DataSource Members

[image] [image]

SQL Data Compare API 7.1.0
DataSource Members
DataSource Class Constructors Methods Properties See Also

The DataSource type exposes the following members.

Constructors

Name | Description
DataSource |

Methods

Name | Description
Clone | Creates a clone of the current DataSource.
Deserialize | This method deserializes the object using the specified ISerializeFormatter.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this object using the specified ISerializeFormatter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | Gets or sets the name of the database.
IsWriteable | Returns true if this DataSource can be written to.
ServerName | Gets or sets the name of the SQL Server.
Version | Gets the accepted object version number for this object.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Constructor

[image]

SQL Data Compare API 7.1.0
DataSource Constructor
DataSource Class See Also

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DataSource()
Visual C++
protected:
DataSource()

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Methods

[image] [image]

SQL Data Compare API 7.1.0
DataSource Methods
DataSource Class See Also

The DataSource type exposes the following methods.

Methods

Name | Description
Clone | Creates a clone of the current DataSource.
Deserialize | This method deserializes the object using the specified ISerializeFormatter.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this object using the specified ISerializeFormatter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
DataSource..::.Clone Method
DataSource Class See Also

Creates a clone of the current DataSource.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone As IDataSource
C#
public abstract IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() abstract

Implements

IDataSource..::.Clone()()()

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Deserialize Method

[image]

SQL Data Compare API 7.1.0
DataSource..::.Deserialize Method
DataSource Class See Also

This method deserializes the object using the specified ISerializeFormatter.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public abstract bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) abstract

Parameters

versionId
Type: System..::.Int32
The version of the serialized data.
formatter
Type: ISerializeFormatter
The serialization formatter to use.

Return Value

True if deserialized successfully, false if deserialization fails or versionId is not recognised.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Serialize Method

[image]

SQL Data Compare API 7.1.0
DataSource..::.Serialize Method
DataSource Class See Also

Serializes this object using the specified ISerializeFormatter.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public abstract void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) abstract

Parameters

formatter
Type: ISerializeFormatter
The serialization formatter to use.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DataSource Properties

[image] [image]

SQL Data Compare API 7.1.0
DataSource Properties
DataSource Class See Also

The DataSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the name of the database.
IsWriteable | Returns true if this DataSource can be written to.
ServerName | Gets or sets the name of the SQL Server.
Version | Gets the accepted object version number for this object.

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
DataSource..::.DatabaseName Property
DataSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property DatabaseName As String
C#
public abstract string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Implements

IDataSource..::.DatabaseName

See Also

DataSource Class
RedGate.Shared.SQL Namespace


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
DataSource..::.IsWriteable Property
DataSource Class See Also

Returns true if this DataSource can be written to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsWriteable As Boolean
C#
public abstract bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () abstract;
}

Implements

IDataSource..::.IsWriteable

See Also

DataSource Class
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
DataSource..::.ServerName Property
DataSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property ServerName As String
C#
public abstract string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () abstract;
    void set (String^ value) abstract;
}

Implements

IDataSource..::.ServerName

See Also

DataSource Class
RedGate.Shared.SQL Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
DataSource..::.Version Property
DataSource Class See Also

Gets the accepted object version number for this object.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Version As Integer
C#
public abstract int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () abstract;
}

See Also

DataSource Class
RedGate.Shared.SQL Namespace


DBConnectionInformation Class

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation Class
Members See Also

Contains all the information needed to connect to a SQL Server database.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DBConnectionInformation
C#
public sealed class DBConnectionInformation
Visual C++
public ref class DBConnectionInformation sealed

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DBConnectionInformation

See Also

DBConnectionInformation Members
RedGate.Shared.SQL Namespace


DBConnectionInformation Members

[image] [image]

SQL Data Compare API 7.1.0
DBConnectionInformation Members
DBConnectionInformation Class Constructors Methods Properties See Also

The DBConnectionInformation type exposes the following members.

Constructors

Name | Description
DBConnectionInformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | The database to connect to.
IntegratedSecurity | If true, integrated authentication will be used. If false, SQL Server authentication will be used.
Password | The password to use if using SQL Server authentication.
ServerName | The server to connect to.
UserName | The user to connect as if using SQL Server authentication.

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor

[image] [image]

SQL Data Compare API 7.1.0
DBConnectionInformation Constructor
DBConnectionInformation Class See Also

Overload List

Name | Description
DBConnectionInformation(String, String) | Constructs a new DBConnectionInformation object using integrated authentication (also known as Windows authentication).
DBConnectionInformation(String, String, String, String) | Constructs a new DBConnectionInformation object using SQL Server authentication.

See Also

DBConnectionInformation Class
DBConnectionInformation Members
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation Constructor (String, String)
DBConnectionInformation Class See Also

Constructs a new DBConnectionInformation object using integrated authentication (also known as Windows authentication).

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String _
)
C#
public DBConnectionInformation(
    string serverName,
    string databaseName
)
Visual C++
public:
DBConnectionInformation(
    String^ serverName,
    String^ databaseName
)

Parameters

serverName
Type: System..::.String
The server to connect to.
databaseName
Type: System..::.String
The database to connect to.

See Also

DBConnectionInformation Class
DBConnectionInformation Overload
RedGate.Shared.SQL Namespace


DBConnectionInformation Constructor (String, String, String, String)

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation Constructor (String, String, String, String)
DBConnectionInformation Class See Also

Constructs a new DBConnectionInformation object using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String, _
    userName As String, _
    password As String _
)
C#
public DBConnectionInformation(
    string serverName,
    string databaseName,
    string userName,
    string password
)
Visual C++
public:
DBConnectionInformation(
    String^ serverName,
    String^ databaseName,
    String^ userName,
    String^ password
)

Parameters

serverName
Type: System..::.String
The server to connect to.
databaseName
Type: System..::.String
The database to connect to.
userName
Type: System..::.String
The user to connect as.
password
Type: System..::.String
The password to use.

See Also

DBConnectionInformation Class
DBConnectionInformation Overload
RedGate.Shared.SQL Namespace


DBConnectionInformation Properties

[image] [image]

SQL Data Compare API 7.1.0
DBConnectionInformation Properties
DBConnectionInformation Class See Also

The DBConnectionInformation type exposes the following properties.

Properties

Name | Description
DatabaseName | The database to connect to.
IntegratedSecurity | If true, integrated authentication will be used. If false, SQL Server authentication will be used.
Password | The password to use if using SQL Server authentication.
ServerName | The server to connect to.
UserName | The user to connect as if using SQL Server authentication.

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation..::.DatabaseName Property
DBConnectionInformation Class See Also

The database to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
C#
public string DatabaseName { get; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


IntegratedSecurity Property

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation..::.IntegratedSecurity Property
DBConnectionInformation Class See Also

If true, integrated authentication will be used. If false, SQL Server authentication will be used.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


Password Property

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation..::.Password Property
DBConnectionInformation Class See Also

The password to use if using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Password As String
C#
public string Password { get; }
Visual C++
public:
property String^ Password {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation..::.ServerName Property
DBConnectionInformation Class See Also

The server to connect to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerName As String
C#
public string ServerName { get; }
Visual C++
public:
property String^ ServerName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


UserName Property

[image]

SQL Data Compare API 7.1.0
DBConnectionInformation..::.UserName Property
DBConnectionInformation Class See Also

The user to connect as if using SQL Server authentication.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserName As String
C#
public string UserName { get; }
Visual C++
public:
property String^ UserName {
    String^ get ();
}

See Also

DBConnectionInformation Class
RedGate.Shared.SQL Namespace


IDataSource Interface

[image]

SQL Data Compare API 7.1.0
IDataSource Interface
Members See Also

Represents a database data source.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataSource
C#
public interface IDataSource
Visual C++
public interface class IDataSource

See Also

IDataSource Members
RedGate.Shared.SQL Namespace


IDataSource Members

[image] [image]

SQL Data Compare API 7.1.0
IDataSource Members
IDataSource Interface Methods Properties See Also

The IDataSource type exposes the following members.

Methods

Name | Description
Clone | Creates a clone of this IDataSource.

Properties

Name | Description
DatabaseName | Gets or sets the data source database name.
IsWriteable | Gets a value indicating if this data source can be written to.
ServerName | Gets or sets the data source server name.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IDataSource Methods

[image] [image]

SQL Data Compare API 7.1.0
IDataSource Methods
IDataSource Interface See Also

The IDataSource type exposes the following methods.

Methods

Name | Description
Clone | Creates a clone of this IDataSource.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
IDataSource..::.Clone Method
IDataSource Interface See Also

Creates a clone of this IDataSource.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function Clone As IDataSource
C#
IDataSource Clone()
Visual C++
IDataSource^ Clone()

Return Value

A clone of this IDataSource.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IDataSource Properties

[image] [image]

SQL Data Compare API 7.1.0
IDataSource Properties
IDataSource Interface See Also

The IDataSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the data source database name.
IsWriteable | Gets a value indicating if this data source can be written to.
ServerName | Gets or sets the data source server name.

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
IDataSource..::.DatabaseName Property
IDataSource Interface See Also

Gets or sets the data source database name.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Property DatabaseName As String
C#
string DatabaseName { get; set; }
Visual C++
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
IDataSource..::.IsWriteable Property
IDataSource Interface See Also

Gets a value indicating if this data source can be written to.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsWriteable As Boolean
C#
bool IsWriteable { get; }
Visual C++
property bool IsWriteable {
    bool get ();
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
IDataSource..::.ServerName Property
IDataSource Interface See Also

Gets or sets the data source server name.

Namespace: RedGate.Shared.SQL
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Property ServerName As String
C#
string ServerName { get; set; }
Visual C++
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

See Also

IDataSource Interface
RedGate.Shared.SQL Namespace


RedGate.Shared.SQL.BackupReaderInterfaces Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.SQL.BackupReaderInterfaces Namespace

Interfaces

Interface | Description
IBackupConnection | A base interface for Backup Connections
IBackupSet | A base interface for a BackupSet

Enumerations

Enumeration | Description
BackupType | The backup type - full, differential etc.


BackupType Enumeration

[image]

SQL Data Compare API 7.1.0
BackupType Enumeration
See Also

The backup type - full, differential etc.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration BackupType
C#
public enum BackupType
Visual C++
public enum class BackupType

Members

Member name | Description
Other | Unknown or other type
Full | Full backup
Differential | Differential backup
Log | Transaction log backup
Partial | Partial backup
FileGroup | File / filegroup backup

See Also

RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Interface

[image]

SQL Data Compare API 7.1.0
IBackupConnection Interface
Members See Also

A base interface for Backup Connections

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBackupConnection _
    Implements IDbConnection, IDisposable, ICancellable
C#
public interface IBackupConnection : IDbConnection,
    IDisposable, ICancellable
Visual C++
public interface class IBackupConnection : IDbConnection,
    IDisposable, ICancellable

See Also

IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Members

[image] [image]

SQL Data Compare API 7.1.0
IBackupConnection Members
IBackupConnection Interface Methods Properties See Also

The IBackupConnection type exposes the following members.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ChangeDatabase | Changes the current database for an open Connection object. (Inherited from IDbConnection.)
Close | Closes the connection to the database. (Inherited from IDbConnection.)
CreateCommand | Creates and returns a Command object associated with the connection. (Inherited from IDbConnection.)
CreateSysTableCommand | Generate a command to run against the Backup Reader's system table store.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetBackupSets | Get the list of BackupSets linked to the connection.
IsPasswordRequired | Whether a password is required
Open | Opens a database connection with the settings specified by the ConnectionString property of the provider-specific Connection object. (Inherited from IDbConnection.)
OpenForMetaInformation | A quick open that just populates the meta information
PopulateAdditionalSystemTables | Overloaded.
UseBackupSet | Select the BackupSet to use in the connection.

Properties

Name | Description
BackupTemporaryDirectory | All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files
CompatibilityVersion | Compatibility version number
ConnectionString | Gets or sets the string used to open a database. (Inherited from IDbConnection.)
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error. (Inherited from IDbConnection.)
CurrentBackupSet | The current backup set being used.
Database | Gets the name of the current database or the database to be used after a connection is opened. (Inherited from IDbConnection.)
DatabaseGuid | Database GUID (syscomments for SS2000 requires this)
SQLServerInternalVersionNumber | SQL Server implementation dependent version number
State | Gets the current state of the connection. (Inherited from IDbConnection.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
Version | The external version number (e.g. 10 for SS2008)

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Methods

[image] [image]

SQL Data Compare API 7.1.0
IBackupConnection Methods
IBackupConnection Interface See Also

The IBackupConnection type exposes the following methods.

Methods

Name | Description
BeginTransaction | Overloaded.
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread (Inherited from ICancellable.)
ChangeDatabase | Changes the current database for an open Connection object. (Inherited from IDbConnection.)
Close | Closes the connection to the database. (Inherited from IDbConnection.)
CreateCommand | Creates and returns a Command object associated with the connection. (Inherited from IDbConnection.)
CreateSysTableCommand | Generate a command to run against the Backup Reader's system table store.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetBackupSets | Get the list of BackupSets linked to the connection.
IsPasswordRequired | Whether a password is required
Open | Opens a database connection with the settings specified by the ConnectionString property of the provider-specific Connection object. (Inherited from IDbConnection.)
OpenForMetaInformation | A quick open that just populates the meta information
PopulateAdditionalSystemTables | Overloaded.
UseBackupSet | Select the BackupSet to use in the connection.

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BeginTransaction Method

[image] [image]

SQL Data Compare API 7.1.0
IBackupConnection..::.BeginTransaction Method
IBackupConnection Interface See Also

Overload List

Name | Description
BeginTransaction()()() | Begins a database transaction. (Inherited from IDbConnection.)
BeginTransaction(IsolationLevel) | Begins a database transaction with the specified IsolationLevel value. (Inherited from IDbConnection.)

See Also

IBackupConnection Interface
IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CreateSysTableCommand Method

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.CreateSysTableCommand Method
IBackupConnection Interface See Also

Generate a command to run against the Backup Reader's system table store.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function CreateSysTableCommand As IDbCommand
C#
IDbCommand CreateSysTableCommand()
Visual C++
IDbCommand^ CreateSysTableCommand()

Return Value

The IDbCommand for execution against the system table store

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


GetBackupSets Method

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.GetBackupSets Method
IBackupConnection Interface See Also

Get the list of BackupSets linked to the connection.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function GetBackupSets As IList(Of IBackupSet)
C#
IList<IBackupSet> GetBackupSets()
Visual C++
IList<IBackupSet^>^ GetBackupSets()

Return Value

List of BackupSets

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.IsPasswordRequired Method
IBackupConnection Interface See Also

Whether a password is required

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Function IsPasswordRequired As Boolean
C#
bool IsPasswordRequired()
Visual C++
bool IsPasswordRequired()

Return Value

True if required, false otherwise

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


OpenForMetaInformation Method

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.OpenForMetaInformation Method
IBackupConnection Interface See Also

A quick open that just populates the meta information

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub OpenForMetaInformation
C#
void OpenForMetaInformation()
Visual C++
void OpenForMetaInformation()

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method

[image] [image]

SQL Data Compare API 7.1.0
IBackupConnection..::.PopulateAdditionalSystemTables Method
IBackupConnection Interface See Also

Overload List

Name | Description
PopulateAdditionalSystemTables(array<ITableName>[]()[]) | Populate System Tables not populated by the BackupConnection by default
PopulateAdditionalSystemTables(List<(Of <(ITableName>)>)) | Populate System Tables not populated by the BackupConnection by default

See Also

IBackupConnection Interface
IBackupConnection Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method ([])

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.PopulateAdditionalSystemTables Method (array<>[]()[])
IBackupConnection Interface See Also

Populate System Tables not populated by the BackupConnection by default

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateAdditionalSystemTables ( _
    ParamArray tables As ITableName() _
)
C#
void PopulateAdditionalSystemTables(
    params ITableName[] tables
)
Visual C++
void PopulateAdditionalSystemTables(
    ... array<ITableName^>^ tables
)

Parameters

tables
Type: array<ITableName>[]()[]
List of extra tables to populate

See Also

IBackupConnection Interface
PopulateAdditionalSystemTables Overload
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


PopulateAdditionalSystemTables Method (List())

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.PopulateAdditionalSystemTables Method (List<(Of <(>)>))
IBackupConnection Interface See Also

Populate System Tables not populated by the BackupConnection by default

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateAdditionalSystemTables ( _
    tables As List(Of ITableName) _
)
C#
void PopulateAdditionalSystemTables(
    List<ITableName> tables
)
Visual C++
void PopulateAdditionalSystemTables(
    List<ITableName^>^ tables
)

Parameters

tables
Type: System.Collections.Generic..::.List <(Of <(ITableName>)>)
List of extra tables to populate

See Also

IBackupConnection Interface
PopulateAdditionalSystemTables Overload
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


UseBackupSet Method

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.UseBackupSet Method
IBackupConnection Interface See Also

Select the BackupSet to use in the connection.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Sub UseBackupSet ( _
    backupSet As IBackupSet _
)
C#
void UseBackupSet(
    IBackupSet backupSet
)
Visual C++
void UseBackupSet(
    IBackupSet^ backupSet
)

Parameters

backupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The BackupSet to use

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupConnection Properties

[image] [image]

SQL Data Compare API 7.1.0
IBackupConnection Properties
IBackupConnection Interface See Also

The IBackupConnection type exposes the following properties.

Properties

Name | Description
BackupTemporaryDirectory | All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files
CompatibilityVersion | Compatibility version number
ConnectionString | Gets or sets the string used to open a database. (Inherited from IDbConnection.)
ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error. (Inherited from IDbConnection.)
CurrentBackupSet | The current backup set being used.
Database | Gets the name of the current database or the database to be used after a connection is opened. (Inherited from IDbConnection.)
DatabaseGuid | Database GUID (syscomments for SS2000 requires this)
SQLServerInternalVersionNumber | SQL Server implementation dependent version number
State | Gets the current state of the connection. (Inherited from IDbConnection.)
Status | Gets and sets a delegate that can be used to notify of message or percentage changes (Inherited from ICancellable.)
Version | The external version number (e.g. 10 for SS2008)

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BackupTemporaryDirectory Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.BackupTemporaryDirectory Property
IBackupConnection Interface See Also

All Backup Temp files will be placed in this directory - due to handle persistance in the UI the UI can delete this directory on shutdown to eliminate all Backup Files

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BackupTemporaryDirectory As String
C#
string BackupTemporaryDirectory { get; }
Visual C++
property String^ BackupTemporaryDirectory {
    String^ get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CompatibilityVersion Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.CompatibilityVersion Property
IBackupConnection Interface See Also

Compatibility version number

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CompatibilityVersion As Integer
C#
int CompatibilityVersion { get; }
Visual C++
property int CompatibilityVersion {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CurrentBackupSet Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.CurrentBackupSet Property
IBackupConnection Interface See Also

The current backup set being used.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentBackupSet As IBackupSet
C#
IBackupSet CurrentBackupSet { get; }
Visual C++
property IBackupSet^ CurrentBackupSet {
    IBackupSet^ get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


DatabaseGuid Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.DatabaseGuid Property
IBackupConnection Interface See Also

Database GUID (syscomments for SS2000 requires this)

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseGuid As Guid
C#
Guid DatabaseGuid { get; }
Visual C++
property Guid DatabaseGuid {
    Guid get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


SQLServerInternalVersionNumber Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.SQLServerInternalVersionNumber Property
IBackupConnection Interface See Also

SQL Server implementation dependent version number

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SQLServerInternalVersionNumber As Integer
C#
int SQLServerInternalVersionNumber { get; }
Visual C++
property int SQLServerInternalVersionNumber {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
IBackupConnection..::.Version Property
IBackupConnection Interface See Also

The external version number (e.g. 10 for SS2008)

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Version As Integer
C#
int Version { get; }
Visual C++
property int Version {
    int get ();
}

See Also

IBackupConnection Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Interface

[image]

SQL Data Compare API 7.1.0
IBackupSet Interface
Members See Also

A base interface for a BackupSet

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBackupSet
C#
public interface IBackupSet
Visual C++
public interface class IBackupSet

See Also

IBackupSet Members
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Members

[image] [image]

SQL Data Compare API 7.1.0
IBackupSet Members
IBackupSet Interface Properties See Also

The IBackupSet type exposes the following members.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
DatabaseName | The Database Name that the backup was made on
Encrypted | Whether the Backup is Encrypted
EndDate | When the backup was finished
FirstLsn | First LogSequenceNumber in the Backup
LastLsn | Last LogSequenceNumber in the Backup
Name | The Name of the BackupSet
ServerName | The Server Name that the backup was made on
Size | Size (in bytes) of this backup
StartDate | When the backup was started

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


IBackupSet Properties

[image] [image]

SQL Data Compare API 7.1.0
IBackupSet Properties
IBackupSet Interface See Also

The IBackupSet type exposes the following properties.

Properties

Name | Description
BackupType | The type of backup
CanHandle | Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.
DatabaseName | The Database Name that the backup was made on
Encrypted | Whether the Backup is Encrypted
EndDate | When the backup was finished
FirstLsn | First LogSequenceNumber in the Backup
LastLsn | Last LogSequenceNumber in the Backup
Name | The Name of the BackupSet
ServerName | The Server Name that the backup was made on
Size | Size (in bytes) of this backup
StartDate | When the backup was started

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


BackupType Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.BackupType Property
IBackupSet Interface See Also

The type of backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BackupType As BackupType
C#
BackupType BackupType { get; }
Visual C++
property BackupType BackupType {
    BackupType get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


CanHandle Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.CanHandle Property
IBackupSet Interface See Also

Gets whether SQL Backup Reader is able to handle this BackupSet. This should be used by the user interface to determine whether the user is allowed to select this backup set.

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanHandle As Boolean
C#
bool CanHandle { get; }
Visual C++
property bool CanHandle {
    bool get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.DatabaseName Property
IBackupSet Interface See Also

The Database Name that the backup was made on

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DatabaseName As String
C#
string DatabaseName { get; }
Visual C++
property String^ DatabaseName {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Encrypted Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.Encrypted Property
IBackupSet Interface See Also

Whether the Backup is Encrypted

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Encrypted As Boolean
C#
bool Encrypted { get; }
Visual C++
property bool Encrypted {
    bool get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


EndDate Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.EndDate Property
IBackupSet Interface See Also

When the backup was finished

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EndDate As DateTime
C#
DateTime EndDate { get; }
Visual C++
property DateTime EndDate {
    DateTime get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


FirstLsn Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.FirstLsn Property
IBackupSet Interface See Also

First LogSequenceNumber in the Backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FirstLsn As String
C#
string FirstLsn { get; }
Visual C++
property String^ FirstLsn {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


LastLsn Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.LastLsn Property
IBackupSet Interface See Also

Last LogSequenceNumber in the Backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastLsn As String
C#
string LastLsn { get; }
Visual C++
property String^ LastLsn {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.Name Property
IBackupSet Interface See Also

The Name of the BackupSet

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.ServerName Property
IBackupSet Interface See Also

The Server Name that the backup was made on

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ServerName As String
C#
string ServerName { get; }
Visual C++
property String^ ServerName {
    String^ get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


Size Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.Size Property
IBackupSet Interface See Also

Size (in bytes) of this backup

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Size As ULong
C#
ulong Size { get; }
Visual C++
property unsigned long long Size {
    unsigned long long get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


StartDate Property

[image]

SQL Data Compare API 7.1.0
IBackupSet..::.StartDate Property
IBackupSet Interface See Also

When the backup was started

Namespace: RedGate.Shared.SQL.BackupReaderInterfaces
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StartDate As DateTime
C#
DateTime StartDate { get; }
Visual C++
property DateTime StartDate {
    DateTime get ();
}

See Also

IBackupSet Interface
RedGate.Shared.SQL.BackupReaderInterfaces Namespace


RedGate.Shared.SQL.ExecutionBlock Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.SQL.ExecutionBlock Namespace

Classes

Class | Description
Batch | A class representing a batch of SQL statements.
BlockExecutor | Runs the SQL code in an ExecutionBlock on the SQL Server. This action can be cancelled.
BlockSaver | Saves BlockExecutors using ICancellable. This class writes the contents of an Execution block to disk. The caller can specify the file name and the type of encoding.
ExecutionBlock | A series of SQL batches to be executed.
ExecutionBlockPrinter | Class that provides a method for printing an ExecutionBlock onto standard output.


Batch Class

[image]

SQL Data Compare API 7.1.0
Batch Class
Members See Also

A class representing a batch of SQL statements.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class Batch
C#
public class Batch
Visual C++
public ref class Batch

Remarks

A batch is a set of SQL statements that can be executed on a SQL Server. The batch can contain more than one SQL statement, but this is not usually the case. A batch can contain more than one line (for example, the SQL to create a stored procedure might contain 100 lines).

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL.ExecutionBlock..::.Batch

See Also

Batch Members
RedGate.Shared.SQL.ExecutionBlock Namespace


Batch Members

[image] [image]

SQL Data Compare API 7.1.0
Batch Members
Batch Class Methods Properties See Also

The Batch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CancelAllRepeating | Removes all currently set Repeating properties if set to true.
Contents | The contents of the batch.
ExtraCRLF | True if an extra CRLF has been appended to the batch.
Marker | True if this batch is a separator (for example, a GO statement).
Repeating | True if the contents of the batch must be executed every time a command is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Batch Properties

[image] [image]

SQL Data Compare API 7.1.0
Batch Properties
Batch Class See Also

The Batch type exposes the following properties.

Properties

Name | Description
CancelAllRepeating | Removes all currently set Repeating properties if set to true.
Contents | The contents of the batch.
ExtraCRLF | True if an extra CRLF has been appended to the batch.
Marker | True if this batch is a separator (for example, a GO statement).
Repeating | True if the contents of the batch must be executed every time a command is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelAllRepeating Property

[image]

SQL Data Compare API 7.1.0
Batch..::.CancelAllRepeating Property
Batch Class See Also

Removes all currently set Repeating properties if set to true.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property CancelAllRepeating As Boolean
C#
public bool CancelAllRepeating { get; internal set; }
Visual C++
public:
property bool CancelAllRepeating {
    bool get ();
    void set (bool value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Contents Property

[image]

SQL Data Compare API 7.1.0
Batch..::.Contents Property
Batch Class See Also

The contents of the batch.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Contents As String
C#
public string Contents { get; internal set; }
Visual C++
public:
property String^ Contents {
    String^ get ();
    void set (String^ value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExtraCRLF Property

[image]

SQL Data Compare API 7.1.0
Batch..::.ExtraCRLF Property
Batch Class See Also

True if an extra CRLF has been appended to the batch.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraCRLF As Boolean
C#
public bool ExtraCRLF { get; }
Visual C++
public:
property bool ExtraCRLF {
    bool get ();
}

Remarks

Sometimes the definitions of stored procedures, views, and so on, do not end in a CRLF. If executed in SQL Query Analyzer, an extra CRLF will be appended. If this flag is set, the extra CRLF will be stripped when the script is run using ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String).

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Marker Property

[image]

SQL Data Compare API 7.1.0
Batch..::.Marker Property
Batch Class See Also

True if this batch is a separator (for example, a GO statement).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Marker As Boolean
C#
public bool Marker { get; internal set; }
Visual C++
public:
property bool Marker {
    bool get ();
    void set (bool value);
}

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Repeating Property

[image]

SQL Data Compare API 7.1.0
Batch..::.Repeating Property
Batch Class See Also

True if the contents of the batch must be executed every time a command is executed.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Repeating As Boolean
C#
public bool Repeating { get; internal set; }
Visual C++
public:
property bool Repeating {
    bool get ();
    void set (bool value);
}

Remarks

This is set to true if a variable declaration is made, because the variable must be declared at the beginning of every statement that is executed.

See Also

Batch Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Class

[image]

SQL Data Compare API 7.1.0
BlockExecutor Class
Members See Also

Runs the SQL code in an ExecutionBlock on the SQL Server. This action can be cancelled.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockExecutor _
    Implements ICancellable
C#
public class BlockExecutor : ICancellable
Visual C++
public ref class BlockExecutor : ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL.ExecutionBlock..::.BlockExecutor

See Also

BlockExecutor Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Members

[image] [image]

SQL Data Compare API 7.1.0
BlockExecutor Members
BlockExecutor Class Constructors Methods Properties See Also

The BlockExecutor type exposes the following members.

Constructors

Name | Description
BlockExecutor |

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteBlock | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLast500Errors | Returns the last 500 errors from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LastCommandText | The last SQL command to be executed from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.
Status | The event handler for status events.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Constructor

[image]

SQL Data Compare API 7.1.0
BlockExecutor Constructor
BlockExecutor Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BlockExecutor()
Visual C++
public:
BlockExecutor()

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Methods

[image] [image]

SQL Data Compare API 7.1.0
BlockExecutor Methods
BlockExecutor Class See Also

The BlockExecutor type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteBlock | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLast500Errors | Returns the last 500 errors from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.CancelOperation Method
BlockExecutor Class See Also

Cancels the current operation.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method

[image] [image]

SQL Data Compare API 7.1.0
BlockExecutor..::.ExecuteBlock Method
BlockExecutor Class See Also

Overload List

Name | Description
ExecuteBlock(ExecutionBlock, DBConnectionInformation) | Runs a block of SQL code contained in an ExecutionBlock.
ExecuteBlock(ExecutionBlock, String, String) | Runs a block of SQL code contained in an ExecutionBlock using integrated security.
ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) | Runs a block of SQL code contained in an ExecutionBlock.

See Also

BlockExecutor Class
BlockExecutor Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (ExecutionBlock, DBConnectionInformation)

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.ExecuteBlock Method (ExecutionBlock, DBConnectionInformation)
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As ExecutionBlock, _
    connection As DBConnectionInformation _
)
C#
public void ExecuteBlock(
    ExecutionBlock block,
    DBConnectionInformation connection
)
Visual C++
public:
void ExecuteBlock(
    ExecutionBlock^ block,
    DBConnectionInformation^ connection
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The block of SQL code to run.
connection
Type: RedGate.Shared.SQL..::.DBConnectionInformation
The connection information to use.

Remarks

Feedback is provided via the Status event handler.

See GetMigrationSQL()()() and BuildFromDifferences()()() for code samples.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (ExecutionBlock, String, String)

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.ExecuteBlock Method (ExecutionBlock, String, String)
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock using integrated security.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As ExecutionBlock, _
    server As String, _
    database As String _
)
C#
public void ExecuteBlock(
    ExecutionBlock block,
    string server,
    string database
)
Visual C++
public:
void ExecuteBlock(
    ExecutionBlock^ block,
    String^ server,
    String^ database
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The block of SQL code to run.
server
Type: System..::.String
The SQL Server on which to run the code.
database
Type: System..::.String
The database on which to run the code.

Remarks

Feedback is provided via the Status event handler. See ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) for more details.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecuteBlock Method (ExecutionBlock, String, String, Boolean, String, String)

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.ExecuteBlock Method (ExecutionBlock, String, String, Boolean, String, String)
BlockExecutor Class See Also

Runs a block of SQL code contained in an ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteBlock ( _
    block As ExecutionBlock, _
    server As String, _
    database As String, _
    integratedSecurity As Boolean, _
    userName As String, _
    password As String _
)
C#
public void ExecuteBlock(
    ExecutionBlock block,
    string server,
    string database,
    bool integratedSecurity,
    string userName,
    string password
)
Visual C++
public:
void ExecuteBlock(
    ExecutionBlock^ block,
    String^ server,
    String^ database,
    bool integratedSecurity,
    String^ userName,
    String^ password
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The block of SQL code to run.
server
Type: System..::.String
The SQL Server on which to run the code.
database
Type: System..::.String
The database on which to run the code.
integratedSecurity
Type: System..::.Boolean
True to use integrated security.
userName
Type: System..::.String
The user name to use to connect to the SQL Server.
password
Type: System..::.String
The password to use to connect to the SQL Server.

Remarks

Feedback is provided via the Status event handler.

See GetMigrationSQL()()() and BuildFromDifferences()()() for code samples.

See Also

BlockExecutor Class
ExecuteBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


GetLast500Errors Method

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.GetLast500Errors Method
BlockExecutor Class See Also

Returns the last 500 errors from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLast500Errors As SqlError()
C#
public SqlError[] GetLast500Errors()
Visual C++
public:
array<SqlError^>^ GetLast500Errors()

Return Value

An array containing the last 500 errors.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockExecutor Properties

[image] [image]

SQL Data Compare API 7.1.0
BlockExecutor Properties
BlockExecutor Class See Also

The BlockExecutor type exposes the following properties.

Properties

Name | Description
LastCommandText | The last SQL command to be executed from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.
Status | The event handler for status events.

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LastCommandText Property

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.LastCommandText Property
BlockExecutor Class See Also

The last SQL command to be executed from the ExecuteBlock(ExecutionBlock, String, String, Boolean, String, String) method.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastCommandText As String
C#
public string LastCommandText { get; }
Visual C++
public:
property String^ LastCommandText {
    String^ get ();
}

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
BlockExecutor..::.Status Property
BlockExecutor Class See Also

The event handler for status events.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BlockExecutor Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Class

[image]

SQL Data Compare API 7.1.0
BlockSaver Class
Members See Also

Saves BlockExecutors using ICancellable. This class writes the contents of an Execution block to disk. The caller can specify the file name and the type of encoding.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockSaver _
    Implements ICancellable
C#
public class BlockSaver : ICancellable
Visual C++
public ref class BlockSaver : ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL.ExecutionBlock..::.BlockSaver

See Also

BlockSaver Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Members

[image] [image]

SQL Data Compare API 7.1.0
BlockSaver Members
BlockSaver Class Constructors Methods Properties See Also

The BlockSaver type exposes the following members.

Constructors

Name | Description
BlockSaver | Overloaded.

Methods

Name | Description
CancelOperation | Cancels the operation (used by ICancellable).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AppendToFile | Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.
EncodingType | Sets the EncodingType. You should call this only once.
ExecutionBlock | Sets the ExecutionBlock. You should call this only once.
FileName | Sets the FileName. You should call this only once.
Status | Cancellable Status Handler (used by ICancellable).

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor

[image] [image]

SQL Data Compare API 7.1.0
BlockSaver Constructor
BlockSaver Class See Also

Overload List

Name | Description
BlockSaver()()() | Default constructor. You must set the FileName, EncodingType, and ExecutionBlock before the BlockSaver can be run.
BlockSaver(String, EncodingType, ExecutionBlock) | Constructs a BlockSaver with all the parameters specified.
BlockSaver(String, EncodingType, ExecutionBlock, Boolean) | Constructs a BlockSaver with all the parameters specified.

See Also

BlockSaver Class
BlockSaver Members
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor

[image]

SQL Data Compare API 7.1.0
BlockSaver Constructor
BlockSaver Class See Also

Default constructor. You must set the FileName, EncodingType, and ExecutionBlock before the BlockSaver can be run.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BlockSaver()
Visual C++
public:
BlockSaver()

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor (String, , ExecutionBlock)

[image]

SQL Data Compare API 7.1.0
BlockSaver Constructor (String, , ExecutionBlock)
BlockSaver Class See Also

Constructs a BlockSaver with all the parameters specified.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As EncodingType, _
    block As ExecutionBlock _
)
C#
public BlockSaver(
    string fileName,
    EncodingType encoding,
    ExecutionBlock block
)
Visual C++
public:
BlockSaver(
    String^ fileName,
    EncodingType encoding,
    ExecutionBlock^ block
)

Parameters

fileName
Type: System..::.String
The file name to use.
encoding
Type: EncodingType
The type of encoding to use.
block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The block of SQL code to use.

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Constructor (String, , ExecutionBlock, Boolean)

[image]

SQL Data Compare API 7.1.0
BlockSaver Constructor (String, , ExecutionBlock, Boolean)
BlockSaver Class See Also

Constructs a BlockSaver with all the parameters specified.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    encoding As EncodingType, _
    block As ExecutionBlock, _
    appendToFile As Boolean _
)
C#
public BlockSaver(
    string fileName,
    EncodingType encoding,
    ExecutionBlock block,
    bool appendToFile
)
Visual C++
public:
BlockSaver(
    String^ fileName,
    EncodingType encoding,
    ExecutionBlock^ block,
    bool appendToFile
)

Parameters

fileName
Type: System..::.String
The file name to use.
encoding
Type: EncodingType
The type of encoding to use.
block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The block of SQL code to use.
appendToFile
Type: System..::.Boolean
Whether the append the block to the file (if it exists) or whether to create a new file (and overwrite existing file)

See Also

BlockSaver Class
BlockSaver Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Methods

[image] [image]

SQL Data Compare API 7.1.0
BlockSaver Methods
BlockSaver Class See Also

The BlockSaver type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the operation (used by ICancellable).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.CancelOperation Method
BlockSaver Class See Also

Cancels the operation (used by ICancellable).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SaveToFile Method

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.SaveToFile Method
BlockSaver Class See Also

Saves a copy of the ExecutionBlock to a text file with the given encoding. If the file exists, it will be overwritten. This function is not thread safe.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToFile
C#
public void SaveToFile()
Visual C++
public:
void SaveToFile()

Exceptions

Exception | Condition
RedGate.Shared.Utils..::.OperationCancelledException | The operation was cancelled.
System..::.ArgumentException | FileName has not been set.
System.IO..::.IOException | An I/O error occured.
System.IO..::.DirectoryNotFoundException | The directory location specified by FileName is invalid.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BlockSaver Properties

[image] [image]

SQL Data Compare API 7.1.0
BlockSaver Properties
BlockSaver Class See Also

The BlockSaver type exposes the following properties.

Properties

Name | Description
AppendToFile | Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.
EncodingType | Sets the EncodingType. You should call this only once.
ExecutionBlock | Sets the ExecutionBlock. You should call this only once.
FileName | Sets the FileName. You should call this only once.
Status | Cancellable Status Handler (used by ICancellable).

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


AppendToFile Property

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.AppendToFile Property
BlockSaver Class See Also

Whether the block is appended to the exisitng file (if it exists) or whether a new file is always written.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property AppendToFile As Boolean
C#
public bool AppendToFile { get; set; }
Visual C++
public:
property bool AppendToFile {
    bool get ();
    void set (bool value);
}

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


EncodingType Property

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.EncodingType Property
BlockSaver Class See Also

Sets the EncodingType. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property EncodingType As EncodingType
C#
public EncodingType EncodingType { get; set; }
Visual C++
public:
property EncodingType EncodingType {
    EncodingType get ();
    void set (EncodingType value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | If set, and EncodingType has already been set, or get, and EncodingType has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Property

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.ExecutionBlock Property
BlockSaver Class See Also

Sets the ExecutionBlock. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecutionBlock As ExecutionBlock
C#
public ExecutionBlock ExecutionBlock { get; set; }
Visual C++
public:
property ExecutionBlock^ ExecutionBlock {
    ExecutionBlock^ get ();
    void set (ExecutionBlock^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | If set, and ExecutionBlock has already been set, or get, and ExecutionBlock has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.FileName Property
BlockSaver Class See Also

Sets the FileName. You should call this only once.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | If set, and FileName has already been set, or get, and FileName has not been set.

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
BlockSaver..::.Status Property
BlockSaver Class See Also

Cancellable Status Handler (used by ICancellable).

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

BlockSaver Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Class

[image]

SQL Data Compare API 7.1.0
ExecutionBlock Class
Members See Also

A series of SQL batches to be executed.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Class ExecutionBlock _
    Inherits DisposableBase
C#
public class ExecutionBlock : DisposableBase
Visual C++
public ref class ExecutionBlock : public DisposableBase

Remarks

An ExecutionBlock contains a series of SQL batches that can be executed against a SQL database. It is essentially a wrapper over a text file with extra information about batch markers (GO statements) and statements that need to be repeated before a batch is run (such as variable declarations).

An ExecutionBlock contains Line objects which in turn contain GetFileStream()()() objects.

The underlying stream can be accessed from M

ExecutionBlock objects are created by [!:RedGate.SQLDataCompare.Engine.SqlProvider.GetMigrationSQL]. There should be no need to create an ExecutionBlock manually.

It is essential to call the Dispose(Boolean) method of ExecutionBlock objects to ensure temporary files are deleted.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock

See Also

ExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Members

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlock Members
ExecutionBlock Class Methods Properties See Also

The ExecutionBlock type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBatch | Gets a batch of SQL.
GetFileStream | Returns a stream to the underlying SQL text file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLine | Gets a line of SQL.
GetString | Returns the contents of the ExecutionBlock.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Obsolete. Saves a copy of the ExecutionBlock to a text file with the given encoding.
StopWriting | Indicates that writing has finished.
ToString | Obsolete. Returns the contents of the ExecutionBlock. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
BatchCount | The number of batches.
CharCount | The number of characters in the ExecutionBlock
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
LineCount | The number of lines.
MaxLineLength | The maximum length of a line.
Name | Gets or sets the name of the block

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Methods

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlock Methods
ExecutionBlock Class See Also

The ExecutionBlock type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBatch | Gets a batch of SQL.
GetFileStream | Returns a stream to the underlying SQL text file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLine | Gets a line of SQL.
GetString | Returns the contents of the ExecutionBlock.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToFile | Obsolete. Saves a copy of the ExecutionBlock to a text file with the given encoding.
StopWriting | Indicates that writing has finished.
ToString | Obsolete. Returns the contents of the ExecutionBlock. (Overrides Object ..::. ToString()()().)

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.Dispose Method
ExecutionBlock Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

ExecutionBlock Class
ExecutionBlock Members
RedGate.Shared.SQL.ExecutionBlock Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.Dispose Method (Boolean)
ExecutionBlock Class See Also

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ExecutionBlock Class
Dispose Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


GetBatch Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.GetBatch Method
ExecutionBlock Class See Also

Gets a batch of SQL.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBatch ( _
    index As Long _
) As Batch
C#
public Batch GetBatch(
    long index
)
Visual C++
public:
Batch^ GetBatch(
    long long index
)

Parameters

index
Type: System..::.Int64
The index of the batch to get.

Return Value

A batch of SQL.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The index is not valid

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetFileStream Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.GetFileStream Method
ExecutionBlock Class See Also

Returns a stream to the underlying SQL text file.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFileStream As Stream
C#
public Stream GetFileStream()
Visual C++
public:
Stream^ GetFileStream()

Return Value

A stream.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetLine Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.GetLine Method
ExecutionBlock Class See Also

Gets a line of SQL.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLine ( _
    index As Long _
) As Line
C#
public Line GetLine(
    long index
)
Visual C++
public:
Line^ GetLine(
    long long index
)

Parameters

index
Type: System..::.Int64
The index of the line to get.

Return Value

A line of SQL.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


GetString Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.GetString Method
ExecutionBlock Class See Also

Returns the contents of the ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Function GetString As String
C#
public string GetString()
Visual C++
public:
String^ GetString()

Return Value

A large SQL statement.

Remarks

If the ExecutionBlock contains a lot of SQL code, this method can cause virtual memory problems; you are recommended to use GetFileStream instead.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


SaveToFile Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.SaveToFile Method
ExecutionBlock Class See Also

Saves a copy of the ExecutionBlock to a text file with the given encoding.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use BlockSaver instead", False)> _
Public Sub SaveToFile ( _
    fileName As String, _
    encoding As EncodingType _
)
C#
[ObsoleteAttribute("Please use BlockSaver instead", false)]
public void SaveToFile(
    string fileName,
    EncodingType encoding
)
Visual C++
[ObsoleteAttribute(L"Please use BlockSaver instead", false)]
public:
void SaveToFile(
    String^ fileName,
    EncodingType encoding
)

Parameters

fileName
Type: System..::.String
The name of the file.
encoding
Type: EncodingType
The encoding to use.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


StopWriting Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.StopWriting Method
ExecutionBlock Class See Also

Indicates that writing has finished.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Sub StopWriting
C#
public void StopWriting()
Visual C++
public:
void StopWriting()

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.ToString Method
ExecutionBlock Class See Also

Returns the contents of the ExecutionBlock.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This is obsolete! Please rewrite your code to use GetString().",  _
    True)> _
Public Overrides Function ToString As String
C#
[ObsoleteAttribute("This is obsolete! Please rewrite your code to use GetString().",
    true)]
public override string ToString()
Visual C++
[ObsoleteAttribute(L"This is obsolete! Please rewrite your code to use GetString().",
    true)]
public:
virtual String^ ToString() override

Return Value

A large SQL statement.

Remarks

If the ExecutionBlock contains a lot of SQL code, this method can cause virtual memory problems; you are recommended to use GetFileStream instead.

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlock Properties

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlock Properties
ExecutionBlock Class See Also

The ExecutionBlock type exposes the following properties.

Properties

Name | Description
BatchCount | The number of batches.
CharCount | The number of characters in the ExecutionBlock
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
LineCount | The number of lines.
MaxLineLength | The maximum length of a line.
Name | Gets or sets the name of the block

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


BatchCount Property

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.BatchCount Property
ExecutionBlock Class See Also

The number of batches.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BatchCount As Long
C#
public long BatchCount { get; }
Visual C++
public:
property long long BatchCount {
    long long get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


CharCount Property

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.CharCount Property
ExecutionBlock Class See Also

The number of characters in the ExecutionBlock

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CharCount As Long
C#
public long CharCount { get; }
Visual C++
public:
property long long CharCount {
    long long get ();
}

Remarks

Note that this is not always the same as the number of bytes because of Unicode issues

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


LineCount Property

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.LineCount Property
ExecutionBlock Class See Also

The number of lines.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineCount As Long
C#
public long LineCount { get; }
Visual C++
public:
property long long LineCount {
    long long get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


MaxLineLength Property

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.MaxLineLength Property
ExecutionBlock Class See Also

The maximum length of a line.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLineLength As Integer
C#
public int MaxLineLength { get; }
Visual C++
public:
property int MaxLineLength {
    int get ();
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
ExecutionBlock..::.Name Property
ExecutionBlock Class See Also

Gets or sets the name of the block

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ExecutionBlock Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Class

[image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter Class
Members See Also

Class that provides a method for printing an ExecutionBlock onto standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey := "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")> _
Public NotInheritable Class ExecutionBlockPrinter
C#
[StrongNameIdentityPermissionAttribute(SecurityAction.LinkDemand, PublicKey = "0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public static class ExecutionBlockPrinter
Visual C++
[StrongNameIdentityPermissionAttribute(SecurityAction::LinkDemand, PublicKey = L"0x00240000048000009400000006020000002400005253413100040000010001008FC10F454406BF85568F958675567383EB344EF516BEC3937AAD9239B15EDF1EB663E2501CE211AB47FB6C26554697B487E8CDA6B2D662B42146417D62AA9C74C4719BC5910DB2659584ADC4F07F0687744B038085B76CC6336A7108738CCFD0AABE44760EC94C8DFD29009FC2DEF78455CE1920A2A5696D108734386CE04AD9")]
public ref class ExecutionBlockPrinter abstract sealed

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlockPrinter

See Also

ExecutionBlockPrinter Members
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Members

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter Members
ExecutionBlockPrinter Class Methods See Also

Methods

Name | Description
PrintExecutionBlock | Overloaded.

See Also

ExecutionBlockPrinter Class
RedGate.Shared.SQL.ExecutionBlock Namespace


ExecutionBlockPrinter Methods

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter Methods
ExecutionBlockPrinter Class See Also

Methods

Name | Description
PrintExecutionBlock | Overloaded.

See Also

ExecutionBlockPrinter Class
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method

[image] [image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter..::.PrintExecutionBlock Method
ExecutionBlockPrinter Class See Also

Overload List

Name | Description
PrintExecutionBlock(ExecutionBlock) | Prints the SQL script wrapped by the supplied ExecutionBlock to standard output.
PrintExecutionBlock(ExecutionBlock, String, Boolean) | Obsolete. Prints the SQL script wrapped by the supplied execution block to the specified file. If the supplied filename is null the method returns without taking any action. If the value of filename is set to 'stdout' the script will be written to standard output.

See Also

ExecutionBlockPrinter Class
ExecutionBlockPrinter Members
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method (ExecutionBlock)

[image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter..::.PrintExecutionBlock Method (ExecutionBlock)
ExecutionBlockPrinter Class See Also

Prints the SQL script wrapped by the supplied ExecutionBlock to standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PrintExecutionBlock ( _
    block As ExecutionBlock _
)
C#
public static void PrintExecutionBlock(
    ExecutionBlock block
)
Visual C++
public:
static void PrintExecutionBlock(
    ExecutionBlock^ block
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
The ExecutionBlock to write onto standard output.

See Also

ExecutionBlockPrinter Class
PrintExecutionBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


PrintExecutionBlock Method (ExecutionBlock, String, Boolean)

[image]

SQL Data Compare API 7.1.0
ExecutionBlockPrinter..::.PrintExecutionBlock Method (ExecutionBlock, String, Boolean)
ExecutionBlockPrinter Class See Also

Prints the SQL script wrapped by the supplied execution block to the specified file. If the supplied filename is null the method returns without taking any action. If the value of filename is set to 'stdout' the script will be written to standard output.

Namespace: RedGate.Shared.SQL.ExecutionBlock
Assembly: RedGate.Shared.SQL (in RedGate.Shared.SQL.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")> _
Public Shared Sub PrintExecutionBlock ( _
    block As ExecutionBlock, _
    filename As String, _
    force As Boolean _
)
C#
[ObsoleteAttribute("Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")]
public static void PrintExecutionBlock(
    ExecutionBlock block,
    string filename,
    bool force
)
Visual C++
[ObsoleteAttribute(L"Please use BlockSaver if writing to a file, or PrintExecutionBlock(ExecutionBlock) if writing to stdout")]
public:
static void PrintExecutionBlock(
    ExecutionBlock^ block,
    String^ filename,
    bool force
)

Parameters

block
Type: RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
execution block.
filename
Type: System..::.String
filename to which SQL script should be written.
force
Type: System..::.Boolean
true to force writing of script even if specified file exists, if set to false an IOException will be thrown if the specified output file already exists.

Exceptions

Exception | Condition
System.IO..::.IOException | if an error occurs writing to the file.

See Also

ExecutionBlockPrinter Class
PrintExecutionBlock Overload
RedGate.Shared.SQL.ExecutionBlock Namespace


RedGate.Shared.Utils Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.Utils Namespace

Classes

Class | Description
DisposableBase | Helper class that implements the recommended IDisposable design pattern.
OperationCancelledException | This exception is thrown when the operation is cancelled by the CancelOperation()()() method.
StatusEventArgs | Represents arguments to the StatusEventHandler event.

Interfaces

Interface | Description
ICancellable | An interface for objects with operations that can be cancelled.

Delegates

Delegate | Description
StatusEventHandler | Represents a method that can receive status events.


DisposableBase Class

[image]

SQL Data Compare API 7.1.0
DisposableBase Class
Members See Also

Helper class that implements the recommended IDisposable design pattern.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DisposableBase _
    Implements IDisposable
C#
public abstract class DisposableBase : IDisposable
Visual C++
public ref class DisposableBase abstract : IDisposable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.Shared.SQL.ExecutionBlock..::.ExecutionBlock
RedGate.SQLCompare.Engine..::.Database
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.ComparisonSession
RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader
RedGate.SQLDataCompare.Engine.ResultsStore..::.Store

See Also

DisposableBase Members
RedGate.Shared.Utils Namespace


DisposableBase Members

[image] [image]

SQL Data Compare API 7.1.0
DisposableBase Members
DisposableBase Class Methods Properties See Also

The DisposableBase type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object ..::. Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed or not.

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


DisposableBase Methods

[image] [image]

SQL Data Compare API 7.1.0
DisposableBase Methods
DisposableBase Class See Also

The DisposableBase type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object ..::. Finalize()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
DisposableBase..::.Dispose Method
DisposableBase Class See Also

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) | Method called when disposing or finalizing.

See Also

DisposableBase Class
DisposableBase Members
RedGate.Shared.Utils Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
DisposableBase..::.Dispose Method
DisposableBase Class See Also

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DisposableBase Class
Dispose Overload
RedGate.Shared.Utils Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
DisposableBase..::.Dispose Method (Boolean)
DisposableBase Class See Also

Method called when disposing or finalizing.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
If true, this was called by the Dispose()()() method, and so managed and unmanaged resources should be cleaned up. If false, this was called by the finalizer, so only unmanaged resources should be cleaned up.

Remarks

As a guide, all methods of a class inheriting IDisposable should check if it is disposed when every non-private method is called using the provided method CheckDisposed()()().

See Also

DisposableBase Class
Dispose Overload
RedGate.Shared.Utils Namespace


Finalize Method

[image]

SQL Data Compare API 7.1.0
DisposableBase..::.Finalize Method
DisposableBase Class See Also

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


DisposableBase Properties

[image] [image]

SQL Data Compare API 7.1.0
DisposableBase Properties
DisposableBase Class See Also

The DisposableBase type exposes the following properties.

Properties

Name | Description
IsDisposed | Returns a value indicating if this instance has been disposed or not.

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


IsDisposed Property

[image]

SQL Data Compare API 7.1.0
DisposableBase..::.IsDisposed Property
DisposableBase Class See Also

Returns a value indicating if this instance has been disposed or not.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDisposed As Boolean
C#
public bool IsDisposed { get; }
Visual C++
public:
property bool IsDisposed {
    bool get ();
}

See Also

DisposableBase Class
RedGate.Shared.Utils Namespace


ICancellable Interface

[image]

SQL Data Compare API 7.1.0
ICancellable Interface
Members See Also

An interface for objects with operations that can be cancelled.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICancellable
C#
public interface ICancellable
Visual C++
public interface class ICancellable

Remarks

SQL Compare and SQL Data Compare have operations which can take a long time and may need to be cancelled. Examples include executing SQL scripts, registering databases in SQL Compare and generating SQL Data Compare scripts.

If a long-running operation is cancelled then an OperationCancelledException is thrown

See RedGate.SQLDataCompare.Engine.ComparisonSession for a code sample.

See Also

ICancellable Members
RedGate.Shared.Utils Namespace


ICancellable Members

[image] [image]

SQL Data Compare API 7.1.0
ICancellable Members
ICancellable Interface Methods Properties See Also

The ICancellable type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


ICancellable Methods

[image] [image]

SQL Data Compare API 7.1.0
ICancellable Methods
ICancellable Interface See Also

The ICancellable type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
ICancellable..::.CancelOperation Method
ICancellable Interface See Also

Cancels the current running operation. This will throw an instance of OperationCancelledException at the currently executing location on the executing thread

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Sub CancelOperation
C#
void CancelOperation()
Visual C++
void CancelOperation()

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


ICancellable Properties

[image] [image]

SQL Data Compare API 7.1.0
ICancellable Properties
ICancellable Interface See Also

The ICancellable type exposes the following properties.

Properties

Name | Description
Status | Gets and sets a delegate that can be used to notify of message or percentage changes

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
ICancellable..::.Status Property
ICancellable Interface See Also

Gets and sets a delegate that can be used to notify of message or percentage changes

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Property Status As StatusEventHandler
C#
StatusEventHandler Status { get; set; }
Visual C++
property StatusEventHandler^ Status {
    StatusEventHandler^ get ();
    void set (StatusEventHandler^ value);
}

See Also

ICancellable Interface
RedGate.Shared.Utils Namespace


OperationCancelledException Class

[image]

SQL Data Compare API 7.1.0
OperationCancelledException Class
Members See Also

This exception is thrown when the operation is cancelled by the CancelOperation()()() method.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OperationCancelledException _
    Inherits Exception
C#
[SerializableAttribute]
public class OperationCancelledException : Exception
Visual C++
[SerializableAttribute]
public ref class OperationCancelledException : public Exception

Remarks

Note that there is also an OperationCanceledException in the class libraries - you need to be catching this one and not OperationCanceledException.

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils..::.OperationCancelledException

See Also

OperationCancelledException Members
RedGate.Shared.Utils Namespace


OperationCancelledException Members

[image] [image]

SQL Data Compare API 7.1.0
OperationCancelledException Members
OperationCancelledException Class Constructors Methods Properties See Also

The OperationCancelledException type exposes the following members.

Constructors

Name | Description
OperationCancelledException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCancelledException Class
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor

[image] [image]

SQL Data Compare API 7.1.0
OperationCancelledException Constructor
OperationCancelledException Class See Also

Overload List

Name | Description
OperationCancelledException()()() | Initializes a new instance of the OperationCancelledException class.
OperationCancelledException(String) | Initializes a new instance of the OperationCancelledException class with a specified error message.
OperationCancelledException(SerializationInfo, StreamingContext) | Initializes a new instance of the OperationCancelledException class with serialized data.
OperationCancelledException(String, Exception) | Initializes a new instance of the OperationCancelledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

OperationCancelledException Class
OperationCancelledException Members
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor

[image]

SQL Data Compare API 7.1.0
OperationCancelledException Constructor
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OperationCancelledException()
Visual C++
public:
OperationCancelledException()

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor (String)

[image]

SQL Data Compare API 7.1.0
OperationCancelledException Constructor (String)
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with a specified error message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public OperationCancelledException(
    string message
)
Visual C++
public:
OperationCancelledException(
    String^ message
)

Parameters

message
Type: System..::.String
A message that describes the error.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
OperationCancelledException Constructor (SerializationInfo, StreamingContext)
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with serialized data.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected OperationCancelledException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
OperationCancelledException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


OperationCancelledException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
OperationCancelledException Constructor (String, Exception)
OperationCancelledException Class See Also

Initializes a new instance of the OperationCancelledException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public OperationCancelledException(
    string message,
    Exception innerException
)
Visual C++
public:
OperationCancelledException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception.

See Also

OperationCancelledException Class
OperationCancelledException Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Class

[image]

SQL Data Compare API 7.1.0
StatusEventArgs Class
Members See Also

Represents arguments to the StatusEventHandler event.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class StatusEventArgs _
    Inherits EventArgs
C#
public class StatusEventArgs : EventArgs
Visual C++
public ref class StatusEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
RedGate.Shared.Utils..::.StatusEventArgs

See Also

StatusEventArgs Members
RedGate.Shared.Utils Namespace


StatusEventArgs Members

[image] [image]

SQL Data Compare API 7.1.0
StatusEventArgs Members
StatusEventArgs Class Constructors Methods Properties See Also

The StatusEventArgs type exposes the following members.

Constructors

Name | Description
StatusEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | The status message.
Percentage | The percentage complete.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor

[image] [image]

SQL Data Compare API 7.1.0
StatusEventArgs Constructor
StatusEventArgs Class See Also

Overload List

Name | Description
StatusEventArgs(Int32) | Initializes a new instance of the StatusEventArgs class with the specified completion percentage.
StatusEventArgs(String) | Initializes a new instance of the StatusEventArgs class with the specified message.
StatusEventArgs(String, Int32) | Initializes a new instance of the StatusEventArgs class with the specified message and completion percentage.

See Also

StatusEventArgs Class
StatusEventArgs Members
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor (Int32)

[image]

SQL Data Compare API 7.1.0
StatusEventArgs Constructor (Int32)
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified completion percentage.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    percentage As Integer _
)
C#
public StatusEventArgs(
    int percentage
)
Visual C++
public:
StatusEventArgs(
    int percentage
)

Parameters

percentage
Type: System..::.Int32
The percentage complete of the currently executing operation.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor (String)

[image]

SQL Data Compare API 7.1.0
StatusEventArgs Constructor (String)
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public StatusEventArgs(
    string message
)
Visual C++
public:
StatusEventArgs(
    String^ message
)

Parameters

message
Type: System..::.String
The status message.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Constructor (String, Int32)

[image]

SQL Data Compare API 7.1.0
StatusEventArgs Constructor (String, Int32)
StatusEventArgs Class See Also

Initializes a new instance of the StatusEventArgs class with the specified message and completion percentage.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    percentage As Integer _
)
C#
public StatusEventArgs(
    string message,
    int percentage
)
Visual C++
public:
StatusEventArgs(
    String^ message,
    int percentage
)

Parameters

message
Type: System..::.String
The status message.
percentage
Type: System..::.Int32
The percentage complete of the currently executing operation.

See Also

StatusEventArgs Class
StatusEventArgs Overload
RedGate.Shared.Utils Namespace


StatusEventArgs Properties

[image] [image]

SQL Data Compare API 7.1.0
StatusEventArgs Properties
StatusEventArgs Class See Also

The StatusEventArgs type exposes the following properties.

Properties

Name | Description
Message | The status message.
Percentage | The percentage complete.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


Message Property

[image]

SQL Data Compare API 7.1.0
StatusEventArgs..::.Message Property
StatusEventArgs Class See Also

The status message.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}

Remarks

This can be null.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


Percentage Property

[image]

SQL Data Compare API 7.1.0
StatusEventArgs..::.Percentage Property
StatusEventArgs Class See Also

The percentage complete.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Percentage As Integer
C#
public int Percentage { get; }
Visual C++
public:
property int Percentage {
    int get ();
}

Remarks

This is -1 if there is no percentage complete information.

See Also

StatusEventArgs Class
RedGate.Shared.Utils Namespace


StatusEventHandler Delegate

[image]

SQL Data Compare API 7.1.0
StatusEventHandler Delegate
See Also

Represents a method that can receive status events.

Namespace: RedGate.Shared.Utils
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub StatusEventHandler ( _
    sender As Object, _
    e As StatusEventArgs _
)
C#
public delegate void StatusEventHandler(
    Object sender,
    StatusEventArgs e
)
Visual C++
public delegate void StatusEventHandler(
    Object^ sender,
    StatusEventArgs^ e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: RedGate.Shared.Utils..::.StatusEventArgs
A StatusEventArgs object that contains the event data.

See Also

RedGate.Shared.Utils Namespace


RedGate.Shared.Utils.Collections Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.Utils.Collections Namespace

Classes

Class | Description
DictionaryBasedSet<(Of <(T>)>) | Class containing all the ICollection implementations for a dictionary-backed Set, that simply pass the relevant methods calls to the private backing dictionary.
EnumerableBase<(Of <(T>)>) | An enumerable that simply uses the same enumerator obtained from the generic GetEnumerator() for the non-generic GetEnumerator.
InnerList<(Of <(T>)>) | A collection wrapping a List<(Of <(T>)>) object.
Set<(Of <(T>)>) | A collection representing an unordered set of unique values.


DictionaryBasedSet(T) Generic Class

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>) Generic Class
Members See Also

Class containing all the ICollection implementations for a dictionary-backed Set, that simply pass the relevant methods calls to the private backing dictionary.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DictionaryBasedSet(Of T) _
    Inherits EnumerableBase(Of T) _
    Implements ICollection(Of T), IEnumerable(Of T),  _
    IEnumerable
C#
[SerializableAttribute]
public abstract class DictionaryBasedSet<T> : EnumerableBase<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class DictionaryBasedSet abstract : public EnumerableBase<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type to store in the set.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set<(Of <(T>)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Members

[image] [image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>) Members
DictionaryBasedSet<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add |
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.
Clear |
Contains |
CopyTo |
Difference |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Union |

Properties

Name | Description
Count |
IsReadOnly |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>) Methods
DictionaryBasedSet<(Of <(T>)>) Class See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add |
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.
Clear |
Contains |
CopyTo |
Difference |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Union |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Add Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Add Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    item As T _
)
C#
public void Add(
    T item
)
Visual C++
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


AddIfNotExists Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.AddIfNotExists Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function AddIfNotExists ( _
    item As T _
) As Boolean
C#
public bool AddIfNotExists(
    T item
)
Visual C++
public:
bool AddIfNotExists(
    T item
)

Parameters

item
Type: T
The item to add to the DictionaryBasedSet<(Of <(T>)>).

Return Value

True if the item was successfully added, false if it is in the set already.

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Clear Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Clear Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Contains Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Contains Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    item As T _
) As Boolean
C#
public bool Contains(
    T item
)
Visual C++
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


CopyTo Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.CopyTo Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    startIndex As Integer _
)
C#
public void CopyTo(
    T[] array,
    int startIndex
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int startIndex
) sealed

Parameters

array
Type: array< T >[]()[]
startIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Difference Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Difference Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Difference ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Difference(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Difference(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.GetEnumerator Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetEnumerator As IEnumerator(Of T)
C#
public override sealed IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() override sealed

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Intersection Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Intersection Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Intersection ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Intersection(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Intersection(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Remove Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Remove Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove ( _
    item As T _
) As Boolean
C#
public bool Remove(
    T item
)
Visual C++
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Union Method

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Union Method
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Union ( _
    other As ISet(Of T) _
) As IEnumerable(Of T)
C#
public virtual IEnumerable<T> Union(
    ISet<T> other
)
Visual C++
public:
virtual IEnumerable<T>^ Union(
    ISet<T>^ other
)

Parameters

other
Type: ISet<(Of <( T >)>)

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


DictionaryBasedSet(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>) Properties
DictionaryBasedSet<(Of <(T>)>) Class See Also

The DictionaryBasedSet<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count |
IsReadOnly |

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Count Property

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.Count Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IsReadOnly Property

[image]

SQL Data Compare API 7.1.0
DictionaryBasedSet<(Of <(T>)>)..::.IsReadOnly Property
DictionaryBasedSet<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly { get; }
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

DictionaryBasedSet<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Generic Class

[image]

SQL Data Compare API 7.1.0
EnumerableBase<(Of <(T>)>) Generic Class
Members See Also

An enumerable that simply uses the same enumerator obtained from the generic GetEnumerator() for the non-generic GetEnumerator.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class EnumerableBase(Of T) _
    Implements IEnumerable(Of T), IEnumerable
C#
public abstract class EnumerableBase<T> : IEnumerable<T>,
    IEnumerable
Visual C++
generic<typename T>
public ref class EnumerableBase abstract : IEnumerable<T>,
    IEnumerable

Type Parameters

T
The type of object returned from the enumerable.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.InnerList<(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.KeyedCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.FullTextStopwords

See Also

EnumerableBase<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Members

[image] [image]

SQL Data Compare API 7.1.0
EnumerableBase<(Of <(T>)>) Members
EnumerableBase<(Of <(T>)>) Class Methods Explicit Interface Implementations See Also

The EnumerableBase<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


EnumerableBase(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
EnumerableBase<(Of <(T>)>) Methods
EnumerableBase<(Of <(T>)>) Class See Also

The EnumerableBase<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
EnumerableBase<(Of <(T>)>)..::.GetEnumerator Method
EnumerableBase<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetEnumerator As IEnumerator(Of T)
C#
public abstract IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() abstract

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IEnumerable.GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
EnumerableBase<(Of <(T>)>)..::.IEnumerable..::.GetEnumerator Method
EnumerableBase<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

EnumerableBase<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Generic Class

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>) Generic Class
Members See Also

A collection wrapping a List<(Of <(T>)>) object.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class InnerList(Of T) _
    Inherits EnumerableBase(Of T) _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IEnumerable
C#
[SerializableAttribute]
public abstract class InnerList<T> : EnumerableBase<T>, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class InnerList abstract : public EnumerableBase<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type stored in the list.

Remarks

This class is intended to simplify programming wrapper collections around lists; all the methods are virtual so can be overridden as required for the particular collection.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.InnerList<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.ClrFiles
RedGate.SQLCompare.Engine..::.Differences
RedGate.SQLCompare.Engine..::.FileGroups
RedGate.SQLCompare.Engine..::.Mappings<(Of <(TMap, TContext>)>)
RedGate.SQLCompare.Engine..::.Messages
RedGate.SQLCompare.Engine..::.Permissions
RedGate.SQLCompare.Engine..::.Regions
RedGate.SQLDataCompare.Engine..::.FieldPairs
RedGate.SQLDataCompare.Engine..::.TableDifferences
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSorts

See Also

InnerList<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Members

[image] [image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>) Members
InnerList<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The InnerList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Contains |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
Item |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>) Methods
InnerList<(Of <(T>)>) Class See Also

The InnerList<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Contains |
CopyTo |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Contains Method

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.Contains Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As T _
) As Boolean
C#
public virtual bool Contains(
    T item
)
Visual C++
public:
virtual bool Contains(
    T item
)

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


CopyTo Method

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.CopyTo Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyTo ( _
    array As T(), _
    index As Integer _
)
C#
public virtual void CopyTo(
    T[] array,
    int index
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int index
)

Parameters

array
Type: array< T >[]()[]
index
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.GetEnumerator Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator(Of T)
C#
public override IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() override

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


IndexOf Method

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.IndexOf Method
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOf ( _
    item As T _
) As Integer
C#
public virtual int IndexOf(
    T item
)
Visual C++
public:
virtual int IndexOf(
    T item
)

Parameters

item
Type: T

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


InnerList(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>) Properties
InnerList<(Of <(T>)>) Class See Also

The InnerList<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count |
Item |

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Count Property

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.Count Property
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
C#
public virtual int Count { get; }
Visual C++
public:
virtual property int Count {
    int get ();
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Item Property

[image]

SQL Data Compare API 7.1.0
InnerList<(Of <(T>)>)..::.Item Property
InnerList<(Of <(T>)>) Class See Also

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item ( _
    index As Integer _
) As T
C#
public virtual T this[
    int index
] { get; set; }
Visual C++
public:
virtual property T default[int index] {
    T get (int index);
    void set (int index, T value);
}

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

InnerList<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Set(T) Generic Class

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Generic Class
Members See Also

A collection representing an unordered set of unique values.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class Set(Of T) _
    Inherits DictionaryBasedSet(Of T)
C#
public class Set<T> : DictionaryBasedSet<T>
Visual C++
generic<typename T>
public ref class Set : public DictionaryBasedSet<T>

Type Parameters

T
The type to store in this set.

Remarks

Please note that behaviour of the set operations is undefined between two Sets that use different IEqualityComparer<(Of <(T>)>)s.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( T >)>)
RedGate.Shared.Utils.Collections..::.DictionaryBasedSet <(Of <(T>)>)
RedGate.Shared.Utils.Collections..::.Set<(Of <(T>)>)

See Also

Set<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


Set(T) Members

[image] [image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Members
Set<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The Set<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
Set<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
AddIfNotExists | Adds item to the DictionaryBasedSet<(Of <(T>)>) if it does not already exist. (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Clear | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Contains | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
CopyTo | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Difference | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Union | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Properties

Name | Description
Count | (Inherited from DictionaryBasedSet<(Of <(T>)>).)
IsReadOnly | (Inherited from DictionaryBasedSet<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Set<(Of <(T>)>) Class
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor

[image] [image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor
Set<(Of <(T>)>) Class See Also

Overload List

Name | Description
Set<(Of <(T>)>)()()() | Initialises a new instance of the Set<(Of <(T>)>) class with the default equality comparer and default capacity.
Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable<(Of <(T>)>), using the default equality comparer.
Set<(Of <(T>)>)(IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the default capacity and the specified IEqualityComparer<(Of <(T>)>).
Set<(Of <(T>)>)(Int32) | Initialises a new instance of the Set<(Of <(T>)>) class with the specified initial capacity and default equality comparer.
Set<(Of <(T>)>)(IEnumerable<(Of <(T>)>), IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable<(Of <(T>)>), using the specified IEqualityComparer<(Of <(T>)>).
Set<(Of <(T>)>)(Int32, IEqualityComparer<(Of <(T>)>)) | Initialises a new instance of the Set<(Of <(T>)>) class with the specified capacity and IEqualityComparer<(Of <(T>)>).

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Members
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the default equality comparer and default capacity.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Set()
Visual C++
public:
Set()

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (IEnumerable(T))

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor (IEnumerable<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable<(Of <(T>)>), using the default equality comparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    src As IEnumerable(Of T) _
)
C#
public Set(
    IEnumerable<T> src
)
Visual C++
public:
Set(
    IEnumerable<T>^ src
)

Parameters

src
Type: System.Collections.Generic..::.IEnumerable <(Of <( T >)>)
The items to add to the Set.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (IEqualityComparer(T))

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor (IEqualityComparer<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the default capacity and the specified IEqualityComparer<(Of <(T>)>).

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    IEqualityComparer<T>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (Int32)

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor (Int32)
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the specified initial capacity and default equality comparer.

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
C#
public Set(
    int capacity
)
Visual C++
public:
Set(
    int capacity
)

Parameters

capacity
Type: System..::.Int32
The initial capacity.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (IEnumerable(T), IEqualityComparer(T))

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor (IEnumerable<(Of <(T>)>), IEqualityComparer<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the contents copied from the specified IEnumerable<(Of <(T>)>), using the specified IEqualityComparer<(Of <(T>)>).

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    src As IEnumerable(Of T), _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    IEnumerable<T> src,
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    IEnumerable<T>^ src,
    IEqualityComparer<T>^ comparer
)

Parameters

src
Type: System.Collections.Generic..::.IEnumerable <(Of <( T >)>)
The items to add to the Set.
comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


Set(T) Constructor (Int32, IEqualityComparer(T))

[image]

SQL Data Compare API 7.1.0
Set<(Of <(T>)>) Constructor (Int32, IEqualityComparer<(Of <(T>)>))
Set<(Of <(T>)>) Class See Also

Initialises a new instance of the Set<(Of <(T>)>) class with the specified capacity and IEqualityComparer<(Of <(T>)>).

Namespace: RedGate.Shared.Utils.Collections
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer, _
    comparer As IEqualityComparer(Of T) _
)
C#
public Set(
    int capacity,
    IEqualityComparer<T> comparer
)
Visual C++
public:
Set(
    int capacity,
    IEqualityComparer<T>^ comparer
)

Parameters

capacity
Type: System..::.Int32
The initial capacity.
comparer
Type: System.Collections.Generic..::.IEqualityComparer <(Of <( T >)>)
The equality comparer to use.

See Also

Set<(Of <(T>)>) Class
Set<(Of <(T>)>) Overload
RedGate.Shared.Utils.Collections Namespace


RedGate.Shared.Utils.IO.Serialization Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.Shared.Utils.IO.Serialization Namespace

Classes

Class | Description
SerializationException | Base exception for Serialization errors.
SerializationInvalidFileException | Serialization error caused by an incorrectly formatted file.
SerializationInvalidFileTypeException | Serialization error caused by an unexpected type name in the file.
SerializationInvalidTypeException | Serialization error caused by a type name not being recognised by the deserializer.
SerializationInvalidVersionException | Serialization error caused by attempting to deserialize a file for which the serialization version is different to the specified object version.
SerializationNotSupportedException | Serialization error caused by a class not implementing the IRedGateSerializable interface.
SerializationParameterConversionException | Serialization error caused by an error raised when converting a parameter. This could be because the serialized file has been edited manually.
SerializationParameterEmptyException | Serialization error caused by an empty parameter.
SerializationParameterMissingException | Serialization error caused by a missing parameter.


SerializationException Class

[image]

SQL Data Compare API 7.1.0
SerializationException Class
Members See Also

Base exception for Serialization errors.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SerializationException _
    Inherits Exception
C#
[SerializableAttribute]
public class SerializationException : Exception
Visual C++
[SerializableAttribute]
public ref class SerializationException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterConversionException
RedGate.Shared.Utils.IO.Serialization..::.SerializationNotSupportedException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidTypeException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidVersionException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterMissingException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterEmptyException

See Also

SerializationException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationException Members
SerializationException Class Constructors Methods Properties See Also

The SerializationException type exposes the following members.

Constructors

Name | Description
SerializationException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationException Constructor
SerializationException Class See Also

Overload List

Name | Description
SerializationException()()() | Initializes a new instance of the SerializationException class.
SerializationException(String) | Initializes a new instance of the SerializationException class with a specified error message.
SerializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializationException class with serialized data.
SerializationException(String, Exception) | Initializes a new instance of the SerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationException Class
SerializationException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor

[image]

SQL Data Compare API 7.1.0
SerializationException Constructor
SerializationException Class See Also

Initializes a new instance of the SerializationException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SerializationException()
Visual C++
public:
SerializationException()

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SerializationException Constructor (String)
SerializationException Class See Also

Initializes a new instance of the SerializationException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SerializationException(
    string message
)
Visual C++
public:
SerializationException(
    String^ message
)

Parameters

message
Type: System..::.String
A message that describes the error.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
SerializationException Constructor (SerializationInfo, StreamingContext)
SerializationException Class See Also

Initializes a new instance of the SerializationException class with serialized data.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SerializationException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SerializationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
SerializationException Constructor (String, Exception)
SerializationException Class See Also

Initializes a new instance of the SerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public SerializationException(
    string message,
    Exception innerException
)
Visual C++
public:
SerializationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception.

See Also

SerializationException Class
SerializationException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Class

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Class
Members See Also

Serialization error caused by an incorrectly formatted file.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationInvalidFileException _
    Inherits SerializationException
C#
public class SerializationInvalidFileException : SerializationException
Visual C++
public ref class SerializationInvalidFileException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileTypeException

See Also

SerializationInvalidFileException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Members
SerializationInvalidFileException Class Constructors Methods Properties See Also

The SerializationInvalidFileException type exposes the following members.

Constructors

Name | Description
SerializationInvalidFileException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Constructor
SerializationInvalidFileException Class See Also

Overload List

Name | Description
SerializationInvalidFileException(String) | Initializes a new instance of the SerializationInvalidFileException class.
SerializationInvalidFileException(String, String) | Initializes a new instance of the SerializationInvalidFileException class with a specified error message.
SerializationInvalidFileException(String, String, Exception) | Initializes a new instance of the SerializationInvalidFileException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Constructor (String)
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
C#
public SerializationInvalidFileException(
    string fileName
)
Visual C++
public:
SerializationInvalidFileException(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the file that caused the exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Constructor (String, String)
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String _
)
C#
public SerializationInvalidFileException(
    string message,
    string fileName
)
Visual C++
public:
SerializationInvalidFileException(
    String^ message,
    String^ fileName
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Constructor (String, String, Exception)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Constructor (String, String, Exception)
SerializationInvalidFileException Class See Also

Initializes a new instance of the SerializationInvalidFileException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    innerException As Exception _
)
C#
public SerializationInvalidFileException(
    string message,
    string fileName,
    Exception innerException
)
Visual C++
public:
SerializationInvalidFileException(
    String^ message,
    String^ fileName,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception.

See Also

SerializationInvalidFileException Class
SerializationInvalidFileException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException Properties
SerializationInvalidFileException Class See Also

The SerializationInvalidFileException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileException..::.FileName Property
SerializationInvalidFileException Class See Also

Gets the name of the file that is incorrectly formatted.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

SerializationInvalidFileException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Class

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Class
Members See Also

Serialization error caused by an unexpected type name in the file.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationInvalidFileTypeException _
    Inherits SerializationInvalidFileException
C#
public class SerializationInvalidFileTypeException : SerializationInvalidFileException
Visual C++
public ref class SerializationInvalidFileTypeException : public SerializationInvalidFileException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidFileTypeException

See Also

SerializationInvalidFileTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Members
SerializationInvalidFileTypeException Class Constructors Methods Properties See Also

The SerializationInvalidFileTypeException type exposes the following members.

Constructors

Name | Description
SerializationInvalidFileTypeException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted. (Inherited from SerializationInvalidFileException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Constructor
SerializationInvalidFileTypeException Class See Also

Overload List

Name | Description
SerializationInvalidFileTypeException(String, String) | Initializes a new instance of the SerializationInvalidFileTypeException class.
SerializationInvalidFileTypeException(String, String, String) | Initializes a new instance of the SerializationInvalidFileTypeException class with a specified error message.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Constructor (String, String)
SerializationInvalidFileTypeException Class See Also

Initializes a new instance of the SerializationInvalidFileTypeException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    typeName As String _
)
C#
public SerializationInvalidFileTypeException(
    string fileName,
    string typeName
)
Visual C++
public:
SerializationInvalidFileTypeException(
    String^ fileName,
    String^ typeName
)

Parameters

fileName
Type: System..::.String
The name of the file that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Constructor (String, String, String)
SerializationInvalidFileTypeException Class See Also

Initializes a new instance of the SerializationInvalidFileTypeException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    typeName As String _
)
C#
public SerializationInvalidFileTypeException(
    string message,
    string fileName,
    string typeName
)
Visual C++
public:
SerializationInvalidFileTypeException(
    String^ message,
    String^ fileName,
    String^ typeName
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
SerializationInvalidFileTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidFileTypeException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException Properties
SerializationInvalidFileTypeException Class See Also

The SerializationInvalidFileTypeException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that is incorrectly formatted. (Inherited from SerializationInvalidFileException.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidFileTypeException..::.TypeName Property
SerializationInvalidFileTypeException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

SerializationInvalidFileTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Class

[image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Class
Members See Also

Serialization error caused by a type name not being recognised by the deserializer.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationInvalidTypeException _
    Inherits SerializationException
C#
public class SerializationInvalidTypeException : SerializationException
Visual C++
public ref class SerializationInvalidTypeException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidTypeException

See Also

SerializationInvalidTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Members
SerializationInvalidTypeException Class Constructors Methods Properties See Also

The SerializationInvalidTypeException type exposes the following members.

Constructors

Name | Description
SerializationInvalidTypeException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Constructor
SerializationInvalidTypeException Class See Also

Overload List

Name | Description
SerializationInvalidTypeException(String, String) | Initializes a new instance of the SerializationInvalidTypeException.
SerializationInvalidTypeException(String, String, String) | Initializes a new instance of the SerializationInvalidTypeException with the specified error message.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Constructor (String, String)
SerializationInvalidTypeException Class See Also

Initializes a new instance of the SerializationInvalidTypeException.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String _
)
C#
public SerializationInvalidTypeException(
    string paramName,
    string typeName
)
Visual C++
public:
SerializationInvalidTypeException(
    String^ paramName,
    String^ typeName
)

Parameters

paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Constructor (String, String, String)
SerializationInvalidTypeException Class See Also

Initializes a new instance of the SerializationInvalidTypeException with the specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String _
)
C#
public SerializationInvalidTypeException(
    string message,
    string paramName,
    string typeName
)
Visual C++
public:
SerializationInvalidTypeException(
    String^ message,
    String^ paramName,
    String^ typeName
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationInvalidTypeException Class
SerializationInvalidTypeException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidTypeException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException Properties
SerializationInvalidTypeException Class See Also

The SerializationInvalidTypeException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException..::.Parameter Property
SerializationInvalidTypeException Class See Also

Gets the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidTypeException..::.TypeName Property
SerializationInvalidTypeException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

SerializationInvalidTypeException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Class

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Class
Members See Also

Serialization error caused by attempting to deserialize a file for which the serialization version is different to the specified object version.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationInvalidVersionException _
    Inherits SerializationException
C#
public class SerializationInvalidVersionException : SerializationException
Visual C++
public ref class SerializationInvalidVersionException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationInvalidVersionException

See Also

SerializationInvalidVersionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Members
SerializationInvalidVersionException Class Constructors Methods Properties See Also

The SerializationInvalidVersionException type exposes the following members.

Constructors

Name | Description
SerializationInvalidVersionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.
Version | Gets the version that caused the exception.

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Constructor
SerializationInvalidVersionException Class See Also

Overload List

Name | Description
SerializationInvalidVersionException(String, String, String) | Initializes a new instance of the SerializationInvalidVersionException class.
SerializationInvalidVersionException(String, String, String, String) | Initializes a new instance of the SerializationInvalidVersionException class with a specified error message.
SerializationInvalidVersionException(String, String, String, String, Exception) | Initializes a new instance of the SerializationInvalidVersionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Constructor (String, String, String)
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String, _
    version As String _
)
C#
public SerializationInvalidVersionException(
    string paramName,
    string typeName,
    string version
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ paramName,
    String^ typeName,
    String^ version
)

Parameters

paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.
version
Type: System..::.String
The version that caused the exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (String, String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Constructor (String, String, String, String)
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String, _
    version As String _
)
C#
public SerializationInvalidVersionException(
    string message,
    string paramName,
    string typeName,
    string version
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ message,
    String^ paramName,
    String^ typeName,
    String^ version
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.
version
Type: System..::.String
The version that caused the exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Constructor (String, String, String, String, Exception)

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Constructor (String, String, String, String, Exception)
SerializationInvalidVersionException Class See Also

Initializes a new instance of the SerializationInvalidVersionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String, _
    version As String, _
    innerException As Exception _
)
C#
public SerializationInvalidVersionException(
    string message,
    string paramName,
    string typeName,
    string version,
    Exception innerException
)
Visual C++
public:
SerializationInvalidVersionException(
    String^ message,
    String^ paramName,
    String^ typeName,
    String^ version,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.
version
Type: System..::.String
The version that caused the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception.

See Also

SerializationInvalidVersionException Class
SerializationInvalidVersionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationInvalidVersionException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException Properties
SerializationInvalidVersionException Class See Also

The SerializationInvalidVersionException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.
Version | Gets the version that caused the exception.

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException..::.Parameter Property
SerializationInvalidVersionException Class See Also

Gets the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException..::.TypeName Property
SerializationInvalidVersionException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
SerializationInvalidVersionException..::.Version Property
SerializationInvalidVersionException Class See Also

Gets the version that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As String
C#
public string Version { get; }
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

SerializationInvalidVersionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Class

[image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Class
Members See Also

Serialization error caused by a class not implementing the IRedGateSerializable interface.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationNotSupportedException _
    Inherits SerializationException
C#
public class SerializationNotSupportedException : SerializationException
Visual C++
public ref class SerializationNotSupportedException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationNotSupportedException

See Also

SerializationNotSupportedException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Members
SerializationNotSupportedException Class Constructors Methods Properties See Also

The SerializationNotSupportedException type exposes the following members.

Constructors

Name | Description
SerializationNotSupportedException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Constructor
SerializationNotSupportedException Class See Also

Overload List

Name | Description
SerializationNotSupportedException(String, String) | Initializes a new instance of the SerializationNotSupportedException.
SerializationNotSupportedException(String, String, String) | Initializes a new instance of the SerializationNotSupportedException with a specified error message.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Constructor (String, String)
SerializationNotSupportedException Class See Also

Initializes a new instance of the SerializationNotSupportedException.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    typeName As String _
)
C#
public SerializationNotSupportedException(
    string paramName,
    string typeName
)
Visual C++
public:
SerializationNotSupportedException(
    String^ paramName,
    String^ typeName
)

Parameters

paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Constructor (String, String, String)
SerializationNotSupportedException Class See Also

Initializes a new instance of the SerializationNotSupportedException with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    typeName As String _
)
C#
public SerializationNotSupportedException(
    string message,
    string paramName,
    string typeName
)
Visual C++
public:
SerializationNotSupportedException(
    String^ message,
    String^ paramName,
    String^ typeName
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
typeName
Type: System..::.String
The type name that caused the exception.

See Also

SerializationNotSupportedException Class
SerializationNotSupportedException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationNotSupportedException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException Properties
SerializationNotSupportedException Class See Also

The SerializationNotSupportedException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
TypeName | Gets the type name that caused the exception.

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException..::.Parameter Property
SerializationNotSupportedException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


TypeName Property

[image]

SQL Data Compare API 7.1.0
SerializationNotSupportedException..::.TypeName Property
SerializationNotSupportedException Class See Also

Gets the type name that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

SerializationNotSupportedException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Class

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Class
Members See Also

Serialization error caused by an error raised when converting a parameter. This could be because the serialized file has been edited manually.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationParameterConversionException _
    Inherits SerializationException
C#
public class SerializationParameterConversionException : SerializationException
Visual C++
public ref class SerializationParameterConversionException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterConversionException

See Also

SerializationParameterConversionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Members
SerializationParameterConversionException Class Constructors Methods Properties See Also

The SerializationParameterConversionException type exposes the following members.

Constructors

Name | Description
SerializationParameterConversionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Constructor
SerializationParameterConversionException Class See Also

Overload List

Name | Description
SerializationParameterConversionException(String, String) | Initializes a new instance of the SerializationParameterConversionException class.
SerializationParameterConversionException(String, String, String) | Initializes a new instance of the SerializationParameterConversionException class with a specified error message.
SerializationParameterConversionException(String, String, String, Exception) | Initializes a new instance of the SerializationParameterConversionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Constructor (String, String)
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paramName As String, _
    fileName As String _
)
C#
public SerializationParameterConversionException(
    string paramName,
    string fileName
)
Visual C++
public:
SerializationParameterConversionException(
    String^ paramName,
    String^ fileName
)

Parameters

paramName
Type: System..::.String
The name of the parameter that caused the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Constructor (String, String, String)
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    fileName As String _
)
C#
public SerializationParameterConversionException(
    string message,
    string paramName,
    string fileName
)
Visual C++
public:
SerializationParameterConversionException(
    String^ message,
    String^ paramName,
    String^ fileName
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Constructor (String, String, String, Exception)

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Constructor (String, String, String, Exception)
SerializationParameterConversionException Class See Also

Initializes a new instance of the SerializationParameterConversionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    paramName As String, _
    fileName As String, _
    innerException As Exception _
)
C#
public SerializationParameterConversionException(
    string message,
    string paramName,
    string fileName,
    Exception innerException
)
Visual C++
public:
SerializationParameterConversionException(
    String^ message,
    String^ paramName,
    String^ fileName,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
paramName
Type: System..::.String
The name of the parameter that caused the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.
innerException
Type: System..::.Exception
The exception that is the cause of the current exception.

See Also

SerializationParameterConversionException Class
SerializationParameterConversionException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterConversionException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException Properties
SerializationParameterConversionException Class See Also

The SerializationParameterConversionException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the name of the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException..::.FileName Property
SerializationParameterConversionException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterConversionException..::.Parameter Property
SerializationParameterConversionException Class See Also

Gets the name of the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationParameterConversionException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Class

[image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Class
Members See Also

Serialization error caused by an empty parameter.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationParameterEmptyException _
    Inherits SerializationException
C#
public class SerializationParameterEmptyException : SerializationException
Visual C++
public ref class SerializationParameterEmptyException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterEmptyException

See Also

SerializationParameterEmptyException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Members
SerializationParameterEmptyException Class Constructors Methods Properties See Also

The SerializationParameterEmptyException type exposes the following members.

Constructors

Name | Description
SerializationParameterEmptyException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Constructor
SerializationParameterEmptyException Class See Also

Overload List

Name | Description
SerializationParameterEmptyException(String, String) | Initializes a new instance of the SerializationParameterEmptyException class.
SerializationParameterEmptyException(String, String, String) | Initializes a new instance of the SerializationParameterEmptyException class with a specified error message.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Constructor (String, String)
SerializationParameterEmptyException Class See Also

Initializes a new instance of the SerializationParameterEmptyException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterEmptyException(
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterEmptyException(
    String^ fileName,
    String^ parameter
)

Parameters

fileName
Type: System..::.String
The name of the file that caused the exception.
parameter
Type: System..::.String
The name of the parameter that caused the exception.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Constructor (String, String, String)
SerializationParameterEmptyException Class See Also

Initializes a new instance of the SerializationParameterEmptyException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterEmptyException(
    string message,
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterEmptyException(
    String^ message,
    String^ fileName,
    String^ parameter
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.
parameter
Type: System..::.String
The name of the parameter that caused the exception.

See Also

SerializationParameterEmptyException Class
SerializationParameterEmptyException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterEmptyException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException Properties
SerializationParameterEmptyException Class See Also

The SerializationParameterEmptyException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException..::.FileName Property
SerializationParameterEmptyException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterEmptyException..::.Parameter Property
SerializationParameterEmptyException Class See Also

Gets the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationParameterEmptyException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Class

[image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Class
Members See Also

Serialization error caused by a missing parameter.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Class SerializationParameterMissingException _
    Inherits SerializationException
C#
public class SerializationParameterMissingException : SerializationException
Visual C++
public ref class SerializationParameterMissingException : public SerializationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.Shared.Utils.IO.Serialization..::.SerializationException
RedGate.Shared.Utils.IO.Serialization..::.SerializationParameterMissingException

See Also

SerializationParameterMissingException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Members

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Members
SerializationParameterMissingException Class Constructors Methods Properties See Also

The SerializationParameterMissingException type exposes the following members.

Constructors

Name | Description
SerializationParameterMissingException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Constructor
SerializationParameterMissingException Class See Also

Overload List

Name | Description
SerializationParameterMissingException(String, String) | Initializes a new instance of the SerializationParameterMissingException class.
SerializationParameterMissingException(String, String, String) | Initializes a new instance of the SerializationParameterMissingException class with a specified error message.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Members
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Constructor (String, String)
SerializationParameterMissingException Class See Also

Initializes a new instance of the SerializationParameterMissingException class.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterMissingException(
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterMissingException(
    String^ fileName,
    String^ parameter
)

Parameters

fileName
Type: System..::.String
The name of the file that caused the exception.
parameter
Type: System..::.String
The name of the parameter that caused the exception.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Constructor (String, String, String)

[image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Constructor (String, String, String)
SerializationParameterMissingException Class See Also

Initializes a new instance of the SerializationParameterMissingException class with a specified error message.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    fileName As String, _
    parameter As String _
)
C#
public SerializationParameterMissingException(
    string message,
    string fileName,
    string parameter
)
Visual C++
public:
SerializationParameterMissingException(
    String^ message,
    String^ fileName,
    String^ parameter
)

Parameters

message
Type: System..::.String
The error message that explains the reason for the exception.
fileName
Type: System..::.String
The name of the file that caused the exception.
parameter
Type: System..::.String
The name of the parameter that caused the exception.

See Also

SerializationParameterMissingException Class
SerializationParameterMissingException Overload
RedGate.Shared.Utils.IO.Serialization Namespace


SerializationParameterMissingException Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException Properties
SerializationParameterMissingException Class See Also

The SerializationParameterMissingException type exposes the following properties.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
FileName | Gets the name of the file that caused the exception.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Parameter | Gets the parameter that caused the exception.
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException..::.FileName Property
SerializationParameterMissingException Class See Also

Gets the name of the file that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName { get; }
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


Parameter Property

[image]

SQL Data Compare API 7.1.0
SerializationParameterMissingException..::.Parameter Property
SerializationParameterMissingException Class See Also

Gets the parameter that caused the exception.

Namespace: RedGate.Shared.Utils.IO.Serialization
Assembly: RedGate.Shared.Utils (in RedGate.Shared.Utils.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter As String
C#
public string Parameter { get; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
}

See Also

SerializationParameterMissingException Class
RedGate.Shared.Utils.IO.Serialization Namespace


RedGate.SQLCompare.Engine Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.SQLCompare.Engine Namespace

Classes

Class | Description
AsymmetricKey | An asymmetric key.
AsymmetricKeys | A collection of asymmetric keys.
Certificate | A certificate.
Certificates | A collection of certificates.
CheckConstraint | A check constraint.
CheckConstraints | A collection of check constraints.
ClrAssemblies | A collection of Common Language Runtime (CLR) assemblies.
ClrAssembly | A Common Language Runtime (CLR) assembly.
ClrFile | A Common Language Runtime (CLR) file.
ClrFiles | A collection of CLR files.
ConnectionProperties | The connection properties used to connect to a SQL Server database.
Contract | A contract.
Contracts | A collection of contracts.
Database | A SQL Server database.
Database..::.EventLogFullException | This exception is used when debugging is enabled and the event log is full.
DatabaseLevelPermission | A database-level permission.
DatabaseLevelPermissions | A collection of database-level permissions.
DatabaseObjectWithAuthorization | A database object that can have its owner altered using ALTER AUTHORIZATION.
DdlTrigger | A DDL trigger.
DdlTriggers | A collection of DDL triggers.
Default | A database default.
Defaults | A collection of defaults.
Difference | A difference between two database objects.
Differences | A collection of difference objects representing the differences between two databases.
EventNotification | An event notification.
EventNotifications | A collection of event notifications.
EventTypes | A collection of EventTypes.
ExtendedProperties | The extended properties associated with a database object.
ExtendedProperty | An extended property.
Field | A SQL Server field.
Fields | A collection of fields.
FileGroup | A filegroup.
FileGroups | A collection of filegroups.
ForeignKey | A foreign key.
ForeignKeys | A collection of foreign keys.
FullTextCatalog | A full text catalog.
FullTextCatalogs | A collection of full text catalogs.
FullTextStoplist | A full text stoplist.
FullTextStoplists | A collection of full text stoplists.
FullTextStopwords | A collection of stopwords associated with a full text stoplist.
Function | A user-defined function.
Functions | A collection of functions.
Index | An index.
Indexes | A collection of indexes.
KeyedCollection<(Of <(T>)>) | A collection that can store items by key as well as by list index.
LiveDatabaseSource | A standard SQL Server database.
Mapping<(Of <(T>)>) | Abstract class used to contain a mapping between two database objects.
MappingException | Exception thrown when an error is encountered whilst mapping.
Mappings<(Of <(TMap, TContext>)>) | Abstract class for creating a set of mappings from a list of database objects.
Members | A collection of role members. These can be users or roles.
Message | A message.
Messages | A collection of messages.
MessageType | A message type.
MessageTypes | A collection of message types.
MessageUsage | A message usage.
MessageUsages | A collection of message usages.
ObjectNotInDatabaseException | An exception that is used when a database object that is not in the database is requested.
ObjectNotInDifferences | Exception that is used when a database object that is not in the differences collection is requested.
OptionDescriptionAttribute | Options used in comparison and synchronization.
Parameter | A SQL Server parameter.
Parameters | A collection of parameters.
PartitionFunction | A partition function.
PartitionFunctions | A collection of partition functions.
PartitionScheme | A partition scheme.
PartitionSchemes | A collection of partition schemes.
Permission | A permission.
Permissions | A collection of permissions.
Project | A SQL Compare project.
Queue | A queue.
Queues | A collection of queues.
Region | A region of text.
Regions | A collection of regions.
Role | A role.
Roles | A collection of roles.
Route | A route.
Routes | A collection of routes.
Rule | A rule.
Rules | A collection of rules.
Schema | A schema.
SchemaObject | A schema object.
SchemaObjectWithAuthorization | Represents a schema object that can also have an ALTER AUTHORIZATION applied to it to change the user as well (so it can have both user & schema).
Schemas | A collection of schemas.
ScriptableDatabaseObject | Represents a scriptable database object. Also has default implementations of some of the IDatabaseObject methods & properties
SerializableCollection<(Of <(T>)>) | A collection that can be serialized to disk.
SerializableDatabaseObjectCollection<(Of <(T>)>) | A collection of database objects that can be serialized to disk.
Service | A service.
ServiceBinding | A service binding.
ServiceBindings | A collection of service bindings.
Services | A collection of services.
SnapshotSource | A SQL Server database encapsulated within a snapshot.
SqlCompareException | This exception is used as the general exception for SQL Compare.
SqlCompareOwnerMapping | Obsolete. Contains a mapping between the schema or owners in the different databases.
SqlCompareOwnerMappings | Holds mappings for the schema or owners between the two databases. Uses the database objects to create the mappings for the views and the tables from the two databases.
SqlSetOptions | SQL set options.
StoredProcedure | A stored procedure.
StoredProcedures | A collection of stored procedures.
SymmetricKey | A symmetric key.
SymmetricKeys | A collection of symmetric keys.
Synonym | A synonym.
Synonyms | A collection of synonyms.
Table | A table.
Tables | A collection of tables.
Trigger | A trigger.
Triggers | A collection of triggers.
User | A user.
UserDefinedType | A user-defined type.
UserDefinedTypes | A collection of user-defined types.
Users | A collection of users.
View | A view.
Views | A collection of views.
ViewsAndTables | A collection of Views and Tables.
ViewTableSuperClass | A view or table superclass.
Work | Used to calculate the work to be done to synchronize databases.
XmlSchemaCollection | An XML schema collection.
XmlSchemaCollections | A collection of XML schema collections.

Interfaces

Interface | Description
IDatabaseObject | An interface implemented by database objects.
IDatabaseObjects<(Of <(T>)>) | A collection of database objects.
IExecuteAs | Used by database objects that can be executed as a specific user. This is used only for SQL Server 2005.
IHasAuthorization | Marks objects that have an owner instead of a schema. Note that some objects can have both an owner and a schema; in this instance, SchemaObjectWithAuthorization is used instead.
IHasPermissions | The database object may have permissions associated with it.
IIsSystemObject | Indicates that an object instance is a system object when implemented by a class.
IOwner | An interface representing an object that can 'own' other objects

Delegates

Delegate | Description
PrepareStringDelegate<(Of <(TMap, TContext>)>) | Creates the name used for comparing two objects when creating mappings.

Enumerations

Enumeration | Description
AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm | The asymmetric key encryption algorithm.
AsymmetricKey..::.AsymmetricKeyKeyEncryption | How the private key of the asymmetric key is encrypted.
Certificate..::.CertificateKeyEncryption | How the private key of the certificate is encrypted.
DatabaseEncryption | The type of encryption applied to the database.
DatabaseLevelPermissionAction | The database-level permission.
DataCompression | Compression used for a table or index record. This has been introduced in SQL Server 2008.
DifferenceType | The type of difference.
EventType | The type of event.
FullTextChangeTracking | The type of change tracking applied to the full text index on a view or table.
FullTextStoplistType | The stoplist used by the full text index on a view or table.
FunctionType | The type of function.
MessageTypeValidation | The validation type for a message type.
ObjectType | The type of database object.
Options | Options used when comparing and synchronizing databases.
PermissionAction | The action that a permission allows.
PermissionClass | The class on which the permission exists.
PermissionSet | The code access permissions for CLR assemblies.
PermissionType | The type of permission.
ReferentialAction | Referential actions for foreign keys.
SpatialIndexInformation..::.GridDensities | The grid densities of spatial indexes
SpatialIndexInformation..::.SpatialIndexTypes | The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.
SpatialIndexInformation..::.TesselationSchemes | Used to specify the tesselation scheme for the spatial index.
SqlType | A SQL Server data type.
SymmetricKey..::.SymmetricKeyEncryptionAlgorithm | The symmetric key encryption algorithm.
SynchronizationDirection | The direction of migration for synchronization.
Table..::.TableChangeTracking | Table change tracking option set. This has been introduced in SQL Server 2008.
UserType | The type of user.
WarningSeverity | Warning severity.
XmlIndexType | The type of XML index.


AsymmetricKey Class

[image]

SQL Data Compare API 7.1.0
AsymmetricKey Class
Members See Also

An asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AsymmetricKey _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class AsymmetricKey : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class AsymmetricKey sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.AsymmetricKey

See Also

AsymmetricKey Members
RedGate.SQLCompare.Engine Namespace


AsymmetricKey Members

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKey Members
AsymmetricKey Class Methods Fields Properties See Also

The AsymmetricKey type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The key algorithm.
KeyLength | The length of the asymmetric key.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.AsymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this asymmetric key.
PrivateKeyEncryption | The encryption type of the asymmetric key's private key.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ThumbPrint | The thumb print for the asymmetric key.

See Also

AsymmetricKey Class


AsymmetricKey Methods

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKey Methods
AsymmetricKey Class See Also

The AsymmetricKey type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AsymmetricKey Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.Equals Method
AsymmetricKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the asymmetric key with a specified asymmetric key. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

AsymmetricKey Class
AsymmetricKey Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.Equals Method (IDatabaseObject, Options)
AsymmetricKey Class See Also

Compares the asymmetric key with a specified asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The asymmetric key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the asymmetric keys are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

AsymmetricKey Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.ScriptObject Method
AsymmetricKey Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, for example quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

AsymmetricKey Class


AsymmetricKey Properties

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKey Properties
AsymmetricKey Class See Also

The AsymmetricKey type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The key algorithm.
KeyLength | The length of the asymmetric key.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.AsymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this asymmetric key.
PrivateKeyEncryption | The encryption type of the asymmetric key's private key.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ThumbPrint | The thumb print for the asymmetric key.

See Also

AsymmetricKey Class


KeyAlgorithm Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.KeyAlgorithm Property
AsymmetricKey Class See Also

The key algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm
C#
public AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm KeyAlgorithm { get; internal set; }
Visual C++
public:
property AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm KeyAlgorithm {
    AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm get ();
    void set (AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm value);
}

See Also

AsymmetricKey Class


KeyLength Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.KeyLength Property
AsymmetricKey Class See Also

The length of the asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; internal set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

AsymmetricKey Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.ObjectType Property
AsymmetricKey Class See Also

Returns ObjectType.AsymmetricKey

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

AsymmetricKey Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.Permissions Property
AsymmetricKey Class See Also

The permissions on this asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

AsymmetricKey Class


PrivateKeyEncryption Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.PrivateKeyEncryption Property
AsymmetricKey Class See Also

The encryption type of the asymmetric key's private key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrivateKeyEncryption As AsymmetricKey..::.AsymmetricKeyKeyEncryption
C#
public AsymmetricKey..::.AsymmetricKeyKeyEncryption PrivateKeyEncryption { get; internal set; }
Visual C++
public:
property AsymmetricKey..::.AsymmetricKeyKeyEncryption PrivateKeyEncryption {
    AsymmetricKey..::.AsymmetricKeyKeyEncryption get ();
    void set (AsymmetricKey..::.AsymmetricKeyKeyEncryption value);
}

See Also

AsymmetricKey Class


ThumbPrint Property

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.ThumbPrint Property
AsymmetricKey Class See Also

The thumb print for the asymmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; internal set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

AsymmetricKey Class


AsymmetricKey.AsymmetricKeyEncryptionAlgorithm Enumeration

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.AsymmetricKeyEncryptionAlgorithm Enumeration
AsymmetricKey Class See Also

The asymmetric key encryption algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration AsymmetricKeyEncryptionAlgorithm
C#
public enum AsymmetricKeyEncryptionAlgorithm
Visual C++
public enum class AsymmetricKeyEncryptionAlgorithm

Members

Member name | Description
RSA512 | 1R = RSA 512
RSA1024 | 1R = RSA 1024
RSA2048 | 1R = RSA 2048

See Also


AsymmetricKey.AsymmetricKeyKeyEncryption Enumeration

[image]

SQL Data Compare API 7.1.0
AsymmetricKey..::.AsymmetricKeyKeyEncryption Enumeration
AsymmetricKey Class See Also

How the private key of the asymmetric key is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration AsymmetricKeyKeyEncryption
C#
public enum AsymmetricKeyKeyEncryption
Visual C++
public enum class AsymmetricKeyKeyEncryption

Members

Member name | Description
NotAvailable | NA = There is no private key for the asymmetric key.
MasterKey | MK = Private key is encrypted by the master key.
PrivateKey | PW = Private key is encrypted by a user-defined password.
ServiceKey | SK = Private key is encrypted by the service master key.

See Also


AsymmetricKeys Class

[image]

SQL Data Compare API 7.1.0
AsymmetricKeys Class
Members See Also

A collection of asymmetric keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AsymmetricKeys _
    Inherits SerializableDatabaseObjectCollection(Of AsymmetricKey)
C#
public sealed class AsymmetricKeys : SerializableDatabaseObjectCollection<AsymmetricKey>
Visual C++
public ref class AsymmetricKeys sealed : public SerializableDatabaseObjectCollection<AsymmetricKey^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( AsymmetricKey >)>)
RedGate.SQLCompare.Engine..::.AsymmetricKeys

See Also

AsymmetricKeys Members


AsymmetricKeys Members

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKeys Members
AsymmetricKeys Class Methods Properties Explicit Interface Implementations See Also

The AsymmetricKeys type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

AsymmetricKeys Class


Certificate Class

[image]

SQL Data Compare API 7.1.0
Certificate Class
Members See Also

A certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Certificate _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class Certificate : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class Certificate sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Certificate

See Also

Certificate Members


Certificate Members

[image] [image]

SQL Data Compare API 7.1.0
Certificate Members
Certificate Class Methods Fields Properties See Also

The Certificate type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
ActiveForDialog | True if the certificate is available to the initiator of a Service Broker dialog conversation.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExpiryDate | The expiry date of the certificate.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IssuerName | The name of the certificate's issuer.
KeyEncryptionType | The certificate's private key encryption type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Certificate (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this certificate.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
SerialNumber | The certificate's serial number.
StartDate | The start date of the certificate.
Subject | The certificate's subject.
ThumbPrint | The thumb print for this certificate.

See Also

Certificate Class


Certificate Methods

[image] [image]

SQL Data Compare API 7.1.0
Certificate Methods
Certificate Class See Also

The Certificate type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Certificate Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Certificate..::.Equals Method
Certificate Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the certificate with a specified certificate. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Certificate Class
Certificate Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Certificate..::.Equals Method (IDatabaseObject, Options)
Certificate Class See Also

Compares the certificate with a specified certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The certificate to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the certificates are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Certificate Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Certificate..::.ScriptObject Method
Certificate Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Certificate Class


Certificate Properties

[image] [image]

SQL Data Compare API 7.1.0
Certificate Properties
Certificate Class See Also

The Certificate type exposes the following properties.

Properties

Name | Description
ActiveForDialog | True if the certificate is available to the initiator of a Service Broker dialog conversation.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExpiryDate | The expiry date of the certificate.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IssuerName | The name of the certificate's issuer.
KeyEncryptionType | The certificate's private key encryption type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Certificate (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this certificate.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
SerialNumber | The certificate's serial number.
StartDate | The start date of the certificate.
Subject | The certificate's subject.
ThumbPrint | The thumb print for this certificate.

See Also

Certificate Class


ActiveForDialog Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.ActiveForDialog Property
Certificate Class See Also

True if the certificate is available to the initiator of a Service Broker dialog conversation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveForDialog As Boolean
C#
public bool ActiveForDialog { get; internal set; }
Visual C++
public:
property bool ActiveForDialog {
    bool get ();
    void set (bool value);
}

See Also

Certificate Class


ExpiryDate Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.ExpiryDate Property
Certificate Class See Also

The expiry date of the certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpiryDate As DateTime
C#
public DateTime ExpiryDate { get; internal set; }
Visual C++
public:
property DateTime ExpiryDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Certificate Class


IssuerName Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.IssuerName Property
Certificate Class See Also

The name of the certificate's issuer.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IssuerName As String
C#
public string IssuerName { get; internal set; }
Visual C++
public:
property String^ IssuerName {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class


KeyEncryptionType Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.KeyEncryptionType Property
Certificate Class See Also

The certificate's private key encryption type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyEncryptionType As Certificate..::.CertificateKeyEncryption
C#
public Certificate..::.CertificateKeyEncryption KeyEncryptionType { get; internal set; }
Visual C++
public:
property Certificate..::.CertificateKeyEncryption KeyEncryptionType {
    Certificate..::.CertificateKeyEncryption get ();
    void set (Certificate..::.CertificateKeyEncryption value);
}

See Also

Certificate Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.ObjectType Property
Certificate Class See Also

Returns ObjectType.Certificate

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Certificate Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.Permissions Property
Certificate Class See Also

The permissions on this certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Certificate Class


SerialNumber Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.SerialNumber Property
Certificate Class See Also

The certificate's serial number.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
C#
public string SerialNumber { get; internal set; }
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class


StartDate Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.StartDate Property
Certificate Class See Also

The start date of the certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property StartDate As DateTime
C#
public DateTime StartDate { get; internal set; }
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Certificate Class


Subject Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.Subject Property
Certificate Class See Also

The certificate's subject.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject { get; internal set; }
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

Certificate Class


ThumbPrint Property

[image]

SQL Data Compare API 7.1.0
Certificate..::.ThumbPrint Property
Certificate Class See Also

The thumb print for this certificate.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ThumbPrint As Byte()
C#
public byte[] ThumbPrint { get; internal set; }
Visual C++
public:
property array<unsigned char>^ ThumbPrint {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

Certificate Class


Certificate.CertificateKeyEncryption Enumeration

[image]

SQL Data Compare API 7.1.0
Certificate..::.CertificateKeyEncryption Enumeration
Certificate Class See Also

How the private key of the certificate is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration CertificateKeyEncryption
C#
public enum CertificateKeyEncryption
Visual C++
public enum class CertificateKeyEncryption

Members

Member name | Description
NotAvailable | NA = There is no private key for the certificate.
MasterKey | MK = Private key is encrypted by the master key.
PrivateKey | PW = Private key is encrypted by a user-defined password.
ServiceKey | SK = Private key is encrypted by the service master key.

See Also


Certificates Class

[image]

SQL Data Compare API 7.1.0
Certificates Class
Members See Also

A collection of certificates.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Certificates _
    Inherits SerializableDatabaseObjectCollection(Of Certificate)
C#
public sealed class Certificates : SerializableDatabaseObjectCollection<Certificate>
Visual C++
public ref class Certificates sealed : public SerializableDatabaseObjectCollection<Certificate^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Certificate >)>)
RedGate.SQLCompare.Engine..::.Certificates

See Also

Certificates Members


Certificates Members

[image] [image]

SQL Data Compare API 7.1.0
Certificates Members
Certificates Class Methods Properties Explicit Interface Implementations See Also

The Certificates type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Certificates Class


CheckConstraint Class

[image]

SQL Data Compare API 7.1.0
CheckConstraint Class
Members See Also

A check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckConstraint _
    Implements IDatabaseObject
C#
public sealed class CheckConstraint : IDatabaseObject
Visual C++
public ref class CheckConstraint sealed : IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.CheckConstraint

See Also

CheckConstraint Members


CheckConstraint Members

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraint Members
CheckConstraint Class Methods Properties See Also

The CheckConstraint type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database | The database to which the object belongs.
Disabled | True if the check constraint is disabled.
Fields | The fields in the check constraint.
FullyQualifiedName | The fully-qualified name of the object.
Name | The constraint name.
NoCheck | True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).
NotForReplication | True if the check constraint is marked not for replication.
ObjectType | Returns ObjectType.CheckConstraint.
Owner | The owner or schema of the object.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
SysobjectID | The sysobject identier of the object.
Text | The constraint text.

See Also

CheckConstraint Class


CheckConstraint Methods

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraint Methods
CheckConstraint Class See Also

The CheckConstraint type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CheckConstraint Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Equals Method
CheckConstraint Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the check constraint with a specified check constraint.

See Also

CheckConstraint Class
CheckConstraint Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Equals Method (IDatabaseObject, Options)
CheckConstraint Class See Also

Compares the check constraint with a specified check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    obj As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public bool Equals(
    IDatabaseObject obj,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ obj,
    Options options
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The constraint to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

Compares the table with a specified table.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

CheckConstraint Class
Equals Overload


CheckConstraint Properties

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraint Properties
CheckConstraint Class See Also

The CheckConstraint type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
Disabled | True if the check constraint is disabled.
Fields | The fields in the check constraint.
FullyQualifiedName | The fully-qualified name of the object.
Name | The constraint name.
NoCheck | True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).
NotForReplication | True if the check constraint is marked not for replication.
ObjectType | Returns ObjectType.CheckConstraint.
Owner | The owner or schema of the object.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
SysobjectID | The sysobject identier of the object.
Text | The constraint text.

See Also

CheckConstraint Class


Database Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Database Property
CheckConstraint Class See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As Database
C#
public Database Database { get; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

CheckConstraint Class


Disabled Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Disabled Property
CheckConstraint Class See Also

True if the check constraint is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; internal set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class


Fields Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Fields Property
CheckConstraint Class See Also

The fields in the check constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As Fields
C#
public Fields Fields { get; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
}

See Also

CheckConstraint Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.FullyQualifiedName Property
CheckConstraint Class See Also

The fully-qualified name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

CheckConstraint Class


Name Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Name Property
CheckConstraint Class See Also

The constraint name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseObject..::.Name

See Also

CheckConstraint Class


NoCheck Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.NoCheck Property
CheckConstraint Class See Also

True if the constraint is marked as WITH NOCHECK (that is, it is not trusted).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCheck As Boolean
C#
public bool NoCheck { get; internal set; }
Visual C++
public:
property bool NoCheck {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class


NotForReplication Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.NotForReplication Property
CheckConstraint Class See Also

True if the check constraint is marked not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

CheckConstraint Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.ObjectType Property
CheckConstraint Class See Also

Returns ObjectType.CheckConstraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

IDatabaseObject..::.ObjectType

See Also

CheckConstraint Class


Owner Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Owner Property
CheckConstraint Class See Also

The owner or schema of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.Owner

See Also

CheckConstraint Class


ScriptSource Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.ScriptSource Property
CheckConstraint Class See Also

The location of the creation script for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

CheckConstraint Class


SysobjectID Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.SysobjectID Property
CheckConstraint Class See Also

The sysobject identier of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

See Also

CheckConstraint Class


Text Property

[image]

SQL Data Compare API 7.1.0
CheckConstraint..::.Text Property
CheckConstraint Class See Also

The constraint text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

CheckConstraint Class


CheckConstraints Class

[image]

SQL Data Compare API 7.1.0
CheckConstraints Class
Members See Also

A collection of check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CheckConstraints _
    Inherits SerializableCollection(Of CheckConstraint)
C#
public sealed class CheckConstraints : SerializableCollection<CheckConstraint>
Visual C++
public ref class CheckConstraints sealed : public SerializableCollection<CheckConstraint^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( CheckConstraint >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( CheckConstraint >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( CheckConstraint >)>)
RedGate.SQLCompare.Engine..::.CheckConstraints

See Also

CheckConstraints Members


CheckConstraints Members

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraints Members
CheckConstraints Class Methods Properties Explicit Interface Implementations See Also

The CheckConstraints type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

CheckConstraints Class


CheckConstraints Properties

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraints Properties
CheckConstraints Class See Also

The CheckConstraints type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

CheckConstraints Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
CheckConstraints..::.Item Property
CheckConstraints Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns a check constraint given a name. (Overrides KeyedCollection <(Of <( CheckConstraint >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(Table, String])]) | Returns a check constraint given a table and a name.

See Also

CheckConstraints Class
CheckConstraints Members


Item Property (String)

[image]

SQL Data Compare API 7.1.0
CheckConstraints..::.Item Property (String)
CheckConstraints Class See Also

Returns a check constraint given a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As CheckConstraint
C#
public override CheckConstraint this[
    string name
] { get; }
Visual C++
public:
virtual property CheckConstraint^ default[String^ name] {
    CheckConstraint^ get (String^ name) override;
}

Parameters

name
Type: System..::.String
The string-based index of the element to get or set.

See Also

CheckConstraints Class
Item Overload


Item Property (Table, String)

[image]

SQL Data Compare API 7.1.0
CheckConstraints..::.Item Property (Table, String)
CheckConstraints Class See Also

Returns a check constraint given a table and a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    table As Table, _
    name As String _
) As CheckConstraint
C#
public CheckConstraint this[
    Table table,
    string name
] { get; }
Visual C++
public:
property CheckConstraint^ default[Table^ table, String^ name] {
    CheckConstraint^ get (Table^ table, String^ name);
}

Parameters

table
Type: RedGate.SQLCompare.Engine..::.Table
The table component of the string-based index of the element to get or set.
name
Type: System..::.String
The name component of the string-based index of the element to get or set.

See Also

CheckConstraints Class
Item Overload


ClrAssemblies Class

[image]

SQL Data Compare API 7.1.0
ClrAssemblies Class
Members See Also

A collection of Common Language Runtime (CLR) assemblies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrAssemblies _
    Inherits SerializableDatabaseObjectCollection(Of ClrAssembly)
C#
public sealed class ClrAssemblies : SerializableDatabaseObjectCollection<ClrAssembly>
Visual C++
public ref class ClrAssemblies sealed : public SerializableDatabaseObjectCollection<ClrAssembly^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ClrAssembly >)>)
RedGate.SQLCompare.Engine..::.ClrAssemblies

See Also

ClrAssemblies Members


ClrAssemblies Members

[image] [image]

SQL Data Compare API 7.1.0
ClrAssemblies Members
ClrAssemblies Class Methods Properties Explicit Interface Implementations See Also

The ClrAssemblies type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ClrAssemblies Class


ClrAssemblies Properties

[image] [image]

SQL Data Compare API 7.1.0
ClrAssemblies Properties
ClrAssemblies Class See Also

The ClrAssemblies type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ClrAssemblies Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
ClrAssemblies..::.Item Property
ClrAssemblies Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns a CLR assembly given its identifier. (Overrides KeyedCollection <(Of <( ClrAssembly >)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

ClrAssemblies Class
ClrAssemblies Members


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
ClrAssemblies..::.Item Property (Int32)
ClrAssemblies Class See Also

Returns a CLR assembly given its identifier.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    index As Integer _
) As ClrAssembly
C#
public override ClrAssembly this[
    int index
] { get; }
Visual C++
public:
virtual property ClrAssembly^ default[int index] {
    ClrAssembly^ get (int index) override;
}

Parameters

index
Type: System..::.Int32
The system id of the assmebly.

See Also

ClrAssemblies Class
Item Overload


ClrAssembly Class

[image]

SQL Data Compare API 7.1.0
ClrAssembly Class
Members See Also

A Common Language Runtime (CLR) assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrAssembly _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class ClrAssembly : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class ClrAssembly sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ClrAssembly

See Also

ClrAssembly Members


ClrAssembly Members

[image] [image]

SQL Data Compare API 7.1.0
ClrAssembly Members
ClrAssembly Class Methods Fields Properties See Also

The ClrAssembly type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
CLRName | The CLR name of the assembly.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the CLR assembly.
Files | The files that belong to the assembly.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
ID | The sysobject identifier for the CLR assembly.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this CLR assembly.
PermissionSet | The code access permission for the CLR assembly.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSourceVisibility | The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files
Visibility | Indicates whether the assembly's visibility is set to on or off.

See Also

ClrAssembly Class


ClrAssembly Methods

[image] [image]

SQL Data Compare API 7.1.0
ClrAssembly Methods
ClrAssembly Class See Also

The ClrAssembly type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClrAssembly Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ClrAssembly..::.Equals Method
ClrAssembly Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the assembly with a specified assembly. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ClrAssembly Class
ClrAssembly Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.Equals Method (IDatabaseObject, Options)
ClrAssembly Class See Also

Compares the assembly with a specified assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The assembly to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the assemblies are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ClrAssembly Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.ScriptObject Method
ClrAssembly Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.

Return Value

Regions that contain the script.

See Also

ClrAssembly Class


ClrAssembly Properties

[image] [image]

SQL Data Compare API 7.1.0
ClrAssembly Properties
ClrAssembly Class See Also

The ClrAssembly type exposes the following properties.

Properties

Name | Description
CLRName | The CLR name of the assembly.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the CLR assembly.
Files | The files that belong to the assembly.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
ID | The sysobject identifier for the CLR assembly.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this CLR assembly.
PermissionSet | The code access permission for the CLR assembly.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ScriptSourceVisibility | The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files
Visibility | Indicates whether the assembly's visibility is set to on or off.

See Also

ClrAssembly Class


CLRName Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.CLRName Property
ClrAssembly Class See Also

The CLR name of the assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRName As String
C#
public string CLRName { get; internal set; }
Visual C++
public:
property String^ CLRName {
    String^ get ();
    void set (String^ value);
}

See Also

ClrAssembly Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.ExtendedProperties Property
ClrAssembly Class See Also

The extended properties defined for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

ClrAssembly Class


Files Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.Files Property
ClrAssembly Class See Also

The files that belong to the assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Files As ClrFiles
C#
public ClrFiles Files { get; }
Visual C++
public:
property ClrFiles^ Files {
    ClrFiles^ get ();
}

See Also

ClrAssembly Class


ID Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.ID Property
ClrAssembly Class See Also

The sysobject identifier for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As Integer
C#
public int ID { get; }
Visual C++
public:
property int ID {
    int get ();
}

See Also

ClrAssembly Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.ObjectType Property
ClrAssembly Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

ClrAssembly Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.Permissions Property
ClrAssembly Class See Also

The permissions on this CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

ClrAssembly Class


PermissionSet Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.PermissionSet Property
ClrAssembly Class See Also

The code access permission for the CLR assembly.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionSet As PermissionSet
C#
public PermissionSet PermissionSet { get; internal set; }
Visual C++
public:
property PermissionSet PermissionSet {
    PermissionSet get ();
    void set (PermissionSet value);
}

See Also

ClrAssembly Class


ScriptSourceVisibility Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.ScriptSourceVisibility Property
ClrAssembly Class See Also

The script source for any ALTER ASSEMBLY statements attached to this assembly other than adding files

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceVisibility As ScriptSource
C#
public ScriptSource ScriptSourceVisibility { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceVisibility {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ClrAssembly Class


Visibility Property

[image]

SQL Data Compare API 7.1.0
ClrAssembly..::.Visibility Property
ClrAssembly Class See Also

Indicates whether the assembly's visibility is set to on or off.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Visibility As Boolean
C#
public bool Visibility { get; internal set; }
Visual C++
public:
property bool Visibility {
    bool get ();
    void set (bool value);
}

See Also

ClrAssembly Class


ClrFile Class

[image]

SQL Data Compare API 7.1.0
ClrFile Class
Members See Also

A Common Language Runtime (CLR) file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrFile
C#
public sealed class ClrFile
Visual C++
public ref class ClrFile sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ClrFile

See Also

ClrFile Members


ClrFile Members

[image] [image]

SQL Data Compare API 7.1.0
ClrFile Members
ClrFile Class Methods Properties See Also

The ClrFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Contents | The raw data of the CLR assembly file.
Name | The name of the CLR file.
ScriptSource | The script source for this CLR file.

See Also

ClrFile Class


ClrFile Properties

[image] [image]

SQL Data Compare API 7.1.0
ClrFile Properties
ClrFile Class See Also

The ClrFile type exposes the following properties.

Properties

Name | Description
Contents | The raw data of the CLR assembly file.
Name | The name of the CLR file.
ScriptSource | The script source for this CLR file.

See Also

ClrFile Class


Contents Property

[image]

SQL Data Compare API 7.1.0
ClrFile..::.Contents Property
ClrFile Class See Also

The raw data of the CLR assembly file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contents As Byte()
C#
public byte[] Contents { get; }
Visual C++
public:
property array<unsigned char>^ Contents {
    array<unsigned char>^ get ();
}

See Also

ClrFile Class


Name Property

[image]

SQL Data Compare API 7.1.0
ClrFile..::.Name Property
ClrFile Class See Also

The name of the CLR file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ClrFile Class


ScriptSource Property

[image]

SQL Data Compare API 7.1.0
ClrFile..::.ScriptSource Property
ClrFile Class See Also

The script source for this CLR file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ClrFile Class


ClrFiles Class

[image]

SQL Data Compare API 7.1.0
ClrFiles Class
Members See Also

A collection of CLR files.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ClrFiles _
    Inherits InnerList(Of ClrFile)
C#
public sealed class ClrFiles : InnerList<ClrFile>
Visual C++
public ref class ClrFiles sealed : public InnerList<ClrFile^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ClrFile >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( ClrFile >)>)
RedGate.SQLCompare.Engine..::.ClrFiles

See Also

ClrFiles Members


ClrFiles Members

[image] [image]

SQL Data Compare API 7.1.0
ClrFiles Members
ClrFiles Class Methods Properties Explicit Interface Implementations See Also

The ClrFiles type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ClrFiles Class


ConnectionProperties Class

[image]

SQL Data Compare API 7.1.0
ConnectionProperties Class
Members See Also

The connection properties used to connect to a SQL Server database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConnectionProperties _
    Implements ISerializable
C#
[SerializableAttribute]
public class ConnectionProperties : ISerializable
Visual C++
[SerializableAttribute]
public ref class ConnectionProperties : ISerializable

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ConnectionProperties

See Also

ConnectionProperties Members


ConnectionProperties Members

[image] [image]

SQL Data Compare API 7.1.0
ConnectionProperties Members
ConnectionProperties Class Constructors Methods Properties See Also

The ConnectionProperties type exposes the following members.

Constructors

Name | Description
ConnectionProperties | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Used in serialization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties.
ToString | (Overrides Object ..::. ToString()()().)

Properties

Name | Description
DatabaseName | The name of the database to connect to.
IntegratedSecurity | True to use integrated authentication, false for SQL Server authentication.
Password | The password to use when connecting to the SQL Server.
ServerName | The name of the SQL Server to connect to.
UserName | The user name to use when connecting to the SQL Server.

See Also

ConnectionProperties Class


ConnectionProperties Constructor

[image] [image]

SQL Data Compare API 7.1.0
ConnectionProperties Constructor
ConnectionProperties Class See Also

Overload List

Name | Description
ConnectionProperties()()() | Constructor for the ConnectionProperties class.
ConnectionProperties(String, String) | Constructor for integrated security.
ConnectionProperties(String, String, String, String) | Constructor for SQL security.

See Also

ConnectionProperties Class
ConnectionProperties Members


ConnectionProperties Constructor

[image]

SQL Data Compare API 7.1.0
ConnectionProperties Constructor
ConnectionProperties Class See Also

Constructor for the ConnectionProperties class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ConnectionProperties()
Visual C++
public:
ConnectionProperties()

See Also

ConnectionProperties Class
ConnectionProperties Overload


ConnectionProperties Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
ConnectionProperties Constructor (String, String)
ConnectionProperties Class See Also

Constructor for integrated security.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String _
)
C#
public ConnectionProperties(
    string serverName,
    string databaseName
)
Visual C++
public:
ConnectionProperties(
    String^ serverName,
    String^ databaseName
)

Parameters

serverName
Type: System..::.String
The SQL Server name.
databaseName
Type: System..::.String
The database name.

See Also

ConnectionProperties Class
ConnectionProperties Overload


ConnectionProperties Constructor (String, String, String, String)

[image]

SQL Data Compare API 7.1.0
ConnectionProperties Constructor (String, String, String, String)
ConnectionProperties Class See Also

Constructor for SQL security.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String, _
    databaseName As String, _
    userName As String, _
    password As String _
)
C#
public ConnectionProperties(
    string serverName,
    string databaseName,
    string userName,
    string password
)
Visual C++
public:
ConnectionProperties(
    String^ serverName,
    String^ databaseName,
    String^ userName,
    String^ password
)

Parameters

serverName
Type: System..::.String
The SQL Server name.
databaseName
Type: System..::.String
The database name.
userName
Type: System..::.String
The user name to use to connect to the SQL Server.
password
Type: System..::.String
The password to use to connect to the SQL Server.

See Also

ConnectionProperties Class
ConnectionProperties Overload


ConnectionProperties Methods

[image] [image]

SQL Data Compare API 7.1.0
ConnectionProperties Methods
ConnectionProperties Class See Also

The ConnectionProperties type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Used in serialization.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToDBConnectionInformation | Returns a DBConnectionInformation object representing the current connection properties.
ToString | (Overrides Object ..::. ToString()()().)

See Also

ConnectionProperties Class


GetObjectData Method

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.GetObjectData Method
ConnectionProperties Class See Also

Used in serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ConnectionProperties Class


ToDBConnectionInformation Method

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.ToDBConnectionInformation Method
ConnectionProperties Class See Also

Returns a DBConnectionInformation object representing the current connection properties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ToDBConnectionInformation As DBConnectionInformation
C#
public DBConnectionInformation ToDBConnectionInformation()
Visual C++
public:
DBConnectionInformation^ ToDBConnectionInformation()

Return Value

A DBConnectionInformation object with the same connection information as this object.

Remarks

This can be passed to ExecuteBlock(ExecutionBlock, DBConnectionInformation) to use these connection properties to run a synchronization script on the database represented by the current ConnectionProperties object.

See Also

ConnectionProperties Class


ToString Method

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.ToString Method
ConnectionProperties Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

See Also

ConnectionProperties Class


ConnectionProperties Properties

[image] [image]

SQL Data Compare API 7.1.0
ConnectionProperties Properties
ConnectionProperties Class See Also

The ConnectionProperties type exposes the following properties.

Properties

Name | Description
DatabaseName | The name of the database to connect to.
IntegratedSecurity | True to use integrated authentication, false for SQL Server authentication.
Password | The password to use when connecting to the SQL Server.
ServerName | The name of the SQL Server to connect to.
UserName | The user name to use when connecting to the SQL Server.

See Also

ConnectionProperties Class


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.DatabaseName Property
ConnectionProperties Class See Also

The name of the database to connect to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseName As String
C#
public string DatabaseName { get; set; }
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

ConnectionProperties Class


IntegratedSecurity Property

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.IntegratedSecurity Property
ConnectionProperties Class See Also

True to use integrated authentication, false for SQL Server authentication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; set; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

See Also

ConnectionProperties Class


Password Property

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.Password Property
ConnectionProperties Class See Also

The password to use when connecting to the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ConnectionProperties Class


ServerName Property

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.ServerName Property
ConnectionProperties Class See Also

The name of the SQL Server to connect to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerName As String
C#
public string ServerName { get; set; }
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

See Also

ConnectionProperties Class


UserName Property

[image]

SQL Data Compare API 7.1.0
ConnectionProperties..::.UserName Property
ConnectionProperties Class See Also

The user name to use when connecting to the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ConnectionProperties Class


Contract Class

[image]

SQL Data Compare API 7.1.0
Contract Class
Members See Also

A contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Contract _
    Inherits DatabaseObjectWithAuthorization _
    Implements IIsSystemObject, IHasPermissions, IDatabaseObject
C#
public sealed class Contract : DatabaseObjectWithAuthorization, IIsSystemObject,
    IHasPermissions, IDatabaseObject
Visual C++
public ref class Contract sealed : public DatabaseObjectWithAuthorization,
    IIsSystemObject, IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Contract

See Also

Contract Members


Contract Members

[image] [image]

SQL Data Compare API 7.1.0
Contract Members
Contract Class Methods Fields Properties See Also

The Contract type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the contract.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this contract.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Services | The services that depend on the contract.
Usages | The message types used by the contract.

See Also

Contract Class


Contract Methods

[image] [image]

SQL Data Compare API 7.1.0
Contract Methods
Contract Class See Also

The Contract type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Contract Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Contract..::.Equals Method
Contract Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the contract with a specified contract. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Contract Class
Contract Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Contract..::.Equals Method (IDatabaseObject, Options)
Contract Class See Also

Compares the contract with a specified contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The contract to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the contracts are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Contract Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Contract..::.ScriptObject Method
Contract Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Contract Class


Contract Properties

[image] [image]

SQL Data Compare API 7.1.0
Contract Properties
Contract Class See Also

The Contract type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the contract.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this contract.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Services | The services that depend on the contract.
Usages | The message types used by the contract.

See Also

Contract Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Contract..::.ExtendedProperties Property
Contract Class See Also

The extended properties defined for the contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

Contract Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
Contract..::.IsSystemObject Property
Contract Class See Also

Indicates whether the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Contract Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Contract..::.ObjectType Property
Contract Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Contract Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Contract..::.Permissions Property
Contract Class See Also

The permissions on this contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Contract Class


Services Property

[image]

SQL Data Compare API 7.1.0
Contract..::.Services Property
Contract Class See Also

The services that depend on the contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As Services
C#
public Services Services { get; }
Visual C++
public:
property Services^ Services {
    Services^ get ();
}

See Also

Contract Class


Usages Property

[image]

SQL Data Compare API 7.1.0
Contract..::.Usages Property
Contract Class See Also

The message types used by the contract.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Usages As MessageUsages
C#
public MessageUsages Usages { get; }
Visual C++
public:
property MessageUsages^ Usages {
    MessageUsages^ get ();
}

See Also

Contract Class


Contracts Class

[image]

SQL Data Compare API 7.1.0
Contracts Class
Members See Also

A collection of contracts.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Contracts _
    Inherits SerializableDatabaseObjectCollection(Of Contract)
C#
public sealed class Contracts : SerializableDatabaseObjectCollection<Contract>
Visual C++
public ref class Contracts sealed : public SerializableDatabaseObjectCollection<Contract^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Contract >)>)
RedGate.SQLCompare.Engine..::.Contracts

See Also

Contracts Members


Contracts Members

[image] [image]

SQL Data Compare API 7.1.0
Contracts Members
Contracts Class Methods Properties Explicit Interface Implementations See Also

The Contracts type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Contracts Class


Database Class

[image]

SQL Data Compare API 7.1.0
Database Class
Members See Also

A SQL Server database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Database _
    Inherits DisposableBase _
    Implements ICancellable, ICloneable
C#
public class Database : DisposableBase, ICancellable,
    ICloneable
Visual C++
public ref class Database : public DisposableBase,
    ICancellable, ICloneable

Remarks

Use Register(ConnectionProperties, Options) to register the database from a live server or LoadFromDisk(String) to load a database from a snapshot.

Registering a database is a long-running operation. Status feedback is provided via the Status event handler. To cancel the operation, call CancelOperation.

You must call Dispose(Boolean) when you have finished using a Database object.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine..::.Database
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupSetDatabase

See Also

Database Members


Database Members

[image] [image]

SQL Data Compare API 7.1.0
Database Members
Database Class Constructors Methods Properties See Also

The Database type exposes the following members.

Constructors

Name | Description
Database | Constructor

Methods

Name | Description
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetAvailableOptions | Returns a list of available options.
GetConnectionPropertiesFromFile | Reads connection properties from a file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads the database from disk.
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RetrieveCaseInformationFromLiveDatabase | This static method returns true if the database in question is using a case sensitive collation.
SaveToDisk | Saves the database to disk.
SaveToFolder | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Cancel | Indicates whether the database registration has been canceled.
CaseSensitive | Indicates whether the database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DateScripted | The date the database object was created.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EncryptionAlgorithm | The transparent database encryption algorithm set for the database.
EncryptionEnabled | Whether database encryption is enabled for this database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextEnabled | True if the database has full text enabled.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the database is running in a compatibility mode.
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
Status | Used to provide status events.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

Database Class


Database Constructor

[image]

SQL Data Compare API 7.1.0
Database Constructor
Database Class See Also

Constructor

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Database()
Visual C++
public:
Database()

See Also

Database Class


Database Methods

[image] [image]

SQL Data Compare API 7.1.0
Database Methods
Database Class See Also

The Database type exposes the following methods.

Methods

Name | Description
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetAvailableOptions | Returns a list of available options.
GetConnectionPropertiesFromFile | Reads connection properties from a file.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads the database from disk.
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
RetrieveCaseInformationFromLiveDatabase | This static method returns true if the database in question is using a case sensitive collation.
SaveToDisk | Saves the database to disk.
SaveToFolder | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Database Class


CompareWith Method

[image] [image]

SQL Data Compare API 7.1.0
Database..::.CompareWith Method
Database Class See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the database with another database.
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the database with another database.

See Also

Database Class
Database Members


CompareWith Method (Database, Options)

[image]

SQL Data Compare API 7.1.0
Database..::.CompareWith Method (Database, Options)
Database Class Example See Also

Compares the database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetDatabase As Database, _
    options As Options _
) As Differences
C#
public Differences CompareWith(
    Database targetDatabase,
    Options options
)
Visual C++
public:
Differences^ CompareWith(
    Database^ targetDatabase,
    Options options
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

A Differences collection containing the differences between the two databases.

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

Examples

This example shows how you compare two databases and print out a summary of the differences.
C# Copy Code
            Database db1=new Database();
            Database db2=new Database();

            db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);
            db2.Register(new ConnectionProperties(".", "WidgetProduction"), Options.Default);

            Differences differences=db1.CompareWith(db2, Options.Default);

            foreach (Difference difference in differences)
            {
                Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name);
            }

            //dispose of the objects
            db1.Dispose();
            db2.Dispose();
Visual Basic Copy Code
            Dim db1 As New Database()
            Dim db2 As New Database()

            db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
            db2.Register(New ConnectionProperties(".", "WidgetProduction"), Options.Default)

            Dim differences As Differences = db1.CompareWith(db2, Options.Default)

            Dim difference As Difference

            For Each difference In differences
                Console.WriteLine("{0} {1} {2}", difference.Type.ToString(), difference.DatabaseObjectType.ToString(), difference.Name)
            Next

            'dispose of the objects
            db1.Dispose()
            db2.Dispose()

See Also

Database Class
CompareWith Overload


CompareWith Method (Database, Options, SqlCompareOwnerMappings)

[image]

SQL Data Compare API 7.1.0
Database..::.CompareWith Method (Database, Options, SqlCompareOwnerMappings)
Database Class See Also

Compares the database with another database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareWith ( _
    targetDatabase As Database, _
    options As Options, _
    mappings As SqlCompareOwnerMappings _
) As Differences
C#
public Differences CompareWith(
    Database targetDatabase,
    Options options,
    SqlCompareOwnerMappings mappings
)
Visual C++
public:
Differences^ CompareWith(
    Database^ targetDatabase,
    Options options,
    SqlCompareOwnerMappings^ mappings
)

Parameters

targetDatabase
Type: RedGate.SQLCompare.Engine..::.Database
The database to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.
mappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
Owner mappings.

Return Value

A Differences collection containing the differences between the two databases.

Remarks

When two databases have been compared they can be synchronized using the Work class. Note that all objects that differ are selected for synchronization by default.

Progress feedback is provided via the Status event.

See Also

Database Class
CompareWith Overload


CreateEmptyTarget Method

[image]

SQL Data Compare API 7.1.0
Database..::.CreateEmptyTarget Method
Database Class See Also

For internal use only

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateEmptyTarget As Database
C#
public Database CreateEmptyTarget()
Visual C++
public:
Database^ CreateEmptyTarget()

Return Value

See Also

Database Class


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
Database..::.Dispose Method
Database Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Disposes of the object. (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Database Class
Database Members


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
Database..::.Dispose Method (Boolean)
Database Class See Also

Disposes of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

Remarks

It is important to dispose of the object to delete any temporary files it uses.

See Also

Database Class
Dispose Overload


GetAvailableOptions Method

[image]

SQL Data Compare API 7.1.0
Database..::.GetAvailableOptions Method
Database Class See Also

Returns a list of available options.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableOptions As Options()
C#
public static Options[] GetAvailableOptions()
Visual C++
public:
static array<Options>^ GetAvailableOptions()

Return Value

A list of options.

See Also

Database Class


GetConnectionPropertiesFromFile Method

[image]

SQL Data Compare API 7.1.0
Database..::.GetConnectionPropertiesFromFile Method
Database Class See Also

Reads connection properties from a file.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionPropertiesFromFile ( _
    fileName As String _
) As ConnectionProperties
C#
public static ConnectionProperties GetConnectionPropertiesFromFile(
    string fileName
)
Visual C++
public:
static ConnectionProperties^ GetConnectionPropertiesFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of a .scdb file.

Return Value

Connection properties.

Remarks

Provides a way to retrieve SQL Server name, database name, and other connection information from a .snp file without loading the file.

See Also

Database Class


LoadFromDisk Method

[image]

SQL Data Compare API 7.1.0
Database..::.LoadFromDisk Method
Database Class Example See Also

Loads the database from disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadFromDisk ( _
    fileName As String _
)
C#
public void LoadFromDisk(
    string fileName
)
Visual C++
public:
void LoadFromDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the database snapshot file to load.

Remarks

Progress events are fired via the Status event.

Examples

See SaveToDisk(String) for a code sample.

See Also

Database Class


LoadFromStream Method

[image]

SQL Data Compare API 7.1.0
Database..::.LoadFromStream Method
Database Class See Also

Loads the database from a stream. This is an alternative to the LoadFromDisk method.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadFromStream ( _
    f As Stream _
)
C#
public void LoadFromStream(
    Stream f
)
Visual C++
public:
void LoadFromStream(
    Stream^ f
)

Parameters

f
Type: System.IO..::.Stream
The open stream from which to read the database.

See Also

Database Class


Register Method

[image] [image]

SQL Data Compare API 7.1.0
Database..::.Register Method
Database Class See Also

Overload List

Name | Description
Register(ConnectionProperties, Options) | Registers a database.
Register(String, ReadFromScriptDatabaseInformation, Options) | Registers the database from creation scripts that are stored in the folder specified by the path parameter.

See Also

Database Class
Database Members


Register Method (ConnectionProperties, Options)

[image]

SQL Data Compare API 7.1.0
Database..::.Register Method (ConnectionProperties, Options)
Database Class Example See Also

Registers a database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
public void Register(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
public:
void Register(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties associated with the database.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

Remarks

Connects to a database and retrieves all schema information. The database object can then be saved to disk or used in a comparison. Progress feedback is provided via the Status event.

Examples

This example shows how you register a database from a live server, with feedback.
C# Copy Code
            using System;
            using RedGate.Shared.Utils;
            using RedGate.SQLCompare.Engine;

            namespace ConsoleApplication2
            {
                /// <summary>
                /// Summary description for SQLDataCompareSnippets.
                /// </summary>
                public class Class1
                {

                    public static void Main()
                    {
                        Class1 c1=new Class1();
                        c1.Run();
                    }

                    private void StatusCallback(object sender, StatusEventArgs e)
                    {
                        //fired by the SqlProvider to indicate events

                        if (e.Message!=null)
                        {
                            Console.WriteLine(e.Message);
                        }

                        if (e.Percentage!=-1)
                        {
                            Console.WriteLine("{0}%", e.Percentage);
                        }

                    }

                    private void Run()
                    {
                        Database db=new Database();
                        db.Status+=new StatusEventHandler(StatusCallback);
                        db.Register(new ConnectionProperties(".", "WidgetStaging"),Options.Default);
                        db.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.Shared.Utils
            Imports RedGate.SQLCompare.Engine

            Module Module3

                Sub Main()

                    Dim c As Class1 = New Class1()

                    c.Run()
                    Console.WriteLine("Press [Enter]")
                    Console.ReadLine()

                End Sub

                Public Class Class1

                    Sub StatusCallback(ByVal sender As Object, ByVal e As StatusEventArgs)

                        If Not (e.Message Is Nothing) Then
                            Console.WriteLine(e.Message)
                        End If

                        If e.Percentage <> -1 Then
                            Console.WriteLine("{0}%", e.Percentage)
                        End If

                    End Sub

                    Sub Run()

                        Dim db As New Database()
                        db.Status = New StatusEventHandler(AddressOf Me.StatusCallback)
                        db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
                        db.Dispose()
                    End Sub

                End Class
            End Module

See Also

Database Class
Register Overload


Register Method (String, ReadFromScriptDatabaseInformation, Options)

[image]

SQL Data Compare API 7.1.0
Database..::.Register Method (String, ReadFromScriptDatabaseInformation, Options)
Database Class See Also

Registers the database from creation scripts that are stored in the folder specified by the path parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    path As String, _
    dbinfo As ReadFromScriptDatabaseInformation, _
    options As Options _
)
C#
public void Register(
    string path,
    ReadFromScriptDatabaseInformation dbinfo,
    Options options
)
Visual C++
public:
void Register(
    String^ path,
    ReadFromScriptDatabaseInformation^ dbinfo,
    Options options
)

Parameters

path
Type: System..::.String
The path to the folder that contains the creations scripts.
dbinfo
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation
This is an optional parameter. If the specified folder contains the SQL Compare generated xml file with the necessary database information, it does not need to be specified. However, if the folder does not contain this information, or this information needs to be overriden, then this parameter must be set.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

See Also

Database Class
Register Overload


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 7.1.0
Database..::.RegisterForDataCompare Method
Database Class See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a database for SQL Data Compare.
RegisterForDataCompare(ConnectionProperties, Options) | Registers a database for SQL Data Compare.

See Also

Database Class
Database Members


RegisterForDataCompare Method (ConnectionProperties)

[image]

SQL Data Compare API 7.1.0
Database..::.RegisterForDataCompare Method (ConnectionProperties)
Database Class See Also

Registers a database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties _
)
C#
public void RegisterForDataCompare(
    ConnectionProperties connectionProperties
)
Visual C++
public:
void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the database connection.

See Also

Database Class
RegisterForDataCompare Overload


RegisterForDataCompare Method (ConnectionProperties, Options)

[image]

SQL Data Compare API 7.1.0
Database..::.RegisterForDataCompare Method (ConnectionProperties, Options)
Database Class See Also

Registers a database for SQL Data Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterForDataCompare ( _
    connectionProperties As ConnectionProperties, _
    options As Options _
)
C#
public void RegisterForDataCompare(
    ConnectionProperties connectionProperties,
    Options options
)
Visual C++
public:
void RegisterForDataCompare(
    ConnectionProperties^ connectionProperties,
    Options options
)

Parameters

connectionProperties
Type: RedGate.SQLCompare.Engine..::.ConnectionProperties
The connection properties to use for the database connection.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options.

See Also

Database Class
RegisterForDataCompare Overload


RetrieveCaseInformationFromLiveDatabase Method

[image]

SQL Data Compare API 7.1.0
Database..::.RetrieveCaseInformationFromLiveDatabase Method
Database Class See Also

This static method returns true if the database in question is using a case sensitive collation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RetrieveCaseInformationFromLiveDatabase ( _
    connection As SqlConnection _
) As Boolean
C#
public static bool RetrieveCaseInformationFromLiveDatabase(
    SqlConnection connection
)
Visual C++
public:
static bool RetrieveCaseInformationFromLiveDatabase(
    SqlConnection^ connection
)

Parameters

connection
Type: System.Data.SqlClient..::.SqlConnection
A connection to the database to be checked. If the connection that is provided is closed, it will be opened again, then closed.

Return Value

True if the database collation is case sensitive.

See Also

Database Class


SaveToDisk Method

[image]

SQL Data Compare API 7.1.0
Database..::.SaveToDisk Method
Database Class Example See Also

Saves the database to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToDisk ( _
    fileName As String _
)
C#
public void SaveToDisk(
    string fileName
)
Visual C++
public:
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The name of the snapshot file to be created.

Examples

The example shows how you save and load a snapshot.
C# Copy Code
            //register a database using integrated security
            Database db1=new Database();
            db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            //save the database to disk
            db1.SaveToDisk(@"c:\WidgetStaging.snp");

            Database db2=new Database();
            db2.LoadFromDisk(@"c:\WidgetStaging.snp");

            //dispose of the objects
            db1.Dispose();
            db2.Dispose();
Visual Basic Copy Code
            'register a database using integrated security
            Dim db1 As New Database()
            db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            'save the database to disk
            db1.SaveToDisk("c:\WidgetStaging.snp")

            Dim db2 As New Database()
            db2.LoadFromDisk("c:\WidgetStaging.snp")

            'dispose of the objects
            db1.Dispose()
            db2.Dispose()

See Also

Database Class


SaveToFolder Method

[image] [image]

SQL Data Compare API 7.1.0
Database..::.SaveToFolder Method
Database Class See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the database as a set of creation scripts to the specified folder.
SaveToFolder(String, WriteToFileOptions) | Saves the database as a set of creation scripts to the specified folder.

See Also

Database Class
Database Members


SaveToFolder Method (String)

[image]

SQL Data Compare API 7.1.0
Database..::.SaveToFolder Method (String)
Database Class See Also

Saves the database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use the SaveToFolder(string folderName, WriteToFileOptions wtf) method!",  _
    True)> _
Public Sub SaveToFolder ( _
    folderName As String _
)
C#
[ObsoleteAttribute("Please use the SaveToFolder(string folderName, WriteToFileOptions wtf) method!",
    true)]
public void SaveToFolder(
    string folderName
)
Visual C++
[ObsoleteAttribute(L"Please use the SaveToFolder(string folderName, WriteToFileOptions wtf) method!",
    true)]
public:
void SaveToFolder(
    String^ folderName
)

Parameters

folderName
Type: System..::.String

See Also

Database Class
SaveToFolder Overload


SaveToFolder Method (String, WriteToFileOptions)

[image]

SQL Data Compare API 7.1.0
Database..::.SaveToFolder Method (String, WriteToFileOptions)
Database Class See Also

Saves the database as a set of creation scripts to the specified folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToFolder ( _
    folderName As String, _
    wtf As WriteToFileOptions _
)
C#
public void SaveToFolder(
    string folderName,
    WriteToFileOptions wtf
)
Visual C++
public:
void SaveToFolder(
    String^ folderName,
    WriteToFileOptions^ wtf
)

Parameters

folderName
Type: System..::.String
wtf
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.WriteToFileOptions
Options to control how the script files are written to the folder.

See Also

Database Class
SaveToFolder Overload


Database Properties

[image] [image]

SQL Data Compare API 7.1.0
Database Properties
Database Class See Also

The Database type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.
Cancel | Indicates whether the database registration has been canceled.
CaseSensitive | Indicates whether the database has been set up as case sensitive.
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005.
Collation | The collation of the database.
ConnectionProperties | The connection properties for the database.
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005.
DateScripted | The date the database object was created.
DdlTriggers | The DDL triggers in the database.
Defaults | The defaults in the database.
EncryptionAlgorithm | The transparent database encryption algorithm set for the database.
EncryptionEnabled | Whether database encryption is enabled for this database.
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.
ExtendedProperties | Database-level extended properties.
FullTextCatalogs | The full-text catalogs in the database.
FullTextEnabled | True if the database has full text enabled.
FullTextStoplists | The full-text stoplists in the database.
Functions | The user-defined functions in the database.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database.
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005.
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005.
Roles | The roles in the database.
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005.
Rules | The rules in the database.
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005.
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the database is running in a compatibility mode.
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.
Services | The services in the database. Note that services were introduced in SQL Server 2005.
Status | Used to provide status events.
StoredProcedures | The stored procedures in the database.
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.
Tables | The tables in the database.
UserDefinedTypes | The user-defined types in the database.
Users | The users in the database.
Views | The views in the database.
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

See Also

Database Class


Assemblies Property

[image]

SQL Data Compare API 7.1.0
Database..::.Assemblies Property
Database Class See Also

The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assemblies As ClrAssemblies
C#
public ClrAssemblies Assemblies { get; }
Visual C++
public:
property ClrAssemblies^ Assemblies {
    ClrAssemblies^ get ();
}

See Also

Database Class


AsymmetricKeys Property

[image]

SQL Data Compare API 7.1.0
Database..::.AsymmetricKeys Property
Database Class See Also

The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AsymmetricKeys As AsymmetricKeys
C#
public AsymmetricKeys AsymmetricKeys { get; }
Visual C++
public:
property AsymmetricKeys^ AsymmetricKeys {
    AsymmetricKeys^ get ();
}

See Also

Database Class


Cancel Property

[image]

SQL Data Compare API 7.1.0
Database..::.Cancel Property
Database Class See Also

Indicates whether the database registration has been canceled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cancel As Boolean
C#
public bool Cancel { get; }
Visual C++
public:
property bool Cancel {
    bool get ();
}

See Also

Database Class


CaseSensitive Property

[image]

SQL Data Compare API 7.1.0
Database..::.CaseSensitive Property
Database Class See Also

Indicates whether the database has been set up as case sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; internal set; }
Visual C++
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

Database Class


Certificates Property

[image]

SQL Data Compare API 7.1.0
Database..::.Certificates Property
Database Class See Also

The certificates in the database. Note that certificates were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Certificates As Certificates
C#
public Certificates Certificates { get; }
Visual C++
public:
property Certificates^ Certificates {
    Certificates^ get ();
}

See Also

Database Class


Collation Property

[image]

SQL Data Compare API 7.1.0
Database..::.Collation Property
Database Class See Also

The collation of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; internal set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

Database Class


ConnectionProperties Property

[image]

SQL Data Compare API 7.1.0
Database..::.ConnectionProperties Property
Database Class See Also

The connection properties for the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ConnectionProperties { get; set; }
Visual C++
public:
property ConnectionProperties^ ConnectionProperties {
    ConnectionProperties^ get ();
    void set (ConnectionProperties^ value);
}

See Also

Database Class


Contracts Property

[image]

SQL Data Compare API 7.1.0
Database..::.Contracts Property
Database Class See Also

The contracts in the database. Note that contracts were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contracts As Contracts
C#
public Contracts Contracts { get; }
Visual C++
public:
property Contracts^ Contracts {
    Contracts^ get ();
}

See Also

Database Class


DateScripted Property

[image]

SQL Data Compare API 7.1.0
Database..::.DateScripted Property
Database Class See Also

The date the database object was created.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DateScripted As DateTime
C#
public DateTime DateScripted { get; internal set; }
Visual C++
public:
property DateTime DateScripted {
    DateTime get ();
    void set (DateTime value);
}

See Also

Database Class


DdlTriggers Property

[image]

SQL Data Compare API 7.1.0
Database..::.DdlTriggers Property
Database Class See Also

The DDL triggers in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DdlTriggers As DdlTriggers
C#
public DdlTriggers DdlTriggers { get; }
Visual C++
public:
property DdlTriggers^ DdlTriggers {
    DdlTriggers^ get ();
}

See Also

Database Class


Defaults Property

[image]

SQL Data Compare API 7.1.0
Database..::.Defaults Property
Database Class See Also

The defaults in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Defaults As Defaults
C#
public Defaults Defaults { get; }
Visual C++
public:
property Defaults^ Defaults {
    Defaults^ get ();
}

See Also

Database Class


EncryptionAlgorithm Property

[image]

SQL Data Compare API 7.1.0
Database..::.EncryptionAlgorithm Property
Database Class See Also

The transparent database encryption algorithm set for the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptionAlgorithm As DatabaseEncryption
C#
public DatabaseEncryption EncryptionAlgorithm { get; internal set; }
Visual C++
public:
property DatabaseEncryption EncryptionAlgorithm {
    DatabaseEncryption get ();
    void set (DatabaseEncryption value);
}

See Also

Database Class


EncryptionEnabled Property

[image]

SQL Data Compare API 7.1.0
Database..::.EncryptionEnabled Property
Database Class See Also

Whether database encryption is enabled for this database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptionEnabled As Boolean
C#
public bool EncryptionEnabled { get; internal set; }
Visual C++
public:
property bool EncryptionEnabled {
    bool get ();
    void set (bool value);
}

See Also

Database Class


EventNotifications Property

[image]

SQL Data Compare API 7.1.0
Database..::.EventNotifications Property
Database Class See Also

The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

Database Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Database..::.ExtendedProperties Property
Database Class See Also

Database-level extended properties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; internal set; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
    void set (ExtendedProperties^ value);
}

Remarks

The collection contains extended properties that have been defined at the database level. Individual database objects (such as tables and users) can also have extended properties defined on them.

See Also

Database Class


FullTextCatalogs Property

[image]

SQL Data Compare API 7.1.0
Database..::.FullTextCatalogs Property
Database Class See Also

The full-text catalogs in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextCatalogs As FullTextCatalogs
C#
public FullTextCatalogs FullTextCatalogs { get; }
Visual C++
public:
property FullTextCatalogs^ FullTextCatalogs {
    FullTextCatalogs^ get ();
}

See Also

Database Class


FullTextEnabled Property

[image]

SQL Data Compare API 7.1.0
Database..::.FullTextEnabled Property
Database Class See Also

True if the database has full text enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextEnabled As Boolean
C#
public bool FullTextEnabled { get; internal set; }
Visual C++
public:
property bool FullTextEnabled {
    bool get ();
    void set (bool value);
}

See Also

Database Class


FullTextStoplists Property

[image]

SQL Data Compare API 7.1.0
Database..::.FullTextStoplists Property
Database Class See Also

The full-text stoplists in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextStoplists As FullTextStoplists
C#
public FullTextStoplists FullTextStoplists { get; }
Visual C++
public:
property FullTextStoplists^ FullTextStoplists {
    FullTextStoplists^ get ();
}

See Also

Database Class


Functions Property

[image]

SQL Data Compare API 7.1.0
Database..::.Functions Property
Database Class See Also

The user-defined functions in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Functions As Functions
C#
public Functions Functions { get; }
Visual C++
public:
property Functions^ Functions {
    Functions^ get ();
}

See Also

Database Class


MajorVersion Property

[image]

SQL Data Compare API 7.1.0
Database..::.MajorVersion Property
Database Class See Also

The major version of the SQL Server for the database. This reflects the compatibility mode of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MajorVersion As SQLVersion
C#
public SQLVersion MajorVersion { get; internal set; }
Visual C++
public:
property SQLVersion MajorVersion {
    SQLVersion get ();
    void set (SQLVersion value);
}

See Also

Database Class


MessageTypes Property

[image]

SQL Data Compare API 7.1.0
Database..::.MessageTypes Property
Database Class See Also

The message types in the database. Note that message types were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageTypes As MessageTypes
C#
public MessageTypes MessageTypes { get; }
Visual C++
public:
property MessageTypes^ MessageTypes {
    MessageTypes^ get ();
}

See Also

Database Class


PartitionFunctions Property

[image]

SQL Data Compare API 7.1.0
Database..::.PartitionFunctions Property
Database Class See Also

The partition functions in the database. Note that partition functions were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PartitionFunctions As PartitionFunctions
C#
public PartitionFunctions PartitionFunctions { get; }
Visual C++
public:
property PartitionFunctions^ PartitionFunctions {
    PartitionFunctions^ get ();
}

See Also

Database Class


PartitionSchemes Property

[image]

SQL Data Compare API 7.1.0
Database..::.PartitionSchemes Property
Database Class See Also

The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PartitionSchemes As PartitionSchemes
C#
public PartitionSchemes PartitionSchemes { get; }
Visual C++
public:
property PartitionSchemes^ PartitionSchemes {
    PartitionSchemes^ get ();
}

See Also

Database Class


Queues Property

[image]

SQL Data Compare API 7.1.0
Database..::.Queues Property
Database Class See Also

The queues in the database. Note that queues were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queues As Queues
C#
public Queues Queues { get; }
Visual C++
public:
property Queues^ Queues {
    Queues^ get ();
}

See Also

Database Class


Roles Property

[image]

SQL Data Compare API 7.1.0
Database..::.Roles Property
Database Class See Also

The roles in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Roles As Roles
C#
public Roles Roles { get; }
Visual C++
public:
property Roles^ Roles {
    Roles^ get ();
}

See Also

Database Class


Routes Property

[image]

SQL Data Compare API 7.1.0
Database..::.Routes Property
Database Class See Also

The routes in the database. Note that routes were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Routes As Routes
C#
public Routes Routes { get; }
Visual C++
public:
property Routes^ Routes {
    Routes^ get ();
}

See Also

Database Class


Rules Property

[image]

SQL Data Compare API 7.1.0
Database..::.Rules Property
Database Class See Also

The rules in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rules As Rules
C#
public Rules Rules { get; }
Visual C++
public:
property Rules^ Rules {
    Rules^ get ();
}

See Also

Database Class


Schemas Property

[image]

SQL Data Compare API 7.1.0
Database..::.Schemas Property
Database Class See Also

The schemas in the database. Note that schemas were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schemas As Schemas
C#
public Schemas Schemas { get; }
Visual C++
public:
property Schemas^ Schemas {
    Schemas^ get ();
}

See Also

Database Class


ServerMajorVersion Property

[image]

SQL Data Compare API 7.1.0
Database..::.ServerMajorVersion Property
Database Class See Also

The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the database is running in a compatibility mode.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerMajorVersion As SQLVersion
C#
public SQLVersion ServerMajorVersion { get; internal set; }
Visual C++
public:
property SQLVersion ServerMajorVersion {
    SQLVersion get ();
    void set (SQLVersion value);
}

See Also

Database Class


ServiceBindings Property

[image]

SQL Data Compare API 7.1.0
Database..::.ServiceBindings Property
Database Class See Also

The service bindings in the database. Note that service bindings were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServiceBindings As ServiceBindings
C#
public ServiceBindings ServiceBindings { get; }
Visual C++
public:
property ServiceBindings^ ServiceBindings {
    ServiceBindings^ get ();
}

See Also

Database Class


Services Property

[image]

SQL Data Compare API 7.1.0
Database..::.Services Property
Database Class See Also

The services in the database. Note that services were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As Services
C#
public Services Services { get; }
Visual C++
public:
property Services^ Services {
    Services^ get ();
}

See Also

Database Class


Status Property

[image]

SQL Data Compare API 7.1.0
Database..::.Status Property
Database Class See Also

Used to provide status events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Database Class


StoredProcedures Property

[image]

SQL Data Compare API 7.1.0
Database..::.StoredProcedures Property
Database Class See Also

The stored procedures in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StoredProcedures As StoredProcedures
C#
public StoredProcedures StoredProcedures { get; }
Visual C++
public:
property StoredProcedures^ StoredProcedures {
    StoredProcedures^ get ();
}

See Also

Database Class


SymmetricKeys Property

[image]

SQL Data Compare API 7.1.0
Database..::.SymmetricKeys Property
Database Class See Also

The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SymmetricKeys As SymmetricKeys
C#
public SymmetricKeys SymmetricKeys { get; }
Visual C++
public:
property SymmetricKeys^ SymmetricKeys {
    SymmetricKeys^ get ();
}

See Also

Database Class


Synonyms Property

[image]

SQL Data Compare API 7.1.0
Database..::.Synonyms Property
Database Class See Also

The synonyms in the database. Note that synonyms were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Synonyms As Synonyms
C#
public Synonyms Synonyms { get; }
Visual C++
public:
property Synonyms^ Synonyms {
    Synonyms^ get ();
}

See Also

Database Class


Tables Property

[image]

SQL Data Compare API 7.1.0
Database..::.Tables Property
Database Class See Also

The tables in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As Tables
C#
public Tables Tables { get; }
Visual C++
public:
property Tables^ Tables {
    Tables^ get ();
}

See Also

Database Class


UserDefinedTypes Property

[image]

SQL Data Compare API 7.1.0
Database..::.UserDefinedTypes Property
Database Class See Also

The user-defined types in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserDefinedTypes As UserDefinedTypes
C#
public UserDefinedTypes UserDefinedTypes { get; }
Visual C++
public:
property UserDefinedTypes^ UserDefinedTypes {
    UserDefinedTypes^ get ();
}

See Also

Database Class


Users Property

[image]

SQL Data Compare API 7.1.0
Database..::.Users Property
Database Class See Also

The users in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Users As Users
C#
public Users Users { get; }
Visual C++
public:
property Users^ Users {
    Users^ get ();
}

See Also

Database Class


Views Property

[image]

SQL Data Compare API 7.1.0
Database..::.Views Property
Database Class See Also

The views in the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Views As Views
C#
public Views Views { get; }
Visual C++
public:
property Views^ Views {
    Views^ get ();
}

See Also

Database Class


XmlSchemaCollections Property

[image]

SQL Data Compare API 7.1.0
Database..::.XmlSchemaCollections Property
Database Class See Also

The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlSchemaCollections As XmlSchemaCollections
C#
public XmlSchemaCollections XmlSchemaCollections { get; }
Visual C++
public:
property XmlSchemaCollections^ XmlSchemaCollections {
    XmlSchemaCollections^ get ();
}

See Also

Database Class


Database.EventLogFullException Class

[image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Class
Database Class Members See Also

This exception is used when debugging is enabled and the event log is full.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventLogFullException _
    Inherits ApplicationException
C#
public sealed class EventLogFullException : ApplicationException
Visual C++
public ref class EventLogFullException sealed : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
RedGate.SQLCompare.Engine..::.Database..::.EventLogFullException

See Also

Database..::.EventLogFullException Members


Database.EventLogFullException Members

[image] [image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Members
Database..::.EventLogFullException Class Constructors Methods Properties See Also

A SQL Server database.

The Database..::.EventLogFullException type exposes the following members.

Constructors

Name | Description
Database..::.EventLogFullException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Database..::.EventLogFullException Class


Database.EventLogFullException Constructor

[image] [image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Constructor
Database..::.EventLogFullException Class See Also

Overload List

Name | Description
Database..::.EventLogFullException()()() | Constructs an event log full exception.
Database..::.EventLogFullException(String) | Constructs an event log full exception.
Database..::.EventLogFullException(String, Exception) | Constructs an event log full exception.

See Also

Database..::.EventLogFullException Class
Database..::.EventLogFullException Members


Database.EventLogFullException Constructor

[image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Constructor
Database..::.EventLogFullException Class See Also

Constructs an event log full exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EventLogFullException()
Visual C++
public:
EventLogFullException()

See Also

Database..::.EventLogFullException Class
Database..::.EventLogFullException Overload


Database.EventLogFullException Constructor (String)

[image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Constructor (String)
Database..::.EventLogFullException Class See Also

Constructs an event log full exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public EventLogFullException(
    string message
)
Visual C++
public:
EventLogFullException(
    String^ message
)

Parameters

message
Type: System..::.String
The message for the exception.

See Also

Database..::.EventLogFullException Class
Database..::.EventLogFullException Overload


Database.EventLogFullException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
Database..::.EventLogFullException Constructor (String, Exception)
Database..::.EventLogFullException Class See Also

Constructs an event log full exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public EventLogFullException(
    string message,
    Exception inner
)
Visual C++
public:
EventLogFullException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The message for the exception.
inner
Type: System..::.Exception
The inner exception.

See Also

Database..::.EventLogFullException Class
Database..::.EventLogFullException Overload


DatabaseEncryption Enumeration

[image]

SQL Data Compare API 7.1.0
DatabaseEncryption Enumeration
See Also

The type of encryption applied to the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DatabaseEncryption
C#
public enum DatabaseEncryption
Visual C++
public enum class DatabaseEncryption

Members

Member name | Description
None | No encryption.
AES128 | AES 128-bit encryption.
AES192 | AES 192-bit encryption.
AES256 | AES 256-bit encryption.
TripleDes | Triple DES 192-bit encryption.

See Also


DatabaseLevelPermission Class

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission Class
Members See Also

A database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseLevelPermission
C#
public sealed class DatabaseLevelPermission
Visual C++
public ref class DatabaseLevelPermission sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.DatabaseLevelPermission

See Also

DatabaseLevelPermission Members


DatabaseLevelPermission Members

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission Members
DatabaseLevelPermission Class Methods Properties See Also

The DatabaseLevelPermission type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPermissionActionName | Returns the SQL text name for a database-level permission.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | The action to which the permission applies.
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

DatabaseLevelPermission Class


DatabaseLevelPermission Methods

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission Methods
DatabaseLevelPermission Class See Also

The DatabaseLevelPermission type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPermissionActionName | Returns the SQL text name for a database-level permission.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLevelPermission Class


GetPermissionActionName Method

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission..::.GetPermissionActionName Method
DatabaseLevelPermission Class See Also

Returns the SQL text name for a database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPermissionActionName ( _
    pa As DatabaseLevelPermissionAction _
) As String
C#
public static string GetPermissionActionName(
    DatabaseLevelPermissionAction pa
)
Visual C++
public:
static String^ GetPermissionActionName(
    DatabaseLevelPermissionAction pa
)

Parameters

pa
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissionAction
The permission action for which the SQL name is requested.

Return Value

The SQL text name for a database-level permission.

See Also

DatabaseLevelPermission Class


DatabaseLevelPermission Properties

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission Properties
DatabaseLevelPermission Class See Also

The DatabaseLevelPermission type exposes the following properties.

Properties

Name | Description
Action | The action to which the permission applies.
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

DatabaseLevelPermission Class


Action Property

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission..::.Action Property
DatabaseLevelPermission Class See Also

The action to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As DatabaseLevelPermissionAction
C#
public DatabaseLevelPermissionAction Action { get; }
Visual C++
public:
property DatabaseLevelPermissionAction Action {
    DatabaseLevelPermissionAction get ();
}

See Also

DatabaseLevelPermission Class


Type Property

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission..::.Type Property
DatabaseLevelPermission Class See Also

The type of permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PermissionType
C#
public PermissionType Type { get; }
Visual C++
public:
property PermissionType Type {
    PermissionType get ();
}

See Also

DatabaseLevelPermission Class


UserName Property

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermission..::.UserName Property
DatabaseLevelPermission Class See Also

The user or role to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserName As String
C#
public string UserName { get; }
Visual C++
public:
property String^ UserName {
    String^ get ();
}

See Also

DatabaseLevelPermission Class


DatabaseLevelPermissionAction Enumeration

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissionAction Enumeration
See Also

The database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DatabaseLevelPermissionAction
C#
public enum DatabaseLevelPermissionAction
Visual C++
public enum class DatabaseLevelPermissionAction

Members

Member name | Description
None | None, this is for internal use only.
Alter | Alter (AL )
AlterAnyAsymmetricKey | Alter Any Asymmetric Key (ALAK)
AlterAnyApplicationRole | Alter Any Application Role (ALAR)
AlterAnyAssembly | Alter Any Assembly (ALAS)
AlterAnyCertificate | Alter Any Certificate (ALCF)
AlterAnyDataspace | Alter Any Data Space (ALDS)
AlterAnyDatabaseEventNotification | Alter Any Database Event Notification (ALED)
AlterAnyFulltextCatalog | Alter Any Full Text Catalog (ALFT)
AlterAnyMessageType | Alter Any Message Type (ALMT)
AlterAnyRole | Alter Any Role (ALRL)
AlterAnyRoute | Alter Any Route (ALRT)
AlterAnyRemoteServiceBinding | Alter Any Remote Service Binding (ALSB)
AlterAnyContract | Alter Any Contract (ALSC)
AlterAnySymmetricKey | Alter Any Symmetric Key (ALSK)
AlterAnySchema | Alter Any Schema (ALSM)
AlterAnyService | Alter Any Service (ALSV)
AlterAnyDatabaseDdlTrigger | Alter Any Database DDL Trigger (ALTG)
AlterAnyUser | Alter Any User (ALUS)
Authenticate | Authenticate (AUTH)
BackupDatabase | Back Up Database (BADB)
BackupLog | Back Up Log (BALO)
Control | Control (CL )
Connect | Connect (CO )
ConnectReplication | Connect Replication (CORP)
Checkpoint | Checkpoint (CP )
CreateAggregate | Create Aggregate (CRAG)
CreateAsymmetricKey | Create Asymmetric Key (CRAK)
CreateAssembly | Create Assembly (CRAS)
CreateCertificate | Create Certificate (CRCF)
CreateDatabase | Create Database (CRDB)
CreateDefault | Create Default (CRDF)
CreateDatabaseDdlEventNotification | Create Database DDL Event Notification (CRED)
CreateFunction | Create Function (CRFN)
CreateFulltextCatalog | Create Full Text Catalog (CRFT)
CreateMessageType | Create Message Type (CRMT)
CreateProcedure | Create Procedure (CRPR)
CreateQueue | Create Queue (CRQU)
CreateRole | Create Role (CRRL)
CreateRoute | Create Route (CRRT)
CreateRule | Create Rule (CRRU)
CreateRemoteServiceBinding | Create Remote Service Binding (CRSB)
CreateContract | Create Contract (CRSC)
CreateSymmetricKey | Create Symmetric Key (CRSK)
CreateSchema | Create Schema (CRSM)
CreateSynonym | Create Synonym (CRSN)
CreateService | Create Service (CRSV)
CreateTable | Create Table (CRTB)
CreateType | Create Type (CRTY)
CreateView | Create View (CRVW)
CreateXmlSchemaCollection | Create XML Schema Collection (CRXS)
Delete | Delete (DL)
Execute | Execute (EX)
Impersonate | Impersonate (IM)
Insert | Insert (IN )
Receive | Receive (RC)
References | References (RF)
Select | Select (SL)
Send | Send (SN)
Showplan | Showplan (SPLN)
SubscribeQueryNotifications | Subscribe Query Notifications (SUQN)
TakeOwnership | Take Ownership (TO )
Update | Update (UP)
ViewDefinition | View Definition (VW)
ViewDatabaseState | View Database State (VWDS)

See Also


DatabaseLevelPermissions Class

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions Class
Members See Also

A collection of database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DatabaseLevelPermissions
C#
public sealed class DatabaseLevelPermissions
Visual C++
public ref class DatabaseLevelPermissions sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.DatabaseLevelPermissions

See Also

DatabaseLevelPermissions Members


DatabaseLevelPermissions Members

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions Members
DatabaseLevelPermissions Class Methods Properties See Also

The DatabaseLevelPermissions type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | The permission type for a specific permission action.

See Also

DatabaseLevelPermissions Class


DatabaseLevelPermissions Methods

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions Methods
DatabaseLevelPermissions Class See Also

The DatabaseLevelPermissions type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatabaseLevelPermissions Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions..::.Equals Method
DatabaseLevelPermissions Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(DatabaseLevelPermissions, Options) | Compares the database-level permission with a specified database-level permission.

See Also

DatabaseLevelPermissions Class
DatabaseLevelPermissions Members


Equals Method (DatabaseLevelPermissions, Options)

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions..::.Equals Method (DatabaseLevelPermissions, Options)
DatabaseLevelPermissions Class See Also

Compares the database-level permission with a specified database-level permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetPermissions As DatabaseLevelPermissions, _
    options As Options _
) As Boolean
C#
public bool Equals(
    DatabaseLevelPermissions targetPermissions,
    Options options
)
Visual C++
public:
bool Equals(
    DatabaseLevelPermissions^ targetPermissions,
    Options options
)

Parameters

targetPermissions
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissions
The database-level permissions to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the database-level permisssions are identical; otherwise, false.

See Also

DatabaseLevelPermissions Class
Equals Overload


DatabaseLevelPermissions Properties

[image] [image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions Properties
DatabaseLevelPermissions Class See Also

The DatabaseLevelPermissions type exposes the following properties.

Properties

Name | Description
Item | The permission type for a specific permission action.

See Also

DatabaseLevelPermissions Class


Item Property

[image]

SQL Data Compare API 7.1.0
DatabaseLevelPermissions..::.Item Property
DatabaseLevelPermissions Class See Also

The permission type for a specific permission action.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item ( _
    permission As DatabaseLevelPermissionAction _
) As PermissionType
C#
public PermissionType this[
    DatabaseLevelPermissionAction permission
] { get; set; }
Visual C++
public:
property PermissionType default[DatabaseLevelPermissionAction permission] {
    PermissionType get (DatabaseLevelPermissionAction permission);
    void set (DatabaseLevelPermissionAction permission, PermissionType value);
}

Parameters

permission
Type: RedGate.SQLCompare.Engine..::.DatabaseLevelPermissionAction
The permission type.

See Also

DatabaseLevelPermissions Class


DatabaseObjectWithAuthorization Class

[image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization Class
Members See Also

A database object that can have its owner altered using ALTER AUTHORIZATION.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DatabaseObjectWithAuthorization _
    Inherits ScriptableDatabaseObject _
    Implements IHasAuthorization, IDatabaseObject
C#
public abstract class DatabaseObjectWithAuthorization : ScriptableDatabaseObject, IHasAuthorization,
    IDatabaseObject
Visual C++
public ref class DatabaseObjectWithAuthorization abstract : public ScriptableDatabaseObject,
    IHasAuthorization, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.AsymmetricKey
RedGate.SQLCompare.Engine..::.Certificate
RedGate.SQLCompare.Engine..::.ClrAssembly
RedGate.SQLCompare.Engine..::.Contract
RedGate.SQLCompare.Engine..::.FullTextStoplist
RedGate.SQLCompare.Engine..::.FullTextCatalog
RedGate.SQLCompare.Engine..::.MessageType
RedGate.SQLCompare.Engine..::.Role
RedGate.SQLCompare.Engine..::.Route
RedGate.SQLCompare.Engine..::.Schema
RedGate.SQLCompare.Engine..::.Service
RedGate.SQLCompare.Engine..::.ServiceBinding
RedGate.SQLCompare.Engine..::.SymmetricKey

See Also

DatabaseObjectWithAuthorization Members


DatabaseObjectWithAuthorization Members

[image] [image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization Members
DatabaseObjectWithAuthorization Class Constructors Methods Fields Properties See Also

The DatabaseObjectWithAuthorization type exposes the following members.

Constructors

Name | Description
DatabaseObjectWithAuthorization |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement.

See Also

DatabaseObjectWithAuthorization Class


DatabaseObjectWithAuthorization Constructor

[image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization Constructor
DatabaseObjectWithAuthorization Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DatabaseObjectWithAuthorization()
Visual C++
protected:
DatabaseObjectWithAuthorization()

See Also

DatabaseObjectWithAuthorization Class


DatabaseObjectWithAuthorization Properties

[image] [image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization Properties
DatabaseObjectWithAuthorization Class See Also

The DatabaseObjectWithAuthorization type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement.

See Also

DatabaseObjectWithAuthorization Class


ScriptSourceAuthorization Property

[image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization..::.ScriptSourceAuthorization Property
DatabaseObjectWithAuthorization Class See Also

The script source for any ALTER AUTHORIZATION statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceAuthorization As ScriptSource
C#
public ScriptSource ScriptSourceAuthorization { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceAuthorization {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

DatabaseObjectWithAuthorization Class


DataCompression Enumeration

[image]

SQL Data Compare API 7.1.0
DataCompression Enumeration
See Also

Compression used for a table or index record. This has been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataCompression
C#
public enum DataCompression
Visual C++
public enum class DataCompression

Members

Member name | Description
None | No compression
Row | Row compression
Page | Page compression

See Also


DdlTrigger Class

[image]

SQL Data Compare API 7.1.0
DdlTrigger Class
Members See Also

A DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DdlTrigger _
    Inherits ScriptableDatabaseObject _
    Implements IExecuteAs, IDatabaseObject
C#
public sealed class DdlTrigger : ScriptableDatabaseObject, IExecuteAs,
    IDatabaseObject
Visual C++
public ref class DdlTrigger sealed : public ScriptableDatabaseObject,
    IExecuteAs, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DdlTrigger

See Also

DdlTrigger Members


DdlTrigger Members

[image] [image]

SQL Data Compare API 7.1.0
DdlTrigger Members
DdlTrigger Class Methods Fields Properties See Also

The DdlTrigger type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DDL trigger, for a CLR DDL trigger.
AssemblyClass | The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.
AssemblyMethod | The CLR assembly method name for the DDL trigger, for a CLR trigger.
CLRObject | True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the DDL trigger definition is encrypted.
EventTypes | The event types for the DDL trigger.
ExecuteAs | The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties defined for the DDL trigger.
FullyQualifiedName | The fully-qualified name of the DDL trigger. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.DdlTrigger (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the DDL trigger, if it is not a CLR DDL trigger.

See Also

DdlTrigger Class


DdlTrigger Methods

[image] [image]

SQL Data Compare API 7.1.0
DdlTrigger Methods
DdlTrigger Class See Also

The DdlTrigger type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DdlTrigger Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Equals Method
DdlTrigger Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(DdlTrigger, Options) | Compares the DDL trigger with the specified DDL trigger.
Equals(IDatabaseObject, Options) | Compares the DDL trigger with a specified DDL trigger. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

DdlTrigger Class
DdlTrigger Members


Equals Method (DdlTrigger, Options)

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Equals Method (DdlTrigger, Options)
DdlTrigger Class See Also

Compares the DDL trigger with the specified DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As DdlTrigger, _
    options As Options _
) As Boolean
C#
public bool Equals(
    DdlTrigger target,
    Options options
)
Visual C++
public:
bool Equals(
    DdlTrigger^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.DdlTrigger
The DDL trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the DDL triggers are identical; otherwise false.

See Also

DdlTrigger Class
Equals Overload


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Equals Method (IDatabaseObject, Options)
DdlTrigger Class See Also

Compares the DDL trigger with a specified DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    value As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject value,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ value,
    Options options
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The DDL trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the DDL triggers are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

DdlTrigger Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.ScriptObject Method
DdlTrigger Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifiers on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

DdlTrigger Class


DdlTrigger Properties

[image] [image]

SQL Data Compare API 7.1.0
DdlTrigger Properties
DdlTrigger Class See Also

The DdlTrigger type exposes the following properties.

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DDL trigger, for a CLR DDL trigger.
AssemblyClass | The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.
AssemblyMethod | The CLR assembly method name for the DDL trigger, for a CLR trigger.
CLRObject | True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the DDL trigger definition is encrypted.
EventTypes | The event types for the DDL trigger.
ExecuteAs | The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties defined for the DDL trigger.
FullyQualifiedName | The fully-qualified name of the DDL trigger. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.DdlTrigger (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the DDL trigger, if it is not a CLR DDL trigger.

See Also

DdlTrigger Class


After Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.After Property
DdlTrigger Class See Also

True if the trigger is an after trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property After As Boolean
C#
public bool After { get; }
Visual C++
public:
property bool After {
    bool get ();
}

See Also

DdlTrigger Class


AnsiNullsOn Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.AnsiNullsOn Property
DdlTrigger Class See Also

True if the trigger was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

DdlTrigger Class


Assembly Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Assembly Property
DdlTrigger Class See Also

The CLR assembly for the DDL trigger, for a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

DdlTrigger Class


AssemblyClass Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.AssemblyClass Property
DdlTrigger Class See Also

The CLR assembly class name for the DDL trigger, for a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTrigger Class


AssemblyMethod Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.AssemblyMethod Property
DdlTrigger Class See Also

The CLR assembly method name for the DDL trigger, for a CLR trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

DdlTrigger Class


CLRObject Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.CLRObject Property
DdlTrigger Class See Also

True if the DDL trigger is a Common Language Runtime (CLR) DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

DdlTrigger Class


Encrypted Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Encrypted Property
DdlTrigger Class See Also

True if the DDL trigger definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

Remarks

The contents of the trigger cannot be decrypted.

See Also

DdlTrigger Class


EventTypes Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.EventTypes Property
DdlTrigger Class See Also

The event types for the DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventTypes As EventTypes
C#
public EventTypes EventTypes { get; }
Visual C++
public:
property EventTypes^ EventTypes {
    EventTypes^ get ();
}

See Also

DdlTrigger Class


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.ExecuteAs Property
DdlTrigger Class See Also

The user whose security context is to be used for the execution of the DDL trigger. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

DdlTrigger Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.ExtendedProperties Property
DdlTrigger Class See Also

The extended properties defined for the DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

DdlTrigger Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.FullyQualifiedName Property
DdlTrigger Class See Also

The fully-qualified name of the DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName
IDatabaseObject..::.FullyQualifiedName

See Also

DdlTrigger Class


InsteadOf Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.InsteadOf Property
DdlTrigger Class See Also

True if the trigger is an instead of trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InsteadOf As Boolean
C#
public bool InsteadOf { get; internal set; }
Visual C++
public:
property bool InsteadOf {
    bool get ();
    void set (bool value);
}

See Also

DdlTrigger Class


IsDisabled Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.IsDisabled Property
DdlTrigger Class See Also

True if the trigger is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

DdlTrigger Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.ObjectType Property
DdlTrigger Class See Also

Returns ObjectType.DdlTrigger

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

DdlTrigger Class


QuotedIdentifierOn Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.QuotedIdentifierOn Property
DdlTrigger Class See Also

True if the trigger was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

DdlTrigger Class


Text Property

[image]

SQL Data Compare API 7.1.0
DdlTrigger..::.Text Property
DdlTrigger Class See Also

The text of the DDL trigger, if it is not a CLR DDL trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

See Also

DdlTrigger Class


DdlTriggers Class

[image]

SQL Data Compare API 7.1.0
DdlTriggers Class
Members See Also

A collection of DDL triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DdlTriggers _
    Inherits SerializableDatabaseObjectCollection(Of DdlTrigger)
C#
public sealed class DdlTriggers : SerializableDatabaseObjectCollection<DdlTrigger>
Visual C++
public ref class DdlTriggers sealed : public SerializableDatabaseObjectCollection<DdlTrigger^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( DdlTrigger >)>)
RedGate.SQLCompare.Engine..::.DdlTriggers

See Also

DdlTriggers Members


DdlTriggers Members

[image] [image]

SQL Data Compare API 7.1.0
DdlTriggers Members
DdlTriggers Class Methods Properties Explicit Interface Implementations See Also

The DdlTriggers type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DdlTriggers Class


Default Class

[image]

SQL Data Compare API 7.1.0
Default Class
Members See Also

A database default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Default _
    Inherits SchemaObject _
    Implements IDatabaseObject
C#
public sealed class Default : SchemaObject, IDatabaseObject
Visual C++
public ref class Default sealed : public SchemaObject,
    IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Default

See Also

Default Members


Default Members

[image] [image]

SQL Data Compare API 7.1.0
Default Members
Default Class Methods Fields Properties See Also

The Default type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Default (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the default.

See Also

Default Class


Default Methods

[image] [image]

SQL Data Compare API 7.1.0
Default Methods
Default Class See Also

The Default type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

Default Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Default..::.Equals Method
Default Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the default with a specified default. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Default Class
Default Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Default..::.Equals Method (IDatabaseObject, Options)
Default Class See Also

Compares the default with a specified default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the defaults are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Default Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Default..::.ScriptObject Method
Default Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Default Class


Default Properties

[image] [image]

SQL Data Compare API 7.1.0
Default Properties
Default Class See Also

The Default type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Default (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the default.

See Also

Default Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Default..::.ObjectType Property
Default Class See Also

Returns ObjectType.Default

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Default Class


Text Property

[image]

SQL Data Compare API 7.1.0
Default..::.Text Property
Default Class See Also

The text of the default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

See Also

Default Class


Defaults Class

[image]

SQL Data Compare API 7.1.0
Defaults Class
Members See Also

A collection of defaults.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Defaults _
    Inherits SerializableDatabaseObjectCollection(Of Default)
C#
public sealed class Defaults : SerializableDatabaseObjectCollection<Default>
Visual C++
public ref class Defaults sealed : public SerializableDatabaseObjectCollection<Default^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Default >)>)
RedGate.SQLCompare.Engine..::.Defaults

See Also

Defaults Members


Defaults Members

[image] [image]

SQL Data Compare API 7.1.0
Defaults Members
Defaults Class Methods Properties Explicit Interface Implementations See Also

The Defaults type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Defaults Class


Difference Class

[image]

SQL Data Compare API 7.1.0
Difference Class
Members See Also

A difference between two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Difference
C#
public sealed class Difference
Visual C++
public ref class Difference sealed

Remarks

See CompareWith(Database, Options) and Work for more information.

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Difference

See Also

Difference Members


Difference Members

[image] [image]

SQL Data Compare API 7.1.0
Difference Members
Difference Class Methods Properties See Also

The Difference type exposes the following members.

Methods

Name | Description
Equals | Equality check. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hashcode for the difference. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObjectType | The type of database object the difference represents.
Name | The name of the database object.
ObjectIn1 | The object in the first database.
ObjectIn2 | The object in the second database.
Selected | True if the difference is selected.
Type | The type of difference.

See Also

Difference Class


Difference Methods

[image] [image]

SQL Data Compare API 7.1.0
Difference Methods
Difference Class See Also

The Difference type exposes the following methods.

Methods

Name | Description
Equals | Equality check. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Hashcode for the difference. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Difference Class


Equals Method

[image]

SQL Data Compare API 7.1.0
Difference..::.Equals Method
Difference Class See Also

Equality check.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
Difference instance to compare against.

Return Value

True if the two Difference instances are equal.

See Also

Difference Class


GetHashCode Method

[image]

SQL Data Compare API 7.1.0
Difference..::.GetHashCode Method
Difference Class See Also

Hashcode for the difference.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

Hashcode for the difference.

See Also

Difference Class


Difference Properties

[image] [image]

SQL Data Compare API 7.1.0
Difference Properties
Difference Class See Also

The Difference type exposes the following properties.

Properties

Name | Description
DatabaseObjectType | The type of database object the difference represents.
Name | The name of the database object.
ObjectIn1 | The object in the first database.
ObjectIn2 | The object in the second database.
Selected | True if the difference is selected.
Type | The type of difference.

See Also

Difference Class


DatabaseObjectType Property

[image]

SQL Data Compare API 7.1.0
Difference..::.DatabaseObjectType Property
Difference Class See Also

The type of database object the difference represents.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseObjectType As ObjectType
C#
public ObjectType DatabaseObjectType { get; internal set; }
Visual C++
public:
property ObjectType DatabaseObjectType {
    ObjectType get ();
    void set (ObjectType value);
}

See Also

Difference Class


Name Property

[image]

SQL Data Compare API 7.1.0
Difference..::.Name Property
Difference Class See Also

The name of the database object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Difference Class


ObjectIn1 Property

[image]

SQL Data Compare API 7.1.0
Difference..::.ObjectIn1 Property
Difference Class See Also

The object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectIn1 As IDatabaseObject
C#
public IDatabaseObject ObjectIn1 { get; internal set; }
Visual C++
public:
property IDatabaseObject^ ObjectIn1 {
    IDatabaseObject^ get ();
    void set (IDatabaseObject^ value);
}

See Also

Difference Class


ObjectIn2 Property

[image]

SQL Data Compare API 7.1.0
Difference..::.ObjectIn2 Property
Difference Class See Also

The object in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectIn2 As IDatabaseObject
C#
public IDatabaseObject ObjectIn2 { get; internal set; }
Visual C++
public:
property IDatabaseObject^ ObjectIn2 {
    IDatabaseObject^ get ();
    void set (IDatabaseObject^ value);
}

See Also

Difference Class


Selected Property

[image]

SQL Data Compare API 7.1.0
Difference..::.Selected Property
Difference Class See Also

True if the difference is selected.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
C#
public bool Selected { get; set; }
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

Remarks

Set to true to include the difference in a migration script.

See Also

Difference Class


Type Property

[image]

SQL Data Compare API 7.1.0
Difference..::.Type Property
Difference Class See Also

The type of difference.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DifferenceType
C#
public DifferenceType Type { get; internal set; }
Visual C++
public:
property DifferenceType Type {
    DifferenceType get ();
    void set (DifferenceType value);
}

See Also

Difference Class


Differences Class

[image]

SQL Data Compare API 7.1.0
Differences Class
Members See Also

A collection of difference objects representing the differences between two databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Differences _
    Inherits InnerList(Of Difference)
C#
public sealed class Differences : InnerList<Difference>
Visual C++
public ref class Differences sealed : public InnerList<Difference^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Difference >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Difference >)>)
RedGate.SQLCompare.Engine..::.Differences

See Also

Differences Members


Differences Members

[image] [image]

SQL Data Compare API 7.1.0
Differences Members
Differences Class Methods Properties Explicit Interface Implementations See Also

The Differences type exposes the following members.

Methods

Name | Description
Add | Adds an item to the Differences collection. (Overrides InnerList <(Of <( Difference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Database1 | The first database to be compared.
Database2 | The second database to be compared.
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Differences Class


Differences Methods

[image] [image]

SQL Data Compare API 7.1.0
Differences Methods
Differences Class See Also

The Differences type exposes the following methods.

Methods

Name | Description
Add | Adds an item to the Differences collection. (Overrides InnerList <(Of <( Difference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Differences Class


Add Method

[image]

SQL Data Compare API 7.1.0
Differences..::.Add Method
Differences Class See Also

Adds an item to the Differences collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Difference _
)
C#
public override void Add(
    Difference value
)
Visual C++
public:
virtual void Add(
    Difference^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Difference
The object to add.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

Differences Class


Differences Properties

[image] [image]

SQL Data Compare API 7.1.0
Differences Properties
Differences Class See Also

The Differences type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Database1 | The first database to be compared.
Database2 | The second database to be compared.
Item | (Inherited from InnerList<(Of <(T>)>).)

See Also

Differences Class


Database1 Property

[image]

SQL Data Compare API 7.1.0
Differences..::.Database1 Property
Differences Class See Also

The first database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database1 As Database
C#
public Database Database1 { get; internal set; }
Visual C++
public:
property Database^ Database1 {
    Database^ get ();
    void set (Database^ value);
}

See Also

Differences Class


Database2 Property

[image]

SQL Data Compare API 7.1.0
Differences..::.Database2 Property
Differences Class See Also

The second database to be compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database2 As Database
C#
public Database Database2 { get; internal set; }
Visual C++
public:
property Database^ Database2 {
    Database^ get ();
    void set (Database^ value);
}

See Also

Differences Class


DifferenceType Enumeration

[image]

SQL Data Compare API 7.1.0
DifferenceType Enumeration
See Also

The type of difference.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DifferenceType
C#
public enum DifferenceType
Visual C++
public enum class DifferenceType

Members

Member name | Description
OnlyIn1 | The object exists only in the first database.
OnlyIn2 | The object exists only in the second database.
Different | The object exists in both databases, but is different.
Equal | The object exists in both databases and is identical.

See Also


EventNotification Class

[image]

SQL Data Compare API 7.1.0
EventNotification Class
Members See Also

An event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventNotification _
    Inherits ScriptableDatabaseObject
C#
public sealed class EventNotification : ScriptableDatabaseObject
Visual C++
public ref class EventNotification sealed : public ScriptableDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.EventNotification

See Also

EventNotification Members


EventNotification Members

[image] [image]

SQL Data Compare API 7.1.0
EventNotification Members
EventNotification Class Methods Fields Properties See Also

The EventNotification type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventTypes | The event types.
ExtendedProperties | The extended properties defined for the event notification.
FanIn | True if the event notification has the fan in option enabled.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ServiceName | The name of the service.

See Also

EventNotification Class


EventNotification Methods

[image] [image]

SQL Data Compare API 7.1.0
EventNotification Methods
EventNotification Class See Also

The EventNotification type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventNotification Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
EventNotification..::.Equals Method
EventNotification Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the event notification with a specified event notification. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

EventNotification Class
EventNotification Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
EventNotification..::.Equals Method (IDatabaseObject, Options)
EventNotification Class See Also

Compares the event notification with a specified event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The event notification to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the event notifications are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

EventNotification Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
EventNotification..::.ScriptObject Method
EventNotification Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

EventNotification Class


EventNotification Properties

[image] [image]

SQL Data Compare API 7.1.0
EventNotification Properties
EventNotification Class See Also

The EventNotification type exposes the following properties.

Properties

Name | Description
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventTypes | The event types.
ExtendedProperties | The extended properties defined for the event notification.
FanIn | True if the event notification has the fan in option enabled.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ServiceName | The name of the service.

See Also

EventNotification Class


BrokerInstance Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.BrokerInstance Property
EventNotification Class See Also

The broker instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; internal set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotification Class


EventTypes Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.EventTypes Property
EventNotification Class See Also

The event types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventTypes As EventTypes
C#
public EventTypes EventTypes { get; }
Visual C++
public:
property EventTypes^ EventTypes {
    EventTypes^ get ();
}

See Also

EventNotification Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.ExtendedProperties Property
EventNotification Class See Also

The extended properties defined for the event notification.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

EventNotification Class


FanIn Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.FanIn Property
EventNotification Class See Also

True if the event notification has the fan in option enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FanIn As Boolean
C#
public bool FanIn { get; internal set; }
Visual C++
public:
property bool FanIn {
    bool get ();
    void set (bool value);
}

See Also

EventNotification Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.ObjectType Property
EventNotification Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType

See Also

EventNotification Class


ServiceName Property

[image]

SQL Data Compare API 7.1.0
EventNotification..::.ServiceName Property
EventNotification Class See Also

The name of the service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceName As String
C#
public string ServiceName { get; internal set; }
Visual C++
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

EventNotification Class


EventNotifications Class

[image]

SQL Data Compare API 7.1.0
EventNotifications Class
Members See Also

A collection of event notifications.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventNotifications _
    Inherits SerializableDatabaseObjectCollection(Of EventNotification)
C#
public sealed class EventNotifications : SerializableDatabaseObjectCollection<EventNotification>
Visual C++
public ref class EventNotifications sealed : public SerializableDatabaseObjectCollection<EventNotification^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( EventNotification >)>)
RedGate.SQLCompare.Engine..::.EventNotifications

See Also

EventNotifications Members


EventNotifications Members

[image] [image]

SQL Data Compare API 7.1.0
EventNotifications Members
EventNotifications Class Methods Properties Explicit Interface Implementations See Also

The EventNotifications type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

EventNotifications Class


EventNotifications Methods

[image] [image]

SQL Data Compare API 7.1.0
EventNotifications Methods
EventNotifications Class See Also

The EventNotifications type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

EventNotifications Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
EventNotifications..::.Equals Method
EventNotifications Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(EventNotifications, Options) | Compares the event notification collection with a specified event notification collection.

See Also

EventNotifications Class
EventNotifications Members


Equals Method (EventNotifications, Options)

[image]

SQL Data Compare API 7.1.0
EventNotifications..::.Equals Method (EventNotifications, Options)
EventNotifications Class See Also

Compares the event notification collection with a specified event notification collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As EventNotifications, _
    options As Options _
) As Boolean
C#
public bool Equals(
    EventNotifications target,
    Options options
)
Visual C++
public:
bool Equals(
    EventNotifications^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.EventNotifications
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the event notification collections are identical; otherwise, false.

See Also

EventNotifications Class
Equals Overload


EventType Enumeration

[image]

SQL Data Compare API 7.1.0
EventType Enumeration
See Also

The type of event.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EventType
C#
public enum EventType
Visual C++
public enum class EventType

Members

Member name | Description
Unknown | Unknown
Insert | INSERT
Update | UPDATE
Delete | DELETE
CreateTable | CREATE_TABLE
AlterTable | ALTER_TABLE
DropTable | DROP_TABLE
CreateIndex | CREATE_INDEX
AlterIndex | ALTER_INDEX
DropIndex | DROP_INDEX
CreateStatistics | CREATE_STATISTICS
UpdateStatistics | UPDATE_STATISTICS
DropStatistics | DROP_STATISTICS
CreateSynonym | CREATE_SYNONYM
DropSynonym | DROP_SYNONYM
CreateView | CREATE_VIEW
AlterView | ALTER_VIEW
DropView | DROP_VIEW
CreateProcedure | CREATE_PROCEDURE
AlterProcedure | ALTER_PROCEDURE
DropProcedure | DROP_PROCEDURE
CreateFunction | CREATE_FUNCTION
AlterFunction | ALTER_FUNCTION
DropFunction | DROP_FUNCTION
CreateTrigger | CREATE_TRIGGER
AlterTrigger | ALTER_TRIGGER
DropTrigger | DROP_TRIGGER
CreateEventNotification | CREATE_EVENT_NOTIFICATION
DropEventNotification | DROP_EVENT_NOTIFICATION
CreateType | CREATE_TYPE
DropType | DROP_TYPE
CreateAssembly | CREATE_ASSEMBLY
AlterAssembly | ALTER_ASSEMBLY
DropAssembly | DROP_ASSEMBLY
CreateUser | CREATE_USER
AlterUser | ALTER_USER
DropUser | DROP_USER
CreateRole | CREATE_ROLE
AlterRole | ALTER_ROLE
DropRole | DROP_ROLE
CreateApplicationRole | CREATE_APPLICATION_ROLE
AlterApplicationRole | ALTER_APPLICATION_ROLE
DropApplicationRole | DROP_APPLICATION_ROLE
CreateSchema | CREATE_SCHEMA
AlterSchema | ALTER_SCHEMA
DropSchema | DROP_SCHEMA
CreateLogin | CREATE_LOGIN
AlterLogin | ALTER_LOGIN
DropLogin | DROP_LOGIN
CreateMessageType | CREATE_MESSAGE_TYPE
AlterMessageType | ALTER_MESSAGE_TYPE
DropMessageType | DROP_MESSAGE_TYPE
CreateContract | CREATE_CONTRACT
DropContract | DROP_CONTRACT
CreateQueue | CREATE_QUEUE
AlterQueue | ALTER_QUEUE
DropQueue | DROP_QUEUE
BrokerQueueDisabled | BROKER_QUEUE_DISABLED
CreateService | CREATE_SERVICE
AlterService | ALTER_SERVICE
DropService | DROP_SERVICE
CreateRoute | CREATE_ROUTE
AlterRoute | ALTER_ROUTE
DropRoute | DROP_ROUTE
GrantServer | GRANT_SERVER
DenyServer | DENY_SERVER
RevokeServer | REVOKE_SERVER
GrantDatabase | GRANT_DATABASE
DenyDatabase | DENY_DATABASE
RevokeDatabase | REVOKE_DATABASE
QueueActivation | QUEUE_ACTIVATION
CreateRemoteServiceBinding | CREATE_REMOTE_SERVICE_BINDING
AlterRemoteServiceBinding | ALTER_REMOTE_SERVICE_BINDING
DropRemoteServiceBinding | DROP_REMOTE_SERVICE_BINDING
CreateXmlSchemaCollection | CREATE_XML_SCHEMA_COLLECTION
AlterXmlSchemaCollection | ALTER_XML_SCHEMA_COLLECTION
DropXmlSchemaCollection | DROP_XML_SCHEMA_COLLECTION
CreateEndpoint | CREATE_ENDPOINT
AlterEndpoint | ALTER_ENDPOINT
DropEndpoint | DROP_ENDPOINT
CreatePartitionFunction | CREATE_PARTITION_FUNCTION
AlterPartitionFunction | ALTER_PARTITION_FUNCTION
DropPartitionFunction | DROP_PARTITION_FUNCTION
CreatePartitionScheme | CREATE_PARTITION_SCHEME
AlterPartitionScheme | ALTER_PARTITION_SCHEME
DropPartitionScheme | DROP_PARTITION_SCHEME
CreateCertificate | CREATE_CERTIFICATE
AlterCertificate | ALTER_CERTIFICATE
DropCertificate | DROP_CERTIFICATE
CreateDatabase | CREATE_DATABASE
AlterDatabase | ALTER_DATABASE
DropDatabase | DROP_DATABASE
AlterAuthorizationServer | ALTER_AUTHORIZATION_SERVER
AlterAuthorizationDatabase | ALTER_AUTHORIZATION_DATABASE
CreateXmlIndex | CREATE_XML_INDEX
AddRoleMember | ADD_ROLE_MEMBER
DropRoleMember | DROP_ROLE_MEMBER
AddServerRoleMember | ADD_SERVER_ROLE_MEMBER
DropServerRoleMember | DROP_SERVER_ROLE_MEMBER
AlterExtendedProperty | ALTER_EXTENDED_PROPERTY
AlterFulltextCatalog | ALTER_FULLTEXT_CATALOG
AlterFulltextIndex | ALTER_FULLTEXT_INDEX
AlterInstance | ALTER_INSTANCE
AlterMessage | ALTER_MESSAGE
AlterPlanGuide | ALTER_PLAN_GUIDE
AlterRemoteServer | ALTER_REMOTE_SERVER
BindDefault | BIND_DEFAULT
BindRule | BIND_RULE
CreateDefault | CREATE_DEFAULT
CreateExtendedProcedure | CREATE_EXTENDED_PROCEDURE
CreateExtendedProperty | CREATE_EXTENDED_PROPERTY
CreateFulltextCatalog | CREATE_FULLTEXT_CATALOG
CreateFulltextIndex | CREATE_FULLTEXT_INDEX
CreateLinkedServer | CREATE_LINKED_SERVER
CreateLinkedServerLogin | CREATE_LINKED_SERVER_LOGIN
CreateMessage | CREATE_MESSAGE
CreatePlanGuide | CREATE_PLAN_GUIDE
CreateRule | CREATE_RULE
CreateRemoteServer | CREATE_REMOTE_SERVER
DropDefault | DROP_DEFAULT
DropExtendedProcedure | DROP_EXTENDED_PROCEDURE
DropExtendedProperty | DROP_EXTENDED_PROPERTY
DropFulltextCatalog | DROP_FULLTEXT_CATALOG
DropFulltextIndex | DROP_FULLTEXT_INDEX
DropLinkedServerLogin | DROP_LINKED_SERVER_LOGIN
DropMessage | DROP_MESSAGE
DropPlanGuide | DROP_PLAN_GUIDE
DropRule | DROP_RULE
DropRemoteServer | DROP_REMOTE_SERVER
Rename | RENAME
UnbindDefault | UNBIND_DEFAULT
UnbindRule | UNBIND_RULE
CreateSymmetricKey | CREATE_SYMMETRIC_KEY
AlterSymmetricKey | ALTER_SYMMETRIC_KEY
DropSymmetricKey | DROP_SYMMETRIC_KEY
CreateAsymmetricKey | CREATE_ASYMMETRIC_KEY
AlterAsymmetricKey | ALTER_ASYMMETRIC_KEY
DropAsymmetricKey | DROP_ASYMMETRIC_KEY
AlterServiceMasterKey | ALTER_SERVICE_MASTER_KEY
CreateMasterKey | CREATE_MASTER_KEY
AlterMasterKey | ALTER_MASTER_KEY
DropMasterKey | DROP_MASTER_KEY
AddSignatureSchemaObject | ADD_SIGNATURE_SCHEMA_OBJECT
DropSignatureSchemaObject | DROP_SIGNATURE_SCHEMA_OBJECT
AddSignature | ADD_SIGNATURE
DropSignature | DROP_SIGNATURE
CreateCredential | CREATE_CREDENTIAL
AlterCredential | ALTER_CREDENTIAL
DropCredential | DROP_CREDENTIAL
DropLinkedServer | DROP_LINKED_SERVER
AlterLinkedServer | ALTER_LINKED_SERVER
CreateEventSession | CREATE_EVENT_SESSION
AlterEventSession | ALTER_EVENT_SESSION
DropEventSession | DROP_EVENT_SESSION
CreateResourcePool | CREATE_RESOURCE_POOL
AlterResourcePool | ALTER_RESOURCE_POOL
DropResourcePool | DROP_RESOURCE_POOL
CreateWorkloadGroup | CREATE_WORKLOAD_GROUP
AlterWorkloadGroup | ALTER_WORKLOAD_GROUP
DropWorkloadGroup | DROP_WORKLOAD_GROUP
AlterResourceGovernorConfig | ALTER_RESOURCE_GOVERNOR_CONFIG
CreateSpatialIndex | CREATE_SPATIAL_INDEX
CreateCryptographicProvider | CREATE_CRYPTOGRAPHIC_PROVIDER
AlterCryptographicProvider | ALTER_CRYPTOGRAPHIC_PROVIDER
DropCryptographicProvider | DROP_CRYPTOGRAPHIC_PROVIDER
CreateDatabaseEncryptionKey | CREATE_DATABASE_ENCRYPTION_KEY
AlterDatabaseEncryptionKey | ALTER_DATABASE_ENCRYPTION_KEY
DropDatabaseEncryptionKey | DROP_DATABASE_ENCRYPTION_KEY
CreateBrokerPriority | CREATE_BROKER_PRIORITY
AlterBrokerPriority | ALTER_BROKER_PRIORITY
DropBrokerPriority | DROP_BROKER_PRIORITY
CreateServerAudit | CREATE_SERVER_AUDIT
AlterServerAudit | ALTER_SERVER_AUDIT
DropServerAudit | DROP_SERVER_AUDIT
CreateServerAuditSpecification | CREATE_SERVER_AUDIT_SPECIFICATION
AlterServerAuditSpecification | ALTER_SERVER_AUDIT_SPECIFICATION
DropServerAuditSpecification | DROP_SERVER_AUDIT_SPECIFICATION
CreateDatabaseAuditSpecification | CREATE_DATABASE_AUDIT_SPECIFICATION
AlterDatabaseAuditSpecification | ALTER_DATABASE_AUDIT_SPECIFICATION
DropDatabaseAuditSpecification | DROP_DATABASE_AUDIT_SPECIFICATION
CreateFulltextStoplist | CREATE_FULLTEXT_STOPLIST
AlterFulltextStoplist | ALTER_FULLTEXT_STOPLIST
DropFulltextStoplist | DROP_FULLTEXT_STOPLIST
AuditLogin | AUDIT_LOGIN
AuditLogout | AUDIT_LOGOUT
AuditLoginFailed | AUDIT_LOGIN_FAILED
Eventlog | EVENTLOG
Errorlog | ERRORLOG
LockDeadlock | LOCK_DEADLOCK
Exception | EXCEPTION
SpCachemiss | SP_CACHEMISS
SpCacheinsert | SP_CACHEINSERT
SpCacheremove | SP_CACHEREMOVE
SpRecompile | SP_RECOMPILE
ObjectCreated | OBJECT_CREATED
ObjectDeleted | OBJECT_DELETED
HashWarning | HASH_WARNING
LockDeadlockChain | LOCK_DEADLOCK_CHAIN
LockEscalation | LOCK_ESCALATION
OledbErrors | OLEDB_ERRORS
ExecutionWarnings | EXECUTION_WARNINGS
SortWarnings | SORT_WARNINGS
MissingColumnStatistics | MISSING_COLUMN_STATISTICS
MissingJoinPredicate | MISSING_JOIN_PREDICATE
ServerMemoryChange | SERVER_MEMORY_CHANGE
Userconfigurable0 | USERCONFIGURABLE_0
Userconfigurable1 | USERCONFIGURABLE_1
Userconfigurable2 | USERCONFIGURABLE_2
Userconfigurable3 | USERCONFIGURABLE_3
Userconfigurable4 | USERCONFIGURABLE_4
Userconfigurable5 | USERCONFIGURABLE_5
Userconfigurable6 | USERCONFIGURABLE_6
Userconfigurable7 | USERCONFIGURABLE_7
Userconfigurable8 | USERCONFIGURABLE_8
Userconfigurable9 | USERCONFIGURABLE_9
DataFileAutoGrow | DATA_FILE_AUTO_GROW
LogFileAutoGrow | LOG_FILE_AUTO_GROW
DataFileAutoShrink | DATA_FILE_AUTO_SHRINK
LogFileAutoShrink | LOG_FILE_AUTO_SHRINK
AuditDatabaseScopeGdrEvent | AUDIT_DATABASE_SCOPE_GDR_EVENT
AuditSchemaObjectGdrEvent | AUDIT_SCHEMA_OBJECT_GDR_EVENT
AuditAddloginEvent | AUDIT_ADDLOGIN_EVENT
AuditLoginGdrEvent | AUDIT_LOGIN_GDR_EVENT
AuditLoginChangePropertyEvent | AUDIT_LOGIN_CHANGE_PROPERTY_EVENT
AuditLoginChangePasswordEvent | AUDIT_LOGIN_CHANGE_PASSWORD_EVENT
AuditAddLoginToServerRoleEvent | AUDIT_ADD_LOGIN_TO_SERVER_ROLE_EVENT
AuditAddDbUserEvent | AUDIT_ADD_DB_USER_EVENT
AuditAddMemberToDbRoleEvent | AUDIT_ADD_MEMBER_TO_DB_ROLE_EVENT
AuditAddRoleEvent | AUDIT_ADD_ROLE_EVENT
AuditAppRoleChangePasswordEvent | AUDIT_APP_ROLE_CHANGE_PASSWORD_EVENT
AuditSchemaObjectAccessEvent | AUDIT_SCHEMA_OBJECT_ACCESS_EVENT
AuditBackupRestoreEvent | AUDIT_BACKUP_RESTORE_EVENT
AuditDbccEvent | AUDIT_DBCC_EVENT
AuditChangeAuditEvent | AUDIT_CHANGE_AUDIT_EVENT
OledbCallEvent | OLEDB_CALL_EVENT
OledbQueryinterfaceEvent | OLEDB_QUERYINTERFACE_EVENT
OledbDatareadEvent | OLEDB_DATAREAD_EVENT
ShowplanXml | SHOWPLAN_XML
DeprecationAnnouncement | DEPRECATION_ANNOUNCEMENT
DeprecationFinalSupport | DEPRECATION_FINAL_SUPPORT
ExchangeSpillEvent | EXCHANGE_SPILL_EVENT
AuditDatabaseManagementEvent | AUDIT_DATABASE_MANAGEMENT_EVENT
AuditDatabaseObjectManagementEvent | AUDIT_DATABASE_OBJECT_MANAGEMENT_EVENT
AuditDatabasePrincipalManagementEvent | AUDIT_DATABASE_PRINCIPAL_MANAGEMENT_EVENT
AuditSchemaObjectManagementEvent | AUDIT_SCHEMA_OBJECT_MANAGEMENT_EVENT
AuditServerPrincipalImpersonationEvent | AUDIT_SERVER_PRINCIPAL_IMPERSONATION_EVENT
AuditDatabasePrincipalImpersonationEvent | AUDIT_DATABASE_PRINCIPAL_IMPERSONATION_EVENT
AuditServerObjectTakeOwnershipEvent | AUDIT_SERVER_OBJECT_TAKE_OWNERSHIP_EVENT
AuditDatabaseObjectTakeOwnershipEvent | AUDIT_DATABASE_OBJECT_TAKE_OWNERSHIP_EVENT
BlockedProcessReport | BLOCKED_PROCESS_REPORT
ShowplanXmlStatisticsProfile | SHOWPLAN_XML_STATISTICS_PROFILE
DeadlockGraph | DEADLOCK_GRAPH
TraceFileClose | TRACE_FILE_CLOSE
AuditChangeDatabaseOwner | AUDIT_CHANGE_DATABASE_OWNER
AuditSchemaObjectTakeOwnershipEvent | AUDIT_SCHEMA_OBJECT_TAKE_OWNERSHIP_EVENT
FtCrawlStarted | FT_CRAWL_STARTED
FtCrawlStopped | FT_CRAWL_STOPPED
FtCrawlAborted | FT_CRAWL_ABORTED
UserErrorMessage | USER_ERROR_MESSAGE
ObjectAltered | OBJECT_ALTERED
SqlStmtrecompile | SQL_STMTRECOMPILE
DatabaseMirroringStateChange | DATABASE_MIRRORING_STATE_CHANGE
ShowplanXmlForQueryCompile | SHOWPLAN_XML_FOR_QUERY_COMPILE
ShowplanAllForQueryCompile | SHOWPLAN_ALL_FOR_QUERY_COMPILE
AuditServerScopeGdrEvent | AUDIT_SERVER_SCOPE_GDR_EVENT
AuditServerObjectGdrEvent | AUDIT_SERVER_OBJECT_GDR_EVENT
AuditDatabaseObjectGdrEvent | AUDIT_DATABASE_OBJECT_GDR_EVENT
AuditServerOperationEvent | AUDIT_SERVER_OPERATION_EVENT
AuditServerAlterTraceEvent | AUDIT_SERVER_ALTER_TRACE_EVENT
AuditServerObjectManagementEvent | AUDIT_SERVER_OBJECT_MANAGEMENT_EVENT
AuditServerPrincipalManagementEvent | AUDIT_SERVER_PRINCIPAL_MANAGEMENT_EVENT
AuditDatabaseOperationEvent | AUDIT_DATABASE_OPERATION_EVENT
AuditDatabaseObjectAccessEvent | AUDIT_DATABASE_OBJECT_ACCESS_EVENT
OledbProviderInformation | OLEDB_PROVIDER_INFORMATION
MountTape | MOUNT_TAPE
AssemblyLoad | ASSEMBLY_LOAD
XqueryStaticType | XQUERY_STATIC_TYPE
QnSubscription | QN__SUBSCRIPTION
QnParameterTable | QN__PARAMETER_TABLE
QnTemplate | QN__TEMPLATE
QnDynamics | QN__DYNAMICS
BitmapWarning | BITMAP_WARNING
DatabaseSuspectDataPage | DATABASE_SUSPECT_DATA_PAGE
CpuThresholdExceeded | CPU_THRESHOLD_EXCEEDED
DdlEvents | DDL_EVENTS
DdlServerLevelEvents | DDL_SERVER_LEVEL_EVENTS
DdlEndpointEvents | DDL_ENDPOINT_EVENTS
DdlDatabaseEvents | DDL_DATABASE_EVENTS
DdlServerSecurityEvents | DDL_SERVER_SECURITY_EVENTS
DdlLoginEvents | DDL_LOGIN_EVENTS
DdlGdrServerEvents | DDL_GDR_SERVER_EVENTS
DdlAuthorizationServerEvents | DDL_AUTHORIZATION_SERVER_EVENTS
DdlCredentialEvents | DDL_CREDENTIAL_EVENTS
DdlServiceMasterKeyEvents | DDL_SERVICE_MASTER_KEY_EVENTS
DdlExtendedProcedureEvents | DDL_EXTENDED_PROCEDURE_EVENTS
DdlLinkedServerEvents | DDL_LINKED_SERVER_EVENTS
DdlLinkedServerLoginEvents | DDL_LINKED_SERVER_LOGIN_EVENTS
DdlMessageEvents | DDL_MESSAGE_EVENTS
DdlRemoteServerEvents | DDL_REMOTE_SERVER_EVENTS
DdlDatabaseLevelEvents | DDL_DATABASE_LEVEL_EVENTS
DdlTableViewEvents | DDL_TABLE_VIEW_EVENTS
DdlTableEvents | DDL_TABLE_EVENTS
DdlViewEvents | DDL_VIEW_EVENTS
DdlIndexEvents | DDL_INDEX_EVENTS
DdlStatisticsEvents | DDL_STATISTICS_EVENTS
DdlSynonymEvents | DDL_SYNONYM_EVENTS
DdlFunctionEvents | DDL_FUNCTION_EVENTS
DdlProcedureEvents | DDL_PROCEDURE_EVENTS
DdlTriggerEvents | DDL_TRIGGER_EVENTS
DdlEventNotificationEvents | DDL_EVENT_NOTIFICATION_EVENTS
DdlAssemblyEvents | DDL_ASSEMBLY_EVENTS
DdlTypeEvents | DDL_TYPE_EVENTS
DdlDatabaseSecurityEvents | DDL_DATABASE_SECURITY_EVENTS
DdlCertificateEvents | DDL_CERTIFICATE_EVENTS
DdlUserEvents | DDL_USER_EVENTS
DdlRoleEvents | DDL_ROLE_EVENTS
DdlApplicationRoleEvents | DDL_APPLICATION_ROLE_EVENTS
DdlSchemaEvents | DDL_SCHEMA_EVENTS
DdlGdrDatabaseEvents | DDL_GDR_DATABASE_EVENTS
DdlAuthorizationDatabaseEvents | DDL_AUTHORIZATION_DATABASE_EVENTS
DdlSymmetricKeyEvents | DDL_SYMMETRIC_KEY_EVENTS
DdlAsymmetricKeyEvents | DDL_ASYMMETRIC_KEY_EVENTS
DdlCryptoSignatureEvents | DDL_CRYPTO_SIGNATURE_EVENTS
DdlMasterKeyEvents | DDL_MASTER_KEY_EVENTS
DdlSsbEvents | DDL_SSB_EVENTS
DdlMessageTypeEvents | DDL_MESSAGE_TYPE_EVENTS
DdlContractEvents | DDL_CONTRACT_EVENTS
DdlQueueEvents | DDL_QUEUE_EVENTS
DdlServiceEvents | DDL_SERVICE_EVENTS
DdlRouteEvents | DDL_ROUTE_EVENTS
DdlRemoteServiceBindingEvents | DDL_REMOTE_SERVICE_BINDING_EVENTS
DdlXmlSchemaCollectionEvents | DDL_XML_SCHEMA_COLLECTION_EVENTS
DdlPartitionEvents | DDL_PARTITION_EVENTS
DdlPartitionFunctionEvents | DDL_PARTITION_FUNCTION_EVENTS
DdlPartitionSchemeEvents | DDL_PARTITION_SCHEME_EVENTS
DdlDefaultEvents | DDL_DEFAULT_EVENTS
DdlExtendedPropertyEvents | DDL_EXTENDED_PROPERTY_EVENTS
DdlFulltextCatalogEvents | DDL_FULLTEXT_CATALOG_EVENTS
DdlPlanGuideEvents | DDL_PLAN_GUIDE_EVENTS
DdlRuleEvents | DDL_RULE_EVENTS
DdlEventSessionEvents | DDL_EVENT_SESSION_EVENTS
DdlResourceGovernorEvents | DDL_RESOURCE_GOVERNOR_EVENTS
DdlResourcePool | DDL_RESOURCE_POOL
DdlWorkloadGroup | DDL_WORKLOAD_GROUP
DdlCryptographicProviderEvents | DDL_CRYPTOGRAPHIC_PROVIDER_EVENTS
DdlDatabaseEncryptionKeyEvents | DDL_DATABASE_ENCRYPTION_KEY_EVENTS
DdlBrokerPriorityEvents | DDL_BROKER_PRIORITY_EVENTS
DdlServerAuditEvents | DDL_SERVER_AUDIT_EVENTS
DdlServerAuditSpecificationEvents | DDL_SERVER_AUDIT_SPECIFICATION_EVENTS
DdlDatabaseAuditSpecificationEvents | DDL_DATABASE_AUDIT_SPECIFICATION_EVENTS
DdlFulltextStoplistEvents | DDL_FULLTEXT_STOPLIST_EVENTS
TrcAllEvents | TRC_ALL_EVENTS
TrcDatabase | TRC_DATABASE
TrcErrorsAndWarnings | TRC_ERRORS_AND_WARNINGS
TrcLocks | TRC_LOCKS
TrcObjects | TRC_OBJECTS
TrcPerformance | TRC_PERFORMANCE
TrcSecurityAudit | TRC_SECURITY_AUDIT
TrcServer | TRC_SERVER
TrcStoredProcedures | TRC_STORED_PROCEDURES
TrcTsql | TRC_TSQL
TrcUserConfigurable | TRC_USER_CONFIGURABLE
TrcOledb | TRC_OLEDB
TrcFullText | TRC_FULL_TEXT
TrcDeprecation | TRC_DEPRECATION
TrcClr | TRC_CLR
TrcQueryNotifications | TRC_QUERY_NOTIFICATIONS

See Also


EventTypes Class

[image]

SQL Data Compare API 7.1.0
EventTypes Class
Members See Also

A collection of EventTypes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EventTypes _
    Inherits SerializableCollection(Of EventType)
C#
public sealed class EventTypes : SerializableCollection<EventType>
Visual C++
public ref class EventTypes sealed : public SerializableCollection<EventType>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( EventType >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( EventType >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( EventType >)>)
RedGate.SQLCompare.Engine..::.EventTypes

See Also

EventTypes Members


EventTypes Members

[image] [image]

SQL Data Compare API 7.1.0
EventTypes Members
EventTypes Class Methods Properties Explicit Interface Implementations See Also

The EventTypes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

EventTypes Class


ExtendedProperties Class

[image]

SQL Data Compare API 7.1.0
ExtendedProperties Class
Members See Also

The extended properties associated with a database object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedProperties _
    Inherits SerializableCollection(Of ExtendedProperty)
C#
public sealed class ExtendedProperties : SerializableCollection<ExtendedProperty>
Visual C++
public ref class ExtendedProperties sealed : public SerializableCollection<ExtendedProperty^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ExtendedProperty >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ExtendedProperty >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ExtendedProperty >)>)
RedGate.SQLCompare.Engine..::.ExtendedProperties

See Also

ExtendedProperties Members


ExtendedProperties Members

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperties Members
ExtendedProperties Class Methods Properties Explicit Interface Implementations See Also

The ExtendedProperties type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ExtendedProperties Class


ExtendedProperties Properties

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperties Properties
ExtendedProperties Class See Also

The ExtendedProperties type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ExtendedProperties Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperties..::.Item Property
ExtendedProperties Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(ExtendedProperty])]) | Returns an extended property.
Item[([(String, String, String, String, String, String, String])]) | Returns an extended property given information about its types and names.

See Also

ExtendedProperties Class
ExtendedProperties Members


Item Property (ExtendedProperty)

[image]

SQL Data Compare API 7.1.0
ExtendedProperties..::.Item Property (ExtendedProperty)
ExtendedProperties Class See Also

Returns an extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    value As ExtendedProperty _
) As ExtendedProperty
C#
public ExtendedProperty this[
    ExtendedProperty value
] { get; }
Visual C++
public:
property ExtendedProperty^ default[ExtendedProperty^ value] {
    ExtendedProperty^ get (ExtendedProperty^ value);
}

Parameters

value
Type: RedGate.SQLCompare.Engine..::.ExtendedProperty
The value of the extended property to get.

See Also

ExtendedProperties Class
Item Overload


Item Property (String, String, String, String, String, String, String)

[image]

SQL Data Compare API 7.1.0
ExtendedProperties..::.Item Property (String, String, String, String, String, String, String)
ExtendedProperties Class See Also

Returns an extended property given information about its types and names.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    level0Type As String, _
    level0Name As String, _
    level1Type As String, _
    level1Name As String, _
    level2Type As String, _
    level2Name As String, _
    name As String _
) As ExtendedProperty
C#
public ExtendedProperty this[
    string level0Type,
    string level0Name,
    string level1Type,
    string level1Name,
    string level2Type,
    string level2Name,
    string name
] { get; }
Visual C++
public:
property ExtendedProperty^ default[String^ level0Type, String^ level0Name, String^ level1Type, String^ level1Name, String^ level2Type, String^ level2Name, String^ name] {
    ExtendedProperty^ get (String^ level0Type, String^ level0Name, String^ level1Type, String^ level1Name, String^ level2Type, String^ level2Name, String^ name);
}

Parameters

level0Type
Type: System..::.String
The type of the level0 object for which the extended property is specified.
level0Name
Type: System..::.String
The name of the level0 object for which the extended property is specified.
level1Type
Type: System..::.String
The type of the level1 object for which the extended property is specified.
level1Name
Type: System..::.String
The name of the level1 object for which the extended property is specified.
level2Type
Type: System..::.String
The type of the level2 object for which the extended property is specified.
level2Name
Type: System..::.String
The name of the level2 object for which the extended property is specified.
name
Type: System..::.String
The name of the extended property.

See Also

ExtendedProperties Class
Item Overload


ExtendedProperty Class

[image]

SQL Data Compare API 7.1.0
ExtendedProperty Class
Members See Also

An extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExtendedProperty
C#
public sealed class ExtendedProperty
Visual C++
public ref class ExtendedProperty sealed

Remarks

See sp_addextendedproperty in SQL Server Books Online for more information.

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ExtendedProperty

See Also

ExtendedProperty Members


ExtendedProperty Members

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperty Members
ExtendedProperty Class Methods Properties See Also

The ExtendedProperty type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | A string representation of the extended property. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Level0Name | The Level0 name of the extended property.
Level0Type | The Level0 type of the extended property.
Level1Name | The Level1 name of the extended property.
Level1Type | The Level1 type of the extended property.
Level2Name | The Level2 name of the extended property.
Level2Type | The Level2 type of the extended property.
Name | The name of the extended property.
Value | The value of the extended property.

See Also

ExtendedProperty Class


ExtendedProperty Methods

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperty Methods
ExtendedProperty Class See Also

The ExtendedProperty type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | A string representation of the extended property. (Overrides Object ..::. ToString()()().)

See Also

ExtendedProperty Class


ToString Method

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.ToString Method
ExtendedProperty Class See Also

A string representation of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A string.

See Also

ExtendedProperty Class


ExtendedProperty Properties

[image] [image]

SQL Data Compare API 7.1.0
ExtendedProperty Properties
ExtendedProperty Class See Also

The ExtendedProperty type exposes the following properties.

Properties

Name | Description
Level0Name | The Level0 name of the extended property.
Level0Type | The Level0 type of the extended property.
Level1Name | The Level1 name of the extended property.
Level1Type | The Level1 type of the extended property.
Level2Name | The Level2 name of the extended property.
Level2Type | The Level2 type of the extended property.
Name | The name of the extended property.
Value | The value of the extended property.

See Also

ExtendedProperty Class


Level0Name Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level0Name Property
ExtendedProperty Class See Also

The Level0 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level0Name As String
C#
public string Level0Name { get; internal set; }
Visual C++
public:
property String^ Level0Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Level0Type Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level0Type Property
ExtendedProperty Class See Also

The Level0 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level0Type As String
C#
public string Level0Type { get; internal set; }
Visual C++
public:
property String^ Level0Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Level1Name Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level1Name Property
ExtendedProperty Class See Also

The Level1 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Name As String
C#
public string Level1Name { get; internal set; }
Visual C++
public:
property String^ Level1Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Level1Type Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level1Type Property
ExtendedProperty Class See Also

The Level1 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level1Type As String
C#
public string Level1Type { get; internal set; }
Visual C++
public:
property String^ Level1Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Level2Name Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level2Name Property
ExtendedProperty Class See Also

The Level2 name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Name As String
C#
public string Level2Name { get; internal set; }
Visual C++
public:
property String^ Level2Name {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Level2Type Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Level2Type Property
ExtendedProperty Class See Also

The Level2 type of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Level2Type As String
C#
public string Level2Type { get; internal set; }
Visual C++
public:
property String^ Level2Type {
    String^ get ();
    void set (String^ value);
}

Remarks

See SQL Server Books Online for more information.

See Also

ExtendedProperty Class


Name Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Name Property
ExtendedProperty Class See Also

The name of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ExtendedProperty Class


Value Property

[image]

SQL Data Compare API 7.1.0
ExtendedProperty..::.Value Property
ExtendedProperty Class See Also

The value of the extended property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public Object Value { get; }
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

Remarks

This can be any data type.

See Also

ExtendedProperty Class


Field Class

[image]

SQL Data Compare API 7.1.0
Field Class
Members See Also

A SQL Server field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Field _
    Implements IDatabaseObject
C#
public sealed class Field : IDatabaseObject
Visual C++
public ref class Field sealed : IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Field

See Also

Field Members


Field Members

[image] [image]

SQL Data Compare API 7.1.0
Field Members
Field Class Methods Properties Explicit Interface Implementations See Also

The Field type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
Descending | True if the field is part of a descending index.
DRIDefault | The Declarative Referential Integrity (DRI) default.
Filestream | Specifies if this is a filestream column.
FullTextIndexed | True if the field is contained in a full-text index.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Identity | True if the field is an identity field.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
Included | The column is in an index, and it is included.
Name | The name of the field.
NotForReplication | True if the field is marked as not for replication.
ObjectType | Returns ObjectType.Field
Owner | The owner of the field. This is undefined.
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Field Class


Field Methods

[image] [image]

SQL Data Compare API 7.1.0
Field Methods
Field Class See Also

The Field type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Field Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Field..::.Equals Method
Field Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Field, Options) | Compares the field with a specified field.

See Also

Field Class
Field Members


Equals Method (Field, Options)

[image]

SQL Data Compare API 7.1.0
Field..::.Equals Method (Field, Options)
Field Class See Also

Compares the field with a specified field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetField As Field, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Field targetField,
    Options options
)
Visual C++
public:
bool Equals(
    Field^ targetField,
    Options options
)

Parameters

targetField
Type: RedGate.SQLCompare.Engine..::.Field
The field to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the fields are identical; otherwise, false.

See Also

Field Class
Equals Overload


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 7.1.0
Field..::.IDatabaseObject..::.Equals Method
Field Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Field Class


Field Properties

[image] [image]

SQL Data Compare API 7.1.0
Field Properties
Field Class See Also

The Field type exposes the following properties.

Properties

Name | Description
AllowNulls | True if the field can contain NULL values.
Collation | The collation order of character fields.
ColumnSet | True if this field is a column set.
Computed | True if the field is computed.
ComputedText | The computed text of the field.
Default | The default that is bound to the field.
DefaultText | The text of the field's default value.
DefinedSize | The length of the field.
Descending | True if the field is part of a descending index.
DRIDefault | The Declarative Referential Integrity (DRI) default.
Filestream | Specifies if this is a filestream column.
FullTextIndexed | True if the field is contained in a full-text index.
FullTextLanguage | The language of any full-text index to which the field belongs.
FullTextTypeColumn | The column that holds document type information. This is a SQL Server 2005 feature.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
Identity | True if the field is an identity field.
IdentityIncrement | The identity increment.
IdentitySeed | The identity seed.
Included | The column is in an index, and it is included.
Name | The name of the field.
NotForReplication | True if the field is marked as not for replication.
ObjectType | Returns ObjectType.Field
Owner | The owner of the field. This is undefined.
Persisted | The column is in a calculated column that is persisted.
Precision | The precision of a decimal or numeric data type.
RowGUIDCol | True if the field is a ROWGUIDCOL.
Rule | The rule bound to the field.
Scale | The scale of the field.
ScriptSourceForDefault | The location of the creation script for the default binding of this field if the database source is set to scripts folder.
ScriptSourceForFullTextColumn | The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding of this field if the database source is set to scripts folder.
Sparse | Whether this column is a sparse column
SqlType | The field type.
TypeName | The name of the field type.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | The referenced XML document.
XmlSchemaCollection | The referenced XML schema collection.

See Also

Field Class


AllowNulls Property

[image]

SQL Data Compare API 7.1.0
Field..::.AllowNulls Property
Field Class See Also

True if the field can contain NULL values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; internal set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

Field Class


Collation Property

[image]

SQL Data Compare API 7.1.0
Field..::.Collation Property
Field Class See Also

The collation order of character fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; internal set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


ColumnSet Property

[image]

SQL Data Compare API 7.1.0
Field..::.ColumnSet Property
Field Class See Also

True if this field is a column set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnSet As Boolean
C#
public bool ColumnSet { get; internal set; }
Visual C++
public:
property bool ColumnSet {
    bool get ();
    void set (bool value);
}

See Also

Field Class


Computed Property

[image]

SQL Data Compare API 7.1.0
Field..::.Computed Property
Field Class See Also

True if the field is computed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Computed As Boolean
C#
public bool Computed { get; internal set; }
Visual C++
public:
property bool Computed {
    bool get ();
    void set (bool value);
}

See Also

Field Class


ComputedText Property

[image]

SQL Data Compare API 7.1.0
Field..::.ComputedText Property
Field Class See Also

The computed text of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ComputedText As String
C#
public string ComputedText { get; internal set; }
Visual C++
public:
property String^ ComputedText {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


Default Property

[image]

SQL Data Compare API 7.1.0
Field..::.Default Property
Field Class See Also

The default that is bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Default
C#
public Default Default { get; internal set; }
Visual C++
public:
property Default^ Default {
    Default^ get ();
    void set (Default^ value);
}

See Also

Field Class


DefaultText Property

[image]

SQL Data Compare API 7.1.0
Field..::.DefaultText Property
Field Class See Also

The text of the field's default value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultText As String
C#
public string DefaultText { get; internal set; }
Visual C++
public:
property String^ DefaultText {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


DefinedSize Property

[image]

SQL Data Compare API 7.1.0
Field..::.DefinedSize Property
Field Class See Also

The length of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinedSize As Integer
C#
public int DefinedSize { get; internal set; }
Visual C++
public:
property int DefinedSize {
    int get ();
    void set (int value);
}

Remarks

Valid only for character and binary data.

See Also

Field Class


Descending Property

[image]

SQL Data Compare API 7.1.0
Field..::.Descending Property
Field Class See Also

True if the field is part of a descending index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Descending As Boolean
C#
public bool Descending { get; internal set; }
Visual C++
public:
property bool Descending {
    bool get ();
    void set (bool value);
}

Remarks

Valid only if the field belongs to an Index.Fields collection.

See Also

Field Class


DRIDefault Property

[image]

SQL Data Compare API 7.1.0
Field..::.DRIDefault Property
Field Class See Also

The Declarative Referential Integrity (DRI) default.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIDefault As String
C#
public string DRIDefault { get; internal set; }
Visual C++
public:
property String^ DRIDefault {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


Filestream Property

[image]

SQL Data Compare API 7.1.0
Field..::.Filestream Property
Field Class See Also

Specifies if this is a filestream column.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filestream As Boolean
C#
public bool Filestream { get; internal set; }
Visual C++
public:
property bool Filestream {
    bool get ();
    void set (bool value);
}

See Also

Field Class


FullTextIndexed Property

[image]

SQL Data Compare API 7.1.0
Field..::.FullTextIndexed Property
Field Class See Also

True if the field is contained in a full-text index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; internal set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

Field Class


FullTextLanguage Property

[image]

SQL Data Compare API 7.1.0
Field..::.FullTextLanguage Property
Field Class See Also

The language of any full-text index to which the field belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextLanguage As Integer
C#
public int FullTextLanguage { get; internal set; }
Visual C++
public:
property int FullTextLanguage {
    int get ();
    void set (int value);
}

See Also

Field Class


FullTextTypeColumn Property

[image]

SQL Data Compare API 7.1.0
Field..::.FullTextTypeColumn Property
Field Class See Also

The column that holds document type information. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextTypeColumn As String
C#
public string FullTextTypeColumn { get; internal set; }
Visual C++
public:
property String^ FullTextTypeColumn {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


FullyQualifiedTypeName Property

[image]

SQL Data Compare API 7.1.0
Field..::.FullyQualifiedTypeName Property
Field Class See Also

The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedTypeName As String
C#
public string FullyQualifiedTypeName { get; }
Visual C++
public:
property String^ FullyQualifiedTypeName {
    String^ get ();
}

See Also

Field Class


Identity Property

[image]

SQL Data Compare API 7.1.0
Field..::.Identity Property
Field Class See Also

True if the field is an identity field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Identity As Boolean
C#
public bool Identity { get; internal set; }
Visual C++
public:
property bool Identity {
    bool get ();
    void set (bool value);
}

See Also

Field Class


IdentityIncrement Property

[image]

SQL Data Compare API 7.1.0
Field..::.IdentityIncrement Property
Field Class See Also

The identity increment.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentityIncrement As Long
C#
public long IdentityIncrement { get; internal set; }
Visual C++
public:
property long long IdentityIncrement {
    long long get ();
    void set (long long value);
}

See Also

Field Class


IdentitySeed Property

[image]

SQL Data Compare API 7.1.0
Field..::.IdentitySeed Property
Field Class See Also

The identity seed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IdentitySeed As SqlDecimal
C#
public SqlDecimal IdentitySeed { get; internal set; }
Visual C++
public:
property SqlDecimal IdentitySeed {
    SqlDecimal get ();
    void set (SqlDecimal value);
}

See Also

Field Class


Included Property

[image]

SQL Data Compare API 7.1.0
Field..::.Included Property
Field Class See Also

The column is in an index, and it is included.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Included As Boolean
C#
public bool Included { get; internal set; }
Visual C++
public:
property bool Included {
    bool get ();
    void set (bool value);
}

See Also

Field Class


Name Property

[image]

SQL Data Compare API 7.1.0
Field..::.Name Property
Field Class See Also

The name of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseObject..::.Name

See Also

Field Class


NotForReplication Property

[image]

SQL Data Compare API 7.1.0
Field..::.NotForReplication Property
Field Class See Also

True if the field is marked as not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

Field Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Field..::.ObjectType Property
Field Class See Also

Returns ObjectType.Field

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

IDatabaseObject..::.ObjectType

See Also

Field Class


Owner Property

[image]

SQL Data Compare API 7.1.0
Field..::.Owner Property
Field Class See Also

The owner of the field. This is undefined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.Owner

See Also

Field Class


Persisted Property

[image]

SQL Data Compare API 7.1.0
Field..::.Persisted Property
Field Class See Also

The column is in a calculated column that is persisted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Persisted As Boolean
C#
public bool Persisted { get; internal set; }
Visual C++
public:
property bool Persisted {
    bool get ();
    void set (bool value);
}

See Also

Field Class


Precision Property

[image]

SQL Data Compare API 7.1.0
Field..::.Precision Property
Field Class See Also

The precision of a decimal or numeric data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

Field Class


RowGUIDCol Property

[image]

SQL Data Compare API 7.1.0
Field..::.RowGUIDCol Property
Field Class See Also

True if the field is a ROWGUIDCOL.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RowGUIDCol As Boolean
C#
public bool RowGUIDCol { get; internal set; }
Visual C++
public:
property bool RowGUIDCol {
    bool get ();
    void set (bool value);
}

See Also

Field Class


Rule Property

[image]

SQL Data Compare API 7.1.0
Field..::.Rule Property
Field Class See Also

The rule bound to the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Rule As Rule
C#
public Rule Rule { get; internal set; }
Visual C++
public:
property Rule^ Rule {
    Rule^ get ();
    void set (Rule^ value);
}

See Also

Field Class


Scale Property

[image]

SQL Data Compare API 7.1.0
Field..::.Scale Property
Field Class See Also

The scale of the field.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

Valid for numeric and decimal data types.

See Also

Field Class


ScriptSourceForDefault Property

[image]

SQL Data Compare API 7.1.0
Field..::.ScriptSourceForDefault Property
Field Class See Also

The location of the creation script for the default binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForDefault As ScriptSource
C#
public ScriptSource ScriptSourceForDefault { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForDefault {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Field Class


ScriptSourceForFullTextColumn Property

[image]

SQL Data Compare API 7.1.0
Field..::.ScriptSourceForFullTextColumn Property
Field Class See Also

The location of the creation script for the fulltext column information for this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForFullTextColumn As ScriptSource
C#
public ScriptSource ScriptSourceForFullTextColumn { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForFullTextColumn {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Field Class


ScriptSourceForRule Property

[image]

SQL Data Compare API 7.1.0
Field..::.ScriptSourceForRule Property
Field Class See Also

The location of the creation script for the rule binding of this field if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForRule As ScriptSource
C#
public ScriptSource ScriptSourceForRule { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForRule {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Field Class


Sparse Property

[image]

SQL Data Compare API 7.1.0
Field..::.Sparse Property
Field Class See Also

Whether this column is a sparse column

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Sparse As Boolean
C#
public bool Sparse { get; internal set; }
Visual C++
public:
property bool Sparse {
    bool get ();
    void set (bool value);
}

See Also

Field Class


SqlType Property

[image]

SQL Data Compare API 7.1.0
Field..::.SqlType Property
Field Class See Also

The field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; internal set; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

Field Class


TypeName Property

[image]

SQL Data Compare API 7.1.0
Field..::.TypeName Property
Field Class See Also

The name of the field type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; internal set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


TypeSchemaName Property

[image]

SQL Data Compare API 7.1.0
Field..::.TypeSchemaName Property
Field Class See Also

The name of the schema for the field's data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; internal set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class


XmlDocument Property

[image]

SQL Data Compare API 7.1.0
Field..::.XmlDocument Property
Field Class See Also

The referenced XML document.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocument As Boolean
C#
public bool XmlDocument { get; internal set; }
Visual C++
public:
property bool XmlDocument {
    bool get ();
    void set (bool value);
}

See Also

Field Class


XmlSchemaCollection Property

[image]

SQL Data Compare API 7.1.0
Field..::.XmlSchemaCollection Property
Field Class See Also

The referenced XML schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlSchemaCollection { get; internal set; }
Visual C++
public:
property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

Field Class


Fields Class

[image]

SQL Data Compare API 7.1.0
Fields Class
Members See Also

A collection of fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Fields _
    Inherits SerializableCollection(Of Field)
C#
public sealed class Fields : SerializableCollection<Field>
Visual C++
public ref class Fields sealed : public SerializableCollection<Field^>

Remarks

A table contains a collection of fields. An index also contains a collection of fields.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Field >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Field >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Field >)>)
RedGate.SQLCompare.Engine..::.Fields

See Also

Fields Members


Fields Members

[image] [image]

SQL Data Compare API 7.1.0
Fields Members
Fields Class Methods Properties Explicit Interface Implementations See Also

The Fields type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Fields Class


FileGroup Class

[image]

SQL Data Compare API 7.1.0
FileGroup Class
Members See Also

A filegroup.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileGroup
C#
public sealed class FileGroup
Visual C++
public ref class FileGroup sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.FileGroup

See Also

FileGroup Members


FileGroup Members

[image] [image]

SQL Data Compare API 7.1.0
FileGroup Members
FileGroup Class Methods Properties See Also

The FileGroup type exposes the following members.

Methods

Name | Description
Equals | Compares the filegroup with a specified filegroup. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | The name of the filegroup.

See Also

FileGroup Class


FileGroup Methods

[image] [image]

SQL Data Compare API 7.1.0
FileGroup Methods
FileGroup Class See Also

The FileGroup type exposes the following methods.

Methods

Name | Description
Equals | Compares the filegroup with a specified filegroup. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileGroup Class


Equals Method

[image]

SQL Data Compare API 7.1.0
FileGroup..::.Equals Method
FileGroup Class See Also

Compares the filegroup with a specified filegroup.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The filegroup to compare.

Return Value

True if the filegroups are identical; otherwise, false.

See Also

FileGroup Class


FileGroup Properties

[image] [image]

SQL Data Compare API 7.1.0
FileGroup Properties
FileGroup Class See Also

The FileGroup type exposes the following properties.

Properties

Name | Description
Name | The name of the filegroup.

See Also

FileGroup Class


Name Property

[image]

SQL Data Compare API 7.1.0
FileGroup..::.Name Property
FileGroup Class See Also

The name of the filegroup.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FileGroup Class


FileGroups Class

[image]

SQL Data Compare API 7.1.0
FileGroups Class
Members See Also

A collection of filegroups.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FileGroups _
    Inherits InnerList(Of FileGroup)
C#
public sealed class FileGroups : InnerList<FileGroup>
Visual C++
public ref class FileGroups sealed : public InnerList<FileGroup^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( FileGroup >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( FileGroup >)>)
RedGate.SQLCompare.Engine..::.FileGroups

See Also

FileGroups Members


FileGroups Members

[image] [image]

SQL Data Compare API 7.1.0
FileGroups Members
FileGroups Class Methods Properties Explicit Interface Implementations See Also

The FileGroups type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FileGroups Class


ForeignKey Class

[image]

SQL Data Compare API 7.1.0
ForeignKey Class
Members See Also

A foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKey
C#
public sealed class ForeignKey
Visual C++
public ref class ForeignKey sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ForeignKey

See Also

ForeignKey Members


ForeignKey Members

[image] [image]

SQL Data Compare API 7.1.0
ForeignKey Members
ForeignKey Class Methods Properties See Also

The ForeignKey type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeleteCascade | Obsolete. True if the foreign key is marked as on delete cascade.
DeleteReferentialAction | The referential action in case of a delete.
Disabled | True if the foreign key is disabled (it is set to NOCHECK).
Fields | The fields in the foreign key.
Name | The name of the foreign key.
NoCheck | True if the foreign key is not trusted (it was created using WITH NOCHECK).
NotForReplication | True if the foreign key is marked as not for replication.
ReferencedFields | The fields referenced by the foreign key.
ReferencedTable | The table referenced by the foreign key.
ScriptSource | The location of the creation script for object if the database source is set to scripts folder.
UpdateCascade | Obsolete. True if the foreign key is marked as on update cascade.
UpdateReferentialAction | The referential action in case of an update.

See Also

ForeignKey Class


ForeignKey Methods

[image] [image]

SQL Data Compare API 7.1.0
ForeignKey Methods
ForeignKey Class See Also

The ForeignKey type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ForeignKey Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ForeignKey..::.Equals Method
ForeignKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(ForeignKey, Options) | Compares the foreign key with a specified foreign key.

See Also

ForeignKey Class
ForeignKey Members


Equals Method (ForeignKey, Options)

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.Equals Method (ForeignKey, Options)
ForeignKey Class See Also

Compares the foreign key with a specified foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    value As ForeignKey, _
    options As Options _
) As Boolean
C#
public bool Equals(
    ForeignKey value,
    Options options
)
Visual C++
public:
bool Equals(
    ForeignKey^ value,
    Options options
)

Parameters

value
Type: RedGate.SQLCompare.Engine..::.ForeignKey
The foreign key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the foreign keys are identical; otherwise, false.

See Also

ForeignKey Class
Equals Overload


ForeignKey Properties

[image] [image]

SQL Data Compare API 7.1.0
ForeignKey Properties
ForeignKey Class See Also

The ForeignKey type exposes the following properties.

Properties

Name | Description
DeleteCascade | Obsolete. True if the foreign key is marked as on delete cascade.
DeleteReferentialAction | The referential action in case of a delete.
Disabled | True if the foreign key is disabled (it is set to NOCHECK).
Fields | The fields in the foreign key.
Name | The name of the foreign key.
NoCheck | True if the foreign key is not trusted (it was created using WITH NOCHECK).
NotForReplication | True if the foreign key is marked as not for replication.
ReferencedFields | The fields referenced by the foreign key.
ReferencedTable | The table referenced by the foreign key.
ScriptSource | The location of the creation script for object if the database source is set to scripts folder.
UpdateCascade | Obsolete. True if the foreign key is marked as on update cascade.
UpdateReferentialAction | The referential action in case of an update.

See Also

ForeignKey Class


DeleteCascade Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.DeleteCascade Property
ForeignKey Class See Also

True if the foreign key is marked as on delete cascade.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use DeleteReferentialAction.", False)> _
Public ReadOnly Property DeleteCascade As Boolean
C#
[ObsoleteAttribute("Use DeleteReferentialAction.", false)]
public bool DeleteCascade { get; }
Visual C++
[ObsoleteAttribute(L"Use DeleteReferentialAction.", false)]
public:
property bool DeleteCascade {
    bool get ();
}

See Also

ForeignKey Class


DeleteReferentialAction Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.DeleteReferentialAction Property
ForeignKey Class See Also

The referential action in case of a delete.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DeleteReferentialAction As ReferentialAction
C#
public ReferentialAction DeleteReferentialAction { get; internal set; }
Visual C++
public:
property ReferentialAction DeleteReferentialAction {
    ReferentialAction get ();
    void set (ReferentialAction value);
}

See Also

ForeignKey Class


Disabled Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.Disabled Property
ForeignKey Class See Also

True if the foreign key is disabled (it is set to NOCHECK).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As Boolean
C#
public bool Disabled { get; internal set; }
Visual C++
public:
property bool Disabled {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class


Fields Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.Fields Property
ForeignKey Class See Also

The fields in the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As Fields
C#
public Fields Fields { get; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
}

See Also

ForeignKey Class


Name Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.Name Property
ForeignKey Class See Also

The name of the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ForeignKey Class


NoCheck Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.NoCheck Property
ForeignKey Class See Also

True if the foreign key is not trusted (it was created using WITH NOCHECK).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCheck As Boolean
C#
public bool NoCheck { get; internal set; }
Visual C++
public:
property bool NoCheck {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class


NotForReplication Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.NotForReplication Property
ForeignKey Class See Also

True if the foreign key is marked as not for replication.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

ForeignKey Class


ReferencedFields Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.ReferencedFields Property
ForeignKey Class See Also

The fields referenced by the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReferencedFields As Fields
C#
public Fields ReferencedFields { get; }
Visual C++
public:
property Fields^ ReferencedFields {
    Fields^ get ();
}

See Also

ForeignKey Class


ReferencedTable Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.ReferencedTable Property
ForeignKey Class See Also

The table referenced by the foreign key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReferencedTable As Table
C#
public Table ReferencedTable { get; }
Visual C++
public:
property Table^ ReferencedTable {
    Table^ get ();
}

See Also

ForeignKey Class


ScriptSource Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.ScriptSource Property
ForeignKey Class See Also

The location of the creation script for object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ForeignKey Class


UpdateCascade Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.UpdateCascade Property
ForeignKey Class See Also

True if the foreign key is marked as on update cascade.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UpdateReferentialAction.", False)> _
Public ReadOnly Property UpdateCascade As Boolean
C#
[ObsoleteAttribute("Use UpdateReferentialAction.", false)]
public bool UpdateCascade { get; }
Visual C++
[ObsoleteAttribute(L"Use UpdateReferentialAction.", false)]
public:
property bool UpdateCascade {
    bool get ();
}

See Also

ForeignKey Class


UpdateReferentialAction Property

[image]

SQL Data Compare API 7.1.0
ForeignKey..::.UpdateReferentialAction Property
ForeignKey Class See Also

The referential action in case of an update.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpdateReferentialAction As ReferentialAction
C#
public ReferentialAction UpdateReferentialAction { get; internal set; }
Visual C++
public:
property ReferentialAction UpdateReferentialAction {
    ReferentialAction get ();
    void set (ReferentialAction value);
}

See Also

ForeignKey Class


ForeignKeys Class

[image]

SQL Data Compare API 7.1.0
ForeignKeys Class
Members See Also

A collection of foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ForeignKeys _
    Inherits SerializableCollection(Of ForeignKey)
C#
public sealed class ForeignKeys : SerializableCollection<ForeignKey>
Visual C++
public ref class ForeignKeys sealed : public SerializableCollection<ForeignKey^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ForeignKey >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ForeignKey >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ForeignKey >)>)
RedGate.SQLCompare.Engine..::.ForeignKeys

See Also

ForeignKeys Members


ForeignKeys Members

[image] [image]

SQL Data Compare API 7.1.0
ForeignKeys Members
ForeignKeys Class Methods Properties Explicit Interface Implementations See Also

The ForeignKeys type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ForeignKeys Class


ForeignKeys Properties

[image] [image]

SQL Data Compare API 7.1.0
ForeignKeys Properties
ForeignKeys Class See Also

The ForeignKeys type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

ForeignKeys Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
ForeignKeys..::.Item Property
ForeignKeys Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns a foreign key given its name (Overrides KeyedCollection <(Of <( ForeignKey >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

ForeignKeys Class
ForeignKeys Members


Item Property (String)

[image]

SQL Data Compare API 7.1.0
ForeignKeys..::.Item Property (String)
ForeignKeys Class See Also

Returns a foreign key given its name

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As ForeignKey
C#
public override ForeignKey this[
    string name
] { get; }
Visual C++
public:
virtual property ForeignKey^ default[String^ name] {
    ForeignKey^ get (String^ name) override;
}

Parameters

name
Type: System..::.String
The string-based index of the element to get or set.

See Also

ForeignKeys Class
Item Overload


FullTextCatalog Class

[image]

SQL Data Compare API 7.1.0
FullTextCatalog Class
Members See Also

A full text catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextCatalog _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class FullTextCatalog : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class FullTextCatalog sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.FullTextCatalog

See Also

FullTextCatalog Members


FullTextCatalog Members

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalog Members
FullTextCatalog Class Methods Fields Properties See Also

The FullTextCatalog type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FileGroup | The filegroup of the catalog. This is set only for SQL Server 2005 databases.
FullyQualifiedName | The fully-qualified name of the catalog. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsAccentSensitive | Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.
IsDefault | Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.FullTextCatalog (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Path | The path of the catalog. This is used only for SQL Server 2005 databases.
Permissions | The permissions on this catalog.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ViewsAndTables | The views and tables that belong to the catalog.

See Also

FullTextCatalog Class


FullTextCatalog Methods

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalog Methods
FullTextCatalog Class See Also

The FullTextCatalog type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextCatalog Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.Equals Method
FullTextCatalog Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the full text catalog with a specified full text catalog. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

FullTextCatalog Class
FullTextCatalog Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.Equals Method (IDatabaseObject, Options)
FullTextCatalog Class See Also

Compares the full text catalog with a specified full text catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The catalog to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the full text catalogs are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FullTextCatalog Class
Equals Overload


FullTextCatalog Properties

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalog Properties
FullTextCatalog Class See Also

The FullTextCatalog type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FileGroup | The filegroup of the catalog. This is set only for SQL Server 2005 databases.
FullyQualifiedName | The fully-qualified name of the catalog. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsAccentSensitive | Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.
IsDefault | Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.FullTextCatalog (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Path | The path of the catalog. This is used only for SQL Server 2005 databases.
Permissions | The permissions on this catalog.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
ViewsAndTables | The views and tables that belong to the catalog.

See Also

FullTextCatalog Class


FileGroup Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.FileGroup Property
FullTextCatalog Class See Also

The filegroup of the catalog. This is set only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalog Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.FullyQualifiedName Property
FullTextCatalog Class See Also

The fully-qualified name of the catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName
IDatabaseObject..::.FullyQualifiedName

See Also

FullTextCatalog Class


IsAccentSensitive Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.IsAccentSensitive Property
FullTextCatalog Class See Also

Indicates whether the catalog is accent sensitive. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsAccentSensitive As Boolean
C#
public bool IsAccentSensitive { get; internal set; }
Visual C++
public:
property bool IsAccentSensitive {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalog Class


IsDefault Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.IsDefault Property
FullTextCatalog Class See Also

Indicates whether the catalog is the default full text catalog. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDefault As Boolean
C#
public bool IsDefault { get; internal set; }
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

FullTextCatalog Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.ObjectType Property
FullTextCatalog Class See Also

Returns ObjectType.FullTextCatalog

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

FullTextCatalog Class


Path Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.Path Property
FullTextCatalog Class See Also

The path of the catalog. This is used only for SQL Server 2005 databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; internal set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextCatalog Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.Permissions Property
FullTextCatalog Class See Also

The permissions on this catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

FullTextCatalog Class


ViewsAndTables Property

[image]

SQL Data Compare API 7.1.0
FullTextCatalog..::.ViewsAndTables Property
FullTextCatalog Class See Also

The views and tables that belong to the catalog.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ViewsAndTables As ViewsAndTables
C#
public ViewsAndTables ViewsAndTables { get; }
Visual C++
public:
property ViewsAndTables^ ViewsAndTables {
    ViewsAndTables^ get ();
}

See Also

FullTextCatalog Class


FullTextCatalogs Class

[image]

SQL Data Compare API 7.1.0
FullTextCatalogs Class
Members See Also

A collection of full text catalogs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextCatalogs _
    Inherits SerializableDatabaseObjectCollection(Of FullTextCatalog)
C#
public sealed class FullTextCatalogs : SerializableDatabaseObjectCollection<FullTextCatalog>
Visual C++
public ref class FullTextCatalogs sealed : public SerializableDatabaseObjectCollection<FullTextCatalog^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( FullTextCatalog >)>)
RedGate.SQLCompare.Engine..::.FullTextCatalogs

See Also

FullTextCatalogs Members


FullTextCatalogs Members

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalogs Members
FullTextCatalogs Class Methods Properties Explicit Interface Implementations See Also

The FullTextCatalogs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FullTextCatalogs Class


FullTextChangeTracking Enumeration

[image]

SQL Data Compare API 7.1.0
FullTextChangeTracking Enumeration
See Also

The type of change tracking applied to the full text index on a view or table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FullTextChangeTracking
C#
public enum FullTextChangeTracking
Visual C++
public enum class FullTextChangeTracking

Members

Member name | Description
Off | Change tracking is disabled.
Manual | The change tracking log is propagated manually
Auto | The full text index is updated automatically.

See Also


FullTextStoplist Class

[image]

SQL Data Compare API 7.1.0
FullTextStoplist Class
Members See Also

A full text stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStoplist _
    Inherits DatabaseObjectWithAuthorization
C#
public sealed class FullTextStoplist : DatabaseObjectWithAuthorization
Visual C++
public ref class FullTextStoplist sealed : public DatabaseObjectWithAuthorization

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.FullTextStoplist

See Also

FullTextStoplist Members


FullTextStoplist Members

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplist Members
FullTextStoplist Class Methods Fields Properties See Also

The FullTextStoplist type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the stoplist. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Stopwords | Returns the words in this stoplist.

See Also

FullTextStoplist Class


FullTextStoplist Methods

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplist Methods
FullTextStoplist Class See Also

The FullTextStoplist type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FullTextStoplist Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.Equals Method
FullTextStoplist Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

FullTextStoplist Class
FullTextStoplist Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.Equals Method (IDatabaseObject, Options)
FullTextStoplist Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

FullTextStoplist Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.ScriptObject Method
FullTextStoplist Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.

Return Value

Regions that contain the script.

See Also

FullTextStoplist Class


FullTextStoplist Properties

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplist Properties
FullTextStoplist Class See Also

The FullTextStoplist type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the stoplist. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Stopwords | Returns the words in this stoplist.

See Also

FullTextStoplist Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.FullyQualifiedName Property
FullTextStoplist Class See Also

The fully-qualified name of the stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

FullTextStoplist Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.ObjectType Property
FullTextStoplist Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType

See Also

FullTextStoplist Class


Stopwords Property

[image]

SQL Data Compare API 7.1.0
FullTextStoplist..::.Stopwords Property
FullTextStoplist Class See Also

Returns the words in this stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stopwords As FullTextStopwords
C#
public FullTextStopwords Stopwords { get; }
Visual C++
public:
property FullTextStopwords^ Stopwords {
    FullTextStopwords^ get ();
}

See Also

FullTextStoplist Class


FullTextStoplists Class

[image]

SQL Data Compare API 7.1.0
FullTextStoplists Class
Members See Also

A collection of full text stoplists.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStoplists _
    Inherits SerializableDatabaseObjectCollection(Of FullTextStoplist)
C#
public sealed class FullTextStoplists : SerializableDatabaseObjectCollection<FullTextStoplist>
Visual C++
public ref class FullTextStoplists sealed : public SerializableDatabaseObjectCollection<FullTextStoplist^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( FullTextStoplist >)>)
RedGate.SQLCompare.Engine..::.FullTextStoplists

See Also

FullTextStoplists Members


FullTextStoplists Members

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplists Members
FullTextStoplists Class Methods Properties Explicit Interface Implementations See Also

The FullTextStoplists type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FullTextStoplists Class


FullTextStoplistType Enumeration

[image]

SQL Data Compare API 7.1.0
FullTextStoplistType Enumeration
See Also

The stoplist used by the full text index on a view or table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FullTextStoplistType
C#
public enum FullTextStoplistType
Visual C++
public enum class FullTextStoplistType

Members

Member name | Description
None | No stoplist is used for the fulltext index.
System | The system stoplist is used.
UserDefined | A user-defined stoplist is used.

See Also


FullTextStopwords Class

[image]

SQL Data Compare API 7.1.0
FullTextStopwords Class
Members See Also

A collection of stopwords associated with a full text stoplist.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FullTextStopwords _
    Inherits EnumerableBase(Of KeyValuePair(Of Integer, ICollection(Of String)))
C#
public sealed class FullTextStopwords : EnumerableBase<KeyValuePair<int, ICollection<string>>>
Visual C++
public ref class FullTextStopwords sealed : public EnumerableBase<KeyValuePair<int, ICollection<String^>^>>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( KeyValuePair <(Of <( Int32, ICollection <(Of <( String >)>)>)>)>)>)
RedGate.SQLCompare.Engine..::.FullTextStopwords

See Also

FullTextStopwords Members


FullTextStopwords Members

[image] [image]

SQL Data Compare API 7.1.0
FullTextStopwords Members
FullTextStopwords Class Methods Properties Explicit Interface Implementations See Also

The FullTextStopwords type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator of the languages in this stoplist and the stopwords associated with each language. (Overrides EnumerableBase <(Of <( KeyValuePair <(Of <( Int32, ICollection <(Of <( String >)>)>)>)>)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | A collection of stopwords associated with the specified LCID.
Languages | The LCIDs of the languages in this collection.
TotalStopwords | The total number of stopwords in this collection.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FullTextStopwords Class


FullTextStopwords Methods

[image] [image]

SQL Data Compare API 7.1.0
FullTextStopwords Methods
FullTextStopwords Class See Also

The FullTextStopwords type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator of the languages in this stoplist and the stopwords associated with each language. (Overrides EnumerableBase <(Of <( KeyValuePair <(Of <( Int32, ICollection <(Of <( String >)>)>)>)>)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FullTextStopwords Class


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
FullTextStopwords..::.GetEnumerator Method
FullTextStopwords Class See Also

Returns an enumerator of the languages in this stoplist and the stopwords associated with each language.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator(Of KeyValuePair(Of Integer, ICollection(Of String)))
C#
public override IEnumerator<KeyValuePair<int, ICollection<string>>> GetEnumerator()
Visual C++
public:
virtual IEnumerator<KeyValuePair<int, ICollection<String^>^>>^ GetEnumerator() override

Return Value

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

FullTextStopwords Class


FullTextStopwords Properties

[image] [image]

SQL Data Compare API 7.1.0
FullTextStopwords Properties
FullTextStopwords Class See Also

The FullTextStopwords type exposes the following properties.

Properties

Name | Description
Item | A collection of stopwords associated with the specified LCID.
Languages | The LCIDs of the languages in this collection.
TotalStopwords | The total number of stopwords in this collection.

See Also

FullTextStopwords Class


Item Property

[image]

SQL Data Compare API 7.1.0
FullTextStopwords..::.Item Property
FullTextStopwords Class See Also

A collection of stopwords associated with the specified LCID.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    language As Integer _
) As ICollection(Of String)
C#
public ICollection<string> this[
    int language
] { get; }
Visual C++
public:
property ICollection<String^>^ default[int language] {
    ICollection<String^>^ get (int language);
}

Parameters

language
Type: System..::.Int32
The LCID of the stopwords to return.

Return Value

A collection of stopwords for the specified LCID.

See Also

FullTextStopwords Class


Languages Property

[image]

SQL Data Compare API 7.1.0
FullTextStopwords..::.Languages Property
FullTextStopwords Class See Also

The LCIDs of the languages in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Languages As ICollection(Of Integer)
C#
public ICollection<int> Languages { get; }
Visual C++
public:
property ICollection<int>^ Languages {
    ICollection<int>^ get ();
}

See Also

FullTextStopwords Class


TotalStopwords Property

[image]

SQL Data Compare API 7.1.0
FullTextStopwords..::.TotalStopwords Property
FullTextStopwords Class See Also

The total number of stopwords in this collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalStopwords As Integer
C#
public int TotalStopwords { get; }
Visual C++
public:
property int TotalStopwords {
    int get ();
}

See Also

FullTextStopwords Class


Function Class

[image]

SQL Data Compare API 7.1.0
Function Class
Members See Also

A user-defined function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Function _
    Inherits SchemaObjectWithAuthorization _
    Implements IExecuteAs, IIsSystemObject, IHasPermissions, IDatabaseObject
C#
public sealed class Function : SchemaObjectWithAuthorization, IExecuteAs,
    IIsSystemObject, IHasPermissions, IDatabaseObject
Visual C++
public ref class Function sealed : public SchemaObjectWithAuthorization,
    IExecuteAs, IIsSystemObject, IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Function

See Also

Function Members


Function Members

[image] [image]

SQL Data Compare API 7.1.0
Function Members
Function Class Methods Fields Properties See Also

The Function type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AnsiNullsOn | True if the function was created with ansi nulls on.
Assembly | The CLR assembly for the function, if this is a CLR function.
AssemblyClass | The CLR assembly class name for the function, if this is a CLR function.
AssemblyMethod | The CLR assembly method name for the function, if this is a CLR function.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the function is a CLR function.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the function definition was encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
FunctionType | Returns the function type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
NullOnNullInput | The function returns NULL on NULL input.
ObjectType | Returns ObjectType.Function (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The function parameters.
Permissions | The permissions on this function.
QuotedIdentifierOn | True if the function was created with quoted identifiers on.
ReturnFields | The function's return fields.
ReturnParameter | The function's return parameter.
SchemaBound | True if the function is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Text | The text of the function.

See Also

Function Class


Function Methods

[image] [image]

SQL Data Compare API 7.1.0
Function Methods
Function Class See Also

The Function type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

Function Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Function..::.Equals Method
Function Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the function with a specified function. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Function Class
Function Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Function..::.Equals Method (IDatabaseObject, Options)
Function Class See Also

Compares the function with a specified function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The function to compare with.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the functions are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Function Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Function..::.ScriptObject Method
Function Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Function Class


Function Properties

[image] [image]

SQL Data Compare API 7.1.0
Function Properties
Function Class See Also

The Function type exposes the following properties.

Properties

Name | Description
AnsiNullsOn | True if the function was created with ansi nulls on.
Assembly | The CLR assembly for the function, if this is a CLR function.
AssemblyClass | The CLR assembly class name for the function, if this is a CLR function.
AssemblyMethod | The CLR assembly method name for the function, if this is a CLR function.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the function is a CLR function.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the function definition was encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
FunctionType | Returns the function type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
NullOnNullInput | The function returns NULL on NULL input.
ObjectType | Returns ObjectType.Function (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The function parameters.
Permissions | The permissions on this function.
QuotedIdentifierOn | True if the function was created with quoted identifiers on.
ReturnFields | The function's return fields.
ReturnParameter | The function's return parameter.
SchemaBound | True if the function is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Text | The text of the function.

See Also

Function Class


AnsiNullsOn Property

[image]

SQL Data Compare API 7.1.0
Function..::.AnsiNullsOn Property
Function Class See Also

True if the function was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Function Class


Assembly Property

[image]

SQL Data Compare API 7.1.0
Function..::.Assembly Property
Function Class See Also

The CLR assembly for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

Function Class


AssemblyClass Property

[image]

SQL Data Compare API 7.1.0
Function..::.AssemblyClass Property
Function Class See Also

The CLR assembly class name for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

Function Class


AssemblyMethod Property

[image]

SQL Data Compare API 7.1.0
Function..::.AssemblyMethod Property
Function Class See Also

The CLR assembly method name for the function, if this is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

Function Class


CLRObject Property

[image]

SQL Data Compare API 7.1.0
Function..::.CLRObject Property
Function Class See Also

True if the function is a CLR function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Function Class


Encrypted Property

[image]

SQL Data Compare API 7.1.0
Function..::.Encrypted Property
Function Class See Also

True if the function definition was encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Function Class


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
Function..::.ExecuteAs Property
Function Class See Also

The user whose security context is to be used for the execution of the function. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Function Class


FunctionType Property

[image]

SQL Data Compare API 7.1.0
Function..::.FunctionType Property
Function Class See Also

Returns the function type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionType As FunctionType
C#
public FunctionType FunctionType { get; internal set; }
Visual C++
public:
property FunctionType FunctionType {
    FunctionType get ();
    void set (FunctionType value);
}

See Also

Function Class


NullOnNullInput Property

[image]

SQL Data Compare API 7.1.0
Function..::.NullOnNullInput Property
Function Class See Also

The function returns NULL on NULL input.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NullOnNullInput As Boolean
C#
public bool NullOnNullInput { get; internal set; }
Visual C++
public:
property bool NullOnNullInput {
    bool get ();
    void set (bool value);
}

See Also

Function Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Function..::.ObjectType Property
Function Class See Also

Returns ObjectType.Function

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Function Class


Parameters Property

[image]

SQL Data Compare API 7.1.0
Function..::.Parameters Property
Function Class See Also

The function parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

Function Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Function..::.Permissions Property
Function Class See Also

The permissions on this function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Function Class


QuotedIdentifierOn Property

[image]

SQL Data Compare API 7.1.0
Function..::.QuotedIdentifierOn Property
Function Class See Also

True if the function was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Function Class


ReturnFields Property

[image]

SQL Data Compare API 7.1.0
Function..::.ReturnFields Property
Function Class See Also

The function's return fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnFields As Fields
C#
public Fields ReturnFields { get; internal set; }
Visual C++
public:
property Fields^ ReturnFields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

Function Class


ReturnParameter Property

[image]

SQL Data Compare API 7.1.0
Function..::.ReturnParameter Property
Function Class See Also

The function's return parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnParameter As Parameter
C#
public Parameter ReturnParameter { get; internal set; }
Visual C++
public:
property Parameter^ ReturnParameter {
    Parameter^ get ();
    void set (Parameter^ value);
}

See Also

Function Class


SchemaBound Property

[image]

SQL Data Compare API 7.1.0
Function..::.SchemaBound Property
Function Class See Also

True if the function is schema bound.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; internal set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

Function Class


Text Property

[image]

SQL Data Compare API 7.1.0
Function..::.Text Property
Function Class See Also

The text of the function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

See Also

Function Class


Functions Class

[image]

SQL Data Compare API 7.1.0
Functions Class
Members See Also

A collection of functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Functions _
    Inherits SerializableDatabaseObjectCollection(Of Function)
C#
public sealed class Functions : SerializableDatabaseObjectCollection<Function>
Visual C++
public ref class Functions sealed : public SerializableDatabaseObjectCollection<Function^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Function >)>)
RedGate.SQLCompare.Engine..::.Functions

See Also

Functions Members


Functions Members

[image] [image]

SQL Data Compare API 7.1.0
Functions Members
Functions Class Methods Properties Explicit Interface Implementations See Also

The Functions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Functions Class


FunctionType Enumeration

[image]

SQL Data Compare API 7.1.0
FunctionType Enumeration
See Also

The type of function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FunctionType
C#
public enum FunctionType
Visual C++
public enum class FunctionType

Members

Member name | Description
Unknown | Unknown
Inline | An inline function.
Scalar | A scalar function.
Table | A table function.
Aggregate | An aggregate.

See Also


IDatabaseObject Interface

[image]

SQL Data Compare API 7.1.0
IDatabaseObject Interface
Members See Also

An interface implemented by database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseObject
C#
public interface IDatabaseObject
Visual C++
public interface class IDatabaseObject

See Also

IDatabaseObject Members


IDatabaseObject Members

[image] [image]

SQL Data Compare API 7.1.0
IDatabaseObject Members
IDatabaseObject Interface Methods Properties See Also

The IDatabaseObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object.
Name | The name of the object.
ObjectType | The type of the object.
Owner | The owner or schema of the object.

See Also

IDatabaseObject Interface


IDatabaseObject Methods

[image] [image]

SQL Data Compare API 7.1.0
IDatabaseObject Methods
IDatabaseObject Interface See Also

The IDatabaseObject type exposes the following methods.

Methods

Name | Description
Equals | Compares two database objects.

See Also

IDatabaseObject Interface


Equals Method

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.Equals Method
IDatabaseObject Interface See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
bool Equals(
    IDatabaseObject^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

See Also

IDatabaseObject Interface


IDatabaseObject Properties

[image] [image]

SQL Data Compare API 7.1.0
IDatabaseObject Properties
IDatabaseObject Interface See Also

The IDatabaseObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object.
Name | The name of the object.
ObjectType | The type of the object.
Owner | The owner or schema of the object.

See Also

IDatabaseObject Interface


Database Property

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.Database Property
IDatabaseObject Interface See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Database As Database
C#
Database Database { get; }
Visual C++
property Database^ Database {
    Database^ get ();
}

See Also

IDatabaseObject Interface


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.FullyQualifiedName Property
IDatabaseObject Interface See Also

The fully-qualified name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullyQualifiedName As String
C#
string FullyQualifiedName { get; }
Visual C++
property String^ FullyQualifiedName {
    String^ get ();
}

See Also

IDatabaseObject Interface


Name Property

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.Name Property
IDatabaseObject Interface See Also

The name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IDatabaseObject Interface


ObjectType Property

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.ObjectType Property
IDatabaseObject Interface See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ObjectType As ObjectType
C#
ObjectType ObjectType { get; }
Visual C++
property ObjectType ObjectType {
    ObjectType get ();
}

See Also

IDatabaseObject Interface


Owner Property

[image]

SQL Data Compare API 7.1.0
IDatabaseObject..::.Owner Property
IDatabaseObject Interface See Also

The owner or schema of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Owner As String
C#
string Owner { get; }
Visual C++
property String^ Owner {
    String^ get ();
}

See Also

IDatabaseObject Interface


IDatabaseObjects(T) Generic Interface

[image]

SQL Data Compare API 7.1.0
IDatabaseObjects<(Of <(T>)>) Generic Interface
Members See Also

A collection of database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDatabaseObjects(Of T As IDatabaseObject) _
    Implements IEnumerable(Of T), IEnumerable
C#
public interface IDatabaseObjects<T> : IEnumerable<T>,
    IEnumerable where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
public interface class IDatabaseObjects : IEnumerable<T>,
    IEnumerable

Type Parameters

T

See Also

IDatabaseObjects<(Of <(T>)>) Members


IDatabaseObjects(T) Members

[image] [image]

SQL Data Compare API 7.1.0
IDatabaseObjects<(Of <(T>)>) Members
IDatabaseObjects<(Of <(T>)>) Interface Methods See Also

Methods

Name | Description
GetEnumerator | Overloaded.

See Also

IDatabaseObjects<(Of <(T>)>) Interface


IExecuteAs Interface

[image]

SQL Data Compare API 7.1.0
IExecuteAs Interface
Members See Also

Used by database objects that can be executed as a specific user. This is used only for SQL Server 2005.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExecuteAs _
    Implements IDatabaseObject
C#
public interface IExecuteAs : IDatabaseObject
Visual C++
public interface class IExecuteAs : IDatabaseObject

See Also

IExecuteAs Members


IExecuteAs Members

[image] [image]

SQL Data Compare API 7.1.0
IExecuteAs Members
IExecuteAs Interface Methods Properties See Also

The IExecuteAs type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
ExecuteAs | The user whose security context is to be used.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IExecuteAs Interface


IExecuteAs Properties

[image] [image]

SQL Data Compare API 7.1.0
IExecuteAs Properties
IExecuteAs Interface See Also

The IExecuteAs type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
ExecuteAs | The user whose security context is to be used.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IExecuteAs Interface


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
IExecuteAs..::.ExecuteAs Property
IExecuteAs Interface See Also

The user whose security context is to be used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ExecuteAs As User
C#
User ExecuteAs { get; }
Visual C++
property User^ ExecuteAs {
    User^ get ();
}

See Also

IExecuteAs Interface


IHasAuthorization Interface

[image]

SQL Data Compare API 7.1.0
IHasAuthorization Interface
Members See Also

Marks objects that have an owner instead of a schema. Note that some objects can have both an owner and a schema; in this instance, SchemaObjectWithAuthorization is used instead.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasAuthorization _
    Implements IDatabaseObject
C#
public interface IHasAuthorization : IDatabaseObject
Visual C++
public interface class IHasAuthorization : IDatabaseObject

See Also

IHasAuthorization Members


IHasAuthorization Members

[image] [image]

SQL Data Compare API 7.1.0
IHasAuthorization Members
IHasAuthorization Interface Methods Properties See Also

The IHasAuthorization type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IHasAuthorization Interface


IHasPermissions Interface

[image]

SQL Data Compare API 7.1.0
IHasPermissions Interface
Members See Also

The database object may have permissions associated with it.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHasPermissions _
    Implements IDatabaseObject
C#
public interface IHasPermissions : IDatabaseObject
Visual C++
public interface class IHasPermissions : IDatabaseObject

See Also

IHasPermissions Members


IHasPermissions Members

[image] [image]

SQL Data Compare API 7.1.0
IHasPermissions Members
IHasPermissions Interface Methods Properties See Also

The IHasPermissions type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)
Permissions | The permissions of the object.

See Also

IHasPermissions Interface


IHasPermissions Properties

[image] [image]

SQL Data Compare API 7.1.0
IHasPermissions Properties
IHasPermissions Interface See Also

The IHasPermissions type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)
Permissions | The permissions of the object.

See Also

IHasPermissions Interface


Permissions Property

[image]

SQL Data Compare API 7.1.0
IHasPermissions..::.Permissions Property
IHasPermissions Interface See Also

The permissions of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Permissions As Permissions
C#
Permissions Permissions { get; }
Visual C++
property Permissions^ Permissions {
    Permissions^ get ();
}

See Also

IHasPermissions Interface


IIsSystemObject Interface

[image]

SQL Data Compare API 7.1.0
IIsSystemObject Interface
Members See Also

Indicates that an object instance is a system object when implemented by a class.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IIsSystemObject _
    Implements IDatabaseObject
C#
public interface IIsSystemObject : IDatabaseObject
Visual C++
public interface class IIsSystemObject : IDatabaseObject

See Also

IIsSystemObject Members


IIsSystemObject Members

[image] [image]

SQL Data Compare API 7.1.0
IIsSystemObject Members
IIsSystemObject Interface Methods Properties See Also

The IIsSystemObject type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
IsSystemObject | Indicates that the object is a system object.
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IIsSystemObject Interface


IIsSystemObject Properties

[image] [image]

SQL Data Compare API 7.1.0
IIsSystemObject Properties
IIsSystemObject Interface See Also

The IIsSystemObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
IsSystemObject | Indicates that the object is a system object.
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IIsSystemObject Interface


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
IIsSystemObject..::.IsSystemObject Property
IIsSystemObject Interface See Also

Indicates that the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSystemObject As Boolean
C#
bool IsSystemObject { get; }
Visual C++
property bool IsSystemObject {
    bool get ();
}

See Also

IIsSystemObject Interface


Index Class

[image]

SQL Data Compare API 7.1.0
Index Class
Members See Also

An index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Index _
    Implements IDatabaseObject
C#
public sealed class Index : IDatabaseObject
Visual C++
public ref class Index sealed : IDatabaseObject

Remarks

Primary keys, unique constraints, and statistics are considered to be special types of index.

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Index

See Also

Index Members


Index Members

[image] [image]

SQL Data Compare API 7.1.0
Index Members
Index Class Methods Properties Explicit Interface Implementations See Also

The Index type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowPageLocks | True if the index allows page locks.
AllowRowLocks | True if the index allows row locks.
Clustered | True if the index is clustered.
Database | The database to which the index belongs.
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
Fields | The fields in the index.
FileGroup | The filegroup or the partition scheme on which the index is defined.
FilestreamFileGroup | The filegroup or partition scheme containing filestream data.
FillFactor | The fill factor.
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullTextKey | True if the index is used in a full-text key.
FullyQualifiedName | The fully-qualified name of the index.
IgnoreDuplicateKeys | True if set to ignore duplicate keys.
IsDisabled | Indicates whether the index is disabled.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the filegroup property.
Name | The name of the index.
NoRecompute | True if the index is defined with NORECOMPUTE.
ObjectType | Returns ObjectType.Index
Owner | The owner of the index. This is undefined.
Pad | The index padding.
PartitionedField | Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.
PrimaryKey | True if the index is a primary key.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
Spatial | True if the index is a spatial index.
SpatialIndexInformation | The spatial index information, if this is a spatial index.
Statistics | True if the index is a statistic.
Unique | True if the index is unique.
UniqueConstraint | True if the index is a unique constraint.
Xml | True if the index is an XML index.
XmlIndexType | The type of the XML index. This type can be Value, Path, Property, or None.
XmlPrimaryIndex | The primary XML index, if this index is a secondary XML index.

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Index Class


Index Methods

[image] [image]

SQL Data Compare API 7.1.0
Index Methods
Index Class See Also

The Index type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Index Class


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 7.1.0
Index..::.IDatabaseObject..::.Equals Method
Index Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Index Class


Index Properties

[image] [image]

SQL Data Compare API 7.1.0
Index Properties
Index Class See Also

The Index type exposes the following properties.

Properties

Name | Description
AllowPageLocks | True if the index allows page locks.
AllowRowLocks | True if the index allows row locks.
Clustered | True if the index is clustered.
Database | The database to which the index belongs.
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
Fields | The fields in the index.
FileGroup | The filegroup or the partition scheme on which the index is defined.
FilestreamFileGroup | The filegroup or partition scheme containing filestream data.
FillFactor | The fill factor.
Filter | The filtering condition on the index. This property exists in SQL Server 2008 and later.
FullTextKey | True if the index is used in a full-text key.
FullyQualifiedName | The fully-qualified name of the index.
IgnoreDuplicateKeys | True if set to ignore duplicate keys.
IsDisabled | Indicates whether the index is disabled.
IsPartitioned | Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the filegroup property.
Name | The name of the index.
NoRecompute | True if the index is defined with NORECOMPUTE.
ObjectType | Returns ObjectType.Index
Owner | The owner of the index. This is undefined.
Pad | The index padding.
PartitionedField | Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.
PrimaryKey | True if the index is a primary key.
ScriptSource | The location of the creation script for this object if the database source is set to scripts folder.
Spatial | True if the index is a spatial index.
SpatialIndexInformation | The spatial index information, if this is a spatial index.
Statistics | True if the index is a statistic.
Unique | True if the index is unique.
UniqueConstraint | True if the index is a unique constraint.
Xml | True if the index is an XML index.
XmlIndexType | The type of the XML index. This type can be Value, Path, Property, or None.
XmlPrimaryIndex | The primary XML index, if this index is a secondary XML index.

See Also

Index Class


AllowPageLocks Property

[image]

SQL Data Compare API 7.1.0
Index..::.AllowPageLocks Property
Index Class See Also

True if the index allows page locks.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowPageLocks As Boolean
C#
public bool AllowPageLocks { get; internal set; }
Visual C++
public:
property bool AllowPageLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class


AllowRowLocks Property

[image]

SQL Data Compare API 7.1.0
Index..::.AllowRowLocks Property
Index Class See Also

True if the index allows row locks.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowRowLocks As Boolean
C#
public bool AllowRowLocks { get; internal set; }
Visual C++
public:
property bool AllowRowLocks {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Clustered Property

[image]

SQL Data Compare API 7.1.0
Index..::.Clustered Property
Index Class See Also

True if the index is clustered.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clustered As Boolean
C#
public bool Clustered { get; internal set; }
Visual C++
public:
property bool Clustered {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Database Property

[image]

SQL Data Compare API 7.1.0
Index..::.Database Property
Index Class See Also

The database to which the index belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database As Database
C#
public Database Database { get; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
}

Implements

IDatabaseObject..::.Database

See Also

Index Class


DataCompressionPartitions Property

[image]

SQL Data Compare API 7.1.0
Index..::.DataCompressionPartitions Property
Index Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataCompressionPartitions As IDictionary(Of Integer, DataCompression)
C#
public IDictionary<int, DataCompression> DataCompressionPartitions { get; }
Visual C++
public:
property IDictionary<int, DataCompression>^ DataCompressionPartitions {
    IDictionary<int, DataCompression>^ get ();
}

See Also

Index Class


Fields Property

[image]

SQL Data Compare API 7.1.0
Index..::.Fields Property
Index Class See Also

The fields in the index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As Fields
C#
public Fields Fields { get; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
}

See Also

Index Class


FileGroup Property

[image]

SQL Data Compare API 7.1.0
Index..::.FileGroup Property
Index Class See Also

The filegroup or the partition scheme on which the index is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Index Class


FilestreamFileGroup Property

[image]

SQL Data Compare API 7.1.0
Index..::.FilestreamFileGroup Property
Index Class See Also

The filegroup or partition scheme containing filestream data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilestreamFileGroup As String
C#
public string FilestreamFileGroup { get; internal set; }
Visual C++
public:
property String^ FilestreamFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Index Class


FillFactor Property

[image]

SQL Data Compare API 7.1.0
Index..::.FillFactor Property
Index Class See Also

The fill factor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FillFactor As Byte
C#
public byte FillFactor { get; internal set; }
Visual C++
public:
property unsigned char FillFactor {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Index Class


Filter Property

[image]

SQL Data Compare API 7.1.0
Index..::.Filter Property
Index Class See Also

The filtering condition on the index. This property exists in SQL Server 2008 and later.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; internal set; }
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

Index Class


FullTextKey Property

[image]

SQL Data Compare API 7.1.0
Index..::.FullTextKey Property
Index Class See Also

True if the index is used in a full-text key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextKey As Boolean
C#
public bool FullTextKey { get; internal set; }
Visual C++
public:
property bool FullTextKey {
    bool get ();
    void set (bool value);
}

See Also

Index Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
Index..::.FullyQualifiedName Property
Index Class See Also

The fully-qualified name of the index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

Index Class


IgnoreDuplicateKeys Property

[image]

SQL Data Compare API 7.1.0
Index..::.IgnoreDuplicateKeys Property
Index Class See Also

True if set to ignore duplicate keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreDuplicateKeys As Boolean
C#
public bool IgnoreDuplicateKeys { get; internal set; }
Visual C++
public:
property bool IgnoreDuplicateKeys {
    bool get ();
    void set (bool value);
}

See Also

Index Class


IsDisabled Property

[image]

SQL Data Compare API 7.1.0
Index..::.IsDisabled Property
Index Class See Also

Indicates whether the index is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

Index Class


IsPartitioned Property

[image]

SQL Data Compare API 7.1.0
Index..::.IsPartitioned Property
Index Class See Also

Indicates whether the index is built on a partition scheme. If it is, the name of the partition scheme is returned by the filegroup property.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPartitioned As Boolean
C#
public bool IsPartitioned { get; internal set; }
Visual C++
public:
property bool IsPartitioned {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Name Property

[image]

SQL Data Compare API 7.1.0
Index..::.Name Property
Index Class See Also

The name of the index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseObject..::.Name

See Also

Index Class


NoRecompute Property

[image]

SQL Data Compare API 7.1.0
Index..::.NoRecompute Property
Index Class See Also

True if the index is defined with NORECOMPUTE.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NoRecompute As Boolean
C#
public bool NoRecompute { get; internal set; }
Visual C++
public:
property bool NoRecompute {
    bool get ();
    void set (bool value);
}

See Also

Index Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Index..::.ObjectType Property
Index Class See Also

Returns ObjectType.Index

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

IDatabaseObject..::.ObjectType

See Also

Index Class


Owner Property

[image]

SQL Data Compare API 7.1.0
Index..::.Owner Property
Index Class See Also

The owner of the index. This is undefined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As String
C#
public string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.Owner

See Also

Index Class


Pad Property

[image]

SQL Data Compare API 7.1.0
Index..::.Pad Property
Index Class See Also

The index padding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Pad As Boolean
C#
public bool Pad { get; internal set; }
Visual C++
public:
property bool Pad {
    bool get ();
    void set (bool value);
}

See Also

Index Class


PartitionedField Property

[image]

SQL Data Compare API 7.1.0
Index..::.PartitionedField Property
Index Class See Also

Indicates the field over which the index is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionedField As Field
C#
public Field PartitionedField { get; internal set; }
Visual C++
public:
property Field^ PartitionedField {
    Field^ get ();
    void set (Field^ value);
}

See Also

Index Class


PrimaryKey Property

[image]

SQL Data Compare API 7.1.0
Index..::.PrimaryKey Property
Index Class See Also

True if the index is a primary key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PrimaryKey As Boolean
C#
public bool PrimaryKey { get; internal set; }
Visual C++
public:
property bool PrimaryKey {
    bool get ();
    void set (bool value);
}

See Also

Index Class


ScriptSource Property

[image]

SQL Data Compare API 7.1.0
Index..::.ScriptSource Property
Index Class See Also

The location of the creation script for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Index Class


Spatial Property

[image]

SQL Data Compare API 7.1.0
Index..::.Spatial Property
Index Class See Also

True if the index is a spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Spatial As Boolean
C#
public bool Spatial { get; }
Visual C++
public:
property bool Spatial {
    bool get ();
}

See Also

Index Class


SpatialIndexInformation Property

[image]

SQL Data Compare API 7.1.0
Index..::.SpatialIndexInformation Property
Index Class See Also

The spatial index information, if this is a spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SpatialIndexInformation As SpatialIndexInformation
C#
public SpatialIndexInformation SpatialIndexInformation { get; internal set; }
Visual C++
public:
property SpatialIndexInformation^ SpatialIndexInformation {
    SpatialIndexInformation^ get ();
    void set (SpatialIndexInformation^ value);
}

See Also

Index Class


Statistics Property

[image]

SQL Data Compare API 7.1.0
Index..::.Statistics Property
Index Class See Also

True if the index is a statistic.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Statistics As Boolean
C#
public bool Statistics { get; internal set; }
Visual C++
public:
property bool Statistics {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Unique Property

[image]

SQL Data Compare API 7.1.0
Index..::.Unique Property
Index Class See Also

True if the index is unique.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Unique As Boolean
C#
public bool Unique { get; internal set; }
Visual C++
public:
property bool Unique {
    bool get ();
    void set (bool value);
}

See Also

Index Class


UniqueConstraint Property

[image]

SQL Data Compare API 7.1.0
Index..::.UniqueConstraint Property
Index Class See Also

True if the index is a unique constraint.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UniqueConstraint As Boolean
C#
public bool UniqueConstraint { get; internal set; }
Visual C++
public:
property bool UniqueConstraint {
    bool get ();
    void set (bool value);
}

See Also

Index Class


Xml Property

[image]

SQL Data Compare API 7.1.0
Index..::.Xml Property
Index Class See Also

True if the index is an XML index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Xml As Boolean
C#
public bool Xml { get; internal set; }
Visual C++
public:
property bool Xml {
    bool get ();
    void set (bool value);
}

See Also

Index Class


XmlIndexType Property

[image]

SQL Data Compare API 7.1.0
Index..::.XmlIndexType Property
Index Class See Also

The type of the XML index. This type can be Value, Path, Property, or None.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlIndexType As XmlIndexType
C#
public XmlIndexType XmlIndexType { get; internal set; }
Visual C++
public:
property XmlIndexType XmlIndexType {
    XmlIndexType get ();
    void set (XmlIndexType value);
}

See Also

Index Class


XmlPrimaryIndex Property

[image]

SQL Data Compare API 7.1.0
Index..::.XmlPrimaryIndex Property
Index Class See Also

The primary XML index, if this index is a secondary XML index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlPrimaryIndex As Index
C#
public Index XmlPrimaryIndex { get; internal set; }
Visual C++
public:
property Index^ XmlPrimaryIndex {
    Index^ get ();
    void set (Index^ value);
}

See Also

Index Class


Indexes Class

[image]

SQL Data Compare API 7.1.0
Indexes Class
Members See Also

A collection of indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Indexes _
    Inherits SerializableCollection(Of Index)
C#
public sealed class Indexes : SerializableCollection<Index>
Visual C++
public ref class Indexes sealed : public SerializableCollection<Index^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Index >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Index >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Index >)>)
RedGate.SQLCompare.Engine..::.Indexes

See Also

Indexes Members


Indexes Members

[image] [image]

SQL Data Compare API 7.1.0
Indexes Members
Indexes Class Methods Properties Explicit Interface Implementations See Also

The Indexes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Indexes Class


Indexes Properties

[image] [image]

SQL Data Compare API 7.1.0
Indexes Properties
Indexes Class See Also

The Indexes type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Indexes Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Indexes..::.Item Property
Indexes Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns an index given a name. (Overrides KeyedCollection <(Of <( Index >)>)..::. Item[([(String])]).)
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Indexes Class
Indexes Members


Item Property (String)

[image]

SQL Data Compare API 7.1.0
Indexes..::.Item Property (String)
Indexes Class See Also

Returns an index given a name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    name As String _
) As Index
C#
public override Index this[
    string name
] { get; }
Visual C++
public:
virtual property Index^ default[String^ name] {
    Index^ get (String^ name) override;
}

Parameters

name
Type: System..::.String
The string-based index of the element to get or set.

See Also

Indexes Class
Item Overload


IOwner Interface

[image]

SQL Data Compare API 7.1.0
IOwner Interface
Members See Also

An interface representing an object that can 'own' other objects

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Interface IOwner _
    Implements IDatabaseObject
C#
public interface IOwner : IDatabaseObject
Visual C++
public interface class IOwner : IDatabaseObject

Remarks

Currently used for Role, Schema, User

See Also

IOwner Members


IOwner Members

[image] [image]

SQL Data Compare API 7.1.0
IOwner Members
IOwner Interface Methods Properties See Also

The IOwner type exposes the following members.

Methods

Name | Description
Equals | Compares two database objects. (Inherited from IDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from IDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from IDatabaseObject.)
Name | The name of the object. (Inherited from IDatabaseObject.)
ObjectType | The type of the object. (Inherited from IDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from IDatabaseObject.)

See Also

IOwner Interface


KeyedCollection(T) Generic Class

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>) Generic Class
Members See Also

A collection that can store items by key as well as by list index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class KeyedCollection(Of T) _
    Inherits EnumerableBase(Of T)
C#
public abstract class KeyedCollection<T> : EnumerableBase<T>
Visual C++
generic<typename T>
public ref class KeyedCollection abstract : public EnumerableBase<T>

Type Parameters

T
The type stored in the KeyedCollection<(Of <(T>)>).

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.KeyedCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.Members
RedGate.SQLCompare.Engine..::.ViewsAndTables

See Also

KeyedCollection<(Of <(T>)>) Members


KeyedCollection(T) Members

[image] [image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>) Members
KeyedCollection<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The KeyedCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

KeyedCollection<(Of <(T>)>) Class


KeyedCollection(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>) Methods
KeyedCollection<(Of <(T>)>) Class See Also

The KeyedCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Overrides EnumerableBase <(Of <( T >)>)..::. GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

KeyedCollection<(Of <(T>)>) Class


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.GetEnumerator Method
KeyedCollection<(Of <(T>)>) Class See Also

Returns the list enumerator.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IEnumerator(Of T)
C#
public override IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() override

Return Value

An enumerator.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

KeyedCollection<(Of <(T>)>) Class


KeyedCollection(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>) Properties
KeyedCollection<(Of <(T>)>) Class See Also

The KeyedCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively.
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).
Item | Overloaded.

See Also

KeyedCollection<(Of <(T>)>) Class


CaseSensitive Property

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.CaseSensitive Property
KeyedCollection<(Of <(T>)>) Class See Also

True if the keys are stored case-sensitively.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Property CaseSensitive As Boolean
C#
protected internal bool CaseSensitive { get; protected set; }
Visual C++
protected public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

KeyedCollection<(Of <(T>)>) Class


Count Property

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.Count Property
KeyedCollection<(Of <(T>)>) Class See Also

Returns the number of elements stored in the KeyedCollection<(Of <(T>)>).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
property int Count {
    int get ();
}

See Also

KeyedCollection<(Of <(T>)>) Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.Item Property
KeyedCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index.
Item[([(String])]) | Returns elements by key.

See Also

KeyedCollection<(Of <(T>)>) Class
KeyedCollection<(Of <(T>)>) Members


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.Item Property (Int32)
KeyedCollection<(Of <(T>)>) Class See Also

Returns elements by index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    index As Integer _
) As T
C#
public virtual T this[
    int index
] { get; }
Visual C++
public:
virtual property T default[int index] {
    T get (int index);
}

Parameters

index
Type: System..::.Int32

Return Value

See Also

KeyedCollection<(Of <(T>)>) Class
Item Overload


Item Property (String)

[image]

SQL Data Compare API 7.1.0
KeyedCollection<(Of <(T>)>)..::.Item Property (String)
KeyedCollection<(Of <(T>)>) Class See Also

Returns elements by key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    key As String _
) As T
C#
public virtual T this[
    string key
] { get; }
Visual C++
public:
virtual property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: System..::.String

Return Value

The value, or default(T) if not found.

See Also

KeyedCollection<(Of <(T>)>) Class
Item Overload


LiveDatabaseSource Class

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource Class
Members See Also

A standard SQL Server database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LiveDatabaseSource _
    Inherits DataSource
C#
public sealed class LiveDatabaseSource : DataSource
Visual C++
public ref class LiveDatabaseSource sealed : public DataSource

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.LiveDatabaseSource

See Also

LiveDatabaseSource Members


LiveDatabaseSource Members

[image] [image]

SQL Data Compare API 7.1.0
LiveDatabaseSource Members
LiveDatabaseSource Class Constructors Methods Properties See Also

The LiveDatabaseSource type exposes the following members.

Constructors

Name | Description
LiveDatabaseSource | Constructor.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the specified object. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties | Returns the ConnectionProperties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
IntegratedSecurity | Specifies whether Windows Integrated security or SQL authentication is used.
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
Password | Gets or sets the password for the SQL user.
SavePassword | Specifies whether the password should be written to disk when serializing the project.
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
UserName | Gets or sets the SQL Server user name with which to connect to the SQL Server.
Version | Gets the current serialized version number of LiveDatabaseSource. (Overrides DataSource ..::. Version.)

See Also

LiveDatabaseSource Class


LiveDatabaseSource Constructor

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource Constructor
LiveDatabaseSource Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LiveDatabaseSource()
Visual C++
public:
LiveDatabaseSource()

See Also

LiveDatabaseSource Class


LiveDatabaseSource Methods

[image] [image]

SQL Data Compare API 7.1.0
LiveDatabaseSource Methods
LiveDatabaseSource Class See Also

The LiveDatabaseSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes the specified object. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties | Returns the ConnectionProperties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LiveDatabaseSource Class


Clone Method

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.Clone Method
LiveDatabaseSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IDataSource..::.Clone()()()

See Also

LiveDatabaseSource Class


Deserialize Method

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.Deserialize Method
LiveDatabaseSource Class See Also

Deserializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    nVersionId As Integer, _
    obj As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int nVersionId,
    ISerializeFormatter obj
)
Visual C++
public:
virtual bool Deserialize(
    int nVersionId,
    ISerializeFormatter^ obj
) override

Parameters

nVersionId
Type: System..::.Int32
The serialization version.
obj
Type: ISerializeFormatter
The ISerializeFormatter for deserialization.

See Also

LiveDatabaseSource Class


IsDifferentSource Method

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.IsDifferentSource Method
LiveDatabaseSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    comparisonDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource comparisonDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ comparisonDataSource
) override

Parameters

comparisonDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

LiveDatabaseSource Class


Serialize Method

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.Serialize Method
LiveDatabaseSource Class See Also

Serializes the specified object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    obj As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter obj
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ obj
) override

Parameters

obj
Type: ISerializeFormatter
The object to serialize.

See Also

LiveDatabaseSource Class


ToConnectionProperties Method

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.ToConnectionProperties Method
LiveDatabaseSource Class See Also

Returns the ConnectionProperties.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ToConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ToConnectionProperties()
Visual C++
public:
ConnectionProperties^ ToConnectionProperties()

See Also

LiveDatabaseSource Class


LiveDatabaseSource Properties

[image] [image]

SQL Data Compare API 7.1.0
LiveDatabaseSource Properties
LiveDatabaseSource Class See Also

The LiveDatabaseSource type exposes the following properties.

Properties

Name | Description
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
IntegratedSecurity | Specifies whether Windows Integrated security or SQL authentication is used.
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
Password | Gets or sets the password for the SQL user.
SavePassword | Specifies whether the password should be written to disk when serializing the project.
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
UserName | Gets or sets the SQL Server user name with which to connect to the SQL Server.
Version | Gets the current serialized version number of LiveDatabaseSource. (Overrides DataSource ..::. Version.)

See Also

LiveDatabaseSource Class


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.DatabaseName Property
LiveDatabaseSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

LiveDatabaseSource Class


IntegratedSecurity Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.IntegratedSecurity Property
LiveDatabaseSource Class See Also

Specifies whether Windows Integrated security or SQL authentication is used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratedSecurity As Boolean
C#
public bool IntegratedSecurity { get; set; }
Visual C++
public:
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

See Also

LiveDatabaseSource Class


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.IsWriteable Property
LiveDatabaseSource Class See Also

The data source can be written to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

LiveDatabaseSource Class


Password Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.Password Property
LiveDatabaseSource Class See Also

Gets or sets the password for the SQL user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class


SavePassword Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.SavePassword Property
LiveDatabaseSource Class See Also

Specifies whether the password should be written to disk when serializing the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SavePassword As Boolean
C#
public bool SavePassword { get; set; }
Visual C++
public:
property bool SavePassword {
    bool get ();
    void set (bool value);
}

See Also

LiveDatabaseSource Class


ServerName Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.ServerName Property
LiveDatabaseSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

LiveDatabaseSource Class


UserName Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.UserName Property
LiveDatabaseSource Class See Also

Gets or sets the SQL Server user name with which to connect to the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

LiveDatabaseSource Class


Version Property

[image]

SQL Data Compare API 7.1.0
LiveDatabaseSource..::.Version Property
LiveDatabaseSource Class See Also

Gets the current serialized version number of LiveDatabaseSource.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

LiveDatabaseSource Class


Mapping(T) Generic Class

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>) Generic Class
Members See Also

Abstract class used to contain a mapping between two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Mapping(Of T As {Class, IDatabaseObject}) _
    Implements IComparable(Of Mapping(Of T)), ICloneable
C#
public class Mapping<T> : IComparable<Mapping<T>>,
    ICloneable where T : class, IDatabaseObject
Visual C++
generic<typename T>
where T : ref class, IDatabaseObject
public ref class Mapping : IComparable<Mapping<T>^>,
    ICloneable

Type Parameters

T
The type stored in the mappings.

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMapping
RedGate.SQLDataCompare.Engine..::.FieldMapping
RedGate.SQLDataCompare.Engine..::.IndexMapping
RedGate.SQLDataCompare.Engine..::.SchemaMapping
RedGate.SQLDataCompare.Engine..::.TableMapping

See Also

Mapping<(Of <(T>)>) Members


Mapping(T) Members

[image] [image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>) Members
Mapping<(Of <(T>)>) Class Methods Properties See Also

The Mapping<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Clone | Creates a shallow copy.
CompareTo | Sorts the Mappings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Include | Specifies whether the mapping is to be included.
Obj1 | Returns the object from the first database
Obj2 | Returns the object from the second database

See Also

Mapping<(Of <(T>)>) Class


Mapping(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>) Methods
Mapping<(Of <(T>)>) Class See Also

The Mapping<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy.
CompareTo | Sorts the Mappings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mapping<(Of <(T>)>) Class


Clone Method

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>)..::.Clone Method
Mapping<(Of <(T>)>) Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone As Object
C#
public virtual Object Clone()
Visual C++
public:
virtual Object^ Clone()

Return Value

A shallow copy.

Implements

ICloneable..::.Clone()()()

See Also

Mapping<(Of <(T>)>) Class


CompareTo Method

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>)..::.CompareTo Method
Mapping<(Of <(T>)>) Class See Also

Sorts the Mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CompareTo ( _
    obj As Mapping(Of T) _
) As Integer
C#
public virtual int CompareTo(
    Mapping<T> obj
)
Visual C++
public:
virtual int CompareTo(
    Mapping<T>^ obj
)

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( T >)>)
The object to be compared.

Return Value

Less than zero when this instance is less than the specified object; zero when this instance is equal to the specified object; greater then zero when this instance is greater than the specified object.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

Mapping<(Of <(T>)>) Class


Mapping(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>) Properties
Mapping<(Of <(T>)>) Class See Also

The Mapping<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Include | Specifies whether the mapping is to be included.
Obj1 | Returns the object from the first database
Obj2 | Returns the object from the second database

See Also

Mapping<(Of <(T>)>) Class


Include Property

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>)..::.Include Property
Mapping<(Of <(T>)>) Class See Also

Specifies whether the mapping is to be included.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Include As Boolean
C#
public virtual bool Include { get; set; }
Visual C++
public:
virtual property bool Include {
    bool get ();
    void set (bool value);
}

See Also

Mapping<(Of <(T>)>) Class


Obj1 Property

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>)..::.Obj1 Property
Mapping<(Of <(T>)>) Class See Also

Returns the object from the first database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Obj1 As T
C#
public T Obj1 { get; }
Visual C++
public:
property T Obj1 {
    T get ();
}

See Also

Mapping<(Of <(T>)>) Class


Obj2 Property

[image]

SQL Data Compare API 7.1.0
Mapping<(Of <(T>)>)..::.Obj2 Property
Mapping<(Of <(T>)>) Class See Also

Returns the object from the second database

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Obj2 As T
C#
public T Obj2 { get; }
Visual C++
public:
property T Obj2 {
    T get ();
}

See Also

Mapping<(Of <(T>)>) Class


MappingException Class

[image]

SQL Data Compare API 7.1.0
MappingException Class
Members See Also

Exception thrown when an error is encountered whilst mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MappingException _
    Inherits ApplicationException
C#
[SerializableAttribute]
public class MappingException : ApplicationException
Visual C++
[SerializableAttribute]
public ref class MappingException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
RedGate.SQLCompare.Engine..::.MappingException

See Also

MappingException Members


MappingException Members

[image] [image]

SQL Data Compare API 7.1.0
MappingException Members
MappingException Class Constructors Methods Properties See Also

The MappingException type exposes the following members.

Constructors

Name | Description
MappingException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MappingException Class


MappingException Constructor

[image] [image]

SQL Data Compare API 7.1.0
MappingException Constructor
MappingException Class See Also

Overload List

Name | Description
MappingException()()() | Creates a new exception.
MappingException(String) | Creates a new exception with the specified detail message.
MappingException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
MappingException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

MappingException Class
MappingException Members


MappingException Constructor

[image]

SQL Data Compare API 7.1.0
MappingException Constructor
MappingException Class See Also

Creates a new exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MappingException()
Visual C++
public:
MappingException()

See Also

MappingException Class
MappingException Overload


MappingException Constructor (String)

[image]

SQL Data Compare API 7.1.0
MappingException Constructor (String)
MappingException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public MappingException(
    string message
)
Visual C++
public:
MappingException(
    String^ message
)

Parameters

message
Type: System..::.String
Detail message.

See Also

MappingException Class
MappingException Overload


MappingException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
MappingException Constructor (SerializationInfo, StreamingContext)
MappingException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected MappingException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
MappingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

MappingException Class
MappingException Overload


MappingException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
MappingException Constructor (String, Exception)
MappingException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public MappingException(
    string message,
    Exception cause
)
Visual C++
public:
MappingException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::.String
Detail message.
cause
Type: System..::.Exception
Cause of exception.

See Also

MappingException Class
MappingException Overload


Mappings(TMap, TContext) Generic Class

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>) Generic Class
Members See Also

Abstract class for creating a set of mappings from a list of database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Mappings(Of TMap As {Class, IDatabaseObject}, TContext) _
    Inherits InnerList(Of Mapping(Of TMap)) _
    Implements ICancellable
C#
public abstract class Mappings<TMap, TContext> : InnerList<Mapping<TMap>>, ICancellable where TMap : class, IDatabaseObject
Visual C++
generic<typename TMap, typename TContext>
where TMap : ref class, IDatabaseObject
public ref class Mappings abstract : public InnerList<Mapping<TMap>^>,
    ICancellable

Type Parameters

TMap
TContext

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <(TMap>)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <(TMap>)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings<(Of <(TMap, TContext>)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
RedGate.SQLDataCompare.Engine..::.DataCompareMappings<(Of <(T>)>)

See Also

Mappings<(Of <(TMap, TContext>)>) Members


Mappings(TMap, TContext) Members

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>) Members
Mappings<(Of <(TMap, TContext>)>) Class Methods Properties Explicit Interface Implementations See Also

The Mappings<(Of <(TMap, TContext>)>) type exposes the following members.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Add(UTP).)
CancelOperation | Cancels the current operation.
Clear | Removes all objects from the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::. Contains(T).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromOne | Overloaded.
FromTwo | Overloaded.
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::. IndexOf(T).)
Insert | Not Implemented. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Insert(Int32, UTP).)
Join | Attempts to join two objects in one mapping.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Remove(UTP).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.RemoveAt(Int32).)
Sort | Sorts the Mappings according the criteria appropriate for the object.
Split | Splits a mapping and creates two mappings; one to null, and one from null.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Status | The event handler used to receive status update events.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Mappings(TMap, TContext) Methods

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>) Methods
Mappings<(Of <(TMap, TContext>)>) Class See Also

The Mappings<(Of <(TMap, TContext>)>) type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Add(UTP).)
CancelOperation | Cancels the current operation.
Clear | Removes all objects from the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::. Contains(T).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromOne | Overloaded.
FromTwo | Overloaded.
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::. IndexOf(T).)
Insert | Not Implemented. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Insert(Int32, UTP).)
Join | Attempts to join two objects in one mapping.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.Remove(UTP).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::.RemoveAt(Int32).)
Sort | Sorts the Mappings according the criteria appropriate for the object.
Split | Splits a mapping and creates two mappings; one to null, and one from null.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Add Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Add Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As Mapping(Of TMap) _
)
C#
public override void Add(
    Mapping<TMap> value
)
Visual C++
public:
virtual void Add(
    Mapping<TMap>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The object to be added to the end of the Mappings instance.

Return Value

The Mappings index at which the object has been added.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.CancelOperation Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CancelOperation
C#
public virtual void CancelOperation()
Visual C++
public:
virtual void CancelOperation()

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException will be thrown.

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Clear Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Clear Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Removes all objects from the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Contains Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Contains Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Determines whether the Mappings instance contains a specified object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Contains ( _
    value As Mapping(Of TMap) _
) As Boolean
C#
public override bool Contains(
    Mapping<TMap> value
)
Visual C++
public:
virtual bool Contains(
    Mapping<TMap>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The Mapping<(Of <(T>)>) to locate in the Mappings instance.

Return Value

true if the Mappings instance contains the specified object; otherwise, false.

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


CreateMappings(U) Generic Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.CreateMappings<(Of <(U>)>) Generic Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CreateMappings(Of U As ) ( _
    in1 As KeyedCollection(Of U), _
    in2 As KeyedCollection(Of U), _
    extra As Object, _
    useFullName As Boolean _
)
C#
protected void CreateMappings<U>(
    KeyedCollection<U> in1,
    KeyedCollection<U> in2,
    Object extra,
    bool useFullName
) where U :
Visual C++
protected:
generic<typename U>
where U :
void CreateMappings(
    KeyedCollection<U>^ in1,
    KeyedCollection<U>^ in2,
    Object^ extra,
    bool useFullName
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <(U>)>)
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <(U>)>)
List of objects in the second database, or null.
extra
Type: System..::.Object
This can be used by the Join(TMap, TMap) function for extra information on how to join the objects.
useFullName
Type: System..::.Boolean
Use the FullyQualifiedName for matching

Type Parameters

U

See Also

Mappings<(Of <(TMap, TContext>)>) Class


FromOne Method

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromOne Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Overload List

Name | Description
FromOne(String) | Returns the Mapping of the object in the first database.
FromOne(TMap) | Returns the mapping of the object in the first database.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
Mappings<(Of <(TMap, TContext>)>) Members


FromOne Method (String)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromOne Method (String)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Returns the Mapping of the object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FromOne ( _
    in1 As String _
) As Mapping(Of TMap)
C#
public Mapping<TMap> FromOne(
    string in1
)
Visual C++
public:
Mapping<TMap>^ FromOne(
    String^ in1
)

Parameters

in1
Type: System..::.String
The FullyQualifiedName of the object in the first database.

Return Value

If no mapping exists, null; otherwise, the Mapping.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
FromOne Overload


FromOne Method (TMap)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromOne Method (TMap)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Returns the mapping of the object in the first database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function FromOne ( _
    in1 As TMap _
) As Mapping(Of TMap)
C#
protected Mapping<TMap> FromOne(
    TMap in1
)
Visual C++
protected:
Mapping<TMap>^ FromOne(
    TMap in1
)

Parameters

in1
Type: TMap
object that the mapping is from, not null.

Return Value

null if no mapping exists, or the mapping.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
FromOne Overload


FromTwo Method

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromTwo Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Overload List

Name | Description
FromTwo(String) | Returns the Mapping of the object in the second database.
FromTwo(TMap) | Returns the mapping of the object in the second database.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
Mappings<(Of <(TMap, TContext>)>) Members


FromTwo Method (String)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromTwo Method (String)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Returns the Mapping of the object in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FromTwo ( _
    in2 As String _
) As Mapping(Of TMap)
C#
public Mapping<TMap> FromTwo(
    string in2
)
Visual C++
public:
Mapping<TMap>^ FromTwo(
    String^ in2
)

Parameters

in2
Type: System..::.String
The FullyQualifiedName of the object in the second database.

Return Value

If no mapping exists, null; otherwise, the Mapping.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
FromTwo Overload


FromTwo Method (TMap)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.FromTwo Method (TMap)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Returns the mapping of the object in the second database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Function FromTwo ( _
    in2 As TMap _
) As Mapping(Of TMap)
C#
protected Mapping<TMap> FromTwo(
    TMap in2
)
Visual C++
protected:
Mapping<TMap>^ FromTwo(
    TMap in2
)

Parameters

in2
Type: TMap
object that the mapping is from, not null.

Return Value

null if no mapping exists, or the mapping.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
FromTwo Overload


GetKey Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.GetKey Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Return the key that should be used for the specified fully qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetKey ( _
    fullyQualifiedName As String _
) As String
C#
protected virtual string GetKey(
    string fullyQualifiedName
)
Visual C++
protected:
virtual String^ GetKey(
    String^ fullyQualifiedName
)

Parameters

fullyQualifiedName
Type: System..::.String

Return Value

See Also

Mappings<(Of <(TMap, TContext>)>) Class


IndexOf Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.IndexOf Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IndexOf ( _
    value As Mapping(Of TMap) _
) As Integer
C#
public override int IndexOf(
    Mapping<TMap> value
)
Visual C++
public:
virtual int IndexOf(
    Mapping<TMap>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The object to locate in the Mappings instance.

Return Value

If found, the zero-based index of the first occurrence of the object within the Mappings instance; otherwise, -1.

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Insert Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Insert Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Not Implemented.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    value As Mapping(Of TMap) _
)
C#
public override void Insert(
    int index,
    Mapping<TMap> value
)
Visual C++
public:
virtual void Insert(
    int index,
    Mapping<TMap>^ value
) override

Parameters

index
Type: System..::.Int32
Ignored.
value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
Ignored.

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

Exceptions

Exception | Condition
System..::.NotImplementedException | Throws NotImplementedException always

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Join Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Join Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Attempts to join two objects in one mapping.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Join ( _
    obj1 As TMap, _
    obj2 As TMap _
) As Mapping(Of TMap)
C#
public abstract Mapping<TMap> Join(
    TMap obj1,
    TMap obj2
)
Visual C++
public:
virtual Mapping<TMap>^ Join(
    TMap obj1,
    TMap obj2
) abstract

Parameters

obj1
Type: TMap
The first object, or null.
obj2
Type: TMap
The second object, or null.

Return Value

The mapping created.

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Remove Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Remove Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Remove ( _
    value As Mapping(Of TMap) _
) As Boolean
C#
public override bool Remove(
    Mapping<TMap> value
)
Visual C++
public:
virtual bool Remove(
    Mapping<TMap>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The object to remove from the Mappings instance.

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

Mappings<(Of <(TMap, TContext>)>) Class


RemoveAt Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.RemoveAt Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Removes the mapping at the specified index of the Mappings instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub RemoveAt ( _
    index As Integer _
)
C#
public override sealed void RemoveAt(
    int index
)
Visual C++
public:
virtual void RemoveAt(
    int index
) override sealed

Parameters

index
Type: System..::.Int32
The index of the mapping to be removed.

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | Mapping is null at the specified index.

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Sort Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Sort Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Sorts the Mappings according the criteria appropriate for the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Sort
C#
public void Sort()
Visual C++
public:
void Sort()

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Split Method

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Split Method
Mappings<(Of <(TMap, TContext>)>) Class See Also

Splits a mapping and creates two mappings; one to null, and one from null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Split ( _
    old1 As Mapping(Of TMap) _
)
C#
public virtual void Split(
    Mapping<TMap> old1
)
Visual C++
public:
virtual void Split(
    Mapping<TMap>^ old1
)

Parameters

old1
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( TMap >)>)
The mapping to be split, both obj1 and obj2 should be not null.

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Mappings(TMap, TContext) Properties

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>) Properties
Mappings<(Of <(TMap, TContext>)>) Class See Also

The Mappings<(Of <(TMap, TContext>)>) type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Status | The event handler used to receive status update events.

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Item Property
Mappings<(Of <(TMap, TContext>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Overrides InnerList <(Of <( Mapping <(Of <( TMap >)>)>)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
Mappings<(Of <(TMap, TContext>)>) Members


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Item Property (Int32)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Gets the Mapping<(Of <(T>)>) at the specified index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As Mapping(Of TMap)
C#
public override Mapping<TMap> this[
    int index
] { set; }
Visual C++
public:
virtual property Mapping<TMap>^ default[int index] {
    void set (int index, Mapping<TMap>^ value) override;
}

Parameters

index
Type: System..::.Int32
The zero-based index of the Mapping to get or set.

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

Mappings<(Of <(TMap, TContext>)>) Class
Item Overload


Item Property (String)

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Item Property (String)
Mappings<(Of <(TMap, TContext>)>) Class See Also

Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    fullyQualifiedName As String _
) As Mapping(Of TMap)
C#
public Mapping<TMap> this[
    string fullyQualifiedName
] { get; }
Visual C++
public:
property Mapping<TMap>^ default[String^ fullyQualifiedName] {
    Mapping<TMap>^ get (String^ fullyQualifiedName);
}

Parameters

fullyQualifiedName
Type: System..::.String
The string-based index of the element to get.

See Also

Mappings<(Of <(TMap, TContext>)>) Class
Item Overload


Status Property

[image]

SQL Data Compare API 7.1.0
Mappings<(Of <(TMap, TContext>)>)..::.Status Property
Mappings<(Of <(TMap, TContext>)>) Class See Also

The event handler used to receive status update events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Mappings<(Of <(TMap, TContext>)>) Class


Members Class

[image]

SQL Data Compare API 7.1.0
Members Class
Members See Also

A collection of role members. These can be users or roles.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Members _
    Inherits KeyedCollection(Of IOwner)
C#
public sealed class Members : KeyedCollection<IOwner>
Visual C++
public ref class Members sealed : public KeyedCollection<IOwner^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( IOwner >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( IOwner >)>)
RedGate.SQLCompare.Engine..::.Members

See Also

Members Members


Members Members

[image] [image]

SQL Data Compare API 7.1.0
Members Members
Members Class Methods Properties Explicit Interface Implementations See Also

The Members type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Members Class


Message Class

[image]

SQL Data Compare API 7.1.0
Message Class
Members See Also

A message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Message
C#
public sealed class Message
Visual C++
public ref class Message sealed

Remarks

See Work for more information.

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Message

See Also

Message Members


Message Members

[image] [image]

SQL Data Compare API 7.1.0
Message Members
Message Class Methods Properties See Also

The Message type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseObject | The database object to which this message belongs.
MessageTypeID | The identifier of the message type.
Text | The text of the message.
WarningSeverity | The severity of the message or warning.

See Also

Message Class


Message Properties

[image] [image]

SQL Data Compare API 7.1.0
Message Properties
Message Class See Also

The Message type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object to which this message belongs.
MessageTypeID | The identifier of the message type.
Text | The text of the message.
WarningSeverity | The severity of the message or warning.

See Also

Message Class


DatabaseObject Property

[image]

SQL Data Compare API 7.1.0
Message..::.DatabaseObject Property
Message Class See Also

The database object to which this message belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseObject As IDatabaseObject
C#
public IDatabaseObject DatabaseObject { get; }
Visual C++
public:
property IDatabaseObject^ DatabaseObject {
    IDatabaseObject^ get ();
}

See Also

Message Class


MessageTypeID Property

[image]

SQL Data Compare API 7.1.0
Message..::.MessageTypeID Property
Message Class See Also

The identifier of the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageTypeID As String
C#
public string MessageTypeID { get; }
Visual C++
public:
property String^ MessageTypeID {
    String^ get ();
}

See Also

Message Class


Text Property

[image]

SQL Data Compare API 7.1.0
Message..::.Text Property
Message Class See Also

The text of the message.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

Message Class


WarningSeverity Property

[image]

SQL Data Compare API 7.1.0
Message..::.WarningSeverity Property
Message Class See Also

The severity of the message or warning.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WarningSeverity As WarningSeverity
C#
public WarningSeverity WarningSeverity { get; }
Visual C++
public:
property WarningSeverity WarningSeverity {
    WarningSeverity get ();
}

See Also

Message Class


Messages Class

[image]

SQL Data Compare API 7.1.0
Messages Class
Members See Also

A collection of messages.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Messages _
    Inherits InnerList(Of Message)
C#
public sealed class Messages : InnerList<Message>
Visual C++
public ref class Messages sealed : public InnerList<Message^>

Remarks

See Work for more information.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Message >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Message >)>)
RedGate.SQLCompare.Engine..::.Messages

See Also

Messages Members


Messages Members

[image] [image]

SQL Data Compare API 7.1.0
Messages Members
Messages Class Methods Properties Explicit Interface Implementations See Also

The Messages type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts the messages using the specified comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Messages Class


Messages Methods

[image] [image]

SQL Data Compare API 7.1.0
Messages Methods
Messages Class See Also

The Messages type exposes the following methods.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts the messages using the specified comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Messages Class


Sort Method

[image]

SQL Data Compare API 7.1.0
Messages..::.Sort Method
Messages Class See Also

Sorts the messages using the specified comparer.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Sort ( _
    comparer As IComparer(Of Message) _
)
C#
public void Sort(
    IComparer<Message> comparer
)
Visual C++
public:
void Sort(
    IComparer<Message^>^ comparer
)

Parameters

comparer
Type: System.Collections.Generic..::.IComparer <(Of <( Message >)>)
The IComparer to be used for the sorting.

See Also

Messages Class


MessageType Class

[image]

SQL Data Compare API 7.1.0
MessageType Class
Members See Also

A message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageType _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IIsSystemObject, IDatabaseObject
C#
public sealed class MessageType : DatabaseObjectWithAuthorization, IHasPermissions,
    IIsSystemObject, IDatabaseObject
Visual C++
public ref class MessageType sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IIsSystemObject, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.MessageType

See Also

MessageType Members


MessageType Members

[image] [image]

SQL Data Compare API 7.1.0
MessageType Members
MessageType Class Methods Fields Properties See Also

The MessageType type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the message type.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object in question is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.MessageType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this message type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Validation | The validation requirement for the message type.
XmlCollection | The XML schema collection referenced by the message type.

See Also

MessageType Class


MessageType Methods

[image] [image]

SQL Data Compare API 7.1.0
MessageType Methods
MessageType Class See Also

The MessageType type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageType Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
MessageType..::.Equals Method
MessageType Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the message type with a specified message type. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

MessageType Class
MessageType Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
MessageType..::.Equals Method (IDatabaseObject, Options)
MessageType Class See Also

Compares the message type with a specified message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The message type to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the message types are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

MessageType Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
MessageType..::.ScriptObject Method
MessageType Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

MessageType Class


MessageType Properties

[image] [image]

SQL Data Compare API 7.1.0
MessageType Properties
MessageType Class See Also

The MessageType type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the message type.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object in question is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.MessageType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this message type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
Validation | The validation requirement for the message type.
XmlCollection | The XML schema collection referenced by the message type.

See Also

MessageType Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.ExtendedProperties Property
MessageType Class See Also

The extended properties defined for the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

MessageType Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.IsSystemObject Property
MessageType Class See Also

Indicates whether the object in question is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

MessageType Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.ObjectType Property
MessageType Class See Also

Returns ObjectType.MessageType

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

MessageType Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.Permissions Property
MessageType Class See Also

The permissions on this message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

MessageType Class


Validation Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.Validation Property
MessageType Class See Also

The validation requirement for the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Validation As MessageTypeValidation
C#
public MessageTypeValidation Validation { get; internal set; }
Visual C++
public:
property MessageTypeValidation Validation {
    MessageTypeValidation get ();
    void set (MessageTypeValidation value);
}

See Also

MessageType Class


XmlCollection Property

[image]

SQL Data Compare API 7.1.0
MessageType..::.XmlCollection Property
MessageType Class See Also

The XML schema collection referenced by the message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlCollection { get; internal set; }
Visual C++
public:
property XmlSchemaCollection^ XmlCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

MessageType Class


MessageTypes Class

[image]

SQL Data Compare API 7.1.0
MessageTypes Class
Members See Also

A collection of message types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageTypes _
    Inherits SerializableDatabaseObjectCollection(Of MessageType)
C#
public sealed class MessageTypes : SerializableDatabaseObjectCollection<MessageType>
Visual C++
public ref class MessageTypes sealed : public SerializableDatabaseObjectCollection<MessageType^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( MessageType >)>)
RedGate.SQLCompare.Engine..::.MessageTypes

See Also

MessageTypes Members


MessageTypes Members

[image] [image]

SQL Data Compare API 7.1.0
MessageTypes Members
MessageTypes Class Methods Properties Explicit Interface Implementations See Also

The MessageTypes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

MessageTypes Class


MessageTypeValidation Enumeration

[image]

SQL Data Compare API 7.1.0
MessageTypeValidation Enumeration
See Also

The validation type for a message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration MessageTypeValidation
C#
public enum MessageTypeValidation
Visual C++
public enum class MessageTypeValidation

Members

Member name | Description
None | None.
Xml | XML.
Empty | Empty.

See Also


MessageUsage Class

[image]

SQL Data Compare API 7.1.0
MessageUsage Class
Members See Also

A message usage.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageUsage
C#
public sealed class MessageUsage
Visual C++
public ref class MessageUsage sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.MessageUsage

See Also

MessageUsage Members


MessageUsage Members

[image] [image]

SQL Data Compare API 7.1.0
MessageUsage Members
MessageUsage Class Methods Properties See Also

The MessageUsage type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MessageType | The message type.
SentByInitiator | True if the message type in the usage is sent by the initiator.
SentByTarget | True if the message type in the usage is sent by the target.

See Also

MessageUsage Class


MessageUsage Methods

[image] [image]

SQL Data Compare API 7.1.0
MessageUsage Methods
MessageUsage Class See Also

The MessageUsage type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageUsage Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
MessageUsage..::.Equals Method
MessageUsage Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(MessageUsage, Options) | Compares the message usage with a specified message usage.

See Also

MessageUsage Class
MessageUsage Members


Equals Method (MessageUsage, Options)

[image]

SQL Data Compare API 7.1.0
MessageUsage..::.Equals Method (MessageUsage, Options)
MessageUsage Class See Also

Compares the message usage with a specified message usage.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As MessageUsage, _
    options As Options _
) As Boolean
C#
public bool Equals(
    MessageUsage target,
    Options options
)
Visual C++
public:
bool Equals(
    MessageUsage^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.MessageUsage
The message usage to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the message usages are identical; otherwise, false.

See Also

MessageUsage Class
Equals Overload


MessageUsage Properties

[image] [image]

SQL Data Compare API 7.1.0
MessageUsage Properties
MessageUsage Class See Also

The MessageUsage type exposes the following properties.

Properties

Name | Description
MessageType | The message type.
SentByInitiator | True if the message type in the usage is sent by the initiator.
SentByTarget | True if the message type in the usage is sent by the target.

See Also

MessageUsage Class


MessageType Property

[image]

SQL Data Compare API 7.1.0
MessageUsage..::.MessageType Property
MessageUsage Class See Also

The message type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageType As MessageType
C#
public MessageType MessageType { get; internal set; }
Visual C++
public:
property MessageType^ MessageType {
    MessageType^ get ();
    void set (MessageType^ value);
}

See Also

MessageUsage Class


SentByInitiator Property

[image]

SQL Data Compare API 7.1.0
MessageUsage..::.SentByInitiator Property
MessageUsage Class See Also

True if the message type in the usage is sent by the initiator.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByInitiator As Boolean
C#
public bool SentByInitiator { get; internal set; }
Visual C++
public:
property bool SentByInitiator {
    bool get ();
    void set (bool value);
}

See Also

MessageUsage Class


SentByTarget Property

[image]

SQL Data Compare API 7.1.0
MessageUsage..::.SentByTarget Property
MessageUsage Class See Also

True if the message type in the usage is sent by the target.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SentByTarget As Boolean
C#
public bool SentByTarget { get; internal set; }
Visual C++
public:
property bool SentByTarget {
    bool get ();
    void set (bool value);
}

See Also

MessageUsage Class


MessageUsages Class

[image]

SQL Data Compare API 7.1.0
MessageUsages Class
Members See Also

A collection of message usages.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MessageUsages _
    Inherits SerializableCollection(Of MessageUsage)
C#
public sealed class MessageUsages : SerializableCollection<MessageUsage>
Visual C++
public ref class MessageUsages sealed : public SerializableCollection<MessageUsage^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( MessageUsage >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( MessageUsage >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( MessageUsage >)>)
RedGate.SQLCompare.Engine..::.MessageUsages

See Also

MessageUsages Members


MessageUsages Members

[image] [image]

SQL Data Compare API 7.1.0
MessageUsages Members
MessageUsages Class Methods Properties Explicit Interface Implementations See Also

The MessageUsages type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

MessageUsages Class


ObjectNotInDatabaseException Class

[image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Class
Members See Also

An exception that is used when a database object that is not in the database is requested.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectNotInDatabaseException _
    Inherits SqlCompareException
C#
public class ObjectNotInDatabaseException : SqlCompareException
Visual C++
public ref class ObjectNotInDatabaseException : public SqlCompareException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.ObjectNotInDatabaseException

See Also

ObjectNotInDatabaseException Members


ObjectNotInDatabaseException Members

[image] [image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Members
ObjectNotInDatabaseException Class Constructors Methods Properties See Also

The ObjectNotInDatabaseException type exposes the following members.

Constructors

Name | Description
ObjectNotInDatabaseException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectNotInDatabaseException Class


ObjectNotInDatabaseException Constructor

[image] [image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Constructor
ObjectNotInDatabaseException Class See Also

Overload List

Name | Description
ObjectNotInDatabaseException()()() | Constructs an ObjectNotInDatabaseException exception.
ObjectNotInDatabaseException(String) | Constructs an ObjectNotInDatabaseException exception.
ObjectNotInDatabaseException(String, Exception) | Constructs an ObjectNotInDatabaseException exception.

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Members


ObjectNotInDatabaseException Constructor

[image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Constructor
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectNotInDatabaseException()
Visual C++
public:
ObjectNotInDatabaseException()

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload


ObjectNotInDatabaseException Constructor (String)

[image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Constructor (String)
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ObjectNotInDatabaseException(
    string message
)
Visual C++
public:
ObjectNotInDatabaseException(
    String^ message
)

Parameters

message
Type: System..::.String
The message for the exception.

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload


ObjectNotInDatabaseException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
ObjectNotInDatabaseException Constructor (String, Exception)
ObjectNotInDatabaseException Class See Also

Constructs an ObjectNotInDatabaseException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public ObjectNotInDatabaseException(
    string message,
    Exception inner
)
Visual C++
public:
ObjectNotInDatabaseException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The message for the exception.
inner
Type: System..::.Exception
The inner exception.

See Also

ObjectNotInDatabaseException Class
ObjectNotInDatabaseException Overload


ObjectNotInDifferences Class

[image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Class
Members See Also

Exception that is used when a database object that is not in the differences collection is requested.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectNotInDifferences _
    Inherits SqlCompareException
C#
public class ObjectNotInDifferences : SqlCompareException
Visual C++
public ref class ObjectNotInDifferences : public SqlCompareException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.ObjectNotInDifferences

See Also

ObjectNotInDifferences Members


ObjectNotInDifferences Members

[image] [image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Members
ObjectNotInDifferences Class Constructors Methods Properties See Also

The ObjectNotInDifferences type exposes the following members.

Constructors

Name | Description
ObjectNotInDifferences | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectNotInDifferences Class


ObjectNotInDifferences Constructor

[image] [image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Constructor
ObjectNotInDifferences Class See Also

Overload List

Name | Description
ObjectNotInDifferences()()() | Constructs an ObjectNotInDifferences exception.
ObjectNotInDifferences(String) | Constructs an ObjectNotInDifferences exception.
ObjectNotInDifferences(String, Exception) | Constructs an ObjectNotInDifferences exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Members


ObjectNotInDifferences Constructor

[image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Constructor
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectNotInDifferences()
Visual C++
public:
ObjectNotInDifferences()

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload


ObjectNotInDifferences Constructor (String)

[image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Constructor (String)
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ObjectNotInDifferences(
    string message
)
Visual C++
public:
ObjectNotInDifferences(
    String^ message
)

Parameters

message
Type: System..::.String
The message for the exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload


ObjectNotInDifferences Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
ObjectNotInDifferences Constructor (String, Exception)
ObjectNotInDifferences Class See Also

Constructs an ObjectNotInDifferences exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public ObjectNotInDifferences(
    string message,
    Exception inner
)
Visual C++
public:
ObjectNotInDifferences(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The message for the exception.
inner
Type: System..::.Exception
The inner exception.

See Also

ObjectNotInDifferences Class
ObjectNotInDifferences Overload


ObjectType Enumeration

[image]

SQL Data Compare API 7.1.0
ObjectType Enumeration
See Also

The type of database object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ObjectType
C#
public enum ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
None | Not used.
Table | Table.
StoredProcedure | Stored procedure.
View | View.
Default | Default.
FullTextCatalog | Full text catalog.
Function | User-defined function.
Role | Role.
Rule | Rule.
User | User.
UserDefinedType | User-defined type.
Trigger | Trigger.
DdlTrigger | DDL trigger.
Assembly | Assembly.
Synonym | Synonym.
XmlSchemaCollection | XML schema collection.
MessageType | Message type.
Contract | Contract.
Queue | Queue.
Service | Service.
Route | Route.
EventNotification | Event notification.
PartitionScheme | Partition scheme.
PartitionFunction | Partition function.
Field | Field.
Index | Index.
Schema | Schema.
ServiceBinding | Service binding.
Certificate | Certificate.
SymmetricKey | Symmetric key.
AsymmetricKey | Asymmetric key.
CheckConstraint | Check constraint.
FullTextStoplist | Full text stoplist.

See Also


OptionDescriptionAttribute Class

[image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute Class
Members See Also

Options used in comparison and synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field)> _
Public NotInheritable Class OptionDescriptionAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Field)]
public sealed class OptionDescriptionAttribute : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Field)]
public ref class OptionDescriptionAttribute sealed : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
RedGate.SQLCompare.Engine..::.OptionDescriptionAttribute

See Also

OptionDescriptionAttribute Members


OptionDescriptionAttribute Members

[image] [image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute Members
OptionDescriptionAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The OptionDescriptionAttribute type exposes the following members.

Constructors

Name | Description
OptionDescriptionAttribute | Constructor.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

OptionDescriptionAttribute Class


OptionDescriptionAttribute Constructor

[image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute Constructor
OptionDescriptionAttribute Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    friendlyName As String, _
    helpText As String _
)
C#
public OptionDescriptionAttribute(
    string friendlyName,
    string helpText
)
Visual C++
public:
OptionDescriptionAttribute(
    String^ friendlyName,
    String^ helpText
)

Parameters

friendlyName
Type: System..::.String
The friendly name of the option description.
helpText
Type: System..::.String
Help text.

See Also

OptionDescriptionAttribute Class


OptionDescriptionAttribute Properties

[image] [image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute Properties
OptionDescriptionAttribute Class See Also

The OptionDescriptionAttribute type exposes the following properties.

Properties

Name | Description
FriendlyName | A friendly name.
HelpText | Some help text.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

OptionDescriptionAttribute Class


FriendlyName Property

[image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute..::.FriendlyName Property
OptionDescriptionAttribute Class See Also

A friendly name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FriendlyName As String
C#
public string FriendlyName { get; }
Visual C++
public:
property String^ FriendlyName {
    String^ get ();
}

See Also

OptionDescriptionAttribute Class


HelpText Property

[image]

SQL Data Compare API 7.1.0
OptionDescriptionAttribute..::.HelpText Property
OptionDescriptionAttribute Class See Also

Some help text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HelpText As String
C#
public string HelpText { get; }
Visual C++
public:
property String^ HelpText {
    String^ get ();
}

See Also

OptionDescriptionAttribute Class


Options Enumeration

[image]

SQL Data Compare API 7.1.0
Options Enumeration
See Also

Options used when comparing and synchronizing databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration Options
C#
[FlagsAttribute]
public enum Options
Visual C++
[FlagsAttribute]
public enum class Options

Members

Member name Description
None
None.
Default

The default options for a comparison. These are:

  • IgnoreFileGroups
  • IgnoreFillFactor
  • IgnoreUserProperties
  • IgnoreWhiteSpace
  • IgnoreWithElementOrder
  • IncludeDependencies
  • IgnoreDatabaseNames
ForceColumnOrder
Force table column order to be identical.
IgnoreFillFactor
Ignore fill factor.
IgnorePermissions
Ignore permissions.
IgnoreWhiteSpace
Ignore white space.
IgnoreBindings
Ignore bindings.
IgnoreQuotedIdentifiersAndAnsiNullSettings
Ignore SET QUOTED_IDENTIFIER and SET ANSI_NULLS statements.
CaseSensitiveObjectDefinition
Treat items as case sensitive.
IgnoreExtendedProperties
Ignore extended properties
IgnoreFullTextIndexing
Ignore full text indexing.
NoSQLPlumbing
Do not include plumbing for transactional synchronization scripts.
IgnoreCollations
Ignore collation order.
IgnoreComments
Ignore comments.
IgnoreIndexes
Ignore indexes.
IgnoreKeys
Ignore foreign keys.
IgnoreChecks
Ignore check constraints.
IgnoreTriggers
Ignore DML triggers.
IncludeDependencies
Include dependencies.
IgnoreInsteadOfTriggers
Ignore INSTEAD OF triggers.
IgnoreFileGroups
Ignore filegroups, partition schemes, and partition functions.
IgnoreIdentitySeedAndIncrement
Ignore identity seed and increment values.
IgnoreWithNocheck
Ignore WITH NOCHECK on foreign keys and check constraints.
IgnoreConstraintNames
Ignore constraint names.
IgnoreStatistics
Ignore statistics.
DoNotOutputCommentHeader
Do not output comment header.
AddWithEncryption
Add WITH ENCRYPTION option to stored procedures etc.
IgnoreSynonymDependencies
Ignore dependencies through synonyms.
SeparateTriggers
Separate triggers from tables and views.
IgnoreOwners
Ignore owners when checking for equality.
IgnoreQueueEventNotifications
Ignore event notifications on queues.
TargetIsPre2005
Flag target database as prior to SQL Server 2005. Internal use only.
UseClrUdtToStringForClrMigration
If a CLR assembly must be changed, unbind the dependent types from tables using ToString, and then convert these table values back to CLR type.
ConsiderNextFilegroupInPartitionSchemes
If set, the next filegroups in partition schemes are compared with the filegroups that have a partition range associated with them.
IgnoreCertificatesAndCryptoKeys
Ignore certificates, symmetric keys, and asymmetric keys in SQL Server 2005 databases.
IgnoreTriggerOrder
Ignore trigger order.
IgnoreUsers
Ignore users' permissions and role memberships.
IgnoreUserProperties
Ignore user properties.
DisableAndReenableDdlTriggers
Disable and later re-enable DDL triggers. SQL Server 2005 only.
IgnoreWithElementOrder
Ignore the order of with elements in non CLR stored procedures, functions, triggers, DDL triggers, and views.
IgnoreIndexLockProperties
Ignore the lock properties of indexes.
IgnoreReplicationTriggers
Ignore replication triggers.
IgnoreIdentityProperties
Ignores identity properties.
IgnoreNotForReplication
Ignores NOT FOR REPLICATION.
TargetIsPre2008
Flag target database as prior to SQL Server 2008. Internal use only.
IgnoreDataCompression
Ignores data compression.
IgnoreDatabaseName
Ignores database names in synonyms
AddDatabaseUseStatement
Adds a USE statement at the top of the sync sql
IgnoreSchemaObjectAuthorization
Ignores owner authorization on schema objects.
DecryptPost2kEncryptedObjects
Decrypt 2005 and 2008 encrypted objects. Note that this can have a significant performance impact.

See Also


Parameter Class

[image]

SQL Data Compare API 7.1.0
Parameter Class
Members See Also

A SQL Server parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter
C#
public sealed class Parameter
Visual C++
public ref class Parameter sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Parameter

See Also

Parameter Members


Parameter Members

[image] [image]

SQL Data Compare API 7.1.0
Parameter Members
Parameter Class Methods Properties See Also

The Parameter type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collation | The collation of the parameter.
DefaultValue | The default value of the parameter.
DefinedSize | The length of the parameter.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
HasDefaultValue | True if there is a default value.
IsOutput | Indicates whether the parameter is an output parameter.
Name | The name of the parameter.
Precision | The precision of a decimal or numeric data type.
Scale | The scale of the parameter.
SqlType | The type of the parameter.
TypeName | The name of the type of the parameter.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | True if the parameter is an XML document.
XmlSchemaCollection | The XML schema collection for strongly-typed XML parameters.

See Also

Parameter Class


Parameter Methods

[image] [image]

SQL Data Compare API 7.1.0
Parameter Methods
Parameter Class See Also

The Parameter type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Parameter..::.Equals Method
Parameter Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Parameter, Options) | Compares the parameter with a specified parameter.

See Also

Parameter Class
Parameter Members


Equals Method (Parameter, Options)

[image]

SQL Data Compare API 7.1.0
Parameter..::.Equals Method (Parameter, Options)
Parameter Class See Also

Compares the parameter with a specified parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetParameter As Parameter, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Parameter targetParameter,
    Options options
)
Visual C++
public:
bool Equals(
    Parameter^ targetParameter,
    Options options
)

Parameters

targetParameter
Type: RedGate.SQLCompare.Engine..::.Parameter
The parameter to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the parameters are identical; otherwise, false.

See Also

Parameter Class
Equals Overload


Parameter Properties

[image] [image]

SQL Data Compare API 7.1.0
Parameter Properties
Parameter Class See Also

The Parameter type exposes the following properties.

Properties

Name | Description
Collation | The collation of the parameter.
DefaultValue | The default value of the parameter.
DefinedSize | The length of the parameter.
FullyQualifiedTypeName | The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.
HasDefaultValue | True if there is a default value.
IsOutput | Indicates whether the parameter is an output parameter.
Name | The name of the parameter.
Precision | The precision of a decimal or numeric data type.
Scale | The scale of the parameter.
SqlType | The type of the parameter.
TypeName | The name of the type of the parameter.
TypeSchemaName | The name of the schema for the field's data type.
XmlDocument | True if the parameter is an XML document.
XmlSchemaCollection | The XML schema collection for strongly-typed XML parameters.

See Also

Parameter Class


Collation Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.Collation Property
Parameter Class See Also

The collation of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Collation As String
C#
public string Collation { get; internal set; }
Visual C++
public:
property String^ Collation {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class


DefaultValue Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.DefaultValue Property
Parameter Class See Also

The default value of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; internal set; }
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class


DefinedSize Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.DefinedSize Property
Parameter Class See Also

The length of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefinedSize As Integer
C#
public int DefinedSize { get; internal set; }
Visual C++
public:
property int DefinedSize {
    int get ();
    void set (int value);
}

Remarks

Valid only for character and binary data.

See Also

Parameter Class


FullyQualifiedTypeName Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.FullyQualifiedTypeName Property
Parameter Class See Also

The name of the fully-qualified field type. For SQL Server 2005, this property contains the schema name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedTypeName As String
C#
public string FullyQualifiedTypeName { get; }
Visual C++
public:
property String^ FullyQualifiedTypeName {
    String^ get ();
}

See Also

Parameter Class


HasDefaultValue Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.HasDefaultValue Property
Parameter Class See Also

True if there is a default value.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasDefaultValue As Boolean
C#
public bool HasDefaultValue { get; internal set; }
Visual C++
public:
property bool HasDefaultValue {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class


IsOutput Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.IsOutput Property
Parameter Class See Also

Indicates whether the parameter is an output parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsOutput As Boolean
C#
public bool IsOutput { get; internal set; }
Visual C++
public:
property bool IsOutput {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class


Name Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.Name Property
Parameter Class See Also

The name of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; internal set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class


Precision Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.Precision Property
Parameter Class See Also

The precision of a decimal or numeric data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

Parameter Class


Scale Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.Scale Property
Parameter Class See Also

The scale of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

Valid for numeric and decimal data types.

See Also

Parameter Class


SqlType Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.SqlType Property
Parameter Class See Also

The type of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; internal set; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

Parameter Class


TypeName Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.TypeName Property
Parameter Class See Also

The name of the type of the parameter.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
C#
public string TypeName { get; internal set; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class


TypeSchemaName Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.TypeSchemaName Property
Parameter Class See Also

The name of the schema for the field's data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSchemaName As String
C#
public string TypeSchemaName { get; internal set; }
Visual C++
public:
property String^ TypeSchemaName {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class


XmlDocument Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.XmlDocument Property
Parameter Class See Also

True if the parameter is an XML document.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocument As Boolean
C#
public bool XmlDocument { get; internal set; }
Visual C++
public:
property bool XmlDocument {
    bool get ();
    void set (bool value);
}

See Also

Parameter Class


XmlSchemaCollection Property

[image]

SQL Data Compare API 7.1.0
Parameter..::.XmlSchemaCollection Property
Parameter Class See Also

The XML schema collection for strongly-typed XML parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlSchemaCollection As XmlSchemaCollection
C#
public XmlSchemaCollection XmlSchemaCollection { get; internal set; }
Visual C++
public:
property XmlSchemaCollection^ XmlSchemaCollection {
    XmlSchemaCollection^ get ();
    void set (XmlSchemaCollection^ value);
}

See Also

Parameter Class


Parameters Class

[image]

SQL Data Compare API 7.1.0
Parameters Class
Members See Also

A collection of parameters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameters _
    Inherits SerializableCollection(Of Parameter)
C#
public sealed class Parameters : SerializableCollection<Parameter>
Visual C++
public ref class Parameters sealed : public SerializableCollection<Parameter^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Parameter >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Parameter >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Parameter >)>)
RedGate.SQLCompare.Engine..::.Parameters

See Also

Parameters Members


Parameters Members

[image] [image]

SQL Data Compare API 7.1.0
Parameters Members
Parameters Class Methods Properties Explicit Interface Implementations See Also

The Parameters type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Parameters Class


Parameters Methods

[image] [image]

SQL Data Compare API 7.1.0
Parameters Methods
Parameters Class See Also

The Parameters type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Parameters Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Parameters..::.Equals Method
Parameters Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Parameters, Options) | Compares the parameters collection with a specified parameters collection.

See Also

Parameters Class
Parameters Members


Equals Method (Parameters, Options)

[image]

SQL Data Compare API 7.1.0
Parameters..::.Equals Method (Parameters, Options)
Parameters Class See Also

Compares the parameters collection with a specified parameters collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    target As Parameters, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Parameters target,
    Options options
)
Visual C++
public:
bool Equals(
    Parameters^ target,
    Options options
)

Parameters

target
Type: RedGate.SQLCompare.Engine..::.Parameters
The collection of parameters to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the parameter collections are identical; otherwise, false.

See Also

Parameters Class
Equals Overload


Parameters Properties

[image] [image]

SQL Data Compare API 7.1.0
Parameters Properties
Parameters Class See Also

The Parameters type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Parameters Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Parameters..::.Item Property
Parameters Class See Also

Overload List

Name | Description
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(Int32])]) | Returns the parameter at the specified position. (Overrides KeyedCollection <(Of <( Parameter >)>)..::. Item[([(Int32])]).)

See Also

Parameters Class
Parameters Members


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
Parameters..::.Item Property (Int32)
Parameters Class See Also

Returns the parameter at the specified position.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    index As Integer _
) As Parameter
C#
public override Parameter this[
    int index
] { get; }
Visual C++
public:
virtual property Parameter^ default[int index] {
    Parameter^ get (int index) override;
}

Parameters

index
Type: System..::.Int32
The zero-based index of the element to get or set.

See Also

Parameters Class
Item Overload


PartitionFunction Class

[image]

SQL Data Compare API 7.1.0
PartitionFunction Class
Members See Also

A partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionFunction _
    Inherits ScriptableDatabaseObject
C#
public sealed class PartitionFunction : ScriptableDatabaseObject
Visual C++
public ref class PartitionFunction sealed : public ScriptableDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.PartitionFunction

See Also

PartitionFunction Members


PartitionFunction Members

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunction Members
PartitionFunction Class Methods Fields Properties See Also

The PartitionFunction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition function.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.PartitionFunction (Overrides ScriptableDatabaseObject ..::. ObjectType.)
OnRight | True if the boundary values belong to the interval on the right.
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the function.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Values | The boundary values.

See Also

PartitionFunction Class


PartitionFunction Methods

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunction Methods
PartitionFunction Class See Also

The PartitionFunction type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PartitionFunction Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunction..::.Equals Method
PartitionFunction Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the partition function with a specified partition function. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

PartitionFunction Class
PartitionFunction Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.Equals Method (IDatabaseObject, Options)
PartitionFunction Class See Also

Compares the partition function with a specified partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The partition function to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the partition functions are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

PartitionFunction Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.ScriptObject Method
PartitionFunction Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

PartitionFunction Class


PartitionFunction Properties

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunction Properties
PartitionFunction Class See Also

The PartitionFunction type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition function.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.PartitionFunction (Overrides ScriptableDatabaseObject ..::. ObjectType.)
OnRight | True if the boundary values belong to the interval on the right.
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the function.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Values | The boundary values.

See Also

PartitionFunction Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.ExtendedProperties Property
PartitionFunction Class See Also

The extended properties defined for the partition function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

PartitionFunction Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.ObjectType Property
PartitionFunction Class See Also

Returns ObjectType.PartitionFunction

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType

See Also

PartitionFunction Class


OnRight Property

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.OnRight Property
PartitionFunction Class See Also

True if the boundary values belong to the interval on the right.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property OnRight As Boolean
C#
public bool OnRight { get; internal set; }
Visual C++
public:
property bool OnRight {
    bool get ();
    void set (bool value);
}

See Also

PartitionFunction Class


Parameters Property

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.Parameters Property
PartitionFunction Class See Also

The parameters of the function.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

PartitionFunction Class


Values Property

[image]

SQL Data Compare API 7.1.0
PartitionFunction..::.Values Property
PartitionFunction Class See Also

The boundary values.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Values As Object()
C#
public Object[] Values { get; internal set; }
Visual C++
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

See Also

PartitionFunction Class


PartitionFunctions Class

[image]

SQL Data Compare API 7.1.0
PartitionFunctions Class
Members See Also

A collection of partition functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionFunctions _
    Inherits SerializableDatabaseObjectCollection(Of PartitionFunction)
C#
public sealed class PartitionFunctions : SerializableDatabaseObjectCollection<PartitionFunction>
Visual C++
public ref class PartitionFunctions sealed : public SerializableDatabaseObjectCollection<PartitionFunction^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( PartitionFunction >)>)
RedGate.SQLCompare.Engine..::.PartitionFunctions

See Also

PartitionFunctions Members


PartitionFunctions Members

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunctions Members
PartitionFunctions Class Methods Properties Explicit Interface Implementations See Also

The PartitionFunctions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

PartitionFunctions Class


PartitionScheme Class

[image]

SQL Data Compare API 7.1.0
PartitionScheme Class
Members See Also

A partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionScheme _
    Inherits ScriptableDatabaseObject
C#
public sealed class PartitionScheme : ScriptableDatabaseObject
Visual C++
public ref class PartitionScheme sealed : public ScriptableDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.PartitionScheme

See Also

PartitionScheme Members


PartitionScheme Members

[image] [image]

SQL Data Compare API 7.1.0
PartitionScheme Members
PartitionScheme Class Methods Fields Properties See Also

The PartitionScheme type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition scheme.
FileGroups | The filegroups that are used for partitioning.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Function | The partition function for the partition scheme.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)

See Also

PartitionScheme Class


PartitionScheme Methods

[image] [image]

SQL Data Compare API 7.1.0
PartitionScheme Methods
PartitionScheme Class See Also

The PartitionScheme type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PartitionScheme Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
PartitionScheme..::.Equals Method
PartitionScheme Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the partition scheme with a specified partition scheme. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

PartitionScheme Class
PartitionScheme Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.Equals Method (IDatabaseObject, Options)
PartitionScheme Class See Also

Compares the partition scheme with a specified partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The partition scheme to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the partition schemes are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

PartitionScheme Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.ScriptObject Method
PartitionScheme Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

PartitionScheme Class


PartitionScheme Properties

[image] [image]

SQL Data Compare API 7.1.0
PartitionScheme Properties
PartitionScheme Class See Also

The PartitionScheme type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the partition scheme.
FileGroups | The filegroups that are used for partitioning.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Function | The partition function for the partition scheme.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)

See Also

PartitionScheme Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.ExtendedProperties Property
PartitionScheme Class See Also

The extended properties defined for the partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

PartitionScheme Class


FileGroups Property

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.FileGroups Property
PartitionScheme Class See Also

The filegroups that are used for partitioning.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileGroups As FileGroups
C#
public FileGroups FileGroups { get; }
Visual C++
public:
property FileGroups^ FileGroups {
    FileGroups^ get ();
}

See Also

PartitionScheme Class


Function Property

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.Function Property
PartitionScheme Class See Also

The partition function for the partition scheme.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Function As PartitionFunction
C#
public PartitionFunction Function { get; internal set; }
Visual C++
public:
property PartitionFunction^ Function {
    PartitionFunction^ get ();
    void set (PartitionFunction^ value);
}

See Also

PartitionScheme Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
PartitionScheme..::.ObjectType Property
PartitionScheme Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType

See Also

PartitionScheme Class


PartitionSchemes Class

[image]

SQL Data Compare API 7.1.0
PartitionSchemes Class
Members See Also

A collection of partition schemes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PartitionSchemes _
    Inherits SerializableDatabaseObjectCollection(Of PartitionScheme)
C#
public sealed class PartitionSchemes : SerializableDatabaseObjectCollection<PartitionScheme>
Visual C++
public ref class PartitionSchemes sealed : public SerializableDatabaseObjectCollection<PartitionScheme^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( PartitionScheme >)>)
RedGate.SQLCompare.Engine..::.PartitionSchemes

See Also

PartitionSchemes Members


PartitionSchemes Members

[image] [image]

SQL Data Compare API 7.1.0
PartitionSchemes Members
PartitionSchemes Class Methods Properties Explicit Interface Implementations See Also

The PartitionSchemes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

PartitionSchemes Class


Permission Class

[image]

SQL Data Compare API 7.1.0
Permission Class
Members See Also

A permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Permission
C#
public sealed class Permission
Visual C++
public ref class Permission sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Permission

See Also

Permission Members


Permission Members

[image] [image]

SQL Data Compare API 7.1.0
Permission Members
Permission Class Methods Properties See Also

The Permission type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | The action to which the permission applies.
Fields | The fields to which the permission applies.
PermissionClass | The class of permission (for example, object, XML schema collection).
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

Permission Class


Permission Properties

[image] [image]

SQL Data Compare API 7.1.0
Permission Properties
Permission Class See Also

The Permission type exposes the following properties.

Properties

Name | Description
Action | The action to which the permission applies.
Fields | The fields to which the permission applies.
PermissionClass | The class of permission (for example, object, XML schema collection).
Type | The type of permission.
UserName | The user or role to which the permission applies.

See Also

Permission Class


Action Property

[image]

SQL Data Compare API 7.1.0
Permission..::.Action Property
Permission Class See Also

The action to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Action As PermissionAction
C#
public PermissionAction Action { get; internal set; }
Visual C++
public:
property PermissionAction Action {
    PermissionAction get ();
    void set (PermissionAction value);
}

See Also

Permission Class


Fields Property

[image]

SQL Data Compare API 7.1.0
Permission..::.Fields Property
Permission Class See Also

The fields to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Fields As Fields
C#
public Fields Fields { get; internal set; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
    void set (Fields^ value);
}

See Also

Permission Class


PermissionClass Property

[image]

SQL Data Compare API 7.1.0
Permission..::.PermissionClass Property
Permission Class See Also

The class of permission (for example, object, XML schema collection).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PermissionClass As PermissionClass
C#
public PermissionClass PermissionClass { get; internal set; }
Visual C++
public:
property PermissionClass PermissionClass {
    PermissionClass get ();
    void set (PermissionClass value);
}

See Also

Permission Class


Type Property

[image]

SQL Data Compare API 7.1.0
Permission..::.Type Property
Permission Class See Also

The type of permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As PermissionType
C#
public PermissionType Type { get; internal set; }
Visual C++
public:
property PermissionType Type {
    PermissionType get ();
    void set (PermissionType value);
}

See Also

Permission Class


UserName Property

[image]

SQL Data Compare API 7.1.0
Permission..::.UserName Property
Permission Class See Also

The user or role to which the permission applies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; internal set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

Permission Class


PermissionAction Enumeration

[image]

SQL Data Compare API 7.1.0
PermissionAction Enumeration
See Also

The action that a permission allows.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionAction
C#
public enum PermissionAction
Visual C++
public enum class PermissionAction

Members

Member name | Description
None | Used for error handling.
Alter | Alter.
Control | Control.
ReceiveOrImpersonate | Receive in the case of objects; Impersonate in the case of users.
Send | Send.
TakeOwnership | Take ownership.
ViewDefinition | View definition.
References | References.
Select | Select.
Insert | Insert .
Delete | Delete.
Update | Update.
Execute | Execute.

See Also


PermissionClass Enumeration

[image]

SQL Data Compare API 7.1.0
PermissionClass Enumeration
See Also

The class on which the permission exists.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionClass
C#
public enum PermissionClass
Visual C++
public enum class PermissionClass

Members

Member name | Description
Other | None, this is used for error handling.
Database | Database.
ObjectOrColumn | Object or column. Prior to SQL Server 2005, this is the only permission class used.
Schema | Schema.
DatabasePrincipal | Database principal.
Assembly | Assembly.
Type | Type.
XmlSchemaCollection | XML schema collection.
MessageType | Message type.
ServiceContract | Service contract.
Service | Service.
RemoteServiceBinding | Remote service binding.
Route | Route.
FullTextCatalog | Full text catalog
SymmetricKey | Symmetric key.
AsymmetricKey | Asymmetric key.
Certificate | Certificate.

See Also


Permissions Class

[image]

SQL Data Compare API 7.1.0
Permissions Class
Members See Also

A collection of permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Permissions _
    Inherits InnerList(Of Permission)
C#
public sealed class Permissions : InnerList<Permission>
Visual C++
public ref class Permissions sealed : public InnerList<Permission^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Permission >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Permission >)>)
RedGate.SQLCompare.Engine..::.Permissions

See Also

Permissions Members


Permissions Members

[image] [image]

SQL Data Compare API 7.1.0
Permissions Members
Permissions Class Methods Properties Explicit Interface Implementations See Also

The Permissions type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Permissions Class


PermissionSet Enumeration

[image]

SQL Data Compare API 7.1.0
PermissionSet Enumeration
See Also

The code access permissions for CLR assemblies.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionSet
C#
public enum PermissionSet
Visual C++
public enum class PermissionSet

Members

Member name | Description
SAFE | Safe.
EXTERNAL_ACCESS | External access.
UNSAFE | Unsafe.

See Also


PermissionType Enumeration

[image]

SQL Data Compare API 7.1.0
PermissionType Enumeration
See Also

The type of permission.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PermissionType
C#
public enum PermissionType
Visual C++
public enum class PermissionType

Members

Member name | Description
None | None.
GrantWithGrant | Grant with grant option.
Grant | Grant.
Deny | Deny.
Revoke | Revoke.

See Also


PrepareStringDelegate(TMap, TContext) Generic Delegate

[image]

SQL Data Compare API 7.1.0
PrepareStringDelegate<(Of <(TMap, TContext>)>) Generic Delegate
See Also

Creates the name used for comparing two objects when creating mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function PrepareStringDelegate(Of TMap As {Class, IDatabaseObject}, TContext) ( _
    obj As TMap, _
    useFullName As Boolean, _
    context As TContext _
) As String
C#
public delegate string PrepareStringDelegate<TMap, TContext>(
    TMap obj,
    bool useFullName,
    TContext context
) where TMap : class, IDatabaseObject
Visual C++
generic<typename TMap, typename TContext>
where TMap : ref class, IDatabaseObject
public delegate String^ PrepareStringDelegate(
    TMap obj,
    bool useFullName,
    TContext context
)

Parameters

obj
Type: TMap
The object for which the name is to be generated.
useFullName
Type: System..::.Boolean
If true, uses the fully-qualified name. If false, uses the name.
context
Type: TContext
The context object passed back from the Mappings class.

Type Parameters

TMap
The type stored in the mapping.
TContext
The type of the context object.

See Also


Project Class

[image]

SQL Data Compare API 7.1.0
Project Class
Members Example See Also

A SQL Compare project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Project
C#
public sealed class Project
Visual C++
public ref class Project sealed

Remarks

Use this class to load projects generated by SQL Compare, or to save projects for SQL Compare. Note that a project contains only connection information. It does not contain information about database schemas.

Examples

This example shows how to save and load a project.
C# Copy Code
            Project project1=new Project();

            //by default DataSource1/DataSource2 are created as a LiveDatabaseSources with
            //the server name set to "(local)".
            project1.DataSource1.DatabaseName = "WidgetProduction";
            project1.DataSource2.DatabaseName = "WidgetStaging";

            //this project can now be opened up in SQL Compare
            project1.SaveToDisk(@"c:\A sample project.scp");

            //load the project from disk
            Project project2=Project.LoadFromDisk(@"c:\A sample project.scp");

            Console.WriteLine(project2.FileName);
Visual Basic Copy Code
            Dim project1 As New Project()

            'by default DataSource1/DataSource2 are created as a LiveDatabaseSources with
            'the server name set to "(local)".
            project1.DataSource1.DatabaseName = "WidgetProduction"
            project1.DataSource2.DatabaseName = "WidgetStaging"

            'this project can now be opened up in SQL Compare
            project1.SaveToDisk("c:\A sample project.scp")

            'load the project from disk
            Dim project2 As Project = Project.LoadFromDisk("c:\A sample project.scp")

            Console.WriteLine(project2.FileName)

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Project

See Also

Project Members


Project Members

[image] [image]

SQL Data Compare API 7.1.0
Project Members
Project Class Constructors Methods Properties See Also

The Project type exposes the following members.

Constructors

Name | Description
Project | Constructor.

Methods

Name | Description
ChangeSynchronizationDirection | Changes the direction in which changes are to be migrated.
CreateNew | Creates a new blank project.
Deserialize | Support for serialization.
DiscardClone | Discards the current clone.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToDisk | Save the project to disk
Serialize | Support for serialization.
SynchronizeClone | Synchronizes the settings in the clone with the settings in the main object.
ToString | Converts an instance of Project to a string. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Clone | Returns a clone of the current project.
ComparisonOptions | Options used when running a comparison or synchronization on the project.
DataSource1 | The connection properties for the first data source.
DataSource2 | The connection properties for the second data source.
Direction | The direction in which changes are migrated when a synchronization is run on the project.
Dirty | True if the project has been modified.
FileName | The file name of the project.
HasClone | Returns true if the current project has been cloned.
IsNewProject | Determines whether the project is a new project.
LastCompared | The time at which the project was last compared.
Name | The file name of a project, or "New Project".
ObjectSelectionUserActions | Gets or sets the ObjectSelectionUserActions.
SelectedFilters | Gets or sets SelectedFilters.
Source1AsLiveDB | A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.
Source2AsLiveDB | A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.
UserNote | Gets or sets the user notes.
Version | The current project version. Used for serialization.

See Also

Project Class


Project Constructor

[image]

SQL Data Compare API 7.1.0
Project Constructor
Project Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Project()
Visual C++
public:
Project()

See Also

Project Class


Project Methods

[image] [image]

SQL Data Compare API 7.1.0
Project Methods
Project Class See Also

The Project type exposes the following methods.

Methods

Name | Description
ChangeSynchronizationDirection | Changes the direction in which changes are to be migrated.
CreateNew | Creates a new blank project.
Deserialize | Support for serialization.
DiscardClone | Discards the current clone.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveToDisk | Save the project to disk
Serialize | Support for serialization.
SynchronizeClone | Synchronizes the settings in the clone with the settings in the main object.
ToString | Converts an instance of Project to a string. (Overrides Object ..::. ToString()()().)

See Also

Project Class


ChangeSynchronizationDirection Method

[image]

SQL Data Compare API 7.1.0
Project..::.ChangeSynchronizationDirection Method
Project Class See Also

Changes the direction in which changes are to be migrated.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeSynchronizationDirection
C#
public void ChangeSynchronizationDirection()
Visual C++
public:
void ChangeSynchronizationDirection()

See Also

Project Class


CreateNew Method

[image]

SQL Data Compare API 7.1.0
Project..::.CreateNew Method
Project Class See Also

Creates a new blank project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateNew As Project
C#
public static Project CreateNew()
Visual C++
public:
static Project^ CreateNew()

Return Value

A new instance of class Project.

See Also

Project Class


Deserialize Method

[image]

SQL Data Compare API 7.1.0
Project..::.Deserialize Method
Project Class See Also

Support for serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

versionId
Type: System..::.Int32
The version of the project to be deserialized.
formatter
Type: ISerializeFormatter
The formatter to read from.

Return Value

true on success.

See Also

Project Class


DiscardClone Method

[image]

SQL Data Compare API 7.1.0
Project..::.DiscardClone Method
Project Class See Also

Discards the current clone.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub DiscardClone
C#
public void DiscardClone()
Visual C++
public:
void DiscardClone()

See Also

Project Class


LoadFromDisk Method

[image]

SQL Data Compare API 7.1.0
Project..::.LoadFromDisk Method
Project Class See Also

Loads a project from disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromDisk ( _
    fileName As String _
) As Project
C#
public static Project LoadFromDisk(
    string fileName
)
Visual C++
public:
static Project^ LoadFromDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file name of the project.

Return Value

A Project object.

See Also

Project Class


SaveToDisk Method

[image]

SQL Data Compare API 7.1.0
Project..::.SaveToDisk Method
Project Class See Also

Save the project to disk

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToDisk ( _
    fileName As String _
)
C#
public void SaveToDisk(
    string fileName
)
Visual C++
public:
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file name

See Also

Project Class


Serialize Method

[image]

SQL Data Compare API 7.1.0
Project..::.Serialize Method
Project Class See Also

Support for serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter
The formatter to write to.

See Also

Project Class


SynchronizeClone Method

[image]

SQL Data Compare API 7.1.0
Project..::.SynchronizeClone Method
Project Class See Also

Synchronizes the settings in the clone with the settings in the main object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SynchronizeClone
C#
public void SynchronizeClone()
Visual C++
public:
void SynchronizeClone()

See Also

Project Class


ToString Method

[image]

SQL Data Compare API 7.1.0
Project..::.ToString Method
Project Class See Also

Converts an instance of Project to a string.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the project details.

See Also

Project Class


Project Properties

[image] [image]

SQL Data Compare API 7.1.0
Project Properties
Project Class See Also

The Project type exposes the following properties.

Properties

Name | Description
Clone | Returns a clone of the current project.
ComparisonOptions | Options used when running a comparison or synchronization on the project.
DataSource1 | The connection properties for the first data source.
DataSource2 | The connection properties for the second data source.
Direction | The direction in which changes are migrated when a synchronization is run on the project.
Dirty | True if the project has been modified.
FileName | The file name of the project.
HasClone | Returns true if the current project has been cloned.
IsNewProject | Determines whether the project is a new project.
LastCompared | The time at which the project was last compared.
Name | The file name of a project, or "New Project".
ObjectSelectionUserActions | Gets or sets the ObjectSelectionUserActions.
SelectedFilters | Gets or sets SelectedFilters.
Source1AsLiveDB | A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.
Source2AsLiveDB | A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.
UserNote | Gets or sets the user notes.
Version | The current project version. Used for serialization.

See Also

Project Class


Clone Property

[image]

SQL Data Compare API 7.1.0
Project..::.Clone Property
Project Class See Also

Returns a clone of the current project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Clone As Project
C#
public Project Clone { get; }
Visual C++
public:
property Project^ Clone {
    Project^ get ();
}

Remarks

Used for holding softstate inside the UI.

See Also

Project Class


ComparisonOptions Property

[image]

SQL Data Compare API 7.1.0
Project..::.ComparisonOptions Property
Project Class See Also

Options used when running a comparison or synchronization on the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ComparisonOptions As Options
C#
public Options ComparisonOptions { get; set; }
Visual C++
public:
property Options ComparisonOptions {
    Options get ();
    void set (Options value);
}

See Also

Project Class


DataSource1 Property

[image]

SQL Data Compare API 7.1.0
Project..::.DataSource1 Property
Project Class See Also

The connection properties for the first data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource1 As DataSource
C#
public DataSource DataSource1 { get; set; }
Visual C++
public:
property DataSource^ DataSource1 {
    DataSource^ get ();
    void set (DataSource^ value);
}

See Also

Project Class


DataSource2 Property

[image]

SQL Data Compare API 7.1.0
Project..::.DataSource2 Property
Project Class See Also

The connection properties for the second data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource2 As DataSource
C#
public DataSource DataSource2 { get; set; }
Visual C++
public:
property DataSource^ DataSource2 {
    DataSource^ get ();
    void set (DataSource^ value);
}

See Also

Project Class


Direction Property

[image]

SQL Data Compare API 7.1.0
Project..::.Direction Property
Project Class See Also

The direction in which changes are migrated when a synchronization is run on the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Direction As SynchronizationDirection
C#
public SynchronizationDirection Direction { get; set; }
Visual C++
public:
property SynchronizationDirection Direction {
    SynchronizationDirection get ();
    void set (SynchronizationDirection value);
}

See Also

Project Class


Dirty Property

[image]

SQL Data Compare API 7.1.0
Project..::.Dirty Property
Project Class See Also

True if the project has been modified.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dirty As Boolean
C#
public bool Dirty { get; }
Visual C++
public:
property bool Dirty {
    bool get ();
}

See Also

Project Class


FileName Property

[image]

SQL Data Compare API 7.1.0
Project..::.FileName Property
Project Class See Also

The file name of the project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class


HasClone Property

[image]

SQL Data Compare API 7.1.0
Project..::.HasClone Property
Project Class See Also

Returns true if the current project has been cloned.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasClone As Boolean
C#
public bool HasClone { get; }
Visual C++
public:
property bool HasClone {
    bool get ();
}

See Also

Project Class


IsNewProject Property

[image]

SQL Data Compare API 7.1.0
Project..::.IsNewProject Property
Project Class See Also

Determines whether the project is a new project.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNewProject As Boolean
C#
public bool IsNewProject { get; }
Visual C++
public:
property bool IsNewProject {
    bool get ();
}

See Also

Project Class


LastCompared Property

[image]

SQL Data Compare API 7.1.0
Project..::.LastCompared Property
Project Class See Also

The time at which the project was last compared.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastCompared As DateTime
C#
public DateTime LastCompared { get; set; }
Visual C++
public:
property DateTime LastCompared {
    DateTime get ();
    void set (DateTime value);
}

See Also

Project Class


Name Property

[image]

SQL Data Compare API 7.1.0
Project..::.Name Property
Project Class See Also

The file name of a project, or "New Project".

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Project Class


ObjectSelectionUserActions Property

[image]

SQL Data Compare API 7.1.0
Project..::.ObjectSelectionUserActions Property
Project Class See Also

Gets or sets the ObjectSelectionUserActions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectSelectionUserActions As ArrayList
C#
public ArrayList ObjectSelectionUserActions { get; set; }
Visual C++
public:
property ArrayList^ ObjectSelectionUserActions {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

Project Class


SelectedFilters Property

[image]

SQL Data Compare API 7.1.0
Project..::.SelectedFilters Property
Project Class See Also

Gets or sets SelectedFilters.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedFilters As ArrayList
C#
public ArrayList SelectedFilters { get; set; }
Visual C++
public:
property ArrayList^ SelectedFilters {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

Project Class


Source1AsLiveDB Property

[image]

SQL Data Compare API 7.1.0
Project..::.Source1AsLiveDB Property
Project Class See Also

A convenience method for accessing the first data source as a live database, rather than casting explicitly in code.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source1AsLiveDB As LiveDatabaseSource
C#
public LiveDatabaseSource Source1AsLiveDB { get; }
Visual C++
public:
property LiveDatabaseSource^ Source1AsLiveDB {
    LiveDatabaseSource^ get ();
}

See Also

Project Class


Source2AsLiveDB Property

[image]

SQL Data Compare API 7.1.0
Project..::.Source2AsLiveDB Property
Project Class See Also

A convenience method for accessing the second data source as a live database, rather than casting explicitly in code.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source2AsLiveDB As LiveDatabaseSource
C#
public LiveDatabaseSource Source2AsLiveDB { get; }
Visual C++
public:
property LiveDatabaseSource^ Source2AsLiveDB {
    LiveDatabaseSource^ get ();
}

See Also

Project Class


UserNote Property

[image]

SQL Data Compare API 7.1.0
Project..::.UserNote Property
Project Class See Also

Gets or sets the user notes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserNote As String
C#
public string UserNote { get; set; }
Visual C++
public:
property String^ UserNote {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class


Version Property

[image]

SQL Data Compare API 7.1.0
Project..::.Version Property
Project Class See Also

The current project version. Used for serialization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

Project Class


Queue Class

[image]

SQL Data Compare API 7.1.0
Queue Class
Members See Also

A queue.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Queue _
    Inherits SchemaObjectWithAuthorization _
    Implements IIsSystemObject, IExecuteAs, IHasPermissions, IDatabaseObject
C#
public sealed class Queue : SchemaObjectWithAuthorization, IIsSystemObject,
    IExecuteAs, IHasPermissions, IDatabaseObject
Visual C++
public ref class Queue sealed : public SchemaObjectWithAuthorization,
    IIsSystemObject, IExecuteAs, IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Queue

See Also

Queue Members


Queue Members

[image] [image]

SQL Data Compare API 7.1.0
Queue Members
Queue Class Methods Fields Properties See Also

The Queue type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
ActivationEnabled | True if the activation is enabled.
ActivationProcedure | The name of the activation stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnqueueEnabled | True if enqueue is enabled.
EventNotifications | The dependent event notifications.
ExecuteAs | The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.
ExecuteAsOwner | True if the security context of the owner of the queue is to be used for the execution.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FileGroup | The filegroup for the queue.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
IsSystemObject | Indicates whether the object in question is a system object.
MaxReaders | The maximum number of readers.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Queue (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this queue.
ReceiveEnabled | True if the queue is receive enabled.
RetentionEnabled | True if retention is enabled.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Services | The dependent services.

See Also

Queue Class


Queue Methods

[image] [image]

SQL Data Compare API 7.1.0
Queue Methods
Queue Class See Also

The Queue type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

Queue Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Queue..::.Equals Method
Queue Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

Queue Class
Queue Members


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Queue..::.ScriptObject Method
Queue Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Queue Class


Queue Properties

[image] [image]

SQL Data Compare API 7.1.0
Queue Properties
Queue Class See Also

The Queue type exposes the following properties.

Properties

Name | Description
ActivationEnabled | True if the activation is enabled.
ActivationProcedure | The name of the activation stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EnqueueEnabled | True if enqueue is enabled.
EventNotifications | The dependent event notifications.
ExecuteAs | The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.
ExecuteAsOwner | True if the security context of the owner of the queue is to be used for the execution.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FileGroup | The filegroup for the queue.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
IsSystemObject | Indicates whether the object in question is a system object.
MaxReaders | The maximum number of readers.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Queue (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this queue.
ReceiveEnabled | True if the queue is receive enabled.
RetentionEnabled | True if retention is enabled.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Services | The dependent services.

See Also

Queue Class


ActivationEnabled Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ActivationEnabled Property
Queue Class See Also

True if the activation is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivationEnabled As Boolean
C#
public bool ActivationEnabled { get; internal set; }
Visual C++
public:
property bool ActivationEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class


ActivationProcedure Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ActivationProcedure Property
Queue Class See Also

The name of the activation stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivationProcedure As String
C#
public string ActivationProcedure { get; internal set; }
Visual C++
public:
property String^ ActivationProcedure {
    String^ get ();
    void set (String^ value);
}

See Also

Queue Class


EnqueueEnabled Property

[image]

SQL Data Compare API 7.1.0
Queue..::.EnqueueEnabled Property
Queue Class See Also

True if enqueue is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property EnqueueEnabled As Boolean
C#
public bool EnqueueEnabled { get; internal set; }
Visual C++
public:
property bool EnqueueEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class


EventNotifications Property

[image]

SQL Data Compare API 7.1.0
Queue..::.EventNotifications Property
Queue Class See Also

The dependent event notifications.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

Queue Class


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ExecuteAs Property
Queue Class See Also

The user whose security context is to be used for the execution of the queue. This is a SQL Server 2005 feature only.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Queue Class


ExecuteAsOwner Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ExecuteAsOwner Property
Queue Class See Also

True if the security context of the owner of the queue is to be used for the execution.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAsOwner As Boolean
C#
public bool ExecuteAsOwner { get; internal set; }
Visual C++
public:
property bool ExecuteAsOwner {
    bool get ();
    void set (bool value);
}

See Also

Queue Class


FileGroup Property

[image]

SQL Data Compare API 7.1.0
Queue..::.FileGroup Property
Queue Class See Also

The filegroup for the queue.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Queue Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
Queue..::.IsSystemObject Property
Queue Class See Also

Indicates whether the object in question is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Queue Class


MaxReaders Property

[image]

SQL Data Compare API 7.1.0
Queue..::.MaxReaders Property
Queue Class See Also

The maximum number of readers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxReaders As Short
C#
public short MaxReaders { get; internal set; }
Visual C++
public:
property short MaxReaders {
    short get ();
    void set (short value);
}

See Also

Queue Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ObjectType Property
Queue Class See Also

Returns ObjectType.Queue

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Queue Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Queue..::.Permissions Property
Queue Class See Also

The permissions on this queue.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Queue Class


ReceiveEnabled Property

[image]

SQL Data Compare API 7.1.0
Queue..::.ReceiveEnabled Property
Queue Class See Also

True if the queue is receive enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReceiveEnabled As Boolean
C#
public bool ReceiveEnabled { get; internal set; }
Visual C++
public:
property bool ReceiveEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class


RetentionEnabled Property

[image]

SQL Data Compare API 7.1.0
Queue..::.RetentionEnabled Property
Queue Class See Also

True if retention is enabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RetentionEnabled As Boolean
C#
public bool RetentionEnabled { get; internal set; }
Visual C++
public:
property bool RetentionEnabled {
    bool get ();
    void set (bool value);
}

See Also

Queue Class


Services Property

[image]

SQL Data Compare API 7.1.0
Queue..::.Services Property
Queue Class See Also

The dependent services.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Services As Services
C#
public Services Services { get; }
Visual C++
public:
property Services^ Services {
    Services^ get ();
}

See Also

Queue Class


Queues Class

[image]

SQL Data Compare API 7.1.0
Queues Class
Members See Also

A collection of queues.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Queues _
    Inherits SerializableDatabaseObjectCollection(Of Queue)
C#
public sealed class Queues : SerializableDatabaseObjectCollection<Queue>
Visual C++
public ref class Queues sealed : public SerializableDatabaseObjectCollection<Queue^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Queue >)>)
RedGate.SQLCompare.Engine..::.Queues

See Also

Queues Members


Queues Members

[image] [image]

SQL Data Compare API 7.1.0
Queues Members
Queues Class Methods Properties Explicit Interface Implementations See Also

The Queues type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Queues Class


ReferentialAction Enumeration

[image]

SQL Data Compare API 7.1.0
ReferentialAction Enumeration
See Also

Referential actions for foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ReferentialAction
C#
public enum ReferentialAction
Visual C++
public enum class ReferentialAction

Members

Member name | Description
NoAction | No action.
Cascade | No action.
SetNull | No action.
SetDefault | No action.

See Also


Region Class

[image]

SQL Data Compare API 7.1.0
Region Class
Members Example See Also

A region of text.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Region
C#
public class Region
Visual C++
public ref class Region

Remarks

The script for a SQL object is returned as a collection of regions. For example, the SQL script for a table might contain regions for columns, constraints, indexes, foreign keys, and permissions.

Use ToString()()() to view the entire SQL script.

Examples

Viewing the SQL script to create a table.
C# Copy Code
            Database db=new Database();

            db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            Work work=new Work();

            //get the script for an object
            Regions regions=work.ScriptObject(db.Tables[0], Options.Default);

            Console.WriteLine("Entire SQL script:\n{0}", regions.ToString());

            Console.WriteLine("By region:\n");

            foreach (Region region in regions)
            {
                Console.WriteLine("***{0}", region.Name);
                Console.WriteLine(region.SQL);
            }

            db.Dispose();
Visual Basic Copy Code
            Dim db As New Database()

            db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            Dim work As New Work()

            'get the script for an object

            Dim regions As Regions = work.ScriptObject(db.Tables(0), Options.Default)

            Console.WriteLine("Entire SQL script:")
            Console.WriteLine("{0}", regions.ToString())

            Dim region As Region

            For Each region In regions
                Console.WriteLine("***{0}", region.Name)
                Console.WriteLine(region.SQL)
            Next

            'dispose
            db.Dispose()

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Region

See Also

Region Members


Region Members

[image] [image]

SQL Data Compare API 7.1.0
Region Members
Region Class Methods Properties See Also

The Region type exposes the following members.

Methods

Name | Description
AddGOStatement | Add a GO to the last region written.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL code that a region contains. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Name | The name of the region.
SQL | The SQL code that a region contains.
SubRegions | The sub-regions contained within this region

See Also

Region Class


Region Methods

[image] [image]

SQL Data Compare API 7.1.0
Region Methods
Region Class See Also

The Region type exposes the following methods.

Methods

Name | Description
AddGOStatement | Add a GO to the last region written.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL code that a region contains. (Overrides Object ..::. ToString()()().)

See Also

Region Class


AddGOStatement Method

[image]

SQL Data Compare API 7.1.0
Region..::.AddGOStatement Method
Region Class See Also

Add a GO to the last region written.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddGOStatement
C#
public void AddGOStatement()
Visual C++
public:
void AddGOStatement()

See Also

Region Class


ToString Method

[image]

SQL Data Compare API 7.1.0
Region..::.ToString Method
Region Class See Also

The SQL code that a region contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

SQL code.

See Also

Region Class


Region Properties

[image] [image]

SQL Data Compare API 7.1.0
Region Properties
Region Class See Also

The Region type exposes the following properties.

Properties

Name | Description
Name | The name of the region.
SQL | The SQL code that a region contains.
SubRegions | The sub-regions contained within this region

See Also

Region Class


Name Property

[image]

SQL Data Compare API 7.1.0
Region..::.Name Property
Region Class See Also

The name of the region.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Region Class


SQL Property

[image]

SQL Data Compare API 7.1.0
Region..::.SQL Property
Region Class See Also

The SQL code that a region contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SQL As String
C#
public string SQL { get; }
Visual C++
public:
property String^ SQL {
    String^ get ();
}

See Also

Region Class


SubRegions Property

[image]

SQL Data Compare API 7.1.0
Region..::.SubRegions Property
Region Class See Also

The sub-regions contained within this region

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubRegions As List(Of KeyValuePair(Of String, String))
C#
public List<KeyValuePair<string, string>> SubRegions { get; }
Visual C++
public:
property List<KeyValuePair<String^, String^>>^ SubRegions {
    List<KeyValuePair<String^, String^>>^ get ();
}

See Also

Region Class


Regions Class

[image]

SQL Data Compare API 7.1.0
Regions Class
Members See Also

A collection of regions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Regions _
    Inherits InnerList(Of Region)
C#
public class Regions : InnerList<Region>
Visual C++
public ref class Regions : public InnerList<Region^>

Remarks

Use the ToString() method to return the text that the regions represent.

See Region for more information and code samples.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Region >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Region >)>)
RedGate.SQLCompare.Engine..::.Regions

See Also

Regions Members


Regions Members

[image] [image]

SQL Data Compare API 7.1.0
Regions Members
Regions Class Methods Properties Explicit Interface Implementations See Also

The Regions type exposes the following members.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL script that a collection of regions contains. (Overrides Object ..::. ToString()()().)
WriteToStream | Writes the region to the specified stream.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | (Inherited from InnerList<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Regions Class


Regions Methods

[image] [image]

SQL Data Compare API 7.1.0
Regions Methods
Regions Class See Also

The Regions type exposes the following methods.

Methods

Name | Description
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | The SQL script that a collection of regions contains. (Overrides Object ..::. ToString()()().)
WriteToStream | Writes the region to the specified stream.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Regions Class


ToString Method

[image]

SQL Data Compare API 7.1.0
Regions..::.ToString Method
Regions Class See Also

The SQL script that a collection of regions contains.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

SQL script.

See Also

Regions Class


WriteToStream Method

[image]

SQL Data Compare API 7.1.0
Regions..::.WriteToStream Method
Regions Class See Also

Writes the region to the specified stream.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteToStream ( _
    sw As StreamWriter _
)
C#
public void WriteToStream(
    StreamWriter sw
)
Visual C++
public:
void WriteToStream(
    StreamWriter^ sw
)

Parameters

sw
Type: System.IO..::.StreamWriter
The stream where the regions are to be written to.

See Also

Regions Class


Role Class

[image]

SQL Data Compare API 7.1.0
Role Class
Members See Also

A role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Role _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IOwner, IDatabaseObject
C#
public sealed class Role : DatabaseObjectWithAuthorization, IHasPermissions,
    IOwner, IDatabaseObject
Visual C++
public ref class Role sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IOwner, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Role

See Also

Role Members


Role Members

[image] [image]

SQL Data Compare API 7.1.0
Role Members
Role Class Methods Fields Properties See Also

The Role type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AppRole | True if the role is an application role.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the role's database-level permissions.
DefaultSchema | The default schema for the application role. If the role is not an application role the value for the default schema is null.
ExtendedProperties | The extended properties defined for the role.
FullyQualifiedName | The fully-qualified name of the role. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Members | The users in the role.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Role (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this role.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Role Class


Role Methods

[image] [image]

SQL Data Compare API 7.1.0
Role Methods
Role Class See Also

The Role type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Role Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Role..::.Equals Method
Role Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the role with a specified role. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Role Class
Role Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Role..::.Equals Method (IDatabaseObject, Options)
Role Class See Also

Compares the role with a specified role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The role to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the roles are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Role Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Role..::.ScriptObject Method
Role Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Role Class


Role Properties

[image] [image]

SQL Data Compare API 7.1.0
Role Properties
Role Class See Also

The Role type exposes the following properties.

Properties

Name | Description
AppRole | True if the role is an application role.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the role's database-level permissions.
DefaultSchema | The default schema for the application role. If the role is not an application role the value for the default schema is null.
ExtendedProperties | The extended properties defined for the role.
FullyQualifiedName | The fully-qualified name of the role. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Members | The users in the role.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Role (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this role.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Role Class


AppRole Property

[image]

SQL Data Compare API 7.1.0
Role..::.AppRole Property
Role Class See Also

True if the role is an application role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AppRole As Boolean
C#
public bool AppRole { get; internal set; }
Visual C++
public:
property bool AppRole {
    bool get ();
    void set (bool value);
}

See Also

Role Class


DatabaseLevelPermissions Property

[image]

SQL Data Compare API 7.1.0
Role..::.DatabaseLevelPermissions Property
Role Class See Also

Access to the role's database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseLevelPermissions As DatabaseLevelPermissions
C#
public DatabaseLevelPermissions DatabaseLevelPermissions { get; }
Visual C++
public:
property DatabaseLevelPermissions^ DatabaseLevelPermissions {
    DatabaseLevelPermissions^ get ();
}

See Also

Role Class


DefaultSchema Property

[image]

SQL Data Compare API 7.1.0
Role..::.DefaultSchema Property
Role Class See Also

The default schema for the application role. If the role is not an application role the value for the default schema is null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultSchema As String
C#
public string DefaultSchema { get; }
Visual C++
public:
property String^ DefaultSchema {
    String^ get ();
}

See Also

Role Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Role..::.ExtendedProperties Property
Role Class See Also

The extended properties defined for the role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

Role Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
Role..::.FullyQualifiedName Property
Role Class See Also

The fully-qualified name of the role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName
IDatabaseObject..::.FullyQualifiedName

See Also

Role Class


Members Property

[image]

SQL Data Compare API 7.1.0
Role..::.Members Property
Role Class See Also

The users in the role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Members As Members
C#
public Members Members { get; }
Visual C++
public:
property Members^ Members {
    Members^ get ();
}

See Also

Role Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Role..::.ObjectType Property
Role Class See Also

Returns ObjectType.Role

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Role Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Role..::.Permissions Property
Role Class See Also

The permissions on this role.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Role Class


Roles Class

[image]

SQL Data Compare API 7.1.0
Roles Class
Members See Also

A collection of roles.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Roles _
    Inherits SerializableDatabaseObjectCollection(Of Role)
C#
public sealed class Roles : SerializableDatabaseObjectCollection<Role>
Visual C++
public ref class Roles sealed : public SerializableDatabaseObjectCollection<Role^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Role >)>)
RedGate.SQLCompare.Engine..::.Roles

See Also

Roles Members


Roles Members

[image] [image]

SQL Data Compare API 7.1.0
Roles Members
Roles Class Methods Properties Explicit Interface Implementations See Also

The Roles type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Roles Class


Route Class

[image]

SQL Data Compare API 7.1.0
Route Class
Members See Also

A route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Route _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IIsSystemObject, IDatabaseObject
C#
public sealed class Route : DatabaseObjectWithAuthorization, IHasPermissions,
    IIsSystemObject, IDatabaseObject
Visual C++
public ref class Route sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IIsSystemObject, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Route

See Also

Route Members


Route Members

[image] [image]

SQL Data Compare API 7.1.0
Route Members
Route Class Methods Fields Properties See Also

The Route type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Address | The address of the route.
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the route.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
HasLifeTime | True if the route has a lifetime set.
IsSystemObject | Indicates whether the route is a system object.
Lifetime | The lifetime of the route.
MirrorAddress | The mirror address of the route.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this route.
RemoteServiceName | The name of the remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Route Class


Route Methods

[image] [image]

SQL Data Compare API 7.1.0
Route Methods
Route Class See Also

The Route type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Route Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Route..::.Equals Method
Route Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the route with a specified route. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Route Class
Route Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Route..::.Equals Method (IDatabaseObject, Options)
Route Class See Also

Compares the route with a specified route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The route to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the routes are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Route Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Route..::.ScriptObject Method
Route Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Route Class


Route Properties

[image] [image]

SQL Data Compare API 7.1.0
Route Properties
Route Class See Also

The Route type exposes the following properties.

Properties

Name | Description
Address | The address of the route.
BrokerInstance | The broker instance.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the route.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
HasLifeTime | True if the route has a lifetime set.
IsSystemObject | Indicates whether the route is a system object.
Lifetime | The lifetime of the route.
MirrorAddress | The mirror address of the route.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Assembly (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this route.
RemoteServiceName | The name of the remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Route Class


Address Property

[image]

SQL Data Compare API 7.1.0
Route..::.Address Property
Route Class See Also

The address of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As String
C#
public string Address { get; internal set; }
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class


BrokerInstance Property

[image]

SQL Data Compare API 7.1.0
Route..::.BrokerInstance Property
Route Class See Also

The broker instance.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerInstance As String
C#
public string BrokerInstance { get; internal set; }
Visual C++
public:
property String^ BrokerInstance {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Route..::.ExtendedProperties Property
Route Class See Also

The extended properties defined for the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

Route Class


HasLifeTime Property

[image]

SQL Data Compare API 7.1.0
Route..::.HasLifeTime Property
Route Class See Also

True if the route has a lifetime set.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property HasLifeTime As Boolean
C#
public bool HasLifeTime { get; internal set; }
Visual C++
public:
property bool HasLifeTime {
    bool get ();
    void set (bool value);
}

See Also

Route Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
Route..::.IsSystemObject Property
Route Class See Also

Indicates whether the route is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Route Class


Lifetime Property

[image]

SQL Data Compare API 7.1.0
Route..::.Lifetime Property
Route Class See Also

The lifetime of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Lifetime As DateTime
C#
public DateTime Lifetime { get; internal set; }
Visual C++
public:
property DateTime Lifetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

Route Class


MirrorAddress Property

[image]

SQL Data Compare API 7.1.0
Route..::.MirrorAddress Property
Route Class See Also

The mirror address of the route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MirrorAddress As String
C#
public string MirrorAddress { get; internal set; }
Visual C++
public:
property String^ MirrorAddress {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Route..::.ObjectType Property
Route Class See Also

Returns ObjectType.Assembly

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Route Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Route..::.Permissions Property
Route Class See Also

The permissions on this route.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Route Class


RemoteServiceName Property

[image]

SQL Data Compare API 7.1.0
Route..::.RemoteServiceName Property
Route Class See Also

The name of the remote service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteServiceName As String
C#
public string RemoteServiceName { get; internal set; }
Visual C++
public:
property String^ RemoteServiceName {
    String^ get ();
    void set (String^ value);
}

See Also

Route Class


Routes Class

[image]

SQL Data Compare API 7.1.0
Routes Class
Members See Also

A collection of routes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Routes _
    Inherits SerializableDatabaseObjectCollection(Of Route)
C#
public sealed class Routes : SerializableDatabaseObjectCollection<Route>
Visual C++
public ref class Routes sealed : public SerializableDatabaseObjectCollection<Route^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Route >)>)
RedGate.SQLCompare.Engine..::.Routes

See Also

Routes Members


Routes Members

[image] [image]

SQL Data Compare API 7.1.0
Routes Members
Routes Class Methods Properties Explicit Interface Implementations See Also

The Routes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Routes Class


Rule Class

[image]

SQL Data Compare API 7.1.0
Rule Class
Members See Also

A rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Rule _
    Inherits SchemaObject _
    Implements IDatabaseObject
C#
public sealed class Rule : SchemaObject, IDatabaseObject
Visual C++
public ref class Rule sealed : public SchemaObject,
    IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Rule

See Also

Rule Members


Rule Members

[image] [image]

SQL Data Compare API 7.1.0
Rule Members
Rule Class Methods Fields Properties See Also

The Rule type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Overrides SchemaObject ..::. ToString()()().)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Rule (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the rule.

See Also

Rule Class


Rule Methods

[image] [image]

SQL Data Compare API 7.1.0
Rule Methods
Rule Class See Also

The Rule type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Overrides SchemaObject ..::. ToString()()().)

See Also

Rule Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Rule..::.Equals Method
Rule Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the rule with a specified rule. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Rule Class
Rule Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Rule..::.Equals Method (IDatabaseObject, Options)
Rule Class See Also

Compares the rule with a specified rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The rule to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the rules are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Rule Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Rule..::.ScriptObject Method
Rule Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Rule Class


ToString Method

[image]

SQL Data Compare API 7.1.0
Rule..::.ToString Method
Rule Class See Also

Returns a String that represents the current Object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

Rule Class


Rule Properties

[image] [image]

SQL Data Compare API 7.1.0
Rule Properties
Rule Class See Also

The Rule type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Rule (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
Text | The text of the rule.

See Also

Rule Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Rule..::.ObjectType Property
Rule Class See Also

Returns ObjectType.Rule

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Rule Class


Text Property

[image]

SQL Data Compare API 7.1.0
Rule..::.Text Property
Rule Class See Also

The text of the rule.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; internal set; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

See Also

Rule Class


Rules Class

[image]

SQL Data Compare API 7.1.0
Rules Class
Members See Also

A collection of rules.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Rules _
    Inherits SerializableDatabaseObjectCollection(Of Rule)
C#
public sealed class Rules : SerializableDatabaseObjectCollection<Rule>
Visual C++
public ref class Rules sealed : public SerializableDatabaseObjectCollection<Rule^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Rule >)>)
RedGate.SQLCompare.Engine..::.Rules

See Also

Rules Members


Rules Members

[image] [image]

SQL Data Compare API 7.1.0
Rules Members
Rules Class Methods Properties Explicit Interface Implementations See Also

The Rules type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Rules Class


Schema Class

[image]

SQL Data Compare API 7.1.0
Schema Class
Members See Also

A schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Schema _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IIsSystemObject, IOwner, IDatabaseObject
C#
public sealed class Schema : DatabaseObjectWithAuthorization, IHasPermissions,
    IIsSystemObject, IOwner, IDatabaseObject
Visual C++
public ref class Schema sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IIsSystemObject, IOwner, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Schema

See Also

Schema Members


Schema Members

[image] [image]

SQL Data Compare API 7.1.0
Schema Members
Schema Class Methods Fields Properties See Also

The Schema type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the schema.
FullyQualifiedName | The name of the schema. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject | Indicates whether the schema is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this schema.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Schema Class


Schema Methods

[image] [image]

SQL Data Compare API 7.1.0
Schema Methods
Schema Class See Also

The Schema type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Schema Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Schema..::.Equals Method
Schema Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the schema with a specified schema. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Schema Class
Schema Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Schema..::.Equals Method (IDatabaseObject, Options)
Schema Class See Also

Compares the schema with a specified schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The schema to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the schemas are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Schema Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Schema..::.ScriptObject Method
Schema Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Schema Class


Schema Properties

[image] [image]

SQL Data Compare API 7.1.0
Schema Properties
Schema Class See Also

The Schema type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the schema.
FullyQualifiedName | The name of the schema. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSystemObject | Indicates whether the schema is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this schema.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Schema Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Schema..::.ExtendedProperties Property
Schema Class See Also

The extended properties defined for the schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

Schema Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
Schema..::.FullyQualifiedName Property
Schema Class See Also

The name of the schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName
IDatabaseObject..::.FullyQualifiedName

See Also

Schema Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
Schema..::.IsSystemObject Property
Schema Class See Also

Indicates whether the schema is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Schema Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Schema..::.ObjectType Property
Schema Class See Also

Returns ObjectType.User

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Schema Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Schema..::.Permissions Property
Schema Class See Also

The permissions on this schema.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Schema Class


SchemaObject Class

[image]

SQL Data Compare API 7.1.0
SchemaObject Class
Members See Also

A schema object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SchemaObject _
    Inherits ScriptableDatabaseObject
C#
public abstract class SchemaObject : ScriptableDatabaseObject
Visual C++
public ref class SchemaObject abstract : public ScriptableDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.Default
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Rule

See Also

SchemaObject Members


SchemaObject Members

[image] [image]

SQL Data Compare API 7.1.0
SchemaObject Members
SchemaObject Class Methods Fields Properties See Also

The SchemaObject type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Overrides Object ..::. ToString()()().)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties |
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object.
FullyQualifiedName | The fully-qualified name of the object. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObject Class


SchemaObject Fields

[image] [image]

SQL Data Compare API 7.1.0
SchemaObject Fields
SchemaObject Class See Also

The SchemaObject type exposes the following fields.

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties |
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObject Class


m_ExtendedProperties Field

[image]

SQL Data Compare API 7.1.0
SchemaObject..::.m_ExtendedProperties Field
SchemaObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ExtendedProperties As ExtendedProperties
C#
protected ExtendedProperties m_ExtendedProperties
Visual C++
protected:
ExtendedProperties^ m_ExtendedProperties

See Also

SchemaObject Class


SchemaObject Methods

[image] [image]

SQL Data Compare API 7.1.0
SchemaObject Methods
SchemaObject Class See Also

The SchemaObject type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Overrides Object ..::. ToString()()().)

See Also

SchemaObject Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
SchemaObject..::.Equals Method
SchemaObject Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObject Class
SchemaObject Members


ToString Method

[image]

SQL Data Compare API 7.1.0
SchemaObject..::.ToString Method
SchemaObject Class See Also

Returns the fully-qualified name of the object prefixed with the object type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The fully-qualified name of the object prefixed with the object type.

See Also

SchemaObject Class


SchemaObject Properties

[image] [image]

SQL Data Compare API 7.1.0
SchemaObject Properties
SchemaObject Class See Also

The SchemaObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object.
FullyQualifiedName | The fully-qualified name of the object. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObject Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
SchemaObject..::.ExtendedProperties Property
SchemaObject Class See Also

The extended properties on the schema object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

SchemaObject Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
SchemaObject..::.FullyQualifiedName Property
SchemaObject Class See Also

The fully-qualified name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

SchemaObject Class


SchemaObjectWithAuthorization Class

[image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization Class
Members See Also

Represents a schema object that can also have an ALTER AUTHORIZATION applied to it to change the user as well (so it can have both user & schema).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SchemaObjectWithAuthorization _
    Inherits SchemaObject
C#
public abstract class SchemaObjectWithAuthorization : SchemaObject
Visual C++
public ref class SchemaObjectWithAuthorization abstract : public SchemaObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Function
RedGate.SQLCompare.Engine..::.Queue
RedGate.SQLCompare.Engine..::.StoredProcedure
RedGate.SQLCompare.Engine..::.Synonym
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.UserDefinedType
RedGate.SQLCompare.Engine..::.XmlSchemaCollection

See Also

SchemaObjectWithAuthorization Members


SchemaObjectWithAuthorization Members

[image] [image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization Members
SchemaObjectWithAuthorization Class Methods Fields Properties See Also

The SchemaObjectWithAuthorization type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.

See Also

SchemaObjectWithAuthorization Class


SchemaObjectWithAuthorization Properties

[image] [image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization Properties
SchemaObjectWithAuthorization Class See Also

The SchemaObjectWithAuthorization type exposes the following properties.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.

See Also

SchemaObjectWithAuthorization Class


Authorization Property

[image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization..::.Authorization Property
SchemaObjectWithAuthorization Class See Also

Returns the authorization owner of the object (as opposed to the schema; see Owner()()()).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Authorization As String
C#
public string Authorization { get; internal set; }
Visual C++
public:
property String^ Authorization {
    String^ get ();
    void set (String^ value);
}

See Also

SchemaObjectWithAuthorization Class


ScriptSourceAuthorization Property

[image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization..::.ScriptSourceAuthorization Property
SchemaObjectWithAuthorization Class See Also

The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceAuthorization As ScriptSource
C#
public ScriptSource ScriptSourceAuthorization { get; internal set; }
Visual C++
public:
property ScriptSource^ ScriptSourceAuthorization {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

SchemaObjectWithAuthorization Class


Schemas Class

[image]

SQL Data Compare API 7.1.0
Schemas Class
Members See Also

A collection of schemas.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Schemas _
    Inherits SerializableDatabaseObjectCollection(Of Schema)
C#
public sealed class Schemas : SerializableDatabaseObjectCollection<Schema>
Visual C++
public ref class Schemas sealed : public SerializableDatabaseObjectCollection<Schema^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Schema >)>)
RedGate.SQLCompare.Engine..::.Schemas

See Also

Schemas Members


Schemas Members

[image] [image]

SQL Data Compare API 7.1.0
Schemas Members
Schemas Class Methods Properties Explicit Interface Implementations See Also

The Schemas type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Schemas Class


ScriptableDatabaseObject Class

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Class
Members See Also

Represents a scriptable database object. Also has default implementations of some of the IDatabaseObject methods & properties

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ScriptableDatabaseObject _
    Implements IDatabaseObject
C#
public abstract class ScriptableDatabaseObject : IDatabaseObject
Visual C++
public ref class ScriptableDatabaseObject abstract : IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.DdlTrigger
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.EventNotification
RedGate.SQLCompare.Engine..::.PartitionFunction
RedGate.SQLCompare.Engine..::.PartitionScheme
RedGate.SQLCompare.Engine..::.User

See Also

ScriptableDatabaseObject Members


ScriptableDatabaseObject Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Members
ScriptableDatabaseObject Class Constructors Methods Fields Properties See Also

The ScriptableDatabaseObject type exposes the following members.

Constructors

Name | Description
ScriptableDatabaseObject |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive |
m_Database |
m_ID |
m_Name |
m_Owner |

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object.
Name | The name of the object.
ObjectType | The type of the object.
Owner | The owner or schema of the object.
ScriptSource | The script source for this object, if the database source is set to scripts folder.

See Also

ScriptableDatabaseObject Class


ScriptableDatabaseObject Constructor

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Constructor
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected ScriptableDatabaseObject()
Visual C++
protected:
ScriptableDatabaseObject()

See Also

ScriptableDatabaseObject Class


ScriptableDatabaseObject Fields

[image] [image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Fields
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following fields.

Fields

Name | Description
m_CaseSensitive |
m_Database |
m_ID |
m_Name |
m_Owner |

See Also

ScriptableDatabaseObject Class


m_CaseSensitive Field

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.m_CaseSensitive Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_CaseSensitive As Boolean
C#
protected bool m_CaseSensitive
Visual C++
protected:
bool m_CaseSensitive

See Also

ScriptableDatabaseObject Class


m_Database Field

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.m_Database Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Database As Database
C#
protected Database m_Database
Visual C++
protected:
Database^ m_Database

See Also

ScriptableDatabaseObject Class


m_ID Field

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.m_ID Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ID As Integer
C#
protected int m_ID
Visual C++
protected:
int m_ID

See Also

ScriptableDatabaseObject Class


m_Name Field

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.m_Name Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Name As String
C#
protected string m_Name
Visual C++
protected:
String^ m_Name

See Also

ScriptableDatabaseObject Class


m_Owner Field

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.m_Owner Field
ScriptableDatabaseObject Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Owner As String
C#
protected string m_Owner
Visual C++
protected:
String^ m_Owner

See Also

ScriptableDatabaseObject Class


ScriptableDatabaseObject Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Methods
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptableDatabaseObject Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.Equals Method
ScriptableDatabaseObject Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects.

See Also

ScriptableDatabaseObject Class
ScriptableDatabaseObject Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.Equals Method (IDatabaseObject, Options)
ScriptableDatabaseObject Class See Also

Compares two database objects.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public abstract bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) abstract

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The object to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the database objects are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ScriptableDatabaseObject Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.ScriptObject Method
ScriptableDatabaseObject Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public abstract Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) abstract

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Options that may influence the scripting.

Return Value

Regions that contain the script.

See Also

ScriptableDatabaseObject Class


ScriptableDatabaseObject Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject Properties
ScriptableDatabaseObject Class See Also

The ScriptableDatabaseObject type exposes the following properties.

Properties

Name | Description
Database | The database to which the object belongs.
FullyQualifiedName | The fully-qualified name of the object.
Name | The name of the object.
ObjectType | The type of the object.
Owner | The owner or schema of the object.
ScriptSource | The script source for this object, if the database source is set to scripts folder.

See Also

ScriptableDatabaseObject Class


Database Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.Database Property
ScriptableDatabaseObject Class See Also

The database to which the object belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As Database
C#
public Database Database { get; internal set; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
    void set (Database^ value) sealed;
}

Implements

IDatabaseObject..::.Database

See Also

ScriptableDatabaseObject Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.FullyQualifiedName Property
ScriptableDatabaseObject Class See Also

The fully-qualified name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FullyQualifiedName As String
C#
public virtual string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get ();
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

ScriptableDatabaseObject Class


Name Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.Name Property
ScriptableDatabaseObject Class See Also

The name of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; internal set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Implements

IDatabaseObject..::.Name

See Also

ScriptableDatabaseObject Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.ObjectType Property
ScriptableDatabaseObject Class See Also

The type of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ObjectType As ObjectType
C#
public abstract ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () abstract;
}

Implements

IDatabaseObject..::.ObjectType

See Also

ScriptableDatabaseObject Class


Owner Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.Owner Property
ScriptableDatabaseObject Class See Also

The owner or schema of the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Owner As String
C#
public virtual string Owner { get; internal set; }
Visual C++
public:
virtual property String^ Owner {
    String^ get ();
    void set (String^ value);
}

Implements

IDatabaseObject..::.Owner

See Also

ScriptableDatabaseObject Class


ScriptSource Property

[image]

SQL Data Compare API 7.1.0
ScriptableDatabaseObject..::.ScriptSource Property
ScriptableDatabaseObject Class See Also

The script source for this object, if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSource As ScriptSource
C#
public ScriptSource ScriptSource { get; internal set; }
Visual C++
public:
virtual property ScriptSource^ ScriptSource {
    ScriptSource^ get () sealed;
    void set (ScriptSource^ value) sealed;
}

See Also

ScriptableDatabaseObject Class


SerializableCollection(T) Generic Class

[image]

SQL Data Compare API 7.1.0
SerializableCollection<(Of <(T>)>) Generic Class
Members See Also

A collection that can be serialized to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SerializableCollection(Of T) _
    Inherits KeyedCollection(Of T)
C#
public abstract class SerializableCollection<T> : KeyedCollection<T>
Visual C++
generic<typename T>
public ref class SerializableCollection abstract : public KeyedCollection<T>

Type Parameters

T

Remarks

For internal use by SQL Compare.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.CheckConstraints
RedGate.SQLCompare.Engine..::.EventTypes
RedGate.SQLCompare.Engine..::.ExtendedProperties
RedGate.SQLCompare.Engine..::.Fields
RedGate.SQLCompare.Engine..::.ForeignKeys
RedGate.SQLCompare.Engine..::.Indexes
RedGate.SQLCompare.Engine..::.MessageUsages
RedGate.SQLCompare.Engine..::.Parameters
RedGate.SQLCompare.Engine..::.Triggers

See Also

SerializableCollection<(Of <(T>)>) Members


SerializableCollection(T) Members

[image] [image]

SQL Data Compare API 7.1.0
SerializableCollection<(Of <(T>)>) Members
SerializableCollection<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The SerializableCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SerializableCollection<(Of <(T>)>) Class


SerializableDatabaseObjectCollection(T) Generic Class

[image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>) Generic Class
Members See Also

A collection of database objects that can be serialized to disk.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SerializableDatabaseObjectCollection(Of T As IDatabaseObject) _
    Inherits SerializableCollection(Of T) _
    Implements IDatabaseObjects(Of T), IEnumerable(Of T),  _
    IEnumerable
C#
public abstract class SerializableDatabaseObjectCollection<T> : SerializableCollection<T>, IDatabaseObjects<T>,
    IEnumerable<T>, IEnumerable where T : IDatabaseObject
Visual C++
generic<typename T>
where T : IDatabaseObject
public ref class SerializableDatabaseObjectCollection abstract : public SerializableCollection<T>,
    IDatabaseObjects<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type stored in the collection.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <(T>)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection<(Of <(T>)>)
RedGate.SQLCompare.Engine..::.FullTextStoplists
RedGate.SQLCompare.Engine..::.AsymmetricKeys
RedGate.SQLCompare.Engine..::.Certificates
RedGate.SQLCompare.Engine..::.ClrAssemblies
RedGate.SQLCompare.Engine..::.Contracts
RedGate.SQLCompare.Engine..::.DdlTriggers
RedGate.SQLCompare.Engine..::.Defaults
RedGate.SQLCompare.Engine..::.EventNotifications
RedGate.SQLCompare.Engine..::.FullTextCatalogs
RedGate.SQLCompare.Engine..::.Functions
RedGate.SQLCompare.Engine..::.MessageTypes
RedGate.SQLCompare.Engine..::.PartitionFunctions
RedGate.SQLCompare.Engine..::.PartitionSchemes
RedGate.SQLCompare.Engine..::.Queues
RedGate.SQLCompare.Engine..::.Roles
RedGate.SQLCompare.Engine..::.Routes
RedGate.SQLCompare.Engine..::.Rules
RedGate.SQLCompare.Engine..::.Schemas
RedGate.SQLCompare.Engine..::.ServiceBindings
RedGate.SQLCompare.Engine..::.Services
RedGate.SQLCompare.Engine..::.StoredProcedures
RedGate.SQLCompare.Engine..::.SymmetricKeys
RedGate.SQLCompare.Engine..::.Synonyms
RedGate.SQLCompare.Engine..::.Tables
RedGate.SQLCompare.Engine..::.UserDefinedTypes
RedGate.SQLCompare.Engine..::.Users
RedGate.SQLCompare.Engine..::.Views
RedGate.SQLCompare.Engine..::.XmlSchemaCollections

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Members


SerializableDatabaseObjectCollection(T) Members

[image] [image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>) Members
SerializableDatabaseObjectCollection<(Of <(T>)>) Class Methods Properties Explicit Interface Implementations See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Overrides KeyedCollection <(Of <( T >)>)..::.GetKey(UTP).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class


SerializableDatabaseObjectCollection(T) Methods

[image] [image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>) Methods
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Overrides KeyedCollection <(Of <( T >)>)..::.GetKey(UTP).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class


GetKey Method

[image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.GetKey Method
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

For internal use.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Friend Overrides Function GetKey ( _
    value As T _
) As String
C#
protected internal override string GetKey(
    T value
)
Visual C++
protected public:
virtual String^ GetKey(
    T value
) override

Parameters

value
Type: T
For internal use

Return Value

For internal use

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class


SerializableDatabaseObjectCollection(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>) Properties
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

The SerializableDatabaseObjectCollection<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.Item Property
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
SerializableDatabaseObjectCollection<(Of <(T>)>) Members


Item Property (String, String)

[image]

SQL Data Compare API 7.1.0
SerializableDatabaseObjectCollection<(Of <(T>)>)..::.Item Property (String, String)
SerializableDatabaseObjectCollection<(Of <(T>)>) Class See Also

Returns a database object given its owner and name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    owner As String, _
    name As String _
) As T
C#
public T this[
    string owner,
    string name
] { get; }
Visual C++
public:
property T default[String^ owner, String^ name] {
    T get (String^ owner, String^ name);
}

Parameters

owner
Type: System..::.String
The owner component of the string-based index of the element to get or set.
name
Type: System..::.String
The name component of the string-based index of the element to get or set.

See Also

SerializableDatabaseObjectCollection<(Of <(T>)>) Class
Item Overload


Service Class

[image]

SQL Data Compare API 7.1.0
Service Class
Members See Also

A service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Service _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IIsSystemObject, IDatabaseObject
C#
public sealed class Service : DatabaseObjectWithAuthorization, IHasPermissions,
    IIsSystemObject, IDatabaseObject
Visual C++
public ref class Service sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IIsSystemObject, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Service

See Also

Service Members


Service Members

[image] [image]

SQL Data Compare API 7.1.0
Service Members
Service Class Methods Fields Properties See Also

The Service type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Contracts | The contracts that the service uses.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventNotifications | The event notifications that depend on the service.
ExtendedProperties | The extended properties defined for the service.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this service.
Queue | The queue that the service is on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Service Class


Service Methods

[image] [image]

SQL Data Compare API 7.1.0
Service Methods
Service Class See Also

The Service type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Service Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Service..::.Equals Method
Service Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the service with a specified service. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Service Class
Service Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Service..::.Equals Method (IDatabaseObject, Options)
Service Class See Also

Compares the service with a specified service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The service to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the services are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Service Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Service..::.ScriptObject Method
Service Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Service Class


Service Properties

[image] [image]

SQL Data Compare API 7.1.0
Service Properties
Service Class See Also

The Service type exposes the following properties.

Properties

Name | Description
Contracts | The contracts that the service uses.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
EventNotifications | The event notifications that depend on the service.
ExtendedProperties | The extended properties defined for the service.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
IsSystemObject | Indicates whether the object is a system object.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this service.
Queue | The queue that the service is on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

Service Class


Contracts Property

[image]

SQL Data Compare API 7.1.0
Service..::.Contracts Property
Service Class See Also

The contracts that the service uses.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contracts As Contracts
C#
public Contracts Contracts { get; }
Visual C++
public:
property Contracts^ Contracts {
    Contracts^ get ();
}

See Also

Service Class


EventNotifications Property

[image]

SQL Data Compare API 7.1.0
Service..::.EventNotifications Property
Service Class See Also

The event notifications that depend on the service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventNotifications As EventNotifications
C#
public EventNotifications EventNotifications { get; }
Visual C++
public:
property EventNotifications^ EventNotifications {
    EventNotifications^ get ();
}

See Also

Service Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
Service..::.ExtendedProperties Property
Service Class See Also

The extended properties defined for the service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

Service Class


IsSystemObject Property

[image]

SQL Data Compare API 7.1.0
Service..::.IsSystemObject Property
Service Class See Also

Indicates whether the object is a system object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSystemObject As Boolean
C#
public bool IsSystemObject { get; }
Visual C++
public:
virtual property bool IsSystemObject {
    bool get () sealed;
}

Implements

IIsSystemObject..::.IsSystemObject

See Also

Service Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Service..::.ObjectType Property
Service Class See Also

Returns ObjectType.Service

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Service Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Service..::.Permissions Property
Service Class See Also

The permissions on this service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Service Class


Queue Property

[image]

SQL Data Compare API 7.1.0
Service..::.Queue Property
Service Class See Also

The queue that the service is on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Queue As Queue
C#
public Queue Queue { get; internal set; }
Visual C++
public:
property Queue^ Queue {
    Queue^ get ();
    void set (Queue^ value);
}

See Also

Service Class


ServiceBinding Class

[image]

SQL Data Compare API 7.1.0
ServiceBinding Class
Members See Also

A service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServiceBinding _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class ServiceBinding : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class ServiceBinding sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ServiceBinding

See Also

ServiceBinding Members


ServiceBinding Members

[image] [image]

SQL Data Compare API 7.1.0
ServiceBinding Members
ServiceBinding Class Methods Fields Properties See Also

The ServiceBinding type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Anonymous | True if anonymous authentication is to be used.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the service binding.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this service binding.
RemoteService | The remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
UserName | The user name.

See Also

ServiceBinding Class


ServiceBinding Methods

[image] [image]

SQL Data Compare API 7.1.0
ServiceBinding Methods
ServiceBinding Class See Also

The ServiceBinding type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServiceBinding Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ServiceBinding..::.Equals Method
ServiceBinding Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the service binding with a specified service binding. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

ServiceBinding Class
ServiceBinding Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.Equals Method (IDatabaseObject, Options)
ServiceBinding Class See Also

Compares the service binding with a specified service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The service to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the service bindings are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

ServiceBinding Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.ScriptObject Method
ServiceBinding Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

ServiceBinding Class


ServiceBinding Properties

[image] [image]

SQL Data Compare API 7.1.0
ServiceBinding Properties
ServiceBinding Class See Also

The ServiceBinding type exposes the following properties.

Properties

Name | Description
Anonymous | True if anonymous authentication is to be used.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties defined for the service binding.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Service (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this service binding.
RemoteService | The remote service.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)
UserName | The user name.

See Also

ServiceBinding Class


Anonymous Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.Anonymous Property
ServiceBinding Class See Also

True if anonymous authentication is to be used.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Anonymous As Boolean
C#
public bool Anonymous { get; internal set; }
Visual C++
public:
property bool Anonymous {
    bool get ();
    void set (bool value);
}

See Also

ServiceBinding Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.ExtendedProperties Property
ServiceBinding Class See Also

The extended properties defined for the service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

ServiceBinding Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.ObjectType Property
ServiceBinding Class See Also

Returns ObjectType.Service

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

ServiceBinding Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.Permissions Property
ServiceBinding Class See Also

The permissions on this service binding.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

ServiceBinding Class


RemoteService Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.RemoteService Property
ServiceBinding Class See Also

The remote service.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteService As String
C#
public string RemoteService { get; internal set; }
Visual C++
public:
property String^ RemoteService {
    String^ get ();
    void set (String^ value);
}

See Also

ServiceBinding Class


UserName Property

[image]

SQL Data Compare API 7.1.0
ServiceBinding..::.UserName Property
ServiceBinding Class See Also

The user name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; internal set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ServiceBinding Class


ServiceBindings Class

[image]

SQL Data Compare API 7.1.0
ServiceBindings Class
Members See Also

A collection of service bindings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServiceBindings _
    Inherits SerializableDatabaseObjectCollection(Of ServiceBinding)
C#
public sealed class ServiceBindings : SerializableDatabaseObjectCollection<ServiceBinding>
Visual C++
public ref class ServiceBindings sealed : public SerializableDatabaseObjectCollection<ServiceBinding^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( ServiceBinding >)>)
RedGate.SQLCompare.Engine..::.ServiceBindings

See Also

ServiceBindings Members


ServiceBindings Members

[image] [image]

SQL Data Compare API 7.1.0
ServiceBindings Members
ServiceBindings Class Methods Properties Explicit Interface Implementations See Also

The ServiceBindings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ServiceBindings Class


Services Class

[image]

SQL Data Compare API 7.1.0
Services Class
Members See Also

A collection of services.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Services _
    Inherits SerializableDatabaseObjectCollection(Of Service)
C#
public sealed class Services : SerializableDatabaseObjectCollection<Service>
Visual C++
public ref class Services sealed : public SerializableDatabaseObjectCollection<Service^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Service >)>)
RedGate.SQLCompare.Engine..::.Services

See Also

Services Members


Services Members

[image] [image]

SQL Data Compare API 7.1.0
Services Members
Services Class Methods Properties Explicit Interface Implementations See Also

The Services type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Services Class


SnapshotSource Class

[image]

SQL Data Compare API 7.1.0
SnapshotSource Class
Members See Also

A SQL Server database encapsulated within a snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SnapshotSource _
    Inherits DataSource
C#
public sealed class SnapshotSource : DataSource
Visual C++
public ref class SnapshotSource sealed : public DataSource

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine..::.SnapshotSource

See Also

SnapshotSource Members


SnapshotSource Members

[image] [image]

SQL Data Compare API 7.1.0
SnapshotSource Members
SnapshotSource Class Constructors Methods Properties See Also

The SnapshotSource type exposes the following members.

Constructors

Name | Description
SnapshotSource | Overloaded.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes data. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CreationTime | Gets the creation time of the snapshot file (the time at which the file was last written to).
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
FileName | Gets or sets the snapshot file name.
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.
IsWriteable | The data source cannot be written to. (Overrides DataSource ..::. IsWriteable.)
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

See Also

SnapshotSource Class


SnapshotSource Constructor

[image] [image]

SQL Data Compare API 7.1.0
SnapshotSource Constructor
SnapshotSource Class See Also

Overload List

Name | Description
SnapshotSource()()() | Constructs a snapshot.
SnapshotSource(String) | Constructs the snapshot file name.

See Also

SnapshotSource Class
SnapshotSource Members


SnapshotSource Constructor

[image]

SQL Data Compare API 7.1.0
SnapshotSource Constructor
SnapshotSource Class See Also

Constructs a snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SnapshotSource()
Visual C++
public:
SnapshotSource()

See Also

SnapshotSource Class
SnapshotSource Overload


SnapshotSource Constructor (String)

[image]

SQL Data Compare API 7.1.0
SnapshotSource Constructor (String)
SnapshotSource Class See Also

Constructs the snapshot file name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    snapshotFileName As String _
)
C#
public SnapshotSource(
    string snapshotFileName
)
Visual C++
public:
SnapshotSource(
    String^ snapshotFileName
)

Parameters

snapshotFileName
Type: System..::.String
The file name of the snapshot.

See Also

SnapshotSource Class
SnapshotSource Overload


SnapshotSource Methods

[image] [image]

SQL Data Compare API 7.1.0
SnapshotSource Methods
SnapshotSource Class See Also

The SnapshotSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes data. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes data. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SnapshotSource Class


Clone Method

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.Clone Method
SnapshotSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IDataSource..::.Clone()()()

See Also

SnapshotSource Class


Deserialize Method

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.Deserialize Method
SnapshotSource Class See Also

Deserializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: System..::.Int32
The serialization version.
formatter
Type: ISerializeFormatter
The ISerializeFormatter for deserialization.

Return Value

true if the data can be deserialized.

See Also

SnapshotSource Class


IsDifferentSource Method

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.IsDifferentSource Method
SnapshotSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    comparisonDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource comparisonDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ comparisonDataSource
) override

Parameters

comparisonDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

SnapshotSource Class


Serialize Method

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.Serialize Method
SnapshotSource Class See Also

Serializes data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter
The ISerializeFormatter for serialization.

See Also

SnapshotSource Class


SnapshotSource Properties

[image] [image]

SQL Data Compare API 7.1.0
SnapshotSource Properties
SnapshotSource Class See Also

The SnapshotSource type exposes the following properties.

Properties

Name | Description
CreationTime | Gets the creation time of the snapshot file (the time at which the file was last written to).
DatabaseName | Gets or sets the name of the database. (Overrides DataSource ..::. DatabaseName.)
FileName | Gets or sets the snapshot file name.
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.
IsWriteable | The data source cannot be written to. (Overrides DataSource ..::. IsWriteable.)
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

See Also

SnapshotSource Class


CreationTime Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.CreationTime Property
SnapshotSource Class See Also

Gets the creation time of the snapshot file (the time at which the file was last written to).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CreationTime As DateTime
C#
public DateTime CreationTime { get; }
Visual C++
public:
property DateTime CreationTime {
    DateTime get ();
}

See Also

SnapshotSource Class


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.DatabaseName Property
SnapshotSource Class See Also

Gets or sets the name of the database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

SnapshotSource Class


FileName Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.FileName Property
SnapshotSource Class See Also

Gets or sets the snapshot file name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

SnapshotSource Class


IsValid Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.IsValid Property
SnapshotSource Class See Also

True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid { get; }
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

SnapshotSource Class


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.IsWriteable Property
SnapshotSource Class See Also

The data source cannot be written to.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

SnapshotSource Class


ServerName Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.ServerName Property
SnapshotSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

SnapshotSource Class


Version Property

[image]

SQL Data Compare API 7.1.0
SnapshotSource..::.Version Property
SnapshotSource Class See Also

Gets the current serialized version number of the snapshot.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

SnapshotSource Class


.GridDensities Enumeration

[image]

SQL Data Compare API 7.1.0
..::.GridDensities Enumeration
SpatialIndexInformation See Also

The grid densities of spatial indexes

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration GridDensities
C#
public enum GridDensities
Visual C++
public enum class GridDensities

Members

Member name | Description
LOW | LOW (16)
MEDIUM | MEDIUM (64)
HIGH | HIGH (256)

See Also


.SpatialIndexTypes Enumeration

[image]

SQL Data Compare API 7.1.0
..::.SpatialIndexTypes Enumeration
SpatialIndexInformation See Also

The type of the spatial index. In SQL Server 2008 this can be either geometry or geography.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SpatialIndexTypes
C#
public enum SpatialIndexTypes
Visual C++
public enum class SpatialIndexTypes

Members

Member name | Description
Geometry | Geometry
Geography | Geography

See Also


.TesselationSchemes Enumeration

[image]

SQL Data Compare API 7.1.0
..::.TesselationSchemes Enumeration
SpatialIndexInformation See Also

Used to specify the tesselation scheme for the spatial index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TesselationSchemes
C#
public enum TesselationSchemes
Visual C++
public enum class TesselationSchemes

Members

Member name | Description
GeometryGrid | GEOMETRY_GRID
GeographyGrid | GEOGRAPHY_GRID

See Also


SqlCompareException Class

[image]

SQL Data Compare API 7.1.0
SqlCompareException Class
Members See Also

This exception is used as the general exception for SQL Compare.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlCompareException _
    Inherits Exception
C#
[SerializableAttribute]
public class SqlCompareException : Exception
Visual C++
[SerializableAttribute]
public ref class SqlCompareException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLCompare.Engine..::.SqlCompareException
RedGate.SQLCompare.Engine..::.ObjectNotInDatabaseException
RedGate.SQLCompare.Engine..::.ObjectNotInDifferences

See Also

SqlCompareException Members


SqlCompareException Members

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareException Members
SqlCompareException Class Constructors Methods Properties See Also

The SqlCompareException type exposes the following members.

Constructors

Name | Description
SqlCompareException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlCompareException Class


SqlCompareException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareException Constructor
SqlCompareException Class See Also

Overload List

Name | Description
SqlCompareException()()() | Constructs a SqlCompareException exception.
SqlCompareException(String) | Constructs a SqlCompareException exception.
SqlCompareException(SerializationInfo, StreamingContext) | Constructs an SqlCompareException exception.
SqlCompareException(String, Exception) | Constructs a SqlCompareException exception.

See Also

SqlCompareException Class
SqlCompareException Members


SqlCompareException Constructor

[image]

SQL Data Compare API 7.1.0
SqlCompareException Constructor
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareException()
Visual C++
public:
SqlCompareException()

See Also

SqlCompareException Class
SqlCompareException Overload


SqlCompareException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SqlCompareException Constructor (String)
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SqlCompareException(
    string message
)
Visual C++
public:
SqlCompareException(
    String^ message
)

Parameters

message
Type: System..::.String
The message for the exception.

See Also

SqlCompareException Class
SqlCompareException Overload


SqlCompareException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
SqlCompareException Constructor (SerializationInfo, StreamingContext)
SqlCompareException Class See Also

Constructs an SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlCompareException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlCompareException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

See Also

SqlCompareException Class
SqlCompareException Overload


SqlCompareException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
SqlCompareException Constructor (String, Exception)
SqlCompareException Class See Also

Constructs a SqlCompareException exception.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public SqlCompareException(
    string message,
    Exception inner
)
Visual C++
public:
SqlCompareException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The message for the exception.
inner
Type: System..::.Exception
The inner exception.

See Also

SqlCompareException Class
SqlCompareException Overload


SqlCompareOwnerMapping Class

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Class
Members See Also

Contains a mapping between the schema or owners in the different databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use Mapping<IOwner> instead", True)> _
Public Class SqlCompareOwnerMapping _
    Inherits Mapping(Of IOwner)
C#
[ObsoleteAttribute("Please use Mapping<IOwner> instead", true)]
public class SqlCompareOwnerMapping : Mapping<IOwner>
Visual C++
[ObsoleteAttribute(L"Please use Mapping<IOwner> instead", true)]
public ref class SqlCompareOwnerMapping : public Mapping<IOwner^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMapping

See Also

SqlCompareOwnerMapping Members


SqlCompareOwnerMapping Members

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Members
SqlCompareOwnerMapping Class Constructors Methods Properties See Also

The SqlCompareOwnerMapping type exposes the following members.

Constructors

Name | Description
SqlCompareOwnerMapping | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

See Also

SqlCompareOwnerMapping Class


SqlCompareOwnerMapping Constructor

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Constructor
SqlCompareOwnerMapping Class See Also

Overload List

Name | Description
SqlCompareOwnerMapping(Mapping<(Of <(IOwner>)>)) | Copy constructor.
SqlCompareOwnerMapping(IOwner, IOwner) | Contructor, calls the base constructor.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Members


SqlCompareOwnerMapping Constructor (Mapping(IOwner))

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Constructor (Mapping<(Of <(IOwner>)>))
SqlCompareOwnerMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    copy As Mapping(Of IOwner) _
)
C#
protected SqlCompareOwnerMapping(
    Mapping<IOwner> copy
)
Visual C++
protected:
SqlCompareOwnerMapping(
    Mapping<IOwner^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
SchemaMapping to copy.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Overload


SqlCompareOwnerMapping Constructor (IOwner, IOwner)

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Constructor (IOwner, IOwner)
SqlCompareOwnerMapping Class See Also

Contructor, calls the base constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IOwner, _
    obj2 As IOwner _
)
C#
public SqlCompareOwnerMapping(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
SqlCompareOwnerMapping(
    IOwner^ obj1,
    IOwner^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the second database.

See Also

SqlCompareOwnerMapping Class
SqlCompareOwnerMapping Overload


SqlCompareOwnerMapping Methods

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping Methods
SqlCompareOwnerMapping Class See Also

The SqlCompareOwnerMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlCompareOwnerMapping Class


Clone Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMapping..::.Clone Method
SqlCompareOwnerMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Object
C#
public override Object Clone()
Visual C++
public:
virtual Object^ Clone() override

Return Value

A shallow copy.

Implements

ICloneable..::.Clone()()()

See Also

SqlCompareOwnerMapping Class


SqlCompareOwnerMappings Class

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Class
Members See Also

Holds mappings for the schema or owners between the two databases. Uses the database objects to create the mappings for the views and the tables from the two databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlCompareOwnerMappings _
    Inherits Mappings(Of IOwner, Boolean) _
    Implements IDisposable
C#
public class SqlCompareOwnerMappings : Mappings<IOwner, bool>, IDisposable
Visual C++
public ref class SqlCompareOwnerMappings : public Mappings<IOwner^, bool>,
    IDisposable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( IOwner, Boolean >)>)
RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings

See Also

SqlCompareOwnerMappings Members


SqlCompareOwnerMappings Members

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Members
SqlCompareOwnerMappings Class Constructors Methods Properties Explicit Interface Implementations See Also

The SqlCompareOwnerMappings type exposes the following members.

Constructors

Name | Description
SqlCompareOwnerMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. CancelOperation()()().)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object ..::. Finalize()()().)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. GetKey(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(Mapping<(Of <(TMap>)>)). (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. Join(TMap, TMap).)
MapDatabase | Maps the specified database according to the current mappings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits apart a mapping and creates two mappings, one to null and one from null. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. Split(Mapping<(Of <(TMap>)>)).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are case-sensitive.
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
SchemaObjectMappings | Returns the schema object mappings for the databases.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareOwnerMappings Class


SqlCompareOwnerMappings Constructor

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Constructor
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
SqlCompareOwnerMappings()()() | Default constructor, with case-sensitive mapping keys.
SqlCompareOwnerMappings(Boolean) | Constructor specifying case-sensitivity.
SqlCompareOwnerMappings(SqlCompareOwnerMappings) | Shallow copy constructor.

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members


SqlCompareOwnerMappings Constructor

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Constructor
SqlCompareOwnerMappings Class See Also

Default constructor, with case-sensitive mapping keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlCompareOwnerMappings()
Visual C++
public:
SqlCompareOwnerMappings()

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload


SqlCompareOwnerMappings Constructor (Boolean)

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Constructor (Boolean)
SqlCompareOwnerMappings Class See Also

Constructor specifying case-sensitivity.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    caseSensitive As Boolean _
)
C#
public SqlCompareOwnerMappings(
    bool caseSensitive
)
Visual C++
public:
SqlCompareOwnerMappings(
    bool caseSensitive
)

Parameters

caseSensitive
Type: System..::.Boolean
If true, the mappings will be done using case-sensitive keys. If false, the keys will be case-insensitive

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload


SqlCompareOwnerMappings Constructor (SqlCompareOwnerMappings)

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Constructor (SqlCompareOwnerMappings)
SqlCompareOwnerMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    ownerMappings As SqlCompareOwnerMappings _
)
C#
public SqlCompareOwnerMappings(
    SqlCompareOwnerMappings ownerMappings
)
Visual C++
public:
SqlCompareOwnerMappings(
    SqlCompareOwnerMappings^ ownerMappings
)

Parameters

ownerMappings
Type: RedGate.SQLCompare.Engine..::.SqlCompareOwnerMappings
SqlCompareOwnerMappings to copy.

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Overload


SqlCompareOwnerMappings Methods

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Methods
SqlCompareOwnerMappings Class See Also

The SqlCompareOwnerMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. CancelOperation()()().)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Overrides Object ..::. Finalize()()().)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. GetKey(String).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(Mapping<(Of <(TMap>)>)). (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. Join(TMap, TMap).)
MapDatabase | Maps the specified database according to the current mappings.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits apart a mapping and creates two mappings, one to null and one from null. (Overrides Mappings <(Of <( IOwner, Boolean >)>)..::. Split(Mapping<(Of <(TMap>)>)).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SqlCompareOwnerMappings Class


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.CancelOperation Method
SqlCompareOwnerMappings Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelOperation
C#
public override void CancelOperation()
Visual C++
public:
virtual void CancelOperation() override

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException will be thrown.

See Also

SqlCompareOwnerMappings Class


CreateMappings Method

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.CreateMappings Method
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
CreateMappings(Database, Database) | Creates a mapping for each owner or schema in the database where such a mapping is possible.
CreateMappings<(Of <(U>)>)(KeyedCollection<(Of <(U>)>), KeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members


CreateMappings Method (Database, Database)

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.CreateMappings Method (Database, Database)
SqlCompareOwnerMappings Class See Also

Creates a mapping for each owner or schema in the database where such a mapping is possible.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    db1 As Database, _
    db2 As Database _
)
C#
public void CreateMappings(
    Database db1,
    Database db2
)
Visual C++
public:
void CreateMappings(
    Database^ db1,
    Database^ db2
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database, or null.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database, or null.

See Also

SqlCompareOwnerMappings Class
CreateMappings Overload


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Dispose Method
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) |

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members


Dispose Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Dispose Method
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

SqlCompareOwnerMappings Class
Dispose Overload


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Dispose Method (Boolean)
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean

See Also

SqlCompareOwnerMappings Class
Dispose Overload


Finalize Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Finalize Method
SqlCompareOwnerMappings Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override

See Also

SqlCompareOwnerMappings Class


GetKey Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.GetKey Method
SqlCompareOwnerMappings Class See Also

Return the key that should be used for the specified fully qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetKey ( _
    fullyQualifiedName As String _
) As String
C#
protected override string GetKey(
    string fullyQualifiedName
)
Visual C++
protected:
virtual String^ GetKey(
    String^ fullyQualifiedName
) override

Parameters

fullyQualifiedName
Type: System..::.String

Return Value

See Also

SqlCompareOwnerMappings Class


Join Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Join Method
SqlCompareOwnerMappings Class See Also

Called to join two schemas or users tables together. For each schema or user, attempts to map the tables and views in the specified schema or belonging to the specified user. Any tables mapped in the schema or belonging to the user will be Split(Mapping<(Of <(TMap>)>)).

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As IOwner, _
    obj2 As IOwner _
) As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Join(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
virtual Mapping<IOwner^>^ Join(
    IOwner^ obj1,
    IOwner^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
System..::.ArgumentException | SchemaMappings.Join must be called with Schema or Users arguments.

See Also

SqlCompareOwnerMappings Class


MapDatabase Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.MapDatabase Method
SqlCompareOwnerMappings Class See Also

Maps the specified database according to the current mappings.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub MapDatabase ( _
    first As Boolean _
)
C#
public void MapDatabase(
    bool first
)
Visual C++
public:
void MapDatabase(
    bool first
)

Parameters

first
Type: System..::.Boolean
If true, Database1()()() is mapped. If false, Database2()()() is mapped.

See Also

SqlCompareOwnerMappings Class


Split Method

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Split Method
SqlCompareOwnerMappings Class See Also

Splits apart a mapping and creates two mappings, one to null and one from null.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Split ( _
    old1 As Mapping(Of IOwner) _
)
C#
public override void Split(
    Mapping<IOwner> old1
)
Visual C++
public:
virtual void Split(
    Mapping<IOwner^>^ old1
) override

Parameters

old1
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
The mapping to be split. Both obj1 and obj2 should be not null.

See Also

SqlCompareOwnerMappings Class


SqlCompareOwnerMappings Properties

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings Properties
SqlCompareOwnerMappings Class See Also

The SqlCompareOwnerMappings type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are case-sensitive.
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
SchemaObjectMappings | Returns the schema object mappings for the databases.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

SqlCompareOwnerMappings Class


CaseSensitive Property

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.CaseSensitive Property
SqlCompareOwnerMappings Class See Also

True if the keys are case-sensitive.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; }
Visual C++
public:
property bool CaseSensitive {
    bool get ();
}

See Also

SqlCompareOwnerMappings Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.Item Property
SqlCompareOwnerMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

SqlCompareOwnerMappings Class
SqlCompareOwnerMappings Members


SchemaObjectMappings Property

[image]

SQL Data Compare API 7.1.0
SqlCompareOwnerMappings..::.SchemaObjectMappings Property
SqlCompareOwnerMappings Class See Also

Returns the schema object mappings for the databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaObjectMappings As SchemaObjectMappings
C#
public SchemaObjectMappings SchemaObjectMappings { get; }
Visual C++
public:
property SchemaObjectMappings^ SchemaObjectMappings {
    SchemaObjectMappings^ get ();
}

See Also

SqlCompareOwnerMappings Class


SqlSetOptions Class

[image]

SQL Data Compare API 7.1.0
SqlSetOptions Class
Members See Also

SQL set options.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SqlSetOptions
C#
public sealed class SqlSetOptions
Visual C++
public ref class SqlSetOptions sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.SqlSetOptions

See Also

SqlSetOptions Members


SqlSetOptions Members

[image] [image]

SQL Data Compare API 7.1.0
SqlSetOptions Members
SqlSetOptions Class Constructors Methods See Also

The SqlSetOptions type exposes the following members.

Constructors

Name | Description
SqlSetOptions | Constructs a SQLSetOptions class. This stores information about connection settings, such as ANSI warnings, ANSI NULLs, quoted identifiers, etc.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultOptions | Sets the default options. This sets numeric roundabort to false, ANSI padding to true, ANSI warnings to true, concatenation yields NULL to true, arithmetic abort to true, quoted identifiers to true, and ANSI NULLs to true.
SetOption | Sets an option.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlSetOptions Class


SqlSetOptions Constructor

[image]

SQL Data Compare API 7.1.0
SqlSetOptions Constructor
SqlSetOptions Class See Also

Constructs a SQLSetOptions class. This stores information about connection settings, such as ANSI warnings, ANSI NULLs, quoted identifiers, etc.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlSetOptions()
Visual C++
public:
SqlSetOptions()

See Also

SqlSetOptions Class


SqlSetOptions Methods

[image] [image]

SQL Data Compare API 7.1.0
SqlSetOptions Methods
SqlSetOptions Class See Also

The SqlSetOptions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultOptions | Sets the default options. This sets numeric roundabort to false, ANSI padding to true, ANSI warnings to true, concatenation yields NULL to true, arithmetic abort to true, quoted identifiers to true, and ANSI NULLs to true.
SetOption | Sets an option.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlSetOptions Class


SetDefaultOptions Method

[image]

SQL Data Compare API 7.1.0
SqlSetOptions..::.SetDefaultOptions Method
SqlSetOptions Class See Also

Sets the default options. This sets numeric roundabort to false, ANSI padding to true, ANSI warnings to true, concatenation yields NULL to true, arithmetic abort to true, quoted identifiers to true, and ANSI NULLs to true.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDefaultOptions ( _
    block As IBlockWriter _
)
C#
public void SetDefaultOptions(
    IBlockWriter block
)
Visual C++
public:
void SetDefaultOptions(
    IBlockWriter^ block
)

Parameters

block
Type: IBlockWriter

See Also

SqlSetOptions Class


SetOption Method

[image]

SQL Data Compare API 7.1.0
SqlSetOptions..::.SetOption Method
SqlSetOptions Class See Also

Sets an option.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetOption ( _
    block As IBlockWriter, _
    setName As String, _
    value As Boolean _
)
C#
public void SetOption(
    IBlockWriter block,
    string setName,
    bool value
)
Visual C++
public:
void SetOption(
    IBlockWriter^ block,
    String^ setName,
    bool value
)

Parameters

block
Type: IBlockWriter
The block writer in which the option setting should be scripted to.
setName
Type: System..::.String
The name of the setting. This could be NSI_PADDING, ANSI_WARNINGS, CONCAT_NULL_YIELDS_NULL, ARITHABORT, QUOTED_IDENTIFIER, ANSI_NULLS, or NUMERIC_ROUNDABORT.
value
Type: System..::.Boolean
The value of the setting. This can be true or false.

See Also

SqlSetOptions Class


SqlType Enumeration

[image]

SQL Data Compare API 7.1.0
SqlType Enumeration
See Also

A SQL Server data type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlType
C#
public enum SqlType
Visual C++
public enum class SqlType

Members

Member name | Description
Other | Unknown or UDT
ClrType | CLR type
Table | Table type
Empty | Not used
Binary | binary
Varbinary | varbinary
Char | char
Varchar | varchar
NChar | nchar
NVarchar | nvarchar
DateTime | datetime
SmallDatetime | smalldatetime
Decimal | decimal
Numeric | numeric
Float | float
Real | real
Integer64 | integer64
Integer32 | integer32
Integer16 | integer16
Byte | byte
Money | money
SmallMoney | smallmoney
Boolean | boolean
Timestamp | timestamp
Guid | guid
Image | image
NText | ntext
Text | text
Variant | variant
Xml | XML
Date | date
Time | time
DateTimeOffset | datetimeoffset
DateTime2 | datetime2

See Also


StoredProcedure Class

[image]

SQL Data Compare API 7.1.0
StoredProcedure Class
Members See Also

A stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoredProcedure _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IExecuteAs, IIsSystemObject, IDatabaseObject
C#
public sealed class StoredProcedure : SchemaObjectWithAuthorization, IHasPermissions,
    IExecuteAs, IIsSystemObject, IDatabaseObject
Visual C++
public ref class StoredProcedure sealed : public SchemaObjectWithAuthorization,
    IHasPermissions, IExecuteAs, IIsSystemObject, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.StoredProcedure

See Also

StoredProcedure Members


StoredProcedure Members

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedure Members
StoredProcedure Class Methods Fields Properties See Also

The StoredProcedure type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AnsiNullsOn | True if the stored procedure was created with ansi nulls on.
Assembly | The CLR assembly for the stored procedure, if it is a CLR stored procedure.
AssemblyClass | The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.
AssemblyMethod | The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the stored procedure is a CLR stored procedure.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the stored procedure definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.StoredProcedure (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the stored procedure.
Permissions | The permissions on this stored procedure.
QuotedIdentifierOn | True if the stored procedure was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Text | The text of the stored procedure.

See Also

StoredProcedure Class


StoredProcedure Methods

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedure Methods
StoredProcedure Class See Also

The StoredProcedure type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

StoredProcedure Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Equals Method
StoredProcedure Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the stored procedure with a specified stored procedure. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

StoredProcedure Class
StoredProcedure Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Equals Method (IDatabaseObject, Options)
StoredProcedure Class See Also

Compares the stored procedure with a specified stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The stored procedure to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the stored procedures are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

StoredProcedure Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.ScriptObject Method
StoredProcedure Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

StoredProcedure Class


StoredProcedure Properties

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedure Properties
StoredProcedure Class See Also

The StoredProcedure type exposes the following properties.

Properties

Name | Description
AnsiNullsOn | True if the stored procedure was created with ansi nulls on.
Assembly | The CLR assembly for the stored procedure, if it is a CLR stored procedure.
AssemblyClass | The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.
AssemblyMethod | The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
CLRObject | True if the stored procedure is a CLR stored procedure.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | True if the stored procedure definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.StoredProcedure (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Parameters | The parameters of the stored procedure.
Permissions | The permissions on this stored procedure.
QuotedIdentifierOn | True if the stored procedure was created with quoted identifiers on.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
Text | The text of the stored procedure.

See Also

StoredProcedure Class


AnsiNullsOn Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.AnsiNullsOn Property
StoredProcedure Class See Also

True if the stored procedure was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

StoredProcedure Class


Assembly Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Assembly Property
StoredProcedure Class See Also

The CLR assembly for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

StoredProcedure Class


AssemblyClass Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.AssemblyClass Property
StoredProcedure Class See Also

The CLR assembly class name for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

StoredProcedure Class


AssemblyMethod Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.AssemblyMethod Property
StoredProcedure Class See Also

The CLR assembly method name for the stored procedure, if it is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

StoredProcedure Class


CLRObject Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.CLRObject Property
StoredProcedure Class See Also

True if the stored procedure is a CLR stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

StoredProcedure Class


Encrypted Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Encrypted Property
StoredProcedure Class See Also

True if the stored procedure definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

StoredProcedure Class


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.ExecuteAs Property
StoredProcedure Class See Also

The user whose security context is to be used for the execution of the stored procedure. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

StoredProcedure Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.ObjectType Property
StoredProcedure Class See Also

Returns ObjectType.StoredProcedure

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

StoredProcedure Class


Parameters Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Parameters Property
StoredProcedure Class See Also

The parameters of the stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As Parameters
C#
public Parameters Parameters { get; }
Visual C++
public:
property Parameters^ Parameters {
    Parameters^ get ();
}

See Also

StoredProcedure Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Permissions Property
StoredProcedure Class See Also

The permissions on this stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

StoredProcedure Class


QuotedIdentifierOn Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.QuotedIdentifierOn Property
StoredProcedure Class See Also

True if the stored procedure was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

StoredProcedure Class


Text Property

[image]

SQL Data Compare API 7.1.0
StoredProcedure..::.Text Property
StoredProcedure Class See Also

The text of the stored procedure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

See Also

StoredProcedure Class


StoredProcedures Class

[image]

SQL Data Compare API 7.1.0
StoredProcedures Class
Members See Also

A collection of stored procedures.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StoredProcedures _
    Inherits SerializableDatabaseObjectCollection(Of StoredProcedure)
C#
public sealed class StoredProcedures : SerializableDatabaseObjectCollection<StoredProcedure>
Visual C++
public ref class StoredProcedures sealed : public SerializableDatabaseObjectCollection<StoredProcedure^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( StoredProcedure >)>)
RedGate.SQLCompare.Engine..::.StoredProcedures

See Also

StoredProcedures Members


StoredProcedures Members

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedures Members
StoredProcedures Class Methods Properties Explicit Interface Implementations See Also

The StoredProcedures type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

StoredProcedures Class


SymmetricKey Class

[image]

SQL Data Compare API 7.1.0
SymmetricKey Class
Members See Also

A symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SymmetricKey _
    Inherits DatabaseObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class SymmetricKey : DatabaseObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class SymmetricKey sealed : public DatabaseObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.DatabaseObjectWithAuthorization
RedGate.SQLCompare.Engine..::.SymmetricKey

See Also

SymmetricKey Members


SymmetricKey Members

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKey Members
SymmetricKey Class Methods Fields Properties See Also

The SymmetricKey type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
CreateDate | The date of creation for the symmetric key.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The symmetric key algorithm.
KeyGuid | The GUID for the symmetric key.
KeyLength | The length of the symmetric key.
ModifyDate | The date of the last modification for the symmetric key.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.SymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this symmetric key.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

SymmetricKey Class


SymmetricKey Methods

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKey Methods
SymmetricKey Class See Also

The SymmetricKey type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymmetricKey Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKey..::.Equals Method
SymmetricKey Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the symmetric key with a specified symmetric key. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

SymmetricKey Class
SymmetricKey Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.Equals Method (IDatabaseObject, Options)
SymmetricKey Class See Also

Compares the symmetric key with a specified symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The symmetric key to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the symmetric keys are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

SymmetricKey Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.ScriptObject Method
SymmetricKey Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options, e.g. quoted identifier on or off.
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

SymmetricKey Class


SymmetricKey Properties

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKey Properties
SymmetricKey Class See Also

The SymmetricKey type exposes the following properties.

Properties

Name | Description
CreateDate | The date of creation for the symmetric key.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from ScriptableDatabaseObject.)
KeyAlgorithm | The symmetric key algorithm.
KeyGuid | The GUID for the symmetric key.
KeyLength | The length of the symmetric key.
ModifyDate | The date of the last modification for the symmetric key.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.SymmetricKey (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this symmetric key.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The script source for any ALTER AUTHORIZATION statement. (Inherited from DatabaseObjectWithAuthorization.)

See Also

SymmetricKey Class


CreateDate Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.CreateDate Property
SymmetricKey Class See Also

The date of creation for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateDate As DateTime
C#
public DateTime CreateDate { get; internal set; }
Visual C++
public:
property DateTime CreateDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SymmetricKey Class


KeyAlgorithm Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.KeyAlgorithm Property
SymmetricKey Class See Also

The symmetric key algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyAlgorithm As SymmetricKey..::.SymmetricKeyEncryptionAlgorithm
C#
public SymmetricKey..::.SymmetricKeyEncryptionAlgorithm KeyAlgorithm { get; internal set; }
Visual C++
public:
property SymmetricKey..::.SymmetricKeyEncryptionAlgorithm KeyAlgorithm {
    SymmetricKey..::.SymmetricKeyEncryptionAlgorithm get ();
    void set (SymmetricKey..::.SymmetricKeyEncryptionAlgorithm value);
}

See Also

SymmetricKey Class


KeyGuid Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.KeyGuid Property
SymmetricKey Class See Also

The GUID for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyGuid As Guid
C#
public Guid KeyGuid { get; internal set; }
Visual C++
public:
property Guid KeyGuid {
    Guid get ();
    void set (Guid value);
}

See Also

SymmetricKey Class


KeyLength Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.KeyLength Property
SymmetricKey Class See Also

The length of the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyLength As Integer
C#
public int KeyLength { get; internal set; }
Visual C++
public:
property int KeyLength {
    int get ();
    void set (int value);
}

See Also

SymmetricKey Class


ModifyDate Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.ModifyDate Property
SymmetricKey Class See Also

The date of the last modification for the symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifyDate As DateTime
C#
public DateTime ModifyDate { get; internal set; }
Visual C++
public:
property DateTime ModifyDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SymmetricKey Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.ObjectType Property
SymmetricKey Class See Also

Returns ObjectType.SymmetricKey

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

SymmetricKey Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.Permissions Property
SymmetricKey Class See Also

The permissions on this symmetric key.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

SymmetricKey Class


SymmetricKey.SymmetricKeyEncryptionAlgorithm Enumeration

[image]

SQL Data Compare API 7.1.0
SymmetricKey..::.SymmetricKeyEncryptionAlgorithm Enumeration
SymmetricKey Class See Also

The symmetric key encryption algorithm.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SymmetricKeyEncryptionAlgorithm
C#
public enum SymmetricKeyEncryptionAlgorithm
Visual C++
public enum class SymmetricKeyEncryptionAlgorithm

Members

Member name | Description
Unknown | Unknown
R2 | R2 = RC2
R4 | R4 = RC4
D | D = DES
D3 | D3 = Triple DES
DX | DX = DESX
A1 | A1 = AES 128
A2 | A2 = AES 192
A3 | A3 = AES 256

See Also


SymmetricKeys Class

[image]

SQL Data Compare API 7.1.0
SymmetricKeys Class
Members See Also

A collection of symmetric keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SymmetricKeys _
    Inherits SerializableDatabaseObjectCollection(Of SymmetricKey)
C#
public sealed class SymmetricKeys : SerializableDatabaseObjectCollection<SymmetricKey>
Visual C++
public ref class SymmetricKeys sealed : public SerializableDatabaseObjectCollection<SymmetricKey^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( SymmetricKey >)>)
RedGate.SQLCompare.Engine..::.SymmetricKeys

See Also

SymmetricKeys Members


SymmetricKeys Members

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKeys Members
SymmetricKeys Class Methods Properties Explicit Interface Implementations See Also

The SymmetricKeys type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SymmetricKeys Class


SynchronizationDirection Enumeration

[image]

SQL Data Compare API 7.1.0
SynchronizationDirection Enumeration
See Also

The direction of migration for synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SynchronizationDirection
C#
public enum SynchronizationDirection
Visual C++
public enum class SynchronizationDirection

Members

Member name | Description
From1To2 | SQL scripts will migrate any changes in DataSource1 to DataSource2.
From2To1 | SQL scripts will migrate any changes in DataSource2 to DataSource1.

See Also


Synonym Class

[image]

SQL Data Compare API 7.1.0
Synonym Class
Members See Also

A synonym.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Synonym _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class Synonym : SchemaObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class Synonym sealed : public SchemaObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.Synonym

See Also

Synonym Members


Synonym Members

[image] [image]

SQL Data Compare API 7.1.0
Synonym Members
Synonym Class Methods Fields Properties See Also

The Synonym type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Synonym (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this synonym.
ReferencedName | The name that the synonym references.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)

See Also

Synonym Class


Synonym Methods

[image] [image]

SQL Data Compare API 7.1.0
Synonym Methods
Synonym Class See Also

The Synonym type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

Synonym Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Synonym..::.Equals Method
Synonym Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

Synonym Class
Synonym Members


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Synonym..::.ScriptObject Method
Synonym Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Synonym Class


Synonym Properties

[image] [image]

SQL Data Compare API 7.1.0
Synonym Properties
Synonym Class See Also

The Synonym type exposes the following properties.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Synonym (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this synonym.
ReferencedName | The name that the synonym references.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)

See Also

Synonym Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Synonym..::.ObjectType Property
Synonym Class See Also

Returns ObjectType.Synonym

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

Synonym Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
Synonym..::.Permissions Property
Synonym Class See Also

The permissions on this synonym.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

Synonym Class


ReferencedName Property

[image]

SQL Data Compare API 7.1.0
Synonym..::.ReferencedName Property
Synonym Class See Also

The name that the synonym references.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferencedName As String
C#
public string ReferencedName { get; internal set; }
Visual C++
public:
property String^ ReferencedName {
    String^ get ();
    void set (String^ value);
}

See Also

Synonym Class


Synonyms Class

[image]

SQL Data Compare API 7.1.0
Synonyms Class
Members See Also

A collection of synonyms.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Synonyms _
    Inherits SerializableDatabaseObjectCollection(Of Synonym)
C#
public sealed class Synonyms : SerializableDatabaseObjectCollection<Synonym>
Visual C++
public ref class Synonyms sealed : public SerializableDatabaseObjectCollection<Synonym^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Synonym >)>)
RedGate.SQLCompare.Engine..::.Synonyms

See Also

Synonyms Members


Synonyms Members

[image] [image]

SQL Data Compare API 7.1.0
Synonyms Members
Synonyms Class Methods Properties Explicit Interface Implementations See Also

The Synonyms type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Synonyms Class


Table Class

[image]

SQL Data Compare API 7.1.0
Table Class
Members See Also

A table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Table _
    Inherits ViewTableSuperClass
C#
public sealed class Table : ViewTableSuperClass
Visual C++
public ref class Table sealed : public ViewTableSuperClass

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.Table

See Also

Table Members


Table Members

[image] [image]

SQL Data Compare API 7.1.0
Table Members
Table Class Methods Fields Properties See Also

The Table type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_CatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_FullTextCatalog | (Inherited from ViewTableSuperClass.)
m_FullTextChangeTracking | (Inherited from ViewTableSuperClass.)
m_FullTextIndexed | (Inherited from ViewTableSuperClass.)
m_FullTextStoplist | (Inherited from ViewTableSuperClass.)
m_FullTextStoplistType | (Inherited from ViewTableSuperClass.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_IsSystemObject | This is to be used only by SQL Prompt (Inherited from ViewTableSuperClass.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)
m_Permissions | Permissions. (Inherited from ViewTableSuperClass.)
m_SchemaBoundFunctions | Schema bound functions. (Inherited from ViewTableSuperClass.)
m_SchemaBoundViews | Schema bound views. (Inherited from ViewTableSuperClass.)
m_StoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
m_Triggers | Triggers. (Inherited from ViewTableSuperClass.)

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement.
CheckConstraints | The table's check constraints.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FileGroup | The filegroup on which the table is defined.
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored.
ForeignKeys | The table's foreign keys.
FullTextCatalog | The full-text catalog defined for the table or view. (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextIndex | The full-text index for the table or view. (Inherited from ViewTableSuperClass.)
FullTextIndexed | True if the table or view is full-text indexed. (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature.
Permissions | The permissions applied to this view or table. (Inherited from ViewTableSuperClass.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
TextFileGroup | The filegroup on which the text in the table is defined.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

Table Class


Table Methods

[image] [image]

SQL Data Compare API 7.1.0
Table Methods
Table Class See Also

The Table type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

Table Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Table..::.Equals Method
Table Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the table with a specified table. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

Table Class
Table Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
Table..::.Equals Method (IDatabaseObject, Options)
Table Class See Also

Compares the table with a specified table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The table to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the tables are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Table Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Table..::.ScriptObject Method
Table Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

Table Class


Table Properties

[image] [image]

SQL Data Compare API 7.1.0
Table Properties
Table Class See Also

The Table type exposes the following properties.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
ChangeTracking | Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.
ChangeTrackingScriptSource | The script source for any ALTER TABLE CHANGE_TRACKING statement.
CheckConstraints | The table's check constraints.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DataCompressionPartitions | The partitions on which the table compression is set. This is a SQL Server 2008 feature.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FileGroup | The filegroup on which the table is defined.
FilestreamFileGroup | The filegroup on which the filestreams of the table are to be stored.
ForeignKeys | The table's foreign keys.
FullTextCatalog | The full-text catalog defined for the table or view. (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextIndex | The full-text index for the table or view. (Inherited from ViewTableSuperClass.)
FullTextIndexed | True if the table or view is full-text indexed. (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
IsPartitioned | Indicates whether the table is partitioned. This is a SQL Server 2005 feature.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.Table (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
PartitionedField | Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.
PartitionScheme | The partition scheme for this table. This is a SQL Server 2005 feature.
Permissions | The permissions applied to this view or table. (Inherited from ViewTableSuperClass.)
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
TextFileGroup | The filegroup on which the text in the table is defined.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

Table Class


ChangeTracking Property

[image]

SQL Data Compare API 7.1.0
Table..::.ChangeTracking Property
Table Class See Also

Whether change tracking is enabled for this table. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTracking As Table..::.TableChangeTracking
C#
public Table..::.TableChangeTracking ChangeTracking { get; internal set; }
Visual C++
public:
property Table..::.TableChangeTracking ChangeTracking {
    Table..::.TableChangeTracking get ();
    void set (Table..::.TableChangeTracking value);
}

See Also

Table Class


ChangeTrackingScriptSource Property

[image]

SQL Data Compare API 7.1.0
Table..::.ChangeTrackingScriptSource Property
Table Class See Also

The script source for any ALTER TABLE CHANGE_TRACKING statement.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeTrackingScriptSource As ScriptSource
C#
public ScriptSource ChangeTrackingScriptSource { get; internal set; }
Visual C++
public:
property ScriptSource^ ChangeTrackingScriptSource {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

Table Class


CheckConstraints Property

[image]

SQL Data Compare API 7.1.0
Table..::.CheckConstraints Property
Table Class See Also

The table's check constraints.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckConstraints As CheckConstraints
C#
public CheckConstraints CheckConstraints { get; }
Visual C++
public:
property CheckConstraints^ CheckConstraints {
    CheckConstraints^ get ();
}

See Also

Table Class


DataCompressionPartitions Property

[image]

SQL Data Compare API 7.1.0
Table..::.DataCompressionPartitions Property
Table Class See Also

The partitions on which the table compression is set. This is a SQL Server 2008 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataCompressionPartitions As IDictionary(Of Integer, DataCompression)
C#
public IDictionary<int, DataCompression> DataCompressionPartitions { get; }
Visual C++
public:
property IDictionary<int, DataCompression>^ DataCompressionPartitions {
    IDictionary<int, DataCompression>^ get ();
}

See Also

Table Class


FileGroup Property

[image]

SQL Data Compare API 7.1.0
Table..::.FileGroup Property
Table Class See Also

The filegroup on which the table is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGroup As String
C#
public string FileGroup { get; internal set; }
Visual C++
public:
property String^ FileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class


FilestreamFileGroup Property

[image]

SQL Data Compare API 7.1.0
Table..::.FilestreamFileGroup Property
Table Class See Also

The filegroup on which the filestreams of the table are to be stored.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FilestreamFileGroup As String
C#
public string FilestreamFileGroup { get; internal set; }
Visual C++
public:
property String^ FilestreamFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class


ForeignKeys Property

[image]

SQL Data Compare API 7.1.0
Table..::.ForeignKeys Property
Table Class See Also

The table's foreign keys.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForeignKeys As ForeignKeys
C#
public ForeignKeys ForeignKeys { get; }
Visual C++
public:
property ForeignKeys^ ForeignKeys {
    ForeignKeys^ get ();
}

See Also

Table Class


IsPartitioned Property

[image]

SQL Data Compare API 7.1.0
Table..::.IsPartitioned Property
Table Class See Also

Indicates whether the table is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPartitioned As Boolean
C#
public bool IsPartitioned { get; internal set; }
Visual C++
public:
property bool IsPartitioned {
    bool get ();
    void set (bool value);
}

See Also

Table Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Table..::.ObjectType Property
Table Class See Also

Returns ObjectType.Table

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType

See Also

Table Class


PartitionedField Property

[image]

SQL Data Compare API 7.1.0
Table..::.PartitionedField Property
Table Class See Also

Indicates the field over which the table is partitioned. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionedField As Field
C#
public Field PartitionedField { get; internal set; }
Visual C++
public:
property Field^ PartitionedField {
    Field^ get ();
    void set (Field^ value);
}

See Also

Table Class


PartitionScheme Property

[image]

SQL Data Compare API 7.1.0
Table..::.PartitionScheme Property
Table Class See Also

The partition scheme for this table. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionScheme As PartitionScheme
C#
public PartitionScheme PartitionScheme { get; internal set; }
Visual C++
public:
property PartitionScheme^ PartitionScheme {
    PartitionScheme^ get ();
    void set (PartitionScheme^ value);
}

See Also

Table Class


TextFileGroup Property

[image]

SQL Data Compare API 7.1.0
Table..::.TextFileGroup Property
Table Class See Also

The filegroup on which the text in the table is defined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TextFileGroup As String
C#
public string TextFileGroup { get; internal set; }
Visual C++
public:
property String^ TextFileGroup {
    String^ get ();
    void set (String^ value);
}

See Also

Table Class


Table.TableChangeTracking Enumeration

[image]

SQL Data Compare API 7.1.0
Table..::.TableChangeTracking Enumeration
Table Class See Also

Table change tracking option set. This has been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TableChangeTracking
C#
public enum TableChangeTracking
Visual C++
public enum class TableChangeTracking

Members

Member name | Description
Disabled | Change tracking is disabled.
Enabled | Change tracking is enabled.
EnabledWithTrackColumnsUpdated | Change tracking is enabled with information on which columns were updated.

See Also


Tables Class

[image]

SQL Data Compare API 7.1.0
Tables Class
Members See Also

A collection of tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Tables _
    Inherits SerializableDatabaseObjectCollection(Of Table)
C#
public sealed class Tables : SerializableDatabaseObjectCollection<Table>
Visual C++
public ref class Tables sealed : public SerializableDatabaseObjectCollection<Table^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( Table >)>)
RedGate.SQLCompare.Engine..::.Tables

See Also

Tables Members


Tables Members

[image] [image]

SQL Data Compare API 7.1.0
Tables Members
Tables Class Methods Properties Explicit Interface Implementations See Also

The Tables type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Tables Class


Trigger Class

[image]

SQL Data Compare API 7.1.0
Trigger Class
Members See Also

A trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Trigger _
    Implements IExecuteAs, IDatabaseObject
C#
public sealed class Trigger : IExecuteAs,
    IDatabaseObject
Visual C++
public ref class Trigger sealed : IExecuteAs,
    IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Trigger

See Also

Trigger Members


Trigger Members

[image] [image]

SQL Data Compare API 7.1.0
Trigger Members
Trigger Class Methods Properties Explicit Interface Implementations See Also

The Trigger type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DML trigger, if it is a CLR DML trigger.
AssemblyClass | The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.
AssemblyMethod | The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.
CLRObject | True if the trigger is a CLR trigger.
Database | The database to which the trigger belongs.
Delete | True if the trigger is a delete trigger.
Encrypted | True if the trigger definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 feature.
FirstDeleteTrigger | True if the trigger is the first delete trigger.
FirstInsertTrigger | True if the trigger is the first insert trigger.
FirstUpdateTrigger | True if the trigger is the first update trigger.
FullyQualifiedName | The fully-qualified name of the trigger.
ID | Obsolete. The identifier of the trigger.
Insert | True if the trigger is an insert trigger.
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
LastDeleteTrigger | True if the trigger is the last delete trigger.
LastInsertTrigger | True if the trigger is the last insert trigger.
LastUpdateTrigger | True if the trigger is the last update trigger.
Name | The name of the trigger.
NotForReplication | True if this trigger is NOT FOR REPLICATION.
ObjectType | Returns ObjectType.Trigger
Owner | The owner or the schema of the trigger.
Parent | The parent of the trigger.
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
SysobjectID | The identifier of the trigger.
Text | The text of the trigger.
Update | True if the trigger is an update trigger.

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Trigger Class


Trigger Methods

[image] [image]

SQL Data Compare API 7.1.0
Trigger Methods
Trigger Class See Also

The Trigger type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IDatabaseObject..::.Equals |

See Also

Trigger Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Trigger..::.Equals Method
Trigger Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Trigger, Options) | Compares the trigger with a specified trigger.

See Also

Trigger Class
Trigger Members


Equals Method (Trigger, Options)

[image]

SQL Data Compare API 7.1.0
Trigger..::.Equals Method (Trigger, Options)
Trigger Class See Also

Compares the trigger with a specified trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    targetTrigger As Trigger, _
    options As Options _
) As Boolean
C#
public bool Equals(
    Trigger targetTrigger,
    Options options
)
Visual C++
public:
bool Equals(
    Trigger^ targetTrigger,
    Options options
)

Parameters

targetTrigger
Type: RedGate.SQLCompare.Engine..::.Trigger
The trigger to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the triggers are identical; otherwise, false.

See Also

Trigger Class
Equals Overload


IDatabaseObject.Equals Method

[image]

SQL Data Compare API 7.1.0
Trigger..::.IDatabaseObject..::.Equals Method
Trigger Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean Implements IDatabaseObject.Equals
C#
bool IDatabaseObject.Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
private:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) sealed = IDatabaseObject::Equals

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

Trigger Class


Trigger Properties

[image] [image]

SQL Data Compare API 7.1.0
Trigger Properties
Trigger Class See Also

The Trigger type exposes the following properties.

Properties

Name | Description
After | True if the trigger is an after trigger.
AnsiNullsOn | True if the trigger was created with ansi nulls on.
Assembly | The CLR assembly for the DML trigger, if it is a CLR DML trigger.
AssemblyClass | The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.
AssemblyMethod | The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.
CLRObject | True if the trigger is a CLR trigger.
Database | The database to which the trigger belongs.
Delete | True if the trigger is a delete trigger.
Encrypted | True if the trigger definition is encrypted.
ExecuteAs | The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 feature.
FirstDeleteTrigger | True if the trigger is the first delete trigger.
FirstInsertTrigger | True if the trigger is the first insert trigger.
FirstUpdateTrigger | True if the trigger is the first update trigger.
FullyQualifiedName | The fully-qualified name of the trigger.
ID | Obsolete. The identifier of the trigger.
Insert | True if the trigger is an insert trigger.
InsteadOf | True if the trigger is an instead of trigger.
IsDisabled | True if the trigger is disabled.
LastDeleteTrigger | True if the trigger is the last delete trigger.
LastInsertTrigger | True if the trigger is the last insert trigger.
LastUpdateTrigger | True if the trigger is the last update trigger.
Name | The name of the trigger.
NotForReplication | True if this trigger is NOT FOR REPLICATION.
ObjectType | Returns ObjectType.Trigger
Owner | The owner or the schema of the trigger.
Parent | The parent of the trigger.
QuotedIdentifierOn | True if the trigger was created with quoted identifiers on.
SysobjectID | The identifier of the trigger.
Text | The text of the trigger.
Update | True if the trigger is an update trigger.

See Also

Trigger Class


After Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.After Property
Trigger Class See Also

True if the trigger is an after trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property After As Boolean
C#
public bool After { get; internal set; }
Visual C++
public:
property bool After {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


AnsiNullsOn Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.AnsiNullsOn Property
Trigger Class See Also

True if the trigger was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Trigger Class


Assembly Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Assembly Property
Trigger Class See Also

The CLR assembly for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

Trigger Class


AssemblyClass Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.AssemblyClass Property
Trigger Class See Also

The CLR assembly class name for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


AssemblyMethod Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.AssemblyMethod Property
Trigger Class See Also

The CLR assembly method name for the DML trigger, if it is a CLR DML trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyMethod As String
C#
public string AssemblyMethod { get; internal set; }
Visual C++
public:
property String^ AssemblyMethod {
    String^ get ();
    void set (String^ value);
}

See Also

Trigger Class


CLRObject Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.CLRObject Property
Trigger Class See Also

True if the trigger is a CLR trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Trigger Class


Database Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Database Property
Trigger Class See Also

The database to which the trigger belongs.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As Database
C#
public Database Database { get; internal set; }
Visual C++
public:
virtual property Database^ Database {
    Database^ get () sealed;
    void set (Database^ value) sealed;
}

Implements

IDatabaseObject..::.Database

See Also

Trigger Class


Delete Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Delete Property
Trigger Class See Also

True if the trigger is a delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Delete As Boolean
C#
public bool Delete { get; internal set; }
Visual C++
public:
property bool Delete {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


Encrypted Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Encrypted Property
Trigger Class See Also

True if the trigger definition is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Trigger Class


ExecuteAs Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.ExecuteAs Property
Trigger Class See Also

The user whose security context is to be used for the execution of the trigger. This is a SQL Server 2005 feature.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecuteAs As User
C#
public User ExecuteAs { get; internal set; }
Visual C++
public:
virtual property User^ ExecuteAs {
    User^ get () sealed;
    void set (User^ value) sealed;
}

Implements

IExecuteAs..::.ExecuteAs

See Also

Trigger Class


FirstDeleteTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.FirstDeleteTrigger Property
Trigger Class See Also

True if the trigger is the first delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstDeleteTrigger As Boolean
C#
public bool FirstDeleteTrigger { get; internal set; }
Visual C++
public:
property bool FirstDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


FirstInsertTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.FirstInsertTrigger Property
Trigger Class See Also

True if the trigger is the first insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstInsertTrigger As Boolean
C#
public bool FirstInsertTrigger { get; internal set; }
Visual C++
public:
property bool FirstInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


FirstUpdateTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.FirstUpdateTrigger Property
Trigger Class See Also

True if the trigger is the first update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstUpdateTrigger As Boolean
C#
public bool FirstUpdateTrigger { get; internal set; }
Visual C++
public:
property bool FirstUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.FullyQualifiedName Property
Trigger Class See Also

The fully-qualified name of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullyQualifiedName As String
C#
public string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.FullyQualifiedName

See Also

Trigger Class


ID Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.ID Property
Trigger Class See Also

The identifier of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use SysobjectID instead")> _
Public ReadOnly Property ID As Integer
C#
[ObsoleteAttribute("Please use SysobjectID instead")]
public int ID { get; }
Visual C++
[ObsoleteAttribute(L"Please use SysobjectID instead")]
public:
property int ID {
    int get ();
}

See Also

Trigger Class


Insert Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Insert Property
Trigger Class See Also

True if the trigger is an insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Insert As Boolean
C#
public bool Insert { get; internal set; }
Visual C++
public:
property bool Insert {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


InsteadOf Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.InsteadOf Property
Trigger Class See Also

True if the trigger is an instead of trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InsteadOf As Boolean
C#
public bool InsteadOf { get; internal set; }
Visual C++
public:
property bool InsteadOf {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


IsDisabled Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.IsDisabled Property
Trigger Class See Also

True if the trigger is disabled.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDisabled As Boolean
C#
public bool IsDisabled { get; internal set; }
Visual C++
public:
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


LastDeleteTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.LastDeleteTrigger Property
Trigger Class See Also

True if the trigger is the last delete trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastDeleteTrigger As Boolean
C#
public bool LastDeleteTrigger { get; internal set; }
Visual C++
public:
property bool LastDeleteTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


LastInsertTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.LastInsertTrigger Property
Trigger Class See Also

True if the trigger is the last insert trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastInsertTrigger As Boolean
C#
public bool LastInsertTrigger { get; internal set; }
Visual C++
public:
property bool LastInsertTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


LastUpdateTrigger Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.LastUpdateTrigger Property
Trigger Class See Also

True if the trigger is the last update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastUpdateTrigger As Boolean
C#
public bool LastUpdateTrigger { get; internal set; }
Visual C++
public:
property bool LastUpdateTrigger {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


Name Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Name Property
Trigger Class See Also

The name of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IDatabaseObject..::.Name

See Also

Trigger Class


NotForReplication Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.NotForReplication Property
Trigger Class See Also

True if this trigger is NOT FOR REPLICATION.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property NotForReplication As Boolean
C#
public bool NotForReplication { get; internal set; }
Visual C++
public:
property bool NotForReplication {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.ObjectType Property
Trigger Class See Also

Returns ObjectType.Trigger

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As ObjectType
C#
public ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () sealed;
}

Implements

IDatabaseObject..::.ObjectType

See Also

Trigger Class


Owner Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Owner Property
Trigger Class See Also

The owner or the schema of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; internal set; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatabaseObject..::.Owner

See Also

Trigger Class


Parent Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Parent Property
Trigger Class See Also

The parent of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As IDatabaseObject
C#
public IDatabaseObject Parent { get; internal set; }
Visual C++
public:
property IDatabaseObject^ Parent {
    IDatabaseObject^ get ();
    void set (IDatabaseObject^ value);
}

See Also

Trigger Class


QuotedIdentifierOn Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.QuotedIdentifierOn Property
Trigger Class See Also

True if the trigger was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Trigger Class


SysobjectID Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.SysobjectID Property
Trigger Class See Also

The identifier of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SysobjectID As Integer
C#
public int SysobjectID { get; internal set; }
Visual C++
public:
virtual property int SysobjectID {
    int get () sealed;
    void set (int value) sealed;
}

See Also

Trigger Class


Text Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Text Property
Trigger Class See Also

The text of the trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

See Also

Trigger Class


Update Property

[image]

SQL Data Compare API 7.1.0
Trigger..::.Update Property
Trigger Class See Also

True if the trigger is an update trigger.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Update As Boolean
C#
public bool Update { get; internal set; }
Visual C++
public:
property bool Update {
    bool get ();
    void set (bool value);
}

See Also

Trigger Class


Triggers Class

[image]

SQL Data Compare API 7.1.0
Triggers Class
Members See Also

A collection of triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Triggers _
    Inherits SerializableCollection(Of Trigger)
C#
public sealed class Triggers : SerializableCollection<Trigger>
Visual C++
public ref class Triggers sealed : public SerializableCollection<Trigger^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Trigger >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( Trigger >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( Trigger >)>)
RedGate.SQLCompare.Engine..::.Triggers

See Also

Triggers Members


Triggers Members

[image] [image]

SQL Data Compare API 7.1.0
Triggers Members
Triggers Class Methods Properties Explicit Interface Implementations See Also

The Triggers type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Triggers Class


Triggers Properties

[image] [image]

SQL Data Compare API 7.1.0
Triggers Properties
Triggers Class See Also

The Triggers type exposes the following properties.

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

See Also

Triggers Class


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Triggers..::.Item Property
Triggers Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns a trigger given its fully-qualified name. (Overrides KeyedCollection <(Of <( Trigger >)>)..::. Item[([(String])]).)
Item[([(String, String])]) | Returns a trigger given its name and owner.

See Also

Triggers Class
Triggers Members


Item Property (String)

[image]

SQL Data Compare API 7.1.0
Triggers..::.Item Property (String)
Triggers Class See Also

Returns a trigger given its fully-qualified name.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    fullyQualifiedName As String _
) As Trigger
C#
public override Trigger this[
    string fullyQualifiedName
] { get; }
Visual C++
public:
virtual property Trigger^ default[String^ fullyQualifiedName] {
    Trigger^ get (String^ fullyQualifiedName) override;
}

Parameters

fullyQualifiedName
Type: System..::.String
The string-based index of the element to get or set.

See Also

Triggers Class
Item Overload


Item Property (String, String)

[image]

SQL Data Compare API 7.1.0
Triggers..::.Item Property (String, String)
Triggers Class See Also

Returns a trigger given its name and owner.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    owner As String, _
    name As String _
) As Trigger
C#
public Trigger this[
    string owner,
    string name
] { get; }
Visual C++
public:
property Trigger^ default[String^ owner, String^ name] {
    Trigger^ get (String^ owner, String^ name);
}

Parameters

owner
Type: System..::.String
The owner component of the string-based index of the element to get or set.
name
Type: System..::.String
The name component of the string-based index of the element to get or set.

See Also

Triggers Class
Item Overload


User Class

[image]

SQL Data Compare API 7.1.0
User Class
Members See Also

A user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class User _
    Inherits ScriptableDatabaseObject _
    Implements IHasPermissions, IOwner, IDatabaseObject
C#
public sealed class User : ScriptableDatabaseObject, IHasPermissions,
    IOwner, IDatabaseObject
Visual C++
public ref class User sealed : public ScriptableDatabaseObject,
    IHasPermissions, IOwner, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.User

See Also

User Members


User Members

[image] [image]

SQL Data Compare API 7.1.0
User Members
User Class Methods Fields Properties See Also

The User type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AsymmetricKey | The name of the asymmetric key if the user is an asymmetric key bound user.
Certificate | The name of the certificate key if the user is an certificate key bound user.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the user's database-level permissions.
DefaultSchema | The default schema of SQL Server 2005 users.
ExtendedProperties | The extended properties defined for the user.
FullyQualifiedName | The fully-qualified name of the user. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSQLUser | Obsolete. True if the user is a SQL user.
IsWindowsUser | Obsolete. True if the user is a Windows user.
LoginName | The login name of the user.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner of the user. This is undefined. (Overrides ScriptableDatabaseObject ..::. Owner.)
Permissions | The permissions on this user.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
UserType | The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

See Also

User Class


User Methods

[image] [image]

SQL Data Compare API 7.1.0
User Methods
User Class See Also

The User type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

User Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
User..::.Equals Method
User Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the user with a specified user. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

User Class
User Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
User..::.Equals Method (IDatabaseObject, Options)
User Class See Also

Compares the user with a specified user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The user to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the users are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

User Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
User..::.ScriptObject Method
User Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

User Class


User Properties

[image] [image]

SQL Data Compare API 7.1.0
User Properties
User Class See Also

The User type exposes the following properties.

Properties

Name | Description
AsymmetricKey | The name of the asymmetric key if the user is an asymmetric key bound user.
Certificate | The name of the certificate key if the user is an certificate key bound user.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DatabaseLevelPermissions | Access to the user's database-level permissions.
DefaultSchema | The default schema of SQL Server 2005 users.
ExtendedProperties | The extended properties defined for the user.
FullyQualifiedName | The fully-qualified name of the user. (Overrides ScriptableDatabaseObject ..::. FullyQualifiedName.)
IsSQLUser | Obsolete. True if the user is a SQL user.
IsWindowsUser | Obsolete. True if the user is a Windows user.
LoginName | The login name of the user.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.User (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner of the user. This is undefined. (Overrides ScriptableDatabaseObject ..::. Owner.)
Permissions | The permissions on this user.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
UserType | The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

See Also

User Class


AsymmetricKey Property

[image]

SQL Data Compare API 7.1.0
User..::.AsymmetricKey Property
User Class See Also

The name of the asymmetric key if the user is an asymmetric key bound user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AsymmetricKey As String
C#
public string AsymmetricKey { get; internal set; }
Visual C++
public:
property String^ AsymmetricKey {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


Certificate Property

[image]

SQL Data Compare API 7.1.0
User..::.Certificate Property
User Class See Also

The name of the certificate key if the user is an certificate key bound user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Certificate As String
C#
public string Certificate { get; internal set; }
Visual C++
public:
property String^ Certificate {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


DatabaseLevelPermissions Property

[image]

SQL Data Compare API 7.1.0
User..::.DatabaseLevelPermissions Property
User Class See Also

Access to the user's database-level permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseLevelPermissions As DatabaseLevelPermissions
C#
public DatabaseLevelPermissions DatabaseLevelPermissions { get; }
Visual C++
public:
property DatabaseLevelPermissions^ DatabaseLevelPermissions {
    DatabaseLevelPermissions^ get ();
}

See Also

User Class


DefaultSchema Property

[image]

SQL Data Compare API 7.1.0
User..::.DefaultSchema Property
User Class See Also

The default schema of SQL Server 2005 users.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSchema As String
C#
public string DefaultSchema { get; internal set; }
Visual C++
public:
property String^ DefaultSchema {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


ExtendedProperties Property

[image]

SQL Data Compare API 7.1.0
User..::.ExtendedProperties Property
User Class See Also

The extended properties defined for the user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtendedProperties As ExtendedProperties
C#
public ExtendedProperties ExtendedProperties { get; }
Visual C++
public:
property ExtendedProperties^ ExtendedProperties {
    ExtendedProperties^ get ();
}

See Also

User Class


FullyQualifiedName Property

[image]

SQL Data Compare API 7.1.0
User..::.FullyQualifiedName Property
User Class See Also

The fully-qualified name of the user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullyQualifiedName As String
C#
public override string FullyQualifiedName { get; }
Visual C++
public:
virtual property String^ FullyQualifiedName {
    String^ get () override;
}

Implements

IDatabaseObject..::.FullyQualifiedName
IDatabaseObject..::.FullyQualifiedName

See Also

User Class


IsSQLUser Property

[image]

SQL Data Compare API 7.1.0
User..::.IsSQLUser Property
User Class See Also

True if the user is a SQL user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UserType.", False)> _
Public ReadOnly Property IsSQLUser As Boolean
C#
[ObsoleteAttribute("Use UserType.", false)]
public bool IsSQLUser { get; }
Visual C++
[ObsoleteAttribute(L"Use UserType.", false)]
public:
property bool IsSQLUser {
    bool get ();
}

See Also

User Class


IsWindowsUser Property

[image]

SQL Data Compare API 7.1.0
User..::.IsWindowsUser Property
User Class See Also

True if the user is a Windows user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use UserType.", False)> _
Public ReadOnly Property IsWindowsUser As Boolean
C#
[ObsoleteAttribute("Use UserType.", false)]
public bool IsWindowsUser { get; }
Visual C++
[ObsoleteAttribute(L"Use UserType.", false)]
public:
property bool IsWindowsUser {
    bool get ();
}

See Also

User Class


LoginName Property

[image]

SQL Data Compare API 7.1.0
User..::.LoginName Property
User Class See Also

The login name of the user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LoginName As String
C#
public string LoginName { get; internal set; }
Visual C++
public:
property String^ LoginName {
    String^ get ();
    void set (String^ value);
}

See Also

User Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
User..::.ObjectType Property
User Class See Also

Returns ObjectType.User

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

User Class


Owner Property

[image]

SQL Data Compare API 7.1.0
User..::.Owner Property
User Class See Also

The owner of the user. This is undefined.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Owner As String
C#
public override string Owner { get; }
Visual C++
public:
virtual property String^ Owner {
    String^ get () override;
}

Implements

IDatabaseObject..::.Owner
IDatabaseObject..::.Owner

See Also

User Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
User..::.Permissions Property
User Class See Also

The permissions on this user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Permissions As Permissions
C#
public Permissions Permissions { get; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

User Class


UserType Property

[image]

SQL Data Compare API 7.1.0
User..::.UserType Property
User Class See Also

The user type. This can be a certificate or asymmetric key bound user. In addition, in SQL Sever 2000 and earlier this can be a Windows user or a SQL user in SQL Server 2000.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserType As UserType
C#
public UserType UserType { get; internal set; }
Visual C++
public:
property UserType UserType {
    UserType get ();
    void set (UserType value);
}

See Also

User Class


UserDefinedType Class

[image]

SQL Data Compare API 7.1.0
UserDefinedType Class
Members See Also

A user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserDefinedType _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class UserDefinedType : SchemaObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class UserDefinedType sealed : public SchemaObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.UserDefinedType

See Also

UserDefinedType Members


UserDefinedType Members

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedType Members
UserDefinedType Class Methods Fields Properties See Also

The UserDefinedType type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
AllowNulls | True if the user-defined type allows nulls.
Assembly | The CLR assembly for the user-defined type, if this is a CLR user-defined type.
AssemblyClass | The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
BaseTypeName | The name of the underlying type.
CLRObject | True if the user-defined type is a CLR user-defined type.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Default | The default bound to the user-defined type.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Length | The length of the user-defined type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.UserDefinedType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this user-defined type.
Precision | The precision of the user-defined type.
Rule | The rule bound to the user-defined type.
Scale | The scale of the user-defined type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForDefault | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding statement for this object if the database source is set to scripts folder.
SqlType | The underlying type.
TypeTable | This table contains inforamtion about the type if it is a table type. Table types have been introduced in SQL Server 2008.

See Also

UserDefinedType Class


UserDefinedType Methods

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedType Methods
UserDefinedType Class See Also

The UserDefinedType type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

UserDefinedType Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Equals Method
UserDefinedType Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the user-defined type with a specified user-defined type. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

UserDefinedType Class
UserDefinedType Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Equals Method (IDatabaseObject, Options)
UserDefinedType Class See Also

Compares the user-defined type with a specified user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The user-defined type to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
The comparison options.

Return Value

True if the user-defined types are identical; otherwise, false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

UserDefinedType Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.ScriptObject Method
UserDefinedType Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

UserDefinedType Class


UserDefinedType Properties

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedType Properties
UserDefinedType Class See Also

The UserDefinedType type exposes the following properties.

Properties

Name | Description
AllowNulls | True if the user-defined type allows nulls.
Assembly | The CLR assembly for the user-defined type, if this is a CLR user-defined type.
AssemblyClass | The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
BaseTypeName | The name of the underlying type.
CLRObject | True if the user-defined type is a CLR user-defined type.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Default | The default bound to the user-defined type.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Length | The length of the user-defined type.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.UserDefinedType (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this user-defined type.
Precision | The precision of the user-defined type.
Rule | The rule bound to the user-defined type.
Scale | The scale of the user-defined type.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForDefault | The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.
ScriptSourceForRule | The location of the creation script for the rule binding statement for this object if the database source is set to scripts folder.
SqlType | The underlying type.
TypeTable | This table contains inforamtion about the type if it is a table type. Table types have been introduced in SQL Server 2008.

See Also

UserDefinedType Class


AllowNulls Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.AllowNulls Property
UserDefinedType Class See Also

True if the user-defined type allows nulls.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowNulls As Boolean
C#
public bool AllowNulls { get; internal set; }
Visual C++
public:
property bool AllowNulls {
    bool get ();
    void set (bool value);
}

See Also

UserDefinedType Class


Assembly Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Assembly Property
UserDefinedType Class See Also

The CLR assembly for the user-defined type, if this is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Assembly As ClrAssembly
C#
public ClrAssembly Assembly { get; internal set; }
Visual C++
public:
virtual property ClrAssembly^ Assembly {
    ClrAssembly^ get () sealed;
    void set (ClrAssembly^ value) sealed;
}

See Also

UserDefinedType Class


AssemblyClass Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.AssemblyClass Property
UserDefinedType Class See Also

The CLR assembly class name for the user-defined type, if this is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyClass As String
C#
public string AssemblyClass { get; internal set; }
Visual C++
public:
property String^ AssemblyClass {
    String^ get ();
    void set (String^ value);
}

See Also

UserDefinedType Class


BaseTypeName Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.BaseTypeName Property
UserDefinedType Class See Also

The name of the underlying type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseTypeName As String
C#
public string BaseTypeName { get; internal set; }
Visual C++
public:
property String^ BaseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

UserDefinedType Class


CLRObject Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.CLRObject Property
UserDefinedType Class See Also

True if the user-defined type is a CLR user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property CLRObject As Boolean
C#
public bool CLRObject { get; internal set; }
Visual C++
public:
virtual property bool CLRObject {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

UserDefinedType Class


Default Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Default Property
UserDefinedType Class See Also

The default bound to the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Default As Default
C#
public Default Default { get; internal set; }
Visual C++
public:
property Default^ Default {
    Default^ get ();
    void set (Default^ value);
}

See Also

UserDefinedType Class


Length Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Length Property
UserDefinedType Class See Also

The length of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; internal set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.ObjectType Property
UserDefinedType Class See Also

Returns ObjectType.UserDefinedType

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

UserDefinedType Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Permissions Property
UserDefinedType Class See Also

The permissions on this user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

UserDefinedType Class


Precision Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Precision Property
UserDefinedType Class See Also

The precision of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Precision As Integer
C#
public int Precision { get; internal set; }
Visual C++
public:
property int Precision {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class


Rule Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Rule Property
UserDefinedType Class See Also

The rule bound to the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Rule As Rule
C#
public Rule Rule { get; internal set; }
Visual C++
public:
property Rule^ Rule {
    Rule^ get ();
    void set (Rule^ value);
}

See Also

UserDefinedType Class


Scale Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.Scale Property
UserDefinedType Class See Also

The scale of the user-defined type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale { get; internal set; }
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

See Also

UserDefinedType Class


ScriptSourceForDefault Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.ScriptSourceForDefault Property
UserDefinedType Class See Also

The location of the creation script for the default binding statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForDefault As ScriptSource
C#
public ScriptSource ScriptSourceForDefault { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForDefault {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

UserDefinedType Class


ScriptSourceForRule Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.ScriptSourceForRule Property
UserDefinedType Class See Also

The location of the creation script for the rule binding statement for this object if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForRule As ScriptSource
C#
public ScriptSource ScriptSourceForRule { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForRule {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

UserDefinedType Class


SqlType Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.SqlType Property
UserDefinedType Class See Also

The underlying type.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlType As SqlType
C#
public SqlType SqlType { get; internal set; }
Visual C++
public:
property SqlType SqlType {
    SqlType get ();
    void set (SqlType value);
}

See Also

UserDefinedType Class


TypeTable Property

[image]

SQL Data Compare API 7.1.0
UserDefinedType..::.TypeTable Property
UserDefinedType Class See Also

This table contains inforamtion about the type if it is a table type. Table types have been introduced in SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeTable As Table
C#
public Table TypeTable { get; internal set; }
Visual C++
public:
property Table^ TypeTable {
    Table^ get ();
    void set (Table^ value);
}

See Also

UserDefinedType Class


UserDefinedTypes Class

[image]

SQL Data Compare API 7.1.0
UserDefinedTypes Class
Members See Also

A collection of user-defined types.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UserDefinedTypes _
    Inherits SerializableDatabaseObjectCollection(Of UserDefinedType)
C#
public sealed class UserDefinedTypes : SerializableDatabaseObjectCollection<UserDefinedType>
Visual C++
public ref class UserDefinedTypes sealed : public SerializableDatabaseObjectCollection<UserDefinedType^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( UserDefinedType >)>)
RedGate.SQLCompare.Engine..::.UserDefinedTypes

See Also

UserDefinedTypes Members


UserDefinedTypes Members

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedTypes Members
UserDefinedTypes Class Methods Properties Explicit Interface Implementations See Also

The UserDefinedTypes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

UserDefinedTypes Class


Users Class

[image]

SQL Data Compare API 7.1.0
Users Class
Members See Also

A collection of users.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Users _
    Inherits SerializableDatabaseObjectCollection(Of User)
C#
public sealed class Users : SerializableDatabaseObjectCollection<User>
Visual C++
public ref class Users sealed : public SerializableDatabaseObjectCollection<User^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( User >)>)
RedGate.SQLCompare.Engine..::.Users

See Also

Users Members


Users Members

[image] [image]

SQL Data Compare API 7.1.0
Users Members
Users Class Methods Properties Explicit Interface Implementations See Also

The Users type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Users Class


UserType Enumeration

[image]

SQL Data Compare API 7.1.0
UserType Enumeration
See Also

The type of user.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration UserType
C#
public enum UserType
Visual C++
public enum class UserType

Members

Member name | Description
SqlUser | SQL Server user.
WindowsUser | Windows user.
CertificateUser | Certificate bound user.
AsymmetricKeyUser | Asymmetric key bound user.

See Also


View Class

[image]

SQL Data Compare API 7.1.0
View Class
Members See Also

A view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class View _
    Inherits ViewTableSuperClass _
    Implements IDatabaseObject
C#
public sealed class View : ViewTableSuperClass, IDatabaseObject
Visual C++
public ref class View sealed : public ViewTableSuperClass,
    IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.View

See Also

View Members


View Members

[image] [image]

SQL Data Compare API 7.1.0
View Members
View Class Methods Fields Properties See Also

The View type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_CatalogNameFromSerialization | (Inherited from ViewTableSuperClass.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_Fields | Fields. (Inherited from ViewTableSuperClass.)
m_FullTextCatalog | (Inherited from ViewTableSuperClass.)
m_FullTextChangeTracking | (Inherited from ViewTableSuperClass.)
m_FullTextIndexed | (Inherited from ViewTableSuperClass.)
m_FullTextStoplist | (Inherited from ViewTableSuperClass.)
m_FullTextStoplistType | (Inherited from ViewTableSuperClass.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Indexes | Indexes. (Inherited from ViewTableSuperClass.)
m_IsSystemObject | This is to be used only by SQL Prompt (Inherited from ViewTableSuperClass.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)
m_Permissions | Permissions. (Inherited from ViewTableSuperClass.)
m_SchemaBoundFunctions | Schema bound functions. (Inherited from ViewTableSuperClass.)
m_SchemaBoundViews | Schema bound views. (Inherited from ViewTableSuperClass.)
m_StoplistNameFromSerialization | (Inherited from ViewTableSuperClass.)
m_Triggers | Triggers. (Inherited from ViewTableSuperClass.)

Properties

Name | Description
AnsiNullsOn | True if the view was created with ansi nulls on.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | Identifies whether the view is encrypted.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FullTextCatalog | The full-text catalog defined for the table or view. (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextIndex | The full-text index for the table or view. (Inherited from ViewTableSuperClass.)
FullTextIndexed | True if the table or view is full-text indexed. (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.View (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions applied to this view or table. (Inherited from ViewTableSuperClass.)
QuotedIdentifierOn | True if the view was created with quoted identifiers on.
SchemaBound | True if the view is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
Text | The text of the view.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

View Class


View Methods

[image] [image]

SQL Data Compare API 7.1.0
View Methods
View Class See Also

The View type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

View Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
View..::.Equals Method
View Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the view with a specified view. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

View Class
View Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
View..::.Equals Method (IDatabaseObject, Options)
View Class See Also

Compares the view with a specified view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    target As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject target,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ target,
    Options options
) override

Parameters

target
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The view to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the views are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

View Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
View..::.ScriptObject Method
View Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

View Class


View Properties

[image] [image]

SQL Data Compare API 7.1.0
View Properties
View Class See Also

The View type exposes the following properties.

Properties

Name | Description
AnsiNullsOn | True if the view was created with ansi nulls on.
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
Encrypted | Identifies whether the view is encrypted.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view. (Inherited from ViewTableSuperClass.)
FullTextCatalog | The full-text catalog defined for the table or view. (Inherited from ViewTableSuperClass.)
FullTextChangeTracking | The change tracking setting for the full text index. (Inherited from ViewTableSuperClass.)
FullTextIndex | The full-text index for the table or view. (Inherited from ViewTableSuperClass.)
FullTextIndexed | True if the table or view is full-text indexed. (Inherited from ViewTableSuperClass.)
FullTextStoplist | The user-defined stoplist for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullTextStoplistType | The stoplist type used for the full text index on the table or view. (Inherited from ViewTableSuperClass.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view. (Inherited from ViewTableSuperClass.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.View (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions applied to this view or table. (Inherited from ViewTableSuperClass.)
QuotedIdentifierOn | True if the view was created with quoted identifiers on.
SchemaBound | True if the view is schema bound.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder. (Inherited from ViewTableSuperClass.)
Text | The text of the view.
Triggers | The triggers defined on the table or view. (Inherited from ViewTableSuperClass.)

See Also

View Class


AnsiNullsOn Property

[image]

SQL Data Compare API 7.1.0
View..::.AnsiNullsOn Property
View Class See Also

True if the view was created with ansi nulls on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property AnsiNullsOn As Boolean
C#
public bool AnsiNullsOn { get; internal set; }
Visual C++
public:
virtual property bool AnsiNullsOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

View Class


Encrypted Property

[image]

SQL Data Compare API 7.1.0
View..::.Encrypted Property
View Class See Also

Identifies whether the view is encrypted.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; internal set; }
Visual C++
public:
virtual property bool Encrypted {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

View Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
View..::.ObjectType Property
View Class See Also

Returns ObjectType.View

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

View Class


QuotedIdentifierOn Property

[image]

SQL Data Compare API 7.1.0
View..::.QuotedIdentifierOn Property
View Class See Also

True if the view was created with quoted identifiers on.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property QuotedIdentifierOn As Boolean
C#
public bool QuotedIdentifierOn { get; internal set; }
Visual C++
public:
virtual property bool QuotedIdentifierOn {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

View Class


SchemaBound Property

[image]

SQL Data Compare API 7.1.0
View..::.SchemaBound Property
View Class See Also

True if the view is schema bound.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaBound As Boolean
C#
public bool SchemaBound { get; internal set; }
Visual C++
public:
property bool SchemaBound {
    bool get ();
    void set (bool value);
}

See Also

View Class


Text Property

[image]

SQL Data Compare API 7.1.0
View..::.Text Property
View Class See Also

The text of the view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
}

See Also

View Class


Views Class

[image]

SQL Data Compare API 7.1.0
Views Class
Members See Also

A collection of views.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Views _
    Inherits SerializableDatabaseObjectCollection(Of View)
C#
public sealed class Views : SerializableDatabaseObjectCollection<View>
Visual C++
public ref class Views sealed : public SerializableDatabaseObjectCollection<View^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( View >)>)
RedGate.SQLCompare.Engine..::.Views

See Also

Views Members


Views Members

[image] [image]

SQL Data Compare API 7.1.0
Views Members
Views Class Methods Properties Explicit Interface Implementations See Also

The Views type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

Views Class


ViewsAndTables Class

[image]

SQL Data Compare API 7.1.0
ViewsAndTables Class
Members See Also

A collection of Views and Tables.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ViewsAndTables _
    Inherits KeyedCollection(Of ViewTableSuperClass)
C#
public sealed class ViewsAndTables : KeyedCollection<ViewTableSuperClass>
Visual C++
public ref class ViewsAndTables sealed : public KeyedCollection<ViewTableSuperClass^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ViewTableSuperClass >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( ViewTableSuperClass >)>)
RedGate.SQLCompare.Engine..::.ViewsAndTables

See Also

ViewsAndTables Members


ViewsAndTables Members

[image] [image]

SQL Data Compare API 7.1.0
ViewsAndTables Members
ViewsAndTables Class Methods Properties Explicit Interface Implementations See Also

The ViewsAndTables type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ViewsAndTables Class


ViewTableSuperClass Class

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass Class
Members See Also

A view or table superclass.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ViewTableSuperClass _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IIsSystemObject, IDatabaseObject
C#
public abstract class ViewTableSuperClass : SchemaObjectWithAuthorization, IHasPermissions,
    IIsSystemObject, IDatabaseObject
Visual C++
public ref class ViewTableSuperClass abstract : public SchemaObjectWithAuthorization,
    IHasPermissions, IIsSystemObject, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.ViewTableSuperClass
RedGate.SQLCompare.Engine..::.Table
RedGate.SQLCompare.Engine..::.View

See Also

ViewTableSuperClass Members


ViewTableSuperClass Members

[image] [image]

SQL Data Compare API 7.1.0
ViewTableSuperClass Members
ViewTableSuperClass Class Constructors Methods Fields Properties See Also

The ViewTableSuperClass type exposes the following members.

Constructors

Name | Description
ViewTableSuperClass |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Inherited from ScriptableDatabaseObject.)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_CatalogNameFromSerialization |
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_Fields | Fields.
m_FullTextCatalog |
m_FullTextChangeTracking |
m_FullTextIndexed |
m_FullTextStoplist |
m_FullTextStoplistType |
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Indexes | Indexes.
m_IsSystemObject | This is to be used only by SQL Prompt
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)
m_Permissions | Permissions.
m_SchemaBoundFunctions | Schema bound functions.
m_SchemaBoundViews | Schema bound views.
m_StoplistNameFromSerialization |
m_Triggers | Triggers.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view.
FullTextCatalog | The full-text catalog defined for the table or view.
FullTextChangeTracking | The change tracking setting for the full text index.
FullTextIndex | The full-text index for the table or view.
FullTextIndexed | True if the table or view is full-text indexed.
FullTextStoplist | The user-defined stoplist for the full text index on the table or view.
FullTextStoplistType | The stoplist type used for the full text index on the table or view.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions applied to this view or table.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.
Triggers | The triggers defined on the table or view.

See Also

ViewTableSuperClass Class


ViewTableSuperClass Constructor

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass Constructor
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected ViewTableSuperClass()
Visual C++
protected:
ViewTableSuperClass()

See Also

ViewTableSuperClass Class


ViewTableSuperClass Fields

[image] [image]

SQL Data Compare API 7.1.0
ViewTableSuperClass Fields
ViewTableSuperClass Class See Also

The ViewTableSuperClass type exposes the following fields.

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_CatalogNameFromSerialization |
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_Fields | Fields.
m_FullTextCatalog |
m_FullTextChangeTracking |
m_FullTextIndexed |
m_FullTextStoplist |
m_FullTextStoplistType |
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Indexes | Indexes.
m_IsSystemObject | This is to be used only by SQL Prompt
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)
m_Permissions | Permissions.
m_SchemaBoundFunctions | Schema bound functions.
m_SchemaBoundViews | Schema bound views.
m_StoplistNameFromSerialization |
m_Triggers | Triggers.

See Also

ViewTableSuperClass Class


m_CatalogNameFromSerialization Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_CatalogNameFromSerialization Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_CatalogNameFromSerialization As String
C#
protected string m_CatalogNameFromSerialization
Visual C++
protected:
String^ m_CatalogNameFromSerialization

See Also

ViewTableSuperClass Class


m_Fields Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_Fields Field
ViewTableSuperClass Class See Also

Fields.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Fields As Fields
C#
protected Fields m_Fields
Visual C++
protected:
Fields^ m_Fields

See Also

ViewTableSuperClass Class


m_FullTextCatalog Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_FullTextCatalog Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextCatalog As FullTextCatalog
C#
protected FullTextCatalog m_FullTextCatalog
Visual C++
protected:
FullTextCatalog^ m_FullTextCatalog

See Also

ViewTableSuperClass Class


m_FullTextChangeTracking Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_FullTextChangeTracking Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextChangeTracking As FullTextChangeTracking
C#
protected FullTextChangeTracking m_FullTextChangeTracking
Visual C++
protected:
FullTextChangeTracking m_FullTextChangeTracking

See Also

ViewTableSuperClass Class


m_FullTextIndexed Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_FullTextIndexed Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextIndexed As Boolean
C#
protected bool m_FullTextIndexed
Visual C++
protected:
bool m_FullTextIndexed

See Also

ViewTableSuperClass Class


m_FullTextStoplist Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_FullTextStoplist Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextStoplist As FullTextStoplist
C#
protected FullTextStoplist m_FullTextStoplist
Visual C++
protected:
FullTextStoplist^ m_FullTextStoplist

See Also

ViewTableSuperClass Class


m_FullTextStoplistType Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_FullTextStoplistType Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FullTextStoplistType As FullTextStoplistType
C#
protected FullTextStoplistType m_FullTextStoplistType
Visual C++
protected:
FullTextStoplistType m_FullTextStoplistType

See Also

ViewTableSuperClass Class


m_Indexes Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_Indexes Field
ViewTableSuperClass Class See Also

Indexes.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Indexes As Indexes
C#
protected Indexes m_Indexes
Visual C++
protected:
Indexes^ m_Indexes

See Also

ViewTableSuperClass Class


m_IsSystemObject Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_IsSystemObject Field
ViewTableSuperClass Class See Also

This is to be used only by SQL Prompt

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_IsSystemObject As Boolean
C#
protected bool m_IsSystemObject
Visual C++
protected:
bool m_IsSystemObject

See Also

ViewTableSuperClass Class


m_Permissions Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_Permissions Field
ViewTableSuperClass Class See Also

Permissions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Permissions As Permissions
C#
protected Permissions m_Permissions
Visual C++
protected:
Permissions^ m_Permissions

See Also

ViewTableSuperClass Class


m_SchemaBoundFunctions Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_SchemaBoundFunctions Field
ViewTableSuperClass Class See Also

Schema bound functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SchemaBoundFunctions As Functions
C#
protected Functions m_SchemaBoundFunctions
Visual C++
protected:
Functions^ m_SchemaBoundFunctions

See Also

ViewTableSuperClass Class


m_SchemaBoundViews Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_SchemaBoundViews Field
ViewTableSuperClass Class See Also

Schema bound views.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_SchemaBoundViews As Views
C#
protected Views m_SchemaBoundViews
Visual C++
protected:
Views^ m_SchemaBoundViews

See Also

ViewTableSuperClass Class


m_StoplistNameFromSerialization Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_StoplistNameFromSerialization Field
ViewTableSuperClass Class See Also

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_StoplistNameFromSerialization As String
C#
protected string m_StoplistNameFromSerialization
Visual C++
protected:
String^ m_StoplistNameFromSerialization

See Also

ViewTableSuperClass Class


m_Triggers Field

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.m_Triggers Field
ViewTableSuperClass Class See Also

Triggers.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Triggers As Triggers
C#
protected Triggers m_Triggers
Visual C++
protected:
Triggers^ m_Triggers

See Also

ViewTableSuperClass Class


ViewTableSuperClass Properties

[image] [image]

SQL Data Compare API 7.1.0
ViewTableSuperClass Properties
ViewTableSuperClass Class See Also

The ViewTableSuperClass type exposes the following properties.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
Fields | The fields belonging to the table or view.
FullTextCatalog | The full-text catalog defined for the table or view.
FullTextChangeTracking | The change tracking setting for the full text index.
FullTextIndex | The full-text index for the table or view.
FullTextIndexed | True if the table or view is full-text indexed.
FullTextStoplist | The user-defined stoplist for the full text index on the table or view.
FullTextStoplistType | The stoplist type used for the full text index on the table or view.
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Indexes | The indexes defined on the table or view.
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | The type of the object. (Inherited from ScriptableDatabaseObject.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions applied to this view or table.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)
ScriptSourceForFullTextTable | The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.
Triggers | The triggers defined on the table or view.

See Also

ViewTableSuperClass Class


Fields Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.Fields Property
ViewTableSuperClass Class See Also

The fields belonging to the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As Fields
C#
public Fields Fields { get; }
Visual C++
public:
property Fields^ Fields {
    Fields^ get ();
}

See Also

ViewTableSuperClass Class


FullTextCatalog Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextCatalog Property
ViewTableSuperClass Class See Also

The full-text catalog defined for the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextCatalog As FullTextCatalog
C#
public FullTextCatalog FullTextCatalog { get; internal set; }
Visual C++
public:
property FullTextCatalog^ FullTextCatalog {
    FullTextCatalog^ get ();
    void set (FullTextCatalog^ value);
}

See Also

ViewTableSuperClass Class


FullTextChangeTracking Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextChangeTracking Property
ViewTableSuperClass Class See Also

The change tracking setting for the full text index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextChangeTracking As FullTextChangeTracking
C#
public FullTextChangeTracking FullTextChangeTracking { get; internal set; }
Visual C++
public:
property FullTextChangeTracking FullTextChangeTracking {
    FullTextChangeTracking get ();
    void set (FullTextChangeTracking value);
}

See Also

ViewTableSuperClass Class


FullTextIndex Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextIndex Property
ViewTableSuperClass Class See Also

The full-text index for the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullTextIndex As Index
C#
public Index FullTextIndex { get; }
Visual C++
public:
property Index^ FullTextIndex {
    Index^ get ();
}

See Also

ViewTableSuperClass Class


FullTextIndexed Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextIndexed Property
ViewTableSuperClass Class See Also

True if the table or view is full-text indexed.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextIndexed As Boolean
C#
public bool FullTextIndexed { get; internal set; }
Visual C++
public:
property bool FullTextIndexed {
    bool get ();
    void set (bool value);
}

See Also

ViewTableSuperClass Class


FullTextStoplist Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextStoplist Property
ViewTableSuperClass Class See Also

The user-defined stoplist for the full text index on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplist As FullTextStoplist
C#
public FullTextStoplist FullTextStoplist { get; set; }
Visual C++
public:
property FullTextStoplist^ FullTextStoplist {
    FullTextStoplist^ get ();
    void set (FullTextStoplist^ value);
}

See Also

ViewTableSuperClass Class


FullTextStoplistType Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.FullTextStoplistType Property
ViewTableSuperClass Class See Also

The stoplist type used for the full text index on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FullTextStoplistType As FullTextStoplistType
C#
public FullTextStoplistType FullTextStoplistType { get; set; }
Visual C++
public:
property FullTextStoplistType FullTextStoplistType {
    FullTextStoplistType get ();
    void set (FullTextStoplistType value);
}

See Also

ViewTableSuperClass Class


Indexes Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.Indexes Property
ViewTableSuperClass Class See Also

The indexes defined on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Indexes As Indexes
C#
public Indexes Indexes { get; }
Visual C++
public:
property Indexes^ Indexes {
    Indexes^ get ();
}

See Also

ViewTableSuperClass Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.Permissions Property
ViewTableSuperClass Class See Also

The permissions applied to this view or table.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

ViewTableSuperClass Class


ScriptSourceForFullTextTable Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.ScriptSourceForFullTextTable Property
ViewTableSuperClass Class See Also

The location of the creation script for the fulltext table statement for this table or view if the database source is set to scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSourceForFullTextTable As ScriptSource
C#
public ScriptSource ScriptSourceForFullTextTable { get; set; }
Visual C++
public:
property ScriptSource^ ScriptSourceForFullTextTable {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ViewTableSuperClass Class


Triggers Property

[image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.Triggers Property
ViewTableSuperClass Class See Also

The triggers defined on the table or view.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Triggers As Triggers
C#
public Triggers Triggers { get; }
Visual C++
public:
property Triggers^ Triggers {
    Triggers^ get ();
}

See Also

ViewTableSuperClass Class


WarningSeverity Enumeration

[image]

SQL Data Compare API 7.1.0
WarningSeverity Enumeration
See Also

Warning severity.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration WarningSeverity
C#
public enum WarningSeverity
Visual C++
public enum class WarningSeverity

Members

Member name | Description
Information | Information.
Low | Low.
Medium | Medium.
High | High.

See Also


Work Class

[image]

SQL Data Compare API 7.1.0
Work Class
Members Example See Also

Used to calculate the work to be done to synchronize databases.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Work _
    Implements ICancellable
C#
public sealed class Work : ICancellable
Visual C++
public ref class Work sealed : ICancellable

Remarks

The Work class is used to convert a set of Differences into an ExecutionBlock containing SQL script, which can be used to synchronize two databases. It also provides Warnings and Messages about the work to be done.

ScriptObject(IDatabaseObject, Options) can be used to generate scripts for individual database objects.

Note that you should not re-use a Work object; you should re-create a new object every time.

Examples

This example shows how to compare and synchronize two databases.
C# Copy Code
            Database db1=new Database();
            Database db2=new Database();

            db1.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);
            db2.Register(new ConnectionProperties(".", "WidgetProduction"), Options.Default);

            Differences differences=db1.CompareWith(db2, Options.Default);

            foreach (Difference difference in differences)
            {
                //make sure the difference is selected so it is included in the synchronization
                difference.Selected=true;
            }

            Work work=new Work();

            //calculate the work to do using sensible default options
            //the script is to be run on WidgetProduction so the runOnTwo parameter is true
            work.BuildFromDifferences(differences, Options.Default, true);

            //we can now access the messages and warnings

            Console.WriteLine("Messages:");

            foreach (Message message in work.Messages)
            {
                Console.WriteLine(message.Text);
            }

            Console.WriteLine("Warnings:");

            foreach (Message message in work.Warnings)
            {
                Console.WriteLine(message.Text);
            }

            //print out the SQL used to synchronize

            ExecutionBlock block=work.ExecutionBlock;

            Console.WriteLine("SQL to synchronize:");

            Console.WriteLine(block.GetString());

            //and run the SQL

            RedGate.Shared.Sql.ExecutionBlock.BlockExecutor executor=new RedGate.Shared.Sql.ExecutionBlock.BlockExecutor();
            executor.ExecuteBlock(block, ".", "WidgetProduction");

            //dispose of the objects
            block.Dispose();
            db1.Dispose();
            db2.Dispose();
Visual Basic Copy Code
            Dim db1 As Database = New Database()
            Dim db2 As Database = New Database()

            db1.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)
            db2.Register(New ConnectionProperties(".", "WidgetProduction"), Options.Default)

            Dim differences As Differences = db1.CompareWith(db2, Options.Default)

            Dim difference As Difference

            For Each difference In differences
                'make sure the difference is selected so it is included in the synchronization
                difference.Selected = True
            Next

            Dim work As Work = New Work()

            'calculate the work to do using sensible default options
            'the script is to be run on WidgetProduction so the runOnTwo parameter is true

            work.BuildFromDifferences(differences, Options.Default, True)

            'we can now access the messages and warnings

            Console.WriteLine("Messages:")

            Dim message As Message

            For Each message In work.Messages
                Console.WriteLine(message.Text)
            Next

            Console.WriteLine("Warnings:")

            For Each message In work.Warnings
                Console.WriteLine(message.Text)
            Next

            'print out the SQL used to synchronize

            Dim block As ExecutionBlock = work.ExecutionBlock

            Console.WriteLine("SQL to synchronize:")

            Console.WriteLine(block.GetString())

            'and run the SQL

            Dim executor As BlockExecutor = New BlockExecutor

            executor.ExecuteBlock(block, ".", "WidgetProduction")

            'dispose of the objects
            block.Dispose()
            db1.Dispose()
            db2.Dispose()

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Work

See Also

Work Members


Work Members

[image] [image]

SQL Data Compare API 7.1.0
Work Members
Work Class Constructors Methods Properties See Also

The Work type exposes the following members.

Constructors

Name | Description
Work | Constructor.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Returns the script necessary to create a SQL object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CanRollBackOnFailure | True if the transaction can be completely rolled back on failure.
ExecutionBlock | A block of SQL batches containing SQL script for synchronization.
Messages | Informational messages about the work to be done.
ScriptSynchronizationActions | The script synchronization actions that will be performed during the synchronization.
Status | The event handler for status events.
Warnings | Warnings about the work to be done.

See Also

Work Class


Work Constructor

[image]

SQL Data Compare API 7.1.0
Work Constructor
Work Class See Also

Constructor.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Work()
Visual C++
public:
Work()

See Also

Work Class


Work Methods

[image] [image]

SQL Data Compare API 7.1.0
Work Methods
Work Class See Also

The Work type exposes the following methods.

Methods

Name | Description
BuildFromDifferences | Overloaded.
CancelOperation | Cancels the current operation.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Returns the script necessary to create a SQL object.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Work Class


BuildFromDifferences Method

[image] [image]

SQL Data Compare API 7.1.0
Work..::.BuildFromDifferences Method
Work Class See Also

Overload List

Name | Description
BuildFromDifferences(Differences, Options, Boolean) | Build the work object from a set of differences. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Difference, Options, Boolean) | Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.
BuildFromDifferences(Differences, Options, Boolean, WriteToFileOptions) | Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.
BuildFromDifferences(Differences, Difference, Options, Boolean, WriteToFileOptions) | Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

See Also

Work Class
Work Members


BuildFromDifferences Method (Differences, Options, Boolean)

[image]

SQL Data Compare API 7.1.0
Work..::.BuildFromDifferences Method (Differences, Options, Boolean)
Work Class See Also

Build the work object from a set of differences. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo
)
Visual C++
public:
void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: System..::.Boolean
True if the SQL script is to be run on the second database.

See Also

Work Class
BuildFromDifferences Overload


BuildFromDifferences Method (Differences, Difference, Options, Boolean)

[image]

SQL Data Compare API 7.1.0
Work..::.BuildFromDifferences Method (Differences, Difference, Options, Boolean)
Work Class See Also

Builds the work object from an individual difference. It sets the ExecutionBlock property to include the script for synchronization. Use this method when synchronizing to a live database.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)
Visual C++
public:
void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: System..::.Boolean
True if the SQL script is to be run on the second database.

See Also

Work Class
BuildFromDifferences Overload


BuildFromDifferences Method (Differences, Options, Boolean, WriteToFileOptions)

[image]

SQL Data Compare API 7.1.0
Work..::.BuildFromDifferences Method (Differences, Options, Boolean, WriteToFileOptions)
Work Class See Also

Build the work object from a set of differences. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    options As Options, _
    runOnTwo As Boolean, _
    writeToFileOptions As WriteToFileOptions _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Options options,
    bool runOnTwo,
    WriteToFileOptions writeToFileOptions
)
Visual C++
public:
void BuildFromDifferences(
    Differences^ differences,
    Options options,
    bool runOnTwo,
    WriteToFileOptions^ writeToFileOptions
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: System..::.Boolean
True if the SQL script is to be run on the second database.
writeToFileOptions
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.WriteToFileOptions
Options that sepcify how files are to be created when synchronizing to a scripts folder.

See Also

Work Class
BuildFromDifferences Overload


BuildFromDifferences Method (Differences, Difference, Options, Boolean, WriteToFileOptions)

[image]

SQL Data Compare API 7.1.0
Work..::.BuildFromDifferences Method (Differences, Difference, Options, Boolean, WriteToFileOptions)
Work Class See Also

Builds the work object from an individual difference. It sets the ScriptSynchronizationActions property to include the synchronization actions for modifying a scripts folder. Use this method when synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub BuildFromDifferences ( _
    differences As Differences, _
    onlyDifferenceToInclude As Difference, _
    options As Options, _
    runOnTwo As Boolean, _
    writeToFileOptions As WriteToFileOptions _
)
C#
public void BuildFromDifferences(
    Differences differences,
    Difference onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    WriteToFileOptions writeToFileOptions
)
Visual C++
public:
void BuildFromDifferences(
    Differences^ differences,
    Difference^ onlyDifferenceToInclude,
    Options options,
    bool runOnTwo,
    WriteToFileOptions^ writeToFileOptions
)

Parameters

differences
Type: RedGate.SQLCompare.Engine..::.Differences
The differences to use.
onlyDifferenceToInclude
Type: RedGate.SQLCompare.Engine..::.Difference
The single difference to include.
options
Type: RedGate.SQLCompare.Engine..::.Options
The synchronization options.
runOnTwo
Type: System..::.Boolean
True if the SQL script is to be run on the second database.
writeToFileOptions
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.WriteToFileOptions
Options that sepcify how files are to be created when synchronizing to a scripts folder.

See Also

Work Class
BuildFromDifferences Overload


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
Work..::.CancelOperation Method
Work Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

Work Class


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
Work..::.ScriptObject Method
Work Class Example See Also

Returns the script necessary to create a SQL object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ScriptObject ( _
    objectToScript As IDatabaseObject, _
    options As Options _
) As Regions
C#
public Regions ScriptObject(
    IDatabaseObject objectToScript,
    Options options
)
Visual C++
public:
Regions^ ScriptObject(
    IDatabaseObject^ objectToScript,
    Options options
)

Parameters

objectToScript
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
options
Type: RedGate.SQLCompare.Engine..::.Options

Return Value

A Regions collection containing batches of SQL script.

Remarks

This creates SQL code used to create an object such as a table, view, or stored procedure.

Examples

C# Copy Code
            Database db=new Database();

            db.Register(new ConnectionProperties(".", "WidgetStaging"), Options.Default);

            Work work=new Work();

            //get the script for an object
            Regions regions=work.ScriptObject(db.Tables[0], Options.Default);

            Console.WriteLine("SQL script:\n{0}", regions.ToString());

            db.Dispose();
Visual Basic Copy Code
            Dim db As New Database()

            db.Register(New ConnectionProperties(".", "WidgetStaging"), Options.Default)

            Dim work As New Work()

            'get the script for an object

            Dim regions As Regions = work.ScriptObject(db.Tables(0), Options.Default)

            Console.WriteLine("SQL script:")
            Console.WriteLine("{0}", regions.ToString())

            'dispose
            db.Dispose()

See Also

Work Class


Work Properties

[image] [image]

SQL Data Compare API 7.1.0
Work Properties
Work Class See Also

The Work type exposes the following properties.

Properties

Name | Description
CanRollBackOnFailure | True if the transaction can be completely rolled back on failure.
ExecutionBlock | A block of SQL batches containing SQL script for synchronization.
Messages | Informational messages about the work to be done.
ScriptSynchronizationActions | The script synchronization actions that will be performed during the synchronization.
Status | The event handler for status events.
Warnings | Warnings about the work to be done.

See Also

Work Class


CanRollBackOnFailure Property

[image]

SQL Data Compare API 7.1.0
Work..::.CanRollBackOnFailure Property
Work Class See Also

True if the transaction can be completely rolled back on failure.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanRollBackOnFailure As Boolean
C#
public bool CanRollBackOnFailure { get; }
Visual C++
public:
property bool CanRollBackOnFailure {
    bool get ();
}

Remarks

Some synchronization commands, such as full-text operations, cannot be included within transactions. If a script fails, these operations cannot be rolled back.

See Also

Work Class


ExecutionBlock Property

[image]

SQL Data Compare API 7.1.0
Work..::.ExecutionBlock Property
Work Class See Also

A block of SQL batches containing SQL script for synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutionBlock As ExecutionBlock
C#
public ExecutionBlock ExecutionBlock { get; }
Visual C++
public:
property ExecutionBlock^ ExecutionBlock {
    ExecutionBlock^ get ();
}

See Also

Work Class


Messages Property

[image]

SQL Data Compare API 7.1.0
Work..::.Messages Property
Work Class See Also

Informational messages about the work to be done.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

Work Class


ScriptSynchronizationActions Property

[image]

SQL Data Compare API 7.1.0
Work..::.ScriptSynchronizationActions Property
Work Class See Also

The script synchronization actions that will be performed during the synchronization.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ScriptSynchronizationActions As ScriptSynchronizationActions
C#
public ScriptSynchronizationActions ScriptSynchronizationActions { get; set; }
Visual C++
public:
property ScriptSynchronizationActions^ ScriptSynchronizationActions {
    ScriptSynchronizationActions^ get ();
    void set (ScriptSynchronizationActions^ value);
}

See Also

Work Class


Status Property

[image]

SQL Data Compare API 7.1.0
Work..::.Status Property
Work Class See Also

The event handler for status events.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Work Class


Warnings Property

[image]

SQL Data Compare API 7.1.0
Work..::.Warnings Property
Work Class See Also

Warnings about the work to be done.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As Messages
C#
public Messages Warnings { get; }
Visual C++
public:
property Messages^ Warnings {
    Messages^ get ();
}

See Also

Work Class


XmlIndexType Enumeration

[image]

SQL Data Compare API 7.1.0
XmlIndexType Enumeration
See Also

The type of XML index.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlIndexType
C#
public enum XmlIndexType
Visual C++
public enum class XmlIndexType

Members

Member name | Description
None | None.
Value | Value.
Path | Path.
Property | Property.

See Also


XmlSchemaCollection Class

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection Class
Members See Also

An XML schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollection _
    Inherits SchemaObjectWithAuthorization _
    Implements IHasPermissions, IDatabaseObject
C#
public sealed class XmlSchemaCollection : SchemaObjectWithAuthorization, IHasPermissions,
    IDatabaseObject
Visual C++
public ref class XmlSchemaCollection sealed : public SchemaObjectWithAuthorization,
    IHasPermissions, IDatabaseObject

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.ScriptableDatabaseObject
RedGate.SQLCompare.Engine..::.SchemaObject
RedGate.SQLCompare.Engine..::.SchemaObjectWithAuthorization
RedGate.SQLCompare.Engine..::.XmlSchemaCollection

See Also

XmlSchemaCollection Members


XmlSchemaCollection Members

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollection Members
XmlSchemaCollection Class Methods Fields Properties See Also

The XmlSchemaCollection type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

Fields

Name | Description
m_CaseSensitive | (Inherited from ScriptableDatabaseObject.)
m_Database | (Inherited from ScriptableDatabaseObject.)
m_ExtendedProperties | (Inherited from SchemaObject.)
m_ID | (Inherited from ScriptableDatabaseObject.)
m_Name | (Inherited from ScriptableDatabaseObject.)
m_Owner | (Inherited from ScriptableDatabaseObject.)

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Contents | The raw schema data.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DependentFields | The dependent database columns.
DependentFunctions | The dependent functions.
DependentStoredProcedures | The dependent stored procedures.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.XmlSchemaCollection (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this xml schema collection.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)

See Also

XmlSchemaCollection Class


XmlSchemaCollection Methods

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollection Methods
XmlSchemaCollection Class See Also

The XmlSchemaCollection type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScriptObject | Scripts the object. (Overrides ScriptableDatabaseObject ..::. ScriptObject(SqlSetOptions, Options).)
ToString | Returns the fully-qualified name of the object prefixed with the object type. (Inherited from SchemaObject.)

See Also

XmlSchemaCollection Class


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.Equals Method
XmlSchemaCollection Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares the schema collection with a specified schema collection. (Overrides ScriptableDatabaseObject ..::. Equals(IDatabaseObject, Options).)

See Also

XmlSchemaCollection Class
XmlSchemaCollection Members


Equals Method (IDatabaseObject, Options)

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.Equals Method (IDatabaseObject, Options)
XmlSchemaCollection Class See Also

Compares the schema collection with a specified schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    targetObject As IDatabaseObject, _
    options As Options _
) As Boolean
C#
public override bool Equals(
    IDatabaseObject targetObject,
    Options options
)
Visual C++
public:
virtual bool Equals(
    IDatabaseObject^ targetObject,
    Options options
) override

Parameters

targetObject
Type: RedGate.SQLCompare.Engine..::.IDatabaseObject
The schema collection to compare.
options
Type: RedGate.SQLCompare.Engine..::.Options
Comparison options.

Return Value

True if the schema collections are identical; otherwise false.

Implements

IDatabaseObject..::.Equals(IDatabaseObject, Options)
IDatabaseObject..::.Equals(IDatabaseObject, Options)

See Also

XmlSchemaCollection Class
Equals Overload


ScriptObject Method

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.ScriptObject Method
XmlSchemaCollection Class See Also

Scripts the object.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ScriptObject ( _
    sqlSetOptions As SqlSetOptions, _
    options As Options _
) As Regions
C#
public override Regions ScriptObject(
    SqlSetOptions sqlSetOptions,
    Options options
)
Visual C++
public:
virtual Regions^ ScriptObject(
    SqlSetOptions^ sqlSetOptions,
    Options options
) override

Parameters

sqlSetOptions
Type: RedGate.SQLCompare.Engine..::.SqlSetOptions
SQL options (for example, quoted identifier on or off).
options
Type: RedGate.SQLCompare.Engine..::.Options
Scripting options.

Return Value

Regions that contain the script.

See Also

XmlSchemaCollection Class


XmlSchemaCollection Properties

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollection Properties
XmlSchemaCollection Class See Also

The XmlSchemaCollection type exposes the following properties.

Properties

Name | Description
Authorization | Returns the authorization owner of the object (as opposed to the schema; see Owner()()()). (Inherited from SchemaObjectWithAuthorization.)
Contents | The raw schema data.
Database | The database to which the object belongs. (Inherited from ScriptableDatabaseObject.)
DependentFields | The dependent database columns.
DependentFunctions | The dependent functions.
DependentStoredProcedures | The dependent stored procedures.
ExtendedProperties | The extended properties on the schema object. (Inherited from SchemaObject.)
FullyQualifiedName | The fully-qualified name of the object. (Inherited from SchemaObject.)
Name | The name of the object. (Inherited from ScriptableDatabaseObject.)
ObjectType | Returns ObjectType.XmlSchemaCollection (Overrides ScriptableDatabaseObject ..::. ObjectType.)
Owner | The owner or schema of the object. (Inherited from ScriptableDatabaseObject.)
Permissions | The permissions on this xml schema collection.
ScriptSource | The script source for this object, if the database source is set to scripts folder. (Inherited from ScriptableDatabaseObject.)
ScriptSourceAuthorization | The location of the creation script for the ALTER AUTHORIZATION statement for this object if the database source is set to scripts folder. (Inherited from SchemaObjectWithAuthorization.)

See Also

XmlSchemaCollection Class


Contents Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.Contents Property
XmlSchemaCollection Class See Also

The raw schema data.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contents As String
C#
public string Contents { get; }
Visual C++
public:
property String^ Contents {
    String^ get ();
}

See Also

XmlSchemaCollection Class


DependentFields Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.DependentFields Property
XmlSchemaCollection Class See Also

The dependent database columns.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentFields As List(Of Field)
C#
public List<Field> DependentFields { get; }
Visual C++
public:
property List<Field^>^ DependentFields {
    List<Field^>^ get ();
}

See Also

XmlSchemaCollection Class


DependentFunctions Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.DependentFunctions Property
XmlSchemaCollection Class See Also

The dependent functions.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentFunctions As Functions
C#
public Functions DependentFunctions { get; }
Visual C++
public:
property Functions^ DependentFunctions {
    Functions^ get ();
}

See Also

XmlSchemaCollection Class


DependentStoredProcedures Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.DependentStoredProcedures Property
XmlSchemaCollection Class See Also

The dependent stored procedures.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependentStoredProcedures As StoredProcedures
C#
public StoredProcedures DependentStoredProcedures { get; }
Visual C++
public:
property StoredProcedures^ DependentStoredProcedures {
    StoredProcedures^ get ();
}

See Also

XmlSchemaCollection Class


ObjectType Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.ObjectType Property
XmlSchemaCollection Class See Also

Returns ObjectType.XmlSchemaCollection

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ObjectType As ObjectType
C#
public override ObjectType ObjectType { get; }
Visual C++
public:
virtual property ObjectType ObjectType {
    ObjectType get () override;
}

Implements

IDatabaseObject..::.ObjectType
IDatabaseObject..::.ObjectType

See Also

XmlSchemaCollection Class


Permissions Property

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollection..::.Permissions Property
XmlSchemaCollection Class See Also

The permissions on this xml schema collection.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As Permissions
C#
public Permissions Permissions { get; internal set; }
Visual C++
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
    void set (Permissions^ value) sealed;
}

Implements

IHasPermissions..::.Permissions

See Also

XmlSchemaCollection Class


XmlSchemaCollections Class

[image]

SQL Data Compare API 7.1.0
XmlSchemaCollections Class
Members See Also

A collection of XML schema collections.

Namespace: RedGate.SQLCompare.Engine
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlSchemaCollections _
    Inherits SerializableDatabaseObjectCollection(Of XmlSchemaCollection)
C#
public sealed class XmlSchemaCollections : SerializableDatabaseObjectCollection<XmlSchemaCollection>
Visual C++
public ref class XmlSchemaCollections sealed : public SerializableDatabaseObjectCollection<XmlSchemaCollection^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.KeyedCollection <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.SerializableCollection <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.SerializableDatabaseObjectCollection <(Of <( XmlSchemaCollection >)>)
RedGate.SQLCompare.Engine..::.XmlSchemaCollections

See Also

XmlSchemaCollections Members


XmlSchemaCollections Members

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollections Members
XmlSchemaCollections Class Methods Properties Explicit Interface Implementations See Also

The XmlSchemaCollections type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns the list enumerator. (Inherited from KeyedCollection<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | For internal use. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | True if the keys are stored case-sensitively. (Inherited from KeyedCollection<(Of <(T>)>).)
Count | Returns the number of elements stored in the KeyedCollection<(Of <(T>)>). (Inherited from KeyedCollection<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

XmlSchemaCollections Class


RedGate.SQLCompare.Engine.ReadFromBackup Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.SQLCompare.Engine.ReadFromBackup Namespace

Classes

Class | Description
BackupDatabaseSource | Representation of a data source that takes its data from a backup of a database.
BackupSetDatabase | A SQL Server database represented by one or more backup sets.
SQLBackupReaderLoadException | SQLBackupReaderLoadException


BackupDatabaseSource Class

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Class
Members See Also

Representation of a data source that takes its data from a backup of a database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BackupDatabaseSource _
    Inherits DataSource
C#
public sealed class BackupDatabaseSource : DataSource
Visual C++
public ref class BackupDatabaseSource sealed : public DataSource

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupDatabaseSource

See Also

BackupDatabaseSource Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Members

[image] [image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Members
BackupDatabaseSource Class Constructors Methods Properties See Also

The BackupDatabaseSource type exposes the following members.

Constructors

Name | Description
BackupDatabaseSource | Overloaded.

Methods

Name | Description
Clone | Overridden. Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Overridden. Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackupSet | Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.
DatabaseName | Overridden. Gets the database name of the backup set. (Overrides DataSource ..::. DatabaseName.)
Files | The files that should be used as the source for the backup for this data source.
IsCaseSensitive | Whether the underlying database is case sensitive or not!
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.
IsWriteable | Overridden. The data source cannot be written to. This property always returns false. (Overrides DataSource ..::. IsWriteable.)
LastDatabaseName | Gets or sets the name of the database for the last backup set.
LastServerName | Gets or sets the name of the SQL Server for the last backup set.
Passwords | The SQL Backup passwords (one for each file) that are used to access the data source.
ServerName | Overridden. Gets the name of the SQL Server of the backup set. (Overrides DataSource ..::. ServerName.)
UseLatestBackupSet | internal storage value for the UI
Version | Overridden. Gets the current serialized version number of BackupDatabaseSource. (Overrides DataSource ..::. Version.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor

[image] [image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Constructor
BackupDatabaseSource Class See Also

Overload List

Name | Description
BackupDatabaseSource()()() | Constructs this object with an empty files list.
BackupDatabaseSource(IEnumerable<(Of <(String>)>), IEnumerable<(Of <(String>)>), IBackupSet) | Constructs this object using the specified files.

See Also

BackupDatabaseSource Class
BackupDatabaseSource Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Constructor
BackupDatabaseSource Class See Also

Constructs this object with an empty files list.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupDatabaseSource()
Visual C++
public:
BackupDatabaseSource()

See Also

BackupDatabaseSource Class
BackupDatabaseSource Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Constructor (IEnumerable(String), IEnumerable(String), IBackupSet)

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Constructor (IEnumerable<(Of <(String>)>), IEnumerable<(Of <(String>)>), IBackupSet)
BackupDatabaseSource Class See Also

Constructs this object using the specified files.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    files As IEnumerable(Of String), _
    passwords As IEnumerable(Of String), _
    backupSet As IBackupSet _
)
C#
public BackupDatabaseSource(
    IEnumerable<string> files,
    IEnumerable<string> passwords,
    IBackupSet backupSet
)
Visual C++
public:
BackupDatabaseSource(
    IEnumerable<String^>^ files,
    IEnumerable<String^>^ passwords,
    IBackupSet^ backupSet
)

Parameters

files
Type: System.Collections.Generic..::.IEnumerable <(Of <( String >)>)
The files from which to construct this data source
passwords
Type: System.Collections.Generic..::.IEnumerable <(Of <( String >)>)
The SQL Backup passwords (one for each file) that are used to access the data source
backupSet
Type: RedGate.Shared.SQL.BackupReaderInterfaces..::.IBackupSet
The backup set with which to construct this data source

See Also

BackupDatabaseSource Class
BackupDatabaseSource Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Methods
BackupDatabaseSource Class See Also

The BackupDatabaseSource type exposes the following methods.

Methods

Name | Description
Clone | Overridden. Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDifferentSource | Overridden. Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Serialize | Serializes this data source. Note that the database information settings are serialized along with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToConnectionProperties |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Clone Method
BackupDatabaseSource Class See Also

Overridden. Clones the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Return Value

Implements

IDataSource..::.Clone()()()

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Deserialize Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Deserialize Method
BackupDatabaseSource Class See Also

Deserializes this data source. Note that the database information settings are serialized along with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: System..::.Int32
formatter
Type: ISerializeFormatter

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.IsDifferentSource Method
BackupDatabaseSource Class See Also

Overridden. Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.IsPasswordRequired Method
BackupDatabaseSource Class See Also

Returns true if the backup files need a password to be read, false otherwise.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsPasswordRequired ( _
    filePaths As IList(Of String) _
) As Boolean
C#
public static bool IsPasswordRequired(
    IList<string> filePaths
)
Visual C++
public:
static bool IsPasswordRequired(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
A list of the files to open

Return Value

true if the backup files need a password to be read, false otherwise

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Serialize Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Serialize Method
BackupDatabaseSource Class See Also

Serializes this data source. Note that the database information settings are serialized along with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


ToConnectionProperties Method

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.ToConnectionProperties Method
BackupDatabaseSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ToConnectionProperties As ConnectionProperties
C#
public ConnectionProperties ToConnectionProperties()
Visual C++
public:
ConnectionProperties^ ToConnectionProperties()

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupDatabaseSource Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupDatabaseSource Properties
BackupDatabaseSource Class See Also

The BackupDatabaseSource type exposes the following properties.

Properties

Name | Description
BackupSet | Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.
DatabaseName | Overridden. Gets the database name of the backup set. (Overrides DataSource ..::. DatabaseName.)
Files | The files that should be used as the source for the backup for this data source.
IsCaseSensitive | Whether the underlying database is case sensitive or not!
IsValid | True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.
IsWriteable | Overridden. The data source cannot be written to. This property always returns false. (Overrides DataSource ..::. IsWriteable.)
LastDatabaseName | Gets or sets the name of the database for the last backup set.
LastServerName | Gets or sets the name of the SQL Server for the last backup set.
Passwords | The SQL Backup passwords (one for each file) that are used to access the data source.
ServerName | Overridden. Gets the name of the SQL Server of the backup set. (Overrides DataSource ..::. ServerName.)
UseLatestBackupSet | internal storage value for the UI
Version | Overridden. Gets the current serialized version number of BackupDatabaseSource. (Overrides DataSource ..::. Version.)

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSet Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.BackupSet Property
BackupDatabaseSource Class See Also

Gets or sets the BackupSet to be used in the backup file. If this is null the latest backup set will be used.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupSet As IBackupSet
C#
public IBackupSet BackupSet { get; set; }
Visual C++
public:
property IBackupSet^ BackupSet {
    IBackupSet^ get ();
    void set (IBackupSet^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.DatabaseName Property
BackupDatabaseSource Class See Also

Overridden. Gets the database name of the backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Files Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Files Property
BackupDatabaseSource Class See Also

The files that should be used as the source for the backup for this data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As List(Of String)
C#
public List<string> Files { get; set; }
Visual C++
public:
property List<String^>^ Files {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsCaseSensitive Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.IsCaseSensitive Property
BackupDatabaseSource Class See Also

Whether the underlying database is case sensitive or not!

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCaseSensitive As Boolean
C#
public bool IsCaseSensitive { get; }
Visual C++
public:
property bool IsCaseSensitive {
    bool get ();
}

Return Value

true if case-sensitive, false otherwise

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsValid Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.IsValid Property
BackupDatabaseSource Class See Also

True if this snapshot represents a valid data source that can be used in comparison. If false, then there is a problem with the snapshot file - for example, it could not be found or is in the wrong format.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid { get; }
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.IsWriteable Property
BackupDatabaseSource Class See Also

Overridden. The data source cannot be written to. This property always returns false.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


LastDatabaseName Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.LastDatabaseName Property
BackupDatabaseSource Class See Also

Gets or sets the name of the database for the last backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastDatabaseName As String
C#
public string LastDatabaseName { get; set; }
Visual C++
public:
property String^ LastDatabaseName {
    String^ get ();
    void set (String^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


LastServerName Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.LastServerName Property
BackupDatabaseSource Class See Also

Gets or sets the name of the SQL Server for the last backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastServerName As String
C#
public string LastServerName { get; set; }
Visual C++
public:
property String^ LastServerName {
    String^ get ();
    void set (String^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Passwords Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Passwords Property
BackupDatabaseSource Class See Also

The SQL Backup passwords (one for each file) that are used to access the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Passwords As List(Of String)
C#
public List<string> Passwords { get; set; }
Visual C++
public:
property List<String^>^ Passwords {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.ServerName Property
BackupDatabaseSource Class See Also

Overridden. Gets the name of the SQL Server of the backup set.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


UseLatestBackupSet Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.UseLatestBackupSet Property
BackupDatabaseSource Class See Also

internal storage value for the UI

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UseLatestBackupSet As Boolean
C#
public bool UseLatestBackupSet { get; set; }
Visual C++
public:
property bool UseLatestBackupSet {
    bool get ();
    void set (bool value);
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
BackupDatabaseSource..::.Version Property
BackupDatabaseSource Class See Also

Overridden. Gets the current serialized version number of BackupDatabaseSource.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

BackupDatabaseSource Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Class

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase Class
Members See Also

A SQL Server database represented by one or more backup sets.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class BackupSetDatabase _
    Inherits Database
C#
public class BackupSetDatabase : Database
Visual C++
public ref class BackupSetDatabase : public Database

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLCompare.Engine..::.Database
RedGate.SQLCompare.Engine.ReadFromBackup..::.BackupSetDatabase

See Also

BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Members

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase Members
BackupSetDatabase Class Constructors Methods Properties See Also

The BackupSetDatabase type exposes the following members.

Constructors

Name | Description
BackupSetDatabase |

Methods

Name | Description
CancelOperation | Cancels the current operation. (Overrides Database ..::.CancelOperation()()().)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from Database.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBackupSets | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
LoadFromDisk | Loads the database from disk. (Inherited from Database.)
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from Database.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
SaveToDisk | Saves the database to disk. (Inherited from Database.)
SaveToFolder | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from Database.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from Database.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the database registration has been canceled. (Inherited from Database.)
CaseSensitive | Indicates whether the database has been set up as case sensitive. (Inherited from Database.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from Database.)
Collation | The collation of the database. (Inherited from Database.)
ConnectionProperties | The connection properties for the database. (Inherited from Database.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from Database.)
DateScripted | The date the database object was created. (Inherited from Database.)
DdlTriggers | The DDL triggers in the database. (Inherited from Database.)
Defaults | The defaults in the database. (Inherited from Database.)
EncryptionAlgorithm | The transparent database encryption algorithm set for the database. (Inherited from Database.)
EncryptionEnabled | Whether database encryption is enabled for this database. (Inherited from Database.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from Database.)
ExtendedProperties | Database-level extended properties. (Inherited from Database.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from Database.)
FullTextEnabled | True if the database has full text enabled. (Inherited from Database.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from Database.)
Functions | The user-defined functions in the database. (Inherited from Database.)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from Database.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from Database.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from Database.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from Database.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from Database.)
Roles | The roles in the database. (Inherited from Database.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from Database.)
Rules | The rules in the database. (Inherited from Database.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from Database.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the database is running in a compatibility mode. (Inherited from Database.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from Database.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from Database.)
Status | Used to provide status events. (Inherited from Database.)
StoredProcedures | The stored procedures in the database. (Inherited from Database.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from Database.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from Database.)
Tables | The tables in the database. (Inherited from Database.)
UserDefinedTypes | The user-defined types in the database. (Inherited from Database.)
Users | The users in the database. (Inherited from Database.)
Views | The views in the database. (Inherited from Database.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from Database.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Constructor

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase Constructor
BackupSetDatabase Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BackupSetDatabase()
Visual C++
public:
BackupSetDatabase()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Methods

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase Methods
BackupSetDatabase Class See Also

The BackupSetDatabase type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation. (Overrides Database ..::.CancelOperation()()().)
Close | Closes the connection to the backup database.
CompareWith | Overloaded.
CreateEmptyTarget | For internal use only (Inherited from Database.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetBackupSets | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsPasswordRequired | Returns true if the backup files need a password to be read, false otherwise.
LoadFromDisk | Loads the database from disk. (Inherited from Database.)
LoadFromStream | Loads the database from a stream. This is an alternative to the LoadFromDisk method. (Inherited from Database.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Overloaded.
RegisterForDataCompare | Overloaded.
SaveToDisk | Saves the database to disk. (Inherited from Database.)
SaveToFolder | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.CancelOperation Method
BackupSetDatabase Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelOperation
C#
public override void CancelOperation()
Visual C++
public:
virtual void CancelOperation() override

Implements

ICancellable..::.CancelOperation()()()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Close Method

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.Close Method
BackupSetDatabase Class See Also

Closes the connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


CompareWith Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.CompareWith Method
BackupSetDatabase Class See Also

Overload List

Name | Description
CompareWith(Database, Options) | Compares the database with another database. (Inherited from Database.)
CompareWith(Database, Options, SqlCompareOwnerMappings) | Compares the database with another database. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.Dispose Method
BackupSetDatabase Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Disposes of the object. (Overrides Database ..::. Dispose(Boolean).)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.Dispose Method (Boolean)
BackupSetDatabase Class See Also

Disposes of the object.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

Remarks

It is important to dispose of the object to delete any temporary files it uses.

See Also

BackupSetDatabase Class
Dispose Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.GetBackupSets Method
BackupSetDatabase Class See Also

Overload List

Name | Description
GetBackupSets(IList<(Of <(String>)>)) | Retreives a list of backup sets from the given backup files. This operation is ICancellable.
GetBackupSets(IList<(Of <(String>)>), IList<(Of <(String>)>)) | Retreives a list of backup sets from the given backup files. This operation is ICancellable.

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method (IList(String))

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.GetBackupSets Method (IList<(Of <(String>)>))
BackupSetDatabase Class See Also

Retreives a list of backup sets from the given backup files. This operation is ICancellable.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets ( _
    filePaths As IList(Of String) _
) As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets(
    IList<string> filePaths
)
Visual C++
public:
IList<IBackupSet^>^ GetBackupSets(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
A list of the files to open.

Return Value

A list of the available backup sets in the given files.

See Also

BackupSetDatabase Class
GetBackupSets Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


GetBackupSets Method (IList(String), IList(String))

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.GetBackupSets Method (IList<(Of <(String>)>), IList<(Of <(String>)>))
BackupSetDatabase Class See Also

Retreives a list of backup sets from the given backup files. This operation is ICancellable.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBackupSets ( _
    filePaths As IList(Of String), _
    passwords As IList(Of String) _
) As IList(Of IBackupSet)
C#
public IList<IBackupSet> GetBackupSets(
    IList<string> filePaths,
    IList<string> passwords
)
Visual C++
public:
IList<IBackupSet^>^ GetBackupSets(
    IList<String^>^ filePaths,
    IList<String^>^ passwords
)

Parameters

filePaths
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
A list of the files to open.
passwords
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
A list of passwords for the files if this is an encrypted SQL Backup, String.Empty if password not needed for that file.

Return Value

A list of the available backup sets in the given files.

See Also

BackupSetDatabase Class
GetBackupSets Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


IsPasswordRequired Method

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.IsPasswordRequired Method
BackupSetDatabase Class See Also

Returns true if the backup files need a password to be read, false otherwise.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsPasswordRequired ( _
    filePaths As IList(Of String) _
) As Boolean
C#
public static bool IsPasswordRequired(
    IList<string> filePaths
)
Visual C++
public:
static bool IsPasswordRequired(
    IList<String^>^ filePaths
)

Parameters

filePaths
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
A list of the files to open.

Return Value

true if the backup files need a password to be read, false otherwise.

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


Register Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.Register Method
BackupSetDatabase Class See Also

Overload List

Name | Description
Register(ConnectionProperties, Options) | Registers a database. (Inherited from Database.)
Register(String, ReadFromScriptDatabaseInformation, Options) | Registers the database from creation scripts that are stored in the folder specified by the path parameter. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RegisterForDataCompare Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.RegisterForDataCompare Method
BackupSetDatabase Class See Also

Overload List

Name | Description
RegisterForDataCompare(ConnectionProperties) | Registers a database for SQL Data Compare. (Inherited from Database.)
RegisterForDataCompare(ConnectionProperties, Options) | Registers a database for SQL Data Compare. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SaveToFolder Method

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.SaveToFolder Method
BackupSetDatabase Class See Also

Overload List

Name | Description
SaveToFolder(String) | Obsolete. Saves the database as a set of creation scripts to the specified folder. (Inherited from Database.)
SaveToFolder(String, WriteToFileOptions) | Saves the database as a set of creation scripts to the specified folder. (Inherited from Database.)

See Also

BackupSetDatabase Class
BackupSetDatabase Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupSetDatabase Properties

[image] [image]

SQL Data Compare API 7.1.0
BackupSetDatabase Properties
BackupSetDatabase Class See Also

The BackupSetDatabase type exposes the following properties.

Properties

Name | Description
Assemblies | The CLR assemblies in the database. Note that CLR assemblies were introduced in SQL Server 2005. (Inherited from Database.)
AsymmetricKeys | The asymmetric keys in the database. Note that asymmetric keys were introduced in SQL Server 2005. (Inherited from Database.)
BackupConnection | After registering a database this will contain the active connection to the backup database.
Cancel | Indicates whether the database registration has been canceled. (Inherited from Database.)
CaseSensitive | Indicates whether the database has been set up as case sensitive. (Inherited from Database.)
Certificates | The certificates in the database. Note that certificates were introduced in SQL Server 2005. (Inherited from Database.)
Collation | The collation of the database. (Inherited from Database.)
ConnectionProperties | The connection properties for the database. (Inherited from Database.)
Contracts | The contracts in the database. Note that contracts were introduced in SQL Server 2005. (Inherited from Database.)
DateScripted | The date the database object was created. (Inherited from Database.)
DdlTriggers | The DDL triggers in the database. (Inherited from Database.)
Defaults | The defaults in the database. (Inherited from Database.)
EncryptionAlgorithm | The transparent database encryption algorithm set for the database. (Inherited from Database.)
EncryptionEnabled | Whether database encryption is enabled for this database. (Inherited from Database.)
EventNotifications | The database-level event notifications in the database. Note that event notifications were introduced in SQL Server 2005. (Inherited from Database.)
ExtendedProperties | Database-level extended properties. (Inherited from Database.)
FullTextCatalogs | The full-text catalogs in the database. (Inherited from Database.)
FullTextEnabled | True if the database has full text enabled. (Inherited from Database.)
FullTextStoplists | The full-text stoplists in the database. (Inherited from Database.)
Functions | The user-defined functions in the database. (Inherited from Database.)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
MajorVersion | The major version of the SQL Server for the database. This reflects the compatibility mode of the database. (Inherited from Database.)
MessageTypes | The message types in the database. Note that message types were introduced in SQL Server 2005. (Inherited from Database.)
PartitionFunctions | The partition functions in the database. Note that partition functions were introduced in SQL Server 2005. (Inherited from Database.)
PartitionSchemes | The partition schemes in the database. Note that partitions schemes were introduced in SQL Server 2005. (Inherited from Database.)
Queues | The queues in the database. Note that queues were introduced in SQL Server 2005. (Inherited from Database.)
Roles | The roles in the database. (Inherited from Database.)
Routes | The routes in the database. Note that routes were introduced in SQL Server 2005. (Inherited from Database.)
Rules | The rules in the database. (Inherited from Database.)
Schemas | The schemas in the database. Note that schemas were introduced in SQL Server 2005. (Inherited from Database.)
ServerMajorVersion | The major server version of the SQL Server for the database. This may be different from the MajorVersion property if the database is running in a compatibility mode. (Inherited from Database.)
ServiceBindings | The service bindings in the database. Note that service bindings were introduced in SQL Server 2005. (Inherited from Database.)
Services | The services in the database. Note that services were introduced in SQL Server 2005. (Inherited from Database.)
Status | Used to provide status events. (Inherited from Database.)
StoredProcedures | The stored procedures in the database. (Inherited from Database.)
SymmetricKeys | The symmetric keys in the database. Note that symmetric keys were introduced in SQL Server 2005. (Inherited from Database.)
Synonyms | The synonyms in the database. Note that synonyms were introduced in SQL Server 2005. (Inherited from Database.)
Tables | The tables in the database. (Inherited from Database.)
UserDefinedTypes | The user-defined types in the database. (Inherited from Database.)
Users | The users in the database. (Inherited from Database.)
Views | The views in the database. (Inherited from Database.)
XmlSchemaCollections | The XML schema collections in the database. Note that XML schema collections were introduced in SQL Server 2005. (Inherited from Database.)

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


BackupConnection Property

[image]

SQL Data Compare API 7.1.0
BackupSetDatabase..::.BackupConnection Property
BackupSetDatabase Class See Also

After registering a database this will contain the active connection to the backup database.

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackupConnection As IBackupConnection
C#
public IBackupConnection BackupConnection { get; }
Visual C++
public:
property IBackupConnection^ BackupConnection {
    IBackupConnection^ get ();
}

See Also

BackupSetDatabase Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Class

[image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Class
Members See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SQLBackupReaderLoadException _
    Inherits Exception
C#
public class SQLBackupReaderLoadException : Exception
Visual C++
public ref class SQLBackupReaderLoadException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLCompare.Engine.ReadFromBackup..::.SQLBackupReaderLoadException

See Also

SQLBackupReaderLoadException Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Members

[image] [image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Members
SQLBackupReaderLoadException Class Constructors Methods Properties See Also

The SQLBackupReaderLoadException type exposes the following members.

Constructors

Name | Description
SQLBackupReaderLoadException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SQLBackupReaderLoadException Class
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Constructor
SQLBackupReaderLoadException Class See Also

Overload List

Name | Description
SQLBackupReaderLoadException()()() | SQLBackupReaderLoadException
SQLBackupReaderLoadException(String) | SQLBackupReaderLoadException
SQLBackupReaderLoadException(String, Exception) | SQLBackupReaderLoadException

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Members
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor

[image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Constructor
SQLBackupReaderLoadException Class See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SQLBackupReaderLoadException()
Visual C++
public:
SQLBackupReaderLoadException()

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Constructor (String)
SQLBackupReaderLoadException Class See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SQLBackupReaderLoadException(
    string message
)
Visual C++
public:
SQLBackupReaderLoadException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


SQLBackupReaderLoadException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
SQLBackupReaderLoadException Constructor (String, Exception)
SQLBackupReaderLoadException Class See Also

SQLBackupReaderLoadException

Namespace: RedGate.SQLCompare.Engine.ReadFromBackup
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    exception As Exception _
)
C#
public SQLBackupReaderLoadException(
    string message,
    Exception exception
)
Visual C++
public:
SQLBackupReaderLoadException(
    String^ message,
    Exception^ exception
)

Parameters

message
Type: System..::.String
exception
Type: System..::.Exception

See Also

SQLBackupReaderLoadException Class
SQLBackupReaderLoadException Overload
RedGate.SQLCompare.Engine.ReadFromBackup Namespace


RedGate.SQLCompare.Engine.ReadFromFolder Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.SQLCompare.Engine.ReadFromFolder Namespace

Classes

Class | Description
FolderDataSource | Representation of a data source that will take its data from a series of scripts in a folder.
ReadFromScriptDatabaseInformation | Options and settings that control how the creation SQL files are loaded and processed.
ScriptSource | Information about the source of a database object. This information includes details of the creation script file, as well as the starting and ending character position for the creation statement.
ScriptSynchronizationAction | A synchronization action that is used when a file needs to be created or altered during synchronizing to a scripts folder.
ScriptSynchronizationActionCreateObject | A synchronization action that creates a new file for a database object.
ScriptSynchronizationActionDBInfo | A synchronization action that is used to modify database settings during synchronizing to a scripts folder.
ScriptSynchronizationActionRewrite | A synchronization action that modifies a creation SQL file.
ScriptSynchronizationActions | The synchronization actions that need to be executed during synchronizing to a scripts folder.
WriteToFileOptions | Options that control how script files are written to a scripts folder.

Enumerations

Enumeration | Description
FolderInformationErrors | A set of flags indicating warnings and errors that can occur while setting up a read from folder data source


FolderDataSource Class

[image]

SQL Data Compare API 7.1.0
FolderDataSource Class
Members See Also

Representation of a data source that will take its data from a series of scripts in a folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FolderDataSource _
    Inherits DataSource
C#
public sealed class FolderDataSource : DataSource
Visual C++
public ref class FolderDataSource sealed : public DataSource

Inheritance Hierarchy

System..::.Object
RedGate.Shared.SQL..::.DataSource
RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderDataSource

See Also

FolderDataSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Members

[image] [image]

SQL Data Compare API 7.1.0
FolderDataSource Members
FolderDataSource Class Constructors Methods Properties See Also

The FolderDataSource type exposes the following members.

Constructors

Name | Description
FolderDataSource | Overloaded.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInformationFromXmlFile | Given a TextReader for an XML file, returns a database information object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlFromInformation | Given a database information object, returns an XML file that represents it.
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromPath | Refreshes the database information for this folder, and sets the Errors property.
Serialize | Serializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DatabaseInformation | Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.
DatabaseName | Gets or sets the name of the SQL Server database. (Overrides DataSource ..::. DatabaseName.)
Errors | Returns the errors that occurred last time the database metadata for this data source was loaded.
GetLatestVersion |
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
Path | The path for the folder to be used as the source for the scripts making up this data source.
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor

[image] [image]

SQL Data Compare API 7.1.0
FolderDataSource Constructor
FolderDataSource Class See Also

Overload List

Name | Description
FolderDataSource()()() | Constructs this object with an empty path for the folder.
FolderDataSource(String) | Constructs this object using the specified folder. If a SqlCompareDatabaseInfo.xml file exists in the specified directory, then this will be parsed to fill in the values in the Information object.
FolderDataSource(ReadFromScriptDatabaseInformation) | Constructs this object with an empty path for the folder and specific settings for the folder information.
FolderDataSource(String, ReadFromScriptDatabaseInformation) | Constructs a data source that will read from a specific folder, and optionally override the server information.

See Also

FolderDataSource Class
FolderDataSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor

[image]

SQL Data Compare API 7.1.0
FolderDataSource Constructor
FolderDataSource Class See Also

Constructs this object with an empty path for the folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FolderDataSource()
Visual C++
public:
FolderDataSource()

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor (String)

[image]

SQL Data Compare API 7.1.0
FolderDataSource Constructor (String)
FolderDataSource Class See Also

Constructs this object using the specified folder. If a SqlCompareDatabaseInfo.xml file exists in the specified directory, then this will be parsed to fill in the values in the Information object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    folder As String _
)
C#
public FolderDataSource(
    string folder
)
Visual C++
public:
FolderDataSource(
    String^ folder
)

Parameters

folder
Type: System..::.String
The folder to construct this datasource from

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor (ReadFromScriptDatabaseInformation)

[image]

SQL Data Compare API 7.1.0
FolderDataSource Constructor (ReadFromScriptDatabaseInformation)
FolderDataSource Class See Also

Constructs this object with an empty path for the folder and specific settings for the folder information.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    information As ReadFromScriptDatabaseInformation _
)
C#
public FolderDataSource(
    ReadFromScriptDatabaseInformation information
)
Visual C++
public:
FolderDataSource(
    ReadFromScriptDatabaseInformation^ information
)

Parameters

information
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation
The database information. This should not be null.

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Constructor (String, ReadFromScriptDatabaseInformation)

[image]

SQL Data Compare API 7.1.0
FolderDataSource Constructor (String, ReadFromScriptDatabaseInformation)
FolderDataSource Class See Also

Constructs a data source that will read from a specific folder, and optionally override the server information.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    folder As String, _
    information As ReadFromScriptDatabaseInformation _
)
C#
public FolderDataSource(
    string folder,
    ReadFromScriptDatabaseInformation information
)
Visual C++
public:
FolderDataSource(
    String^ folder,
    ReadFromScriptDatabaseInformation^ information
)

Parameters

folder
Type: System..::.String
The folder to read scripts from
information
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation
The database information. If null, then the script directory will be checked for a settings XML file.

See Also

FolderDataSource Class
FolderDataSource Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Methods

[image] [image]

SQL Data Compare API 7.1.0
FolderDataSource Methods
FolderDataSource Class See Also

The FolderDataSource type exposes the following methods.

Methods

Name | Description
Clone | Clones the data source. (Overrides DataSource ..::. Clone()()().)
Deserialize | Deserializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Deserialize(Int32, ISerializeFormatter).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInformationFromXmlFile | Given a TextReader for an XML file, returns a database information object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlFromInformation | Given a database information object, returns an XML file that represents it.
IsDifferentSource | Compares the data source with a specified data source. (Overrides DataSource ..::.IsDifferentSource(IDataSource).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromPath | Refreshes the database information for this folder, and sets the Errors property.
Serialize | Serializes this data source. Note that the database information settings are serialized with the data source. (Overrides DataSource ..::. Serialize(ISerializeFormatter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Clone Method
FolderDataSource Class See Also

Clones the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As IDataSource
C#
public override IDataSource Clone()
Visual C++
public:
virtual IDataSource^ Clone() override

Implements

IDataSource..::.Clone()()()

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Deserialize Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Deserialize Method
FolderDataSource Class See Also

Deserializes this data source. Note that the database information settings are serialized with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Deserialize ( _
    versionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public override bool Deserialize(
    int versionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int versionId,
    ISerializeFormatter^ formatter
) override

Parameters

versionId
Type: System..::.Int32
formatter
Type: ISerializeFormatter

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetInformationFromXmlFile Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.GetInformationFromXmlFile Method
FolderDataSource Class See Also

Given a TextReader for an XML file, returns a database information object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetInformationFromXmlFile ( _
    file As TextReader, _
    <OutAttribute> ByRef errors As FolderInformationErrors _
) As ReadFromScriptDatabaseInformation
C#
public static ReadFromScriptDatabaseInformation GetInformationFromXmlFile(
    TextReader file,
    out FolderInformationErrors errors
)
Visual C++
public:
static ReadFromScriptDatabaseInformation^ GetInformationFromXmlFile(
    TextReader^ file,
    [OutAttribute] FolderInformationErrors% errors
)

Parameters

file
Type: System.IO..::.TextReader
A TextReader for an XML file representing database metadata.
errors
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.FolderInformationErrors %
Changed on output to indicate any errors or warnings that might have occurred while the file was loaded.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetXmlFromInformation Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.GetXmlFromInformation Method
FolderDataSource Class See Also

Given a database information object, returns an XML file that represents it.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetXmlFromInformation ( _
    info As ReadFromScriptDatabaseInformation _
) As String
C#
public static string GetXmlFromInformation(
    ReadFromScriptDatabaseInformation info
)
Visual C++
public:
static String^ GetXmlFromInformation(
    ReadFromScriptDatabaseInformation^ info
)

Parameters

info
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation
The database information object.

Return Value

An XML file that represents the database information object.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsDifferentSource Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.IsDifferentSource Method
FolderDataSource Class See Also

Compares the data source with a specified data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDifferentSource ( _
    newDataSource As IDataSource _
) As Boolean
C#
public override bool IsDifferentSource(
    IDataSource newDataSource
)
Visual C++
public:
virtual bool IsDifferentSource(
    IDataSource^ newDataSource
) override

Parameters

newDataSource
Type: RedGate.Shared.SQL..::.IDataSource
The data source to compare.

Return Value

true if the data sources are different.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


RefreshFromPath Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.RefreshFromPath Method
FolderDataSource Class See Also

Refreshes the database information for this folder, and sets the Errors property.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshFromPath
C#
public void RefreshFromPath()
Visual C++
public:
void RefreshFromPath()

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Serialize Method

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Serialize Method
FolderDataSource Class See Also

Serializes this data source. Note that the database information settings are serialized with the data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public override void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) override

Parameters

formatter
Type: ISerializeFormatter

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderDataSource Properties

[image] [image]

SQL Data Compare API 7.1.0
FolderDataSource Properties
FolderDataSource Class See Also

The FolderDataSource type exposes the following properties.

Properties

Name | Description
DatabaseInformation | Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.
DatabaseName | Gets or sets the name of the SQL Server database. (Overrides DataSource ..::. DatabaseName.)
Errors | Returns the errors that occurred last time the database metadata for this data source was loaded.
GetLatestVersion |
IsWriteable | The data source can be written to. (Overrides DataSource ..::. IsWriteable.)
Path | The path for the folder to be used as the source for the scripts making up this data source.
ServerName | Gets or sets the name of the SQL Server. (Overrides DataSource ..::. ServerName.)
Version | Gets the current serialized version number of the snapshot. (Overrides DataSource ..::. Version.)

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseInformation Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.DatabaseInformation Property
FolderDataSource Class See Also

Extra information that would normally be stored in the database that needs to be retrieved from an alternative source. The preferred method is the SqlCompareDatabaseInfo.xml script stored in the folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabaseInformation As ReadFromScriptDatabaseInformation
C#
public ReadFromScriptDatabaseInformation DatabaseInformation { get; set; }
Visual C++
public:
property ReadFromScriptDatabaseInformation^ DatabaseInformation {
    ReadFromScriptDatabaseInformation^ get ();
    void set (ReadFromScriptDatabaseInformation^ value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseName Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.DatabaseName Property
FolderDataSource Class See Also

Gets or sets the name of the SQL Server database.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property DatabaseName As String
C#
public override string DatabaseName { get; set; }
Visual C++
public:
virtual property String^ DatabaseName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.DatabaseName

Remarks

Scripts folders are not associated with any SQL Server, so this value is not meaningful. By default it is derived from the path name.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Errors Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Errors Property
FolderDataSource Class See Also

Returns the errors that occurred last time the database metadata for this data source was loaded.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Errors As FolderInformationErrors
C#
public FolderInformationErrors Errors { get; set; }
Visual C++
public:
property FolderInformationErrors Errors {
    FolderInformationErrors get ();
    void set (FolderInformationErrors value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetLatestVersion Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.GetLatestVersion Property
FolderDataSource Class See Also

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property GetLatestVersion As Boolean
C#
public bool GetLatestVersion { get; set; }
Visual C++
public:
property bool GetLatestVersion {
    bool get ();
    void set (bool value);
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


IsWriteable Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.IsWriteable Property
FolderDataSource Class See Also

The data source can be written to.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsWriteable As Boolean
C#
public override bool IsWriteable { get; }
Visual C++
public:
virtual property bool IsWriteable {
    bool get () override;
}

Implements

IDataSource..::.IsWriteable

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Path Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Path Property
FolderDataSource Class See Also

The path for the folder to be used as the source for the scripts making up this data source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Remarks

Call RefreshFromPath after setting this value in order to cause this object to update itself with information from the specified path. Refreshing can be a lengthy process if the path refers to a network location.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ServerName Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.ServerName Property
FolderDataSource Class See Also

Gets or sets the name of the SQL Server.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ServerName As String
C#
public override string ServerName { get; set; }
Visual C++
public:
virtual property String^ ServerName {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDataSource..::.ServerName

Remarks

Scripts folders are not associated with any SQL Server, so this value is not meaningful. By default it is 'Scripts', but it can be changed.

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
FolderDataSource..::.Version Property
FolderDataSource Class See Also

Gets the current serialized version number of the snapshot.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Version As Integer
C#
public override int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () override;
}

See Also

FolderDataSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FolderInformationErrors Enumeration

[image]

SQL Data Compare API 7.1.0
FolderInformationErrors Enumeration
See Also

A set of flags indicating warnings and errors that can occur while setting up a read from folder data source

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration FolderInformationErrors
C#
[FlagsAttribute]
public enum FolderInformationErrors
Visual C++
[FlagsAttribute]
public enum class FolderInformationErrors

Members

Member name | Description
OK | Indicates that there are no errors or warnings
Error | Mask of all the possible errors that can occur
PathNotFound | Indicates that the path to the folder could not be found, so the database information file could not be loaded
Unauthorized | Indicates that an unauthorized access exception occurred while trying to load the information file
NotSupported | Indicates that a NotSupportedException occurred while trying to load the information file
IOException | Indicates that an IOException occurred while trying to load the information file
NeedsRefresh | Indicates that RefreshFromPath() needs to be called on this object to make it valid
Warnings | Mask of all the possible warnings that can occur
UnsupportedSqlServerVersion | Indicates that the database information file sets an unsupported SQL server version (so we picked SQL Server 2000 arbitrarily)
DatabaseInformationBadFormat | Indicates that the database information file has a bad format (not XML or malformed XML), so we're using the defaults
DatabaseInformationNotFound | Minor warning: no database information file was found, so we're using the defaults
DatabaseInformationPartialFile | Minor warning: the file was found and loaded, but some settings were missing so the defaults were chosen instead.

Remarks

Note that these flags include both errors and warnings. In order to check only for errors, perform a logical AND with the Error mask.

See Also

RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromScriptDatabaseInformation Class

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation Class
Members See Also

Options and settings that control how the creation SQL files are loaded and processed.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReadFromScriptDatabaseInformation _
    Implements IEquatable(Of ReadFromScriptDatabaseInformation)
C#
public sealed class ReadFromScriptDatabaseInformation : IEquatable<ReadFromScriptDatabaseInformation>
Visual C++
public ref class ReadFromScriptDatabaseInformation sealed : IEquatable<ReadFromScriptDatabaseInformation^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation

See Also

ReadFromScriptDatabaseInformation Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromScriptDatabaseInformation Members

[image] [image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation Members
ReadFromScriptDatabaseInformation Class Constructors Methods Properties See Also

The ReadFromScriptDatabaseInformation type exposes the following members.

Constructors

Name | Description
ReadFromScriptDatabaseInformation | Constructs a new ReadFromScriptDatabaseInformation object. By default it initializes itself with values that represent a SQL Server 2005 database with Latin1_General_CS_AS collation.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CaseSensitive | Indicates whether the database is case sensitive.
DefaultCollation | The default collation for this database.
DefaultFilegroup | Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.
DefaultOwner | Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.
DefaultUser | Sets or gets the default user that should be used for AUTHORIZATION clauses.
SQLServerDBVersion | Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromScriptDatabaseInformation Constructor

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation Constructor
ReadFromScriptDatabaseInformation Class See Also

Constructs a new ReadFromScriptDatabaseInformation object. By default it initializes itself with values that represent a SQL Server 2005 database with Latin1_General_CS_AS collation.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReadFromScriptDatabaseInformation()
Visual C++
public:
ReadFromScriptDatabaseInformation()

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromScriptDatabaseInformation Methods

[image] [image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation Methods
ReadFromScriptDatabaseInformation Class See Also

The ReadFromScriptDatabaseInformation type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.Equals Method
ReadFromScriptDatabaseInformation Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(ReadFromScriptDatabaseInformation) | Determines whether the two ReadFromScriptDatabaseInformation instances are equal.

See Also

ReadFromScriptDatabaseInformation Class
ReadFromScriptDatabaseInformation Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method (ReadFromScriptDatabaseInformation)

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.Equals Method (ReadFromScriptDatabaseInformation)
ReadFromScriptDatabaseInformation Class See Also

Determines whether the two ReadFromScriptDatabaseInformation instances are equal.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As ReadFromScriptDatabaseInformation _
) As Boolean
C#
public bool Equals(
    ReadFromScriptDatabaseInformation other
)
Visual C++
public:
virtual bool Equals(
    ReadFromScriptDatabaseInformation^ other
) sealed

Parameters

other
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ReadFromScriptDatabaseInformation
The ReadFromScriptDatabaseInformation to compare with.

Return Value

True if the two instances are equal.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

ReadFromScriptDatabaseInformation Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ReadFromScriptDatabaseInformation Properties

[image] [image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation Properties
ReadFromScriptDatabaseInformation Class See Also

The ReadFromScriptDatabaseInformation type exposes the following properties.

Properties

Name | Description
CaseSensitive | Indicates whether the database is case sensitive.
DefaultCollation | The default collation for this database.
DefaultFilegroup | Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.
DefaultOwner | Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.
DefaultUser | Sets or gets the default user that should be used for AUTHORIZATION clauses.
SQLServerDBVersion | Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CaseSensitive Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.CaseSensitive Property
ReadFromScriptDatabaseInformation Class See Also

Indicates whether the database is case sensitive.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; }
Visual C++
public:
property bool CaseSensitive {
    bool get ();
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultCollation Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.DefaultCollation Property
ReadFromScriptDatabaseInformation Class See Also

The default collation for this database.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultCollation As String
C#
public string DefaultCollation { get; set; }
Visual C++
public:
property String^ DefaultCollation {
    String^ get ();
    void set (String^ value);
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultFilegroup Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.DefaultFilegroup Property
ReadFromScriptDatabaseInformation Class See Also

Sets or gets the filegroup that should be used if nothing or "DEFAULT" is specified in a creation SQL statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultFilegroup As String
C#
public string DefaultFilegroup { get; set; }
Visual C++
public:
property String^ DefaultFilegroup {
    String^ get ();
    void set (String^ value);
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultOwner Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.DefaultOwner Property
ReadFromScriptDatabaseInformation Class See Also

Sets or gets the default owner for the database objects. In SQL Server 2005 this will set the default schema; in SQL Server 2000 it will set the default user owner.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultOwner As String
C#
public string DefaultOwner { get; set; }
Visual C++
public:
property String^ DefaultOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DefaultUser Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.DefaultUser Property
ReadFromScriptDatabaseInformation Class See Also

Sets or gets the default user that should be used for AUTHORIZATION clauses.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultUser As String
C#
public string DefaultUser { get; set; }
Visual C++
public:
property String^ DefaultUser {
    String^ get ();
    void set (String^ value);
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SQLServerDBVersion Property

[image]

SQL Data Compare API 7.1.0
ReadFromScriptDatabaseInformation..::.SQLServerDBVersion Property
ReadFromScriptDatabaseInformation Class See Also

Gets or sets the database major version. 8 is for SQL Server 2000. 9 is for SQL Server 2005. 10 is for SQL Server 2008.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SQLServerDBVersion As SQLVersion
C#
public SQLVersion SQLServerDBVersion { get; set; }
Visual C++
public:
property SQLVersion SQLServerDBVersion {
    SQLVersion get ();
    void set (SQLVersion value);
}

See Also

ReadFromScriptDatabaseInformation Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSource Class

[image]

SQL Data Compare API 7.1.0
ScriptSource Class
Members See Also

Information about the source of a database object. This information includes details of the creation script file, as well as the starting and ending character position for the creation statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSource _
    Implements IEqualityComparer(Of ScriptSource)
C#
public sealed class ScriptSource : IEqualityComparer<ScriptSource>
Visual C++
public ref class ScriptSource sealed : IEqualityComparer<ScriptSource^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSource

See Also

ScriptSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSource Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource Members
ScriptSource Class Methods Fields Properties See Also

The ScriptSource type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Empty | An empty script source.

Properties

Name | Description
FileInfo | Information about the file that contains the SQL statement.
LowerPosition | The first character position of the SQL statement.
PermissionsSources | A collection of script sources for the permission statements.
SetAnsiNulls | The script source of the relevant "SET ANSII NULLS" statement.
SetQuotedIdentifiers | The script source of the relevant "SET QUOTED IDENTIFIERS" statement.
UpperPosition | The last character position of the SQL statement.

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSource Fields

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource Fields
ScriptSource Class See Also

The ScriptSource type exposes the following fields.

Fields

Name | Description
Empty | An empty script source.

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Empty Field

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.Empty Field
ScriptSource Class See Also

An empty script source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As ScriptSource
C#
public static readonly ScriptSource Empty
Visual C++
public:
static initonly ScriptSource^ Empty

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSource Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource Methods
ScriptSource Class See Also

The ScriptSource type exposes the following methods.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource..::.Equals Method
ScriptSource Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(ScriptSource, ScriptSource) | Checks if two script sources are equal.

See Also

ScriptSource Class
ScriptSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Equals Method (ScriptSource, ScriptSource)

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.Equals Method (ScriptSource, ScriptSource)
ScriptSource Class See Also

Checks if two script sources are equal.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    x As ScriptSource, _
    y As ScriptSource _
) As Boolean
C#
public bool Equals(
    ScriptSource x,
    ScriptSource y
)
Visual C++
public:
virtual bool Equals(
    ScriptSource^ x,
    ScriptSource^ y
) sealed

Parameters

x
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSource
The first script source.
y
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSource
The second script source.

Return Value

True if the two script sources are equal.

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

ScriptSource Class
Equals Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetHashCode Method

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource..::.GetHashCode Method
ScriptSource Class See Also

Overload List

Name | Description
GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHashCode(ScriptSource) | Calculates the hash code for the script source.

See Also

ScriptSource Class
ScriptSource Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


GetHashCode Method (ScriptSource)

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.GetHashCode Method (ScriptSource)
ScriptSource Class See Also

Calculates the hash code for the script source.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHashCode ( _
    obj As ScriptSource _
) As Integer
C#
public int GetHashCode(
    ScriptSource obj
)
Visual C++
public:
virtual int GetHashCode(
    ScriptSource^ obj
) sealed

Parameters

obj
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSource
The script source for which the hash code is required.

Return Value

The hash code for the script source.

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

See Also

ScriptSource Class
GetHashCode Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSource Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptSource Properties
ScriptSource Class See Also

The ScriptSource type exposes the following properties.

Properties

Name | Description
FileInfo | Information about the file that contains the SQL statement.
LowerPosition | The first character position of the SQL statement.
PermissionsSources | A collection of script sources for the permission statements.
SetAnsiNulls | The script source of the relevant "SET ANSII NULLS" statement.
SetQuotedIdentifiers | The script source of the relevant "SET QUOTED IDENTIFIERS" statement.
UpperPosition | The last character position of the SQL statement.

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileInfo Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.FileInfo Property
ScriptSource Class See Also

Information about the file that contains the SQL statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileInfo As FileInfo
C#
public FileInfo FileInfo { get; internal set; }
Visual C++
public:
property FileInfo^ FileInfo {
    FileInfo^ get ();
    void set (FileInfo^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


LowerPosition Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.LowerPosition Property
ScriptSource Class See Also

The first character position of the SQL statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LowerPosition As Integer
C#
public int LowerPosition { get; internal set; }
Visual C++
public:
property int LowerPosition {
    int get ();
    void set (int value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


PermissionsSources Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.PermissionsSources Property
ScriptSource Class See Also

A collection of script sources for the permission statements.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PermissionsSources As List(Of ScriptSource)
C#
public List<ScriptSource> PermissionsSources { get; }
Visual C++
public:
property List<ScriptSource^>^ PermissionsSources {
    List<ScriptSource^>^ get ();
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SetAnsiNulls Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.SetAnsiNulls Property
ScriptSource Class See Also

The script source of the relevant "SET ANSII NULLS" statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SetAnsiNulls As ScriptSource
C#
public ScriptSource SetAnsiNulls { get; internal set; }
Visual C++
public:
property ScriptSource^ SetAnsiNulls {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SetQuotedIdentifiers Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.SetQuotedIdentifiers Property
ScriptSource Class See Also

The script source of the relevant "SET QUOTED IDENTIFIERS" statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SetQuotedIdentifiers As ScriptSource
C#
public ScriptSource SetQuotedIdentifiers { get; internal set; }
Visual C++
public:
property ScriptSource^ SetQuotedIdentifiers {
    ScriptSource^ get ();
    void set (ScriptSource^ value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


UpperPosition Property

[image]

SQL Data Compare API 7.1.0
ScriptSource..::.UpperPosition Property
ScriptSource Class See Also

The last character position of the SQL statement.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UpperPosition As Integer
C#
public int UpperPosition { get; internal set; }
Visual C++
public:
property int UpperPosition {
    int get ();
    void set (int value);
}

See Also

ScriptSource Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Class

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Class
Members See Also

A synchronization action that is used when a file needs to be created or altered during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ScriptSynchronizationAction
C#
public abstract class ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationAction abstract

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionCreateObject
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionDBInfo
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionRewrite

See Also

ScriptSynchronizationAction Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Members
ScriptSynchronizationAction Class Constructors Methods Fields Properties See Also

The ScriptSynchronizationAction type exposes the following members.

Constructors

Name | Description
ScriptSynchronizationAction | Constructs a ScriptSynchronizationAction.

Methods

Name | Description
Check | Checks preconditions for the execution.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_FileName | The name of the file this synchronization action should work with.
m_Options | Options that control how the databases are compared and case sensitivity.
m_ScriptFolder | The path to the folder where the scripts should be created and altered.
m_Wtf | WriteToFileOptions that control how the synchronization actions create new files.

Properties

Name | Description
FileName | The file name for this synchronization action.
ShortFileName | The name of the file and its prefix folder for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Constructor

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Constructor
ScriptSynchronizationAction Class See Also

Constructs a ScriptSynchronizationAction.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    wtf As WriteToFileOptions, _
    options As Options, _
    scriptFolder As String, _
    fileName As String _
)
C#
public ScriptSynchronizationAction(
    WriteToFileOptions wtf,
    Options options,
    string scriptFolder,
    string fileName
)
Visual C++
public:
ScriptSynchronizationAction(
    WriteToFileOptions^ wtf,
    Options options,
    String^ scriptFolder,
    String^ fileName
)

Parameters

wtf
Type: RedGate.SQLCompare.Engine.ReadFromFolder..::.WriteToFileOptions
The options that control how to write to the scripts folder.
options
Type: RedGate.SQLCompare.Engine..::.Options
Database options.
scriptFolder
Type: System..::.String
The scripts folder for the target scripts.
fileName
Type: System..::.String
The name of the file for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Fields

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Fields
ScriptSynchronizationAction Class See Also

The ScriptSynchronizationAction type exposes the following fields.

Fields

Name | Description
m_FileName | The name of the file this synchronization action should work with.
m_Options | Options that control how the databases are compared and case sensitivity.
m_ScriptFolder | The path to the folder where the scripts should be created and altered.
m_Wtf | WriteToFileOptions that control how the synchronization actions create new files.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


m_FileName Field

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.m_FileName Field
ScriptSynchronizationAction Class See Also

The name of the file this synchronization action should work with.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_FileName As String
C#
protected string m_FileName
Visual C++
protected:
String^ m_FileName

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


m_Options Field

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.m_Options Field
ScriptSynchronizationAction Class See Also

Options that control how the databases are compared and case sensitivity.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Options As Options
C#
protected Options m_Options
Visual C++
protected:
Options m_Options

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


m_ScriptFolder Field

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.m_ScriptFolder Field
ScriptSynchronizationAction Class See Also

The path to the folder where the scripts should be created and altered.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_ScriptFolder As String
C#
protected string m_ScriptFolder
Visual C++
protected:
String^ m_ScriptFolder

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


m_Wtf Field

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.m_Wtf Field
ScriptSynchronizationAction Class See Also

WriteToFileOptions that control how the synchronization actions create new files.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected m_Wtf As WriteToFileOptions
C#
protected WriteToFileOptions m_Wtf
Visual C++
protected:
WriteToFileOptions^ m_Wtf

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Methods
ScriptSynchronizationAction Class See Also

The ScriptSynchronizationAction type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.Check Method
ScriptSynchronizationAction Class See Also

Checks preconditions for the execution.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Check
C#
public abstract void Check()
Visual C++
public:
virtual void Check() abstract

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.Execute Method
ScriptSynchronizationAction Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Execute
C#
public abstract void Execute()
Visual C++
public:
virtual void Execute() abstract

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationAction Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction Properties
ScriptSynchronizationAction Class See Also

The ScriptSynchronizationAction type exposes the following properties.

Properties

Name | Description
FileName | The file name for this synchronization action.
ShortFileName | The name of the file and its prefix folder for this particular synchronization action.

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.FileName Property
ScriptSynchronizationAction Class See Also

The file name for this synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; protected internal set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ShortFileName Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationAction..::.ShortFileName Property
ScriptSynchronizationAction Class See Also

The name of the file and its prefix folder for this particular synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortFileName As String
C#
public string ShortFileName { get; }
Visual C++
public:
property String^ ShortFileName {
    String^ get ();
}

See Also

ScriptSynchronizationAction Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Class

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject Class
Members See Also

A synchronization action that creates a new file for a database object.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionCreateObject _
    Inherits ScriptSynchronizationAction
C#
public sealed class ScriptSynchronizationActionCreateObject : ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationActionCreateObject sealed : public ScriptSynchronizationAction

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionCreateObject

See Also

ScriptSynchronizationActionCreateObject Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject Members
ScriptSynchronizationActionCreateObject Class Methods Fields Properties See Also

The ScriptSynchronizationActionCreateObject type exposes the following members.

Methods

Name | Description
Check | Checks preconditions for the execution. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_FileName | The name of the file this synchronization action should work with. (Inherited from ScriptSynchronizationAction.)
m_Options | Options that control how the databases are compared and case sensitivity. (Inherited from ScriptSynchronizationAction.)
m_ScriptFolder | The path to the folder where the scripts should be created and altered. (Inherited from ScriptSynchronizationAction.)
m_Wtf | WriteToFileOptions that control how the synchronization actions create new files. (Inherited from ScriptSynchronizationAction.)

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action.
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject Methods
ScriptSynchronizationActionCreateObject Class See Also

The ScriptSynchronizationActionCreateObject type exposes the following methods.

Methods

Name | Description
Check | Checks preconditions for the execution. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject..::.Check Method
ScriptSynchronizationActionCreateObject Class See Also

Checks preconditions for the execution.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject..::.Execute Method
ScriptSynchronizationActionCreateObject Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionCreateObject Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject Properties
ScriptSynchronizationActionCreateObject Class See Also

The ScriptSynchronizationActionCreateObject type exposes the following properties.

Properties

Name | Description
DatabaseObject | The database object that is to be created by this synchronization action.
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DatabaseObject Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionCreateObject..::.DatabaseObject Property
ScriptSynchronizationActionCreateObject Class See Also

The database object that is to be created by this synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseObject As IDatabaseObject
C#
public IDatabaseObject DatabaseObject { get; }
Visual C++
public:
property IDatabaseObject^ DatabaseObject {
    IDatabaseObject^ get ();
}

See Also

ScriptSynchronizationActionCreateObject Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionDBInfo Class

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo Class
Members See Also

A synchronization action that is used to modify database settings during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionDBInfo _
    Inherits ScriptSynchronizationAction
C#
public sealed class ScriptSynchronizationActionDBInfo : ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationActionDBInfo sealed : public ScriptSynchronizationAction

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionDBInfo

See Also

ScriptSynchronizationActionDBInfo Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionDBInfo Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo Members
ScriptSynchronizationActionDBInfo Class Methods Fields Properties See Also

The ScriptSynchronizationActionDBInfo type exposes the following members.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_FileName | The name of the file this synchronization action should work with. (Inherited from ScriptSynchronizationAction.)
m_Options | Options that control how the databases are compared and case sensitivity. (Inherited from ScriptSynchronizationAction.)
m_ScriptFolder | The path to the folder where the scripts should be created and altered. (Inherited from ScriptSynchronizationAction.)
m_Wtf | WriteToFileOptions that control how the synchronization actions create new files. (Inherited from ScriptSynchronizationAction.)

Properties

Name | Description
DbInfo | The database settings for this sychronization action. These settings contain information about the database the creation scripts belong to.
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionDBInfo Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo Methods
ScriptSynchronizationActionDBInfo Class See Also

The ScriptSynchronizationActionDBInfo type exposes the following methods.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo..::.Check Method
ScriptSynchronizationActionDBInfo Class See Also

Checks if the script synchronization action can be carried out.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo..::.Execute Method
ScriptSynchronizationActionDBInfo Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionDBInfo Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo Properties
ScriptSynchronizationActionDBInfo Class See Also

The ScriptSynchronizationActionDBInfo type exposes the following properties.

Properties

Name | Description
DbInfo | The database settings for this sychronization action. These settings contain information about the database the creation scripts belong to.
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


DbInfo Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionDBInfo..::.DbInfo Property
ScriptSynchronizationActionDBInfo Class See Also

The database settings for this sychronization action. These settings contain information about the database the creation scripts belong to.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbInfo As ReadFromScriptDatabaseInformation
C#
public ReadFromScriptDatabaseInformation DbInfo { get; }
Visual C++
public:
property ReadFromScriptDatabaseInformation^ DbInfo {
    ReadFromScriptDatabaseInformation^ get ();
}

See Also

ScriptSynchronizationActionDBInfo Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Class

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionRewrite Class
Members See Also

A synchronization action that modifies a creation SQL file.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptSynchronizationActionRewrite _
    Inherits ScriptSynchronizationAction
C#
public sealed class ScriptSynchronizationActionRewrite : ScriptSynchronizationAction
Visual C++
public ref class ScriptSynchronizationActionRewrite sealed : public ScriptSynchronizationAction

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationAction
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActionRewrite

See Also

ScriptSynchronizationActionRewrite Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionRewrite Members
ScriptSynchronizationActionRewrite Class Methods Fields Properties See Also

The ScriptSynchronizationActionRewrite type exposes the following members.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_FileName | The name of the file this synchronization action should work with. (Inherited from ScriptSynchronizationAction.)
m_Options | Options that control how the databases are compared and case sensitivity. (Inherited from ScriptSynchronizationAction.)
m_ScriptFolder | The path to the folder where the scripts should be created and altered. (Inherited from ScriptSynchronizationAction.)
m_Wtf | WriteToFileOptions that control how the synchronization actions create new files. (Inherited from ScriptSynchronizationAction.)

Properties

Name | Description
FileName | The file name for this synchronization action. (Inherited from ScriptSynchronizationAction.)
ShortFileName | The name of the file and its prefix folder for this particular synchronization action. (Inherited from ScriptSynchronizationAction.)

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActionRewrite Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionRewrite Methods
ScriptSynchronizationActionRewrite Class See Also

The ScriptSynchronizationActionRewrite type exposes the following methods.

Methods

Name | Description
Check | Checks if the script synchronization action can be carried out. (Overrides ScriptSynchronizationAction ..::. Check()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Executes the synchronization action. (Overrides ScriptSynchronizationAction ..::. Execute()()().)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionRewrite..::.Check Method
ScriptSynchronizationActionRewrite Class See Also

Checks if the script synchronization action can be carried out.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Check
C#
public override void Check()
Visual C++
public:
virtual void Check() override

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActionRewrite..::.Execute Method
ScriptSynchronizationActionRewrite Class See Also

Executes the synchronization action.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Execute
C#
public override void Execute()
Visual C++
public:
virtual void Execute() override

See Also

ScriptSynchronizationActionRewrite Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Class

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions Class
Members See Also

The synchronization actions that need to be executed during synchronizing to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ScriptSynchronizationActions _
    Implements ICancellable
C#
public class ScriptSynchronizationActions : ICancellable
Visual C++
public ref class ScriptSynchronizationActions : ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.ScriptSynchronizationActions

See Also

ScriptSynchronizationActions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Members

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions Members
ScriptSynchronizationActions Class Methods Properties See Also

The ScriptSynchronizationActions type exposes the following members.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Check | Checks if the script synchronization actions can be carried out.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fire the status events.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Status | Used to provide status events.
SynchronizationActions | Access to the synchronization actions.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Methods

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions Methods
ScriptSynchronizationActions Class See Also

The ScriptSynchronizationActions type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
Check | Checks if the script synchronization actions can be carried out.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fire the status events.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.CancelOperation Method
ScriptSynchronizationActions Class See Also

Cancels the current operation.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Check Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.Check Method
ScriptSynchronizationActions Class See Also

Checks if the script synchronization actions can be carried out.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Check
C#
public void Check()
Visual C++
public:
void Check()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Execute Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.Execute Method
ScriptSynchronizationActions Class See Also

Performs the script synchronization actions; it will modify the SQL script files in the target scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute
C#
public void Execute()
Visual C++
public:
void Execute()

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


OnStatus Method

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.OnStatus Method
ScriptSynchronizationActions Class See Also

Fire the status events.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs
Arguments.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ScriptSynchronizationActions Properties

[image] [image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions Properties
ScriptSynchronizationActions Class See Also

The ScriptSynchronizationActions type exposes the following properties.

Properties

Name | Description
Status | Used to provide status events.
SynchronizationActions | Access to the synchronization actions.

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.Status Property
ScriptSynchronizationActions Class See Also

Used to provide status events.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


SynchronizationActions Property

[image]

SQL Data Compare API 7.1.0
ScriptSynchronizationActions..::.SynchronizationActions Property
ScriptSynchronizationActions Class See Also

Access to the synchronization actions.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SynchronizationActions As Dictionary(Of String, ScriptSynchronizationAction)
C#
public Dictionary<string, ScriptSynchronizationAction> SynchronizationActions { get; internal set; }
Visual C++
public:
property Dictionary<String^, ScriptSynchronizationAction^>^ SynchronizationActions {
    Dictionary<String^, ScriptSynchronizationAction^>^ get ();
    void set (Dictionary<String^, ScriptSynchronizationAction^>^ value);
}

See Also

ScriptSynchronizationActions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteToFileOptions Class

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions Class
Members See Also

Options that control how script files are written to a scripts folder.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WriteToFileOptions
C#
public class WriteToFileOptions
Visual C++
public ref class WriteToFileOptions

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine.ReadFromFolder..::.WriteToFileOptions

See Also

WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteToFileOptions Members

[image] [image]

SQL Data Compare API 7.1.0
WriteToFileOptions Members
WriteToFileOptions Class Constructors Methods Properties See Also

The WriteToFileOptions type exposes the following members.

Constructors

Name | Description
WriteToFileOptions | Constructs a new instance of the WriteToFileOptions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

Properties

Name | Description
ObjectPrefixes | The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.

See Also

WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteToFileOptions Constructor

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions Constructor
WriteToFileOptions Class See Also

Constructs a new instance of the WriteToFileOptions class.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WriteToFileOptions()
Visual C++
public:
WriteToFileOptions()

See Also

WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteToFileOptions Methods

[image] [image]

SQL Data Compare API 7.1.0
WriteToFileOptions Methods
WriteToFileOptions Class See Also

The WriteToFileOptions type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromXml | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

See Also

WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method

[image] [image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method
WriteToFileOptions Class See Also

Overload List

Name | Description
FromXml(Stream) | Constructs a new WriteToFileOptions object given a stream. Returns null if the options cannot be constructed from the XML.
FromXml(TextReader) | Constructs a new WriteToFileOptions object given a textreader containing XML generated by GetXml(). Returns null if the options cannot be constructed from the XML.
FromXml(String) | Constructs a new WriteToFileOptions object given an XML string generated by GetXml() method. Returns null if the options cannot be constructed from the XML.
FromXml(XmlNode) | Constructs a new WriteToFileOptions object given a document node for a WriteToFileOptions instance. Returns null if the options cannot be constructed from the XML.
FromXml(XmlReader) | Constructs a new WriteToFileOptions object given an XML reader. Returns null if the options cannot be constructed from the XML.

See Also

WriteToFileOptions Class
WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method (Stream)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method (Stream)
WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given a stream. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xmlStream As Stream _
) As WriteToFileOptions
C#
public static WriteToFileOptions FromXml(
    Stream xmlStream
)
Visual C++
public:
static WriteToFileOptions^ FromXml(
    Stream^ xmlStream
)

Parameters

xmlStream
Type: System.IO..::.Stream

See Also

WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method (TextReader)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method (TextReader)
WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given a textreader containing XML generated by GetXml(). Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xmlText As TextReader _
) As WriteToFileOptions
C#
public static WriteToFileOptions FromXml(
    TextReader xmlText
)
Visual C++
public:
static WriteToFileOptions^ FromXml(
    TextReader^ xmlText
)

Parameters

xmlText
Type: System.IO..::.TextReader

See Also

WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method (String)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method (String)
WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given an XML string generated by GetXml() method. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    xml As String _
) As WriteToFileOptions
C#
public static WriteToFileOptions FromXml(
    string xml
)
Visual C++
public:
static WriteToFileOptions^ FromXml(
    String^ xml
)

Parameters

xml
Type: System..::.String

See Also

WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method (XmlNode)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method (XmlNode)
WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given a document node for a WriteToFileOptions instance. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    rootNode As XmlNode _
) As WriteToFileOptions
C#
public static WriteToFileOptions FromXml(
    XmlNode rootNode
)
Visual C++
public:
static WriteToFileOptions^ FromXml(
    XmlNode^ rootNode
)

Parameters

rootNode
Type: System.Xml..::.XmlNode

See Also

WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


FromXml Method (XmlReader)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.FromXml Method (XmlReader)
WriteToFileOptions Class See Also

Constructs a new WriteToFileOptions object given an XML reader. Returns null if the options cannot be constructed from the XML.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromXml ( _
    reader As XmlReader _
) As WriteToFileOptions
C#
public static WriteToFileOptions FromXml(
    XmlReader reader
)
Visual C++
public:
static WriteToFileOptions^ FromXml(
    XmlReader^ reader
)

Parameters

reader
Type: System.Xml..::.XmlReader

See Also

WriteToFileOptions Class
FromXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method

[image] [image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.WriteXml Method
WriteToFileOptions Class See Also

Overload List

Name | Description
WriteXml(Stream) | Writes an XML version of these options to a stream.
WriteXml(XmlWriter) | Writes an XML version of these options to an XmlWriter.

See Also

WriteToFileOptions Class
WriteToFileOptions Members
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method (Stream)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.WriteXml Method (Stream)
WriteToFileOptions Class See Also

Writes an XML version of these options to a stream.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml ( _
    stream As Stream _
)
C#
public void WriteXml(
    Stream stream
)
Visual C++
public:
void WriteXml(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

WriteToFileOptions Class
WriteXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteXml Method (XmlWriter)

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.WriteXml Method (XmlWriter)
WriteToFileOptions Class See Also

Writes an XML version of these options to an XmlWriter.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteXml ( _
    optionWriter As XmlWriter _
)
C#
public void WriteXml(
    XmlWriter optionWriter
)
Visual C++
public:
void WriteXml(
    XmlWriter^ optionWriter
)

Parameters

optionWriter
Type: System.Xml..::.XmlWriter

See Also

WriteToFileOptions Class
WriteXml Overload
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


WriteToFileOptions Properties

[image] [image]

SQL Data Compare API 7.1.0
WriteToFileOptions Properties
WriteToFileOptions Class See Also

The WriteToFileOptions type exposes the following properties.

Properties

Name | Description
ObjectPrefixes | The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.

See Also

WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


ObjectPrefixes Property

[image]

SQL Data Compare API 7.1.0
WriteToFileOptions..::.ObjectPrefixes Property
WriteToFileOptions Class See Also

The object prefixes for all the ObjectType enumeration elements. These prefixes may contain one or more subfolder names and an object name prefix.

Namespace: RedGate.SQLCompare.Engine.ReadFromFolder
Assembly: RedGate.SQLCompare.Engine (in RedGate.SQLCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefixes As String()
C#
public string[] ObjectPrefixes { get; internal set; }
Visual C++
public:
property array<String^>^ ObjectPrefixes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

WriteToFileOptions Class
RedGate.SQLCompare.Engine.ReadFromFolder Namespace


RedGate.SQLDataCompare.Engine Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.SQLDataCompare.Engine Namespace

Classes

Class | Description
Blob | Wrapper class for a byte array.
CLR | Wrapper class for a CLR data type.
ComparisonSession |
ComparisonSessionException | Exception thrown by ComparisonSession when it encounters an error comparing the databases.
DataCompareMappings<(Of <(T>)>) | Base class of object mappings used in Data Compare.
DataCompareVariant | Wrapper class for the SQL Variant data type.
DifferencesSummary | Holds information about the differences in the ResultsStore .
EngineDataCompareOptions | Class containing the three options enumerations for the three stages in data comparison.
FieldMapping | Contains a mapping from a field in one table to a field in another table.
FieldMappings | Holds mappings for fields in a table or view.
FieldPair | Field definition used in the ResultsStore class.
FieldPairs | A collection of FieldPair objects.
IndexMapping | Contains a mapping between the indexes in the different databases.
IndexMappings | Holds mappings of indexes. The indexes must be PrimaryKey, Unique, or UniqueConstraint to be included. The names of the indexes are not used for the mapping.
Project | A SQL Data Compare project.
SchemaMapping | Obsolete. Contains a mapping between the schema, user, or role in two databases.
SchemaMappings | Holds mappings for schemas, users, or roles. Uses the database objects to create the mappings for the views and the tables from the two databases.
SpatialCLRType | Wrapper class for a Spatial CLR data type (SQL2008).
SqlDataCompareException | Superclass of all exceptions thrown by the SQL Data Compare engine.
SqlProvider | The provider for access to SQL Server databases.
SqlProviderException | Exception thrown by SqlProvider when it encounters an error whilst generating SQL code.
TableDifference | The results of a table being compared in two databases.
TableDifferences | A collection of TableDifference objects.
TableMapping | Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.
TableMappings | Holds mappings for tables or views in a schema.
WhereClause | An encapsulation class for the WHERE clause used on the tables in the databases.

Structures

Structure | Description
SynchronizationRecord | A record to be included in a synchronization. This is used by the script generation routines to confirm the inclusion of a record. Passed a parameter to the SelectionDelegate.
UserActionWarning | Contains details of a user action that has failed due to schema changes since the project was created.

Delegates

Delegate | Description
SelectionDelegate | The delegate called to indicate whether a record should be included in the synchronization SQL script.

Enumerations

Enumeration | Description
ComparisonOptions | Options used when comparing databases.
FieldMappingStatus | The result of the FieldMapping.
MappingOptions | Options used when generating the mapping between two databases.
SessionSettings | Settings for comparing objects.
SqlOptions | Options used when synchronizing databases.
SqlSynchronization | Controls which parts of the SQL script are produced when the synchronization script is created.
TableMappingStatus | The result of the mapping.


Blob Class

[image]

SQL Data Compare API 7.1.0
Blob Class
Members Example See Also

Wrapper class for a byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Blob _
    Inherits DisposableBase _
    Implements IComparable
C#
public class Blob : DisposableBase, IComparable
Visual C++
public ref class Blob : public DisposableBase,
    IComparable

Remarks

The Blob object is used internally by SQL Data Compare to represent a byte array. Use the ByteArray property to access the underlying data.

Examples

C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                public class BlobExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        // Register the databases
                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        using (ComparisonSession session = new ComparisonSession())
                        {
                            // Create the schema mappings used to compare the database
                            SchemaMappings mappings = new SchemaMappings();
                            mappings.CreateMappings(db1, db2);

                            session.CompareDatabases(db1, db2, mappings);

                            // Get the reader for the different rows in the results
                            Reader different=session.TableDifferences["[dbo].[WidgetDescriptions]"].ResultsStore.GetReader(Row.RowType.Different);

                            // get the first row in the ResultsStore Reader for the different rows.

                            Row currentRow=different.GetRow(0);

                            //field1 and field2 contain the position of the two BLOBs in the ResultsStore
                            int field1 = different.Fields["Picture"].OrdinalInResults1;
                            int field2 = different.Fields["Picture"].OrdinalInResults2;

                            Blob blob1=(Blob)currentRow.Values[field1];
                            Blob blob2=(Blob)currentRow.Values[field2];

                            // Output the first 20 bytes
                            for (int i=0; i<20; i++)
                            {
                                Console.Write("{0:X} ", blob1.ByteArray[i]);
                            }
                            Console.WriteLine();

                            // Output the first 20 bytes
                            for (int i=0; i<20; i++)
                            {
                                Console.Write("{0:X} ", blob2.ByteArray[i]);
                            }
                            Console.WriteLine();
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Class BlobExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create the schema mappings used to compare the database
                    Dim mappings As New SchemaMappings
                    mappings.CreateMappings(db1, db2)

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim different As Reader = session.TableDifferences("[dbo].[WidgetDescriptions]").ResultsStore.GetReader(Row.RowType.Different)

                    'work out the two positions in the fields
                    Dim field1 As Integer = different.Fields("Picture").OrdinalInResults1
                    Dim field2 As Integer = different.Fields("Picture").OrdinalInResults2

                    'get the first row in the ResultsStore
                    Dim currentRow As Row = different.GetRow(0)

                    'field1 and field2 contain the position of the two BLOBs in the ResultsStore
                    Dim blob1 As Blob = currentRow.Values(field1)
                    Dim blob2 As Blob = currentRow.Values(field2)

                    Dim i As Integer

                    For i = 0 To 20
                        Console.Write("{0:X} ", blob1.ByteArray(i))
                    Next
                    Console.WriteLine()

                    For i = 0 To 20
                        Console.Write("{0:X} ", blob2.ByteArray(i))
                    Next
                    Console.WriteLine()

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR

See Also

Blob Members
RedGate.SQLDataCompare.Engine Namespace


Blob Members

[image] [image]

SQL Data Compare API 7.1.0
Blob Members
Blob Class Constructors Methods Properties See Also

The Blob type exposes the following members.

Constructors

Name | Description
Blob | Constructs the Blob object with a specified byte array.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ByteArray | The underlying byte array.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Blob Constructor

[image]

SQL Data Compare API 7.1.0
Blob Constructor
Blob Class See Also

Constructs the Blob object with a specified byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte() _
)
C#
public Blob(
    byte[] bytes
)
Visual C++
public:
Blob(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Blob Methods

[image] [image]

SQL Data Compare API 7.1.0
Blob Methods
Blob Class See Also

The Blob type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 7.1.0
Blob..::.CompareTo Method
Blob Class See Also

Compares the Blob with another Blob.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
The Blob to compare.

Return Value

Returns -1, 0, or 1.

Implements

IComparable..::.CompareTo(Object)

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
Blob..::.Dispose Method
Blob Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Blob Class
Blob Members
RedGate.SQLDataCompare.Engine Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
Blob..::.Dispose Method (Boolean)
Blob Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

Blob Class
Dispose Overload
RedGate.SQLDataCompare.Engine Namespace


Blob Properties

[image] [image]

SQL Data Compare API 7.1.0
Blob Properties
Blob Class See Also

The Blob type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array.

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


ByteArray Property

[image]

SQL Data Compare API 7.1.0
Blob..::.ByteArray Property
Blob Class See Also

The underlying byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ByteArray As Byte()
C#
public byte[] ByteArray { get; }
Visual C++
public:
property array<unsigned char>^ ByteArray {
    array<unsigned char>^ get ();
}

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


Length Property

[image]

SQL Data Compare API 7.1.0
Blob..::.Length Property
Blob Class See Also

The number of bytes in the underlying byte array.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
Visual C++
public:
property int Length {
    int get ();
}

See Also

Blob Class
RedGate.SQLDataCompare.Engine Namespace


CLR Class

[image]

SQL Data Compare API 7.1.0
CLR Class
Members See Also

Wrapper class for a CLR data type.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class CLR _
    Inherits Blob
C#
public class CLR : Blob
Visual C++
public ref class CLR : public Blob

Remarks

The CLR object is used internally by SQL Data Compare to represent a CLR data type. Use the ByteArray and Text properties to access the underlying data.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR
RedGate.SQLDataCompare.Engine..::.SpatialCLRType

See Also

CLR Members
RedGate.SQLDataCompare.Engine Namespace


CLR Members

[image] [image]

SQL Data Compare API 7.1.0
CLR Members
CLR Class Constructors Methods Properties See Also

The CLR type exposes the following members.

Constructors

Name | Description
CLR | Overloaded.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides Object ..::. ToString()()().)

Operators

Name | Description
Explicit | Explicit conversion from CLR to string.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
Text | The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor

[image] [image]

SQL Data Compare API 7.1.0
CLR Constructor
CLR Class See Also

Overload List

Name | Description
CLR(array<Byte>[]()[]) | Constructs the CLR object with a given byte array and textual representation.
CLR(array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.

See Also

CLR Class
CLR Members
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor (Byte[])

[image]

SQL Data Compare API 7.1.0
CLR Constructor (array<Byte>[]()[])
CLR Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte() _
)
C#
public CLR(
    byte[] bytes
)
Visual C++
public:
CLR(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array.

See Also

CLR Class
CLR Overload
RedGate.SQLDataCompare.Engine Namespace


CLR Constructor (Byte[], String)

[image]

SQL Data Compare API 7.1.0
CLR Constructor (array<Byte>[]()[], String)
CLR Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bytes As Byte(), _
    textual As String _
)
C#
public CLR(
    byte[] bytes,
    string textual
)
Visual C++
public:
CLR(
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
The byte array.
textual
Type: System..::.String
The textual representation of the CLR object.

See Also

CLR Class
CLR Overload
RedGate.SQLDataCompare.Engine Namespace


CLR Methods

[image] [image]

SQL Data Compare API 7.1.0
CLR Methods
CLR Class See Also

The CLR type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides Object ..::. ToString()()().)

Operators

Name | Description
Explicit | Explicit conversion from CLR to string.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
CLR..::.Dispose Method
CLR Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Inherited from Blob.)

See Also

CLR Class
CLR Members
RedGate.SQLDataCompare.Engine Namespace


Explicit Operator

[image]

SQL Data Compare API 7.1.0
CLR..::.Explicit Operator
CLR Class See Also

Explicit conversion from CLR to string.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    clr As CLR _
) As String
C#
public static explicit operator string (
    CLR clr
)
Visual C++
static explicit operator String^ (
    CLR^ clr
)

Parameters

clr
Type: RedGate.SQLDataCompare.Engine..::.CLR
The CLR to cast.

Return Value

The textual representation of the CLR.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
CLR..::.ToString Method
CLR Class See Also

Returns a string representation of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


CLR Properties

[image] [image]

SQL Data Compare API 7.1.0
CLR Properties
CLR Class See Also

The CLR type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
Text | The textual representation of the CLR object.

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


HasText Property

[image]

SQL Data Compare API 7.1.0
CLR..::.HasText Property
CLR Class See Also

Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasText As Boolean
C#
public bool HasText { get; }
Visual C++
public:
property bool HasText {
    bool get ();
}

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


Text Property

[image]

SQL Data Compare API 7.1.0
CLR..::.Text Property
CLR Class See Also

The textual representation of the CLR object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

CLR Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonOptions Enumeration

[image]

SQL Data Compare API 7.1.0
ComparisonOptions Enumeration
See Also

Options used when comparing databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ComparisonOptions
C#
[FlagsAttribute]
public enum ComparisonOptions
Visual C++
[FlagsAttribute]
public enum class ComparisonOptions

Members

Member name | Description
Default | None.
None | None.
TrimTrailingSpaces | If two columns of data differ only by the number of spaces at the end of the string, SQL Data Compare considers the data to be identical. The trailing spaces are not included in the synchronization script. This option does not apply to CLR or variant columns.
ForceBinaryCollation | For all string data types, forces binary collation irrespective of column collation, resulting in a case-sensitive comparison. When this option is selected and the comparison key is a string, this may result in slower performance because the indexes are not used.
UseChecksumComparison | When you are comparing tables or views with a large volume of data that changes infrequently, if you set this option, a checksum is used to compare the data. If the checksums differ, the data is compared; if the checksums are the same, the data is not compared. On SQL Server 2000 the connected user must be a member of the db_owner role or the system administrator role. This option applies only to SQL Server 2000 or later.
CompressTemporaryFiles | Compresses the temporary files that SQL Data Compare generates while performing the comparison. This reduces the possibility of running out of temporary disk space when comparing very large databases. When you select this option, you will not be able to sort the results of the comparison.

See Also

RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Class

[image]

SQL Data Compare API 7.1.0
ComparisonSession Class
Members See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ComparisonSession _
    Inherits DisposableBase _
    Implements ICancellable
C#
public class ComparisonSession : DisposableBase, ICancellable
Visual C++
public ref class ComparisonSession : public DisposableBase,
    ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.ComparisonSession

See Also

ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Members

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSession Members
ComparisonSession Class Constructors Methods Properties See Also

The ComparisonSession type exposes the following members.

Constructors

Name | Description
ComparisonSession | Constructor.

Methods

Name | Description
CancelOperation | Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.
CompareDatabases | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the status event handler.
RefreshSelectedItems | Refreshes the TableDifferences collection with any changes that have been made to the underlying data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Database1 | Returns the first database that is being compared.
Database2 | Returns the second database that is being compared.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Options | The options used when the databases are compared.
Status | The event handler used to receive status update events.
TableDifferences | The differences resulting from the database comparison.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Constructor

[image]

SQL Data Compare API 7.1.0
ComparisonSession Constructor
ComparisonSession Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparisonSession()
Visual C++
public:
ComparisonSession()

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Methods

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSession Methods
ComparisonSession Class See Also

The ComparisonSession type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.
CompareDatabases | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the status event handler.
RefreshSelectedItems | Refreshes the TableDifferences collection with any changes that have been made to the underlying data.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CancelOperation Method
ComparisonSession Class Example See Also

Cancels the current operation. Any table differences that were generated before the operation was canceled will be invalid.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

Remarks

An OperationCancelledException is thrown.

Examples

See CompareDatabases(Database, Database, SchemaMappings) for an example of how to receive status events and cancel operations.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CompareDatabases Method
ComparisonSession Class See Also

Overload List

Name | Description
CompareDatabases(Database, Database, SchemaMappings) | Compares two databases using default session settings.
CompareDatabases(Database, Database, TableMappings) | Compares the tables in two databases using default session settings.
CompareDatabases(Database, Database, SchemaMappings, SessionSettings) | Compares two databases with customized session settings.
CompareDatabases(Database, Database, TableMappings, SessionSettings) | Compares the tables in two databases using customized session settings.

See Also

ComparisonSession Class
ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (Database, Database, SchemaMappings)

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CompareDatabases Method (Database, Database, SchemaMappings)
ComparisonSession Class See Also

Compares two databases using default session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As Database, _
    db2 As Database, _
    mappings As SchemaMappings _
)
C#
public void CompareDatabases(
    Database db1,
    Database db2,
    SchemaMappings mappings
)
Visual C++
public:
void CompareDatabases(
    Database^ db1,
    Database^ db2,
    SchemaMappings^ mappings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
Mappings from the first database to the second database.

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (Database, Database, TableMappings)

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CompareDatabases Method (Database, Database, TableMappings)
ComparisonSession Class See Also

Compares the tables in two databases using default session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As Database, _
    db2 As Database, _
    mappings As TableMappings _
)
C#
public void CompareDatabases(
    Database db1,
    Database db2,
    TableMappings mappings
)
Visual C++
public:
void CompareDatabases(
    Database^ db1,
    Database^ db2,
    TableMappings^ mappings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.TableMappings
Mappings from the first database to the second database.

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (Database, Database, SchemaMappings, SessionSettings)

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CompareDatabases Method (Database, Database, SchemaMappings, SessionSettings)
ComparisonSession Class See Also

Compares two databases with customized session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As Database, _
    db2 As Database, _
    mappings As SchemaMappings, _
    sessionSettings As SessionSettings _
)
C#
public void CompareDatabases(
    Database db1,
    Database db2,
    SchemaMappings mappings,
    SessionSettings sessionSettings
)
Visual C++
public:
void CompareDatabases(
    Database^ db1,
    Database^ db2,
    SchemaMappings^ mappings,
    SessionSettings sessionSettings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
Mappings from the first database to the second database.
sessionSettings
Type: RedGate.SQLDataCompare.Engine..::.SessionSettings
The records to include, by comparison status (identical, different, additional, missing).

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


CompareDatabases Method (Database, Database, TableMappings, SessionSettings)

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.CompareDatabases Method (Database, Database, TableMappings, SessionSettings)
ComparisonSession Class See Also

Compares the tables in two databases using customized session settings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompareDatabases ( _
    db1 As Database, _
    db2 As Database, _
    mappings As TableMappings, _
    sessionSettings As SessionSettings _
)
C#
public void CompareDatabases(
    Database db1,
    Database db2,
    TableMappings mappings,
    SessionSettings sessionSettings
)
Visual C++
public:
void CompareDatabases(
    Database^ db1,
    Database^ db2,
    TableMappings^ mappings,
    SessionSettings sessionSettings
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database to compare.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database to compare, or null.
mappings
Type: RedGate.SQLDataCompare.Engine..::.TableMappings
Mappings from the first database to the second database.
sessionSettings
Type: RedGate.SQLDataCompare.Engine..::.SessionSettings
The records to include, by comparison status (identical, different, additional, missing).

See Also

ComparisonSession Class
CompareDatabases Overload
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Dispose Method
ComparisonSession Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

ComparisonSession Class
ComparisonSession Members
RedGate.SQLDataCompare.Engine Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Dispose Method (Boolean)
ComparisonSession Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ComparisonSession Class
Dispose Overload
RedGate.SQLDataCompare.Engine Namespace


OnStatus Method

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.OnStatus Method
ComparisonSession Class See Also

Fires the status event handler.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


RefreshSelectedItems Method

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.RefreshSelectedItems Method
ComparisonSession Class See Also

Refreshes the TableDifferences collection with any changes that have been made to the underlying data.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshSelectedItems
C#
public void RefreshSelectedItems()
Visual C++
public:
void RefreshSelectedItems()

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSession Properties

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSession Properties
ComparisonSession Class See Also

The ComparisonSession type exposes the following properties.

Properties

Name | Description
Database1 | Returns the first database that is being compared.
Database2 | Returns the second database that is being compared.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Options | The options used when the databases are compared.
Status | The event handler used to receive status update events.
TableDifferences | The differences resulting from the database comparison.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Database1 Property

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Database1 Property
ComparisonSession Class See Also

Returns the first database that is being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database1 As Database
C#
public Database Database1 { get; }
Visual C++
public:
property Database^ Database1 {
    Database^ get ();
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Database2 Property

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Database2 Property
ComparisonSession Class See Also

Returns the second database that is being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Database2 As Database
C#
public Database Database2 { get; }
Visual C++
public:
property Database^ Database2 {
    Database^ get ();
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Options Property
ComparisonSession Class See Also

The options used when the databases are compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.Status Property
ComparisonSession Class Example See Also

The event handler used to receive status update events.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

Examples

See CompareDatabases(Database, Database, SchemaMappings) for an example of how to receive status events and cancel operations.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Property

[image]

SQL Data Compare API 7.1.0
ComparisonSession..::.TableDifferences Property
ComparisonSession Class Example See Also

The differences resulting from the database comparison.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableDifferences As TableDifferences
C#
public TableDifferences TableDifferences { get; }
Visual C++
public:
property TableDifferences^ TableDifferences {
    TableDifferences^ get ();
}

Examples

See ComparisonSession for an example of how to use this.

See Also

ComparisonSession Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Class

[image]

SQL Data Compare API 7.1.0
ComparisonSessionException Class
Members See Also

Exception thrown by ComparisonSession when it encounters an error comparing the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ComparisonSessionException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class ComparisonSessionException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class ComparisonSessionException : public SqlDataCompareException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionException

See Also

ComparisonSessionException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Members

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSessionException Members
ComparisonSessionException Class Constructors Methods Properties See Also

The ComparisonSessionException type exposes the following members.

Constructors

Name | Description
ComparisonSessionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ComparisonSessionException Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor

[image] [image]

SQL Data Compare API 7.1.0
ComparisonSessionException Constructor
ComparisonSessionException Class See Also

Overload List

Name | Description
ComparisonSessionException()()() | Creates a new exception.
ComparisonSessionException(String) | Creates a new exception with the specified detail message.
ComparisonSessionException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
ComparisonSessionException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

ComparisonSessionException Class
ComparisonSessionException Members
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor

[image]

SQL Data Compare API 7.1.0
ComparisonSessionException Constructor
ComparisonSessionException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ComparisonSessionException()
Visual C++
public:
ComparisonSessionException()

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor (String)

[image]

SQL Data Compare API 7.1.0
ComparisonSessionException Constructor (String)
ComparisonSessionException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ComparisonSessionException(
    string message
)
Visual C++
public:
ComparisonSessionException(
    String^ message
)

Parameters

message
Type: System..::.String
Detail message.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
ComparisonSessionException Constructor (SerializationInfo, StreamingContext)
ComparisonSessionException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ComparisonSessionException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ComparisonSessionException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


ComparisonSessionException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
ComparisonSessionException Constructor (String, Exception)
ComparisonSessionException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public ComparisonSessionException(
    string message,
    Exception cause
)
Visual C++
public:
ComparisonSessionException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::.String
Detail message.
cause
Type: System..::.Exception
Cause of exception.

See Also

ComparisonSessionException Class
ComparisonSessionException Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Generic Class

[image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Generic Class
Members See Also

Base class of object mappings used in Data Compare.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataCompareMappings(Of T As {Class, IDatabaseObject}) _
    Inherits Mappings(Of T, EngineDataCompareOptions)
C#
public abstract class DataCompareMappings<T> : Mappings<T, EngineDataCompareOptions> where T : class, IDatabaseObject
Visual C++
generic<typename T>
where T : ref class, IDatabaseObject
public ref class DataCompareMappings abstract : public Mappings<T, EngineDataCompareOptions^>

Type Parameters

T
The type stored in the mappings.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <(T>)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <(T>)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <(T, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings<(Of <(T>)>)
RedGate.SQLDataCompare.Engine..::.FieldMappings
RedGate.SQLDataCompare.Engine..::.IndexMappings
RedGate.SQLDataCompare.Engine..::.SchemaMappings
RedGate.SQLDataCompare.Engine..::.TableMappings

See Also

DataCompareMappings<(Of <(T>)>) Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Members

[image] [image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Members
DataCompareMappings<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also

The DataCompareMappings<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
DataCompareMappings<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings<(Of <(U>)>) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Attempts to join two objects in one mapping. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options |
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

DataCompareMappings<(Of <(T>)>) Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Constructor

[image] [image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Constructor
DataCompareMappings<(Of <(T>)>) Class See Also

Overload List

Name | Description
DataCompareMappings<(Of <(T>)>)()()() | Default constructor.
DataCompareMappings<(Of <(T>)>)(Mappings<(Of <(T, EngineDataCompareOptions>)>)) | Shallow copy constructor.
DataCompareMappings<(Of <(T>)>)(PrepareStringDelegate<(Of <(T, EngineDataCompareOptions>)>)) | Contructor used when string preparation delegate is being changed.

See Also

DataCompareMappings<(Of <(T>)>) Class
DataCompareMappings<(Of <(T>)>) Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Constructor

[image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Constructor
DataCompareMappings<(Of <(T>)>) Class See Also

Default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected DataCompareMappings()
Visual C++
protected:
DataCompareMappings()

See Also

DataCompareMappings<(Of <(T>)>) Class
DataCompareMappings<(Of <(T>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Constructor (Mappings(T, EngineDataCompareOptions))

[image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Constructor (Mappings<(Of <(T, EngineDataCompareOptions>)>))
DataCompareMappings<(Of <(T>)>) Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    mappings As Mappings(Of T, EngineDataCompareOptions) _
)
C#
protected DataCompareMappings(
    Mappings<T, EngineDataCompareOptions> mappings
)
Visual C++
protected:
DataCompareMappings(
    Mappings<T, EngineDataCompareOptions^>^ mappings
)

Parameters

mappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( T, EngineDataCompareOptions >)>)
Mappings to copy.

See Also

DataCompareMappings<(Of <(T>)>) Class
DataCompareMappings<(Of <(T>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Constructor (PrepareStringDelegate(T, EngineDataCompareOptions))

[image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Constructor (PrepareStringDelegate<(Of <(T, EngineDataCompareOptions>)>))
DataCompareMappings<(Of <(T>)>) Class See Also

Contructor used when string preparation delegate is being changed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    prepareStringDelegate As PrepareStringDelegate(Of T, EngineDataCompareOptions) _
)
C#
protected DataCompareMappings(
    PrepareStringDelegate<T, EngineDataCompareOptions> prepareStringDelegate
)
Visual C++
protected:
DataCompareMappings(
    PrepareStringDelegate<T, EngineDataCompareOptions^>^ prepareStringDelegate
)

Parameters

prepareStringDelegate
Type: RedGate.SQLCompare.Engine..::.PrepareStringDelegate <(Of <( T, EngineDataCompareOptions >)>)
Function to be used to prepare string.

See Also

DataCompareMappings<(Of <(T>)>) Class
DataCompareMappings<(Of <(T>)>) Overload
RedGate.SQLDataCompare.Engine Namespace


DataCompareMappings(T) Properties

[image] [image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>) Properties
DataCompareMappings<(Of <(T>)>) Class See Also

The DataCompareMappings<(Of <(T>)>) type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options |
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

DataCompareMappings<(Of <(T>)>) Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>)..::.Item Property
DataCompareMappings<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

DataCompareMappings<(Of <(T>)>) Class
DataCompareMappings<(Of <(T>)>) Members
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 7.1.0
DataCompareMappings<(Of <(T>)>)..::.Options Property
DataCompareMappings<(Of <(T>)>) Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

DataCompareMappings<(Of <(T>)>) Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Class

[image]

SQL Data Compare API 7.1.0
DataCompareVariant Class
Members See Also

Wrapper class for the SQL Variant data type.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class DataCompareVariant _
    Implements IComparable
C#
public class DataCompareVariant : IComparable
Visual C++
public ref class DataCompareVariant : IComparable

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.DataCompareVariant

See Also

DataCompareVariant Members
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Members

[image] [image]

SQL Data Compare API 7.1.0
DataCompareVariant Members
DataCompareVariant Class Methods Properties See Also

The DataCompareVariant type exposes the following members.

Methods

Name | Description
CompareTo | Compare the DataCompareVariant object with another object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Shows the string value of the DataCompareVariant object. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
BaseType | The base type of the underlying SQL Variant.
Collation | The collation of the SQL Variant.
MaxLength | The maximum data type length of the SQL Variant.
Precision | The precision of the SQL Variant.
Scale | The scale of the SQL Variant.
Value | The value of the SQL Variant.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Methods

[image] [image]

SQL Data Compare API 7.1.0
DataCompareVariant Methods
DataCompareVariant Class See Also

The DataCompareVariant type exposes the following methods.

Methods

Name | Description
CompareTo | Compare the DataCompareVariant object with another object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Shows the string value of the DataCompareVariant object. (Overrides Object ..::. ToString()()().)

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.CompareTo Method
DataCompareVariant Class See Also

Compare the DataCompareVariant object with another object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
The object to compare.

Return Value

Returns -1, 0, or 1.

Implements

IComparable..::.CompareTo(Object)

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.ToString Method
DataCompareVariant Class See Also

Shows the string value of the DataCompareVariant object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The string value of the the DataCompareVariant object.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DataCompareVariant Properties

[image] [image]

SQL Data Compare API 7.1.0
DataCompareVariant Properties
DataCompareVariant Class See Also

The DataCompareVariant type exposes the following properties.

Properties

Name | Description
BaseType | The base type of the underlying SQL Variant.
Collation | The collation of the SQL Variant.
MaxLength | The maximum data type length of the SQL Variant.
Precision | The precision of the SQL Variant.
Scale | The scale of the SQL Variant.
Value | The value of the SQL Variant.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


BaseType Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.BaseType Property
DataCompareVariant Class See Also

The base type of the underlying SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As String
C#
public string BaseType { get; }
Visual C++
public:
property String^ BaseType {
    String^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Collation Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.Collation Property
DataCompareVariant Class See Also

The collation of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Collation As String
C#
public string Collation { get; }
Visual C++
public:
property String^ Collation {
    String^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


MaxLength Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.MaxLength Property
DataCompareVariant Class See Also

The maximum data type length of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLength As Integer
C#
public int MaxLength { get; }
Visual C++
public:
property int MaxLength {
    int get ();
}

Remarks

MaxLength is in bytes so for example the MaxLength of nvarchar(50) is 100.

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Precision Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.Precision Property
DataCompareVariant Class See Also

The precision of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Integer
C#
public int Precision { get; }
Visual C++
public:
property int Precision {
    int get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Scale Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.Scale Property
DataCompareVariant Class See Also

The scale of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Integer
C#
public int Scale { get; }
Visual C++
public:
property int Scale {
    int get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


Value Property

[image]

SQL Data Compare API 7.1.0
DataCompareVariant..::.Value Property
DataCompareVariant Class See Also

The value of the SQL Variant.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public Object Value { get; }
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

DataCompareVariant Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Class

[image]

SQL Data Compare API 7.1.0
DifferencesSummary Class
Members See Also

Holds information about the differences in the ResultsStore .

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DifferencesSummary
C#
public sealed class DifferencesSummary
Visual C++
public ref class DifferencesSummary sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.DifferencesSummary

See Also

DifferencesSummary Members
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Members

[image] [image]

SQL Data Compare API 7.1.0
DifferencesSummary Members
DifferencesSummary Class Methods Properties See Also

The DifferencesSummary type exposes the following members.

Methods

Name | Description
DifferenceCount | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RepeatedKeys | If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Different | Obsolete. The number of rows that exist in both databases but are different.
In1 | Obsolete. The number of rows only in the second database.
In2 | Obsolete. The number of rows only in the first database.
Same | Obsolete. The number of rows that are the same in both databases.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Methods

[image] [image]

SQL Data Compare API 7.1.0
DifferencesSummary Methods
DifferencesSummary Class See Also

The DifferencesSummary type exposes the following methods.

Methods

Name | Description
DifferenceCount | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RepeatedKeys | If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method

[image] [image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.DifferenceCount Method
DifferencesSummary Class See Also

Overload List

Name | Description
DifferenceCount()()() | Returns the number of rows that are different.
DifferenceCount(FieldPair) | Returns the number of rows of the specified FieldPair that are different.
DifferenceCount(Row..::.RowType) | Returns the number of rows of the specified rowType that are different.
DifferenceCount(Row..::.RowType, FieldPair) | Returns the number of different fields of the specified RowType and FieldPair.

See Also

DifferencesSummary Class
DifferencesSummary Members
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.DifferenceCount Method
DifferencesSummary Class See Also

Returns the number of rows that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount As Integer
C#
public int DifferenceCount()
Visual C++
public:
int DifferenceCount()

Return Value

The number of rows that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (FieldPair)

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.DifferenceCount Method (FieldPair)
DifferencesSummary Class See Also

Returns the number of rows of the specified FieldPair that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    fieldPair As FieldPair _
) As Integer
C#
public int DifferenceCount(
    FieldPair fieldPair
)
Visual C++
public:
int DifferenceCount(
    FieldPair^ fieldPair
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The field for the count.

Return Value

The number of rows for the specified FieldPair that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (Row.RowType)

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.DifferenceCount Method (Row..::.RowType)
DifferencesSummary Class See Also

Returns the number of rows of the specified rowType that are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    rowType As Row..::.RowType _
) As Integer
C#
public int DifferenceCount(
    Row..::.RowType rowType
)
Visual C++
public:
int DifferenceCount(
    Row..::.RowType rowType
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of rows to be for the returned count.

Return Value

The number of rows of the specified rowType that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


DifferenceCount Method (Row.RowType, FieldPair)

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.DifferenceCount Method (Row..::.RowType, FieldPair)
DifferencesSummary Class See Also

Returns the number of different fields of the specified RowType and FieldPair.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function DifferenceCount ( _
    rowType As Row..::.RowType, _
    fieldPair As FieldPair _
) As Integer
C#
public int DifferenceCount(
    Row..::.RowType rowType,
    FieldPair fieldPair
)
Visual C++
public:
int DifferenceCount(
    Row..::.RowType rowType,
    FieldPair^ fieldPair
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of rows for the returned count.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair for which you want the count.

Return Value

The number of fields of the specified RowType and FieldPair that are different.

See Also

DifferencesSummary Class
DifferenceCount Overload
RedGate.SQLDataCompare.Engine Namespace


RepeatedKeys Method

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.RepeatedKeys Method
DifferencesSummary Class See Also

If true, the matching keys for the table were not unique, and therefore synchronization may not be possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function RepeatedKeys ( _
    runOnTwo As Boolean _
) As Boolean
C#
public bool RepeatedKeys(
    bool runOnTwo
)
Visual C++
public:
bool RepeatedKeys(
    bool runOnTwo
)

Parameters

runOnTwo
Type: System..::.Boolean
True to run on the second database.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Properties

[image] [image]

SQL Data Compare API 7.1.0
DifferencesSummary Properties
DifferencesSummary Class See Also

The DifferencesSummary type exposes the following properties.

Properties

Name | Description
Different | Obsolete. The number of rows that exist in both databases but are different.
In1 | Obsolete. The number of rows only in the second database.
In2 | Obsolete. The number of rows only in the first database.
Same | Obsolete. The number of rows that are the same in both databases.

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


Different Property

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.Different Property
DifferencesSummary Class See Also

The number of rows that exist in both databases but are different.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Different)")> _
Public ReadOnly Property Different As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Different)")]
public int Different { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.Different)")]
public:
property int Different {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


In1 Property

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.In1 Property
DifferencesSummary Class See Also

The number of rows only in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In1)")> _
Public ReadOnly Property In1 As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In1)")]
public int In1 { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.In1)")]
public:
property int In1 {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


In2 Property

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.In2 Property
DifferencesSummary Class See Also

The number of rows only in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In2)")> _
Public ReadOnly Property In2 As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.In2)")]
public int In2 { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.In2)")]
public:
property int In2 {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


Same Property

[image]

SQL Data Compare API 7.1.0
DifferencesSummary..::.Same Property
DifferencesSummary Class See Also

The number of rows that are the same in both databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Same)")> _
Public ReadOnly Property Same As Integer
C#
[ObsoleteAttribute("Please use DifferenceCount(Row.RowType.Same)")]
public int Same { get; }
Visual C++
[ObsoleteAttribute(L"Please use DifferenceCount(Row.RowType.Same)")]
public:
property int Same {
    int get ();
}

See Also

DifferencesSummary Class
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Class

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Class
Members See Also

Class containing the three options enumerations for the three stages in data comparison.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class EngineDataCompareOptions _
    Implements ISerializable, ICloneable
C#
[SerializableAttribute]
public sealed class EngineDataCompareOptions : ISerializable,
    ICloneable
Visual C++
[SerializableAttribute]
public ref class EngineDataCompareOptions sealed : ISerializable,
    ICloneable

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.EngineDataCompareOptions

See Also

EngineDataCompareOptions Members
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Members

[image] [image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Members
EngineDataCompareOptions Class Constructors Methods Properties See Also

The EngineDataCompareOptions type exposes the following members.

Constructors

Name | Description
EngineDataCompareOptions | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy of the options.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAvailableComparisonOptions | Returns a list of available options for comparing databases.
GetAvailableMappingOptions | Returns a list of available options for mapping databases.
GetAvailableSqlOptions | Returns a list of available options for generating the synchronization SQL script.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ComparisonOptions | Options that must be set before the databases are compared.
MappingOptions | Options that must be set before the databases are mapped.
SqlOptions | Options that must be set before the SQL script is generated.

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Constructor

[image] [image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Constructor
EngineDataCompareOptions Class See Also

Overload List

Name | Description
EngineDataCompareOptions()()() | Creates an options class and sets all of the options enumerations to default.
EngineDataCompareOptions(MappingOptions, ComparisonOptions, SqlOptions) | Creates an options class and sets all of the options enumerations to the parameters of the constructor.

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Members
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Constructor

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Constructor
EngineDataCompareOptions Class See Also

Creates an options class and sets all of the options enumerations to default.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EngineDataCompareOptions()
Visual C++
public:
EngineDataCompareOptions()

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Overload
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Constructor (MappingOptions, ComparisonOptions, SqlOptions)

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Constructor (MappingOptions, ComparisonOptions, SqlOptions)
EngineDataCompareOptions Class See Also

Creates an options class and sets all of the options enumerations to the parameters of the constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    mappingOptions As MappingOptions, _
    comparisonOptions As ComparisonOptions, _
    sqlOptions As SqlOptions _
)
C#
public EngineDataCompareOptions(
    MappingOptions mappingOptions,
    ComparisonOptions comparisonOptions,
    SqlOptions sqlOptions
)
Visual C++
public:
EngineDataCompareOptions(
    MappingOptions mappingOptions,
    ComparisonOptions comparisonOptions,
    SqlOptions sqlOptions
)

Parameters

mappingOptions
Type: RedGate.SQLDataCompare.Engine..::.MappingOptions
Options to use when mapping the databases.
comparisonOptions
Type: RedGate.SQLDataCompare.Engine..::.ComparisonOptions
Options to use when comparing the databases.
sqlOptions
Type: RedGate.SQLDataCompare.Engine..::.SqlOptions
Options to use when generating the synchronization SQL script.

See Also

EngineDataCompareOptions Class
EngineDataCompareOptions Overload
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Methods

[image] [image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Methods
EngineDataCompareOptions Class See Also

The EngineDataCompareOptions type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy of the options.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAvailableComparisonOptions | Returns a list of available options for comparing databases.
GetAvailableMappingOptions | Returns a list of available options for mapping databases.
GetAvailableSqlOptions | Returns a list of available options for generating the synchronization SQL script.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.Clone Method
EngineDataCompareOptions Class See Also

Creates a shallow copy of the options.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As Object
C#
public Object Clone()
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A shallow copy of the options.

Implements

ICloneable..::.Clone()()()

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


GetAvailableComparisonOptions Method

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.GetAvailableComparisonOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for comparing databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableComparisonOptions As ComparisonOptions()
C#
public static ComparisonOptions[] GetAvailableComparisonOptions()
Visual C++
public:
static array<ComparisonOptions>^ GetAvailableComparisonOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


GetAvailableMappingOptions Method

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.GetAvailableMappingOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for mapping databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableMappingOptions As MappingOptions()
C#
public static MappingOptions[] GetAvailableMappingOptions()
Visual C++
public:
static array<MappingOptions>^ GetAvailableMappingOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


GetAvailableSqlOptions Method

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.GetAvailableSqlOptions Method
EngineDataCompareOptions Class See Also

Returns a list of available options for generating the synchronization SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAvailableSqlOptions As SqlOptions()
C#
public static SqlOptions[] GetAvailableSqlOptions()
Visual C++
public:
static array<SqlOptions>^ GetAvailableSqlOptions()

Return Value

A list of options.

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.GetObjectData Method
EngineDataCompareOptions Class See Also

Gets serialization information with all of the data needed to recreate an instance of the EngineDataCompareOptions class.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object to be populated with serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination context of the serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


EngineDataCompareOptions Properties

[image] [image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions Properties
EngineDataCompareOptions Class See Also

The EngineDataCompareOptions type exposes the following properties.

Properties

Name | Description
ComparisonOptions | Options that must be set before the databases are compared.
MappingOptions | Options that must be set before the databases are mapped.
SqlOptions | Options that must be set before the SQL script is generated.

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


ComparisonOptions Property

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.ComparisonOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the databases are compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ComparisonOptions As ComparisonOptions
C#
public ComparisonOptions ComparisonOptions { get; set; }
Visual C++
public:
property ComparisonOptions ComparisonOptions {
    ComparisonOptions get ();
    void set (ComparisonOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


MappingOptions Property

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.MappingOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the databases are mapped.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MappingOptions As MappingOptions
C#
public MappingOptions MappingOptions { get; set; }
Visual C++
public:
property MappingOptions MappingOptions {
    MappingOptions get ();
    void set (MappingOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


SqlOptions Property

[image]

SQL Data Compare API 7.1.0
EngineDataCompareOptions..::.SqlOptions Property
EngineDataCompareOptions Class See Also

Options that must be set before the SQL script is generated.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlOptions As SqlOptions
C#
public SqlOptions SqlOptions { get; set; }
Visual C++
public:
property SqlOptions SqlOptions {
    SqlOptions get ();
    void set (SqlOptions value);
}

See Also

EngineDataCompareOptions Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Class

[image]

SQL Data Compare API 7.1.0
FieldMapping Class
Members See Also

Contains a mapping from a field in one table to a field in another table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldMapping _
    Inherits Mapping(Of Field)
C#
public class FieldMapping : Mapping<Field>
Visual C++
public ref class FieldMapping : public Mapping<Field^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( Field >)>)
RedGate.SQLDataCompare.Engine..::.FieldMapping

See Also

FieldMapping Members
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Members

[image] [image]

SQL Data Compare API 7.1.0
FieldMapping Members
FieldMapping Class Constructors Methods Properties See Also

The FieldMapping type exposes the following members.

Constructors

Name | Description
FieldMapping | Constructor. Calls the base constructor.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( Field >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( Field >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Constructor

[image]

SQL Data Compare API 7.1.0
FieldMapping Constructor
FieldMapping Class See Also

Constructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As Field, _
    obj2 As Field, _
    status As FieldMappingStatus _
)
C#
public FieldMapping(
    Field obj1,
    Field obj2,
    FieldMappingStatus status
)
Visual C++
public:
FieldMapping(
    Field^ obj1,
    Field^ obj2,
    FieldMappingStatus status
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.Field
The field in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.Field
The field in the second database.
status
Type: RedGate.SQLDataCompare.Engine..::.FieldMappingStatus
The status of the mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Methods

[image] [image]

SQL Data Compare API 7.1.0
FieldMapping Methods
FieldMapping Class See Also

The FieldMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy of the field mapping. (Overrides Mapping <(Of <( Field >)>)..::. Clone()()().)
CompareTo | Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database. (Overrides Mapping <(Of <( Field >)>)..::. CompareTo(Mapping<(Of <(T>)>)).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
FieldMapping..::.Clone Method
FieldMapping Class See Also

Creates a shallow copy of the field mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Object
C#
public override Object Clone()
Visual C++
public:
virtual Object^ Clone() override

Return Value

A shallow copy of the field mapping.

Implements

ICloneable..::.Clone()()()

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


CompareTo Method

[image]

SQL Data Compare API 7.1.0
FieldMapping..::.CompareTo Method
FieldMapping Class See Also

Sorts the FieldMappings by fully-qualified name in the first database; if null in the first database, sorts by fully-qualified name in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CompareTo ( _
    obj As Mapping(Of Field) _
) As Integer
C#
public override int CompareTo(
    Mapping<Field> obj
)
Visual C++
public:
virtual int CompareTo(
    Mapping<Field^>^ obj
) override

Parameters

obj
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( Field >)>)
The object to be compared.

Return Value

Less than zero when this instance is less than the specified object; zero when this instance is equal to the specified object; greater then zero when this instance is greater than the specified object.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMapping Properties

[image] [image]

SQL Data Compare API 7.1.0
FieldMapping Properties
FieldMapping Class See Also

The FieldMapping type exposes the following properties.

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the field mapping.
ValidForMatching | Specifies whether the FieldMapping can be used in a matching mapping.

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
FieldMapping..::.Status Property
FieldMapping Class See Also

The status of the field mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As FieldMappingStatus
C#
public FieldMappingStatus Status { get; }
Visual C++
public:
property FieldMappingStatus Status {
    FieldMappingStatus get ();
}

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


ValidForMatching Property

[image]

SQL Data Compare API 7.1.0
FieldMapping..::.ValidForMatching Property
FieldMapping Class See Also

Specifies whether the FieldMapping can be used in a matching mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property ValidForMatching As Boolean
C#
public bool ValidForMatching { get; internal set; }
Visual C++
public:
property bool ValidForMatching {
    bool get ();
    void set (bool value);
}

See Also

FieldMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Class

[image]

SQL Data Compare API 7.1.0
FieldMappings Class
Members See Also

Holds mappings for fields in a table or view.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class FieldMappings _
    Inherits DataCompareMappings(Of Field)
C#
public class FieldMappings : DataCompareMappings<Field>
Visual C++
public ref class FieldMappings : public DataCompareMappings<Field^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <( Field >)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( Field >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( Field, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( Field >)>)
RedGate.SQLDataCompare.Engine..::.FieldMappings

See Also

FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Members

[image] [image]

SQL Data Compare API 7.1.0
FieldMappings Members
FieldMappings Class Constructors Methods Properties Explicit Interface Implementations See Also

The FieldMappings type exposes the following members.

Constructors

Name | Description
FieldMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the FieldMappings instance. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::.OnValidate(Mapping<(Of <(UTP>)>)).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor

[image] [image]

SQL Data Compare API 7.1.0
FieldMappings Constructor
FieldMappings Class See Also

Overload List

Name | Description
FieldMappings(TableMapping) | The default constructor.
FieldMappings(TableMapping, Mappings<(Of <(Field, EngineDataCompareOptions>)>)) | Shallow copy constructor.
FieldMappings(TableMapping, FieldMappings, Boolean) | Shallow copy constructor for matching mappings.

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping)

[image]

SQL Data Compare API 7.1.0
FieldMappings Constructor (TableMapping)
FieldMappings Class See Also

The default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping _
)
C#
public FieldMappings(
    TableMapping parent
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping, Mappings(Field, EngineDataCompareOptions))

[image]

SQL Data Compare API 7.1.0
FieldMappings Constructor (TableMapping, Mappings<(Of <(Field, EngineDataCompareOptions>)>))
FieldMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping, _
    fieldMappings As Mappings(Of Field, EngineDataCompareOptions) _
)
C#
public FieldMappings(
    TableMapping parent,
    Mappings<Field, EngineDataCompareOptions> fieldMappings
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent,
    Mappings<Field^, EngineDataCompareOptions^>^ fieldMappings
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( Field, EngineDataCompareOptions >)>)
The field mappings to copy.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Constructor (TableMapping, FieldMappings, Boolean)

[image]

SQL Data Compare API 7.1.0
FieldMappings Constructor (TableMapping, FieldMappings, Boolean)
FieldMappings Class See Also

Shallow copy constructor for matching mappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As TableMapping, _
    fieldMappings As FieldMappings, _
    isMatching As Boolean _
)
C#
public FieldMappings(
    TableMapping parent,
    FieldMappings fieldMappings,
    bool isMatching
)
Visual C++
public:
FieldMappings(
    TableMapping^ parent,
    FieldMappings^ fieldMappings,
    bool isMatching
)

Parameters

parent
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
Table to which this FieldMappings class belongs.
fieldMappings
Type: RedGate.SQLDataCompare.Engine..::.FieldMappings
FieldMappings to copy.
isMatching
Type: System..::.Boolean
true for matching mappings; false otherwise.

See Also

FieldMappings Class
FieldMappings Overload
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Methods

[image] [image]

SQL Data Compare API 7.1.0
FieldMappings Methods
FieldMappings Class See Also

The FieldMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CanBeMapped | Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the FieldMappings instance. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnValidate | Performs additionl custom proccesses when validating a value. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::.OnValidate(Mapping<(Of <(UTP>)>)).)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Field, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


CanBeMapped Method

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.CanBeMapped Method
FieldMappings Class See Also

Returns true if the two fields can be mapped together because the types can be compared by the SQL Data Compare engine.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanBeMapped ( _
    field1 As Field, _
    field2 As Field _
) As Boolean
C#
public static bool CanBeMapped(
    Field field1,
    Field field2
)
Visual C++
public:
static bool CanBeMapped(
    Field^ field1,
    Field^ field2
)

Parameters

field1
Type: RedGate.SQLCompare.Engine..::.Field
The field from the first database.
field2
Type: RedGate.SQLCompare.Engine..::.Field
The field from the second database.

Return Value

true if the types are comparable; otherwise false.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.Clear Method
FieldMappings Class See Also

Removes all objects from the FieldMappings instance.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Remarks

If this FieldMapping is the matching mapping, it will also set the IndexMapping on the parent table class to null.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 7.1.0
FieldMappings..::.CreateMappings Method
FieldMappings Class See Also

Overload List

Name | Description
CreateMappings(Fields, Fields) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(KeyedCollection<(Of <(U>)>), KeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Fields, Fields)

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.CreateMappings Method (Fields, Fields)
FieldMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Fields, _
    in2 As Fields _
)
C#
public void CreateMappings(
    Fields in1,
    Fields in2
)
Visual C++
public:
void CreateMappings(
    Fields^ in1,
    Fields^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Fields
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Fields
List of objects in the second database, or null.

See Also

FieldMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.Join Method
FieldMappings Class See Also

Joins two fields in the different databases, and returns the created mapping. The mapping may not have its status set as Success if the field types are incompatible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    field1 As Field, _
    field2 As Field _
) As Mapping(Of Field)
C#
public override Mapping<Field> Join(
    Field field1,
    Field field2
)
Visual C++
public:
virtual Mapping<Field^>^ Join(
    Field^ field1,
    Field^ field2
) override

Parameters

field1
Type: RedGate.SQLCompare.Engine..::.Field
The field in the first database.
field2
Type: RedGate.SQLCompare.Engine..::.Field
The field in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
System..::.ArgumentException | FieldMappings. Join must be called with Field arguments.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


OnValidate Method

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.OnValidate Method
FieldMappings Class See Also

Performs additionl custom proccesses when validating a value.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Mapping(Of Field) _
)
C#
protected override void OnValidate(
    Mapping<Field> value
)
Visual C++
protected:
virtual void OnValidate(
    Mapping<Field^>^ value
) override

Parameters

value
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( Field >)>)
The object to validate.

Exceptions

Exception | Condition
System..::.ArgumentException | FieldMappings only supports FieldMapping objects.
System..::.ArgumentException | FieldMapping not valid for MatchingMappings

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 7.1.0
FieldMappings..::.ShouldInclude Method
FieldMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As Field, _
    obj2 As Field, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    Field obj1,
    Field obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    Field^ obj1,
    Field^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.Field
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.Field
object or null if obj1 not null.
extra
Type: System..::.Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

FieldMappings Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappingStatus Enumeration

[image]

SQL Data Compare API 7.1.0
FieldMappingStatus Enumeration
See Also

The result of the FieldMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FieldMappingStatus
C#
public enum FieldMappingStatus
Visual C++
public enum class FieldMappingStatus

Members

Member name | Description
Success | Mapping success.
UnableToCompare | Mapping succeeded but SQL Data Compare is still unable to compare the databases. This is usually because of type comparison failure.

See Also

RedGate.SQLDataCompare.Engine Namespace


FieldPair Class

[image]

SQL Data Compare API 7.1.0
FieldPair Class
Members See Also

Field definition used in the ResultsStore class.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldPair _
    Implements ISerializable
C#
[SerializableAttribute]
public sealed class FieldPair : ISerializable
Visual C++
[SerializableAttribute]
public ref class FieldPair sealed : ISerializable

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.FieldPair

See Also

FieldPair Members
RedGate.SQLDataCompare.Engine Namespace


FieldPair Members

[image] [image]

SQL Data Compare API 7.1.0
FieldPair Members
FieldPair Class Methods Properties See Also

The FieldPair type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EscapedFieldName | A convenience function that escapes the field name from the databases. Caches the result for speed improvement.
Field | A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data required to recreate an instance of this FieldPair.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnicode | Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SqlType | A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Type | A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

Properties

Name | Description
Field1 | The field from the first database.
Field2 | The field from the second database.
Matching | True if the FieldPair is used to match the databases.
OrdinalInResults1 | The ordinal in the ResultsStore for the field in the first database.
OrdinalInResults2 | The ordinal in the ResultsStore for the field in the second database.
SqlType1 | The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.
SqlType2 | The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.
Type1 | The ResultsStore type of the field in the first database.
Type2 | The ResultsStore type of the field in the second database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPair Methods

[image] [image]

SQL Data Compare API 7.1.0
FieldPair Methods
FieldPair Class See Also

The FieldPair type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EscapedFieldName | A convenience function that escapes the field name from the databases. Caches the result for speed improvement.
Field | A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data required to recreate an instance of this FieldPair.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsUnicode | Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SqlType | A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Type | A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


EscapedFieldName Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.EscapedFieldName Method
FieldPair Class See Also

A convenience function that escapes the field name from the databases. Caches the result for speed improvement.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function EscapedFieldName ( _
    onTwo As Boolean _
) As String
C#
public string EscapedFieldName(
    bool onTwo
)
Visual C++
public:
String^ EscapedFieldName(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for the second database; false for the first database.

Return Value

The escaped field name for the requested database; if null, the escaped field name for the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Field Method
FieldPair Class See Also

A convenience function for easy access to the first or second field in a FieldPair. Returns the requested field, or the field in the other database if the requested field is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Field ( _
    onTwo As Boolean _
) As Field
C#
public Field Field(
    bool onTwo
)
Visual C++
public:
Field^ Field(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for the second database; false for the first database.

Return Value

The field for the requested database; if this is null, the field for the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.GetObjectData Method
FieldPair Class See Also

Gets serialization information with all of the data required to recreate an instance of this FieldPair.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object to be populated with serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination context of the serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


IsUnicode Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.IsUnicode Method
FieldPair Class See Also

Returns true if the Field is Unicode (NChar, NText, NVarChar, XML, CLR).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsUnicode ( _
    onTwo As Boolean _
) As Boolean
C#
public bool IsUnicode(
    bool onTwo
)
Visual C++
public:
bool IsUnicode(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for the second database; false for the first database.

Return Value

true if the Field is Unicode; otherwise, false.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.SqlType Method
FieldPair Class See Also

A convenience function for easy access to the first or second SqlType in a FieldPair. Returns the requested SqlType, or the other SqlType if the requested field is null. Also de-references user-defined types.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlType ( _
    onTwo As Boolean _
) As SqlType
C#
public SqlType SqlType(
    bool onTwo
)
Visual C++
public:
SqlType SqlType(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for the second database; false for the first database.

Return Value

The SqlType for the field in the requested database; if null, the SqlType for the field in the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Type Method

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Type Method
FieldPair Class See Also

A convenience function for easy access to the first or second FieldType in a FieldPair. Returns the requested FieldType, or the FieldType for the other database if the requested FieldType is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Type ( _
    onTwo As Boolean _
) As FieldType
C#
public FieldType Type(
    bool onTwo
)
Visual C++
public:
FieldType Type(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for the second database; false for the first database.

Return Value

The FieldType for the field in the requested database; if null, the FieldType for the field in the other database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPair Properties

[image] [image]

SQL Data Compare API 7.1.0
FieldPair Properties
FieldPair Class See Also

The FieldPair type exposes the following properties.

Properties

Name | Description
Field1 | The field from the first database.
Field2 | The field from the second database.
Matching | True if the FieldPair is used to match the databases.
OrdinalInResults1 | The ordinal in the ResultsStore for the field in the first database.
OrdinalInResults2 | The ordinal in the ResultsStore for the field in the second database.
SqlType1 | The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.
SqlType2 | The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.
Type1 | The ResultsStore type of the field in the first database.
Type2 | The ResultsStore type of the field in the second database.

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field1 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Field1 Property
FieldPair Class See Also

The field from the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field1 As Field
C#
public Field Field1 { get; }
Visual C++
public:
property Field^ Field1 {
    Field^ get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Field2 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Field2 Property
FieldPair Class See Also

The field from the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field2 As Field
C#
public Field Field2 { get; }
Visual C++
public:
property Field^ Field2 {
    Field^ get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Matching Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Matching Property
FieldPair Class See Also

True if the FieldPair is used to match the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Matching As Boolean
C#
public bool Matching { get; }
Visual C++
public:
property bool Matching {
    bool get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


OrdinalInResults1 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.OrdinalInResults1 Property
FieldPair Class See Also

The ordinal in the ResultsStore for the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalInResults1 As Integer
C#
public int OrdinalInResults1 { get; }
Visual C++
public:
property int OrdinalInResults1 {
    int get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


OrdinalInResults2 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.OrdinalInResults2 Property
FieldPair Class See Also

The ordinal in the ResultsStore for the field in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalInResults2 As Integer
C#
public int OrdinalInResults2 { get; }
Visual C++
public:
property int OrdinalInResults2 {
    int get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType1 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.SqlType1 Property
FieldPair Class See Also

The SqlType of the field in the first database, or the underlying SqlType of the User Defined Type of the field.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlType1 As SqlType
C#
public SqlType SqlType1 { get; }
Visual C++
public:
property SqlType SqlType1 {
    SqlType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


SqlType2 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.SqlType2 Property
FieldPair Class See Also

The SqlType of the field in the second database, or the SqlType of the User Defined Type of the field.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlType2 As SqlType
C#
public SqlType SqlType2 { get; }
Visual C++
public:
property SqlType SqlType2 {
    SqlType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Type1 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Type1 Property
FieldPair Class See Also

The ResultsStore type of the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type1 As FieldType
C#
public FieldType Type1 { get; }
Visual C++
public:
property FieldType Type1 {
    FieldType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


Type2 Property

[image]

SQL Data Compare API 7.1.0
FieldPair..::.Type2 Property
FieldPair Class See Also

The ResultsStore type of the field in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type2 As FieldType
C#
public FieldType Type2 { get; }
Visual C++
public:
property FieldType Type2 {
    FieldType get ();
}

See Also

FieldPair Class
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Class

[image]

SQL Data Compare API 7.1.0
FieldPairs Class
Members See Also

A collection of FieldPair objects.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public NotInheritable Class FieldPairs _
    Inherits InnerList(Of FieldPair) _
    Implements ISerializable
C#
[SerializableAttribute]
public sealed class FieldPairs : InnerList<FieldPair>, ISerializable
Visual C++
[SerializableAttribute]
public ref class FieldPairs sealed : public InnerList<FieldPair^>,
    ISerializable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( FieldPair >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( FieldPair >)>)
RedGate.SQLDataCompare.Engine..::.FieldPairs

See Also

FieldPairs Members
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Members

[image] [image]

SQL Data Compare API 7.1.0
FieldPairs Members
FieldPairs Class Methods Properties Explicit Interface Implementations See Also

The FieldPairs type exposes the following members.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( FieldPair >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
OrdinalCount | Returns the number of unique field ordinals in the small fields collection.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Methods

[image] [image]

SQL Data Compare API 7.1.0
FieldPairs Methods
FieldPairs Class See Also

The FieldPairs type exposes the following methods.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( FieldPair >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 7.1.0
FieldPairs..::.Add Method
FieldPairs Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As FieldPair _
)
C#
public override void Add(
    FieldPair value
)
Visual C++
public:
virtual void Add(
    FieldPair^ value
) override

Parameters

value
Type: RedGate.SQLDataCompare.Engine..::.FieldPair

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


GetObjectData Method

[image]

SQL Data Compare API 7.1.0
FieldPairs..::.GetObjectData Method
FieldPairs Class See Also

Gets serialization information with all of the data needed to recreate an instance of the FieldPairs collection.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object to be populated with serialization information.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination context of the serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


FieldPairs Properties

[image] [image]

SQL Data Compare API 7.1.0
FieldPairs Properties
FieldPairs Class See Also

The FieldPairs type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
OrdinalCount | Returns the number of unique field ordinals in the small fields collection.

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
FieldPairs..::.Item Property
FieldPairs Class See Also

Overload List

Name | Description
Item[([(Int32])]) | (Inherited from InnerList<(Of <(T>)>).)
Item[([(String])]) | Gets the FieldPair at the specified index.

See Also

FieldPairs Class
FieldPairs Members
RedGate.SQLDataCompare.Engine Namespace


Item Property (String)

[image]

SQL Data Compare API 7.1.0
FieldPairs..::.Item Property (String)
FieldPairs Class See Also

Gets the FieldPair at the specified index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As FieldPair
C#
public FieldPair this[
    string name
] { get; }
Visual C++
public:
property FieldPair^ default[String^ name] {
    FieldPair^ get (String^ name);
}

Parameters

name
Type: System..::.String
The string-based index of the FieldPair to get.

See Also

FieldPairs Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


OrdinalCount Property

[image]

SQL Data Compare API 7.1.0
FieldPairs..::.OrdinalCount Property
FieldPairs Class See Also

Returns the number of unique field ordinals in the small fields collection.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrdinalCount As Integer
C#
public int OrdinalCount { get; }
Visual C++
public:
property int OrdinalCount {
    int get ();
}

Return Value

number of ordinals.

See Also

FieldPairs Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Class

[image]

SQL Data Compare API 7.1.0
IndexMapping Class
Members See Also

Contains a mapping between the indexes in the different databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexMapping _
    Inherits Mapping(Of Index)
C#
public class IndexMapping : Mapping<Index>
Visual C++
public ref class IndexMapping : public Mapping<Index^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( Index >)>)
RedGate.SQLDataCompare.Engine..::.IndexMapping

See Also

IndexMapping Members
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Members

[image] [image]

SQL Data Compare API 7.1.0
IndexMapping Members
IndexMapping Class Constructors Methods Properties See Also

The IndexMapping type exposes the following members.

Constructors

Name | Description
IndexMapping | Overloaded.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( Index >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the index name from the first database, or if null, from the second database. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor

[image] [image]

SQL Data Compare API 7.1.0
IndexMapping Constructor
IndexMapping Class See Also

Overload List

Name | Description
IndexMapping(Mapping<(Of <(Index>)>)) | Copy constructor.
IndexMapping(Index, Index) | Contructor. Calls the base constructor.

See Also

IndexMapping Class
IndexMapping Members
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor (Mapping(Index))

[image]

SQL Data Compare API 7.1.0
IndexMapping Constructor (Mapping<(Of <(Index>)>))
IndexMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    copy As Mapping(Of Index) _
)
C#
protected IndexMapping(
    Mapping<Index> copy
)
Visual C++
protected:
IndexMapping(
    Mapping<Index^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( Index >)>)
IndexMapping to copy.

See Also

IndexMapping Class
IndexMapping Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Constructor (Index, Index)

[image]

SQL Data Compare API 7.1.0
IndexMapping Constructor (Index, Index)
IndexMapping Class See Also

Contructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As Index, _
    obj2 As Index _
)
C#
public IndexMapping(
    Index obj1,
    Index obj2
)
Visual C++
public:
IndexMapping(
    Index^ obj1,
    Index^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.Index
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.Index
The index in the second database.

See Also

IndexMapping Class
IndexMapping Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Methods

[image] [image]

SQL Data Compare API 7.1.0
IndexMapping Methods
IndexMapping Class See Also

The IndexMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( Index >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the index name from the first database, or if null, from the second database. (Overrides Object ..::. ToString()()().)

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
IndexMapping..::.Clone Method
IndexMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Object
C#
public override Object Clone()
Visual C++
public:
virtual Object^ Clone() override

Return Value

A shallow copy.

Implements

ICloneable..::.Clone()()()

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
IndexMapping..::.ToString Method
IndexMapping Class See Also

Returns the index name from the first database, or if null, from the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The name of the index.

See Also

IndexMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Class

[image]

SQL Data Compare API 7.1.0
IndexMappings Class
Members See Also

Holds mappings of indexes. The indexes must be PrimaryKey, Unique, or UniqueConstraint to be included. The names of the indexes are not used for the mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class IndexMappings _
    Inherits DataCompareMappings(Of Index)
C#
public class IndexMappings : DataCompareMappings<Index>
Visual C++
public ref class IndexMappings : public DataCompareMappings<Index^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <( Index >)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( Index >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( Index, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( Index >)>)
RedGate.SQLDataCompare.Engine..::.IndexMappings

See Also

IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Members

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings Members
IndexMappings Class Constructors Methods Properties Explicit Interface Implementations See Also

The IndexMappings type exposes the following members.

Constructors

Name | Description
IndexMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the IndexMappings instance. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
PrimaryKey | Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings Constructor
IndexMappings Class See Also

Overload List

Name | Description
IndexMappings(IndexMappings) | Shallow copy constructor.
IndexMappings(TableMapping) | Creates an IndexMapping.

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor (IndexMappings)

[image]

SQL Data Compare API 7.1.0
IndexMappings Constructor (IndexMappings)
IndexMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    indexMappings As IndexMappings _
)
C#
public IndexMappings(
    IndexMappings indexMappings
)
Visual C++
public:
IndexMappings(
    IndexMappings^ indexMappings
)

Parameters

indexMappings
Type: RedGate.SQLDataCompare.Engine..::.IndexMappings
The IndexMappings to copy.

See Also

IndexMappings Class
IndexMappings Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Constructor (TableMapping)

[image]

SQL Data Compare API 7.1.0
IndexMappings Constructor (TableMapping)
IndexMappings Class See Also

Creates an IndexMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parentTable As TableMapping _
)
C#
public IndexMappings(
    TableMapping parentTable
)
Visual C++
public:
IndexMappings(
    TableMapping^ parentTable
)

Parameters

parentTable
Type: RedGate.SQLDataCompare.Engine..::.TableMapping
The parent table mapping.

See Also

IndexMappings Class
IndexMappings Overload
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Methods

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings Methods
IndexMappings Class See Also

The IndexMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the IndexMappings instance. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::. Clear()()().)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( Index, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


Clear Method

[image]

SQL Data Compare API 7.1.0
IndexMappings..::.Clear Method
IndexMappings Class See Also

Removes all objects from the IndexMappings instance.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

Remarks

If there is an index mapping, also sets the IndexMapping on the parent table class to null, and clears the MatchingMappings.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings..::.CreateMappings Method
IndexMappings Class See Also

Overload List

Name | Description
CreateMappings(Indexes, Indexes) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(KeyedCollection<(Of <(U>)>), KeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Indexes, Indexes)

[image]

SQL Data Compare API 7.1.0
IndexMappings..::.CreateMappings Method (Indexes, Indexes)
IndexMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Indexes, _
    in2 As Indexes _
)
C#
public void CreateMappings(
    Indexes in1,
    Indexes in2
)
Visual C++
public:
void CreateMappings(
    Indexes^ in1,
    Indexes^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Indexes
A list of the objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Indexes
A list of the objects in the second database, or null.

See Also

IndexMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 7.1.0
IndexMappings..::.Join Method
IndexMappings Class See Also

Joins two indexes in different databases. Returns the created mapping. The mapping created may not have its status set as Success. If the indexes are both primary keys, the parent table will have UseIndexForMapping called for this index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    index1 As Index, _
    index2 As Index _
) As Mapping(Of Index)
C#
public override Mapping<Index> Join(
    Index index1,
    Index index2
)
Visual C++
public:
virtual Mapping<Index^>^ Join(
    Index^ index1,
    Index^ index2
) override

Parameters

index1
Type: RedGate.SQLCompare.Engine..::.Index
The index from the first database.
index2
Type: RedGate.SQLCompare.Engine..::.Index
The index from the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
System..::.ArgumentException | IndexMappings.Join must called with Field arguments.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 7.1.0
IndexMappings..::.ShouldInclude Method
IndexMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As Index, _
    obj2 As Index, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    Index obj1,
    Index obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    Index^ obj1,
    Index^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.Index
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.Index
object or null if obj1 not null.
extra
Type: System..::.Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


IndexMappings Properties

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings Properties
IndexMappings Class See Also

The IndexMappings type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
PrimaryKey | Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
IndexMappings..::.Item Property
IndexMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

IndexMappings Class
IndexMappings Members
RedGate.SQLDataCompare.Engine Namespace


PrimaryKey Property

[image]

SQL Data Compare API 7.1.0
IndexMappings..::.PrimaryKey Property
IndexMappings Class See Also

Contains a reference to the mapping that is identified as a usable primary key shared on both tables; null if no usable primary key is found.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrimaryKey As IndexMapping
C#
public IndexMapping PrimaryKey { get; }
Visual C++
public:
property IndexMapping^ PrimaryKey {
    IndexMapping^ get ();
}

See Also

IndexMappings Class
RedGate.SQLDataCompare.Engine Namespace


MappingOptions Enumeration

[image]

SQL Data Compare API 7.1.0
MappingOptions Enumeration
See Also

Options used when generating the mapping between two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MappingOptions
C#
[FlagsAttribute]
public enum MappingOptions
Visual C++
[FlagsAttribute]
public enum class MappingOptions

Members

Member name Description
Default

The default options when generating the mappings. These are:

  • IgnoreCase
  • IgnoreSpaces
  • IncludeIdentities
  • IncludeTimestamps
None
None.
IgnoreCase
Ignores the case of the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget] is considered to be the same as [dbo].[widget] when you select this option.
IgnoreSpaces
Ignores the spaces in the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget Prices] is considered to be the same as [dbo].[WidgetPrices] when you select this option.
IgnoreUnderscores
Ignores the underscores in the object names (tables, views, users, roles, schemas, indexes, and columns) when mapping. For example, [dbo].[Widget_Prices] is considered to be the same as [dbo].[WidgetPrices] when you select this option.
MissingFrom2AsInclude
When the object does not exist in the second database, the Mapping status is set to success and include is set to true.
IncludeTimestamps
Includes timestamp columns from the tables or views in the schema information for the database. Timestamp columns cannot be synchronized.
IncludeIndexedViews
Includes views in the schema information for the database. Views can be synchronized only if the referenced rows are from a single table, and the referenced columns are simple (for example, they must not include identity columns or computed columns).
IncludeIdentities
Includes identity columns from the tables or views in the schema information for the database. You cannot synchronize views if they include an identity column.

See Also

RedGate.SQLDataCompare.Engine Namespace


Project Class

[image]

SQL Data Compare API 7.1.0
Project Class
Members Example See Also

A SQL Data Compare project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Project _
    Implements IEquatable(Of Project)
C#
public class Project : IEquatable<Project>
Visual C++
public ref class Project : IEquatable<Project^>

Remarks

This class provides an easy way to load and save comparison settings.

Examples

Saving a project to, and loading from, disk
C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using Project = RedGate.SQLDataCompare.Engine.Project;

            namespace SQLDataCompareCodeSnippets
            {
                /// <summary>
                /// Summary description for ProjectExample.
                /// </summary>
                public class ProjectExample
                {
                    public void RunExample()
                    {
                        Project project=new Project();

                        project.DataSource1.DatabaseName = "WidgetDev";
                        project.DataSource2.DatabaseName = "WidgetLive";
                        project.SessionSettings = SessionSettings.Default;
                        project.Options = new EngineDataCompareOptions(MappingOptions.Default,ComparisonOptions.Default, SqlOptions.Default);
                        Console.WriteLine("Saving project");
                        project.SaveToDisk(@"c:\testproject.sdc");

                        //load up the project
                        Project project2=Project.LoadFromDisk(@"c:\testproject.sdc");
                        Console.WriteLine("Project loaded");

                        //get the two databases
                        Database db1= new Database();
                        Database db2= new Database();
                        SchemaMappings mappings = new SchemaMappings();

                        //Should check if this is true
                        LiveDatabaseSource liveDb = project2.DataSource1 as LiveDatabaseSource;
                        db1.RegisterForDataCompare(liveDb.ToConnectionProperties());

                        //Should check if this is true
                        liveDb = project2.DataSource2 as LiveDatabaseSource;
                        db2.RegisterForDataCompare(liveDb.ToConnectionProperties());

                        mappings.Options = project2.Options;
                        mappings.CreateMappings(db1, db2);

                        //Disable any mappings here that you may want....
                        ComparisonSession session=new ComparisonSession();
                        session.Options = project2.Options;
                        session.CompareDatabases(db1, db2, mappings);

                        Console.WriteLine("Comparison run");
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports Project = RedGate.SQLDataCompare.Engine.Project

            Public Class ProjectExample
                Sub RunExample()
                    Dim project As New Project

                    project.DataSource1.DatabaseName = "WidgetDev"
                    project.DataSource2.DatabaseName = "WidgetLive"
                    project.SessionSettings = SessionSettings.Default
                    project.Options = New EngineDataCompareOptions(MappingOptions.Default, ComparisonOptions.Default, SqlOptions.Default)
                    Console.WriteLine("Saving project")
                    project.SaveToDisk("c:\testproject.sdc")

                    'load up the project
                    Dim project2 As Project = project.LoadFromDisk("c:\testproject.sdc")
                    Console.WriteLine("Project loaded")

                    'get the two databases
                    Dim db1 As New Database
                    Dim db2 As New Database
                    Dim mappings As New SchemaMappings

                    'Should check if this is true
                    Dim livedb As LiveDatabaseSource = DirectCast(project2.DataSource1, LiveDatabaseSource)
                    db1.RegisterForDataCompare(livedb.ToConnectionProperties())

                    'Should check if this is true
                    livedb = DirectCast(project2.DataSource2, LiveDatabaseSource)
                    db2.RegisterForDataCompare(livedb.ToConnectionProperties())

                    mappings.Options = project2.Options
                    mappings.CreateMappings(db1, db2)

                    'Disable any mappings here that you may want....
                    Dim session As New ComparisonSession
                    session.Options = project2.Options
                    session.CompareDatabases(db1, db2, mappings)

                    Console.WriteLine("Comparison run")
                End Sub
            End Class

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.Project

See Also

Project Members
RedGate.SQLDataCompare.Engine Namespace


Project Members

[image] [image]

SQL Data Compare API 7.1.0
Project Members
Project Class Constructors Methods Properties See Also

The Project type exposes the following members.

Constructors

Name | Description
Project | Constructor.

Methods

Name | Description
Deserialize | Support for serialization.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk. If the file cannot be found in the current folder, SQL Data Compare looks in the ProjectFolder for the file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReplayUserActions | Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.
SaveToDisk | Saves the project to disk.
Serialize | Support for serialization.
ToString | Returns a string representation of the project. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Changed | True if the project has changes that have not yet been saved.
DataSource1 | The connection properties for the first database being compared.
DataSource2 | The connection properties for the second database being compared.
Direction | The direction in which the project migrates the changes to synchronize the databases.
FileName | The file name of the project if it has been saved. If the project has not been saved then the file name is String.Empty
IsNewProject | True if the project has not yet been saved.
LastCompared | The time at which the project was last compared.
Name | The name of the project.
Options | The options used when running the engine.
SessionSettings | The session settings used in the project comparison.
UserNote | A note relating to this project.
Version | The current project version. Used during serialization.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Project Constructor

[image]

SQL Data Compare API 7.1.0
Project Constructor
Project Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Project()
Visual C++
public:
Project()

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Project Methods

[image] [image]

SQL Data Compare API 7.1.0
Project Methods
Project Class See Also

The Project type exposes the following methods.

Methods

Name | Description
Deserialize | Support for serialization.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromDisk | Loads a project from disk. If the file cannot be found in the current folder, SQL Data Compare looks in the ProjectFolder for the file.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReplayUserActions | Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.
SaveToDisk | Saves the project to disk.
Serialize | Support for serialization.
ToString | Returns a string representation of the project. (Overrides Object ..::. ToString()()().)

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Deserialize Method

[image]

SQL Data Compare API 7.1.0
Project..::.Deserialize Method
Project Class See Also

Support for serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize ( _
    nVersionId As Integer, _
    formatter As ISerializeFormatter _
) As Boolean
C#
public bool Deserialize(
    int nVersionId,
    ISerializeFormatter formatter
)
Visual C++
public:
virtual bool Deserialize(
    int nVersionId,
    ISerializeFormatter^ formatter
) sealed

Parameters

nVersionId
Type: System..::.Int32
The version of the project that is being de-serialized.
formatter
Type: ISerializeFormatter
The formatter to read from.

Return Value

true on success.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
Project..::.Equals Method
Project Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Project) | Indicates whether the current project is equal to another project. If the file names are the same, then the projects are the same project.

See Also

Project Class
Project Members
RedGate.SQLDataCompare.Engine Namespace


Equals Method (Project)

[image]

SQL Data Compare API 7.1.0
Project..::.Equals Method (Project)
Project Class See Also

Indicates whether the current project is equal to another project. If the file names are the same, then the projects are the same project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As Project _
) As Boolean
C#
public bool Equals(
    Project other
)
Visual C++
public:
virtual bool Equals(
    Project^ other
) sealed

Parameters

other
Type: RedGate.SQLDataCompare.Engine..::.Project
A project to compare with this project.

Return Value

true if the current project is equal to the value specified in other; otherwise, false.

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

Project Class
Equals Overload
RedGate.SQLDataCompare.Engine Namespace


LoadFromDisk Method

[image]

SQL Data Compare API 7.1.0
Project..::.LoadFromDisk Method
Project Class See Also

Loads a project from disk. If the file cannot be found in the current folder, SQL Data Compare looks in the ProjectFolder for the file.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromDisk ( _
    fileName As String _
) As Project
C#
public static Project LoadFromDisk(
    string fileName
)
Visual C++
public:
static Project^ LoadFromDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file name of the project.

Return Value

A Project object.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


ReplayUserActions Method

[image]

SQL Data Compare API 7.1.0
Project..::.ReplayUserActions Method
Project Class See Also

Replays the selections, custom mappings, and WHERE clause settings that the user has made before saving the project. Modifies the passed SchemaMappings to reflect the user changes.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function ReplayUserActions ( _
    ByRef schemaMappings As SchemaMappings _
) As List(Of UserActionWarning)
C#
public List<UserActionWarning> ReplayUserActions(
    ref SchemaMappings schemaMappings
)
Visual C++
public:
List<UserActionWarning>^ ReplayUserActions(
    SchemaMappings^% schemaMappings
)

Parameters

schemaMappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings %

Return Value

A list of the selections, custom mappings, and WHERE clause settings that could not be replayed due to changes in the database schema.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


SaveToDisk Method

[image]

SQL Data Compare API 7.1.0
Project..::.SaveToDisk Method
Project Class See Also

Saves the project to disk.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToDisk ( _
    fileName As String _
)
C#
public void SaveToDisk(
    string fileName
)
Visual C++
public:
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The file name for the project.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Serialize Method

[image]

SQL Data Compare API 7.1.0
Project..::.Serialize Method
Project Class See Also

Support for serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Serialize ( _
    formatter As ISerializeFormatter _
)
C#
public void Serialize(
    ISerializeFormatter formatter
)
Visual C++
public:
virtual void Serialize(
    ISerializeFormatter^ formatter
) sealed

Parameters

formatter
Type: ISerializeFormatter
The formatter to write to.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
Project..::.ToString Method
Project Class See Also

Returns a string representation of the project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

Returns a string representation of the project.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Project Properties

[image] [image]

SQL Data Compare API 7.1.0
Project Properties
Project Class See Also

The Project type exposes the following properties.

Properties

Name | Description
Changed | True if the project has changes that have not yet been saved.
DataSource1 | The connection properties for the first database being compared.
DataSource2 | The connection properties for the second database being compared.
Direction | The direction in which the project migrates the changes to synchronize the databases.
FileName | The file name of the project if it has been saved. If the project has not been saved then the file name is String.Empty
IsNewProject | True if the project has not yet been saved.
LastCompared | The time at which the project was last compared.
Name | The name of the project.
Options | The options used when running the engine.
SessionSettings | The session settings used in the project comparison.
UserNote | A note relating to this project.
Version | The current project version. Used during serialization.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Changed Property

[image]

SQL Data Compare API 7.1.0
Project..::.Changed Property
Project Class See Also

True if the project has changes that have not yet been saved.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Changed As Boolean
C#
public bool Changed { get; set; }
Visual C++
public:
property bool Changed {
    bool get ();
    void set (bool value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


DataSource1 Property

[image]

SQL Data Compare API 7.1.0
Project..::.DataSource1 Property
Project Class See Also

The connection properties for the first database being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource1 As DataSource
C#
public DataSource DataSource1 { get; set; }
Visual C++
public:
property DataSource^ DataSource1 {
    DataSource^ get ();
    void set (DataSource^ value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


DataSource2 Property

[image]

SQL Data Compare API 7.1.0
Project..::.DataSource2 Property
Project Class See Also

The connection properties for the second database being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSource2 As DataSource
C#
public DataSource DataSource2 { get; set; }
Visual C++
public:
property DataSource^ DataSource2 {
    DataSource^ get ();
    void set (DataSource^ value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Direction Property

[image]

SQL Data Compare API 7.1.0
Project..::.Direction Property
Project Class See Also

The direction in which the project migrates the changes to synchronize the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Direction As SynchronizationDirection
C#
public SynchronizationDirection Direction { get; set; }
Visual C++
public:
property SynchronizationDirection Direction {
    SynchronizationDirection get ();
    void set (SynchronizationDirection value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


FileName Property

[image]

SQL Data Compare API 7.1.0
Project..::.FileName Property
Project Class See Also

The file name of the project if it has been saved. If the project has not been saved then the file name is String.Empty

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


IsNewProject Property

[image]

SQL Data Compare API 7.1.0
Project..::.IsNewProject Property
Project Class See Also

True if the project has not yet been saved.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNewProject As Boolean
C#
public bool IsNewProject { get; }
Visual C++
public:
property bool IsNewProject {
    bool get ();
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


LastCompared Property

[image]

SQL Data Compare API 7.1.0
Project..::.LastCompared Property
Project Class See Also

The time at which the project was last compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property LastCompared As DateTime
C#
public DateTime LastCompared { get; set; }
Visual C++
public:
property DateTime LastCompared {
    DateTime get ();
    void set (DateTime value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
Project..::.Name Property
Project Class See Also

The name of the project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

The file name leaf, or New Project.

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 7.1.0
Project..::.Options Property
Project Class See Also

The options used when running the engine.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


SessionSettings Property

[image]

SQL Data Compare API 7.1.0
Project..::.SessionSettings Property
Project Class See Also

The session settings used in the project comparison.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SessionSettings As SessionSettings
C#
public SessionSettings SessionSettings { get; set; }
Visual C++
public:
property SessionSettings SessionSettings {
    SessionSettings get ();
    void set (SessionSettings value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


UserNote Property

[image]

SQL Data Compare API 7.1.0
Project..::.UserNote Property
Project Class See Also

A note relating to this project.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property UserNote As String
C#
public string UserNote { get; set; }
Visual C++
public:
property String^ UserNote {
    String^ get ();
    void set (String^ value);
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


Version Property

[image]

SQL Data Compare API 7.1.0
Project..::.Version Property
Project Class See Also

The current project version. Used during serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Integer
C#
public int Version { get; }
Visual C++
public:
virtual property int Version {
    int get () sealed;
}

See Also

Project Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Class

[image]

SQL Data Compare API 7.1.0
SchemaMapping Class
Members See Also

Contains a mapping between the schema, user, or role in two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Please use Mapping<IOwner> instead", True)> _
Public Class SchemaMapping _
    Inherits Mapping(Of IOwner)
C#
[ObsoleteAttribute("Please use Mapping<IOwner> instead", true)]
public class SchemaMapping : Mapping<IOwner>
Visual C++
[ObsoleteAttribute(L"Please use Mapping<IOwner> instead", true)]
public ref class SchemaMapping : public Mapping<IOwner^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
RedGate.SQLDataCompare.Engine..::.SchemaMapping

See Also

SchemaMapping Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Members

[image] [image]

SQL Data Compare API 7.1.0
SchemaMapping Members
SchemaMapping Class Constructors Methods Properties See Also

The SchemaMapping type exposes the following members.

Constructors

Name | Description
SchemaMapping | Overloaded.

Methods

Name | Description
Clone | (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Include | Specifies whether the mapping is to be included. (Inherited from Mapping<(Of <(T>)>).)
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor

[image] [image]

SQL Data Compare API 7.1.0
SchemaMapping Constructor
SchemaMapping Class See Also

Overload List

Name | Description
SchemaMapping(Mapping<(Of <(IOwner>)>)) | Copy constructor.
SchemaMapping(IOwner, IOwner) | Contructor. Calls the base constructor.

See Also

SchemaMapping Class
SchemaMapping Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor (Mapping(IOwner))

[image]

SQL Data Compare API 7.1.0
SchemaMapping Constructor (Mapping<(Of <(IOwner>)>))
SchemaMapping Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    copy As Mapping(Of IOwner) _
)
C#
public SchemaMapping(
    Mapping<IOwner> copy
)
Visual C++
public:
SchemaMapping(
    Mapping<IOwner^>^ copy
)

Parameters

copy
Type: RedGate.SQLCompare.Engine..::.Mapping <(Of <( IOwner >)>)
SchemaMapping to copy.

See Also

SchemaMapping Class
SchemaMapping Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Constructor (IOwner, IOwner)

[image]

SQL Data Compare API 7.1.0
SchemaMapping Constructor (IOwner, IOwner)
SchemaMapping Class See Also

Contructor. Calls the base constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As IOwner, _
    obj2 As IOwner _
)
C#
public SchemaMapping(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
SchemaMapping(
    IOwner^ obj1,
    IOwner^ obj2
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The index in the second database.

See Also

SchemaMapping Class
SchemaMapping Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMapping Methods

[image] [image]

SQL Data Compare API 7.1.0
SchemaMapping Methods
SchemaMapping Class See Also

The SchemaMapping type exposes the following methods.

Methods

Name | Description
Clone | (Overrides Mapping <(Of <( IOwner >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
SchemaMapping..::.Clone Method
SchemaMapping Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Object
C#
public override Object Clone()
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

SchemaMapping Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Class

[image]

SQL Data Compare API 7.1.0
SchemaMappings Class
Members See Also

Holds mappings for schemas, users, or roles. Uses the database objects to create the mappings for the views and the tables from the two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SchemaMappings _
    Inherits DataCompareMappings(Of IOwner)
C#
public class SchemaMappings : DataCompareMappings<IOwner>
Visual C++
public ref class SchemaMappings : public DataCompareMappings<IOwner^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( IOwner >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( IOwner, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( IOwner >)>)
RedGate.SQLDataCompare.Engine..::.SchemaMappings

See Also

SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Members

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings Members
SchemaMappings Class Constructors Methods Properties Explicit Interface Implementations See Also

The SchemaMappings type exposes the following members.

Constructors

Name | Description
SchemaMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views. (Overrides Mappings <(Of <( IOwner, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( IOwner, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
TableMappings | Returns the table mappings for the databases.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings Constructor
SchemaMappings Class See Also

Overload List

Name | Description
SchemaMappings()()() | The default constructor.
SchemaMappings(SchemaMappings) | Shallow copy constructor.

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor

[image]

SQL Data Compare API 7.1.0
SchemaMappings Constructor
SchemaMappings Class See Also

The default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SchemaMappings()
Visual C++
public:
SchemaMappings()

See Also

SchemaMappings Class
SchemaMappings Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Constructor (SchemaMappings)

[image]

SQL Data Compare API 7.1.0
SchemaMappings Constructor (SchemaMappings)
SchemaMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    schemaMappings As SchemaMappings _
)
C#
public SchemaMappings(
    SchemaMappings schemaMappings
)
Visual C++
public:
SchemaMappings(
    SchemaMappings^ schemaMappings
)

Parameters

schemaMappings
Type: RedGate.SQLDataCompare.Engine..::.SchemaMappings
The SchemaMappings to copy.

See Also

SchemaMappings Class
SchemaMappings Overload
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Methods

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings Methods
SchemaMappings Class See Also

The SchemaMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views. (Overrides Mappings <(Of <( IOwner, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( IOwner, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings..::.CreateMappings Method
SchemaMappings Class See Also

Overload List

Name | Description
CreateMappings(Database, Database) | Creates a mapping for each schema, user, or role in the database where such a mapping is possible.
CreateMappings<(Of <(U>)>)(KeyedCollection<(Of <(U>)>), KeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Database, Database)

[image]

SQL Data Compare API 7.1.0
SchemaMappings..::.CreateMappings Method (Database, Database)
SchemaMappings Class See Also

Creates a mapping for each schema, user, or role in the database where such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    db1 As Database, _
    db2 As Database _
)
C#
public void CreateMappings(
    Database db1,
    Database db2
)
Visual C++
public:
void CreateMappings(
    Database^ db1,
    Database^ db2
)

Parameters

db1
Type: RedGate.SQLCompare.Engine..::.Database
The first database, or null.
db2
Type: RedGate.SQLCompare.Engine..::.Database
The second database, or null.

See Also

SchemaMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 7.1.0
SchemaMappings..::.Join Method
SchemaMappings Class See Also

Joins two schemas, two users, or a schema and a user, and attempts to map their tables and views.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As IOwner, _
    obj2 As IOwner _
) As Mapping(Of IOwner)
C#
public override Mapping<IOwner> Join(
    IOwner obj1,
    IOwner obj2
)
Visual C++
public:
virtual Mapping<IOwner^>^ Join(
    IOwner^ obj1,
    IOwner^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
The schema or user in the second database.

Return Value

the created mapping.

Exceptions

Exception | Condition
System..::.ArgumentException | SchemaMappings. Join must be called with Schema or Users arguments.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 7.1.0
SchemaMappings..::.ShouldInclude Method
SchemaMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As IOwner, _
    obj2 As IOwner, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    IOwner obj1,
    IOwner obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    IOwner^ obj1,
    IOwner^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.IOwner
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.IOwner
object or null if obj1 not null.
extra
Type: System..::.Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SchemaMappings Properties

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings Properties
SchemaMappings Class See Also

The SchemaMappings type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
TableMappings | Returns the table mappings for the databases.

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
SchemaMappings..::.Item Property
SchemaMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

SchemaMappings Class
SchemaMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Property

[image]

SQL Data Compare API 7.1.0
SchemaMappings..::.TableMappings Property
SchemaMappings Class See Also

Returns the table mappings for the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMappings As TableMappings
C#
public TableMappings TableMappings { get; }
Visual C++
public:
property TableMappings^ TableMappings {
    TableMappings^ get ();
}

See Also

SchemaMappings Class
RedGate.SQLDataCompare.Engine Namespace


SelectionDelegate Delegate

[image]

SQL Data Compare API 7.1.0
SelectionDelegate Delegate
See Also

The delegate called to indicate whether a record should be included in the synchronization SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function SelectionDelegate ( _
    synchronizationRecord As SynchronizationRecord _
) As Boolean
C#
public delegate bool SelectionDelegate(
    SynchronizationRecord synchronizationRecord
)
Visual C++
public delegate bool SelectionDelegate(
    SynchronizationRecord synchronizationRecord
)

Parameters

synchronizationRecord
Type: RedGate.SQLDataCompare.Engine..::.SynchronizationRecord
The record to include.

Field Value

true if the record is to be included; false otherwise.

See Also

RedGate.SQLDataCompare.Engine Namespace


SessionSettings Enumeration

[image]

SQL Data Compare API 7.1.0
SessionSettings Enumeration
See Also

Settings for comparing objects.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SessionSettings
C#
[FlagsAttribute]
public enum SessionSettings
Visual C++
[FlagsAttribute]
public enum class SessionSettings

Members

Member name | Description
IncludeIdenticalRecords | Include records that are the same in both databases.
IncludeDifferentRecords | Include records that exist in both databases and are different.
IncludeRecordsInOne | Include records that exist in the first database, but not the second.
IncludeRecordsInTwo | Include records that exist in the second database, but not the first.
Default | The default setting.

See Also

RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Class

[image]

SQL Data Compare API 7.1.0
SpatialCLRType Class
Members See Also

Wrapper class for a Spatial CLR data type (SQL2008).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SpatialCLRType _
    Inherits CLR
C#
public class SpatialCLRType : CLR
Visual C++
public ref class SpatialCLRType : public CLR

Remarks

The CLR object is used internally by SQL Data Compare to represent a Spatial data type. Use the ByteArray and Text properties to access the underlying data.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine..::.Blob
RedGate.SQLDataCompare.Engine..::.CLR
RedGate.SQLDataCompare.Engine..::.SpatialCLRType

See Also

SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Members

[image] [image]

SQL Data Compare API 7.1.0
SpatialCLRType Members
SpatialCLRType Class Constructors Methods Properties See Also

The SpatialCLRType type exposes the following members.

Constructors

Name | Description
SpatialCLRType | Overloaded.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides CLR ..::. ToString()()().)

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup). (Inherited from CLR.)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
IsGeography | Gets whether the type represents a geography (not geometry type)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
SRID | Get the unique ID associated with the type
Text | The textual representation of the CLR object. (Inherited from CLR.)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor

[image] [image]

SQL Data Compare API 7.1.0
SpatialCLRType Constructor
SpatialCLRType Class See Also

Overload List

Name | Description
SpatialCLRType(Boolean, array<Byte>[]()[]) | Constructs the CLR object with a given byte array and textual representation.
SpatialCLRType(Boolean, array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.
SpatialCLRType(Boolean, Int32, array<Byte>[]()[], String) | Constructs the CLR object with a given byte array and textual representation.

See Also

SpatialCLRType Class
SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (Boolean, Byte[])

[image]

SQL Data Compare API 7.1.0
SpatialCLRType Constructor (Boolean, array<Byte>[]()[])
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    bytes As Byte() _
)
C#
public SpatialCLRType(
    bool geography,
    byte[] bytes
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    array<unsigned char>^ bytes
)

Parameters

geography
Type: System..::.Boolean
Whether this CLR object represents a geography type.
bytes
Type: array< System..::.Byte >[]()[]
The byte array.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (Boolean, Byte[], String)

[image]

SQL Data Compare API 7.1.0
SpatialCLRType Constructor (Boolean, array<Byte>[]()[], String)
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    bytes As Byte(), _
    textual As String _
)
C#
public SpatialCLRType(
    bool geography,
    byte[] bytes,
    string textual
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

geography
Type: System..::.Boolean
Whether this CLR object represents a geography type.
bytes
Type: array< System..::.Byte >[]()[]
The byte array.
textual
Type: System..::.String
The textual representation of the CLR object.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Constructor (Boolean, Int32, Byte[], String)

[image]

SQL Data Compare API 7.1.0
SpatialCLRType Constructor (Boolean, Int32, array<Byte>[]()[], String)
SpatialCLRType Class See Also

Constructs the CLR object with a given byte array and textual representation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    geography As Boolean, _
    uniqueID As Integer, _
    bytes As Byte(), _
    textual As String _
)
C#
public SpatialCLRType(
    bool geography,
    int uniqueID,
    byte[] bytes,
    string textual
)
Visual C++
public:
SpatialCLRType(
    bool geography,
    int uniqueID,
    array<unsigned char>^ bytes,
    String^ textual
)

Parameters

geography
Type: System..::.Boolean
Whether this CLR object represents a geography type.
uniqueID
Type: System..::.Int32
Unique identifier of the spatial data type
bytes
Type: array< System..::.Byte >[]()[]
The byte array.
textual
Type: System..::.String
The textual representation of the CLR object.

See Also

SpatialCLRType Class
SpatialCLRType Overload
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Methods

[image] [image]

SQL Data Compare API 7.1.0
SpatialCLRType Methods
SpatialCLRType Class See Also

The SpatialCLRType type exposes the following methods.

Methods

Name | Description
CompareTo | Compares the Blob with another Blob. (Inherited from Blob.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a string representation of the object. (Overrides CLR ..::. ToString()()().)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
SpatialCLRType..::.Dispose Method
SpatialCLRType Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Inherited from Blob.)

See Also

SpatialCLRType Class
SpatialCLRType Members
RedGate.SQLDataCompare.Engine Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
SpatialCLRType..::.ToString Method
SpatialCLRType Class See Also

Returns a string representation of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

The textual representation of the CLR object.

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SpatialCLRType Properties

[image] [image]

SQL Data Compare API 7.1.0
SpatialCLRType Properties
SpatialCLRType Class See Also

The SpatialCLRType type exposes the following properties.

Properties

Name | Description
ByteArray | The underlying byte array. (Inherited from Blob.)
HasText | Returns true if the CLR type has been populated with text, false otherwise (e.g. CLR was populated from a database backup). (Inherited from CLR.)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
IsGeography | Gets whether the type represents a geography (not geometry type)
Length | The number of bytes in the underlying byte array. (Inherited from Blob.)
SRID | Get the unique ID associated with the type
Text | The textual representation of the CLR object. (Inherited from CLR.)

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


IsGeography Property

[image]

SQL Data Compare API 7.1.0
SpatialCLRType..::.IsGeography Property
SpatialCLRType Class See Also

Gets whether the type represents a geography (not geometry type)

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGeography As Boolean
C#
public bool IsGeography { get; }
Visual C++
public:
property bool IsGeography {
    bool get ();
}

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SRID Property

[image]

SQL Data Compare API 7.1.0
SpatialCLRType..::.SRID Property
SpatialCLRType Class See Also

Get the unique ID associated with the type

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SRID As Integer
C#
public int SRID { get; }
Visual C++
public:
property int SRID {
    int get ();
}

See Also

SpatialCLRType Class
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Class

[image]

SQL Data Compare API 7.1.0
SqlDataCompareException Class
Members See Also

Superclass of all exceptions thrown by the SQL Data Compare engine.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class SqlDataCompareException _
    Inherits Exception
C#
[SerializableAttribute]
public abstract class SqlDataCompareException : Exception
Visual C++
[SerializableAttribute]
public ref class SqlDataCompareException abstract : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.ComparisonSessionException
RedGate.SQLDataCompare.Engine..::.SqlProviderException
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException

See Also

SqlDataCompareException Members
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Members

[image] [image]

SQL Data Compare API 7.1.0
SqlDataCompareException Members
SqlDataCompareException Class Constructors Methods Properties See Also

The SqlDataCompareException type exposes the following members.

Constructors

Name | Description
SqlDataCompareException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlDataCompareException Class
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SqlDataCompareException Constructor
SqlDataCompareException Class See Also

Overload List

Name | Description
SqlDataCompareException()()() | Creates a new exception.
SqlDataCompareException(String) | Creates a new exception with the specified detail message.
SqlDataCompareException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
SqlDataCompareException(String, Exception) | Creates a new exception with the specified detail message that was caused by the supplied exception.

See Also

SqlDataCompareException Class
SqlDataCompareException Members
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor

[image]

SQL Data Compare API 7.1.0
SqlDataCompareException Constructor
SqlDataCompareException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected SqlDataCompareException()
Visual C++
protected:
SqlDataCompareException()

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SqlDataCompareException Constructor (String)
SqlDataCompareException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    message As String _
)
C#
protected SqlDataCompareException(
    string message
)
Visual C++
protected:
SqlDataCompareException(
    String^ message
)

Parameters

message
Type: System..::.String
Detail message.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
SqlDataCompareException Constructor (SerializationInfo, StreamingContext)
SqlDataCompareException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlDataCompareException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlDataCompareException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlDataCompareException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
SqlDataCompareException Constructor (String, Exception)
SqlDataCompareException Class See Also

Creates a new exception with the specified detail message that was caused by the supplied exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    cause As Exception _
)
C#
protected SqlDataCompareException(
    string message,
    Exception cause
)
Visual C++
protected:
SqlDataCompareException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::.String
Detail message.
cause
Type: System..::.Exception
Cause of exception.

See Also

SqlDataCompareException Class
SqlDataCompareException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlOptions Enumeration

[image]

SQL Data Compare API 7.1.0
SqlOptions Enumeration
See Also

Options used when synchronizing databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SqlOptions
C#
[FlagsAttribute]
public enum SqlOptions
Visual C++
[FlagsAttribute]
public enum class SqlOptions

Members

Member name Description
Default

The default options when synchronizing databases. These are:

  • DisableKeys
  • OutputCommentHeader
  • UseTransactions
  • OutputComments
  • ReseedIdentity
None
None.
DisableTriggers
Disable, then re-enable, DML triggers on tables and views in the synchronization script.
DisableKeys
Disable, then re-enable, foreign keys in the synchronization script. Note that in some circumstances foreign keys are dropped and recreated rather than disabled and re-enabled.
DropConstraintsAndIndexes
Drop and recreate primary keys, indexes, and unique constraints in the synchronization script. If the primary key, index, or unique constraint is the comparison key, it cannot be dropped.
OutputCommentHeader
Include the comment header in the synchronization script. The comment header contains information about the databases that you are comparing, and the version of SQL Data Compare.
UseTransactions
Inserts BEGIN TRANSACTION at the beginning of the synchronization script and COMMIT TRANSACTION at the end of the synchronization script.
TransportCLRBinary
In the synchronization script, SQL Data Compare can use the binary representation or the string representation (.ToString()) of the CLR column. Setting this option forces SQL Data Compare to use the binary representation in the synchronization script. The binary representations of the CLR columns must be the same.
DDLTriggerDisable
Disable and then re-enable all DDL triggers in the synchronization script.
OutputComments
Include the comments in the output script. The comments make it easier to locate items in the output.
ReseedIdentity
Reseeds identity columns so that identity values in the database you are updating match values in the source database.

See Also

RedGate.SQLDataCompare.Engine Namespace


SqlProvider Class

[image]

SQL Data Compare API 7.1.0
SqlProvider Class
Members Example See Also

The provider for access to SQL Server databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlProvider _
    Implements ICancellable
C#
public class SqlProvider : ICancellable
Visual C++
public ref class SqlProvider : ICancellable

Remarks

Use %GetMigrationSQL(ComparisonSession, System.Boolean)% to get an ExecutionBlock containing the SQL script to migrate data between two databases. It also provides helper methods used internally by SQL Data Compare.

Examples

See ComparisonSessionfor code samples on comparing data See GetMigrationSQL(ComparisonSession, Boolean)for code samples on synchronizing data.

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.SqlProvider

See Also

SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Members

[image] [image]

SQL Data Compare API 7.1.0
SqlProvider Members
SqlProvider Class Constructors Methods Properties See Also

The SqlProvider type exposes the following members.

Constructors

Name | Description
SqlProvider |

Methods

Name | Description
CancelOperation | Cancels the current operation.
ClearPostSQL | Clears all the current pre sql contents.
ClearPreSQL | Clears all the current pre sql contents.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationSQL | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the Status event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Block | The last execution block returned by GetMigrationSQL(ComparisonSession, TableDifference, Boolean).
Messages | Informal messages about the contents of the created SQL script.
Options | The options to use when synchronizing the databases.
Status | The event handler for status events.
Warnings | Warnings about the created SQL script.

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Constructor

[image]

SQL Data Compare API 7.1.0
SqlProvider Constructor
SqlProvider Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProvider()
Visual C++
public:
SqlProvider()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Methods

[image] [image]

SQL Data Compare API 7.1.0
SqlProvider Methods
SqlProvider Class See Also

The SqlProvider type exposes the following methods.

Methods

Name | Description
CancelOperation | Cancels the current operation.
ClearPostSQL | Clears all the current pre sql contents.
ClearPreSQL | Clears all the current pre sql contents.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMigrationSQL | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnStatus | Fires the Status event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.CancelOperation Method
SqlProvider Class See Also

Cancels the current operation.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


ClearPostSQL Method

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.ClearPostSQL Method
SqlProvider Class See Also

Clears all the current pre sql contents.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearPostSQL
C#
public void ClearPostSQL()
Visual C++
public:
void ClearPostSQL()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


ClearPreSQL Method

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.ClearPreSQL Method
SqlProvider Class See Also

Clears all the current pre sql contents.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearPreSQL
C#
public void ClearPreSQL()
Visual C++
public:
void ClearPreSQL()

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method

[image] [image]

SQL Data Compare API 7.1.0
SqlProvider..::.GetMigrationSQL Method
SqlProvider Class See Also

Overload List

Name | Description
GetMigrationSQL(ComparisonSession, Boolean) | Gets information about the SQL script for synchronizing multiple tables.
GetMigrationSQL(ComparisonSession, SelectionDelegate, Boolean) | Gets information about the SQL script for synchronizing multiple tables.
GetMigrationSQL(ComparisonSession, TableDifference, Boolean) | Gets information about the SQL script for synchronizing a single table.
GetMigrationSQL(ComparisonSession, TableDifference, SelectionDelegate, Boolean) | Gets information about the SQL script for synchronizing a single table.

See Also

SqlProvider Class
SqlProvider Members
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, Boolean)

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, Boolean)
SqlProvider Class Example See Also

Gets information about the SQL script for synchronizing multiple tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    runOnTwo As Boolean _
) As ExecutionBlock
C#
public ExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    bool runOnTwo
)
Visual C++
public:
ExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
runOnTwo
Type: System..::.Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

The Selected property must be set on all the TableDifferences to be included in the SQL script.

Remarks

The Messages and Warnings properties will be available

Examples

This example shows how to get and run the SQL script to synchronize two databases.
C# Copy Code
            using System;
            using RedGate.SQL.Shared;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;

            namespace SQLDataCompareCodeSnippets
            {
                public class SqlProviderExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        // Create the mappings between the two databases
                        TableMappings mappings = new TableMappings();
                        mappings.CreateMappings(db1.Tables, db2.Tables);

                        using (ComparisonSession session=new ComparisonSession())
                        {
                            session.CompareDatabases(db1, db2, mappings);

                            // now get the ExecutionBlock containing the SQL
                            // we want to run this on WidgetLive so we pass on true as the second parameter
                            SqlProvider provider=new SqlProvider();
                            ExecutionBlock block;
                            try
                            {
                                block = provider.GetMigrationSQL(session, true);

                                Console.WriteLine("The synchronization SQL contains {0} lines in {1} batches", block.LineCount, block.BatchCount);

                                // if the ExecutionBlock was very large this could cause memory problems
                                Console.WriteLine("The SQL to be run is:");
                                Console.WriteLine(block.GetString());

                                // we can access the SQL in a memory efficient manner by accessing the underlying stream
                                // FileStream stream=block.GetFileStream();

                                // run the SQL ( commented out by default )
                                // BlockExecutor executor = new BlockExecutor();
                                // executor.ExecuteBlock(block, ".", "WidgetLive");
                            }
                            finally
                            {
                                block = provider.Block;
                                if (block != null)
                                {
                                    block.Dispose();    // dispose of the objects to delete temporary files
                                }
                            }
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQL.Shared
            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine

            Class SqlProviderExample
                Sub RunExample()
                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create an intersection of the tables
                    Dim mappings As New TableMappings
                    mappings.CreateMappings(db1.Tables, db2.Tables)

                    'compare the databases
                    Dim session As New ComparisonSession
                    session.CompareDatabases(db1, db2, mappings)

                    'now get the ExecutionBlock containing the SQL
                    'we want to run this on WidgetLive so we pass on true as the second parameter
                    Dim provider As New SqlProvider
                    Dim block As ExecutionBlock
                    Try
                        block = provider.GetMigrationSQL(session, True)

                        Console.WriteLine("The synchronization SQL contains {0} lines in {1} batches", block.LineCount, block.BatchCount)

                        'if the ExecutionBlock was very large this could cause memory problems
                        Console.WriteLine("The SQL to be run is:")
                        Console.WriteLine(block.GetString())

                        'we can access the SQL in a memory efficient manner by accessing the underlying stream
                        'Dim stream As FileStream=block.GetFileStream()

                        'run the SQL ( commented out by default )

                        'Dim executor As RedGate.SQL.Shared.BlockExecutor = New BlockExecutor
                        'executor.ExecuteBlock(block, ".", "WidgetLive")
                    Finally
                        block = provider.Block
                        If (Typeof block Is ExecutionBlock) Then
                            block.Dispose()            'dispose of the objects to delete temporary files
                        End If
                    End Try

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine..::.SqlProviderException | If attempting to migrate data from a table with no primary key, unique index, or unique constraint defined on it, which means that rows cannot be uniquely identified.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, SelectionDelegate, Boolean)

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, SelectionDelegate, Boolean)
SqlProvider Class See Also

Gets information about the SQL script for synchronizing multiple tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    select As SelectionDelegate, _
    runOnTwo As Boolean _
) As ExecutionBlock
C#
public ExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    SelectionDelegate select,
    bool runOnTwo
)
Visual C++
public:
ExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    SelectionDelegate^ select,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
select
Type: RedGate.SQLDataCompare.Engine..::.SelectionDelegate
The selection delegate used to include specific records in the synchronization.
runOnTwo
Type: System..::.Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine..::.SqlProviderException | If attempting to migrate data from a table with no primary key, unique index, or unique constraint defined on it, which means that rows cannot be uniquely identified.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, TableDifference, Boolean)

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, TableDifference, Boolean)
SqlProvider Class See Also

Gets information about the SQL script for synchronizing a single table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    tableDifference As TableDifference, _
    runOnTwo As Boolean _
) As ExecutionBlock
C#
public ExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    TableDifference tableDifference,
    bool runOnTwo
)
Visual C++
public:
ExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    TableDifference^ tableDifference,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
tableDifference
Type: RedGate.SQLDataCompare.Engine..::.TableDifference
The table for which the the SQL script is to be retrieved.
runOnTwo
Type: System..::.Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


GetMigrationSQL Method (ComparisonSession, TableDifference, SelectionDelegate, Boolean)

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.GetMigrationSQL Method (ComparisonSession, TableDifference, SelectionDelegate, Boolean)
SqlProvider Class See Also

Gets information about the SQL script for synchronizing a single table.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMigrationSQL ( _
    session As ComparisonSession, _
    tableDifference As TableDifference, _
    select As SelectionDelegate, _
    runOnTwo As Boolean _
) As ExecutionBlock
C#
public ExecutionBlock GetMigrationSQL(
    ComparisonSession session,
    TableDifference tableDifference,
    SelectionDelegate select,
    bool runOnTwo
)
Visual C++
public:
ExecutionBlock^ GetMigrationSQL(
    ComparisonSession^ session,
    TableDifference^ tableDifference,
    SelectionDelegate^ select,
    bool runOnTwo
)

Parameters

session
Type: RedGate.SQLDataCompare.Engine..::.ComparisonSession
The ComparisonSession used to compare the databases.
tableDifference
Type: RedGate.SQLDataCompare.Engine..::.TableDifference
The table for which the the SQL script is to be retrieved.
select
Type: RedGate.SQLDataCompare.Engine..::.SelectionDelegate
The selection delegate used to include specific records in the synchronization.
runOnTwo
Type: System..::.Boolean
true if the SQL script is to be run on the second database.

Return Value

An ExecutionBlock containing the SQL code to run.

Remarks

See GetMigrationSQL(ComparisonSession, Boolean) for more information.

See Also

SqlProvider Class
GetMigrationSQL Overload
RedGate.SQLDataCompare.Engine Namespace


OnStatus Method

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.OnStatus Method
SqlProvider Class See Also

Fires the Status event.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub OnStatus ( _
    e As StatusEventArgs _
)
C#
protected void OnStatus(
    StatusEventArgs e
)
Visual C++
protected:
void OnStatus(
    StatusEventArgs^ e
)

Parameters

e
Type: RedGate.Shared.Utils..::.StatusEventArgs

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProvider Properties

[image] [image]

SQL Data Compare API 7.1.0
SqlProvider Properties
SqlProvider Class See Also

The SqlProvider type exposes the following properties.

Properties

Name | Description
Block | The last execution block returned by GetMigrationSQL(ComparisonSession, TableDifference, Boolean).
Messages | Informal messages about the contents of the created SQL script.
Options | The options to use when synchronizing the databases.
Status | The event handler for status events.
Warnings | Warnings about the created SQL script.

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Block Property

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.Block Property
SqlProvider Class See Also

The last execution block returned by GetMigrationSQL(ComparisonSession, TableDifference, Boolean).

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Block As ExecutionBlock
C#
public ExecutionBlock Block { get; }
Visual C++
public:
property ExecutionBlock^ Block {
    ExecutionBlock^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Messages Property

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.Messages Property
SqlProvider Class See Also

Informal messages about the contents of the created SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Options Property

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.Options Property
SqlProvider Class See Also

The options to use when synchronizing the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As EngineDataCompareOptions
C#
public EngineDataCompareOptions Options { get; set; }
Visual C++
public:
property EngineDataCompareOptions^ Options {
    EngineDataCompareOptions^ get ();
    void set (EngineDataCompareOptions^ value);
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.Status Property
SqlProvider Class See Also

The event handler for status events.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


Warnings Property

[image]

SQL Data Compare API 7.1.0
SqlProvider..::.Warnings Property
SqlProvider Class See Also

Warnings about the created SQL script.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As Messages
C#
public Messages Warnings { get; }
Visual C++
public:
property Messages^ Warnings {
    Messages^ get ();
}

See Also

SqlProvider Class
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Class

[image]

SQL Data Compare API 7.1.0
SqlProviderException Class
Members See Also

Exception thrown by SqlProvider when it encounters an error whilst generating SQL code.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlProviderException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class SqlProviderException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class SqlProviderException : public SqlDataCompareException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine..::.SqlProviderException

See Also

SqlProviderException Members
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Members

[image] [image]

SQL Data Compare API 7.1.0
SqlProviderException Members
SqlProviderException Class Constructors Methods Properties See Also

The SqlProviderException type exposes the following members.

Constructors

Name | Description
SqlProviderException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SqlProviderException Class
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor

[image] [image]

SQL Data Compare API 7.1.0
SqlProviderException Constructor
SqlProviderException Class See Also

Overload List

Name | Description
SqlProviderException()()() | Creates a new exception.
SqlProviderException(String) | Creates a new exception with the specified detail message.
SqlProviderException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
SqlProviderException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

SqlProviderException Class
SqlProviderException Members
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor

[image]

SQL Data Compare API 7.1.0
SqlProviderException Constructor
SqlProviderException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlProviderException()
Visual C++
public:
SqlProviderException()

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor (String)

[image]

SQL Data Compare API 7.1.0
SqlProviderException Constructor (String)
SqlProviderException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SqlProviderException(
    string message
)
Visual C++
public:
SqlProviderException(
    String^ message
)

Parameters

message
Type: System..::.String
Detail message.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
SqlProviderException Constructor (SerializationInfo, StreamingContext)
SqlProviderException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected SqlProviderException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
SqlProviderException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlProviderException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
SqlProviderException Constructor (String, Exception)
SqlProviderException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public SqlProviderException(
    string message,
    Exception cause
)
Visual C++
public:
SqlProviderException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::.String
Detail message.
cause
Type: System..::.Exception
Cause of exception.

See Also

SqlProviderException Class
SqlProviderException Overload
RedGate.SQLDataCompare.Engine Namespace


SqlSynchronization Enumeration

[image]

SQL Data Compare API 7.1.0
SqlSynchronization Enumeration
See Also

Controls which parts of the SQL script are produced when the synchronization script is created.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration SqlSynchronization
C#
[FlagsAttribute]
public enum SqlSynchronization
Visual C++
[FlagsAttribute]
public enum class SqlSynchronization

Members

Member name | Description
None | No update SQL will be produced.
UpdateSql | Include the update SQL.
DeleteSql | Include the delete SQL.
AddSql | Include the insertion SQL.
AllSql | Include all SQL ( default ).

See Also

RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Structure

[image]

SQL Data Compare API 7.1.0
SynchronizationRecord Structure
Members See Also

A record to be included in a synchronization. This is used by the script generation routines to confirm the inclusion of a record. Passed a parameter to the SelectionDelegate.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure SynchronizationRecord
C#
public struct SynchronizationRecord
Visual C++
public value class SynchronizationRecord

See Also

SynchronizationRecord Members
RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Members

[image] [image]

SQL Data Compare API 7.1.0
SynchronizationRecord Members
SynchronizationRecord Structure Methods Properties See Also

The SynchronizationRecord type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Bookmark | The bookmark in the Store.
ResultsStoreType | The Row..::.RowType of the record.
TableName | The name of the table to which the record belongs.

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


SynchronizationRecord Properties

[image] [image]

SQL Data Compare API 7.1.0
SynchronizationRecord Properties
SynchronizationRecord Structure See Also

The SynchronizationRecord type exposes the following properties.

Properties

Name | Description
Bookmark | The bookmark in the Store.
ResultsStoreType | The Row..::.RowType of the record.
TableName | The name of the table to which the record belongs.

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


Bookmark Property

[image]

SQL Data Compare API 7.1.0
SynchronizationRecord..::.Bookmark Property
SynchronizationRecord Structure See Also

The bookmark in the Store.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As Integer
C#
public int Bookmark { get; }
Visual C++
public:
property int Bookmark {
    int get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


ResultsStoreType Property

[image]

SQL Data Compare API 7.1.0
SynchronizationRecord..::.ResultsStoreType Property
SynchronizationRecord Structure See Also

The Row..::.RowType of the record.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultsStoreType As Row..::.RowType
C#
public Row..::.RowType ResultsStoreType { get; }
Visual C++
public:
property Row..::.RowType ResultsStoreType {
    Row..::.RowType get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


TableName Property

[image]

SQL Data Compare API 7.1.0
SynchronizationRecord..::.TableName Property
SynchronizationRecord Structure See Also

The name of the table to which the record belongs.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName As String
C#
public string TableName { get; }
Visual C++
public:
property String^ TableName {
    String^ get ();
}

See Also

SynchronizationRecord Structure
RedGate.SQLDataCompare.Engine Namespace


TableDifference Class

[image]

SQL Data Compare API 7.1.0
TableDifference Class
Members Example See Also

The results of a table being compared in two databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableDifference _
    Implements IDisposable
C#
public sealed class TableDifference : IDisposable
Visual C++
public ref class TableDifference sealed : IDisposable

Remarks

When CompareDatabases(Database, Database, SchemaMappings) is called, its TableDifferences collection contains a set of TableDifference objects, each one corresponding to a table that has been compared. Each TableDifference object contains properties giving a summary of the number of different records in the two tables, and a series of ResultsStore objects containing the details of differing and identical rows.

Examples

See ComparisonSession for an in-depth example.

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.TableDifference

See Also

TableDifference Members
RedGate.SQLDataCompare.Engine Namespace


TableDifference Members

[image] [image]

SQL Data Compare API 7.1.0
TableDifference Members
TableDifference Class Methods Properties See Also

The TableDifference type exposes the following members.

Methods

Name | Description
Dispose | Disposes of the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TargetTable | Returns the target table on the specified database, or returns the source table if the target table does not exist.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DifferencesSummary | The differences summary object for the table difference.
Name | The fully-qualified name of the table being compared.
RefreshSelected | Set if the table is to be included when refreshing the TableDifferences. Defaults to true.
ResultsStore | The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().
SqlSynchronization | Affects which parts of the SQL code are produced when the synchronization SQL script is generated.
TableMapping | The setting to be used when the table differences are refreshed.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifference Methods

[image] [image]

SQL Data Compare API 7.1.0
TableDifference Methods
TableDifference Class See Also

The TableDifference type exposes the following methods.

Methods

Name | Description
Dispose | Disposes of the object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
TargetTable | Returns the target table on the specified database, or returns the source table if the target table does not exist.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


Dispose Method

[image]

SQL Data Compare API 7.1.0
TableDifference..::.Dispose Method
TableDifference Class See Also

Disposes of the object.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

Remarks

Disposes of all the ResultsStore objects representing records in the two databases. These objects make extensive use of temporary files, therefore it is very important to call the Dispose method.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TargetTable Method

[image]

SQL Data Compare API 7.1.0
TableDifference..::.TargetTable Method
TableDifference Class See Also

Returns the target table on the specified database, or returns the source table if the target table does not exist.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function TargetTable ( _
    onTwo As Boolean _
) As ViewTableSuperClass
C#
public ViewTableSuperClass TargetTable(
    bool onTwo
)
Visual C++
public:
ViewTableSuperClass^ TargetTable(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true for second database.

Return Value

The target table.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifference Properties

[image] [image]

SQL Data Compare API 7.1.0
TableDifference Properties
TableDifference Class See Also

The TableDifference type exposes the following properties.

Properties

Name | Description
DifferencesSummary | The differences summary object for the table difference.
Name | The fully-qualified name of the table being compared.
RefreshSelected | Set if the table is to be included when refreshing the TableDifferences. Defaults to true.
ResultsStore | The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().
SqlSynchronization | Affects which parts of the SQL code are produced when the synchronization SQL script is generated.
TableMapping | The setting to be used when the table differences are refreshed.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


DifferencesSummary Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.DifferencesSummary Property
TableDifference Class See Also

The differences summary object for the table difference.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DifferencesSummary As DifferencesSummary
C#
public DifferencesSummary DifferencesSummary { get; }
Visual C++
public:
property DifferencesSummary^ DifferencesSummary {
    DifferencesSummary^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


Name Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.Name Property
TableDifference Class See Also

The fully-qualified name of the table being compared.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This is the name of the table in the first database; if null, this is the name of the table in the second database.

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


RefreshSelected Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.RefreshSelected Property
TableDifference Class See Also

Set if the table is to be included when refreshing the TableDifferences. Defaults to true.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshSelected As Boolean
C#
public bool RefreshSelected { get; set; }
Visual C++
public:
property bool RefreshSelected {
    bool get ();
    void set (bool value);
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


ResultsStore Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.ResultsStore Property
TableDifference Class See Also

The records that are in the two databases. This can be affected by ApplyFilter(Boolean) and ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultsStore As Store
C#
public Store ResultsStore { get; }
Visual C++
public:
property Store^ ResultsStore {
    Store^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


SqlSynchronization Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.SqlSynchronization Property
TableDifference Class See Also

Affects which parts of the SQL code are produced when the synchronization SQL script is generated.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SqlSynchronization As SqlSynchronization
C#
public SqlSynchronization SqlSynchronization { get; set; }
Visual C++
public:
property SqlSynchronization SqlSynchronization {
    SqlSynchronization get ();
    void set (SqlSynchronization value);
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Property

[image]

SQL Data Compare API 7.1.0
TableDifference..::.TableMapping Property
TableDifference Class See Also

The setting to be used when the table differences are refreshed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMapping As TableMapping
C#
public TableMapping TableMapping { get; }
Visual C++
public:
property TableMapping^ TableMapping {
    TableMapping^ get ();
}

See Also

TableDifference Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Class

[image]

SQL Data Compare API 7.1.0
TableDifferences Class
Members See Also

A collection of TableDifference objects.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TableDifferences _
    Inherits InnerList(Of TableDifference)
C#
public sealed class TableDifferences : InnerList<TableDifference>
Visual C++
public ref class TableDifferences sealed : public InnerList<TableDifference^>

Remarks

Contains the results of a comparison.

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( TableDifference >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( TableDifference >)>)
RedGate.SQLDataCompare.Engine..::.TableDifferences

See Also

TableDifferences Members
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Members

[image] [image]

SQL Data Compare API 7.1.0
TableDifferences Members
TableDifferences Class Methods Properties Explicit Interface Implementations See Also

The TableDifferences type exposes the following members.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( TableDifference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Methods

[image] [image]

SQL Data Compare API 7.1.0
TableDifferences Methods
TableDifferences Class See Also

The TableDifferences type exposes the following methods.

Methods

Name | Description
Add | (Overrides InnerList <(Of <( TableDifference >)>)..::.Add(UTP).)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


Add Method

[image]

SQL Data Compare API 7.1.0
TableDifferences..::.Add Method
TableDifferences Class See Also

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    item As TableDifference _
)
C#
public override void Add(
    TableDifference item
)
Visual C++
public:
virtual void Add(
    TableDifference^ item
) override

Parameters

item
Type: RedGate.SQLDataCompare.Engine..::.TableDifference

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


TableDifferences Properties

[image] [image]

SQL Data Compare API 7.1.0
TableDifferences Properties
TableDifferences Class See Also

The TableDifferences type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.

See Also

TableDifferences Class
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
TableDifferences..::.Item Property
TableDifferences Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the TableDifference at the specified index. (Overrides InnerList <(Of <( TableDifference >)>)..::. Item[([(Int32])]).)
Item[([(String])]) | Returns a given TableDifference. The index is the name of the table in the first database or if null, the name of the table in the second database.

See Also

TableDifferences Class
TableDifferences Members
RedGate.SQLDataCompare.Engine Namespace


Item Property (Int32)

[image]

SQL Data Compare API 7.1.0
TableDifferences..::.Item Property (Int32)
TableDifferences Class See Also

Gets the TableDifference at the specified index.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As TableDifference
C#
public override TableDifference this[
    int index
] { set; }
Visual C++
public:
virtual property TableDifference^ default[int index] {
    void set (int index, TableDifference^ value) override;
}

Parameters

index
Type: System..::.Int32
The zero-based index of the TableDifference to get or set.

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

TableDifferences Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


Item Property (String)

[image]

SQL Data Compare API 7.1.0
TableDifferences..::.Item Property (String)
TableDifferences Class See Also

Returns a given TableDifference. The index is the name of the table in the first database or if null, the name of the table in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As TableDifference
C#
public TableDifference this[
    string name
] { get; }
Visual C++
public:
property TableDifference^ default[String^ name] {
    TableDifference^ get (String^ name);
}

Parameters

name
Type: System..::.String
The string-based index of the TableDifference to get.

See Also

TableDifferences Class
Item Overload
RedGate.SQLDataCompare.Engine Namespace


TableMapping Class

[image]

SQL Data Compare API 7.1.0
TableMapping Class
Members See Also

Contains a mapping from a view or table to another view or table. Also contains information on the criteria used for matching the two tables, which can be based on an index or an arbitrary set of mapped fields.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TableMapping _
    Inherits Mapping(Of ViewTableSuperClass)
C#
public class TableMapping : Mapping<ViewTableSuperClass>
Visual C++
public ref class TableMapping : public Mapping<ViewTableSuperClass^>

Inheritance Hierarchy

System..::.Object
RedGate.SQLCompare.Engine..::.Mapping <(Of <( ViewTableSuperClass >)>)
RedGate.SQLDataCompare.Engine..::.TableMapping

See Also

TableMapping Members
RedGate.SQLDataCompare.Engine Namespace


TableMapping Members

[image] [image]

SQL Data Compare API 7.1.0
TableMapping Members
TableMapping Class Constructors Methods Properties See Also

The TableMapping type exposes the following members.

Constructors

Name | Description
TableMapping | Constructor. Calls the base constructor and initializes the index mappings.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatching | Determines whether the specified field is being used for matching the databases.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseIndexForMapping | Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
IndexMapping | If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.
IndexMappings | The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.
MatchingMappings | The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.
Where | Where clause object used on the databases.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Constructor

[image]

SQL Data Compare API 7.1.0
TableMapping Constructor
TableMapping Class See Also

Constructor. Calls the base constructor and initializes the index mappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    status As TableMappingStatus _
)
C#
public TableMapping(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    TableMappingStatus status
)
Visual C++
public:
TableMapping(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    TableMappingStatus status
)

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The view or table in the second database.
status
Type: RedGate.SQLDataCompare.Engine..::.TableMappingStatus
The status of the mapping.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Methods

[image] [image]

SQL Data Compare API 7.1.0
TableMapping Methods
TableMapping Class See Also

The TableMapping type exposes the following methods.

Methods

Name | Description
Clone | Creates a shallow copy. (Overrides Mapping <(Of <( ViewTableSuperClass >)>)..::. Clone()()().)
CompareTo | Sorts the Mappings. (Inherited from Mapping<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatching | Determines whether the specified field is being used for matching the databases.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshMappingStatus | Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared. If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UseIndexForMapping | Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Clone Method

[image]

SQL Data Compare API 7.1.0
TableMapping..::.Clone Method
TableMapping Class See Also

Creates a shallow copy.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone As Object
C#
public override Object Clone()
Visual C++
public:
virtual Object^ Clone() override

Return Value

A shallow copy.

Implements

ICloneable..::.Clone()()()

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


IsMatching Method

[image]

SQL Data Compare API 7.1.0
TableMapping..::.IsMatching Method
TableMapping Class See Also

Determines whether the specified field is being used for matching the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function IsMatching ( _
    fieldName As String, _
    inTwo As Boolean _
) As Boolean
C#
public bool IsMatching(
    string fieldName,
    bool inTwo
)
Visual C++
public:
bool IsMatching(
    String^ fieldName,
    bool inTwo
)

Parameters

fieldName
Type: System..::.String
The name of the field.
inTwo
Type: System..::.Boolean
true if the check is to be performed on the second database.

Return Value

true if the field is being used for matching.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


RefreshMappingStatus Method

[image]

SQL Data Compare API 7.1.0
TableMapping..::.RefreshMappingStatus Method
TableMapping Class See Also

Checks the current contents of IndexMapping and MatchingMappings to determine whether the current TableMapping can be compared.

If the TableMapping can be compared, the TableMapping Status is set to Success; otherwise the Status is set to UnableToCompare. If not all of the fields in the table are mapped successfully, if the Status is not already set to UnableToCompare, it is set to PartialSuccess.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshMappingStatus
C#
public void RefreshMappingStatus()
Visual C++
public:
void RefreshMappingStatus()

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


UseIndexForMapping Method

[image]

SQL Data Compare API 7.1.0
TableMapping..::.UseIndexForMapping Method
TableMapping Class See Also

Changes the matching mappings to be the fields from the matched indexes. The property IndexMapping is set to the specified mapping; or null if a problem was encountered.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function UseIndexForMapping ( _
    mapping As IndexMapping _
) As Boolean
C#
public bool UseIndexForMapping(
    IndexMapping mapping
)
Visual C++
public:
bool UseIndexForMapping(
    IndexMapping^ mapping
)

Parameters

mapping
Type: RedGate.SQLDataCompare.Engine..::.IndexMapping
The IndexMapping to be used.

Return Value

true if the mapping was successfully used; otherwise false.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMapping Properties

[image] [image]

SQL Data Compare API 7.1.0
TableMapping Properties
TableMapping Class See Also

The TableMapping type exposes the following properties.

Properties

Name | Description
FieldMappings | Returns the field mappings for the tables.
Include | The include property for tables.
IndexMapping | If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.
IndexMappings | The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.
MatchingMappings | The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.
Messages | Messages that explain any issues concerning the mapping; null if no issues exist.
Obj1 | Returns the object from the first database (Inherited from Mapping<(Of <(T>)>).)
Obj2 | Returns the object from the second database (Inherited from Mapping<(Of <(T>)>).)
Status | The status of the Table Mapping.
Where | Where clause object used on the databases.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


FieldMappings Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.FieldMappings Property
TableMapping Class See Also

Returns the field mappings for the tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldMappings As FieldMappings
C#
public FieldMappings FieldMappings { get; }
Visual C++
public:
property FieldMappings^ FieldMappings {
    FieldMappings^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Include Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.Include Property
TableMapping Class See Also

The include property for tables.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Include As Boolean
C#
public bool Include { get; set; }
Visual C++
public:
property bool Include {
    bool get ();
    void set (bool value);
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


IndexMapping Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.IndexMapping Property
TableMapping Class See Also

If an IndexMapping is being used for matching, this is the IndexMapping. Its FieldMapping is also in MatchingMappings.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IndexMapping As IndexMapping
C#
public IndexMapping IndexMapping { get; }
Visual C++
public:
property IndexMapping^ IndexMapping {
    IndexMapping^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
UseIndexForMapping Method


IndexMappings Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.IndexMappings Property
TableMapping Class See Also

The IndexMappings for the indexes that can be used to compare tables or views. The indexes must be PrimaryKey, Unique, or UniqueConstraint.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IndexMappings As IndexMappings
C#
public IndexMappings IndexMappings { get; }
Visual C++
public:
property IndexMappings^ IndexMappings {
    IndexMappings^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
UseIndexForMapping Method


MatchingMappings Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.MatchingMappings Property
TableMapping Class See Also

The FieldMappings that are used to compare the databases. These may have been set from an IndexMapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatchingMappings As FieldMappings
C#
public FieldMappings MatchingMappings { get; }
Visual C++
public:
property FieldMappings^ MatchingMappings {
    FieldMappings^ get ();
}

Remarks

Changing the mapping of fields that are used for matching may have unforseen consequences.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace
RefreshMappingStatus Method
UseIndexForMapping Method


Messages Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.Messages Property
TableMapping Class See Also

Messages that explain any issues concerning the mapping; null if no issues exist.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Messages As Messages
C#
public Messages Messages { get; }
Visual C++
public:
property Messages^ Messages {
    Messages^ get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.Status Property
TableMapping Class See Also

The status of the Table Mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As TableMappingStatus
C#
public TableMappingStatus Status { get; }
Visual C++
public:
property TableMappingStatus Status {
    TableMappingStatus get ();
}

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


Where Property

[image]

SQL Data Compare API 7.1.0
TableMapping..::.Where Property
TableMapping Class See Also

Where clause object used on the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Where As WhereClause
C#
public WhereClause Where { get; set; }
Visual C++
public:
property WhereClause^ Where {
    WhereClause^ get ();
    void set (WhereClause^ value);
}

Remarks

Initialized to empty strings.

See Also

TableMapping Class
RedGate.SQLDataCompare.Engine Namespace


TableMappings Class

[image]

SQL Data Compare API 7.1.0
TableMappings Class
Members Example See Also

Holds mappings for tables or views in a schema.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class TableMappings _
    Inherits DataCompareMappings(Of ViewTableSuperClass)
C#
public class TableMappings : DataCompareMappings<ViewTableSuperClass>
Visual C++
public ref class TableMappings : public DataCompareMappings<ViewTableSuperClass^>

Examples

C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace RedGate.SQLDataCompare.ExampleTests
            {
                public class TableMappingExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();
                        ComparisonSession session=new ComparisonSession();
                        TableMappings mappings = new TableMappings();

                        try
                        {
                            db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                            db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                            // Create the mappings between a certain table
                            TableMapping tableMapping = (TableMapping)mappings.Join(db1.Tables["[dbo].[WidgetPrices]"], db2.Tables["[dbo].[WidgetPrices]"]);

                            // Set the custom comparison key for the table
                            tableMapping.MatchingMappings.Clear();
                            tableMapping.MatchingMappings.Add(tableMapping.FieldMappings["WidgetID"]);
                            tableMapping.RefreshMappingStatus();

                            // Set the where clause for the comparison
                            tableMapping.Where = new WhereClause("Active = 'Y'");

                            // Peform the comparison
                            session.CompareDatabases(db1, db2, mappings);

                            TableDifference difference=session.TableDifferences["[dbo].[WidgetPrices]"];

                            // Loop through all the rows
                            foreach(Row row in difference.ResultsStore)
                            {
                                Console.WriteLine("Row {0} type {1}", row.Index, row.Type.ToString());
                                int i=0;
                                foreach (FieldPair field in difference.ResultsStore.Fields)
                                {
                                    int field1=field.OrdinalInResults1;
                                    int field2=field.OrdinalInResults2;

                                    if (field1 != field2)
                                    {
                                        //get the values
                                        object value1=row.Values[field1];
                                        object value2=row.Values[field2];
                                        if (value1 == null)
                                            value1="NULL";
                                        if (value2 == null)
                                            value2="NULL";
                                        Console.WriteLine("{0}\t{1}\t{2}\t{3}",field.Field(false).Name, value1.ToString(),row.FieldDifferent(i)?"<>":"==",  value2.ToString());
                                    }
                                    else
                                    {
                                        //this is part of the custom index we are comparing on
                                        object value=row.Values[field1];
                                        Console.WriteLine("*{0}\t{1}",field.Field(false).Name, value.ToString());
                                    }
                                    i++;
                                }
                            }
                        }
                        finally
                        {
                            session.Dispose();
                            db1.Dispose();
                            db2.Dispose();
                        }
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Public Class TableMappingExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    Dim mappings As New TableMappings

                    Dim tableMapping As tableMapping = mappings.Join(db1.Tables("[dbo].[WidgetPrices]"), db2.Tables("[dbo].[WidgetPrices]"))

                    ' Set the custom comparison key for the table
                    tableMapping.MatchingMappings.Clear()
                    tableMapping.MatchingMappings.Add(tableMapping.FieldMappings("WidgetID"))
                    tableMapping.RefreshMappingStatus()

                    ' Set the where clause for the comparison
                    tableMapping.Where = New WhereClause("Active = 'Y'")

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim mapping As TableMapping

                    Dim difference As TableDifference = session.TableDifferences("[dbo].[WidgetPrices]")
                    Dim row As row
                    For Each row In difference.ResultsStore  'loop through all the rows
                        Dim field As FieldPair
                        Dim i As Int32 = 0
                        Console.WriteLine("Row {0} type {1}", row.Index, row.Type.ToString())
                        For Each field In difference.ResultsStore.Fields
                            'work out where about in the results the field data is stored
                            'if we were comparing identical records, or records present in one
                            'database but not the other then we would not need to
                            'use the OrdinalInResults1 and OrdinalInResults2 properties
                            'but just OrdinalInResults
                            Dim field1 As Int32 = field.OrdinalInResults1
                            Dim field2 As Int32 = field.OrdinalInResults2

                            If (field1 <> field2) Then
                                'get the values
                                Dim value1 As Object = row.Values(field1)
                                Dim value2 As Object = row.Values(field2)
                                If (value1 Is Nothing) Then
                                    value1 = "NULL"
                                End If
                                If (value2 Is Nothing) Then
                                    value2 = "NULL"
                                End If
                                If row.FieldDifferent(i) Then
                                    Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                Else
                                    Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                                End If
                            Else
                                'this is part of the unique index we are comparing on
                                Dim value As Object = row.Values(field1)
                                Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
                            End If
                            i += 1
                        Next
                    Next
                    'dispose of the objects
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( Mapping <(Of <( ViewTableSuperClass >)>)>)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( Mapping <(Of <( ViewTableSuperClass >)>)>)>)
RedGate.SQLCompare.Engine..::.Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)
RedGate.SQLDataCompare.Engine..::.DataCompareMappings <(Of <( ViewTableSuperClass >)>)
RedGate.SQLDataCompare.Engine..::.TableMappings

See Also

TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Members

[image] [image]

SQL Data Compare API 7.1.0
TableMappings Members
TableMappings Class Constructors Methods Properties Explicit Interface Implementations See Also

The TableMappings type exposes the following members.

Constructors

Name | Description
TableMappings | Overloaded.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Overloaded.
Options | (Inherited from DataCompareMappings<(Of <(T>)>).)
Status | The event handler used to receive status update events. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor

[image] [image]

SQL Data Compare API 7.1.0
TableMappings Constructor
TableMappings Class See Also

Overload List

Name | Description
TableMappings()()() | Default constructor.
TableMappings(Mappings<(Of <(ViewTableSuperClass, EngineDataCompareOptions>)>)) | Shallow copy constructor.

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor

[image]

SQL Data Compare API 7.1.0
TableMappings Constructor
TableMappings Class See Also

Default constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TableMappings()
Visual C++
public:
TableMappings()

See Also

TableMappings Class
TableMappings Overload
RedGate.SQLDataCompare.Engine Namespace


TableMappings Constructor (Mappings(ViewTableSuperClass, EngineDataCompareOptions))

[image]

SQL Data Compare API 7.1.0
TableMappings Constructor (Mappings<(Of <(ViewTableSuperClass, EngineDataCompareOptions>)>))
TableMappings Class See Also

Shallow copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    tableMappings As Mappings(Of ViewTableSuperClass, EngineDataCompareOptions) _
)
C#
public TableMappings(
    Mappings<ViewTableSuperClass, EngineDataCompareOptions> tableMappings
)
Visual C++
public:
TableMappings(
    Mappings<ViewTableSuperClass^, EngineDataCompareOptions^>^ tableMappings
)

Parameters

tableMappings
Type: RedGate.SQLCompare.Engine..::.Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)
The TableMappings to be copied.

See Also

TableMappings Class
TableMappings Overload
RedGate.SQLDataCompare.Engine Namespace


TableMappings Methods

[image] [image]

SQL Data Compare API 7.1.0
TableMappings Methods
TableMappings Class See Also

The TableMappings type exposes the following methods.

Methods

Name | Description
Add | Adds an Mapping<(Of <(T>)>) to the end of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CancelOperation | Cancels the current operation. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Clear | Removes all objects from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Contains | Determines whether the Mappings instance contains a specified object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
CreateMappings | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetKey | Return the key that should be used for the specified fully qualified name. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified Mapping<(Of <(T>)>) and returns the zero-based index of the first occurrence within the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Insert | Not Implemented. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Join | Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare. (Overrides Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)..::. Join(TMap, TMap).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of the specified Mapping<(Of <(T>)>) from the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
RemoveAt | Removes the mapping at the specified index of the Mappings instance. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ShouldInclude | Called to determine if an object should be included in the mapping at all, one of the obj arguments is null. (Overrides Mappings <(Of <( ViewTableSuperClass, EngineDataCompareOptions >)>)..::.ShouldInclude(UTP, UTP, Object).)
Sort | Sorts the Mappings according the criteria appropriate for the object. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Split | Splits a mapping and creates two mappings; one to null, and one from null. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method

[image] [image]

SQL Data Compare API 7.1.0
TableMappings..::.CreateMappings Method
TableMappings Class See Also

Overload List

Name | Description
CreateMappings(Tables, Tables) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings(Views, Views) | Creates a mapping for each object in the collection for which such a mapping is possible.
CreateMappings<(Of <(U>)>)(KeyedCollection<(Of <(U>)>), KeyedCollection<(Of <(U>)>), Object, Boolean) | Creates a mapping for each object in the collection where such a mapping is possible. All of the iteration is performed here and the matching can be affected by changing ShouldInclude(UTP, UTP, Object) in the sub class. The main action of joining to objects together is performed by Join(TMap, TMap) which can itself call CreateMappings on child database objects. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Tables, Tables)

[image]

SQL Data Compare API 7.1.0
TableMappings..::.CreateMappings Method (Tables, Tables)
TableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Tables, _
    in2 As Tables _
)
C#
public void CreateMappings(
    Tables in1,
    Tables in2
)
Visual C++
public:
void CreateMappings(
    Tables^ in1,
    Tables^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Tables
A list of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Tables
A list of objects in the second database, or null.

See Also

TableMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


CreateMappings Method (Views, Views)

[image]

SQL Data Compare API 7.1.0
TableMappings..::.CreateMappings Method (Views, Views)
TableMappings Class See Also

Creates a mapping for each object in the collection for which such a mapping is possible.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateMappings ( _
    in1 As Views, _
    in2 As Views _
)
C#
public void CreateMappings(
    Views in1,
    Views in2
)
Visual C++
public:
void CreateMappings(
    Views^ in1,
    Views^ in2
)

Parameters

in1
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the first database, or null.
in2
Type: RedGate.SQLCompare.Engine..::.Views
List of objects in the second database, or null.

See Also

TableMappings Class
CreateMappings Overload
RedGate.SQLDataCompare.Engine Namespace


Join Method

[image]

SQL Data Compare API 7.1.0
TableMappings..::.Join Method
TableMappings Class See Also

Joins two views or tables, and attempts to map their fields and indexes. If there are no suitable indexes, the status is set to Unable to Compare.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Join ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass _
) As Mapping(Of ViewTableSuperClass)
C#
public override Mapping<ViewTableSuperClass> Join(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2
)
Visual C++
public:
virtual Mapping<ViewTableSuperClass^>^ Join(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the first database.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
The table or view in the second database.

Return Value

The created mapping.

Exceptions

Exception | Condition
System..::.ArgumentException | TableMappings. Join must be called with ViewTableSuperClass arguments.

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


ShouldInclude Method

[image]

SQL Data Compare API 7.1.0
TableMappings..::.ShouldInclude Method
TableMappings Class See Also

Called to determine if an object should be included in the mapping at all, one of the obj arguments is null.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldInclude ( _
    obj1 As ViewTableSuperClass, _
    obj2 As ViewTableSuperClass, _
    extra As Object _
) As Boolean
C#
protected override bool ShouldInclude(
    ViewTableSuperClass obj1,
    ViewTableSuperClass obj2,
    Object extra
)
Visual C++
protected:
virtual bool ShouldInclude(
    ViewTableSuperClass^ obj1,
    ViewTableSuperClass^ obj2,
    Object^ extra
) override

Parameters

obj1
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj2 not null.
obj2
Type: RedGate.SQLCompare.Engine..::.ViewTableSuperClass
object or null if obj1 not null.
extra
Type: System..::.Object
extra data passed into CreateMappings internally to determine relevance.

Return Value

true ( default )for inclusion, false otherwise.

See Also

TableMappings Class
RedGate.SQLDataCompare.Engine Namespace


TableMappingStatus Enumeration

[image]

SQL Data Compare API 7.1.0
TableMappingStatus Enumeration
See Also

The result of the mapping.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TableMappingStatus
C#
public enum TableMappingStatus
Visual C++
public enum class TableMappingStatus

Members

Member name | Description
Success | The mapping was successful.
UnableToCompare | The mapping succeeded, but SQL Data Compare is unable to compare. This is usually because of type comparison failure.
PartialSuccess | The mapping was a partial success; some columns remain unmapped.

See Also

RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Structure

[image]

SQL Data Compare API 7.1.0
UserActionWarning Structure
Members See Also

Contains details of a user action that has failed due to schema changes since the project was created.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Structure UserActionWarning
C#
public struct UserActionWarning
Visual C++
public value class UserActionWarning

See Also

UserActionWarning Members
RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Members

[image] [image]

SQL Data Compare API 7.1.0
UserActionWarning Members
UserActionWarning Structure Methods Properties See Also

The UserActionWarning type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


UserActionWarning Properties

[image] [image]

SQL Data Compare API 7.1.0
UserActionWarning Properties
UserActionWarning Structure See Also

The UserActionWarning type exposes the following properties.

Properties

Name | Description
Message | Textual description of the reason for the failure of the user action.
UserAction | The user action that has failed.

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


Message Property

[image]

SQL Data Compare API 7.1.0
UserActionWarning..::.Message Property
UserActionWarning Structure See Also

Textual description of the reason for the failure of the user action.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


UserAction Property

[image]

SQL Data Compare API 7.1.0
UserActionWarning..::.UserAction Property
UserActionWarning Structure See Also

The user action that has failed.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserAction As SelectTableEvent
C#
public SelectTableEvent UserAction { get; }
Visual C++
public:
property SelectTableEvent UserAction {
    SelectTableEvent get ();
}

See Also

UserActionWarning Structure
RedGate.SQLDataCompare.Engine Namespace


WhereClause Class

[image]

SQL Data Compare API 7.1.0
WhereClause Class
Members See Also

An encapsulation class for the WHERE clause used on the tables in the databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class WhereClause
C#
public class WhereClause
Visual C++
public ref class WhereClause

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine..::.WhereClause

See Also

WhereClause Members
RedGate.SQLDataCompare.Engine Namespace


WhereClause Members

[image] [image]

SQL Data Compare API 7.1.0
WhereClause Members
WhereClause Class Constructors Methods Properties See Also

The WhereClause type exposes the following members.

Constructors

Name | Description
WhereClause | Overloaded.

Methods

Name | Description
Clause | A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Clause1 | The WHERE clause used on the table in the first database.
Clause2 | The WHERE clause used on the table in the second database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor

[image] [image]

SQL Data Compare API 7.1.0
WhereClause Constructor
WhereClause Class See Also

Overload List

Name | Description
WhereClause()()() | Default constructor. The WHERE clauses are set to empty strings for both databases.
WhereClause(String) | Constructor.
WhereClause(WhereClause) | Copy constructor.
WhereClause(String, String) | Constructor.

See Also

WhereClause Class
WhereClause Members
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor

[image]

SQL Data Compare API 7.1.0
WhereClause Constructor
WhereClause Class See Also

Default constructor. The WHERE clauses are set to empty strings for both databases.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WhereClause()
Visual C++
public:
WhereClause()

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor (String)

[image]

SQL Data Compare API 7.1.0
WhereClause Constructor (String)
WhereClause Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    clause As String _
)
C#
public WhereClause(
    string clause
)
Visual C++
public:
WhereClause(
    String^ clause
)

Parameters

clause
Type: System..::.String
The WHERE clause to be used on the tables in both databases.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor (WhereClause)

[image]

SQL Data Compare API 7.1.0
WhereClause Constructor (WhereClause)
WhereClause Class See Also

Copy constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    source As WhereClause _
)
C#
public WhereClause(
    WhereClause source
)
Visual C++
public:
WhereClause(
    WhereClause^ source
)

Parameters

source
Type: RedGate.SQLDataCompare.Engine..::.WhereClause
The source WHERE clause to be copied to the new class.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Constructor (String, String)

[image]

SQL Data Compare API 7.1.0
WhereClause Constructor (String, String)
WhereClause Class See Also

Constructor.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    clause1 As String, _
    clause2 As String _
)
C#
public WhereClause(
    string clause1,
    string clause2
)
Visual C++
public:
WhereClause(
    String^ clause1,
    String^ clause2
)

Parameters

clause1
Type: System..::.String
The WHERE clause to be used on the table in the first database.
clause2
Type: System..::.String
The WHERE clause to be used on the table in the second database.

See Also

WhereClause Class
WhereClause Overload
RedGate.SQLDataCompare.Engine Namespace


WhereClause Methods

[image] [image]

SQL Data Compare API 7.1.0
WhereClause Methods
WhereClause Class See Also

The WhereClause type exposes the following methods.

Methods

Name | Description
Clause | A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause Method

[image]

SQL Data Compare API 7.1.0
WhereClause..::.Clause Method
WhereClause Class See Also

A convenience function for easy access to the first or second WHERE clause. Returns the appropriate WHERE clause.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function Clause ( _
    onTwo As Boolean _
) As String
C#
public string Clause(
    bool onTwo
)
Visual C++
public:
String^ Clause(
    bool onTwo
)

Parameters

onTwo
Type: System..::.Boolean
true to return the WHERE clause for the second database; false to return the WHERE clause for first database.

Return Value

The WHERE clause for the requested database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


WhereClause Properties

[image] [image]

SQL Data Compare API 7.1.0
WhereClause Properties
WhereClause Class See Also

The WhereClause type exposes the following properties.

Properties

Name | Description
Clause1 | The WHERE clause used on the table in the first database.
Clause2 | The WHERE clause used on the table in the second database.

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause1 Property

[image]

SQL Data Compare API 7.1.0
WhereClause..::.Clause1 Property
WhereClause Class See Also

The WHERE clause used on the table in the first database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clause1 As String
C#
public string Clause1 { get; set; }
Visual C++
public:
property String^ Clause1 {
    String^ get ();
    void set (String^ value);
}

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


Clause2 Property

[image]

SQL Data Compare API 7.1.0
WhereClause..::.Clause2 Property
WhereClause Class See Also

The WHERE clause used on the table in the second database.

Namespace: RedGate.SQLDataCompare.Engine
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Clause2 As String
C#
public string Clause2 { get; set; }
Visual C++
public:
property String^ Clause2 {
    String^ get ();
    void set (String^ value);
}

See Also

WhereClause Class
RedGate.SQLDataCompare.Engine Namespace


RedGate.SQLDataCompare.Engine.ResultsStore Namespace

[image]

SQL Data Compare API 7.1.0
RedGate.SQLDataCompare.Engine.ResultsStore Namespace

Classes

Class | Description
ColumnConstraint | A class to filter the ResultsStore on field data.
ColumnRange | A range for a ColumnConstraint. A ColumnConstraint can contain a number of ranges.
ColumnSort | A class to sort the ResultsStore by field data.
ColumnSorts | A collection of ColumnSorts to be applied to a ResultsStore.
Filter | Used to create a filtered ResultsStore using the ApplyFilter method.
Missing | Signifies a Missing result, for which there is no value in the ResultsStore. There is a singleton class of this type, so all reference comparisons are valid.
Reader | Reads data from a results store. Can be created using GetReader()()().
ResultsStoreException | Exception thrown by classes in the RedGate.SQLDataCompare.Engine.ResultsStore namespace when it encounters an error.
Row | A row containing data in a ResultsStore object.
Sort | Used to specify a sort order for the ResultsStore when using ApplySort()()().
Store | A data set containing a collection of rows.
StoreEnumerator | This is the enumerator for a ResultsStore or Reader.

Enumerations

Enumeration | Description
FieldType | The types of field that a ResultsStore can contain.
Row..::.RowType | The type of the row. The values All and TotalDifferent can be used for DifferenceCount()()().


ColumnConstraint Class

[image]

SQL Data Compare API 7.1.0
ColumnConstraint Class
Members See Also

A class to filter the ResultsStore on field data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ColumnConstraint
C#
public class ColumnConstraint
Visual C++
public ref class ColumnConstraint

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnConstraint

See Also

ColumnConstraint Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Members

[image] [image]

SQL Data Compare API 7.1.0
ColumnConstraint Members
ColumnConstraint Class Constructors Methods Properties See Also

The ColumnConstraint type exposes the following members.

Constructors

Name | Description
ColumnConstraint | Constructs a new ColumnConstraint object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConstraintRanges | A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.
FieldPair | The FieldPair to be filtered.
InOne | The constraint is to be used on the field in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Constructor

[image]

SQL Data Compare API 7.1.0
ColumnConstraint Constructor
ColumnConstraint Class See Also

Constructs a new ColumnConstraint object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fieldPair As FieldPair, _
    inOne As Boolean _
)
C#
public ColumnConstraint(
    FieldPair fieldPair,
    bool inOne
)
Visual C++
public:
ColumnConstraint(
    FieldPair^ fieldPair,
    bool inOne
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair being filtered.
inOne
Type: System..::.Boolean
true if the field is being filtered on the data in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraint Properties

[image] [image]

SQL Data Compare API 7.1.0
ColumnConstraint Properties
ColumnConstraint Class See Also

The ColumnConstraint type exposes the following properties.

Properties

Name | Description
ConstraintRanges | A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.
FieldPair | The FieldPair to be filtered.
InOne | The constraint is to be used on the field in the first database.

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ConstraintRanges Property

[image]

SQL Data Compare API 7.1.0
ColumnConstraint..::.ConstraintRanges Property
ColumnConstraint Class See Also

A set of ColumnRanges. The field must conform to at least one of the ColumnRanges.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConstraintRanges As IList(Of ColumnRange)
C#
public IList<ColumnRange> ConstraintRanges { get; }
Visual C++
public:
property IList<ColumnRange^>^ ConstraintRanges {
    IList<ColumnRange^>^ get ();
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldPair Property

[image]

SQL Data Compare API 7.1.0
ColumnConstraint..::.FieldPair Property
ColumnConstraint Class See Also

The FieldPair to be filtered.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldPair As FieldPair
C#
public FieldPair FieldPair { get; set; }
Visual C++
public:
property FieldPair^ FieldPair {
    FieldPair^ get ();
    void set (FieldPair^ value);
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


InOne Property

[image]

SQL Data Compare API 7.1.0
ColumnConstraint..::.InOne Property
ColumnConstraint Class See Also

The constraint is to be used on the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InOne As Boolean
C#
public bool InOne { get; set; }
Visual C++
public:
property bool InOne {
    bool get ();
    void set (bool value);
}

See Also

ColumnConstraint Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Class

[image]

SQL Data Compare API 7.1.0
ColumnRange Class
Members See Also

A range for a ColumnConstraint. A ColumnConstraint can contain a number of ranges.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class ColumnRange
C#
public class ColumnRange
Visual C++
public ref class ColumnRange

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnRange

See Also

ColumnRange Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Members

[image] [image]

SQL Data Compare API 7.1.0
ColumnRange Members
ColumnRange Class Constructors Methods Properties See Also

The ColumnRange type exposes the following members.

Constructors

Name | Description
ColumnRange | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsMissing | If set, the field value must be Missing. IsNull takes priority over this property.
IsNull | If set, the field must be null. This property takes priority over IsMissing.
MaxValue | The maximum (inclusive) value for a field.
MinValue | The minimum (inclusive) value for a field.

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor

[image] [image]

SQL Data Compare API 7.1.0
ColumnRange Constructor
ColumnRange Class See Also

Overload List

Name | Description
ColumnRange(Boolean) | Constructs a range constraint in which the field must be null if true, or not null if false.
ColumnRange(IComparable) | Constructs a range constraint for a field filter in which the field must be greater than or equal to the specified value.
ColumnRange(IComparable, IComparable) | Constructs a range constraint for a field filter in which the field must be greater than or equal to the minimum value, and less than or equal to the maximum value.

See Also

ColumnRange Class
ColumnRange Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor (Boolean)

[image]

SQL Data Compare API 7.1.0
ColumnRange Constructor (Boolean)
ColumnRange Class See Also

Constructs a range constraint in which the field must be null if true, or not null if false.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isNull As Boolean _
)
C#
public ColumnRange(
    bool isNull
)
Visual C++
public:
ColumnRange(
    bool isNull
)

Parameters

isNull
Type: System..::.Boolean
true if the field must be null.

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor (IComparable)

[image]

SQL Data Compare API 7.1.0
ColumnRange Constructor (IComparable)
ColumnRange Class See Also

Constructs a range constraint for a field filter in which the field must be greater than or equal to the specified value.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    minValue As IComparable _
)
C#
public ColumnRange(
    IComparable minValue
)
Visual C++
public:
ColumnRange(
    IComparable^ minValue
)

Parameters

minValue
Type: System..::.IComparable
The minimum value (inclusive).

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Constructor (IComparable, IComparable)

[image]

SQL Data Compare API 7.1.0
ColumnRange Constructor (IComparable, IComparable)
ColumnRange Class See Also

Constructs a range constraint for a field filter in which the field must be greater than or equal to the minimum value, and less than or equal to the maximum value.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    minValue As IComparable, _
    maxValue As IComparable _
)
C#
public ColumnRange(
    IComparable minValue,
    IComparable maxValue
)
Visual C++
public:
ColumnRange(
    IComparable^ minValue,
    IComparable^ maxValue
)

Parameters

minValue
Type: System..::.IComparable
The minimum value (inclusive).
maxValue
Type: System..::.IComparable
The maximum value (inclusive).

See Also

ColumnRange Class
ColumnRange Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnRange Properties

[image] [image]

SQL Data Compare API 7.1.0
ColumnRange Properties
ColumnRange Class See Also

The ColumnRange type exposes the following properties.

Properties

Name | Description
IsMissing | If set, the field value must be Missing. IsNull takes priority over this property.
IsNull | If set, the field must be null. This property takes priority over IsMissing.
MaxValue | The maximum (inclusive) value for a field.
MinValue | The minimum (inclusive) value for a field.

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IsMissing Property

[image]

SQL Data Compare API 7.1.0
ColumnRange..::.IsMissing Property
ColumnRange Class See Also

If set, the field value must be Missing. IsNull takes priority over this property.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMissing As Boolean
C#
public bool IsMissing { get; set; }
Visual C++
public:
property bool IsMissing {
    bool get ();
    void set (bool value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IsNull Property

[image]

SQL Data Compare API 7.1.0
ColumnRange..::.IsNull Property
ColumnRange Class See Also

If set, the field must be null. This property takes priority over IsMissing.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property IsNull As Boolean
C#
public bool IsNull { get; set; }
Visual C++
public:
property bool IsNull {
    bool get ();
    void set (bool value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


MaxValue Property

[image]

SQL Data Compare API 7.1.0
ColumnRange..::.MaxValue Property
ColumnRange Class See Also

The maximum (inclusive) value for a field.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxValue As IComparable
C#
public IComparable MaxValue { get; set; }
Visual C++
public:
property IComparable^ MaxValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


MinValue Property

[image]

SQL Data Compare API 7.1.0
ColumnRange..::.MinValue Property
ColumnRange Class See Also

The minimum (inclusive) value for a field.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property MinValue As IComparable
C#
public IComparable MinValue { get; set; }
Visual C++
public:
property IComparable^ MinValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

See Also

ColumnRange Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Class

[image]

SQL Data Compare API 7.1.0
ColumnSort Class
Members See Also

A class to sort the ResultsStore by field data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnSort
C#
public sealed class ColumnSort
Visual C++
public ref class ColumnSort sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSort

See Also

ColumnSort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Members

[image] [image]

SQL Data Compare API 7.1.0
ColumnSort Members
ColumnSort Class Constructors Methods Properties See Also

The ColumnSort type exposes the following members.

Constructors

Name | Description
ColumnSort | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ascending | Specifies whether the field is sorted ascending or descending.
FieldPair | The name of the field being sorted.
InOne | Sort by the field in the first database.
SortByType | Sorts by the type.

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor

[image] [image]

SQL Data Compare API 7.1.0
ColumnSort Constructor
ColumnSort Class See Also

Overload List

Name | Description
ColumnSort()()() | Constructs a new ColumnSort object for sorting by type. SortByType is set to true.
ColumnSort(FieldPair, Boolean) | Constructs a new ColumnSort object.

See Also

ColumnSort Class
ColumnSort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor

[image]

SQL Data Compare API 7.1.0
ColumnSort Constructor
ColumnSort Class See Also

Constructs a new ColumnSort object for sorting by type. SortByType is set to true.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ColumnSort()
Visual C++
public:
ColumnSort()

See Also

ColumnSort Class
ColumnSort Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Constructor (FieldPair, Boolean)

[image]

SQL Data Compare API 7.1.0
ColumnSort Constructor (FieldPair, Boolean)
ColumnSort Class See Also

Constructs a new ColumnSort object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fieldPair As FieldPair, _
    inOne As Boolean _
)
C#
public ColumnSort(
    FieldPair fieldPair,
    bool inOne
)
Visual C++
public:
ColumnSort(
    FieldPair^ fieldPair,
    bool inOne
)

Parameters

fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair being sorted.
inOne
Type: System..::.Boolean
The field is being sorted using the data in the first database.

See Also

ColumnSort Class
ColumnSort Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSort Properties

[image] [image]

SQL Data Compare API 7.1.0
ColumnSort Properties
ColumnSort Class See Also

The ColumnSort type exposes the following properties.

Properties

Name | Description
Ascending | Specifies whether the field is sorted ascending or descending.
FieldPair | The name of the field being sorted.
InOne | Sort by the field in the first database.
SortByType | Sorts by the type.

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Ascending Property

[image]

SQL Data Compare API 7.1.0
ColumnSort..::.Ascending Property
ColumnSort Class See Also

Specifies whether the field is sorted ascending or descending.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Ascending As Boolean
C#
public bool Ascending { get; set; }
Visual C++
public:
property bool Ascending {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldPair Property

[image]

SQL Data Compare API 7.1.0
ColumnSort..::.FieldPair Property
ColumnSort Class See Also

The name of the field being sorted.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldPair As FieldPair
C#
public FieldPair FieldPair { get; set; }
Visual C++
public:
property FieldPair^ FieldPair {
    FieldPair^ get ();
    void set (FieldPair^ value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


InOne Property

[image]

SQL Data Compare API 7.1.0
ColumnSort..::.InOne Property
ColumnSort Class See Also

Sort by the field in the first database.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property InOne As Boolean
C#
public bool InOne { get; set; }
Visual C++
public:
property bool InOne {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


SortByType Property

[image]

SQL Data Compare API 7.1.0
ColumnSort..::.SortByType Property
ColumnSort Class See Also

Sorts by the type.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property SortByType As Boolean
C#
public bool SortByType { get; set; }
Visual C++
public:
property bool SortByType {
    bool get ();
    void set (bool value);
}

See Also

ColumnSort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Class

[image]

SQL Data Compare API 7.1.0
ColumnSorts Class
Members See Also

A collection of ColumnSorts to be applied to a ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnSorts _
    Inherits InnerList(Of ColumnSort)
C#
public sealed class ColumnSorts : InnerList<ColumnSort>
Visual C++
public ref class ColumnSorts sealed : public InnerList<ColumnSort^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils.Collections..::.EnumerableBase <(Of <( ColumnSort >)>)
RedGate.Shared.Utils.Collections..::.InnerList <(Of <( ColumnSort >)>)
RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSorts

See Also

ColumnSorts Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Members

[image] [image]

SQL Data Compare API 7.1.0
ColumnSorts Members
ColumnSorts Class Methods Properties Explicit Interface Implementations See Also

The ColumnSorts type exposes the following members.

Methods

Name | Description
Add | Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Add(UTP).)
Clear | Removes all ColumnSorts from the collection. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Clear()()().)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAt | Removes the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::.RemoveAt(Int32).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Returns the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::. Item[([(Int32])]).)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Methods

[image] [image]

SQL Data Compare API 7.1.0
ColumnSorts Methods
ColumnSorts Class See Also

The ColumnSorts type exposes the following methods.

Methods

Name | Description
Add | Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Add(UTP).)
Clear | Removes all ColumnSorts from the collection. (Overrides InnerList <(Of <( ColumnSort >)>)..::.Clear()()().)
Contains | (Inherited from InnerList<(Of <(T>)>).)
CopyTo | (Inherited from InnerList<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | (Inherited from InnerList<(Of <(T>)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | (Inherited from InnerList<(Of <(T>)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveAt | Removes the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::.RemoveAt(Int32).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from EnumerableBase<(Of <(T>)>).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Add Method

[image]

SQL Data Compare API 7.1.0
ColumnSorts..::.Add Method
ColumnSorts Class See Also

Adds ColumnSort to the ColumnSorts collection. ColumnSorts are added in order.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Add ( _
    value As ColumnSort _
)
C#
public override void Add(
    ColumnSort value
)
Visual C++
public:
virtual void Add(
    ColumnSort^ value
) override

Parameters

value
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.ColumnSort
The ColumnSort to be added.

Return Value

The index of the new ColumnSort.

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Clear Method

[image]

SQL Data Compare API 7.1.0
ColumnSorts..::.Clear Method
ColumnSorts Class See Also

Removes all ColumnSorts from the collection.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear
C#
public override void Clear()
Visual C++
public:
virtual void Clear() override

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RemoveAt Method

[image]

SQL Data Compare API 7.1.0
ColumnSorts..::.RemoveAt Method
ColumnSorts Class See Also

Removes the ColumnSort at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub RemoveAt ( _
    index As Integer _
)
C#
public override void RemoveAt(
    int index
)
Visual C++
public:
virtual void RemoveAt(
    int index
) override

Parameters

index
Type: System..::.Int32
The index of the ColumnSort to be removed.

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Properties

[image] [image]

SQL Data Compare API 7.1.0
ColumnSorts Properties
ColumnSorts Class See Also

The ColumnSorts type exposes the following properties.

Properties

Name | Description
Count | (Inherited from InnerList<(Of <(T>)>).)
Item | Returns the ColumnSort at the specified index. (Overrides InnerList <(Of <( ColumnSort >)>)..::. Item[([(Int32])]).)

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Item Property

[image]

SQL Data Compare API 7.1.0
ColumnSorts..::.Item Property
ColumnSorts Class See Also

Returns the ColumnSort at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Default Property Item ( _
    index As Integer _
) As ColumnSort
C#
public override ColumnSort this[
    int index
] { set; }
Visual C++
public:
virtual property ColumnSort^ default[int index] {
    void set (int index, ColumnSort^ value) override;
}

Parameters

index
Type: System..::.Int32
The zero-based index of the ColumnSort to get or set.

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ColumnSorts Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldType Enumeration

[image]

SQL Data Compare API 7.1.0
FieldType Enumeration
See Also

The types of field that a ResultsStore can contain.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FieldType
C#
public enum FieldType
Visual C++
public enum class FieldType

Members

Member name | Description
Empty | Not used.
Integer8 | 8-bit signed integer.
Integer16 | 16-bit signed integer.
Integer32 | 32-bit signed integer.
Integer64 | 64-bit signed integer.
Byte | 8-bit unsigned integer.
UInteger16 | 16-bit unsigned integer.
UInteger32 | 32-bit unsigned integer.
UInteger64 | 64-bit unsigned integer.
Single | Single-precision, 32-bit number.
Boolean | Boolean, True/False value.
String | String or XML.
Double | Double-precision, 64-bit number.
DateTime | Date and time.
Binary | Binary data.
Decimal | High-precision, decimal number suitable for financial information.
Object | An object.
Clr | A CLR type.
SortByte | An byte for sorting by type (cannot be compared).
Guid | A GUID/unique identifier.
Date | Date only
Time | Time only
DateTime2 | Datetime2
DateTimeOffset | DateTimeOffset
TimeSpan |

See Also

RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Class

[image]

SQL Data Compare API 7.1.0
Filter Class
Members See Also

Used to create a filtered ResultsStore using the ApplyFilter method.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Filter
C#
public class Filter
Visual C++
public ref class Filter

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Filter

See Also

Filter Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Members

[image] [image]

SQL Data Compare API 7.1.0
Filter Members
Filter Class Methods Properties See Also

The Filter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnConstraints | The ColumnConstraints for the filter.

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Properties

[image] [image]

SQL Data Compare API 7.1.0
Filter Properties
Filter Class See Also

The Filter type exposes the following properties.

Properties

Name | Description
ColumnConstraints | The ColumnConstraints for the filter.

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnConstraints Property

[image]

SQL Data Compare API 7.1.0
Filter..::.ColumnConstraints Property
Filter Class See Also

The ColumnConstraints for the filter.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnConstraints As IList(Of ColumnConstraint)
C#
public IList<ColumnConstraint> ColumnConstraints { get; }
Visual C++
public:
property IList<ColumnConstraint^>^ ColumnConstraints {
    IList<ColumnConstraint^>^ get ();
}

See Also

Filter Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Class

[image]

SQL Data Compare API 7.1.0
Missing Class
Members See Also

Signifies a Missing result, for which there is no value in the ResultsStore. There is a singleton class of this type, so all reference comparisons are valid.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Missing _
    Implements IComparable
C#
public class Missing : IComparable
Visual C++
public ref class Missing : IComparable

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Missing

See Also

Missing Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Members

[image] [image]

SQL Data Compare API 7.1.0
Missing Members
Missing Class Methods See Also

The Missing type exposes the following members.

Methods

Name | Description
CompareTo | Compares Missing objects, for which there is no value in the ResultsStore.
Equals | Indicates whether the Missing instance is identical to a specified object. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns the hash code for the instance. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Missing". (Overrides Object ..::. ToString()()().)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Methods

[image] [image]

SQL Data Compare API 7.1.0
Missing Methods
Missing Class See Also

The Missing type exposes the following methods.

Methods

Name | Description
CompareTo | Compares Missing objects, for which there is no value in the ResultsStore.
Equals | Indicates whether the Missing instance is identical to a specified object. (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. Returns the hash code for the instance. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns "Missing". (Overrides Object ..::. ToString()()().)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


CompareTo Method

[image]

SQL Data Compare API 7.1.0
Missing..::.CompareTo Method
Missing Class See Also

Compares Missing objects, for which there is no value in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
C#
public int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object
The object to be compared.

Return Value

Zero if the object is a Missing object; otherwise -1.

Implements

IComparable..::.CompareTo(Object)

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Equals Method

[image]

SQL Data Compare API 7.1.0
Missing..::.Equals Method
Missing Class See Also

Indicates whether the Missing instance is identical to a specified object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object
The object to compare.

Return Value

true if the underlying Missing data is the same; otherwise, false.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetHashCode Method

[image]

SQL Data Compare API 7.1.0
Missing..::.GetHashCode Method
Missing Class See Also

Overridden. Returns the hash code for the instance.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

Exceptions

Exception | Condition
System..::.NotSupportedException | Missing class is used as a singleton; unable to create a hash code.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ToString Method

[image]

SQL Data Compare API 7.1.0
Missing..::.ToString Method
Missing Class See Also

Returns "Missing".

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

Missing.

See Also

Missing Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Class

[image]

SQL Data Compare API 7.1.0
Reader Class
Members See Also

Reads data from a results store. Can be created using GetReader()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Reader _
    Inherits DisposableBase _
    Implements IEnumerable(Of Row), IEnumerable,  _
    ICancellable
C#
public sealed class Reader : DisposableBase, IEnumerable<Row>,
    IEnumerable, ICancellable
Visual C++
public ref class Reader sealed : public DisposableBase,
    IEnumerable<Row^>, IEnumerable, ICancellable

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader

See Also

Reader Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Members

[image] [image]

SQL Data Compare API 7.1.0
Reader Members
Reader Class Methods Properties Explicit Interface Implementations See Also

The Reader type exposes the following members.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a ResultsStore StoreEnumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Missing | Compare against this singleton to check for Missing values.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Methods

[image] [image]

SQL Data Compare API 7.1.0
Reader Methods
Reader Class See Also

The Reader type exposes the following methods.

Methods

Name | Description
ApplyFilter | Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.
ApplySort | Sorts the ResultsStore according to SortOrder.
CancelOperation | Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a ResultsStore StoreEnumerator.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a row at the specified index.
GetRowType | Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.
GetSummaryRow | Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReverseSort | Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplyFilter Method

[image]

SQL Data Compare API 7.1.0
Reader..::.ApplyFilter Method
Reader Class See Also

Applies the ResultsStore Filter class to the Reader. Any access to this Reader after the filter has been applied will access only the filtered data.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplyFilter ( _
    useOriginalResultsStore As Boolean _
)
C#
public void ApplyFilter(
    bool useOriginalResultsStore
)
Visual C++
public:
void ApplyFilter(
    bool useOriginalResultsStore
)

Parameters

useOriginalResultsStore
Type: System..::.Boolean
When true, the filter will be applied to the original ResultsStore; when false, the filter will be applied to the current state of the ResultsStore.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ApplySort Method

[image]

SQL Data Compare API 7.1.0
Reader..::.ApplySort Method
Reader Class See Also

Sorts the ResultsStore according to SortOrder.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplySort
C#
public void ApplySort()
Visual C++
public:
void ApplySort()

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Unable to sort when using a compressed results store.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


CancelOperation Method

[image]

SQL Data Compare API 7.1.0
Reader..::.CancelOperation Method
Reader Class See Also

Cancels the running operation. This may be a ApplyFilter(Boolean) or a ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelOperation
C#
public void CancelOperation()
Visual C++
public:
virtual void CancelOperation() sealed

Implements

ICancellable..::.CancelOperation()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
Reader..::.Dispose Method
Reader Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | Method called when disposing or finalizing. (Inherited from DisposableBase.)

See Also

Reader Class
Reader Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
Reader..::.GetEnumerator Method
Reader Class See Also

Returns a ResultsStore StoreEnumerator.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Row)
C#
public IEnumerator<Row> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed

Return Value

Enumerator for the ResultsStore.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IEnumerable.GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
Reader..::.IEnumerable..::.GetEnumerator Method
Reader Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRow Method

[image]

SQL Data Compare API 7.1.0
Reader..::.GetRow Method
Reader Class See Also

Gets a row at the specified index.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRow ( _
    index As Integer _
) As Row
C#
public Row GetRow(
    int index
)
Visual C++
public:
Row^ GetRow(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Remarks

The current row depends on how the ResultsStore is currently sorted

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetRowType Method

[image]

SQL Data Compare API 7.1.0
Reader..::.GetRowType Method
Reader Class See Also

Gets the type of a row at the specified index. Does not retrieve all the row fields if not needed.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRowType ( _
    index As Integer _
) As Row..::.RowType
C#
public Row..::.RowType GetRowType(
    int index
)
Visual C++
public:
Row..::.RowType GetRowType(
    int index
)

Parameters

index
Type: System..::.Int32

Return Value

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetSummaryRow Method

[image]

SQL Data Compare API 7.1.0
Reader..::.GetSummaryRow Method
Reader Class See Also

Gets a summary row at the specified index. If the current row has already been retrieved in full, the complete row is returned.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSummaryRow ( _
    index As Integer _
) As Row
C#
public Row GetSummaryRow(
    int index
)
Visual C++
public:
Row^ GetSummaryRow(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the row to retrieve.

Return Value

The row at the requested index.

Remarks

The current row depends on how the ResultsStore is currently sorted.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ReverseSort Method

[image]

SQL Data Compare API 7.1.0
Reader..::.ReverseSort Method
Reader Class See Also

Reverses the current order of the ResultsStore. This is a fast operation; it is much quicker than applying the sort in the reverse order.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReverseSort
C#
public void ReverseSort()
Visual C++
public:
void ReverseSort()

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reader Properties

[image] [image]

SQL Data Compare API 7.1.0
Reader Properties
Reader Class See Also

The Reader type exposes the following properties.

Properties

Name | Description
Fields | Returns the fields for the current reader.
Filter | The filter used to generate a filtered ResultsStore.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Missing | Compare against this singleton to check for Missing values.
Position | Gets and sets the absolute position of the current row.
RowCount | Returns the row count for the current reader.
SortOrder | The sort order to be used on the current ResultsStore.
Status | The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Fields Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Fields Property
Reader Class See Also

Returns the fields for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldPairs
C#
public FieldPairs Fields { get; }
Visual C++
public:
property FieldPairs^ Fields {
    FieldPairs^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Filter Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Filter Property
Reader Class See Also

The filter used to generate a filtered ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter
C#
public Filter Filter { get; }
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Missing Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Missing Property
Reader Class See Also

Compare against this singleton to check for Missing values.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Missing As Missing
C#
public static Missing Missing { get; }
Visual C++
public:
static property Missing^ Missing {
    Missing^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Position Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Position Property
Reader Class See Also

Gets and sets the absolute position of the current row.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As Integer
C#
public int Position { get; set; }
Visual C++
public:
property int Position {
    int get ();
    void set (int value);
}

Remarks

This depends on the current sorting of the ResultsStore.

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Invalid row index.

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RowCount Property

[image]

SQL Data Compare API 7.1.0
Reader..::.RowCount Property
Reader Class See Also

Returns the row count for the current reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
C#
public int RowCount { get; }
Visual C++
public:
property int RowCount {
    int get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


SortOrder Property

[image]

SQL Data Compare API 7.1.0
Reader..::.SortOrder Property
Reader Class See Also

The sort order to be used on the current ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortOrder As Sort
C#
public Sort SortOrder { get; }
Visual C++
public:
property Sort^ SortOrder {
    Sort^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Status Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Status Property
Reader Class See Also

The status handler for the ApplySort()()() or ApplyFilter(Boolean) operations.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As StatusEventHandler
C#
public StatusEventHandler Status { get; set; }
Visual C++
public:
virtual property StatusEventHandler^ Status {
    StatusEventHandler^ get () sealed;
    void set (StatusEventHandler^ value) sealed;
}

Implements

ICancellable..::.Status

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Where Property

[image]

SQL Data Compare API 7.1.0
Reader..::.Where Property
Reader Class See Also

Contains the WHERE clause that was used to create the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Where As WhereClause
C#
public WhereClause Where { get; }
Visual C++
public:
property WhereClause^ Where {
    WhereClause^ get ();
}

See Also

Reader Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Class

[image]

SQL Data Compare API 7.1.0
ResultsStoreException Class
Members See Also

Exception thrown by classes in the RedGate.SQLDataCompare.Engine.ResultsStore namespace when it encounters an error.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ResultsStoreException _
    Inherits SqlDataCompareException
C#
[SerializableAttribute]
public class ResultsStoreException : SqlDataCompareException
Visual C++
[SerializableAttribute]
public ref class ResultsStoreException : public SqlDataCompareException

Inheritance Hierarchy

System..::.Object
System..::.Exception
RedGate.SQLDataCompare.Engine..::.SqlDataCompareException
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException

See Also

ResultsStoreException Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Members

[image] [image]

SQL Data Compare API 7.1.0
ResultsStoreException Members
ResultsStoreException Class Constructors Methods Properties See Also

The ResultsStoreException type exposes the following members.

Constructors

Name | Description
ResultsStoreException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ResultsStoreException Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor

[image] [image]

SQL Data Compare API 7.1.0
ResultsStoreException Constructor
ResultsStoreException Class See Also

Overload List

Name | Description
ResultsStoreException()()() | Creates a new exception.
ResultsStoreException(String) | Creates a new exception with the specified detail message.
ResultsStoreException(SerializationInfo, StreamingContext) | This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.
ResultsStoreException(String, Exception) | Creates a new exception with the specified detail message and cause.

See Also

ResultsStoreException Class
ResultsStoreException Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor

[image]

SQL Data Compare API 7.1.0
ResultsStoreException Constructor
ResultsStoreException Class See Also

Creates a new exception.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ResultsStoreException()
Visual C++
public:
ResultsStoreException()

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor (String)

[image]

SQL Data Compare API 7.1.0
ResultsStoreException Constructor (String)
ResultsStoreException Class See Also

Creates a new exception with the specified detail message.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ResultsStoreException(
    string message
)
Visual C++
public:
ResultsStoreException(
    String^ message
)

Parameters

message
Type: System..::.String
Detail message.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor (SerializationInfo, StreamingContext)

[image]

SQL Data Compare API 7.1.0
ResultsStoreException Constructor (SerializationInfo, StreamingContext)
ResultsStoreException Class See Also

This constructor is called during deserialization to reconstitute the exception object transmitted over a stream. For more information, see XML and SOAP Serialization.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected ResultsStoreException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
ResultsStoreException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The contextual information about the source or destination.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ResultsStoreException Constructor (String, Exception)

[image]

SQL Data Compare API 7.1.0
ResultsStoreException Constructor (String, Exception)
ResultsStoreException Class See Also

Creates a new exception with the specified detail message and cause.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    cause As Exception _
)
C#
public ResultsStoreException(
    string message,
    Exception cause
)
Visual C++
public:
ResultsStoreException(
    String^ message,
    Exception^ cause
)

Parameters

message
Type: System..::.String
Detail message.
cause
Type: System..::.Exception
Cause of exception.

See Also

ResultsStoreException Class
ResultsStoreException Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Class

[image]

SQL Data Compare API 7.1.0
Row Class
Members See Also

A row containing data in a ResultsStore object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Row
C#
public sealed class Row
Visual C++
public ref class Row sealed

Remarks

See RedGate.SQLDataCompare.Engine.ResultsStore for more information and code samples.

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Row

See Also

Row Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Members

[image] [image]

SQL Data Compare API 7.1.0
Row Members
Row Class Methods Properties See Also

The Row type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldDifferent | Returns true if the FieldPair of the specified ordinal is different.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | The bookmark of the row in the ResultsStore.
Index | The index of the row in the ResultsStore.
Type | The type of the results in the row from Row..::.RowType.
Values | The values of the fields in the row.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Methods

[image] [image]

SQL Data Compare API 7.1.0
Row Methods
Row Class See Also

The Row type exposes the following methods.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FieldDifferent | Returns true if the FieldPair of the specified ordinal is different.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FieldDifferent Method

[image]

SQL Data Compare API 7.1.0
Row..::.FieldDifferent Method
Row Class See Also

Returns true if the FieldPair of the specified ordinal is different.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function FieldDifferent ( _
    fieldIndex As Integer _
) As Boolean
C#
public bool FieldDifferent(
    int fieldIndex
)
Visual C++
public:
bool FieldDifferent(
    int fieldIndex
)

Parameters

fieldIndex
Type: System..::.Int32
Ordinal of the FieldPair in the ResultsStore.

Return Value

true if values are different; otherwise false.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row Properties

[image] [image]

SQL Data Compare API 7.1.0
Row Properties
Row Class See Also

The Row type exposes the following properties.

Properties

Name | Description
Bookmark | The bookmark of the row in the ResultsStore.
Index | The index of the row in the ResultsStore.
Type | The type of the results in the row from Row..::.RowType.
Values | The values of the fields in the row.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Bookmark Property

[image]

SQL Data Compare API 7.1.0
Row..::.Bookmark Property
Row Class See Also

The bookmark of the row in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmark As Integer
C#
public int Bookmark { get; }
Visual C++
public:
property int Bookmark {
    int get ();
}

Remarks

The Bookmark property is independent of how the ResultsStore is sorted. Note that using the bookmark property is slow.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Index Property

[image]

SQL Data Compare API 7.1.0
Row..::.Index Property
Row Class See Also

The index of the row in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
C#
public int Index { get; }
Visual C++
public:
property int Index {
    int get ();
}

Remarks

The Index property changes as the ResultsStore is sorted.

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Type Property

[image]

SQL Data Compare API 7.1.0
Row..::.Type Property
Row Class See Also

The type of the results in the row from Row..::.RowType.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Row..::.RowType
C#
public Row..::.RowType Type { get; }
Visual C++
public:
property Row..::.RowType Type {
    Row..::.RowType get ();
}

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Values Property

[image]

SQL Data Compare API 7.1.0
Row..::.Values Property
Row Class See Also

The values of the fields in the row.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As Object()
C#
public Object[] Values { get; }
Visual C++
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
}

See Also

Row Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Row.RowType Enumeration

[image]

SQL Data Compare API 7.1.0
Row..::.RowType Enumeration
Row Class See Also

The type of the row. The values All and TotalDifferent can be used for DifferenceCount()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration RowType
C#
public enum RowType
Visual C++
public enum class RowType

Members

Member name | Description
In1 | Data exists only in the first database.
Different | Data exists in both databases and is different.
In2 | Data exists only in the second database.
Same | All data is identical.
All | All rows. Used for indexing Readers. Not a true row type.
TotalDifferent | The rows that differ, (Different, In1, and In2). Not a true row type.

See Also

RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Class

[image]

SQL Data Compare API 7.1.0
Sort Class
Members See Also

Used to specify a sort order for the ResultsStore when using ApplySort()()().

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Sort
C#
public sealed class Sort
Visual C++
public ref class Sort sealed

Inheritance Hierarchy

System..::.Object
RedGate.SQLDataCompare.Engine.ResultsStore..::.Sort

See Also

Sort Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Members

[image] [image]

SQL Data Compare API 7.1.0
Sort Members
Sort Class Methods Properties See Also

The Sort type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnSorts | A collection of ColumnSort objects.

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Sort Properties

[image] [image]

SQL Data Compare API 7.1.0
Sort Properties
Sort Class See Also

The Sort type exposes the following properties.

Properties

Name | Description
ColumnSorts | A collection of ColumnSort objects.

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


ColumnSorts Property

[image]

SQL Data Compare API 7.1.0
Sort..::.ColumnSorts Property
Sort Class See Also

A collection of ColumnSort objects.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnSorts As ColumnSorts
C#
public ColumnSorts ColumnSorts { get; }
Visual C++
public:
property ColumnSorts^ ColumnSorts {
    ColumnSorts^ get ();
}

See Also

Sort Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Class

[image]

SQL Data Compare API 7.1.0
Store Class
Members Example See Also

A data set containing a collection of rows.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class Store _
    Inherits DisposableBase _
    Implements IEnumerable(Of Row), IEnumerable
C#
public class Store : DisposableBase, IEnumerable<Row>,
    IEnumerable
Visual C++
public ref class Store : public DisposableBase,
    IEnumerable<Row^>, IEnumerable

Remarks

SQL Data Compare returns results from a comparison as a ResultsStore class. A ResultsStore contains a number of field definitions. The fields can be of a number of different data types.

See FieldPair for more information on how to cross reference the ResultsStore to the underlying database tables being compared.

To access the data in a ResultsStore, use the GetReader()()() method to retrieve a Reader that can be used for data sorting, filtering and retrieval. You can also use the GetEnumerator()()() to retreive a StoreEnumerator that can be used to access the ResultsStore quickly.

Examples

Printing out different records in a table.
C# Copy Code
            using System;
            using RedGate.SQLCompare.Engine;
            using RedGate.SQLDataCompare.Engine;
            using RedGate.SQLDataCompare.Engine.ResultsStore;

            namespace SQLDataCompareCodeSnippets
            {
                /// <summary>
                /// Summary description for StoreExample.
                /// </summary>
                public class StoreExample
                {
                    public void RunExample()
                    {
                        Database db1=new Database();
                        Database db2=new Database();

                        db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
                        db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));

                        using(ComparisonSession session=new ComparisonSession())
                        {

                            // Create the mappings between the two databases
                            TableMappings mappings = new TableMappings();
                            mappings.CreateMappings(db1.Tables, db2.Tables);

                            session.CompareDatabases(db1, db2, mappings);

                            Reader resultsReader=session.TableDifferences["[dbo].[Widgets]"].ResultsStore.GetReader();

                            // work out the two positions in the fields
                            int description1=resultsReader.Fields["Description"].OrdinalInResults1;
                            int description2=resultsReader.Fields["Description"].OrdinalInResults2;

                            // work out the position of the RecordID column
                            // this is part of the unique index we are comparing on
                            int recordID=resultsReader.Fields["RecordID"].OrdinalInResults1;

                            // sort by description in the first database
                            resultsReader.SortOrder.ColumnSorts.Add(new ColumnSort(resultsReader.Fields["Description"], true));
                            resultsReader.ApplySort();

                            foreach(Row row in resultsReader)
                            {
                                Console.Write("{0}:{1},{2}", row.Values[recordID], row.Values[description1], row.Values[description2]);
                                Console.WriteLine();
                            }
                        }
                        db1.Dispose();
                        db2.Dispose();
                    }
                }
            }
Visual Basic Copy Code
            Option Explicit On

            Imports RedGate.SQLCompare.Engine
            Imports RedGate.SQLDataCompare.Engine
            Imports RedGate.SQLDataCompare.Engine.ResultsStore

            Public Class StoreExample
                Sub RunExample()
                    Dim session As New ComparisonSession

                    'register the databases for comparison
                    Dim db1 As New Database
                    Dim db2 As New Database

                    db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
                    db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))

                    'create an intersection of the tables
                    Dim mappings As New TableMappings
                    mappings.CreateMappings(db1.Tables, db2.Tables)

                    'compare the databases
                    session.CompareDatabases(db1, db2, mappings)

                    Dim resultsReader As Reader = session.TableDifferences("[dbo].[Widgets]").ResultsStore.GetReader

                    'work out the two positions in the fields
                    Dim description1 As Integer = resultsReader.Fields("Description").OrdinalInResults1
                    Dim description2 As Integer = resultsReader.Fields("Description").OrdinalInResults2

                    'work out the position of the RecordID column
                    'this is part of the unique index we are comparing on

                    Dim recordID As Integer = resultsReader.Fields("RecordID").OrdinalInResults1

                    'sort by description in the first database
                    resultsReader.SortOrder.ColumnSorts.Add(New ColumnSort(resultsReader.Fields("Description"), True))
                    resultsReader.ApplySort()

                    Dim row As Row
                    For Each row In resultsReader
                        Console.Write("{0}:{1},{2}", row.Values(recordID), row.Values(description1), row.Values(description2))
                        Console.WriteLine()
                    Next

                    'dispose of the objects to delete temporary files
                    session.Dispose()
                    db1.Dispose()
                    db2.Dispose()
                End Sub
            End Class

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
RedGate.SQLDataCompare.Engine.ResultsStore..::.Store

See Also

Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Members

[image] [image]

SQL Data Compare API 7.1.0
Store Members
Store Class Methods Properties Explicit Interface Implementations See Also

The Store type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a default enumerator for the ResultsStore.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReader | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IdenticalValues | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Compressed | True if the results store is using compressed temporary files, false otherwise.
Fields | The fields in the ResultsStore object.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
RowCount | The number of rows in the ResultsStore.
Where | Contains the WHERE clause that was used to create the ResultsStore.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Methods

[image] [image]

SQL Data Compare API 7.1.0
Store Methods
Store Class See Also

The Store type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetEnumerator | Returns a default enumerator for the ResultsStore.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetReader | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IdenticalValues | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
Store..::.Dispose Method
Store Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
Store..::.Dispose Method (Boolean)
Store Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

Store Class
Dispose Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
Store..::.GetEnumerator Method
Store Class See Also

Returns a default enumerator for the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of Row)
C#
public IEnumerator<Row> GetEnumerator()
Visual C++
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed

Return Value

StoreEnumerator that can be used to access the results store.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IEnumerable.GetEnumerator Method

[image]

SQL Data Compare API 7.1.0
Store..::.IEnumerable..::.GetEnumerator Method
Store Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method

[image] [image]

SQL Data Compare API 7.1.0
Store..::.GetReader Method
Store Class See Also

Overload List

Name | Description
GetReader()()() | Gets a reader so that the ResultsStore can be read in a multi-threaded environment. By default, this is the same as calling GetReader()()() with an argument of RowType.All.
GetReader(Reader) | Gets a Reader for the ResultsStore that uses the state of the readerToCopy argument as its base.
GetReader(Row..::.RowType) | Gets a reader for the ResultsStore for a specified type of results.

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method

[image]

SQL Data Compare API 7.1.0
Store..::.GetReader Method
Store Class See Also

Gets a reader so that the ResultsStore can be read in a multi-threaded environment. By default, this is the same as calling GetReader()()() with an argument of RowType.All.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader As Reader
C#
public Reader GetReader()
Visual C++
public:
Reader^ GetReader()

Return Value

A Reader.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method (Reader)

[image]

SQL Data Compare API 7.1.0
Store..::.GetReader Method (Reader)
Store Class See Also

Gets a Reader for the ResultsStore that uses the state of the readerToCopy argument as its base.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader ( _
    readerToCopy As Reader _
) As Reader
C#
public Reader GetReader(
    Reader readerToCopy
)
Visual C++
public:
Reader^ GetReader(
    Reader^ readerToCopy
)

Parameters

readerToCopy
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Reader
The Reader that will be copied.

Return Value

A new copy of a Reader based on the readerToCopy argument.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


GetReader Method (Row.RowType)

[image]

SQL Data Compare API 7.1.0
Store..::.GetReader Method (Row..::.RowType)
Store Class See Also

Gets a reader for the ResultsStore for a specified type of results.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReader ( _
    rowType As Row..::.RowType _
) As Reader
C#
public Reader GetReader(
    Row..::.RowType rowType
)
Visual C++
public:
Reader^ GetReader(
    Row..::.RowType rowType
)

Parameters

rowType
Type: RedGate.SQLDataCompare.Engine.ResultsStore..::.Row..::.RowType
The type of row to be matched.

Return Value

A Reader.

See Also

Store Class
GetReader Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method

[image] [image]

SQL Data Compare API 7.1.0
Store..::.IdenticalValues Method
Store Class See Also

Overload List

Name | Description
IdenticalValues(Object, Object) | Obsolete. Returns true if two values are identical. This method is now obsolete; use IdenticalValues(object value1, object value2, Field f).
IdenticalValues(Object, Object, FieldPair) | Returns true if two specified values are identical.
IdenticalValues(Object, Object, FieldPair, Boolean) | Returns true if two specified values are identical.

See Also

Store Class
Store Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (Object, Object)

[image]

SQL Data Compare API 7.1.0
Store..::.IdenticalValues Method (Object, Object)
Store Class See Also

Returns true if two values are identical. This method is now obsolete; use IdenticalValues(object value1, object value2, Field f).

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Comparing values without field information can produce unreliable information, please pass Field information.",  _
    False)> _
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object _
) As Boolean
C#
[ObsoleteAttribute("Comparing values without field information can produce unreliable information, please pass Field information.",
    false)]
public static bool IdenticalValues(
    Object value1,
    Object value2
)
Visual C++
[ObsoleteAttribute(L"Comparing values without field information can produce unreliable information, please pass Field information.",
    false)]
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2
)

Parameters

value1
Type: System..::.Object
The first value to compare.
value2
Type: System..::.Object
The second value to compare.

Return Value

true if the two values are identical.

Remarks

If the values are of different types, or if one value is null, returns false.

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (Object, Object, FieldPair)

[image]

SQL Data Compare API 7.1.0
Store..::.IdenticalValues Method (Object, Object, FieldPair)
Store Class See Also

Returns true if two specified values are identical.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object, _
    fieldPair As FieldPair _
) As Boolean
C#
public static bool IdenticalValues(
    Object value1,
    Object value2,
    FieldPair fieldPair
)
Visual C++
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2,
    FieldPair^ fieldPair
)

Parameters

value1
Type: System..::.Object
The first value to compare.
value2
Type: System..::.Object
The second value to compare.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair information for use in the comparison (collation and type information).

Return Value

true if the values are identical.

Remarks

If the values are of different types, or if one value is null, returns false. If you are using GetSummaryRow(Int32) to retrieve the data, you must use the FieldDifferent(Int32) method to determine whether the values are the same in a Row.

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


IdenticalValues Method (Object, Object, FieldPair, Boolean)

[image]

SQL Data Compare API 7.1.0
Store..::.IdenticalValues Method (Object, Object, FieldPair, Boolean)
Store Class See Also

Returns true if two specified values are identical.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IdenticalValues ( _
    value1 As Object, _
    value2 As Object, _
    fieldPair As FieldPair, _
    forceBinaryString As Boolean _
) As Boolean
C#
public static bool IdenticalValues(
    Object value1,
    Object value2,
    FieldPair fieldPair,
    bool forceBinaryString
)
Visual C++
public:
static bool IdenticalValues(
    Object^ value1,
    Object^ value2,
    FieldPair^ fieldPair,
    bool forceBinaryString
)

Parameters

value1
Type: System..::.Object
The first value to compare.
value2
Type: System..::.Object
The second value to compare.
fieldPair
Type: RedGate.SQLDataCompare.Engine..::.FieldPair
The FieldPair information for use in the comparison (collation and type information).
forceBinaryString
Type: System..::.Boolean
If set to true the collation of the field is ignored for the comparison causing a binary string comparison.

Return Value

true if the values are identical.

Remarks

If the values are of different types, or if one value is null, returns false. If you are using GetSummaryRow(Int32) to retrieve the data, you must use the FieldDifferent(Int32) method to determine whether the values are the same in a Row.

See Also

Store Class
IdenticalValues Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Store Properties

[image] [image]

SQL Data Compare API 7.1.0
Store Properties
Store Class See Also

The Store type exposes the following properties.

Properties

Name | Description
Compressed | True if the results store is using compressed temporary files, false otherwise.
Fields | The fields in the ResultsStore object.
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
RowCount | The number of rows in the ResultsStore.
Where | Contains the WHERE clause that was used to create the ResultsStore.

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Compressed Property

[image]

SQL Data Compare API 7.1.0
Store..::.Compressed Property
Store Class See Also

True if the results store is using compressed temporary files, false otherwise.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Compressed As Boolean
C#
public bool Compressed { get; }
Visual C++
public:
property bool Compressed {
    bool get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Fields Property

[image]

SQL Data Compare API 7.1.0
Store..::.Fields Property
Store Class See Also

The fields in the ResultsStore object.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldPairs
C#
public FieldPairs Fields { get; }
Visual C++
public:
property FieldPairs^ Fields {
    FieldPairs^ get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


RowCount Property

[image]

SQL Data Compare API 7.1.0
Store..::.RowCount Property
Store Class See Also

The number of rows in the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
C#
public int RowCount { get; }
Visual C++
public:
property int RowCount {
    int get ();
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Where Property

[image]

SQL Data Compare API 7.1.0
Store..::.Where Property
Store Class See Also

Contains the WHERE clause that was used to create the ResultsStore.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Where As WhereClause
C#
public WhereClause Where { get; set; }
Visual C++
public:
property WhereClause^ Where {
    WhereClause^ get ();
    void set (WhereClause^ value);
}

See Also

Store Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


StoreEnumerator Class

[image]

SQL Data Compare API 7.1.0
StoreEnumerator Class
Members See Also

This is the enumerator for a ResultsStore or Reader.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Class StoreEnumerator _
    Inherits EnumeratorBase(Of Row)
C#
public class StoreEnumerator : EnumeratorBase<Row>
Visual C++
public ref class StoreEnumerator : public EnumeratorBase<Row^>

Inheritance Hierarchy

System..::.Object
RedGate.Shared.Utils..::.DisposableBase
EnumeratorBase<(Of <( Row >)>)
RedGate.SQLDataCompare.Engine.ResultsStore..::.StoreEnumerator

See Also

StoreEnumerator Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


StoreEnumerator Members

[image] [image]

SQL Data Compare API 7.1.0
StoreEnumerator Members
StoreEnumerator Class Methods Properties See Also

The StoreEnumerator type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveNext | Advances the enumerator to the next element of the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.MoveNext()()().)
Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.Reset()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets the current element in the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.Current()()().)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Summary | Controls whether the enumerator is for summary row information only, or full row information. By default, this is false.

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


StoreEnumerator Methods

[image] [image]

SQL Data Compare API 7.1.0
StoreEnumerator Methods
StoreEnumerator Class See Also

The StoreEnumerator type exposes the following methods.

Methods

Name | Description
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | (Inherited from DisposableBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveNext | Advances the enumerator to the next element of the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.MoveNext()()().)
Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.Reset()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method

[image] [image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.Dispose Method
StoreEnumerator Class See Also

Overload List

Name | Description
Dispose()()() | (Inherited from DisposableBase.)
Dispose(Boolean) | (Overrides DisposableBase ..::. Dispose(Boolean).)

See Also

StoreEnumerator Class
StoreEnumerator Members
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Dispose Method (Boolean)

[image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.Dispose Method (Boolean)
StoreEnumerator Class See Also

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

StoreEnumerator Class
Dispose Overload
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


MoveNext Method

[image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.MoveNext Method
StoreEnumerator Class See Also

Advances the enumerator to the next element of the collection.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MoveNext As Boolean
C#
public override bool MoveNext()
Visual C++
public:
virtual bool MoveNext() override

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::.MoveNext()()()

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Reset Method

[image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.Reset Method
StoreEnumerator Class See Also

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset
C#
public override void Reset()
Visual C++
public:
virtual void Reset() override

Implements

IEnumerator..::.Reset()()()

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


StoreEnumerator Properties

[image] [image]

SQL Data Compare API 7.1.0
StoreEnumerator Properties
StoreEnumerator Class See Also

The StoreEnumerator type exposes the following properties.

Properties

Name | Description
Current | Gets the current element in the collection. (Overrides EnumeratorBase<(Of <( Row >)>)..::.Current()()().)
IsDisposed | Returns a value indicating if this instance has been disposed or not. (Inherited from DisposableBase.)
Summary | Controls whether the enumerator is for summary row information only, or full row information. By default, this is false.

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Current Property

[image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.Current Property
StoreEnumerator Class See Also

Gets the current element in the collection.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Current As Row
C#
public override Row Current { get; }
Visual C++
public:
virtual property Row^ Current {
    Row^ get () override;
}

Field Value

The current element in the collection.

Implements

IEnumerator<(Of <(T>)>)..::.Current

Exceptions

Exception | Condition
RedGate.SQLDataCompare.Engine.ResultsStore..::.ResultsStoreException | Reader not positioned on a row

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


Summary Property

[image]

SQL Data Compare API 7.1.0
StoreEnumerator..::.Summary Property
StoreEnumerator Class See Also

Controls whether the enumerator is for summary row information only, or full row information. By default, this is false.

Namespace: RedGate.SQLDataCompare.Engine.ResultsStore
Assembly: RedGate.SQLDataCompare.Engine (in RedGate.SQLDataCompare.Engine.dll)

Syntax

Visual Basic (Declaration)
Public Property Summary As Boolean
C#
public bool Summary { get; set; }
Visual C++
public:
property bool Summary {
    bool get ();
    void set (bool value);
}

See Also

StoreEnumerator Class
RedGate.SQLDataCompare.Engine.ResultsStore Namespace


FAQs for the SQL Data Compare API

SQL Comparison SDK: SQL Data Compare API 7.0

Frequently Asked Questions

How do I change the comparison key?

If there is no primary key, unique index, or unique constraint, you can set a custom comparison key by adding FieldMappings objects to the MatchingMappings for a particular TableMapping. Call RefreshMappingStatus to confirm that SQL Data Compare can compare the tables.

For example, create a mapping for the WidgetPrices table, and then set WidgetID as the custom comparison key:

TableMapping tableMapping = (TableMapping)mappings.Join(db1.Tables["[dbo].[WidgetPrices]"], db2.Tables["[dbo].[WidgetPrices]"]);

tableMapping.MatchingMappings.Clear();
tableMapping.MatchingMappings.Add(tableMapping.FieldMappings["WidgetID"]);
tableMapping.RefreshMappingStatus();

To set a comparison key using columns from a particular index, call UseIndexForMapping

How do I exclude tables from the comparison?

To exclude a particular table, set the Include property for the TableMapping to false.

For example, to exclude the table WidgetPrices:

tableMapping["[dbo].[WidgetPrices]"].Include=false;

To exclude tables that begin with a particular string or that belong to particular schema (owner), you can loop through the tables and set the Include property as follows:

foreach (TableMapping m in tableMappings)
{
    if (m.Obj1.FullyQualifiedName.StartsWith("[dbo]"))
        m.Include=false;
}
m.RefreshMappingStatus();

How do I filter the rows that are compared?

You can filter the data that will be compared setting the Where property on a TableMapping object.

For example, to compare only rows where RecordID is greater than or equal to 2 in the Widgets table:

foreach (TableMapping mapping in mappings)
{
    if (mapping.Obj1.FullyQualifiedName=="[dbo].[Widgets]")
    {
        mapping.Include=true;
        mapping.Where = new WhereClause("RecordID>=2");
    }
    else
    {
    mapping.Include = false;
    }
}

If required, you can set a different WHERE clause for the two tables that you are comparing, using the Clause1 and Clause2 properties.

For example:

WhereClause w=new WhereClause();
w.Clause1="RecordID<2";
w.Clause2="RecordID>2"
tableMapping.Where=w;

How do I set the comparison options?

You specify the options on the SchemaMappings.Options property from the MappingOptions, ComparisonOptions, and SqlOptions enumerations.

MappingOptions are used for table and column mappings. The default options are as follows:

  • IgnoreCase
  • IgnoreSpaces
  • IncludeIdentities
  • IncludeTimestamps

ComparisonOptions are used for comparing the databases. There are no default options.

SqlOptions are used when you synchronize the databases. The default options are as follows:

  • DisableKeys
  • OutputCommentHeader
  • UseTransactions
  • OutputComments
  • ReseedIdentity

For example, to ignore trailing spaces when comparing strings, set the TrimTrailingSpaces option in ComparisonOptions:

tableMapping.FieldMappings.Options.ComparisonOptions = ComparisonOptions.TrimTrailingSpaces | ComparisonOptions.Default;

To set more than one option, logically OR them together; in Visual Basic, use Or and in C#, use the pipe character (|).

How can I choose individual records to synchronize?

Create a new SelectionDelegate and point it at a function that will return true or false, indicating whether the record is to be synchronized. This function will accept a SynchronizationRecord object as the only argument. Pass the SelectionDelegate as the second argument to the GetMigrationSQL method of the SqlProvider object.

Do I have to distribute my license file with my application?

No. A properly compiled SQL Data Compare API application will not request a serial number when it is distributed.

How do I install my application on the client?

Copy your application and the assemblies it references to the same folder (or the Global Assembly Cache - not recommended). No registration or registry entries are required unless specifically requested by your application.

See Also

Getting Started with the SQL Data Compare API

API Reference Information


Worked Example

SQL Comparison SDK: SQL Data Compare API 7.1

Worked Example

This worked example shows you how to create a command-line program to compare and synchronize the data in two online databases, WidgetDev and WidgetLive.

You will see how to:

  1. Set up the databases.
  2. Set up the project.
  3. Create a database object.
  4. Compare the databases.
  5. Print the changes to be made.
  6. Get the synchronization SQL.
  7. Run the SQL script.
  8. Dispose of the objects.

For detailed information about the API, see the Reference topics provided in this online help.

Set up the databases

  1. If they already exist, delete WidgetDev and WidgetLive from your SQL Server.
  2. Click here to open the SQL creation script for the databases, and then run the script in your SQL application.

Set up the project

  1. Create a new console application project ConsoleApplication1 using Visual Studio® .NET
  2. Add references to RedGate.SQLCompare.Engine.dll, RedGate.SQLDataCompare.Engine.dll, RedGate.Shared.Utils.dll and RedGate.Shared.SQL.dll

    You can find the .dll files in the folder where you installed SQL Data Compare. The default location is Program Files\Red Gate\SQL Data Compare 7

  3. Create a file licenses.licx and add it to the project, then add the following lines to it:

    RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine

    RedGate.SQLDataCompare.Engine.ComparisonSession, RedGate.SQLDataCompare.Engine

Create a database object

  1. Ensure the default module or class is importing or using the RedGate.SQLCompare.Engine, RedGate.SQLDataCompare.Engine, RedGate.Shared.Utils and RedGate.Shared.SQL assemblies.
  2. Alter the Main method to instantiate two Database classes and call RegisterForDataCompare on them, passing in the details of the SQL Servers and databases that you want to connect to.
[Visual Basic]
Imports RedGate.Shared.Utils
Imports RedGate.Shared.SQL
Imports RedGate.SQLCompare.Engine
Imports RedGate.SQLDataCompare.Engine

Imports RedGate.SQLDataCompare.Engine.ResultsStore

Module Module1

  Sub Main()
     Dim db1 As New Database
     Dim db2 As New Database

     db1.RegisterForDataCompare(New ConnectionProperties(".", "WidgetDev"))
     db2.RegisterForDataCompare(New ConnectionProperties(".", "WidgetLive"))
  End Sub

End Module

[C#]
using System;
using RedGate.Shared.Utils;
using RedGate.Shared.SQL
using RedGate.SQLCompare.Engine;
using RedGate.SQLDataCompare.Engine;
using RedGate.SQLDataCompare.Engine.ResultsStore;

namespace ConsoleApplication1
{
  class Class1
     {
        [STAThread]
         static void Main(string[] args)
         {
            Database db1=new Database();
            Database db2=new Database();

            db1.RegisterForDataCompare(new ConnectionProperties(".", "WidgetDev"));
            db2.RegisterForDataCompare(new ConnectionProperties(".", "WidgetLive"));
         }
     }
}

Compare the databases

SQL Data Compare works best on databases that have identical structures. Because real databases often do not have identical structures, you can use SQL Data Compare to determine which tables are common to both databases, and which fields and indexes are common to these tables. SQL Data Compare provides the CreateMappings method for this.

When you have done this, create a ComparisonSession object and call CompareDatabases.

[Visual Basic]

    Dim mappings As New SchemaMappings
    mappings.CreateMappings(db1, db2)

    Dim session As New ComparisonSession()
    session.CompareDatabases(db1, db2, mappings)

[C#]

    SchemaMappings mappings = new SchemaMappings();
    mappings.CreateMappings(db1, db2);

    ComparisonSession session=new ComparisonSession();
    session.CompareDatabases(db1, db2, mappings);

Print the changes to be made

You can use the TableDifferences property to view summary information about the data differences between the two databases. This collection contains a number of TableDifference objects, indexed by fully-qualified table name. Each of these objects has a property ResultsStore that is a pointer to a ResultsStore.Store object. This object contains a list of the records that are identical, different, or present in one database but not the other.

You must use the OrdinalInResults1 and OrdinalInResults2 properties of a FieldPair class to retrieve the data from the Values property of a ResultsStore.Row.

  • If the ResultsStore represents identical records, or records that exist in only one database, the OrdinalInResults1 and OrdinalInResults2 are the same and indicate the position of the data for the field in the ResultsStore.
  • If the ResultsStore represents different records and the field is part of the unique index being used for the comparison, OrdinalInResults1 and OrdinalInResults2 are the same and indicate the position of the data.
  • If the ResultsStore represents different records and the field is not part of the unique index, OrdinalInResults1 and OrdinalInResults2 indicate the position of the data in the first database and second database respectively.

For example, if you are comparing two tables with the following structures:

*RecordID, FirstName, LastName

where * indicates a unique index, the ResultsStore representing identical records, or records present in only one database, will have the following structure:

RecordID, FirstName, LastName

and the OrdinalInResults1 and OrdinalInResults2 properties will have the following values in the Fields collection:

RecordID : 0
FirstName : 1
LastName : 2

If, however, the ResultsStore represents different records, it will have the following structure:

RecordID, FirstName, FirstName, LastName, LastName

The FirstName and LastName fields appear twice because they contain data from the two databases. The OrdinalInResults1 and OrdinalInResults2 properties on the Fields collection will have the following values:

RecordID : 0,0
FirstName : 1,2
LastName : 3,4

[Visual Basic]
    Dim mapping As TableMapping

    For Each mapping In mappings.TableMappings
      Dim table As ViewTableSuperClass = mapping.Obj1
      Dim difference As TableDifference = session.TableDifferences(table.FullyQualifiedName)

      ' Any tables that couldn't be compared we don't output the results
      If difference Is Nothing Then
         Continue For
      End If

      Dim row As Row
      For Each row In difference.ResultsStore  'loop through all the rows
         If (row.Type <> row.RowType.Same) Then 'go through the non same records
            Dim field As FieldPair
            Dim i As Int32 = 0
            Console.WriteLine("{0} Row {1} type {2}", table.FullyQualifiedName, row.Index, row.Type.ToString())
            For Each field In difference.ResultsStore.Fields
               'work out where about in the results the field data is stored
               'if we were comparing identical records, or records present in one
               'database but not the other then we would not need to
               'use the OrdinalInResults1 and OrdinalInResults2 properties
               'but just OrdinalInResults
               Dim field1 As Int32 = field.OrdinalInResults1
               Dim field2 As Int32 = field.OrdinalInResults2

               If (field1 <> field2) Then
                  'get the values
                  Dim value1 As Object = row.Values(field1)
                  Dim value2 As Object = row.Values(field2)
                  If (value1 Is Nothing) Then
                      value1 = "NULL"
                  End If
                  If (value2 Is Nothing) Then
                      value2 = "NULL"
                  End If
                  If row.FieldDifferent(i) Then
                     Console.WriteLine("{0}:{1} <> {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                  Else
                     Console.WriteLine("{0}:{1} == {2}", field.Field(False).Name, value1.ToString(), value2.ToString())
                  End If
               Else
                  'this is part of the unique index we are comparing on
                  Dim value As Object = row.Values(field1)
                  Console.WriteLine("*{0}:{1}", field.Field(False).Name, value.ToString())
               End If
                  i += 1
            Next
         End If
      Next
    Next

[C#]
    foreach (TableMapping mapping in mappings.TableMappings)
    {
      TableDifference difference=session.TableDifferences[mapping.Obj1.FullyQualifiedName];
      //display the different records

      // Any tables that couldn't be compared we don't output the results
      if (difference == null)
         continue;

      //loop through all the rows
      foreach(Row row in difference.ResultsStore)
      {
         //go through the non same records
         if (row.Type != Row.RowType.Same)
         {
            Console.WriteLine("{0} Row {1} type {2}", mapping.Obj1.FullyQualifiedName, row.Index, row.Type.ToString());
            int i=0;
            foreach (FieldPair field in difference.ResultsStore.Fields)
            {
               int field1=field.OrdinalInResults1;
               int field2=field.OrdinalInResults2;

               if (field1 != field2)
               {
                  //get the values
                  object value1=row.Values[field1];
                  object value2=row.Values[field2];
                  if (value1 == null)
                      value1="NULL";
                  if (value2 == null)
                      value2="NULL";
                  Console.WriteLine("{0}\t{1}\t{2}\t{3}",field.Field(false).Name, value1.ToString(),row.FieldDifferent(i)?"<>":"==",  value2.ToString());
                }
                else
                {
                   //this is part of the unique index we are comparing on
                   object value=row.Values[field1];
                   Console.WriteLine("*{0}\t{1}",field.Field(false).Name, value.ToString());
                }
                i++;
             }
          }
       }
    }

Get the synchronization SQL

  1. Ensure the Selected property is set to true only on the TableDifference objects that you want to synchronize.

    In this worked example, we will synchronize all changes.

  2. Call GetMigrationSQL to get an ExecutionBlock containing the synchronization SQL.
[Visual Basic]
    Dim provider as New SQLProvider
    'we want to run the SQL on WidgetLive so pass in true as the second parameter
    Dim block As ExecutionBlock = provider.GetMigrationSQL(session, True)
    Console.WriteLine("Migration SQL:")
    Console.WriteLine(block.GetString())

[C#]
    SqlProvider provider = New SqlProvider();
    //we want to run the SQL on WidgetLive so pass in true as the second parameter
    ExecutionBlock block=provider.GetMigrationSQL(session, true);
    Console.WriteLine("Migration SQL:");
    Console.WriteLine(block.GetString());

Run the SQL script

Instantiate a BlockExecutor object and call the ExecuteBlock method to run the SQL script. Ensure you run it on the correct database.

[Visual Basic]
    Dim executor As BlockExecutor = New BlockExecutor
    executor.ExecuteBlock(block, ".", "WidgetLive")

[C#]
    BlockExecutor executor = new BlockExecutor();
    executor.ExecuteBlock(block, ".", "WidgetLive");

Dispose of the objects

SQL Data Compare makes extensive use of temporary files. To ensure that these files are deleted you must dispose of the objects you have used.

[Visual Basic]
    session.Dispose()
    block.Dispose()
    db1.Dispose()
    db2.Dispose()

[C#]
    session.Dispose();
    block.Dispose();
    db1.Dispose();
    db2.Dispose();

See Also

Comparing and Synchronizing Data Using the API | Frequently Asked Questions for the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


Distributing your Applications

SQL Comparison SDK: SQL Data Compare API 7.1

Distributing your Applications

To distribute your applications:

  1. Ensure you have a valid SQL Comparison SDK serial number.

    If you do not have a valid, activated serial number, the applications you distribute will display a trial expiry dialog box and will stop working when your trial expires.

  2. Add a licenses.licx file to your C# or Visual Basic .NET project in Visual Studio.

    If a licenses.licx file does not exist in your Visual Studio .NET project, you must create one with the following entries in it:

    RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine

    RedGate.SQLDataCompare.Engine.ComparisonSession, RedGate.SQLDataCompare.Engine

  3. Compile your application.

    If you have a valid serial number and a valid licenses.licx file, your executable file will run SQL Data Compare without displaying the trial expiry dialog box.

  4. Distribute your application.

    You must distribute the following files with your application:

    • RedGate.Shared.Utils.dll
    • RedGate.Shared.SQL.dll
    • RedGate.SQLCompare.Engine.dll
    • RedGate.SQLCompare.Rewriter.dll
    • RedGate.SQLCompare.ASTParser.dll
    • RedGate.SQLDataCompare.Engine.dll

    For comparing to backups, you must also distribute the following files:

    • RedGate.BackupReader.dll
    • RedGate.SQLCompare.BackupReader.dll
    • System.Data.SQLite.dll

    For comparing to SQL Backup files, you must also distribute the following files:

    • RedGate.BackupReader.SqbReader.dll
    • RedGate.BackupReader.CryptoHelper.dll
    • rglz.dll
    • zlib1.dll

Note that you are not permitted to distribute any other Red Gate files. In particular, you must not distribute any .lic files.

See Also

Getting Started with the SQL Data Compare API | Frequently Asked Questions for the SQL Data Compare API

© 2009 Red Gate Software Ltd. All rights reserved.


ExecuteReader Method

[image] [image]

SQL Data Compare API 7.1.0
BackupCommand..::.ExecuteReader Method
BackupCommand Class See Also

Overload List

Name | Description
ExecuteReader()()() | (Inherited from BackupReaderCommandBase.)
ExecuteReader(CommandBehavior) | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

See Also

BackupCommand Class
BackupCommand Members
RedGate.BackupReader Namespace


ExecuteReader Method

[image] [image]

SQL Data Compare API 7.1.0
LiveCommand..::.ExecuteReader Method
LiveCommand Class See Also

Overload List

Name | Description
ExecuteReader()()() | (Inherited from BackupReaderCommandBase.)
ExecuteReader(CommandBehavior) | Not implemented in this implementation (Inherited from BackupReaderCommandBase.)

See Also

LiveCommand Class
LiveCommand Members
RedGate.BackupReader Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
AsymmetricKeys..::.Item Property
AsymmetricKeys Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

AsymmetricKeys Class
AsymmetricKeys Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Certificates..::.Item Property
Certificates Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Certificates Class
Certificates Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Contracts..::.Item Property
Contracts Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Contracts Class
Contracts Members


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
DatabaseObjectWithAuthorization..::.Equals Method
DatabaseObjectWithAuthorization Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

DatabaseObjectWithAuthorization Class
DatabaseObjectWithAuthorization Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
DdlTriggers..::.Item Property
DdlTriggers Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

DdlTriggers Class
DdlTriggers Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Defaults..::.Item Property
Defaults Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Defaults Class
Defaults Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
EventNotifications..::.Item Property
EventNotifications Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

EventNotifications Class
EventNotifications Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
EventTypes..::.Item Property
EventTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

EventTypes Class
EventTypes Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Fields..::.Item Property
Fields Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Fields Class
Fields Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
FullTextCatalogs..::.Item Property
FullTextCatalogs Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

FullTextCatalogs Class
FullTextCatalogs Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
FullTextStoplists..::.Item Property
FullTextStoplists Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

FullTextStoplists Class
FullTextStoplists Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Functions..::.Item Property
Functions Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Functions Class
Functions Members


GetEnumerator Method

[image] [image]

SQL Data Compare API 7.1.0
IDatabaseObjects<(Of <(T>)>)..::.GetEnumerator Method
IDatabaseObjects<(Of <(T>)>) Interface See Also

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( T >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IDatabaseObjects<(Of <(T>)>) Interface
IDatabaseObjects<(Of <(T>)>) Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Members..::.Item Property
Members Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

Members Class
Members Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
MessageTypes..::.Item Property
MessageTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

MessageTypes Class
MessageTypes Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
MessageUsages..::.Item Property
MessageUsages Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

MessageUsages Class
MessageUsages Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
PartitionFunctions..::.Item Property
PartitionFunctions Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

PartitionFunctions Class
PartitionFunctions Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
PartitionSchemes..::.Item Property
PartitionSchemes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

PartitionSchemes Class
PartitionSchemes Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Queues..::.Item Property
Queues Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Queues Class
Queues Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Roles..::.Item Property
Roles Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Roles Class
Roles Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Routes..::.Item Property
Routes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Routes Class
Routes Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Rules..::.Item Property
Rules Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Rules Class
Rules Members


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
SchemaObjectWithAuthorization..::.Equals Method
SchemaObjectWithAuthorization Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

SchemaObjectWithAuthorization Class
SchemaObjectWithAuthorization Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Schemas..::.Item Property
Schemas Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Schemas Class
Schemas Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
SerializableCollection<(Of <(T>)>)..::.Item Property
SerializableCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

SerializableCollection<(Of <(T>)>) Class
SerializableCollection<(Of <(T>)>) Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
ServiceBindings..::.Item Property
ServiceBindings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

ServiceBindings Class
ServiceBindings Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Services..::.Item Property
Services Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Services Class
Services Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
StoredProcedures..::.Item Property
StoredProcedures Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

StoredProcedures Class
StoredProcedures Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
SymmetricKeys..::.Item Property
SymmetricKeys Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

SymmetricKeys Class
SymmetricKeys Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Synonyms..::.Item Property
Synonyms Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Synonyms Class
Synonyms Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Tables..::.Item Property
Tables Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Tables Class
Tables Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
UserDefinedTypes..::.Item Property
UserDefinedTypes Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

UserDefinedTypes Class
UserDefinedTypes Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Users..::.Item Property
Users Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Users Class
Users Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
Views..::.Item Property
Views Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

Views Class
Views Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
ViewsAndTables..::.Item Property
ViewsAndTables Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)

See Also

ViewsAndTables Class
ViewsAndTables Members


Equals Method

[image] [image]

SQL Data Compare API 7.1.0
ViewTableSuperClass..::.Equals Method
ViewTableSuperClass Class See Also

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IDatabaseObject, Options) | Compares two database objects. (Inherited from ScriptableDatabaseObject.)

See Also

ViewTableSuperClass Class
ViewTableSuperClass Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
XmlSchemaCollections..::.Item Property
XmlSchemaCollections Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Returns elements by index. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String])]) | Returns elements by key. (Inherited from KeyedCollection<(Of <(T>)>).)
Item[([(String, String])]) | Returns a database object given its owner and name. (Inherited from SerializableDatabaseObjectCollection<(Of <(T>)>).)

See Also

XmlSchemaCollections Class
XmlSchemaCollections Members


Item Property

[image] [image]

SQL Data Compare API 7.1.0
FieldMappings..::.Item Property
FieldMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

FieldMappings Class
FieldMappings Members
RedGate.SQLDataCompare.Engine Namespace


Item Property

[image] [image]

SQL Data Compare API 7.1.0
TableMappings..::.Item Property
TableMappings Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the Mapping<(Of <(T>)>) at the specified index. (Inherited from Mappings<(Of <(TMap, TContext>)>).)
Item[([(String])]) | Gets the mapping of the specified object name, first attempting to match against objects in the first database, then matching against objects in the second database. Returns null if a mapping is not found. (Inherited from Mappings<(Of <(TMap, TContext>)>).)

See Also

TableMappings Class
TableMappings Members
RedGate.SQLDataCompare.Engine Namespace