Command text preprocessing

AnyDAC
Command text preprocessing
Topics Send Feedback
Topics
Name | Description
Character macro functions |
Numeric macro functions |
Date and time macro functions |
System macro functions |
Convert macro function |
Links
Topics
Description
General

AnyDAC supports three kinds of macro instructions:

• Substitution variables: They allow substitution to put parameters in command text. This is to extend the use of parameters. For example, to parameterize a table name in FROM clause or column names in SELECT clause substitution variables can be used but parameters are of no use.

• Escape sequences: They allow writing DBMS independent SQL commands.

• Conditional substitutions: They allow expand SQL command conditionally, depending on application defined attributes or currently attached DBMS.

Setting CommandText or SQL property values will automatically fill the Macros collection property, if ResourceOptions.MacroCreate is True. At Prepare call, the AnyDAC macro processor transforms command text into a form understood by the DBMS, if ResourceOptions.MacroExpand is True. This means, the macros are not visible to the DBMS.

Substitution variables

Substitution variables starts with a ‘!’ or ‘&’ symbol and is followed by a macro variable name. For example:

 SELECT * FROM &SomeTab

The symbols have the following meaning:

• ‘!’ - “string” substitution mode. Macro value will be substituted “as is”, directly into the command text without any transformations.

• ‘&’ – “SQL” substitution mode. Macro value will be substituted depending on the macro data type, using target DBMS syntax rules.

Escape sequences

AnyDAC has 5 kinds of escape sequences:

• Allowing constant substitution.

• Allowing identifier substitution.

• Conditional substitution.

• LIKE operator escape sequence.

• Scalar functions.

The constant substitution escape sequences allow writing constants in command text, independent on DBMS syntax and regional settings. Following describes escape sequences expansion to DBMS syntax:

Format | Description
{e <number>} | Number constant of numeric format. For example: {e 123.7} -> 123,7 on MSAccess
{d <date>} | Date constant. Here <date> must be specified in “yyyy-mm-dd” format. For example: {d 2004-08-30} -> TO_DATE(‘2004-08-30’, ‘yyyy-mm-dd’) on Oracle.
{t <time>} | Time constant. Here <time> must be specified in “hh24:mi:ss” format. For example: {t 14:30:00} -> CONVERT(DATETIME, '14:30:00', 114) on MSSQL
{dt <date & time>} | Date and time constant. Here <date & time> must be in format as above.
{l <boolean>} | Boolean constant. Here <boolean> is False or True. If DBMS supports Boolean data type, then sequence expands to that type constant, otherwise to numeric values 0 or 1.
{s <string>} | String constant. Here <string> is quoted or not quoted sequence of characters. For example: {s Company '1st Coding'} -> 'Company ''1st Coding'''

The identifier substitution escape sequence allows abstracting from DBMS specific identifier quoting rules. The syntax is:

Format | Description
{id <identifier name>} | Expands to DBMS specific quoted identifier syntax. For example: {id Order Details} -> “Order Details” on Oracle.

The escape function sequence allows abstracting from a DBMS specific set of a build-in functions and their syntax. The syntax is:

Format
Description
{fn <function name>(<arguments>)}
The escape functions syntax and theyr set follow close to the rules of ODBC escape functions. In sub topics AnyDAC escape functions are listed and it is explained how to use them.
For example:
SELECT * FROM MyTab WHERE Year = {fn YEAR({fn NOW()}} or
SELECT * FROM MyTab WHERE Year = {YEAR({NOW()}} ->
SELECT * FROM MyTab WHERE Year = TO_NUMBER(TO_CHAR(SYSDATE, 'YYYY')) on Oracle.
{<function name>(<arguments>)}
The same as above.

Conditional substitution

Conditional substitution escape sequences are very special case of escape sequences. They allow substitute text into command, depending on either DBMS application is connected to, either on macro variable value. Beside different syntaxes, these constructions handle parameters and macros in different ways. Escape sequence syntaxes are:

Format
Description
{iif (X1, Y1, …, XN, YN, YN+1) }
Here Xi is either:

  • AnyDAC DBMS kind identifier. So, if application is connected to this DBMS, then Yi text will be substituted into command.
  • Macro variable. If it value is not empty, then Yi text will be substituted into command.

If neither of conditions is meted and YN+1 text is specified, then it will be substituted into command. Parameters and macros in either Xi and Yi will be created in Params and Macros collection.

{if x} y {fi}
Here X is either:

  • AnyDAC DBMS kind identifier. So, if application is connected to this DBMS, then Y text will be substituted into command.
  • Macro variable. If it value is not empty, then Y text will be substituted into command.

Parameters and macros in Y will be created in Params and Macros collection only if X is “true”.

For example:

{iif (Oracl, TO_CHAR, MSSQL, CONVERT)}          -> ‘TO_CHAR’ on Oracle and ‘CONVERT’ on MSSQL.
{iif (&v1, Me, &v2, You, We)}                   -> ‘Me’ if &v1 has nonempty value, ‘you’ if &v2 has nonempty value, otherwise ‘We’.
{if Oracl} TO_CHAR {fi} {if MSSQL} CONVERT {fi} -> TO_CHAR on Oracle and CONVERT on MSSQL.
{if &v1} Me {fi} {if &v2} You {fi}              -> ‘Me’ if &v1 has nonempty value + ‘you’ if &v2 has nonempty value.

Special character processing

To transmit special characters - ‘!’, ‘&’, ‘:’, ‘{‘ or ‘}’ – to DBMS, you will need:

• Either precede this character by ‘^’ character. For example, ‘^:’.

• Either double special character. For example, ‘{{‘.

• Either on MySQL, precede this character by ‘\’ character. For example, ‘\”’.

Otherwise special characters will be treated as macro command, excluding following cases:

• Oracle PL/SQL assignment operator is detected by AnyDAC and will not be treated as parameter marker.

• Firebird EXECUTE BLOCK parameters inside of BEGIN … END are detected by AnyDAC and will not be treated as parameter marker.

• TSQL label is detected by AnyDAC and will not be treated as parameter marker.

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.
Contents | Index | Home
What do you think about this topic? Send feedback!


Character macro functions

Character macro functions
Command text preprocessing Send Feedback
Group

Command text preprocessing

Links
Command text preprocessing
Description
CHARACTER
Function | Description
ASCII(string_exp) | Returns the ASCII code value of the leftmost character of string_exp as an integer.
BIT_LENGTH(string_exp) | Returns the length in bits of the string expression.
CHAR(code) | Returns the character that has the ASCII code value specified by code. The value of code should be between 0 and 255; otherwise, the return value is data source–dependent.
CHAR_LENGTH(string_exp) | Returns the length in characters of the string expression, if the string expression is of a character data type; otherwise, returns the length in bytes of the string expression (the smallest integer not less than the number of bits divided by 8). (This function is the same as the CHARACTER_LENGTH function.)
CHARACTER_LENGTH(string_exp) | Returns the length in characters of the string expression, if the string expression is of a character data type; otherwise, returns the length in bytes of the string expression (the smallest integer not less than the number of bits divided by 8). (This function is the same as the CHAR_LENGTH function.)
CONCAT(string_exp1, string_exp2) | Returns a character string that is the result of concatenating string_exp2 to string_exp1. The resulting string is DBMS-dependent. For example, if the column represented by string_exp1 contained a NULL value, DB2 would return NULL but SQL Server would return the non-NULL string.
DIFFERENCE(string_exp1, string_exp2) | Returns an integer value that indicates the difference between the values returned by the SOUNDEX function for string_exp1 and string_exp2.
INSERT(string_exp1, start, length, string_exp2) | Returns a character string where length characters have been deleted from string_exp1, beginning at start, and where string_exp2 has been inserted into string_exp, beginning at start.
LCASE(string_exp) (ODBC 1.0) | Returns a string equal to that in string_exp, with all uppercase characters converted to lowercase.
LEFT(string_exp, count) | Returns the leftmost count characters of string_exp.
LENGTH(string_exp) | Returns the number of characters in string_exp, excluding trailing blanks.
LOCATE(string_exp1, string_exp2[, start]) | Returns the starting position of the first occurrence of string_exp1 within string_exp2. The search for the first occurrence of string_exp1 begins with the first character position in string_exp2 unless the optional argument, start, is specified. If start is specified, the search begins with the character position indicated by the value of start. The first character position in string_exp2 is indicated by the value 1. If string_exp1 is not found within string_exp2, the value 0 is returned.
LTRIM(string_exp) | Returns the characters of string_exp, with leading blanks removed.
OCTET_LENGTH(string_exp) | Returns the length in bytes of the string expression. The result is the smallest integer not less than the number of bits divided by 8.
POSITION(character_exp, character_exp) | Returns the position of the first character expression in the second character expression. The result is an exact numeric with an implementation-defined precision and a scale of 0.
REPEAT(string_exp, count) | Returns a character string composed of string_exp repeated count times.
REPLACE(string_exp1, string_exp2, string_exp3) | Search string_exp1 for occurrences of string_exp2, and replace with string_exp3.
RIGHT(string_exp, count) | Returns the rightmost count characters of string_exp.
RTRIM(string_exp) | Returns the characters of string_exp with trailing blanks removed.
SOUNDEX(string_exp) | Returns a data source–dependent character string representing the sound of the words in string_exp. For example, SQL Server returns a 4-digit SOUNDEX code; Oracle returns a phonetic representation of each word.
SPACE(count) | Returns a character string consisting of count spaces.
SUBSTRING(string_exp, start, length) | Returns a character string that is derived from string_exp, beginning at the character position specified by start for length characters.
UCASE(string_exp) | Returns a string equal to that in string_exp, with all lowercase characters converted to uppercase.


Numeric macro functions

Numeric macro functions
Command text preprocessing Send Feedback
Group

Command text preprocessing

Links
Command text preprocessing
Description
NUMERIC
Function | Description
ABS(numeric_exp) | Returns the absolute value of numeric_exp.
ACOS(float_exp) | Returns the arccosine of float_exp as an angle, expressed in radians.
ASIN(float_exp) | Returns the arcsine of float_exp as an angle, expressed in radians.
ATAN(float_exp) | Returns the arctangent of float_exp as an angle, expressed in radians.
ATAN2(float_exp1, float_exp2) | Returns the arctangent of the x and y coordinates, specified by float_exp1 and float_exp2, respectively, as an angle, expressed in radians.
CEILING(numeric_exp) | Returns the smallest integer greater than or equal to numeric_exp. The return value is of the same data type as the input parameter.
COS(float_exp) | Returns the cosine of float_exp, where float_exp is an angle expressed in radians.
COT(float_exp) | Returns the cotangent of float_exp, where float_exp is an angle expressed in radians.
DEGREES(numeric_exp) | Returns the number of degrees converted from numeric_exp radians.
EXP(float_exp) | Returns the exponential value of float_exp.
FLOOR(numeric_exp) | Returns the largest integer less than or equal to numeric_exp. The return value is of the same data type as the input parameter.
LOG(float_exp) | Returns the natural logarithm of float_exp.
LOG10(float_exp) | Returns the base 10 logarithm of float_exp.
MOD(integer_exp1, integer_exp2) | Returns the remainder (modulus) of integer_exp1 divided by integer_exp2.
PI( ) | Returns the constant value of pi as a floating-point value.
POWER(numeric_exp, integer_exp) | Returns the value of numeric_exp to the power of integer_exp.
RADIANS(numeric_exp) | Returns the number of radians converted from numeric_exp degrees.
RAND([integer_exp]) | Returns a random floating-point value using integer_exp as the optional seed value.
ROUND(numeric_exp, integer_exp) | Returns numeric_exp rounded to integer_exp places right of the decimal point. If integer_exp is negative, numeric_exp is rounded to |integer_exp| places to the left of the decimal point.
SIGN(numeric_exp) | Returns an indicator of the sign of numeric_exp. If numeric_exp is less than zero, –1 is returned. If numeric_exp equals zero, 0 is returned. If numeric_exp is greater than zero, 1 is returned.
SIN(float_exp) | Returns the sine of float_exp, where float_exp is an angle expressed in radians.
SQRT(float_exp) | Returns the square root of float_exp.
TAN(float_exp) | Returns the tangent of float_exp, where float_exp is an angle expressed in radians.
TRUNCATE(numeric_exp, integer_exp) | Returns numeric_exp truncated to integer_exp places right of the decimal point. If integer_exp is negative, numeric_exp is truncated to |integer_exp| places to the left of the decimal point.


Date and time macro functions

Date and time macro functions
Command text preprocessing Send Feedback
Group

Command text preprocessing

Links
Command text preprocessing
Description
DATE, TIME
Function | Description
CURRENT_DATE( ) | Returns the current date.
CURRENT_TIME[(time-precision)] | Returns the current local time. The time-precision argument determines the seconds precision of the returned value.
CURRENT_TIMESTAMP [(timestamp-precision)] | Returns the current local date and local time as a timestamp value. The timestamp-precision argument determines the seconds precision of the returned timestamp.
CURDATE( ) | Returns the current date.
CURTIME( ) | Returns the current local time.
DAYNAME(date_exp) | Returns a character string containing the data source–specific name of the day (for example, Sunday through Saturday or Sun. through Sat. for a data source that uses English, or Sonntag through Samstag for a data source that uses German) for the day portion of date_exp.
DAYOFMONTH(date_exp) | Returns the day of the month based on the month field in date_exp as an integer value in the range of 1–31.
DAYOFWEEK(date_exp) | Returns the day of the week based on the week field in date_exp as an integer value in the range of 1–7, where 1 represents Sunday.
DAYOFYEAR(date_exp) | Returns the day of the year based on the year field in date_exp as an integer value in the range of 1–366.
EXTRACT(extract-field, extract-source) | Returns the extract-field portion of the extract-source. The extract-source argument is a datetime or interval expression. The extract-field argument can be one of the following keywords: YEAR MONTH DAY HOUR MINUTE SECOND The precision of the returned value is implementation-defined. The scale is 0 unless SECOND is specified, in which case the scale is not less than the fractional seconds precision of the extract-source field.
HOUR(time_exp) | Returns the hour based on the hour field in time_exp as an integer value in the range of 0–23.
MINUTE(time_exp) | Returns the minute based on the minute field in time_exp as an integer value in the range of 0–59.
MONTH(date_exp) | Returns the month based on the month field in date_exp as an integer value in the range of 1–12.
MONTHNAME(date_exp) | Returns a character string containing the data source–specific name of the month (for example, January through December or Jan. through Dec. for a data source that uses English, or Januar through Dezember for a data source that uses German) for the month portion of date_exp.
NOW( ) | Returns current date and time as a timestamp value.
QUARTER(date_exp) | Returns the quarter in date_exp as an integer value in the range of 1–4, where 1 represents January 1 through March 31.
SECOND(time_exp) | Returns the second based on the second field in time_exp as an integer value in the range of 0–59.
TIMESTAMPADD(interval, integer_exp, timestamp_exp) | Returns the timestamp calculated by adding integer_exp intervals of type interval to timestamp_exp. Valid values of interval are the following keywords: FRAC_SECOND SECOND MINUTE HOUR DAY WEEK MONTH QUARTER YEAR where fractional seconds are expressed in billionths of a second. For example, the following SQL statement returns the name of each employee and his or her one-year anniversary date: SELECT NAME, {fn TIMESTAMPADD(‘YEAR’, 1, HIRE_DATE)} FROM EMPLOYEES If timestamp_exp is a time value and interval specifies days, weeks, months, quarters, or years, the date portion of timestamp_exp is set to the current date before calculating the resulting timestamp. If timestamp_exp is a date value and interval specifies fractional seconds, seconds, minutes, or hours, the time portion of timestamp_exp is set to 0 before calculating the resulting timestamp.
TIMESTAMPDIFF(interval, timestamp_exp1, timestamp_exp2) | Returns the integer number of intervals of type interval by which timestamp_exp2 is greater than timestamp_exp1. Valid values of interval are the following keywords: FRAC_SECOND SECOND MINUTE HOUR DAY WEEK MONTH QUARTER YEAR where fractional seconds are expressed in billionths of a second. For example, the following SQL statement returns the name of each employee and the number of years he or she has been employed: SELECT NAME, {fn TIMESTAMPDIFF(‘YEAR’, {fn CURDATE()}, HIRE_DATE)} FROM EMPLOYEES If either timestamp expression is a time value and interval specifies days, weeks, months, quarters, or years, the date portion of that timestamp is set to the current date before calculating the difference between the timestamps. If either timestamp expression is a date value and interval specifies fractional seconds, seconds, minutes, or hours, the time portion of that timestamp is set to 0 before calculating the difference between the timestamps.
WEEK(date_exp) | Returns the week of the year based on the week field in date_exp as an integer value in the range of 1–53.
YEAR(date_exp) | Returns the year based on the year field in date_exp as an integer value. The range is data source–dependent.


System macro functions

System macro functions
Command text preprocessing Send Feedback
Group

Command text preprocessing

Links
Command text preprocessing
Description
SYSTEM
Function | Description
DATABASE( ) | Returns the name of the database corresponding to the connection.
IFNULL(exp, value) | If exp is null, value is returned. If exp is not null, exp is returned. The possible data type or types of value must be compatible with the data type of exp.
USER( ) | Returns the user name in the DBMS. This can be different than the login name.


Convert macro function

Convert macro function
Command text preprocessing Send Feedback
Group

Command text preprocessing

Links
Command text preprocessing
Description
CONVERT

The format of the CONVERT function is:

CONVERT(value_exp, data_type)

The function returns the value specified by value_exp converted to the specified data_type, where data_type is one of the following keywords:

BIGINT | REAL
BINARY | SMALLINT
BIT | DATE
CHAR | TIME
DECIMAL | TIMESTAMP
DOUBLE | TINYINT
FLOAT | VARBINARY
GUID | VARCHAR
INTEGER | WCHAR
LONGVARBINARY | WLONGVARCHAR
LONGVARCHAR | WVARCHAR
NUMERIC |

The syntax for the explicit data type conversion function does not support specification of conversion format. The argument value_exp can be a column name, the result of another scalar function, or a numeric or string literal. For example:

 { fn CONVERT( { fn CURDATE() }, CHAR ) }

converts the output of the CURDATE scalar function to a character string. Because AnyDAC does not mandate a data type for return values from scalar functions (because the functions are often data source–specific), applications should use the CONVERT scalar function whenever possible to force data type conversion. The following two examples illustrate the use of the CONVERT function. These examples assume the existence of a table called EMPLOYEES, with an EMPNO column of type SQL_SMALLINT and an EMPNAME column of type SQL_CHAR. If an application specifies the following SQL statement:

 SELECT EMPNO FROM EMPLOYEES WHERE {fn CONVERT(EMPNO,CHAR)} LIKE '1%'
  • A driver for ORACLE translates the SQL statement to:
 SELECT EMPNO FROM EMPLOYEES WHERE to_char(EMPNO) LIKE '1%'
  • A driver for SQL Server translates the SQL statement to:
 SELECT EMPNO FROM EMPLOYEES WHERE convert(char,EMPNO) LIKE '1%'

If an application specifies the following SQL statement:

 SELECT {fn ABS(EMPNO)}, {fn CONVERT(EMPNAME,SMALLINT)} FROM EMPLOYEES WHERE EMPNO <> 0

A driver for ORACLE translates the SQL statement to:

 SELECT abs(EMPNO), to_number(EMPNAME) FROM EMPLOYEES WHERE EMPNO <> 0

A driver for SQL Server translates the SQL statement to:

 SELECT abs(EMPNO), convert(smallint, EMPNAME) FROM EMPLOYEES WHERE EMPNO <> 0


Array DML

Array DML
Example 1 Example 2 Send Feedback
Links
Example 1, Example 2
General

The Array DML execution technique submits a single DBMS command with an array of parameters. Each command parameter has array of values and all parameters have arrays of the same length. Then AnyDAC requests the DBMS to execute a command once for each row in arrays. This technique reduces the amount of communication between DBMS and client, enables DBMS to stream command execution. That speeds up a execution in times.

Following picture shows that:

In AnyDAC terms "batch command execution" and "Array DML execution" are used often as synonyms.

AnyDAC implements Array DML using native DBMS API capabilities or emulates Array DML execution, if the DBMS API does not support it. Oracle, MS SQL Server, IBM DB2, SQL Anywhere, Interbase, Firebird, MySQL and ODBC drivers support native Array DML execution. MS Access and dbExpress drivers are emulating Array DML.

Array DML may be used almost for all parameterized commands, including stored procedure calls.

Usage

Before Array DML execution, the application code must setup parameter value arrays. First, setup array length by assigning value to Params.ArraySize. Assigning this property value, implicitly assigns specified array length to all parameters ArraySize property. So, Params collection must be not empty before assigning to Params.ArraySize. Second, assing values to parameter arrays. TADParam class has a set of AsXXXs[AIndex: Integer] properties, similar to AsXXX properties. And other properties and methods accepting as first parameter array index. For example:

ADQuery1.SQL.Text := 'insert into MyTab values (:p1, :p2, :p3)';
// here ADQuery1.Params collection is filled by 2 parameters
ADQuery1.Params.ArraySize := 100;
for i := 0 to 100-1 do begin
  ADQuery1.Params[0].AsIntegers[i] := i;
  ADQuery1.Params[1].AsStrings[i] := 'qwe';
  ADQuery1.Params[2].Clear(i);
end;

IADPhysCommand interface and TADCustomCommand, TADDataSet classes and it descendants (TADQuery, TADStoredProc) have the method Execute(ATimes: Integer = 0; AOffset: Integer = 0). Here, ATimes defines the length of the array. AOffset is index of first item in the array. So, the command will be executed (ATimes - AOffset) times, starting from AOffset row. ATimes must be equal or less Params.ArraySize. For example:

ADQuery1.Execute(100, 0);

After Array DML execution, the property RowsAffected has the number of succesfull executions, not the total number of affected rows by all executions. For example:

ShowMessage(IntToStr(ADQuery1.RowsAffected));

Error Handling

IADPhysCommand and TADAdaptedDataSet and it descendants (TADQuery, TADStoredProc) have ability to trap errors using event handlers and take application defined actions on each error.

If the error handler is not assigned and a error happens, then Execute will raise an exception. And RowsAffected will be equal to the amount of rows successfully processed before the failed row.

if TADAdaptedDataSet.OnExecuteError event handler is assigned, it will get original exception object, current times and offset and after taking some actions must return AAction value, talking to AnyDAC what to do next. For example:

procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;
Notes
  1. It is important to properly setup parameters, including setting property Size for string parameters. In case of Oracle, for example, AnyDAC will allocate 4000 bytes for each string parameter value, if this parameter property Size is not assigned. So, for 10,000 of values will be allocated 40 Mb buffer. If there are many parameters, then application can eat all system memory.
  2. Most DBMS have implicit limit for Array DML size. In general, it is dependent on DBMS client library buffer size or maximum allowed network packet. You should consult to your DBMS documentation for details. How to understand, that application got into Array DML size limiation ? In most cases, you will get AV (like on MSSQL) or application will hang up (like on Oracle) on Execute call. We are sorry, but DBMS API's does not provide information about maximum allowed Array DML size. For a while, single approach is test, test and test. Really, the difference in perfromance between Array DML of 100 size and 1000 size is not big, so just does not use big Array DML sizes.
Example 1

Array DML with IADPhysCommand:

var
  oCmd: IADPhysCommand;
……
  with oCmd do begin
    CommandText := 'insert into Customers (ID, Name) values (:ID, :Name)';
    // Set up parameter types
    Params[0].DataType := ftInteger;
    Params[1].DataType := ftString;
    Params[1].Size := 40;
    // Set up parameters' array size
    Params.ArraySize := 10000;
    // Set parameter values
    for i := 0 to 10000 - 1 do begin
      Params[0].AsIntegers[i] := i;
      Params[1].AsStrings[i] := 'Somebody ' + IntToStr(i);
    end;
    // Execute batch
    Execute(10000, 0);
  end;
Example 2

Array DML with TADQuery and error handling:

procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  case AException.Errors[0].Kind of
  ekPKViolated:
    begin
      // fix ID to be unique
      ADQuery.Params[0].AsIntegers[AException.Errors[0].RowIndex] := AException.Errors[0].RowIndex;
      AAction := eaRetry;
    end;
  ekFKViolated:
    // if Region with RegionID is not found, then just skip row
    AAction := eaSkip;
  else
    AAction := eaFail;
  end;
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  with ADQuery1 do begin
    SQL.Text := 'insert into Customers (ID, RegionID, Name, Note) values (:ID, :RegionID, :Name, :Note)';
    // Set up parameter types
    Params[0].DataType := ftInteger;
    Params[1].DataType := ftInteger;
    Params[2].DataType := ftString;
    Params[2].Size := 40;
    Params[3].DataSize := ftMemo;
    // Set up parameters' array size
    Params.ArraySize := 10000;
    // Set parameter values
    for i := 0 to 10000 - 1 do begin
      if i mod 100 = 0 then
        // force PK violation
        Params[0].AsIntegers[i] := i - 1
      else
        Params[0].AsIntegers[i] := i;
      Params[1].AsIntegers[i] := GetRegionIdForCustomer(i);
      Params[2].AsStrings[i] := 'Somebody ' + IntToStr(i);
      Params[3].Clear(i);
    end;
    // Execute batch
    Execute(10000, 0);
  end;
end;


Setting options

Setting options
See Also Send Feedback

..

Links
See Also
Description

..

See Also

..


Retriving metadata

Retriving metadata
See Also Send Feedback

..

Links
See Also
Description

..

See Also

..


Writing expressions

Writing expressions
See Also Send Feedback

..

Links
See Also
Description

..

See Also

..


uADCompClient Unit

uADCompClient Unit
Classes Functions Legend See Also Topics Types Records, Enums Send Feedback

..

Classes
Name | Description
TADAdaptedDataSet | The TADAdaptedDataSet class uses data adapter to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS.
TADCommand | The class is responsible for execution of SQL commands.
TADConnection | The class is responsible to connection establishment with a DBMS.
TADCustomCommand | The base class is responsible for execution of SQL commands.
TADCustomConnection | The class is responsible to connection establishment with a DBMS.
TADCustomManager | The class is responsible to connection definitions and connections management.
TADCustomMemTable | The class implementing in-memory dataset.
TADCustomQuery | The class implementing dataset, capable to execute SQL queries.
TADCustomSchemaAdapter |
TADCustomStoredProc | The class implementing dataset, capable to execute server side stored procedures.
TADCustomTableAdapter |
TADCustomTransaction | The class is responsible to transaction management for connection.
TADCustomUpdateObject | ..
TADManager | ..
TADMemTable | ..
TADMetaInfoCommand | ..
TADMetaInfoQuery | ..
TADQuery | ..
TADRdbmsDataSet | ..
TADSchemaAdapter |
TADStoredProc | ..
TADTable | ..
TADTableAdapter |
TADTransaction | ..
TADUpdateSQL | ..
Functions
Name | Description
ADFindDefaultConnection |
ADManager | Function returns reference to global TADCustomManager object.
ADSetConnectionClass | Sets the TADCustomConnection descendant class.
ADSetManagerClass | Set the TADCustomManager descendant class.
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TADChangingKinds |
TADConnectionLoginEvent |
TADConnectionRecoverEvent |
TADCustomConnectionClass |
TADCustomManagerClass |
TADDescribeColumnEvent |
TADDescribeTableEvent |
TADErrorEvent |
TADExecuteErrorEvent |
TADOperationFinishedEvent |
TADReconcileRowEvent |
TADUpdateRowEvent |
Records, Enums
Name | Description
TADBindedBy |
TADChangingKind |
Links
Classes, Functions, Legend, See Also, Topics, Types, Records, Enums
Description

..

See Also

..


Classes

Classes
Classes uADCompClient Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADAdaptedDataSet | The TADAdaptedDataSet class uses data adapter to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS.
TADCommand | The class is responsible for execution of SQL commands.
TADConnection | The class is responsible to connection establishment with a DBMS.
TADCustomCommand | The base class is responsible for execution of SQL commands.
TADCustomConnection | The class is responsible to connection establishment with a DBMS.
TADCustomManager | The class is responsible to connection definitions and connections management.
TADCustomMemTable | The class implementing in-memory dataset.
TADCustomQuery | The class implementing dataset, capable to execute SQL queries.
TADCustomSchemaAdapter |
TADCustomStoredProc | The class implementing dataset, capable to execute server side stored procedures.
TADCustomTableAdapter |
TADCustomTransaction | The class is responsible to transaction management for connection.
TADCustomUpdateObject | ..
TADManager | ..
TADMemTable | ..
TADMetaInfoCommand | ..
TADMetaInfoQuery | ..
TADQuery | ..
TADRdbmsDataSet | ..
TADSchemaAdapter |
TADStoredProc | ..
TADTable | ..
TADTableAdapter |
TADTransaction | ..
TADUpdateSQL | ..
Unit

uADCompClient Unit

Links
Classes, uADCompClient Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADAdaptedDataSet Class

TADAdaptedDataSet Class
public Classes Send Feedback

The TADAdaptedDataSet class uses data adapter to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes
Description

The TADAdaptedDataSet class is an intermediate class in AnyDAC dataset classes hierarchy. The programmer must not use it directly.

The TADAdaptedDataSet class uses data adapter, pointed by Adapter property to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS. The dataset itself cannot work with DBMS.

Syntax
TADAdaptedDataSet = class(TADDataSet);


public

public
TADAdaptedDataSet Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADAdaptedDataSet class are listed here.

Class

TADAdaptedDataSet Class

Public Events
Name | Description
OnError | The event is triggered when an error happens, while dataset is talking to DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
Public Methods
Name | Description
AbortJob | Use the AbortJob method to abort current dataset operation.
Disconnect | Disconnects the dataset from DBMS.
NextRecordSet | Go to the next cursor, returned by the SQL command.
Offline | Sets dataset to offline mode.
ServerAppend | Used by TADDataMove to edit directly DBMS data.
ServerCancel | Used by TADDataMove to edit directly DBMS data.
ServerDelete | Used by TADDataMove to edit directly DBMS data.
ServerDeleteAll | Used by TADDataMove to edit directly DBMS data.
ServerEdit | Used by TADDataMove to edit directly DBMS data.
ServerGotoKey | Used by TADDataMove to edit directly DBMS data.
ServerPerform | Used by TADDataMove to edit directly DBMS data.
ServerSetKey | Used by TADDataMove to edit directly DBMS data.
Public Properties
Name | Description
Adapter | Reference to a data adapter.
Command | The reference to the command, used to execute / open queries.
DatSManager | The reference to the inmemory data storage manager.
PointedConnection | The actual connection object.
ServerEditRequest | Used by TADDataMove to edit directly DBMS data.
Links
TADAdaptedDataSet Class, Legend, Public Events, Public Methods, Public Properties


TADAdaptedDataSet.Adapter Property

TADAdaptedDataSet.Adapter Property
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

Reference to a data adapter.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Description

Use this property to get/set data adapter for dataset. The dataset will use data adapter to talk to DBMS, when he needs to execute query, fetch rows, post changes back to DBMS.

Syntax
property Adapter: TADCustomTableAdapter;
See Also

TADCustomTableAdapter

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADAdaptedDataSet.Command Property

TADAdaptedDataSet.Command Property
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

The reference to the command, used to execute / open queries.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Description

Property returns the reference to the Select command of data adapter. This command is used by data adapter to execute DBMS queries by one of the Execute, ExecSQL and Open dataset methods.

Syntax
property Command: TADCustomCommand;
See Also

TADCustomCommand

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADAdaptedDataSet.DatSManager Property

TADAdaptedDataSet.DatSManager Property
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

The reference to the inmemory data storage manager.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Description

The property get/set the reference to the data storage manager. In general, data storage manager is a collection of data storage tables. Each dataset cursor will be represented by one data storage table.

Syntax
property DatSManager: TADDatSManager;
See Also

TADDatSManager, TADDatSTable

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADAdaptedDataSet.OnError Event

TADAdaptedDataSet.OnError Event
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

The event is triggered when an error happens, while dataset is talking to DBMS.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event is triggered, when dataset executes one of the following dataset operations and error happens:

  • Prepare. The dataset is preparing DBMS command for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • ExecSQL/ExecProc/Execute. The dataset is executing DBMS command.
  • Fetch. The dataset is fetching rows from cursor.

You can use also OnExecuteError event to handle Array DML errors, and OnUpdateError event to handle updates posting errors.

Syntax
property OnError: TADErrorEvent;
See Also

TDataSet.Open, TADDataSet.Execute, TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, OnExecuteError, OnUpdateError


TADAdaptedDataSet.OnExecuteError Event

TADAdaptedDataSet.OnExecuteError Event
TADAdaptedDataSet Class uADCompClient Unit Example public See Also Send Feedback

The event is triggered when an error happens, while executing a Array DML query.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
ATimes | The current Array DML size. It may be different from value of the Execute method ATimes parameter, if full operation is splitted into few more small (on Firebird, for example).
AOffset | The current Array DML offset. It may be different from value of the Execute method AOffset parameter, if there was skiped erroneous rows or full operation is splitted into few more small (on Firebird, for example).
AException | The original DBMS returned error. Check AException.Errors[i].RowIndex for the index of errorneous row in parameters array.
AAction | The action dataset should take after return from event handler.
Description

The OnExecuteError event is triggered, when dataset executes Array DML using Execute method and ATimes > 1. Using this event handler you can:

  • skip erroneous row of the parameters array;
  • change values in erroneous row of the parameters array;
  • stop full Array DML execution.
Syntax
property OnExecuteError: TADExecuteErrorEvent;
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute

Example
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


TADAdaptedDataSet.PointedConnection Property

TADAdaptedDataSet.PointedConnection Property
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

The actual connection object.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Description

The PointedConnection property returns reference to the connection object, which:

  • is referenced by descendant datasets Connection property;
  • has the name specified by descendant datasets ConnectionName property.
Syntax
property PointedConnection: TADCustomConnection;
See Also

TADRdbmsDataSet.Connection, TADRdbmsDataSet.ConnectionName, TADCustomConnection


TADAdaptedDataSet.ServerEditRequest Property

TADAdaptedDataSet.ServerEditRequest Property
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
property ServerEditRequest: TADPhysRequest;


TADAdaptedDataSet.AbortJob Method

TADAdaptedDataSet.AbortJob Method
TADAdaptedDataSet Class uADCompClient Unit Example public See Also Send Feedback

Use the AbortJob method to abort current dataset operation.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
AWait: Boolean = False | If True, then caller will wait until a current operation will be terminated.
Description

The AbortJob method aborts one of the following dataset operations:

  • Open. The dataset is executing DBMS command to open cursor.
  • ExecSQL/Execute. The dataset is executing DBMS command.
  • Fetch. The dataset is fetching rows from cursor.

After AbortJob call dataset state will be Active=False and Prepared=True for Open/ExecSQL/Execute. And Active=True for Fetch. The AbortJob method must be called from the other thread, than where a operation is performing.

Syntax
procedure AbortJob(AWait: Boolean = False);
See Also

Disconnect

Example
ADQuery1.ResourceOptions.CmdExecMode := amAsync;
ADQuery1.Open('select OrderID, count(*) from "Order Details" group by OrderID');
ADQuery1.AbortJob(True);


TADAdaptedDataSet.Disconnect Method

TADAdaptedDataSet.Disconnect Method
TADAdaptedDataSet Class uADCompClient Unit Example public See Also Send Feedback

Disconnects the dataset from DBMS.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
AAbortJob: Boolean = False | If True, then current dataset task will be aborted. The code will wait, while task abortion will be finished.
Description

The Disconnect method optionally aborts current dataset task, like a Open, Execute, ExecSQL or rows fetching. Then closes dataset and unprepares it.

Syntax
procedure Disconnect(AAbortJob: Boolean = False); override;
See Also

AbortJob

Example
ADQuery1.Disconnect(True);
// is equivalent to:
// ADQuery1.AbortJob(True);
// ADQuery1.Close;
// ADQuery1.Unprepare;


TADAdaptedDataSet.NextRecordSet Method

TADAdaptedDataSet.NextRecordSet Method
TADAdaptedDataSet Class uADCompClient Unit Example public See Also Send Feedback

Go to the next cursor, returned by the SQL command.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, Example, public, See Also
Description

The NextRecordSet method closes current cursor, forwards it to the next accessible cursor and opens dataset. If there is no more accessible cursors, then after call dataset is closed.

The Close method closes current cursor. The CloseAll method call discards all assocciated cursors. So, to get all cursors, you should set FetchOptions.AutoClose to False before opening dataset.

Oracle REF CURSOR's for AnyDAC are also command cursors, and NextRecordSet call will select next PL/SQL REF CURSOR parameter.

In design time, you can forward dataset to the next cursor, by right clicking component and choosing "Next record set" popup menu item.

Syntax
procedure NextRecordSet;
See Also

TADFetchOptions.AutoClose, TDataSet.Open, TDataSet.Close

Example
ADQuery1.FetchOptions.AutoClose := False;
ADQuery1.SQL.Text := 'select 1 as i; select ''qwe'' as s';
ADQuery1.Open;
ShowMessage(ADQuery1.Fields[0].FieldName + ' ' + ADQuery1.Fields[0].AsString); // output "i 1"
ADQuery1.NextRecordSet;
ShowMessage(ADQuery1.Fields[0].FieldName + ' ' + ADQuery1.Fields[0].AsString); // output "s qwe"
ADQuery1.Close;


TADAdaptedDataSet.Offline Method

TADAdaptedDataSet.Offline Method
TADAdaptedDataSet Class uADCompClient Unit public See Also Send Feedback

Sets dataset to offline mode.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public, See Also
Description

The Offline method disconnects dataset from DBMS, but does not close it. After call the dataset continue to work as an in-memory dataset and you can perform with the dataset any operation, which does not require DBMS, like a browsing.

Most often the method will be not called directly, but indirectly through TADCustomConnection.Offline method.

Syntax
procedure Offline; override;
See Also

TADCustomConnection.Offline, TADCustomConnection.Online


TADAdaptedDataSet.ServerAppend Method

TADAdaptedDataSet.ServerAppend Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerAppend;


TADAdaptedDataSet.ServerCancel Method

TADAdaptedDataSet.ServerCancel Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Description
Syntax
procedure ServerCancel;


TADAdaptedDataSet.ServerDelete Method

TADAdaptedDataSet.ServerDelete Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerDelete;


TADAdaptedDataSet.ServerDeleteAll Method

TADAdaptedDataSet.ServerDeleteAll Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerDeleteAll(ANoUndo: Boolean = False);


TADAdaptedDataSet.ServerEdit Method

TADAdaptedDataSet.ServerEdit Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerEdit;


TADAdaptedDataSet.ServerGotoKey Method

TADAdaptedDataSet.ServerGotoKey Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
function ServerGotoKey: Boolean;


TADAdaptedDataSet.ServerPerform Method

TADAdaptedDataSet.ServerPerform Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerPerform;


TADAdaptedDataSet.ServerSetKey Method

TADAdaptedDataSet.ServerSetKey Method
TADAdaptedDataSet Class uADCompClient Unit public Send Feedback

Used by TADDataMove to edit directly DBMS data.

Group

public

Links
TADAdaptedDataSet Class, uADCompClient Unit, public
Syntax
procedure ServerSetKey;


TADCommand Class

TADCommand Class
published Classes See Also Send Feedback

The class is responsible for execution of SQL commands.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

Use the TADCommand class to execute SQL command, which does not return resultsets, requiring TDataSet-aware access.

Syntax
TADCommand = class(TADCustomCommand);
See Also

TADCustomCommand, TADCustomQuery, IADPhysCommand


published

published
TADCommand Class Legend Published Events Published Properties Send Feedback

The published members of the TADCommand class are listed here.

Class

TADCommand Class

Published Events
Name | Description
AfterClose | The event fires after command is closed.
AfterExecute | The event fires after command is executed.
AfterOpen | The event fires after command is opened.
AfterPrepare | The event fires after command is prepared.
AfterUnprepare | The event fires after command is unprepared.
BeforeClose | The event fires before command will be closed.
BeforeExecute | The event fires before command will be executed.
BeforeOpen | The event fires before command will be opened.
BeforePrepare | The event fires before command will be prepared.
BeforeUnprepare | The event fires before command will be unprepared.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.
Published Properties
Name | Description
Active | Gets or sets command active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
BaseObjectName | Identifies base object name for some of command kinds.
CatalogName | Identifies catalog name for some command kinds.
CommandKind | Identifies command kind.
CommandText | The SQL command text to execute.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FetchOptions | The set of options to control rows fetching.
FormatOptions | The set of options to control data representation.
Macros | The collection of macro substitution variables.
Overload | Oracle stored procedure overload index.
Params | The collection of parameters for a SQL command.
Prepared | Gets or sets command prepare for execution status.
ResourceOptions | The set of options to control resources usage.
SchemaName | Identifies schema name for some of command kinds.
Transaction | Specifies the trasaction object.
UpdateOptions | The set of options to control updates posting.
Links
TADCommand Class, Legend, Published Events, Published Properties


TADCommand.Active Property

TADCommand.Active Property
TADCommand Class uADCompClient Unit Example published See Also Send Feedback

Gets or sets command active status.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example, published, See Also
Description

Set Active to True to execute SQL command and return cursor. After that the State = csOpen and you can fetch rows from current cursor using Fetch method. Setting Active to True, will call Open method.

Set Active to False to close current command cursor. After that State = csPrepared. Setting Active to False, will call Close method. To close all command cursors (if command returns multiple result sets), use CloseAll method.

Syntax
property Active: Boolean;
See Also

Fetch, Define, Open, Close, CloseAll, State

Example
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


TADCommand.ActiveStoredUsage Property

TADCommand.ActiveStoredUsage Property
TADCommand Class uADCompClient Unit published Send Feedback

Controls how to use Active property value saved to DFM.

Group

published

Links
TADCommand Class, uADCompClient Unit, published
Description

The ActiveStoredUsage property controls how to use Active property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADCommand.AfterClose Event

TADCommand.AfterClose Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is closed.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The AfterClose event fires, after command is closed by calling Close or setting Active = False.

Syntax
property AfterClose: TNotifyEvent;
See Also

BeforeClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.AfterExecute Event

TADCommand.AfterExecute Event
TADCommand Class uADCompClient Unit Example published See Also Send Feedback

The event fires after command is executed.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example, published, See Also
Description

The AfterExecute event fires, after command is executed by calling Execute method.

Syntax
property AfterExecute: TNotifyEvent;
See Also

BeforeExecute, Execute

Example
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


TADCommand.AfterOpen Event

TADCommand.AfterOpen Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is opened.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The AfterOpen event fires, after command is opened by calling Open or setting Active = True.

Syntax
property AfterOpen: TNotifyEvent;
See Also

BeforeOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.AfterPrepare Event

TADCommand.AfterPrepare Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is prepared.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The AfterPrepare event fires, after command is prepared by calling Prepare method.

Syntax
property AfterPrepare: TNotifyEvent;
See Also

BeforePrepare, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.AfterUnprepare Event

TADCommand.AfterUnprepare Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is unprepared.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The AfterUnprepare event fires, after command is unprepared by calling Unprepare method.

Syntax
property AfterUnprepare: TNotifyEvent;
See Also

BeforeUnprepare, Unprepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.BaseObjectName Property

TADCommand.BaseObjectName Property
TADCommand Class uADCompClient Unit Example published See Also Send Feedback

Identifies base object name for some of command kinds.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example, published, See Also
Description

The BaseObjectName identifies the name of the base object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs] and DBMS is Oracle, then BaseObjectName specifies the name of the package, if procedure is packaged procedure.
  • If MetaInfoKind in [mkIndexFields, mkPrimaryKeyFields, mkForeignKeyFields], then BaseObjectName specifies the name of the table.
  • If MetaInfoKind in [mkProcs, mkProcArgs], and DBMS is Oracle, then BaseObjectName specifies the name of the package.
Syntax
property BaseObjectName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind

Example
ADCommand1.BaseObjectName := 'MY_PACK';
ADCommand1.CommandText.Text := 'PROC1';
// or just ADCommand1.CommandText.Text := 'MY_PACK.PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Codegear Delphi';
ADCommand1.Execute;


TADCommand.BeforeClose Event

TADCommand.BeforeClose Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be closed.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The BeforeClose event fires, before command will be closed by calling Close or setting Active = False.

Syntax
property BeforeClose: TNotifyEvent;
See Also

AfterClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.BeforeExecute Event

TADCommand.BeforeExecute Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be executed.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The BeforeExecute event fires, before command will be executed by calling Execute method.

Syntax
property BeforeExecute: TNotifyEvent;
See Also

AfterExecute, Execute

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.BeforeOpen Event

TADCommand.BeforeOpen Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be opened.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The AfterOpen event fires, before command will be opened by calling Open or setting Active = True.

Syntax
property BeforeOpen: TNotifyEvent;
See Also

AfterOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.BeforePrepare Event

TADCommand.BeforePrepare Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be prepared.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The BeforePrepare event fires, before command will be prepared by calling Prepare method.

Syntax
property BeforePrepare: TNotifyEvent;
See Also

AfterPrepare, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.BeforeUnprepare Event

TADCommand.BeforeUnprepare Event
TADCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be unprepared.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The BeforeUnprepare event fires, before command wille be unprepared by calling Unprepare method.

Syntax
property BeforeUnprepare: TNotifyEvent;
See Also

BeforeUnprepare, Unprepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.CatalogName Property

TADCommand.CatalogName Property
TADCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies catalog name for some command kinds.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The CatalogName identifies the name of the catalog where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then CatalogName specifies the name of the catalog, where resides the procedure.
  • If MetaInfoKind is not mkNone, then CatalogName specifies the name of the catalog, where resides the describing object.
Syntax
property CatalogName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADCommand.CommandKind Property

TADCommand.CommandKind Property
TADCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies command kind.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The CommandKind property identifies the kind of the content of CommandText property. You can explicitly set it value before Prepare call, otherwise it will be automatically assigned by AnyDAC after analyzing CommandText content. There is only single need to assign it - when you are preparing stored procedure.

Syntax
property CommandKind: TADPhysCommandKind;
See Also

CommandText

Example 1
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
Example 2
ADCommand1.CommandText.Text := 'ALTER PROCEDURE MY_PROC COMPILE';
case ADCommand1.CommandKind of
skAlter: ShowMessage('Alter command');
..........
else     ShowMessage('Other command');
end;


TADCommand.CommandText Property

TADCommand.CommandText Property
TADCommand Class uADCompClient Unit Example 1 Example 2 Example 3 published See Also Send Feedback

The SQL command text to execute.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, Example 3, published, See Also
Description

The CommandText set/get:

  • SQL command text to execute
  • or name of the stored procedure to execute, if CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs].

After setting CommandText, AnyDAC will do for non-stored procedures:

  • extract parameters names and fill Params collection, if ResourceOptions.ParamCreate = True;
  • extract macro name and fill Macros collection, if ResourceOptions.MacroCreate = True;
  • extract FROM table name for SELECT commands and assign it to CommandIntf.SourceObjectName, if ResourceOptions.PreprocessCmdText = True;
  • fill CommandKind property value, if it is not explicitly set.

If you are adding long command, using CommandText.Add method, then it is recommended before command modification to call CommandText.BeginUpdate and after finishing command modification to call CommandText.EndUpdate.

Later on Prepare call command text will be preprocessed and transformed in target DBMS command. See chapter Command text preprocessing for details about AnyDAC macros and escape sequences - preprocessor instructions.

Syntax
property CommandText: TStrings;
See Also

TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADResourceOptions.PreprocessCmdText, TADPhysCommandIntf.SourceObjectName, CommandKind, Params, Macros, ResourceOptions

Example 1

Stored procedure:

ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;
Example 2

General SQL command:

ADCommand1.CommandText.Text := 'insert into MyTab values (:p1)';
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;
Example 3

Adding long command:

with ADCommand1.CommandText do begin
  BeginUpdate;
  Add('............');
  ......
  Add('............');
  EndUpdate;
end;


TADCommand.Connection Property

TADCommand.Connection Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

Specifies the connection object.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The Connection property value points to the connection object. Alternatively may be specified the ConnectionName property value. The Connection property value must be specified before Prepare call.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.ConnectionName Property

TADCommand.ConnectionName Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

Specifies connection name.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file or created on fly;
  • ConnectionName of one of the TADConnection objects.

Alternatively may be specified the Connection property value. The ConnectionName property value must be specified before Prepare call. If is specified the name of one of connection definitions, then AnyDAC will transparently create connection object and link it with command.

Syntax
property ConnectionName: String;
See Also

Connection, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.FetchOptions Property

TADCommand.FetchOptions Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

The set of options to control rows fetching.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The FetchOptions property is the set of properties, controlling the fetching of cursor rows. These properties will inherit its values from FetchOptions of connection object.

Syntax
property FetchOptions: TADFetchOptions;
See Also

TADFetchOptions, Fetch

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.FormatOptions Property

TADCommand.FormatOptions Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

The set of options to control data representation.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The FormatOptions property is the set of properties, controlling the data type mapping, and some other aspects of data handling.

Syntax
property FormatOptions: TADFormatOptions;
See Also

TADFormatOptions, Fetch, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.Macros Property

TADCommand.Macros Property
TADCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The collection of macro substitution variables.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The Macros property is the collection of macro substitution variables. It is populated automatically after assigning CommandText, if ResourceOptions.MacroCreate = True. Otherwise it may be populated by hands. At Prepare call, macro values will be substituted into CommandText, if ResourceOptions.MacroExpand = True.

Syntax
property Macros: TADMacros;
See Also

CommandText, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand

Example 1

Substitute table name:

ADCommand1.CommandText.Text := 'select * from &Tab';
ADCommand1.Macros[0].AsIdentifier := 'Order Details';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from "Order Details"
Example 2

Substitute WHERE condition:

ADCommand1.CommandText.Text := 'select * from MyTab {if !cond} where !cond {fi}';
ADCommand1.Macros[0].AsString := 'ID > 100';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab where ID > 100
ADCommand1.Macros[0].Clear;
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab


TADCommand.OnCommandChanged Event

TADCommand.OnCommandChanged Event
TADCommand Class uADCompClient Unit Example published See Also Send Feedback

The event fires after CommandText is changed.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example, published, See Also
Description

The OnCommandChanged event fires, after CommandText is changed.

Syntax
property OnCommandChanged: TNotifyEvent;
See Also

CommandText

Example
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


TADCommand.OnError Event

TADCommand.OnError Event
TADCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while command is communicating with DBMS.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to command.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when command executes one of the following operations and an error happens:

  • Prepare. The command is preparing DBMS command text for execution.
  • Open. The command is executing DBMS command to open cursor.
  • Execute. The command is executing DBMS command text.
  • Fetch. The command is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use code like in the example.

Syntax
property OnError: TADErrorEvent;
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException

Example 1

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADCommand.Overload Property

TADCommand.Overload Property
TADCommand Class uADCompClient Unit Example published See Also Send Feedback

Oracle stored procedure overload index.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example, published, See Also
Description

The Overload property specifies Oracle packaged stored procedure overload index. It has no meaning for other DBMS's.

Syntax
property Overload: Word;
See Also

CommandText, CommandKind

Example
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


TADCommand.Params Property

TADCommand.Params Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

The collection of parameters for a SQL command.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The Params property is the collection of parameters for a SQL command.

If CommandKind is not in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then Params is populated automatically after assigning CommandText, if ResourceOptions.ParamCreate = True.

If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then Params is populated automatically after calling Prepare method, if fiMeta is in FetchOption.Items.

Otherwise Params may be populated by hands. At Prepare call, parameters will be binded to prepared SQL command. After that you cannot change parameter types, otherwise will get an exception.

Syntax
property Params: TADParams;
See Also

CommandText, Macros, Prepare, TADParams, TADResourceOptions.ParamCreate, TADFetchOptions.Items


TADCommand.Prepared Property

TADCommand.Prepared Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

Gets or sets command prepare for execution status.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

Set Prepared to True to prepare SQL command for execution. After that the State = csPrepared. Setting Prepared to True, will call Prepare method. It is not required to set Prepared to True for standard SQL command before execution, because first Execute / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise an exception will be raised.

After SQL command preparation application cannot change command parameter data types and sizes, otherwise on next Execute or Open call an exception will be raised. So, setup parameters before setting Prepared to True.

Set Prepared to False to unprepare SQL command and release all it resources. After that State = csInactive. Setting Prepared to False, will call Unprepare method.

Syntax
property Prepared: Boolean;
See Also

Prepare, Unprepare, State, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.ResourceOptions Property

TADCommand.ResourceOptions Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

The set of options to control resources usage.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The ResourceOptions property is the set of properties, controlling the resources usage by the command. These properties will inherit its values from ResourceOptions of connection object.

Syntax
property ResourceOptions: TADResourceOptions;
See Also

TADBottomResourceOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCommand.SchemaName Property

TADCommand.SchemaName Property
TADCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies schema name for some of command kinds.

Group

published

Links
TADCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The SchemaName identifies the name of the schema where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then SchemaName specifies the name of the schema, where resides the procedure.
  • If MetaInfoKind is not mkNone, then SchemaName specifies the name of the schema, where resides the describing object.
Syntax
property SchemaName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADCommand.Transaction Property

TADCommand.Transaction Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

Specifies the trasaction object.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The Transaction property value points to the transaction object. The SQL command will be prepared and executed in the context of this transaction. The Transaction property value must be specified before Prepare call. If a value is not specified, then command will use default transaction object, specified at TADCustomConnection.Transaction or internal connection transaction object.

Notes

At moment only Interbase / Firebird driver supports assignment of transaction to the command.

Syntax
property Transaction: TADCustomTransaction;
See Also

TADTransaction, TADCustomConnection.Transaction


TADCommand.UpdateOptions Property

TADCommand.UpdateOptions Property
TADCommand Class uADCompClient Unit published See Also Send Feedback

The set of options to control updates posting.

Group

published

Links
TADCommand Class, uADCompClient Unit, published, See Also
Description

The UpdateOptions property is the set of properties, controlling the posting of updates. These properties will inherit its values from ResourceOptions of connection object.

Syntax
property UpdateOptions: TADUpdateOptions;
See Also

TADBottomUpdateOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection Class

TADConnection Class
published Classes See Also Send Feedback

The class is responsible to connection establishment with a DBMS.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

Use TADConnection to establish connection to a DBMS and manage associated datasets.

Syntax
TADConnection = class(TADCustomConnection);
See Also

TADCustomConnection, IADPhysConnection

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


published

published
TADConnection Class Legend Published Events Published Properties Send Feedback

The published members of the TADConnection class are listed here.

Class

TADConnection Class

Published Events
Name | Description
AfterConnect |
AfterDisconnect |
BeforeConnect |
BeforeDisconnect |
OnError | Fires before AnyDAC will raise exception.
OnLogin | Fires when an application connects to a DBMS.
OnLosted | Fires after AnyDAC was not able to restore losted connection to DBMS.
OnRecover | Fires after AnyDAC discovered that connection to DBMS is losted.
OnRestored | Fires after AnyDAC successfully restored losted connection to DBMS.
Published Properties
Name | Description
Connected | Gets / sets connection active status.
ConnectedStoredUsage | Controls how to use Connected property value saved to DFM.
ConnectionDefName | The name of connection definition to use.
ConnectionName | Specifies the name of the connection to associate with this connection object.
DriverName | Specifies the ID of the AnyDAC driver for the connection.
FetchOptions | The set of default options to control rows fetching.
FormatOptions | The set of default options to control data representation.
LoginDialog | Gets / sets the reference to login dialog interface.
LoginPrompt | Specifies whether a login dialog appears immediately before opening a new connection.
Params | Lists database connection parameters for the AnyDAC connection definition associated with the connection object.
ResourceOptions | The set of default options to control resources usage.
Transaction | The reference to TADCustomTransaction object.
TxOptions | The set of options to control transactions.
UpdateOptions | The set of default options to control data updating.
UpdateTransaction | The reference to TADCustomTransaction object, which will be used to post changes to DB.
Links
TADConnection Class, Legend, Published Events, Published Properties


TADConnection.AfterConnect Property

TADConnection.AfterConnect Property
TADConnection Class uADCompClient Unit published Send Feedback
Group

published

Links
TADConnection Class, uADCompClient Unit, published
Syntax
property AfterConnect;


TADConnection.AfterDisconnect Property

TADConnection.AfterDisconnect Property
TADConnection Class uADCompClient Unit published Send Feedback
Group

published

Links
TADConnection Class, uADCompClient Unit, published
Syntax
property AfterDisconnect;


TADConnection.BeforeConnect Property

TADConnection.BeforeConnect Property
TADConnection Class uADCompClient Unit published Send Feedback
Group

published

Links
TADConnection Class, uADCompClient Unit, published
Syntax
property BeforeConnect;


TADConnection.BeforeDisconnect Property

TADConnection.BeforeDisconnect Property
TADConnection Class uADCompClient Unit published Send Feedback
Group

published

Links
TADConnection Class, uADCompClient Unit, published
Syntax
property BeforeDisconnect;


TADConnection.Connected Property

TADConnection.Connected Property
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets connection active status.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

Set Connected to true to establish a connection to an DBMS. Set Connected to false to close a connection. The default value for Connected is false.

An application can check Connected to determine the current status of a connection. If Connected is true, the connection is active; if false, and the KeepConnection property is also false, then the connection is inactive.

To open connection, it must be setup in one of the following ways:

  1. set ConnectionDefName to the name of one of a existing connection definitions and optionally override connection definition parameters in Params;
  2. set DriverName to the name of one of a registered drivers (or add DriverID into Params) and specifiy connection definition parameters in Params.

If connection definition is pooled (Pooled=True), then use (1) and does not override any of parameters, otherwise you will get an exception.

Setting Connected to False will disconnect (close and unprepare) all associated commands and datasets. If you just need to disconnect from DBMS, but does not close objects, then use Offlined property.

Syntax
property Connected: Boolean;
See Also

TCustomConnection.BeforeConnect, TCustomConnection.AfterConnect, TCustomConnection.BeforeDisconnect, TCustomConnection.AfterDisconnect, ConnectionDefName, DriverName, Params, Offlined

Example
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


TADConnection.ConnectedStoredUsage Property

TADConnection.ConnectedStoredUsage Property
TADConnection Class uADCompClient Unit published Send Feedback

Controls how to use Connected property value saved to DFM.

Group

published

Links
TADConnection Class, uADCompClient Unit, published
Description

The ConnectedStoredUsage property controls how to use Connected property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ConnectedStoredUsage: TADStoredActivationUsage;


TADConnection.ConnectionDefName Property

TADConnection.ConnectionDefName Property
TADConnection Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The name of connection definition to use.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The ConnectionDefName property specifies the name of one of a existing connection definitions. It must be stored in ADConnectionDefs.ini or created dynamically.

Notes

Attempting to set ConnectionDefName when the Connected property is true raises an exception.

Syntax
property ConnectionDefName: string;
See Also

TADCustomManager

Example 1
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;
Example 2

See demo AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs for details how to create and use connection definitions.


TADConnection.ConnectionName Property

TADConnection.ConnectionName Property
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Specifies the name of the connection to associate with this connection object.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

Use ConnectionName to specify the name of the connection to use with a connection object. If ConnectionName is the same as an existing connection definition, then the ConnectionDefName and DriverName properties need not be set. If ConnectionName does not match an existing connection definition, then either the application must also supply a valid connection definition in the ConnectionDefName property in addition to the or it must supply the DriverName and Params properties.

You can specifiy as ConnectionName for TADCustomCommand or TADRDBMSDataSet component and its descendants (TADQuery, TADStoredProc, TADTable), the ConnectionName of one of the existing TADConnection objects or the name of one of the existing connection definitions.

Notes
  1. Attempting to set ConnectionName when the Connected property is true raises an exception.
  2. At design time double-click a TConnection component to invoke the Database editor and set the ConnectionName.
Syntax
property ConnectionName: String;
See Also

ConnectionDefName, DriverName, Params, TADCustomCommand.ConnectionName, TADRDBMSDataSet.ConnectionName

Example
ADConnection1.ConnectionName := 'TestConn';
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.ConnectionName := 'TestConn';
ADQuery1.Open('select * from test_tab');


TADConnection.DriverName Property

TADConnection.DriverName Property
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Specifies the ID of the AnyDAC driver for the connection.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

Use DriverName to specify the ID of the AnyDAC driver to use for connection that do not specify an ConnectionDefName. DriverName must be a valid AnyDAC registered driver ID.

If an application sets DriverName, it must also specify connection parameters in the Params property. Ordinarily the alias specified in the ConnectionDefName property supplies connection parameters, but when DriverName is set, the ConnectionDefName property is automatically cleared to avoid AnyDAC driver ID contention.

Attempting to set DriverName when the Connected property is True raises an exception.

Setting DriverName value, will add DriverID=<xxx> parameter to the Params list.

Notes

At design time double-click a TConnection component to invoke the Connection editor and set the DriverName.

Or choose DriverName value in property inspector from drop-down list.

Syntax
property DriverName: string;
See Also

Params, ConnectionDefName

Example
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.Connection := ADConnection1;
ADQuery1.Open('select * from test_tab');


TADConnection.FetchOptions Property

TADConnection.FetchOptions Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The set of default options to control rows fetching.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The FetchOptions property is the set of default properties, controlling the fetching of cursor rows. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from FetchOptions of ADManager object.

Syntax
property FetchOptions: TADFetchOptions;
See Also

TADFetchOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.FormatOptions Property

TADConnection.FormatOptions Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The set of default options to control data representation.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The FormatOptions property is the set of the default properties, controlling the data type mapping, and some other aspects of data handling. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from FormatOptions of ADManager object.

Syntax
property FormatOptions: TADFormatOptions;
See Also

TADFormatOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.LoginDialog Property

TADConnection.LoginDialog Property
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the reference to login dialog interface.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

The LoginDialog property allows to associate the interface of the login dialog with this connection. The standard login dialog interface implementation is TADGUIxFormsLoginDialog component. The interface assigned to the LoginDialog will be used only by this connection object.

If the LoginDialog property is not assigned, but unit uADGUIxFormsfLogin is linked into application, then connection object will use default internal loging dialog instance.

The login dialog will popup at connecting to a DBMS only if all of the following conditions are met:

  • LoginPrompt=True;
  • connection definition is not pooled (Pooled=False);
  • global silent flag is not set to True (ADGUIxSilent() = False);
  • connection object does not use shared CLI handle (SharedCliHandle = nil).
Syntax
property LoginDialog: IADGUIxLoginDialog;
See Also

TADGUIxFormsLoginDialog, LoginPrompt, SharedCliHandle, ADGUIxSilent

Example

Using private login dialog

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


TADConnection.LoginPrompt Property

TADConnection.LoginPrompt Property
TADConnection Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Specifies whether a login dialog appears immediately before opening a new connection.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

Set LoginPrompt to True to provide login support when establishing a connection. When LoginPrompt is True, a dialog appears to prompt users for a name, password and other optional parameters. The dialog appears after the BeforeConnect event and before the AfterConnect event, unless you supply an OnLogin event handler. If there is an OnLogin event handler, that event occurs in place of the login dialog. If correct values for the user name, password and other optional parameters are not supplied in the dialog or by the OnLogin event handler, the connection fails. This OnLogin event does not fire unless LoginPrompt is set to True.

When LoginPrompt is False, the application must supply user name, password and other optional parameter values programmatically. For that application can specify User_name, Password, etc parameters in Params.

The login dialog will popup at connecting to a DBMS only if all of the following conditions are met:

  • LoginPrompt=True;
  • connection definition is not pooled (Pooled=False);
  • global silent flag is not set to True (ADGUIxSilent() = False);
  • connection object does not use shared CLI handle (SharedCliHandle = nil).
Syntax
property LoginPrompt;
See Also

OnLogin, LoginDialog, Params, SharedCliHandle, ADGUIxSilent

Example 1

Using login dialog:

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;
Example 2

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := 'sql';
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


TADConnection.OnError Event

TADConnection.OnError Event
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Fires before AnyDAC will raise exception.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Parameters
Parameters | Description
ASender | This connection object.
AInitiator | The interface of the object initially discovered error.
AException | The exception object to be raised.
Description

The OnError event handler fires before AnyDAC will raise exception inside of call of one of the connection or assocciated commands or datasets methods. In most cases AException will be of EADDBEngineException class.

The event handler can replace AException object with some other custom exception. In this case original object must be freed.

Syntax
property OnError: TADErrorEvent;
See Also

EADDBEngineException

Example
procedure TForm1.ADConnection1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if (AException is EADDBEngineException) and (EADDBEngineException(AException).Kind = ekUKViolated) then begin
    AException.Free;
    AException := Exception.Create('You must enter unique document number !');
  end;
end;


TADConnection.OnLogin Event

TADConnection.OnLogin Event
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Fires when an application connects to a DBMS.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

Write an OnLogin event handler to take specific actions when an application attempts to connect to a DBMS. When the LoginPrompt property is True, a database login is required. The login dialog and OnLogin event only occur when the LoginPrompt property is true.

If there is no OnLogin event handler, the current UserName is read from the Params property or connection definition, and a standard Login dialog box opens. The dialog prompts for a user name, password and other optional parameters, and then uses the values entered by the user to set the UserName, Password and other optional values in the Params property. These values are then passed to the DBMS.

Applications that provide alternative OnLogin event handlers may set the UserName, Password and other optional values in AConnectionDef. AConnectionDef is a temporary connection definition and is freed automatically when no longer needed.

Syntax
property OnLogin: TADConnectionLoginEvent;
See Also

LoginPrompt, Connected, IADStanConnectionDef

Example

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := InputBox('Login', 'Please enter DBA password', 'sql');
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


TADConnection.OnLosted Event

TADConnection.OnLosted Event
TADConnection Class uADCompClient Unit published See Also Send Feedback

Fires after AnyDAC was not able to restore losted connection to DBMS.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The OnLosted event fires after AnyDAC was not able to automatically restore connection to the DBMS, after discovering that it is losted.

Syntax
property OnLosted: TNotifyEvent;
See Also

OnRecover, OnRestored

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.OnRecover Event

TADConnection.OnRecover Event
TADConnection Class uADCompClient Unit published See Also Send Feedback

Fires after AnyDAC discovered that connection to DBMS is losted.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Parameters
Parameters | Description
ASender | This connection object.
AInitiator | The interface of the object initially discovered error.
AException | The exception object describing losted connection issue.
AAction | The action AnyDAC should take after return from event handler.
Description

The OnRecover event fires after AnyDAC discovered that connection to DBMs is losted. The event handler can analyze the reason, ask user how to proceed, show some status and returns the action, AnyDAC should take:

Action | Description
faDefault | If TADTopResourceOptions.AutoConnRestore=True, then AnyDAC will try to reconnect, otherwise will raise an exception, that connection is losted. By default TADTopResourceOptions.AutoConnRestore=False.
faFail | Close connection and raise an exception, that connection is losted.
faRetry | Try to reconnect.
faCloseAbort | Close connection and abort current operation.
faOfflineAbort | Switch connection to the offline mode and abort current operation.

If event handler is not assigned, then AnyDAC will take default (faDefault) action. If after 3 trials connection cannot be restored, then AnyDAC will close connection and raise an exception, that connection is losted.

Syntax
property OnRecover: TADConnectionRecoverEvent;
See Also

OnLosted, OnRestored, TADTopResourceOptions.AutoConnRestore, Connected, Offlined


TADConnection.OnRestored Event

TADConnection.OnRestored Event
TADConnection Class uADCompClient Unit published See Also Send Feedback

Fires after AnyDAC successfully restored losted connection to DBMS.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The OnRestored event fires after AnyDAC successfully restored connection to the DBMS, after discovering that it is losted.

Syntax
property OnRestored: TNotifyEvent;
See Also

OnLosted, OnRecover

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.Params Property

TADConnection.Params Property
TADConnection Class uADCompClient Unit Example published See Also Send Feedback

Lists database connection parameters for the AnyDAC connection definition associated with the connection object.

Group

published

Links
TADConnection Class, uADCompClient Unit, Example, published, See Also
Description

Use Params to list DBMS connection definition parameters, such server name, port, database, client character set, user name and password. The possible set of parameters depends on the DBMS kind to connect to.

Params is a list of string items, each representing a different DBMS connection definition parameter. If the ConnectionDefName property specifies a valid AnyDAC connection definition, then parameters, specified in Params, will override corresponsding connection definition parameters. If an application need to specify connection definition parameter on-fly, then an application must fill-in all required connection definition parameter into Params.

At design time double-click a TConnection component to invoke the Connection editor and set Params.

Syntax
property Params: TStrings;
See Also

ConnectionDefName, DriverName, OnLogin

Example
with ADConnection1.Params do begin
  Clear;
  Add('DriverID=Ora');
  Add('Database=ORA_920_APP');
  Add('User_Name=ADDemo');
  Add('Password=a');
end;
ADConnection1.Connected := True;


TADConnection.ResourceOptions Property

TADConnection.ResourceOptions Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The set of default options to control resources usage.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The ResourceOptions property is the set of the default properties, controlling the resources usage by the command. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from ResourceOptions of ADManager object.

Syntax
property ResourceOptions: TADResourceOptions;
See Also

TADTopResourceOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.Transaction Property

TADConnection.Transaction Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The reference to TADCustomTransaction object.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The Transaction property get/set reference to the transaction object, which will be default one for the connection and all associated datasets and commands without explicitly assigned Transaction property. At moment, this behaviour has the meaning only for Interbase / Firebird connection.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomTransaction

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.TxOptions Property

TADConnection.TxOptions Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The set of options to control transactions.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The TxOptions property is the set of the properties, controlling the transactions in this connection. If you set Transaction property, then application should use Transaction.Options, instead of TxOptions.

Syntax
property TxOptions: TADTxOptions;
See Also

Transaction, TADTxOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.UpdateOptions Property

TADConnection.UpdateOptions Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The set of default options to control data updating.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The UpdateOptions property is the set of the default properties, controlling the data updating by the datasets. These properties will be inherited by datasets, associated with this connection. Also these properties will inherit its values from UpdateOptions of ADManager object.

Syntax
property UpdateOptions: TADUpdateOptions;
See Also

TADUpdateOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADConnection.UpdateTransaction Property

TADConnection.UpdateTransaction Property
TADConnection Class uADCompClient Unit published See Also Send Feedback

The reference to TADCustomTransaction object, which will be used to post changes to DB.

Group

published

Links
TADConnection Class, uADCompClient Unit, published, See Also
Description

The UpdateTransaction property get/set reference to the transaction object, which will be default one for all associated datasets without explicitly assigned UpdateTransaction property. This transaction will be used by datasets to post changes to the DB.

If UpdateTransaction is not assigned, but Transaction is assigned, then Transaction object will be used as update transaction.

At moment, this behaviour has the meaning only for Interbase / Firebird connection.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomTransaction

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand Class

TADCustomCommand Class
public Classes See Also Send Feedback

The base class is responsible for execution of SQL commands.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use the TADCustomCommand class to execute SQL command, which does not return resultsets, requiring TDataSet-aware access.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADCommand.

Syntax
TADCustomCommand = class(TComponent, IUnknown, IADStanOptions, IADStanErrorHandler, IADStanObject, IADStanAsyncHandler, IADPhysCommandStateHandler);
See Also

TADCommand, TADCustomQuery, IADPhysCommand


public

public
TADCustomCommand Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADCustomCommand class are listed here.

Class

TADCustomCommand Class

Public Events
Name | Description
AfterClose | The event fires after command is closed.
AfterExecute | The event fires after command is executed.
AfterFetch | The event fires after fetching from command cursor.
AfterOpen | The event fires after command is opened.
AfterPrepare | The event fires after command is prepared.
AfterUnprepare | The event fires after command is unprepared.
BeforeClose | The event fires before command will be closed.
BeforeExecute | The event fires before command will be executed.
BeforeFetch | The event fires before fetching from command cursor.
BeforeOpen | The event fires before command will be opened.
BeforePrepare | The event fires before command will be prepared.
BeforeUnprepare | The event fires before command will be unprepared.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.
Public Methods
Name | Description
AbortJob | Use the AbortJob method to abort current command operation.
AcquireConnection | Acquires reference to the actual connection object.
Close | Closes command current cursor.
CloseAll | Closes all command cursors.
Define | Defines DatS manager for command multiple result sets.
Define | Define DatS table structure for command's current cursor.
Disconnect | Use Disconnect method to release DBMS resources, used by this command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Fetch | Fetches rows from current command cursor.
FillParams | Fills the Params collection.
FindMacro | Returns macro by its name.
FindParam | Returns parameter by its name.
GetConnection | Returns the connection object.
MacroByName | Returns macro by its name.
NextRecordSet | Go to the next cursor, returned by the SQL command.
Open | Executes SQL command, returning cursor.
OpenOrExecute | Execute SQL command, optionally returning cursor.
ParamByName | Returns parameter by its name.
Prepare | Prepares SQL command for execution.
ReleaseConnection | Releases reference to the actual connection object.
Unprepare | Releases SQL command resources.
Public Properties
Name | Description
Active | Gets or sets command active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
BaseObjectName | Identifies base object name for some of command kinds.
BindedBy | Determines how command is connected to connection object.
CatalogName | Identifies catalog name for some command kinds.
CommandIntf | Returns IADPhysCommand interface.
CommandKind | Identifies command kind.
CommandText | The SQL command text to execute.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FetchOptions | The set of options to control rows fetching.
FixedCommandKind | True, if the CommandKind property value is set explicitly.
FormatOptions | The set of options to control data representation.
Macros | The collection of macro substitution variables.
Overload | Oracle stored procedure overload index.
ParamBindMode | Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.
Params | The collection of parameters for a SQL command.
Prepared | Gets or sets command prepare for execution status.
ResourceOptions | The set of options to control resources usage.
RowsAffected | Returns the number of rows operated upon by the latest query execution.
SchemaName | Identifies schema name for some of command kinds.
SQLText | The SQL command text as it will be sent to the DBMS.
State | Returns the current state of the command object.
Transaction | Specifies the trasaction object.
UpdateOptions | The set of options to control updates posting.
Values | Provides access to the values for all parameters for the command.
Links
TADCustomCommand Class, Legend, Public Events, Public Methods, Public Properties


TADCustomCommand.Active Property

TADCustomCommand.Active Property
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Gets or sets command active status.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

Set Active to True to execute SQL command and return cursor. After that the State = csOpen and you can fetch rows from current cursor using Fetch method. Setting Active to True, will call Open method.

Set Active to False to close current command cursor. After that State = csPrepared. Setting Active to False, will call Close method. To close all command cursors (if command returns multiple result sets), use CloseAll method.

Syntax
property Active: Boolean;
See Also

Fetch, Define, Open, Close, CloseAll, State

Example
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


TADCustomCommand.ActiveStoredUsage Property

TADCustomCommand.ActiveStoredUsage Property
TADCustomCommand Class uADCompClient Unit public Send Feedback

Controls how to use Active property value saved to DFM.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public
Description

The ActiveStoredUsage property controls how to use Active property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADCustomCommand.AfterClose Event

TADCustomCommand.AfterClose Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires after command is closed.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The AfterClose event fires, after command is closed by calling Close or setting Active = False.

Syntax
property AfterClose: TNotifyEvent;
See Also

BeforeClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.AfterExecute Event

TADCustomCommand.AfterExecute Event
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

The event fires after command is executed.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The AfterExecute event fires, after command is executed by calling Execute method.

Syntax
property AfterExecute: TNotifyEvent;
See Also

BeforeExecute, Execute

Example
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


TADCustomCommand.AfterFetch Event

TADCustomCommand.AfterFetch Event
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

The event fires after fetching from command cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The AfterFetch event fires, after rows are fetched from command cursor by calling Fetch method.

Syntax
property AfterFetch: TNotifyEvent;
See Also

BeforeFetch, Fetch

Example
procedure TForm1.ADCommand1AfterFetch(ASender: TObject);
begin
  StatusBar1.SimpleText := Format('%d rows fetched', [ADCommand1.RowsAffected]);
end;


TADCustomCommand.AfterOpen Event

TADCustomCommand.AfterOpen Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires after command is opened.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The AfterOpen event fires, after command is opened by calling Open or setting Active = True.

Syntax
property AfterOpen: TNotifyEvent;
See Also

BeforeOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.AfterPrepare Event

TADCustomCommand.AfterPrepare Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires after command is prepared.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The AfterPrepare event fires, after command is prepared by calling Prepare method.

Syntax
property AfterPrepare: TNotifyEvent;
See Also

BeforePrepare, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.AfterUnprepare Event

TADCustomCommand.AfterUnprepare Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires after command is unprepared.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The AfterUnprepare event fires, after command is unprepared by calling Unprepare method.

Syntax
property AfterUnprepare: TNotifyEvent;
See Also

BeforeUnprepare, Unprepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BaseObjectName Property

TADCustomCommand.BaseObjectName Property
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Identifies base object name for some of command kinds.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The BaseObjectName identifies the name of the base object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs] and DBMS is Oracle, then BaseObjectName specifies the name of the package, if procedure is packaged procedure.
  • If MetaInfoKind in [mkIndexFields, mkPrimaryKeyFields, mkForeignKeyFields], then BaseObjectName specifies the name of the table.
  • If MetaInfoKind in [mkProcs, mkProcArgs], and DBMS is Oracle, then BaseObjectName specifies the name of the package.
Syntax
property BaseObjectName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind

Example
ADCommand1.BaseObjectName := 'MY_PACK';
ADCommand1.CommandText.Text := 'PROC1';
// or just ADCommand1.CommandText.Text := 'MY_PACK.PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Codegear Delphi';
ADCommand1.Execute;


TADCustomCommand.BeforeClose Event

TADCustomCommand.BeforeClose Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before command will be closed.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BeforeClose event fires, before command will be closed by calling Close or setting Active = False.

Syntax
property BeforeClose: TNotifyEvent;
See Also

AfterClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BeforeExecute Event

TADCustomCommand.BeforeExecute Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before command will be executed.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BeforeExecute event fires, before command will be executed by calling Execute method.

Syntax
property BeforeExecute: TNotifyEvent;
See Also

AfterExecute, Execute

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BeforeFetch Event

TADCustomCommand.BeforeFetch Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before fetching from command cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BeforeFetch event fires, before rows will be fetched from command cursor by calling Fetch method.

Syntax
property BeforeFetch: TNotifyEvent;
See Also

AfterFetch, Fetch

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BeforeOpen Event

TADCustomCommand.BeforeOpen Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before command will be opened.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The AfterOpen event fires, before command will be opened by calling Open or setting Active = True.

Syntax
property BeforeOpen: TNotifyEvent;
See Also

AfterOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BeforePrepare Event

TADCustomCommand.BeforePrepare Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before command will be prepared.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BeforePrepare event fires, before command will be prepared by calling Prepare method.

Syntax
property BeforePrepare: TNotifyEvent;
See Also

AfterPrepare, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BeforeUnprepare Event

TADCustomCommand.BeforeUnprepare Event
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The event fires before command will be unprepared.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BeforeUnprepare event fires, before command wille be unprepared by calling Unprepare method.

Syntax
property BeforeUnprepare: TNotifyEvent;
See Also

BeforeUnprepare, Unprepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.BindedBy Property

TADCustomCommand.BindedBy Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Determines how command is connected to connection object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The BindedBy property returns value, determining how command is connected to the connection object:

  • bbObject if Connection property is not nil;
  • bbName is ConnectionName property is not empty.
Syntax
property BindedBy: TADBindedBy;
See Also

Connection, ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.CatalogName Property

TADCustomCommand.CatalogName Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Identifies catalog name for some command kinds.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The CatalogName identifies the name of the catalog where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then CatalogName specifies the name of the catalog, where resides the procedure.
  • If MetaInfoKind is not mkNone, then CatalogName specifies the name of the catalog, where resides the describing object.
Syntax
property CatalogName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADCustomCommand.CommandIntf Property

TADCustomCommand.CommandIntf Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns IADPhysCommand interface.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The CommandIntf property returns the reference to the IADPhysCommand interface. It is not nil, if the command is prepared. Otherwise it is nil. It is not recommended to mix usage of TADCommand API and TADCommand.CommandIntf API.

Syntax
property CommandIntf: IADPhysCommand;
See Also

IADPhysCommand

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.CommandKind Property

TADCustomCommand.CommandKind Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Identifies command kind.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The CommandKind property identifies the kind of the content of CommandText property. You can explicitly set it value before Prepare call, otherwise it will be automatically assigned by AnyDAC after analyzing CommandText content. There is only single need to assign it - when you are preparing stored procedure.

Syntax
property CommandKind: TADPhysCommandKind;
See Also

CommandText

Example 1
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
Example 2
ADCommand1.CommandText.Text := 'ALTER PROCEDURE MY_PROC COMPILE';
case ADCommand1.CommandKind of
skAlter: ShowMessage('Alter command');
..........
else     ShowMessage('Other command');
end;


TADCustomCommand.CommandText Property

TADCustomCommand.CommandText Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 Example 3 public See Also Send Feedback

The SQL command text to execute.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, Example 3, public, See Also
Description

The CommandText set/get:

  • SQL command text to execute
  • or name of the stored procedure to execute, if CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs].

After setting CommandText, AnyDAC will do for non-stored procedures:

  • extract parameters names and fill Params collection, if ResourceOptions.ParamCreate = True;
  • extract macro name and fill Macros collection, if ResourceOptions.MacroCreate = True;
  • extract FROM table name for SELECT commands and assign it to CommandIntf.SourceObjectName, if ResourceOptions.PreprocessCmdText = True;
  • fill CommandKind property value, if it is not explicitly set.

If you are adding long command, using CommandText.Add method, then it is recommended before command modification to call CommandText.BeginUpdate and after finishing command modification to call CommandText.EndUpdate.

Later on Prepare call command text will be preprocessed and transformed in target DBMS command. See chapter Command text preprocessing for details about AnyDAC macros and escape sequences - preprocessor instructions.

Syntax
property CommandText: TStrings;
See Also

TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADResourceOptions.PreprocessCmdText, TADPhysCommandIntf.SourceObjectName, CommandKind, Params, Macros, ResourceOptions

Example 1

Stored procedure:

ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;
Example 2

General SQL command:

ADCommand1.CommandText.Text := 'insert into MyTab values (:p1)';
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;
Example 3

Adding long command:

with ADCommand1.CommandText do begin
  BeginUpdate;
  Add('............');
  ......
  Add('............');
  EndUpdate;
end;


TADCustomCommand.Connection Property

TADCustomCommand.Connection Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Specifies the connection object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The Connection property value points to the connection object. Alternatively may be specified the ConnectionName property value. The Connection property value must be specified before Prepare call.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.ConnectionName Property

TADCustomCommand.ConnectionName Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Specifies connection name.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file or created on fly;
  • ConnectionName of one of the TADConnection objects.

Alternatively may be specified the Connection property value. The ConnectionName property value must be specified before Prepare call. If is specified the name of one of connection definitions, then AnyDAC will transparently create connection object and link it with command.

Syntax
property ConnectionName: String;
See Also

Connection, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.FetchOptions Property

TADCustomCommand.FetchOptions Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The set of options to control rows fetching.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The FetchOptions property is the set of properties, controlling the fetching of cursor rows. These properties will inherit its values from FetchOptions of connection object.

Syntax
property FetchOptions: TADFetchOptions;
See Also

TADFetchOptions, Fetch

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.FixedCommandKind Property

TADCustomCommand.FixedCommandKind Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

True, if the CommandKind property value is set explicitly.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Syntax
property FixedCommandKind: Boolean;
See Also

CommandKind

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.FormatOptions Property

TADCustomCommand.FormatOptions Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The set of options to control data representation.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The FormatOptions property is the set of properties, controlling the data type mapping, and some other aspects of data handling.

Syntax
property FormatOptions: TADFormatOptions;
See Also

TADFormatOptions, Fetch, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.Macros Property

TADCustomCommand.Macros Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

The collection of macro substitution variables.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The Macros property is the collection of macro substitution variables. It is populated automatically after assigning CommandText, if ResourceOptions.MacroCreate = True. Otherwise it may be populated by hands. At Prepare call, macro values will be substituted into CommandText, if ResourceOptions.MacroExpand = True.

Syntax
property Macros: TADMacros;
See Also

CommandText, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand

Example 1

Substitute table name:

ADCommand1.CommandText.Text := 'select * from &Tab';
ADCommand1.Macros[0].AsIdentifier := 'Order Details';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from "Order Details"
Example 2

Substitute WHERE condition:

ADCommand1.CommandText.Text := 'select * from MyTab {if !cond} where !cond {fi}';
ADCommand1.Macros[0].AsString := 'ID > 100';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab where ID > 100
ADCommand1.Macros[0].Clear;
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab


TADCustomCommand.OnCommandChanged Event

TADCustomCommand.OnCommandChanged Event
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

The event fires after CommandText is changed.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The OnCommandChanged event fires, after CommandText is changed.

Syntax
property OnCommandChanged: TNotifyEvent;
See Also

CommandText

Example
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


TADCustomCommand.OnError Event

TADCustomCommand.OnError Event
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

The event fires when an error happens, while command is communicating with DBMS.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
ASender | The reference to command.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when command executes one of the following operations and an error happens:

  • Prepare. The command is preparing DBMS command text for execution.
  • Open. The command is executing DBMS command to open cursor.
  • Execute. The command is executing DBMS command text.
  • Fetch. The command is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use code like in the example.

Syntax
property OnError: TADErrorEvent;
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException

Example 1

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADCustomCommand.Overload Property

TADCustomCommand.Overload Property
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Oracle stored procedure overload index.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The Overload property specifies Oracle packaged stored procedure overload index. It has no meaning for other DBMS's.

Syntax
property Overload: Word;
See Also

CommandText, CommandKind

Example
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


TADCustomCommand.ParamBindMode Property

TADCustomCommand.ParamBindMode Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

Get or set ParamBindMode to determine the order in which parameters in the Params property are matched to the parameters used by the SQL command on the server. ParamBindMode can be one of the following:

Value | Ordering
pbByName | Parameters specified in the Params property are matched to identically named parameters on the server. This is the default.
pbByNumber | Parameters in Params are assigned one-by-one to the next available parameter on the server (for example, the first parameter in Params is assigned to the first parameter used by the SQL command, and so on).

Whenever possible, ParamBindMode should be pbByName. This guarantees that parameters are matched to the correct parameters used by the SQL command regardless of physical ordering in Params. At design time, the names of known parameters appear in the Parameters editor.

Syntax
property ParamBindMode: TADParamBindMode;
See Also

Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.Params Property

TADCustomCommand.Params Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The collection of parameters for a SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The Params property is the collection of parameters for a SQL command.

If CommandKind is not in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then Params is populated automatically after assigning CommandText, if ResourceOptions.ParamCreate = True.

If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then Params is populated automatically after calling Prepare method, if fiMeta is in FetchOption.Items.

Otherwise Params may be populated by hands. At Prepare call, parameters will be binded to prepared SQL command. After that you cannot change parameter types, otherwise will get an exception.

Syntax
property Params: TADParams;
See Also

CommandText, Macros, Prepare, TADParams, TADResourceOptions.ParamCreate, TADFetchOptions.Items


TADCustomCommand.Prepared Property

TADCustomCommand.Prepared Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Gets or sets command prepare for execution status.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

Set Prepared to True to prepare SQL command for execution. After that the State = csPrepared. Setting Prepared to True, will call Prepare method. It is not required to set Prepared to True for standard SQL command before execution, because first Execute / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise an exception will be raised.

After SQL command preparation application cannot change command parameter data types and sizes, otherwise on next Execute or Open call an exception will be raised. So, setup parameters before setting Prepared to True.

Set Prepared to False to unprepare SQL command and release all it resources. After that State = csInactive. Setting Prepared to False, will call Unprepare method.

Syntax
property Prepared: Boolean;
See Also

Prepare, Unprepare, State, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.ResourceOptions Property

TADCustomCommand.ResourceOptions Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The set of options to control resources usage.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The ResourceOptions property is the set of properties, controlling the resources usage by the command. These properties will inherit its values from ResourceOptions of connection object.

Syntax
property ResourceOptions: TADBottomResourceOptions;
See Also

TADBottomResourceOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.RowsAffected Property

TADCustomCommand.RowsAffected Property
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Returns the number of rows operated upon by the latest query execution.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

Inspect RowsAffected to determine how many rows were inserted, updated, deleted or fetched by the last command operation. If no rows were processed, RowsAffected = 0. If numbers of processed rows is not accessible, RowsAffected = –1.

Syntax
property RowsAffected: LongInt;
See Also

Execute, Fetch

Example
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


TADCustomCommand.SchemaName Property

TADCustomCommand.SchemaName Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Identifies schema name for some of command kinds.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The SchemaName identifies the name of the schema where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then SchemaName specifies the name of the schema, where resides the procedure.
  • If MetaInfoKind is not mkNone, then SchemaName specifies the name of the schema, where resides the describing object.
Syntax
property SchemaName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADCustomCommand.SQLText Property

TADCustomCommand.SQLText Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The SQL command text as it will be sent to the DBMS.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The SQLText property returns SQL command text as it will be sent to the DBMS. It is accessible only after command is prepared. This text will not have any of command preprocess instructions (macros, escapes, etc), will have adjusted parameter markers and end-of-line markers.

Syntax
property SQLText: String;
See Also

CommandText, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.State Property

TADCustomCommand.State Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns the current state of the command object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The property State returns the current state of the command object. It has one of the following values:

Value | Description
csInactive | The command is not prepared for execution.
csPrepared | The command is prepared for execution.
csExecuting | The command is executing.
csOpen | The command is executed and it has active cursor.
csFetching | The command is fetching rows.
csAborting | The command is aborting current operation.

csExecuting, csFetching, csAborting values are "visible" if command is executing asynchronously or State property is checked from other thread than performing operation.

Syntax
property State: TADPhysCommandState;
See Also

Prepare, Execute, Open, AbortJob, Fetch, Close, Unprepare


TADCustomCommand.Transaction Property

TADCustomCommand.Transaction Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Specifies the trasaction object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The Transaction property value points to the transaction object. The SQL command will be prepared and executed in the context of this transaction. The Transaction property value must be specified before Prepare call. If a value is not specified, then command will use default transaction object, specified at TADCustomConnection.Transaction or internal connection transaction object.

Notes

At moment only Interbase / Firebird driver supports assignment of transaction to the command.

Syntax
property Transaction: TADCustomTransaction;
See Also

TADTransaction, TADCustomConnection.Transaction


TADCustomCommand.UpdateOptions Property

TADCustomCommand.UpdateOptions Property
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

The set of options to control updates posting.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The UpdateOptions property is the set of properties, controlling the posting of updates. These properties will inherit its values from ResourceOptions of connection object.

Syntax
property UpdateOptions: TADBottomUpdateOptions;
See Also

TADBottomUpdateOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.Values Property

TADCustomCommand.Values Property
TADCustomCommand Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Provides access to the values for all parameters for the command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The property Values gets / sets values for parameters in a command. AParamNames is the single parameter name or ';' separated list of the parameter names to read from or write to.

Values accepts and returns a Variant, so it can handle and convert parameters of any data type. Because Values is the default property for TADCommand, the property name may be omited when referencing this property.

Syntax
property Values [const AParamNames: String]: Variant;
See Also

Params, ParamByName, FindParam, TADParam.Value

Example 1

The following statements are semantically identical and write the value from an edit box into an integer parameter:

ADCommand1.Values['CustNo'] := Edit1.Text;
ADCommand1['CustNo'] := Edit1.Text;
Example 2

The next statement reads a string value from a parameter into an edit box:

Edit1.Text := ADCommand1['Company'];


TADCustomCommand.AbortJob Method

TADCustomCommand.AbortJob Method
TADCustomCommand Class uADCompClient Unit Example public Send Feedback

Use the AbortJob method to abort current command operation.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public
Parameters
Parameters | Description
AWait: Boolean = False | If True, then caller will wait until a current operation will be terminated.
Description

The AbortJob method aborts one of the following command operations:

  • Open. The command is executing DBMS command to open cursor.
  • Execute. The command is executing DBMS command.
  • Fetch. The command is fetching rows from cursor.

After AbortJob call command state will be csPrepared for Open/Execute calls. And csActive for Fetch. The AbortJob method must be called from the other thread, than where a operation is performing.

Notes

Not all DBMS API's support abortion of command execution. In this case the AbortJob method will wait until the execution will be finished.

Syntax
procedure AbortJob(AWait: Boolean = False);
Example
ADCommand1.ResourceOptions.CmdExecMode := amAsync;
ADCommand1.Prepare('select OrderID, count(*) from "Order Details" group by OrderID');
ADCommand1.Open;
ADCommand1.AbortJob(True);


TADCustomCommand.AcquireConnection Method

TADCustomCommand.AcquireConnection Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Acquires reference to the actual connection object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Returns

The connection object. Or raises exception, if Connection and ConnectionName property values are empty.

Description

The AcquireConnection method acquires connection object reference, depending on Connection or ConnectionName property values, and increment it usage count. After usage connection object must be released, by calling ReleaseConnection method. Command object automatically acquires connection at Prepare call and releases connection at Unprepare call.

Syntax
function AcquireConnection: TADCustomConnection;
See Also

ReleaseConnection, Connection, ConnectionName


TADCustomCommand.Close Method

TADCustomCommand.Close Method
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Closes command current cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The Close method closes current command cursor. After that State = csPrepared.

To close all command cursors (if command returns multiple result sets) use CloseAll method. If there is only single result set, then Close is quivalent to CloseAll. After Close call to forward command to next accessible cursor use NextRecordSet method.

The command object will automatically close all command cursors after fetching of last record from current cursor, if FetchOptions.AutoClose = False.

Syntax
procedure Close;
See Also

Open, Active, CloseAll, NextRecordSet, BeforeClose, AfterClose

Example
var
  oTab: TADDatSTable;
....
  ADCommand1.Prepare('select * from "Orders"');
  oTab := ADCommand1.Define;
  try
    ADCommand1.Fetch(oTab);
  finally
    ADCommand1.Close;
    oTab.Free;
  end;


TADCustomCommand.CloseAll Method

TADCustomCommand.CloseAll Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Closes all command cursors.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

The CloseAll method closes all command cursors. After that State = csPrepared.

Syntax
procedure CloseAll;
See Also

Open, Active, Close, NextRecordSet, BeforeClose, AfterClose


TADCustomCommand.Define Method (TADDatSManager, TADDatSTable, TADPhysMetaInfoMergeMode)

TADCustomCommand.Define Method (TADDatSManager, TADDatSTable, TADPhysMetaInfoMergeMode)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Defines DatS manager for command multiple result sets.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ASchema: TADDatSManager | _nt_
ATable: TADDatSTable = nil | _nt_
AMetaInfoMergeMode: TADPhysMetaInfoMergeMode = mmReset | _nt_
Returns

..

Description

..

Syntax
function Define(ASchema: TADDatSManager; ATable: TADDatSTable = nil; AMetaInfoMergeMode: TADPhysMetaInfoMergeMode = mmReset): TADDatSTable; overload;
See Also

..

Example

..


TADCustomCommand.Define Method (TADDatSTable, TADPhysMetaInfoMergeMode)

TADCustomCommand.Define Method (TADDatSTable, TADPhysMetaInfoMergeMode)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Define DatS table structure for command's current cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ATable: TADDatSTable = nil | A reference to the existing DatS table or nil.
AMetaInfoMergeMode: TADPhysMetaInfoMergeMode = mmReset | Defines how to adjust ATable DatS table structure using current result set structure.
Returns

The reference to the existing DatS table.

If ATable was nil, then returned value is new created DatS table. The calling code is responsible for freeing it after usage.

Description

The Define method defines DatS table structure for command's current cursor if command is open or for first cursor if it is closed. Method creates new DatS table, if ATable parameter value is nil. If the SQL command is SELECT and fiMeta in FetchOptions.Items, then Define will request DBMS for primary key fields for table in FROM clause. And method will fill DatS table column list.

Syntax
function Define(ATable: TADDatSTable = nil; AMetaInfoMergeMode: TADPhysMetaInfoMergeMode = mmReset): TADDatSTable; overload;
See Also

TADDatSTable, TADDatSTable.Columns

Example
var
  oTab: TADDatSTable;
....
  ADCommand1.Prepare('select * from MyTab');
  oTab := ADCommand1.Define;
  ADCommand1.Open;
  ADCommand1.Fetch(oTab);
  ADCommand1.Close;

  // Some time later, after the structure of DB table MyTab have changed.
  // For example, field was removed.

  ADCommand1.Prepare('select * from MyTab');
  oTab := ADCommand1.Define(oTab, mmOverride);
  ADCommand1.Open;
  ADCommand1.Fetch(oTab);
  ADCommand1.Close;


TADCustomCommand.Disconnect Method

TADCustomCommand.Disconnect Method
TADCustomCommand Class uADCompClient Unit Example public Send Feedback

Use Disconnect method to release DBMS resources, used by this command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public
Parameters
Parameters | Description
AAbortJob: Boolean = False | If True, then method will abort current operation.
Description

The Disconnect method optionally abort current operation and releases DBMS resources, used by this command. After the call command is in csInactive state.

Syntax
procedure Disconnect(AAbortJob: Boolean = False);
Example
ADCommand1.CommandText.Text := 'select * from [Order Details]';
ADCommand1.Prepare := True;
ADCommand1.Active := True;
ADCommand1.Disconnect;
// Active = False and Prepare = False
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.Execute Method (Integer, Integer)

TADCustomCommand.Execute Method (Integer, Integer)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ATimes: Integer = 0 | A number of times to execute SQL command.
AOffset: Integer = 0 | A index of first row in parameters array, to start execution.
Description

The Execute method executes SQL command, which does not return result sets. If command will return result sets, then all they will be discarded. The command may be executed in one of the modes:

Mode | Parameter values | RowsAffected meaning
Standard or default. The SQL command will be executed single time. | ATimes <= 1 | The number of rows affected by SQL command (inserted, updated, deleted, etc). This information is provided by DBMS and is not "reviewed" by AnyDAC.
Array DML. | ATimes > 1 | The number of successfull command executions for each of parameter array items. For detailed description see chapter Array DML.
Syntax
procedure Execute(ATimes: Integer = 0; AOffset: Integer = 0); overload;
See Also

RowsAffected, SQL, Params

Example
ADCommand1.CommandText.Text := 'create table MyTab (f1 number, f2 varchar2(10))';
ADCommand1.Execute;


TADCustomCommand.Execute Method (String)

TADCustomCommand.Execute Method (String)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | The SQL command text to execute.
Description

The Execute method executes SQL command, which does not return result sets. If command will return result sets, then all they will be discarded.

Syntax
function Execute(const ASQL: String): LongInt; overload;
See Also

RowsAffected, SQL, Params

Example
ADCommand1.Execute('DROP TABLE MyTab');


TADCustomCommand.Execute Method (String, array of Variant)

TADCustomCommand.Execute Method (String, array of Variant)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | The SQL command text to execute.
const AParams: array of Variant | The open array of parameter values. The values will be assigned in order of accurencies in the SQL command text.
Description

The Execute method executes parameterized SQL command, which does not return result sets. If command will return result sets, then all they will be discarded.

Syntax
function Execute(const ASQL: String; const AParams: array of Variant): LongInt; overload;
See Also

RowsAffected, SQL, Params

Example
ADCommand1.Execute('delete from MyTab where id = : id', [100]);


TADCustomCommand.Execute Method (String, array of Variant, array of TFieldType)

TADCustomCommand.Execute Method (String, array of Variant, array of TFieldType)
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | The SQL command text to execute.
const AParams: array of Variant | The open array of parameter values. The values will be assigned in order of occurrences in the SQL command text.
const ATypes: array of TFieldType | The open array of parameter data types.
Description

The Execute method executes parameterized SQL command, which does not return result sets. If command will return result sets, then all they will be discarded. The method requires to specify parameter data types.

Syntax
function Execute(const ASQL: String; const AParams: array of Variant; const ATypes: array of TFieldType): LongInt; overload;
See Also

RowsAffected, SQL, Params

Example
ADCommand1.Execute('insert into MyTab (id, bval) values (:id, :bval)', [100, StringOfChar('x', 100000)], [ftInteger, ftBLOB]);


TADCustomCommand.Fetch Method

TADCustomCommand.Fetch Method
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Fetches rows from current command cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ATable: TADDatSTable | DatS table into which store fetched rows.
AAll: Boolean | If True, then at first Fetch call AnyDAC will fetch all rows from the current cursor.
Description

The Fetch method fetches rows from current command cursor into DatS table. To call Fetch, command must be opened (in csActive state) by Open call, otherwise it will raise exception.

At each call will be fetched up to FetchOptions.RowsetSize rows. If FetchOptions.AutoClose=True, then after fetching of last row AnyDAC will automatically call CloseAll method.

If fiBlobs in FetchOptions.Items, then BLOB field values will be fetched together with other field values. If fiDetails in FetchOptions.Items, then nested dataset will be fetched together with other field values. While fetching, field values will be converted according FormatOptions and stored into DatS rows.

Syntax
procedure Fetch(ATable: TADDatSTable; AAll: Boolean); overload;
See Also

TADFetchOptions, Close, CloseAll, Open, Active

Example
var
  oTab: TADDatSTable;
...
  ADCommand1.CommandKind := skStoredProc;
  ADCommand1.CommandText.Text := 'SEL_CUST_PROC';
  oTab := ADCommand1.Define;
  try
    ADCommand1.Open;
    repeat
      oTab.Clear;
      ADCommand1.Fetch(oTab, False);
      // process next rowset
    until ADCommand1.RowsAffected = 0;
  finally
    oTab.Free;
  end;


TADCustomCommand.FillParams Method

TADCustomCommand.FillParams Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Fills the Params collection.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
AParams: TADParams | The parameters collection to fill in.
const ASQL: String = '' | The SQL command from which to get parameters. If it is empty string, then will be used CommandText.
Description

The FillParams method fills the Params collection, if it is not done automatically in one of the following cases:

  • CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs] and fiMeta is not in FetchOptions.Items;
  • CommandKind is not in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs] and ResourceOptions.CreateParams = False.
Syntax
procedure FillParams(AParams: TADParams; const ASQL: String = '');
See Also

Params, TADFetchOptions.Items, TADResourceOptions.CreateParams


TADCustomCommand.FindMacro Method

TADCustomCommand.FindMacro Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns macro by its name.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | Name of a macro.
Returns

The macro with Name = AValue or nil if such macro does not exists.

Description

The FindMacro method returns a macro from Macros collection by its name AValue. If there is no such macro, then method will return nil.

Syntax
function FindMacro(const AValue: string): TADMacro;
See Also

Macros, MacroByName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.FindParam Method

TADCustomCommand.FindParam Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns parameter by its name.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | Name of a parameter.
Returns

The parameter with Name = AValue or nil if such parameter does not exists.

Description

The FindParam method returns a parameter from Params collection by its name AValue. If there is no such parameter, then method will return nil.

Syntax
function FindParam(const AValue: string): TADParam;
See Also

Params, ParamByName, Values

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.GetConnection Method

TADCustomCommand.GetConnection Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns the connection object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
ACheck: Boolean | If True, and connection object is not found then method will raise the exception.
Description

Returns the connection object using either Connection or ConnectionName properties.

Syntax
function GetConnection(ACheck: Boolean): TADCustomConnection;
See Also

Connection, ConnectionName, AcquireConnection, ReleaseConnection


TADCustomCommand.MacroByName Method

TADCustomCommand.MacroByName Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns macro by its name.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | Name of a macro.
Returns

The macro with Name = AValue.

Description

The MacroByName method returns a macro from Macros collection by its name AValue. If there is no such macro, then exception will be raised.

Syntax
function MacroByName(const AValue: string): TADMacro;
See Also

Macros, FindMacro

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.NextRecordSet Method

TADCustomCommand.NextRecordSet Method
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Go to the next cursor, returned by the SQL command.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Description

The NextRecordSet method closes current cursor, forwards it to the next accessible cursor and opens command. If there is no more accessible cursors, then after call command is closed (State = csPrepared).

The Close method closes current cursor. The CloseAll method discards all assocciated cursors. So, to get all cursors, you should set FetchOptions.AutoClose to False before opening command.

Oracle REF CURSOR's for AnyDAC are also command cursors, and NextRecordSet call will select next PL/SQL REF CURSOR parameter.

In design time, you can forward dataset to the next cursor, by right clicking component and choosing "Next record set" popup menu item.

Syntax
procedure NextRecordSet;
See Also

TADFetchOptions.AutoClose, TADCustomCommand.Open, TADCustomCommand.Close, TADCustomCommand.CloseAll, TADCustomCommand.Fetch

Example
ADCommand1.FetchOptions.AutoClose := False;
ADCommand1.CommandText.Text := 'select 1 as i; select ''qwe'' as s';
ADCommand1.Open;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ShowMessage(oTab.Rows[0].DumpRow(True)); // output "i: 1"
finally
  oTab.Free;
end;
ADCommand1.NextRecordSet;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ShowMessage(oTab.Rows[0].DumpRow(True)); // output "s: qwe"
finally
  oTab.Free;
end;
ADQuery1.CloseAll;


TADCustomCommand.Open Method

TADCustomCommand.Open Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Executes SQL command, returning cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

Call the Open method to execute SQL command and return cursor. After that the State = csOpen and you can fetch rows from current cursor using Fetch method. The Open method will raise an exception, if command does not return cursors.

Syntax
procedure Open;
See Also

Active, Close, CloseAll, State

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.OpenOrExecute Method

TADCustomCommand.OpenOrExecute Method
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Execute SQL command, optionally returning cursor.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Returns

True, if command returned cursor.

Description

Call the OpenOrExecute method to execute SQL command, optionally returning cursor. If the SQL command returns cursor, then after call the State=csActive and you can fetch rows from current cursor using Fetch method. If the SQL command does not return cursors, then the State=csPrepared.

The OpenOrExecute method is usefull, when you does not know a command kind to be executed.

Syntax
function OpenOrExecute: Boolean;
See Also

Execute, Open, Active, Close, CloseAll

Example
if ADCommand1.OpenOrExecute then begin
  oTab := ADCommand1.Define;
  try
    ADCommand1.Fetch(oTab);
  finally
    ADCommand1.CloseAll;
    oTab.Free;
  end;
end;


TADCustomCommand.ParamByName Method

TADCustomCommand.ParamByName Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Returns parameter by its name.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | Name of a parameter.
Returns

The parameter with Name = AValue.

Description

The ParamByName method returns a parameter from Params collection by its name AValue. If there is no such parameter, then exception will be raised.

Syntax
function ParamByName(const AValue: string): TADParam;
See Also

Params, FindParam, Values

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomCommand.Prepare Method

TADCustomCommand.Prepare Method
TADCustomCommand Class uADCompClient Unit Example public See Also Send Feedback

Prepares SQL command for execution.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACommandText: String = '' | Optional SQL command text to prepare.
Description

Call the Prepar method to prepare SQL command for execution. After that the State = csPrepared. It is not required to call Prepare for standard SQL command before execution, because first Execute / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise exception will be raised.

After prepare call application cannot change command parameter data types and sizes, otherwise on next Execute or Open call an exception will be raised. So, setup parameters before Prepare call.

Syntax
procedure Prepare(const ACommandText: String = '');
See Also

Prepared, Unprepare, State, Params

Example
ADCommand1.Prepare('select * from MyTab');


TADCustomCommand.ReleaseConnection Method

TADCustomCommand.ReleaseConnection Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Releases reference to the actual connection object.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
var AConnection: TADCustomConnection | The reference to the connection to release. It must be previously acquired by AcquireConnection call.
Description

The ReleaseConnection method releases connection object reference, and decrement it usage count. Command object automatically releases connection at Unprepare call.

Syntax
procedure ReleaseConnection(var AConnection: TADCustomConnection);
See Also

AcquireConnection, Connection, ConnectionName


TADCustomCommand.Unprepare Method

TADCustomCommand.Unprepare Method
TADCustomCommand Class uADCompClient Unit public See Also Send Feedback

Releases SQL command resources.

Group

public

Links
TADCustomCommand Class, uADCompClient Unit, public, See Also
Description

Use Unprepare call to release prepared SQL command resources. After call the State=csInactive. You can unprepare command by setting Prepared to False.

Syntax
procedure Unprepare;
See Also

Prepare, Prepared

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection Class

TADCustomConnection Class
public Classes See Also Send Feedback

The class is responsible to connection establishment with a DBMS.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomConnection to establish connection to a DBMS and manage associated datasets.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADConnection.

Syntax
TADCustomConnection = class(TCustomConnection, IUnknown, IADStanOptions, IADStanErrorHandler, IADStanObject, IADPhysConnectionRecoverHandler, IADPhysTransactionStateHandler);
See Also

TADConnection, IADPhysConnection

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


public

public
TADCustomConnection Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADCustomConnection class are listed here.

Class

TADCustomConnection Class

Public Events
Name | Description
OnError | Fires before AnyDAC will raise exception.
OnLogin | Fires when an application connects to a DBMS.
OnLosted | Fires after AnyDAC was not able to restore losted connection to DBMS.
OnRecover | Fires after AnyDAC discovered that connection to DBMS is losted.
OnRestored | Fires after AnyDAC successfully restored losted connection to DBMS.
Public Methods
Name | Description
ApplyUpdates | Applies change logs of specified datasets to the DBMS.
CheckActive | Checks to see if the connection is active.
CheckConnectionDef | Checks that connection definition is filled correctly.
CheckInactive | Checks to see if the connection is inactive.
CheckOnline | Checks to see if the connection is in online mode.
CloseClients | Closes all connection associated datasets and commands.
Commit | Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.
CommitRetaining | Permanently stores modifications to the data made in the current transaction, without ending the current transaction.
DecodeObjectName | Splits DB object name into parts.
EncodeObjectName | Assembles DB object name from it parts.
ExecSQL | Executes SQL command without parameters.
ExecSQL | Executes SQL command with parameters.
ExecSQL | Executes SQL command with parameters.
GetFieldNames | Populates a string list with the names of fields in a table.
GetGeneratorNames | Populates a string list with the names of generators / sequences / <how else> in a database.
GetKeyFieldNames | Populates a string list with the names of key fields in a table.
GetLastAutoGenValue | Returns last auto generated value.
GetPackageNames | Populates a string list with the names of Oracle packages in a DB.
GetStoredProcNames | Populates a string list with the names of stored procedures in a DB.
GetTableNames | Populates a string list with the names of tables in a DB.
Offline | Sets connection to offline mode.
Online | Sets connection to online mode.
Ping | Pings the DBMS server.
RefreshMetadataCache | Invalidates meta data cache.
Rollback | Cancels all modifications to the data made in the current transaction and optionally ends transaction.
RollbackRetaining | Cancels all modifications to the data made in the current transaction, without ending the current transaction.
StartTransaction | Starts new transaction at database.
Public Properties
Name | Description
CliHandle | CLI handle for connection sharing.
CliObj | CLI connection wrapping object.
CommandCount | The number of assocciated TADCustomCommand objects.
Commands | Returns assocciated TADCustomCommand objects.
Connected | Gets / sets connection active status.
ConnectedStoredUsage | Controls how to use Connected property value saved to DFM.
ConnectionDefName | The name of connection definition to use.
ConnectionIntf | Returns IADPhysConnection interface.
ConnectionName | Specifies the name of the connection to associate with this connection object.
DataSets | Returns assocciated TADDataSet objects.
DriverName | Specifies the ID of the AnyDAC driver for the connection.
FetchOptions | The set of default options to control rows fetching.
FormatOptions | The set of default options to control data representation.
InTransaction | Indicates whether a connection transaction is in progress or not.
IsSQLBased | Property returns True, if datasource supports SQL language.
LastUsed | The date and time of last usage of the connection.
LoginDialog | Gets / sets the reference to login dialog interface.
LoginPrompt | Specifies whether a login dialog appears immediately before opening a new connection.
Offlined | Gets / sets connection offline status.
OptionsIntf | The reference to IADStanOptions interface.
Params | Lists database connection parameters for the AnyDAC connection definition associated with the connection object.
RDBMSKind | Returns the brand of DBMS currently connected.
RefCount |
ResourceOptions | The set of default options to control resources usage.
ResultConnectionDef | The actual connection definition used to establish connection to a DBMS.
SharedCliHandle | CLI handle shared with other connection.
Temporary | Shows whether a connection object is created on fly (temporary one) and managed automatically or a persistent one explicitly created, managed, and freed by the application.
Transaction | The reference to TADCustomTransaction object.
TxOptions | The set of options to control transactions.
UpdateOptions | The set of default options to control data updating.
UpdateTransaction | The reference to TADCustomTransaction object, which will be used to post changes to DB.
Links
TADCustomConnection Class, Legend, Public Events, Public Methods, Public Properties


TADCustomConnection.CliHandle Property

TADCustomConnection.CliHandle Property
TADCustomConnection Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

CLI handle for connection sharing.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The CliHandle property returns DBMS Call Level Interface connection handle. Then this value may be assigned to another TADCustomConnection object SharedCliHandle property.

After setting Connected=True for that object, both connection objects will share the same physical DBMS connection. This connection must be closed after all other connections, sharing the same CLI handle.

This is useful to transfer connection from application into DLL.

Syntax
property CliHandle: Pointer;
See Also

SharedCliHandle, Connected

Example 1

See demo application AnyDAC\Samples\Comp Layer\TADConnection\DLL_Sharing.

Example 2

Application code (without checks):

  FhDll := LoadLibrary(PChar('Project2.dll'));
  @FpShowData := GetProcAddress(FhDll, PChar('ShowData'));
  FpShowData(ADConnection1.CliHandle);

DLL code:

procedure ShowData(ACliHandle: LongWord);
begin
  ADConnection1.SharedCliHandle := ACliHandle;
  ADConnection1.Connected := True;
  ADQuery1.Active := True;
end;


TADCustomConnection.CliObj Property

TADCustomConnection.CliObj Property
TADCustomConnection Class uADCompClient Unit public Send Feedback

CLI connection wrapping object.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

The CliObj property returns DBMS Call Level Interface connection wrapping object. The class of the object depends on AnyDAC driver. Following table lists drivers and connection wrapping classes. The wrapping object may be usefull for performing low-level operations with DBMS Call Level Interface.

Driver | Wrapping class
Oracle | TOCIService, uADPhysOraclWrapper.pas
Interbase / Firebird | TIBDatabase, uADPhysIBWrapper.pas
MySQL | TMySQLSession, uADPhysMySQLWrapper.pas
MS SQL Server, MS Access, IBM DB2, Sybase SQL Anywhere, ODBC | TODBCConnection, uADPhysODBCWrapper.pas
dbExpress | ISQLConnection
TDBX | TDBXConnection
Syntax
property CliObj: Pointer;


TADCustomConnection.CommandCount Property

TADCustomConnection.CommandCount Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

The number of assocciated TADCustomCommand objects.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The CommandCount property returns the number of prepared (State <> csInactive) TADCustomCommand objects, assocciated with this connection object.

Syntax
property CommandCount: Integer;
See Also

Commands, TADCustomCommand

Example
var
  i: Integer;
...
  for i := ADConnection1.CommandCount - 1 downto 0 do
    ADConnection1.Commands[i].Disconnect(True);


TADCustomConnection.Commands Property

TADCustomConnection.Commands Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Returns assocciated TADCustomCommand objects.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The Commands indexed property returns a prepared (State <> csInactive) TADCustomCommand object, assocciated with this connection object, by it index.

Syntax
property Commands [AIndex: Integer]: TADCustomCommand;
See Also

CommandCount, TADCustomCommand

Example
var
  i: Integer;
...
  for i := ADConnection1.CommandCount - 1 downto 0 do
    ADConnection1.Commands[i].Disconnect(True);


TADCustomConnection.Connected Property

TADCustomConnection.Connected Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Gets / sets connection active status.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Set Connected to true to establish a connection to an DBMS. Set Connected to false to close a connection. The default value for Connected is false.

An application can check Connected to determine the current status of a connection. If Connected is true, the connection is active; if false, and the KeepConnection property is also false, then the connection is inactive.

To open connection, it must be setup in one of the following ways:

  1. set ConnectionDefName to the name of one of a existing connection definitions and optionally override connection definition parameters in Params;
  2. set DriverName to the name of one of a registered drivers (or add DriverID into Params) and specifiy connection definition parameters in Params.

If connection definition is pooled (Pooled=True), then use (1) and does not override any of parameters, otherwise you will get an exception.

Setting Connected to False will disconnect (close and unprepare) all associated commands and datasets. If you just need to disconnect from DBMS, but does not close objects, then use Offlined property.

Syntax
property Connected: Boolean;
See Also

TCustomConnection.BeforeConnect, TCustomConnection.AfterConnect, TCustomConnection.BeforeDisconnect, TCustomConnection.AfterDisconnect, ConnectionDefName, DriverName, Params, Offlined

Example
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


TADCustomConnection.ConnectedStoredUsage Property

TADCustomConnection.ConnectedStoredUsage Property
TADCustomConnection Class uADCompClient Unit public Send Feedback

Controls how to use Connected property value saved to DFM.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

The ConnectedStoredUsage property controls how to use Connected property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ConnectedStoredUsage: TADStoredActivationUsage;


TADCustomConnection.ConnectionDefName Property

TADCustomConnection.ConnectionDefName Property
TADCustomConnection Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

The name of connection definition to use.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The ConnectionDefName property specifies the name of one of a existing connection definitions. It must be stored in ADConnectionDefs.ini or created dynamically.

Notes

Attempting to set ConnectionDefName when the Connected property is true raises an exception.

Syntax
property ConnectionDefName: string;
See Also

TADCustomManager

Example 1
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;
Example 2

See demo AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs for details how to create and use connection definitions.


TADCustomConnection.ConnectionIntf Property

TADCustomConnection.ConnectionIntf Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Returns IADPhysConnection interface.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The ConnectionIntf property returns the reference to the IADPhysConnection interface. It is not nil, if the connection is established. Otherwise it is nil. It is not recommended to mix usage of TADCustomConnection API and TADCustomConnection.ConnectionIntf API.

Syntax
property ConnectionIntf: IADPhysConnection;
See Also

IADPhysConnection

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.ConnectionName Property

TADCustomConnection.ConnectionName Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Specifies the name of the connection to associate with this connection object.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Use ConnectionName to specify the name of the connection to use with a connection object. If ConnectionName is the same as an existing connection definition, then the ConnectionDefName and DriverName properties need not be set. If ConnectionName does not match an existing connection definition, then either the application must also supply a valid connection definition in the ConnectionDefName property in addition to the or it must supply the DriverName and Params properties.

You can specifiy as ConnectionName for TADCustomCommand or TADRDBMSDataSet component and its descendants (TADQuery, TADStoredProc, TADTable), the ConnectionName of one of the existing TADConnection objects or the name of one of the existing connection definitions.

Notes
  1. Attempting to set ConnectionName when the Connected property is true raises an exception.
  2. At design time double-click a TConnection component to invoke the Database editor and set the ConnectionName.
Syntax
property ConnectionName: String;
See Also

ConnectionDefName, DriverName, Params, TADCustomCommand.ConnectionName, TADRDBMSDataSet.ConnectionName

Example
ADConnection1.ConnectionName := 'TestConn';
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.ConnectionName := 'TestConn';
ADQuery1.Open('select * from test_tab');


TADCustomConnection.DataSets Property

TADCustomConnection.DataSets Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Returns assocciated TADDataSet objects.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The DataSets indexed property returns a prepared (State <> csInactive) TADRdbmsDataSet objects, assocciated with this connection object, by it index.

Syntax
property DataSets [AIndex: Integer]: TADDataSet;
See Also

DataSetCount, TADRdbmsDataSet

Example
var
  i: Integer;
...
  for i := ADConnection1.DataSetCount - 1 downto 0 do
    ADConnection1.DataSets[i].Disconnect(True);


TADCustomConnection.DriverName Property

TADCustomConnection.DriverName Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Specifies the ID of the AnyDAC driver for the connection.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Use DriverName to specify the ID of the AnyDAC driver to use for connection that do not specify an ConnectionDefName. DriverName must be a valid AnyDAC registered driver ID.

If an application sets DriverName, it must also specify connection parameters in the Params property. Ordinarily the alias specified in the ConnectionDefName property supplies connection parameters, but when DriverName is set, the ConnectionDefName property is automatically cleared to avoid AnyDAC driver ID contention.

Attempting to set DriverName when the Connected property is True raises an exception.

Setting DriverName value, will add DriverID=<xxx> parameter to the Params list.

Notes

At design time double-click a TConnection component to invoke the Connection editor and set the DriverName.

Or choose DriverName value in property inspector from drop-down list.

Syntax
property DriverName: string;
See Also

Params, ConnectionDefName

Example
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.Connection := ADConnection1;
ADQuery1.Open('select * from test_tab');


TADCustomConnection.FetchOptions Property

TADCustomConnection.FetchOptions Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The set of default options to control rows fetching.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The FetchOptions property is the set of default properties, controlling the fetching of cursor rows. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from FetchOptions of ADManager object.

Syntax
property FetchOptions: TADFetchOptions;
See Also

TADFetchOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.FormatOptions Property

TADCustomConnection.FormatOptions Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The set of default options to control data representation.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The FormatOptions property is the set of the default properties, controlling the data type mapping, and some other aspects of data handling. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from FormatOptions of ADManager object.

Syntax
property FormatOptions: TADFormatOptions;
See Also

TADFormatOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.InTransaction Property

TADCustomConnection.InTransaction Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Indicates whether a connection transaction is in progress or not.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Examine InTransaction at run-time to determine if a connection transaction is currently in progress. InTransaction is True if a transaction is in progress, False otherwise.

The value of InTransaction cannot be changed directly. Calling StartTransaction sets InTransaction to True. Calling Commit or Rollback sets InTransaction to False.

InTransaction is the shortcut for ConnectionIntf.Transaction.IsActive or Transaction.IsActive.

Syntax
property InTransaction: Boolean;
See Also

StartTransaction, Commit, Rollback, TADTransaction


TADCustomConnection.IsSQLBased Property

TADCustomConnection.IsSQLBased Property
TADCustomConnection Class uADCompClient Unit public Send Feedback

Property returns True, if datasource supports SQL language.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

Property returns True, if datasource supports SQL language. Actually, the property were introduced for BDE compatibility. All AnyDAC drivers support SQL language, so IsSQLBased is always True.

Syntax
property IsSQLBased: Boolean;


TADCustomConnection.LastUsed Property

TADCustomConnection.LastUsed Property
TADCustomConnection Class uADCompClient Unit public Send Feedback

The date and time of last usage of the connection.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

The LastUsed property returns the date and time of the last activity on this connection.

Syntax
property LastUsed: TDateTime;


TADCustomConnection.LoginDialog Property

TADCustomConnection.LoginDialog Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Gets / sets the reference to login dialog interface.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The LoginDialog property allows to associate the interface of the login dialog with this connection. The standard login dialog interface implementation is TADGUIxFormsLoginDialog component. The interface assigned to the LoginDialog will be used only by this connection object.

If the LoginDialog property is not assigned, but unit uADGUIxFormsfLogin is linked into application, then connection object will use default internal loging dialog instance.

The login dialog will popup at connecting to a DBMS only if all of the following conditions are met:

  • LoginPrompt=True;
  • connection definition is not pooled (Pooled=False);
  • global silent flag is not set to True (ADGUIxSilent() = False);
  • connection object does not use shared CLI handle (SharedCliHandle = nil).
Syntax
property LoginDialog: IADGUIxLoginDialog;
See Also

TADGUIxFormsLoginDialog, LoginPrompt, SharedCliHandle, ADGUIxSilent

Example

Using private login dialog

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


TADCustomConnection.LoginPrompt Property

TADCustomConnection.LoginPrompt Property
TADCustomConnection Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Specifies whether a login dialog appears immediately before opening a new connection.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

Set LoginPrompt to True to provide login support when establishing a connection. When LoginPrompt is True, a dialog appears to prompt users for a name, password and other optional parameters. The dialog appears after the BeforeConnect event and before the AfterConnect event, unless you supply an OnLogin event handler. If there is an OnLogin event handler, that event occurs in place of the login dialog. If correct values for the user name, password and other optional parameters are not supplied in the dialog or by the OnLogin event handler, the connection fails. This OnLogin event does not fire unless LoginPrompt is set to True.

When LoginPrompt is False, the application must supply user name, password and other optional parameter values programmatically. For that application can specify User_name, Password, etc parameters in Params.

The login dialog will popup at connecting to a DBMS only if all of the following conditions are met:

  • LoginPrompt=True;
  • connection definition is not pooled (Pooled=False);
  • global silent flag is not set to True (ADGUIxSilent() = False);
  • connection object does not use shared CLI handle (SharedCliHandle = nil).
Syntax
property LoginPrompt;
See Also

OnLogin, LoginDialog, Params, SharedCliHandle, ADGUIxSilent

Example 1

Using login dialog:

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;
Example 2

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := 'sql';
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


TADCustomConnection.Offlined Property

TADCustomConnection.Offlined Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Gets / sets connection offline status.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Set Offlined to True to switch connection and associated with it commands and datasets to the offline mode. In offline mode connection to DBMS is closed, but datasets remain open.

If dataset, associated with this connection object is active and not all records are fetched from DBMS cursor, then if ResourceOptions.AutoDisconnect=True, the dataset will fetch all records from cursor and will go to offline mode. If ResourceOptions.AutoDisconnect=False, then the dataset will raise an exception. By default AutoDisconnect=True.

If application will try to perform on a command or a dataset objects any operation requiring DBMS connection, then if ResourceOptions.AutoOnline=True, the connection will automatically estabslish connection to DBMS. If ResourceOptions.AutoOnline=False, then connection object will raise an exception. By default AutoOnline=True.

Set Offlined to False to establish connection with DBMS and switch to online mode.

Syntax
property Offlined: Boolean;
See Also

TADTopResourceOptions.AutoOnline, TADResourceOptions.AutoDisconnect, Connected, Offline, Online


TADCustomConnection.OnError Event

TADCustomConnection.OnError Event
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Fires before AnyDAC will raise exception.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
ASender | This connection object.
AInitiator | The interface of the object initially discovered error.
AException | The exception object to be raised.
Description

The OnError event handler fires before AnyDAC will raise exception inside of call of one of the connection or assocciated commands or datasets methods. In most cases AException will be of EADDBEngineException class.

The event handler can replace AException object with some other custom exception. In this case original object must be freed.

Syntax
property OnError: TADErrorEvent;
See Also

EADDBEngineException

Example
procedure TForm1.ADConnection1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if (AException is EADDBEngineException) and (EADDBEngineException(AException).Kind = ekUKViolated) then begin
    AException.Free;
    AException := Exception.Create('You must enter unique document number !');
  end;
end;


TADCustomConnection.OnLogin Event

TADCustomConnection.OnLogin Event
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Fires when an application connects to a DBMS.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Write an OnLogin event handler to take specific actions when an application attempts to connect to a DBMS. When the LoginPrompt property is True, a database login is required. The login dialog and OnLogin event only occur when the LoginPrompt property is true.

If there is no OnLogin event handler, the current UserName is read from the Params property or connection definition, and a standard Login dialog box opens. The dialog prompts for a user name, password and other optional parameters, and then uses the values entered by the user to set the UserName, Password and other optional values in the Params property. These values are then passed to the DBMS.

Applications that provide alternative OnLogin event handlers may set the UserName, Password and other optional values in AConnectionDef. AConnectionDef is a temporary connection definition and is freed automatically when no longer needed.

Syntax
property OnLogin: TADConnectionLoginEvent;
See Also

LoginPrompt, Connected, IADStanConnectionDef

Example

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := InputBox('Login', 'Please enter DBA password', 'sql');
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


TADCustomConnection.OnLosted Event

TADCustomConnection.OnLosted Event
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Fires after AnyDAC was not able to restore losted connection to DBMS.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The OnLosted event fires after AnyDAC was not able to automatically restore connection to the DBMS, after discovering that it is losted.

Syntax
property OnLosted: TNotifyEvent;
See Also

OnRecover, OnRestored

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.OnRecover Event

TADCustomConnection.OnRecover Event
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Fires after AnyDAC discovered that connection to DBMS is losted.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
ASender | This connection object.
AInitiator | The interface of the object initially discovered error.
AException | The exception object describing losted connection issue.
AAction | The action AnyDAC should take after return from event handler.
Description

The OnRecover event fires after AnyDAC discovered that connection to DBMs is losted. The event handler can analyze the reason, ask user how to proceed, show some status and returns the action, AnyDAC should take:

Action | Description
faDefault | If TADTopResourceOptions.AutoConnRestore=True, then AnyDAC will try to reconnect, otherwise will raise an exception, that connection is losted. By default TADTopResourceOptions.AutoConnRestore=False.
faFail | Close connection and raise an exception, that connection is losted.
faRetry | Try to reconnect.
faCloseAbort | Close connection and abort current operation.
faOfflineAbort | Switch connection to the offline mode and abort current operation.

If event handler is not assigned, then AnyDAC will take default (faDefault) action. If after 3 trials connection cannot be restored, then AnyDAC will close connection and raise an exception, that connection is losted.

Syntax
property OnRecover: TADConnectionRecoverEvent;
See Also

OnLosted, OnRestored, TADTopResourceOptions.AutoConnRestore, Connected, Offlined


TADCustomConnection.OnRestored Event

TADCustomConnection.OnRestored Event
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Fires after AnyDAC successfully restored losted connection to DBMS.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The OnRestored event fires after AnyDAC successfully restored connection to the DBMS, after discovering that it is losted.

Syntax
property OnRestored: TNotifyEvent;
See Also

OnLosted, OnRecover

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.OptionsIntf Property

TADCustomConnection.OptionsIntf Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The reference to IADStanOptions interface.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The OptionsIntf returns reference to the IADStanOptions interface, implemented by this connection.

Syntax
property OptionsIntf: IADStanOptions;
See Also

IADStanOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.Params Property

TADCustomConnection.Params Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Lists database connection parameters for the AnyDAC connection definition associated with the connection object.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Use Params to list DBMS connection definition parameters, such server name, port, database, client character set, user name and password. The possible set of parameters depends on the DBMS kind to connect to.

Params is a list of string items, each representing a different DBMS connection definition parameter. If the ConnectionDefName property specifies a valid AnyDAC connection definition, then parameters, specified in Params, will override corresponsding connection definition parameters. If an application need to specify connection definition parameter on-fly, then an application must fill-in all required connection definition parameter into Params.

At design time double-click a TConnection component to invoke the Connection editor and set Params.

Syntax
property Params: TStrings;
See Also

ConnectionDefName, DriverName, OnLogin

Example
with ADConnection1.Params do begin
  Clear;
  Add('DriverID=Ora');
  Add('Database=ORA_920_APP');
  Add('User_Name=ADDemo');
  Add('Password=a');
end;
ADConnection1.Connected := True;


TADCustomConnection.RDBMSKind Property

TADCustomConnection.RDBMSKind Property
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Returns the brand of DBMS currently connected.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The RDBMSKind property returns the brand of the DBMS, to which connection object is currently connected. If connection is not active, then property returns mkUnknown.

Syntax
property RDBMSKind: TADRDBMSKind;
See Also

TADRDBMSKind, Connected

Example
case ADConnection1.RDBMSKind of
mkOracle:    s := 'select mySeq.NextVal from dual';
mkInterbase: s := 'select gen_id(myGen, 1) from rdb$database';
else         Exit;
end;
ADQuery1.Open(s);


TADCustomConnection.RefCount Property

TADCustomConnection.RefCount Property
TADCustomConnection Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Syntax
property RefCount: Integer;


TADCustomConnection.ResourceOptions Property

TADCustomConnection.ResourceOptions Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The set of default options to control resources usage.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The ResourceOptions property is the set of the default properties, controlling the resources usage by the command. These properties will be inherited by commands and datasets, accossiated with this connection. Also these properties will inherit its values from ResourceOptions of ADManager object.

Syntax
property ResourceOptions: TADTopResourceOptions;
See Also

TADTopResourceOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.ResultConnectionDef Property

TADCustomConnection.ResultConnectionDef Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The actual connection definition used to establish connection to a DBMS.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The ResultConnectionDef property returns reference to the resulting connection definition used by connection object. It represents original connection definition specified by ConnectionDefName (if it is specified), overriden by Params connection parameters.

Syntax
property ResultConnectionDef: IADStanConnectionDef;
See Also

ConnectionDefName, Params, DriverName, IADStanConnectionDef


TADCustomConnection.SharedCliHandle Property

TADCustomConnection.SharedCliHandle Property
TADCustomConnection Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

CLI handle shared with other connection.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

Use SharedCliHandle, to set shared DBMS Call Level Interface connection handle, returned by other connection CliHandle property.

After setting Connected=True for this connection, it will use the same physical DBMS connection / session as other connection.

After setting Connected=False, this connection object will not release connection resources to the DBMC client. The other connection is responsible for resources releasing. Because that the other connection must be closed after closing all of sharing connection objects.

This is useful to transfer connection from application into DLL.

Syntax
property SharedCliHandle: Pointer;
See Also

CliHandle, Connected

Example 1

See demo application AnyDAC\Samples\Comp Layer\TADConnection\DLL_Sharing.

Example 2

Application code (without checks):

  FhDll := LoadLibrary(PChar('Project2.dll'));
  @FpShowData := GetProcAddress(FhDll, PChar('ShowData'));
  FpShowData(ADConnection1.CliHandle);

DLL code:

procedure ShowData(ACliHandle: LongWord);
begin
  ADConnection1.SharedCliHandle := ACliHandle;
  ADConnection1.Connected := True;
  ADQuery1.Active := True;
end;


TADCustomConnection.Temporary Property

TADCustomConnection.Temporary Property
TADCustomConnection Class uADCompClient Unit Example public Send Feedback

Shows whether a connection object is created on fly (temporary one) and managed automatically or a persistent one explicitly created, managed, and freed by the application.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public
Description

Use Temporary property to determine if a connection component is created on fly (temporary one) and managed automatically - True, or a persistent one explicitly created, managed, and freed by the application - False.

A temporary connection object is created when a dataset / command has set ConnectionName to the name of the existing connection definition and needs real connection object to communicate with DBMS. That happens at Prepare / Open / Execute / ExecSQL / ExecProc calls.

A temporary connection object is freed when the dataset / command is unprepared. An application can keep temporary connection object for later reusing by setting Temporary to False. After that the application is then responsible for closing the connection when it is no longer needed.

Syntax
property Temporary: Boolean;
Example
var
  oConn: TADconnection;
...
ADQuery1.ConnectionName := 'Access_Demo';
ADQuery1.Open;
...
oConn := ADManager.FindConnection('Access_Demo');
// here oConn.Temporary = True. The oConn will bedestroyed after disconnecting of ADQuery1
oConn.Temporary := False;
...
ADQuery1.Disconnect;
// here oConn is alive due to setting of oConn.Temporary to False


TADCustomConnection.Transaction Property

TADCustomConnection.Transaction Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The reference to TADCustomTransaction object.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The Transaction property get/set reference to the transaction object, which will be default one for the connection and all associated datasets and commands without explicitly assigned Transaction property. At moment, this behaviour has the meaning only for Interbase / Firebird connection.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomTransaction

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.TxOptions Property

TADCustomConnection.TxOptions Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The set of options to control transactions.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The TxOptions property is the set of the properties, controlling the transactions in this connection. If you set Transaction property, then application should use Transaction.Options, instead of TxOptions.

Syntax
property TxOptions: TADTxOptions;
See Also

Transaction, TADTxOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.UpdateOptions Property

TADCustomConnection.UpdateOptions Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The set of default options to control data updating.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The UpdateOptions property is the set of the default properties, controlling the data updating by the datasets. These properties will be inherited by datasets, associated with this connection. Also these properties will inherit its values from UpdateOptions of ADManager object.

Syntax
property UpdateOptions: TADUpdateOptions;
See Also

TADUpdateOptions

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.UpdateTransaction Property

TADCustomConnection.UpdateTransaction Property
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

The reference to TADCustomTransaction object, which will be used to post changes to DB.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

The UpdateTransaction property get/set reference to the transaction object, which will be default one for all associated datasets without explicitly assigned UpdateTransaction property. This transaction will be used by datasets to post changes to the DB.

If UpdateTransaction is not assigned, but Transaction is assigned, then Transaction object will be used as update transaction.

At moment, this behaviour has the meaning only for Interbase / Firebird connection.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomTransaction

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.ApplyUpdates Method

TADCustomConnection.ApplyUpdates Method
TADCustomConnection Class uADCompClient Unit public Send Feedback

Applies change logs of specified datasets to the DBMS.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Parameters
Parameters | Description
const ADataSets: array of TADDataSet | A open array, containing a list of datasets to post pending updates.
Description

Call ApplyUpdates to apply change logs for specified active datasets to the database. ApplyUpdates is only meaningful if the CachedUpdates property is True for specified datasets.

ADataSets is an open array of datasets. For each specified dataset this method calls the dataset’s ApplyUpdates and CommitUpdates methods to apply that dataset’s change log to database.

Syntax
procedure ApplyUpdates(const ADataSets: array of TADDataSet);


TADCustomConnection.CheckActive Method

TADCustomConnection.CheckActive Method
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Checks to see if the connection is active.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Call CheckActive to assert that the connection to a DBMS is active. If the connection is inactive, then if ResourceOptions.AutoConnect=True, then connection object will automatically connect to the DBMS, otherwise an exception is raised.

Syntax
procedure CheckActive;
See Also

TADTopResourceOptions.AutoConnect, Connected


TADCustomConnection.CheckConnectionDef Method

TADCustomConnection.CheckConnectionDef Method
TADCustomConnection Class uADCompClient Unit public Send Feedback

Checks that connection definition is filled correctly.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

Checks that connection definition is filled correctly with minimal set of required parameters for current environment. The method is mostly usefull for tools or applications, creating the connection definitions of fly.

Syntax
procedure CheckConnectionDef; virtual;


TADCustomConnection.CheckInactive Method

TADCustomConnection.CheckInactive Method
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Checks to see if the connection is inactive.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Call CheckInactive to assert that the connection to a DBMS is inactive. If the connection is active, then if ResourceOptions.AutoConnect=True, then connection object will automatically disconnect from the DBMS, otherwise an exception is raised.

Syntax
procedure CheckInactive;
See Also

TADTopResourceOptions.AutoConnect, Connected


TADCustomConnection.CheckOnline Method

TADCustomConnection.CheckOnline Method
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Checks to see if the connection is in online mode.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Call CheckOnline to assert that the connection to a DBMS is in online mode. If the connection is offlined, then if ResourceOptions.AutoOnline=True, then connection object will automatically go to the online mode, otherwise an exception is raised.

Syntax
procedure CheckOnline;
See Also

TADTopResourceOptions.AutoOnline, Offlined


TADCustomConnection.CloseClients Method

TADCustomConnection.CloseClients Method
TADCustomConnection Class uADCompClient Unit public Send Feedback

Closes all connection associated datasets and commands.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public
Description

The CloseClients method disconnects (closes and unprepares) all datasets and commands associated with this connection object.

Syntax
procedure CloseClients;


TADCustomConnection.Commit Method

TADCustomConnection.Commit Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Call Commit to permanently store modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

The Commit call is the shortcut to Transaction.Commit, if Transaction property is assigned. Otherwise Commit will operate on default connection transaction.

Before calling Commit, an application may check the status of the InTransaction property. If an application calls Commit and there is no current transaction, an exception is raised.

Commit call on Interbase / Firebird will close and unprepare all datasets and commands, associated with this transaction object.

Syntax
procedure Commit;
See Also

StartTransaction, InTransaction, Rollback, CommitRetaining

Example
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.Commit;
    end;
  except
    ADConnection1.Rollback;
    raise;
  end;
end;


TADCustomConnection.CommitRetaining Method

TADCustomConnection.CommitRetaining Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Permanently stores modifications to the data made in the current transaction, without ending the current transaction.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Call CommitRetaining to permanently store modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database without finishing transaction.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints. CommitRetaining is usefull only for main transaction, not for nested ones.

The CommitRetaining call is the shortcut to Transaction.CommitRetaining, if Transaction property is assigned. Otherwise CommitRetaining will operate on default connection transaction.

Before calling CommitRetaining, an application may check the status of the InTransaction property. If an application calls CommitRetaining and there is no current transaction, an exception is raised.

CommitRetaining will use native functionality on IB/FB. On other DBMS's the method will be equal to calls of Commit, then of StartTransaction.

Syntax
procedure CommitRetaining;
See Also

StartTransaction, InTransaction, Rollback, Commit

Example
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.CommitRetaining;
    end;
  except
    ADConnection1.RollbackRetaining;
    raise;
  end;
end;


TADCustomConnection.DecodeObjectName Method

TADCustomConnection.DecodeObjectName Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Splits DB object name into parts.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AFullName: String | A full DB object name to parse.
var ACatalogName: String | A catalog name specified in a object name.
var ASchemaName: String | A schema name specified in a object name.
var ABaseObjectName: String | A base object name specified in a object name, like a package name in Oracle.
var AObjectName: String | A object name specified in a full object name.
Description

The DecodeObjectName method parses DB object name into parts, using the current DBMS rules.

Syntax
procedure DecodeObjectName(const AFullName: String; var ACatalogName: String; var ASchemaName: String; var ABaseObjectName: String; var AObjectName: String);
See Also

EncodeObjectName

Example

On Oracle:

var
  sCatalog, sSchema, sBaseObj, sObj: String;
...
  ADConnection1.DecodeObjectName('ADDemo."MyPack".Proc1', sCatalog, sSchema, sBaseObj, sObj);
  // sCatalog -> ''
  // sSchema -> ADDEMO
  // sBaseObj -> MyPack
  // sObj -> PROC1
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomConnection.EncodeObjectName Method

TADCustomConnection.EncodeObjectName Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Assembles DB object name from it parts.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: String | A catalog name part.
const ASchemaName: String | A schema name part.
const ABaseObjectName: String | A base object name part, like a package name in Oracle.
const AObjectName: String | A object name.
Returns

A full object name, assembled from specified name parts.

Description

The EncodeObjectName method assembles DB object name from it parts, using the current DBMS rules.

Syntax
function EncodeObjectName(const ACatalogName: String; const ASchemaName: String; const ABaseObjectName: String; const AObjectName: String): String;
See Also

DecodeObjectName

Example

On Oracle:

ShowMessage(ADConnection1.EncodeObjectName('', 'ADDEMO', 'MyPack', 'PROC1')); // -> ADDEMO."MyPack".PROC1


TADCustomConnection.ExecSQL Method (String)

TADCustomConnection.ExecSQL Method (String)
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command without parameters.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
Returns

The number of affected rows.

Description

The ExecSQL method executes SQL command without parameters. All returned cursors will be discarded.

Syntax
function ExecSQL(const ASQL: String): LongInt; overload;
See Also

TADQuery

Example
ADConnection1.ExecSQL('truncate table tab1');


TADCustomConnection.ExecSQL Method (String, array of Variant)

TADCustomConnection.ExecSQL Method (String, array of Variant)
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command with parameters.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
const AParams: array of Variant | An open array of parameter values.
Returns

The number of affected rows.

Description

The ExecSQL method executes SQL command with parameters. All returned cursors will be discarded.

Syntax
function ExecSQL(const ASQL: String; const AParams: array of Variant): LongInt; overload;
See Also

TADQuery

Example
ADConnection1.ExecSQL('delete from mytab where id > :p1', [1000]);


TADCustomConnection.ExecSQL Method (String, array of Variant, array of TFieldType)

TADCustomConnection.ExecSQL Method (String, array of Variant, array of TFieldType)
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Executes SQL command with parameters.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
const AParams: array of Variant | An open array of parameter values.
const ATypes: array of TFieldType | An open array of parameter values.
Returns

The number of affected rows.

Description

The ExecSQL method executes SQL command with parameters. All returned cursors will be discarded.

Syntax
function ExecSQL(const ASQL: String; const AParams: array of Variant; const ATypes: array of TFieldType): LongInt; overload;
See Also

TADQuery

Example
ADConnection1.ExecSQL('update mytab where id = :p1 set blobfld = :blb',
  [1000, StringOfChar('x', 100000)], [ftInteger, ftBLOB]);


TADCustomConnection.GetFieldNames Method

TADCustomConnection.GetFieldNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of fields in a table.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const ATableName: string | A table name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving field names.
Description

Call GetFieldNames to retrieve a list of fields in a table.

ACatalogName, ASchemaName, ATableName names the table whose field names you want added to the list.

APattern is the LIKE-pattern filtering field names.

AList is a TStrings descendant that receives the field names. Any existing strings are deleted from the list before GetFieldNames adds the names of all the fields in ATableName.

The field names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case.

Syntax
procedure GetFieldNames(const ACatalogName: string; const ASchemaName: string; const ATableName: string; const APattern: string; AList: TStrings);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetFieldNames('', '', 'MYTAB', '', ListBox1.Items);


TADCustomConnection.GetGeneratorNames Method

TADCustomConnection.GetGeneratorNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of generators / sequences / <how else> in a database.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving generator names.
AScopes: TADPhysObjectScopes = [osMy] | Generator scopes to returns.
Description

Call GetGeneratorNames to retrieve a list of generators / sequences / <how else> in a database.

ACatalogName and ASchemaName restrict generator names to the catalog and schema.

APattern is the LIKE-pattern filtering generator names.

AList is a TStrings descendant that receives the generator names. Any existing strings are deleted from the list before GetFieldNames adds the names of generators.

AScopes restricts generator names to the specified scopes.

The generator names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in generator names.

Syntax
procedure GetGeneratorNames(const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetGeneratorNames('', '', 'MY%', ListBox1.Items, [osMy, osSystem]);


TADCustomConnection.GetKeyFieldNames Method

TADCustomConnection.GetKeyFieldNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of key fields in a table.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const ATableName: string | A table name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving primary key field names.
Description

Call GetKeyFieldNames to retrieve a list of primary key fields in a table.

ACatalogName, ASchemaName, ATableName names the table whose primary field names you want added to the list.

APattern is the LIKE-pattern filtering field names.

AList is a TStrings descendant that receives the primary key field names. Any existing strings are deleted from the list before GetKeyFieldNames adds the names of the primary key fields in ATableName.

The field names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case.

Syntax
procedure GetKeyFieldNames(const ACatalogName: string; const ASchemaName: string; const ATableName: string; const APattern: string; AList: TStrings);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetKeyFieldNames('NORTHWIND', 'DBO', 'MYTAB', '', ListBox1.Items);


TADCustomConnection.GetLastAutoGenValue Method

TADCustomConnection.GetLastAutoGenValue Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Returns last auto generated value.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AName: String | The name of generator or sequence or empty string.
Returns

The last auto generated value

Description

The GetLastAutoGenValue method returns last auto-generated value. The meaning and result depends on DBMS:

DBMS | Description
Oracle | AName is the name of a sequence. The method will return CurrValue, if it exists in the session.
Interbase / Firebird | AName is the name of a generator. The method will return GEN_ID(0).
MS SQL Server, MySQL, etc | The last auto generated value in the session.
Syntax
function GetLastAutoGenValue(const AName: String): Variant;
See Also

RDBMSKind

Example
ShowMessage(VarToStr(ADConnection1.GetLastAutoGenValue('MyGen')));


TADCustomConnection.GetPackageNames Method

TADCustomConnection.GetPackageNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of Oracle packages in a DB.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving package names.
AScopes: TADPhysObjectScopes = [osMy] | Package scopes to return.
Description

Call GetPackageNames to retrieve a list of Oracle packages in a DB.

ACatalogName, ASchemaName restrict package names to the catalog and schema.

APattern is the LIKE-pattern filtering package names.

AList is a TStrings descendant that receives the package names. Any existing strings are deleted from the list before GetPackageNames adds the names of all the packages in a DB.

AScopes restricts package names to the specified scopes.

The generator names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in package names.

Syntax
procedure GetPackageNames(const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetPackageNames('', 'SYS', 'DBMS%', ListBox1.Items, [osMy, osSystem]);


TADCustomConnection.GetStoredProcNames Method

TADCustomConnection.GetStoredProcNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of stored procedures in a DB.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APackage: string | A Oracle package name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving procedure names.
AScopes: TADPhysObjectScopes = [osMy] | Procedure scopes to return.
Description

Call GetStoredProcNames to retrieve a list of stored procedures and functions in a DB.

ACatalogName, ASchemaName restrict procedure names to the catalog and schema.

APackage restricts procedure names to the Oracle package.

APattern is the LIKE-pattern filtering procedure names.

AList is a TStrings descendant that receives the procedure names. Any existing strings are deleted from the list before GetStoredProcNames adds the names of all the procedures in a DB.

AScopes restricts stored procedure names to the specified scopes. Applies only to non-packaged procedures.

The stored procedure names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in procedure names.

Syntax
procedure GetStoredProcNames(const ACatalogName: string; const ASchemaName: string; const APackage: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetStoredProcNames('', '', '', '', ListBox1.Items, [osMy, osSystem]);


TADCustomConnection.GetTableNames Method

TADCustomConnection.GetTableNames Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of tables in a DB.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE-pattern.
AList: TStrings | A list receiving table names.
AScopes: TADPhysObjectScopes = [osMy] | Table scopes to return.
AKinds: TADPhysTableKinds = [tkSynonym, tkTable, tkView] | Object kinds to return.
Description

Call GetTableNames to retrieve a list of tables in a DB.

ACatalogName, ASchemaName restrict table names to the catalog and schema.

APattern is the LIKE-pattern filtering table names.

AList is a TStrings descendant that receives the table names. Any existing strings are deleted from the list before GetTableNames adds the names of all the tables in a DB.

AScopes restricts table names to the specified scopes.

AKinds restricts tables to the specified object kinds.

The table names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in table names.

Syntax
procedure GetTableNames(const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]; AKinds: TADPhysTableKinds = [tkSynonym, tkTable, tkView]);
See Also

TADMetaInfoQuery

Example
ADConnection1.GetTableNames('NORTHWIND', 'DBO', 'ADQA%', '', ListBox1.Items,
  [osMy, osSystem, osOther], [tkTable, tkView]);


TADCustomConnection.Offline Method

TADCustomConnection.Offline Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Sets connection to offline mode.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The Offline method disconnects datasets associated with this connection from DBMS, but does not close them. Then closes the connection to the DBMS by implicitly setting Connected to False.

After call the dataset continue to work as an in-memory dataset and you can perform with the dataset any operation, which does not require DBMS, like a browsing. If application in offline mode will try to perform any operation, requiring to communicate with DBMS, then following will happens:

  • If ResourceOptions.AutoManage is True, then will be called Online method, trying to establish connection to the DBMS;
  • If ResourceOptions.AutoManage is False, then exception will be raised.

To bring connection and associated datasets to online state, call the Online method.

Calling Offline method is the same as set Offlined to True.

Syntax
procedure Offline;
See Also

Online, Offlined, Connected, TADAdaptedDataSet.Offline

Example
ADConnection1.Offline;
lblState.Caption := '<not connected>';


TADCustomConnection.Online Method

TADCustomConnection.Online Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Sets connection to online mode.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The Online method opens the connection to the DBMS by implicitly setting Connected to True and changes the state to online.

To bring connection and associated datasets to offline state, call the Offline method.

Calling Online method is the same as set Offlined to False.

Syntax
procedure Online;
See Also

Offline, Offlined, Connected

Example
ADConnection1.Online;
lblState.Caption := '<connected>';


TADCustomConnection.Ping Method

TADCustomConnection.Ping Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Pings the DBMS server.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Returns

True, if the connection to the DBMS is working.

Description

The Ping method checks whether the connection to the DBMS server is working. If the connection has gone down and ResourceOptions.AutoReconnect is True, then an automatic reconnection is attempted.

This function can be used by clients that remain idle for a long while or work in non stable environment (eg bad network), to check whether the server has closed the connection or is unaccessible and reconnect if necessary.

Syntax
function Ping: Boolean;
See Also

TADTopResourceOptions.AutoReconnect, Offline, Online, Connected

Example
procedure TMyDataModule.DoPing(ASender: TObject);
begin
  if not ADConnection1.Ping then
    ShowMessage('Connection is losted !');
end;
.......
FTimer := TTimer.Create;
FTimer.OnTimer := DoPing;
FTimer.Interval := 30000; // each 30 secs
FTimer.Enabled := True;


TADCustomConnection.RefreshMetadataCache Method

TADCustomConnection.RefreshMetadataCache Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Invalidates meta data cache.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

The RefreshMetadataCache method discards all cached metadata, like a stored procedure definitions and table primary keys. Call this method, if the DB metadata has been changed, so the cached metadata is invalid. The metadata is cached by datasets, if fiMeta is included into FetchOptions.Cache.

Syntax
procedure RefreshMetadataCache;
See Also

TADFetchOptions.Cache

Example
ADConnection1.ExecSQL('alter table mytab drop primary key');
ADConnection1.RefreshMetadataCache;


TADCustomConnection.Rollback Method

TADCustomConnection.Rollback Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Cancels all modifications to the data made in the current transaction and optionally ends transaction.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Call Rollback to cancel all modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

The Rollback call is the shortcut to Transaction.Rollback, if Transaction property is assigned. Otherwise Rollback will operate on default connection transaction.

Before calling Rollback, an application may check the status of the InTransaction property. If an application calls Rollback and there is no current transaction, an exception is raised.

Rollback call on Interbase / Firebird will close and unprepare all datasets and commands, associated with this transaction object.

Syntax
procedure Rollback;
See Also

StartTransaction, InTransaction, Commit, RollbackRetaining

Example
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.Commit;
    end;
  except
    ADConnection1.Rollback;
    raise;
  end;
end;


TADCustomConnection.RollbackRetaining Method

TADCustomConnection.RollbackRetaining Method
TADCustomConnection Class uADCompClient Unit Example public See Also Send Feedback

Cancels all modifications to the data made in the current transaction, without ending the current transaction.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, Example, public, See Also
Description

Call RollbackRetaining to cancel all modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

The RollbackRetaining call is the shortcut to Transaction.RollbackRetaining, if Transaction property is assigned. Otherwise RollbackRetaining will operate on default connection transaction.

Before calling RollbackRetaining, an application may check the status of the InTransaction property. If an application calls RollbackRetaining and there is no current transaction, an exception is raised.

RollbackRetaining will use native functionality on IB/FB. On other DBMS's the method will be equal to calls of Rollback, then of StartTransaction.

Syntax
procedure RollbackRetaining;
See Also

StartTransaction, InTransaction, Commit, Rollback

Example
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.CommitRetaining;
    end;
  except
    ADConnection1.RollbackRetaining;
    raise;
  end;
end;


TADCustomConnection.StartTransaction Method

TADCustomConnection.StartTransaction Method
TADCustomConnection Class uADCompClient Unit public See Also Send Feedback

Starts new transaction at database.

Group

public

Links
TADCustomConnection Class, uADCompClient Unit, public, See Also
Description

Call StartTransaction to start a new transaction at the DBMS.

The AnyDAC supports nested transactions, emulating them by savepoints. If transaction is already active, then anyDAC will put savepoint.

Before calling StartTransaction, an application should adjust settings of the TxOptions property as desired.

All data modifications, like a INSERT's / UPDATE's / DELETE's, made after a call of StartTransaction, may be either confirmed by calling Commit, either undone by calling Rollback.

Syntax
procedure StartTransaction;
See Also

InTransaction, Commit, Rollback, TxOptions


TADCustomManager Class

TADCustomManager Class
public Classes See Also Send Feedback

The class is responsible to connection definitions and connections management.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomManager to manage connection definitions and connection objects.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADManager.

Syntax
TADCustomManager = class(TComponent, IUnknown, IADStanOptions);
See Also

TADManager, ADManager, IADPhysManager

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


public

public
TADCustomManager Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADCustomManager class are listed here.

Class

TADCustomManager Class

Public Events
Name | Description
AfterLoadConnectionDefFile | Fires after connection definitions file is loaded.
BeforeLoadConnectionDefFile | Fires before connection definitions file is loaded.
OnShutdown | Fires after manager is finished.
OnStartup | Fires after manager is started.
Public Methods
Name | Description
AcquireConnection |
AcquireConnection |
AddConnectionDef | Adds private connection definition.
Close | Terminates AnyDAC manager.
DeleteConnectionDef | Deletes connection definition.
DropConnections |
FindConnection | Find the TADCustomConnection instance with ConnectionName equal to AConnectionName.
GetConnectionDefNames | Fills the list by existing connection definition names.
GetConnectionDefParams | Fills the list by connection definition parameters.
GetConnectionNames | Fills the list by connection names.
GetDriverNames | Fills the list by registered driver ID's.
GetFieldNames | Populates a string list with the names of fields in a table.
GetGeneratorNames | Populates a string list with the names of generators / sequences / <how else> in a database.
GetKeyFieldNames | Populates a string list with the names of key fields in a table.
GetPackageNames | Populates a string list with the names of Oracle packages in a DB.
GetStoredProcNames | Populates a string list with the names of stored procedures in a DB.
GetTableNames | Populates a string list with the names of tables in a DB.
IsConnectionDef | Check if name is connection definition name.
LoadConnectionDefFile | Loads connection definitions file.
ModifyConnectionDef | Modifies parameters of an existing connection definition.
Open | Activates AnyDAC manager.
RefreshConnectionDefFile | Refreshes connection definition list.
RefreshMetadataCache | Invalidates meta data cache for all connections.
ReleaseConnection |
SaveConnectionDefFile | Saves connection definitions into a file.
Public Properties
Name | Description
Active | Gets or sets AnyDAC manager active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
AutoCreated | Is manager object auto created.
CanRefreshConnectionDefFile | Checks if connection definition list may be refreshed.
ConnectionCount | The number of connection objects.
ConnectionDefFileAutoLoad | Controls how connection definitions file must be loaded.
ConnectionDefFileLoaded | Checks is loaded the connection definitions file.
ConnectionDefFileName | Gets / sets the name of a connection definitions file.
ConnectionDefs | The list of connection definitions.
Connections | The application connection objects.
DriverDefFileAutoLoad | Controls how driver definitions file must be loaded.
DriverDefFileName | Gets / sets the name of a driver definitions file.
FetchOptions | The "root" fetch options.
FormatOptions | The "root" data format options.
ResourceOptions | The "root" resources control options.
SilentMode | Gets or sets AnyDAC global "silent" flag.
State | Returns the current state of AnyDAC manager.
UpdateOptions | The "root" data updating options.
WaitCursor | Gets or sets AnyDAC wait cursor shape.
Links
TADCustomManager Class, Legend, Public Events, Public Methods, Public Properties


TADCustomManager.Active Property

TADCustomManager.Active Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Gets or sets AnyDAC manager active status.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

Set Active to True to activate AnyDAC manager. After that the State = dmsActive. At activating, ADPhysManager loads driver definition file, allocates internal driver structures (does not load DBMC client DLL) and runs driver management thread. So, if it is required, set DriverDefFileAutoLoad and DriverDefFileName before activating manager.

Set Active to False to terminate AnyDAC manager. After that the State = dmsInactive. At terminating, manager calls TADCustomConnection.Close for all connection objects in application, ADPhysManager waits until all connections interfaces (IADPhysConnection) will be released, unloads DBMS client DLL's and releases internal driver structures.

TADCustomConnection activates manager automatically before first time connection.

Notes

To change any driver settings, manager must be inactive.

Syntax
property Active: Boolean;
See Also

DriverDefFileAutoLoad, DriverDefFileName, Open, Close


TADCustomManager.ActiveStoredUsage Property

TADCustomManager.ActiveStoredUsage Property
TADCustomManager Class uADCompClient Unit public Send Feedback

Controls how to use Active property value saved to DFM.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Description

The ActiveStoredUsage property controls how to use Active property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADCustomManager.AfterLoadConnectionDefFile Event

TADCustomManager.AfterLoadConnectionDefFile Event
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Fires after connection definitions file is loaded.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The AfterLoadConnectionDefFile event is fired after the connection definitions file is loaded.

Syntax
property AfterLoadConnectionDefFile: TNotifyEvent;
See Also

BeforeLoadConnectionDefFile

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.AutoCreated Property

TADCustomManager.AutoCreated Property
TADCustomManager Class uADCompClient Unit public Send Feedback

Is manager object auto created.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Description

Returns True, if manager object is created internally by AnyDAC.

Syntax
property AutoCreated: Boolean;


TADCustomManager.BeforeLoadConnectionDefFile Event

TADCustomManager.BeforeLoadConnectionDefFile Event
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Fires before connection definitions file is loaded.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The BeforeLoadConnectionDefFile event is fired before the connection definitions file is loaded.

Syntax
property BeforeLoadConnectionDefFile: TNotifyEvent;
See Also

AfterLoadConnectionDefFile

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.CanRefreshConnectionDefFile Property

TADCustomManager.CanRefreshConnectionDefFile Property
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Checks if connection definition list may be refreshed.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Description

The CanRefreshConnectionDefFile property returns True, if not one active connection is associated with any of connection definitions in the ConnectionDefs list. In this case ConnectionDefs may be erased or refreshed.

Syntax
property CanRefreshConnectionDefFile: Boolean;
See Also

ConnectionDefs

Example
// reload connection definition list
if ADManager.CanRefreshConnectionDefFile then begin
  ADManager.ConnectionDefs.Clear;
  ADManager.ConnectionDefs.Load;
end;


TADCustomManager.ConnectionCount Property

TADCustomManager.ConnectionCount Property
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

The number of connection objects.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Description

The ConnectionCount property returns the number of existing TADCustomConnection objects in the application.

Syntax
property ConnectionCount: Integer;
See Also

TADCustomConnection, Connections

Example
// perform some task for all application connection objects
for i := 0 to ADManager.ConnectionCount - 1 do
  ADManager.Connections[i].Ping;


TADCustomManager.ConnectionDefFileAutoLoad Property

TADCustomManager.ConnectionDefFileAutoLoad Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Controls how connection definitions file must be loaded.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The ConnectionDefFileAutoLoad property controls, should be a connection definition file loaded automatically or explicitly by programmer. If True, then AnyDAC will load file at first "touch" to the content of the ConnectionDefs list.

If False, then programmer should call ConnectionDefs.Load method before first "touch" to the ConnectionDefs list, including:

  • opening a connection referencing to a connection definition by its name (see TADCustomConnection.ConnectionDefName);
  • iterating through existing connection definitions (see TADCustomManager.ConnectionDefs);
  • adding new connection definition, deleting existing connection definition or looking for existing connection definition (see TADCustomManager.ConnectionDefs);

Otherwise an exception will be raised.

Syntax
property ConnectionDefFileAutoLoad: Boolean;
See Also

ConnectionDefs, ConnectionDefFileLoaded, ConnectionDefFileName, LoadConnectionDefFile


TADCustomManager.ConnectionDefFileLoaded Property

TADCustomManager.ConnectionDefFileLoaded Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Checks is loaded the connection definitions file.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The ConnectionDefFileLoaded property returns True, if connection definitions file is loaded and it content is accessible through the ConnectionDefs list.

Syntax
property ConnectionDefFileLoaded: Boolean;
See Also

ConnectionDefs, ConnectionDefFileautoLoad, ConnectionDefFileName


TADCustomManager.ConnectionDefFileName Property

TADCustomManager.ConnectionDefFileName Property
TADCustomManager Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Gets / sets the name of a connection definitions file.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

The ConnectionDefFileName property allows to get or set the name of a connection definition file.

The application can set the name before connection definitions file will be loaded. For example in BeforeLoadConnectionDefFile event handler.

Syntax
property ConnectionDefFileName: String;
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded

Example 1
ADManager.ConnectionDefFileName := ExtractFilePath(Application.ExeName) + 'myconndef.ini';
ADManager.ConnectionDefFileAutoLoad := True;
oConn := TADConnection.Create(nil);
oConn.ConnectionDefName := 'myconn';
oConn.Connected := True;
Example 2
procedure TMyDataModule.DoBeforeLoad(ASender: TNotifyEvent);
begin
  ADManager.ConnectionDefFileName := FSettings.MyConnectionDefFile;
end;
...
ADManager.BeforeLoadConnectionDefFile := DoBeforeLoad;


TADCustomManager.ConnectionDefs Property

TADCustomManager.ConnectionDefs Property
TADCustomManager Class uADCompClient Unit Example 1 Example 2 Example 3 public See Also Send Feedback

The list of connection definitions.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example 1, Example 2, Example 3, public, See Also
Description

The ConnectionDefs property returns the list of connection definitions loaded from connection definitions file, if it exists. The list may be manipulated directly, including adding, changing or deleting of connection definitions.

Syntax
property ConnectionDefs: IADStanConnectionDefs;
See Also

ConnectionDefFileName, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded

Example 1
// find the connection definition, change it properties and save it to file
oDef := ADManager.ConnectionDefs.ConnectionDefByName('MyDef');
oDef.Server := '127.0.0.1';
oDef.Apply;
Example 2
// add new connection definition and save it to file
oDef := ADManager.ConnectionDefs.AddConnectionDef;
oDef.Name := 'MyDef';
oDef.Server := '127.0.0.1';
oDef.UserName := 'dba';
// use new connection definition
ADConnection1.ConnectionDefName := 'MyDef';
Example 3

See AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs sample for details of how to work with ConnectionDefs.


TADCustomManager.Connections Property

TADCustomManager.Connections Property
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

The application connection objects.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Description

The Connections property gives access by index to the list of application connection objects.

Syntax
property Connections [Index: Integer]: TADCustomConnection;
See Also

TADCustomConnection, ConnectionCount

Example
// perform some task for all application connection objects
for i := 0 to ADManager.ConnectionCount - 1 do
  ADManager.Connections[i].Ping;


TADCustomManager.DriverDefFileAutoLoad Property

TADCustomManager.DriverDefFileAutoLoad Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Controls how driver definitions file must be loaded.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The DriverDefFileAutoLoad property controls, should be driver definition file loaded automatically or explicitly by programmer. If True, then AnyDAC will load file at manager activation.

If False, then programmer should call ADPhysManager.DriverDefs.Load method before manager activation. Otherwise an exception will be raised.

Syntax
property DriverDefFileAutoLoad: Boolean;
See Also

DriverDefFileName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.DriverDefFileName Property

TADCustomManager.DriverDefFileName Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Gets / sets the name of a driver definitions file.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The DriverDefFileName property allows to get or set the name of a driver definition file. The application can set the name before manager activation.

Syntax
property DriverDefFileName: String;
See Also

DriverDefFileAutoLoad

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.FetchOptions Property

TADCustomManager.FetchOptions Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

The "root" fetch options.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The FetchOptions property returns the reference to the "root" instance of the fetch options. These options control how the data will be fetched and cached in the memory.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property FetchOptions: TADFetchOptions;
See Also

FormatOptions, UpdateOptions, ResourceOptions


TADCustomManager.FormatOptions Property

TADCustomManager.FormatOptions Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

The "root" data format options.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The FormatOptions property returns the reference to the "root" instance of the data format options. These options control how the DBMS data types will be mapped into dataset data types.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property FormatOptions: TADFormatOptions;
See Also

FetchOptions, UpdateOptions, ResourceOptions


TADCustomManager.OnShutdown Event

TADCustomManager.OnShutdown Event
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Fires after manager is finished.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The OnShutdown event is fired after AnyDAC manager is terminated.

Syntax
property OnShutdown: TNotifyEvent;
See Also

Active, Close, OnStartup

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.OnStartup Event

TADCustomManager.OnStartup Event
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Fires after manager is started.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The OnStartup event is fired after AnyDAC manager is started.

Syntax
property OnStartup: TNotifyEvent;
See Also

Active, Open, OnShutdown

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.ResourceOptions Property

TADCustomManager.ResourceOptions Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

The "root" resources control options.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The ResourceOptions property returns the reference to the "root" instance of the resources control options. These options control how AnyDAC should use DBMS and workstation resources.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property ResourceOptions: TADTopResourceOptions;
See Also

FetchOptions, UpdateOptions, FormatOptions


TADCustomManager.SilentMode Property

TADCustomManager.SilentMode Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Gets or sets AnyDAC global "silent" flag.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

Set SilentMode to True to not show wait cursors and dialogs. This flag is application wide. Its value overrides all TADResourceOptions.SilentMode values.

Syntax
property SilentMode: Boolean;
See Also

TADResourceOptions.SilentMode, WaitCursor


TADCustomManager.State Property

TADCustomManager.State Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Returns the current state of AnyDAC manager.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The State property returns the current state of AnyDAC manager.

Syntax
property State: TADPhysManagerState;
See Also

Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.UpdateOptions Property

TADCustomManager.UpdateOptions Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

The "root" data updating options.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The UpdateOptions property returns the reference to the "root" instance of the data updating options. These options control how AnyDAC should post data changes back to a DB.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomTableAdapter's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property UpdateOptions: TADUpdateOptions;
See Also

FetchOptions, ResourceOptions, FormatOptions


TADCustomManager.WaitCursor Property

TADCustomManager.WaitCursor Property
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Gets or sets AnyDAC wait cursor shape.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The WaitCursor property gets or sets the wait cursor shape.

Syntax
property WaitCursor: TADGUIxScreenCursor;
See Also

SilentMode

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.AcquireConnection Method (TADCustomConnection, String)

TADCustomManager.AcquireConnection Method (TADCustomConnection, String)
TADCustomManager Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Syntax
function AcquireConnection(AConnection: TADCustomConnection; const AObjName: String): TADCustomConnection; overload;


TADCustomManager.AcquireConnection Method (string, String)

TADCustomManager.AcquireConnection Method (string, String)
TADCustomManager Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Syntax
function AcquireConnection(const AConnectionName: string; const AObjName: String): TADCustomConnection; overload;


TADCustomManager.AddConnectionDef Method

TADCustomManager.AddConnectionDef Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Adds private connection definition.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AName: string | A connection definition name.
const ADriver: string | A driver ID.
AList: TStrings | A list of parameter name=value pairs.
APersistent: Boolean = False | A persistance flag. By default is False.
Description

The AddConnectionDef method adds new private or persistent connection definition to the ConnectionDefs list.

The connection definition will get name AName, DriverID ADriver and parameters AList. The name must be unique across other connection definitions in the ConnectionDefs list, otherwise exception will be raised.

Set APersistent to True, to mark connection definition as persistent, otherwise it will be private one. After the call a persistent connection definition is not stored to a file. Call SaveConnectionDefFile to save this and other changes to a file. Not stored connection definitions will be discarded after AnyDAC manager or application will be terminated.

After connection definition is added, it may be referenced by TADCustomConnection.ConnectionDefName.

Syntax
procedure AddConnectionDef(const AName: string; const ADriver: string; AList: TStrings; APersistent: Boolean = False);
See Also

ConnectionDefs, SaveConnectionDefFile, DeleteConnectionDef, ModifyConnectionDef, IADStanConnectionDefs.AddConnectionDef, TADCustomConnection.ConnectionDefName

Example
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=127.0.0.1');
  oList.Add('Database=addemo');
  ADManager.AddConnectionDef('myconn', 'MySQL', oList);
......
  ADConnection1.ConnectionDefName := 'myconn';
  ADConnection1.Connected := True;


TADCustomManager.Close Method

TADCustomManager.Close Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Terminates AnyDAC manager.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The Close method terminates manager, by setting Active to False.

Syntax
procedure Close;
See Also

Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.DeleteConnectionDef Method

TADCustomManager.DeleteConnectionDef Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Deletes connection definition.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AName: string | A connection definition name.
Description

The DeleteConnectionDef method deletes connection definition by its name from the ConnectionDefs list. If specified name is not found, then exception will be raised.

After the call a persistent connection definition is not deleted from a file. Call SaveConnectionDefFile to delete it and save other changes to a file.

Syntax
procedure DeleteConnectionDef(const AName: string);
See Also

ConnectionDefs, SaveConnectionDefFile, AddConnectionDef, IADStanDefinition.Delete

Example
  ADManager.DeleteConnectionDef('myconn');


TADCustomManager.DropConnections Method

TADCustomManager.DropConnections Method
TADCustomManager Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Syntax
procedure DropConnections;


TADCustomManager.FindConnection Method

TADCustomManager.FindConnection Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Find the TADCustomConnection instance with ConnectionName equal to AConnectionName.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | The connection name
Returns

An TADCustomConnection instance, if found. Nil - otherwise.

Description

The FindConnection method finds the TADCustomConnection instance with ConnectionName equal to AConnectionName.

Syntax
function FindConnection(const AConnectionName: string): TADCustomConnection;
See Also

GetConnectionNames, TADCustomConnection.ConnectionName, TADCustomCommand.ConnectionName, TADRdbmsDataSet.ConnectionName


TADCustomManager.GetConnectionDefNames Method

TADCustomManager.GetConnectionDefNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Fills the list by existing connection definition names.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
AList: TStrings | A list to fill.
Description

The GetConnectionDefNames method fills an AList list by the names of connection definitions in the ConnectionDefs list. A list will be sorted alphabetically.

Syntax
procedure GetConnectionDefNames(AList: TStrings);
See Also

IADStanDefinition.Name

Example
ADManager.GetConnectionDefNames(ListBox1.Items);


TADCustomManager.GetConnectionDefParams Method

TADCustomManager.GetConnectionDefParams Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Fills the list by connection definition parameters.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AName: string | A connection definition name.
AList: TStrings | A list to fill.
Description

The GetConnectionDefParams method fills an AList list by the name=value pairs of AName connection definition in the ConnectionDefs list.

Syntax
procedure GetConnectionDefParams(const AName: string; AList: TStrings);
See Also

IADStanDefinition.Params

Example
ADManager.GetConnectionDefParams('myconn', ListBox1.Items);


TADCustomManager.GetConnectionNames Method

TADCustomManager.GetConnectionNames Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Fills the list by connection names.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
AList: TStrings | A list to fill.
Description

The GetConnectionNames method fills an AList list by the connection names. A list will be sorted alphabetically.

Syntax
procedure GetConnectionNames(AList: TStrings);
See Also

FindConnection, TADCustomConnection.ConnectionName, TADCustomCommand.ConnectionName, TADRdbmsDataSet.ConnectionName


TADCustomManager.GetDriverNames Method

TADCustomManager.GetDriverNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Fills the list by registered driver ID's.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
AList: TStrings | A list to fill.
Description

The GetDriverNames method fills an AList list by the registered driver ID's. A list will be sorted alphabetically.

Syntax
procedure GetDriverNames(AList: TStrings);
See Also

IADStanConnectionDef.DriverID

Example
ADManager.GetDriverNames(ListBox1.Items);


TADCustomManager.GetFieldNames Method

TADCustomManager.GetFieldNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of fields in a table.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const ATableName: string | A table name.
const APattern: string | A LIKE patten.
AList: TStrings | A list to fill.
Description

Call GetFieldNames to retrieve a list of fields in a table.

AConnectionName is the connection name to use.

ACatalogName, ASchemaName, ATableName names the table whose field names you want added to the list.

APattern is the LIKE-pattern filtering field names.

AList is a TStrings descendant that receives the field names. Any existing strings are deleted from the list before GetFieldNames adds the names of all the fields in ATableName.

The field names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case.

Syntax
procedure GetFieldNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const ATableName: string; const APattern: string; AList: TStrings);
See Also

TADMetaInfoQuery, TADCustomConnection.GetFieldNames

Example
ADManager.GetFieldNames('myconn', '', '', 'MYTAB', '', ListBox1.Items);


TADCustomManager.GetGeneratorNames Method

TADCustomManager.GetGeneratorNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of generators / sequences / <how else> in a database.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE pattern.
AList: TStrings | A list to fill.
AScopes: TADPhysObjectScopes = [osMy] | A object scopes.
Description

Call GetGeneratorNames to retrieve a list of generators / sequences / <how else> in a database.

AConnectionName is the connection name to use.

ACatalogName and ASchemaName restrict generator names to the catalog and schema.

APattern is the LIKE-pattern filtering generator names.

AList is a TStrings descendant that receives the generator names. Any existing strings are deleted from the list before GetFieldNames adds the names of generators.

AScopes restricts generator names to the specified scopes.

The generator names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in generator names.

Syntax
procedure GetGeneratorNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery, TADCustomConnection.GetGeneratorNames

Example
ADManager.GetGeneratorNames('myconn', '', '', 'MY%', ListBox1.Items, [osMy, osSystem]);


TADCustomManager.GetKeyFieldNames Method

TADCustomManager.GetKeyFieldNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of key fields in a table.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const ATableName: string | A table name.
const APattern: string | A LIKE pattern.
AList: TStrings | A list to fill.
Description

Call GetKeyFieldNames to retrieve a list of primary key fields in a table.

AConnectionName is the connection name to use.

ACatalogName, ASchemaName, ATableName names the table whose primary field names you want added to the list.

APattern is the LIKE-pattern filtering field names.

AList is a TStrings descendant that receives the primary key field names. Any existing strings are deleted from the list before GetKeyFieldNames adds the names of the primary key fields in ATableName.

The field names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case.

Syntax
procedure GetKeyFieldNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const ATableName: string; const APattern: string; AList: TStrings);
See Also

TADMetaInfoQuery, TADCustomConnection.GetKeyFieldNames

Example
ADManager.GetKeyFieldNames('myconn', 'NORTHWIND', 'DBO', 'MYTAB', '', ListBox1.Items);


TADCustomManager.GetPackageNames Method

TADCustomManager.GetPackageNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of Oracle packages in a DB.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE pattern.
AList: TStrings | A list to fill.
AScopes: TADPhysObjectScopes = [osMy] | A object scopes.
Description

Call GetPackageNames to retrieve a list of Oracle packages in a DB.

AConnectionName is the connection name to use.

ACatalogName, ASchemaName restrict package names to the catalog and schema.

APattern is the LIKE-pattern filtering package names.

AList is a TStrings descendant that receives the package names. Any existing strings are deleted from the list before GetPackageNames adds the names of all the packages in a DB.

AScopes restricts package names to the specified scopes.

The generator names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in package names.

Syntax
procedure GetPackageNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery, TADCustomConnection.GetPackageNames

Example
ADManager.GetPackageNames('myconn', '', 'SYS', 'DBMS%', ListBox1.Items, [osMy, osSystem]);


TADCustomManager.GetStoredProcNames Method

TADCustomManager.GetStoredProcNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of stored procedures in a DB.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APackage: string | A Oracle package name.
const APattern: string | A LIKE pattern.
AList: TStrings | A list to fill.
AScopes: TADPhysObjectScopes = [osMy] | A object scopes.
Description

Call GetStoredProcNames to retrieve a list of stored procedures and functions in a DB.

AConnectionName is the connection name to use.

ACatalogName, ASchemaName restrict procedure names to the catalog and schema.

APackage restricts procedure names to the Oracle package.

APattern is the LIKE-pattern filtering procedure names.

AList is a TStrings descendant that receives the procedure names. Any existing strings are deleted from the list before GetStoredProcNames adds the names of all the procedures in a DB.

AScopes restricts stored procedure names to the specified scopes. Applies only to non-packaged procedures.

The stored procedure names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in procedure names.

Syntax
procedure GetStoredProcNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const APackage: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery, TADCustomConnection.GetStoredProcNames

Example
ADManager.GetStoredProcNames('myconn', '', '', '', '', ListBox1.Items, [osMy, osSystem]);


TADCustomManager.GetTableNames Method

TADCustomManager.GetTableNames Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Populates a string list with the names of tables in a DB.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AConnectionName: string | A connection name.
const ACatalogName: string | A catalog name.
const ASchemaName: string | A schema name.
const APattern: string | A LIKE pattern.
AList: TStrings | A list to fill.
AScopes: TADPhysObjectScopes = [osMy] | A object scopes.
Description

Call GetTableNames to retrieve a list of tables in a DB.

AConnectionName is the connection name to use.

ACatalogName, ASchemaName restrict table names to the catalog and schema.

APattern is the LIKE-pattern filtering table names.

AList is a TStrings descendant that receives the table names. Any existing strings are deleted from the list before GetTableNames adds the names of all the tables in a DB.

AScopes restricts table names to the specified scopes.

AKinds restricts tables to the specified object kinds.

The table names are normalized - enclosed into quotes, if that is required, otherwise converted to default dictionary case. Specify the MetaDefSchema and/or MetaDefCatalog parameters in connection definition, to avoid these schema and/or catalog names in table names.

Syntax
procedure GetTableNames(const AConnectionName: string; const ACatalogName: string; const ASchemaName: string; const APattern: string; AList: TStrings; AScopes: TADPhysObjectScopes = [osMy]);
See Also

TADMetaInfoQuery, TADCustomConnection.GetTableNames

Example
ADManager.GetTableNames('myconn', 'NORTHWIND', 'DBO', 'ADQA%', '', ListBox1.Items,
  [osMy, osSystem, osOther], [tkTable, tkView]);


TADCustomManager.IsConnectionDef Method

TADCustomManager.IsConnectionDef Method
TADCustomManager Class uADCompClient Unit public Send Feedback

Check if name is connection definition name.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Parameters
Parameters | Description
const AName: String | A name to check.
Returns

True, if the AName is connection definition name. False - otherwise.

Description

The IsConnectionDef method checks if AName value is the name of existing connection definition in ConnectionDefs list.

Syntax
function IsConnectionDef(const AName: String): Boolean;


TADCustomManager.LoadConnectionDefFile Method

TADCustomManager.LoadConnectionDefFile Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Loads connection definitions file.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The LoadConnectionDefFile method explicitly loads a connection definition file, specified by ConnectionDefFileName. Use this method, if you set ConnectionDefFileAutoLoad to False.

Syntax
procedure LoadConnectionDefFile;
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded, ConnectionDefFileName


TADCustomManager.ModifyConnectionDef Method

TADCustomManager.ModifyConnectionDef Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Modifies parameters of an existing connection definition.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AName: string | A connection definition name to modify.
AList: TStrings | A list of name=value pairs.
Description

The ModifyConnectionDef method modifies parameters of an existing connection definition in the ConnectionDefs list using AList parameter values.

After the call a persistent connection definition is not stored to a file. Call SaveConnectionDefFile to save this and other changes to a file. Not stored connection definition changes will be discarded after AnyDAC manager or application will be terminated.

If connection definition with AName name is not found, then exception will be raised.

Syntax
procedure ModifyConnectionDef(const AName: string; AList: TStrings);
See Also

ConnectionDefs, SaveConnectionDefFile, DeleteConnectionDef, AddConnectionDef

Example
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=myhoster');
  ADManager.ModifyConnectionDef('myconn', oList);
  ADManager.SaveConnectionDefFile;


TADCustomManager.Open Method

TADCustomManager.Open Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Activates AnyDAC manager.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The Open method activates manager, by setting Active to True.

Syntax
procedure Open;
See Also

Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomManager.RefreshConnectionDefFile Method

TADCustomManager.RefreshConnectionDefFile Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Refreshes connection definition list.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Description

The RefreshConnectionDefFile method discards all changes in the ConnectionDefs list and loads connection definition file. The list may be refreshed, if there is no active connections using connection definitions from the list.

Syntax
procedure RefreshConnectionDefFile;
See Also

CanRefreshConnectionDefFile, ConnectionDefs

Example
if ADManager.CanRefreshConnectionDefFile then
  ADManager.RefreshConnectionDefFile;


TADCustomManager.RefreshMetadataCache Method

TADCustomManager.RefreshMetadataCache Method
TADCustomManager Class uADCompClient Unit public See Also Send Feedback

Invalidates meta data cache for all connections.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, public, See Also
Description

The RefreshMetadataCache method discards all cached metadata, like a stored procedure definitions and table primary keys for all TADCustomConnection instances. Call this method, if the DB metadata has been changed, so the cached metadata is invalid. The metadata is cached by datasets, if fiMeta is included into FetchOptions.Cache.

Syntax
procedure RefreshMetadataCache;
See Also

TADFetchOptions.Cache, TADCustomConnection.RefreshMetadataCache


TADCustomManager.ReleaseConnection Method

TADCustomManager.ReleaseConnection Method
TADCustomManager Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomManager Class, uADCompClient Unit, public
Syntax
procedure ReleaseConnection(var AConnection: TADCustomConnection);


TADCustomManager.SaveConnectionDefFile Method

TADCustomManager.SaveConnectionDefFile Method
TADCustomManager Class uADCompClient Unit Example public See Also Send Feedback

Saves connection definitions into a file.

Group

public

Links
TADCustomManager Class, uADCompClient Unit, Example, public, See Also
Description

The SaveConnectionDefFile method saves all changes in the ConnectionDefs list to the file specified by ConnectionDefFileName.

Syntax
procedure SaveConnectionDefFile;
See Also

ConnectionDefs, DeleteConnectionDef, AddConnectionDef, ModifyConnectionDef

Example
  ADManager.DeleteConnectionDef('myconn');
  ADManager.SaveConnectionDefFile;


TADCustomMemTable Class

TADCustomMemTable Class
public Classes See Also Send Feedback

The class implementing in-memory dataset.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomMemTable to manage data in the client memory and optionally exchange the data with a DBMS.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADMemTable.

Syntax
TADCustomMemTable = class(TADAdaptedDataSet, IADStanOptions);
See Also

TADMemTable, TADDatSTable, TADCustomTableAdapter


public

public
TADCustomMemTable Class Legend Public Properties Send Feedback

The public members of the TADCustomMemTable class are listed here.

Class

TADCustomMemTable Class

Public Properties
Name | Description
Adapter | Reference to a data adapter.
Links
TADCustomMemTable Class, Legend, Public Properties


TADCustomMemTable.Adapter Property

TADCustomMemTable.Adapter Property
TADCustomMemTable Class uADCompClient Unit public See Also Send Feedback

Reference to a data adapter.

Group

public

Links
TADCustomMemTable Class, uADCompClient Unit, public, See Also
Description

Use this property to get/set data adapter for dataset. The dataset will use data adapter to talk to DBMS, when he needs to execute query, fetch rows, post changes back to DBMS.

Syntax
property Adapter: TADCustomTableAdapter;
See Also

TADCustomTableAdapter

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomQuery Class

TADCustomQuery Class
public Classes See Also Send Feedback

The class implementing dataset, capable to execute SQL queries.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomQuery to execute SQL queries, browse the resultsets and edit the resultset records.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADQuery.

Syntax
TADCustomQuery = class(TADRdbmsDataSet);
See Also

TADQuery, TADCustomCommand

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


public

public
TADCustomQuery Class Legend Public Methods Public Properties Send Feedback

The public members of the TADCustomQuery class are listed here.

Class

TADCustomQuery Class

Public Methods
Name | Description
ExecSQL | Executes the SQL statement for the query.
ExecSQL | Executes the specified SQL statement for the query.
ExecSQL | Executes the specified SQL statement and parameter values for the query.
ExecSQL | Executes the specified SQL statement and assigns parameter values for the query.
Public Properties
Name | Description
DataSource | Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.
ParamCount | Returns the current number of parameters in the query SQL text.
SQL | Contains the text of the SQL statement to execute for the query.
Text | Points to the actual text of the SQL query passed to the DBMS CLI.
Links
TADCustomQuery Class, Legend, Public Methods, Public Properties


TADCustomQuery.DataSource Property

TADCustomQuery.DataSource Property
TADCustomQuery Class uADCompClient Unit Example public See Also Send Feedback

Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example, public, See Also
Description

Use the DataSource property to automatically fill parameters in a query with fields values from another dataset. Parameters that have the same name as fields in the other dataset are filled with the field values. Parameters with names that are not the same as fields in the other dataset do not automatically get values, and must be programmatically set.

When the master dataset current position is changed or is changed the data in the current record of the master dataset, then this dataset (detail dataset) will reopen query using new master dataset field values. If that is not desired behaviour or you must quickly walk through master dataset, then use DisableControls / EnableControls on master dataset.

Syntax
property DataSource: TDataSource;
See Also

SQL, Params, ParamByName, TDataSet.BeforeOpen

Example
MasterQuery.Open('select * from {id Orders}');
MasterSource.DataSet := MasterQuery;
DetailQuery.DataSource := MasterSource;
DetailQuery.Open('select * from {id Order Details} where OrderID = :OrderID');
// here :OrderID parameter of DetailQuery will get the current value of OrderID
// field from MasterQuery
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomQuery.ParamCount Property

TADCustomQuery.ParamCount Property
TADCustomQuery Class uADCompClient Unit public See Also Send Feedback

Returns the current number of parameters in the query SQL text.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, public, See Also
Description

The ParamCount property value is the shortcut for Params.Count property. If the ResourceOptions.ParamCreate property is True, ParamCount always corresponds to the number of actual parameters in the SQL statement for the query.

Syntax
property ParamCount;
See Also

Params, SQL, TADResourceOptions.ParamCreate


TADCustomQuery.SQL Property

TADCustomQuery.SQL Property
TADCustomQuery Class uADCompClient Unit Example public See Also Send Feedback

Contains the text of the SQL statement to execute for the query.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example, public, See Also
Description

Use SQL property to specify the SQL command that a query will Execute / ExecSQL / Open.

At design time the SQL property can be edited by invoking AnyDAC Query Editor dialog. For that double click on TADCustomQuery component. The dialog offers syntax hilighting editor, query builder, ability to test query and other.

The SQL property may contain one SQL command or "batch" SQL command, consisting from few SQL command or server side programming language block of code. To execute full featured SQL script use the TADScript component.

The SQL statement in the SQL property may contain also:

  • parameter markers, following standard SQL-92 syntax conventions. Parameters are created automatically and stored in the Params property, if ResourceOptions.ParamCreate is True. If ParamBindMode is pbByName, then for all occurencies of the same marker will be created single item in Params. If pbByNumber, then - one item per each marker.
  • substitution variable markers. Macros are created automatically and stored in the Macros property, if ResourceOptions.MacroCreate is True.
  • escape sequences. They allow writing DBMS independent SQL commands.
  • conditional substitutions. They allow expand SQL command conditionally, depending on application defined attributes

For details see Command text preprocessing.

To improove performance on adding big SQL queries to the property using TStringList methods, surround this code into SQL.BeginUpdate / SQL.EndUpdate.

After filling this property value the Param collection will be filled automatically, if ResourceOptions.ParamCreate is True.

Syntax
property SQL: TStrings;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, ExecSQL, TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADRdbmsDataSet.ParamBindMode

Example
ADQuery1.SQL.BeginUpdate;
try
  ADQuery1.SQL.Add('SELECT ...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('WHERE ID = :ID');
finally
  ADQuery1.SQL.EndUpdate;
end;
ADQuery1.ParamByName('ID').AsInteger := 100;
ADQuery1.Open;


TADCustomQuery.Text Property

TADCustomQuery.Text Property
TADCustomQuery Class uADCompClient Unit public See Also Send Feedback

Points to the actual text of the SQL query passed to the DBMS CLI.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, public, See Also
Description

Text is a read-only property that can be examined to determine the actual contents of SQL statement passed to the DBMS. For parameterized queries, Text contains the SQL statement with parameters replaced by the parameter substitution symbol (? or else) in place of actual parameter values, substituted macro values and processed escape sequences.

In general there should be no need to examine the Text property. To access or change the SQL statement for the query, use the SQL property. To examine or modify parameters, use the Params property.

To check what AnyDAC sends to the DBMS, consider to use AnyDAC monitoring.

Syntax
property Text: String;
See Also

SQL

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomQuery.ExecSQL Method ()

TADCustomQuery.ExecSQL Method ()
TADCustomQuery Class uADCompClient Unit Example public See Also Send Feedback

Executes the SQL statement for the query.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example, public, See Also
Description

Call ExecSQL to execute the SQL statement currently assigned to the SQL property. Use ExecSQL to execute queries that do not return a cursor to data (such as INSERT, UPDATE, DELETE, and CREATE TABLE). For SELECT statements and others, returning cursors, call Open instead of ExecSQL. For Array DML call Execute instead of ExecSQL.

ExecSQL prepares the statement in SQL property for execution if it has not already been prepared. To speed performance, an application should ordinarily call Prepare before calling ExecSQL for the first time.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

Before command execution the BeforeExecute event is fired. If server will return command execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After command execution is finished, AfterExecute event is fired.

Syntax
procedure ExecSQL; overload;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.SQL.Text := 'insert into mytab values (:id, :name)';
ADQuery1.Params[0].AsInteger := 100;
ADQuery1.Params[0].AsString := 'qwe';
ADQuery1.ExecSQL;


TADCustomQuery.ExecSQL Method (String)

TADCustomQuery.ExecSQL Method (String)
TADCustomQuery Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified SQL statement for the query.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command text.
Returns

The number of updated rows, if any.

Description

Call ExecSQL to execute the SQL statement specified in ASQL or is currently assigned to the SQL property, if ASQL is empty. Use ExecSQL to execute queries that do not return a cursor to data (such as INSERT, UPDATE, DELETE, and CREATE TABLE), does not have parameters (such as CREATE TABLE). For SELECT statements and others, returning cursors, call Open instead of ExecSQL. For Array DML call Execute instead of ExecSQL.

ExecSQL prepares the statement in ASQL, then executes it. If an application needs to call the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling ExecSQL for the first time, then use any ExecSQL version without specifing ASQL.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

Before command execution the BeforeExecute event is fired. If server will return command execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After command execution is finished, AfterExecute event is fired.

Syntax
function ExecSQL(const ASQL: String): LongInt; overload;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.ExecSQL('create table ...');


TADCustomQuery.ExecSQL Method (String, array of Variant)

TADCustomQuery.ExecSQL Method (String, array of Variant)
TADCustomQuery Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Executes the specified SQL statement and parameter values for the query.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command text.
const AParams: array of Variant | An open array of parameter values.
Returns

The number of updated rows, if any.

Description

Call ExecSQL to execute the SQL statement specified in ASQL or is currently assigned to the SQL property, if ASQL is empty. Use ExecSQL to execute queries that do not return a cursor to data and have parameters (such as INSERT, UPDATE, DELETE). For SELECT statements and others, returning cursors, call Open instead of ExecSQL. For Array DML call Execute instead of ExecSQL.

ExecSQL prepares the statement in ASQL, then executes it. If an application needs to call the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling ExecSQL for the first time, then use any ExecSQL version without specifing ASQL.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

Before command execution the BeforeExecute event is fired. If server will return command execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After command execution is finished, AfterExecute event is fired.

Syntax
function ExecSQL(const ASQL: String; const AParams: array of Variant): LongInt; overload;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example 1
ADQuery1.ExecSQL('insert into mytab (f1, f2) values (:f1, :f2)', [100, 'qweqwe']);
Example 2
ADQuery1.SQL.Text := 'insert into mytab (f1, f2) values (:f1, :f2)';
ADQuery1.Params[0].DataType := ftInteger;
ADQuery1.Params[1].DataType := ftWideString;
ADQuery1.ExecSQL('', [100, 'qweqwe']);
ADQuery1.ExecSQL('', [101, 'asdasd']);
ADQuery1.ExecSQL('', [102, 'zxczxc']);


TADCustomQuery.ExecSQL Method (String, array of Variant, array of TFieldType)

TADCustomQuery.ExecSQL Method (String, array of Variant, array of TFieldType)
TADCustomQuery Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified SQL statement and assigns parameter values for the query.

Group

public

Links
TADCustomQuery Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command text.
const AParams: array of Variant | An open array of parameter values.
const ATypes: array of TFieldType | An open array of parameter data types.
Returns

The number of updated rows, if any.

Description

Call ExecSQL to execute the SQL statement specified in ASQL or is currently assigned to the SQL property, if ASQL is empty. Use ExecSQL to execute queries that do not return a cursor to data, have parameters (such as INSERT, UPDATE, DELETE) and will be executed only once. For SELECT statements and others, returning cursors, call Open instead of ExecSQL. For Array DML call Execute instead of ExecSQL.

This method allows to specify exact parameter data types. If you need to leave parameter data type unchanged, then put ftUnknown into array item corresponding to the parameter.

ExecSQL prepares the statement in ASQL, then executes it. If an application needs to call the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling ExecSQL for the first time, then use ExecSQL version without specifing ASQL and parameter types.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

Before command execution the BeforeExecute event is fired. If server will return command execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After command execution is finished, AfterExecute event is fired.

Syntax
function ExecSQL(const ASQL: String; const AParams: array of Variant; const ATypes: array of TFieldType): LongInt; overload;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.ExecSQL('insert into mytab (f1, f2) values (:f1, :f2)',
  [100, 'qweqwe'], [ftInteger, ftWideString]);


TADCustomSchemaAdapter Class

TADCustomSchemaAdapter Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes
Syntax
TADCustomSchemaAdapter = class(TComponent, IUnknown, IADStanErrorHandler, IADDAptUpdateHandler);


public

public
TADCustomSchemaAdapter Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADCustomSchemaAdapter class are listed here.

Class

TADCustomSchemaAdapter Class

Public Events
Name | Description
OnError |
OnReconcileRow |
OnUpdateRow |
Public Methods
Name | Description
Reconcile |
Update |
Public Properties
Name | Description
DatSManager |
TableAdaptersIntf |
Links
TADCustomSchemaAdapter Class, Legend, Public Events, Public Methods, Public Properties


TADCustomSchemaAdapter.DatSManager Property

TADCustomSchemaAdapter.DatSManager Property
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
property DatSManager: TADDatSManager;


TADCustomSchemaAdapter.OnError Event

TADCustomSchemaAdapter.OnError Event
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
property OnError: TADErrorEvent;


TADCustomSchemaAdapter.OnReconcileRow Event

TADCustomSchemaAdapter.OnReconcileRow Event
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
property OnReconcileRow: TADReconcileRowEvent;


TADCustomSchemaAdapter.OnUpdateRow Event

TADCustomSchemaAdapter.OnUpdateRow Event
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
property OnUpdateRow: TADUpdateRowEvent;


TADCustomSchemaAdapter.TableAdaptersIntf Property

TADCustomSchemaAdapter.TableAdaptersIntf Property
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
property TableAdaptersIntf: IADDAptTableAdapters;


TADCustomSchemaAdapter.Reconcile Method

TADCustomSchemaAdapter.Reconcile Method
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
function Reconcile: Boolean;


TADCustomSchemaAdapter.Update Method

TADCustomSchemaAdapter.Update Method
TADCustomSchemaAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomSchemaAdapter Class, uADCompClient Unit, public
Syntax
function Update(AMaxErrors: Integer = -1): Integer;


TADCustomStoredProc Class

TADCustomStoredProc Class
public Classes See Also Send Feedback

The class implementing dataset, capable to execute server side stored procedures.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomStoredProc to execute server side stored procedures, browse the result sets and edit the result set records.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADStoredProc.

Syntax
TADCustomStoredProc = class(TADRdbmsDataSet);
See Also

TADStoredProc, TADCustomQuery

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


public

public
TADCustomStoredProc Class Legend Public Methods Public Properties Send Feedback

The public members of the TADCustomStoredProc class are listed here.

Class

TADCustomStoredProc Class

Public Methods
Name | Description
DescriptionsAvailable | Determines if parameter information is available from the stored procedure on the server.
ExecProc | Executes the specified stored procedure in the DBMS session.
ExecProc | Executes the specified stored procedure in the DBMS session.
ExecProc | Executes the specified stored procedure and assigns parameter values for the stored proc.
ExecProc | Executes the specified stored procedure in the DBMS session.
GetResults |
Public Properties
Name | Description
CatalogName | Limits the stored procedure names to the specified catalog.
Overload | Specifies which Oracle overloaded packaged stored procedure to execute.
PackageName | Limits the stored procedure names to the specified Oracle package name.
ParamCount | Returns the number of parameters for the stored procedure.
RowsAffected | Returns the number of rows operated upon by the latest query execution.
SchemaName | Limits the stored procedure names to the specified schema.
StoredProcName | Identifies the name of the stored procedure on the server to call.
Links
TADCustomStoredProc Class, Legend, Public Methods, Public Properties


TADCustomStoredProc.CatalogName Property

TADCustomStoredProc.CatalogName Property
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Limits the stored procedure names to the specified catalog.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Description

Specify the CatalogName property value to limit the set of stored procedures to the specified catalog.

Syntax
property CatalogName: String;
See Also

SchemaName, PackageName, Overload, StoredProcName


TADCustomStoredProc.Overload Property

TADCustomStoredProc.Overload Property
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Specifies which Oracle overloaded packaged stored procedure to execute.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Description

Use Overload to specify which overloaded stored procedure to execute on an Oracle server. An Oracle overloaded stored procedure is one that shares a name with one or more other stored procedures. Oracle distinguishes among overloaded stored procedures by assigning each procedure a unique numeric identifier. An application can specify this identifier using the Overload property.

By default, Overload is zero, which assumes there is no procedure overloading. For all servers except Oracle, this value will not have the effect. If an application attempts to access an Oracle overloaded procedure without setting Overload, the AnyDAC accesses the lowest numbered, or first, overloaded procedure on the server.

If Overload is 1, the AnyDAC executes the first overloaded procedure on the server. If Overload is 2, it executes the second, and so on.

While Oracle overloaded procedures share names, their parameter lists are unique. An application must ensure that it passes the correct parameter list to an overloaded procedure.

Syntax
property Overload: Word;
See Also

Params, StoredProcName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomStoredProc.PackageName Property

TADCustomStoredProc.PackageName Property
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Limits the stored procedure names to the specified Oracle package name.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Description

Specify the PackageName property value to limit the procedure name to the specified Oracle package.

Syntax
property PackageName: String;
See Also

CatalogName, SchemaName, Overload, StoredProcName


TADCustomStoredProc.ParamCount Property

TADCustomStoredProc.ParamCount Property
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Returns the number of parameters for the stored procedure.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Description

The ParamCount property is shortcut for the Params.Count property. If the fiMeta is in FetchOptions.Items, then ParamCount corresponds to the number of actual parameters of the stored procedure.

Syntax
property ParamCount;
See Also

Params, SQL, TADResourceOptions.ParamCreate


TADCustomStoredProc.RowsAffected Property

TADCustomStoredProc.RowsAffected Property
TADCustomStoredProc Class uADCompClient Unit Example public Send Feedback

Returns the number of rows operated upon by the latest query execution.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, Example, public
Description

Inspect RowsAffected to determine how many rows were inserted, updated, deleted or fetched by the last dataset operation. If no rows were processed, RowsAffected = 0. If numbers of processed rows is not accessible, RowsAffected = –1.

Syntax
property RowsAffected;
Example
procedure TForm1.ADQuery1AfterExecute(ASender: TObject);
begin
  if ADQuery1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADQuery1.Command1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADQuery1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADQuery1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADQuery1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADQuery1.RowsAffected]);
    end;
end;


TADCustomStoredProc.SchemaName Property

TADCustomStoredProc.SchemaName Property
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Limits the stored procedure names to the specified schema.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Description

Specify the SchemaName property value to limit the set of schemas to the specified schema.

Syntax
property SchemaName: String;
See Also

CatalogName, PackageName, Overload, StoredProcName


TADCustomStoredProc.StoredProcName Property

TADCustomStoredProc.StoredProcName Property
TADCustomStoredProc Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Identifies the name of the stored procedure on the server to call.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Description

Set StoredProcName to specify the name of the stored in database procedure to call. The full name of the stored procedure will be build from CatalogName, SchemaName, PackageName, Overload property values. Also a full name may be assigned to the StoredProcName (on Oracle only for non-packaged procedures). If name is case sensitive or contains special characters, then it must be explicitly quoted.

If database does not have stored procedure with StoredProcName name, then when the application attempts to prepare the stored procedure, an exception will be raised.

Syntax
property StoredProcName: string;
See Also

CatalogName, SchemaName, PackageName, Overload

Example 1
ADStoredProc1.StoredProcName := 'Northwind.dbo.[my proc]';
// the same as following
ADStoredProc1.CatalogName := 'Northwind';
ADStoredProc1.SchemaName := 'dbo';
ADStoredProc1.StoredProcName := '[my proc]';
Example 2
ADStoredProc1.PackageName := 'sys.dbms_sql';
ADStoredProc1.StoredProcName := 'execute';


TADCustomStoredProc.DescriptionsAvailable Method

TADCustomStoredProc.DescriptionsAvailable Method
TADCustomStoredProc Class uADCompClient Unit public See Also Send Feedback

Determines if parameter information is available from the stored procedure on the server.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public, See Also
Returns

True, if info is available.

Description

Call DescriptionsAvailable to determine if a stored procedure on a server can return parameter information to the application. If DescriptionsAvailable returns True, parameter information is available from the server. If DescriptionsAvailable returns False, parameter information is not available.

Syntax
function DescriptionsAvailable: Boolean;
See Also

ExecProc, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomStoredProc.ExecProc Method ()

TADCustomStoredProc.ExecProc Method ()
TADCustomStoredProc Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified stored procedure in the DBMS session.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, Example, public, See Also
Description

Call ExecProc to execute a stored procedure in the DBMS session, using the currently assigned stored procedure name. Use ExecProc to execute stored procedures, that do not return a cursor to data.

Before calling ExecProc, assing stored procedure name to the CatalogName, SchemaName, PackageName, StoredProcName, Overload properties. Then if fiMeta in FetchOptions.Items, then call Prepare method. After that Params property will be filled by parameters. Otherwise, if fiMeta is not in FetchOptions.Items, provide correct set of parameters in the Params property, then call Prepare method. After that SQL statement, calling stored procedure, is built and parameters are binded.

Then assign values to the input parameters and call ExecProc. After return from ExecProc you can read output parameter values.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum stored procedure execution time. After that time stored procedure execution will be canceled and exception raised.

To cancel stored procedure execution use TADAdaptedDataSet.AbortJob.

Before stored procedure execution the BeforeExecute event is fired. If server will return stored procedure execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After stored procedure execution is finished, AfterExecute event is fired.

Syntax
procedure ExecProc; overload;
function ExecProc(const AProcName: String; const AParams: array of Variant; const ATypes: array of TFieldType): LongInt; overload;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADStoredProc1.StoredProcName := 'myproc';
ADStoredProc1.Prepare;
ADStoredProc1.ParamByName('inval').Value := 100;
ADStoredProc1.ExecProc;
ShowMessage(ADStoredProc1.ParamByName('outval').AsString);


TADCustomStoredProc.ExecProc Method (String)

TADCustomStoredProc.ExecProc Method (String)
TADCustomStoredProc Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified stored procedure in the DBMS session.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const AProcName: String | A stored procedure name.
Returns

The number of updated rows, if any.

Description

Call ExecProc to execute a stored procedure in the DBMS session, specified in AProcName or is currently assigned to the StoredProcName property, if AProcName is empty. Use ExecProc to execute stored procedures, that do not return a cursor to data and does not have parameters.

Before calling ExecProc, assing stored procedure additional name parts to the CatalogName, SchemaName, PackageName, Overload properties. As part of ExecProc call, the SQL statement, calling stored procedure, is built.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum stored procedure execution time. After that time stored procedure execution will be canceled and exception raised.

To cancel stored procedure execution use TADAdaptedDataSet.AbortJob.

Before stored procedure execution the BeforeExecute event is fired. If server will return stored procedure execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After stored procedure execution is finished, AfterExecute event is fired.

Syntax
function ExecProc(const AProcName: String): LongInt; overload;
See Also

CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADStoredProc1.ExecProc('myproc');


TADCustomStoredProc.ExecProc Method (String, array of Variant)

TADCustomStoredProc.ExecProc Method (String, array of Variant)
TADCustomStoredProc Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Executes the specified stored procedure and assigns parameter values for the stored proc.

Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
const AProcName: String | A stored procedure name.
const AParams: array of Variant | An open array of parameter values.
Returns

The number of updated rows, if any.

Description

Call ExecProc to execute a stored procedure in the DBMS session, specified in AProcName or is currently assigned to the StoredProcName property, if AProcName is empty. Use ExecProc to execute stored procedures, that do not return a cursor to data.

Before calling ExecProc, assing stored procedure additional name parts to the CatalogName, SchemaName, PackageName, Overload properties. As part of ExecProc call, the SQL statement, calling stored procedure, is built, parameters are binded and AParams values are assigned to the input parameters.

After return from ExecProc you can read output parameter values.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum stored procedure execution time. After that time stored procedure execution will be canceled and exception raised.

To cancel stored procedure execution use TADAdaptedDataSet.AbortJob.

Before stored procedure execution the BeforeExecute event is fired. If server will return stored procedure execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After stored procedure execution is finished, AfterExecute event is fired.

Syntax
function ExecProc(const AProcName: String; const AParams: array of Variant): LongInt; overload;
See Also

CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example 1
ADStoredProc1.ExecProc('myproc', [100, 'qweqwe']);
Example 2
ADStoredProc1.StoredProcName := 'myproc';
ADStoredProc1.ExecProc('', [100, 'qweqwe']);
ADStoredProc1.ExecProc('', [101, 'asdasd']);
ADStoredProc1.ExecProc('', [102, 'zxczxc']);


TADCustomStoredProc.GetResults Method

TADCustomStoredProc.GetResults Method
TADCustomStoredProc Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomStoredProc Class, uADCompClient Unit, public
Syntax
procedure GetResults;


TADCustomTableAdapter Class

TADCustomTableAdapter Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes
Syntax
TADCustomTableAdapter = class(TComponent, IUnknown, IADStanErrorHandler, IADDAptUpdateHandler, IADPhysDescribeHandler);


public

public
TADCustomTableAdapter Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADCustomTableAdapter class are listed here.

Class

TADCustomTableAdapter Class

Public Events
Name | Description
OnDescribeColumn |
OnDescribeTable |
OnError |
OnReconcileRow |
OnUpdateRow |
Public Methods
Name | Description
Define |
Fetch |
Fetch |
Lock |
Reconcile |
Reset |
UnLock |
Update |
Update |
Public Properties
Name | Description
ColumnMappings |
DatSManager |
DatSTable |
DatSTableName |
DeleteCommand |
FetchRowCommand |
InsertCommand |
LockCommand |
MetaInfoMergeMode |
SchemaAdapter |
SelectCommand |
SourceRecordSetID |
SourceRecordSetName |
TableAdapterIntf |
UnLockCommand |
UpdateCommand |
UpdateTableName |
UpdateTransaction |
Links
TADCustomTableAdapter Class, Legend, Public Events, Public Methods, Public Properties


TADCustomTableAdapter.ColumnMappings Property

TADCustomTableAdapter.ColumnMappings Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property ColumnMappings: TADDAptColumnMappings;


TADCustomTableAdapter.DatSManager Property

TADCustomTableAdapter.DatSManager Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property DatSManager: TADDatSManager;


TADCustomTableAdapter.DatSTable Property

TADCustomTableAdapter.DatSTable Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property DatSTable: TADDatSTable;


TADCustomTableAdapter.DatSTableName Property

TADCustomTableAdapter.DatSTableName Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property DatSTableName: String;


TADCustomTableAdapter.DeleteCommand Property

TADCustomTableAdapter.DeleteCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property DeleteCommand: TADCustomCommand;


TADCustomTableAdapter.FetchRowCommand Property

TADCustomTableAdapter.FetchRowCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property FetchRowCommand: TADCustomCommand;


TADCustomTableAdapter.InsertCommand Property

TADCustomTableAdapter.InsertCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property InsertCommand: TADCustomCommand;


TADCustomTableAdapter.LockCommand Property

TADCustomTableAdapter.LockCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property LockCommand: TADCustomCommand;


TADCustomTableAdapter.MetaInfoMergeMode Property

TADCustomTableAdapter.MetaInfoMergeMode Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property MetaInfoMergeMode: TADPhysMetaInfoMergeMode;


TADCustomTableAdapter.OnDescribeColumn Event

TADCustomTableAdapter.OnDescribeColumn Event
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property OnDescribeColumn: TADDescribeColumnEvent;


TADCustomTableAdapter.OnDescribeTable Event

TADCustomTableAdapter.OnDescribeTable Event
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property OnDescribeTable: TADDescribeTableEvent;


TADCustomTableAdapter.OnError Event

TADCustomTableAdapter.OnError Event
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property OnError: TADErrorEvent;


TADCustomTableAdapter.OnReconcileRow Event

TADCustomTableAdapter.OnReconcileRow Event
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property OnReconcileRow: TADReconcileRowEvent;


TADCustomTableAdapter.OnUpdateRow Event

TADCustomTableAdapter.OnUpdateRow Event
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property OnUpdateRow: TADUpdateRowEvent;


TADCustomTableAdapter.SchemaAdapter Property

TADCustomTableAdapter.SchemaAdapter Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property SchemaAdapter: TADCustomSchemaAdapter;


TADCustomTableAdapter.SelectCommand Property

TADCustomTableAdapter.SelectCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property SelectCommand: TADCustomCommand;


TADCustomTableAdapter.SourceRecordSetID Property

TADCustomTableAdapter.SourceRecordSetID Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property SourceRecordSetID: Integer;


TADCustomTableAdapter.SourceRecordSetName Property

TADCustomTableAdapter.SourceRecordSetName Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property SourceRecordSetName: String;


TADCustomTableAdapter.TableAdapterIntf Property

TADCustomTableAdapter.TableAdapterIntf Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property TableAdapterIntf: IADDAptTableAdapter;


TADCustomTableAdapter.UnLockCommand Property

TADCustomTableAdapter.UnLockCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property UnLockCommand: TADCustomCommand;


TADCustomTableAdapter.UpdateCommand Property

TADCustomTableAdapter.UpdateCommand Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property UpdateCommand: TADCustomCommand;


TADCustomTableAdapter.UpdateTableName Property

TADCustomTableAdapter.UpdateTableName Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property UpdateTableName: String;


TADCustomTableAdapter.UpdateTransaction Property

TADCustomTableAdapter.UpdateTransaction Property
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
property UpdateTransaction: TADCustomTransaction;


TADCustomTableAdapter.Define Method

TADCustomTableAdapter.Define Method
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
function Define: TADDatSTable;


TADCustomTableAdapter.Fetch Method (Boolean)

TADCustomTableAdapter.Fetch Method (Boolean)
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure Fetch(AAll: Boolean = False); overload;


TADCustomTableAdapter.Fetch Method (TADDatSRow, TADErrorAction, Integer, TADPhysFillRowOptions)

TADCustomTableAdapter.Fetch Method (TADDatSRow, TADErrorAction, Integer, TADPhysFillRowOptions)
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure Fetch(ARow: TADDatSRow; var AAction: TADErrorAction; AColumn: Integer; ARowOptions: TADPhysFillRowOptions); overload;


TADCustomTableAdapter.Lock Method

TADCustomTableAdapter.Lock Method
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure Lock(ARow: TADDatSRow; var AAction: TADErrorAction; AUpdRowOptions: TADPhysUpdateRowOptions = []);


TADCustomTableAdapter.Reconcile Method

TADCustomTableAdapter.Reconcile Method
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
function Reconcile: Boolean;


TADCustomTableAdapter.Reset Method

TADCustomTableAdapter.Reset Method
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure Reset;


TADCustomTableAdapter.UnLock Method

TADCustomTableAdapter.UnLock Method
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure UnLock(ARow: TADDatSRow; var AAction: TADErrorAction; AUpdRowOptions: TADPhysUpdateRowOptions = []);


TADCustomTableAdapter.Update Method (Integer)

TADCustomTableAdapter.Update Method (Integer)
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
function Update(AMaxErrors: Integer = -1): Integer; overload;


TADCustomTableAdapter.Update Method (TADDatSRow, TADErrorAction, TADPhysUpdateRowOptions, TADPhysRequest)

TADCustomTableAdapter.Update Method (TADDatSRow, TADErrorAction, TADPhysUpdateRowOptions, TADPhysRequest)
TADCustomTableAdapter Class uADCompClient Unit public Send Feedback
Group

public

Links
TADCustomTableAdapter Class, uADCompClient Unit, public
Syntax
procedure Update(ARow: TADDatSRow; var AAction: TADErrorAction; AUpdRowOptions: TADPhysUpdateRowOptions = []; AForceRequest: TADPhysRequest = arFromRow); overload;


TADCustomTransaction Class

TADCustomTransaction Class
public Classes See Also Send Feedback

The class is responsible to transaction management for connection.

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

Use TADCustomTransaction to manage transactions in connection to a DBMS.

The component, at first, is target to Interbase / Firebird client application developers.

This class hides some of properties, allowing to control visibility of properties by descendant classes. End users should use TADTransaction.

Syntax
TADCustomTransaction = class(TComponent, IADPhysTransactionStateHandler);
See Also

TADTransaction, TADCustomConnection

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


public

public
TADCustomTransaction Class Legend Public Methods Public Properties Send Feedback

The public members of the TADCustomTransaction class are listed here.

Class

TADCustomTransaction Class

Public Methods
Name | Description
Commit | Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.
CommitRetaining | Permanently stores modifications to the data made in the current transaction, without ending the current transaction.
Rollback | Cancels all modifications to the data made in the current transaction and optionally ends transaction.
RollbackRetaining | Cancels all modifications to the data made in the current transaction, without ending the current transaction.
StartTransaction | Starts new transaction at database.
Public Properties
Name | Description
Connection | Specifies the connection component that actually forms the connection to the DBMS.
DataSetCount | Returns the number of datasets associated with this transaction.
DataSets | Returns the dataset associated with this transaction by it index.
IsActive | Indicates whether a database transaction is in progress or not.
Options | The set of options controlling transactions behaviour.
TransactionIntf | Returns IADPhysTransaction interface.
Links
TADCustomTransaction Class, Legend, Public Methods, Public Properties


TADCustomTransaction.Connection Property

TADCustomTransaction.Connection Property
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Specifies the connection component that actually forms the connection to the DBMS.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

Set Connection to the connection component that establishes a connection to the DBMS. If to change Connection property value, while transaction is active, an exception will be raised.

Syntax
property Connection: TADCustomConnection;
See Also

IsActive

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomTransaction.DataSetCount Property

TADCustomTransaction.DataSetCount Property
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Returns the number of datasets associated with this transaction.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

Returns the number of datasets whos TADRdbmsDataSet.Transaction property points to this transaction.

Syntax
property DataSetCount: Integer;
See Also

TADRdbmsDataSet.Transaction, DataSets

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomTransaction.DataSets Property

TADCustomTransaction.DataSets Property
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Returns the dataset associated with this transaction by it index.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

Returns the dataset whos TADRdbmsDataSet.Transaction property points to this transaction by dataset index.

Syntax
property DataSets [AIndex: Integer]: TADDataSet;
See Also

DataSetCount

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomTransaction.IsActive Property

TADCustomTransaction.IsActive Property
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Indicates whether a database transaction is in progress or not.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

Examine IsActive at run-time to determine if a database transaction is currently in progress. IsActive is True if a transaction is in progress, False otherwise.

The value of IsActive cannot be changed directly. Calling StartTransaction sets IsActive to True. Calling Commit or Rollback sets IsActive to False.

Syntax
property IsActive: Boolean;
See Also

StartTransaction, Commit, Rollback

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomTransaction.Options Property

TADCustomTransaction.Options Property
TADCustomTransaction Class uADCompClient Unit Example public See Also Send Feedback

The set of options controlling transactions behaviour.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, Example, public, See Also
Description

The Options property returns reference to object, consisting of the set of options, controlling transactions behaviour. Changing options will not take immediate effect, it is deferred until first transaction control statement.

Syntax
property Options: TADTxOptions;
See Also

StartTransaction, Commit, Rollback

Example
ADTransaction1.Options.ReadOnly := True;
ADTransaction1.StartTransaction;


TADCustomTransaction.TransactionIntf Property

TADCustomTransaction.TransactionIntf Property
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Returns IADPhysTransaction interface.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

The TransactionIntf property returns the reference to the IADPhysTransaction interface. It is not nil, if the connection. Otherwise it is nil. It is not recommended to mix usage of TADCommand API and TADCommand.CommandIntf API.

Syntax
property TransactionIntf: IADPhysTransaction;
See Also

IADPhysTransaction

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADCustomTransaction.Commit Method

TADCustomTransaction.Commit Method
TADCustomTransaction Class uADCompClient Unit Example public See Also Send Feedback

Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, Example, public, See Also
Description

Call Commit to permanently store modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

Before calling Commit, an application may check the status of the InActive property. If an application calls Commit and there is no current transaction, an exception is raised.

Commit call on Interbase / Firebird will close and unprepare all datasets and commands, associated with this transaction object.

Syntax
procedure Commit;
See Also

StartTransaction, IsActive, Rollback, CommitRetaining

Example
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'update employees set salary = salary * :k where id = :id';
  ADTransaction1.StartTransaction;
  try
    ADQuery1.ExecSQL('', [1.2, 100]);
    ADQuery1.ExecSQL('', [1.3, 200]);
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


TADCustomTransaction.CommitRetaining Method

TADCustomTransaction.CommitRetaining Method
TADCustomTransaction Class uADCompClient Unit Example public See Also Send Feedback

Permanently stores modifications to the data made in the current transaction, without ending the current transaction.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, Example, public, See Also
Description

Call CommitRetaining to permanently store modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database without finishing transaction.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints. CommitRetaining is usefull only for main transaction, not for nested ones.

Before calling CommitRetaining, an application may check the status of the InActive property. If an application calls CommitRetaining and there is no current transaction, an exception is raised.

CommitRetaining will use native functionality on IB/FB. On other DBMS's the method will be equal to calls of Commit, then of StartTransaction.

Syntax
procedure CommitRetaining;
See Also

StartTransaction, IsActive, Rollback, Commit

Example
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'select * from employees';

  ADQuery2.Transaction := ADTransaction1;
  ADQuery2.SQL.Text := 'update employees set salary = salary * :k where id = :id';

  ADTransaction1.StartTransaction;
  try
    ADQuery1.Open;
    while not ADQuery1.Eof do begin
      ADQuery2.ExecSQL('', [1.2, ADQuery1.FieldByName('id').AsInteger]);
      ADTransaction1.CommitRetaining;
      ADQuery1.Next;
    end;
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


TADCustomTransaction.Rollback Method

TADCustomTransaction.Rollback Method
TADCustomTransaction Class uADCompClient Unit Example public See Also Send Feedback

Cancels all modifications to the data made in the current transaction and optionally ends transaction.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, Example, public, See Also
Description

Call Rollback to cancel all modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

Before calling Rollback, an application may check the status of the InActive property. If an application calls Rollback and there is no current transaction, an exception is raised.

Rollback call on Interbase / Firebird will close and unprepare all datasets and commands, associated with this transaction object.

Syntax
procedure Rollback;
See Also

StartTransaction, IsActive, Commit, RollbackRetaining

Example
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'update employees set salary = salary * :k where id = :id';
  ADTransaction1.StartTransaction;
  try
    ADQuery1.ExecSQL('', [1.2, 100]);
    ADQuery1.ExecSQL('', [1.3, 200]);
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


TADCustomTransaction.RollbackRetaining Method

TADCustomTransaction.RollbackRetaining Method
TADCustomTransaction Class uADCompClient Unit public See Also Send Feedback

Cancels all modifications to the data made in the current transaction, without ending the current transaction.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, public, See Also
Description

Call RollbackRetaining to cancel all modifications, like a INSERT's / UPDATE's / DELETE's, made in current transaction to the database.

AnyDAC supports nested transactions, so the current transaction is the one started with most recent StartTransaction call. If the database does not support nested transactions, like most of DBMS's, then AnyDAC will emulate nested transactions using savepoints.

Before calling RollbackRetaining, an application may check the status of the InActive property. If an application calls RollbackRetaining and there is no current transaction, an exception is raised.

RollbackRetaining will use native functionality on IB/FB. On other DBMS's the method will be equal to calls of Rollback, then of StartTransaction.

Syntax
procedure RollbackRetaining;
See Also

StartTransaction, InTransaction, Commit, Rollback


TADCustomTransaction.StartTransaction Method

TADCustomTransaction.StartTransaction Method
TADCustomTransaction Class uADCompClient Unit Example public See Also Send Feedback

Starts new transaction at database.

Group

public

Links
TADCustomTransaction Class, uADCompClient Unit, Example, public, See Also
Description

Call StartTransaction to start a new transaction at the DBMS.

The AnyDAC supports nested transactions, emulating them by savepoints. If transaction is already active, then AnyDAC will put savepoint.

Before calling StartTransaction, an application should adjust settings of the Options property as desired.

All data modifications, like a INSERT's / UPDATE's / DELETE's, made after a call of StartTransaction, may be either confirmed by calling Commit, either undone by calling Rollback.

Syntax
procedure StartTransaction;
See Also

IsActive, Commit, Rollback, Options

Example
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'select * from employees';

  ADQuery2.Transaction := ADTransaction1;
  ADQuery2.SQL.Text := 'update employees set salary = salary * :k where id = :id';

  ADTransaction1.Options.Isolation := xiRepeatableRead;
  ADTransaction1.StartTransaction;
  try
    ADQuery1.Open;
    while not ADQuery1.Eof do begin
      ADQuery2.ExecSQL('', [1.2, ADQuery1.FieldByName('id').AsInteger]);
      ADTransaction1.CommitRetaining;
      ADQuery1.Next;
    end;
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


TADCustomUpdateObject Class

TADCustomUpdateObject Class
public Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

..

Syntax
TADCustomUpdateObject = class(TADComponent);
See Also

..


public

public
TADCustomUpdateObject Class Legend Public Methods Public Properties Send Feedback

The public members of the TADCustomUpdateObject class are listed here.

Class

TADCustomUpdateObject Class

Public Methods
Name | Description
Apply | Applies record update request to DB for current record in DataSet.
Public Properties
Name | Description
DataSet | Identifies the dataset on which change log update object will operate.
Links
TADCustomUpdateObject Class, Legend, Public Methods, Public Properties


TADCustomUpdateObject.DataSet Property

TADCustomUpdateObject.DataSet Property
TADCustomUpdateObject Class uADCompClient Unit public See Also Send Feedback

Identifies the dataset on which change log update object will operate.

Group

public

Links
TADCustomUpdateObject Class, uADCompClient Unit, public, See Also
Description

TADCustomUpdateObject uses the DataSet property for two purposes:

  • It fetches the original and updated field values from this dataset when performing parameter substitution.
  • If this dataset is a TADRdbmsDataSet descendant, it uses its Connection and ConnectionName properties to identify the connection that it uses when performing its update queries.

If you are using a single update object, then the DataSet property is set automatically when you set the source dataset's UpdateObject property. If you are using multiple update objects, you must set the DataSet property at runtime in an OnUpdateRecord event handler.

Syntax
property DataSet: TADAdaptedDataSet;
See Also

TADDataSet.OnUpdateRecord, TADRdbmsDataSet.Connection, TADRdbmsDataSet.ConnectionName


TADCustomUpdateObject.Apply Method

TADCustomUpdateObject.Apply Method
TADCustomUpdateObject Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Applies record update request to DB for current record in DataSet.

Group

public

Links
TADCustomUpdateObject Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
ARequest: TADPhysUpdateRequest | A record update request.
var AAction: TADErrorAction | A completion status.
AOptions: TADPhysUpdateRowOptions | An additional request options.
Description

Call Apply to apply changes of current record in DataSet to database. ARequest indicates which update request must be handled.

Standard implementation - TADUpdateSQL - sets parameters for an SQL statement and execute it to update a record. So, ARequest indicates which SQL statement to bind and execute. If appropriate SQL statement is not specified, then AnyDAC will generate default one, as it is doing if TADAdaptedDataSet.UpdateObject is not specified.

ARequest update request can be one of the following values:

Value | Meaning | TADUpdateSQL SQL property
arInsert | Insert record to database. | InsertSQL
arUpdate | Update record in database. | ModifySQL
arDelete | Delete record from database. | DeleteSQL
arLock | Lock record in database. | LockSQL
arUnlock | Release record lock in database. | UnlockSQL
arFetchRow | Refetch record from database. | FetchRowSQL
arUpdateHBlobs | Update Oracle BLOB/CLOB values in database. | -
arFetchGenerators | Fetch generator values to put into record. | -

Apply is primarily intended for manually executing update statements from an OnUpdateRecord event handler. There event handler ARequest, AAction and AOptions argument values must be assigned to Apply method corresponding arguments.

Syntax
procedure Apply(ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction; AOptions: TADPhysUpdateRowOptions); virtual; abstract;
See Also

TADUpdateSQL, TADAdaptedDataSet.UpdateObject

Example 1
procedure TfrmCachedUpdates.qrProductsUpdateRecord(ASender: TDataSet;
      ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction;
      AOptions: TADPhysUpdateRowOptions);
begin
  usProducts.ConnectionName := qrProducts.ConnectionName;
  usProducts.DataSet := qrProducts;
  usProducts.Apply(ARequest, AAction, AOptions);

  usCategories.ConnectionName := qrProducts.ConnectionName;
  usCategories.DataSet := qrProducts;
  usCategories.Apply(ARequest, AAction, AOptions);

  AAction := eaApplied;
end;
Example 2

See AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main demo application.


TADManager Class

TADManager Class
published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

..

Syntax
TADManager = class(TADCustomManager);
See Also

..


published

published
TADManager Class Legend Published Events Published Properties Send Feedback

The published members of the TADManager class are listed here.

Class

TADManager Class

Published Events
Name | Description
AfterLoadConnectionDefFile | Fires after connection definitions file is loaded.
BeforeLoadConnectionDefFile | Fires before connection definitions file is loaded.
OnShutdown | Fires after manager is finished.
OnStartup | Fires after manager is started.
Published Properties
Name | Description
Active | Gets or sets AnyDAC manager active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
ConnectionDefFileAutoLoad | Controls how connection definitions file must be loaded.
ConnectionDefFileName | Gets / sets the name of a connection definitions file.
DriverDefFileAutoLoad | Controls how driver definitions file must be loaded.
DriverDefFileName | Gets / sets the name of a driver definitions file.
FetchOptions | The "root" fetch options.
FormatOptions | The "root" data format options.
ResourceOptions | The "root" resources control options.
SilentMode | Gets or sets AnyDAC global "silent" flag.
UpdateOptions | The "root" data updating options.
WaitCursor | Gets or sets AnyDAC wait cursor shape.
Links
TADManager Class, Legend, Published Events, Published Properties


TADManager.Active Property

TADManager.Active Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Gets or sets AnyDAC manager active status.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

Set Active to True to activate AnyDAC manager. After that the State = dmsActive. At activating, ADPhysManager loads driver definition file, allocates internal driver structures (does not load DBMC client DLL) and runs driver management thread. So, if it is required, set DriverDefFileAutoLoad and DriverDefFileName before activating manager.

Set Active to False to terminate AnyDAC manager. After that the State = dmsInactive. At terminating, manager calls TADCustomConnection.Close for all connection objects in application, ADPhysManager waits until all connections interfaces (IADPhysConnection) will be released, unloads DBMS client DLL's and releases internal driver structures.

TADCustomConnection activates manager automatically before first time connection.

Notes

To change any driver settings, manager must be inactive.

Syntax
property Active: Boolean;
See Also

DriverDefFileAutoLoad, DriverDefFileName, Open, Close


TADManager.ActiveStoredUsage Property

TADManager.ActiveStoredUsage Property
TADManager Class uADCompClient Unit published Send Feedback

Controls how to use Active property value saved to DFM.

Group

published

Links
TADManager Class, uADCompClient Unit, published
Description

The ActiveStoredUsage property controls how to use Active property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADManager.AfterLoadConnectionDefFile Event

TADManager.AfterLoadConnectionDefFile Event
TADManager Class uADCompClient Unit published See Also Send Feedback

Fires after connection definitions file is loaded.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The AfterLoadConnectionDefFile event is fired after the connection definitions file is loaded.

Syntax
property AfterLoadConnectionDefFile: TNotifyEvent;
See Also

BeforeLoadConnectionDefFile

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.BeforeLoadConnectionDefFile Event

TADManager.BeforeLoadConnectionDefFile Event
TADManager Class uADCompClient Unit published See Also Send Feedback

Fires before connection definitions file is loaded.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The BeforeLoadConnectionDefFile event is fired before the connection definitions file is loaded.

Syntax
property BeforeLoadConnectionDefFile: TNotifyEvent;
See Also

AfterLoadConnectionDefFile

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.ConnectionDefFileAutoLoad Property

TADManager.ConnectionDefFileAutoLoad Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Controls how connection definitions file must be loaded.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The ConnectionDefFileAutoLoad property controls, should be a connection definition file loaded automatically or explicitly by programmer. If True, then AnyDAC will load file at first "touch" to the content of the ConnectionDefs list.

If False, then programmer should call ConnectionDefs.Load method before first "touch" to the ConnectionDefs list, including:

  • opening a connection referencing to a connection definition by its name (see TADCustomConnection.ConnectionDefName);
  • iterating through existing connection definitions (see TADCustomManager.ConnectionDefs);
  • adding new connection definition, deleting existing connection definition or looking for existing connection definition (see TADCustomManager.ConnectionDefs);

Otherwise an exception will be raised.

Syntax
property ConnectionDefFileAutoLoad: Boolean;
See Also

ConnectionDefs, ConnectionDefFileLoaded, ConnectionDefFileName, LoadConnectionDefFile


TADManager.ConnectionDefFileName Property

TADManager.ConnectionDefFileName Property
TADManager Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Gets / sets the name of a connection definitions file.

Group

published

Links
TADManager Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The ConnectionDefFileName property allows to get or set the name of a connection definition file.

The application can set the name before connection definitions file will be loaded. For example in BeforeLoadConnectionDefFile event handler.

Syntax
property ConnectionDefFileName: String;
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded

Example 1
ADManager.ConnectionDefFileName := ExtractFilePath(Application.ExeName) + 'myconndef.ini';
ADManager.ConnectionDefFileAutoLoad := True;
oConn := TADConnection.Create(nil);
oConn.ConnectionDefName := 'myconn';
oConn.Connected := True;
Example 2
procedure TMyDataModule.DoBeforeLoad(ASender: TNotifyEvent);
begin
  ADManager.ConnectionDefFileName := FSettings.MyConnectionDefFile;
end;
...
ADManager.BeforeLoadConnectionDefFile := DoBeforeLoad;


TADManager.DriverDefFileAutoLoad Property

TADManager.DriverDefFileAutoLoad Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Controls how driver definitions file must be loaded.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The DriverDefFileAutoLoad property controls, should be driver definition file loaded automatically or explicitly by programmer. If True, then AnyDAC will load file at manager activation.

If False, then programmer should call ADPhysManager.DriverDefs.Load method before manager activation. Otherwise an exception will be raised.

Syntax
property DriverDefFileAutoLoad: Boolean;
See Also

DriverDefFileName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.DriverDefFileName Property

TADManager.DriverDefFileName Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Gets / sets the name of a driver definitions file.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The DriverDefFileName property allows to get or set the name of a driver definition file. The application can set the name before manager activation.

Syntax
property DriverDefFileName: String;
See Also

DriverDefFileAutoLoad

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.FetchOptions Property

TADManager.FetchOptions Property
TADManager Class uADCompClient Unit published See Also Send Feedback

The "root" fetch options.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The FetchOptions property returns the reference to the "root" instance of the fetch options. These options control how the data will be fetched and cached in the memory.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property FetchOptions: TADFetchOptions;
See Also

FormatOptions, UpdateOptions, ResourceOptions


TADManager.FormatOptions Property

TADManager.FormatOptions Property
TADManager Class uADCompClient Unit published See Also Send Feedback

The "root" data format options.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The FormatOptions property returns the reference to the "root" instance of the data format options. These options control how the DBMS data types will be mapped into dataset data types.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property FormatOptions: TADFormatOptions;
See Also

FetchOptions, UpdateOptions, ResourceOptions


TADManager.OnShutdown Event

TADManager.OnShutdown Event
TADManager Class uADCompClient Unit published See Also Send Feedback

Fires after manager is finished.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The OnShutdown event is fired after AnyDAC manager is terminated.

Syntax
property OnShutdown: TNotifyEvent;
See Also

Active, Close, OnStartup

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.OnStartup Event

TADManager.OnStartup Event
TADManager Class uADCompClient Unit published See Also Send Feedback

Fires after manager is started.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The OnStartup event is fired after AnyDAC manager is started.

Syntax
property OnStartup: TNotifyEvent;
See Also

Active, Open, OnShutdown

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADManager.ResourceOptions Property

TADManager.ResourceOptions Property
TADManager Class uADCompClient Unit published See Also Send Feedback

The "root" resources control options.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The ResourceOptions property returns the reference to the "root" instance of the resources control options. These options control how AnyDAC should use DBMS and workstation resources.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomCommand's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property ResourceOptions: TADResourceOptions;
See Also

FetchOptions, UpdateOptions, FormatOptions


TADManager.SilentMode Property

TADManager.SilentMode Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Gets or sets AnyDAC global "silent" flag.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

Set SilentMode to True to not show wait cursors and dialogs. This flag is application wide. Its value overrides all TADResourceOptions.SilentMode values.

Syntax
property SilentMode: Boolean;
See Also

TADResourceOptions.SilentMode, WaitCursor


TADManager.UpdateOptions Property

TADManager.UpdateOptions Property
TADManager Class uADCompClient Unit published See Also Send Feedback

The "root" data updating options.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The UpdateOptions property returns the reference to the "root" instance of the data updating options. These options control how AnyDAC should post data changes back to a DB.

The option values will be inherited by all TADCustomConnection's and, consequently, by all TADCustomTableAdapter's and all datasets in application.

See Setting options for review of how to work with options.

Syntax
property UpdateOptions: TADUpdateOptions;
See Also

FetchOptions, ResourceOptions, FormatOptions


TADManager.WaitCursor Property

TADManager.WaitCursor Property
TADManager Class uADCompClient Unit published See Also Send Feedback

Gets or sets AnyDAC wait cursor shape.

Group

published

Links
TADManager Class, uADCompClient Unit, published, See Also
Description

The WaitCursor property gets or sets the wait cursor shape.

Syntax
property WaitCursor: TADGUIxScreenCursor;
See Also

SilentMode

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMemTable Class

TADMemTable Class
published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

..

Syntax
TADMemTable = class(TADCustomMemTable);
See Also

..


published

published
TADMemTable Class Legend Published Events Published Properties Send Feedback

The published members of the TADMemTable class are listed here.

Class

TADMemTable Class

Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterExecute |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeExecute |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnDeleteError |
OnEditError |
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Adapter | Reference to a data adapter.
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
Constraints |
ConstraintsEnabled |
DataSetField |
FetchOptions |
FieldDefs |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
IndexDefs |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MasterFields |
MasterSource |
ObjectView |
ResourceOptions |
StoreDefs |
UpdateOptions |
Links
TADMemTable Class, Legend, Published Events, Published Properties


TADMemTable.Active Property

TADMemTable.Active Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Active;


TADMemTable.ActiveStoredUsage Property

TADMemTable.ActiveStoredUsage Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADMemTable.Adapter Property

TADMemTable.Adapter Property
TADMemTable Class uADCompClient Unit published See Also Send Feedback

Reference to a data adapter.

Group

published

Links
TADMemTable Class, uADCompClient Unit, published, See Also
Description

Use this property to get/set data adapter for dataset. The dataset will use data adapter to talk to DBMS, when he needs to execute query, fetch rows, post changes back to DBMS.

Syntax
property Adapter: TADCustomTableAdapter;
See Also

TADCustomTableAdapter

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMemTable.AfterApplyUpdates Event

TADMemTable.AfterApplyUpdates Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterApplyUpdates: TADAfterApplyUpdatesEvent;


TADMemTable.AfterCancel Property

TADMemTable.AfterCancel Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterCancel;


TADMemTable.AfterClose Property

TADMemTable.AfterClose Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterClose;


TADMemTable.AfterDelete Property

TADMemTable.AfterDelete Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterDelete;


TADMemTable.AfterEdit Property

TADMemTable.AfterEdit Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterEdit;


TADMemTable.AfterExecute Event

TADMemTable.AfterExecute Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterExecute: TADDataSetEvent;


TADMemTable.AfterGetRecords Event

TADMemTable.AfterGetRecords Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterGetRecords: TADDataSetEvent;


TADMemTable.AfterInsert Property

TADMemTable.AfterInsert Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterInsert;


TADMemTable.AfterOpen Property

TADMemTable.AfterOpen Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterOpen;


TADMemTable.AfterPost Property

TADMemTable.AfterPost Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterPost;


TADMemTable.AfterRefresh Property

TADMemTable.AfterRefresh Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterRefresh;


TADMemTable.AfterRowRequest Event

TADMemTable.AfterRowRequest Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterRowRequest: TADDataSetEvent;


TADMemTable.AfterScroll Property

TADMemTable.AfterScroll Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AfterScroll;


TADMemTable.Aggregates Property

TADMemTable.Aggregates Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Aggregates: TADAggregates;


TADMemTable.AggregatesActive Property

TADMemTable.AggregatesActive Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AggregatesActive: Boolean;


TADMemTable.AutoCalcFields Property

TADMemTable.AutoCalcFields Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property AutoCalcFields;


TADMemTable.BeforeApplyUpdates Event

TADMemTable.BeforeApplyUpdates Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeApplyUpdates: TADDataSetEvent;


TADMemTable.BeforeCancel Property

TADMemTable.BeforeCancel Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeCancel;


TADMemTable.BeforeClose Property

TADMemTable.BeforeClose Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeClose;


TADMemTable.BeforeDelete Property

TADMemTable.BeforeDelete Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeDelete;


TADMemTable.BeforeEdit Property

TADMemTable.BeforeEdit Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeEdit;


TADMemTable.BeforeExecute Event

TADMemTable.BeforeExecute Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeExecute: TADDataSetEvent;


TADMemTable.BeforeGetRecords Event

TADMemTable.BeforeGetRecords Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeGetRecords: TADDataSetEvent;


TADMemTable.BeforeInsert Property

TADMemTable.BeforeInsert Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeInsert;


TADMemTable.BeforeOpen Property

TADMemTable.BeforeOpen Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeOpen;


TADMemTable.BeforePost Property

TADMemTable.BeforePost Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforePost;


TADMemTable.BeforeRefresh Property

TADMemTable.BeforeRefresh Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeRefresh;


TADMemTable.BeforeRowRequest Event

TADMemTable.BeforeRowRequest Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeRowRequest: TADDataSetEvent;


TADMemTable.BeforeScroll Property

TADMemTable.BeforeScroll Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property BeforeScroll;


TADMemTable.CachedUpdates Property

TADMemTable.CachedUpdates Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property CachedUpdates: Boolean;


TADMemTable.Constraints Property

TADMemTable.Constraints Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Constraints;


TADMemTable.ConstraintsEnabled Property

TADMemTable.ConstraintsEnabled Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property ConstraintsEnabled: Boolean;


TADMemTable.DataSetField Property

TADMemTable.DataSetField Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property DataSetField;


TADMemTable.FetchOptions Property

TADMemTable.FetchOptions Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property FetchOptions: TADFetchOptions;


TADMemTable.FieldDefs Property

TADMemTable.FieldDefs Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property FieldDefs;


TADMemTable.Filter Property

TADMemTable.Filter Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Filter;


TADMemTable.FilterChanges Property

TADMemTable.FilterChanges Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property FilterChanges: TUpdateRecordTypes;


TADMemTable.Filtered Property

TADMemTable.Filtered Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Filtered;


TADMemTable.FilterOptions Property

TADMemTable.FilterOptions Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property FilterOptions;


TADMemTable.FormatOptions Property

TADMemTable.FormatOptions Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property FormatOptions: TADFormatOptions;


TADMemTable.IndexDefs Property

TADMemTable.IndexDefs Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property IndexDefs: TIndexDefs;


TADMemTable.Indexes Property

TADMemTable.Indexes Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property Indexes: TADIndexes;


TADMemTable.IndexesActive Property

TADMemTable.IndexesActive Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property IndexesActive: Boolean;


TADMemTable.IndexFieldNames Property

TADMemTable.IndexFieldNames Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property IndexFieldNames: String;


TADMemTable.IndexName Property

TADMemTable.IndexName Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property IndexName: String;


TADMemTable.MasterFields Property

TADMemTable.MasterFields Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property MasterFields: String;


TADMemTable.MasterSource Property

TADMemTable.MasterSource Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property MasterSource: TDataSource;


TADMemTable.ObjectView Property

TADMemTable.ObjectView Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property ObjectView;


TADMemTable.OnCalcFields Property

TADMemTable.OnCalcFields Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnCalcFields;


TADMemTable.OnDeleteError Property

TADMemTable.OnDeleteError Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnDeleteError;


TADMemTable.OnEditError Property

TADMemTable.OnEditError Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnEditError;


TADMemTable.OnFilterRecord Property

TADMemTable.OnFilterRecord Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnFilterRecord;


TADMemTable.OnNewRecord Property

TADMemTable.OnNewRecord Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnNewRecord;


TADMemTable.OnPostError Property

TADMemTable.OnPostError Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnPostError;


TADMemTable.OnReconcileError Event

TADMemTable.OnReconcileError Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnReconcileError: TADReconcileErrorEvent;


TADMemTable.OnUpdateError Event

TADMemTable.OnUpdateError Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnUpdateError: TADUpdateErrorEvent;


TADMemTable.OnUpdateRecord Event

TADMemTable.OnUpdateRecord Event
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property OnUpdateRecord: TADUpdateRecordEvent;


TADMemTable.ResourceOptions Property

TADMemTable.ResourceOptions Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property ResourceOptions: TADResourceOptions;


TADMemTable.StoreDefs Property

TADMemTable.StoreDefs Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property StoreDefs;


TADMemTable.UpdateOptions Property

TADMemTable.UpdateOptions Property
TADMemTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMemTable Class, uADCompClient Unit, published
Syntax
property UpdateOptions: TADUpdateOptions;


TADMetaInfoCommand Class

TADMetaInfoCommand Class
public published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, published, Classes, See Also
Description

..

Syntax
TADMetaInfoCommand = class(TADCustomCommand);
See Also

..


public

public
TADMetaInfoCommand Class Legend Public Methods Send Feedback

The public members of the TADMetaInfoCommand class are listed here.

Class

TADMetaInfoCommand Class

Public Methods
Name | Description
Create |
Links
TADMetaInfoCommand Class, Legend, Public Methods


TADMetaInfoCommand.Create Constructor

TADMetaInfoCommand.Create Constructor
TADMetaInfoCommand Class uADCompClient Unit public Send Feedback
Group

public

Links
TADMetaInfoCommand Class, uADCompClient Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


published

published
TADMetaInfoCommand Class Legend Published Events Published Properties Send Feedback

The published members of the TADMetaInfoCommand class are listed here.

Class

TADMetaInfoCommand Class

Published Events
Name | Description
AfterClose | The event fires after command is closed.
AfterOpen | The event fires after command is opened.
BeforeClose | The event fires before command will be closed.
BeforeOpen | The event fires before command will be opened.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.
Published Properties
Name | Description
Active | Gets or sets command active status.
BaseObjectName | Gets / sets the name of base object.
CatalogName | Identifies catalog name for some command kinds.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FormatOptions | The set of options to control data representation.
MetaInfoKind | Gets / sets the kind of metadata to retrieve.
ObjectName | Gets / sets the name of object to get detailed information about it.
ObjectScopes | Gets / sets object scopes filter.
Overload | Oracle stored procedure overload index.
SchemaName | Identifies schema name for some of command kinds.
TableKinds | Gets / sets table kind filter.
Wildcard | Gets / sets objects filter by their name.
Links
TADMetaInfoCommand Class, Legend, Published Events, Published Properties


TADMetaInfoCommand.Active Property

TADMetaInfoCommand.Active Property
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

Gets or sets command active status.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

Set Active to True to execute SQL command and return cursor. After that the State = csOpen and you can fetch rows from current cursor using Fetch method. Setting Active to True, will call Open method.

Set Active to False to close current command cursor. After that State = csPrepared. Setting Active to False, will call Close method. To close all command cursors (if command returns multiple result sets), use CloseAll method.

Syntax
property Active: Boolean;
See Also

Fetch, Define, Open, Close, CloseAll, State

Example
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


TADMetaInfoCommand.AfterClose Event

TADMetaInfoCommand.AfterClose Event
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is closed.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The AfterClose event fires, after command is closed by calling Close or setting Active = False.

Syntax
property AfterClose: TNotifyEvent;
See Also

BeforeClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.AfterOpen Event

TADMetaInfoCommand.AfterOpen Event
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

The event fires after command is opened.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The AfterOpen event fires, after command is opened by calling Open or setting Active = True.

Syntax
property AfterOpen: TNotifyEvent;
See Also

BeforeOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.BaseObjectName Property

TADMetaInfoCommand.BaseObjectName Property
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the name of base object.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

The BaseObjectName property value meaning and optionality depends on MetaInfoKind:

MetaInfoKind | Meaning
mkIndexFields | Table name.
mkPrimaryKeyFields | Table name.
mkForeignKeyFields | Table name.
mkProcs | Oracle package name.
mkProcArgs | Oracle package name.

The BaseObjectName property value together with CatalogName and SchemaName constitutes the full base object name. If BaseObjectName is case sensitive or contains special character, then it must be explicitly quoted.

Assignment to this property value closes and unprepares command.

Syntax
property BaseObjectName: String;
See Also

MetaInfoKind, CatalogName, SchemaName, ObjectName

Example
var
  oTab: TADDatSTable;
....
  ADMetaInfoCommand1.BaseObjectName := 'Northwind.dbo.Employees';
  ADMetaInfoCommand1.ObjectName := 'FK_DEPARTMENTS';
  ADMetaInfoCommand1.MetaInfoKind := mkForeignKeyFields;
  ADMetaInfoCommand1.Define(oTab);
  ADMetaInfoCommand1.Open(oTab);
  ADMetaInfoCommand1.Fetch(oTab, True);


TADMetaInfoCommand.BeforeClose Event

TADMetaInfoCommand.BeforeClose Event
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be closed.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The BeforeClose event fires, before command will be closed by calling Close or setting Active = False.

Syntax
property BeforeClose: TNotifyEvent;
See Also

AfterClose, Close, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.BeforeOpen Event

TADMetaInfoCommand.BeforeOpen Event
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

The event fires before command will be opened.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The AfterOpen event fires, before command will be opened by calling Open or setting Active = True.

Syntax
property BeforeOpen: TNotifyEvent;
See Also

AfterOpen, Open, Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.CatalogName Property

TADMetaInfoCommand.CatalogName Property
TADMetaInfoCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies catalog name for some command kinds.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The CatalogName identifies the name of the catalog where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then CatalogName specifies the name of the catalog, where resides the procedure.
  • If MetaInfoKind is not mkNone, then CatalogName specifies the name of the catalog, where resides the describing object.
Syntax
property CatalogName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADMetaInfoCommand.Connection Property

TADMetaInfoCommand.Connection Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

Specifies the connection object.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The Connection property value points to the connection object. Alternatively may be specified the ConnectionName property value. The Connection property value must be specified before Prepare call.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.ConnectionName Property

TADMetaInfoCommand.ConnectionName Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

Specifies connection name.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file or created on fly;
  • ConnectionName of one of the TADConnection objects.

Alternatively may be specified the Connection property value. The ConnectionName property value must be specified before Prepare call. If is specified the name of one of connection definitions, then AnyDAC will transparently create connection object and link it with command.

Syntax
property ConnectionName: String;
See Also

Connection, Prepare

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.FormatOptions Property

TADMetaInfoCommand.FormatOptions Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

The set of options to control data representation.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The FormatOptions property is the set of properties, controlling the data type mapping, and some other aspects of data handling.

Syntax
property FormatOptions: TADFormatOptions;
See Also

TADFormatOptions, Fetch, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.MetaInfoKind Property

TADMetaInfoCommand.MetaInfoKind Property
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the kind of metadata to retrieve.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

The MetaInfoKind property determines what meta information will be retrieved. If DBMS or AnyDAC driver does not support specified MetaInfoKind (for example, mkGenerators for Sybase SQL Anywhere), then no exception will be raised at Open and no records will be returned.

Assignment to this property value closes and unprepares command.

See Retriving metadata for structure of returned datasets.

Syntax
property MetaInfoKind: TADPhysMetaInfoKind;
See Also

CatalogName, SchemaName, BaseObjectName, Overload, ObjectName

Example
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.ObjectName Property

TADMetaInfoCommand.ObjectName Property
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the name of object to get detailed information about it.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

The ObjectName property value defines the database objects, for which will be returned detailed information. The meaning, optionality and usage of catalog and schema names depends on MetaInfoKind:

MetaInfoKind | Meaning | Catalog and schema names
mkTableFields | Table name. | Applicable.
mkIndexes | Table name. | Applicable.
mkIndexFields | Index name. | --
mkPrimaryKey | Table name. | Applicable.
mkForeignKeys | Table name. | Applicable.
mkForeignKeyFields | Foreign key constraint name. | --
mkProcArgs | Stored procedure name. | Applicable, for non-packages stored procedures.

The ObjectName together with CatalogName and SchemaName may constitute the full object name. If object name is case sensitive or contains special character, then it must be explicitly quoted.

Assignment to this property value closes dataset.

Syntax
property ObjectName: String;
See Also

MetaInfoKind, CatalogName, SchemaName, BaseObjectName

Example
var
  oTab: TADDatSTable;
....
  ADMetaInfoCommand1.CatalogName := 'Northwind';
  ADMetaInfoCommand1.SchemaName := 'dbo';
  ADMetaInfoCommand1.ObjectName := 'Employees';
  ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
  ADMetaInfoCommand1.Define(oTab);
  ADMetaInfoCommand1.Open(oTab);
  ADMetaInfoCommand1.Fetch(oTab, True);


TADMetaInfoCommand.ObjectScopes Property

TADMetaInfoCommand.ObjectScopes Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

Gets / sets object scopes filter.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

Use the ObjectScopes property value to filter database objects by their scope:

Scope | Meaning
osMy | Objects created by current login user.
osSystem | Objects belonging to the DBMS.
osOther | All other objects.

Assignment to this property value closes and unprepares command.

Syntax
property ObjectScopes: TADPhysObjectScopes;
See Also

TableKinds

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.OnCommandChanged Event

TADMetaInfoCommand.OnCommandChanged Event
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

The event fires after CommandText is changed.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

The OnCommandChanged event fires, after CommandText is changed.

Syntax
property OnCommandChanged: TNotifyEvent;
See Also

CommandText

Example
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


TADMetaInfoCommand.OnError Event

TADMetaInfoCommand.OnError Event
TADMetaInfoCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while command is communicating with DBMS.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to command.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when command executes one of the following operations and an error happens:

  • Prepare. The command is preparing DBMS command text for execution.
  • Open. The command is executing DBMS command to open cursor.
  • Execute. The command is executing DBMS command text.
  • Fetch. The command is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use code like in the example.

Syntax
property OnError: TADErrorEvent;
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException

Example 1

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADMetaInfoCommand.Overload Property

TADMetaInfoCommand.Overload Property
TADMetaInfoCommand Class uADCompClient Unit Example published See Also Send Feedback

Oracle stored procedure overload index.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example, published, See Also
Description

The Overload property specifies Oracle packaged stored procedure overload index. It has no meaning for other DBMS's.

Syntax
property Overload: Word;
See Also

CommandText, CommandKind

Example
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


TADMetaInfoCommand.SchemaName Property

TADMetaInfoCommand.SchemaName Property
TADMetaInfoCommand Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies schema name for some of command kinds.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The SchemaName identifies the name of the schema where resides command object. The meaning depends on CommandKind and MetainfoKind:

  • If CommandKind in [skStoredProc, skStoredProcWithCrs, skStoredProcNoCrs], then SchemaName specifies the name of the schema, where resides the procedure.
  • If MetaInfoKind is not mkNone, then SchemaName specifies the name of the schema, where resides the describing object.
Syntax
property SchemaName: String;
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName

Example 1
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;
Example 2
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


TADMetaInfoCommand.TableKinds Property

TADMetaInfoCommand.TableKinds Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

Gets / sets table kind filter.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The TableKinds property value filters database tables, by their kinds:

Kind | Meaning
tkSynonym | Synonyms.
tkTable | Regular tables.
tkView | Views.
tkTempTable | Temporary tables.
tkLocalTable | Local tables.
Syntax
property TableKinds: TADPhysTableKinds;
See Also

ObjectScopes

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoCommand.Wildcard Property

TADMetaInfoCommand.Wildcard Property
TADMetaInfoCommand Class uADCompClient Unit published See Also Send Feedback

Gets / sets objects filter by their name.

Group

published

Links
TADMetaInfoCommand Class, uADCompClient Unit, published, See Also
Description

The Wildcard property value is the LIKE mask, which will be applied to the object names.

Syntax
property Wildcard: String;
See Also

ObjectScopes, TableKinds

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoQuery Class

TADMetaInfoQuery Class
published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

..

Syntax
TADMetaInfoQuery = class(TADRdbmsDataSet);
See Also

..


published

published
TADMetaInfoQuery Class Legend Published Events Published Properties Send Feedback

The published members of the TADMetaInfoQuery class are listed here.

Class

TADMetaInfoQuery Class

Published Events
Name | Description
AfterClose |
AfterGetRecords |
AfterOpen |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeClose |
BeforeGetRecords |
BeforeOpen |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnFilterRecord |
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
BaseObjectName | Gets / sets the name of base object.
CatalogName |
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
FetchOptions |
Filter |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MetaInfoKind | Gets / sets the kind of metadata to retrieve.
ObjectName | Gets / sets the name of object to get detailed information about it.
ObjectScopes | Gets / sets object scopes filter.
Overload |
SchemaName |
TableKinds | Gets / sets tables filter by their kinds.
Transaction | Gets / sets reference to transaction object.
UpdateTransaction | Gets / sets reference to transaction object.
Wildcard | Gets / sets objects filter by their name.
Links
TADMetaInfoQuery Class, Legend, Published Events, Published Properties


TADMetaInfoQuery.Active Property

TADMetaInfoQuery.Active Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Active;


TADMetaInfoQuery.ActiveStoredUsage Property

TADMetaInfoQuery.ActiveStoredUsage Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADMetaInfoQuery.AfterClose Property

TADMetaInfoQuery.AfterClose Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterClose;


TADMetaInfoQuery.AfterGetRecords Event

TADMetaInfoQuery.AfterGetRecords Event
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterGetRecords: TADDataSetEvent;


TADMetaInfoQuery.AfterOpen Property

TADMetaInfoQuery.AfterOpen Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterOpen;


TADMetaInfoQuery.AfterRefresh Property

TADMetaInfoQuery.AfterRefresh Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterRefresh;


TADMetaInfoQuery.AfterRowRequest Event

TADMetaInfoQuery.AfterRowRequest Event
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterRowRequest: TADDataSetEvent;


TADMetaInfoQuery.AfterScroll Property

TADMetaInfoQuery.AfterScroll Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AfterScroll;


TADMetaInfoQuery.Aggregates Property

TADMetaInfoQuery.Aggregates Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Aggregates: TADAggregates;


TADMetaInfoQuery.AggregatesActive Property

TADMetaInfoQuery.AggregatesActive Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AggregatesActive: Boolean;


TADMetaInfoQuery.AutoCalcFields Property

TADMetaInfoQuery.AutoCalcFields Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property AutoCalcFields;


TADMetaInfoQuery.BaseObjectName Property

TADMetaInfoQuery.BaseObjectName Property
TADMetaInfoQuery Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the name of base object.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example, published, See Also
Description

The BaseObjectName property value meaning and optionality depends on MetaInfoKind:

MetaInfoKind | Meaning
mkIndexFields | Table name.
mkPrimaryKeyFields | Table name.
mkForeignKeyFields | Table name.
mkProcs | Oracle package name.
mkProcArgs | Oracle package name.

The BaseObjectName property value together with CatalogName and SchemaName constitutes the full base object name. If current DBMS session may "see" few objects with the same name, but in different catalogs and/or schemas, then we strongly suggest to specify CatalogName and/or SchemaName property values to explicitly limit the list of objects.

If BaseObjectName is case sensitive or contains special character, then it must be explicitly quoted.

Assignment to this property value closes dataset.

Syntax
property BaseObjectName: String;
See Also

MetaInfoKind, CatalogName, SchemaName, ObjectName

Example
  // get FK_DEPARTMENTS foreign keys fields list for table Northwind.dbo.Employees
  ADMetaInfoQuery1.BaseObjectName := 'Northwind.dbo.Employees';
  ADMetaInfoQuery1.ObjectName := 'FK_DEPARTMENTS';
  ADMetaInfoQuery1.MetaInfoKind := mkForeignKeyFields;
  ADMetaInfoCommand1.Open;


TADMetaInfoQuery.BeforeClose Property

TADMetaInfoQuery.BeforeClose Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeClose;


TADMetaInfoQuery.BeforeGetRecords Event

TADMetaInfoQuery.BeforeGetRecords Event
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeGetRecords: TADDataSetEvent;


TADMetaInfoQuery.BeforeOpen Property

TADMetaInfoQuery.BeforeOpen Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeOpen;


TADMetaInfoQuery.BeforeRefresh Property

TADMetaInfoQuery.BeforeRefresh Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeRefresh;


TADMetaInfoQuery.BeforeRowRequest Event

TADMetaInfoQuery.BeforeRowRequest Event
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeRowRequest: TADDataSetEvent;


TADMetaInfoQuery.BeforeScroll Property

TADMetaInfoQuery.BeforeScroll Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property BeforeScroll;


TADMetaInfoQuery.CatalogName Property

TADMetaInfoQuery.CatalogName Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property CatalogName: String;


TADMetaInfoQuery.Connection Property

TADMetaInfoQuery.Connection Property
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Specifies the AnyDAC connection component to use.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

Use Connection to specify an AnyDAC connection object to use to connect to an DBMS.

At design-time, select from the list of available TADCustomConnection objects (if any have been added to the application) invoked from the Object Inspector. If a form or data module has TADCustomConnection dropped on it, then TADRdbmsDataSet assigns this connection object to Connection property automatically right after dropping on the form or data module.

At runtime, set Connection to reference an existing TADConnection object.

The TADRdbmsDataSet can be binded to TADCustomConnection object using Connection or ConnectionName property. Using ConnectionName property allows to bind to a connection object, if it is even not yet created or is not accessible.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoQuery.ConnectionName Property

TADMetaInfoQuery.ConnectionName Property
TADMetaInfoQuery Class uADCompClient Unit Example published See Also Send Feedback

Specifies the AnyDAC connection to use by its name.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example, published, See Also
Description

Use ConnectionName to specify an AnyDAC connection to use to connect to an DBMS. The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file (persistent) or created on fly (private);
  • ConnectionName of one of the TADConnection objects.

The ConnectionName property value must be specified before Prepare call. If it matches the name of one of connection definitions, then AnyDAC will transparently create connection object and link the dataset with it.

The TADRdbmsDataSet cab be binded to TADCustomConnection object using Connection or ConnectionName property. Using Connection property allows to bind to a connection object explicitly and reduce the overhead for resolving connection names.

Syntax
property ConnectionName: String;
See Also

Connection, TADCustomConnection.Temporary

Example
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


TADMetaInfoQuery.FetchOptions Property

TADMetaInfoQuery.FetchOptions Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property FetchOptions;


TADMetaInfoQuery.Filter Property

TADMetaInfoQuery.Filter Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Filter;


TADMetaInfoQuery.Filtered Property

TADMetaInfoQuery.Filtered Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Filtered;


TADMetaInfoQuery.FilterOptions Property

TADMetaInfoQuery.FilterOptions Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property FilterOptions;


TADMetaInfoQuery.FormatOptions Property

TADMetaInfoQuery.FormatOptions Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property FormatOptions;


TADMetaInfoQuery.Indexes Property

TADMetaInfoQuery.Indexes Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Indexes: TADIndexes;


TADMetaInfoQuery.IndexesActive Property

TADMetaInfoQuery.IndexesActive Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property IndexesActive: Boolean;


TADMetaInfoQuery.IndexFieldNames Property

TADMetaInfoQuery.IndexFieldNames Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property IndexFieldNames: String;


TADMetaInfoQuery.IndexName Property

TADMetaInfoQuery.IndexName Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property IndexName: String;


TADMetaInfoQuery.MetaInfoKind Property

TADMetaInfoQuery.MetaInfoKind Property
TADMetaInfoQuery Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the kind of metadata to retrieve.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example, published, See Also
Description

The MetaInfoKind property determines what meta information will be retrieved. If DBMS or AnyDAC driver does not support specified MetaInfoKind (for example, mkGenerators for Sybase SQL Anywhere), then no exception will be raised at Open and no records will be returned.

Assignment to this property value closes dataset.

See Retriving metadata for structure of returned datasets.

Syntax
property MetaInfoKind: TADPhysMetaInfoKind;
See Also

CatalogName, SchemaName, BaseObjectName, Overload, ObjectName

Example
  // get the table list for Northwind catalog, dbo schema
  ADMetaInfoQuery1.CatalogName := 'Northwind';
  ADMetaInfoQuery1.SchemaName := 'dbo';
  ADMetaInfoQuery1.MetaInfoKind := mkTables;
  ADMetaInfoQuery1.Open;


TADMetaInfoQuery.ObjectName Property

TADMetaInfoQuery.ObjectName Property
TADMetaInfoQuery Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets the name of object to get detailed information about it.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example, published, See Also
Description

The ObjectName property value defines the database objects, for which will be returned detailed information. The meaning, optionality and usage of the catalog and schema names depends on MetaInfoKind:

MetaInfoKind | Meaning | Catalog and schema names
mkTableFields | Table name. | Applicable.
mkIndexes | Table name. | Applicable.
mkIndexFields | Index name. | --
mkPrimaryKey | Table name. | Applicable.
mkForeignKeys | Table name. | Applicable.
mkForeignKeyFields | Foreign key constraint name. | --
mkProcArgs | Stored procedure name. | Applicable, for non-packages stored procedures.

The ObjectName together with CatalogName and SchemaName may constitute the full object name. If current DBMS session may "see" few objects with the same name, but in different catalogs and/or schemas, then we strongly suggest to specify CatalogName and/or SchemaName property values to explicitly limit the list of objects.

If object name is case sensitive or contains special character, then it must be explicitly quoted.

Assignment to this property value closes dataset.

Syntax
property ObjectName: String;
See Also

MetaInfoKind, CatalogName, SchemaName, BaseObjectName

Example
  // get the field list of Northwind.dbo.Employees table
  ADMetaInfoQuery1.CatalogName := 'Northwind';
  ADMetaInfoQuery1.SchemaName := 'dbo';
  ADMetaInfoQuery1.ObjectName := 'Employees';
  ADMetaInfoQuery1.MetaInfoKind := mkTableFields;
  ADMetaInfoQuery1.Open;


TADMetaInfoQuery.ObjectScopes Property

TADMetaInfoQuery.ObjectScopes Property
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Gets / sets object scopes filter.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

Use the ObjectScopes property value to filter database objects by their scope:

Scope | Meaning
osMy | Objects created by current login user.
osSystem | Objects belonging to the DBMS.
osOther | All other objects.

Assignment to this property value closes dataset.

Syntax
property ObjectScopes: TADPhysObjectScopes;
See Also

TableKinds

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoQuery.OnCalcFields Property

TADMetaInfoQuery.OnCalcFields Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property OnCalcFields;


TADMetaInfoQuery.OnCommandChanged Event

TADMetaInfoQuery.OnCommandChanged Event
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Fires after the SQL property value is changed.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

The OnCommandChanged event fires after the SQL command text value is changed:

  • for TADQuery - after SQL is changed;
  • for TADStoredProc - after StoredProcName is changed;
  • for TADTable - after TableName is changed.
Syntax
property OnCommandChanged: TNotifyEvent;
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


TADMetaInfoQuery.OnError Event

TADMetaInfoQuery.OnError Event
TADMetaInfoQuery Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while dataset is communicating with DBMS.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when dataset executes one of the following operations and an error happens:

  • Prepare. The dataset is preparing DBMS command text for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • Execute, ExecSQL, ExecProc. The dataset is executing DBMS command text.
  • Navigation methods. The dataset is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use a code like in the first example.

To centralize error handling, you can consider to use TADCustomConnection.OnError.

Syntax
property OnError: TADErrorEvent;
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError

Example 1

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADMetaInfoQuery.OnFilterRecord Property

TADMetaInfoQuery.OnFilterRecord Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property OnFilterRecord;


TADMetaInfoQuery.Overload Property

TADMetaInfoQuery.Overload Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property Overload: Word;


TADMetaInfoQuery.SchemaName Property

TADMetaInfoQuery.SchemaName Property
TADMetaInfoQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published
Syntax
property SchemaName: String;


TADMetaInfoQuery.TableKinds Property

TADMetaInfoQuery.TableKinds Property
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Gets / sets tables filter by their kinds.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

The TableKinds property value filters database tables, by their kinds. Assignment to this property will close dataset.

Kind | Meaning
tkSynonym | Synonyms.
tkTable | Regular tables.
tkView | Views.
tkTempTable | Temporary tables.
tkLocalTable | Local tables.
Syntax
property TableKinds: TADPhysTableKinds;
See Also

ObjectScopes

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMetaInfoQuery.Transaction Property

TADMetaInfoQuery.Transaction Property
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

The Transaction property allows to associate dataset with explicit transaction object. If it is not specified, then dataset will be associated with connection default transaction.

The specified transaction object will be used only for Prepare, Open, ExecSQL, ExecProc, Execute methods. For commands, generated to apply changes to database, AnyDAC will use UpdateTransaction, if it is specified, otherwise - Transaction.

Currently explicit transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomConnection.Transaction


TADMetaInfoQuery.UpdateTransaction Property

TADMetaInfoQuery.UpdateTransaction Property
TADMetaInfoQuery Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, Example, published, See Also
Description

The UpdateTransaction property allows to associate dataset internal update commands with explicit transaction object. If it is not specified, then dataset update commands will be associated with connection default update transaction. If it is not specified, then - with dataset Transaction.

For Prepare, Open, ExecSQL, ExecProc, Execute methods will be used Transaction objects.

Currently explicit update transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomConnection.UpdateTransaction

Example
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


TADMetaInfoQuery.Wildcard Property

TADMetaInfoQuery.Wildcard Property
TADMetaInfoQuery Class uADCompClient Unit published See Also Send Feedback

Gets / sets objects filter by their name.

Group

published

Links
TADMetaInfoQuery Class, uADCompClient Unit, published, See Also
Description

The Wildcard property value is the LIKE mask, which will be applied to the object names.

Syntax
property Wildcard: String;
See Also

ObjectScopes, TableKinds

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADQuery Class

TADQuery Class
public published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, published, Classes, See Also
Description

..

Syntax
TADQuery = class(TADCustomQuery);
See Also

..


public

public
TADQuery Class Legend Public Properties Send Feedback

The public members of the TADQuery class are listed here.

Class

TADQuery Class

Public Properties
Name | Description
MacroCount | Returns the number of macro in Macros collection.
RowsAffected | Returns the number of rows operated upon by the latest query execution.
Links
TADQuery Class, Legend, Public Properties


TADQuery.MacroCount Property

TADQuery.MacroCount Property
TADQuery Class uADCompClient Unit public See Also Send Feedback

Returns the number of macro in Macros collection.

Group

public

Links
TADQuery Class, uADCompClient Unit, public, See Also
Description

The MacroCount property teturns the number of of macro substitution variables in Macros collection.

Syntax
property MacroCount;
See Also

Macros

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADQuery.RowsAffected Property

TADQuery.RowsAffected Property
TADQuery Class uADCompClient Unit Example public Send Feedback

Returns the number of rows operated upon by the latest query execution.

Group

public

Links
TADQuery Class, uADCompClient Unit, Example, public
Description

Inspect RowsAffected to determine how many rows were inserted, updated, deleted or fetched by the last dataset operation. If no rows were processed, RowsAffected = 0. If numbers of processed rows is not accessible, RowsAffected = –1.

Syntax
property RowsAffected;
Example
procedure TForm1.ADQuery1AfterExecute(ASender: TObject);
begin
  if ADQuery1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADQuery1.Command1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADQuery1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADQuery1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADQuery1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADQuery1.RowsAffected]);
    end;
end;


published

published
TADQuery Class Legend Published Events Published Properties Send Feedback

The published members of the TADQuery class are listed here.

Class

TADQuery Class

Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterExecute |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeExecute |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnDeleteError |
OnEditError |
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
DataSource | Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
Macros | The collection of macro substitution variables.
ObjectView |
Params |
Prepared | Gets or sets command prepare for execution status.
ResourceOptions |
SQL | Contains the text of the SQL statement to execute for the query.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.
Links
TADQuery Class, Legend, Published Events, Published Properties


TADQuery.Active Property

TADQuery.Active Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Active;


TADQuery.ActiveStoredUsage Property

TADQuery.ActiveStoredUsage Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADQuery.AfterApplyUpdates Event

TADQuery.AfterApplyUpdates Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterApplyUpdates: TADAfterApplyUpdatesEvent;


TADQuery.AfterCancel Property

TADQuery.AfterCancel Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterCancel;


TADQuery.AfterClose Property

TADQuery.AfterClose Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterClose;


TADQuery.AfterDelete Property

TADQuery.AfterDelete Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterDelete;


TADQuery.AfterEdit Property

TADQuery.AfterEdit Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterEdit;


TADQuery.AfterExecute Event

TADQuery.AfterExecute Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterExecute: TADDataSetEvent;


TADQuery.AfterGetRecords Event

TADQuery.AfterGetRecords Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterGetRecords: TADDataSetEvent;


TADQuery.AfterInsert Property

TADQuery.AfterInsert Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterInsert;


TADQuery.AfterOpen Property

TADQuery.AfterOpen Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterOpen;


TADQuery.AfterPost Property

TADQuery.AfterPost Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterPost;


TADQuery.AfterRefresh Property

TADQuery.AfterRefresh Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterRefresh;


TADQuery.AfterRowRequest Event

TADQuery.AfterRowRequest Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterRowRequest: TADDataSetEvent;


TADQuery.AfterScroll Property

TADQuery.AfterScroll Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AfterScroll;


TADQuery.Aggregates Property

TADQuery.Aggregates Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Aggregates: TADAggregates;


TADQuery.AggregatesActive Property

TADQuery.AggregatesActive Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AggregatesActive: Boolean;


TADQuery.AutoCalcFields Property

TADQuery.AutoCalcFields Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property AutoCalcFields;


TADQuery.BeforeApplyUpdates Event

TADQuery.BeforeApplyUpdates Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeApplyUpdates: TADDataSetEvent;


TADQuery.BeforeCancel Property

TADQuery.BeforeCancel Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeCancel;


TADQuery.BeforeClose Property

TADQuery.BeforeClose Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeClose;


TADQuery.BeforeDelete Property

TADQuery.BeforeDelete Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeDelete;


TADQuery.BeforeEdit Property

TADQuery.BeforeEdit Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeEdit;


TADQuery.BeforeExecute Event

TADQuery.BeforeExecute Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeExecute: TADDataSetEvent;


TADQuery.BeforeGetRecords Event

TADQuery.BeforeGetRecords Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeGetRecords: TADDataSetEvent;


TADQuery.BeforeInsert Property

TADQuery.BeforeInsert Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeInsert;


TADQuery.BeforeOpen Property

TADQuery.BeforeOpen Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeOpen;


TADQuery.BeforePost Property

TADQuery.BeforePost Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforePost;


TADQuery.BeforeRefresh Property

TADQuery.BeforeRefresh Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeRefresh;


TADQuery.BeforeRowRequest Event

TADQuery.BeforeRowRequest Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeRowRequest: TADDataSetEvent;


TADQuery.BeforeScroll Property

TADQuery.BeforeScroll Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property BeforeScroll;


TADQuery.CachedUpdates Property

TADQuery.CachedUpdates Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property CachedUpdates: Boolean;


TADQuery.Connection Property

TADQuery.Connection Property
TADQuery Class uADCompClient Unit published See Also Send Feedback

Specifies the AnyDAC connection component to use.

Group

published

Links
TADQuery Class, uADCompClient Unit, published, See Also
Description

Use Connection to specify an AnyDAC connection object to use to connect to an DBMS.

At design-time, select from the list of available TADCustomConnection objects (if any have been added to the application) invoked from the Object Inspector. If a form or data module has TADCustomConnection dropped on it, then TADRdbmsDataSet assigns this connection object to Connection property automatically right after dropping on the form or data module.

At runtime, set Connection to reference an existing TADConnection object.

The TADRdbmsDataSet can be binded to TADCustomConnection object using Connection or ConnectionName property. Using ConnectionName property allows to bind to a connection object, if it is even not yet created or is not accessible.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADQuery.ConnectionName Property

TADQuery.ConnectionName Property
TADQuery Class uADCompClient Unit Example published See Also Send Feedback

Specifies the AnyDAC connection to use by its name.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example, published, See Also
Description

Use ConnectionName to specify an AnyDAC connection to use to connect to an DBMS. The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file (persistent) or created on fly (private);
  • ConnectionName of one of the TADConnection objects.

The ConnectionName property value must be specified before Prepare call. If it matches the name of one of connection definitions, then AnyDAC will transparently create connection object and link the dataset with it.

The TADRdbmsDataSet cab be binded to TADCustomConnection object using Connection or ConnectionName property. Using Connection property allows to bind to a connection object explicitly and reduce the overhead for resolving connection names.

Syntax
property ConnectionName: String;
See Also

Connection, TADCustomConnection.Temporary

Example
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


TADQuery.Constraints Property

TADQuery.Constraints Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Constraints;


TADQuery.ConstraintsEnabled Property

TADQuery.ConstraintsEnabled Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property ConstraintsEnabled: Boolean;


TADQuery.DataSource Property

TADQuery.DataSource Property
TADQuery Class uADCompClient Unit Example published See Also Send Feedback

Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example, published, See Also
Description

Use the DataSource property to automatically fill parameters in a query with fields values from another dataset. Parameters that have the same name as fields in the other dataset are filled with the field values. Parameters with names that are not the same as fields in the other dataset do not automatically get values, and must be programmatically set.

When the master dataset current position is changed or is changed the data in the current record of the master dataset, then this dataset (detail dataset) will reopen query using new master dataset field values. If that is not desired behaviour or you must quickly walk through master dataset, then use DisableControls / EnableControls on master dataset.

Syntax
property DataSource: TDataSource;
See Also

SQL, Params, ParamByName, TDataSet.BeforeOpen

Example
MasterQuery.Open('select * from {id Orders}');
MasterSource.DataSet := MasterQuery;
DetailQuery.DataSource := MasterSource;
DetailQuery.Open('select * from {id Order Details} where OrderID = :OrderID');
// here :OrderID parameter of DetailQuery will get the current value of OrderID
// field from MasterQuery
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADQuery.FetchOptions Property

TADQuery.FetchOptions Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property FetchOptions;


TADQuery.Filter Property

TADQuery.Filter Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Filter;


TADQuery.FilterChanges Property

TADQuery.FilterChanges Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property FilterChanges: TUpdateRecordTypes;


TADQuery.Filtered Property

TADQuery.Filtered Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Filtered;


TADQuery.FilterOptions Property

TADQuery.FilterOptions Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property FilterOptions;


TADQuery.FormatOptions Property

TADQuery.FormatOptions Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property FormatOptions;


TADQuery.Indexes Property

TADQuery.Indexes Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Indexes: TADIndexes;


TADQuery.IndexesActive Property

TADQuery.IndexesActive Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property IndexesActive: Boolean;


TADQuery.IndexFieldNames Property

TADQuery.IndexFieldNames Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property IndexFieldNames: String;


TADQuery.IndexName Property

TADQuery.IndexName Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property IndexName: String;


TADQuery.Macros Property

TADQuery.Macros Property
TADQuery Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The collection of macro substitution variables.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

The Macros property is the collection of macro substitution variables. It is populated automatically after assigning SQL property, if ResourceOptions.MacroCreate = True. Otherwise it may be populated by hands. At Prepare call, macro values will be substituted into SQL, if ResourceOptions.MacroExpand = True.

Syntax
property Macros;
See Also

TADCustomQuery.SQL, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand

Example 1

Substitute table name:

ADQuery1.SQL.Text := 'select * from &Tab';
ADQuery1.Macros[0].AsIdentifier := 'Order Details';
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from "Order Details"
Example 2

Substitute WHERE condition:

ADQuery1.SQL.Text := 'select * from MyTab {if !cond} where !cond {fi}';

ADQuery1.Macros[0].AsString := 'ID > 100';
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from MyTab where ID > 100

ADQuery1.Macros[0].Clear;
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from MyTab


TADQuery.ObjectView Property

TADQuery.ObjectView Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property ObjectView;


TADQuery.OnCalcFields Property

TADQuery.OnCalcFields Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnCalcFields;


TADQuery.OnCommandChanged Event

TADQuery.OnCommandChanged Event
TADQuery Class uADCompClient Unit published See Also Send Feedback

Fires after the SQL property value is changed.

Group

published

Links
TADQuery Class, uADCompClient Unit, published, See Also
Description

The OnCommandChanged event fires after the SQL command text value is changed:

  • for TADQuery - after SQL is changed;
  • for TADStoredProc - after StoredProcName is changed;
  • for TADTable - after TableName is changed.
Syntax
property OnCommandChanged: TNotifyEvent;
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


TADQuery.OnDeleteError Property

TADQuery.OnDeleteError Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnDeleteError;


TADQuery.OnEditError Property

TADQuery.OnEditError Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnEditError;


TADQuery.OnError Event

TADQuery.OnError Event
TADQuery Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while dataset is communicating with DBMS.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when dataset executes one of the following operations and an error happens:

  • Prepare. The dataset is preparing DBMS command text for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • Execute, ExecSQL, ExecProc. The dataset is executing DBMS command text.
  • Navigation methods. The dataset is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use a code like in the first example.

To centralize error handling, you can consider to use TADCustomConnection.OnError.

Syntax
property OnError: TADErrorEvent;
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError

Example 1

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADQuery.OnExecuteError Event

TADQuery.OnExecuteError Event
TADQuery Class uADCompClient Unit Example published See Also Send Feedback

The event is triggered when an error happens, while executing a Array DML query.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
ATimes | The current Array DML size. It may be different from value of the Execute method ATimes parameter, if full operation is splitted into few more small (on Firebird, for example).
AOffset | The current Array DML offset. It may be different from value of the Execute method AOffset parameter, if there was skiped erroneous rows or full operation is splitted into few more small (on Firebird, for example).
AException | The original DBMS returned error. Check AException.Errors[i].RowIndex for the index of errorneous row in parameters array.
AAction | The action dataset should take after return from event handler.
Description

The OnExecuteError event is triggered, when dataset executes Array DML using Execute method and ATimes > 1. Using this event handler you can:

  • skip erroneous row of the parameters array;
  • change values in erroneous row of the parameters array;
  • stop full Array DML execution.
Syntax
property OnExecuteError: TADExecuteErrorEvent;
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute

Example
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


TADQuery.OnFilterRecord Property

TADQuery.OnFilterRecord Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnFilterRecord;


TADQuery.OnNewRecord Property

TADQuery.OnNewRecord Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnNewRecord;


TADQuery.OnPostError Property

TADQuery.OnPostError Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnPostError;


TADQuery.OnReconcileError Event

TADQuery.OnReconcileError Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnReconcileError: TADReconcileErrorEvent;


TADQuery.OnUpdateError Event

TADQuery.OnUpdateError Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnUpdateError: TADUpdateErrorEvent;


TADQuery.OnUpdateRecord Event

TADQuery.OnUpdateRecord Event
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property OnUpdateRecord: TADUpdateRecordEvent;


TADQuery.Params Property

TADQuery.Params Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property Params;


TADQuery.Prepared Property

TADQuery.Prepared Property
TADQuery Class uADCompClient Unit published See Also Send Feedback

Gets or sets command prepare for execution status.

Group

published

Links
TADQuery Class, uADCompClient Unit, published, See Also
Description

Set Prepared to True to prepare SQL command for execution. Setting Prepared to True, will call Prepare method. It is not required to set Prepared to True for standard SQL command before execution, because first Execute / ExecSQL / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise an exception will be raised.

After SQL command preparation application cannot change command parameter data types and sizes, otherwise on next Execute or Open call an exception will be raised. So, setup parameters before setting Prepared to True.

Set Prepared to False to unprepare SQL command and release all it resources. Setting Prepared to False, will call Unprepare method.

Syntax
property Prepared;
See Also

Prepare, Unprepare, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADQuery.ResourceOptions Property

TADQuery.ResourceOptions Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property ResourceOptions;


TADQuery.SQL Property

TADQuery.SQL Property
TADQuery Class uADCompClient Unit Example published See Also Send Feedback

Contains the text of the SQL statement to execute for the query.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example, published, See Also
Description

Use SQL property to specify the SQL command that a query will Execute / ExecSQL / Open.

At design time the SQL property can be edited by invoking AnyDAC Query Editor dialog. For that double click on TADCustomQuery component. The dialog offers syntax hilighting editor, query builder, ability to test query and other.

The SQL property may contain one SQL command or "batch" SQL command, consisting from few SQL command or server side programming language block of code. To execute full featured SQL script use the TADScript component.

The SQL statement in the SQL property may contain also:

  • parameter markers, following standard SQL-92 syntax conventions. Parameters are created automatically and stored in the Params property, if ResourceOptions.ParamCreate is True. If ParamBindMode is pbByName, then for all occurencies of the same marker will be created single item in Params. If pbByNumber, then - one item per each marker.
  • substitution variable markers. Macros are created automatically and stored in the Macros property, if ResourceOptions.MacroCreate is True.
  • escape sequences. They allow writing DBMS independent SQL commands.
  • conditional substitutions. They allow expand SQL command conditionally, depending on application defined attributes

For details see Command text preprocessing.

To improove performance on adding big SQL queries to the property using TStringList methods, surround this code into SQL.BeginUpdate / SQL.EndUpdate.

After filling this property value the Param collection will be filled automatically, if ResourceOptions.ParamCreate is True.

Syntax
property SQL: TStrings;
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, ExecSQL, TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADRdbmsDataSet.ParamBindMode

Example
ADQuery1.SQL.BeginUpdate;
try
  ADQuery1.SQL.Add('SELECT ...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('WHERE ID = :ID');
finally
  ADQuery1.SQL.EndUpdate;
end;
ADQuery1.ParamByName('ID').AsInteger := 100;
ADQuery1.Open;


TADQuery.Transaction Property

TADQuery.Transaction Property
TADQuery Class uADCompClient Unit published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADQuery Class, uADCompClient Unit, published, See Also
Description

The Transaction property allows to associate dataset with explicit transaction object. If it is not specified, then dataset will be associated with connection default transaction.

The specified transaction object will be used only for Prepare, Open, ExecSQL, ExecProc, Execute methods. For commands, generated to apply changes to database, AnyDAC will use UpdateTransaction, if it is specified, otherwise - Transaction.

Currently explicit transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomConnection.Transaction


TADQuery.UpdateObject Property

TADQuery.UpdateObject Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property UpdateObject;


TADQuery.UpdateOptions Property

TADQuery.UpdateOptions Property
TADQuery Class uADCompClient Unit published Send Feedback
Group

published

Links
TADQuery Class, uADCompClient Unit, published
Syntax
property UpdateOptions;


TADQuery.UpdateTransaction Property

TADQuery.UpdateTransaction Property
TADQuery Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADQuery Class, uADCompClient Unit, Example, published, See Also
Description

The UpdateTransaction property allows to associate dataset internal update commands with explicit transaction object. If it is not specified, then dataset update commands will be associated with connection default update transaction. If it is not specified, then - with dataset Transaction.

For Prepare, Open, ExecSQL, ExecProc, Execute methods will be used Transaction objects.

Currently explicit update transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomConnection.UpdateTransaction

Example
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


TADRdbmsDataSet Class

TADRdbmsDataSet Class
public Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, Classes, See Also
Description

..

Syntax
TADRdbmsDataSet = class(TADAdaptedDataSet);
See Also

..


public

public
TADRdbmsDataSet Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADRdbmsDataSet class are listed here.

Class

TADRdbmsDataSet Class

Public Events
Name | Description
OnCommandChanged | Fires after the SQL property value is changed.
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
Public Methods
Name | Description
Create |
Destroy |
Disconnect | Disconnects the dataset from DBMS.
FindMacro | Returns macro by its name.
MacroByName | Returns macro by its name.
Open |
Open | Executes the specified SQL statement and opens dataset.
Open | Executes the specified SQL statement with specified parameter values and opens dataset.
Open | Executes the specified SQL statement with specified parameter values and opens dataset.
Prepare | Prepares SQL command for execution.
Unprepare | Releases SQL command resources.
Public Properties
Name | Description
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Transaction | Gets / sets reference to transaction object.
UpdateTransaction | Gets / sets reference to transaction object.
Links
TADRdbmsDataSet Class, Legend, Public Events, Public Methods, Public Properties


TADRdbmsDataSet.Connection Property

TADRdbmsDataSet.Connection Property
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Specifies the AnyDAC connection component to use.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Description

Use Connection to specify an AnyDAC connection object to use to connect to an DBMS.

At design-time, select from the list of available TADCustomConnection objects (if any have been added to the application) invoked from the Object Inspector. If a form or data module has TADCustomConnection dropped on it, then TADRdbmsDataSet assigns this connection object to Connection property automatically right after dropping on the form or data module.

At runtime, set Connection to reference an existing TADConnection object.

The TADRdbmsDataSet can be binded to TADCustomConnection object using Connection or ConnectionName property. Using ConnectionName property allows to bind to a connection object, if it is even not yet created or is not accessible.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADRdbmsDataSet.ConnectionName Property

TADRdbmsDataSet.ConnectionName Property
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Specifies the AnyDAC connection to use by its name.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Description

Use ConnectionName to specify an AnyDAC connection to use to connect to an DBMS. The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file (persistent) or created on fly (private);
  • ConnectionName of one of the TADConnection objects.

The ConnectionName property value must be specified before Prepare call. If it matches the name of one of connection definitions, then AnyDAC will transparently create connection object and link the dataset with it.

The TADRdbmsDataSet cab be binded to TADCustomConnection object using Connection or ConnectionName property. Using Connection property allows to bind to a connection object explicitly and reduce the overhead for resolving connection names.

Syntax
property ConnectionName: String;
See Also

Connection, TADCustomConnection.Temporary

Example
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


TADRdbmsDataSet.OnCommandChanged Event

TADRdbmsDataSet.OnCommandChanged Event
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Fires after the SQL property value is changed.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Description

The OnCommandChanged event fires after the SQL command text value is changed:

  • for TADQuery - after SQL is changed;
  • for TADStoredProc - after StoredProcName is changed;
  • for TADTable - after TableName is changed.
Syntax
property OnCommandChanged: TNotifyEvent;
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


TADRdbmsDataSet.OnError Event

TADRdbmsDataSet.OnError Event
TADRdbmsDataSet Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

The event fires when an error happens, while dataset is communicating with DBMS.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when dataset executes one of the following operations and an error happens:

  • Prepare. The dataset is preparing DBMS command text for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • Execute, ExecSQL, ExecProc. The dataset is executing DBMS command text.
  • Navigation methods. The dataset is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use a code like in the first example.

To centralize error handling, you can consider to use TADCustomConnection.OnError.

Syntax
property OnError: TADErrorEvent;
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError

Example 1

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADRdbmsDataSet.Transaction Property

TADRdbmsDataSet.Transaction Property
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Gets / sets reference to transaction object.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Description

The Transaction property allows to associate dataset with explicit transaction object. If it is not specified, then dataset will be associated with connection default transaction.

The specified transaction object will be used only for Prepare, Open, ExecSQL, ExecProc, Execute methods. For commands, generated to apply changes to database, AnyDAC will use UpdateTransaction, if it is specified, otherwise - Transaction.

Currently explicit transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomConnection.Transaction


TADRdbmsDataSet.UpdateTransaction Property

TADRdbmsDataSet.UpdateTransaction Property
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Gets / sets reference to transaction object.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Description

The UpdateTransaction property allows to associate dataset internal update commands with explicit transaction object. If it is not specified, then dataset update commands will be associated with connection default update transaction. If it is not specified, then - with dataset Transaction.

For Prepare, Open, ExecSQL, ExecProc, Execute methods will be used Transaction objects.

Currently explicit update transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomConnection.UpdateTransaction

Example
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


TADRdbmsDataSet.Create Constructor

TADRdbmsDataSet.Create Constructor
TADRdbmsDataSet Class uADCompClient Unit public Send Feedback
Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


TADRdbmsDataSet.Destroy Destructor

TADRdbmsDataSet.Destroy Destructor
TADRdbmsDataSet Class uADCompClient Unit public Send Feedback
Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public
Syntax
destructor Destroy; override;


TADRdbmsDataSet.Disconnect Method

TADRdbmsDataSet.Disconnect Method
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Disconnects the dataset from DBMS.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
AAbortJob: Boolean = False | True, if current dataset task must be aborted.
Description

The Disconnect method optionally aborts current dataset task, like a Open, Execute, ExecSQL or rows fetching. Then closes dataset and unprepares it.

Syntax
procedure Disconnect(AAbortJob: Boolean = False); override;
See Also

AbortJob

Example
ADQuery1.Disconnect(True);
// is equivalent to:
// ADQuery1.AbortJob(True);
// ADQuery1.Close;
// ADQuery1.Unprepare;


TADRdbmsDataSet.FindMacro Method

TADRdbmsDataSet.FindMacro Method
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Returns macro by its name.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | A name of macro to return.
Returns

The macro with Name = AValue or nil if such macro does not exists.

Description

The FindMacro method returns a macro from Macros collection by its name AValue. If there is no such macro, then method will return nil.

Syntax
function FindMacro(const AValue: string): TADMacro;
See Also

Macros, MacroByName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADRdbmsDataSet.MacroByName Method

TADRdbmsDataSet.MacroByName Method
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Returns macro by its name.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | A name of macro to return.
Returns

The macro with Name = AValue.

Description

The MacroByName method returns a macro from Macros collection by its name AValue. If there is no such macro, then exception will be raised.

Syntax
function MacroByName(const AValue: string): TADMacro;
See Also

Macros, FindMacro

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADRdbmsDataSet.Open Method ()

TADRdbmsDataSet.Open Method ()
TADRdbmsDataSet Class uADCompClient Unit public Send Feedback
Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public
Syntax
procedure Open; overload;


TADRdbmsDataSet.Open Method (String)

TADRdbmsDataSet.Open Method (String)
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified SQL statement and opens dataset.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
Description

Call Open to execute the SQL statement specified in ASQL or is currently assigned to the internal command object, if ASQL is empty. Open sets the Active property for the dataset to True. When Active is true, dataset can be populated with data. It can fetch data from a database. Depending on the CanModify property, active datasets can post changes.

If an application needs to execute the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling Open for the first time, then use any Open version without specifing ASQL.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

If DBMS returns error, then AnyDAC raises an exception. It may be analyzed in OnError event.

Syntax
procedure Open(const ASQL: String); overload;
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.Open('select * from customers');


TADRdbmsDataSet.Open Method (String, array of Variant)

TADRdbmsDataSet.Open Method (String, array of Variant)
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified SQL statement with specified parameter values and opens dataset.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
const AParams: array of Variant | And open array of parameter values.
Description

Call Open to execute the SQL statement specified in ASQL or is currently assigned to the internal command object, if ASQL is empty. And a command has parameters. Open sets the Active property for the dataset to True. When Active is true, dataset can be populated with data. It can fetch data from a database. Depending on the CanModify property, active datasets can post changes.

If an application needs to execute the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling Open for the first time, then use any Open version without specifing ASQL.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

If DBMS returns error, then AnyDAC raises an exception. It may be analyzed in OnError event.

Syntax
procedure Open(const ASQL: String; const AParams: array of Variant); overload;
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.Open('select * from Employees where department_id = :id', [100]);
....
ADQuery1.Open('', [101]); // executes the above SQL command, but for ID = 101
....
ADQuery1.Open('', [102]); // executes the above SQL command, but for ID = 101
....


TADRdbmsDataSet.Open Method (String, array of Variant, array of TFieldType)

TADRdbmsDataSet.Open Method (String, array of Variant, array of TFieldType)
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Executes the specified SQL statement with specified parameter values and opens dataset.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Parameters
Parameters | Description
const ASQL: String | A SQL command to execute.
const AParams: array of Variant | And open array of parameter values.
const ATypes: array of TFieldType | And open array of parameter data types.
Description

Call Open to execute the SQL statement specified in ASQL or is currently assigned to the internal command object, if ASQL is empty. And a command has parameters. Open sets the Active property for the dataset to True. When Active is true, dataset can be populated with data. It can fetch data from a database. Depending on the CanModify property, active datasets can post changes.

This method allows to specify exact parameter data types. If you need to leave parameter data type unchanged, then put ftUnknown into array item corresponding to the parameter.

If an application needs to execute the same SQL command many times, then an application may ordinarily set SQL property, call Prepare before calling Open for the first time, then use any Open version without specifing ASQL.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use TADAdaptedDataSet.AbortJob.

If DBMS returns error, then AnyDAC raises an exception. It may be analyzed in OnError event.

Syntax
procedure Open(const ASQL: String; const AParams: array of Variant; const ATypes: array of TFieldType); overload;
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError

Example
ADQuery1.Open('select * from Employees where department_id = :id', [100], [ftInteger]);


TADRdbmsDataSet.Prepare Method

TADRdbmsDataSet.Prepare Method
TADRdbmsDataSet Class uADCompClient Unit Example public See Also Send Feedback

Prepares SQL command for execution.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, Example, public, See Also
Description

Call the Prepar method to prepare SQL command for execution. It is not required to call Prepare for standard SQL command before execution, because first Execute / ExecSQL / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise exception will be raised.

After prepare call application cannot change command parameter data types and sizes, otherwise on next Execute / ExecSQL / ExecProc / Open call an exception will be raised. So, setup parameters before Prepare call.

Syntax
procedure Prepare;
See Also

Prepared, Unprepare, Params

Example
ADQuery1.SQL.Text := 'select * from MyTab';
ADQuery1.Prepare;


TADRdbmsDataSet.Unprepare Method

TADRdbmsDataSet.Unprepare Method
TADRdbmsDataSet Class uADCompClient Unit public See Also Send Feedback

Releases SQL command resources.

Group

public

Links
TADRdbmsDataSet Class, uADCompClient Unit, public, See Also
Description

Use Unprepare call to release prepared SQL command resources. You can unprepare command by setting Prepared to False.

Syntax
procedure Unprepare;
See Also

Prepare, Prepared

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADSchemaAdapter Class

TADSchemaAdapter Class
published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes
Syntax
TADSchemaAdapter = class(TADCustomSchemaAdapter);


published

published
TADSchemaAdapter Class Legend Published Events Send Feedback

The published members of the TADSchemaAdapter class are listed here.

Class

TADSchemaAdapter Class

Published Events
Name | Description
OnError |
OnReconcileRow |
OnUpdateRow |
Links
TADSchemaAdapter Class, Legend, Published Events


TADSchemaAdapter.OnError Event

TADSchemaAdapter.OnError Event
TADSchemaAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADSchemaAdapter Class, uADCompClient Unit, published
Syntax
property OnError: TADErrorEvent;


TADSchemaAdapter.OnReconcileRow Event

TADSchemaAdapter.OnReconcileRow Event
TADSchemaAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADSchemaAdapter Class, uADCompClient Unit, published
Syntax
property OnReconcileRow: TADReconcileRowEvent;


TADSchemaAdapter.OnUpdateRow Event

TADSchemaAdapter.OnUpdateRow Event
TADSchemaAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADSchemaAdapter Class, uADCompClient Unit, published
Syntax
property OnUpdateRow: TADUpdateRowEvent;


TADStoredProc Class

TADStoredProc Class
published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

..

Syntax
TADStoredProc = class(TADCustomStoredProc);
See Also

..


published

published
TADStoredProc Class Legend Published Events Published Properties Send Feedback

The published members of the TADStoredProc class are listed here.

Class

TADStoredProc Class

Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterExecute |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeExecute |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnDeleteError |
OnEditError |
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
CatalogName | Limits the stored procedure names to the specified catalog.
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
ObjectView |
Overload | Specifies which Oracle overloaded packaged stored procedure to execute.
PackageName | Limits the stored procedure names to the specified Oracle package name.
ParamBindMode | Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.
Params |
Prepared | Gets or sets command prepare for execution status.
ResourceOptions |
SchemaName | Limits the stored procedure names to the specified schema.
StoredProcName | Identifies the name of the stored procedure on the server to call.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.
Links
TADStoredProc Class, Legend, Published Events, Published Properties


TADStoredProc.Active Property

TADStoredProc.Active Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Active;


TADStoredProc.ActiveStoredUsage Property

TADStoredProc.ActiveStoredUsage Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADStoredProc.AfterApplyUpdates Event

TADStoredProc.AfterApplyUpdates Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterApplyUpdates: TADAfterApplyUpdatesEvent;


TADStoredProc.AfterCancel Property

TADStoredProc.AfterCancel Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterCancel;


TADStoredProc.AfterClose Property

TADStoredProc.AfterClose Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterClose;


TADStoredProc.AfterDelete Property

TADStoredProc.AfterDelete Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterDelete;


TADStoredProc.AfterEdit Property

TADStoredProc.AfterEdit Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterEdit;


TADStoredProc.AfterExecute Event

TADStoredProc.AfterExecute Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterExecute: TADDataSetEvent;


TADStoredProc.AfterGetRecords Event

TADStoredProc.AfterGetRecords Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterGetRecords: TADDataSetEvent;


TADStoredProc.AfterInsert Property

TADStoredProc.AfterInsert Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterInsert;


TADStoredProc.AfterOpen Property

TADStoredProc.AfterOpen Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterOpen;


TADStoredProc.AfterPost Property

TADStoredProc.AfterPost Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterPost;


TADStoredProc.AfterRefresh Property

TADStoredProc.AfterRefresh Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterRefresh;


TADStoredProc.AfterRowRequest Event

TADStoredProc.AfterRowRequest Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterRowRequest: TADDataSetEvent;


TADStoredProc.AfterScroll Property

TADStoredProc.AfterScroll Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AfterScroll;


TADStoredProc.Aggregates Property

TADStoredProc.Aggregates Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Aggregates: TADAggregates;


TADStoredProc.AggregatesActive Property

TADStoredProc.AggregatesActive Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AggregatesActive: Boolean;


TADStoredProc.AutoCalcFields Property

TADStoredProc.AutoCalcFields Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property AutoCalcFields;


TADStoredProc.BeforeApplyUpdates Event

TADStoredProc.BeforeApplyUpdates Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeApplyUpdates: TADDataSetEvent;


TADStoredProc.BeforeCancel Property

TADStoredProc.BeforeCancel Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeCancel;


TADStoredProc.BeforeClose Property

TADStoredProc.BeforeClose Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeClose;


TADStoredProc.BeforeDelete Property

TADStoredProc.BeforeDelete Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeDelete;


TADStoredProc.BeforeEdit Property

TADStoredProc.BeforeEdit Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeEdit;


TADStoredProc.BeforeExecute Event

TADStoredProc.BeforeExecute Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeExecute: TADDataSetEvent;


TADStoredProc.BeforeGetRecords Event

TADStoredProc.BeforeGetRecords Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeGetRecords: TADDataSetEvent;


TADStoredProc.BeforeInsert Property

TADStoredProc.BeforeInsert Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeInsert;


TADStoredProc.BeforeOpen Property

TADStoredProc.BeforeOpen Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeOpen;


TADStoredProc.BeforePost Property

TADStoredProc.BeforePost Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforePost;


TADStoredProc.BeforeRefresh Property

TADStoredProc.BeforeRefresh Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeRefresh;


TADStoredProc.BeforeRowRequest Event

TADStoredProc.BeforeRowRequest Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeRowRequest: TADDataSetEvent;


TADStoredProc.BeforeScroll Property

TADStoredProc.BeforeScroll Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property BeforeScroll;


TADStoredProc.CachedUpdates Property

TADStoredProc.CachedUpdates Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property CachedUpdates: Boolean;


TADStoredProc.CatalogName Property

TADStoredProc.CatalogName Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Limits the stored procedure names to the specified catalog.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Specify the CatalogName property value to limit the set of stored procedures to the specified catalog.

Syntax
property CatalogName: String;
See Also

SchemaName, PackageName, Overload, StoredProcName


TADStoredProc.Connection Property

TADStoredProc.Connection Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Specifies the AnyDAC connection component to use.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Use Connection to specify an AnyDAC connection object to use to connect to an DBMS.

At design-time, select from the list of available TADCustomConnection objects (if any have been added to the application) invoked from the Object Inspector. If a form or data module has TADCustomConnection dropped on it, then TADRdbmsDataSet assigns this connection object to Connection property automatically right after dropping on the form or data module.

At runtime, set Connection to reference an existing TADConnection object.

The TADRdbmsDataSet can be binded to TADCustomConnection object using Connection or ConnectionName property. Using ConnectionName property allows to bind to a connection object, if it is even not yet created or is not accessible.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADStoredProc.ConnectionName Property

TADStoredProc.ConnectionName Property
TADStoredProc Class uADCompClient Unit Example published See Also Send Feedback

Specifies the AnyDAC connection to use by its name.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, Example, published, See Also
Description

Use ConnectionName to specify an AnyDAC connection to use to connect to an DBMS. The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file (persistent) or created on fly (private);
  • ConnectionName of one of the TADConnection objects.

The ConnectionName property value must be specified before Prepare call. If it matches the name of one of connection definitions, then AnyDAC will transparently create connection object and link the dataset with it.

The TADRdbmsDataSet cab be binded to TADCustomConnection object using Connection or ConnectionName property. Using Connection property allows to bind to a connection object explicitly and reduce the overhead for resolving connection names.

Syntax
property ConnectionName: String;
See Also

Connection, TADCustomConnection.Temporary

Example
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


TADStoredProc.Constraints Property

TADStoredProc.Constraints Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Constraints;


TADStoredProc.ConstraintsEnabled Property

TADStoredProc.ConstraintsEnabled Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property ConstraintsEnabled: Boolean;


TADStoredProc.FetchOptions Property

TADStoredProc.FetchOptions Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property FetchOptions;


TADStoredProc.Filter Property

TADStoredProc.Filter Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Filter;


TADStoredProc.FilterChanges Property

TADStoredProc.FilterChanges Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property FilterChanges: TUpdateRecordTypes;


TADStoredProc.Filtered Property

TADStoredProc.Filtered Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Filtered;


TADStoredProc.FilterOptions Property

TADStoredProc.FilterOptions Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property FilterOptions;


TADStoredProc.FormatOptions Property

TADStoredProc.FormatOptions Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property FormatOptions;


TADStoredProc.Indexes Property

TADStoredProc.Indexes Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Indexes: TADIndexes;


TADStoredProc.IndexesActive Property

TADStoredProc.IndexesActive Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property IndexesActive: Boolean;


TADStoredProc.IndexFieldNames Property

TADStoredProc.IndexFieldNames Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property IndexFieldNames: String;


TADStoredProc.IndexName Property

TADStoredProc.IndexName Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property IndexName: String;


TADStoredProc.ObjectView Property

TADStoredProc.ObjectView Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property ObjectView;


TADStoredProc.OnCalcFields Property

TADStoredProc.OnCalcFields Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnCalcFields;


TADStoredProc.OnCommandChanged Event

TADStoredProc.OnCommandChanged Event
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Fires after the SQL property value is changed.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

The OnCommandChanged event fires after the SQL command text value is changed:

  • for TADQuery - after SQL is changed;
  • for TADStoredProc - after StoredProcName is changed;
  • for TADTable - after TableName is changed.
Syntax
property OnCommandChanged: TNotifyEvent;
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


TADStoredProc.OnDeleteError Property

TADStoredProc.OnDeleteError Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnDeleteError;


TADStoredProc.OnEditError Property

TADStoredProc.OnEditError Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnEditError;


TADStoredProc.OnError Event

TADStoredProc.OnError Event
TADStoredProc Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while dataset is communicating with DBMS.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when dataset executes one of the following operations and an error happens:

  • Prepare. The dataset is preparing DBMS command text for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • Execute, ExecSQL, ExecProc. The dataset is executing DBMS command text.
  • Navigation methods. The dataset is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use a code like in the first example.

To centralize error handling, you can consider to use TADCustomConnection.OnError.

Syntax
property OnError: TADErrorEvent;
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError

Example 1

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADStoredProc.OnExecuteError Event

TADStoredProc.OnExecuteError Event
TADStoredProc Class uADCompClient Unit Example published See Also Send Feedback

The event is triggered when an error happens, while executing a Array DML query.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, Example, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
ATimes | The current Array DML size. It may be different from value of the Execute method ATimes parameter, if full operation is splitted into few more small (on Firebird, for example).
AOffset | The current Array DML offset. It may be different from value of the Execute method AOffset parameter, if there was skiped erroneous rows or full operation is splitted into few more small (on Firebird, for example).
AException | The original DBMS returned error. Check AException.Errors[i].RowIndex for the index of errorneous row in parameters array.
AAction | The action dataset should take after return from event handler.
Description

The OnExecuteError event is triggered, when dataset executes Array DML using Execute method and ATimes > 1. Using this event handler you can:

  • skip erroneous row of the parameters array;
  • change values in erroneous row of the parameters array;
  • stop full Array DML execution.
Syntax
property OnExecuteError: TADExecuteErrorEvent;
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute

Example
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


TADStoredProc.OnFilterRecord Property

TADStoredProc.OnFilterRecord Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnFilterRecord;


TADStoredProc.OnNewRecord Property

TADStoredProc.OnNewRecord Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnNewRecord;


TADStoredProc.OnPostError Property

TADStoredProc.OnPostError Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnPostError;


TADStoredProc.OnReconcileError Event

TADStoredProc.OnReconcileError Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnReconcileError: TADReconcileErrorEvent;


TADStoredProc.OnUpdateError Event

TADStoredProc.OnUpdateError Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnUpdateError: TADUpdateErrorEvent;


TADStoredProc.OnUpdateRecord Event

TADStoredProc.OnUpdateRecord Event
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property OnUpdateRecord: TADUpdateRecordEvent;


TADStoredProc.Overload Property

TADStoredProc.Overload Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Specifies which Oracle overloaded packaged stored procedure to execute.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Use Overload to specify which overloaded stored procedure to execute on an Oracle server. An Oracle overloaded stored procedure is one that shares a name with one or more other stored procedures. Oracle distinguishes among overloaded stored procedures by assigning each procedure a unique numeric identifier. An application can specify this identifier using the Overload property.

By default, Overload is zero, which assumes there is no procedure overloading. For all servers except Oracle, this value will not have the effect. If an application attempts to access an Oracle overloaded procedure without setting Overload, the AnyDAC accesses the lowest numbered, or first, overloaded procedure on the server.

If Overload is 1, the AnyDAC executes the first overloaded procedure on the server. If Overload is 2, it executes the second, and so on.

While Oracle overloaded procedures share names, their parameter lists are unique. An application must ensure that it passes the correct parameter list to an overloaded procedure.

Syntax
property Overload: Word;
See Also

Params, StoredProcName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADStoredProc.PackageName Property

TADStoredProc.PackageName Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Limits the stored procedure names to the specified Oracle package name.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Specify the PackageName property value to limit the procedure name to the specified Oracle package.

Syntax
property PackageName: String;
See Also

CatalogName, SchemaName, Overload, StoredProcName


TADStoredProc.ParamBindMode Property

TADStoredProc.ParamBindMode Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Get or set ParamBindMode to determine the order in which parameters in the Params property are matched to the parameters used by the SQL command on the server. ParamBindMode can be one of the following:

Value | Ordering
pbByName | Parameters specified in the Params property are matched to identically named parameters on the server. This is the default.
pbByNumber | Parameters in Params are assigned one-by-one to the next available parameter on the server (for example, the first parameter in Params is assigned to the first parameter used by the SQL command, and so on).

Whenever possible, ParamBindMode should be pbByName. This guarantees that parameters are matched to the correct parameters used by the SQL command regardless of physical ordering in Params. At design time, the names of known parameters appear in the Parameters editor.

Syntax
property ParamBindMode;
See Also

Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADStoredProc.Params Property

TADStoredProc.Params Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property Params;


TADStoredProc.Prepared Property

TADStoredProc.Prepared Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Gets or sets command prepare for execution status.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Set Prepared to True to prepare SQL command for execution. Setting Prepared to True, will call Prepare method. It is not required to set Prepared to True for standard SQL command before execution, because first Execute / ExecSQL / Open call will automatically prepare command. But it is required for stored procedures, if you need to automatically populate Params collection. After command is prepared, SQLText will return SQL command text as it is sent to the DBMS.

To prepare SQL command DBMS connection must be active, otherwise an exception will be raised.

After SQL command preparation application cannot change command parameter data types and sizes, otherwise on next Execute or Open call an exception will be raised. So, setup parameters before setting Prepared to True.

Set Prepared to False to unprepare SQL command and release all it resources. Setting Prepared to False, will call Unprepare method.

Syntax
property Prepared;
See Also

Prepare, Unprepare, Params

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADStoredProc.ResourceOptions Property

TADStoredProc.ResourceOptions Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property ResourceOptions;


TADStoredProc.SchemaName Property

TADStoredProc.SchemaName Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Limits the stored procedure names to the specified schema.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

Specify the SchemaName property value to limit the set of schemas to the specified schema.

Syntax
property SchemaName: String;
See Also

CatalogName, PackageName, Overload, StoredProcName


TADStoredProc.StoredProcName Property

TADStoredProc.StoredProcName Property
TADStoredProc Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Identifies the name of the stored procedure on the server to call.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

Set StoredProcName to specify the name of the stored in database procedure to call. The full name of the stored procedure will be build from CatalogName, SchemaName, PackageName, Overload property values. Also a full name may be assigned to the StoredProcName (on Oracle only for non-packaged procedures). If name is case sensitive or contains special characters, then it must be explicitly quoted.

If database does not have stored procedure with StoredProcName name, then when the application attempts to prepare the stored procedure, an exception will be raised.

Syntax
property StoredProcName: string;
See Also

CatalogName, SchemaName, PackageName, Overload

Example 1
ADStoredProc1.StoredProcName := 'Northwind.dbo.[my proc]';
// the same as following
ADStoredProc1.CatalogName := 'Northwind';
ADStoredProc1.SchemaName := 'dbo';
ADStoredProc1.StoredProcName := '[my proc]';
Example 2
ADStoredProc1.PackageName := 'sys.dbms_sql';
ADStoredProc1.StoredProcName := 'execute';


TADStoredProc.Transaction Property

TADStoredProc.Transaction Property
TADStoredProc Class uADCompClient Unit published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, published, See Also
Description

The Transaction property allows to associate dataset with explicit transaction object. If it is not specified, then dataset will be associated with connection default transaction.

The specified transaction object will be used only for Prepare, Open, ExecSQL, ExecProc, Execute methods. For commands, generated to apply changes to database, AnyDAC will use UpdateTransaction, if it is specified, otherwise - Transaction.

Currently explicit transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomConnection.Transaction


TADStoredProc.UpdateObject Property

TADStoredProc.UpdateObject Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property UpdateObject;


TADStoredProc.UpdateOptions Property

TADStoredProc.UpdateOptions Property
TADStoredProc Class uADCompClient Unit published Send Feedback
Group

published

Links
TADStoredProc Class, uADCompClient Unit, published
Syntax
property UpdateOptions;


TADStoredProc.UpdateTransaction Property

TADStoredProc.UpdateTransaction Property
TADStoredProc Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADStoredProc Class, uADCompClient Unit, Example, published, See Also
Description

The UpdateTransaction property allows to associate dataset internal update commands with explicit transaction object. If it is not specified, then dataset update commands will be associated with connection default update transaction. If it is not specified, then - with dataset Transaction.

For Prepare, Open, ExecSQL, ExecProc, Execute methods will be used Transaction objects.

Currently explicit update transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomConnection.UpdateTransaction

Example
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


TADTable Class

TADTable Class
public published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, published, Classes, See Also
Description

..

Syntax
TADTable = class(TADCustomQuery);
See Also

..


public

public
TADTable Class Legend Public Methods Send Feedback

The public members of the TADTable class are listed here.

Class

TADTable Class

Public Methods
Name | Description
Create |
Links
TADTable Class, Legend, Public Methods
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTable.Create Constructor

TADTable.Create Constructor
TADTable Class uADCompClient Unit public Send Feedback
Group

public

Links
TADTable Class, uADCompClient Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


published

published
TADTable Class Legend Published Events Published Properties Send Feedback

The published members of the TADTable class are listed here.

Class

TADTable Class

Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnDeleteError |
OnEditError |
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
CatalogName | Limits the table names to the catalog.
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
Exclusive |
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MasterFields |
MasterSource |
ObjectView |
ResourceOptions |
SchemaName | Limits the table names to the schema.
TableName | Gets / sets table name to open.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.
Links
TADTable Class, Legend, Published Events, Published Properties


TADTable.Active Property

TADTable.Active Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Active;


TADTable.ActiveStoredUsage Property

TADTable.ActiveStoredUsage Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;


TADTable.AfterApplyUpdates Event

TADTable.AfterApplyUpdates Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterApplyUpdates: TADAfterApplyUpdatesEvent;


TADTable.AfterCancel Property

TADTable.AfterCancel Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterCancel;


TADTable.AfterClose Property

TADTable.AfterClose Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterClose;


TADTable.AfterDelete Property

TADTable.AfterDelete Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterDelete;


TADTable.AfterEdit Property

TADTable.AfterEdit Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterEdit;


TADTable.AfterGetRecords Event

TADTable.AfterGetRecords Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterGetRecords: TADDataSetEvent;


TADTable.AfterInsert Property

TADTable.AfterInsert Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterInsert;


TADTable.AfterOpen Property

TADTable.AfterOpen Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterOpen;


TADTable.AfterPost Property

TADTable.AfterPost Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterPost;


TADTable.AfterRefresh Property

TADTable.AfterRefresh Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterRefresh;


TADTable.AfterRowRequest Event

TADTable.AfterRowRequest Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterRowRequest: TADDataSetEvent;


TADTable.AfterScroll Property

TADTable.AfterScroll Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AfterScroll;


TADTable.Aggregates Property

TADTable.Aggregates Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Aggregates: TADAggregates;


TADTable.AggregatesActive Property

TADTable.AggregatesActive Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AggregatesActive: Boolean;


TADTable.AutoCalcFields Property

TADTable.AutoCalcFields Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property AutoCalcFields;


TADTable.BeforeApplyUpdates Event

TADTable.BeforeApplyUpdates Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeApplyUpdates: TADDataSetEvent;


TADTable.BeforeCancel Property

TADTable.BeforeCancel Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeCancel;


TADTable.BeforeClose Property

TADTable.BeforeClose Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeClose;


TADTable.BeforeDelete Property

TADTable.BeforeDelete Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeDelete;


TADTable.BeforeEdit Property

TADTable.BeforeEdit Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeEdit;


TADTable.BeforeGetRecords Event

TADTable.BeforeGetRecords Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeGetRecords: TADDataSetEvent;


TADTable.BeforeInsert Property

TADTable.BeforeInsert Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeInsert;


TADTable.BeforeOpen Property

TADTable.BeforeOpen Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeOpen;


TADTable.BeforePost Property

TADTable.BeforePost Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforePost;


TADTable.BeforeRefresh Property

TADTable.BeforeRefresh Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeRefresh;


TADTable.BeforeRowRequest Event

TADTable.BeforeRowRequest Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeRowRequest: TADDataSetEvent;


TADTable.BeforeScroll Property

TADTable.BeforeScroll Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property BeforeScroll;


TADTable.CachedUpdates Property

TADTable.CachedUpdates Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property CachedUpdates: Boolean;


TADTable.CatalogName Property

TADTable.CatalogName Property
TADTable Class uADCompClient Unit published See Also Send Feedback

Limits the table names to the catalog.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

Specify the CatalogName property value to limit the set of catalogs to the single value.

Syntax
property CatalogName: String;
See Also

SchemaName, TableName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTable.Connection Property

TADTable.Connection Property
TADTable Class uADCompClient Unit published See Also Send Feedback

Specifies the AnyDAC connection component to use.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

Use Connection to specify an AnyDAC connection object to use to connect to an DBMS.

At design-time, select from the list of available TADCustomConnection objects (if any have been added to the application) invoked from the Object Inspector. If a form or data module has TADCustomConnection dropped on it, then TADRdbmsDataSet assigns this connection object to Connection property automatically right after dropping on the form or data module.

At runtime, set Connection to reference an existing TADConnection object.

The TADRdbmsDataSet can be binded to TADCustomConnection object using Connection or ConnectionName property. Using ConnectionName property allows to bind to a connection object, if it is even not yet created or is not accessible.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTable.ConnectionName Property

TADTable.ConnectionName Property
TADTable Class uADCompClient Unit Example published See Also Send Feedback

Specifies the AnyDAC connection to use by its name.

Group

published

Links
TADTable Class, uADCompClient Unit, Example, published, See Also
Description

Use ConnectionName to specify an AnyDAC connection to use to connect to an DBMS. The ConnectionName property value specifies the name of the connection. It must match to the:

  • name of one of connection definitions, either stored in external file (persistent) or created on fly (private);
  • ConnectionName of one of the TADConnection objects.

The ConnectionName property value must be specified before Prepare call. If it matches the name of one of connection definitions, then AnyDAC will transparently create connection object and link the dataset with it.

The TADRdbmsDataSet cab be binded to TADCustomConnection object using Connection or ConnectionName property. Using Connection property allows to bind to a connection object explicitly and reduce the overhead for resolving connection names.

Syntax
property ConnectionName: String;
See Also

Connection, TADCustomConnection.Temporary

Example
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


TADTable.Constraints Property

TADTable.Constraints Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Constraints;


TADTable.ConstraintsEnabled Property

TADTable.ConstraintsEnabled Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property ConstraintsEnabled: Boolean;


TADTable.Exclusive Property

TADTable.Exclusive Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Exclusive: Boolean;


TADTable.FetchOptions Property

TADTable.FetchOptions Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property FetchOptions;


TADTable.Filter Property

TADTable.Filter Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Filter;


TADTable.FilterChanges Property

TADTable.FilterChanges Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property FilterChanges: TUpdateRecordTypes;


TADTable.Filtered Property

TADTable.Filtered Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Filtered;


TADTable.FilterOptions Property

TADTable.FilterOptions Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property FilterOptions;


TADTable.FormatOptions Property

TADTable.FormatOptions Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property FormatOptions;


TADTable.Indexes Property

TADTable.Indexes Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property Indexes: TADIndexes;


TADTable.IndexesActive Property

TADTable.IndexesActive Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property IndexesActive: Boolean;


TADTable.IndexFieldNames Property

TADTable.IndexFieldNames Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property IndexFieldNames: String;


TADTable.IndexName Property

TADTable.IndexName Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property IndexName: String;


TADTable.MasterFields Property

TADTable.MasterFields Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property MasterFields: String;


TADTable.MasterSource Property

TADTable.MasterSource Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property MasterSource: TDataSource;


TADTable.ObjectView Property

TADTable.ObjectView Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property ObjectView;


TADTable.OnCalcFields Property

TADTable.OnCalcFields Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnCalcFields;


TADTable.OnCommandChanged Event

TADTable.OnCommandChanged Event
TADTable Class uADCompClient Unit published See Also Send Feedback

Fires after the SQL property value is changed.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

The OnCommandChanged event fires after the SQL command text value is changed:

  • for TADQuery - after SQL is changed;
  • for TADStoredProc - after StoredProcName is changed;
  • for TADTable - after TableName is changed.
Syntax
property OnCommandChanged: TNotifyEvent;
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


TADTable.OnDeleteError Property

TADTable.OnDeleteError Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnDeleteError;


TADTable.OnEditError Property

TADTable.OnEditError Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnEditError;


TADTable.OnError Event

TADTable.OnError Event
TADTable Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

The event fires when an error happens, while dataset is communicating with DBMS.

Group

published

Links
TADTable Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
AInitiator | The reference to interface of object, which initially raised the exception.
AException | The exception object, which may be modified or even replaced by another exception object instance.
Description

The OnError event fires, when dataset executes one of the following operations and an error happens:

  • Prepare. The dataset is preparing DBMS command text for execution.
  • Open. The dataset is executing DBMS command to open cursor.
  • Execute, ExecSQL, ExecProc. The dataset is executing DBMS command text.
  • Navigation methods. The dataset is fetching rows from cursor.

If most cases AException object will of EADDBEngineException class. If AException is of EADPhysArrayExecuteError class, then it is Array DML error handling case. You should use a code like in the first example.

To centralize error handling, you can consider to use TADCustomConnection.OnError.

Syntax
property OnError: TADErrorEvent;
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError

Example 1

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;
Example 2

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


TADTable.OnExecuteError Event

TADTable.OnExecuteError Event
TADTable Class uADCompClient Unit Example published See Also Send Feedback

The event is triggered when an error happens, while executing a Array DML query.

Group

published

Links
TADTable Class, uADCompClient Unit, Example, published, See Also
Parameters
Parameters | Description
ASender | The reference to dataset.
ATimes | The current Array DML size. It may be different from value of the Execute method ATimes parameter, if full operation is splitted into few more small (on Firebird, for example).
AOffset | The current Array DML offset. It may be different from value of the Execute method AOffset parameter, if there was skiped erroneous rows or full operation is splitted into few more small (on Firebird, for example).
AException | The original DBMS returned error. Check AException.Errors[i].RowIndex for the index of errorneous row in parameters array.
AAction | The action dataset should take after return from event handler.
Description

The OnExecuteError event is triggered, when dataset executes Array DML using Execute method and ATimes > 1. Using this event handler you can:

  • skip erroneous row of the parameters array;
  • change values in erroneous row of the parameters array;
  • stop full Array DML execution.
Syntax
property OnExecuteError: TADExecuteErrorEvent;
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute

Example
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


TADTable.OnFilterRecord Property

TADTable.OnFilterRecord Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnFilterRecord;


TADTable.OnNewRecord Property

TADTable.OnNewRecord Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnNewRecord;


TADTable.OnPostError Property

TADTable.OnPostError Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnPostError;


TADTable.OnReconcileError Event

TADTable.OnReconcileError Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnReconcileError: TADReconcileErrorEvent;


TADTable.OnUpdateError Event

TADTable.OnUpdateError Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnUpdateError: TADUpdateErrorEvent;


TADTable.OnUpdateRecord Event

TADTable.OnUpdateRecord Event
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property OnUpdateRecord: TADUpdateRecordEvent;


TADTable.ResourceOptions Property

TADTable.ResourceOptions Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property ResourceOptions;


TADTable.SchemaName Property

TADTable.SchemaName Property
TADTable Class uADCompClient Unit published See Also Send Feedback

Limits the table names to the schema.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

Specify the SchemaName property value to limit the set of schemas to the single value.

Syntax
property SchemaName: String;
See Also

CatalogName, TableName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTable.TableName Property

TADTable.TableName Property
TADTable Class uADCompClient Unit published See Also Send Feedback

Gets / sets table name to open.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

The TableName property value together with CatalogName and SchemaName forms the full table name. AnyDAC will build SELECT statement to fetch data from specified table.

Syntax
property TableName: String;
See Also

CatalogName, SchemaName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTable.Transaction Property

TADTable.Transaction Property
TADTable Class uADCompClient Unit published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADTable Class, uADCompClient Unit, published, See Also
Description

The Transaction property allows to associate dataset with explicit transaction object. If it is not specified, then dataset will be associated with connection default transaction.

The specified transaction object will be used only for Prepare, Open, ExecSQL, ExecProc, Execute methods. For commands, generated to apply changes to database, AnyDAC will use UpdateTransaction, if it is specified, otherwise - Transaction.

Currently explicit transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property Transaction: TADCustomTransaction;
See Also

UpdateTransaction, TADCustomConnection.Transaction


TADTable.UpdateObject Property

TADTable.UpdateObject Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property UpdateObject;


TADTable.UpdateOptions Property

TADTable.UpdateOptions Property
TADTable Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTable Class, uADCompClient Unit, published
Syntax
property UpdateOptions;


TADTable.UpdateTransaction Property

TADTable.UpdateTransaction Property
TADTable Class uADCompClient Unit Example published See Also Send Feedback

Gets / sets reference to transaction object.

Group

published

Links
TADTable Class, uADCompClient Unit, Example, published, See Also
Description

The UpdateTransaction property allows to associate dataset internal update commands with explicit transaction object. If it is not specified, then dataset update commands will be associated with connection default update transaction. If it is not specified, then - with dataset Transaction.

For Prepare, Open, ExecSQL, ExecProc, Execute methods will be used Transaction objects.

Currently explicit update transaction object assignment is supported only for Interbase / Firebird servers.

Syntax
property UpdateTransaction: TADCustomTransaction;
See Also

Transaction, TADCustomConnection.UpdateTransaction

Example
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


TADTableAdapter Class

TADTableAdapter Class
published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes
Syntax
TADTableAdapter = class(TADCustomTableAdapter);


published

published
TADTableAdapter Class Legend Published Events Published Properties Send Feedback

The published members of the TADTableAdapter class are listed here.

Class

TADTableAdapter Class

Published Events
Name | Description
OnDescribeColumn |
OnDescribeTable |
OnError |
OnReconcileRow |
OnUpdateRow |
Published Properties
Name | Description
ColumnMappings |
DatSTableName |
DeleteCommand |
FetchRowCommand |
InsertCommand |
LockCommand |
MetaInfoMergeMode |
SchemaAdapter |
SelectCommand |
SourceRecordSetID |
SourceRecordSetName |
UnLockCommand |
UpdateCommand |
UpdateTableName |
UpdateTransaction |
Links
TADTableAdapter Class, Legend, Published Events, Published Properties


TADTableAdapter.ColumnMappings Property

TADTableAdapter.ColumnMappings Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property ColumnMappings: TADDAptColumnMappings;


TADTableAdapter.DatSTableName Property

TADTableAdapter.DatSTableName Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property DatSTableName: String;


TADTableAdapter.DeleteCommand Property

TADTableAdapter.DeleteCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property DeleteCommand: TADCustomCommand;


TADTableAdapter.FetchRowCommand Property

TADTableAdapter.FetchRowCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property FetchRowCommand: TADCustomCommand;


TADTableAdapter.InsertCommand Property

TADTableAdapter.InsertCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property InsertCommand: TADCustomCommand;


TADTableAdapter.LockCommand Property

TADTableAdapter.LockCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property LockCommand: TADCustomCommand;


TADTableAdapter.MetaInfoMergeMode Property

TADTableAdapter.MetaInfoMergeMode Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property MetaInfoMergeMode: TADPhysMetaInfoMergeMode;


TADTableAdapter.OnDescribeColumn Event

TADTableAdapter.OnDescribeColumn Event
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property OnDescribeColumn: TADDescribeColumnEvent;


TADTableAdapter.OnDescribeTable Event

TADTableAdapter.OnDescribeTable Event
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property OnDescribeTable: TADDescribeTableEvent;


TADTableAdapter.OnError Event

TADTableAdapter.OnError Event
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property OnError: TADErrorEvent;


TADTableAdapter.OnReconcileRow Event

TADTableAdapter.OnReconcileRow Event
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property OnReconcileRow: TADReconcileRowEvent;


TADTableAdapter.OnUpdateRow Event

TADTableAdapter.OnUpdateRow Event
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property OnUpdateRow: TADUpdateRowEvent;


TADTableAdapter.SchemaAdapter Property

TADTableAdapter.SchemaAdapter Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property SchemaAdapter: TADCustomSchemaAdapter;


TADTableAdapter.SelectCommand Property

TADTableAdapter.SelectCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property SelectCommand: TADCustomCommand;


TADTableAdapter.SourceRecordSetID Property

TADTableAdapter.SourceRecordSetID Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property SourceRecordSetID: Integer;


TADTableAdapter.SourceRecordSetName Property

TADTableAdapter.SourceRecordSetName Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property SourceRecordSetName: String;


TADTableAdapter.UnLockCommand Property

TADTableAdapter.UnLockCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property UnLockCommand: TADCustomCommand;


TADTableAdapter.UpdateCommand Property

TADTableAdapter.UpdateCommand Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property UpdateCommand: TADCustomCommand;


TADTableAdapter.UpdateTableName Property

TADTableAdapter.UpdateTableName Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property UpdateTableName: String;


TADTableAdapter.UpdateTransaction Property

TADTableAdapter.UpdateTransaction Property
TADTableAdapter Class uADCompClient Unit published Send Feedback
Group

published

Links
TADTableAdapter Class, uADCompClient Unit, published
Syntax
property UpdateTransaction: TADCustomTransaction;


TADTransaction Class

TADTransaction Class
published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
published, Classes, See Also
Description

..

Syntax
TADTransaction = class(TADCustomTransaction);
See Also

..


published

published
TADTransaction Class Legend Published Properties Send Feedback

The published members of the TADTransaction class are listed here.

Class

TADTransaction Class

Published Properties
Name | Description
Connection | Specifies the connection component that actually forms the connection to the DBMS.
Options | The set of options controlling transactions behaviour.
Links
TADTransaction Class, Legend, Published Properties


TADTransaction.Connection Property

TADTransaction.Connection Property
TADTransaction Class uADCompClient Unit published See Also Send Feedback

Specifies the connection component that actually forms the connection to the DBMS.

Group

published

Links
TADTransaction Class, uADCompClient Unit, published, See Also
Description

Set Connection to the connection component that establishes a connection to the DBMS. If to change Connection property value, while transaction is active, an exception will be raised.

Syntax
property Connection: TADCustomConnection;
See Also

IsActive

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADTransaction.Options Property

TADTransaction.Options Property
TADTransaction Class uADCompClient Unit Example published See Also Send Feedback

The set of options controlling transactions behaviour.

Group

published

Links
TADTransaction Class, uADCompClient Unit, Example, published, See Also
Description

The Options property returns reference to object, consisting of the set of options, controlling transactions behaviour. Changing options will not take immediate effect, it is deferred until first transaction control statement.

Syntax
property Options: TADTxOptions;
See Also

StartTransaction, Commit, Rollback

Example
ADTransaction1.Options.ReadOnly := True;
ADTransaction1.StartTransaction;


TADUpdateSQL Class

TADUpdateSQL Class
public published Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompClient

Links
public, published, Classes, See Also
Description

..

Syntax
TADUpdateSQL = class(TADCustomUpdateObject);
See Also

..


public

public
TADUpdateSQL Class Legend Public Methods Public Properties Send Feedback

The public members of the TADUpdateSQL class are listed here.

Class

TADUpdateSQL Class

Public Methods
Name | Description
Apply | Applies record update request to DB for current record in DataSet.
Create |
Destroy |
Public Properties
Name | Description
Commands | Returns reference to internal command object, that will handle update request.
SQL | Gets / sets a specified SQL statement used when applying updates to DB.
Links
TADUpdateSQL Class, Legend, Public Methods, Public Properties


TADUpdateSQL.Commands Property

TADUpdateSQL.Commands Property
TADUpdateSQL Class uADCompClient Unit Example public See Also Send Feedback

Returns reference to internal command object, that will handle update request.

Group

public

Links
TADUpdateSQL Class, uADCompClient Unit, Example, public, See Also
Description

The Commands indexed property returns reference to internal TADCustomCommand objects, that will handle update request, specified by ARequest index. Use this reference to setup command properties not accessible through TADUpdateSQL interface. For example, Params or Macros.

Syntax
property Commands [ARequest: TADPhysUpdateRequest]: TADCustomCommand;
See Also

TADCustomCommand, TADCustomCommand.Params, TADCustomCommand.Macros, SQL

Example
ADUpdateSQL1.InsertSQL := 'insert into !tab (workstation_time, id, name) values (:workstation_time, :new_id, :new_name)';
ADUpdateSQL1.Commands[arInsert].ParamByName('workstation_time').AsDateTime := Now();
ADUpdateSQL1.Commands[arInsert].MacroByName('tab').AsRaw := 'mytab';


TADUpdateSQL.SQL Property

TADUpdateSQL.SQL Property
TADUpdateSQL Class uADCompClient Unit public See Also Send Feedback

Gets / sets a specified SQL statement used when applying updates to DB.

Group

public

Links
TADUpdateSQL Class, uADCompClient Unit, public, See Also
Description

Returns the SQL statement in the one of XxxSQL properties, depending on the setting of the ARequest index.

Syntax
property SQL [ARequest: TADPhysUpdateRequest]: TStrings;
See Also

Commands, InsertSQL, ModifySQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL


TADUpdateSQL.Apply Method

TADUpdateSQL.Apply Method
TADUpdateSQL Class uADCompClient Unit Example 1 Example 2 public See Also Send Feedback

Applies record update request to DB for current record in DataSet.

Group

public

Links
TADUpdateSQL Class, uADCompClient Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
ARequest: TADPhysUpdateRequest | A record update request.
var AAction: TADErrorAction | A completion status.
AOptions: TADPhysUpdateRowOptions | An additional request options.
Description

Call Apply to apply changes of current record in DataSet to database. ARequest indicates which update request must be handled.

Standard implementation - TADUpdateSQL - sets parameters for an SQL statement and execute it to update a record. So, ARequest indicates which SQL statement to bind and execute. If appropriate SQL statement is not specified, then AnyDAC will generate default one, as it is doing if TADAdaptedDataSet.UpdateObject is not specified.

ARequest update request can be one of the following values:

Value | Meaning | TADUpdateSQL SQL property
arInsert | Insert record to database. | InsertSQL
arUpdate | Update record in database. | ModifySQL
arDelete | Delete record from database. | DeleteSQL
arLock | Lock record in database. | LockSQL
arUnlock | Release record lock in database. | UnlockSQL
arFetchRow | Refetch record from database. | FetchRowSQL
arUpdateHBlobs | Update Oracle BLOB/CLOB values in database. | -
arFetchGenerators | Fetch generator values to put into record. | -

Apply is primarily intended for manually executing update statements from an OnUpdateRecord event handler. There event handler ARequest, AAction and AOptions argument values must be assigned to Apply method corresponding arguments.

Syntax
procedure Apply(ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction; AOptions: TADPhysUpdateRowOptions); override;
See Also

TADUpdateSQL, TADAdaptedDataSet.UpdateObject

Example 1
procedure TfrmCachedUpdates.qrProductsUpdateRecord(ASender: TDataSet;
      ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction;
      AOptions: TADPhysUpdateRowOptions);
begin
  usProducts.ConnectionName := qrProducts.ConnectionName;
  usProducts.DataSet := qrProducts;
  usProducts.Apply(ARequest, AAction, AOptions);

  usCategories.ConnectionName := qrProducts.ConnectionName;
  usCategories.DataSet := qrProducts;
  usCategories.Apply(ARequest, AAction, AOptions);

  AAction := eaApplied;
end;
Example 2

See AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main demo application.


TADUpdateSQL.Create Constructor

TADUpdateSQL.Create Constructor
TADUpdateSQL Class uADCompClient Unit public Send Feedback
Group

public

Links
TADUpdateSQL Class, uADCompClient Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


TADUpdateSQL.Destroy Destructor

TADUpdateSQL.Destroy Destructor
TADUpdateSQL Class uADCompClient Unit public Send Feedback
Group

public

Links
TADUpdateSQL Class, uADCompClient Unit, public
Syntax
destructor Destroy; override;


published

published
TADUpdateSQL Class Legend Published Properties Send Feedback

The published members of the TADUpdateSQL class are listed here.

Class

TADUpdateSQL Class

Published Properties
Name | Description
Connection | Gets / sets the connection object.
ConnectionName | Gets / sets the connection name.
DeleteSQL | Specifies the SQL statement to use when applying a deletion of a record.
FetchRowSQL | Specifies the SQL statement to use to refetch single record.
InsertSQL | Specifies the SQL statement to use when applying an insertion of a record.
LockSQL | Specifies the SQL statement to use when locking a record.
ModifySQL | Specifies the SQL statement to use when applying an update of a record.
UnlockSQL | Specifies the SQL statement to use when unlocking a record.
Links
TADUpdateSQL Class, Legend, Published Properties


TADUpdateSQL.Connection Property

TADUpdateSQL.Connection Property
TADUpdateSQL Class uADCompClient Unit published See Also Send Feedback

Gets / sets the connection object.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, published, See Also
Description

The Connection property value points to the connection object, which will be assigned to all internal update commands. If the connection is the same as used by DataSet, then leave Connection property empty.

Alternatively may be specified the ConnectionName property value.

Syntax
property Connection: TADCustomConnection;
See Also

ConnectionName, Commands

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADUpdateSQL.ConnectionName Property

TADUpdateSQL.ConnectionName Property
TADUpdateSQL Class uADCompClient Unit published See Also Send Feedback

Gets / sets the connection name.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, published, See Also
Description

The ConnectionName property value is the name of a connection, which will be used by all internal update commands. If the connection name is the same as used by DataSet, then leave ConnectionName property empty.

Alternatively may be specified the Connection property value.

Syntax
property ConnectionName: String;
See Also

Connection, Commands

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADUpdateSQL.DeleteSQL Property

TADUpdateSQL.DeleteSQL Property
TADUpdateSQL Class uADCompClient Unit Example published See Also Send Feedback

Specifies the SQL statement to use when applying a deletion of a record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, Example, published, See Also
Description

Set DeleteSQL to the SQL statement to use when applying an record deletion to a database. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the value of a field as it exists prior to applying deletion, use the :OLD_<field name> parameter name.

To create a DELETE statement at design time, use the UpdateSQL editor to create statements. For that double click on TADUpdateSQL component. Also, you can use stored procedure call or other SQL command to apply deletion.

Syntax
property DeleteSQL: TStrings;
See Also

Commands, InsertSQL, ModifySQL, LockSQL, UnlockSQL, FetchRowSQL

Example
ADUpdateSQL1.DeleteSQL := 'DELETE FROM ADDEMO."Shippers" WHERE SHIPPERID = :OLD_SHIPPERID';


TADUpdateSQL.FetchRowSQL Property

TADUpdateSQL.FetchRowSQL Property
TADUpdateSQL Class uADCompClient Unit Example published See Also Send Feedback

Specifies the SQL statement to use to refetch single record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, Example, published, See Also
Description

Set FetchRowSQL to the SQL statement to use when refetching single record from a database. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the value of a field as it exists prior refetching, use the :OLD_<field name> parameter name.

If statement will fetch record field values using parameters, then to put parameter values into record, use the :NEW_<field name> or :<field name> parameter name and set parameter types to ptOuput. If statement will produce recordset, then it fields must have the same names as in dataset.

To create a SELECT statement at design time, use the UpdateSQL editor to create statements. For that double click on TADUpdateSQL component. Also, you can use stored procedure call or other SQL command to apply record fetching.

Syntax
property FetchRowSQL: TStrings;
See Also

Commands, InsertSQL, ModifySQL, LockSQL, UnlockSQL, DeleteSQL

Example
ADUpdateSQL1.FetchRowSQL := 'SELECT SHIPPERID, COMPANYNAME, PHONE FROM ADDEMO."Shippers" ' +
  'WHERE SHIPPERID = :OLD_SHIPPERID';


TADUpdateSQL.InsertSQL Property

TADUpdateSQL.InsertSQL Property
TADUpdateSQL Class uADCompClient Unit Example 1 Example 2 published See Also Send Feedback

Specifies the SQL statement to use when applying an insertion of a record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, Example 1, Example 2, published, See Also
Description

Set InsertSQL to the SQL statement to use when applying a record insertion to a database. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the value of a field as it exists prior to applying insertion, use the :NEW_<field name> or :<field name> parameter name.

If statement will fetch new record field values (as identity or modified in trigger) using parameters, then to put parameter values into record, use the :NEW_<field name> or :<field name> parameter name and set parameter types to ptOuput. If statement will produce recordset, then it fields must have the same names as in dataset.

To create an INSERT statement at design time, use the UpdateSQL editor to create statements. For that double click on TADUpdateSQL component. Also, you can use stored procedure call or other SQL command to apply insertion.

Syntax
property InsertSQL: TStrings;
See Also

Commands, ModifySQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL

Example 1
// MSSQL sample
ADUpdateSQL1.InsertSQL := 'INSERT INTO [Shippers] (COMPANYNAME, PHONE) ' +
  'VALUES (:NEW_COMPANYNAME, :NEW_PHONE); SELECT SCOPE_IDENTITY() AS SHIPPERID';
Example 2
// Oracle sample
ADUpdateSQL1.InsertSQL := 'INSERT INTO ADDEMO."Shippers" (COMPANYNAME, PHONE) ' +
  'VALUES (:NEW_COMPANYNAME, :NEW_PHONE) RETURNING SHIPPERID INTO :NEW_SHIPPERID';
ADUpdateSQL1.Commands[arInsert].ParamByName('NEW_SHIPPERID').ParamType := ptOutput;


TADUpdateSQL.LockSQL Property

TADUpdateSQL.LockSQL Property
TADUpdateSQL Class uADCompClient Unit published See Also Send Feedback

Specifies the SQL statement to use when locking a record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, published, See Also
Description

Set LockSQL to the SQL statement to use when locking single record in a database. Library uses the statement if UpdateOptions.LockMode is pessimistic or optimistic. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the value of a field as it exists prior locking, use the :OLD_<field name> parameter name.

To create a SELECT [FOR UPDATE] statement at design time, use the UpdateSQL editor to create statements. For that double click on TADUpdateSQL component. Also, you can use stored procedure call or other SQL command to lock record.

Syntax
property LockSQL: TStrings;
See Also

Commands, ModifySQL, DeleteSQL, InsertSQL, UnlockSQL, FetchRowSQL


TADUpdateSQL.ModifySQL Property

TADUpdateSQL.ModifySQL Property
TADUpdateSQL Class uADCompClient Unit Example published See Also Send Feedback

Specifies the SQL statement to use when applying an update of a record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, Example, published, See Also
Description

Set UpdateSQL to the SQL statement to use when applying a record modification to a database. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the original value of a field, use the :OLD_<field name> parameter name. To retrieve the value of a field as it exists prior to applying modification, use the :NEW_<field name> or :<field name> parameter name.

If statement will fetch new record field values (as identity or modified in trigger) using parameters, then to put parameter values into record, use the :NEW_<field name> or :<field name> parameter name and set parameter types to ptOuput. If statement will produce recordset, then it fields must have the same names as in dataset.

To create an UPDATE statement at design time, use the UpdateSQL editor to create statements. For that double click on TADUpdateSQL component. Also, you can use stored procedure call or other SQL command to apply modification.

Syntax
property ModifySQL: TStrings;
See Also

Commands, InsertSQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL

Example
ADUpdateSQL1.InsertSQL := 'UPDATE ADDEMO."Shippers" SET SHIPPERID = :NEW_SHIPPERID, ' +
  'COMPANYNAME = :NEW_COMPANYNAME, PHONE = :NEW_PHONE WHERE SHIPPERID = :OLD_SHIPPERID';


TADUpdateSQL.UnlockSQL Property

TADUpdateSQL.UnlockSQL Property
TADUpdateSQL Class uADCompClient Unit published See Also Send Feedback

Specifies the SQL statement to use when unlocking a record.

Group

published

Links
TADUpdateSQL Class, uADCompClient Unit, published, See Also
Description

Set UnlockSQL to the SQL statement to use when unlocking single record in a database. Library uses the statement if UpdateOptions.LockMode is pessimistic or optimistic. Statements can use parameters and macros. To get access to paramaters or macros collection use Commands property.

To retrieve the value of a field as it exists prior unlocking, use the :OLD_<field name> parameter name.

Most DBMS's unlock record after finishing transaction. So, AnyDAC does not generate any SQL statement for record unlocking.

Syntax
property UnlockSQL: TStrings;
See Also

Commands, ModifySQL, DeleteSQL, InsertSQL, LockSQL, FetchRowSQL


Functions

Functions
Functions uADCompClient Unit Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ADFindDefaultConnection |
ADManager | Function returns reference to global TADCustomManager object.
ADSetConnectionClass | Sets the TADCustomConnection descendant class.
ADSetManagerClass | Set the TADCustomManager descendant class.
Unit

uADCompClient Unit

Links
Functions, uADCompClient Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADCompClient.ADFindDefaultConnection Function

uADCompClient.ADFindDefaultConnection Function
Functions Send Feedback
Group

Functions

File

uADCompClient

Links
Functions
Syntax
function ADFindDefaultConnection(AComp: TComponent): TADCustomConnection;


uADCompClient.ADManager Function

uADCompClient.ADManager Function
Example Functions See Also Send Feedback

Function returns reference to global TADCustomManager object.

Group

Functions

File

uADCompClient

Links
Example, Functions, See Also
Returns

TADCustomManager instance.

Description

The ADManager function returns reference to singleton object, representing default instance of TADCustomManager.

Syntax
function ADManager: TADCustomManager;
See Also

TADCustomManager

Example
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=127.0.0.1');
  oList.Add('Database=addemo');
  ADManager.AddConnectionDef('myconn', 'MySQL', oList);


uADCompClient.ADSetConnectionClass Function

uADCompClient.ADSetConnectionClass Function
Example Functions See Also Send Feedback

Sets the TADCustomConnection descendant class.

Group

Functions

File

uADCompClient

Links
Example, Functions, See Also
Parameters
Parameters | Description
AClass: TADCustomConnectionClass | The class reference.
Description

Sets the TADCustomConnection descendant class, that AnyDAC will use to create internally managed connection objects.

Syntax
procedure ADSetConnectionClass(AClass: TADCustomConnectionClass);
See Also

TADCustomConnection, TADCustomConnection.ConnectionName

Example
ADSetConnectionClass(TMyConnection);


uADCompClient.ADSetManagerClass Function

uADCompClient.ADSetManagerClass Function
Example Functions See Also Send Feedback

Set the TADCustomManager descendant class.

Group

Functions

File

uADCompClient

Links
Example, Functions, See Also
Parameters
Parameters | Description
AClass: TADCustomManagerClass | The class reference.
Description

Sets the TADCustomManager descendant class, that AnyDAC will use to create internally managed manager object.

Syntax
procedure ADSetManagerClass(AClass: TADCustomManagerClass);
See Also

TADCustomManager, ADManager

Example
ADSetManagerClass(TMyManager);


Records, Enums

Records, Enums
Enumerations uADCompClient Unit Legend Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADBindedBy |
TADChangingKind |
Unit

uADCompClient Unit

Links
Enumerations, uADCompClient Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADCompClient.TADBindedBy Enumeration

uADCompClient.TADBindedBy Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompClient

Links
Records, Enums
Syntax
TADBindedBy = (
  bbNone,
  bbName,
  bbObject
);


uADCompClient.TADChangingKind Enumeration

uADCompClient.TADChangingKind Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompClient

Links
Records, Enums
Syntax
TADChangingKind = (
  ckMacros,
  ckLockParse,
  ckPrepare
);


Types

Types
uADCompClient Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADCompClient Unit

Types
Name | Description
TADChangingKinds |
TADConnectionLoginEvent |
TADConnectionRecoverEvent |
TADCustomConnectionClass |
TADCustomManagerClass |
TADDescribeColumnEvent |
TADDescribeTableEvent |
TADErrorEvent |
TADExecuteErrorEvent |
TADOperationFinishedEvent |
TADReconcileRowEvent |
TADUpdateRowEvent |
Links
uADCompClient Unit, Types


uADCompClient.TADChangingKinds Type

uADCompClient.TADChangingKinds Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADChangingKinds = set of TADChangingKind;


uADCompClient.TADConnectionLoginEvent Type

uADCompClient.TADConnectionLoginEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADConnectionLoginEvent = procedure (AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef) of object;


uADCompClient.TADConnectionRecoverEvent Type

uADCompClient.TADConnectionRecoverEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADConnectionRecoverEvent = procedure (ASender: TObject; const AInitiator: IADStanObject; AException: Exception; var AAction: TADPhysConnectionRecoverAction) of object;


uADCompClient.TADCustomConnectionClass Type

uADCompClient.TADCustomConnectionClass Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADCustomConnectionClass = class of TADCustomConnection;


uADCompClient.TADCustomManagerClass Type

uADCompClient.TADCustomManagerClass Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADCustomManagerClass = class of TADCustomManager;


uADCompClient.TADDescribeColumnEvent Type

uADCompClient.TADDescribeColumnEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADDescribeColumnEvent = procedure (ASender: TObject; AColumn: TADDatSColumn; var AAttrs: TADDataAttributes; var AOptions: TADDataOptions; var AObjName: String) of object;


uADCompClient.TADDescribeTableEvent Type

uADCompClient.TADDescribeTableEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADDescribeTableEvent = procedure (ASender: TObject; ATable: TADDatSTable; var AObjName: String) of object;


uADCompClient.TADErrorEvent Type

uADCompClient.TADErrorEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADErrorEvent = procedure (ASender: TObject; const AInitiator: IADStanObject; var AException: Exception) of object;


uADCompClient.TADExecuteErrorEvent Type

uADCompClient.TADExecuteErrorEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADExecuteErrorEvent = procedure (ASender: TObject; ATimes, AOffset: LongInt; AException: EADDBEngineException; var AAction: TADErrorAction) of object;


uADCompClient.TADOperationFinishedEvent Type

uADCompClient.TADOperationFinishedEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADOperationFinishedEvent = procedure (ASander: TObject; AState: TADStanAsyncState; AException: Exception) of object;


uADCompClient.TADReconcileRowEvent Type

uADCompClient.TADReconcileRowEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADReconcileRowEvent = procedure (ASender: TObject; ARow: TADDatSRow; var Action: TADDAptReconcileAction) of object;


uADCompClient.TADUpdateRowEvent Type

uADCompClient.TADUpdateRowEvent Type
Types Send Feedback
Group

Types

File

uADCompClient

Links
Types
Syntax
TADUpdateRowEvent = procedure (ASender: TObject; ARow: TADDatSRow; ARequest: TADPhysUpdateRequest; AUpdRowOptions: TADPhysUpdateRowOptions; var AAction: TADErrorAction) of object;


uADCompDataMove Unit

uADCompDataMove Unit
Classes Legend Topics Types Records, Enums Send Feedback
Classes
Name | Description
TADDataMove |
TADMappingItem |
TADMappings |
TADTextDataDef |
TADTextField |
TADTextFields |
TADTextFormatSettings |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TADDataMoveErrorEvent |
TADDataMoveFindDestRecordEvent |
TADDataMoveOptions |
TADDataMoveProgressEvent |
TADTextFormatSettingsValueSet |
Records, Enums
Name | Description
TADDataMoveMode |
TADDataMoveOption |
TADDataMovePhase |
TADDataSourceKind |
TADLogFileAction |
TADTextDataType |
TADTextEndOfLine |
TADTextFormatSettingsValue |
TADTextRecordFormat |
TFormatSettings |
Links
Classes, Legend, Topics, Types, Records, Enums


Classes

Classes
Classes uADCompDataMove Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADDataMove |
TADMappingItem |
TADMappings |
TADTextDataDef |
TADTextField |
TADTextFields |
TADTextFormatSettings |
Unit

uADCompDataMove Unit

Links
Classes, uADCompDataMove Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataMove Class

TADDataMove Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, published, Classes
Syntax
TADDataMove = class(TADComponent);


public

public
TADDataMove Class Legend Public Methods Public Properties Send Feedback

The public members of the TADDataMove class are listed here.

Class

TADDataMove Class

Public Methods
Name | Description
AbortJob |
Create |
Destroy |
Execute |
Public Properties
Name | Description
DeleteCount |
ExceptionCount |
InsertCount |
ReadCount |
UpdateCount |
WriteCount |
Links
TADDataMove Class, Legend, Public Methods, Public Properties


TADDataMove.DeleteCount Property

TADDataMove.DeleteCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property DeleteCount: LongInt;


TADDataMove.ExceptionCount Property

TADDataMove.ExceptionCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property ExceptionCount: LongInt;


TADDataMove.InsertCount Property

TADDataMove.InsertCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property InsertCount: LongInt;


TADDataMove.ReadCount Property

TADDataMove.ReadCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property ReadCount: LongInt;


TADDataMove.UpdateCount Property

TADDataMove.UpdateCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property UpdateCount: LongInt;


TADDataMove.WriteCount Property

TADDataMove.WriteCount Property
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
property WriteCount: LongInt;


TADDataMove.AbortJob Method

TADDataMove.AbortJob Method
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
procedure AbortJob;


TADDataMove.Create Constructor

TADDataMove.Create Constructor
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


TADDataMove.Destroy Destructor

TADDataMove.Destroy Destructor
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
destructor Destroy; override;


TADDataMove.Execute Method

TADDataMove.Execute Method
TADDataMove Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADDataMove Class, uADCompDataMove Unit, public
Syntax
function Execute: LongInt;


published

published
TADDataMove Class Legend Published Events Published Properties Send Feedback

The published members of the TADDataMove class are listed here.

Class

TADDataMove Class

Published Events
Name | Description
OnError |
OnFindDestRecord |
OnProgress |
Published Properties
Name | Description
CommitCount |
Destination |
DestinationKind |
LogFileAction |
LogFileName |
Mappings |
Mode |
Options |
Source |
SourceKind |
StatisticsInterval |
TextDataDef |
TextFileName |
Links
TADDataMove Class, Legend, Published Events, Published Properties


TADDataMove.CommitCount Property

TADDataMove.CommitCount Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property CommitCount: LongInt;


TADDataMove.Destination Property

TADDataMove.Destination Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property Destination: TADAdaptedDataSet;


TADDataMove.DestinationKind Property

TADDataMove.DestinationKind Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property DestinationKind: TADDataSourceKind;


TADDataMove.LogFileAction Property

TADDataMove.LogFileAction Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property LogFileAction: TADLogFileAction;


TADDataMove.LogFileName Property

TADDataMove.LogFileName Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property LogFileName: String;


TADDataMove.Mappings Property

TADDataMove.Mappings Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property Mappings: TADMappings;


TADDataMove.Mode Property

TADDataMove.Mode Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property Mode: TADDataMoveMode;


TADDataMove.OnError Event

TADDataMove.OnError Event
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property OnError: TADDataMoveErrorEvent;


TADDataMove.OnFindDestRecord Event

TADDataMove.OnFindDestRecord Event
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property OnFindDestRecord: TADDataMoveFindDestRecordEvent;


TADDataMove.OnProgress Event

TADDataMove.OnProgress Event
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property OnProgress: TADDataMoveProgressEvent;


TADDataMove.Options Property

TADDataMove.Options Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property Options: TADDataMoveOptions;


TADDataMove.Source Property

TADDataMove.Source Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property Source: TDataSet;


TADDataMove.SourceKind Property

TADDataMove.SourceKind Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property SourceKind: TADDataSourceKind;


TADDataMove.StatisticsInterval Property

TADDataMove.StatisticsInterval Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property StatisticsInterval: LongInt;


TADDataMove.TextDataDef Property

TADDataMove.TextDataDef Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property TextDataDef: TADTextDataDef;


TADDataMove.TextFileName Property

TADDataMove.TextFileName Property
TADDataMove Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADDataMove Class, uADCompDataMove Unit, published
Syntax
property TextFileName: String;


TADMappingItem Class

TADMappingItem Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, published, Classes
Syntax
TADMappingItem = class(TCollectionItem);


public

public
TADMappingItem Class Legend Public Methods Public Properties Send Feedback

The public members of the TADMappingItem class are listed here.

Class

TADMappingItem Class

Public Methods
Name | Description
Assign |
Destroy |
Move |
Prepare |
Unprepare |
Public Properties
Name | Description
AsText |
DestField |
DestTextField |
DestValue |
InKey |
ItemValue |
SourceEvaluator |
SourceField |
SourceTextField |
SourceValue |
Links
TADMappingItem Class, Legend, Public Methods, Public Properties


TADMappingItem.AsText Property

TADMappingItem.AsText Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property AsText: String;


TADMappingItem.DestField Property

TADMappingItem.DestField Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property DestField: TField;


TADMappingItem.DestTextField Property

TADMappingItem.DestTextField Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property DestTextField: TADTextField;


TADMappingItem.DestValue Property

TADMappingItem.DestValue Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property DestValue: Variant;


TADMappingItem.InKey Property

TADMappingItem.InKey Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property InKey: Boolean;


TADMappingItem.ItemValue Property

TADMappingItem.ItemValue Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property ItemValue: Variant;


TADMappingItem.SourceEvaluator Property

TADMappingItem.SourceEvaluator Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property SourceEvaluator: IADStanExpressionEvaluator;


TADMappingItem.SourceField Property

TADMappingItem.SourceField Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property SourceField: TField;


TADMappingItem.SourceTextField Property

TADMappingItem.SourceTextField Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property SourceTextField: TADTextField;


TADMappingItem.SourceValue Property

TADMappingItem.SourceValue Property
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
property SourceValue: Variant;


TADMappingItem.Assign Method

TADMappingItem.Assign Method
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADMappingItem.Destroy Destructor

TADMappingItem.Destroy Destructor
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
destructor Destroy; override;


TADMappingItem.Move Method

TADMappingItem.Move Method
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
procedure Move;


TADMappingItem.Prepare Method

TADMappingItem.Prepare Method
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
procedure Prepare;


TADMappingItem.Unprepare Method

TADMappingItem.Unprepare Method
TADMappingItem Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappingItem Class, uADCompDataMove Unit, public
Syntax
procedure Unprepare;


published

published
TADMappingItem Class Legend Published Properties Send Feedback

The published members of the TADMappingItem class are listed here.

Class

TADMappingItem Class

Published Properties
Name | Description
DestinationFieldName |
SourceExpression |
SourceFieldName |
Links
TADMappingItem Class, Legend, Published Properties


TADMappingItem.DestinationFieldName Property

TADMappingItem.DestinationFieldName Property
TADMappingItem Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADMappingItem Class, uADCompDataMove Unit, published
Syntax
property DestinationFieldName: String;


TADMappingItem.SourceExpression Property

TADMappingItem.SourceExpression Property
TADMappingItem Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADMappingItem Class, uADCompDataMove Unit, published
Syntax
property SourceExpression: String;


TADMappingItem.SourceFieldName Property

TADMappingItem.SourceFieldName Property
TADMappingItem Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADMappingItem Class, uADCompDataMove Unit, published
Syntax
property SourceFieldName: String;


TADMappings Class

TADMappings Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, Classes
Syntax
TADMappings = class(TCollection);


public

public
TADMappings Class Legend Public Methods Public Properties Send Feedback

The public members of the TADMappings class are listed here.

Class

TADMappings Class

Public Methods
Name | Description
Add |
Add |
AddAll |
Assign |
Create |
IndexOfName |
Move |
Prepare |
Unprepare |
Public Properties
Name | Description
DataMove |
Items |
Links
TADMappings Class, Legend, Public Methods, Public Properties


TADMappings.DataMove Property

TADMappings.DataMove Property
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
property DataMove: TADDataMove;


TADMappings.Items Property

TADMappings.Items Property
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
property Items [Index: Integer]: TADMappingItem;


TADMappings.Add Method ()

TADMappings.Add Method ()
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
function Add: TADMappingItem; overload;


TADMappings.Add Method (String)

TADMappings.Add Method (String)
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure Add(const AMapItem: String); overload;


TADMappings.AddAll Method

TADMappings.AddAll Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure AddAll;


TADMappings.Assign Method

TADMappings.Assign Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADMappings.Create Constructor

TADMappings.Create Constructor
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
constructor Create(ADataMove: TADDataMove);


TADMappings.IndexOfName Method

TADMappings.IndexOfName Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
function IndexOfName(const AName: String): Integer;


TADMappings.Move Method

TADMappings.Move Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure Move(AKeysOnly: Boolean);


TADMappings.Prepare Method

TADMappings.Prepare Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure Prepare;


TADMappings.Unprepare Method

TADMappings.Unprepare Method
TADMappings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADMappings Class, uADCompDataMove Unit, public
Syntax
procedure Unprepare;


TADTextDataDef Class

TADTextDataDef Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, published, Classes
Syntax
TADTextDataDef = class(TPersistent);


public

public
TADTextDataDef Class Legend Public Methods Public Properties Send Feedback

The public members of the TADTextDataDef class are listed here.

Class

TADTextDataDef Class

Public Methods
Name | Description
Assign |
Create |
Destroy |
Public Properties
Name | Description
DataMove |
Links
TADTextDataDef Class, Legend, Public Methods, Public Properties


TADTextDataDef.DataMove Property

TADTextDataDef.DataMove Property
TADTextDataDef Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextDataDef Class, uADCompDataMove Unit, public
Syntax
property DataMove: TADDataMove;


TADTextDataDef.Assign Method

TADTextDataDef.Assign Method
TADTextDataDef Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextDataDef Class, uADCompDataMove Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADTextDataDef.Create Constructor

TADTextDataDef.Create Constructor
TADTextDataDef Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextDataDef Class, uADCompDataMove Unit, public
Syntax
constructor Create(ADataMove: TADDataMove);


TADTextDataDef.Destroy Destructor

TADTextDataDef.Destroy Destructor
TADTextDataDef Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextDataDef Class, uADCompDataMove Unit, public
Syntax
destructor Destroy; override;


published

published
TADTextDataDef Class Legend Published Properties Send Feedback

The published members of the TADTextDataDef class are listed here.

Class

TADTextDataDef Class

Published Properties
Name | Description
Delimiter |
EndOfLine |
Fields |
FormatSettings |
RecordFormat |
Separator |
WithFieldNames |
Links
TADTextDataDef Class, Legend, Published Properties


TADTextDataDef.Delimiter Property

TADTextDataDef.Delimiter Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property Delimiter: Char;


TADTextDataDef.EndOfLine Property

TADTextDataDef.EndOfLine Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property EndOfLine: TADTextEndOfLine;


TADTextDataDef.Fields Property

TADTextDataDef.Fields Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property Fields: TADTextFields;


TADTextDataDef.FormatSettings Property

TADTextDataDef.FormatSettings Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property FormatSettings: TADTextFormatSettings;


TADTextDataDef.RecordFormat Property

TADTextDataDef.RecordFormat Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property RecordFormat: TADTextRecordFormat;


TADTextDataDef.Separator Property

TADTextDataDef.Separator Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property Separator: Char;


TADTextDataDef.WithFieldNames Property

TADTextDataDef.WithFieldNames Property
TADTextDataDef Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextDataDef Class, uADCompDataMove Unit, published
Syntax
property WithFieldNames: Boolean;


TADTextField Class

TADTextField Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, published, Classes
Syntax
TADTextField = class(TCollectionItem);


public

public
TADTextField Class Legend Public Methods Send Feedback

The public members of the TADTextField class are listed here.

Class

TADTextField Class

Public Methods
Name | Description
Assign |
DefineAsField |
Links
TADTextField Class, Legend, Public Methods


TADTextField.Assign Method

TADTextField.Assign Method
TADTextField Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextField Class, uADCompDataMove Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADTextField.DefineAsField Method

TADTextField.DefineAsField Method
TADTextField Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextField Class, uADCompDataMove Unit, public
Syntax
procedure DefineAsField(AFld: TField);


published

published
TADTextField Class Legend Published Properties Send Feedback

The published members of the TADTextField class are listed here.

Class

TADTextField Class

Published Properties
Name | Description
DataType |
FieldName |
FieldSize |
Precision |
Links
TADTextField Class, Legend, Published Properties


TADTextField.DataType Property

TADTextField.DataType Property
TADTextField Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextField Class, uADCompDataMove Unit, published
Syntax
property DataType: TADTextDataType;


TADTextField.FieldName Property

TADTextField.FieldName Property
TADTextField Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextField Class, uADCompDataMove Unit, published
Syntax
property FieldName: String;


TADTextField.FieldSize Property

TADTextField.FieldSize Property
TADTextField Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextField Class, uADCompDataMove Unit, published
Syntax
property FieldSize: Integer;


TADTextField.Precision Property

TADTextField.Precision Property
TADTextField Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextField Class, uADCompDataMove Unit, published
Syntax
property Precision: Integer;


TADTextFields Class

TADTextFields Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, Classes
Syntax
TADTextFields = class(TCollection);


public

public
TADTextFields Class Legend Public Methods Public Properties Send Feedback

The public members of the TADTextFields class are listed here.

Class

TADTextFields Class

Public Methods
Name | Description
Add |
AddAll |
Create |
FieldByName |
FindField |
Public Properties
Name | Description
Items |
Links
TADTextFields Class, Legend, Public Methods, Public Properties


TADTextFields.Items Property

TADTextFields.Items Property
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
property Items [Index: Integer]: TADTextField;


TADTextFields.Add Method

TADTextFields.Add Method
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
function Add: TADTextField;


TADTextFields.AddAll Method

TADTextFields.AddAll Method
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
procedure AddAll;


TADTextFields.Create Constructor

TADTextFields.Create Constructor
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
constructor Create(ADef: TADTextDataDef);


TADTextFields.FieldByName Method

TADTextFields.FieldByName Method
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
function FieldByName(const AName: String): TADTextField;


TADTextFields.FindField Method

TADTextFields.FindField Method
TADTextFields Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFields Class, uADCompDataMove Unit, public
Syntax
function FindField(const AName: String): TADTextField;


TADTextFormatSettings Class

TADTextFormatSettings Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataMove

Links
public, published, Classes
Syntax
TADTextFormatSettings = class(TPersistent);


public

public
TADTextFormatSettings Class Legend Public Methods Public Properties Send Feedback

The public members of the TADTextFormatSettings class are listed here.

Class

TADTextFormatSettings Class

Public Methods
Name | Description
Assign |
Create |
Destroy |
Public Properties
Name | Description
DataDef |
Links
TADTextFormatSettings Class, Legend, Public Methods, Public Properties


TADTextFormatSettings.DataDef Property

TADTextFormatSettings.DataDef Property
TADTextFormatSettings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFormatSettings Class, uADCompDataMove Unit, public
Syntax
property DataDef: TADTextDataDef;


TADTextFormatSettings.Assign Method

TADTextFormatSettings.Assign Method
TADTextFormatSettings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFormatSettings Class, uADCompDataMove Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADTextFormatSettings.Create Constructor

TADTextFormatSettings.Create Constructor
TADTextFormatSettings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFormatSettings Class, uADCompDataMove Unit, public
Syntax
constructor Create(ADef: TADTextDataDef);


TADTextFormatSettings.Destroy Destructor

TADTextFormatSettings.Destroy Destructor
TADTextFormatSettings Class uADCompDataMove Unit public Send Feedback
Group

public

Links
TADTextFormatSettings Class, uADCompDataMove Unit, public
Syntax
destructor Destroy; override;


published

published
TADTextFormatSettings Class Legend Published Properties Send Feedback

The published members of the TADTextFormatSettings class are listed here.

Class

TADTextFormatSettings Class

Published Properties
Name | Description
CurrencyDecimals |
CurrencyFormat |
CurrencyString |
DateSeparator |
DecimalSeparator |
NegCurrFormat |
ShortDateFormat |
ShortTimeFormat |
ThousandSeparator |
TimeAMString |
TimePMString |
TimeSeparator |
TwoDigitYearCenturyWindow |
Links
TADTextFormatSettings Class, Legend, Published Properties


TADTextFormatSettings.CurrencyDecimals Property

TADTextFormatSettings.CurrencyDecimals Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property CurrencyDecimals: Byte;


TADTextFormatSettings.CurrencyFormat Property

TADTextFormatSettings.CurrencyFormat Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property CurrencyFormat: Byte;


TADTextFormatSettings.CurrencyString Property

TADTextFormatSettings.CurrencyString Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property CurrencyString: string;


TADTextFormatSettings.DateSeparator Property

TADTextFormatSettings.DateSeparator Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property DateSeparator: Char;


TADTextFormatSettings.DecimalSeparator Property

TADTextFormatSettings.DecimalSeparator Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property DecimalSeparator: Char;


TADTextFormatSettings.NegCurrFormat Property

TADTextFormatSettings.NegCurrFormat Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property NegCurrFormat: Byte;


TADTextFormatSettings.ShortDateFormat Property

TADTextFormatSettings.ShortDateFormat Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property ShortDateFormat: string;


TADTextFormatSettings.ShortTimeFormat Property

TADTextFormatSettings.ShortTimeFormat Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property ShortTimeFormat: string;


TADTextFormatSettings.ThousandSeparator Property

TADTextFormatSettings.ThousandSeparator Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property ThousandSeparator: Char;


TADTextFormatSettings.TimeAMString Property

TADTextFormatSettings.TimeAMString Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property TimeAMString: string;


TADTextFormatSettings.TimePMString Property

TADTextFormatSettings.TimePMString Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property TimePMString: string;


TADTextFormatSettings.TimeSeparator Property

TADTextFormatSettings.TimeSeparator Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property TimeSeparator: Char;


TADTextFormatSettings.TwoDigitYearCenturyWindow Property

TADTextFormatSettings.TwoDigitYearCenturyWindow Property
TADTextFormatSettings Class uADCompDataMove Unit published Send Feedback
Group

published

Links
TADTextFormatSettings Class, uADCompDataMove Unit, published
Syntax
property TwoDigitYearCenturyWindow: Word;


Records, Enums

Records, Enums
Enumerations uADCompDataMove Unit Legend Records Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADDataMoveMode |
TADDataMoveOption |
TADDataMovePhase |
TADDataSourceKind |
TADLogFileAction |
TADTextDataType |
TADTextEndOfLine |
TADTextFormatSettingsValue |
TADTextRecordFormat |
Unit

uADCompDataMove Unit

Records
Name | Description
TFormatSettings |
Links
Enumerations, uADCompDataMove Unit, Legend, Records


uADCompDataMove.TADDataMoveMode Enumeration

uADCompDataMove.TADDataMoveMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADDataMoveMode = (
  dmAlwaysInsert,
  dmAppend,
  dmUpdate,
  dmAppendUpdate,
  dmDelete
);


uADCompDataMove.TADDataMoveOption Enumeration

uADCompDataMove.TADDataMoveOption Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADDataMoveOption = (
  poOptimiseDest,
  poOptimiseSrc,
  poClearDest,
  poClearDestNoUndo,
  poAbortOnExc,
  poSrcFromCurRec
);


uADCompDataMove.TADDataMovePhase Enumeration

uADCompDataMove.TADDataMovePhase Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADDataMovePhase = (
  psPreparing,
  psStarting,
  psProgress,
  psFinishing,
  psUnpreparing
);


uADCompDataMove.TADDataSourceKind Enumeration

uADCompDataMove.TADDataSourceKind Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADDataSourceKind = (
  skDataSet,
  skText
);


uADCompDataMove.TADLogFileAction Enumeration

uADCompDataMove.TADLogFileAction Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADLogFileAction = (
  laNone,
  laCreate,
  laAppend
);


uADCompDataMove.TADTextDataType Enumeration

uADCompDataMove.TADTextDataType Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADTextDataType = (
  atOther,
  atString,
  atFloat,
  atNumber,
  atBool,
  atLongInt,
  atDate,
  atTime,
  atDateTime,
  atBlob,
  atMemo
);


uADCompDataMove.TADTextEndOfLine Enumeration

uADCompDataMove.TADTextEndOfLine Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADTextEndOfLine = (
  elWindows,
  elUnix,
  elMac
);


uADCompDataMove.TADTextFormatSettingsValue Enumeration

uADCompDataMove.TADTextFormatSettingsValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADTextFormatSettingsValue = (
  fsCurrencyFormat,
  fsNegCurrFormat,
  fsThousandSeparator,
  fsDecimalSeparator,
  fsCurrencyDecimals,
  fsDateSeparator,
  fsTimeSeparator,
  fsCurrencyString,
  fsShortDateFormat,
  fsTimeAMString,
  fsTimePMString,
  fsShortTimeFormat,
  fsTwoDigitYearCenturyWindow
);


uADCompDataMove.TADTextRecordFormat Enumeration

uADCompDataMove.TADTextRecordFormat Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TADTextRecordFormat = (
  rfFixedLength,
  rfCommaDoubleQuote,
  rfFieldPerLine,
  rfTabDoubleQuote,
  rfCustom
);


uADCompDataMove.TFormatSettings Record

uADCompDataMove.TFormatSettings Record
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataMove

Links
Records, Enums
Syntax
TFormatSettings = record
  CurrencyFormat: Byte;
  NegCurrFormat: Byte;
  ThousandSeparator: Char;
  DecimalSeparator: Char;
  CurrencyDecimals: Byte;
  DateSeparator: Char;
  TimeSeparator: Char;
  ListSeparator: Char;
  CurrencyString: string;
  ShortDateFormat: string;
  LongDateFormat: string;
  TimeAMString: string;
  TimePMString: string;
  ShortTimeFormat: string;
  LongTimeFormat: string;
  ShortMonthNames: array[1..12] of string;
  LongMonthNames: array[1..12] of string;
  ShortDayNames: array[1..7] of string;
  LongDayNames: array[1..7] of string;
  TwoDigitYearCenturyWindow: Word;
end;


Types

Types
uADCompDataMove Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADCompDataMove Unit

Types
Name | Description
TADDataMoveErrorEvent |
TADDataMoveFindDestRecordEvent |
TADDataMoveOptions |
TADDataMoveProgressEvent |
TADTextFormatSettingsValueSet |
Links
uADCompDataMove Unit, Types


uADCompDataMove.TADDataMoveErrorEvent Type

uADCompDataMove.TADDataMoveErrorEvent Type
Types Send Feedback
Group

Types

File

uADCompDataMove

Links
Types
Syntax
TADDataMoveErrorEvent = procedure (ASender: TObject; var AAction: TADErrorAction) of object;


uADCompDataMove.TADDataMoveFindDestRecordEvent Type

uADCompDataMove.TADDataMoveFindDestRecordEvent Type
Types Send Feedback
Group

Types

File

uADCompDataMove

Links
Types
Syntax
TADDataMoveFindDestRecordEvent = procedure (ASender: TObject; var AFound: Boolean) of object;


uADCompDataMove.TADDataMoveOptions Type

uADCompDataMove.TADDataMoveOptions Type
Types Send Feedback
Group

Types

File

uADCompDataMove

Links
Types
Syntax
TADDataMoveOptions = set of TADDataMoveOption;


uADCompDataMove.TADDataMoveProgressEvent Type

uADCompDataMove.TADDataMoveProgressEvent Type
Types Send Feedback
Group

Types

File

uADCompDataMove

Links
Types
Syntax
TADDataMoveProgressEvent = procedure (ASender: TObject; APhase: TADDataMovePhase) of object;


uADCompDataMove.TADTextFormatSettingsValueSet Type

uADCompDataMove.TADTextFormatSettingsValueSet Type
Types Send Feedback
Group

Types

File

uADCompDataMove

Links
Types
Syntax
TADTextFormatSettingsValueSet = set of TADTextFormatSettingsValue;


uADCompDataSet Unit

uADCompDataSet Unit
Classes Interfaces Legend Topics Types Records, Enums Send Feedback
Classes
Name | Description
TADAggregate |
TADAggregates |
TADAutoIncField |
TADBlobStream |
TADColMapItem |
TADDataSet | ..
TADIndex |
TADIndexes |
TADMasterDataLink |
TADWideMemoField |
Interfaces
Name | Description
IADDataSet |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
PADKeyBuffer |
TADAfterApplyUpdatesEvent | ..
TADCopyDataSetOptions |
TADDataSetEvent |
TADDataSetFlags |
TADDataSetLocateOptions |
TADReconcileErrorEvent |
TADStoredActivationUsage |
TADUpdateErrorEvent |
TADUpdateRecordEvent |
Records, Enums
Name | Description
TADDataSetLocateOption |
TADKeyBuffer |
TADKeyIndex |
Links
Classes, Interfaces, Legend, Topics, Types, Records, Enums


Classes

Classes
Classes uADCompDataSet Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADAggregate |
TADAggregates |
TADAutoIncField |
TADBlobStream |
TADColMapItem |
TADDataSet | ..
TADIndex |
TADIndexes |
TADMasterDataLink |
TADWideMemoField |
Unit

uADCompDataSet Unit

Links
Classes, uADCompDataSet Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADAggregate Class

TADAggregate Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, published, Classes
Syntax
TADAggregate = class(TCollectionItem);


public

public
TADAggregate Class Legend Public Methods Public Properties Send Feedback

The public members of the TADAggregate class are listed here.

Class

TADAggregate Class

Public Methods
Name | Description
Assign |
BeginUpdate |
Destroy |
EndUpdate |
Public Properties
Name | Description
ActualActive |
DataSet |
DataType |
InUse |
Value |
Links
TADAggregate Class, Legend, Public Methods, Public Properties


TADAggregate.ActualActive Property

TADAggregate.ActualActive Property
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
property ActualActive: Boolean;


TADAggregate.DataSet Property

TADAggregate.DataSet Property
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
property DataSet: TADDataSet;


TADAggregate.DataType Property

TADAggregate.DataType Property
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
property DataType: TADDataType;


TADAggregate.InUse Property

TADAggregate.InUse Property
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
property InUse: Boolean;


TADAggregate.Value Property

TADAggregate.Value Property
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
property Value: Variant;


TADAggregate.Assign Method

TADAggregate.Assign Method
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADAggregate.BeginUpdate Method

TADAggregate.BeginUpdate Method
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
procedure BeginUpdate;


TADAggregate.Destroy Destructor

TADAggregate.Destroy Destructor
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
destructor Destroy; override;


TADAggregate.EndUpdate Method

TADAggregate.EndUpdate Method
TADAggregate Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregate Class, uADCompDataSet Unit, public
Syntax
procedure EndUpdate;


published

published
TADAggregate Class Legend Published Properties Send Feedback

The published members of the TADAggregate class are listed here.

Class

TADAggregate Class

Published Properties
Name | Description
Active |
Expression |
GroupingLevel |
IndexName |
Name |
Links
TADAggregate Class, Legend, Published Properties


TADAggregate.Active Property

TADAggregate.Active Property
TADAggregate Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAggregate Class, uADCompDataSet Unit, published
Syntax
property Active: Boolean;


TADAggregate.Expression Property

TADAggregate.Expression Property
TADAggregate Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAggregate Class, uADCompDataSet Unit, published
Syntax
property Expression: String;


TADAggregate.GroupingLevel Property

TADAggregate.GroupingLevel Property
TADAggregate Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAggregate Class, uADCompDataSet Unit, published
Syntax
property GroupingLevel: Integer;


TADAggregate.IndexName Property

TADAggregate.IndexName Property
TADAggregate Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAggregate Class, uADCompDataSet Unit, published
Syntax
property IndexName: String;


TADAggregate.Name Property

TADAggregate.Name Property
TADAggregate Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAggregate Class, uADCompDataSet Unit, published
Syntax
property Name: String;


TADAggregates Class

TADAggregates Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADAggregates = class(TCollection);


public

public
TADAggregates Class Legend Public Methods Public Properties Send Feedback

The public members of the TADAggregates class are listed here.

Class

TADAggregates Class

Public Methods
Name | Description
Add |
AggregateByName |
Build |
Create |
FindAggregate |
Release |
Public Properties
Name | Description
GroupingLevel |
Items |
Links
TADAggregates Class, Legend, Public Methods, Public Properties


TADAggregates.GroupingLevel Property

TADAggregates.GroupingLevel Property
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
property GroupingLevel: Integer;


TADAggregates.Items Property

TADAggregates.Items Property
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
property Items [AIndex: Integer]: TADAggregate;


TADAggregates.Add Method

TADAggregates.Add Method
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
function Add: TADAggregate;


TADAggregates.AggregateByName Method

TADAggregates.AggregateByName Method
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
function AggregateByName(const AName: String): TADAggregate;


TADAggregates.Build Method

TADAggregates.Build Method
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
procedure Build;


TADAggregates.Create Constructor

TADAggregates.Create Constructor
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
constructor Create(ADataSet: TADDataSet);


TADAggregates.FindAggregate Method

TADAggregates.FindAggregate Method
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
function FindAggregate(const AName: String): TADAggregate;


TADAggregates.Release Method

TADAggregates.Release Method
TADAggregates Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAggregates Class, uADCompDataSet Unit, public
Syntax
procedure Release;


TADAutoIncField Class

TADAutoIncField Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, published, Classes
Syntax
TADAutoIncField = class(TAutoIncField);


public

public
TADAutoIncField Class Legend Public Methods Send Feedback

The public members of the TADAutoIncField class are listed here.

Class

TADAutoIncField Class

Public Methods
Name | Description
Create |
Links
TADAutoIncField Class, Legend, Public Methods


TADAutoIncField.Create Constructor

TADAutoIncField.Create Constructor
TADAutoIncField Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADAutoIncField Class, uADCompDataSet Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


published

published
TADAutoIncField Class Legend Published Properties Send Feedback

The published members of the TADAutoIncField class are listed here.

Class

TADAutoIncField Class

Published Properties
Name | Description
AutoGenerateValue |
AutoIncrementSeed |
AutoIncrementStep |
ClientAutoIncrement |
ProviderFlags |
ReadOnly |
ServerAutoIncrement |
Links
TADAutoIncField Class, Legend, Published Properties


TADAutoIncField.AutoGenerateValue Property

TADAutoIncField.AutoGenerateValue Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property AutoGenerateValue;


TADAutoIncField.AutoIncrementSeed Property

TADAutoIncField.AutoIncrementSeed Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property AutoIncrementSeed: Integer;


TADAutoIncField.AutoIncrementStep Property

TADAutoIncField.AutoIncrementStep Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property AutoIncrementStep: Integer;


TADAutoIncField.ClientAutoIncrement Property

TADAutoIncField.ClientAutoIncrement Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property ClientAutoIncrement: Boolean;


TADAutoIncField.ProviderFlags Property

TADAutoIncField.ProviderFlags Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property ProviderFlags;


TADAutoIncField.ReadOnly Property

TADAutoIncField.ReadOnly Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property ReadOnly;


TADAutoIncField.ServerAutoIncrement Property

TADAutoIncField.ServerAutoIncrement Property
TADAutoIncField Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADAutoIncField Class, uADCompDataSet Unit, published
Syntax
property ServerAutoIncrement: Boolean;


TADBlobStream Class

TADBlobStream Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADBlobStream = class(TMemoryStream);


public

public
TADBlobStream Class Legend Public Methods Send Feedback

The public members of the TADBlobStream class are listed here.

Class

TADBlobStream Class

Public Methods
Name | Description
Create |
Destroy |
Truncate |
Write |
Links
TADBlobStream Class, Legend, Public Methods


TADBlobStream.Create Constructor

TADBlobStream.Create Constructor
TADBlobStream Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADBlobStream Class, uADCompDataSet Unit, public
Syntax
constructor Create(AField: TField; AMode: TBlobStreamMode);


TADBlobStream.Destroy Destructor

TADBlobStream.Destroy Destructor
TADBlobStream Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADBlobStream Class, uADCompDataSet Unit, public
Syntax
destructor Destroy; override;


TADBlobStream.Truncate Method

TADBlobStream.Truncate Method
TADBlobStream Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADBlobStream Class, uADCompDataSet Unit, public
Syntax
procedure Truncate;


TADBlobStream.Write Method

TADBlobStream.Write Method
TADBlobStream Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADBlobStream Class, uADCompDataSet Unit, public
Syntax
function Write(const ABuffer; ACount: Longint): Longint; override;


TADColMapItem Class

TADColMapItem Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADColMapItem = class(TObject);


public

public
TADColMapItem Class Legend Public Fields Send Feedback

The public members of the TADColMapItem class are listed here.

Class

TADColMapItem Class

Public Fields
Name | Description
FColumn |
FColumnIndex |
FPath |
Links
TADColMapItem Class, Legend, Public Fields


TADColMapItem.FColumn Field

TADColMapItem.FColumn Field
TADColMapItem Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADColMapItem Class, uADCompDataSet Unit, public
Syntax
FColumn: TADDatSColumn;


TADColMapItem.FColumnIndex Field

TADColMapItem.FColumnIndex Field
TADColMapItem Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADColMapItem Class, uADCompDataSet Unit, public
Syntax
FColumnIndex: Integer;


TADColMapItem.FPath Field

TADColMapItem.FPath Field
TADColMapItem Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADColMapItem Class, uADCompDataSet Unit, public
Syntax
FPath: array of Integer;


TADDataSet Class

TADDataSet Class
public Classes See Also Send Feedback

..

Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes, See Also
Description

..

Syntax
TADDataSet = class(TDataSet, IUnknown, IADDataSet);
See Also

..


public

public
TADDataSet Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADDataSet class are listed here.

Class

TADDataSet Class

Public Events
Name | Description
AfterApplyUpdates | Fires after cached updates are applied to DB.
AfterExecute | Fires after SQL command execution is finished.
AfterGetRecords | Fires after fetching next rowset.
AfterRowRequest | Fires after fetching record.
BeforeApplyUpdates | Fires before cached updates are applied to DB.
BeforeExecute | Fires before SQL command execution is started.
BeforeGetRecords | Fires before fetching next rowset.
BeforeRowRequest | Fires before fetching record.
OnReconcileError | Fires when a dataset needs to reconcile an update to a record that cannot not be applied.
OnUpdateError | Fires if an exception is generated when updates are applied to a database.
OnUpdateRecord | Occurs when record update is applying to a database.
Public Methods
Name | Description
AddIndex | Creates a new client index for the dataset.
ApplyRange | Applies a range to the dataset.
ApplyUpdates | Applies changes for all records in change log to the database.
AttachTable | Attaches dataset to existing DatS table and optionaly view.
BeginBatch | Optimizes dataset functionality for batch updates.
BookmarkStrValid |
BookmarkValid |
Cancel |
CancelRange | Cancels range for the dataset.
CancelUpdates | Removes all records from the change log and restores the dataset rows to its prior editing state.
CloneCursor | Shares the data belonging to another dataset.
CommitUpdates | Clears the changes log and marks all records as not modified.
CompareBookmarks |
CopyDataSet | Copies records from source dataset to this dataset.
CopyFields | Copies all fields from source dataset to this dataset.
Create |
CreateBlobStream |
CreateDataSet | Creates new empty internal data storage for dataset.
CreateExpression | Creates expression evaluator for dataset.
DeleteIndex | Deletes an client index for the dataset.
DeleteIndexes | Deletes all client indexes for the dataset.
Destroy |
DisableConstraints | Disables the enforcement of client constraints.
Disconnect | Use Disconnect method to release DBMS resources, used by this dataset.
EditKey | Enables modification of the search key buffer.
EditRangeEnd | Enables changing the ending value for an existing range.
EditRangeStart | Enables changing the starting value for an existing range.
EmptyDataSet | Removes all records from the dataset internal data storage.
EnableConstraints | Reenables enforcement of client constraints when records are posted.
EndBatch | Restores normal dataset functionality after batch updates.
Execute | Executes an SQL command.
FetchAgain | Allows to fetch additional records.
FetchAll | Retrieves all records from the current resultset and stores them into internal DatS table.
FetchBlobs | Retrieves BLOB field values from database for current record.
FetchDetails | Retrieves nested datasets from database for current record.
FindKey | Searches for a record containing specified index field values.
FindNearest | Searches for a record containing specified index field values.
FindParam | Finds the parameter in Params property by a given name.
GetColumnField | Returns field corresponding to DatS column.
GetCurrentRecord |
GetDetailLinkFields | Lists the field objects that link this dataset as a detail of a master dataset.
GetFieldColumn | Returns DatS column corresponding to field.
GetFieldData |
GetFieldData |
GetGroupState | Indicates where the current record sits within a specified group of records.
GetIndexNames | Fills the list by client index names.
GetNextPacket | Fetches the next rowset from the DBMS.
GetParentRow | Returns parent row of this nested dataset.
GetRow | Returns DatS row.
GotoCurrent | Sets the current record in this dataset the same as the current record in another, cloned dataset.
GotoKey | Searches for a record, using values in the key buffer.
GotoNearest | Searches for a closest record, using values in the key buffer.
IsIndexed | Returns True, if dataset has current client index.
IsLinked | Returns True, if dataset is linked to another dataset.
IsSequenced |
LoadFromFile | Loads a dataset's data from a file.
LoadFromFileAtOpen | Returns True, if dataset content will be loaded from file at Open.
LoadFromStream | Loads a dataset's data from a stream.
Locate | Searches the dataset for a record with specified field values and makes it current.
LocateEx | Searches the dataset for a specified record by predicate expression and makes that record current or returns its index.
LocateEx | Searches the dataset for a specified record by its fields values and makes that record current or returns its index.
Lookup | Searches the dataset for a record with specified key field values and returns result field values.
LookupEx | Searches the dataset for a record with specified key field values and returns result field values.
LookupEx | Searches the dataset for a record by predicate expression and returns result field values.
Offline | Sets dataset to offline mode.
OpenOrExecute | Executes SQL command and optionally opens dataset.
ParamByName | Searches parameter by its name.
Post |
Reconcile |
RefreshRecord | Rereads field values of the current record from a data source.
RevertRecord | Undoes changes to the current record.
SaveToFile | Saves a dataset's data to a file.
SaveToFileAtClose | Returns True, if dataset content will be saved to file at Close.
SaveToStream | Saves a dataset's data to a stream.
SetFieldAttributes |
SetFieldAttributes |
SetFieldAttributes |
SetFieldAutoGenerateValue |
SetKey | Starts the enter key values mode.
SetRange | Sets the starting and ending values of a range, and applies it.
SetRangeEnd | Sets the ending values of a range.
SetRangeStart | Sets the starting values of a range.
UndoLastChange | Undoes the last modification to the dataset records.
UpdateStatus | Returns the modification status for current record.
Public Properties
Name | Description
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
Aggregates | The collection of client side aggregates, defined for dataset.
AggregatesActive | Controls automatic calculation of aggregate values.
CachedUpdates | Specifies whether dataset will log changes to the data without immediate applying of them to the database.
ChangeCount | Gets the number of changes in the change log.
CloneSource | Gets the dataset (if any) with which this dataset shares data.
Constraints | Specifies record-level client constraints that must be met when editing the data.
ConstraintsEnabled | Specifies whether the dataset perform constraint checking.
Data | Represents the data of the dataset, allowing to copy full data of one dataset into another.
DatSManager | Returns the reference to the internal data storage manager.
Delta | Represents the changed records of the dataset.
FilterChanges | Specifies what kinds of changed records must be "visible" in the dataset.
FilteredData | Represents the currently "visible" data of the dataset.
GroupingLevel | Returns the depth of grouping support provided by the current index.
IndexDefs | Returns indexes definition for the dataset.
Indexes | Lists all client indexes that apply to the dataset.
IndexesActive | Controls automatic maintenance of Index'es.
IndexFieldCount | Returns the number of fields that make up the current index.
IndexFieldNames | Lists the field names to use as an index.
IndexFields | Returns the fields that make up the current index.
IndexName | Gets / sets the current index for the dataset by its name.
KeyExclusive | Controls the exclusion of upper and lower boundaries for a range.
KeyFieldCount | Controls the number of indexed field values to use for key search or range setup.
MasterFields | Gets / sets fields in master dataset, used to establish a master-detail relationship with this dataset.
MasterSource | Gets / sets a master data source, used to establish a master-detail relationship with this dataset.
ParentDataSet | Returns the reference to parent dataset, if this one is nested.
Ranged | Specifies whether the dataset records are limited by a range.
SavePoint | Gets / sets the change log version number.
SourceEOF | Specifies if no more records to fetch from current cursor.
SourceView | The reference to DatS view object, by which rows the dataset is navigating.
Table | The reference to DatS table object, actually representing the internal data storage.
UpdatesPending | Indicates whether the changes log is not empty.
View | The reference to base DatS view object.
Links
TADDataSet Class, Legend, Public Events, Public Methods, Public Properties


TADDataSet.ActiveStoredUsage Property

TADDataSet.ActiveStoredUsage Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Controls how to use Active property value saved to DFM.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The ActiveStoredUsage property controls how to use Active property value saved to DFM. Include:

  • auDesignTime, to use property value at design time;
  • auRunTime, to use property value at run time.
Syntax
property ActiveStoredUsage: TADStoredActivationUsage;
See Also

TDataSet.Active

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.AfterApplyUpdates Event

TADDataSet.AfterApplyUpdates Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires after cached updates are applied to DB.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The AfterApplyUpdates event fires after cached updates are applied to DB as result of ApplyUpdates method call.

Syntax
property AfterApplyUpdates: TADAfterApplyUpdatesEvent;
See Also

TADAfterApplyUpdatesEvent, ApplyUpdates, BeforeApplyUpdates


TADDataSet.AfterExecute Event

TADDataSet.AfterExecute Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires after SQL command execution is finished.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The AfterExecute event fires after SQL command execution is finished as result of Execute method call.

Syntax
property AfterExecute: TADDataSetEvent;
See Also

TADDataSetEvent, Execute, BeforeExecute

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.AfterGetRecords Event

TADDataSet.AfterGetRecords Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires after fetching next rowset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The AfterGetRecords event fires after dataset fetched next rowset as result of navigation methods calls. For example, fetching occurs automatically inside of Next, Last, Locate methods.

Syntax
property AfterGetRecords: TADDataSetEvent;
See Also

TADDataSetEvent, BeforeGetRecords

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.AfterRowRequest Event

TADDataSet.AfterRowRequest Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires after fetching record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The AfterRowRequest event fires after dataset fetched current record as result of RefreshRecord, FetchBlobs or FetchDetails method calls.

Syntax
property AfterRowRequest: TADDataSetEvent;
See Also

TADDataSetEvent, RefreshRecord, FetchBlobs, FetchDetails, BeforeRowRequest


TADDataSet.Aggregates Property

TADDataSet.Aggregates Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

The collection of client side aggregates, defined for dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use Aggregates to define client side aggregating formulas, that will be automatically maintained and calculated for group of or for all records of dataset.

All records in the group of records has the same field values for defined set of fields. Aggregates performing calculation for group of records must be associated with one of the indexes. These aggregate expressions will be calculated only is associated index is current and active.

Adding aggregate field does not add TADAggregate object to Aggregates collection. That are two alternative ways - to use aggregate fields or to use Aggregates.

DataSet will automatically maintain and calculate Aggregates values when dataset is fetching the data or application edits the data, if AggregatesActive is True. If application needs to perform large updates to dataset and aggregate values are not needed while updating, then set AggregatesActive to False before updates, and return to original value after updates. Also see BeginBatch / EndBatch methods.

When aggregates are maintained, the Value method of every active aggregate object returns a value that reflects the current data in the dataset. When users edit the data in the dataset, these values are recalculated to reflect the user's changes.

The expressions in Aggregates must contain aggregating functions, like a SUM, COUNT. AnyDAC supports expression syntax compatible with:

  • BDE data access components;
  • TClientDataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write constraint expressions.

Syntax
property Aggregates: TADAggregates;
See Also

AggregatesActive, BeginBatch, EndBatch

Example
with ADMemTable1.Aggregates.Add do begin
  Expression := 'sum(sal + bonus)';
  Active := True;
end;
with ADMemTable1.Aggregates.Add do begin
  Expression := 'sum(sal + bonus)';
  IndexName := 'by_deps';
  Active := True;
end;
ADMemTable1.IndexName := 'by_deps';
ADMemTable1.AggregatesActive := True;

Label1.Caption := 'Total payments : ' + VarToStr(ADMemTable1.Aggregates[0].Value);
Label2.Caption := 'Current department payments : ' + VarToStr(ADMemTable1.Aggregates[1].Value);


TADDataSet.AggregatesActive Property

TADDataSet.AggregatesActive Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Controls automatic calculation of aggregate values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use AggregatesActive to get / set the flag controlling automatic maintenance and calculation of dataset aggregate values.

When AggregatesActive is False (the default), the dataset does not maintain aggregates. This allows the dataset to perform large updates to the dataset or fetch big volumes of data without overhead of calculating aggregate values, which happens at fetching or data editing. When AggregatesActive is True, the dataset calculates and maintains all aggregate values specified by the Aggregates property that are compatible with the current index.

To selectively enable and disable aggregates rather than turning them all on or off at once, use the Active property of individual TADAggregate objects. These objects are available through the Aggregates property.

If application needs to perform batch updates to dataset, then set AggregatesActive to False before updates, and return to original value after updates. Also see BeginBatch / EndBatch methods.

Syntax
property AggregatesActive: Boolean;
See Also

Aggregates, TADAggregate.Active, BeginBatch, EndBatch

Example
var
  lPrevAggsActive: Boolean;
...
lPrevAggsActive := ADQuery1.AggregatesActive;
ADQuery1.AggregatesActive := False;
try
  // perform updates here, without calculating and reading client aggregates
finally
  ADQuery1.AggregatesActive := lPrevAggsActive;
end;


TADDataSet.BeforeApplyUpdates Event

TADDataSet.BeforeApplyUpdates Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires before cached updates are applied to DB.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The BeforeApplyUpdates event fires before cached updates are applied to database as result of ApplyUpdates method call.

Syntax
property BeforeApplyUpdates: TADDataSetEvent;
See Also

TADDataSetEvent, ApplyUpdates, AfterApplyUpdates


TADDataSet.BeforeExecute Event

TADDataSet.BeforeExecute Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires before SQL command execution is started.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The BeforeExecute event fires before SQL command execution is started as result of Execute method call.

Syntax
property BeforeExecute: TADDataSetEvent;
See Also

TADDataSetEvent, Execute, AfterExecute

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.BeforeGetRecords Event

TADDataSet.BeforeGetRecords Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires before fetching next rowset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The BeforeGetRecords event fires before dataset will fetch next rowset as result of navigation methods calls. For example, fetching occurs automatically inside of Next, Last, Locate methods.

Syntax
property BeforeGetRecords: TADDataSetEvent;
See Also

TADDataSetEvent, AfterGetRecords

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.BeforeRowRequest Event

TADDataSet.BeforeRowRequest Event
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fires before fetching record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The BeforeRowRequest event fires before dataset will fetch current record as result of RefreshRecord, FetchBlobs or FetchDetails method calls.

Syntax
property BeforeRowRequest: TADDataSetEvent;
See Also

TADDataSetEvent, RefreshRecord, FetchBlobs, FetchDetails, AfterRowRequest


TADDataSet.CachedUpdates Property

TADDataSet.CachedUpdates Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Specifies whether dataset will log changes to the data without immediate applying of them to the database.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

CachedUpdates enables (True) or disables (False) the logging of data changes (Insert/Post, Edit/Post, Delete) without immediate applying of them to the database.

An application must explicitly apply changes from change log to the database, using ApplyUpdates method. All changes will be written in comparably small amount of time in single transaction. The main benefits of enabling cached updates are:

  • fewer transactions and shorter transaction times;
  • minimization of network traffic;
  • simplified implementation of undo / redo functionality for dataset;
  • ability to implement application offline mode or briefcase model.

The potential drawbacks of enabling cached updates are:

  • other applications can access and change the actual data on the server while users are editing local copies of the data, resulting in an update conflict when cached updates are applied to the database;
  • other applications cannot access data changes made by an application until its cached updates are applied to the database.
Syntax
property CachedUpdates: Boolean;
See Also

ApplyUpdates, CancelUpdates, CommitUpdates

Example
ADQuery1.CachedUpdates := True;
...
ADQuery1.Edit;
...
ADQuery1.Post;
...
ADQuery1.Append;
...
ADQuery1.Post;
...
ADQuery1.ApplyUpdates;
ADQuery1.CommitUpdates;
ADQuery1.CachedUpdates := False;


TADDataSet.ChangeCount Property

TADDataSet.ChangeCount Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Gets the number of changes in the change log.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use ChangeCount to determine how many modifications are in the datasets change log. ChangeCount:

  • increases when the data is edited (eg Edit / Post);
  • decreses when changes are undone (eg UndoLastChange);
  • sets to zero after commiting (CommitUpdates) or canceling all updates (CancelUpdates).
Syntax
property ChangeCount: Integer;
See Also

CachedUpdates, UndoLastChange, CancelUpdates, CommitUpdates, ApplyUpdates

Example
procedure TForm1.ADQuery1AfterPost(DataSet: TDataSet);
begin
  if TADDataSet(DataSet).ChangeCount = 0 then
    StatusBar1.SimpleText := 'no changes'
  else
    StatusBar1.SimpleText := Format('%d changed rows', [TADDataSet(DataSet).ChangeCount]);
end;


TADDataSet.CloneSource Property

TADDataSet.CloneSource Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Gets the dataset (if any) with which this dataset shares data.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use CloneSource to access another dataset that shares its internal data storage with this one. CloneSource is set by the CloneCursor method when the datasets are linked. If the dataset has not called CloneCursor to share the data storage of another dataset, CloneSource is nil.

Syntax
property CloneSource: TADDataSet;
See Also

CloneCursor

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Constraints Property

TADDataSet.Constraints Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Specifies record-level client constraints that must be met when editing the data.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use Constraints to maintain record-level constraints for the dataset.

Record-level constraints force business ruless limiting few fields in a single record. This constraints are checked at end of data editing (Post / AppendRecord / InsertRecord). Constraints, limiting single field are field constraints and must specified at TField.CustomConstraint or TField.ImportedConstraint.

The Constraints checking is performed when ConstraintsEnabled is True. If application needs to perform large updates to the dataset and application can guarantee the data consistancy, then set ConstraintsEnabled to False before updates, and return to original value after updates. Theconstraints are not checked at data fetching.

The expressions in Constraints must be predicates, evaluating to Boolean value. AnyDAC supports expression syntax compatible with:

  • BDE data access components;
  • Client dataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write constraint expressions.

Syntax
property Constraints;
See Also

ConstraintsEnabled, DisableConstraints, EnableConstraints, BeginBatch, EndBatch, TDataSet.Post, TDataSet.AppendRecord, TDataSet.InsertRecord, TField.CustomConstraint, TField.ImportedConstraint

Example
with ADMemTable1.Constraints.Add do begin
  CustomConstraint := 'sal + bonus <= 2000';
  ErrorMessage := 'The employee payments must be equal or less than 2000 usd';
end;

ADMemTable1.ConstraintsEnabled := True;
ADMemTable1.Edit;
try
  ADMemTable1.FieldByName('sal').AsFloat := 1800;
  ADMemTable1.FieldByName('bonus').AsFloat := 300;
  // here exception will be raised
  ADMemTable1.Post;
except
  ADMemTable1.Cancel;
  Application.HandleException(Self);
end;

ADMemTable1.ConstraintsEnabled := False;
ADMemTable1.Edit;
ADMemTable1.FieldByName('sal').AsFloat := 1800;
ADMemTable1.FieldByName('bonus').AsFloat := 300;
// here exception will be NOT raised, because constraint checking is disabled
ADMemTable1.Post;


TADDataSet.ConstraintsEnabled Property

TADDataSet.ConstraintsEnabled Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Specifies whether the dataset perform constraint checking.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use ConstraintsEnabled to get / set the flag controlling automatic record-level constraints enforcement.

When ConstraintsEnabled is False, the dataset does not check Constraints. This allows the dataset to performe large data updates without overhead of checking constraints. When ConstraintsEnabled is True (the default), the dataset checks Constraints at at end of data editing (Post / AppendRecord / InsertRecord).

If application needs to perform batch updates to dataset, then set ConstraintsEnabled to False before updates, and return to original value after updates. Also see BeginBatch / EndBatch methods.

Syntax
property ConstraintsEnabled: Boolean;
See Also

Constraints, BeginBatch, EndBatch, DisableConstraints, EnableConstraints, TDataSet.Post, TDataSet.AppendRecord, TDataSet.InsertRecord

Example
var
  lPrevConsEnabled: Boolean;
...
lPrevConsEnabled := ADQuery1.ConstraintEnabled;
ADQuery1.ConstraintEnabled := False;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.ConstraintEnabled := lPrevConsEnabled;
end;


TADDataSet.Data Property

TADDataSet.Data Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Represents the data of the dataset, allowing to copy full data of one dataset into another.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

The Data property represents the dataset's internal in-memory data storage. Using this property application can copy current structure and data of one AnyDAC dataset to another AnyDAC dataset.

The property value is reference to IADDataSet interface. It is reference counted and application does not need explicitly to free it. If application keeps the interface reference using a variable or a field, then reference must be released before dataset will be closed.

The dataset must be inactive to set this property value, otherwise exception will be raised. After its setting, the dataset has:

  • structure as original dataset, but no Indexes, IndexDefs, Filter, etc;
  • original dataset data copy.

And the dataset is opened.

Syntax
property Data: IADDataSet;
See Also

Delta, FilteredData, CopyDataSet

Example
ADQuery1.SQL.Text := 'select * from orders; select * from customers';

ADQuery1.Open;
ADQuery1.FetchAll;
// assign orders records to ADMemTable1
ADMemTable1.Data := ADQuery1.Data;

ADQuery1.NextRecordSet;
ADQuery1.FetchAll;
// assign customers records to ADMemTable2
ADMemTable2.Data := ADQuery1.Data;


TADDataSet.DatSManager Property

TADDataSet.DatSManager Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns the reference to the internal data storage manager.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The DatSManager property value is the reference to the internal data storage manager.

Syntax
property DatSManager: TADDatSManager;
See Also

Table, View, SourceView, AttachTable

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Delta Property

TADDataSet.Delta Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Represents the changed records of the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

The Delta property value represents the set of changed records in the dataset. The set may be assigned to other datasets Data property.

The property value is reference to IADDataSet interface. It is reference counted and application does not need explicitly to free it. If application keeps the interface reference using a variable or a field, then reference must be released before dataset will be closed.

Syntax
property Delta: IADDataSet;
See Also

Data, FilteredData

Example
// copy to ADMemTable1 all ADQuery1 changed records and theyr versions
ADMemTable1.Data := ADQuery1.Delta;


TADDataSet.FilterChanges Property

TADDataSet.FilterChanges Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Specifies what kinds of changed records must be "visible" in the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The FilterChanges property allows to get / set changed records kinds, which must be accessible through navigation interface of dataset ("visible" in dataset):

Kind | Meaning
rtModified | Records changed after fetching or last CommitUpdates / CancelUpdates.
rtInserted | New records, not yet posted to DB and added after dataset open or after last CommitUpdates.
rtDeleted | Deleted records, not yet deleted from DB and deleted after dataset open or after last CommitUpdates.
rtUnmodified | Unchanged records.
Syntax
property FilterChanges: TUpdateRecordTypes;
See Also
// see only inserted records
ADQuery1.FilterChanges := [rtInserted];


TADDataSet.FilteredData Property

TADDataSet.FilteredData Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Represents the currently "visible" data of the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

The FilteredData property value represents the set of records accessible through navigation interface of the dataset ("visible" in the dataset). This set is formed by applying of filters, ranges, indexes, etc. The set may be assigned to other datasets Data property.

The property value is reference to IADDataSet interface. It is reference counted and application does not need explicitly to free it. If application keeps the interface reference using a variable or a field, then reference must be released before one of following events occurs:

  • close dataset;
  • change Filter / FilterChanges / FilterOptions / OnFilterRecord / Filtered property values;
  • change IndexName / IndexFieldNames / Indexes property values;
  • change current ranges.
Syntax
property FilteredData: IADDataSet;
See Also

Delta, Data, Filter, OnFilterRecord, IndexName, IndexFieldNames, Indexes

Example
ADQuery1.Filter := 'upper(name) like ''D%''';
ADQuery1.Filtered := True;
// copy to ADMemTable1 all ADQuery1 visible (where name starts from D) records
ADMemTable1.Data := ADQuery1.FilteredData;


TADDataSet.GroupingLevel Property

TADDataSet.GroupingLevel Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns the depth of grouping support provided by the current index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Read GroupingLevel to determine the maximum level group for which grouping support is available. The datasets provide grouping support by GetGroupState method. It indicates where the current record falls within a group.

A group is defined as the set of records that have the same value on each of a set of fields. A level 0 group is the set of all records in the dataset. A level 1 group is the set of records with the same value on the first field of the index. A level 2 group is the set of records with the same values on each of the first two fields of the index. A level n group is the set of records with the same values on each of the first n fields of the index.

By default, GroupingLevel is the default grouping level of the current index or the maximum grouping level of a maintained aggregate on the current index, whichever is greater. GroupingLevel can never be greater than IndexFieldCount.

Syntax
property GroupingLevel: Integer;
See Also

GetGroupState, IndexFieldCount

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.IndexDefs Property

TADDataSet.IndexDefs Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns indexes definition for the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use IndexDefs property to read or maintain indexes definitions.

The dataset also has Indexes collection. Application should use either IndexDefs, either Indexes, but not both in the same time. We suggest to use Indexes, as it is more flexible.

The TADTable will automatically fill IndexDefs by database indexes, if fiMeta in FetchOptions.Items.

Syntax
property IndexDefs: TIndexDefs;
See Also

Indexes, TADFetchOptions.Items

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Indexes Property

TADDataSet.Indexes Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Lists all client indexes that apply to the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use Indexes to define client side data views for the dataset. Indexes is a collection of TADIndex objects, each of which defines:

  • optional sorting fields or sorting expression;
  • optional records filter expression.

Some of navigation methods, like a Locate / Lookup / SetRange are using indexes to optimize its operations.

The individual indexes are not just sort and filter definitions. AnyDAC maintains consistent view of the data for each active index, while application fetches data or edits data. That creates additional overhead, but allows to switch between indexes without delays.

Setting IndexFieldNames does not add TADIndex object to Indexes collection. Defining IndexDefs before dataset opening, will clear Indexes and fill them from using IndexDefs information. So, there are two alternative ways - to use IndexDefs or to use Indexes. We suggest to use Indexes, as it is more flexible.

DataSet will maintain Indexes views, if IndexesActive is True. If application needs to perform batch updates to dataset, then set IndexesActive to False before updates, and return to original value after updates. Also see BeginBatch / EndBatch methods.

The sorting and filter expressions in Indexes supports syntax compatible with:

  • BDE data access components;
  • TClientDataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write constraint expressions.

Syntax
property Indexes: TADIndexes;
See Also

IndexDefs, IndexesActive, IndexFieldNames, IndexName, BeginBatch, EndBatch

Example
with ADMemTable1.Indexes.Add do begin
  Name := 'by_name';
  Fields := 'NAME;DT';
  Active := True;
end;
with ADMemTable1.Indexes.Add do begin
  Name := 'by_payments';
  Expression := 'sum(sal + bonus)';
  Filter := 'dep_id is not null;
  Active := True;
end;
ADMemTable1.IndexesActive := True;
ADMemTable1.IndexFieldName := 'by_name';


TADDataSet.IndexesActive Property

TADDataSet.IndexesActive Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Controls automatic maintenance of Index'es.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use IndexesActive to indicate whether the dataset should maintain data views, declared by indexes.

When IndexesActive is False, the dataset does not maintain data views. This allows the dataset to avoid the overhead of updating views, while data is fetched or is edited. When IndexesActive is True (by default), the dataset maintains data views specified by the Indexes property.

When indexes are maintained, each of them may be current index, selected by TADIndex.Select or by IndexName properties.

To selectively enable and disable data views rather than turning them all on or off at once, use the Active property of individual TADIndex objects. These objects are available through the Indexes property.

If application needs to perform batch updates to dataset, then set IndexesActive to False before updates, and return to original value after updates. Also see BeginBatch / EndBatch methods.

Syntax
property IndexesActive: Boolean;
See Also

Indexes, BeginBatch, EndBatch

Example
var
  lPrevIndsActive: Boolean;
...
lPrevIndsActive := ADQuery1.IndexesActive;
ADQuery1.IndexesActive := False;
try
  // perform updates here, without maintaining client views
finally
  ADQuery1.IndexesActive := lPrevIndsActive;
end;


TADDataSet.IndexFieldCount Property

TADDataSet.IndexFieldCount Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns the number of fields that make up the current index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use IndexFieldCount to determine how many fields are used by the current index for the dataset.

The property has the meaning only for non-expressional indexes.

Syntax
property IndexFieldCount: Integer;
See Also

IndexFieldNames, IndexName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.IndexFieldNames Property

TADDataSet.IndexFieldNames Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Lists the field names to use as an index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use IndexFieldNames as an alternative method of specifying the current index to use for a dataset.

Specify the name of each field on which to index the dataset, separating names with semicolons. Ordering of field names is significant. Optionally specify the postfix for any of fields in form "field[:[D][A][N]]", where:

- 'D' - use descending sorting on this field;

- 'A' - use ascending sorting on this field;

- 'N' - use case-insensitive sorting on this field.

Use IndexFieldNames to create sort orders on the fly. The IndexFieldNames and IndexName properties are mutually exclusive. Setting one clears the other.

Syntax
property IndexFieldNames: String;
See Also

Indexes, IndexName

Example
ADQuery1.IndexFieldNames := 'order_date;customer_name:N';


TADDataSet.IndexFields Property

TADDataSet.IndexFields Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns the fields that make up the current index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

IndexFields is a zero-based array of TField objects, each of which corresponds to a field in the current index.

Index parameter is an ordinal value indicating the position of a field in the index.

To set dataset ordering use the IndexFieldNames or IndexName properties to order datasets on the fly at runtime.

The property has the meaning only for non-expressional indexes.

Syntax
property IndexFields [AIndex: Integer]: TField;
See Also

IndexFieldNames, IndexName, IndexFieldCount


TADDataSet.IndexName Property

TADDataSet.IndexName Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Gets / sets the current index for the dataset by its name.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use IndexName to specify the current index for the dataset.

If IndexName is empty, the dataset's sort order is based on the IndexFieldNames property or on its default ordering as it is in dataset. If IndexName contains a name of valid index from Indexes collection, then that index is used to determine data view (including sort order) of records.

IndexFieldNames and IndexName are mutually exclusive. Setting one clears the other.

Syntax
property IndexName: String;
See Also

Indexes, IndexFieldNames

Example
with ADMemTable1.Indexes.Add do begin
  Name := 'by_name';
  Fields := 'NAME;DT';
  Active := True;
end;
ADMemTable1.IndexFieldName := 'by_name';


TADDataSet.KeyExclusive Property

TADDataSet.KeyExclusive Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Controls the exclusion of upper and lower boundaries for a range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use KeyExclusive to get / set the flag controling should a range include or exclude the records that exactly match starting and ending values range values.

By default, KeyExclusive is False, meaning that exact matching values are included. To restrict a range to those records that are greater than the specified starting value and less than the specified ending value, set KeyExclusive to True. Setting of KeyExclusive is possible only in dsSetKeyMode.

The property has the meaning only for non-expressional indexes.

Syntax
property KeyExclusive: Boolean;
See Also

FindNearest, GotoNearest, SetRange, SetRangeEnd, SetRangeStart


TADDataSet.KeyFieldCount Property

TADDataSet.KeyFieldCount Property
TADDataSet Class uADCompDataSet Unit Example 1 Example 2 public See Also Send Feedback

Controls the number of indexed field values to use for key search or range setup.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example 1, Example 2, public, See Also
Description

Use KeyFieldCount to get / set the number of indexed field values to use for key searching or ranges setup.

The KeyFieldCount must less than or equal to the number of indexed fields - IndexFieldCount. If specified, then AnyDAC will use first KeyFieldCount indexed fields for searching, instead of IndexFieldCount fields. Setting of KeyFieldCount is possible only in dsSetKeyMode.

The property has the meaning only for non-expressional indexes.

Syntax
property KeyFieldCount: Integer;
See Also

FindKey, FindNearest, GotoKey, GotoNearest

Example 1
ADQuery1.IndexFieldNames := 'EmployeeID;CustomerID;SellDate';
ADQuery1.SetKey;
ADQuery1.KeyFieldCount := 2;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.FieldByName('CustomerID').AsInteger := 200;
ADQuery1.GotoKey;
Example 2
ADQuery1.IndexFieldNames := 'EmployeeID;CustomerID;SellDate';
ADQuery1.SetRangeStart;
ADQuery1.KeyFieldCount := 1;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.SetRangeEnd;
ADQuery1.KeyFieldCount := 1;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.ApplyRange;


TADDataSet.MasterFields Property

TADDataSet.MasterFields Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Gets / sets fields in master dataset, used to establish a master-detail relationship with this dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use MasterFields property value to specify semicolon separated list of master dataset field names, used to establish a master-detail relationship with this dataset.

Specify MasterFields property value after assigning MasterSource property value. Additionally application must have current active index. Then when master dataset current data is changed, then to this dataset will be applied ranges, where starting and ending range values are the same. And are equal to corresponding MasterFields field values.

Todo
  1. Give example.
  2. How it is used in MemTable and in Query.
Syntax
property MasterFields: String;
See Also

MasterSource, IndexFieldNames, IndexName

Example
ADMemTable1.IndexFieldNames := 'CustomerID';
ADMemTable1.MasterSource := CustomersDS;
ADMemTable1.MasterFields := 'ID';


TADDataSet.MasterSource Property

TADDataSet.MasterSource Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Gets / sets a master data source, used to establish a master-detail relationship with this dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use MasterSource to specify the data source linked to a dataset, which will be used as master dataset in master-detail relationship between this and specified datasets.

Additionally application must specify MasterFields property value. And must have current active index. Then when master dataset current data is changed, then to this dataset will be applied ranges, where starting and ending range values are the same. And are equal to corresponding MasterFields field values.

Syntax
property MasterSource: TDataSource;
See Also

MasterFields, IndexFieldNames, IndexName

Example
ADMemTable1.IndexFieldNames := 'CustomerID';
ADMemTable1.MasterSource := CustomersDS;
ADMemTable1.MasterFields := 'ID';


TADDataSet.OnReconcileError Event

TADDataSet.OnReconcileError Event
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Fires when a dataset needs to reconcile an update to a record that cannot not be applied.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use the OnReconcileError event handler to respond to error conditions that arise when the ApplyUpdates method was applying changes to the records to the database.

The DataSet will loop through all records in the change log and check if they have associated exception object. Only records for which errors were not handled in an OnUpdateError event handler may have associated exception object. If a record has an exception object, then dataset positions on this record and calls OnReconcileError event handler. The event handler will get E - reference to the exception object, UpdateKind - the kind of update for current recod. After handling error the event handler should set Action argument.

Syntax
property OnReconcileError: TADReconcileErrorEvent;
See Also

Reconcile, ApplyUpdates, OnUpdateError

Example
procedure TForm1.ADMemTable1ReconcileError(DataSet: TADDataSet; E: EADException;
  UpdateKind: TADDatSRowState; var Action: TADDAptReconcileAction);
begin
  if (UpdateKind = rsInserted) and (E is EADDBEngineException) and (EADDBEngineException(E).Kind = ekUKViolated) then begin
    DataSet.FieldByName('ID').AsInteger := GetNextFreeID;
    Action := raCorrect;
  end;
end;


TADDataSet.OnUpdateError Event

TADDataSet.OnUpdateError Event
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Fires if an exception is generated when updates are applied to a database.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use an OnUpdateError event handler to respond to exceptions raised while applying immediate or cached updates to a database.

ASender is the dataset to which updates are applied.

AException is a pointer to a EADException object from which an application can extract an error message and the actual cause of the error condition. The OnUpdateError handler can use this information to determine how to respond to the error condition. In most cases AException object will be of class EADDBEngineException or even one of it DBMS specific subclasses.

ARow is a DatS row object, repesenting erroneous record in dataset. This record is also current record in ASender.

ARequest indicates whether the error occurred while inserting, deleting, or modifying a record.

AAction indicates the action to take when the OnUpdateError handler exits. On entry into the handler, AAction is always set to eaDefault, which leads to uaFail, if not changed. If OnUpdateError can handle or correct the error, set AAction to uaRetry before exiting the error handler. Or consider other options.

The error handler can use the OldValue and NewValue properties TField to evaluate error conditions and set NewValue to a new value to reapply. In this case, set UpdateAction to uaRetry before exiting.

The code in an OnUpdateError handler must not call any methods that make a different record the current one !

Syntax
property OnUpdateError: TADUpdateErrorEvent;
See Also

ApplyUpdates, CachedUpdates, Post, Delete, EADDBEngineException, OnUpdateRecord

Example
procedure TForm1.ADQuery1UpdateError(ASender: TDataSet; AException: EADException;
    ARow: TADDatSRow; ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction);
begin
  if (E is EADDBEngineException) and (EADDBEngineException(E).Kind = ekUKViolated) then begin
    DataSet.FieldByName('ID').AsInteger := GetNextFreeID;
    Action := eaRetry;
  end;
end;


TADDataSet.OnUpdateRecord Event

TADDataSet.OnUpdateRecord Event
TADDataSet Class uADCompDataSet Unit Example 1 Example 2 public See Also Send Feedback

Occurs when record update is applying to a database.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example 1, Example 2, public, See Also
Description

Use an OnUpdateRecord event handler to process immediate or cached updates that cannot be correctly or easialy handled:

  • using AnyDAC automatic SQL update command generation;
  • by a single table adapter component;
  • by a single update component.

This event is useful for applications that require:

  • additional control over parameters and macros substitution in update components;
  • multy SQL statement updates, when DBMS does not support batches or blocks;
  • non-SQL updates posting;
  • etc

ASender is the dataset to which updates are applied.

ARequest indicates whether the current update is the insertion, deletion or modification of a record.

AAction indicates the action taken by the OnUpdateRecord handler before it exits. On entry into the handler, UpdateAction is always set to eaDefault. If OnUpdateRecord is successful, it should set UpdateAction to eaApplied before exiting.

The code in an OnUpdateRecord handler must not call any methods that make a different record the current one !

Syntax
property OnUpdateRecord: TADUpdateRecordEvent;
See Also

ApplyUpdates, CachedUpdates, Post, Delete, OnUpdateError

Example 1
procedure TForm1.ADQuery1UpdateRecord(ASender: TDataSet; ARequest: TADPhysUpdateRequest;
 var AAction: TADErrorAction; AOptions: TADPhysUpdateRowOptions);
begin
  if ARequest = arInsert then begin
    // set the SQL command to insert new record
    ADQuery2.SQL := 'insert into mytab (id, code, name) values (:id, :code, :name) returning tmstamp into :ts';

    // set parameter values
    ADQuery2.Params[0].Value := ASender['id'];
    ADQuery2.Params[1].Value := ASender['code'];
    ADQuery2.Params[2].Value := ASender['name'];

    // specially define TS parameter
    ADQuery2.Params[3].DataType := ftDateTime;
    ADQuery2.Params[3].ParamType := ptOutput;

    // insert new record
    ADQuery2.ExecSQL;

    // move TS output parameter value back to dataset
    ASender['tmstamp'] := ADQuery2.Params[3].Value;

    // return 'Ok' status
    AAction := eaApplied;
  end;
end;
Example 2

See demos:

  • "AnyDAC\Samples\Comp Layer\TADQuery\CachedUpdates\OnUpdateRecord"
  • "AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main"


TADDataSet.ParentDataSet Property

TADDataSet.ParentDataSet Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns the reference to parent dataset, if this one is nested.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The ParentDataSet property returns reference to parent dataset, if this dataset is nested.

Syntax
property ParentDataSet: TADDataSet;
See Also

DB.TDataSetField

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Ranged Property

TADDataSet.Ranged Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Specifies whether the dataset records are limited by a range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The Ranged property returns True, if dataset has range applied using ApplyRange call or setting Ranged to True. When a range is in effect, only those records that fall within the range are available to the application for viewing and editing.

Setting property Ranged to True performs ApplyRange, to False - CancelRange.

Syntax
property Ranged: Boolean;
See Also

ApplyRange, CancelRange

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.SavePoint Property

TADDataSet.SavePoint Property
TADDataSet Class uADCompDataSet Unit Example 1 Example 2 public See Also Send Feedback

Gets / sets the change log version number.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example 1, Example 2, public, See Also
Description

Use SavePoint to get the change log current version number. And later revert change log to the specified version number.

SavePoint may be used only in CachedUpdates mode. SavePoint's may be usefull for applications that use:

  • undo functionality. Although there is no standard ability to implement redo.
  • in-memory transactions.

Datasets can't return to a SavePoint once the change log has been backed out to a prior state. This includes:

  • undoing changes by setting SavePoint to a previously saved value;
  • backing out too many changes using the RevertRecord method;
  • clearing the change log using CancelUpdates or CommitUpdates.

Trying to set SavePoint to a state that is no longer available in the change log raises an exception.

Syntax
property SavePoint: Integer;
See Also

CachedUpdates, ChangeCount, UndoLastChange, RevertRecord, CancelUpdates

Example 1
var
  iSavePoint: Integer;
....
  // remember changes log state
  iSavePoint := ADMemTable1.SavePoint;
  try
    ADMemTable1.AppendRecord(....);
    ADMemTable1.AppendRecord(....);
    ADMemTable1.AppendRecord(....);
    ...
    ADMemTable1.Delete;
    // mark changes as persistent and clear change log
    ADMemTable1.CommitUpdates;
  except
    // in case of exception, undo changes
    ADMemTable1.SavePoint := iSavePoint;
    raise;
  end;
Example 2

See demo "AnyDAC\Samples\Comp Layer\TADMemTable\CachedUpdates".


TADDataSet.SourceEOF Property

TADDataSet.SourceEOF Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Specifies if no more records to fetch from current cursor.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The SourceEOF property returns True, if there is no more records to fetch from current cursor.

Syntax
property SourceEOF: Boolean;
See Also

Next, FetchAll

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.SourceView Property

TADDataSet.SourceView Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

The reference to DatS view object, by which rows the dataset is navigating.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

The SourceView property returns reference to TADDatSView object. The dataset is navigating on this view rows. The view is build by AnyDAC automatically as result of applying of filters, indexes and ranges. The view will be destroyed after dataset closing.

Syntax
property SourceView: TADDatSView;
See Also

Table, View, uADDatSManager.TADDatSView

Example
var
  i, iVal, iMax: Integer;
....
// searching the maximum value of ID integer field, without navigating through dataset
iMax := 0;
for i := 0 to ADQuery1.SourceView.Rows.Count - 1 do
  if ADQuery1.SourceView.Rows[i].GetData('id', @iVal) and (iVal > iMax) then
    iMax := iVal;


TADDataSet.Table Property

TADDataSet.Table Property
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

The reference to DatS table object, actually representing the internal data storage.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

The Table property returns reference to TADDatSTable object. It is the internal data storage containing all dataset rows.

AnyDAC creates table for each dataset automatically at Open. TADCustomMemTable allows to attach to existing table before Open call, using AttachTable method. If table was automatically created, then it will be destroyed after dataset closing.

As result of applying of filters, indexes and ranges, AnyDAC builds views for this table object. All dataset navigation methods does not work with table, but with SourceView view object.

Syntax
property Table: TADDatSTable;
See Also

View, SourceView, AttachTable, TADCustomMemTable

Example
var
  i: Integer;
....
// delete all rows, where ID = 100, without navigating through dataset
for i := ADQuery1.Table.Rows.Count - 1 downto 0 do
  if ADQuery1.Table.Rows[i].GetData('id') = 100 then
    ADQuery1.Table.Rows[i].Delete;
ADQuery1.Resync([]);


TADDataSet.UpdatesPending Property

TADDataSet.UpdatesPending Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Indicates whether the changes log is not empty.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Examine UpdatesPending to check the status of the changes log. If UpdatesPending is true, then there are edited, deleted, or inserted records to apply to the database. If UpdatesPending is false, there are no records in the changes log.

Syntax
property UpdatesPending: Boolean;
See Also

CachedUpdates, ChangeCount, ApplyUpdates, CommitUpdates, CancelUpdates


TADDataSet.View Property

TADDataSet.View Property
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

The reference to base DatS view object.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The View property returns reference to TADDatSView object. It is the base view object, specified as second argument to AttachTable method call. As result of applying of filters, indexes and ranges, AnyDAC builds views above of this view object.

Syntax
property View: TADDatSView;
See Also

Table, SourceView, AttachTable, TADCustomMemTable


TADDataSet.AddIndex Method

TADDataSet.AddIndex Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Creates a new client index for the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
const AName: string | A name of the new index.
const AFields: string | A semicolon-delimited list of the fields to include in the index.
const AExpression: string | A sorting expression.
AOptions: TADSortOptions | A set of additional options for index.
const ADescFields: string = '' | A semicolon-delimited list of field names. Use ADescFields instead of an AOptions value that includes soDescending to create an index that is in ascending order on some fields and descending order on others. All fields named in ADescFields are sorted in descending order.
const ACaseInsFields: string = '' | A semicolon-delimited list of field names. Use ACaseInsFields instead of an AOptions value that includes soNoCase to create an index that is case-insensitive on some fields and case-sensitive on others. All fields named in ACaseInsFields are sorted without regard to case.
Description

Call AddIndex to create a new index for the client dataset.

The method corresponds to manual adding of new index to Indexes property and setting properties of new index. If index with AName name already exists, then exception will be raised. AField and AExpression properties are mutually exclusive. The new index will be active, but not current.

Syntax
procedure AddIndex(const AName: string; const AFields: string; const AExpression: string; AOptions: TADSortOptions; const ADescFields: string = ''; const ACaseInsFields: string = '');
See Also

Indexes

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.ApplyRange Method

TADDataSet.ApplyRange Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Applies a range to the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use ApplyRange to actually filter dataset records using range values specified with SetRangeStart and SetRangeEnd, or EditRangeStart and EditRangeEnd method calls.

When a range is in effect, only those records that fall within the range are available to the application for navigating, viewing and editing. After a call to ApplyRange, the cursor is left on the first record in the range.

Syntax
procedure ApplyRange;
See Also

CancelRange, EditRangeEnd, EditRangeStart, SetRange, SetRangeEnd, SetRangeStart, Ranged

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := '100';
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := '200';
ADQuery1.ApplyRange;


TADDataSet.ApplyUpdates Method

TADDataSet.ApplyUpdates Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Applies changes for all records in change log to the database.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
AMaxErrors: Integer = -1 | A maximum number of allowed errors. Default value is -1.
Returns

The number of errors is encountered.

Description

Use ApplyUpdates to apply changes for all records in change log to the database.

This method is usefull on CachedUpdates = True mode. ApplyUpdates call performs steps:

  1. Fires a BeforeApplyUpdates event.
  2. Calls the data adapter to generate / use SQL update commands for each row.
  3. Fires an AfterApplyUpdates event.
  4. Calls the dataset's Reconcile method to reconcile any records that has errors in step 2.
  5. If no errors, then call CommitUpdates for TADCustomMemTable descendants.

AMaxErrors indicates the maximum number of errors that the AnyDAC should allow before prematurely stopping the update operation. Set AMaxErrors to –1 to indicate that there is no limit to the number of errors.

ApplyUpdates returns the number of errors it encountered. Based on this return value and the setting of AMaxErrors, successfully applied records are removed from the dataset's change log. If the update process is aborted before all updates are applied, any unapplied updates remain in the change log.

Syntax
function ApplyUpdates(AMaxErrors: Integer = -1): Integer;
See Also

CachedUpdated, Reconcile, CommitUpdates, CancelUpdates, UpdatesPending

Example
procedure TForm1.btnApplyClick(ASender: TObject);
begin
  if ADStoredProc1.UpdatesPending then
    ADStoredProc1.ApplyUpdates;
end;


TADDataSet.AttachTable Method

TADDataSet.AttachTable Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Attaches dataset to existing DatS table and optionaly view.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
ATable: TADDatSTable | A DatS table, storing data.
AView: TADDatSView | A DatS view, representing rows.
Description

Use the AttachTable method to attach dataset to existing DatS table and optionally view to navigate, visualize and edit theyr data using standard TDataSet interface. Call dataset Open method to activate dataset after attaching to DatS objects. Before call theyr structure must be filled in. To detach specified DatS objects from dataset, call AtachTable with nils.

The application is responsible for creation and destruction of specified table and view.

This method has meaning for TADCustomMemTable descendants only. And it is used internally only for other AnyDAC datasets.

Syntax
procedure AttachTable(ATable: TADDatSTable; AView: TADDatSView);
See Also

Table, View, SourceView

Example
var
  oTab: TADDatSTable;
...
  oTab := TADDatSTable.Create;
  oTab.Columns.Add('id', dtInt32);
  oTab.Columns.Add('name').Size := 13;
  oTab.Columns.Add('cnt', dtInt16);
  oTab.Columns.Add('price', dtCurrency);
  ADMemTable1.Attach(oTab, nil);
  ADMemTable1.Open;
  // working with ADMemTable1
  ADMemTable1.AttachTable(nil, nil);
  oTab.Free;


TADDataSet.BeginBatch Method

TADDataSet.BeginBatch Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Optimizes dataset functionality for batch updates.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
AWithDelete: Boolean = False | True if after call application will also delete records.
Description

Use BeginBatch method to disable resources consuming operations and setup dataset to perform maximum fast updates. The BeginBatch call disables:

  • dataware controls updatings;
  • constraints updating;
  • aggregates maintaining;
  • wait cursor showing;
  • similar resources consuming processing in DatS objects, which is not controlled through dataset API;

If batch algorythm calls Delete method, then set AWithDelete to True. BeginBatch calls cannot be nested, although AnyDAC will not raise exception on consequent calls. After finishing updates call EndBatch.

Syntax
procedure BeginBatch(AWithDelete: Boolean = False);
See Also

EndBatch

Example
ADQuery1.BeginBatch;
try
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ......
finally
  ADQuery1.EndBatch;
end;


TADDataSet.BookmarkStrValid Method

TADDataSet.BookmarkStrValid Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function BookmarkStrValid(ABookmarkStr: TBookmarkStr): Boolean;


TADDataSet.BookmarkValid Method

TADDataSet.BookmarkValid Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function BookmarkValid(ABookmark: TBookmark): Boolean; override;


TADDataSet.Cancel Method

TADDataSet.Cancel Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure Cancel; override;


TADDataSet.CancelRange Method

TADDataSet.CancelRange Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Cancels range for the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use CancelRange to remove a range currently applied to a dataset.

Canceling a range reenables access to all records in the dataset, excluding ones, that may be:

  • filtered out by Filtered / OnFilterRecord / FilterChanges;
  • filtered out by Indexes with Filter expression specified.
Syntax
procedure CancelRange;
See Also

ApplyRange, EditRangeEnd, EditRangeStart, SetRange, SetRangeEnd, SetRangeStart, Ranged


TADDataSet.CancelUpdates Method

TADDataSet.CancelUpdates Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Removes all records from the change log and restores the dataset rows to its prior editing state.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use CancelUpdates to remove all records from the change log, while the dataset is in CachedUpdates=True mode, and restore the dataset records to the state they was in when the dataset was opened, cached updates were last enabled, or updates were last successfully applied to the database.

When a dataset is closed, or the CachedUpdates property is set to false, CancelUpdates is called automatically.

Note, to undo changes to a single record, call RevertRecord.

Syntax
procedure CancelUpdates;
See Also

ApplyUpdates, CachedUpdates, CommitUpdates, UndoLastChange, SavePoint


TADDataSet.CloneCursor Method

TADDataSet.CloneCursor Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Shares the data belonging to another dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
ASource: TADDataSet | A source dataset to clone.
AReset: Boolean | A flag to reset properties for this dataset.
AKeepSettings: Boolean = False | A flag to keep current setting for this dataset.
Description

Use CloneCursor to share the data belonging to another dataset with this dataset. After calling CloneCursor, the internal data storage is physically the same and single for this dataset and for ASource dataset.

ASource references to dataset whose data will be shared with this one.

AReset and AKeepSettings determine how to set the values of the following properties and events:

  • Filter, Filtered, FilterOptions, OnFilterRecord and FilterChanges;
  • IndexName, IndexFieldNames;
  • MasterSource and MasterFields;
  • ReadOnly.

If AReset and AKeepSettings are both False, the values of the properties listed above are all set to match the source dataset.

If AReset is True, the properties listed above are all set to the default values.

If AReset is False and AKeepSettings is True, the properties listed above are not changed. In this case, the application must ensure that existing indexes, filters, and so on are compatible with the cloned data.

Syntax
procedure CloneCursor(ASource: TADDataSet; AReset: Boolean; AKeepSettings: Boolean = False); virtual;
See Also

Data

Example
ADMemTable1.CloneCursor(ADQuery1, True, False);
ADMemTable1.Locate(...);
ADMemTable1.Edit;
...


TADDataSet.CommitUpdates Method

TADDataSet.CommitUpdates Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Clears the changes log and marks all records as not modified.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Call CommitUpdates to clear the dataset changes log, working in CachedUpdates=True mode, after both a successful call to ApplyUpdates and a database component's Commit method. And marks all dataset record as unchanged.

Applications that use a connection component's ApplyUpdates method to apply and commit pending updates for all datasets associated with the database component do not need to call CommitUpdates.

Syntax
procedure CommitUpdates;
See Also

CachedUpdates, UpdatesPending, OnUpdateError, OnUpdateRecord, ApplyUpdates, CancelUpdates


TADDataSet.CompareBookmarks Method

TADDataSet.CompareBookmarks Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function CompareBookmarks(Bookmark1: TBookmark; Bookmark2: TBookmark): Integer; override;


TADDataSet.CopyDataSet Method

TADDataSet.CopyDataSet Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Copies records from source dataset to this dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
ASource: TDataset | A source dataset.
AOptions: TADCopyDataSetOptions = [] | A copy options.
Description

Use CopyDataSet method to copy records from ASource dataset to this dataset. The method appends record and copies all fields, which names exists in both datasets, then post record change. It is important that fields with the same name in both datasets must be compatible by data types. If ASource field is not found in this dataset, then it will be skipped.

This method is similar to assigning to Data property. The differences are:

  • CopyDataSet can copy from non-AnyDAC dataset. Data copies data only from AnyDAC dataset.
  • CopyDataSet works through TDataSet API, firing appropriate events. Data works through DatS API.
  • CopyDataSet copies only current field values. Data copies all record versions.
  • Assigning to Data is much faster, than CopyDataSet.
Syntax
procedure CopyDataSet(ASource: TDataset; AOptions: TADCopyDataSetOptions = []);
See Also

CopyDataSet, Data, TADDataMove

Example
// copies dataset structure and all records
ADMemTable1.CopyDataSet(Query1, [coRestart, coStructure]);


TADDataSet.CopyFields Method

TADDataSet.CopyFields Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Copies all fields from source dataset to this dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
ASource: TDataset | A source dataset.
AOptions: TADCopyDataSetOptions = [] | A copy options.
Description

Use CopyFields method to copy current record field values from ASource dataset to this dataset. The method copies all fields, which names exists in both datasets. It is important that fields with the same name in both datasets must be compatible by data types. If ASource field is not found in this dataset, then it will be skipped.

Syntax
procedure CopyFields(ASource: TDataset; AOptions: TADCopyDataSetOptions = []);
See Also

CopyDataSet, Data, TADDataMove

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Create Constructor

TADDataSet.Create Constructor
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


TADDataSet.CreateBlobStream Method

TADDataSet.CreateBlobStream Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function CreateBlobStream(Field: TField; Mode: TBlobStreamMode): TStream; override;


TADDataSet.CreateDataSet Method

TADDataSet.CreateDataSet Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Creates new empty internal data storage for dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use CreateDataSet at runtime to create a empty internal data storage for dataset and activate dataset.

After call application may populate dataset by data and optionally save data to the external file.

If the FieldDefs property contains items, then these values are used to create field definitions. Otherwise the Fields property is used. One or both of these properties must contain values in order to create a dataset. If neither property is set, CreateDataSet raises an exception.

The method is not applicapable for all AnyDAC datasets, but for TADCustomMemTable.

Syntax
procedure CreateDataSet;
See Also

TDataSet.FieldDefs, TDataSet.Fields, TADCustomMemTable

Example
with ADMemTable1 do begin
  FieldDefs.Add('ID', ftAutoInc);
  FieldDefs.Add('Code', ftString, 10);
  FieldDefs.Add('Name', ftString, 50);
  CreateDataSet;
  // here dataset is active, has 3 fields and is empty
end;


TADDataSet.CreateExpression Method

TADDataSet.CreateExpression Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Creates expression evaluator for dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AExpr: String | A expression to evaluate.
AOptions: TADExpressionOptions = [] | An evaluator options.
Returns

The evaluator interface reference.

Description

Use CreateExpression method to translate string, containing expression, into binary representation and create expression evaluator. The expression may contain field names from this dataset. To create evaluator, dataset must be active.

The method returns evaluator, which may be used few times to effectively evaluate specified expression, by calling its Evaluate method. The evaluator is associated with current record. After position is changed, application must adjust evaluator:

  oEval.DataSource.Position := ADMemTable1.GetRow;

The evaluator is reference counted interface. You does not need to free it explicitly. All references to evaluator must be released before dataset will be closed.

The expressions cannot contain aggregating functions, like a SUM, COUNT. AnyDAC supports expression syntax compatible with:

  • BDE data access components;
  • TClientDataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write expressions.

Syntax
function CreateExpression(const AExpr: String; AOptions: TADExpressionOptions = []): IADStanExpressionEvaluator;
See Also

GetRow, Aggregates, Constraints, Indexes

Example
var
  oEval: IADStanExpressionEvaluator;
...
oEval := ADMemTable1.CreateExpresison('(sal + comm) * tax / 100');
Label1.Caption := oEval.Evaluate;
...
ADMemTable1.Next;
oEval.DataSource.Position := ADMemTable1.GetRow;
Label1.Caption := oEval.Evaluate;
...
oEval := nil;
ADMemTable1.Close;


TADDataSet.DeleteIndex Method

TADDataSet.DeleteIndex Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Deletes an client index for the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
const AName: string | An index name.
Description

Call DeleteIndex to remove an client index for a dataset from Indexes property.

AName is the name of the index to delete. If index is not found in Indexes, then exception will be riased.

Syntax
procedure DeleteIndex(const AName: string);
See Also

Indexes, AddIndex, DeleteIndexes

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.DeleteIndexes Method

TADDataSet.DeleteIndexes Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Deletes all client indexes for the dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Call DeleteIndexes to remove all client indexes for a dataset from Indexes property.

Syntax
procedure DeleteIndexes;
See Also

Indexes, AddIndex, DeleteIndex

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Destroy Destructor

TADDataSet.Destroy Destructor
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
destructor Destroy; override;


TADDataSet.DisableConstraints Method

TADDataSet.DisableConstraints Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Disables the enforcement of client constraints.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use DisableConstraints to turn off enforcement of client constraints that are in Constraints property (record constraints) or are assigned to the dataset fields (field constraints).

Calling DisableConstraints increments an internal counter. As long as this reference count is greater than zero, constraints are disabled for the dataset. To prevent accidental disabling of constraints, always group a call to DisableConstraints with a call to EnableConstraints.

If application needs to perform batch updates to dataset, then consider to use BeginBatch / EndBatch methods.

Syntax
procedure DisableConstraints;
See Also

EnableConstraints, Constraints, ConstraintsEnabled

Example
ADQuery1.DisableConstraints;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.EnableConstraints;
end;


TADDataSet.Disconnect Method

TADDataSet.Disconnect Method
TADDataSet Class uADCompDataSet Unit Example public Send Feedback

Use Disconnect method to release DBMS resources, used by this dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public
Parameters
Parameters | Description
AAbortJob: Boolean = False | If True, then method will abort current operation.
Description

The Disconnect method optionally abort current operation and releases DBMS resources, used by this dataset. After the call dataset is in dsInactive state. And descendants will have Prepared = False.

Syntax
procedure Disconnect(AAbortJob: Boolean = False); virtual;
Example
ADQuery1.SQL.Text := 'select * from [Order Details]';
ADQuery1.Prepare := True;
ADQuery1.Active := True;
ADQuery1.Disconnect;
// Active = False and Prepare = False
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.EditKey Method

TADDataSet.EditKey Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Enables modification of the search key buffer.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use EditKey to put the dataset into dsSetKey state, preserving the current contents of the search key buffer.

After call the application can modify indexed fields. To iterate through them use IndexFieldCount and IndexFields properties. Optionally may be edited value of KeyFieldCount and/or KeyExclusive properties.

Syntax
procedure EditKey;
See Also

TDataSet.IndexFields, FindKey, GotoKey, GotoNearest, SetKey, TDataSet.State, KeyFieldCount, KeyExclusive

Example
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
...
ADQuery1.EditKey;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 2);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


TADDataSet.EditRangeEnd Method

TADDataSet.EditRangeEnd Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Enables changing the ending value for an existing range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Call EditRangeEnd to bring the dataset to the dsSetKey state and change the ending value for an existing range.

After call the application can modify indexed fields. To iterate through them use IndexFieldCount and IndexFields properties. Optionally may be edited value of KeyFieldCount and/or KeyExclusive properties.

After assigning a new ending value, call ApplyRange to activate the modified range.

Syntax
procedure EditRangeEnd;
See Also

ApplyRange, CancelRange, EditRangeStart, IndexFieldNames, IndexName, KeyExclusive, SetRange, SetRangeEnd, SetRangeStart

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := 100;
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := 200;
ADQuery1.ApplyRange;
......
ADQuery1.EditRangeEnd;
ADQuery1['CUST_NO'] := ADQuery1['CUST_NO'] - 1;
ADQuery1.ApplyRange;


TADDataSet.EditRangeStart Method

TADDataSet.EditRangeStart Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Enables changing the starting value for an existing range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Call EditRangeStart to bring dataset to the dsSetKey state and change the starting value for an existing range.

After call the application can modify indexed fields. To iterate through them use IndexFieldCount and IndexFields properties. Optionally may be edited value of KeyFieldCount and/or KeyExclusive properties.

After assigning a new ending value, call ApplyRange to activate the modified range.

Syntax
procedure EditRangeStart;
See Also

ApplyRange, CancelRange, EditRangeEnd, IndexFieldNames, IndexName, KeyExclusive, SetRange, SetRangeEnd, SetRangeStart

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := 100;
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := 200;
ADQuery1.ApplyRange;
......
ADQuery1.EditRangeStart;
ADQuery1['CUST_NO'] := ADQuery1['CUST_NO'] + 1;
ADQuery1.ApplyRange;


TADDataSet.EmptyDataSet Method

TADDataSet.EmptyDataSet Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Removes all records from the dataset internal data storage.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Call EmptyDataSet to empty the dataset by removing all records from internal data storage and changes log.

Syntax
procedure EmptyDataSet;
See Also

Table, TDataSet.Delete

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.EnableConstraints Method

TADDataSet.EnableConstraints Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Reenables enforcement of client constraints when records are posted.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Call EnableConstraints to turn on client constraints previously disabled by a call to DisableConstraints.

Calling EnableConstraints decrements a reference count. When this reference count is zero constraints are enabled for the dataset. To prevent accidental disabling of constraints, always follow a call to DisableConstraints with a matching call to EnableConstraints.

Syntax
procedure EnableConstraints;
See Also

DisableConstraints, Constraints, ConstraintsEnabled

Example
ADQuery1.DisableConstraints;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.EnableConstraints;
end;


TADDataSet.EndBatch Method

TADDataSet.EndBatch Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Restores normal dataset functionality after batch updates.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use EndBatch method to reenable dataset processing as it was before BeginBatch call.

Syntax
procedure EndBatch;
See Also

BeginBatch

Example
ADQuery1.BeginBatch;
try
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ......
finally
  ADQuery1.EndBatch;
end;


TADDataSet.Execute Method

TADDataSet.Execute Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Executes an SQL command.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
ATimes: Integer = 0 | A parameters array size.
AOffset: Integer = 0 | A offset in parameters array.
Description

Call Execute to execute a SQL statement currently assigned to descendant class properties:

  • TADCustomQuery.SQL;
  • TADCustomStoredProc.StoredProcName;
  • TADCustomMemTable.Adapter.SelectCommand.CommandText. Or command assigned to TADCustomCommand.CommandText of command object. Which is assigned to TADCustomTableAdapter.SelectCommand. And adapter object is assigned to TADAdaptedDataSet.Adapter.

Use Execute to execute queries that do not return a cursor to data (such as INSERT, UPDATE, DELETE, CREATE TABLE, CALL, BEGIN .. END, etc). For SELECT statements and others, returning cursors, call Open instead of Execute.

Execute prepares the SQL statement for execution, if it has not already been prepared. To speed performance, an application should ordinarily call Prepare method before calling Execute for the first time.

Use ResourceOptions.CmdExecMode to control asynchronous execution mode. And ResourceOptions.CmdExecTimeout to set maximum command execution time. After that time command execution will be canceled and exception raised.

To cancel command execution use AbortJob.

Before command execution the BeforeExecute event is fired. If server will return command execution error, then AnyDAC raises an exception. It may be analyzed in OnError event. After command execution is finished, any output parameters are put into Params property and AfterExecute event is fired.

If ATimes is equal to zero or one, then command is executing in standard mode, otherwise in Array DML mode. See Array DML article for details. By default ATimes and AOffset are equal to 0. ATimes specifies parameters array size. AOffset specifies from which row index in parameters array Array DML command execution should be started. ATimes must be less or equal to TADParams.ArraySize, otherwise exeception will be raised.

After command execution application may check RowsAffected property value to see how much database records were affected by last command execution.

Syntax
procedure Execute(ATimes: Integer = 0; AOffset: Integer = 0);
See Also

TADCustomQuery.SQL, TADCustomQuery.ExecSQL, TADCustomStoredProc.StoredProcName, TADCustomStoredProc.ExecProc, TADAdaptedDataSet.AbortJob, TADCustomMemTable.Adapter, TADRdbmsDataSet.Prepare, TADRdbmsDataSet.OnError, BeforeExecute, AfterExecute

Example
var
  i: Integer;
....
ADQuery1.SQL.Text := 'insert into mytab values (:p1, :p2)';
ADQuery1.Params.ArraySize := 10;
for i := 0 to ADQuery1.Params.ArraySize - 1 do begin
  ADQuery1.Params[0].AsIntegers[i] := i;
  ADQuery1.Params[1].AsStrings[i] := 'qwe';
end;
ADQuery1.Execute(ADQuery1.Params.ArraySize, 0);


TADDataSet.FetchAgain Method

TADDataSet.FetchAgain Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Allows to fetch additional records.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Call FetchAgain method to reset "all-data-fetched" flag - SourceEOF. This is usefull for TADCustomMemTable linked to table adapter and allows to fetch few result sets with the same structure into single dataset. After calling FetchAgain TADCustomTableAdapter.SelectCommand must be reexecuted with different parameter values.

The similar thing may be performed for TADCustomQuery or TADCustomStoredProc, for example. Just must be reexecuted internal command object TADAdaptedDataSet.Command.

Syntax
procedure FetchAgain;
See Also

FetchAll, TDataSet.Open, TADCustomCommand, TADCustomTableAdapter

Example
// set SQL command
ADCommand1.CommandText := 'select * from orders where customerid = :cid';
// link command to table adapter
ADTableAdapter1.SelectCommand := ADCommand1;
// link table adapter to memtable
ADMemTable1.Adapter := ADTableAdapter1;

// set SQL command parameter value, then execute command and fetch all records
ADCommand1.Params[0].AsInteger := 100;
ADMemTable1.Open;
ADMemTable1.FetchAll;

// reset SourceEOF flag, reexecute command by hands and fetch all records
ADMemTable1.FetchAgain;
ADCommand1.Close;
ADCommand1.Params[0].AsInteger := 200;
ADCommand1.Open;
ADMemTable1.FetchAll;

// here we will have in memtable orders for customers with ID=100 and ID=200


TADDataSet.FetchAll Method

TADDataSet.FetchAll Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Retrieves all records from the current resultset and stores them into internal DatS table.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Call FetchAll to retrieve all not yet fetched records from current resultset. Calling FetchAll allows:

  • to release server resources faster, because FetchAll implicitly closes DBMS cursor. That does not deactivate dataset.
  • to release Call Level Interface resultset buffer, allowing to execute next command and get resultset. That is applicapable for some DBMS's, like a MSSQL and MySQL.

If to set FetchOptions.Mode to fmAll, then dataset automatically calls FetchAll on Open call.

Syntax
procedure FetchAll;
See Also

TADFetchOptions.Mode, TDataSet.Open

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.FetchBlobs Method

TADDataSet.FetchBlobs Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Retrieves BLOB field values from database for current record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Call FetchBlobs to retrieve BLOB field values from a database for current dataset record, when these values are not provided automatically. BLOB field values are automatically fetched together with other record fields, if fiBlobs is included into FetchOptions.Items, otherwise - not.

Syntax
procedure FetchBlobs;
See Also

TADFetchOptions.Items

Example
ADQuery1.FetchOptions.Items := ADQuery1.FetchOptions.Items - [fiBlobs];
ADQuery1.Open;
....
ADQuery1.FetchBlobs;
oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('image'), bmRead);
try
  // process image
finally
  oStr.Free;
end;


TADDataSet.FetchDetails Method

TADDataSet.FetchDetails Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Retrieves nested datasets from database for current record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
ADataSetField: TDataSetField = nil | A field, whos nested dataset to fetch.
Description

Call FetchDetails to retrieve nested datasets from a database for current dataset record, when these dataset are not provided automatically. Nested dataset are automatically fetched together with other record fields, if fiDetails is included into FetchOptions.Items, otherwise - not.

If ADataSetField is specified, then AnyDAC fetches nested dataset only for these field. Otherwise - all nested datasets.

Syntax
procedure FetchDetails(ADataSetField: TDataSetField = nil);
See Also

TADFetchOptions.Items

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.FindKey Method

TADDataSet.FindKey Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches for a record containing specified index field values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AKeyValues: array of const | An open array of values to search.
Returns

True, if key is found. Othewise - False.

Description

Use FindKey to search for the record in an indexed dataset, using specified index field values.

AKeyValues is an open array containing field values, called a key. Each value in the key can be a literal, a variable or nil. If the number of values passed in KeyValues is less than the number of columns in the index used for the search, the missing values are assumed to be NULL.

If a search is successful, FindKey positions the cursor on the matching record and returns True. Otherwise the cursor is not moved, and FindKey returns False.

Syntax
function FindKey(const AKeyValues: array of const): Boolean;
See Also

FindNearest, GotoKey, GotoNearest, IndexName, IndexFieldNames, Locate

Example
ADQuery1.IndexFieldNames := 'F1;F2';
if not ADQuery1.FindKey([100, 'qwe']) then
  ShowMessage('100;qwe is not found');


TADDataSet.FindNearest Method

TADDataSet.FindNearest Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches for a record containing specified index field values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AKeyValues: array of const | An open array of values to search.
Description

Use FindKey to search for the record in an indexed dataset, using specified index field values.

AKeyValues is an open array containing field values, called a key. Each value in the key can be a literal, a variable or nil. If the number of values passed in KeyValues is less than the number of columns in the index used for the search, the missing values are assumed to be NULL.

If a search is successful, FindKey positions the cursor on the matching record and returns True. Otherwise, positions the cursor on the record that is greater than specified key.

Syntax
procedure FindNearest(const AKeyValues: array of const);
See Also

FindKey, GotoKey, GotoNearest, IndexName, IndexFieldNames, Locate

Example
ADQuery1.IndexFieldNames := 'F1;F2';
ADQuery1.FindNearest([100, 'qwe']);


TADDataSet.FindParam Method

TADDataSet.FindParam Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Finds the parameter in Params property by a given name.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | A parameter name to find.
Returns

Parameter, if found, Otherwise - nil.

Description

Use FindParam to find a parameter by a AValue name.

If a parameter is not found, FindParam returns nil values.

Syntax
function FindParam(const AValue: string): TADParam;
See Also

Params, ParamByName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GetColumnField Method

TADDataSet.GetColumnField Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns field corresponding to DatS column.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
AColumn: TADDatSColumn | A DatS column.
Returns

A field, if column is found. Otherwise - nil.

Description

Use GetColumnField to get field object, corresponding to specified DatS column. A column must belong to dataset internal DatS table. If column is not found, then method returns nil.

Syntax
function GetColumnField(AColumn: TADDatSColumn): TField;
See Also

GetFieldColumn

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GetCurrentRecord Method

TADDataSet.GetCurrentRecord Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function GetCurrentRecord(Buffer: PChar): Boolean; override;


TADDataSet.GetDetailLinkFields Method

TADDataSet.GetDetailLinkFields Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Lists the field objects that link this dataset as a detail of a master dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
AMasterFields: TList | A list of master fields.
ADetailFields: TList | A list of detail fields.
Description

GetDetailLinkFields fills the two lists with field objects that define a master-detail relationship between this dataset and master dataset. The AMasterFields list is filled with fields from the master dataset, whose values must be equal to the values of the fields in the ADetailFields list. The ADetailFields list is filled with fields from this dataset.

Syntax
procedure GetDetailLinkFields(AMasterFields: TList; ADetailFields: TList); override;
See Also

..


TADDataSet.GetFieldColumn Method

TADDataSet.GetFieldColumn Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns DatS column corresponding to field.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
AField: TField | A field.
Returns

A column, if field is found. Otherwise - nil.

Description

Use GetFieldColumn to get DatS column object, corresponding to specified field. If field is not found, then method returns nil.

Syntax
function GetFieldColumn(AField: TField): TADDatSColumn; overload;
See Also

GetColumnField

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GetFieldData Method (Integer, Pointer)

TADDataSet.GetFieldData Method (Integer, Pointer)
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function GetFieldData(FieldNo: Integer; Buffer: Pointer): Boolean; override; overload;


TADDataSet.GetFieldData Method (TField, Pointer)

TADDataSet.GetFieldData Method (TField, Pointer)
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function GetFieldData(Field: TField; Buffer: Pointer): Boolean; override; overload;


TADDataSet.GetGroupState Method

TADDataSet.GetGroupState Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Indicates where the current record sits within a specified group of records.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
ALevel: Integer | A grouping level.
Returns

The set of position markers.

Description

Call GetGroupState to determine where the current record falls in the group of records specified by the ALevel parameter.

ALevel identifies a group by its grouping level on the current index. Grouping level 1 is the set of records with the same value on the first field in the index. Grouping level 2 is the set of records with the same values on the first two fields in the index, and so on.

GetGroupState returns one of the following values:

Value
Meaning
[gbMiddle]
The current record is neither the first nor the last in the group.
[gbFirst]
The current record is the first in the group, which contains at least two records.
[gbLast]
The current record is the last in the group, which contains at least two records.
[gbFirst,gbLast]
The current record is the only record in the group.
[]

  • ALevel specifies a grouping level greater, than the GroupingLevel property.
  • dataset is in one of the states [dsInactive, dsOpening, dsInsert, dsSetKey]
  • AggregatesActive = False
  • IndexName is empty

Syntax
function GetGroupState(ALevel: Integer): TGroupPosInds;
See Also

GroupingLevel, IndexName, AggregatesActive


TADDataSet.GetIndexNames Method

TADDataSet.GetIndexNames Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Fills the list by client index names.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
AList: TStrings | A list to fill.
Description

Call GetIndexNames to fill AList by client index names.

Syntax
procedure GetIndexNames(AList: TStrings);
See Also

IndexDefs, Indexes

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GetNextPacket Method

TADDataSet.GetNextPacket Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Fetches the next rowset from the DBMS.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Returns

The number of fetched records.

Description

Call GetNextPacket to fetch the next rowset from a DBMS cursor.

To specify the maximum number of records to return in a rowset, set the FetchOptions.RowsetSize property before calling GetNextPacket. A rowset is appended to those records already stored in the internal data storage.

GetNextPacket returns the number of records fetched. If the return value is less than FetchOptions.RowsetSize, the dataset has already received all available records from the DBMS cursor.

Use GetNextPacket for manual fetching mode, when FetchOptions.Mode = fmManual.

Syntax
function GetNextPacket: Integer;
See Also

TDataSet.Open, TADFetchOptions.Mode, TADFetchOptions.RowsetSize

Example
ADQuery1.FetchOptions.Mode := dmManual;
ADQuery1.SQL.Text := 'select * from mytab';
ADQuery1.Open;
// here RecordCount = 0
ADQuery1.GetNextPacket;
// here RecordCount <= FetchOptions.RowsetSize


TADDataSet.GetParentRow Method

TADDataSet.GetParentRow Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns parent row of this nested dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Returns

The DatS row or nil.

Description

Call GetParentRow method to get reference to parent row for this nested dataset.

Syntax
function GetParentRow: TADDatSRow;
See Also

ParentDataSet

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GetRow Method

TADDataSet.GetRow Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Returns DatS row.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
ABuffer: PChar = nil | A dataset record buffer or nil (default).
AForceBufferRead: Boolean = False | Set to False (default).
Returns

A DatS row.

Description

Call GetRow method to get DatS row object for specified dataset record buffer or for current record.

If ABuffer specified, then AnyDAC takes assocciated row object from it. Otherwise it uses TDataSet.ActiveBuffer value, which corresponds to current position in dataset.

Syntax
function GetRow(ABuffer: PChar = nil; AForceBufferRead: Boolean = False): TADDatSRow;
See Also

TADDatSRow, TDataSet.ActiveBuffer

Example
var
  oRow: TADDatSRow;
.....
oRow := ADQuery1.GetRow;
// cancel all changes for this row
oRow.RejectChanges;


TADDataSet.GotoCurrent Method

TADDataSet.GotoCurrent Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Sets the current record in this dataset the same as the current record in another, cloned dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
ADataSet: TADDataSet | A dataset to synchronize with.
Description

Use GotoCurrent to position the cursor on the same record that is current in the specified dataset.

ADataSet is the cloned dataset whose cursor position will be used to position on the record in this dataset. GotoCurrent is only useful for synchronizing two cloned datasets that use separate data sources to view and edit the same data.

Syntax
procedure GotoCurrent(ADataSet: TADDataSet);
See Also

CloneCursor

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.GotoKey Method

TADDataSet.GotoKey Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches for a record, using values in the key buffer.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Returns

True, if key is found. Otherwise - False.

Description

Use GotoKey to search for a record, using values assigned to the indexed fields after previous call of SetKey / EditKey.

Before call dataset must be in dsSetKey state. If GotoKey finds a record, it makes it current record in the dataset and returns True. Otherwise the current position remains unchanged, and GotoKey returns False.

Syntax
function GotoKey: Boolean;
See Also

FindKey, FindNearest, GotoNearest, SetKey, Locate

Example
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


TADDataSet.GotoNearest Method

TADDataSet.GotoNearest Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches for a closest record, using values in the key buffer.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use GotoNearest to search for a record, using values assigned to the indexed fields after previous call of SetKey / EditKey.

Before call dataset must be in dsSetKey state. If GotoNearest finds a record, it makes it current record in the dataset. Otherwise the first record with greater values, than the specified values, becomes current record in the dataset.

Syntax
procedure GotoNearest;
See Also

FindKey, FindNearest, GotoKey, SetKey, Locate

Example
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
ADQuery1.GotoNearest;


TADDataSet.IsIndexed Method

TADDataSet.IsIndexed Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns True, if dataset has current client index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Returns

True, if indexed.

Description

Use IsIndexed to determine, if this dataset has current client index set by IndexFieldName or IndexName properties.

Syntax
function IsIndexed: Boolean;
See Also

IndexFieldNames, IndexName

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.IsLinked Method

TADDataSet.IsLinked Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns True, if dataset is linked to another dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Returns

True, if is linked.

Description

Use IsLinked to determine, if this dataset is nested dataset or detail dataset.

Syntax
function IsLinked: Boolean;
See Also

MasterSource, ParentDataSet

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.IsSequenced Method

TADDataSet.IsSequenced Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function IsSequenced: Boolean; override;


TADDataSet.LoadFromFile Method

TADDataSet.LoadFromFile Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Loads a dataset's data from a file.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AFileName: String = '' | A file name to load.
AFormat: TADStorageFormat = sfAuto | A file format.
Description

Use LoadFromFile to populate the dataset with data stored in an external file.

AFileName is the name of the file containing the data to load. If file does not exists, then exception is raised.

AFormat is the file format:

  • sfXML - file is well formed standalone XML file;
  • sfBinary - file is binary file with custom AnyDAC format;
  • sfAuto - format is determined by AFileName extention: ".XML" - XML file, ".ADB" / ".BIN" / ".DAT" - binary file. If AFileName does not have an extention, then format is determined by ResourceOptions.DefaultStoreExt if it is specified, otherwise by ResourceOptions.DefaultStoreFormat.

As option, you can specify ResourceOptions.PersistentFileName and call Open, then dataset data is loaded from specified file. And at Close will be saved back, if data was modified.

AFileName must contain data saved to a file by a previous call to this or another client dataset's SaveToFile method. After call dataset is active.

Syntax
procedure LoadFromFile(const AFileName: String = ''; AFormat: TADStorageFormat = sfAuto);
See Also

LoadFromStream, SaveToFile, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName

Example
ADQuery1.Open('select * from customers');
ADQuery1.FetchAll;
ADQuery1.SaveToFile('c:\customers.xml', sfAuto);
....
ADMemTable1.LoadFromFile('c:\customers.xml', sfAuto);
ADMemTable1.Locate('CUSTOMER_ID', [100], []);


TADDataSet.LoadFromFileAtOpen Method

TADDataSet.LoadFromFileAtOpen Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns True, if dataset content will be loaded from file at Open.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Returns

True, if content will be loaded from file at Open.

Description

Use LoadFromFileAtOpen method to see, if dataset will execute command to get cursor and fetch records or will load its content from data file. To automatically load content from data file, following must be true:

  • dataset must be not nested dataset;
  • ResourceOptions.Persistent = True;
  • File with name resolved from ResourceOptions.PersistentFileName must exist.
Syntax
function LoadFromFileAtOpen: Boolean;
See Also

TADBottomResourceOptions.PersistentFileName, TADTopResourceOptions.DefaultStoreFolder, TADResourceOptions.Persistent


TADDataSet.LoadFromStream Method

TADDataSet.LoadFromStream Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Loads a dataset's data from a stream.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
AStream: TStream | A stream to load.
AFormat: TADStorageFormat = sfAuto | A file format.
Description

Use LoadFromStream to populate the dataset with data stored in an external file.

AStream is the reference to the stream, containing the data to load. The stream position must be at begining of the dataset data, otherwise loading will fail.

AFormat is the file format:

  • sfXML - stream contains a well formed standalone XML data;
  • sfBinary - stream contains a binary data with custom AnyDAC format;
  • sfAuto - format is determined by ResourceOptions.DefaultStoreExt if it is specified, otherwise by ResourceOptions.DefaultStoreFormat.
Syntax
procedure LoadFromStream(AStream: TStream; AFormat: TADStorageFormat = sfAuto);
See Also

LoadFromFile, SaveToStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName

Example
var
  oStr: TStream;
....
oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('data'), bmRead);
try
  ADMemTable1.LoadFromStream(oStr, sfBinary);
finally
  oStr.Free;
end;


TADDataSet.Locate Method

TADDataSet.Locate Method
TADDataSet Class uADCompDataSet Unit Example 1 Example 2 public See Also Send Feedback

Searches the dataset for a record with specified field values and makes it current.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example 1, Example 2, public, See Also
Parameters
Parameters | Description
const AKeyFields: string | A list of fields to match.
const AKeyValues: Variant | A variant value / variant array of values to search.
AOptions: TLocateOptions | A set of options for string values matching.
Returns

True if a matching record is found. Otherwise - False.

Description

Use Locate to search the dataset for a record with specified field values and make it current, if found.

AKeyFields is a semicolon separated list of field names on which to search.

AKeyValues is a Variant containing the values to match to the key fields. If AKeyFields contains a single field name, then AKeyValues is a simple value. If AKeyFields contains few field names, then AKeyValues is a variant array, where items correspond to the key fields.

AOptions is a set of search mode for string fields. If AOptions contains the loCaseInsensitive, then Locate ignores case when matching fields. If AOptions contains the loPartialKey, then the AKeyValues parameter can contain partial strings.

If matching record is found, then this record becomes current and Locate returns True.

To optimize record searching, application can setup client index. The index will be used by the Locate, if following conditions are met:

  • The index field list has as prefix AKeyFields fields;
  • The index is build with soNoCase option and AOptions includes loCaseInsensitive. Or index is build without soNoCase and AOptions does not include loCaseInsensitive.
  • The index is active and is current.
Syntax
function Locate(const AKeyFields: string; const AKeyValues: Variant; AOptions: TLocateOptions): Boolean; override;
See Also

LocateEx, Lookup, LookupEx, Indexes, IndexFieldNames, IndexName

Example 1
CustTable.IndexFieldNames := 'ID';
if CustTable.Locate('ID', 1001, []) then
  CustTable.Delete
else
  ShowMessage('The customer with ID=1001 is not found');
Example 2
CustTable.Locate('Company;Contact;Phone', VarArrayOf(['Sight Diver', 'P', '831-431-1000']), [loPartialKey]);


TADDataSet.LocateEx Method (string, TADDataSetLocateOptions, PInteger)

TADDataSet.LocateEx Method (string, TADDataSetLocateOptions, PInteger)
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches the dataset for a specified record by predicate expression and makes that record current or returns its index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AExpression: string | A predicate expression to search.
AOptions: TADDataSetLocateOptions | A search modes.
ApRecordIndex: PInteger = nil | An optional pointer to variable, receiving record index. Is nil by default.
Returns

True, if record is found.

Description

Use LocateEx to search the dataset for a record meeting the predicate expression and make it current, if found.

AExpression is a string containing the predicate expression on which to search. The expression cannot contain aggregating functions, like a SUM, COUNT and must be the predicate evaluating to True or to False. AnyDAC supports expression syntax compatible with:

  • BDE data access components;
  • TClientDataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write expressions.

AOptions is a set that optionally specifies additional search modes:

Option
Description
lxoCaseInsensitive
If included, then the LocateEx ignores case when matching string values.
lxoPartialKey
If included, then the expression can specify incomplete strings for string values comparision.
lxoFromCurrent
If included, then the LocateEx starts searching from the current record in dataset, otherwise from beginning.
lxoBackward
If included, then the LocateEx searches for record in backward direction, otherwise in forward direction.
lxoCheckOnly
If included, then LocateEx will not:

  • change current position;
  • fire BeforeScroll / AfterScroll events;
  • finish editing mode, if it is.

If matching record is found, then this record becomes current if lxoCheckOnly is not specified, ApRecordIndex pointed variable receives index of found record if ApRecordIndex is specified, and LocateEx returns True.

The searching using this version of LocateEx cannot be optimized. For optimized searching use another version of LocateEx method.

Syntax
function LocateEx(const AExpression: string; AOptions: TADDataSetLocateOptions; ApRecordIndex: PInteger = nil): Boolean; overload;
See Also

Locate, Lookup, LookupEx

Example
procedure TForm1.BtnFindClick(ASender: TObject);
begin
  if not CustTable.LocateEx('name like ''P%D''', [lxoCaseInsensitive]) then
    ShowMessage('The customer with name starting from P and ending by D is not found');
end;

procedure TForm1.BtnNextClick(ASender: TObject);
begin
  if not CustTable.LocateEx('name like ''P%D''', [lxoCaseInsensitive, lxoFromCurrent]) then
    ShowMessage('The customer with name starting from P and ending by D is not found');
end;


TADDataSet.LocateEx Method (string, Variant, TADDataSetLocateOptions, PInteger)

TADDataSet.LocateEx Method (string, Variant, TADDataSetLocateOptions, PInteger)
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches the dataset for a specified record by its fields values and makes that record current or returns its index.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AKeyFields: string | A list of fields to match.
const AKeyValues: Variant | A variant value / variant array of values to search.
AOptions: TADDataSetLocateOptions | A search modes.
ApRecordIndex: PInteger = nil | An optional pointer to variable, receiving record index. Is nil by default.
Returns

True, if record is found.

Description

Use LocateEx to search a dataset for a record with specified field values and make it current, if found.

AKeyFields is a semicolon-separated list of field names on which to search.

AKeyValues is a Variant containing the values to match to the key fields. If AKeyFields contains a single field name, then AKeyValues is a simple value. If AKeyFields contains few field names, then AKeyValues is a variant array, where items correspond to the key fields.

AOptions is a set that optionally specifies additional search modes:

Option
Description
lxoCaseInsensitive
If included, then the LocateEx ignores case when matching string values.
lxoPartialKey
If included, then the expression can specify incomplete strings for string values comparision.
lxoFromCurrent
If included, then the LocateEx starts searching from the current record in dataset, otherwise from beginning.
lxoBackward
If included, then the LocateEx searches for record in backward direction, otherwise in forward direction.
lxoCheckOnly
If included, then LocateEx will not:

  • change current position;
  • fire BeforeScroll / AfterScroll events;
  • finish editing mode, if it is.

If matching record is found, then this record becomes current if lxoCheckOnly is not specified, ApRecordIndex pointed variable receives index of found record if ApRecordIndex is specified, and LocateEx returns True.

To optimize record searching, application can setup client index. The index will be used by the LocateEx, if following conditions are met:

  • The index field list has as prefix AKeyFields fields;
  • The index is build with soNoCase option and AOptions includes lxoCaseInsensitive. Or index is build without soNoCase and AOptions does not include lxoCaseInsensitive.
  • The index is active and is current.
Syntax
function LocateEx(const AKeyFields: string; const AKeyValues: Variant; AOptions: TADDataSetLocateOptions; ApRecordIndex: PInteger = nil): Boolean; overload;
See Also

Locate, Lookup, LookupEx, Indexes, IndexFieldNames, IndexName

Example
procedure TForm1.BtnFindClick(ASender: TObject);
begin
  if not CustTable.LocateEx('COMPANY', 'AMCO', [lxoCaseInsensitive]) then
    ShowMessage('The customer from AMCO company is not found');
end;

procedure TForm1.BtnNextClick(ASender: TObject);
begin
  if not CustTable.LocateEx('COMPANY', 'AMCO', [lxoCaseInsensitive, lxoFromCurrent]) then
    ShowMessage('The customer from AMCO company is not found');
end;


TADDataSet.Lookup Method

TADDataSet.Lookup Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches the dataset for a record with specified key field values and returns result field values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AKeyFields: string | A list of fields to match.
const AKeyValues: Variant | A variant value / variant array of values to search.
const AResultFields: string | A list of fields which values to return.
Returns

If record is found, the values from the fields specified in AResultFields. Otherwise - Null.

Description

Use Lookup to search the dataset for a record with specified key field values and return result field values without changing the current position in the dataset.

AKeyFields is a semicolon separated list of field names on which to search.

AKeyValues is a Variant containing the values to match to the key fields. If AKeyFields contains a single field name, then AKeyValues is a simple value. If AKeyFields contains few field names, then AKeyValues is a variant array, where items correspond to the key fields.

AResultFields is a semicolon separated list of field names, which values to return. If record is found, Lookup returns a variant array containing the values from the fields specified in AResultFields. Otherwise - Null.

To optimize record searching, application can setup client index. The index will be used by the Lookup, if following conditions are met:

  • The index field list has as prefix AKeyFields fields;
  • The index is build without soNoCase option;
  • The index is active and is current.
Syntax
function Lookup(const AKeyFields: string; const AKeyValues: Variant; const AResultFields: string): Variant; override;
See Also

LookupEx, Locate, LocateEx, Indexes, IndexFieldNames, IndexName

Example
procedure TForm1.Button1Click(Sender: TObject);
var
  V: Variant;
  C: Integer;
  A: String;
begin
  V := ADQuery1.Lookup('Company;State', VarArrayOf(['Blue Sports', 'OR']), 'CustNo;Addr1');
  if not VarIsNull(V) then begin
    C := V[0];
    A := V[1];
    ShowMessage(IntToStr(C) + #13#10 + A);
  end
  else
    ShowMessage('The record is not found !');
end;


TADDataSet.LookupEx Method (string, Variant, string, TADDataSetLocateOptions, PInteger)

TADDataSet.LookupEx Method (string, Variant, string, TADDataSetLocateOptions, PInteger)
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Searches the dataset for a record with specified key field values and returns result field values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
const AKeyFields: string | A list of fields to match.
const AKeyValues: Variant | A variant value / variant array of values to search.
const AResultFields: string | A list of fields which values to return.
AOptions: TADDataSetLocateOptions | A set of search modes.
ApRecordIndex: PInteger = nil | An optional pointer to variable, receiving record index. Is nil by default.
Returns

If record is found, the values from the fields specified in AResultFields. Otherwise - Null.

Description

Use Lookup to search the dataset for a record with specified key field values and return result field values without changing the current position in the dataset.

AKeyFields is a semicolon separated list of field names on which to search.

AKeyValues is a Variant containing the values to match to the key fields. If AKeyFields contains a single field name, then AKeyValues is a simple value. If AKeyFields contains few field names, then AKeyValues is a variant array, where items correspond to the key fields.

AResultFields is a semicolon separated list of field names, which values to return. If record is found, Lookup returns a variant array containing the values from the fields specified in AResultFields. Otherwise - Null.

AOptions is a set that optionally specifies additional search modes:

Option
Description
lxoCaseInsensitive
If included, then the LookupEx ignores case when matching string values.
lxoPartialKey
If included, then the AKeyValues can specify incomplete strings for string values comparision.
lxoFromCurrent
If included, then the LookupEx starts searching from the current record in dataset, otherwise from beginning.
lxoBackward
If included, then the LookupEx searches for record in backward direction, otherwise in forward direction.
lxoCheckOnly
If included, then LookupEx will not:

  • finish editing mode, if it is.

If matching record is found and ApRecordIndex is not nil, then pointed variable receives index of found record.

To optimize record searching, application can setup client index. The index will be used by the LookupEx, if following conditions are met:

  • The index field list has as prefix AKeyFields fields;
  • The index is build without soNoCase option;
  • The index is active and is current.
Syntax
function LookupEx(const AKeyFields: string; const AKeyValues: Variant; const AResultFields: string; AOptions: TADDataSetLocateOptions; ApRecordIndex: PInteger = nil): Variant; overload;
See Also

Lookup, Locate, LocateEx, Indexes, IndexFieldNames, IndexName


TADDataSet.LookupEx Method (string, string, TADDataSetLocateOptions, PInteger)

TADDataSet.LookupEx Method (string, string, TADDataSetLocateOptions, PInteger)
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Searches the dataset for a record by predicate expression and returns result field values.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AExpression: string | A predicate expression to search.
const AResultFields: string | A list of fields which values to return.
AOptions: TADDataSetLocateOptions | A set of search modes.
ApRecordIndex: PInteger = nil | An optional pointer to variable, receiving record index. Is nil by default.
Returns

If record is found, the values from the fields specified in AResultFields. Otherwise - Null.

Description

Use Lookup to search the dataset for a record for which specified predicate expression evaluates to True and return other field values from the found record.

AExpression is a string containing the predicate expression on which to search. The expression cannot contain aggregating functions, like a SUM, COUNT and must be the predicate evaluating to True or to False. AnyDAC supports expression syntax compatible with:

  • BDE data access components;
  • TClientDataset;
  • Oracle 8 (not for 100%).

See Writing expressions for details of how to write expressions.

AResultFields is a semicolon separated list of field names, which values to return. If record is found, Lookup returns a variant array containing the values from the fields specified in AResultFields. Otherwise - Null.

AOptions is a set that optionally specifies additional search modes:

Option
Description
lxoCaseInsensitive
If included, then the LookupEx ignores case when matching string values.
lxoPartialKey
If included, then the AKeyValues can specify incomplete strings for string values comparision.
lxoFromCurrent
If included, then the LookupEx starts searching from the current record in dataset, otherwise from beginning.
lxoBackward
If included, then the LookupEx searches for record in backward direction, otherwise in forward direction.
lxoCheckOnly
If included, then LookupEx will not:

  • finish editing mode, if it is.

If matching record is found and ApRecordIndex is not nil, then pointed variable receives index of found record.

The searching using this version of LookupEx cannot be optimized. For optimized searching use another version of LookupEx method.

Syntax
function LookupEx(const AExpression: string; const AResultFields: string; AOptions: TADDataSetLocateOptions; ApRecordIndex: PInteger = nil): Variant; overload;
See Also

Lookup, Locate, LocateEx

Example
procedure TForm1.Button1Click(Sender: TObject);
var
  V: Variant;
  C: Integer;
  A: String;
begin
  V := ADQuery1.LookupEx('Company = ''Blue Sports'' and State = ''OR''', 'CustNo;Addr1', [lxoCaseInsensitive]);
  if not VarIsNull(V) then begin
    C := V[0];
    A := V[1];
    ShowMessage(IntToStr(C) + #13#10 + A);
  end
  else
    ShowMessage('The record is not found !');
end;


TADDataSet.Offline Method

TADDataSet.Offline Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Sets dataset to offline mode.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

The Offline method call disconnects dataset from DBMS, but does not close it. After this call, dataset will not fetch any more records from cursor, SourceEOF will be True, and no more cursors will be accessible.

If ResourceOptions.AutoDisconnect is True, then before entering into offline mode, dataset will fetch all remaining records from current cursor. If it is False and not all records are fetched, then will be raised an exception. Application can fetch all records using FetchAll.

In most cases there is no need to call Offline method by hands. It is used by connection Offline method to set connection and all assocciated dataset to offline mode.

Syntax
procedure Offline; virtual;
See Also

TADCustomConnection.Offline, FetchAll

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.OpenOrExecute Method

TADDataSet.OpenOrExecute Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Executes SQL command and optionally opens dataset.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Returns

True, if command returned result set.

Description

Use OpenOrExecute method, if you does not know - will command return result set or not. The most common case for that is the execution of an ad hoc query.

The OpenOrExecute method executes SQL command. And if command returns any result set, then this method opens dataset. The method supplements Open and Execute / ExecSQL / ExecProc methods:

  • the Open method raises an exception, if command does not return result set, like a INSERT;
  • the Execute / ExecSQL / ExecProc methods raise and exception, if command returns result set, like a SELECT.
Syntax
function OpenOrExecute: Boolean;
See Also

TDataSet.Open, Execute, TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc

Example
ADQuery1.Disconnect(True);
ADQuery1.SQL.Assign(Memo1.Lines);
if ADQuery1.OpenOrExecute then begin
  PageControl1.ActivePage := DataGridPage;
  DataGridPage.TabVisible := True;
end
else
  DataGridPage.TabVisible := False;


TADDataSet.ParamByName Method

TADDataSet.ParamByName Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Searches parameter by its name.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Parameters
Parameters | Description
const AValue: string | A name of parameter.
Returns

Parameter, if it is found.

Description

Use ParamByName to find a parameter by its name.

AValue is the name of the parameter for which to retrieve information. If parameter with AValue name is not found, then exception is raised.

Syntax
function ParamByName(const AValue: string): TADParam;
See Also

FindParam

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.Post Method

TADDataSet.Post Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure Post; override;


TADDataSet.Reconcile Method

TADDataSet.Reconcile Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
function Reconcile: Boolean;


TADDataSet.RefreshRecord Method

TADDataSet.RefreshRecord Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Rereads field values of the current record from a data source.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use RefreshRecord to discard all changes of the current record and reread it from the data source.

To reread record AnyDAC will perform sequence of steps:

  • If is assigned OnUpdateRecord event handler, then it will be called with ARequest = arFetchRow.
  • If event handler is not assigned or it returns AAction = eaDefault, then:
    • If is assigned TADAdaptedDataSet.UpdateObject and TADUpdateSQL.FetchRowSQL is not empty, then this SQL command will be executed.
    • Otherwise AnyDAC will generate SELECT command rereading single row from database and will execute command.

A similar method, TDataSet.Refresh, replaces the entire contents of the dataset by reexecuting SQL command.

Syntax
procedure RefreshRecord;
See Also

TDataSet.Refresh, OnUpdateRecord, TADAdaptedDataSet.UpdateObject, TADUpdateSQL.FetchRowSQL

Example
ADQuery1.UpdateObject := ADUpdateSQL;
// PL/SQL block calling packaged procedure returning customer data by its ID
ADUpdateSQL.FetchRowSQL.Text := 'begin cust_pack.read_cust_data(:new_name, :new_company, :new_state, :old_id); end;';
// always is required to setup output parameters
with ADUpdateSQL.Commands[arFetchRow] do begin
  Params[0].ParamType := ptOutput;
  Params[0].DataType := ftString;
  Params[1].ParamType := ptOutput;
  Params[1].DataType := ftString;
  Params[2].ParamType := ptOutput;
  Params[2].DataType := ftString;
end;
...
ADQuery1.RefreshRecord;


TADDataSet.RevertRecord Method

TADDataSet.RevertRecord Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Undoes changes to the current record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Description

Use RevertRecord to undo changes to the current record and remove it from the dataset changes log.

To undo the last edit made to a data set, call UndoLastChange. To cancel all pending modifications, call CancelUpdates. To undo all edits since an application-defined state, use the SavePoint property.

Syntax
procedure RevertRecord;
See Also

UndoLastChange, CancelUpdates, SavePoint

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADDataSet.SaveToFile Method

TADDataSet.SaveToFile Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Saves a dataset's data to a file.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AFileName: String = '' | An extrernal file name.
AFormat: TADStorageFormat = sfAuto | A file format.
Description

Use SaveToFile to write a dataset's data to an external file for later use by this or other datasets.

AFileName is the name of the external file to save the data.

AFormat is the file format:

  • sfXML - file is well formed standalone XML file;
  • sfBinary - file is binary file with custom AnyDAC format;
  • sfAuto - format is determined by AFileName extention: ".XML" - XML file, ".ADB" / ".BIN" / ".DAT" - binary file. If AFileName does not have an extention, then format is determined by ResourceOptions.DefaultStoreExt if it is specified, otherwise by ResourceOptions.DefaultStoreFormat.

As option, you can specify ResourceOptions.PersistentFileName before calling Open. Then data will be saved to file at Close, if data was modified or file does not exists.

If file exists and ResourceOptions.Backup = True, then original file extention will be changed to ResourceOptions.BackupExt and it will be saved to ResourceOptions.BackupFolder. And then will be written new file.

Syntax
procedure SaveToFile(const AFileName: String = ''; AFormat: TADStorageFormat = sfAuto);
See Also

SaveToStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName

Example
ADQuery1.Open('select * from customers');
ADQuery1.FetchAll;
ADQuery1.SaveToFile('c:\customers.xml', sfAuto);
....
ADMemTable1.LoadFromFile('c:\customers.xml', sfAuto);
ADMemTable1.Locate('CUSTOMER_ID', [100], []);


TADDataSet.SaveToFileAtClose Method

TADDataSet.SaveToFileAtClose Method
TADDataSet Class uADCompDataSet Unit public See Also Send Feedback

Returns True, if dataset content will be saved to file at Close.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public, See Also
Returns

True, if dataset content will be saved.

Description

Call SaveFileAtClose method to see, if dataset will save its data to the external file at Close. To automatically save content to data file, following must be true:

  • dataset must be not nested dataset;
  • ResourceOptions.Persistent = True;
  • resolved ResourceOptions.PersistentFileName must be not empty;
  • file does not exists or dataset was changed science last saving or loading of data from file or opening.
Syntax
function SaveToFileAtClose: Boolean;
See Also

TADBottomResourceOptions.PersistentFileName, TADTopResourceOptions.DefaultStoreFolder, TADResourceOptions.Persistent


TADDataSet.SaveToStream Method

TADDataSet.SaveToStream Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Saves a dataset's data to a stream.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
AStream: TStream | A stream to write.
AFormat: TADStorageFormat = sfAuto | A file format.
Description

Call SaveToStream to save the dataset data to an external file.

AStream is the reference to the stream, to which the data to write. The dataset will start to write its data at current stream position.

AFormat is the file format:

  • sfXML - stream contains a well formed standalone XML data;
  • sfBinary - stream contains a binary data with custom AnyDAC format;
  • sfAuto - format is determined by ResourceOptions.DefaultStoreExt if it is specified, otherwise by ResourceOptions.DefaultStoreFormat.
Syntax
procedure SaveToStream(AStream: TStream; AFormat: TADStorageFormat = sfAuto);
See Also

SaveToFile, LoadFromStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName

Example
var
  oStr: TStream;
  ....
  ADQuery1.Edit;
  oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('data'), bmWrite);
  try
    ADMemTable1.SaveToStream(oStr, sfBinary);
  finally
    oStr.Free;
    ADQuery1.Post;
  end;


TADDataSet.SetFieldAttributes Method ()

TADDataSet.SetFieldAttributes Method ()
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure SetFieldAttributes; overload;


TADDataSet.SetFieldAttributes Method (TField, TADDatSColumn, Boolean)

TADDataSet.SetFieldAttributes Method (TField, TADDatSColumn, Boolean)
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure SetFieldAttributes(AField: TField; AColumn: TADDatSColumn; ASkeepAutoInc: Boolean); overload;


TADDataSet.SetFieldAttributes Method (TFields)

TADDataSet.SetFieldAttributes Method (TFields)
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure SetFieldAttributes(AFields: TFields); overload;


TADDataSet.SetFieldAutoGenerateValue Method

TADDataSet.SetFieldAutoGenerateValue Method
TADDataSet Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADDataSet Class, uADCompDataSet Unit, public
Syntax
procedure SetFieldAutoGenerateValue(AField: TField; AValue: TAutoRefreshFlag);


TADDataSet.SetKey Method

TADDataSet.SetKey Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Starts the enter key values mode.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use SetKey to put the dataset into dsSetKey state, clear the current content of the search key buffer and enable to enter key field values.

Use EditKey to modify an existing key field values, without initially erasing them.

Syntax
procedure SetKey;
See Also

EditKey, GotoKey, SetRange, SetRangeEnd, SetRangeStart, TDataSet.State, TDataSet.FieldByName, IndexName, IndexFieldNames, Indexes

Example
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


TADDataSet.SetRange Method

TADDataSet.SetRange Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Sets the starting and ending values of a range, and applies it.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
const AStartValues: array of const | An open array of starting range values.
const AEndValues: array of const | An open array of ending range values.
Description

Use SetRange to specify the beginning and ending range values for the dataset and apply the range.

AStartValues sets starting range the indexed field values. AEndValues sets ending range the indexed fields values. SetRange performs the following steps:

  • puts the dataset into dsSetKey state;
  • erases any previously specified starting range values and ending range values;
  • sets the start and end range values;
  • applies the range to the dataset.

If the current dataset record is within new range, then it will be current after a call to SetRange. Otherwise the current position will be set to the first record in the range.

If either AStartValues or AEndValues has fewer elements than the number of fields in the current index, then the remaining entries are set to NULL.

Syntax
procedure SetRange(const AStartValues: array of const; const AEndValues: array of const);
See Also

SetRangeEnd, SetRangeStart, ApplyRange, TDataSet.State, TDataSet.FieldByName, IndexName, IndexFieldNames, Indexes

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRange([100], [200]);


TADDataSet.SetRangeEnd Method

TADDataSet.SetRangeEnd Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Sets the ending values of a range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use SetRangeEnd to put the dataset into dsSetKey state and erase any previously specified ending range values.

After that application can assign ending range values to the dataset indexed fields.

Syntax
procedure SetRangeEnd;
See Also

SetRangeStart, EditRangeStart, ApplyRange, IndexName, IndexFieldNames, Indexes, TDataSet.State, TDataSet.FieldByName

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
...
ADQuery1.SetRangeEnd;
ADQuery1.FieldByName('CUST_NO').AsInteger := 200;
...
ADQuery1.ApplyRange;


TADDataSet.SetRangeStart Method

TADDataSet.SetRangeStart Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Sets the starting values of a range.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Description

Use SetRangeStart to put the dataset into dsSetKey state and erase any previously specified starting range values.

After that application can assign starting range values to the dataset indexed fields.

Syntax
procedure SetRangeStart;
See Also

SetRangeEnd, EditRangeStart, ApplyRange, IndexName, IndexFieldNames, Indexes, TDataSet.State, TDataSet.FieldByName

Example
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1.FieldByName('CUST_NO').AsInteger := 100;
...
ADQuery1.ApplyRange;


TADDataSet.UndoLastChange Method

TADDataSet.UndoLastChange Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Undoes the last modification to the dataset records.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Parameters
Parameters | Description
AFollowChange: Boolean | A flag controlling current position in dataset.
Returns

True, if a change was undone.

Description

Use UndoLastChange to undo the last modification to the dataset records and remove the change from the dataset change log.

The method is applicapable to the datasets working in CachedUpdates = True mode.

If AFollowChange is True, then the current position in dataset is set to restored record. Otherwise the position remains unchanged.

To check if changed log is not empty read the UpdatesPending property value. If it is True, then there are changes to undo.

Syntax
function UndoLastChange(AFollowChange: Boolean): Boolean;
See Also

UpdatesPending, RevertRecord, CancelUpdates, SavePoint

Example
procedure TForm1.btnUndoClick(ASender: TObject);
begin
  ADQuery1.UndoLastChange(True);
end;


TADDataSet.UpdateStatus Method

TADDataSet.UpdateStatus Method
TADDataSet Class uADCompDataSet Unit Example public See Also Send Feedback

Returns the modification status for current record.

Group

public

Links
TADDataSet Class, uADCompDataSet Unit, Example, public, See Also
Returns

Record modification status.

Description

Use UpdateStatus method to get the modification status for the current dataset record. The function returns one of the following values:

Status | Description
usUnmodified | Record is in its original unmodified state.
usModified | Record is modified. Changes are not posted to database.
usDeleted | Record is deleted. Changes are not posted to database.
usInserted | Record is inserted. Changes are not posted to database.
Syntax
function UpdateStatus: TUpdateStatus; override;
See Also

UndoLastChange

Example
procedure TForm1.ADQuery1AfterScroll(DataSet: TDataSet);
begin
  case TADQuery(DataSet).UpdateStatus of
  usUnmodified: Label1.Caption := '';
  usModified: Label1.Caption := 'Modified';
  usDeleted: Label1.Caption := 'Deleted';
  usInserted: Label1.Caption := 'Inserted';
  end;
end;


TADIndex Class

TADIndex Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, published, Classes
Syntax
TADIndex = class(TCollectionItem);


public

public
TADIndex Class Legend Public Methods Public Properties Send Feedback

The public members of the TADIndex class are listed here.

Class

TADIndex Class

Public Methods
Name | Description
Assign |
BeginUpdate |
Destroy |
EndUpdate |
Public Properties
Name | Description
ActualActive |
DataSet |
Links
TADIndex Class, Legend, Public Methods, Public Properties


TADIndex.ActualActive Property

TADIndex.ActualActive Property
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
property ActualActive: Boolean;


TADIndex.DataSet Property

TADIndex.DataSet Property
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
property DataSet: TADDataSet;


TADIndex.Assign Method

TADIndex.Assign Method
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADIndex.BeginUpdate Method

TADIndex.BeginUpdate Method
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
procedure BeginUpdate;


TADIndex.Destroy Destructor

TADIndex.Destroy Destructor
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
destructor Destroy; override;


TADIndex.EndUpdate Method

TADIndex.EndUpdate Method
TADIndex Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndex Class, uADCompDataSet Unit, public
Syntax
procedure EndUpdate;


published

published
TADIndex Class Legend Published Properties Send Feedback

The published members of the TADIndex class are listed here.

Class

TADIndex Class

Published Properties
Name | Description
Active |
CaseInsFields |
DescFields |
Expression |
Fields |
Filter |
FilterOptions |
Name |
Options |
Selected |
Links
TADIndex Class, Legend, Published Properties


TADIndex.Active Property

TADIndex.Active Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Active: Boolean;


TADIndex.CaseInsFields Property

TADIndex.CaseInsFields Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property CaseInsFields: String;


TADIndex.DescFields Property

TADIndex.DescFields Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property DescFields: String;


TADIndex.Expression Property

TADIndex.Expression Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Expression: String;


TADIndex.Fields Property

TADIndex.Fields Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Fields: String;


TADIndex.Filter Property

TADIndex.Filter Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Filter: String;


TADIndex.FilterOptions Property

TADIndex.FilterOptions Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property FilterOptions: TADExpressionOptions;


TADIndex.Name Property

TADIndex.Name Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Name: String;


TADIndex.Options Property

TADIndex.Options Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Options: TADSortOptions;


TADIndex.Selected Property

TADIndex.Selected Property
TADIndex Class uADCompDataSet Unit published Send Feedback
Group

published

Links
TADIndex Class, uADCompDataSet Unit, published
Syntax
property Selected: Boolean;


TADIndexes Class

TADIndexes Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADIndexes = class(TCollection);


public

public
TADIndexes Class Legend Public Methods Public Properties Send Feedback

The public members of the TADIndexes class are listed here.

Class

TADIndexes Class

Public Methods
Name | Description
Add |
Build |
Create |
FindIndex |
FindIndexForFields |
IndexByName |
Release |
Public Properties
Name | Description
Items |
Links
TADIndexes Class, Legend, Public Methods, Public Properties


TADIndexes.Items Property

TADIndexes.Items Property
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
property Items [AIndex: Integer]: TADIndex;


TADIndexes.Add Method

TADIndexes.Add Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
function Add: TADIndex;


TADIndexes.Build Method

TADIndexes.Build Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
procedure Build;


TADIndexes.Create Constructor

TADIndexes.Create Constructor
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
constructor Create(ADataSet: TADDataSet);


TADIndexes.FindIndex Method

TADIndexes.FindIndex Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
function FindIndex(const AName: String): TADIndex;


TADIndexes.FindIndexForFields Method

TADIndexes.FindIndexForFields Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
function FindIndexForFields(const AFields: String; ARequiredOptions: TADSortOptions = []; AProhibitedOptions: TADSortOptions = []): TADIndex;


TADIndexes.IndexByName Method

TADIndexes.IndexByName Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
function IndexByName(const AName: String): TADIndex;


TADIndexes.Release Method

TADIndexes.Release Method
TADIndexes Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADIndexes Class, uADCompDataSet Unit, public
Syntax
procedure Release;


TADMasterDataLink Class

TADMasterDataLink Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADMasterDataLink = class(TMasterDataLink);


public

public
TADMasterDataLink Class Legend Public Events Send Feedback

The public members of the TADMasterDataLink class are listed here.

Class

TADMasterDataLink Class

Public Events
Name | Description
OnMasterFieldsDefined |
Links
TADMasterDataLink Class, Legend, Public Events


TADMasterDataLink.OnMasterFieldsDefined Event

TADMasterDataLink.OnMasterFieldsDefined Event
TADMasterDataLink Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADMasterDataLink Class, uADCompDataSet Unit, public
Syntax
property OnMasterFieldsDefined: TNotifyEvent;


TADWideMemoField Class

TADWideMemoField Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompDataSet

Links
public, Classes
Syntax
TADWideMemoField = class(TBlobField);


public

public
TADWideMemoField Class Legend Public Methods Public Properties Send Feedback

The public members of the TADWideMemoField class are listed here.

Class

TADWideMemoField Class

Public Methods
Name | Description
Create |
Public Properties
Name | Description
Value |
Links
TADWideMemoField Class, Legend, Public Methods, Public Properties


TADWideMemoField.Value Property

TADWideMemoField.Value Property
TADWideMemoField Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADWideMemoField Class, uADCompDataSet Unit, public
Syntax
property Value: WideString;


TADWideMemoField.Create Constructor

TADWideMemoField.Create Constructor
TADWideMemoField Class uADCompDataSet Unit public Send Feedback
Group

public

Links
TADWideMemoField Class, uADCompDataSet Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


Interfaces

Interfaces
uADCompDataSet Unit Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Unit

uADCompDataSet Unit

Interfaces
Name | Description
IADDataSet |
Links
uADCompDataSet Unit, Interfaces, Legend


IADDataSet Interface

IADDataSet Interface
public Interfaces Send Feedback
Group

Interfaces

Class Hierarchy
File

uADCompDataSet

Links
public, Interfaces
Syntax
IADDataSet = interface(IUnknown);


public

public
IADDataSet Interface Legend Public Methods Public Properties Send Feedback

The public members of the IADDataSet class are listed here.

Interface

IADDataSet Interface

Public Methods
Name | Description
GetDataView |
Public Properties
Name | Description
DataView |
Links
IADDataSet Interface, Legend, Public Methods, Public Properties


IADDataSet.DataView Property

IADDataSet.DataView Property
IADDataSet Interface uADCompDataSet Unit public Send Feedback
Group

public

Links
IADDataSet Interface, uADCompDataSet Unit, public
Syntax
property DataView: TADDatSView;


IADDataSet.GetDataView Method

IADDataSet.GetDataView Method
IADDataSet Interface uADCompDataSet Unit public Send Feedback
Group

public

Links
IADDataSet Interface, uADCompDataSet Unit, public
Syntax
function GetDataView: TADDatSView;


Records, Enums

Records, Enums
Enumerations uADCompDataSet Unit Legend Records Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADDataSetLocateOption |
TADKeyIndex |
Unit

uADCompDataSet Unit

Records
Name | Description
TADKeyBuffer |
Links
Enumerations, uADCompDataSet Unit, Legend, Records


uADCompDataSet.TADDataSetLocateOption Enumeration

uADCompDataSet.TADDataSetLocateOption Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataSet

Links
Records, Enums
Syntax
TADDataSetLocateOption = (
  lxoCaseInsensitive,
  lxoPartialKey,
  lxoFromCurrent,
  lxoBackward,
  lxoCheckOnly
);


uADCompDataSet.TADKeyBuffer Record

uADCompDataSet.TADKeyBuffer Record
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataSet

Links
Records, Enums
Syntax
TADKeyBuffer = packed record
  Modified: Boolean;
  Exclusive: Boolean;
  FieldCount: Integer;
end;


uADCompDataSet.TADKeyIndex Enumeration

uADCompDataSet.TADKeyIndex Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompDataSet

Links
Records, Enums
Syntax
TADKeyIndex = (
  kiLookup,
  kiRangeStart,
  kiRangeEnd,
  kiCurRangeStart,
  kiCurRangeEnd,
  kiSave
);


Types

Types
uADCompDataSet Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADCompDataSet Unit

Types
Name | Description
PADKeyBuffer |
TADAfterApplyUpdatesEvent | ..
TADCopyDataSetOptions |
TADDataSetEvent |
TADDataSetFlags |
TADDataSetLocateOptions |
TADReconcileErrorEvent |
TADStoredActivationUsage |
TADUpdateErrorEvent |
TADUpdateRecordEvent |
Links
uADCompDataSet Unit, Types


uADCompDataSet.PADKeyBuffer Type

uADCompDataSet.PADKeyBuffer Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
PADKeyBuffer = ^TADKeyBuffer;


uADCompDataSet.TADAfterApplyUpdatesEvent Type

uADCompDataSet.TADAfterApplyUpdatesEvent Type
Types See Also Send Feedback

..

Group

Types

File

uADCompDataSet

Links
Types, See Also
Parameters
Parameters | Description
Param1 | Description
Param2 | Description
Description

..

Syntax
TADAfterApplyUpdatesEvent = procedure (DataSet: TADDataSet; AErrors: Integer) of object;
See Also

..


uADCompDataSet.TADCopyDataSetOptions Type

uADCompDataSet.TADCopyDataSetOptions Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADCopyDataSetOptions = set of (coExcludeNewEmptyValues, coRestart, coStructure);


uADCompDataSet.TADDataSetEvent Type

uADCompDataSet.TADDataSetEvent Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADDataSetEvent = procedure (DataSet: TADDataSet) of object;


uADCompDataSet.TADDataSetFlags Type

uADCompDataSet.TADDataSetFlags Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADDataSetFlags = set of (dfOpenBlob, dfOfflining, dfKeyBuffersAllocated, dfRangeFromExclusive, dfRangeToExclusive, dfLockNoBMK, dfClearIndexDefs, dfColumnAttributesUpdated, dfCalcFieldInIndex);


uADCompDataSet.TADDataSetLocateOptions Type

uADCompDataSet.TADDataSetLocateOptions Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADDataSetLocateOptions = set of TADDataSetLocateOption;


uADCompDataSet.TADReconcileErrorEvent Type

uADCompDataSet.TADReconcileErrorEvent Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADReconcileErrorEvent = procedure (DataSet: TADDataSet; E: EADException; UpdateKind: TADDatSRowState; var Action: TADDAptReconcileAction) of object;


uADCompDataSet.TADStoredActivationUsage Type

uADCompDataSet.TADStoredActivationUsage Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADStoredActivationUsage = set of (auDesignTime, auRunTime);


uADCompDataSet.TADUpdateErrorEvent Type

uADCompDataSet.TADUpdateErrorEvent Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADUpdateErrorEvent = procedure (ASender: TDataSet; AException: EADException; ARow: TADDatSRow; ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction) of object;


uADCompDataSet.TADUpdateRecordEvent Type

uADCompDataSet.TADUpdateRecordEvent Type
Types Send Feedback
Group

Types

File

uADCompDataSet

Links
Types
Syntax
TADUpdateRecordEvent = procedure (ASender: TDataSet; ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction; AOptions: TADPhysUpdateRowOptions) of object;


uADCompScript Unit

uADCompScript Unit
Classes Functions Legend Topics Types Records, Enums Send Feedback
Classes
Name | Description
TADScript |
TADScriptCommand |
TADScriptCommandRegistry |
TADScriptOptions |
TADScriptParser |
TADSQLScript |
TADSQLScripts |
Functions
Name | Description
ADKeywordMatch |
ADScriptCommandRegistry |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TADConsoleGetEvent |
TADConsoleLockUpdate |
TADConsolePutEvent |
TADGetStreamEvent |
TADHostCommandEvent |
TADPauseEvent |
TADScriptCharSet |
TADScriptCommandClass |
Records, Enums
Name | Description
TADScriptCommandLookupRes |
TADScriptEchoCommands |
TADScriptSpoolOutputMode |
TADScriptStatus |
TADScriptStreamMode |
Links
Classes, Functions, Legend, Topics, Types, Records, Enums


Classes

Classes
Classes uADCompScript Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADScript |
TADScriptCommand |
TADScriptCommandRegistry |
TADScriptOptions |
TADScriptParser |
TADSQLScript |
TADSQLScripts |
Unit

uADCompScript Unit

Links
Classes, uADCompScript Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADScript Class

TADScript Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, published, Classes
Syntax
TADScript = class(TADComponent, IUnknown, IADStanOptions, IADStanErrorHandler, IADStanObject, IADGUIxScriptDialogInfoProvider);


public

public
TADScript Class Legend Public Methods Public Properties Send Feedback

The public members of the TADScript class are listed here.

Class

TADScript Class

Public Methods
Name | Description
AbortJob |
CheckCommand |
CloseConnection |
CloseSpool |
ConGet |
ConLockUpdate |
ConPut |
ConUnlockUpdate |
Create |
Destroy |
ExecuteAll |
ExecuteAll |
ExecuteHostCommand |
ExecuteStep |
ExecuteStep |
ExpandString |
GetStream |
OpenConnection |
Progress |
ReleaseStream |
UpdateCommandSeparator |
UpdateSpool |
ValidateAll |
ValidateAll |
ValidateStep |
ValidateStep |
Public Properties
Name | Description
AllSpools |
CallStack |
CommandIntf |
ConnectionIntf |
CurrentCommand |
EOF |
Finished |
LastSpoolFileName |
Position |
ProcessedAfterCommit |
RDBMSKind |
Status |
Table |
TotalErrors |
TotalJobDone |
TotalJobSize |
TotalPct10Done |
Links
TADScript Class, Legend, Public Methods, Public Properties


TADScript.AllSpools Property

TADScript.AllSpools Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property AllSpools: TStrings;


TADScript.CallStack Property

TADScript.CallStack Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property CallStack: TStrings;


TADScript.CommandIntf Property

TADScript.CommandIntf Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property CommandIntf: IADPhysCommand;


TADScript.ConnectionIntf Property

TADScript.ConnectionIntf Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property ConnectionIntf: IADPhysConnection;


TADScript.CurrentCommand Property

TADScript.CurrentCommand Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property CurrentCommand: TADScriptCommand;


TADScript.EOF Property

TADScript.EOF Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property EOF: Boolean;


TADScript.Finished Property

TADScript.Finished Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property Finished: Boolean;


TADScript.LastSpoolFileName Property

TADScript.LastSpoolFileName Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property LastSpoolFileName: String;


TADScript.Position Property

TADScript.Position Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property Position: TPoint;


TADScript.ProcessedAfterCommit Property

TADScript.ProcessedAfterCommit Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property ProcessedAfterCommit: Integer;


TADScript.RDBMSKind Property

TADScript.RDBMSKind Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property RDBMSKind: TADRDBMSKind;


TADScript.Status Property

TADScript.Status Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property Status: TADScriptStatus;


TADScript.Table Property

TADScript.Table Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property Table: TADDatSTable;


TADScript.TotalErrors Property

TADScript.TotalErrors Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property TotalErrors: Integer;


TADScript.TotalJobDone Property

TADScript.TotalJobDone Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property TotalJobDone: Integer;


TADScript.TotalJobSize Property

TADScript.TotalJobSize Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property TotalJobSize: Integer;


TADScript.TotalPct10Done Property

TADScript.TotalPct10Done Property
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
property TotalPct10Done: Integer;


TADScript.AbortJob Method

TADScript.AbortJob Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure AbortJob(const AWait: Boolean = False);


TADScript.CheckCommand Method

TADScript.CheckCommand Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure CheckCommand;


TADScript.CloseConnection Method

TADScript.CloseConnection Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure CloseConnection;


TADScript.CloseSpool Method

TADScript.CloseSpool Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure CloseSpool;


TADScript.ConGet Method

TADScript.ConGet Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ConGet(const APrompt: String; var AResult: String); virtual;


TADScript.ConLockUpdate Method

TADScript.ConLockUpdate Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ConLockUpdate; virtual;


TADScript.ConPut Method

TADScript.ConPut Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ConPut(const AMsg: String; AKind: TADScriptOuputKind); virtual;


TADScript.ConUnlockUpdate Method

TADScript.ConUnlockUpdate Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ConUnlockUpdate; virtual;


TADScript.Create Constructor

TADScript.Create Constructor
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
constructor Create(AOwner: TComponent); override;


TADScript.Destroy Destructor

TADScript.Destroy Destructor
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
destructor Destroy; override;


TADScript.ExecuteAll Method ()

TADScript.ExecuteAll Method ()
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ExecuteAll: Boolean; overload;


TADScript.ExecuteAll Method (TADScriptParser)

TADScript.ExecuteAll Method (TADScriptParser)
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ExecuteAll(AParser: TADScriptParser): Boolean; overload;


TADScript.ExecuteHostCommand Method

TADScript.ExecuteHostCommand Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ExecuteHostCommand(const ACommand: String); virtual;


TADScript.ExecuteStep Method ()

TADScript.ExecuteStep Method ()
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ExecuteStep: Boolean; overload;


TADScript.ExecuteStep Method (TADScriptParser)

TADScript.ExecuteStep Method (TADScriptParser)
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ExecuteStep(AParser: TADScriptParser): Boolean; overload;


TADScript.ExpandString Method

TADScript.ExpandString Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ExpandString(const AValue: String): String;


TADScript.GetStream Method

TADScript.GetStream Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure GetStream(const AFileName: String; AMode: TADScriptStreamMode; out AStream: TStream); virtual;


TADScript.OpenConnection Method

TADScript.OpenConnection Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure OpenConnection(const AConnectionString: String);


TADScript.Progress Method

TADScript.Progress Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure Progress;


TADScript.ReleaseStream Method

TADScript.ReleaseStream Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure ReleaseStream(const AFileName: String; AMode: TADScriptStreamMode; var AStream: TStream); virtual;


TADScript.UpdateCommandSeparator Method

TADScript.UpdateCommandSeparator Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure UpdateCommandSeparator;


TADScript.UpdateSpool Method

TADScript.UpdateSpool Method
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
procedure UpdateSpool;


TADScript.ValidateAll Method ()

TADScript.ValidateAll Method ()
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ValidateAll: Boolean; overload;


TADScript.ValidateAll Method (TADScriptParser)

TADScript.ValidateAll Method (TADScriptParser)
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ValidateAll(AParser: TADScriptParser): Boolean; overload;


TADScript.ValidateStep Method ()

TADScript.ValidateStep Method ()
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ValidateStep: Boolean; overload;


TADScript.ValidateStep Method (TADScriptParser)

TADScript.ValidateStep Method (TADScriptParser)
TADScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScript Class, uADCompScript Unit, public
Syntax
function ValidateStep(AParser: TADScriptParser): Boolean; overload;


published

published
TADScript Class Legend Published Events Published Properties Send Feedback

The published members of the TADScript class are listed here.

Class

TADScript Class

Published Events
Name | Description
AfterExecute |
AfterScript |
BeforeExecute |
BeforeScript |
OnConsoleGet |
OnConsoleLockUpdate |
OnConsolePut |
OnError |
OnGetStream |
OnHostCommand |
OnPause |
OnProgress |
OnReleaseStream |
OnSpoolPut |
Published Properties
Name | Description
Arguments |
Connection |
DefaultDriverName |
FetchOptions |
FormatOptions |
Macros |
Params |
ResourceOptions |
ScriptDialog |
ScriptOptions |
SQLScriptFileName |
SQLScripts |
Links
TADScript Class, Legend, Published Events, Published Properties


TADScript.AfterExecute Event

TADScript.AfterExecute Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property AfterExecute: TNotifyEvent;


TADScript.AfterScript Event

TADScript.AfterScript Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property AfterScript: TNotifyEvent;


TADScript.Arguments Property

TADScript.Arguments Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property Arguments: TStrings;


TADScript.BeforeExecute Event

TADScript.BeforeExecute Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property BeforeExecute: TNotifyEvent;


TADScript.BeforeScript Event

TADScript.BeforeScript Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property BeforeScript: TNotifyEvent;


TADScript.Connection Property

TADScript.Connection Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property Connection: TADCustomConnection;


TADScript.DefaultDriverName Property

TADScript.DefaultDriverName Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property DefaultDriverName: String;


TADScript.FetchOptions Property

TADScript.FetchOptions Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property FetchOptions: TADFetchOptions;


TADScript.FormatOptions Property

TADScript.FormatOptions Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property FormatOptions: TADFormatOptions;


TADScript.Macros Property

TADScript.Macros Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property Macros: TADMacros;


TADScript.OnConsoleGet Event

TADScript.OnConsoleGet Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnConsoleGet: TADConsoleGetEvent;


TADScript.OnConsoleLockUpdate Event

TADScript.OnConsoleLockUpdate Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnConsoleLockUpdate: TADConsoleLockUpdate;


TADScript.OnConsolePut Event

TADScript.OnConsolePut Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnConsolePut: TADConsolePutEvent;


TADScript.OnError Event

TADScript.OnError Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnError: TADErrorEvent;


TADScript.OnGetStream Event

TADScript.OnGetStream Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnGetStream: TADGetStreamEvent;


TADScript.OnHostCommand Event

TADScript.OnHostCommand Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnHostCommand: TADHostCommandEvent;


TADScript.OnPause Event

TADScript.OnPause Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnPause: TADPauseEvent;


TADScript.OnProgress Event

TADScript.OnProgress Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnProgress: TNotifyEvent;


TADScript.OnReleaseStream Event

TADScript.OnReleaseStream Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnReleaseStream: TADGetStreamEvent;


TADScript.OnSpoolPut Event

TADScript.OnSpoolPut Event
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property OnSpoolPut: TADConsolePutEvent;


TADScript.Params Property

TADScript.Params Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property Params: TADParams;


TADScript.ResourceOptions Property

TADScript.ResourceOptions Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property ResourceOptions: TADResourceOptions;


TADScript.ScriptDialog Property

TADScript.ScriptDialog Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property ScriptDialog: IADGUIxScriptDialog;


TADScript.ScriptOptions Property

TADScript.ScriptOptions Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property ScriptOptions: TADScriptOptions;


TADScript.SQLScriptFileName Property

TADScript.SQLScriptFileName Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property SQLScriptFileName: String;


TADScript.SQLScripts Property

TADScript.SQLScripts Property
TADScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScript Class, uADCompScript Unit, published
Syntax
property SQLScripts: TADSQLScripts;


TADScriptCommand Class

TADScriptCommand Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, Classes
Syntax
TADScriptCommand = class(TObject);


public

public
TADScriptCommand Class Legend Public Methods Public Properties Send Feedback

The public members of the TADScriptCommand class are listed here.

Class

TADScriptCommand Class

Public Methods
Name | Description
AbortJob |
Create |
Destroy |
Execute |
Help |
Keywords |
Parse |
Validate |
Public Properties
Name | Description
Engine |
Parser |
Position |
Links
TADScriptCommand Class, Legend, Public Methods, Public Properties


TADScriptCommand.Engine Property

TADScriptCommand.Engine Property
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
property Engine: TADScript;


TADScriptCommand.Parser Property

TADScriptCommand.Parser Property
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
property Parser: TADScriptParser;


TADScriptCommand.Position Property

TADScriptCommand.Position Property
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
property Position: TPoint;


TADScriptCommand.AbortJob Method

TADScriptCommand.AbortJob Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
procedure AbortJob(const AWait: Boolean = False); virtual;


TADScriptCommand.Create Constructor

TADScriptCommand.Create Constructor
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
constructor Create(AParser: TADScriptParser; AEngine: TADScript); virtual;


TADScriptCommand.Destroy Destructor

TADScriptCommand.Destroy Destructor
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
destructor Destroy; override;


TADScriptCommand.Execute Method

TADScriptCommand.Execute Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
procedure Execute; virtual;


TADScriptCommand.Help Method

TADScriptCommand.Help Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
class function Help: String; virtual;


TADScriptCommand.Keywords Method

TADScriptCommand.Keywords Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
class procedure Keywords(AKwds: TStrings); virtual;


TADScriptCommand.Parse Method

TADScriptCommand.Parse Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
function Parse(const AKwd: String): Boolean; virtual;


TADScriptCommand.Validate Method

TADScriptCommand.Validate Method
TADScriptCommand Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommand Class, uADCompScript Unit, public
Syntax
procedure Validate; virtual;


TADScriptCommandRegistry Class

TADScriptCommandRegistry Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, Classes
Syntax
TADScriptCommandRegistry = class(TObject);


public

public
TADScriptCommandRegistry Class Legend Public Methods Public Properties Send Feedback

The public members of the TADScriptCommandRegistry class are listed here.

Class

TADScriptCommandRegistry Class

Public Methods
Name | Description
AddCommand |
Create |
Destroy |
Help |
LookupCommand |
Public Properties
Name | Description
DefaultPLSQLCommandClass |
DefaultSQLCommandClass |
Links
TADScriptCommandRegistry Class, Legend, Public Methods, Public Properties


TADScriptCommandRegistry.DefaultPLSQLCommandClass Property

TADScriptCommandRegistry.DefaultPLSQLCommandClass Property
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
property DefaultPLSQLCommandClass: TADScriptCommandClass;


TADScriptCommandRegistry.DefaultSQLCommandClass Property

TADScriptCommandRegistry.DefaultSQLCommandClass Property
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
property DefaultSQLCommandClass: TADScriptCommandClass;


TADScriptCommandRegistry.AddCommand Method

TADScriptCommandRegistry.AddCommand Method
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
procedure AddCommand(ACommand: TADScriptCommandClass);


TADScriptCommandRegistry.Create Constructor

TADScriptCommandRegistry.Create Constructor
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
constructor Create;


TADScriptCommandRegistry.Destroy Destructor

TADScriptCommandRegistry.Destroy Destructor
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
destructor Destroy; override;


TADScriptCommandRegistry.Help Method

TADScriptCommandRegistry.Help Method
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
function Help: String;


TADScriptCommandRegistry.LookupCommand Method

TADScriptCommandRegistry.LookupCommand Method
TADScriptCommandRegistry Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptCommandRegistry Class, uADCompScript Unit, public
Syntax
function LookupCommand(const AStr: String; out ACommand: TADScriptCommandClass): TADScriptCommandLookupRes;


TADScriptOptions Class

TADScriptOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, published, Classes
Syntax
TADScriptOptions = class(TPersistent);


public

public
TADScriptOptions Class Legend Public Properties Send Feedback

The public members of the TADScriptOptions class are listed here.

Class

TADScriptOptions Class

Public Properties
Name | Description
ActualCommandSeparator |
Links
TADScriptOptions Class, Legend, Public Properties


TADScriptOptions.ActualCommandSeparator Property

TADScriptOptions.ActualCommandSeparator Property
TADScriptOptions Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptOptions Class, uADCompScript Unit, public
Syntax
property ActualCommandSeparator: String;


published

published
TADScriptOptions Class Legend Published Methods Published Properties Send Feedback

The published members of the TADScriptOptions class are listed here.

Class

TADScriptOptions Class

Published Methods
Name | Description
Assign |
Create |
Published Properties
Name | Description
AutoPrintParams |
BreakOnError |
ColumnHeadings |
CommandSeparator |
CommitEachNCommands |
ConsoleOutput |
DefaultDataPath |
DefaultScriptPath |
DropNonexistObj |
EchoCommands |
EchoCommandTrim |
FeedbackCommands |
FeedbackScript |
LineSize |
MacroExpand |
MaxBytesToPrintLongs |
PageSize |
ParamArraySize |
SpoolFileName |
SpoolOutput |
Timing |
TrimConsole |
TrimSpool |
Verify |
Links
TADScriptOptions Class, Legend, Published Methods, Published Properties


TADScriptOptions.AutoPrintParams Property

TADScriptOptions.AutoPrintParams Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property AutoPrintParams: Boolean;


TADScriptOptions.BreakOnError Property

TADScriptOptions.BreakOnError Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property BreakOnError: Boolean;


TADScriptOptions.ColumnHeadings Property

TADScriptOptions.ColumnHeadings Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property ColumnHeadings: Boolean;


TADScriptOptions.CommandSeparator Property

TADScriptOptions.CommandSeparator Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property CommandSeparator: String;


TADScriptOptions.CommitEachNCommands Property

TADScriptOptions.CommitEachNCommands Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property CommitEachNCommands: Integer;


TADScriptOptions.ConsoleOutput Property

TADScriptOptions.ConsoleOutput Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property ConsoleOutput: Boolean;


TADScriptOptions.DefaultDataPath Property

TADScriptOptions.DefaultDataPath Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property DefaultDataPath: String;


TADScriptOptions.DefaultScriptPath Property

TADScriptOptions.DefaultScriptPath Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property DefaultScriptPath: String;


TADScriptOptions.DropNonexistObj Property

TADScriptOptions.DropNonexistObj Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property DropNonexistObj: Boolean;


TADScriptOptions.EchoCommands Property

TADScriptOptions.EchoCommands Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property EchoCommands: TADScriptEchoCommands;


TADScriptOptions.EchoCommandTrim Property

TADScriptOptions.EchoCommandTrim Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property EchoCommandTrim: Integer;


TADScriptOptions.FeedbackCommands Property

TADScriptOptions.FeedbackCommands Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property FeedbackCommands: Boolean;


TADScriptOptions.FeedbackScript Property

TADScriptOptions.FeedbackScript Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property FeedbackScript: Boolean;


TADScriptOptions.LineSize Property

TADScriptOptions.LineSize Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property LineSize: Integer;


TADScriptOptions.MacroExpand Property

TADScriptOptions.MacroExpand Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property MacroExpand: Boolean;


TADScriptOptions.MaxBytesToPrintLongs Property

TADScriptOptions.MaxBytesToPrintLongs Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property MaxBytesToPrintLongs: Integer;


TADScriptOptions.PageSize Property

TADScriptOptions.PageSize Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property PageSize: Integer;


TADScriptOptions.ParamArraySize Property

TADScriptOptions.ParamArraySize Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property ParamArraySize: Integer;


TADScriptOptions.SpoolFileName Property

TADScriptOptions.SpoolFileName Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property SpoolFileName: String;


TADScriptOptions.SpoolOutput Property

TADScriptOptions.SpoolOutput Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property SpoolOutput: TADScriptSpoolOutputMode;


TADScriptOptions.Timing Property

TADScriptOptions.Timing Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property Timing: Boolean;


TADScriptOptions.TrimConsole Property

TADScriptOptions.TrimConsole Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property TrimConsole: Boolean;


TADScriptOptions.TrimSpool Property

TADScriptOptions.TrimSpool Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property TrimSpool: Boolean;


TADScriptOptions.Verify Property

TADScriptOptions.Verify Property
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
property Verify: Boolean;


TADScriptOptions.Assign Method

TADScriptOptions.Assign Method
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
procedure Assign(Source: TPersistent); override;


TADScriptOptions.Create Constructor

TADScriptOptions.Create Constructor
TADScriptOptions Class uADCompScript Unit published Send Feedback
Group

published

Links
TADScriptOptions Class, uADCompScript Unit, published
Syntax
constructor Create(AOwner: TPersistent);


TADScriptParser Class

TADScriptParser Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, Classes
Syntax
TADScriptParser = class(TObject);


public

public
TADScriptParser Class Legend Public Methods Public Properties Send Feedback

The public members of the TADScriptParser class are listed here.

Class

TADScriptParser Class

Public Methods
Name | Description
Create |
ExtractCommand |
ExtractString |
GetBookmark |
GetChar |
GetIdentifier |
GetLine |
GetNumber |
GetOnOfChar |
GetOnOff |
GetString |
GetStringInFull |
GetUCWord |
InvalidSyntax |
SetBookmark |
SkipWS |
SkipWSLF |
UnGetChar |
Public Properties
Name | Description
Ch |
FileName |
LineNumber |
ParentCommand |
Position |
ScriptOptions |
TotalSize |
WasBeginningOfLine |
Links
TADScriptParser Class, Legend, Public Methods, Public Properties


TADScriptParser.Ch Property

TADScriptParser.Ch Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property Ch: Char;


TADScriptParser.FileName Property

TADScriptParser.FileName Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property FileName: String;


TADScriptParser.LineNumber Property

TADScriptParser.LineNumber Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property LineNumber: Integer;


TADScriptParser.ParentCommand Property

TADScriptParser.ParentCommand Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property ParentCommand: TADScriptCommand;


TADScriptParser.Position Property

TADScriptParser.Position Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property Position: TPoint;


TADScriptParser.ScriptOptions Property

TADScriptParser.ScriptOptions Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property ScriptOptions: TADScriptOptions;


TADScriptParser.TotalSize Property

TADScriptParser.TotalSize Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property TotalSize: Integer;


TADScriptParser.WasBeginningOfLine Property

TADScriptParser.WasBeginningOfLine Property
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
property WasBeginningOfLine: Boolean;


TADScriptParser.Create Constructor

TADScriptParser.Create Constructor
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
constructor Create(AFileName: String; AParentCommand: TADScriptCommand; AStream: TStream);


TADScriptParser.ExtractCommand Method

TADScriptParser.ExtractCommand Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function ExtractCommand(AEngine: TADScript): TADScriptCommand;


TADScriptParser.ExtractString Method

TADScriptParser.ExtractString Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function ExtractString(ABmk1: Integer; ABmk2: Integer): String;


TADScriptParser.GetBookmark Method

TADScriptParser.GetBookmark Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetBookmark: Integer;


TADScriptParser.GetChar Method

TADScriptParser.GetChar Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure GetChar;


TADScriptParser.GetIdentifier Method

TADScriptParser.GetIdentifier Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetIdentifier: String;


TADScriptParser.GetLine Method

TADScriptParser.GetLine Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetLine: String;


TADScriptParser.GetNumber Method

TADScriptParser.GetNumber Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetNumber(ADef: Integer = 0): Integer;


TADScriptParser.GetOnOfChar Method

TADScriptParser.GetOnOfChar Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetOnOfChar(ADef: Char): Integer;


TADScriptParser.GetOnOff Method

TADScriptParser.GetOnOff Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetOnOff: Integer;


TADScriptParser.GetString Method

TADScriptParser.GetString Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetString(ARequired: Boolean = False): String;


TADScriptParser.GetStringInFull Method

TADScriptParser.GetStringInFull Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetStringInFull: String;


TADScriptParser.GetUCWord Method

TADScriptParser.GetUCWord Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
function GetUCWord: String;


TADScriptParser.InvalidSyntax Method

TADScriptParser.InvalidSyntax Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure InvalidSyntax;


TADScriptParser.SetBookmark Method

TADScriptParser.SetBookmark Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure SetBookmark(ABmk: Integer);


TADScriptParser.SkipWS Method

TADScriptParser.SkipWS Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure SkipWS;


TADScriptParser.SkipWSLF Method

TADScriptParser.SkipWSLF Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure SkipWSLF;


TADScriptParser.UnGetChar Method

TADScriptParser.UnGetChar Method
TADScriptParser Class uADCompScript Unit public Send Feedback
Group

public

Links
TADScriptParser Class, uADCompScript Unit, public
Syntax
procedure UnGetChar;


TADSQLScript Class

TADSQLScript Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, published, Classes
Syntax
TADSQLScript = class(TCollectionItem);


public

public
TADSQLScript Class Legend Public Methods Send Feedback

The public members of the TADSQLScript class are listed here.

Class

TADSQLScript Class

Public Methods
Name | Description
Assign |
Create |
Destroy |
Links
TADSQLScript Class, Legend, Public Methods


TADSQLScript.Assign Method

TADSQLScript.Assign Method
TADSQLScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScript Class, uADCompScript Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADSQLScript.Create Constructor

TADSQLScript.Create Constructor
TADSQLScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScript Class, uADCompScript Unit, public
Syntax
constructor Create(Collection: TCollection); override;


TADSQLScript.Destroy Destructor

TADSQLScript.Destroy Destructor
TADSQLScript Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScript Class, uADCompScript Unit, public
Syntax
destructor Destroy; override;


published

published
TADSQLScript Class Legend Published Properties Send Feedback

The published members of the TADSQLScript class are listed here.

Class

TADSQLScript Class

Published Properties
Name | Description
Name |
SQL |
Links
TADSQLScript Class, Legend, Published Properties


TADSQLScript.Name Property

TADSQLScript.Name Property
TADSQLScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADSQLScript Class, uADCompScript Unit, published
Syntax
property Name: String;


TADSQLScript.SQL Property

TADSQLScript.SQL Property
TADSQLScript Class uADCompScript Unit published Send Feedback
Group

published

Links
TADSQLScript Class, uADCompScript Unit, published
Syntax
property SQL: TStrings;


TADSQLScripts Class

TADSQLScripts Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADCompScript

Links
public, Classes
Syntax
TADSQLScripts = class(TOwnedCollection);


public

public
TADSQLScripts Class Legend Public Methods Public Properties Send Feedback

The public members of the TADSQLScripts class are listed here.

Class

TADSQLScripts Class

Public Methods
Name | Description
Add |
Create |
FindScript |
Public Properties
Name | Description
Items |
Links
TADSQLScripts Class, Legend, Public Methods, Public Properties


TADSQLScripts.Items Property

TADSQLScripts.Items Property
TADSQLScripts Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScripts Class, uADCompScript Unit, public
Syntax
property Items [AIndex: Integer]: TADSQLScript;


TADSQLScripts.Add Method

TADSQLScripts.Add Method
TADSQLScripts Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScripts Class, uADCompScript Unit, public
Syntax
function Add: TADSQLScript;


TADSQLScripts.Create Constructor

TADSQLScripts.Create Constructor
TADSQLScripts Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScripts Class, uADCompScript Unit, public
Syntax
constructor Create(AScript: TADScript);


TADSQLScripts.FindScript Method

TADSQLScripts.FindScript Method
TADSQLScripts Class uADCompScript Unit public Send Feedback
Group

public

Links
TADSQLScripts Class, uADCompScript Unit, public
Syntax
function FindScript(const AName: String): TADSQLScript;


Functions

Functions
Functions uADCompScript Unit Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ADKeywordMatch |
ADScriptCommandRegistry |
Unit

uADCompScript Unit

Links
Functions, uADCompScript Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADCompScript.ADKeywordMatch Function

uADCompScript.ADKeywordMatch Function
Functions Send Feedback
Group

Functions

File

uADCompScript

Links
Functions
Syntax
function ADKeywordMatch(const AStr: String; const AMatch: String; AOptLength: Integer): Boolean;


uADCompScript.ADScriptCommandRegistry Function

uADCompScript.ADScriptCommandRegistry Function
Functions Send Feedback
Group

Functions

File

uADCompScript

Links
Functions
Syntax
function ADScriptCommandRegistry: TADScriptCommandRegistry;


Records, Enums

Records, Enums
Enumerations uADCompScript Unit Legend Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADScriptCommandLookupRes |
TADScriptEchoCommands |
TADScriptSpoolOutputMode |
TADScriptStatus |
TADScriptStreamMode |
Unit

uADCompScript Unit

Links
Enumerations, uADCompScript Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADCompScript.TADScriptCommandLookupRes Enumeration

uADCompScript.TADScriptCommandLookupRes Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompScript

Links
Records, Enums
Syntax
TADScriptCommandLookupRes = (
  ucNone,
  ucPartial,
  ucShort,
  ucExact
);


uADCompScript.TADScriptEchoCommands Enumeration

uADCompScript.TADScriptEchoCommands Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompScript

Links
Records, Enums
Syntax
TADScriptEchoCommands = (
  ecNone,
  ecSQL,
  ecAll
);


uADCompScript.TADScriptSpoolOutputMode Enumeration

uADCompScript.TADScriptSpoolOutputMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompScript

Links
Records, Enums
Syntax
TADScriptSpoolOutputMode = (
  smNone,
  smOnReset,
  smOnAppend
);


uADCompScript.TADScriptStatus Enumeration

uADCompScript.TADScriptStatus Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompScript

Links
Records, Enums
Syntax
TADScriptStatus = (
  ssInactive,
  ssValidating,
  ssRunning,
  ssFinishWithErrors,
  ssFinishSuccess,
  ssAborted
);


uADCompScript.TADScriptStreamMode Enumeration

uADCompScript.TADScriptStreamMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADCompScript

Links
Records, Enums
Syntax
TADScriptStreamMode = (
  smRead,
  smWriteReset,
  smWriteAppend
);


Types

Types
uADCompScript Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADCompScript Unit

Types
Name | Description
TADConsoleGetEvent |
TADConsoleLockUpdate |
TADConsolePutEvent |
TADGetStreamEvent |
TADHostCommandEvent |
TADPauseEvent |
TADScriptCharSet |
TADScriptCommandClass |
Links
uADCompScript Unit, Types


uADCompScript.TADConsoleGetEvent Type

uADCompScript.TADConsoleGetEvent Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADConsoleGetEvent = procedure (AEngine: TADScript; const APrompt: String; var AResult: String) of object;


uADCompScript.TADConsoleLockUpdate Type

uADCompScript.TADConsoleLockUpdate Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADConsoleLockUpdate = procedure (AEngine: TADScript; ALock: Boolean) of object;


uADCompScript.TADConsolePutEvent Type

uADCompScript.TADConsolePutEvent Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADConsolePutEvent = procedure (AEngine: TADScript; const AMessage: String; AKind: TADScriptOuputKind) of object;


uADCompScript.TADGetStreamEvent Type

uADCompScript.TADGetStreamEvent Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADGetStreamEvent = procedure (AEngine: TADScript; const AFileName: String; AMode: TADScriptStreamMode; out AStream: TStream) of object;


uADCompScript.TADHostCommandEvent Type

uADCompScript.TADHostCommandEvent Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADHostCommandEvent = procedure (AEngine: TADScript; const ACommand: String; var ADoDefault: Boolean) of object;


uADCompScript.TADPauseEvent Type

uADCompScript.TADPauseEvent Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADPauseEvent = procedure (AEngine: TADScript; const AText: String) of object;


uADCompScript.TADScriptCharSet Type

uADCompScript.TADScriptCharSet Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADScriptCharSet = set of Char;


uADCompScript.TADScriptCommandClass Type

uADCompScript.TADScriptCommandClass Type
Types Send Feedback
Group

Types

File

uADCompScript

Links
Types
Syntax
TADScriptCommandClass = class of TADScriptCommand;


uADStanOption Unit

uADStanOption Unit
Classes Interfaces Legend Topics Types Records, Enums Send Feedback
Classes
Name | Description
TADBottomResourceOptions |
TADBottomUpdateOptions |
TADCustomOptions |
TADFetchOptions | The set of options controlling data and metadata fetching.
TADFormatConversionBuffer |
TADFormatOptions |
TADMapRule |
TADMapRules |
TADResourceOptions |
TADTopResourceOptions |
TADTxOptions |
TADUpdateOptions |
Interfaces
Name | Description
IADStanOptions |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TADFetchItems |
TADFetchOptionValues |
TADFormatOptionValues |
TADOptionChangeEvent |
TADResourceOptionValues |
TADTxStopOptions |
TADTxValues |
TADUpdateOptionValues |
Records, Enums
Name | Description
TADFetchGeneratorsPoint |
TADFetchItem |
TADFetchMode |
TADFetchOptionValue |
TADFormatOptionValue |
TADLockMode |
TADLockPoint |
TADRecordCountMode |
TADRefreshMode |
TADResourceOptionValue |
TADStorageFormat |
TADTxAction |
TADTxIsolation |
TADTxStopOption |
TADTxValue |
TADUpdateOptionValue |
Links
Classes, Interfaces, Legend, Topics, Types, Records, Enums


Classes

Classes
Classes uADStanOption Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADBottomResourceOptions |
TADBottomUpdateOptions |
TADCustomOptions |
TADFetchOptions | The set of options controlling data and metadata fetching.
TADFormatConversionBuffer |
TADFormatOptions |
TADMapRule |
TADMapRules |
TADResourceOptions |
TADTopResourceOptions |
TADTxOptions |
TADUpdateOptions |
Unit

uADStanOption Unit

Links
Classes, uADStanOption Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADBottomResourceOptions Class

TADBottomResourceOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADBottomResourceOptions = class(TADResourceOptions);


public

public
TADBottomResourceOptions Class Legend Public Methods Send Feedback

The public members of the TADBottomResourceOptions class are listed here.

Class

TADBottomResourceOptions Class

Public Methods
Name | Description
Assign |
ResolveFileName |
RestoreDefaults |
Links
TADBottomResourceOptions Class, Legend, Public Methods


TADBottomResourceOptions.Assign Method

TADBottomResourceOptions.Assign Method
TADBottomResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADBottomResourceOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADBottomResourceOptions.ResolveFileName Method

TADBottomResourceOptions.ResolveFileName Method
TADBottomResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADBottomResourceOptions Class, uADStanOption Unit, public
Syntax
function ResolveFileName(const AFileName: string = ''): String;


TADBottomResourceOptions.RestoreDefaults Method

TADBottomResourceOptions.RestoreDefaults Method
TADBottomResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADBottomResourceOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADBottomResourceOptions Class Legend Published Properties Send Feedback

The published members of the TADBottomResourceOptions class are listed here.

Class

TADBottomResourceOptions Class

Published Properties
Name | Description
PersistentFileName |
Links
TADBottomResourceOptions Class, Legend, Published Properties


TADBottomResourceOptions.PersistentFileName Property

TADBottomResourceOptions.PersistentFileName Property
TADBottomResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADBottomResourceOptions Class, uADStanOption Unit, published
Syntax
property PersistentFileName: string;


TADBottomUpdateOptions Class

TADBottomUpdateOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADBottomUpdateOptions = class(TADUpdateOptions);


public

public
TADBottomUpdateOptions Class Legend Public Methods Send Feedback

The public members of the TADBottomUpdateOptions class are listed here.

Class

TADBottomUpdateOptions Class

Public Methods
Name | Description
Assign |
RestoreDefaults |
Links
TADBottomUpdateOptions Class, Legend, Public Methods


TADBottomUpdateOptions.Assign Method

TADBottomUpdateOptions.Assign Method
TADBottomUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADBottomUpdateOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADBottomUpdateOptions.RestoreDefaults Method

TADBottomUpdateOptions.RestoreDefaults Method
TADBottomUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADBottomUpdateOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADBottomUpdateOptions Class Legend Published Properties Send Feedback

The published members of the TADBottomUpdateOptions class are listed here.

Class

TADBottomUpdateOptions Class

Published Properties
Name | Description
AutoIncFields |
KeyFields |
UpdateTableName |
Links
TADBottomUpdateOptions Class, Legend, Published Properties


TADBottomUpdateOptions.AutoIncFields Property

TADBottomUpdateOptions.AutoIncFields Property
TADBottomUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADBottomUpdateOptions Class, uADStanOption Unit, published
Syntax
property AutoIncFields: String;


TADBottomUpdateOptions.KeyFields Property

TADBottomUpdateOptions.KeyFields Property
TADBottomUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADBottomUpdateOptions Class, uADStanOption Unit, published
Syntax
property KeyFields: String;


TADBottomUpdateOptions.UpdateTableName Property

TADBottomUpdateOptions.UpdateTableName Property
TADBottomUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADBottomUpdateOptions Class, uADStanOption Unit, published
Syntax
property UpdateTableName: String;


TADCustomOptions Class

TADCustomOptions Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, Classes
Syntax
TADCustomOptions = class(TPersistent);


public

public
TADCustomOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADCustomOptions class are listed here.

Class

TADCustomOptions Class

Public Methods
Name | Description
BeforeDestruction |
Create |
RestoreDefaults |
Public Properties
Name | Description
Owner |
OwnerObj |
Links
TADCustomOptions Class, Legend, Public Methods, Public Properties


TADCustomOptions.Owner Property

TADCustomOptions.Owner Property
TADCustomOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADCustomOptions Class, uADStanOption Unit, public
Syntax
property Owner: IADStanOptions;


TADCustomOptions.OwnerObj Property

TADCustomOptions.OwnerObj Property
TADCustomOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADCustomOptions Class, uADStanOption Unit, public
Syntax
property OwnerObj: TPersistent;


TADCustomOptions.BeforeDestruction Method

TADCustomOptions.BeforeDestruction Method
TADCustomOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADCustomOptions Class, uADStanOption Unit, public
Syntax
procedure BeforeDestruction; override;


TADCustomOptions.Create Constructor

TADCustomOptions.Create Constructor
TADCustomOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADCustomOptions Class, uADStanOption Unit, public
Syntax
constructor Create(const AOwner: TObject);


TADCustomOptions.RestoreDefaults Method

TADCustomOptions.RestoreDefaults Method
TADCustomOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADCustomOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; virtual;


TADFetchOptions Class

TADFetchOptions Class
public published Classes See Also Send Feedback

The set of options controlling data and metadata fetching.

Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes, See Also
Description

The TADFetchOptions class represents the set of properties controlling how AnyDAC components and Phys Layer command interfaces fetch the data and metadata. For example, it is possible to fetch all result set records at once, or fetch records on demand.

See Setting options for more details.

Syntax
TADFetchOptions = class(TADCustomOptions);
See Also

TADCustomManager.FetchOptions, TADCustomConnection.FetchOptions, TADCustomCommand.FetchOptions, TADQuery.FetchOptions, IADPhysCommand.Options


public

public
TADFetchOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADFetchOptions class are listed here.

Class

TADFetchOptions Class

Public Methods
Name | Description
Assign |
IsValueOwned |
RestoreDefaults |
Public Properties
Name | Description
ActualRowsetSize |
AssignedValues |
Links
TADFetchOptions Class, Legend, Public Methods, Public Properties


TADFetchOptions.ActualRowsetSize Property

TADFetchOptions.ActualRowsetSize Property
TADFetchOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFetchOptions Class, uADStanOption Unit, public
Syntax
property ActualRowsetSize: Integer;


TADFetchOptions.AssignedValues Property

TADFetchOptions.AssignedValues Property
TADFetchOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFetchOptions Class, uADStanOption Unit, public
Syntax
property AssignedValues: TADFetchOptionValues;


TADFetchOptions.Assign Method

TADFetchOptions.Assign Method
TADFetchOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFetchOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADFetchOptions.IsValueOwned Method

TADFetchOptions.IsValueOwned Method
TADFetchOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFetchOptions Class, uADStanOption Unit, public
Syntax
function IsValueOwned(AValue: TADFetchOptionValue; out AParentOpts: IADStanOptions): Boolean;


TADFetchOptions.RestoreDefaults Method

TADFetchOptions.RestoreDefaults Method
TADFetchOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFetchOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADFetchOptions Class Legend Published Properties Send Feedback

The published members of the TADFetchOptions class are listed here.

Class

TADFetchOptions Class

Published Properties
Name | Description
AutoClose | ..
Cache | Controls what kind of data to cache in memory.
Items | Controls what kind of data to fetch.
Mode | Controls how to fetch data.
RecordCountMode | Controls how to count records in resultset.
RecsMax | Controls the maximum number of records to be fetched.
RowsetSize | Controls the number of records per single fetch.
Unidirectional | Specifies possible directions of navigation by dataset records.
Links
TADFetchOptions Class, Legend, Published Properties


TADFetchOptions.AutoClose Property

TADFetchOptions.AutoClose Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

..

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

..

Syntax
property AutoClose: Boolean;
See Also

..


TADFetchOptions.Cache Property

TADFetchOptions.Cache Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls what kind of data to cache in memory.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use Cache property to control what kind of data and metdata to cache in internal data storage.

Option
Description
fiBlobs
If included, then the BLOB field values are not discarded from memory after usage.
fiDetails
If included, then:

  • the nested cursor fields are not discarded from memory after usage;
  • detail dataset records are not discarded from memory after changing master records.

fiMeta
If included, then the command metadata is not discarded from memory after usage.

The default value is [fiBlobs, fiDetails, fiMeta], meaning all data and metadata will be cached after usage.

Syntax
property Cache: TADFetchItems;
See Also

Items

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADFetchOptions.Items Property

TADFetchOptions.Items Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls what kind of data to fetch.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use Items property to control what kind of data and metdata to fetch.

Option
Description
fiBlobs
If included, then the BLOB field values must be fetched together with other record fields in result sets. Otherwise, the fetching will be deferred until BLOB value will be reading.
Option mostly applicapable to AnyDAC components, than to Phys Layer interfaces.
fiDetails
If included, then the nested cursor fields must be fetched together with other record fields in result sets. Otherwise, the fetching will be deferred until nested cursor value will be reading.
Option mostly applicapable to AnyDAC components, than to Phys Layer interfaces.
fiMeta
If included, then the command metadata will be fetched. Otherwise, programmer must supply metadata on your own. The kind of metadata and the point then it will be fetched depends on command kind:

  • TADCustomStoredProc, TADCustomCommand.CommandKind = ckStoredProc, etc. The metadata is description of stored procedure parameters. It will be fetched at Prepare call. If fiMeta is not in Items, then programmer must fill Params collection by your own.
  • TADCustomQuery, TADCustomCommand.CommandKind = ckSelect, etc. The metadata is the set of base table columns, forming the table primary key. It is used to automatically generate updating SQL commands. The metadata will be fetched at Open / Define calls. If fiMeta is not in Items, then programmer must do one of following to specify PK fields:
    • include pfInKey into TField.ProviderFlags for PK fields;
    • set UpdateOptions.KeyFields to the colon separated list of PK field names;
    • include coInKey in TADDatSColumn.Options for PK columns.

The default value is [fiBlobs, fiDetails, fiMeta], meaning all data and metadata will be fetched automatically at proper moments.

Syntax
property Items: TADFetchItems;
See Also

Cache, TField.ProviderFlags, TADBottomUpdateOptions.KeyFields, TADDatSColumn.Options


TADFetchOptions.Mode Property

TADFetchOptions.Mode Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls how to fetch data.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use Mode property to control how the result set records must be fetched into AnyDAC internal data storage.

Mode
Description
fmManual
The records are not fetched automatically by AnyDAC. Programmer must write code to fetch records at required moments, using following methods:

  • TADDataSet.FetchAll to fetch all records;
  • TADDataSet.GetNextPacket to fetch next recordset (packet), containing RowsetSize records;
  • IADPhysCommand.Fetch to fetch all records or next recordset;

fmOnDemand
The records are fetched automatically by AnyDAC, when they are demanded by navigation or other dataset methods. At each demand AnyDAC will fetch one or more recordsets, containing RowsetSize records.
This mode allows to open big resultset without significant delay, like a fmAll mode. But total time of fetching of all records will be more than in fmAll mode. For example, on Microsoft SQL Server will be used server side static cursor.
fmAll
All resultset records are fetched automatically by AnyDAC at dataset Open call or at first IADPhysCommand.Fetch call.
On big resultset it may take time, but then navigation through dataset will be fast, because all records will be stored in AnyDAC internal data storage. For many DBMS's, like a Microsoft SQL Server, MySQL Server, Sybase SQL Anywhere:

  • it releases client resultset buffer and allows to execute next command returning resultsets;
  • gives maximum fetch performance. For example, on Microsoft SQL Server will be used fast forward-only cursor.

fmExactRecsMax
Similar to fmAll, but if amount of records differs from specified in RecsMax, then exception is raised.

The default value is fmOnDemand.

Syntax
property Mode: TADFetchMode;
See Also

TADDataSet.FetchAll, TADDataSet.GetNextPacket, RecsMax, RowsetSize, Unidirectional


TADFetchOptions.RecordCountMode Property

TADFetchOptions.RecordCountMode Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls how to count records in resultset.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use RecordCountMode property to control how the TADDataSet will count number of records in the result set.

Mode | Description
cmVisible | The TDataSet.RecordCount returns number of records accessible through TDataSet navigation interface. This is the total number of fetched records minus total number of deleted and filtered out records. This mode has no overhead, and gives the value sensible for end-user users.
cmFetched | The TDataSet.RecordCount returns number of fetched records to the current moment in time. This mode has no overhead, but gives rather the current wheight of result set, than the value sensible for end-user users.
cmTotal | The TDataSet.RecordCount returns number of records, which will be returned by command. For that AnyDAC issues SELECT COUNT(*) FROM (<original SQL command text>). This mode has significant overhead at dataset opening, but gives nearly exact number of records.

Default value is cmVisible.

Syntax
property RecordCountMode: TADRecordCountMode;
See Also

TDataSet.RecordCount, Mode

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADFetchOptions.RecsMax Property

TADFetchOptions.RecsMax Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls the maximum number of records to be fetched.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use RecsMax to limit number of records to be fetched from single resultset.

AnyDAC returns only first RecsMax records, other records are discarded. The -1 value means - no limit. If combined with Mode = fmExactRecsMax, then AnyDAC raises an exception, if resultset has number of records not equal to RecsMax.

The default value is -1.

Syntax
property RecsMax: Integer;
See Also

Mode. RowsetSize

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADFetchOptions.RowsetSize Property

TADFetchOptions.RowsetSize Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Controls the number of records per single fetch.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use RowsetSize property to set the size of single set of rows, that will be fetched at single fetch operation.

AnyDAC uses underlying DBMS CLI features to optimize resultset fetching. Most of supported DBMS's offers rowset fetching feature, while MySQL Server, Microsoft Access database does not. The rowset fetching allows to transfer from DBMS server to DBMS client few records in single packet at single roundtrip. That raises the fetching performance few times, comparing to fetching by one record per fetch operation and trasmiting single record per roundtrip.

If DBMS does not support rowset fetching, then AnyDAC will emulate it, unifying fetching behaviour across all drivers.

There is significant performance difference between RowsetSize <= 5 and RowsetSize >= 50. But there may be no significant performance difference between RowsetSize ~= 100 and RowsetSize ~= 500, for example. Anyway, you should check what value will be more suitable for your environment.

Syntax
property RowsetSize: Integer;
See Also

Mode, Unidirectional

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADFetchOptions.Unidirectional Property

TADFetchOptions.Unidirectional Property
TADFetchOptions Class uADStanOption Unit published See Also Send Feedback

Specifies possible directions of navigation by dataset records.

Group

published

Links
TADFetchOptions Class, uADStanOption Unit, published, See Also
Description

Use Unidirectional property to specify will application navigate by dataset records in forward-only direction or in forward and backward directions.

Setting Unidirectional to True enables application to navigate in forward-only direction. AnyDAC will automatically discard prior rows from internal data storage after moving current position in dataset, because they are not needed anymore. That dramatically reduces memory consumption on big resultsets.

Notes

Do not use Unidirectional datasets to display data in grid control. It requires bi-directional datasets.

Syntax
property Unidirectional: Boolean;
See Also

RowsetSize, Mode

(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADFormatConversionBuffer Class

TADFormatConversionBuffer Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, Classes
Syntax
TADFormatConversionBuffer = class(TObject);


public

public
TADFormatConversionBuffer Class Legend Public Fields Public Methods Public Properties Send Feedback

The public members of the TADFormatConversionBuffer class are listed here.

Class

TADFormatConversionBuffer Class

Public Fields
Name | Description
FBuffer |
FBufferSize |
Public Methods
Name | Description
Check |
Create |
Destroy |
Extend |
Release |
Public Properties
Name | Description
Ptr |
Size |
Links
TADFormatConversionBuffer Class, Legend, Public Fields, Public Methods, Public Properties


TADFormatConversionBuffer.FBuffer Field

TADFormatConversionBuffer.FBuffer Field
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
FBuffer: Pointer;


TADFormatConversionBuffer.FBufferSize Field

TADFormatConversionBuffer.FBufferSize Field
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
FBufferSize: LongWord;


TADFormatConversionBuffer.Ptr Property

TADFormatConversionBuffer.Ptr Property
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
property Ptr: Pointer;


TADFormatConversionBuffer.Size Property

TADFormatConversionBuffer.Size Property
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
property Size: LongWord;


TADFormatConversionBuffer.Check Method

TADFormatConversionBuffer.Check Method
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
procedure Check(ALen: LongWord = 0);


TADFormatConversionBuffer.Create Constructor

TADFormatConversionBuffer.Create Constructor
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
constructor Create;


TADFormatConversionBuffer.Destroy Destructor

TADFormatConversionBuffer.Destroy Destructor
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
destructor Destroy; override;


TADFormatConversionBuffer.Extend Method

TADFormatConversionBuffer.Extend Method
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
procedure Extend(ASrcDataLen: LongWord; var ADestDataLen: LongWord; ASrcType: TADDataType; ADestType: TADDataType);


TADFormatConversionBuffer.Release Method

TADFormatConversionBuffer.Release Method
TADFormatConversionBuffer Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatConversionBuffer Class, uADStanOption Unit, public
Syntax
procedure Release;


TADFormatOptions Class

TADFormatOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADFormatOptions = class(TADCustomOptions);


public

public
TADFormatOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADFormatOptions class are listed here.

Class

TADFormatOptions Class

Public Methods
Name | Description
Assign |
CheckConversion |
ColumnDef2FieldDef |
ConvertRawData |
Create |
Destroy |
FieldDef2ColumnDef |
IsValueOwned |
ResolveDataType |
ResolveFieldType |
RestoreDefaults |
Public Properties
Name | Description
AssignedValues |
StrsDivLen2 |
Links
TADFormatOptions Class, Legend, Public Methods, Public Properties


TADFormatOptions.AssignedValues Property

TADFormatOptions.AssignedValues Property
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
property AssignedValues: TADFormatOptionValues;


TADFormatOptions.StrsDivLen2 Property

TADFormatOptions.StrsDivLen2 Property
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
property StrsDivLen2: Boolean;


TADFormatOptions.Assign Method

TADFormatOptions.Assign Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADFormatOptions.CheckConversion Method

TADFormatOptions.CheckConversion Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure CheckConversion(ASrc: TADDataType; ADest: TADDataType);


TADFormatOptions.ColumnDef2FieldDef Method

TADFormatOptions.ColumnDef2FieldDef Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure ColumnDef2FieldDef(ASrcDataType: TADDataType; ASrcScale: Integer; ASrcPrec: Integer; ASrcSize: LongWord; ASrcAttrs: TADDataAttributes; var ADestFieldType: TFieldType; var ADestSize: LongWord; var ADestPrec: Integer);


TADFormatOptions.ConvertRawData Method

TADFormatOptions.ConvertRawData Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure ConvertRawData(ASrcType: TADDataType; ADestType: TADDataType; ApSrc: Pointer; ASrcSize: LongWord; var ApDest: Pointer; ADestMaxSize: LongWord; var ADestSize: LongWord);


TADFormatOptions.Create Constructor

TADFormatOptions.Create Constructor
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
constructor Create(const AOwner: TObject);


TADFormatOptions.Destroy Destructor

TADFormatOptions.Destroy Destructor
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
destructor Destroy; override;


TADFormatOptions.FieldDef2ColumnDef Method

TADFormatOptions.FieldDef2ColumnDef Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
class procedure FieldDef2ColumnDef(ASrcFieldType: TFieldType; ASrcSize: LongWord; ASrcPrec: Integer; var ADestDataType: TADDataType; var ADestScale: Integer; var ADestPrec: Integer; var ADestSize: LongWord; var ADestAttrs: TADDataAttributes);


TADFormatOptions.IsValueOwned Method

TADFormatOptions.IsValueOwned Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
function IsValueOwned(AValue: TADFormatOptionValue; out AParentOpts: IADStanOptions): Boolean;


TADFormatOptions.ResolveDataType Method

TADFormatOptions.ResolveDataType Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure ResolveDataType(ASrcDataType: TADDataType; ASrcSize: LongWord; ASrcPrec: Integer; ASrcScale: Integer; var ADestDataType: TADDataType; AForward: Boolean);


TADFormatOptions.ResolveFieldType Method

TADFormatOptions.ResolveFieldType Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure ResolveFieldType(ASrcFieldType: TFieldType; ASrcADFieldType: TADDataType; ASrcSize: LongWord; ASrcPrecision: Integer; var ADestFieldType: TFieldType; var ADestSize: LongWord; var ADestPrecision: Integer; var ASrcDataType: TADDataType; var ADestDataType: TADDataType; AForward: Boolean);


TADFormatOptions.RestoreDefaults Method

TADFormatOptions.RestoreDefaults Method
TADFormatOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADFormatOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADFormatOptions Class Legend Published Properties Send Feedback

The published members of the TADFormatOptions class are listed here.

Class

TADFormatOptions Class

Published Properties
Name | Description
DefaultParamDataType |
InlineDataSize |
MapRules |
MaxBcdPrecision |
MaxBcdScale |
MaxStringSize |
OwnMapRules |
StrsEmpty2Null |
StrsTrim |
Links
TADFormatOptions Class, Legend, Published Properties


TADFormatOptions.DefaultParamDataType Property

TADFormatOptions.DefaultParamDataType Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property DefaultParamDataType: TFieldType;


TADFormatOptions.InlineDataSize Property

TADFormatOptions.InlineDataSize Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property InlineDataSize: Integer;


TADFormatOptions.MapRules Property

TADFormatOptions.MapRules Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property MapRules: TADMapRules;


TADFormatOptions.MaxBcdPrecision Property

TADFormatOptions.MaxBcdPrecision Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property MaxBcdPrecision: Integer;


TADFormatOptions.MaxBcdScale Property

TADFormatOptions.MaxBcdScale Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property MaxBcdScale: Integer;


TADFormatOptions.MaxStringSize Property

TADFormatOptions.MaxStringSize Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property MaxStringSize: LongWord;


TADFormatOptions.OwnMapRules Property

TADFormatOptions.OwnMapRules Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property OwnMapRules: Boolean;


TADFormatOptions.StrsEmpty2Null Property

TADFormatOptions.StrsEmpty2Null Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property StrsEmpty2Null: Boolean;


TADFormatOptions.StrsTrim Property

TADFormatOptions.StrsTrim Property
TADFormatOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADFormatOptions Class, uADStanOption Unit, published
Syntax
property StrsTrim: Boolean;


TADMapRule Class

TADMapRule Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADMapRule = class(TCollectionItem);


public

public
TADMapRule Class Legend Public Methods Send Feedback

The public members of the TADMapRule class are listed here.

Class

TADMapRule Class

Public Methods
Name | Description
Assign |
Create |
Links
TADMapRule Class, Legend, Public Methods
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMapRule.Assign Method

TADMapRule.Assign Method
TADMapRule Class uADStanOption Unit public Send Feedback
Group

public

Links
TADMapRule Class, uADStanOption Unit, public
Syntax
procedure Assign(Source: TPersistent); override;


TADMapRule.Create Constructor

TADMapRule.Create Constructor
TADMapRule Class uADStanOption Unit public Send Feedback
Group

public

Links
TADMapRule Class, uADStanOption Unit, public
Syntax
constructor Create(Collection: TCollection); override;


published

published
TADMapRule Class Legend Published Properties Send Feedback

The published members of the TADMapRule class are listed here.

Class

TADMapRule Class

Published Properties
Name | Description
PrecMax |
PrecMin |
ScaleMax |
ScaleMin |
SizeMax |
SizeMin |
SourceDataType |
TargetDataType |
Links
TADMapRule Class, Legend, Published Properties


TADMapRule.PrecMax Property

TADMapRule.PrecMax Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property PrecMax: Integer;


TADMapRule.PrecMin Property

TADMapRule.PrecMin Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property PrecMin: Integer;


TADMapRule.ScaleMax Property

TADMapRule.ScaleMax Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property ScaleMax: Integer;


TADMapRule.ScaleMin Property

TADMapRule.ScaleMin Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property ScaleMin: Integer;


TADMapRule.SizeMax Property

TADMapRule.SizeMax Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property SizeMax: LongWord;


TADMapRule.SizeMin Property

TADMapRule.SizeMin Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property SizeMin: LongWord;


TADMapRule.SourceDataType Property

TADMapRule.SourceDataType Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property SourceDataType: TADDataType;


TADMapRule.TargetDataType Property

TADMapRule.TargetDataType Property
TADMapRule Class uADStanOption Unit published Send Feedback
Group

published

Links
TADMapRule Class, uADStanOption Unit, published
Syntax
property TargetDataType: TADDataType;


TADMapRules Class

TADMapRules Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, Classes
Syntax
TADMapRules = class(TCollection);


public

public
TADMapRules Class Legend Public Methods Public Properties Send Feedback

The public members of the TADMapRules class are listed here.

Class

TADMapRules Class

Public Methods
Name | Description
Add |
Create |
Public Properties
Name | Description
Items |
Links
TADMapRules Class, Legend, Public Methods, Public Properties


TADMapRules.Items Property

TADMapRules.Items Property
TADMapRules Class uADStanOption Unit public Send Feedback
Group

public

Links
TADMapRules Class, uADStanOption Unit, public
Syntax
property Items [AIndex: Integer]: TADMapRule;


TADMapRules.Add Method

TADMapRules.Add Method
TADMapRules Class uADStanOption Unit public Send Feedback
Group

public

Links
TADMapRules Class, uADStanOption Unit, public
Syntax
function Add: TADMapRule;


TADMapRules.Create Constructor

TADMapRules.Create Constructor
TADMapRules Class uADStanOption Unit public Send Feedback
Group

public

Links
TADMapRules Class, uADStanOption Unit, public
Syntax
constructor Create(AFormatOptions: TADFormatOptions);


TADResourceOptions Class

TADResourceOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADResourceOptions = class(TADCustomOptions);


public

public
TADResourceOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADResourceOptions class are listed here.

Class

TADResourceOptions Class

Public Methods
Name | Description
Assign |
IsValueOwned |
RestoreDefaults |
Public Properties
Name | Description
ActualSilentMode |
AssignedValues |
BackupExt |
BackupFolder |
DefaultStoreExt |
DefaultStoreFolder |
DefaultStoreFormat |
PreprocessCmdText |
Links
TADResourceOptions Class, Legend, Public Methods, Public Properties


TADResourceOptions.ActualSilentMode Property

TADResourceOptions.ActualSilentMode Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property ActualSilentMode: Boolean;


TADResourceOptions.AssignedValues Property

TADResourceOptions.AssignedValues Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property AssignedValues: TADResourceOptionValues;


TADResourceOptions.BackupExt Property

TADResourceOptions.BackupExt Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property BackupExt: String;


TADResourceOptions.BackupFolder Property

TADResourceOptions.BackupFolder Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property BackupFolder: String;


TADResourceOptions.DefaultStoreExt Property

TADResourceOptions.DefaultStoreExt Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property DefaultStoreExt: String;


TADResourceOptions.DefaultStoreFolder Property

TADResourceOptions.DefaultStoreFolder Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property DefaultStoreFolder: String;


TADResourceOptions.DefaultStoreFormat Property

TADResourceOptions.DefaultStoreFormat Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property DefaultStoreFormat: TADStorageFormat;


TADResourceOptions.PreprocessCmdText Property

TADResourceOptions.PreprocessCmdText Property
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
property PreprocessCmdText: Boolean;


TADResourceOptions.Assign Method

TADResourceOptions.Assign Method
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADResourceOptions.IsValueOwned Method

TADResourceOptions.IsValueOwned Method
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
function IsValueOwned(AValue: TADResourceOptionValue; out AParentOpts: IADStanOptions): Boolean;


TADResourceOptions.RestoreDefaults Method

TADResourceOptions.RestoreDefaults Method
TADResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADResourceOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADResourceOptions Class Legend Published Properties Send Feedback

The published members of the TADResourceOptions class are listed here.

Class

TADResourceOptions Class

Published Properties
Name | Description
ArrayDMLSize |
AutoManage |
Backup |
CmdExecMode |
CmdExecTimeout |
DefaultParamType |
DirectExecute |
EscapeExpand |
MacroCreate |
MacroExpand |
ParamCreate |
ParamExpand |
Persistent |
SilentMode |
Links
TADResourceOptions Class, Legend, Published Properties


TADResourceOptions.ArrayDMLSize Property

TADResourceOptions.ArrayDMLSize Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property ArrayDMLSize: Integer;


TADResourceOptions.AutoManage Property

TADResourceOptions.AutoManage Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property AutoManage: Boolean;


TADResourceOptions.Backup Property

TADResourceOptions.Backup Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property Backup: Boolean;


TADResourceOptions.CmdExecMode Property

TADResourceOptions.CmdExecMode Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property CmdExecMode: TADStanAsyncMode;


TADResourceOptions.CmdExecTimeout Property

TADResourceOptions.CmdExecTimeout Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property CmdExecTimeout: LongWord;


TADResourceOptions.DefaultParamType Property

TADResourceOptions.DefaultParamType Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property DefaultParamType: TParamType;


TADResourceOptions.DirectExecute Property

TADResourceOptions.DirectExecute Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property DirectExecute: Boolean;


TADResourceOptions.EscapeExpand Property

TADResourceOptions.EscapeExpand Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property EscapeExpand: Boolean;


TADResourceOptions.MacroCreate Property

TADResourceOptions.MacroCreate Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property MacroCreate: Boolean;


TADResourceOptions.MacroExpand Property

TADResourceOptions.MacroExpand Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property MacroExpand: Boolean;


TADResourceOptions.ParamCreate Property

TADResourceOptions.ParamCreate Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property ParamCreate: Boolean;


TADResourceOptions.ParamExpand Property

TADResourceOptions.ParamExpand Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property ParamExpand: Boolean;


TADResourceOptions.Persistent Property

TADResourceOptions.Persistent Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property Persistent: Boolean;


TADResourceOptions.SilentMode Property

TADResourceOptions.SilentMode Property
TADResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADResourceOptions Class, uADStanOption Unit, published
Syntax
property SilentMode: Boolean;


TADTopResourceOptions Class

TADTopResourceOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADTopResourceOptions = class(TADResourceOptions);


public

public
TADTopResourceOptions Class Legend Public Methods Send Feedback

The public members of the TADTopResourceOptions class are listed here.

Class

TADTopResourceOptions Class

Public Methods
Name | Description
Assign |
RestoreDefaults |
Links
TADTopResourceOptions Class, Legend, Public Methods


TADTopResourceOptions.Assign Method

TADTopResourceOptions.Assign Method
TADTopResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTopResourceOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADTopResourceOptions.RestoreDefaults Method

TADTopResourceOptions.RestoreDefaults Method
TADTopResourceOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTopResourceOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADTopResourceOptions Class Legend Published Properties Send Feedback

The published members of the TADTopResourceOptions class are listed here.

Class

TADTopResourceOptions Class

Published Properties
Name | Description
AutoReconnect |
BackupExt |
BackupFolder |
DefaultStoreExt |
DefaultStoreFolder |
DefaultStoreFormat |
MaxCursors |
ServerOutput |
ServerOutputSize |
Links
TADTopResourceOptions Class, Legend, Published Properties


TADTopResourceOptions.AutoReconnect Property

TADTopResourceOptions.AutoReconnect Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property AutoReconnect: Boolean;


TADTopResourceOptions.BackupExt Property

TADTopResourceOptions.BackupExt Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property BackupExt: String;


TADTopResourceOptions.BackupFolder Property

TADTopResourceOptions.BackupFolder Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property BackupFolder: String;


TADTopResourceOptions.DefaultStoreExt Property

TADTopResourceOptions.DefaultStoreExt Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property DefaultStoreExt: String;


TADTopResourceOptions.DefaultStoreFolder Property

TADTopResourceOptions.DefaultStoreFolder Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property DefaultStoreFolder: String;


TADTopResourceOptions.DefaultStoreFormat Property

TADTopResourceOptions.DefaultStoreFormat Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property DefaultStoreFormat: TADStorageFormat;


TADTopResourceOptions.MaxCursors Property

TADTopResourceOptions.MaxCursors Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property MaxCursors: Integer;


TADTopResourceOptions.ServerOutput Property

TADTopResourceOptions.ServerOutput Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property ServerOutput: Boolean;


TADTopResourceOptions.ServerOutputSize Property

TADTopResourceOptions.ServerOutputSize Property
TADTopResourceOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTopResourceOptions Class, uADStanOption Unit, published
Syntax
property ServerOutputSize: Integer;


TADTxOptions Class

TADTxOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADTxOptions = class(TPersistent);


public

public
TADTxOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADTxOptions class are listed here.

Class

TADTxOptions Class

Public Methods
Name | Description
Assign |
ClearChanged |
Create |
Destroy |
Public Properties
Name | Description
Changed |
Links
TADTxOptions Class, Legend, Public Methods, Public Properties


TADTxOptions.Changed Property

TADTxOptions.Changed Property
TADTxOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTxOptions Class, uADStanOption Unit, public
Syntax
property Changed: TADTxValues;


TADTxOptions.Assign Method

TADTxOptions.Assign Method
TADTxOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTxOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADTxOptions.ClearChanged Method

TADTxOptions.ClearChanged Method
TADTxOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTxOptions Class, uADStanOption Unit, public
Syntax
procedure ClearChanged;


TADTxOptions.Create Constructor

TADTxOptions.Create Constructor
TADTxOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTxOptions Class, uADStanOption Unit, public
Syntax
constructor Create;


TADTxOptions.Destroy Destructor

TADTxOptions.Destroy Destructor
TADTxOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADTxOptions Class, uADStanOption Unit, public
Syntax
destructor Destroy; override;


published

published
TADTxOptions Class Legend Published Properties Send Feedback

The published members of the TADTxOptions class are listed here.

Class

TADTxOptions Class

Published Properties
Name | Description
AutoCommit |
AutoStart |
AutoStop |
DisconnectAction |
Isolation |
Params |
ReadOnly |
StopOptions |
Links
TADTxOptions Class, Legend, Published Properties


TADTxOptions.AutoCommit Property

TADTxOptions.AutoCommit Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property AutoCommit: Boolean;


TADTxOptions.AutoStart Property

TADTxOptions.AutoStart Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property AutoStart: Boolean;


TADTxOptions.AutoStop Property

TADTxOptions.AutoStop Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property AutoStop: Boolean;


TADTxOptions.DisconnectAction Property

TADTxOptions.DisconnectAction Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property DisconnectAction: TADTxAction;


TADTxOptions.Isolation Property

TADTxOptions.Isolation Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property Isolation: TADTxIsolation;


TADTxOptions.Params Property

TADTxOptions.Params Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property Params: TStrings;


TADTxOptions.ReadOnly Property

TADTxOptions.ReadOnly Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property ReadOnly: Boolean;


TADTxOptions.StopOptions Property

TADTxOptions.StopOptions Property
TADTxOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADTxOptions Class, uADStanOption Unit, published
Syntax
property StopOptions: TADTxStopOptions;


TADUpdateOptions Class

TADUpdateOptions Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanOption

Links
public, published, Classes
Syntax
TADUpdateOptions = class(TADCustomOptions);


public

public
TADUpdateOptions Class Legend Public Methods Public Properties Send Feedback

The public members of the TADUpdateOptions class are listed here.

Class

TADUpdateOptions Class

Public Methods
Name | Description
Assign |
IsValueOwned |
RestoreDefaults |
Public Properties
Name | Description
AssignedValues |
Links
TADUpdateOptions Class, Legend, Public Methods, Public Properties


TADUpdateOptions.AssignedValues Property

TADUpdateOptions.AssignedValues Property
TADUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADUpdateOptions Class, uADStanOption Unit, public
Syntax
property AssignedValues: TADUpdateOptionValues;


TADUpdateOptions.Assign Method

TADUpdateOptions.Assign Method
TADUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADUpdateOptions Class, uADStanOption Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADUpdateOptions.IsValueOwned Method

TADUpdateOptions.IsValueOwned Method
TADUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADUpdateOptions Class, uADStanOption Unit, public
Syntax
function IsValueOwned(AValue: TADUpdateOptionValue; out AParentOpts: IADStanOptions): Boolean;


TADUpdateOptions.RestoreDefaults Method

TADUpdateOptions.RestoreDefaults Method
TADUpdateOptions Class uADStanOption Unit public Send Feedback
Group

public

Links
TADUpdateOptions Class, uADStanOption Unit, public
Syntax
procedure RestoreDefaults; override;


published

published
TADUpdateOptions Class Legend Published Properties Send Feedback

The published members of the TADUpdateOptions class are listed here.

Class

TADUpdateOptions Class

Published Properties
Name | Description
CacheUpdateCommands |
CountUpdatedRecords |
EnableDelete |
EnableInsert |
EnableUpdate |
FastUpdates |
FetchGeneratorsPoint |
GeneratorName |
LockMode |
LockPoint |
LockWait |
ReadOnly |
RefreshMode |
RequestLive |
UpdateChangedFields |
UpdateMode |
UseProviderFlags |
Links
TADUpdateOptions Class, Legend, Published Properties


TADUpdateOptions.CacheUpdateCommands Property

TADUpdateOptions.CacheUpdateCommands Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property CacheUpdateCommands: Boolean;


TADUpdateOptions.CountUpdatedRecords Property

TADUpdateOptions.CountUpdatedRecords Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property CountUpdatedRecords: Boolean;


TADUpdateOptions.EnableDelete Property

TADUpdateOptions.EnableDelete Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property EnableDelete: Boolean;


TADUpdateOptions.EnableInsert Property

TADUpdateOptions.EnableInsert Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property EnableInsert: Boolean;


TADUpdateOptions.EnableUpdate Property

TADUpdateOptions.EnableUpdate Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property EnableUpdate: Boolean;


TADUpdateOptions.FastUpdates Property

TADUpdateOptions.FastUpdates Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property FastUpdates: Boolean;


TADUpdateOptions.FetchGeneratorsPoint Property

TADUpdateOptions.FetchGeneratorsPoint Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property FetchGeneratorsPoint: TADFetchGeneratorsPoint;


TADUpdateOptions.GeneratorName Property

TADUpdateOptions.GeneratorName Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property GeneratorName: String;


TADUpdateOptions.LockMode Property

TADUpdateOptions.LockMode Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property LockMode: TADLockMode;


TADUpdateOptions.LockPoint Property

TADUpdateOptions.LockPoint Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property LockPoint: TADLockPoint;


TADUpdateOptions.LockWait Property

TADUpdateOptions.LockWait Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property LockWait: Boolean;


TADUpdateOptions.ReadOnly Property

TADUpdateOptions.ReadOnly Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property ReadOnly: Boolean;


TADUpdateOptions.RefreshMode Property

TADUpdateOptions.RefreshMode Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property RefreshMode: TADRefreshMode;


TADUpdateOptions.RequestLive Property

TADUpdateOptions.RequestLive Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property RequestLive: Boolean;


TADUpdateOptions.UpdateChangedFields Property

TADUpdateOptions.UpdateChangedFields Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property UpdateChangedFields: Boolean;


TADUpdateOptions.UpdateMode Property

TADUpdateOptions.UpdateMode Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property UpdateMode: TUpdateMode;


TADUpdateOptions.UseProviderFlags Property

TADUpdateOptions.UseProviderFlags Property
TADUpdateOptions Class uADStanOption Unit published Send Feedback
Group

published

Links
TADUpdateOptions Class, uADStanOption Unit, published
Syntax
property UseProviderFlags: Boolean;


Interfaces

Interfaces
uADStanOption Unit Interfaces Legend Send Feedback

The following table lists interfaces in this documentation.

Unit

uADStanOption Unit

Interfaces
Name | Description
IADStanOptions |
Links
uADStanOption Unit, Interfaces, Legend


IADStanOptions Interface

IADStanOptions Interface
public Interfaces Send Feedback
Group

Interfaces

Class Hierarchy
File

uADStanOption

Links
public, Interfaces
Syntax
IADStanOptions = interface(IUnknown);


public

public
IADStanOptions Interface Legend Public Methods Public Properties Send Feedback

The public members of the IADStanOptions class are listed here.

Interface

IADStanOptions Interface

Public Methods
Name | Description
GetFetchOptions |
GetFormatOptions |
GetParentOptions |
GetResourceOptions |
GetUpdateOptions |
Public Properties
Name | Description
FetchOptions |
FormatOptions |
ResourceOptions |
UpdateOptions |
Links
IADStanOptions Interface, Legend, Public Methods, Public Properties


IADStanOptions.FetchOptions Property

IADStanOptions.FetchOptions Property
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
property FetchOptions: TADFetchOptions;


IADStanOptions.FormatOptions Property

IADStanOptions.FormatOptions Property
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
property FormatOptions: TADFormatOptions;


IADStanOptions.ResourceOptions Property

IADStanOptions.ResourceOptions Property
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
property ResourceOptions: TADResourceOptions;


IADStanOptions.UpdateOptions Property

IADStanOptions.UpdateOptions Property
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
property UpdateOptions: TADUpdateOptions;


IADStanOptions.GetFetchOptions Method

IADStanOptions.GetFetchOptions Method
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
function GetFetchOptions: TADFetchOptions;


IADStanOptions.GetFormatOptions Method

IADStanOptions.GetFormatOptions Method
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
function GetFormatOptions: TADFormatOptions;


IADStanOptions.GetParentOptions Method

IADStanOptions.GetParentOptions Method
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
function GetParentOptions(out AOpts: IADStanOptions): Boolean;


IADStanOptions.GetResourceOptions Method

IADStanOptions.GetResourceOptions Method
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
function GetResourceOptions: TADResourceOptions;


IADStanOptions.GetUpdateOptions Method

IADStanOptions.GetUpdateOptions Method
IADStanOptions Interface uADStanOption Unit public Send Feedback
Group

public

Links
IADStanOptions Interface, uADStanOption Unit, public
Syntax
function GetUpdateOptions: TADUpdateOptions;


Records, Enums

Records, Enums
Enumerations uADStanOption Unit Legend Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADFetchGeneratorsPoint |
TADFetchItem |
TADFetchMode |
TADFetchOptionValue |
TADFormatOptionValue |
TADLockMode |
TADLockPoint |
TADRecordCountMode |
TADRefreshMode |
TADResourceOptionValue |
TADStorageFormat |
TADTxAction |
TADTxIsolation |
TADTxStopOption |
TADTxValue |
TADUpdateOptionValue |
Unit

uADStanOption Unit

Links
Enumerations, uADStanOption Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADStanOption.TADFetchGeneratorsPoint Enumeration

uADStanOption.TADFetchGeneratorsPoint Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADFetchGeneratorsPoint = (
  gpNone,
  gpImmediate,
  gpDeferred
);


uADStanOption.TADFetchItem Enumeration

uADStanOption.TADFetchItem Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADFetchItem = (
  fiBlobs,
  fiDetails,
  fiMeta
);


uADStanOption.TADFetchMode Enumeration

uADStanOption.TADFetchMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADFetchMode = (
  fmManual,
  fmOnDemand,
  fmAll,
  fmExactRecsMax
);


uADStanOption.TADFetchOptionValue Enumeration

uADStanOption.TADFetchOptionValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADFetchOptionValue = (
  evMode,
  evItems,
  evRecsMax,
  evRowsetSize,
  evCache,
  evAutoClose,
  evRecordCountMode,
  evUnidirectional
);


uADStanOption.TADFormatOptionValue Enumeration

uADStanOption.TADFormatOptionValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADFormatOptionValue = (
  fvMapRules,
  fvSE2Null,
  fvStrsTrim,
  fvStrsDivLen2,
  fvMaxStringSize,
  fvMaxBcdPrecision,
  fvMaxBcdScale,
  fvInlineDataSize,
  fvDefaultParamDataType
);


uADStanOption.TADLockMode Enumeration

uADStanOption.TADLockMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADLockMode = (
  lmNone,
  lmPessimistic,
  lmOptimistic
);


uADStanOption.TADLockPoint Enumeration

uADStanOption.TADLockPoint Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADLockPoint = (
  lpImmediate,
  lpDeferred
);


uADStanOption.TADRecordCountMode Enumeration

uADStanOption.TADRecordCountMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADRecordCountMode = (
  cmVisible,
  cmFetched,
  cmTotal
);


uADStanOption.TADRefreshMode Enumeration

uADStanOption.TADRefreshMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADRefreshMode = (
  rmManual,
  rmOnDemand,
  rmAll
);


uADStanOption.TADResourceOptionValue Enumeration

uADStanOption.TADResourceOptionValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADResourceOptionValue = (
  rvParamCreate,
  rvMacroCreate,
  rvMacroExpand,
  rvParamExpand,
  rvEscapeExpand,
  rvAutoManage,
  rvMaxCursors,
  rvCmdExecMode,
  rvCmdExecTimeout,
  rvDirectExecute,
  rvDefaultParamType,
  rvServerOutput,
  rvServerOutputSize,
  rvPersistent,
  rvBackup,
  rvDefaultStoreFolder,
  rvDefaultStoreFormat,
  rvBackupFolder,
  rvDefaultStoreExt,
  rvBackupExt,
  rvAutoReconnect,
  rvArrayDMLSize,
  rvSilentMode
);


uADStanOption.TADStorageFormat Enumeration

uADStanOption.TADStorageFormat Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADStorageFormat = (
  sfAuto,
  sfXML,
  sfBinary
);


uADStanOption.TADTxAction Enumeration

uADStanOption.TADTxAction Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADTxAction = (
  xdNone,
  xdCommit,
  xdRollback
);


uADStanOption.TADTxIsolation Enumeration

uADStanOption.TADTxIsolation Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADTxIsolation = (
  xiUnspecified,
  xiDirtyRead,
  xiReadCommitted,
  xiRepeatableRead,
  xiSerializible
);


uADStanOption.TADTxStopOption Enumeration

uADStanOption.TADTxStopOption Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADTxStopOption = (
  xoIfCmdsInactive,
  xoIfAutoStarted,
  xoFinishRetaining
);


uADStanOption.TADTxValue Enumeration

uADStanOption.TADTxValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADTxValue = (
  xoIsolation,
  xoReadOnly,
  xoParams,
  xoAutoStart,
  xoAutoStop,
  xoStopOptions,
  xoAutoCommit
);


uADStanOption.TADUpdateOptionValue Enumeration

uADStanOption.TADUpdateOptionValue Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanOption

Links
Records, Enums
Syntax
TADUpdateOptionValue = (
  uvEDelete,
  uvEInsert,
  uvEUpdate,
  uvUpdateChngFields,
  uvUpdateMode,
  uvLockMode,
  uvLockPoint,
  uvLockWait,
  uvRefreshMode,
  uvCountUpdatedRecords,
  uvCacheUpdateCommands,
  uvUseProviderFlags,
  uvFetchGeneratorsPoint,
  uvGeneratorName
);


Types

Types
uADStanOption Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADStanOption Unit

Types
Name | Description
TADFetchItems |
TADFetchOptionValues |
TADFormatOptionValues |
TADOptionChangeEvent |
TADResourceOptionValues |
TADTxStopOptions |
TADTxValues |
TADUpdateOptionValues |
Links
uADStanOption Unit, Types


uADStanOption.TADFetchItems Type

uADStanOption.TADFetchItems Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADFetchItems = set of TADFetchItem;


uADStanOption.TADFetchOptionValues Type

uADStanOption.TADFetchOptionValues Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADFetchOptionValues = set of TADFetchOptionValue;


uADStanOption.TADFormatOptionValues Type

uADStanOption.TADFormatOptionValues Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADFormatOptionValues = set of TADFormatOptionValue;


uADStanOption.TADOptionChangeEvent Type

uADStanOption.TADOptionChangeEvent Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADOptionChangeEvent = procedure (AOptions: TADCustomOptions) of object;


uADStanOption.TADResourceOptionValues Type

uADStanOption.TADResourceOptionValues Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADResourceOptionValues = set of TADResourceOptionValue;


uADStanOption.TADTxStopOptions Type

uADStanOption.TADTxStopOptions Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADTxStopOptions = set of TADTxStopOption;


uADStanOption.TADTxValues Type

uADStanOption.TADTxValues Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADTxValues = set of TADTxValue;


uADStanOption.TADUpdateOptionValues Type

uADStanOption.TADUpdateOptionValues Type
Types Send Feedback
Group

Types

File

uADStanOption

Links
Types
Syntax
TADUpdateOptionValues = set of TADUpdateOptionValue;


uADStanParam Unit

uADStanParam Unit
Classes Functions Legend Topics Types Records, Enums Send Feedback
Classes
Name | Description
TADMacro |
TADMacros |
TADParam |
TADParams |
Functions
Name | Description
ADVar2SQL |
ADVar2SQLTyped |
ADVarType2FieldType |
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.
Types
Name | Description
TADGetOwner |
Records, Enums
Name | Description
TADMacroDataType |
TADParamArrayType |
TADParamBindMode |
Links
Classes, Functions, Legend, Topics, Types, Records, Enums


Classes

Classes
Classes uADStanParam Unit Legend Send Feedback

The following table lists classes in this documentation.

Classes
Name | Description
TADMacro |
TADMacros |
TADParam |
TADParams |
Unit

uADStanParam Unit

Links
Classes, uADStanParam Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


TADMacro Class

TADMacro Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanParam

Links
public, published, Classes
Syntax
TADMacro = class(TCollectionItem);


public

public
TADMacro Class Legend Public Methods Public Properties Send Feedback

The public members of the TADMacro class are listed here.

Class

TADMacro Class

Public Methods
Name | Description
Assign |
Clear |
Create |
IsEqual |
Public Properties
Name | Description
AsDate |
AsDateTime |
AsFloat |
AsIdentifier |
AsInteger |
AsRaw |
AsString |
AsTime |
CollectionOwner |
IsNull |
SQL |
Links
TADMacro Class, Legend, Public Methods, Public Properties


TADMacro.AsDate Property

TADMacro.AsDate Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsDate: TDateTime;


TADMacro.AsDateTime Property

TADMacro.AsDateTime Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsDateTime: TDateTime;


TADMacro.AsFloat Property

TADMacro.AsFloat Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsFloat: Double;


TADMacro.AsIdentifier Property

TADMacro.AsIdentifier Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsIdentifier: String;


TADMacro.AsInteger Property

TADMacro.AsInteger Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsInteger: Integer;


TADMacro.AsRaw Property

TADMacro.AsRaw Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsRaw: String;


TADMacro.AsString Property

TADMacro.AsString Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsString: String;


TADMacro.AsTime Property

TADMacro.AsTime Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property AsTime: TDateTime;


TADMacro.CollectionOwner Property

TADMacro.CollectionOwner Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property CollectionOwner: TPersistent;


TADMacro.IsNull Property

TADMacro.IsNull Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property IsNull: Boolean;


TADMacro.SQL Property

TADMacro.SQL Property
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
property SQL: String;


TADMacro.Assign Method

TADMacro.Assign Method
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
procedure Assign(AValue: TPersistent); override;


TADMacro.Clear Method

TADMacro.Clear Method
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
procedure Clear;


TADMacro.Create Constructor

TADMacro.Create Constructor
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
constructor Create(Collection: TCollection); override;


TADMacro.IsEqual Method

TADMacro.IsEqual Method
TADMacro Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacro Class, uADStanParam Unit, public
Syntax
function IsEqual(AValue: TADMacro): Boolean;


published

published
TADMacro Class Legend Published Properties Send Feedback

The published members of the TADMacro class are listed here.

Class

TADMacro Class

Published Properties
Name | Description
DataType |
Name |
Value |
Links
TADMacro Class, Legend, Published Properties


TADMacro.DataType Property

TADMacro.DataType Property
TADMacro Class uADStanParam Unit published Send Feedback
Group

published

Links
TADMacro Class, uADStanParam Unit, published
Syntax
property DataType: TADMacroDataType;


TADMacro.Name Property

TADMacro.Name Property
TADMacro Class uADStanParam Unit published Send Feedback
Group

published

Links
TADMacro Class, uADStanParam Unit, published
Syntax
property Name: String;


TADMacro.Value Property

TADMacro.Value Property
TADMacro Class uADStanParam Unit published Send Feedback
Group

published

Links
TADMacro Class, uADStanParam Unit, published
Syntax
property Value: Variant;


TADMacros Class

TADMacros Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanParam

Links
public, Classes
Syntax
TADMacros = class(TCollection);


public

public
TADMacros Class Legend Public Events Public Methods Public Properties Send Feedback

The public members of the TADMacros class are listed here.

Class

TADMacros Class

Public Events
Name | Description
OnChanged |
Public Methods
Name | Description
Add |
AddRef |
Assign |
AssignValues |
Create |
CreateRefCounted |
Destroy |
EndUpdate |
FindMacro |
IsEqual |
MacroByName |
RemRef |
TempLockUpdate |
Public Properties
Name | Description
Command |
IsRefCounted |
Items |
UpdateCount |
Links
TADMacros Class, Legend, Public Events, Public Methods, Public Properties


TADMacros.Command Property

TADMacros.Command Property
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
property Command: TDataSet;


TADMacros.IsRefCounted Property

TADMacros.IsRefCounted Property
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
property IsRefCounted: Boolean;


TADMacros.Items Property

TADMacros.Items Property
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
property Items [AIndex: Integer]: TADMacro;


TADMacros.OnChanged Event

TADMacros.OnChanged Event
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
property OnChanged: TNotifyEvent;


TADMacros.UpdateCount Property

TADMacros.UpdateCount Property
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
property UpdateCount;


TADMacros.Add Method

TADMacros.Add Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
function Add: TADMacro;


TADMacros.AddRef Method

TADMacros.AddRef Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure AddRef;


TADMacros.Assign Method

TADMacros.Assign Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure Assign(AValue: TPersistent); override;


TADMacros.AssignValues Method

TADMacros.AssignValues Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure AssignValues(AValue: TADMacros);


TADMacros.Create Constructor

TADMacros.Create Constructor
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
constructor Create; overload;


TADMacros.CreateRefCounted Constructor

TADMacros.CreateRefCounted Constructor
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
constructor CreateRefCounted(AGetOwner: TADGetOwner);


TADMacros.Destroy Destructor

TADMacros.Destroy Destructor
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
destructor Destroy; override;


TADMacros.EndUpdate Method

TADMacros.EndUpdate Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure EndUpdate; override;


TADMacros.FindMacro Method

TADMacros.FindMacro Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
function FindMacro(const AValue: String): TADMacro;


TADMacros.IsEqual Method

TADMacros.IsEqual Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
function IsEqual(AValue: TADMacros): Boolean;


TADMacros.MacroByName Method

TADMacros.MacroByName Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
function MacroByName(const AValue: String): TADMacro;


TADMacros.RemRef Method

TADMacros.RemRef Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure RemRef;


TADMacros.TempLockUpdate Method

TADMacros.TempLockUpdate Method
TADMacros Class uADStanParam Unit public Send Feedback
Group

public

Links
TADMacros Class, uADStanParam Unit, public
Syntax
procedure TempLockUpdate;


TADParam Class

TADParam Class
public published Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanParam

Links
public, published, Classes
Syntax
TADParam = class(TCollectionItem);


public

public
TADParam Class Legend Public Methods Public Properties Send Feedback

The public members of the TADParam class are listed here.

Class

TADParam Class

Public Methods
Name | Description
Assign |
AssignField |
AssignFieldValue |
AssignVarRec |
Clear |
Create |
Create |
GetBlobRawData |
GetData |
GetDataSize |
LoadFromFile |
LoadFromStream |
SetBlobRawData |
SetData |
Public Properties
Name | Description
AsBCD |
AsBCDs |
AsBlob |
AsBlobs |
AsBoolean |
AsBooleans |
AsByte |
AsBytes |
AsCurrency |
AsCurrencys |
AsDate |
AsDates |
AsDateTime |
AsDateTimes |
AsFixedChar |
AsFixedChars |
AsFloat |
AsFloats |
AsFMTBCD |
AsFMTBCDs |
AsGUID |
AsGUIDs |
AsInteger |
AsIntegers |
AsLargeInt |
AsLargeInts |
AsMemo |
AsMemos |
AsSmallInt |
AsSmallInts |
AsSQLTimeStamp |
AsSQLTimeStamps |
AsString |
AsStrings |
AsTime |
AsTimes |
AsVarByte |
AsVarBytes |
AsWideMemo |
AsWideMemos |
AsWideString |
AsWideStrings |
AsWord |
AsWords |
BaseParam |
Bound |
IsNull |
IsNulls |
Text |
Texts |
Values |
Links
TADParam Class, Legend, Public Methods, Public Properties


TADParam.AsBCD Property

TADParam.AsBCD Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBCD: Currency;


TADParam.AsBCDs Property

TADParam.AsBCDs Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBCDs [AIndex: Integer]: Currency;


TADParam.AsBlob Property

TADParam.AsBlob Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBlob: TBlobData;


TADParam.AsBlobs Property

TADParam.AsBlobs Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBlobs [AIndex: Integer]: TBlobData;


TADParam.AsBoolean Property

TADParam.AsBoolean Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBoolean: Boolean;


TADParam.AsBooleans Property

TADParam.AsBooleans Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBooleans [AIndex: Integer]: Boolean;


TADParam.AsByte Property

TADParam.AsByte Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsByte: String;


TADParam.AsBytes Property

TADParam.AsBytes Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsBytes [AIndex: Integer]: String;


TADParam.AsCurrency Property

TADParam.AsCurrency Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsCurrency: Currency;


TADParam.AsCurrencys Property

TADParam.AsCurrencys Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsCurrencys [AIndex: Integer]: Currency;


TADParam.AsDate Property

TADParam.AsDate Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsDate: TDateTime;


TADParam.AsDates Property

TADParam.AsDates Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsDates [AIndex: Integer]: TDateTime;


TADParam.AsDateTime Property

TADParam.AsDateTime Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsDateTime: TDateTime;


TADParam.AsDateTimes Property

TADParam.AsDateTimes Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsDateTimes [AIndex: Integer]: TDateTime;


TADParam.AsFixedChar Property

TADParam.AsFixedChar Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFixedChar: String;


TADParam.AsFixedChars Property

TADParam.AsFixedChars Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFixedChars [AIndex: Integer]: String;


TADParam.AsFloat Property

TADParam.AsFloat Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFloat: Extended;


TADParam.AsFloats Property

TADParam.AsFloats Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFloats [AIndex: Integer]: Extended;


TADParam.AsFMTBCD Property

TADParam.AsFMTBCD Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFMTBCD: TADBcd;


TADParam.AsFMTBCDs Property

TADParam.AsFMTBCDs Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsFMTBCDs [AIndex: Integer]: TADBcd;


TADParam.AsGUID Property

TADParam.AsGUID Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsGUID: TGUID;


TADParam.AsGUIDs Property

TADParam.AsGUIDs Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsGUIDs [AIndex: Integer]: TGUID;


TADParam.AsInteger Property

TADParam.AsInteger Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsInteger: LongInt;


TADParam.AsIntegers Property

TADParam.AsIntegers Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsIntegers [AIndex: Integer]: LongInt;


TADParam.AsLargeInt Property

TADParam.AsLargeInt Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsLargeInt: LargeInt;


TADParam.AsLargeInts Property

TADParam.AsLargeInts Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsLargeInts [AIndex: Integer]: LargeInt;


TADParam.AsMemo Property

TADParam.AsMemo Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsMemo: String;


TADParam.AsMemos Property

TADParam.AsMemos Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsMemos [AIndex: Integer]: String;


TADParam.AsSmallInt Property

TADParam.AsSmallInt Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsSmallInt: LongInt;


TADParam.AsSmallInts Property

TADParam.AsSmallInts Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsSmallInts [AIndex: Integer]: LongInt;


TADParam.AsSQLTimeStamp Property

TADParam.AsSQLTimeStamp Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsSQLTimeStamp: TADSQLTimeStamp;


TADParam.AsSQLTimeStamps Property

TADParam.AsSQLTimeStamps Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsSQLTimeStamps [AIndex: Integer]: TADSQLTimeStamp;


TADParam.AsString Property

TADParam.AsString Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsString: String;


TADParam.AsStrings Property

TADParam.AsStrings Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsStrings [AIndex: Integer]: String;


TADParam.AsTime Property

TADParam.AsTime Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsTime: TDateTime;


TADParam.AsTimes Property

TADParam.AsTimes Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsTimes [AIndex: Integer]: TDateTime;


TADParam.AsVarByte Property

TADParam.AsVarByte Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsVarByte: String;


TADParam.AsVarBytes Property

TADParam.AsVarBytes Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsVarBytes [AIndex: Integer]: String;


TADParam.AsWideMemo Property

TADParam.AsWideMemo Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWideMemo: WideString;


TADParam.AsWideMemos Property

TADParam.AsWideMemos Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWideMemos [AIndex: Integer]: WideString;


TADParam.AsWideString Property

TADParam.AsWideString Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWideString: WideString;


TADParam.AsWideStrings Property

TADParam.AsWideStrings Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWideStrings [AIndex: Integer]: WideString;


TADParam.AsWord Property

TADParam.AsWord Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWord: LongInt;


TADParam.AsWords Property

TADParam.AsWords Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property AsWords [AIndex: Integer]: LongInt;


TADParam.BaseParam Property

TADParam.BaseParam Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property BaseParam: TADParam;


TADParam.Bound Property

TADParam.Bound Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property Bound: Boolean;


TADParam.IsNull Property

TADParam.IsNull Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property IsNull: Boolean;


TADParam.IsNulls Property

TADParam.IsNulls Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property IsNulls [AIndex: Integer]: Boolean;


TADParam.Text Property

TADParam.Text Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property Text: String;


TADParam.Texts Property

TADParam.Texts Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property Texts [AIndex: Integer]: String;


TADParam.Values Property

TADParam.Values Property
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
property Values [AIndex: Integer]: Variant;


TADParam.Assign Method

TADParam.Assign Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure Assign(ASource: TPersistent); override;


TADParam.AssignField Method

TADParam.AssignField Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure AssignField(AField: TField);


TADParam.AssignFieldValue Method

TADParam.AssignFieldValue Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure AssignFieldValue(AField: TField; const AValue: Variant);


TADParam.AssignVarRec Method

TADParam.AssignVarRec Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure AssignVarRec(const AVarRec: TVarRec; AIndex: Integer = -1);


TADParam.Clear Method

TADParam.Clear Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure Clear(AIndex: Integer = -1);


TADParam.Create Constructor (TCollection)

TADParam.Create Constructor (TCollection)
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
constructor Create(Collection: TCollection); override; overload;


TADParam.Create Constructor (TParams, TParamType)

TADParam.Create Constructor (TParams, TParamType)
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
constructor Create(AParams: TParams; AParamType: TParamType); overload; reintroduce;


TADParam.GetBlobRawData Method

TADParam.GetBlobRawData Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
function GetBlobRawData(var ALen: LongWord; var APtr: TADBuffer; AIndex: Integer = -1): Boolean;


TADParam.GetData Method

TADParam.GetData Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure GetData(ABuffer: TADBuffer; AIndex: Integer = -1);


TADParam.GetDataSize Method

TADParam.GetDataSize Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
function GetDataSize(AIndex: Integer = -1): Integer;


TADParam.LoadFromFile Method

TADParam.LoadFromFile Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure LoadFromFile(const FileName: String; BlobType: TBlobType; AIndex: Integer = -1);


TADParam.LoadFromStream Method

TADParam.LoadFromStream Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure LoadFromStream(Stream: TStream; BlobType: TBlobType; AIndex: Integer = -1);


TADParam.SetBlobRawData Method

TADParam.SetBlobRawData Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
function SetBlobRawData(ALen: LongWord; APtr: TADBuffer; AIndex: Integer = -1): TADBytes;


TADParam.SetData Method

TADParam.SetData Method
TADParam Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParam Class, uADStanParam Unit, public
Syntax
procedure SetData(ABuffer: TADBuffer; ALen: LongWord = $FFFFFFFF; AIndex: Integer = -1);


published

published
TADParam Class Legend Published Properties Send Feedback

The published members of the TADParam class are listed here.

Class

TADParam Class

Published Properties
Name | Description
ADDataType |
ArraySize |
ArrayType |
DataType |
IsCaseSensitive |
Name |
NumericScale |
ParamType |
Position |
Precision |
Size |
Value |
Links
TADParam Class, Legend, Published Properties


TADParam.ADDataType Property

TADParam.ADDataType Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property ADDataType: TADDataType;


TADParam.ArraySize Property

TADParam.ArraySize Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property ArraySize: Integer;


TADParam.ArrayType Property

TADParam.ArrayType Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property ArrayType: TADParamArrayType;


TADParam.DataType Property

TADParam.DataType Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property DataType: TFieldType;


TADParam.IsCaseSensitive Property

TADParam.IsCaseSensitive Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property IsCaseSensitive: Boolean;


TADParam.Name Property

TADParam.Name Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property Name: String;


TADParam.NumericScale Property

TADParam.NumericScale Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property NumericScale: Integer;


TADParam.ParamType Property

TADParam.ParamType Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property ParamType: TParamType;


TADParam.Position Property

TADParam.Position Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property Position: Integer;


TADParam.Precision Property

TADParam.Precision Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property Precision: Integer;


TADParam.Size Property

TADParam.Size Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property Size: Integer;


TADParam.Value Property

TADParam.Value Property
TADParam Class uADStanParam Unit published Send Feedback
Group

published

Links
TADParam Class, uADStanParam Unit, published
Syntax
property Value: Variant;


TADParams Class

TADParams Class
public Classes Send Feedback
Group

Classes

Class Hierarchy
File

uADStanParam

Links
public, Classes
Syntax
TADParams = class(TCollection);


public

public
TADParams Class Legend Public Methods Public Properties Send Feedback

The public members of the TADParams class are listed here.

Class

TADParams Class

Public Methods
Name | Description
Add |
Add |
Add |
AddRef |
Assign |
AssignValues |
ClearValues |
Create |
CreateParam |
CreateRefCounted |
Destroy |
FindParam |
GetParamList |
IsEqual |
ParamByName |
Prepare |
RemRef |
Public Properties
Name | Description
ArraySize |
BindMode |
IsRefCounted |
Items |
ParamValues |
Links
TADParams Class, Legend, Public Methods, Public Properties


TADParams.ArraySize Property

TADParams.ArraySize Property
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
property ArraySize: Integer;


TADParams.BindMode Property

TADParams.BindMode Property
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
property BindMode: TADParamBindMode;


TADParams.IsRefCounted Property

TADParams.IsRefCounted Property
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
property IsRefCounted: Boolean;


TADParams.Items Property

TADParams.Items Property
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
property Items [Index: Integer]: TADParam;


TADParams.ParamValues Property

TADParams.ParamValues Property
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
property ParamValues [const AParamName: WideString]: Variant;


TADParams.Add Method ()

TADParams.Add Method ()
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function Add: TADParam; overload;


TADParams.Add Method (String, TFieldType, Integer, TParamType)

TADParams.Add Method (String, TFieldType, Integer, TParamType)
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function Add(const AName: String; AType: TFieldType; ASize: Integer = -1; AParamType: TParamType = ptUnknown): TADParam; overload;


TADParams.Add Method (String, Variant, TParamType)

TADParams.Add Method (String, Variant, TParamType)
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function Add(const AName: String; const AValue: Variant; AParamType: TParamType = ptUnknown): TADParam; overload;


TADParams.AddRef Method

TADParams.AddRef Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure AddRef;


TADParams.Assign Method

TADParams.Assign Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure Assign(AValue: TPersistent); override;


TADParams.AssignValues Method

TADParams.AssignValues Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure AssignValues(AValue: TADParams);


TADParams.ClearValues Method

TADParams.ClearValues Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure ClearValues(AIndex: Integer = -1);


TADParams.Create Constructor

TADParams.Create Constructor
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
constructor Create; overload;


TADParams.CreateParam Method

TADParams.CreateParam Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function CreateParam(AFldType: TFieldType; const AParamName: String; AParamType: TParamType): TADParam;


TADParams.CreateRefCounted Constructor

TADParams.CreateRefCounted Constructor
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
constructor CreateRefCounted(AGetOwner: TADGetOwner); overload;


TADParams.Destroy Destructor

TADParams.Destroy Destructor
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
destructor Destroy; override;


TADParams.FindParam Method

TADParams.FindParam Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function FindParam(const AValue: String): TADParam;


TADParams.GetParamList Method

TADParams.GetParamList Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure GetParamList(AList: TList; const AParamNames: String);


TADParams.IsEqual Method

TADParams.IsEqual Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function IsEqual(AValue: TADParams): Boolean;


TADParams.ParamByName Method

TADParams.ParamByName Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
function ParamByName(const AValue: String): TADParam;


TADParams.Prepare Method

TADParams.Prepare Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure Prepare(ADefaultDataType: TFieldType);


TADParams.RemRef Method

TADParams.RemRef Method
TADParams Class uADStanParam Unit public Send Feedback
Group

public

Links
TADParams Class, uADStanParam Unit, public
Syntax
procedure RemRef;


Functions

Functions
Functions uADStanParam Unit Legend Send Feedback

The following table lists functions in this documentation.

Functions
Name | Description
ADVar2SQL |
ADVar2SQLTyped |
ADVarType2FieldType |
Unit

uADStanParam Unit

Links
Functions, uADStanParam Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADStanParam.ADVar2SQL Function

uADStanParam.ADVar2SQL Function
Functions Send Feedback
Group

Functions

File

uADStanParam

Links
Functions
Syntax
function ADVar2SQL(const AValue: Variant): String;


uADStanParam.ADVar2SQLTyped Function

uADStanParam.ADVar2SQLTyped Function
Functions Send Feedback
Group

Functions

File

uADStanParam

Links
Functions
Syntax
function ADVar2SQLTyped(const AValue: Variant; AFieldType: TADMacroDataType): String;


uADStanParam.ADVarType2FieldType Function

uADStanParam.ADVarType2FieldType Function
Functions Send Feedback
Group

Functions

File

uADStanParam

Links
Functions
Syntax
function ADVarType2FieldType(const AValue: Variant): TADMacroDataType;


Records, Enums

Records, Enums
Enumerations uADStanParam Unit Legend Send Feedback

The following table lists records, enums in this documentation.

Enumerations
Name | Description
TADMacroDataType |
TADParamArrayType |
TADParamBindMode |
Unit

uADStanParam Unit

Links
Enumerations, uADStanParam Unit, Legend
(c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.


uADStanParam.TADMacroDataType Enumeration

uADStanParam.TADMacroDataType Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanParam

Links
Records, Enums
Syntax
TADMacroDataType = (
  mdUnknown,
  mdString,
  mdIdentifier,
  mdInteger,
  mdBoolean,
  mdFloat,
  mdDate,
  mdTime,
  mdDateTime,
  mdRaw
);


uADStanParam.TADParamArrayType Enumeration

uADStanParam.TADParamArrayType Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanParam

Links
Records, Enums
Syntax
TADParamArrayType = (
  atScalar,
  atArray,
  atPLSQLTable
);


uADStanParam.TADParamBindMode Enumeration

uADStanParam.TADParamBindMode Enumeration
Records, Enums Send Feedback
Group

Records, Enums

File

uADStanParam

Links
Records, Enums
Syntax
TADParamBindMode = (
  pbByName,
  pbByNumber
);


Types

Types
uADStanParam Unit Types Send Feedback

The following table lists types in this documentation.

Unit

uADStanParam Unit

Types
Name | Description
TADGetOwner |
Links
uADStanParam Unit, Types


uADStanParam.TADGetOwner Type

uADStanParam.TADGetOwner Type
Types Send Feedback
Group

Types

File

uADStanParam

Links
Types
Syntax
TADGetOwner = function : TPersistent of object;


Classes

Classes
Classes Legend
Classes
Name | Description
TADAdaptedDataSet | The TADAdaptedDataSet class uses data adapter to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS.
TADCommand | The class is responsible for execution of SQL commands.
TADConnection | The class is responsible to connection establishment with a DBMS.
TADCustomCommand | The base class is responsible for execution of SQL commands.
TADCustomConnection | The class is responsible to connection establishment with a DBMS.
TADCustomManager | The class is responsible to connection definitions and connections management.
TADCustomMemTable | The class implementing in-memory dataset.
TADCustomQuery | The class implementing dataset, capable to execute SQL queries.
TADCustomSchemaAdapter |
TADCustomStoredProc | The class implementing dataset, capable to execute server side stored procedures.
TADCustomTableAdapter |
TADCustomTransaction | The class is responsible to transaction management for connection.
TADCustomUpdateObject | ..
TADManager | ..
TADMemTable | ..
TADMetaInfoCommand | ..
TADMetaInfoQuery | ..
TADQuery | ..
TADRdbmsDataSet | ..
TADSchemaAdapter |
TADStoredProc | ..
TADTable | ..
TADTableAdapter |
TADTransaction | ..
TADUpdateSQL | ..


Classes

Legend
Legend
Class


Legend

Legend
Classes
Legend
Class


Classes

Classes
Classes Legend
Classes
Name | Description
TADDataMove |
TADMappingItem |
TADMappings |
TADTextDataDef |
TADTextField |
TADTextFields |
TADTextFormatSettings |


Classes

Classes
Classes Legend
Classes
Name | Description
TADAggregate |
TADAggregates |
TADAutoIncField |
TADBlobStream |
TADColMapItem |
TADDataSet | ..
TADIndex |
TADIndexes |
TADMasterDataLink |
TADWideMemoField |


Classes

Classes
Classes Legend
Classes
Name | Description
TADScript |
TADScriptCommand |
TADScriptCommandRegistry |
TADScriptOptions |
TADScriptParser |
TADSQLScript |
TADSQLScripts |


Classes

Classes
Classes Legend
Classes
Name | Description
TADBottomResourceOptions |
TADBottomUpdateOptions |
TADCustomOptions |
TADFetchOptions | The set of options controlling data and metadata fetching.
TADFormatConversionBuffer |
TADFormatOptions |
TADMapRule |
TADMapRules |
TADResourceOptions |
TADTopResourceOptions |
TADTxOptions |
TADUpdateOptions |


Classes

Classes
Classes Legend
Classes
Name | Description
TADMacro |
TADMacros |
TADParam |
TADParams |


Functions

Functions
Functions Legend
Functions
Name | Description
ADFindDefaultConnection |
ADManager | Function returns reference to global TADCustomManager object.
ADSetConnectionClass | Sets the TADCustomConnection descendant class.
ADSetManagerClass | Set the TADCustomManager descendant class.


Functions

Legend
Legend
Method


Legend

Legend
Functions
Legend
Method


Functions

Functions
Functions Legend
Functions
Name | Description
ADKeywordMatch |
ADScriptCommandRegistry |


Functions

Functions
Functions Legend
Functions
Name | Description
ADVar2SQL |
ADVar2SQLTyped |
ADVarType2FieldType |


Interfaces

Interfaces
Interfaces Legend
Interfaces
Name | Description
IADDataSet |


Interfaces

Legend
Legend
Interface


Legend

Legend
Interfaces
Legend
Interface


Interfaces

Interfaces
Interfaces Legend
Interfaces
Name | Description
IADStanOptions |


Legend

Legend
public
Legend
Property
read only
write only
Event
Method
virtual


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnError | The event is triggered when an error happens, while dataset is talking to DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.


Public Events

Legend
Legend
Event


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AbortJob | Use the AbortJob method to abort current dataset operation.
Disconnect | Disconnects the dataset from DBMS.
NextRecordSet | Go to the next cursor, returned by the SQL command.
Offline | Sets dataset to offline mode.
ServerAppend | Used by TADDataMove to edit directly DBMS data.
ServerCancel | Used by TADDataMove to edit directly DBMS data.
ServerDelete | Used by TADDataMove to edit directly DBMS data.
ServerDeleteAll | Used by TADDataMove to edit directly DBMS data.
ServerEdit | Used by TADDataMove to edit directly DBMS data.
ServerGotoKey | Used by TADDataMove to edit directly DBMS data.
ServerPerform | Used by TADDataMove to edit directly DBMS data.
ServerSetKey | Used by TADDataMove to edit directly DBMS data.


Public Methods

Legend
Legend
Method
virtual


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Adapter | Reference to a data adapter.
Command | The reference to the command, used to execute / open queries.
DatSManager | The reference to the inmemory data storage manager.
PointedConnection | The actual connection object.
ServerEditRequest | Used by TADDataMove to edit directly DBMS data.


Public Properties

Legend
Legend
Property
read only
write only


Legend

Legend
public
Legend
Property
read only
Event
Method


public Public Events

public Public Events
public Legend
Public Events
Name | Description
AfterClose | The event fires after command is closed.
AfterExecute | The event fires after command is executed.
AfterFetch | The event fires after fetching from command cursor.
AfterOpen | The event fires after command is opened.
AfterPrepare | The event fires after command is prepared.
AfterUnprepare | The event fires after command is unprepared.
BeforeClose | The event fires before command will be closed.
BeforeExecute | The event fires before command will be executed.
BeforeFetch | The event fires before fetching from command cursor.
BeforeOpen | The event fires before command will be opened.
BeforePrepare | The event fires before command will be prepared.
BeforeUnprepare | The event fires before command will be unprepared.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AbortJob | Use the AbortJob method to abort current command operation.
AcquireConnection | Acquires reference to the actual connection object.
Close | Closes command current cursor.
CloseAll | Closes all command cursors.
Define | Defines DatS manager for command multiple result sets.
Define | Define DatS table structure for command's current cursor.
Disconnect | Use Disconnect method to release DBMS resources, used by this command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Execute | Executes SQL command.
Fetch | Fetches rows from current command cursor.
FillParams | Fills the Params collection.
FindMacro | Returns macro by its name.
FindParam | Returns parameter by its name.
GetConnection | Returns the connection object.
MacroByName | Returns macro by its name.
NextRecordSet | Go to the next cursor, returned by the SQL command.
Open | Executes SQL command, returning cursor.
OpenOrExecute | Execute SQL command, optionally returning cursor.
ParamByName | Returns parameter by its name.
Prepare | Prepares SQL command for execution.
ReleaseConnection | Releases reference to the actual connection object.
Unprepare | Releases SQL command resources.


Public Methods

Legend
Legend
Method


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Active | Gets or sets command active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
BaseObjectName | Identifies base object name for some of command kinds.
BindedBy | Determines how command is connected to connection object.
CatalogName | Identifies catalog name for some command kinds.
CommandIntf | Returns IADPhysCommand interface.
CommandKind | Identifies command kind.
CommandText | The SQL command text to execute.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FetchOptions | The set of options to control rows fetching.
FixedCommandKind | True, if the CommandKind property value is set explicitly.
FormatOptions | The set of options to control data representation.
Macros | The collection of macro substitution variables.
Overload | Oracle stored procedure overload index.
ParamBindMode | Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.
Params | The collection of parameters for a SQL command.
Prepared | Gets or sets command prepare for execution status.
ResourceOptions | The set of options to control resources usage.
RowsAffected | Returns the number of rows operated upon by the latest query execution.
SchemaName | Identifies schema name for some of command kinds.
SQLText | The SQL command text as it will be sent to the DBMS.
State | Returns the current state of the command object.
Transaction | Specifies the trasaction object.
UpdateOptions | The set of options to control updates posting.
Values | Provides access to the values for all parameters for the command.


Public Properties

Legend
Legend
Property
read only


Legend

Legend
public
Legend
Property
read only
Event
Method
virtual


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnError | Fires before AnyDAC will raise exception.
OnLogin | Fires when an application connects to a DBMS.
OnLosted | Fires after AnyDAC was not able to restore losted connection to DBMS.
OnRecover | Fires after AnyDAC discovered that connection to DBMS is losted.
OnRestored | Fires after AnyDAC successfully restored losted connection to DBMS.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
ApplyUpdates | Applies change logs of specified datasets to the DBMS.
CheckActive | Checks to see if the connection is active.
CheckConnectionDef | Checks that connection definition is filled correctly.
CheckInactive | Checks to see if the connection is inactive.
CheckOnline | Checks to see if the connection is in online mode.
CloseClients | Closes all connection associated datasets and commands.
Commit | Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.
CommitRetaining | Permanently stores modifications to the data made in the current transaction, without ending the current transaction.
DecodeObjectName | Splits DB object name into parts.
EncodeObjectName | Assembles DB object name from it parts.
ExecSQL | Executes SQL command without parameters.
ExecSQL | Executes SQL command with parameters.
ExecSQL | Executes SQL command with parameters.
GetFieldNames | Populates a string list with the names of fields in a table.
GetGeneratorNames | Populates a string list with the names of generators / sequences / <how else> in a database.
GetKeyFieldNames | Populates a string list with the names of key fields in a table.
GetLastAutoGenValue | Returns last auto generated value.
GetPackageNames | Populates a string list with the names of Oracle packages in a DB.
GetStoredProcNames | Populates a string list with the names of stored procedures in a DB.
GetTableNames | Populates a string list with the names of tables in a DB.
Offline | Sets connection to offline mode.
Online | Sets connection to online mode.
Ping | Pings the DBMS server.
RefreshMetadataCache | Invalidates meta data cache.
Rollback | Cancels all modifications to the data made in the current transaction and optionally ends transaction.
RollbackRetaining | Cancels all modifications to the data made in the current transaction, without ending the current transaction.
StartTransaction | Starts new transaction at database.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
CliHandle | CLI handle for connection sharing.
CliObj | CLI connection wrapping object.
CommandCount | The number of assocciated TADCustomCommand objects.
Commands | Returns assocciated TADCustomCommand objects.
Connected | Gets / sets connection active status.
ConnectedStoredUsage | Controls how to use Connected property value saved to DFM.
ConnectionDefName | The name of connection definition to use.
ConnectionIntf | Returns IADPhysConnection interface.
ConnectionName | Specifies the name of the connection to associate with this connection object.
DataSets | Returns assocciated TADDataSet objects.
DriverName | Specifies the ID of the AnyDAC driver for the connection.
FetchOptions | The set of default options to control rows fetching.
FormatOptions | The set of default options to control data representation.
InTransaction | Indicates whether a connection transaction is in progress or not.
IsSQLBased | Property returns True, if datasource supports SQL language.
LastUsed | The date and time of last usage of the connection.
LoginDialog | Gets / sets the reference to login dialog interface.
LoginPrompt | Specifies whether a login dialog appears immediately before opening a new connection.
Offlined | Gets / sets connection offline status.
OptionsIntf | The reference to IADStanOptions interface.
Params | Lists database connection parameters for the AnyDAC connection definition associated with the connection object.
RDBMSKind | Returns the brand of DBMS currently connected.
RefCount |
ResourceOptions | The set of default options to control resources usage.
ResultConnectionDef | The actual connection definition used to establish connection to a DBMS.
SharedCliHandle | CLI handle shared with other connection.
Temporary | Shows whether a connection object is created on fly (temporary one) and managed automatically or a persistent one explicitly created, managed, and freed by the application.
Transaction | The reference to TADCustomTransaction object.
TxOptions | The set of options to control transactions.
UpdateOptions | The set of default options to control data updating.
UpdateTransaction | The reference to TADCustomTransaction object, which will be used to post changes to DB.


public Public Events

public Public Events
public Legend
Public Events
Name | Description
AfterLoadConnectionDefFile | Fires after connection definitions file is loaded.
BeforeLoadConnectionDefFile | Fires before connection definitions file is loaded.
OnShutdown | Fires after manager is finished.
OnStartup | Fires after manager is started.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AcquireConnection |
AcquireConnection |
AddConnectionDef | Adds private connection definition.
Close | Terminates AnyDAC manager.
DeleteConnectionDef | Deletes connection definition.
DropConnections |
FindConnection | Find the TADCustomConnection instance with ConnectionName equal to AConnectionName.
GetConnectionDefNames | Fills the list by existing connection definition names.
GetConnectionDefParams | Fills the list by connection definition parameters.
GetConnectionNames | Fills the list by connection names.
GetDriverNames | Fills the list by registered driver ID's.
GetFieldNames | Populates a string list with the names of fields in a table.
GetGeneratorNames | Populates a string list with the names of generators / sequences / <how else> in a database.
GetKeyFieldNames | Populates a string list with the names of key fields in a table.
GetPackageNames | Populates a string list with the names of Oracle packages in a DB.
GetStoredProcNames | Populates a string list with the names of stored procedures in a DB.
GetTableNames | Populates a string list with the names of tables in a DB.
IsConnectionDef | Check if name is connection definition name.
LoadConnectionDefFile | Loads connection definitions file.
ModifyConnectionDef | Modifies parameters of an existing connection definition.
Open | Activates AnyDAC manager.
RefreshConnectionDefFile | Refreshes connection definition list.
RefreshMetadataCache | Invalidates meta data cache for all connections.
ReleaseConnection |
SaveConnectionDefFile | Saves connection definitions into a file.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Active | Gets or sets AnyDAC manager active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
AutoCreated | Is manager object auto created.
CanRefreshConnectionDefFile | Checks if connection definition list may be refreshed.
ConnectionCount | The number of connection objects.
ConnectionDefFileAutoLoad | Controls how connection definitions file must be loaded.
ConnectionDefFileLoaded | Checks is loaded the connection definitions file.
ConnectionDefFileName | Gets / sets the name of a connection definitions file.
ConnectionDefs | The list of connection definitions.
Connections | The application connection objects.
DriverDefFileAutoLoad | Controls how driver definitions file must be loaded.
DriverDefFileName | Gets / sets the name of a driver definitions file.
FetchOptions | The "root" fetch options.
FormatOptions | The "root" data format options.
ResourceOptions | The "root" resources control options.
SilentMode | Gets or sets AnyDAC global "silent" flag.
State | Returns the current state of AnyDAC manager.
UpdateOptions | The "root" data updating options.
WaitCursor | Gets or sets AnyDAC wait cursor shape.


Legend

Legend
public
Legend
Property
write only


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Adapter | Reference to a data adapter.


Public Properties

Legend
Legend
Property
write only


Legend

Legend
public
Legend
Property
read only
Method


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
ExecSQL | Executes the SQL statement for the query.
ExecSQL | Executes the specified SQL statement for the query.
ExecSQL | Executes the specified SQL statement and parameter values for the query.
ExecSQL | Executes the specified SQL statement and assigns parameter values for the query.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataSource | Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.
ParamCount | Returns the current number of parameters in the query SQL text.
SQL | Contains the text of the SQL statement to execute for the query.
Text | Points to the actual text of the SQL query passed to the DBMS CLI.


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnError |
OnReconcileRow |
OnUpdateRow |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Reconcile |
Update |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DatSManager |
TableAdaptersIntf |


Legend

Legend
public
Legend
Property
Method


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
DescriptionsAvailable | Determines if parameter information is available from the stored procedure on the server.
ExecProc | Executes the specified stored procedure in the DBMS session.
ExecProc | Executes the specified stored procedure in the DBMS session.
ExecProc | Executes the specified stored procedure and assigns parameter values for the stored proc.
ExecProc | Executes the specified stored procedure in the DBMS session.
GetResults |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
CatalogName | Limits the stored procedure names to the specified catalog.
Overload | Specifies which Oracle overloaded packaged stored procedure to execute.
PackageName | Limits the stored procedure names to the specified Oracle package name.
ParamCount | Returns the number of parameters for the stored procedure.
RowsAffected | Returns the number of rows operated upon by the latest query execution.
SchemaName | Limits the stored procedure names to the specified schema.
StoredProcName | Identifies the name of the stored procedure on the server to call.


Public Properties

Legend
Legend
Property


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnDescribeColumn |
OnDescribeTable |
OnError |
OnReconcileRow |
OnUpdateRow |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Define |
Fetch |
Fetch |
Lock |
Reconcile |
Reset |
UnLock |
Update |
Update |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ColumnMappings |
DatSManager |
DatSTable |
DatSTableName |
DeleteCommand |
FetchRowCommand |
InsertCommand |
LockCommand |
MetaInfoMergeMode |
SchemaAdapter |
SelectCommand |
SourceRecordSetID |
SourceRecordSetName |
TableAdapterIntf |
UnLockCommand |
UpdateCommand |
UpdateTableName |
UpdateTransaction |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Commit | Permanently stores modifications to the data made in the current transaction, and optionally ends the current transactions.
CommitRetaining | Permanently stores modifications to the data made in the current transaction, without ending the current transaction.
Rollback | Cancels all modifications to the data made in the current transaction and optionally ends transaction.
RollbackRetaining | Cancels all modifications to the data made in the current transaction, without ending the current transaction.
StartTransaction | Starts new transaction at database.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Connection | Specifies the connection component that actually forms the connection to the DBMS.
DataSetCount | Returns the number of datasets associated with this transaction.
DataSets | Returns the dataset associated with this transaction by it index.
IsActive | Indicates whether a database transaction is in progress or not.
Options | The set of options controlling transactions behaviour.
TransactionIntf | Returns IADPhysTransaction interface.


Legend

Legend
public
Legend
Property
Method
abstract


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Apply | Applies record update request to DB for current record in DataSet.


Public Methods

Legend
Legend
Method
abstract


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataSet | Identifies the dataset on which change log update object will operate.


Legend

Legend
public
Legend
Constructor
virtual


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Create |


Public Methods

Legend
Legend
Constructor
virtual


Legend

Legend
public
Legend
Property


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
MacroCount | Returns the number of macro in Macros collection.
RowsAffected | Returns the number of rows operated upon by the latest query execution.


Legend

Legend
public
Legend
Property
Event
Constructor
virtual


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnCommandChanged | Fires after the SQL property value is changed.
OnError | The event fires when an error happens, while dataset is communicating with DBMS.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Create |
Destroy |
Disconnect | Disconnects the dataset from DBMS.
FindMacro | Returns macro by its name.
MacroByName | Returns macro by its name.
Open |
Open | Executes the specified SQL statement and opens dataset.
Open | Executes the specified SQL statement with specified parameter values and opens dataset.
Open | Executes the specified SQL statement with specified parameter values and opens dataset.
Prepare | Prepares SQL command for execution.
Unprepare | Releases SQL command resources.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Transaction | Gets / sets reference to transaction object.
UpdateTransaction | Gets / sets reference to transaction object.


Legend

Legend
public
Legend
Property
read only
Method
virtual


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Apply | Applies record update request to DB for current record in DataSet.
Create |
Destroy |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Commands | Returns reference to internal command object, that will handle update request.
SQL | Gets / sets a specified SQL statement used when applying updates to DB.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AbortJob |
Create |
Destroy |
Execute |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DeleteCount |
ExceptionCount |
InsertCount |
ReadCount |
UpdateCount |
WriteCount |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
Destroy |
Move |
Prepare |
Unprepare |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AsText |
DestField |
DestTextField |
DestValue |
InKey |
ItemValue |
SourceEvaluator |
SourceField |
SourceTextField |
SourceValue |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
Add |
AddAll |
Assign |
Create |
IndexOfName |
Move |
Prepare |
Unprepare |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataMove |
Items |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
Create |
Destroy |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataMove |


Legend

Legend
public
Legend
Method
virtual


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
DefineAsField |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
AddAll |
Create |
FieldByName |
FindField |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Items |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataDef |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
GetDataView |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DataView |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
BeginUpdate |
Destroy |
EndUpdate |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActualActive |
DataSet |
DataType |
InUse |
Value |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
AggregateByName |
Build |
Create |
FindAggregate |
Release |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
GroupingLevel |
Items |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Create |
Destroy |
Truncate |
Write |


Legend

Legend
public
Legend
Data Member


public Public Fields

public Public Fields
public Legend
Public Fields
Name | Description
FColumn |
FColumnIndex |
FPath |


Public Fields

Legend
Legend
Data Member


public Public Events

public Public Events
public Legend
Public Events
Name | Description
AfterApplyUpdates | Fires after cached updates are applied to DB.
AfterExecute | Fires after SQL command execution is finished.
AfterGetRecords | Fires after fetching next rowset.
AfterRowRequest | Fires after fetching record.
BeforeApplyUpdates | Fires before cached updates are applied to DB.
BeforeExecute | Fires before SQL command execution is started.
BeforeGetRecords | Fires before fetching next rowset.
BeforeRowRequest | Fires before fetching record.
OnReconcileError | Fires when a dataset needs to reconcile an update to a record that cannot not be applied.
OnUpdateError | Fires if an exception is generated when updates are applied to a database.
OnUpdateRecord | Occurs when record update is applying to a database.


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AddIndex | Creates a new client index for the dataset.
ApplyRange | Applies a range to the dataset.
ApplyUpdates | Applies changes for all records in change log to the database.
AttachTable | Attaches dataset to existing DatS table and optionaly view.
BeginBatch | Optimizes dataset functionality for batch updates.
BookmarkStrValid |
BookmarkValid |
Cancel |
CancelRange | Cancels range for the dataset.
CancelUpdates | Removes all records from the change log and restores the dataset rows to its prior editing state.
CloneCursor | Shares the data belonging to another dataset.
CommitUpdates | Clears the changes log and marks all records as not modified.
CompareBookmarks |
CopyDataSet | Copies records from source dataset to this dataset.
CopyFields | Copies all fields from source dataset to this dataset.
Create |
CreateBlobStream |
CreateDataSet | Creates new empty internal data storage for dataset.
CreateExpression | Creates expression evaluator for dataset.
DeleteIndex | Deletes an client index for the dataset.
DeleteIndexes | Deletes all client indexes for the dataset.
Destroy |
DisableConstraints | Disables the enforcement of client constraints.
Disconnect | Use Disconnect method to release DBMS resources, used by this dataset.
EditKey | Enables modification of the search key buffer.
EditRangeEnd | Enables changing the ending value for an existing range.
EditRangeStart | Enables changing the starting value for an existing range.
EmptyDataSet | Removes all records from the dataset internal data storage.
EnableConstraints | Reenables enforcement of client constraints when records are posted.
EndBatch | Restores normal dataset functionality after batch updates.
Execute | Executes an SQL command.
FetchAgain | Allows to fetch additional records.
FetchAll | Retrieves all records from the current resultset and stores them into internal DatS table.
FetchBlobs | Retrieves BLOB field values from database for current record.
FetchDetails | Retrieves nested datasets from database for current record.
FindKey | Searches for a record containing specified index field values.
FindNearest | Searches for a record containing specified index field values.
FindParam | Finds the parameter in Params property by a given name.
GetColumnField | Returns field corresponding to DatS column.
GetCurrentRecord |
GetDetailLinkFields | Lists the field objects that link this dataset as a detail of a master dataset.
GetFieldColumn | Returns DatS column corresponding to field.
GetFieldData |
GetFieldData |
GetGroupState | Indicates where the current record sits within a specified group of records.
GetIndexNames | Fills the list by client index names.
GetNextPacket | Fetches the next rowset from the DBMS.
GetParentRow | Returns parent row of this nested dataset.
GetRow | Returns DatS row.
GotoCurrent | Sets the current record in this dataset the same as the current record in another, cloned dataset.
GotoKey | Searches for a record, using values in the key buffer.
GotoNearest | Searches for a closest record, using values in the key buffer.
IsIndexed | Returns True, if dataset has current client index.
IsLinked | Returns True, if dataset is linked to another dataset.
IsSequenced |
LoadFromFile | Loads a dataset's data from a file.
LoadFromFileAtOpen | Returns True, if dataset content will be loaded from file at Open.
LoadFromStream | Loads a dataset's data from a stream.
Locate | Searches the dataset for a record with specified field values and makes it current.
LocateEx | Searches the dataset for a specified record by predicate expression and makes that record current or returns its index.
LocateEx | Searches the dataset for a specified record by its fields values and makes that record current or returns its index.
Lookup | Searches the dataset for a record with specified key field values and returns result field values.
LookupEx | Searches the dataset for a record with specified key field values and returns result field values.
LookupEx | Searches the dataset for a record by predicate expression and returns result field values.
Offline | Sets dataset to offline mode.
OpenOrExecute | Executes SQL command and optionally opens dataset.
ParamByName | Searches parameter by its name.
Post |
Reconcile |
RefreshRecord | Rereads field values of the current record from a data source.
RevertRecord | Undoes changes to the current record.
SaveToFile | Saves a dataset's data to a file.
SaveToFileAtClose | Returns True, if dataset content will be saved to file at Close.
SaveToStream | Saves a dataset's data to a stream.
SetFieldAttributes |
SetFieldAttributes |
SetFieldAttributes |
SetFieldAutoGenerateValue |
SetKey | Starts the enter key values mode.
SetRange | Sets the starting and ending values of a range, and applies it.
SetRangeEnd | Sets the ending values of a range.
SetRangeStart | Sets the starting values of a range.
UndoLastChange | Undoes the last modification to the dataset records.
UpdateStatus | Returns the modification status for current record.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
Aggregates | The collection of client side aggregates, defined for dataset.
AggregatesActive | Controls automatic calculation of aggregate values.
CachedUpdates | Specifies whether dataset will log changes to the data without immediate applying of them to the database.
ChangeCount | Gets the number of changes in the change log.
CloneSource | Gets the dataset (if any) with which this dataset shares data.
Constraints | Specifies record-level client constraints that must be met when editing the data.
ConstraintsEnabled | Specifies whether the dataset perform constraint checking.
Data | Represents the data of the dataset, allowing to copy full data of one dataset into another.
DatSManager | Returns the reference to the internal data storage manager.
Delta | Represents the changed records of the dataset.
FilterChanges | Specifies what kinds of changed records must be "visible" in the dataset.
FilteredData | Represents the currently "visible" data of the dataset.
GroupingLevel | Returns the depth of grouping support provided by the current index.
IndexDefs | Returns indexes definition for the dataset.
Indexes | Lists all client indexes that apply to the dataset.
IndexesActive | Controls automatic maintenance of Index'es.
IndexFieldCount | Returns the number of fields that make up the current index.
IndexFieldNames | Lists the field names to use as an index.
IndexFields | Returns the fields that make up the current index.
IndexName | Gets / sets the current index for the dataset by its name.
KeyExclusive | Controls the exclusion of upper and lower boundaries for a range.
KeyFieldCount | Controls the number of indexed field values to use for key search or range setup.
MasterFields | Gets / sets fields in master dataset, used to establish a master-detail relationship with this dataset.
MasterSource | Gets / sets a master data source, used to establish a master-detail relationship with this dataset.
ParentDataSet | Returns the reference to parent dataset, if this one is nested.
Ranged | Specifies whether the dataset records are limited by a range.
SavePoint | Gets / sets the change log version number.
SourceEOF | Specifies if no more records to fetch from current cursor.
SourceView | The reference to DatS view object, by which rows the dataset is navigating.
Table | The reference to DatS table object, actually representing the internal data storage.
UpdatesPending | Indicates whether the changes log is not empty.
View | The reference to base DatS view object.


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActualActive |
DataSet |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
Build |
Create |
FindIndex |
FindIndexForFields |
IndexByName |
Release |


Legend

Legend
public
Legend
Event


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnMasterFieldsDefined |


Legend

Legend
public
Legend
Property
Constructor
virtual


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Value |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AbortJob |
CheckCommand |
CloseConnection |
CloseSpool |
ConGet |
ConLockUpdate |
ConPut |
ConUnlockUpdate |
Create |
Destroy |
ExecuteAll |
ExecuteAll |
ExecuteHostCommand |
ExecuteStep |
ExecuteStep |
ExpandString |
GetStream |
OpenConnection |
Progress |
ReleaseStream |
UpdateCommandSeparator |
UpdateSpool |
ValidateAll |
ValidateAll |
ValidateStep |
ValidateStep |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AllSpools |
CallStack |
CommandIntf |
ConnectionIntf |
CurrentCommand |
EOF |
Finished |
LastSpoolFileName |
Position |
ProcessedAfterCommit |
RDBMSKind |
Status |
Table |
TotalErrors |
TotalJobDone |
TotalJobSize |
TotalPct10Done |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AbortJob |
Create |
Destroy |
Execute |
Help |
Keywords |
Parse |
Validate |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Engine |
Parser |
Position |


Legend

Legend
public
Legend
Property
Method
virtual


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
AddCommand |
Create |
Destroy |
Help |
LookupCommand |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
DefaultPLSQLCommandClass |
DefaultSQLCommandClass |


Legend

Legend
public
Legend
Property
read only


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActualCommandSeparator |


Legend

Legend
public
Legend
Property
read only
Constructor


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Create |
ExtractCommand |
ExtractString |
GetBookmark |
GetChar |
GetIdentifier |
GetLine |
GetNumber |
GetOnOfChar |
GetOnOff |
GetString |
GetStringInFull |
GetUCWord |
InvalidSyntax |
SetBookmark |
SkipWS |
SkipWSLF |
UnGetChar |


Public Methods

Legend
Legend
Constructor


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Ch |
FileName |
LineNumber |
ParentCommand |
Position |
ScriptOptions |
TotalSize |
WasBeginningOfLine |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
Create |
FindScript |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
GetFetchOptions |
GetFormatOptions |
GetParentOptions |
GetResourceOptions |
GetUpdateOptions |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
FetchOptions |
FormatOptions |
ResourceOptions |
UpdateOptions |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
ResolveFileName |
RestoreDefaults |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
RestoreDefaults |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
BeforeDestruction |
Create |
RestoreDefaults |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Owner |
OwnerObj |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
IsValueOwned |
RestoreDefaults |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActualRowsetSize |
AssignedValues |


Legend

Legend
public
Legend
Data Member
Property
read only
Method
virtual


public Public Fields

public Public Fields
public Legend
Public Fields
Name | Description
FBuffer |
FBufferSize |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Check |
Create |
Destroy |
Extend |
Release |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Ptr |
Size |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
CheckConversion |
ColumnDef2FieldDef |
ConvertRawData |
Create |
Destroy |
FieldDef2ColumnDef |
IsValueOwned |
ResolveDataType |
ResolveFieldType |
RestoreDefaults |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AssignedValues |
StrsDivLen2 |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
Create |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
Create |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ActualSilentMode |
AssignedValues |
BackupExt |
BackupFolder |
DefaultStoreExt |
DefaultStoreFolder |
DefaultStoreFormat |
PreprocessCmdText |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
ClearChanged |
Create |
Destroy |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Changed |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AssignedValues |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
Clear |
Create |
IsEqual |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AsDate |
AsDateTime |
AsFloat |
AsIdentifier |
AsInteger |
AsRaw |
AsString |
AsTime |
CollectionOwner |
IsNull |
SQL |


public Public Events

public Public Events
public Legend
Public Events
Name | Description
OnChanged |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
AddRef |
Assign |
AssignValues |
Create |
CreateRefCounted |
Destroy |
EndUpdate |
FindMacro |
IsEqual |
MacroByName |
RemRef |
TempLockUpdate |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
Command |
IsRefCounted |
Items |
UpdateCount |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Assign |
AssignField |
AssignFieldValue |
AssignVarRec |
Clear |
Create |
Create |
GetBlobRawData |
GetData |
GetDataSize |
LoadFromFile |
LoadFromStream |
SetBlobRawData |
SetData |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
AsBCD |
AsBCDs |
AsBlob |
AsBlobs |
AsBoolean |
AsBooleans |
AsByte |
AsBytes |
AsCurrency |
AsCurrencys |
AsDate |
AsDates |
AsDateTime |
AsDateTimes |
AsFixedChar |
AsFixedChars |
AsFloat |
AsFloats |
AsFMTBCD |
AsFMTBCDs |
AsGUID |
AsGUIDs |
AsInteger |
AsIntegers |
AsLargeInt |
AsLargeInts |
AsMemo |
AsMemos |
AsSmallInt |
AsSmallInts |
AsSQLTimeStamp |
AsSQLTimeStamps |
AsString |
AsStrings |
AsTime |
AsTimes |
AsVarByte |
AsVarBytes |
AsWideMemo |
AsWideMemos |
AsWideString |
AsWideStrings |
AsWord |
AsWords |
BaseParam |
Bound |
IsNull |
IsNulls |
Text |
Texts |
Values |


public Public Methods

public Public Methods
public Legend
Public Methods
Name | Description
Add |
Add |
Add |
AddRef |
Assign |
AssignValues |
ClearValues |
Create |
CreateParam |
CreateRefCounted |
Destroy |
FindParam |
GetParamList |
IsEqual |
ParamByName |
Prepare |
RemRef |


public Public Properties

public Public Properties
public Legend
Public Properties
Name | Description
ArraySize |
BindMode |
IsRefCounted |
Items |
ParamValues |


Legend

Legend
published
Legend
Property
Event


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterClose | The event fires after command is closed.
AfterExecute | The event fires after command is executed.
AfterOpen | The event fires after command is opened.
AfterPrepare | The event fires after command is prepared.
AfterUnprepare | The event fires after command is unprepared.
BeforeClose | The event fires before command will be closed.
BeforeExecute | The event fires before command will be executed.
BeforeOpen | The event fires before command will be opened.
BeforePrepare | The event fires before command will be prepared.
BeforeUnprepare | The event fires before command will be unprepared.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.


Published Events

Legend
Legend
Event


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active | Gets or sets command active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
BaseObjectName | Identifies base object name for some of command kinds.
CatalogName | Identifies catalog name for some command kinds.
CommandKind | Identifies command kind.
CommandText | The SQL command text to execute.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FetchOptions | The set of options to control rows fetching.
FormatOptions | The set of options to control data representation.
Macros | The collection of macro substitution variables.
Overload | Oracle stored procedure overload index.
Params | The collection of parameters for a SQL command.
Prepared | Gets or sets command prepare for execution status.
ResourceOptions | The set of options to control resources usage.
SchemaName | Identifies schema name for some of command kinds.
Transaction | Specifies the trasaction object.
UpdateOptions | The set of options to control updates posting.


Published Properties

Legend
Legend
Property


Legend

Legend
published
Legend
Event
Property


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterConnect |
AfterDisconnect |
BeforeConnect |
BeforeDisconnect |
OnError | Fires before AnyDAC will raise exception.
OnLogin | Fires when an application connects to a DBMS.
OnLosted | Fires after AnyDAC was not able to restore losted connection to DBMS.
OnRecover | Fires after AnyDAC discovered that connection to DBMS is losted.
OnRestored | Fires after AnyDAC successfully restored losted connection to DBMS.


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Connected | Gets / sets connection active status.
ConnectedStoredUsage | Controls how to use Connected property value saved to DFM.
ConnectionDefName | The name of connection definition to use.
ConnectionName | Specifies the name of the connection to associate with this connection object.
DriverName | Specifies the ID of the AnyDAC driver for the connection.
FetchOptions | The set of default options to control rows fetching.
FormatOptions | The set of default options to control data representation.
LoginDialog | Gets / sets the reference to login dialog interface.
LoginPrompt | Specifies whether a login dialog appears immediately before opening a new connection.
Params | Lists database connection parameters for the AnyDAC connection definition associated with the connection object.
ResourceOptions | The set of default options to control resources usage.
Transaction | The reference to TADCustomTransaction object.
TxOptions | The set of options to control transactions.
UpdateOptions | The set of default options to control data updating.
UpdateTransaction | The reference to TADCustomTransaction object, which will be used to post changes to DB.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterLoadConnectionDefFile | Fires after connection definitions file is loaded.
BeforeLoadConnectionDefFile | Fires before connection definitions file is loaded.
OnShutdown | Fires after manager is finished.
OnStartup | Fires after manager is started.


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active | Gets or sets AnyDAC manager active status.
ActiveStoredUsage | Controls how to use Active property value saved to DFM.
ConnectionDefFileAutoLoad | Controls how connection definitions file must be loaded.
ConnectionDefFileName | Gets / sets the name of a connection definitions file.
DriverDefFileAutoLoad | Controls how driver definitions file must be loaded.
DriverDefFileName | Gets / sets the name of a driver definitions file.
FetchOptions | The "root" fetch options.
FormatOptions | The "root" data format options.
ResourceOptions | The "root" resources control options.
SilentMode | Gets or sets AnyDAC global "silent" flag.
UpdateOptions | The "root" data updating options.
WaitCursor | Gets or sets AnyDAC wait cursor shape.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterExecute |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeExecute |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnDeleteError |
OnEditError |
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Adapter | Reference to a data adapter.
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
Constraints |
ConstraintsEnabled |
DataSetField |
FetchOptions |
FieldDefs |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
IndexDefs |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MasterFields |
MasterSource |
ObjectView |
ResourceOptions |
StoreDefs |
UpdateOptions |


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterClose | The event fires after command is closed.
AfterOpen | The event fires after command is opened.
BeforeClose | The event fires before command will be closed.
BeforeOpen | The event fires before command will be opened.
OnCommandChanged | The event fires after CommandText is changed.
OnError | The event fires when an error happens, while command is communicating with DBMS.


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active | Gets or sets command active status.
BaseObjectName | Gets / sets the name of base object.
CatalogName | Identifies catalog name for some command kinds.
Connection | Specifies the connection object.
ConnectionName | Specifies connection name.
FormatOptions | The set of options to control data representation.
MetaInfoKind | Gets / sets the kind of metadata to retrieve.
ObjectName | Gets / sets the name of object to get detailed information about it.
ObjectScopes | Gets / sets object scopes filter.
Overload | Oracle stored procedure overload index.
SchemaName | Identifies schema name for some of command kinds.
TableKinds | Gets / sets table kind filter.
Wildcard | Gets / sets objects filter by their name.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterClose |
AfterGetRecords |
AfterOpen |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeClose |
BeforeGetRecords |
BeforeOpen |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnFilterRecord |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
BaseObjectName | Gets / sets the name of base object.
CatalogName |
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
FetchOptions |
Filter |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MetaInfoKind | Gets / sets the kind of metadata to retrieve.
ObjectName | Gets / sets the name of object to get detailed information about it.
ObjectScopes | Gets / sets object scopes filter.
Overload |
SchemaName |
TableKinds | Gets / sets tables filter by their kinds.
Transaction | Gets / sets reference to transaction object.
UpdateTransaction | Gets / sets reference to transaction object.
Wildcard | Gets / sets objects filter by their name.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterExecute |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeExecute |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnDeleteError |
OnEditError |
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
DataSource | Specifies the data source object from which associated dataset to get matching field values to the details dataset parameters.
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
Macros | The collection of macro substitution variables.
ObjectView |
Params |
Prepared | Gets or sets command prepare for execution status.
ResourceOptions |
SQL | Contains the text of the SQL statement to execute for the query.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.


Legend

Legend
published
Legend
Event


published Published Events

published Published Events
published Legend
Published Events
Name | Description
OnError |
OnReconcileRow |
OnUpdateRow |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
CatalogName | Limits the stored procedure names to the specified catalog.
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
ObjectView |
Overload | Specifies which Oracle overloaded packaged stored procedure to execute.
PackageName | Limits the stored procedure names to the specified Oracle package name.
ParamBindMode | Determines the order in which a component’s parameters are assigned to the parameter list for SQL command on the DBMS.
Params |
Prepared | Gets or sets command prepare for execution status.
ResourceOptions |
SchemaName | Limits the stored procedure names to the specified schema.
StoredProcName | Identifies the name of the stored procedure on the server to call.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterApplyUpdates |
AfterCancel |
AfterClose |
AfterDelete |
AfterEdit |
AfterGetRecords |
AfterInsert |
AfterOpen |
AfterPost |
AfterRefresh |
AfterRowRequest |
AfterScroll |
BeforeApplyUpdates |
BeforeCancel |
BeforeClose |
BeforeDelete |
BeforeEdit |
BeforeGetRecords |
BeforeInsert |
BeforeOpen |
BeforePost |
BeforeRefresh |
BeforeRowRequest |
BeforeScroll |
OnCalcFields |
OnCommandChanged | Fires after the SQL property value is changed.
OnDeleteError |
OnEditError |
OnError | The event fires when an error happens, while dataset is communicating with DBMS.
OnExecuteError | The event is triggered when an error happens, while executing a Array DML query.
OnFilterRecord |
OnNewRecord |
OnPostError |
OnReconcileError |
OnUpdateError |
OnUpdateRecord |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
ActiveStoredUsage |
Aggregates |
AggregatesActive |
AutoCalcFields |
CachedUpdates |
CatalogName | Limits the table names to the catalog.
Connection | Specifies the AnyDAC connection component to use.
ConnectionName | Specifies the AnyDAC connection to use by its name.
Constraints |
ConstraintsEnabled |
Exclusive |
FetchOptions |
Filter |
FilterChanges |
Filtered |
FilterOptions |
FormatOptions |
Indexes |
IndexesActive |
IndexFieldNames |
IndexName |
MasterFields |
MasterSource |
ObjectView |
ResourceOptions |
SchemaName | Limits the table names to the schema.
TableName | Gets / sets table name to open.
Transaction | Gets / sets reference to transaction object.
UpdateObject |
UpdateOptions |
UpdateTransaction | Gets / sets reference to transaction object.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
OnDescribeColumn |
OnDescribeTable |
OnError |
OnReconcileRow |
OnUpdateRow |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
ColumnMappings |
DatSTableName |
DeleteCommand |
FetchRowCommand |
InsertCommand |
LockCommand |
MetaInfoMergeMode |
SchemaAdapter |
SelectCommand |
SourceRecordSetID |
SourceRecordSetName |
UnLockCommand |
UpdateCommand |
UpdateTableName |
UpdateTransaction |


Legend

Legend
published
Legend
Property


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Connection | Specifies the connection component that actually forms the connection to the DBMS.
Options | The set of options controlling transactions behaviour.


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Connection | Gets / sets the connection object.
ConnectionName | Gets / sets the connection name.
DeleteSQL | Specifies the SQL statement to use when applying a deletion of a record.
FetchRowSQL | Specifies the SQL statement to use to refetch single record.
InsertSQL | Specifies the SQL statement to use when applying an insertion of a record.
LockSQL | Specifies the SQL statement to use when locking a record.
ModifySQL | Specifies the SQL statement to use when applying an update of a record.
UnlockSQL | Specifies the SQL statement to use when unlocking a record.


published Published Events

published Published Events
published Legend
Published Events
Name | Description
OnError |
OnFindDestRecord |
OnProgress |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
CommitCount |
Destination |
DestinationKind |
LogFileAction |
LogFileName |
Mappings |
Mode |
Options |
Source |
SourceKind |
StatisticsInterval |
TextDataDef |
TextFileName |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
DestinationFieldName |
SourceExpression |
SourceFieldName |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Delimiter |
EndOfLine |
Fields |
FormatSettings |
RecordFormat |
Separator |
WithFieldNames |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
DataType |
FieldName |
FieldSize |
Precision |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
CurrencyDecimals |
CurrencyFormat |
CurrencyString |
DateSeparator |
DecimalSeparator |
NegCurrFormat |
ShortDateFormat |
ShortTimeFormat |
ThousandSeparator |
TimeAMString |
TimePMString |
TimeSeparator |
TwoDigitYearCenturyWindow |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
Expression |
GroupingLevel |
IndexName |
Name |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoGenerateValue |
AutoIncrementSeed |
AutoIncrementStep |
ClientAutoIncrement |
ProviderFlags |
ReadOnly |
ServerAutoIncrement |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Active |
CaseInsFields |
DescFields |
Expression |
Fields |
Filter |
FilterOptions |
Name |
Options |
Selected |


published Published Events

published Published Events
published Legend
Published Events
Name | Description
AfterExecute |
AfterScript |
BeforeExecute |
BeforeScript |
OnConsoleGet |
OnConsoleLockUpdate |
OnConsolePut |
OnError |
OnGetStream |
OnHostCommand |
OnPause |
OnProgress |
OnReleaseStream |
OnSpoolPut |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Arguments |
Connection |
DefaultDriverName |
FetchOptions |
FormatOptions |
Macros |
Params |
ResourceOptions |
ScriptDialog |
ScriptOptions |
SQLScriptFileName |
SQLScripts |


Legend

Legend
published
Legend
Property
Method
virtual


published Published Methods

published Published Methods
published Legend
Published Methods
Name | Description
Assign |
Create |


Published Methods

Legend
Legend
Method
virtual


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoPrintParams |
BreakOnError |
ColumnHeadings |
CommandSeparator |
CommitEachNCommands |
ConsoleOutput |
DefaultDataPath |
DefaultScriptPath |
DropNonexistObj |
EchoCommands |
EchoCommandTrim |
FeedbackCommands |
FeedbackScript |
LineSize |
MacroExpand |
MaxBytesToPrintLongs |
PageSize |
ParamArraySize |
SpoolFileName |
SpoolOutput |
Timing |
TrimConsole |
TrimSpool |
Verify |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
Name |
SQL |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
PersistentFileName |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoIncFields |
KeyFields |
UpdateTableName |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoClose | ..
Cache | Controls what kind of data to cache in memory.
Items | Controls what kind of data to fetch.
Mode | Controls how to fetch data.
RecordCountMode | Controls how to count records in resultset.
RecsMax | Controls the maximum number of records to be fetched.
RowsetSize | Controls the number of records per single fetch.
Unidirectional | Specifies possible directions of navigation by dataset records.


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
DefaultParamDataType |
InlineDataSize |
MapRules |
MaxBcdPrecision |
MaxBcdScale |
MaxStringSize |
OwnMapRules |
StrsEmpty2Null |
StrsTrim |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
PrecMax |
PrecMin |
ScaleMax |
ScaleMin |
SizeMax |
SizeMin |
SourceDataType |
TargetDataType |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
ArrayDMLSize |
AutoManage |
Backup |
CmdExecMode |
CmdExecTimeout |
DefaultParamType |
DirectExecute |
EscapeExpand |
MacroCreate |
MacroExpand |
ParamCreate |
ParamExpand |
Persistent |
SilentMode |


Legend

Legend
published
Legend
Property
write only


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoReconnect |
BackupExt |
BackupFolder |
DefaultStoreExt |
DefaultStoreFolder |
DefaultStoreFormat |
MaxCursors |
ServerOutput |
ServerOutputSize |


Published Properties

Legend
Legend
Property
write only


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
AutoCommit |
AutoStart |
AutoStop |
DisconnectAction |
Isolation |
Params |
ReadOnly |
StopOptions |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
CacheUpdateCommands |
CountUpdatedRecords |
EnableDelete |
EnableInsert |
EnableUpdate |
FastUpdates |
FetchGeneratorsPoint |
GeneratorName |
LockMode |
LockPoint |
LockWait |
ReadOnly |
RefreshMode |
RequestLive |
UpdateChangedFields |
UpdateMode |
UseProviderFlags |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
DataType |
Name |
Value |


published Published Properties

published Published Properties
published Legend
Published Properties
Name | Description
ADDataType |
ArraySize |
ArrayType |
DataType |
IsCaseSensitive |
Name |
NumericScale |
ParamType |
Position |
Precision |
Size |
Value |


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADBindedBy |
TADChangingKind |


Enumerations

Legend
Legend
Enumeration


Legend

Legend
Records, Enums
Legend
Enumeration


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADDataMoveMode |
TADDataMoveOption |
TADDataMovePhase |
TADDataSourceKind |
TADLogFileAction |
TADTextDataType |
TADTextEndOfLine |
TADTextFormatSettingsValue |
TADTextRecordFormat |


Legend

Legend
Records, Enums
Legend
Enumeration
Record


Records, Enums Records

Records, Enums Records
Records, Enums Legend
Records
Name | Description
TFormatSettings |


Records

Legend
Legend
Record


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADDataSetLocateOption |
TADKeyIndex |


Records, Enums Records

Records, Enums Records
Records, Enums Legend
Records
Name | Description
TADKeyBuffer |


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADScriptCommandLookupRes |
TADScriptEchoCommands |
TADScriptSpoolOutputMode |
TADScriptStatus |
TADScriptStreamMode |


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADFetchGeneratorsPoint |
TADFetchItem |
TADFetchMode |
TADFetchOptionValue |
TADFormatOptionValue |
TADLockMode |
TADLockPoint |
TADRecordCountMode |
TADRefreshMode |
TADResourceOptionValue |
TADStorageFormat |
TADTxAction |
TADTxIsolation |
TADTxStopOption |
TADTxValue |
TADUpdateOptionValue |


Records, Enums Enumerations

Records, Enums Enumerations
Records, Enums Legend
Enumerations
Name | Description
TADMacroDataType |
TADParamArrayType |
TADParamBindMode |


Types

Types
Types
Types
Name | Description
TADChangingKinds |
TADConnectionLoginEvent |
TADConnectionRecoverEvent |
TADCustomConnectionClass |
TADCustomManagerClass |
TADDescribeColumnEvent |
TADDescribeTableEvent |
TADErrorEvent |
TADExecuteErrorEvent |
TADOperationFinishedEvent |
TADReconcileRowEvent |
TADUpdateRowEvent |


Types

Types
Types
Types
Name | Description
TADDataMoveErrorEvent |
TADDataMoveFindDestRecordEvent |
TADDataMoveOptions |
TADDataMoveProgressEvent |
TADTextFormatSettingsValueSet |


Types

Types
Types
Types
Name | Description
PADKeyBuffer |
TADAfterApplyUpdatesEvent | ..
TADCopyDataSetOptions |
TADDataSetEvent |
TADDataSetFlags |
TADDataSetLocateOptions |
TADReconcileErrorEvent |
TADStoredActivationUsage |
TADUpdateErrorEvent |
TADUpdateRecordEvent |


Types

Types
Types
Types
Name | Description
TADConsoleGetEvent |
TADConsoleLockUpdate |
TADConsolePutEvent |
TADGetStreamEvent |
TADHostCommandEvent |
TADPauseEvent |
TADScriptCharSet |
TADScriptCommandClass |


Types

Types
Types
Types
Name | Description
TADFetchItems |
TADFetchOptionValues |
TADFormatOptionValues |
TADOptionChangeEvent |
TADResourceOptionValues |
TADTxStopOptions |
TADTxValues |
TADUpdateOptionValues |


Types

Types
Types
Types
Name | Description
TADGetOwner |


Example 1

Example 1
Array DML

Array DML with IADPhysCommand:

var
  oCmd: IADPhysCommand;
……
  with oCmd do begin
    CommandText := 'insert into Customers (ID, Name) values (:ID, :Name)';
    // Set up parameter types
    Params[0].DataType := ftInteger;
    Params[1].DataType := ftString;
    Params[1].Size := 40;
    // Set up parameters' array size
    Params.ArraySize := 10000;
    // Set parameter values
    for i := 0 to 10000 - 1 do begin
      Params[0].AsIntegers[i] := i;
      Params[1].AsStrings[i] := 'Somebody ' + IntToStr(i);
    end;
    // Execute batch
    Execute(10000, 0);
  end;


Example 2

Example 2
Array DML

Array DML with TADQuery and error handling:

procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  case AException.Errors[0].Kind of
  ekPKViolated:
    begin
      // fix ID to be unique
      ADQuery.Params[0].AsIntegers[AException.Errors[0].RowIndex] := AException.Errors[0].RowIndex;
      AAction := eaRetry;
    end;
  ekFKViolated:
    // if Region with RegionID is not found, then just skip row
    AAction := eaSkip;
  else
    AAction := eaFail;
  end;
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  with ADQuery1 do begin
    SQL.Text := 'insert into Customers (ID, RegionID, Name, Note) values (:ID, :RegionID, :Name, :Note)';
    // Set up parameter types
    Params[0].DataType := ftInteger;
    Params[1].DataType := ftInteger;
    Params[2].DataType := ftString;
    Params[2].Size := 40;
    Params[3].DataSize := ftMemo;
    // Set up parameters' array size
    Params.ArraySize := 10000;
    // Set parameter values
    for i := 0 to 10000 - 1 do begin
      if i mod 100 = 0 then
        // force PK violation
        Params[0].AsIntegers[i] := i - 1
      else
        Params[0].AsIntegers[i] := i;
      Params[1].AsIntegers[i] := GetRegionIdForCustomer(i);
      Params[2].AsStrings[i] := 'Somebody ' + IntToStr(i);
      Params[3].Clear(i);
    end;
    // Execute batch
    Execute(10000, 0);
  end;
end;


Topics

Topics
Command text preprocessing
Topics
Name | Description
Character macro functions |
Numeric macro functions |
Date and time macro functions |
System macro functions |
Convert macro function |


See Also

See Also
Retriving metadata
See Also

..


See Also

See Also
Setting options
See Also

..


See Also

See Also
uADCompClient Unit
See Also

..


uADCompClient Unit Classes

uADCompClient Unit Classes
uADCompClient Unit Legend
Classes
Name | Description
TADAdaptedDataSet | The TADAdaptedDataSet class uses data adapter to execute DBMS queries, open DBMS cursors, fetch rows and post changes back to DBMS.
TADCommand | The class is responsible for execution of SQL commands.
TADConnection | The class is responsible to connection establishment with a DBMS.
TADCustomCommand | The base class is responsible for execution of SQL commands.
TADCustomConnection | The class is responsible to connection establishment with a DBMS.
TADCustomManager | The class is responsible to connection definitions and connections management.
TADCustomMemTable | The class implementing in-memory dataset.
TADCustomQuery | The class implementing dataset, capable to execute SQL queries.
TADCustomSchemaAdapter |
TADCustomStoredProc | The class implementing dataset, capable to execute server side stored procedures.
TADCustomTableAdapter |
TADCustomTransaction | The class is responsible to transaction management for connection.
TADCustomUpdateObject | ..
TADManager | ..
TADMemTable | ..
TADMetaInfoCommand | ..
TADMetaInfoQuery | ..
TADQuery | ..
TADRdbmsDataSet | ..
TADSchemaAdapter |
TADStoredProc | ..
TADTable | ..
TADTableAdapter |
TADTransaction | ..
TADUpdateSQL | ..


Classes (AutoDoc Folder)

Legend
Legend
Class


uADCompClient Unit Functions

uADCompClient Unit Functions
uADCompClient Unit Legend
Functions
Name | Description
ADFindDefaultConnection |
ADManager | Function returns reference to global TADCustomManager object.
ADSetConnectionClass | Sets the TADCustomConnection descendant class.
ADSetManagerClass | Set the TADCustomManager descendant class.


Functions (AutoDoc Folder)

Legend
Legend
Method


Legend

Legend
uADCompClient Unit
Legend
Class
Method
Enumeration


Records, Enums

Records, Enums
uADCompClient Unit Legend
Records, Enums
Name | Description
TADBindedBy |
TADChangingKind |


Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration


Topics

Topics
uADCompClient Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADCompClient Unit Types

uADCompClient Unit Types
uADCompClient Unit
Types
Name | Description
TADChangingKinds |
TADConnectionLoginEvent |
TADConnectionRecoverEvent |
TADCustomConnectionClass |
TADCustomManagerClass |
TADDescribeColumnEvent |
TADDescribeTableEvent |
TADErrorEvent |
TADExecuteErrorEvent |
TADOperationFinishedEvent |
TADReconcileRowEvent |
TADUpdateRowEvent |


Example

Example
uADCompClient.ADManager Function
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=127.0.0.1');
  oList.Add('Database=addemo');
  ADManager.AddConnectionDef('myconn', 'MySQL', oList);


See Also

See Also
uADCompClient.ADManager Function
See Also

TADCustomManager


Example

Example
uADCompClient.ADSetConnectionClass Function
ADSetConnectionClass(TMyConnection);


See Also

See Also
uADCompClient.ADSetConnectionClass Function
See Also

TADCustomConnection, TADCustomConnection.ConnectionName


Example

Example
uADCompClient.ADSetManagerClass Function
ADSetManagerClass(TMyManager);


See Also

See Also
uADCompClient.ADSetManagerClass Function
See Also

TADCustomManager, ADManager


Example

Example
TADAdaptedDataSet.AbortJob Method
ADQuery1.ResourceOptions.CmdExecMode := amAsync;
ADQuery1.Open('select OrderID, count(*) from "Order Details" group by OrderID');
ADQuery1.AbortJob(True);


See Also

See Also
TADAdaptedDataSet.AbortJob Method
See Also

Disconnect


See Also

See Also
TADAdaptedDataSet.Adapter Property
See Also

TADCustomTableAdapter


See Also

See Also
TADAdaptedDataSet.Command Property
See Also

TADCustomCommand


See Also

See Also
TADAdaptedDataSet.DatSManager Property
See Also

TADDatSManager, TADDatSTable


Example

Example
TADAdaptedDataSet.Disconnect Method
ADQuery1.Disconnect(True);
// is equivalent to:
// ADQuery1.AbortJob(True);
// ADQuery1.Close;
// ADQuery1.Unprepare;


See Also

See Also
TADAdaptedDataSet.Disconnect Method
See Also

AbortJob


Example

Example
TADAdaptedDataSet.NextRecordSet Method
ADQuery1.FetchOptions.AutoClose := False;
ADQuery1.SQL.Text := 'select 1 as i; select ''qwe'' as s';
ADQuery1.Open;
ShowMessage(ADQuery1.Fields[0].FieldName + ' ' + ADQuery1.Fields[0].AsString); // output "i 1"
ADQuery1.NextRecordSet;
ShowMessage(ADQuery1.Fields[0].FieldName + ' ' + ADQuery1.Fields[0].AsString); // output "s qwe"
ADQuery1.Close;


See Also

See Also
TADAdaptedDataSet.NextRecordSet Method
See Also

TADFetchOptions.AutoClose, TDataSet.Open, TDataSet.Close


See Also

See Also
TADAdaptedDataSet.Offline Method
See Also

TADCustomConnection.Offline, TADCustomConnection.Online


See Also

See Also
TADAdaptedDataSet.OnError Event
See Also

TDataSet.Open, TADDataSet.Execute, TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, OnExecuteError, OnUpdateError


Example

Example
TADAdaptedDataSet.OnExecuteError Event
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


See Also

See Also
TADAdaptedDataSet.OnExecuteError Event
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute


See Also

See Also
TADAdaptedDataSet.PointedConnection Property
See Also

TADRdbmsDataSet.Connection, TADRdbmsDataSet.ConnectionName, TADCustomConnection


See Also

See Also
TADCommand Class
See Also

TADCustomCommand, TADCustomQuery, IADPhysCommand


Example

Example
TADCommand.Active Property
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


See Also

See Also
TADCommand.Active Property
See Also

Fetch, Define, Open, Close, CloseAll, State


See Also

See Also
TADCommand.AfterClose Event
See Also

BeforeClose, Close, Active


Example

Example
TADCommand.AfterExecute Event
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


See Also

See Also
TADCommand.AfterExecute Event
See Also

BeforeExecute, Execute


See Also

See Also
TADCommand.AfterOpen Event
See Also

BeforeOpen, Open, Active


See Also

See Also
TADCommand.AfterPrepare Event
See Also

BeforePrepare, Prepare


See Also

See Also
TADCommand.AfterUnprepare Event
See Also

BeforeUnprepare, Unprepare


Example

Example
TADCommand.BaseObjectName Property
ADCommand1.BaseObjectName := 'MY_PACK';
ADCommand1.CommandText.Text := 'PROC1';
// or just ADCommand1.CommandText.Text := 'MY_PACK.PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Codegear Delphi';
ADCommand1.Execute;


See Also

See Also
TADCommand.BaseObjectName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind


See Also

See Also
TADCommand.BeforeClose Event
See Also

AfterClose, Close, Active


See Also

See Also
TADCommand.BeforeExecute Event
See Also

AfterExecute, Execute


See Also

See Also
TADCommand.BeforeOpen Event
See Also

AfterOpen, Open, Active


See Also

See Also
TADCommand.BeforePrepare Event
See Also

AfterPrepare, Prepare


See Also

See Also
TADCommand.BeforeUnprepare Event
See Also

BeforeUnprepare, Unprepare


Example 1

Example 1
TADCommand.CatalogName Property
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADCommand.CatalogName Property
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADCommand.CatalogName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


Example 1

Example 1
TADCommand.CommandKind Property
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;


Example 2

Example 2
TADCommand.CommandKind Property
ADCommand1.CommandText.Text := 'ALTER PROCEDURE MY_PROC COMPILE';
case ADCommand1.CommandKind of
skAlter: ShowMessage('Alter command');
..........
else     ShowMessage('Other command');
end;


See Also

See Also
TADCommand.CommandKind Property
See Also

CommandText


Example 1

Example 1
TADCommand.CommandText Property

Stored procedure:

ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;


Example 2

Example 2
TADCommand.CommandText Property

General SQL command:

ADCommand1.CommandText.Text := 'insert into MyTab values (:p1)';
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;


Example 3

Example 3
TADCommand.CommandText Property

Adding long command:

with ADCommand1.CommandText do begin
  BeginUpdate;
  Add('............');
  ......
  Add('............');
  EndUpdate;
end;


See Also

See Also
TADCommand.CommandText Property
See Also

TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADResourceOptions.PreprocessCmdText, TADPhysCommandIntf.SourceObjectName, CommandKind, Params, Macros, ResourceOptions


See Also

See Also
TADCommand.Connection Property
See Also

ConnectionName, Prepare


See Also

See Also
TADCommand.ConnectionName Property
See Also

Connection, Prepare


See Also

See Also
TADCommand.FetchOptions Property
See Also

TADFetchOptions, Fetch


See Also

See Also
TADCommand.FormatOptions Property
See Also

TADFormatOptions, Fetch, Params


Example 1

Example 1
TADCommand.Macros Property

Substitute table name:

ADCommand1.CommandText.Text := 'select * from &Tab';
ADCommand1.Macros[0].AsIdentifier := 'Order Details';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from "Order Details"


Example 2

Example 2
TADCommand.Macros Property

Substitute WHERE condition:

ADCommand1.CommandText.Text := 'select * from MyTab {if !cond} where !cond {fi}';
ADCommand1.Macros[0].AsString := 'ID > 100';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab where ID > 100
ADCommand1.Macros[0].Clear;
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab


See Also

See Also
TADCommand.Macros Property
See Also

CommandText, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand


Example

Example
TADCommand.OnCommandChanged Event
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


See Also

See Also
TADCommand.OnCommandChanged Event
See Also

CommandText


Example 1

Example 1
TADCommand.OnError Event

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADCommand.OnError Event

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADCommand.OnError Event
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException


Example

Example
TADCommand.Overload Property
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


See Also

See Also
TADCommand.Overload Property
See Also

CommandText, CommandKind


See Also

See Also
TADCommand.Params Property
See Also

CommandText, Macros, Prepare, TADParams, TADResourceOptions.ParamCreate, TADFetchOptions.Items


See Also

See Also
TADCommand.Prepared Property
See Also

Prepare, Unprepare, State, Params


See Also

See Also
TADCommand.ResourceOptions Property
See Also

TADBottomResourceOptions


Example 1

Example 1
TADCommand.SchemaName Property
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADCommand.SchemaName Property
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADCommand.SchemaName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


See Also

See Also
TADCommand.Transaction Property
See Also

TADTransaction, TADCustomConnection.Transaction


See Also

See Also
TADCommand.UpdateOptions Property
See Also

TADBottomUpdateOptions


See Also

See Also
TADConnection Class
See Also

TADCustomConnection, IADPhysConnection


Example

Example
TADConnection.Connected Property
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


See Also

See Also
TADConnection.Connected Property
See Also

TCustomConnection.BeforeConnect, TCustomConnection.AfterConnect, TCustomConnection.BeforeDisconnect, TCustomConnection.AfterDisconnect, ConnectionDefName, DriverName, Params, Offlined


Example 1

Example 1
TADConnection.ConnectionDefName Property
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


Example 2

Example 2
TADConnection.ConnectionDefName Property

See demo AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs for details how to create and use connection definitions.


See Also

See Also
TADConnection.ConnectionDefName Property
See Also

TADCustomManager


Example

Example
TADConnection.ConnectionName Property
ADConnection1.ConnectionName := 'TestConn';
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.ConnectionName := 'TestConn';
ADQuery1.Open('select * from test_tab');


See Also

See Also
TADConnection.ConnectionName Property
See Also

ConnectionDefName, DriverName, Params, TADCustomCommand.ConnectionName, TADRDBMSDataSet.ConnectionName


Example

Example
TADConnection.DriverName Property
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.Connection := ADConnection1;
ADQuery1.Open('select * from test_tab');


See Also

See Also
TADConnection.DriverName Property
See Also

Params, ConnectionDefName


See Also

See Also
TADConnection.FetchOptions Property
See Also

TADFetchOptions


See Also

See Also
TADConnection.FormatOptions Property
See Also

TADFormatOptions


Example

Example
TADConnection.LoginDialog Property

Using private login dialog

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


See Also

See Also
TADConnection.LoginDialog Property
See Also

TADGUIxFormsLoginDialog, LoginPrompt, SharedCliHandle, ADGUIxSilent


Example 1

Example 1
TADConnection.LoginPrompt Property

Using login dialog:

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


Example 2

Example 2
TADConnection.LoginPrompt Property

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := 'sql';
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


See Also

See Also
TADConnection.LoginPrompt Property
See Also

OnLogin, LoginDialog, Params, SharedCliHandle, ADGUIxSilent


Example

Example
TADConnection.OnError Event
procedure TForm1.ADConnection1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if (AException is EADDBEngineException) and (EADDBEngineException(AException).Kind = ekUKViolated) then begin
    AException.Free;
    AException := Exception.Create('You must enter unique document number !');
  end;
end;


See Also

See Also
TADConnection.OnError Event
See Also

EADDBEngineException


Example

Example
TADConnection.OnLogin Event

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := InputBox('Login', 'Please enter DBA password', 'sql');
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


See Also

See Also
TADConnection.OnLogin Event
See Also

LoginPrompt, Connected, IADStanConnectionDef


See Also

See Also
TADConnection.OnLosted Event
See Also

OnRecover, OnRestored


See Also

See Also
TADConnection.OnRecover Event
See Also

OnLosted, OnRestored, TADTopResourceOptions.AutoConnRestore, Connected, Offlined


See Also

See Also
TADConnection.OnRestored Event
See Also

OnLosted, OnRecover


Example

Example
TADConnection.Params Property
with ADConnection1.Params do begin
  Clear;
  Add('DriverID=Ora');
  Add('Database=ORA_920_APP');
  Add('User_Name=ADDemo');
  Add('Password=a');
end;
ADConnection1.Connected := True;


See Also

See Also
TADConnection.Params Property
See Also

ConnectionDefName, DriverName, OnLogin


See Also

See Also
TADConnection.ResourceOptions Property
See Also

TADTopResourceOptions


See Also

See Also
TADConnection.Transaction Property
See Also

UpdateTransaction, TADCustomTransaction


See Also

See Also
TADConnection.TxOptions Property
See Also

Transaction, TADTxOptions


See Also

See Also
TADConnection.UpdateOptions Property
See Also

TADUpdateOptions


See Also

See Also
TADConnection.UpdateTransaction Property
See Also

Transaction, TADCustomTransaction


See Also

See Also
TADCustomCommand Class
See Also

TADCommand, TADCustomQuery, IADPhysCommand


Example

Example
TADCustomCommand.AbortJob Method
ADCommand1.ResourceOptions.CmdExecMode := amAsync;
ADCommand1.Prepare('select OrderID, count(*) from "Order Details" group by OrderID');
ADCommand1.Open;
ADCommand1.AbortJob(True);


See Also

See Also
TADCustomCommand.AcquireConnection Method
See Also

ReleaseConnection, Connection, ConnectionName


Example

Example
TADCustomCommand.Active Property
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


See Also

See Also
TADCustomCommand.Active Property
See Also

Fetch, Define, Open, Close, CloseAll, State


See Also

See Also
TADCustomCommand.AfterClose Event
See Also

BeforeClose, Close, Active


Example

Example
TADCustomCommand.AfterExecute Event
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


See Also

See Also
TADCustomCommand.AfterExecute Event
See Also

BeforeExecute, Execute


Example

Example
TADCustomCommand.AfterFetch Event
procedure TForm1.ADCommand1AfterFetch(ASender: TObject);
begin
  StatusBar1.SimpleText := Format('%d rows fetched', [ADCommand1.RowsAffected]);
end;


See Also

See Also
TADCustomCommand.AfterFetch Event
See Also

BeforeFetch, Fetch


See Also

See Also
TADCustomCommand.AfterOpen Event
See Also

BeforeOpen, Open, Active


See Also

See Also
TADCustomCommand.AfterPrepare Event
See Also

BeforePrepare, Prepare


See Also

See Also
TADCustomCommand.AfterUnprepare Event
See Also

BeforeUnprepare, Unprepare


Example

Example
TADCustomCommand.BaseObjectName Property
ADCommand1.BaseObjectName := 'MY_PACK';
ADCommand1.CommandText.Text := 'PROC1';
// or just ADCommand1.CommandText.Text := 'MY_PACK.PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Codegear Delphi';
ADCommand1.Execute;


See Also

See Also
TADCustomCommand.BaseObjectName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind


See Also

See Also
TADCustomCommand.BeforeClose Event
See Also

AfterClose, Close, Active


See Also

See Also
TADCustomCommand.BeforeExecute Event
See Also

AfterExecute, Execute


See Also

See Also
TADCustomCommand.BeforeFetch Event
See Also

AfterFetch, Fetch


See Also

See Also
TADCustomCommand.BeforeOpen Event
See Also

AfterOpen, Open, Active


See Also

See Also
TADCustomCommand.BeforePrepare Event
See Also

AfterPrepare, Prepare


See Also

See Also
TADCustomCommand.BeforeUnprepare Event
See Also

BeforeUnprepare, Unprepare


See Also

See Also
TADCustomCommand.BindedBy Property
See Also

Connection, ConnectionName


Example 1

Example 1
TADCustomCommand.CatalogName Property
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADCustomCommand.CatalogName Property
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADCustomCommand.CatalogName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


Example

Example
TADCustomCommand.Close Method
var
  oTab: TADDatSTable;
....
  ADCommand1.Prepare('select * from "Orders"');
  oTab := ADCommand1.Define;
  try
    ADCommand1.Fetch(oTab);
  finally
    ADCommand1.Close;
    oTab.Free;
  end;


See Also

See Also
TADCustomCommand.Close Method
See Also

Open, Active, CloseAll, NextRecordSet, BeforeClose, AfterClose


See Also

See Also
TADCustomCommand.CloseAll Method
See Also

Open, Active, Close, NextRecordSet, BeforeClose, AfterClose


See Also

See Also
TADCustomCommand.CommandIntf Property
See Also

IADPhysCommand


Example 1

Example 1
TADCustomCommand.CommandKind Property
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;


Example 2

Example 2
TADCustomCommand.CommandKind Property
ADCommand1.CommandText.Text := 'ALTER PROCEDURE MY_PROC COMPILE';
case ADCommand1.CommandKind of
skAlter: ShowMessage('Alter command');
..........
else     ShowMessage('Other command');
end;


See Also

See Also
TADCustomCommand.CommandKind Property
See Also

CommandText


Example 1

Example 1
TADCustomCommand.CommandText Property

Stored procedure:

ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'MY_PROC';
ADCommand1.Prepare;
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;


Example 2

Example 2
TADCustomCommand.CommandText Property

General SQL command:

ADCommand1.CommandText.Text := 'insert into MyTab values (:p1)';
ADCommand1.Params[0].AsString := 'qwe';
ADCommand1.Execute;


Example 3

Example 3
TADCustomCommand.CommandText Property

Adding long command:

with ADCommand1.CommandText do begin
  BeginUpdate;
  Add('............');
  ......
  Add('............');
  EndUpdate;
end;


See Also

See Also
TADCustomCommand.CommandText Property
See Also

TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADResourceOptions.PreprocessCmdText, TADPhysCommandIntf.SourceObjectName, CommandKind, Params, Macros, ResourceOptions


See Also

See Also
TADCustomCommand.Connection Property
See Also

ConnectionName, Prepare


See Also

See Also
TADCustomCommand.ConnectionName Property
See Also

Connection, Prepare


Example

Example
TADCustomCommand.Define Method (TADDatSManager, TADDatSTable, TADPhysMetaInfoMergeMode)

..


See Also

See Also
TADCustomCommand.Define Method (TADDatSManager, TADDatSTable, TADPhysMetaInfoMergeMode)
See Also

..


Example

Example
TADCustomCommand.Define Method (TADDatSTable, TADPhysMetaInfoMergeMode)
var
  oTab: TADDatSTable;
....
  ADCommand1.Prepare('select * from MyTab');
  oTab := ADCommand1.Define;
  ADCommand1.Open;
  ADCommand1.Fetch(oTab);
  ADCommand1.Close;

  // Some time later, after the structure of DB table MyTab have changed.
  // For example, field was removed.

  ADCommand1.Prepare('select * from MyTab');
  oTab := ADCommand1.Define(oTab, mmOverride);
  ADCommand1.Open;
  ADCommand1.Fetch(oTab);
  ADCommand1.Close;


See Also

See Also
TADCustomCommand.Define Method (TADDatSTable, TADPhysMetaInfoMergeMode)
See Also

TADDatSTable, TADDatSTable.Columns


Example

Example
TADCustomCommand.Disconnect Method
ADCommand1.CommandText.Text := 'select * from [Order Details]';
ADCommand1.Prepare := True;
ADCommand1.Active := True;
ADCommand1.Disconnect;
// Active = False and Prepare = False


Example

Example
TADCustomCommand.Execute Method (Integer, Integer)
ADCommand1.CommandText.Text := 'create table MyTab (f1 number, f2 varchar2(10))';
ADCommand1.Execute;


See Also

See Also
TADCustomCommand.Execute Method (Integer, Integer)
See Also

RowsAffected, SQL, Params


Example

Example
TADCustomCommand.Execute Method (String, array of Variant, array of TFieldType)
ADCommand1.Execute('insert into MyTab (id, bval) values (:id, :bval)', [100, StringOfChar('x', 100000)], [ftInteger, ftBLOB]);


See Also

See Also
TADCustomCommand.Execute Method (String, array of Variant, array of TFieldType)
See Also

RowsAffected, SQL, Params


Example

Example
TADCustomCommand.Execute Method (String, array of Variant)
ADCommand1.Execute('delete from MyTab where id = : id', [100]);


See Also

See Also
TADCustomCommand.Execute Method (String, array of Variant)
See Also

RowsAffected, SQL, Params


Example

Example
TADCustomCommand.Execute Method (String)
ADCommand1.Execute('DROP TABLE MyTab');


See Also

See Also
TADCustomCommand.Execute Method (String)
See Also

RowsAffected, SQL, Params


Example

Example
TADCustomCommand.Fetch Method
var
  oTab: TADDatSTable;
...
  ADCommand1.CommandKind := skStoredProc;
  ADCommand1.CommandText.Text := 'SEL_CUST_PROC';
  oTab := ADCommand1.Define;
  try
    ADCommand1.Open;
    repeat
      oTab.Clear;
      ADCommand1.Fetch(oTab, False);
      // process next rowset
    until ADCommand1.RowsAffected = 0;
  finally
    oTab.Free;
  end;


See Also

See Also
TADCustomCommand.Fetch Method
See Also

TADFetchOptions, Close, CloseAll, Open, Active


See Also

See Also
TADCustomCommand.FetchOptions Property
See Also

TADFetchOptions, Fetch


See Also

See Also
TADCustomCommand.FillParams Method
See Also

Params, TADFetchOptions.Items, TADResourceOptions.CreateParams


See Also

See Also
TADCustomCommand.FindMacro Method
See Also

Macros, MacroByName


See Also

See Also
TADCustomCommand.FindParam Method
See Also

Params, ParamByName, Values


See Also

See Also
TADCustomCommand.FixedCommandKind Property
See Also

CommandKind


See Also

See Also
TADCustomCommand.FormatOptions Property
See Also

TADFormatOptions, Fetch, Params


See Also

See Also
TADCustomCommand.GetConnection Method
See Also

Connection, ConnectionName, AcquireConnection, ReleaseConnection


See Also

See Also
TADCustomCommand.MacroByName Method
See Also

Macros, FindMacro


Example 1

Example 1
TADCustomCommand.Macros Property

Substitute table name:

ADCommand1.CommandText.Text := 'select * from &Tab';
ADCommand1.Macros[0].AsIdentifier := 'Order Details';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from "Order Details"


Example 2

Example 2
TADCustomCommand.Macros Property

Substitute WHERE condition:

ADCommand1.CommandText.Text := 'select * from MyTab {if !cond} where !cond {fi}';
ADCommand1.Macros[0].AsString := 'ID > 100';
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab where ID > 100
ADCommand1.Macros[0].Clear;
ADCommand1.Prepare;
ShowMessage(ADCommand1.SQLText); // select * from MyTab


See Also

See Also
TADCustomCommand.Macros Property
See Also

CommandText, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand


Example

Example
TADCustomCommand.NextRecordSet Method
ADCommand1.FetchOptions.AutoClose := False;
ADCommand1.CommandText.Text := 'select 1 as i; select ''qwe'' as s';
ADCommand1.Open;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ShowMessage(oTab.Rows[0].DumpRow(True)); // output "i: 1"
finally
  oTab.Free;
end;
ADCommand1.NextRecordSet;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ShowMessage(oTab.Rows[0].DumpRow(True)); // output "s: qwe"
finally
  oTab.Free;
end;
ADQuery1.CloseAll;


See Also

See Also
TADCustomCommand.NextRecordSet Method
See Also

TADFetchOptions.AutoClose, TADCustomCommand.Open, TADCustomCommand.Close, TADCustomCommand.CloseAll, TADCustomCommand.Fetch


Example

Example
TADCustomCommand.OnCommandChanged Event
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


See Also

See Also
TADCustomCommand.OnCommandChanged Event
See Also

CommandText


Example 1

Example 1
TADCustomCommand.OnError Event

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADCustomCommand.OnError Event

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADCustomCommand.OnError Event
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException


See Also

See Also
TADCustomCommand.Open Method
See Also

Active, Close, CloseAll, State


Example

Example
TADCustomCommand.OpenOrExecute Method
if ADCommand1.OpenOrExecute then begin
  oTab := ADCommand1.Define;
  try
    ADCommand1.Fetch(oTab);
  finally
    ADCommand1.CloseAll;
    oTab.Free;
  end;
end;


See Also

See Also
TADCustomCommand.OpenOrExecute Method
See Also

Execute, Open, Active, Close, CloseAll


Example

Example
TADCustomCommand.Overload Property
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


See Also

See Also
TADCustomCommand.Overload Property
See Also

CommandText, CommandKind


See Also

See Also
TADCustomCommand.ParamBindMode Property
See Also

Params


See Also

See Also
TADCustomCommand.ParamByName Method
See Also

Params, FindParam, Values


See Also

See Also
TADCustomCommand.Params Property
See Also

CommandText, Macros, Prepare, TADParams, TADResourceOptions.ParamCreate, TADFetchOptions.Items


Example

Example
TADCustomCommand.Prepare Method
ADCommand1.Prepare('select * from MyTab');


See Also

See Also
TADCustomCommand.Prepare Method
See Also

Prepared, Unprepare, State, Params


See Also

See Also
TADCustomCommand.Prepared Property
See Also

Prepare, Unprepare, State, Params


See Also

See Also
TADCustomCommand.ReleaseConnection Method
See Also

AcquireConnection, Connection, ConnectionName


See Also

See Also
TADCustomCommand.ResourceOptions Property
See Also

TADBottomResourceOptions


Example

Example
TADCustomCommand.RowsAffected Property
procedure TForm1.ADCommand1AfterExecute(ASender: TObject);
begin
  if ADCommand1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADCommand1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADCommand1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADCommand1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADCommand1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADCommand1.RowsAffected]);
    end;
end;


See Also

See Also
TADCustomCommand.RowsAffected Property
See Also

Execute, Fetch


Example 1

Example 1
TADCustomCommand.SchemaName Property
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADCustomCommand.SchemaName Property
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADCustomCommand.SchemaName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


See Also

See Also
TADCustomCommand.SQLText Property
See Also

CommandText, Prepare


See Also

See Also
TADCustomCommand.State Property
See Also

Prepare, Execute, Open, AbortJob, Fetch, Close, Unprepare


See Also

See Also
TADCustomCommand.Transaction Property
See Also

TADTransaction, TADCustomConnection.Transaction


See Also

See Also
TADCustomCommand.Unprepare Method
See Also

Prepare, Prepared


See Also

See Also
TADCustomCommand.UpdateOptions Property
See Also

TADBottomUpdateOptions


Example 1

Example 1
TADCustomCommand.Values Property

The following statements are semantically identical and write the value from an edit box into an integer parameter:

ADCommand1.Values['CustNo'] := Edit1.Text;
ADCommand1['CustNo'] := Edit1.Text;


Example 2

Example 2
TADCustomCommand.Values Property

The next statement reads a string value from a parameter into an edit box:

Edit1.Text := ADCommand1['Company'];


See Also

See Also
TADCustomCommand.Values Property
See Also

Params, ParamByName, FindParam, TADParam.Value


See Also

See Also
TADCustomConnection Class
See Also

TADConnection, IADPhysConnection


See Also

See Also
TADCustomConnection.CheckActive Method
See Also

TADTopResourceOptions.AutoConnect, Connected


See Also

See Also
TADCustomConnection.CheckInactive Method
See Also

TADTopResourceOptions.AutoConnect, Connected


See Also

See Also
TADCustomConnection.CheckOnline Method
See Also

TADTopResourceOptions.AutoOnline, Offlined


Example 1

Example 1
TADCustomConnection.CliHandle Property

See demo application AnyDAC\Samples\Comp Layer\TADConnection\DLL_Sharing.


Example 2

Example 2
TADCustomConnection.CliHandle Property

Application code (without checks):

  FhDll := LoadLibrary(PChar('Project2.dll'));
  @FpShowData := GetProcAddress(FhDll, PChar('ShowData'));
  FpShowData(ADConnection1.CliHandle);

DLL code:

procedure ShowData(ACliHandle: LongWord);
begin
  ADConnection1.SharedCliHandle := ACliHandle;
  ADConnection1.Connected := True;
  ADQuery1.Active := True;
end;


See Also

See Also
TADCustomConnection.CliHandle Property
See Also

SharedCliHandle, Connected


Example

Example
TADCustomConnection.CommandCount Property
var
  i: Integer;
...
  for i := ADConnection1.CommandCount - 1 downto 0 do
    ADConnection1.Commands[i].Disconnect(True);


See Also

See Also
TADCustomConnection.CommandCount Property
See Also

Commands, TADCustomCommand


Example

Example
TADCustomConnection.Commands Property
var
  i: Integer;
...
  for i := ADConnection1.CommandCount - 1 downto 0 do
    ADConnection1.Commands[i].Disconnect(True);


See Also

See Also
TADCustomConnection.Commands Property
See Also

CommandCount, TADCustomCommand


Example

Example
TADCustomConnection.Commit Method
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.Commit;
    end;
  except
    ADConnection1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomConnection.Commit Method
See Also

StartTransaction, InTransaction, Rollback, CommitRetaining


Example

Example
TADCustomConnection.CommitRetaining Method
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.CommitRetaining;
    end;
  except
    ADConnection1.RollbackRetaining;
    raise;
  end;
end;


See Also

See Also
TADCustomConnection.CommitRetaining Method
See Also

StartTransaction, InTransaction, Rollback, Commit


Example

Example
TADCustomConnection.Connected Property
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


See Also

See Also
TADCustomConnection.Connected Property
See Also

TCustomConnection.BeforeConnect, TCustomConnection.AfterConnect, TCustomConnection.BeforeDisconnect, TCustomConnection.AfterDisconnect, ConnectionDefName, DriverName, Params, Offlined


Example 1

Example 1
TADCustomConnection.ConnectionDefName Property
ADConnection1.ConnectionDefName := 'ASA_Demo';
ADConnection1.Connected := True;


Example 2

Example 2
TADCustomConnection.ConnectionDefName Property

See demo AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs for details how to create and use connection definitions.


See Also

See Also
TADCustomConnection.ConnectionDefName Property
See Also

TADCustomManager


See Also

See Also
TADCustomConnection.ConnectionIntf Property
See Also

IADPhysConnection


Example

Example
TADCustomConnection.ConnectionName Property
ADConnection1.ConnectionName := 'TestConn';
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.ConnectionName := 'TestConn';
ADQuery1.Open('select * from test_tab');


See Also

See Also
TADCustomConnection.ConnectionName Property
See Also

ConnectionDefName, DriverName, Params, TADCustomCommand.ConnectionName, TADRDBMSDataSet.ConnectionName


Example

Example
TADCustomConnection.DataSets Property
var
  i: Integer;
...
  for i := ADConnection1.DataSetCount - 1 downto 0 do
    ADConnection1.DataSets[i].Disconnect(True);


See Also

See Also
TADCustomConnection.DataSets Property
See Also

DataSetCount, TADRdbmsDataSet


Example

Example
TADCustomConnection.DecodeObjectName Method

On Oracle:

var
  sCatalog, sSchema, sBaseObj, sObj: String;
...
  ADConnection1.DecodeObjectName('ADDemo."MyPack".Proc1', sCatalog, sSchema, sBaseObj, sObj);
  // sCatalog -> ''
  // sSchema -> ADDEMO
  // sBaseObj -> MyPack
  // sObj -> PROC1


See Also

See Also
TADCustomConnection.DecodeObjectName Method
See Also

EncodeObjectName


Example

Example
TADCustomConnection.DriverName Property
ADConnection1.DriverName := 'Oracl';'
ADConnection1.Params.Add('Database=testdb');
....
ADQuery1.Connection := ADConnection1;
ADQuery1.Open('select * from test_tab');


See Also

See Also
TADCustomConnection.DriverName Property
See Also

Params, ConnectionDefName


Example

Example
TADCustomConnection.EncodeObjectName Method

On Oracle:

ShowMessage(ADConnection1.EncodeObjectName('', 'ADDEMO', 'MyPack', 'PROC1')); // -> ADDEMO."MyPack".PROC1


See Also

See Also
TADCustomConnection.EncodeObjectName Method
See Also

DecodeObjectName


Example

Example
TADCustomConnection.ExecSQL Method (String, array of Variant, array of TFieldType)
ADConnection1.ExecSQL('update mytab where id = :p1 set blobfld = :blb',
  [1000, StringOfChar('x', 100000)], [ftInteger, ftBLOB]);


See Also

See Also
TADCustomConnection.ExecSQL Method (String, array of Variant, array of TFieldType)
See Also

TADQuery


Example

Example
TADCustomConnection.ExecSQL Method (String, array of Variant)
ADConnection1.ExecSQL('delete from mytab where id > :p1', [1000]);


See Also

See Also
TADCustomConnection.ExecSQL Method (String, array of Variant)
See Also

TADQuery


Example

Example
TADCustomConnection.ExecSQL Method (String)
ADConnection1.ExecSQL('truncate table tab1');


See Also

See Also
TADCustomConnection.ExecSQL Method (String)
See Also

TADQuery


See Also

See Also
TADCustomConnection.FetchOptions Property
See Also

TADFetchOptions


See Also

See Also
TADCustomConnection.FormatOptions Property
See Also

TADFormatOptions


Example

Example
TADCustomConnection.GetFieldNames Method
ADConnection1.GetFieldNames('', '', 'MYTAB', '', ListBox1.Items);


See Also

See Also
TADCustomConnection.GetFieldNames Method
See Also

TADMetaInfoQuery


Example

Example
TADCustomConnection.GetGeneratorNames Method
ADConnection1.GetGeneratorNames('', '', 'MY%', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomConnection.GetGeneratorNames Method
See Also

TADMetaInfoQuery


Example

Example
TADCustomConnection.GetKeyFieldNames Method
ADConnection1.GetKeyFieldNames('NORTHWIND', 'DBO', 'MYTAB', '', ListBox1.Items);


See Also

See Also
TADCustomConnection.GetKeyFieldNames Method
See Also

TADMetaInfoQuery


Example

Example
TADCustomConnection.GetLastAutoGenValue Method
ShowMessage(VarToStr(ADConnection1.GetLastAutoGenValue('MyGen')));


See Also

See Also
TADCustomConnection.GetLastAutoGenValue Method
See Also

RDBMSKind


Example

Example
TADCustomConnection.GetPackageNames Method
ADConnection1.GetPackageNames('', 'SYS', 'DBMS%', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomConnection.GetPackageNames Method
See Also

TADMetaInfoQuery


Example

Example
TADCustomConnection.GetStoredProcNames Method
ADConnection1.GetStoredProcNames('', '', '', '', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomConnection.GetStoredProcNames Method
See Also

TADMetaInfoQuery


Example

Example
TADCustomConnection.GetTableNames Method
ADConnection1.GetTableNames('NORTHWIND', 'DBO', 'ADQA%', '', ListBox1.Items,
  [osMy, osSystem, osOther], [tkTable, tkView]);


See Also

See Also
TADCustomConnection.GetTableNames Method
See Also

TADMetaInfoQuery


See Also

See Also
TADCustomConnection.InTransaction Property
See Also

StartTransaction, Commit, Rollback, TADTransaction


Example

Example
TADCustomConnection.LoginDialog Property

Using private login dialog

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


See Also

See Also
TADCustomConnection.LoginDialog Property
See Also

TADGUIxFormsLoginDialog, LoginPrompt, SharedCliHandle, ADGUIxSilent


Example 1

Example 1
TADCustomConnection.LoginPrompt Property

Using login dialog:

ADGUIxFormsLoginDialog1.Caption := 'Welcome to the Northwind DB';
ADGUIxFormsLoginDialog1.VisibleItems.Add('User_name');
ADGUIxFormsLoginDialog1.VisibleItems.Add('Password');
ADConnection1.LoginDialog := ADGUIxFormsLoginDialog1;
ADConnection1.LoginPrompt := True;
ADConnection1.Connected := True;


Example 2

Example 2
TADCustomConnection.LoginPrompt Property

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := 'sql';
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


See Also

See Also
TADCustomConnection.LoginPrompt Property
See Also

OnLogin, LoginDialog, Params, SharedCliHandle, ADGUIxSilent


Example

Example
TADCustomConnection.Offline Method
ADConnection1.Offline;
lblState.Caption := '<not connected>';


See Also

See Also
TADCustomConnection.Offline Method
See Also

Online, Offlined, Connected, TADAdaptedDataSet.Offline


See Also

See Also
TADCustomConnection.Offlined Property
See Also

TADTopResourceOptions.AutoOnline, TADResourceOptions.AutoDisconnect, Connected, Offline, Online


Example

Example
TADCustomConnection.OnError Event
procedure TForm1.ADConnection1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if (AException is EADDBEngineException) and (EADDBEngineException(AException).Kind = ekUKViolated) then begin
    AException.Free;
    AException := Exception.Create('You must enter unique document number !');
  end;
end;


See Also

See Also
TADCustomConnection.OnError Event
See Also

EADDBEngineException


Example

Example
TADCustomConnection.Online Method
ADConnection1.Online;
lblState.Caption := '<connected>';


See Also

See Also
TADCustomConnection.Online Method
See Also

Offline, Offlined, Connected


Example

Example
TADCustomConnection.OnLogin Event

Connecting without login dialog:

procedure TForm1.ADConnection1Login(AConnection: TADCustomConnection; const AConnectionDef: IADStanConnectionDef);
begin
  AConnectionDef.UserName := 'dba';
  AConnectionDef.Password := InputBox('Login', 'Please enter DBA password', 'sql');
end;

procedure TForm1.Button1Click(ASender: TObject);
begin
  ADConnection1.OnLogin := ADConnection1Login;
  ADConnection1.LoginPrompt := True;
  ADConnection1.Connected := True;
end;


See Also

See Also
TADCustomConnection.OnLogin Event
See Also

LoginPrompt, Connected, IADStanConnectionDef


See Also

See Also
TADCustomConnection.OnLosted Event
See Also

OnRecover, OnRestored


See Also

See Also
TADCustomConnection.OnRecover Event
See Also

OnLosted, OnRestored, TADTopResourceOptions.AutoConnRestore, Connected, Offlined


See Also

See Also
TADCustomConnection.OnRestored Event
See Also

OnLosted, OnRecover


See Also

See Also
TADCustomConnection.OptionsIntf Property
See Also

IADStanOptions


Example

Example
TADCustomConnection.Params Property
with ADConnection1.Params do begin
  Clear;
  Add('DriverID=Ora');
  Add('Database=ORA_920_APP');
  Add('User_Name=ADDemo');
  Add('Password=a');
end;
ADConnection1.Connected := True;


See Also

See Also
TADCustomConnection.Params Property
See Also

ConnectionDefName, DriverName, OnLogin


Example

Example
TADCustomConnection.Ping Method
procedure TMyDataModule.DoPing(ASender: TObject);
begin
  if not ADConnection1.Ping then
    ShowMessage('Connection is losted !');
end;
.......
FTimer := TTimer.Create;
FTimer.OnTimer := DoPing;
FTimer.Interval := 30000; // each 30 secs
FTimer.Enabled := True;


See Also

See Also
TADCustomConnection.Ping Method
See Also

TADTopResourceOptions.AutoReconnect, Offline, Online, Connected


Example

Example
TADCustomConnection.RDBMSKind Property
case ADConnection1.RDBMSKind of
mkOracle:    s := 'select mySeq.NextVal from dual';
mkInterbase: s := 'select gen_id(myGen, 1) from rdb$database';
else         Exit;
end;
ADQuery1.Open(s);


See Also

See Also
TADCustomConnection.RDBMSKind Property
See Also

TADRDBMSKind, Connected


Example

Example
TADCustomConnection.RefreshMetadataCache Method
ADConnection1.ExecSQL('alter table mytab drop primary key');
ADConnection1.RefreshMetadataCache;


See Also

See Also
TADCustomConnection.RefreshMetadataCache Method
See Also

TADFetchOptions.Cache


See Also

See Also
TADCustomConnection.ResourceOptions Property
See Also

TADTopResourceOptions


See Also

See Also
TADCustomConnection.ResultConnectionDef Property
See Also

ConnectionDefName, Params, DriverName, IADStanConnectionDef


Example

Example
TADCustomConnection.Rollback Method
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.Commit;
    end;
  except
    ADConnection1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomConnection.Rollback Method
See Also

StartTransaction, InTransaction, Commit, RollbackRetaining


Example

Example
TADCustomConnection.RollbackRetaining Method
procedure TForm1.DoThatButtonClick(Sender: TObject);
begin
  ADConnection1.StartTransaction;
  try
    if CustomerQuery.Locate('ID', [100]) then begin
      CustomerQuery.Edit;
      CustomerQuery.FieldByName('status').AsString := 'top';
      CustomerQuery.Post;
      ADConnection1.ExecSQL('delete from debt where CustID = 100');
      ADConnection1.CommitRetaining;
    end;
  except
    ADConnection1.RollbackRetaining;
    raise;
  end;
end;


See Also

See Also
TADCustomConnection.RollbackRetaining Method
See Also

StartTransaction, InTransaction, Commit, Rollback


Example 1

Example 1
TADCustomConnection.SharedCliHandle Property

See demo application AnyDAC\Samples\Comp Layer\TADConnection\DLL_Sharing.


Example 2

Example 2
TADCustomConnection.SharedCliHandle Property

Application code (without checks):

  FhDll := LoadLibrary(PChar('Project2.dll'));
  @FpShowData := GetProcAddress(FhDll, PChar('ShowData'));
  FpShowData(ADConnection1.CliHandle);

DLL code:

procedure ShowData(ACliHandle: LongWord);
begin
  ADConnection1.SharedCliHandle := ACliHandle;
  ADConnection1.Connected := True;
  ADQuery1.Active := True;
end;


See Also

See Also
TADCustomConnection.SharedCliHandle Property
See Also

CliHandle, Connected


See Also

See Also
TADCustomConnection.StartTransaction Method
See Also

InTransaction, Commit, Rollback, TxOptions


Example

Example
TADCustomConnection.Temporary Property
var
  oConn: TADconnection;
...
ADQuery1.ConnectionName := 'Access_Demo';
ADQuery1.Open;
...
oConn := ADManager.FindConnection('Access_Demo');
// here oConn.Temporary = True. The oConn will bedestroyed after disconnecting of ADQuery1
oConn.Temporary := False;
...
ADQuery1.Disconnect;
// here oConn is alive due to setting of oConn.Temporary to False


See Also

See Also
TADCustomConnection.Transaction Property
See Also

UpdateTransaction, TADCustomTransaction


See Also

See Also
TADCustomConnection.TxOptions Property
See Also

Transaction, TADTxOptions


See Also

See Also
TADCustomConnection.UpdateOptions Property
See Also

TADUpdateOptions


See Also

See Also
TADCustomConnection.UpdateTransaction Property
See Also

Transaction, TADCustomTransaction


See Also

See Also
TADCustomManager Class
See Also

TADManager, ADManager, IADPhysManager


See Also

See Also
TADCustomManager.Active Property
See Also

DriverDefFileAutoLoad, DriverDefFileName, Open, Close


Example

Example
TADCustomManager.AddConnectionDef Method
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=127.0.0.1');
  oList.Add('Database=addemo');
  ADManager.AddConnectionDef('myconn', 'MySQL', oList);
......
  ADConnection1.ConnectionDefName := 'myconn';
  ADConnection1.Connected := True;


See Also

See Also
TADCustomManager.AddConnectionDef Method
See Also

ConnectionDefs, SaveConnectionDefFile, DeleteConnectionDef, ModifyConnectionDef, IADStanConnectionDefs.AddConnectionDef, TADCustomConnection.ConnectionDefName


See Also

See Also
TADCustomManager.AfterLoadConnectionDefFile Event
See Also

BeforeLoadConnectionDefFile


See Also

See Also
TADCustomManager.BeforeLoadConnectionDefFile Event
See Also

AfterLoadConnectionDefFile


Example

Example
TADCustomManager.CanRefreshConnectionDefFile Property
// reload connection definition list
if ADManager.CanRefreshConnectionDefFile then begin
  ADManager.ConnectionDefs.Clear;
  ADManager.ConnectionDefs.Load;
end;


See Also

See Also
TADCustomManager.CanRefreshConnectionDefFile Property
See Also

ConnectionDefs


See Also

See Also
TADCustomManager.Close Method
See Also

Open, Active


Example

Example
TADCustomManager.ConnectionCount Property
// perform some task for all application connection objects
for i := 0 to ADManager.ConnectionCount - 1 do
  ADManager.Connections[i].Ping;


See Also

See Also
TADCustomManager.ConnectionCount Property
See Also

TADCustomConnection, Connections


See Also

See Also
TADCustomManager.ConnectionDefFileAutoLoad Property
See Also

ConnectionDefs, ConnectionDefFileLoaded, ConnectionDefFileName, LoadConnectionDefFile


See Also

See Also
TADCustomManager.ConnectionDefFileLoaded Property
See Also

ConnectionDefs, ConnectionDefFileautoLoad, ConnectionDefFileName


Example 1

Example 1
TADCustomManager.ConnectionDefFileName Property
ADManager.ConnectionDefFileName := ExtractFilePath(Application.ExeName) + 'myconndef.ini';
ADManager.ConnectionDefFileAutoLoad := True;
oConn := TADConnection.Create(nil);
oConn.ConnectionDefName := 'myconn';
oConn.Connected := True;


Example 2

Example 2
TADCustomManager.ConnectionDefFileName Property
procedure TMyDataModule.DoBeforeLoad(ASender: TNotifyEvent);
begin
  ADManager.ConnectionDefFileName := FSettings.MyConnectionDefFile;
end;
...
ADManager.BeforeLoadConnectionDefFile := DoBeforeLoad;


See Also

See Also
TADCustomManager.ConnectionDefFileName Property
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded


Example 1

Example 1
TADCustomManager.ConnectionDefs Property
// find the connection definition, change it properties and save it to file
oDef := ADManager.ConnectionDefs.ConnectionDefByName('MyDef');
oDef.Server := '127.0.0.1';
oDef.Apply;


Example 2

Example 2
TADCustomManager.ConnectionDefs Property
// add new connection definition and save it to file
oDef := ADManager.ConnectionDefs.AddConnectionDef;
oDef.Name := 'MyDef';
oDef.Server := '127.0.0.1';
oDef.UserName := 'dba';
// use new connection definition
ADConnection1.ConnectionDefName := 'MyDef';


Example 3

Example 3
TADCustomManager.ConnectionDefs Property

See AnyDAC\Samples\Comp Layer\TADConnection\ConnectionDefs sample for details of how to work with ConnectionDefs.


See Also

See Also
TADCustomManager.ConnectionDefs Property
See Also

ConnectionDefFileName, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded


Example

Example
TADCustomManager.Connections Property
// perform some task for all application connection objects
for i := 0 to ADManager.ConnectionCount - 1 do
  ADManager.Connections[i].Ping;


See Also

See Also
TADCustomManager.Connections Property
See Also

TADCustomConnection, ConnectionCount


Example

Example
TADCustomManager.DeleteConnectionDef Method
  ADManager.DeleteConnectionDef('myconn');


See Also

See Also
TADCustomManager.DeleteConnectionDef Method
See Also

ConnectionDefs, SaveConnectionDefFile, AddConnectionDef, IADStanDefinition.Delete


See Also

See Also
TADCustomManager.DriverDefFileAutoLoad Property
See Also

DriverDefFileName


See Also

See Also
TADCustomManager.DriverDefFileName Property
See Also

DriverDefFileAutoLoad


See Also

See Also
TADCustomManager.FetchOptions Property
See Also

FormatOptions, UpdateOptions, ResourceOptions


See Also

See Also
TADCustomManager.FindConnection Method
See Also

GetConnectionNames, TADCustomConnection.ConnectionName, TADCustomCommand.ConnectionName, TADRdbmsDataSet.ConnectionName


See Also

See Also
TADCustomManager.FormatOptions Property
See Also

FetchOptions, UpdateOptions, ResourceOptions


Example

Example
TADCustomManager.GetConnectionDefNames Method
ADManager.GetConnectionDefNames(ListBox1.Items);


See Also

See Also
TADCustomManager.GetConnectionDefNames Method
See Also

IADStanDefinition.Name


Example

Example
TADCustomManager.GetConnectionDefParams Method
ADManager.GetConnectionDefParams('myconn', ListBox1.Items);


See Also

See Also
TADCustomManager.GetConnectionDefParams Method
See Also

IADStanDefinition.Params


See Also

See Also
TADCustomManager.GetConnectionNames Method
See Also

FindConnection, TADCustomConnection.ConnectionName, TADCustomCommand.ConnectionName, TADRdbmsDataSet.ConnectionName


Example

Example
TADCustomManager.GetDriverNames Method
ADManager.GetDriverNames(ListBox1.Items);


See Also

See Also
TADCustomManager.GetDriverNames Method
See Also

IADStanConnectionDef.DriverID


Example

Example
TADCustomManager.GetFieldNames Method
ADManager.GetFieldNames('myconn', '', '', 'MYTAB', '', ListBox1.Items);


See Also

See Also
TADCustomManager.GetFieldNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetFieldNames


Example

Example
TADCustomManager.GetGeneratorNames Method
ADManager.GetGeneratorNames('myconn', '', '', 'MY%', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomManager.GetGeneratorNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetGeneratorNames


Example

Example
TADCustomManager.GetKeyFieldNames Method
ADManager.GetKeyFieldNames('myconn', 'NORTHWIND', 'DBO', 'MYTAB', '', ListBox1.Items);


See Also

See Also
TADCustomManager.GetKeyFieldNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetKeyFieldNames


Example

Example
TADCustomManager.GetPackageNames Method
ADManager.GetPackageNames('myconn', '', 'SYS', 'DBMS%', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomManager.GetPackageNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetPackageNames


Example

Example
TADCustomManager.GetStoredProcNames Method
ADManager.GetStoredProcNames('myconn', '', '', '', '', ListBox1.Items, [osMy, osSystem]);


See Also

See Also
TADCustomManager.GetStoredProcNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetStoredProcNames


Example

Example
TADCustomManager.GetTableNames Method
ADManager.GetTableNames('myconn', 'NORTHWIND', 'DBO', 'ADQA%', '', ListBox1.Items,
  [osMy, osSystem, osOther], [tkTable, tkView]);


See Also

See Also
TADCustomManager.GetTableNames Method
See Also

TADMetaInfoQuery, TADCustomConnection.GetTableNames


See Also

See Also
TADCustomManager.LoadConnectionDefFile Method
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded, ConnectionDefFileName


Example

Example
TADCustomManager.ModifyConnectionDef Method
var
  oList: TStringList;
......
  oList := TStringList.Create;
  oList.Add('Server=myhoster');
  ADManager.ModifyConnectionDef('myconn', oList);
  ADManager.SaveConnectionDefFile;


See Also

See Also
TADCustomManager.ModifyConnectionDef Method
See Also

ConnectionDefs, SaveConnectionDefFile, DeleteConnectionDef, AddConnectionDef


See Also

See Also
TADCustomManager.OnShutdown Event
See Also

Active, Close, OnStartup


See Also

See Also
TADCustomManager.OnStartup Event
See Also

Active, Open, OnShutdown


See Also

See Also
TADCustomManager.Open Method
See Also

Close, Active


Example

Example
TADCustomManager.RefreshConnectionDefFile Method
if ADManager.CanRefreshConnectionDefFile then
  ADManager.RefreshConnectionDefFile;


See Also

See Also
TADCustomManager.RefreshConnectionDefFile Method
See Also

CanRefreshConnectionDefFile, ConnectionDefs


See Also

See Also
TADCustomManager.RefreshMetadataCache Method
See Also

TADFetchOptions.Cache, TADCustomConnection.RefreshMetadataCache


See Also

See Also
TADCustomManager.ResourceOptions Property
See Also

FetchOptions, UpdateOptions, FormatOptions


Example

Example
TADCustomManager.SaveConnectionDefFile Method
  ADManager.DeleteConnectionDef('myconn');
  ADManager.SaveConnectionDefFile;


See Also

See Also
TADCustomManager.SaveConnectionDefFile Method
See Also

ConnectionDefs, DeleteConnectionDef, AddConnectionDef, ModifyConnectionDef


See Also

See Also
TADCustomManager.SilentMode Property
See Also

TADResourceOptions.SilentMode, WaitCursor


See Also

See Also
TADCustomManager.State Property
See Also

Active


See Also

See Also
TADCustomManager.UpdateOptions Property
See Also

FetchOptions, ResourceOptions, FormatOptions


See Also

See Also
TADCustomManager.WaitCursor Property
See Also

SilentMode


See Also

See Also
TADCustomMemTable Class
See Also

TADMemTable, TADDatSTable, TADCustomTableAdapter


See Also

See Also
TADCustomMemTable.Adapter Property
See Also

TADCustomTableAdapter


See Also

See Also
TADCustomQuery Class
See Also

TADQuery, TADCustomCommand


Example

Example
TADCustomQuery.DataSource Property
MasterQuery.Open('select * from {id Orders}');
MasterSource.DataSet := MasterQuery;
DetailQuery.DataSource := MasterSource;
DetailQuery.Open('select * from {id Order Details} where OrderID = :OrderID');
// here :OrderID parameter of DetailQuery will get the current value of OrderID
// field from MasterQuery


See Also

See Also
TADCustomQuery.DataSource Property
See Also

SQL, Params, ParamByName, TDataSet.BeforeOpen


Example

Example
TADCustomQuery.ExecSQL Method (String, array of Variant, array of TFieldType)
ADQuery1.ExecSQL('insert into mytab (f1, f2) values (:f1, :f2)',
  [100, 'qweqwe'], [ftInteger, ftWideString]);


See Also

See Also
TADCustomQuery.ExecSQL Method (String, array of Variant, array of TFieldType)
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example 1

Example 1
TADCustomQuery.ExecSQL Method (String, array of Variant)
ADQuery1.ExecSQL('insert into mytab (f1, f2) values (:f1, :f2)', [100, 'qweqwe']);


Example 2

Example 2
TADCustomQuery.ExecSQL Method (String, array of Variant)
ADQuery1.SQL.Text := 'insert into mytab (f1, f2) values (:f1, :f2)';
ADQuery1.Params[0].DataType := ftInteger;
ADQuery1.Params[1].DataType := ftWideString;
ADQuery1.ExecSQL('', [100, 'qweqwe']);
ADQuery1.ExecSQL('', [101, 'asdasd']);
ADQuery1.ExecSQL('', [102, 'zxczxc']);


See Also

See Also
TADCustomQuery.ExecSQL Method (String, array of Variant)
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADCustomQuery.ExecSQL Method (String)
ADQuery1.ExecSQL('create table ...');


See Also

See Also
TADCustomQuery.ExecSQL Method (String)
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADCustomQuery.ExecSQL Method ()
ADQuery1.SQL.Text := 'insert into mytab values (:id, :name)';
ADQuery1.Params[0].AsInteger := 100;
ADQuery1.Params[0].AsString := 'qwe';
ADQuery1.ExecSQL;


See Also

See Also
TADCustomQuery.ExecSQL Method ()
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, SQL, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


See Also

See Also
TADCustomQuery.ParamCount Property
See Also

Params, SQL, TADResourceOptions.ParamCreate


Example

Example
TADCustomQuery.SQL Property
ADQuery1.SQL.BeginUpdate;
try
  ADQuery1.SQL.Add('SELECT ...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('WHERE ID = :ID');
finally
  ADQuery1.SQL.EndUpdate;
end;
ADQuery1.ParamByName('ID').AsInteger := 100;
ADQuery1.Open;


See Also

See Also
TADCustomQuery.SQL Property
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, ExecSQL, TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADRdbmsDataSet.ParamBindMode


See Also

See Also
TADCustomQuery.Text Property
See Also

SQL


See Also

See Also
TADCustomStoredProc Class
See Also

TADStoredProc, TADCustomQuery


See Also

See Also
TADCustomStoredProc.CatalogName Property
See Also

SchemaName, PackageName, Overload, StoredProcName


See Also

See Also
TADCustomStoredProc.DescriptionsAvailable Method
See Also

ExecProc, Params


Example

Example
TADCustomStoredProc.ExecProc Method (String, array of Variant, array of TFieldType)
ADStoredProc1.StoredProcName := 'myproc';
ADStoredProc1.Prepare;
ADStoredProc1.ParamByName('inval').Value := 100;
ADStoredProc1.ExecProc;
ShowMessage(ADStoredProc1.ParamByName('outval').AsString);


See Also

See Also
TADCustomStoredProc.ExecProc Method (String, array of Variant, array of TFieldType)
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example 1

Example 1
TADCustomStoredProc.ExecProc Method (String, array of Variant)
ADStoredProc1.ExecProc('myproc', [100, 'qweqwe']);


Example 2

Example 2
TADCustomStoredProc.ExecProc Method (String, array of Variant)
ADStoredProc1.StoredProcName := 'myproc';
ADStoredProc1.ExecProc('', [100, 'qweqwe']);
ADStoredProc1.ExecProc('', [101, 'asdasd']);
ADStoredProc1.ExecProc('', [102, 'zxczxc']);


See Also

See Also
TADCustomStoredProc.ExecProc Method (String, array of Variant)
See Also

CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADCustomStoredProc.ExecProc Method (String)
ADStoredProc1.ExecProc('myproc');


See Also

See Also
TADCustomStoredProc.ExecProc Method (String)
See Also

CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADCustomStoredProc.ExecProc Method ()
ADStoredProc1.StoredProcName := 'myproc';
ADStoredProc1.Prepare;
ADStoredProc1.ParamByName('inval').Value := 100;
ADStoredProc1.ExecProc;
ShowMessage(ADStoredProc1.ParamByName('outval').AsString);


See Also

See Also
TADCustomStoredProc.ExecProc Method ()
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, CatalogName, SchemaName, PackageName, StoredProcName, Overload, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


See Also

See Also
TADCustomStoredProc.Overload Property
See Also

Params, StoredProcName


See Also

See Also
TADCustomStoredProc.PackageName Property
See Also

CatalogName, SchemaName, Overload, StoredProcName


See Also

See Also
TADCustomStoredProc.ParamCount Property
See Also

Params, SQL, TADResourceOptions.ParamCreate


Example

Example
TADCustomStoredProc.RowsAffected Property
procedure TForm1.ADQuery1AfterExecute(ASender: TObject);
begin
  if ADQuery1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADQuery1.Command1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADQuery1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADQuery1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADQuery1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADQuery1.RowsAffected]);
    end;
end;


See Also

See Also
TADCustomStoredProc.SchemaName Property
See Also

CatalogName, PackageName, Overload, StoredProcName


Example 1

Example 1
TADCustomStoredProc.StoredProcName Property
ADStoredProc1.StoredProcName := 'Northwind.dbo.[my proc]';
// the same as following
ADStoredProc1.CatalogName := 'Northwind';
ADStoredProc1.SchemaName := 'dbo';
ADStoredProc1.StoredProcName := '[my proc]';


Example 2

Example 2
TADCustomStoredProc.StoredProcName Property
ADStoredProc1.PackageName := 'sys.dbms_sql';
ADStoredProc1.StoredProcName := 'execute';


See Also

See Also
TADCustomStoredProc.StoredProcName Property
See Also

CatalogName, SchemaName, PackageName, Overload


See Also

See Also
TADCustomTransaction Class
See Also

TADTransaction, TADCustomConnection


Example

Example
TADCustomTransaction.Commit Method
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'update employees set salary = salary * :k where id = :id';
  ADTransaction1.StartTransaction;
  try
    ADQuery1.ExecSQL('', [1.2, 100]);
    ADQuery1.ExecSQL('', [1.3, 200]);
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomTransaction.Commit Method
See Also

StartTransaction, IsActive, Rollback, CommitRetaining


Example

Example
TADCustomTransaction.CommitRetaining Method
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'select * from employees';

  ADQuery2.Transaction := ADTransaction1;
  ADQuery2.SQL.Text := 'update employees set salary = salary * :k where id = :id';

  ADTransaction1.StartTransaction;
  try
    ADQuery1.Open;
    while not ADQuery1.Eof do begin
      ADQuery2.ExecSQL('', [1.2, ADQuery1.FieldByName('id').AsInteger]);
      ADTransaction1.CommitRetaining;
      ADQuery1.Next;
    end;
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomTransaction.CommitRetaining Method
See Also

StartTransaction, IsActive, Rollback, Commit


See Also

See Also
TADCustomTransaction.Connection Property
See Also

IsActive


See Also

See Also
TADCustomTransaction.DataSetCount Property
See Also

TADRdbmsDataSet.Transaction, DataSets


See Also

See Also
TADCustomTransaction.DataSets Property
See Also

DataSetCount


See Also

See Also
TADCustomTransaction.IsActive Property
See Also

StartTransaction, Commit, Rollback


Example

Example
TADCustomTransaction.Options Property
ADTransaction1.Options.ReadOnly := True;
ADTransaction1.StartTransaction;


See Also

See Also
TADCustomTransaction.Options Property
See Also

StartTransaction, Commit, Rollback


Example

Example
TADCustomTransaction.Rollback Method
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'update employees set salary = salary * :k where id = :id';
  ADTransaction1.StartTransaction;
  try
    ADQuery1.ExecSQL('', [1.2, 100]);
    ADQuery1.ExecSQL('', [1.3, 200]);
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomTransaction.Rollback Method
See Also

StartTransaction, IsActive, Commit, RollbackRetaining


See Also

See Also
TADCustomTransaction.RollbackRetaining Method
See Also

StartTransaction, InTransaction, Commit, Rollback


Example

Example
TADCustomTransaction.StartTransaction Method
procedure TForm1.ChangeButtonClick(Sender: TObject);
begin
  ADQuery1.Transaction := ADTransaction1;
  ADQuery1.SQL.Text := 'select * from employees';

  ADQuery2.Transaction := ADTransaction1;
  ADQuery2.SQL.Text := 'update employees set salary = salary * :k where id = :id';

  ADTransaction1.Options.Isolation := xiRepeatableRead;
  ADTransaction1.StartTransaction;
  try
    ADQuery1.Open;
    while not ADQuery1.Eof do begin
      ADQuery2.ExecSQL('', [1.2, ADQuery1.FieldByName('id').AsInteger]);
      ADTransaction1.CommitRetaining;
      ADQuery1.Next;
    end;
    ADTransaction1.Commit;
  except
    ADTransaction1.Rollback;
    raise;
  end;
end;


See Also

See Also
TADCustomTransaction.StartTransaction Method
See Also

IsActive, Commit, Rollback, Options


See Also

See Also
TADCustomTransaction.TransactionIntf Property
See Also

IADPhysTransaction


See Also

See Also
TADCustomUpdateObject Class
See Also

..


Example 1

Example 1
TADCustomUpdateObject.Apply Method
procedure TfrmCachedUpdates.qrProductsUpdateRecord(ASender: TDataSet;
      ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction;
      AOptions: TADPhysUpdateRowOptions);
begin
  usProducts.ConnectionName := qrProducts.ConnectionName;
  usProducts.DataSet := qrProducts;
  usProducts.Apply(ARequest, AAction, AOptions);

  usCategories.ConnectionName := qrProducts.ConnectionName;
  usCategories.DataSet := qrProducts;
  usCategories.Apply(ARequest, AAction, AOptions);

  AAction := eaApplied;
end;


Example 2

Example 2
TADCustomUpdateObject.Apply Method

See AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main demo application.


See Also

See Also
TADCustomUpdateObject.Apply Method
See Also

TADUpdateSQL, TADAdaptedDataSet.UpdateObject


See Also

See Also
TADCustomUpdateObject.DataSet Property
See Also

TADDataSet.OnUpdateRecord, TADRdbmsDataSet.Connection, TADRdbmsDataSet.ConnectionName


See Also

See Also
TADManager Class
See Also

..


See Also

See Also
TADManager.Active Property
See Also

DriverDefFileAutoLoad, DriverDefFileName, Open, Close


See Also

See Also
TADManager.AfterLoadConnectionDefFile Event
See Also

BeforeLoadConnectionDefFile


See Also

See Also
TADManager.BeforeLoadConnectionDefFile Event
See Also

AfterLoadConnectionDefFile


See Also

See Also
TADManager.ConnectionDefFileAutoLoad Property
See Also

ConnectionDefs, ConnectionDefFileLoaded, ConnectionDefFileName, LoadConnectionDefFile


Example 1

Example 1
TADManager.ConnectionDefFileName Property
ADManager.ConnectionDefFileName := ExtractFilePath(Application.ExeName) + 'myconndef.ini';
ADManager.ConnectionDefFileAutoLoad := True;
oConn := TADConnection.Create(nil);
oConn.ConnectionDefName := 'myconn';
oConn.Connected := True;


Example 2

Example 2
TADManager.ConnectionDefFileName Property
procedure TMyDataModule.DoBeforeLoad(ASender: TNotifyEvent);
begin
  ADManager.ConnectionDefFileName := FSettings.MyConnectionDefFile;
end;
...
ADManager.BeforeLoadConnectionDefFile := DoBeforeLoad;


See Also

See Also
TADManager.ConnectionDefFileName Property
See Also

ConnectionDefs, ConnectionDefFileAutoLoad, ConnectionDefFileLoaded


See Also

See Also
TADManager.DriverDefFileAutoLoad Property
See Also

DriverDefFileName


See Also

See Also
TADManager.DriverDefFileName Property
See Also

DriverDefFileAutoLoad


See Also

See Also
TADManager.FetchOptions Property
See Also

FormatOptions, UpdateOptions, ResourceOptions


See Also

See Also
TADManager.FormatOptions Property
See Also

FetchOptions, UpdateOptions, ResourceOptions


See Also

See Also
TADManager.OnShutdown Event
See Also

Active, Close, OnStartup


See Also

See Also
TADManager.OnStartup Event
See Also

Active, Open, OnShutdown


See Also

See Also
TADManager.ResourceOptions Property
See Also

FetchOptions, UpdateOptions, FormatOptions


See Also

See Also
TADManager.SilentMode Property
See Also

TADResourceOptions.SilentMode, WaitCursor


See Also

See Also
TADManager.UpdateOptions Property
See Also

FetchOptions, ResourceOptions, FormatOptions


See Also

See Also
TADManager.WaitCursor Property
See Also

SilentMode


See Also

See Also
TADMemTable Class
See Also

..


See Also

See Also
TADMemTable.Adapter Property
See Also

TADCustomTableAdapter


See Also

See Also
TADMetaInfoCommand Class
See Also

..


Example

Example
TADMetaInfoCommand.Active Property
ADCommand1.CommandText.Text := 'select * from "Orders"';
ADCommand1.Active := True;
oTab := ADCommand1.Define;
try
  ADCommand1.Fetch(oTab);
  ....
finally
  oTab.Free;
end;


See Also

See Also
TADMetaInfoCommand.Active Property
See Also

Fetch, Define, Open, Close, CloseAll, State


See Also

See Also
TADMetaInfoCommand.AfterClose Event
See Also

BeforeClose, Close, Active


See Also

See Also
TADMetaInfoCommand.AfterOpen Event
See Also

BeforeOpen, Open, Active


Example

Example
TADMetaInfoCommand.BaseObjectName Property
var
  oTab: TADDatSTable;
....
  ADMetaInfoCommand1.BaseObjectName := 'Northwind.dbo.Employees';
  ADMetaInfoCommand1.ObjectName := 'FK_DEPARTMENTS';
  ADMetaInfoCommand1.MetaInfoKind := mkForeignKeyFields;
  ADMetaInfoCommand1.Define(oTab);
  ADMetaInfoCommand1.Open(oTab);
  ADMetaInfoCommand1.Fetch(oTab, True);


See Also

See Also
TADMetaInfoCommand.BaseObjectName Property
See Also

MetaInfoKind, CatalogName, SchemaName, ObjectName


See Also

See Also
TADMetaInfoCommand.BeforeClose Event
See Also

AfterClose, Close, Active


See Also

See Also
TADMetaInfoCommand.BeforeOpen Event
See Also

AfterOpen, Open, Active


Example 1

Example 1
TADMetaInfoCommand.CatalogName Property
ADCommand1.CatalogName := 'MY_APP';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADMetaInfoCommand.CatalogName Property
ADMetaInfoCommand1.CatalogName := 'MY_APP';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on MSSQL just ADMetaInfoCommand1.ObjectName := 'MY_APP..MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADMetaInfoCommand.CatalogName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


See Also

See Also
TADMetaInfoCommand.Connection Property
See Also

ConnectionName, Prepare


See Also

See Also
TADMetaInfoCommand.ConnectionName Property
See Also

Connection, Prepare


See Also

See Also
TADMetaInfoCommand.FormatOptions Property
See Also

TADFormatOptions, Fetch, Params


Example

Example
TADMetaInfoCommand.MetaInfoKind Property


See Also

See Also
TADMetaInfoCommand.MetaInfoKind Property
See Also

CatalogName, SchemaName, BaseObjectName, Overload, ObjectName


Example

Example
TADMetaInfoCommand.ObjectName Property
var
  oTab: TADDatSTable;
....
  ADMetaInfoCommand1.CatalogName := 'Northwind';
  ADMetaInfoCommand1.SchemaName := 'dbo';
  ADMetaInfoCommand1.ObjectName := 'Employees';
  ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
  ADMetaInfoCommand1.Define(oTab);
  ADMetaInfoCommand1.Open(oTab);
  ADMetaInfoCommand1.Fetch(oTab, True);


See Also

See Also
TADMetaInfoCommand.ObjectName Property
See Also

MetaInfoKind, CatalogName, SchemaName, BaseObjectName


See Also

See Also
TADMetaInfoCommand.ObjectScopes Property
See Also

TableKinds


Example

Example
TADMetaInfoCommand.OnCommandChanged Event
procedure TForm1.ADCommand1CommandChanged(ASender: TObject);
begin
  if ADCommand1.FindParam('ID') <> nil then
    ADCommand1.FindParams('ID').AsInteger := 100;
end;


See Also

See Also
TADMetaInfoCommand.OnCommandChanged Event
See Also

CommandText


Example 1

Example 1
TADMetaInfoCommand.OnError Event

Handling Array DML errors:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADMetaInfoCommand.OnError Event

Error substitution:

procedure TForm1.ADCommand1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADMetaInfoCommand.OnError Event
See Also

Open, Execute, Prepare, Fetch, EADPhysArrayExecuteError, EADDBEngineException


Example

Example
TADMetaInfoCommand.Overload Property
ADCommand1.CommandKind := skStoredProc;
ADCommand1.CommandText.Text := 'DBMS_SQL.PARSE';
ADCommand1.Overload := 1;


See Also

See Also
TADMetaInfoCommand.Overload Property
See Also

CommandText, CommandKind


Example 1

Example 1
TADMetaInfoCommand.SchemaName Property
ADCommand1.SchemaName := 'SCOTT';
ADCommand1.CommandText.Text := 'PROC1';
ADCommand1.CommandKind := skStoredProc;
ADCommand1.Prepare;
ADCommand1.Params[0].AsInteger := 100;
ADCommand1.Params[1].AsString := 'Bill Gates';
ADCommand1.Execute;


Example 2

Example 2
TADMetaInfoCommand.SchemaName Property
ADMetaInfoCommand1.SchemaName := 'ADDEMO';
ADMetaInfoCommand1.ObjectName := 'MY_TAB';
// or on Oracle just ADMetaInfoCommand1.ObjectName := 'ADDEMO.MY_TAB';
ADMetaInfoCommand1.MetaInfoKind := mkTableFields;
ADMetaInfoCommand1.Open;


See Also

See Also
TADMetaInfoCommand.SchemaName Property
See Also

CommandKind, TADMetaInfoCommand.MetaInfoKind, SchemaName


See Also

See Also
TADMetaInfoCommand.TableKinds Property
See Also

ObjectScopes


See Also

See Also
TADMetaInfoCommand.Wildcard Property
See Also

ObjectScopes, TableKinds


See Also

See Also
TADMetaInfoQuery Class
See Also

..


Example

Example
TADMetaInfoQuery.BaseObjectName Property
  // get FK_DEPARTMENTS foreign keys fields list for table Northwind.dbo.Employees
  ADMetaInfoQuery1.BaseObjectName := 'Northwind.dbo.Employees';
  ADMetaInfoQuery1.ObjectName := 'FK_DEPARTMENTS';
  ADMetaInfoQuery1.MetaInfoKind := mkForeignKeyFields;
  ADMetaInfoCommand1.Open;


See Also

See Also
TADMetaInfoQuery.BaseObjectName Property
See Also

MetaInfoKind, CatalogName, SchemaName, ObjectName


See Also

See Also
TADMetaInfoQuery.Connection Property
See Also

ConnectionName


Example

Example
TADMetaInfoQuery.ConnectionName Property
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


See Also

See Also
TADMetaInfoQuery.ConnectionName Property
See Also

Connection, TADCustomConnection.Temporary


Example

Example
TADMetaInfoQuery.MetaInfoKind Property
  // get the table list for Northwind catalog, dbo schema
  ADMetaInfoQuery1.CatalogName := 'Northwind';
  ADMetaInfoQuery1.SchemaName := 'dbo';
  ADMetaInfoQuery1.MetaInfoKind := mkTables;
  ADMetaInfoQuery1.Open;


See Also

See Also
TADMetaInfoQuery.MetaInfoKind Property
See Also

CatalogName, SchemaName, BaseObjectName, Overload, ObjectName


Example

Example
TADMetaInfoQuery.ObjectName Property
  // get the field list of Northwind.dbo.Employees table
  ADMetaInfoQuery1.CatalogName := 'Northwind';
  ADMetaInfoQuery1.SchemaName := 'dbo';
  ADMetaInfoQuery1.ObjectName := 'Employees';
  ADMetaInfoQuery1.MetaInfoKind := mkTableFields;
  ADMetaInfoQuery1.Open;


See Also

See Also
TADMetaInfoQuery.ObjectName Property
See Also

MetaInfoKind, CatalogName, SchemaName, BaseObjectName


See Also

See Also
TADMetaInfoQuery.ObjectScopes Property
See Also

TableKinds


See Also

See Also
TADMetaInfoQuery.OnCommandChanged Event
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


Example 1

Example 1
TADMetaInfoQuery.OnError Event

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADMetaInfoQuery.OnError Event

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADMetaInfoQuery.OnError Event
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError


See Also

See Also
TADMetaInfoQuery.TableKinds Property
See Also

ObjectScopes


See Also

See Also
TADMetaInfoQuery.Transaction Property
See Also

UpdateTransaction, TADCustomConnection.Transaction


Example

Example
TADMetaInfoQuery.UpdateTransaction Property
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


See Also

See Also
TADMetaInfoQuery.UpdateTransaction Property
See Also

Transaction, TADCustomConnection.UpdateTransaction


See Also

See Also
TADMetaInfoQuery.Wildcard Property
See Also

ObjectScopes, TableKinds


See Also

See Also
TADQuery Class
See Also

..


See Also

See Also
TADQuery.Connection Property
See Also

ConnectionName


Example

Example
TADQuery.ConnectionName Property
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


See Also

See Also
TADQuery.ConnectionName Property
See Also

Connection, TADCustomConnection.Temporary


Example

Example
TADQuery.DataSource Property
MasterQuery.Open('select * from {id Orders}');
MasterSource.DataSet := MasterQuery;
DetailQuery.DataSource := MasterSource;
DetailQuery.Open('select * from {id Order Details} where OrderID = :OrderID');
// here :OrderID parameter of DetailQuery will get the current value of OrderID
// field from MasterQuery


See Also

See Also
TADQuery.DataSource Property
See Also

SQL, Params, ParamByName, TDataSet.BeforeOpen


See Also

See Also
TADQuery.MacroCount Property
See Also

Macros


Example 1

Example 1
TADQuery.Macros Property

Substitute table name:

ADQuery1.SQL.Text := 'select * from &Tab';
ADQuery1.Macros[0].AsIdentifier := 'Order Details';
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from "Order Details"


Example 2

Example 2
TADQuery.Macros Property

Substitute WHERE condition:

ADQuery1.SQL.Text := 'select * from MyTab {if !cond} where !cond {fi}';

ADQuery1.Macros[0].AsString := 'ID > 100';
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from MyTab where ID > 100

ADQuery1.Macros[0].Clear;
ADQuery1.Prepare;
ShowMessage(ADQuery1.SQLText); // select * from MyTab


See Also

See Also
TADQuery.Macros Property
See Also

TADCustomQuery.SQL, Params, Prepare, TADMacros, TADResourceOptions.MacroCreate, TADResourceOptions.MacroExpand


See Also

See Also
TADQuery.OnCommandChanged Event
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


Example 1

Example 1
TADQuery.OnError Event

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADQuery.OnError Event

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADQuery.OnError Event
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError


Example

Example
TADQuery.OnExecuteError Event
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


See Also

See Also
TADQuery.OnExecuteError Event
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute


See Also

See Also
TADQuery.Prepared Property
See Also

Prepare, Unprepare, Params


Example

Example
TADQuery.RowsAffected Property
procedure TForm1.ADQuery1AfterExecute(ASender: TObject);
begin
  if ADQuery1.RowsAffected = -1 then
    StatusBar1.SimpleText := 'Ok'
  else
    case ADQuery1.Command1.CommandKind of
    skDelete: StatusBar1.SimpleText := Format('%d rows deleted', [ADQuery1.RowsAffected]);
    skInsert: StatusBar1.SimpleText := Format('%d rows inserted', [ADQuery1.RowsAffected]);
    skUpdate: StatusBar1.SimpleText := Format('%d rows updated', [ADQuery1.RowsAffected]);
    else      StatusBar1.SimpleText := Format('%d rows affected', [ADQuery1.RowsAffected]);
    end;
end;


Example

Example
TADQuery.SQL Property
ADQuery1.SQL.BeginUpdate;
try
  ADQuery1.SQL.Add('SELECT ...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('...');
  ADQuery1.SQL.Add('WHERE ID = :ID');
finally
  ADQuery1.SQL.EndUpdate;
end;
ADQuery1.ParamByName('ID').AsInteger := 100;
ADQuery1.Open;


See Also

See Also
TADQuery.SQL Property
See Also

TADRdbmsDataSet.Prepare, TDataSet.Open, TADRdbmsDataSet.Open, ExecSQL, TADResourceOptions.ParamCreate, TADResourceOptions.MacroCreate, TADRdbmsDataSet.ParamBindMode


See Also

See Also
TADQuery.Transaction Property
See Also

UpdateTransaction, TADCustomConnection.Transaction


Example

Example
TADQuery.UpdateTransaction Property
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


See Also

See Also
TADQuery.UpdateTransaction Property
See Also

Transaction, TADCustomConnection.UpdateTransaction


See Also

See Also
TADRdbmsDataSet Class
See Also

..


See Also

See Also
TADRdbmsDataSet.Connection Property
See Also

ConnectionName


Example

Example
TADRdbmsDataSet.ConnectionName Property
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


See Also

See Also
TADRdbmsDataSet.ConnectionName Property
See Also

Connection, TADCustomConnection.Temporary


Example

Example
TADRdbmsDataSet.Disconnect Method
ADQuery1.Disconnect(True);
// is equivalent to:
// ADQuery1.AbortJob(True);
// ADQuery1.Close;
// ADQuery1.Unprepare;


See Also

See Also
TADRdbmsDataSet.Disconnect Method
See Also

AbortJob


See Also

See Also
TADRdbmsDataSet.FindMacro Method
See Also

Macros, MacroByName


See Also

See Also
TADRdbmsDataSet.MacroByName Method
See Also

Macros, FindMacro


See Also

See Also
TADRdbmsDataSet.OnCommandChanged Event
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


Example 1

Example 1
TADRdbmsDataSet.OnError Event

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADRdbmsDataSet.OnError Event

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADRdbmsDataSet.OnError Event
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError


Example

Example
TADRdbmsDataSet.Open Method (String, array of Variant, array of TFieldType)
ADQuery1.Open('select * from Employees where department_id = :id', [100], [ftInteger]);


See Also

See Also
TADRdbmsDataSet.Open Method (String, array of Variant, array of TFieldType)
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADRdbmsDataSet.Open Method (String, array of Variant)
ADQuery1.Open('select * from Employees where department_id = :id', [100]);
....
ADQuery1.Open('', [101]); // executes the above SQL command, but for ID = 101
....
ADQuery1.Open('', [102]); // executes the above SQL command, but for ID = 101
....


See Also

See Also
TADRdbmsDataSet.Open Method (String, array of Variant)
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADRdbmsDataSet.Open Method (String)
ADQuery1.Open('select * from customers');


See Also

See Also
TADRdbmsDataSet.Open Method (String)
See Also

Prepare, TDataSet.Open, TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADAdaptedDataSet.AbortJob, TADAdaptedDataSet.OnError


Example

Example
TADRdbmsDataSet.Prepare Method
ADQuery1.SQL.Text := 'select * from MyTab';
ADQuery1.Prepare;


See Also

See Also
TADRdbmsDataSet.Prepare Method
See Also

Prepared, Unprepare, Params


See Also

See Also
TADRdbmsDataSet.Transaction Property
See Also

UpdateTransaction, TADCustomConnection.Transaction


See Also

See Also
TADRdbmsDataSet.Unprepare Method
See Also

Prepare, Prepared


Example

Example
TADRdbmsDataSet.UpdateTransaction Property
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


See Also

See Also
TADRdbmsDataSet.UpdateTransaction Property
See Also

Transaction, TADCustomConnection.UpdateTransaction


See Also

See Also
TADStoredProc Class
See Also

..


See Also

See Also
TADStoredProc.CatalogName Property
See Also

SchemaName, PackageName, Overload, StoredProcName


See Also

See Also
TADStoredProc.Connection Property
See Also

ConnectionName


Example

Example
TADStoredProc.ConnectionName Property
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


See Also

See Also
TADStoredProc.ConnectionName Property
See Also

Connection, TADCustomConnection.Temporary


See Also

See Also
TADStoredProc.OnCommandChanged Event
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


Example 1

Example 1
TADStoredProc.OnError Event

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADStoredProc.OnError Event

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADStoredProc.OnError Event
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError


Example

Example
TADStoredProc.OnExecuteError Event
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


See Also

See Also
TADStoredProc.OnExecuteError Event
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute


See Also

See Also
TADStoredProc.Overload Property
See Also

Params, StoredProcName


See Also

See Also
TADStoredProc.PackageName Property
See Also

CatalogName, SchemaName, Overload, StoredProcName


See Also

See Also
TADStoredProc.ParamBindMode Property
See Also

Params


See Also

See Also
TADStoredProc.Prepared Property
See Also

Prepare, Unprepare, Params


See Also

See Also
TADStoredProc.SchemaName Property
See Also

CatalogName, PackageName, Overload, StoredProcName


Example 1

Example 1
TADStoredProc.StoredProcName Property
ADStoredProc1.StoredProcName := 'Northwind.dbo.[my proc]';
// the same as following
ADStoredProc1.CatalogName := 'Northwind';
ADStoredProc1.SchemaName := 'dbo';
ADStoredProc1.StoredProcName := '[my proc]';


Example 2

Example 2
TADStoredProc.StoredProcName Property
ADStoredProc1.PackageName := 'sys.dbms_sql';
ADStoredProc1.StoredProcName := 'execute';


See Also

See Also
TADStoredProc.StoredProcName Property
See Also

CatalogName, SchemaName, PackageName, Overload


See Also

See Also
TADStoredProc.Transaction Property
See Also

UpdateTransaction, TADCustomConnection.Transaction


Example

Example
TADStoredProc.UpdateTransaction Property
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


See Also

See Also
TADStoredProc.UpdateTransaction Property
See Also

Transaction, TADCustomConnection.UpdateTransaction


See Also

See Also
TADTable Class
See Also

..


See Also

See Also
TADTable.CatalogName Property
See Also

SchemaName, TableName


See Also

See Also
TADTable.Connection Property
See Also

ConnectionName


Example

Example
TADTable.ConnectionName Property
ADQuery1.ConnectionName := 'Ora_Demo';
ADQuery1.Open('select * from "Customers"');


See Also

See Also
TADTable.ConnectionName Property
See Also

Connection, TADCustomConnection.Temporary


See Also

See Also
TADTable.OnCommandChanged Event
See Also

TADCustomQuery.SQL, TADCustomStoredProc.StoredProcName, TADTable.TableName


Example 1

Example 1
TADTable.OnError Event

Handling Array DML errors:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if AException is EADPhysArrayExecuteError then
    with EADPhysArrayExecuteError(AException) do
      if Errors[0].Kind = ekUKViolated then
        AAction := eaSkip
      else
        AAction := eaFail
  else
    ...
end;


Example 2

Example 2
TADTable.OnError Event

Error substitution:

procedure TForm1.ADQuery1Error(ASender: TObject; const AInitiator: IADStanObject; var AException: Exception);
begin
  if EADDBEngineException(AException).Errors[0].Kind = ekPKViolated then begin
    AException.Free;
    AException := Exception.Create('Please, enter unique ID value');
  end;
end;


See Also

See Also
TADTable.OnError Event
See Also

TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc, TDataSet.Open, Prepare, EADPhysArrayExecuteError, EADDBEngineException, TADCustomConnection.OnError


Example

Example
TADTable.OnExecuteError Event
procedure TForm1.ADQuery1ExecuteError(ASender: TObject; ATimes,
  AOffset: Integer; AException: EADDBEngineException; var AAction: TADErrorAction);
begin
  if AException.Errors[0].Kind = ekUKViolated then
    AAction := eaSkip
  else
    AAction := eaFail;
end;


See Also

See Also
TADTable.OnExecuteError Event
See Also

EADDBEngineException, TADErrorAction, TADDataSet.Execute


See Also

See Also
TADTable.SchemaName Property
See Also

CatalogName, TableName


See Also

See Also
TADTable.TableName Property
See Also

CatalogName, SchemaName


See Also

See Also
TADTable.Transaction Property
See Also

UpdateTransaction, TADCustomConnection.Transaction


Example

Example
TADTable.UpdateTransaction Property
var
  oSelectTransaction: TADTransaction;
  oUpdateTransaction: TADTransaction;
  oCusts: TADQuery;
.....
  oSelectTransaction := TADTransaction.Create(nil);
  oSelectTransaction.Connection := ADConnection1;
  oSelectTransaction.Options.ReadOnly := True;

  oUpdateTransaction := TADTransaction.Create(nil);
  oUpdateTransaction.Connection := ADConnection1;

  oCusts := TADQuery.Create(nil);
  oCusts.Connection := ADConnection1;
  oCusts.Transaction := oSelectTransaction;
  oCusts.UpdateTransaction := oUpdateTransaction;
  oCusts.Open('select * from Customers'); // uses oSelectTransaction
  ...
  oCusts.Edit; // uses oUpdateTransaction, if needed
  ...
  oCusts.Post; // uses oUpdateTransaction


See Also

See Also
TADTable.UpdateTransaction Property
See Also

Transaction, TADCustomConnection.UpdateTransaction


See Also

See Also
TADTransaction Class
See Also

..


See Also

See Also
TADTransaction.Connection Property
See Also

IsActive


Example

Example
TADTransaction.Options Property
ADTransaction1.Options.ReadOnly := True;
ADTransaction1.StartTransaction;


See Also

See Also
TADTransaction.Options Property
See Also

StartTransaction, Commit, Rollback


See Also

See Also
TADUpdateSQL Class
See Also

..


Example 1

Example 1
TADUpdateSQL.Apply Method
procedure TfrmCachedUpdates.qrProductsUpdateRecord(ASender: TDataSet;
      ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction;
      AOptions: TADPhysUpdateRowOptions);
begin
  usProducts.ConnectionName := qrProducts.ConnectionName;
  usProducts.DataSet := qrProducts;
  usProducts.Apply(ARequest, AAction, AOptions);

  usCategories.ConnectionName := qrProducts.ConnectionName;
  usCategories.DataSet := qrProducts;
  usCategories.Apply(ARequest, AAction, AOptions);

  AAction := eaApplied;
end;


Example 2

Example 2
TADUpdateSQL.Apply Method

See AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main demo application.


See Also

See Also
TADUpdateSQL.Apply Method
See Also

TADUpdateSQL, TADAdaptedDataSet.UpdateObject


Example

Example
TADUpdateSQL.Commands Property
ADUpdateSQL1.InsertSQL := 'insert into !tab (workstation_time, id, name) values (:workstation_time, :new_id, :new_name)';
ADUpdateSQL1.Commands[arInsert].ParamByName('workstation_time').AsDateTime := Now();
ADUpdateSQL1.Commands[arInsert].MacroByName('tab').AsRaw := 'mytab';


See Also

See Also
TADUpdateSQL.Commands Property
See Also

TADCustomCommand, TADCustomCommand.Params, TADCustomCommand.Macros, SQL


See Also

See Also
TADUpdateSQL.Connection Property
See Also

ConnectionName, Commands


See Also

See Also
TADUpdateSQL.ConnectionName Property
See Also

Connection, Commands


Example

Example
TADUpdateSQL.DeleteSQL Property
ADUpdateSQL1.DeleteSQL := 'DELETE FROM ADDEMO."Shippers" WHERE SHIPPERID = :OLD_SHIPPERID';


See Also

See Also
TADUpdateSQL.DeleteSQL Property
See Also

Commands, InsertSQL, ModifySQL, LockSQL, UnlockSQL, FetchRowSQL


Example

Example
TADUpdateSQL.FetchRowSQL Property
ADUpdateSQL1.FetchRowSQL := 'SELECT SHIPPERID, COMPANYNAME, PHONE FROM ADDEMO."Shippers" ' +
  'WHERE SHIPPERID = :OLD_SHIPPERID';


See Also

See Also
TADUpdateSQL.FetchRowSQL Property
See Also

Commands, InsertSQL, ModifySQL, LockSQL, UnlockSQL, DeleteSQL


Example 1

Example 1
TADUpdateSQL.InsertSQL Property
// MSSQL sample
ADUpdateSQL1.InsertSQL := 'INSERT INTO [Shippers] (COMPANYNAME, PHONE) ' +
  'VALUES (:NEW_COMPANYNAME, :NEW_PHONE); SELECT SCOPE_IDENTITY() AS SHIPPERID';


Example 2

Example 2
TADUpdateSQL.InsertSQL Property
// Oracle sample
ADUpdateSQL1.InsertSQL := 'INSERT INTO ADDEMO."Shippers" (COMPANYNAME, PHONE) ' +
  'VALUES (:NEW_COMPANYNAME, :NEW_PHONE) RETURNING SHIPPERID INTO :NEW_SHIPPERID';
ADUpdateSQL1.Commands[arInsert].ParamByName('NEW_SHIPPERID').ParamType := ptOutput;


See Also

See Also
TADUpdateSQL.InsertSQL Property
See Also

Commands, ModifySQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL


See Also

See Also
TADUpdateSQL.LockSQL Property
See Also

Commands, ModifySQL, DeleteSQL, InsertSQL, UnlockSQL, FetchRowSQL


Example

Example
TADUpdateSQL.ModifySQL Property
ADUpdateSQL1.InsertSQL := 'UPDATE ADDEMO."Shippers" SET SHIPPERID = :NEW_SHIPPERID, ' +
  'COMPANYNAME = :NEW_COMPANYNAME, PHONE = :NEW_PHONE WHERE SHIPPERID = :OLD_SHIPPERID';


See Also

See Also
TADUpdateSQL.ModifySQL Property
See Also

Commands, InsertSQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL


See Also

See Also
TADUpdateSQL.SQL Property
See Also

Commands, InsertSQL, ModifySQL, DeleteSQL, LockSQL, UnlockSQL, FetchRowSQL


See Also

See Also
TADUpdateSQL.UnlockSQL Property
See Also

Commands, ModifySQL, DeleteSQL, InsertSQL, LockSQL, FetchRowSQL


uADCompDataMove Unit Classes

uADCompDataMove Unit Classes
uADCompDataMove Unit Legend
Classes
Name | Description
TADDataMove |
TADMappingItem |
TADMappings |
TADTextDataDef |
TADTextField |
TADTextFields |
TADTextFormatSettings |


Legend

Legend
uADCompDataMove Unit
Legend
Class
Enumeration
Record


Records, Enums

Records, Enums
uADCompDataMove Unit Legend
Records, Enums
Name | Description
TADDataMoveMode |
TADDataMoveOption |
TADDataMovePhase |
TADDataSourceKind |
TADLogFileAction |
TADTextDataType |
TADTextEndOfLine |
TADTextFormatSettingsValue |
TADTextRecordFormat |
TFormatSettings |


Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Record


Topics

Topics
uADCompDataMove Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADCompDataMove Unit Types

uADCompDataMove Unit Types
uADCompDataMove Unit
Types
Name | Description
TADDataMoveErrorEvent |
TADDataMoveFindDestRecordEvent |
TADDataMoveOptions |
TADDataMoveProgressEvent |
TADTextFormatSettingsValueSet |


uADCompDataSet Unit Classes

uADCompDataSet Unit Classes
uADCompDataSet Unit Legend
Classes
Name | Description
TADAggregate |
TADAggregates |
TADAutoIncField |
TADBlobStream |
TADColMapItem |
TADDataSet | ..
TADIndex |
TADIndexes |
TADMasterDataLink |
TADWideMemoField |


uADCompDataSet Unit Interfaces

uADCompDataSet Unit Interfaces
uADCompDataSet Unit Legend
Interfaces
Name | Description
IADDataSet |


Interfaces (AutoDoc Folder)

Legend
Legend
Interface


Legend

Legend
uADCompDataSet Unit
Legend
Class
Interface
Enumeration
Record


Records, Enums

Records, Enums
uADCompDataSet Unit Legend
Records, Enums
Name | Description
TADDataSetLocateOption |
TADKeyBuffer |
TADKeyIndex |


Topics

Topics
uADCompDataSet Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADCompDataSet Unit Types

uADCompDataSet Unit Types
uADCompDataSet Unit
Types
Name | Description
PADKeyBuffer |
TADAfterApplyUpdatesEvent | ..
TADCopyDataSetOptions |
TADDataSetEvent |
TADDataSetFlags |
TADDataSetLocateOptions |
TADReconcileErrorEvent |
TADStoredActivationUsage |
TADUpdateErrorEvent |
TADUpdateRecordEvent |


See Also

See Also
uADCompDataSet.TADAfterApplyUpdatesEvent Type
See Also

..


See Also

See Also
TADDataSet Class
See Also

..


See Also

See Also
TADDataSet.ActiveStoredUsage Property
See Also

TDataSet.Active


See Also

See Also
TADDataSet.AddIndex Method
See Also

Indexes


See Also

See Also
TADDataSet.AfterApplyUpdates Event
See Also

TADAfterApplyUpdatesEvent, ApplyUpdates, BeforeApplyUpdates


See Also

See Also
TADDataSet.AfterExecute Event
See Also

TADDataSetEvent, Execute, BeforeExecute


See Also

See Also
TADDataSet.AfterGetRecords Event
See Also

TADDataSetEvent, BeforeGetRecords


See Also

See Also
TADDataSet.AfterRowRequest Event
See Also

TADDataSetEvent, RefreshRecord, FetchBlobs, FetchDetails, BeforeRowRequest


Example

Example
TADDataSet.Aggregates Property
with ADMemTable1.Aggregates.Add do begin
  Expression := 'sum(sal + bonus)';
  Active := True;
end;
with ADMemTable1.Aggregates.Add do begin
  Expression := 'sum(sal + bonus)';
  IndexName := 'by_deps';
  Active := True;
end;
ADMemTable1.IndexName := 'by_deps';
ADMemTable1.AggregatesActive := True;

Label1.Caption := 'Total payments : ' + VarToStr(ADMemTable1.Aggregates[0].Value);
Label2.Caption := 'Current department payments : ' + VarToStr(ADMemTable1.Aggregates[1].Value);


See Also

See Also
TADDataSet.Aggregates Property
See Also

AggregatesActive, BeginBatch, EndBatch


Example

Example
TADDataSet.AggregatesActive Property
var
  lPrevAggsActive: Boolean;
...
lPrevAggsActive := ADQuery1.AggregatesActive;
ADQuery1.AggregatesActive := False;
try
  // perform updates here, without calculating and reading client aggregates
finally
  ADQuery1.AggregatesActive := lPrevAggsActive;
end;


See Also

See Also
TADDataSet.AggregatesActive Property
See Also

Aggregates, TADAggregate.Active, BeginBatch, EndBatch


Example

Example
TADDataSet.ApplyRange Method
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := '100';
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := '200';
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.ApplyRange Method
See Also

CancelRange, EditRangeEnd, EditRangeStart, SetRange, SetRangeEnd, SetRangeStart, Ranged


Example

Example
TADDataSet.ApplyUpdates Method
procedure TForm1.btnApplyClick(ASender: TObject);
begin
  if ADStoredProc1.UpdatesPending then
    ADStoredProc1.ApplyUpdates;
end;


See Also

See Also
TADDataSet.ApplyUpdates Method
See Also

CachedUpdated, Reconcile, CommitUpdates, CancelUpdates, UpdatesPending


Example

Example
TADDataSet.AttachTable Method
var
  oTab: TADDatSTable;
...
  oTab := TADDatSTable.Create;
  oTab.Columns.Add('id', dtInt32);
  oTab.Columns.Add('name').Size := 13;
  oTab.Columns.Add('cnt', dtInt16);
  oTab.Columns.Add('price', dtCurrency);
  ADMemTable1.Attach(oTab, nil);
  ADMemTable1.Open;
  // working with ADMemTable1
  ADMemTable1.AttachTable(nil, nil);
  oTab.Free;


See Also

See Also
TADDataSet.AttachTable Method
See Also

Table, View, SourceView


See Also

See Also
TADDataSet.BeforeApplyUpdates Event
See Also

TADDataSetEvent, ApplyUpdates, AfterApplyUpdates


See Also

See Also
TADDataSet.BeforeExecute Event
See Also

TADDataSetEvent, Execute, AfterExecute


See Also

See Also
TADDataSet.BeforeGetRecords Event
See Also

TADDataSetEvent, AfterGetRecords


See Also

See Also
TADDataSet.BeforeRowRequest Event
See Also

TADDataSetEvent, RefreshRecord, FetchBlobs, FetchDetails, AfterRowRequest


Example

Example
TADDataSet.BeginBatch Method
ADQuery1.BeginBatch;
try
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ......
finally
  ADQuery1.EndBatch;
end;


See Also

See Also
TADDataSet.BeginBatch Method
See Also

EndBatch


Example

Example
TADDataSet.CachedUpdates Property
ADQuery1.CachedUpdates := True;
...
ADQuery1.Edit;
...
ADQuery1.Post;
...
ADQuery1.Append;
...
ADQuery1.Post;
...
ADQuery1.ApplyUpdates;
ADQuery1.CommitUpdates;
ADQuery1.CachedUpdates := False;


See Also

See Also
TADDataSet.CachedUpdates Property
See Also

ApplyUpdates, CancelUpdates, CommitUpdates


See Also

See Also
TADDataSet.CancelRange Method
See Also

ApplyRange, EditRangeEnd, EditRangeStart, SetRange, SetRangeEnd, SetRangeStart, Ranged


See Also

See Also
TADDataSet.CancelUpdates Method
See Also

ApplyUpdates, CachedUpdates, CommitUpdates, UndoLastChange, SavePoint


Example

Example
TADDataSet.ChangeCount Property
procedure TForm1.ADQuery1AfterPost(DataSet: TDataSet);
begin
  if TADDataSet(DataSet).ChangeCount = 0 then
    StatusBar1.SimpleText := 'no changes'
  else
    StatusBar1.SimpleText := Format('%d changed rows', [TADDataSet(DataSet).ChangeCount]);
end;


See Also

See Also
TADDataSet.ChangeCount Property
See Also

CachedUpdates, UndoLastChange, CancelUpdates, CommitUpdates, ApplyUpdates


Example

Example
TADDataSet.CloneCursor Method
ADMemTable1.CloneCursor(ADQuery1, True, False);
ADMemTable1.Locate(...);
ADMemTable1.Edit;
...


See Also

See Also
TADDataSet.CloneCursor Method
See Also

Data


See Also

See Also
TADDataSet.CloneSource Property
See Also

CloneCursor


See Also

See Also
TADDataSet.CommitUpdates Method
See Also

CachedUpdates, UpdatesPending, OnUpdateError, OnUpdateRecord, ApplyUpdates, CancelUpdates


Example

Example
TADDataSet.Constraints Property
with ADMemTable1.Constraints.Add do begin
  CustomConstraint := 'sal + bonus <= 2000';
  ErrorMessage := 'The employee payments must be equal or less than 2000 usd';
end;

ADMemTable1.ConstraintsEnabled := True;
ADMemTable1.Edit;
try
  ADMemTable1.FieldByName('sal').AsFloat := 1800;
  ADMemTable1.FieldByName('bonus').AsFloat := 300;
  // here exception will be raised
  ADMemTable1.Post;
except
  ADMemTable1.Cancel;
  Application.HandleException(Self);
end;

ADMemTable1.ConstraintsEnabled := False;
ADMemTable1.Edit;
ADMemTable1.FieldByName('sal').AsFloat := 1800;
ADMemTable1.FieldByName('bonus').AsFloat := 300;
// here exception will be NOT raised, because constraint checking is disabled
ADMemTable1.Post;


See Also

See Also
TADDataSet.Constraints Property
See Also

ConstraintsEnabled, DisableConstraints, EnableConstraints, BeginBatch, EndBatch, TDataSet.Post, TDataSet.AppendRecord, TDataSet.InsertRecord, TField.CustomConstraint, TField.ImportedConstraint


Example

Example
TADDataSet.ConstraintsEnabled Property
var
  lPrevConsEnabled: Boolean;
...
lPrevConsEnabled := ADQuery1.ConstraintEnabled;
ADQuery1.ConstraintEnabled := False;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.ConstraintEnabled := lPrevConsEnabled;
end;


See Also

See Also
TADDataSet.ConstraintsEnabled Property
See Also

Constraints, BeginBatch, EndBatch, DisableConstraints, EnableConstraints, TDataSet.Post, TDataSet.AppendRecord, TDataSet.InsertRecord


Example

Example
TADDataSet.CopyDataSet Method
// copies dataset structure and all records
ADMemTable1.CopyDataSet(Query1, [coRestart, coStructure]);


See Also

See Also
TADDataSet.CopyDataSet Method
See Also

CopyDataSet, Data, TADDataMove


See Also

See Also
TADDataSet.CopyFields Method
See Also

CopyDataSet, Data, TADDataMove


Example

Example
TADDataSet.CreateDataSet Method
with ADMemTable1 do begin
  FieldDefs.Add('ID', ftAutoInc);
  FieldDefs.Add('Code', ftString, 10);
  FieldDefs.Add('Name', ftString, 50);
  CreateDataSet;
  // here dataset is active, has 3 fields and is empty
end;


See Also

See Also
TADDataSet.CreateDataSet Method
See Also

TDataSet.FieldDefs, TDataSet.Fields, TADCustomMemTable


Example

Example
TADDataSet.CreateExpression Method
var
  oEval: IADStanExpressionEvaluator;
...
oEval := ADMemTable1.CreateExpresison('(sal + comm) * tax / 100');
Label1.Caption := oEval.Evaluate;
...
ADMemTable1.Next;
oEval.DataSource.Position := ADMemTable1.GetRow;
Label1.Caption := oEval.Evaluate;
...
oEval := nil;
ADMemTable1.Close;


See Also

See Also
TADDataSet.CreateExpression Method
See Also

GetRow, Aggregates, Constraints, Indexes


Example

Example
TADDataSet.Data Property
ADQuery1.SQL.Text := 'select * from orders; select * from customers';

ADQuery1.Open;
ADQuery1.FetchAll;
// assign orders records to ADMemTable1
ADMemTable1.Data := ADQuery1.Data;

ADQuery1.NextRecordSet;
ADQuery1.FetchAll;
// assign customers records to ADMemTable2
ADMemTable2.Data := ADQuery1.Data;


See Also

See Also
TADDataSet.Data Property
See Also

Delta, FilteredData, CopyDataSet


See Also

See Also
TADDataSet.DatSManager Property
See Also

Table, View, SourceView, AttachTable


See Also

See Also
TADDataSet.DeleteIndex Method
See Also

Indexes, AddIndex, DeleteIndexes


See Also

See Also
TADDataSet.DeleteIndexes Method
See Also

Indexes, AddIndex, DeleteIndex


Example

Example
TADDataSet.Delta Property
// copy to ADMemTable1 all ADQuery1 changed records and theyr versions
ADMemTable1.Data := ADQuery1.Delta;


See Also

See Also
TADDataSet.Delta Property
See Also

Data, FilteredData


Example

Example
TADDataSet.DisableConstraints Method
ADQuery1.DisableConstraints;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.EnableConstraints;
end;


See Also

See Also
TADDataSet.DisableConstraints Method
See Also

EnableConstraints, Constraints, ConstraintsEnabled


Example

Example
TADDataSet.Disconnect Method
ADQuery1.SQL.Text := 'select * from [Order Details]';
ADQuery1.Prepare := True;
ADQuery1.Active := True;
ADQuery1.Disconnect;
// Active = False and Prepare = False


Example

Example
TADDataSet.EditKey Method
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
...
ADQuery1.EditKey;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 2);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


See Also

See Also
TADDataSet.EditKey Method
See Also

TDataSet.IndexFields, FindKey, GotoKey, GotoNearest, SetKey, TDataSet.State, KeyFieldCount, KeyExclusive


Example

Example
TADDataSet.EditRangeEnd Method
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := 100;
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := 200;
ADQuery1.ApplyRange;
......
ADQuery1.EditRangeEnd;
ADQuery1['CUST_NO'] := ADQuery1['CUST_NO'] - 1;
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.EditRangeEnd Method
See Also

ApplyRange, CancelRange, EditRangeStart, IndexFieldNames, IndexName, KeyExclusive, SetRange, SetRangeEnd, SetRangeStart


Example

Example
TADDataSet.EditRangeStart Method
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1['CUST_NO'] := 100;
ADQuery1.SetRangeEnd;
ADQuery1['CUST_NO'] := 200;
ADQuery1.ApplyRange;
......
ADQuery1.EditRangeStart;
ADQuery1['CUST_NO'] := ADQuery1['CUST_NO'] + 1;
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.EditRangeStart Method
See Also

ApplyRange, CancelRange, EditRangeEnd, IndexFieldNames, IndexName, KeyExclusive, SetRange, SetRangeEnd, SetRangeStart


See Also

See Also
TADDataSet.EmptyDataSet Method
See Also

Table, TDataSet.Delete


Example

Example
TADDataSet.EnableConstraints Method
ADQuery1.DisableConstraints;
try
  // perform updates here, without checking client constraints
finally
  ADQuery1.EnableConstraints;
end;


See Also

See Also
TADDataSet.EnableConstraints Method
See Also

DisableConstraints, Constraints, ConstraintsEnabled


Example

Example
TADDataSet.EndBatch Method
ADQuery1.BeginBatch;
try
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ADQuery1.AppendRecord([...]);
  ......
finally
  ADQuery1.EndBatch;
end;


See Also

See Also
TADDataSet.EndBatch Method
See Also

BeginBatch


Example

Example
TADDataSet.Execute Method
var
  i: Integer;
....
ADQuery1.SQL.Text := 'insert into mytab values (:p1, :p2)';
ADQuery1.Params.ArraySize := 10;
for i := 0 to ADQuery1.Params.ArraySize - 1 do begin
  ADQuery1.Params[0].AsIntegers[i] := i;
  ADQuery1.Params[1].AsStrings[i] := 'qwe';
end;
ADQuery1.Execute(ADQuery1.Params.ArraySize, 0);


See Also

See Also
TADDataSet.Execute Method
See Also

TADCustomQuery.SQL, TADCustomQuery.ExecSQL, TADCustomStoredProc.StoredProcName, TADCustomStoredProc.ExecProc, TADAdaptedDataSet.AbortJob, TADCustomMemTable.Adapter, TADRdbmsDataSet.Prepare, TADRdbmsDataSet.OnError, BeforeExecute, AfterExecute


Example

Example
TADDataSet.FetchAgain Method
// set SQL command
ADCommand1.CommandText := 'select * from orders where customerid = :cid';
// link command to table adapter
ADTableAdapter1.SelectCommand := ADCommand1;
// link table adapter to memtable
ADMemTable1.Adapter := ADTableAdapter1;

// set SQL command parameter value, then execute command and fetch all records
ADCommand1.Params[0].AsInteger := 100;
ADMemTable1.Open;
ADMemTable1.FetchAll;

// reset SourceEOF flag, reexecute command by hands and fetch all records
ADMemTable1.FetchAgain;
ADCommand1.Close;
ADCommand1.Params[0].AsInteger := 200;
ADCommand1.Open;
ADMemTable1.FetchAll;

// here we will have in memtable orders for customers with ID=100 and ID=200


See Also

See Also
TADDataSet.FetchAgain Method
See Also

FetchAll, TDataSet.Open, TADCustomCommand, TADCustomTableAdapter


See Also

See Also
TADDataSet.FetchAll Method
See Also

TADFetchOptions.Mode, TDataSet.Open


Example

Example
TADDataSet.FetchBlobs Method
ADQuery1.FetchOptions.Items := ADQuery1.FetchOptions.Items - [fiBlobs];
ADQuery1.Open;
....
ADQuery1.FetchBlobs;
oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('image'), bmRead);
try
  // process image
finally
  oStr.Free;
end;


See Also

See Also
TADDataSet.FetchBlobs Method
See Also

TADFetchOptions.Items


See Also

See Also
TADDataSet.FetchDetails Method
See Also

TADFetchOptions.Items


See Also

See Also
TADDataSet.FilterChanges Property
See Also
// see only inserted records
ADQuery1.FilterChanges := [rtInserted];


Example

Example
TADDataSet.FilteredData Property
ADQuery1.Filter := 'upper(name) like ''D%''';
ADQuery1.Filtered := True;
// copy to ADMemTable1 all ADQuery1 visible (where name starts from D) records
ADMemTable1.Data := ADQuery1.FilteredData;


See Also

See Also
TADDataSet.FilteredData Property
See Also

Delta, Data, Filter, OnFilterRecord, IndexName, IndexFieldNames, Indexes


Example

Example
TADDataSet.FindKey Method
ADQuery1.IndexFieldNames := 'F1;F2';
if not ADQuery1.FindKey([100, 'qwe']) then
  ShowMessage('100;qwe is not found');


See Also

See Also
TADDataSet.FindKey Method
See Also

FindNearest, GotoKey, GotoNearest, IndexName, IndexFieldNames, Locate


Example

Example
TADDataSet.FindNearest Method
ADQuery1.IndexFieldNames := 'F1;F2';
ADQuery1.FindNearest([100, 'qwe']);


See Also

See Also
TADDataSet.FindNearest Method
See Also

FindKey, GotoKey, GotoNearest, IndexName, IndexFieldNames, Locate


See Also

See Also
TADDataSet.FindParam Method
See Also

Params, ParamByName


See Also

See Also
TADDataSet.GetColumnField Method
See Also

GetFieldColumn


See Also

See Also
TADDataSet.GetDetailLinkFields Method
See Also

..


See Also

See Also
TADDataSet.GetFieldColumn Method
See Also

GetColumnField


See Also

See Also
TADDataSet.GetGroupState Method
See Also

GroupingLevel, IndexName, AggregatesActive


See Also

See Also
TADDataSet.GetIndexNames Method
See Also

IndexDefs, Indexes


Example

Example
TADDataSet.GetNextPacket Method
ADQuery1.FetchOptions.Mode := dmManual;
ADQuery1.SQL.Text := 'select * from mytab';
ADQuery1.Open;
// here RecordCount = 0
ADQuery1.GetNextPacket;
// here RecordCount <= FetchOptions.RowsetSize


See Also

See Also
TADDataSet.GetNextPacket Method
See Also

TDataSet.Open, TADFetchOptions.Mode, TADFetchOptions.RowsetSize


See Also

See Also
TADDataSet.GetParentRow Method
See Also

ParentDataSet


Example

Example
TADDataSet.GetRow Method
var
  oRow: TADDatSRow;
.....
oRow := ADQuery1.GetRow;
// cancel all changes for this row
oRow.RejectChanges;


See Also

See Also
TADDataSet.GetRow Method
See Also

TADDatSRow, TDataSet.ActiveBuffer


See Also

See Also
TADDataSet.GotoCurrent Method
See Also

CloneCursor


Example

Example
TADDataSet.GotoKey Method
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


See Also

See Also
TADDataSet.GotoKey Method
See Also

FindKey, FindNearest, GotoNearest, SetKey, Locate


Example

Example
TADDataSet.GotoNearest Method
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
ADQuery1.GotoNearest;


See Also

See Also
TADDataSet.GotoNearest Method
See Also

FindKey, FindNearest, GotoKey, SetKey, Locate


See Also

See Also
TADDataSet.GroupingLevel Property
See Also

GetGroupState, IndexFieldCount


See Also

See Also
TADDataSet.IndexDefs Property
See Also

Indexes, TADFetchOptions.Items


Example

Example
TADDataSet.Indexes Property
with ADMemTable1.Indexes.Add do begin
  Name := 'by_name';
  Fields := 'NAME;DT';
  Active := True;
end;
with ADMemTable1.Indexes.Add do begin
  Name := 'by_payments';
  Expression := 'sum(sal + bonus)';
  Filter := 'dep_id is not null;
  Active := True;
end;
ADMemTable1.IndexesActive := True;
ADMemTable1.IndexFieldName := 'by_name';


See Also

See Also
TADDataSet.Indexes Property
See Also

IndexDefs, IndexesActive, IndexFieldNames, IndexName, BeginBatch, EndBatch


Example

Example
TADDataSet.IndexesActive Property
var
  lPrevIndsActive: Boolean;
...
lPrevIndsActive := ADQuery1.IndexesActive;
ADQuery1.IndexesActive := False;
try
  // perform updates here, without maintaining client views
finally
  ADQuery1.IndexesActive := lPrevIndsActive;
end;


See Also

See Also
TADDataSet.IndexesActive Property
See Also

Indexes, BeginBatch, EndBatch


See Also

See Also
TADDataSet.IndexFieldCount Property
See Also

IndexFieldNames, IndexName


Example

Example
TADDataSet.IndexFieldNames Property
ADQuery1.IndexFieldNames := 'order_date;customer_name:N';


See Also

See Also
TADDataSet.IndexFieldNames Property
See Also

Indexes, IndexName


See Also

See Also
TADDataSet.IndexFields Property
See Also

IndexFieldNames, IndexName, IndexFieldCount


Example

Example
TADDataSet.IndexName Property
with ADMemTable1.Indexes.Add do begin
  Name := 'by_name';
  Fields := 'NAME;DT';
  Active := True;
end;
ADMemTable1.IndexFieldName := 'by_name';


See Also

See Also
TADDataSet.IndexName Property
See Also

Indexes, IndexFieldNames


See Also

See Also
TADDataSet.IsIndexed Method
See Also

IndexFieldNames, IndexName


See Also

See Also
TADDataSet.IsLinked Method
See Also

MasterSource, ParentDataSet


See Also

See Also
TADDataSet.KeyExclusive Property
See Also

FindNearest, GotoNearest, SetRange, SetRangeEnd, SetRangeStart


Example 1

Example 1
TADDataSet.KeyFieldCount Property
ADQuery1.IndexFieldNames := 'EmployeeID;CustomerID;SellDate';
ADQuery1.SetKey;
ADQuery1.KeyFieldCount := 2;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.FieldByName('CustomerID').AsInteger := 200;
ADQuery1.GotoKey;


Example 2

Example 2
TADDataSet.KeyFieldCount Property
ADQuery1.IndexFieldNames := 'EmployeeID;CustomerID;SellDate';
ADQuery1.SetRangeStart;
ADQuery1.KeyFieldCount := 1;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.SetRangeEnd;
ADQuery1.KeyFieldCount := 1;
ADQuery1.FieldByName('EmployeeID').AsInteger := 100;
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.KeyFieldCount Property
See Also

FindKey, FindNearest, GotoKey, GotoNearest


Example

Example
TADDataSet.LoadFromFile Method
ADQuery1.Open('select * from customers');
ADQuery1.FetchAll;
ADQuery1.SaveToFile('c:\customers.xml', sfAuto);
....
ADMemTable1.LoadFromFile('c:\customers.xml', sfAuto);
ADMemTable1.Locate('CUSTOMER_ID', [100], []);


See Also

See Also
TADDataSet.LoadFromFile Method
See Also

LoadFromStream, SaveToFile, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName


See Also

See Also
TADDataSet.LoadFromFileAtOpen Method
See Also

TADBottomResourceOptions.PersistentFileName, TADTopResourceOptions.DefaultStoreFolder, TADResourceOptions.Persistent


Example

Example
TADDataSet.LoadFromStream Method
var
  oStr: TStream;
....
oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('data'), bmRead);
try
  ADMemTable1.LoadFromStream(oStr, sfBinary);
finally
  oStr.Free;
end;


See Also

See Also
TADDataSet.LoadFromStream Method
See Also

LoadFromFile, SaveToStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName


Example 1

Example 1
TADDataSet.Locate Method
CustTable.IndexFieldNames := 'ID';
if CustTable.Locate('ID', 1001, []) then
  CustTable.Delete
else
  ShowMessage('The customer with ID=1001 is not found');


Example 2

Example 2
TADDataSet.Locate Method
CustTable.Locate('Company;Contact;Phone', VarArrayOf(['Sight Diver', 'P', '831-431-1000']), [loPartialKey]);


See Also

See Also
TADDataSet.Locate Method
See Also

LocateEx, Lookup, LookupEx, Indexes, IndexFieldNames, IndexName


Example

Example
TADDataSet.LocateEx Method (string, TADDataSetLocateOptions, PInteger)
procedure TForm1.BtnFindClick(ASender: TObject);
begin
  if not CustTable.LocateEx('name like ''P%D''', [lxoCaseInsensitive]) then
    ShowMessage('The customer with name starting from P and ending by D is not found');
end;

procedure TForm1.BtnNextClick(ASender: TObject);
begin
  if not CustTable.LocateEx('name like ''P%D''', [lxoCaseInsensitive, lxoFromCurrent]) then
    ShowMessage('The customer with name starting from P and ending by D is not found');
end;


See Also

See Also
TADDataSet.LocateEx Method (string, TADDataSetLocateOptions, PInteger)
See Also

Locate, Lookup, LookupEx


Example

Example
TADDataSet.LocateEx Method (string, Variant, TADDataSetLocateOptions, PInteger)
procedure TForm1.BtnFindClick(ASender: TObject);
begin
  if not CustTable.LocateEx('COMPANY', 'AMCO', [lxoCaseInsensitive]) then
    ShowMessage('The customer from AMCO company is not found');
end;

procedure TForm1.BtnNextClick(ASender: TObject);
begin
  if not CustTable.LocateEx('COMPANY', 'AMCO', [lxoCaseInsensitive, lxoFromCurrent]) then
    ShowMessage('The customer from AMCO company is not found');
end;


See Also

See Also
TADDataSet.LocateEx Method (string, Variant, TADDataSetLocateOptions, PInteger)
See Also

Locate, Lookup, LookupEx, Indexes, IndexFieldNames, IndexName


Example

Example
TADDataSet.Lookup Method
procedure TForm1.Button1Click(Sender: TObject);
var
  V: Variant;
  C: Integer;
  A: String;
begin
  V := ADQuery1.Lookup('Company;State', VarArrayOf(['Blue Sports', 'OR']), 'CustNo;Addr1');
  if not VarIsNull(V) then begin
    C := V[0];
    A := V[1];
    ShowMessage(IntToStr(C) + #13#10 + A);
  end
  else
    ShowMessage('The record is not found !');
end;


See Also

See Also
TADDataSet.Lookup Method
See Also

LookupEx, Locate, LocateEx, Indexes, IndexFieldNames, IndexName


Example

Example
TADDataSet.LookupEx Method (string, string, TADDataSetLocateOptions, PInteger)
procedure TForm1.Button1Click(Sender: TObject);
var
  V: Variant;
  C: Integer;
  A: String;
begin
  V := ADQuery1.LookupEx('Company = ''Blue Sports'' and State = ''OR''', 'CustNo;Addr1', [lxoCaseInsensitive]);
  if not VarIsNull(V) then begin
    C := V[0];
    A := V[1];
    ShowMessage(IntToStr(C) + #13#10 + A);
  end
  else
    ShowMessage('The record is not found !');
end;


See Also

See Also
TADDataSet.LookupEx Method (string, string, TADDataSetLocateOptions, PInteger)
See Also

Lookup, Locate, LocateEx


See Also

See Also
TADDataSet.LookupEx Method (string, Variant, string, TADDataSetLocateOptions, PInteger)
See Also

Lookup, Locate, LocateEx, Indexes, IndexFieldNames, IndexName


Example

Example
TADDataSet.MasterFields Property
ADMemTable1.IndexFieldNames := 'CustomerID';
ADMemTable1.MasterSource := CustomersDS;
ADMemTable1.MasterFields := 'ID';


See Also

See Also
TADDataSet.MasterFields Property
See Also

MasterSource, IndexFieldNames, IndexName


Example

Example
TADDataSet.MasterSource Property
ADMemTable1.IndexFieldNames := 'CustomerID';
ADMemTable1.MasterSource := CustomersDS;
ADMemTable1.MasterFields := 'ID';


See Also

See Also
TADDataSet.MasterSource Property
See Also

MasterFields, IndexFieldNames, IndexName


See Also

See Also
TADDataSet.Offline Method
See Also

TADCustomConnection.Offline, FetchAll


Example

Example
TADDataSet.OnReconcileError Event
procedure TForm1.ADMemTable1ReconcileError(DataSet: TADDataSet; E: EADException;
  UpdateKind: TADDatSRowState; var Action: TADDAptReconcileAction);
begin
  if (UpdateKind = rsInserted) and (E is EADDBEngineException) and (EADDBEngineException(E).Kind = ekUKViolated) then begin
    DataSet.FieldByName('ID').AsInteger := GetNextFreeID;
    Action := raCorrect;
  end;
end;


See Also

See Also
TADDataSet.OnReconcileError Event
See Also

Reconcile, ApplyUpdates, OnUpdateError


Example

Example
TADDataSet.OnUpdateError Event
procedure TForm1.ADQuery1UpdateError(ASender: TDataSet; AException: EADException;
    ARow: TADDatSRow; ARequest: TADPhysUpdateRequest; var AAction: TADErrorAction);
begin
  if (E is EADDBEngineException) and (EADDBEngineException(E).Kind = ekUKViolated) then begin
    DataSet.FieldByName('ID').AsInteger := GetNextFreeID;
    Action := eaRetry;
  end;
end;


See Also

See Also
TADDataSet.OnUpdateError Event
See Also

ApplyUpdates, CachedUpdates, Post, Delete, EADDBEngineException, OnUpdateRecord


Example 1

Example 1
TADDataSet.OnUpdateRecord Event
procedure TForm1.ADQuery1UpdateRecord(ASender: TDataSet; ARequest: TADPhysUpdateRequest;
 var AAction: TADErrorAction; AOptions: TADPhysUpdateRowOptions);
begin
  if ARequest = arInsert then begin
    // set the SQL command to insert new record
    ADQuery2.SQL := 'insert into mytab (id, code, name) values (:id, :code, :name) returning tmstamp into :ts';

    // set parameter values
    ADQuery2.Params[0].Value := ASender['id'];
    ADQuery2.Params[1].Value := ASender['code'];
    ADQuery2.Params[2].Value := ASender['name'];

    // specially define TS parameter
    ADQuery2.Params[3].DataType := ftDateTime;
    ADQuery2.Params[3].ParamType := ptOutput;

    // insert new record
    ADQuery2.ExecSQL;

    // move TS output parameter value back to dataset
    ASender['tmstamp'] := ADQuery2.Params[3].Value;

    // return 'Ok' status
    AAction := eaApplied;
  end;
end;


Example 2

Example 2
TADDataSet.OnUpdateRecord Event

See demos:

  • "AnyDAC\Samples\Comp Layer\TADQuery\CachedUpdates\OnUpdateRecord"
  • "AnyDAC\Samples\Comp Layer\TADUpdateSQL\Main"


See Also

See Also
TADDataSet.OnUpdateRecord Event
See Also

ApplyUpdates, CachedUpdates, Post, Delete, OnUpdateError


Example

Example
TADDataSet.OpenOrExecute Method
ADQuery1.Disconnect(True);
ADQuery1.SQL.Assign(Memo1.Lines);
if ADQuery1.OpenOrExecute then begin
  PageControl1.ActivePage := DataGridPage;
  DataGridPage.TabVisible := True;
end
else
  DataGridPage.TabVisible := False;


See Also

See Also
TADDataSet.OpenOrExecute Method
See Also

TDataSet.Open, Execute, TADCustomQuery.ExecSQL, TADCustomStoredProc.ExecProc


See Also

See Also
TADDataSet.ParamByName Method
See Also

FindParam


See Also

See Also
TADDataSet.ParentDataSet Property
See Also

DB.TDataSetField


See Also

See Also
TADDataSet.Ranged Property
See Also

ApplyRange, CancelRange


Example

Example
TADDataSet.RefreshRecord Method
ADQuery1.UpdateObject := ADUpdateSQL;
// PL/SQL block calling packaged procedure returning customer data by its ID
ADUpdateSQL.FetchRowSQL.Text := 'begin cust_pack.read_cust_data(:new_name, :new_company, :new_state, :old_id); end;';
// always is required to setup output parameters
with ADUpdateSQL.Commands[arFetchRow] do begin
  Params[0].ParamType := ptOutput;
  Params[0].DataType := ftString;
  Params[1].ParamType := ptOutput;
  Params[1].DataType := ftString;
  Params[2].ParamType := ptOutput;
  Params[2].DataType := ftString;
end;
...
ADQuery1.RefreshRecord;


See Also

See Also
TADDataSet.RefreshRecord Method
See Also

TDataSet.Refresh, OnUpdateRecord, TADAdaptedDataSet.UpdateObject, TADUpdateSQL.FetchRowSQL


See Also

See Also
TADDataSet.RevertRecord Method
See Also

UndoLastChange, CancelUpdates, SavePoint


Example 1

Example 1
TADDataSet.SavePoint Property
var
  iSavePoint: Integer;
....
  // remember changes log state
  iSavePoint := ADMemTable1.SavePoint;
  try
    ADMemTable1.AppendRecord(....);
    ADMemTable1.AppendRecord(....);
    ADMemTable1.AppendRecord(....);
    ...
    ADMemTable1.Delete;
    // mark changes as persistent and clear change log
    ADMemTable1.CommitUpdates;
  except
    // in case of exception, undo changes
    ADMemTable1.SavePoint := iSavePoint;
    raise;
  end;


Example 2

Example 2
TADDataSet.SavePoint Property

See demo "AnyDAC\Samples\Comp Layer\TADMemTable\CachedUpdates".


See Also

See Also
TADDataSet.SavePoint Property
See Also

CachedUpdates, ChangeCount, UndoLastChange, RevertRecord, CancelUpdates


Example

Example
TADDataSet.SaveToFile Method
ADQuery1.Open('select * from customers');
ADQuery1.FetchAll;
ADQuery1.SaveToFile('c:\customers.xml', sfAuto);
....
ADMemTable1.LoadFromFile('c:\customers.xml', sfAuto);
ADMemTable1.Locate('CUSTOMER_ID', [100], []);


See Also

See Also
TADDataSet.SaveToFile Method
See Also

SaveToStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName


See Also

See Also
TADDataSet.SaveToFileAtClose Method
See Also

TADBottomResourceOptions.PersistentFileName, TADTopResourceOptions.DefaultStoreFolder, TADResourceOptions.Persistent


Example

Example
TADDataSet.SaveToStream Method
var
  oStr: TStream;
  ....
  ADQuery1.Edit;
  oStr := ADQuery1.CreateBlobStream(ADQuery1.FieldByName('data'), bmWrite);
  try
    ADMemTable1.SaveToStream(oStr, sfBinary);
  finally
    oStr.Free;
    ADQuery1.Post;
  end;


See Also

See Also
TADDataSet.SaveToStream Method
See Also

SaveToFile, LoadFromStream, TADResourceOptions.DefaultStoreExt, TADResourceOptions.DefaultStoreFormat, TADBottomResourceOptions.PersistentFileName


Example

Example
TADDataSet.SetKey Method
ADQuery1.IndexFieldNames := 'CUSTOMER_ID;ORDER_DATE';
ADQuery1.SetKey;
ADQuery1.FieldByName('CUSTOMER_ID').AsInteger := 100;
ADQuery1.FieldByName('ORDER_DATE').AsDateTime := EncodeDate(2008, 5, 1);
if not ADQuery1.GotoKey then
  ShowMesage('Order is not found');


See Also

See Also
TADDataSet.SetKey Method
See Also

EditKey, GotoKey, SetRange, SetRangeEnd, SetRangeStart, TDataSet.State, TDataSet.FieldByName, IndexName, IndexFieldNames, Indexes


Example

Example
TADDataSet.SetRange Method
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRange([100], [200]);


See Also

See Also
TADDataSet.SetRange Method
See Also

SetRangeEnd, SetRangeStart, ApplyRange, TDataSet.State, TDataSet.FieldByName, IndexName, IndexFieldNames, Indexes


Example

Example
TADDataSet.SetRangeEnd Method
ADQuery1.IndexFieldNames := 'CUST_NO';
...
ADQuery1.SetRangeEnd;
ADQuery1.FieldByName('CUST_NO').AsInteger := 200;
...
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.SetRangeEnd Method
See Also

SetRangeStart, EditRangeStart, ApplyRange, IndexName, IndexFieldNames, Indexes, TDataSet.State, TDataSet.FieldByName


Example

Example
TADDataSet.SetRangeStart Method
ADQuery1.IndexFieldNames := 'CUST_NO';
ADQuery1.SetRangeStart;
ADQuery1.FieldByName('CUST_NO').AsInteger := 100;
...
ADQuery1.ApplyRange;


See Also

See Also
TADDataSet.SetRangeStart Method
See Also

SetRangeEnd, EditRangeStart, ApplyRange, IndexName, IndexFieldNames, Indexes, TDataSet.State, TDataSet.FieldByName


See Also

See Also
TADDataSet.SourceEOF Property
See Also

Next, FetchAll


Example

Example
TADDataSet.SourceView Property
var
  i, iVal, iMax: Integer;
....
// searching the maximum value of ID integer field, without navigating through dataset
iMax := 0;
for i := 0 to ADQuery1.SourceView.Rows.Count - 1 do
  if ADQuery1.SourceView.Rows[i].GetData('id', @iVal) and (iVal > iMax) then
    iMax := iVal;


See Also

See Also
TADDataSet.SourceView Property
See Also

Table, View, uADDatSManager.TADDatSView


Example

Example
TADDataSet.Table Property
var
  i: Integer;
....
// delete all rows, where ID = 100, without navigating through dataset
for i := ADQuery1.Table.Rows.Count - 1 downto 0 do
  if ADQuery1.Table.Rows[i].GetData('id') = 100 then
    ADQuery1.Table.Rows[i].Delete;
ADQuery1.Resync([]);


See Also

See Also
TADDataSet.Table Property
See Also

View, SourceView, AttachTable, TADCustomMemTable


Example

Example
TADDataSet.UndoLastChange Method
procedure TForm1.btnUndoClick(ASender: TObject);
begin
  ADQuery1.UndoLastChange(True);
end;


See Also

See Also
TADDataSet.UndoLastChange Method
See Also

UpdatesPending, RevertRecord, CancelUpdates, SavePoint


See Also

See Also
TADDataSet.UpdatesPending Property
See Also

CachedUpdates, ChangeCount, ApplyUpdates, CommitUpdates, CancelUpdates


Example

Example
TADDataSet.UpdateStatus Method
procedure TForm1.ADQuery1AfterScroll(DataSet: TDataSet);
begin
  case TADQuery(DataSet).UpdateStatus of
  usUnmodified: Label1.Caption := '';
  usModified: Label1.Caption := 'Modified';
  usDeleted: Label1.Caption := 'Deleted';
  usInserted: Label1.Caption := 'Inserted';
  end;
end;


See Also

See Also
TADDataSet.UpdateStatus Method
See Also

UndoLastChange


See Also

See Also
TADDataSet.View Property
See Also

Table, SourceView, AttachTable, TADCustomMemTable


uADCompScript Unit Classes

uADCompScript Unit Classes
uADCompScript Unit Legend
Classes
Name | Description
TADScript |
TADScriptCommand |
TADScriptCommandRegistry |
TADScriptOptions |
TADScriptParser |
TADSQLScript |
TADSQLScripts |


uADCompScript Unit Functions

uADCompScript Unit Functions
uADCompScript Unit Legend
Functions
Name | Description
ADKeywordMatch |
ADScriptCommandRegistry |


Legend

Legend
uADCompScript Unit
Legend
Class
Method
Enumeration


Records, Enums

Records, Enums
uADCompScript Unit Legend
Records, Enums
Name | Description
TADScriptCommandLookupRes |
TADScriptEchoCommands |
TADScriptSpoolOutputMode |
TADScriptStatus |
TADScriptStreamMode |


Topics

Topics
uADCompScript Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADCompScript Unit Types

uADCompScript Unit Types
uADCompScript Unit
Types
Name | Description
TADConsoleGetEvent |
TADConsoleLockUpdate |
TADConsolePutEvent |
TADGetStreamEvent |
TADHostCommandEvent |
TADPauseEvent |
TADScriptCharSet |
TADScriptCommandClass |


uADStanOption Unit Classes

uADStanOption Unit Classes
uADStanOption Unit Legend
Classes
Name | Description
TADBottomResourceOptions |
TADBottomUpdateOptions |
TADCustomOptions |
TADFetchOptions | The set of options controlling data and metadata fetching.
TADFormatConversionBuffer |
TADFormatOptions |
TADMapRule |
TADMapRules |
TADResourceOptions |
TADTopResourceOptions |
TADTxOptions |
TADUpdateOptions |


uADStanOption Unit Interfaces

uADStanOption Unit Interfaces
uADStanOption Unit Legend
Interfaces
Name | Description
IADStanOptions |


Legend

Legend
uADStanOption Unit
Legend
Class
Interface
Enumeration


Records, Enums

Records, Enums
uADStanOption Unit Legend
Records, Enums
Name | Description
TADFetchGeneratorsPoint |
TADFetchItem |
TADFetchMode |
TADFetchOptionValue |
TADFormatOptionValue |
TADLockMode |
TADLockPoint |
TADRecordCountMode |
TADRefreshMode |
TADResourceOptionValue |
TADStorageFormat |
TADTxAction |
TADTxIsolation |
TADTxStopOption |
TADTxValue |
TADUpdateOptionValue |


Topics

Topics
uADStanOption Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Interfaces | The following table lists interfaces in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADStanOption Unit Types

uADStanOption Unit Types
uADStanOption Unit
Types
Name | Description
TADFetchItems |
TADFetchOptionValues |
TADFormatOptionValues |
TADOptionChangeEvent |
TADResourceOptionValues |
TADTxStopOptions |
TADTxValues |
TADUpdateOptionValues |


See Also

See Also
TADFetchOptions Class
See Also

TADCustomManager.FetchOptions, TADCustomConnection.FetchOptions, TADCustomCommand.FetchOptions, TADQuery.FetchOptions, IADPhysCommand.Options


See Also

See Also
TADFetchOptions.AutoClose Property
See Also

..


See Also

See Also
TADFetchOptions.Cache Property
See Also

Items


See Also

See Also
TADFetchOptions.Items Property
See Also

Cache, TField.ProviderFlags, TADBottomUpdateOptions.KeyFields, TADDatSColumn.Options


See Also

See Also
TADFetchOptions.Mode Property
See Also

TADDataSet.FetchAll, TADDataSet.GetNextPacket, RecsMax, RowsetSize, Unidirectional


See Also

See Also
TADFetchOptions.RecordCountMode Property
See Also

TDataSet.RecordCount, Mode


See Also

See Also
TADFetchOptions.RecsMax Property
See Also

Mode. RowsetSize


See Also

See Also
TADFetchOptions.RowsetSize Property
See Also

Mode, Unidirectional


See Also

See Also
TADFetchOptions.Unidirectional Property
See Also

RowsetSize, Mode


uADStanParam Unit Classes

uADStanParam Unit Classes
uADStanParam Unit Legend
Classes
Name | Description
TADMacro |
TADMacros |
TADParam |
TADParams |


uADStanParam Unit Functions

uADStanParam Unit Functions
uADStanParam Unit Legend
Functions
Name | Description
ADVar2SQL |
ADVar2SQLTyped |
ADVarType2FieldType |


Legend

Legend
uADStanParam Unit
Legend
Class
Method
Enumeration


Records, Enums

Records, Enums
uADStanParam Unit Legend
Records, Enums
Name | Description
TADMacroDataType |
TADParamArrayType |
TADParamBindMode |


Topics

Topics
uADStanParam Unit
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Records, Enums | The following table lists records, enums in this documentation.
Types | The following table lists types in this documentation.


uADStanParam Unit Types

uADStanParam Unit Types
uADStanParam Unit
Types
Name | Description
TADGetOwner |


See Also

See Also
Writing expressions
See Also

..


Contents

Contents
AnyDAC Contents
AnyDAC
Command text preprocessing
Character macro functions
Numeric macro functions
Date and time macro functions
System macro functions
Convert macro function
Array DML
Setting options
Retriving metadata
Writing expressions
Symbol Reference
uADCompClient Unit
Classes
TADAdaptedDataSet Class
public
TADAdaptedDataSet.Adapter Property
TADAdaptedDataSet.Command Property
TADAdaptedDataSet.DatSManager Property
TADAdaptedDataSet.OnError Event
TADAdaptedDataSet.OnExecuteError Event
TADAdaptedDataSet.PointedConnection Property
TADAdaptedDataSet.ServerEditRequest Property
TADAdaptedDataSet.AbortJob Method
TADAdaptedDataSet.Disconnect Method
TADAdaptedDataSet.NextRecordSet Method
TADAdaptedDataSet.Offline Method
TADAdaptedDataSet.ServerAppend Method
TADAdaptedDataSet.ServerCancel Method
TADAdaptedDataSet.ServerDelete Method
TADAdaptedDataSet.ServerDeleteAll Method
TADAdaptedDataSet.ServerEdit Method
TADAdaptedDataSet.ServerGotoKey Method
TADAdaptedDataSet.ServerPerform Method
TADAdaptedDataSet.ServerSetKey Method
TADCommand Class
published
TADCommand.Active Property
TADCommand.ActiveStoredUsage Property
TADCommand.AfterClose Event
TADCommand.AfterExecute Event
TADCommand.AfterOpen Event
TADCommand.AfterPrepare Event
TADCommand.AfterUnprepare Event
TADCommand.BaseObjectName Property
TADCommand.BeforeClose Event
TADCommand.BeforeExecute Event
TADCommand.BeforeOpen Event
TADCommand.BeforePrepare Event
TADCommand.BeforeUnprepare Event
TADCommand.CatalogName Property
TADCommand.CommandKind Property
TADCommand.CommandText Property
TADCommand.Connection Property
TADCommand.ConnectionName Property
TADCommand.FetchOptions Property
TADCommand.FormatOptions Property
TADCommand.Macros Property
TADCommand.OnCommandChanged Event
TADCommand.OnError Event
TADCommand.Overload Property
TADCommand.Params Property
TADCommand.Prepared Property
TADCommand.ResourceOptions Property
TADCommand.SchemaName Property
TADCommand.Transaction Property
TADCommand.UpdateOptions Property
TADConnection Class
published
TADConnection.AfterConnect Property
TADConnection.AfterDisconnect Property
TADConnection.BeforeConnect Property
TADConnection.BeforeDisconnect Property
TADConnection.Connected Property
TADConnection.ConnectedStoredUsage Property
TADConnection.ConnectionDefName Property
TADConnection.ConnectionName Property
TADConnection.DriverName Property
TADConnection.FetchOptions Property
TADConnection.FormatOptions Property
TADConnection.LoginDialog Property
TADConnection.LoginPrompt Property
TADConnection.OnError Event
TADConnection.OnLogin Event
TADConnection.OnLosted Event
TADConnection.OnRecover Event
TADConnection.OnRestored Event
TADConnection.Params Property
TADConnection.ResourceOptions Property
TADConnection.Transaction Property
TADConnection.TxOptions Property
TADConnection.UpdateOptions Property
TADConnection.UpdateTransaction Property
TADCustomCommand Class
public
TADCustomCommand.Active Property
TADCustomCommand.ActiveStoredUsage Property
TADCustomCommand.AfterClose Event
TADCustomCommand.AfterExecute Event
TADCustomCommand.AfterFetch Event
TADCustomCommand.AfterOpen Event
TADCustomCommand.AfterPrepare Event
TADCustomCommand.AfterUnprepare Event
TADCustomCommand.BaseObjectName Property
TADCustomCommand.BeforeClose Event
TADCustomCommand.BeforeExecute Event
TADCustomCommand.BeforeFetch Event
TADCustomCommand.BeforeOpen Event
TADCustomCommand.BeforePrepare Event
TADCustomCommand.BeforeUnprepare Event
TADCustomCommand.BindedBy Property
TADCustomCommand.CatalogName Property
TADCustomCommand.CommandIntf Property
TADCustomCommand.CommandKind Property
TADCustomCommand.CommandText Property
TADCustomCommand.Connection Property
TADCustomCommand.ConnectionName Property
TADCustomCommand.FetchOptions Property
TADCustomCommand.FixedCommandKind Property
TADCustomCommand.FormatOptions Property
TADCustomCommand.Macros Property
TADCustomCommand.OnCommandChanged Event
TADCustomCommand.OnError Event
TADCustomCommand.Overload Property
TADCustomCommand.ParamBindMode Property
TADCustomCommand.Params Property
TADCustomCommand.Prepared Property
TADCustomCommand.ResourceOptions Property
TADCustomCommand.RowsAffected Property
TADCustomCommand.SchemaName Property
TADCustomCommand.SQLText Property
TADCustomCommand.State Property
TADCustomCommand.Transaction Property
TADCustomCommand.UpdateOptions Property
TADCustomCommand.Values Property
TADCustomCommand.AbortJob Method
TADCustomCommand.AcquireConnection Method
TADCustomCommand.Close Method
TADCustomCommand.CloseAll Method
TADCustomCommand.Define Method (TADDatSManager, TADDatSTable, TADPhysMetaInfoMergeMode)
TADCustomCommand.Define Method (TADDatSTable, TADPhysMetaInfoMergeMode)
TADCustomCommand.Disconnect Method
TADCustomCommand.Execute Method (Integer, Integer)
TADCustomCommand.Execute Method (String)
TADCustomCommand.Execute Method (String, array of Variant)
TADCustomCommand.Execute Method (String, array of Variant, array of TFieldType)
TADCustomCommand.Fetch Method
TADCustomCommand.FillParams Method
TADCustomCommand.FindMacro Method
TADCustomCommand.FindParam Method
TADCustomCommand.GetConnection Method
TADCustomCommand.MacroByName Method
TADCustomCommand.NextRecordSet Method
TADCustomCommand.Open Method
TADCustomCommand.OpenOrExecute Method
TADCustomCommand.ParamByName Method
TADCustomCommand.Prepare Method
TADCustomCommand.ReleaseConnection Method
TADCustomCommand.Unprepare Method
TADCustomConnection Class
public
TADCustomConnection.CliHandle Property
TADCustomConnection.CliObj Property
TADCustomConnection.CommandCount Property
TADCustomConnection.Commands Property
TADCustomConnection.Connected Property
TADCustomConnection.ConnectedStoredUsage Property
TADCustomConnection.ConnectionDefName Property
TADCustomConnection.ConnectionIntf Property
TADCustomConnection.ConnectionName Property
TADCustomConnection.DataSets Property
TADCustomConnection.DriverName Property
TADCustomConnection.FetchOptions Property
TADCustomConnection.FormatOptions Property
TADCustomConnection.InTransaction Property
TADCustomConnection.IsSQLBased Property
TADCustomConnection.LastUsed Property
TADCustomConnection.LoginDialog Property
TADCustomConnection.LoginPrompt Property
TADCustomConnection.Offlined Property
TADCustomConnection.OnError Event
TADCustomConnection.OnLogin Event
TADCustomConnection.OnLosted Event
TADCustomConnection.OnRecover Event
TADCustomConnection.OnRestored Event
TADCustomConnection.OptionsIntf Property
TADCustomConnection.Params Property
TADCustomConnection.RDBMSKind Property
TADCustomConnection.RefCount Property
TADCustomConnection.ResourceOptions Property
TADCustomConnection.ResultConnectionDef Property
TADCustomConnection.SharedCliHandle Property
TADCustomConnection.Temporary Property
TADCustomConnection.Transaction Property
TADCustomConnection.TxOptions Property
TADCustomConnection.UpdateOptions Property
TADCustomConnection.UpdateTransaction Property
TADCustomConnection.ApplyUpdates Method
TADCustomConnection.CheckActive Method
TADCustomConnection.CheckConnectionDef Method
TADCustomConnection.CheckInactive Method
TADCustomConnection.CheckOnline Method
TADCustomConnection.CloseClients Method
TADCustomConnection.Commit Method
TADCustomConnection.CommitRetaining Method
TADCustomConnection.DecodeObjectName Method
TADCustomConnection.EncodeObjectName Method
TADCustomConnection.ExecSQL Method (String)
TADCustomConnection.ExecSQL Method (String, array of Variant)
TADCustomConnection.ExecSQL Method (String, array of Variant, array of TFieldType)
TADCustomConnection.GetFieldNames Method
TADCustomConnection.GetGeneratorNames Method
TADCustomConnection.GetKeyFieldNames Method
TADCustomConnection.GetLastAutoGenValue Method
TADCustomConnection.GetPackageNames Method
TADCustomConnection.GetStoredProcNames Method
TADCustomConnection.GetTableNames Method
TADCustomConnection.Offline Method
TADCustomConnection.Online Method
TADCustomConnection.Ping Method
TADCustomConnection.RefreshMetadataCache Method
TADCustomConnection.Rollback Method
TADCustomConnection.RollbackRetaining Method
TADCustomConnection.StartTransaction Method
TADCustomManager Class
public
TADCustomManager.Active Property
TADCustomManager.ActiveStoredUsage Property
TADCustomManager.AfterLoadConnectionDefFile Event
TADCustomManager.AutoCreated Property
TADCustomManager.BeforeLoadConnectionDefFile Event
TADCustomManager.CanRefreshConnectionDefFile Property
TADCustomManager.ConnectionCount Property
TADCustomManager.ConnectionDefFileAutoLoad Property
TADCustomManager.ConnectionDefFileLoaded Property
TADCustomManager.ConnectionDefFileName Property
TADCustomManager.ConnectionDefs Property
TADCustomManager.Connections Property
TADCustomManager.DriverDefFileAutoLoad Property
TADCustomManager.DriverDefFileName Property
TADCustomManager.FetchOptions Property
TADCustomManager.FormatOptions Property
TADCustomManager.OnShutdown Event
TADCustomManager.OnStartup Event
TADCustomManager.ResourceOptions Property
TADCustomManager.SilentMode Property
TADCustomManager.State Property
TADCustomManager.UpdateOptions Property
TADCustomManager.WaitCursor Property
TADCustomManager.AcquireConnection Method (TADCustomConnection, String)
TADCustomManager.AcquireConnection Method (string, String)
TADCustomManager.AddConnectionDef Method
TADCustomManager.Close Method
TADCustomManager.DeleteConnectionDef Method
TADCustomManager.DropConnections Method
TADCustomManager.FindConnection Method
TADCustomManager.GetConnectionDefNames Method
TADCustomManager.GetConnectionDefParams Method
TADCustomManager.GetConnectionNames Method
TADCustomManager.GetDriverNames Method
TADCustomManager.GetFieldNames Method
TADCustomManager.GetGeneratorNames Method
TADCustomManager.GetKeyFieldNames Method
TADCustomManager.GetPackageNames Method
TADCustomManager.GetStoredProcNames Method
TADCustomManager.GetTableNames Method
TADCustomManager.IsConnectionDef Method
TADCustomManager.LoadConnectionDefFile Method
TADCustomManager.ModifyConnectionDef Method
TADCustomManager.Open Method
TADCustomManager.RefreshConnectionDefFile Method
TADCustomManager.RefreshMetadataCache Method
TADCustomManager.ReleaseConnection Method
TADCustomManager.SaveConnectionDefFile Method
TADCustomMemTable Class
public
TADCustomMemTable.Adapter Property
TADCustomQuery Class
public
TADCustomQuery.DataSource Property
TADCustomQuery.ParamCount Property
TADCustomQuery.SQL Property
TADCustomQuery.Text Property
TADCustomQuery.ExecSQL Method ()
TADCustomQuery.ExecSQL Method (String)
TADCustomQuery.ExecSQL Method (String, array of Variant)
TADCustomQuery.ExecSQL Method (String, array of Variant, array of TFieldType)
TADCustomSchemaAdapter Class
public
TADCustomSchemaAdapter.DatSManager Property
TADCustomSchemaAdapter.OnError Event
TADCustomSchemaAdapter.OnReconcileRow Event
TADCustomSchemaAdapter.OnUpdateRow Event
TADCustomSchemaAdapter.TableAdaptersIntf Property
TADCustomSchemaAdapter.Reconcile Method
TADCustomSchemaAdapter.Update Method
TADCustomStoredProc Class
public
TADCustomStoredProc.CatalogName Property
TADCustomStoredProc.Overload Property
TADCustomStoredProc.PackageName Property
TADCustomStoredProc.ParamCount Property
TADCustomStoredProc.RowsAffected Property
TADCustomStoredProc.SchemaName Property
TADCustomStoredProc.StoredProcName Property
TADCustomStoredProc.DescriptionsAvailable Method
TADCustomStoredProc.ExecProc Method ()
TADCustomStoredProc.ExecProc Method (String)
TADCustomStoredProc.ExecProc Method (String, array of Variant)
TADCustomStoredProc.GetResults Method
TADCustomTableAdapter Class
public
TADCustomTableAdapter.ColumnMappings Property
TADCustomTableAdapter.DatSManager Property
TADCustomTableAdapter.DatSTable Property
TADCustomTableAdapter.DatSTableName Property
TADCustomTableAdapter.DeleteCommand Property
TADCustomTableAdapter.FetchRowCommand Property
TADCustomTableAdapter.InsertCommand Property
TADCustomTableAdapter.LockCommand Property
TADCustomTableAdapter.MetaInfoMergeMode Property
TADCustomTableAdapter.OnDescribeColumn Event
TADCustomTableAdapter.OnDescribeTable Event
TADCustomTableAdapter.OnError Event
TADCustomTableAdapter.OnReconcileRow Event
TADCustomTableAdapter.OnUpdateRow Event
TADCustomTableAdapter.SchemaAdapter Property
TADCustomTableAdapter.SelectCommand Property
TADCustomTableAdapter.SourceRecordSetID Property
TADCustomTableAdapter.SourceRecordSetName Property
TADCustomTableAdapter.TableAdapterIntf Property
TADCustomTableAdapter.UnLockCommand Property
TADCustomTableAdapter.UpdateCommand Property
TADCustomTableAdapter.UpdateTableName Property
TADCustomTableAdapter.UpdateTransaction Property
TADCustomTableAdapter.Define Method
TADCustomTableAdapter.Fetch Method (Boolean)
TADCustomTableAdapter.Fetch Method (TADDatSRow, TADErrorAction, Integer, TADPhysFillRowOptions)
TADCustomTableAdapter.Lock Method
TADCustomTableAdapter.Reconcile Method
TADCustomTableAdapter.Reset Method
TADCustomTableAdapter.UnLock Method
TADCustomTableAdapter.Update Method (Integer)
TADCustomTableAdapter.Update Method (TADDatSRow, TADErrorAction, TADPhysUpdateRowOptions, TADPhysRequest)
TADCustomTransaction Class
public
TADCustomTransaction.Connection Property
TADCustomTransaction.DataSetCount Property
TADCustomTransaction.DataSets Property
TADCustomTransaction.IsActive Property
TADCustomTransaction.Options Property
TADCustomTransaction.TransactionIntf Property
TADCustomTransaction.Commit Method
TADCustomTransaction.CommitRetaining Method
TADCustomTransaction.Rollback Method
TADCustomTransaction.RollbackRetaining Method
TADCustomTransaction.StartTransaction Method
TADCustomUpdateObject Class
public
TADCustomUpdateObject.DataSet Property
TADCustomUpdateObject.Apply Method
TADManager Class
published
TADManager.Active Property
TADManager.ActiveStoredUsage Property
TADManager.AfterLoadConnectionDefFile Event
TADManager.BeforeLoadConnectionDefFile Event
TADManager.ConnectionDefFileAutoLoad Property
TADManager.ConnectionDefFileName Property
TADManager.DriverDefFileAutoLoad Property
TADManager.DriverDefFileName Property
TADManager.FetchOptions Property
TADManager.FormatOptions Property
TADManager.OnShutdown Event
TADManager.OnStartup Event
TADManager.ResourceOptions Property
TADManager.SilentMode Property
TADManager.UpdateOptions Property
TADManager.WaitCursor Property
TADMemTable Class
published
TADMemTable.Active Property
TADMemTable.ActiveStoredUsage Property
TADMemTable.Adapter Property
TADMemTable.AfterApplyUpdates Event
TADMemTable.AfterCancel Property
TADMemTable.AfterClose Property
TADMemTable.AfterDelete Property
TADMemTable.AfterEdit Property
TADMemTable.AfterExecute Event
TADMemTable.AfterGetRecords Event
TADMemTable.AfterInsert Property
TADMemTable.AfterOpen Property
TADMemTable.AfterPost Property
TADMemTable.AfterRefresh Property
TADMemTable.AfterRowRequest Event
TADMemTable.AfterScroll Property
TADMemTable.Aggregates Property
TADMemTable.AggregatesActive Property
TADMemTable.AutoCalcFields Property
TADMemTable.BeforeApplyUpdates Event
TADMemTable.BeforeCancel Property
TADMemTable.BeforeClose Property
TADMemTable.BeforeDelete Property
TADMemTable.BeforeEdit Property
TADMemTable.BeforeExecute Event
TADMemTable.BeforeGetRecords Event
TADMemTable.BeforeInsert Property
TADMemTable.BeforeOpen Property
TADMemTable.BeforePost Property
TADMemTable.BeforeRefresh Property
TADMemTable.BeforeRowRequest Event
TADMemTable.BeforeScroll Property
TADMemTable.CachedUpdates Property
TADMemTable.Constraints Property
TADMemTable.ConstraintsEnabled Property
TADMemTable.DataSetField Property
TADMemTable.FetchOptions Property
TADMemTable.FieldDefs Property
TADMemTable.Filter Property
TADMemTable.FilterChanges Property
TADMemTable.Filtered Property
TADMemTable.FilterOptions Property
TADMemTable.FormatOptions Property
TADMemTable.IndexDefs Property
TADMemTable.Indexes Property
TADMemTable.IndexesActive Property
TADMemTable.IndexFieldNames Property
TADMemTable.IndexName Property
TADMemTable.MasterFields Property
TADMemTable.MasterSource Property
TADMemTable.ObjectView Property
TADMemTable.OnCalcFields Property
TADMemTable.OnDeleteError Property
TADMemTable.OnEditError Property
TADMemTable.OnFilterRecord Property
TADMemTable.OnNewRecord Property
TADMemTable.OnPostError Property
TADMemTable.OnReconcileError Event
TADMemTable.OnUpdateError Event
TADMemTable.OnUpdateRecord Event
TADMemTable.ResourceOptions Property
TADMemTable.StoreDefs Property
TADMemTable.UpdateOptions Property
TADMetaInfoCommand Class
public
TADMetaInfoCommand.Create Constructor
published
TADMetaInfoCommand.Active Property
TADMetaInfoCommand.AfterClose Event
TADMetaInfoCommand.AfterOpen Event
TADMetaInfoCommand.BaseObjectName Property
TADMetaInfoCommand.BeforeClose Event
TADMetaInfoCommand.BeforeOpen Event
TADMetaInfoCommand.CatalogName Property
TADMetaInfoCommand.Connection Property
TADMetaInfoCommand.ConnectionName Property
TADMetaInfoCommand.FormatOptions Property
TADMetaInfoCommand.MetaInfoKind Property
TADMetaInfoCommand.ObjectName Property
TADMetaInfoCommand.ObjectScopes Property
TADMetaInfoCommand.OnCommandChanged Event
TADMetaInfoCommand.OnError Event
TADMetaInfoCommand.Overload Property
TADMetaInfoCommand.SchemaName Property
TADMetaInfoCommand.TableKinds Property
TADMetaInfoCommand.Wildcard Property
TADMetaInfoQuery Class
published
TADMetaInfoQuery.Active Property
TADMetaInfoQuery.ActiveStoredUsage Property
TADMetaInfoQuery.AfterClose Property
TADMetaInfoQuery.AfterGetRecords Event
TADMetaInfoQuery.AfterOpen Property
TADMetaInfoQuery.AfterRefresh Property
TADMetaInfoQuery.AfterRowRequest Event
TADMetaInfoQuery.AfterScroll Property
TADMetaInfoQuery.Aggregates Property
TADMetaInfoQuery.AggregatesActive Property
TADMetaInfoQuery.AutoCalcFields Property
TADMetaInfoQuery.BaseObjectName Property
TADMetaInfoQuery.BeforeClose Property
TADMetaInfoQuery.BeforeGetRecords Event
TADMetaInfoQuery.BeforeOpen Property
TADMetaInfoQuery.BeforeRefresh Property
TADMetaInfoQuery.BeforeRowRequest Event
TADMetaInfoQuery.BeforeScroll Property
TADMetaInfoQuery.CatalogName Property
TADMetaInfoQuery.Connection Property
TADMetaInfoQuery.ConnectionName Property
TADMetaInfoQuery.FetchOptions Property
TADMetaInfoQuery.Filter Property
TADMetaInfoQuery.Filtered Property
TADMetaInfoQuery.FilterOptions Property
TADMetaInfoQuery.FormatOptions Property
TADMetaInfoQuery.Indexes Property
TADMetaInfoQuery.IndexesActive Property
TADMetaInfoQuery.IndexFieldNames Property
TADMetaInfoQuery.IndexName Property
TADMetaInfoQuery.MetaInfoKind Property
TADMetaInfoQuery.ObjectName Property
TADMetaInfoQuery.ObjectScopes Property
TADMetaInfoQuery.OnCalcFields Property
TADMetaInfoQuery.OnCommandChanged Event
TADMetaInfoQuery.OnError Event
TADMetaInfoQuery.OnFilterRecord Property
TADMetaInfoQuery.Overload Property
TADMetaInfoQuery.SchemaName Property
TADMetaInfoQuery.TableKinds Property
TADMetaInfoQuery.Transaction Property
TADMetaInfoQuery.UpdateTransaction Property
TADMetaInfoQuery.Wildcard Property
TADQuery Class
public
TADQuery.MacroCount Property
TADQuery.RowsAffected Property
published
TADQuery.Active Property
TADQuery.ActiveStoredUsage Property
TADQuery.AfterApplyUpdates Event
TADQuery.AfterCancel Property
TADQuery.AfterClose Property
TADQuery.AfterDelete Property
TADQuery.AfterEdit Property
TADQuery.AfterExecute Event
TADQuery.AfterGetRecords Event
TADQuery.AfterInsert Property
TADQuery.AfterOpen Property
TADQuery.AfterPost Property
TADQuery.AfterRefresh Property
TADQuery.AfterRowRequest Event
TADQuery.AfterScroll Property
TADQuery.Aggregates Property
TADQuery.AggregatesActive Property
TADQuery.AutoCalcFields Property
TADQuery.BeforeApplyUpdates Event
TADQuery.BeforeCancel Property
TADQuery.BeforeClose Property
TADQuery.BeforeDelete Property
TADQuery.BeforeEdit Property
TADQuery.BeforeExecute Event
TADQuery.BeforeGetRecords Event
TADQuery.BeforeInsert Property
TADQuery.BeforeOpen Property
TADQuery.BeforePost Property
TADQuery.BeforeRefresh Property
TADQuery.BeforeRowRequest Event
TADQuery.BeforeScroll Property
TADQuery.CachedUpdates Property
TADQuery.Connection Property
TADQuery.ConnectionName Property
TADQuery.Constraints Property
TADQuery.ConstraintsEnabled Property
TADQuery.DataSource Property
TADQuery.FetchOptions Property
TADQuery.Filter Property
TADQuery.FilterChanges Property
TADQuery.Filtered Property
TADQuery.FilterOptions Property
TADQuery.FormatOptions Property
TADQuery.Indexes Property
TADQuery.IndexesActive Property
TADQuery.IndexFieldNames Property
TADQuery.IndexName Property
TADQuery.Macros Property
TADQuery.ObjectView Property
TADQuery.OnCalcFields Property
TADQuery.OnCommandChanged Event
TADQuery.OnDeleteError Property
TADQuery.OnEditError Property
TADQuery.OnError Event
TADQuery.OnExecuteError Event
TADQuery.OnFilterRecord Property
TADQuery.OnNewRecord Property
TADQuery.OnPostError Property
TADQuery.OnReconcileError Event
TADQuery.OnUpdateError Event
TADQuery.OnUpdateRecord Event
TADQuery.Params Property
TADQuery.Prepared Property
TADQuery.ResourceOptions Property
TADQuery.SQL Property
TADQuery.Transaction Property
TADQuery.UpdateObject Property
TADQuery.UpdateOptions Property
TADQuery.UpdateTransaction Property
TADRdbmsDataSet Class
public
TADRdbmsDataSet.Connection Property
TADRdbmsDataSet.ConnectionName Property
TADRdbmsDataSet.OnCommandChanged Event
TADRdbmsDataSet.OnError Event
TADRdbmsDataSet.Transaction Property
TADRdbmsDataSet.UpdateTransaction Property
TADRdbmsDataSet.Create Constructor
TADRdbmsDataSet.Destroy Destructor
TADRdbmsDataSet.Disconnect Method
TADRdbmsDataSet.FindMacro Method
TADRdbmsDataSet.MacroByName Method
TADRdbmsDataSet.Open Method ()
TADRdbmsDataSet.Open Method (String)
TADRdbmsDataSet.Open Method (String, array of Variant)
TADRdbmsDataSet.Open Method (String, array of Variant, array of TFieldType)
TADRdbmsDataSet.Prepare Method
TADRdbmsDataSet.Unprepare Method
TADSchemaAdapter Class
published
TADSchemaAdapter.OnError Event
TADSchemaAdapter.OnReconcileRow Event
TADSchemaAdapter.OnUpdateRow Event
TADStoredProc Class
published
TADStoredProc.Active Property
TADStoredProc.ActiveStoredUsage Property
TADStoredProc.AfterApplyUpdates Event
TADStoredProc.AfterCancel Property
TADStoredProc.AfterClose Property
TADStoredProc.AfterDelete Property
TADStoredProc.AfterEdit Property
TADStoredProc.AfterExecute Event
TADStoredProc.AfterGetRecords Event
TADStoredProc.AfterInsert Property
TADStoredProc.AfterOpen Property
TADStoredProc.AfterPost Property
TADStoredProc.AfterRefresh Property
TADStoredProc.AfterRowRequest Event
TADStoredProc.AfterScroll Property
TADStoredProc.Aggregates Property
TADStoredProc.AggregatesActive Property
TADStoredProc.AutoCalcFields Property
TADStoredProc.BeforeApplyUpdates Event
TADStoredProc.BeforeCancel Property
TADStoredProc.BeforeClose Property
TADStoredProc.BeforeDelete Property
TADStoredProc.BeforeEdit Property
TADStoredProc.BeforeExecute Event
TADStoredProc.BeforeGetRecords Event
TADStoredProc.BeforeInsert Property
TADStoredProc.BeforeOpen Property
TADStoredProc.BeforePost Property
TADStoredProc.BeforeRefresh Property
TADStoredProc.BeforeRowRequest Event
TADStoredProc.BeforeScroll Property
TADStoredProc.CachedUpdates Property
TADStoredProc.CatalogName Property
TADStoredProc.Connection Property
TADStoredProc.ConnectionName Property
TADStoredProc.Constraints Property
TADStoredProc.ConstraintsEnabled Property
TADStoredProc.FetchOptions Property
TADStoredProc.Filter Property
TADStoredProc.FilterChanges Property
TADStoredProc.Filtered Property
TADStoredProc.FilterOptions Property
TADStoredProc.FormatOptions Property
TADStoredProc.Indexes Property
TADStoredProc.IndexesActive Property
TADStoredProc.IndexFieldNames Property
TADStoredProc.IndexName Property
TADStoredProc.ObjectView Property
TADStoredProc.OnCalcFields Property
TADStoredProc.OnCommandChanged Event
TADStoredProc.OnDeleteError Property
TADStoredProc.OnEditError Property
TADStoredProc.OnError Event
TADStoredProc.OnExecuteError Event
TADStoredProc.OnFilterRecord Property
TADStoredProc.OnNewRecord Property
TADStoredProc.OnPostError Property
TADStoredProc.OnReconcileError Event
TADStoredProc.OnUpdateError Event
TADStoredProc.OnUpdateRecord Event
TADStoredProc.Overload Property
TADStoredProc.PackageName Property
TADStoredProc.ParamBindMode Property
TADStoredProc.Params Property
TADStoredProc.Prepared Property
TADStoredProc.ResourceOptions Property
TADStoredProc.SchemaName Property
TADStoredProc.StoredProcName Property
TADStoredProc.Transaction Property
TADStoredProc.UpdateObject Property
TADStoredProc.UpdateOptions Property
TADStoredProc.UpdateTransaction Property
TADTable Class
public
TADTable.Create Constructor
published
TADTable.Active Property
TADTable.ActiveStoredUsage Property
TADTable.AfterApplyUpdates Event
TADTable.AfterCancel Property
TADTable.AfterClose Property
TADTable.AfterDelete Property
TADTable.AfterEdit Property
TADTable.AfterGetRecords Event
TADTable.AfterInsert Property
TADTable.AfterOpen Property
TADTable.AfterPost Property
TADTable.AfterRefresh Property
TADTable.AfterRowRequest Event
TADTable.AfterScroll Property
TADTable.Aggregates Property
TADTable.AggregatesActive Property
TADTable.AutoCalcFields Property
TADTable.BeforeApplyUpdates Event
TADTable.BeforeCancel Property
TADTable.BeforeClose Property
TADTable.BeforeDelete Property
TADTable.BeforeEdit Property
TADTable.BeforeGetRecords Event
TADTable.BeforeInsert Property
TADTable.BeforeOpen Property
TADTable.BeforePost Property
TADTable.BeforeRefresh Property
TADTable.BeforeRowRequest Event
TADTable.BeforeScroll Property
TADTable.CachedUpdates Property
TADTable.CatalogName Property
TADTable.Connection Property
TADTable.ConnectionName Property
TADTable.Constraints Property
TADTable.ConstraintsEnabled Property
TADTable.Exclusive Property
TADTable.FetchOptions Property
TADTable.Filter Property
TADTable.FilterChanges Property
TADTable.Filtered Property
TADTable.FilterOptions Property
TADTable.FormatOptions Property
TADTable.Indexes Property
TADTable.IndexesActive Property
TADTable.IndexFieldNames Property
TADTable.IndexName Property
TADTable.MasterFields Property
TADTable.MasterSource Property
TADTable.ObjectView Property
TADTable.OnCalcFields Property
TADTable.OnCommandChanged Event
TADTable.OnDeleteError Property
TADTable.OnEditError Property
TADTable.OnError Event
TADTable.OnExecuteError Event
TADTable.OnFilterRecord Property
TADTable.OnNewRecord Property
TADTable.OnPostError Property
TADTable.OnReconcileError Event
TADTable.OnUpdateError Event
TADTable.OnUpdateRecord Event
TADTable.ResourceOptions Property
TADTable.SchemaName Property
TADTable.TableName Property
TADTable.Transaction Property
TADTable.UpdateObject Property
TADTable.UpdateOptions Property
TADTable.UpdateTransaction Property
TADTableAdapter Class
published
TADTableAdapter.ColumnMappings Property
TADTableAdapter.DatSTableName Property
TADTableAdapter.DeleteCommand Property
TADTableAdapter.FetchRowCommand Property
TADTableAdapter.InsertCommand Property
TADTableAdapter.LockCommand Property
TADTableAdapter.MetaInfoMergeMode Property
TADTableAdapter.OnDescribeColumn Event
TADTableAdapter.OnDescribeTable Event
TADTableAdapter.OnError Event
TADTableAdapter.OnReconcileRow Event
TADTableAdapter.OnUpdateRow Event
TADTableAdapter.SchemaAdapter Property
TADTableAdapter.SelectCommand Property
TADTableAdapter.SourceRecordSetID Property
TADTableAdapter.SourceRecordSetName Property
TADTableAdapter.UnLockCommand Property
TADTableAdapter.UpdateCommand Property
TADTableAdapter.UpdateTableName Property
TADTableAdapter.UpdateTransaction Property
TADTransaction Class
published
TADTransaction.Connection Property
TADTransaction.Options Property
TADUpdateSQL Class
public
TADUpdateSQL.Commands Property
TADUpdateSQL.SQL Property
TADUpdateSQL.Apply Method
TADUpdateSQL.Create Constructor
TADUpdateSQL.Destroy Destructor
published
TADUpdateSQL.Connection Property
TADUpdateSQL.ConnectionName Property
TADUpdateSQL.DeleteSQL Property
TADUpdateSQL.FetchRowSQL Property
TADUpdateSQL.InsertSQL Property
TADUpdateSQL.LockSQL Property
TADUpdateSQL.ModifySQL Property
TADUpdateSQL.UnlockSQL Property
Functions
uADCompClient.ADFindDefaultConnection Function
uADCompClient.ADManager Function
uADCompClient.ADSetConnectionClass Function
uADCompClient.ADSetManagerClass Function
Records, Enums
uADCompClient.TADBindedBy Enumeration
uADCompClient.TADChangingKind Enumeration
Types
uADCompClient.TADChangingKinds Type
uADCompClient.TADConnectionLoginEvent Type
uADCompClient.TADConnectionRecoverEvent Type
uADCompClient.TADCustomConnectionClass Type
uADCompClient.TADCustomManagerClass Type
uADCompClient.TADDescribeColumnEvent Type
uADCompClient.TADDescribeTableEvent Type
uADCompClient.TADErrorEvent Type
uADCompClient.TADExecuteErrorEvent Type
uADCompClient.TADOperationFinishedEvent Type
uADCompClient.TADReconcileRowEvent Type
uADCompClient.TADUpdateRowEvent Type
uADCompDataMove Unit
Classes
TADDataMove Class
public
TADDataMove.DeleteCount Property
TADDataMove.ExceptionCount Property
TADDataMove.InsertCount Property
TADDataMove.ReadCount Property
TADDataMove.UpdateCount Property
TADDataMove.WriteCount Property
TADDataMove.AbortJob Method
TADDataMove.Create Constructor
TADDataMove.Destroy Destructor
TADDataMove.Execute Method
published
TADDataMove.CommitCount Property
TADDataMove.Destination Property
TADDataMove.DestinationKind Property
TADDataMove.LogFileAction Property
TADDataMove.LogFileName Property
TADDataMove.Mappings Property
TADDataMove.Mode Property
TADDataMove.OnError Event
TADDataMove.OnFindDestRecord Event
TADDataMove.OnProgress Event
TADDataMove.Options Property
TADDataMove.Source Property
TADDataMove.SourceKind Property
TADDataMove.StatisticsInterval Property
TADDataMove.TextDataDef Property
TADDataMove.TextFileName Property
TADMappingItem Class
public
TADMappingItem.AsText Property
TADMappingItem.DestField Property
TADMappingItem.DestTextField Property
TADMappingItem.DestValue Property
TADMappingItem.InKey Property
TADMappingItem.ItemValue Property
TADMappingItem.SourceEvaluator Property
TADMappingItem.SourceField Property
TADMappingItem.SourceTextField Property
TADMappingItem.SourceValue Property
TADMappingItem.Assign Method
TADMappingItem.Destroy Destructor
TADMappingItem.Move Method
TADMappingItem.Prepare Method
TADMappingItem.Unprepare Method
published
TADMappingItem.DestinationFieldName Property
TADMappingItem.SourceExpression Property
TADMappingItem.SourceFieldName Property
TADMappings Class
public
TADMappings.DataMove Property
TADMappings.Items Property
TADMappings.Add Method ()
TADMappings.Add Method (String)
TADMappings.AddAll Method
TADMappings.Assign Method
TADMappings.Create Constructor
TADMappings.IndexOfName Method
TADMappings.Move Method
TADMappings.Prepare Method
TADMappings.Unprepare Method
TADTextDataDef Class
public
TADTextDataDef.DataMove Property
TADTextDataDef.Assign Method
TADTextDataDef.Create Constructor
TADTextDataDef.Destroy Destructor
published
TADTextDataDef.Delimiter Property
TADTextDataDef.EndOfLine Property
TADTextDataDef.Fields Property
TADTextDataDef.FormatSettings Property
TADTextDataDef.RecordFormat Property
TADTextDataDef.Separator Property
TADTextDataDef.WithFieldNames Property
TADTextField Class
public
TADTextField.Assign Method
TADTextField.DefineAsField Method
published
TADTextField.DataType Property
TADTextField.FieldName Property
TADTextField.FieldSize Property
TADTextField.Precision Property
TADTextFields Class
public
TADTextFields.Items Property
TADTextFields.Add Method
TADTextFields.AddAll Method
TADTextFields.Create Constructor
TADTextFields.FieldByName Method
TADTextFields.FindField Method
TADTextFormatSettings Class
public
TADTextFormatSettings.DataDef Property
TADTextFormatSettings.Assign Method
TADTextFormatSettings.Create Constructor
TADTextFormatSettings.Destroy Destructor
published
TADTextFormatSettings.CurrencyDecimals Property
TADTextFormatSettings.CurrencyFormat Property
TADTextFormatSettings.CurrencyString Property
TADTextFormatSettings.DateSeparator Property
TADTextFormatSettings.DecimalSeparator Property
TADTextFormatSettings.NegCurrFormat Property
TADTextFormatSettings.ShortDateFormat Property
TADTextFormatSettings.ShortTimeFormat Property
TADTextFormatSettings.ThousandSeparator Property
TADTextFormatSettings.TimeAMString Property
TADTextFormatSettings.TimePMString Property
TADTextFormatSettings.TimeSeparator Property
TADTextFormatSettings.TwoDigitYearCenturyWindow Property
Records, Enums
uADCompDataMove.TADDataMoveMode Enumeration
uADCompDataMove.TADDataMoveOption Enumeration
uADCompDataMove.TADDataMovePhase Enumeration
uADCompDataMove.TADDataSourceKind Enumeration
uADCompDataMove.TADLogFileAction Enumeration
uADCompDataMove.TADTextDataType Enumeration
uADCompDataMove.TADTextEndOfLine Enumeration
uADCompDataMove.TADTextFormatSettingsValue Enumeration
uADCompDataMove.TADTextRecordFormat Enumeration
uADCompDataMove.TFormatSettings Record
Types
uADCompDataMove.TADDataMoveErrorEvent Type
uADCompDataMove.TADDataMoveFindDestRecordEvent Type
uADCompDataMove.TADDataMoveOptions Type
uADCompDataMove.TADDataMoveProgressEvent Type
uADCompDataMove.TADTextFormatSettingsValueSet Type
uADCompDataSet Unit
Classes
TADAggregate Class
public
TADAggregate.ActualActive Property
TADAggregate.DataSet Property
TADAggregate.DataType Property
TADAggregate.InUse Property
TADAggregate.Value Property
TADAggregate.Assign Method
TADAggregate.BeginUpdate Method
TADAggregate.Destroy Destructor
TADAggregate.EndUpdate Method
published
TADAggregate.Active Property
TADAggregate.Expression Property
TADAggregate.GroupingLevel Property
TADAggregate.IndexName Property
TADAggregate.Name Property
TADAggregates Class
public
TADAggregates.GroupingLevel Property
TADAggregates.Items Property
TADAggregates.Add Method
TADAggregates.AggregateByName Method
TADAggregates.Build Method
TADAggregates.Create Constructor
TADAggregates.FindAggregate Method
TADAggregates.Release Method
TADAutoIncField Class
public
TADAutoIncField.Create Constructor
published
TADAutoIncField.AutoGenerateValue Property
TADAutoIncField.AutoIncrementSeed Property
TADAutoIncField.AutoIncrementStep Property
TADAutoIncField.ClientAutoIncrement Property
TADAutoIncField.ProviderFlags Property
TADAutoIncField.ReadOnly Property
TADAutoIncField.ServerAutoIncrement Property
TADBlobStream Class
public
TADBlobStream.Create Constructor
TADBlobStream.Destroy Destructor
TADBlobStream.Truncate Method
TADBlobStream.Write Method
TADColMapItem Class
public
TADColMapItem.FColumn Field
TADColMapItem.FColumnIndex Field
TADColMapItem.FPath Field
TADDataSet Class
public
TADDataSet.ActiveStoredUsage Property
TADDataSet.AfterApplyUpdates Event
TADDataSet.AfterExecute Event
TADDataSet.AfterGetRecords Event
TADDataSet.AfterRowRequest Event
TADDataSet.Aggregates Property
TADDataSet.AggregatesActive Property
TADDataSet.BeforeApplyUpdates Event
TADDataSet.BeforeExecute Event
TADDataSet.BeforeGetRecords Event
TADDataSet.BeforeRowRequest Event
TADDataSet.CachedUpdates Property
TADDataSet.ChangeCount Property
TADDataSet.CloneSource Property
TADDataSet.Constraints Property
TADDataSet.ConstraintsEnabled Property
TADDataSet.Data Property
TADDataSet.DatSManager Property
TADDataSet.Delta Property
TADDataSet.FilterChanges Property
TADDataSet.FilteredData Property
TADDataSet.GroupingLevel Property
TADDataSet.IndexDefs Property
TADDataSet.Indexes Property
TADDataSet.IndexesActive Property
TADDataSet.IndexFieldCount Property
TADDataSet.IndexFieldNames Property
TADDataSet.IndexFields Property
TADDataSet.IndexName Property
TADDataSet.KeyExclusive Property
TADDataSet.KeyFieldCount Property
TADDataSet.MasterFields Property
TADDataSet.MasterSource Property
TADDataSet.OnReconcileError Event
TADDataSet.OnUpdateError Event
TADDataSet.OnUpdateRecord Event
TADDataSet.ParentDataSet Property
TADDataSet.Ranged Property
TADDataSet.SavePoint Property
TADDataSet.SourceEOF Property
TADDataSet.SourceView Property
TADDataSet.Table Property
TADDataSet.UpdatesPending Property
TADDataSet.View Property
TADDataSet.AddIndex Method
TADDataSet.ApplyRange Method
TADDataSet.ApplyUpdates Method
TADDataSet.AttachTable Method
TADDataSet.BeginBatch Method
TADDataSet.BookmarkStrValid Method
TADDataSet.BookmarkValid Method
TADDataSet.Cancel Method
TADDataSet.CancelRange Method
TADDataSet.CancelUpdates Method
TADDataSet.CloneCursor Method
TADDataSet.CommitUpdates Method
TADDataSet.CompareBookmarks Method
TADDataSet.CopyDataSet Method
TADDataSet.CopyFields Method
TADDataSet.Create Constructor
TADDataSet.CreateBlobStream Method
TADDataSet.CreateDataSet Method
TADDataSet.CreateExpression Method
TADDataSet.DeleteIndex Method
TADDataSet.DeleteIndexes Method
TADDataSet.Destroy Destructor
TADDataSet.DisableConstraints Method
TADDataSet.Disconnect Method
TADDataSet.EditKey Method
TADDataSet.EditRangeEnd Method
TADDataSet.EditRangeStart Method
TADDataSet.EmptyDataSet Method
TADDataSet.EnableConstraints Method
TADDataSet.EndBatch Method
TADDataSet.Execute Method
TADDataSet.FetchAgain Method
TADDataSet.FetchAll Method
TADDataSet.FetchBlobs Method
TADDataSet.FetchDetails Method
TADDataSet.FindKey Method
TADDataSet.FindNearest Method
TADDataSet.FindParam Method
TADDataSet.GetColumnField Method
TADDataSet.GetCurrentRecord Method
TADDataSet.GetDetailLinkFields Method
TADDataSet.GetFieldColumn Method
TADDataSet.GetFieldData Method (Integer, Pointer)
TADDataSet.GetFieldData Method (TField, Pointer)
TADDataSet.GetGroupState Method
TADDataSet.GetIndexNames Method
TADDataSet.GetNextPacket Method
TADDataSet.GetParentRow Method
TADDataSet.GetRow Method
TADDataSet.GotoCurrent Method
TADDataSet.GotoKey Method
TADDataSet.GotoNearest Method
TADDataSet.IsIndexed Method
TADDataSet.IsLinked Method
TADDataSet.IsSequenced Method
TADDataSet.LoadFromFile Method
TADDataSet.LoadFromFileAtOpen Method
TADDataSet.LoadFromStream Method
TADDataSet.Locate Method
TADDataSet.LocateEx Method (string, TADDataSetLocateOptions, PInteger)
TADDataSet.LocateEx Method (string, Variant, TADDataSetLocateOptions, PInteger)
TADDataSet.Lookup Method
TADDataSet.LookupEx Method (string, Variant, string, TADDataSetLocateOptions, PInteger)
TADDataSet.LookupEx Method (string, string, TADDataSetLocateOptions, PInteger)
TADDataSet.Offline Method
TADDataSet.OpenOrExecute Method
TADDataSet.ParamByName Method
TADDataSet.Post Method
TADDataSet.Reconcile Method
TADDataSet.RefreshRecord Method
TADDataSet.RevertRecord Method
TADDataSet.SaveToFile Method
TADDataSet.SaveToFileAtClose Method
TADDataSet.SaveToStream Method
TADDataSet.SetFieldAttributes Method ()
TADDataSet.SetFieldAttributes Method (TField, TADDatSColumn, Boolean)
TADDataSet.SetFieldAttributes Method (TFields)
TADDataSet.SetFieldAutoGenerateValue Method
TADDataSet.SetKey Method
TADDataSet.SetRange Method
TADDataSet.SetRangeEnd Method
TADDataSet.SetRangeStart Method
TADDataSet.UndoLastChange Method
TADDataSet.UpdateStatus Method
TADIndex Class
public
TADIndex.ActualActive Property
TADIndex.DataSet Property
TADIndex.Assign Method
TADIndex.BeginUpdate Method
TADIndex.Destroy Destructor
TADIndex.EndUpdate Method
published
TADIndex.Active Property
TADIndex.CaseInsFields Property
TADIndex.DescFields Property
TADIndex.Expression Property
TADIndex.Fields Property
TADIndex.Filter Property
TADIndex.FilterOptions Property
TADIndex.Name Property
TADIndex.Options Property
TADIndex.Selected Property
TADIndexes Class
public
TADIndexes.Items Property
TADIndexes.Add Method
TADIndexes.Build Method
TADIndexes.Create Constructor
TADIndexes.FindIndex Method
TADIndexes.FindIndexForFields Method
TADIndexes.IndexByName Method
TADIndexes.Release Method
TADMasterDataLink Class
public
TADMasterDataLink.OnMasterFieldsDefined Event
TADWideMemoField Class
public
TADWideMemoField.Value Property
TADWideMemoField.Create Constructor
Interfaces
IADDataSet Interface
public
IADDataSet.DataView Property
IADDataSet.GetDataView Method
Records, Enums
uADCompDataSet.TADDataSetLocateOption Enumeration
uADCompDataSet.TADKeyBuffer Record
uADCompDataSet.TADKeyIndex Enumeration
Types
uADCompDataSet.PADKeyBuffer Type
uADCompDataSet.TADAfterApplyUpdatesEvent Type
uADCompDataSet.TADCopyDataSetOptions Type
uADCompDataSet.TADDataSetEvent Type
uADCompDataSet.TADDataSetFlags Type
uADCompDataSet.TADDataSetLocateOptions Type
uADCompDataSet.TADReconcileErrorEvent Type
uADCompDataSet.TADStoredActivationUsage Type
uADCompDataSet.TADUpdateErrorEvent Type
uADCompDataSet.TADUpdateRecordEvent Type
uADCompScript Unit
Classes
TADScript Class
public
TADScript.AllSpools Property
TADScript.CallStack Property
TADScript.CommandIntf Property
TADScript.ConnectionIntf Property
TADScript.CurrentCommand Property
TADScript.EOF Property
TADScript.Finished Property
TADScript.LastSpoolFileName Property
TADScript.Position Property
TADScript.ProcessedAfterCommit Property
TADScript.RDBMSKind Property
TADScript.Status Property
TADScript.Table Property
TADScript.TotalErrors Property
TADScript.TotalJobDone Property
TADScript.TotalJobSize Property
TADScript.TotalPct10Done Property
TADScript.AbortJob Method
TADScript.CheckCommand Method
TADScript.CloseConnection Method
TADScript.CloseSpool Method
TADScript.ConGet Method
TADScript.ConLockUpdate Method
TADScript.ConPut Method
TADScript.ConUnlockUpdate Method
TADScript.Create Constructor
TADScript.Destroy Destructor
TADScript.ExecuteAll Method ()
TADScript.ExecuteAll Method (TADScriptParser)
TADScript.ExecuteHostCommand Method
TADScript.ExecuteStep Method ()
TADScript.ExecuteStep Method (TADScriptParser)
TADScript.ExpandString Method
TADScript.GetStream Method
TADScript.OpenConnection Method
TADScript.Progress Method
TADScript.ReleaseStream Method
TADScript.UpdateCommandSeparator Method
TADScript.UpdateSpool Method
TADScript.ValidateAll Method ()
TADScript.ValidateAll Method (TADScriptParser)
TADScript.ValidateStep Method ()
TADScript.ValidateStep Method (TADScriptParser)
published
TADScript.AfterExecute Event
TADScript.AfterScript Event
TADScript.Arguments Property
TADScript.BeforeExecute Event
TADScript.BeforeScript Event
TADScript.Connection Property
TADScript.DefaultDriverName Property
TADScript.FetchOptions Property
TADScript.FormatOptions Property
TADScript.Macros Property
TADScript.OnConsoleGet Event
TADScript.OnConsoleLockUpdate Event
TADScript.OnConsolePut Event
TADScript.OnError Event
TADScript.OnGetStream Event
TADScript.OnHostCommand Event
TADScript.OnPause Event
TADScript.OnProgress Event
TADScript.OnReleaseStream Event
TADScript.OnSpoolPut Event
TADScript.Params Property
TADScript.ResourceOptions Property
TADScript.ScriptDialog Property
TADScript.ScriptOptions Property
TADScript.SQLScriptFileName Property
TADScript.SQLScripts Property
TADScriptCommand Class
public
TADScriptCommand.Engine Property
TADScriptCommand.Parser Property
TADScriptCommand.Position Property
TADScriptCommand.AbortJob Method
TADScriptCommand.Create Constructor
TADScriptCommand.Destroy Destructor
TADScriptCommand.Execute Method
TADScriptCommand.Help Method
TADScriptCommand.Keywords Method
TADScriptCommand.Parse Method
TADScriptCommand.Validate Method
TADScriptCommandRegistry Class
public
TADScriptCommandRegistry.DefaultPLSQLCommandClass Property
TADScriptCommandRegistry.DefaultSQLCommandClass Property
TADScriptCommandRegistry.AddCommand Method
TADScriptCommandRegistry.Create Constructor
TADScriptCommandRegistry.Destroy Destructor
TADScriptCommandRegistry.Help Method
TADScriptCommandRegistry.LookupCommand Method
TADScriptOptions Class
public
TADScriptOptions.ActualCommandSeparator Property
published
TADScriptOptions.AutoPrintParams Property
TADScriptOptions.BreakOnError Property
TADScriptOptions.ColumnHeadings Property
TADScriptOptions.CommandSeparator Property
TADScriptOptions.CommitEachNCommands Property
TADScriptOptions.ConsoleOutput Property
TADScriptOptions.DefaultDataPath Property
TADScriptOptions.DefaultScriptPath Property
TADScriptOptions.DropNonexistObj Property
TADScriptOptions.EchoCommands Property
TADScriptOptions.EchoCommandTrim Property
TADScriptOptions.FeedbackCommands Property
TADScriptOptions.FeedbackScript Property
TADScriptOptions.LineSize Property
TADScriptOptions.MacroExpand Property
TADScriptOptions.MaxBytesToPrintLongs Property
TADScriptOptions.PageSize Property
TADScriptOptions.ParamArraySize Property
TADScriptOptions.SpoolFileName Property
TADScriptOptions.SpoolOutput Property
TADScriptOptions.Timing Property
TADScriptOptions.TrimConsole Property
TADScriptOptions.TrimSpool Property
TADScriptOptions.Verify Property
TADScriptOptions.Assign Method
TADScriptOptions.Create Constructor
TADScriptParser Class
public
TADScriptParser.Ch Property
TADScriptParser.FileName Property
TADScriptParser.LineNumber Property
TADScriptParser.ParentCommand Property
TADScriptParser.Position Property
TADScriptParser.ScriptOptions Property
TADScriptParser.TotalSize Property
TADScriptParser.WasBeginningOfLine Property
TADScriptParser.Create Constructor
TADScriptParser.ExtractCommand Method
TADScriptParser.ExtractString Method
TADScriptParser.GetBookmark Method
TADScriptParser.GetChar Method
TADScriptParser.GetIdentifier Method
TADScriptParser.GetLine Method
TADScriptParser.GetNumber Method
TADScriptParser.GetOnOfChar Method
TADScriptParser.GetOnOff Method
TADScriptParser.GetString Method
TADScriptParser.GetStringInFull Method
TADScriptParser.GetUCWord Method
TADScriptParser.InvalidSyntax Method
TADScriptParser.SetBookmark Method
TADScriptParser.SkipWS Method
TADScriptParser.SkipWSLF Method
TADScriptParser.UnGetChar Method
TADSQLScript Class
public
TADSQLScript.Assign Method
TADSQLScript.Create Constructor
TADSQLScript.Destroy Destructor
published
TADSQLScript.Name Property
TADSQLScript.SQL Property
TADSQLScripts Class
public
TADSQLScripts.Items Property
TADSQLScripts.Add Method
TADSQLScripts.Create Constructor
TADSQLScripts.FindScript Method
Functions
uADCompScript.ADKeywordMatch Function
uADCompScript.ADScriptCommandRegistry Function
Records, Enums
uADCompScript.TADScriptCommandLookupRes Enumeration
uADCompScript.TADScriptEchoCommands Enumeration
uADCompScript.TADScriptSpoolOutputMode Enumeration
uADCompScript.TADScriptStatus Enumeration
uADCompScript.TADScriptStreamMode Enumeration
Types
uADCompScript.TADConsoleGetEvent Type
uADCompScript.TADConsoleLockUpdate Type
uADCompScript.TADConsolePutEvent Type
uADCompScript.TADGetStreamEvent Type
uADCompScript.TADHostCommandEvent Type
uADCompScript.TADPauseEvent Type
uADCompScript.TADScriptCharSet Type
uADCompScript.TADScriptCommandClass Type
uADStanOption Unit
Classes
TADBottomResourceOptions Class
public
TADBottomResourceOptions.Assign Method
TADBottomResourceOptions.ResolveFileName Method
TADBottomResourceOptions.RestoreDefaults Method
published
TADBottomResourceOptions.PersistentFileName Property
TADBottomUpdateOptions Class
public
TADBottomUpdateOptions.Assign Method
TADBottomUpdateOptions.RestoreDefaults Method
published
TADBottomUpdateOptions.AutoIncFields Property
TADBottomUpdateOptions.KeyFields Property
TADBottomUpdateOptions.UpdateTableName Property
TADCustomOptions Class
public
TADCustomOptions.Owner Property
TADCustomOptions.OwnerObj Property
TADCustomOptions.BeforeDestruction Method
TADCustomOptions.Create Constructor
TADCustomOptions.RestoreDefaults Method
TADFetchOptions Class
public
TADFetchOptions.ActualRowsetSize Property
TADFetchOptions.AssignedValues Property
TADFetchOptions.Assign Method
TADFetchOptions.IsValueOwned Method
TADFetchOptions.RestoreDefaults Method
published
TADFetchOptions.AutoClose Property
TADFetchOptions.Cache Property
TADFetchOptions.Items Property
TADFetchOptions.Mode Property
TADFetchOptions.RecordCountMode Property
TADFetchOptions.RecsMax Property
TADFetchOptions.RowsetSize Property
TADFetchOptions.Unidirectional Property
TADFormatConversionBuffer Class
public
TADFormatConversionBuffer.FBuffer Field
TADFormatConversionBuffer.FBufferSize Field
TADFormatConversionBuffer.Ptr Property
TADFormatConversionBuffer.Size Property
TADFormatConversionBuffer.Check Method
TADFormatConversionBuffer.Create Constructor
TADFormatConversionBuffer.Destroy Destructor
TADFormatConversionBuffer.Extend Method
TADFormatConversionBuffer.Release Method
TADFormatOptions Class
public
TADFormatOptions.AssignedValues Property
TADFormatOptions.StrsDivLen2 Property
TADFormatOptions.Assign Method
TADFormatOptions.CheckConversion Method
TADFormatOptions.ColumnDef2FieldDef Method
TADFormatOptions.ConvertRawData Method
TADFormatOptions.Create Constructor
TADFormatOptions.Destroy Destructor
TADFormatOptions.FieldDef2ColumnDef Method
TADFormatOptions.IsValueOwned Method
TADFormatOptions.ResolveDataType Method
TADFormatOptions.ResolveFieldType Method
TADFormatOptions.RestoreDefaults Method
published
TADFormatOptions.DefaultParamDataType Property
TADFormatOptions.InlineDataSize Property
TADFormatOptions.MapRules Property
TADFormatOptions.MaxBcdPrecision Property
TADFormatOptions.MaxBcdScale Property
TADFormatOptions.MaxStringSize Property
TADFormatOptions.OwnMapRules Property
TADFormatOptions.StrsEmpty2Null Property
TADFormatOptions.StrsTrim Property
TADMapRule Class
public
TADMapRule.Assign Method
TADMapRule.Create Constructor
published
TADMapRule.PrecMax Property
TADMapRule.PrecMin Property
TADMapRule.ScaleMax Property
TADMapRule.ScaleMin Property
TADMapRule.SizeMax Property
TADMapRule.SizeMin Property
TADMapRule.SourceDataType Property
TADMapRule.TargetDataType Property
TADMapRules Class
public
TADMapRules.Items Property
TADMapRules.Add Method
TADMapRules.Create Constructor
TADResourceOptions Class
public
TADResourceOptions.ActualSilentMode Property
TADResourceOptions.AssignedValues Property
TADResourceOptions.BackupExt Property
TADResourceOptions.BackupFolder Property
TADResourceOptions.DefaultStoreExt Property
TADResourceOptions.DefaultStoreFolder Property
TADResourceOptions.DefaultStoreFormat Property
TADResourceOptions.PreprocessCmdText Property
TADResourceOptions.Assign Method
TADResourceOptions.IsValueOwned Method
TADResourceOptions.RestoreDefaults Method
published
TADResourceOptions.ArrayDMLSize Property
TADResourceOptions.AutoManage Property
TADResourceOptions.Backup Property
TADResourceOptions.CmdExecMode Property
TADResourceOptions.CmdExecTimeout Property
TADResourceOptions.DefaultParamType Property
TADResourceOptions.DirectExecute Property
TADResourceOptions.EscapeExpand Property
TADResourceOptions.MacroCreate Property
TADResourceOptions.MacroExpand Property
TADResourceOptions.ParamCreate Property
TADResourceOptions.ParamExpand Property
TADResourceOptions.Persistent Property
TADResourceOptions.SilentMode Property
TADTopResourceOptions Class
public
TADTopResourceOptions.Assign Method
TADTopResourceOptions.RestoreDefaults Method
published
TADTopResourceOptions.AutoReconnect Property
TADTopResourceOptions.BackupExt Property
TADTopResourceOptions.BackupFolder Property
TADTopResourceOptions.DefaultStoreExt Property
TADTopResourceOptions.DefaultStoreFolder Property
TADTopResourceOptions.DefaultStoreFormat Property
TADTopResourceOptions.MaxCursors Property
TADTopResourceOptions.ServerOutput Property
TADTopResourceOptions.ServerOutputSize Property
TADTxOptions Class
public
TADTxOptions.Changed Property
TADTxOptions.Assign Method
TADTxOptions.ClearChanged Method
TADTxOptions.Create Constructor
TADTxOptions.Destroy Destructor
published
TADTxOptions.AutoCommit Property
TADTxOptions.AutoStart Property
TADTxOptions.AutoStop Property
TADTxOptions.DisconnectAction Property
TADTxOptions.Isolation Property
TADTxOptions.Params Property
TADTxOptions.ReadOnly Property
TADTxOptions.StopOptions Property
TADUpdateOptions Class
public
TADUpdateOptions.AssignedValues Property
TADUpdateOptions.Assign Method
TADUpdateOptions.IsValueOwned Method
TADUpdateOptions.RestoreDefaults Method
published
TADUpdateOptions.CacheUpdateCommands Property
TADUpdateOptions.CountUpdatedRecords Property
TADUpdateOptions.EnableDelete Property
TADUpdateOptions.EnableInsert Property
TADUpdateOptions.EnableUpdate Property
TADUpdateOptions.FastUpdates Property
TADUpdateOptions.FetchGeneratorsPoint Property
TADUpdateOptions.GeneratorName Property
TADUpdateOptions.LockMode Property
TADUpdateOptions.LockPoint Property
TADUpdateOptions.LockWait Property
TADUpdateOptions.ReadOnly Property
TADUpdateOptions.RefreshMode Property
TADUpdateOptions.RequestLive Property
TADUpdateOptions.UpdateChangedFields Property
TADUpdateOptions.UpdateMode Property
TADUpdateOptions.UseProviderFlags Property
Interfaces
IADStanOptions Interface
public
IADStanOptions.FetchOptions Property
IADStanOptions.FormatOptions Property
IADStanOptions.ResourceOptions Property
IADStanOptions.UpdateOptions Property
IADStanOptions.GetFetchOptions Method
IADStanOptions.GetFormatOptions Method
IADStanOptions.GetParentOptions Method
IADStanOptions.GetResourceOptions Method
IADStanOptions.GetUpdateOptions Method
Records, Enums
uADStanOption.TADFetchGeneratorsPoint Enumeration
uADStanOption.TADFetchItem Enumeration
uADStanOption.TADFetchMode Enumeration
uADStanOption.TADFetchOptionValue Enumeration
uADStanOption.TADFormatOptionValue Enumeration
uADStanOption.TADLockMode Enumeration
uADStanOption.TADLockPoint Enumeration
uADStanOption.TADRecordCountMode Enumeration
uADStanOption.TADRefreshMode Enumeration
uADStanOption.TADResourceOptionValue Enumeration
uADStanOption.TADStorageFormat Enumeration
uADStanOption.TADTxAction Enumeration
uADStanOption.TADTxIsolation Enumeration
uADStanOption.TADTxStopOption Enumeration
uADStanOption.TADTxValue Enumeration
uADStanOption.TADUpdateOptionValue Enumeration
Types
uADStanOption.TADFetchItems Type
uADStanOption.TADFetchOptionValues Type
uADStanOption.TADFormatOptionValues Type
uADStanOption.TADOptionChangeEvent Type
uADStanOption.TADResourceOptionValues Type
uADStanOption.TADTxStopOptions Type
uADStanOption.TADTxValues Type
uADStanOption.TADUpdateOptionValues Type
uADStanParam Unit
Classes
TADMacro Class
public
TADMacro.AsDate Property
TADMacro.AsDateTime Property
TADMacro.AsFloat Property
TADMacro.AsIdentifier Property
TADMacro.AsInteger Property
TADMacro.AsRaw Property
TADMacro.AsString Property
TADMacro.AsTime Property
TADMacro.CollectionOwner Property
TADMacro.IsNull Property
TADMacro.SQL Property
TADMacro.Assign Method
TADMacro.Clear Method
TADMacro.Create Constructor
TADMacro.IsEqual Method
published
TADMacro.DataType Property
TADMacro.Name Property
TADMacro.Value Property
TADMacros Class
public
TADMacros.Command Property
TADMacros.IsRefCounted Property
TADMacros.Items Property
TADMacros.OnChanged Event
TADMacros.UpdateCount Property
TADMacros.Add Method
TADMacros.AddRef Method
TADMacros.Assign Method
TADMacros.AssignValues Method
TADMacros.Create Constructor
TADMacros.CreateRefCounted Constructor
TADMacros.Destroy Destructor
TADMacros.EndUpdate Method
TADMacros.FindMacro Method
TADMacros.IsEqual Method
TADMacros.MacroByName Method
TADMacros.RemRef Method
TADMacros.TempLockUpdate Method
TADParam Class
public
TADParam.AsBCD Property
TADParam.AsBCDs Property
TADParam.AsBlob Property
TADParam.AsBlobs Property
TADParam.AsBoolean Property
TADParam.AsBooleans Property
TADParam.AsByte Property
TADParam.AsBytes Property
TADParam.AsCurrency Property
TADParam.AsCurrencys Property
TADParam.AsDate Property
TADParam.AsDates Property
TADParam.AsDateTime Property
TADParam.AsDateTimes Property
TADParam.AsFixedChar Property
TADParam.AsFixedChars Property
TADParam.AsFloat Property
TADParam.AsFloats Property
TADParam.AsFMTBCD Property
TADParam.AsFMTBCDs Property
TADParam.AsGUID Property
TADParam.AsGUIDs Property
TADParam.AsInteger Property
TADParam.AsIntegers Property
TADParam.AsLargeInt Property
TADParam.AsLargeInts Property
TADParam.AsMemo Property
TADParam.AsMemos Property
TADParam.AsSmallInt Property
TADParam.AsSmallInts Property
TADParam.AsSQLTimeStamp Property
TADParam.AsSQLTimeStamps Property
TADParam.AsString Property
TADParam.AsStrings Property
TADParam.AsTime Property
TADParam.AsTimes Property
TADParam.AsVarByte Property
TADParam.AsVarBytes Property
TADParam.AsWideMemo Property
TADParam.AsWideMemos Property
TADParam.AsWideString Property
TADParam.AsWideStrings Property
TADParam.AsWord Property
TADParam.AsWords Property
TADParam.BaseParam Property
TADParam.Bound Property
TADParam.IsNull Property
TADParam.IsNulls Property
TADParam.Text Property
TADParam.Texts Property
TADParam.Values Property
TADParam.Assign Method
TADParam.AssignField Method
TADParam.AssignFieldValue Method
TADParam.AssignVarRec Method
TADParam.Clear Method
TADParam.Create Constructor (TCollection)
TADParam.Create Constructor (TParams, TParamType)
TADParam.GetBlobRawData Method
TADParam.GetData Method
TADParam.GetDataSize Method
TADParam.LoadFromFile Method
TADParam.LoadFromStream Method
TADParam.SetBlobRawData Method
TADParam.SetData Method
published
TADParam.ADDataType Property
TADParam.ArraySize Property
TADParam.ArrayType Property
TADParam.DataType Property
TADParam.IsCaseSensitive Property
TADParam.Name Property
TADParam.NumericScale Property
TADParam.ParamType Property
TADParam.Position Property
TADParam.Precision Property
TADParam.Size Property
TADParam.Value Property
TADParams Class
public
TADParams.ArraySize Property
TADParams.BindMode Property
TADParams.IsRefCounted Property
TADParams.Items Property
TADParams.ParamValues Property
TADParams.Add Method ()
TADParams.Add Method (String, TFieldType, Integer, TParamType)
TADParams.Add Method (String, Variant, TParamType)
TADParams.AddRef Method
TADParams.Assign Method
TADParams.AssignValues Method
TADParams.ClearValues Method
TADParams.Create Constructor
TADParams.CreateParam Method
TADParams.CreateRefCounted Constructor
TADParams.Destroy Destructor
TADParams.FindParam Method
TADParams.GetParamList Method
TADParams.IsEqual Method
TADParams.ParamByName Method
TADParams.Prepare Method
TADParams.RemRef Method
Functions
uADStanParam.ADVar2SQL Function
uADStanParam.ADVar2SQLTyped Function
uADStanParam.ADVarType2FieldType Function
Records, Enums
uADStanParam.TADMacroDataType Enumeration
uADStanParam.TADParamArrayType Enumeration
uADStanParam.TADParamBindMode Enumeration
Types
uADStanParam.TADGetOwner Type


Index

Index
AnyDAC Index
A | C | D | I | N | R | S | T | U | W
A
Array DML
C
Character macro functions
Command text preprocessing
Convert macro function
D
Date and time macro functions
I
IADDataSet interface
DataView
GetDataView
IADDataSet.DataView property
IADDataSet.GetDataView method
IADStanOptions interface
FetchOptions
FormatOptions
GetFetchOptions
GetFormatOptions
GetParentOptions
GetResourceOptions
GetUpdateOptions
ResourceOptions
UpdateOptions
IADStanOptions.FetchOptions property
IADStanOptions.FormatOptions property
IADStanOptions.GetFetchOptions method
IADStanOptions.GetFormatOptions method
IADStanOptions.GetParentOptions method
IADStanOptions.GetResourceOptions method
IADStanOptions.GetUpdateOptions method
IADStanOptions.ResourceOptions property
IADStanOptions.UpdateOptions property
N
Numeric macro functions
R
Retriving metadata
S
Setting options
System macro functions
T
TADAdaptedDataSet class
AbortJob
Adapter
Command
DatSManager
Disconnect
NextRecordSet
Offline
OnError
OnExecuteError
PointedConnection
ServerAppend
ServerCancel
ServerDelete
ServerDeleteAll
ServerEdit
ServerEditRequest
ServerGotoKey
ServerPerform
ServerSetKey
TADAdaptedDataSet.AbortJob method
TADAdaptedDataSet.Adapter property
TADAdaptedDataSet.Command property
TADAdaptedDataSet.DatSManager property
TADAdaptedDataSet.Disconnect method
TADAdaptedDataSet.NextRecordSet method
TADAdaptedDataSet.Offline method
TADAdaptedDataSet.OnError event
TADAdaptedDataSet.OnExecuteError event
TADAdaptedDataSet.PointedConnection property
TADAdaptedDataSet.ServerAppend method
TADAdaptedDataSet.ServerCancel method
TADAdaptedDataSet.ServerDelete method
TADAdaptedDataSet.ServerDeleteAll method
TADAdaptedDataSet.ServerEdit method
TADAdaptedDataSet.ServerEditRequest property
TADAdaptedDataSet.ServerGotoKey method
TADAdaptedDataSet.ServerPerform method
TADAdaptedDataSet.ServerSetKey method
TADAggregate class
Active
ActualActive
Assign
BeginUpdate
DataSet
DataType
Destroy
EndUpdate
Expression
GroupingLevel
IndexName
InUse
Name
Value
TADAggregate.Active property
TADAggregate.ActualActive property
TADAggregate.Assign method
TADAggregate.BeginUpdate method
TADAggregate.DataSet property
TADAggregate.DataType property
TADAggregate.Destroy destructor
TADAggregate.EndUpdate method
TADAggregate.Expression property
TADAggregate.GroupingLevel property
TADAggregate.IndexName property
TADAggregate.InUse property
TADAggregate.Name property
TADAggregate.Value property
TADAggregates class
Add
AggregateByName
Build
Create
FindAggregate
GroupingLevel
Items
Release
TADAggregates.Add method
TADAggregates.AggregateByName method
TADAggregates.Build method
TADAggregates.Create constructor
TADAggregates.FindAggregate method
TADAggregates.GroupingLevel property
TADAggregates.Items property
TADAggregates.Release method
TADAutoIncField class
AutoGenerateValue
AutoIncrementSeed
AutoIncrementStep
ClientAutoIncrement
Create
ProviderFlags
ReadOnly
ServerAutoIncrement
TADAutoIncField.AutoGenerateValue property
TADAutoIncField.AutoIncrementSeed property
TADAutoIncField.AutoIncrementStep property
TADAutoIncField.ClientAutoIncrement property
TADAutoIncField.Create constructor
TADAutoIncField.ProviderFlags property
TADAutoIncField.ReadOnly property
TADAutoIncField.ServerAutoIncrement property
TADBlobStream class
Create
Destroy
Truncate
Write
TADBlobStream.Create constructor
TADBlobStream.Destroy destructor
TADBlobStream.Truncate method
TADBlobStream.Write method
TADBottomResourceOptions class
Assign
PersistentFileName
ResolveFileName
RestoreDefaults
TADBottomResourceOptions.Assign method
TADBottomResourceOptions.PersistentFileName property
TADBottomResourceOptions.ResolveFileName method
TADBottomResourceOptions.RestoreDefaults method
TADBottomUpdateOptions class
Assign
AutoIncFields
KeyFields
RestoreDefaults
UpdateTableName
TADBottomUpdateOptions.Assign method
TADBottomUpdateOptions.AutoIncFields property
TADBottomUpdateOptions.KeyFields property
TADBottomUpdateOptions.RestoreDefaults method
TADBottomUpdateOptions.UpdateTableName property
TADColMapItem class
FColumn
FColumnIndex
FPath
TADColMapItem.FColumn field
TADColMapItem.FColumnIndex field
TADColMapItem.FPath field
TADCommand class
Active
ActiveStoredUsage
AfterClose
AfterExecute
AfterOpen
AfterPrepare
AfterUnprepare
BaseObjectName
BeforeClose
BeforeExecute
BeforeOpen
BeforePrepare
BeforeUnprepare
CatalogName
CommandKind
CommandText
Connection
ConnectionName
FetchOptions
FormatOptions
Macros
OnCommandChanged
OnError
Overload
Params
Prepared
ResourceOptions
SchemaName
Transaction
UpdateOptions
TADCommand.Active property
TADCommand.ActiveStoredUsage property
TADCommand.AfterClose event
TADCommand.AfterExecute event
TADCommand.AfterOpen event
TADCommand.AfterPrepare event
TADCommand.AfterUnprepare event
TADCommand.BaseObjectName property
TADCommand.BeforeClose event
TADCommand.BeforeExecute event
TADCommand.BeforeOpen event
TADCommand.BeforePrepare event
TADCommand.BeforeUnprepare event
TADCommand.CatalogName property
TADCommand.CommandKind property
TADCommand.CommandText property
TADCommand.Connection property
TADCommand.ConnectionName property
TADCommand.FetchOptions property
TADCommand.FormatOptions property
TADCommand.Macros property
TADCommand.OnCommandChanged event
TADCommand.OnError event
TADCommand.Overload property
TADCommand.Params property
TADCommand.Prepared property
TADCommand.ResourceOptions property
TADCommand.SchemaName property
TADCommand.Transaction property
TADCommand.UpdateOptions property
TADConnection class
AfterConnect
AfterDisconnect
BeforeConnect
BeforeDisconnect
Connected
ConnectedStoredUsage
ConnectionDefName
ConnectionName
DriverName
FetchOptions
FormatOptions
LoginDialog
LoginPrompt
OnError
OnLogin
OnLosted
OnRecover
OnRestored
Params
ResourceOptions
Transaction
TxOptions
UpdateOptions
UpdateTransaction
TADConnection.AfterConnect property
TADConnection.AfterDisconnect property
TADConnection.BeforeConnect property
TADConnection.BeforeDisconnect property
TADConnection.Connected property
TADConnection.ConnectedStoredUsage property
TADConnection.ConnectionDefName property
TADConnection.ConnectionName property
TADConnection.DriverName property
TADConnection.FetchOptions property
TADConnection.FormatOptions property
TADConnection.LoginDialog property
TADConnection.LoginPrompt property
TADConnection.OnError event
TADConnection.OnLogin event
TADConnection.OnLosted event
TADConnection.OnRecover event
TADConnection.OnRestored event
TADConnection.Params property
TADConnection.ResourceOptions property
TADConnection.Transaction property
TADConnection.TxOptions property
TADConnection.UpdateOptions property
TADConnection.UpdateTransaction property
TADCustomCommand class
AbortJob
AcquireConnection
Active
ActiveStoredUsage
AfterClose
AfterExecute
AfterFetch
AfterOpen
AfterPrepare
AfterUnprepare
BaseObjectName
BeforeClose
BeforeExecute
BeforeFetch
BeforeOpen
BeforePrepare
BeforeUnprepare
BindedBy
CatalogName
Close
CloseAll
CommandIntf
CommandKind
CommandText
Connection
ConnectionName
Define
Define
Disconnect
Execute
Execute
Execute
Execute
Fetch
FetchOptions
FillParams
FindMacro
FindParam
FixedCommandKind
FormatOptions
GetConnection
MacroByName
Macros
NextRecordSet
OnCommandChanged
OnError
Open
OpenOrExecute
Overload
ParamBindMode
ParamByName
Params
Prepare
Prepared
ReleaseConnection
ResourceOptions
RowsAffected
SchemaName
SQLText
State
Transaction
Unprepare
UpdateOptions
Values
TADCustomCommand.AbortJob method
TADCustomCommand.AcquireConnection method
TADCustomCommand.Active property
TADCustomCommand.ActiveStoredUsage property
TADCustomCommand.AfterClose event
TADCustomCommand.AfterExecute event
TADCustomCommand.AfterFetch event
TADCustomCommand.AfterOpen event
TADCustomCommand.AfterPrepare event
TADCustomCommand.AfterUnprepare event
TADCustomCommand.BaseObjectName property
TADCustomCommand.BeforeClose event
TADCustomCommand.BeforeExecute event
TADCustomCommand.BeforeFetch event
TADCustomCommand.BeforeOpen event
TADCustomCommand.BeforePrepare event
TADCustomCommand.BeforeUnprepare event
TADCustomCommand.BindedBy property
TADCustomCommand.CatalogName property
TADCustomCommand.Close method
TADCustomCommand.CloseAll method
TADCustomCommand.CommandIntf property
TADCustomCommand.CommandKind property
TADCustomCommand.CommandText property
TADCustomCommand.Connection property
TADCustomCommand.ConnectionName property
TADCustomCommand.Define method
TADCustomCommand.Disconnect method
TADCustomCommand.Execute method
TADCustomCommand.Fetch method
TADCustomCommand.FetchOptions property
TADCustomCommand.FillParams method
TADCustomCommand.FindMacro method
TADCustomCommand.FindParam method
TADCustomCommand.FixedCommandKind property
TADCustomCommand.FormatOptions property
TADCustomCommand.GetConnection method
TADCustomCommand.MacroByName method
TADCustomCommand.Macros property
TADCustomCommand.NextRecordSet method
TADCustomCommand.OnCommandChanged event
TADCustomCommand.OnError event
TADCustomCommand.Open method
TADCustomCommand.OpenOrExecute method
TADCustomCommand.Overload property
TADCustomCommand.ParamBindMode property
TADCustomCommand.ParamByName method
TADCustomCommand.Params property
TADCustomCommand.Prepare method
TADCustomCommand.Prepared property
TADCustomCommand.ReleaseConnection method
TADCustomCommand.ResourceOptions property
TADCustomCommand.RowsAffected property
TADCustomCommand.SchemaName property
TADCustomCommand.SQLText property
TADCustomCommand.State property
TADCustomCommand.Transaction property
TADCustomCommand.Unprepare method
TADCustomCommand.UpdateOptions property
TADCustomCommand.Values property
TADCustomConnection class
ApplyUpdates
CheckActive
CheckConnectionDef
CheckInactive
CheckOnline
CliHandle
CliObj
CloseClients
CommandCount
Commands
Commit
CommitRetaining
Connected
ConnectedStoredUsage
ConnectionDefName
ConnectionIntf
ConnectionName
DataSets
DecodeObjectName
DriverName
EncodeObjectName
ExecSQL
ExecSQL
ExecSQL
FetchOptions
FormatOptions
GetFieldNames
GetGeneratorNames
GetKeyFieldNames
GetLastAutoGenValue
GetPackageNames
GetStoredProcNames
GetTableNames
InTransaction
IsSQLBased
LastUsed
LoginDialog
LoginPrompt
Offline
Offlined
OnError
Online
OnLogin
OnLosted
OnRecover
OnRestored
OptionsIntf
Params
Ping
RDBMSKind
RefCount
RefreshMetadataCache
ResourceOptions
ResultConnectionDef
Rollback
RollbackRetaining
SharedCliHandle
StartTransaction
Temporary
Transaction
TxOptions
UpdateOptions
UpdateTransaction
TADCustomConnection.ApplyUpdates method
TADCustomConnection.CheckActive method
TADCustomConnection.CheckConnectionDef method
TADCustomConnection.CheckInactive method
TADCustomConnection.CheckOnline method
TADCustomConnection.CliHandle property
TADCustomConnection.CliObj property
TADCustomConnection.CloseClients method
TADCustomConnection.CommandCount property
TADCustomConnection.Commands property
TADCustomConnection.Commit method
TADCustomConnection.CommitRetaining method
TADCustomConnection.Connected property
TADCustomConnection.ConnectedStoredUsage property
TADCustomConnection.ConnectionDefName property
TADCustomConnection.ConnectionIntf property
TADCustomConnection.ConnectionName property
TADCustomConnection.DataSets property
TADCustomConnection.DecodeObjectName method
TADCustomConnection.DriverName property
TADCustomConnection.EncodeObjectName method
TADCustomConnection.ExecSQL method
TADCustomConnection.FetchOptions property
TADCustomConnection.FormatOptions property
TADCustomConnection.GetFieldNames method
TADCustomConnection.GetGeneratorNames method
TADCustomConnection.GetKeyFieldNames method
TADCustomConnection.GetLastAutoGenValue method
TADCustomConnection.GetPackageNames method
TADCustomConnection.GetStoredProcNames method
TADCustomConnection.GetTableNames method
TADCustomConnection.InTransaction property
TADCustomConnection.IsSQLBased property
TADCustomConnection.LastUsed property
TADCustomConnection.LoginDialog property
TADCustomConnection.LoginPrompt property
TADCustomConnection.Offline method
TADCustomConnection.Offlined property
TADCustomConnection.OnError event
TADCustomConnection.Online method
TADCustomConnection.OnLogin event
TADCustomConnection.OnLosted event
TADCustomConnection.OnRecover event
TADCustomConnection.OnRestored event
TADCustomConnection.OptionsIntf property
TADCustomConnection.Params property
TADCustomConnection.Ping method
TADCustomConnection.RDBMSKind property
TADCustomConnection.RefCount property
TADCustomConnection.RefreshMetadataCache method
TADCustomConnection.ResourceOptions property
TADCustomConnection.ResultConnectionDef property
TADCustomConnection.Rollback method
TADCustomConnection.RollbackRetaining method
TADCustomConnection.SharedCliHandle property
TADCustomConnection.StartTransaction method
TADCustomConnection.Temporary property
TADCustomConnection.Transaction property
TADCustomConnection.TxOptions property
TADCustomConnection.UpdateOptions property
TADCustomConnection.UpdateTransaction property
TADCustomManager class
AcquireConnection
AcquireConnection
Active
ActiveStoredUsage
AddConnectionDef
AfterLoadConnectionDefFile
AutoCreated
BeforeLoadConnectionDefFile
CanRefreshConnectionDefFile
Close
ConnectionCount
ConnectionDefFileAutoLoad
ConnectionDefFileLoaded
ConnectionDefFileName
ConnectionDefs
Connections
DeleteConnectionDef
DriverDefFileAutoLoad
DriverDefFileName
DropConnections
FetchOptions
FindConnection
FormatOptions
GetConnectionDefNames
GetConnectionDefParams
GetConnectionNames
GetDriverNames
GetFieldNames
GetGeneratorNames
GetKeyFieldNames
GetPackageNames
GetStoredProcNames
GetTableNames
IsConnectionDef
LoadConnectionDefFile
ModifyConnectionDef
OnShutdown
OnStartup
Open
RefreshConnectionDefFile
RefreshMetadataCache
ReleaseConnection
ResourceOptions
SaveConnectionDefFile
SilentMode
State
UpdateOptions
WaitCursor
TADCustomManager.AcquireConnection method
TADCustomManager.Active property
TADCustomManager.ActiveStoredUsage property
TADCustomManager.AddConnectionDef method
TADCustomManager.AfterLoadConnectionDefFile event
TADCustomManager.AutoCreated property
TADCustomManager.BeforeLoadConnectionDefFile event
TADCustomManager.CanRefreshConnectionDefFile property
TADCustomManager.Close method
TADCustomManager.ConnectionCount property
TADCustomManager.ConnectionDefFileAutoLoad property
TADCustomManager.ConnectionDefFileLoaded property
TADCustomManager.ConnectionDefFileName property
TADCustomManager.ConnectionDefs property
TADCustomManager.Connections property
TADCustomManager.DeleteConnectionDef method
TADCustomManager.DriverDefFileAutoLoad property
TADCustomManager.DriverDefFileName property
TADCustomManager.DropConnections method
TADCustomManager.FetchOptions property
TADCustomManager.FindConnection method
TADCustomManager.FormatOptions property
TADCustomManager.GetConnectionDefNames method
TADCustomManager.GetConnectionDefParams method
TADCustomManager.GetConnectionNames method
TADCustomManager.GetDriverNames method
TADCustomManager.GetFieldNames method
TADCustomManager.GetGeneratorNames method
TADCustomManager.GetKeyFieldNames method
TADCustomManager.GetPackageNames method
TADCustomManager.GetStoredProcNames method
TADCustomManager.GetTableNames method
TADCustomManager.IsConnectionDef method
TADCustomManager.LoadConnectionDefFile method
TADCustomManager.ModifyConnectionDef method
TADCustomManager.OnShutdown event
TADCustomManager.OnStartup event
TADCustomManager.Open method
TADCustomManager.RefreshConnectionDefFile method
TADCustomManager.RefreshMetadataCache method
TADCustomManager.ReleaseConnection method
TADCustomManager.ResourceOptions property
TADCustomManager.SaveConnectionDefFile method
TADCustomManager.SilentMode property
TADCustomManager.State property
TADCustomManager.UpdateOptions property
TADCustomManager.WaitCursor property
TADCustomMemTable class
Adapter
TADCustomMemTable.Adapter property
TADCustomOptions class
BeforeDestruction
Create
Owner
OwnerObj
RestoreDefaults
TADCustomOptions.BeforeDestruction method
TADCustomOptions.Create constructor
TADCustomOptions.Owner property
TADCustomOptions.OwnerObj property
TADCustomOptions.RestoreDefaults method
TADCustomQuery class
DataSource
ExecSQL
ExecSQL
ExecSQL
ExecSQL
ParamCount
SQL
Text
TADCustomQuery.DataSource property
TADCustomQuery.ExecSQL method
TADCustomQuery.ParamCount property
TADCustomQuery.SQL property
TADCustomQuery.Text property
TADCustomSchemaAdapter class
DatSManager
OnError
OnReconcileRow
OnUpdateRow
Reconcile
TableAdaptersIntf
Update
TADCustomSchemaAdapter.DatSManager property
TADCustomSchemaAdapter.OnError event
TADCustomSchemaAdapter.OnReconcileRow event
TADCustomSchemaAdapter.OnUpdateRow event
TADCustomSchemaAdapter.Reconcile method
TADCustomSchemaAdapter.TableAdaptersIntf property
TADCustomSchemaAdapter.Update method
TADCustomStoredProc class
CatalogName
DescriptionsAvailable
ExecProc
ExecProc
ExecProc
GetResults
Overload
PackageName
ParamCount
RowsAffected
SchemaName
StoredProcName
TADCustomStoredProc.CatalogName property
TADCustomStoredProc.DescriptionsAvailable method
TADCustomStoredProc.ExecProc method
TADCustomStoredProc.GetResults method
TADCustomStoredProc.Overload property
TADCustomStoredProc.PackageName property
TADCustomStoredProc.ParamCount property
TADCustomStoredProc.RowsAffected property
TADCustomStoredProc.SchemaName property
TADCustomStoredProc.StoredProcName property
TADCustomTableAdapter class
ColumnMappings
DatSManager
DatSTable
DatSTableName
Define
DeleteCommand
Fetch
Fetch
FetchRowCommand
InsertCommand
Lock
LockCommand
MetaInfoMergeMode
OnDescribeColumn
OnDescribeTable
OnError
OnReconcileRow
OnUpdateRow
Reconcile
Reset
SchemaAdapter
SelectCommand
SourceRecordSetID
SourceRecordSetName
TableAdapterIntf
UnLock
UnLockCommand
Update
Update
UpdateCommand
UpdateTableName
UpdateTransaction
TADCustomTableAdapter.ColumnMappings property
TADCustomTableAdapter.DatSManager property
TADCustomTableAdapter.DatSTable property
TADCustomTableAdapter.DatSTableName property
TADCustomTableAdapter.Define method
TADCustomTableAdapter.DeleteCommand property
TADCustomTableAdapter.Fetch method
TADCustomTableAdapter.FetchRowCommand property
TADCustomTableAdapter.InsertCommand property
TADCustomTableAdapter.Lock method
TADCustomTableAdapter.LockCommand property
TADCustomTableAdapter.MetaInfoMergeMode property
TADCustomTableAdapter.OnDescribeColumn event
TADCustomTableAdapter.OnDescribeTable event
TADCustomTableAdapter.OnError event
TADCustomTableAdapter.OnReconcileRow event
TADCustomTableAdapter.OnUpdateRow event
TADCustomTableAdapter.Reconcile method
TADCustomTableAdapter.Reset method
TADCustomTableAdapter.SchemaAdapter property
TADCustomTableAdapter.SelectCommand property
TADCustomTableAdapter.SourceRecordSetID property
TADCustomTableAdapter.SourceRecordSetName property
TADCustomTableAdapter.TableAdapterIntf property
TADCustomTableAdapter.UnLock method
TADCustomTableAdapter.UnLockCommand property
TADCustomTableAdapter.Update method
TADCustomTableAdapter.UpdateCommand property
TADCustomTableAdapter.UpdateTableName property
TADCustomTableAdapter.UpdateTransaction property
TADCustomTransaction class
Commit
CommitRetaining
Connection
DataSetCount
DataSets
IsActive
Options
Rollback
RollbackRetaining
StartTransaction
TransactionIntf
TADCustomTransaction.Commit method
TADCustomTransaction.CommitRetaining method
TADCustomTransaction.Connection property
TADCustomTransaction.DataSetCount property
TADCustomTransaction.DataSets property
TADCustomTransaction.IsActive property
TADCustomTransaction.Options property
TADCustomTransaction.Rollback method
TADCustomTransaction.RollbackRetaining method
TADCustomTransaction.StartTransaction method
TADCustomTransaction.TransactionIntf property
TADCustomUpdateObject class
Apply
DataSet
TADCustomUpdateObject.Apply method
TADCustomUpdateObject.DataSet property
TADDataMove class
AbortJob
CommitCount
Create
DeleteCount
Destination
DestinationKind
Destroy
ExceptionCount
Execute
InsertCount
LogFileAction
LogFileName
Mappings
Mode
OnError
OnFindDestRecord
OnProgress
Options
ReadCount
Source
SourceKind
StatisticsInterval
TextDataDef
TextFileName
UpdateCount
WriteCount
TADDataMove.AbortJob method
TADDataMove.CommitCount property
TADDataMove.Create constructor
TADDataMove.DeleteCount property
TADDataMove.Destination property
TADDataMove.DestinationKind property
TADDataMove.Destroy destructor
TADDataMove.ExceptionCount property
TADDataMove.Execute method
TADDataMove.InsertCount property
TADDataMove.LogFileAction property
TADDataMove.LogFileName property
TADDataMove.Mappings property
TADDataMove.Mode property
TADDataMove.OnError event
TADDataMove.OnFindDestRecord event
TADDataMove.OnProgress event
TADDataMove.Options property
TADDataMove.ReadCount property
TADDataMove.Source property
TADDataMove.SourceKind property
TADDataMove.StatisticsInterval property
TADDataMove.TextDataDef property
TADDataMove.TextFileName property
TADDataMove.UpdateCount property
TADDataMove.WriteCount property
TADDataSet class
ActiveStoredUsage
AddIndex
AfterApplyUpdates
AfterExecute
AfterGetRecords
AfterRowRequest
Aggregates
AggregatesActive
ApplyRange
ApplyUpdates
AttachTable
BeforeApplyUpdates
BeforeExecute
BeforeGetRecords
BeforeRowRequest
BeginBatch
BookmarkStrValid
BookmarkValid
CachedUpdates
Cancel
CancelRange
CancelUpdates
ChangeCount
CloneCursor
CloneSource
CommitUpdates
CompareBookmarks
Constraints
ConstraintsEnabled
CopyDataSet
CopyFields
Create
CreateBlobStream
CreateDataSet
CreateExpression
Data
DatSManager
DeleteIndex
DeleteIndexes
Delta
Destroy
DisableConstraints
Disconnect
EditKey
EditRangeEnd
EditRangeStart
EmptyDataSet
EnableConstraints
EndBatch
Execute
FetchAgain
FetchAll
FetchBlobs
FetchDetails
FilterChanges
FilteredData
FindKey
FindNearest
FindParam
GetColumnField
GetCurrentRecord
GetDetailLinkFields
GetFieldColumn
GetFieldData
GetFieldData
GetGroupState
GetIndexNames
GetNextPacket
GetParentRow
GetRow
GotoCurrent
GotoKey
GotoNearest
GroupingLevel
IndexDefs
Indexes
IndexesActive
IndexFieldCount
IndexFieldNames
IndexFields
IndexName
IsIndexed
IsLinked
IsSequenced
KeyExclusive
KeyFieldCount
LoadFromFile
LoadFromFileAtOpen
LoadFromStream
Locate
LocateEx
LocateEx
Lookup
LookupEx
LookupEx
MasterFields
MasterSource
Offline
OnReconcileError
OnUpdateError
OnUpdateRecord
OpenOrExecute
ParamByName
ParentDataSet
Post
Ranged
Reconcile
RefreshRecord
RevertRecord
SavePoint
SaveToFile
SaveToFileAtClose
SaveToStream
SetFieldAttributes
SetFieldAttributes
SetFieldAttributes
SetFieldAutoGenerateValue
SetKey
SetRange
SetRangeEnd
SetRangeStart
SourceEOF
SourceView
Table
UndoLastChange
UpdatesPending
UpdateStatus
View
TADDataSet.ActiveStoredUsage property
TADDataSet.AddIndex method
TADDataSet.AfterApplyUpdates event
TADDataSet.AfterExecute event
TADDataSet.AfterGetRecords event
TADDataSet.AfterRowRequest event
TADDataSet.Aggregates property
TADDataSet.AggregatesActive property
TADDataSet.ApplyRange method
TADDataSet.ApplyUpdates method
TADDataSet.AttachTable method
TADDataSet.BeforeApplyUpdates event
TADDataSet.BeforeExecute event
TADDataSet.BeforeGetRecords event
TADDataSet.BeforeRowRequest event
TADDataSet.BeginBatch method
TADDataSet.BookmarkStrValid method
TADDataSet.BookmarkValid method
TADDataSet.CachedUpdates property
TADDataSet.Cancel method
TADDataSet.CancelRange method
TADDataSet.CancelUpdates method
TADDataSet.ChangeCount property
TADDataSet.CloneCursor method
TADDataSet.CloneSource property
TADDataSet.CommitUpdates method
TADDataSet.CompareBookmarks method
TADDataSet.Constraints property
TADDataSet.ConstraintsEnabled property
TADDataSet.CopyDataSet method
TADDataSet.CopyFields method
TADDataSet.Create constructor
TADDataSet.CreateBlobStream method
TADDataSet.CreateDataSet method
TADDataSet.CreateExpression method
TADDataSet.Data property
TADDataSet.DatSManager property
TADDataSet.DeleteIndex method
TADDataSet.DeleteIndexes method
TADDataSet.Delta property
TADDataSet.Destroy destructor
TADDataSet.DisableConstraints method
TADDataSet.Disconnect method
TADDataSet.EditKey method
TADDataSet.EditRangeEnd method
TADDataSet.EditRangeStart method
TADDataSet.EmptyDataSet method
TADDataSet.EnableConstraints method
TADDataSet.EndBatch method
TADDataSet.Execute method
TADDataSet.FetchAgain method
TADDataSet.FetchAll method
TADDataSet.FetchBlobs method
TADDataSet.FetchDetails method
TADDataSet.FilterChanges property
TADDataSet.FilteredData property
TADDataSet.FindKey method
TADDataSet.FindNearest method
TADDataSet.FindParam method
TADDataSet.GetColumnField method
TADDataSet.GetCurrentRecord method
TADDataSet.GetDetailLinkFields method
TADDataSet.GetFieldColumn method
TADDataSet.GetFieldData method
TADDataSet.GetGroupState method
TADDataSet.GetIndexNames method
TADDataSet.GetNextPacket method
TADDataSet.GetParentRow method
TADDataSet.GetRow method
TADDataSet.GotoCurrent method
TADDataSet.GotoKey method
TADDataSet.GotoNearest method
TADDataSet.GroupingLevel property
TADDataSet.IndexDefs property
TADDataSet.Indexes property
TADDataSet.IndexesActive property
TADDataSet.IndexFieldCount property
TADDataSet.IndexFieldNames property
TADDataSet.IndexFields property
TADDataSet.IndexName property
TADDataSet.IsIndexed method
TADDataSet.IsLinked method
TADDataSet.IsSequenced method
TADDataSet.KeyExclusive property
TADDataSet.KeyFieldCount property
TADDataSet.LoadFromFile method
TADDataSet.LoadFromFileAtOpen method
TADDataSet.LoadFromStream method
TADDataSet.Locate method
TADDataSet.LocateEx method
TADDataSet.Lookup method
TADDataSet.LookupEx method
TADDataSet.MasterFields property
TADDataSet.MasterSource property
TADDataSet.Offline method
TADDataSet.OnReconcileError event
TADDataSet.OnUpdateError event
TADDataSet.OnUpdateRecord event
TADDataSet.OpenOrExecute method
TADDataSet.ParamByName method
TADDataSet.ParentDataSet property
TADDataSet.Post method
TADDataSet.Ranged property
TADDataSet.Reconcile method
TADDataSet.RefreshRecord method
TADDataSet.RevertRecord method
TADDataSet.SavePoint property
TADDataSet.SaveToFile method
TADDataSet.SaveToFileAtClose method
TADDataSet.SaveToStream method
TADDataSet.SetFieldAttributes method
TADDataSet.SetFieldAutoGenerateValue method
TADDataSet.SetKey method
TADDataSet.SetRange method
TADDataSet.SetRangeEnd method
TADDataSet.SetRangeStart method
TADDataSet.SourceEOF property
TADDataSet.SourceView property
TADDataSet.Table property
TADDataSet.UndoLastChange method
TADDataSet.UpdatesPending property
TADDataSet.UpdateStatus method
TADDataSet.View property
TADFetchOptions class
ActualRowsetSize
Assign
AssignedValues
AutoClose
Cache
IsValueOwned
Items
Mode
RecordCountMode
RecsMax
RestoreDefaults
RowsetSize
Unidirectional
TADFetchOptions.ActualRowsetSize property
TADFetchOptions.Assign method
TADFetchOptions.AssignedValues property
TADFetchOptions.AutoClose property
TADFetchOptions.Cache property
TADFetchOptions.IsValueOwned method
TADFetchOptions.Items property
TADFetchOptions.Mode property
TADFetchOptions.RecordCountMode property
TADFetchOptions.RecsMax property
TADFetchOptions.RestoreDefaults method
TADFetchOptions.RowsetSize property
TADFetchOptions.Unidirectional property
TADFormatConversionBuffer class
Check
Create
Destroy
Extend
FBuffer
FBufferSize
Ptr
Release
Size
TADFormatConversionBuffer.Check method
TADFormatConversionBuffer.Create constructor
TADFormatConversionBuffer.Destroy destructor
TADFormatConversionBuffer.Extend method
TADFormatConversionBuffer.FBuffer field
TADFormatConversionBuffer.FBufferSize field
TADFormatConversionBuffer.Ptr property
TADFormatConversionBuffer.Release method
TADFormatConversionBuffer.Size property
TADFormatOptions class
Assign
AssignedValues
CheckConversion
ColumnDef2FieldDef
ConvertRawData
Create
DefaultParamDataType
Destroy
FieldDef2ColumnDef
InlineDataSize
IsValueOwned
MapRules
MaxBcdPrecision
MaxBcdScale
MaxStringSize
OwnMapRules
ResolveDataType
ResolveFieldType
RestoreDefaults
StrsDivLen2
StrsEmpty2Null
StrsTrim
TADFormatOptions.Assign method
TADFormatOptions.AssignedValues property
TADFormatOptions.CheckConversion method
TADFormatOptions.ColumnDef2FieldDef method
TADFormatOptions.ConvertRawData method
TADFormatOptions.Create constructor
TADFormatOptions.DefaultParamDataType property
TADFormatOptions.Destroy destructor
TADFormatOptions.FieldDef2ColumnDef method
TADFormatOptions.InlineDataSize property
TADFormatOptions.IsValueOwned method
TADFormatOptions.MapRules property
TADFormatOptions.MaxBcdPrecision property
TADFormatOptions.MaxBcdScale property
TADFormatOptions.MaxStringSize property
TADFormatOptions.OwnMapRules property
TADFormatOptions.ResolveDataType method
TADFormatOptions.ResolveFieldType method
TADFormatOptions.RestoreDefaults method
TADFormatOptions.StrsDivLen2 property
TADFormatOptions.StrsEmpty2Null property
TADFormatOptions.StrsTrim property
TADIndex class
Active
ActualActive
Assign
BeginUpdate
CaseInsFields
DataSet
DescFields
Destroy
EndUpdate
Expression
Fields
Filter
FilterOptions
Name
Options
Selected
TADIndex.Active property
TADIndex.ActualActive property
TADIndex.Assign method
TADIndex.BeginUpdate method
TADIndex.CaseInsFields property
TADIndex.DataSet property
TADIndex.DescFields property
TADIndex.Destroy destructor
TADIndex.EndUpdate method
TADIndex.Expression property
TADIndex.Fields property
TADIndex.Filter property
TADIndex.FilterOptions property
TADIndex.Name property
TADIndex.Options property
TADIndex.Selected property
TADIndexes class
Add
Build
Create
FindIndex
FindIndexForFields
IndexByName
Items
Release
TADIndexes.Add method
TADIndexes.Build method
TADIndexes.Create constructor
TADIndexes.FindIndex method
TADIndexes.FindIndexForFields method
TADIndexes.IndexByName method
TADIndexes.Items property
TADIndexes.Release method
TADMacro class
AsDate
AsDateTime
AsFloat
AsIdentifier
AsInteger
AsRaw
Assign
AsString
AsTime
Clear
CollectionOwner
Create
DataType
IsEqual
IsNull
Name
SQL
Value
TADMacro.AsDate property
TADMacro.AsDateTime property
TADMacro.AsFloat property
TADMacro.AsIdentifier property
TADMacro.AsInteger property
TADMacro.AsRaw property
TADMacro.Assign method
TADMacro.AsString property
TADMacro.AsTime property
TADMacro.Clear method
TADMacro.CollectionOwner property
TADMacro.Create constructor
TADMacro.DataType property
TADMacro.IsEqual method
TADMacro.IsNull property
TADMacro.Name property
TADMacro.SQL property
TADMacro.Value property
TADMacros class
Add
AddRef
Assign
AssignValues
Command
Create
CreateRefCounted
Destroy
EndUpdate
FindMacro
IsEqual
IsRefCounted
Items
MacroByName
OnChanged
RemRef
TempLockUpdate
UpdateCount
TADMacros.Add method
TADMacros.AddRef method
TADMacros.Assign method
TADMacros.AssignValues method
TADMacros.Command property
TADMacros.Create constructor
TADMacros.CreateRefCounted constructor
TADMacros.Destroy destructor
TADMacros.EndUpdate method
TADMacros.FindMacro method
TADMacros.IsEqual method
TADMacros.IsRefCounted property
TADMacros.Items property
TADMacros.MacroByName method
TADMacros.OnChanged event
TADMacros.RemRef method
TADMacros.TempLockUpdate method
TADMacros.UpdateCount property
TADManager class
Active
ActiveStoredUsage
AfterLoadConnectionDefFile
BeforeLoadConnectionDefFile
ConnectionDefFileAutoLoad
ConnectionDefFileName
DriverDefFileAutoLoad
DriverDefFileName
FetchOptions
FormatOptions
OnShutdown
OnStartup
ResourceOptions
SilentMode
UpdateOptions
WaitCursor
TADManager.Active property
TADManager.ActiveStoredUsage property
TADManager.AfterLoadConnectionDefFile event
TADManager.BeforeLoadConnectionDefFile event
TADManager.ConnectionDefFileAutoLoad property
TADManager.ConnectionDefFileName property
TADManager.DriverDefFileAutoLoad property
TADManager.DriverDefFileName property
TADManager.FetchOptions property
TADManager.FormatOptions property
TADManager.OnShutdown event
TADManager.OnStartup event
TADManager.ResourceOptions property
TADManager.SilentMode property
TADManager.UpdateOptions property
TADManager.WaitCursor property
TADMappingItem class
Assign
AsText
DestField
DestinationFieldName
Destroy
DestTextField
DestValue
InKey
ItemValue
Move
Prepare
SourceEvaluator
SourceExpression
SourceField
SourceFieldName
SourceTextField
SourceValue
Unprepare
TADMappingItem.Assign method
TADMappingItem.AsText property
TADMappingItem.DestField property
TADMappingItem.DestinationFieldName property
TADMappingItem.Destroy destructor
TADMappingItem.DestTextField property
TADMappingItem.DestValue property
TADMappingItem.InKey property
TADMappingItem.ItemValue property
TADMappingItem.Move method
TADMappingItem.Prepare method
TADMappingItem.SourceEvaluator property
TADMappingItem.SourceExpression property
TADMappingItem.SourceField property
TADMappingItem.SourceFieldName property
TADMappingItem.SourceTextField property
TADMappingItem.SourceValue property
TADMappingItem.Unprepare method
TADMappings class
Add
Add
AddAll
Assign
Create
DataMove
IndexOfName
Items
Move
Prepare
Unprepare
TADMappings.Add method
TADMappings.AddAll method
TADMappings.Assign method
TADMappings.Create constructor
TADMappings.DataMove property
TADMappings.IndexOfName method
TADMappings.Items property
TADMappings.Move method
TADMappings.Prepare method
TADMappings.Unprepare method
TADMapRule class
Assign
Create
PrecMax
PrecMin
ScaleMax
ScaleMin
SizeMax
SizeMin
SourceDataType
TargetDataType
TADMapRule.Assign method
TADMapRule.Create constructor
TADMapRule.PrecMax property
TADMapRule.PrecMin property
TADMapRule.ScaleMax property
TADMapRule.ScaleMin property
TADMapRule.SizeMax property
TADMapRule.SizeMin property
TADMapRule.SourceDataType property
TADMapRule.TargetDataType property
TADMapRules class
Add
Create
Items
TADMapRules.Add method
TADMapRules.Create constructor
TADMapRules.Items property
TADMasterDataLink class
OnMasterFieldsDefined
TADMasterDataLink.OnMasterFieldsDefined event
TADMemTable class
Active
ActiveStoredUsage
Adapter
AfterApplyUpdates
AfterCancel
AfterClose
AfterDelete
AfterEdit
AfterExecute
AfterGetRecords
AfterInsert
AfterOpen
AfterPost
AfterRefresh
AfterRowRequest
AfterScroll
Aggregates
AggregatesActive
AutoCalcFields
BeforeApplyUpdates
BeforeCancel
BeforeClose
BeforeDelete
BeforeEdit
BeforeExecute
BeforeGetRecords
BeforeInsert
BeforeOpen
BeforePost
BeforeRefresh
BeforeRowRequest
BeforeScroll
CachedUpdates
Constraints
ConstraintsEnabled
DataSetField
FetchOptions
FieldDefs
Filter
FilterChanges
Filtered
FilterOptions
FormatOptions
IndexDefs
Indexes
IndexesActive
IndexFieldNames
IndexName
MasterFields
MasterSource
ObjectView
OnCalcFields
OnDeleteError
OnEditError
OnFilterRecord
OnNewRecord
OnPostError
OnReconcileError
OnUpdateError
OnUpdateRecord
ResourceOptions
StoreDefs
UpdateOptions
TADMemTable.Active property
TADMemTable.ActiveStoredUsage property
TADMemTable.Adapter property
TADMemTable.AfterApplyUpdates event
TADMemTable.AfterCancel property
TADMemTable.AfterClose property
TADMemTable.AfterDelete property
TADMemTable.AfterEdit property
TADMemTable.AfterExecute event
TADMemTable.AfterGetRecords event
TADMemTable.AfterInsert property
TADMemTable.AfterOpen property
TADMemTable.AfterPost property
TADMemTable.AfterRefresh property
TADMemTable.AfterRowRequest event
TADMemTable.AfterScroll property
TADMemTable.Aggregates property
TADMemTable.AggregatesActive property
TADMemTable.AutoCalcFields property
TADMemTable.BeforeApplyUpdates event
TADMemTable.BeforeCancel property
TADMemTable.BeforeClose property
TADMemTable.BeforeDelete property
TADMemTable.BeforeEdit property
TADMemTable.BeforeExecute event
TADMemTable.BeforeGetRecords event
TADMemTable.BeforeInsert property
TADMemTable.BeforeOpen property
TADMemTable.BeforePost property
TADMemTable.BeforeRefresh property
TADMemTable.BeforeRowRequest event
TADMemTable.BeforeScroll property
TADMemTable.CachedUpdates property
TADMemTable.Constraints property
TADMemTable.ConstraintsEnabled property
TADMemTable.DataSetField property
TADMemTable.FetchOptions property
TADMemTable.FieldDefs property
TADMemTable.Filter property
TADMemTable.FilterChanges property
TADMemTable.Filtered property
TADMemTable.FilterOptions property
TADMemTable.FormatOptions property
TADMemTable.IndexDefs property
TADMemTable.Indexes property
TADMemTable.IndexesActive property
TADMemTable.IndexFieldNames property
TADMemTable.IndexName property
TADMemTable.MasterFields property
TADMemTable.MasterSource property
TADMemTable.ObjectView property
TADMemTable.OnCalcFields property
TADMemTable.OnDeleteError property
TADMemTable.OnEditError property
TADMemTable.OnFilterRecord property
TADMemTable.OnNewRecord property
TADMemTable.OnPostError property
TADMemTable.OnReconcileError event
TADMemTable.OnUpdateError event
TADMemTable.OnUpdateRecord event
TADMemTable.ResourceOptions property
TADMemTable.StoreDefs property
TADMemTable.UpdateOptions property
TADMetaInfoCommand class
Active
AfterClose
AfterOpen
BaseObjectName
BeforeClose
BeforeOpen
CatalogName
Connection
ConnectionName
Create
FormatOptions
MetaInfoKind
ObjectName
ObjectScopes
OnCommandChanged
OnError
Overload
SchemaName
TableKinds
Wildcard
TADMetaInfoCommand.Active property
TADMetaInfoCommand.AfterClose event
TADMetaInfoCommand.AfterOpen event
TADMetaInfoCommand.BaseObjectName property
TADMetaInfoCommand.BeforeClose event
TADMetaInfoCommand.BeforeOpen event
TADMetaInfoCommand.CatalogName property
TADMetaInfoCommand.Connection property
TADMetaInfoCommand.ConnectionName property
TADMetaInfoCommand.Create constructor
TADMetaInfoCommand.FormatOptions property
TADMetaInfoCommand.MetaInfoKind property
TADMetaInfoCommand.ObjectName property
TADMetaInfoCommand.ObjectScopes property
TADMetaInfoCommand.OnCommandChanged event
TADMetaInfoCommand.OnError event
TADMetaInfoCommand.Overload property
TADMetaInfoCommand.SchemaName property
TADMetaInfoCommand.TableKinds property
TADMetaInfoCommand.Wildcard property
TADMetaInfoQuery class
Active
ActiveStoredUsage
AfterClose
AfterGetRecords
AfterOpen
AfterRefresh
AfterRowRequest
AfterScroll
Aggregates
AggregatesActive
AutoCalcFields
BaseObjectName
BeforeClose
BeforeGetRecords
BeforeOpen
BeforeRefresh
BeforeRowRequest
BeforeScroll
CatalogName
Connection
ConnectionName
FetchOptions
Filter
Filtered
FilterOptions
FormatOptions
Indexes
IndexesActive
IndexFieldNames
IndexName
MetaInfoKind
ObjectName
ObjectScopes
OnCalcFields
OnCommandChanged
OnError
OnFilterRecord
Overload
SchemaName
TableKinds
Transaction
UpdateTransaction
Wildcard
TADMetaInfoQuery.Active property
TADMetaInfoQuery.ActiveStoredUsage property
TADMetaInfoQuery.AfterClose property
TADMetaInfoQuery.AfterGetRecords event
TADMetaInfoQuery.AfterOpen property
TADMetaInfoQuery.AfterRefresh property
TADMetaInfoQuery.AfterRowRequest event
TADMetaInfoQuery.AfterScroll property
TADMetaInfoQuery.Aggregates property
TADMetaInfoQuery.AggregatesActive property
TADMetaInfoQuery.AutoCalcFields property
TADMetaInfoQuery.BaseObjectName property
TADMetaInfoQuery.BeforeClose property
TADMetaInfoQuery.BeforeGetRecords event
TADMetaInfoQuery.BeforeOpen property
TADMetaInfoQuery.BeforeRefresh property
TADMetaInfoQuery.BeforeRowRequest event
TADMetaInfoQuery.BeforeScroll property
TADMetaInfoQuery.CatalogName property
TADMetaInfoQuery.Connection property
TADMetaInfoQuery.ConnectionName property
TADMetaInfoQuery.FetchOptions property
TADMetaInfoQuery.Filter property
TADMetaInfoQuery.Filtered property
TADMetaInfoQuery.FilterOptions property
TADMetaInfoQuery.FormatOptions property
TADMetaInfoQuery.Indexes property
TADMetaInfoQuery.IndexesActive property
TADMetaInfoQuery.IndexFieldNames property
TADMetaInfoQuery.IndexName property
TADMetaInfoQuery.MetaInfoKind property
TADMetaInfoQuery.ObjectName property
TADMetaInfoQuery.ObjectScopes property
TADMetaInfoQuery.OnCalcFields property
TADMetaInfoQuery.OnCommandChanged event
TADMetaInfoQuery.OnError event
TADMetaInfoQuery.OnFilterRecord property
TADMetaInfoQuery.Overload property
TADMetaInfoQuery.SchemaName property
TADMetaInfoQuery.TableKinds property
TADMetaInfoQuery.Transaction property
TADMetaInfoQuery.UpdateTransaction property
TADMetaInfoQuery.Wildcard property
TADParam class
ADDataType
ArraySize
ArrayType
AsBCD
AsBCDs
AsBlob
AsBlobs
AsBoolean
AsBooleans
AsByte
AsBytes
AsCurrency
AsCurrencys
AsDate
AsDates
AsDateTime
AsDateTimes
AsFixedChar
AsFixedChars
AsFloat
AsFloats
AsFMTBCD
AsFMTBCDs
AsGUID
AsGUIDs
AsInteger
AsIntegers
AsLargeInt
AsLargeInts
AsMemo
AsMemos
Assign
AssignField
AssignFieldValue
AssignVarRec
AsSmallInt
AsSmallInts
AsSQLTimeStamp
AsSQLTimeStamps
AsString
AsStrings
AsTime
AsTimes
AsVarByte
AsVarBytes
AsWideMemo
AsWideMemos
AsWideString
AsWideStrings
AsWord
AsWords
BaseParam
Bound
Clear
Create
Create
DataType
GetBlobRawData
GetData
GetDataSize
IsCaseSensitive
IsNull
IsNulls
LoadFromFile
LoadFromStream
Name
NumericScale
ParamType
Position
Precision
SetBlobRawData
SetData
Size
Text
Texts
Value
Values
TADParam.ADDataType property
TADParam.ArraySize property
TADParam.ArrayType property
TADParam.AsBCD property
TADParam.AsBCDs property
TADParam.AsBlob property
TADParam.AsBlobs property
TADParam.AsBoolean property
TADParam.AsBooleans property
TADParam.AsByte property
TADParam.AsBytes property
TADParam.AsCurrency property
TADParam.AsCurrencys property
TADParam.AsDate property
TADParam.AsDates property
TADParam.AsDateTime property
TADParam.AsDateTimes property
TADParam.AsFixedChar property
TADParam.AsFixedChars property
TADParam.AsFloat property
TADParam.AsFloats property
TADParam.AsFMTBCD property
TADParam.AsFMTBCDs property
TADParam.AsGUID property
TADParam.AsGUIDs property
TADParam.AsInteger property
TADParam.AsIntegers property
TADParam.AsLargeInt property
TADParam.AsLargeInts property
TADParam.AsMemo property
TADParam.AsMemos property
TADParam.Assign method
TADParam.AssignField method
TADParam.AssignFieldValue method
TADParam.AssignVarRec method
TADParam.AsSmallInt property
TADParam.AsSmallInts property
TADParam.AsSQLTimeStamp property
TADParam.AsSQLTimeStamps property
TADParam.AsString property
TADParam.AsStrings property
TADParam.AsTime property
TADParam.AsTimes property
TADParam.AsVarByte property
TADParam.AsVarBytes property
TADParam.AsWideMemo property
TADParam.AsWideMemos property
TADParam.AsWideString property
TADParam.AsWideStrings property
TADParam.AsWord property
TADParam.AsWords property
TADParam.BaseParam property
TADParam.Bound property
TADParam.Clear method
TADParam.Create constructor
TADParam.DataType property
TADParam.GetBlobRawData method
TADParam.GetData method
TADParam.GetDataSize method
TADParam.IsCaseSensitive property
TADParam.IsNull property
TADParam.IsNulls property
TADParam.LoadFromFile method
TADParam.LoadFromStream method
TADParam.Name property
TADParam.NumericScale property
TADParam.ParamType property
TADParam.Position property
TADParam.Precision property
TADParam.SetBlobRawData method
TADParam.SetData method
TADParam.Size property
TADParam.Text property
TADParam.Texts property
TADParam.Value property
TADParam.Values property
TADParams class
Add
Add
Add
AddRef
ArraySize
Assign
AssignValues
BindMode
ClearValues
Create
CreateParam
CreateRefCounted
Destroy
FindParam
GetParamList
IsEqual
IsRefCounted
Items
ParamByName
ParamValues
Prepare
RemRef
TADParams.Add method
TADParams.AddRef method
TADParams.ArraySize property
TADParams.Assign method
TADParams.AssignValues method
TADParams.BindMode property
TADParams.ClearValues method
TADParams.Create constructor
TADParams.CreateParam method
TADParams.CreateRefCounted constructor
TADParams.Destroy destructor
TADParams.FindParam method
TADParams.GetParamList method
TADParams.IsEqual method
TADParams.IsRefCounted property
TADParams.Items property
TADParams.ParamByName method
TADParams.ParamValues property
TADParams.Prepare method
TADParams.RemRef method
TADQuery class
Active
ActiveStoredUsage
AfterApplyUpdates
AfterCancel
AfterClose
AfterDelete
AfterEdit
AfterExecute
AfterGetRecords
AfterInsert
AfterOpen
AfterPost
AfterRefresh
AfterRowRequest
AfterScroll
Aggregates
AggregatesActive
AutoCalcFields
BeforeApplyUpdates
BeforeCancel
BeforeClose
BeforeDelete
BeforeEdit
BeforeExecute
BeforeGetRecords
BeforeInsert
BeforeOpen
BeforePost
BeforeRefresh
BeforeRowRequest
BeforeScroll
CachedUpdates
Connection
ConnectionName
Constraints
ConstraintsEnabled
DataSource
FetchOptions
Filter
FilterChanges
Filtered
FilterOptions
FormatOptions
Indexes
IndexesActive
IndexFieldNames
IndexName
MacroCount
Macros
ObjectView
OnCalcFields
OnCommandChanged
OnDeleteError
OnEditError
OnError
OnExecuteError
OnFilterRecord
OnNewRecord
OnPostError
OnReconcileError
OnUpdateError
OnUpdateRecord
Params
Prepared
ResourceOptions
RowsAffected
SQL
Transaction
UpdateObject
UpdateOptions
UpdateTransaction
TADQuery.Active property
TADQuery.ActiveStoredUsage property
TADQuery.AfterApplyUpdates event
TADQuery.AfterCancel property
TADQuery.AfterClose property
TADQuery.AfterDelete property
TADQuery.AfterEdit property
TADQuery.AfterExecute event
TADQuery.AfterGetRecords event
TADQuery.AfterInsert property
TADQuery.AfterOpen property
TADQuery.AfterPost property
TADQuery.AfterRefresh property
TADQuery.AfterRowRequest event
TADQuery.AfterScroll property
TADQuery.Aggregates property
TADQuery.AggregatesActive property
TADQuery.AutoCalcFields property
TADQuery.BeforeApplyUpdates event
TADQuery.BeforeCancel property
TADQuery.BeforeClose property
TADQuery.BeforeDelete property
TADQuery.BeforeEdit property
TADQuery.BeforeExecute event
TADQuery.BeforeGetRecords event
TADQuery.BeforeInsert property
TADQuery.BeforeOpen property
TADQuery.BeforePost property
TADQuery.BeforeRefresh property
TADQuery.BeforeRowRequest event
TADQuery.BeforeScroll property
TADQuery.CachedUpdates property
TADQuery.Connection property
TADQuery.ConnectionName property
TADQuery.Constraints property
TADQuery.ConstraintsEnabled property
TADQuery.DataSource property
TADQuery.FetchOptions property
TADQuery.Filter property
TADQuery.FilterChanges property
TADQuery.Filtered property
TADQuery.FilterOptions property
TADQuery.FormatOptions property
TADQuery.Indexes property
TADQuery.IndexesActive property
TADQuery.IndexFieldNames property
TADQuery.IndexName property
TADQuery.MacroCount property
TADQuery.Macros property
TADQuery.ObjectView property
TADQuery.OnCalcFields property
TADQuery.OnCommandChanged event
TADQuery.OnDeleteError property
TADQuery.OnEditError property
TADQuery.OnError event
TADQuery.OnExecuteError event
TADQuery.OnFilterRecord property
TADQuery.OnNewRecord property
TADQuery.OnPostError property
TADQuery.OnReconcileError event
TADQuery.OnUpdateError event
TADQuery.OnUpdateRecord event
TADQuery.Params property
TADQuery.Prepared property
TADQuery.ResourceOptions property
TADQuery.RowsAffected property
TADQuery.SQL property
TADQuery.Transaction property
TADQuery.UpdateObject property
TADQuery.UpdateOptions property
TADQuery.UpdateTransaction property
TADRdbmsDataSet class
Connection
ConnectionName
Create
Destroy
Disconnect
FindMacro
MacroByName
OnCommandChanged
OnError
Open
Open
Open
Open
Prepare
Transaction
Unprepare
UpdateTransaction
TADRdbmsDataSet.Connection property
TADRdbmsDataSet.ConnectionName property
TADRdbmsDataSet.Create constructor
TADRdbmsDataSet.Destroy destructor
TADRdbmsDataSet.Disconnect method
TADRdbmsDataSet.FindMacro method
TADRdbmsDataSet.MacroByName method
TADRdbmsDataSet.OnCommandChanged event
TADRdbmsDataSet.OnError event
TADRdbmsDataSet.Open method
TADRdbmsDataSet.Prepare method
TADRdbmsDataSet.Transaction property
TADRdbmsDataSet.Unprepare method
TADRdbmsDataSet.UpdateTransaction property
TADResourceOptions class
ActualSilentMode
ArrayDMLSize
Assign
AssignedValues
AutoManage
Backup
BackupExt
BackupFolder
CmdExecMode
CmdExecTimeout
DefaultParamType
DefaultStoreExt
DefaultStoreFolder
DefaultStoreFormat
DirectExecute
EscapeExpand
IsValueOwned
MacroCreate
MacroExpand
ParamCreate
ParamExpand
Persistent
PreprocessCmdText
RestoreDefaults
SilentMode
TADResourceOptions.ActualSilentMode property
TADResourceOptions.ArrayDMLSize property
TADResourceOptions.Assign method
TADResourceOptions.AssignedValues property
TADResourceOptions.AutoManage property
TADResourceOptions.Backup property
TADResourceOptions.BackupExt property
TADResourceOptions.BackupFolder property
TADResourceOptions.CmdExecMode property
TADResourceOptions.CmdExecTimeout property
TADResourceOptions.DefaultParamType property
TADResourceOptions.DefaultStoreExt property
TADResourceOptions.DefaultStoreFolder property
TADResourceOptions.DefaultStoreFormat property
TADResourceOptions.DirectExecute property
TADResourceOptions.EscapeExpand property
TADResourceOptions.IsValueOwned method
TADResourceOptions.MacroCreate property
TADResourceOptions.MacroExpand property
TADResourceOptions.ParamCreate property
TADResourceOptions.ParamExpand property
TADResourceOptions.Persistent property
TADResourceOptions.PreprocessCmdText property
TADResourceOptions.RestoreDefaults method
TADResourceOptions.SilentMode property
TADSchemaAdapter class
OnError
OnReconcileRow
OnUpdateRow
TADSchemaAdapter.OnError event
TADSchemaAdapter.OnReconcileRow event
TADSchemaAdapter.OnUpdateRow event
TADScript class
AbortJob
AfterExecute
AfterScript
AllSpools
Arguments
BeforeExecute
BeforeScript
CallStack
CheckCommand
CloseConnection
CloseSpool
CommandIntf
ConGet
ConLockUpdate
Connection
ConnectionIntf
ConPut
ConUnlockUpdate
Create
CurrentCommand
DefaultDriverName
Destroy
EOF
ExecuteAll
ExecuteAll
ExecuteHostCommand
ExecuteStep
ExecuteStep
ExpandString
FetchOptions
Finished
FormatOptions
GetStream
LastSpoolFileName
Macros
OnConsoleGet
OnConsoleLockUpdate
OnConsolePut
OnError
OnGetStream
OnHostCommand
OnPause
OnProgress
OnReleaseStream
OnSpoolPut
OpenConnection
Params
Position
ProcessedAfterCommit
Progress
RDBMSKind
ReleaseStream
ResourceOptions
ScriptDialog
ScriptOptions
SQLScriptFileName
SQLScripts
Status
Table
TotalErrors
TotalJobDone
TotalJobSize
TotalPct10Done
UpdateCommandSeparator
UpdateSpool
ValidateAll
ValidateAll
ValidateStep
ValidateStep
TADScript.AbortJob method
TADScript.AfterExecute event
TADScript.AfterScript event
TADScript.AllSpools property
TADScript.Arguments property
TADScript.BeforeExecute event
TADScript.BeforeScript event
TADScript.CallStack property
TADScript.CheckCommand method
TADScript.CloseConnection method
TADScript.CloseSpool method
TADScript.CommandIntf property
TADScript.ConGet method
TADScript.ConLockUpdate method
TADScript.Connection property
TADScript.ConnectionIntf property
TADScript.ConPut method
TADScript.ConUnlockUpdate method
TADScript.Create constructor
TADScript.CurrentCommand property
TADScript.DefaultDriverName property
TADScript.Destroy destructor
TADScript.EOF property
TADScript.ExecuteAll method
TADScript.ExecuteHostCommand method
TADScript.ExecuteStep method
TADScript.ExpandString method
TADScript.FetchOptions property
TADScript.Finished property
TADScript.FormatOptions property
TADScript.GetStream method
TADScript.LastSpoolFileName property
TADScript.Macros property
TADScript.OnConsoleGet event
TADScript.OnConsoleLockUpdate event
TADScript.OnConsolePut event
TADScript.OnError event
TADScript.OnGetStream event
TADScript.OnHostCommand event
TADScript.OnPause event
TADScript.OnProgress event
TADScript.OnReleaseStream event
TADScript.OnSpoolPut event
TADScript.OpenConnection method
TADScript.Params property
TADScript.Position property
TADScript.ProcessedAfterCommit property
TADScript.Progress method
TADScript.RDBMSKind property
TADScript.ReleaseStream method
TADScript.ResourceOptions property
TADScript.ScriptDialog property
TADScript.ScriptOptions property
TADScript.SQLScriptFileName property
TADScript.SQLScripts property
TADScript.Status property
TADScript.Table property
TADScript.TotalErrors property
TADScript.TotalJobDone property
TADScript.TotalJobSize property
TADScript.TotalPct10Done property
TADScript.UpdateCommandSeparator method
TADScript.UpdateSpool method
TADScript.ValidateAll method
TADScript.ValidateStep method
TADScriptCommand class
AbortJob
Create
Destroy
Engine
Execute
Help
Keywords
Parse
Parser
Position
Validate
TADScriptCommand.AbortJob method
TADScriptCommand.Create constructor
TADScriptCommand.Destroy destructor
TADScriptCommand.Engine property
TADScriptCommand.Execute method
TADScriptCommand.Help method
TADScriptCommand.Keywords method
TADScriptCommand.Parse method
TADScriptCommand.Parser property
TADScriptCommand.Position property
TADScriptCommand.Validate method
TADScriptCommandRegistry class
AddCommand
Create
DefaultPLSQLCommandClass
DefaultSQLCommandClass
Destroy
Help
LookupCommand
TADScriptCommandRegistry.AddCommand method
TADScriptCommandRegistry.Create constructor
TADScriptCommandRegistry.DefaultPLSQLCommandClass property
TADScriptCommandRegistry.DefaultSQLCommandClass property
TADScriptCommandRegistry.Destroy destructor
TADScriptCommandRegistry.Help method
TADScriptCommandRegistry.LookupCommand method
TADScriptOptions class
ActualCommandSeparator
Assign
AutoPrintParams
BreakOnError
ColumnHeadings
CommandSeparator
CommitEachNCommands
ConsoleOutput
Create
DefaultDataPath
DefaultScriptPath
DropNonexistObj
EchoCommands
EchoCommandTrim
FeedbackCommands
FeedbackScript
LineSize
MacroExpand
MaxBytesToPrintLongs
PageSize
ParamArraySize
SpoolFileName
SpoolOutput
Timing
TrimConsole
TrimSpool
Verify
TADScriptOptions.ActualCommandSeparator property
TADScriptOptions.Assign method
TADScriptOptions.AutoPrintParams property
TADScriptOptions.BreakOnError property
TADScriptOptions.ColumnHeadings property
TADScriptOptions.CommandSeparator property
TADScriptOptions.CommitEachNCommands property
TADScriptOptions.ConsoleOutput property
TADScriptOptions.Create constructor
TADScriptOptions.DefaultDataPath property
TADScriptOptions.DefaultScriptPath property
TADScriptOptions.DropNonexistObj property
TADScriptOptions.EchoCommands property
TADScriptOptions.EchoCommandTrim property
TADScriptOptions.FeedbackCommands property
TADScriptOptions.FeedbackScript property
TADScriptOptions.LineSize property
TADScriptOptions.MacroExpand property
TADScriptOptions.MaxBytesToPrintLongs property
TADScriptOptions.PageSize property
TADScriptOptions.ParamArraySize property
TADScriptOptions.SpoolFileName property
TADScriptOptions.SpoolOutput property
TADScriptOptions.Timing property
TADScriptOptions.TrimConsole property
TADScriptOptions.TrimSpool property
TADScriptOptions.Verify property
TADScriptParser class
Ch
Create
ExtractCommand
ExtractString
FileName
GetBookmark
GetChar
GetIdentifier
GetLine
GetNumber
GetOnOfChar
GetOnOff
GetString
GetStringInFull
GetUCWord
InvalidSyntax
LineNumber
ParentCommand
Position
ScriptOptions
SetBookmark
SkipWS
SkipWSLF
TotalSize
UnGetChar
WasBeginningOfLine
TADScriptParser.Ch property
TADScriptParser.Create constructor
TADScriptParser.ExtractCommand method
TADScriptParser.ExtractString method
TADScriptParser.FileName property
TADScriptParser.GetBookmark method
TADScriptParser.GetChar method
TADScriptParser.GetIdentifier method
TADScriptParser.GetLine method
TADScriptParser.GetNumber method
TADScriptParser.GetOnOfChar method
TADScriptParser.GetOnOff method
TADScriptParser.GetString method
TADScriptParser.GetStringInFull method
TADScriptParser.GetUCWord method
TADScriptParser.InvalidSyntax method
TADScriptParser.LineNumber property
TADScriptParser.ParentCommand property
TADScriptParser.Position property
TADScriptParser.ScriptOptions property
TADScriptParser.SetBookmark method
TADScriptParser.SkipWS method
TADScriptParser.SkipWSLF method
TADScriptParser.TotalSize property
TADScriptParser.UnGetChar method
TADScriptParser.WasBeginningOfLine property
TADSQLScript class
Assign
Create
Destroy
Name
SQL
TADSQLScript.Assign method
TADSQLScript.Create constructor
TADSQLScript.Destroy destructor
TADSQLScript.Name property
TADSQLScript.SQL property
TADSQLScripts class
Add
Create
FindScript
Items
TADSQLScripts.Add method
TADSQLScripts.Create constructor
TADSQLScripts.FindScript method
TADSQLScripts.Items property
TADStoredProc class
Active
ActiveStoredUsage
AfterApplyUpdates
AfterCancel
AfterClose
AfterDelete
AfterEdit
AfterExecute
AfterGetRecords
AfterInsert
AfterOpen
AfterPost
AfterRefresh
AfterRowRequest
AfterScroll
Aggregates
AggregatesActive
AutoCalcFields
BeforeApplyUpdates
BeforeCancel
BeforeClose
BeforeDelete
BeforeEdit
BeforeExecute
BeforeGetRecords
BeforeInsert
BeforeOpen
BeforePost
BeforeRefresh
BeforeRowRequest
BeforeScroll
CachedUpdates
CatalogName
Connection
ConnectionName
Constraints
ConstraintsEnabled
FetchOptions
Filter
FilterChanges
Filtered
FilterOptions
FormatOptions
Indexes
IndexesActive
IndexFieldNames
IndexName
ObjectView
OnCalcFields
OnCommandChanged
OnDeleteError
OnEditError
OnError
OnExecuteError
OnFilterRecord
OnNewRecord
OnPostError
OnReconcileError
OnUpdateError
OnUpdateRecord
Overload
PackageName
ParamBindMode
Params
Prepared
ResourceOptions
SchemaName
StoredProcName
Transaction
UpdateObject
UpdateOptions
UpdateTransaction
TADStoredProc.Active property
TADStoredProc.ActiveStoredUsage property
TADStoredProc.AfterApplyUpdates event
TADStoredProc.AfterCancel property
TADStoredProc.AfterClose property
TADStoredProc.AfterDelete property
TADStoredProc.AfterEdit property
TADStoredProc.AfterExecute event
TADStoredProc.AfterGetRecords event
TADStoredProc.AfterInsert property
TADStoredProc.AfterOpen property
TADStoredProc.AfterPost property
TADStoredProc.AfterRefresh property
TADStoredProc.AfterRowRequest event
TADStoredProc.AfterScroll property
TADStoredProc.Aggregates property
TADStoredProc.AggregatesActive property
TADStoredProc.AutoCalcFields property
TADStoredProc.BeforeApplyUpdates event
TADStoredProc.BeforeCancel property
TADStoredProc.BeforeClose property
TADStoredProc.BeforeDelete property
TADStoredProc.BeforeEdit property
TADStoredProc.BeforeExecute event
TADStoredProc.BeforeGetRecords event
TADStoredProc.BeforeInsert property
TADStoredProc.BeforeOpen property
TADStoredProc.BeforePost property
TADStoredProc.BeforeRefresh property
TADStoredProc.BeforeRowRequest event
TADStoredProc.BeforeScroll property
TADStoredProc.CachedUpdates property
TADStoredProc.CatalogName property
TADStoredProc.Connection property
TADStoredProc.ConnectionName property
TADStoredProc.Constraints property
TADStoredProc.ConstraintsEnabled property
TADStoredProc.FetchOptions property
TADStoredProc.Filter property
TADStoredProc.FilterChanges property
TADStoredProc.Filtered property
TADStoredProc.FilterOptions property
TADStoredProc.FormatOptions property
TADStoredProc.Indexes property
TADStoredProc.IndexesActive property
TADStoredProc.IndexFieldNames property
TADStoredProc.IndexName property
TADStoredProc.ObjectView property
TADStoredProc.OnCalcFields property
TADStoredProc.OnCommandChanged event
TADStoredProc.OnDeleteError property
TADStoredProc.OnEditError property
TADStoredProc.OnError event
TADStoredProc.OnExecuteError event
TADStoredProc.OnFilterRecord property
TADStoredProc.OnNewRecord property
TADStoredProc.OnPostError property
TADStoredProc.OnReconcileError event
TADStoredProc.OnUpdateError event
TADStoredProc.OnUpdateRecord event
TADStoredProc.Overload property
TADStoredProc.PackageName property
TADStoredProc.ParamBindMode property
TADStoredProc.Params property
TADStoredProc.Prepared property
TADStoredProc.ResourceOptions property
TADStoredProc.SchemaName property
TADStoredProc.StoredProcName property
TADStoredProc.Transaction property
TADStoredProc.UpdateObject property
TADStoredProc.UpdateOptions property
TADStoredProc.UpdateTransaction property
TADTable class
Active
ActiveStoredUsage
AfterApplyUpdates
AfterCancel
AfterClose
AfterDelete
AfterEdit
AfterGetRecords
AfterInsert
AfterOpen
AfterPost
AfterRefresh
AfterRowRequest
AfterScroll
Aggregates
AggregatesActive
AutoCalcFields
BeforeApplyUpdates
BeforeCancel
BeforeClose
BeforeDelete
BeforeEdit
BeforeGetRecords
BeforeInsert
BeforeOpen
BeforePost
BeforeRefresh
BeforeRowRequest
BeforeScroll
CachedUpdates
CatalogName
Connection
ConnectionName
Constraints
ConstraintsEnabled
Create
Exclusive
FetchOptions
Filter
FilterChanges
Filtered
FilterOptions
FormatOptions
Indexes
IndexesActive
IndexFieldNames
IndexName
MasterFields
MasterSource
ObjectView
OnCalcFields
OnCommandChanged
OnDeleteError
OnEditError
OnError
OnExecuteError
OnFilterRecord
OnNewRecord
OnPostError
OnReconcileError
OnUpdateError
OnUpdateRecord
ResourceOptions
SchemaName
TableName
Transaction
UpdateObject
UpdateOptions
UpdateTransaction
TADTable.Active property
TADTable.ActiveStoredUsage property
TADTable.AfterApplyUpdates event
TADTable.AfterCancel property
TADTable.AfterClose property
TADTable.AfterDelete property
TADTable.AfterEdit property
TADTable.AfterGetRecords event
TADTable.AfterInsert property
TADTable.AfterOpen property
TADTable.AfterPost property
TADTable.AfterRefresh property
TADTable.AfterRowRequest event
TADTable.AfterScroll property
TADTable.Aggregates property
TADTable.AggregatesActive property
TADTable.AutoCalcFields property
TADTable.BeforeApplyUpdates event
TADTable.BeforeCancel property
TADTable.BeforeClose property
TADTable.BeforeDelete property
TADTable.BeforeEdit property
TADTable.BeforeGetRecords event
TADTable.BeforeInsert property
TADTable.BeforeOpen property
TADTable.BeforePost property
TADTable.BeforeRefresh property
TADTable.BeforeRowRequest event
TADTable.BeforeScroll property
TADTable.CachedUpdates property
TADTable.CatalogName property
TADTable.Connection property
TADTable.ConnectionName property
TADTable.Constraints property
TADTable.ConstraintsEnabled property
TADTable.Create constructor
TADTable.Exclusive property
TADTable.FetchOptions property
TADTable.Filter property
TADTable.FilterChanges property
TADTable.Filtered property
TADTable.FilterOptions property
TADTable.FormatOptions property
TADTable.Indexes property
TADTable.IndexesActive property
TADTable.IndexFieldNames property
TADTable.IndexName property
TADTable.MasterFields property
TADTable.MasterSource property
TADTable.ObjectView property
TADTable.OnCalcFields property
TADTable.OnCommandChanged event
TADTable.OnDeleteError property
TADTable.OnEditError property
TADTable.OnError event
TADTable.OnExecuteError event
TADTable.OnFilterRecord property
TADTable.OnNewRecord property
TADTable.OnPostError property
TADTable.OnReconcileError event
TADTable.OnUpdateError event
TADTable.OnUpdateRecord event
TADTable.ResourceOptions property
TADTable.SchemaName property
TADTable.TableName property
TADTable.Transaction property
TADTable.UpdateObject property
TADTable.UpdateOptions property
TADTable.UpdateTransaction property
TADTableAdapter class
ColumnMappings
DatSTableName
DeleteCommand
FetchRowCommand
InsertCommand
LockCommand
MetaInfoMergeMode
OnDescribeColumn
OnDescribeTable
OnError
OnReconcileRow
OnUpdateRow
SchemaAdapter
SelectCommand
SourceRecordSetID
SourceRecordSetName
UnLockCommand
UpdateCommand
UpdateTableName
UpdateTransaction
TADTableAdapter.ColumnMappings property
TADTableAdapter.DatSTableName property
TADTableAdapter.DeleteCommand property
TADTableAdapter.FetchRowCommand property
TADTableAdapter.InsertCommand property
TADTableAdapter.LockCommand property
TADTableAdapter.MetaInfoMergeMode property
TADTableAdapter.OnDescribeColumn event
TADTableAdapter.OnDescribeTable event
TADTableAdapter.OnError event
TADTableAdapter.OnReconcileRow event
TADTableAdapter.OnUpdateRow event
TADTableAdapter.SchemaAdapter property
TADTableAdapter.SelectCommand property
TADTableAdapter.SourceRecordSetID property
TADTableAdapter.SourceRecordSetName property
TADTableAdapter.UnLockCommand property
TADTableAdapter.UpdateCommand property
TADTableAdapter.UpdateTableName property
TADTableAdapter.UpdateTransaction property
TADTextDataDef class
Assign
Create
DataMove
Delimiter
Destroy
EndOfLine
Fields
FormatSettings
RecordFormat
Separator
WithFieldNames
TADTextDataDef.Assign method
TADTextDataDef.Create constructor
TADTextDataDef.DataMove property
TADTextDataDef.Delimiter property
TADTextDataDef.Destroy destructor
TADTextDataDef.EndOfLine property
TADTextDataDef.Fields property
TADTextDataDef.FormatSettings property
TADTextDataDef.RecordFormat property
TADTextDataDef.Separator property
TADTextDataDef.WithFieldNames property
TADTextField class
Assign
DataType
DefineAsField
FieldName
FieldSize
Precision
TADTextField.Assign method
TADTextField.DataType property
TADTextField.DefineAsField method
TADTextField.FieldName property
TADTextField.FieldSize property
TADTextField.Precision property
TADTextFields class
Add
AddAll
Create
FieldByName
FindField
Items
TADTextFields.Add method
TADTextFields.AddAll method
TADTextFields.Create constructor
TADTextFields.FieldByName method
TADTextFields.FindField method
TADTextFields.Items property
TADTextFormatSettings class
Assign
Create
CurrencyDecimals
CurrencyFormat
CurrencyString
DataDef
DateSeparator
DecimalSeparator
Destroy
NegCurrFormat
ShortDateFormat
ShortTimeFormat
ThousandSeparator
TimeAMString
TimePMString
TimeSeparator
TwoDigitYearCenturyWindow
TADTextFormatSettings.Assign method
TADTextFormatSettings.Create constructor
TADTextFormatSettings.CurrencyDecimals property
TADTextFormatSettings.CurrencyFormat property
TADTextFormatSettings.CurrencyString property
TADTextFormatSettings.DataDef property
TADTextFormatSettings.DateSeparator property
TADTextFormatSettings.DecimalSeparator property
TADTextFormatSettings.Destroy destructor
TADTextFormatSettings.NegCurrFormat property
TADTextFormatSettings.ShortDateFormat property
TADTextFormatSettings.ShortTimeFormat property
TADTextFormatSettings.ThousandSeparator property
TADTextFormatSettings.TimeAMString property
TADTextFormatSettings.TimePMString property
TADTextFormatSettings.TimeSeparator property
TADTextFormatSettings.TwoDigitYearCenturyWindow property
TADTopResourceOptions class
Assign
AutoReconnect
BackupExt
BackupFolder
DefaultStoreExt
DefaultStoreFolder
DefaultStoreFormat
MaxCursors
RestoreDefaults
ServerOutput
ServerOutputSize
TADTopResourceOptions.Assign method
TADTopResourceOptions.AutoReconnect property
TADTopResourceOptions.BackupExt property
TADTopResourceOptions.BackupFolder property
TADTopResourceOptions.DefaultStoreExt property
TADTopResourceOptions.DefaultStoreFolder property
TADTopResourceOptions.DefaultStoreFormat property
TADTopResourceOptions.MaxCursors property
TADTopResourceOptions.RestoreDefaults method
TADTopResourceOptions.ServerOutput property
TADTopResourceOptions.ServerOutputSize property
TADTransaction class
Connection
Options
TADTransaction.Connection property
TADTransaction.Options property
TADTxOptions class
Assign
AutoCommit
AutoStart
AutoStop
Changed
ClearChanged
Create
Destroy
DisconnectAction
Isolation
Params
ReadOnly
StopOptions
TADTxOptions.Assign method
TADTxOptions.AutoCommit property
TADTxOptions.AutoStart property
TADTxOptions.AutoStop property
TADTxOptions.Changed property
TADTxOptions.ClearChanged method
TADTxOptions.Create constructor
TADTxOptions.Destroy destructor
TADTxOptions.DisconnectAction property
TADTxOptions.Isolation property
TADTxOptions.Params property
TADTxOptions.ReadOnly property
TADTxOptions.StopOptions property
TADUpdateOptions class
Assign
AssignedValues
CacheUpdateCommands
CountUpdatedRecords
EnableDelete
EnableInsert
EnableUpdate
FastUpdates
FetchGeneratorsPoint
GeneratorName
IsValueOwned
LockMode
LockPoint
LockWait
ReadOnly
RefreshMode
RequestLive
RestoreDefaults
UpdateChangedFields
UpdateMode
UseProviderFlags
TADUpdateOptions.Assign method
TADUpdateOptions.AssignedValues property
TADUpdateOptions.CacheUpdateCommands property
TADUpdateOptions.CountUpdatedRecords property
TADUpdateOptions.EnableDelete property
TADUpdateOptions.EnableInsert property
TADUpdateOptions.EnableUpdate property
TADUpdateOptions.FastUpdates property
TADUpdateOptions.FetchGeneratorsPoint property
TADUpdateOptions.GeneratorName property
TADUpdateOptions.IsValueOwned method
TADUpdateOptions.LockMode property
TADUpdateOptions.LockPoint property
TADUpdateOptions.LockWait property
TADUpdateOptions.ReadOnly property
TADUpdateOptions.RefreshMode property
TADUpdateOptions.RequestLive property
TADUpdateOptions.RestoreDefaults method
TADUpdateOptions.UpdateChangedFields property
TADUpdateOptions.UpdateMode property
TADUpdateOptions.UseProviderFlags property
TADUpdateSQL class
Apply
Commands
Connection
ConnectionName
Create
DeleteSQL
Destroy
FetchRowSQL
InsertSQL
LockSQL
ModifySQL
SQL
UnlockSQL
TADUpdateSQL.Apply method
TADUpdateSQL.Commands property
TADUpdateSQL.Connection property
TADUpdateSQL.ConnectionName property
TADUpdateSQL.Create constructor
TADUpdateSQL.DeleteSQL property
TADUpdateSQL.Destroy destructor
TADUpdateSQL.FetchRowSQL property
TADUpdateSQL.InsertSQL property
TADUpdateSQL.LockSQL property
TADUpdateSQL.ModifySQL property
TADUpdateSQL.SQL property
TADUpdateSQL.UnlockSQL property
TADWideMemoField class
Create
Value
TADWideMemoField.Create constructor
TADWideMemoField.Value property
U
uADCompClient unit
uADCompClient.ADFindDefaultConnection function
uADCompClient.ADManager function
uADCompClient.ADSetConnectionClass function
uADCompClient.ADSetManagerClass function
uADCompClient.TADBindedBy enumeration
uADCompClient.TADChangingKind enumeration
uADCompClient.TADChangingKinds type
uADCompClient.TADConnectionLoginEvent type
uADCompClient.TADConnectionRecoverEvent type
uADCompClient.TADCustomConnectionClass type
uADCompClient.TADCustomManagerClass type
uADCompClient.TADDescribeColumnEvent type
uADCompClient.TADDescribeTableEvent type
uADCompClient.TADErrorEvent type
uADCompClient.TADExecuteErrorEvent type
uADCompClient.TADOperationFinishedEvent type
uADCompClient.TADReconcileRowEvent type
uADCompClient.TADUpdateRowEvent type
uADCompDataMove unit
uADCompDataMove.TADDataMoveErrorEvent type
uADCompDataMove.TADDataMoveFindDestRecordEvent type
uADCompDataMove.TADDataMoveMode enumeration
uADCompDataMove.TADDataMoveOption enumeration
uADCompDataMove.TADDataMoveOptions type
uADCompDataMove.TADDataMovePhase enumeration
uADCompDataMove.TADDataMoveProgressEvent type
uADCompDataMove.TADDataSourceKind enumeration
uADCompDataMove.TADLogFileAction enumeration
uADCompDataMove.TADTextDataType enumeration
uADCompDataMove.TADTextEndOfLine enumeration
uADCompDataMove.TADTextFormatSettingsValue enumeration
uADCompDataMove.TADTextFormatSettingsValueSet type
uADCompDataMove.TADTextRecordFormat enumeration
uADCompDataMove.TFormatSettings record
uADCompDataSet unit
uADCompDataSet.PADKeyBuffer type
uADCompDataSet.TADAfterApplyUpdatesEvent type
uADCompDataSet.TADCopyDataSetOptions type
uADCompDataSet.TADDataSetEvent type
uADCompDataSet.TADDataSetFlags type
uADCompDataSet.TADDataSetLocateOption enumeration
uADCompDataSet.TADDataSetLocateOptions type
uADCompDataSet.TADKeyBuffer record
uADCompDataSet.TADKeyIndex enumeration
uADCompDataSet.TADReconcileErrorEvent type
uADCompDataSet.TADStoredActivationUsage type
uADCompDataSet.TADUpdateErrorEvent type
uADCompDataSet.TADUpdateRecordEvent type
uADCompScript unit
uADCompScript.ADKeywordMatch function
uADCompScript.ADScriptCommandRegistry function
uADCompScript.TADConsoleGetEvent type
uADCompScript.TADConsoleLockUpdate type
uADCompScript.TADConsolePutEvent type
uADCompScript.TADGetStreamEvent type
uADCompScript.TADHostCommandEvent type
uADCompScript.TADPauseEvent type
uADCompScript.TADScriptCharSet type
uADCompScript.TADScriptCommandClass type
uADCompScript.TADScriptCommandLookupRes enumeration
uADCompScript.TADScriptEchoCommands enumeration
uADCompScript.TADScriptSpoolOutputMode enumeration
uADCompScript.TADScriptStatus enumeration
uADCompScript.TADScriptStreamMode enumeration
uADStanOption unit
uADStanOption.TADFetchGeneratorsPoint enumeration
uADStanOption.TADFetchItem enumeration
uADStanOption.TADFetchItems type
uADStanOption.TADFetchMode enumeration
uADStanOption.TADFetchOptionValue enumeration
uADStanOption.TADFetchOptionValues type
uADStanOption.TADFormatOptionValue enumeration
uADStanOption.TADFormatOptionValues type
uADStanOption.TADLockMode enumeration
uADStanOption.TADLockPoint enumeration
uADStanOption.TADOptionChangeEvent type
uADStanOption.TADRecordCountMode enumeration
uADStanOption.TADRefreshMode enumeration
uADStanOption.TADResourceOptionValue enumeration
uADStanOption.TADResourceOptionValues type
uADStanOption.TADStorageFormat enumeration
uADStanOption.TADTxAction enumeration
uADStanOption.TADTxIsolation enumeration
uADStanOption.TADTxStopOption enumeration
uADStanOption.TADTxStopOptions type
uADStanOption.TADTxValue enumeration
uADStanOption.TADTxValues type
uADStanOption.TADUpdateOptionValue enumeration
uADStanOption.TADUpdateOptionValues type
uADStanParam unit
uADStanParam.ADVar2SQL function
uADStanParam.ADVar2SQLTyped function
uADStanParam.ADVarType2FieldType function
uADStanParam.TADGetOwner type
uADStanParam.TADMacroDataType enumeration
uADStanParam.TADParamArrayType enumeration
uADStanParam.TADParamBindMode enumeration
W
Writing expressions


Welcome

AnyDAC.

Dmitry Arefiev, (c)opyright RemObjects Software 2004-2008. Under exclusive license from DA-SOFT.