Overview

CommStudio
Overview

Glossary Item Box

CommStudio makes it easy to let your application communicate using the serial port and modems. Because CommStudio supports both event-driven and script-driven programming models, you can choose the design that works best with your application and minimizes processor usage.

In addition, CommStudio contains a number of components that help you draw barcodes to any .NET drawing surface, including printers, print preview, bitmaps, and web pages.

Copyright © 1994-2007 Sax Software Corp. All rights reserved.


Technical Support

CommStudio
Technical Support

Glossary Item Box

It's important to register your software immediately after your purchase. Registering your software gives you several important advantages:

  • Obtain the latest versions including fixes and enhancements.
  • Protect against loss in case you misplace your serial number.
  • Obtain technical support and assistance with your product.
  • Receive notification when updates and fixes become available.

To register your copy of the CommStudio, please visit http://www.CommStudio.com/Register.

Getting Assistance

During the time of your subscription, a variety of support options are available for your convenience:

  • Search the Solutions Library
    Obtain information and answers from an extensive database collected from Sax support engineers, solution partners, and customers.
  • Browse the Software Library
    Download updates and samples, and check revision history.
  • Submit an Incident
    Report your problem online to the help desk

All technical supports starts at the CommStudio website. Please visit http://www.CommStudio.com/Support for details.


Developer's Guide

CommStudio
Developer's Guide

Glossary Item Box

The developer's guide teaches you how to get started. It explains how you can use the components with Visual Studio .NET and it contains information on how to deploy your application once it's finished.


Working with Serial Ports

CommStudio
Working with Serial Ports

Glossary Item Box

  • About serial ports
  • Connection options
  • Event-driven vs. script-driven
  • Your first serial port program
  • Writing a port listener program


About Serial Ports

CommStudio
About Serial Ports

Glossary Item Box

On most systems, the serial ports on your system will range from COM1 to COM4. Not all communications ports use the same naming scheme, however. If you have a specific board that supports a large number of ports, your ports may be called something completely different. Please consult the documentation of the hardware you are using and check the Windows Control Panel for details.

Using the CommStudio you can control both RS232 and RS485 serial ports. RS232 ports are the most commonly used serial port and connect to a single device. RS485 is a slightly more advanced type of port that lets you connect multiple devices.

It's possible that some "serial ports" available on your computer are virtual and don't directly connect to a physical port. Instead, they may emulate a port that resides on a different computer on the network, or they may let you connect to a virtual device over an infra-red connection. The communications classes use whichever Windows communications is installed on the system, and will consequently work with most of these devices.


Connection Options

CommStudio
Connection Options

Glossary Item Box

Serial ports have existed for a long time, and the technology has evolved with the advancements in devices and modems. There are thousands of ways to open a serial connection using different options. It is essential that both sides of a connection use exactly the same options. Otherwise, each side will either receive garbage or no data at all.

The most commonly used communications options are:

  • The baudrate which is the connection speed. The connection speed is typically expressed in bits per seconds.
  • The number of databits indicates how many bits each character should hold. In most case eight databits is the perfect choice. Some older networks or terminal connections may require you to use seven data bits, using the eight bit for error checking.
  • In cases where you only use seven databits, the extra available bit is typically used for parity checking. This provides a simple way to add error checking: for example, with "even parity", the eight bit will be set if the number of bits that are set in the lower seven bits is even.
  • Handshaking or flow control determines how both sides tell each other when they are ready to receive data, or when they are unable to process additional data.

As long as all options are identical on both sides of the connection, everything will work great. A small difference can cause communications to break down completely.


Event-Driven vs. Script-Driven

CommStudio
Event-Driven vs. Script-Driven

Glossary Item Box

There are two approaches to writing serial communications code: script-driven or event-driven code.

Script-driven programs

The script-driven approach works well in situations where you have to make a connection, perform a number of steps, and disconnect. For example, you could call a server, log in, check if new data is available and disconnect.

The CommStudio communications component contains several properties and methods that make writing automated scripts very easy. The component can wait for a number of strings you specify and will return which one of them was received. You can then send the appropriate response to the host computer and wait for the next string.

There are two ways for the component to wait for data to come in from the port. The most efficient mode puts the current thread in a wait state until a communications event occurs. This has one important side effect: If you write are writing a Windows Forms applicaiton and you're calling the function from your main thread, the application will not process any keyboard or mouse clicks or even redrawing events and will appear frozen. To remedy this you can use the second type of waiting, which is more processor intensive but continues to process UI while waiting.

Event-driven programs

Script-driven programs are great when you want to be in control. In many cases, however, your system is just waiting to process input from a device. In the mean time your application just sits there waiting. If you want to let the device wake you up when it has data to process, you'll want to write an event-driven application.

CommStudio has an event which is fired when data becomes available in the communications buffer. This means you don't have to constantly poll the device, but instead you get called when it's time to process data. You can process the data, send a response or an acknowledgement to the device. When the even routine is complete, the program will return to what it was doing when the event was fired.


Your First Serial Port Program

CommStudio
Your First Serial Port Program

Glossary Item Box

In this section we will build a very simple application that lets you write lines of text to the serial port. The application doesn't read, it only writes. If you have a null modem cable, you can test the application by connecting two ports, either on the same PC or on different systems. One port is used by this application. The other port could be connected to Windows Hyper Terminal.

To write a Hello Serial Port application:

  1. Start by creating a new Windows Forms application.
  2. Right-click on the toolbox, choose Customize Toolbox and go to the .NET Framework components tab. Check CommStudio.Connections option - if it's not in the list, you can choose the browse button to locate CommStudio.Connections.dll.
  3. Draw a text box control on the form.
  4. Draw a pushbutton control on the form and set its Text property to "Send"
  5. Draw a SerialConnection component on the form. It will appear as an invisible component at the bottom of the form. You can set the Options properties to set the serial communications options in the same way you would set them using Windows Hyper Terminal.
  6. In the button's Click event, write the following code:

Try
   If Not SerialConnection1.IsOpen Then SerialConnection1.Open()
   SerialConnection1.Write(TextBox1.Text + vbCr)
Catch ex As Exception
   MsgBox(ex.Message)
End Try

This code first checks if the port is already open, and if not, opens it. It then writes the data to the port. The code runs inside a Try...Catch block so exceptions are handled gracefully. If the port specified in the Options property of the SerialConnection1 component doesn't exist or is in use, an exception will occur. You will also see an exception if for some reason the component is unable to write to the port.


Writing a Port Listener Program

CommStudio
Writing a Port Listener Program

Glossary Item Box

In this section we will build a very simple application that listens to the serial port and reports what it hears. If you have a null modem cable, you can test the application by connecting two ports, either on the same PC or on different systems. One port is used by this application. The other port could be connected to Windows Hyper Terminal. As you type characters in the Hyperterm window, they should be visible in the application you built.

To write a Hello Serial Port application:

  1. Start by creating a new Windows Forms application.
  2. Right-click on the toolbox, choose Customize Toolbox and go to the .NET Framework components tab. Check the CommStudio.Connections option - if it's not in the list, you can choose the browse button to locate CommStudio.Connections.dll.
  3. Draw a listbox.
  4. Draw a SerialConnection component on the form. It will appear as an invisible component at the bottom of the form. You can set the Options properties to set the serial communications options in the same way you would set them using Windows HyperTerminal.
  5. In the form's Load event, write the following code:
    Try
       SerialConnection1.Open()
    Catch ex As Exception
       MsgBox(ex.Message)
       Me.Close()
    End Try
  6. In the DataAvailable event of the serialConnection1 component, write the following code:
    Try
       ListBox1.Items.Add("Received " & SerialConnection1.Available & " bytes:")
       ListBox1.Items.Add("   " & SerialConnection1.Read(SerialConnection1.Available))
    Catch ex As Exception
       MsgBox(ex.Message)
    End Try

When the form is loaded, the application opens the port. If this fails, the app shows an error message and shuts down. Otherwise, the control will wait for data to come in from the port, and fire the DataAvaillable event when data is available. When this happens, the application adds two lines to the list box: One tells the user how many bytes were received using the Available property. The other line contains the actual data read from the port.


Transferring Files

CommStudio
Transferring Files

Glossary Item Box

CommStudio supports standard file transfer protocols, including different variations of XModem, YModem, and ZModem. File transfer protocols are designed to transfer files from one system to another with great reliability. Files are transmitted in blocks of typically 128 or 1024 bytes and each block contains a checksum or CRC to verify data integrity. If line noise or other transmission errors occur, most file transfer protocols have a mechanism to recover and resend the data that was garbled.


Choosing the right transfer protocol

CommStudio
Choosing the right transfer protocol

Glossary Item Box

In many cases, your choice of protocol is determined by the host you are connecting to. Variations of XModem and YModem are different in the following areas:

  • Block size - XModem typically uses 128 byte block sizes, while YModem uses 1024 block size. Because both XModem and YModem wait for confirmation after each block, a larger block size can significantly increase the speed of the file transfer. On very slow connections that may contain lots of errors, such as wireless connections, a smaller block size may work better.
  • Variable Block Size - On good connections, having a large block size helps reduce the overhead and maximize the amount of raw data that can be sent. Small block sizes work better with bad connections because less data needs to be re-sent in the event of an error. Protocols with variable block size, such as ZModem, let you have the best of both worlds by starting with a large block size and reducing the block size each time an error occurs.
  • Error checking method - Earlier versions of XModem used a checksum to verify the integrity of each block using a checksum. Later versions of XModem and YModem uses a CRC check, significantly reducing the possibility of errors. ZModem has the ability to include a 32-bit CRC check, reducing the possibility of errors to almost zero.
  • Batch capability - All variations XModem only send the data of a file, but no other information such as the filename or the file size. Because the file size is not known, it is rounded on the receiving side to blocks of 128 or 1024 bytes. YModem transfers the filename and file size correctly. In addition, YModem has the ability to transfer multiple files per transfer in one direction.
  • Resume capability - Some protocols have the ability to resume when a long file transfer is interrupted. This makes is easy to transfer very long files even on very bad connections. When the file already exists, a CRC check will verify that the first part of the file on disk is identical to file being transferred. If possible, the file transfer will resume.
  • Streaming capability - Most file transfer protocols send one block and wait for an acknowledgement before the next block is sent. ZModem has the ability to send multiple blocks without requiring an acknowledgement. This results in a significant increase in transfer speed.

The following table provides a brief overview of the different features:

Protocol | Block Size | Variable Block Size | Error Checking | Batch | Resume | Streaming
XModem Checksum | 128 | No | 8-bit Checksum | No | No | No
XModem CRC | 128 | No | 16-bit CRC | No | No | No
XModem 1K | 1024 | No | 16-bit CRC | No | No | No
YModem | 1024 | No | 16-bit CRC | Yes | No | No
ZModem | 128-1024 | Yes | 32-bit CRC | Yes | Yes | Yes

If you are not restricted by the host system in your choice of file transfer protocol, YModem is the best option in the current version of Sax.net Communications.


Sending a File

CommStudio
Sending a File

Glossary Item Box

The Transfer component helps you perform a file transfer on a given connection. It has a Connection property, which you should set to the instance of the SerialConnection class you want to use for the transfer.

Once you have established a connection with the host and you have come to the point where the host is expecting a file, sending it is very straightforward: You simply set the Transfer object's Protocol property to indicate which file transfer protocol you wish to use and call the Upload method of your connection object. The return value of the Upload method will tell you

Transfer1.Protocol = TransferProtocol.Zmodem
Transfer1.Connection = SerialConnection1
Transfer1.Upload("c:\newfile.dat")

If you are using a batch protocol such as YModem or ZModem, you can send multiple files in one call to Upload by passing an array of strings rather than a single filename. If an unexpected error occurs during the transfer, an acception will be thrown.


Receiving a File

CommStudio
Receiving a File

Glossary Item Box

Receiving a file is almost as simple as sending one. In addition to specifying the file transfer protocol, you also need to specify the folder where you want to save the file:

Transfer1.Protocol = XmodemCrc
Transfer1.Path = "c:\downloads"
Transfer1.Download("newfile.dat")
If Transfer1.Status <> TransferStatus.Completed Then
MsgBox("File Transfer Failed")
End If

If you are downloading a file using a batch protocol such as YModem, the other system will send you the suggested name for the file you are receiving. If you don't want to override this name, you can simply call Download without passing any parameters.


Drawing Barcodes

CommStudio
Drawing Barcodes

Glossary Item Box

CommStudio contains a set of classes that help you draw linear and two-dimensional bar codes. Full integration with the .NET framework means that your bar codes can be rendered anywhere:

  • The screen – You can render barcodes directly to a form or to a print preview control.
  • The printer – Sax.net Barcodes supports a variety of printers, including specialized label printers and generic laser or inkjet printers.
  • A database table – You can generate barcodes and save them as a picture in a binary database field.

CommStudio does not use a custom control to render the barcode. Instead, it has a Render method which lets you draw to any object that can return a Graphics class. This makes rendering bar codes both simple and flexible, with support for generic Windows applications, as well as services.


Barcode Basics

CommStudio
Barcode Basics

Glossary Item Box

When drawing a barcode, there are three important elements that determine what the barcode will look like:

1. Data – the data you want to encode in the barcode. This is usually a sequence of characters or numbers which will later be read by a barcode reading device.

2. Symbology – the set of conventions used to render the data. Different symbologies support different types of data. For example, some symbologies only support numbers or upper case characters.

3. Location – the dimensions, size and rotation of the barcode.

For each of these elements, Sax.net Barcodes provides a number of properties that let you specify the exact shape of the barcode. For your convenience, many of properties default to the most commonly used values.


Barcode Symbologies

CommStudio
Barcode Symbologies

Glossary Item Box

Because barcodes are used to encode many different types of information, different symbologies have been developed throughout the years.

To ensure that the barcodes you generate can be scanned by any quality barcode reading device, CommStudio follows the exact industry standard for each of these symbologies. The following one dimensional symbologies are supported:

  • MSI/Plessey – Variable length numeric symbology. A modulo 10 check digit is always appended to the encoded string.
  • Interleaved 2 of 5 – Variable length numeric symbology. A leading zero is appended to make the total number of characters even if necessary.
  • Interleaved 2 of 5 with Check Digit – The same as the Interleaved 2 of 5 with an appended modulo 10 check digit.
  • Codabar Symbology – Variable length symbology. Supports digits 0-9 and six special alphanumeric characters, capital letters A through D.
  • Code 39 or Code 3 of 9 – Variable length alphanumeric symbology. It supports 26 uppercase letters, 10 digits and 7 special characters (space, -, ., %, $, / and +) . The asterisk * is used as start/stop character.
  • Code 39 with Check – The same as Code 39 with a modulo 43 Check Digit.
  • Code 39 Extended – Supports the full 128 ASCII character set.
  • Code 39 Extended with Check – The same as Code 39 Extended with a module 43 Check Digit appended.
  • Code 93 – Encodes digits 0–9, capital letters A through Z, and characters -, ., $, %, /, + and ' ' (space) . Two weighted modulo 47 check digits are appended to the encoded string.
  • Extended Code 93 – Encodes the full 128 ASCII character set. Two weighted modulo 47 check digits are appended.
  • Code 128-A – Variable length alphanumeric symbology. Characters supported include capital letters A-Z, digits 0-9, punctuation marks, signs and special control characters. A modulo 103 check digit is always appended.
  • Code 128 B – Similar to Code 128 A but with the inclusion of lower case characters replacing some of the signs.
  • Code 128 C – High density numeric symbology. The total number of digits must be even. A leading zero is appended if necessary. A modulo 103 check digit is appended.
  • UPC A – Fixed length numeric symbology. Only 11 digits can be supplied and a check digit will be appended to make the total number of digits 12.
  • UPC E – Fixed length seven digit numeric bar code. Six digits must be supplied and a check digit will be appended. If an 11 digit UPC A string is supplied the translation will be performed if possible.
  • EAN 13 – Fixed length 13 digits (including the check digit) numeric code similar to UPC A.
  • EAN 8 – Fixed length 8 digits (including the check digit) numeric code.
  • Postnet – Numeric symbology. As used by the U.S. Postal Service has a fixed length (not enforced by Sax.net Barcodes) and a modulo 10 check digit that is appended automatically.

In addition,CommStudio also supports two dimensional barcodes. By using both horizontal and vertical space to encode data, more information can be packed in less space. CommStudio supports the following 2D barcode symbologies:

  • PDF 417 – A high-density symbology that can be used to encode up 1100 bytes or 1800 ASCII characters.
  • DataMatrix – A two-dimensional encoding standard that can encode up to 1550 bytes or 2300 ASCII characters.


Choosing the Right Symbology

CommStudio
Choosing the Right Symbology

Glossary Item Box

In most cases, existing conventions used in your application’s environment will determine the type of symbology you should use. For example, if you are generating barcodes for items that will be used in a grocery store, you will most likely use the UPC A barcode symbology.

If you have the luxury of choosing the symbology yourself, you should look at four important factors in your decision:

  1. Character set – some symbologies only support numbers, while other support anything from uppercase only characters to the full 128-character ASCII character set.
  2. Space – As a symbology supports more characters, it will also take up more space. If you only have limited space available, you may be better off with a symbology that only supports digits.
  3. Length – Some symbologies only support a specific number of characters. This may be perfect for your use, or you may need to look for alternatives.
  4. Error checking – While you could easily include your own type of error checking in the information you encode, using a barcode that has built in error checking has one important advantage: Your barcode reader will alert the user immediately if the checksum does not match.
  5. Scanner cost and availability – The most popular linear encodings are supports by nearly all scanners. Two dimensional encodings require more sophisticated scanners.

After you have selected a symbology, it’s always a good idea to do a field test with a few real-world cases, and ensure that the barcode scanners used by your readers support the symbology you have chosen.


Drawing Your First Barcode

CommStudio
Drawing Your First Barcode

Glossary Item Box

In this section, we will learn how to draw simple barcodes to the screen and to the printer. We will start by creating a new Windows forms project and drawing barcodes on the screen.


Creating a New Windows Forms Project

CommStudio
Creating a New Windows Forms Project

Glossary Item Box

To create a new Windows Forms project:

  1. Start Microsoft Visual Studio.NET
  2. From the File Menu, choose New Project.
  3. Select the language of your choice (C# or Visual Basic) in the list of Project Types.
  4. Choose Windows Application from the list of Templates.
  5. Enter the name of your project and click OK.


Adding a Reference to CommStudio

CommStudio
Adding a Reference to CommStudio

Glossary Item Box

After you have created a blank project, you need to add a reference to the Sax.net Linear Barcode DLL file.

To add a reference:

  1. In the project window, right-click on the References item and choose Add Reference.
  2. In the References dialog, choose Browse and select CommStudio.2.dll from the Deploy directory under the CommStudio installation directory.
  3. Make sure that CommStudio.2.dll is in the list of selected components and click OK.


Editing the License File

CommStudio
Editing the License File

Glossary Item Box

If you use components that are drawn on a form from the toolbox, Visual Studio will automatically add the license information to your project. If you use a pure class library such as the CommStudio barcode classes, you need to add a license explicitly. These licensed classes are specified in your project using a file called licenses.licx.

To add the license for CommStudio's barcode classes to your project:

  1. Right-click on the project and choose Add | New Item.
  2. Select a "Text File" and name it "licenses.licx"
  3. Add a line to the .licx file:
    CommStudio.Barcodes.Barcode, CommStudio.2
    CommStudio.Barcodes.DataMatrix, CommStudio.2
    CommStudio.Barcodes.Pdf417, CommStudio.2

The next time you build your project, Visual Studio will extract the runtime license key and embed it into the executable.


Rendering the Barcode

CommStudio
Rendering the Barcode

Glossary Item Box

In this example, we will render the barcode in a picture box control.

To draw a picture box on the form:

  1. Open the project's main form in design mode.
  2. Select the PictureBox control from the tool palette and draw a new picture box on the form.

The new control will be named "PictureBox1" by default.

The next few steps depend on the language you are using: In this example, we will use Visual Basic as the programming language. If you are using C# you can read the VB code and translate it to C# on the fly. To make our coding easier, we will use the Imports statement (using in C#) to import the CommStudio.Barcodes namespace in our code module.

To import the CommStudio.Barcodes namespace:

  1. Open the code window for the project's main form.
  2. At the top of the code module, enter the following code:
    Imports CommStudio.Barcodes

The best place to put the actual rendering code is in the Picture Box control's Paint event.

To add code behind the control's Paint event in Visual Basic:

  1. Open the code window for the project's main form.
  2. From the left drop-down box, choose PictureBox1
  3. From the right drop-down box, choose the Paint event.

After Visual Basic has created an empty subroutine for the Paint event, you can add the following code:

Private Sub PictureBox1_Paint(ByVal sender As Object, _
    ByVal e As System.Windows.Forms.PaintEventArgs) _
    Handles PictureBox1.Paint

    Dim bc As New Barcode(BarcodeStyle.Code39)

     bc.DisplayCaption = True
     bc.Render("HELLO", e.Graphics, _
          New Rectangle(New Point(0, 0),  PictureBox1.ClientSize))
     bc.Dispose()
End Sub

Congratulations, you have just written your very first barcode program!

Step by step

Let's step through this code and look at each line of source code that involves the bar codes, one at a time.

First we declare a new instance of the Barcode class:

     Dim bc As New Barcode(BarcodeStyle.Code39)

In the constructor, we pass the barcode style or symbology we would like to use. In this example, we choose the Code39 symbology, because it is very common and it supports letters as well as numbers.

Then, we indicate to the barcode class that we would like to display the caption when rendering the barcode.

     bc.DisplayCaption = True

The most important line of code is the next one, which calls the Render method:

     bc.Render("HELLO", e.Graphics, _
          New Rectangle(New Point(0, 0), PictureBox1.ClientSize))

The first parameter is the text that should be drawn, which needs to conform to the specifications of the barcode symbology you selected.

The Graphics object that the barcode should be rendered to is passed as the second parameter.

The third and final parameter of the Render method is a rectangle that indicates where the barcode should be drawn. In this case we pass a rectangle that consists of the PictureBox control's entire client area.

The last line of code calls Dispose to release all resources used by the class.

    bc.Dispose()

Because of the .NET Framework's automatic garbage collection, the call to Dispose is technically not necessary but it is generally considered a good development practice to ensure that resources are freed as quickly as possible.


Rendering 2D Barcodes

CommStudio
Rendering 2D Barcodes

Glossary Item Box

CommStudio also lets you draw two-dimensional barcodes. Each encoding uses its own class.

Drawing PDF417 barcodes

To draw a barcode using the PDF417 encoding you create a new instance of the Pdf417 class and call its Render function. The most commonly used variation of the render function takes three parameters:

  1. The string of text you wish to render
  2. The Graphics object that the barcode should be rendered to.
  3. The rectangle that marks the boundaries of the barcode.

Private Sub DrawBarcode(ByVal g As Graphics, ByVal rect As Rectangle)
   Dim pdf As New Pdf417()
   pdf.Render("Hello World", g, rect)
End Sub

That's all there is to it! Of course, the Pdf417 class contains several properties and methods that give you full control over how exactly barcodes should be rendered. Please refer to the Reference online documentation for details.

Drawing DataMatrix barcodes

The DataMatrix class works much the same way as the Pdf417 class: You create a new instance of the DataMatrix class, and you call its Render function. The Render function of the DataMatrix class takes the same parameters as the Pdf417 Render function:

Private Sub DrawBarcode(ByVal g As Graphics, ByVal rect As Rectangle)
  Dim pdf As New DataMatrix()
  pdf.Render("Hello World", g, rect)
End Sub

For details on how to customize the rendering of DataMatrix barcodes, please refer to the Reference online documentation.


Printing Barcodes

CommStudio
Printing Barcodes

Glossary Item Box

Barcodes on the screen aren't terribly useful, which is why CommStudio doesn't come as a visual Windows Forms control. Instead, you get a true class library with the ability to render to any device or object that supports graphics. In most cases, the ultimate destination for the barcodes you generate will be some form of printer. CommStudio supports any printer that has a Windows driver, including thermal label printers, standard laser and inkjet printers, and typesetters. The barcodes will be generated using the printer's optimal resolution.


Getting Started

CommStudio
Getting Started

Glossary Item Box

In this section, we will create a Windows application that has a button which prints a bar code when you click on it. You can either use the example program generated in the previous section as a starting point, or you can create a new Windows Forms application and add a reference to Sax.Barcodes.dll, as described in that section.

Once you have Windows forms project with a reference the CommStudio2.dll file and added the license (as described in the previous section), draw a button on the main form:

  1. Open the main form in design mode.
  2. From the toolbox, choose the button control and draw it on the form.


Using the PrintDocument Class

CommStudio
Using the PrintDocument Class

Glossary Item Box

Behind the button's click event, we will put code that prints a page with a barcode on it. Before we do that, we should draw a new PrintDocument component on our form. This component is used by the .NET Framework to facilitate printing.

To add a new PrintDocument component:

  1. Open the main form in design mode.
  2. From the toolbox choose the PrintDocument control.
  3. Draw the control on the form. It will appear below the form as an invisible control.

Now it's time to write code behind the Button's click event.

To add a click event handler for the Button1 control:

1. Open the main form in design mode.

2. Double-click on the Button1 control.

The code that we need to add behind the button's Click event is extremely simple.

Private Sub Button1_Click(ByVal sender As System.Object, _
   ByVal e As System.EventArgs) _
   Handles Button1.Click

   PrintDocument1.Print()

End Sub

All the hard work is done inside the PrintDocument control's PrintPage event.


Handling the PrintPage Event

CommStudio
Handling the PrintPage Event

Glossary Item Box

When the PrintDocument component needs to draw a page, it fires the PrintPage event. This is where you can draw the contents of your document.

To add a PrintPage event handler for the PrintDocument1 control:

  1. Open the main form in design mode.
  2. Double-click on the PrintDocument1 component.

The code for the PrintPage event is very similar to the code in the previous section that rendered a barcode to the screen:

Private Sub PrintDocument1_PrintPage(ByVal sender As System.Object, _
  ByVal e As System.Drawing.Printing.PrintPageEventArgs) _
  Handles PrintDocument1.PrintPage

  Dim bc As New Barcode(BarcodeStyle.Code39)

  bc.DisplayCaption = True
  bc.Render("HELLO", e.Graphics, _
    New Rectangle(e.MarginBounds.Location, New Size(144, 36)))
  bc.Dispose()
  e.HasMorePages = False
End Sub

Let's step through this code:

We first create a new instance of the Barcode class, passing the Code39 encoding as the first parameter of the constructor:

  Dim bc As New Barcode(BarcodeStyle.Code39)

Setting the DisplayCaption property to True ensures that the text is shown at the bottom of the barcode.

  bc.DisplayCaption = True

The actual drawing is done when we call the Render method:

  bc.Render("HELLO", e.Graphics, _
    New Rectangle(e.MarginBounds.Location, New Size(144, 36)))

The first parameter is the text that will be defined by the barcode.

The second parameter is the Graphics object for the current page. This lets us draw directly to the page using the printer's graphics capabilities.

Finally, we pass a rectangle that indicates where the barcode should be drawn. Because this is just a sample, we simply create a rectangle that is about two inches wide and half an inch high, and starts at the top left corner of the page.

Calling the Dispose method immediately cleans up any resources used by the Barcode class.

  bc.Dispose()

Finally, we tell the PrintDocument object that this is the last page by setting the HasMorePages property of the event argument to False:

  e.HasMorePages = False

That's all there is to it! In a real world program you would probably print multiple barcodes, or add more text and graphics. The actual drawing of the barcodes will always remain as simple as this example. CommStudio also gives you several options to fine-tune the appearance of your barcodes. Please refer to the Reference section for details.


Saving Barcodes to an Image File

CommStudio
Saving Barcodes to an Image File

Glossary Item Box

In some cases, you may need to save a barcode to an image file. The .NET framework allows you to save your barcodes in all popular image formats, including Windows Bitmap, Jpeg, GIF, PNG, and TIFF files.

You can either start from the application we built earlier in this guide, or you can create a new application and add a reference to CommStudio.2.dll and edit the license file. In this section, we will simply add a new button that will save the barcode to a file when clicked.

Once you have a Windows forms project with a reference to the barcodes dll file, draw a button on the main form and add a Click event handler:

  1. Open the main form in design mode.
  2. From the toolbox, choose the button control and draw it on the form.


Writing the Code

CommStudio
Writing the Code

Glossary Item Box

If you started from the existing project discussed previously in this guide, the button will be called Button2, because Button 1 already exists. If you started a new button, the new button's name will be Button In that case, just substitute Button2 with Button1 in the code later in this section.

To add a click event handler for the new button control:

  1. Open the main form in design mode.
  2. Double-click on the button control.

The code behind the new button looks like this:

Private Sub Button2_Click(ByVal sender As System.Object, _
   ByVal e As System.EventArgs) _
   Handles Button2.Click

   Const width As Integer = 300
   Const height As Integer = 100
   Dim bmp As New Bitmap(width, height)
   Dim g As Graphics = Graphics.FromImage(bmp)
   Dim bc As New Barcode(BarcodeStyle.Code39)

   bc.DisplayCaption = True
   bc.Render("HELLO", g, _
      New Rectangle(0, 0, width, height))
   bc.Dispose()
   g.Flush()
   bmp.Save("c:\test.gif", Imaging.ImageFormat.Gif)
End Sub


The Code, Step by Step

CommStudio
The Code, Step by Step

Glossary Item Box

When we look at this code step by step, it becomes very clear and simple. We start out by declaring the dimensions of our bitmap as constants:

   Const width As Integer = 300
   Const height As Integer = 100

We then create a new bitmap of the specified dimensions:

   Dim bmp As New Bitmap(width, height)

The Graphics class contains a Shared (static in C#) function called FromImage. This function creates a new Graphics object that we can use to draw directly to the bitmap:

  Dim g As Graphics = Graphics.FromImage(bmp)

The next few lines of code are exactly what we’ve seen before:

   Dim bc As New Barcode(_
      BarcodeStyle.Code39)

   bc.DisplayCaption = True
   bc.Render("HELLO", g,
      New Rectangle(0, 0, width, height))
   bc.Dispose()

After drawing the barcode, we call the Flush( ) function of the Graphics class, to ensure that any drawing operations that were delayed by the Framework for optimization purposes are actually executed.

   g.Flush()

Finally, we save the bitmap to a file in the file format of our choice:

   bmp.Save("c:\test.gif", Imaging.ImageFormat.Gif)


Licensing and Deployment

CommStudio
Licensing and Deployment

Glossary Item Box


Embedding a License

CommStudio
Embedding a License

Glossary Item Box

If you use your component by dragging the component from the toolbox, Visual Studio will automatically add the correct licensing information to your project. In this case, you are done with licensing and may continue with your development project.

If you are creating your Communications object outside of the toolbox, you must explicitly add the class to your Licenses.licx file within your project. This is a simple text file which contains a list of components which need to be licensed.

To add licences.licx to your project:

  1. Right-click on your project and choose the Add | New item.
  2. Select Text File and name the output file Licenses.licx. If you are prompted to replace the existing file, answer No and open the existing file instead.
  3. Depending on the components you use, add one or more of the following lines to the file:

    CommStudio.Connections.SerialConnection, CommStudio.2
    CommStudio.Transfers.Transfer, CommStudio.2
  4. Choose Build | Rebuild Solution.

The next time you build the application Visual Studio will extract the runtime license key using the using lic.exe (License Compiler) and then embed this into your new executable file using al.exe (assembly linker).

Note: You can only add license information to assemblies that are executables. If you are building an assembly that is a DLL, the license needs to be added to the project of the EXE that uses your DLL.

The licenses.licx file is typically hidden from view within your project. You can make it visible by selecting the project and then selecting Show All Files front the Projects menu.

Avoid Spaces in Assembly Names

If the name of your assembly contains a space, Microsoft Visual Studio may not embed a correct license in your compiled assembly. To use licensed components, you'll need to remove the spaces from the assembly name.

To remove spaces from your project's assembly name:

  1. Choose View | Solution Explorer
  2. In the Solution Explorer list, right-click on the project and choose Properties
  3. Remove spaces from the assembly name.


Licensing in ASP.NET

CommStudio
Licensing in ASP.NET

Glossary Item Box

If you are building an ASP.NET application that uses CommStudio, it's important to include your serial number in your web application's web.config file.

For example:

<?xml version="1.0"?>
<configuration>
  <appSettings>
    <add key="CommStudio.SerialNumber" value="000-000000-00" />
  </appSettings>
  <!-- ... other configuration settings -->
</configuration>

Note: If you are using the trial version, CommStudio will only run inside a development server. The trial version does not run under Internet Information Server running as a web service.


Deploying Your Application

CommStudio
Deploying Your Application

Glossary Item Box

If you have followed the steps in the previous section, a license should be embedded inside your application. All you need to do to deploy our application is make sure that the appropriate assembly DLL files are copied with your executable. Your application requires CommStudio.2.dll to be distributed with your application.


CommStudio.Barcodes Namespace

CommStudio.2 Send comments on this topic.
CommStudio.Barcodes Namespace
See Also Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Barcodes Namespace

Classes

Class | Description
Barcode | Represents a bar code generator.
DataMatrix | Summary description for Class1.
Pdf417 | PDF417 bar code generator.

Enumerations

Enumeration | Description
BarcodeAlignment | Possible alignment values of the bar code symbol relative to its layout rectangle.
BarcodeLayoutMode | Describes how the ModuleWidth and ModuleRatio of the bar code are handled: calculated automatically trying to fit the Rectangle supplied in Render or following the user's settings.
BarcodeOrientation | Possible orientation values for the bar code symbol. Specifies in what direction the bar code symbol is drawn.
BarcodeStyle | Different styles or bar code symbologies to use. The style determines the supported character set.
DataMatrix.SymbolEncoding | DataMatrix supports six different encoding schemes or modes. Each scheme has its native character set for which achieves maximum efficiency.
DataMatrix.SymbolOrientation | Possible orientations for the DataMatrix bar code symbol.
DataMatrix.SymbolSize | DataMatrix supports square symbols with sizes from 10x10 up to 144x144 as well as six different rectangular symbols from 8x18 to 16x48. If SymbolSize.Auto is selected then the smaller symbol fr the given amount of data is automatically selected.
Pdf417.SymbolLayout | Describes how the layout of the PDF417 bar code is calculated: how many rows and columns the symbol will have, the ModuleWidth and ModuleHeight values, the Orientation and the Error Correction Level.
Pdf417.SymbolOrientation | Possible orientations for the PDF417 bar code symbol.

See Also

Reference

CommStudio.2 Assembly


Barcode Class

Barcode Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Barcode Class

Represents a bar code generator.

Syntax

Visual Basic (Declaration)
<LicenseProviderAttribute(CommStudio.LicenseProvider)>
Public Class Barcode
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
[LicenseProviderAttribute(CommStudio.LicenseProvider)]
public class Barcode : MarshalByRefObject
Delphi
public class Barcode = class(MarshalByRefObject)

Remarks

Implements IDisposable. The user should call Dispose() when the object instance in no more necessary.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
CommStudio.Barcodes.Barcode

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Barcode Members
CommStudio.Barcodes Namespace


Barcode Class Members

Barcode Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor | Overloaded. Default constructor.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Specifies the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
Public Property | BackColor | Color of the background.
Public Property | Bounds | After a call to Render contains the Rectanglethat bounds the rendered bar code.
Public Property | CaptionFont | Is the Font used to display the Caption if enabled (see DisplayCaption).
Public Property | DisplayCaption | Enable/Disable the display of the Caption in the bar code symbol.
Public Property | EncodedText | After a call to Render contains the string finally encoded including the check digits if they exist.
Public Property | ForeColor | Color of the bar code.
Public Property | LayoutMode | Get/Set the value of the LayoutMode.
Public Property | ModuleRatio | Get/Set the ratio of the wide to the narrow module in bar code styles with two module widths.
Public Property | ModuleWidth | Get/Set the witdh of the bar code module.
Public Property | Orientation | Specifies the BarcodeOrientation of the bar code.
Public Property | Style | Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Frees all resources associated with the Barcode
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Renders the bar code in the supplied layout rectangle.
Public Method | Validate | Validates the passed text against the selected bar code style. Barcode.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Destructor. Called by the GC only if the user does not call Dispose()
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Barcode Class
CommStudio.Barcodes Namespace


Barcode Constructor

Barcode Constructor
See Also
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Barcode Constructor

Default constructor.

Overload List

Overload | Description
Barcode Constructor() | Default constructor.
Barcode Constructor(BarcodeStyle) | Creates a bar code with a given style.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Barcode Constructor()

Barcode Constructor()
See Also
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class > Barcode Constructor : Barcode Constructor()

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Barcode()
C#
public Barcode()
Delphi
public Barcode();

Remarks

The default constructor creates a bar code with a Code39 style.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members
Overload List


Barcode Constructor(BarcodeStyle)

Barcode Constructor(BarcodeStyle)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class > Barcode Constructor : Barcode Constructor(BarcodeStyle)

style
Style of the bar code.
Creates a bar code with a given style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As BarcodeStyle _
)
Visual Basic (Usage) Copy Code
Dim style As BarcodeStyle

Dim instance As Barcode(style)
C#
public Barcode(
   BarcodeStyle style
)
Delphi
public Barcode(
    style: BarcodeStyle
);

Parameters

style
Style of the bar code.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members
Overload List


Barcode Class Methods

Barcode Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Frees all resources associated with the Barcode
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Renders the bar code in the supplied layout rectangle.
Public Method | Validate | Validates the passed text against the selected bar code style. Barcode.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Destructor. Called by the GC only if the user does not call Dispose()
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Barcode Class
CommStudio.Barcodes Namespace


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Dispose Method

Frees all resources associated with the Barcode

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Finalize Method

Finalize Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Finalize Method

Destructor. Called by the GC only if the user does not call Dispose()

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As Barcode

instance.Finalize()
C#
protected override void Finalize()
Delphi
protected procedure Finalize(); override;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Render Method

Render Method
See Also Example
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Render Method

text
Text to encode.
graphics
Graphics object where the bar code will be rendered.
rect
Layout rectangle for the bar code.
Renders the bar code in the supplied layout rectangle.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal text As String, _
   ByVal graphics As Graphics, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim text As String
Dim graphics As Graphics
Dim rect As Rectangle

instance.Render(text, graphics, rect)
C#
public void Render(
   string text,
   Graphics graphics,
   Rectangle rect
)
Delphi
public procedure Render(
    text: String;
    graphics: Graphics;
    rect: Rectangle
);

Parameters

text
Text to encode.
graphics
Graphics object where the bar code will be rendered.
rect
Layout rectangle for the bar code.

Exceptions

Exception | Description
ArgumentException | Thrown when one or more characters are not supported with the selected style.

Example

C# Copy Code

//Consider a Form with a PictureBox pictureBox1 on it.

//Create the Barcode object (Style defaults to Code39).
Barcode bc = new Barcode();

//Get a Graphic object from the PictureBox (The image has to be created first!).
Graphics g = Graphics.FromImage(pictureBox1.Image);

//Render the bar code.
bc.Render("123456", g, pictureBox1.ClientRectangle);

//Dispose resources.
g.Dispose();
bc.Dispose();

Remarks

Note that the Rectangle argumet is passed by reference. When returning, the variable will hold the exact rectangle where the bar code symbol was rendered. This is usefull if some other information has to be displayed in a position relative to the symbol.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Validate Method

Validate Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Validate Method

text
true if a StringText to validate.
allowExceptions
true if a ArgumentException should be thrown if there are invalid characters.
Validates the passed text against the selected bar code style. Barcode.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal text As String, _
   ByVal allowExceptions As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim text As String
Dim allowExceptions As Boolean
Dim value As Boolean

value = instance.Validate(text, allowExceptions)
C#
public bool Validate(
   string text,
   bool allowExceptions
)
Delphi
public function Validate(
    text: String;
    allowExceptions: Boolean
): Boolean;

Parameters

text
true if a StringText to validate.
allowExceptions
true if a ArgumentException should be thrown if there are invalid characters.

Return Value

True if the supplied text is compatible with the selected bar code stype or false otherwise.

Exceptions

Exception | Description
ArgumentException | Thrown if there are characters not compatible with the selected bar code style.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

Barcode Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | Alignment | Specifies the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.
Public Property | BackColor | Color of the background.
Public Property | Bounds | After a call to Render contains the Rectanglethat bounds the rendered bar code.
Public Property | CaptionFont | Is the Font used to display the Caption if enabled (see DisplayCaption).
Public Property | DisplayCaption | Enable/Disable the display of the Caption in the bar code symbol.
Public Property | EncodedText | After a call to Render contains the string finally encoded including the check digits if they exist.
Public Property | ForeColor | Color of the bar code.
Public Property | LayoutMode | Get/Set the value of the LayoutMode.
Public Property | ModuleRatio | Get/Set the ratio of the wide to the narrow module in bar code styles with two module widths.
Public Property | ModuleWidth | Get/Set the witdh of the bar code module.
Public Property | Orientation | Specifies the BarcodeOrientation of the bar code.
Public Property | Style | Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set.
Top

See Also

Reference

Barcode Class
CommStudio.Barcodes Namespace


Alignment Property

Alignment Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Alignment Property

Specifies the BarcodeAlignment of the bar code symbol in the layout rectangle. Defaults to Center.

Syntax

Visual Basic (Declaration)
Public Property Alignment As BarcodeAlignment
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As BarcodeAlignment

instance.Alignment = value

value = instance.Alignment
C#
public BarcodeAlignment Alignment {get; set;}
Delphi
public read-write property Alignment: BarcodeAlignment;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


BackColor Property

BackColor Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : BackColor Property

Color of the background.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Delphi
public read-write property BackColor: Color;

Return Value

A Color object

Remarks

Usually White

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Bounds Property

Bounds Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Bounds Property

After a call to Render contains the Rectanglethat bounds the rendered bar code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Rectangle

value = instance.Bounds
C#
public Rectangle Bounds {get;}
Delphi
public read-only property Bounds: Rectangle;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


CaptionFont Property

CaptionFont Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : CaptionFont Property

Is the Font used to display the Caption if enabled (see DisplayCaption).

Syntax

Visual Basic (Declaration)
Public Property CaptionFont As Font
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Font

instance.CaptionFont = value

value = instance.CaptionFont
C#
public Font CaptionFont {get; set;}
Delphi
public read-write property CaptionFont: Font;

Remarks

If no Font is supplied a default "Arial" 8pt is used.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


DisplayCaption Property

DisplayCaption Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : DisplayCaption Property

Enable/Disable the display of the Caption in the bar code symbol.

Syntax

Visual Basic (Declaration)
Public Property DisplayCaption As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Boolean

instance.DisplayCaption = value

value = instance.DisplayCaption
C#
public bool DisplayCaption {get; set;}
Delphi
public read-write property DisplayCaption: Boolean;

Remarks

The Caption shows the original string without any additional character, like check digits, that might be appended to the final encoded string.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


EncodedText Property

EncodedText Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : EncodedText Property

After a call to Render contains the string finally encoded including the check digits if they exist.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EncodedText As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

value = instance.EncodedText
C#
public string EncodedText {get;}
Delphi
public read-only property EncodedText: String;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


ForeColor Property

ForeColor Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : ForeColor Property

Color of the bar code.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: Color;

Return Value

A Color object

Remarks

Usually Black

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


LayoutMode Property

LayoutMode Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : LayoutMode Property

Get/Set the value of the LayoutMode.

Syntax

Visual Basic (Declaration)
Public Property LayoutMode As BarcodeLayoutMode
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As BarcodeLayoutMode

instance.LayoutMode = value

value = instance.LayoutMode
C#
public BarcodeLayoutMode LayoutMode {get; set;}
Delphi
public read-write property LayoutMode: BarcodeLayoutMode;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


ModuleRatio Property

ModuleRatio Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : ModuleRatio Property

Get/Set the ratio of the wide to the narrow module in bar code styles with two module widths.

Syntax

Visual Basic (Declaration)
Public Property ModuleRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.ModuleRatio = value

value = instance.ModuleRatio
C#
public float ModuleRatio {get; set;}
Delphi
public read-write property ModuleRatio: Single;

Exceptions

Exception | Description
ArgumentException | Thrown if the users attempts to set a value less than 1.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


ModuleWidth Property

ModuleWidth Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : ModuleWidth Property

Get/Set the witdh of the bar code module.

Syntax

Visual Basic (Declaration)
Public Property ModuleWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Integer

instance.ModuleWidth = value

value = instance.ModuleWidth
C#
public int ModuleWidth {get; set;}
Delphi
public read-write property ModuleWidth: Integer;

Exceptions

Exception | Description
ArgumentException | Thrown if the users attempts to set a value less or equal zero.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Orientation Property

Orientation Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Orientation Property

Specifies the BarcodeOrientation of the bar code.

Syntax

Visual Basic (Declaration)
Public Property Orientation As BarcodeOrientation
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As BarcodeOrientation

instance.Orientation = value

value = instance.Orientation
C#
public BarcodeOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: BarcodeOrientation;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


Style Property

Style Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Barcode Class : Style Property

Specifies the BarcodeStyle or Symbology for the bar code. This determines the supported character set.

Syntax

Visual Basic (Declaration)
Public Property Style As BarcodeStyle
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As BarcodeStyle

instance.Style = value

value = instance.Style
C#
public BarcodeStyle Style {get; set;}
Delphi
public read-write property Style: BarcodeStyle;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Barcode Class
Barcode Members


DataMatrix Class

DataMatrix Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix Class

Summary description for Class1.

Syntax

Visual Basic (Declaration)
<LicenseProviderAttribute(CommStudio.LicenseProvider)>
Public Class DataMatrix
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
C#
[LicenseProviderAttribute(CommStudio.LicenseProvider)]
public class DataMatrix : MarshalByRefObject
Delphi
public class DataMatrix = class(MarshalByRefObject)

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
CommStudio.Barcodes.DataMatrix

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

DataMatrix Members
CommStudio.Barcodes Namespace


DataMatrix Class Members

DataMatrix Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix Class

The following tables list the members exposed by DataMatrix.

Public Constructors

 | Name | Description
Public Constructor | DataMatrix Constructor | Instance Constructor.
Top

Public Properties

 | Name | Description
Public Property | BackColor | DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.
Public Property | Bounds | After a call to Render returns the exact position of the bidimensional bar code.
Public Property | Columns | After a call to Render returns how many Columns has the resulting symbol.
Public Property | Encoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public Property | ForeColor | DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.
Public Property | ModuleSize | Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.
Public Property | Orientation | Gets, set the Orientation of the DataMatrix symbol.
Public Property | Rows | After a call to Render returns how many Rows has the resulting symbol.
Public Property | Size | Gets or set the SymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Disposes the instance.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Overloaded. Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Instance Finalizer.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

DataMatrix Class
CommStudio.Barcodes Namespace


DataMatrix Constructor

DataMatrix Constructor
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : DataMatrix Constructor

Instance Constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix()
C#
public DataMatrix()
Delphi
public DataMatrix();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


DataMatrix Class Methods

DataMatrix Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix Class

For a list of all members of this type, see DataMatrix members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Disposes the instance.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Overloaded. Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Instance Finalizer.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

DataMatrix Class
CommStudio.Barcodes Namespace


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Dispose Method

Disposes the instance.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Finalize Method

Finalize Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Finalize Method

Instance Finalizer.

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix

instance.Finalize()
C#
protected override void Finalize()
Delphi
protected procedure Finalize(); override;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Render Method

Render Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Render Method

Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.

Overload List

Overload | Description
Render(Byte[],Graphics,Rectangle) | Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.
Render(String,Graphics,Rectangle) | Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected SymbolEncoding.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Render(Byte[],Graphics,Rectangle) Method

Render(Byte[],Graphics,Rectangle) Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class > Render Method : Render(Byte[],Graphics,Rectangle) Method

buffer
The stream of bytes to be encoded in the DataMatrix symbol.
g
The Graphics object where the symbol will be rendered.
rect
The Rectangle where the DataMatrix symbol will be centered.
Renders a sequence of bytes as a DataMatrix symbol. Base256 is used.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Render( _
   ByVal buffer() As Byte, _
   ByVal g As Graphics, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim buffer() As Byte
Dim g As Graphics
Dim rect As Rectangle

instance.Render(buffer, g, rect)
C#
public void Render(
   byte[] buffer,
   Graphics g,
   Rectangle rect
)
Delphi
public procedure Render(
    buffer: Bytearray of;
    g: Graphics;
    rect: Rectangle
);

Parameters

buffer
The stream of bytes to be encoded in the DataMatrix symbol.
g
The Graphics object where the symbol will be rendered.
rect
The Rectangle where the DataMatrix symbol will be centered.

Remarks

The Encoding setting is ignored when calling this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members
Overload List


Render(String,Graphics,Rectangle) Method

Render(String,Graphics,Rectangle) Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class > Render Method : Render(String,Graphics,Rectangle) Method

text
The string of characters to be encoded in the DataMatrix symbol.
g
The Graphics object where the symbol will be rendered.
rect
The Rectangle where the DataMatrix symbol will be centered.
Renders a string of characters as a DataMatrix symbol. The characters are encoded according to the selected SymbolEncoding.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Render( _
   ByVal text As String, _
   ByVal g As Graphics, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim text As String
Dim g As Graphics
Dim rect As Rectangle

instance.Render(text, g, rect)
C#
public void Render(
   string text,
   Graphics g,
   Rectangle rect
)
Delphi
public procedure Render(
    text: String;
    g: Graphics;
    rect: Rectangle
);

Parameters

text
The string of characters to be encoded in the DataMatrix symbol.
g
The Graphics object where the symbol will be rendered.
rect
The Rectangle where the DataMatrix symbol will be centered.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members
Overload List


DataMatrix Class Properties

DataMatrix Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix Class

For a list of all members of this type, see DataMatrix members.

Public Properties

 | Name | Description
Public Property | BackColor | DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.
Public Property | Bounds | After a call to Render returns the exact position of the bidimensional bar code.
Public Property | Columns | After a call to Render returns how many Columns has the resulting symbol.
Public Property | Encoding | Gets and Set the Encoding scheme to use. Defaults to Auto.
Public Property | ForeColor | DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.
Public Property | ModuleSize | Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.
Public Property | Orientation | Gets, set the Orientation of the DataMatrix symbol.
Public Property | Rows | After a call to Render returns how many Rows has the resulting symbol.
Public Property | Size | Gets or set the SymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.
Top

See Also

Reference

DataMatrix Class
CommStudio.Barcodes Namespace


BackColor Property

BackColor Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : BackColor Property

DataMatrix supports both dark-on-light and light-on-dark symbols. BackColor defaults to white.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Delphi
public read-write property BackColor: Color;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Bounds Property

Bounds Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Bounds Property

After a call to Render returns the exact position of the bidimensional bar code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Rectangle

value = instance.Bounds
C#
public Rectangle Bounds {get;}
Delphi
public read-only property Bounds: Rectangle;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Columns Property

Columns Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Columns Property

After a call to Render returns how many Columns has the resulting symbol.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Integer

value = instance.Columns
C#
public int Columns {get;}
Delphi
public read-only property Columns: Integer;

Remarks

Read only.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Encoding Property

Encoding Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Encoding Property

Gets and Set the Encoding scheme to use. Defaults to Auto.

Syntax

Visual Basic (Declaration)
Public Property Encoding As DataMatrix.SymbolEncoding
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As DataMatrix.SymbolEncoding

instance.Encoding = value

value = instance.Encoding
C#
public DataMatrix.SymbolEncoding Encoding {get; set;}
Delphi
public read-write property Encoding: DataMatrix.SymbolEncoding;

Remarks

If in the data supplied in Render are characters incompatible with the selected encoding mode an Exception is thrown.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


ForeColor Property

ForeColor Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : ForeColor Property

DataMatrix supports both dark-on-light and light-on-dark symbols. ForeColor defaults to black.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: Color;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


ModuleSize Property

ModuleSize Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : ModuleSize Property

Gets or set the size of the smalles square element in the symbol. Defaults to 20 mils.

Syntax

Visual Basic (Declaration)
Public Property ModuleSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Integer

instance.ModuleSize = value

value = instance.ModuleSize
C#
public int ModuleSize {get; set;}
Delphi
public read-write property ModuleSize: Integer;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Orientation Property

Orientation Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Orientation Property

Gets, set the Orientation of the DataMatrix symbol.

Syntax

Visual Basic (Declaration)
Public Property Orientation As DataMatrix.SymbolOrientation
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As DataMatrix.SymbolOrientation

instance.Orientation = value

value = instance.Orientation
C#
public DataMatrix.SymbolOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: DataMatrix.SymbolOrientation;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Rows Property

Rows Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Rows Property

After a call to Render returns how many Rows has the resulting symbol.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As Integer

value = instance.Rows
C#
public int Rows {get;}
Delphi
public read-only property Rows: Integer;

Remarks

Read only.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Size Property

Size Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > DataMatrix Class : Size Property

Gets or set the SymbolSize to use. Defaults to Auto and the final size will be the smaller possible for the supplied data.

Syntax

Visual Basic (Declaration)
Public Property Size As DataMatrix.SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix
Dim value As DataMatrix.SymbolSize

instance.Size = value

value = instance.Size
C#
public DataMatrix.SymbolSize Size {get; set;}
Delphi
public read-write property Size: DataMatrix.SymbolSize;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

DataMatrix Class
DataMatrix Members


Pdf417 Class

Pdf417 Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417 Class

PDF417 bar code generator.

Syntax

Visual Basic (Declaration)
<LicenseProviderAttribute(CommStudio.LicenseProvider)>
Public Class Pdf417
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
C#
[LicenseProviderAttribute(CommStudio.LicenseProvider)]
public class Pdf417 : MarshalByRefObject
Delphi
public class Pdf417 = class(MarshalByRefObject)

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
CommStudio.Barcodes.Pdf417

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Pdf417 Members
CommStudio.Barcodes Namespace


Pdf417 Class Members

Pdf417 Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417 Class

The following tables list the members exposed by Pdf417.

Public Constructors

 | Name | Description
Public Constructor | Pdf417 Constructor | Default constructor.
Top

Public Properties

 | Name | Description
Public Property | Bounds | After a call to Render, returns the Rectangle bounding the PDF417 Symbol.
Public Property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public Property | ErrorCorrectionLevel | Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Public Property | Layout | Get/Set the value of the Layout.
Public Property | ModuleHeight | The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.
Public Property | ModuleWidth | The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.
Public Property | Orientation | Get/Set the value of the bar code Orientation"/>.
Public Property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Public Property | Truncated | Indicates that the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Implementation of IDisposable
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Overloaded. Creates the PDF417 bar code.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Destructor. Should never be called.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Pdf417 Class
CommStudio.Barcodes Namespace


Pdf417 Constructor

Pdf417 Constructor
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Pdf417 Constructor

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Pdf417()
C#
public Pdf417()
Delphi
public Pdf417();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Pdf417 Class Methods

Pdf417 Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417 Class

For a list of all members of this type, see Pdf417 members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Implementation of IDisposable
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Render | Overloaded. Creates the PDF417 bar code.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Destructor. Should never be called.
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Pdf417 Class
CommStudio.Barcodes Namespace


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Dispose Method

Implementation of IDisposable

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Pdf417

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Finalize Method

Finalize Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Finalize Method

Destructor. Should never be called.

Syntax

Visual Basic (Declaration)
Overrides Protected Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As Pdf417

instance.Finalize()
C#
protected override void Finalize()
Delphi
protected procedure Finalize(); override;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Render Method

Render Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Render Method

Creates the PDF417 bar code.

Overload List

Overload | Description
Render(Byte[],Graphics,Rectangle) | Creates the PDF417 bar code.
Render(String,Graphics,Rectangle) | Creates the PDF417 bar code.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Render(Byte[],Graphics,Rectangle) Method

Render(Byte[],Graphics,Rectangle) Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class > Render Method : Render(Byte[],Graphics,Rectangle) Method

bytes
Array of bytes to encode.
g
Graphic object where the bar code will be rendered.
rect
Layout rectangle in the graphic object where the bar code symbol will be centered.
Creates the PDF417 bar code.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Render( _
   ByVal bytes() As Byte, _
   ByVal g As Graphics, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim bytes() As Byte
Dim g As Graphics
Dim rect As Rectangle

instance.Render(bytes, g, rect)
C#
public void Render(
   byte[] bytes,
   Graphics g,
   Rectangle rect
)
Delphi
public procedure Render(
    bytes: Bytearray of;
    g: Graphics;
    rect: Rectangle
);

Parameters

bytes
Array of bytes to encode.
g
Graphic object where the bar code will be rendered.
rect
Layout rectangle in the graphic object where the bar code symbol will be centered.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members
Overload List


Render(String,Graphics,Rectangle) Method

Render(String,Graphics,Rectangle) Method
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class > Render Method : Render(String,Graphics,Rectangle) Method

text
The characters to encode. If text consists only of digits then Numeric Encoding is used, otherwise Text Encoding is used.
g
Graphic object where the bar code will be rendered.
rect
Layout rectangle in the graphic object where the bar code symbol will be centered.
Creates the PDF417 bar code.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Render( _
   ByVal text As String, _
   ByVal g As Graphics, _
   ByVal rect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim text As String
Dim g As Graphics
Dim rect As Rectangle

instance.Render(text, g, rect)
C#
public void Render(
   string text,
   Graphics g,
   Rectangle rect
)
Delphi
public procedure Render(
    text: String;
    g: Graphics;
    rect: Rectangle
);

Parameters

text
The characters to encode. If text consists only of digits then Numeric Encoding is used, otherwise Text Encoding is used.
g
Graphic object where the bar code will be rendered.
rect
Layout rectangle in the graphic object where the bar code symbol will be centered.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members
Overload List


Pdf417 Class Properties

Pdf417 Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417 Class

For a list of all members of this type, see Pdf417 members.

Public Properties

 | Name | Description
Public Property | Bounds | After a call to Render, returns the Rectangle bounding the PDF417 Symbol.
Public Property | Columns | Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.
Public Property | ErrorCorrectionLevel | Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.
Public Property | Layout | Get/Set the value of the Layout.
Public Property | ModuleHeight | The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.
Public Property | ModuleWidth | The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.
Public Property | Orientation | Get/Set the value of the bar code Orientation"/>.
Public Property | Rows | Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.
Public Property | Truncated | Indicates that the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.
Top

See Also

Reference

Pdf417 Class
CommStudio.Barcodes Namespace


Bounds Property

Bounds Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Bounds Property

After a call to Render, returns the Rectangle bounding the PDF417 Symbol.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Rectangle

value = instance.Bounds
C#
public Rectangle Bounds {get;}
Delphi
public read-only property Bounds: Rectangle;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Columns Property

Columns Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Columns Property

Number of data columns in the symbol. Note that appart from data columns a symbol has start/stop columns and left and right row indicators. That is why a symbol printed with Columns = 1 will appear to have 5 columsn when printed. Acceptable values are in the range 1-30. The product Rows*Columns cannot exceed 925.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Delphi
public read-write property Columns: Integer;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


ErrorCorrectionLevel Property

ErrorCorrectionLevel Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : ErrorCorrectionLevel Property

Error Correction Level. Determines how many extra Error Correction Codewords (ECC) will be encoded in the final symbol to allow the posibility of recovering from damage in the symbol.

Syntax

Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Integer

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
C#
public int ErrorCorrectionLevel {get; set;}
Delphi
public read-write property ErrorCorrectionLevel: Integer;

Remarks

Only values in the range 0-8 are valid. Depending on the value of the Error Correction Level different number of Error Correction Codewords (ECC) are appended. In any Layout if the User selects a valid Error Correction Level that value is respected.
Error Correction Level | Codewords
0 | 2
1 | 4
2 | 8
3 | 16
4 | 32
5 | 64
6 | 128
7 | 256
8 | 512
AIM (Automatic Identification Manufacturers) Standard for PDF417 recommends the following EC Levels depending on the amount of Data:
Data Codewords | Recommended EC Level
1-40 | 2
41-160 | 3
161-320 | 4
321-863 | 5

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Layout Property

Layout Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Layout Property

Get/Set the value of the Layout.

Syntax

Visual Basic (Declaration)
Public Property Layout As Pdf417.SymbolLayout
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Pdf417.SymbolLayout

instance.Layout = value

value = instance.Layout
C#
public Pdf417.SymbolLayout Layout {get; set;}
Delphi
public read-write property Layout: Pdf417.SymbolLayout;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


ModuleHeight Property

ModuleHeight Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : ModuleHeight Property

The height of module, equivalent to the height of a row. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.

Syntax

Visual Basic (Declaration)
Public Property ModuleHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Integer

instance.ModuleHeight = value

value = instance.ModuleHeight
C#
public int ModuleHeight {get; set;}
Delphi
public read-write property ModuleHeight: Integer;

Remarks

Using ScaleTransform PageScale any desired ModuleWidth value can be obtained.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


ModuleWidth Property

ModuleWidth Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : ModuleWidth Property

The width of module, the smallest element in the symbol. The units will be determined by the PageUnit of the Graphics in Render. By default for printing the units are Document which corresponds to 10 mils per unit.

Syntax

Visual Basic (Declaration)
Public Property ModuleWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Integer

instance.ModuleWidth = value

value = instance.ModuleWidth
C#
public int ModuleWidth {get; set;}
Delphi
public read-write property ModuleWidth: Integer;

Remarks

Using ScaleTransform PageScale any desired ModuleWidth value can be obtained.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Orientation Property

Orientation Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Orientation Property

Get/Set the value of the bar code Orientation"/>.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Pdf417.SymbolOrientation
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Pdf417.SymbolOrientation

instance.Orientation = value

value = instance.Orientation
C#
public Pdf417.SymbolOrientation Orientation {get; set;}
Delphi
public read-write property Orientation: Pdf417.SymbolOrientation;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Rows Property

Rows Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Rows Property

Number of rows in the symbol. Acceptable values are in the range 3-90. The product Rows*Columns cannot exceed 925.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Delphi
public read-write property Rows: Integer;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


Truncated Property

Truncated Property
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace > Pdf417 Class : Truncated Property

Indicates that the Stop pattern and Right Row Indicator at the end of each row can be omitted resulting in a smaller symbol.

Syntax

Visual Basic (Declaration)
Public Property Truncated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Pdf417
Dim value As Boolean

instance.Truncated = value

value = instance.Truncated
C#
public bool Truncated {get; set;}
Delphi
public read-write property Truncated: Boolean;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Pdf417 Class
Pdf417 Members


BarcodeAlignment Enumeration

BarcodeAlignment Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : BarcodeAlignment Enumeration

Possible alignment values of the bar code symbol relative to its layout rectangle.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeAlignment
C#
public enum BarcodeAlignment : Enum
Delphi
public enum BarcodeAlignment = class(Enum)

Members

Member | Description
Near | Specifies the symbol be aligned at the near end of the layout rectangle.
Center | Specifies the symbol be aligned at the center the layout.
Far | Specifies the symbol be aligned at the far end of the layout rectangle.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.BarcodeAlignment

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace
BarcodeOrientation Enumeration


BarcodeLayoutMode Enumeration

BarcodeLayoutMode Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : BarcodeLayoutMode Enumeration

Describes how the ModuleWidth and ModuleRatio of the bar code are handled: calculated automatically trying to fit the Rectangle supplied in Render or following the user's settings.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeLayoutMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeLayoutMode
C#
public enum BarcodeLayoutMode : Enum
Delphi
public enum BarcodeLayoutMode = class(Enum)

Members

Member | Description
Auto | ModuleWidth and ModuleRatio are calculated automatically from the information supplied in the Render method.
Manual | ModuleWidth and ModuleRatio have to be set by the user.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.BarcodeLayoutMode

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


BarcodeOrientation Enumeration

BarcodeOrientation Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : BarcodeOrientation Enumeration

Possible orientation values for the bar code symbol. Specifies in what direction the bar code symbol is drawn.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeOrientation
C#
public enum BarcodeOrientation : Enum
Delphi
public enum BarcodeOrientation = class(Enum)

Members

Member | Description
Right | The symbol is drawn from Left to Right.
Left | The symbol is drawn from Right to Left.
Up | The symbol is drawn from Bottom to Top.
Down | The symbol is drawn from Top to Bottom.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.BarcodeOrientation

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


BarcodeStyle Enumeration

BarcodeStyle Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : BarcodeStyle Enumeration

Different styles or bar code symbologies to use. The style determines the supported character set.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeStyle
C#
public enum BarcodeStyle : Enum
Delphi
public enum BarcodeStyle = class(Enum)

Members

Member | Description
MsiPlessey | MSI/Plessey Symbology. Variable length numeric symbology. A modulo 10 check digit is always appended to the encoded string.
Interleaved2of5 | Interleaved 2 of 5 Symbology. Variable length numeric symbology. A leading zero is appended to make the total number of characters even if necessary.
Interleaved2of5Chk | Interleaved 2 of 5 with Check Digit. The same as the Interleaved 2 of 5 with an appended modulo 10 check digit.
Codabar | Codabar Symbology. Variable length symbology. Supports digits 0-9 and six special alphanumeric characters, capital letters A through D.
Code39 | Code 39 or Code 3 of 9. Variable length alphanumeric symbology. It supports 26 uppercase letters, 10 digits and 7 special characters (space, -, ., $, %, / and +). The asterisk * is used as start/stop character.
Code39Chk | The same as Code 39 with a modulo 43 Check Digit.
Code39Ext | Code 39 Extended. Supports the full 128 ASCII character set.
Code39ExtChk | The same as Code 39 Extended with a module 43 Check Digit appended.
Code93 | Code 93. Encodes digits 0–9, capital letters A through Z, and characters -, ., $, %, /, + and ' ' (space) . Two weighted modulo 47 check digits are appended to the encoded string.
Code93Ext | Extended Code 93. Encodes the full 128 ASCII character set. Two weighted modulo 47 check digits are appended.
Code128A | Code 128-A. Variable length alphanumeric symbology. Character supported include capital letters A-Z, digits 0-9, punctuation marks, signs and special control characters. A modulo 103 check digit is always appended.
Code128B | Code 128 B. Similar to Code 128 A but with the inclusion of lower case latters replacing some of the signs.
Code128C | Code 128 C. High density numeric symbology.. The total number of digits must be even. A leading zero is appended if necessary. A modulo 103 check digit is appended.
UpcA | UPC A. Fixed length numeric symbology. Only 11 digits can be supplied and an check digit will be always appended to make the total number of digits 12.
UpcE | UPC E. Fixed length seven digit numeric bar code. Six digits must be supplied and a check digit will be appended. If an 11 digit UPC A string is supplied the translation will be performed if possible.
Ean13 | EAN 13. Fixed length 13 digits (including the check digit) numeric code similar to UPC A.
Ean8 | EAN 8. Fixed length 8 digits (including the check digit) numeric code.
Postnet | Postnet. Numeric symbology. As used by the U.S. Postal Service has a fixed length (not enforced by CommStudio.Barcodes) and an modulo 10 check digit that is appended automatically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.BarcodeStyle

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


DataMatrix.SymbolEncoding Enumeration

DataMatrix.SymbolEncoding Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix.SymbolEncoding Enumeration

DataMatrix supports six different encoding schemes or modes. Each scheme has its native character set for which achieves maximum efficiency.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrix.SymbolEncoding
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix.SymbolEncoding
C#
public enum DataMatrix.SymbolEncoding : Enum
Delphi
public enum DataMatrix.SymbolEncoding = class(Enum)

Members

Member | Description
Auto | The data is encoded in the best possible way using all the available encodation modes. Auto is the default mode.
ASCII | Encodes all 127 standard ASCII characters as well as the extended ASCII character set 128-255.
C40 | Encodes all characters from the standard and extended ASCII sets. Is more efficient than ASCII encodation for upper-case alphabetic and numeric characters.
Text | Encodes all characters from the standard and extended ASCII sets. Is more efficient than ASCII encodation for lower-case alphabetic and numeric characters.
X12 | Encodes only A-Z, 0-9, space and X12 control characters with ASCII values 13, 42 and 62.
EDIFACT | Encodes characters from the standard ASCII set in the range 32 through 94 which includes all upper and lower case alphabetic letters, numbers 0-9, the space as well as many symbols and punctuation characters.
Base256 | Encodes characters in the range 0-255. Adecuate for the encodation of binary data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.DataMatrix.SymbolEncoding

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


DataMatrix.SymbolOrientation Enumeration

DataMatrix.SymbolOrientation Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix.SymbolOrientation Enumeration

Possible orientations for the DataMatrix bar code symbol.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrix.SymbolOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix.SymbolOrientation
C#
public enum DataMatrix.SymbolOrientation : Enum
Delphi
public enum DataMatrix.SymbolOrientation = class(Enum)

Members

Member | Description
Horizontal | The DataMatrix bar code will be rendered horizontally.
Vertical | The DataMatrix will be rendered vertically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.DataMatrix.SymbolOrientation

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


DataMatrix.SymbolSize Enumeration

DataMatrix.SymbolSize Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : DataMatrix.SymbolSize Enumeration

DataMatrix supports square symbols with sizes from 10x10 up to 144x144 as well as six different rectangular symbols from 8x18 to 16x48. If SymbolSize.Auto is selected then the smaller symbol fr the given amount of data is automatically selected.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrix.SymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrix.SymbolSize
C#
public enum DataMatrix.SymbolSize : Enum
Delphi
public enum DataMatrix.SymbolSize = class(Enum)

Members

Member | Description
Auto | The size is determined by the length of the data supplied.
S010x010 | 10 rows x 10 columns.
S012x012 | 12 rows x 12 columns.
S014x014 | 14 rows x 14 columns.
S016x016 | 16 rows x 16 columns.
S018x018 | 18 rows x 18 columns.
S020x020 | 20 rows x 20 columns.
S022x022 | 22 rows x 22 columns.
S024x024 | 24 rows x 24 columns.
S026x026 | 26 rows x 26 columns.
S032x032 | 32 rows x 32 columns.
S036x036 | 36 rows x 36 columns.
S040x040 | 40 rows x 40 columns.
S044x044 | 44 rows x 44 columns.
S048x048 | 48 rows x 48 columns.
S052x052 | 52 rows x 52 columns.
S064x064 | 64 rows x 64 columns.
S072x072 | 72 rows x 72 columns.
S080x080 | 80 rows x 80 columns.
S088x088 | 88 rows x 88 columns.
S096x096 | 96 rows x 96 columns.
S104x104 | 104 rows x 104 columns.
S120x120 | 120 rows x 120 columns.
S132x132 | 132 rows x 132 columns.
S144x144 | 144 rows x 144 columns.
R008x018 | 8 rows x 18 columns.
R008x032 | 8 rows x 32 columns.
R012x026 | 12 rows x 26 columns.
R012x036 | 12 rows x 36 columns.
R016x036 | 16 rows x 36 columns.
R016x048 | 16 rows x 48 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.DataMatrix.SymbolSize

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


Pdf417.SymbolLayout Enumeration

Pdf417.SymbolLayout Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417.SymbolLayout Enumeration

Describes how the layout of the PDF417 bar code is calculated: how many rows and columns the symbol will have, the ModuleWidth and ModuleHeight values, the Orientation and the Error Correction Level.

Syntax

Visual Basic (Declaration)
Public Enum Pdf417.SymbolLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Pdf417.SymbolLayout
C#
public enum Pdf417.SymbolLayout : Enum
Delphi
public enum Pdf417.SymbolLayout = class(Enum)

Members

Member | Description
Auto | All bar code parameters (rows, columns, orientation, module dimensions and Error Correction Level are calculated automatically from the information supplied in the Render method. Nevertheless, if the User sets the values for ErrorCorrectionLevel, ModuleWidth or ModuleHeight they are not changed.
Manual | All bar code parameters have to be set by the user. In case the values are incompatible with the data supplied in the method Render an ArgumentException will ne thrown.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.Pdf417.SymbolLayout

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


Pdf417.SymbolOrientation Enumeration

Pdf417.SymbolOrientation Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Barcodes Namespace : Pdf417.SymbolOrientation Enumeration

Possible orientations for the PDF417 bar code symbol.

Syntax

Visual Basic (Declaration)
Public Enum Pdf417.SymbolOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Pdf417.SymbolOrientation
C#
public enum Pdf417.SymbolOrientation : Enum
Delphi
public enum Pdf417.SymbolOrientation = class(Enum)

Members

Member | Description
Horizontal | The PDF417 bar code will be rendered horizontally.
Vertical | The PDF417 will be rendered vertically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Barcodes.Pdf417.SymbolOrientation

Requirements

Namespace: CommStudio.Barcodes

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Barcodes Namespace


CommStudio.Connections Namespace

CommStudio.Connections Namespace
See Also Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Connections Namespace

Classes

Class | Description
CommunicationsLockedPortException | Thrown when the port is locked from public usage by an active file transfer.
Connection | Implements the base functionality for a connection.
Connection.CommErrorEventArgs | Data to be used for the communication error event handler.
ConnectionKey | Defines the key used to temporarily lock out all other functions from transmitting through a device.
SerialConnection | Lets you connect directly to a serial port.
SerialPortInfo | Describes a serial port that is installed on the system.

Structures

Structure | Description
SerialOptions | Defines the settings for a serial port connection.

Delegates

Delegate | Description
Connection.DataAvailableEventHandler | Event fired when new data is waiting in the input buffer.
Connection.DeviceErrorEventHandler | Event fired when an error happens while waiting on a device event.
SerialConnection.BreakEventHandler | Event fired when a 'break' is detected on input.
SerialConnection.CarrierEventHandler | Event fired when the Carrier signal changes.
SerialConnection.CtsEventHandler | Event fired when CTS signal changed.
SerialConnection.DsrEventHandler | Event fired when the DSR signal has changed on input.
SerialConnection.RingEventHandler | Fired when a ring indicator is detected.
SerialConnection.WriteCompleteEventHandler | Event fires when the last character in the output buffer was sent.

Enumerations

Enumeration | Description
CommStopBits | Defines the valid number of stop bits which may be used
Parity | Defines the type of parity checking that should be performed.
WaitMethod | Defines the method used when waiting for data.

See Also

Reference

CommStudio.2 Assembly


CommunicationsLockedPortException Class

CommunicationsLockedPortException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : CommunicationsLockedPortException Class

Thrown when the port is locked from public usage by an active file transfer.

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class CommunicationsLockedPortException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As CommunicationsLockedPortException
C#
[SerializableAttribute()]
public class CommunicationsLockedPortException : ApplicationException
Delphi
public class CommunicationsLockedPortException = class(ApplicationException)

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
CommStudio.Connections.CommunicationsLockedPortException

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommunicationsLockedPortException Members
CommStudio.Connections Namespace


CommunicationsLockedPortException Class Members

CommunicationsLockedPortException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : CommunicationsLockedPortException Class

The following tables list the members exposed by CommunicationsLockedPortException.

Public Constructors

 | Name | Description
Public Constructor | CommunicationsLockedPortException Constructor | Overloaded. Exception is thrown when the port is locked from public usage by an active file transfer.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

CommunicationsLockedPortException Class
CommStudio.Connections Namespace


CommunicationsLockedPortException Constructor

CommunicationsLockedPortException Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > CommunicationsLockedPortException Class : CommunicationsLockedPortException Constructor

Exception is thrown when the port is locked from public usage by an active file transfer.

Overload List

Overload | Description
CommunicationsLockedPortException Constructor() | Exception is thrown when the port is locked from public usage by an active file transfer.
CommunicationsLockedPortException Constructor(SerializationInfo,StreamingContext) | Exception is thrown when the port is locked from public usage by an active file transfer.
CommunicationsLockedPortException Constructor(String) | Exception is thrown when the port is locked from public usage by an active file transfer.
CommunicationsLockedPortException Constructor(String,Exception) | Exception is thrown when the port is locked from public usage by an active file transfer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

CommunicationsLockedPortException Class
CommunicationsLockedPortException Members


CommunicationsLockedPortException Constructor()

CommunicationsLockedPortException Constructor()
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > CommunicationsLockedPortException Class > CommunicationsLockedPortException Constructor : CommunicationsLockedPortException Constructor()

Exception is thrown when the port is locked from public usage by an active file transfer.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CommunicationsLockedPortException()
C#
public CommunicationsLockedPortException()
Delphi
public CommunicationsLockedPortException();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

CommunicationsLockedPortException Class
CommunicationsLockedPortException Members
Overload List


CommunicationsLockedPortException Constructor(SerializationInfo,StreamingContext)

CommunicationsLockedPortException Constructor(SerializationInfo,StreamingContext)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > CommunicationsLockedPortException Class > CommunicationsLockedPortException Constructor : CommunicationsLockedPortException Constructor(SerializationInfo,StreamingContext)

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.
Exception is thrown when the port is locked from public usage by an active file transfer.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As CommunicationsLockedPortException(info, context)
C#
protected CommunicationsLockedPortException(
   SerializationInfo info,
   StreamingContext context
)
Delphi
protected CommunicationsLockedPortException(
    info: SerializationInfo;
    context: StreamingContext
);

Parameters

info
The object that holds the serialized object data.
context
The contextual information about the source or destination.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

CommunicationsLockedPortException Class
CommunicationsLockedPortException Members
Overload List


CommunicationsLockedPortException Constructor(String)

CommunicationsLockedPortException Constructor(String)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > CommunicationsLockedPortException Class > CommunicationsLockedPortException Constructor : CommunicationsLockedPortException Constructor(String)

message
A message that describes the error.
Exception is thrown when the port is locked from public usage by an active file transfer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As CommunicationsLockedPortException(message)
C#
public CommunicationsLockedPortException(
   string message
)
Delphi
public CommunicationsLockedPortException(
    message: String
);

Parameters

message
A message that describes the error.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

CommunicationsLockedPortException Class
CommunicationsLockedPortException Members
Overload List


CommunicationsLockedPortException Constructor(String,Exception)

CommunicationsLockedPortException Constructor(String,Exception)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > CommunicationsLockedPortException Class > CommunicationsLockedPortException Constructor : CommunicationsLockedPortException Constructor(String,Exception)

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Exception is thrown when the port is locked from public usage by an active file transfer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As CommunicationsLockedPortException(message, innerException)
C#
public CommunicationsLockedPortException(
   string message,
   Exception innerException
)
Delphi
public CommunicationsLockedPortException(
    message: String;
    innerException: Exception
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

CommunicationsLockedPortException Class
CommunicationsLockedPortException Members
Overload List


Connection Class

Connection Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection Class

Implements the base functionality for a connection.

Syntax

Visual Basic (Declaration)
Public MustInherit Class Connection
   Inherits Component
Visual Basic (Usage) Copy Code
Dim instance As Connection
C#
public abstract class Connection : Component
Delphi
public class Connection = class(Component)abstract;

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CommStudio.Connections.Connection
CommStudio.Connections.SerialConnection

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Connection Members
CommStudio.Connections Namespace


Connection Class Members

Connection Class Members
See Also Properties Methods Events
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection Class

The following tables list the members exposed by Connection.

Protected Constructors

 | Name | Description
Protected Constructor | Connection Constructor | Overloaded. Creates a new instance of the Connection class in the specified container
Top

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if a status dialog should be shown when a new connection is established.
Public Property | Available | Returns the number of bytes available in the input buffer.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DataAvailableThreshold | Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired. The argument cannot be negative.
Public Property | Encoding | Defines the type of encoding used when converting between text strings and byte arrays.
Public Property | Handle | Returns the operating system-level handle of the connection.
Public Property | IsOpen | Gets a value indicating whether the current connection is open
Public Property | ReadTimeOut | Defines the number of milliseconds the control should wait for data from the port.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads
Public Property | WaitMethod | Defines the method used when waiting for data.
Public Property | WriteTimeOut | Defines the number of milliseconds the control should wait for data write into the port.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | BeginLock | Locks the current connection from use except by methods which know the correct key.
Public Method | Close | Closes the connection to the current device
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Disposes of the resources used by the object
Public Method | EndLock | Unlocks the connection so that any method may access the read/write abilities.
Public Method | Flush | Overloaded. Clears all buffers for this connection and causes any buffered data to be discarded
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Open | Opens a connection to the device
Public Method | Peek | Overloaded. Returns the next available character but does not consume it.
Public Method | Read | Overloaded. Reads bytes from the serial port into a byte array, not checking for locked condition.
Public Method | ReadLine | Overloaded. Reads a line of text from the serial port.
Public Method | ReadUntil | Overloaded. Reads until a specified string is found.
Public Method | ShowPropertiesDialog | Overloaded. Shows a properties dialog to change the settings of this connection with the specified owner
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | WaitForInput | Overloaded. Wait for a certain number of bytes to be input using current Read timeout value.
Public Method | Write | Overloaded. Writes bytes from a byte array to the serial port, not checking for locked condition.
Top

Protected Methods

 | Name | Description
Protected Method | EmptyReceiveQueue | Empties the input queue of all data, waiting a specified time for it to empty.
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | FireBreakReceived | Method to call when a break was encountered.
Protected Method | FireCarrierChanged | Method to call when the carrier signal changed.
Protected Method | FireClosed | Method to call an attempt to close a connection was completed.
Protected Method | FireCtsChanged | Method to call when the CTS signal changed.
Protected Method | FireDsrChanged | Method to call when the DSR signal changed.
Protected Method | FireOpened | Method to call when an attempt to establish a new connection has been completed.
Protected Method | FireRingDetected | Method to call when the CTS signal changed.
Protected Method | FireWriteBufferEmpty | Method to call when last character in write buffer was sent.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | SupportsEightBitProtocol | Makes sure the current connection is valid for 8-bit protocols (X and Y Modem).
Protected Method | ValidKey | Lets you verify if the product can be used with the supplied key.
Top

Public Events

 | Name | Description
Public Event | Closed | Event fired when an attempt to establish a new connection was completed.
Public Event | DataAvailable | Event fired when new data is waiting in the input buffer.
Public Event | DeviceError | Event fired when an error happens while waiting on a device event.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Opened | Event fired when an attempt to establish a new connection was completed.
Top

See Also

Reference

Connection Class
CommStudio.Connections Namespace


Connection Constructor

Connection Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Connection Constructor

Creates a new instance of the Connection class in the specified container

Overload List

Overload | Description
Connection Constructor() | Initializes a new instances of the Connection class
Connection Constructor(IContainer) | Creates a new instance of the Connection class in the specified container

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Connection Constructor()

Connection Constructor()
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Connection Constructor : Connection Constructor()

Initializes a new instances of the Connection class

Syntax

Visual Basic (Declaration)
Protected Function New()
Visual Basic (Usage) Copy Code
Dim instance As Connection()
C#
protected Connection()
Delphi
protected Connection();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Connection Constructor(IContainer)

Connection Constructor(IContainer)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Connection Constructor : Connection Constructor(IContainer)

container
Container to place this new instance of the Connection class.
Creates a new instance of the Connection class in the specified container

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As Connection(container)
C#
protected Connection(
   IContainer container
)
Delphi
protected Connection(
    container: IContainer
);

Parameters

container
Container to place this new instance of the Connection class.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Connection Class Methods

Connection Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection Class

For a list of all members of this type, see Connection members.

Public Methods

 | Name | Description
Public Method | BeginLock | Locks the current connection from use except by methods which know the correct key.
Public Method | Close | Closes the connection to the current device
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Disposes of the resources used by the object
Public Method | EndLock | Unlocks the connection so that any method may access the read/write abilities.
Public Method | Flush | Overloaded. Clears all buffers for this connection and causes any buffered data to be discarded
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Open | Opens a connection to the device
Public Method | Peek | Overloaded. Returns the next available character but does not consume it.
Public Method | Read | Overloaded. Reads bytes from the serial port into a byte array, not checking for locked condition.
Public Method | ReadLine | Overloaded. Reads a line of text from the serial port.
Public Method | ReadUntil | Overloaded. Reads until a specified string is found.
Public Method | ShowPropertiesDialog | Overloaded. Shows a properties dialog to change the settings of this connection with the specified owner
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | WaitForInput | Overloaded. Wait for a certain number of bytes to be input using current Read timeout value.
Public Method | Write | Overloaded. Writes bytes from a byte array to the serial port, not checking for locked condition.
Top

Protected Methods

 | Name | Description
Protected Method | EmptyReceiveQueue | Empties the input queue of all data, waiting a specified time for it to empty.
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | FireBreakReceived | Method to call when a break was encountered.
Protected Method | FireCarrierChanged | Method to call when the carrier signal changed.
Protected Method | FireClosed | Method to call an attempt to close a connection was completed.
Protected Method | FireCtsChanged | Method to call when the CTS signal changed.
Protected Method | FireDsrChanged | Method to call when the DSR signal changed.
Protected Method | FireOpened | Method to call when an attempt to establish a new connection has been completed.
Protected Method | FireRingDetected | Method to call when the CTS signal changed.
Protected Method | FireWriteBufferEmpty | Method to call when last character in write buffer was sent.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | SupportsEightBitProtocol | Makes sure the current connection is valid for 8-bit protocols (X and Y Modem).
Protected Method | ValidKey | Lets you verify if the product can be used with the supplied key.
Top

See Also

Reference

Connection Class
CommStudio.Connections Namespace


BeginLock Method

BeginLock Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : BeginLock Method

key
Generic object to use as the key.
Locks the current connection from use except by methods which know the correct key.

Syntax

Visual Basic (Declaration)
Public Sub BeginLock( _
   ByVal key As ConnectionKey _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim key As ConnectionKey

instance.BeginLock(key)
C#
public void BeginLock(
   ConnectionKey key
)
Delphi
public procedure BeginLock(
    key: ConnectionKey
);

Parameters

key
Generic object to use as the key.

Exceptions

Exception | Description
CommunicationsLockedPortException | Attempt to lock a connection which is already locked.

Remarks

The primary purpose of locking is for a protocol to shield unwanted calls from modifying the required data stream. This method should be called when starting your protocol.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Close Method

Close Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Close Method

Closes the connection to the current device

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Connection

instance.Close()
C#
public virtual abstract void Close()
Delphi
public procedure Close(); virtual; abstract;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Dispose Method

Disposes of the resources used by the object

Overload List

Overload | Description
Dispose(Boolean) | Disposes of the resources used by the object
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Dispose Method : Dispose(Boolean) Method

disposing
Determines if the code was called directly by the user's code
Disposes of the resources used by the object

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;

Parameters

disposing
Determines if the code was called directly by the user's code

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


EmptyReceiveQueue Method

EmptyReceiveQueue Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : EmptyReceiveQueue Method

timeout
Maximum time to wait for the queue to remain empty.
key
Key as defined by the user (may be null for no key).
Empties the input queue of all data, waiting a specified time for it to empty.

Syntax

Visual Basic (Declaration)
Protected Overridable MustOverride Function EmptyReceiveQueue( _
   ByVal timeout As Integer, _
   ByVal key As ConnectionKey _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim timeout As Integer
Dim key As ConnectionKey
Dim value As Boolean

value = instance.EmptyReceiveQueue(timeout, key)
C#
protected virtual abstract bool EmptyReceiveQueue(
   int timeout,
   ConnectionKey key
)
Delphi
protected function EmptyReceiveQueue(
    timeout: Integer;
    key: ConnectionKey
): Boolean; virtual; abstract;

Parameters

timeout
Maximum time to wait for the queue to remain empty.
key
Key as defined by the user (may be null for no key).

Return Value

If the queue is empty upon return.

Remarks

The function will return when the earliest of: a read timeout or the specified timeout are reached. This method only affects the input (read) queue.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


EndLock Method

EndLock Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : EndLock Method

key
Generic object currently used as the key.
Unlocks the connection so that any method may access the read/write abilities.

Syntax

Visual Basic (Declaration)
Public Sub EndLock( _
   ByVal key As ConnectionKey _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim key As ConnectionKey

instance.EndLock(key)
C#
public void EndLock(
   ConnectionKey key
)
Delphi
public procedure EndLock(
    key: ConnectionKey
);

Parameters

key
Generic object currently used as the key.

Exceptions

Exception | Description
CommunicationsLockedPortException | Attempt to lock a connection which is already locked.

Remarks

The primary purpose of locking is for a protocol to shield unwanted calls from modifying the required data stream. This method should be called when your protocol as completed.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireBreakReceived Method

FireBreakReceived Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireBreakReceived Method

Method to call when a break was encountered.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireBreakReceived() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireBreakReceived()
C#
protected virtual bool FireBreakReceived()
Delphi
protected function FireBreakReceived(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireCarrierChanged Method

FireCarrierChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireCarrierChanged Method

Method to call when the carrier signal changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireCarrierChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireCarrierChanged()
C#
protected virtual bool FireCarrierChanged()
Delphi
protected function FireCarrierChanged(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireClosed Method

FireClosed Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireClosed Method

Method to call an attempt to close a connection was completed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireClosed() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireClosed()
C#
protected virtual bool FireClosed()
Delphi
protected function FireClosed(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireCtsChanged Method

FireCtsChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireCtsChanged Method

Method to call when the CTS signal changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireCtsChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireCtsChanged()
C#
protected virtual bool FireCtsChanged()
Delphi
protected function FireCtsChanged(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireDsrChanged Method

FireDsrChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireDsrChanged Method

Method to call when the DSR signal changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireDsrChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireDsrChanged()
C#
protected virtual bool FireDsrChanged()
Delphi
protected function FireDsrChanged(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireOpened Method

FireOpened Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireOpened Method

Method to call when an attempt to establish a new connection has been completed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireOpened() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireOpened()
C#
protected virtual bool FireOpened()
Delphi
protected function FireOpened(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireRingDetected Method

FireRingDetected Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireRingDetected Method

Method to call when the CTS signal changed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireRingDetected() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireRingDetected()
C#
protected virtual bool FireRingDetected()
Delphi
protected function FireRingDetected(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


FireWriteBufferEmpty Method

FireWriteBufferEmpty Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : FireWriteBufferEmpty Method

Method to call when last character in write buffer was sent.

Syntax

Visual Basic (Declaration)
Protected Overridable Function FireWriteBufferEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.FireWriteBufferEmpty()
C#
protected virtual bool FireWriteBufferEmpty()
Delphi
protected function FireWriteBufferEmpty(): Boolean; virtual;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

This is the base version which does nothing, you should derive a functional version from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Flush Method

Flush Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Flush Method

Clears all buffers for this connection and causes any buffered data to be discarded

Overload List

Overload | Description
Flush() | Clears all buffers for this connection and causes any buffered data to be discarded
Flush(Boolean,Int32) | Allows timeout to clear all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.
Flush(Boolean) | Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Flush() Method

Flush() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Flush Method : Flush() Method

Clears all buffers for this connection and causes any buffered data to be discarded

Syntax

Visual Basic (Declaration)
Overloads Public Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Connection

instance.Flush()
C#
public void Flush()
Delphi
public procedure Flush();

Remarks

The output buffer will be emptied while ensuring that the contents are transmitted (a synchronous operation). This is subject to flow control but not to write time-outs, and it will not return until all pending write operations have been transmitted. Also, this will not affect the contents of the input buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Flush(Boolean,Int32) Method

Flush(Boolean,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Flush Method : Flush(Boolean,Int32) Method

discard
Indicates whether any buffered data should be discarded.
timeout
Number of milliseconds to wait before aborting the flush.
Allows timeout to clear all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Sub Flush( _
   ByVal discard As Boolean, _
   ByVal timeout As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim discard As Boolean
Dim timeout As Integer

instance.Flush(discard, timeout)
C#
public virtual abstract void Flush(
   bool discard,
   int timeout
)
Delphi
public procedure Flush(
    discard: Boolean;
    timeout: Integer
); virtual; abstract;

Parameters

discard
Indicates whether any buffered data should be discarded.
timeout
Number of milliseconds to wait before aborting the flush.

Exceptions

Exception | Description
Exception | Timeout expired prior to completion of non-discard flush.

Remarks

Setting 'discard' to 'true' will flush the input and output buffers, the deleted characters are not transmitted. Setting 'discard' to 'false' will empty the output buffer while ensuring that the contents are transmitted (a synchronous operation). This last option is subject to flow control but not to write time-outs, and it will not return until all pending write operations have been transmitted. Also, a setting of 'false' will not affect the input buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Flush(Boolean) Method

Flush(Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Flush Method : Flush(Boolean) Method

discard
Indicates whether any buffered data should be discarded.
Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Sub Flush( _
   ByVal discard As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim discard As Boolean

instance.Flush(discard)
C#
public virtual abstract void Flush(
   bool discard
)
Delphi
public procedure Flush(
    discard: Boolean
); virtual; abstract;

Parameters

discard
Indicates whether any buffered data should be discarded.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Open Method

Open Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Open Method

Opens a connection to the device

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Sub Open()
Visual Basic (Usage) Copy Code
Dim instance As Connection

instance.Open()
C#
public virtual abstract void Open()
Delphi
public procedure Open(); virtual; abstract;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Peek Method

Peek Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Peek Method

Returns the next available character but does not consume it.

Overload List

Overload | Description
Peek() | Returns the next available character but does not consume it.
Peek(ConnectionKey) | Returns the next available character but does not consume it (key protected version).

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Peek() Method

Peek() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Peek Method : Peek() Method

Returns the next available character but does not consume it.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Peek() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

value = instance.Peek()
C#
public virtual abstract int Peek()
Delphi
public function Peek(): Integer; virtual; abstract;

Return Value

The next character to be read, or -1 if no characters are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Peek(ConnectionKey) Method

Peek(ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Peek Method : Peek(ConnectionKey) Method

key
Key as defined by the user (may be null for no key).
Returns the next available character but does not consume it (key protected version).

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Peek( _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim key As ConnectionKey
Dim value As Integer

value = instance.Peek(key)
C#
public virtual abstract int Peek(
   ConnectionKey key
)
Delphi
public function Peek(
    key: ConnectionKey
): Integer; virtual; abstract;

Parameters

key
Key as defined by the user (may be null for no key).

Return Value

The next character to be read, or -1 if no characters are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Read Method

Read Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Read Method

Reads bytes from the serial port into a byte array, not checking for locked condition.

Overload List

Overload | Description
Read(Byte[],Int32,Int32,ConnectionKey) | Reads bytes from the serial port into a byte array, not checking for locked condition.
Read(ConnectionKey) | Reads a byte from the connection or -1 if no bytes are available.
Read(Byte[],Int32,Int32) | Reads bytes from the serial port into a byte array.
Read(Int32) | Reads the specified number of bytes from the connection and returns them as a string.
Read() | Reads a byte from the connection or -1 if no bytes are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Read(Byte[],Int32,Int32,ConnectionKey) Method

Read(Byte[],Int32,Int32,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Read Method : Read(Byte[],Int32,Int32,ConnectionKey) Method

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
key
Communication locking key.
Reads bytes from the serial port into a byte array, not checking for locked condition.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim key As ConnectionKey
Dim value As Integer

value = instance.Read(buffer, offset, count, key)
C#
public virtual abstract int Read(
   byte[] buffer,
   int offset,
   int count,
   ConnectionKey key
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    key: ConnectionKey
): Integer; virtual; abstract;

Parameters

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
key
Communication locking key.

Return Value

The number of characters read into buffer. This might be less than the number of bytes requested if that many bytes are not available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Read(ConnectionKey) Method

Read(ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Read Method : Read(ConnectionKey) Method

key
Communication locking key.
Reads a byte from the connection or -1 if no bytes are available.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Read( _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim key As ConnectionKey
Dim value As Integer

value = instance.Read(key)
C#
public virtual abstract int Read(
   ConnectionKey key
)
Delphi
public function Read(
    key: ConnectionKey
): Integer; virtual; abstract;

Parameters

key
Communication locking key.

Return Value

The byte that was read, or -1 if no bytes are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Read(Byte[],Int32,Int32) Method

Read(Byte[],Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
Reads bytes from the serial port into a byte array.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public virtual abstract int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; virtual; abstract;

Parameters

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.

Return Value

The number of characters read into buffer. This might be less than the number of bytes requested if that many bytes are not available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Read(Int32) Method

Read(Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Read Method : Read(Int32) Method

count
The number of bytes to read.
Reads the specified number of bytes from the connection and returns them as a string.

Syntax

Visual Basic (Declaration)
Overloads Public Function Read( _
   ByVal count As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim count As Integer
Dim value As String

value = instance.Read(count)
C#
public string Read(
   int count
)
Delphi
public function Read(
    count: Integer
): String;

Parameters

count
The number of bytes to read.

Return Value

The bytes read, converted to a string using the current Encoding.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Read() Method

Read() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Read Method : Read() Method

Reads a byte from the connection or -1 if no bytes are available.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Read() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

value = instance.Read()
C#
public virtual abstract int Read()
Delphi
public function Read(): Integer; virtual; abstract;

Return Value

The byte that was read, or -1 if no bytes are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ReadLine Method

ReadLine Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : ReadLine Method

Reads a line of text from the serial port.

Overload List

Overload | Description
ReadLine() | Reads a line of text from the serial port.
ReadLine(Int32) | Reads a line of text from the serial port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


ReadLine() Method

ReadLine() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ReadLine Method : ReadLine() Method

Reads a line of text from the serial port.

Syntax

Visual Basic (Declaration)
Overloads Public Function ReadLine() As String
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As String

value = instance.ReadLine()
C#
public string ReadLine()
Delphi
public function ReadLine(): String;

Return Value

The line of text, not including the carriage return or line feed.

Remarks

The maximum length of the line is 1024 characters.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ReadLine(Int32) Method

ReadLine(Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ReadLine Method : ReadLine(Int32) Method

maxCount
The maximum length of the line, not including the carriage return or line feed
Reads a line of text from the serial port.

Syntax

Visual Basic (Declaration)
Overloads Public Function ReadLine( _
   ByVal maxCount As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim maxCount As Integer
Dim value As String

value = instance.ReadLine(maxCount)
C#
public string ReadLine(
   int maxCount
)
Delphi
public function ReadLine(
    maxCount: Integer
): String;

Parameters

maxCount
The maximum length of the line, not including the carriage return or line feed

Return Value

The line of text, not including the carriage return or line feed.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ReadUntil Method

ReadUntil Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : ReadUntil Method

Reads until a specified string is found.

Overload List

Overload | Description
ReadUntil(Int32,String,Boolean) | Reads until a specified string is found.
ReadUntil(Int32,String[],Int32) | Reads until one of the specified strings is found.
ReadUntil(Int32,Byte[],Boolean) | Reads until a specified string is found.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


ReadUntil(Int32,String,Boolean) Method

ReadUntil(Int32,String,Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ReadUntil Method : ReadUntil(Int32,String,Boolean) Method

maxCount
The maximum number of bytes to read.
match
The string to be found.
found
true if the string was found.
Reads until a specified string is found.

Syntax

Visual Basic (Declaration)
Overloads Public Function ReadUntil( _
   ByVal maxCount As Integer, _
   ByVal match As String, _
   ByRef found As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim maxCount As Integer
Dim match As String
Dim found As Boolean
Dim value As String

value = instance.ReadUntil(maxCount, match, found)
C#
public string ReadUntil(
   int maxCount,
   string match,
   ref bool found
)
Delphi
public function ReadUntil(
    maxCount: Integer;
    match: String;
   var  found: Boolean
): String;

Parameters

maxCount
The maximum number of bytes to read.
match
The string to be found.
found
true if the string was found.

Return Value

The data which has been read.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ReadUntil(Int32,String[],Int32) Method

ReadUntil(Int32,String[],Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ReadUntil Method : ReadUntil(Int32,String[],Int32) Method

maxCount
The maximum number of bytes to read.
matches
An array of strings to be found.
matchIndex
Value assigned upon return. A zero based index into the 'matches' array to which the item was found. '-1' when the item was not found.
Reads until one of the specified strings is found.

Syntax

Visual Basic (Declaration)
Overloads Public Function ReadUntil( _
   ByVal maxCount As Integer, _
   ByVal matches() As String, _
   ByRef matchIndex As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim maxCount As Integer
Dim matches() As String
Dim matchIndex As Integer
Dim value As String

value = instance.ReadUntil(maxCount, matches, matchIndex)
C#
public string ReadUntil(
   int maxCount,
   string[] matches,
   ref int matchIndex
)
Delphi
public function ReadUntil(
    maxCount: Integer;
    matches: Stringarray of;
   var  matchIndex: Integer
): String;

Parameters

maxCount
The maximum number of bytes to read.
matches
An array of strings to be found.
matchIndex
Value assigned upon return. A zero based index into the 'matches' array to which the item was found. '-1' when the item was not found.

Return Value

Data which was read (ends with match from supplied list).

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ReadUntil(Int32,Byte[],Boolean) Method

ReadUntil(Int32,Byte[],Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ReadUntil Method : ReadUntil(Int32,Byte[],Boolean) Method

maxCount
The maximum number of bytes to read.
match
The array of bytes to be found.
found
true if the string was found.
Reads until a specified string is found.

Syntax

Visual Basic (Declaration)
Overloads Public Function ReadUntil( _
   ByVal maxCount As Integer, _
   ByVal match() As Byte, _
   ByRef found As Boolean _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim maxCount As Integer
Dim match() As Byte
Dim found As Boolean
Dim value() As Byte

value = instance.ReadUntil(maxCount, match, found)
C#
public byte[] ReadUntil(
   int maxCount,
   byte[] match,
   ref bool found
)
Delphi
public function ReadUntil(
    maxCount: Integer;
    match: Bytearray of;
   var  found: Boolean
): array of Byte;

Parameters

maxCount
The maximum number of bytes to read.
match
The array of bytes to be found.
found
true if the string was found.

Return Value

The data which has been read.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ShowPropertiesDialog Method

ShowPropertiesDialog Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : ShowPropertiesDialog Method

Shows a properties dialog to change the settings of this connection with the specified owner

Overload List

Overload | Description
ShowPropertiesDialog(IWin32Window) | Shows a properties dialog to change the settings of this connection with the specified owner
ShowPropertiesDialog() | Shows a properties dialog to change the settings of this connection with a default owner

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


ShowPropertiesDialog(IWin32Window) Method

ShowPropertiesDialog(IWin32Window) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ShowPropertiesDialog Method : ShowPropertiesDialog(IWin32Window) Method

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.
Shows a properties dialog to change the settings of this connection with the specified owner

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function ShowPropertiesDialog( _
   ByVal owner As IWin32Window _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim owner As IWin32Window
Dim value As DialogResult

value = instance.ShowPropertiesDialog(owner)
C#
public virtual abstract DialogResult ShowPropertiesDialog(
   IWin32Window owner
)
Delphi
public function ShowPropertiesDialog(
    owner: IWin32Window
): DialogResult; virtual; abstract;

Parameters

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


ShowPropertiesDialog() Method

ShowPropertiesDialog() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > ShowPropertiesDialog Method : ShowPropertiesDialog() Method

Shows a properties dialog to change the settings of this connection with a default owner

Syntax

Visual Basic (Declaration)
Overloads Public Function ShowPropertiesDialog() As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As DialogResult

value = instance.ShowPropertiesDialog()
C#
public DialogResult ShowPropertiesDialog()
Delphi
public function ShowPropertiesDialog(): DialogResult;

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


SupportsEightBitProtocol Method

SupportsEightBitProtocol Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : SupportsEightBitProtocol Method

Makes sure the current connection is valid for 8-bit protocols (X and Y Modem).

Syntax

Visual Basic (Declaration)
Protected Overridable Function SupportsEightBitProtocol() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.SupportsEightBitProtocol()
C#
protected virtual bool SupportsEightBitProtocol()
Delphi
protected function SupportsEightBitProtocol(): Boolean; virtual;

Return Value

If this connection will support the protocol.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


ValidKey Method

ValidKey Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : ValidKey Method

key
Key as defined by the user (may be null for no key).
Lets you verify if the product can be used with the supplied key.

Syntax

Visual Basic (Declaration)
Protected Function ValidKey( _
   ByVal key As ConnectionKey _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim key As ConnectionKey
Dim value As Boolean

value = instance.ValidKey(key)
C#
protected bool ValidKey(
   ConnectionKey key
)
Delphi
protected function ValidKey(
    key: ConnectionKey
): Boolean;

Parameters

key
Key as defined by the user (may be null for no key).

Return Value

If it is OK to use the product given the key.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


WaitForInput Method

WaitForInput Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : WaitForInput Method

Wait for a certain number of bytes to be input using current Read timeout value.

Overload List

Overload | Description
WaitForInput(Int32) | Wait for a certain number of bytes to be input using current Read timeout value.
WaitForInput(Int32,Int32,Int32) | Wait for a certain number of bytes to be input, allows complete definition of timeout.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


WaitForInput(Int32) Method

WaitForInput(Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > WaitForInput Method : WaitForInput(Int32) Method

count
Number of bytes to wait for.
Wait for a certain number of bytes to be input using current Read timeout value.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function WaitForInput( _
   ByVal count As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim count As Integer
Dim value As Boolean

value = instance.WaitForInput(count)
C#
public virtual abstract bool WaitForInput(
   int count
)
Delphi
public function WaitForInput(
    count: Integer
): Boolean; virtual; abstract;

Parameters

count
Number of bytes to wait for.

Return Value

If the requested number of bytes are available for reading.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


WaitForInput(Int32,Int32,Int32) Method

WaitForInput(Int32,Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > WaitForInput Method : WaitForInput(Int32,Int32,Int32) Method

count
Number of bytes to wait for.
waitConst
Minimum amount of time to wait for input bytes.
waitMult
Milliseconds to wait for each byte to appear in the queue (default=0).
Wait for a certain number of bytes to be input, allows complete definition of timeout.

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable MustOverride Function WaitForInput( _
   ByVal count As Integer, _
   ByVal waitConst As Integer, _
   ByVal waitMult As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim count As Integer
Dim waitConst As Integer
Dim waitMult As Integer
Dim value As Boolean

value = instance.WaitForInput(count, waitConst, waitMult)
C#
protected virtual abstract bool WaitForInput(
   int count,
   int waitConst,
   int waitMult
)
Delphi
protected function WaitForInput(
    count: Integer;
    waitConst: Integer;
    waitMult: Integer
): Boolean; virtual; abstract;

Parameters

count
Number of bytes to wait for.
waitConst
Minimum amount of time to wait for input bytes.
waitMult
Milliseconds to wait for each byte to appear in the queue (default=0).

Return Value

true if the requested number of bytes are available for reading.

Exceptions

Exception | Description
IOException | The specified port is not open.

Remarks

The total time waiting for the specified bytes will be the constant value + the multiplier*[Total bytes waiting for].

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Write Method

Write Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Write Method

Writes bytes from a byte array to the serial port, not checking for locked condition.

Overload List

Overload | Description
Write(Byte[],Int32,Int32,ConnectionKey) | Writes bytes from a byte array to the serial port, not checking for locked condition.
Write(Byte,ConnectionKey) | Writes a byte to the connection.
Write(Byte[],Int32,Int32) | Writes bytes from a byte array to the serial port.
Write(String) | Writes the specified string to the connection.
Write(Byte) | Writes a byte to the connection.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Write(Byte[],Int32,Int32,ConnectionKey) Method

Write(Byte[],Int32,Int32,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Write Method : Write(Byte[],Int32,Int32,ConnectionKey) Method

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
key
Communication locking key.
Writes bytes from a byte array to the serial port, not checking for locked condition.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim key As ConnectionKey
Dim value As Integer

value = instance.Write(buffer, offset, count, key)
C#
public virtual abstract int Write(
   byte[] buffer,
   int offset,
   int count,
   ConnectionKey key
)
Delphi
public function Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    key: ConnectionKey
): Integer; virtual; abstract;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
key
Communication locking key.

Return Value

Returns the number of bytes written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Write(Byte,ConnectionKey) Method

Write(Byte,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Write Method : Write(Byte,ConnectionKey) Method

b
The byte that should be written.
key
Communication locking key.
Writes a byte to the connection.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Sub Write( _
   ByVal b As Byte, _
   ByVal key As ConnectionKey _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim b As Byte
Dim key As ConnectionKey

instance.Write(b, key)
C#
public virtual abstract void Write(
   byte b,
   ConnectionKey key
)
Delphi
public procedure Write(
    b: Byte;
    key: ConnectionKey
); virtual; abstract;

Parameters

b
The byte that should be written.
key
Communication locking key.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Write(Byte[],Int32,Int32) Method

Write(Byte[],Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
Writes bytes from a byte array to the serial port.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Write(buffer, offset, count)
C#
public virtual abstract int Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; virtual; abstract;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.

Return Value

Returns the number of bytes written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Write(String) Method

Write(String) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Write Method : Write(String) Method

outputText
The text that should be written, which is converted using the current Encoding.
Writes the specified string to the connection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Write( _
   ByVal outputText As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim outputText As String

instance.Write(outputText)
C#
public void Write(
   string outputText
)
Delphi
public procedure Write(
    outputText: String
);

Parameters

outputText
The text that should be written, which is converted using the current Encoding.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Write(Byte) Method

Write(Byte) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class > Write Method : Write(Byte) Method

b
The byte that should be written.
Writes a byte to the connection.

Syntax

Visual Basic (Declaration)
Overloads Public Overridable MustOverride Sub Write( _
   ByVal b As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim b As Byte

instance.Write(b)
C#
public virtual abstract void Write(
   byte b
)
Delphi
public procedure Write(
    b: Byte
); virtual; abstract;

Parameters

b
The byte that should be written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members
Overload List


Connection Class Properties

Connection Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection Class

For a list of all members of this type, see Connection members.

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if a status dialog should be shown when a new connection is established.
Public Property | Available | Returns the number of bytes available in the input buffer.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DataAvailableThreshold | Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired. The argument cannot be negative.
Public Property | Encoding | Defines the type of encoding used when converting between text strings and byte arrays.
Public Property | Handle | Returns the operating system-level handle of the connection.
Public Property | IsOpen | Gets a value indicating whether the current connection is open
Public Property | ReadTimeOut | Defines the number of milliseconds the control should wait for data from the port.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads
Public Property | WaitMethod | Defines the method used when waiting for data.
Public Property | WriteTimeOut | Defines the number of milliseconds the control should wait for data write into the port.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Connection Class
CommStudio.Connections Namespace


AutoShowStatusDialog Property

AutoShowStatusDialog Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : AutoShowStatusDialog Property

Determines if a status dialog should be shown when a new connection is established.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("User Interface")>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines if a status dialog should be shown when a new connection is established.")>
Public Property AutoShowStatusDialog As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

instance.AutoShowStatusDialog = value

value = instance.AutoShowStatusDialog
C#
[BrowsableAttribute(true)]
[CategoryAttribute("User Interface")]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if a status dialog should be shown when a new connection is established.")]
public bool AutoShowStatusDialog {get; set;}
Delphi
public read-write property AutoShowStatusDialog: Boolean;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Available Property

Available Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Available Property

Returns the number of bytes available in the input buffer.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Available As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

value = instance.Available
C#
public virtual abstract int Available {get;}
Delphi
public read-only property Available: Integer; virtual; abstract;

Return Value

Number of bytes in the input buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


DataAvailableThreshold Property

DataAvailableThreshold Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : DataAvailableThreshold Property

Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired. The argument cannot be negative.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
Public Property DataAvailableThreshold As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

instance.DataAvailableThreshold = value

value = instance.DataAvailableThreshold
C#
[DescriptionAttribute("Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public int DataAvailableThreshold {get; set;}
Delphi
public read-write property DataAvailableThreshold: Integer;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Encoding Property

Encoding Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Encoding Property

Defines the type of encoding used when converting between text strings and byte arrays.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Encoding

instance.Encoding = value

value = instance.Encoding
C#
[BrowsableAttribute(false)]
public Encoding Encoding {get; set;}
Delphi
public read-write property Encoding: Encoding;

Return Value

Type of encoding to use.

Remarks

The default is ASCIIEncoding.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Handle Property

Handle Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Handle Property

Returns the operating system-level handle of the connection.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Handle As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As IntPtr

value = instance.Handle
C#
public virtual abstract IntPtr Handle {get;}
Delphi
public read-only property Handle: IntPtr; virtual; abstract;

Return Value

Handle of the communications port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


IsOpen Property

IsOpen Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : IsOpen Property

Gets a value indicating whether the current connection is open

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property IsOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Boolean

value = instance.IsOpen
C#
public virtual abstract bool IsOpen {get;}
Delphi
public read-only property IsOpen: Boolean; virtual; abstract;

Return Value

true if the connection is currently open (else it is closed)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


ReadTimeOut Property

ReadTimeOut Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : ReadTimeOut Property

Defines the number of milliseconds the control should wait for data from the port.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Property ReadTimeOut As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

instance.ReadTimeOut = value

value = instance.ReadTimeOut
C#
public virtual abstract int ReadTimeOut {get; set;}
Delphi
public read-write property ReadTimeOut: Integer; virtual; abstract;

Return Value

Maximum number of milliseconds to wait for data in the port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


SynchronizingObject Property

SynchronizingObject Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : SynchronizingObject Property

Gets or sets the object used to marshal the event handler calls issued from other threads

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The object used to marshal the event handler calls issued from communications threads")>
<BrowsableAttribute(True)>
<CategoryAttribute()>
Public Property SynchronizingObject As ISynchronizeInvoke
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As ISynchronizeInvoke

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
[DescriptionAttribute("The object used to marshal the event handler calls issued from communications threads")]
[BrowsableAttribute(true)]
[CategoryAttribute()]
public ISynchronizeInvoke SynchronizingObject {get; set;}
Delphi
public read-write property SynchronizingObject: ISynchronizeInvoke;

Remarks

When SynchronizingObject is a null reference (Nothing in Visual Basic), event methods are called on a thread from the system thread pool. For more information on system thread pools, see ThreadPool. When the component is used in a Windows Forms environment, accessing the form or any of its controls through the system thread pool might not work, or may result in an exception. Avoid this by setting SynchronizingObject to a Windows Forms component, which causes the methods that handle the events to be called on the same thread on which the component was created. If the Connection component is used inside Visual Studio .NET in a Windows Forms designer, SynchronizingObject automatically sets to the control that contains the Connection. For example, if you place a Connection on a designer for Form1 (which inherits from Form) the SynchronizingObject property of Connection is set to the instance of Form1.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


WaitMethod Property

WaitMethod Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : WaitMethod Property

Defines the method used when waiting for data.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Defines the method used when waiting for data.")>
<CategoryAttribute("Behavior")>
Public Property WaitMethod As WaitMethod
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As WaitMethod

instance.WaitMethod = value

value = instance.WaitMethod
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[DescriptionAttribute("Defines the method used when waiting for data.")]
[CategoryAttribute("Behavior")]
public WaitMethod WaitMethod {get; set;}
Delphi
public read-write property WaitMethod: WaitMethod;

Return Value

Method to use while waiting for data.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


WriteTimeOut Property

WriteTimeOut Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : WriteTimeOut Property

Defines the number of milliseconds the control should wait for data write into the port.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Property WriteTimeOut As Integer
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim value As Integer

instance.WriteTimeOut = value

value = instance.WriteTimeOut
C#
public virtual abstract int WriteTimeOut {get; set;}
Delphi
public read-write property WriteTimeOut: Integer; virtual; abstract;

Return Value

Maximum number of milliseconds to wait for the write to complete.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Connection Class Events

Connection Class Events
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection Class

For a list of all members of this type, see Connection members.

Public Events

 | Name | Description
Public Event | Closed | Event fired when an attempt to establish a new connection was completed.
Public Event | DataAvailable | Event fired when new data is waiting in the input buffer.
Public Event | DeviceError | Event fired when an error happens while waiting on a device event.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Opened | Event fired when an attempt to establish a new connection was completed.
Top

See Also

Reference

Connection Class
CommStudio.Connections Namespace


Closed Event

Closed Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Closed Event

Event fired when an attempt to establish a new connection was completed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Status")>
<DescriptionAttribute("An attempt to establish a new connection was completed.")>
<BrowsableAttribute(True)>
Public Event Closed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
[CategoryAttribute("Status")]
[DescriptionAttribute("An attempt to establish a new connection was completed.")]
[BrowsableAttribute(true)]
public event EventHandler Closed()
Delphi
public event Closed: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


DataAvailable Event

DataAvailable Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : DataAvailable Event

Event fired when new data is waiting in the input buffer.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Data is waiting in the read buffer.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Data")>
Public Event DataAvailable() As Connection.DataAvailableEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim handler As Connection.DataAvailableEventHandler

AddHandler instance.DataAvailable, handler
C#
[DescriptionAttribute("Data is waiting in the read buffer.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Data")]
public event Connection.DataAvailableEventHandler DataAvailable()
Delphi
public event DataAvailable: Connection.DataAvailableEventHandler;

Remarks

This will fire an event whenever a new set of byte(s) arrives in the input queue.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


DeviceError Event

DeviceError Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : DeviceError Event

Event fired when an error happens while waiting on a device event.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("Errors")>
<DescriptionAttribute("An error was reported by the device.")>
Public Event DeviceError() As Connection.DeviceErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim handler As Connection.DeviceErrorEventHandler

AddHandler instance.DeviceError, handler
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Errors")]
[DescriptionAttribute("An error was reported by the device.")]
public event Connection.DeviceErrorEventHandler DeviceError()
Delphi
public event DeviceError: Connection.DeviceErrorEventHandler;

Event Data

The event handler receives an argument of type Connection.CommErrorEventArgs containing data related to this event. The following Connection.CommErrorEventArgs properties provide information specific to this event.

Property | Description
Message | Returns the description of the error which triggered this event.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Opened Event

Opened Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection Class : Opened Event

Event fired when an attempt to establish a new connection was completed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("An attempt to establish a new connection was completed.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Status")>
Public Event Opened() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Connection
Dim handler As EventHandler

AddHandler instance.Opened, handler
C#
[DescriptionAttribute("An attempt to establish a new connection was completed.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Status")]
public event EventHandler Opened()
Delphi
public event Opened: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection Class
Connection Members


Connection.CommErrorEventArgs Class

Connection.CommErrorEventArgs Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection.CommErrorEventArgs Class

Data to be used for the communication error event handler.

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Class Connection.CommErrorEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As Connection.CommErrorEventArgs
C#
[ComVisibleAttribute(false)]
public class Connection.CommErrorEventArgs : EventArgs
Delphi
public class Connection.CommErrorEventArgs = class(EventArgs)

Inheritance Hierarchy

System.Object
System.EventArgs
CommStudio.Connections.Connection.CommErrorEventArgs

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Connection.CommErrorEventArgs Members
CommStudio.Connections Namespace


Connection.CommErrorEventArgs Class Members

Connection.CommErrorEventArgs Class Members
See Also Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection.CommErrorEventArgs Class

The following tables list the members exposed by Connection.CommErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | Connection.CommErrorEventArgs Constructor | Default constructor for defining the data passed when an error has occurred in the communication driver.
Top

Public Properties

 | Name | Description
Public Property | Message | Returns the description of the error which triggered this event.
Top

See Also

Reference

Connection.CommErrorEventArgs Class
CommStudio.Connections Namespace


Connection.CommErrorEventArgs Constructor

Connection.CommErrorEventArgs Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection.CommErrorEventArgs Class : Connection.CommErrorEventArgs Constructor

errorMessage
Text describing what error just occurred.
Default constructor for defining the data passed when an error has occurred in the communication driver.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal errorMessage As String _
)
Visual Basic (Usage) Copy Code
Dim errorMessage As String

Dim instance As Connection.CommErrorEventArgs(errorMessage)
C#
public Connection.CommErrorEventArgs(
   string errorMessage
)
Delphi
public Connection.CommErrorEventArgs(
    errorMessage: String
);

Parameters

errorMessage
Text describing what error just occurred.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection.CommErrorEventArgs Class
Connection.CommErrorEventArgs Members


Connection.CommErrorEventArgs Class Properties

Connection.CommErrorEventArgs Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection.CommErrorEventArgs Class

For a list of all members of this type, see Connection.CommErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Message | Returns the description of the error which triggered this event.
Top

See Also

Reference

Connection.CommErrorEventArgs Class
CommStudio.Connections Namespace


Message Property

Message Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > Connection.CommErrorEventArgs Class : Message Property

Returns the description of the error which triggered this event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As Connection.CommErrorEventArgs
Dim value As String

value = instance.Message
C#
public string Message {get;}
Delphi
public read-only property Message: String;

Return Value

Textual description of the error.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Connection.CommErrorEventArgs Class
Connection.CommErrorEventArgs Members


ConnectionKey Class

ConnectionKey Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : ConnectionKey Class

Defines the key used to temporarily lock out all other functions from transmitting through a device.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConnectionKey
Visual Basic (Usage) Copy Code
Dim instance As ConnectionKey
C#
public sealed class ConnectionKey
Delphi
public class ConnectionKey sealed;

Remarks

The primary purpose of this class is to create a unique key to be used by file transfer protocol management. During the execution of a specific transfer, it is important that all other processes and functions be prevented from either reading or writing to the device.

Inheritance Hierarchy

System.Object
CommStudio.Connections.ConnectionKey

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

ConnectionKey Members
CommStudio.Connections Namespace


ConnectionKey Class Members

ConnectionKey Class Members
See Also Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : ConnectionKey Class

The following tables list the members exposed by ConnectionKey.

Public Constructors

 | Name | Description
Public Constructor | ConnectionKey Constructor | Default constructor for the ConnectionKey object.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compare | Compares the two instances of the ConnectionKey objects.
Public Method | Equals | Overridden. Determines whether the specified Object is equal to the current ConnectionKey object.
Public Method | GetHashCode | Overridden. Returns the hash code for this instance.
Top

See Also

Reference

ConnectionKey Class
CommStudio.Connections Namespace


ConnectionKey Constructor

ConnectionKey Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > ConnectionKey Class : ConnectionKey Constructor

Default constructor for the ConnectionKey object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ConnectionKey()
C#
public ConnectionKey()
Delphi
public ConnectionKey();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

ConnectionKey Class
ConnectionKey Members


ConnectionKey Class Methods

ConnectionKey Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : ConnectionKey Class

For a list of all members of this type, see ConnectionKey members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Compare | Compares the two instances of the ConnectionKey objects.
Public Method | Equals | Overridden. Determines whether the specified Object is equal to the current ConnectionKey object.
Public Method | GetHashCode | Overridden. Returns the hash code for this instance.
Top

See Also

Reference

ConnectionKey Class
CommStudio.Connections Namespace


Compare Method

Compare Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > ConnectionKey Class : Compare Method

a
First key structure to compare
b
Second key structure to compare
Compares the two instances of the ConnectionKey objects.

Syntax

Visual Basic (Declaration)
Public Shared Function Compare( _
   ByVal a As ConnectionKey, _
   ByVal b As ConnectionKey _
) As Boolean
Visual Basic (Usage) Copy Code
Dim a As ConnectionKey
Dim b As ConnectionKey
Dim value As Boolean

value = ConnectionKey.Compare(a, b)
C#
public static bool Compare(
   ConnectionKey a,
   ConnectionKey b
)
Delphi
public function Compare(
    a: ConnectionKey;
    b: ConnectionKey
): Boolean; static;

Parameters

a
First key structure to compare
b
Second key structure to compare

Return Value

'true' if they are the same.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

ConnectionKey Class
ConnectionKey Members


Equals Method

Equals Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > ConnectionKey Class : Equals Method

other
The Object to compare with the current ConnectionKey.
Determines whether the specified Object is equal to the current ConnectionKey object.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function Equals( _
   ByVal other As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ConnectionKey
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
C#
public override bool Equals(
   object other
)
Delphi
public function Equals(
    other: TObject
): Boolean; override;

Parameters

other
The Object to compare with the current ConnectionKey.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

ConnectionKey Class
ConnectionKey Members


GetHashCode Method

GetHashCode Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > ConnectionKey Class : GetHashCode Method

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ConnectionKey
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Delphi
public function GetHashCode(): Integer; override;

Return Value

Hash code for this object.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

ConnectionKey Class
ConnectionKey Members


SerialConnection Class

SerialConnection Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection Class

Lets you connect directly to a serial port.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<LicenseProviderAttribute(CommStudio.LicenseProvider)>
Public Class SerialConnection
   Inherits Connection
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[LicenseProviderAttribute(CommStudio.LicenseProvider)]
public class SerialConnection : Connection
Delphi
public class SerialConnection = class(Connection)

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CommStudio.Connections.Connection
CommStudio.Connections.SerialConnection

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

SerialConnection Members
CommStudio.Connections Namespace


SerialConnection Class Members

SerialConnection Class Members
See Also Properties Methods Events
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection Class

The following tables list the members exposed by SerialConnection.

Public Constructors

 | Name | Description
Public Constructor | SerialConnection Constructor | Overloaded. Creates a new instance of the SerialConnection class inside a Windows Forms designer.
Top

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if a status dialog should be shown when a new connection is established. (Inherited from Connection)
Public Property | Available | Overridden. Returns the number of bytes available in the input buffer.
Public Property | Break | Suspends or restores character transmission for the device, placing the status of the Break state as set (suspended transmission) or Cleared (non-break) state.
Public Property | Carrier | Gets the status of the Carrier/Receive Line Signal Detect (RLSD) signal.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Cts | Gets the status of the Clear-To-Send (CTS) signal.
Public Property | DataAvailableThreshold | Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired. The argument cannot be negative. (Inherited from Connection)
Public Property | Dsr | Gets the status of the DSR (data-set-ready) signal.
Public Property | Dtr | Sets the status of the DTR (data-terminal-ready) signal.
Public Property | Encoding | Defines the type of encoding used when converting between text strings and byte arrays. (Inherited from Connection)
Public Property | Handle | Overridden. Returns the operating-system level handle of the communications port.
Public Property | IsOpen | Overridden. Gets a value indicating whether the current connection is open.
Public Property | Options | Determines the current serial port and its settings.
Public Property | ReadTimeOut | Overridden. Defines the number of milliseconds the control should wait for input data from the port.
Public Property | Ring | Gets the status of the Ring indicator signal.
Public Property | Rts | Sets the status (clear/send) of the RTS (request-to-send) signal.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads (Inherited from Connection)
Public Property | Unwritten | Returns the number of bytes which remain in the output buffer and are waiting to be sent.
Public Property | WaitMethod | Defines the method used when waiting for data. (Inherited from Connection)
Public Property | WriteTimeOut | Overridden. Defines the number of milliseconds the control should wait for data to travel through the output port.
Public Property | Xon | Causes the control to act as if a Xon (true) or Xoff (false) character was received.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | BeginLock | Locks the current connection from use except by methods which know the correct key. (Inherited from Connection)
Public Method | Close | Overridden. Closes the connection to the current device
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | EndLock | Unlocks the connection so that any method may access the read/write abilities. (Inherited from Connection)
Public Method | Flush | Overloaded. Overridden. Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Open | Overloaded. Overridden. Opens a connection to the device.
Public Method | Peek | Overloaded. Overridden. Returns the next available character but does not consume it.
Public Method | Read | Overloaded. Overridden. Reads bytes from the serial port into a byte array, not checking for locked condition.
Public Method | ReadLine | Overloaded. Reads a line of text from the serial port. (Inherited from Connection)
Public Method | ReadUntil | Overloaded. Reads until a specified string is found. (Inherited from Connection)
Public Method | SetOptions | Assigns the supplied options to the current device. If the device is open, then the settings will happen immediately, else they will be delayed until Open() is called.
Public Method | ShowPropertiesDialog | Overloaded. Overridden. Shows a properties dialog to change the settings of this connection with the specified owner
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | WaitForInput | Overloaded. Overridden. Wait for a certain number of bytes to be input using current Read timeout value.
Public Method | Write | Overloaded. Overridden. Writes bytes from a byte array to the serial port, not checking for locked condition.
Top

Protected Methods

 | Name | Description
Protected Method | EmptyReceiveQueue | Overridden. Empties the input queue of all data, waiting a specified time for it to empty.
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | FireBreakReceived | Overridden. Method to call when a break was encountered.
Protected Method | FireCarrierChanged | Overridden. Method to call when the carrier signal changed.
Protected Method | FireClosed | Method to call an attempt to close a connection was completed. (Inherited from Connection)
Protected Method | FireCtsChanged | Overridden. Method to call when the CTS signal changed.
Protected Method | FireDsrChanged | Overridden. Method to call when the DSR signal changed.
Protected Method | FireOpened | Method to call when an attempt to establish a new connection has been completed. (Inherited from Connection)
Protected Method | FireRingDetected | Overridden. Method to call when the ring indicator is detected.
Protected Method | FireWriteBufferEmpty | Overridden. Method to call when last character in write buffer was sent.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | SupportsEightBitProtocol | Overridden. Makes sure the current connection is valid for 8-bit protocols (X and Y Modem)
Protected Method | ValidKey | Lets you verify if the product can be used with the supplied key. (Inherited from Connection)
Protected Method | WriteUnlocked | Overloaded. Writes a byte to the connection (w/out lock checking).
Top

Public Events

 | Name | Description
Public Event | BreakReceived | Event fired when a 'break' is detected on input.
Public Event | CarrierChanged | Event Fires whenever the Carrier signal changes.
Public Event | Closed | Event fired when an attempt to establish a new connection was completed. (Inherited from Connection)
Public Event | CtsChanged | Event fired when CTS signal changed.
Public Event | DataAvailable | Event fired when new data is waiting in the input buffer. (Inherited from Connection)
Public Event | DeviceError | Event fired when an error happens while waiting on a device event. (Inherited from Connection)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DsrChanged | Event fired when the DSR signal has changed on input.
Public Event | Opened | Event fired when an attempt to establish a new connection was completed. (Inherited from Connection)
Public Event | RingDetected | Event fired to report the detection of Ring indicator.
Public Event | WriteComplete | Event fires to report when the last character in write buffer was sent.
Top

See Also

Reference

SerialConnection Class
CommStudio.Connections Namespace


SerialConnection Constructor

SerialConnection Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : SerialConnection Constructor

Creates a new instance of the SerialConnection class inside a Windows Forms designer.

Overload List

Overload | Description
SerialConnection Constructor() | Creates a new instance of the SerialConnection class.
SerialConnection Constructor(IContainer) | Creates a new instance of the SerialConnection class inside a Windows Forms designer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


SerialConnection Constructor()

SerialConnection Constructor()
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > SerialConnection Constructor : SerialConnection Constructor()

Creates a new instance of the SerialConnection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection()
C#
public SerialConnection()
Delphi
public SerialConnection();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


SerialConnection Constructor(IContainer)

SerialConnection Constructor(IContainer)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > SerialConnection Constructor : SerialConnection Constructor(IContainer)

container
Container to place this new instance of the SerialConnection class.
Creates a new instance of the SerialConnection class inside a Windows Forms designer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As SerialConnection(container)
C#
public SerialConnection(
   IContainer container
)
Delphi
public SerialConnection(
    container: IContainer
);

Parameters

container
Container to place this new instance of the SerialConnection class.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


SerialConnection Class Methods

SerialConnection Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection Class

For a list of all members of this type, see SerialConnection members.

Public Methods

 | Name | Description
Public Method | BeginLock | Locks the current connection from use except by methods which know the correct key. (Inherited from Connection)
Public Method | Close | Overridden. Closes the connection to the current device
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | EndLock | Unlocks the connection so that any method may access the read/write abilities. (Inherited from Connection)
Public Method | Flush | Overloaded. Overridden. Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Open | Overloaded. Overridden. Opens a connection to the device.
Public Method | Peek | Overloaded. Overridden. Returns the next available character but does not consume it.
Public Method | Read | Overloaded. Overridden. Reads bytes from the serial port into a byte array, not checking for locked condition.
Public Method | ReadLine | Overloaded. Reads a line of text from the serial port. (Inherited from Connection)
Public Method | ReadUntil | Overloaded. Reads until a specified string is found. (Inherited from Connection)
Public Method | SetOptions | Assigns the supplied options to the current device. If the device is open, then the settings will happen immediately, else they will be delayed until Open() is called.
Public Method | ShowPropertiesDialog | Overloaded. Overridden. Shows a properties dialog to change the settings of this connection with the specified owner
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | WaitForInput | Overloaded. Overridden. Wait for a certain number of bytes to be input using current Read timeout value.
Public Method | Write | Overloaded. Overridden. Writes bytes from a byte array to the serial port, not checking for locked condition.
Top

Protected Methods

 | Name | Description
Protected Method | EmptyReceiveQueue | Overridden. Empties the input queue of all data, waiting a specified time for it to empty.
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | FireBreakReceived | Overridden. Method to call when a break was encountered.
Protected Method | FireCarrierChanged | Overridden. Method to call when the carrier signal changed.
Protected Method | FireClosed | Method to call an attempt to close a connection was completed. (Inherited from Connection)
Protected Method | FireCtsChanged | Overridden. Method to call when the CTS signal changed.
Protected Method | FireDsrChanged | Overridden. Method to call when the DSR signal changed.
Protected Method | FireOpened | Method to call when an attempt to establish a new connection has been completed. (Inherited from Connection)
Protected Method | FireRingDetected | Overridden. Method to call when the ring indicator is detected.
Protected Method | FireWriteBufferEmpty | Overridden. Method to call when last character in write buffer was sent.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | SupportsEightBitProtocol | Overridden. Makes sure the current connection is valid for 8-bit protocols (X and Y Modem)
Protected Method | ValidKey | Lets you verify if the product can be used with the supplied key. (Inherited from Connection)
Protected Method | WriteUnlocked | Overloaded. Writes a byte to the connection (w/out lock checking).
Top

See Also

Reference

SerialConnection Class
CommStudio.Connections Namespace


Close Method

Close Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Close Method

Closes the connection to the current device

Syntax

Visual Basic (Declaration)
Overrides Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Dispose Method

Clean up any resources being used.

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Dispose Method : Dispose(Boolean) Method

disposing
If disposing equals true, the method has been called directly or indirectly by a user's code. Managed and unmanaged resources can be disposed. If disposing equals false, the method has been called by the runtime from inside the finalizer and you should not reference other objects. Only unmanaged resources can be disposed.
Clean up any resources being used.

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;

Parameters

disposing
If disposing equals true, the method has been called directly or indirectly by a user's code. Managed and unmanaged resources can be disposed. If disposing equals false, the method has been called by the runtime from inside the finalizer and you should not reference other objects. Only unmanaged resources can be disposed.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


EmptyReceiveQueue Method

EmptyReceiveQueue Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : EmptyReceiveQueue Method

timeout
Maximum time to wait for the queue to remain empty.
key
Key as defined by the user (may be null for no key).
Empties the input queue of all data, waiting a specified time for it to empty.

Syntax

Visual Basic (Declaration)
Overrides Protected Function EmptyReceiveQueue( _
   ByVal timeout As Integer, _
   ByVal key As ConnectionKey _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim timeout As Integer
Dim key As ConnectionKey
Dim value As Boolean

value = instance.EmptyReceiveQueue(timeout, key)
C#
protected override bool EmptyReceiveQueue(
   int timeout,
   ConnectionKey key
)
Delphi
protected function EmptyReceiveQueue(
    timeout: Integer;
    key: ConnectionKey
): Boolean; override;

Parameters

timeout
Maximum time to wait for the queue to remain empty.
key
Key as defined by the user (may be null for no key).

Return Value

If the queue is empty upon return.

Remarks

The function will return when the earliest of: a read timeout or the specified timeout are reached. This method only affects the input (read) queue.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireBreakReceived Method

FireBreakReceived Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireBreakReceived Method

Method to call when a break was encountered.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireBreakReceived() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireBreakReceived()
C#
protected override bool FireBreakReceived()
Delphi
protected function FireBreakReceived(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireCarrierChanged Method

FireCarrierChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireCarrierChanged Method

Method to call when the carrier signal changed.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireCarrierChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireCarrierChanged()
C#
protected override bool FireCarrierChanged()
Delphi
protected function FireCarrierChanged(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireCtsChanged Method

FireCtsChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireCtsChanged Method

Method to call when the CTS signal changed.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireCtsChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireCtsChanged()
C#
protected override bool FireCtsChanged()
Delphi
protected function FireCtsChanged(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireDsrChanged Method

FireDsrChanged Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireDsrChanged Method

Method to call when the DSR signal changed.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireDsrChanged() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireDsrChanged()
C#
protected override bool FireDsrChanged()
Delphi
protected function FireDsrChanged(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireRingDetected Method

FireRingDetected Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireRingDetected Method

Method to call when the ring indicator is detected.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireRingDetected() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireRingDetected()
C#
protected override bool FireRingDetected()
Delphi
protected function FireRingDetected(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Remarks

There should be no need to further derive from this method.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


FireWriteBufferEmpty Method

FireWriteBufferEmpty Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : FireWriteBufferEmpty Method

Method to call when last character in write buffer was sent.

Syntax

Visual Basic (Declaration)
Overrides Protected Function FireWriteBufferEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.FireWriteBufferEmpty()
C#
protected override bool FireWriteBufferEmpty()
Delphi
protected function FireWriteBufferEmpty(): Boolean; override;

Return Value

'true' if the event was handled, else 'false' if no handlers are defined.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Flush Method

Flush Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Flush Method

Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Overload List

Overload | Description
Flush(Boolean) | Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.
Flush(Boolean,Int32) | Allows timeout to clear all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.
Flush() | Clears all buffers for this connection and causes any buffered data to be discarded (Inherited from Connection)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Flush(Boolean) Method

Flush(Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Flush Method : Flush(Boolean) Method

discard
Indicates whether any buffered data should be discarded.
Clears all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub Flush( _
   ByVal discard As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim discard As Boolean

instance.Flush(discard)
C#
public override void Flush(
   bool discard
)
Delphi
public procedure Flush(
    discard: Boolean
); override;

Parameters

discard
Indicates whether any buffered data should be discarded.

Remarks

Setting 'discard' to 'true' will flush the input and output buffers, the deleted characters are not transmitted. Setting 'discard' to 'false' will empty the output buffer while ensuring that the contents are transmitted (a synchronous operation). This last option is subject to flow control but not to write time-outs, and it will not return until all pending write operations have been transmitted. Also, a setting of 'false' will not affect the input buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Flush(Boolean,Int32) Method

Flush(Boolean,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Flush Method : Flush(Boolean,Int32) Method

discard
Indicates whether any buffered data should be discarded.
timeout
Number of milliseconds to wait before aborting the flush.
Allows timeout to clear all buffers for this connection and causes any buffered data to either be discarded or written to the underlying device.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub Flush( _
   ByVal discard As Boolean, _
   ByVal timeout As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim discard As Boolean
Dim timeout As Integer

instance.Flush(discard, timeout)
C#
public override void Flush(
   bool discard,
   int timeout
)
Delphi
public procedure Flush(
    discard: Boolean;
    timeout: Integer
); override;

Parameters

discard
Indicates whether any buffered data should be discarded.
timeout
Number of milliseconds to wait before aborting the flush.

Exceptions

Exception | Description
Exception | Timeout expired prior to completion of non-discard flush.

Remarks

Setting 'discard' to 'true' will flush the input and output buffers, the deleted characters are not transmitted. Setting 'discard' to 'false' will empty the output buffer while ensuring that the contents are transmitted (a synchronous operation). This last option is subject to flow control but not to write time-outs, and it will not return until all pending write operations have been transmitted. Also, a setting of 'false' will not affect the input buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Open Method

Open Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Open Method

Opens a connection to the device.

Overload List

Overload | Description
Open() | Opens a connection to the device.
Open(Int64,Int64) | Opens a connection to the device.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Open() Method

Open() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Open Method : Open() Method

Opens a connection to the device.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub Open()
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection

instance.Open()
C#
public override void Open()
Delphi
public procedure Open(); override;

Exceptions

Exception | Description
IOException | Error encountered opening the device.
ArgumentException | General error occurred, check message for details.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Open(Int64,Int64) Method

Open(Int64,Int64) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Open Method : Open(Int64,Int64) Method

inputQueueSize
Specifies the recommended size, in bytes, of the device's internal input buffer.
outputQueueSize
Specifies the recommended size, in bytes, of the device's internal output buffer.
Opens a connection to the device.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Open( _
   ByVal inputQueueSize As Long, _
   ByVal outputQueueSize As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim inputQueueSize As Long
Dim outputQueueSize As Long

instance.Open(inputQueueSize, outputQueueSize)
C#
public void Open(
   long inputQueueSize,
   long outputQueueSize
)
Delphi
public procedure Open(
    inputQueueSize: Int64;
    outputQueueSize: Int64
);

Parameters

inputQueueSize
Specifies the recommended size, in bytes, of the device's internal input buffer.
outputQueueSize
Specifies the recommended size, in bytes, of the device's internal output buffer.

Exceptions

Exception | Description
IOException | Error encountered opening the device - check error message for details.
ArgumentException | General error occurred, check message for details.

Remarks

If either Queue size is invalid for a device, the device uses the default parameters when the first call to another communications function occurs. The inputQueueSize and outputQueueSize parameters specify the recommended sizes for the internal buffers used by the driver for the specified device. The device driver receives the recommended buffer sizes, but is free to use any input and output (I/O) buffering scheme, as long as it provides reasonable performance and data is not lost due to overrun (except under extreme circumstances). For example, the function can succeed even though the driver does not allocate a buffer, as long as some other portion of the system provides equivalent functionality.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Peek Method

Peek Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Peek Method

Returns the next available character but does not consume it.

Overload List

Overload | Description
Peek() | Returns the next available character but does not consume it.
Peek(ConnectionKey) | Returns the next available character but does not consume it (key protected version).

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Peek() Method

Peek() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Peek Method : Peek() Method

Returns the next available character but does not consume it.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Peek() As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

value = instance.Peek()
C#
public override int Peek()
Delphi
public function Peek(): Integer; override;

Return Value

The next character to be read, or -1 if no characters are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Peek(ConnectionKey) Method

Peek(ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Peek Method : Peek(ConnectionKey) Method

key
Key as defined by the user (may be null for no key).
Returns the next available character but does not consume it (key protected version).

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Peek( _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim key As ConnectionKey
Dim value As Integer

value = instance.Peek(key)
C#
public override int Peek(
   ConnectionKey key
)
Delphi
public function Peek(
    key: ConnectionKey
): Integer; override;

Parameters

key
Key as defined by the user (may be null for no key).

Return Value

The next character to be read, or -1 if no characters are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Read Method

Read Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Read Method

Reads bytes from the serial port into a byte array, not checking for locked condition.

Overload List

Overload | Description
Read(Byte[],Int32,Int32,ConnectionKey) | Reads bytes from the serial port into a byte array, not checking for locked condition.
Read(ConnectionKey) | Reads a byte from the connection or -1 if no bytes are available.
Read() | Reads a byte from the connection or -1 if no bytes are available.
Read(Byte[],Int32,Int32) | Reads bytes from the serial port into a byte array.
Read(Int32) | Reads the specified number of bytes from the connection and returns them as a string. (Inherited from Connection)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Read(Byte[],Int32,Int32,ConnectionKey) Method

Read(Byte[],Int32,Int32,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Read Method : Read(Byte[],Int32,Int32,ConnectionKey) Method

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
key
Communication locking key.
Reads bytes from the serial port into a byte array, not checking for locked condition.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim key As ConnectionKey
Dim value As Integer

value = instance.Read(buffer, offset, count, key)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count,
   ConnectionKey key
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    key: ConnectionKey
): Integer; override;

Parameters

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
key
Communication locking key.

Return Value

The number of characters read into buffer. This might be less than the number of bytes requested if that many bytes are not available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Read(ConnectionKey) Method

Read(ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Read Method : Read(ConnectionKey) Method

key
Communication locking key.
Reads a byte from the connection or -1 if no bytes are available.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Read( _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim key As ConnectionKey
Dim value As Integer

value = instance.Read(key)
C#
public override int Read(
   ConnectionKey key
)
Delphi
public function Read(
    key: ConnectionKey
): Integer; override;

Parameters

key
Communication locking key.

Return Value

The byte that was read, or -1 if no bytes are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Read() Method

Read() Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Read Method : Read() Method

Reads a byte from the connection or -1 if no bytes are available.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Read() As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

value = instance.Read()
C#
public override int Read()
Delphi
public function Read(): Integer; override;

Return Value

The byte that was read, or -1 if no bytes are available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Read(Byte[],Int32,Int32) Method

Read(Byte[],Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.
Reads bytes from the serial port into a byte array.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;

Parameters

buffer
The buffer to read data into.
offset
The starting point in the buffer at which to begin reading into the buffer.
count
The number of characters to read.

Return Value

The number of characters read into buffer. This might be less than the number of bytes requested if that many bytes are not available.

Exceptions

Exception | Description
ArgumentException | The buffer length minus index is less than count.
ArgumentNullException | buffer is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | offset or count is negative
IOException | The specified port is not open.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


SetOptions Method

SetOptions Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : SetOptions Method

newOptions
Set of options to use for the current device.
Assigns the supplied options to the current device. If the device is open, then the settings will happen immediately, else they will be delayed until Open() is called.

Syntax

Visual Basic (Declaration)
Public Sub SetOptions( _
   ByVal newOptions As SerialOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim newOptions As SerialOptions

instance.SetOptions(newOptions)
C#
public void SetOptions(
   SerialOptions newOptions
)
Delphi
public procedure SetOptions(
    newOptions: SerialOptions
);

Parameters

newOptions
Set of options to use for the current device.

Exceptions

Exception | Description
Exception | General error trying to set state of device.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


ShowPropertiesDialog Method

ShowPropertiesDialog Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : ShowPropertiesDialog Method

Shows a properties dialog to change the settings of this connection with the specified owner

Overload List

Overload | Description
ShowPropertiesDialog(IWin32Window) | Shows a properties dialog to change the settings of this connection with the specified owner
ShowPropertiesDialog() | Shows a properties dialog to change the settings of this connection with a default owner (Inherited from Connection)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


ShowPropertiesDialog(IWin32Window) Method

ShowPropertiesDialog(IWin32Window) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > ShowPropertiesDialog Method : ShowPropertiesDialog(IWin32Window) Method

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.
Shows a properties dialog to change the settings of this connection with the specified owner

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ShowPropertiesDialog( _
   ByVal owner As IWin32Window _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim owner As IWin32Window
Dim value As DialogResult

value = instance.ShowPropertiesDialog(owner)
C#
public override DialogResult ShowPropertiesDialog(
   IWin32Window owner
)
Delphi
public function ShowPropertiesDialog(
    owner: IWin32Window
): DialogResult; override;

Parameters

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Remarks

Please call the Application.EnableVisualStyles method at the start of your application to make sure the properties window has modern look and feel.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


SupportsEightBitProtocol Method

SupportsEightBitProtocol Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : SupportsEightBitProtocol Method

Makes sure the current connection is valid for 8-bit protocols (X and Y Modem)

Syntax

Visual Basic (Declaration)
Overrides Protected Function SupportsEightBitProtocol() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.SupportsEightBitProtocol()
C#
protected override bool SupportsEightBitProtocol()
Delphi
protected function SupportsEightBitProtocol(): Boolean; override;

Return Value

If this connection will support the protocol.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


WaitForInput Method

WaitForInput Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : WaitForInput Method

Wait for a certain number of bytes to be input using current Read timeout value.

Overload List

Overload | Description
WaitForInput(Int32) | Wait for a certain number of bytes to be input using current Read timeout value.
WaitForInput(Int32,Int32,Int32) | Wait for a certain number of bytes to be input, allows complete definition of timeout.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


WaitForInput(Int32) Method

WaitForInput(Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > WaitForInput Method : WaitForInput(Int32) Method

count
Number of bytes to wait for.
Wait for a certain number of bytes to be input using current Read timeout value.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function WaitForInput( _
   ByVal count As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim count As Integer
Dim value As Boolean

value = instance.WaitForInput(count)
C#
public override bool WaitForInput(
   int count
)
Delphi
public function WaitForInput(
    count: Integer
): Boolean; override;

Parameters

count
Number of bytes to wait for.

Return Value

If the requested number of bytes are available for reading.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


WaitForInput(Int32,Int32,Int32) Method

WaitForInput(Int32,Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > WaitForInput Method : WaitForInput(Int32,Int32,Int32) Method

count
Number of bytes to wait for.
waitConst
Minimum amount of time to wait for input bytes.
waitMult
Milliseconds to wait for each byte to appear in the queue (default=0).
Wait for a certain number of bytes to be input, allows complete definition of timeout.

Syntax

Visual Basic (Declaration)
Overloads Overrides Protected Function WaitForInput( _
   ByVal count As Integer, _
   ByVal waitConst As Integer, _
   ByVal waitMult As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim count As Integer
Dim waitConst As Integer
Dim waitMult As Integer
Dim value As Boolean

value = instance.WaitForInput(count, waitConst, waitMult)
C#
protected override bool WaitForInput(
   int count,
   int waitConst,
   int waitMult
)
Delphi
protected function WaitForInput(
    count: Integer;
    waitConst: Integer;
    waitMult: Integer
): Boolean; override;

Parameters

count
Number of bytes to wait for.
waitConst
Minimum amount of time to wait for input bytes.
waitMult
Milliseconds to wait for each byte to appear in the queue (default=0).

Return Value

If the requested number of bytes are available for reading.

Exceptions

Exception | Description
IOException | The specified port is not open.

Remarks

The total time waiting for the specified bytes will be the constant value + the multiplier*[Total bytes waiting for].

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Write Method

Write Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Write Method

Writes bytes from a byte array to the serial port, not checking for locked condition.

Overload List

Overload | Description
Write(Byte[],Int32,Int32,ConnectionKey) | Writes bytes from a byte array to the serial port, not checking for locked condition.
Write(Byte,ConnectionKey) | Writes a byte to the connection.
Write(Byte) | Writes a byte to the connection.
Write(Byte[],Int32,Int32) | Writes bytes from a byte array to the serial port.
Write(String) | Writes the specified string to the connection. (Inherited from Connection)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Write(Byte[],Int32,Int32,ConnectionKey) Method

Write(Byte[],Int32,Int32,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Write Method : Write(Byte[],Int32,Int32,ConnectionKey) Method

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
key
Communication locking key.
Writes bytes from a byte array to the serial port, not checking for locked condition.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal key As ConnectionKey _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim key As ConnectionKey
Dim value As Integer

value = instance.Write(buffer, offset, count, key)
C#
public override int Write(
   byte[] buffer,
   int offset,
   int count,
   ConnectionKey key
)
Delphi
public function Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    key: ConnectionKey
): Integer; override;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
key
Communication locking key.

Return Value

Returns the number of bytes written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Write(Byte,ConnectionKey) Method

Write(Byte,ConnectionKey) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Write Method : Write(Byte,ConnectionKey) Method

b
The byte that should be written.
key
Communication locking key.
Writes a byte to the connection.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub Write( _
   ByVal b As Byte, _
   ByVal key As ConnectionKey _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim b As Byte
Dim key As ConnectionKey

instance.Write(b, key)
C#
public override void Write(
   byte b,
   ConnectionKey key
)
Delphi
public procedure Write(
    b: Byte;
    key: ConnectionKey
); override;

Parameters

b
The byte that should be written.
key
Communication locking key.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Write(Byte) Method

Write(Byte) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Write Method : Write(Byte) Method

b
The byte that should be written.
Writes a byte to the connection.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Sub Write( _
   ByVal b As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim b As Byte

instance.Write(b)
C#
public override void Write(
   byte b
)
Delphi
public procedure Write(
    b: Byte
); override;

Parameters

b
The byte that should be written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


Write(Byte[],Int32,Int32) Method

Write(Byte[],Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
Writes bytes from a byte array to the serial port.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Write(buffer, offset, count)
C#
public override int Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.

Return Value

Returns the number of bytes written to the port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


WriteUnlocked Method

WriteUnlocked Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : WriteUnlocked Method

Writes a byte to the connection (w/out lock checking).

Overload List

Overload | Description
WriteUnlocked(Byte) | Writes a byte to the connection (w/out lock checking).
WriteUnlocked(Byte[],Int32,Int32) | Writes bytes from a byte array to the serial port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


WriteUnlocked(Byte) Method

WriteUnlocked(Byte) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > WriteUnlocked Method : WriteUnlocked(Byte) Method

b
The byte that should be written.
Writes a byte to the connection (w/out lock checking).

Syntax

Visual Basic (Declaration)
Overloads Protected Sub WriteUnlocked( _
   ByVal b As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim b As Byte

instance.WriteUnlocked(b)
C#
protected void WriteUnlocked(
   byte b
)
Delphi
protected procedure WriteUnlocked(
    b: Byte
);

Parameters

b
The byte that should be written.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


WriteUnlocked(Byte[],Int32,Int32) Method

WriteUnlocked(Byte[],Int32,Int32) Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class > WriteUnlocked Method : WriteUnlocked(Byte[],Int32,Int32) Method

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.
Writes bytes from a byte array to the serial port.

Syntax

Visual Basic (Declaration)
Overloads Protected Function WriteUnlocked( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.WriteUnlocked(buffer, offset, count)
C#
protected int WriteUnlocked(
   byte[] buffer,
   int offset,
   int count
)
Delphi
protected function WriteUnlocked(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer;

Parameters

buffer
The data to write to the stream.
offset
The location in the buffer to start writing data from.
count
The number of bytes to write to the stream.

Return Value

Returns the number of bytes written to the port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Overload List


SerialConnection Class Properties

SerialConnection Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection Class

For a list of all members of this type, see SerialConnection members.

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if a status dialog should be shown when a new connection is established. (Inherited from Connection)
Public Property | Available | Overridden. Returns the number of bytes available in the input buffer.
Public Property | Break | Suspends or restores character transmission for the device, placing the status of the Break state as set (suspended transmission) or Cleared (non-break) state.
Public Property | Carrier | Gets the status of the Carrier/Receive Line Signal Detect (RLSD) signal.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Cts | Gets the status of the Clear-To-Send (CTS) signal.
Public Property | DataAvailableThreshold | Indicates the number of bytes that need to be in the receive buffer before the DataAvailable event is fired. The argument cannot be negative. (Inherited from Connection)
Public Property | Dsr | Gets the status of the DSR (data-set-ready) signal.
Public Property | Dtr | Sets the status of the DTR (data-terminal-ready) signal.
Public Property | Encoding | Defines the type of encoding used when converting between text strings and byte arrays. (Inherited from Connection)
Public Property | Handle | Overridden. Returns the operating-system level handle of the communications port.
Public Property | IsOpen | Overridden. Gets a value indicating whether the current connection is open.
Public Property | Options | Determines the current serial port and its settings.
Public Property | ReadTimeOut | Overridden. Defines the number of milliseconds the control should wait for input data from the port.
Public Property | Ring | Gets the status of the Ring indicator signal.
Public Property | Rts | Sets the status (clear/send) of the RTS (request-to-send) signal.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads (Inherited from Connection)
Public Property | Unwritten | Returns the number of bytes which remain in the output buffer and are waiting to be sent.
Public Property | WaitMethod | Defines the method used when waiting for data. (Inherited from Connection)
Public Property | WriteTimeOut | Overridden. Defines the number of milliseconds the control should wait for data to travel through the output port.
Public Property | Xon | Causes the control to act as if a Xon (true) or Xoff (false) character was received.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SerialConnection Class
CommStudio.Connections Namespace


Available Property

Available Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Available Property

Returns the number of bytes available in the input buffer.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Overrides Public ReadOnly Property Available As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

value = instance.Available
C#
[BrowsableAttribute(false)]
public override int Available {get;}
Delphi
public read-only property Available: Integer; override;

Return Value

Number of bytes in the input buffer.

Exceptions

Exception | Description
IOException | The specified port is not open.

Remarks

This property reports how many bytes are waiting to be read from the receive buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Unwritten Property


Break Property

Break Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Break Property

Suspends or restores character transmission for the device, placing the status of the Break state as set (suspended transmission) or Cleared (non-break) state.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Break As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

instance.Break = value

value = instance.Break
C#
[BrowsableAttribute(false)]
public bool Break {get; set;}
Delphi
public read-write property Break: Boolean;

Return Value

If character transmission is suspended and line is in break state - true=break, false=non-break.

Remarks

A communications device is placed in a break state by the setting this property to true. Character transmission is then suspended until the break state is cleared by setting this value to false (non-break state). Note: This does not flush data that has not been transmitted.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Carrier Property

Carrier Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Carrier Property

Gets the status of the Carrier/Receive Line Signal Detect (RLSD) signal.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Carrier As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.Carrier
C#
[BrowsableAttribute(false)]
public bool Carrier {get;}
Delphi
public read-only property Carrier: Boolean;

Return Value

Status of the RLSD signal - true=signal is on, false=off.

Remarks

The set accessor is not available for this property.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Cts Property

Cts Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Cts Property

Gets the status of the Clear-To-Send (CTS) signal.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Cts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.Cts
C#
[BrowsableAttribute(false)]
public bool Cts {get;}
Delphi
public read-only property Cts: Boolean;

Return Value

Current status of the CTS signal - true=on, else off

Remarks

The function returns false if the hardware does not support the CTS signal.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Dsr Property

Dsr Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Dsr Property

Gets the status of the DSR (data-set-ready) signal.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Dsr As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.Dsr
C#
[BrowsableAttribute(false)]
public bool Dsr {get;}
Delphi
public read-only property Dsr: Boolean;

Return Value

Status of the DSR indicator signal - true=signal is on, false=off.

Remarks

The set accessor is not available for this property.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Dtr Property

Dtr Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Dtr Property

Sets the status of the DTR (data-terminal-ready) signal.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public WriteOnly Property Dtr
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As

instance.Dtr = value
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public void Dtr {set;}
Delphi
public write-only property Dtr;

Return Value

Status of the DTR signal - true=send, false=clear

Remarks

The current status of the DTR is not available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Handle Property

Handle Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Handle Property

Returns the operating-system level handle of the communications port.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Overrides Public ReadOnly Property Handle As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As IntPtr

value = instance.Handle
C#
[BrowsableAttribute(false)]
public override IntPtr Handle {get;}
Delphi
public read-only property Handle: IntPtr; override;

Return Value

Handle of the communications port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


IsOpen Property

IsOpen Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : IsOpen Property

Gets a value indicating whether the current connection is open.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Indicates if the current connection is open.")>
<BrowsableAttribute(False)>
Overrides Public ReadOnly Property IsOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.IsOpen
C#
[DescriptionAttribute("Indicates if the current connection is open.")]
[BrowsableAttribute(false)]
public override bool IsOpen {get;}
Delphi
public read-only property IsOpen: Boolean; override;

Return Value

If the current connection is open.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Options Property

Options Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Options Property

Determines the current serial port and its settings.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Determines the current serial port and its settings.")>
<DesignerSerializationVisibilityAttribute()>
Public Property Options As SerialOptions
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As SerialOptions

instance.Options = value

value = instance.Options
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Determines the current serial port and its settings.")]
[DesignerSerializationVisibilityAttribute()]
public SerialOptions Options {get; set;}
Delphi
public read-write property Options: SerialOptions;

Return Value

Settings for current serial port.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


ReadTimeOut Property

ReadTimeOut Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : ReadTimeOut Property

Defines the number of milliseconds the control should wait for input data from the port.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Milliseconds to wait for data from the input queue of the port.")>
<DefaultValueAttribute()>
Overrides Public Property ReadTimeOut As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

instance.ReadTimeOut = value

value = instance.ReadTimeOut
C#
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Milliseconds to wait for data from the input queue of the port.")]
[DefaultValueAttribute()]
public override int ReadTimeOut {get; set;}
Delphi
public read-write property ReadTimeOut: Integer; override;

Return Value

Number of milliseconds to wait for data in the input port before failing on the read.

Remarks

  • Allowable values are between zero and 4294967295.
  • This action will be performed immediately on an open port.
  • A value of zero specifies that the read operation is to return immediately with the bytes that have already been received, even if no bytes have been received.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Ring Property

Ring Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Ring Property

Gets the status of the Ring indicator signal.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Ring As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Boolean

value = instance.Ring
C#
[BrowsableAttribute(false)]
public bool Ring {get;}
Delphi
public read-only property Ring: Boolean;

Return Value

Status of the Ring indicator signal - true=signal is on, false=off.

Remarks

The set accessor is not available for this property.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Rts Property

Rts Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Rts Property

Sets the status (clear/send) of the RTS (request-to-send) signal.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Sets the status (clear/send) of the RTS (request-to-send) signal (may not get this value).")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public WriteOnly Property Rts
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As

instance.Rts = value
C#
[DescriptionAttribute("Sets the status (clear/send) of the RTS (request-to-send) signal (may not get this value).")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public void Rts {set;}
Delphi
public write-only property Rts;

Return Value

Status of the RTS signal - true=send, false=clear

Remarks

The current status of the RTS (get) is not available.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Unwritten Property

Unwritten Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Unwritten Property

Returns the number of bytes which remain in the output buffer and are waiting to be sent.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Unwritten As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

value = instance.Unwritten
C#
[BrowsableAttribute(false)]
public int Unwritten {get;}
Delphi
public read-only property Unwritten: Integer;

Return Value

Number of waiting bytes in the output buffer.

Exceptions

Exception | Description
IOException | The specified port is not open.

Remarks

This function reports how many bytes are waiting to be sent, not how much room is left within the output buffer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members
Available Property


WriteTimeOut Property

WriteTimeOut Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : WriteTimeOut Property

Defines the number of milliseconds the control should wait for data to travel through the output port.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Milliseconds to wait for data to travel through the output queue")>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Overrides Public Property WriteTimeOut As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As Integer

instance.WriteTimeOut = value

value = instance.WriteTimeOut
C#
[DescriptionAttribute("Milliseconds to wait for data to travel through the output queue")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public override int WriteTimeOut {get; set;}
Delphi
public read-write property WriteTimeOut: Integer; override;

Return Value

Number of milliseconds to wait for data in the input port before failing on the read.

Remarks

  • Allowable values are between zero and 4294967295.
  • This action will be performed immediately on an open port.
  • A value of zero specifies that the write operation is to wait indefinitely for the bytes to be sent through the device.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


Xon Property

Xon Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : Xon Property

Causes the control to act as if a Xon (true) or Xoff (false) character was received.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public WriteOnly Property Xon
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim value As

instance.Xon = value
C#
[BrowsableAttribute(false)]
public void Xon {set;}
Delphi
public write-only property Xon;

Return Value

Transmission will act as if a Xon character has been received - true=Xon, false=Xoff.

Remarks

The get accessor is not available for this property.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


SerialConnection Class Events

SerialConnection Class Events
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection Class

For a list of all members of this type, see SerialConnection members.

Public Events

 | Name | Description
Public Event | BreakReceived | Event fired when a 'break' is detected on input.
Public Event | CarrierChanged | Event Fires whenever the Carrier signal changes.
Public Event | Closed | Event fired when an attempt to establish a new connection was completed. (Inherited from Connection)
Public Event | CtsChanged | Event fired when CTS signal changed.
Public Event | DataAvailable | Event fired when new data is waiting in the input buffer. (Inherited from Connection)
Public Event | DeviceError | Event fired when an error happens while waiting on a device event. (Inherited from Connection)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DsrChanged | Event fired when the DSR signal has changed on input.
Public Event | Opened | Event fired when an attempt to establish a new connection was completed. (Inherited from Connection)
Public Event | RingDetected | Event fired to report the detection of Ring indicator.
Public Event | WriteComplete | Event fires to report when the last character in write buffer was sent.
Top

See Also

Reference

SerialConnection Class
CommStudio.Connections Namespace


BreakReceived Event

BreakReceived Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : BreakReceived Event

Event fired when a 'break' is detected on input.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Action")>
<DescriptionAttribute("A break was detected on input.")>
<BrowsableAttribute(True)>
Public Event BreakReceived() As SerialConnection.BreakEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.BreakEventHandler

AddHandler instance.BreakReceived, handler
C#
[CategoryAttribute("Action")]
[DescriptionAttribute("A break was detected on input.")]
[BrowsableAttribute(true)]
public event SerialConnection.BreakEventHandler BreakReceived()
Delphi
public event BreakReceived: SerialConnection.BreakEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


CarrierChanged Event

CarrierChanged Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : CarrierChanged Event

Event Fires whenever the Carrier signal changes.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The carrier signal changed.")>
<CategoryAttribute("Property Changed")>
<BrowsableAttribute(True)>
Public Event CarrierChanged() As SerialConnection.CarrierEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.CarrierEventHandler

AddHandler instance.CarrierChanged, handler
C#
[DescriptionAttribute("The carrier signal changed.")]
[CategoryAttribute("Property Changed")]
[BrowsableAttribute(true)]
public event SerialConnection.CarrierEventHandler CarrierChanged()
Delphi
public event CarrierChanged: SerialConnection.CarrierEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


CtsChanged Event

CtsChanged Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : CtsChanged Event

Event fired when CTS signal changed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The CTS signal changed state.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Property Changed")>
Public Event CtsChanged() As SerialConnection.CtsEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.CtsEventHandler

AddHandler instance.CtsChanged, handler
C#
[DescriptionAttribute("The CTS signal changed state.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Property Changed")]
public event SerialConnection.CtsEventHandler CtsChanged()
Delphi
public event CtsChanged: SerialConnection.CtsEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


DsrChanged Event

DsrChanged Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : DsrChanged Event

Event fired when the DSR signal has changed on input.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Property Changed")>
<BrowsableAttribute(True)>
<DescriptionAttribute("The DSR signal changed state.")>
Public Event DsrChanged() As SerialConnection.DsrEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.DsrEventHandler

AddHandler instance.DsrChanged, handler
C#
[CategoryAttribute("Property Changed")]
[BrowsableAttribute(true)]
[DescriptionAttribute("The DSR signal changed state.")]
public event SerialConnection.DsrEventHandler DsrChanged()
Delphi
public event DsrChanged: SerialConnection.DsrEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


RingDetected Event

RingDetected Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : RingDetected Event

Event fired to report the detection of Ring indicator.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("Action")>
<DescriptionAttribute("A ring indicator was detected.")>
Public Event RingDetected() As SerialConnection.RingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.RingEventHandler

AddHandler instance.RingDetected, handler
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Action")]
[DescriptionAttribute("A ring indicator was detected.")]
public event SerialConnection.RingEventHandler RingDetected()
Delphi
public event RingDetected: SerialConnection.RingEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


WriteComplete Event

WriteComplete Event
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialConnection Class : WriteComplete Event

Event fires to report when the last character in write buffer was sent.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The last character in the output buffer was sent.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Data")>
Public Event WriteComplete() As SerialConnection.WriteCompleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SerialConnection
Dim handler As SerialConnection.WriteCompleteEventHandler

AddHandler instance.WriteComplete, handler
C#
[DescriptionAttribute("The last character in the output buffer was sent.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Data")]
public event SerialConnection.WriteCompleteEventHandler WriteComplete()
Delphi
public event WriteComplete: SerialConnection.WriteCompleteEventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialConnection Class
SerialConnection Members


SerialPortInfo Class

SerialPortInfo Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialPortInfo Class

Describes a serial port that is installed on the system.

Syntax

Visual Basic (Declaration)
Public Class SerialPortInfo
Visual Basic (Usage) Copy Code
Dim instance As SerialPortInfo
C#
public class SerialPortInfo
Delphi
public class SerialPortInfo

Inheritance Hierarchy

System.Object
CommStudio.Connections.SerialPortInfo

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

SerialPortInfo Members
CommStudio.Connections Namespace


SerialPortInfo Class Members

SerialPortInfo Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialPortInfo Class

The following tables list the members exposed by SerialPortInfo.

Public Properties

 | Name | Description
Public Property | Description | A description of the port
Public Property | Name | The name of the port that is used by the system to identify the port, such as COM1.
static (Shared in Visual Basic) | Ports | Returns an array that of SerialPortInfo objects describing the serial ports that are available on the system
Top

Public Methods

 | Name | Description
Public Method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public Method | ToString | Overridden. Returns the port name
Top

See Also

Reference

SerialPortInfo Class
CommStudio.Connections Namespace


SerialPortInfo Class Methods

SerialPortInfo Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialPortInfo Class

For a list of all members of this type, see SerialPortInfo members.

Public Methods

 | Name | Description
Public Method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values.
Public Method | ToString | Overridden. Returns the port name
Top

See Also

Reference

SerialPortInfo Class
CommStudio.Connections Namespace


CompareTo Method

CompareTo Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialPortInfo Class : CompareTo Method

obj
An object to compare to this instance, or a null reference (Nothing in Visual Basic).
Compares this instance to a specified object and returns an indication of their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialPortInfo
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
C#
public int CompareTo(
   object obj
)
Delphi
public function CompareTo(
    obj: TObject
): Integer;

Parameters

obj
An object to compare to this instance, or a null reference (Nothing in Visual Basic).

Return Value

A signed integer that indicates the relative order of this instance and obj.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialPortInfo Class
SerialPortInfo Members


ToString Method

ToString Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialPortInfo Class : ToString Method

Returns the port name

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As SerialPortInfo
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;

Return Value

The Name property

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialPortInfo Class
SerialPortInfo Members


SerialPortInfo Class Properties

SerialPortInfo Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialPortInfo Class

For a list of all members of this type, see SerialPortInfo members.

Public Properties

 | Name | Description
Public Property | Description | A description of the port
Public Property | Name | The name of the port that is used by the system to identify the port, such as COM1.
static (Shared in Visual Basic) | Ports | Returns an array that of SerialPortInfo objects describing the serial ports that are available on the system
Top

See Also

Reference

SerialPortInfo Class
CommStudio.Connections Namespace


Description Property

Description Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialPortInfo Class : Description Property

A description of the port

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As SerialPortInfo
Dim value As String

value = instance.Description
C#
public string Description {get;}
Delphi
public read-only property Description: String;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialPortInfo Class
SerialPortInfo Members


Name Property

Name Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialPortInfo Class : Name Property

The name of the port that is used by the system to identify the port, such as COM1.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SerialPortInfo
Dim value As String

value = instance.Name
C#
public string Name {get;}
Delphi
public read-only property Name: String;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialPortInfo Class
SerialPortInfo Members


Ports Property

Ports Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialPortInfo Class : Ports Property

Returns an array that of SerialPortInfo objects describing the serial ports that are available on the system

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ports As SerialPortInfo()
Visual Basic (Usage) Copy Code
Dim value() As SerialPortInfo

value = SerialPortInfo.Ports
C#
public static SerialPortInfo[] Ports {get;}
Delphi
public read-only property Ports: array of SerialPortInfo; static;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialPortInfo Class
SerialPortInfo Members


CommStopBits Enumeration

CommStopBits Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : CommStopBits Enumeration

Defines the valid number of stop bits which may be used

Syntax

Visual Basic (Declaration)
Public Enum CommStopBits
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CommStopBits
C#
public enum CommStopBits : Enum
Delphi
public enum CommStopBits = class(Enum)

Members

Member | Description
One | 1 Stop bit.
OnePointFive | 1.5 Stop bits.
Two | 2 stop bits.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Connections.CommStopBits

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


Parity Enumeration

Parity Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Parity Enumeration

Defines the type of parity checking that should be performed.

Syntax

Visual Basic (Declaration)
Public Enum Parity
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Parity
C#
public enum Parity : Enum
Delphi
public enum Parity = class(Enum)

Members

Member | Description
None | No parity checking
Odd | The parity bit is set when the number of data bits that are set is odd.
Even | The parity bit is set when the number of data bits that are set is even.
Mark | The parity bit is always on.
Space | The parity bit is always off.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Connections.Parity

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


WaitMethod Enumeration

WaitMethod Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : WaitMethod Enumeration

Defines the method used when waiting for data.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Determines the method used when waiting for data.")>
Public Enum WaitMethod
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As WaitMethod
C#
[DescriptionAttribute("Determines the method used when waiting for data.")]
public enum WaitMethod : Enum
Delphi
public enum WaitMethod = class(Enum)

Members

Member | Description
Automatic | Automatically detects if the current thread has user interface.
DoEvents | Check the Windows message loop while waiting to allow the user to interact with the application.
Sleep | Put the processor in a sleep state or allow it to perform other tasks.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Connections.WaitMethod

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialOptions Structure

SerialOptions Structure
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialOptions Structure

Defines the settings for a serial port connection.

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
<TypeConverterAttribute("CommStudio.Connections.SerialOptionsConverter, CommStudio.2, Version=2.0.0.3102, Culture=neutral, PublicKeyToken=98fd87b7d0f115c7")>
<SerializableAttribute()>
Public Structure SerialOptions
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
C#
[ComVisibleAttribute(false)]
[TypeConverterAttribute("CommStudio.Connections.SerialOptionsConverter, CommStudio.2, Version=2.0.0.3102, Culture=neutral, PublicKeyToken=98fd87b7d0f115c7")]
[SerializableAttribute()]
public struct SerialOptions : ValueType
Delphi
public type SerialOptions = class(ValueType)

Inheritance Hierarchy

System.Object
System.ValueType
CommStudio.Connections.SerialOptions

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

SerialOptions Members
CommStudio.Connections Namespace


SerialOptions Structure Members

SerialOptions Structure Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialOptions Structure

The following tables list the members exposed by SerialOptions.

Public Constructors

 | Name | Description
Public Constructor | SerialOptions Constructor | Overloaded. Creates a new instance of the SerialOptions object.
Top

Public Properties

 | Name | Description
Public Property | BaudRate | Defines the communications speed of the connection.
Public Property | DataBits | Defines the number of bits in each byte that is transmitted or received.
Public Property | EnableDtr | Defines whether the DTR signal should be enabled.
Public Property | EnableRts | Defines whether the RTS signal should be enabled.
Public Property | FlowControlCtsRts | Defines whether the CTS and RTS signals should be used for handshaking.
Public Property | FlowControlDsrDtr | Defines whether the DSR and DTR signals should be used for handshaking.
Public Property | FlowControlRs485 | Defines whether this is an RS485 connection (else it is an RS232).
Public Property | FlowControlXonXoff | Defines whether Xon and Xoff characters should be used for handshaking.
Public Property | Parity | Defines the type of parity checking that is performed.
Public Property | PortName | Defines the communications port used to make the connection.
Public Property | StopBits | Defines the number of stopbits to be used.
Top

Public Methods

 | Name | Description
Public Method | CheckValid | Throws an exception if any of the properties are invalid.
Public Method | Equals | (Inherited from System.ValueType)
static (Shared in Visual Basic) | FromString | Creates a new instance of the SerialOptions from a string.
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | Overridden. Returns the options in a string.
Top

See Also

Reference

SerialOptions Structure
CommStudio.Connections Namespace


SerialOptions Constructor

SerialOptions Constructor
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : SerialOptions Constructor

Creates a new instance of the SerialOptions object.

Overload List

Overload | Description
SerialOptions Constructor(SerialOptions) | Copy constructor to initialize a new instance of a SerialOptions object using an existing SerialOptions as a template for initial settings.
SerialOptions Constructor(String,Int32,Parity) | Creates a new instance of the SerialOptions object.
SerialOptions Constructor(String,Int32,Parity,Int32,CommStopBits,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean) | Creates a new instance of the SerialOptions object.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


SerialOptions Constructor(SerialOptions)

SerialOptions Constructor(SerialOptions)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure > SerialOptions Constructor : SerialOptions Constructor(SerialOptions)

copy
Existing SerialOptions to copy settings from.
Copy constructor to initialize a new instance of a SerialOptions object using an existing SerialOptions as a template for initial settings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal copy As SerialOptions _
)
Visual Basic (Usage) Copy Code
Dim copy As SerialOptions

Dim instance As SerialOptions(copy)
C#
public SerialOptions(
   SerialOptions copy
)
Delphi
public SerialOptions(
    copy: SerialOptions
);

Parameters

copy
Existing SerialOptions to copy settings from.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members
Overload List


SerialOptions Constructor(String,Int32,Parity)

SerialOptions Constructor(String,Int32,Parity)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure > SerialOptions Constructor : SerialOptions Constructor(String,Int32,Parity)

portName
Name of port to connect to.
baudRate
Defines the communications speed of the connection.
parity
The parity checking scheme to use.
Creates a new instance of the SerialOptions object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal portName As String, _
   ByVal baudRate As Integer, _
   ByVal parity As Parity _
)
Visual Basic (Usage) Copy Code
Dim portName As String
Dim baudRate As Integer
Dim parity As Parity

Dim instance As SerialOptions(portName, baudRate, parity)
C#
public SerialOptions(
   string portName,
   int baudRate,
   Parity parity
)
Delphi
public SerialOptions(
    portName: String;
    baudRate: Integer;
    parity: Parity
);

Parameters

portName
Name of port to connect to.
baudRate
Defines the communications speed of the connection.
parity
The parity checking scheme to use.

Remarks

Handshaking will be set to use CTS and RTS (Hardware). The number of databits will be set to 8 of no Parity None is specified, or 7 otherwise.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members
Overload List


SerialOptions Constructor(String,Int32,Parity,Int32,CommStopBits,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean)

SerialOptions Constructor(String,Int32,Parity,Int32,CommStopBits,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure > SerialOptions Constructor : SerialOptions Constructor(String,Int32,Parity,Int32,CommStopBits,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean)

portName
Name of port to connect to.
baudRate
Defines the communications speed of the connection.
parity
The parity checking scheme to use.
dataBits
Defines the number of bits in each byte that is transmitted or received (1-255).
stopBits
Number of stop bits.
flowControlDsrDtr
Defines whether the DSR and DTR signals should be used for handshaking.
flowControlXonXoff
Defines whether Xon and Xoff characters should be used for handshaking.
flowControlCtsRts
Defines whether the CTS and RTS signals should be used for handshaking.
flowControlRs485
Defines whether this is an RS485 or RS232 connection.
enableDtr
Defines whether the DTR signal should be enabled.
enableRts
Defines whether the RTS signal should be enabled.
Creates a new instance of the SerialOptions object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal portName As String, _
   ByVal baudRate As Integer, _
   ByVal parity As Parity, _
   ByVal dataBits As Integer, _
   ByVal stopBits As CommStopBits, _
   ByVal flowControlDsrDtr As Boolean, _
   ByVal flowControlXonXoff As Boolean, _
   ByVal flowControlCtsRts As Boolean, _
   ByVal flowControlRs485 As Boolean, _
   ByVal enableDtr As Boolean, _
   ByVal enableRts As Boolean _
)
Visual Basic (Usage) Copy Code
Dim portName As String
Dim baudRate As Integer
Dim parity As Parity
Dim dataBits As Integer
Dim stopBits As CommStopBits
Dim flowControlDsrDtr As Boolean
Dim flowControlXonXoff As Boolean
Dim flowControlCtsRts As Boolean
Dim flowControlRs485 As Boolean
Dim enableDtr As Boolean
Dim enableRts As Boolean

Dim instance As SerialOptions(portName, baudRate, parity, dataBits, stopBits, flowControlDsrDtr, flowControlXonXoff, flowControlCtsRts, flowControlRs485, enableDtr, enableRts)
C#
public SerialOptions(
   string portName,
   int baudRate,
   Parity parity,
   int dataBits,
   CommStopBits stopBits,
   bool flowControlDsrDtr,
   bool flowControlXonXoff,
   bool flowControlCtsRts,
   bool flowControlRs485,
   bool enableDtr,
   bool enableRts
)
Delphi
public SerialOptions(
    portName: String;
    baudRate: Integer;
    parity: Parity;
    dataBits: Integer;
    stopBits: CommStopBits;
    flowControlDsrDtr: Boolean;
    flowControlXonXoff: Boolean;
    flowControlCtsRts: Boolean;
    flowControlRs485: Boolean;
    enableDtr: Boolean;
    enableRts: Boolean
);

Parameters

portName
Name of port to connect to.
baudRate
Defines the communications speed of the connection.
parity
The parity checking scheme to use.
dataBits
Defines the number of bits in each byte that is transmitted or received (1-255).
stopBits
Number of stop bits.
flowControlDsrDtr
Defines whether the DSR and DTR signals should be used for handshaking.
flowControlXonXoff
Defines whether Xon and Xoff characters should be used for handshaking.
flowControlCtsRts
Defines whether the CTS and RTS signals should be used for handshaking.
flowControlRs485
Defines whether this is an RS485 or RS232 connection.
enableDtr
Defines whether the DTR signal should be enabled.
enableRts
Defines whether the RTS signal should be enabled.

Remarks

In order to access any COM port, append the port number to the end of the word "COM" (e.g. "COM7" for port 7).

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members
Overload List


SerialOptions Structure Methods

SerialOptions Structure Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialOptions Structure

For a list of all members of this type, see SerialOptions members.

Public Methods

 | Name | Description
Public Method | CheckValid | Throws an exception if any of the properties are invalid.
Public Method | Equals | (Inherited from System.ValueType)
static (Shared in Visual Basic) | FromString | Creates a new instance of the SerialOptions from a string.
Public Method | GetHashCode | (Inherited from System.ValueType)
Public Method | ToString | Overridden. Returns the options in a string.
Top

See Also

Reference

SerialOptions Structure
CommStudio.Connections Namespace


CheckValid Method

CheckValid Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : CheckValid Method

Throws an exception if any of the properties are invalid.

Syntax

Visual Basic (Declaration)
Public Sub CheckValid()
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions

instance.CheckValid()
C#
public void CheckValid()
Delphi
public procedure CheckValid();

Exceptions

Exception | Description
ArgumentException | When an invalid set of options are defined. The exception will contain a description of which arguments are invalid. Applies to: Parity/DataBits.
ArgumentOutOfRangeException | When an individual option item is set to an invalid value.Applies to: DataBits

Remarks

This member performs a very basic validation, only invalid conditions common to all port devices are checked. Additional conditions which generally cause an invalid connection are: 1) Data Bits set to 5 and Stop Bits set to 2 2) Data Bits set to 6 and Stop Bits set to 1.5 3) Data Bits set to 7 and Stop Bits set to 1.5

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


FromString Method

FromString Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : FromString Method

value
A string that describes the options
Creates a new instance of the SerialOptions from a string.

Syntax

Visual Basic (Declaration)
Public Shared Function FromString( _
   ByVal value As String _
) As SerialOptions
Visual Basic (Usage) Copy Code
Dim value As String
Dim value As SerialOptions

value = SerialOptions.FromString(value)
C#
public static SerialOptions FromString(
   string value
)
Delphi
public function FromString(
    value: String
): SerialOptions; static;

Parameters

value
A string that describes the options

Return Value

A new instance of the SerialOptions.

Example

"COM3:9600,n,7,1.5,DTR,RTS,CTSRTS,DSRDTR,RS485,XONXOFF"

Remarks

The string has the following format: PortName:BaudRate,Parity,DataBits,StopBits[,DTR,RTS,CTSRTS,DSRDTR,RS485,XONXOFF]

  • Parity will be one of the following:
    • Even: e"
    • Mark: "m"
    • None: "n"
    • Odd: "o"
    • Space: "s"
  • Data Bits must be 5, 6, 7, or 8
  • The stop bits must be 1, 1.5, or 2. The closest valid value to the supplied value will be used

The following optional values are used to turn the property on (true)-

  • EnableDtr: "DTR"
  • EnableRts: "RTS"
  • FlowControlCtsRts: "CTSRTS"
  • FlowControlDsrDtr: "DSRDTR"
  • FlowControlRs485: "RS485"
  • FlowControlXonXoff: "XONXOFF"

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members
ToString Method


ToString Method

ToString Method
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : ToString Method

Returns the options in a string.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Delphi
public function ToString(): String; override;

Return Value

String containing the options.

Example

"COM3:9600,n,7,1.5,DTR,RTS,CTSRTS,DSRDTR,RS485,XONXOFF"

Remarks

The string has the following format: PortName:BaudRate,Parity,DataBits,StopBits[,DTR,RTS,CTSRTS,DSRDTR,RS485,XONXOFF]

  • Parity will be one of the following:
    • Even: e"
    • Mark: "m"
    • None: "n"
    • Odd: "o"
    • Space: "s"
  • Data Bits must be 5, 6, 7, or 8
  • The stop bits must be 1, 1.5, or 2. The closest valid value to the supplied value will be used

The following optional values are used to turn the property on (true)-

  • EnableDtr: "DTR"
  • EnableRts: "RTS"
  • FlowControlCtsRts: "CTSRTS"
  • FlowControlDsrDtr: "DSRDTR"
  • FlowControlRs485: "RS485"
  • FlowControlXonXoff: "XONXOFF"

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members
FromString Method


SerialOptions Structure Properties

SerialOptions Structure Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialOptions Structure

For a list of all members of this type, see SerialOptions members.

Public Properties

 | Name | Description
Public Property | BaudRate | Defines the communications speed of the connection.
Public Property | DataBits | Defines the number of bits in each byte that is transmitted or received.
Public Property | EnableDtr | Defines whether the DTR signal should be enabled.
Public Property | EnableRts | Defines whether the RTS signal should be enabled.
Public Property | FlowControlCtsRts | Defines whether the CTS and RTS signals should be used for handshaking.
Public Property | FlowControlDsrDtr | Defines whether the DSR and DTR signals should be used for handshaking.
Public Property | FlowControlRs485 | Defines whether this is an RS485 connection (else it is an RS232).
Public Property | FlowControlXonXoff | Defines whether Xon and Xoff characters should be used for handshaking.
Public Property | Parity | Defines the type of parity checking that is performed.
Public Property | PortName | Defines the communications port used to make the connection.
Public Property | StopBits | Defines the number of stopbits to be used.
Top

See Also

Reference

SerialOptions Structure
CommStudio.Connections Namespace


BaudRate Property

BaudRate Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : BaudRate Property

Defines the communications speed of the connection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("The communications speed of the connection.")>
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property BaudRate As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Integer

instance.BaudRate = value

value = instance.BaudRate
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("The communications speed of the connection.")]
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public int BaudRate {get; set;}
Delphi
public read-write property BaudRate: Integer;

Return Value

Baud rate at which the communication device operates.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


DataBits Property

DataBits Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : DataBits Property

Defines the number of bits in each byte that is transmitted or received.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The number of bits in each byte that is transmitted or received (5,6,7, or 8).")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
Public Property DataBits As Integer
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Integer

instance.DataBits = value

value = instance.DataBits
C#
[DescriptionAttribute("The number of bits in each byte that is transmitted or received (5,6,7, or 8).")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public int DataBits {get; set;}
Delphi
public read-write property DataBits: Integer;

Return Value

Number of bits to use in each byte.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value was less than 5 or greater than 8.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


EnableDtr Property

EnableDtr Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : EnableDtr Property

Defines whether the DTR signal should be enabled.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Whether the DTR signal should be enabled.")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
Public Property EnableDtr As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.EnableDtr = value

value = instance.EnableDtr
C#
[DescriptionAttribute("Whether the DTR signal should be enabled.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public bool EnableDtr {get; set;}
Delphi
public read-write property EnableDtr: Boolean;

Return Value

If DTR signal is enabled.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


EnableRts Property

EnableRts Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : EnableRts Property

Defines whether the RTS signal should be enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Whether the RTS signal should be enabled.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
Public Property EnableRts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.EnableRts = value

value = instance.EnableRts
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Whether the RTS signal should be enabled.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public bool EnableRts {get; set;}
Delphi
public read-write property EnableRts: Boolean;

Return Value

If RTS signal is enabled.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


FlowControlCtsRts Property

FlowControlCtsRts Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : FlowControlCtsRts Property

Defines whether the CTS and RTS signals should be used for handshaking.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Whether CTS and RTS signals should be used for handshaking.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
Public Property FlowControlCtsRts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.FlowControlCtsRts = value

value = instance.FlowControlCtsRts
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Whether CTS and RTS signals should be used for handshaking.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public bool FlowControlCtsRts {get; set;}
Delphi
public read-write property FlowControlCtsRts: Boolean;

Return Value

If CTS/RTS signals are used for handshaking.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


FlowControlDsrDtr Property

FlowControlDsrDtr Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : FlowControlDsrDtr Property

Defines whether the DSR and DTR signals should be used for handshaking.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Whether DSR and DTR signals should be used for handshaking.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property FlowControlDsrDtr As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.FlowControlDsrDtr = value

value = instance.FlowControlDsrDtr
C#
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Whether DSR and DTR signals should be used for handshaking.")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public bool FlowControlDsrDtr {get; set;}
Delphi
public read-write property FlowControlDsrDtr: Boolean;

Return Value

If DSR/DTR signals are used for handshaking.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


FlowControlRs485 Property

FlowControlRs485 Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : FlowControlRs485 Property

Defines whether this is an RS485 connection (else it is an RS232).

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("Whether this is a RS485 connection (else it is an RS232).")>
<BrowsableAttribute(True)>
Public Property FlowControlRs485 As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.FlowControlRs485 = value

value = instance.FlowControlRs485
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("Whether this is a RS485 connection (else it is an RS232).")]
[BrowsableAttribute(true)]
public bool FlowControlRs485 {get; set;}
Delphi
public read-write property FlowControlRs485: Boolean;

Return Value

If this is an RS485 connection.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


FlowControlXonXoff Property

FlowControlXonXoff Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : FlowControlXonXoff Property

Defines whether Xon and Xoff characters should be used for handshaking.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Whether Xon and Xoff characters should be used for handshaking.")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property FlowControlXonXoff As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Boolean

instance.FlowControlXonXoff = value

value = instance.FlowControlXonXoff
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Whether Xon and Xoff characters should be used for handshaking.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool FlowControlXonXoff {get; set;}
Delphi
public read-write property FlowControlXonXoff: Boolean;

Return Value

If Xon/Xoff handshaking should be used.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


Parity Property

Parity Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : Parity Property

Defines the type of parity checking that is performed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The type of parity checking that is performed.")>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property Parity As Parity
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As Parity

instance.Parity = value

value = instance.Parity
C#
[DescriptionAttribute("The type of parity checking that is performed.")]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public Parity Parity {get; set;}
Delphi
public read-write property Parity: Parity;

Return Value

Type of parity checking in effect.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


PortName Property

PortName Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : PortName Property

Defines the communications port used to make the connection.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("The name of the communications port used to make the connection.")>
<BrowsableAttribute(True)>
Public Property PortName As String
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As String

instance.PortName = value

value = instance.PortName
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("The name of the communications port used to make the connection.")]
[BrowsableAttribute(true)]
public string PortName {get; set;}
Delphi
public read-write property PortName: String;

Return Value

Name of port used for current connection.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


StopBits Property

StopBits Property
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace > SerialOptions Structure : StopBits Property

Defines the number of stopbits to be used.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The number of stopbits to use.")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
Public Property StopBits As CommStopBits
Visual Basic (Usage) Copy Code
Dim instance As SerialOptions
Dim value As CommStopBits

instance.StopBits = value

value = instance.StopBits
C#
[DescriptionAttribute("The number of stopbits to use.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public CommStopBits StopBits {get; set;}
Delphi
public read-write property StopBits: CommStopBits;

Return Value

Number of stopbits.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

SerialOptions Structure
SerialOptions Members


Connection.DataAvailableEventHandler Delegate

Connection.DataAvailableEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection.DataAvailableEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when new data is waiting in the input buffer.

Syntax

Visual Basic (Declaration)
Public Delegate Sub Connection.DataAvailableEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataAvailableEventHandler(AddressOf HandlerMethod)
C#
public delegate void Connection.DataAvailableEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate Connection.DataAvailableEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Remarks

This event will fire an event whenever a new set of byte(s) arrives in the input queue.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


Connection.DeviceErrorEventHandler Delegate

Connection.DeviceErrorEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : Connection.DeviceErrorEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when an error happens while waiting on a device event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub Connection.DeviceErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As Connection.CommErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DeviceErrorEventHandler(AddressOf HandlerMethod)
C#
public delegate void Connection.DeviceErrorEventHandler(
   object sender,
   Connection.CommErrorEventArgs e
)
Delphi
public delegate Connection.DeviceErrorEventHandler(
    sender: TObject;
    e: Connection.CommErrorEventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.BreakEventHandler Delegate

SerialConnection.BreakEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.BreakEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when a 'break' is detected on input.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.BreakEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New BreakEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.BreakEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.BreakEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.CarrierEventHandler Delegate

SerialConnection.CarrierEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.CarrierEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when the Carrier signal changes.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.CarrierEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CarrierEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.CarrierEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.CarrierEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.CtsEventHandler Delegate

SerialConnection.CtsEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.CtsEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when CTS signal changed.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.CtsEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CtsEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.CtsEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.CtsEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.DsrEventHandler Delegate

SerialConnection.DsrEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.DsrEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired when the DSR signal has changed on input.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.DsrEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DsrEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.DsrEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.DsrEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.RingEventHandler Delegate

SerialConnection.RingEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.RingEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Fired when a ring indicator is detected.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.RingEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New RingEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.RingEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.RingEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


SerialConnection.WriteCompleteEventHandler Delegate

SerialConnection.WriteCompleteEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : SerialConnection.WriteCompleteEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fires when the last character in the output buffer was sent.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SerialConnection.WriteCompleteEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WriteCompleteEventHandler(AddressOf HandlerMethod)
C#
public delegate void SerialConnection.WriteCompleteEventHandler(
   object sender,
   EventArgs e
)
Delphi
public delegate SerialConnection.WriteCompleteEventHandler(
    sender: TObject;
    e: EventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Requirements

Namespace: CommStudio.Connections

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Connections Namespace


CommStudio.Transfers Namespace

CommStudio.Transfers Namespace
See Also Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Transfers Namespace

Classes

Class | Description
Transfer | This component is used with the Connection class to perform a file transfer. (Professional Edition only)
Transfer.EndFileEventArgs | Fired when the transfer of a single file has been completed. The FileStatus property indicates success or failure.
TransferException | The exception that is thrown when a transfer error occurs.
TransferLocalCanceledException | The exception that is thrown when the local user or application cancels a transfer.
TransferRemoteCanceledException | The exception that is thrown when the remote system cancels a transfer.
TransferTimeOutException | The exception that is thrown when timeout occurs during transfers.
TransferTooFewFilesException | The exception that is thrown when fewer than expected files are transferred.
TransferTooManyFilesException | The exception that is thrown when more files are attempted to be transferred than expected.

Delegates

Delegate | Description
Transfer.EndFileEventHandler | Event fired after each file during the transfer session

Enumerations

Enumeration | Description
TransferFileStatus | The status of the latest file that was transferred (Professional Edition only)
TransferProtocol | Defines all the possible protocols for file transfer. (Professional Edition only)
TransferStatus | The status of the latest or current file transfer session. (Professional Edition only)

See Also

Reference

CommStudio.2 Assembly


Transfer Class

Transfer Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer Class

This component is used with the Connection class to perform a file transfer. (Professional Edition only)

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<LicenseProviderAttribute(CommStudio.LicenseProvider)>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class Transfer
   Inherits Component
Visual Basic (Usage) Copy Code
Dim instance As Transfer
C#
[ToolboxBitmapAttribute()]
[LicenseProviderAttribute(CommStudio.LicenseProvider)]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class Transfer : Component
Delphi
public class Transfer = class(Component)

Remarks

This class is only available in the Professional Edition.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
CommStudio.Transfers.Transfer

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Transfer Members
CommStudio.Transfers Namespace


Transfer Class Members

Transfer Class Members
See Also Properties Methods Events
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer Class

The following tables list the members exposed by Transfer.

Public Constructors

 | Name | Description
Public Constructor | Transfer Constructor | Overloaded. Creates a new instance of the Transfer class inside a Windows Forms designer.
Top

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if the transfer status dialog should be shown when a new transfer is started.
Public Property | Connection | The connection that will be used to perform the file transfer
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Length | Returns the Length in bytes of the current file or stream being transferred, or -1 if unkown.
Public Property | LocalFilename | Gets or sets the full name and path of the file being transferred on the local computer.
Public Property | Path | Defines the default path to use for reading and writing files on the local machine.
Public Property | Position | Indicates the number of bytes that have been transferred
Public Property | Protocol | Type of protocol to be used by the next file transfer.
Public Property | RemoteFilename | Gets or sets the name of the current file as indicated to or from the remote system.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Status | Returns the status of the current file transfer session.
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads
Public Property | TimeElapsed | Indicates the time that has elapsed since the transfer of the current file was started.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | Cancel | Signals the current file transfer to cancel processing as soon as possible.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Download | Overloaded. Starts a file download which uses the supplied stream for the local output.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Upload | Overloaded. Uploads one file from a Stream with specific naming of the file for the receiving system.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
Public Event | BeginFile | Event fired just before a new file is transferred
Public Event | BeginSession | Event fired when a new file transfer session was started.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndFile | Event fired when a file transfer session has terminated.
Public Event | EndSession | Event fired when a file transfer session has terminated.
Public Event | PositionChanged | Event fired when the status of the transfer has changed.
Top

See Also

Reference

Transfer Class
CommStudio.Transfers Namespace


Transfer Constructor

Transfer Constructor
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Transfer Constructor

Creates a new instance of the Transfer class inside a Windows Forms designer.

Overload List

Overload | Description
Transfer Constructor() | Creates a new instance of the Transfer class
Transfer Constructor(IContainer) | Creates a new instance of the Transfer class inside a Windows Forms designer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Transfer Constructor()

Transfer Constructor()
See Also
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Transfer Constructor : Transfer Constructor()

Creates a new instance of the Transfer class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Transfer()
C#
public Transfer()
Delphi
public Transfer();

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Transfer Constructor(IContainer)

Transfer Constructor(IContainer)
See Also
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Transfer Constructor : Transfer Constructor(IContainer)

container
Container to place this new instance of the Transfer class.
Creates a new instance of the Transfer class inside a Windows Forms designer.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As Transfer(container)
C#
public Transfer(
   IContainer container
)
Delphi
public Transfer(
    container: IContainer
);

Parameters

container
Container to place this new instance of the Transfer class.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Transfer Class Methods

Transfer Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer Class

For a list of all members of this type, see Transfer members.

Public Methods

 | Name | Description
Public Method | Cancel | Signals the current file transfer to cancel processing as soon as possible.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Download | Overloaded. Starts a file download which uses the supplied stream for the local output.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Upload | Overloaded. Uploads one file from a Stream with specific naming of the file for the receiving system.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

Transfer Class
CommStudio.Transfers Namespace


Cancel Method

Cancel Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Cancel Method

Signals the current file transfer to cancel processing as soon as possible.

Syntax

Visual Basic (Declaration)
Public Sub Cancel()
Visual Basic (Usage) Copy Code
Dim instance As Transfer

instance.Cancel()
C#
public void Cancel()
Delphi
public procedure Cancel();

Return Value

State of cancel before this member was called ('true' signals the transfer was already trying to abort when this function was called).

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Dispose Method

Dispose Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Dispose Method

Clean up any resources being used.

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Dispose Method : Dispose(Boolean) Method

disposing
Clean up any resources being used.

Syntax

Visual Basic (Declaration)
Overloads Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;

Parameters

disposing

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Download Method

Download Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Download Method

Starts a file download which uses the supplied stream for the local output.

Overload List

Overload | Description
Download(Stream) | Starts a file download which uses the supplied stream for the local output.
Download(Stream[]) | Starts a transfer for a set of files, the resulting files use the default filename.
Download() | Starts a new file download using the default filename.
Download(String) | Starts a file download which uses the supplied name for the local file.
Download(String[]) | Starts a transfer for a set of files, the resulting files use the default filename.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Download(Stream) Method

Download(Stream) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Download Method : Download(Stream) Method

outputStream
Source data stream to send.
Starts a file download which uses the supplied stream for the local output.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Download( _
   ByVal outputStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim outputStream As Stream

instance.Download(outputStream)
C#
public void Download(
   Stream outputStream
)
Delphi
public procedure Download(
    outputStream: Stream
);

Parameters

outputStream
Source data stream to send.

Return Value

Completion status of the transfer.

Remarks

  • This method will place the active thread in a wait state for a new file to begin a transfer using the active protocol on the current port.
  • The output filename will be ignored from any protocol providing one a name.
  • The restart option will not be used, even when the protocol supports it.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Download(Stream[]) Method

Download(Stream[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Download Method : Download(Stream[]) Method

outputStreams
List of Streams to use for output of the next set of arriving files.
Starts a transfer for a set of files, the resulting files use the default filename.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Download( _
   ByVal outputStreams() As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim outputStreams() As Stream

instance.Download(outputStreams)
C#
public void Download(
   Stream[] outputStreams
)
Delphi
public procedure Download(
    outputStreams: Streamarray of
);

Parameters

outputStreams
List of Streams to use for output of the next set of arriving files.

Return Value

Completion status of the transfer.

Remarks

This method will place the active thread in a wait state until all files to finish transfer using the active protocol on the current port. Also, the return code tells you the worst case return code from all of the files in the supplied list.
  • If the current protocol is not Xmodem, the new filename will use that which is supplied.
  • Other protocol types will be named according to the supplied argument (replacing the name sent via the transmission).
  • For Xmodem, any existing file by this name will always be replaced.
  • For protocols which support it and when the file already exists, the system will attempt to restart where it last stopped.
  • Incoming requested filenames will be ignored.
  • Any incoming transfers in excess of the available list will be assigned a default filename.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Download() Method

Download() Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Download Method : Download() Method

Starts a new file download using the default filename.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Download()
Visual Basic (Usage) Copy Code
Dim instance As Transfer

instance.Download()
C#
public void Download()
Delphi
public procedure Download();

Return Value

Completion status of the transfer.

Remarks

  • This method will place the active thread in a wait state until the file transfer has completed using the active protocol on the current port.
  • If the current protocol is Xmodem, a new filename called Untitled.xxx is automatically generated, where xxx is 000, 001, 002, etc. For other protocols, the filename supplied by the other computer is used.
  • Attempting to transfer more than one file using Xmodem may cause unexpected results on the receiving side since no file separators sent.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Download(String) Method

Download(String) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Download Method : Download(String) Method

localFilename
Name to assign to the next arriving file (will use directly for Xmodem or rename the file for other protocols).
Starts a file download which uses the supplied name for the local file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Download( _
   ByVal localFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim localFilename As String

instance.Download(localFilename)
C#
public void Download(
   string localFilename
)
Delphi
public procedure Download(
    localFilename: String
);

Parameters

localFilename
Name to assign to the next arriving file (will use directly for Xmodem or rename the file for other protocols).

Return Value

Completion status of the transfer.
Completion status of the transfer.

Exceptions

Exception | Description
IOException | The process cannot access the file because it does not exist or is being used by another process.
UnauthorizedAccessException | Access to the path or file is denied.
DirectoryNotFoundException | Could not find a part of the supplied path.
FileNotFoundException | Could not find the supplied file.

Remarks

  • This method will place the active thread in a wait state until the transfer has completed using the active protocol on the current port.
  • If the current protocol is not Xmodem, the new filename will use that which is supplied.
  • Other protocol types will be named according to the supplied argument (replacing the name sent via the transmission).
  • For Xmodem, any existing file by this name will always be replaced.
  • For protocols which support it, and when the file already exists, the system will attempt to restart where it last stopped.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Download(String[]) Method

Download(String[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Download Method : Download(String[]) Method

localFilenames
Names to assign to the next set of arriving files (will use directly for Xmodem or rename the file for other protocols).
Starts a transfer for a set of files, the resulting files use the default filename.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Download( _
   ByVal localFilenames() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim localFilenames() As String

instance.Download(localFilenames)
C#
public void Download(
   string[] localFilenames
)
Delphi
public procedure Download(
    localFilenames: Stringarray of
);

Parameters

localFilenames
Names to assign to the next set of arriving files (will use directly for Xmodem or rename the file for other protocols).

Return Value

Completion status of the transfer.
Completion status of the transfer.

Remarks

This method will place the active thread in a wait state until the transfer has completed for all files using the active protocol on the current port.
  • If the current protocol is not Xmodem, the new filename will use that which is supplied.
  • Other protocol types will be named according to the supplied argument (replacing the name sent via the transmission).
  • For Xmodem, any existing file by this name will always be replaced.
  • For protocols which support it and when the file already exists, the system will attempt to restart where it last stopped.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload Method

Upload Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Upload Method

Uploads one file from a Stream with specific naming of the file for the receiving system.

Overload List

Overload | Description
Upload(Stream,String) | Uploads one file from a Stream with specific naming of the file for the receiving system.
Upload(Stream) | Uploads one file from a Stream with the destination name automatically generated.
Upload(Stream[]) | Synchronously uploads a list of files.
Upload(Stream[],String[]) | Synchronously uploads a list of Stream classes with the ability to produce new names on the receiving system.
Upload(String,String) | Uploads one file with specific naming of the file for the receiving system.
Upload(String) | Uploads one file with the destination name the same as the base input filename.
Upload(String[]) | Synchronously uploads a list of files.
Upload(String[],String[]) | Synchronously uploads a list of files with the ability to produce new names on the receiving system.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Upload(Stream,String) Method

Upload(Stream,String) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(Stream,String) Method

inputStream
Source data stream to send.
destinationFilename
Name to assign to the resulting file on the receiving system.
Uploads one file from a Stream with specific naming of the file for the receiving system.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal inputStream As Stream, _
   ByVal destinationFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim inputStream As Stream
Dim destinationFilename As String

instance.Upload(inputStream, destinationFilename)
C#
public void Upload(
   Stream inputStream,
   string destinationFilename
)
Delphi
public procedure Upload(
    inputStream: Stream;
    destinationFilename: String
);

Parameters

inputStream
Source data stream to send.
destinationFilename
Name to assign to the resulting file on the receiving system.

Return Value

Completion status of the transfer.

Remarks

  • This is a synchronous process- your process will be wait until the transfer of this file has completed.
  • Not all protocols assign a name to the resulting file, so the resulting name may differ from the input name.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(Stream) Method

Upload(Stream) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(Stream) Method

inputStream
Source data stream to send.
Uploads one file from a Stream with the destination name automatically generated.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal inputStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim inputStream As Stream

instance.Upload(inputStream)
C#
public void Upload(
   Stream inputStream
)
Delphi
public procedure Upload(
    inputStream: Stream
);

Parameters

inputStream
Source data stream to send.

Return Value

Completion status of the transfer.

Exceptions

Exception | Description
NotSupportedException | Thrown when the supplied stream does not support read or seek.

Remarks

  • Some protocols require that a name be assigned to the resulting file. For this case, a name will be generated according to automatic name generation rules.
  • The stream must support seeking in order to determine the length in bytes of the stream. Without this ability, the transfer protocols would be unable to operate properly.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(Stream[]) Method

Upload(Stream[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(Stream[]) Method

inputStreams
List of Streams to upload to another system.
Synchronously uploads a list of files.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal inputStreams() As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim inputStreams() As Stream

instance.Upload(inputStreams)
C#
public void Upload(
   Stream[] inputStreams
)
Delphi
public procedure Upload(
    inputStreams: Streamarray of
);

Parameters

inputStreams
List of Streams to upload to another system.

Return Value

Completion status - OK signifies that an attempt was made to upload each file in the list.

Exceptions

Exception | Description
NotSupportedException | Thrown when the supplied stream does not support the read and seek properties.

Remarks

The return code does not tell you if all files were correctly Uploaded, only that an attempt was made to upload each file. A failure return on any file will store that value and return it.
  • This is a synchronous process- your process will be wait until the transfer of all files have completed.
  • Not all protocols assign a name to the resulting file, so the resulting name may differ from the input name.
  • Attempting to transfer more than one file using Xmodem may cause unexpected results on the receiving side since no file separators are sent.
  • The stream must support seeking in order to determine the length in bytes of the stream. Without this ability, the transfer protocols would be unable to operate properly.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(Stream[],String[]) Method

Upload(Stream[],String[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(Stream[],String[]) Method

inputStreams
List of Streams to upload to another system.
remoteFilenames
List of names to assign to the resulting files on the receiving system.
Synchronously uploads a list of Stream classes with the ability to produce new names on the receiving system.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal inputStreams() As Stream, _
   ByVal remoteFilenames() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim inputStreams() As Stream
Dim remoteFilenames() As String

instance.Upload(inputStreams, remoteFilenames)
C#
public void Upload(
   Stream[] inputStreams,
   string[] remoteFilenames
)
Delphi
public procedure Upload(
    inputStreams: Streamarray of;
    remoteFilenames: Stringarray of
);

Parameters

inputStreams
List of Streams to upload to another system.
remoteFilenames
List of names to assign to the resulting files on the receiving system.

Return Value

Completion status of the transfer.

Exceptions

Exception | Description
NotSupportedException | Thrown when the supplied stream does not support the read and seek properties.

Remarks

  • This is a synchronous process- your process will be wait until the transfer of this file has completed.
  • Attempting to transfer more than one file using Xmodem may cause unexpected results on the receiving side since no file separators sent.
  • The stream must support seeking in order to determine the length in bytes of the stream. Without this ability, the transfer protocols would be unable to operate properly.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(String,String) Method

Upload(String,String) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(String,String) Method

localFilename
Name of the file to upload.
destinationFilename
Name to assign to the resulting file on the receiving system.
Uploads one file with specific naming of the file for the receiving system.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal localFilename As String, _
   ByVal destinationFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim localFilename As String
Dim destinationFilename As String

instance.Upload(localFilename, destinationFilename)
C#
public void Upload(
   string localFilename,
   string destinationFilename
)
Delphi
public procedure Upload(
    localFilename: String;
    destinationFilename: String
);

Parameters

localFilename
Name of the file to upload.
destinationFilename
Name to assign to the resulting file on the receiving system.

Return Value

Completion status of the transfer.

Exceptions

Exception | Description
IOException | The process cannot access the file because it does not exist or is being used by another process.
UnauthorizedAccessException | Access to the path or file is denied.
DirectoryNotFoundException | Could not find a part of the supplied path.
FileNotFoundException | Could not find the supplied file.

Remarks

  • This is a synchronous process- your process will be wait until the transfer of this file has completed.
  • Not all protocols assign a name to the resulting file, so the resulting name may differ from the input name.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(String) Method

Upload(String) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(String) Method

localFilename
Name of the file to upload.
Uploads one file with the destination name the same as the base input filename.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal localFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim localFilename As String

instance.Upload(localFilename)
C#
public void Upload(
   string localFilename
)
Delphi
public procedure Upload(
    localFilename: String
);

Parameters

localFilename
Name of the file to upload.

Return Value

Completion status of the transfer.

Remarks

Not all protocols assign a name to the resulting file, so the resulting name may differ from the input name.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(String[]) Method

Upload(String[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(String[]) Method

filenames
List of files to upload to another system.
Synchronously uploads a list of files.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal filenames() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim filenames() As String

instance.Upload(filenames)
C#
public void Upload(
   string[] filenames
)
Delphi
public procedure Upload(
    filenames: Stringarray of
);

Parameters

filenames
List of files to upload to another system.

Return Value

Completion status of the transfer.

Remarks

  • This is a synchronous process- your process will wait until the transfer of all files have completed.
  • Not all protocols assign a name to the resulting file, so the resulting name may differ from the input name.
  • Attempting to transfer more than one file using Xmodem may cause unexpected results on the receiving side since no file separators are sent.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Upload(String[],String[]) Method

Upload(String[],String[]) Method
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class > Upload Method : Upload(String[],String[]) Method

localFilenames
List of files to upload to another system.
remoteFilenames
List of names to assign to the resulting files on the receiving system.
Synchronously uploads a list of files with the ability to produce new names on the receiving system.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Upload( _
   ByVal localFilenames() As String, _
   ByVal remoteFilenames() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim localFilenames() As String
Dim remoteFilenames() As String

instance.Upload(localFilenames, remoteFilenames)
C#
public void Upload(
   string[] localFilenames,
   string[] remoteFilenames
)
Delphi
public procedure Upload(
    localFilenames: Stringarray of;
    remoteFilenames: Stringarray of
);

Parameters

localFilenames
List of files to upload to another system.
remoteFilenames
List of names to assign to the resulting files on the receiving system.

Return Value

Completion status of the transfer.

Remarks

  • This is a synchronous process- your process will wait until the transfer of all files have completed.
  • Attempting to transfer more than one file using Xmodem may cause unexpected results on the receiving side since no file separators sent.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members
Overload List


Transfer Class Properties

Transfer Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer Class

For a list of all members of this type, see Transfer members.

Public Properties

 | Name | Description
Public Property | AutoShowStatusDialog | Determines if the transfer status dialog should be shown when a new transfer is started.
Public Property | Connection | The connection that will be used to perform the file transfer
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Length | Returns the Length in bytes of the current file or stream being transferred, or -1 if unkown.
Public Property | LocalFilename | Gets or sets the full name and path of the file being transferred on the local computer.
Public Property | Path | Defines the default path to use for reading and writing files on the local machine.
Public Property | Position | Indicates the number of bytes that have been transferred
Public Property | Protocol | Type of protocol to be used by the next file transfer.
Public Property | RemoteFilename | Gets or sets the name of the current file as indicated to or from the remote system.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Status | Returns the status of the current file transfer session.
Public Property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued from other threads
Public Property | TimeElapsed | Indicates the time that has elapsed since the transfer of the current file was started.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Transfer Class
CommStudio.Transfers Namespace


AutoShowStatusDialog Property

AutoShowStatusDialog Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : AutoShowStatusDialog Property

Determines if the transfer status dialog should be shown when a new transfer is started.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("User Interface")>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines if the transfer status dialog should be shown when a new transfer is started.")>
<BrowsableAttribute(True)>
Public Property AutoShowStatusDialog As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As Boolean

instance.AutoShowStatusDialog = value

value = instance.AutoShowStatusDialog
C#
[CategoryAttribute("User Interface")]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the transfer status dialog should be shown when a new transfer is started.")]
[BrowsableAttribute(true)]
public bool AutoShowStatusDialog {get; set;}
Delphi
public read-write property AutoShowStatusDialog: Boolean;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Connection Property

Connection Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Connection Property

The connection that will be used to perform the file transfer

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The connection that will be used to perform the file transfer.")>
<CategoryAttribute("File Transfer")>
<BrowsableAttribute(True)>
Public Property Connection As Connection
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As Connection

instance.Connection = value

value = instance.Connection
C#
[DescriptionAttribute("The connection that will be used to perform the file transfer.")]
[CategoryAttribute("File Transfer")]
[BrowsableAttribute(true)]
public Connection Connection {get; set;}
Delphi
public read-write property Connection: Connection;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Length Property

Length Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Length Property

Returns the Length in bytes of the current file or stream being transferred, or -1 if unkown.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DescriptionAttribute("The Length in bytes of the current file or stream being transferred, or -1 if unkown")>
Public ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As Long

value = instance.Length
C#
[BrowsableAttribute(false)]
[DescriptionAttribute("The Length in bytes of the current file or stream being transferred, or -1 if unkown")]
public long Length {get;}
Delphi
public read-only property Length: Int64;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


LocalFilename Property

LocalFilename Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : LocalFilename Property

Gets or sets the full name and path of the file being transferred on the local computer.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The full name and path of the file being transferred on the local computer")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property LocalFilename As String
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As String

value = instance.LocalFilename
C#
[DescriptionAttribute("The full name and path of the file being transferred on the local computer")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string LocalFilename {get;}
Delphi
public read-only property LocalFilename: String;

Remarks

Except during a BegingFileTransfer event, this property is read-only. It can be set during a BeginFileTransfer event to override the local file. It is null if no transfer is in progress, or of the Upload or Download variations that only use streams were used to initiate the transfer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Path Property

Path Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Path Property

Defines the default path to use for reading and writing files on the local machine.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("File Transfer")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Default path to use for reading and writing files on the local machine.")>
Public Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As String

instance.Path = value

value = instance.Path
C#
[CategoryAttribute("File Transfer")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Default path to use for reading and writing files on the local machine.")]
public string Path {get; set;}
Delphi
public read-write property Path: String;

Return Value

Default path for files on local machine.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Position Property

Position Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Position Property

Indicates the number of bytes that have been transferred

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DescriptionAttribute("The number of bytes that have been transferred")>
Public ReadOnly Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As Long

value = instance.Position
C#
[BrowsableAttribute(false)]
[DescriptionAttribute("The number of bytes that have been transferred")]
public long Position {get;}
Delphi
public read-only property Position: Int64;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Protocol Property

Protocol Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Protocol Property

Type of protocol to be used by the next file transfer.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Type of protocol to use in the file transfer.")>
<CategoryAttribute("File Transfer")>
<BrowsableAttribute(True)>
Public Property Protocol As TransferProtocol
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As TransferProtocol

instance.Protocol = value

value = instance.Protocol
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Type of protocol to use in the file transfer.")]
[CategoryAttribute("File Transfer")]
[BrowsableAttribute(true)]
public TransferProtocol Protocol {get; set;}
Delphi
public read-write property Protocol: TransferProtocol;

Return Value

File protocol used on current or next transfer.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


RemoteFilename Property

RemoteFilename Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : RemoteFilename Property

Gets or sets the name of the current file as indicated to or from the remote system.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("The name of the current file as indicated to or from the remote system")>
Public ReadOnly Property RemoteFilename As String
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As String

value = instance.RemoteFilename
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("The name of the current file as indicated to or from the remote system")]
public string RemoteFilename {get;}
Delphi
public read-only property RemoteFilename: String;

Remarks

Except during a BeginFileTransfer event, this property is read-only. During an upload, this property can be set inside a BeginFileTransfer event to override the filename that is sent to the remote system. It is null if no transfer is in progress, or if a protocol is used that doesn't transfer the filename, such as XModem.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Status Property

Status Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : Status Property

Returns the status of the current file transfer session.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Returns the status of the current file transfer session.")>
<CategoryAttribute("File Transfer")>
<BrowsableAttribute(False)>
Public ReadOnly Property Status As TransferStatus
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As TransferStatus

value = instance.Status
C#
[DescriptionAttribute("Returns the status of the current file transfer session.")]
[CategoryAttribute("File Transfer")]
[BrowsableAttribute(false)]
public TransferStatus Status {get;}
Delphi
public read-only property Status: TransferStatus;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


SynchronizingObject Property

SynchronizingObject Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : SynchronizingObject Property

Gets or sets the object used to marshal the event handler calls issued from other threads

Syntax

Visual Basic (Declaration)
<CategoryAttribute()>
<DescriptionAttribute("The object used to marshal the event handler calls issued from communications threads")>
<BrowsableAttribute(True)>
Public Property SynchronizingObject As ISynchronizeInvoke
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As ISynchronizeInvoke

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
[CategoryAttribute()]
[DescriptionAttribute("The object used to marshal the event handler calls issued from communications threads")]
[BrowsableAttribute(true)]
public ISynchronizeInvoke SynchronizingObject {get; set;}
Delphi
public read-write property SynchronizingObject: ISynchronizeInvoke;

Remarks

When SynchronizingObject is a null reference (Nothing in Visual Basic), event methods are called on a thread from the system thread pool. For more information on system thread pools, see ThreadPool. When the component is used in a Windows Forms environment, accessing the form or any of its controls through the system thread pool might not work, or may result in an exception. Avoid this by setting SynchronizingObject to a Windows Forms component, which causes the methods that handle the events to be called on the same thread on which the component was created. If the Connection component is used inside Visual Studio .NET in a Windows Forms designer, SynchronizingObject automatically sets to the control that contains the Connection. For example, if you place a Connection on a designer for Form1 (which inherits from Form) the SynchronizingObject property of Connection is set to the instance of Form1.

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


TimeElapsed Property

TimeElapsed Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : TimeElapsed Property

Indicates the time that has elapsed since the transfer of the current file was started.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The time that has elapsed since the transfer of the current file was started.")>
<BrowsableAttribute(False)>
Public ReadOnly Property TimeElapsed As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim value As TimeSpan

value = instance.TimeElapsed
C#
[DescriptionAttribute("The time that has elapsed since the transfer of the current file was started.")]
[BrowsableAttribute(false)]
public TimeSpan TimeElapsed {get;}
Delphi
public read-only property TimeElapsed: TimeSpan;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Transfer Class Events

Transfer Class Events
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer Class

For a list of all members of this type, see Transfer members.

Public Events

 | Name | Description
Public Event | BeginFile | Event fired just before a new file is transferred
Public Event | BeginSession | Event fired when a new file transfer session was started.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndFile | Event fired when a file transfer session has terminated.
Public Event | EndSession | Event fired when a file transfer session has terminated.
Public Event | PositionChanged | Event fired when the status of the transfer has changed.
Top

See Also

Reference

Transfer Class
CommStudio.Transfers Namespace


BeginFile Event

BeginFile Event
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : BeginFile Event

Event fired just before a new file is transferred

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Event fired just before a new file is transferred")>
<CategoryAttribute("File Transfer")>
Public Event BeginFile() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim handler As EventHandler

AddHandler instance.BeginFile, handler
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Event fired just before a new file is transferred")]
[CategoryAttribute("File Transfer")]
public event EventHandler BeginFile()
Delphi
public event BeginFile: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


BeginSession Event

BeginSession Event
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : BeginSession Event

Event fired when a new file transfer session was started.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("A new file transfer session was started.")>
<CategoryAttribute("File Transfer")>
Public Event BeginSession() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim handler As EventHandler

AddHandler instance.BeginSession, handler
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("A new file transfer session was started.")]
[CategoryAttribute("File Transfer")]
public event EventHandler BeginSession()
Delphi
public event BeginSession: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


EndFile Event

EndFile Event
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : EndFile Event

Event fired when a file transfer session has terminated.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The file transfer has terminated.")>
<BrowsableAttribute(True)>
<CategoryAttribute("File Transfer")>
Public Event EndFile() As Transfer.EndFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim handler As Transfer.EndFileEventHandler

AddHandler instance.EndFile, handler
C#
[DescriptionAttribute("The file transfer has terminated.")]
[BrowsableAttribute(true)]
[CategoryAttribute("File Transfer")]
public event Transfer.EndFileEventHandler EndFile()
Delphi
public event EndFile: Transfer.EndFileEventHandler;

Event Data

The event handler receives an argument of type Transfer.EndFileEventArgs containing data related to this event. The following Transfer.EndFileEventArgs properties provide information specific to this event.

Property | Description
FileStatus | Indicates whether the file was transferred successfully

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


EndSession Event

EndSession Event
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : EndSession Event

Event fired when a file transfer session has terminated.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The file transfer has terminated.")>
<BrowsableAttribute(True)>
<CategoryAttribute("File Transfer")>
Public Event EndSession() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim handler As EventHandler

AddHandler instance.EndSession, handler
C#
[DescriptionAttribute("The file transfer has terminated.")]
[BrowsableAttribute(true)]
[CategoryAttribute("File Transfer")]
public event EventHandler EndSession()
Delphi
public event EndSession: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


PositionChanged Event

PositionChanged Event
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer Class : PositionChanged Event

Event fired when the status of the transfer has changed.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Event fired when the Position property, indicating the number of bytes transferred, has changed.")>
<CategoryAttribute("File Transfer")>
Public Event PositionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Transfer
Dim handler As EventHandler

AddHandler instance.PositionChanged, handler
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Event fired when the Position property, indicating the number of bytes transferred, has changed.")]
[CategoryAttribute("File Transfer")]
public event EventHandler PositionChanged()
Delphi
public event PositionChanged: EventHandler;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer Class
Transfer Members


Transfer.EndFileEventArgs Class

Transfer.EndFileEventArgs Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer.EndFileEventArgs Class

Fired when the transfer of a single file has been completed. The FileStatus property indicates success or failure.

Syntax

Visual Basic (Declaration)
Public Class Transfer.EndFileEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As Transfer.EndFileEventArgs
C#
public class Transfer.EndFileEventArgs : EventArgs
Delphi
public class Transfer.EndFileEventArgs = class(EventArgs)

Inheritance Hierarchy

System.Object
System.EventArgs
CommStudio.Transfers.Transfer.EndFileEventArgs

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

Transfer.EndFileEventArgs Members
CommStudio.Transfers Namespace


Transfer.EndFileEventArgs Class Members

Transfer.EndFileEventArgs Class Members
See Also Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer.EndFileEventArgs Class

The following tables list the members exposed by Transfer.EndFileEventArgs.

Public Constructors

 | Name | Description
Public Constructor | Transfer.EndFileEventArgs Constructor | Creates a new instance o fthe EndFileEventArgs class
Top

Public Properties

 | Name | Description
Public Property | FileStatus | Indicates whether the file was transferred successfully
Top

See Also

Reference

Transfer.EndFileEventArgs Class
CommStudio.Transfers Namespace


Transfer.EndFileEventArgs Constructor

Transfer.EndFileEventArgs Constructor
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer.EndFileEventArgs Class : Transfer.EndFileEventArgs Constructor

fileStatus
Indicates whether the file was transferred successfully
Creates a new instance o fthe EndFileEventArgs class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileStatus As TransferFileStatus _
)
Visual Basic (Usage) Copy Code
Dim fileStatus As TransferFileStatus

Dim instance As Transfer.EndFileEventArgs(fileStatus)
C#
public Transfer.EndFileEventArgs(
   TransferFileStatus fileStatus
)
Delphi
public Transfer.EndFileEventArgs(
    fileStatus: TransferFileStatus
);

Parameters

fileStatus
Indicates whether the file was transferred successfully

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer.EndFileEventArgs Class
Transfer.EndFileEventArgs Members


Transfer.EndFileEventArgs Class Properties

Transfer.EndFileEventArgs Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer.EndFileEventArgs Class

For a list of all members of this type, see Transfer.EndFileEventArgs members.

Public Properties

 | Name | Description
Public Property | FileStatus | Indicates whether the file was transferred successfully
Top

See Also

Reference

Transfer.EndFileEventArgs Class
CommStudio.Transfers Namespace


FileStatus Property

FileStatus Property
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > Transfer.EndFileEventArgs Class : FileStatus Property

Indicates whether the file was transferred successfully

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileStatus As TransferFileStatus
Visual Basic (Usage) Copy Code
Dim instance As Transfer.EndFileEventArgs
Dim value As TransferFileStatus

value = instance.FileStatus
C#
public TransferFileStatus FileStatus {get;}
Delphi
public read-only property FileStatus: TransferFileStatus;

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

Transfer.EndFileEventArgs Class
Transfer.EndFileEventArgs Members


TransferException Class

TransferException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferException Class

The exception that is thrown when a transfer error occurs.

Syntax

Visual Basic (Declaration)
Public Class TransferException
   Inherits Exception
Visual Basic (Usage) Copy Code
Dim instance As TransferException
C#
public class TransferException : Exception
Delphi
public class TransferException = class(Exception)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferTooManyFilesException
CommStudio.Transfers.TransferTooFewFilesException
CommStudio.Transfers.TransferTimeOutException
CommStudio.Transfers.TransferRemoteCanceledException
CommStudio.Transfers.TransferLocalCanceledException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferException Members
CommStudio.Transfers Namespace


TransferException Class Members

TransferException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferException Class

The following tables list the members exposed by TransferException.

Public Constructors

 | Name | Description
Public Constructor | TransferException Constructor | Initializes a new instance of the TransferException class.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferException Class
CommStudio.Transfers Namespace


TransferException Constructor

TransferException Constructor
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace > TransferException Class : TransferException Constructor

message
Initializes a new instance of the TransferException class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As TransferException(message)
C#
public TransferException(
   string message
)
Delphi
public TransferException(
    message: String
);

Parameters

message

Requirements

Platforms: Windows XP, Windows Vista, Windows 2003 Server

See Also

Reference

TransferException Class
TransferException Members


TransferLocalCanceledException Class

TransferLocalCanceledException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferLocalCanceledException Class

The exception that is thrown when the local user or application cancels a transfer.

Syntax

Visual Basic (Declaration)
Public Class TransferLocalCanceledException
   Inherits TransferException
Visual Basic (Usage) Copy Code
Dim instance As TransferLocalCanceledException
C#
public class TransferLocalCanceledException : TransferException
Delphi
public class TransferLocalCanceledException = class(TransferException)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferLocalCanceledException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferLocalCanceledException Members
CommStudio.Transfers Namespace


TransferLocalCanceledException Class Members

TransferLocalCanceledException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferLocalCanceledException Class

The following tables list the members exposed by TransferLocalCanceledException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferLocalCanceledException Class
CommStudio.Transfers Namespace


TransferRemoteCanceledException Class

TransferRemoteCanceledException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferRemoteCanceledException Class

The exception that is thrown when the remote system cancels a transfer.

Syntax

Visual Basic (Declaration)
Public Class TransferRemoteCanceledException
   Inherits TransferException
Visual Basic (Usage) Copy Code
Dim instance As TransferRemoteCanceledException
C#
public class TransferRemoteCanceledException : TransferException
Delphi
public class TransferRemoteCanceledException = class(TransferException)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferRemoteCanceledException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferRemoteCanceledException Members
CommStudio.Transfers Namespace


TransferRemoteCanceledException Class Members

TransferRemoteCanceledException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferRemoteCanceledException Class

The following tables list the members exposed by TransferRemoteCanceledException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferRemoteCanceledException Class
CommStudio.Transfers Namespace


TransferTimeOutException Class

TransferTimeOutException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTimeOutException Class

The exception that is thrown when timeout occurs during transfers.

Syntax

Visual Basic (Declaration)
Public Class TransferTimeOutException
   Inherits TransferException
Visual Basic (Usage) Copy Code
Dim instance As TransferTimeOutException
C#
public class TransferTimeOutException : TransferException
Delphi
public class TransferTimeOutException = class(TransferException)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferTimeOutException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferTimeOutException Members
CommStudio.Transfers Namespace


TransferTimeOutException Class Members

TransferTimeOutException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTimeOutException Class

The following tables list the members exposed by TransferTimeOutException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTimeOutException Class
CommStudio.Transfers Namespace


TransferTooFewFilesException Class

TransferTooFewFilesException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooFewFilesException Class

The exception that is thrown when fewer than expected files are transferred.

Syntax

Visual Basic (Declaration)
Public Class TransferTooFewFilesException
   Inherits TransferException
Visual Basic (Usage) Copy Code
Dim instance As TransferTooFewFilesException
C#
public class TransferTooFewFilesException : TransferException
Delphi
public class TransferTooFewFilesException = class(TransferException)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferTooFewFilesException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferTooFewFilesException Members
CommStudio.Transfers Namespace


TransferTooFewFilesException Class Members

TransferTooFewFilesException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooFewFilesException Class

The following tables list the members exposed by TransferTooFewFilesException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooFewFilesException Class
CommStudio.Transfers Namespace


TransferTooManyFilesException Class

TransferTooManyFilesException Class
See Also Members
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooManyFilesException Class

The exception that is thrown when more files are attempted to be transferred than expected.

Syntax

Visual Basic (Declaration)
Public Class TransferTooManyFilesException
   Inherits TransferException
Visual Basic (Usage) Copy Code
Dim instance As TransferTooManyFilesException
C#
public class TransferTooManyFilesException : TransferException
Delphi
public class TransferTooManyFilesException = class(TransferException)

Inheritance Hierarchy

System.Object
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferTooManyFilesException

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

TransferTooManyFilesException Members
CommStudio.Transfers Namespace


TransferTooManyFilesException Class Members

TransferTooManyFilesException Class Members
See Also Properties Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooManyFilesException Class

The following tables list the members exposed by TransferTooManyFilesException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooManyFilesException Class
CommStudio.Transfers Namespace


TransferFileStatus Enumeration

TransferFileStatus Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferFileStatus Enumeration

The status of the latest file that was transferred (Professional Edition only)

Syntax

Visual Basic (Declaration)
Public Enum TransferFileStatus
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransferFileStatus
C#
public enum TransferFileStatus : Enum
Delphi
public enum TransferFileStatus = class(Enum)

Members

Member | Description
Completed | The file was transfered successfully
Failed | The file transfer failed
Skipped | The file was skipped and it was not transferred

Remarks

This enumeration is only available in the Professional Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Transfers.TransferFileStatus

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Transfers Namespace


TransferProtocol Enumeration

TransferProtocol Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferProtocol Enumeration

Defines all the possible protocols for file transfer. (Professional Edition only)

Syntax

Visual Basic (Declaration)
Public Enum TransferProtocol
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransferProtocol
C#
public enum TransferProtocol : Enum
Delphi
public enum TransferProtocol = class(Enum)

Members

Member | Description
XmodemChecksum | Original Xmodem protocol using simple checksum for error detection.
XmodemCrc | Xmodem using Cyclic Redundancy Check (CRC) for error detection.
Xmodem1K | Xmodem protocol using CRC for error detection and a 1024 byte buffer for transfer.
Ymodem | Ymodem protocol (uses CRC for error detection).
Zmodem | Zmodem protocol (uses CRC for error detection, a sliding window, and may restart from a disconnected file transfer).

Remarks

This enumeration is only available in the Professional Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Transfers.TransferProtocol

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Transfers Namespace


TransferStatus Enumeration

TransferStatus Enumeration
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferStatus Enumeration

The status of the latest or current file transfer session. (Professional Edition only)

Syntax

Visual Basic (Declaration)
Public Enum TransferStatus
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TransferStatus
C#
public enum TransferStatus : Enum
Delphi
public enum TransferStatus = class(Enum)

Members

Member | Description
NotStarted | No file transfer has been started
Completed | The last file transfer session was completed successfully
CanceledByRemote | The last file transfer session was canceled by the remote computer
CanceledByLocal | The last file transfer session was canceled by the local computer
Failed | The last file transfer session failed unexepectedly
Uploading | A current file transfer session to upload files is in progress
Downloading | A current file transfer session to download files is in progress

Remarks

This enumeration is only available in the Professional Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
CommStudio.Transfers.TransferStatus

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Transfers Namespace


Transfer.EndFileEventHandler Delegate

Transfer.EndFileEventHandler Delegate
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : Transfer.EndFileEventHandler Delegate

sender
Class sending the event.
e
Object containing information to describe the event.
Event fired after each file during the transfer session

Syntax

Visual Basic (Declaration)
Public Delegate Sub Transfer.EndFileEventHandler( _
   ByVal sender As Object, _
   ByVal e As Transfer.EndFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New EndFileEventHandler(AddressOf HandlerMethod)
C#
public delegate void Transfer.EndFileEventHandler(
   object sender,
   Transfer.EndFileEventArgs e
)
Delphi
public delegate Transfer.EndFileEventHandler(
    sender: TObject;
    e: Transfer.EndFileEventArgs
);

Parameters

sender
Class sending the event.
e
Object containing information to describe the event.

Remarks

The FileStatus property in the event arguments indicates if the file transfer was completed successfully, failed, or skipped.

Requirements

Namespace: CommStudio.Transfers

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

Assembly: CommStudio.2 (in CommStudio.2.dll)

See Also

Reference

CommStudio.Transfers Namespace


Barcodes

CommStudio
Barcodes

Glossary Item Box


Assembly Overview

CommStudio.2 Assembly

Namespaces

Namespace | Description
CommStudio.Barcodes |
CommStudio.Connections |
CommStudio.Transfers |


Getting Started - CommStudio.2

Getting Started


Introduction - CommStudio.2

Introduction


CommStudio.Barcodes Namespace Inheritance Hierarchy

CommStudio.Barcodes Namespace Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Barcodes Namespace

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
CommStudio.Barcodes.Barcode
CommStudio.Barcodes.DataMatrix
CommStudio.Barcodes.Pdf417

See Also

Reference

CommStudio.2 Assembly


CommunicationsLockedPortException Class Methods

CommunicationsLockedPortException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : CommunicationsLockedPortException Class

For a list of all members of this type, see CommunicationsLockedPortException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

CommunicationsLockedPortException Class
CommStudio.Connections Namespace


CommunicationsLockedPortException Class Properties

CommunicationsLockedPortException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Connections Namespace : CommunicationsLockedPortException Class

For a list of all members of this type, see CommunicationsLockedPortException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

CommunicationsLockedPortException Class
CommStudio.Connections Namespace


CommStudio.Connections Namespace Inheritance Hierarchy

CommStudio.Connections Namespace Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Connections Namespace

Inheritance Hierarchy

System.Object
CommStudio.Connections.ConnectionKey
CommStudio.Connections.SerialPortInfo
System.EventArgs
CommStudio.Connections.Connection.CommErrorEventArgs
System.Exception
System.ApplicationException
CommStudio.Connections.CommunicationsLockedPortException
System.MarshalByRefObject
System.ComponentModel.Component
CommStudio.Connections.Connection
CommStudio.Connections.SerialConnection

See Also

Reference

CommStudio.2 Assembly


TransferException Class Methods

TransferException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferException Class

For a list of all members of this type, see TransferException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferException Class
CommStudio.Transfers Namespace


TransferException Class Properties

TransferException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferException Class

For a list of all members of this type, see TransferException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferException Class
CommStudio.Transfers Namespace


TransferLocalCanceledException Class Methods

TransferLocalCanceledException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferLocalCanceledException Class

For a list of all members of this type, see TransferLocalCanceledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferLocalCanceledException Class
CommStudio.Transfers Namespace


TransferLocalCanceledException Class Properties

TransferLocalCanceledException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferLocalCanceledException Class

For a list of all members of this type, see TransferLocalCanceledException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferLocalCanceledException Class
CommStudio.Transfers Namespace


TransferRemoteCanceledException Class Methods

TransferRemoteCanceledException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferRemoteCanceledException Class

For a list of all members of this type, see TransferRemoteCanceledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferRemoteCanceledException Class
CommStudio.Transfers Namespace


TransferRemoteCanceledException Class Properties

TransferRemoteCanceledException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferRemoteCanceledException Class

For a list of all members of this type, see TransferRemoteCanceledException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferRemoteCanceledException Class
CommStudio.Transfers Namespace


TransferTimeOutException Class Methods

TransferTimeOutException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTimeOutException Class

For a list of all members of this type, see TransferTimeOutException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTimeOutException Class
CommStudio.Transfers Namespace


TransferTimeOutException Class Properties

TransferTimeOutException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTimeOutException Class

For a list of all members of this type, see TransferTimeOutException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferTimeOutException Class
CommStudio.Transfers Namespace


TransferTooFewFilesException Class Methods

TransferTooFewFilesException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooFewFilesException Class

For a list of all members of this type, see TransferTooFewFilesException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooFewFilesException Class
CommStudio.Transfers Namespace


TransferTooFewFilesException Class Properties

TransferTooFewFilesException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooFewFilesException Class

For a list of all members of this type, see TransferTooFewFilesException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooFewFilesException Class
CommStudio.Transfers Namespace


TransferTooManyFilesException Class Methods

TransferTooManyFilesException Class Methods
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooManyFilesException Class

For a list of all members of this type, see TransferTooManyFilesException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooManyFilesException Class
CommStudio.Transfers Namespace


TransferTooManyFilesException Class Properties

TransferTooManyFilesException Class Properties
[image]
CommStudio.2 Assembly > CommStudio.Transfers Namespace : TransferTooManyFilesException Class

For a list of all members of this type, see TransferTooManyFilesException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

TransferTooManyFilesException Class
CommStudio.Transfers Namespace


CommStudio.Transfers Namespace Inheritance Hierarchy

CommStudio.Transfers Namespace Inheritance Hierarchy
CommStudio.2 Assembly : CommStudio.Transfers Namespace

Inheritance Hierarchy

System.Object
System.EventArgs
CommStudio.Transfers.Transfer.EndFileEventArgs
System.Exception
CommStudio.Transfers.TransferException
CommStudio.Transfers.TransferLocalCanceledException
CommStudio.Transfers.TransferRemoteCanceledException
CommStudio.Transfers.TransferTimeOutException
CommStudio.Transfers.TransferTooFewFilesException
CommStudio.Transfers.TransferTooManyFilesException
System.MarshalByRefObject
System.ComponentModel.Component
CommStudio.Transfers.Transfer

See Also

Reference

CommStudio.2 Assembly


Glossary

CommStudio
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you