NetCombos Reference
NetCombos
CollapseAll image

Softgroup .Net Combos Controls include six advanced controls: ComboColors and EditColor, ComboDrives, ComboFonts, ComboImages and ComboPrinters. With Softgroup .Net Combos Controls you can enhance the user interface of your applications.

by Softgroup


Softgroup.NetCombos Namespace

Softgroup.NetCombos Namespace
collapseAll image DropDown image

Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Classes

 | Name | Description
Supported by the .NET Compact Framework. | ComboColors | Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.
Supported by the .NET Compact Framework. | ComboDrives | Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.
Supported by the .NET Compact Framework. | ComboFonts | Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.
Supported by the .NET Compact Framework. | ComboImages | Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)
Supported by the .NET Compact Framework. | ComboPrinters | Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).
Supported by the .NET Compact Framework. | EditColor | Softgroup .Net Edit Color is an advanced Edit color control with wich user can select any combination of standard/custom color.
Supported by the .NET Compact Framework. | ItemImage | Softgroup.Image is a class that contain a single Image object of a ComboImages item
Supported by the .NET Compact Framework. | ItemImages | Softgroup.Images is a collection class to manage Images of a ComboImages control
Supported by the .NET Compact Framework. | License | License class holds licenses informations data.
Top

Expand image Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | ColorEnum | Enumeration used to define types of colours to display
Supported by the .NET Compact Framework. | FlatStyleEditColor | Enumeration for Button Color FlatStyle property
Supported by the .NET Compact Framework. | FocusStyleEnum | Enumeration used to define FocusStyle property for combos
Top

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x


ComboColors Class

ComboColors Class
Members
collapseAll image DropDown image

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ComboColors
    Inherits ComboBox
C#
public class ComboColors : ComboBox

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetCombos.ComboColors

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Members


ComboColors Members

ComboColors Members
See Also Properties
CollapseAll image DropDown image

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of System Colors or Know Colors.

The following tables list the members exposed by the ComboColors type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ColorType | Gets/Sets the type of color shown in list.
Supported by the .NET Compact Framework. | FocusStyle | Gets and sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedColor | Gets currently selected color.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboColors Class


ComboColors Properties

ComboColors Properties
See Also
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ColorType | Gets/Sets the type of color shown in list.
Supported by the .NET Compact Framework. | FocusStyle | Gets and sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedColor | Gets currently selected color.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboColors Class


ComboColors.ColorType Property

ComboColors.ColorType Property

Gets/Sets the type of color shown in list.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ColorType( _
   ByRef "Gets/Sets the type of color shown in list." As Object _
) As ColorEnum
C#
[System.Runtime.CompilerServices.IndexerName("ColorType")]
public ColorEnum this[
   ref object "Gets/Sets the type of color shown in list."
] {get; set;}

Parameters

"Gets/Sets the type of color shown in list."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.FocusStyle Property

ComboColors.FocusStyle Property

Gets and sets the focus style.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FocusStyle( _
   ByRef "Gets and sets the focus style." As Object _
) As FocusStyleEnum
C#
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets and sets the focus style."
] {get; set;}

Parameters

"Gets and sets the focus style."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Items Property

ComboColors.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
C#
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}

Parameters

False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.SelectedColor Property

ComboColors.SelectedColor Property

Gets currently selected color.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedColor() As Color
C#
public Color SelectedColor {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Class
ComboColors Members


ComboColors.Text Property

ComboColors.Text Property

Gets currently Text of combo.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Property Text() As String
C#
public override string Text {get; set;}

Expand image Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboColors Class
ComboColors Members


ComboDrives Class

ComboDrives Class
Members
collapseAll image DropDown image

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ComboDrives
    Inherits ComboBox
C#
public class ComboDrives : ComboBox

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetCombos.ComboDrives

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Members


ComboDrives Members

ComboDrives Members
See Also Methods Properties
CollapseAll image DropDown image

Softgroup .Net Combo Colors is an advanced ComboBox that display a list of system Drives with automatic detection of system drives changes.

The following tables list the members exposed by the ComboDrives type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AutoRefresh | Gets/Sets if list of drives will be automatically updated
Supported by the .NET Compact Framework. | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedDrive | Gets currently selected Drive name.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshDrives | Force a refresh of drives list in combo
Top

Expand image See Also

Reference

ComboDrives Class


ComboDrives Properties

ComboDrives Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AutoRefresh | Gets/Sets if list of drives will be automatically updated
Supported by the .NET Compact Framework. | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedDrive | Gets currently selected Drive name.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboDrives Class


ComboDrives.AutoRefresh Property

ComboDrives.AutoRefresh Property

Gets/Sets if list of drives will be automatically updated
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoRefresh( _
   ByRef "Gets/Sets if list of drives will be automatically updated." As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("AutoRefresh")]
public bool this[
   ref object "Gets/Sets if list of drives will be automatically updated."
] {get; set;}

Parameters

"Gets/Sets if list of drives will be automatically updated."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.AutoRefreshTimeout Property

ComboDrives.AutoRefreshTimeout Property

Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoRefreshTimeout( _
   ByRef "Gets/Sets the timeout  As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("AutoRefreshTimeout")]
public int this[
   ref object "Gets/Sets the timeout
] {get; set;}

Parameters

"Gets/Sets the timeout

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.FocusStyle Property

ComboDrives.FocusStyle Property

Gets/Sets the focus style.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
C#
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}

Parameters

"Gets/Sets the focus style."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Items Property

ComboDrives.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
C#
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}

Parameters

False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.SelectedDrive Property

ComboDrives.SelectedDrive Property

Gets currently selected Drive name.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedDrive() As String
C#
public string SelectedDrive {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives.Text Property

ComboDrives.Text Property

Gets currently Text of combo.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Property Text() As String
C#
public override string Text {get; set;}

Expand image Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboDrives Methods

ComboDrives Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshDrives | Force a refresh of drives list in combo
Top

Expand image See Also

Reference

ComboDrives Class


ComboDrives.RefreshDrives Method

ComboDrives.RefreshDrives Method

Force a refresh of drives list in combo
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub RefreshDrives()
C#
public System.Void RefreshDrives();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboDrives Class
ComboDrives Members


ComboFonts Class

ComboFonts Class
Members
collapseAll image DropDown image

Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ComboFonts
    Inherits ComboBox
C#
public class ComboFonts : ComboBox

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetCombos.ComboFonts

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Members


ComboFonts Members

ComboFonts Members
See Also Methods Properties
CollapseAll image DropDown image

Softgroup .Net Combo Fonts is an advanced ComboBox that display a list of system installed Fonts.

The following tables list the members exposed by the ComboFonts type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedFont | Gets currently selected font name.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshFonts | Refresh content of combo fonts
Top

Expand image See Also

Reference

ComboFonts Class


ComboFonts Properties

ComboFonts Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedFont | Gets currently selected font name.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboFonts Class


ComboFonts.FocusStyle Property

ComboFonts.FocusStyle Property

Gets/Sets the focus style.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
C#
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}

Parameters

"Gets/Sets the focus style."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Items Property

ComboFonts.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
C#
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}

Parameters

False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.SelectedFont Property

ComboFonts.SelectedFont Property

Gets currently selected font name.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedFont() As String
C#
public string SelectedFont {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts.Text Property

ComboFonts.Text Property

Gets currently Text of combo.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Property Text() As String
C#
public override string Text {get; set;}

Expand image Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Class
ComboFonts Members


ComboFonts Methods

ComboFonts Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshFonts | Refresh content of combo fonts
Top

Expand image See Also

Reference

ComboFonts Class


ComboFonts.RefreshFonts Method

ComboFonts.RefreshFonts Method

Refresh content of combo fonts
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub RefreshFonts()
C#
public System.Void RefreshFonts();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboFonts Class
ComboFonts Members


ComboImages Class

ComboImages Class
Members
collapseAll image DropDown image

Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ComboImages
    Inherits ComboBox
C#
public class ComboImages : ComboBox

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetCombos.ComboImages

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboImages Members


ComboImages Members

ComboImages Members
See Also Properties
CollapseAll image DropDown image

Softgroup .Net Combo Images is an advanced ComboBox that display images with text. Images can be added from icon associated file extension, icon into executable files, image file or runtime images (System.Drawing.Bitmap, System.Drawing.Image or System.Drawing.Icon)

The following tables list the members exposed by the ComboImages type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Images | Collection of images associated into combo
Supported by the .NET Compact Framework. | SelectedImage | Gets currently selected image.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboImages Class


ComboImages Properties

ComboImages Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Images | Collection of images associated into combo
Supported by the .NET Compact Framework. | SelectedImage | Gets currently selected image.
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboImages Class


ComboImages.FocusStyle Property

ComboImages.FocusStyle Property

Gets/Sets the focus style.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
C#
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}

Parameters

"Gets/Sets the focus style."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Images Property

ComboImages.Images Property

Collection of images associated into combo
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Images() As ItemImages
C#
public ItemImages Images {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.SelectedImage Property

ComboImages.SelectedImage Property

Gets currently selected image.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedImage() As Image
C#
public Image SelectedImage {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboImages Class
ComboImages Members


ComboImages.Text Property

ComboImages.Text Property

Gets currently Text of combo.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Property Text() As String
C#
public override string Text {get; set;}

Expand image Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboImages Class
ComboImages Members


ComboPrinters Class

ComboPrinters Class
Members
collapseAll image DropDown image

Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ComboPrinters
    Inherits ComboBox
C#
public class ComboPrinters : ComboBox

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Softgroup.NetCombos.ComboPrinters

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Members


ComboPrinters Members

ComboPrinters Members
See Also Methods Properties
CollapseAll image DropDown image

Softgroup .Net Combo Printers is an advanced ComboBox that display a list of system installed Printers with automatic detection of system printers changes (for plug and play devices).

The following tables list the members exposed by the ComboPrinters type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AutoRefresh | Gets/Sets if list of printers will be automatically updated
Supported by the .NET Compact Framework. | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedPrinter | Gets currently selected printer name.
Supported by the .NET Compact Framework. | ShowInvalidPrinters | Gets/Sets if invalid printers must be shown
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshPrinters | Force a refresh of printers list in combo
Top

Expand image See Also

Reference

ComboPrinters Class


ComboPrinters Properties

ComboPrinters Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | AutoRefresh | Gets/Sets if list of printers will be automatically updated
Supported by the .NET Compact Framework. | AutoRefreshTimeout | Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Supported by the .NET Compact Framework. | FocusStyle | Gets/Sets the focus style.
Supported by the .NET Compact Framework. | Items | A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Supported by the .NET Compact Framework. | SelectedPrinter | Gets currently selected printer name.
Supported by the .NET Compact Framework. | ShowInvalidPrinters | Gets/Sets if invalid printers must be shown
Supported by the .NET Compact Framework. | Text | Gets currently Text of combo.
Top

Expand image See Also

Reference

ComboPrinters Class


ComboPrinters.AutoRefresh Property

ComboPrinters.AutoRefresh Property

Gets/Sets if list of printers will be automatically updated
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoRefresh( _
   ByRef "Gets/Sets if list of printers will be automatically updated." As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("AutoRefresh")]
public bool this[
   ref object "Gets/Sets if list of printers will be automatically updated."
] {get; set;}

Parameters

"Gets/Sets if list of printers will be automatically updated."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.AutoRefreshTimeout Property

ComboPrinters.AutoRefreshTimeout Property

Gets/Sets the timeout (in milliseconds) used by AutoRefresh property to automatically updated list of printers
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoRefreshTimeout( _
   ByRef "Gets/Sets the timeout  As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("AutoRefreshTimeout")]
public int this[
   ref object "Gets/Sets the timeout
] {get; set;}

Parameters

"Gets/Sets the timeout

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.FocusStyle Property

ComboPrinters.FocusStyle Property

Gets/Sets the focus style.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FocusStyle( _
   ByRef "Gets/Sets the focus style." As Object _
) As FocusStyleEnum
C#
[System.Runtime.CompilerServices.IndexerName("FocusStyle")]
public FocusStyleEnum this[
   ref object "Gets/Sets the focus style."
] {get; set;}

Parameters

"Gets/Sets the focus style."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Items Property

ComboPrinters.Items Property

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items( _
   ByRef False As Object _
) As ObjectCollection
C#
[System.Runtime.CompilerServices.IndexerName("Items")]
public ObjectCollection this[
   ref object False
] {get;}

Parameters

False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.SelectedPrinter Property

ComboPrinters.SelectedPrinter Property

Gets currently selected printer name.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedPrinter() As String
C#
public string SelectedPrinter {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.ShowInvalidPrinters Property

ComboPrinters.ShowInvalidPrinters Property

Gets/Sets if invalid printers must be shown
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowInvalidPrinters( _
   ByRef "Gets/Sets if invalid printers must be shown" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowInvalidPrinters")]
public bool this[
   ref object "Gets/Sets if invalid printers must be shown"
] {get; set;}

Parameters

"Gets/Sets if invalid printers must be shown"

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters.Text Property

ComboPrinters.Text Property

Gets currently Text of combo.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overrides Property Text() As String
C#
public override string Text {get; set;}

Expand image Remarks

This property is read only attempt to assign a value to this property will produce no effects.

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


ComboPrinters Methods

ComboPrinters Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | RefreshPrinters | Force a refresh of printers list in combo
Top

Expand image See Also

Reference

ComboPrinters Class


ComboPrinters.RefreshPrinters Method

ComboPrinters.RefreshPrinters Method

Force a refresh of printers list in combo
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub RefreshPrinters()
C#
public System.Void RefreshPrinters();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ComboPrinters Class
ComboPrinters Members


EditColor Class

EditColor Class
Members
collapseAll image DropDown image

Softgroup .Net Edit Color is an advanced Edit color control with wich user can select any combination of standard/custom color.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class EditColor
    Inherits UserControl
C#
public class EditColor : UserControl

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetCombos.EditColor

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Members


EditColor Members

EditColor Members
See Also Events Methods Properties
CollapseAll image DropDown image

Softgroup .Net Edit Color is an advanced Edit color control with wich user can select any combination of standard/custom color.

The following tables list the members exposed by the EditColor type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ButtonColor | Gets/Sets command button control backcolor
Supported by the .NET Compact Framework. | FlatStyle | Gets/Sets Flat Style of control
Supported by the .NET Compact Framework. | SelectedColor | Gets/Sets the current selected color.
Supported by the .NET Compact Framework. | ToolTipText | Gets/Sets the current tooltip text.
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ShowDialog | Display Color Dialog associated to the control
Top

Expand image Public Events

 | Name | Description
Supported by the .NET Compact Framework. | SelectedColorChanged | This event will be generated any time selected index change
Top

Expand image See Also

Reference

EditColor Class


EditColor Properties

EditColor Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | ButtonColor | Gets/Sets command button control backcolor
Supported by the .NET Compact Framework. | FlatStyle | Gets/Sets Flat Style of control
Supported by the .NET Compact Framework. | SelectedColor | Gets/Sets the current selected color.
Supported by the .NET Compact Framework. | ToolTipText | Gets/Sets the current tooltip text.
Top

Expand image See Also

Reference

EditColor Class


EditColor.ButtonColor Property

EditColor.ButtonColor Property

Gets/Sets command button control backcolor
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ButtonColor( _
   ByRef "Gets/Sets command button control backcolor" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("ButtonColor")]
public Color this[
   ref object "Gets/Sets command button control backcolor"
] {get; set;}

Parameters

"Gets/Sets command button control backcolor"

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


EditColor.FlatStyle Property

EditColor.FlatStyle Property

Gets/Sets Flat Style of control
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FlatStyle( _
   ByRef "Gets/Sets Flat Style of control" As Object _
) As FlatStyleEditColor
C#
[System.Runtime.CompilerServices.IndexerName("FlatStyle")]
public FlatStyleEditColor this[
   ref object "Gets/Sets Flat Style of control"
] {get; set;}

Parameters

"Gets/Sets Flat Style of control"

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


EditColor.SelectedColor Property

EditColor.SelectedColor Property

Gets/Sets the current selected color.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property SelectedColor( _
   ByRef "Gets/Sets the current selected color." As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("SelectedColor")]
public Color this[
   ref object "Gets/Sets the current selected color."
] {get; set;}

Parameters

"Gets/Sets the current selected color."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


EditColor.ToolTipText Property

EditColor.ToolTipText Property

Gets/Sets the current tooltip text.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ToolTipText( _
   ByRef "Gets/Sets the current tooltip text." As Object _
) As String
C#
[System.Runtime.CompilerServices.IndexerName("ToolTipText")]
public string this[
   ref object "Gets/Sets the current tooltip text."
] {get; set;}

Parameters

"Gets/Sets the current tooltip text."

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


EditColor Methods

EditColor Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ShowDialog | Display Color Dialog associated to the control
Top

Expand image See Also

Reference

EditColor Class


EditColor.ShowDialog Method

EditColor.ShowDialog Method

Display Color Dialog associated to the control
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ShowDialog()
C#
public System.Void ShowDialog();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


EditColor Events

EditColor Events
CollapseAll image DropDown image

Expand image Public Events

 | Name | Description
Supported by the .NET Compact Framework. | SelectedColorChanged | This event will be generated any time selected index change
Top

Expand image See Also

Reference

EditColor Class


SelectedColorChanged Event

SelectedColorChanged Event

This event will be generated any time selected index change
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event SelectedColorChanged()
C#
public event SelectedColorChangedEventHandler SelectedColorChanged;
delegate void SelectedColorChangedEventHandler()

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

EditColor Class
EditColor Members


ItemImage Class

ItemImage Class
Members
collapseAll image DropDown image

Softgroup.Image is a class that contain a single Image object of a ComboImages item
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ItemImage
C#
public class ItemImage

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetCombos.ItemImage

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImage Members


ItemImage Members

ItemImage Members
See Also Properties
CollapseAll image DropDown image

Softgroup.Image is a class that contain a single Image object of a ComboImages item

The following tables list the members exposed by the ItemImage type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FileName | Gets the file name associated to the image
Supported by the .NET Compact Framework. | Image | Gets a System.Drawing.Icon from this FileIcon object
Supported by the .NET Compact Framework. | Key | Gets the string key associated to the image
Supported by the .NET Compact Framework. | Text | Gets the text of combo item
Top

Expand image See Also

Reference

ItemImage Class


ItemImage Properties

ItemImage Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | FileName | Gets the file name associated to the image
Supported by the .NET Compact Framework. | Image | Gets a System.Drawing.Icon from this FileIcon object
Supported by the .NET Compact Framework. | Key | Gets the string key associated to the image
Supported by the .NET Compact Framework. | Text | Gets the text of combo item
Top

Expand image See Also

Reference

ItemImage Class


ItemImage.FileName Property

ItemImage.FileName Property

Gets the file name associated to the image
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName() As String
C#
public string FileName {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Image Property

ItemImage.Image Property

Gets a System.Drawing.Icon from this FileIcon object
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Image() As Image
C#
public Image Image {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Key Property

ItemImage.Key Property

Gets the string key associated to the image
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Key() As String
C#
public string Key {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImage Class
ItemImage Members


ItemImage.Text Property

ItemImage.Text Property

Gets the text of combo item
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text() As String
C#
public string Text {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImage Class
ItemImage Members


ItemImages Class

ItemImages Class
Members
collapseAll image DropDown image

Softgroup.Images is a collection class to manage Images of a ComboImages control
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class ItemImages
    Implements IEnumerable
C#
public class ItemImages : IEnumerable

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetCombos.ItemImages

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Members


ItemImages Members

ItemImages Members
See Also Methods Properties
CollapseAll image DropDown image

Softgroup.Images is a collection class to manage Images of a ComboImages control

The following tables list the members exposed by the ItemImages type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Count | Gets the number of elements in the collection. First item start from 1.
Supported by the .NET Compact Framework. | Item | (Overloaded) Gets a specified item collection throw Index
Top

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddFromFileExecutable | Add a new image from icon extracted from specified executable file
Supported by the .NET Compact Framework. | AddFromFileExtension | Add a new image extracted from specified file extension association
Supported by the .NET Compact Framework. | AddFromFileImage | Add a new image from file
Supported by the .NET Compact Framework. | AddImage | (Overloaded) Add a new image
Supported by the .NET Compact Framework. | Clear | Clear the content of the collection
Supported by the .NET Compact Framework. | Exist | Check if a specified specified key exists in the collection
Supported by the .NET Compact Framework. | IndexOf | Gets index of specified key otherwise return -1 if key does not exists
Supported by the .NET Compact Framework. | Remove | (Overloaded) Remove the specified Item key from the collection
Top

Expand image See Also

Reference

ItemImages Class


ItemImages Properties

ItemImages Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Count | Gets the number of elements in the collection. First item start from 1.
Supported by the .NET Compact Framework. | Item | (Overloaded) Gets a specified item collection throw Index
Top

Expand image See Also

Reference

ItemImages Class


ItemImages.Count Property

ItemImages.Count Property

Gets the number of elements in the collection. First item start from 1.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count() As Integer
C#
public int Count {get;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Item (System.Int32) Property

ItemImages.Item (System.Int32) Property

Gets a specified item collection throw Index

Expand image Overload List

Name | Description
public ItemImage this[int] {get;} | Gets a specified item collection throw Index
public ItemImage this[string] {get;} | Gets a specified item collection throw key

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages Methods

ItemImages Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | AddFromFileExecutable | Add a new image from icon extracted from specified executable file
Supported by the .NET Compact Framework. | AddFromFileExtension | Add a new image extracted from specified file extension association
Supported by the .NET Compact Framework. | AddFromFileImage | Add a new image from file
Supported by the .NET Compact Framework. | AddImage | (Overloaded) Add a new image
Supported by the .NET Compact Framework. | Clear | Clear the content of the collection
Supported by the .NET Compact Framework. | Exist | Check if a specified specified key exists in the collection
Supported by the .NET Compact Framework. | IndexOf | Gets index of specified key otherwise return -1 if key does not exists
Supported by the .NET Compact Framework. | Remove | (Overloaded) Remove the specified Item key from the collection
Top

Expand image See Also

Reference

ItemImages Class


ItemImages.AddFromFileExecutable Method

ItemImages.AddFromFileExecutable Method

Add a new image from icon extracted from specified executable file
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddFromFileExecutable( _
   ByVal Text As String, _
   ByVal FileName As String, _
   ByVal Key As String _
)
C#
public System.Void AddFromFileExecutable(
   string Text,
   string FileName,
   string Key
);

Parameters

Text

Combo Item Text

FileName

Name of executable file name.

Key

The key associated to the image in the collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddFromFileExtension Method

ItemImages.AddFromFileExtension Method

Add a new image extracted from specified file extension association
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddFromFileExtension( _
   ByVal Text As String, _
   ByVal FileExtension As String, _
   ByVal Key As String _
)
C#
public System.Void AddFromFileExtension(
   string Text,
   string FileExtension,
   string Key
);

Parameters

Text

Combo Item Text

FileExtension

File extension (for example doc or .doc).

Key

The key associated to the image in the collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddFromFileImage Method

ItemImages.AddFromFileImage Method

Add a new image from file
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddFromFileImage( _
   ByVal Text As String, _
   ByVal FileName As String, _
   ByVal Key As String _
)
C#
public System.Void AddFromFileImage(
   string Text,
   string FileName,
   string Key
);

Parameters

Text

Combo Item Text

FileName

Name of file.

Key

The key associated to the image in the collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddImage (System.String, System.Drawing.Image, System.String) Method

ItemImages.AddImage (System.String, System.Drawing.Image, System.String) Method
See Also
collapseAll image DropDown image

Add a new image

Expand image Overload List

Name | Description
public System.Void AddImage(string, Icon, string); | Add a new icon
public System.Void AddImage(string, Image, string); | Add a new image

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Clear Method

ItemImages.Clear Method

Clear the content of the collection
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public System.Void Clear();

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Exist Method

ItemImages.Exist Method

Check if a specified specified key exists in the collection
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Exist( _
   ByVal Key As String _
) As Boolean
C#
public bool Exist(
   string Key
);

Parameters

Key

Key to check

Return Value

True is Key exists otherwise False

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.IndexOf Method

ItemImages.IndexOf Method

Gets index of specified key otherwise return -1 if key does not exists
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal Key As String _
) As Integer
C#
public int IndexOf(
   string Key
);

Parameters

Key

Key for wich find index

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove (System.String) Method

ItemImages.Remove (System.String) Method

Remove the specified Item key from the collection

Expand image Overload List

Name | Description
public System.Void Remove(int); | Remove the specified Item Index from the collection
public System.Void Remove(string); | Remove the specified Item key from the collection

Expand image See Also

Reference

ItemImages Class
ItemImages Members


License Class

License Class
Members
collapseAll image DropDown image

License class holds licenses informations data.
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class License
C#
public sealed class License

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetCombos.License

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

License Members


License Members

License Members
See Also Properties
CollapseAll image DropDown image

License class holds licenses informations data.

The following tables list the members exposed by the License type.

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | LicenseKey | Gets/Sets the license key for the product
Supported by the .NET Compact Framework. | LicenseName | Gets/Sets the license company name for the product
Supported by the .NET Compact Framework. | LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License Properties

License Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | LicenseKey | Gets/Sets the license key for the product
Supported by the .NET Compact Framework. | LicenseName | Gets/Sets the license company name for the product
Supported by the .NET Compact Framework. | LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License.LicenseKey Property

License.LicenseKey Property

Gets/Sets the license key for the product
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseKey() As String
C#
public static string LicenseKey {get; set;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

License Class
License Members


License.LicenseName Property

License.LicenseName Property

Gets/Sets the license company name for the product
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseName() As String
C#
public static string LicenseName {get; set;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

License Class
License Members


License.LicenseUser Property

License.LicenseUser Property

Gets/Sets the license user name (usually and email address) for the product
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseUser() As String
C#
public static string LicenseUser {get; set;}

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

License Class
License Members


ColorEnum Enumeration

ColorEnum Enumeration

Enumeration used to define types of colours to display
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Members

Member name | Description
KnownColor | Display know colors
SystemColor | Display System Colors

Expand image See Also

Reference


FlatStyleEditColor Enumeration

FlatStyleEditColor Enumeration

Enumeration for Button Color FlatStyle property
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Members

Member name | Description
Flat | Flat Style
Popup | Popup Style
Standard | Standard Style

Expand image See Also

Reference


FocusStyleEnum Enumeration

FocusStyleEnum Enumeration

Enumeration used to define FocusStyle property for combos
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Members

Member name | Description
Blend | Blend focus style
Normal | Normal focus style

Expand image See Also

Reference


ItemImages.Item (System.String) Property

ItemImages.Item (System.String) Property

Gets a specified item collection throw key
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Key As String _
) As ItemImage
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public ItemImage this[
   string Key
] {get;}

Parameters

Key

Key of item to retrieve

Property Value

A Softgroup.Image object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddImage (System.String, System.Drawing.Image, System.String) Method

ItemImages.AddImage (System.String, System.Drawing.Image, System.String) Method
See Also
collapseAll image DropDown image

Add a new image
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddImage( _
   ByVal Text As String, _
   ByVal NewImage As Image, _
   ByVal Key As String _
)
C#
public System.Void AddImage(
   string Text,
   Image NewImage,
   string Key
);

Parameters

Text

Combo Item Text

NewImage

A valid Image object.

Key

The key associated to the image in the collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.AddImage (System.String, System.Drawing.Icon, System.String) Method

ItemImages.AddImage (System.String, System.Drawing.Icon, System.String) Method
See Also
collapseAll image DropDown image

Add a new icon
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddImage( _
   ByVal Text As String, _
   ByVal NewIcon As Icon, _
   ByVal Key As String _
)
C#
public System.Void AddImage(
   string Text,
   Icon NewIcon,
   string Key
);

Parameters

Text

Combo Item Text

NewIcon

A valid Icon object.

Key

The key associated to the image in the collection

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove (System.String) Method

ItemImages.Remove (System.String) Method

Remove the specified Item key from the collection
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Key As String _
)
C#
public System.Void Remove(
   string Key
);

Parameters

Key

An existing Key

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Remove (System.Int32) Method

ItemImages.Remove (System.Int32) Method

Remove the specified Item Index from the collection
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Index As Integer _
)
C#
public System.Void Remove(
   int Index
);

Parameters

Index

An existing Index

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members


ItemImages.Item (System.Int32) Property

ItemImages.Item (System.Int32) Property

Gets a specified item collection throw Index
Assembly: Softgroup.NetCombos (in Softgroup.NetCombos.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As ItemImage
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public ItemImage this[
   int Index
] {get;}

Parameters

Index

Index of item to retrieve

Property Value

A Softgroup.Image object

Expand image Platforms

Windows 98, Windows 2000 SP4, Windows Millennium Edition, Windows Server 2003, Windows XP Media Center Edition, Windows XP Professional x64 Edition, Windows XP SP2, Windows XP Starter Edition

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 3.x, 2.x

.NET Compact Framework

Supported in: 2.x

Expand image See Also

Reference

ItemImages Class
ItemImages Members