NetData Reference

[image] [image] [image]

Softgroup .Net Data Objects gives to developers powerful objects for accessing, editing, and updating data from a wide range of databases throw a unique driver interface.

With Softgroup NetData Objects developers can especially easy migrate old data-oriented projects that use Microsoft ADO or ODBC technology to Microsoft .NET languages without rewriting many lines of code.

In fact in order to facilitate the migration of source code NetData Objects contains most of same objects (with most same Properties and Methods) of Microsoft ADO (Connection, Recordset, Fields etc.)

In addition Softgroup .Net Data Objects contains other useful SQL objects and functions to query, insert, update and delete tables data on a database using auto-generated standard SQL statements that can be executed in all supported databases.

Softgroup .Net Data Objects con also be used as a standard way to write fast data acces .Net solutions that support most populars databases:

  • Microsoft Access
  • Microsoft SQL Server
  • Oracle
  • IBM DB2
  • MySQL
  • PostgreSQL
  • FireBird

Softgroup .Net Data Objects implements in a unique interface native third-party drivers that make use of ADO .Net, OleDb or Odbc technologies.

The most common usage of Softgroup .Net Data Objects is to query a table or tables in a relational database, retrieve and display the results in an application, and let users make and save changes to the data.

Other tasks include:

  • Open a Connection to a database
  • Easy manipulation of database objects: Databases, Tables, Indexes, Foreing Keys, Views, Procedures, Triggers, Permissions, Groups, Users etc.
  • Perform advanced operations on Databases like: enumerate existing databases, create or delete e database, backup or restore a database etc.
  • Multilamguage advanced dialogs for Login to a database, Backup and Restore operations.
  • Querying a database using SQL and displaying the results.
  • Executing commands and stored procedures with parameters.
  • Dynamically create Recordset objects, to navigate data like Microsoft ADO Recordset object.
  • Performing transactional database operations.
  • Filtering and sorting recordset data based on run-time criteria.
  • A series of SQL objects and functions in order to standardize writing of SQL statements in your code.
  • Support for unicode databases
by Softgroup


Softgroup.NetData Namespace

[image] [image] [image]

NetData Reference
Softgroup.NetData Namespace

Softgroup .Net Data Objects gives to developers powerful objects for accessing, editing, and updating data from a wide range of databases throw a unique driver interface.

With Softgroup NetData Objects developers can especially easy migrate old data-oriented projects that use Microsoft ADO or ODBC technology to Microsoft .NET languages without rewriting many lines of code.

In fact in order to facilitate the migration of source code NetData Objects contains most of same objects (with most same Properties and Methods) of Microsoft ADO (Connection, Recordset, Fields etc.)

In addition Softgroup .Net Data Objects contains other useful SQL objects and functions to query, insert, update and delete tables data on a database using auto-generated standard SQL statements that can be executed in all supported databases.

Softgroup .Net Data Objects con also be used as a standard way to write fast data acces .Net solutions that support most populars databases:

  • Microsoft Access
  • Microsoft SQL Server
  • Oracle
  • IBM DB2
  • MySQL
  • PostgreSQL
  • FireBird

Softgroup .Net Data Objects implements in a unique interface native third-party drivers that make use of ADO .Net, OleDb or Odbc technologies.

The most common usage of Softgroup .Net Data Objects is to query a table or tables in a relational database, retrieve and display the results in an application, and let users make and save changes to the data.

Other tasks include:

  • Open a Connection to a database
  • Easy manipulation of database objects: Databases, Tables, Indexes, Foreing Keys, Views, Procedures, Triggers, Permissions, Groups, Users etc.
  • Perform advanced operations on Databases like: enumerate existing databases, create or delete e database, backup or restore a database etc.
  • Multilamguage advanced dialogs for Login to a database, Backup and Restore operations.
  • Querying a database using SQL and displaying the results.
  • Executing commands and stored procedures with parameters.
  • Dynamically create Recordset objects, to navigate data like Microsoft ADO Recordset object.
  • Performing transactional database operations.
  • Filtering and sorting recordset data based on run-time criteria.
  • A series of SQL objects and functions in order to standardize writing of SQL statements in your code.
  • Support for unicode databases

Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Classes

Name | Description
Public class | Command | This class has same behavior of .Net Command object
Public class Connection Softgroup Connection object must be used for establish the connection to a database.

To estabish a connection with a database you must initialize Connection object with a specific Driver and than call the Open method; Close method must be used for close the connection to a Database.

Connection object support most feautures of Microsoft ADO Connection or Net DBConnection object and can be used to replace it during the conversion of Microsoft Visual Basic 6 projects that make use of Microsoft ADO library.
Public class | ConnectionStringBuild | Provides a simple way to create and manage the contents of connection strings used by the Connection class.
Public class | ConnectionStringProperty | This class hola a propety that contains key, value and value type used in a connection string.
Public class | DataDriver | This class holds drives informations
Public class | DataForeignKey | This class holds Foreign Key informations data
Public class | DataIndex | This class holds Index informations
Public class | DataReader | This class has same behavior of Net DataReader object
Public class | Field | This class is used to store properties of a field
Public class | Fields | Fields is a collection object of Field objects used to store properties and values of fields
Public class | License | License class holds licenses informations data.
Public class | Localize | This class provide shared localization string for Softgroup .Net Data Objects
Public class | Parameter | The Parameter object provides information about a single parameter used in a stored procedure or query of Command.
Public class | Parameters | The Parameters Collection is a collection of the Parameter objects associated with a specific Command object. Each Parameter object provides detailed information about a single parameter used in a stored procedure or a parameterized query.
Public class | Recordset | A Recordset object represents the entire set of records as the results of a SQL SELECT command.
Public class | SQLDelete | SQLDelete provide an easy and unique way for generate and/or execute SQL DELETE statements that can be used for any database type supported by Softgroup Connection.
Public class | SQLInsert | SQLInsert provide an easy and unique way for generate and/or execute SQL INSERT statements that can be used for any database type supported by Softgroup Connection.
Public class | SQLSelect | SQLSelect provide an easy and unique way for generate and/or execute SQL SELECT statements that can be used for any database type supported by Softgroup Connection.
Public class | SQLTable | This object is used in SQLTables collection for store properties of tables
Public class | SQLTables | SQLTables is a collection object of SQLTable objects used by GSQLSelect object for store properties and values of tables used if SQL SELECT statements
Public class | SQLUpdate | SQLUpdate provide an easy and unique way for generate and/or execute SQL UPDATE statements that can be used for any database type supported by Softgroup Connection.
Public class | TransactionAlreadyActiveException | The exception that is thrown when a Transaction is already active
Public class | TransactionNotActivated | The exception that is thrown when no Transaction is previously activated
Top

Expand image Enumerations

 | Name | Description
Public enumeration | CommandTypeEnum | Enumeration of CommandType parameter used by DataAdapter method.
Public enumeration | CompareValueEnum | Enumeration used by CompareDate and CompareTime methods of Field object
Public enumeration | ConnectionStringValueTypeEnum | Enumeration of values types of properties
Public enumeration | ConvertCaseEnum | Enumeration of database objects names name convertion.
Public enumeration | DataTypeEnum | Enumeration of supported databases Data Types. For compatibility with all supported databases Connection object uses a unified list of custom data types that maps various databases data type with .NET data types.
Public enumeration | DriverTypeEnum | Enumeration that defines data access technology used by driver (.Net, OLEDB or ODBC)
Public enumeration | FindRecordEnum | Enumeration used by Find Method of Recordset class used to specify search direction
Public enumeration | ForeignKeyActionEnum | Supported actions for Update/Delete operations on creation of foreign keys database objects
Public enumeration | JoinTypeEnum | Enumeration of joins type used by Add method in SQLTables object of SQLSelect object.
Public enumeration | PermissionObjectEnum | Enumeration used to define supported objects to grant and revoke database permission
Public enumeration | ProviderTypeEnum | Enumeration that defines constants for Provider Type (generic type of database used)
Public enumeration | RecordsetStateEnum | Enumeration of current state of a recordset.
Public enumeration | RequireEnum | This Enumeration is used by Required method of Connection object
Public enumeration | SupportsEnum | Enumeration of SupportOption parameter for Supports method of Connection Object.
Public enumeration | TriggerActionEnum | Supported values for triggers moment operations
Top

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x


Command Class

[image] [image] [image]

NetData Reference
Command Class
Members

This class has same behavior of .Net Command object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Command
C#
public sealed class Command

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Command

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Members


Command Members

[image] [image] [image]

NetData Reference
Command Members
Command Class Methods Properties See Also

This class has same behavior of .Net Command object

The following tables list the members exposed by the Command type.

Expand image Public Properties

 | Name | Description
Public property | ActiveConnection | Gets the Connection used by this Command.
Public property | AsyncFetch | Gets if an asynchronous fetch is used to retrieve data.
Public property | CommandText | Gets or sets the text command to run against the data source.
Public property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public property | CommandType | Indicates or specifies how the CommandText property is interpreted.
Public property | Parameters | Gets the collection of Softgroup.NetData.Parameters objects.
Public property | Transaction | Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Top

Expand image Public Methods

 | Name | Description
Public method | Cancel | Attempts to cancels the execution of a Command.
Public method | Dispose | Releases all resources used by the objectt.
Public method | ExecuteNonQuery | Executes a SQL statement against a connection object
Public method | ExecuteReader | (Overloaded) Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
Public method | ExecuteScalar | Executes the query and returns the first column of the first row in the result set returned by the query. All other columns and rows are ignored.
Public method | Prepare | Creates a prepared (or compiled) version of the command on the data source.
Top

Expand image See Also

Reference

Command Class


Command Properties

[image] [image] [image]

NetData Reference
Command Properties
Command Class See Also

Expand image Public Properties

 | Name | Description
Public property | ActiveConnection | Gets the Connection used by this Command.
Public property | AsyncFetch | Gets if an asynchronous fetch is used to retrieve data.
Public property | CommandText | Gets or sets the text command to run against the data source.
Public property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public property | CommandType | Indicates or specifies how the CommandText property is interpreted.
Public property | Parameters | Gets the collection of Softgroup.NetData.Parameters objects.
Public property | Transaction | Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Top

Expand image See Also

Reference

Command Class


Command.ActiveConnection Property

[image] [image] [image]

NetData Reference
Command.ActiveConnection Property
See Also

Gets the Connection used by this Command.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveConnection() As Object
C#
public object ActiveConnection {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.AsyncFetch Property

[image] [image] [image]

NetData Reference
Command.AsyncFetch Property
See Also

Gets if an asynchronous fetch is used to retrieve data.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property AsyncFetch() As Boolean
C#
public bool AsyncFetch {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.CommandText Property

[image] [image] [image]

NetData Reference
Command.CommandText Property
See Also

Gets or sets the text command to run against the data source.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandText() As String
C#
public string CommandText {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.CommandTimeout Property

[image] [image] [image]

NetData Reference
Command.CommandTimeout Property
See Also

Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandTimeout() As Integer
C#
public int CommandTimeout {get; set;}

Expand image Remarks

For a unlimited time set this value to 0. Default is -1 (driver default value).

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.CommandType Property

[image] [image] [image]

NetData Reference
Command.CommandType Property
See Also

Indicates or specifies how the CommandText property is interpreted.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandType() As CommandType
C#
public CommandType CommandType {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.Parameters Property

[image] [image] [image]

NetData Reference
Command.Parameters Property
See Also

Gets the collection of Softgroup.NetData.Parameters objects.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters() As Parameters
C#
public Parameters Parameters {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.Transaction Property

[image] [image] [image]

NetData Reference
Command.Transaction Property
See Also

Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Transaction() As DbTransaction
C#
public DbTransaction Transaction {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command Methods

[image] [image] [image]

NetData Reference
Command Methods
Command Class See Also

Expand image Public Methods

 | Name | Description
Public method | Cancel | Attempts to cancels the execution of a Command.
Public method | Dispose | Releases all resources used by the objectt.
Public method | ExecuteNonQuery | Executes a SQL statement against a connection object
Public method | ExecuteReader | (Overloaded) Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
Public method | ExecuteScalar | Executes the query and returns the first column of the first row in the result set returned by the query. All other columns and rows are ignored.
Public method | Prepare | Creates a prepared (or compiled) version of the command on the data source.
Top

Expand image See Also

Reference

Command Class


Command.Cancel Method

[image] [image] [image]

NetData Reference
Command.Cancel Method
See Also

Attempts to cancels the execution of a Command.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Cancel()
C#
public System.Void Cancel()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.Dispose Method

[image] [image] [image]

NetData Reference
Command.Dispose Method
See Also

Releases all resources used by the objectt.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

C#
public System.Void Dispose()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.ExecuteNonQuery Method

[image] [image] [image]

NetData Reference
Command.ExecuteNonQuery Method
See Also

Executes a SQL statement against a connection object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteNonQuery() As Integer
C#
public int ExecuteNonQuery()

Return Value

The number of rows affected.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.ExecuteReader Method

[image] [image] [image]

NetData Reference
Command.ExecuteReader Method
Command Class See Also

Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.

Expand image Overload List

Name | Description
ExecuteReader() | Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
ExecuteReader(bool) | Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
ExecuteReader(bool, bool) | Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.

Expand image See Also

Reference

Command Class
Command Members


Command.ExecuteScalar Method

[image] [image] [image]

NetData Reference
Command.ExecuteScalar Method
See Also

Executes the query and returns the first column of the first row in the result set returned by the query. All other columns and rows are ignored.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteScalar() As Object
C#
public object ExecuteScalar()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.Prepare Method

[image] [image] [image]

NetData Reference
Command.Prepare Method
See Also

Creates a prepared (or compiled) version of the command on the data source.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Prepare()
C#
public System.Void Prepare()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Connection Class

[image] [image] [image]

NetData Reference
Connection Class
Members

Softgroup Connection object must be used for establish the connection to a database.

To estabish a connection with a database you must initialize Connection object with a specific Driver and than call the Open method; Close method must be used for close the connection to a Database.

Connection object support most feautures of Microsoft ADO Connection or Net DBConnection object and can be used to replace it during the conversion of Microsoft Visual Basic 6 projects that make use of Microsoft ADO library.

Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Connection
    Implements IDisposable
C#
public sealed class Connection : IDisposable

Expand image Remarks

Many other feautures are included in Connection object to manage database objects:

  • Database Backup
  • Database Restore
  • Database Compact
  • Database Transactions
  • Tables (create, delete, exist, list)
  • Indexes (create, delete, exist, list, fields list of an index)
  • Views (create, delete, exist, list)
  • Foreing Keys (create, delete, exist, list)
  • Procedures (create, delete, exist, list)
  • Triggers (create, delete, exist, list)
  • Groups (create, delete, exist, list)
  • Users (create, delete, exist, list, change password)
  • Generic Permissions Grand/Revoke

A set of SQL string functions and convertions are supplied for writing in your code database-indipendent SQL statements.

Connection object supply also customizable-language dialogs for:

  • Driver Selection
  • Login and Open a Database
  • Backup Operations
  • Restore Operations

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Connection

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Members


Connection Members

[image] [image] [image]

NetData Reference
Connection Members
Connection Class Constructors Events Methods Properties See Also

Softgroup Connection object must be used for establish the connection to a database.

To estabish a connection with a database you must initialize Connection object with a specific Driver and than call the Open method; Close method must be used for close the connection to a Database.

Connection object support most feautures of Microsoft ADO Connection or Net DBConnection object and can be used to replace it during the conversion of Microsoft Visual Basic 6 projects that make use of Microsoft ADO library.

The following tables list the members exposed by the Connection type.

Expand image Public Constructors

 | Name | Description
Public constructor | Connection Constructor | (Overloaded) Create new instance of Connection object.
Top

Expand image Public Properties

 | Name | Description
Public property | CacheTablesSchema | Enable/Disable caching of tables schema. Default is enabled (True)
Public property | CommandTimeout | Gets/Sets the command timeout execution in seconds.
Public property | ConnectionTimeout | Gets/Sets the connection timeout in seconds.
Public property | ConvertStringCase | Gets a value that indicete if driver make case-translation of strings.
Public property | DataSource | Gets/Sets the name of data source (server, hostname, ip address or instance name)
Public property | DatabaseName | Gets/Sets the name of database
Public property | DatabasePassword | Gets/Sets the database password (supported only by Microsoft Access Jet ALEDB Provider)
Public property | DefaultDatabaseName | Gets the name of the default database name used by the driver
Public property | DefaultSchemaName | Gets/Sets the name of the default schema name used by the driver
Public property | DefaultSystemDatabaseName | Gets/Sets the name of the default system database name used by the driver
Public property | DefaultUserName | Gets/Sets the name of the default user name used by the driver
Public property | DriverAssembly | Gets currently native assembly driver used by Connection object
Public property | DriverName | Gets the current driver name of an empty string if no driver will be initialized
Public property | DriverType | Gets current data access technology used by native driver.
Public property | ExclusiveMode | Return True if Database is open in exclusive mode (supported by Microsoft Access only)
Public property | IsAlive | Return True if server connection is alive.
Public property | IsClosed | Return True if connection state is Closed.
Public property | IsOpen | Gets the Connection object state.
Public property | IsolationLevel | Gets/Sets the Isolation Level of database.
Public property | OSAuthentication | Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Public property | ParameterChar | Gets the string used by provider to identify a parameter in a SQL statement.
Public property | PersistSecurityInfo | Gets/Set if user name and/or pawword must be returned in connection string
Public property | ProviderName | Gets current provider Driver name.
Public property | ProviderType | Gets current provider type code.
Public property | QuoteIdentifierLeft | Gets left character quote identifier used for Tables and Columns names
Public property | QuoteIdentifierRight | Gets right character quote identifier used for Tables and Columns names
Public property | StandardJoins | Return a boolean value that indicate if database support standard joins. Standard joins uses LEFT, RIGHT and INNER JOIN keywords in SQL statements to link two or more tables. Not standard joins uses WHERE clause in SQL statements to join two or more tables (tableA.fieldA [+]=[+] tableB.fieldB)
Public property | StandardUnionAll | Return a boolean value that indicate if database support UNION SELECT ALL syntax for union select queries or UNION ALL SELECT syntax.
Public property | SystemDatabaseName | Gets/Sets the path/file of system database (usually system.mdw) for Microsoft Access databases.
Public property | TableAliasPrefix | Return the Prefix string used to alia a table in a SQL statement.
Public property | Transaction | Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Public property | TransactionPending | Return True if a Transaction is already started (pending) with a call to TransBegin method.
Public property | Unicode | Gets if Unicode support is enabled
Public property | UseADO | Gets/Sets if class must use Microsoft ADO objects
Public property | UserName | Gets/Sets the user name used to login into the database
Public property | UserPassword | Gets/Sets the user password used to login into the database
Public property | VersionString | Obtain the string server version of database.
Top

Expand image Public Methods

 | Name | Description
Public method | BinaryExport | Read the contents of a binary field of a table and write content to specified disk file
Public method | BinaryImport | Read specified file content and write all bytes into a binary field of a table
Public method | BinaryRead | Read the contents of a binary field of a table and return a Byte array of the data
Public method | BinaryWrite | Write a byte array of data into a binary field of a table
 | ClearAllPools | Try call ClearAllPools method of Connection object.
 | ClearPool | Try call ClearAllPools method of Connection object.
Public method | Close | Close a Connection object and free resources associated
Public method | Command | (Overloaded) Obtain a Softgroup.NetData.Command from the Connection object. This method create a command of type CommandType.Text.
Public method | CommandBuilder | Obtain a System.Data.Common.DbCommandBuilder from the Connection object.
Public method | ConnectionString | (Overloaded) Gets the connection string used for establish the database connection. The returned string value can be used to re-open the connection.
Public method | ConnectionStringDriver | (Overloaded) Gets the native connection string used by the underline driver.
Public method | CounterValue | (Overloaded) Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Public method | CounterValueIdentity | Return the next custom counter or identity value of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Public method | CounterValueIdentityLong | Return the next custom counter or identity value (as long) of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Public method | CounterValueLong | (Overloaded) Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Public method | DataAdapter | Obtain a System.Data.Common.DbDataAdapter from the Connection object.
Public method | DataReader | (Overloaded) Obtain a Softgroup.NetData.DataReader from the Connection object. This method does not retrive extended schema informations of fields.
Public method | DataTable | (Overloaded) Obtain a System.Data.DataTable from the Connection object.
Public method | DatabaseBackup | (Overloaded) Execute a Backup operation of the specified database
Public method | DatabaseChangePassword | Change or set password of a Microsoft Access database (this method can be used only with Microsoft JET OLEDB Provider)
Public method | DatabaseCompact | Compact the current database
Public method | DatabaseCreate | (Overloaded) Create the specified database and open the connection to the database (current connection will be closed).
Public method | DatabaseDelete | Delete the specified database
Public method | DatabaseExist | Check if the specified database exist.
Public method | DatabaseRestore | (Overloaded) Execute a Restore operation of the specified database
Public method | DatabasesList | Return an array of strings that contains the list of databases in the specified server or path (DataSource property)
Public method | DialogBackup | (Overloaded) Display a dialog for the backup operation of the specified database
Public method | DialogConnect | (Overloaded) Display a dialog for the connection to a database
Public method | DialogDrivers | (Overloaded) Display a selection dialog of available driver to use for the Connection to a database
Public method | DialogRestore | (Overloaded) Display a dialog for the restore operation of the specified database
Public method | Dispose | Close a Connection object and free resources associated
Public method | DriverInit | (Overloaded) Initialize the connection with the specific driver.
Public method | DriversList | Returns the list of available drivers.
Public method | ExecuteSQL | Execute a non-query statement. A non-query statement is an SQL statement that returns no data like INSERT, UPDATE or DELETE statement.
Public method | ExecuteSQLScalar | Execute an SQL statement and return the result of first value of first column.
Public method | FileExport | Create a file using the content of a binary field in the specified table.
Public method | FileExtension | Return the file extension of the file-database associated to the Connection object.
Public method | FileImport | Import the content of a file in a binary field of a Table.
Public method | ForeignKeyCreate | (Overloaded) Create a ForeignKey in the specified table of the current database
Public method | ForeignKeyDelete | Delete a ForeignKey from a table of the current database.
Public method | ForeignKeyExist | Check if a ForeignKey exists in a table of the current database.
Public method | ForeignKeysList | Returns the list of Fireign Keys in the current database.
Public method | FormatSQL | (Overloaded) Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.
Public method | GetDBConnection | Gets the native connection object associated to the instance of this class.
Public method | GetDBConnectionString | Gets the native connection string associated to the instance of this class.
Public method | GetServerDateTime | Gets the current date time of database server.
Public method | GroupAdd | Add a Group / Role to the current database
Public method | GroupDelete | Delete a Group / Role from the current database
Public method | GroupExist | Check if a Group / Role exist in the current database
Public method | GroupsList | Returns the list of Groups or Roles in the current database.
Public method | IndexCreate | Create a normal Index or Primary Key or Unique Index in the specified table of the current database.
Public method | IndexDelete | Delete an Index or Primary Key from a table of the current database.
Public method | IndexExist | Check if an index exist in a table of the current database.
Public method | IndexFieldsList | Returns the list of Fields contained in the specified Index associated to a Table in the current database.
Public method | IndexInfo | Returns informations about an index in a table of the current database
Public method | IndexesList | Returns the list of Indexes associated to a specified Table in the current database.
Public method | Open | (Overloaded) Open a connection to a database. Return True for success otherwise return False.
Public method | OpenTest | (Overloaded) Test a connection to a database throw a Connection object
Public method | PermissionsGrant | (Overloaded) Grant Permissions on specifed objects to Group/Users in the current database
Public method | PermissionsRevoke | (Overloaded) Revoke Permissions on specifed objects to Group/Users in the current database
Public method | ProcedureCreate | Create a procedure in the current database.
Public method | ProcedureDelete | Delete a procedure in the current database.
Public method | ProcedureExist | (Overloaded) Check if a procedure exist in the current database.
Public method | ProceduresList | (Overloaded) Returns the list of Procedures contained in the current database.
Public method | QueryFieldBoolean | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDate | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDecimal | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDouble | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldInteger | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldLong | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldObject | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldShort | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldSingle | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldString | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldTime | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | Recordset | (Overloaded) Create and open a Recordset object from specified DataTable.
Public method | Require | Gets if a driver require specified characteristic for opening the connection
Public method | SQLParse | Return the SQL TEXT statement properly converted for the driver.
Public method | SetDatabaseOption | Change database options
Public method | SqlAbs | Return the SQL statempent text to obtain absolute value of numeric expression or field that contain a number.
Public method | SqlCast | Return the SQL statempent text to execute a cast (or convertion) of an expression or field to a specified data type.
Public method | SqlConcatenate | (Overloaded) Return the SQL statempent text to execute a concatenation of an expression or field.
Public method | SqlDay | Return the SQL statempent text to obtain the DAY of week from an expression or field that contain a date value.
Public method | SqlHour | Return the SQL statempent text to obtain the HOUR of time from an expression or field that contain a time value.
Public method | SqlIfNull | (Overloaded) Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.
Public method | SqlIif | Return the SQL statement text to obtain a value by checking an expression that can be True or False.
Public method | SqlInstr | Return the SQL statempent text to obtain from a text field or expression the location of specified substring.
Public method | SqlLcase | Return the SQL statempent text to obtain the lower case converted value of an expression or field.
Public method | SqlLeft | Return the SQL statement to return the left part of an expression or text field for requested number of characters.
Public method | SqlLen | Return the SQL statement to return the size of an expression or text field.
Public method | SqlMid | Return the SQL statement to extract characters from an expression or text field starting from specified position.
Public method | SqlMinute | Return the SQL statement text to obtain the MINUTE of time from an expression or field that contain a time value.
Public method | SqlMonth | Return the SQL statement text to obtain the MONTH of year from an expression or field that contain a date value.
Public method | SqlNoLock | Return the SQL text used to force reading uncommetted records from specified table into SELECT statements.
Public method | SqlReplace | Return the SQL statement to extract characters from an expression or text field starting from specified position.
Public method | SqlRight | Return the SQL statement for return the right part of an expression or text field for requested number of characters.
Public method | SqlSecond | Return the SQL statement text to obtain the SECOND of time from an expression or field that contain a time value.
Public method | SqlUcase | Return the SQL statement text to obtain the upper case converted value of an expression or field.
Public method | SqlValue | (Overloaded) Return the SQL statement text to obtain the correct value or comparison value specified.
Public method | SqlWeek | Return the SQL statement text to obtain the WEEK of year from an expression or field that contain a date value.
Public method | SqlWhere | (Overloaded) Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Public method | SqlYear | Return the SQL statement text to obtain the YEAR from an expression or field that contain a date value.
 | SupportClearPools | Return True if clear of all connections pool is supported by specified driver name.
Public method | Supports | Determines whether a specified characteristic is supported by Connection object .
Public method | TableCopyTo | (Overloaded) Copy a table structure and data from current connection to a specified destination connection
Public method | TableCreate | Create the specified table in the current database
Public method | TableCreateTo | Create a table structure and indexes from current connection to a specified destination connection
Public method | TableDelete | Delete the specified table from current database.
Public method | TableExist | (Overloaded) Verify if the specified table from current database exist.
Public method | TableFieldAdd | (Overloaded) Add a field in the specified table of the current database
Public method | TableFieldDelete | Delete a field in the specified table of the current database.
Public method | TableFieldExist | Check if a field exist in the specified table of the current database.
Public method | TableFieldInfo | (Overloaded) Returns informations about a field in a specified table of the current database with partial information schema details.
Public method | TableFieldsList | (Overloaded) Returns the list of Fields contained in the specified Table of the current database with full information schema details.
Public method | TableHasBinaryFields | Return True if specified table name contains almost a field of type binary otherwise return False.
Public method | TableInsertSelect | (Overloaded) Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
Public method | TableRecordCount | Returns the total number of records in the specified table
Public method | TableRecordCountLong | Returns the total number of records (as a Long value) in the specified table
Public method | TableRename | Rename a table in the current database
Public method | TablesList | (Overloaded) Returns the list of Tables contained in the current database.
Public method | TransBegin | Start a Transaction in the current database.
Public method | TransCommit | Complete a Transaction in the current database.
Public method | TransRollback | Cancel a Transaction in the current database.
Public method | TriggerCreate | Create a Trigger on the specified table of current database
Public method | TriggerDelete | Delete e Trigger on the specified table from the current database
Public method | TriggerExist | Check if a Trigger exist on the specified table of the current database
Public method | TriggersList | Returns the list of Triggers contained in the specified table of current database.
Public method | UserAdd | (Overloaded) Add a user in the current database
Public method | UserDelete | (Overloaded) Delete a user in the current database
Public method | UserExist | (Overloaded) Check if a user exist in the current database
Public method | UserPasswordChange | Change the password of a user in the current database.
Public method | UsersList | (Overloaded) Returns the list of Users contained in the current database.
Public method | ViewCreate | Create a view in the current database.
Public method | ViewDelete | Delete a view in the current database.
Public method | ViewExist | (Overloaded) Check if a view exist in the current database.
Public method | ViewsList | (Overloaded) Returns the list of Views contained in the current database.
Top

Expand image Public Events

 | Name | Description
Public event | ConnectionClosed | This event will be generated after a connection is closed.
Public event | ConnectionOpened | This event will be generated after a connection is opened.
Public event | DatabaseBackuped | This event will be generated after a backup operation is completed.
Public event | DatabaseCompacted | This event will be generated after a database compact operation is completed.
Public event | DatabaseRestored | This event will be generated after a restore operation is completed.
Public event | DriverListFilter | This event will be generated every time a list of driver will be requested..
Public event | TableCopyProgress | This event will be generated during TableCopy method.
Top

Expand image See Also

Reference

Connection Class


Connection Constructor

[image] [image] [image]

NetData Reference
Connection Constructor
Connection Class See Also

Create new instance of Connection object.

Expand image Overload List

Name | Description
Connection() | Create new instance of Connection object.
Connection(Connection) | Create new instance of Connection object base on another Connection object and open it.
Connection(Connection, bool) | Create new instance of Connection object base on another Connection object and open it.
Connection(ConnectionStringBuild) | Create new instance of Connection object and open connection with specified ConnectionStringBuild object.
Connection(string) | Create new instance of Connection object and open connection with specified connection string.

Expand image See Also

Reference

Connection Class
Connection Members


Connection Properties

[image] [image] [image]

NetData Reference
Connection Properties
Connection Class See Also

Expand image Public Properties

 | Name | Description
Public property | CacheTablesSchema | Enable/Disable caching of tables schema. Default is enabled (True)
Public property | CommandTimeout | Gets/Sets the command timeout execution in seconds.
Public property | ConnectionTimeout | Gets/Sets the connection timeout in seconds.
Public property | ConvertStringCase | Gets a value that indicete if driver make case-translation of strings.
Public property | DataSource | Gets/Sets the name of data source (server, hostname, ip address or instance name)
Public property | DatabaseName | Gets/Sets the name of database
Public property | DatabasePassword | Gets/Sets the database password (supported only by Microsoft Access Jet ALEDB Provider)
Public property | DefaultDatabaseName | Gets the name of the default database name used by the driver
Public property | DefaultSchemaName | Gets/Sets the name of the default schema name used by the driver
Public property | DefaultSystemDatabaseName | Gets/Sets the name of the default system database name used by the driver
Public property | DefaultUserName | Gets/Sets the name of the default user name used by the driver
Public property | DriverAssembly | Gets currently native assembly driver used by Connection object
Public property | DriverName | Gets the current driver name of an empty string if no driver will be initialized
Public property | DriverType | Gets current data access technology used by native driver.
Public property | ExclusiveMode | Return True if Database is open in exclusive mode (supported by Microsoft Access only)
Public property | IsAlive | Return True if server connection is alive.
Public property | IsClosed | Return True if connection state is Closed.
Public property | IsOpen | Gets the Connection object state.
Public property | IsolationLevel | Gets/Sets the Isolation Level of database.
Public property | OSAuthentication | Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Public property | ParameterChar | Gets the string used by provider to identify a parameter in a SQL statement.
Public property | PersistSecurityInfo | Gets/Set if user name and/or pawword must be returned in connection string
Public property | ProviderName | Gets current provider Driver name.
Public property | ProviderType | Gets current provider type code.
Public property | QuoteIdentifierLeft | Gets left character quote identifier used for Tables and Columns names
Public property | QuoteIdentifierRight | Gets right character quote identifier used for Tables and Columns names
Public property | StandardJoins | Return a boolean value that indicate if database support standard joins. Standard joins uses LEFT, RIGHT and INNER JOIN keywords in SQL statements to link two or more tables. Not standard joins uses WHERE clause in SQL statements to join two or more tables (tableA.fieldA [+]=[+] tableB.fieldB)
Public property | StandardUnionAll | Return a boolean value that indicate if database support UNION SELECT ALL syntax for union select queries or UNION ALL SELECT syntax.
Public property | SystemDatabaseName | Gets/Sets the path/file of system database (usually system.mdw) for Microsoft Access databases.
Public property | TableAliasPrefix | Return the Prefix string used to alia a table in a SQL statement.
Public property | Transaction | Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Public property | TransactionPending | Return True if a Transaction is already started (pending) with a call to TransBegin method.
Public property | Unicode | Gets if Unicode support is enabled
Public property | UseADO | Gets/Sets if class must use Microsoft ADO objects
Public property | UserName | Gets/Sets the user name used to login into the database
Public property | UserPassword | Gets/Sets the user password used to login into the database
Public property | VersionString | Obtain the string server version of database.
Top

Expand image See Also

Reference

Connection Class


Connection.CacheTablesSchema Property

[image] [image] [image]

NetData Reference
Connection.CacheTablesSchema Property
See Also

Enable/Disable caching of tables schema. Default is enabled (True)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CacheTablesSchema() As Boolean
C#
public bool CacheTablesSchema {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CommandTimeout Property

[image] [image] [image]

NetData Reference
Connection.CommandTimeout Property
See Also

Gets/Sets the command timeout execution in seconds.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandTimeout() As Short
C#
public short CommandTimeout {get; set;}

Expand image Remarks

For a unlimited time set this value to 0. Default is -1 (driver default value).

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ConnectionTimeout Property

[image] [image] [image]

NetData Reference
Connection.ConnectionTimeout Property
See Also

Gets/Sets the connection timeout in seconds.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ConnectionTimeout() As Short
C#
public short ConnectionTimeout {get; set;}

Expand image Remarks

For a unlimited time set this value to 0. Default is -1 (driver default value).

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ConvertStringCase Property

[image] [image] [image]

NetData Reference
Connection.ConvertStringCase Property
See Also

Gets a value that indicete if driver make case-translation of strings.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConvertStringCase() As ConvertCaseEnum
C#
public ConvertCaseEnum ConvertStringCase {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataSource Property

[image] [image] [image]

NetData Reference
Connection.DataSource Property
See Also

Gets/Sets the name of data source (server, hostname, ip address or instance name)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DataSource() As String
C#
public string DataSource {get; set;}

Expand image Remarks

Fore file-based databases like Microsoft access this property can represent the path of database(s).

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseName Property

[image] [image] [image]

NetData Reference
Connection.DatabaseName Property
See Also

Gets/Sets the name of database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DatabaseName() As String
C#
public string DatabaseName {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabasePassword Property

[image] [image] [image]

NetData Reference
Connection.DatabasePassword Property
See Also

Gets/Sets the database password (supported only by Microsoft Access Jet ALEDB Provider)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DatabasePassword() As String
C#
public string DatabasePassword {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DefaultDatabaseName Property

[image] [image] [image]

NetData Reference
Connection.DefaultDatabaseName Property
See Also

Gets the name of the default database name used by the driver
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultDatabaseName() As String
C#
public string DefaultDatabaseName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DefaultSchemaName Property

[image] [image] [image]

NetData Reference
Connection.DefaultSchemaName Property
See Also

Gets/Sets the name of the default schema name used by the driver
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DefaultSchemaName() As String
C#
public string DefaultSchemaName {get; set;}

Expand image Remarks

By default methods: TablesList, ViewsList, TriggersList, ProceduresList, IndexesList and ForeignKeysList not returns the schema name if equivalent to property value of DefaultSchemaName. To return always the name of schema set the value of this property to an empty string.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DefaultSystemDatabaseName Property

[image] [image] [image]

NetData Reference
Connection.DefaultSystemDatabaseName Property
See Also

Gets/Sets the name of the default system database name used by the driver
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultSystemDatabaseName() As String
C#
public string DefaultSystemDatabaseName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DefaultUserName Property

[image] [image] [image]

NetData Reference
Connection.DefaultUserName Property
See Also

Gets/Sets the name of the default user name used by the driver
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultUserName() As String
C#
public string DefaultUserName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverAssembly Property

[image] [image] [image]

NetData Reference
Connection.DriverAssembly Property
See Also

Gets currently native assembly driver used by Connection object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverAssembly() As Assembly
C#
public Assembly DriverAssembly {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverName Property

[image] [image] [image]

NetData Reference
Connection.DriverName Property
See Also

Gets the current driver name of an empty string if no driver will be initialized
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverName() As String
C#
public string DriverName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverType Property

[image] [image] [image]

NetData Reference
Connection.DriverType Property
See Also

Gets current data access technology used by native driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverType() As DriverTypeEnum
C#
public DriverTypeEnum DriverType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ExclusiveMode Property

[image] [image] [image]

NetData Reference
Connection.ExclusiveMode Property
See Also

Return True if Database is open in exclusive mode (supported by Microsoft Access only)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ExclusiveMode() As Boolean
    Get
C#
public bool ExclusiveMode {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IsAlive Property

[image] [image] [image]

NetData Reference
Connection.IsAlive Property
See Also

Return True if server connection is alive.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAlive() As Boolean
C#
public bool IsAlive {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IsClosed Property

[image] [image] [image]

NetData Reference
Connection.IsClosed Property
See Also

Return True if connection state is Closed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed() As Boolean
C#
public bool IsClosed {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IsOpen Property

[image] [image] [image]

NetData Reference
Connection.IsOpen Property
See Also

Gets the Connection object state.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOpen() As Boolean
C#
public bool IsOpen {get;}

Expand image Remarks

See System.Data.ConnectionState .NET documentation for more details

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IsolationLevel Property

[image] [image] [image]

NetData Reference
Connection.IsolationLevel Property
See Also

Gets/Sets the Isolation Level of database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property IsolationLevel() As IsolationLevel
C#
public IsolationLevel IsolationLevel {get; set;}

Expand image Remarks

See System.Data.IsolationLevel documentation for more details.

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.OSAuthentication Property

[image] [image] [image]

NetData Reference
Connection.OSAuthentication Property
See Also

Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property OSAuthentication() As Boolean
C#
public bool OSAuthentication {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ParameterChar Property

[image] [image] [image]

NetData Reference
Connection.ParameterChar Property
See Also

Gets the string used by provider to identify a parameter in a SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterChar() As String
C#
public string ParameterChar {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PersistSecurityInfo Property

[image] [image] [image]

NetData Reference
Connection.PersistSecurityInfo Property
See Also

Gets/Set if user name and/or pawword must be returned in connection string
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property PersistSecurityInfo() As Boolean
C#
public bool PersistSecurityInfo {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProviderName Property

[image] [image] [image]

NetData Reference
Connection.ProviderName Property
See Also

Gets current provider Driver name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProviderName() As String
C#
public string ProviderName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProviderType Property

[image] [image] [image]

NetData Reference
Connection.ProviderType Property
See Also

Gets current provider type code.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProviderType() As ProviderTypeEnum
C#
public ProviderTypeEnum ProviderType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QuoteIdentifierLeft Property

[image] [image] [image]

NetData Reference
Connection.QuoteIdentifierLeft Property
See Also

Gets left character quote identifier used for Tables and Columns names
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property QuoteIdentifierLeft() As String
C#
public string QuoteIdentifierLeft {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QuoteIdentifierRight Property

[image] [image] [image]

NetData Reference
Connection.QuoteIdentifierRight Property
See Also

Gets right character quote identifier used for Tables and Columns names
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property QuoteIdentifierRight() As String
C#
public string QuoteIdentifierRight {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.StandardJoins Property

[image] [image] [image]

NetData Reference
Connection.StandardJoins Property
See Also

Return a boolean value that indicate if database support standard joins. Standard joins uses LEFT, RIGHT and INNER JOIN keywords in SQL statements to link two or more tables. Not standard joins uses WHERE clause in SQL statements to join two or more tables (tableA.fieldA [+]=[+] tableB.fieldB)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property StandardJoins() As Boolean
C#
public bool StandardJoins {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.StandardUnionAll Property

[image] [image] [image]

NetData Reference
Connection.StandardUnionAll Property
See Also

Return a boolean value that indicate if database support UNION SELECT ALL syntax for union select queries or UNION ALL SELECT syntax.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property StandardUnionAll() As Boolean
C#
public bool StandardUnionAll {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SystemDatabaseName Property

[image] [image] [image]

NetData Reference
Connection.SystemDatabaseName Property
See Also

Gets/Sets the path/file of system database (usually system.mdw) for Microsoft Access databases.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property SystemDatabaseName() As String
C#
public string SystemDatabaseName {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableAliasPrefix Property

[image] [image] [image]

NetData Reference
Connection.TableAliasPrefix Property
See Also

Return the Prefix string used to alia a table in a SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableAliasPrefix() As String
C#
public string TableAliasPrefix {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Transaction Property

[image] [image] [image]

NetData Reference
Connection.Transaction Property
See Also

Gets a System.Data.Common.DbTransaction object associated to the Connection object. Return Nothing on ADO connections.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Transaction() As DbTransaction
C#
public DbTransaction Transaction {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TransactionPending Property

[image] [image] [image]

NetData Reference
Connection.TransactionPending Property
See Also

Return True if a Transaction is already started (pending) with a call to TransBegin method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property TransactionPending() As Boolean
C#
public bool TransactionPending {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Unicode Property

[image] [image] [image]

NetData Reference
Connection.Unicode Property
See Also

Gets if Unicode support is enabled
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unicode() As Boolean
C#
public bool Unicode {get;}

Expand image Remarks

When Unicode support is enabled the Connection object uses unicode specific instructions during the creation of databases and tables with Text or Memo type columns.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UseADO Property

[image] [image] [image]

NetData Reference
Connection.UseADO Property
See Also

Gets/Sets if class must use Microsoft ADO objects
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property UseADO() As Boolean
C#
public bool UseADO {get; set;}

Expand image Remarks

Changing this property while a connection is opened will result an Exception

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserName Property

[image] [image] [image]

NetData Reference
Connection.UserName Property
See Also

Gets/Sets the user name used to login into the database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property UserName() As String
C#
public string UserName {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserPassword Property

[image] [image] [image]

NetData Reference
Connection.UserPassword Property
See Also

Gets/Sets the user password used to login into the database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property UserPassword() As String
C#
public string UserPassword {get; set;}

Expand image Remarks

Value of property can't be changed while connection is open.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.VersionString Property

[image] [image] [image]

NetData Reference
Connection.VersionString Property
See Also

Obtain the string server version of database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property VersionString() As String
C#
public string VersionString {get;}

Property Value

String of database server version

Expand image Remarks

Connection must be opened

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Methods

[image] [image] [image]

NetData Reference
Connection Methods
Connection Class See Also

Expand image Public Methods

 | Name | Description
Public method | BinaryExport | Read the contents of a binary field of a table and write content to specified disk file
Public method | BinaryImport | Read specified file content and write all bytes into a binary field of a table
Public method | BinaryRead | Read the contents of a binary field of a table and return a Byte array of the data
Public method | BinaryWrite | Write a byte array of data into a binary field of a table
 | ClearAllPools | Try call ClearAllPools method of Connection object.
 | ClearPool | Try call ClearAllPools method of Connection object.
Public method | Close | Close a Connection object and free resources associated
Public method | Command | (Overloaded) Obtain a Softgroup.NetData.Command from the Connection object. This method create a command of type CommandType.Text.
Public method | CommandBuilder | Obtain a System.Data.Common.DbCommandBuilder from the Connection object.
Public method | ConnectionString | (Overloaded) Gets the connection string used for establish the database connection. The returned string value can be used to re-open the connection.
Public method | ConnectionStringDriver | (Overloaded) Gets the native connection string used by the underline driver.
Public method | CounterValue | (Overloaded) Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Public method | CounterValueIdentity | Return the next custom counter or identity value of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Public method | CounterValueIdentityLong | Return the next custom counter or identity value (as long) of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Public method | CounterValueLong | (Overloaded) Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Public method | DataAdapter | Obtain a System.Data.Common.DbDataAdapter from the Connection object.
Public method | DataReader | (Overloaded) Obtain a Softgroup.NetData.DataReader from the Connection object. This method does not retrive extended schema informations of fields.
Public method | DataTable | (Overloaded) Obtain a System.Data.DataTable from the Connection object.
Public method | DatabaseBackup | (Overloaded) Execute a Backup operation of the specified database
Public method | DatabaseChangePassword | Change or set password of a Microsoft Access database (this method can be used only with Microsoft JET OLEDB Provider)
Public method | DatabaseCompact | Compact the current database
Public method | DatabaseCreate | (Overloaded) Create the specified database and open the connection to the database (current connection will be closed).
Public method | DatabaseDelete | Delete the specified database
Public method | DatabaseExist | Check if the specified database exist.
Public method | DatabaseRestore | (Overloaded) Execute a Restore operation of the specified database
Public method | DatabasesList | Return an array of strings that contains the list of databases in the specified server or path (DataSource property)
Public method | DialogBackup | (Overloaded) Display a dialog for the backup operation of the specified database
Public method | DialogConnect | (Overloaded) Display a dialog for the connection to a database
Public method | DialogDrivers | (Overloaded) Display a selection dialog of available driver to use for the Connection to a database
Public method | DialogRestore | (Overloaded) Display a dialog for the restore operation of the specified database
Public method | Dispose | Close a Connection object and free resources associated
Public method | DriverInit | (Overloaded) Initialize the connection with the specific driver.
Public method | DriversList | Returns the list of available drivers.
Public method | ExecuteSQL | Execute a non-query statement. A non-query statement is an SQL statement that returns no data like INSERT, UPDATE or DELETE statement.
Public method | ExecuteSQLScalar | Execute an SQL statement and return the result of first value of first column.
Public method | FileExport | Create a file using the content of a binary field in the specified table.
Public method | FileExtension | Return the file extension of the file-database associated to the Connection object.
Public method | FileImport | Import the content of a file in a binary field of a Table.
Public method | ForeignKeyCreate | (Overloaded) Create a ForeignKey in the specified table of the current database
Public method | ForeignKeyDelete | Delete a ForeignKey from a table of the current database.
Public method | ForeignKeyExist | Check if a ForeignKey exists in a table of the current database.
Public method | ForeignKeysList | Returns the list of Fireign Keys in the current database.
Public method | FormatSQL | (Overloaded) Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.
Public method | GetDBConnection | Gets the native connection object associated to the instance of this class.
Public method | GetDBConnectionString | Gets the native connection string associated to the instance of this class.
Public method | GetServerDateTime | Gets the current date time of database server.
Public method | GroupAdd | Add a Group / Role to the current database
Public method | GroupDelete | Delete a Group / Role from the current database
Public method | GroupExist | Check if a Group / Role exist in the current database
Public method | GroupsList | Returns the list of Groups or Roles in the current database.
Public method | IndexCreate | Create a normal Index or Primary Key or Unique Index in the specified table of the current database.
Public method | IndexDelete | Delete an Index or Primary Key from a table of the current database.
Public method | IndexExist | Check if an index exist in a table of the current database.
Public method | IndexFieldsList | Returns the list of Fields contained in the specified Index associated to a Table in the current database.
Public method | IndexInfo | Returns informations about an index in a table of the current database
Public method | IndexesList | Returns the list of Indexes associated to a specified Table in the current database.
Public method | Open | (Overloaded) Open a connection to a database. Return True for success otherwise return False.
Public method | OpenTest | (Overloaded) Test a connection to a database throw a Connection object
Public method | PermissionsGrant | (Overloaded) Grant Permissions on specifed objects to Group/Users in the current database
Public method | PermissionsRevoke | (Overloaded) Revoke Permissions on specifed objects to Group/Users in the current database
Public method | ProcedureCreate | Create a procedure in the current database.
Public method | ProcedureDelete | Delete a procedure in the current database.
Public method | ProcedureExist | (Overloaded) Check if a procedure exist in the current database.
Public method | ProceduresList | (Overloaded) Returns the list of Procedures contained in the current database.
Public method | QueryFieldBoolean | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDate | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDecimal | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldDouble | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldInteger | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldLong | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldObject | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldShort | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldSingle | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldString | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | QueryFieldTime | (Overloaded) Get the field value of first record founded in specified Table using supplied Where clause
Public method | Recordset | (Overloaded) Create and open a Recordset object from specified DataTable.
Public method | Require | Gets if a driver require specified characteristic for opening the connection
Public method | SQLParse | Return the SQL TEXT statement properly converted for the driver.
Public method | SetDatabaseOption | Change database options
Public method | SqlAbs | Return the SQL statempent text to obtain absolute value of numeric expression or field that contain a number.
Public method | SqlCast | Return the SQL statempent text to execute a cast (or convertion) of an expression or field to a specified data type.
Public method | SqlConcatenate | (Overloaded) Return the SQL statempent text to execute a concatenation of an expression or field.
Public method | SqlDay | Return the SQL statempent text to obtain the DAY of week from an expression or field that contain a date value.
Public method | SqlHour | Return the SQL statempent text to obtain the HOUR of time from an expression or field that contain a time value.
Public method | SqlIfNull | (Overloaded) Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.
Public method | SqlIif | Return the SQL statement text to obtain a value by checking an expression that can be True or False.
Public method | SqlInstr | Return the SQL statempent text to obtain from a text field or expression the location of specified substring.
Public method | SqlLcase | Return the SQL statempent text to obtain the lower case converted value of an expression or field.
Public method | SqlLeft | Return the SQL statement to return the left part of an expression or text field for requested number of characters.
Public method | SqlLen | Return the SQL statement to return the size of an expression or text field.
Public method | SqlMid | Return the SQL statement to extract characters from an expression or text field starting from specified position.
Public method | SqlMinute | Return the SQL statement text to obtain the MINUTE of time from an expression or field that contain a time value.
Public method | SqlMonth | Return the SQL statement text to obtain the MONTH of year from an expression or field that contain a date value.
Public method | SqlNoLock | Return the SQL text used to force reading uncommetted records from specified table into SELECT statements.
Public method | SqlReplace | Return the SQL statement to extract characters from an expression or text field starting from specified position.
Public method | SqlRight | Return the SQL statement for return the right part of an expression or text field for requested number of characters.
Public method | SqlSecond | Return the SQL statement text to obtain the SECOND of time from an expression or field that contain a time value.
Public method | SqlUcase | Return the SQL statement text to obtain the upper case converted value of an expression or field.
Public method | SqlValue | (Overloaded) Return the SQL statement text to obtain the correct value or comparison value specified.
Public method | SqlWeek | Return the SQL statement text to obtain the WEEK of year from an expression or field that contain a date value.
Public method | SqlWhere | (Overloaded) Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Public method | SqlYear | Return the SQL statement text to obtain the YEAR from an expression or field that contain a date value.
 | SupportClearPools | Return True if clear of all connections pool is supported by specified driver name.
Public method | Supports | Determines whether a specified characteristic is supported by Connection object .
Public method | TableCopyTo | (Overloaded) Copy a table structure and data from current connection to a specified destination connection
Public method | TableCreate | Create the specified table in the current database
Public method | TableCreateTo | Create a table structure and indexes from current connection to a specified destination connection
Public method | TableDelete | Delete the specified table from current database.
Public method | TableExist | (Overloaded) Verify if the specified table from current database exist.
Public method | TableFieldAdd | (Overloaded) Add a field in the specified table of the current database
Public method | TableFieldDelete | Delete a field in the specified table of the current database.
Public method | TableFieldExist | Check if a field exist in the specified table of the current database.
Public method | TableFieldInfo | (Overloaded) Returns informations about a field in a specified table of the current database with partial information schema details.
Public method | TableFieldsList | (Overloaded) Returns the list of Fields contained in the specified Table of the current database with full information schema details.
Public method | TableHasBinaryFields | Return True if specified table name contains almost a field of type binary otherwise return False.
Public method | TableInsertSelect | (Overloaded) Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
Public method | TableRecordCount | Returns the total number of records in the specified table
Public method | TableRecordCountLong | Returns the total number of records (as a Long value) in the specified table
Public method | TableRename | Rename a table in the current database
Public method | TablesList | (Overloaded) Returns the list of Tables contained in the current database.
Public method | TransBegin | Start a Transaction in the current database.
Public method | TransCommit | Complete a Transaction in the current database.
Public method | TransRollback | Cancel a Transaction in the current database.
Public method | TriggerCreate | Create a Trigger on the specified table of current database
Public method | TriggerDelete | Delete e Trigger on the specified table from the current database
Public method | TriggerExist | Check if a Trigger exist on the specified table of the current database
Public method | TriggersList | Returns the list of Triggers contained in the specified table of current database.
Public method | UserAdd | (Overloaded) Add a user in the current database
Public method | UserDelete | (Overloaded) Delete a user in the current database
Public method | UserExist | (Overloaded) Check if a user exist in the current database
Public method | UserPasswordChange | Change the password of a user in the current database.
Public method | UsersList | (Overloaded) Returns the list of Users contained in the current database.
Public method | ViewCreate | Create a view in the current database.
Public method | ViewDelete | Delete a view in the current database.
Public method | ViewExist | (Overloaded) Check if a view exist in the current database.
Public method | ViewsList | (Overloaded) Returns the list of Views contained in the current database.
Top

Expand image See Also

Reference

Connection Class


Connection.BinaryExport Method

[image] [image] [image]

NetData Reference
Connection.BinaryExport Method
See Also

Read the contents of a binary field of a table and write content to specified disk file
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function BinaryExport( _
   ByVal TableName As String, _
   ByVal BinaryFieldName As String, _
   ByVal Where As String, _
   ByVal File As String _
) As Boolean
C#
public bool BinaryExport(
   string TableName,
   string BinaryFieldName,
   string Where,
   string File
)

Parameters

TableName

Type: string

Name of table

BinaryFieldName

Type: string

Name of field that contain binary data to read

Where

Type: string

SQL Where clause (without the WHERE keyword) to find the record that contains data

File

Type: string

File name where export binary data (if file already exists it will be overwritten)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.BinaryImport Method

[image] [image] [image]

NetData Reference
Connection.BinaryImport Method
See Also

Read specified file content and write all bytes into a binary field of a table
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function BinaryImport( _
   ByVal TableName As String, _
   ByVal BinaryFieldName As String, _
   ByVal Where As String, _
   ByVal File As String _
) As Boolean
C#
public bool BinaryImport(
   string TableName,
   string BinaryFieldName,
   string Where,
   string File
)

Parameters

TableName

Type: string

Name of table

BinaryFieldName

Type: string

Name of binary field to update.

Where

Type: string

SQL Where clause (without the WHERE keyword) used to find the record that contains data

File

Type: string

File name that contains binary data to import. If file does't exist an exception will be throw.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.BinaryRead Method

[image] [image] [image]

NetData Reference
Connection.BinaryRead Method
See Also

Read the contents of a binary field of a table and return a Byte array of the data
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function BinaryRead( _
   ByVal TableName As String, _
   ByVal BinaryFieldName As String, _
   ByVal Where As String, _
   ByRef Data As Byte() _
) As Boolean
C#
public bool BinaryRead(
   string TableName,
   string BinaryFieldName,
   string Where,
   ref byte[] Data
)

Parameters

TableName

Type: string

Name of table

BinaryFieldName

Type: string

Name of field that contain binary data to read

Where

Type: string

SQL Where clause (without the WHERE keyword) to find the record that contains data

Data

Type: byte[]

Byte array of the data contained in the field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.BinaryWrite Method

[image] [image] [image]

NetData Reference
Connection.BinaryWrite Method
See Also

Write a byte array of data into a binary field of a table
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function BinaryWrite( _
   ByVal TableName As String, _
   ByVal BinaryFieldName As String, _
   ByVal Where As String, _
   ByVal Data As Byte() _
) As Boolean
C#
public bool BinaryWrite(
   string TableName,
   string BinaryFieldName,
   string Where,
   byte[] Data
)

Parameters

TableName

Type: string

Name of table

BinaryFieldName

Type: string

Name of binary field to update.

Where

Type: string

SQL Where clause (without the WHERE keyword) used to find the record that contains data

Data

Type: byte[]

Byte array of the data to write

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ClearAllPools Method

[image] [image] [image]

NetData Reference
Connection.ClearAllPools Method
See Also

Try call ClearAllPools method of Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub ClearAllPools( _
   ByVal sDriverName As String _
)
C#
public static System.Void ClearAllPools(
   string sDriverName
)

Parameters

sDriverName

Type: string

A valid driver name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ClearPool Method

[image] [image] [image]

NetData Reference
Connection.ClearPool Method
See Also

Try call ClearAllPools method of Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub ClearPool( _
   ByVal sDriverName As String, _
   ByVal oDBConnection As Object _
)
C#
public static System.Void ClearPool(
   string sDriverName,
   object oDBConnection
)

Parameters

sDriverName

Type: string

A valid driver name

oDBConnection

Type: object

A valid native Connection

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Close Method

[image] [image] [image]

NetData Reference
Connection.Close Method
See Also

Close a Connection object and free resources associated
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public System.Void Close()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Command Method

[image] [image] [image]

NetData Reference
Connection.Command Method
Connection Class See Also

Obtain a Softgroup.NetData.Command from the Connection object. This method create a command of type CommandType.Text.

Expand image Overload List

Name | Description
Command(string) | Obtain a Softgroup.NetData.Command from the Connection object. This method create a command of type CommandType.Text.
Command(string, CommandType) | Obtain a Softgroup.NetData.Command from the Connection object.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CommandBuilder Method

[image] [image] [image]

NetData Reference
Connection.CommandBuilder Method
See Also

Obtain a System.Data.Common.DbCommandBuilder from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CommandBuilder( _
   ByVal oDataAdapter As DbDataAdapter _
) As DbCommandBuilder
C#
public DbCommandBuilder CommandBuilder(
   DbDataAdapter oDataAdapter
)

Parameters

oDataAdapter

Type: DbDataAdapter

A System.Data.Common.DbDataAdapter.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ConnectionString Method

[image] [image] [image]

NetData Reference
Connection.ConnectionString Method
Connection Class See Also

Gets the connection string used for establish the database connection. The returned string value can be used to re-open the connection.

Expand image Overload List

Name | Description
ConnectionString() | Gets the connection string used for establish the database connection. The returned string value can be used to re-open the connection.
ConnectionString(bool) | The connection string consists of a series of values separated by a semicolon, which contain the information necessary to establish a database connection. Driver must be initialized using DriverInit method before collig this property.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ConnectionStringDriver Method

[image] [image] [image]

NetData Reference
Connection.ConnectionStringDriver Method
Connection Class See Also

Gets the native connection string used by the underline driver.

Expand image Overload List

Name | Description
ConnectionStringDriver() | Gets the native connection string used by the underline driver.
ConnectionStringDriver(bool) | Gets the native connection string used by the underline driver.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CounterValue Method

[image] [image] [image]

NetData Reference
Connection.CounterValue Method
Connection Class See Also

Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.

Expand image Overload List

Name | Description
CounterValue(string, string) | Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
CounterValue(string, string, string) | Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CounterValueIdentity Method

[image] [image] [image]

NetData Reference
Connection.CounterValueIdentity Method
See Also

Return the next custom counter or identity value of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValueIdentity( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Integer
C#
public int CounterValueIdentity(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

Return Value

Return the next counter value or 0 on errors.

Expand image Remarks

If field is not associated to a custom counter or identity the return value is same as CounterValue function.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CounterValueIdentityLong Method

[image] [image] [image]

NetData Reference
Connection.CounterValueIdentityLong Method
See Also

Return the next custom counter or identity value (as long) of a numeric a field type of the table in the current database. All custom counters start from 1 and increment value is 1.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValueIdentityLong( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Long
C#
public long CounterValueIdentityLong(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

Return Value

Return the next counter value or 0 on errors.

Expand image Remarks

If field is not associated to a custom counter or identity the return value is same as CounterValue function.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.CounterValueLong Method

[image] [image] [image]

NetData Reference
Connection.CounterValueLong Method
Connection Class See Also

Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.

Expand image Overload List

Name | Description
CounterValueLong(string, string) | Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
CounterValueLong(string, string, string) | Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataAdapter Method

[image] [image] [image]

NetData Reference
Connection.DataAdapter Method
See Also

Obtain a System.Data.Common.DbDataAdapter from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataAdapter( _
   ByVal oCommand As Command _
) As DbDataAdapter
C#
public DbDataAdapter DataAdapter(
   Command oCommand
)

Parameters

oCommand

Type: Command

A valid Softgroup.NetData.Command object (only select command are supported)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataReader Method

[image] [image] [image]

NetData Reference
Connection.DataReader Method
Connection Class See Also

Obtain a Softgroup.NetData.DataReader from the Connection object. This method does not retrive extended schema informations of fields.

Expand image Overload List

Name | Description
DataReader(Command) | Obtain a Softgroup.NetData.DataReader from the Connection object. This method does not retrive extended schema informations of fields.
DataReader(Command, bool) | Obtain a Softgroup.NetData.DataReader from the Connection object.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataTable Method

[image] [image] [image]

NetData Reference
Connection.DataTable Method
Connection Class See Also

Obtain a System.Data.DataTable from the Connection object.

Expand image Overload List

Name | Description
DataTable(string) | Obtain a System.Data.DataTable from the Connection object.
DataTable(string, string) | Obtain a System.Data.DataTable from the Connection object.
DataTable(Command) | Obtain a System.Data.DataTable from the Connection object.
DataTable(Command, string) | Obtain a System.Data.DataTable from the Connection object.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseBackup Method

[image] [image] [image]

NetData Reference
Connection.DatabaseBackup Method
Connection Class See Also

Execute a Backup operation of the specified database

Expand image Overload List

Name | Description
DatabaseBackup(string) | Execute a Backup operation of the specified database
DatabaseBackup(string, string) | Execute a Backup operation of the specified database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseChangePassword Method

[image] [image] [image]

NetData Reference
Connection.DatabaseChangePassword Method
See Also

Change or set password of a Microsoft Access database (this method can be used only with Microsoft JET OLEDB Provider)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseChangePassword( _
   ByVal sPassword As String _
) As Boolean
C#
public bool DatabaseChangePassword(
   string sPassword
)

Parameters

sPassword

Type: string

New password for database.

Return Value

Return True on success otherwise return False.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseCompact Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCompact Method
See Also

Compact the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCompact() As Boolean
C#
public bool DatabaseCompact()

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseCreate Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate Method
Connection Class See Also

Create the specified database and open the connection to the database (current connection will be closed).

Expand image Overload List

Name | Description
DatabaseCreate(string) | Create the specified database and open the connection to the database (current connection will be closed).
DatabaseCreate(string, string) | Create the specified database and open the connection (current connection will be closed).
DatabaseCreate(string, string, string) | Create the specified database and optionally open the connection.
DatabaseCreate(string, string, string, bool) | Create the specified database and optionally open the connection.
DatabaseCreate(string, string, bool) | Create the specified database and optionally open the connection.
DatabaseCreate(string, bool) | Create the specified database and optionally open the connection.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseDelete Method

[image] [image] [image]

NetData Reference
Connection.DatabaseDelete Method
See Also

Delete the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseDelete( _
   ByVal DBName As String _
) As Boolean
C#
public bool DatabaseDelete(
   string DBName
)

Parameters

DBName

Type: string

Name of database to delete.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseExist Method

[image] [image] [image]

NetData Reference
Connection.DatabaseExist Method
See Also

Check if the specified database exist.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseExist( _
   ByVal DBName As String _
) As Boolean
C#
public bool DatabaseExist(
   string DBName
)

Parameters

DBName

Type: string

Name of database to check.

Return Value

Return True if database exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseRestore Method

[image] [image] [image]

NetData Reference
Connection.DatabaseRestore Method
Connection Class See Also

Execute a Restore operation of the specified database

Expand image Overload List

Name | Description
DatabaseRestore(string) | Execute a Restore operation of the specified database
DatabaseRestore(string, string) | Execute a Restore operation of the specified database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabasesList Method

[image] [image] [image]

NetData Reference
Connection.DatabasesList Method
See Also

Return an array of strings that contains the list of databases in the specified server or path (DataSource property)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabasesList() As String()
C#
public string[] DatabasesList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogBackup Method

[image] [image] [image]

NetData Reference
Connection.DialogBackup Method
Connection Class See Also

Display a dialog for the backup operation of the specified database

Expand image Overload List

Name | Description
DialogBackup() | Display a dialog for the backup operation of the specified database
DialogBackup(Form) | Display a dialog for the backup operation of the specified database
DialogBackup(Form, string) | Display a dialog for the backup operation of the specified database
DialogBackup(Form, string, string) | Display a dialog for the backup operation of the specified database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogConnect Method

[image] [image] [image]

NetData Reference
Connection.DialogConnect Method
Connection Class See Also

Display a dialog for the connection to a database

Expand image Overload List

Name | Description
DialogConnect() | Display a dialog for the connection to a database
DialogConnect(Form) | Display a dialog for the Connection to a database
DialogConnect(Form, bool) | Display a dialog for the Connection to a database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogDrivers Method

[image] [image] [image]

NetData Reference
Connection.DialogDrivers Method
Connection Class See Also

Display a selection dialog of available driver to use for the Connection to a database

Expand image Overload List

Name | Description
DialogDrivers() | Display a selection dialog of available driver to use for the Connection to a database
DialogDrivers(Form) | Display a selection dialog of a driver to use for the Connection to a database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogRestore Method

[image] [image] [image]

NetData Reference
Connection.DialogRestore Method
Connection Class See Also

Display a dialog for the restore operation of the specified database

Expand image Overload List

Name | Description
DialogRestore() | Display a dialog for the restore operation of the specified database
DialogRestore(Form) | Display a dialog for the restore operation of the specified database
DialogRestore(Form, string) | Display a dialog for the restore operation of the specified database
DialogRestore(Form, string, string) | Display a dialog for the restore operation of the specified database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Dispose Method

[image] [image] [image]

NetData Reference
Connection.Dispose Method
See Also

Close a Connection object and free resources associated
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Dispose() Implements  _
   IDisposable.Dispose
C#
public System.Void Dispose()

Implements

IDisposable.Dispose

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverInit Method

[image] [image] [image]

NetData Reference
Connection.DriverInit Method
Connection Class See Also

Initialize the connection with the specific driver.

Expand image Overload List

Name | Description
DriverInit(string) | Initialize the connection with the specific driver.
DriverInit(string, bool) | Initialize the connection with the specific driver.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriversList Method

[image] [image] [image]

NetData Reference
Connection.DriversList Method
See Also

Returns the list of available drivers.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DriversList() As DataDriver()
C#
public DataDriver[] DriversList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ExecuteSQL Method

[image] [image] [image]

NetData Reference
Connection.ExecuteSQL Method
See Also

Execute a non-query statement. A non-query statement is an SQL statement that returns no data like INSERT, UPDATE or DELETE statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteSQL( _
   ByVal SQL As String _
) As Boolean
C#
public bool ExecuteSQL(
   string SQL
)

Parameters

SQL

Type: string

A non-query SQL statement.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ExecuteSQLScalar Method

[image] [image] [image]

NetData Reference
Connection.ExecuteSQLScalar Method
See Also

Execute an SQL statement and return the result of first value of first column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteSQLScalar( _
   ByVal SQL As String _
) As Object
C#
public object ExecuteSQLScalar(
   string SQL
)

Parameters

SQL

Type: string

A valid SQL statement.

Return Value

Return value or a System.DBNull.Value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FileExport Method

[image] [image] [image]

NetData Reference
Connection.FileExport Method
See Also

Create a file using the content of a binary field in the specified table.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FileExport( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal Where As String, _
   ByVal FileName As String _
) As Boolean
C#
public bool FileExport(
   string TableName,
   string FieldName,
   string Where,
   string FileName
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field that contain binary data to export

Where

Type: string

SQL Where clause (without the WHERE keyword) to find the record that contains data

FileName

Type: string

Name of file to export data. If file already exists will be overwritten.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FileExtension Method

[image] [image] [image]

NetData Reference
Connection.FileExtension Method
See Also

Return the file extension of the file-database associated to the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FileExtension() As String
C#
public string FileExtension()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FileImport Method

[image] [image] [image]

NetData Reference
Connection.FileImport Method
See Also

Import the content of a file in a binary field of a Table.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FileImport( _
   ByVal TableName As String, _
   ByVal SelectFields As String(), _
   ByVal BinaryFieldName As String, _
   ByVal Where As String, _
   ByVal FileName As String _
) As Boolean
C#
public bool FileImport(
   string TableName,
   string[] SelectFields,
   string BinaryFieldName,
   string Where,
   string FileName
)

Parameters

TableName

Type: string

Name of table

SelectFields

Type: string[]

An array of string that contains fields names to use in the SQL SELECT statement. Array must contain binary field name to update and all fields names of a primary o unique index.

BinaryFieldName

Type: string

Name of field that contain binary data to import

Where

Type: string

SQL Where clause (without the WHERE keyword) to find the record in the import data

FileName

Type: string

Name of file to import.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyCreate Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyCreate Method
Connection Class See Also

Create a ForeignKey in the specified table of the current database

Expand image Overload List

Name | Description
ForeignKeyCreate(string, string, string, string) | Create a ForeignKey in the specified table of the current database
ForeignKeyCreate(string, string, string, string, string) | Create a ForeignKey in the specified table of the current database
ForeignKeyCreate(string, string, string, string, string, ForeignKeyActionEnum) | Create a ForeignKey in the specified table of the current database
ForeignKeyCreate(string, string, string, string, string, ForeignKeyActionEnum, ForeignKeyActionEnum) | Create a ForeignKey in the specified table of the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyDelete Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyDelete Method
See Also

Delete a ForeignKey from a table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyDelete( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String _
) As Boolean
C#
public bool ForeignKeyDelete(
   string TableName,
   string ForeignKeyName
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of Constraint

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyExist Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyExist Method
See Also

Check if a ForeignKey exists in a table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyExist( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String _
) As Boolean
C#
public bool ForeignKeyExist(
   string TableName,
   string ForeignKeyName
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of index to check

Return Value

Return True if success else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeysList Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeysList Method
See Also

Returns the list of Fireign Keys in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeysList( _
   ByVal TableName As String _
) As DataForeignKey()
C#
public DataForeignKey[] ForeignKeysList(
   string TableName
)

Parameters

TableName

Type: string

Name of Table

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FormatSQL Method

[image] [image] [image]

NetData Reference
Connection.FormatSQL Method
Connection Class See Also

Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.

Expand image Overload List

Name | Description
FormatSQL(string) | Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.
FormatSQL(string, bool) | Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GetDBConnection Method

[image] [image] [image]

NetData Reference
Connection.GetDBConnection Method
See Also

Gets the native connection object associated to the instance of this class.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDBConnection() As Object
C#
public object GetDBConnection()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GetDBConnectionString Method

[image] [image] [image]

NetData Reference
Connection.GetDBConnectionString Method
See Also

Gets the native connection string associated to the instance of this class.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDBConnectionString() As String
C#
public string GetDBConnectionString()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GetServerDateTime Method

[image] [image] [image]

NetData Reference
Connection.GetServerDateTime Method
See Also

Gets the current date time of database server.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetServerDateTime() As Date
C#
public DateTime GetServerDateTime()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GroupAdd Method

[image] [image] [image]

NetData Reference
Connection.GroupAdd Method
See Also

Add a Group / Role to the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GroupAdd( _
   ByVal GName As String _
) As Boolean
C#
public bool GroupAdd(
   string GName
)

Parameters

GName

Type: string

Name of Group or Role to add

Return Value

Return True if succes else return False

Expand image Remarks

Before call this method check Supports method to see if Database support groups/roles.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GroupDelete Method

[image] [image] [image]

NetData Reference
Connection.GroupDelete Method
See Also

Delete a Group / Role from the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GroupDelete( _
   ByVal GName As String _
) As Boolean
C#
public bool GroupDelete(
   string GName
)

Parameters

GName

Type: string

Name of Group or Role to delete

Return Value

Return True if succes else return False

Expand image Remarks

Before calling this method, verify with Supports method to check if Database support groups/roles. Before deleting the specified group this method check if it exists. If group will not be found no errors will be generated and return True.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GroupExist Method

[image] [image] [image]

NetData Reference
Connection.GroupExist Method
See Also

Check if a Group / Role exist in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GroupExist( _
   ByVal GroupName As String _
) As Boolean
C#
public bool GroupExist(
   string GroupName
)

Parameters

GroupName

Type: string

Name of Group or Role to check

Return Value

Return True if Group/Role exist else return False

Expand image Remarks

Before calling this method, control Supports method to check if Database support groups/roles.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.GroupsList Method

[image] [image] [image]

NetData Reference
Connection.GroupsList Method
See Also

Returns the list of Groups or Roles in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GroupsList() As String()
C#
public string[] GroupsList()

Expand image Remarks

Use Supports method to chek if database support Groups Roles

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexCreate Method

[image] [image] [image]

NetData Reference
Connection.IndexCreate Method
See Also

Create a normal Index or Primary Key or Unique Index in the specified table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexCreate( _
   ByVal TableName As String, _
   ByVal IndexName As String, _
   ByVal IndexPrimary As Boolean, _
   ByVal IndexUnique As Boolean, _
   ByVal IndexFields As String() _
) As Boolean
C#
public bool IndexCreate(
   string TableName,
   string IndexName,
   bool IndexPrimary,
   bool IndexUnique,
   string[] IndexFields
)

Parameters

TableName

Type: string

Name of table associated to the index

IndexName

Type: string

Name of index to create

IndexPrimary

Type: bool

Specificy if the Index is a Primary Key

IndexUnique

Type: bool

Specify if the Index is a Unique key

IndexFields

Type: string[]

Array of Strngs that contains fields name that compose the index

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexDelete Method

[image] [image] [image]

NetData Reference
Connection.IndexDelete Method
See Also

Delete an Index or Primary Key from a table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexDelete( _
   ByVal TableName As String, _
   ByVal IndexName As String _
) As Boolean
C#
public bool IndexDelete(
   string TableName,
   string IndexName
)

Parameters

TableName

Type: string

Name of table associated to the index

IndexName

Type: string

Name of index to delete

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexExist Method

[image] [image] [image]

NetData Reference
Connection.IndexExist Method
See Also

Check if an index exist in a table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexExist( _
   ByVal TableName As String, _
   ByVal IndexName As String _
) As Boolean
C#
public bool IndexExist(
   string TableName,
   string IndexName
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

IndexName

Type: string

Name of index to check

Return Value

Return True if Index exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexFieldsList Method

[image] [image] [image]

NetData Reference
Connection.IndexFieldsList Method
See Also

Returns the list of Fields contained in the specified Index associated to a Table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexFieldsList( _
   ByVal TableName As String, _
   ByVal IndexName As String _
) As String()
C#
public string[] IndexFieldsList(
   string TableName,
   string IndexName
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

IndexName

Type: string

Name of index

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexInfo Method

[image] [image] [image]

NetData Reference
Connection.IndexInfo Method
See Also

Returns informations about an index in a table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexInfo( _
   ByVal TableName As String, _
   ByVal IndexName As String _
) As DataIndex
C#
public DataIndex IndexInfo(
   string TableName,
   string IndexName
)

Parameters

TableName

Type: string

Name of table associated to the index

IndexName

Type: string

Name of index to check

Return Value

Return an IndexData object with index informations otherwise return Nothing is specified index name doesn not exists.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.IndexesList Method

[image] [image] [image]

NetData Reference
Connection.IndexesList Method
See Also

Returns the list of Indexes associated to a specified Table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexesList( _
   ByVal TableName As String _
) As DataIndex()
C#
public DataIndex[] IndexesList(
   string TableName
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Open Method

[image] [image] [image]

NetData Reference
Connection.Open Method
Connection Class See Also

Open a connection to a database. Return True for success otherwise return False.

Expand image Overload List

Name | Description
Open() | Open a connection to a database. Return True for success otherwise return False.
Open(IsolationLevel) | Open a connection to a database with specified Isolation Level. Return True for success otherwise return False.
Open(string) | Open a connection to a database using specified connection string.
Open(string, IsolationLevel) | Open a connection to a database using specified connection string.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.OpenTest Method

[image] [image] [image]

NetData Reference
Connection.OpenTest Method
Connection Class See Also

Test a connection to a database throw a Connection object

Expand image Overload List

Name | Description
OpenTest() | Test a connection to a database throw a Connection object
OpenTest(string) | Test a connection to a database with specified connection string

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsGrant Method

[image] [image] [image]

NetData Reference
Connection.PermissionsGrant Method
Connection Class See Also

Grant Permissions on specifed objects to Group/Users in the current database

Expand image Overload List

Name | Description
PermissionsGrant(PermissionObjectEnum, string) | Grant Permissions on specifed objects to Group/Users in the current database
PermissionsGrant(PermissionObjectEnum, string, string) | Grant Permissions on specifed objects to Group/Users in the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsRevoke Method

[image] [image] [image]

NetData Reference
Connection.PermissionsRevoke Method
Connection Class See Also

Revoke Permissions on specifed objects to Group/Users in the current database

Expand image Overload List

Name | Description
PermissionsRevoke(PermissionObjectEnum, string) | Revoke Permissions on specifed objects to Group/Users in the current database
PermissionsRevoke(PermissionObjectEnum, string, string) | Revoke Permissions on specifed objects to Group/Users in the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProcedureCreate Method

[image] [image] [image]

NetData Reference
Connection.ProcedureCreate Method
See Also

Create a procedure in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProcedureCreate( _
   ByVal ProcName As String, _
   ByVal ProcParameters As String, _
   ByVal SQLText As String _
) As Boolean
C#
public bool ProcedureCreate(
   string ProcName,
   string ProcParameters,
   string SQLText
)

Parameters

ProcName

Type: string

Name of procedure.

ProcParameters

Type: string

Parameters of procedure or an empty string for no parameters.

SQLText

Type: string

Text of procedure. See database documentation for more details.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProcedureDelete Method

[image] [image] [image]

NetData Reference
Connection.ProcedureDelete Method
See Also

Delete a procedure in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProcedureDelete( _
   ByVal ProcName As String _
) As Boolean
C#
public bool ProcedureDelete(
   string ProcName
)

Parameters

ProcName

Type: string

Name of procedure.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProcedureExist Method

[image] [image] [image]

NetData Reference
Connection.ProcedureExist Method
Connection Class See Also

Check if a procedure exist in the current database.

Expand image Overload List

Name | Description
ProcedureExist(string) | Check if a procedure exist in the current database.
ProcedureExist(string, string) | Check if a procedure exist in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProceduresList Method

[image] [image] [image]

NetData Reference
Connection.ProceduresList Method
Connection Class See Also

Returns the list of Procedures contained in the current database.

Expand image Overload List

Name | Description
ProceduresList() | Returns the list of Procedures contained in the current database.
ProceduresList(string) | Returns the list of Procedures contained in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldBoolean Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldBoolean Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldBoolean(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldBoolean(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldBoolean(string, string, string, string, bool) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldBoolean(string, string, string, string, bool, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDate Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDate Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldDate(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDate(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDate(string, string, string, string, DateTime) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDate(string, string, string, string, DateTime, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDecimal Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDecimal Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldDecimal(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDecimal(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDecimal(string, string, string, string, decimal) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDecimal(string, string, string, string, decimal, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDouble Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDouble Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldDouble(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDouble(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDouble(string, string, string, string, double) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldDouble(string, string, string, string, double, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldInteger Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldInteger Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldInteger(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldInteger(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldInteger(string, string, string, string, int) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldInteger(string, string, string, string, int, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldLong Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldLong Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldLong(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldLong(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldLong(string, string, string, string, long) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldLong(string, string, string, string, long, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldObject Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldObject Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldObject(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldObject(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldObject(string, string, string, string, object) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldObject(string, string, string, string, object, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldShort Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldShort Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldShort(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldShort(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldShort(string, string, string, string, short) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldShort(string, string, string, string, short, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldSingle Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldSingle Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldSingle(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldSingle(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldSingle(string, string, string, string, float) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldSingle(string, string, string, string, float, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldString Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldString Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldString(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldString(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldString(string, string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldString(string, string, string, string, string, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldTime Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldTime Method
Connection Class See Also

Get the field value of first record founded in specified Table using supplied Where clause

Expand image Overload List

Name | Description
QueryFieldTime(string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldTime(string, string, string, string) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldTime(string, string, string, string, TimeSpan) | Get the field value of first record founded in specified Table using supplied Where clause
QueryFieldTime(string, string, string, string, TimeSpan, bool) | Get the field value of first record founded in specified Table using supplied Where clause

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset Method

[image] [image] [image]

NetData Reference
Connection.Recordset Method
Connection Class See Also

Create and open a Recordset object from specified DataTable.

Expand image Overload List

Name | Description
Recordset(DataTable) | Create and open a Recordset object from specified DataTable.
Recordset(string) | Create and open a Recordset object from current connection object.
Recordset(string, bool) | Create and open a Recordset object from current connection object.
Recordset(string, bool, int) | Create and open a Recordset object from current connection object.
Recordset(string, bool, int, bool, int) | Create and open a Recordset object from current connection object.
Recordset(string, bool, int, bool, int, bool) | Create and open a Recordset object from current connection object.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Require Method

[image] [image] [image]

NetData Reference
Connection.Require Method
See Also

Gets if a driver require specified characteristic for opening the connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Require( _
   ByVal eRequire As RequireEnum _
) As Boolean
C#
public bool Require(
   RequireEnum eRequire
)

Parameters

eRequire

Type: RequireEnum

A RequireEnum value constant

Return Value

Return True if specified characteristic is required/supported otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SQLParse Method

[image] [image] [image]

NetData Reference
Connection.SQLParse Method
See Also

Return the SQL TEXT statement properly converted for the driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQLParse( _
   ByVal SQL As String _
) As String
C#
public string SQLParse(
   string SQL
)

Parameters

SQL

Type: string

Expand image Remarks

This function format SQL Text and convert tables and fields names to upper or lower cases properly for the driver.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SetDatabaseOption Method

[image] [image] [image]

NetData Reference
Connection.SetDatabaseOption Method
See Also

Change database options
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SetDatabaseOption( _
   ByVal Value As String _
) As Boolean
C#
public bool SetDatabaseOption(
   string Value
)

Parameters

Value

Type: string

A string value that define the option type and parameter

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlAbs Method

[image] [image] [image]

NetData Reference
Connection.SqlAbs Method
See Also

Return the SQL statempent text to obtain absolute value of numeric expression or field that contain a number.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlAbs( _
   ByVal sExpression As String _
) As String
C#
public string SqlAbs(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlCast Method

[image] [image] [image]

NetData Reference
Connection.SqlCast Method
See Also

Return the SQL statempent text to execute a cast (or convertion) of an expression or field to a specified data type.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlCast( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum _
) As String
C#
public string SqlCast(
   string sExpression,
   DataTypeEnum FieldType
)

Parameters

sExpression

Type: string

Name of field or expression to convert

FieldType

Type: DataTypeEnum

Data type returned

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlConcatenate Method

[image] [image] [image]

NetData Reference
Connection.SqlConcatenate Method
Connection Class See Also

Return the SQL statempent text to execute a concatenation of an expression or field.

Expand image Overload List

Name | Description
SqlConcatenate(string, string) | Return the SQL statempent text to execute a concatenation of an expression or field.
SqlConcatenate(string, string, string) | Return the SQL statempent text to execute a concatenation of an expression or field.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlDay Method

[image] [image] [image]

NetData Reference
Connection.SqlDay Method
See Also

Return the SQL statempent text to obtain the DAY of week from an expression or field that contain a date value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlDay( _
   ByVal sExpression As String _
) As String
C#
public string SqlDay(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlHour Method

[image] [image] [image]

NetData Reference
Connection.SqlHour Method
See Also

Return the SQL statempent text to obtain the HOUR of time from an expression or field that contain a time value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlHour( _
   ByVal sExpression As String _
) As String
C#
public string SqlHour(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlIfNull Method

[image] [image] [image]

NetData Reference
Connection.SqlIfNull Method
Connection Class See Also

Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.

Expand image Overload List

Name | Description
SqlIfNull(string, DataTypeEnum) | Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.
SqlIfNull(string, DataTypeEnum, string) | Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlIif Method

[image] [image] [image]

NetData Reference
Connection.SqlIif Method
See Also

Return the SQL statement text to obtain a value by checking an expression that can be True or False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlIif( _
   ByVal sExpression As String, _
   ByVal sExpressionTrue As String, _
   ByVal sExpressionFalse As String _
) As String
C#
public string SqlIif(
   string sExpression,
   string sExpressionTrue,
   string sExpressionFalse
)

Parameters

sExpression

Type: string

SQL Text or Expression to check

sExpressionTrue

Type: string

SQL Text for value returned if Expression is True.

sExpressionFalse

Type: string

SQL Text for value returned if Expression is False.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlInstr Method

[image] [image] [image]

NetData Reference
Connection.SqlInstr Method
See Also

Return the SQL statempent text to obtain from a text field or expression the location of specified substring.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlInstr( _
   ByVal sExpression As String, _
   ByVal sFind As String _
) As String
C#
public string SqlInstr(
   string sExpression,
   string sFind
)

Parameters

sExpression

Type: string

Name of field or expression

sFind

Type: string

Substring to find

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlLcase Method

[image] [image] [image]

NetData Reference
Connection.SqlLcase Method
See Also

Return the SQL statempent text to obtain the lower case converted value of an expression or field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlLcase( _
   ByVal sExpression As String _
) As String
C#
public string SqlLcase(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlLeft Method

[image] [image] [image]

NetData Reference
Connection.SqlLeft Method
See Also

Return the SQL statement to return the left part of an expression or text field for requested number of characters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlLeft( _
   ByVal sExpression As String, _
   ByVal iLenght As Integer _
) As String
C#
public string SqlLeft(
   string sExpression,
   int iLenght
)

Parameters

sExpression

Type: string

Name of field or expression

iLenght

Type: int

Number of charachters to extract

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlLen Method

[image] [image] [image]

NetData Reference
Connection.SqlLen Method
See Also

Return the SQL statement to return the size of an expression or text field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlLen( _
   ByVal sExpression As String _
) As String
C#
public string SqlLen(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlMid Method

[image] [image] [image]

NetData Reference
Connection.SqlMid Method
See Also

Return the SQL statement to extract characters from an expression or text field starting from specified position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlMid( _
   ByVal sExpression As String, _
   ByVal iStart As Integer, _
   ByVal iLenght As Integer _
) As String
C#
public string SqlMid(
   string sExpression,
   int iStart,
   int iLenght
)

Parameters

sExpression

Type: string

Name of field or expression

iStart

Type: int

String start position

iLenght

Type: int

Number of charachters to extract

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlMinute Method

[image] [image] [image]

NetData Reference
Connection.SqlMinute Method
See Also

Return the SQL statement text to obtain the MINUTE of time from an expression or field that contain a time value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlMinute( _
   ByVal sExpression As String _
) As String
C#
public string SqlMinute(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlMonth Method

[image] [image] [image]

NetData Reference
Connection.SqlMonth Method
See Also

Return the SQL statement text to obtain the MONTH of year from an expression or field that contain a date value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlMonth( _
   ByVal sExpression As String _
) As String
C#
public string SqlMonth(
   string sExpression
)

Parameters

sExpression

Type: string

Field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlNoLock Method

[image] [image] [image]

NetData Reference
Connection.SqlNoLock Method
See Also

Return the SQL text used to force reading uncommetted records from specified table into SELECT statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlNoLock( _
   ByVal sTableName As String _
) As String
C#
public string SqlNoLock(
   string sTableName
)

Parameters

sTableName

Type: string

Name of table (alias included if used: for example customers AS c) to which append NOLOCK statement if supported

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlReplace Method

[image] [image] [image]

NetData Reference
Connection.SqlReplace Method
See Also

Return the SQL statement to extract characters from an expression or text field starting from specified position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlReplace( _
   ByVal sExpression As String, _
   ByVal OldValue As String, _
   ByVal NewValue As String _
) As String
C#
public string SqlReplace(
   string sExpression,
   string OldValue,
   string NewValue
)

Parameters

sExpression

Type: string

Name of field or expression

OldValue

Type: string

String value to search

NewValue

Type: string

String to replace old value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlRight Method

[image] [image] [image]

NetData Reference
Connection.SqlRight Method
See Also

Return the SQL statement for return the right part of an expression or text field for requested number of characters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlRight( _
   ByVal sExpression As String, _
   ByVal iLenght As Integer _
) As String
C#
public string SqlRight(
   string sExpression,
   int iLenght
)

Parameters

sExpression

Type: string

Name of field or expression

iLenght

Type: int

Number of charachters to extract

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlSecond Method

[image] [image] [image]

NetData Reference
Connection.SqlSecond Method
See Also

Return the SQL statement text to obtain the SECOND of time from an expression or field that contain a time value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlSecond( _
   ByVal sExpression As String _
) As String
C#
public string SqlSecond(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlUcase Method

[image] [image] [image]

NetData Reference
Connection.SqlUcase Method
See Also

Return the SQL statement text to obtain the upper case converted value of an expression or field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlUcase( _
   ByVal sExpression As String _
) As String
C#
public string SqlUcase(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlValue Method

[image] [image] [image]

NetData Reference
Connection.SqlValue Method
Connection Class See Also

Return the SQL statement text to obtain the correct value or comparison value specified.

Expand image Overload List

Name | Description
SqlValue(object, DataTypeEnum) | Return the SQL statement text to obtain the correct value or comparison value specified.
SqlValue(object, DataTypeEnum, bool) | Return the SQL statement text to obtain the correct value or comparison value specified.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWeek Method

[image] [image] [image]

NetData Reference
Connection.SqlWeek Method
See Also

Return the SQL statement text to obtain the WEEK of year from an expression or field that contain a date value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlWeek( _
   ByVal sExpression As String _
) As String
C#
public string SqlWeek(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWhere Method

[image] [image] [image]

NetData Reference
Connection.SqlWhere Method
Connection Class See Also

Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.

Expand image Overload List

Name | Description
SqlWhere(string, DataTypeEnum, object) | Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
SqlWhere(string, DataTypeEnum, object, string) | Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
SqlWhere(string, DataTypeEnum, object, string, bool) | Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
SqlWhere(string, DataTypeEnum, object, string, bool, bool) | Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlYear Method

[image] [image] [image]

NetData Reference
Connection.SqlYear Method
See Also

Return the SQL statement text to obtain the YEAR from an expression or field that contain a date value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlYear( _
   ByVal sExpression As String _
) As String
C#
public string SqlYear(
   string sExpression
)

Parameters

sExpression

Type: string

Name of field or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SupportClearPools Method

[image] [image] [image]

NetData Reference
Connection.SupportClearPools Method
See Also

Return True if clear of all connections pool is supported by specified driver name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SupportClearPools( _
   ByVal sDriverName As String _
) As Boolean
C#
public static bool SupportClearPools(
   string sDriverName
)

Parameters

sDriverName

Type: string

A valid driver name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Supports Method

[image] [image] [image]

NetData Reference
Connection.Supports Method
See Also

Determines whether a specified characteristic is supported by Connection object .
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Supports( _
   ByVal SupportOptions As SupportsEnum _
) As Boolean
C#
public bool Supports(
   SupportsEnum SupportOptions
)

Parameters

SupportOptions

Type: SupportsEnum

Supported options to check

Return Value

Returns a Boolean value that indicates whether specifying a feature identified by the SupportOptions argument are supported by the Connection

Expand image Remarks

Use the Supports method to determine what types of functionality a Connection object supports. If the Connection object supports the features whose corresponding constants are in SupportOptions, the Supports method returns True. Otherwise, it returns False.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo Method
Connection Class See Also

Copy a table structure and data from current connection to a specified destination connection

Expand image Overload List

Name | Description
TableCopyTo(Connection, string, string) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool, bool) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool, bool, bool) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool, bool, bool, bool) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool, bool, bool, bool, bool) | Copy a table structure and data from current connection to a specified destination connection
TableCopyTo(Connection, string, string, bool, bool, bool, bool, bool, bool) | Copy a table structure and data from current connection to a specified destination connection

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCreate Method

[image] [image] [image]

NetData Reference
Connection.TableCreate Method
See Also

Create the specified table in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableCreate( _
   ByVal TableName As String, _
   ByVal oFields As Fields _
) As Boolean
C#
public bool TableCreate(
   string TableName,
   Fields oFields
)

Parameters

TableName

Type: string

Name of table.

oFields

Type: Fields

Object of type Fields with the list of fields in the table

Return Value

Return True if succes else return False

Expand image Remarks

If Unicode property is sets to True, Connection object create the table column as unicode data type for Text and Memo fields.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCreateTo Method

[image] [image] [image]

NetData Reference
Connection.TableCreateTo Method
See Also

Create a table structure and indexes from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCreateTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean, _
   ByVal CreateIndexes As Boolean, _
   ByVal UseTransactions As Boolean _
)
C#
public System.Void TableCreateTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData,
   bool CreateIndexes,
   bool UseTransactions
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

CreateIndexes

Type: bool

Create Indexes on destination table

UseTransactions

Type: bool

Use transactions for all operation

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableDelete Method

[image] [image] [image]

NetData Reference
Connection.TableDelete Method
See Also

Delete the specified table from current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableDelete( _
   ByVal TableName As String _
) As Boolean
C#
public bool TableDelete(
   string TableName
)

Parameters

TableName

Type: string

Name of table

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableExist Method

[image] [image] [image]

NetData Reference
Connection.TableExist Method
Connection Class See Also

Verify if the specified table from current database exist.

Expand image Overload List

Name | Description
TableExist(string) | Verify if the specified table from current database exist.
TableExist(string, string) | Verify if the specified table from current database exist.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldAdd Method

[image] [image] [image]

NetData Reference
Connection.TableFieldAdd Method
Connection Class See Also

Add a field in the specified table of the current database

Expand image Overload List

Name | Description
TableFieldAdd(string, string, DataTypeEnum, int, bool) | Add a field in the specified table of the current database
TableFieldAdd(string, string, DataTypeEnum, int, bool, bool) | Add a field in the specified table of the current database
TableFieldAdd(string, string, DataTypeEnum, int, bool, bool, object) | Add a field in the specified table of the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldDelete Method

[image] [image] [image]

NetData Reference
Connection.TableFieldDelete Method
See Also

Delete a field in the specified table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldDelete( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Boolean
C#
public bool TableFieldDelete(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldExist Method

[image] [image] [image]

NetData Reference
Connection.TableFieldExist Method
See Also

Check if a field exist in the specified table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldExist( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Boolean
C#
public bool TableFieldExist(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

Return Value

Return True if field exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldInfo Method

[image] [image] [image]

NetData Reference
Connection.TableFieldInfo Method
Connection Class See Also

Returns informations about a field in a specified table of the current database with partial information schema details.

Expand image Overload List

Name | Description
TableFieldInfo(string, string) | Returns informations about a field in a specified table of the current database with partial information schema details.
TableFieldInfo(string, string, bool) | Returns informations about a field in a specified table of the current database.
TableFieldInfo(string, string, bool, bool) | Returns informations about a field in a specified table of the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldsList Method

[image] [image] [image]

NetData Reference
Connection.TableFieldsList Method
Connection Class See Also

Returns the list of Fields contained in the specified Table of the current database with full information schema details.

Expand image Overload List

Name | Description
TableFieldsList(string) | Returns the list of Fields contained in the specified Table of the current database with full information schema details.
TableFieldsList(string, bool) | Returns the list of Fields contained in the specified Table of the current database.
TableFieldsList(string, bool, bool) | Returns the list of Fields contained in the specified Table of the current database.
TableFieldsList(string, bool, bool, bool) | Returns the list of Fields contained in the specified Table of the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableHasBinaryFields Method

[image] [image] [image]

NetData Reference
Connection.TableHasBinaryFields Method
See Also

Return True if specified table name contains almost a field of type binary otherwise return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableHasBinaryFields( _
   ByVal TableName As String _
) As Boolean
C#
public bool TableHasBinaryFields(
   string TableName
)

Parameters

TableName

Type: string

Name of table.

Expand image Remarks

This method can be used to check if a table contains a binary type field not supported by SQLInsert class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableInsertSelect Method

[image] [image] [image]

NetData Reference
Connection.TableInsertSelect Method
Connection Class See Also

Copy data from a source table to a destination table in the current database and optionally create destination table if not exist

Expand image Overload List

Name | Description
TableInsertSelect(string, string, string, string) | Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
TableInsertSelect(string, string, string, string, string) | Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
TableInsertSelect(string, string, string, string, string, bool) | Copy data from a source table to a destination table in the current database and optionally create destination table if not exist

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableRecordCount Method

[image] [image] [image]

NetData Reference
Connection.TableRecordCount Method
See Also

Returns the total number of records in the specified table
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableRecordCount( _
   ByVal TableName As String _
) As Integer
C#
public int TableRecordCount(
   string TableName
)

Parameters

TableName

Type: string

Table name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableRecordCountLong Method

[image] [image] [image]

NetData Reference
Connection.TableRecordCountLong Method
See Also

Returns the total number of records (as a Long value) in the specified table
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableRecordCountLong( _
   ByVal TableName As String _
) As Long
C#
public long TableRecordCountLong(
   string TableName
)

Parameters

TableName

Type: string

Table name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableRename Method

[image] [image] [image]

NetData Reference
Connection.TableRename Method
See Also

Rename a table in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableRename( _
   ByVal OldTableName As String, _
   ByVal NewTableName As String _
) As Boolean
C#
public bool TableRename(
   string OldTableName,
   string NewTableName
)

Parameters

OldTableName

Type: string

Current name of table

NewTableName

Type: string

New name of table

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TablesList Method

[image] [image] [image]

NetData Reference
Connection.TablesList Method
Connection Class See Also

Returns the list of Tables contained in the current database.

Expand image Overload List

Name | Description
TablesList() | Returns the list of Tables contained in the current database.
TablesList(string) | Returns the list of Tables contained in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TransBegin Method

[image] [image] [image]

NetData Reference
Connection.TransBegin Method
See Also

Start a Transaction in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TransBegin()
C#
public System.Void TransBegin()

Expand image Remarks

Only one Transaction for connection at a time is supported. See TransactionPending to check if another transaction is already started. Use TransCommit method to complete the transaction or TransRollback for cancel the transaction operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TransCommit Method

[image] [image] [image]

NetData Reference
Connection.TransCommit Method
See Also

Complete a Transaction in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TransCommit()
C#
public System.Void TransCommit()

Expand image Remarks

Only one Transaction for connection at a time is supported. See TranactionPending to check if a transaction is already started by a previous call to TransBegin. Use TransRollback for cancel the transaction operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TransRollback Method

[image] [image] [image]

NetData Reference
Connection.TransRollback Method
See Also

Cancel a Transaction in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TransRollback()
C#
public System.Void TransRollback()

Expand image Remarks

Only one Transaction for connection at a time is supported. See TransactionPending to check if a transaction is already started by a previous call to TransBegin.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TriggerCreate Method

[image] [image] [image]

NetData Reference
Connection.TriggerCreate Method
See Also

Create a Trigger on the specified table of current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TriggerCreate( _
   ByVal TableName As String, _
   ByVal TriggerName As String, _
   ByVal TriggerAction As TriggerActionEnum, _
   ByVal InsertEvent As Boolean, _
   ByVal UpdateEvent As Boolean, _
   ByVal DeleteEvent As Boolean, _
   ByVal TriggerProc As String _
) As Boolean
C#
public bool TriggerCreate(
   string TableName,
   string TriggerName,
   TriggerActionEnum TriggerAction,
   bool InsertEvent,
   bool UpdateEvent,
   bool DeleteEvent,
   string TriggerProc
)

Parameters

TableName

Type: string

Name of table

TriggerName

Type: string

Name of trigger

TriggerAction

Type: TriggerActionEnum

InsertEvent

Type: bool

True for activate trigger on INSERT operations

UpdateEvent

Type: bool

True for activate trigger on UPDATE operations

DeleteEvent

Type: bool

True for activate trigger on DELETE operations

TriggerProc

Type: string

Additional SQL text or procedure for trigger

Return Value

Return True for success or False for errors

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TriggerDelete Method

[image] [image] [image]

NetData Reference
Connection.TriggerDelete Method
See Also

Delete e Trigger on the specified table from the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TriggerDelete( _
   ByVal TableName As String, _
   ByVal TriggerName As String _
) As Boolean
C#
public bool TriggerDelete(
   string TableName,
   string TriggerName
)

Parameters

TableName

Type: string

Name of table

TriggerName

Type: string

Name of Trigger

Return Value

Return True for success or False for errors

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TriggerExist Method

[image] [image] [image]

NetData Reference
Connection.TriggerExist Method
See Also

Check if a Trigger exist on the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TriggerExist( _
   ByVal TableName As String, _
   ByVal TriggerName As String _
) As Boolean
C#
public bool TriggerExist(
   string TableName,
   string TriggerName
)

Parameters

TableName

Type: string

Name of table

TriggerName

Type: string

Name of Trigger

Return Value

Return True if Trigger exists or False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TriggersList Method

[image] [image] [image]

NetData Reference
Connection.TriggersList Method
See Also

Returns the list of Triggers contained in the specified table of current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TriggersList( _
   ByVal TableName As String _
) As String()
C#
public string[] TriggersList(
   string TableName
)

Parameters

TableName

Type: string

Name of table (table name can have syntax: SchemaName.TableNama)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserAdd Method

[image] [image] [image]

NetData Reference
Connection.UserAdd Method
Connection Class See Also

Add a user in the current database

Expand image Overload List

Name | Description
UserAdd(string, string) | Add a user in the current database
UserAdd(string, string, string) | Add a user in the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserDelete Method

[image] [image] [image]

NetData Reference
Connection.UserDelete Method
Connection Class See Also

Delete a user in the current database

Expand image Overload List

Name | Description
UserDelete(string) | Delete a user in the current database
UserDelete(string, string) | Delete a user in the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserExist Method

[image] [image] [image]

NetData Reference
Connection.UserExist Method
Connection Class See Also

Check if a user exist in the current database

Expand image Overload List

Name | Description
UserExist(string) | Check if a user exist in the current database
UserExist(string, string) | Check if a user exist in the current database

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserPasswordChange Method

[image] [image] [image]

NetData Reference
Connection.UserPasswordChange Method
See Also

Change the password of a user in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserPasswordChange( _
   ByVal UName As String, _
   ByVal NewUPassword As String, _
   ByVal OldUPassword As String _
) As Boolean
C#
public bool UserPasswordChange(
   string UName,
   string NewUPassword,
   string OldUPassword
)

Parameters

UName

Type: string

User name

NewUPassword

Type: string

New user password

OldUPassword

Type: string

Current user password

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UsersList Method

[image] [image] [image]

NetData Reference
Connection.UsersList Method
Connection Class See Also

Returns the list of Users contained in the current database.

Expand image Overload List

Name | Description
UsersList() | Returns the list of Users contained in the current database.
UsersList(string) | Returns the list of Users contained in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewCreate Method

[image] [image] [image]

NetData Reference
Connection.ViewCreate Method
See Also

Create a view in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewCreate( _
   ByVal ViewName As String, _
   ByVal ViewParameters As String, _
   ByVal SQLText As String _
) As Boolean
C#
public bool ViewCreate(
   string ViewName,
   string ViewParameters,
   string SQLText
)

Parameters

ViewName

Type: string

Name of procedure.

ViewParameters

Type: string

Parameters of view or an empty string for no parameters.

SQLText

Type: string

Text of view. See database documentation for more details.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewDelete Method

[image] [image] [image]

NetData Reference
Connection.ViewDelete Method
See Also

Delete a view in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewDelete( _
   ByVal ViewName As String _
) As Boolean
C#
public bool ViewDelete(
   string ViewName
)

Parameters

ViewName

Type: string

Name of view.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewExist Method

[image] [image] [image]

NetData Reference
Connection.ViewExist Method
Connection Class See Also

Check if a view exist in the current database.

Expand image Overload List

Name | Description
ViewExist(string) | Check if a view exist in the current database.
ViewExist(string, string) | Check if a view exist in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewsList Method

[image] [image] [image]

NetData Reference
Connection.ViewsList Method
Connection Class See Also

Returns the list of Views contained in the current database.

Expand image Overload List

Name | Description
ViewsList() | Returns the list of Views contained in the current database.
ViewsList(string) | Returns the list of Views contained in the current database.

Expand image See Also

Reference

Connection Class
Connection Members


Connection Events

[image] [image] [image]

NetData Reference
Connection Events
Connection Class See Also

Expand image Public Events

 | Name | Description
Public event | ConnectionClosed | This event will be generated after a connection is closed.
Public event | ConnectionOpened | This event will be generated after a connection is opened.
Public event | DatabaseBackuped | This event will be generated after a backup operation is completed.
Public event | DatabaseCompacted | This event will be generated after a database compact operation is completed.
Public event | DatabaseRestored | This event will be generated after a restore operation is completed.
Public event | DriverListFilter | This event will be generated every time a list of driver will be requested..
Public event | TableCopyProgress | This event will be generated during TableCopy method.
Top

Expand image See Also

Reference

Connection Class


ConnectionClosed Event

[image] [image] [image]

NetData Reference
ConnectionClosed Event
See Also

This event will be generated after a connection is closed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event ConnectionClosed()
C#
public event ConnectionClosedEventHandler ConnectionClosed
delegate void ConnectionClosedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


ConnectionOpened Event

[image] [image] [image]

NetData Reference
ConnectionOpened Event
See Also

This event will be generated after a connection is opened.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event ConnectionOpened()
C#
public event ConnectionOpenedEventHandler ConnectionOpened
delegate void ConnectionOpenedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DatabaseBackuped Event

[image] [image] [image]

NetData Reference
DatabaseBackuped Event
See Also

This event will be generated after a backup operation is completed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event DatabaseBackuped( _
   ByVal DBName As String, _
   ByVal sDestination As String _
)
C#
public event DatabaseBackupedEventHandler DatabaseBackuped
delegate void DatabaseBackupedEventHandler(
   string DBName,
   string sDestination
)

Parameters

DBName

Type: string

Database name

sDestination

Type: string

Destination path

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DatabaseCompacted Event

[image] [image] [image]

NetData Reference
DatabaseCompacted Event
See Also

This event will be generated after a database compact operation is completed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event DatabaseCompacted()
C#
public event DatabaseCompactedEventHandler DatabaseCompacted
delegate void DatabaseCompactedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DatabaseRestored Event

[image] [image] [image]

NetData Reference
DatabaseRestored Event
See Also

This event will be generated after a restore operation is completed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event DatabaseRestored( _
   ByVal DBName As String, _
   ByVal sSource As String _
)
C#
public event DatabaseRestoredEventHandler DatabaseRestored
delegate void DatabaseRestoredEventHandler(
   string DBName,
   string sSource
)

Parameters

DBName

Type: string

Database name

sSource

Type: string

Source path

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DriverListFilter Event

[image] [image] [image]

NetData Reference
DriverListFilter Event
See Also

This event will be generated every time a list of driver will be requested..
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event DriverListFilter( _
   ByVal oDataDriver As DataDriver, _
   ByRef Visible As Boolean _
)
C#
public event DriverListFilterEventHandler DriverListFilter
delegate void DriverListFilterEventHandler(
   DataDriver oDataDriver,
   ref bool Visible
)

Parameters

oDataDriver

Type: DataDriver

A DataDriver object that hold driver informations

Visible

Type: bool

Set to False to exclude driver from output list of drivers. Default is True.

Expand image Remarks

It is possible to exclude a driver from list setting Visible parameter to False.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


TableCopyProgress Event

[image] [image] [image]

NetData Reference
TableCopyProgress Event
See Also

This event will be generated during TableCopy method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event TableCopyProgress( _
   ByVal RecordNumber As Integer, _
   ByVal RecordCount As Integer _
)
C#
public event TableCopyProgressEventHandler TableCopyProgress
delegate void TableCopyProgressEventHandler(
   int RecordNumber,
   int RecordCount
)

Parameters

RecordNumber

Type: int

Current record number

RecordCount

Type: int

Total number of records

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


ConnectionStringBuild Class

[image] [image] [image]

NetData Reference
ConnectionStringBuild Class
Members

Provides a simple way to create and manage the contents of connection strings used by the Connection class.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConnectionStringBuild
C#
public sealed class ConnectionStringBuild

Expand image Remarks

The connection string consists of a series of values separated by a semicolon, which contain the information necessary to establish a database connection. The following table displays the values with which you can create a connection string:

Key | Value
DriverName | Name of softgroup driver
Unicode | True if driver supports unicode otherwise False
DataSource | Server name or DNS
DatabaseName | Name of database to c
SystemDatabaseName | Some drivers require a system database used to store security informations (like Microsof Access Database)
ConnectionTimeout | The connection timeout (-1 equals use driver default)
OSAuthentication | If driver supports trusted connections (OS authentication) this parameter can be True otherwise False to make a standard connection
UserName | Nome of user
Password | Password for user
UseADO | If DriverName is an OLEDB driver you can sets this parameter to True to force direct calls to Microsoft ADO library instead of using System.Data.OleDb .Net class.

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.ConnectionStringBuild

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Members


ConnectionStringBuild Members

[image] [image] [image]

NetData Reference
ConnectionStringBuild Members
ConnectionStringBuild Class Constructors Methods Properties See Also

Provides a simple way to create and manage the contents of connection strings used by the Connection class.

The following tables list the members exposed by the ConnectionStringBuild type.

Expand image Public Constructors

 | Name | Description
Public constructor | ConnectionStringBuild Constructor | (Overloaded) Create a new instance of the class.
Top

Expand image Public Properties

 | Name | Description
Public property | CommandTimeout | Gets/Sets the command timeout (-1 equals use driver default)
Public property | ConnectionTimeout | Gets/Sets the connection timeout (-1 equals use driver default)
Public property | DataSource | Gets/Sets Data Source name or DNS or Server name.
Public property | DatabaseName | Gets/Sets Database name.
Public property | DatabasePassword | Gets/Sets Database Password (this property is suppored only by Microsoft Access OLEDB Provider
Public property | DriverName | Gets/Sets Softgroup Interface Driver name thath must be used for the connection.
Public property | ExclusiveMode | Return True if Database must be open in exclusive mode (supported by Microsoft Access only)
Public property | IsDriverLoaded | Return True if a native Driver is currently loaded otherwise return False.
Public property | OSAuthentication | Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Public property | Password | Gets/Sets user password.
Public property | PersistSecurityInfo | Gets/Set if user name and/or pawword must be returned in connection string
Public property | Properties | Gets the list of properties used to build the connecton string
Public property | SystemDatabaseName | Gets/Sets system database name (needed by some providers).
Public property | Unicode | Gets/Sets if unicode support must be enabled
Public property | UseADO | Gets/Sets if class must use Microsoft ADO objects
Public property | UserName | Gets/Sets User name
Top

Expand image Public Methods

 | Name | Description
Public method | ConnectionString | Gets the connection string used by Softgroup.NetData.Connection object.
Public method | ConnectionStringDriver | Gets the native connection string used by the underline driver.
Public method | FromConnectionString | Load connection parameters values from specified connection string.
Top

Expand image See Also

Reference

ConnectionStringBuild Class


ConnectionStringBuild Constructor

[image] [image] [image]

NetData Reference
ConnectionStringBuild Constructor
ConnectionStringBuild Class See Also

Create a new instance of the class.

Expand image Overload List

Name | Description
ConnectionStringBuild() | Create a new instance of the class.
ConnectionStringBuild(string, bool) | Create a new instance of the class for specified driver name.
ConnectionStringBuild(string, bool, string, string, string, string, string) | Create a new instance of the class with specified parameters.
ConnectionStringBuild(string, bool, string, string, string, string, string, bool) | Create a new instance of the class with specified parameters.

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild Properties

[image] [image] [image]

NetData Reference
ConnectionStringBuild Properties
ConnectionStringBuild Class See Also

Expand image Public Properties

 | Name | Description
Public property | CommandTimeout | Gets/Sets the command timeout (-1 equals use driver default)
Public property | ConnectionTimeout | Gets/Sets the connection timeout (-1 equals use driver default)
Public property | DataSource | Gets/Sets Data Source name or DNS or Server name.
Public property | DatabaseName | Gets/Sets Database name.
Public property | DatabasePassword | Gets/Sets Database Password (this property is suppored only by Microsoft Access OLEDB Provider
Public property | DriverName | Gets/Sets Softgroup Interface Driver name thath must be used for the connection.
Public property | ExclusiveMode | Return True if Database must be open in exclusive mode (supported by Microsoft Access only)
Public property | IsDriverLoaded | Return True if a native Driver is currently loaded otherwise return False.
Public property | OSAuthentication | Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Public property | Password | Gets/Sets user password.
Public property | PersistSecurityInfo | Gets/Set if user name and/or pawword must be returned in connection string
Public property | Properties | Gets the list of properties used to build the connecton string
Public property | SystemDatabaseName | Gets/Sets system database name (needed by some providers).
Public property | Unicode | Gets/Sets if unicode support must be enabled
Public property | UseADO | Gets/Sets if class must use Microsoft ADO objects
Public property | UserName | Gets/Sets User name
Top

Expand image See Also

Reference

ConnectionStringBuild Class


ConnectionStringBuild.CommandTimeout Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.CommandTimeout Property
See Also

Gets/Sets the command timeout (-1 equals use driver default)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandTimeout() As Short
C#
public short CommandTimeout {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.ConnectionTimeout Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.ConnectionTimeout Property
See Also

Gets/Sets the connection timeout (-1 equals use driver default)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ConnectionTimeout() As Short
C#
public short ConnectionTimeout {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.DataSource Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.DataSource Property
See Also

Gets/Sets Data Source name or DNS or Server name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DataSource() As String
C#
public string DataSource {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.DatabaseName Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.DatabaseName Property
See Also

Gets/Sets Database name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DatabaseName() As String
C#
public string DatabaseName {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.DatabasePassword Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.DatabasePassword Property
See Also

Gets/Sets Database Password (this property is suppored only by Microsoft Access OLEDB Provider
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DatabasePassword() As String
C#
public string DatabasePassword {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.DriverName Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.DriverName Property
See Also

Gets/Sets Softgroup Interface Driver name thath must be used for the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverName() As String
C#
public string DriverName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.ExclusiveMode Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.ExclusiveMode Property
See Also

Return True if Database must be open in exclusive mode (supported by Microsoft Access only)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ExclusiveMode() As Boolean
C#
public bool ExclusiveMode {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.IsDriverLoaded Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.IsDriverLoaded Property
See Also

Return True if a native Driver is currently loaded otherwise return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDriverLoaded() As Boolean
C#
public bool IsDriverLoaded {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.OSAuthentication Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.OSAuthentication Property
See Also

Gets/Sets if a trusted connection (or authentication) is used to connect to a database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property OSAuthentication() As Boolean
C#
public bool OSAuthentication {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.Password Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.Password Property
See Also

Gets/Sets user password.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Password() As String
C#
public string Password {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.PersistSecurityInfo Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.PersistSecurityInfo Property
See Also

Gets/Set if user name and/or pawword must be returned in connection string
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property PersistSecurityInfo() As Boolean
C#
public bool PersistSecurityInfo {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.Properties Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.Properties Property
See Also

Gets the list of properties used to build the connecton string
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties() As List(Of ConnectionStringProperty)
C#
public List<ConnectionStringProperty> Properties {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.SystemDatabaseName Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.SystemDatabaseName Property
See Also

Gets/Sets system database name (needed by some providers).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property SystemDatabaseName() As String
C#
public string SystemDatabaseName {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.Unicode Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.Unicode Property
See Also

Gets/Sets if unicode support must be enabled
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Unicode() As Boolean
C#
public bool Unicode {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.UseADO Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.UseADO Property
See Also

Gets/Sets if class must use Microsoft ADO objects
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property UseADO() As Boolean
C#
public bool UseADO {get; set;}

Expand image Remarks

If DriverName is an OLEDB driver you can sets this parameter to True to force direct calls to Microsoft ADO library instead of using System.Data.OleDb .Net class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.UserName Property

[image] [image] [image]

NetData Reference
ConnectionStringBuild.UserName Property
See Also

Gets/Sets User name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property UserName() As String
C#
public string UserName {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild Methods

[image] [image] [image]

NetData Reference
ConnectionStringBuild Methods
ConnectionStringBuild Class See Also

Expand image Public Methods

 | Name | Description
Public method | ConnectionString | Gets the connection string used by Softgroup.NetData.Connection object.
Public method | ConnectionStringDriver | Gets the native connection string used by the underline driver.
Public method | FromConnectionString | Load connection parameters values from specified connection string.
Top

Expand image See Also

Reference

ConnectionStringBuild Class


ConnectionStringBuild.ConnectionString Method

[image] [image] [image]

NetData Reference
ConnectionStringBuild.ConnectionString Method
See Also

Gets the connection string used by Softgroup.NetData.Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionString() As String
C#
public string ConnectionString()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.ConnectionStringDriver Method

[image] [image] [image]

NetData Reference
ConnectionStringBuild.ConnectionStringDriver Method
See Also

Gets the native connection string used by the underline driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionStringDriver() As String
C#
public string ConnectionStringDriver()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild.FromConnectionString Method

[image] [image] [image]

NetData Reference
ConnectionStringBuild.FromConnectionString Method
See Also

Load connection parameters values from specified connection string.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FromConnectionString( _
   ByVal sConnectionString As String _
) As Boolean
C#
public bool FromConnectionString(
   string sConnectionString
)

Parameters

sConnectionString

Type: string

Connection String

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringProperty Class

[image] [image] [image]

NetData Reference
ConnectionStringProperty Class
Members

This class hola a propety that contains key, value and value type used in a connection string.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConnectionStringProperty
C#
public sealed class ConnectionStringProperty

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.ConnectionStringProperty

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringProperty Members


ConnectionStringProperty Members

[image] [image] [image]

NetData Reference
ConnectionStringProperty Members
ConnectionStringProperty Class Constructors Properties See Also

This class hola a propety that contains key, value and value type used in a connection string.

The following tables list the members exposed by the ConnectionStringProperty type.

Expand image Public Constructors

 | Name | Description
Public constructor | ConnectionStringProperty Constructor | Create a new property value connection string
Top

Expand image Public Properties

 | Name | Description
Public property | Key | Gets the key associated to the property
Public property | Value | Gets/Sets the value associated to the property
Public property | ValueType | Gets the Value Type associated to the property
Top

Expand image See Also

Reference

ConnectionStringProperty Class


ConnectionStringProperty Constructor

[image] [image] [image]

NetData Reference
ConnectionStringProperty Constructor
See Also

Create a new property value connection string
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sKey As String, _
   ByVal sValue As String, _
   ByVal sValueType As ConnectionStringValueTypeEnum _
)
C#
public ConnectionStringProperty(
   string sKey,
   string sValue,
   ConnectionStringValueTypeEnum sValueType
)

Parameters

sKey

Type: string

Key for value

sValue

Type: string

Value of property

sValueType

Type: ConnectionStringValueTypeEnum

Value type of property

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringProperty Class
ConnectionStringProperty Members


ConnectionStringProperty Properties

[image] [image] [image]

NetData Reference
ConnectionStringProperty Properties
ConnectionStringProperty Class See Also

Expand image Public Properties

 | Name | Description
Public property | Key | Gets the key associated to the property
Public property | Value | Gets/Sets the value associated to the property
Public property | ValueType | Gets the Value Type associated to the property
Top

Expand image See Also

Reference

ConnectionStringProperty Class


ConnectionStringProperty.Key Property

[image] [image] [image]

NetData Reference
ConnectionStringProperty.Key Property
See Also

Gets the key associated to the property
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Key() As String
C#
public string Key {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringProperty Class
ConnectionStringProperty Members


ConnectionStringProperty.Value Property

[image] [image] [image]

NetData Reference
ConnectionStringProperty.Value Property
See Also

Gets/Sets the value associated to the property
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Value() As String
C#
public string Value {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringProperty Class
ConnectionStringProperty Members


ConnectionStringProperty.ValueType Property

[image] [image] [image]

NetData Reference
ConnectionStringProperty.ValueType Property
See Also

Gets the Value Type associated to the property
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType() As ConnectionStringValueTypeEnum
C#
public ConnectionStringValueTypeEnum ValueType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringProperty Class
ConnectionStringProperty Members


DataDriver Class

[image] [image] [image]

NetData Reference
DataDriver Class
Members

This class holds drives informations
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataDriver
C#
public sealed class DataDriver

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.DataDriver

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataDriver Members


DataDriver Members

[image] [image] [image]

NetData Reference
DataDriver Members
DataDriver Class Properties See Also

This class holds drives informations

The following tables list the members exposed by the DataDriver type.

Expand image Public Properties

 | Name | Description
Public property | DriverName | Gets Driver Name
Public property | DriverType | Gets Driver Type
Public property | ProviderName | Gets Provider name
Public property | ProviderType | Gets Provider type
Top

Expand image See Also

Reference

DataDriver Class


DataDriver Properties

[image] [image] [image]

NetData Reference
DataDriver Properties
DataDriver Class See Also

Expand image Public Properties

 | Name | Description
Public property | DriverName | Gets Driver Name
Public property | DriverType | Gets Driver Type
Public property | ProviderName | Gets Provider name
Public property | ProviderType | Gets Provider type
Top

Expand image See Also

Reference

DataDriver Class


DataDriver.DriverName Property

[image] [image] [image]

NetData Reference
DataDriver.DriverName Property
See Also

Gets Driver Name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverName() As String
C#
public string DriverName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataDriver Class
DataDriver Members


DataDriver.DriverType Property

[image] [image] [image]

NetData Reference
DataDriver.DriverType Property
See Also

Gets Driver Type
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriverType() As DriverTypeEnum
C#
public DriverTypeEnum DriverType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataDriver Class
DataDriver Members


DataDriver.ProviderName Property

[image] [image] [image]

NetData Reference
DataDriver.ProviderName Property
See Also

Gets Provider name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProviderName() As String
C#
public string ProviderName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataDriver Class
DataDriver Members


DataDriver.ProviderType Property

[image] [image] [image]

NetData Reference
DataDriver.ProviderType Property
See Also

Gets Provider type
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProviderType() As ProviderTypeEnum
C#
public ProviderTypeEnum ProviderType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataDriver Class
DataDriver Members


DataForeignKey Class

[image] [image] [image]

NetData Reference
DataForeignKey Class
Members

This class holds Foreign Key informations data
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataForeignKey
C#
public sealed class DataForeignKey

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.DataForeignKey

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataForeignKey Members


DataForeignKey Members

[image] [image] [image]

NetData Reference
DataForeignKey Members
DataForeignKey Class Properties See Also

This class holds Foreign Key informations data

The following tables list the members exposed by the DataForeignKey type.

Expand image Public Properties

 | Name | Description
Public property | Name | Gets name of index
Public property | ReferencedTable | Gets name of referenced table of foreign key
Top

Expand image See Also

Reference

DataForeignKey Class


DataForeignKey Properties

[image] [image] [image]

NetData Reference
DataForeignKey Properties
DataForeignKey Class See Also

Expand image Public Properties

 | Name | Description
Public property | Name | Gets name of index
Public property | ReferencedTable | Gets name of referenced table of foreign key
Top

Expand image See Also

Reference

DataForeignKey Class


DataForeignKey.Name Property

[image] [image] [image]

NetData Reference
DataForeignKey.Name Property
See Also

Gets name of index
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Name() As String
    Get
C#
public string Name {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataForeignKey Class
DataForeignKey Members


DataForeignKey.ReferencedTable Property

[image] [image] [image]

NetData Reference
DataForeignKey.ReferencedTable Property
See Also

Gets name of referenced table of foreign key
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ReferencedTable() As String
    Get
C#
public string ReferencedTable {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataForeignKey Class
DataForeignKey Members


DataIndex Class

[image] [image] [image]

NetData Reference
DataIndex Class
Members

This class holds Index informations
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataIndex
C#
public sealed class DataIndex

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.DataIndex

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataIndex Members


DataIndex Members

[image] [image] [image]

NetData Reference
DataIndex Members
DataIndex Class Properties See Also

This class holds Index informations

The following tables list the members exposed by the DataIndex type.

Expand image Public Properties

 | Name | Description
Public property | Name | Gets name of index
Public property | Primaty | Gets True if index is a primary key
Public property | Unique | Gets True if index is unique
Top

Expand image See Also

Reference

DataIndex Class


DataIndex Properties

[image] [image] [image]

NetData Reference
DataIndex Properties
DataIndex Class See Also

Expand image Public Properties

 | Name | Description
Public property | Name | Gets name of index
Public property | Primaty | Gets True if index is a primary key
Public property | Unique | Gets True if index is unique
Top

Expand image See Also

Reference

DataIndex Class


DataIndex.Name Property

[image] [image] [image]

NetData Reference
DataIndex.Name Property
See Also

Gets name of index
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Name() As String
    Get
C#
public string Name {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataIndex Class
DataIndex Members


DataIndex.Primaty Property

[image] [image] [image]

NetData Reference
DataIndex.Primaty Property
See Also

Gets True if index is a primary key
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Primaty() As Boolean
    Get
C#
public bool Primaty {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataIndex Class
DataIndex Members


DataIndex.Unique Property

[image] [image] [image]

NetData Reference
DataIndex.Unique Property
See Also

Gets True if index is unique
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Unique() As Boolean
    Get
C#
public bool Unique {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataIndex Class
DataIndex Members


DataReader Class

[image] [image] [image]

NetData Reference
DataReader Class
Members

This class has same behavior of Net DataReader object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataReader
C#
public sealed class DataReader

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.DataReader

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Members


DataReader Members

[image] [image] [image]

NetData Reference
DataReader Members
DataReader Class Methods Properties See Also

This class has same behavior of Net DataReader object

The following tables list the members exposed by the DataReader type.

Expand image Public Properties

 | Name | Description
Public property | FieldCount | Gets the number of columns in the current row.
Public property | HasRows | Gets a value that indicates whether this DataReader contains one or more rows
Public property | IsClosed | Gets a value indicating whether the DataReader is closed.
Public property | Item | (Overloaded) Gets the value of a specified column as an instance of Object.
Top

Expand image Public Methods

 | Name | Description
Public method | Cancel | Attempts to cancels the execution of a reader.
Public method | Close | Closes the DataReader object.
Public method | Dispose | Releases all resources used by the objectt.
Public method | GetDataTypeName | (Overloaded) Gets name of the data type of the specified column.
Public method | GetFieldType | (Overloaded) Gets the data type of the specified column.
Public method | GetName | Gets the name of the column, given the zero-based column ordinal.
Public method | GetOrdinal | Gets the column ordinal given the name of the column.
Public method | GetSchemaTable | Returns a DataTable that describes the column metadata of the DataReader.
Public method | GetValue | (Overloaded) Gets the value of the specified column as an Object.
Public method | GetValues | Gets all values columns for the current row.
Public method | IsDBNull | (Overloaded) Gets a value that indicates whether the column contains nonexistent or missing values.
Public method | NextResult | Advances the reader to the next result when reading the results of a batch of statements.
Public method | Read | Advances the reader to the next record in a result set.
Top

Expand image See Also

Reference

DataReader Class


DataReader Properties

[image] [image] [image]

NetData Reference
DataReader Properties
DataReader Class See Also

Expand image Public Properties

 | Name | Description
Public property | FieldCount | Gets the number of columns in the current row.
Public property | HasRows | Gets a value that indicates whether this DataReader contains one or more rows
Public property | IsClosed | Gets a value indicating whether the DataReader is closed.
Public property | Item | (Overloaded) Gets the value of a specified column as an instance of Object.
Top

Expand image See Also

Reference

DataReader Class


DataReader.FieldCount Property

[image] [image] [image]

NetData Reference
DataReader.FieldCount Property
See Also

Gets the number of columns in the current row.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldCount() As Integer
C#
public int FieldCount {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.HasRows Property

[image] [image] [image]

NetData Reference
DataReader.HasRows Property
See Also

Gets a value that indicates whether this DataReader contains one or more rows
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasRows() As Boolean
C#
public bool HasRows {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.IsClosed Property

[image] [image] [image]

NetData Reference
DataReader.IsClosed Property
See Also

Gets a value indicating whether the DataReader is closed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed() As Boolean
C#
public bool IsClosed {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Item Property

[image] [image] [image]

NetData Reference
DataReader.Item Property
DataReader Class See Also

Gets the value of a specified column as an instance of Object.

Expand image Overload List

Name | Description
this[string] | Gets the value of a specified column as an instance of Object.
this[int] | Gets the value of a specified column as an instance of Object.

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader Methods

[image] [image] [image]

NetData Reference
DataReader Methods
DataReader Class See Also

Expand image Public Methods

 | Name | Description
Public method | Cancel | Attempts to cancels the execution of a reader.
Public method | Close | Closes the DataReader object.
Public method | Dispose | Releases all resources used by the objectt.
Public method | GetDataTypeName | (Overloaded) Gets name of the data type of the specified column.
Public method | GetFieldType | (Overloaded) Gets the data type of the specified column.
Public method | GetName | Gets the name of the column, given the zero-based column ordinal.
Public method | GetOrdinal | Gets the column ordinal given the name of the column.
Public method | GetSchemaTable | Returns a DataTable that describes the column metadata of the DataReader.
Public method | GetValue | (Overloaded) Gets the value of the specified column as an Object.
Public method | GetValues | Gets all values columns for the current row.
Public method | IsDBNull | (Overloaded) Gets a value that indicates whether the column contains nonexistent or missing values.
Public method | NextResult | Advances the reader to the next result when reading the results of a batch of statements.
Public method | Read | Advances the reader to the next record in a result set.
Top

Expand image See Also

Reference

DataReader Class


DataReader.Cancel Method

[image] [image] [image]

NetData Reference
DataReader.Cancel Method
See Also

Attempts to cancels the execution of a reader.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Cancel()
C#
public System.Void Cancel()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Close Method

[image] [image] [image]

NetData Reference
DataReader.Close Method
See Also

Closes the DataReader object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public System.Void Close()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Dispose Method

[image] [image] [image]

NetData Reference
DataReader.Dispose Method
See Also

Releases all resources used by the objectt.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

C#
new public System.Void Dispose()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetDataTypeName Method

[image] [image] [image]

NetData Reference
DataReader.GetDataTypeName Method
DataReader Class See Also

Gets name of the data type of the specified column.

Expand image Overload List

Name | Description
GetDataTypeName(int) | Gets name of the data type of the specified column.
GetDataTypeName(string) | Gets name of the data type of the specified column.

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetFieldType Method

[image] [image] [image]

NetData Reference
DataReader.GetFieldType Method
DataReader Class See Also

Gets the data type of the specified column.

Expand image Overload List

Name | Description
GetFieldType(int) | Gets the data type of the specified column.
GetFieldType(string) | Gets the data type of the specified column.

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetName Method

[image] [image] [image]

NetData Reference
DataReader.GetName Method
See Also

Gets the name of the column, given the zero-based column ordinal.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetName( _
   ByVal i As Integer _
) As String
C#
public string GetName(
   int i
)

Parameters

i

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetOrdinal Method

[image] [image] [image]

NetData Reference
DataReader.GetOrdinal Method
See Also

Gets the column ordinal given the name of the column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetOrdinal( _
   ByVal Name As String _
) As Integer
C#
public int GetOrdinal(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetSchemaTable Method

[image] [image] [image]

NetData Reference
DataReader.GetSchemaTable Method
See Also

Returns a DataTable that describes the column metadata of the DataReader.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSchemaTable() As DataTable
C#
public DataTable GetSchemaTable()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetValue Method

[image] [image] [image]

NetData Reference
DataReader.GetValue Method
DataReader Class See Also

Gets the value of the specified column as an Object.

Expand image Overload List

Name | Description
GetValue(int) | Gets the value of the specified column as an Object.
GetValue(string) | Gets the value of the specified column as an Object.

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetValues Method

[image] [image] [image]

NetData Reference
DataReader.GetValues Method
See Also

Gets all values columns for the current row.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValues() As Object()
C#
public object[] GetValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.IsDBNull Method

[image] [image] [image]

NetData Reference
DataReader.IsDBNull Method
DataReader Class See Also

Gets a value that indicates whether the column contains nonexistent or missing values.

Expand image Overload List

Name | Description
IsDBNull(string) | Gets a value that indicates whether the column contains nonexistent or missing values.
IsDBNull(int) | Gets a value that indicates whether the column contains nonexistent or missing values.

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.NextResult Method

[image] [image] [image]

NetData Reference
DataReader.NextResult Method
See Also

Advances the reader to the next result when reading the results of a batch of statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function NextResult() As Boolean
C#
public bool NextResult()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Read Method

[image] [image] [image]

NetData Reference
DataReader.Read Method
See Also

Advances the reader to the next record in a result set.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Read() As Boolean
C#
public bool Read()

Return Value

true if there are more rows; otherwise false.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


Field Class

[image] [image] [image]

NetData Reference
Field Class
Members

This class is used to store properties of a field
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Field
C#
public sealed class Field

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Members


Field Members

[image] [image] [image]

NetData Reference
Field Members
Field Class Constructors Methods Properties See Also

This class is used to store properties of a field

The following tables list the members exposed by the Field type.

Expand image Public Constructors

 | Name | Description
Public constructor | Field Constructor | (Overloaded) Create New Field object.
Top

Expand image Public Properties

 | Name | Description
Public property | AllowDBNull | Gets/Sets if the field accept null values.
Public property | AutoIncrement | Gets/Sets if the field is an autoincrement field.
Public property | BaseCatalog | Gets/Sets base catalog name of column
Public property | BaseName | Gets/Sets base column name
Public property | BaseSchema | Gets/Sets base schema name of column
Public property | BaseTable | Gets/Sets base table name of column
Public property | DataType | Gets/Sets the data type of field. See DataTypeEnum enumeration for more details.
Public property | DefaultValue | Gets/Sets default value for field.
Public property | DefinedSize | Gets/Sets the maximum size in bytes of a field.
Public property | FieldType | Gets System.Type of Field object.
Public property | FullDateTime | Get/Sets if Date-time value of field should also take account of the time part (not only date part)
Public property | Name | Gets the field name.
Public property | NativeType | Gets native data type.
Public property | Ordinal | Gets/Sets the Ordinal index of a field.
Public property | Precision | Gets numeric precision.
Public property | ReadOnly | Gets/Sets if the column value can be modified.
Public property | Scale | Gets numeric Scale.
Public property | Unique | If it's true, two rows of data can't have the same value in this column.
Public property | Value | Gets/Sets the current value of the field.
Top

Expand image Public Methods

 | Name | Description
Public method | ActualSize | Gets the actual size in bytes of a field value.
Public method | HasValue | Return True if a field contains a value otherwise return False.
Public method | IsNull | Gets True if value of a field is a System.DBNull or Nothing value
Public method | SetValue | Set value of field without type checking
Public method | SetValueField | Set value of field with type checking
Public method | ValueReset | (Overloaded) Reset value and status of value field.
Top

Expand image See Also

Reference

Field Class


Field Constructor

[image] [image] [image]

NetData Reference
Field Constructor
Field Class See Also

Create New Field object.

Expand image Overload List

Name | Description
Field() | Create New Field object.
Field(string) | Create New Field object.
Field(string, DataTypeEnum) | Create New Field object.
Field(string, DataTypeEnum, bool) | Create New Field object.
Field(string, DataTypeEnum, int) | Create New Field object.
Field(string, DataTypeEnum, int, bool) | Create New Field object.
Field(string, DataTypeEnum, int, bool, bool) | Create New Field object.
Field(string, DataTypeEnum, int, bool, bool, bool) | Create New Field object.

Expand image See Also

Reference

Field Class
Field Members


Field Properties

[image] [image] [image]

NetData Reference
Field Properties
Field Class See Also

Expand image Public Properties

 | Name | Description
Public property | AllowDBNull | Gets/Sets if the field accept null values.
Public property | AutoIncrement | Gets/Sets if the field is an autoincrement field.
Public property | BaseCatalog | Gets/Sets base catalog name of column
Public property | BaseName | Gets/Sets base column name
Public property | BaseSchema | Gets/Sets base schema name of column
Public property | BaseTable | Gets/Sets base table name of column
Public property | DataType | Gets/Sets the data type of field. See DataTypeEnum enumeration for more details.
Public property | DefaultValue | Gets/Sets default value for field.
Public property | DefinedSize | Gets/Sets the maximum size in bytes of a field.
Public property | FieldType | Gets System.Type of Field object.
Public property | FullDateTime | Get/Sets if Date-time value of field should also take account of the time part (not only date part)
Public property | Name | Gets the field name.
Public property | NativeType | Gets native data type.
Public property | Ordinal | Gets/Sets the Ordinal index of a field.
Public property | Precision | Gets numeric precision.
Public property | ReadOnly | Gets/Sets if the column value can be modified.
Public property | Scale | Gets numeric Scale.
Public property | Unique | If it's true, two rows of data can't have the same value in this column.
Public property | Value | Gets/Sets the current value of the field.
Top

Expand image See Also

Reference

Field Class


Field.AllowDBNull Property

[image] [image] [image]

NetData Reference
Field.AllowDBNull Property
See Also

Gets/Sets if the field accept null values.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AllowDBNull() As Boolean
C#
public bool AllowDBNull {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.AutoIncrement Property

[image] [image] [image]

NetData Reference
Field.AutoIncrement Property
See Also

Gets/Sets if the field is an autoincrement field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoIncrement() As Boolean
C#
public bool AutoIncrement {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.BaseCatalog Property

[image] [image] [image]

NetData Reference
Field.BaseCatalog Property
See Also

Gets/Sets base catalog name of column
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property BaseCatalog() As String
C#
public string BaseCatalog {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.BaseName Property

[image] [image] [image]

NetData Reference
Field.BaseName Property
See Also

Gets/Sets base column name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property BaseName() As String
C#
public string BaseName {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.BaseSchema Property

[image] [image] [image]

NetData Reference
Field.BaseSchema Property
See Also

Gets/Sets base schema name of column
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property BaseSchema() As String
C#
public string BaseSchema {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.BaseTable Property

[image] [image] [image]

NetData Reference
Field.BaseTable Property
See Also

Gets/Sets base table name of column
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property BaseTable() As String
C#
public string BaseTable {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.DataType Property

[image] [image] [image]

NetData Reference
Field.DataType Property
See Also

Gets/Sets the data type of field. See DataTypeEnum enumeration for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DataType() As DataTypeEnum
C#
public DataTypeEnum DataType {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.DefaultValue Property

[image] [image] [image]

NetData Reference
Field.DefaultValue Property
See Also

Gets/Sets default value for field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DefaultValue() As Object
C#
public object DefaultValue {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.DefinedSize Property

[image] [image] [image]

NetData Reference
Field.DefinedSize Property
See Also

Gets/Sets the maximum size in bytes of a field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DefinedSize() As Integer
C#
public int DefinedSize {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

This property can be set only for dtText or dtMemo type fields

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.FieldType Property

[image] [image] [image]

NetData Reference
Field.FieldType Property
See Also

Gets System.Type of Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldType() As Type
C#
public Type FieldType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.FullDateTime Property

[image] [image] [image]

NetData Reference
Field.FullDateTime Property
See Also

Get/Sets if Date-time value of field should also take account of the time part (not only date part)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FullDateTime() As Boolean
C#
public bool FullDateTime {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Name Property

[image] [image] [image]

NetData Reference
Field.Name Property
See Also

Gets the field name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Name() As String
C#
public string Name {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.NativeType Property

[image] [image] [image]

NetData Reference
Field.NativeType Property
See Also

Gets native data type.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property NativeType() As Integer
C#
public int NativeType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Ordinal Property

[image] [image] [image]

NetData Reference
Field.Ordinal Property
See Also

Gets/Sets the Ordinal index of a field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Ordinal() As Integer
C#
public int Ordinal {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Precision Property

[image] [image] [image]

NetData Reference
Field.Precision Property
See Also

Gets numeric precision.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision() As Integer
C#
public int Precision {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.ReadOnly Property

[image] [image] [image]

NetData Reference
Field.ReadOnly Property
See Also

Gets/Sets if the column value can be modified.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ReadOnly() As Boolean
    Get
C#
public bool ReadOnly {get;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Scale Property

[image] [image] [image]

NetData Reference
Field.Scale Property
See Also

Gets numeric Scale.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale() As Integer
C#
public int Scale {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Unique Property

[image] [image] [image]

NetData Reference
Field.Unique Property
See Also

If it's true, two rows of data can't have the same value in this column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Unique() As Boolean
C#
public bool Unique {get; set;}

Expand image Remarks

If you try to alter property value of a field associated to a SQLInsert or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.Value Property

[image] [image] [image]

NetData Reference
Field.Value Property
See Also

Gets/Sets the current value of the field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Value() As Object
C#
public object Value {get; set;}

Expand image Remarks

If you try to sets value of this property in a field with ReadOnly property sets to True an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Methods

[image] [image] [image]

NetData Reference
Field Methods
Field Class See Also

Expand image Public Methods

 | Name | Description
Public method | ActualSize | Gets the actual size in bytes of a field value.
Public method | HasValue | Return True if a field contains a value otherwise return False.
Public method | IsNull | Gets True if value of a field is a System.DBNull or Nothing value
Public method | SetValue | Set value of field without type checking
Public method | SetValueField | Set value of field with type checking
Public method | ValueReset | (Overloaded) Reset value and status of value field.
Top

Expand image See Also

Reference

Field Class


Field.ActualSize Method

[image] [image] [image]

NetData Reference
Field.ActualSize Method
See Also

Gets the actual size in bytes of a field value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ActualSize() As Integer
C#
public int ActualSize()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.HasValue Method

[image] [image] [image]

NetData Reference
Field.HasValue Method
See Also

Return True if a field contains a value otherwise return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function HasValue() As Boolean
C#
public bool HasValue()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.IsNull Method

[image] [image] [image]

NetData Reference
Field.IsNull Method
See Also

Gets True if value of a field is a System.DBNull or Nothing value
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IsNull() As Boolean
C#
public bool IsNull()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.SetValue Method

[image] [image] [image]

NetData Reference
Field.SetValue Method
See Also

Set value of field without type checking
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetValue( _
   ByVal oValue As Object _
)
C#
public System.Void SetValue(
   object oValue
)

Parameters

oValue

Type: object

Value of field

Expand image Remarks

If you try to sets value of this property in a field with ReadOnly property sets to True an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.SetValueField Method

[image] [image] [image]

NetData Reference
Field.SetValueField Method
See Also

Set value of field with type checking
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetValueField( _
   ByVal oValue As Object _
)
C#
public System.Void SetValueField(
   object oValue
)

Parameters

oValue

Type: object

Value of field

Expand image Remarks

If you try to sets value of this property in a field with ReadOnly property sets to True an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.ValueReset Method

[image] [image] [image]

NetData Reference
Field.ValueReset Method
Field Class See Also

Reset value and status of value field.

Expand image Overload List

Name | Description
ValueReset() | Reset value and status of value field.
ValueReset(bool) | Reset value and status of value field.

Expand image See Also

Reference

Field Class
Field Members


Fields Class

[image] [image] [image]

NetData Reference
Fields Class
Members

Fields is a collection object of Field objects used to store properties and values of fields
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Fields
C#
public sealed class Fields

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Fields

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Members


Fields Members

[image] [image] [image]

NetData Reference
Fields Members
Fields Class Constructors Methods Properties See Also

Fields is a collection object of Field objects used to store properties and values of fields

The following tables list the members exposed by the Fields type.

Expand image Public Constructors

 | Name | Description
Public constructor | Fields Constructor | Create a new instance of the object
Top

Expand image Public Properties

 | Name | Description
Public property | Count | Gets the total number of fields in then current collection.
Public property | Item | (Overloaded) This is the default readonly property for accessing Field objects stored in the collection.
Public property | ReadOnly | Gets if fields collection is read only (can't add or remove fields).
Top

Expand image Public Methods

 | Name | Description
Public method | Add | Add a new field to the collection
Public method | Clear | This method clear the collection and release all Field
Public method | CopyFrom | Copy all values of fields from current position of specified Recordset object
Public method | Exist | Check if a field is already in the collection
Public method | GetEnumerator | Implementation to support of enumeration
Public method | HasValues | Return True if at least one field has a value assigned, else return False.
Public method | IndexOf | Return the Index associated to specified field name otherwise -1 if not found.
Public method | Remove | (Overloaded) Remove a field from the collection
Top

Expand image See Also

Reference

Fields Class


Fields Constructor

[image] [image] [image]

NetData Reference
Fields Constructor
See Also

Create a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Fields()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields Properties

[image] [image] [image]

NetData Reference
Fields Properties
Fields Class See Also

Expand image Public Properties

 | Name | Description
Public property | Count | Gets the total number of fields in then current collection.
Public property | Item | (Overloaded) This is the default readonly property for accessing Field objects stored in the collection.
Public property | ReadOnly | Gets if fields collection is read only (can't add or remove fields).
Top

Expand image See Also

Reference

Fields Class


Fields.Count Property

[image] [image] [image]

NetData Reference
Fields.Count Property
See Also

Gets the total number of fields in then current collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count() As Integer
C#
public int Count {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Item Property

[image] [image] [image]

NetData Reference
Fields.Item Property
Fields Class See Also

This is the default readonly property for accessing Field objects stored in the collection.

Expand image Overload List

Name | Description
this[int] | This is the default readonly property for accessing Field objects stored in the collection.
this[string] | This is the default readonly property for accessing Field objects stored in the collection.

Expand image See Also

Reference

Fields Class
Fields Members


Fields.ReadOnly Property

[image] [image] [image]

NetData Reference
Fields.ReadOnly Property
See Also

Gets if fields collection is read only (can't add or remove fields).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadOnly() As Boolean
C#
public bool ReadOnly {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields Methods

[image] [image] [image]

NetData Reference
Fields Methods
Fields Class See Also

Expand image Public Methods

 | Name | Description
Public method | Add | Add a new field to the collection
Public method | Clear | This method clear the collection and release all Field
Public method | CopyFrom | Copy all values of fields from current position of specified Recordset object
Public method | Exist | Check if a field is already in the collection
Public method | GetEnumerator | Implementation to support of enumeration
Public method | HasValues | Return True if at least one field has a value assigned, else return False.
Public method | IndexOf | Return the Index associated to specified field name otherwise -1 if not found.
Public method | Remove | (Overloaded) Remove a field from the collection
Top

Expand image See Also

Reference

Fields Class


Fields.Add Method

[image] [image] [image]

NetData Reference
Fields.Add Method
See Also

Add a new field to the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal oField As Field _
)
C#
public System.Void Add(
   Field oField
)

Parameters

oField

Type: Field

A field object

Expand image Remarks

If you try to Add a field to a collection associated to a Recordset, SQLSelect or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Clear Method

[image] [image] [image]

NetData Reference
Fields.Clear Method
See Also

This method clear the collection and release all Field
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public System.Void Clear()

Expand image Remarks

If you try to call RemoveAll of a Fields collection in a Recordset, SQLSelect or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.CopyFrom Method

[image] [image] [image]

NetData Reference
Fields.CopyFrom Method
See Also

Copy all values of fields from current position of specified Recordset object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal oRecordset As Recordset _
)
C#
public System.Void CopyFrom(
   Recordset oRecordset
)

Parameters

oRecordset

Type: Recordset

A valid Recordset object object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Exist Method

[image] [image] [image]

NetData Reference
Fields.Exist Method
See Also

Check if a field is already in the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Exist( _
   ByVal Name As String _
) As Boolean
C#
public bool Exist(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.GetEnumerator Method

[image] [image] [image]

NetData Reference
Fields.GetEnumerator Method
See Also

Implementation to support of enumeration
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
C#
new public IEnumerator GetEnumerator()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.HasValues Method

[image] [image] [image]

NetData Reference
Fields.HasValues Method
See Also

Return True if at least one field has a value assigned, else return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function HasValues() As Boolean
C#
public bool HasValues()

Expand image Remarks

AutoIncrement and ReadOnly Fields are ignored by this function.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.IndexOf Method

[image] [image] [image]

NetData Reference
Fields.IndexOf Method
See Also

Return the Index associated to specified field name otherwise -1 if not found.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal Name As String _
) As Integer
C#
public int IndexOf(
   string Name
)

Parameters

Name

Type: string

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Remove Method

[image] [image] [image]

NetData Reference
Fields.Remove Method
Fields Class See Also

Remove a field from the collection

Expand image Overload List

Name | Description
Remove(int) | Remove a field from the collection
Remove(string) | Remove a field from the collection

Expand image See Also

Reference

Fields Class
Fields Members


License Class

[image] [image] [image]

NetData Reference
License Class
Members

License class holds licenses informations data.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class License
C#
public sealed class License

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.License

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

License Members


License Members

[image] [image] [image]

NetData Reference
License Members
License Class Properties See Also

License class holds licenses informations data.

The following tables list the members exposed by the License type.

Expand image Public Properties

Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License Properties

[image] [image] [image]

NetData Reference
License Properties
License Class See Also

Expand image Public Properties

Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License.LicenseKey Property

[image] [image] [image]

NetData Reference
License.LicenseKey Property
See Also

Gets/Sets the license key for the product
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseKey() As String
C#
public static string LicenseKey {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

License Class
License Members


License.LicenseName Property

[image] [image] [image]

NetData Reference
License.LicenseName Property
See Also

Gets/Sets the license company name for the product
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseName() As String
C#
public static string LicenseName {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

License Class
License Members


License.LicenseUser Property

[image] [image] [image]

NetData Reference
License.LicenseUser Property
See Also

Gets/Sets the license user name (usually and email address) for the product
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseUser() As String
C#
public static string LicenseUser {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

License Class
License Members


Localize Class

[image] [image] [image]

NetData Reference
Localize Class
Members

This class provide shared localization string for Softgroup .Net Data Objects
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Localize
C#
public sealed class Localize

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Localize

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Localize Members


Parameter Class

[image] [image] [image]

NetData Reference
Parameter Class
Members

The Parameter object provides information about a single parameter used in a stored procedure or query of Command.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameter
C#
public sealed class Parameter

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Members


Parameter Members

[image] [image] [image]

NetData Reference
Parameter Members
Parameter Class Properties See Also

The Parameter object provides information about a single parameter used in a stored procedure or query of Command.

The following tables list the members exposed by the Parameter type.

Expand image Public Properties

 | Name | Description
Public property | DbType | Gets the DbType of the parameter.
Public property | Direction | Gets a value that indicates whether the parameter is input-only, output-only, bidirectional, or a stored procedure return value parameter.
Public property | Name | Gets the name of the Parameter.
Public property | Size | Gets the maximum size, in bytes, of the data within the column.
Public property | Value | Gets the value of the parameter.
Top

Expand image See Also

Reference

Parameter Class


Parameter Properties

[image] [image] [image]

NetData Reference
Parameter Properties
Parameter Class See Also

Expand image Public Properties

 | Name | Description
Public property | DbType | Gets the DbType of the parameter.
Public property | Direction | Gets a value that indicates whether the parameter is input-only, output-only, bidirectional, or a stored procedure return value parameter.
Public property | Name | Gets the name of the Parameter.
Public property | Size | Gets the maximum size, in bytes, of the data within the column.
Public property | Value | Gets the value of the parameter.
Top

Expand image See Also

Reference

Parameter Class


Parameter.DbType Property

[image] [image] [image]

NetData Reference
Parameter.DbType Property
See Also

Gets the DbType of the parameter.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbType() As DbType
C#
public DbType DbType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Class
Parameter Members


Parameter.Direction Property

[image] [image] [image]

NetData Reference
Parameter.Direction Property
See Also

Gets a value that indicates whether the parameter is input-only, output-only, bidirectional, or a stored procedure return value parameter.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Direction() As ParameterDirection
C#
public ParameterDirection Direction {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Class
Parameter Members


Parameter.Name Property

[image] [image] [image]

NetData Reference
Parameter.Name Property
See Also

Gets the name of the Parameter.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name() As String
C#
public string Name {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Class
Parameter Members


Parameter.Size Property

[image] [image] [image]

NetData Reference
Parameter.Size Property
See Also

Gets the maximum size, in bytes, of the data within the column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size() As Integer
C#
public int Size {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Class
Parameter Members


Parameter.Value Property

[image] [image] [image]

NetData Reference
Parameter.Value Property
See Also

Gets the value of the parameter.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value() As Object
C#
public object Value {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameter Class
Parameter Members


Parameters Class

[image] [image] [image]

NetData Reference
Parameters Class
Members

The Parameters Collection is a collection of the Parameter objects associated with a specific Command object. Each Parameter object provides detailed information about a single parameter used in a stored procedure or a parameterized query.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Parameters
C#
public sealed class Parameters

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Members


Parameters Members

[image] [image] [image]

NetData Reference
Parameters Members
Parameters Class Methods Properties See Also

The Parameters Collection is a collection of the Parameter objects associated with a specific Command object. Each Parameter object provides detailed information about a single parameter used in a stored procedure or a parameterized query.

The following tables list the members exposed by the Parameters type.

Expand image Public Properties

 | Name | Description
Public property | Count | Gets a the total numer of parameters
Public property | Item | (Overloaded) Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by index
Public property | Parameter | (Overloaded) Gets the underline Parameter object of Command by name
Top

Expand image Public Methods

 | Name | Description
Public method | Add | (Overloaded) Adds a Parameter item to the Parameters collection.
Public method | Clear | Removes all Parameter values from the Parameter collection.
Public method | Refresh | The Refresh method updates the Parameter objects in the Parameters Collection with the latest information from the provider (used only by ADO providers and ingored for .Net Providers)
Public method | Remove | (Overloaded) Removes the specified Parameter by index.
Top

Expand image See Also

Reference

Parameters Class


Parameters Properties

[image] [image] [image]

NetData Reference
Parameters Properties
Parameters Class See Also

Expand image Public Properties

 | Name | Description
Public property | Count | Gets a the total numer of parameters
Public property | Item | (Overloaded) Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by index
Public property | Parameter | (Overloaded) Gets the underline Parameter object of Command by name
Top

Expand image See Also

Reference

Parameters Class


Parameters.Count Property

[image] [image] [image]

NetData Reference
Parameters.Count Property
See Also

Gets a the total numer of parameters
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count() As Integer
C#
public int Count {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Item Property

[image] [image] [image]

NetData Reference
Parameters.Item Property
Parameters Class See Also

Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by index

Expand image Overload List

Name | Description
this[int] | Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by index
this[string] | Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by name

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Parameter Property

[image] [image] [image]

NetData Reference
Parameters.Parameter Property
Parameters Class See Also

Gets the underline Parameter object of Command by name

Expand image Overload List

Name | Description
this[int] | Gets the underline Parameter object of Command by index
this[string] | Gets the underline Parameter object of Command by name

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters Methods

[image] [image] [image]

NetData Reference
Parameters Methods
Parameters Class See Also

Expand image Public Methods

 | Name | Description
Public method | Add | (Overloaded) Adds a Parameter item to the Parameters collection.
Public method | Clear | Removes all Parameter values from the Parameter collection.
Public method | Refresh | The Refresh method updates the Parameter objects in the Parameters Collection with the latest information from the provider (used only by ADO providers and ingored for .Net Providers)
Public method | Remove | (Overloaded) Removes the specified Parameter by index.
Top

Expand image See Also

Reference

Parameters Class


Parameters.Add Method

[image] [image] [image]

NetData Reference
Parameters.Add Method
Parameters Class See Also

Adds a Parameter item to the Parameters collection.

Expand image Overload List

Name | Description
Add(string, ParameterDirection, DbType) | Add a new parameter object
Add(string, ParameterDirection, DbType, object) | Add a new parameter object
Add(string, ParameterDirection, DbType, object, int) | Add a new parameter object
Add(object) | Adds a Parameter item to the Parameters collection.

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Clear Method

[image] [image] [image]

NetData Reference
Parameters.Clear Method
See Also

Removes all Parameter values from the Parameter collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Overloads Sub Clear()
C#
public System.Void Clear()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Refresh Method

[image] [image] [image]

NetData Reference
Parameters.Refresh Method
See Also

The Refresh method updates the Parameter objects in the Parameters Collection with the latest information from the provider (used only by ADO providers and ingored for .Net Providers)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public System.Void Refresh()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Remove Method

[image] [image] [image]

NetData Reference
Parameters.Remove Method
Parameters Class See Also

Removes the specified Parameter by index.

Expand image Overload List

Name | Description
Remove(int) | Removes the specified Parameter by index.
Remove(string) | Removes the specified Parameter by name.

Expand image See Also

Reference

Parameters Class
Parameters Members


Recordset Class

[image] [image] [image]

NetData Reference
Recordset Class
Members

A Recordset object represents the entire set of records as the results of a SQL SELECT command.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class Recordset
C#
public sealed class Recordset

Expand image Remarks

At any time, the Recordset object only refers to a single record within the set as the current record.

Softgroup.Recordset is the easy way to convert your VB6 projects that uses ADO Recordset to .NET projects.

Unlike Micorosft ADO Recordset object Softgroup NetData Recorset objects does not support insert, update or delete of records.

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.Recordset

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Members


Recordset Members

[image] [image] [image]

NetData Reference
Recordset Members
Recordset Class Constructors Events Methods Properties See Also

A Recordset object represents the entire set of records as the results of a SQL SELECT command.

The following tables list the members exposed by the Recordset type.

Expand image Public Constructors

 | Name | Description
Public constructor | Recordset Constructor | (Overloaded) Create a new instance of a recordset from specified DataTable object.
Top

Expand image Public Properties

 | Name | Description
Public property | AsyncFetch | Gets if an asynchronous fetch is used to retrieve data.
Public property | BOF | The BOF property returns True if the current record position is before the first record and False if the current record position is on or after the first record.
Public property | ClientCursors | Gets if Recordset is opened using client-side cursors
Public property | Completed | Gets if Recordset object has finished to fetch data from source.
Public property | Connection | Gets the Connection object used by recordset.
Public property | Disposed | Return True if Close or Dispose method has been already called.
Public property | EOF | The EOF property returns True if the current record position is after the last record and False if the current record position is on or before the last record.
Public property | FetchReport | Gets if FetchProgress and FetchCompleted event will be generated during an asynchronous fetch.
Public property | Filter | Gets/Sets the string expression used to filter recordset data.
Public property | Position | Get the current index record position or -1 if not supported
Public property | RecordCount | Return the number of rows contained in the recordset.
Public property | RecordLoaded | Return the number of rows currently loaded in the recordset where server side cursor or asynchronous fetch is enabled.
Public property | Sort | Gets/Sets the names of the fields in the Recordset that must be sorted. Each name must be separated by a delimiter comma.
Public property | Source | Gets the sql statement used to open recordset.
Public property | UseADO | Gets Recordset is using Microsoft ADO objects
Public property | Value | (Overloaded) Gets the value of specified field in the current record position
Top

Expand image Public Methods

 | Name | Description
Public method | Close | Close the Recordset.
Public method | CompareDate | (Overloaded) Compare current date value of field with specified value and return a CompareTypeEnum constant
Public method | CompareTime | (Overloaded) Compare current time value of field with specified value and return a CompareTypeEnum constant
Public method | CopyTo | Copy all values of fields in the recordset at the current position into specified Fields collection
Public method | DataSource | Get the Data Source: can be a System.Data.DataTable or ADODB.Recordset object.
Public method | Dispose | Free resources allocated by the object and close recordset
Public method | FieldActualSize | (Overloaded) Gets the actual size in bytes of a field value.
Public method | FieldAllowDBNull | (Overloaded) Gets if the field accept null values.
Public method | FieldAutoIncrement | (Overloaded) Gets if the field is an autoincrement field.
Public method | FieldDefinedSize | (Overloaded) Gets the maximum size in bytes of a field.
Public method | FieldExist | Gets True if specified field exists in fields collection
Public method | FieldName | Gets the field name.
Public method | FieldOrdinal | Gets the ordinal index of a field.
Public method | FieldReadOnly | (Overloaded) Gets if column data can be written.
Public method | FieldType | (Overloaded) Gets the data type of field. See DataTypeEnum enumeration for more details.
Public method | FieldUnique | (Overloaded) If it's true two rows of data can't have the same value in this column.
Public method | FieldValueType | (Overloaded) Gets System.Type of field object.
Public method | FieldsCount | Gets the total number of fields in recordset.
Public method | Find | (Overloaded) The Find method searches for a record in the Recordset that match specified criteria staring from first. If the search is successful, the record Position will point to the first found record.
Public method | GetAllValues | Gets a list of all values for current record
Public method | GetBoolean | (Overloaded) Gets a Boolean value of specified field for the current record
Public method | GetByte | (Overloaded) Gets a Byte value of specified field for the current record
Public method | GetBytes | (Overloaded) Gets a Byte array values of specified field for the current record
Public method | GetChar | (Overloaded) Gets a Char value of specified field for the current record
Public method | GetChars | (Overloaded) Gets a Char array values of specified field for the current record
Public method | GetDate | (Overloaded) Gets a Date value of specified field for the current record
Public method | GetDateText | (Overloaded) Gets the string value of a DateTime field type in the system date short format for the current record.
Public method | GetDateTimeText | (Overloaded) Gets the string value of a DateTime field type in the system datetime short format for the current record.
Public method | GetDecimal | (Overloaded) Gets a Decimal value of specified field for the current record
Public method | GetDouble | (Overloaded) Gets a Double value of specified field for the current record
Public method | GetFieldsValues | (Overloaded) Return a FieldsValues object from this recordset
Public method | GetGuid | (Overloaded) Gets a Guid value of specified field for the current record
Public method | GetInteger | (Overloaded) Gets a Integer value of specified field for the current record
Public method | GetLong | (Overloaded) Gets a Long value of specified field for the current record
Public method | GetRecordString | Return s string of data rappresenting record values separated by specified char
Public method | GetShort | (Overloaded) Gets a Short value of specified field for the current record
Public method | GetSingle | (Overloaded) Gets a Single value of specified field for the current record
Public method | GetString | (Overloaded) Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Public method | GetText | (Overloaded) Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Public method | GetTime | (Overloaded) Gets a TimeSpan value of specified field for the current record
Public method | GetTimeText | (Overloaded) Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
Public method | GetValue | (Overloaded) Gets the value of specified field in the current record position
Public method | GetValues | (Overloaded) Gets an array of all values for the current record position
Public method | IsValid | Returns True if Recordset is opened and both BOF and EOF properties are False
Public method | MaxRecords | Gets maximum number of records returned from the recordset. This value is the same used as parameter on Open method.
Public method | MoveFirst | Move current record at the beginning of recordset.
Public method | MoveLast | Move current record at the end of recordset.
Public method | MoveNext | Move current record to the next record in recordset.
Public method | MovePrevious | Move current record to the previous record in recordset.
Public method | Open | (Overloaded) Open the recordset from a DataTable object.
Public method | PercentPosition | Return the percent position of current record in a Recordsets object or -1 if not supported.
Public method | State | Gest the current state of recordset. See StateEnum for more details.
Public method | ValueIsNull | (Overloaded) Return True if value of a field is Null value
Top

Expand image Public Events

 | Name | Description
Public event | Closed | This event will be generated if recordset was closed.
Public event | FetchCompleted | This event will be generated after an asynchronous fetch is completed and report the total number of records loaded from data source.
Public event | FetchProgress | This event will be generated during an asynchronous fetch and report the total number of records currently loaded from data source.
Public event | Filtered | This event will be generated every time Filter method was invoked.
Public event | MoveComplete | This event will be generated every time current record position change
Public event | Opened | This event will be generated every time Open or Requery method was invoked.
Public event | Sorted | This event will be generated every time Sort method was invoked.
Top

Expand image See Also

Reference

Recordset Class


Recordset Constructor

[image] [image] [image]

NetData Reference
Recordset Constructor
Recordset Class See Also

Create a new instance of a recordset from specified DataTable object.

Expand image Overload List

Name | Description
Recordset(Connection) | Create a new instance of a Recordset object.
Recordset(Connection, string) | Create a new instance of the class and open the recordset (see Open method for more details).
Recordset(Connection, string, bool) | Create a new instance of the class and open the recordset (see Open method for more details).
Recordset(Connection, string, bool, int) | Create a new instance of the class and open the recordset (see Open method for more details).
Recordset(Connection, string, bool, int, bool, int) | Create a new instance of the class and open the recordset (see Open method for more details).
Recordset(Connection, string, bool, int, bool, int, bool) | Create a new instance of the class and open the recordset (see Open method for more details).
Recordset(DataTable) | Create a new instance of a recordset from specified DataTable object.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Properties

[image] [image] [image]

NetData Reference
Recordset Properties
Recordset Class See Also

Expand image Public Properties

 | Name | Description
Public property | AsyncFetch | Gets if an asynchronous fetch is used to retrieve data.
Public property | BOF | The BOF property returns True if the current record position is before the first record and False if the current record position is on or after the first record.
Public property | ClientCursors | Gets if Recordset is opened using client-side cursors
Public property | Completed | Gets if Recordset object has finished to fetch data from source.
Public property | Connection | Gets the Connection object used by recordset.
Public property | Disposed | Return True if Close or Dispose method has been already called.
Public property | EOF | The EOF property returns True if the current record position is after the last record and False if the current record position is on or before the last record.
Public property | FetchReport | Gets if FetchProgress and FetchCompleted event will be generated during an asynchronous fetch.
Public property | Filter | Gets/Sets the string expression used to filter recordset data.
Public property | Position | Get the current index record position or -1 if not supported
Public property | RecordCount | Return the number of rows contained in the recordset.
Public property | RecordLoaded | Return the number of rows currently loaded in the recordset where server side cursor or asynchronous fetch is enabled.
Public property | Sort | Gets/Sets the names of the fields in the Recordset that must be sorted. Each name must be separated by a delimiter comma.
Public property | Source | Gets the sql statement used to open recordset.
Public property | UseADO | Gets Recordset is using Microsoft ADO objects
Public property | Value | (Overloaded) Gets the value of specified field in the current record position
Top

Expand image See Also

Reference

Recordset Class


Recordset.AsyncFetch Property

[image] [image] [image]

NetData Reference
Recordset.AsyncFetch Property
See Also

Gets if an asynchronous fetch is used to retrieve data.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property AsyncFetch() As Boolean
C#
public bool AsyncFetch {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.BOF Property

[image] [image] [image]

NetData Reference
Recordset.BOF Property
See Also

The BOF property returns True if the current record position is before the first record and False if the current record position is on or after the first record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property BOF() As Boolean
C#
public bool BOF {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.ClientCursors Property

[image] [image] [image]

NetData Reference
Recordset.ClientCursors Property
See Also

Gets if Recordset is opened using client-side cursors
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientCursors() As Boolean
C#
public bool ClientCursors {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Completed Property

[image] [image] [image]

NetData Reference
Recordset.Completed Property
See Also

Gets if Recordset object has finished to fetch data from source.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Completed() As Boolean
C#
public bool Completed {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Connection Property

[image] [image] [image]

NetData Reference
Recordset.Connection Property
See Also

Gets the Connection object used by recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connection() As Connection
C#
public Connection Connection {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Disposed Property

[image] [image] [image]

NetData Reference
Recordset.Disposed Property
See Also

Return True if Close or Dispose method has been already called.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Disposed() As Boolean
C#
public bool Disposed {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.EOF Property

[image] [image] [image]

NetData Reference
Recordset.EOF Property
See Also

The EOF property returns True if the current record position is after the last record and False if the current record position is on or before the last record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property EOF() As Boolean
C#
public bool EOF {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FetchReport Property

[image] [image] [image]

NetData Reference
Recordset.FetchReport Property
See Also

Gets if FetchProgress and FetchCompleted event will be generated during an asynchronous fetch.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FetchReport() As Boolean
C#
public bool FetchReport {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Filter Property

[image] [image] [image]

NetData Reference
Recordset.Filter Property
See Also

Gets/Sets the string expression used to filter recordset data.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Filter() As String
C#
public string Filter {get; set;}

Expand image Remarks

In order to use Filter property ClientCursors and Completed property of a Recordset object must return True.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Position Property

[image] [image] [image]

NetData Reference
Recordset.Position Property
See Also

Get the current index record position or -1 if not supported
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Position() As Integer
C#
public int Position {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.RecordCount Property

[image] [image] [image]

NetData Reference
Recordset.RecordCount Property
See Also

Return the number of rows contained in the recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordCount() As Integer
C#
public int RecordCount {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.RecordLoaded Property

[image] [image] [image]

NetData Reference
Recordset.RecordLoaded Property
See Also

Return the number of rows currently loaded in the recordset where server side cursor or asynchronous fetch is enabled.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordLoaded() As Integer
C#
public int RecordLoaded {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Sort Property

[image] [image] [image]

NetData Reference
Recordset.Sort Property
See Also

Gets/Sets the names of the fields in the Recordset that must be sorted. Each name must be separated by a delimiter comma.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Sort() As String
C#
public string Sort {get; set;}

Expand image Remarks

In order to use Sort property ClientCursors and Completed property of a Recordset object must return True.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Source Property

[image] [image] [image]

NetData Reference
Recordset.Source Property
See Also

Gets the sql statement used to open recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source() As String
C#
public string Source {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.UseADO Property

[image] [image] [image]

NetData Reference
Recordset.UseADO Property
See Also

Gets Recordset is using Microsoft ADO objects
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property UseADO() As Boolean
C#
public bool UseADO {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Value Property

[image] [image] [image]

NetData Reference
Recordset.Value Property
Recordset Class See Also

Gets the value of specified field in the current record position

Expand image Overload List

Name | Description
this[int] | Gets the value of specified field in the current record position
this[string] | Gets the value of specified field in the current record position
this[int, int] | Gets the value of specified field in the specified record position
this[int, string] | Gets the value of specified field in the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Methods

[image] [image] [image]

NetData Reference
Recordset Methods
Recordset Class See Also

Expand image Public Methods

 | Name | Description
Public method | Close | Close the Recordset.
Public method | CompareDate | (Overloaded) Compare current date value of field with specified value and return a CompareTypeEnum constant
Public method | CompareTime | (Overloaded) Compare current time value of field with specified value and return a CompareTypeEnum constant
Public method | CopyTo | Copy all values of fields in the recordset at the current position into specified Fields collection
Public method | DataSource | Get the Data Source: can be a System.Data.DataTable or ADODB.Recordset object.
Public method | Dispose | Free resources allocated by the object and close recordset
Public method | FieldActualSize | (Overloaded) Gets the actual size in bytes of a field value.
Public method | FieldAllowDBNull | (Overloaded) Gets if the field accept null values.
Public method | FieldAutoIncrement | (Overloaded) Gets if the field is an autoincrement field.
Public method | FieldDefinedSize | (Overloaded) Gets the maximum size in bytes of a field.
Public method | FieldExist | Gets True if specified field exists in fields collection
Public method | FieldName | Gets the field name.
Public method | FieldOrdinal | Gets the ordinal index of a field.
Public method | FieldReadOnly | (Overloaded) Gets if column data can be written.
Public method | FieldType | (Overloaded) Gets the data type of field. See DataTypeEnum enumeration for more details.
Public method | FieldUnique | (Overloaded) If it's true two rows of data can't have the same value in this column.
Public method | FieldValueType | (Overloaded) Gets System.Type of field object.
Public method | FieldsCount | Gets the total number of fields in recordset.
Public method | Find | (Overloaded) The Find method searches for a record in the Recordset that match specified criteria staring from first. If the search is successful, the record Position will point to the first found record.
Public method | GetAllValues | Gets a list of all values for current record
Public method | GetBoolean | (Overloaded) Gets a Boolean value of specified field for the current record
Public method | GetByte | (Overloaded) Gets a Byte value of specified field for the current record
Public method | GetBytes | (Overloaded) Gets a Byte array values of specified field for the current record
Public method | GetChar | (Overloaded) Gets a Char value of specified field for the current record
Public method | GetChars | (Overloaded) Gets a Char array values of specified field for the current record
Public method | GetDate | (Overloaded) Gets a Date value of specified field for the current record
Public method | GetDateText | (Overloaded) Gets the string value of a DateTime field type in the system date short format for the current record.
Public method | GetDateTimeText | (Overloaded) Gets the string value of a DateTime field type in the system datetime short format for the current record.
Public method | GetDecimal | (Overloaded) Gets a Decimal value of specified field for the current record
Public method | GetDouble | (Overloaded) Gets a Double value of specified field for the current record
Public method | GetFieldsValues | (Overloaded) Return a FieldsValues object from this recordset
Public method | GetGuid | (Overloaded) Gets a Guid value of specified field for the current record
Public method | GetInteger | (Overloaded) Gets a Integer value of specified field for the current record
Public method | GetLong | (Overloaded) Gets a Long value of specified field for the current record
Public method | GetRecordString | Return s string of data rappresenting record values separated by specified char
Public method | GetShort | (Overloaded) Gets a Short value of specified field for the current record
Public method | GetSingle | (Overloaded) Gets a Single value of specified field for the current record
Public method | GetString | (Overloaded) Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Public method | GetText | (Overloaded) Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Public method | GetTime | (Overloaded) Gets a TimeSpan value of specified field for the current record
Public method | GetTimeText | (Overloaded) Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
Public method | GetValue | (Overloaded) Gets the value of specified field in the current record position
Public method | GetValues | (Overloaded) Gets an array of all values for the current record position
Public method | IsValid | Returns True if Recordset is opened and both BOF and EOF properties are False
Public method | MaxRecords | Gets maximum number of records returned from the recordset. This value is the same used as parameter on Open method.
Public method | MoveFirst | Move current record at the beginning of recordset.
Public method | MoveLast | Move current record at the end of recordset.
Public method | MoveNext | Move current record to the next record in recordset.
Public method | MovePrevious | Move current record to the previous record in recordset.
Public method | Open | (Overloaded) Open the recordset from a DataTable object.
Public method | PercentPosition | Return the percent position of current record in a Recordsets object or -1 if not supported.
Public method | State | Gest the current state of recordset. See StateEnum for more details.
Public method | ValueIsNull | (Overloaded) Return True if value of a field is Null value
Top

Expand image See Also

Reference

Recordset Class


Recordset.Close Method

[image] [image] [image]

NetData Reference
Recordset.Close Method
See Also

Close the Recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public System.Void Close()

Expand image Remarks

While a Recordset object is closed, calling any methods other than Open method generate an error.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareDate Method

[image] [image] [image]

NetData Reference
Recordset.CompareDate Method
Recordset Class See Also

Compare current date value of field with specified value and return a CompareTypeEnum constant

Expand image Overload List

Name | Description
CompareDate(int, object) | Compare current date value of field with specified value and return a CompareTypeEnum constant
CompareDate(string, object) | Compare current date value of field with specified value and return a CompareTypeEnum constant

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareTime Method

[image] [image] [image]

NetData Reference
Recordset.CompareTime Method
Recordset Class See Also

Compare current time value of field with specified value and return a CompareTypeEnum constant

Expand image Overload List

Name | Description
CompareTime(int, object) | Compare current time value of field with specified value and return a CompareTypeEnum constant
CompareTime(string, object) | Compare current time value of field with specified value and return a CompareTypeEnum constant

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CopyTo Method

[image] [image] [image]

NetData Reference
Recordset.CopyTo Method
See Also

Copy all values of fields in the recordset at the current position into specified Fields collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal oFields As Fields _
)
C#
public System.Void CopyTo(
   Fields oFields
)

Parameters

oFields

Type: Fields

Fields collection where values will be copied

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.DataSource Method

[image] [image] [image]

NetData Reference
Recordset.DataSource Method
See Also

Get the Data Source: can be a System.Data.DataTable or ADODB.Recordset object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataSource() As Object
C#
public object DataSource()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Dispose Method

[image] [image] [image]

NetData Reference
Recordset.Dispose Method
See Also

Free resources allocated by the object and close recordset
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

C#
new public System.Void Dispose()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldActualSize Method

[image] [image] [image]

NetData Reference
Recordset.FieldActualSize Method
Recordset Class See Also

Gets the actual size in bytes of a field value.

Expand image Overload List

Name | Description
FieldActualSize(int) | Gets the actual size in bytes of a field value.
FieldActualSize(string) | Gets the actual size in bytes of a field value.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldAllowDBNull Method

[image] [image] [image]

NetData Reference
Recordset.FieldAllowDBNull Method
Recordset Class See Also

Gets if the field accept null values.

Expand image Overload List

Name | Description
FieldAllowDBNull(int) | Gets if the field accept null values.
FieldAllowDBNull(string) | Gets if the field accept null values.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldAutoIncrement Method

[image] [image] [image]

NetData Reference
Recordset.FieldAutoIncrement Method
Recordset Class See Also

Gets if the field is an autoincrement field.

Expand image Overload List

Name | Description
FieldAutoIncrement(int) | Gets if the field is an autoincrement field.
FieldAutoIncrement(string) | Gets if the field is an autoincrement field.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldDefinedSize Method

[image] [image] [image]

NetData Reference
Recordset.FieldDefinedSize Method
Recordset Class See Also

Gets the maximum size in bytes of a field.

Expand image Overload List

Name | Description
FieldDefinedSize(int) | Gets the maximum size in bytes of a field.
FieldDefinedSize(string) | Gets the maximum size in bytes of a field.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldExist Method

[image] [image] [image]

NetData Reference
Recordset.FieldExist Method
See Also

Gets True if specified field exists in fields collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldExist( _
   ByVal Name As String _
) As Boolean
C#
public bool FieldExist(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldName Method

[image] [image] [image]

NetData Reference
Recordset.FieldName Method
See Also

Gets the field name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldName( _
   ByVal Index As Integer _
) As String
C#
public string FieldName(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldOrdinal Method

[image] [image] [image]

NetData Reference
Recordset.FieldOrdinal Method
See Also

Gets the ordinal index of a field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldOrdinal( _
   ByVal Name As String _
) As Integer
C#
public int FieldOrdinal(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldReadOnly Method

[image] [image] [image]

NetData Reference
Recordset.FieldReadOnly Method
Recordset Class See Also

Gets if column data can be written.

Expand image Overload List

Name | Description
FieldReadOnly(int) | Gets if column data can be written.
FieldReadOnly(string) | Gets if column data can be written.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldType Method

[image] [image] [image]

NetData Reference
Recordset.FieldType Method
Recordset Class See Also

Gets the data type of field. See DataTypeEnum enumeration for more details.

Expand image Overload List

Name | Description
FieldType(int) | Gets the data type of field. See DataTypeEnum enumeration for more details.
FieldType(string) | Gets the data type of field. See DataTypeEnum enumeration for more details.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldUnique Method

[image] [image] [image]

NetData Reference
Recordset.FieldUnique Method
Recordset Class See Also

If it's true two rows of data can't have the same value in this column.

Expand image Overload List

Name | Description
FieldUnique(int) | If it's true two rows of data can't have the same value in this column.
FieldUnique(string) | If it's true two rows of data can't have the same value in this column.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldValueType Method

[image] [image] [image]

NetData Reference
Recordset.FieldValueType Method
Recordset Class See Also

Gets System.Type of field object.

Expand image Overload List

Name | Description
FieldValueType(int) | Gets System.Type of field object.
FieldValueType(string) | Gets System.Type of field object.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldsCount Method

[image] [image] [image]

NetData Reference
Recordset.FieldsCount Method
See Also

Gets the total number of fields in recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldsCount() As Integer
C#
public int FieldsCount()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Find Method

[image] [image] [image]

NetData Reference
Recordset.Find Method
Recordset Class See Also

The Find method searches for a record in the Recordset that match specified criteria staring from first. If the search is successful, the record Position will point to the first found record.

Expand image Overload List

Name | Description
Find(string) | The Find method searches for a record in the Recordset that match specified criteria staring from first. If the search is successful, the record Position will point to the first found record.
Find(string, FindRecordEnum) | The Find method searches for a record in the Recordset that match specified criteria starting from specified position. If the search is successful, the record Position will point to the first found record.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetAllValues Method

[image] [image] [image]

NetData Reference
Recordset.GetAllValues Method
See Also

Gets a list of all values for current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetAllValues() As List(Of Object())
C#
public List<object[]> GetAllValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBoolean Method

[image] [image] [image]

NetData Reference
Recordset.GetBoolean Method
Recordset Class See Also

Gets a Boolean value of specified field for the current record

Expand image Overload List

Name | Description
GetBoolean(int) | Gets a Boolean value of specified field for the current record
GetBoolean(string) | Gets a Boolean value of specified field for the current record
GetBoolean(int, int) | Gets a Boolean value of specified field for the specified record position
GetBoolean(int, string) | Gets a Boolean value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetByte Method

[image] [image] [image]

NetData Reference
Recordset.GetByte Method
Recordset Class See Also

Gets a Byte value of specified field for the current record

Expand image Overload List

Name | Description
GetByte(int) | Gets a Byte value of specified field for the current record
GetByte(string) | Gets a Byte value of specified field for the current record
GetByte(int, int) | Gets a Byte value of specified field for the specified record position
GetByte(int, string) | Gets a Byte value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBytes Method

[image] [image] [image]

NetData Reference
Recordset.GetBytes Method
Recordset Class See Also

Gets a Byte array values of specified field for the current record

Expand image Overload List

Name | Description
GetBytes(int) | Gets a Byte array values of specified field for the current record
GetBytes(string) | Gets a Byte array values of specified field for the current record
GetBytes(int, int) | Gets a Byte array values of specified field for the specified record position
GetBytes(int, string) | Gets a Byte array values of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChar Method

[image] [image] [image]

NetData Reference
Recordset.GetChar Method
Recordset Class See Also

Gets a Char value of specified field for the current record

Expand image Overload List

Name | Description
GetChar(int) | Gets a Char value of specified field for the current record
GetChar(string) | Gets a Char value of specified field for the current record
GetChar(int, int) | Gets a Char value of specified field for the specified record position
GetChar(int, string) | Gets a Char value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChars Method

[image] [image] [image]

NetData Reference
Recordset.GetChars Method
Recordset Class See Also

Gets a Char array values of specified field for the current record

Expand image Overload List

Name | Description
GetChars(int) | Gets a Char array values of specified field for the current record
GetChars(string) | Gets a Char array values of specified field for the current record
GetChars(int, int) | Gets a Char array values of specified field for the specified record position
GetChars(int, string) | Gets a Char array values of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDate Method

[image] [image] [image]

NetData Reference
Recordset.GetDate Method
Recordset Class See Also

Gets a Date value of specified field for the current record

Expand image Overload List

Name | Description
GetDate(int) | Gets a Date value of specified field for the current record
GetDate(string) | Gets a Date value of specified field for the current record
GetDate(int, int) | Gets a Date value of specified field for the specified record position
GetDate(int, string) | Gets a Date value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateText Method

[image] [image] [image]

NetData Reference
Recordset.GetDateText Method
Recordset Class See Also

Gets the string value of a DateTime field type in the system date short format for the current record.

Expand image Overload List

Name | Description
GetDateText(int) | Gets the string value of a DateTime field type in the system date short format for the current record.
GetDateText(string) | Gets the string value of a DateTime field type in the system date short format for the current record.
GetDateText(int, int) | Gets the string value of a DateTime field type in the system date short format for specified record position.
GetDateText(int, string) | Gets the string value of a DateTime field type in the system date short format for specified record position.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateTimeText Method

[image] [image] [image]

NetData Reference
Recordset.GetDateTimeText Method
Recordset Class See Also

Gets the string value of a DateTime field type in the system datetime short format for the current record.

Expand image Overload List

Name | Description
GetDateTimeText(int) | Gets the string value of a DateTime field type in the system datetime short format for the current record.
GetDateTimeText(string) | Gets the string value of a DateTime field type in the system datetime short format for the current record.
GetDateTimeText(int, int) | Gets the string value of a DateTime field type in the system datetime short format for specified record position.
GetDateTimeText(int, string) | Gets the string value of a DateTime field type in the system datetime short format for specified record position.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDecimal Method

[image] [image] [image]

NetData Reference
Recordset.GetDecimal Method
Recordset Class See Also

Gets a Decimal value of specified field for the current record

Expand image Overload List

Name | Description
GetDecimal(int) | Gets a Decimal value of specified field for the current record
GetDecimal(string) | Gets a Decimal value of specified field for the current record
GetDecimal(int, int) | Gets a Decimal value of specified field for the specified record position
GetDecimal(int, string) | Gets a Decimal value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDouble Method

[image] [image] [image]

NetData Reference
Recordset.GetDouble Method
Recordset Class See Also

Gets a Double value of specified field for the current record

Expand image Overload List

Name | Description
GetDouble(int) | Gets a Double value of specified field for the current record
GetDouble(string) | Gets a Double value of specified field for the current record
GetDouble(int, int) | Gets a Double value of specified field for the specified record position
GetDouble(int, string) | Gets a Double value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetFieldsValues Method

[image] [image] [image]

NetData Reference
Recordset.GetFieldsValues Method
Recordset Class See Also

Return a FieldsValues object from this recordset

Expand image Overload List

Name | Description
GetFieldsValues() | Return a FieldsValues object from this recordset
GetFieldsValues(bool) | Return a FieldsValues object from this recordset

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetGuid Method

[image] [image] [image]

NetData Reference
Recordset.GetGuid Method
Recordset Class See Also

Gets a Guid value of specified field for the current record

Expand image Overload List

Name | Description
GetGuid(int) | Gets a Guid value of specified field for the current record
GetGuid(string) | Gets a Guid value of specified field for the current record
GetGuid(int, int) | Gets a Guid value of specified field for the specified record position
GetGuid(int, string) | Gets a Guid value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetInteger Method

[image] [image] [image]

NetData Reference
Recordset.GetInteger Method
Recordset Class See Also

Gets a Integer value of specified field for the current record

Expand image Overload List

Name | Description
GetInteger(int) | Gets a Integer value of specified field for the current record
GetInteger(string) | Gets a Integer value of specified field for the current record
GetInteger(int, int) | Gets a Integer value of specified field for the specified record position
GetInteger(int, string) | Gets a Integer value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetLong Method

[image] [image] [image]

NetData Reference
Recordset.GetLong Method
Recordset Class See Also

Gets a Long value of specified field for the current record

Expand image Overload List

Name | Description
GetLong(int) | Gets a Long value of specified field for the current record
GetLong(string) | Gets a Long value of specified field for the current record
GetLong(int, int) | Gets a Long value of specified field for the specified record position
GetLong(int, string) | Gets a Long value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetRecordString Method

[image] [image] [image]

NetData Reference
Recordset.GetRecordString Method
See Also

Return s string of data rappresenting record values separated by specified char
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetRecordString( _
   ByVal cSeparator As Char _
) As String
C#
public string GetRecordString(
   char cSeparator
)

Parameters

cSeparator

Type: char

Character separator

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetShort Method

[image] [image] [image]

NetData Reference
Recordset.GetShort Method
Recordset Class See Also

Gets a Short value of specified field for the current record

Expand image Overload List

Name | Description
GetShort(int) | Gets a Short value of specified field for the current record
GetShort(string) | Gets a Short value of specified field for the current record
GetShort(int, int) | Gets a Short value of specified field for the specified record position
GetShort(int, string) | Gets a Short value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetSingle Method

[image] [image] [image]

NetData Reference
Recordset.GetSingle Method
Recordset Class See Also

Gets a Single value of specified field for the current record

Expand image Overload List

Name | Description
GetSingle(int) | Gets a Single value of specified field for the current record
GetSingle(string) | Gets a Single value of specified field for the current record
GetSingle(int, int) | Gets a Single value of specified field for the specified record position
GetSingle(int, string) | Gets a Single value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetString Method

[image] [image] [image]

NetData Reference
Recordset.GetString Method
Recordset Class See Also

Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.

Expand image Overload List

Name | Description
GetString(int) | Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
GetString(string) | Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
GetString(int, int) | Gets a String value of specified field for the specified record position. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
GetString(int, string) | Gets a String value of specified field for the specified record position. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText Method

[image] [image] [image]

NetData Reference
Recordset.GetText Method
Recordset Class See Also

Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.

Expand image Overload List

Name | Description
GetText(int) | Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(int, bool) | Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(string) | Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(string, bool) | Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(int, int) | Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(int, int, bool) | Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(int, string) | Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
GetText(int, string, bool) | Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTime Method

[image] [image] [image]

NetData Reference
Recordset.GetTime Method
Recordset Class See Also

Gets a TimeSpan value of specified field for the current record

Expand image Overload List

Name | Description
GetTime(int) | Gets a TimeSpan value of specified field for the current record
GetTime(string) | Gets a TimeSpan value of specified field for the current record
GetTime(int, int) | Gets a TimeSpan value of specified field for the specified record position
GetTime(int, string) | Gets a TimeSpan value of specified field for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTimeText Method

[image] [image] [image]

NetData Reference
Recordset.GetTimeText Method
Recordset Class See Also

Gets the current string value of a TimeSpan field type in the format HH:MM:SS.

Expand image Overload List

Name | Description
GetTimeText(int) | Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
GetTimeText(string) | Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
GetTimeText(int, int) | Gets the string value of a TimeSpan field type in the format HH:MM:SS for specified record position.
GetTimeText(int, string) | Gets the string value of a TimeSpan field type in the format HH:MM:SS for specified record position.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValue Method

[image] [image] [image]

NetData Reference
Recordset.GetValue Method
Recordset Class See Also

Gets the value of specified field in the current record position

Expand image Overload List

Name | Description
GetValue(int) | Gets the value of specified field in the current record position
GetValue(string) | Gets the value of specified field in the current record position
GetValue(int, int) | Gets the value of specified field in the specified record position
GetValue(int, string) | Gets the value of specified field in the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValues Method

[image] [image] [image]

NetData Reference
Recordset.GetValues Method
Recordset Class See Also

Gets an array of all values for the current record position

Expand image Overload List

Name | Description
GetValues() | Gets an array of all values for the current record position
GetValues(int) | Gets an array of all values for the specified record position

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.IsValid Method

[image] [image] [image]

NetData Reference
Recordset.IsValid Method
See Also

Returns True if Recordset is opened and both BOF and EOF properties are False
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IsValid() As Boolean
C#
public bool IsValid()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.MaxRecords Method

[image] [image] [image]

NetData Reference
Recordset.MaxRecords Method
See Also

Gets maximum number of records returned from the recordset. This value is the same used as parameter on Open method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function MaxRecords() As Integer
C#
public int MaxRecords()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.MoveFirst Method

[image] [image] [image]

NetData Reference
Recordset.MoveFirst Method
See Also

Move current record at the beginning of recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveFirst()
C#
public System.Void MoveFirst()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.MoveLast Method

[image] [image] [image]

NetData Reference
Recordset.MoveLast Method
See Also

Move current record at the end of recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveLast()
C#
public System.Void MoveLast()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.MoveNext Method

[image] [image] [image]

NetData Reference
Recordset.MoveNext Method
See Also

Move current record to the next record in recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
C#
public System.Void MoveNext()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.MovePrevious Method

[image] [image] [image]

NetData Reference
Recordset.MovePrevious Method
See Also

Move current record to the previous record in recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MovePrevious()
C#
public System.Void MovePrevious()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open Method

[image] [image] [image]

NetData Reference
Recordset.Open Method
Recordset Class See Also

Open the recordset from a DataTable object.

Expand image Overload List

Name | Description
Open(Connection, string) | Open the recordset for reading operations in the associated connection.
Open(Connection, string, bool) | Open the recordset for read operations in the associated connection.
Open(Connection, string, bool, int) | Open the recordset for read operations in the associated connection.
Open(Connection, string, bool, int, bool, int) | Open the recordset for read operations in the associated connection.
Open(Connection, string, bool, int, bool, int, bool) | Open the recordset for read operations in the associated connection.
Open(DataTable) | Open the recordset from a DataTable object.

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.PercentPosition Method

[image] [image] [image]

NetData Reference
Recordset.PercentPosition Method
See Also

Return the percent position of current record in a Recordsets object or -1 if not supported.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function PercentPosition() As Short
C#
public short PercentPosition()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.State Method

[image] [image] [image]

NetData Reference
Recordset.State Method
See Also

Gest the current state of recordset. See StateEnum for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function State() As RecordsetStateEnum
C#
public RecordsetStateEnum State()

Expand image Remarks

You can use the State property to determine the current state at any time.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.ValueIsNull Method

[image] [image] [image]

NetData Reference
Recordset.ValueIsNull Method
Recordset Class See Also

Return True if value of a field is Null value

Expand image Overload List

Name | Description
ValueIsNull(int) | Return True if value of a field is Null value
ValueIsNull(string) | Return True if value of a field is Null value
ValueIsNull(int, int) | Return True if value of a field is Null value
ValueIsNull(int, string) | Return True if value of a field is Null value

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Events

[image] [image] [image]

NetData Reference
Recordset Events
Recordset Class See Also

Expand image Public Events

 | Name | Description
Public event | Closed | This event will be generated if recordset was closed.
Public event | FetchCompleted | This event will be generated after an asynchronous fetch is completed and report the total number of records loaded from data source.
Public event | FetchProgress | This event will be generated during an asynchronous fetch and report the total number of records currently loaded from data source.
Public event | Filtered | This event will be generated every time Filter method was invoked.
Public event | MoveComplete | This event will be generated every time current record position change
Public event | Opened | This event will be generated every time Open or Requery method was invoked.
Public event | Sorted | This event will be generated every time Sort method was invoked.
Top

Expand image See Also

Reference

Recordset Class


Closed Event

[image] [image] [image]

NetData Reference
Closed Event
See Also

This event will be generated if recordset was closed.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event Closed()
C#
public event ClosedEventHandler Closed
delegate void ClosedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


FetchCompleted Event

[image] [image] [image]

NetData Reference
FetchCompleted Event
See Also

This event will be generated after an asynchronous fetch is completed and report the total number of records loaded from data source.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event FetchCompleted()
C#
public event FetchCompletedEventHandler FetchCompleted
delegate void FetchCompletedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


FetchProgress Event

[image] [image] [image]

NetData Reference
FetchProgress Event
See Also

This event will be generated during an asynchronous fetch and report the total number of records currently loaded from data source.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event FetchProgress( _
   ByVal iProgress As Integer _
)
C#
public event FetchProgressEventHandler FetchProgress
delegate void FetchProgressEventHandler(
   int iProgress
)

Parameters

iProgress

Type: int

Total number of records currently loaded from data source

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Filtered Event

[image] [image] [image]

NetData Reference
Filtered Event
See Also

This event will be generated every time Filter method was invoked.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event Filtered()
C#
public event FilteredEventHandler Filtered
delegate void FilteredEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


MoveComplete Event

[image] [image] [image]

NetData Reference
MoveComplete Event
See Also

This event will be generated every time current record position change
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event MoveComplete()
C#
public event MoveCompleteEventHandler MoveComplete
delegate void MoveCompleteEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Opened Event

[image] [image] [image]

NetData Reference
Opened Event
See Also

This event will be generated every time Open or Requery method was invoked.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event Opened()
C#
public event OpenedEventHandler Opened
delegate void OpenedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Sorted Event

[image] [image] [image]

NetData Reference
Sorted Event
See Also

This event will be generated every time Sort method was invoked.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event Sorted()
C#
public event SortedEventHandler Sorted
delegate void SortedEventHandler()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


SQLDelete Class

[image] [image] [image]

NetData Reference
SQLDelete Class
Members

SQLDelete provide an easy and unique way for generate and/or execute SQL DELETE statements that can be used for any database type supported by Softgroup Connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLDelete
C#
public sealed class SQLDelete

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.SQLDelete

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Members


SQLDelete Members

[image] [image] [image]

NetData Reference
SQLDelete Members
SQLDelete Class Constructors Methods Properties See Also

SQLDelete provide an easy and unique way for generate and/or execute SQL DELETE statements that can be used for any database type supported by Softgroup Connection.

The following tables list the members exposed by the SQLDelete type.

Expand image Public Constructors

 | Name | Description
Public constructor | SQLDelete Constructor | (Overloaded) Create a new instance of the object (Init method must be called before using object)
Top

Expand image Public Properties

 | Name | Description
Public property | TableName | Gets the name of table where delete data
Public property | Where | Gets/Sets the text for WHERE clause of SQL Statement
Top

Expand image Public Methods

 | Name | Description
Public method | Execute | Execute the SQL DELETE statement
Public method | Init | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | Gets the SQL DELETE statement
Top

Expand image See Also

Reference

SQLDelete Class


SQLDelete Constructor

[image] [image] [image]

NetData Reference
SQLDelete Constructor
SQLDelete Class See Also

Create a new instance of the object (Init method must be called before using object)

Expand image Overload List

Name | Description
SQLDelete() | Create a new instance of the object (Init method must be called before using object)
SQLDelete(Connection, string) | Create and initialize a new instance of the object

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete Properties

[image] [image] [image]

NetData Reference
SQLDelete Properties
SQLDelete Class See Also

Expand image Public Properties

 | Name | Description
Public property | TableName | Gets the name of table where delete data
Public property | Where | Gets/Sets the text for WHERE clause of SQL Statement
Top

Expand image See Also

Reference

SQLDelete Class


SQLDelete.TableName Property

[image] [image] [image]

NetData Reference
SQLDelete.TableName Property
See Also

Gets the name of table where delete data
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName() As String
C#
public string TableName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete.Where Property

[image] [image] [image]

NetData Reference
SQLDelete.Where Property
See Also

Gets/Sets the text for WHERE clause of SQL Statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Where() As String
C#
public string Where {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete Methods

[image] [image] [image]

NetData Reference
SQLDelete Methods
SQLDelete Class See Also

Expand image Public Methods

 | Name | Description
Public method | Execute | Execute the SQL DELETE statement
Public method | Init | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | Gets the SQL DELETE statement
Top

Expand image See Also

Reference

SQLDelete Class


SQLDelete.Execute Method

[image] [image] [image]

NetData Reference
SQLDelete.Execute Method
See Also

Execute the SQL DELETE statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute() As Boolean
C#
public bool Execute()

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete.Init Method

[image] [image] [image]

NetData Reference
SQLDelete.Init Method
See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public System.Void Init(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete.SQL Method

[image] [image] [image]

NetData Reference
SQLDelete.SQL Method
See Also

Gets the SQL DELETE statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL() As String
C#
public string SQL()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLInsert Class

[image] [image] [image]

NetData Reference
SQLInsert Class
Members

SQLInsert provide an easy and unique way for generate and/or execute SQL INSERT statements that can be used for any database type supported by Softgroup Connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLInsert
C#
public sealed class SQLInsert

Expand image Remarks

Binary fields type are not supported

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.SQLInsert

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Members


SQLInsert Members

[image] [image] [image]

NetData Reference
SQLInsert Members
SQLInsert Class Constructors Methods Properties See Also

SQLInsert provide an easy and unique way for generate and/or execute SQL INSERT statements that can be used for any database type supported by Softgroup Connection.

The following tables list the members exposed by the SQLInsert type.

Expand image Public Constructors

 | Name | Description
Public constructor | SQLInsert Constructor | (Overloaded) Create a new instance of the object (Init method must be called before using object)
Top

Expand image Public Properties

 | Name | Description
Public property | DefaultValueNoDbNull | Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)
Public property | Fields | This is the collection of fields of the table. This collection is generated automatically from the Init method.
Public property | FullSchemaFields | Return True if fields has full schema
Public property | ReplaceSingleQuoteWithCompatibleChar | Replace single quote char with a compatible char in Text field values
Public property | TableName | Gets name of table where insert data
Top

Expand image Public Methods

 | Name | Description
Public method | ClearValues | This method clear all values of fields and sets it to System.DbNull.
Public method | Execute | (Overloaded) Execute the SQL INSERT statement
Public method | Init | (Overloaded) Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | (Overloaded) Gets the SQL INSERT statement
Top

Expand image See Also

Reference

SQLInsert Class


SQLInsert Constructor

[image] [image] [image]

NetData Reference
SQLInsert Constructor
SQLInsert Class See Also

Create a new instance of the object (Init method must be called before using object)

Expand image Overload List

Name | Description
SQLInsert() | Create a new instance of the object (Init method must be called before using object)
SQLInsert(Connection, string) | Create and initialize a new instance of the object
SQLInsert(Connection, string, bool) | Create and initialize a new instance of the object
SQLInsert(Connection, string, bool, bool) | Create and initialize a new instance of the object

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert Properties

[image] [image] [image]

NetData Reference
SQLInsert Properties
SQLInsert Class See Also

Expand image Public Properties

 | Name | Description
Public property | DefaultValueNoDbNull | Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)
Public property | Fields | This is the collection of fields of the table. This collection is generated automatically from the Init method.
Public property | FullSchemaFields | Return True if fields has full schema
Public property | ReplaceSingleQuoteWithCompatibleChar | Replace single quote char with a compatible char in Text field values
Public property | TableName | Gets name of table where insert data
Top

Expand image See Also

Reference

SQLInsert Class


SQLInsert.DefaultValueNoDbNull Property

[image] [image] [image]

NetData Reference
SQLInsert.DefaultValueNoDbNull Property
See Also

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property DefaultValueNoDbNull() As Boolean
C#
public bool DefaultValueNoDbNull {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Fields Property

[image] [image] [image]

NetData Reference
SQLInsert.Fields Property
See Also

This is the collection of fields of the table. This collection is generated automatically from the Init method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields() As Fields
C#
public Fields Fields {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.FullSchemaFields Property

[image] [image] [image]

NetData Reference
SQLInsert.FullSchemaFields Property
See Also

Return True if fields has full schema
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullSchemaFields() As Boolean
C#
public bool FullSchemaFields {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.ReplaceSingleQuoteWithCompatibleChar Property

[image] [image] [image]

NetData Reference
SQLInsert.ReplaceSingleQuoteWithCompatibleChar Property
See Also

Replace single quote char with a compatible char in Text field values
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ReplaceSingleQuoteWithCompatibleChar() As Boolean
C#
public bool ReplaceSingleQuoteWithCompatibleChar {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.TableName Property

[image] [image] [image]

NetData Reference
SQLInsert.TableName Property
See Also

Gets name of table where insert data
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName() As String
C#
public string TableName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert Methods

[image] [image] [image]

NetData Reference
SQLInsert Methods
SQLInsert Class See Also

Expand image Public Methods

 | Name | Description
Public method | ClearValues | This method clear all values of fields and sets it to System.DbNull.
Public method | Execute | (Overloaded) Execute the SQL INSERT statement
Public method | Init | (Overloaded) Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | (Overloaded) Gets the SQL INSERT statement
Top

Expand image See Also

Reference

SQLInsert Class


SQLInsert.ClearValues Method

[image] [image] [image]

NetData Reference
SQLInsert.ClearValues Method
See Also

This method clear all values of fields and sets it to System.DbNull.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ClearValues()
C#
public System.Void ClearValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Execute Method

[image] [image] [image]

NetData Reference
SQLInsert.Execute Method
SQLInsert Class See Also

Execute the SQL INSERT statement

Expand image Overload List

Name | Description
Execute() | Execute the SQL INSERT statement
Execute(bool) | Execute the SQL INSERT statement
Execute(string) | Execute the SQL INSERT statement
Execute(string, bool) | Execute the SQL INSERT statement

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Init Method

[image] [image] [image]

NetData Reference
SQLInsert.Init Method
SQLInsert Class See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.

Expand image Overload List

Name | Description
Init(Connection, string) | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Init(Connection, string, bool) | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Init(Connection, string, bool, bool) | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.SQL Method

[image] [image] [image]

NetData Reference
SQLInsert.SQL Method
SQLInsert Class See Also

Gets the SQL INSERT statement

Expand image Overload List

Name | Description
SQL() | Gets the SQL INSERT statement
SQL(bool) | Gets the SQL INSERT statement
SQL(string) | Gets the SQL INSERT statement
SQL(string, bool) | Gets the SQL INSERT statement

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLSelect Class

[image] [image] [image]

NetData Reference
SQLSelect Class
Members

SQLSelect provide an easy and unique way for generate and/or execute SQL SELECT statements that can be used for any database type supported by Softgroup Connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLSelect
C#
public sealed class SQLSelect

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.SQLSelect

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Members


SQLSelect Members

[image] [image] [image]

NetData Reference
SQLSelect Members
SQLSelect Class Constructors Methods Properties See Also

SQLSelect provide an easy and unique way for generate and/or execute SQL SELECT statements that can be used for any database type supported by Softgroup Connection.

The following tables list the members exposed by the SQLSelect type.

Expand image Public Constructors

 | Name | Description
Public constructor | SQLSelect Constructor | (Overloaded) Create a new instance of the object (Init method must be called before using object)
Top

Expand image Public Properties

 | Name | Description
Public property | Fields | Gets/Sets the text fields (or expressions) list part of SQL SELECT statement.
Public property | GroupBy | Gets/Sets the text for GROUP BY clause of SQL statement.
Public property | Having | Gets/Sets the text for HAVING clause of SQL statement.
Public property | NoLock | Gets/Sets if SQL statement must include keywords to force reading uncommetted records from tables.
Public property | OrderBy | Gets/Sets the text for ORDER BY clause of SQL statement.
Public property | Tables | Return an object SQLTables for the collection of tables used in the SQL SELECT Statement.
Public property | Where | Gets/Sets the text for WHERE clause of SQL statement.
Top

Expand image Public Methods

 | Name | Description
Public method | AddField | (Overloaded) Append new field or expression to sql SELECT clause.
Public method | AddFieldGroupBy | Append new field or expression to sql GROUP BY clause.
Public method | AddFieldOrderBy | Append new field or expression to sql ORDER BY clause.
Public method | Execute | (Overloaded) Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Public method | Init | (Overloaded) Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.
Public method | SQL | (Overloaded) Return the SQL statement text
Top

Expand image See Also

Reference

SQLSelect Class


SQLSelect Constructor

[image] [image] [image]

NetData Reference
SQLSelect Constructor
SQLSelect Class See Also

Create a new instance of the object (Init method must be called before using object)

Expand image Overload List

Name | Description
SQLSelect() | Create a new instance of the object (Init method must be called before using object)
SQLSelect(Connection) | Create and initialize a new instance of the object
SQLSelect(Connection, bool) | Create and initialize a new instance of the object

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect Properties

[image] [image] [image]

NetData Reference
SQLSelect Properties
SQLSelect Class See Also

Expand image Public Properties

 | Name | Description
Public property | Fields | Gets/Sets the text fields (or expressions) list part of SQL SELECT statement.
Public property | GroupBy | Gets/Sets the text for GROUP BY clause of SQL statement.
Public property | Having | Gets/Sets the text for HAVING clause of SQL statement.
Public property | NoLock | Gets/Sets if SQL statement must include keywords to force reading uncommetted records from tables.
Public property | OrderBy | Gets/Sets the text for ORDER BY clause of SQL statement.
Public property | Tables | Return an object SQLTables for the collection of tables used in the SQL SELECT Statement.
Public property | Where | Gets/Sets the text for WHERE clause of SQL statement.
Top

Expand image See Also

Reference

SQLSelect Class


SQLSelect.Fields Property

[image] [image] [image]

NetData Reference
SQLSelect.Fields Property
See Also

Gets/Sets the text fields (or expressions) list part of SQL SELECT statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Fields() As String
C#
public string Fields {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.GroupBy Property

[image] [image] [image]

NetData Reference
SQLSelect.GroupBy Property
See Also

Gets/Sets the text for GROUP BY clause of SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property GroupBy() As String
C#
public string GroupBy {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Having Property

[image] [image] [image]

NetData Reference
SQLSelect.Having Property
See Also

Gets/Sets the text for HAVING clause of SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Having() As String
C#
public string Having {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.NoLock Property

[image] [image] [image]

NetData Reference
SQLSelect.NoLock Property
See Also

Gets/Sets if SQL statement must include keywords to force reading uncommetted records from tables.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property NoLock() As Boolean
C#
public bool NoLock {get; set;}

Expand image Remarks

This behavior is supported only by Microsoft SQL Server, MySQL and IBM DB2 database providers

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.OrderBy Property

[image] [image] [image]

NetData Reference
SQLSelect.OrderBy Property
See Also

Gets/Sets the text for ORDER BY clause of SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property OrderBy() As String
C#
public string OrderBy {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Tables Property

[image] [image] [image]

NetData Reference
SQLSelect.Tables Property
See Also

Return an object SQLTables for the collection of tables used in the SQL SELECT Statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables() As SQLTables
C#
public SQLTables Tables {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Where Property

[image] [image] [image]

NetData Reference
SQLSelect.Where Property
See Also

Gets/Sets the text for WHERE clause of SQL statement.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Where() As String
C#
public string Where {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect Methods

[image] [image] [image]

NetData Reference
SQLSelect Methods
SQLSelect Class See Also

Expand image Public Methods

 | Name | Description
Public method | AddField | (Overloaded) Append new field or expression to sql SELECT clause.
Public method | AddFieldGroupBy | Append new field or expression to sql GROUP BY clause.
Public method | AddFieldOrderBy | Append new field or expression to sql ORDER BY clause.
Public method | Execute | (Overloaded) Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Public method | Init | (Overloaded) Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.
Public method | SQL | (Overloaded) Return the SQL statement text
Top

Expand image See Also

Reference

SQLSelect Class


SQLSelect.AddField Method

[image] [image] [image]

NetData Reference
SQLSelect.AddField Method
SQLSelect Class See Also

Append new field or expression to sql SELECT clause.

Expand image Overload List

Name | Description
AddField(string) | Append new field or expression to sql SELECT clause.
AddField(string, bool) | Append new field or expression to sql SELECT clause.

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.AddFieldGroupBy Method

[image] [image] [image]

NetData Reference
SQLSelect.AddFieldGroupBy Method
See Also

Append new field or expression to sql GROUP BY clause.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddFieldGroupBy( _
   ByVal sFieldExpression As String _
)
C#
public System.Void AddFieldGroupBy(
   string sFieldExpression
)

Parameters

sFieldExpression

Type: string

A valid file name or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.AddFieldOrderBy Method

[image] [image] [image]

NetData Reference
SQLSelect.AddFieldOrderBy Method
See Also

Append new field or expression to sql ORDER BY clause.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddFieldOrderBy( _
   ByVal sFieldExpression As String _
)
C#
public System.Void AddFieldOrderBy(
   string sFieldExpression
)

Parameters

sFieldExpression

Type: string

A valid file name or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Execute Method

[image] [image] [image]

NetData Reference
SQLSelect.Execute Method
SQLSelect Class See Also

Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.

Expand image Overload List

Name | Description
Execute() | Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Execute(bool) | Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Execute(bool, int) | Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Execute(bool, int, bool, int, bool) | Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Init Method

[image] [image] [image]

NetData Reference
SQLSelect.Init Method
SQLSelect Class See Also

Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.

Expand image Overload List

Name | Description
Init(Connection) | Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.
Init(Connection, bool) | Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.SQL Method

[image] [image] [image]

NetData Reference
SQLSelect.SQL Method
SQLSelect Class See Also

Return the SQL statement text

Expand image Overload List

Name | Description
SQL() | Return the SQL statement text
SQL(bool) | Return the SQL statement text
SQL(bool, bool) | Return the SQL statement text

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLTable Class

[image] [image] [image]

NetData Reference
SQLTable Class
Members

This object is used in SQLTables collection for store properties of tables
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLTable
C#
public sealed class SQLTable

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.SQLTable

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTable Members


SQLTable Members

[image] [image] [image]

NetData Reference
SQLTable Members
SQLTable Class Properties See Also

This object is used in SQLTables collection for store properties of tables

The following tables list the members exposed by the SQLTable type.

Expand image Public Properties

 | Name | Description
Public property | JoinFields | Gets/Sets a string for joins fields; must have this syntax: TableName.FieldA = JoinTable.FieldB. Multiple join fields can be added in a unique string separated by a pipe character (|). If JoinTable is assigned (a non empty string) you must assign a value also for joins fields.
Public property | JoinTable | Gets/Sets the name of join table. If you assign a join table it is necessary to assign valid values also to JoinFiels and JoinType properties.
Public property | JoinType | Gets/Sets the join type of the table with the jointable. Ses JoinTypeEnum enumeration for details.
Public property | TableName | Gets/Sets the name of table
Top

Expand image See Also

Reference

SQLTable Class


SQLTable Properties

[image] [image] [image]

NetData Reference
SQLTable Properties
SQLTable Class See Also

Expand image Public Properties

 | Name | Description
Public property | JoinFields | Gets/Sets a string for joins fields; must have this syntax: TableName.FieldA = JoinTable.FieldB. Multiple join fields can be added in a unique string separated by a pipe character (|). If JoinTable is assigned (a non empty string) you must assign a value also for joins fields.
Public property | JoinTable | Gets/Sets the name of join table. If you assign a join table it is necessary to assign valid values also to JoinFiels and JoinType properties.
Public property | JoinType | Gets/Sets the join type of the table with the jointable. Ses JoinTypeEnum enumeration for details.
Public property | TableName | Gets/Sets the name of table
Top

Expand image See Also

Reference

SQLTable Class


SQLTable.JoinFields Property

[image] [image] [image]

NetData Reference
SQLTable.JoinFields Property
See Also

Gets/Sets a string for joins fields; must have this syntax: TableName.FieldA = JoinTable.FieldB. Multiple join fields can be added in a unique string separated by a pipe character (|). If JoinTable is assigned (a non empty string) you must assign a value also for joins fields.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property JoinFields() As String
C#
public string JoinFields {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTable Class
SQLTable Members


SQLTable.JoinTable Property

[image] [image] [image]

NetData Reference
SQLTable.JoinTable Property
See Also

Gets/Sets the name of join table. If you assign a join table it is necessary to assign valid values also to JoinFiels and JoinType properties.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property JoinTable() As String
C#
public string JoinTable {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTable Class
SQLTable Members


SQLTable.JoinType Property

[image] [image] [image]

NetData Reference
SQLTable.JoinType Property
See Also

Gets/Sets the join type of the table with the jointable. Ses JoinTypeEnum enumeration for details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property JoinType() As JoinTypeEnum
C#
public JoinTypeEnum JoinType {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTable Class
SQLTable Members


SQLTable.TableName Property

[image] [image] [image]

NetData Reference
SQLTable.TableName Property
See Also

Gets/Sets the name of table
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property TableName() As String
    Get
C#
public string TableName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTable Class
SQLTable Members


SQLTables Class

[image] [image] [image]

NetData Reference
SQLTables Class
Members

SQLTables is a collection object of SQLTable objects used by GSQLSelect object for store properties and values of tables used if SQL SELECT statements
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLTables
    Inherits NameObjectCollectionBase
C#
public sealed class SQLTables : NameObjectCollectionBase

Expand image Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
Softgroup.NetData.SQLTables

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Members


SQLTables Members

[image] [image] [image]

NetData Reference
SQLTables Members
SQLTables Class Methods Properties See Also

SQLTables is a collection object of SQLTable objects used by GSQLSelect object for store properties and values of tables used if SQL SELECT statements

The following tables list the members exposed by the SQLTables type.

Expand image Public Properties

 | Name | Description
Public property | Item | This is the default readonly property for accessing SQLTable objects stored in the collection.
Public property | TableAliasPrefix | Gets/Sets Tables Alias Prefix
Top

Expand image Public Methods

 | Name | Description
Public method | Add | (Overloaded) Add a table and optionally a join table to the collection
Public method | Clear | This method clear the collection and release all Field
Public method | GetEnumerator | implementation for support of enumeration of collection
Public method | Remove | Remove a table from the collection
Top

Expand image See Also

Reference

SQLTables Class


SQLTables Properties

[image] [image] [image]

NetData Reference
SQLTables Properties
SQLTables Class See Also

Expand image Public Properties

 | Name | Description
Public property | Item | This is the default readonly property for accessing SQLTable objects stored in the collection.
Public property | TableAliasPrefix | Gets/Sets Tables Alias Prefix
Top

Expand image See Also

Reference

SQLTables Class


SQLTables.Item Property

[image] [image] [image]

NetData Reference
SQLTables.Item Property
See Also

This is the default readonly property for accessing SQLTable objects stored in the collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As SQLTable
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public SQLTable this[
   int Index
] {get;}

Parameters

Index

Type: int

Index of table

Property Value

Return a SQLTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.TableAliasPrefix Property

[image] [image] [image]

NetData Reference
SQLTables.TableAliasPrefix Property
See Also

Gets/Sets Tables Alias Prefix
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property TableAliasPrefix() As String
C#
public string TableAliasPrefix {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables Methods

[image] [image] [image]

NetData Reference
SQLTables Methods
SQLTables Class See Also

Expand image Public Methods

 | Name | Description
Public method | Add | (Overloaded) Add a table and optionally a join table to the collection
Public method | Clear | This method clear the collection and release all Field
Public method | GetEnumerator | implementation for support of enumeration of collection
Public method | Remove | Remove a table from the collection
Top

Expand image See Also

Reference

SQLTables Class


SQLTables.Add Method

[image] [image] [image]

NetData Reference
SQLTables.Add Method
SQLTables Class See Also

Add a table and optionally a join table to the collection

Expand image Overload List

Name | Description
Add(string) | Add a table and optionally a join table to the collection
Add(string, string) | Add a table and optionally a join table to the collection
Add(string, string, JoinTypeEnum) | Add a table and optionally a join table to the collection
Add(string, string, JoinTypeEnum, string) | Add a table and optionally a join table to the collection

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.Clear Method

[image] [image] [image]

NetData Reference
SQLTables.Clear Method
See Also

This method clear the collection and release all Field
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public System.Void Clear()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.GetEnumerator Method

[image] [image] [image]

NetData Reference
SQLTables.GetEnumerator Method
See Also

implementation for support of enumeration of collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
C#
new public IEnumerator GetEnumerator()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.Remove Method

[image] [image] [image]

NetData Reference
SQLTables.Remove Method
See Also

Remove a table from the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Index As Integer _
)
C#
public System.Void Remove(
   int Index
)

Parameters

Index

Type: int

Index of table

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLUpdate Class

[image] [image] [image]

NetData Reference
SQLUpdate Class
Members

SQLUpdate provide an easy and unique way for generate and/or execute SQL UPDATE statements that can be used for any database type supported by Softgroup Connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class SQLUpdate
C#
public sealed class SQLUpdate

Expand image Remarks

Binary fields type are not supported

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetData.SQLUpdate

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Members


SQLUpdate Members

[image] [image] [image]

NetData Reference
SQLUpdate Members
SQLUpdate Class Constructors Methods Properties See Also

SQLUpdate provide an easy and unique way for generate and/or execute SQL UPDATE statements that can be used for any database type supported by Softgroup Connection.

The following tables list the members exposed by the SQLUpdate type.

Expand image Public Constructors

 | Name | Description
Public constructor | SQLUpdate Constructor | (Overloaded) Create a new instance of the object (Init method must be called before using object)
Top

Expand image Public Properties

 | Name | Description
Public property | Fields | This is the collection of fields of the table. This collection is generated automatically from the Init method.
Public property | ReplaceSingleQuoteWithCompatibleChar | Replace single quote char with a compatible char in Text field values
Public property | TableName | Gets name of table where update data
Public property | Where | Gets/Sets the text for WHERE clause of SQL Statement
Top

Expand image Public Methods

 | Name | Description
Public method | ClearValues | This method clear all values of fields and sets it to System.DbNull.
Public method | Execute | (Overloaded) Execute the SQL UPDATET statement
Public method | Init | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | (Overloaded) Gets the SQL UPDATE statement
Top

Expand image See Also

Reference

SQLUpdate Class


SQLUpdate Constructor

[image] [image] [image]

NetData Reference
SQLUpdate Constructor
SQLUpdate Class See Also

Create a new instance of the object (Init method must be called before using object)

Expand image Overload List

Name | Description
SQLUpdate() | Create a new instance of the object (Init method must be called before using object)
SQLUpdate(Connection, string) | Create and initialize a new instance of the object

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate Properties

[image] [image] [image]

NetData Reference
SQLUpdate Properties
SQLUpdate Class See Also

Expand image Public Properties

 | Name | Description
Public property | Fields | This is the collection of fields of the table. This collection is generated automatically from the Init method.
Public property | ReplaceSingleQuoteWithCompatibleChar | Replace single quote char with a compatible char in Text field values
Public property | TableName | Gets name of table where update data
Public property | Where | Gets/Sets the text for WHERE clause of SQL Statement
Top

Expand image See Also

Reference

SQLUpdate Class


SQLUpdate.Fields Property

[image] [image] [image]

NetData Reference
SQLUpdate.Fields Property
See Also

This is the collection of fields of the table. This collection is generated automatically from the Init method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields() As Fields
C#
public Fields Fields {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.ReplaceSingleQuoteWithCompatibleChar Property

[image] [image] [image]

NetData Reference
SQLUpdate.ReplaceSingleQuoteWithCompatibleChar Property
See Also

Replace single quote char with a compatible char in Text field values
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ReplaceSingleQuoteWithCompatibleChar() As Boolean
C#
public bool ReplaceSingleQuoteWithCompatibleChar {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.TableName Property

[image] [image] [image]

NetData Reference
SQLUpdate.TableName Property
See Also

Gets name of table where update data
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName() As String
C#
public string TableName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Where Property

[image] [image] [image]

NetData Reference
SQLUpdate.Where Property
See Also

Gets/Sets the text for WHERE clause of SQL Statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Where() As String
C#
public string Where {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate Methods

[image] [image] [image]

NetData Reference
SQLUpdate Methods
SQLUpdate Class See Also

Expand image Public Methods

 | Name | Description
Public method | ClearValues | This method clear all values of fields and sets it to System.DbNull.
Public method | Execute | (Overloaded) Execute the SQL UPDATET statement
Public method | Init | Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Public method | SQL | (Overloaded) Gets the SQL UPDATE statement
Top

Expand image See Also

Reference

SQLUpdate Class


SQLUpdate.ClearValues Method

[image] [image] [image]

NetData Reference
SQLUpdate.ClearValues Method
See Also

This method clear all values of fields and sets it to System.DbNull.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ClearValues()
C#
public System.Void ClearValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Execute Method

[image] [image] [image]

NetData Reference
SQLUpdate.Execute Method
SQLUpdate Class See Also

Execute the SQL UPDATET statement

Expand image Overload List

Name | Description
Execute() | Execute the SQL UPDATET statement
Execute(bool) | Execute the SQL UPDATET statement
Execute(string) | Execute the SQL UPDATET statement
Execute(string, bool) | Execute the SQL UPDATET statement

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Init Method

[image] [image] [image]

NetData Reference
SQLUpdate.Init Method
See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public System.Void Init(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where update data

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.SQL Method

[image] [image] [image]

NetData Reference
SQLUpdate.SQL Method
SQLUpdate Class See Also

Gets the SQL UPDATE statement

Expand image Overload List

Name | Description
SQL(bool) | Gets the SQL UPDATE statement
SQL(string) | Gets the SQL UPDATE statement
SQL(string, bool) | Gets the SQL UPDATE statement

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


TransactionAlreadyActiveException Class

[image] [image] [image]

NetData Reference
TransactionAlreadyActiveException Class
Members

The exception that is thrown when a Transaction is already active
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class TransactionAlreadyActiveException
    Inherits Exception
C#
public class TransactionAlreadyActiveException : Exception

Expand image Inheritance Hierarchy

System.Object
System.Exception
Softgroup.NetData.TransactionAlreadyActiveException

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

TransactionAlreadyActiveException Members


TransactionAlreadyActiveException Members

[image] [image] [image]

NetData Reference
TransactionAlreadyActiveException Members
TransactionAlreadyActiveException Class Properties See Also

The exception that is thrown when a Transaction is already active

The following tables list the members exposed by the TransactionAlreadyActiveException type.

Expand image Public Properties

 | Name | Description
Public property | DatabaseName | Return the name of database where exception occurs.
Top

Expand image See Also

Reference

TransactionAlreadyActiveException Class


TransactionAlreadyActiveException Properties

[image] [image] [image]

NetData Reference
TransactionAlreadyActiveException Properties
TransactionAlreadyActiveException Class See Also

Expand image Public Properties

 | Name | Description
Public property | DatabaseName | Return the name of database where exception occurs.
Top

Expand image See Also

Reference

TransactionAlreadyActiveException Class


TransactionAlreadyActiveException.DatabaseName Property

[image] [image] [image]

NetData Reference
TransactionAlreadyActiveException.DatabaseName Property
See Also

Return the name of database where exception occurs.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName() As String
C#
public string DatabaseName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

TransactionAlreadyActiveException Class
TransactionAlreadyActiveException Members


TransactionNotActivated Class

[image] [image] [image]

NetData Reference
TransactionNotActivated Class
Members

The exception that is thrown when no Transaction is previously activated
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class TransactionNotActivated
    Inherits Exception
C#
public class TransactionNotActivated : Exception

Expand image Inheritance Hierarchy

System.Object
System.Exception
Softgroup.NetData.TransactionNotActivated

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

TransactionNotActivated Members


TransactionNotActivated Members

[image] [image] [image]

NetData Reference
TransactionNotActivated Members
TransactionNotActivated Class Properties See Also

The exception that is thrown when no Transaction is previously activated

The following tables list the members exposed by the TransactionNotActivated type.

Expand image Public Properties

 | Name | Description
Public property | DatabaseName | Return the name of database where exception occurs.
Top

Expand image See Also

Reference

TransactionNotActivated Class


TransactionNotActivated Properties

[image] [image] [image]

NetData Reference
TransactionNotActivated Properties
TransactionNotActivated Class See Also

Expand image Public Properties

 | Name | Description
Public property | DatabaseName | Return the name of database where exception occurs.
Top

Expand image See Also

Reference

TransactionNotActivated Class


TransactionNotActivated.DatabaseName Property

[image] [image] [image]

NetData Reference
TransactionNotActivated.DatabaseName Property
See Also

Return the name of database where exception occurs.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName() As String
C#
public string DatabaseName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

TransactionNotActivated Class
TransactionNotActivated Members


CommandTypeEnum Enumeration

[image] [image] [image]

NetData Reference
CommandTypeEnum Enumeration

Enumeration of CommandType parameter used by DataAdapter method.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Delete | Command parameter is a DELETE command.
Insert | Command parameter is an INSERT command
Select | Command parameter is a SELECT command
Update | Command parameter is an UPDATE command

Expand image See Also

Reference

by Softgroup


CompareValueEnum Enumeration

[image] [image] [image]

NetData Reference
CompareValueEnum Enumeration

Enumeration used by CompareDate and CompareTime methods of Field object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
IsEqual | Current value is equal to specified parameter value
IsMajor | Current value is grater than specified parameter value
IsMinor | Current value is minor then specified parameter value

Expand image See Also

Reference

by Softgroup


ConnectionStringValueTypeEnum Enumeration

[image] [image] [image]

NetData Reference
ConnectionStringValueTypeEnum Enumeration

Enumeration of values types of properties
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Boolean | The values is boolean (True or False)
Integer | The values is numeric
String | The values is a string

Expand image See Also

Reference

by Softgroup


ConvertCaseEnum Enumeration

[image] [image] [image]

NetData Reference
ConvertCaseEnum Enumeration

Enumeration of database objects names name convertion.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Lower | Tables and columns names are converted in lowercase
None | No conversion
Upper | Tables and columns names are converted to uppercase

Expand image Remarks

The Connection object automatically convert database objects names to upper/lower case as required by some databases (like Tables names, Fields names etc.).

Expand image See Also

Reference

by Softgroup


DataTypeEnum Enumeration

[image] [image] [image]

NetData Reference
DataTypeEnum Enumeration

Enumeration of supported databases Data Types.

For compatibility with all supported databases Connection object uses a unified list of custom data types that maps various databases data type with .NET data types.

Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
dtBinary | Byte Array rappresentation of binary data
dtBoolean | Boolean
dtDate | Date
dtDecimal | Decimal
dtDouble | Double Precision
dtInteger | Integer or Int32 or UInt32
dtLong | Long or Int64 or UInt64
dtMemo | Chars/string of defined size
dtShort | Short or Int16 or UInt16
dtSingle | Single Precision
dtText | Chars/string up to 255 characters
dtTime | Time

Expand image Remarks

On some databases Date fields type are reappresented from a Date/Time fields.

For databases that support Time fields are mapped to System.TimeSpan .Net object.

Expand image See Also

Reference

by Softgroup


DriverTypeEnum Enumeration

[image] [image] [image]

NetData Reference
DriverTypeEnum Enumeration

Enumeration that defines data access technology used by driver (.Net, OLEDB or ODBC)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
DotNet | .Net native driver type
Odbc | Odbc native driver type
OleDb | OleDb native driver type
Unknow | The driver type is unknow

Expand image See Also

Reference

by Softgroup


FindRecordEnum Enumeration

[image] [image] [image]

NetData Reference
FindRecordEnum Enumeration

Enumeration used by Find Method of Recordset class used to specify search direction
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
SearchBackward | Searches backward from the current position. Stops at the beginning of the Recordset. If no match, the record position is placed at the beginning of the Recordset
SearchEnd | Search start from last record
SearchForward | Searches forward from the current position. Stops at the end of the Recordset. If no match, the record position is placed at the end of the Recordset
SearchStart | Search start from first record

Expand image See Also

Reference

by Softgroup


ForeignKeyActionEnum Enumeration

[image] [image] [image]

NetData Reference
ForeignKeyActionEnum Enumeration

Supported actions for Update/Delete operations on creation of foreign keys database objects
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Cascade | Cascade Action
NoAction | No Action
SetNull | Set Null Action (not supported by all databases)

Expand image Remarks

This parameter is required by ForeignKeyCreate method of Connection object

Expand image See Also

Reference

by Softgroup


JoinTypeEnum Enumeration

[image] [image] [image]

NetData Reference
JoinTypeEnum Enumeration

Enumeration of joins type used by Add method in SQLTables object of SQLSelect object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
InnerJoin | Inner Join
LeftJoin | Left Join
RightJoin | Right Join

Expand image See Also

Reference

by Softgroup


PermissionObjectEnum Enumeration

[image] [image] [image]

NetData Reference
PermissionObjectEnum Enumeration

Enumeration used to define supported objects to grant and revoke database permission
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Database | Grant/Revoke permissions on Database
Procedure | Grant/Revoke permissions on Procedure
Table | Grant/Revoke permissions on Tables
View | Grant/Revoke permissions on Views

Expand image Remarks

Connection object support only a generic Grant/Revoke "all" permissions to major databases objects

Expand image See Also

Reference

by Softgroup


ProviderTypeEnum Enumeration

[image] [image] [image]

NetData Reference
ProviderTypeEnum Enumeration

Enumeration that defines constants for Provider Type (generic type of database used)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Access | Microsoft Access database
Firebird | Firebird SQL database
IBMDB2 | IBM DB2 database
MSSQL | Microsoft SQL Server database
MySQL | MySQL database
ORACLE | Oracle database
PostgreSql | ProstgreSQL database
Unknow | The provider type is unknow

Expand image See Also

Reference

by Softgroup


RecordsetStateEnum Enumeration

[image] [image] [image]

NetData Reference
RecordsetStateEnum Enumeration

Enumeration of current state of a recordset.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
Closed | Recordset is closed
Open | Recordset is opened

Expand image Remarks

Use State property of a Recordset object to determine its actual state.

Expand image See Also

Reference

by Softgroup


RequireEnum Enumeration

[image] [image] [image]

NetData Reference
RequireEnum Enumeration

This Enumeration is used by Required method of Connection object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
DatabaseName | Database name is required or supported
ServerDNS | Server name or Host address is required or supported
SystemDatabase | System Database name is required or supported

Expand image See Also

Reference

by Softgroup


SupportsEnum Enumeration

[image] [image] [image]

NetData Reference
SupportsEnum Enumeration

Enumeration of SupportOption parameter for Supports method of Connection Object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
AsyncFetch | Asynchronous fetch are supported
DatabaseBackup | Backup of databases are supported
DatabaseCompact | Compact of databases are supported
DatabaseCreate | Creation of databases are supported
DatabaseDelete | Deletion of databases are supported
DatabaseExist | Check if a specific database exists is supported
DatabaseRestore | Restore of databases are supported
DatabasesList | List of existing databases are supported
ForeignKeys | Foreign keys are supported
GroupUsers | Groups of Users are supported
Groups | Groups are supported
OSAuthentication | Operative System Authentication is supported
Procedures | Procedures are supported
Schemas | Schemas are supported
Transactions | Transactions are supported
Triggers | Triggers are supported
UseADO | Gets if UseADO property can be sets to True
UserPasswordChange | Change of users passwords is supported
Users | Users are supported
Views | Views are supported

Expand image See Also

Reference

by Softgroup


TriggerActionEnum Enumeration

[image] [image] [image]

NetData Reference
TriggerActionEnum Enumeration

Supported values for triggers moment operations
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Members

Member name | Description
After | After Trigger execution
Before | Before Trigger execution
InsteadOf | Instead of Trigger execution

Expand image Remarks

Some databases does not support Triggers or toaInsteadOf constant.

Expand image See Also

Reference

by Softgroup


Connection.Recordset (System.Data.DataTable) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.Data.DataTable) Method
See Also

Create and open a Recordset object from specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal oDataTable As DataTable _
) As Recordset
C#
public Recordset Recordset(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset (System.String) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.String) Method
See Also

Create and open a Recordset object from current connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal sSource As String _
) As Recordset
C#
public Recordset Recordset(
   string sSource
)

Parameters

sSource

Type: string

A valid SELECT SQL statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.String, System.Boolean) Method
See Also

Create and open a Recordset object from current connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean _
) As Recordset
C#
public Recordset Recordset(
   string sSource,
   bool bClientCursors
)

Parameters

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset (System.String, System.Boolean, System.Int32) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.String, System.Boolean, System.Int32) Method
See Also

Create and open a Recordset object from current connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer _
) As Recordset
C#
public Recordset Recordset(
   string sSource,
   bool bClientCursors,
   int iMaxRecords
)

Parameters

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset (System.String, System.Boolean, System.Int32, System.Boolean, System.Int32) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.String, System.Boolean, System.Int32, System.Boolean, System.Int32) Method
See Also

Create and open a Recordset object from current connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer _
) As Recordset
C#
public Recordset Recordset(
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize
)

Parameters

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset.

bAsyncFetch

Type: bool

True to enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Recordset (System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.Recordset (System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method
See Also

Create and open a Recordset object from current connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Recordset( _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer, _
   ByVal bFetchProgress As Boolean _
) As Recordset
C#
public Recordset Recordset(
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize,
   bool bFetchProgress
)

Parameters

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset.

bAsyncFetch

Type: bool

True to enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

bFetchProgress

Type: bool

Enable progress of total number of records readed during asynchronous operations

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlConcatenate (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.SqlConcatenate (System.String, System.String) Method
See Also

Return the SQL statempent text to execute a concatenation of an expression or field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlConcatenate( _
   ByVal ExpressionA As String, _
   ByVal ExpressionB As String _
) As String
C#
public string SqlConcatenate(
   string ExpressionA,
   string ExpressionB
)

Parameters

ExpressionA

Type: string

First expression or field to concatenate

ExpressionB

Type: string

Second expression or field to concatenate

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlConcatenate (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.SqlConcatenate (System.String, System.String, System.String) Method
See Also

Return the SQL statempent text to execute a concatenation of an expression or field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlConcatenate( _
   ByVal ExpressionA As String, _
   ByVal ExpressionB As String, _
   ByVal ExpressionC As String _
) As String
C#
public string SqlConcatenate(
   string ExpressionA,
   string ExpressionB,
   string ExpressionC
)

Parameters

ExpressionA

Type: string

First expression or field to concatenate

ExpressionB

Type: string

Second expression or field to concatenate

ExpressionC

Type: string

Third expression or field to concatenate (if an empty string will be ignored)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlIfNull (System.String, Softgroup.NetData.DataTypeEnum) Method

[image] [image] [image]

NetData Reference
Connection.SqlIfNull (System.String, Softgroup.NetData.DataTypeEnum) Method
See Also

Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlIfNull( _
   ByVal sExpression As String, _
   ByVal iType As DataTypeEnum _
) As String
C#
public string SqlIfNull(
   string sExpression,
   DataTypeEnum iType
)

Parameters

sExpression

Type: string

Name of field or expression

iType

Type: DataTypeEnum

Data Type returned.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlIfNull (System.String, Softgroup.NetData.DataTypeEnum, System.String) Method

[image] [image] [image]

NetData Reference
Connection.SqlIfNull (System.String, Softgroup.NetData.DataTypeEnum, System.String) Method
See Also

Return the SQL statement text to obtain the value of an expression or field. If it is NULL The default value of numeric data types is zero (0) or an empty string ('') for strings.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlIfNull( _
   ByVal sExpression As String, _
   ByVal iType As DataTypeEnum, _
   ByVal sReturnValue As String _
) As String
C#
public string SqlIfNull(
   string sExpression,
   DataTypeEnum iType,
   string sReturnValue
)

Parameters

sExpression

Type: string

Name of field or expression

iType

Type: DataTypeEnum

Data Type returned.

sReturnValue

Type: string

Null or expresion value returned.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlValue (System.Object, Softgroup.NetData.DataTypeEnum) Method

[image] [image] [image]

NetData Reference
Connection.SqlValue (System.Object, Softgroup.NetData.DataTypeEnum) Method
See Also

Return the SQL statement text to obtain the correct value or comparison value specified.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlValue( _
   ByVal FieldValue As Object, _
   ByVal FieldType As DataTypeEnum _
) As String
C#
public string SqlValue(
   object FieldValue,
   DataTypeEnum FieldType
)

Parameters

FieldValue

Type: object

Value or field.

FieldType

Type: DataTypeEnum

Type of value. See DataTypeEnum for more details.

Expand image Remarks

Binary fields type are not supported

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlValue (System.Object, Softgroup.NetData.DataTypeEnum, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.SqlValue (System.Object, Softgroup.NetData.DataTypeEnum, System.Boolean) Method
See Also

Return the SQL statement text to obtain the correct value or comparison value specified.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlValue( _
   ByVal FieldValue As Object, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string SqlValue(
   object FieldValue,
   DataTypeEnum FieldType,
   bool FullDateTime
)

Parameters

FieldValue

Type: object

Value or field.

FieldType

Type: DataTypeEnum

Type of value. See DataTypeEnum for more details.

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Remarks

Binary fields type are not supported

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object) Method

[image] [image] [image]

NetData Reference
Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object) Method
See Also

Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlWhere( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object _
) As String
C#
public string SqlWhere(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

Expand image Remarks

This method use always an equal (=) operator

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String) Method

[image] [image] [image]

NetData Reference
Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String) Method
See Also

Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlWhere( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String _
) As String
C#
public string SqlWhere(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean) Method
See Also

Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlWhere( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String, _
   ByVal CheckNull As Boolean _
) As String
C#
public string SqlWhere(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType,
   bool CheckNull
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

CheckNull

Type: bool

True if statement must include check for null values

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.SqlWhere (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean, System.Boolean) Method
See Also

Return the SQL statement text to obtain the comparison value to use in a WHERE clause of a SQL statement of a field or expression.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SqlWhere( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String, _
   ByVal CheckNull As Boolean, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string SqlWhere(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType,
   bool CheckNull,
   bool FullDateTime
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

CheckNull

Type: bool

True if statement must include check for null values

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableExist (System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableExist (System.String) Method
See Also

Verify if the specified table from current database exist.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableExist( _
   ByVal TableName As String _
) As Boolean
C#
public bool TableExist(
   string TableName
)

Parameters

TableName

Type: string

Name of table

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableExist (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableExist (System.String, System.String) Method
See Also

Verify if the specified table from current database exist.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableExist( _
   ByVal TableName As String, _
   ByVal SchemaName As String _
) As Boolean
C#
public bool TableExist(
   string TableName,
   string SchemaName
)

Parameters

TableName

Type: string

Name of table

SchemaName

Type: string

Name of Schema

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean) Method
See Also

Add a field in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldAdd( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldSize As Integer, _
   ByVal FieldAllowDBNull As Boolean _
) As Boolean
C#
public bool TableFieldAdd(
   string TableName,
   string FieldName,
   DataTypeEnum FieldType,
   int FieldSize,
   bool FieldAllowDBNull
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

FieldType

Type: DataTypeEnum

Type of data. See DataTypeEnum for more details

FieldSize

Type: int

Size of field.

FieldAllowDBNull

Type: bool

Boolean value that indicate if a field accept null values

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean) Method
See Also

Add a field in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldAdd( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldSize As Integer, _
   ByVal FieldAllowDBNull As Boolean, _
   ByVal FieldAutoIncrement As Boolean _
) As Boolean
C#
public bool TableFieldAdd(
   string TableName,
   string FieldName,
   DataTypeEnum FieldType,
   int FieldSize,
   bool FieldAllowDBNull,
   bool FieldAutoIncrement
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

FieldType

Type: DataTypeEnum

Type of data. See DataTypeEnum for more details

FieldSize

Type: int

Size of field.

FieldAllowDBNull

Type: bool

Boolean value that indicate if a field accept null values

FieldAutoIncrement

Type: bool

Boolean value that indicate if a field contains and autoincrement value

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean, System.Object) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldAdd (System.String, System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean, System.Object) Method
See Also

Add a field in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldAdd( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldSize As Integer, _
   ByVal FieldAllowDBNull As Boolean, _
   ByVal FieldAutoIncrement As Boolean, _
   ByVal DefaultValue As Object _
) As Boolean
C#
public bool TableFieldAdd(
   string TableName,
   string FieldName,
   DataTypeEnum FieldType,
   int FieldSize,
   bool FieldAllowDBNull,
   bool FieldAutoIncrement,
   object DefaultValue
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

FieldType

Type: DataTypeEnum

Type of data. See DataTypeEnum for more details

FieldSize

Type: int

Size of field.

FieldAllowDBNull

Type: bool

Boolean value that indicate if a field accept null values

FieldAutoIncrement

Type: bool

Boolean value that indicate if a field contains and autoincrement value

DefaultValue

Type: object

Default value for field

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Constructor

[image] [image] [image]

NetData Reference
Connection Constructor
See Also

Create new instance of Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Connection()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldInfo (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldInfo (System.String, System.String) Method
See Also

Returns informations about a field in a specified table of the current database with partial information schema details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldInfo( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Field
C#
public Field TableFieldInfo(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

Return Value

Return an object of type Field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldInfo (System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldInfo (System.String, System.String, System.Boolean) Method
See Also

Returns informations about a field in a specified table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldInfo( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal FullSchema As Boolean _
) As Field
C#
public Field TableFieldInfo(
   string TableName,
   string FieldName,
   bool FullSchema
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

FullSchema

Type: bool

Set to False this parameter to retrieve full table fields schema informations otherwise set to False to read only partial table fields schema informations (this is more fast but only field name and data type information will be returned)

Return Value

Return an object of type Field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldInfo (System.String, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldInfo (System.String, System.String, System.Boolean, System.Boolean) Method
See Also

Returns informations about a field in a specified table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldInfo( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal FullSchema As Boolean, _
   ByVal IncludeAutoincrement As Boolean _
) As Field
C#
public Field TableFieldInfo(
   string TableName,
   string FieldName,
   bool FullSchema,
   bool IncludeAutoincrement
)

Parameters

TableName

Type: string

Name of table.

FieldName

Type: string

Name of field

FullSchema

Type: bool

Set to False this parameter to retrieve full table fields schema informations otherwise set to False to read only partial table fields schema informations (this is more fast but only field name and data type information will be returned)

IncludeAutoincrement

Type: bool

Return Value

Return an object of type Field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldsList (System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldsList (System.String) Method
See Also

Returns the list of Fields contained in the specified Table of the current database with full information schema details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldsList( _
   ByVal TableName As String _
) As Fields
C#
public Fields TableFieldsList(
   string TableName
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

Return Value

A Softgroup.Fields object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldsList (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldsList (System.String, System.Boolean) Method
See Also

Returns the list of Fields contained in the specified Table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldsList( _
   ByVal TableName As String, _
   ByVal FullSchema As Boolean _
) As Fields
C#
public Fields TableFieldsList(
   string TableName,
   bool FullSchema
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

FullSchema

Type: bool

Set to False this parameter to retrieve full table fields schema informations otherwise set to False to read only partial table fields schema informations (this is more fast but only field name and data type information will be returned)

Return Value

A Softgroup.Fields object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldsList (System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldsList (System.String, System.Boolean, System.Boolean) Method
See Also

Returns the list of Fields contained in the specified Table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldsList( _
   ByVal TableName As String, _
   ByVal FullSchema As Boolean, _
   ByVal IncludeAutoincrement As Boolean _
) As Fields
C#
public Fields TableFieldsList(
   string TableName,
   bool FullSchema,
   bool IncludeAutoincrement
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

FullSchema

Type: bool

Set to False this parameter to retrieve full table fields schema informations otherwise set to False to read only partial table fields schema informations (this is more fast but only field name and data type information will be returned)

IncludeAutoincrement

Type: bool

Set to True this parameter to retrieve full table autoincrement fields schema informations otherwise.

Return Value

A Softgroup.Fields object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableFieldsList (System.String, System.Boolean, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableFieldsList (System.String, System.Boolean, System.Boolean, System.Boolean) Method
See Also

Returns the list of Fields contained in the specified Table of the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableFieldsList( _
   ByVal TableName As String, _
   ByVal FullSchema As Boolean, _
   ByVal IncludeAutoincrement As Boolean, _
   ByVal NoLock As Boolean _
) As Fields
C#
public Fields TableFieldsList(
   string TableName,
   bool FullSchema,
   bool IncludeAutoincrement,
   bool NoLock
)

Parameters

TableName

Type: string

Name of table (Syntax: [Schema].Table)

FullSchema

Type: bool

Set to False this parameter to retrieve full table fields schema informations otherwise set to False to read only partial table fields schema informations (this is more fast but only field name and data type information will be returned)

IncludeAutoincrement

Type: bool

Set to True this parameter to retrieve full table autoincrement fields schema informations otherwise.

NoLock

Type: bool

Return Value

A Softgroup.Fields object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableInsertSelect (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableInsertSelect (System.String, System.String, System.String, System.String) Method
See Also

Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableInsertSelect( _
   ByVal TableSource As String, _
   ByVal FieldsSource As String, _
   ByVal TableDestination As String, _
   ByVal FieldsDestination As String _
) As Boolean
C#
public bool TableInsertSelect(
   string TableSource,
   string FieldsSource,
   string TableDestination,
   string FieldsDestination
)

Parameters

TableSource

Type: string

Source table name

FieldsSource

Type: string

List of source table fields to copy data to destination table. Name of fields must be separated from a "," character.

TableDestination

Type: string

Name of destination table.

FieldsDestination

Type: string

List of destination table fields in the sampe order of FieldsSource parameter. Name of fields must be separated from e "," character.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableInsertSelect (System.String, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableInsertSelect (System.String, System.String, System.String, System.String, System.String) Method
See Also

Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableInsertSelect( _
   ByVal TableSource As String, _
   ByVal FieldsSource As String, _
   ByVal TableDestination As String, _
   ByVal FieldsDestination As String, _
   ByVal Where As String _
) As Boolean
C#
public bool TableInsertSelect(
   string TableSource,
   string FieldsSource,
   string TableDestination,
   string FieldsDestination,
   string Where
)

Parameters

TableSource

Type: string

Source table name

FieldsSource

Type: string

List of source table fields to copy data to destination table. Name of fields must be separated from a "," character.

TableDestination

Type: string

Name of destination table.

FieldsDestination

Type: string

List of destination table fields in the sampe order of FieldsSource parameter. Name of fields must be separated from e "," character.

Where

Type: string

WHERE clause of SQL statement to filter data from source table.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableInsertSelect (System.String, System.String, System.String, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableInsertSelect (System.String, System.String, System.String, System.String, System.String, System.Boolean) Method
See Also

Copy data from a source table to a destination table in the current database and optionally create destination table if not exist
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TableInsertSelect( _
   ByVal TableSource As String, _
   ByVal FieldsSource As String, _
   ByVal TableDestination As String, _
   ByVal FieldsDestination As String, _
   ByVal Where As String, _
   ByVal CreateTable As Boolean _
) As Boolean
C#
public bool TableInsertSelect(
   string TableSource,
   string FieldsSource,
   string TableDestination,
   string FieldsDestination,
   string Where,
   bool CreateTable
)

Parameters

TableSource

Type: string

Source table name

FieldsSource

Type: string

List of source table fields to copy data to destination table. Name of fields must be separated from a "," character.

TableDestination

Type: string

Name of destination table.

FieldsDestination

Type: string

List of destination table fields in the sampe order of FieldsSource parameter. Name of fields must be separated from e "," character.

Where

Type: string

WHERE clause of SQL statement to filter data from source table.

CreateTable

Type: bool

Create destination Table if not exist using the structure (all fields) of source Table. Default False.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TablesList Method

[image] [image] [image]

NetData Reference
Connection.TablesList Method
See Also

Returns the list of Tables contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TablesList() As String()
C#
public string[] TablesList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Constructor (Softgroup.NetData.Connection)

[image] [image] [image]

NetData Reference
Connection Constructor (Softgroup.NetData.Connection)
See Also

Create new instance of Connection object base on another Connection object and open it.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection _
)
C#
public Connection(
   Connection oConnection
)

Parameters

oConnection

Type: Connection

Connection object from which create the new Connection

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TablesList (System.String) Method

[image] [image] [image]

NetData Reference
Connection.TablesList (System.String) Method
See Also

Returns the list of Tables contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function TablesList( _
   ByVal SchemaName As String _
) As String()
C#
public string[] TablesList(
   string SchemaName
)

Parameters

SchemaName

Type: string

Schema name filter.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserAdd (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserAdd (System.String, System.String) Method
See Also

Add a user in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserAdd( _
   ByVal sUserName As String, _
   ByVal sUserPassword As String _
) As Boolean
C#
public bool UserAdd(
   string sUserName,
   string sUserPassword
)

Parameters

sUserName

Type: string

User name

sUserPassword

Type: string

User password

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserAdd (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserAdd (System.String, System.String, System.String) Method
See Also

Add a user in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserAdd( _
   ByVal sUserName As String, _
   ByVal sUserPassword As String, _
   ByVal sGroupName As String _
) As Boolean
C#
public bool UserAdd(
   string sUserName,
   string sUserPassword,
   string sGroupName
)

Parameters

sUserName

Type: string

User name

sUserPassword

Type: string

User password

sGroupName

Type: string

Parameter for add a user to a specific Group or Role only. If this parameter is passed UserPassword parameter is ignored.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserDelete (System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserDelete (System.String) Method
See Also

Delete a user in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserDelete( _
   ByVal sUserName As String _
) As Boolean
C#
public bool UserDelete(
   string sUserName
)

Parameters

sUserName

Type: string

User name

Return Value

Return True if succes else return False

Expand image Remarks

Before delete the specified user this method check if it exists. If user will not be found no errors are generated and return True.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserDelete (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserDelete (System.String, System.String) Method
See Also

Delete a user in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserDelete( _
   ByVal sUserName As String, _
   ByVal sGroupName As String _
) As Boolean
C#
public bool UserDelete(
   string sUserName,
   string sGroupName
)

Parameters

sUserName

Type: string

User name

sGroupName

Type: string

Delete a user from a specific Group or Role only.

Return Value

Return True if succes else return False

Expand image Remarks

Before delete the specified user this method check if it exists. If user will not be found no errors are generated and return True.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserExist (System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserExist (System.String) Method
See Also

Check if a user exist in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserExist( _
   ByVal sUserName As String _
) As Boolean
C#
public bool UserExist(
   string sUserName
)

Parameters

sUserName

Type: string

User name

Return Value

Return True if user exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UserExist (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.UserExist (System.String, System.String) Method
See Also

Check if a user exist in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UserExist( _
   ByVal sUserName As String, _
   ByVal sGroupName As String _
) As Boolean
C#
public bool UserExist(
   string sUserName,
   string sGroupName
)

Parameters

sUserName

Type: string

User name

sGroupName

Type: string

Use this parameter to check if user exists in a specific Group or Role only.

Return Value

Return True if user exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UsersList Method

[image] [image] [image]

NetData Reference
Connection.UsersList Method
See Also

Returns the list of Users contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UsersList() As String()
C#
public string[] UsersList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.UsersList (System.String) Method

[image] [image] [image]

NetData Reference
Connection.UsersList (System.String) Method
See Also

Returns the list of Users contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function UsersList( _
   ByVal sGroupName As String _
) As String()
C#
public string[] UsersList(
   string sGroupName
)

Parameters

sGroupName

Type: string

Parameter to obtain list of users of a specific group name.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Constructor (Softgroup.NetData.Connection, System.Boolean)

[image] [image] [image]

NetData Reference
Connection Constructor (Softgroup.NetData.Connection, System.Boolean)
See Also

Create new instance of Connection object base on another Connection object and open it.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal bOpen As Boolean _
)
C#
public Connection(
   Connection oConnection,
   bool bOpen
)

Parameters

oConnection

Type: Connection

Connection object from which create the new Connection

bOpen

Type: bool

True to Open the connection otherwise False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewExist (System.String) Method

[image] [image] [image]

NetData Reference
Connection.ViewExist (System.String) Method
See Also

Check if a view exist in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewExist( _
   ByVal ViewName As String _
) As Boolean
C#
public bool ViewExist(
   string ViewName
)

Parameters

ViewName

Type: string

Name of View.

Return Value

Return True if view exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewExist (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.ViewExist (System.String, System.String) Method
See Also

Check if a view exist in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewExist( _
   ByVal ViewName As String, _
   ByVal SchemaName As String _
) As Boolean
C#
public bool ViewExist(
   string ViewName,
   string SchemaName
)

Parameters

ViewName

Type: string

Name of View.

SchemaName

Type: string

Name of Schema.

Return Value

Return True if view exists else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewsList Method

[image] [image] [image]

NetData Reference
Connection.ViewsList Method
See Also

Returns the list of Views contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewsList() As String()
C#
public string[] ViewsList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ViewsList (System.String) Method

[image] [image] [image]

NetData Reference
Connection.ViewsList (System.String) Method
See Also

Returns the list of Views contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ViewsList( _
   ByVal SchemaName As String _
) As String()
C#
public string[] ViewsList(
   string SchemaName
)

Parameters

SchemaName

Type: string

Parameter for Schema name filter.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

Expand image Remarks

This method does not erase data on destination table and make uses of transactions

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

Expand image Remarks

This method does not erase data on destination table and make uses of transactions

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

Expand image Remarks

This method make uses of transactions

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean, _
   ByVal CreateIndexes As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData,
   bool CreateIndexes
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

CreateIndexes

Type: bool

Create Indexes on destination table

Expand image Remarks

This method make uses of transactions

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean, _
   ByVal CreateIndexes As Boolean, _
   ByVal UseTransactions As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData,
   bool CreateIndexes,
   bool UseTransactions
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

CreateIndexes

Type: bool

Create Indexes on destination table

UseTransactions

Type: bool

Expand image Remarks

This method make uses of transactions

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean, _
   ByVal CreateIndexes As Boolean, _
   ByVal UseTransactions As Boolean, _
   ByVal TruncateTextFieldsValues As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData,
   bool CreateIndexes,
   bool UseTransactions,
   bool TruncateTextFieldsValues
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

CreateIndexes

Type: bool

Create Indexes on destination table

UseTransactions

Type: bool

Use transactions for all operation

TruncateTextFieldsValues

Type: bool

Truncate text fields values too long

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.TableCopyTo (Softgroup.NetData.Connection, System.String, System.String, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean, System.Boolean) Method
See Also

Copy a table structure and data from current connection to a specified destination connection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub TableCopyTo( _
   ByVal Destination As Connection, _
   ByVal TableSource As String, _
   ByVal TableDestination As String, _
   ByVal ReplaceExist As Boolean, _
   ByVal EraseData As Boolean, _
   ByVal CreateIndexes As Boolean, _
   ByVal UseTransactions As Boolean, _
   ByVal TruncateTextFieldsValues As Boolean, _
   ByVal FullDateTime As Boolean _
)
C#
public System.Void TableCopyTo(
   Connection Destination,
   string TableSource,
   string TableDestination,
   bool ReplaceExist,
   bool EraseData,
   bool CreateIndexes,
   bool UseTransactions,
   bool TruncateTextFieldsValues,
   bool FullDateTime
)

Parameters

Destination

Type: Connection

A valid destination connection object

TableSource

Type: string

A valid source table name

TableDestination

Type: string

A valid destination table name

ReplaceExist

Type: bool

Drop and replace destination table and data

EraseData

Type: bool

Erase data on destination table before copy

CreateIndexes

Type: bool

Create Indexes on destination table

UseTransactions

Type: bool

Use transactions for all operation

TruncateTextFieldsValues

Type: bool

Truncate text fields values too long

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ConnectionString (System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.ConnectionString (System.Boolean) Method
See Also

The connection string consists of a series of values separated by a semicolon, which contain the information necessary to establish a database connection. Driver must be initialized using DriverInit method before collig this property.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionString( _
   ByVal bPersistSecurityInfo As Boolean _
) As String
C#
public string ConnectionString(
   bool bPersistSecurityInfo
)

Parameters

bPersistSecurityInfo

Type: bool

Boolean value that indicate if User Name and Password must be saved in the list of parameters.

Expand image Remarks

The following table displays the properties of Connection object that must be initialized to get correct connection string:

Key | Value
DriverName | Name of softgroup driver
Unicode | True if driver supports unicode otherwise False
DataSource | Server name or DNS
DatabaseName | Name of database to connect
SystemDatabaseName | Some drivers require a system database used to store security informations (like Microsof Access Database)
OSAuthentication | If driver supports trusted connections (OS authentication) this parameter can be True otherwise False to make a standard connection
UserName | Nome of user
Password | Password for user
UseADO | If DriverName is an OLEDB driver you can sets this parameter to True to force direct calls to Microsoft ADO library instead of using System.Data.OleDb .Net class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.FieldReadOnly (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldReadOnly (System.Int32) Method
See Also

Gets if column data can be written.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldReadOnly( _
   ByVal Index As Integer _
) As Boolean
C#
public bool FieldReadOnly(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldReadOnly (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldReadOnly (System.String) Method
See Also

Gets if column data can be written.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldReadOnly( _
   ByVal Name As String _
) As Boolean
C#
public bool FieldReadOnly(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldType (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldType (System.Int32) Method
See Also

Gets the data type of field. See DataTypeEnum enumeration for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldType( _
   ByVal Index As Integer _
) As DataTypeEnum
C#
public DataTypeEnum FieldType(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldType (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldType (System.String) Method
See Also

Gets the data type of field. See DataTypeEnum enumeration for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldType( _
   ByVal Name As String _
) As DataTypeEnum
C#
public DataTypeEnum FieldType(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldUnique (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldUnique (System.Int32) Method
See Also

If it's true two rows of data can't have the same value in this column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldUnique( _
   ByVal Index As Integer _
) As Boolean
C#
public bool FieldUnique(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldUnique (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldUnique (System.String) Method
See Also

If it's true two rows of data can't have the same value in this column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldUnique( _
   ByVal Name As String _
) As Boolean
C#
public bool FieldUnique(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldValueType (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldValueType (System.Int32) Method
See Also

Gets System.Type of field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldValueType( _
   ByVal Index As Integer _
) As Type
C#
public Type FieldValueType(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldValueType (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldValueType (System.String) Method
See Also

Gets System.Type of field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldValueType( _
   ByVal Name As String _
) As Type
C#
public Type FieldValueType(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBoolean (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetBoolean (System.Int32) Method
See Also

Gets a Boolean value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBoolean( _
   ByVal Index As Integer _
) As Boolean
C#
public bool GetBoolean(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBoolean (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetBoolean (System.String) Method
See Also

Gets a Boolean value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBoolean( _
   ByVal Name As String _
) As Boolean
C#
public bool GetBoolean(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBoolean (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetBoolean (System.Int32, System.Int32) Method
See Also

Gets a Boolean value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBoolean( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Boolean
C#
public bool GetBoolean(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBoolean (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetBoolean (System.Int32, System.String) Method
See Also

Gets a Boolean value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBoolean( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Boolean
C#
public bool GetBoolean(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.ConnectionStringDriver Method

[image] [image] [image]

NetData Reference
Connection.ConnectionStringDriver Method
See Also

Gets the native connection string used by the underline driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionStringDriver() As String
C#
public string ConnectionStringDriver()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.GetByte (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetByte (System.Int32) Method
See Also

Gets a Byte value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetByte( _
   ByVal Index As Integer _
) As Byte
C#
public byte GetByte(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetByte (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetByte (System.String) Method
See Also

Gets a Byte value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetByte( _
   ByVal Name As String _
) As Byte
C#
public byte GetByte(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetByte (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetByte (System.Int32, System.Int32) Method
See Also

Gets a Byte value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetByte( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Byte
C#
public byte GetByte(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetByte (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetByte (System.Int32, System.String) Method
See Also

Gets a Byte value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetByte( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Byte
C#
public byte GetByte(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBytes (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetBytes (System.Int32) Method
See Also

Gets a Byte array values of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBytes( _
   ByVal Index As Integer _
) As Byte()
C#
public byte[] GetBytes(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBytes (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetBytes (System.String) Method
See Also

Gets a Byte array values of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBytes( _
   ByVal Name As String _
) As Byte()
C#
public byte[] GetBytes(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBytes (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetBytes (System.Int32, System.Int32) Method
See Also

Gets a Byte array values of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBytes( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Byte()
C#
public byte[] GetBytes(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetBytes (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetBytes (System.Int32, System.String) Method
See Also

Gets a Byte array values of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetBytes( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Byte()
C#
public byte[] GetBytes(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChar (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetChar (System.Int32) Method
See Also

Gets a Char value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChar( _
   ByVal Index As Integer _
) As Char
C#
public char GetChar(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChar (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetChar (System.String) Method
See Also

Gets a Char value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChar( _
   ByVal Name As String _
) As Char
C#
public char GetChar(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChar (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetChar (System.Int32, System.Int32) Method
See Also

Gets a Char value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChar( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Char
C#
public char GetChar(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChar (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetChar (System.Int32, System.String) Method
See Also

Gets a Char value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChar( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Char
C#
public char GetChar(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChars (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetChars (System.Int32) Method
See Also

Gets a Char array values of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChars( _
   ByVal Index As Integer _
) As Char()
C#
public char[] GetChars(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChars (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetChars (System.String) Method
See Also

Gets a Char array values of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChars( _
   ByVal Name As String _
) As Char()
C#
public char[] GetChars(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChars (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetChars (System.Int32, System.Int32) Method
See Also

Gets a Char array values of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChars( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Char()
C#
public char[] GetChars(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetChars (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetChars (System.Int32, System.String) Method
See Also

Gets a Char array values of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetChars( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Char()
C#
public char[] GetChars(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.ConnectionStringDriver (System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.ConnectionStringDriver (System.Boolean) Method
See Also

Gets the native connection string used by the underline driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionStringDriver( _
   ByVal bPersistSecurityInfo As Boolean _
) As String
C#
public string ConnectionStringDriver(
   bool bPersistSecurityInfo
)

Parameters

bPersistSecurityInfo

Type: bool

Boolean value that indicate if User Name and Password must be saved in the list of parameters.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.GetDate (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDate (System.Int32) Method
See Also

Gets a Date value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDate( _
   ByVal Index As Integer _
) As Date
C#
public DateTime GetDate(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDate (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDate (System.String) Method
See Also

Gets a Date value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDate( _
   ByVal Name As String _
) As Date
C#
public DateTime GetDate(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDate (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDate (System.Int32, System.Int32) Method
See Also

Gets a Date value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDate( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Date
C#
public DateTime GetDate(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDate (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDate (System.Int32, System.String) Method
See Also

Gets a Date value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDate( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Date
C#
public DateTime GetDate(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateText (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateText (System.Int32) Method
See Also

Gets the string value of a DateTime field type in the system date short format for the current record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateText( _
   ByVal Index As Integer _
) As String
C#
public string GetDateText(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateText (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateText (System.String) Method
See Also

Gets the string value of a DateTime field type in the system date short format for the current record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateText( _
   ByVal Name As String _
) As String
C#
public string GetDateText(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateText (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateText (System.Int32, System.Int32) Method
See Also

Gets the string value of a DateTime field type in the system date short format for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateText( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As String
C#
public string GetDateText(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateText (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateText (System.Int32, System.String) Method
See Also

Gets the string value of a DateTime field type in the system date short format for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateText( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As String
C#
public string GetDateText(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateTimeText (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateTimeText (System.Int32) Method
See Also

Gets the string value of a DateTime field type in the system datetime short format for the current record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateTimeText( _
   ByVal Index As Integer _
) As String
C#
public string GetDateTimeText(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateTimeText (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateTimeText (System.String) Method
See Also

Gets the string value of a DateTime field type in the system datetime short format for the current record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateTimeText( _
   ByVal Name As String _
) As String
C#
public string GetDateTimeText(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateTimeText (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateTimeText (System.Int32, System.Int32) Method
See Also

Gets the string value of a DateTime field type in the system datetime short format for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateTimeText( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As String
C#
public string GetDateTimeText(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDateTimeText (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDateTimeText (System.Int32, System.String) Method
See Also

Gets the string value of a DateTime field type in the system datetime short format for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDateTimeText( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As String
C#
public string GetDateTimeText(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDecimal (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDecimal (System.Int32) Method
See Also

Gets a Decimal value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDecimal( _
   ByVal Index As Integer _
) As Decimal
C#
public decimal GetDecimal(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDecimal (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDecimal (System.String) Method
See Also

Gets a Decimal value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDecimal( _
   ByVal Name As String _
) As Decimal
C#
public decimal GetDecimal(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDecimal (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDecimal (System.Int32, System.Int32) Method
See Also

Gets a Decimal value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDecimal( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Decimal
C#
public decimal GetDecimal(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDecimal (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDecimal (System.Int32, System.String) Method
See Also

Gets a Decimal value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDecimal( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Decimal
C#
public decimal GetDecimal(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.CounterValue (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.CounterValue (System.String, System.String) Method
See Also

Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValue( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Integer
C#
public int CounterValue(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

Return Value

Return the next counter value or 0 on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.GetDouble (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDouble (System.Int32) Method
See Also

Gets a Double value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDouble( _
   ByVal Index As Integer _
) As Double
C#
public double GetDouble(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDouble (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDouble (System.String) Method
See Also

Gets a Double value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDouble( _
   ByVal Name As String _
) As Double
C#
public double GetDouble(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDouble (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetDouble (System.Int32, System.Int32) Method
See Also

Gets a Double value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDouble( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Double
C#
public double GetDouble(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetDouble (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetDouble (System.Int32, System.String) Method
See Also

Gets a Double value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDouble( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Double
C#
public double GetDouble(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetFieldsValues Method

[image] [image] [image]

NetData Reference
Recordset.GetFieldsValues Method
See Also

Return a FieldsValues object from this recordset
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetFieldsValues() As FieldsValues
C#
public FieldsValues GetFieldsValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetFieldsValues (System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.GetFieldsValues (System.Boolean) Method
See Also

Return a FieldsValues object from this recordset
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetFieldsValues( _
   ByVal bCurrentRecordOnly As Boolean _
) As FieldsValues
C#
public FieldsValues GetFieldsValues(
   bool bCurrentRecordOnly
)

Parameters

bCurrentRecordOnly

Type: bool

Copy only current record values from recordset to FieldsValues collection

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetGuid (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetGuid (System.Int32) Method
See Also

Gets a Guid value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetGuid( _
   ByVal Index As Integer _
) As Guid
C#
public Guid GetGuid(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetGuid (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetGuid (System.String) Method
See Also

Gets a Guid value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetGuid( _
   ByVal Name As String _
) As Guid
C#
public Guid GetGuid(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetGuid (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetGuid (System.Int32, System.Int32) Method
See Also

Gets a Guid value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetGuid( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Guid
C#
public Guid GetGuid(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetGuid (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetGuid (System.Int32, System.String) Method
See Also

Gets a Guid value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetGuid( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Guid
C#
public Guid GetGuid(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetInteger (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetInteger (System.Int32) Method
See Also

Gets a Integer value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetInteger( _
   ByVal Index As Integer _
) As Integer
C#
public int GetInteger(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetInteger (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetInteger (System.String) Method
See Also

Gets a Integer value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetInteger( _
   ByVal Name As String _
) As Integer
C#
public int GetInteger(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetInteger (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetInteger (System.Int32, System.Int32) Method
See Also

Gets a Integer value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetInteger( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Integer
C#
public int GetInteger(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetInteger (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetInteger (System.Int32, System.String) Method
See Also

Gets a Integer value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetInteger( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Integer
C#
public int GetInteger(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetLong (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetLong (System.Int32) Method
See Also

Gets a Long value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetLong( _
   ByVal Index As Integer _
) As Long
C#
public long GetLong(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetLong (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetLong (System.String) Method
See Also

Gets a Long value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetLong( _
   ByVal Name As String _
) As Long
C#
public long GetLong(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.CounterValue (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.CounterValue (System.String, System.String, System.String) Method
See Also

Return the next counter value of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValue( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal WhereClause As String _
) As Integer
C#
public int CounterValue(
   string TableName,
   string FieldName,
   string WhereClause
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

WhereClause

Type: string

A WHERE clause used to filter records.

Return Value

Return the next counter value or 0 on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.GetLong (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetLong (System.Int32, System.Int32) Method
See Also

Gets a Long value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetLong( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Long
C#
public long GetLong(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetLong (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetLong (System.Int32, System.String) Method
See Also

Gets a Long value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetLong( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Long
C#
public long GetLong(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetShort (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetShort (System.Int32) Method
See Also

Gets a Short value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetShort( _
   ByVal Index As Integer _
) As Short
C#
public short GetShort(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetShort (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetShort (System.String) Method
See Also

Gets a Short value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetShort( _
   ByVal Name As String _
) As Short
C#
public short GetShort(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetShort (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetShort (System.Int32, System.Int32) Method
See Also

Gets a Short value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetShort( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Short
C#
public short GetShort(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetShort (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetShort (System.Int32, System.String) Method
See Also

Gets a Short value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetShort( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Short
C#
public short GetShort(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetSingle (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetSingle (System.Int32) Method
See Also

Gets a Single value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSingle( _
   ByVal Index As Integer _
) As Single
C#
public float GetSingle(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetSingle (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetSingle (System.String) Method
See Also

Gets a Single value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSingle( _
   ByVal Name As String _
) As Single
C#
public float GetSingle(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetSingle (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetSingle (System.Int32, System.Int32) Method
See Also

Gets a Single value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSingle( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Single
C#
public float GetSingle(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetSingle (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetSingle (System.Int32, System.String) Method
See Also

Gets a Single value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSingle( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Single
C#
public float GetSingle(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetString (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetString (System.Int32) Method
See Also

Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetString( _
   ByVal Index As Integer _
) As String
C#
public string GetString(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetString (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetString (System.String) Method
See Also

Gets a String value of specified field for the current record. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetString( _
   ByVal Name As String _
) As String
C#
public string GetString(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetString (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetString (System.Int32, System.Int32) Method
See Also

Gets a String value of specified field for the specified record position. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetString( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As String
C#
public string GetString(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetString (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetString (System.Int32, System.String) Method
See Also

Gets a String value of specified field for the specified record position. Null values will be returned as an empty string. Floating point values is returned with system decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetString( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As String
C#
public string GetString(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32) Method
See Also

Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal Index As Integer _
) As String
C#
public string GetText(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32, System.Boolean) Method
See Also

Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal Index As Integer, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string GetText(
   int Index,
   bool FullDateTime
)

Parameters

Index

Type: int

Index of field

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.CounterValueLong (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.CounterValueLong (System.String, System.String) Method
See Also

Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValueLong( _
   ByVal TableName As String, _
   ByVal FieldName As String _
) As Long
C#
public long CounterValueLong(
   string TableName,
   string FieldName
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

Return Value

Return the next counter value or 0 on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.GetText (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.String) Method
See Also

Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal Name As String _
) As String
C#
public string GetText(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.String, System.Boolean) Method
See Also

Gets the current value of the field as string. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal Name As String, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string GetText(
   string Name,
   bool FullDateTime
)

Parameters

Name

Type: string

Name of field

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32, System.Int32) Method
See Also

Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As String
C#
public string GetText(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32, System.Int32, System.Boolean) Method
See Also

Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string GetText(
   int iPosition,
   int Index,
   bool FullDateTime
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32, System.String) Method
See Also

Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As String
C#
public string GetText(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetText (System.Int32, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.GetText (System.Int32, System.String, System.Boolean) Method
See Also

Gets the current value of the field as string for the specified record position. Null values will be returned as an empty string. Floating point values is returned with "." decimal separator character.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetText( _
   ByVal iPosition As Integer, _
   ByVal Name As String, _
   ByVal FullDateTime As Boolean _
) As String
C#
public string GetText(
   int iPosition,
   string Name,
   bool FullDateTime
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTime (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetTime (System.Int32) Method
See Also

Gets a TimeSpan value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTime( _
   ByVal Index As Integer _
) As TimeSpan
C#
public TimeSpan GetTime(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTime (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetTime (System.String) Method
See Also

Gets a TimeSpan value of specified field for the current record
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTime( _
   ByVal Name As String _
) As TimeSpan
C#
public TimeSpan GetTime(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTime (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetTime (System.Int32, System.Int32) Method
See Also

Gets a TimeSpan value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTime( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As TimeSpan
C#
public TimeSpan GetTime(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTime (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetTime (System.Int32, System.String) Method
See Also

Gets a TimeSpan value of specified field for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTime( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As TimeSpan
C#
public TimeSpan GetTime(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTimeText (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetTimeText (System.Int32) Method
See Also

Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTimeText( _
   ByVal Index As Integer _
) As String
C#
public string GetTimeText(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTimeText (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetTimeText (System.String) Method
See Also

Gets the current string value of a TimeSpan field type in the format HH:MM:SS.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTimeText( _
   ByVal Name As String _
) As String
C#
public string GetTimeText(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTimeText (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetTimeText (System.Int32, System.Int32) Method
See Also

Gets the string value of a TimeSpan field type in the format HH:MM:SS for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTimeText( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As String
C#
public string GetTimeText(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetTimeText (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetTimeText (System.Int32, System.String) Method
See Also

Gets the string value of a TimeSpan field type in the format HH:MM:SS for specified record position.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTimeText( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As String
C#
public string GetTimeText(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValue (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetValue (System.Int32) Method
See Also

Gets the value of specified field in the current record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal Index As Integer _
) As Object
C#
public object GetValue(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValue (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetValue (System.String) Method
See Also

Gets the value of specified field in the current record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal Name As String _
) As Object
C#
public object GetValue(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.DatabaseCreate (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String, System.Boolean) Method
See Also

Create the specified database and optionally open the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String, _
   ByVal OpenConnection As Boolean _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName,
   bool OpenConnection
)

Parameters

DBName

Type: string

Name of database to create.

OpenConnection

Type: bool

If True create database and open the connection to new database or False create database and maintain current database connection.

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create a unicode database.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DataShared.RecValid Method

[image] [image] [image]

NetData Reference
DataShared.RecValid Method

Check is a Recordset object is valid. A Recordset object is not valid if variable is Nothing or BOF property is True of EOF property is True.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function RecValid( _
   ByVal oRecordset As Recordset _
) As Boolean
C#
public static bool RecValid(
   Recordset oRecordset
)

Parameters

oRecordset

Type: Recordset

An object of type Recordset.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlValueExpression (System.Object, Softgroup.NetData.DataTypeEnum) Method

[image] [image] [image]

NetData Reference
DataShared.SqlValueExpression (System.Object, Softgroup.NetData.DataTypeEnum) Method

Return the expression for specified value that can be used in the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlValueExpression( _
   ByVal FieldValue As Object, _
   ByVal FieldType As DataTypeEnum _
) As String
C#
public static string SqlValueExpression(
   object FieldValue,
   DataTypeEnum FieldType
)

Parameters

FieldValue

Type: object

Value or field.

FieldType

Type: DataTypeEnum

Typpe of value. See DataTypeEnum for more details.

Expand image Remarks

Binary fields type are not supported

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlValueExpression (System.Object, Softgroup.NetData.DataTypeEnum, System.Boolean) Method

[image] [image] [image]

NetData Reference
DataShared.SqlValueExpression (System.Object, Softgroup.NetData.DataTypeEnum, System.Boolean) Method

Return the expression for specified value that can be used in the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlValueExpression( _
   ByVal FieldValue As Object, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FullDateTime As Boolean _
) As String
C#
public static string SqlValueExpression(
   object FieldValue,
   DataTypeEnum FieldType,
   bool FullDateTime
)

Parameters

FieldValue

Type: object

Value or field.

FieldType

Type: DataTypeEnum

Typpe of value. See DataTypeEnum for more details.

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Remarks

Binary fields type are not supported

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object) Method

[image] [image] [image]

NetData Reference
DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object) Method

Return the comparison expression that can assigned to the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlWhereExpression( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object _
) As String
C#
public static string SqlWhereExpression(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String) Method

Return the comparison expression that can assigned to the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlWhereExpression( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String _
) As String
C#
public static string SqlWhereExpression(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean) Method

Return the comparison expression that can assigned to the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlWhereExpression( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String, _
   ByVal CheckNull As Boolean _
) As String
C#
public static string SqlWhereExpression(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType,
   bool CheckNull
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

CheckNull

Type: bool

True if expression must include check for null values

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
DataShared.SqlWhereExpression (System.String, Softgroup.NetData.DataTypeEnum, System.Object, System.String, System.Boolean, System.Boolean) Method

Return the comparison expression that can assigned to the RowFilter property of DataView object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function SqlWhereExpression( _
   ByVal sExpression As String, _
   ByVal FieldType As DataTypeEnum, _
   ByVal FieldValue As Object, _
   ByVal OperatorType As String, _
   ByVal CheckNull As Boolean, _
   ByVal FullDateTime As Boolean _
) As String
C#
public static string SqlWhereExpression(
   string sExpression,
   DataTypeEnum FieldType,
   object FieldValue,
   string OperatorType,
   bool CheckNull,
   bool FullDateTime
)

Parameters

sExpression

Type: string

Name of field or expression

FieldType

Type: DataTypeEnum

Type of field value. See DataTypeEnum for more details.

FieldValue

Type: object

Field value or expression to compare.

OperatorType

Type: string

String Operator to use in the comparison For example =, >, <, <>, >=, <= etc.

CheckNull

Type: bool

True if expression must include check for null values

FullDateTime

Type: bool

Date-time values should also take account of the time part (not only date part)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetFilter Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetFilter Method

Sets filter expression of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetFilter( _
   ByVal oDataTable As DataTable, _
   ByVal sFilter As String _
)
C#
public static System.Void DataTableSetFilter(
   DataTable oDataTable,
   string sFilter
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

sFilter

Type: string

Filter expression string

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableGetPrimaryKey Method

[image] [image] [image]

NetData Reference
DataShared.DataTableGetPrimaryKey Method

Sets a DataColumn array that rappresent columns of primary key for specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DataTableGetPrimaryKey( _
   ByVal oDataTable As DataTable _
) As DataColumn()
C#
public static DataColumn[] DataTableGetPrimaryKey(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String) Method

Sets the primary key columns of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetPrimaryKey( _
   ByVal oDataTable As DataTable, _
   ByVal ColName As String _
)
C#
public static System.Void DataTableSetPrimaryKey(
   DataTable oDataTable,
   string ColName
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName

Type: string

Column name of primary key

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String) Method

Sets the primary key columns of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetPrimaryKey( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String _
)
C#
public static System.Void DataTableSetPrimaryKey(
   DataTable oDataTable,
   string ColName1,
   string ColName2
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First column name of primary key

ColName2

Type: string

Second column name of primary key

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String) Method

Sets the primary key columns of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetPrimaryKey( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String _
)
C#
public static System.Void DataTableSetPrimaryKey(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First column name of primary key

ColName2

Type: string

Second column name of primary key

ColName3

Type: string

Third column name of primary key

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String, System.String) Method

Sets the primary key columns of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetPrimaryKey( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String, _
   ByVal ColName4 As String _
)
C#
public static System.Void DataTableSetPrimaryKey(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3,
   string ColName4
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First column name of primary key

ColName2

Type: string

Second column name of primary key

ColName3

Type: string

Third column name of primary key

ColName4

Type: string

Fourth column name of primary key

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetPrimaryKey (System.Data.DataTable, System.String, System.String, System.String, System.String, System.String) Method

Sets the primary key columns of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetPrimaryKey( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String, _
   ByVal ColName4 As String, _
   ByVal ColName5 As String _
)
C#
public static System.Void DataTableSetPrimaryKey(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3,
   string ColName4,
   string ColName5
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First column name of primary key

ColName2

Type: string

Second column name of primary key

ColName3

Type: string

Third column name of primary key

ColName4

Type: string

Fourth column name of primary key

ColName5

Type: string

Fifth column name of primary key

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetSort (System.Data.DataTable, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetSort (System.Data.DataTable, System.String) Method

Sets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetSort( _
   ByVal oDataTable As DataTable, _
   ByVal ColName As String _
)
C#
public static System.Void DataTableSetSort(
   DataTable oDataTable,
   string ColName
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName

Type: string

Sort column name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String) Method

Sets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetSort( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String _
)
C#
public static System.Void DataTableSetSort(
   DataTable oDataTable,
   string ColName1,
   string ColName2
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First sort column name

ColName2

Type: string

Second sort column name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


Connection.DatabaseCreate (System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String, System.String, System.Boolean) Method
See Also

Create the specified database and optionally open the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String, _
   ByVal DBSystem As String, _
   ByVal OpenConnection As Boolean _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName,
   string DBSystem,
   bool OpenConnection
)

Parameters

DBName

Type: string

Name of database to create.

DBSystem

Type: string

Name of system database to use.

OpenConnection

Type: bool

If True create database and open the connection to new database or False create database and maintain current database connection.

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create a unicode database.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String) Method

Sets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetSort( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String _
)
C#
public static System.Void DataTableSetSort(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First sort column name

ColName2

Type: string

Second sort column name

ColName3

Type: string

Third sort column name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String, System.String) Method

Sets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetSort( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String, _
   ByVal ColName4 As String _
)
C#
public static System.Void DataTableSetSort(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3,
   string ColName4
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First sort column name

ColName2

Type: string

Second sort column name

ColName3

Type: string

Third sort column name

ColName4

Type: string

Fourth sort column name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableSetSort (System.Data.DataTable, System.String, System.String, System.String, System.String, System.String) Method

Sets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Sub DataTableSetSort( _
   ByVal oDataTable As DataTable, _
   ByVal ColName1 As String, _
   ByVal ColName2 As String, _
   ByVal ColName3 As String, _
   ByVal ColName4 As String, _
   ByVal ColName5 As String _
)
C#
public static System.Void DataTableSetSort(
   DataTable oDataTable,
   string ColName1,
   string ColName2,
   string ColName3,
   string ColName4,
   string ColName5
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

ColName1

Type: string

First sort column name

ColName2

Type: string

Second sort column name

ColName3

Type: string

Third sort column name

ColName4

Type: string

Fourth sort column name

ColName5

Type: string

Fifth sort column name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String, System.String) Method

Get the connection string using provider specific parameters and using best available driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionString( _
   ByVal eProviderType As ProviderTypeEnum, _
   ByVal sServerName As String, _
   ByVal sDatabaseName As String, _
   ByVal sUserName As String, _
   ByVal sPassword As String _
) As String
C#
public static string GetConnectionString(
   ProviderTypeEnum eProviderType,
   string sServerName,
   string sDatabaseName,
   string sUserName,
   string sPassword
)

Parameters

eProviderType

Type: ProviderTypeEnum

The provider type

sServerName

Type: string

Server or host name

sDatabaseName

Type: string

Database Name (must include full path/file name if required by provider)

sUserName

Type: string

User name

sPassword

Type: string

Password

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String, System.String, System.Boolean) Method

Get the connection string using provider specific parameters and using best available driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionString( _
   ByVal eProviderType As ProviderTypeEnum, _
   ByVal sServerName As String, _
   ByVal sDatabaseName As String, _
   ByVal sUserName As String, _
   ByVal sPassword As String, _
   ByVal bOSAuthentication As Boolean _
) As String
C#
public static string GetConnectionString(
   ProviderTypeEnum eProviderType,
   string sServerName,
   string sDatabaseName,
   string sUserName,
   string sPassword,
   bool bOSAuthentication
)

Parameters

eProviderType

Type: ProviderTypeEnum

The provider type

sServerName

Type: string

Server or host name

sDatabaseName

Type: string

Database Name (must include full path/file name if required by provider)

sUserName

Type: string

User name

sPassword

Type: string

Password

bOSAuthentication

Type: bool

True if OS Authentication must be used

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.String) Method

Get the connection string using provider specific parameters and using best available driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionString( _
   ByVal eProviderType As ProviderTypeEnum, _
   ByVal sDatabaseName As String, _
   ByVal sUserName As String, _
   ByVal sPassword As String _
) As String
C#
public static string GetConnectionString(
   ProviderTypeEnum eProviderType,
   string sDatabaseName,
   string sUserName,
   string sPassword
)

Parameters

eProviderType

Type: ProviderTypeEnum

The provider type

sDatabaseName

Type: string

Database Name (must include full path/file name if required by provider)

sUserName

Type: string

User name

sPassword

Type: string

Password

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.Boolean, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
DataShared.GetConnectionString (Softgroup.NetData.ProviderTypeEnum, System.String, System.String, System.Boolean, System.String, System.String, System.Boolean) Method

Get the connection string using provider specific parameters and using best available driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function GetConnectionString( _
   ByVal eProviderType As ProviderTypeEnum, _
   ByVal sServerName As String, _
   ByVal sDatabaseName As String, _
   ByVal bSystemDatabase As Boolean, _
   ByVal sUserName As String, _
   ByVal sPassword As String, _
   ByVal bOSAuthentication As Boolean _
) As String
C#
public static string GetConnectionString(
   ProviderTypeEnum eProviderType,
   string sServerName,
   string sDatabaseName,
   bool bSystemDatabase,
   string sUserName,
   string sPassword,
   bool bOSAuthentication
)

Parameters

eProviderType

Type: ProviderTypeEnum

The provider type

sServerName

Type: string

Server or host name

sDatabaseName

Type: string

Database Name (must include full path/file name if required by provider)

bSystemDatabase

Type: bool

True to use default system database (required only by Access provider: system.mdw)

sUserName

Type: string

User name

sPassword

Type: string

Password

bOSAuthentication

Type: bool

True if OS Authentication must be used

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


Connection.DatabaseCreate (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String, System.String, System.String) Method
See Also

Create the specified database and optionally open the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String, _
   ByVal DBSystem As String, _
   ByVal DBPassword As String _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName,
   string DBSystem,
   string DBPassword
)

Parameters

DBName

Type: string

Name of database to create.

DBSystem

Type: string

Name of system database to use.

DBPassword

Type: string

Database Password supported (only by Microsoft JET OLEDB Provider).

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create a unicode database.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseCreate (System.String, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String, System.String, System.String, System.Boolean) Method
See Also

Create the specified database and optionally open the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String, _
   ByVal DBSystem As String, _
   ByVal DBPassword As String, _
   ByVal OpenConnection As Boolean _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName,
   string DBSystem,
   string DBPassword,
   bool OpenConnection
)

Parameters

DBName

Type: string

Name of database to create.

DBSystem

Type: string

Name of system database to use.

DBPassword

Type: string

Database Password supported (only by Microsoft JET OLEDB Provider).

OpenConnection

Type: bool

If True create database and open the connection to new database or False create database and maintain current database connection.

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create a unicode database.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogBackup (System.Windows.Forms.Form) Method

[image] [image] [image]

NetData Reference
Connection.DialogBackup (System.Windows.Forms.Form) Method
See Also

Display a dialog for the backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogBackup( _
   ByVal FrmOwner As Form _
) As Boolean
C#
public bool DialogBackup(
   Form FrmOwner
)

Parameters

FrmOwner

Type: Form

A variabile of type Systsem.Windows.Forms.Form for the parent window from wich display the dialog

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogBackup (System.Windows.Forms.Form, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DialogBackup (System.Windows.Forms.Form, System.String) Method
See Also

Display a dialog for the backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogBackup( _
   ByVal FrmOwner As Form, _
   ByVal DBName As String _
) As Boolean
C#
public bool DialogBackup(
   Form FrmOwner,
   string DBName
)

Parameters

FrmOwner

Type: Form

A variabile of type Systsem.Windows.Forms.Form for the parent window from wich display the dialog

DBName

Type: string

Name of database to Backup

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogBackup (System.Windows.Forms.Form, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DialogBackup (System.Windows.Forms.Form, System.String, System.String) Method
See Also

Display a dialog for the backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogBackup( _
   ByVal FrmOwner As Form, _
   ByVal DBName As String, _
   ByVal sFile As String _
) As Boolean
C#
public bool DialogBackup(
   Form FrmOwner,
   string DBName,
   string sFile
)

Parameters

FrmOwner

Type: Form

A variabile of type Systsem.Windows.Forms.Form for the parent window from wich display the dialog

DBName

Type: string

Name of database to Backup

sFile

Type: string

Default destination file name for the backup operation

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogConnect Method

[image] [image] [image]

NetData Reference
Connection.DialogConnect Method
See Also

Display a dialog for the connection to a database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogConnect() As Boolean
C#
public bool DialogConnect()

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogConnect (System.Windows.Forms.Form) Method

[image] [image] [image]

NetData Reference
Connection.DialogConnect (System.Windows.Forms.Form) Method
See Also

Display a dialog for the Connection to a database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogConnect( _
   ByVal FrmOwner As Form _
) As Boolean
C#
public bool DialogConnect(
   Form FrmOwner
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogConnect (System.Windows.Forms.Form, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DialogConnect (System.Windows.Forms.Form, System.Boolean) Method
See Also

Display a dialog for the Connection to a database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogConnect( _
   ByVal FrmOwner As Form, _
   ByVal CreateDatabaseMode As Boolean _
) As Boolean
C#
public bool DialogConnect(
   Form FrmOwner,
   bool CreateDatabaseMode
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

CreateDatabaseMode

Type: bool

Display a "Create Database" dialog not a "Connect Database Dialog"

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String) Method
See Also

Create a ForeignKey in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyCreate( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String, _
   ByVal ForeignKeyFields As String, _
   ByVal ReferenceTable As String _
) As Boolean
C#
public bool ForeignKeyCreate(
   string TableName,
   string ForeignKeyName,
   string ForeignKeyFields,
   string ReferenceTable
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of index to check

ForeignKeyFields

Type: string

List of fields in the ForeignKey table separated by a comma ","

ReferenceTable

Type: string

Name of references table

Return Value

Return True if success else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String) Method
See Also

Create a ForeignKey in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyCreate( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String, _
   ByVal ForeignKeyFields As String, _
   ByVal ReferenceTable As String, _
   ByVal ReferenceFields As String _
) As Boolean
C#
public bool ForeignKeyCreate(
   string TableName,
   string ForeignKeyName,
   string ForeignKeyFields,
   string ReferenceTable,
   string ReferenceFields
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of index to check

ForeignKeyFields

Type: string

List of fields in the ForeignKey table separated by a comma ","

ReferenceTable

Type: string

Name of references table

ReferenceFields

Type: string

List of fields in the ForeignKey of the references table separated by a comma ","

Return Value

Return True if success else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsGrant (Softgroup.NetData.PermissionObjectEnum, System.String) Method

[image] [image] [image]

NetData Reference
Connection.PermissionsGrant (Softgroup.NetData.PermissionObjectEnum, System.String) Method
See Also

Grant Permissions on specifed objects to Group/Users in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function PermissionsGrant( _
   ByVal ObjectType As PermissionObjectEnum, _
   ByVal ObjectName As String _
) As Boolean
C#
public bool PermissionsGrant(
   PermissionObjectEnum ObjectType,
   string ObjectName
)

Parameters

ObjectType

Type: PermissionObjectEnum

Type of object on which grant permissions (see PermissionObjectEnum for more details)

ObjectName

Type: string

Name of object on which grant permissions

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsGrant (Softgroup.NetData.PermissionObjectEnum, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.PermissionsGrant (Softgroup.NetData.PermissionObjectEnum, System.String, System.String) Method
See Also

Grant Permissions on specifed objects to Group/Users in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function PermissionsGrant( _
   ByVal ObjectType As PermissionObjectEnum, _
   ByVal ObjectName As String, _
   ByVal GroupUser As String _
) As Boolean
C#
public bool PermissionsGrant(
   PermissionObjectEnum ObjectType,
   string ObjectName,
   string GroupUser
)

Parameters

ObjectType

Type: PermissionObjectEnum

Type of object on which grant permissions (see PermissionObjectEnum for more details)

ObjectName

Type: string

Name of object on which grant permissions

GroupUser

Type: string

Name of group or user on which grant permissions. Use '*' to grant permissions to all users in the database.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsRevoke (Softgroup.NetData.PermissionObjectEnum, System.String) Method

[image] [image] [image]

NetData Reference
Connection.PermissionsRevoke (Softgroup.NetData.PermissionObjectEnum, System.String) Method
See Also

Revoke Permissions on specifed objects to Group/Users in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function PermissionsRevoke( _
   ByVal ObjectType As PermissionObjectEnum, _
   ByVal ObjectName As String _
) As Boolean
C#
public bool PermissionsRevoke(
   PermissionObjectEnum ObjectType,
   string ObjectName
)

Parameters

ObjectType

Type: PermissionObjectEnum

Type of object on which revoke permissions (see PermissionObjectEnum for more details)

ObjectName

Type: string

Name of object on which revoke permissions

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.PermissionsRevoke (Softgroup.NetData.PermissionObjectEnum, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.PermissionsRevoke (Softgroup.NetData.PermissionObjectEnum, System.String, System.String) Method
See Also

Revoke Permissions on specifed objects to Group/Users in the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function PermissionsRevoke( _
   ByVal ObjectType As PermissionObjectEnum, _
   ByVal ObjectName As String, _
   ByVal GroupUser As String _
) As Boolean
C#
public bool PermissionsRevoke(
   PermissionObjectEnum ObjectType,
   string ObjectName,
   string GroupUser
)

Parameters

ObjectType

Type: PermissionObjectEnum

Type of object on which revoke permissions (see PermissionObjectEnum for more details)

ObjectName

Type: string

Name of object on which revoke permissions

GroupUser

Type: string

Name of group or user on which revoke permissions. Use '*' to revoke permissions to all users in the database.

Return Value

Return True if succes else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDate (System.String, System.String, System.String, System.String, System.DateTime) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDate (System.String, System.String, System.String, System.String, System.DateTime) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDate( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Date _
) As Date
C#
public DateTime QueryFieldDate(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   DateTime DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: DateTime

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDate (System.String, System.String, System.String, System.String, System.DateTime, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDate (System.String, System.String, System.String, System.String, System.DateTime, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDate( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Date, _
   ByVal NoLock As Boolean _
) As Date
C#
public DateTime QueryFieldDate(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   DateTime DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: DateTime

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDecimal (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDecimal (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDecimal( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Decimal
C#
public decimal QueryFieldDecimal(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDecimal( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Decimal
C#
public decimal QueryFieldDecimal(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String, System.Decimal) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String, System.Decimal) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDecimal( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Decimal _
) As Decimal
C#
public decimal QueryFieldDecimal(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   decimal DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: decimal

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String, System.Decimal, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDecimal (System.String, System.String, System.String, System.String, System.Decimal, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDecimal( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Decimal, _
   ByVal NoLock As Boolean _
) As Decimal
C#
public decimal QueryFieldDecimal(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   decimal DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: decimal

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldLong (System.String, System.String, System.String, System.String, System.Int64) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldLong (System.String, System.String, System.String, System.String, System.Int64) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldLong( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Long _
) As Long
C#
public long QueryFieldLong(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   long DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: long

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldLong (System.String, System.String, System.String, System.String, System.Int64, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldLong (System.String, System.String, System.String, System.String, System.Int64, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldLong( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Long, _
   ByVal NoLock As Boolean _
) As Long
C#
public long QueryFieldLong(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   long DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: long

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldObject (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldObject (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldObject( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Object
C#
public object QueryFieldObject(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldObject (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldObject (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldObject( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Object
C#
public object QueryFieldObject(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldObject (System.String, System.String, System.String, System.String, System.Object) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldObject (System.String, System.String, System.String, System.String, System.Object) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldObject( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Object _
) As Object
C#
public object QueryFieldObject(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   object DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: object

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldObject (System.String, System.String, System.String, System.String, System.Object, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldObject (System.String, System.String, System.String, System.String, System.Object, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldObject( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Object, _
   ByVal NoLock As Boolean _
) As Object
C#
public object QueryFieldObject(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   object DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: object

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldString (System.String, System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldString (System.String, System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldString( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As String _
) As String
C#
public string QueryFieldString(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   string DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: string

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldString (System.String, System.String, System.String, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldString (System.String, System.String, System.String, System.String, System.String, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldString( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As String, _
   ByVal NoLock As Boolean _
) As String
C#
public string QueryFieldString(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   string DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: string

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldTime (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldTime (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldTime( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As TimeSpan
C#
public TimeSpan QueryFieldTime(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldTime (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldTime (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldTime( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As TimeSpan
C#
public TimeSpan QueryFieldTime(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldTime (System.String, System.String, System.String, System.String, System.TimeSpan) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldTime (System.String, System.String, System.String, System.String, System.TimeSpan) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldTime( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As TimeSpan _
) As TimeSpan
C#
public TimeSpan QueryFieldTime(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   TimeSpan DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: TimeSpan

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldTime (System.String, System.String, System.String, System.String, System.TimeSpan, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldTime (System.String, System.String, System.String, System.String, System.TimeSpan, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldTime( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As TimeSpan, _
   ByVal NoLock As Boolean _
) As TimeSpan
C#
public TimeSpan QueryFieldTime(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   TimeSpan DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: TimeSpan

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Constructor (System.String)

[image] [image] [image]

NetData Reference
Connection Constructor (System.String)
See Also

Create new instance of Connection object and open connection with specified connection string.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sConnectionString As String _
)
C#
public Connection(
   string sConnectionString
)

Parameters

sConnectionString

Type: string

A valid connection string

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection Constructor (Softgroup.NetData.ConnectionStringBuild)

[image] [image] [image]

NetData Reference
Connection Constructor (Softgroup.NetData.ConnectionStringBuild)
See Also

Create new instance of Connection object and open connection with specified ConnectionStringBuild object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnectionStringBuild As ConnectionStringBuild _
)
C#
public Connection(
   ConnectionStringBuild oConnectionStringBuild
)

Parameters

oConnectionStringBuild

Type: ConnectionStringBuild

A valid ConnectionStringBuild object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


SQLSelect Constructor (Softgroup.NetData.Connection)

[image] [image] [image]

NetData Reference
SQLSelect Constructor (Softgroup.NetData.Connection)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection _
)
C#
public SQLSelect(
   Connection oConnection
)

Parameters

oConnection

Type: Connection

A Connection object type

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect Constructor (Softgroup.NetData.Connection, System.Boolean)

[image] [image] [image]

NetData Reference
SQLSelect Constructor (Softgroup.NetData.Connection, System.Boolean)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal bNoLock As Boolean _
)
C#
public SQLSelect(
   Connection oConnection,
   bool bNoLock
)

Parameters

oConnection

Type: Connection

A Connection object type

bNoLock

Type: bool

True if SQL statement must include keywords to force reading uncommetted records from tables

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Execute Method

[image] [image] [image]

NetData Reference
SQLSelect.Execute Method
See Also

Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute() As Recordset
C#
public Recordset Execute()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Execute (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.Execute (System.Boolean) Method
See Also

Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal bClientCursors As Boolean _
) As Recordset
C#
public Recordset Execute(
   bool bClientCursors
)

Parameters

bClientCursors

Type: bool

True to use client side cursors (default is True)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Execute (System.Boolean, System.Int32) Method

[image] [image] [image]

NetData Reference
SQLSelect.Execute (System.Boolean, System.Int32) Method
See Also

Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer _
) As Recordset
C#
public Recordset Execute(
   bool bClientCursors,
   int iMaxRecords
)

Parameters

bClientCursors

Type: bool

True to use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Execute (System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.Execute (System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method
See Also

Execute the SQL SELECT statement and return a Recordset object. See Recordset object for more details.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer, _
   ByVal bBindMode As Boolean _
) As Recordset
C#
public Recordset Execute(
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize,
   bool bBindMode
)

Parameters

bClientCursors

Type: bool

True to use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset.

bAsyncFetch

Type: bool

True to enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

bBindMode

Type: bool

Open Recordset for binding operations

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


DataReader.IsDBNull (System.Int32) Method

[image] [image] [image]

NetData Reference
DataReader.IsDBNull (System.Int32) Method
See Also

Gets a value that indicates whether the column contains nonexistent or missing values.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IsDBNull( _
   ByVal i As Integer _
) As Boolean
C#
public bool IsDBNull(
   int i
)

Parameters

i

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.IsDBNull (System.String) Method

[image] [image] [image]

NetData Reference
DataReader.IsDBNull (System.String) Method
See Also

Gets a value that indicates whether the column contains nonexistent or missing values.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IsDBNull( _
   ByVal Name As String _
) As Boolean
C#
public bool IsDBNull(
   string Name
)

Parameters

Name

Type: string

Name of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


SQLTables.Add (System.String, System.String) Method

[image] [image] [image]

NetData Reference
SQLTables.Add (System.String, System.String) Method
See Also

Add a table and optionally a join table to the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal TableName As String, _
   ByVal JoinTable As String _
) As SQLTable
C#
public SQLTable Add(
   string TableName,
   string JoinTable
)

Parameters

TableName

Type: string

Name of table to add

JoinTable

Type: string

Join table name

Return Value

Return a SQLTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.Add (System.String, System.String, Softgroup.NetData.JoinTypeEnum) Method

[image] [image] [image]

NetData Reference
SQLTables.Add (System.String, System.String, Softgroup.NetData.JoinTypeEnum) Method
See Also

Add a table and optionally a join table to the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal TableName As String, _
   ByVal JoinTable As String, _
   ByVal JoinType As JoinTypeEnum _
) As SQLTable
C#
public SQLTable Add(
   string TableName,
   string JoinTable,
   JoinTypeEnum JoinType
)

Parameters

TableName

Type: string

Name of table to add

JoinTable

Type: string

Join table name

JoinType

Type: JoinTypeEnum

This parameter identify the type of join between tables. See GaJoinsType for details. This parameter must be specified if JoinTable is not an empty string.

Return Value

Return a SQLTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


SQLTables.Add (System.String, System.String, Softgroup.NetData.JoinTypeEnum, System.String) Method

[image] [image] [image]

NetData Reference
SQLTables.Add (System.String, System.String, Softgroup.NetData.JoinTypeEnum, System.String) Method
See Also

Add a table and optionally a join table to the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal TableName As String, _
   ByVal JoinTable As String, _
   ByVal JoinType As JoinTypeEnum, _
   ByVal JoinFields As String _
) As SQLTable
C#
public SQLTable Add(
   string TableName,
   string JoinTable,
   JoinTypeEnum JoinType,
   string JoinFields
)

Parameters

TableName

Type: string

Name of table to add

JoinTable

Type: string

Join table name

JoinType

Type: JoinTypeEnum

This parameter identify the type of join between tables. See GaJoinsType for details. This parameter must be specified if JoinTable is not an empty string.

JoinFields

Type: string

This parameter is used to define join fields. Joins fields must have this syntax: TableName.FieldA = JoinTable.FieldB. Multiple join fields can be added in a unique string separated by a pipe character (|). This parameter must be specified if JoinTable is not an empty string.

Return Value

Return a SQLTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


Connection.Command (System.String) Method

[image] [image] [image]

NetData Reference
Connection.Command (System.String) Method
See Also

Obtain a Softgroup.NetData.Command from the Connection object. This method create a command of type CommandType.Text.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Command( _
   ByVal Source As String _
) As Command
C#
public Command Command(
   string Source
)

Parameters

Source

Type: string

SQL statement or Procedure or Table name associated to the Command object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


ConnectionStringBuild Constructor

[image] [image] [image]

NetData Reference
ConnectionStringBuild Constructor
See Also

Create a new instance of the class.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ConnectionStringBuild()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild Constructor (System.String, System.Boolean)

[image] [image] [image]

NetData Reference
ConnectionStringBuild Constructor (System.String, System.Boolean)
See Also

Create a new instance of the class for specified driver name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sDriverName As String, _
   ByVal bUnicode As Boolean _
)
C#
public ConnectionStringBuild(
   string sDriverName,
   bool bUnicode
)

Parameters

sDriverName

Type: string

Driver Name

bUnicode

Type: bool

True to enable unicode supports of Driver

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild Constructor (System.String, System.Boolean, System.String, System.String, System.String, System.String, System.String)

[image] [image] [image]

NetData Reference
ConnectionStringBuild Constructor (System.String, System.Boolean, System.String, System.String, System.String, System.String, System.String)
See Also

Create a new instance of the class with specified parameters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sDriverName As String, _
   ByVal bUnicode As Boolean, _
   ByVal sDataSource As String, _
   ByVal sDatabaseName As String, _
   ByVal sSystemDatabaseName As String, _
   ByVal sUserName As String, _
   ByVal sPassword As String _
)
C#
public ConnectionStringBuild(
   string sDriverName,
   bool bUnicode,
   string sDataSource,
   string sDatabaseName,
   string sSystemDatabaseName,
   string sUserName,
   string sPassword
)

Parameters

sDriverName

Type: string

Driver Name

bUnicode

Type: bool

Enable unicode support

sDataSource

Type: string

Data Source Name or DNS or Server Name

sDatabaseName

Type: string

Database name

sSystemDatabaseName

Type: string

System database name

sUserName

Type: string

User Name

sPassword

Type: string

User Password

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


ConnectionStringBuild Constructor (System.String, System.Boolean, System.String, System.String, System.String, System.String, System.String, System.Boolean)

[image] [image] [image]

NetData Reference
ConnectionStringBuild Constructor (System.String, System.Boolean, System.String, System.String, System.String, System.String, System.String, System.Boolean)
See Also

Create a new instance of the class with specified parameters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sDriverName As String, _
   ByVal bUnicode As Boolean, _
   ByVal sDataSource As String, _
   ByVal sDatabaseName As String, _
   ByVal sSystemDatabaseName As String, _
   ByVal sUserName As String, _
   ByVal sPassword As String, _
   ByVal bUseADO As Boolean _
)
C#
public ConnectionStringBuild(
   string sDriverName,
   bool bUnicode,
   string sDataSource,
   string sDatabaseName,
   string sSystemDatabaseName,
   string sUserName,
   string sPassword,
   bool bUseADO
)

Parameters

sDriverName

Type: string

Driver Name

bUnicode

Type: bool

Enable unicode support

sDataSource

Type: string

Data Source Name or DNS or Server Name

sDatabaseName

Type: string

Database name

sSystemDatabaseName

Type: string

System database name

sUserName

Type: string

User Name

sPassword

Type: string

User Password

bUseADO

Type: bool

Use Microsoft ADO

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

ConnectionStringBuild Class
ConnectionStringBuild Members


Connection.Command (System.String, System.Data.CommandType) Method

[image] [image] [image]

NetData Reference
Connection.Command (System.String, System.Data.CommandType) Method
See Also

Obtain a Softgroup.NetData.Command from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Command( _
   ByVal Source As String, _
   ByVal CmdType As CommandType _
) As Command
C#
public Command Command(
   string Source,
   CommandType CmdType
)

Parameters

Source

Type: string

SQL statement or Procedure or Table name associated to the Command object.

CmdType

Type: CommandType

Type of Command.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset Constructor (System.Data.DataTable)

[image] [image] [image]

NetData Reference
Recordset Constructor (System.Data.DataTable)
See Also

Create a new instance of a recordset from specified DataTable object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oDataTable As DataTable _
)
C#
public Recordset(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Constructor (Softgroup.NetData.Connection)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection)
See Also

Create a new instance of a Recordset object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection _
)
C#
public Recordset(
   Connection oConnection
)

Parameters

oConnection

Type: Connection

A valid Connection object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Constructor (Softgroup.NetData.Connection, System.String)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection, System.String)
See Also

Create a new instance of the class and open the recordset (see Open method for more details).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal sSource As String _
)
C#
public Recordset(
   Connection oConnection,
   string sSource
)

Parameters

oConnection

Type: Connection

A valid Connection object

sSource

Type: string

A valid SELECT SQL statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean)
See Also

Create a new instance of the class and open the recordset (see Open method for more details).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean _
)
C#
public Recordset(
   Connection oConnection,
   string sSource,
   bool bClientCursors
)

Parameters

oConnection

Type: Connection

A valid Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client cursors (True is default)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32)
See Also

Create a new instance of the class and open the recordset (see Open method for more details).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer _
)
C#
public Recordset(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords
)

Parameters

oConnection

Type: Connection

A valid Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client cursors (True is default)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value i 0 (all records).

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.ConnectionString Method

[image] [image] [image]

NetData Reference
Connection.ConnectionString Method
See Also

Gets the connection string used for establish the database connection. The returned string value can be used to re-open the connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ConnectionString() As String
C#
public string ConnectionString()

Return Value

Driver must be initialized using DriverInit method before collig this property.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.FieldAllowDBNull (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldAllowDBNull (System.String) Method
See Also

Gets if the field accept null values.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldAllowDBNull( _
   ByVal Name As String _
) As Boolean
C#
public bool FieldAllowDBNull(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldAutoIncrement (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldAutoIncrement (System.Int32) Method
See Also

Gets if the field is an autoincrement field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldAutoIncrement( _
   ByVal Index As Integer _
) As Boolean
C#
public bool FieldAutoIncrement(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldAutoIncrement (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldAutoIncrement (System.String) Method
See Also

Gets if the field is an autoincrement field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldAutoIncrement( _
   ByVal Name As String _
) As Boolean
C#
public bool FieldAutoIncrement(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldDefinedSize (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldDefinedSize (System.Int32) Method
See Also

Gets the maximum size in bytes of a field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldDefinedSize( _
   ByVal Index As Integer _
) As Integer
C#
public int FieldDefinedSize(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldDefinedSize (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldDefinedSize (System.String) Method
See Also

Gets the maximum size in bytes of a field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldDefinedSize( _
   ByVal Name As String _
) As Integer
C#
public int FieldDefinedSize(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Connection.CounterValueLong (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.CounterValueLong (System.String, System.String, System.String) Method
See Also

Return the next counter value (as Long) of a numeric field type (not associated to a custom counter or identity) of specified table in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CounterValueLong( _
   ByVal TableName As String, _
   ByVal FieldName As String, _
   ByVal WhereClause As String _
) As Long
C#
public long CounterValueLong(
   string TableName,
   string FieldName,
   string WhereClause
)

Parameters

TableName

Type: string

Name of table

FieldName

Type: string

Name of field. Only Integer numeric fields are supported.

WhereClause

Type: string

A WHERE clause used to filter records.

Return Value

Return the next counter value or 0 on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Recordset.ValueIsNull (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.ValueIsNull (System.Int32, System.Int32) Method
See Also

Return True if value of a field is Null value
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ValueIsNull( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Boolean
C#
public bool ValueIsNull(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.ValueIsNull (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.ValueIsNull (System.Int32, System.String) Method
See Also

Return True if value of a field is Null value
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ValueIsNull( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Boolean
C#
public bool ValueIsNull(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32) Method
See Also

Open the recordset for read operations in the associated connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer _
)
C#
public System.Void Open(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize
)

Parameters

oConnection

Type: Connection

A Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value is 0 (all records).

bAsyncFetch

Type: bool

True to enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

Expand image Remarks

Recordset object is writable (AddNew or Edit and Update methods) only if table used in SQL SELECT statements contains all fields of at least a Primary Key or Unique index. Data provider must returns also the correct base table name in case of SQL statements with tables aliases or joins.

SQL SELECT statement must have the syntax (supported by most databases):

SELECT [FROM] [WHERE] [GROUP BY] [HAVING] [ORDER BY]

Other specific-database sql syntax are not supported.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean) Method
See Also

Open the recordset for read operations in the associated connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer, _
   ByVal bFetchProgress As Boolean _
)
C#
public System.Void Open(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize,
   bool bFetchProgress
)

Parameters

oConnection

Type: Connection

A Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value is 0 (all records).

bAsyncFetch

Type: bool

True to enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

bFetchProgress

Type: bool

Enable progress of total number of records readed during asynchronous operations

Expand image Remarks

Recordset object is writable (AddNew or Edit and Update methods) only if table used in SQL SELECT statements contains all fields of at least a Primary Key or Unique index. Data provider must returns also the correct base table name in case of SQL statements with tables aliases or joins.

SQL SELECT statement must have the syntax (supported by most databases):

SELECT [FROM] [WHERE] [GROUP BY] [HAVING] [ORDER BY]

Other specific-database sql syntax are not supported.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Value (System.Int32) Property

[image] [image] [image]

NetData Reference
Recordset.Value (System.Int32) Property
See Also

Gets the value of specified field in the current record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Value( _
   ByVal Index As Integer _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Value")]
public object this[
   int Index
] {get;}

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Value (System.Int32, System.String) Property

[image] [image] [image]

NetData Reference
Recordset.Value (System.Int32, System.String) Property
See Also

Gets the value of specified field in the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Value( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Value")]
public object this[
   int iPosition,
   string Name
] {get;}

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Value (System.Int32, System.Int32) Property

[image] [image] [image]

NetData Reference
Recordset.Value (System.Int32, System.Int32) Property
See Also

Gets the value of specified field in the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Value( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Value")]
public object this[
   int iPosition,
   int Index
] {get;}

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Value (System.String) Property

[image] [image] [image]

NetData Reference
Recordset.Value (System.String) Property
See Also

Gets the value of specified field in the current record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Value( _
   ByVal Name As String _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Value")]
public object this[
   string Name
] {get;}

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Parameters.Add (System.Object) Method

[image] [image] [image]

NetData Reference
Parameters.Add (System.Object) Method
See Also

Adds a Parameter item to the Parameters collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal oParameter As Object _
)
C#
public System.Void Add(
   object oParameter
)

Parameters

oParameter

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType) Method

[image] [image] [image]

NetData Reference
Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType) Method
See Also

Add a new parameter object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal PName As String, _
   ByVal PDirection As ParameterDirection, _
   ByVal PType As DbType _
)
C#
public System.Void Add(
   string PName,
   ParameterDirection PDirection,
   DbType PType
)

Parameters

PName

Type: string

Parameter Name

PDirection

Type: ParameterDirection

Parameter Direction

PType

Type: DbType

Parameter Type

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType, System.Object) Method

[image] [image] [image]

NetData Reference
Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType, System.Object) Method
See Also

Add a new parameter object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal PName As String, _
   ByVal PDirection As ParameterDirection, _
   ByVal PType As DbType, _
   ByVal PValue As Object _
)
C#
public System.Void Add(
   string PName,
   ParameterDirection PDirection,
   DbType PType,
   object PValue
)

Parameters

PName

Type: string

Parameter Name

PDirection

Type: ParameterDirection

Parameter Direction

PType

Type: DbType

Parameter Type

PValue

Type: object

Parameter Value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType, System.Object, System.Int32) Method

[image] [image] [image]

NetData Reference
Parameters.Add (System.String, System.Data.ParameterDirection, System.Data.DbType, System.Object, System.Int32) Method
See Also

Add a new parameter object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal PName As String, _
   ByVal PDirection As ParameterDirection, _
   ByVal PType As DbType, _
   ByVal PValue As Object, _
   ByVal PSize As Integer _
)
C#
public System.Void Add(
   string PName,
   ParameterDirection PDirection,
   DbType PType,
   object PValue,
   int PSize
)

Parameters

PName

Type: string

Parameter Name

PDirection

Type: ParameterDirection

Parameter Direction

PType

Type: DbType

Parameter Type

PValue

Type: object

Parameter Value

PSize

Type: int

Size of parameter in bytes

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Connection.DatabaseBackup (System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseBackup (System.String) Method
See Also

Execute a Backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseBackup( _
   ByVal DBName As String _
) As Boolean
C#
public bool DatabaseBackup(
   string DBName
)

Parameters

DBName

Type: string

Name of database to Backup

Return Value

Return True if success or False for errors

Expand image Remarks

SQL databases perform backup operations with a path relative to server not to client application.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseBackup (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseBackup (System.String, System.String) Method
See Also

Execute a Backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseBackup( _
   ByVal DBName As String, _
   ByVal sDestination As String _
) As Boolean
C#
public bool DatabaseBackup(
   string DBName,
   string sDestination
)

Parameters

DBName

Type: string

Name of database to Backup

sDestination

Type: string

Destination file name for the backup operation.

Return Value

Return True if success or False for errors

Expand image Remarks

SQL databases perform backup operations with a path relative to server not to client application.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


SQLInsert Constructor

[image] [image] [image]

NetData Reference
SQLInsert Constructor
See Also

Create a new instance of the object (Init method must be called before using object)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SQLInsert()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert Constructor (Softgroup.NetData.Connection, System.String)

[image] [image] [image]

NetData Reference
SQLInsert Constructor (Softgroup.NetData.Connection, System.String)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public SQLInsert(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert Constructor (Softgroup.NetData.Connection, System.String, System.Boolean)

[image] [image] [image]

NetData Reference
SQLInsert Constructor (Softgroup.NetData.Connection, System.String, System.Boolean)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal TableName As String, _
   ByVal bDefaultValueNoDbNull As Boolean _
)
C#
public SQLInsert(
   Connection oConnection,
   string TableName,
   bool bDefaultValueNoDbNull
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

bDefaultValueNoDbNull

Type: bool

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Boolean)

[image] [image] [image]

NetData Reference
SQLInsert Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Boolean)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal TableName As String, _
   ByVal bDefaultValueNoDbNull As Boolean, _
   ByVal bFullSchemaFields As Boolean _
)
C#
public SQLInsert(
   Connection oConnection,
   string TableName,
   bool bDefaultValueNoDbNull,
   bool bFullSchemaFields
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

bDefaultValueNoDbNull

Type: bool

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)

bFullSchemaFields

Type: bool

True to get full fields schema

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Execute Method

[image] [image] [image]

NetData Reference
SQLInsert.Execute Method
See Also

Execute the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute() As Boolean
C#
public bool Execute()

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Init (Softgroup.NetData.Connection, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.Init (Softgroup.NetData.Connection, System.String, System.Boolean, System.Boolean) Method
See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal TableName As String, _
   ByVal bDefaultValueNoDbNull As Boolean, _
   ByVal bFullSchemaFields As Boolean _
)
C#
public System.Void Init(
   Connection oConnection,
   string TableName,
   bool bDefaultValueNoDbNull,
   bool bFullSchemaFields
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

bDefaultValueNoDbNull

Type: bool

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)

bFullSchemaFields

Type: bool

True to get full fields schema

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


Connection.DatabaseCreate (System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String) Method
See Also

Create the specified database and open the connection to the database (current connection will be closed).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName
)

Parameters

DBName

Type: string

Name of database to create.

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create the database with specific instruction contained in driver

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


SQLUpdate Constructor

[image] [image] [image]

NetData Reference
SQLUpdate Constructor
See Also

Create a new instance of the object (Init method must be called before using object)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SQLUpdate()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate Constructor (Softgroup.NetData.Connection, System.String)

[image] [image] [image]

NetData Reference
SQLUpdate Constructor (Softgroup.NetData.Connection, System.String)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public SQLUpdate(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Execute Method

[image] [image] [image]

NetData Reference
SQLUpdate.Execute Method
See Also

Execute the SQL UPDATET statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute() As Boolean
C#
public bool Execute()

Return Value

Return True for success or False for error

Expand image Remarks

This method display error messages if execution failed.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Execute (System.String) Method

[image] [image] [image]

NetData Reference
SQLUpdate.Execute (System.String) Method
See Also

Execute the SQL UPDATET statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal FieldCounter As String _
) As Boolean
C#
public bool Execute(
   string FieldCounter
)

Parameters

FieldCounter

Type: string

This parameter identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

Return Value

Return True for success or False for error

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


Connection.DatabaseCreate (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseCreate (System.String, System.String) Method
See Also

Create the specified database and open the connection (current connection will be closed).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseCreate( _
   ByVal DBName As String, _
   ByVal DBSystem As String _
) As Boolean
C#
public bool DatabaseCreate(
   string DBName,
   string DBSystem
)

Parameters

DBName

Type: string

Name of database to create.

DBSystem

Type: string

Name of system database to use.

Return Value

Return True on success otherwise return False

Expand image Remarks

If Unicode property is True Connection object create the unicode database.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


DataShared.DataTableCreate (Softgroup.NetData.Fields) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableCreate (Softgroup.NetData.Fields) Method

Obtain a new System.Data.DataTable from specified Fields collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DataTableCreate( _
   ByVal oFields As Fields _
) As DataTable
C#
public static DataTable DataTableCreate(
   Fields oFields
)

Parameters

oFields

Type: Fields

A valid Fields collection with which DataTable must be created.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableCreate (System.String, Softgroup.NetData.Fields) Method

[image] [image] [image]

NetData Reference
DataShared.DataTableCreate (System.String, Softgroup.NetData.Fields) Method

Obtain a new System.Data.DataTable from specified Fields collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DataTableCreate( _
   ByVal TableName As String, _
   ByVal oFields As Fields _
) As DataTable
C#
public static DataTable DataTableCreate(
   string TableName,
   Fields oFields
)

Parameters

TableName

Type: string

A name for DataTable.

oFields

Type: Fields

A valid Fields collection with which DataTable must be created.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableGetFilter Method

[image] [image] [image]

NetData Reference
DataShared.DataTableGetFilter Method

Gets filter expression of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DataTableGetFilter( _
   ByVal oDataTable As DataTable _
) As String
C#
public static string DataTableGetFilter(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.DataTableGetSort Method

[image] [image] [image]

NetData Reference
DataShared.DataTableGetSort Method

Gets sort column(s) of specified DataTable.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function DataTableGetSort( _
   ByVal oDataTable As DataTable _
) As String
C#
public static string DataTableGetSort(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


DataShared.GetDataType Method

[image] [image] [image]

NetData Reference
DataShared.GetDataType Method

Map an System Type to a NetData.DataTypeEnum
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Function GetDataType( _
   ByVal oType As Type _
) As DataTypeEnum
C#
public static DataTypeEnum GetDataType(
   Type oType
)

Parameters

oType

Type: Type

System.Type value.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

by Softgroup


Connection.DatabaseRestore (System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseRestore (System.String) Method
See Also

Execute a Restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseRestore( _
   ByVal DBName As String _
) As Boolean
C#
public bool DatabaseRestore(
   string DBName
)

Parameters

DBName

Type: string

Name of database to Restore

Return Value

Return True on success otherwise return False

Expand image Remarks

SQL databases perform restore operations with a path relative to server not to client application.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DatabaseRestore (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DatabaseRestore (System.String, System.String) Method
See Also

Execute a Restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DatabaseRestore( _
   ByVal DBName As String, _
   ByVal sSource As String _
) As Boolean
C#
public bool DatabaseRestore(
   string DBName,
   string sSource
)

Parameters

DBName

Type: string

Name of database to Restore

sSource

Type: string

Source path/file name for the restore operation that contain a valid backup.

Return Value

Return True on success otherwise return False

Expand image Remarks

SQL databases perform restore operations with a path relative to server not to client application.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Field Constructor

[image] [image] [image]

NetData Reference
Field Constructor
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Field()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String)

[image] [image] [image]

NetData Reference
Field Constructor (System.String)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String _
)
C#
public Field(
   string sName
)

Parameters

sName

Type: string

Field Name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Boolean)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Boolean)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum, _
   ByVal bUnique As Boolean _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType,
   bool bUnique
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

bUnique

Type: bool

True if field must contains uniques values otherwise False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum, _
   ByVal iDefinedSize As Integer _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType,
   int iDefinedSize
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

iDefinedSize

Type: int

Field Size

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Connection.DataReader (Softgroup.NetData.Command) Method

[image] [image] [image]

NetData Reference
Connection.DataReader (Softgroup.NetData.Command) Method
See Also

Obtain a Softgroup.NetData.DataReader from the Connection object. This method does not retrive extended schema informations of fields.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataReader( _
   ByVal oCommand As Command _
) As DataReader
C#
public DataReader DataReader(
   Command oCommand
)

Parameters

oCommand

Type: Command

A valid Softgroup.NetData.Command object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataReader (Softgroup.NetData.Command, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DataReader (Softgroup.NetData.Command, System.Boolean) Method
See Also

Obtain a Softgroup.NetData.DataReader from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataReader( _
   ByVal oCommand As Command, _
   ByVal ExtendedSchemaInfo As Boolean _
) As DataReader
C#
public DataReader DataReader(
   Command oCommand,
   bool ExtendedSchemaInfo
)

Parameters

oCommand

Type: Command

A valid Softgroup.NetData.Command object

ExtendedSchemaInfo

Type: bool

Obtain extended schema informations of fields.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataTable (Softgroup.NetData.Command) Method

[image] [image] [image]

NetData Reference
Connection.DataTable (Softgroup.NetData.Command) Method
See Also

Obtain a System.Data.DataTable from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataTable( _
   ByVal oCommand As Command _
) As DataTable
C#
public DataTable DataTable(
   Command oCommand
)

Parameters

oCommand

Type: Command

A valid Softgroup.NetData.Command object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataTable (Softgroup.NetData.Command, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DataTable (Softgroup.NetData.Command, System.String) Method
See Also

Obtain a System.Data.DataTable from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataTable( _
   ByVal oCommand As Command, _
   ByVal TableName As String _
) As DataTable
C#
public DataTable DataTable(
   Command oCommand,
   string TableName
)

Parameters

oCommand

Type: Command

A valid Softgroup.NetData.Command object

TableName

Type: string

Specify the table name for the System.Data.DataTable object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataTable (System.String) Method

[image] [image] [image]

NetData Reference
Connection.DataTable (System.String) Method
See Also

Obtain a System.Data.DataTable from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataTable( _
   ByVal Source As String _
) As DataTable
C#
public DataTable DataTable(
   string Source
)

Parameters

Source

Type: string

SQL statement or Procedure or Table name associated to the Command object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DataTable (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DataTable (System.String, System.String) Method
See Also

Obtain a System.Data.DataTable from the Connection object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DataTable( _
   ByVal Source As String, _
   ByVal TableName As String _
) As DataTable
C#
public DataTable DataTable(
   string Source,
   string TableName
)

Parameters

Source

Type: string

SQL statement or Procedure or Table name associated to the Command object.

TableName

Type: string

Table name for the System.Data.DataTable object.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogBackup Method

[image] [image] [image]

NetData Reference
Connection.DialogBackup Method
See Also

Display a dialog for the backup operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogBackup() As Boolean
C#
public bool DialogBackup()

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogDrivers Method

[image] [image] [image]

NetData Reference
Connection.DialogDrivers Method
See Also

Display a selection dialog of available driver to use for the Connection to a database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogDrivers() As Boolean
C#
public bool DialogDrivers()

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogDrivers (System.Windows.Forms.Form) Method

[image] [image] [image]

NetData Reference
Connection.DialogDrivers (System.Windows.Forms.Form) Method
See Also

Display a selection dialog of a driver to use for the Connection to a database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogDrivers( _
   ByVal FrmOwner As Form _
) As Boolean
C#
public bool DialogDrivers(
   Form FrmOwner
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogRestore Method

[image] [image] [image]

NetData Reference
Connection.DialogRestore Method
See Also

Display a dialog for the restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogRestore() As Boolean
C#
public bool DialogRestore()

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogRestore (System.Windows.Forms.Form) Method

[image] [image] [image]

NetData Reference
Connection.DialogRestore (System.Windows.Forms.Form) Method
See Also

Display a dialog for the restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogRestore( _
   ByVal FrmOwner As Form _
) As Boolean
C#
public bool DialogRestore(
   Form FrmOwner
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogRestore (System.Windows.Forms.Form, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DialogRestore (System.Windows.Forms.Form, System.String) Method
See Also

Display a dialog for the restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogRestore( _
   ByVal FrmOwner As Form, _
   ByVal DBName As String _
) As Boolean
C#
public bool DialogRestore(
   Form FrmOwner,
   string DBName
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

DBName

Type: string

Name of database to Restore

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DialogRestore (System.Windows.Forms.Form, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.DialogRestore (System.Windows.Forms.Form, System.String, System.String) Method
See Also

Display a dialog for the restore operation of the specified database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DialogRestore( _
   ByVal FrmOwner As Form, _
   ByVal DBName As String, _
   ByVal sFile As String _
) As Boolean
C#
public bool DialogRestore(
   Form FrmOwner,
   string DBName,
   string sFile
)

Parameters

FrmOwner

Type: Form

A variabile of type System.Windows.Forms.Form for the parent window from wich display the dialog

DBName

Type: string

Name of database to Restore

sFile

Type: string

Name of file that contains a valid previous backup.

Return Value

Return True if success or False on errors or user cancel operation.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverInit (System.String) Method

[image] [image] [image]

NetData Reference
Connection.DriverInit (System.String) Method
See Also

Initialize the connection with the specific driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DriverInit( _
   ByVal sDriverName As String _
) As Boolean
C#
public bool DriverInit(
   string sDriverName
)

Parameters

sDriverName

Type: string

Name of the driver

Return Value

Return True if success otherwise False

Expand image Remarks

Before using any property or methods of Connection object it is necessary to initialize it with a specific driver.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.DriverInit (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.DriverInit (System.String, System.Boolean) Method
See Also

Initialize the connection with the specific driver.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function DriverInit( _
   ByVal sDriverName As String, _
   ByVal bUnicode As Boolean _
) As Boolean
C#
public bool DriverInit(
   string sDriverName,
   bool bUnicode
)

Parameters

sDriverName

Type: string

Name of the driver

bUnicode

Type: bool

Enable Unicode support

Return Value

Return True if succes else return False

Expand image Remarks

Before using any property or methods of Connection object it is necessary to initialize it with a specific driver.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String, Softgroup.NetData.ForeignKeyActionEnum) Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String, Softgroup.NetData.ForeignKeyActionEnum) Method
See Also

Create a ForeignKey in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyCreate( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String, _
   ByVal ForeignKeyFields As String, _
   ByVal ReferenceTable As String, _
   ByVal ReferenceFields As String, _
   ByVal OnUpdateAction As ForeignKeyActionEnum _
) As Boolean
C#
public bool ForeignKeyCreate(
   string TableName,
   string ForeignKeyName,
   string ForeignKeyFields,
   string ReferenceTable,
   string ReferenceFields,
   ForeignKeyActionEnum OnUpdateAction
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of index to check

ForeignKeyFields

Type: string

List of fields in the ForeignKey table separated by a comma ","

ReferenceTable

Type: string

Name of references table

ReferenceFields

Type: string

List of fields in the ForeignKey of the references table separated by a comma ","

OnUpdateAction

Type: ForeignKeyActionEnum

ForeignKeyActionEnum.roaNoAction. A variable of type Softgroup.ForeignKeyActionEnum for the Update Action

Return Value

Return True if success else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String, Softgroup.NetData.ForeignKeyActionEnum, Softgroup.NetData.ForeignKeyActionEnum) Method

[image] [image] [image]

NetData Reference
Connection.ForeignKeyCreate (System.String, System.String, System.String, System.String, System.String, Softgroup.NetData.ForeignKeyActionEnum, Softgroup.NetData.ForeignKeyActionEnum) Method
See Also

Create a ForeignKey in the specified table of the current database
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ForeignKeyCreate( _
   ByVal TableName As String, _
   ByVal ForeignKeyName As String, _
   ByVal ForeignKeyFields As String, _
   ByVal ReferenceTable As String, _
   ByVal ReferenceFields As String, _
   ByVal OnUpdateAction As ForeignKeyActionEnum, _
   ByVal OnDeleteAction As ForeignKeyActionEnum _
) As Boolean
C#
public bool ForeignKeyCreate(
   string TableName,
   string ForeignKeyName,
   string ForeignKeyFields,
   string ReferenceTable,
   string ReferenceFields,
   ForeignKeyActionEnum OnUpdateAction,
   ForeignKeyActionEnum OnDeleteAction
)

Parameters

TableName

Type: string

Name of table associated to the index

ForeignKeyName

Type: string

Name of index to check

ForeignKeyFields

Type: string

List of fields in the ForeignKey table separated by a comma ","

ReferenceTable

Type: string

Name of references table

ReferenceFields

Type: string

List of fields in the ForeignKey of the references table separated by a comma ","

OnUpdateAction

Type: ForeignKeyActionEnum

ForeignKeyActionEnum.roaNoAction. A variable of type Softgroup.ForeignKeyActionEnum for the Update Action

OnDeleteAction

Type: ForeignKeyActionEnum

ForeignKeyActionEnum.roaNoAction. A variable of type Softgroup.ForeignKeyActionEnum for the Delete Action

Return Value

Return True if success else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FormatSQL (System.String) Method

[image] [image] [image]

NetData Reference
Connection.FormatSQL (System.String) Method
See Also

Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FormatSQL( _
   ByVal StringValue As String _
) As String
C#
public string FormatSQL(
   string StringValue
)

Parameters

StringValue

Type: string

String to format: can be a database object name like Table name, Column name etc.

Return Value

The formatted string to use in SQL statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.FormatSQL (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.FormatSQL (System.String, System.Boolean) Method
See Also

Format specified string for use in SQL statements commands. On some databases for example name of tables or fields must be specified using lower case characters or if name of table or fields contains spaces it must be quoted with special identifiers characters.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FormatSQL( _
   ByVal StringValue As String, _
   ByVal bIsExpression As Boolean _
) As String
C#
public string FormatSQL(
   string StringValue,
   bool bIsExpression
)

Parameters

StringValue

Type: string

String to format: can be a database object name like Table name, Column name etc.

bIsExpression

Type: bool

Before format value the function check if string can be an expression value and in this case no convertions are executed. Set to True this parameter to disable expression check.

Return Value

The formatted string to use in SQL statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Open Method

[image] [image] [image]

NetData Reference
Connection.Open Method
See Also

Open a connection to a database. Return True for success otherwise return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Open() As Boolean
C#
public bool Open()

Return Value

Return True if success or False on errors.

Expand image Remarks

Before executing this method it is necessary to sets almost DataSource, DatabaseName, UserName and UserPassword (if needed) properties.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Open (System.Data.IsolationLevel) Method

[image] [image] [image]

NetData Reference
Connection.Open (System.Data.IsolationLevel) Method
See Also

Open a connection to a database with specified Isolation Level. Return True for success otherwise return False.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal eIsolationLevel As IsolationLevel _
) As Boolean
C#
public bool Open(
   IsolationLevel eIsolationLevel
)

Parameters

eIsolationLevel

Type: IsolationLevel

The isolation level of connection

Return Value

Return True if success or False on errors.

Expand image Remarks

Before executing this method it is necessary to sets almost DataSource, DatabaseName, UserName and UserPassword (if needed) properties.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Open (System.String) Method

[image] [image] [image]

NetData Reference
Connection.Open (System.String) Method
See Also

Open a connection to a database using specified connection string.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal sConnectionString As String _
) As Boolean
C#
public bool Open(
   string sConnectionString
)

Parameters

sConnectionString

Type: string

A valid connection string

Return Value

Return True if success or False on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.Open (System.String, System.Data.IsolationLevel) Method

[image] [image] [image]

NetData Reference
Connection.Open (System.String, System.Data.IsolationLevel) Method
See Also

Open a connection to a database using specified connection string.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal sConnectionString As String, _
   ByVal eIsolationLevel As IsolationLevel _
) As Boolean
C#
public bool Open(
   string sConnectionString,
   IsolationLevel eIsolationLevel
)

Parameters

sConnectionString

Type: string

A valid connection string

eIsolationLevel

Type: IsolationLevel

The isolation level of connection

Return Value

Return True if success or False on errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.OpenTest Method

[image] [image] [image]

NetData Reference
Connection.OpenTest Method
See Also

Test a connection to a database throw a Connection object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function OpenTest() As Boolean
C#
public bool OpenTest()

Return Value

Return True if success or False on errors.

Expand image Remarks

Before executing this method it is necessary to sets DataSource, DatabaseName, UserName and UserPassword properties.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.OpenTest (System.String) Method

[image] [image] [image]

NetData Reference
Connection.OpenTest (System.String) Method
See Also

Test a connection to a database with specified connection string
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function OpenTest( _
   ByVal sConnectionString As String _
) As Boolean
C#
public bool OpenTest(
   string sConnectionString
)

Parameters

sConnectionString

Type: string

A valid connection string

Return Value

Return True if success otherwise False for errors.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProcedureExist (System.String) Method

[image] [image] [image]

NetData Reference
Connection.ProcedureExist (System.String) Method
See Also

Check if a procedure exist in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProcedureExist( _
   ByVal ProcedureName As String _
) As Boolean
C#
public bool ProcedureExist(
   string ProcedureName
)

Parameters

ProcedureName

Type: string

Name of procedure (Syntax: [Schema].Table).

Return Value

Return True if procedure exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProcedureExist (System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.ProcedureExist (System.String, System.String) Method
See Also

Check if a procedure exist in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProcedureExist( _
   ByVal ProcedureName As String, _
   ByVal SchemaName As String _
) As Boolean
C#
public bool ProcedureExist(
   string ProcedureName,
   string SchemaName
)

Parameters

ProcedureName

Type: string

Name of procedure

SchemaName

Type: string

Name of schema)

Return Value

Return True if procedure exist else return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProceduresList Method

[image] [image] [image]

NetData Reference
Connection.ProceduresList Method
See Also

Returns the list of Procedures contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProceduresList() As String()
C#
public string[] ProceduresList()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.ProceduresList (System.String) Method

[image] [image] [image]

NetData Reference
Connection.ProceduresList (System.String) Method
See Also

Returns the list of Procedures contained in the current database.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ProceduresList( _
   ByVal SchemaName As String _
) As String()
C#
public string[] ProceduresList(
   string SchemaName
)

Parameters

SchemaName

Type: string

Schema name filter.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldBoolean (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldBoolean (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldBoolean( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Boolean
C#
public bool QueryFieldBoolean(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldBoolean( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Boolean
C#
public bool QueryFieldBoolean(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldBoolean( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Boolean _
) As Boolean
C#
public bool QueryFieldBoolean(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   bool DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: bool

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String, System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldBoolean (System.String, System.String, System.String, System.String, System.Boolean, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldBoolean( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Boolean, _
   ByVal NoLock As Boolean _
) As Boolean
C#
public bool QueryFieldBoolean(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   bool DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: bool

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDate (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDate (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDate( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Date
C#
public DateTime QueryFieldDate(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDate (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDate (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDate( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Date
C#
public DateTime QueryFieldDate(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDouble (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDouble (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDouble( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Double
C#
public double QueryFieldDouble(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDouble (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDouble (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDouble( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Double
C#
public double QueryFieldDouble(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDouble (System.String, System.String, System.String, System.String, System.Double) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDouble (System.String, System.String, System.String, System.String, System.Double) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDouble( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Double _
) As Double
C#
public double QueryFieldDouble(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   double DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: double

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldDouble (System.String, System.String, System.String, System.String, System.Double, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldDouble (System.String, System.String, System.String, System.String, System.Double, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldDouble( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Double, _
   ByVal NoLock As Boolean _
) As Double
C#
public double QueryFieldDouble(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   double DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: double

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldInteger (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldInteger (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldInteger( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Integer
C#
public int QueryFieldInteger(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldInteger (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldInteger (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldInteger( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Integer
C#
public int QueryFieldInteger(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldInteger (System.String, System.String, System.String, System.String, System.Int32) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldInteger (System.String, System.String, System.String, System.String, System.Int32) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldInteger( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Integer _
) As Integer
C#
public int QueryFieldInteger(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   int DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: int

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldInteger (System.String, System.String, System.String, System.String, System.Int32, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldInteger (System.String, System.String, System.String, System.String, System.Int32, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldInteger( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Integer, _
   ByVal NoLock As Boolean _
) As Integer
C#
public int QueryFieldInteger(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   int DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: int

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldLong (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldLong (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldLong( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Long
C#
public long QueryFieldLong(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldLong (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldLong (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldLong( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Long
C#
public long QueryFieldLong(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldShort (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldShort (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldShort( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Short
C#
public short QueryFieldShort(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldShort (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldShort (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldShort( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Short
C#
public short QueryFieldShort(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldShort (System.String, System.String, System.String, System.String, System.Int16) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldShort (System.String, System.String, System.String, System.String, System.Int16) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldShort( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Short _
) As Short
C#
public short QueryFieldShort(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   short DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: short

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldShort (System.String, System.String, System.String, System.String, System.Int16, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldShort (System.String, System.String, System.String, System.String, System.Int16, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldShort( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Short, _
   ByVal NoLock As Boolean _
) As Short
C#
public short QueryFieldShort(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   short DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: short

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldSingle (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldSingle (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldSingle( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As Single
C#
public float QueryFieldSingle(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldSingle (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldSingle (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldSingle( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As Single
C#
public float QueryFieldSingle(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldSingle (System.String, System.String, System.String, System.String, System.Single) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldSingle (System.String, System.String, System.String, System.String, System.Single) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldSingle( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Single _
) As Single
C#
public float QueryFieldSingle(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   float DefaultValue
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: float

Default value

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldSingle (System.String, System.String, System.String, System.String, System.Single, System.Boolean) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldSingle (System.String, System.String, System.String, System.String, System.Single, System.Boolean) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldSingle( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String, _
   ByVal DefaultValue As Single, _
   ByVal NoLock As Boolean _
) As Single
C#
public float QueryFieldSingle(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL,
   float DefaultValue,
   bool NoLock
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

DefaultValue

Type: float

Default value

NoLock

Type: bool

Use NOLOCK for SELECT tabels

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldString (System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldString (System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldString( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String _
) As String
C#
public string QueryFieldString(
   string sTable,
   string sFieldSQL,
   string sWhereSQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name

sWhereSQL

Type: string

Where clause part of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


Connection.QueryFieldString (System.String, System.String, System.String, System.String) Method

[image] [image] [image]

NetData Reference
Connection.QueryFieldString (System.String, System.String, System.String, System.String) Method
See Also

Get the field value of first record founded in specified Table using supplied Where clause
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function QueryFieldString( _
   ByVal sTable As String, _
   ByVal sFieldSQL As String, _
   ByVal sWhereSQL As String, _
   ByVal sOrderBySQL As String _
) As String
C#
public string QueryFieldString(
   string sTable,
   string sFieldSQL,
   string sWhereSQL,
   string sOrderBySQL
)

Parameters

sTable

Type: string

Table name

sFieldSQL

Type: string

Field name or expression for SELECT statment

sWhereSQL

Type: string

WHERE part clause of a SQL SELECT statement

sOrderBySQL

Type: string

ORDER BY part clause of a SQL SELECT statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Connection Class
Connection Members


SQLSelect Constructor

[image] [image] [image]

NetData Reference
SQLSelect Constructor
See Also

Create a new instance of the object (Init method must be called before using object)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SQLSelect()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.SQL Method

[image] [image] [image]

NetData Reference
SQLSelect.SQL Method
See Also

Return the SQL statement text
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL() As String
C#
public string SQL()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.SQL (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.SQL (System.Boolean) Method
See Also

Return the SQL statement text
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal bUnionSelect As Boolean _
) As String
C#
public string SQL(
   bool bUnionSelect
)

Parameters

bUnionSelect

Type: bool

This parameter that can be used for generate UNION SELECT statements.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.SQL (System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.SQL (System.Boolean, System.Boolean) Method
See Also

Return the SQL statement text
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal bUnionSelect As Boolean, _
   ByVal bDistinct As Boolean _
) As String
C#
public string SQL(
   bool bUnionSelect,
   bool bDistinct
)

Parameters

bUnionSelect

Type: bool

This parameter that can be used for generate UNION SELECT statements.

bDistinct

Type: bool

True to use SELECT DISTINCT sql statement

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.AddField (System.String) Method

[image] [image] [image]

NetData Reference
SQLSelect.AddField (System.String) Method
See Also

Append new field or expression to sql SELECT clause.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddField( _
   ByVal sFieldExpression As String _
)
C#
public System.Void AddField(
   string sFieldExpression
)

Parameters

sFieldExpression

Type: string

A valid file name or expression

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.AddField (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.AddField (System.String, System.Boolean) Method
See Also

Append new field or expression to sql SELECT clause.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub AddField( _
   ByVal sFieldExpression As String, _
   ByVal bAddToGroupBy As Boolean _
)
C#
public System.Void AddField(
   string sFieldExpression,
   bool bAddToGroupBy
)

Parameters

sFieldExpression

Type: string

A valid file name or expression

bAddToGroupBy

Type: bool

Add field also to GROUP BY clause

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Init (Softgroup.NetData.Connection) Method

[image] [image] [image]

NetData Reference
SQLSelect.Init (Softgroup.NetData.Connection) Method
See Also

Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection _
)
C#
public System.Void Init(
   Connection oConnection
)

Parameters

oConnection

Type: Connection

A Connection object type

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


SQLSelect.Init (Softgroup.NetData.Connection, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLSelect.Init (Softgroup.NetData.Connection, System.Boolean) Method
See Also

Initialize and associate the object with a specific Connection object used to generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal bNoLock As Boolean _
)
C#
public System.Void Init(
   Connection oConnection,
   bool bNoLock
)

Parameters

oConnection

Type: Connection

A Connection object type

bNoLock

Type: bool

True if SQL statement must include keywords to force reading uncommetted records from tables

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLSelect Class
SQLSelect Members


DataReader.GetDataTypeName (System.Int32) Method

[image] [image] [image]

NetData Reference
DataReader.GetDataTypeName (System.Int32) Method
See Also

Gets name of the data type of the specified column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDataTypeName( _
   ByVal Index As Integer _
) As String
C#
public string GetDataTypeName(
   int Index
)

Parameters

Index

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetDataTypeName (System.String) Method

[image] [image] [image]

NetData Reference
DataReader.GetDataTypeName (System.String) Method
See Also

Gets name of the data type of the specified column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDataTypeName( _
   ByVal Name As String _
) As String
C#
public string GetDataTypeName(
   string Name
)

Parameters

Name

Type: string

Name of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetFieldType (System.Int32) Method

[image] [image] [image]

NetData Reference
DataReader.GetFieldType (System.Int32) Method
See Also

Gets the data type of the specified column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetFieldType( _
   ByVal Index As Integer _
) As Type
C#
public Type GetFieldType(
   int Index
)

Parameters

Index

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetFieldType (System.String) Method

[image] [image] [image]

NetData Reference
DataReader.GetFieldType (System.String) Method
See Also

Gets the data type of the specified column.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetFieldType( _
   ByVal Name As String _
) As Type
C#
public Type GetFieldType(
   string Name
)

Parameters

Name

Type: string

Name of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetValue (System.Int32) Method

[image] [image] [image]

NetData Reference
DataReader.GetValue (System.Int32) Method
See Also

Gets the value of the specified column as an Object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal Index As Integer _
) As Object
C#
public object GetValue(
   int Index
)

Parameters

Index

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.GetValue (System.String) Method

[image] [image] [image]

NetData Reference
DataReader.GetValue (System.String) Method
See Also

Gets the value of the specified column as an Object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal Name As String _
) As Object
C#
public object GetValue(
   string Name
)

Parameters

Name

Type: string

Name of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Item (System.String) Property

[image] [image] [image]

NetData Reference
DataReader.Item (System.String) Property
See Also

Gets the value of a specified column as an instance of Object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Name As String _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public object this[
   string Name
] {get;}

Parameters

Name

Type: string

Field name

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


DataReader.Item (System.Int32) Property

[image] [image] [image]

NetData Reference
DataReader.Item (System.Int32) Property
See Also

Gets the value of a specified column as an instance of Object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public object this[
   int i
] {get;}

Parameters

i

Type: int

Index of column

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

DataReader Class
DataReader Members


Localize Members

[image] [image] [image]

NetData Reference
Localize Members
Localize Class See Also

This class provide shared localization string for Softgroup .Net Data Objects

The following tables list the members exposed by the Localize type.

Expand image See Also

Reference

Localize Class


SQLTables.Add (System.String) Method

[image] [image] [image]

NetData Reference
SQLTables.Add (System.String) Method
See Also

Add a table and optionally a join table to the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal TableName As String _
) As SQLTable
C#
public SQLTable Add(
   string TableName
)

Parameters

TableName

Type: string

Name of table to add

Return Value

Return a SQLTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLTables Class
SQLTables Members


Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32)
See Also

Create a new instance of the class and open the recordset (see Open method for more details).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer _
)
C#
public Recordset(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize
)

Parameters

oConnection

Type: Connection

A valid Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client cursors (True is default)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value i 0 (all records).

bAsyncFetch

Type: bool

Enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean)

[image] [image] [image]

NetData Reference
Recordset Constructor (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32, System.Boolean, System.Int32, System.Boolean)
See Also

Create a new instance of the class and open the recordset (see Open method for more details).
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer, _
   ByVal bAsyncFetch As Boolean, _
   ByVal iInitialFetchSize As Integer, _
   ByVal bFetchProgress As Boolean _
)
C#
public Recordset(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords,
   bool bAsyncFetch,
   int iInitialFetchSize,
   bool bFetchProgress
)

Parameters

oConnection

Type: Connection

A valid Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client cursors (True is default)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value i 0 (all records).

bAsyncFetch

Type: bool

Enable asynchronous reading of data

iInitialFetchSize

Type: int

Determines how many records are fetched synchronously before the asynchronous thread is created

bFetchProgress

Type: bool

Enable progress of total number of records readed during asynchronous operations

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareDate (System.Int32, System.Object) Method

[image] [image] [image]

NetData Reference
Recordset.CompareDate (System.Int32, System.Object) Method
See Also

Compare current date value of field with specified value and return a CompareTypeEnum constant
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CompareDate( _
   ByVal Index As Integer, _
   ByVal oDate As Object _
) As CompareValueEnum
C#
public CompareValueEnum CompareDate(
   int Index,
   object oDate
)

Parameters

Index

Type: int

Index of field

oDate

Type: object

A date value to campare

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareDate (System.String, System.Object) Method

[image] [image] [image]

NetData Reference
Recordset.CompareDate (System.String, System.Object) Method
See Also

Compare current date value of field with specified value and return a CompareTypeEnum constant
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CompareDate( _
   ByVal Name As String, _
   ByVal oDate As Object _
) As CompareValueEnum
C#
public CompareValueEnum CompareDate(
   string Name,
   object oDate
)

Parameters

Name

Type: string

Name of field

oDate

Type: object

A date value to campare

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareTime (System.Int32, System.Object) Method

[image] [image] [image]

NetData Reference
Recordset.CompareTime (System.Int32, System.Object) Method
See Also

Compare current time value of field with specified value and return a CompareTypeEnum constant
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CompareTime( _
   ByVal Index As Integer, _
   ByVal oTime As Object _
) As CompareValueEnum
C#
public CompareValueEnum CompareTime(
   int Index,
   object oTime
)

Parameters

Index

Type: int

Index of field

oTime

Type: object

A time value to campare

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.CompareTime (System.String, System.Object) Method

[image] [image] [image]

NetData Reference
Recordset.CompareTime (System.String, System.Object) Method
See Also

Compare current time value of field with specified value and return a CompareTypeEnum constant
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CompareTime( _
   ByVal Name As String, _
   ByVal oTime As Object _
) As CompareValueEnum
C#
public CompareValueEnum CompareTime(
   string Name,
   object oTime
)

Parameters

Name

Type: string

Name of field

oTime

Type: object

A time value to campare

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldActualSize (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldActualSize (System.Int32) Method
See Also

Gets the actual size in bytes of a field value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldActualSize( _
   ByVal Index As Integer _
) As Integer
C#
public int FieldActualSize(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldActualSize (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.FieldActualSize (System.String) Method
See Also

Gets the actual size in bytes of a field value.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldActualSize( _
   ByVal Name As String _
) As Integer
C#
public int FieldActualSize(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.FieldAllowDBNull (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.FieldAllowDBNull (System.Int32) Method
See Also

Gets if the field accept null values.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function FieldAllowDBNull( _
   ByVal Index As Integer _
) As Boolean
C#
public bool FieldAllowDBNull(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValue (System.Int32, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.GetValue (System.Int32, System.String) Method
See Also

Gets the value of specified field in the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal iPosition As Integer, _
   ByVal Name As String _
) As Object
C#
public object GetValue(
   int iPosition,
   string Name
)

Parameters

iPosition

Type: int

Record position

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValue (System.Int32, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetValue (System.Int32, System.Int32) Method
See Also

Gets the value of specified field in the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal iPosition As Integer, _
   ByVal Index As Integer _
) As Object
C#
public object GetValue(
   int iPosition,
   int Index
)

Parameters

iPosition

Type: int

Record position

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValues Method

[image] [image] [image]

NetData Reference
Recordset.GetValues Method
See Also

Gets an array of all values for the current record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValues() As Object()
C#
public object[] GetValues()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.GetValues (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.GetValues (System.Int32) Method
See Also

Gets an array of all values for the specified record position
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetValues( _
   ByVal iPosition As Integer _
) As Object()
C#
public object[] GetValues(
   int iPosition
)

Parameters

iPosition

Type: int

Record position

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.ValueIsNull (System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.ValueIsNull (System.Int32) Method
See Also

Return True if value of a field is Null value
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ValueIsNull( _
   ByVal Index As Integer _
) As Boolean
C#
public bool ValueIsNull(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.ValueIsNull (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.ValueIsNull (System.String) Method
See Also

Return True if value of a field is Null value
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ValueIsNull( _
   ByVal Name As String _
) As Boolean
C#
public bool ValueIsNull(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Find (System.String) Method

[image] [image] [image]

NetData Reference
Recordset.Find (System.String) Method
See Also

The Find method searches for a record in the Recordset that match specified criteria staring from first. If the search is successful, the record Position will point to the first found record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Find( _
   ByVal Criteria As String _
)
C#
public System.Void Find(
   string Criteria
)

Parameters

Criteria

Type: string

A valid string crireria

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Find (System.String, Softgroup.NetData.FindRecordEnum) Method

[image] [image] [image]

NetData Reference
Recordset.Find (System.String, Softgroup.NetData.FindRecordEnum) Method
See Also

The Find method searches for a record in the Recordset that match specified criteria starting from specified position. If the search is successful, the record Position will point to the first found record.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Find( _
   ByVal Criteria As String, _
   ByVal Direction As FindRecordEnum _
)
C#
public System.Void Find(
   string Criteria,
   FindRecordEnum Direction
)

Parameters

Criteria

Type: string

A valid string crireria

Direction

Type: FindRecordEnum

A valid value from FindRecordEnum enumeration that define starting position from Recordset

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (System.Data.DataTable) Method

[image] [image] [image]

NetData Reference
Recordset.Open (System.Data.DataTable) Method
See Also

Open the recordset from a DataTable object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oDataTable As DataTable _
)
C#
public System.Void Open(
   DataTable oDataTable
)

Parameters

oDataTable

Type: DataTable

A valid DataTable object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (Softgroup.NetData.Connection, System.String) Method

[image] [image] [image]

NetData Reference
Recordset.Open (Softgroup.NetData.Connection, System.String) Method
See Also

Open the recordset for reading operations in the associated connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oConnection As Connection, _
   ByVal sSource As String _
)
C#
public System.Void Open(
   Connection oConnection,
   string sSource
)

Parameters

oConnection

Type: Connection

A Connection object

sSource

Type: string

A valid SELECT SQL statement

Expand image Remarks

SQL SELECT statement must have the syntax (supported by most databases):

SELECT [FROM] [WHERE] [GROUP BY] [HAVING] [ORDER BY]

Other specific-database sql syntax are not supported.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean) Method
See Also

Open the recordset for read operations in the associated connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean _
)
C#
public System.Void Open(
   Connection oConnection,
   string sSource,
   bool bClientCursors
)

Parameters

oConnection

Type: Connection

A Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

Expand image Remarks

Recordset object is writable (AddNew or Edit and Update methods) only if table used in SQL SELECT statements contains all fields of at least a Primary Key or Unique index. Data provider must returns also the correct base table name in case of SQL statements with tables aliases or joins.

SQL SELECT statement must have the syntax (supported by most databases):

SELECT [FROM] [WHERE] [GROUP BY] [HAVING] [ORDER BY]

Other specific-database sql syntax are not supported.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32) Method

[image] [image] [image]

NetData Reference
Recordset.Open (Softgroup.NetData.Connection, System.String, System.Boolean, System.Int32) Method
See Also

Open the recordset for read operations in the associated connection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Open( _
   ByVal oConnection As Connection, _
   ByVal sSource As String, _
   ByVal bClientCursors As Boolean, _
   ByVal iMaxRecords As Integer _
)
C#
public System.Void Open(
   Connection oConnection,
   string sSource,
   bool bClientCursors,
   int iMaxRecords
)

Parameters

oConnection

Type: Connection

A Connection object

sSource

Type: string

A valid SELECT SQL statement

bClientCursors

Type: bool

Use client side cursors (default is True)

iMaxRecords

Type: int

Maximum number of records that can be returned by recordset. Default value is 0 (all records).

Expand image Remarks

Recordset object is writable (AddNew or Edit and Update methods) only if table used in SQL SELECT statements contains all fields of at least a Primary Key or Unique index. Data provider must returns also the correct base table name in case of SQL statements with tables aliases or joins.

SQL SELECT statement must have the syntax (supported by most databases):

SELECT [FROM] [WHERE] [GROUP BY] [HAVING] [ORDER BY]

Other specific-database sql syntax are not supported.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Recordset Class
Recordset Members


SQLDelete Constructor

[image] [image] [image]

NetData Reference
SQLDelete Constructor
See Also

Create a new instance of the object (Init method must be called before using object)
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SQLDelete()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


SQLDelete Constructor (Softgroup.NetData.Connection, System.String)

[image] [image] [image]

NetData Reference
SQLDelete Constructor (Softgroup.NetData.Connection, System.String)
See Also

Create and initialize a new instance of the object
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public SQLDelete(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

TableName

Type: string

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLDelete Class
SQLDelete Members


Parameters.Remove (System.Int32) Method

[image] [image] [image]

NetData Reference
Parameters.Remove (System.Int32) Method
See Also

Removes the specified Parameter by index.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Index As Integer _
)
C#
public System.Void Remove(
   int Index
)

Parameters

Index

Type: int

Index of Parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Remove (System.String) Method

[image] [image] [image]

NetData Reference
Parameters.Remove (System.String) Method
See Also

Removes the specified Parameter by name.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Name As String _
)
C#
public System.Void Remove(
   string Name
)

Parameters

Name

Type: string

Index of Parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Parameter (System.String) Property

[image] [image] [image]

NetData Reference
Parameters.Parameter (System.String) Property
See Also

Gets the underline Parameter object of Command by name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter( _
   ByVal Name As String _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Parameter")]
public object this[
   string Name
] {get;}

Parameters

Name

Type: string

Name of parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Item (System.Int32) Property

[image] [image] [image]

NetData Reference
Parameters.Item (System.Int32) Property
See Also

Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by index
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As Parameter
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public Parameter this[
   int Index
] {get;}

Parameters

Index

Type: int

Index of parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Item (System.String) Property

[image] [image] [image]

NetData Reference
Parameters.Item (System.String) Property
See Also

Gets a Softgroup.NetData.Parameter object that rappresent the specified Parameter by name
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Name As String _
) As Parameter
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public Parameter this[
   string Name
] {get;}

Parameters

Name

Type: string

Name of parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Parameters.Parameter (System.Int32) Property

[image] [image] [image]

NetData Reference
Parameters.Parameter (System.Int32) Property
See Also

Gets the underline Parameter object of Command by index
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameter( _
   ByVal Index As Integer _
) As Object
C#
[System.Runtime.CompilerServices.IndexerName("Parameter")]
public object this[
   int Index
] {get;}

Parameters

Index

Type: int

Index of parameter

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Parameters Class
Parameters Members


Fields.Remove (System.Int32) Method

[image] [image] [image]

NetData Reference
Fields.Remove (System.Int32) Method
See Also

Remove a field from the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Index As Integer _
)
C#
public System.Void Remove(
   int Index
)

Parameters

Index

Type: int

Index of field

Expand image Remarks

If you try to Remove a field of a Fields collection in a Recordset, SQLSelect or SQLUpdate object an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Remove (System.String) Method

[image] [image] [image]

NetData Reference
Fields.Remove (System.String) Method
See Also

Remove a field from the collection
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal Name As String _
)
C#
public System.Void Remove(
   string Name
)

Parameters

Name

Type: string

Name of field

Expand image Remarks

If you try to Remove a field of a Fields collection in a Recordset, SQLSelect or SQLUpdate object, an error will be generated.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Item (System.String) Property

[image] [image] [image]

NetData Reference
Fields.Item (System.String) Property
See Also

This is the default readonly property for accessing Field objects stored in the collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Name As String _
) As Field
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public Field this[
   string Name
] {get;}

Parameters

Name

Type: string

Name of field

Property Value

Return a Field object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


Fields.Item (System.Int32) Property

[image] [image] [image]

NetData Reference
Fields.Item (System.Int32) Property
See Also

This is the default readonly property for accessing Field objects stored in the collection.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As Field
C#
[System.Runtime.CompilerServices.IndexerName("Item")]
public Field this[
   int Index
] {get;}

Parameters

Index

Type: int

Index of field

Property Value

Return a Field object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Fields Class
Fields Members


SQLInsert.Execute (System.String) Method

[image] [image] [image]

NetData Reference
SQLInsert.Execute (System.String) Method
See Also

Execute the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal FieldCounter As String _
) As Boolean
C#
public bool Execute(
   string FieldCounter
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Execute (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.Execute (System.Boolean) Method
See Also

Execute the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As Boolean
C#
public bool Execute(
   bool ExcludeBinaryFieldsType
)

Parameters

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Execute (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.Execute (System.String, System.Boolean) Method
See Also

Execute the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal FieldCounter As String, _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As Boolean
C#
public bool Execute(
   string FieldCounter,
   bool ExcludeBinaryFieldsType
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Return Value

Return True on success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.SQL (System.String) Method

[image] [image] [image]

NetData Reference
SQLInsert.SQL (System.String) Method
See Also

Gets the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal FieldCounter As String _
) As String
C#
public string SQL(
   string FieldCounter
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.SQL (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.SQL (System.Boolean) Method
See Also

Gets the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As String
C#
public string SQL(
   bool ExcludeBinaryFieldsType
)

Parameters

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.SQL Method

[image] [image] [image]

NetData Reference
SQLInsert.SQL Method
See Also

Gets the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL() As String
C#
public string SQL()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.SQL (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.SQL (System.String, System.Boolean) Method
See Also

Gets the SQL INSERT statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal FieldCounter As String, _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As String
C#
public string SQL(
   string FieldCounter,
   bool ExcludeBinaryFieldsType
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Init (Softgroup.NetData.Connection, System.String) Method

[image] [image] [image]

NetData Reference
SQLInsert.Init (Softgroup.NetData.Connection, System.String) Method
See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal TableName As String _
)
C#
public System.Void Init(
   Connection oConnection,
   string TableName
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


SQLInsert.Init (Softgroup.NetData.Connection, System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLInsert.Init (Softgroup.NetData.Connection, System.String, System.Boolean) Method
See Also

Initialize and associate the object with a specific Connection object used for generate and execute SQL statements.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal oConnection As Connection, _
   ByVal TableName As String, _
   ByVal bDefaultValueNoDbNull As Boolean _
)
C#
public System.Void Init(
   Connection oConnection,
   string TableName,
   bool bDefaultValueNoDbNull
)

Parameters

oConnection

Type: Connection

A Connection object type

TableName

Type: string

Nome of table where insert data

bDefaultValueNoDbNull

Type: bool

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)

Expand image Remarks

It is necessary to call this method befor using any other property or method of the class.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLInsert Class
SQLInsert Members


Command.ExecuteReader Method

[image] [image] [image]

NetData Reference
Command.ExecuteReader Method
See Also

Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteReader() As DataReader
C#
public DataReader ExecuteReader()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.ExecuteReader (System.Boolean) Method

[image] [image] [image]

NetData Reference
Command.ExecuteReader (System.Boolean) Method
See Also

Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteReader( _
   ByVal ExtendedSchemaInfo As Boolean _
) As DataReader
C#
public DataReader ExecuteReader(
   bool ExtendedSchemaInfo
)

Parameters

ExtendedSchemaInfo

Type: bool

True to return extended schema informations for fields

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


Command.ExecuteReader (System.Boolean, System.Boolean) Method

[image] [image] [image]

NetData Reference
Command.ExecuteReader (System.Boolean, System.Boolean) Method
See Also

Executes the CommandText against the Connection and returns a Softgroup.NetData.DataReader.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function ExecuteReader( _
   ByVal ExtendedSchemaInfo As Boolean, _
   ByVal bAsyncFetch As Boolean _
) As DataReader
C#
public DataReader ExecuteReader(
   bool ExtendedSchemaInfo,
   bool bAsyncFetch
)

Parameters

ExtendedSchemaInfo

Type: bool

True to return extended schema informations for fields

bAsyncFetch

Type: bool

Enable asynchronous reading of data (this feature is not supported from all drivers and will be enabled only if UseADO property of Connection object is sets to True)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Command Class
Command Members


SQLUpdate.Execute (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLUpdate.Execute (System.Boolean) Method
See Also

Execute the SQL UPDATET statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As Boolean
C#
public bool Execute(
   bool ExcludeBinaryFieldsType
)

Parameters

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Return Value

Return True for success or False for error

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.Execute (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLUpdate.Execute (System.String, System.Boolean) Method
See Also

Execute the SQL UPDATET statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Execute( _
   ByVal FieldCounter As String, _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As Boolean
C#
public bool Execute(
   string FieldCounter,
   bool ExcludeBinaryFieldsType
)

Parameters

FieldCounter

Type: string

This parameter identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Return Value

Return True for success or False for error

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.SQL (System.String) Method

[image] [image] [image]

NetData Reference
SQLUpdate.SQL (System.String) Method
See Also

Gets the SQL UPDATE statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal FieldCounter As String _
) As String
C#
public string SQL(
   string FieldCounter
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.SQL (System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLUpdate.SQL (System.Boolean) Method
See Also

Gets the SQL UPDATE statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As String
C#
public string SQL(
   bool ExcludeBinaryFieldsType
)

Parameters

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


SQLUpdate.SQL (System.String, System.Boolean) Method

[image] [image] [image]

NetData Reference
SQLUpdate.SQL (System.String, System.Boolean) Method
See Also

Gets the SQL UPDATE statement
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SQL( _
   ByVal FieldCounter As String, _
   ByVal ExcludeBinaryFieldsType As Boolean _
) As String
C#
public string SQL(
   string FieldCounter,
   bool ExcludeBinaryFieldsType
)

Parameters

FieldCounter

Type: string

This parameter that identify a field name that acts as counter or autoincrement field that is updated with maximum value in the table + 1.

ExcludeBinaryFieldsType

Type: bool

If True binary fields type are ignored otherwise an exception will be throwgh.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

SQLUpdate Class
SQLUpdate Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum, _
   ByVal iDefinedSize As Integer, _
   ByVal bAllowDBNull As Boolean _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType,
   int iDefinedSize,
   bool bAllowDBNull
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

iDefinedSize

Type: int

Field Size

bAllowDBNull

Type: bool

True if field accept null values

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum, _
   ByVal iDefinedSize As Integer, _
   ByVal bAllowDBNull As Boolean, _
   ByVal bAutoIncrement As Boolean _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType,
   int iDefinedSize,
   bool bAllowDBNull,
   bool bAutoIncrement
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

iDefinedSize

Type: int

Field Size

bAllowDBNull

Type: bool

True if field accept null values

bAutoIncrement

Type: bool

True if field is an auto-increment field

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean, System.Boolean)

[image] [image] [image]

NetData Reference
Field Constructor (System.String, Softgroup.NetData.DataTypeEnum, System.Int32, System.Boolean, System.Boolean, System.Boolean)
See Also

Create New Field object.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub New( _
   ByVal sName As String, _
   ByVal eDataType As DataTypeEnum, _
   ByVal iDefinedSize As Integer, _
   ByVal bAllowDBNull As Boolean, _
   ByVal bAutoIncrement As Boolean, _
   ByVal bUnique As Boolean _
)
C#
public Field(
   string sName,
   DataTypeEnum eDataType,
   int iDefinedSize,
   bool bAllowDBNull,
   bool bAutoIncrement,
   bool bUnique
)

Parameters

sName

Type: string

Field Name

eDataType

Type: DataTypeEnum

Field Type

iDefinedSize

Type: int

Field Size

bAllowDBNull

Type: bool

True if field accept null values

bAutoIncrement

Type: bool

True if field is an auto-increment field

bUnique

Type: bool

True if field must contains uniques values otherwise False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.ValueReset Method

[image] [image] [image]

NetData Reference
Field.ValueReset Method
See Also

Reset value and status of value field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ValueReset()
C#
public System.Void ValueReset()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members


Field.ValueReset (System.Boolean) Method

[image] [image] [image]

NetData Reference
Field.ValueReset (System.Boolean) Method
See Also

Reset value and status of value field.
Assembly: Softgroup.NetData (in Softgroup.NetData.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ValueReset( _
   ByVal bDefaultValueNoDbNull As Boolean _
)
C#
public System.Void ValueReset(
   bool bDefaultValueNoDbNull
)

Parameters

bDefaultValueNoDbNull

Type: bool

Sets the default field value to corresponding type without using System.DbNull.Value (empty String for text or zero for numeric fields)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, Windows Server 2008, Windows Server 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 4.x,3.x, 2.x

Expand image See Also

Reference

Field Class
Field Members