NetMultimedia Reference

[image] [image] [image]

Softgroup .Net Multimedia Control is a fast, small and lightweight .NET control that can be used to play most Audio and Video files using .NET technology.

by Softgroup


Softgroup.NetMultimedia Namespace

[image] [image] [image]

NetMultimedia Reference
Softgroup.NetMultimedia Namespace

Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Classes

Name | Description
Public class | License | License class holds licenses informations data.
Public class Multimedia Softgroup Multimedia control is a full customizable MultiMedia player component with video/sound control display.

It is able to play CD Audio and most populars multimedia sound/video file formats:

File type extension | Description
AIF, AIFF, AIFC | Audio Interchange File
AVI | Audio Video Interleave
AU | uLaw/AU Audio File
DAT | Video stream from a Video CD (VCD)
ENC | Encore Musical Notation
MID | Musical Instrument Digital Interface MIDI-sequention Sound
MOV | QuickTime Video Clip
MPG, MPEG | MPEG 1 System Stream
MPE | MPEG Movie Clip
MPA | MPEG Audio Stream, Layer I, II or III
MPM | MPEG Movie
MPV | MPEG-1 Video File
MP1 | MPEG Audio Stream, Layer I
MP2 | MPEG Audio Stream, Layer II
MP3 | MPEG Audio Stream, Layer III
MP4 | MPEG Audio Stream, Layer IV
QT | QuickTime Movie
RMI | MIDI File
SND | Audio Files
VOB | DVD Video Movie File
WAV | Windows WAVE Sound File
WMA | Windows Media Audio File
WMV | Windows Media Video File
Public class | OnErrorEventArgs | OnErrorEventArgs class hold OnError event parameters
Public class | OnOpenEventArgs | OnOpenEventArgs class hold OnOpen event parameters
Public class | OnToolTipShowing | OnToolTipShowing class hold ToolTipShowing event parameters
Top

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x


License Class

[image] [image] [image]

NetMultimedia Reference
License Class
Members

License class holds licenses informations data.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public NotInheritable Class License
C#
public sealed class License

Expand image Inheritance Hierarchy

System.Object
Softgroup.NetMultimedia.License

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

License Members


License Members

[image] [image] [image]

NetMultimedia Reference
License Members
License Class Properties See Also

License class holds licenses informations data.

The following tables list the members exposed by the License type.

Expand image Public Properties

Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License Properties

[image] [image] [image]

NetMultimedia Reference
License Properties
License Class See Also

Expand image Public Properties

Name | Description
LicenseKey | Gets/Sets the license key for the product
LicenseName | Gets/Sets the license company name for the product
LicenseUser | Gets/Sets the license user name (usually and email address) for the product
Top

Expand image See Also

Reference

License Class


License.LicenseKey Property

[image] [image] [image]

NetMultimedia Reference
License.LicenseKey Property
See Also

Gets/Sets the license key for the product
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseKey() As String
C#
public static string LicenseKey {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

License Class
License Members


License.LicenseName Property

[image] [image] [image]

NetMultimedia Reference
License.LicenseName Property
See Also

Gets/Sets the license company name for the product
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseName() As String
C#
public static string LicenseName {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

License Class
License Members


License.LicenseUser Property

[image] [image] [image]

NetMultimedia Reference
License.LicenseUser Property
See Also

Gets/Sets the license user name (usually and email address) for the product
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Shared Property LicenseUser() As String
C#
public static string LicenseUser {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

License Class
License Members


Multimedia Class

[image] [image] [image]

NetMultimedia Reference
Multimedia Class
Members

Softgroup Multimedia control is a full customizable MultiMedia player component with video/sound control display.

It is able to play CD Audio and most populars multimedia sound/video file formats:

File type extension | Description
AIF, AIFF, AIFC | Audio Interchange File
AVI | Audio Video Interleave
AU | uLaw/AU Audio File
DAT | Video stream from a Video CD (VCD)
ENC | Encore Musical Notation
MID | Musical Instrument Digital Interface MIDI-sequention Sound
MOV | QuickTime Video Clip
MPG, MPEG | MPEG 1 System Stream
MPE | MPEG Movie Clip
MPA | MPEG Audio Stream, Layer I, II or III
MPM | MPEG Movie
MPV | MPEG-1 Video File
MP1 | MPEG Audio Stream, Layer I
MP2 | MPEG Audio Stream, Layer II
MP3 | MPEG Audio Stream, Layer III
MP4 | MPEG Audio Stream, Layer IV
QT | QuickTime Movie
RMI | MIDI File
SND | Audio Files
VOB | DVD Video Movie File
WAV | Windows WAVE Sound File
WMA | Windows Media Audio File
WMV | Windows Media Video File

Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class Multimedia
    Inherits UserControl
C#
public class Multimedia : UserControl

Expand image Remarks

To play some video formats verify that required codec is installed on your system

Expand image Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Softgroup.NetMultimedia.Multimedia

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Members


Multimedia Members

[image] [image] [image]

NetMultimedia Reference
Multimedia Members
Multimedia Class Events Methods Properties See Also

Softgroup Multimedia control is a full customizable MultiMedia player component with video/sound control display.

It is able to play CD Audio and most populars multimedia sound/video file formats:

File type extension | Description
AIF, AIFF, AIFC | Audio Interchange File
AVI | Audio Video Interleave
AU | uLaw/AU Audio File
DAT | Video stream from a Video CD (VCD)
ENC | Encore Musical Notation
MID | Musical Instrument Digital Interface MIDI-sequention Sound
MOV | QuickTime Video Clip
MPG, MPEG | MPEG 1 System Stream
MPE | MPEG Movie Clip
MPA | MPEG Audio Stream, Layer I, II or III
MPM | MPEG Movie
MPV | MPEG-1 Video File
MP1 | MPEG Audio Stream, Layer I
MP2 | MPEG Audio Stream, Layer II
MP3 | MPEG Audio Stream, Layer III
MP4 | MPEG Audio Stream, Layer IV
QT | QuickTime Movie
RMI | MIDI File
SND | Audio Files
VOB | DVD Video Movie File
WAV | Windows WAVE Sound File
WMA | Windows Media Audio File
WMV | Windows Media Video File

The following tables list the members exposed by the Multimedia type.

Expand image Public Properties

Name | Description
Public property | AutoPlay | Gets/Sets AutoPlay mode: automatic start play on Open
Public property | BackColor | Gets/Sets background color of control
Public property | Balance | Gets/Sets Volume Balance of Right and Left channels. Value must be between -100 and 100. A value of 0 set both volume channels to 100. Check SupportBalance method before change this property.
Public property | ButtonTip | Gets/Sets text for tooltips used in Command Bar buttons. Any tooltip text can be customized (for example for multilanguage applications).
Public property | CommandBarBackColor | Gets/Sets background colour of commands bar
Public property | CommandBarBorder | Gets/Sets border style or command bar
Public property | CommandBarPosition | Gets/Sets command bar position
Public property | CommandBarThumbColor | Gets/Sets slider thumb colour of volume and balance
Public property | CommandLedBackColor | Gets/Sets background colour of led panel
Public property | CommandLedForeColor | Gets/Sets foreground colour of led panel
Public property | Frame | Gets/Sets current frame number If vaue is not supported by media file 0 will be returned)..
Public property | Frames | Gets total number of frames. If vaue is not supported by media file 0 will be returned).
Public property | FullScreen | Gets/Sets if container Form of Multimedia control is in FullScreen mode. When sets FullScreen property to True the control make the container Form at current screen dimensions and autohide the TaskBar of Microsoft Windows if visible. If you sets FullScreen property to False all previous settings of Taskbar and container Form will be restored. You are responsable to hide/show any other control on form where Multimedia control is placed before change FullScreen mode property.
Public property | Mute | Gets/Sets audio state ON (False) or OFF (True). Check SupportVolume method before change this property.
Public property | OriginalSize | Obtain the original (screen) size of the media.
Public property | Position | Gets/Sets the position for sound and video media files (value must be between 0 and value of Duration property). Must use Track property for CD media type (value must be between 1 and value of Tracks property).
Public property | Repeat | Gets/Sets the repeat flag media play loop.
Public property | ShowCommandsBar | Show/Hide commands bar.
Public property | ShowPosition | Show/Hide media position progress indicator
Public property | ShowProgress | Show/Hide media progress led indicator
Public property | ShowTipBalance | Gets/Sets if balance ToolTip must be displayed
Public property | ShowTipPosition | Gets/Sets if position ToolTip must be displayed
Public property | ShowTipVolume | Gets/Sets if volume ToolTip must be displayed
Public property | ShowWindow | Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent.
Public property | Speed | Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property
Public property TipBalance Gets/Sets text tooltips used by Balance control.

For Balance tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%L (Left Volume Balance) | Current Left Volume Balance Value
%R (Right Volume Balance) | Current Right Volume Balance Value

Default TextTip values for Balance is:

Text | Default Value
Balance | Balance +L %L / +R %R
Public property TipPosition Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized (for example for multilanguage applications).

For Position tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%D (used in TipPosition) | Total Tracks/Seconds/Milliseconds Duration value
%R (used in TipBalance) | Current Right Volume Balance Value
&T (used in TipPosition) | Current Track time Position (for CdAudio)

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Position | Position %P of %D %T
Public property TipVolume Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized (for example for multilanguage applications).

For Volume tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%V | Current Volume value

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Volume | Volume %V"
Public property | Track | Gets/Sets current number of track in the media. This property is supported only by CD media. If not supported will return zero.
Public property | Tracks | Gets total number of tracks in the media. This property is supported only by CD media. If not supported will return zero.
Public property | Volume | Gets/Sets the volume of sound card. Value must be between 0 to 100. Check if SupportVolume is True method before change this property.
Top

Expand image Public Methods

 | Name | Description
Public method | CDDoorClose | Close the CDROM drive Door
Public method | CDDoorOpen | Open the CDROM drive Door
Public method | CDRomPresent | Check if a CDRom is present on drive
Public method | Close | This method close a previous opened sound/video file and free resources.
Public method | Duration | Gets the length of media file in milliseconds or number of tracks (for CDAudio media type only)
Public method | GetDriveFile | Gets the current opened video file name. If no file is open an empty string will be returned
Public method | GetMediaType | Get current media type
Public method | GetMediaTypeFromDriveFile | Gets the current media file type
Public method | GetSoundCardName | Return currently used sound card name
Public method | GetStartPosition | Gets start position of media in milliseconds..
Public method | GetTimeFromMS | Return a string that rappresent the time in the format hh.mm.ss of specified value in milliseconds
Public method | GetTrackLength | (Overloaded) Gets current track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Public method | GetTrackStartPosition | (Overloaded) Gets current track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Public method | IsSoundCardPresent | Return True if a sound card is detected.
Public method | LastErrorCode | Gets last error code
Public method | LastErrorString | Gets last error string
Public method | MoveBackward | Move media backward.
Public method | MoveEnd | Move media to the end.
Public method | MoveForward | Move media forward.
Public method | MoveStart | Move media at start.
Public method | Open | Open the specified video file. If a media file is already opened it will be closed.
Public method | Pause | Pause playing current media file
Public method | Play | (Overloaded) Play media from start
Public method | ResetError | Reset last error code occured
Public method | Resume | Resume playing current media file
Public method | SetImageBackward | Change the Backward image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageBegin | Change the Begin image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageEnd | Change the End image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageForward | Change the Forward image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageMute | Change the Mute image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageOpenCD | Change the Open CD image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageOpenFile | Change the Open File image button of CommandBar (must be a valid 32x32 image).
Public method | SetImagePause | Change the Pause image button of CommandBar (must be a valid 32x32 image).
Public method | SetImagePlay | Change the Play image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageRepeat | Change the Repeat image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageSpeedDouble | Change the Speed Double image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageSpeedHalf | Change the Speed Half image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageStop | ' Change the Stop image button of CommandBar (must be a valid 32x32 image).
Public method | State | Gets actual media state (see MediaStatusInfo enumeration)
Public method | Stop | Stops playing media and rewinds
Public method | SupportBalance | Gets if Balance volume control of separated channnels (Left/Right) is supported
Public method | SupportSpeed | Gets if Speed property is supported
Public method | SupportVolume | Gets if Volume control is supported
Top

Expand image Public Events

 | Name | Description
Public event | OnEnd | This event will be raised after play will end
Public event | OnError | This event will be raised after an error occurs
Public event | OnMuteChange | This event will be raised before sound will be enabled/disapled
Public event | OnOpen | This event will be raised after a new file will by opened
Public event | OnPause | This event will be raised after play will be paused
Public event | OnPlay | This event will be raised after play of media will start
Public event | OnPositionChange | This event will be raised before position will be changed. You can change Value parameter (must be from 0 to Duration)
Public event | OnResume | This event will be raised after play will be resume
Public event | OnSpeedChange | This event will be raised before speed will be changed. You can change Value parameter (must be from 0 to 2000)
Public event | OnStop | This event will be raised after play will be stopped
Public event | OnVolumeChange | This event will be raised before volume will be changed. You can change Value parameter (must be from 0 to 1000)
Top

Expand image Enumerations

 | Name | Description
Public enumeration | ButtonTipEnum | ButtonTipEnum enum defines constant to Gets/Sets Tooltip CommandsBar buttons throw ButtonTip property
Public enumeration | MediaCommandBarPosition | Defines Multimedia CommandBar position
Public enumeration | MediaStatusInfo | Defines the different states of media status
Public enumeration | MediaTypeEnum | Defines the type of media
Public enumeration | MediaVideoSpeed | Defines Multimedia video playing Speed
Top

Expand image See Also

Reference

Multimedia Class


ButtonTipEnum Enumeration

[image] [image] [image]

NetMultimedia Reference
ButtonTipEnum Enumeration
See Also

ButtonTipEnum enum defines constant to Gets/Sets Tooltip CommandsBar buttons throw ButtonTip property
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Members

Member name | Description
TipBackward | Backward button tooltip
TipBegin | Begin button tooltip
TipEnd | End button tooltip
TipForward | Forward button tooltip
TipOpenCD | Open CD button tooltip
TipOpenFile | Open file button tooltip
TipPlay | Play button tooltip
TipPosition | Progress control tooltip
TipRepeat | Repeat button tooltip
TipSound | Sound button tooltip
TipSpeedDouble | Speed double button tooltip
TipSpeedHalf | Speed half button tooltip

Expand image See Also

Reference

Multimedia Class


MediaCommandBarPosition Enumeration

[image] [image] [image]

NetMultimedia Reference
MediaCommandBarPosition Enumeration
See Also

Defines Multimedia CommandBar position
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Members

Member name | Description
DockBottom | Multimedi Command Bar is Docked Bottom
DockTop | Multimedi Command Bar is Docked Top

Expand image See Also

Reference

Multimedia Class


MediaStatusInfo Enumeration

[image] [image] [image]

NetMultimedia Reference
MediaStatusInfo Enumeration
See Also

Defines the different states of media status
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Members

Member name | Description
Paused | The media is paused.
Playing | The media is playing.
Stopped | The media is stopped.
Unknown | The media status is unknown.

Expand image See Also

Reference

Multimedia Class


MediaTypeEnum Enumeration

[image] [image] [image]

NetMultimedia Reference
MediaTypeEnum Enumeration
See Also

Defines the type of media
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Members

Member name | Description
CDAudio | The media is a audio CD.
SoundFile | The media file is of type Sound.
Unknow | The media file is unknow.
VideoFile | The media file is of type Video.

Expand image See Also

Reference

Multimedia Class


MediaVideoSpeed Enumeration

[image] [image] [image]

NetMultimedia Reference
MediaVideoSpeed Enumeration
See Also

Defines Multimedia video playing Speed
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Members

Member name | Description
SpeedDouble | Double speed
SpeedHalf | Half normal speed
SpeedNormal | Normal speed

Expand image See Also

Reference

Multimedia Class


Multimedia Properties

[image] [image] [image]

NetMultimedia Reference
Multimedia Properties
Multimedia Class See Also

Expand image Public Properties

Name | Description
Public property | AutoPlay | Gets/Sets AutoPlay mode: automatic start play on Open
Public property | BackColor | Gets/Sets background color of control
Public property | Balance | Gets/Sets Volume Balance of Right and Left channels. Value must be between -100 and 100. A value of 0 set both volume channels to 100. Check SupportBalance method before change this property.
Public property | ButtonTip | Gets/Sets text for tooltips used in Command Bar buttons. Any tooltip text can be customized (for example for multilanguage applications).
Public property | CommandBarBackColor | Gets/Sets background colour of commands bar
Public property | CommandBarBorder | Gets/Sets border style or command bar
Public property | CommandBarPosition | Gets/Sets command bar position
Public property | CommandBarThumbColor | Gets/Sets slider thumb colour of volume and balance
Public property | CommandLedBackColor | Gets/Sets background colour of led panel
Public property | CommandLedForeColor | Gets/Sets foreground colour of led panel
Public property | Frame | Gets/Sets current frame number If vaue is not supported by media file 0 will be returned)..
Public property | Frames | Gets total number of frames. If vaue is not supported by media file 0 will be returned).
Public property | FullScreen | Gets/Sets if container Form of Multimedia control is in FullScreen mode. When sets FullScreen property to True the control make the container Form at current screen dimensions and autohide the TaskBar of Microsoft Windows if visible. If you sets FullScreen property to False all previous settings of Taskbar and container Form will be restored. You are responsable to hide/show any other control on form where Multimedia control is placed before change FullScreen mode property.
Public property | Mute | Gets/Sets audio state ON (False) or OFF (True). Check SupportVolume method before change this property.
Public property | OriginalSize | Obtain the original (screen) size of the media.
Public property | Position | Gets/Sets the position for sound and video media files (value must be between 0 and value of Duration property). Must use Track property for CD media type (value must be between 1 and value of Tracks property).
Public property | Repeat | Gets/Sets the repeat flag media play loop.
Public property | ShowCommandsBar | Show/Hide commands bar.
Public property | ShowPosition | Show/Hide media position progress indicator
Public property | ShowProgress | Show/Hide media progress led indicator
Public property | ShowTipBalance | Gets/Sets if balance ToolTip must be displayed
Public property | ShowTipPosition | Gets/Sets if position ToolTip must be displayed
Public property | ShowTipVolume | Gets/Sets if volume ToolTip must be displayed
Public property | ShowWindow | Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent.
Public property | Speed | Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property
Public property TipBalance Gets/Sets text tooltips used by Balance control.

For Balance tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%L (Left Volume Balance) | Current Left Volume Balance Value
%R (Right Volume Balance) | Current Right Volume Balance Value

Default TextTip values for Balance is:

Text | Default Value
Balance | Balance +L %L / +R %R
Public property TipPosition Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized (for example for multilanguage applications).

For Position tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%D (used in TipPosition) | Total Tracks/Seconds/Milliseconds Duration value
%R (used in TipBalance) | Current Right Volume Balance Value
&T (used in TipPosition) | Current Track time Position (for CdAudio)

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Position | Position %P of %D %T
Public property TipVolume Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized (for example for multilanguage applications).

For Volume tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%V | Current Volume value

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Volume | Volume %V"
Public property | Track | Gets/Sets current number of track in the media. This property is supported only by CD media. If not supported will return zero.
Public property | Tracks | Gets total number of tracks in the media. This property is supported only by CD media. If not supported will return zero.
Public property | Volume | Gets/Sets the volume of sound card. Value must be between 0 to 100. Check if SupportVolume is True method before change this property.
Top

Expand image See Also

Reference

Multimedia Class


Multimedia.AutoPlay Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.AutoPlay Property
See Also

Gets/Sets AutoPlay mode: automatic start play on Open
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property AutoPlay( _
   ByRef "Gets/Sets AutoPlay mode: automatic start play on Open" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("AutoPlay")]
public bool this[
   ref object "Gets/Sets AutoPlay mode: automatic start play on Open"
] {get; set;}

Parameters

"Gets/Sets AutoPlay mode: automatic start play on Open"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.BackColor Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.BackColor Property
See Also

Gets/Sets background color of control
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property BackColor( _
   ByRef "Gets/Sets background color of control" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("BackColor")]
public Color this[
   ref object "Gets/Sets background color of control"
] {get; set;}

Parameters

"Gets/Sets background color of control"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Balance Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Balance Property
See Also

Gets/Sets Volume Balance of Right and Left channels. Value must be between -100 and 100. A value of 0 set both volume channels to 100. Check SupportBalance method before change this property.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Balance( _
   ByRef False As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Balance")]
public int this[
   ref object False
] {get; set;}

Parameters

False

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ButtonTip Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ButtonTip Property
See Also

Gets/Sets text for tooltips used in Command Bar buttons. Any tooltip text can be customized (for example for multilanguage applications).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ButtonTip( _
   ByRef "Gets/Sets text for Tooltips used in Command Bar buttons." As Object _
) As String
C#
[System.Runtime.CompilerServices.IndexerName("ButtonTip")]
public string this[
   ref object "Gets/Sets text for Tooltips used in Command Bar buttons."
] {get; set;}

Parameters

"Gets/Sets text for Tooltips used in Command Bar buttons."

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandBarBackColor Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandBarBackColor Property
See Also

Gets/Sets background colour of commands bar
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandBarBackColor( _
   ByRef "Gets/Sets background colour of commands bar" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("CommandBarBackColor")]
public Color this[
   ref object "Gets/Sets background colour of commands bar"
] {get; set;}

Parameters

"Gets/Sets background colour of commands bar"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandBarBorder Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandBarBorder Property
See Also

Gets/Sets border style or command bar
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandBarBorder( _
   ByRef "Gets/Sets border style or command bar" As Object _
) As TableLayoutPanelCellBorderStyle
C#
[System.Runtime.CompilerServices.IndexerName("CommandBarBorder")]
public TableLayoutPanelCellBorderStyle this[
   ref object "Gets/Sets border style or command bar"
] {get; set;}

Parameters

"Gets/Sets border style or command bar"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandBarPosition Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandBarPosition Property
See Also

Gets/Sets command bar position
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandBarPosition( _
   ByRef "Gets/Sets command bar position" As Object _
) As MediaCommandBarPosition
C#
[System.Runtime.CompilerServices.IndexerName("CommandBarPosition")]
public MediaCommandBarPosition this[
   ref object "Gets/Sets command bar position"
] {get; set;}

Parameters

"Gets/Sets command bar position"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandBarThumbColor Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandBarThumbColor Property
See Also

Gets/Sets slider thumb colour of volume and balance
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandBarThumbColor( _
   ByRef "Gets/Sets slider thumb colour of volume and balance" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("CommandBarThumbColor")]
public Color this[
   ref object "Gets/Sets slider thumb colour of volume and balance"
] {get; set;}

Parameters

"Gets/Sets slider thumb colour of volume and balance"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandLedBackColor Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandLedBackColor Property
See Also

Gets/Sets background colour of led panel
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandLedBackColor( _
   ByRef "Gets/Sets background colour of led panel" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("CommandLedBackColor")]
public Color this[
   ref object "Gets/Sets background colour of led panel"
] {get; set;}

Parameters

"Gets/Sets background colour of led panel"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CommandLedForeColor Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.CommandLedForeColor Property
See Also

Gets/Sets foreground colour of led panel
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property CommandLedForeColor( _
   ByRef "Gets/Sets foreground colour of led panel" As Object _
) As Color
C#
[System.Runtime.CompilerServices.IndexerName("CommandLedForeColor")]
public Color this[
   ref object "Gets/Sets foreground colour of led panel"
] {get; set;}

Parameters

"Gets/Sets foreground colour of led panel"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Frame Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Frame Property
See Also

Gets/Sets current frame number If vaue is not supported by media file 0 will be returned)..
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Frame( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Frame")]
public int this[
   ref object DesignerSerializationVisibility.Hidden
] {get; set;}

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Frames Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Frames Property
See Also

Gets total number of frames. If vaue is not supported by media file 0 will be returned).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Frames( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Frames")]
public int this[
   ref object DesignerSerializationVisibility.Hidden
] {get;}

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.FullScreen Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.FullScreen Property
See Also

Gets/Sets if container Form of Multimedia control is in FullScreen mode. When sets FullScreen property to True the control make the container Form at current screen dimensions and autohide the TaskBar of Microsoft Windows if visible. If you sets FullScreen property to False all previous settings of Taskbar and container Form will be restored. You are responsable to hide/show any other control on form where Multimedia control is placed before change FullScreen mode property.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property FullScreen( _
   ByRef False As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("FullScreen")]
public bool this[
   ref object False
] {get; set;}

Parameters

False

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Mute Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Mute Property
See Also

Gets/Sets audio state ON (False) or OFF (True). Check SupportVolume method before change this property.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Mute( _
   ByRef False As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("Mute")]
public bool this[
   ref object False
] {get; set;}

Parameters

False

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.OriginalSize Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.OriginalSize Property
See Also

Obtain the original (screen) size of the media.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginalSize() As Size
C#
public Size OriginalSize {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Position Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Position Property
See Also

Gets/Sets the position for sound and video media files (value must be between 0 and value of Duration property). Must use Track property for CD media type (value must be between 1 and value of Tracks property).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Position( _
   ByRef "Gets/Sets the position for sound and video media files  As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Position")]
public int this[
   ref object "Gets/Sets the position for sound and video media files
] {get; set;}

Parameters

"Gets/Sets the position for sound and video media files

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Repeat Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Repeat Property
See Also

Gets/Sets the repeat flag media play loop.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Repeat( _
   ByRef False As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("Repeat")]
public bool this[
   ref object False
] {get; set;}

Parameters

False

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowCommandsBar Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowCommandsBar Property
See Also

Show/Hide commands bar.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowCommandsBar( _
   ByRef "Show/Hide commands bar." As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowCommandsBar")]
public bool this[
   ref object "Show/Hide commands bar."
] {get; set;}

Parameters

"Show/Hide commands bar."

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowPosition Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowPosition Property
See Also

Show/Hide media position progress indicator
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowPosition( _
   ByRef "Show/Hide media progress led indicator" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowPosition")]
public bool this[
   ref object "Show/Hide media progress led indicator"
] {get; set;}

Parameters

"Show/Hide media progress led indicator"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowProgress Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowProgress Property
See Also

Show/Hide media progress led indicator
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowProgress( _
   ByRef "Show/Hide media progress led indicator" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowProgress")]
public bool this[
   ref object "Show/Hide media progress led indicator"
] {get; set;}

Parameters

"Show/Hide media progress led indicator"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowTipBalance Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowTipBalance Property
See Also

Gets/Sets if balance ToolTip must be displayed
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowTipBalance( _
   ByRef "Gets/Sets if balance ToolTip must be displayed" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowTipBalance")]
public bool this[
   ref object "Gets/Sets if balance ToolTip must be displayed"
] {get; set;}

Parameters

"Gets/Sets if balance ToolTip must be displayed"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowTipPosition Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowTipPosition Property
See Also

Gets/Sets if position ToolTip must be displayed
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowTipPosition( _
   ByRef "Gets/Sets if position ToolTip must be displayed" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowTipPosition")]
public bool this[
   ref object "Gets/Sets if position ToolTip must be displayed"
] {get; set;}

Parameters

"Gets/Sets if position ToolTip must be displayed"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowTipVolume Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowTipVolume Property
See Also

Gets/Sets if volume ToolTip must be displayed
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowTipVolume( _
   ByRef "Gets/Sets if volume ToolTip must be displayed" As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowTipVolume")]
public bool this[
   ref object "Gets/Sets if volume ToolTip must be displayed"
] {get; set;}

Parameters

"Gets/Sets if volume ToolTip must be displayed"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.ShowWindow Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.ShowWindow Property
See Also

Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property ShowWindow( _
   ByRef "Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent." As Object _
) As Boolean
C#
[System.Runtime.CompilerServices.IndexerName("ShowWindow")]
public bool this[
   ref object "Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent."
] {get; set;}

Parameters

"Show/Hide multimedia window portion. Window can't be hidden if control is docked to its parent."

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Speed Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Speed Property
See Also

Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Speed( _
   ByRef "Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property" As Object _
) As MediaVideoSpeed
C#
[System.Runtime.CompilerServices.IndexerName("Speed")]
public MediaVideoSpeed this[
   ref object "Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property"
] {get; set;}

Parameters

"Gets/Sets the playback speed of the media file to 1x or 2x speed. Check SupportSpeed method before change this property"

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.TipBalance Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.TipBalance Property
See Also

Gets/Sets text tooltips used by Balance control.

For Balance tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%L (Left Volume Balance) | Current Left Volume Balance Value
%R (Right Volume Balance) | Current Right Volume Balance Value

Default TextTip values for Balance is:

Text | Default Value
Balance | Balance +L %L / +R %R

Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property TipBalance( _
   ByRef "Gets/Sets text tooltips used by Balance control." As Object _
) As String
C#
[System.Runtime.CompilerServices.IndexerName("TipBalance")]
public string this[
   ref object "Gets/Sets text tooltips used by Balance control."
] {get; set;}

Parameters

"Gets/Sets text tooltips used by Balance control."

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.TipPosition Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.TipPosition Property
See Also

Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized (for example for multilanguage applications).

For Position tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%D (used in TipPosition) | Total Tracks/Seconds/Milliseconds Duration value
%R (used in TipBalance) | Current Right Volume Balance Value
&T (used in TipPosition) | Current Track time Position (for CdAudio)

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Position | Position %P of %D %T

Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property TipPosition( _
   ByRef "Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized  As Object _
) As String
C#
[System.Runtime.CompilerServices.IndexerName("TipPosition")]
public string this[
   ref object "Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized
] {get; set;}

Parameters

"Gets/Sets text for tooltips used by Progress and Led indicator controls. Any tooltip text can be customized

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.TipVolume Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.TipVolume Property
See Also

Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized (for example for multilanguage applications).

For Volume tooltips you can specify constants values that will be replaced with current values before display tips text as follow.

Constants | Description
%V | Current Volume value

Default TextTip values for Balance, Position and Value are:

Text | Default Value
Volume | Volume %V"

Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property TipVolume( _
   ByRef "Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized  As Object _
) As String
C#
[System.Runtime.CompilerServices.IndexerName("TipVolume")]
public string this[
   ref object "Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized
] {get; set;}

Parameters

"Gets/Sets text for tooltips used by Volume control. Any tooltip text can be customized

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Track Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Track Property
See Also

Gets/Sets current number of track in the media. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Track( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Track")]
public int this[
   ref object DesignerSerializationVisibility.Hidden
] {get; set;}

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Tracks Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Tracks Property
See Also

Gets total number of tracks in the media. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tracks( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Tracks")]
public int this[
   ref object DesignerSerializationVisibility.Hidden
] {get;}

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Volume Property

[image] [image] [image]

NetMultimedia Reference
Multimedia.Volume Property
See Also

Gets/Sets the volume of sound card. Value must be between 0 to 100. Check if SupportVolume is True method before change this property.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Volume( _
   ByRef DesignerSerializationVisibility.Hidden As Object _
) As Integer
C#
[System.Runtime.CompilerServices.IndexerName("Volume")]
public int this[
   ref object DesignerSerializationVisibility.Hidden
] {get; set;}

Parameters

DesignerSerializationVisibility.Hidden

Type: object

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia Methods

[image] [image] [image]

NetMultimedia Reference
Multimedia Methods
Multimedia Class See Also

Expand image Public Methods

 | Name | Description
Public method | CDDoorClose | Close the CDROM drive Door
Public method | CDDoorOpen | Open the CDROM drive Door
Public method | CDRomPresent | Check if a CDRom is present on drive
Public method | Close | This method close a previous opened sound/video file and free resources.
Public method | Duration | Gets the length of media file in milliseconds or number of tracks (for CDAudio media type only)
Public method | GetDriveFile | Gets the current opened video file name. If no file is open an empty string will be returned
Public method | GetMediaType | Get current media type
Public method | GetMediaTypeFromDriveFile | Gets the current media file type
Public method | GetSoundCardName | Return currently used sound card name
Public method | GetStartPosition | Gets start position of media in milliseconds..
Public method | GetTimeFromMS | Return a string that rappresent the time in the format hh.mm.ss of specified value in milliseconds
Public method | GetTrackLength | (Overloaded) Gets current track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Public method | GetTrackStartPosition | (Overloaded) Gets current track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Public method | IsSoundCardPresent | Return True if a sound card is detected.
Public method | LastErrorCode | Gets last error code
Public method | LastErrorString | Gets last error string
Public method | MoveBackward | Move media backward.
Public method | MoveEnd | Move media to the end.
Public method | MoveForward | Move media forward.
Public method | MoveStart | Move media at start.
Public method | Open | Open the specified video file. If a media file is already opened it will be closed.
Public method | Pause | Pause playing current media file
Public method | Play | (Overloaded) Play media from start
Public method | ResetError | Reset last error code occured
Public method | Resume | Resume playing current media file
Public method | SetImageBackward | Change the Backward image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageBegin | Change the Begin image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageEnd | Change the End image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageForward | Change the Forward image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageMute | Change the Mute image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageOpenCD | Change the Open CD image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageOpenFile | Change the Open File image button of CommandBar (must be a valid 32x32 image).
Public method | SetImagePause | Change the Pause image button of CommandBar (must be a valid 32x32 image).
Public method | SetImagePlay | Change the Play image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageRepeat | Change the Repeat image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageSpeedDouble | Change the Speed Double image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageSpeedHalf | Change the Speed Half image button of CommandBar (must be a valid 32x32 image).
Public method | SetImageStop | ' Change the Stop image button of CommandBar (must be a valid 32x32 image).
Public method | State | Gets actual media state (see MediaStatusInfo enumeration)
Public method | Stop | Stops playing media and rewinds
Public method | SupportBalance | Gets if Balance volume control of separated channnels (Left/Right) is supported
Public method | SupportSpeed | Gets if Speed property is supported
Public method | SupportVolume | Gets if Volume control is supported
Top

Expand image See Also

Reference

Multimedia Class


Multimedia.CDDoorClose Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.CDDoorClose Method
See Also

Close the CDROM drive Door
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CDDoorClose() As Boolean
C#
public bool CDDoorClose()

Return Value

Return True for success otherwise return false

Expand image Remarks

This method is applicable only if Media Type id CDRom

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CDDoorOpen Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.CDDoorOpen Method
See Also

Open the CDROM drive Door
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CDDoorOpen() As Boolean
C#
public bool CDDoorOpen()

Return Value

Return True for success otherwise return false

Expand image Remarks

This method is applicable only if Media Type id CDRom

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.CDRomPresent Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.CDRomPresent Method
See Also

Check if a CDRom is present on drive
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function CDRomPresent() As Boolean
C#
public bool CDRomPresent()

Return Value

Return True if a CDROM is present otherwise return false

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Close Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Close Method
See Also

This method close a previous opened sound/video file and free resources.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Close() As Boolean
C#
public bool Close()

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Duration Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Duration Method
See Also

Gets the length of media file in milliseconds or number of tracks (for CDAudio media type only)
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Duration() As Integer
C#
public int Duration()

Return Value

This property returns the total number of tracks for CDAuto media type otherwise returns the total number of milliseconds of media duration

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetDriveFile Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetDriveFile Method
See Also

Gets the current opened video file name. If no file is open an empty string will be returned
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetDriveFile() As String
C#
public string GetDriveFile()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetMediaType Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetMediaType Method
See Also

Get current media type
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetMediaType() As MediaTypeEnum
C#
public MediaTypeEnum GetMediaType()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetMediaTypeFromDriveFile Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetMediaTypeFromDriveFile Method
See Also

Gets the current media file type
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetMediaTypeFromDriveFile( _
   ByVal DriveFile As String _
) As MediaTypeEnum
C#
public MediaTypeEnum GetMediaTypeFromDriveFile(
   string DriveFile
)

Parameters

DriveFile

Type: string

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetSoundCardName Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetSoundCardName Method
See Also

Return currently used sound card name
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetSoundCardName() As String
C#
public string GetSoundCardName()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetStartPosition Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetStartPosition Method
See Also

Gets start position of media in milliseconds..
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetStartPosition() As Integer
C#
public int GetStartPosition()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTimeFromMS Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTimeFromMS Method
See Also

Return a string that rappresent the time in the format hh.mm.ss of specified value in milliseconds
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTimeFromMS( _
   ByVal Value As Integer _
) As String
C#
public string GetTimeFromMS(
   int Value
)

Parameters

Value

Type: int

Value in milliseconds

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTrackLength Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackLength Method
Multimedia Class See Also

Gets current track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.

Expand image Overload List

Name | Description
GetTrackLength() | Gets current track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
GetTrackLength(int) | Gets specified track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTrackStartPosition Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackStartPosition Method
Multimedia Class See Also

Gets current track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.

Expand image Overload List

Name | Description
GetTrackStartPosition() | Gets current track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
GetTrackStartPosition(int) | Gets specified track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.

Expand image See Also

Reference

Multimedia Class


Multimedia.IsSoundCardPresent Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.IsSoundCardPresent Method
See Also

Return True if a sound card is detected.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function IsSoundCardPresent() As Boolean
C#
public bool IsSoundCardPresent()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.LastErrorCode Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.LastErrorCode Method
See Also

Gets last error code
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function LastErrorCode() As Integer
C#
public int LastErrorCode()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.LastErrorString Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.LastErrorString Method
See Also

Gets last error string
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function LastErrorString() As String
C#
public string LastErrorString()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.MoveBackward Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.MoveBackward Method
See Also

Move media backward.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveBackward()
C#
public System.Void MoveBackward()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.MoveEnd Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.MoveEnd Method
See Also

Move media to the end.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveEnd()
C#
public System.Void MoveEnd()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.MoveForward Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.MoveForward Method
See Also

Move media forward.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveForward()
C#
public System.Void MoveForward()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.MoveStart Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.MoveStart Method
See Also

Move media at start.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub MoveStart()
C#
public System.Void MoveStart()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Open Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Open Method
See Also

Open the specified video file. If a media file is already opened it will be closed.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Open( _
   ByVal DriveFile As String _
) As Boolean
C#
public bool Open(
   string DriveFile
)

Parameters

DriveFile

Type: string

Full pathname of file to open

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Pause Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Pause Method
See Also

Pause playing current media file
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Pause() As Boolean
C#
public bool Pause()

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Play Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Play Method
Multimedia Class See Also

Play media from start

Expand image Overload List

Name | Description
Play(int) | Play media from specified position
Play() | Play media from start

Expand image See Also

Reference

Multimedia Class


Multimedia.ResetError Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.ResetError Method
See Also

Reset last error code occured
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub ResetError()
C#
public System.Void ResetError()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Resume Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Resume Method
See Also

Resume playing current media file
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Resume() As Boolean
C#
public bool Resume()

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageBackward Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageBackward Method
See Also

Change the Backward image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageBackward( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageBackward(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageBegin Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageBegin Method
See Also

Change the Begin image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageBegin( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageBegin(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageEnd Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageEnd Method
See Also

Change the End image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageEnd( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageEnd(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageForward Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageForward Method
See Also

Change the Forward image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageForward( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageForward(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageMute Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageMute Method
See Also

Change the Mute image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageMute( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageMute(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageOpenCD Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageOpenCD Method
See Also

Change the Open CD image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageOpenCD( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageOpenCD(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageOpenFile Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageOpenFile Method
See Also

Change the Open File image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageOpenFile( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageOpenFile(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImagePause Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImagePause Method
See Also

Change the Pause image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImagePause( _
   ByVal oImage As Image _
)
C#
public System.Void SetImagePause(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImagePlay Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImagePlay Method
See Also

Change the Play image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImagePlay( _
   ByVal oImage As Image _
)
C#
public System.Void SetImagePlay(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageRepeat Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageRepeat Method
See Also

Change the Repeat image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageRepeat( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageRepeat(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageSpeedDouble Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageSpeedDouble Method
See Also

Change the Speed Double image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageSpeedDouble( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageSpeedDouble(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageSpeedHalf Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageSpeedHalf Method
See Also

Change the Speed Half image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageSpeedHalf( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageSpeedHalf(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SetImageStop Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SetImageStop Method
See Also

' Change the Stop image button of CommandBar (must be a valid 32x32 image).
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Sub SetImageStop( _
   ByVal oImage As Image _
)
C#
public System.Void SetImageStop(
   Image oImage
)

Parameters

oImage

Type: Image

A valid 32x32 image.

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.State Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.State Method
See Also

Gets actual media state (see MediaStatusInfo enumeration)
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function State() As MediaStatusInfo
C#
public MediaStatusInfo State()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Stop Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Stop Method
See Also

Stops playing media and rewinds
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Stop() As Boolean
C#
public bool Stop()

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SupportBalance Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SupportBalance Method
See Also

Gets if Balance volume control of separated channnels (Left/Right) is supported
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SupportBalance() As Boolean
C#
public bool SupportBalance()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SupportSpeed Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SupportSpeed Method
See Also

Gets if Speed property is supported
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SupportSpeed() As Boolean
C#
public bool SupportSpeed()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.SupportVolume Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.SupportVolume Method
See Also

Gets if Volume control is supported
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function SupportVolume() As Boolean
C#
public bool SupportVolume()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia Events

[image] [image] [image]

NetMultimedia Reference
Multimedia Events
Multimedia Class See Also

Expand image Public Events

 | Name | Description
Public event | OnEnd | This event will be raised after play will end
Public event | OnError | This event will be raised after an error occurs
Public event | OnMuteChange | This event will be raised before sound will be enabled/disapled
Public event | OnOpen | This event will be raised after a new file will by opened
Public event | OnPause | This event will be raised after play will be paused
Public event | OnPlay | This event will be raised after play of media will start
Public event | OnPositionChange | This event will be raised before position will be changed. You can change Value parameter (must be from 0 to Duration)
Public event | OnResume | This event will be raised after play will be resume
Public event | OnSpeedChange | This event will be raised before speed will be changed. You can change Value parameter (must be from 0 to 2000)
Public event | OnStop | This event will be raised after play will be stopped
Public event | OnVolumeChange | This event will be raised before volume will be changed. You can change Value parameter (must be from 0 to 1000)
Top

Expand image See Also

Reference

Multimedia Class


OnEnd Event

[image] [image] [image]

NetMultimedia Reference
OnEnd Event
See Also

This event will be raised after play will end
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnEnd( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnEndEventHandler OnEnd
delegate void OnEndEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnError Event

[image] [image] [image]

NetMultimedia Reference
OnError Event
See Also

This event will be raised after an error occurs
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnError( _
   ByVal sender As Object, _
   ByVal e As OnErrorEventArgs _
)
C#
public event OnErrorEventHandler OnError
delegate void OnErrorEventHandler(
   object sender,
   OnErrorEventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: OnErrorEventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnMuteChange Event

[image] [image] [image]

NetMultimedia Reference
OnMuteChange Event
See Also

This event will be raised before sound will be enabled/disapled
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnMuteChange( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnMuteChangeEventHandler OnMuteChange
delegate void OnMuteChangeEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnOpen Event

[image] [image] [image]

NetMultimedia Reference
OnOpen Event
See Also

This event will be raised after a new file will by opened
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnOpen( _
   ByVal sender As Object, _
   ByVal e As OnOpenEventArgs _
)
C#
public event OnOpenEventHandler OnOpen
delegate void OnOpenEventHandler(
   object sender,
   OnOpenEventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: OnOpenEventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnPause Event

[image] [image] [image]

NetMultimedia Reference
OnPause Event
See Also

This event will be raised after play will be paused
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnPause( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnPauseEventHandler OnPause
delegate void OnPauseEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnPlay Event

[image] [image] [image]

NetMultimedia Reference
OnPlay Event
See Also

This event will be raised after play of media will start
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnPlay( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnPlayEventHandler OnPlay
delegate void OnPlayEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnPositionChange Event

[image] [image] [image]

NetMultimedia Reference
OnPositionChange Event
See Also

This event will be raised before position will be changed. You can change Value parameter (must be from 0 to Duration)
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnPositionChange( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnPositionChangeEventHandler OnPositionChange
delegate void OnPositionChangeEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnResume Event

[image] [image] [image]

NetMultimedia Reference
OnResume Event
See Also

This event will be raised after play will be resume
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnResume( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnResumeEventHandler OnResume
delegate void OnResumeEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnSpeedChange Event

[image] [image] [image]

NetMultimedia Reference
OnSpeedChange Event
See Also

This event will be raised before speed will be changed. You can change Value parameter (must be from 0 to 2000)
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnSpeedChange( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnSpeedChangeEventHandler OnSpeedChange
delegate void OnSpeedChangeEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnStop Event

[image] [image] [image]

NetMultimedia Reference
OnStop Event
See Also

This event will be raised after play will be stopped
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnStop( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnStopEventHandler OnStop
delegate void OnStopEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnVolumeChange Event

[image] [image] [image]

NetMultimedia Reference
OnVolumeChange Event
See Also

This event will be raised before volume will be changed. You can change Value parameter (must be from 0 to 1000)
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Event OnVolumeChange( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
C#
public event OnVolumeChangeEventHandler OnVolumeChange
delegate void OnVolumeChangeEventHandler(
   object sender,
   EventArgs e
)

Parameters

sender

Type: object

Event sender object

e

Type: EventArgs

A variable that contains event parameters

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


OnErrorEventArgs Class

[image] [image] [image]

NetMultimedia Reference
OnErrorEventArgs Class
Members

OnErrorEventArgs class hold OnError event parameters
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class OnErrorEventArgs
    Inherits EventArgs
C#
public class OnErrorEventArgs : EventArgs

Expand image Inheritance Hierarchy

System.Object
System.EventArgs
Softgroup.NetMultimedia.OnErrorEventArgs

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnErrorEventArgs Members


OnErrorEventArgs Members

[image] [image] [image]

NetMultimedia Reference
OnErrorEventArgs Members
OnErrorEventArgs Class Properties See Also

OnErrorEventArgs class hold OnError event parameters

The following tables list the members exposed by the OnErrorEventArgs type.

Expand image Public Properties

 | Name | Description
Public property | ErrorCode | Return the error code
Public property | ErrorString | Return the error string
Top

Expand image See Also

Reference

OnErrorEventArgs Class


OnErrorEventArgs Properties

[image] [image] [image]

NetMultimedia Reference
OnErrorEventArgs Properties
OnErrorEventArgs Class See Also

Expand image Public Properties

 | Name | Description
Public property | ErrorCode | Return the error code
Public property | ErrorString | Return the error string
Top

Expand image See Also

Reference

OnErrorEventArgs Class


OnErrorEventArgs.ErrorCode Property

[image] [image] [image]

NetMultimedia Reference
OnErrorEventArgs.ErrorCode Property
See Also

Return the error code
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorCode() As Integer
C#
public int ErrorCode {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnErrorEventArgs Class
OnErrorEventArgs Members


OnErrorEventArgs.ErrorString Property

[image] [image] [image]

NetMultimedia Reference
OnErrorEventArgs.ErrorString Property
See Also

Return the error string
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorString() As String
C#
public string ErrorString {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnErrorEventArgs Class
OnErrorEventArgs Members


OnOpenEventArgs Class

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs Class
Members

OnOpenEventArgs class hold OnOpen event parameters
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class OnOpenEventArgs
    Inherits EventArgs
C#
public class OnOpenEventArgs : EventArgs

Expand image Inheritance Hierarchy

System.Object
System.EventArgs
Softgroup.NetMultimedia.OnOpenEventArgs

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnOpenEventArgs Members


OnOpenEventArgs Members

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs Members
OnOpenEventArgs Class Properties See Also

OnOpenEventArgs class hold OnOpen event parameters

The following tables list the members exposed by the OnOpenEventArgs type.

Expand image Public Properties

 | Name | Description
Public property | DeviceType | Return the device type
Public property | FileName | Return the File Name
Public property | MediaType | Return the media type
Top

Expand image See Also

Reference

OnOpenEventArgs Class


OnOpenEventArgs Properties

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs Properties
OnOpenEventArgs Class See Also

Expand image Public Properties

 | Name | Description
Public property | DeviceType | Return the device type
Public property | FileName | Return the File Name
Public property | MediaType | Return the media type
Top

Expand image See Also

Reference

OnOpenEventArgs Class


OnOpenEventArgs.DeviceType Property

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs.DeviceType Property
See Also

Return the device type
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceType() As String
C#
public string DeviceType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnOpenEventArgs Class
OnOpenEventArgs Members


OnOpenEventArgs.FileName Property

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs.FileName Property
See Also

Return the File Name
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName() As String
C#
public string FileName {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnOpenEventArgs Class
OnOpenEventArgs Members


OnOpenEventArgs.MediaType Property

[image] [image] [image]

NetMultimedia Reference
OnOpenEventArgs.MediaType Property
See Also

Return the media type
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public ReadOnly Property MediaType() As MediaTypeEnum
C#
public MediaTypeEnum MediaType {get;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnOpenEventArgs Class
OnOpenEventArgs Members


OnToolTipShowing Class

[image] [image] [image]

NetMultimedia Reference
OnToolTipShowing Class
Members

OnToolTipShowing class hold ToolTipShowing event parameters
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Class OnToolTipShowing
    Inherits EventArgs
C#
public class OnToolTipShowing : EventArgs

Expand image Inheritance Hierarchy

System.Object
System.EventArgs
Softgroup.NetMultimedia.OnToolTipShowing

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnToolTipShowing Members


OnToolTipShowing Members

[image] [image] [image]

NetMultimedia Reference
OnToolTipShowing Members
OnToolTipShowing Class Properties See Also

OnToolTipShowing class hold ToolTipShowing event parameters

The following tables list the members exposed by the OnToolTipShowing type.

Expand image Public Properties

 | Name | Description
Public property | Text | Gets/Sets Tooltip text
Top

Expand image See Also

Reference

OnToolTipShowing Class


OnToolTipShowing Properties

[image] [image] [image]

NetMultimedia Reference
OnToolTipShowing Properties
OnToolTipShowing Class See Also

Expand image Public Properties

 | Name | Description
Public property | Text | Gets/Sets Tooltip text
Top

Expand image See Also

Reference

OnToolTipShowing Class


OnToolTipShowing.Text Property

[image] [image] [image]

NetMultimedia Reference
OnToolTipShowing.Text Property
See Also

Gets/Sets Tooltip text
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Property Text() As String
C#
public string Text {get; set;}

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

OnToolTipShowing Class
OnToolTipShowing Members


Multimedia.GetTrackLength (System.Int32) Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackLength (System.Int32) Method
See Also

Gets specified track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTrackLength( _
   ByVal iTrack As Integer _
) As Integer
C#
public int GetTrackLength(
   int iTrack
)

Parameters

iTrack

Type: int

A valid track number form 1 to track count (see Tracks property)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTrackStartPosition Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackStartPosition Method
See Also

Gets current track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTrackStartPosition() As Integer
C#
public int GetTrackStartPosition()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTrackStartPosition (System.Int32) Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackStartPosition (System.Int32) Method
See Also

Gets specified track start position of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTrackStartPosition( _
   ByVal iTrack As Integer _
) As Integer
C#
public int GetTrackStartPosition(
   int iTrack
)

Parameters

iTrack

Type: int

A valid track number form 1 to track count (see Tracks property)

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.GetTrackLength Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.GetTrackLength Method
See Also

Gets current track length of media in milliseconds. This property is supported only by CD media. If not supported will return zero.
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function GetTrackLength() As Integer
C#
public int GetTrackLength()

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Play Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Play Method
See Also

Play media from start
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Play() As Boolean
C#
public bool Play()

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class


Multimedia.Play (System.Int32) Method

[image] [image] [image]

NetMultimedia Reference
Multimedia.Play (System.Int32) Method
See Also

Play media from specified position
Assembly: Softgroup.NetMultimedia (in Softgroup.NetMultimedia.dll)

Expand image Syntax

Visual Basic (Declaration)
Public Function Play( _
   ByVal iFrom As Integer _
) As Boolean
C#
public bool Play(
   int iFrom
)

Parameters

iFrom

Type: int

Starting playing position (0 equals to start). For CDAudio Media Type is the track number otherwise is the milliseconds starting position

Return Value

Return True for success otherwise return False

Expand image Platforms

Windows XP SP3, Windows Vista, Windows 7, 8, 10, Windows Server 2003, 2008, 2012

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Expand image Version Information

.NET Framework

Supported in: 2.x, 3.x, 4.x

Expand image See Also

Reference

Multimedia Class